/[Apache-SVN]
ViewVC logotype

Revision 1768759


Jump to revision: Previous Next
Author: radu
Date: Tue Nov 8 18:30:46 2016 UTC (2 years, 11 months ago)
Changed paths: 2
Log Message:
SLING-6258 - The PackageAdminClassLoader cannot load classes from bundles providing older API versions

* check all bundles providing the same API package when trying to solve a class / resource and return the first
non-null result; this will always return the class / resource with the highest API version

Changed paths

Path Details
Directorysling/trunk/bundles/commons/classloader/src/main/java/org/apache/sling/commons/classloader/impl/PackageAdminClassLoader.java modified , text changed
Directorysling/trunk/bundles/commons/classloader/src/test/java/org/apache/sling/commons/classloader/impl/ClassLoadingTest.java modified , text changed

infrastructure at apache.org
ViewVC Help
Powered by ViewVC 1.1.26