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Ce este OpenOffice.org?

Ce este OpenOffice.org?

OpenOffice.org este o suită de aplicaţii de birou disponibilă în mod liber şi gratuit, care 
prezintă toate opţiunile ce vă sunt necesare. Acest capitol descrie:

• Componentele OpenOffice.org.

• Câteva dintre îmbunătăţirile şi noile facilităţi din versiunea 2.

• O comparaţie a OpenOffice.org cu alte suite de aplicaţii de birou.

• Cum să primiţi ajutor.

• Cum este licenţiat OpenOffice.org.

• Răspunsuri la întrebările frevente.

Notă Deoarece “OpenOffice” este marcă înregistrată a altcuiva, numele corect atât pentru 
proiectul de sursă publică cât şi pentru  programele rezultate este “OpenOffice.org”.

OpenOffice.org (OOo) este atât un program software cât şi numele unei comunităţi de 
voluntari care produc şi oferă suport pentru software.

Oricine este liber să redistribuie OOo, datorită licenţei în termenii căreia este disponibilă 
licenţa codului sursă (vedeţi “Cum este licenţiat OpenOffice.org?” la pagina 14).

Dacă sunteţi nou utilizator al OOo, nu stiţi despre crearea acestuia şi despre comunitatea care 
este în spatele său, ar trebui să citiţi acest capitol.

OOo 2.0 este o îmbunătăţire majoră a unui suite deja funcţionale. Dacă aţi folosit versiuni 
anterioare ale OOo, aruncaţi o privire asupra secţiunii “Noi facilităţi în versiunea 2” la pagina 
8.

Ce include OpenOffice.org?

Suita OpenOffice.org 2.0 include următoarele componente.

Writer (editor de text)

Writer este o unealtă cu multe facilităţi pentru crearea 
scrisorilor, rapoartelor, buletinelor de ştiri, broşurilor 
ca şi a altor documente. Puteţi insera imagini şi 
obiecte din alte componente în documente Writer. 
Writer poate exporta fişierele dumneavoastră în 
formate ca HTML, XHTML, XML, Adobe’s Portable 
Document Format (PDF), şi câteva versiuni de 
formate Microsoft Word. Se poate conecta de 
asemenea la clientul dumneavoastră de email.
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Calc (foaie de calcul)

Calc are toate funcţiile de analiză avansată, 
cartografiere şi prelucrare condiţionată care sunt de 
aşteptat la un program de foi de calcul avansat. Include 
peste 300 de funcţii pentru operaţii financiare, 
matematice, statistice etc. Analizorul de scenarii 
Scenario Manager) generează analiză bazate pe 
supoziţii (“what if”). Calc generează hărţi 2-D şi 3-D, 
care pot fi integrate în alte documente OOo. Puteţi de 
asemenea să deschideţi şi să lucraţi cu registre 
Microsoft Excel, salvându-le în format Excel. Calc 
poate exporta foi de calcul în formatele Adobe - PDF şi 
în HTML.

Impress (prezent ri grafice)ă

Impress oferă toate uneltele de prezentare multimedia 
uzuale, cum sunt efectele speciale, animaţie, uneltele 
de desenat. Ese integrat cu facilităţile grafice avansate 
din componentele Draw şi Math. Diapozitivele pot 
beneficia de efectele speciale de text disponibile în 
FontWork, ca şi de sunet şi videoclipuri. Impress este 
compatibil cu formatuld e fişier al programului 
PowerPoint de la Microsoft şi poate salva numca 
dumneavoastră în numeroase alte formate, inclusiv în 
Macromedia Flash (SWF).

Draw (grafic  vectorială ă)

Draw is a vector drawing tool that can produce 
everything from simple diagrams or flowcharts to 3-D 
artwork. Its Smart Connectors feature allows you to 
define your own connection points. You can use Draw 
to create drawings for use in any of OOo’s other 
components, and you can create your own clipart and 
add it to the Gallery. Draw can import graphics from 
many common formats and save them in over 20 
formats including PNG, HTML, PDF, and Flash.
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Base (baze de date)

Base vă oferă unelte pentru munca zilnică cu baze de 
date dintr-o interfaţă simplă. Poate crea şi edita 
formulare, rapoarte, interogări, tabele, vizualizări, 
relaţii, astfel încât lucrul cu o bază de date este similar 
cu al altor aplicaţii cunoscute de baze de date. Base 
oferă multe facilităţi noi, ca de exemplu posibilitatea de 
a analiza şi de a edita relaţiile dintr-o interfaţă tip 
diagramă. Base încorporează HSQLDB ca motor uzual 
de baze de date relaţionale. Poate folosi şi dBASE, 
Microsoft Access, MySQL sau Oracle, ori altă bază de 
date compatibilă cu ODBC sau  JDBC. Base 
implementează suport şi pentru un subset din 
specificaţia ANSI-92 SQL.

Math (editorul de formule)
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Math este editorul OOo de formule sau ecuaţii. Îl puteţi 
folosi pentru a crea ecuaţii complexe care includ 
caractere sau simboluri sau caractere indisponibile în 
fonturile obişnuite. Deşi este cel mai mult utilizat 
pentru a crea formule în alte componente, ca de 
exemplu în Writer sau Impress, Math poate să lucreze şi 
independent. Puteţi să salvaţi formulele în limnajul 
(standard) Mathematical Markup Language (MathML) 
pentru a le putea include în pagini web sau în alte 
documente care nu sunt create cu OOo.

Avantajele OpenOffice.org

Iată câteva dintre avantajele oferite de OpenOffice.org faţă de alte suite de birou:

• Fără taxe de licenţiere. OOo este gratuit pentru oricine, att să îl folosească cât şi să îl 
distribuie. Multe facilităţi pentru care în alte suite se plăteşte separat (de exemplu 
posibilitatea de export în PDF) sunt gratuite de asemenea în OOo. Nu există taxe 
ascunse şi nici nu vor exista pe viitor.

• Sursă publică. Puteţi distribui, copia, modifica softwareul în orice mod doriţi, în 
conformitate cu oricare dintre cele 2 licenţe tip Sursă publică (Open Source) sub care 
este licenţiat OOo.

• Multi-platformă. OOo 2.0 este disponibil pe câteva arhitecturi hardware şi sub mai 
multe sisteme de operare, cum sunt Microsoft Windows, Mac OS X, Linux şi Sun 
Solaris.
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• Localizare extinsă. Interfaţa utilizator a OOo este disponibilă în peste 40 de limbi, iar 
proiectul OOo furnizează dicţionare de ortografie, punctuaţie, cuvinte în peste 70 de 
limbi şi dialecte. OOo oferă de asemenea suport pentru limbajele care folosesc 
Aranjament complex al textului - Complex Text Layout (CTL) şi De la dreapta la stânga 
- Right to Left (RTL), cum sunt hindusa, israeliana şi araba.

• Interfaţă utilizator consecventă. Toate componentele au o înfăţişare şi un mod de 
lucru similar, fiind astfel uşor de a lucra şi de a le stăpâni.

• Integrare. Componentele din OpenOffice.org sunt integrate unele cu altele.

• Toate componentele împart un corector ortografic comun şi alte unelte, care sunt 
utilizate consecvent în toată suita. De exemplu, uneltele de desenare disponibile în 
Writer se găsesc şi în Calc, de asemenea, în variante cu mai multe opţiuni, în Draw 
şi Impress.

• Nu trebuie să ştiţi ce aplicaţie a fost folosită pentru a crea un anume fişier (de 
exemplu, puteţi deschide un fişier Draw din Writer).

• Granularitate. De obicei modificarea unei opţiuni afectează toată suita. Totuşi, 
opţiunile OOo pot fi stabilite numai pentru o componentă sau chiar numai pentru un 
document.

• Compatibilitate la nivel de fişier. OOo include facilităţi pentru a exporta în PDF şi 
Flash, ca şi posibilitatea de a deschide şi salva în formatele de fişier Microsoft Office, 
HTML, XML, WordPerfect şi Lotus 123.

• Nu depindeţi de un vânzător. OOo 2.0 foloseşte OpenDocument, un format de fişier 
XML (eXtensible Markup Language) dezvoltat ca standard industrial de către OASIS 
(Organization for the Advancement of Structured Information Standards) şi adoptat ca 
atare de către ISO pe 16 mai 2005. Aceste fişiere pot fi uşor dezipate şi citite cu orice 
editor de text, iar structura lor este publică.

• Părerea dumnevoastră contează. Îmbunătăţirile, corecturile îm software, data 
lansărilor sunt cerute de comunitate. Puteţi să vă alăturaţi comunităţii şi să influenţaţi 
evoluţia produsului.

Puteţi să citiţi mai mult despre OpenOffice.org, scopul său, istoria, licenţierea precum şi alte 
informaţii aici: http://www.openoffice.org/about.html
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Cum st  OpenOffice.org în ă compara ii?ţ

OpenOffice.org poate oferi cel puţin la fel de multe opţiuni ca şi suitele de aplicaţii cu care 
concurează. Următorul tabel listează principalele componente ale OOo şi le compară cu 
echivalentele lor din 2 suite majore de birou, Microsoft Office 2003 (MSO) şi WordPerfect 
Office X3 (WP).

Func iaţ OOo MSO WP

Editor de text Writer Word® WordPerfect® X3

Foi de calcul Calc Excel® Quattro Pro® X3

Grafică vectorială Draw nu nu

Diapozitive Impress PowerPoint® Presentations™ X3

Baze de date Base Access® 1 Paradox® 2

Editor de ecuaţii 
(matematice)

Math da nu

1 Numai versiunea Professional.
2 Numai versiunile Professional şi Student and Teacher.

Facilit iăţ

Următorul tabel enumeră câteva importante facilităţi ale OpenOffice.org şi le compară cu cele 
2 suite menţionate, Microsoft Office 2003 (MSO) şi WordPerfect X3 (WP).

Stiluri şi formatare

Facilitate OOo MSO WP

Navigator da limitat1 nu

Fereastră Stiluri şi formatare da da nu

Suport de tastatură pentru stiluri de 
paragraf

da da nu

Suport pentru stiluri de pagină, cadru şi 
listă

da nu nu

Completare cuvinte da numai în Excel nu

Module pentru corectoarele ortografice 70+ 50+2 25

Unelte pentru formule sau ecuaţii da da nu
1 “Outline View” din Word oferă un subset din facilităţile din Navigator.
2 Necesită o licenţă adiţională pentru Multilingual User Interface Pack.

Interoperabilitate

Facilitate OOo MSO WP

Export în format PDF da da1 da

Export în format Flash da nu da
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Facilitate OOo MSO WP

Export în format XML da da da

Format OpenDocument XML da nu nu

Import/Export format Microsoft Office da da da

Import fişiere WordPerfect da da da

Import fişiere Lotus 123 da da da

Conectare la baze de date externe 
(MySQL, Oracle, Access, etc.)

da da da

Limbaje în care este disponibil 
(localizări)

40+ 35+
30

Sisteme de operare suportate Windows, Mac OS X, 
Linux, Solaris

numai 
Windows

2

numai 
Windows

Suport Unicode pentru limbaje da da nu

1 Necesită software produs de terţi, ca de exemplu PDF Writer ori PDF Converter.
2 Microsoft Office: Mac nu este compatibil ca facilităţi cu Microsoft Office 2003.

Programabilitate

Macro-urile sunt programe care implementează funcţii şi care pot fi incluse în documente. 
Următorul tabel arată limbajele disponibile pentru scrierea de comenzi macro în fiecare suită 
de birou.

Limbaj OOo MSO WP

Limbaj tip Basic OpenBasic VBA VBA

Beanshell da nu nu

Java da nu nu

JavaScript da nu nu

Python da nu nu

Dincolo de macro-uri simple, unele suite de birou pot fi extinse pentru a oferi noi facilităţi. 
Această posibilitate se realizează de obicei prin plug-in-uri (componente adiţionale). În cazul 
OpenOffice.org însă, această extindere poate fi realizată direct prin modificarea codului sursă.

Facilitate OOo MSO WP

C şi C++ da da da

Java da nu nu

Python da nu nu

Sursă disponibilă da nu nu

Securitate
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Facilitate OOo MSO WP

Semnături digitale da da da

Criptare performantă da da da

Căi sigure pentru execuţia macro-urilor da da nu

Noi facilit i în versiunea 2ăţ

OpenOffice.org 2.0 adaugă sute de îmbunătăţiri precum şi noi facilităţi. Mai jos sunt 
enumerate câteva dintre cele majore.

• Instalare simplificată. Instalările sunt acum efectuate de către pragrame native fiecărei 
platforme fără a mai fi necesar să folosiţi opţiuni din linia de comandă pentru instalările 
multi-utilizator. Puteţi de asemenea alege ce versiune de Java (dacă sunt mai multe) să 
fie utilizată de către OOo din interfaţa de instalare.

• Noua componentă, Base - baze de date. În noua componentă de sine stătătoare puteţi 
crea formulare, rapoarte, interogări, tabele, vizualizări şi relaţii. OOo include acum 
HSQLDB, o bazp de date relaţională mică şi rapidă care suportă un subset al ANSI-92 
SQL, împreună cu o interfaţă uşor de utilizat. În plus, este foarte facil de folosit alte 
baze de date (dBASE, MySQL, Oracle, printre altele).

• Noul format de fişier. OOo 2.0 foloseşte formatul de fişier OpenDocument XML 
(standardizat de OASIS, http://www.oasis-open.org/home/index.php) ca format de fişier 
implicit. Acest nou format de fişier este de asemenea folosit în StarOffice, IBM 
Workspace şi KOffice, şi va fi folosit de alte produse pe viitor. OOo 2.0 poate în 
continuare deschide şi salva fişiere în formatele suportate anterior de OOo 1.x, inclusiv 
formatele Microsoft Office.

• Integrarea temei din sistemul de operare. Pentru a integra şi mai mult OpenOffice.org 
cu sistemul de operare pe care rulează, toate elementele din interfaţa utilizator (cum sunt 
butoatenele şi barele de derulare) arată la fel ca cele utilizate de celelalte aplicaţii native 
de pe aceeaşi platformă.

• Semnături digitale. Semnăturile digitale oeferă posibilitatea autentificării semnăturii 
autorului sau editorului unui document. Această facilitate oferă de asemenea securitate 
la execuţia macro-urilor.

• Criptare performantă. Implementarea algortimului de criptare XML (eXtensible 
Markup Language) oferă securitate suplimentară pentru document.

• Îmbunătăţiri privind utilizarea. Noiele bare de unelte, reconcepute, sunt mai uşor de 
folositşi afişează numai unelte selectate şi cele legate de acestea. Utilizarea categoriei 
Meniuri (Menus) a dialogului  Unelte > Personalizare (Tools > Customize) a fost 
îmbunătăţită. Alte facilităţi au fost redenumite pentru consecvenţă cu terminologia din 
alte suite de birou (de exemplu, “AutoPilot” este acum “Vrăjitor - Wizard”).

• Previzualizări miniaturizate. Noul plug-in pentru navigatorul de fişiere oferă 
previzualizarea miniaturizată a fişierelor OO. Câteva dintre navigatoarele de fişiere 
uzuale care pot folosi acesată facilitate sunt Microsoft Windows Explorer, Nautilus 
(Gnome) şi Konqueror (KDE).
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• Filtre de import şi export
• Filtrul de export PDF a fost îmbunătăţit şi acum include semne de carte, note, 

elemente de securitate, etc.

• La filtrele Word au fost adăugate importul şi exportul butoanelor de rotire şi barele 
de derulare din Microsoft Office 95 şi Office 97.

• Filtrul de import pentru documente Microsoft PowerPoint creează acum obiecte text 
având spaţierea independentă de fontul folosit.

• Export îmbunătăţit în HTML produce documente valide “XHTML 1.0 Strict”. 
Exportul în XHTML a fost adăugat în Calc, Draw şi Impress.

• Puteţi deschide acum documente Microsoft Office protejate cu parolă. 

• Noi filtre de import pentru WordPerfect şi Lotus 123.

• Trimitere de document ca email. OOo 2.0 uşurează utilizarea clientului de email 
pentru a trimite documentul curent ca ataşament.

• Îmbunătăţirea facilităţii de concatenare a emailurilor. Îmbunătăţirile includ un 
management mai bun al bazelor de date şi salvarea într-un singur fişier.

• Creare de stiluri prin tragere. Puteţi crea un nou stil de paragraf sau caracter trăgând o 
selecţie de text în fereastra Stiluri şi formatare (Styles and Formatting).

• Controale de formular. Controalele de formular pot fi înglobate în orice document OO 
care acceptă formulare.

• Noi taste rapide. Puteţi folosi tastatura pentru a efectua operaţiunile din meniul 
Editare > Lipire specială (Edit > Paste Special). Selecţia mutliplă de foi din Calc 
poate fi deselectată folosind tastatura. Stilurile, inclusiv de paragraf, pot fi legate de 
combinaţii de taste.

• Auto - recuperare a fişierelor şi a mediului de lucru. Unealta de raportare erori (OOo 
Error Reporting) şi facilităţile de recuperare a documentelor au fost combinate. Dacă 
OOo se va prăbuşi documentele active sutn salvate. Veţi putea recupera documentele şi 
să trimiteţi un raport privind eroarea.

• Facilităţi îmbunătăţite în Calc. Aceste îmbunătăţiri includ o mai bună recunoaştere a 
numerelor, o funcţie Hyperlink îmbunătăţită, matrice condiţionale, mai multe antete şi 
subsoluri predefinite, mai multe opţiuni despre cum să fie imprimate foile de calcul, noi 
opţiuni pentru facilitatea DataPilotşi suport pentru limbile scrise de la dreapta la stânga.

• Limita maximă de rânduri din Calc a fost majorată. Acum numărul a fost majorat la 
65536, acelaşi cu cel din Microsoft Excel.

• Îmbunătăţiri pentru multimedia. Prezentările multimedia folosesc acum standardul 
W3C Synchronized Multimedia Integration Language (SMIL). Acum Impress poate 
executa aproape toate efectele de animaţie din Microsoft PowerPoint. Două noi paneluri 
de sarcini oferă acces la efectele intermediare privind formele şi diapozitivele.
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• Controlul meniului şi a elementelor din panourile cu unelte se poate programa. 
Programatorii terţi pot scrie plug-in-uri pentru a manipula bara de meniu şi aspectul 
panourilor cu unelte după necesităţi. Dezvoltătorii pot acum insera, elimina şi modifica 
elemente de meniu, meniuri contextuale şi elementele din panourile cu unelte la 
momentul execuţiei.

• Interfaţă pentru limbaje tip "scripting". Interfaţa scripting vă permite să scrieţi 
macro-uri în mai multe limbaje, altele decât OOo Basic. Puteţi asocia aceste maro-uri cu 
elementele din meniuri, taste rapide, evenimente din document sau aplicaţie, controalele 
formular din documente, precum şi cu alte obiecte din documente.

Pentru o enumerare completă şi detaliată citiţi Suita de birou OpenOffice.org 2.0, Ghidul 
facilităţilor noi de la adresa http://marketing.openoffice.org/2.0/featureguide.html#enduser

Cerin e minimeţ

OpenOffice.org 2.0 necesită unul dintre sistemele de operare următoare:

• Microsoft Windows 98, Windows ME, Windows 2000 (Service Pack 2 sau mai nou), 
Windows XP, Windows 2003, sau Windows Vista

• GNU/Linux Kernel version 2.2.13 şi glibc 2.2.0 sau mai nou

• Mac OS X 10.3.x (10.3.5 recomandat), Mac OS X 10.4.x, este necesar X11

• Solaris versiunea 8 sau mai nouă

În viitor vor fi suportate mai multe sisteme de operare.

Câteva dintre facilităţile OpenOffice.org (vrăjitorii şi motorul de baze de date HSQLDB) 
necesită Java Runtime Environment (JRE) instalat pe calculatorul dumnevaoastră.  Deşi OOo 
va rula fără probleme şi fără suport Java, câteva dintre facilităţi nu vor fi disponibile. Puteţi 
obţine ultima versiune Java de la http://www.java.com.

Pentru o expunere mai detaliată (şi poate mai de actualitate) a cerinţelor minime citiţi:
http://www.openoffice.org/dev_docs/source/sys_reqs_20.html.

Ob inerea programuluiţ

Puteţi să obţineţi pachetul de instalare al OpenOffice.org astfel:

• Copiaţi-l de pe pagina proiectului: http://www.openoffice.org.

• Folosiţi un client P2P, ca de exemplu BitTorrent. Instrucţiunile sunt aici: 
http://distribution.openoffice.org/p2p/.

• Cumpăraţi o copie pe CD-ROM sau în altă formă digitală de la un distribuitor. Proiectul 
menţine o listă de distribuitori. Aceşti distribuitori nu sunt afiliaţi la/ susţinuţi de 
OpenOffice.org:
http://distribution.openoffice.org/cdrom/sellers.html.
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• Proiectul de portare OpenOffice.org (Porting Project) are legături spre versiunile 
programului care au fost portate sau sunt în curs de portare pentru a putea rula pe alte 
sisteme de operare, inclusiv în mod nativ pe Mac OS X: 
http://porting.openoffice.org/index.html.

Instalarea programului

Informaţii despre cum să instalaţi şi să configuraţi OpenOffice.org pe diversele sisteme de 
operare suportate găsiţi la http://download.openoffice.org/2.1.0/instructions.html, ca de altfel şi 
în acest ghid, în capitolele următoare.

Puteţi descărca ghidul mult mai detaliat (în câteva limbi) Setup Guide de la 
http://documentation.openoffice.org/setup_guide2/index.html 

Cum s  primi i ajutoră ţ

Sistemul de ajutor integrat
OOo vine cu un amplu sistem de ajutorare (Help). Acesta este prima sursă de ajutor pentru 
utilizarea OOo.

Pentru a afişa acest sistem apăsaţi F1 sau selectaţi OpenOffice.org Ajutor (OpenOffice.org 
Help) din meniul Ajutor (Help). În plus, puteţi alege dacă să activaţi ponturile, ponturile 
extinse şi Agentul de ajutor (Help Agent), folosind Unelte > Opţiuni > General (Tools > 
Options > General).

Dacă ponturile sunt activate plasaţi cursorul mausului peste oricare dintre pictograme pentru a 
vedea o căsuţă cu o scurtă explicaţie a funcţiei butonului. Pentru o explicaţie mai detaliată, 
selectaţi Ajutor > Ce este aceasta? (Help > What's This?) şi ţineţi cursorul mausului peste 
pictogramă.
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Meniul Ajutor (Help).

Ajutor gratuit pe internet
Comunitatea OpenOffice.org nu se limitează la a dezvolta programul, dar vă oferă şi ajutor 
gratuit, de către voluntari. Utilizatorii de OOo pot obţine acest ajutor pe căile obişnuite ale unei 
astfel de comunităţi, respectiv newsgroup-uri, forumuri sau liste de email. Sunt disponibile de 
asemenea numeroase site-uri web pe acest subiect, unde veţi găsi, în mod gratuit, ponturi şi 
tutoriale.

Suport gratuit OpenOffice.org

Proiectul User Help – FAQ
Întrebări frecvente (FAQ), informaţii, cunoştinţe
http://user-faq.openoffice.org/new-faq/index.html

Lista de email a utilizatorilor

Suport oferit gratuit de comunitate de către câteva 
sute de utilizatori experimentaţi. Trebuie să vă abonaţi 
pentru a trimite mesaje. Pentru a vă abona, trimiteţi un 
email fără conţinut la  
users-subscribe@openoffice.org

Arhivele listei sunt aici:
http://www.openoffice.org/servlets/SummarizeList? 
listName=users

Proiectul de documentaţie
Şabloane, ghiduri utilizator, instrucţiuni şi altă 
documentaţie. http://documentation.openoffice.org/

Proiectul de localizare (Native 
Language Project)

Informaţii, resurse şi liste de email în diverse limbi 
http://projects.openoffice.org/native-lang.html

Suport pentru Mac
Ajutor pentru instalarea şi utilizarea versiunii pentru 
Mac OS X (bazată pe X11). 
http://porting.openoffice.org/mac/support.html

 Forumul OpenOffice.org

Forum de discuţii amănunţite despre problemele 
ridicate de OpenOffice.org de la instalare şi până la 
facilităţile avansate de programare. 
http://www.oooforum.org/

Colecţia de cunoştinţe OOo - 
KnowledgeBase

O colecţie de întrebări şi răspunsuri ce pot fi cercetate 
de către utilizatori.  http://mindmeld.cybersite.com.au/

Citiţi mai multe despre opţiunile de suport ale OpenOffice.org la:
http://support.openoffice.org/index.html
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Cum s  primi i ajutoră ţ

Suport pl tit şi cursuriă

În mod alternativ, puteţi plăti pentru serviciile de suport. Contractele de suport pot fi cumpărate 
de la un distribuitor sau o firmă de consultanţă specializată în OpenOffice.org. 

OOo este suportat de către Sun Microsystems, Inc. în conformitate cu programul Sun Software 
Support, care include 2 niveluri de suport care acoperă şi orele suplimentare ori programul 
non-stop pentru instalările ce necesită aceasta. 
http://www.sun.com/service/support/software/openoffice/index.html

O listă de consultanţi şi a serviciilor oferite, listaţi alfabetic după regiune şi tară, este 
întreţinută pe situl web al proiectului OpenOffice.org. 
http://bizdev.openoffice.org/consultants.html

Alte resurse, aplica ii complementareţ

Câteva situri web furnizează resurse suplimentare gratuite şi diverse aplicaţii pentru a 
îmbunătăţi OpenOffice.org. Următorul tabel menţionează câteva dintre acestea.

Şabloane, grafic , aplica ii, alte resurse gratuite pentru OOoă ţ

OOExtras
Oferă şabloane, modele şi macro-uri în câteva limbi. 
http://ooextras.sourceforge.net/

OOoMacros
O magazie pentru macrouri OOo şi aplicaţii şi 
documentaţie despre scrierea macro-urilor sau 
extinderea OOo. http://www.ooomacros.org/

Biblioteca de grafică publică 
(Open Clip Art Library)

O arhivă de grafică care este disponibilă gratuit pentru 
orice utilizare. http://www.openclipart.org/

 Informaţii despre macro-uri 

Andrew Pitonyak, autorul cărţii despre macro-uri în 
OOo OpenOffice.org Macros Explained, menţine 
acest sit care vă oferă documentaţie detaliată despre 
opţiunile OOo pentru macro-uri. Sunt furnizate de 
asemenea multe linkuri către referinţe de calitate. 
http://www.pitonyak.org/oo.php

O scurt  ă istorie a OpenOffice.org

Proiectul OpenOffice.org a început o dată cu oferirea de către Sun Microsystems a codului 
sursă (“blueprints”) pentru softwarul StarOffice® către comunitatea dedicată sursei publice în 
2000. Aceasta a permis celor de la Sun să se folosească de cunoştinţele tehnice şi ciclul de 
dezvoltare scurt al proiectelor de sursă publică în propriile produse software. Toate versiunile 
recente ale StarOffice de la Sun folosesc codul sursă dezvoltat de comunitatea OpenOffice.org. 
Totuşi, produsele Sun nu oferă în mod exact aceleaşi facilităţi, datorită diverselor drepturi de 
autor ale terţilor, ale căror modalităţi de licenţiere nu sunt compatibile cu licenţierea în regim 
de sursă publică.

Citiţi mai multe despre istoria OpenOffice.org şi organizaţia în sine la: 
http://about.openoffice.org/
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O scurt  istorie a OpenOffice.orgă

Informaţii despre StarOffice pot fi găsite la: http://www.sun.com/software/star/staroffice/

Cum este licen iat OpenOffice.org?ţ

OpenOffice.org este distribuit sub licenţa Lesser General Public License (LGPL) aprobată de 
către Open Source Initiative (OSI).

Licenţa LGPL poate fi citită pe situl web al OOo la: 
http://www.openoffice.org/licenses/lgpl_license.html

Pentru mai multe informaţii despre licenţierea OOo citiţi şi: 
http://www.openoffice.org/license.html

Ce este “surs  public ”?ă ă

Idealurile programelor cu sursă publică (open-source) sunt exprimate prin 4 principii, care sunt 
înglobate în licenţa Free Software Foundation’s General Public License (GPL):

• Dreptul de a folosi programul pentru orice scop.

• Libertatea de a redistribui programul gratuit sau contracost.

• Acces la sursa completă a programului (numită “blueprints”).

• Dreptul de a modifica orice parte din sursă, sau de a folosi porţiuni din aceasta în alte 
programe.

Altă perspectivă asupra acestei filozofii este dată de Open Source Definiton:

“Ideea primară din spatele conceptului de sursă publică este foarte simplă: Când 
programatorii pot citi, redistribui şi modifica codul sursă al programelor, acestea vor 
evolua. Oamenii le vor îmbunătăţi, le vor adapta, vor repara erorile. Şi toate acestea se vor 
întâmpla cu o viteză care, prin comparaţie cu ritmul lent de dezvoltare a unui program în 
mod convenţional, pare uluitoare.”

Pentru mai multe informaţii despre programele gratuite şi în regim de sursă publică, vizitaţi 
aceste situri:

Open Source Initiative (OSI): http://www.opensource.org

Free Software Foundation (FSF): http://www.gnu.org

Întreb ri puse frecventă

Acest program este o versiune "demo"? Nu, este un o suită de programe complet funcţională.

Pot să distribui OOo către oricine? Da.

Pe câte calculatoare îl pot instala? Pe oricâte doriţi.

Pot să îl comercializez? Da.
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Întreb ri puse frecventă

Pot să folosesc OpenOffice.org în cadrul 
unei afaceri?

Da.

Este OpenOffice disponibil în limba mea? OpenOffice.org a fost tradus (localizat) în peste 40 de 
limbi, astfel încât limba dumnevoastră este probabil 
implementată. Suplimentar, sunt peste 70 de 
dicţionare  ortografice, de punctuaţie şi de cuvinte 
disponibile pentru diverse limbi, ca şi pentru dialecte 
care nu au o interfaţă specifică. Aceste dicţionare sunt 
disponibile pe situl web al OpenOffice.org la: 
http://lingucomponent.openoffice.org/download
_dictionary.html

Cum de este gratuit? O mare parte din dezvoltare, ca şi mare parte din 
suportul pentru proiect, este furnizată sau 
sponsorizată de către Sun Microsystems. Sunt de 
asemenea mulţi oameni care muncesc la OOo ca 
voluntari.

Şi dacă am nevoie de suport tehnic? Citiţi secţiunea intitulată “Cum să primiţi ajutor”.

Cine este proprietarul programului? Dreptul de autor este deţinut în comun de Sun 
Microsystems şi toţi voluntarii care au contribuit.

Aceasta înseamnă că pot să îşi ia înapoi 
programul?

Nu. Licenţele (contractele de utilizare) sub care OOo 
este dezvoltat şi distribuit nu vor putea fi niciodată 
revocate, astfel încât programul nu poate fi luat 
înapoi.

Scriu un program. Pot folosi cod sursă din 
OpenOffice.org în programul meu?

Puteţi, în limitele permise de licenţa LGPL. O puteţi 
citi la: http://www.openoffice.org/license.html

De ce facilitatea mea favorită din 
StarOffice nu este disponibilă şi în 
OpenOffice.org?

Această facilitate este probabil o aplicaţie 
complementară de la un terţ pe care Sun nu o poate 
distribui împreună cu OpenOffice.org.

De ce este necesar Java pentru a rula 
OpenOffice.org? Este scris în Java?

OpenOffice.org nu este scris în Java; este scris în 
limbajul C++. Java este unul dintre limbajele care pot 
fi folosite pentru a extinde OOo. Java JDK/JRE este 
necesar numai pentru câteva funcţii. Cea mai 
importantă dintre acestea este motorul de baze de date 
relaţionale HSQLDB.

Note: Java este disponibilă gratuit. Chiar dacă nu 
doriţi să folosiţi Java, veţi putea totuşi folosi aproape 
toate funcţiile şi facilităţile OOo.

Cum pot contribui la OpenOffice.org? Puteţi să ajutaţi dezvoltarea OOo în multe modalităţi, 
nefiind necesar să fiţi un programator. Pentru a 
începe, vedeţi această pagină web: 
http://www.openoffice.org/contributing.html

Care-i şmecheria? Niciuna. Citiţi licenţa: 
http://www.openoffice.org/license.html
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Lansarea OOo din meniul sistemului

Lansarea OOo din meniul sistemului

Folosirea meniului sistemului este metoda cea mai obişnuită pentru a lansa OpenOffice.org. 
Meniul sistemului este un meniu standard de unde pot fi pornite cam toate aplicaţiile. În 
Windows meniul este denumit Start. În GNOME este denumit Applications. În KDE este 
identificat prin simbolul KDE, iar pe Mac OS X este meniul Applications.

Când OpenOffice.org a fost instalat s-a adăugat un submeniu la meniul sistemului 
dumneavoastră. Numele exact şi localizarea acestui submeniu depind de interfaţa grafică pe 
care o folosiţi. Acest capitol se va referi la Windows, GNOME şi KDE pe Linux, şi Mac OS X. 
Conceptele ar trebui să fie uşor de aplicat şi pe celelalte sisteme de operare.

Windows
În Windows, meniul OpenOffice.org este localizat în Programs > OpenOffice.org 2.x,  unde 
“2.x” corespunde cu versiune exactă a OpenOffice.org. Imaginea 1 înfăţişează meniul tipic 
pentru Windows XP. Selectaţi OpenOffice.org Writer pentru a porni Writer cu un document 
gol.

Imaginea 1: Lansarea OOo din meniul Start din Windows XP.
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Lansarea OOo din meniul sistemului

Linux/GNOME
Instalările GNOME diferă de la o distribuţie la alta. Cele mai multe distribuţii moderne vin cu 
OpenOffice.org deja instalat. Veţi găsi OpenOffice.org la Applications > Office. Vedeţi 
Imaginea 2.

Imaginea 2: Lansarea OOo din meniul Applications din 
GNOME.

Fedora/Red Hat Enterprise Linux vin cu OpenOffice.org preinstalat. Pe desktopul GNOME 
OOo poate fi găsit la Main Menu > Office. Dacă aveţi instalată o versiune mai nouă de OOo o 
veţi găsi la Main Menu > Office > More Office Applications.

Dacă aţi descărcat OOo de la websitul http://www.openoffice.org OOo este la Applications > 
Other.
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Linux/KDE
În KDE, OpenOffice.org este instalat în propriul său meniu denumit “Office” (vedeţi Imaginea
3).

Imaginea 3: Lansarea OOo din meniul de start din  KDE .

Unele distribuţii Linux instalează OpenOffice.org în submeniul Office. Mandrake este un 
exemplu. În acest caz, pentru a lansa Math (de exemplu) alegeţi Office > Word processors > 
OpenOffice.org Math. Imaginea 4 illustrates this. În versiunea KDE în lima română, meniul 
"Office" este tradus ca "Aplicaţii de birou".
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Lansarea OOo din meniul sistemului

Imaginea 4: Lansarea OOo Math din meniul KDE din Mandrake.

Mac OS X
Deschideţi directorul unde aţi instalat OpenOffice.org. Ar trebui să vedeţi pictograma acesteia 
în directorul Applications (Imaginea 5). Pentru a lansa OpenOffice.org daţi dublu clic pe 
aceasta.

Imaginea 5: Lansarea OpenOffice.org din directorul Applications al Mac-ului.
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Lansarea dintr-un document existent

Lansarea dintr-un document existent

Puteţi lansa OOo în mod automat dacă daţi dublu clic pe numele fişierului documentului OOo 
într-un manager de fişiere. Va fi lansată componenta OOo corespunzătoare tipului 
documentului, iar documentul va fi încărcat.

Pentru utilizatorii Windows
Asocierile de fişiere sunt folosite pentru a deschide anumite tipuri de fişiere în mod automat cu 
OpenOffice.org. În timpul instalării OOo, puteţi opta pentru a asocia tipurile de fişiere folosite 
de Microsoft Office cu OOo. Dacă veţi alege să faceţi aceasta, după aceea puteţi să daţi dublu - 
clic pe un fişier  .doc (creat, de obicei, cu Word), să îl deschideţi în Writer; un fişier .xls 
(Excel) se va deschide în Calc, iar un fişier .ppt (Powerpoint) în Impress.

Dacă nu veţi asocia tipurile de fişiere, atunci când veţi da dublu - clic pe un document 
Microsoft Word se va dechide în Microsoft Word (dacă Word este instalat pe calculatorul 
dumneavoastră), fişierele Excel se vor deschide în Excel, iar cele Powerpoint în Powerpoint.

Puteţi folosi şi o altă metodă pentru a deschide în OOo fişierele .doc şi a salva folosind 
formatul .doc din OOo. Citiţi capitolul 3 (Gestiunea fişierelor în OpenOffice.org) pentru mai 
multe informaţii.

Utilizarea Quickstarter în Windows

Quickstarter (tradus literal prin lansare rapidă) este vizibil ca o pictogramă din tava de sistem; 
de obicei este încarcat o data cu sistemul de operare. Indică faptul că OpenOffice.org a fost 
lansat şi este gata de a fi utilizat. (Quickstarter încarcă bibliotecile de sistem .DLL care sunt 
necesare OOo, scurtând astfel timpul necesar componentelor OOo pentru a se lansa cu aproape 
jumătate.) Dacă aţi dezactivat Quickstarter, citiţi “Reactivarea Quickstarter” pentru a vedea 
cum să îl reactivaţi.

Utilizarea Quickstarter
Daţi clic dreapta pe pictograma Quickstarter din tava de sistem pentru a deschide un meniu 
contextual de unde puteţi deschide un nou document, dialogul Şabloane şi documente 
(Templates and Documents) sau să alegeţi un document existent şi să îl deschideţi. (Vedeţi 
Imaginea 6.) Dacă veţi da dublu clic pe pictograma Quickstarter se va afişa direct dialogul 
Şabloane şi documente.

Dezactivarea facilit ii Quickstarterăţ

Pentru a închide Quickstarter daţi clic dreapta pe pictograma din tava de sistem şi apoi alegeţi 
Părăseşte Quickstarter (Exit Quickstarter) din meniul contextual. Însă data următoare când 
veţi încărca sistemul Quickstarter se va lansa din nou.
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Utilizarea Quickstarter în Windows

Pentru a opri OpenOffice.org să se încarce o data cu pornirea sistemului de operare debifaţi 
opţiunea Încarcă OpenOffice.org la pornirea sistemului (Load OpenOffice.org During 
System Start-Up) din meniul contextual. Veţi fi nevoit să faceţi aceasta dacă nu aveţi 
suficientă memorie pe calculatorul pe care lucraţi, de exemplu.

Imaginea 6: Meniul contextual Quickstarter.

Reactivarea Quickstarter
Dacă aţi dezactivat Quickstarter şi doriţi să îl reactivaţi bifaţi căsuţa Încarcă OpenOffice.org 
la pornirea sistemului din Unelte > Opţiuni > OpenOffice.org > Memorie (Tools > 
Options > OpenOffice.org > Memory).

Folosirea Quickstarter pe Linux

Unele instalări de OpenOffice.org pe Linux includ un Quickstarter care arată şi funcţionează ca 
versiunea sa de Windows (căsuţa din meniul Memorie este denumită Activează Quickstarter 
din tava de sistem (Enable systray quickstarter). Quickstarter este dezactivat pe Linux în 
celelalte instalări, dar va deveni disponibil în timp.

Pre-înc rcarea OOo în Linux/KDEă

În Linux/KDE, puteţi folosi KDocker pentru a încărca OOo la iniţializarea sistemului grafic de 
interfaţă cu utilizatorul şi a-l avea gata de utilizare. KDocker nu face parte din OOo; este un 
program generic de “docare a aplicaţiilor” în tava de sistem a KDE care vă este de mare ajutor 
dacă deschideţi des OOo.
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Lansarea din linia de comandă

Puteţi dori să lansaţi OOo din linia de comandă (folosind astfel tastatura în loc de maus). De 
ce? Ei bine, deoarece aveţi mai mult control asupra a ceea ce se întâmplă atunci când OOo 
porneşte. De exemplu, folosind linia de comandă, puteţi să comandaţi Writer-ului să încarce un 
document şi să îl imprime imediat sau să pornească fără a mai afişa imaginea de pornire.

Notă Majoritatea utilizatorilor nu au nevoie de aceste lucruri.

Sunt mai multe feluri de a porni OOo din linia de comandă, în funcţie de versiunea de OOo 
instalată, şi anume una personalizată sau cea standard disponibilă pe websitul OpenOffice.org.

Dacă aţi instalat versiunea standard puteţi lansa Writer tastând în linia de comandă:

soffice -writer
sau       swriter

Writer se va lansa şi va crea un document nou. Componentele OOo se lansează similar din linia 
de comandă:

Tipul documentului Componentă Op iunea din linia deţ  
comandă

Text Writer -writer

Foaie de calcul 
(Spreadsheet)

Calc -calc

Desen (Drawing) Draw -draw

Prezentare (Presentation) Impress -impress

Formulă (matematică) Math -math

Pagină Web Writer -web

Pentru a vizualiza lista opţiunilor pe care le aveţi când lansaţi Writer din linia de comandă, 
tastaţi:

soffice -?
Mai jos este o listă cu opţiunile mai des folosite.
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Op iuneţ Descriere

-help Se afişează lista completă a opţiunilor.

-nologo Nu arată imaginea de pornire.

-show <odp-file> Începe prezentarea imediat.

-view <documents 
...>

Deschide documentele fără posibilitatea de a le modifica (doar 
citire).

-minimized Lansează OOo minimizat.

-norestore Fără repornire/restaurare la erorile fatale.

-invisible Fără imagine de pornire, fără document încărcat automat şi 
fără interfaţă cu utilizatorul. Această opţiune este folositoare 
dacă utilizaţi o altă aplicaţie care foloseşte funcţiile oferite de 
OOo.

Dacă însă aveţi instalată o versiune modificată de OOo (cum sunt cele furnizate de Linux 
Mandrake sau Gentoo), puteţi porni Writer tastând din linia de comandă:

oowriter

Notă Deşi sintaxa comenzilor diferă, efectul va fi identic: va porni OOo cu un document 
Writer gol.
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Deschiderea fişierelor

Deschiderea fişierelor

Pentru a deschide un fişier existent alegeţi Fişier > Deschide (File > Open) sau apăsaţi 
pictograma Deschide fişier (Open File) de pe bara instrumentelor Standard ori apăsaţi tastele 
Control+O.

Dialogul Deschide (Open) va apare. Imaginea 13 înfăţişează aspectul din WindowsXP al 
acestui dialog.

Imaginea 7. Dialogul Deschide (Open) din WindowsXP.

Alegeţi fişierul, apoi daţi clic pe Deschide (Open).

Notă Dacă folosiţi Microsoft Windows aveţi de ales între a folosi dialogurile Deschide şi 
Salvează ca... furnizate fie de Microsoft Windows fie de OpenOffice.org. Pentru mai 
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Deschiderea fişierelor

multe detalii vedeţi “Utilizarea dialogurilor Deschide (Open) şi Salvează ca (Save
As)” la pagina 45.

Formatele de fişier
OpenOffice.org poate importa (citi) fişierele folosite de Microsoft Office. Pe de altă parte, la 
această dată Microsoft Office nu poate importa fişierele în formatul OpenDocument, care este 
folosit de OpenOffice.org. Programe ajutătoare sunt disponibile pentru a permite Microsoft 
Office să citească şi să scrie fişiere OpenDocument, dar dacă veţi dori să transmiteţi un fişier 
unui utilizator de Microsoft Office şi vreţi să fiţi sigur că va putea să îl deschidă, va trebui să îl 
salvaţi într-un format folosit de Microsoft Office sau în .rtf. Tabelul 1 oferă o ghidare uşoară.

Tabelul 1: Comparaţie între tipurile de fişier OpenDocument şi Microsoft Office

Tipul OpenDocument Aplica iaţ Extensia Echivalent MS Office

Text Writer .odt .doc

Şablon text (Template text) Writer .ott .dot

Document master Writer .odm .doc

Foaie de calcul (Spreadsheet) Calc .ods .xsl

Şablon foaie de calcul Calc .ots .xst

Desen (Drawing) Draw .odg N/A

Şablon desen (Drawing) Draw .otg N/A

Prezentare (Presentation) Impress .odp .ppt

Şablon prezentare Impress .otp .pot

Formulă Math .odf N/A

Grafic (Chart) Chart .odc N/A

Bază de date (Database) Base .odb .mdb

Formatele de fişier implicite
OpenOffice.org salvează fişierele implicit în formatul OpenDocument format, dar puteţi să 
selectaţi şi un alt format dacă, de exemplu, doriţi ca întotdeauna să vă salvaţi documentele ca 
fişiere Microsoft Office. Pentru a schimba formatele de fişier implicite:

1) Mergeţi la Unelte > Opţiuni > Încarcă/Salvează > General (Tools > Options > 
Load/Save > General). (Vedeţi Imaginea 8.)

2) La secţiunea Formatul implicit de fişier (Default file format) alegeţi tipul documentului 
(de exemplu, “Text document”) şi apoi formatul de fişier pe care doriţi să îl folosiţi de 
obicei din lista Întotdeauna salvează ca (Always Save As).

3) Va trebui să repetaţi pentru fiecare tip de document pentru care doriţi să faceţi 
schimbări.
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4) Apăsaţi OK pentru a salva schimbările.

Note Dacă opţiunea "Avertisment când nu salvez în formatul OpenDocument sau în cel 
implicit" (“Warn when not saving in OpenDocument or default format”) este bifată în 
dialogul Opţiuni – Încarcă/Salvează – General (Options – Load/Save – General) 
(Imaginea 8), un avertisment cu privire la eventuale pierderi de formatări va fi afişat. 
De obicei nu se va produce nici o pierdere de formatări, astfel încât s-ar putea să fiţi 
agasat inutil de acest avertisment şi să îl dezactivaţi.

Este necesar să aveţi instalat Java Runtime Environment pentru a folosi filtrele pentru 
dispozitivele mobile cum sunt AportisDoc (Palm), Pocket Word şi Pocket Excel.

Imaginea 8. Alegerea formatelor implicite pentru salvarea fişierelor.

Deschiderea fişierelor tip text
În plus faţă de formatele OpenDocument (.odt, .ott, .oth şi .odm), Writer 2.x poate deschide 
formatele utilizate de OOo 1.x (.sxw, .stw şi .sxg) şi următoarele formate de documente text:

Microsoft Word 6.0/95/97/2000/XP) (.doc şi .dot) WordPerfect Document (.wpd)
Microsoft Word 2003 XML (.xml) WPS 2000/Office 1.0 (.wps)
Microsoft WinWord 5 (.doc) DocBook (.xml)
StarWriter formats (.sdw, .sgl şi .vor) Ichitaro 8/9/10/11 (.jtd şi .jtt)
AportisDoc (Palm) (.pdb) Hangul WP 97 (.hwp)
Pocket Word (.psw) .rtf, .txt şi .csv

Când deschideţi fişiere .htm sau .html (folosite la paginile web) OpenOffice.org foloseşte un 
Writer optimizat special pentru lucrul cu aceste fişiere.
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Deschiderea foilor de calcul
În plus faţă de formatele OpenDocument (.ods şi .ots), Calc 2.x poate deschide formatele 
OpenOffice 1.x (.sxc şi .stc) ca şi următoarele formate de foi de calcul:

Microsoft Excel 97/2000/XP (.xls, .xlw şi .xlt) Rich Text Format (.rtf)
Microsoft Excel 4.x–5.0/95 (.xls, .xlw şi .xlt) Text CSV (.csv şi .txt)
Microsoft Excel 2003 XML (.xml) Lotus 1-2-3 (.wk1, .wks şi  .123)
Data Interchange Format (.dif) StarCalc formats (.sdc şi .vor)
dBase (.dbf) SYLK (.slk)
fişiere .htm şi .html inclusiv interogări de pagini Web Pocket Excel (pxl)
Quattro Pro 6.0 (.wb2)

Deschiderea prezent riloră

În plus faţă de formatele OpenDocument (.odp, .odg şi .otp), Impress 2.x poate deschide 
formatele folosite de OOo 1.x (.sxi şi .sti) şi formatele de prezentări folosite de:

• Microsoft PowerPoint 97/2000/XP (.ppt, .pps şi .pot)
• StarDraw şi StarImpress (.sda, .sdd, .sdp şi .vor)
• CGM – Computer Graphics Metafile (.cgm)

Deschiderea fişierelor de tip grafic
În plus faţă de formatele OpenDocument (.odg şi .otg), Draw 2.x poate deschide formatele 
grafice folosite de OOo 1.x (.sxd şi .std) şi formatele grafice următoare:

BMP JPEG, JPG PCX PSD SGV WMF
DXF MET PGM RAS SVM XBM
EMF PBM PLT SDA TGA XPM
EPS PCD PNG SDD TIF, TIFF
GIF PCT PPM SGF VOR

Deschiderea fişierelor de formule matematice
În plus faţă de formatele OpenDocument Formula (.odf), Math 2.x poate deschide formatele 
folosite de OOo 1.x (.sxm), StarMath, (.smf) şi MathML (.mml).

Dacă deschideţi fişiere produse de MS Word care conţin obiecte ale editorului de ecuaţii iar 
opţiunea din Unelte > Opţiuni > Încarcă/Salvează > Microsoft Office (Tools > Options > 
Load/Save > Microsoft Office) este bifată obiectul va fi în mod automat convertit în formatul 
OpenOffice.org Math.

Salvarea fişierelor

Pentru a salva un fişier nou:

1) Alegeţi Fişier > Salvează ca (File > Save As). 
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2) Când apare dialogul Salvează ca (Save As), introduceţi numele fişierului şi verificaţi-i 
tipul (dacă aveţi posibilitatea). 

Pentru a salva un document cu numele pe care deja îl are alegeţi Fişier > Salvează (File > 
Save). Aceasta va suprascrie versiunea salvată anterior.

Protec ia prin ţ parolă
Pentru a proteja întregul document împotriva consultării fără a introduce în prealabil o parolă, 
folosiţi opţiunea din dialogul Salvează ca (Save As) pentru introducerea unei parole. Această 
opţiune este disponibilă numai pentru formatele OpenDocument sau cele folosite de versiunea 
mai veche, OpenOffice.org 1.x. 

1) La dialogul Salvează ca (Save As), bifaţi casuţa de lângă Salvează cu parolă (Save 
with password) şi apoi apăsaţi Salvează (Save). Veţi fi întrebat:

2) Tastaţi aceeaşi parolă în câmpul Parolă (Password) ca şi în câmpul Confirm(are), apoi 
apăsaţi OK.  Dacă aţi introdus aceeaşi parolă în ambele câmpuri documentul va fi salvat 
protejat de parolă. Daca parolele nu se potrivesc veţi fi întrebat din nou.

Notă Parolele trebuie să conţina minim 5 caractere. Până nu introduceţi cele 5 caractere 
butonul OK nu va fi disponibil.

Salvarea automat  a unui documentă

Puteţi alege să salvaţi fişierele în mod automat de către OpenOffice.org. Salvarea automată, ca 
şi cea manuală, va suprascrie salvarea precedentă. Pentru a activa această opţiune:

1) Alegeţi Unelte > Opţiuni > Încarcă/Salvează > General (Tools > Options > 
Load/Save > General). (Vedeţi Imaginea 8.)

2) Bifaţi Salvează informaţia de recuperare la fiecare (Save AutoRecovery 
information every), şi stabiliţi intervalul de timp.

Writer poate salva în aceste formate de fişier
În plus faţă de formatele OpenDocument (.odt şi .ott), Writer 2.x poate salva în aceste formate:

• OpenOffice.org 1.x Text Document(.sxw)
• OpenOffice.org 1.x Text Document Template (.stw)
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• Microsoft Word 6.0, 95 şi 97/2000/XP (.doc)
• Microsoft Word 2003 XML (.xml)
• Rich Text Format (.rtf)
• StarWriter 3.0, 4.0 şi 5.0 (.sdw)
• StarWriter 3.0, 4.0 şi 5.0 Template (.vor)
• Text (.txt)
• Text Encoded (.txt)
• HTML Document (OpenOffice.org Writer) (.html şi .htm)
• DocBook (.xml)
• AportisDoc (Palm) (.pdb)
• Pocket Word (.psw)

Notă Formatul .rtf este folosit în mod obişnuit pentru transferul documentelor text între 
aplicaţii dar se poate întâmpla să fie pierdute elemente de formatare sau imagini. În 
aceste cazuri va trebui să folosiţi alte formate.

Calc poate salva în aceste formate de fişier
În plus faţă de formatele OpenDocument (.ods şi .ots), Calc 2.x poate salva în aceste formate:

• OpenOffice.org 1.x Spreadsheet (.sxc)
• OpenOffice.org 1.x Spreadsheet Template (.stc)
• Microsoft Excel 97/2000/XP (.xls şi .xlw)
• Microsoft Excel 97/2000/XP Template (.xlt)
• Microsoft Excel 5.0 and 95 (.xls şi .xlw)
• Microsoft Excel 2003 XML (.xml)
• Data Interchange Format (.dif)
• dBase (.dbf)
• SYLK (.slk)
• Text CSV (.csv şi .txt)
• StarCalc 3.0, 4.0 şi 5.0 formats (.sdc şi .vor)
• HTML Document (OpenOffice.org Calc) (.html şi .htm)
• Pocket Excel (.pxl)

Notă Este necesar să aveţi instalat Java Runtime Environment pentru a folosi filtrele pentru 
dispozitivele mobile ce folosesc AportisDoc (Palm), Pocket Word şi Pocket Excel.

Impress poate salva în aceste formate de fişier
În plus faţă de formatele OpenDocument (.odp, .otp, and .odg), Impress 2.x poate salva în 
aceste formate de fişier:
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• OpenOffice.org 1.x Presentation (.sxi)
• OpenOffice.org 1.x Presentation Template (.sti)
• Microsoft PowerPoint 97/2000/XP (.ppt şi .pps)
• Microsoft PowerPoint 97/2000/XP Template (.pot)
• StarDraw, StarImpress (.sda, .sdd şi .vor)

Impress poate de asemenea exporta fişiere MacroMedia Flash (.swf) sau în orice format 
cunoscut de componenta Draw.

Draw poate salva în aceste formate de fişier
Draw poate salva numai în formatele OpenDocument Drawing (.odg şi .otg), formatele folosite 
de OpenOffice.org 1.x (.sxd şi .std) şi formatele folosite de StarDraw (.sda, .sdd şi .vor).

Totuşi, Draw poate exporta în BMP, EMF, EPS, GIF, JPEG, MET, PBM, PCT, PGM, PNG, 
PPM, RAS, SVG, SVM, TIFF, WMF şi XPM.

Writer/Web poate salva în aceste formate
Document HTML (.html şi .htm)
OpenOffice.org 1.0 HTML Template (.stw)
OpenOffice.org 2.x HTML Template (.oth)
StarWriter/Web 4.0 şi 5.0 (.vor)
Text (OpenOffice.org Writer/Web) (.txt)
Text Encoded (OpenOffice.org Writer/Web) (.txt)

Exportul fişierelor

Export în XHTML, BibTeX, LaTeX şi Flash
OpenOffice.org poate exporta fişiere în formatul XHTML.

În plus, OOo Writer poate exporta în BibTeX (.bib) şi LaTeX 2e (.tex). OOo Draw şi OOo 
Impress pot exporta în Macromedia Flash (.swf).

Pentru a exporta într-unul din aceste formate, alegeţi Fişier > Export (File > Export). În 
dialogul Export selectaţi formatul dorit din lista Formatul fişierului (File format).

Export în PDF
Fiecare componentă OpenOffice.org  are abilitatea de a exporta direct în PDF. Acesta este un 
standard în domeniul calculatoarelor, fiind ideal pentru a trimite fişiere către cineva care doar 
le citeşte, putând fi vizualizate cu Acrobat Reader sau alte vizualizatoare de PDF.
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Puteţi exporta direct în PDF folosind butonul din bara uneltelor  sau alegând Fişier > 
Exportă ca PDF (File > Export as PDF). 

Dacă veţi folosi Fişier > Exportă ca PDF, vi se va cere să introduceţi numele fişierului PDF, 
iar apoi se va deschide dialogul Opţiuni PDF (PDF Options) din Imaginea 9.

Notă Dacă folosiţi butonul Exportă direct ca PDF (Export Directly as PDF), vi se va 
cere să alegeţi numele fişierului dar nu veţi avea posibilitatea de a stabili ce pagini, 
cum să fie comprimate imaginile sau alte opţiuni privind exportul.

Op iuni PDFţ

Dialogul Opţiuni PDF (PDF Options) are patru categorii (General, Aspect iniţial - Initial View, 
Interfaţa utilizator - User Interface, Securitate - Security). Stabiliţi parametrii doriţi, apoi 
apăsaţi Export.

Categoria General din dialogul Op iuni PDFţ

La categoria General (Imaginea 9), puteţi să alegeţi ce pagini să fie exportate în PDF, tipul de 
comprimare ce va fi folosit pentru imagini (acesta afectează calitatea imaginilor din PDF), 
precum şi alte opţiuni.
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Imaginea 9: Categoria General din dialogul Opţiuni PDF.

Sec iunea Domeniu (Range)ţ

• Tot (All): Exportă întregul document.

• Pagini (Pages): Pentru a exporta pagini consecutive, folosiţi notaţia de forma 3-6 
(paginile de la 3 la 6). Pentru a exporta pagini individuale, folosiţi notaţia 7;9;11 
(paginile 7, 9 şi 11).  Puteţi să combinaţi cele două notaţii, ca de exemplu 3-6;8;10;12.

• Selecţie (Selection): Exportă material care este selectat.

Sec iunea Imagini (Images)ţ

• Comprimare fără pierderi de calitate (Lossless compression):  Imaginile sunt stocate 
fără nici o pierdere de calitate. Vor rezulta de obicei fişiere mari dacă sunt conţinute 
fotografii, astfel încât este recomandat doar pentru celelalte tipuri de imagini.

• Comprimare JPEG (JPEG compression): Permite mai multe niveluri de calitate. 
Nivelul de 90% de obicei este în regulă cu fotografiile, mărimea fişierului fiind mică iar 
pierderea de calitate imperceptibilă.

• Micşorează rezoluţia imaginii (Reduce image resolution): Un DPI (dots per inch, 
numărul de puncte pe un ţol) scăzut înseamnă o calitate mai slabă a imaginilor.

Notă Imaginile EPS ce au încorporate previzualizări sunt exportate numai ca previzualizări, 
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iar cele fără previzualizări sunt exportate ca locuri vide.

Sec iunea Generalţ

• Etichete PDF (Tagged PDF): Include etichete speciale între etichetele obişnuite pentru 
PDF, mărimea fişierului crescând astfel în mod direct şi, evetual, semnificativ. Aceste 
etichete pot fi cuprinsul, hiperlegăturile şi controale.

• Export notiţe (Export notes): Exportă notiţele (notele de subsol, comentariile) din 
Writer şi din Calc ca notiţe PDF. S-ar putea să nu fie ceea ce doriţi!

• Exportă semne de carte (Export bookmarks): Exportă titlurile ca semne de carte (un 
cuprins ce poate fi afişat de unele vizualizatoare de fişiere PDF, inclusiv de Adobe 
Reader).

• Creare de formulare PDF - Mod de trimitere (Create PDF form - Submit format): 
Alegeţi modalitatea de trimitere a câmpurilor din formularul PDF. Această opţiune 
modifică setarea URL a câmpului aşa cum a fost stabilită în document. Este doar o 
opţiune validă pentru întreg documentul: PDF (trimite întregul document), FDF (trimite 
conţinutul câmpurilor), HTML şi XML. Cel mai probabil veţi alege modalitatea PDF.

• Export pagini goale inserate automat (Export automatically inserted blank pages): 
Dacă veţi bifa această opţiune paginile goale inserate automat vor fi exportate în fiţierul 
PDF. Este bine de folosit dacă veţi tipări documentul faţă-verso. De exemplu, cărţile de 
obicei au capitolele începând cu paginile impare. În acest caz, dacă precedentul capitol 
se termină tot pe o pagină impară, OOo va insera automat o pagină goală între cele 
două. Această opţiune controlează exportul acestor pagini albe.

Categoria Aspect ini ial (Initial View) a dialogului Op iuni PDFţ ţ

La categoria Aspect iniţial (Initial View) (vezi Imaginea 10) puteţi alege cum va arăta fişierul 
PDF la deschiderea într-un vizualizator PDF. Opţiunile ar trebui să fie destul de explicite.

Categoria Interfa a utilizator (User Interface) a dialogului Op iuni PDFţ ţ

La categoria Interfaţa utilizator (User Interface) (vezi Imaginea 11) puteţi selecta diverse 
opţiuni care vă permit să controlaţi afişarea fişierului PDF în vizualizator. Unele dintre acestea 
sunt realmente folositoare atunci când creaţi un PDF ce va fi utilizat ca prezentare sau pe un 
info-chioşc.

Sec iunea Op iuni fereastr  (Window options)ţ ţ ă

• Redimensionează fereastra pe măsura primei pagini (Resize window to initial 
page). Vizualizatorul PDF va redimensiona fereastra astfel încât să încadreze prima 
pagină din documentul PDF.

• Centrează fereastra pe ecran (Center window on screen). Fereastra vizualizatorului 
PDF va fi centrată pe mijlocul ecranului monitorului.

• Se va deschide pe tot ecranul (Open in full screen mode). Vizualizatorul PDF va avea 
o fereastră pe tot ecranul în loc de una obişnuită, mai mică.

• Afişează titlul documentului (Display document title). Vizualizatorul PDF va afişa 
titlul documentului în bara titlului.
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Imaginea 10: Categoria Aspect iniţial (Initial View) a dialogului Opţiuni PDF

Imaginea 11: Categoria Interfaţa utilizator (User Interface) a dialogului Opţiuni PDF.

Sec iunea Op iuni interfa  utilizator (User interface options)ţ ţ ţă

• Ascunde bara meniului (Hide menubar). Vizualizatorul PDF va ascunde bara 
meniului.

• Ascunde bara uneltelor (Hide toolbar). Vizualizatorul PDF va ascunde bara uneltelor.
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• Ascunde controalele ferestrei (Hide window controls). Vizualizatorul PDF va 
ascunde celelalte elemente de control din fereastră.

Sec iunea Efecte intermediare (Transitions)ţ

Transpune efectele intermediare ce însoţesc trecerea de la un cadru la altul definite în Impress 
în efectele corespondente PDF.

Sec iunea Semne de carte (Bookmarks)ţ

Selectaţi tipurile de titluri care vor fi folosite ca semne de carte, dacă "Exportă semne de carte" 
(“Export bookmarks”) este selectat  la categoria General. Acestea sunt selectate ca toate 
stilurile intitulate "Heading", respectiv ca stilurile "Heading" numerotate de la 1 la n, unde n 
este selectat în câmpul alăturat.
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Categoria Securitate (Security) a dialogului Op iuni PDFţ

Începând cu versiunea OOo 2.0.4, exportul în format PDF include opţiuni pentru criptarea 
documentului PDF, astfel încât să nu poată fi deschis fără a furniza o parolă, şi a folosi unele 
facilităţi privind controlul drepturilor utilizatorului (digital rights management - DRM).

Imaginea 12: Categoria Securitate (Security) a dialogului Opţiuni PDF.

• Dacă va fi stabilită o parolă pentru citire (open password), documentul PDF poate fi 
deschis numai dacă este furnizată parola respectivă. După aceea, nu sunt nici un fel de 
restricţii asupra drepturilor utilizatorului (adică a ceea ce poate face utilizatorul cu 
respectivul document).

• Dacă va fi stabilită o parolă pentru permisiuni (permissions password) documentul PDF 
poate fi deschide către oricine, dar modul de utilizare a acestuia poate fi restricţionat. 
Vedeţi Imaginea 12.

• Dacă vor fi stabilite ambele tipuri de parole documentul PDF va putea fi deschis numai 
cu parola respectivă, iar permisiunile de utilizare vor putea fi restricţionate.
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Notă Dacă opţiunile privind permisiunile vor fi impuse sau nu este la latitudinea 
vizualizatorului documentului PDF folosit de utilizator.

Imaginea 7 înfăţişează dialogul pentru introducerea parolei de citire, care va apare atunci când 
apăsaţi butonul Stabileşte parola de citire (Set open password) din categoria Securitate a 
dialogului Opţiuni PDF.

După ce veţi stabili o parolă pentru permisiuni vor deveni selectabile celelale opţiuni din 
categoria Securitate, ca în Imaginea 12. Acestea se referă la Imprimare (Printing), cu 
opţiunile Interzis (Not permitted), Calitate scăzută (Low resolution), Aşa cum este (High 
resolution); la Modificări (Changes), cu opţiunile Interzis (Not permitted), Inserarea, 
ştergerea şi rotirea paginilor (Inserting, deleting, and rotating pages), şi cu bifele Permite 
copierea conţinutului (Enable copying of content) şi Permite citirea textului de cititoarele 
de ecran (Enable text access for accessibility tools).

Imaginea 13: Stabilirea unei parole pentru criptarea documentului 
PDF.

Ştergerea şi redenumirea fişierelor

Puteţi redenumi sau şterge fişiere din cadrul dialogurilor OpenOffice.org. Nu este însă posibil 
să copiaţi sau să mutaţi fişiere în cadrul dialogurilor.

Redenumirea unui fişier
Pentru a redenumi un fişier folosind OpenOffice.org:

1) Alegeţi Fişier > Deschide (File > Open) şi răsfoiţi până la fişierul dorit. 

2) Daţi clic dreapta pe numele fişierului şi alegeţi Redenumeşte (Rename). Va fi selectat 
numele fişierului.

3) Tastaţi pentru a înlocui numele selectat sau folosiţi tastele săgeţi pentru a muta cursorul 
şi a modifica numele existent.
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Ştergerea unui fişier
Pentru a şterge un fişier folosind acest dialog: 

1) Daţi clic-dreapta pe numele fişierului pentru a afişa meniul contextual. 

2) Apăsaţi Şterge (Delete) şi răspundeţi la dialogul ce apare, confirmând ştergerea.

Notă În loc de clic-dreapta şi să selctaţi Şterge (Delete) puteţi apăsa direct tasta Delete.

Asocierile de fişiere

Asocierile de fişiere sunt folosite pentru a putea deschide anumite fişiere cu OpenOffice.org în 
mod automat din exteriorul acestuia. Aveţi opţiunea de a asocia fişierele Microsoft Office cu 
OpenOffice. Dacă veţi face aceasta, fişierele vor rămâne tot de tipul Microsoft Office, dar 
pictograma asociată acestora se va modifica în cea OOo, iar dublul-clic pe aceasta va deschide 
fişierul în OOo. (Puteţi să îl deschideţi în continuare în Microsoft Office lansând 
dumneavoastră MS Office şi deschizând explicit fişierul din meniul acestuia.)

Când instalaţi OpenOffice.org veţi fi întrebat despre asocierea fişierelor, după cum vedeţi în 
Imaginea 18. Dacă doriţi să continuaţi să deschideţi fişierele Microsoft Office cu această suită, 
atunci nu bifaţi aceste căsuţe. (Puteţi să deschideţi fişierele MS Office în OOo pornind separat 
OOo şi apoi selectând Fişier > Deschide (File > Open).) 
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Puteţi modifica, ulterior instalării, opţiunea de a (nu) deschide fişierele Microsoft Office cu 
OpenOffice.org astfel:

1) În Windows, mergeţi la Start > Settings > Add or Remove Programs. Derulaţi lista 
până ajungeţi la OpenOffice.org 2.0 şi apăsaţi pe acesta o singură dată. Ar trebui să 
devină vizibile două butoane: Change şi Remove, după cum se vede în Imaginea 15. 
Acestea s-ar putea să difere pe alte versiuni de Windows.

2) Apăsaţi Change pentru a lansa din nou Vrăjitorul de instalare (Installation Wizard).

3) Parcurgeţi paginile Vrăjitorului până când veţi ajunge din nou la pagina din Imaginea
18. Stabiliţi asocierea tipurilor de fişiere după cum doriţi (bifaţi căsuţele tipurilor de 
fişiere pe care doriţi să le deschideţi cu OOo) şi apăsaţi OK.

Imaginea 15. Modificarea instalării OOo pe Windows XP.
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Crearea fişierelor noi

Sunt mai multe moduri pentru a crea un fişier nou:

• Folosiţi Fişier > Nou (File > New) şi alegeţi tipul noului document.

• Folosiţi săgeţica din cadrul butonului Nou (New) de pe principala bară de unelte. Va fi 
afişat un meniu cu tipurile de fişiere (Imaginea 14); selectaţi tipul documentului pe care 
doriţi să îl creaţi.

• Pe Windows, folosiţi programul “Quick start”. De exemplu, versiunea de Microsoft 

Windows a OpenOffice.org are o pictogramă Quickstart  pe care o instalează în tava 
de sistem. Vedeţi Capitolul 2 (Lansarea OpenOffice.org) pentru detalii.

• Apăsaţi tastele Control+N.

• Folosiţi Fişier > Vrăjitori (File > Wizards) pentru unele tipuri de documente. (Vezi 
Imaginea 17.)
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Imaginea 17. Crearea unui fişier folosind un Vrăjitor (Wizard).

Utilizarea dialogurilor Deschide (Open) şi 
Salveaz  ca (Save As)ă

Dacă folosiţi Microsoft Windows puteţi să alegeţi între a folosi dialogurile de deschidere şi 
salvare fişiere ale OpenOffice.org  sau cele standard ale Windows. Puteţi schimba tipul de 
dialog folosit de OpenOffice.org astfel:

1) Alegeţi Unelte > Opţiuni > OpenOffice.org > General (Tools > Options > 
OpenOffice.org > General).

2) Bifaţi căsuţa Utilizează dialogurile OpenOffice.org (Use OpenOffice.org dialogs).

Această secţiune documentează dialogurile Deschide şi Salvează ca oferite de 
OpenOffice.org. Vedeţi imaginile  şi 19 pentru exemple ale acestor dialoguri.

Cele trei butoane din partea de sus a dialogului OOo Deschide () au următoarele semnificaţii 
(de la stânga la dreapta):

• În sus un nivel (Up one level) schimbă în directorul părinte al directorului curent. Cu 
alte cuvinte, urcă un nivel, spre rădăcină, în arborele directoarelor. Puteţi ţine apăsat 
butonul pentru a selecta direct directorul destinaţie, fără a mai trece prin nivelurile 
intermediare.

• Creează director nou (Create New Directory).

• Directorul obişnuit (Default Directory).
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Pentru documentele OpenOffice.org care au fost salvate cu mai multe versiuni folosiţi lista 
derulantă pentru selectarea versiunii. Aceasta va fi deschisă în numai pentru citire (read-only).

Notă Pentru documentele Microsoft Office poate fi deschisă numai versiunea curentă.

Imaginea 18. Dialogul OOo Deschide, cu lista derulantă a tipurile de fişiere ce pot fi  
deschise.

Folosiţi câmpul Tip fişier (Files of type) pentru a afişa în fereastră numai tipul respectiv de 
fişier, respectiv pentru a salva documentul în formatul respectiv.

Bifa Numai citire (Read-only) va determina OOo să deschidă documentul numai pentru citire 
(documentul va putea fi doar vizualizat sau imprimat). Pe cale de consecinţă, cea mai mare 
parte din barele de unelte vor dispărea, iar marea majoritate a opţiunilor din meniuri nu vor fi 
disponibile. Va fi afişat un buton, Editare fişier (Edit File) pe bara uneltelor Funcţii pentru a 
schimba modul de lucru cu fişierul din citire în editare.

Este posibil să deschideţi fişiere din internet folosind adresele specifice (URL).
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Utilizarea dialogurilor Deschide (Open) şi Salveaz  ca (Save As)ă

Imaginea 19. Dialogul OOo Salvează ca, cu lista derulantă a tipurile de fişiere ce pot fi 
salvate.

Semnarea digital  a documenteloră

Pentru a semna digital un document veţi avea nevoie de o cheie personală digitală numită 
certificat. O cheie personală este păstrată pe calculatorul dumneavoastră ca o combinaţie 
formată dintr-o cheie privată, ce va trebui ţinută secretă, şi una publică, care va fi adăugată 
documentelor pe care le semnaţi. Puteţi obţine un certificat de la o autoritate de certificare, ce 
poate să fie o companie privată sau o autoritate guvernamentală.

Când veţi aplica semnătura digitală unui document se va genera unl fel de sumă de control pe 
baza conţinutului documentului plus cheia dumneavoastră personală. Această sumă de control, 
ca şi cheia publică vor fi incluse în document.

Când, ulterior, cineva va deschide documentul pe calculatorul lor (această facilitate este 
suportată de versiunile recente ale OpenOffice.org) programul va verifica suma de control şi o 
va compara cu cea stocată în fişier. Dacă acestea corespund vă va fi semnalat că documentul 
este original. În plus, programul vă poate arăta informaţiile din cheia publică din semnătură, iar 
dumneavoastră puteţi compara aceste informaţii cu cele din cheia publică aşa cum apar pe situl 
de internet al autorităţii de certificare.

Dacă ulterior altcineva efectuează modificări asupra documentului, acestea vor distruge 
semnătura digitală.
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Semnarea digital  a documenteloră

Pe sistemele de operare Windows se vor folosi facilităţile de validare a semnăturii oferite de 
acestea. Pe sistemele Solaris şi Linux vor fi folosite fişierele ce sunt instalate cu Thunderbird, 
Mozilla sau Firefox. Pentru o descriere mai detaliată despre cum să obţineţi şi să folosiţi 
certificatele şi să validaţi semnăturile citiţi “Using Digital Signatures” (Folosirea semnăturilor 
digitale) în paginile de ajutor ale OOo.

Pentru a semna un document:

1) Alegeţi Fişier > Semnături digitale (File > Digital Signatures).

2) Dacă documentul nu este salvat cu toate modificările va apare un mesaj în acest sens. 
Apăsaţi Da (Yes) pentru a salva fişierul.

3) După salvare veţi vedea dialogul Semnături digitale (Digital Signatures). Apăsaţi 
Adaugă (Add) pentru a adăuga o cheie publică în document.

4) În dialogul Selectare certificat (Select Certificate) selectaţi certificatul dorit şi apăsaţi 
OK.

5) Va fi afişat din nou dialogul Semnături digitale, unde veţi putea adăuga şi alte certificate 
dacă doriţi. Apăsaţi OK pentru a adăuga cheia publică la fişierul salvat.

Un document semnat va prezenta o pictogramă, , în bara de stare. Puteţi să daţi dublu-clic 
pe aceasta pentru a vedea certificatul.
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  Meniuri şi bare de unelte

Utilizarea şi personalizarea opţiunilor comune 
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Meniuri

Meniuri

Bara meniului (Imaginea 20) este situată în partea de sus a ecranului, chiar sub bara titlului. 
Opţiunile din meniul principal sunt Fişier (File), Editare (Edit), Vizualizare (View), 
Inserare (Insert), Formatare (Format), Tabel (Table), Unelte (Tools), Fereastră (Window) 
şi Ajutor (Help). Când selectaţi una dintre acestea este afişat un submeniu pentru celelalte 
opţiuni.

Imaginea 20. Bara meniului

• Fişier (File) conţine comenzile care se aplică întregului document, cum sunt Deschide 
(Open), Salvează (Save) şi Exportă ca PDF (Export as PDF).

• Editare (Edit) conţine comenzi pentru editarea documentului cum sunt Reface (Undo) şi 
Găseşte şi înlocuieşte (Find & Replace).

• Vizualizare (View) conţine comenzi pentru controlul afişării documentului cum sunt 
Lupă (Zoom) şi  Aspect Web (Web Layout).

• Inserare (Insert) conţine comenzi pentru inserarea de elemente în document cum sunt 
Antet (Header), Subsol (Footer) şi Imagine (Picture).

• Formatare (Format) conţine comenzi, cum sunt Stiluri şi formatare (Styles and 
Formatting) şi AutoFormatare (AutoFormatare), pentru definirea aspectului 
documentului dumneavoastră.

• Tabel (Table) arată toate comenzile necesare pentru a insera şi a edita un tabel în document.

• Unelte (Tools) conţine funcţii cum sunt Verifică ortografia (Spellcheck), Personalizare 
(Customize) şi Opţiuni (Options).

• Fereastră (Window) conţine comenzi în legătură cu afişarea ferestrelor.

• Ajutor (Help) conţine legături către programul de asistenţă, unealta de ajutor “Ce este 
aceasta?” (What’s This) şi informaţii despre versiunea de OpenOffice.org pe care o aveţi 
instalată. 

Personalizarea fontului pentru meniuri
Dacă doriţi să schimbaţi fontul folosit de meniuri, care este instalat o dată cu OOo, cu fontul 
sistemului de operare, procedaţi astfel:

1) Alegeţi Unelte > Opţiuni > OpenOffice.org > Vizualizare (Tools > Options > 
OpenOffice.org > View).

2) Bifaţi Utilizează fontul de sistem pentru interfaţa utilizator (Use system font for 
user interface).

3) Apăsaţi OK.
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Meniuri

Personalizarea con inutului meniurilorţ

Este posibil să personalizaţi meniurile în OpenOffice.org. Procedaţi astfel:

1) Alegeţi Unelte > Personalizare (Tools > Customize).

2) La dialogul Personalizare (Customize) alegeţi categoria Meniuri (Menus)  (Imaginea
21). 

3) Din lista derulantă Salvează în (Save In) puteţi selecta ce meniuri personalizaţi: pentru o 
aplicaţie (de exemplu, Writer) sau numai pentru un anumit document deschis în acest 
moment.

4) Din lista derulantă OpenOffice.org <nume program (exemplu: Writer)>  Menus, 
selectaţi meniul pe care doriţi să îl personalizaţi în lista derulantă Meniu (Menu).

5) Puteţi personaliza fiecare meniu apăsând butoanele Meniu (Menu) sau Modifică 
(Modify).

6) Puteţi adăuga noi comenzi într-un meniu apăsând butonul Adaugă (Add).

7) Puteţi crea un nou meniu apăsând pe butonul Nou (New).

Imaginea 21. Categoria Meniuri (Menus) din dialogul Personalizare (Customize).
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Bare de unelte

Bare de unelte

Bara de unelte din partea de sus (este poziţia obişnuită) este denumită bara de unelte standard 
(Standard Bar). Bara de unelte standard este similară în toate aplicaţiile OpenOffice.org.

Cea de a doua bară de unelte de sus (în poziţia obişnuită) este bara de unelte pentru formatare 
(Formatting toolbar). Aceasta este o bară de unelte contextuală (adică modificată în funcţie de 
contextul cursorului din document) care afişează butoane grafice în funcţie de poziţia 
cursorului sau selecţia curentă. De exemplu, când cursorul este deasupra unei imagini, aceasta 
afişează uneltele pentru editarea imaginilor, iar dacă este deasupra textului uneltele sunt pentru 
formatarea textului.

Barele de unelte flotante
Writer include câteva bare de unelte suplimentare, contextuale, care în mod obişnuit apar ca 
bare de unelte flotante ca urmare a elementului din document de sub cursor sau a selecţiei 
efectuate. De exemplu, atunci când cursorul intră într-un tabel, apare o bară flotantă numită 
Tabel (Table), iar atunci când cursorul este într-o listă numerotată sau cu buline va apare 
panoul Buline şi numerotare (Bullets and Numbering). Puteţi încorpora aceste bare de unelte pe 
marginile ferestrei, după preferinţe (vedeţi “Mutarea barelor de unelte” la pagina 53).

Butoane ap sate lung şi ă bare de unelte detaşabile
Butoanele cu un mic triunghi negru vor afişa 
submeniuri, bare de unelte detaşabile şi alte elemente 
selectabile cu un clic lung.

Imaginea 22 înfăţişează submeniul Lipire (Paste).

Imaginea 23 înfăţişează o bară detaşabilă din bara de 
unelte Desenare (Drawing).

Barele detaşabile pot fi flotante sau încorporate pe 
lângă o margine a ferestrei ori într-o zonă cu alte bare 
de unelte. Pentru a muta o bară detaşabilă trebuie să o trageţi de titlu. Vedeţi  “Mutarea barelor
de unelte” la pagina 53.
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Bare de unelte

Imaginea 23: Example of a tear-off toolbar

Afişarea şi ascunderea barelor de unelte
Pentru a afişa sau a ascunde barele de unelte alegeţi Vizualizare > Bare de unelte (View > 
Toolbars), apoi daţi clic pe numele barei de unelte din listă. O bară de unelte activă are un mic 
semn lângă numele său. Barele detaşabile nu sunt afişate în această listă.

Mutarea barelor de unelte
Pentru a muta o bară de unelte încorporată poziţionaţi cursorul mausului desupra mânerului 
barei de unelte, ţineţi apăsat butonul stâng al mausului, trageţi bara în noua poziţie şi apoi 
eliberaţi butonul mausului. Vedeţi Imaginea 24.

Pentru a muta o bară de unelte flotantă, poziţionaţi cursorul deasupra mânerului panoului, ţineţi 
apăsat butonul stâng al mausului şi trageţi bara de unelte în noua poziţie. Vedeţi Imaginea 25.

Imaginea 24: Mutarea barei de unelte încorporate.

Imaginea 25: Mutarea unei bare de unelte flotante.
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Bare de unelte

Personalizarea unei bare de unelte
Sunt trei metode pentru a ajunge la dialogul de personalizare a unei bare de unelte:

• Pe bara de unelte, apăsaţi săgeata din capătul său şi alegeţi Personalizare bară de unelte 
(Customize Toolbar). 

• Alegeţi Vizualizare > Bare de unelte > Personalizare (View > Toolbars > Customize) 
din meniul principal.

• Alegeţi Unelte > Personalizare (Tools > Customize) din bara de meniu. La categoria Bare 
de unelte (Toolbars) (Imaginea 30), alegeţi barele de unelte pe care doriţi să le modificaţi 
şi apăsaţi pe butoanele Bară de unelte (Toolbar) sau Modifică (Modify).

Notă Nu există nici o unealtă OOo pentru a edita pictogramele. Pentru a folosi o 
pictogramă proprie, copiaţi-o în  {directorul de instalare}/share 
/config/symbol în format *.bmp. OOo caută noi pictograme în acest director în 
mod automat de fiecare dată când este deschis dialogul Butoane personalizate 
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Bare de unelte

(Customize Buttons). Pictogramele proprii trebuie să fie de 16 x 16 sau 26 x 26 pixeli 
şi nu pot conţine mai mult de 256 de culori.

Crearea unei noi bare de unelte
Pentru a crea o nouă bară de unelte:

1) Alegeţi Unelte > Personalizare > Bare de unelte (Tools > Customize > Toolbars) din 
meniul principal.

2) Apăsaţi Nou (New). Aceasta va crea o bară de unelte intitulată “New Toolbar1”.

3) Personalizaţi-o ca mai sus.

Utilizarea fereastrelor încorporabile/flotante şi 
a barelor de unelte

Barele de unelte şi unele fereastre, cum sunt Navigatorul şi fereastra Stiluri şi formatare, sunt 
încorporabile. Le puteţi muta, redimensiona sau ataşa la una din marginile ecranului.

Pentru a încorpora o fereastră procedaţi astfel:

• Apăsaţi pe bara de titlu a ferestrei flotante şi 
trageţi-o spre margine până când veţi observa 
conturul mai gros al unui dreptunghi în fereastra 
principală (vezi Imaginea 27), apoi eliberaţi 
fereastra. Această metodă depinde însă de 
setările managerului de ferestre al sistemului 
dumneavoastră, aşa că la dumneavoastră s-ar 
putea să nu funcţioneze.

• Ţineţi apăsată tasta Control şi daţi dublu-clic pe 
o zonă liberă a ferestrei flotante pentru a o 
încorpora în locul unde a fost ultima dată 
încorporată. În cazul în care nu funcţionează, 
încercaţi să daţi dublu-clic fără a mai apăsa tasta 
Control, cel mai bine pe bara de titlu.

Pentru a detaşa o fereastră ţineţi apăsată tasta Control şi 
daţi dublu-clic pe o zonă liberă a ferestrei încorporate.

Notă Fereastra Stiluri şi formatare poate fi 
încorporată şi detaşată folosind 
Control+dublu-clic pe zona gri de lângă 
pictogramele din partea de sus a acesteia.

Imaginea 27: Încorporarea unei 
ferestre.
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Utilizarea Navigatorului

Utilizarea Navigatorului
Navigatorul afişează toate obiectele conţinute în document. Este o cale foarte convenabilă de a 
inspecta conţinutul documentului şi de a regăsi elementele căutate. Butonul Navigator-ului este 
amplasat pe bara de unelte standard.

Navigatorul (Imaginea 28) afişează lista titlurilor, tabelelor, cadrelor de text, imaginilor, 
semnelor de carte şi celorlalte elemente. Apăsaţi pe semnul + de lângă fiecare listă pentru a-i 
vedea conţinutul.

Dacă doriţi să vedeţi conţinutul unei singure categorii, selectaţi categoria respectivă şi apăsaţi 
butonul Vizualizare conţinut (Content View). 

Imaginea 28. Navigatorul.

Notă Navigatorul arată uşor diferit când este folosit pe un document de tip master. Citiţi 
capitolul 13 (Lucrul cu documente master) din Ghidul Writer pentru mai multe 
detalii.

Navigatorul vă ajută să regăsiţi rapid obiecte. Dublu-clic pe un obiect în Navigator vă va duce 
direct la poziţia obiectului în document, după cum se vede în Imaginea 29.
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Utilizarea Navigatorului

Imaginea 29. Utilizarea Navigatorului pentru a sări rapid la un titlu în 
Writer.

Aranjarea capitolelor folosind Navigatorul
Puteţi aranja capitolele şi să mutaţi titlurile într-un document Writer utilizând Navigatorul.

1) Apăsaţi pictograma Vizualizare conţinut (Content View).

2) Apăsaţi pe titlul dorit.

3) Trageţi titlul la noua poziţie direct în Navigator, sau apăsaţi pe titlu în lista din 
Navigator, apoi apăsaţi Promovează capitolul (Promote Chapter) sau Retrogradează 
capitolul (Demote Chapter).

Imaginea 30: Navigatorul.
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Op iunile care afecteaz  toat  suita OOoţ ă ă

Op iunile care afecteaz  toat  suita OOoţ ă ă

Această secţiune se referă la setările care afectează toate componentele OOo. Dacă doriţi 
informaţii suplimentare faţă de cele prezentzte aici, puteţi consulta ajutorul integrat în 
program.

4) Apăsaţi Unelte > Opţiuni (Tools > Options). Lista din partea stângă variază în funcţie 
de componenta OOo din care aţi apelat această comandă. Ilustraţiile din acest capitol 
înfăţişează lista aşa cum apare atunci când nu era deschis nici un document. (De 
exemplu, dacă ar fi fost deschis un document Writer, ar fi apărut opţiuni suplimentare 
legate de OpenOffice.org Writer şi OpenOffice.org Writer/Web.)

5) Apăsaţi pe semnul + de la stânga secţiunii OpenOffice.org, aflată în partea stângă. O să 
apară o listă de subsecţiuni.

Notă Butonul Înapoi (Back) are acelaşi efect pe toate paginile dialogului Opţiuni 
(Options). El resetează opţiunile la valorile din momentul în care aţi pornit 
OpenOffice.org.

Op iunile despre datele utilizatorului (User Data)ţ

Deoarece facilităţile OOo cu privire la revizuirile documentelor semnează automat 
modificările şi comentariile pe care le efectuaţi cu numele sau iniţialele stabilite aici, este de 
dorit ca să le introduceţi. Pentru aceasta:

1) În dialogul Opţiuni (Options), apăsaţi OpenOffice.org > Date utilizator (User Data). 

2) Completaţi formularul de pe pagina OpenOffice.org Date utilizator (OpenOffice.org 
User Data) (Imaginea 31), sau ştergeţi informaţiile greşite.
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Op iunile care afecteaz  toat  suita OOoţ ă ă

Imaginea 31. Completarea datelor utilizatorului.

Op iunile ţ generale
1) În dialogul Opţiuni (Options), apăsaţi OpenOffice.org > General. 

2) Pe pagina OpenOffice.org – General (Imaginea 32) sunt următoarele opţiuni descrise 
mai jos:

Imaginea 32. Stabilirea opţiunilor generale pentru OpenOffice.org .
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Op iunile care afecteaz  toat  suita OOoţ ă ă

Ajutor - Ponturi (Help - Tips)

Când ponturile (Help Tips) sunt activate, vor apare unul sau două cuvinte de ajutor când ţineţi 
mausul deasupra unei pictograme sau unui câmp din fereastra principală OOo. Această opţiune 
afectează şi afişarea notiţelor: când atât Ponturile (Help Tips), cât şi Ponturile extinse 
(Extended Tips) sunt dezactivate, nu va mai fi afişat textul notiţelor atunci când cursorul 
mausului zăboveşte asupra lor.

Ajutor - Ponturi extinse (Help - Extended tips)

Când Ponturile extinse (Extended tips) sunt activate, o scurtă descriere a funcţiei îndeplinite de 
o anumită pictogramă sau comandă ori de un câmp din dialoguri va fi afişată când veţi ţine 
cursorul deasupra lor.

Agentul de ajutor (Help Agent)

Pentru a închide Agentul de ajutor  (similar cu Microsoft’s Office Assistant), debifaţi această 
căsuţă. Pentru a reveni la comportamentul obişnuit, apăsaţi Resetează agentul de ajutor 
(Reset Help Agent). 

Formatarea paginilor de ajutor (Help formatting)

Contrast ridicat (high contrast) este o facilitate a sistemului de operare ce modifică culorile 
folosite astfel încât ecranul să fie mai uşor de citit. Pentru a afişa paginile de Ajutor în acest 
mod (aceasta dacă sistemul dumneavoastră de operare suportă), alegeţi din listă unul din 
stilurile de contrast ridicat.

Dialogurile Deschide/Salveaz  (ă Open/Save dialogs)

Dacă doriţi să folosiţi dialogurile de deschidere şi salvare fişier oferite de sistemul de operare, 
în loc de cele specifice OOo, debifaţi căsuţa Utilizează dialogurile OpenOffice.org (Use 
OpenOffice.org dialogs). Când aceasta căsuţă este selectată vor fi folosite casetele de dialog 
proprii OpenOffice.org. (Citiţi capitolul 3 “Gestiunea fişierelor în OpenOffice.org” pentru mai 
multe informaţii depre dialogurile proprii OOo pentru deschidere şi salvare de fişiere).

Starea documentului (Document status)

Puteţi să alegeţi dacă starea documentului este marcată ca modificat atunci când îl imprimaţi. 
Dacă această opţiune este selectată, atunci data viitoare când îl veţi închide după ce l-aţi 
imprimat se vor salva în document, la caracteristici, data imprimării, şi veţi fi solicitat să 
salvaţi din nou fişierul, chiar dacă nu aţi modificat defel conţinutul propriu-zis.

Anul (dou  cifre) - ă Year (two digits)

Specificaţi cum să fie interpretaţi anii de 2 cifre. De exemplu, dacă anul de 2 cifre este stabilit 
ca fiind 1930, iar apoi introduceţi data de 01.01.30 sau ulterioară, data este interpretată ca 
01.01.1930 sau ulterior. A dată anterioară va fi interpretată ca fiind din secolul următor: 
01.01.20 este interpretat ca fiind 01.01.2020.

Op iunile privind memoria (ţ Memory)
1) În dialogul Opţiuni (Options), apăsaţi OpenOffice.org > Memorie (OpenOffice.org > 

Memory).

2) În dialogul OpenOffice.org – Memory (Imaginea 33):
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• Mai multă memorie poate face ca OpenOffice.org să funcţioneze mai rapid şi mai 
satisfăcător (de exemplu, mai multă memorie pentru salvarea modificărilor înseamnă 
că se pot reface mai multe modificări nedorite); reversul este că va fi mai uţină 
memorie disponibilă pentru alte aplicaţii, aceasta putând fi, la o adică, şi epuizată.

• Pentru a încărca Quickstarter (care apare ca o pictogramă în tava de sistem, numai pe 
Windows) la pornirea calculatorului, bifaţi căsuţa corespunzătoare din partea de jos a 
dialogului. Aceasta va determina OpenOffice.org să pornească mai repede, deoarece 
de fapt o parte din OOo va fi încărcată tot timpul în memorie; aceasta înseamnă însă 
că o parte din memorie va fi întotdeauna ocupată, chiar şi atunci când nu folosiţi 
programul. Această opţiune (numită "Activează Quickstarter din tava de sistem", sau 
“Enable systray quickstarter”) este dezactivată în unele distribuţii pentru Linux.

Imaginea 33. Alegerea opţiunilor privind memoria pentru componentele OpenOffice.org.

Op iunile de vizualizare (ţ View)
Opţiunile disponibile pentru vizualizare afectează cum arată şi se comportă ferestrele cu 
documente.

1) În dialogul Opţiuni (Options), apăsaţi OpenOffice.org > Vizualizare (OpenOffice.org 
> View).

2) Pe pagina OpenOffice.org – Vizualizare (View) (Imaginea 34), stabiliţi opţiunile care vi 
se potrivesc. Câteva dintre acestea sunt descrise mai jos.
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Imaginea 34. Alegerea opţiunilor de vizualizare pentru componentele OpenOffice.org.

Interfa a utilizator - Scalare (ţ User Interface – Scaling)

Dacă nu vă convine mărimea textului din fişierele de ajutor sau din meniurile OOo, o puteţi 
adapta specificând un factor pentru scalare. Ţineţi minte că o astfel de schimbare poate avea şi 
efecte neprevăzute, totul depinzând de fonturile care sunt instalate pe calculatorul 
dumneavoastră. Nu este afectată dimensiunea fontului din fişierele respective.

Interfa a utilizator - Dimensiunea şi stilul pictogramelor (User Interfaceţ  
– Icon size and style)

Prima căsuţă selectează dimensiunea pictogramelor de pe panourile cu unelte (mic - small; 
mare - large; automatic); opţiunea Automatic preia de fapt dimensiunea folosită în sistemul de 
operare. Cea de a doua căsuţă selectează motivul pictogramelor (tema); aici opţiunea 
Automatic înseamnă a se folosi un set de pictograme compatibil cu sistemul de operare: de 
exemplu, KDE sau Gnome pe Linux.

Interfa a utilizator - Utilizeaz  fontul de sistem pentru interfa aţ ă ţ  
utilizator (User Interface – Use system font for user interface)

Dacă preferaţi să folosiţi pentru interfaţa utilizator fontul de sistem (adică cel care este folosit 
de către sistemul de operare) în loc de fontul furnizat de OOo bifaţi această căsuţă.

Interfa a utilizator - Antialiere fonturi de ecran (User interface – ţ Screen 
font antialiasing)

(Opţiunea nu este disponibilă în Windows, astfel încât nu apare în Imaginea 34).) Bifaţi această 
opţiune pentru a rotunji aspectul textului pe ecran. Introduceţi şi dimensiunea minimă a 
fontului de la care se aplică antialierea, care constă în sugerarea liniilor curbe şi oblice ca fiind 
continue deşi acestea sunt formate din pixeli situaţi într-o matrice.
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Meniu - Pictograme în meniuri (Menu – icons in menus)

Bifaţi această opţiune dacă doriţi ca pictogramele alăturate cuvintelor să fie vizibile în meniuri.

Liste fonturi - Previzualizare fonturi (Font Lists - Show preview of 
fonts)

Când această opţiune este selectată, lista fonturilor arată ca în Imaginea 35, stânga, cu numele 
fonturilor afişate chiar cu fontul respectiv, ca un exemplu; când este însă dezactivată, lista 
fonturilor afişează numai numele fonturilor, nu şi aspectul lor (Imaginea 35, dreapta). Fonturile 
pe care le veţi vedea listate sunt cele pe care le aveţi instalate pe sistemul dumneavoastra.

Imaginea 35. (Stânga) Lista fonturilor cu previzualizare; (Dreapta) fără previzualizare.

Liste fonturi - Arat  ultimele fonturi utilizate (Font Lists - Show ă font 
history)

Când bifaţi această opţiune, ultimele 5 fonturi pe care le-aţi folosit sunt afişate la începutul 
listei fonturilor.

Vizualizare 3D (3D view)

Aceste opţiuni sunt utilizate de către Draw şi Impress. Pentru detalii consultaţi ajutorul online 
sau documentaţia specifică acestor componente.

Maus (Mouse)

Puteţi să folosiţi aceste opţiuni pentru a alege cum este poziţionat mausul în dialogurile noi 
deschise şi pentru a selecta funcţia atribuită butonului din mijloc.

Op iunile de imprimare (ţ Print)
Stabiliţi opţiunile de imprimare care se potrivesc imprimantei dumneavoastră şi modului în 
care o folosiţi. Puteţi să modificaţi aceste setări oricând, fie din acest dialog fie la momentul 
imprimării, din dialogul de Imprimare (Print), apăsând pe butonul Opţiuni (Options).

1) În dialogul Opţiuni (Options), apăsaţi OpenOffice.org > Imprimare (OpenOffice.org 
> Print).

2) În dialogul OpenOffice.org – Imprimare (Print) (Imaginea 36), priviţi la secţiunea 
Avertismente imprimantă (Printer warnings) din partea de jos.
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3) Aici puteţi alege să fiţi avertizat dacă dimensiunea foii de hârtie sau orientarea acesteia 
nu se potrivesc cu cele ale documentului. Selectarea acestor opţiuni poate fi foarte utilă 
în mod special dacă lucraţi cu documente create cu mărimi diferite de pagină, de 
exemplu de oameni din mai multe ţări, cu standarde diferite de pagină decât cele ale 
dumneavoastră.

PONT Dacă tipăriturile dumneavoastră nu sunt poziţionate corespunzător pe pagină, au 
marginile tăiate sau imprimanta refuză să imprime, atunci cauza probabilă este o 
incompatibilitate a dimensiunii paginii.

Imaginea 36. Selectarea opţiunilor generale de imprimare cu aplicabilitate asupra tuturor 
componentelor OOo.

Alegerea c ilor (ă Paths)
Puteţi modifica locul fişierelor asociate cu ori folosite de OpenOffice.org, adaptându-l 
necesităţilor dumneavoastră. Pe Windows, de exemplu, puteţi dori să păstraţi fişierele în altă 
parte decât în My Documents (Documentele mele).

1) În dialogul Opţiuni (Options), apăsaţi OpenOffice.org > Căi (OpenOffice.org > 
Paths).

2) Pentru a efectua modificări, selectaţi un element din lista prezentată în Imaginea 37 şi 
apăsaţi Editare (Edit). În dialogul Selectare căi (Select Paths) - nu este arătat aici, 
adăugaţi sau ştergeţi directoare după cum vă este necesar, şi apoi apăsaţi OK pentru a vă 
reîntoarce la dialogul Options. Observaţi că multe elemente au cel puţin 2 căi selectate: 
una către un director partajat (care poate să fie şi pe o reţea), iar alta către un director 
personal fiecărui utilizator, situat de obicei pe calculatorul personal.
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PONT Puteţi să folosiţi intrările din acest dialog pentru a compila o listă de fişiere, precum 
cele care conţin AutoText, şi pe care doriţi să le faceţi o copie de siguranţă sau să le 
copiaţi pe alt calculator.

Imaginea 37. Vizualizarea căilor pentru fişierele folosite de OpenOffice.org.
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Op iunile privind culorile (ţ Colors)
În dialogul OpenOffice.org - Culori (OpenOffice.org – Colors) din Imaginea 38 puteţi 
specifica culorile care vor fi utilizate în documentele OOo. Puteţi să selectaţi culoarea din 
tabelul de culori, să editaţi o culoare existentă sau să definiţi noi culori. Aceste culori vor fi 
disponibile în paletele de selectare de culori din OOo.

Imaginea 38. Definirea culorilor din paletele de culori din OOo.

Op iunile privind fonturile (ţ Fonts)
Puteţi să definiţi înlocuirile pentru orice fonturi care pot să apară în documentele cu care 
lucraţi. Astfel, dacă veţi primi de la cineva un document care specifică fonturi pe care nu le 
aveţi instalate, OpenOffice.org va substitui fonturi în locul celor pe care nu le aveţi. Aici puteţi 
alege un alt font de substituire decât cel ales automat.

1) În dialogul Opţiuni (Options), apăsaţi OpenOffice.org > Fonturi (OpenOffice.org > 
Fonts).

2) În dialogul OpenOffice.org – Fonturi (Imaginea 39):

• Bifaţi căsuţa Foloseşte tabelul de înlocuire (Apply Replacement Table).

• Selectaţi sau tastaţi numele fontului care va trebui înlocuit în câmpul Font. (Dacă 
acesta nu este instalat pe sistemul dumneavoastră, atunci nu va fi afişat în listă şi 
va trebui să îl tastaţi.)

• În câmpul Înlocuieşte cu (Replace with) selectaţi un font potrivit din lista 
derulantă a fonturilor disponibile pe sistemul dumneavoastră.
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3) Bifa de la dreapta câmpului Înlocuieşte cu (Replace with) se va înverzi. Apăsaţi pe 
aceasta. Un nou rând cu informaţii va fi afişat în tabelul de sub câmpurile de 
introducere. Bifaţi căsuţele din coloanele Întotdeauna (Always) şi Ecran (Screen).

4) În secţiunea din partea de jos a dialogului puteţi modifica aspectul şi mărimea fontului 
folosit pentru a afişa codul sursă HTML sau Basic (din macro-uri).

Imaginea 39. Definirea unei substituţii de fonturi.

Op iuni privind securitatea (ţ Security)
Folosiţi pagina OpenOffice.org – Securitate (OpenOffice.org – Security) (Imaginea 40)  pentru 
a alege opţiunile referitoare la deschiderea şi salvarea documentelor şi cele privind macro-urile 
din documente.
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Imaginea 40. Alegerea opţiunilor de securitate pentru deschiderea şi salvarea documentelor.

Op iunile de afişare (ţ Appearance)
Conceperea, editarea şi paginarea sunt de obicei mai uşor de făcut atunci când puteţi vizualiza 
cât mai mult din ceea ce se întâmplă în documentul în lucru. Astfel, puteţi dori să devină 
vizibile lucruri ca text, tabele, delimitările secţiunilor (în documentele Writer), marginile de 
pagină în Calc sau grila de linii în Calc sau Writer. În plus, s-ar putea să preferaţi alte culori 
decât cele obişnuite ale OOo pentru elemente ca notiţe sau umbrirea câmpurilor.

Pe pagina OpenOffice.org - Afişare (OpenOffice.org – Appearance) din Imaginea 41, puteţi 
specifica ce elemente sunt vizibile ca şi culorile ce vor fi folosite pentru a le afişa.

1) În dialogul Opţiuni (Options), apăsaţi OpenOffice.org > Afişare (OpenOffice.org > 
Appearance).

2) Pentru a afişa sau a ascunde elemente ca de exemplu marginile textului, bifaţi sau 
debifaţi căsuţele de lângă numele elementelor.

Pentru a modifica culorile obişnuite atribuite elementelor apăsaţi săgeata-jos din 
coloana Stabilire culoare (Color Setting) de lângă numele elementului şi selectaţi o 
culoare din casetă.

3) Pentru a salva modificările culorilor ca pe o schemă de culori, apăsaţi Salvează (Save), 
tastaţi un nume în câmpul Schemă (Scheme), apoi apăsaţi OK.
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Imaginea 41. Afişarea sau ascunderea textului, obiectelor şi a marginilor tabelelor.

Op iuni privind accesibilitatea (ţ Accessibility)
Opţiunile privind accesibilitatea (Accessibility) includ opţiunea de grafică sau text animat, 
durata afişării ponturilor de ajutor, unele opţiuni legate de un contrast ridicat şi posibilitatea de 
a modifica fontul interfeţei utilizator a programului OpenOffice.org (vedeţi Imaginea 42).

Suportul de accesibilitate utilizează tehnologia Sun Microsystems Java pentru a comunica cu 
uneltele de accesibilitate (asistenţă pentru persoanele cu dizabilităţi). Citiţi şi “Java“ la pagina 
72. Opţiunea "Suport pentru uneltele de asistentă" (“Support assistive technology tools”) nu 
este prezentă în toate kiturile de instalare OOo. Citiţi "Unelte de asistenţă în OpenOffice.org" 
(“Assistive Tools in OpenOffice.org”) în Ajutor pentru mai multe detalii şi cerinţe.

Imaginea 42. Alegerea opţiunilor privind accesibilitatea.
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1) În dialogul Opţiuni (Options), apăsaţi OpenOffice.org > Accesibilitate 
(OpenOffice.org > Accessibility).

2) Selectaţi sau deselectaţi opţiunile după cum vă este necesar.

Op iuni privind ţ Java
Dacă veţi instala sau actualiza programele Java Runtime Environment (JRE) după instalarea 
OpenOffice.org, sau dacă aveţi mai mult de o versiune JRE instalată pe calculator, puteţi folosi 
pagina de opţiuni privind Java (Imaginea 43) pentru a alege versiunea JRE pe care o va folosi 
OOo.

Dacă sunteţi administrator de sistem, programator sau doriţi să personalizaţi versiunile Java, 
puteţi să modificaţi opţiunile în paginile Parametri (Parameters) şi Căile către clase (Class 
Path), la care ajungeţi din această pagină apăsând butoanele respective.

1) În dialogul Opţiuni (Options), apăsaţi OpenOffice.org > Java.

2) Dacă nu vedeţi nimic listat în caseta din mijloc, aşteptaţi câteva minute până când OOo 
va termina de căutat programele JRE pe harddisk.

3) Dacă OOo găseşte una sau mai multe instalări JRE le va afişa aici. Puteţi apoi bifa 
Foloseşte un mediu de execuţie Java (Use a Java runtime environment) şi (dacă este 
cazul) să alegeţi unul dintre JRE-urile listate.

Imaginea 43. Alegerea unui mediu de execuţie Java.

Actualizare prin re ea (Online Update)ţ

Pe pagina "Actualizare online" ("Online Update") puteţi alege când şi cât de des OOo să 
verifice situl de internet OOo pentru actualizări ale programului.
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Alegerea op iunilor pentru înc rcarea şiţ ă  
salvarea documentelor

Puteţi stabili opţiunile de privind încărcarea şi salvarea ( Load/Save) documentelor conform 
stilului dumneavoastră de lucru.

Op iunile generaleţ

1) Dacă dialogul Opţiuni (Options) nu este deja deschis, apăsaţi Unelte -> Opţiuni (Tools 
> Options). Apăsaţi semnul + de la stânga lui Încarcă/Salvează (Load/Save).

2) Alegeţi Încarcă/Salvează > General (Load/Save > General) .

Cea mai mare parte dintre opţiunile dialogului Opţiuni – Încarcă/Salvează – General (Imaginea
44) sunt familiare utilizatorilor de aplicaţii de birou. Câteva dintre acestea, care prezintă mai 
mult interes, sunt prezentate mai jos.

Imaginea 44. Alegerea opţiunilor privind încărcarea şi salvarea documentelor.

Înc rcarea ă set rilor specifice utilizatoruluiă  din document

La salvarea unui documet, în acesta se salvează şi diverse setări. De exemplu, modul în care se 
va face actualizarea legăturilor (update links - în cadrul opţiunilor privind OOo Writer) este 
una dintre setările salvate, şi astfel va fi afectată de opţiunea Încarcă setările specifice 
utilizatorului (Load user-specific settings). Unele setări (numele imprimantei, sursele de 
date) sunt întotdeauna încărcate o dată cu documentul, indiferent de această opţiune.
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Dacă nu veţi bifa această opţiune, vor fi folosite setările utilizatorului aşa cum sunt stabilite în 
OOo, şi nu setările din document, cu unele excepţii detaliate în Ajutorul integrat.

Editarea propriet ilor documentului înainte de salvare (ăţ Edit document 
properties before saving)

Dacă această opţiune este bifată, de fiecare dată când veţi salva un document nou (sau folosiţi 
Salvează ca - Save As) va fi afişat dialogul Proprietăţile documentului (Document Properties) 
pentru a vă permite să introduceţi informaţiile relevante.

AutoSalvarea periodic   (Save AutoRecovery information every)ă

Este de remarcat că AutoSalvarea (AutoRecovery) din OpenOffice.org suprascrie fişierul 
original. Dacă aţi ales şi Creează întotdeauna copie de siguranţă (Always create backup 
copy), atunci fişierul original va suprascrie la rândul lui această copie. Aşadar, dacă veţi bifa 
această opţiune, va fi mai uşor să vă recuperaţi fişierul în cazul unei opriri accidentale, dar va 
fi mai greu să găsiţi o versiune anterioară a documentului.

Fişiere cât mai mici (greu de citit) - Size optimization for XML format 
(no pretty printing)

Documentele OpenOffice.org sunt salvate ca fişiere XML. Când bifaţi această opţiune acestea 
sunt salvate fără aranjarea textului în paragrafe, adică fără spaţiile şi identările care permit 
citirea uşoară, cu orice editor de text, a documentelor XML. Dacă doriţi să citiţi documentele 
create de OpenOffice.org în orice editor text debifaţi această opţiune.

Formatul implicit de fişier - Default file format

Dacă folosiţi în mod obişnuit un anumit format de fişier, de exemplu dacă trimiteţi documente 
către utilizatori ai Microsoft Word, puteţi modifica pentru fişierele text setarea Întotdeauna 
salvează ca (Always save as) din secţiunea Formatul implicit de fişier într-unul folosit şi de 
Word.

Propriet ile VBA (VBA Properties)ăţ

1) Alegeţi Încărcare/Salvare > Proprietăţile VBA (Load/Save > VBA Properties).

2) În dialogul din pagina Opţiuni – Încarcă/Salvează – Proprietăţile VBA (Imaginea 45), 
puteţi alege dacă veţi păstra macro-urile din documentele MSOffice pe care le veţi 
deschide în OOo.

• Dacă veţi alege Salvează codul Basic original (Save original Basic code), 
macro-urile nu vor rula în OOo dar sunt păstrate dacă veţi salva fişierul într-un 
format Microsoft Office.

• Dacă veţi alege Încarcă codul Basic pentru editare (Load Basic code to edit), 
codul modificat va fi salvat în documente de tip OOo dar nu va fi păstrat dacă veţi 
salva fişierul într-un format MSOffice.
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Imaginea 45. Alegerea proprietăţilor VBA - Încărcare/Salvare.

Op iunile ţ Microsoft Office
1) Apăsaţi Încarcă/Salvează > Microsoft Office (Load/Save > Microsoft Office).

2) În dialogul din pagina Opţiuni – Încarcă/Salvează – Microsoft Office (Imaginea 46), 
puteţi alege ce se va întâmpla la importul şi exportul de obiecte Microsoft Office OLE 
(sunt obiecte legate sau înglobate ori documente ca de exemplu foi de calcul şi formule 
matematice).

Bifaţi căsuţele [L] pentru a converti obiectele Microsoft OLE în obiectele 
corespunzătoare OpenOffice.org OLE când se va încărca un document Microsoft 
document în OOo (mnemonic: “L” for “load” - “a încărca” în engleză în original).

Bifaţi căsuţele [S] pentru a converti obiectele OpenOffice.org OLE în obiectele 
corespunzătoare Microsoft OLE când veţi salva un document în format Microsoft 
(mnemonic: “S” for “save” - “a salva” în engleză în original).
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Imaginea 46. Alegerea opţiunilor privind încărcarea/salvarea documentelor Microsoft Office.

Op iunile de compatibilitate pentru HTML (ţ HTML 
compatibility)
Alegerile efectuate în dialogul Încarcă/Salvează – Compatibilitate HTML (Imaginea 47) 
afectează paginile HTML importate şi exportate în/din OpenOffice.org.

Imaginea 47. Alegerea opţiunilor de compatibilitate pentru HTML.
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Alegerea set rilor de limbajă

Pentru a finaliza setările legate de limbajul folosit va trebui să puneţi la punct mai multe 
lucruri:

• Instalaţi dicţionarele necesare

• Schimbaţi unele setări privind localizarea şi limbajul

• Alegeţi dintre opţiunile privind ortografia

Instalarea dic ionarelor necesareţ

OOo 2.0 instalează automat câteva dicţionare îmrepună cu restul aplicaţiei. Pentru a adăuga 
alte dicţionare, folosiţi Fişier > Vrăjitori > Instalare dicţionare noi (File > Wizards > Install 
new dictionaries). Un document OOo se va deschide, oferindu-vă legături spre diverse 
limbaje pe care le puteţi instala. Urmaţi instrucţiunile afişate.

Modificarea set rilor privind ă localizarea şi limbajul
Puteţi modifica unele setări dintre cele ce ţin de localizare şi limbaj folosite de OOo atât pentru 
toate documentele cât şi pentru anumite documente.

1) În dialogul Opţiuni (Options), apăsaţi Setări limbaj > Limbaje (Language Settings > 
Languages).

2) În partea dreaptă (după cum se vede în Imaginea 48),  puteţi modifica Localizare 
(Locale setting), Valuta curentă (Default currency), şi Limbajele implicite pentru 
documente ( Default languages for documents) după cum vă este necesar. De exemplu, 
(Australia) a fost selectată ca şi localizare, iar dolarul australian (AUD) ca valută 
curentă. Deşi există şi un dicţionar English (Australia), utilizatorul respectiv a preferat 
dicţionarul English (UK) ca limbaje implicite pentru documente.
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Imaginea 48. Alegerea opţiunilor privind limbajul.

3) Dacă doriţi ca limbajul (dicţionarul) stabilit aici să fie aplicat numai documentului în 
lucru, în loc să rămână ca atare pentru toate documentele ce vor fi create pe viitor, bifaţi 
căsuţa intitulată Numai pentru documentul curent (For the current document only).

4) Dacă este cazul, selectaţi căsuţele pentru a activa suportul pentru limbajele asiatice 
( chineză, japoneză, coreeană) şi suportul pentru limbajele CTL ( Complex Text Layout 
- aspect complex al textului) cum sunt hindusa, thailandeza, ebraică şi arabă. Dacă veţi 
bifa aceste opţiuni, data următoare când veţi redeschide acest dialog veţi vedea nişte 
opţiuni suplimentare, care sunt arătate în Imaginea 49. Aceste opţiuni (Căutare în 
japoneză, Aspect asiatic şi Aspect complex al textului - Searching in Japanese, Asian 
Layout, şi Complex Text Layout) nu sunt discutate aici.

5) Apăsaţi OK pentru a salva modificările şi a închide dialogul.
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Imaginea 49. Opţiunile suplimentare afişate când este activat suportul pentru limbajele 
asiatice şi cele complexe.

Alegerea op iunilor privind ortografia (ţ spelling)
Pentru a alege dintre opţiunile privind ortografia:

1) În dialogul Opţiuni (Options), apăsaţi Setări limbaj > Asistenţă scriere (Language 
Settings > Writing Aids).

2) În secţiunea Opţiuni (Options) a dialogului Setări limbaj – Asistenţă scriere (Language 
Settings – Writing Aids) din Imaginea 50 alegeţi setările care vă convin. Câteva lucruri 
de reţinut:

• Dacă nu doriţi să fie verificată ortografia pe măsură ce tastaţi, debifaţi Verific 
ortografia pe măsură ce scrieţi (Check spelling as you type) şi selectaţi Nu marca 
greşelile (Do not mark errors). (A doua opţiune se găseşte mai jos în lista Opţiuni.)

• Dacă folosiţi un dictionar personalizat care include cuvinte numai cu majuscule şi 
cuvinte cu numere (de exemplu, AS/400), bifaţi Verific cuvintele cu majuscule 
(Check uppercase words) şi Verific cuvintele cu numere (Check words with 
numbers).

• Verific zonele speciale (Check special regions) se referă includerea de antete, 
subsoluri, cadre şi tabele în verificarea ortografică.

• Aici puteţi şi să verificaţi ce dicţionare definite de utilizator sunt activate, şi puteţi 
adăuga sau elimina dicţionare apăsând pe butoanele Nou (New) sau Şterge 
(Delete). 
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Imaginea 50. Alegerea limbajelor, dicţionarelor şi opţiunile privind verificarea ortografică.

Op iunile privind Internetulţ

Folosiţi pagina de opţiuni privind Internetul (Internet Options) pentru a defini motoarele de 
căutare şi a stabili setările privind proxy-ul pe care îl va utiliza OpenOffice.org.

Dacă folosiţi un browser Netscape sau Mozilla (ca de exemplu Firefox), puteţi să activaţi 
Mozilla Plug-in astfel încât să deschideţi fişierele OOo direct în browser, putând să le 
imprimaţi, să le salvaţi şi în general să lucraţi cu ele după cum doriţi.

Dacă folosiţi un sistem de operare bazat pe Unix sau Linux (incluzând aici şi Mac OS X) va fi 
disponibilă o pagină suplimentară cu opţiuni legate de E-mail, unde puteţi specifica ce 
program de e-mail să folosiţi atunci când veţi trimite documentul afşat în editare ca ataşament 
la e-mail (Imaginea 51).

Imaginea 51: Opţiunile privind Internetul, cu pagina privind programul de E-mail existentă 
numai în versiunile ce rulează pe Linux sau Unix.
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Controlul func iilor de autocorectareţ  
(AutoCorrect) din OOo

Sunt utilizatori care găsesc că toate facilităţile de auto-corectare din funcţiile AutoCorect din 
OOo sunt deranjante deoarece modifică ceea ce ai tastat şi atunci când nu îţi doreşti aceasta. 
Sunt însă alţi utilizatori care le găsesc foarte folositoare; dacă faceţi parte dintre aceştia, 
parcurgeţi opţiunile şi selectaţi-le pe cele dorite. Iar atunci când observaţi modificări 
inexplicabile în document aici este unul din locurile în care va trebui să verificaţi.

Pentru a deschide dialogul AutoCorectare, selectaţi Unelte > AutoCorectare (Tools > 
AutoCorrect). (Trebuie să fie un document deschis pentru ca să apară acest element din 
meniu.)

În Writer, acest dialog are 5 categorii, după cum se vede în Imaginea 52. În alte componente 
ale OOo, unde dialogul are numai 4 categorii, conţinutul categoriei Opţiuni (Options) este 
înfăţişat în Imaginea 53.

Imaginea 52. Dialogul AutoCorect din Writer, cele 5 categorii şi unele dintre opţiunile 
categoriei Opţiuni (Options).
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Imaginea 53. Dialogul AutoCorect din Calc, cu 4 categorii şi opţiunile categoriei Opţiuni 
(Options).
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    Iniţiere în WriterIniţiere în Writer
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Ce este Writer?

Ce este Writer?

Writer este un procesor de text, component al suitei OpenOffice.org (OOo). În plus faţă de 
funcţiile banale ale unui procesor de text (corectare ortografică, dicţionar, despărţire în silabe, 
auto-corectare, căutare & înlocuire, generarea automată a cuprinsului şi indecşilor, concatenare 
de email, etc.), Writer oferă şi aceste facilităţi importante:

• Şabloane şi stiluri

• Controlul performant al aspectului paginii, incluzând cadre, coloane şi tabele

• Includerea sau legarea imaginilor, foilor de calcul sau a altor obiecte

• Unelte de desenare incluse

• Documente master

• Urmărirea modificărilor corespunzătoare reviziilor documentului

• Integrarea bazelor de date, inclusiv a uneia de bibliografie

• Export în format PDF, incluzând semnele de carte

• şi multe altele.

Aceste facilităţi sunt descrise în detaliu în Ghidul Writer.

Interfa a Writerţ

Spaţiul principal de lucru al Writer este înfăţişat în Imaginea 54. Meniurile şi barele de unelte 
sunt descrise în capitolul 4 ("Meniuri şi bare de unelte"). Alte elemente ale interfeţei Writer 
sunt descrise în acest capitol.
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Imaginea 54: Spaţiul principal de lucru al Writer, în modul Aspect la imprimantă.

Schimbarea vizualiz rii ă documentului

Writer vă oferă mai multe posibilităţi de a vizualiza un document: Aspect la imprimantă (Print 
Layout), Aspect Web ( Web Layout), Pe tot ecranul (Full Screen) şi Lupă (Zoom). Pentru a 
alege dintre acestea mergeţi la meniul Vizualizare (View). Singurul mod de vizualizare care 
prezintă un submeniu este Lupă.

Crearea unui nou document

Puteţi să creaţi un document nou, fără text, cu Writer în mai multe feluri:

• Apăsaţi tastele Control+N. Va apare un nou document, vid. Dacă aveţi deja un 
document deschis, acest nou document va fi afişat într-o fereastră separată.

• Folosiţi Fişier > Nou > Document text (File > New > Text Document). Rezultatul este 
acelaşi ca la apăsarea tastelor Control+N.

• Apăsaţi butonul Nou (New) de pe bara de unelte principală (Standard) .

Crearea unui document pe baza unui şablon
Puteţi folosi şabloane pentru a crea noi documente în Writer. Şabloanele servesc ca o fundaţie 
pentru anumite documente, asigurându-vă că vor arăta, toate, la fel. De exemplu, toate 
documentele care compun acest Ghid de utilizare sunt bazate pe acelaşi şablon. Folosindu-l, 
toate documentele arată la fel; au aceleaşi antete şi subsoluri, folosesc aceleaşi fonturi, etc.
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Crearea unui nou document

Instalarea iniţială OpenOffice.org nu are foarte multe şabloane, însă există posibilitatea de a 
adăuga noi şabloane ulterior, folosindu-le la crearea de noi documente. Acestea sunt explicate 
în capitolul 12 (Lucrul cu şabloane). Puteţi descărca de pe Internet câte şabloane doriţi.

După ce aţi instalat şabloanele dorite, puteţi crea noi documente bazate pe acestea folosind 
Fişier > Nou > Şabloane şi documente (File > New > Templates and Documents). Aceasta 
deschide o fereastră de unde puteţi să alegeţi ce şablon doriţi să folosiţi pentru noul document.

Exemplul din Imaginea 55 foloseşte un şablon intitulat “book” din directorul Templates. 
Selectaţi-l, apoi apăsaţi butonul Deschide (Open). Va fi creat un nou document în funcţie de 
formatele din şablon.

Imaginea 55. Crearea unui document pe baza unui şablon.

Salvarea unui document

Salvaţi documentele Writer la fel ca pe oricare alte fişiere. Pentru mai multe detalii, citiţi şi 
capitolul 3 (“Gestiunea fişierelor în OpenOffice.org”).

Salvarea ca document Microsoft Word
Puteţi dori să trimiteţi documentele dumneavoastră către alţi utilizatori care nu folosesc OOo, 
ci Microsoft Word. Din fericire, OOo poate atât citi cât şi scrie documentele Word. Pentru a 
salva un document în formatul folosit de Microsoft Word:
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1) Întâi ar fi bine să salvaţi documentul în formatul folosit de OOo (.ODT). Dacă nu veţi 
face aceasta va trebui ca pe viitor să folosiţi tot documentul salvat în format Word, 
deoarece va conţine modificările efectuate de la ultima salvare.

2) Apoi apăsaţi Fişier > Salvare ca (File > Save As). Va apare fereastra Salvare ca 
(Imaginea 56).

3) În meniul derulant Salvează de tipul (Save as type) selectaţi tipul dorit de document 
Word. Apăsaţi Salvează (Save).

Din acest moment, toate modificările efectuate pe document vor apărea numai în documentul 
Microsoft Word. De fapt, salvându-l aţi schimbat numele documentului (şi anume extensia 
acestuia). Dacă veţi dori ca să lucraţi în continuare cu versiunea în formatul OOo va trebui să o 
deschideţi ca pe orice alt document.

PONT Pentru a salva în mod pbişnuit documentele create cu OOo într-un format Microsoft 
Word mergeţi la Unelte > Opţiuni > Încarcă/Salvează (Tools > Options > 
Load/Save). Este acolo o secţiune intulată Format implicit de fişier (Default file 
format). Sub Tip document (Document Type), selectaţi Document text (Text  
Document), apoi sub Întotdeauna salvează ca (Always save as) selectaţi formatul de 
fişier preferat. Citiţi şi “Alegerea opţiunilor pentru încărcarea şi salvarea 
documentelor” în Capitolul 5 (Configurare OpenOffice.org).

Imaginea 56. Salvarea unui fişier în formatul Microsoft Word.
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Lucrul cu text

Lucrul cu text (selctare, copiere, lipire, mutare) în Writer este similar cu lucrul cu text în orice 
alt procesor de text. OOo vă oferă de asemenea metode convenabile de a selecta elemente care 
nu sunt consecutive, de a muta rapid paragrafele şi de a lipi text fără formatări.

Selectarea elementelor disparate
Pentru a selecta elemente care nu sunt consecutive (ca în Imaginea 57) folosind mausul:

1) Selectaţi prima porţiune de text.

2) Ţineţi apăsată tasta Control şi folosiţi mausul pentru a selecta următoarea porţiune de 
text.

3) Repetaţi de câte ori este necesar.

4) Acum puteţi opera asupra elementelor selectate (le puteţi copia, şterge, schimba 
stilurile, orice doriţi).

Notă Utilizatorii Macintosh: folosiţi tasta Command atunci când în acest ghid se face 
referire la tasta Control.

Pentru a selecta elemente care nu sunt consecutive folosind tastatura:

1) Selectaţi prima porţiune de text. (Pentru mai multe informaţii despre selectarea textului 
cu tastatura citiţi topicul “Navigating and selecting with the keyboard” în Ajutor - Help 
din program.)

1) Apăsaţi Shift+F8. Aceasta va pune Writer în modul “ADD” (adăugare). Cuvântul ADD 
va fi afişat pe bara de status.

2) Folosiţi săgeţile pentru a vă deplasa la începutul următoarei porţiuni de text pe care 
doriţi să o selectaţi. Ţineţi apăsată tasta Shift şi selectaţi următoarea porţiune de text.

5) Repetaţi de câte ori este necesar.

3) Acum puteţi opera asupra elementelor selectate .

4) Apăsaţi Esc pentru a reveni la modul normal de lucru.
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Imaginea 57: Selectarea elementelor disparate.

Decuparea, copierea şi lipirea textului
Decuparea şi copierea textului în Writer este similară cu decuparea şi copierea textului în alte 
aplicaţii. Pentru aceste operaţii puteţi folosi mausul sau tastatura.

Decupare: Folosiţi Editare > Decupare (Edit > Cut) sau tastele rapide Control+X sau 
pictograma Decupare (Cut) de pe panoul de unelte.

Copiere: Folosiţi Editare > Copiere (Edit  > Copy) sau tastele rapide Control+C sau 
pictograma Copiere (Copy).

Lipire: Folosiţi Editare > Lipire (Edit > Paste) sau tastele rapide Control+V sau 
pictograma Lipire (Paste).

Dacă doar apăsaţi pe pictograma Lipire vor fi păstrate toate formatările pe care le are textul (ca 
de exemplu aldine sau cursiv). Pentru a prelua însă formatarea textului lângă care va fi lipit, 
apăsaţi pe triunghiul de la dreapta pictogramei Lipire şi selectaţi Text neformatat 
(Unformatted text) din meniul afişat (Imaginea 58).

Imaginea 58: Meniul Lipire.

Mutarea rapid  a paragrafeloră

1) Amplasaţi cursorul oriunde în paragraf.

2) Ţineţi apăsată tasta Control şi apăsaţi săgeţile sus ori jos.

Pragraful va fi mutat înaintea paragrafului anterior sau după paragraful următor din document. 
Pentru a muta simultan mai mult de un paragraf, selectaţi cel puţin o parte din ambele 
paragrafe înainte de a apăsa tastele Control+săgeţi.
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Dacă utilizaţi sistemul de operare Solaris, combinaţia de taste este Control+AltGr+săgeţi .

PONT Dacă paragraful la care lucraţi sare brusc în altă parte cel mai probabil aţi apăsat 
accidental aceste taste.

G sirea şi înlocuirea textului şi format riloră ă

Writer are o funcţie de Găseşte şi înlocuieşte (Find and Replace) care automatizează sarcina de 
a găsi textul în cadrul unui document. În plus faţă de a găsi şi de a înlocui cuvinte şi fraze, 
puteţi face şi următoarele:

• Să folosiţi expresii regulate (jockeri ) pentru a defini o căutare (detalii găsiţi în Ajutor - 
Help din program).

• Să găsiţi şi să înlocuiţi formatările dorite (citiţi Ghidul Writer pentru amănunte).

• Să găsiţi şi să înlocuiţi stilurile de paragraf (citiţi Ghidul Writer pentru amănunte).

Pentru a afişa dialogul Găseşte & Înlocuieşte (Find & Replace) (Imaginea 59), folosiţi tastele 
rapide Control+F sau selectaţi Editare > Găseşte & Înlocuieşte (Edit > Find & Replace). 

1) Tastaţi textul pe care doriţi să îl localizaţi în căsuţa Caută (Search for).

2) Pentru a-l înlocui cu altceva, tastaţi noul text în căsuţa Înlocuieşte cu (Replace with).

3) Puteţi activa diverse opţiuni, ca de exemplu verificare majuscule / minuscule, căutarea 
numai după cuvinte întregi (separate prin spaţii) sau căutare după cuvinte similare. 
(Vedeţi mai jos şi alte opţiuni.)

4) Când aţi terminat de configurat căutarea, apăsaţi Găseşte (Find). Pentru a înlocui textul 
folosiţi în schimb Înlocuieşte (Replace). 
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Imaginea 59: Dialogul extins Găseşte & Înlocuieşte.

PONT Dacă apăsaţi Găseşte tot (Find All), OOo selectează toate apariţiile din document ale 
textului căutat . Similar, dacă apăsaţi Înlocuieşte tot (Replace All), OOo va înlocui 
toate apariţiile. 

Caution Folosiţi Înlocuieşte tot (Replace All) cu atenţie; altfel, aţi putea ajunge la greşeli 
ilare (şi foarte neplăcute ulterior). O greşeală cu Înlocuieşte tot (Replace All) poate 
să vă ducă la o căutare manuală, cuvânt cu cuvânt, a întregului document.
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Inserarea caracterelor speciale
Un caracter “special” este acela care nu figurează pe tastatura obişnuită englezească. De 
exemplu, © ¾ æ ç ñ ö ø ¢ sunt, toate, caractere speciale. Pentru a insera un astfel de caracter 
procedaţi astfel:

1) Plasaţi cursorul la locul dorit pentru inserţie.

2) Apăsaţi  Inserare > Caracter special (Insert > Special Character) pentru a deschide 
fereastra Caractere speciale (Special Characters) (Imaginea 60).

3) Selectaţi caracterele pe care doriţi să le inseraţi, în ordinea corespunzătoare, apoi apăsaţi 
OK. Caracterele selectate sunt afişate în partea din stânga - jos a dialogului. La 
selectarea unui caracter, acesta este afişat în partea dreapta - jos, împreună cu codul său 
numeric.

Notă Fonturi diferite înseamnă caractere speciale diferite. Dacă nu găsiţi un anumit 
caracter încercaţi să schimbaţi fontul curent din lista derulantă Font.

Imaginea 60: Fereastra Caractere speciale, de unde puteţi insera astfel de caractere.

PONT Observaţi cum caracterele selectate apar în colţul din stânga - jos al ferestrei.
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Stabilirea spa ierii taburilorţ 1 şi a indent riloră 2

Rigla orizontală indică spaţierea taburilor, atât cea implicită cât şi cele definite de 
dumneavoastră. Pentru a stabili unitatea de măsură şi spaţierea implicită mergeţi la Unelte > 
Opţiuni > OpenOffice.org Writer > General (Tools > Options > OpenOffice.org Writer > 
General).

Puteţi să modificaţi unitatea de măsură şi cu clic-dreapta pe riglă pentru a fi afişată lista tuturor 
unităţilor de măsură, ca în Imaginea 61. Click on one of them to change the ruler to that unit.

Imaginea 61: Rigla indică spaţierea implicită a taburilor.

Daţi dublu-clic pe partea nefolosită a riglei pentru a deschide categoria Indentare şi spaţiere 
(Indents & Spacing) din dialogul Paragraf (Paragraph). Daţi dublu-clic pe riglă în zona gradată 
pentrua  deschide categoria Taburi (Tabs) din dialogul Paragraf şi a putea stabili în detaliu 
spaţierea taburilor.

Verificarea ortografiei
Writer vă pune la dispoziţie un verificator ortografic, care poate fi utilizat în două moduri.

Verifică automat ortografia (AutoSpellcheck) verifică fiecare cuvânt pe măsură ce este 
scris şi afişează o linie roşie vălurită sub cuvintele pe care le consideră greşite. Dacă veţi 

corecta cuvântul linia va dispărea.

 Pentru a executa o verificare separată pe tot documentul sau doar pe textul selectat 
apăsaţi butonul Verifică ortografia (Spellcheck). Aceasta va verifica documentul sau 
selecţia şi va deschide dialogul Verifică ortografia (Spellcheck) dacă va găsi cuvinte 

greşite.

Iată câteva facilităţi ale verificatorului ortografic:

• Puteţi schimba dicţionarul în funcţie de limbă (de exemplu, în Franceză, Germană, 
Spaniolă, Română) din dialogul Verifică ortografia (Spellcheck).

• Puteţi adăuga cuvinte în dicţionar. Apăsaţi Adaugă (Add) în dialogul Verifică ortografia 
(Spellcheck) şi alegeţi dicţionarul unde doriţi să adăugaţi.

1 (în limba engleză tab stops) Programele de procesare a textului definesc pe fiecare linie a textului un număr de 
taburi, de obicei la intervale regulate, şi care pot fi modificate de utilizator. Apăsarea tastei Tab va duce cursorul la 
următorul tab, iar distanţa dintre 2 taburi este denumită spaţiere sau, în engleză, tab stop. Serveşte la formatarea 
facilă a textului în coloane. Taburile în sine sunt invizibile în pagină, fiind marcate doar pe rigla orizontală.

2 Indentare (indent în limba engleză) înseamnă retragerea întregului paragraf faţă de marginea paginii cu o anumită 
distanţă.
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• Dialogul Opţiuni (Options) din unealta Verifică ortografia (Spellcheck) are anumite 
opţiuni, ca de exemplu dacă să verifice cuvintele scrise cu majuscule sau cele care 
conţin numere. De asemenea, vă permite să administraţi dicţionare personalizate, adică 
să adăugaţi sau să ştergeţi dicţionare sau cuvinte din dicţionare.

• În categoria Font din dialogul Stiluri de paragraf (Paragraph Styles) puteţi stabili ca 
paragrafele să fie verificate în alte limbi decât restul documentului. Citiţi capitolul 7 
“Lucrul cu stiluri (Working with Styles)” din Ghidul Writer pentru mai multe informaţii.

Utilizarea AutoCorectare (AutoCorrect)
Funcţia AutoCorectare din Writer procesează o lungă listă de greşeli frecvente pe care le poate 
corecta automat. De exemplu, “hte” va deveni “the”. Selectaţi Unelte > AutoCorectare (Tools 
> AutoCorrect) pentru a deschide dialogul AutoCorectare. Acolo veţi putea defini şirurile ce 
vor fi corectate şi în ce mod. De obicei setările existente sunt bune.

PONT AutoCorectare este activat de la început. Pentru a-l dezactiva debifaţi Formatare > 
AutoFormatare > Când tastaţi (Format > AutoFormat > While Typing).

• Pentru a opri Writer de la înlocuirea anumitor şiruri, folosiţi Unelte >AutoCorectare > 
Înlocuieşte (Tools > AutoCorrect > Replace), selectaţi perechea de cuvinte şi apăsaţi 
Şterge (Delete).

• Pentru a adăuga o nouă pereche de corectat, tastaţi-o în câmpurile Înlocuieşte (Replace) 
şi Cu (With) boxes şi apăsaţi Nou (New).

• Uitaţi-vă la celelalte categorii ale ferestrei de dialog pentru a observa celelalte opţiuni 
disponibile pentru reglarea în detaliu a funcţiei AutoCorectare.

PONT AutoCorectare poate fi folosit şi ca o cale rapidă pentru a insera caractere speciale. 
De exemplu, (c)  va fi autocorectat în ©. Vă puteţi adăuga propriile combinaţii.

Utilizarea complet rii cuvinteloră

Dacă este activat Completare cuvânt (Word Completion), Writer va încerca să ghicească ce 
cuvânt intenţionaţi să tastaţi după primele caractere introduse şi se va oferi să completeze restul 
de litere pentru dumneavoastră. Pentru a accepta sugestia, apăsaţi Enter. Altfel, continuaţi să 
tastaţi.

PONT Mulţi utilizatori preferă să nu folosească Completare cuvânt. Dacă nu doriţi să folosiţi 
această facilitate, selectaţi Unelte > AutoCorectare > Completare cuvânt (Tools > 
AutoCorrect > Word Completion) şi debifaţi Activează completare cuvânt (Enable 
Word Completion).

Puteţi să personalizaţi completarea cuvintelor din categoria Unelte > AutoCorectare > 
Completare cuvânt (Tools > AutoCorrect > Word Completion):

• Să fie adăugat automat un spaţiu după un cuvânt acceptat.
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• Să fie arătat cuvântul ghicit ca un pont (deasupra textului pe care îl tastaţi) în loc de a fi 
afişat în continuarea textului tastat de dumneavoastră.

• Să modificaţi numărul maxim de cuvinte stocate şi dimensiunea minimă a unui astfel de 
cuvânt.

• Să ştergeţi anumite cuvinte din listă.

• Să modificaţi tasta cu care se acceptă completarea propusă—opţiunile sunt Săgeată 
dreapta, tasta End, Return (Enter) şi tasta Space.

Notă Completarea automată a cuvântului funcţionează după ce cuvântul a fost deja tastat o 
dată în document.

Utilizarea AutoText
AutoText vă permite să asociaţi text, tabele, grafică şi alte elemente cu combinaţii de taste. De 
exemplu, în loc să tastaţi “Senior Management” de fiecare dată, puteţi pur şi simplu să tastaţi 
“sm” şi să apăsaţi F3. Sau puteţi să salvaţi o Notă, cu formatarea aferentă (cum sunt cele din 
acest document) ca AutoText şi apoi să inseraţi o copie tastând "notă" şi apăsând F3.

Pentru a asocia un text unei prescurtări AutoText:

1) Tastaţi textul respectiv în document.

2) Selectaţi textul astfel, acesta fiind marcat ca atare.

3) Selectaţi Editare > AutoText (Edit > AutoText) (sau apăsaţi Control+F3).

4) Introduceţi o denumire pentru prescurtare. Writer vă va sugera o denumire de o literă, pe 
care însă o puteţi modifica.

5) Apăsaţi butonul AutoText din dreapta şi selectaţi Nou (numai text) (New (text only)) 
din meniu.

6) Apăsaţi Închide (Close) pentru a reveni la editarea documentului.

PONT Dacă singura opţiune de sub butonul AutoText este Import, fie nu aţi introdus nici un 
nume pentru prescurtare fie nu aţi selectat nici un text în document.

AutoText este în mod special foarte util atunci când este asociat cu câmpuri. Citiţi capitolul 14 
"Lucrul cu câmpuri" (“Working with Fields”) în Ghidul Writer pentru detalii.

Inserarea liniu elor orizontale şi a ţ spa iilor deţ  
leg tură ă

Puteţi insera o liniuţă orizontală (linie de dialog sau linie de pauză) folosind fie fereastra 
Caractere speciale (Special Characters) fie AutoCorectare. (Dacă doriţi să aflaţi mai multe 
despre AutoCorrect, citiţi “Controlul funcţiilor de autocorectare (AutoCorrect) din OOo” în 
Capitolul 5, “Configurare OpenOffice.org” şi “Utilizarea AutoCorectare (AutoCorrect)” la 
pagina 94 în acest capitol).
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Aceste liniuţe sunt următoarele:

– este liniuţa en (en-dash); adică este aşa-numita liniuţă de pauză, şi care are lăţimea literei 
“n” corespunzătoare fontului folosit. Este numerotată U+2013 (derulaţi secţiunea 
Punctuaţie obişnuită (General Punctuation) din fereastra Caractere speciale). Pentru a 
insera o liniuţă-en folosind AutoCorrect tastaţi minim un caracter, un spaţiu, două cratime, 
încă un spaţiu, şi încă minim o literă. Cele două cratime vor fi înlocuite cu o liniuţă-en.

— este liniuţa em (em-dash); adică este aşa-numita liniuţă de dialog, şi care are lăţimea literei 
“m” corespunzătoare fontului folosit. Este numerotată U+2014. Pentru a insera o liniuţă-em 
folosind AutoCorrect tastaţi minim un caracter, două cratime, încă minim o literă şi încă un 
spaţiu. Cele două cratime vor fi înlocuite cu o liniuţă-em.

Pentru a insera un spaţiu de legătură astfel încât, deşi despărţite de un spaţiu, caracterele să fie 
totuşi legate, apăsaţi Control+Space.

Notă Semnele de punctuaţie şi de ortografie sunt precizate în lucrarea "Îndreptar 
Ortografic, Ortoepic şi de Punctuaţie" editată de Academia Română, Institutul de 
Lingvistică "Iorgu Iordan – Alexandru Rosetti", ultima fiind ediţia a V-a, editura 
Univers Enciclopedic, Bucureşti, 1995.

Conform ÎOOP (p. 81-83), liniile de dialog şi de pauză au o lungime identică pentru 
cele două funcţii. Lungimea exactă nu se specifică decît generic, cum că este mai 
mare decât lungimea cratimei.

Pentru linia de pauză, programele de autocorecţie (internaţional) folosesc en-dash. De 
asemenea, vizual, em-dash ar fi deranjant de lungă pentru linia de pauză.

Deoarece prin definiţie (ÎOOP) cele două sunt identice, rezultă că amândouă ar trebui 
să fie en-dash. Pe acest considerent, standardul de tastatură românească prevede 
generarea caracterului en-dash prin tastarea AltGr+Shift+[tasta minus / underscore] 
(tasta de coordonate E11). Deoarece nu a existat nici un motiv oficial, caracterul em-
dash nu a fost prevăzut nicăieri (precizarea aparţine dlui Cristian Secară).

Formatarea textului

Utilizarea stilurilor
Stilurile sunt esenţiale pentru utilizarea Writer-ului. Stilurile vă vor permite să vă formataţi cu 
uşurinţă documentul în mod unitar, iar apoi să efectuaţi modificările dorite cu minimum de 
efort. Adesea, atunci când redactaţi un document în Writer, folosiţi stilurile fără să o ştiţi. Un 
stil este un set de opţiuni de formatare. Writer defineşte câteva tipuri de stiluri, pentru diferite 
elemente de text: caractere, paragrafe, pagini, cadre şi liste. Dacă doriţi să vă informaţi despre 
avantajele stilurilor şi cum să le folosiţi, citiţi capitolul 13 (Lucrul cu stiluri) din această carte. 
Utilizarea stilurilor este descrisă detaliat în capitolele 6 şi 7 intitulate “Introducere în stiluri” şi 
“Lucrul cu stiluri” din Ghidul Writer.

96 Capitolul 6  Ini iere în Writerţ



Formatarea textului

Formatarea paragrafelor
Puteţi aplica multe formate paragrafelor folosind butoanele de pe bara de unelte Formatare. 
Imaginea 62 vă arată bara de unelte Formatare detaşată de meniu şi modificată să arate numai 
butoanele pentru formatarea paragrafelor.

PONT Este foarte recomandat ca să folosiţi stilurile de paragraf decât să formataţi manual 
paragrafele, mai ales pentru documente lungi sau tipizate.

1  Buline Da/Nu   8  Inserează element nenumerotat
2  Numerotare Da/Nu   9  Mută în sus
3  Fără numerotare 10  Mută în jos
4  Ridică un nivel 11  Mută în sus cu subpuncte
5  Coboară un nivel 12  Mută în jos cu subpuncte
6  Mută în sus (un nivel) cu subpuncte 13  Reia numerotarea
7  Mută în jos (un nivel) cu subpuncte 14  Buline şi numerotare

Imaginea 62: Bara de unelte Formatare, cu butoanele pentru formatarea 
paragrafelor

Imaginea 63 exemplifică diferite opţiuni de aliniere.

Imaginea 63: Diferite opţiuni de aliniere a textului.

Formatarea caracterelor
Puteţi aplica multe formatări caracterelor folosind butoanele de pe bara de unelte Formatare. În 
Imaginea 64 această bară este detaşată şi personalizată pentru a afişa numai butoanele ce se 
referă la formatarea caracterelor.

PONT Este foarte recomandat să folosiţi stiluri de caracter decât să formaţi manual 
caracterele.
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1 Deschide fereastra  5 Aldin (Bold) 10 Măreşte fontul 15 Deschide dialogul
   Stiluri şi formatare 6 Cursiv (Italic) 11 Micşorează fontul      Formatare caracter
2 Aplică stilul 7 Subliniat 12 Culoarea fontului

3 Numele fontului 8 Scris sus 13 Evidenţiere

4 Font Size 9 Scris jos 14 Culoarea fundalului

Imaginea 64: Bara de unelte Formatare, cu butoanele pentru formatarea caracterelor.

PONT Pentru a elimina formatările manuale, selectaţi textul şi apăsaţi Formatare > 
Formatare obişnuită (Format > Default Formatting), sau daţi clic-dreapta şi 
selectaţi Formatare obişnuită (Default Formatting) din meniul contextual.

Autoformatare
Puteţi programa Writer-ul să efectueze în mod automat formatarea unor părţi de document, în 
funcţie de opţiunile alese în categoria Opţiuni (Options) din dialogul AutoCorectare 
(AutoCorrrect) de la Unelte > AutoCorectare > Opţiuni (Tools > AutoCorrect > Options).

PONT Dacă veţi observa modificări neaşteptate de formatare în documentul dumneavoastră, 
aici este primul loc unde ar trebui să vă uitaţi pentru o explicaţie.

Câteva modificări nedorite sau neaşteptate includ:

• Linii orizontale. Dacă veţi tastat 3 sau mai multe cratime (---), liniuţe de subliniere 
(___) sau semne egal (===) pe o linie şi apoi apăsaţi Enter, paragraful va fi înlocuit de o 
linie orizontală pe toată lăţimea paginii. Această linie marchează de fapt marginea 
inferioară a paragrafului anterior.

• Listele cu buline şi cele numerotate. O listă cu buline este creată atunci când tastaţi o 
cratimă (-), steluţă (*) sau un semn plus (+) urmate de un spaţiu sau de tab, la începutul 
paragrafului. O listă numerotată este creată atunci când tastaţi un număr urmat de punct 
(.), urmat de un spaţiu sau de un tab, la începutul paragrafului. Numerotarea automată 
este aplicată numai paragrafelor formatate cu stilurile de parafrag Default, Text body sau 
Text body indent.

Pentru a activa sau dezactiva autoformatarea mergeţi la Formatare > AutoFormatare 
(Format > AutoFormat) şi selectaţi sau ştergeţi elementele din submeniu.

Crearea listelor numerotate sau cu buline
Sunt câteva moduri în care puteţi să creaţi liste numerotate sau cu buline:

• Folosiţi autoformatarea, aşa cum este descris mai sus.
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• Folosiţi stilurile de listă (numerotare), aşa cum este explicat în capitolul 7, “Lucrul cu 
stiluri”, din Ghidul Writer.

• Folosiţi pictogramele Numerotare (Numbering) şi Buline (Bullets) de pe panoul de 
formatări de paragraf (priviţi Imaginea 62). Această metodă este descrisă aici.

Pentru a realiza o listă numerotată sau cu buline selectaţi paragrafele ce vor fi în listă, iar apoi 
apăsaţi pictograma corespunzătoare de pe panoul cu unelte.

Notă Nu contează dacă întâi introduceţi elementele listei sub formă de paragrafe şi apoi 
aplicaţi stilul de listă dorit ori dacă lucraţi de la început sub forma de listă numerotată 
sau cu buline.

Utilizarea barei de unelte Buline şi numerotare

Puteţi crea liste în cadrul altor liste (când elementele listei au o sublistă sub acestea, ca într-o 
schiţă) utilizând butoanele de pe bara de unelte Buline şi numerotare (Bullets and Numbering) 
din Imaginea 65. Puteţi să mutaţi elementele în sus şi în jos în cadrul listei, să creaţi subpuncte 
şi să modificaţi stilul bulinelor. Folosiţi Vizualizare > Bare de unelte > Buline şi numerotare 
(View > Toolbars > Bullets and Numbering) pentru a vizualiza bara de unelte.

1  Buline activat/dezactivat   8  Inserare intrare nenumerotată
2  Numerotare activat/dezactivat   9  Mută în sus
3  Fără numerotare 10  Mută în jos
4  În sus un nivel 11  Mută în sus cu subpuncte
5  În jos un nivel 12  Mută în jos cu subpuncte
6  Mută în sus (un nivel) cu subpuncte 13  Reîncepe numerotarea
7  Mută în jos (un nivel) cu subpuncte 14  Buline şi numerotare

Imaginea 65: Bara de unelte Buline şi numerotare.

Desp r irea în silabeă ţ

Pentru a porni/ opri despărţirea automată în silabe:

1) Apăsaţi F11 pentru a deschide fereastra Stiluri şi formatare (Styles and Formatting) 
(Imaginea 66). 

2) La categoria Stiluri de paragraf din cadrul fereastrei apăsaţi clic-dreapta pe Obişnuit 
(Default) din listă şi selectaţi Modifică (Modify).
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Imaginea 66: Modificarea stilului Default.

3) În dialogul Stilul paragrafului, selectaţi categoria Aranjament text (Text Flow) (vedeţi 
Imaginea 67).

4) Sub Silabisire (Hyphenation), bifaţi sau debifaţi căsuţa Automat (Automatically). 
Apăsaţi OK pentru a salva.

Notă Activarea silabisirii pentru stilul de paragraf Obişnuit (Default) va afecta toate 
paragrafele bazate pe acesta. Puteţi să modificaţi individual alte stiluri astfel încât 
silabisirea să nu fie activată; de exemplu, s-ar putea să nu doriţi să vă fie despărţite în 
silabe şi titlurile. Orice alte stiluri care nu sunt bazate pe stilul Obişnuit (Default) nu 
vor fi, în acest exemplu, afectate. 

Imaginea 67: Activarea despărţitii automate în silabe.

Puteţi de asemenea stabili reguli de silabisire cu ajutorul Unelte > Opţiuni > Setări limbaj > 
Asistenţă scriere (Tools > Options > Language Settings > Writing Aids). La Opţiuni 
(Options), lângă partea de jos a dialogului, derulaţi în jos pentru a găsi regulile de silabisire 
(vedeţi Imaginea 68).
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Imaginea 68: Stabilirea opţiunilor de despărţire în silabe.

Note Regulile de silabisire din dialogul Asistenţă scriere (Writing Aids) sunt folosite numai 
dacă silabisirea este activată prin intermediul stilurilor de paragraf.

Opţiunile din Ajutorul de scriere pentru "caractere înainte de linie nouă" (“characters 
before line break”) şi "caractere după linie nouă" (“characters after line break”) 
înlătură opţiunile din stilurile de paragraf pentru "caractere la sfârşit de linie" 
(“characters at line end”) şi "caractere la început de linie" (“characters at line begin”). 
Aceasta este rezultatul unei greşeli de implementare.

Pentru a introduce o despărţire condiţionată în silabe în cadrul unui cuvânt, apăsaţi 
Control+semnul minus. Cuvântul va fi despărţit în silabe atunci când va apare la sfârşitul 
liniei, chiar şi atunci când silabisirea automată este dezactivată.

Pentru a insera o cratimă de legătura, apăsaţi Control+Shift+semnul minus.

Refacerea şi repetarea modific riloră

Pentru a reface forma iniţială a textului, anulând modificările ce au avut loc, apăsaţi 

Control+Z, sau apăsaţi pictograma Reface (Undo)  de pe bara de unelte Standard, sau 
selectaţi Editare > Refacere (Edit > Undo) din meniu. 

Meniul Editare (Edit) arată ultima modificare ce poate fi refăcută, după cum se vede în 
Imaginea 69.

Imaginea 69: Editare > Reface ultima modificare (Edit > Undo).

Apăsaţi pe micul triunghi de la dreapta pictogramei Reface (Undo) pentru a se afişa lista 
tuturor modificările ce pot fi anulate  (Imaginea 70). Puteţi selecta mai multe modificări şi să 
le anulaţi simultan.
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Imaginea 70: Lista modificărilor ce pot fi  
anulate.

După ce modificările au fost anulate, Repetă (Redo) devine activă. Pentru a repeta o 
modificare, selectaţi Editare > Repetă (Edit > Redo), sau apăsaţi Control+Y ori apăsaţi 
pictograma Repetă (Redo) . La fel ca şi la Reface, apăsând pe triunghiul de la dreapta 

săgeţii va afişa o listă de modificări ce pot fi repetate.

Pentru a modifica numărul de modificări memorate de OpenOffice.org selectaţi Unelte > 
Opţiuni > OpenOffice.org > Memorie (Tools > Options > OpenOffice.org > Memory) şi 
modificaţi Numărul de modificări anulabile (Undo number of steps). Dacă veţi alege 
memorarea unui număr mai mare de modificări, OOo va consuma mai multă memorie.

Eviden a modific rilor unui documentţ ă

Puteţi folosi câteva metode pentru a ţine evidenţa modificărilor intervenite asupra unui 
document.

1) Efectuaţi modificările asupra unei copii a documentului (salvat într-un alt director, sub 
un alt nume, etc.), apoi folosiţi Writer pentru a compara cele 2 fişiere şi a evidenţia 
modificările. Apăsaţi Editare > Comparare document (Edit > Compare Document). 
Această tehnică este în mod particular utilă dacă sunteţi singura persoană care editează 
documentul, deoarece evită creşterea dimensiunii şi complexităţii fişierului, ambele 
cauzate de celelalte metode.

2) Salvaţi versiunile în cadrul fişierului original. Această metodă poate cauza probleme 
dacă documentele sunt mari sau complexe, şi mai ales dacă salvaţi multe versiuni. 
Evitaţi această metodă dacă puteţi.

3) Folosiţi semnele de modificări ale Writer (deseori numite, "linii roşii",  “redlines” sau 
“revision marks”) pentru a evidenţia unde aţi adăugat sau aţi şters material ori aţi 
schimbat formatarea. Ulterior, dvoastră sau o altă persoană poate verifica şi poate să 
accepte sau să respingă fiecare modificare, individual.

PONT Nu toate modificările sunt înregistrate. De exemplu, modificarea spaţierii taburilor, 
modificările în formule (ecuaţii) sau modificările legăturilor către imagini nu sunt 
înregistrate.
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Înregistrarea modific riloră

Citiţi capitolul al doilea intitulat “Setting up Writer” din Ghidul Writer pentru instrucţiunile 
necesare stabilirii modului cum vor fi înregistrate modificările.

1) Pentru a începe să înregistraţi, apăsaţi Editare > Modificări > Înregistrare (Edit > 
Changes > Record).

Pentru a afişa sau a ascunde modificările intervenite apăsaţi Editare > Modificări > 
Afişează (Edit > Changes > Show). 

PONT Ţineţi cursorul mausului deasupra semnului de modificare; veţi vedea un Pont de 
ajutor  afişând tipul, autorul, data şi ora modificării. Dacă Ponturile extinse sunt 
activate, se vor afişa şi comentariile asociate acelei modificări.

2) Pentru a introduce un comentariu asociat unei modificări, plasaţi cursorul in zona 
modificată şi apoi apăsaţi Editare > Modificări > Comentariu (Edit > Changes > 
Comment). (Vedeţi Imaginea 71.) În plus faţă de afişarea ca Pont extins comentariul 
este afişat în cadrul dialogului Accepta sau respinge modificările (Accept or Reject 
Changes).

Vă puteţi deplasa de la modificare marcată la următoarea folosind tastele săgeţi.
Dacă nu a fost înregistrat nici un comentariu aferent modificării câmpul Text va fi gol.

3) Pentru a opri înregistrarea modificărilor, apăsaţi din nou Editare > Modificări > 
Înregistrare (Edit > Changes > Record).

Imaginea 71: Insertarea unui comentariu în timpul 
înregistrării modificărilor.
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Inserarea adnot riloră

Pentru a insera o notă care nu este asociată cu o modificare înregistrată:

1) Poziţionaţi cursorul deasupra textului despre care doriţi să comentaţi, şi apoi apăsaţi 
Inserare > Notă (Insert > Note).

2) În dialogul Inserare notă (Insert Note - Imaginea 72), tastaţi nota dorită. Apăsaţi Autor 
(Author) pentru a insera iniţialele dumneavoastră, precum şi data şi ora.

Imaginea 72: Adnotare: inserarea unei note.

Pentru a vizualiza o notă poziţionaţi cursorul mausului deasupra balizei notei (afişată ca un mic 
dreptunghi galben). Writer va afişa nota ca un Pont deasupra textului. Puteţi şi să daţi dublu-
clic pe notă pentru a o edita cu dialogul Editare notă (Edit Note). Dacă nu vă descurcaţi să 
identificaţi sau să vizualizaţi notele în acest mod, puteţi să folosiţi şi Navigatorul: expandaţi 
lista notelor, selectaţi-o pe cea dorită, daţi clic-dreapta pe aceasta, şi apoi selectaţi Editare 
(Edit) pentru a afişa dialogul Editare notă.

Dialogul Editare notă seamănă cu dialogul Inserare notă, dar există în plus butoanele de 
înainte/ înapoi dacă în document există introdusă mai mult de o singură notă.

PONT Puteţi modifica culoarea balizei folosind dialogul Unelte > Opţiuni > 
OpenOffice.org > Afişare (Tools > Options > OpenOffice.org > Appearance).

Acceptarea sau respingerea modific rilor şi aă  
comentariilor

1) Apăsaţi Editare > Modificări > Acceptă sau Respinge (Edit > Changes > Accept or 
Reject). Se va deschide dialogul Acceptă sau respinge modificările (Accept or Reject 
Changes - Imaginea 73).

2) Când selectaţi o modificare în caseta de dialog textul corespunzător din document este 
subliniat, astfel încât puteţi observa ce editaţi.
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3) Apăsaţi Acceptă (Accept) ori Respinge (Reject) pentru a accepta sau a respinge 
modificările selectate. Puteţi de asemenea apăsa Acceptă tot (Accept All) ori Respinge 
tot (Reject All) dacă nu doriţi să examinaţi modificările una câte una.

Imaginea 73: Categoria Listă (List) a dialogului Acceptă sau respinge modificările.

Modificările care nu au fost încă acceptate sau respinse vor fi afişate în această listă. 
Modificările acceptate vor fi şterse din listă şi vor fi afişate în textul din document fără nici un 
fel de semnalizare.

Pentru a afişa numai modificările efectuate de anumite persoane, sau în funcţie de zile ori ate 
criterii folosiţi categoria Filtru (Filter) a dialogului. După ce veţi specifica criteriile dorite 
comutaţi înapoi la categoria Listă pentru a vedea ce modificări îndeplinesc criteriile fixate.

Formatarea paginilor

Writer vă oferă câteva metode pentru a controla aspectul paginii:

• Stilurile de pagină

• Coloanele

• Cadrele

• Tabelele

• Secţiunile

Pentru mai multe informaţii, citiţi capitolul omonim (“Formatting Pages”) din Ghidul Writer.

PONT Modificarea aspectului paginii este de obicei uşurată dacă veţi selecta să fie afişate 
textul, obiectele, tabelele şi limitele secţiunilor de la Unelte > Opţiuni > 
OpenOffice.org > Afişare (Tools > Options > OpenOffice.org > Appearance), 
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precum şi sfârşitul paragrafelor, taburile, spaţierile şi alte elemente de la Unelte > 
Opţiuni > OpenOffice.org Writer > Asistenţă formatare (Tools > Options > 
OpenOffice.org Writer > Formatting Aids).

Ce tip de aspect s  alege i?ă ţ

Cel mai bun aspect diferă în funcţie de documentul final, şi anume de cum ar trebui să arate 
acesta şi de ce fel de informaţii va conţine. Iată şi câteva exemple.

Pentru o carte similară cu acest ghid de 
utlizare, cu o singură coloană de text, câteva 
imagini, unele neînsoţite de text, altele având 
text lângă ele, veţi folosi stilurile de pagină 
pentru aspectul de bază şi tabele pentru a 
amplasa imaginile însoţite de textul 
explicativ atunci când este necesar.

Pentru un index sau alte documente cu 2 
coloane de text, unde textul se continuă de la 
coloana din stânga la cea din dreapta şi apoi 
la pagina următoare, totul secvenţial (în 
limba engleză este denumit  “snaking 
columns”), veţi folosi stiluri de pagină (cu 2 
coloane). Dacă titlul documentului (pe prima 
pagină) se întinde pe lăţimea întregii pagini 
atunci amplasaţi-l într-o secţiune cu o singură 
coloană.
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Pentru o scrisoare cu un aspect complex, 2 
sau 3 coloane pe pagină, şi unele articole 
care continuă de pe o pagină pe alte pagini 
ulterioare folosiţi stiluri de pagină pentru 
aspectul de bază. Amplsaţi articolele în cadre 
legate şi, dacă este necesar, ancoraţi 
imaginile la poziţii fixe în cadrul paginii.

Pentru un document cu termeni şi traduceri 
care apar unul lângă altul în ceea ce arată ca 
2 coloane, folosiţi un tabel pentru a menţine 
alinierea elementelor, astfel încât puteţi tasta 
în ambele "coloane".

Crearea antetelor şi a subsolurilor

Un antet este zona de la începutul paginii. Subsolul apare la sfârşitul paginii. Informaţiile, ca 
de exemplu numerele de pagini, inserate în cadrul antetelor sau subsolurile apar pe fiecare 
pagină al cărei stil specifică afişarea acestora.

Pentru a insera un antet, apăsaţi Inserare > Antet > Obişnuit (Insert > Header > Default) 
(sau stilul de pagină, dacă nu este cel Obişnuit - Default) după cum se vede în Imaginea 74.
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Imaginea 74:  Inserarea antetelor şi a subsolurilor.

Alte informaţii ca titlurile documentului şi titlurile capitolului sunt în mod uzual amplasate în 
antete sau subsoluri. Aceste elemente trebuiesc adăugate sub formă de câmpuri, pentru ca să 
fie modificate automat de către Writer o dată cu modificarea paginii pe care sunt amplasate. 
Iată şi un exemplu banal.

Pentru a insera titlul documentului în antet:

1) Apăsaţi Fişier > Proprietăţi > Descriere (File > Properties > Description) şi 
introduceţi un titlu pentru documentul dumneavoastră.

2) Adăugaţi un antet (Inserare > Antet > Obişnuit - Insert > Header > Default).

3) Poziţionaţi cursorul în antet.

4) Selectaţi Inserare > Câmpuri > Titlu (Insert > Fields > Title).  Titlul ar trebui să 
apară pe un fundal gri (care însă nu apare la imprimantă şi poate fi dezactivat).

5) Pentru a schimba titlul întregului document reveniţi şi modificaţi textul de la Fişier > 
Proprietăţi > Descriere (File > Properties > Description).

Folosirea câmpurilor este descrisă detaliat în capitolul 14, intitulat "Lucrul cu câmpuri" 
(“Working with Fields”), din Ghidul Writer. 

Penru mai multe informaţii despre antete şi subsoluri citiţi capitolele 4 şi 6 intitulate 
"Formatarea paginilor" (“Formatting Pages”) şi "Introducere în stiluri" (“Introduction to 
Styles”) din Ghidul Writer.
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Numerotarea paginilor

Pentru a numerota paginile în mod automat:

1) Inseraţi un antet sau un subsol, aşa cum am descris mai sus în “Crearea antetelor şi a
subsolurilor” la pagina 107.

2) Poziţionaţi cursorul în antet sau în subsol, acolo unde doriţi să apară antetul sau subsolul 
şi apăsaţi Inserare > Câmpuri > Număr pagină (Insert > Fields > Page Number).

Includerea num rului total de paginiă

Pentru a afişa inclusiv numărul total de pagini (ca de exemplu "pagina 1 din 12"):

1) Tastaţi cuvântul "pagina ", şi apoi inseraţi numărul paginii curente ca mai sus.

2) Tastaţi " din " şi apoi apăsaţi Inserare > Câmpuri > Număr total pagini (Insert > 
Fields > Page Count).

Notă Câmpul Număr total pagini (Page Count) va insera numărul total de pagini din 
document, aşa cum sunt afişate la categoria Statistici (Statistics) din fereastra 
Proprietăţi a documentului (Fişier > Proprietăţi - File > Properties). Dacă însă veţi 
reîncepe numerotarea paginilor în cadrul documentului, s-ar putea ca numărul afişat 
să nu mai fie ceea ce doriţi. Citiţi capitolul 4 intitulat "Formatarea paginilor" 
(“Formatting Pages”) din Ghidul Writer pentru mai multe informaţii.

Reînceperea numerot rii paginiloră

Adesea va trebuie să reîncepeţi numerotarea paginilor de la 1, de exemplu pe pagina următoare 
paginii de titlu sau cuprinsului. În plus, multe documente au numerotări diferite pentru secţiuni 
precum cuprinsul (numerotare cu cifre romane) faţă de restul documentului, numerotat de 
obicei cu cifre arabe, începând de la 1. 

Puteţi reîncepe numerotarea în 2 modalităţi.

Metoda 1 (recomandată):

1) Poziţionaţi cursorul în primul paragraf de pe noua pagină.

2) Apăsaţi Formatare > Paragraf (Format > Paragraph).

3) La categoria Aranjament text (Text Flow) din dialogul Paragraf (Paragraph) (Imaginea
67 de la pagina 100), la secţiunea Întreruperi (Breaks), selectaţi Inserare (Insert) şi 
apoi Cu stil de pagină (With Page Style) şi specificaţi stilul de pagină pe care îl veţi 
folosi.

4) Specificaţi numărul de pagină de la care să se înceapă numerotarea, şi apoi apăsaţi OK.

PONT Metoda 1 este utilă şi pentru numerotarea primei pagini din document cu un număr 
mai mare de 1. De exemplu, puteţi să scrieţi o carte cu fiecare capitol în fişiere 
separate. Capitolul 1 va porni de la pagina 1, dar capitolul 2 va porni de la pagina 25 
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şi capitolul 3 de la pagina 51.

Metoda 2:

1) Inserare > Întrerupere manuală (Insert > Manual break). 

2) În mod obişnuit Întrerupere de pagină (Page break) este selectată în dialogul Inserare 
întrerupere (Insert Break) (Imaginea 75).

Imaginea 75: Restartarea numerotării paginii după o întrerupere manuală de pagină.

3) Alegeţi ce Stil (Style) de pagină aveţi nevoie.

4) Bifaţi Schimbă numărul paginii (Change page number).

5) Specificaţi numărul de la care să înceapă numerotarea paginilor, şi apoi apăsaţi OK.

Schimbarea dimensiunii şi marginilor paginii

Puteţi modifica marginile paginii în 2 modalităţi:

• Folosind riglele de pe pagină—este facil, dar nu aveţi un control precis.

• Folosind dialogul Stil pagină (Page Style)—puteţi specifica dimensiunile marginilor cu 
precizie de 2 zecimale.

Notă Dacă modificaţi marginile folosind riglele, noile setări vor afecta stilul de pagină şi 
vor fi afişate în dialogul Stilul paginii când îl veţi deschide.

Pentru a schimba marginile folosind riglele:

1) Segmentele gri ale riglelor sunt marginile (vedeţi Imaginea 76). Poziţionaţi mausul 
deasupra liniei care separă secţiunea gri de cea albă; acesta se va schimba într-o săgeată 
dublă.

2) Ţineţi apăsat butonul stâng al mausului şi trageţi marginea cu mausul.
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Imaginea 76: Mutarea marginilor.

PONT Micile triunghiuri de pe riglă sunt folosite pentru indentarea paragrafelor. Acestea de 
obicei coincid cu marginile paginii, astfel încât va trebui să fiţi atenţi să deplasaţi 
marginea paginii, şi nu indicatorii de indentare. Plasaţi mausul între triunghiuri şi, când 
cursorul acestuia se va transforma în săgeata dublă, mutaţi marginea paginii 
(triunghiurile de indentare se vor muta o dată cu aceasta).

Pentru a modifica marginile sau dimensiunea (formatul) paginii folosind dialogul Stilul paginii 
(Page Style):

1) Daţi clic-dreapta oriunde pe pagină şi selectaţi Pagină (Page) din meniul contextual.

2) La categoria Pagină (Page) din dialogul ce este afişat, tastaţi dimensiunile dorite în 
câmpurile de Margini (Margins). Puteţi şi să selectaţi formatul dorit (de exemplu, A4).
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Ce este Calc?

Ce este Calc?

Calc este componenta de calcul tabelar din suita OpenOffice.org (OOo). Puteţi introduce date - 
de obicei date numerice - într-o foaie de calcul şi apoi să lucraţi cu aceste date pentru a vă face 
treaba.

Alternativ puteţi introduce date şi apoi să le folosiţi în Calc pentru a face diverse teste sau a 
vedea rezultatul unor ipoteze, deoarece după introducerea noilor date puteţi observa rezultatul 
fără a reintroduce restul datelor.

Foi de calcul, pagini şi celule

Calc lucrează cu elemente numite foi de calcul (spreadsheets). Acestea cuprind un număr de 
pagini (sheets) individuale, fiecare conţinând un bloc de celule dispuse în rânduri şi coloane.

Aceste celule păstrează elementele individuale —text, numere, formule etc.—pe baza cărora se 
fac calculele şi se determină ce se va afişa pe ecran.

Fiecare foiae de calcul poate avea multe pagini iar fiecare pagină poate avea multe celule 
individuale. Fiecare pagină din Calc poate să aibă maximum 65,536 rânduri şi maximum 245 
coloane (numerotate de la A la IV). Aceasta înseamnă 16,056,320 de celule individuale per 
pagină.

Elementele din fereastra principal  Calcă

Când Calc este pornit, fereastra aplicaţiei arată ca în Imaginea 77.

Imaginea 77: Elementele ferestrei Calc.
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Elementele din fereastra principal  Calcă

Bara Formulă
În partea stângă a barei Formulă (vedeţi Imaginea 78) este un câmp de text, numit Nume 
(Name), care conţine o literă şi un număr, de exemplu D7.  Acestea indică rândul şi coloana 
celulei curente (care mai este denumită celulă de referinţă).

Imaginea 78. Bara Formulă.

La dreapta câmpului Nume sunt Vrăjitorul Funcţie şi butoanele Sumă şi Funcţie.

Dacă daţi clic pe Vrăjitorul Funcţie (Function Wizard) se va deschide o casetă de dialog 
unde puteţi căuta prin lista funcţiilor disponibile. Este de obicei foarte folositoare, mai ales că 
arată şi cum sunt formatate funcţiile.

Butonul Sumă (Sum) inserează în celula curentă o formulă care calculează suma celulelor de 
deasupra sau, dacă celula de deasupra nu conţine numere, cele de la stânga.

Butonul Funcţie (Function) inserează semnul egal în celula selectată şi în Linia de 
introducere, celula fiind astfel pregătită să accepte o formulă.

Pe timpul cât introduceţi date noi într-o celulă ce deja conţinea ceva, butoanele Sumă (Sum) şi 
Egal (Equals) sunt înlocuite de butoanele Anulează (Cancel) şi Acceptă (Accept)  .

Conţinutul celulei curente (date, formule sau funcţii) este afişat în câmpul Linia de introducere 
(Input Line), care face parte din bara Formulă. Puteţi edita conţinutul celulei curente direct în 
acest câmp, sau puteţi să editaţi în celula curentă. Pentru a edita în Linia de introducere, daţi 
clic-stânga unde doriţi să poziţionati cursorul în cadrul textului din Linia de introducere, apoi 
puteţi să scrieţi. Pentru a edita celula curentă este suficient să daţi dublu-clic pe aceasta.

Celule individuale
Cea mai mare parte a ecranului afişează celulele sub forma unei grile, fiecare celulă fiind 
situată la intersecţia dintre un rând şi o coloană.

Deasupra coloanelor şi în partea stângă a rândurilor sunt o serie de celule gri conţinând litere şi 
numere. Acestea sunt capetele de coloană şi de rând. Coloanele încep cu 'A' şi cresc spre 
dreapta, rândurile încep cu '1' şi cresc în jos.
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Elementele din fereastra principal  Calcă

Cotoarele paginilor (Sheet tabs)
În partea de jos a fiecărei pagini, sub reţeaua de celule, sunt cotoarele paginilor (vedeţi 
Imaginea 79). Aceste cotoare oferă accesul la fiecare pagină, iar cotorul paginii active - cea 
vizualizată pe ecran - este alb.

Dacă daţi clic pe alt cotor se va afişa pagina corespunzătoare, iar cotorul va deveni alb. Puteti 
deasemenea să selectaţi mai multe cotoare simultan ţinând apăsată tasta Control în timp ce daţi 
clic cu mausul pe cotoare.

Imaginea 79. Cotoarele paginilor (Sheet tabs).

Administrarea fişierelor

Crearea unor noi foi de calcul
Puteţi crea o nouă foaie de calcul pentru Calc din oricare componentă a suitei OOo. De 
exemplu, o foaie de calcul poate fi creată din Writer sau Draw.

• Din meniul Fişier—Daţi clic pe meniul Fişier (File) şi apoi selectaţi Nou > Foaie de 
calcul (New > Spreadsheet).

• Din panoul cu unelte—Folosiţi butonul Document nou (New Document)   de pe 
bara de unelte Standard. Apăsaţi săgeata derulantă pentru a afişa lista tipurilor de 
documente (text, foi de calcul, etc.). Apăsaţi direct pe buton pentru a crea un nou 
document, tipul documentului fiind indicat de pictograma de pe buton. 

• De la tastatură—Dacă tocmai editaţi într-o foaie de calcul puteţi apăsa Control+N 
pentru a crea o altă foaie de calcul.

Deschiderea foilor de calcul existente
O foaie de calcul poate fi deschisă de asemenea din oricare componentă OOo vă aflaţi.

• Din meniul Fişier—Daţi clic pe meniul Fişier (File) şi apoi selectaţi Deschide (Open).

• Din bara de unelte—Daţi clic pe butonul Deschide (Open)  de pe bara de unelte 
Standard.

• De la tastatură—Apăsaţi Control+O.

Oricare dintre aceste opţiuni deschide caseta de dialog Deschide (Open) , unde puteţi regăsi 
foaie de calcul (fişierul) pe care doriţi să o deschideţi.
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Salvarea foilor de calcul
Foile de calcul pot fi salvate în trei modalităţi.

• Din meniul Fişier (File)—Daţi clic pe meniul Fişier (File) şi apoi selectaţi Salvează 
(Save).

• Din bara de unelte—Daţi clic pe butonul Salvează (Save)  de pe bara de unelte 
Funcţii (Function).

• De la tastatură—Apăsaţi Control+S.

Dacă foaia de calcul nu mai fusese salvată, atunci oricare dintre acţiunile de mai sus vor 
conduce la apariţia casetei de dialog Salvează ca (Save As). Aici puteţi specifica numele foii de 
calcul şi unde să fie aceasta salvată.

Deplasarea în foile de calcul

Selectarea unei celule individuale

Folosind mausul

Plasaţi mausul deasupra celulei şi daţi clic-stânga.

Folosind coordonatele celulei

Daţi clic pe săgetuţa de lângă câmpul Nume (Imaginea 78). Coordonatele celulei afişate în 
câmp vor fi evidenţiate. Tastaţi noile coordonate şi apăsaţi Enter. Sau daţi clic în câmpul 
Nume, apoi ştergeţi tot cu tasta Backspace şi apoi tastaţi noile coordonate.

Folosind Navigatorul

Daţi clic pe butonul Navigator  din bara de unelte Standard (sau apăsaţi F5) pentru a afişa 
Navigatorul. Tastaţi coordonatele celulei în cele două câmpuri de sus, denumite Coloană 

(Column) şi Rând (Row), şi apăsati Enter. În Imaginea 80 Navigatorul va selecta celula F5.
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Imaginea 80. Navigatorul din 
Calc.

Deplasarea de la o celul  la altaă

În foaia de calcul, o celulă (este posibil să fie şi mai multe) are o margine neagră mai evidentă. 
Această margine indică unde este focusul (vedeţi  Imaginea 81).

 
Imaginea 81. (Stânga) O singură celulă şi (dreapta) un grup de celule selectate.

Folosind tastele Tab şi Enter

• Apăsarea Enter sau Shift+Enter mută focusul în jos sau în sus, respectiv.

• Apăsarea Tab sau Shift+Tab mută focusul la dreapta sau la stânga, respectiv.

Folosind tastele cursor

Apăsarea tastelor cursor mută focusul în direcţia săgeţilor.
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Folosind tastele Home, End, Page Up şi Page Down

• Home mută focusul la începutul rândului.

• End mută focusul la coloana ce conţine date situată cel mai la dreapta.

• Page Down vizualizează celulele aflate un ecran mai jos, iar Page Up pe cele aflate cu 
un ecran mai sus.

• Combinations of Control and Alt with Home, End, Page Down, Page Up, and the cursor 
keys move the focus of the current cell in other ways.

PONT Dacă ţineţi apăsate Alt+tastă cursor redimensionaţi celula.

Mutarea de la o pagin  la altaă

Fiecare pagină dintr-o foaie de calcul este independentă de celelalte, deşi pot fi create referinţe 
între pagini. Sunt trei modalităţi de a naviga între diferitele pagini dintr-o foaie de calcul.

Folosind tastatura

Apăsarea Control+PgDn mută o pagină la dreapta iar apăsarea Control+PgUp mută o pagină 
la stânga.

Folosind mausul

Selectaţi o pagină dând clic pe cotorul ei (vedeţi Imaginea 79).

Dacă aveţi multe pagini, cotorul unora nu va putea fi afişat din cauza spaţiului limitat. În acest 
caz, cele patru butoane de la stânga cotoarelor derulează cotoarele prin zona vizibilă. Imaginea
82 exemplifică aceasta.

Imaginea 82. Butoanele cu săgeţi de lângă 
cotoare.

Observaţi că paginile nu sunt numerotate ordonat, ci au diferite denumiri. Puteţi să le denumiţi 
după bunul plac.

Notă Butoanele cu săgeţi din Imaginea 82 apar numai dacă nu pot fi afişate toate cotoarele. 
Altfel vor apărea dezactivate ca în Imaginea 79.
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Selectarea elementelor unei pagini sau ale 
unei foi de calcul

Selectarea celulelor
Celulele pot fi selectate într-o varietate de combinaţii şi de cantităţi.

O singur  celulă ă

Daţi clic - stânga în celulă. Rezultatul va arăta ca în partea din stânga din Imaginea 81. Puteţi 
să verificaţi selecţia privind la câmpul Nume.

Bloc continuu de celule

Un bloc de celule pot fi selectate folosind tastatura sau mausul.

Pentru a selecta un bloc de celule prin tragere cu mausul:

3) Daţi clic într-o celulă.

4) Apăsaţi şi ţineţi apăsat butonul stâng al mausului.

5) Deplasaţi mausul pe ecran.

6) După ce aţi selectat blocul de celule dorit, eliberaţi butonul mausului.

Pentru a selecta un bloc de celule cu mausul fără tragere:

1) Daţi clic într-o celulă care va fi colţul viitorului bloc.

2) Deplasaţi mausul la colţul din diagonală al blocului de celule dorit.

3) Apăsaţi tasta Shift şi daţi clic.

Pentru a selecta un bloc de celule fără a folosi mausul:

1) Selectaţi celula care va fi colţul viitorului bloc.

2) Ţinând apăsată tasta Shift, folosiţi tastele cursor pentru a selecta restul blocului.

Rezultatul oricăreia dintre aceste metode este arătat în partea dreaptă în Imaginea 81.

PONT Puteţi să selectaţi direct blocul de celule folosind câmpul Nume. Daţi clic în câmp 
după cum a fost descris în “Folosind coordonatele celulei” la pagina 117. Pentru a 
selecta un bloc de celule, introduceţi coordonatele celulei din stânga - sus, urmate de 
două-puncte (:), şi apoi coordonatele celulei din dreapta - jos. De exemplu, pentru a 
selecta blocul ale cărui colţuri în diagonală sunt celulele A3 şi C6, introduceţi A3:C6.

Bloc discontinuu de celule

1) Selectaţi o celulă sau un bloc de celule folosind una din metodele de mai sus.

2) Deplasaţi mausul la începutul următorului bloc continuu sau a celulei individuale.

3) Ţineţi apăsată tasta Control şi daţi clic sau ţineţi apăsat butonul mausului şi trageţi 
pentru a selecta un bloc continuu. 
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4) Repetaţi de câte ori este necesar .

Selectarea coloanelor şi a rândurilor
Coloane şi rânduri întregi pot fi selectate foarte repede în OOo.

O singur  coloan  sau rândă ă

Coloanele pot fi selectate dând clic - stânga pe capul de coloană respectiv (vedeţi Imaginea
77).

Daţi clic pe capul de rând pentru a selecta întreg rândul (vedeţi  Imaginea 77).

Coloane şi rânduri multiple

Pentru a selecta coloane sau rânduri multiple care sunt continue:

1) Daţi clic pe prima coloană sau primul rând din grup.

2) Ţineţi apăsată tasta Shift.

3) Daţi clic pe ultima coloană sau ultimul rând din grup.

Pentru a selecta coloane sau rânduri multiple care nu sunt continue:

1) Daţi clic pe prima coloană sau primul rând din grup.

2) Ţineţi apăsată tasta Control.

3) Daţi clic pe următoarea coloană sau următorul rând din grup, ţinând apăsată tasta 
Control.

Toat  paginaă

Dacă doriţi să selectaţi toate celulele de pe pagină puteţi să daţi clic pe micul pătrat de la 
intersecţia capetelor de coloană cu capetele de rând (langă coloana 'A' şi rândul '1'). Pentru a 
selecta toate celulele de pe pagină cu tastatura apăsaţi Control+A.

Imaginea 83. Căsuţa Selectează tot.

Lucrul cu rânduri şi coloane

Inserarea coloanelor şi a rândurilor
Coloanele şi rândurile pot fi inserate în câteva modalităţi şi cantităţi.
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Lucrul cu rânduri şi coloane

O singur  coloan  sau un singur rândă ă

O singură coloană sau un singur rând pot fi inserate folosind meniul Inserare (Insert):

1) Selectaţi coloana sau rândul unde doriţi ca noua coloană sau noul rând să fie inserate.

2) Selectaţi, după caz, Inserare > Coloană (Insert > Column) ori Inserare > Rând 
(Insert > Row).

Notă Când inseraţi o singură coloană, este inserată la stânga coloanei curente. Când 
inseraţi un rând, este inserat deasupra rândului curent.

O singură coloană sau un singur rând pot fi inserate şi folosind mausul:

1) Selectaţi coloana sau rândul unde doriţi ca noua coloană sau noul rând să fie inserate.

2) Daţi clic - dreapta pe capul coloanei respectiv rândului.

3) Selectaţi Inserare rând (Insert Row) sau Inserare coloană (Insert Column).

Coloane sau rânduri multiple

Coloanele sau rândurile multiple poat fi inserate dintr-o dată, nefiind nevoie să le inseraţi unul 
câte unul.

1) Selectaţi atâtea rânduri sau coloane doriţi să inseraţi, dând clic cu mausul deasupra 
rândului sau coloanei unde doriţi să inseraţi şi ţinând apăsat butonul stânga al mausului.

2) Procedaţi ca atunci când inseraţi un singur rând sau o singură coloană.

Ştergerea coloanelor şi rândurilor
Coloanele şi rândurile pot fi şterse individual sau în grupuri.

O singur  coloan  sau un singur rândă ă

O singură coloană sau un singur rând pot fi şterse folosind mausul:

1) Selectati coloana sau rândul de şters.

2) Daţi clic - dreapta pe capul de rând sau coloană.

3) Selectaţi Şterge coloana (Delete Column) sau Şterge rândul (Delete Row) din meniul 
contextual.

O singură coloană sau un singur rând pot fi şterse folosind meniul Editare (Edit):

1) Selectaţi o celulă din coloana sau rândul pe care le doriţi şterse.

2) Selectaţi Editare > Şterge celule (Edit > Delete Cells), unde puteţi selecta ce anume 
doriţi să ştergeţi: Mută celulele în sus (Shift Cells Up), Mută celulele la stânga (Shift 
Cells Left), Şterge rândul sau rândurile (Delete entire row(s)), Şterge coloana sau 
coloanele (Delete entire column(s)).
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Coloane sau rânduri multiple

Coloanele sau rândurile multiple pot fi şterse dintr-o dată, nefiind necesar să fie şterse unul 
câte unul.

1) Daţi clic - stânga cu mausul deasupra primului rând, respectiv deasupra primei coloane 
şi deplasaţi mausul deasupra rândurilor sau coloanelor pe care doriţi să le ştergeţi. 
Acestea vor fi selectate.

2) Procedaţi ca mai sus, atunci când ştergeţi un singur rând sau o singură coloană.

Lucrul cu pagini

Ca şi orice alt element din Calc, paginile pot fi inserate, şterse şi redenumite.

Inserarea unei pagini noi
Sunt mai multe modalităţi de a insera o nouă pagină. Primul pas în toate cazurile este să 
selectaţi pagina lângă care va fi inserată noua pagină. Apoi următoarele variante pot fi folosite:

• Daţi clic pe meniul Inserare (Insert), şi selectaţi Pagină (Sheet), sau

• Daţi clic - dreapta pe cotor şi selectaţi Inserare pagină (Insert Sheet), sau

• Daţi clic într-un spaţiu gol de după ultimul cotor (vedeţi Imaginea 84).

Imaginea 84. Crearea unei noi pagini.

Fiecare metodă va deschide caseta de dialog Inserare pagină (Insert Sheet) (Imaginea 85). De 
aici puteţi selecta dacă inserţia se va face înainte sau după pagina curentă şi câte pagini vreţi să 
inseraţi. Dacă veţi insera numai una singură atunci veţi putea să o şi denumiţi.
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Lucrul cu pagini

Imaginea 85. Caseta de dialog Inserare pagină (Insert Sheet).

Ştergerea paginilor
Paginile pot fi şterse individual sau în grupuri.

O singur  pagină ă

Daţi clic - dreapta pe cotorul paginii pe care doriţi să o stergeţi şi selectaţi Şterge (Delete) din 
meniul contextual.

Mai multe pagini

Pentru a şterge mai multe pagini, selectaţi-le cum am descris mai sus, daţi clic - dreapta pe 
unul dintre cotoare şi selectaţi Şterge (Delete) din meniul contextual.

Redenumirea paginilor
Numele de început pentru fiecare pagină este de forma “SheetX”, unde X este un număr. Dacă 
aceasta este acceptabil pentru o foaie de calcul cu puţine pagini, devine incomod când numărul 
de pagini este mai mare.

Pentru a da unei pagini un nume semnificativ, puteţi face următoarele:

• Introduceţi numele în câmpul de nume atunci când creaţi pagina, sau

• Daţi clic - dreapta pe un cotor şi selectaţi Redenumeşte pagina (Rename Sheet) din 
meniul contextual şi înlocuiţi numele existent cu unul mai potrivit.

Notă Numele paginilor trebuie să înceapă fie cu o literă fie cu un număr; alte caractere 
(inclusiv spaţiile) nu sunt permise. Următoarele caractere pot fi litere, cifre, spaţii şi 

124 Capitolul 7  Ini iere în Calc:ţ



Lucrul cu pagini

liniuţă_jos. Tentativa de a introduce caractere interzise va produce un mesaj de 
eroare.

Vizualizare în Calc

Fixarea rândurilor şi coloanelor
Fixarea vizează un număr de rânduri şi/sau de coloane, obligatoriu cele de la începutul paginii. 
Apoi, când deplasaţi cursorul, rândurile şi coloanele fixate îşi vor păstra locul pe ecran, 
rămânând astfel vizibile.

Imaginea 86 arată câteva rânduri şi coloane fixate. Linia orizontală mai groasă dintre rândurile 
3 şi 14 şi cea verticală dintre coloanele C şi H delimitează zonele. Rândurile de la 4 la 13 şi 
coloanele de la D la G au fost îndepărtate de pe ecran prin derularea paginii. Deoarece primele 
trei rânduri şi primele trei coloane au fost fixate, ele sunt păstrate în fereastră.

Imaginea 86. Rânduri şi coloane fixate.

Puteţi stabili punctul de fixare atât pe rânduri cât şi pe coloane, separat pe fiecare, după cum se 
vede în Imaginea 86.

Fixarea unui singur rând sau a unei singure coloane

1) Daţi clic pe capul rândului sub care doriţi fixarea sau pe cel al coloanei la dreapta căreia 
doriţi fixarea.

2) Selectaţi Fereastră > Fixare (Window > Freeze).

O linie întunecata va marca locul fixării.

Capitolul 7  Ini iere în Calc:ţ 125



Vizualizare în Calc

Fixarea unui rând şi a unei coloane

1) Daţi clic în celula situată imediat sub rândul pe care îl doriţi fixat şi imediat la dreapta 
coloanei pe care o doriţi fixată.

2) Selectaţi Fereastră > Fixare (Window > Freeze).

Veţi observa pe ecran apariţia a două linii, una orizontală deasupra acestei celule şi alta 
verticală la stânga ei. După aceasta, dacă veţi derula ecranul, celulele aflate deasupra şi 
respectiv la stânga liniilor vor rămâne pe loc, fiind vizibile.

Încetarea fix riiă

Pentru a înceta fixarea rândurilor sau coloanelor, selectaţi Fereastră > Fixare (Window > 
Freeze). Liniile de delimitare a zonei fixate vor dispare.

Împ r irea ferestreiă ţ

Altă modalitate de a schimba vizualizarea celulelor este de a împărţi fereastra – operaţiune 
denumită şi împărţirea ecranului. Ecranul poate fi împărţit orizontal, vertical sau în ambele 
moduri. Aceasta vă permite să aveţi maxim patru zone din pagină vizibile permanent.

De ce să faceţi aceasta? Îmaginaţi-vă că aveţi o pagină foarte mare şi una dintre celule conţine 
un număr folosit de trei formule, situate bineînţeles în alte celule. Folosind împărţirea 
ecranului, puteţi poziţiona celula cu numărul într-una din zonele vizibile şi fiecare dintre cele 
trei formule în câte o altă zonă vizibilă. Apoi puteţi să schimbaţi numărul din prima celulă şi să 
vedeţi cum sunt afectate celelalte celule.

Imaginea 87. Exemplu de împărţire a ferestrei.
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Împ r irea ecranului pe orizontală ţ ă

Pentru a împărţi ecranul pe orizontală:

1) Deplasaţi mausul în bara de derulare verticală, pe partea dreaptă a ecranului, şi plasaţi-l 
peste micul buton de sus cu un triunghi negru.

Imaginea 88. Linia de împărţire a ecranului 
deasupra barei verticale de derulare.

2) Imediat deasupra acestui buton observaţi o linie groasă neagră (Imaginea 88). Mutaţi 
mausul deasupra acestei linii şi se va transforma într-o linie cu două săgeţi.

3) Ţineţi apăsat butonul mausului şi va apărea o linie gri, de-a latul întregii pagini. Trageti 
mausul în jos şi această linie va coborâ şi ea.

4) Eliberaţi butonul mausului şi ecranul va fi împărţit în două zone, fiecare cu propria ei 
bară de derulare pe verticală. 

Observaţi în Imaginea 87 că valorile ‘Beta’ şi ‘A0’ sunt situate în partea de sus a ferestrei şi 
celelalte formule în partea de jos. Puteţi derula cele două zone independent. Astfel puteţi 
ajunge la valorile Beta şi A0 şi să urmăriţi efectele schimbării lor asupra formulelor din partea 
de jos a ecranului.

Puteţi de asemenea să împărţiţi ecranul pe verticală procedând după cum vom explica mai jos – 
cu aceleaşi rezultate, să fiţi capabil să derulaţi amble zone ale ecranului independent. Dacă 
realizaţi şi împărţirea verticală şi cea orizontală, veţi avea patru ferestre independente.

Împ r irea ecranului pe verticală ţ ă

Pentru a împărţi ecranul pe verticală:

1) Deplasaţi mausul la bara de derulare orizontală din partea de jos a ecranului şi plasaţi-l 
deasupra micului buton din stânga cu triunghiul negru.

Imaginea 89: Linia de împărţire pe bara de derulare orizontală.

2) Imediat la dreapta acestui buton veţi observa o linie groasă neagră (Imaginea 89). 
Deplasaţi mausul deasupra acestei linii şi se va transforma într-o linie cu două săgeţi.

3) Ţineti apăsat butonul stâng al mausului şi o linie gri va apărea, de-a lungul paginii. 
Trageţi mausul spre stânga şi această linie se va deplasa şi ea.
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4) Eliberaţi butonul mausului şi ecranul se va împărţi în două zone, fiecare cu propria bară 
de derulare orizontală.

Notă Împărţirea ecranului simultan pe orizontală şi pe verticală va genera patru zone, 
fiecare cu propriile bare de derulare pe orizontală şi pe verticală.

Înl turarea împ r irii ecranuluiă ă ţ

• Daţi dublu - clic pe fiecare linie de împărţire, sau

• Trageţi cu mausul liniile de împărţire înapoi la locurile lor de lângă barele de derulare, 
sau

• Selectaţi Fereastră > Împărţire (Window > Split). Aceasta va îndepărta toate liniile de 
împărţire existente.

PONT Puteţi de asemenea să împărţiţi ecranul folosind meniul. Selectaţi o celulă care este 
prima de dedesubtul şi prima la dreapta punctului de împărţire a ecranului, şi selectaţi 
Fereastră > Împărţire (Window > Split).

Introducerea datelor într-o pagină

Introducerea numerelor
Selectaţi celula şi tastaţi cifrele folosind fie tastele corespunzătoare de pe tastură fie cele de pe 
anexa numerică a tastaturii.

Pentru a introduce un număr negativ, fie tastaţi un semn de minus (–) în faţa sa fie îl închideţi 
în paranteze ( ).

În mod obisnuit numerele sunt aliniate la dreapta iar numerele negative au un minus în faţă.

Introducerea textului
Selectaţi celula şi tastaţi textul. Textul este aliniat în mod obişnuit la stânga.

Introducerea numerelor ca text
Dacă numărul este introdus cu un 0 în faţă (01481), Calc va îndepărta zeroul. Pentru a păstra 
acel zero (de exemplu în cazul codurilor din numerele pentru telefon), precedaţi numărul cu un 
apostrof, astfel: '01481. Totuşi, data este privită acum de Calc ca fiind un text. Operaţiile 
aritmetice nu vor putea fi aplicate, fiind fie ignorată fie producând o eroare.

Notă Când veţi introduce un apostrof pentru a permite afişarea unui zero la început, 
apostroful nu va fi vizibil în celulă după ce veţi apăsa Enter numai dacă este un 
apostrof ordinar (nu unul de tip “ghilimele inteligente”). Tipul apostrofului este 
selectat din meniu la Unelte > AutoCorectare > Ghilimele personalizate (Tools > 
Autocorrect > Custom Quotes). Selecţia va afecta Calc şi Writer. Dacă “ghilimele 
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inteligente (smart quotes)” vor fi selectate ca apostrof, acesta va rămâne vizibil în 
celulă şi după apăsarea tastei Enter.

PONT Numerele pot avea zerouri ca primă cifră şi să fie tratate ca text dacă celulele sunt 
formatate corespunzător. Daţi clic - dreapta pe o celulă şi alegeţi Formatare celule > 
Numere (Format Cells > Numbers). Modificaţi opţiunea referitoare la zerouri şi 
specificaţi câte zerouri să fie afişate la început.

Introducerea datei şi orei
Selectaţi celula şi tastaţi data sau ora. Puteţi separa elementele cu o bară (/) sau cu o cratimă (–) 
sau să tastaţi ceva gen 10 Oct 03. Calc recunoaşte o largă varietate de formate de dată. 
Elementele orei le separaţi cu două puncte, ca de exemplu 10:43:45.

Imprimarea

OpenOffice.org Calc vă oferă un sistem de imprimare performant, foarte flexibil şi deosebit de 
configurabil. Multe detalii pot fi configurate să fie sau să nu fie imprimate. Puteţi să specificaţi 
ordinea de tipărire a paginilor, ca şi mărimea lor. Anumite rânduri sau coloane pot fi tipărite pe 
toate paginile şi puteţi specifica o arie pentru tipărire.

Imprimarea unei foi de calcul
Pentru a imprima o foaie de calcul, indiferent că o trimiteţi la o imprimantă sau într-un fişier, 
alegeţi Fişier > Imprimare (File > Print). Caseta de dialog Imprimare (Print) (Imaginea 90)
permite modificarea setărilor specifice imprimantei. Obiectul tipăririi poate fi stabilit foarte 
rapid din această casetă de dialog: tot documentul, anumite pagini sau blocul de celule 
selectate. Numărul copiilor, cum să fie sortate copiile sunt de asemenea stabilite aici. Apăsaţi 
OK pentru a imprima.
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Imaginea 90. Caseta de dialog Imprimare (Print).

Op iunile de imprimareţ

Opţiunile de imprimare pot fi stabilite numai pentru documentul curent sau pentru toate 
documentele. Dacă doriţi să stabiliţi aceste opţiuni numai pentru documentul curent, alegeţi 
butonul Opţiuni (Options) din partea de jos - stânga. Dacă doriţi ca aceste opţiuni să se aplice 
şi celorlalte documente, alegeţi Unelte > Opţiuni > OpenOffice.org Calc > Imprimare 
(Tools > Options > OpenOffice.org Calc > Print). Casetele de dialog pentru ambele sunt 
similare. Vedeţi Imaginea 91.

Selectarea paginilor de imprimat
Puteţi selecta pentru imprimare una sau mai multe pagini. Aceasta poate fi folositor daca aveţi 
o foaie de calcul cu multe pagini şi nu doriţi să imprimaţi toate paginile. Dacă aveţi de 
exemplu o foaie de calcul cu câte o pagina pentru fiecare lună, şi doriţi să imprimaţi numai 
luna Noiembrie, urmaţi aceşti paşi:

5) Selectaţi paginile pe care le doriţi imprimate. (Apăsaţi tasta Control în timp ce dati clic 
pe fiecare cotor pentru a selecta mai multe pagini.)

6) Alegeţi Fişier > Imprimare (File > Print) şi selectaţi Opţiuni (Options).

Notă Butonul Opţiuni (Options) este diferit de butonul Proprietăţi (Properties). 
Proprietăţi are de a face cu setările referitoare la imprimantă, pe când Opţiuni se 
referă la imprimarea documentelor OOo.

7) Bifaţi căsuţa Imprimă numai paginile selectate (Print only selected sheets). Apăsaţi 
OK.
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Imaginea 91. Caseta de dialog Opţiunile de imprimare (Printer Options).

Ajustarea ariei deimprimat

Imprimarea rândurilor sau coloanelor pe fiecare 
pagină

Dacă o pagină din foaia de calcul va fi imprimată pe mai multe pagini de hârtie, anumite 
rânduri sau coloane pot fi alese pentru a fi imprimate pe fiecare pagină tipărită.

Ca un exemplu, dacă primele două rânduri şi prima coloană de pe pagină ('A') trebuie să fie 
imprimate pe toate paginile de hârtie, procedaţi astfel:

1) Alegeţi Formatare > Arii imprimare > Editare arie imprimare (Format > Print 
Ranges > Edit Print Range).

2) Va fi afişată caseta de dialog Editare arii imprimare (Edit Print Ranges) (Imaginea 83). 
Daţi clic pe - nimic (none) - din stânga zonei Rânduri de repetat (Rows to repeat), şi 
alegeţi - stabilit de utilizator (user defined) -.

3) În câmpul din centru, scrieţi rândurile care se vor repeta. De exemplu, pentru a repeta 
primele două rânduri, tastaţi $1:$2. (Sau puteţi să apăsaţi în celula A1 şi să o trageţi cu 
mausul în celula A2.)

4) Coloanele pot fi repetate şi ele, aşa că daţi clic pe - nimic (none) - din stânga zonei 
Coloane de repetat (Columns to repeat), şi alegeţi - stabilit de utilizator (user 
defined) -.

5) În câmpul din centru, scrieţi coloanele care se vor repeta. De exemplu, pentru a repeta 
prima coloană ("A"), tastaţi $A. (Sau puteţi apăsa în celula A1.)
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6) Apăsaţi OK.

Imaginea 92. Dialogul Editarea arii imprimare (Edit Print Ranges).

Notă Nu este nevoie s  selecta i toate celule pe care le vre i repetate. Selectarea uneiă ţ ţ  
singure celule de pe fiecare rând pe care îl dori i repetat este suficient .ţ ă

Definirea ariei de imprimare
În mod obişnuit, dacă nu a fost definită nici o arie de imprimare, va fi imprimat întregul 
conţinut al foii de calcul. Dacă doriţi, puteţi însă defini o arie de imprimare. Aceasta poate fi 
folositor dacă, dintr-o foaie de calcul, aveţi nevoie să imprimaţi numai o porţiune din date.

Pentru a defini o arie de imprimare:

1) Marcaţi (prin selectare) blocul de celule care alcătuiesc aria de imprimare.

2) Alegeţi Formatare > Arii imprimare > Definire arie de imprimare (Format > Print 
Ranges > Define Print Range).

Linii marcând separarea paginilor de hârtie vor fi afişate pe ecran.

Notă Puteţi verifica aria de imprimare folosind Fişier > Previzualizare pagină (File > 
Page Preview). OOo va afişa numai celulele din aria de imprimare.

Extinderea ariei de imprimare
După ce aţi definit o arie de imprimare puteţi adăuga şi alte celule. Aceasta vă va permite să 
imprimaţi mai multe zone de celule, chiar şi discontinue, în condiţiile în care nu vreţi să 
imprimaţi întreaga pagină. După ce aţi definit o arie de imprimare:

1) Selectaţi celulele pe care doriţi să le adăugaţi.

2) Alegeţi Formatare > Arii imprimare > Extinde aria de imprimare (Format > Print 
Ranges > Add Print Range).

Aceasta va adăuga noile celule selectate la aria de imprimare.

Vor dispare de pe ecran liniile marcând separarea paginilor de hârtie.
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Notă Celulele adăugate ariei de imprimare se vor imprima pe altă pagină de hârtie, 
chiar dacă aparţin aceleiaşi pagini din foaia de calcul.

Anularea ariei de imprimare
Poate deveni necesar să renunţaţi la aria de imprimare, de exemplu daca vă hotărâţi să 
imprimaţi toată pagina din foaia de calcul.

Pentru a renunţa complet la aria de imprimare, alegeţi Formatare > Arii imprimare > 
Anulează aria de imprimare (Format > Print Ranges > Clear Print Range).

Aceasta va anula toate ariile de pe imprimare definite pentru pagina respectivă.

După ce aria de imprimare este anulată pe ecran vor fi marcate sfârşiturile de pagină obişnuite.
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Ce este Draw?

Ce este Draw?

Draw este un program pentru desenarea de grafică vectorială. Vă oferă o suită de unelte 
performante care vă permit crearea rapidă de grafică de orice fel. Grafica vectorială descrie şi 
afişează o imagine prin vectori (două puncte şi o linie) în loc de un număr de pixeli (punctele 
de pe ecran). Grafica vectorială uşurează astfel memorarea şi redimensionarea unei imagini.

Draw este integrat perfect în suita OpenOffice.org, şi aceasta face ca schimbarea graficii cu 
celelalte componente să fie foarte facilă. De exemplu, dacă creaţi o imgine în Draw, o puteţi 
folosi într-un document Writer cu o simplă copiere şi lipire. Puteţi să folosiţi un subset din 
uneltele şi funcţiile din Draw lucrând direct în Writer sau Impress.

Funcţionalitatea lui Draw este largă si completă. Chiar dacă nu a fost conceput pentru a rivaliza 
cu aplicaţiile grafice de vârf, Draw oferă mai multe funcţii decât marea majoritate a 
programelor de desenare care sunt integrate în suite de birou.

Câteva exemple din ce ştie să facă s-ar putea să vă trezească interesul: administrare pe straturi, 
reţea de puncte magnetice, dimensionarea şi măsurarea suprafeţei de afişare, conectori pentru 
alcătuirea de grafice, funcţii 3D pentru crearea de imagini tridimensionale de mici dimensiuni 
(cu texturi şi efecte de iluminare), stiluri de desenare şi de pagină, curbe Bezier, şi multe altele.

Acest capitol prezintă câteva dintre funcţiile şi facilităţile din Draw, dar nu încearcă să le 
descrie pe toate. Pentru mai multe informaţii citiţi Ghidul Draw (Draw Guide) şi consultaţi 
Ajutorul din program.

Locul de muncă

Componentele principale ale interfeţei Draw sunt înfăţişate în Imaginea 93.

Zona mare din centrul ecranului este locul unde veţi alcătui desenele. Este înconjurată de bare 
de unelte şi zone de informare, dar numărul şi poziţionarea lor pot varia în funcţie de cum 
doriţi să vă organizaţi spaţiul de lucru. De exemplu, multe persoane plasează bara de unelte 
principală din Draw pe partea stângă a spaţiului de lucru, nu în partea de jos cum am procedat 
aici.

Barele de unelte
Diversele bare cu unelte din Draw pot fi afişate sau ascunse după cum doriţi.

Pentru a afişa sau a ascundebarele de unelte, apăsaţi Vizualizare > Bare de unelte (View > 
Toolbars). În cadrul meniului care o să apară veţi alege care dintre panouri vor fi afişate.

Puteţi de asemenea selecta care dintre butoane să apară pe panoul aferent. În meniul 
Vizualizare > Bare de unelte (View > Toolbars), selectaţi Personalizare (Customize), 
selectaţi categoria Bare de unelte (Toolbars), selectaţi bare de unelte pe care doriţi să o 
modificaţi, şi apoi selectaţi butoanele dorite pentru acea bară de unelte. Fiecare bară are o listă 
diferită de butoane. Citiţi Capitolul 4 (Meniuri şi bare de unelte) pentru detalii.
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Imaginea 93. Fereastra iniţială din Draw.

Multe butoane de pe barele de unelte sunt marcate cu o mică săgeată în lateral. Această săgeată 
indică faptul că acel buton are şi funcţii adiţionale. Apăsaţi săgeata respectivă şi va apare un 
submeniu sau o bară detaşabilă, afişând funcţiile adiţionale (vedeţi Imaginea 94).

Imaginea 94 O săgeată în lateralul unui buton indică funcţii adiţionale.

S-ar putea să doriţi să păstraţi acest submeniu pe ecran, dar în altă poziţie decât cea obişnuită. 
Puteţi transforma acest submeniu într-o bară flotantă (floating toolbar). Pentru a face aceasta, 
apăsaţi cu mausul bara de titlu a submeniului, trageţi-o în poziţia dorită şi apoi eliberaţi 
butonul mausului. Barele flotante pot fi andocate pe marginea ecranului sau în cadrul unei zone 
cu bare de unelte din partea de sus a ecranului, aceste aspecte fiind descrise în Capitolul 4.
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Notă Majoritatea butoanelor marcate cu o mică săgeată pot deveni panouri detaşabile. 
Detaşarea unui panou este o facilitate comună pentru toate componentele 
OpenOffice.org.

Apăsaţi pe săgeata de pe bara de titlu a unei bare flotante pentru a afişa funcţiile suplimentare 
(vedeţi Imaginea 95).

Imaginea 95. O săgeată pe o bară flotantă indică prezenţa funcţiilor 
suplimentare.

Uneltele disponibile în diversele panouri sunt explicate în secţiunile următoare.

Bara de unelte Standard
Bara de unelte Standard arată astfel:

Aceasta este aceeaşi pentru toate componentele din OpenOffice.org.

Bara de unelte Linie şi umplere
Bara de unelte Linie şi umplere (Line and Filling) vă permite să modificaţi principalele 
caracteristici ale unui obiect tip desen. Citiţi la pagina 153 pentru detalii.

Dacă obiectul selectat este text, bara de unelte se schimbă în cea de mai jos, care este similară 
cu bara Formatare din Writer.
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Bara de unelte Desenare
Bara de unelte Desenare (Drawing) este cea mai importantă din Draw. Acesta conţine toate 
funcţiile necesare pentru trasarea diverselor forme, atât cele geometrice cât şi forme proprii, şi 
organizarea lor în pagină.

Bara Culoare
Pentru a afişa bara Culoare apăsaţi Vizualizare > Bare de unelte > Bara Culoare (View > 
Toolbars > Color Bar). Această bară de unelte va fi afişată în partae de jos a spaţiului de 
lucru.

Aceasta vă permite modificarea rapidă a culorii cu care desenaţi. Prima căsuţă din paletă 
corespunde cu Invizibil (fără culoare).

Paleta de culori obişnuită poate fi modificată folosind Formatare > Zonă (Format > Area), 
după cum veţi vedea în Imaginea 96. Alegeţi categoria numită Culori (Colors).

Imaginea 96. Modificarea paletei de culori

Dacă veţi apăsa pe butonul Încarcă lista de culori (Load Color List), marcat în imagine cu o 
elipsă, caseta de dialog pentru deschiderea fişierelor vă va permite să alegeţi un fişier de paletă 
(aceste fişiere au extensia .soc). Împreună cu OpenOffice.org sunt furnizate mai multe palete 
standard. De exemplu, web.soc este o paletă de culori adaptată pentru desene destinate 
paginilor Web, deoarece culorile vor fi afişate corect şi pe calculatoare cu ecrane care afişează 
în 256 de culori.
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Căsuţa de selectare a culorii de asemenea vă permite să modificaţi paleta, şi anume modificând 
individual fiecare culoare prin modificarea valorilor numerice afişate în dreapta paletei. Puteţi 
să apăsaţi pe Editare (Edit) pentru a afişa o casetă de dialog (arătată în Imaginea 97), uşurând 
alegerea culorilor.

Imaginea 97. Definirea compoziţiei culorii.

Puteţi folosi sistemele de codificare a culorii CMYK (Cyan, Magenta, Yellow, Black), RGB 
(Red, Green, Blue) sau HSB (Hue, Saturation, Brightness).

Bara de unelte Op iuniţ
Acest panou de unelte vă permite activarea sau deactivarea diverselor unelte pentru desenat. 
Acest panou nu este afişat în mod obişnuit, iar pentru a-l afişa selectaţi Vizualizare > Bare de 
unelte > Opţiuni (View > Toolbars > Options).
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Locul de muncă

Utilizarea grilei magnetice
Uneltele de agăţare sunt divizate în 3 grupuri: grila magnetică, liniile de agăţare şi punctele de 
agăţare.

Grila magnetică constă dintr-o reţea de puncte în care pot fi agăţate obiectele. Apăsaţi pe 
butonul Afişare grilă (Display Grid) din bara Opţiuni pentru a afişa grila şi apoi apăsaţi pe 
butonul Agăţare la grilă (Snap to Grid) pentru a o activa. Zona de lucru va fi umplută cu 
puncte, ca în Imaginea 98. Această grilă nu va fi imprimată şi nici nu va apare în fişierele 
exportate, ca de exemplu în PDF-uri.

Când grila este activă formele pot fi aranjate cu uşurinţă folosind punctele ca ghid. În exemplul 
următor, obiectele sunt poziţionate exact pe punctele din grilă.

Imaginea 98: Cu agăţarea de grilă obiectele 
sunt alineate riguros.

Spaţierea dintre puncte este definită la dialogul cu opţiunile privind grila din categoria 
Drawing din opţiunile OOo (Unelte > Opţiuni > OpenOffice.org Draw > Grilă - Tools > 
Options > OpenOffice.org Draw > Grid).
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Locul de muncă

Imaginea 99. Stabilirea caracteristicilor grilei.

Cu ajutorul dialogului din Imaginea 99 puteţi stabili următorii parametri:

• Spaţierea orizontală şi verticală a punctelor din grilă. Puteţi de asemenea modifica şi 
unitatea de măsură utilizată în opţiunile generale Draw (Unelte > Opţiuni > 
Openoffice.org Draw > Grilă > General - Tools > Options > OpenOffice.org Draw 
> Grid > General).

• Rezoluţia reprezintă mărimea pătratelor sau dreptunghiurilor din grilă. Dacă rezoluţia 
este Orizontal 1 cm, Vertical 2 cm, grila constă în dreptunghiuri înalte de 2 cm şi late de 
1 cm.

• Subdiviziunile sunt puncte adiţionale care apar pe marginea fiecărui dreptunghi sau 
pătrat din grilă. Obiectele se agaţă la subdiviziuni la fel de bine ca şi la colţurile grilei.

• Mărimea pixelului din zona de agăţare determină cât de aproape trebuie să aduceţi un 
obiect faţă de un punct sau linie de agăţare pentru a fi agăţat.

În mod obişnuit punctele grilei sunt colorate în gri deschis, o culoare destul de ştearsă. Pentru a 
opta pentru o culoare mai uşor vizibilă mergeţu la Unelte > Opţiuni > OpenOffice.org > 
Afişare (Tools > Options > OpenOffice.org > Appearance) (Imaginea 100).
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Imaginea 100: Modificarea culorii punctelor din grilă.

Sub Culori personalizate (Custom colors), derulaţi în jos până ajungeţi la Desenare/ 
Prezentare (Drawing / Presentation). Apoi stabiliţi culoarea grilei la ceva mai întunecat ca de 
exemplu negru.

Rigle
Ar trebui să vedeţi riglele în partea de sus şi în cea stângă a spaţiului de lucru (vedeţi Imaginea 
101). Acestea arată mărimea obiectelor din pagină. Riglele indică şi cursorul mausului pentru a 
vă ajuta să poziţionaţi obiectele mai precis. Riglele sunt utilizate şi pentru a punctele tip mâner 
şi liniile de captură care uşurează poziţionarea obiectelor.

Imaginea 101. Riglele într-un desen.

Marginile paginii din zona de desenare sunt şi ele reprezentate pe rigle. Puteţi modifica 
marginile direct din rigle prin tragere cu mausul. Pentru a modifica unitatea de măsură a 
riglelor daţi clic - dreapta pe oricare dintre ele. Fiecare riglă are propria ei unitate de măsură.

Bara Stare
Bara de Stare (Status Bar) este poziţionată în partea de jos a ecranului. Pentru Draw este 
relevantă în mod deosebit partea de mijloc.
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Mărimile sunt date în unitatea de măsurare curentă (a nu se confunda cu unităţile folosite de 
rigle). Această unitate este definită în Unelte > Opţiuni > OpenOffice.org Draw > General 
(Tools > Options > OpenOffice.org Draw > General), unde puteţi să modificati şi factorul 
de scalare Un alt mod de modificare a scalării este de a da dublu - clic pe numărul arătat în 
bara Stare.

Formele de desenare primare

Draw furnizează o gamă largă de forme, puse în palete accesibile din bara de unelte Desenare. 
Acest capitol descrie numai câteva dintre acestea; citiţi Ghidul Draw (Draw Guide) pentru o 
descriere completă a formelor disponibile. Aceste forme inclus dreptunghiuri şi pătrate; 
cercuri, elipse, arcuri; obiecte 3D; curbe; linii şi săgeţi; text şi conectori.

Trasarea unui segment de linie dreaptă

Să începem prin a trasa cea mai simplă dintre forme: o linie dreaptă. Apăsaţi pe butonul Linie 

(Line) de pe panoul Desenare  şi plasaţi cursorul mausului în punctul de unde doriţi să 
înceapă linia.

Trageţi mausul în timp ce ţineţi apăsat butonul acestuia. Eliberaţi butonul mausului când aţi 
ajuns până unde doriţi să trasaţi linia. Un mâner albastru sau verde va fi afişat la fiecare capăt 
al liniei, indicând că aceasta este obiectul selectat. Culorile exacte depind de modul de 
selectare implicit: vor fi verzi pentru selecţia simplă şi albastru când sunteţi în modul de 
editare de puncte.

Imaginea 102: Trasarea unei linii drepte.

Apăsaţi tasta Shift în timp ce trasaţi linia pentru a forţa trasarea liniei la un multiplu de 45° faţă 
de orizontală. 

Dacă veţi apăsa tasta Control (Ctrl pe tastatura PC-urilor) pentru ca Draw să se comporte pe 
moment invers faţă de opţiunea privind agăţarea la grilă.

Pentru a trasa linia simetric faţă de punctul de start apăsaţi tasta Alt (linia se va extinde în 
ambele parţi ale punctul de pornire în mod simetric). Aceasta vă permite şi să trasaţi linii 
drepte pornind de la mijlocul liniilor.

Linia trasată va primi caracteristicile obişnuite (de exemplu, culoarea şi tipul acesteia). Pentru 
a schimba caracteristicile liniei, apăsaţi cu masul deasupra ei pentru a o selecta şi apoi folosiţi 
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Formele de desenare primare

uneltele din bara de unelte Linie şi umplere; sau, pentru mai mult control, daţi clic - dreapta şi 
folosiţi dialogul Linie (Line).

Trasarea unui dreptunghi
Trasarea dreptunghiurilor este similară cu trasarea liniilor drepte, cu deosebirea că veţi folosi 
butonul Dreptunghi (Rectangle)   de pe panoul Desenare. Linia (imaginară) pe care aţi fi 
trasat-o cu mausul va corespunde cu diagonala dreptunghiului.

Imaginea 103: Trasarea unui 
dreptunghi.

Ţineţi apăsată tasta Shift pentru a trasa un pătrat, sau tasta Alt pentru a trasa un dreptunghi 
pornind din centrul său.Pentru un efect combinat apăsaţi simultan ambele taste, Shift şi Alt.

Trasarea unui cerc sau a unei elipse

Pentru a trasa o elipsă sau un cerc, folosiţi butonul Elipsă (Ellipse)  de pe panoul Desenare 
(un cerc este de fapt o elipsă ale cărei axe au aceeaşi lungime). Elipsa trasată va fi cea mai 
mare care ar încape în cercul imaginar sugerat de deplasarea mausului.

Imaginea 104: Trasarea unei elipse.

Sunt şi alte trei modalitaţi de a trasa o elipsă sau un cerc:

• Apăsaţi tasta Shift pentru a trasa un cerc în loc de o elipsă.

• Apăsaţi tasta Alt pentru a trasa o elipsă simetrică sau un cerc pornind din mijloc în loc 
de a porni dintr-un colţ.
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Formele de desenare primare

• Apăsaţi tasta Ctrl în timp ce trageţi cu mausul pentru a alipi elipsa sau cercul la liniile 
grilei.

Notă Dacă apăsaţi întâi (şi ţineţi apăsată) tasta Control înainte de a apăsa pe oricare dintre 
aceste butoane (Linie, Dreptunghi, Elipsă şi Text), obiectul ales apare direct pe pagină 
cu o mărime, formă şi culoare implicite, urmând ca apoi să le modificaţi după cum 
doriţi.

Scrierea textului

Folosiţi unealta Text  pentru a scrie text şi a selecta fonctul, culoarea, mărimea şi alte 
caracteristici. Apăsaţi pe un loc gol din spaţiul de muncă pentru a scrie un text în acel loc. 
Marginea textului va deveni cadrul de text. Apăsaţi Enter pentru a trece la linia următoare. 

Când aţi terminat de tastat textul, apăsaţi  în interiorul cadrului de text. Daţi dublu - clic 
oricând pe text pentru a-l edita.

Când scrieţi text, panoul cu unelte din partea de sus include caracteristicile obişnuite ale unui 
paragraf: indentare, prima linie şi spaţierea taburilor.

Puteţi modifica stilul pentru tot textul sau numai parţial. Fereastra Stiluri şi formatare va 
funcţiona şi aici (selectaţi Formatare > Stiluri şi formatare - Format > Styles and 
Formatting sau apăsaţi F11 pentru a o afişa), astfel încât veţi putea crea stiluri grafice pe care 
apoi să le reutilizaţi în alte cadre de text. Stilurile grafice afectează tot textul dintr-un cadru de 
text. Pentru a aplica stiluri doar unor părţi din acest text va trebui să le formataţi direct cu 
ajutorul barei de unelte.

Cadrele de text pot avea de asemenea culori de umplere, umbre şi alte caracteristici, la fel ca 
oricare alt obiect Draw. Puteţi să rotiţi cadrul şi să scrieţi text la orice unghi. Aceste opţiuni 
sunt disponibile dând clic - dreapta pe obiect.

Folosiţi unealta Apelare (Callout), situată pe panoul Desenare, pentru a atribui obiectului un 
titlu sau o legendă (în limba engleză caption / callout / figure label).

Dacă daţi dublu-clic pe un obiect sau apăsaţi F2 (sau pictograma Text din bara de unelte 
Desenare) când un obiect este selectat, textul va fi scris în centrul obiectului şi nu va ieşi în 
exterior. Aproape toate tipurile de obiecte pot conţine un astfel de element de text. Aceste 
elemente de text prezintă mici diferenţe faţă de cadrele de text obişnuite în ceea ce priveşte 
poziţionarea şi despărţirea în silabe.

Utilizarea conectorilor
Conectorii sunt un tip de linie sau săgeată ale căror capete se lipesc de puncte de lipire (glue 
points) pe alte obiecte. Când mutaţi acele obiecte, conectorii se vor muta o dată cu ele. Draw 
are o plajă largă de conectori. Puteţi modifica tipurile conectorilor din meniul contextual.

Conectorii sunt în mod particular folositori atunci când realizaţi grafice de activitate (sau de 
exemplu evaluţia cursului valutar).  Veţi putea reorganiza blocurile ce compun graficul, iar 
elementele de legătură vor rămâne conectate.
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Formele de desenare primare

Punctele de lipire sunt diferite de mânere (micile pătrate verzi sau albastre din jurul unui 
obiect). Utilizaţi mânerele pentru a redimensiona obiectele; utilizaţi punctele de lipire pentru a 
ataşa conectori la obiecte.

Modurile de selectare
Sunt trei moduri de selectare: mutarea şi redimensionarea, rotirea şi editarea punctelor.

Modul obişnuit pentru selectarea obiectelor depinde de starea butonului Puncte (Points) de pe 

bara de unelte Desenare; dacă este activ (apare aprins)  sau inactiv (apare închis la culoare 
sau stins) .

Când butonul Puncte (Points) nu este activ, modul de selectare este mutarea sau 
redimensionarea; selecţiile sunt indicate de pătrăţele verzi.

Când butonul Puncte (Points) este activ, modul de selectare este editarea; selecţiile sunt 
indicate prin pătrăţele albastre. Unele obiecte au mai multe sau mai puţine astfel de mânere, 
care pot fi mai mari sau colorate diferit. Aceste aspecte sunt detaliate în Ghidul Draw (Draw 
Guide).

Selecţiile pentru rotirea obiectelor sunt indicate prin cerculeţe roşii şi un simbol suplimentar, 
care indică centrul de rotaţie. Pentru acest mod de selecţie, apăsaţi butonul derulant Efecte 
(Effects)  de pe bara de unelte Desenare.

Capitolul 8  Ini iere în Draw:ţ 147



Modurile de selectare

Schimbarea modului de selectare
Pentru a schimba de la un mod la altul procedaţi astfel:

Dacă este necesar, inversaţi starea butonului Puncte (Points) de pe bara Desenare pentru a 

trece de la modul simplu de selecţie la modul Puncte (Points) . Puteţi pentru aceasta să 
utilizaţi şi tasta rapidă F8 (Puncte).

Apăsaţi butonul derulant Efecte (Effects) de pe bara Desenare  pentru a activa modul 
Rotaţie (Rotation) pentru obiectul selectat.

Apăsând butonul Modul rotaţie prin clic pe obiect (Rotation Mode after Clicking 
Object)  din bara Opţiuni, puteţi trece de la modul normal la rotaţie (şi înapoi) prin 
simpla apăsare pe obiect. Aceasta este mult mai facil decât să apăsaţi pe obiect, apoi să 
apăsaţi pe butonul Rotire (Rotate) de pe bara de unelte Desenare.

Selectarea obiectelor

Selectarea directă

Pentru a selecta un obiect cel mai uşor este să apăsaţi cu mausul direct pe acesta. Pentru 
obiectele care nu sunt umplute va trebui să apăsaţi pe contur pentru a le selecta.

Selectarea prin încadrare
Puteţi selecta mai multe obiecte trăgând cu mausul un dreptunghi care 
să cuprindă obiectele cu butonul de selectare, aşa cum vedeţi alături.

Pentru ca un obiect să fie selectat trebuie să se afle integral în cadrul 
dreptunghiului.

Selectarea obiectelor ascunse
Chiar dacă obiectele sunt localizate în spatele altora ele pot fi totuşi selectate. Pentru a selecta 
un obiect ascuns după un altul, apăsaţi tasta Alt şi daţi clic pe obiect. Pentru a selecta un obiect 
care se află ascuns după mai multe obiecte, ţineţi apăsată tasta Alt şi apăsaţi cu mausul până 
când ajungeţi la obiectul dorit. Pentru a parcurge obiectele în ordine inversă, ţineţi apăsate 
tastele Alt+Shift. Pentru a vă ajuta în selectarea obiectelor pe bara de stare, în partea stângă, se 
afişează numărul şi tipul obiectelor selectate.

Notă Tasta Alt s-ar putea să se comporte diferit pe unele sisteme de operare.

Pentru a selecta un obiect care este acoperit de un alt obiect cu tastatura, apăsaţi Tab pentru a 
vă deplasa de la un obiect la altul. Pentru a inversa ordinea, apăsaţi Shift+Tab.
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Cea mai uşoară metodă este de a folosi tasta Tab pentru a vă deplasa de la un obiect la altul, şi 
să vă opriţi la obiectul dorit. (Aceasta s-ar putea insă să nu mai fie posibil dacă aveţi un număr 
mare de obiecte în desen.) Când daţi clic pe obiectul selectat conturul lui va fi afişat scurt prin 
obiectele de deasupra sa.

În imaginea de mai jos, pătratul din spatele cercului a fost selectat ca mai sus (cercul a fost 
făcut transparent pentru a putea fi observat pătratul).

Aranjarea obiectelor
Într-un desen complex s-ar putea să aveţi obiecte stivuite unele peste altele. Pentru a le rearanja 
procedaţi astfel:

• Selectaţi unul dintre obiectele din stivă şi apoi selectaţi Modifică > Aranjează (Modify 
> Arrange) şi selectaţi opţiunile corespunzătoare  Mută în faţă (Bring Forward) sau 
Mută în spate (Send Backward).

• Daţi clic-dreapta pe obiect şi selectaţi Aranjează (Arrange) din meniul contextual, 
apoi selectaţi, după cum este necesar, dintre opţiunile Mută în faţă (Bring Forward) 
sau Mută în spate (Send Backward).

Draw are disponibile unelte pentru alinierea mai multor obiecte; detalii găsiţi în Ghidul Draw 
(Draw Guide).

Selectarea mai multor obiecte
Pentru a  selecta sau a deselecta mai multe obiecte unul câte unul, apăsaţi tasta Shift şi daţi clic 
pe diversele obiecte pentru a le selecta sau deselecta.

Mutarea şi ajustarea m rimii unui obiectă

Sunt câteva metode pentru a muta sau modifica mărimea unui obiect. Metoda descrisă aici va 
fi denumită dinamică în sensul că este efectuată folosind mausul.

Când veţi modifica dinamic un obiect, amintiţi-vă să verificaţi zona centrală a barei de stare 
din partea de jos a ecranului. Acea zonă arată informaţii exacte despre starea acţiunii. De 
exemplu, în timpul unei redimensionări, va fi afişat un conţinut similar celui de mai jos. 
Această informaţie se va modifica atunci când veţi deplasa mausul.
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Mutarea dinamic  a obiecteloră

Pentru a muta un obiect selectaţi-l, apăsaţi în interiorul marginilor sale şi apoi ţineţi apăsat 
butonul stând al mausului şi trageţi-l până unde doriţi, apoi eliberaţi butonul mausului. În 
timpul deplasării, conturul obiectului apare ca o linie punctată, pentru a vă ajuta să îl 
repoziţionaţi.

                    

Modificarea dinamic  a m rimii obiecteloră ă

Pentru a modifica mărimea unui obiect (sau grup de obiecte selectate) cu mausul va trebui să 
deplasaţi unul din mânerele din jurul selecţiei. Aşa ilustrează imaginea de mai jos, noul contur 
al obiectului apare ca o linie punctată.

Rezultatele vor diferi în funcţie de care mâner veţi utiliza. Dacă alegeţi un mâner dintr-un colţ, 
veţi redimensiona obiectele de-a lungul a doua axe simultan. Dacă veţi folosi un mâner lateral 
obiectele vor fi redimensionate de-a lungul unei singure axe.

Notă Dacă apăsaţi tasta Shift în timpul redimensionării modificările vior fi efectuate 
simetric faţă de ambele axe; această vă permite să păstraţi proporţiile obiectului 
(lungime/ înălţime).

Efecte speciale

Cu Draw puteţi aplica multe efecte speciale obiectelor şi grupurilor de obiecte. Această 
secţiune descrie câteva dintre acestea. Altele incluzând distorsiuni, umbre şi transparenţă le 
veţi găsi descrise în Ghidul Draw (Draw Guide).
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Efecte speciale

Rotirea
Rotirea unui obiect vă permite să îl mişcaţi de-a lungul unei axe. Pentru a face aceasta 
dinamic, folosiţi mânerele roşii, similar cum procedaţi când îi schimbaţi dimensiunea.

Notă Rotirea funcţionează uşor diferit pentru obiectele 3D deoarece rotirea va fi făcută în 
spaţiu tridimensional şi nu într-unul plan. Citiţi în Ghidul Draw şi despre rotire atunci 
când modul activ este Editare puncte (Edit Points).

Pentru a roti un obiect (sau un grup de obiecte), trageţi mânerele roşii din colţurile selecţiei cu 
mausul. Cursorul mausului ia forma unui arc de cerc cu câte o săgetuţă la fiecare capăt. Un 
contur cu linie punctată al obiectului va fi afişat, iar unghiul de rotaţie va fi afişat în bara de 
stare.

Rotaţiile sunt făcute în jurul unei axe care este afişată ca un mic simbol. Puteţi deplasa axa de 
rotaţie cu mausul, aşa cum este exmplificat mai jos.

Dacă ţineţi apăsată tasta Shift în timpul rotirii aceasta va fi efectuată în multipli de 15°.

Inclinarea
Pentru a inclina ori a denatura un obiect folosiţi mânerele roşii localizate pe una din marginile 
obiectului selectat. Axa de inclinare este înfăţişată ca cel mai apropiat mâner pe latura opusă.

Ca si la rotire, operaţia va fi efectuată în multipli de 15° apăsând tasta Shift în timp ce mutaţi 
mânerul.

Duplicarea
Această funcţie duplică o anumită formă dar vă permite să schimbaţi opţiunile duplicatelor. 
Rezultatul duplicării este un nou grup.
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Pentru a începe duplicarea, apăsaţi pe un obiect (sau un grup de obiecte selectate), apoi alegeţi 
Editare > Duplicare (Edit > Duplicate). Va fi afişat dialogul din Imaginea 103.

Puteţi alege:

• Numărul copiilor.

• Deplasarea pe axele X şi Y dintre 2 copii.

• Unghiul de rotaţie dintre 2 copii.

• Modificări ale mărimii dintre fiecare copie.

• Culorile primei şi ultimei copii.

Imaginea 105: Duplicarea unui obiect.

Opţiunile din imaginea de mai sus aplicate unui dreptunghi albastru produc următorul rezultat:
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Mixaj încrucişat (Cross-Fading)
Mixajul încrucişat transformă o formă în altă formă, OpenOffice.org manipulând toate formele 
intermediare. Rezultatul constituie un nou grup de obiecte.

Pentru a realiza un mixaj selectaţi ambele obiecte (ţineti tasta Shift apăsată în timp ce selectaţi 
pe rând fiecare obiect) şi apoi alegeţi Editare > Mixaj încrucişat (Edit > Cross-fading). Va fi 
afişat următorul dialog:

Mai jos este un exemplu de utilizare.

Începem cu 2 forme... ...şi realizăm mixajul pentru a obţine 
următorul desen.

Editarea obiectelor

Pentru a modifica atributele unui obiect (cum sunt culoarea şi grosimea marginii), puteţi utiliza 
bara de unelte Linie şi umplere sau meniul contextual.

Dacă bara de unelte Linie şi umplere nu este vizibilă puteţi să o afişaţi selectând Vizualizare > 
Bare de unelte > Linie şi umplere (View > Toolbars > Line and Filling). De aici veţi putea 
edita atributele obişnuite ale obiectelor. Puteţi şi să deschideţi dialogul Linie apăsând 
pictograma  şi dialogul Zonă (Area) apăsând pictograma  pentru a vedea opţiunile 
suplimenatre.
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Editarea obiectelor

1  Stiluri şi formatare 4  Stil linie 7      Zonă
2  Linie 5  Lăţime linie 8–9  Stil zonă/ Umplere 
3  Stil săgeată 6  Culoare linie 10    Umbră

Când un obiect este selectat puteţi da clic-dreapta pentru a obţine meniul contextual (Imaginea
102). Elementele cu o săgeată duc la un submeniu.

Imaginea 106: Daţi clic-dreapta pe un obiect selectat pentru meniul 
contextual.

Cea mai des modificată caracteristică este stilul liniei (solid, punctat - dashed, invizibil), 
culoara sau lăţimea. Aceste opţiuni sunt disponibile în bara de unelte Linie şi umplere. Puteţi 
de asemenea edita aceste caracteristici din dialogul Linie. Puteţi şi să definiţi noi stiluri de linie 
şi săgeţi (citiţi Ghidul Draw pentru detalii).

Termenul folsoit în OOo pentru interiorul unui obiect este Umplere zonă (Area fill). 
Umplerea zonei unui obiect se poate face cu o culoarea uniformă, un degrade sau o imagine. 
Aceste opţiuni sunt toate disponibile pe bara de unelte Linie şi umplere. Puteţi şi să definiţi noi 
tipuri de umplere (citiţi Ghidul Draw).

Inserarea imaginilor din alte surse

Puteţi să adăugaţi imagini din mai multe surse:

• Galeria—citiţi Capitolul 14 (Lucrul cu galeria)

• Direct de la un scanner (Inserare > Imagine > Scanează (Insert > Picture > Scan))

• Imagini create de alt program, inclusiv fotografii de la camere digitale (Inserare > 
Imagine > Din fişier (Insert > Picture > From File))
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Inserarea imaginilor din alte surse

Draw furnizează unelte pentru lucrul cu imagini bitmap (ca de exemplu fotografii): bara de 
unelte Imagine (Picture) şi paleta de administrare a imaginii bitmap. Citiţi Ghidul Draw pentru 
detalii şi exemple.

Exportarea obiectelor şi fişierelor

Pentru a salva o imagine Draw într-un format extern folosiţi Fişier > Export (File > Export). 
Draw poate salva în multe formate grafice, aşa cum am arătat în Capitolul 3.

Puteţi să exportaţi fişiere Draw în HTML, PDF sau Flash. Exportul în PDF este identic pentru 
toate componentele OpenOffice.org, aşa cum am descris şi în Capitolul 3 (Administrarea 
fişierelor). Exportul în Flash crează un fişier .swf.

Exportul în HTML foloseşte un vrăjitor care vă ajută să realizaţi conversia, care va crea câte o 
pagină web pentru fiecare pagină din desenul dumneavoastră Draw. Puteţi opţional să alegeţi 
să afişaţi paginile în cadre cu un navigator şi puteaţi realiza o pagină de index. Pentru mai 
multe informaţii citiţi Capitolul 16 (Crearea paginilor Web: Salvarea documentelor ca fişiere 
HTML).
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Iniţiere

Capitolul 99
  Iniţiere în Impress

Prezentări cu OpenOffice.org



Ce este Impress?

Ce este Impress?

Impress este componenta de prezentare de diapozitive din OpenOffice.org. Puteţi crea 
diapozitive ce conţin multe elemente diferite, incluzând text, liste numerotate sau cu simboluri 
grafice, tabele, grafice şi o vastă paletă de imagini şi obiecte grafice. Impress mai include un 
verificator ortografic, un dicţionar, stiluri text gata definite şi stiluri pentru fundal atractive.

Acest capitol vă oferă instructaj, capturi ale ferestrelor programului şi sfaturi utile pentru a vă 
ghida prin mediul de lucru Impress în timp ce veţi crea prezentări facile. Deşi ne vom referi şi 
la prezentări mai complicate, explicaţiile despre crearea acestora le găsiţi în Ghidul Impress 
(Impress Guide). Dacă deja aveţi o oarecare experienţă în crearea prezentărilor vă recomandăm 
să citiţi direct Impress Guide.

Notă Folosirea Impress pentru a crea ceva mai mult decât prezentări simple necesită 
cunoaşterea elementelor care vor compune prezentările. Diapozitivele care conţin text 
necesită cunoaşterea stilurilor de text. Diapozitivelele care conţin obiecte sunt create 
în acelaşi mod în care sunt create desenele în Draw. Din acest motiv, vă recomandăm 
să citiţi şi capitolul 8 (Iniţiere în Draw) şi capitolul 13 (Lucrul cu stiluri).

Crearea unei noi prezent riă

Această secţiune vă arată cum să porniţi o nouă prezentare. Setările folosite aici sunt generale: 
se aplică tuturor diapozitivelor din prezentare. Secţiunea “Lucrul cu diapozitive” de la pagina 
172 vă explică cum să aveţi setări diferite în funcţie de fiecare diapozitiv. Aceste explicaţii sunt 
aplicabile şi unor setări generale.

Planificarea unei prezent riă

Primul lucru este de a vă decide la ce veţi folosi prezentarea. De exemplu, să colaţionaţi câteva 
fotografii într-o prezentare nu prea necesită planificare. Însă crearea unei prezentări pentru a-i 
învăţa ceva pe ceilalţi necesită mult mai multă analiză.

Notă Acest capitol este disponibil sub formă de prezentare pe Internet la 
http://oooauthors.org/en/authors/user_howtos/Simple_Presentation.odp. A fost creat 
folosind paşii indicaţi în acest capitol.

Trebuie să vă puneţi şi să găsiţi răspunsuri la multe întrebări înainte de a trece la treabă. Dacă 
nu sunteţi familiar cu crearea prezentărilor răspunsurile vor fi cam generale. Cei care au creat 
frecvent prezentări vor dori să primească răspunsuri specifice.

Cine va viziona prezentarea? Cum va fi utilizată? Despre ce va fi? Ce va conţine? Cât de 
detaliată va fi? Va avea înglobate fişiere audio? Este acceptabilă animaţia? Cum se va realiza 
tranziţia dintre diapozitive? Sunt multe astfel de întrebări pentru care trebuiesc găsite 
răspunsuri  care să fie şi scrise undeva înainte de a crea prezentarea. Sunetul şi animaţia sunt 
elemente mai avansate şi sunt explicate în Ghidul Impress.
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Crearea unei noi prezent riă

Din nou, nu este întotdeauna necesar în acest moment să aveţi răspunsuri la toate aceste 
întrebări. Să faceţi o schiţă contează cel mai mult. S-ar putea să ştiţi precis ce vor conţine unele 
diapozitive, şi doar vag ce vor conţine altele. Este în regulă. Schimbări puteţi efectua oricând. 
Aveţi grijă să vă modificaţi schiţa în conformitate cu modificările efectuate în diapozitive.

Cel mai important este să aveţi o idee generală despre ceea ce doriţi să faceţi şi cum veţi 
realiza aceasta. Scrieţi aceste lucruri pe hârtie. Aceasta vă va uşura considerabil efortul de a 
crea o prezentare.

Pornirea Vr jitorului de prezent riă ă

Puteţi lansa Impress în oricare dintre cele 2 moduri:

• Apăsaţi pe triunghiul de la dreapta pictogramei Nou (New) şi selectaţi Prezentare 
(Presentation) din meniul derulant.

• Alegeţi din meniu Fişier > Nou > Prezentare (File > New > Presentation).

Când lansaţi Impress va fi pornit Vrăjitorul de Prezentări (Presentation Wizard) (Imaginea
107).

PONT Dacă nu doriţi ca Vrăjitorul să fie afişat de fiecare dată când porniţi Impress bifaţi 
căsuţa Nu mai afişa din nou acest vrăjitor (Do not show this wizard again).

Imaginea 107. Alegerea tipului de prezentare din Vrăjitor.

3) Selectaţi Prezentare vidă (Empty Presentation) la Tip (Type). Va crea o prezentare în 
care veţi porni de la zero.
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Crearea unei noi prezent riă

PONT Lăsaţi bifată căsuţa Previzualizare (Preview) astfel încât şabloanele, designul 
diapozitivelor şi efectele intermediare să le vizualizaţi în fereastra de previzualizare 
pe măsură ce le selectaţi.

Notă Din şablon (From Template) foloseşte un şablon deja existent ca bază pentru noua 
prezentare. Vrăjitorul vă va oferi o listă cu şabloanele disponibile, din care îl puteţi 
alege pe cel care vă este necesar.

Deschide o prezentare existentă (Open Existing Presentation) continuă munca la o 
prezentare deja creată. Vrăjitorul vă va oferi o listă cu prezentările disponibile, din 
care o puteţi alege pe cea dorită.

Ambele opţiuni sunt descrise în Ghidul Impress (Impress Guide).

4) Apăsaţi Următorul (Next). Va fi afişată fereastra Vrăjitorului de la pasul secund. 
Imaginea 108 arată Vrăjitorul după selectarea la primul pas a Prezentării vide (Empty 
Presentation). Dacă aţi fi selectat Din şablon (From Template) ar fi fost afişată o 
previzualizare în zona corespunzătoare (Preview).

Imaginea 108. Selectarea unui design pentru diapozitiv folosind Vrăjitorul.

5) Alegeţi un design de la Selectează un design pentru diapozitiv (Select a slide design). 
Secţiunea Concepere diapozitiv (slide design) vă oferă 2 opţiuni principale: Fundaluri 
de prezentare (Presentation Backgrounds) şi Prezentări (Presentations). Fiecare are o 
listă de opţiuni pentru designul diapozitivelor. Dacă veţi dori să folosiţi una dintre 
acestea, alta decât <Original>, daţi un clic pentru a o selecta.
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Crearea unei noi prezent riă

Tipurile de Fundaluri de prezentare (Presentation Backgrounds) sunt arătate în 
Imaginea 108. Dând clic pe un element veţi previzualiza designul diapozitivului în 
fereastra Previzualizare (Preview). Impress oferă 3 opţiuni la Prezentări (Presentations): 
<Original>, Prezentarea unui produs nou (Introducing a New Product) şi 
Recomandarea unei strategii (Recommendation of a Strategy).

• <Original> este pentru o prezentare vidă, fără un aspect (design) anume.

• Ambele opţiuni Prezentarea unui produs nou (Introducing a New Product) şi 
Recomandarea unei strategii (Recommendation of a Strategy) au propriile 
designuri predefinite pentru diapozitive. Fiecare design va apare în fereastra 
Previzualizare atunci când veţi da clic pe numele său.

Notă Prezentarea unui produs nou şi Recomandarea unei strategii sunt şabloane 
predefinite pentru prezentări. Ele pot fi folosite pentru crearea unei prezentări 
selectând Din şablon (From template) la primul pas (Imaginea 107).

6) Selectaţi cum va fi expusă prezentarea la Selectare mediu de prezentare (Select an 
output medium). Cel mai des prezentările sunt făcute pentru a fi afişate pe monitor. 
Selectaţi Ecran (Screen).

7) Apăsati Următorul (Next). Va apare fereastra de la pasul 3 al Vrăjitorului (Imaginea
109).

Imaginea 109. Selectarea efectelor intermediare şi a vitezei.
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Crearea unei noi prezent riă

8) Alegeţi efectul intermediar dorit (sau lipsa acestuia) din lista derulantă Efect (Effect).

PONT Puteţi să acceptaţi setările oferite pentru ambele opţiuni Efect (Effect) şi Viteză 
(Speed) dacă nu sunteţi suficient de priceput la manipularea acestora. Ambele valori 
pot fi modificate ulterior de la Tranziţii dintre diapozitive şi animaţii (Slide 
transitions and animations). Acestea două sunt explicate detaliat infra în acest 
capitol.

9) Selectaţi viteza dorită pentru tranziţia dintre diapozitive din lista derulantă Viteză 
(Speed) pentru rularea efectelor intermediare. Mediu (Medium) este o opţiune bună 
pentru început.

10)Apăsaţi Creează (Create). Va fi creată o nouă prezentare.

Notă Dacă aţi fi selectat Din şablon (From Template) la primul pas din fereastra 
Vrăjitorului, butonul Următor (Next) ar fi fost disponibil la pasul 3 şi alte pagini, care 
nu sunt descrise aici, ar fi devenit disponibile.

Formatarea unei prezent riă

De aici începeţi să creaţi prezentarea conform schiţei pe care o aveţi. Veţi lucra în fereastra 
principală (Main window) din Impress (Imaginea 110). Întâi vă voi descrie scopul fiecărei părţi 
din fereastră, iar după aceasta vă voi descrie cum să le folosiţi în alcătuirea prezentării.

Imaginea 110: Fereastra principală din Impress.
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Formatarea unei prezent riă

Fereastra principal  din Impressă

Fereastra principală are 3 zone: Diapozitive (Slides), Spaţiul de lucru (Workspace) şi Sarcini 
(Tasks). Zona diapozitivelor conţine imagini micşorate ale fiecărui diapozitiv. Puteţi să selectaţi 
un anumit diapozitiv pe care să îl prelucraţi. Spaţiul de lucru este zona unde veţi lucra pentru 
compunerea fiecărui diapozitiv. Zona sarcinilor conţine un grup de 4 sarcini care afectează 
stilurile, aspectul animaţiile şi tranziţia dintre diapozitivele din prezentare.

PONT Puteţi să alegeţi să nu se mai afişeze pe ecran zona Diapozitive (Slides) sau zona 
Sarcini (Task) apăsând pe x pentru a le închide ca pe orice altă fereastră, sau de la 
Vizualizare > Zonă diapozitiv (View > Slide Pane) sau Vizualizare > Zona 
sarcinilor (View > Task Pane). Pentru a afişa din nou zonele de diapozitive sau 
sarcini selectaţi din nou Vizualizare > Zonă diapozitiv sau Vizualizare > Zona 
sarcinilor.

Diapozitive

Zona Diapozitive conţine imagini micşorate (miniaturi) ale diapozitivelor din prezentare. 
Acestea sunt în ordinea de afişare din prezentare. Dacă daţi clic pe un diapozitiv îl veţi selecta 
şi îl plasaţi în Spaţiul de lucru.

Mai sunt alte câteva operaţiuni pe care le puteţi efectua asupra unuia sau a mai multor 
diapozitive direct în zona Diapozitive:

• Adăugaţi noi diapozitive la orice poziţie în cadrul prezentării, după primul diapozitiv.

• Marcaţi un diapozitiv ca ascuns astfel încât nu va fi afişat în cadrul prezentării.

• Ştergeţi un diapozitiv din prezentare.

• Redenumiţi un diapozitiv.

• Copiaţi sau mutaţi conţinutul unui diapozitiv în altul (prin copiere şi lipire, respectiv 
prin decupare şi lipire).

Este de asemenea posibil să efectuaţi următoarele operaţiuni, deşi sunt metode mult mai 
eficiente decât din zona Diapozitive:

• Să modificaţi efectele de tranziţie ce urmau după diapozitivul selectat sau după fiecare 
diapozitiv din grupul de diapozitive selectate.

• Să modificaţi ordinea diapozitivelor în prezentare.

• Să modificaţi designul diapozitivului (se va deschide o fereastră de unde veţi putea 
încărca propriul design).

• Să modificaţi aspectul diapozitivului pentru un grup de mai multe diapozitive, simultan. 
(Va fi necesar să folosiţi secţiunea Aspect (Layouts) din zona Sarcini.)

Capitolul 9  Ini iere în Impressţ 163



Formatarea unei prezent riă

Spa iul de lucruţ

Spaţiul de lucru are 5 moduri de vizualizare, aranjate pe categorii: Normal, Schiţă (Outline), 
Notiţe (Notes), Pliant (Handout) şi Sortare diapozitive (Slide Sorter). Aceste 5 categorii 
sunt denumite Butoane de vizualizare (View Buttons) (Imaginea 111). Sunt de asemenea 
multe bare de unelte folosite pentru crearea unui diapozitiv; puteţi vizualiza ce este disponibil 
la Vizualizare > Bare de unelte (View > Toolbars). Spaţiul de lucru  (Workspace) este sub 
butoanele de vizualizare. Aici veţi compune diapozitivul, pe baza diferitelor părţi.

Imaginea 111: Butoanele de vizualizare.

Fiecare mod de vizualizare este conceput astfel încât să efectuaţi mai uşor anumite operaţiuni.

• Modul Normal este modul principal pentru crearea diapozitivelor individuale. Folosiţi 
acest mod pentru a formata şi a concepe diapozitivul, pentru a adăuga text, imagini şi 
efecte de animaţie. Alte capitole din Ghid descriu cum să creaţi şi să editaţi diapozitive 
folosind Normal. Informaţii suplimentare sunt disponibile în Ghidul Impress (Impress 
Guide).

• Modul Schiţă (Outline) în care sunt vizualizate doar titlurile, listele numerotate şi cele 
cu simboluri grafice. Acest mod vă permite reordonarea diapozitivelor, editarea titlurilor 
şi a antetelor, reordonarea elementelor din liste şi adăugarea de noi diapozitive.

• Modul Notiţe (Notes) permite adăugarea de comentarii pentru fiecare diapozitiv, 
comentarii ce nu vor fi afişate în cadrul prezentării. Apăsaţi pe cuvintele "Apasă pentru 
a adăuga comentarii" (“Click to add notes”) şi puteţi începe să tastaţi. Puteţi 
redimensiona caseta de text folosind mânerele verzi şi să o mutaţi plasând cursorul 
mausului deasupra marginii şi apoi trăgând-o cu mausul. Modificări ale stilului de text 
pot fi făcute şi apăsând tasta F11.

• Modul Sortare diapozitive (Slide Sorter) vă prezintă fiecare diapozitiv în miniatură şi în 
ordinea în care sunt în prezentare. Puteţi reordona diapozitivele, genera o prezentare 
temporizată sau adăuga efecte de tranziţie între diapozitive.

• Modul Pliant (Handout) vă permite imprimarea diapozitivelor pentru pliante. Puteţi 
alege să puneţi pe pagină unul, două, trei, patru sau şase diapozitive de la Zona 
sarcinilor > Aspect (Task pane > Layouts). Această opţiune determină şi câte 
miniaturi sunt vizibile. Puteţi să reordonaţi diapozitivele în acest mod prin simpla lor 
tragere cu mausul.

Sarcini (Task pane)

Zona Sarcini are 4 secţiuni:

• Pagini master (Master Pages): Aici veţi defini stilul de pagină (Page Style) pe care 
doriţi să îl folosiţi în prezentare. Impress vă oferă 5 pagini master predefinite. Unul 
dintre acestea — Implicit (Default) — este vid, iar celelalte au definit un fundal.

Pont Apăsaţi F11 pentru de deschide fereastra Stiluri şi formatare (Styles and Formating), 
unde puteţi modifica stilurile folosite în orice diapozitiv master după cum doriţi. 
Aceasta o puteţi face oricând.

164 Capitolul 9  Ini iere în Impressţ



Formatarea unei prezent riă

• Aspect (Layout): Sunt expuse 20 de modele predefinite. Îl puteţi alege pe cel dorit, pe 
care îl puteţi folosi aşa cum este sau puteţi să îl modificaţi după dorinţă. În acest 
moment nu este posibil să creaţi propriile dumneavoastră modele.

• Animaţie personalizată (Custom Animation): Sunt listate  mai multe animaţii aplicabile 
elementelor selectate din diapozitiv. Animaţiile pot fi adăugate la un diapozitiv, pot fi 
modificate sau şterse ulterior.

• Tranziţie între diapozitive (Slide Transition): Sunt disponibile 56 de tranziţii, inclusiv 
Fără tranziţie (No Transition). Puteţi selecta viteza tranziţiei (încet = slow, mediu = 
medium, rapid = fast). Puteţi opta între tranziţie automată sau manuală de la un 
diapozitiv la altul, iar în cazul tranziţiei automate puteţi stabili cât timp să fie afişat un 
diapozitiv.

Crearea unei prezent riă

Acest proces începe cu determinarea caracteristicilor comune tuturor diapozitivelor, pe baza 
cărora puteţi determina ce diapozitiv master (slide master) veţi folosi pentru diapozitive şi ce 
modificări sunt necesare să îi aduceţi acestuia.

Alegerea unui diapozitiv master

Un diapozitiv master (Slide Master) este un diapozitiv cu un anumit set de proprietăţi deja 
definite, şi care este folosit ca punct de plecare în definirea celorlalte diapozitive. Aceste 
proprietăţi sunt fundalul, formatarea textului utilizat, formatarea desenelor folosite pentru 
fundal.

Notă Impress foloseşte 3 termeni pentru acest concept. Diapozitiv master (Master slide, 
slide master) şi pagină/i master (master page) se referă toate la acelaşi lucru - un 
diapozitiv care este utilizat pentru a crea alte diapozitive. Acest capitol precum şi 
Ghidul Impress (Impress Guide) vor încerca să folosească numai termenul diapozitiv  
master (slide master).

Pentru o prezentare simplă se va folosi în mod normal numai o singură pagină master. Toate 
diapozitivele vor fi create adăugând elemente unei pagini master, însă poate fi folosită şi altă 
pagină master dacă vă este necesar.

Dacă veţi decide mai târziu că pagina master folosită nu este cea potrivită puteţi alege o alta 
sau puteţi să modificaţi chiar pagina master. Toate diapozitivele care sunt derivate din această 
pagină master vor fi modificate corespunzător.

Pont În timp ce creaţi diapozitivul master şi diapozitivele succesive, apăsaţi F5 sau F9 
pentru a viziona diapozitivele pe tot ecranul. Apăsaţi apoi tasta Esc pentru a reveni la 
editare. Astfel vă va fi mai uşor să detectaţi problemele.

În primul rând va trebui să determinaţi stilurile pe care doriţi să le folosiţi în prezentare. Sunt 5 
diapozitive master predefinite, afişate în secţiunea Pagini master (Master Pages) din zona 
Sarcini (Task pane) (vezi imaginea 112). Alegeţi-l pe cel care este cel mai apropiat de ceea ce 
doriţi, şi vom vorbi despre modificarea lui mai încolo.
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Imaginea 112: Diapozitivele master 
disponibile.

Notă Pagina master implicită (Default Master Page) este un diapozitiv vid cu stiluri 
specifice pentru o schiţă (Outline). Celelalte patru Pagini master (Master Pages) 
conţin modele de design ca şi stiluri schiţă specifice.

Pentru a vă face o idee examinaţi paginile master predefinite. Pentru aceasta, selectaţi 
Vizualizare > Master > Diapozitiv master (View > Master > Master Slide) pentru a 
deschide secţiunea Pagini master (Master Pages). Din moment ce Pagina master implicită 
(Default Master Page) este vidă, luaţi în considerare numai celelalte patru pagini master 
disponibile.

Pont Vizualizare > Master > Diapozitiv master (View > Master > Master Slide) vă 
permite să efectuaţi modificări în diapozitivul master. Modificările efectuate asupra 
diapozitivului master vor efecta toate diapozitivele prezentării.

Vizualizare -> Normal (View > Normal) vă permite să lucraţi numai asupra 
diapozitivelor individuale, dar nici una dintre aceste modificări nu vor modifica 
diapozitivul master  pe care este fundamentat diapozitivul curent.

Primii doi paşi în crearea unei prezentări sunt: Selectaţi diapozitivul master cel mai apropiat de 
ceea ce aveţi nevoie, şi apoi salvaţi prezentarea. Apoi începeţi să modificaţi diapozitivul 
master.

Aten ieţ Amintiţi-vă să salvaţi des prezentarea, pentru a preîntâmpina pierderea modificărilor 
în caz că intervine ceva neaşteptat. Puteţi de asemenea să activaţi funcţia 
AutoRecuperare (AutoRecovery) de la Unelte > Opţiuni > Încarcă/Salvează > 
General (Tools > Options > Load/Save > General). Verificaţi că Salvează 
informaţia de recuperare la fiecare (Save AutoRecovery information every) este 
selectată şi aţi introdus un număr de minute. (Selectaţi între 5 şi 10 minute.)
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Efectuaţi modificările la diapozitivul master ales selectând Vizualizare > Master > Diapozitiv 
master (View > Master > Master Slide). Cea mai mare parte din muncă va consta în alegerea 
stilurilor. Tasta F11 deschide fereastra Stiluri şi formatare (Styles and Formating). Pictograma 
Stiluri de prezentare (Presentation Styles) ar trebui să fie deja selectată, iar dacă nu este o veţi 
selecta dumneavoastră. Sunt listate 14 stiluri, toate putând fi modificate, dar nu veţi putea 
adăuga stiluri noi. Pentru a modifica oricare dintre aceste stiluri, daţi clic-dreapta pe numele 
stilului şi alegeţi Modifică (Modify) din meniul derulant.

Pont Când selectaţi Vizualizare > Master > Diapozitiv master (View > Master >Master 
Slide) se va deschide şi bara de unelte Vizualizare master (Master View) (vezi 
Imaginea 113). Citiţi Ghidul Impress (Impress Guide) pentru instrucţiuni despre 
folosirea acestei bare de unelte.

Imaginea 113: Bara de unelte Vizualizare master (Master View).

Sunt disponibile următoarele stiluri de prezentare:

1) Stilurile Fundal (Background):

• Nimic (None) semnifică că toate fundalurile prezentării vor fi albe.

• Culoare (Color) vă permite selectarea unei culori pentru fundal.

• Gradient are 15 fundaluri predefinite. Incrementele dintre culori sunt stabilite în 
mod automat dar puteţi să modificaţi după cum doriţi. Pot fi creaţi noi gradienţi de 
la Formatare > Zonă > Gradient (Format > Area > Gradient) (este o categorie 
din fereastra Zonă).

• Haşurare (Hatching) are 10 modele predefinite. Mai multe pot fi create de la 
Formatare > Zonă > Haşurare (Format > Area > Hatching). La haşură poate fi 
definită o culoare de fundal.

• Bitmap are 20 de modele predefinite. Mai multe modele pot fi adăugate listei dacă 
sunt într-un format grafic cunoscut de OOo. (Citiţi mai jos.) Folosiţi Formatare > 
Zonă > Bitmapuri (Format > Area > Bitmaps). Folosiţi butonul Import pentru a 
localiza bitmap-ul şi a-l denumi. Folosiţi F11 şi selectaţi Bitmapuri (Bitmaps) din 
stilurile Fundal (Background) şi ar trebui să vedeţi bitmapul importat la sfârşitul 
listei.

Note Unelte > Opţiuni > OpenOffice.org > Culori (Tools > Options > OpenOffice.org 
> Colors) vă permite să creaţi propriile dumneavoastră culori. O dată ce aţi creat o 
culoare în acest mod va fi listată în paleta de culori disponibilă pentru fundal.

Despre cum să creaţi noi gradienţi, haşuri şi bitmapuri citiţi Ghidul Impress (Impress 
Guide).

Pentru a vedea toate formatele grafice pe care OOo le acceptă ca bitmapuri selectaţi 
Formatare > Zonă > Bitmapuri (Format > Area > Bitmaps). Apăsaţi Import. 
Tipuri fişier (File types) conţine întreaga listă a formatele acceptate.
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2) Stilul Obiecte fundal (Background objects): Folosiţi-l pentru a stabili caracteristicile 
tuturor obiectelor pe care le veţi adăuga la diapozitivul master. Efectuaţi orice 
modificări sunt necesare. Amintiţi-vă să folosiţi F5 după efectuarea unei modificări 
pentru a vă asigura că este ceea ce doriţi. Folosiţi tasta Esc pentru a vă reîntoarce.

Notă Ca şi la stilurile Paragraf şi Caracter din Writer, stilul obiecte fundal poate fi 
modificat punctual prin aplicarea unor formatări manuale, astfel încât este posibil să 
aveţi 2 obiecte de fundal formatate diferit.

Folosirea obiectelor de fundal necesită cunoştinţe despre componenta Draw şi 
depăşeşte scopul acestui capitol.

3) Stilul Notiţe (Notes): Dacă doriţi să introduceţi notiţe în diapozitive, daţi clic-dreapta pe 
stilul Notiţe, selectaţi Modifică (Modify), şi stabiliţi ce formatări doriţi să aibă notiţele. 
Amintiţi-vă că această formatare va fi aplicată notiţelor din fiecare diapozitiv ce este 
bazat pe acelaşi diapozitiv master. Partea de jos a ferestrei Notiţe (Notes) conţine un 
exemplu de cum arată alegerile pe care le faceţi.

Notă În această versiune nu puteţi să vizualizaţi notiţele în timpul derulării prezentării. 
Notiţele pot fi incluse în versiunea tipărită a prezentării.

4) Schiţă 1 (Outline 1) la Schiţă 9 (Outline 9): Aceste stiluri stabilesc formatarea pentru 
nivelurile corespunzătoare de text din casetele de text din diapozitive. Toate au valori 
predefinite destul de bune, astfel încât nu ar trebui să aveţi nevoie să le modificaţi. 
Deoarece într-o prezentare simplă este utilizat un singur diapozitiv master, orice 
modificare efectuată se va resfrânge asupra tuturor celorlalte diapozitive unde este 
utilizat stilul respectiv. De exemplu, 5 diapozitive conţin text formatat cu stilul Schiţă 2 
(Outline 2). Dacă veţi modifica dimensiunea fontului pentru acest stil de la 20 la 18 
schimbarea va fi aplicată în toate cele 5 diapozitive tuturor paragrafelor ce folosesc 
stilul.

5) Titlu şi subtitlu (Title and Subtitle): Modificaţi aceste stiluri ca pe stilurile Schiţă 1 ... 9 
de mai sus. Cele mai multe din aceste stiluri nu vor avea nevoie de nici o modificare. 
Părţile pe care probabil că le veţi modifica vor fi Font, Typeface, Dimensiunea fontului 
(Font size) şi Culoarea fontului (Font color), din categoria Efecte font (Font Effects).

6) Când aţi terminat modificările, selectaţi Vizualizare > Normal (View > Normal) sau 
puteţi apăsa Închide vizualizarea master (Close Master View) din bara de unelte 
Vizualizare master (Master View).

Crearea primului diapozitiv

Primul diapozitiv este în mod firesc pagina de titlu (Title Page). Alegeţi o machetă (Imaginea
114) care să corespundă cu ceea ce doriţi pentru primul diapozitiv. Cel mai bine păstraţi 
lucrurile cât mai simple. Câteva aspecte potrivite sunt Diapozitiv titlu (Title Slide) (conţine şi o 
secţiune pentru un subtitlu) sau diapozitivul Numai titlu (Title Only). Restul machetelor sunt 
mai potrivite fie pentru diapozitivele ulterioare, fie pentru prezentări complexe.

Notă Pentru prezentări foarte simple s-ar putea să nu fie nevoie de un titlu; de exemplu, 
dacă prezentarea constă în câteva imagini puse împreună pentru a fi văzute ca atare. 
Celelate prezentări au, în general, nevoie de un prim diapozitiv de titlu.
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Imaginea 114: Alegerea unei machete pentru 
diapozitiv.

Ad ugarea de elemente Paginii de titlu (Title Page)ă

Toate machetele prezentate conţin o secţiune pentru titlu în partea de sus. Pentru a introduce 
titlul daţi clic pe fraza Apasă pentru a introduce titlul (Click to add title). Tastaţi titlul. 
Modificarea formatării titlului poate fi realizată folosind tasta F11, cu clic-dreapta pe stilul 
Titlu (Title) sau  selectând Modifică (Modify) din meniul derulant.

Dacă folosiţi macheta pentru diapozitivul de titlu Title Slide, daţi clic pe fraza Apasă pentru a 
introduce text (Click to add text) pentru a tasta un subtitlu. Efectuaţi orice modificare de 
formatare este necesară, la fel ca la modificarea formatării titlului: folosiţi tasta F11, daţi clic-
dreapta pe stilul Subtitlu (Subtitle), selectaţi Modifică (Modify) din meniul derulant. Apăsaţi 
OK pentru a aplica modificările efectuate subtitlului.

Poate fi folosită şi macheta Title, Object. Pentru a face aceasta trebuie să ştiţi cum să mutaţi şi 
să redimensionaţi imaginile (obiectele grafice). Inseraţi obiectul ca un OLE Object. Pentru 
aceasta:

 1) Daţi dublu-clic pe imagine.

 2) Selectaţi Creare din fişier (Create from file) şi apăsaţi OK.

Aten ieţ Alegeţi Legătură către fişier (Link to file) numai dacă intenţionaţi să păstraţi 
prezentarea şi imaginea în aceleaşi directoare în care se găsesc la crearea legăturii, 
altfel nu veţi mai putea accesa obiectele OLE pe viitor.

 3) Apăsaţi Caută (Search) pentru a localiza fişierul dorit. Selectaţi-l, şi apăsaţi Deschide 
(Open). Apoi apăsaţi OK.

 4) Redimensionaţi şi poziţionaţi obiectul pentru a se încadra în diapozitiv.
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Inserarea de diapozitive suplimentare
Paşii pe care trebuie să-i urmaţi pentru inserarea de diapozitive suplimentare sunt în esenţă 
aceiaşi ca cei pentru selectarea paginii de titlu. Este un proces care va trebui repetat pentru 
fiecare diapozitiv individual. Deoarece deocamdată veţi folosi numai un diapozitiv master, 
singurul lucru de care veţi ţine cont acum este secţiunea Aspect (Layouts) din zona Sarcini 
(Tasks pane) din partea dreaptă.

În primul rând, ar trebui să inseraţi toate diapozitivele pe care le-aţi planificat în schiţa 
prezentării. Numai după aceasta veţi insera efecte speciale gen animaţii şi tranziţii. (Acestea 
sunt explicate în secţiunea următoare.)

Pasul 1: Inseraţi un nou diapozitiv. Aceasta poate fi făcută în mai multe feluri, astfel:

• Inserare > Diapozitiv (Insert > Slide).

• Daţi clic-dreapta pe diapozitivul curent şi selectaţi Diapozitiv nou (New Slide) din 
meniul contextual.

• Apăsaţi pictograma Diapozitiv (Slide) din bara de unelte Prezentare (Presentation) 
(Imaginea 115).

Imaginea 115: Bara de unelte 
Prezentare.

Pasul 2: Selectaţi un diapozitiv cu aspectul care este cel mai potrivit pentru ce vreţi să faceţi.

Dacă veţi folosi în diapozitiv numai un titlu cu o imagine, un grafic sau o foaie de calcul puteţi 
să le inseraţi ca un obiect OLE, ceea ce este cel mai simplu pentru imagine dar nu şi pentru 
grafic sau foaia de calcul.

Pasul 3: Modificaţi elementele diapozitivului. La acest pas, diapozitivul conţine toate 
elementele din pagina master şi din diapozitivul cu aspectul ales la pasul anterior. Prin 
modificare veţi şterge elementele inutile, le veţi adăuga pe cele necesare (imagini şi obiecte 
OLE) şi veţi insera text.

Aten ieţ Modificări la aspectele predefinite pot fi făcute numai în modul Vizualizare > Normal 
(View > Normal), care este cel implicit. Orice încercare de a face aceasta prin 
modificarea unui diapozitiv master va genera un mesaj de eroare. (Diapozitivul master 
poate fi modificat folosind Vizualizare > Master > Diapozitiv master (View > 
Master > Master Slide).)

1) Ştergerea oricărui element din diapozitiv care nu vă este necesar (Imaginea 116).

1) Apăsaţi pe element pentru a-l selecta. (Pătrăţelele verzi vor indica că este selectat.)

2) Apăsaţi tasta Delete pentru a-l şterge.

170 Capitolul 9  Ini iere în Impressţ



Formatarea unei prezent riă

Imaginea 116: Ştergerea unui element din diapozitiv.

Pont Uneori veţi selecta din greşeală un diapozitiv greşit. Puteţi corecta prin apăsarea pe 
diapozitivul corect.

2) Adaugaţi în diapozitiv orice elemente vă sunt necesare.

1) Adăugarea imaginilor într-un subcadru (frame) din diapozitiv:

1) Daţi dublu-clic pe imaginea existentă.

2) Localizaţi imaginea dorită.

3) Selectaţi-o şi apăsaţi Deschide (Open).

4) Redimensionaţi imaginea dacă este necesar. Citiţi ce scrie mai jos la Atenţie.

2) Adăugarea imaginilor din fişiere de imagine în alte zone din diapozitiv decât un 
subcadru:

1) Inserare > Imagine > Din fişier (Insert > Picture > From File).

2) Localizaţi fişierul, selectaţi-l şi apăsaţi Deschide (Open).

3) Mutaţi imaginea în poziţia dorită.

4) Redimensionaţi imaginea dacă este necesar.

3) Adăugarea de obiecte OLE este o tehnică avansată descrisă în Ghidul Impress.

Aten ieţ Când redimensionaţi o imagine daţi clic-dreapta pe aceasta. Selectaţi Poziţie şi 
dimensiune (Position and Size) din meniul contextual. Asiguraţi-vă că este bifată 
Păstrează proporţiile (Keep ratio). Apoi ajustaţi înălţimea sau lăţimea la 
dimensiunea dorită. (Pe măsură ce veţi modifica una din acestea, cealaltă se va 
modifica proporţional.) Dacă nu veţi bifa căsuţa menţionată imaginea se va 
distorsiona.
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3) Adăugaţi text în diapozitiv: Dacă există deja zone de text, apăsaţi fraza Apăsă pentru a 
adăuga un rezumat (Click to add an outline) din subcadrul textului. Tastaţi textul în 
subcadru.

Notă Textul din diapozitiv este formatat ca schiţă (outline): fiecare nivel este alineat mai la 
dreapta decât nivelul anterior. Sunt 10 niveluri, de la 1 la 10.

1) Pentru a modifica nivelul alineatului (Outline Levels) pe măsură ce tastaţi, folosiţi 
tastele cursor stânga şi dreapta (Imaginea 117).

• Tasta săgeată-stânga pentru a seta nivelul anterior pentru alineat ( de la nivelul 
3 la 2, de exemplu).

• Tasta săgeată-dreapta pentru a seta nivelul următor pentru alineat ( de la 
nivelul 2 la 3, de exemplu).

Imaginea 117: Săgeţile pentru mutarea 
textului.

2) Pentru a schimba ordinea paragrafelor folosiţi butoanele săgeată-sus şi săgeată-jos.

• Săgeată-sus mută paragraful deasupra paragrafului anterior.

• Săgeată-jos mută paragraful sub paragraful următor.

Notă Mutarea textului pe verticală cere de obicei şi ajustarea alineatului , astfel încât veţi 
combina tastele. De exemplu, un paragraf mai sus poate însemna că trebuie să treceţi 
la un alineat de un nivel mai mic (mai la stânga, mai apropiat de 1), iar invers la un 
nivel mai mare (mai la dreapta, mai apropiat de 10).

Pasul 4: Pentru a crea diapozitive suplimentare repetaţi paşii 1–3.

Lucrul cu diapozitive
Acum a sosit momentul să revedeţi întreaga prezentare şi să răspundeţi la câteva întrebări. 
Vizionaţi prezentarea cel puţin o dată înainte de a da răspunsurile. S-ar putea ca să vă formulaţi 
chiar dumneavoastră întrebări suplimentare.

1) Sunt diapozitivele în ordinea corectă? Dacă nu sunt va trebui să le mutaţi după cum este 
necesar.

2) Ar face un diapozitiv suplimentar mai clar un anumit topic? Va trebui să creaţi 
diapozitivul.

3) Ar ajuta vreun diapozitiv o animaţie personalizată? (Este o tehnică avansată.)

4) Ar trebui ca unele diapozitive să aibă alte efecte de tranziţie decât celelalte? Efectele de 
tranziţie corespunzătoare vor trebui modificate.

5) Sunt diapozitive care par inutile? Verificaţi că sunt într-adevăr inutile şi ştergeţi-le.
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Aten ie ţ Dacă unul sau mai multe diapozitive par a fi inutile le puteţi ascunde şi vizulizaţi 
prezentarea de câteva ori fără acestea, pentru a vă asigura. Pentru a ascunde un 
diapozitiv daţi clic-dreapta pe el în zona Diapozitive şi selectaţi Ascunde diapozitiv 
(Hide Slide) din meniul contextual. Nu ştergeţi un diapozitiv înainte, deoarece s-ar 
putea ca să fiţi sub o impresie de moment atunci când decideţi că este inutil, şi să 
trebuiască să îl recreaţi.

După ce aţi răspuns întrebări de mai sus, ca şi celor formulate de către dumneavoastră, ar trebui 
să efectuaţi modificările necesare. Aceastea se vor efectua cel mai facil în modul Sortare 
diapozitive (Slide Sorter) şi vom explica aici cum. Dacă vor fi necesare unul sai mai multe 
cadre suplimentare, urmaţi paşii din “Inserarea de diapozitive suplimentare” de la pagina 170.

Anima ii personalizateţ

Dacă ştiţi să adăugaţi o animaţie personalizată unui diapozitiv realizaţi-o acum. Aceasta face 
parte din tehnicile avansate şi este explicată în Ghidul Impress (Impress Guide).

Efectele pentru tranzi iile între ţ diapozitive3

Primei dumneavoastre prezentări probabil că i-ar sta bine cu acelaşi efect de tranziţie între 
toate diapozitivele. Stabilirea Avans diapozitiv (Advance slide) ca La apăsarea mausului (On 
mouse click) este setarea implicită şi cea mai simplă. Dacă doriţi ca fiecare diapozitiv să fie 
afişat un anumit timp, apăsaţi Automat după (Automatic after) şi introduceţi numărul de 
secunde. Apăsaţi Aplică tuturor diapozitivelor (Apply to all slides).

Pont Secţiunea Tranziţii între diapozitive are o opţiune foarte folositoare: Previzualizare 
automată (Automatic preview). Selectaţi căsuţa aferentă. Apoi, atunci când efectuaţi 
modificări asupra tranziţiei, noul diapozitiv cu tot cu efectul de tranziţie va fi 
previzualizat în spaţiul de lucru.

Modificările ce pot fi aplicate tranziţiei dintre diapozitive:

1) Aplică tuturor diapozitivelor (Apply to selected slides) prezintă lista cu tranziţiile 
posibile între diapozitive.

 a) Asiguraţi-vă că este bifat Previzualizare automată (Automatic preview).

 b) Apăsaţi pe un efect de tranziţie din lista Aplică tuturor diapozitivelor.

 c) Urmăriţi tranziţia respectivă.

 d) Selectaţi tranziţia dorită.

2) Modifică  tranziţia (Modify transition) prezintă două liste derulante.

• Selectaţi lista Viteză (Speed): încet - slow, mediu - medium, şi rapid - fast.

• Selectaţi un Sunet (Sound) din lista omonimă, dacă doriţi sunete.

3) După ce aţi efectuat modificările dorite, dacă a fost cazul, apăsaţi Once you have made 
your selections, if any, click Aplică tuturor diapozitivelor pentru a defini aceeaşi 
tranziţie pentru toate diapozitivele.

3 Pentru efectele de tranziţie ce pot fi selectate între cadre am folosit direct cuvântul tranziţie/i.
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4) Redă (Play) şi Prezentare diapozitive (Slide Show) sunt folosite pentru a prezenta 
unul sau mai multe diapozitive din cadrul prezentării.

• Apăsarea Redă are acelaşi efect cu bifarea Previzualizare automată (Automatic 
Preview): un singur diapozitiv este afişat, împreună cu tranziţia definită.

• Prezentare diapozitive începe prezentarea diapozivelor de la cel curent şi continuă 
până la final.

PONT Dacă vreţi să folosiţi acest buton pentru a verifica toată prezentarea, selectaţi primul 
diapozitiv din Diapozitive (Slides), apoi apăsaţi Prezentare diapozitive (Slide Show) 
în secţiunea Tranziţie între diapozitive din Sarcini (Task).

Spa iul de lucru (Workspace)ţ

Deja aţi citit despre prima înfăţişare a spaţiului de lucru: Normal. Toată munca dumneavoastră 
de până acum a fost efectuată acolo, diapozitiv cu diapozitiv. Celelalte înfăţisări, sau moduri de 
vizualizare ale spaţiului de lucru vă permit efectuarea altor operaţiuni.

Normal

Sunt 2 metode pentru a plasa un diapozitiv în zona de Concepere diapozitiv (Slide Design) ale 
modului de vizulizare Normal: daţi clic pe pictograma diapozitivului din Diapozitive sau 
folosiţi Navigatorul. Pentru a deschide Navigatorul, apăsaţi butonul Navigator de pe panoul de 
unelte Standard (vezi imaginea 118). Pentru a selecta un diapozitiv derulaţi lista din Navigator 
până când daţi de el şi apoi daţi-i dublu-clic.

Imaginea 118: Butonul Navigator.

Notă Unul dintre motivele pentru a denumi fiecare diapozitiv este de a le identifica facil cu 
planul prezentării creat de la început. Altul îl poate constitui faptul că astfel veţi regăsi 
diapozitivul mai uşor în Navigator.

Schi  (Outline)ţă

Modul de vizualizare Schiţă (Outline) (vezi Imaginea 119) conţine toate diapozitivele din 
prezentare în ordinea crescătoare a numărului fiecăruia. Este afişat numai textul din 
diapozitive. Nu sunt afişate numele diapozitivelor.
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Imaginea 119: Mutarea diapozitivelor în modul Schiţă.

Modul Schiţă a fost conceput pentru 2 obiective.

1) Modificarea textului din diapozitive:

• Puteţi adăuga sau şterge text dintr-un diapozitiv la fel ca în modul Normal.

• Puteţi muta paragrafele de text din diapozitivul selectat în sus sau în jos folosind 
tastele săgeţi sus şi jos corespunzătoare (Imaginea 117).

• Puteţi modifica nivelul alineatului (Outline Level) pentru un paragraf din diapozitiv 
folosind tastele săgeţi stânga şi dreapta.

2) Diapozitivele pot fi comparate cu schiţa prezentării. Dacă veţi observa că aţi uitat vreun 
diapozitiv vă puteţi reîntoarce în modul Normal pentru a-l crea, şi să reveniţi pentru a 
continua verificarea planului iniţial.

• Dacă un diapozitiv nu este în ordinea dorită îl puteţi muta unde trebuie să apară:

• Apăsaţi pe pictograma diapozitivului pe care îl doriţi muta.

• Trageţi-l la destinaţie.

Noti e (Notes)ţ

Modul  Notiţe (Notes) este utilizat pentru a adăuga notiţe unui diapozitiv. În această versiune a 
programului acestea nu vor fi vizibile persoanei care derulează prezentarea. Acestea pot fi 
tipărite ca parte din pliant dar nu este deloc facil.

Pentru a adăuga notiţe unui diapozitiv:

1) Apăsaţi categoria Notiţe (Note) din spaţiul de lucru (vezi imaginea 120).
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Imaginea 120: Modul Notiţe.

2) Selectaţi diapozitivul căruia îi veţi adăuga notiţele.

• Daţi dublu-clic pe diapozitiv în zona Diapozitive, sau

• Daţi dublu-clic pe numele diapozitivului din Navigator.

3) Tastaţi notiţele în caseta de text de sub diapozitiv.

Sortare diapozitive (Slide Sorter)

Sortare diapozitive (Slide Sorter) conţine toate pictogramele diapozitivelor (vezi imaginea 
121). Acest mod de vizualizare vă permite selecţia mai multor diapozitive în vederea 
reordonării acestora. Este posibil şi să lucraţi pe un singur diapozitiv.
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Imaginea 121: Modul Sortare diapozitive (Slide Sorter).

Puteţi modifica numărul de diapozitive afişate pe un rând.

1) Bifaţi Vizualizare > Bare de unelte > Vizualizare diapozitiv (View > Toolbars > 
Slide View) pentru a afişa bara de unelte Vizualizare diapozitiv (Slide view) (vezi 
imaginea 122).

Imaginea 122: Bara de unelte Vizualizare diapozitiv (Slide 
View).

2) Ajustaţi numărul de cadre pe rând.

3) După ce aţi efectuat ajustarea debifaţi Vizualizare > Bare de unelte > Vizualizare 
diapozitiv (View > Toolbars > Slide View) iar bara de unelte va dispare.

Pentru a muta un diapozitiv în acest mod de vizualizare:

1) Apăsaţi pe diapozitiv. Va fi desenată o margine groasă neagră împrejurul acestuia.

2) Trageţi-l în locul dorit.

• Pe măsură ce veţi deplasa diapozitivul va fi afişată o linie verticală neagră care 
marchează locul unde va fi mutat diapozitivul.

• Trageţi până când aceasta va fi poziţionată la locul dorit pentru diapozitiv.

Pentru a selecta un grup de diapozitive:

1) Apăsaţi pe numărul primului diapozitiv.

2) Ţineţi apăsat butonul stânga al mausului.
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3) Trageţi cursorul până la ultimul diapozitiv. Va fi afişat un dreptunghi cu un contur de 
linie punctată pe măsură ce mişcaţi mausul. Asiguraţi-vă că acest dreptunghi include 
toate diapozitivele pe care doriţi să le selectaţi.

Pentru a muta un grup de diapozitive:

1) Selectaţi grupul.

2) Trageţi grupul la locul dorit. Apare aceeaşi linie verticală neagră ce vă indică locul 
inserţiei.

Notă Selectarea unui grup de diapozitive este limitată de trasarea dreptunghiului. De 
exemplu, puteţi selecta diapozitivele 1, 2 ,3, 5, 6 şi 7 dar nu şi 1, 2, 5, 6 şi 7.

Puteţi să lucraţi cu diapozitivele în modul de vizualizare Sortare diapozitive exact ca şi în zona 
Diapozitive. Pentru a efectua modificări daţi clic-dreapta pe un diapozitiv şi puteţi efectua 
următoarele operaţiuni din meniul derulant:

• Adăugaţi un nou diapozitiv după cel selectat..

• Ştergeţi diapozitivul selectat.

• Modificaţi aspectul diapozitivului (Slide Layout).

• Modificaţi tranziţia dintre diapozitive (Slide transition).

1) Pentru un singur diapozitiv apăsaţi pe acesta pentru a-l selecta, apoi efectuaţi 
modificarea.

2) Pentru mai multe diapozitive selectaţi-le ca un grup şi efectuaţi modificarea dorită.

• Ascundeţi diapozitivul selectat. Acesta nu va fi afişat la derularea prezentării.

• Copiaţi şi lipiţi un diapozitiv.

• Decupaţi şi lipiţi un diapozitiv.

Pliante (Handouts)

Acest mod de vizualizare este pentru stabilirea aspectului diapozitivului în vederea tipăririi 
unui pliant. Aveţi 5 opţiuni, respectiv 1, 2, 3, 4 şi 6 (şase) diapozitive pe o pagină (vezi 
imaginea 123). Dacă veţi dori să fie tipărite şi notiţele aferente diapozitivelor consultaţi Ghidul 
Impress (Impress Guide). Nu este descrisă aici deoarece necesită cunoştinţe avansate.

Imaginea 123: Aspecte pentru pliante.

Pentru a tipări un pliant:
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1) Selectaţi diapozitivele folosind Sortare diapozitive (Slide Sorter). (Folosiţi paşii descrişi 
la selectarea unui grup de diapozitive la pagina 177.)

2) Selectaţi Fişier > Imprimare (File > Print) sau apăsaţi Control+P.

3) Selectaţi Opţiuni (Options) din colţul stânga-jos.

4) Bifaţi Pliant (Handout) şi apăsaţi OK.

5) Selectaţi Arie imprimare (Print Range).

6) Apăsaţi OK din fereastra Imprimare (Print).

Notă Prin selectarea unui singur diapozitiv este posibil să-l tipăriţi cu tot cu notiţele 
conţinute. Tipărirea întregii prezentări cu notiţele aferente depăşeşte scopul acestui 
ghid.

Derularea prezent riiă

Pentru a lansa prezentarea procedaţi în unul din modurile următoare:

• Apăsaţi Prezentare diapozitive > Prezentare diapozitive (Slide Show > Slide Show).

• Apăsaţi butonul Prezentare diapozitive (Slide Show) (Imaginea 124).

Imaginea  124:  Bara  de  unelte  Prezentare 
(Presentation).

• Apăsaţi F5 sau F9 pentru a lansa prezentarea diapozitivelor.

Dacă trecerea de la un diapozitiv la altul este stabilită ca Automat după x secunde (Automatic 
after x seconds), puteţi lăsa prezentarea să se deruleze automat.

Dacă trecerea de la un diapozitiv la altul este stabilită ca La apăsarea mausului (On mouse 
click), procedaţi în unul din modurile următoare pentru a trece de la un diapozitiv la următorul.

• Folosiţi tastele săgeţi pentru a trece la diapozitivl următor, sau puteţi trece şi la cel 
anterior.

• Puteţi să daţi clic cu mausul.

• Apăsaţi tasta spaţiu.

Pentru a opri prezentarea oricând, inclusiv după ce s-a afişat ultimul diapozitiv, apăsaţi tasta 
Esc.
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Capitolul 1010
  Iniţiere în Base

Componenta de baze de date din OpenOffice.org
   



Introducere

Introducere

O sursă de date, sau o bază de date, este o colecţie de informaţii care pot fi accesate şi 
prelucrate de OpenOffice.org (OOo). De exemplu, o listă de nume şi adrese este o sursă de 
date care poate fi folosită pentru a produce o scrisoare. Inventarul unui magazin poate fi 
prelucrat prin OOo.

Notă OpenOffice.org foloseşte termenii "Sursă de date" (“Data Source”) şi "Bază de date" 
(“Database”) pentru a se referi la acelaşi lucru, care poate fi o bază de date ca 
MySQL sau dBase sau o foaie de calcul ori un document text în care se găsesc date.

Acest capitol explică crearea unei baze de date, vizualizarea a ceea ce este conţinut în aceasta 
şi cum foloseşte OOo diferitele componente. Explică de asemenea cum să folosiţi componenta 
Base din OOo pentru a lucra şi cu alte surse de date. O sursă de date înseamnă o baza de date, 
o foaie de calcul sau un document text.

Acest capitol este doar o introducere în folosirea surselor de date. Pentru mai multe informaţii 
consultaţi Ghidul bazelor de date (Ghidul bazelor de date (Database Guide)).

Notă OOo Base foloseşte motorul de baze de date HSQL. Toate fişierele create de acesta 
sunt păstrate într-un singur fişier zip4. Formularele bazei de date sunt şi ele incluse în 
acest fişier.

O bază de date (database) consistă dintr-un număr de câmpuri (fields) care conţin fişierele 
individuale. Fiecare tabel (table) din baza de date este un grup de câmpuri. Când creaţi un 
tabel determinaţi simultan şi caracteristicile fiecărui câmp din acesta. Formularele (Forms) 
sunt pentru introducerea datelor în câmpurile dintr-unul sau mai multe tabele asociate cu un 
formular, şi pot fi deasemenea folosite pentru a insepcta câmpurile dintr-unul sau mai multe 
tabele. O interogare (query) crează un nou tabel pe baza tabelelor existente în funcţie de 
opţiunile dumneavoastră. Un raport (report) organizează informaţiile din câmpurile unei 
interogări sub forma unui document, în funcţie de cerinţele dumneavoastră.

Aten ieţ

   

Bazele de date din OOo necesită Java Runtime Environment (JRE). Daca aceste 
programe nu sunt instalate pe calculatorul dumneavoastră atunci vă rog să le 
descărcaţi de la www.java.com şi să le instalaţi (instrucţiuni găsiţi pe acel site). Ar 
trebuie să fie Java 5.0 su mai recent. În OOo, folosiţi Unelte > Opţiuni > 
OpenOffice.org > Java (Tools > Options > OpenOffice.org > Java) pentru a 
configura Java.

Versiunea pentru Window a JRE nu poate fi utilizată, dar există alte versiuni de Java 
care funcţionează.

Base creează baze de date relaţionale (relational databases). Aceasta înseamnă că va fi uşor să 
creaţi o bază de date în care câmpurile acesteia să aibă legături între ele.

4 Zip este un format pentru arhive, de obicei comprimate, de fişiere. Poate fi citit cu o multitudine de programe.
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De exemplu: Gândiţi-vă la o bază de date pentru o bibliotecă. Va conţine un câmp pentru 
numele autorilor şi altul pentru titlul cărţilor. Există o relaţie evidentă între autori şi cărţile pe 
care le-au scris. Biblioteca poate conţine mai mult decât un titlu scris de acelaşi autor. Aceasta 
este denumită o relaţie unul-la-mulţi: un autor şi mai mult de un titlu. Cele mai multe, dacă nu 
toate legăturile dintr-o astfel de bază de date vor fi de acest tip.

Gândiţi-vă la o bază de date pentru salariaţii aceleiaşi biblioteci. Unul dintre câmpuri conţine 
numele angajaţilor pe când ceilalţi conţin codul numeric personal sau alte date personale. 
Relaţia dintre nume şi CNP este de unul-la-unul: CNP-ul este unic pentru fiecare angajat.

Dacă sunteţi obişnuit cu mulţimile din matematică, o bază de date relaţională poate fi descrisă 
în termeni din matematica mulţimilor: elemente, submulţimi, uniuni şi intersecţii. Câmpurile 
sunt elementele. Tabelele sunt submulţimile. Relaţiile sunt definite în termeni de uniuni şi 
intersecţii a submulţimilor (tabelelor).

Pentru a explica utilizarea unei baze de date vom crea una pentru cheltuielile cu maşinile, şi cu 
acest prilej veţi afla şi cum funcţionează o bază de date.

Crearea unei baze de date

Primul pas în crearea unei baze de date constă în a vă pune numeroase întrebări. Scrieţi-le şi 
lăsaţi spaţiu pentru răspunsuri. O parte dintre aceste răspunsuri vor veni de la sine după ce veţi 
analiza suficient problema pe care doriţi să o soluţionaţi.

S-ar putea ca să repretaţi acest prim pas de mai multe ori până veţi clarifica totul, atât pe hârtie 
cât şi mental. Dacă veţi scrie întrebările într-un document text va fi mai uşor să le mutaţi de 
colo-colo şi să le modificaţi.

Iată câteva dintre întrebările şi răspunsurile pe care le-am formulat înainte de a crea o bază de 
date pentru cheltuielile cu automobilele. Aveam o idee despre ceea ce doream când m-am 
apucat, dar când am început să îmi pun nişte întrebări şi să formulez răspunsuri, am descoperit 
că îmi sun tnecesare tabele şi câmpuri suplimentare.

Ce câmpuri voi folosi? Cheltuielile implicate vor fi împărţite în 3 categorii mari: 
combustibilul, întreţinerea şi concediile. Costul anual pentru rovinietă, licenţă, permisul 
şoferilor o dată la câţiva ani nu se înadrau în nici unul dintre aceste câmpuri, astfel că am decis 
să creez un tabel de sine stătător: taxe de licenţă.

Ce câmpuri vor fi cu privire la combustibil? Data achiziţiei, citirea indicatorului rezervorului, 
costul combustibilului, cantitatea de combustibil şi modalitatea de plată. (Consumul de 
carburanţi va putea fi astfel calculat printr-o interogare.)

Ce câmpuri vor fi cu privire la întreţinere? Data reparaţiei, citirea indicatorului rezervorului, 
tipul reparaţiei, costul acesteia, şi data următoarei intrări în service (inclusiv pentru schimbarea 
uleiului). Dar ar fi bine dacă s-ar putea scrie şi diverse adnotări. Aşa că am adăugat pe listă şi 
un câmp pentru notiţe.
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Ce câmpuri vor fi cu privire la concedii? Data, citirea indicatorului rezervorului, carburantul 
(incluzând toate câmpurile din tabelul privind carburanţii), mâncarea (inclusiv gustările sau 
snackurile), motelul, total diverse taxe, şi altele. Din moment ce aceste achiziţii sunt efectuate 
printr-unul din cele 2 carduri bancare sau cu numerar am adăugat şi un câmp pentru a specifica 
metoda de plată.

Ce câmpuri vor descrie mâncarea? Micul dejun, prânzul, supa şi snackurile ar intra. Dar voi 
introduce fiecare snack în parte sau doar totalul zilnic? Aşa că am ales să împart snackurile în 
două câmpuri: numărul acestora şi costul total. De asemenea, am nevoie şi de metoda de plată 
pentru fiecare dintre acestea: micul dejun, prânzul, supa şi costul total cu snackurile.

Ce câmpuri vor fi comune pentru mai mult de un domeniu? Data va apare în toate domeniile şi 
la fel citirea indicatorului rezervorului şi metoda de plată.

Ce o să fac acum cu aceste trei câmpuri? Cât timp sunt în concediu, doresc ca cheltuielile 
zilnice să fie listate împreună. Câmpul de dată sugerează o posibilă alăturare între tabelul 
privind concediile şi cele privind combustibilul şi mâncarea, aşa că va fi folosit pentru a 
relaţiona tabelele între ele pe măsură ce vom crea baza de date.

Metoda de plată se referă la doup tipuri de carte de credit şi numerar, aşa că com crea un tabel 
cu un câmp pentru metoda plăţii şi vom folosi o listă derulantă din formularul de introducere 
de date.

Pont Deşi am înşirat mai sus câmpurile din viitoarea bază de date, mai există un câmp care 
s-ar putea să fie necesar: câmpul ce păstrează cheia primară. În unele tabele, acesta a 
fost deja decis, în altele ca de exemplu la metoda de plată acesta va fi creat 
suplimentar.

Crearea unei noi baze de date

Imaginea 125: Crearea unei noi baze de 
date.

Pentru a crea o nouă bază de date, apăsaţi pe săgeata de lângă pictograma Nou (New). Din 
meniul derulant, selectaţi Bază de date (Database) (Imaginea 125). This opens the Vrăjitorul 
de baze de date. Puteţi să deschideţi acest vrăjitor de la Fişier > Nou > Bază de date (File > 
New > Database).

Primul pas din Vrăjitorul de baze de date este o întrebare cu 2 răspunsuri: Creează o nouă 
bază de date (Create a new database) sau Conectare la o bază de date existentă (Connect 
to an existing database). Pentru acest exemplu, selectaţi Creează o nouă bază de date şi 
apoi apăsaţi Următorul (Next).
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Al doilea pas vă pune 2 întrebări cu câte 2 răspunsuri fiecare. Răspunsul implicit pentru prima 
întrebare este Da, înregistrează baza de date pentru mine (Yes, register the database for 
me) iar pentru a doua este Deschide baza de date pentru editare (Open the database for 
editing). Verificaţi că sunt selectate aceste răspunsuri şi apăsaţi Încheiere (Finish).

Notă Dacă baza de date nu este înregistrată nu va fi accesibilă în alte componente ale OOo 
precum Writer şi Calc. Dacă este înregistrată, va putea fi accesată de către toate 
componentele.

Salvaţi noua bază de date cu numele Automobile. Aceasta va deschide fereastra Automobile – 
OpenOffice.org Base, prezentată parţial în Imaginea 126.

Pont De fiecare dată când veţi deschide baza de date Automobile se ve deschide şi fereastra 
Automobile –  OpenOffice.org Base, Cu ajutorul acesteia pot fi efectuate modificări 
asupra bazei de date. Titlul acesteia va fi tot timpul de forma (numele bazei de date) – 
OpenOffice.org.

Aten ieţ Pe măsură ce creaţi şi editaţi baza de date trebuie să vă salvaţi munca în mod regulat. 
Aceasta înseamnă mai mult decât să îi daţi o salvare la început imediat după crearea 
tabelului. Va trebui să salvaţi baza de date integral după editarea tabelului.

De exemplu, după ce aţi creat primul tabel, va trebui să îl salvaţi înainte de a-l închide. 
Priviţi pictograma Salvează (Save) de pe bara de uenlte Standard (de sus) după ce 
tocmai aţi închis tabelul, şi veţi vedea că este activă. Apăsaţi-o, şi se va dezactiva. 
Astfel, aţi salvat nu numai tabelul, dar a fost salvat ca parte a bazei de date.

Crearea tabelelor din baza de date

Notă Într-o bază de date, un tabel (table) păstrează informaţia pentru un grup de elemente 
denumite câmpuri (fields). De exemplu, un tabel poate păstra o agendă, o listă de 
acţiuni, o agendă telefonică sau o listă de preţuri. O bază de date poate conţine unul 
sau mai multe tabele.

Pentru a lucra cu tabelele apăsaţi pictograma Tabele (Tables) din lista Bază de date (Database) 
sau apăsaţi Alt+a. Cele 3 operaţiuni pe care le puteţi efectua asupra unui tabel sunt în lista 
Sarcini (Task) (vedeţi Imaginea 126).
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Imaginea 126: Crearea tabelelor.

Utilizarea Vr jitorului pentru a cră ea un tabel

Aten ieţ

   

Fiecare tabel necesită un Câmpul de cheie primară (Primary key field). (Ce este cu 
acest câmp vă voi explica mai târziu.) Vom folosi acest câmp pentru a numerota 
înregistrările, aşa că ne dorim ca numărul să se incrementeze automat pe măsură ce 
adăugăm noi înregistrări.

Din moment ce nici unul dintre câmpurile necesare pentru baza de date Automobile nu sunt 
conţinute în vreunul dintre tabelele vrăjitorului, vom crea un tabel simplu, folosind Vrăjitorul, 
şi care tabel nu are nimic de a face cu baza noastră de date, pentru a vedea cum funcţionează 
Vrăjitorul.

Vrăjitorul permite ca într-un tabel câmpurile să provină din mai multe tabele din cele sugerate, 
aşa că vom crea un tabel cu câmpuri care provin din 3 tabele separate, sugerate de Vrăjitor.

Apăsaţi Utilizează Vrăjitorul pentru a crea un tabel (Use Wizard to Create Table). Aceasta va 
deschide Vrăjitorul de tabel (Table Wizard).

Notă Un câmp din tabel este o părticică de informaţie. De exemplu, într-un tabel ce 
conţine o listă de preţuri, va fi un câmp pentru numele produsului, unul pentru 
descrierea acestuia şi un al treilea pentru preţ. Pot fi adăugate mai multe câmpuri 
dacă este necesar.

Pasul 1: Selectaţi câmpurile.

Trebuie să alegeţi între 2 mari clase de tabele: Afaceri (Business) şi Privat (Personal). Fiecare 
categorie conţine propriile tabele dintre care puteţi alege. Vom folosi colecţia de tabele CD-
Collection Sample din categoria Privat pentru a selecta câmpurile necesare.

1) Categorie (Category): Selectaţi Privat (Personal). Lista derulantă Tabele exemplu 
(Sample Tables) se va modifica corespunzător.
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2) Tabele exemplu (Sample Tables): Selectaţi CD-Collection. Fereastra Câmpuri 
disponibile (Available fields) va afişa câmpurile disponibile în fiecare tabel.

3) Câmpuri selectate (Selected Fields): Folosind butonul > mutaţi câmpurile dorite din 
fereastra Câmpuri disponibile în fereastra Câmpuri selectate în următoarea ordine: 
CollectionID, AlbumTitle, Artist, DatePurchased, Format, Notes, şi NumberofTracks.

4) Câmpuri selectate din alt tabel (Selected Fields from another sample table). Apăsaţi pe 
Afaceri (Business) ca şi Categorie. Selectaţi Employees din lista derulantă cu tabelele 
exemplu. Folosiţi butonul > pentru a muta câmpul Photo din fereastra Câmpuri 
disponibile (Available fields) în fereastra Câmpuri selectate (Selected fields). Va fi afişat 
la sfârşitul listei imediat după câmpul NumberofTracks.

5) Dacă din greşeală câmpurile sunt într-o altă ordine decât cea de mai sus este momentul 
să corectaţi. Daţi clic pe nume câmpului pe care doriţi să îl mutaţi, pentru a-l selecta. 
Apoi, folosiţi săgeţile Sus (Up) şi Jos (Down) din partea din dreapta a listei Câmpuri 
selectate (Selected Fields) (vedeţi Imaginea 127) pentru a muta numele câmpului în 
ordinea dorită. Apăsaţi Următorul (Next).

Imaginea 127: Ordinea câmpurilor.

Aten ieţ

   

Sub lista Câmpuri selectate (Selected Fields) sunt 2 butoane, + şi –. Aceste butoane 
sunt folosite pentru a adăuga sau a şterge câmpurile din această listă. Fiţi atenţi când 
le utilizaţi, măcar până vă veţi obişnui cu crearea tabelelor (Imaginea 127).
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Pasul 2: Stabilirea tipurilor câmpurilor şi a formatelor.

La acest pas veţi stabili caracteristicile (proprietăţile) câmpurilor. La apăsarea pe un câmp 
informaţia din dreapta se va schimba. Puteţi ulterior să efectuaţi modificările dorite. (Vedeţi 
Imaginea 128.) Apăsaţi pe fiecare câmp, câte unul pe rând, şi efectuaţi schimbările listate mai 
jos.

Imaginea 128: Modificarea tipurilor câmpurilor.

Notă Dacă vreunul dintre aceste câmpuri necesită introducerea de informaţii, stabiliţi 
Înregistrare necesară (Entry required) ca Da (Yes). Dacă Înregistrare necesară este 
setat ca Da, atunci acest câmp va trebui să conţină ceva. De exemplu dacă FirstName 
are Înregistrare necesară setat ca Da, o înregistrare cu acest câmp vid nu va fi 
permisă. În general, stabiliţi ca Înregistrare necesară să fie Da numai dacă este 
necesar să existe neapărat ceva în acel câmp. În mod implicit, Înregistrare necesară 
este setat ca Nu (No).

• CollectionID: Modificaţi AutoValue de la No la Yes.

• AlbumTitle:

• Înregistrare necesară (Entry required): Dacă toată muzica dumneavoastră este 
pe albume, modificaţi Înregistrare necesară la Da. Altfel, lăsaţi Înregistrare 
necesară ca Nu.

• Lungime (Length): Cu excepţia când vreunul dintre titlurile albumelor depăşeşte 
100 caractere, inclusiv spaţiile, nu modificaţi lungimea.

Notă În Base lungimea maximă a fiecărui câmp trebuie specificată la crearea acestuia. Nu 
este uşor să o modificaţi mai târziu, astfel că luaţi-vă o marjă de siguranţă. Base 
foloseşte VCHAR ca formatare a câmpurilor de text. Acest format înseamnă că sunt 
folosite numai numărul de caractere păstrate în câmp, până la dimensiunea maximă a 
câmpului, Astfel, un câmp conţinând 20 de caractere va utiliza numai spaţiu pentru 20 
de caractere chiar dacă limita este stabilită ca fiind 100, aşa că 2 albume cu titluri de 
25 şi respectiv 32 de caractere vor utiliza spaţiul necesar numai pentru 25 şi 32 de 
caractere, nu pentru 200 de caractere.

• Artist: Folosiţi opţiunea Implicit (Default). Şi, deoarece muzica are autori, setaţi 
Înregistrare necesară la Da.

• Date Purchased: Lungime (Length): opţiunea implicită. Înregistrare necesară ar trebui 
să fie Nu. (S-ar putea să nu cunoaşteţi data.)

• Format: Modificaţi numai Înregistrare necesară de la Nu la Da.
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• Notes: Fără modificări.

• NumberofTracks: Modificaţi Tip câmp (Field Type) în Tiny Integer[TINYINT]. Număr 
maxim de piste audio (tracks) va fi 999.

• Photo: Folosiţi opţiunile implicite. Când aţi terminat, apăsaţi Următorul (Next).

Notă Fiecare câmp are ataşat un Tip câmp (Field Type). În Base tipul câmpului trebuie 
specificat. Acest tipuri includ text, numere întregi (integer), dată (date) şi numere 
zecimale (decimal). Dacă în câmp va fi păstrată informaţie de ordin general (de exemplu 
un nume sau o descriere) va trebui să folosiţi text. Dacă va conţine totdeauna un număr 
(de exemplu un preţ) tipul ar trebui să fie zecimal sau alt format numeric corespunzător. 
Vrăjitorul alege tipul corespunzător, astfel încât dacă doriţi să vedeţi exemple alegeţi 
câmpuri şi examinaţi ce rezultă cu ajutorul Vrăjitorului.

Pasul 3: Stabilirea cheii primare (primary key).

1) Creează o cheie primară (Create a primary key) ar trebui să fie selectat.

2) Selectaţi opţiunea Foloseşte un câmp existent ca cheie primară (Use an existing field as 
a primary key).

3) În lista derulantă Nume câmp (Field name) selectaţi CollectionID.

4) Bifaţi Valoare automată (Auto value) dacă nu este deja bifată.

5) Apăsaţi Următorul (Next).

Notă O cheie primară identifică în mod unic un element (sau înregistrare) dintr-un tabel. De 
exemplu, s-ar putea să cunoaşteţi 2 persoane numite “Randy Herring” sau 3 persoane 
ce au aceeaşi adresă, aşa că baza de date trebuie să poată distinge între aceştia.

Cea mai simplă metodă este de atribui un număr unic fiecăruia: se numerotează prima 
persoană cu 1, a doua cu 2 şi tot aşa. Fiecare element are un singur număr şi fiecare 
umăr este diferit, astfel încât este uşor să spui “înregistrarea nr. 172”. Aceasta este 
opţiunea aleasă aici: CollectionID este doar un număr atribuit automat de către Base 
fiecărei înregistrări din acest tabel.

Sunt şi căi mult mai complexe pentru a realiza aceasta, toate răspunsuri la 
întrebarea“Cum să fi usigur că fiecare înregistrare individuală din baza mea de date 
poate fi identificată în mod unic?”

Pasul 4: Crearea tabelului.

1) Dacă doriţi, puteţi să redenumiţi tabelul la acest moment, iar dacă o faceţi, daţi-i un 
nume sugestiv. În exemplul nostru nu este nevoie de nici o modificare.

2) Păstraţi bifată opţiunea Inserez date imediat (Insert data immediately).

3) Apăsaţi Încheiere (Finish) pentru a închide vrăjitorul. Închideţi fereastra creată de 
vrăjitor. Acum sunteţi înapoi în fereastra principală a bazei de date cu lista tabelelor, 
interogărilor, formularelor şi rapoartelor.
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Crearea unui tabel prin copierea unuia existent

Dacă deţineţi o vastă colecţie de muzică, s-ar putea să doriţi să creaţi câte un tabel pentru 
fiecare gen de muzică. În loc de a crea câte un tabel folosind vrăjitorul, este posibil să copiaţi 
tabelul original. Fiecare tabel poate fi denumit în funcţi de genul de muzică căruia îi este 
destinat, de exemplu Classical, Pop, Country şi Western, şi Rock - printre altele.

1) Apăsaţi pictograma Tabele (Tables) de pe bara Bază de date (Database) pentru a vedea 
tabelele existente.

2) Daţi clic-dreapta pe pictograma tabelului CD-Collection. Selectaţi Copiere (Copy) din 
meniul contextual.

3) Mutaţi pointerul mausului sub acest tabel, daţi clic-dreapta, şi selectaţi Lipire (Paste) 
din meniul contextual. Se ve deschide fereastra Copiere tabel (Copy table).

4) Modificaţi numele tabelului în Pop şi apăsaţi Următorul (Next).

5) Apăsaţi butonul >> pentru a muta toate câmpurile (Fields) din fereastra stângă în cea 
dreaptă şi apoi apăsaţi Următorul (Next).

6) Din moment ce toate câmpurile au deja tipul (File Type) corespunzător, nu ar trebui să 
fie necesară nici o modificare. Totuşi, acum este momentul de a efectua modificări. 
(Citiţi mai jos nota de Atenţie pentru a afla de ce.)  Apăsaţi Creează  (Create). Este 
creat un nou tabel.

Aten ieţ

   

O dată ce tabelele au fost create folosind vrăjitorul, posibilitatea de editare 
ulterioară a lor este limitată. Cheia primară (primary key) nu va mai putea fi 
modificată nicicum. Este totuşi posibil să adăugaţi noi câmpuri sau să le ştergeţi pe 
cele existente. Este posibil şi să modificaţi tipul câmpului, şi la crearea tabelului şi 
ulterior, cu condiţia ca acel câmp să nu conţină cheia primară. După ce au fost 
introduse date, ştergerea unui câmp duce la pierderea informaţiilor conţinute în 
câmpul respectiv din înregistrările introduse. Când creaţi un nou tabel este bine să 
stabiliţi corect numele, lungimea şi formatul câmpurilor înainte de a introduce date.

Aten ieţ Tabelele pot fi şterse foarte simplu, dar ştergerea implică pierderea tuturor datelor 
conţinute în fiecare câmp din tabelul şters. Dacă nu sunteţi sigur de ceea ce faceţi, 
nu ştergeţi un tabel.

Pentru a şterge un tabel, daţi clic-dreapta pe acesta în lista tabelelor. Selectaţi Şterge 
(Delete) din meniul contextual. O fereastră vă va întreba dacă sunteţi sigur că doriţi 
să ştergeţi tabelul. După ce aţi ales Da (Yes), tabelul şi datele ce erau în el sunt 
pierdute pentru totdeauna cu excepţia când aveţi o copie de siguranţă.

Crearea tabelelor în Concepere vizual  (Design View)ă

Conceperea vizuală este o metodă mai avansată pentru crearea unui nou tabel. Aceasta vă 
permite să introduceţi direct informaţiile despre fiecare câmp din tabel. Vom folosi această 
metodă pentru tabelele din baza noastră de date.

Notă Deşi Tip câmp (Field type) şi formatare (formatting) sunt diferite în Conceperea 
vizuală, conceptele sunt aceleaşi ca la Vrăjitor.
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Primul tabel pe care îl creem este Fuel. Câmpurile sale sunt FuelID, Date, FuelCost, 
FuelQuantity, Odometer şi PaymentType. FuelCost foloseşte moneda (currency) şi 2 zecimale. 
FuelQuantity şi Odometer folosesc tipul numeric cu 3 zecimale şi respectiv 1 zecimală. 
PaymentType foloseşte formatul text.

1) Apăsaţi Creare tabel în Concepere vizuală (Create Table in Design View).

2) FuelID:

1) Introduceţi FuelID ca primul Nume câmp (Field Name).

2) Selectaţi Integer[INTEGER] ca Tip câmp (Field Type) din lista derulantă. (Setarea 
implicită este Text[VARCHAR].)

Pont Tastă rapidă pentru selectarea din lista derulantă Tip câmp: apăsaţi tasta pentru prima 
literă a opţiunii dumneavoastră. Aceasta ar putea presupune să trebuiască să apăsaţi 
tasta de mai multe ori ca să ajungeţi la opţiunea dorită. După ce parcurgeţi opţiunile 
încă o apăsare vă va duce din nou la prima opţiune (ciclează).

După ce tastaţi numele câmpului în coloana Câmpuri (Fields), folosiţi tasta Tab 
pentru a vă deplasa la coloana Tip câmp (Field Type). Aceasta va introduce numele 
câmpului şi va selecta lista derulantă, în care puteţi apăsa pe prima literă a opţiunii 
dorite pentru o selectare rapidă, însă trebuie să o apăsaţi de câte ori este necesar.

3) Modificaţi Proprietăţile câmpului (Field Properties) din secţiunea de jos.

• Modificaţi Valoare automată (AutoValue) de la Nu la Da (Imaginea 129).

Imaginea 129: Secţiunea Proprietăţile câmpului (Field 
Properties) (AutoValue).

4) Setaţi FuelID ca şi Cheie primară (Primary key). 

• Daţi clic-dreapta pe triunghiul verde de la stânga lui FuelID (Imaginea 130).

Imaginea 130: Câmpul Cheie primară (Primary key).

• Apăsaţi PCheie primară (Primary Key din meniul contextual. Aceasta va plasa o 
pictogramă în faţa FuelID.

Notă Cheia primară (primary key) serveşte unui singur scop. Orice nume poate fi folosit 
pentru acest câmp. Nu este necesar ca numele câmpului de cheie primară să fie 
FuelID. L-am pus aşa ca să ştim cărui tabel îi aparţine după nume (Fuel + ID).
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3) Toate celelalte câmpuri:

1) Introduceţi numele următorului câmp în prima coloană (coloana Nume câmp, Field 
Name).

2) Selectaţi Tip câmp (Field Type) pentru fiecare câmp.

• Pentru Date folosiţi Date[DATE]. (Apăsaţi tasta D o dată pentru a o selecta.)

• PaymentType foloseşte Text[VARCHAR], setarea implicită.

• Toate celelate câmpuri folosesc Number[NUMERIC]. (Apăsaţi tasta N o dată 
pentru a o selecta.)

3) Selectaţi Proprietăţile câmpului (Field Properties) (Imaginea 131).

Imaginea 131: Secţiunea Proprietăţile câmpului (Field Properties).

• FuelCost, FuelQuantity şi Odometer necesită modificări în secţiunea 
Proprietăţile câmpului (Imaginea 131).

• FuelQuantity: Modificaţi Lungimea (Length) la 6 şi Cifre zecimale (Decimal 
places) la 3. (Multe pompe de combustibil măsoară combustibilul cu 3 
zecimale, cel puţin în SUA.)

• Odometer: Modificaţi Lungimea la 10 şi Cifre zecimale la 1.

• FuelCost: Modificaţi Lungimea la 5 şi Număr zecimale la 2. Apăsaţi butonul 
Exemplu formatare (Format example). Aceasta va deschide fereastra 
Formatare câmp (Field Format) (Imaginea 132).
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Imaginea 132: Opţiunile Formatare câmp (Field Format).

• Utilizaţi Monedă (Currency) ca şi Categorie (Category) şi orice din lista 
Formatare (Format) cu 2 cifre zecimale.

4) Repetaţi aceşti paşi pentru fiecare câmp din tabel.

Pentru a accesa mai multe opţiuni de formatare apăsaţi pe butonul din dreapta câmpului 
(din formular, nu din tabel!) Exemplu formatare (Format example) (butonul Format 
example).

5) Description poate fi orice, sau puteţi să nu scrieţi nimic. (Imaginea 133 este un 
exemplu.)

6) Pentru a salva şi a închide tabelul, selectaţi Fişier > Închide (File > Close).  Denumiţi 
tabelul Fuel.
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Imaginea 133: Exemplu de intrări Description.

Urmaţi aceiaşi paşi pentru a crea şi tabelul Vacations. Câmpurile şi tipurile acestora sunt listate 
în Imaginea 133. Asiguraţi-vă că aţi ales câmpul Date ca şi cheie primară înainte de a închide 
tabelul, denumiţi-l Vacations, şi salvaţi-l.

Crearea tabelelor din listă

Când aceeaşi informaţie ar figura în mai multe câmpuri, destinaţi un tabel pentru aceasta. 
Fiecare astfel de tabel va conţine doar 2 câmpuri: câmpul cu informaţia respectivă şi câmpul de 
ID, în această ordine. 

1) Urmaţi îndrumările din “Crearea tabelelor în Concepere vizuală (Design View)” de la 
pagina 190. În tabelul pe care îl vom crea, cele 2 câmpuri vor fi Type şi PaymentID. 
Asiguraţi-vă că AutoValue este stabilit ca Da (Yes) pentru câmpul PaymentID.  Setaţi 
câmpul PaymentID ca şi cheie primară. (Vedeţi Imaginea 134.)

2) Salvaţi tabelul sub numele Payment Type.

Imaginea 134: Tabel în Concepere vizuală.

Not : ă Dacă aveţi de creat mai multe tabele cu aceleaşi câmpuri, concepeţi un singur tabel şi 
produceţi-le pe celelalte prin copiere şi lipire. (Citiţi “Crearea unui tabel prin copierea
unuia existent” la pagina 190.) 

194 Capitolul 10  Ini iere în Baseţ



Crearea unei baze de date

Ad ugarea de date într-un ă tabel-listă

Tabelul-listă nu necesită un formular. În loc de acesta, adăugaţi datele direct în tabel. În acest 
exemplu, utilizaţi numele a două persoane cu un cont bancar şi cu numerar pentru plăţi.

1) În fereastra principală a bazei de date, apăsaţi pe pictograma Tabele (Tables) (Imaginea
126). Daţi clic-dreapta pe Payment Type  şi selectaţi Deschide (Open) din meniul 
contextual.

1) Introduceţi Dan în primul rând. Apăsaţi tasta Tab pentru a merge la rândul următor.

2) Introduceţi Kevin în al doilea rând.

3) Introduceţi Cash în al treilea rând.

2) Salvaţi şi închideţi fereastra tabelului.

Pont Tasta Enter poate fi folosită de asemenea pentru a vă deplasa între câmpuri. În acest 
exemplu, introduceţi Jan. în primul câmp Name. Enter mută cursorul la câmpul ID. 
Enter apoi mută cursorul la al doilea câmp Name. Tasta Săgeată-jos poate fi folosită 
pentru a vă deplasa din rând în rând.

Notă Câmpul PaymentID conţine <AutoField> până când veţi apăsa tasta Enter pentru a 
vă deplasa pe rândul secund, apoi devine 0. Pe măsură ce adăugaţi înregistrări pe 
fiecare rând, rândurile câmpului PaymentID conţin numere naturale consecutive. De 
exemplu primele 3 numere din acest câmp sunt 0,1,2.

Crearea unei Vizualiz ri (View)ă

O Vizualizare este o interogare (query). Din această cauză, detaliile despre cum să creaţi şi să 
utilizaţi o Vizualizare sunt în secţiunea Creating queries.

Imaginea 135: Vedere a unor câmpuri din tabelul Vacations.

O Vizualizare este de asemenea un tabel. Câmpurile acesteia provin din câmpurile unuia sau a 
mai multor tabele din baza de date. Vă permite să examinaţi diverse câmpuri fără a conta 
tabelul din care provin. O Vizualizare poate să cuprindă şi numai unele câmpuri dintr-un singur 
tabel, ca în Imaginea 135, sau câmpuri din mai multe tabele ca în Imaginea 136.

Imaginea 136: Vizualizare a câmpurilor din tabelele Fuel şi Payment Type.

Aten ieţ Nu puteţi introduce date într-o Vizualizare similar cu adăugarea lor într-un tabel, 

Capitolul 10  Ini iere în Baseţ 195



Crearea unei baze de date

deoarece aceasta este numai pentru vizualizarea datelor care au fost deja introduse.

Definirea rela iilorţ

Now that the tables have been created, what are the relationships between our tables? This is 
the time to define them based upon the questions we asked and answered in the beginning.

When on vacation, we want to enter all of our expenses all at one time each day. Most of these 
expenses are in the Vacations table, but the fuel we buy is not. So, we will relate these two 
tables using the Date fields. Since the Fuel table may have more than one entry per date, this 
relationship between the Vacations and Fuel tables is one to many. (It is designated 1:n.)

The Vacations tables also contains several fields for the type of payment used. For each field 
listing the payment type, there is only one entry from the Payment Type table. This is a one to 
one relationship: one field in one table to one entry from the other table. (It is designated 1:1.) 
Other tables also contain fields for the type of payment. The relationship between these fields 
of those tables and the Payment Type table are also 1:1.

Since the Payment Type table only provides a static list, we will not be defining a relationship 
between the Payment Type table and the fields of the other tables which use the entries of the 
Payment Type table. That will be done when the forms are created.

The Fuel and Maintenance tables do not really have a relationship even though they share 
similar fields: Date, and Odometer. Unless a person is in a habit of regularly getting fuel and 
having their vehicle serviced, the entries in these tables do not share anything in common.

Tip As you create your own databases, you need to also determine where tables 
are related and how.

Imaginea 137: Relation design window

We begin defining relationships by Tools > Relationships. The Automobile – OpenOffice.org 
Base: Relation design window opens (Imaginea 137). The icons we will use are  Add Tables 
and New Relation.

1) Click the Add Tables icon.  The Add Tables window opens.

1) There are two ways to add a table to the Relation design window. 

• Double-click the name of the table. In our case, do this for both Vacations and 
Fuel.
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• Or, click the name of the table and then click Add.

2) Click Close when you have added the tables you want (Imaginea 197).

Imaginea 138: Added table lists

2) Defining the relationship between the Vacations and Fuel tables.

1) Two ways exist to do this:

1) Click and drag the Date field in the Fuel table to the Date field in the Vacations 
table. When you release the left mouse button, a connecting line forms between 
the two date fields (Imaginea 139).

Imaginea 139: Designation for a 1:n relationship

1) Or, click the New Relation icon. This opens the Relations window (Imaginea 
140). Our two tables are listed in the Tables involved section.

1) In the Fields involved section, click the dropdown list under the Fuel label.

Imaginea 140: Setting the relationship between tables

1) Select Date from the Fuel table list.

2) Click in the cell to the right of this dropdown list. This opens a dropdown 
list for the Vacations table.
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3) Select Date from the Vacations table list. It should now look like Imaginea 
141.

4) Click OK.

Imaginea 141: Selected fields in a relationship

3) Modifying the Update options and Delete options section of the Relation window.

1) Right-click the line connecting the Date fields in the two table lists to open a context 
menu.

2) Select Edit to open the Relation window (Imaginea 142).

3) Select Update cascade.

4) Select Delete cascade.

Imaginea 142: Update options and Delete options section

While these options are not absolutely necessary, they do help. Having these options selected 
permits you to update a table that has a relationship defined with another table. It also permits 
you to delete a field from the table.

Creating a database form

Databases are used to store data. But, how is the data put into the database? Forms are used to 
do this. In the language of databases, a form is a front end for data entry and editing.
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A simple form consists of the fields from a table (Imaginea 208). More complex forms can 

contain much more. These can contain additional text, graphics, selection boxes and many 
other elements. Imaginea 207 is made from the same table with a text label (Fuel Purchases), a 
list box placed in PaymentType, and a graphic background.

Using the Wizard to create a form
We will use the Wizard to create two forms: Fuel and Vacations. The Fuel form will be a 
simple form while the Vacations form will contain a form and a subform. We will create the 
Vacations form with its subform and let you modify the Fuel form using the same process.

In the main database window (Imaginea 126), click the Form icon. Double-click Use Wizard 
to Create Form to open the wizard (Imaginea 145). Simple forms use only require some of 
these steps while more complex forms may use all of them.

Step 1: Select fields.

1) Under Tables or queries, select Vacations as the table. Available fields lists the fields for 
the Vacations table.

2) Click the right double arrow to move all of these fields to the Fields in the form list. 
Click Next.

Imaginea 145: Form Wizard steps
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Step 2: Set up a subform.

Since we have already created a relationship between the Fuel and Vacations tables, we will 
use that relationship. If no relationship had been defined, this would be done in step 4.

1) Click the box labeled Add Subform.

2) Click the radio button labeled Subform based upon existing relation.

3) Fuel is listed as a relation we want to add. So, click Fuel to highlight it as in Imaginea
146. Click Next.

Imaginea 146: Adding a subform

Step 3: Add subform fields.

This step is exactly the same as step 1. The only difference is  that not all of  the  fields will be 
used in the subform.

1. Select Fuel under Tables or queries.

2. Use the >> button to move all the fields to the right.

3. Click the FuelID field to highlight it.

4. Use the < button to move the FuelID to the left (Imaginea 147). 

5. Click Next.
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Imaginea 147: Selecting fields of a subform

Step 4: Get joined fields.

This step is for tables or queries for which no relationship has been defined. Since we want to 
list all expenses by the day they occur in both the form and subform, we will joint the Date 
fields of these two tables (Imaginea 148).

Imaginea 148: Selection of joined subform and main form fields

1) Select Date from the First joined subform field dropdown list. This is the Date field in 
the Fuel table. This is not the Primary key for the Fuel table, but it is known as a 
Foreign key.

2) Select Date from the First joined main form field dropdown list. This is the Date field in 
the Vacations table. This is the Primary key for the Vacations table. Click Next.

Note It is possible to create a relationship between two tables that is based upon more than 
one pair of fields. How to do that and why is discussed in the Base Guide.
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Caution When selecting a pair of fields from two tables to use as a relationship, they have to 
have the same field type. That is why we used the Date field from both tables: both 
their field types are Date[DATE]. 

Whether a single pair of fields from two tables are chosen as the relationship or two 
or more pairs are chosen, certain requirements must be met for the form to work.

• No field from the subform can be the Primary key for its table. (FuelID 
cannot be used.)

• Each pair of joined fields must have the same file type.

• One of the fields from the main form must be the Primary key for its table. 
(Date would have to be used.)

Step 5: Arrange controls.

Note  Each control in a form consists of two parts: label and field. This step in 
creating the form determine where a control's label and field are placed in 
relationship with each other. The four choices from left to right are Columnar 
left, Columnar - Labels on top, As Data Sheet, and In Blocks - Labels Above 
(Imaginea 149).

1) Arrangement of the main form: Click Columnar - Labels on top. (The labels will be 
placed above their field.

2) Arrangement of the subform: Click As Data Sheet. (The labels are column headings and 
the field entries are in spreadsheet format.) Click Next.

Imaginea 149: Control arrangements

Step 6: Set data entry.

Unless you have a need for any of these entries to be checked, accept the default settings. Click 
Next.
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Step 7: Apply styles.

1) Select the color you want in the Apply Styles list. (I chose the beige which is Orange 4 
in the Color table.)

2) Select the Field border you want. (I prefer the 3-D look. You might want to experiment 
with the different possible settings.)

3) Click Next.

Step 8: Set name.

1) Enter the name for the form. In this case, it is Fuel.

2) Click the circle in from of Modify the form. (This circle is called a radio button.)

3) Click Next. The form opens in Edit mode.

Modifying a form
We will be moving the controls to different places in the form and changing the background to 
a picture. We will also modify the label for the PaymentType field as well as change the field 
to a list box.

First, we must decide what we want to change and to what. The discussion will follow this ten 
step outline.

1) The Date field in the main form needs a dropdown capability. It also needs to be 
lengthened to show the day of the week, month, day, and year.

2) Shorten the length of the payment fields (all fields containing the word payment).

3) The controls need to be move into groups: food, fuel subform, and miscellaneous.

4) Some of the labels need to have their wording changed. Some single words should be 
two words. Some abbreviations should be used if possible (Misc. for miscellaneous).

5) The widths of several fields and labels need to be changed. Only Lunch, Supper, Motel, 
and Tolls have acceptable lengths. But for a better appearance, changes will be made to 
these as well.

6) All the fields whose label ends in Payment will be replaced with a list box. This box 
contains the entries from the Payment Type table.

7) The Note field needs to be lengthened vertically and a scroll bar added. It also needs to 
be moved.

8) Changes need to be made in the Date and PaymentType columns of the subform that are 
similar to the changes in the main form.

9) Headings need to be added for each group in the main form.

10)The background needs to be changed to a picture. Some of the labels will have to be 
modified so that they can be read clearly. The font color of the headings need to be 
changed as well.
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Here are some pointers that we will be using in these steps. The controls in the main form 
consists of a label and its field. Sometimes we want to work with the entire control, and other 
times we want to work with only the label or field. There are times when we want to work with 
a group of controls.

• Clicking a label or field selects the entire control. A border appears around the control 
with eight green handles (Imaginea 150). You can then drag and drop it where you want.

• Control+click a label or field selects only the label or field (Imaginea 151).

Imaginea 150: A selected control

• By using the Tab key, you can change the selection from the field to the label or the 
label to the field.

Imaginea 151: Selecting a field of a 
control

• Moving a group of controls is almost as easy as moving one of them.

1) Click the field of one of the top left control to be moved to select it.

2) Move the cursor to just above and to the left of the selected control.

3) Drag the cursor to the bottom right of the group of controls and release the mouse 
button.

1) As you drag the cursor, a dashed box appears showing what is contained in your 
selection. Make sure it is big enough to include the entire length of all the 
controls.

2) When you release the mouse button, a border with its green handles appears 
around the controls you selected (Imaginea 152).

Imaginea 152: Selecting multiple 
controls

4) Move the cursor over one of the fields. It changes to a double arrow (Imaginea 153).
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Imaginea 153: Double 
arrow

5) Drag the group of controls to where you want them.

Before changing the Date field, we will move the Lunch and Tolls controls to the right 5 cm (2 
inches).

Tip When either changing a size or moving a control, two properties of the Form Design 
toolbar should be selected: Snap to Grid, and Guides when Moving.  Your controls will 
line up better, and an outline of what you are moving moves as the cursor moves.

You should also have both rulers active (Tools > Options > OpenOffice.org Writer 
> View). Since the form is created in Writer, that is where you have to make sure both 
horizontal and vertical rulers have a check in the box in front of them.

Note I use centimeters when making changes in a form because centimeters are more 
accurate than inches. When moving controls (fields and their labels), placement is 
also more accurate. You can change your rulers from inches to centimeters by right-
clicking each ruler and selecting centimeter from the context menu. You do not have 
to understand what centimeters are. You only have to match your controls, labels, or 
fields to specific numerals on a ruler.

Step 1: Change the Date field.

1) Control+click the Date field to select it (Imaginea 151).

2) Move the cursor over the middle green handle on the right 
side. It should change to a single arrow (Imaginea 206).

3) Hold the left mouse button down as you drag the cursor to 
the right until the length is 6 cm. The vertical dashed line is lined up with the 6. (This is 
approximately 2.4 inches.) Release the mouse button.

4) Click the Control icon in the Form Controls toolbar (Imaginea 155). It is the one circled 
in red. The Properties: Date Field window opens. Each line contains a property of the 
field.

Imaginea 155: Form Controls toolbar

1) Go to the Date format property. This is a dropdown list with Standard (short) as the 
default setting.

1) Click the default Standard (short) to open the list.

2) Click the Standard (long) entry to select it.
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2) Scroll down to the Dropdown property. Its default setting is No. It is also a 
dropdown list.

1) Click the default No setting to open the list.

2) Click Yes to select it.

Tip To see what the Date field will look like, click the Form Mode On/Off icon (the 
second icon from the left in Imaginea 155). You can do this any time you want to see 
the form with the changes you have made.

Step 2: Shorten the width of a field.

All of the fields whose label contains the word payment are too wide. They need shortening 
before the controls are moved.

1) Control+click the BPayment field (Imaginea 156).

Imaginea 156: Selecting a field

1) Move the cursor over the middle green handle on the right. The cursor becomes a 
single arrow.

2) Drag the cursor to the left until the field is 2.5 cm wide (1 inch).

Note If you have the Snap to Grid and Guides when moving icons selected in the Design 
Format toolbar, you will see how wide the field is as you shorten it.

3) Repeat these steps to shorten these fields: Lpayment, SPayment,  SnPayment, 
Mpayment, and MiscPayment.

Step 3: Move the controls to group them by category.

We want to move the controls so that they look like Imaginea 157.
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Imaginea 157: Positioning of Controls

1) Click the first control you want to move. A border appears around the control with eight 
green handles.

2) Move the cursor over the label or field of the control. It becomes a double arrow 
(Imaginea 153).

3) Drag and drop the control to where you want it.

Caution

   

Do not use Control+click when moving a field. It moves either the field or the label 
but not both. To move both, use a mouse click and drag to the desired spot.

4) Use the same steps to move the rest of the controls to where they belong.

Note The only way to learn to do these two steps well is to practice them. Another way 
exists which will place controls where you want them, but this is a more advanced 
feature and will be explained in the Base Guide.

Step 4: Change the label wording.

Field names need to be single words. However, the labels for the fields can be more than one 
word. So, we will change them. To do so, we will be editing the text in the label.

1) Control+click the SnackNo label. Do one of the following:

1) Right-click the SnackNo label.

1) Select Control from the context menu (Imaginea 158). The window that opens 
is labeled Properties: Label field. It contains all of the properties of the selected 
label. 
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Imaginea 158: Context menu

1) In the Label selection, click between the k and N in SnackNo.

2) Use the spacebar to make SnackNo into 
two words.

3) Place a . (period) after the No.

1) Close the Properties window.

2)  Or, click the Control icon in the Form Control 
toolbar (Imaginea 160). The Properties window opens. The rest of the steps are the 
same.

Imaginea 160: Form Controls toolbar

2) Use the same procedure to change these labels as well: BPayment to Payment, 
LPayment to Payment, SPayment to Payment, Miscellaneous to Misc., SnackCost to 
Snack Cost, MPayment to Payment, MiscPayment to Misc. Payment, and MiscNotes to 
Misc. Notes.

Tip All of the listings in the Properties window can be modified by you. For example, by 
changing the Alignment from Left to Center, the word or words in the label are 
centered within the Label.  When you have some time, you might want to experiment 
with different settings just to see the results you get.

Step 5: Change the widths of the labels and fields.

We want the following controls to be 2 cm wide (0.8 inches): Breakfast, Lunch, Supper, 
Odometer, Snack No., Tolls, Snack Cost, Motel, and Misc. All of the payment fields were 
changed in step 2, but Misc. Payment needs to be changed to 3 cm (1.2 inches).

1) Click Breakfast. The border around it appears with eight green handles.
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2) Move the cursor over the middle green handle on the right. The cursor changes into a 
single arrow.

3) Drag and drop the cursor to the left to shorten the control or to the right to lengthen the 
control. Use the guide lines to determine the width.

4) Repeat for the other listed controls.

Step 6: Replace fields with other fields.

We want to replace the PaymentType field with a List Box. Then we can choose the type of 
payment from the Payment Type table rather than having to manually enter the type. In my 
case, each of my payment types begins with a different letter. If I enter the first letter of the 
payment type, the rest of the word automatically appears. I can then go to the next field.

1) Control+click the Payment field for Breakfast. The green handles appear around the 
field but not around the Label.

Imaginea 161: Selecting a field of a 
control

2) Right-click within the green handles and select Replace with > List Box. (Imaginea 158 
is the context menu which contains the Replace with select, and Imaginea 162 is the list 
of replacement fields.)
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Imaginea 162: Replacement fields

3) Click the Control icon in the Form Controls toolbar (Imaginea 160) to open the 
Properties window.

4) On the General tab, scroll down to the Dropdown selection. Change the No to Yes in this 
dropdown list.

Imaginea 163: Dropdown list open to reveal choices

5) Click the Data tab.
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Imaginea 164: Type of list contents dropdown list 

1) Type of list contents is a dropdown list. Change it to Sql.

2) Type the following exactly as it is in the List contents box:

SELECT "Type", "Type" FROM "Payment Type"

Tip You should be able to copy and paste SELECT "Type", "Type" FROM "Payment  
Type" from above directly into the List content box. Just make sure you copy from 
the  S in SELECT to the double quotation mark after the phrase Payment Type and no 
more than this.

Imaginea 165: List content for payment type fields

Note What you wrote is called an SQL command. The words SELECT and FROM are 
written in capital letters because they are commands. When the command SELECT is 
used, it requires a field name within quotation marks and then the field’s alias, also 
within quotation marks. In this case, the field and its alias are the same. The FROM 
command requires the name of the table which contains the field. Single-word table 
names do not require quotation marks, but multiple-word table names do.

6) Repeat these steps for the payment fields for Lunch, Supper, Motel, Snacks, and Misc. 
The main form should look like Imaginea 166 as far as where the controls are located. It 
also shows what the Note control should look like. Those changes are explained in the 
next step.
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7) Close the Properties window.

Imaginea 166: Position of controls in main form

Step 7: Change the Note field.

We want the Note control where it is located in Imaginea 166. Since it has a memo field type, 
it needs a vertical scrollbar for additional text space if desired.

1) Click the Note control.

2) Control+click the Note field. The green handles should surround the Note field but not 
its label.

3) Click the Control icon to open the Properties window (Imaginea 155).

4) Scroll down to the Scrollbars setting. Change the selection from None to Vertical in this 
dropdown list. 

Imaginea 167: Scrollbar selections in Properties 
window

5) Close the Properties window.
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6) Lengthen the Note field.

1) Move the cursor over the middle green handle at the bottom of the Note field. It 
becomes a vertical single arrow.

2) Drag the cursor down until the length is 6 cm (2.4 inches). 

Step 8: Change labels and fields in a subform.

The Date column needs to be widened. The field in the PaymentType column needs to be 
changed to a list box. The label for PaymentType column needs to be two words.

1) Change the PaymentType column.

1) Right-click the label PaymentType to open a context menu (Imaginea 168).

Imaginea 168: Choices for modifying a control in a 
subform

 

2) Select Replace with, and then select List box from the context menu.

3) Again right-click the label PaymentType to open a context menu.

4) Select Column. This opens the Properties window. (Imaginea 169)

5) In the Label box, change PaymentType to Payment Type.
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Imaginea 169: Properties window for control in a subform

6) Click the Data tab.

7) From the Type of list contents dropdown list, select sql.

8) Type the following exactly as it is written:

SELECT "Type", "Type" FROM "Payment Type"

9) Close the Properties window.

Tip Step 6: Replace fields with other fields., beginning with part 5, contains more 
detailed instruction.

Step 9: Add headings to groups.

1) Make sure the cursor in in the upper left corner. If it is not, click in that corner to move 
it there. 

2) Use the Enter key to move the cursor  to the fifth line from the top.

3) Change the Apply Styles dropdown list from Default to Heading 2 (Imaginea 170).

Imaginea 170: Apply Styles list

4) Use the spacebar to move the cursor to where you want the heading to start.

5) Type the heading Meals.

6) Use the spacebar to move the cursor to the center of snack area.
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7) Type the heading Snacks.

8) Use the Enter key to move the cursor between the Supper control and the subform.

9) Use the spacebar to move the cursor to the center of the subform.

10) Type the heading Fuel Data.

Note If you know how to use styles, you can open the Styles and Formatting window using 
F11. Right-clicking the Heading 2 paragraph style allows you to modify the 
appearance of all three headings. See the Writer Guide Chapter 6.

Step 10: Change the background of a form.

The background for a form can be a color, or a graphic (picture). You can use any of the colors 
in the Color Table at Tools > Options > OpenOffice.org > Colors. If you know how to create 
custom colors, you can use them. You can also use a picture (graphic file) as the background. 
We will use a picture found in OOo: sky.gif (Imaginea 171). Since the background is dark in 
places, many of the labels and headings will need changing in order to be seen.

Imaginea 171: background 
graphic

1)  Select the labels of the top row of controls.

1) Control+click the Date label.

2) Control+shift+click the rest of the labels of the top row. The border will gradually 
grow to the right as you do this until all the labels are enclosed in it.

Imaginea 172: Selecting multiple labels at one time

3) Click the Control  icon in the Design Form toolbar to open the Properties window.

4) Change the Background selection from Default to Light cyan. (This is a dropdown 
list.)

2) Select the other labels in the same way and then change their background color.

3) Close the Properties window.

Note I have chosen to use Light cyan as the background color for my labels. You are free 
to choose whatever color you wish including a custom color you earlier created.
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4) Press the F11 key to open the Styles and Formatting window (Imaginea 173). Notice the 
left icon has a black outline around it. This is the Paragraph Styles icon. Below it is a 
list of paragraph styles including headings.

Imaginea 173: Top portion of the Styles and Formatting window

1) Right-click Heading 2 and select Modify from the context menu.

Imaginea 174: Tabs of the Paragraphs: Heading 2 window

2) On the Paragraph Style dialog (Imaginea 174), click the Font Effects tab.

Imaginea 175: Left side of Font Effects 
tab
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3) Change the Font color dropdown list to Light cyan.

4) Click OK to close the Paragraph Style: Heading 2 dialog.

5) Press the F11 key to close the Formatting and Styles window.

Tip Learning how to use styles can be very helpful at times. By using styles, we changed 
the font color for all three headings at one time. There are other methods of changing 
the font color, but they require repeating the same steps for each heading.

5) Right-click the background and select Page from the context menu.

6) Click the Background tab (Imaginea 176).

Imaginea 176: Background tab of Page Styles

1) Change the As dropdown list from Color to Graphic.

2) Search for this file: sky.gif. It is located in the Gallery folder of OOo. 

3)  Click the Browse button in the File section. Browse to the folder containing sky.gif.

4) Select this file and click Open.

5) In the Type section, select Area.

6) Click OK to close the Page Style: Default window.

The form should look like Imaginea 178.

Step 11: Change the tab order.

The Tab key moves the cursor from field to field. This is much easier to do than to click each 
field to enter data into it. It also permits us to group our expenses into areas before we begin 
entering data. For example, all of our meal receipts can be grouped together as can our snacks 
and also our fuel purchases.

1) Control+click the Date field.
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2) Click the Form Design icon in the Form Controls toolbar to open the Form Design 
toolbar (Imaginea 177).

Imaginea 177: Form Controls toolbar with Form Design icon circled

Imaginea 178: Finished form

3) Click the Activation Order icon (Imaginea 179).

Imaginea 179: Form Design toolbar with Activation Order icon circled

4) Rearrange the order of the fields in the Tab Order window (Imaginea 180).
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Imaginea 180: Tab Order window

1) Find the txtMPayment listing near the bottom of the list and click it.

2) Click the Move Up button until txtPayment is just below fmtMotel. 

3) Use the same two steps to put the fields in the same order as in Imaginea 181.

Imaginea 181: Tab order for the main form

4) Click OK.

5) Save and close the form.

6) Save the database.
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Creating forms in Design View
This method requires using the Form Controls and Form Design toolbars extensively. These 
techniques are beyond the scope of this document. Instructions for creating forms using Design 
view will be described in the Ghidul bazelor de date (Database Guide).

Creating subforms in Design View
Again, this is beyond the scope of this document. Creation of subforms in Design View will be 
described in the Ghidul bazelor de date (Database Guide).

Accessing other data sources

OpenOffice.org allows data sources to be accessed and then linked into OOo documents. For 
example, a mail merge links an external document containing a list of names and addresses into 
a letter, with one copy of the letter being generated for each entry.

To register a data source, choose File > New > Database to open the Database Wizard. Select 
Connect to an existing database. This allows access to the list of data sources that can be 
registered with OOo. These data sources can be accessed similarly to a dBase database as 
explained in the next section.

Once a data source has been registered, it can be used in any other OOo component (for 
example Writer or Calc) by selecting View > Data Sources or pressing the F4 key.

Tip Mozilla Address Books and dBase databases (among others) can be accessed, and 
entries can be added or changed.

Caution Spreadsheets can be accessed, but no changes can be made in the spreadsheet entries. 
All changes in a spreadsheet sheet must be made in the spreadsheet, itself. Update the 
database afterwards to see the changes made in the spreadsheet.

Accessing a dBase database
1) File > New > Database  opens the Database Wizard window.

Note Clicking the New icon and Database in the drop-down menu also open the Database 
Wizard window. (See Imaginea 125.)

2) Select Connect to an existing database. Pressing the TAB key highlights the Database 
type drop-down list. Typing D selects dBase. Click Next. 

Note Clicking the arrows opens a menu from which you can select dBase (Imaginea 182).

220 Capitolul 10  Ini iere în Baseţ



Accessing other data sources

Imaginea 182: Database type selection

3) Click Browse and select the folder containing the database. Click Next.

4) Accept the default settings: Register the database for me, and Open the database for 
editing. Click Finish. Name and save the database in the location of your choice.

5) Create the Form using the Form Wizard as explained in “Creating a database form” 
beginning on page 198.

Accessing a Mozilla address book
Accessing a Mozilla Address Book is very similar to accessing a dBase database. 

1) Select File > New > Database.

2) Select Connect to an existing database. Select Mozilla Address Book as the database 
type (Imaginea 182).

3) Register this data source.

These are steps 1, 2 and 4 of “Accessing a dBase database” on page 220.

Accessing spreadsheets
Accessing a spreadsheet is also very similar to accessing a dBase database.

1) Select File > New > Database.

2) Select Connect to an existing database. Select Spreadsheet as the Database type 
(Imaginea 182).

3) Click Browse to locate the spreadsheet you want to access. If the spreadsheet is 
password protected, check the Password required box. Click Next.

4) If the spreadsheet requires a user’s name, enter it. If a password is also required, check 
its box. Click Next.

Caution This method of accessing a spreadsheet does not allow you to change anything in the 
spreadsheet. All modifications must be made in the spreadsheet itself. This method 
only allows you to view the contents  of the spreadsheet, run queries, and create 
reports based upon the data already entered into the spreadsheet.
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Registering databases created by OOo2.x
This is a simple procedure. Tools > Options > OpenOffice.org Base > Databases. Under 
Registered databases,there is a list of these databases. Below this list are three buttons: New..., 
Delete, Edit... To register a database created by OOo2.x:

1) Click New.

2) Browse to where the database is located.

3) Make sure the registered name is correct.

4) Click OK.

Using data sources in OpenOffice.org

Having registered the data source, whether a spreadsheet, text document, external database or 
other accepted data source, you can use it in other OpenOffice.org components including 
Writer and Calc.

Viewing data sources
Open a document in Writer or Calc. To view the data sources available, press F4 or select View 
> Data Sources from the pull-down menu. This brings up a list of registered databases, which 
will include Bibliography and any other database registered.

To view each database, click on the + to the left of the database’s name. (This has been done 
for the Automobile database in Imaginea 183.) This brings up Tables and Queries. Click on the 
+ next to Tables to view the individual tables created. Now double-click on a table to see all 
the records held in it.

Imaginea 183: Databases

Editing data sources
Some data sources can be edited in the View Data Sources dialog. A spreadsheet can not. A 
record can be edited, added or deleted.

The data is displayed on the right side of the screen. Click in a field to edit the value.

Beneath the records are five tiny buttons. The first four move backwards or forwards through 
the records, or to the beginning or end. The fifth button, with a small star, inserts a new record 
(Imaginea 184).

222 Capitolul 10  Ini iere în Baseţ



Using data sources in OpenOffice.org

Imaginea 184: View Data Sources navigation buttons

To delete a record, right-click on the gray box to the left of a row to highlight the entire row, 
and select Delete Rows to remove the selected row.

Imaginea 185: Deleting a row in the Data View window

Launching Base to work on data sources
You can launch OOo Base at any time from the View Data Source pane. Just right-click on a 
database or the Tables or Queries icons and select Edit Database File. Once in Base, you can 
edit, add and delete tables, queries, forms and reports.

Using data sources in OOo documents
To insert a field from a table into a document (for example a Calc spreadsheet or Writer 
document), click on the field name (the gray square at the top of the field list) and, with the left 
mouse button held down, drag the field onto the document. In a Writer document, it will appear 
as <FIELD> (where FIELD is the name of the field you dragged). In Calc it will appear as a 
text box.

One common way to use a data source is to perform a mail merge. Selecting Tools > Mail 
Merge Wizard or clicking on the Mail Merge icon (a small paper-and-envelope icon on the 
View Data Source pane) launches the Mail Merge wizard which steps through creating a mail 
merge document. This is covered in Chapter 11 (Using Mail Merge) in the Writer Guide.

Entering data in a form

Records are used to organize the data we enter into a form. They also organize the data we 
enter into a subform (Imaginea 186).
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Imaginea 186: Single Record 

Each type of field allows a different method to enter the data. In most if not all cases, more 
than one method can be used.

The first step to entering data in a form is to open it from the main database window.

• Click the Forms icon in the Database list.

• Find the form’s name in the Forms list (Vacations).

• Double-click the form’s name.

The quickest way to enter a date in the Date field is to click the arrow that opens the dropdown 
calendar. Then click the date you want (Imaginea 187). Use the Tab key to go to the Odometer 
field.

• Click the left arrow before May to go back one month (April 2007). 

• Click the right arrow after 2007 to go forward one month (June 2007). 

• Multiple clicks in either direction will change the month and year the same number of 
times as the number of clicks.
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Imaginea 187: Calendar dropdown

The Odometer, Tolls, and Motel fields are numerical fields. Enter values directly into them, or 
use the up and down arrows. When the value is entered, use the Tab key to go to the next field.

• The up arrow increases the value, and the down arrow decreases the value. 

• These two arrows only change the numerals to the left of the decimal place.

• Numerals to the right of the decimal place must be changed by deleting them and typing 
the desired ones.

The Motel's Payment field is a dropdown list. If as in my case, all of the elements of the list 
start with different letters, typing the first letter will select the desired letter. 

• If two or more elements of the list have the same first letter, repeated typing of the first 
letter will cycle through the elements with this same first letter. So, if you accidentally 
go past the the element you wanted, you can keep typing the first letter until it reappears 
again.

• When the selection is correct, use the Tab key to go to the Misc. field.

The rest of the fields of the main form are either numerical fields or dropdown lists until we 
reach the Misc. Notes field. It is a text field. Type anything you desire in this field just as you 
would any simple text editor.

Caution Since the Tab key is used to move between fields, it can not be used in a text field. 
All spacing must be done by the spacebar. Finally, the Enter key only acts as a line 
break to move the cursor to the next line.

Note If we did not have a subform for fuel data, using the Tab key would save all of the 
fields, clear them, and make the form ready to accept data on the second record. 

Since we have a subform form, using the Tab key places the cursor in the first Date field of the 
subform with the date automatically entered to match the Date field of the main form.
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The FuelCost, FuelQuanity, and Odometer fields are numerical fields. The Payment field is a 
dropdown list. Enter the data just as you did in the main form, and use the Tab key to go to the 
next field.

When you use the Tab key to leave the Payment field, it goes to the Date field of the next line 
and automatically enters the date. Now you can enter your second set of fuel data for this day.

To move to another record when the form has a subform, the directional arrows at the bottom 
must be use. There are four of them from left to right: First Record, Previous Record, Next 
Record, and Last Record (Imaginea 188). To the right of these arrows in the New Record icon.

To create a new record while in another record, click the New Record icon. And, two choices 
exist for creating a new record following the present record.

• Click the Next Record icon.

• Or, click the New Record icon.

Imaginea 188: Navigation arrows of a form

Tip The number in the Record box is the number of the record whose data is shown in the 
form. (The data from the second record of the Vacations form was displayed when I 
took the screenshot for Imaginea 188.) 

If you know the number of the record you want, you can enter it into the record box 
and then use the Enter key to take you to that record.

Imaginea 189 is a record with data inserted in its fields. Note that not all fields have data in 
them. It is only necessary to have data in every field if you determine ahead of time to require 
all fields contain data.
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Imaginea 189: Sample record of the Vacation form and subform

Creating queries

Queries are used to get specific information from a database. Using our CD-Collection table, 
we will create a list of albums by a particular artist. We will do this using the Wizard. The 
information we might want from the Fuel table includes what our fuel economy is. We will do 
this using the Design View.

Note Queries blur the differences between a database and a data source. A database is only 
one type of data source. However, searching for usable information from a data 
source requires a query. Since the query (one part of a database) does this, the data 
source appears to become one part of that database: its table or tables. Query results, 
themselves, are special tables within the database.

Using the Wizard to create a query
Queries created by the wizard provide a list or lists of information based upon what one wants 
to know. It is possible to obtain a single answer or multiple answers, depending upon the 
circumstances. Queries which require calculations are best created with the Design view.

In the main database window (Imaginea 126), click the Queries icon in the Databases section, 
then in the Tasks section, click Use Wizard to Create Query. The Query Wizard window opens 
(Imaginea 190). The information we want is what albums are by a certain musical group or 
individual (the album’s author). We can include when each album was bought.
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Note When working with a query, more than one table can be used. Since different tables 
may contain the same field names, the format for naming fields in a query is Table 
name and field name. A period (.) is placed between the table name and the field 
name.

Imaginea 190: First page of the Query Wizard

Step 1: Select the fields.

1) Select the CD-Collection table from the dropdown list of tables.

1) If the Tables selection is not Table: CD-Collection, click the arrow (circled in red in 
Imaginea 190).

2) Click Table: CD-Collection in the list to select it.

2) Select fields from the CD-Collection table in the Available fields list.

1) Click AlbumTitle, and use the > button (black oval in Imaginea 190) to move it to 
the Fields in Query list.

2) Move the Artist and DatePurchased fields in the same manner.

Tip To change the order of the fields, select the field you want to move and click the up 
or down arrow to move it up or down (circled in magenta in Imaginea 190).

3) Use the up arrow to change the order of the fields: artist, album, and date purchased.

1) Click the CD-Collection.Artist field.

2) Click the up arrow to move it above CD-Collection.AlbumTitle.
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Imaginea 191: List of fields added to the 
query

4) Click Next.

Step 2: Select the sorting order.

Up to four fields can be used to sort the information of our query. A little simple logic helps at 
this point. Which field is most important?

In our query, the artist is most important. The album title is less important, and the date 
purchased is of least importance. Of course, if we were interested in what music we bought on 
a given day, the date purchased would be the most important.

Imaginea 192: Sorting order page

1) Click the first Sort by dropdown list.

1) Click CD-Collection.Artist to select it.

2) If you want the artists to be listed in alphabetical order (a-z), select Ascending on the 
right. If you want the artist listed in reverse order (z-a), select Descending on the 
right (Imaginea 192).

2) Click the second Sort by dropdown list.

1) Click CD-Collection.ArtistTitle

2) Select Ascending or Descending according to the order you want.

3) Repeat this process for CD-Collection.DatePurchased.

4) Click Next.

Step 3: Select the search conditions.
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The search conditions available are listed in Imaginea 193. They allow us to compare the name 
we entered with the names of the artist in our database and decide whether to include a 
particular artist in our query or not.

Imaginea 193: Search conditions in the Query 
Wizard

• is equal to: the same as

• is not equal to: not the same as

• is smaller than: comes before

• is greater than: comes after 

• is equal or less than: the same as or comes before

• is equal or greater than: the same as or comes after

• like: similar to in some way

Note These conditions apply to numbers, letters (using the alphabetical order), and dates.

1) Since we are only searching for one thing, we will use the default setting of Match all 
of the following.

2) We are looking for a particular artist, so select is equal to.

3) Enter the name of the artist in the Value box. Click Next.

Step 4: Select type of query.

We want simple information, so the default setting: Detailed query is what we want. Click 
Next at the bottom of the window.

Note Since we have a simple query, the Grouping and Grouping conditions are not needed. 
Those two steps are skipped in our query.

Step 5: Assign aliases if desired.

We want the default settings. Click Next.

Step 6: Overview.

Name the query (suggestion: Query_Artists). To the right of this are two choices. Select 
Display Query. Click Finish.
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Step 7: Modify the query.

We are skipping this step since we have nothing to modify. If you select the Modify Query 
choice, the query would open in Design view. To make modifications, follow the instructions 
in the next section, “Using the Design View to create a query”.

Using the Design View to create a query
Creating a query using Design View is not as hard as it may first seem. It may take multiple 
steps, but each step is fairly simple.

What fuel economy is our vehicle getting (miles per gallon in the USA)? This question 
requires creating two queries, with the first query being used as part of the second query.

Caution The procedures we will be using only work with relational databases. This is because 
of how relational databases are constructed. The elements of a relational database are 
unique. (The primary key insures this uniqueness.) That is, there are no two elements 
which are exactly alike. This allows us to select specific elements to place into our 
queries. Without the elements of the relational database being unique from all other 
elements, we could not perform these procedures.

Step 1: Open the first query in Design View.

Click Create Query in Design View.

Step 2: Add tables.

Imaginea 194: Add Tables or Query window

1) Click Fuel to highlight it.

2) Click Add.

3) Click Close.

Tip Move the cursor over the bottom edge of the fuel table (Imaginea 195). The cursor 
become a single arrow with two heads. Drag the bottom of the table to make it longer 
and easier to see all of the fields in the table.
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Imaginea 195: Fuel table in 
query

Step 3: Add fields to the table at the bottom.

1) Double-click the FuelID field in the Fuel table.

2) Double-click the Odometer field.

3) Double-click the FuelQuantity field.

The table at the bottom of the query window should now have three columns (Imaginea 196).

Imaginea 196: Query table

Step 4: Set the criterion for the query.

We want to the query's FuelID to begin with the numeral 1.

1) Type >0 in the Criterion cell under FuelID in the query table

2) Click the Run Query icon in the Query Design toolbar. This icon is circled in red in 
Imaginea 197.

Imaginea 197: Query Design toolbar

Imaginea 198 contains the Fuel table with my entries and the query results based upon the Fuel 
table.
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Imaginea 198: Fuel table and query of the fuel table

Step 5: Save and close the query.

Since this query contains the ending odometer reading for our calculations, name it End-
Reading when saving it. Then close the query.

Step 6: Create the query to calculate the fuel economy.

1) Click Create Query in Design View to open a new query.

2) Add the Fuel table to the query just as you did in step 2: Add tables. But, do not close 
the Add Tables window.

3) Add the End-Reading query to this query.

1) Click the Query radio button to get the list of queries in the database (Imaginea
199).

Imaginea 199: Selecting queries to add to another 
query

2) Click End-Reading.

3) Click Add, and then click Close.

Step 7: Add fields to the table at the bottom of the query.
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Imaginea 200: Tables in this query

We are going to calculate the fuel economy. To do this we need the FuelQuantity and distance 
traveled. Since the FuelQuantity we want to use is at the ending odometer reading, we will use 
the End-Reading query to get it. We will also use the Odometer field from the Fuel table and 
End-Reading query.

1) Double-click FuelQuantity in the End-Reading query.

2) Double-click Odometer in the End-Reading query.

3) Double-click Odometer in the Fuel table.

Imaginea 201: Added fields to the 
query

Step 8: Enter the FuelID difference field.

We want the difference between the FuelID value of the Fuel table and FuelID value of the 
End-Reading query to equal one (1).

1) Type "End-Reading".FuelID - Fuel.FuelID in the field to the right of the Odometer field 
of the Fuel Table (Imaginea 202).

Type the numeral 1 (one) in the Criterion cell of this column.

Caution When entering fields for these calculations, you must follow this format: table or 
query name followed by a period follow by the field name. For hyphenated or 
multiple-word names (table or query), use double quotes around the table or query 
name. The query will then add the rest of the double quotes as in Imaginea 202.

Use the arithmetical symbol between the two. More than one calculation can be done 
by using parentheses to group the arithmetical operations. 
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Imaginea 202: Typing in calculation of fields

2) Calculate the distance traveled (Imaginea 203):

• Type "End-Reading".Odometer – Fuel.Odometer in the Field cell.

• Type >0 in the Criterion cell.

Imaginea 203: Field for distance traveled calculations

3) Calculate fuel economy (Imaginea 204):

1) Type ("End-Reading".Odometer – Fuel.Odometer)/"End-Reading".FuelQuanity in 
the Field in the next column to the right.

Imaginea 204: Fuel economy calculation field

Step 9: Run the query and make some modification.

After we run the query to make sure it works correctly, we will hide all of the fields that we do 
not need.

1) Click the Run Query icon in the Design Query toolbar. (Imaginea 197) The results are 
in Imaginea 205.
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Imaginea 205: Result of running the fuel economy query

Notice that not all of the last column label is visible because some of the labels are 
long. We can fix this problem by using an alias for many of the fields. The labels are 
replaced by their aliases.

2) Add Aliases: Type in aliases as they are listed in Imaginea 201.

Imaginea 206: Query table with aliases added

3) Run the query again. The results are in Imaginea 200.

Imaginea 207: Query run with aliases

We really do not need the column showing the difference between the FuelID fields 
from the table and query. So, we will hide it. While it will not be visible, it will still be 
used in the calculations.

4) Hide a field that does not need to be seen.

Remove the check in the box of the Visible cell as in Imaginea 194.

Imaginea 208: Making a field invisible in a query run

5) Rerun the query (Imaginea 191).

Imaginea 209: Query run with aliases
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Step 10: Close, save, and name the query.

My suggestion for a name is Fuel Economy.

There are obviously other calculations that can be made in this query such as cost per distance 
traveled and  how much of the cost belongs to each of the payments types.

Note To fully use queries requires a knowledge of mathematics and specifically set 
operations (unions, intersections, and, or, complements, and any combinations of 
these). For example, we listed all of our criteria in one row. That means that all of 
these criteria have to be met before a row of values will be created in the query. This 
is how the and operator works on sets.

It also requires having a copy of the Hsqldb User Guide available from 
http://hsqldb.org/.

Creating reports

Reports provide information found in the database in a useful way. In this they are similar to 
queries. Reports are generated from the database’s tables or queries. They can contain all of the 
fields of the table or query or just a selected group of fields. Reports can be static or dynamic. 
Static reports contain the data in the selected fields at the time the report was created. Dynamic 
reports can be updated to show the latest data.

For example, a report on vacation expenses divided into categories should probably be a static 
report because it is based upon specific data that does not change. However, a report on the 
fuel data should probably be a dynamic report, because this report depends upon data that does 
change.

Caution All reports are based upon a single table or query. So you need first to decide what 
fields you want to use in the report. If you want to use fields from different tables, 
you must first combine these fields in a single query. Then you can create a report on 
this query.

An example of this caution is creating a report on vacation expenses. Fuel costs are one part of 
that report as are meal costs. These values are contained in fields of two different tables: 
Vacations and Fuel. So this report requires creating a query.

Creating a static report
We will create a report on vacation expenses. Certain questions need to be asked before 
creating the report.

• What information do we want in the report?

• How do we want the information arraigned? 

• What fields are required to provide this information?

• Will a query have to be created because these fields are in different tables?
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• Are there any calculations required in the data before being added to the report?

The expenses for our vacation are motel, tolls, miscellaneous, breakfast, lunch, supper, snacks, 
and fuel. One possible report would simply list the totals of each of these expense groups. 
Another possible report would list the expense totals for each day of the vacation. A third 
possible report would list the totals for each expense group for each type of payment. (This 
would let us know where the money came from to pay the expenses.) At the present time, 
using the data from the queries in a spreadsheet is the best way to handle reports like this. In 
the near future, the report feature will include these abilities.

For our purposes, we will create two reports. The first one will list the expenses each day other 
than fuel. The second report will list the fuel costs each day. 

The fields we will need for the first report from the Vacations table are: Date, Motel, Toll, 
Breakfast, Lunch, Supper, SnackCost, and Miscellaneous. This report will not require an 
additional query.

The second report involves the Fuel table. Since fuel was purchased and entered into this table 
at times other than during the vacation, a query needs to be created that contains only the fuel 
purchased during the vacation.

Vacations table report

1) Create a new report.

1) Click the Reports icon in the Database list in the Automobile – OpenOffice.org 
window (Imaginea 126).

2) In the Tasks list, click Use Wizard to Create Report. The Report Wizard window 
opens.

2) Select the fields.

1) Select Table: Vacations in the Tables or Queries dropdown list.

2) Use the > to move these fields from the Available fields list to the Fields in report 
list: Date, Motel, Tolls, Miscellaneous, Breakfast, Lunch, Supper, and SnackCost 
(Imaginea 185). Click Next.

Imaginea 210: Adding fields to a report
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3) Label the fields.

Shorten Miscellaneous to Misc. Click Next.

4) Group fields.

Since we are grouping by the date, use the > button to move the Date field to the 
Grouping list. Click Next.

5) Sort options.

We do not want to do any additional sorting. Click Next.

6) Choose layout.

We will be using the default settings for the layout. Click Next.

Note If you feel adventurous, try selecting some of the other layout choices. After selecting 
a choice, drag and drop the Report Wizard window so that you can see what you have 
selected. (Move the cursor over the Heading of this window, and then drag and drop.)

7) Create report.

1) Label the report: Vacation Expenses.

2) Select Static report.

3) Click Finished.

Vacation fuel report

1) Create a query containing only fuel bought on the days of the vacation.

1) Open a query in Design View.

2) Follow the steps for adding tables in Add tables. Add the Fuel table.

3) Double-click these fields in the Fuel table listing: Date and FuelCost to enter them 
in the table at the bottom of the query.

4) In the Criterion cell of the Date field, type the following:

BETWEEN #5/25/2007# AND #5/26/2007#  
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Imaginea 211: Setting the criterion for a query

5) Save, name, and close the query. (Suggestion: Vacation Fuel Purchases.)

Tip When using dates in a query, enter them in numerical form MM/DDYYYY or 
DD/MM/YYYY depending upon your language's default setting for dates (my default 
setting is MM/DD/YYYY).

All dates must have a # before and after it. Hence, May 25, 2007 is written 
#05/25/2007#.

2) Open a new report.

1) Right-click the Vacation Fuel Purchases query.

2) Select Report Wizard from the context menu.

Note When a new report is opened in this way, the query used to open it is automatically 
selected in the Tables or Queries dropdown list.

3) Create the report.

Use >> to move both fields from the Available Fields to the Fields in Report list. Click 
Next.

4) Label fields.

Add a space to FuelCost to make it Fuel Cost (two words). Click Next.

5) Group fields.

1) Click Date to highlight it.

2) Use > to move the Date field to the Groupings list. Click Next.

6) Choose layout.

We will be making no changes in the layout. Click Next.

7) Create report (final settings).

1) Use the suggested name, which is the same as the query.

2) Select Static report. Click Finish.

240 Capitolul 10  Ini iere în Baseţ



Creating reports

Creating a dynamic report
We will create a report with some statistics on our fuel consumption. To do this, we have to 
modify two queries: End-Reading and Fuel Economy. We will be adding the FuelCost field to 
the End-Reading query. Then we will add the FuelCost field from the End-Reading query to 
the Fuel Economy query.

Tip When opening a query to edit it, it might appear as in Imaginea 175.  If you move 
your cursor over the black line (circled in red), it becomes a double headed arrow. 
Drag and drop it to a lower position.

Imaginea 212: Appearance of query when opened for editing

1) Add the FuelCost field to the End-Reading query:

1) Right-click the End-Reading query and select Edit from the context menu.

2) In the Fuel table list, double-click to add FuelCost to the bottom table (Imaginea
172).

3) Save and close the query.

Imaginea 213: Adding an additional field to the query
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2) Add the FuelCost field from the End-Reading query to the Fuel Economy query.

1) Right-click the Fuel Economy query and select Edit from the context menu.

2) Double-click the FuelCost field in the End-Reading query list to the table at the 
bottom.

3) Add a calculation field to the right of the FuelCost field.

1) Type the following in the Field cell:

"End-Reading".FuelCost/("End-Reading".Odometer – Fuel.Odometer)

2) Type the following in the Alias cell:

cost per mile

Note If you use the metric system, cost per km is the appropriate alias.

4) Save and close the query.

5) Open a new report.

Right-click the Fuel Economy query and select Report Wizard.

6) Select fields.

Move all the fields from the Available fields to the Fields in report list. Use the >> to 
do so. Click Next.

7) Label fields.

Change FuelCost to Fuel Cost by placing a space between the words. Click Next.

8) Group fields.

Use > to move the Date field to the Groupings list. Click Next.

9) Sort options: the wizard skipped this one.

10)Choose layout.

Accept the default. Click Next.

11)Create the report.

1) Change the report name to Fuel Statistics.

2) The default setting is Dynamic report, so no change is necessary.

3) Select Modify report layout. Click Finish.

Modifying a report
At the end of the last section, we left the Fuel Statistics report open in the edit mode (Imaginea
167). We will be working on that report. These same steps can be used with any report that you 
open for editing.
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Imaginea 214: A report in edit mode

The Author is the name you listed in Tools > Options > OpenOffice.org > User Data. The 
date is not correct. The columns need to be moved to the left to give a better appearance. None 
of the numbers are correct, but their only purpose is to show the number of decimal places.

Step 1: Change the date.

1) Click to the right of the date (4/26/20) so that the cursor is next to the field. Use the 
Backspace key to erase the date.

2) Insert > Fields > Date. This places today’s date where the original date was.

3) Changing the date formating:

1) Double-click the date field you just inserted. The Edit Fields: Document window 
opens (Imaginea 165).

Imaginea 215: Modifying a date field

2) Since this is a dynamic report, change the Select field from Date (fixed) to Date.

3) Change the Format to what you desire. (I use the Friday, December 31, 1999 
choice.) Click OK.

Step 2: Change the column widths.

The column widths can be changed by moving the cursor over the right border of each column 
so that it becomes a double-headed arrow. Then drag and drop it where you want it. This has to 
be done for each column in each table in the report. This can also be done with the last column 
on the right even though there is no black border. It should now look something like Imaginea
164.
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Imaginea 216: Realigned columns in a report

Step 3: Change the number formating in the cells.

The fuel quantity should have three decimal places. The Begin, End, and Distance should have 
one decimal place. Fuel Cost should be currency and have two decimal places, and Cost per 
mile should have three decimal places.

1) Right-click the cell below Quantity to open the context menu. (The cell is circled in red 
in Imaginea 164.)

2) Select Number format.

3) In the Options section (Imaginea 163), 

1) Change the number of Decimal places to 3.

2) Click the green checkmark. Click OK.

Imaginea 217: Option section of the Number Formating window

4) Change the Fuel Cost field.

1) Right-click in the cell below Fuel Cost.

2) Select Number Format.

3) In the Category list, select Currency. Click OK.

5) Change the Cost per mile field.

1) Right-click in the cell below Cost per mile.

2) Select Number Format.

3) In the Category list, select Currency.

244 Capitolul 10  Ini iere în Baseţ



Creating reports

4) In the Option section:

1) Set the number of decimal places to 3.

2) Click the green checkmark.

5) Click OK.

Step 4: Save and close the report.

Double-click the report. It should now look like Imaginea 161.

Imaginea 218: Final report
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Ce este Math?

Ce este Math?

Math este componenta din OpenOffice.org (OOo) componentă pentru scrierea ecuaţiilor 
matematice. Este folosită de obicei pentru editarea ecuaţiilor din documentele text, dar poate fi 
utilizată şi în cadrul altor aplicaţii sau în mod separat. Când este utilizată cadrul Writer-ului 
ecuaţiile sunt gestionate ca obiecte incluse în documentul text.

Notă Editorul de ecuaţii este utilizat doar pentru scrierea ecuaţiilor în forma specifică (după 
cum se vede în ecuaţia 1). Dacă doriţi să evaluaţi o expresie matematică vă rugăm să 
citiţi Calc Guide.

df x
dx

=ln x tan−1x2  
(1)

S  începemă

Pentru a insera o ecuaţie, mergeţi la Inserare > Obiect > Formulă (Insert > Object > 
Formula).

Editorul de ecuaţii deschide o zonă în partea de jos a ecranului şi o fereastră flotantă (Selecţie - 
Selection) apare pe ecran. De asemenea, veţi observa şi un mic dreptunghi (cu margini gri) în 
documentul dumneavoastră; este locul unde formula va fi afişată, ca în Imaginea 219.

Imaginea 219. Editorul de ecuaţii, fereastra Selecţie (Selection), şi locul 
unde va fi afişată formula.
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Editorul de ecuaţii foloseşte un limbaj bazat pe comenzi (instrucţiuni şi simboluri), numite 
markup, pentru a reprezenta formulele. De exemplu, %beta reprezintă caracterul grecesc beta (
 ). Acest limbaj este conceput să semene cu limba engleză cât mai mult posibil. De exemplu, 

a over b (a supra b) reprezintă o fracţie: 
a
b

.

Introducerea unei formule

Sunt trei metode de a introduce o formulă:

• Selectaţi simbolul formulei din fereastra Selecţie (Selection).

• Daţi clic-dreapta în editorul de ecuaţii şi selectaţi simbolul formulei din meniul 
contextual.

• Tastaţi o comandă în editorul de ecuaţii.

Meniul contextual şi fereastra Selecţie inserează în document comanda corespunzătoare 
simbolului dorit, sau comanda introdusă direct. Deoarece ceea ce scrieţi apare ca atare în 
cadrul documentului, este şi o metodă facilă de a învăţa limbajul OOoMath.

Notă Daţi clic în cadrul documentului pentru a ieşi din editorul de formule.

Daţi dublu-clic pe o formulă pentru a reintra în editor.

Fereastra Selec ie (Selection)ţ

Cea mai simplă metodă pentru a introduce o formulă este fereastra Selecţie, prezentată în 
Imaginea 220.

Imaginea 220. Simbolurile sunt împărţite în 
categorii.

Fereastra Selecţie este împărţită în două categorii principale.
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• Partea de sus grupează categoriile de simboluri. Daţi clic pe acestea pentru a schimba 
lista simbolurilor.

• Partea de jos arată lista simbolurilor disponibile în categoria curentă.

PONT Puteţi să afişaţi sau să ascundeţi fereastra Selecţie cu Vizualizare > Selecţie (View > 
Selection).

Exemplul 1 5×4

Pentru acest exemplu vom introduce o formulă simplă: 5×4 cu ajutorul fereastrei Selecţie:

1) Selectaţi din secţiunea categoriilor butonul grafic din stânga-sus (Imaginea 221).

2) Daţi clic pe simbolul înmulţirii (ca în Imaginea 221).

Imaginea 221. Operatori unari/binari.

Când selectaţi simbolul înmulţirii în fereastra Selecţie se petrec două lucruri:

• Editorul de ecuaţii arată instrucţiunea: <?> times <?>

• În textul documentului apare un dreptunghi gri cu imaginea: ×

Imaginea 222. Simbolul pentru înmulţire.

Simbolurile “ <?>” (Imaginea 222) sunt locurile în care veti scrie text. Ecuaţia va fi actualizata 
în mod automat, iar rezultatul va fi asemănător cu cel din Imaginea 223.
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Imaginea 223. Rezultatul introducerii lui "5" şi "4" de o parte şi 
de alta a operatorului "times" ("înmulţire").

Pont Pentru ca ecuaţia să nu mai fie actualizată automat, selectaţi Vizualizare > 
AutoActualizează ecranul (View > AutoUpdate display). 

Pentru a actualiza manual o formulă, apăsaţi F9 sau selectaţi Vizualizare > Actualizare 
(View > Update).

Meniul contextual
Altă metodă pentru accesarea simbolurilor matematice este să daţi clic-dreapta pe editorul de 
ecuaţii. Aceasta va conduce la apariţia unui meniu ca cel din Imaginea 224.

Imaginea 224. Meniul contextual.

Notă Opţiunile din acest meniu corespund exact cu cele arătate în fereastra Selecţie.

Markup
Puteţi introduce direct în editorul de ecuatii limbaj markup. De exemplu, dacă tastaţi “5 times 
4” obţineti 5×4 . Dacă veţi învăţa limbajul markup, aceasta va fi cea mai rapidă metodă de a 
introduce o formulă.
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Pont Pentru a va reaminti mai uşor, reprezentarea formulei în limbajul markup aminteşte de 
cum sună citirea formulei în engleză.

Mai jos este o scurtă listă de ecuaţii des întâlnite şi reprezentările corespunzătoare.

Formulă Comandă Formulă Comandă

a=b a = b  a sqrt {a}

a2 a^2 an a_n

∫ f xdx int f(x) dx ∑ an
sum a_n

a≤b a <= b ∞ infinity

a×b a times b x⋅y x cdot y

Caracterele greceşti

Caracterele greceşti (  ,  , , , etc) sunt des întâlnite în formule matematice. Aceste 
caractere nu se găsesc în fereastra Selecţie sau în meniul contextual. Astfel încât va trebui să 
învăţaţi reprezentarea lor textuală, care din fericire este destul de simplă: Tastaţi semnul % 
urmat de numele literei pe care o doriţi, dar în engleză.

• Pentru a introduce o minusculă, scrieţi numele caracterului cu minuscule.

• Pentru a introduce o majusculă, scrieţi numele caracterului cu minuscule.

Iată şi câteva exemple:

Minuscule Majuscule

%alpha   %ALPHA  A

%beta   %BETA  B

%gamma   %GAMMA  

%psi    %PSI   

%phi    %PHI   

%theta   %THETA  

Notă Tabelul cu toate caracterele alfabetului grecesc este inclus în capitolul 16 intitulat  
"Obiecte matematice" (“Math Objects”) din Ghidul Writer (Writer Guide).

Altă modalitate de a insera caractere greceşti este de a folosi fereastra Catalog. Alegeţi Unelte 
> Catalog (Tools > Catalog). Fereastra catalog este arătată în Imaginea 225. Sub Setul de 
simboluri (Symbol Set) selectaţi Grecesc (Greek) şi daţi dublu - clic pe o literă grecească din 
listă.
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Imaginea 225. Catalog - utilizat pentru introducerea caracterelor 
greceşti.

Exemplul 2  ≃ 3.14159

Pentru acest exemplu vom presupune că:

• Vrem să introducem formula de mai sus (valoarea lui pi rotunjită la 5 zecimale).

• Ştim numele caracterului grecesc (“pi”).

• Dar nu ştim cuvântul din limbajul markup pentru simbolul ≃ .

Pasul 1: Tastaţi “%” urmat de textul “pi”. Va apare caracterul grecesc  .

Pasul 2: Deschideţi fereastra Selecţie (Vizualizare > Selecţie (View > Selection)).

Pasul 3: Simbolul ≃  denotă o relaţie, aşa că vom apăsa pe butonul grafic pentru relaţii . 
Dacă ţineti mausul deasupra acestui buton (şi aveţi ponturile activate) va apare indicaţia despre 
categoria butonului, "Relaţii" “Relations” (Imaginea 226).

Imaginea 226. Pontul indică butonul grafic "Relaţii" 
(Relations).

Pasul 4: Ştergeţi textul <?> şi adăugaţi “3.14159” la sfârşitul ecuaţiei.  Aici vedem în fereastra 
editorului de ecuaţii “ %pi simeq 3.14159 ”. Rezultatul este arătat în Imaginea 227.
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Imaginea 227. Rezultatul final.

Personaliz riă

Editorul de formule ca fereastr  flotantă ă

După cum s-a văzut în Imaginea 219, editorul de formule poate acoperi o parte semnificativă a 
ferestrei de editare a Writer-ului. Pentru a transforma editorul de formule într-o fereastră 
separată procedaţi astfel:

1) Ţineţi mausul deasupra marginii ferestrei editorului de formule, ca în Imaginea 228.

2) Ţineti apăsată tasta Control şi daţi dublu-clic.

Imaginea 228. Ţineti apăsată tasta Control şi daţi dublu-clic pe marginea 
editorului de formule matematice pentru a-l transforma într-o fereastră 
flotantă.

Imaginea 229 arată rezultatul. Puteţi andoca fereastra folosind aceiaşi paşi. Ţineţi apăsată tasta 
Control şi daţi dublu-clic  key deasupra marginii ferestrei.
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Imaginea 229. Editorul de ecuaţii în fereastră separată.

Cum pot s  ă m rescă  formula?

Aceasta face parte dintre întrebările cele mai des repetate de către utilizatorii OOoMath. 
Răspunsul este simplu, dar nu intuitiv:

1) Porniţi editorul de formule şi alegeţi Fonturi > Dimensiunea fontului (Fonts > Font 
size).

Imaginea 230. Schimbarea dimensiunii fontului unei 
formule.

2) Selectaţi o dimensiune de font mai mare de la "Dimensiunea de bază" (“Base Size”) 
(primul câmp de sus), ca în Imaginea 231.
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Imaginea 231. Editaţi câmpul Dimensiunea de bază (Base 
size), primul de sus, pentru a mări formula.

Rezultatul este arătat în Imaginea 232.

Imaginea 232. Rezultatul schimbării dimensiunii fontului de 
bază.

Elaborarea formulei

Cea mai dificilă parte a utilizării OOoMath vine atunci când scrieţi ecuaţii complicate. Această 
secţiune vă oferă câteva sfaturi despre scrierea formulelor complexe.

Folosi i parantezeţ

OOoMath nu "ştie" nimic despre ordinea operaţiilor. Trebuie să folosiţi paranteze pentru a 
stabili explicit ordinea operaţiilor. De exemplu:

Expresie markup Rezultat

2 over  x + 1 2
x
1

2 over {x + 1} 2
x1

Ecua ii pe mai multe rânduriţ

Să presupunem ca doriţi să tastaţi o ecuaţie scrisă pe mai multe rânduri. De exemplu:
x=3
y=1
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Prima dumneavoastra reacţie ar fi să apăsaţi pur şi simplu Enter. Totuşi, veţi observa că atunci 
când apăsaţi Enter expresia markup trece pe linia următoare, însă nu şi ecuaţia. Va trebui să 
tastaţi explicit comanda pentru o linie nouă. Aceasta este arătată în tabelul de mai jos (newline 
se traduce prin linie nouă).

Expresie markup Rezultat

x = 3

y = 1

x=3 y=1

x = 3 newline

y = 1

x=3
y=1

Întreb ri frecventeă

Cum adaug limite pentru sum /integral ?ă ă

Comenzilor “sum” and “int” li se pot specifica (opţional) parametrii “from” şi “to”. Acesţia 
sunt utilizaţi pentru limitele de sus şi de jos. Aceşti parametri pot fi folosiţi câte unul sau 
împreună. Limitele pentru integrale sunt create ca scris-jos (subscript) şi scris-sus (superscript).

Expresie markup Rezultat

sum from k = 1 to n a_k
∑
k=1

n

ak

int from 0 to x f(t) dt

or 

int_0^x f(t) dt

∫
0

x

f t dt  or  ∫0

x
f t dt

int from Re f ∫
ℜ

f

sum to infinity 2^{-n} ∑
∞

2−n

Notă Pentru mai multe detalii despre integrale şi sume, citiţi capitolul 16 "Obiecte 
matematice" (“Math Objects”) din Ghidul Writer (Writer Guide).

Parantezele pentru matrice arat  oribil!ă

Pentru început, să vedem sintaxa comenzii pentru matrici:
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Expresie markup Rezultat

matrix { a # b ## c # d } a b
c d

Notă Rândurile sunt separate de două caractere # şi conţinutul fiecărui element este separat 
printr-un singur #.

Prima problemă este că parantezele obişnuite nu "acoperă" toată matricea:

Expresie markup Rezultat

(  matrix { a # b ## c # d }  ) 
a b
c d



OOoMath oferă paranteze "scalabile". Aceasta înseamnă că aceste paranteze cresc o data cu 
conţinutul matricei. Folosiţi comenzile left( and right) ( în traducere stânga şi dreapta) pentru a 
introduce paranteze scalabile.

Expresie markup Rezultat

left(  matrix { a # b ## c # d }  right)  a b
c d 

PONT Folosiţi left[ şi right] pentru paranteze scalabile pătrate.

Cum scriu o derivat ?ă

Scrierea derivatelor se face folosind un truc: Le scrieţi ca pe o fracţie.

Cu alte cuvinte, va trebui să folosiţi comanda “over”. Combinaţi aceasta fie cu litera “d” 
(pentru o derivare integrală) sau comanda “partial” (pentru o derivare parţială) pentru a obţine 
aspectul unei derivate.

Expresie markup Rezultat

{df} over {dx} df
dx

{partial f} over {partial y} ∂ f
∂ y

{partial^2 f} over {partial t^2} ∂2 f

∂ t 2

Notă Observaţi că a trebuit să folosim acolade pentru a scrie derivata.
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Întreb ri frecventeă

Numerotarea ecua iilorţ

Numerotarea ecuaţiilor este una dintre facilităţile obscure ale OOoMath. Paşii de urmat sunt 
simpli, dar neintuitivi:

1) Treceţi pe o linie nouă.

2) Tastaţi “fn” şi apoi apăsaţi F3.

Cuvântul “fn” este înlocuit de o formulă numerotată:

E=mc2  (2)

Acum puteţi da dublu-clic pe formulă pentru a o edita. De exemplu, mai jos este funcţia 
Riemann Zeta:

 z =∑
n=1

∞ 1

nz
 (3)

Puteţi să faceţi o referire la o ecuaţie (“după cum puteţi observa în ecuaţia (2)”) urmând aceşti 
paşi:

1) Inserare > Referinţă încrucişată (Insert > Cross-reference).

2) Daţi clic pe categoria Referinţe (References tab) (Imaginea 230).

3) Sub Tip (Type), selectaţi Text.

4) Sub Selecţie (Selection), alegeţi numărul ecuaţiei.

5) Sub Format, alegeţi Referinţă (Reference).

6) Apăsaţi Inserare (Insert).

Gata! Dacă mai târziu veţi adăuga ecuaţii în document înaintea ecuaţiei referite, toate ecuaţiile 
vor fi în mod automat renumerotate iar referinţele încrucişate vor fi actualizate.
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Imaginea 233. Inserarea unei referinţe către o ecuaţie numerotată.

PONT Pentru a insera numărul ecuaţiei fără paranteze, alegeţi Numerotare (Numbering) sub 
Format în loc de Referinţă (Reference).
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Ce este un şablon?

Ce este un şablon?

Un şablon este un model pe care îl folosiţi pentru a crea alte documente. De exemplu, puteţi să 
creaţi un şablon pentru rapoartele societăţii unde lucraţi care să aibă pe prima pagină sigla 
acesteia. Toate noile documente create pe baza acestui şablon vor avea întotdeauna sigla 
societăţii pe prima pagină.

Şabloanele pot conţine orice conţin şi documentele obişnuite, cum sunt textul, imaginile, 
stilurile, informaţiile specifice fiecărui utilizator precum unităţile de măsură, limba, care 
imprimantă este folosită uzual, personalizările de meniuri şi barele cu unelte.

Toate documentele din OpenOffice.org (OOo) sunt bazate pe şabloane. Puteţi crea un anumit 
şablon pentru orice tip de document (text, foaie de calcul, desen, prezentare). Chiar dacă nu 
specificaţi un şablon când creaţi un nou document, acesta va fi creat pe baza şablonului 
implicit în funcţie de tipul documentului. Chiar dacă nu aţi definit dumneavoastră un şablon 
implicit, documentul este creat pe baza unui şablon fără conţinut care a fost instalat o dată cu 
OOo. Consultaţi “Stabilirea unui şablon implicit” la pagina 269 pentru detalii.

Acest capitol vă va arăta cum să:

• Folosiţi un şablon pentru a crea un document

• Creaţi un şablon

• Modificaţi un şablon

• Stabiliţi un şablon implicit

• Organize templates

• Gestionaţi şabloanele

Folosirea unui şablon pentru a crea un 
document

Pentru a folosi un şablon când creaţi un document:

1) Alegeţi din meniu Fişier > Nou > Şabloane şi documente (File > New > Templates 
and Documents). Se va deschide fereastra Şabloane şi documente (Templates and 
Documents). (Vedeţi  Imaginea 234.)

2) În căsuţa din stânga, apăsaţi pe pictograma Şabloane (Templates) dacă nu este deja 
selectată. În căsuţa din centru va apare o listă de directoare cu şabloane.

3) Daţi dublu-clic pe directorul care conţine şablonul pe care doriţi să îl folosiţi. În căsuţa 
din centru va apare o listă cu toate şabloanele din acel director.

4) Apăsaţi pe şablonul pe care doriţi să îl folosiţi. Puteţi să previzualizaţi şablonul sau să 
vedeţi proprietăţile sale:

• Pentru a previzualiza şablonul, apăsaţi pictograma Previzualizare (Preview). O 
previzualizare a şablonului va fi afişată în căsuţa din dreapta.
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• Pentru a vedea proprietăţile şablonului, apăsaţi pictograma Proprietăţile 
documentului (Document Properties). Acestea vor fi afişate în căsuţa din dreapta.

5) Apăsaţi Deschide (Open). Fereastra Şabloane şi documente (Templates and Documents) 
se va închide şi un nou document bazat pe acel şablon se va deschide în OOo. Veţi putea 
modifica şi salva noul document la fel ca pe oricare altul.

 Imaginea 234. Fereastra Şabloane şi documente (Templates and Documents).

Crearea unui şablon

Puteţi să va creaţi propriile şabloane în două modalităţi:

• Pe baza unui document

• Folosind un vrăjitor

Crearea unui şablon pe baza unui document
Pentru a crea un şablon pe baza unui document:

1) Deschideţi un document nou sau existent de tipul celor pentru care creaţi şablonul (text, 
foaie de calcul, desen, prezentare).

2) Adăugaţi conţinutul şi stilurile pe care le doriţi.

1) Din meniul principal, alegeţi Fişier > Şabloane > Salvare (File > Templates > Save). 
Se va deschide fereastra Şabloane (Templates). (Vedeţi Imaginea 235).
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4) În câmpul Şablon nou (New template) introduceţi un nume pentru şablon.

5) În lista Categorii (Categories) alegeţi categoria căreia vreţi să îi asociaţi şablonul. 
(Categoria desemnează pur şi simplu directorul în care doriţi să salvaţi şablonul. De 
exemplu, pentru a-l salva în directorul “My Templates” (Şabloanele mele), apăsaţi pe 
categoria My Templates.)

Pentru a afla mai multe despre directoarele cu şabloane, vedeţi “Organizarea
şabloanelor” la pagina 270.

6) Apăsaţi OK. OOo va salva noul şablon iar fereastra Şabloane se va închide.

Imaginea 235. Salvarea unui şablon.

Orice opţiune sau setare care poate fi adăugată sau modificată într-un document poate fi 
inclusă într-un şablon. De exemplu, mai jos sunt câteva dintre setările care pot fi incluse într-
un document Writer şi care pot fi salvate în şablon pentru o utilizare ulterioară:

• Setările de imprimantă: imprimanta selectată, o singură faţă / faţă - verso, şi mărimea 
colii, etc

• Stilurile disponibile, incluzându-le pe cele de caracter, pagină, cadru, numerotare şi 
paragraf

• Formatări şi opţiuni privind indecşii, tabelele, bibliografiile, cuprinsul

Crearea unui şablon utilizând vr jitorulă

Puteţi folosi vrăjitorii pentru a crea aceste tipuri de şabloane:

• Scrisoare (Letter)

• Fax

• Agendă (Agenda)

• Prezentare (Presentation)

• Pagină web (Web page)
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De exemplu, vrăjitorul pentru fax vă conduce prin următoarele opţiuni:

• Tipul faxului (personal sau de afaceri)

• Elementele documentului ca de exemplu data, linia de subiect (faxul de afaceri) şi 
formula de salut, finalul

• Opţiunile privind informaţiile despre expeditor şi destinatar (faxul de afaceri)

• Textul care va fi inclus în subsolul paginii (faxul de afaceri)

Pentru a crea un şablon folosind un vrăjitor:

7) Din meniu alegeţi Fişier > Vrăjitori > (File > Wizards >) tipul şablonului necesar 
(Imaginea 236).

Imaginea 236. Crearea unui şablon folosind un 
vrăjitor.

8) Urmaţi instrucţiunile vrăjitorului. Acest proces va fi uşor diferit pentru fiecare tip de 
şablon, dar pe ansamblu sunt similare.

9) În ultima secţiune a vrăjitorului, şablonul ar trebui salvat. Destinaţia obişnuită este 
directorul personal pentru şabloane al utilizatorului, dar veţi putea alege o altă locaţie 
după preferinţă.

10)La sfârşit, aveţi opţiunea de a crea imediat un nou document bazat pe şablonul tocmai 
creat, ori să modificaţi şablonul. Pentru viitoarele documente veţi putea folosi şablonul 
creat de dumneavoastră cu vrăjitorul la fel ca pe celelalte şabloane.
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Modificarea unui şablon

Puteţi să modificaţi stilurile şi conţinutul unui şablon şi, după dorinţă, puteţi să reaplicaţi noile 
stiluri documentelor care au fost create pe baza şablonului. (Observaţi că nu puteţi decât să 
reaplicaţi stilurile. Nu veti putea reaplica şi conţinutul.)

Pentru a modifica un şablon:

1) Din meniu, alegeţi Fişier > Şabloane > Organizare (File > Templates > Organize). 
Se va deschide fereastra Management şabloane (Template Management). (Vedeţi 
Imaginea 237).

Imaginea 237. Fereastra Management şabloane (Template Management).

2) În căsuţa din partea stângă, daţi dublu-clic pe directorul care conţine şablonul pe care 
doriţi să îl editaţi. O listă cu toate şabloanele conţinute în acel director va fi afişată sub 
numele directorului.

3) Daţi clic pe şablonul pe care doriţi să îl editaţi.

4) Apăsaţi butonul Comenzi (Commands). Va apare un meniu derulant. 

5) Din meniul derulant alegeţi Editare (Edit). Fereastra Management şabloane se va 
închide iar şablonul selectat va fi deschis.

6) Modificaţi şablonul la fel cum aţi face cu orice alt document. Pentru a salva 
modificările, alegeţi Fişier > Salvează (File > Save) din meniul principal.

Data următoare când veţi deschide un document care a fost creat pe baza şablonului care acum 
este modificat va apărea o casetă de dialog, astfel:
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Imaginea 238. Dialogul pentru actualizarea stilurilor.

Apăsaţi Da (Yes) pentru a aplica documentului stilurile care s-au modificat în şablon. Apăsaţi 
Nu (No) dacă nu doriţi aceasta. Oricare dintre aceste opţiuni veti alege caseta de dialog se va 
închide iar documentul se va deschide în OOo.

Aten ie ţ Dacă veţi opta pentru Nu (No) în caseta de dialog anterioară, mesajul nu va mai fi 
afişat din nou la următoare redeschidere a documentului, astfel încât nu veţi mai avea 
nici o şansă de a actualiza stilurile pe baza şablonului în acest fel facil. Puteţi utiliza 
pentru aceasta macro-ul din Nota de mai jos.

Notă Pentru a reactiva actualizarea documentului pe baza şablonului:

1) Folosiţi Unelte > Macrouri > Organizare macrouri > OpenOffice.org Basic 
(Tools > Macros > Organize Macros > OpenOffice.org Basic). Selectaţi 
documentul din listă, apăsaţi semnul +, şi selectaţi Standard. Dacă Standard are un 
semn + lângă el, apăsaţi pe acela şi selectaţi un modul.

2) Denumiţi macroul. De exemplu, spuneţi-i FixDocument. Dacă butonul Editare 
(Edit) este activ, apăsaţi pe el. Dacă este inactiv, apăsaţi Nou (New), tastaţi un nume 
de modul în dialog şi apăsaţi OK.

3) În fereastra Basic introduceţi astfel:
Sub FixDocument
TemplateName = ThisComponent.DocumentInfo.Template
  if TemplateName <> "" then
  ThisComponent.DocumentInfo.Template = TemplateName
  end if
End Sub

4) Apăsaţi pictograma Rulează BASIC (Run BASIC), apoi închideţi fereastra 
Basic.

5) Salvaţi documentul.

Data următoare când veţi deschide documentul veţi fi întrebat din nou dacă doriţi 
actualizarea documentului.

Ad ugarea de şabloane cu ă Gestiune extensii

Package Manager (Gestiune pachete) a fost introdus în OOo 2.0.4 şi redenumit Gestiune 
extensii (Extension Manager) în OOo 2.1. Această facilitate este menită a oferi o cale facilă 
pentru instalarea de colecţii de şabloane, imagini, macrouri sau alte lucruri adăugate instalării 
uzuale a OOo care au fost în prealabil "împachetate" în fişiere cu  extensia *.OXT.
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1) După ce descărcaţi un pachet, selectaţi Unelte > Gestiune extensii (Tools > Extension 
Manager) din bara de meniu. În dialogul Gestiune extensii (Extension Manager) 
(Imaginea 239), apăsaţi Adaugă (Add).

Imaginea 239: Instalarea unui pachet de şabloane.

2) Se va deschide o fereastră pentru a localiza fişierul dorit. Găsiţi şi selectaţi pachetul de 
şabloane pe care doriţi să le instalaţi şi apăsaţi Deschide (Open).

3) În dialogul Gestiune extensii (Imaginea 238) selectaţi pachetul pe care tocmai l-aţi 
adăugat şi apăsaţi Activează (Enable).

Imaginea 240: Activarea unui proaspăt adăugat pachet de şabloane.
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Stabilirea unui şablon implicit

Atunci când creaţi un document alegând din meniu Fişier > Nou > Document text (File > 
New > Text Document) (sau Foaie de calcul - Spreadsheet, Prezentare - Presentation sau 
Desen - Drawing) OOo crează documentul pe baza şablonului implicit (default) pentru acel tip 
de document. Ce şablon este considerat implicit poate fi stabilit de către dumneavoastră. Puteţi 
de asemenea să reveniţi la setarea "de fabrică" dacă doriţi.

Stabilirea unui şablon personalizat ca implicit
Puteţi stabili ca orice şablon să fie cel implicit (Default), atâta vreme cât se afla într-unul din 
directoarele afişate în fereastra Management şabloane (Template Management).

Pentru a folosi un şablon propriu ca implicit:

1) Din meniu alegeţi Fişier > Şabloane > Organizare (File > Templates > Organize). Se 
va deschide fereastra Management şabloane (Template Management) (Imaginea 237).

1) În căsuţa din partea stângă daţi dublu-clic pe directorul conţinând şablonul pe care vreţi 
să îl folosiţi implicit.

2) Apăsaţi pe şablonul pe care doriţi să îl folosiţi implicit.

3) Apăsaţi butonul Comenzi (Commands).

4) Din meniul derulant apărut alegeţi Stabileşte ca şablon implicit (Set as Default 
Template). Data următoare când creaţi un document selectând Fişier > Nou (File > 
New), documentul va fi creat pe baza şablonului. 

Revenirea la şablonul implicit ini ial al OOoţ

Pentru a reveni la şablonul Default al OOo pentru un anumit tip de document:

1) Din meniul principal alegeţi Fişier > Şabloane > Organizare (File > Templates > 
Organize). Se va deschide fereastra Management şabloane (Template Management) 
(Imaginea 237).

2) În căsuţa din stânga apăsaţi pe orice director.

3) Apăsaţi butonul Comenzi (Commands).

4) Din meniul derulant apărut alegeţi Revenire la şablonul implicit iniţial (Reset Default 
Template).
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Organizarea şabloanelor

OOo poate folosi oricare dintre şabloanele care sunt în directoarele pentru şabloane ale OOo. 
Puteţi de asemenea să creaţi propriile directoare pentru şabloane şi să le folosiţi pentru a vă 
organiza şi administra şabloanele. De exemplu, vă puteţi crea un director pentru şabloanele 
pentru scrisori şi un altul pentru rapoartele pe care le scrieţi. Puteţi de asemenea importa şi 
exporta şabloane.

Pentru a începe, alegeţi Fişier > Şabloane > Organizare (File > Templates > Organize). Se 
va deschide fereastra Management şabloane (Template Management) (Imaginea 237).

Notă
Toate acţiunile realizate din butonul Comenzi (Commands) din fereastra Management 
şabloane pot fi realizate la fel dând clic-dreapta pe şabloane sau pe directoare.

Crearea unui director pentru şabloane
Pentru a crea un director pentru şabloane:

1) În fereastra Management şabloane apăsaţi pe orice director.

2) Apăsaţi butonul Comenzi (Commands).

3) Din meniul derulant alegeţi Nou (New). Un nou director denumit Untitled (Fară_titlu) 
va apare.

4) Tastaţi un nume pentru noul director şi apoi apăsaţi tasta Enter. OOo va salva directorul 
cu numele pe care l-aţi tastat.

Ştergerea unui director pentru şabloane
Nu puteţi şterge directoarele de şabloane create la instalarea OOo sau instalate din Gestiune 
extensii; puteţi şterge numai directoarele create de către dumneavoastră.

Pentru a şterge un director pentru şabloane:

1) În fereastra Management şabloane apăsaţi pe orice director.

2) Apăsaţi butonul Comenzi (Commands).

3) Din meniul derulant alegeţi Şterge (Delete). Va apare o casetă de dialog şi veţi fi rugat 
să confirmaţi ştergerea. Apăsaţi Da (Yes).

Mutarea unui şablon
Pentru a muta un şablon dintr-un director pentru şabloane în altul:

1) În fereastra Management şabloane daţi dublu-clic pe directorul care conţine şablonul pe 
care doriţi să îl mutaţi. O listă cu toate şabloanele conţinute în acel director va fi afişată 
sub numele său.
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2) Apăsaţi şablonul pe care doriţi să îl mutaţi şi trageţi-l în directorul dorit. Dacă nu 
deţineţi permisiunea de a şterge şabloane din directorul sursă, această acţiune copie 
şablonul în loc să îl mute (adică nu îl mai şterge din directorul iniţial).

Ştergerea unui şablon
Nu puteţi şterge şabloanele instalate de OOo sau din Gestiune extensii; puteţi şterge numai 
şabloanele create de către dumneavoastră.

Pentru a şterge un şablon:

1) În fereastra Management şabloane daţi dublu-clic pe directorul care conţine şablonul pe 
care doriţi să îl ştergeţi. O listă cu toate şabloanele conţinute în acel director va fi afişată 
sub numele său.

2) Apăsaţi pe şablonul pe care doriţi să îl ştergeţi.

3) Apăsaţi butonul Comenzi (Commands).

4) Din meniul derulant alegeţi Şterge (Delete). Va apare o casetă de dialog şi veţi fi rugat 
să confirmaţi ştergerea. Apăsaţi Da (Yes).

Importarea unui şablon
Dacă şablonul pe care doriţi să îl folosiţi este în afara sistemului de directoare ale OOo atunci 
va trebui să îl importaţi într-un director pentru şabloane al OO.

Pentru a importa un şablon într-un director pentru şabloane:

1) În fereastra Management şabloane daţi dublu-clic pe directorul în care doriţi să importaţi 
şablonul.

2) Apăsaţi butonul Comenzi (Commands).

3) Din meniul derulant alegeţi Import şablon (Import Template). Se va deschide 
fereastra obişnuită pentru localizat fişiere.

4) Găsiţi şablonul pe care doriţi să îl importaţi şi apăsaţi Deschide (Open). Fereastra se va 
închide iar şablonul va apare în directorul selectat. 

Exportarea unui şablon
Pentru a exporta un şablon dintr-un director pentru şabloane în altă parte:

1) În fereastra Management şabloane daţi dublu-clic pe directorul care conţine şablonul pe 
care doriţi să îl exportaţi. O listă cu toate şabloanele conţinute în acel director va fi 
afişată sub numele său.

2) Apăsaţi pe şablonul pe care doriţi să îl exportaţi.

3) Apăsaţi butonul Comenzi (Commands).
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4) Din meniul derulant alegeţi Export şablon (Export Template). Se va deschide 
fereastra Salvează ca (Save As).

5) Găsiţi directorul în care doriţi să exportaţi şablonul şi apăsaţi Salvează (Save).
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Ce sunt stilurile?

Ce sunt stilurile?

Un stil este un set de formatări pe care le puteţi aplica paginilor selectate, textului, cadrelor şi 
altor elemente din documentul dumneavoastră pentru a le schimba rapid înfăţişarea. Când 
aplicaţi un stil, aplicaţi simultan tot setul de formatări.

OpenOffice.org suportă următoarele tipuri de stiluri:

• Stilurile de pagină includ marginile, antetele şi subsolurile, chenarele şi fundalurile. În 
Calc, stilurile de pagină includ şi ordinea tipăririi paginilor.

• Stilurile de paragraf controlează toate opţiunile privind aspectul paragrafelor, ca 
alinierea textului, aliniatele, spaţierea dintre linii, chenarele şi pot să includă şi 
formatarea caracterelor.

• Stilurile de caracter afectează textul selectat din cadrul unui paragraf determinându-i 
fontul şi mărimea sau caracteristici precum caractere aldine sau italice.

• Stilurile de cadru sunt folosite pentru formatarea cadrelor imaginilor şi textului, 
incluzând felul trunchierii, chenarele, fundalurile şi coloanele.

• Stilurile de numerotare aplică alinierea, caracterele pentru numerotarea numerică sau 
grafică şi fonturile pentru listele cu buline sau numerotate, care astfel pot fi 
uniformizate.

• Stilurile de celulă includ fonturi, aliniere, chenare, fundal, formatul numerelor (de 
exemplu, valuta, data, numărul) şi protejarea celulelor.

• Stilurile grafice din desene şi prezentări includ linia, aria, umbrirea, transparenţa, fontul, 
conectorii, dimensionarea şi alte atribute.

• Stilurile de prezentare includ atributele pentru font, spaţiere pentru aliniate şi între linii, 
aliniere şi aliniate.

Stiluri diferite sunt disponibile în diversele componente ale OOo, fiind listate în Tabelul 2.

Tabelul 2. Stilurile disponibile în componentele OOo.

Tipul stilului Writer Calc Draw Impress

Pagină X X

Paragraf X

Caracter X

Cadru X

Numerotare X

Celulă X

Prezentări X X

Grafice (inclus în 
stilurile 
Cadru)

X X
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OpenOffice.org vine cu multe stiluri predefinite. Puteţi folosi aceste stiluri aşa cum vin sau 
puteţi să le modificaţi ori să creaţi noi stiluri, după cum veţi vedea în acest capitol.

De ce s  folosim stiluri?ă

Mulţi utilizatori formatează manual paragrafele, cuvintele, tabelele, paginile şi alte părţi din 
documentele lor fără a folosi stiluri. Ei sunt obişnuiţi să îşi scrie documentele în funcţie de 
atributele fizice. De exemplu, puteţi specifica fontul, mărimea lui şi alte atribute ca aldin sau 
italic.

Stilurile sunt atribute logice. Folosirea stilurilor înseamnă a înceta să spui “font de mărimea 
14pt, Times New Roman, aldin, centrat” pentru a spune “Titlu”, deoarece aţi definit stilul 
“Titlu” ca având acele atribute. Cu alte cuvinte, stilurile înseamnă că deplasaţi accentul de la 
cum arată textul, pagina sau alt element, la ce semnificaţie are.

Stilurile vă ajută să redactaţi uniform un document. De asemenea, facilitează schimbările 
majore de formatare. De exemplu, puteţi schimba alinierea tuturor paragrafelor sau schimba 
fontul tuturor titlurilor. În cazul unui document lung, aceste lucruri simple sunt prohibitive. 
Stilurile fac aceste sarcini uşoare.

În plus, stilurile sunt utilizate de OpenOffice.org pentru multe funcţii, chiar dacă nu sunteţi 
conştient de ele. De exemplu, OOo se bazează de stilurile de tip heading (folosite pentru titluri; 
poate folosi şi alte stiluri specificate de dumneavoastră) atunci când creează cuprinsul.

Aplicarea stilurilor

OpenOffice.org vă oferă câteva metode pentru a selecta stilurile pe care le veţi aplica.

Folosind fereastra Stiluri şi formatare

1) Apăsaţi pictograma Stiluri şi formatare (Styles and Formatting)  aflat în capătul 
stâng al panoului obiect sau alegeţi Formatare > Stiluri şi formatare (Format > 
Styles and Formatting) ori apăsaţi F11. Fereastra Stiluri şi formatare vă arată tipurile 
de stiluri disponibile în cadrul componentei OOo pe care o folosiţi. Imaginea 241 arată 
fereastra pentru Writer, fiind vizibile stilurile Pagină.

2) Puteţi deplasa această fereastră într-o zonă convenabilă pe ecran sau să o încorporaţi 
într-o margine (ţineţi apăsată tasta Ctrl şi trageţi-o de bara de titlu unde doriţi să o 
încorporaţi).

3) Daţi clic pe unul dintre pictogramele din partea de sus-stânga ale ferestrei Stiluri şi 
formatare pentru a afişa lista stilurilor din acea categorie.

4) Pentru a aplica un stil existent (cu excepţia stilurilor Caracter), poziţionaţi cursorul în 
cadrul paragrafului, cadrului sau paginii şi apoi daţi dublu clic pe numele stilului dorit 
din lista corespunzătoare. Pentru a aplica un stil Caracter, selectaţi caracterele mai întâi.
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Pont În partea de jos a ferestrei Stiluri şi formatare este o listă derulantă. În Imaginea 241 
fereastra arată Automatic, aceasta însemnând că lista include numai stilurile aplicate 
în mod automat de OOo). Puteţi alege să fie afişate toate stilurile sau diverse grupuri 
de stiluri, ca de exemplu numai stilurile personalizate.

Imaginea 241. Fereastra Stiluri şi formatare din Writer, arătând stilurile de paragraf.

Utilizarea modului Umplere formatare (Fill Format)
Utilizaţi Umplere formatare (Fill Format) pentru a aplica un stil la multe zone diferite rapid, 
fără a trebui să trecţi prin fereastra Stiluri şi formatare şi să daţi dublu-clic de fiecare dată. 
Această metodă este foarte folositoare când trebuie să formataţi multe paragrafe răzleţe, celule 
sau alte elemente cu acelaşi stil.

1) Deschideţi fereastra Stiluri şi formatare (Imaginea 241) şi selectaţi stilul pe care doriţi 
să-l aplicaţi.

2) Apăsaţi pe pictograma Mod Umplere formatare (Fill Format mode)  . Cursorul 
mausului se va schimba în această pictogramă.

3) Poziţionaţi cursorul mausului deasupra paragrafului căruia doriţi să îi aplicaţi stilul şi 
apăsaţi butonul mausului.

4) Dacă aplicaţi un stil de caracter, ţineţi apăsat butonul mausului în timp ce selectaţi 
caracterele.

5) Pentru a ieşi din modul de formatare cu umplere, apăsaţi încă o dată pictograma Mod 
Umplere formatare sau apăsaţi tasta Esc.

Aten ieţ Când este activ acest mod, un clic-dreapta oriunde în cadrul documentului 
anulează ultima acţiune de tip umplere cu formatare. Fiţi atenţi să nu daţi din 
greşeală clic-dreapta şi astfel să pierdeţi formatările efectuate.
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Folosind lista Aplic  stilulă

După ce l-aţi folosit cel puţin o data în document, numele stilului apare în lista Aplică stilul 
(Apply Style) (Imaginea 242) în partea de jos - stânga a barei de unelte Formatare, lângă 
pictograma Stiluri şi formatare.

Puteţi derula această listă şi alege stilul dorit cu un singur clic de maus sau puteţi folosi tastele 
cursor pentru a vă deplasa sus - jos iar când aţi găsit stilul dorit să tastaţi Enter pentru a-l 
aplica.

Imaginea 242. Lista Aplică stilul (Apply Style) de pe bara de unelte Formatare.

Pont Selectaţi Mai mult... (More...) la capătul listei pentru a deschide fereastra Stiluri şi 
formatare (Styles and Formatting).

Asignarea stilurilor tastelor rapide
OOo asigură un set de taste rapide (combinaţii de taste) predefinite care vă permit aplicarea 
rapidă a stilurilor, în timp ce tastaţi documentul. Puteţi să redefiniţi aceste taste rapide sau să 
vă definiţi propriile combinaţii.

1) Apăsaţi Unelte > Personalizare > Tastatură (Tools > Customize > Keyboard). Se va 
deschide categoria Tastatură (Keyboard) din dialogul Personalizare (Customize) 
(Imaginea 243).

2) Pentru a defini tasta rapidă numai pentru o componentă OOo (de exemplu, Writer), 
selectaţi componenta în partea din dreapta-sus a dialogului; dacă doriţi ca tasta rapidă să 
fie disponibilă în toate componentele OOo, selectaţi OpenOffice.org.

3) Alegeţi tastele rapide pe care doriţi să le definiţi. În acest exemplu am ales Ctrl+9.

4) La secţiunea Funcţii (Functions) din partea de jos a dialogului derulaţi în lista Categorie 
(Category) până la Stiluri (Styles) şi apăsaţi semnul +.

5) Alegeţi tipul stilului (în exemplu am ales un stil de paragraf). Lista Funcţie (Function) 
va afişa numele stilurilor disponibile pentru respectivul tip de stil. În imaginea captată 
se văd câteva stiluri predefinite ale OOo.
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6) Pentru a stabili ca Ctrl+9 să fie tasta rapidă pentru stilul Text Body (corp text), selectaţi 
Text Body din lista Funcţie şi apoi apăsaţi Modifică (Modify). Ctrl+9 va apare acum în 
lista Taste (Keys).

7) Efectuaşi orice al modificări vă sunt necesare şi apoi apăsaţi OK pentru a salva aceste 
setări şi a închide caseta de dialog.

.

Imaginea 243. Definirea tastelor rapide pentru aplicarea stilurilor.

Modificarea stilurilor

OpenOffice.org vă pune la dispoziţie două modalităţi de a modifica stilurile (atât stilurile 
predefinite cât şi cele create de dumneavoastră):

• Modificarea unui stil din caseta de dialog Stil

• Actualizarea unui stil pe baza selecţiei
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Pont Toate modificările făcute documentului sunt efective numai în documentul curent. 
Acestea nu sunt efectuate şi în documentul tip şablon pe baza căruia aţi creat 
documentul curent. Dacă doriţi ca schimbarea făcută să fie aplicabilă tuturor 
documentelor, va trebui să modificaţi şablonul (citiţi capitolul 12, Lucrul cu şabloane) 
sau copiaţi stilurile în celelalte documente, dupa cum este descris în “Copierea şi
mutarea stilurilor“ la pagina 281.

Modificarea unui stil din dialogul Stil
Pentru a modifica un stil existent folosind dialogul Stil, daţi clic dreapta pe stilul respectiv în 
fereastra Stiluri şi formatare (Imaginea 241) şi selectaţi Modifică (Modify) din meniul 
contextual.

Dialogul Stil afişat depinde de tipul stilului selectat. Fiecare tip de dialog are câteva categorii. 
Pentru detalii, vedeţi capitolele despre stiluri din ghidurile utilizator pentru fiecare componentă 
OOo.

Actualizarea unui stil pe baza selec ieiţ

Pentru a actualiza un stil pe baza selecţiei:

1) Deschideţi fereastra Stiluri şi formatare.

2) În document, selectaţi un element care este formatat tot aşa cum doriţi să fie şi stilul.

3) În fereastra Stiluri şi formatare selectaţi stilul pe are doriţi să-l actualizaţi (cu un singur 
clic, nu cu dublu clic), daţi clic mai lung pe săgeata de lângă butonul grafic Stil nou pe 
baza selecţiei (New Style from Selection) şi apoi daţi clic pe Actualizează stilul 
(Update Style) (vedeţi Imaginea 244).

Imaginea 244. Actualizarea unui stil pe baza selecţiei

Folosirea AutoActualizare (numai stilurile Paragraf şi 
Cadru)
Dacă este bifată căsuţa AutoActualizare (AutoUpdate) din pagina Organizator (Organizer) a 
dialogurilor Stil Paragraf sau Stil Cadru (Frame Style), modificarea în mod direct a formatării 
unui paragraf sau cadru ce foloseşte acest stil ve determina actualizarea automată a stilului.

Pont Dacă aveţi obiceiul ca să modificaţi documentul fără să vă pese de aspectul său unitar 
şi stilurile folosite atunci nu activaţi AutoActualizare. 
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Actualizarea stilurilor pe baza unui document sau 
şablon
Puteţi să actualizaţi stilurile copiindu-le sau încărcându-le dintr-un şablon sau dintr-un alt 
document. Citiţi “Copierea şi mutarea stilurilor” la pagina 281.

Crearea de stiluri noi (personalizate)

Puteţi să creaţi stiluri noi. Aveţi la dispoziţie două metode:

• Crearea unui stil nou folosind dialogul Stil (Style)
• Crearea unui stil nou pe baza selecţiei

Crearea unui stil nou folosind dialogul Stil (Style)
Pentru a crea un stil nou folosind dialogul Stil, daţi clic-dreapta în fereastra Stiluri şi formatare 
şi selectaţi Nou (New) din meniul contextual.

Dacă doriţi ca noul stil să fie legat cu un stil existent, în primul rând selectaţi acel stil, daţi clic-
dreapta şi selectaţi Nou (New).

Dacă legaţi stiluri, atunci când veţi modifica stilul de bază (de exemplu, schimbaţi fontul din 
Times în Helvetica), toate stilurile legate vor fi schimbate de asemenea. Uneori aceasta este 
exact ceea ce doriţi; alteori nu veţi dori ca schimbările să se repercuteze asupra tuturor 
stilurilor. Vă va ajuta o planificare atentă înainte de începerea redactării.

Dialogurile şi opţiunile sunt identice pentru definirea stilurilor noi ca şi pentru modificarea 
stilurilor existente. Citiţi capitolele despre stiluri din ghidurile utilizator pentru detalii.

Crearea unui stil nou pe baza selec ieiţ

Puteţi crea un stil nou copiind un stil existent. Acest nou stil va exista numai în documentul 
curent; nu va fi salvat în şablon.

1) Deschideţi fereastra Stiluri şi formatare şi selectaţi tipul stilului pe care doriţi să îl 
creaţi.

2) În document, selectaţi elementul al cărui stil doriţi să îl preluaţi.

3) În fereastra Stiluri şi formatare daţi clic pe pictograma Stil nou pe baza selecţiei (New 
Style from Selection).

4) În dialogul Creare stil (Create Style) (Imaginea 245), tastaţi numele noului stil. Lista 
arata numele stilurilor proprii existente de tipul respectiv. Daţi OK pentru a salva noul 
stil.
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Imaginea 245: Crearea unui stil nou pe baza selecţiei.

Tragerea cu mausul a unei selec ii pentru a crea unţ  
stil
Puteţi să trageţi cu mausul un text selectat în fereastra Stiluri şi formatare pentru a crea un stil 
nou.

Writer

Selectaţi nişte text şi trageţi-l cu mausul în fereastra Stiluri şi formatare. Dacă sunt selectate 
stilurile de paragraf, atunci la listă va fi adăugat un stil de paragraf. Dacă sunt selectate stilurile 
de caracter, atunci la listă va fi adăugat un stil de caracter.

Calc

Trageţi celulele selectate în fereastra Stiluri şi formatare pentru a crea un nou stil de celulă.

Draw/Impress

Selectaţi şi trageţi obiecte desenate în fereastra Stiluri şi formatare pentru a crea noi stiluri 
grafice.

Copierea şi mutarea stilurilor

Puteţi copia sau muta stiluri dintr-un şablon sau dintr-un document în alt şablon ori document, 
în două moduri:

• Folosind dialogul Managementul şabloanelor (Template Management)

• Încarcarea stilurilor dintr-un şablon sau dintr-un document

Folosind dialogul Managementul şabloanelor
Pentru a copia sau muta stiluri folosind dialogul Managementul şabloanelor:

1) Alegeţi Fişier > Şabloane > Organizare (File > Templates > Organize).
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2) În dialogul Managementul şabloanelor (Imaginea 247), selectaţi din listele derulante fie 
şabloane fie documente, după cum doriţi. Implicit este Şabloane în stânga şi Documente 
în dreapta.

Pont Pentru a încărca stiluri dintr-un document care nu este deschis în acest moment, 
apăsaţi butonul Fişier (File). După ce vă veţi reîntoarce la această fereastră fişierul 
selectat va fi afişat în ambele liste alături de celelalte documente care sunt deschise.

Imaginea 246: Optarea pentru a copia stiluri din documente, nu din şabloane.

3) Deschideţi directoarele şi localizaţi şabloanele din care şi în care doriţi să copiaţi.  Daţi 
dublic-clic pe numele şablonului sau al documentului, şi apoi daţi dublu-clic pictograma 
Stiluri (Styles) pentru a afişa lista stilurilor individuale(Imaginea 248).

4) Pentru a copia un stil ţineţi apăsată tasta Ctrl şi trageţi numele stiluri dintr-o listă în alta.

Aten ieţ Dacă nu veţi ţine apăsată tasta Control în timp ce trageţi stilul acesta va fi mutat 
dintr-o listă în alta, ceea ce înseamnă că va fi şters din lista de unde l-aţi luat.

5) Repetaţi pasul anterior pentru fiecare stil pe care doriţi să îl copiaţi. Dacă şablonul sau 
documentul destinaţie are deja mai multe stiluri va trebui să căutaţi stilurile copiate sau 
mutate la sfârşitul listei acestora. Când aţi terminat apăsaţi Închide (Close).
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Imaginea 247: Copierea unui stil dintr-un document în altul.

Înc rcarea stilurilor dintr-un şablon sau dintr-ună  
document
Puteţi copia stiluri încărcându-le dintr-un şablon sau alt document:

1) Deschideţi documentul în care doriţi să copiaţi stilurile.

2) În fereastra Stiluri şi formatare, ţineţi apăsat pe săgeata de lângă butonul grafic Stil nou 
pe baza selecţiei (New Style from Selection) şi apoi daţi clic pe Încarcă stiluri (Load 
Styles) (vedeţi Imaginea 244).

3) În dialogul Încarcă stiluri (Load Styles) (Imaginea 248) găsiţi şi selectaţi şablonul din 
care doriţi să copiaţi stilurile.

Imaginea 248. Copierea stilurilor din şablon în documentul deschis.

4) Bifaţi căsuţele pentru categoriile de stiluri pe care doriţi să le copiati. Selectaţi 
Suprascrie (Overwrite) dacă doriţi ca stilurile copiate să înlocuiască oricare alte stiluri 
cu aceeaşi denumire deja existente în documentul în care copiaţi stilurile.

5) Apăsaţi OK pentru a copia stilurile. Nu se va afişa nimic pe ecran.
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Notă Pentru a copia stilurile din alt document, alegeţi butonul Din fişier (From File) 
pentru a deschide o fereastră din care veţi putea selecta documentul necesar. 

Ştergerea stilurilor

Nu puteţi şterge stilurile predefinite ale OOo dintr-un şablon, chiar dacă nu le folosiţi în 
document.

Puteţi şterge din stilurile proprii, însă înainte de a face aceasta asiguraţi-vă că respectivele 
stiluri nu sunt folosite. Dacă doriţi să ştergeţi stiluri care sunt folosite, substituiţi-le.

Înlocuirea stilurilor (urmată de ştergerea celor nedorite) poate fi foarte utilă dacă aveţi de a face 
cu un document pe care au lucrat mai mulţi utilizatori sau a fost alcătuit pe baza mai multor 
documente, din surse diferite.

Pentru a şterge stilurile nedorite, daţi clic-dreapta pe ele (unul câte unul) în fereastra Stiluri şi 
formatare şi apoi alegeţi Şterge (Delete) din meniul contextual.

Dacă stilul este încă folosit în document, veţi fi avertizat ca în Imaginea 249.

Imaginea 249. Ştergerea unui stil folosit.

Aten ie ţ Asiguraţi-vă că stilul nu mai este folosit înainte de a-l şterge, altminteri toate 
obiectele care îl aveau aplicat vor primi stilul implicit şi vor reţine toate formatările 
stilului şters ca formatări manuale, ceea ce poate deveni o problemă într-un document 
mare.

Dacă stilul nu mai este folosit, veţi primi mesajul din Imaginea 246.

Imaginea 250. Ştergerea unui stil nefolosit.
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Ce este Galeria?

Ce este Galeria?

Galeria (Gallery) conţine obiecte (imagini şi sunete) pe care le puteţi insera în documentele 
dumneavoastră. Galeria este disponibilă în toate componentele OpenOffice.org.

Pentru a  deschide Galeria alegeţi Unelte > Galerie (Tools > Gallery), sau apăsaţi pictograma 

Galeriei . Dacă Galeria era deja deschisă aceste acţiuni o vor închide la loc.

Oniectele grafice din Galerie sunt grupate pe teme, de exemplu Buline (Bullets), Rigle 
(Rulers) şi Efecte 3D (3D Effects). Puteţi crea alte grupuri sau “teme” după dorinţă.

Zona din stânga ferestrei Galeriei afişează temele disponibile. Apăsaţi pe o temă pentru a afişa 
în fereastra Galeriei obiectele pe care le conţine.

Imaginile 251 şi 252 prezintă una dintre temele furnizate împreună cu OpenOffice.org în cele 2 
modalităţi de vizualizare.

Pentru a vizualiza Galeria aveţi două opţiuni,  Vizualizare pictograme (Icon View) sau 
Vizualizare detaliată (Detailed View), şi puteţi afişa sau  ascunde Galeria cu butonul Ascunde 
(Hide).

Imaginea 251. Vizualizare ca pictograme (Icon view) a unei teme din Galerie.

Imaginea 252. Vizualizare detaliată (Detailed view) a aceleiaşi teme din 
Galerie.
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Inserarea obiectelor în document

Puteţi să copiaţi sau să legaţi un obiect din Galerie într-un document. Diferenţa este că dacă 
obiectul este legat, puteţi opta pentru actualizarea lui şi în document după modificarea 
obiectului în Galerie, actualizând legătura (link).

Pentru a insera un obiect:

1) Alegeţi Unelte > Galerie (Tools > Gallery) şi selectaţi o temă.

2) Selectaţi un obiect cu un singur clic, apoi trageţi-l în document. (Vedeţi Imaginea 253.)

Imaginea 253. Copierea unui obiect grafic din Galerie în documenul curent.

De asemenea, puteţi da clic-dreapta pe obiect pentru a deschide meniul contextual şi să 
selectaţi Inserare > Copiere (Insert > Copy).

Inserarea obiectelor ca leg turiă

Pentru a insera nu obiectul, ci o legătură către el:

1) Alegeţi Unelte > Galerie (Tools > Gallery) şi selectaţi o temă.

2) Selectaţi un obiect cu un singur clic, apoi trageţi obiectul în document ţinând apăsate 
tastele Shift şi Ctrl.
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Inserarea unui obiect ca fundal
Pentru a insera un obiect ca fundal al unei pagini sau al unui paragraf:

1) Alegeţi Unelte > Galerie (Tools > Gallery) şi selectaţi o temă. 

2) Selectaţi un obiect cu un singur clic, daţi clic-dreapta pe el şi alegeţi Inserare > Fundal 
> Pagină sau paragraf (Insert > Background > Page or Paragraph).

Gestionarea Galeriei

Temele instalate cu Openoffice.org sunt blocate; nu pot fi adăugate sau şterse obiectele din 
acestea. Temele blocate pot fi recunoscute uşor dând clic-dreapta pe ele; singura opţiune 
disponibilă în meniul contextual este Proprietăţi (Properties).

În instalarea obişnuită poate fi personalizată numai tema My themes iar pe lângă aceasta mai 
pot fi create noi teme, aşa cum este explicat în continuare.

Ad ugarea imaginilor în Galerieă

Metoda 1 (selectarea unui fişier):

1) Daţi clic-dreapta pe numele temei din lista temelor şi alegeţi Proprietăţi (Properties) 
din meniul contextual.

2) Apăsaţi pe categoria Fişiere (Files) dacă este necesar.

3) Apăsaţi Adaugă (Add).

4) Selectaţi un fişier şi apăsaţi Deschide (Open). Imaginea este adăugată temei.

Metoda 2 (prin tragere):

1) Deschideţi documentul care conţine imginea pe care doriţi să o adăugaţi la Galerie, şi 
afişaţi tema din Galerie în care doriţi să adăugaţi imaginea. 

2) Poziţionaţi cursorul mausului deasupra imaginii din document fără să daţi clic.

3) Dacă cursorul mausului se va modifica şi va arăta ca o mână, înseamnă că imaginea este 
de fapt o (hiper)legătură. În acest caz, apăsaţi tasta Alt în timp ce daţi clic pe imagine, 
pentru a evita să executaţi legătura. Iar dacă cursorul mausului nu se modifică într-o 
mână, atunci este o imagine obişnuită şi daţi clic pe ea pentru a o selecta.

4) După ce aţi selectat imaginea, lucru indicat de mânere verzi din jurul acesteia, eliberaţi 
butonul mausului. Apăsaţi din nou pe imagine, ţinând apăsat butonul mausului pentru 
mai mult de 2 secunde, şi apoi, fără a da drumul butonului, trageţi imaginea în Galerie. 

5) Eliberaţi butonul mausului.
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Ştergerea imaginilor din Galerie
Pentru a şterge un obiect dintr-o temă:

1) Daţi clic-dreapta pe numele fişierului grafic corespondent sau pe miniatura sa din 
Galerie.

2) Apăsaţi Şterge (Delete) din meniul contextual. Va fi afişat un mesaj, întrebându-vă dacă 
doriţi să ştergeţi obiectul. Apăsaţi Da (Yes).

Notă Ştergerea numelui unui fişier din Galerie nu determină ştergerea sa şi de pe hard-disk 
sau de unde este stocat.

Crearea unei teme noi
1) Apăsaţi butonul Temă nouă (New Theme) de deasupra listei temelor (vedeţi Imaginea

251).

2) Apăsaţi categoria General şi tastaţi un nume pentru noua temă.

3) Apăsaţi categoria Fişiere (Files).

4) Apăsaţi Găseşte fişiere (Find Files). Se va deschide dialogul Selectare cale (Select Path 
din Imaginea 254). Navigaţi până la directorul care conţine fişierele cu imagini pentru 
noua temă şi apăsaţi OK.

5) Înapoi la categoria Fişiere (Files), fie apăsaţi pe Adaugă tot (Add All) pentru a adăuga 
toate imaginile din directorul selectat, fie folosiţi Tip fişier (File Type) şi/sau selectaţi 
unul sau mai multe fişiere din lista afişată, apoi apăsaţi pe Adaugă (Add) pentru a 
adăuga fişierele selectate la temă.

6) Apăsaţi OK când consideraţi că aţi terminat.
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Imaginea 254. Crearea unei noi teme în cadrul Galeriei.  

Notă Fişierele nu vor fi afişate în caseta mare de sub caseta Tip fişier (File Type); iar la 
categoria General, Conţinut (Contents) va afişa “0 Obiecte,” dar fişierele selectate 
sunt într-adevăr inserate în noua temă. Ţineţi minte şi că puteţi adăuga sau şterge 
imaginile ulterior.

Ştergerea unei teme din Galerie
Pentru a şterge o temă din Galerie:

1) Mergeţi la Unelte > Galerie (Tools > Gallery).

2) În partea din stânga a Galeriei selectaţi din lista temelor disponibile pe cea pe care 
doriţi să o ştergeţi.

3) Daţi clic-dreapta pe aceasta şi apoi alegeţi Şterge (Delete) din meniul contextual.

Localizarea Galeriei şi a obiectelor con inute înţ  
aceasta

Imaginile şi alte obiecte din Galerie pot fi localizate oriunde pe hard-discul calculatorului, pe 
un alt calculator din reţea sau pe un CD-ROM. Localizarea fiecărui obiect este afişată în 
Galerie. Când adăugaţi imagini în Galerie, acestea nu sunt mutate sau copiate; numai 
localizarea fiecăreia este adăugată, ca o referinţă.
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Dacă participaţi la un proiect de grup, puteţi avea acces la o Galerie comună (şi unde nu veţi 
putea schimba obiectele conţinute decât dacă sunteţi autorizat să faceţi aceasta) şi o Galerie 
proprie fiecărui utilizator, unde puteţi adăuga, modifica sau şterge obiectele.

Localizarea Galeriei este stabilită în Unelte > Opţiuni > OpenOffice.org > Căi (Tools > 
Options > OpenOffice.org > Paths). De obicei este ceva de genul \openoffice\user\gallery, 
deşi localizarea exactă este în funcţie de sistemul de operare pe care îl folosiţi. Puteţi modifica 
această locaţie şi puteţi copia fişierele galeriei (*.sdv) pe alte calculatoare.

Conţinutul Galeriei instalată o dată cu OOo este situat în openoffice\share\gallery. Nu puteţi 
schimba localizarea acestuia.
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Ce este Fontwork?

Ce este Fontwork?

Cu Fontwork puteţi crea obiecte grafice din text, care vă vor face lucrarea mult mai 
prezentabilă. Sunt disponibile foarte multe setări pentru obiectele grafice de tip text (aliniere, 
zona, poziţie, mărime, etc.), astfel încât aveţi de unde alege. Veţi găsi cu siguranţă ceva potrivit 
documentului dumneavoastră.

Fontwork este disponibil din fiecare componentă OpenOffice.org, dar veţi observa mici 
diferenţe în felul în care fiecare dintre aceste componente îl afişează.

Uneltele din Fontwork

Puteţi utiliza două bare diferite de unelte pentru crearea şi editarea unui obiect Fontwork.

7) Alegeţi Vizualizare > Bare de unelte > Fontwork (View > Toolbars > Fontwork).

Imaginea 255. Bara de unelte Fontwork, 
flotantă.

• Dacă apăsaţi pe un obiect Fontwork deja existent, bara Formatare (Formatting) se va 
modifica, afişând opţiunile specifice Fontwork ca în Imaginea 256. Conţinutul 
acestei bare de unelte variază în funcţie de componenta OOo.

Imaginea 256. Bara de unelte Formatare din Writer când este selectat un obiect Fontwork.

Crearea unui obiect Fontwork

1) De pe barele Desenare (Drawing) sau Fontwork apăsaţi pe pictograma Galeria Fontwork 

(Fontwork Gallery): . Dacă bara Desenare nu este vizibilă, selectaţi Vizualizare > 
Bare de unelte > Desenare (View > Toolbars > Drawing) pentru a o afişa.

2) În dialogul Galeria Fontwork (Imaginea 257), selectaţi un stil Fontwork şi apoi apăsaţi 
OK. Obiectul Fontwork va apare în documentul dumneavoastră. Observaţi pătrăţelele 
albastre de pe margine (care indică faptul că obiectul este selectat) şi punctul galben; 
acestea sunt discutate în “Mutarea şi redimensionarea obiectelor Fontwork” la pagina 
302.
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Crearea unui obiect Fontwork

Imaginea 257. Galeria Fontwork.

3) Daţi dublu clic pe obiect pentru a edita textul "Fontwork".  Tastaţi propriul 
dumneavoastră text în locul textului de culoare neagră “Fontwork” care apare peste 
obiect (Imaginea 258).

Imaginea 258. Editarea textului 
Fontwork.

4) Apăsaţi oriunde este un spaţiu gol sau apăsaţi tasta Esc pentru a se reţine modificările 
făcute.
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Editarea unui obiect Fontwork

Acum că am creat primul obiect Fontwork, putem să modificăm câteva dintre caracteristicile 
sale. Pentru aceasta putem folosi bara de unelte Fontwork, bara de unelte Formatare sau 
opţiunile din meniuri, după cum veţi vedea în această secţiune.

Folosirea barei de unelte Fontwork
Verificaţi că este afişată bara de unelte toolbar, arătată în Imaginea 255. Dacă nu o vedeţi 
mergeţi la Vizualizare > Bare de unelte > Fontwork (View > Toolbars > Fontwork).

Apăsaţi pe diversele pictograme pentru a edita obiectele Fontwork:

Forma Fontwork (Fontwork Shape): Editează forma obiectului selectat. Puteţi selecta 
dintr-o paletă de forme, după cum se vede în Imaginea 259.

Imaginea 259. Bara de unelte Fontwork afişând paleta de 
forme.

Litere de aceeaşi înălţime (Fontwork Same Letter Heights): Schimbă înălţimea 
literelor din obiect, de la cea normală (unele litere sunt mai înalte decât altele, ca de 
exemplu majusculele, d, h, l etc.) la aceeaşi înălţime pentru toate literele. Vedeţi 

Imaginea 260.

Imaginea 260. Stânga: litere normale; dreapta: litere de aceeaşi înălţime.

Aliniere Fontwork (Fontwork Alignment): Schimbă alinierea caracterelor. Opţiunile 
disponibile sunt aliniere la stânga, la dreapta, la centru, umplere la nivel de cuvânt şi 
umplere prin întindere. Efectele alinierii pe text pot fi observate numai dacă textul se 
întinde pe 2 sau mai multe linii. La umplerea prin întindere, toate liniile sunt umplute 

complet.
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Imaginea 261: Bara de unelte extinsă pentru 
aliniere.

Spaţierea caracterelor Fontwork (Fontwork Character Spacing): Schimbă spaţierea 
caracterelor precum şi unele elemente ale caracterelor din obiect. Pentru spaţierea 
personalizată introduceţi o valoare procentuală: 100% reprezintă spaţierea normală, iar 

mai puţin de 100% semnifică restrângerea spaţierii. Mai mult de 100% este o spaţiere expansivă.

Imaginea 262: Bara de unelte extinsă pentru spaţiere.

Utilizarea barei de unelte Formatare
Pentru început vom continua să personalizăm obiectul Fontwork folosind noi opţiuni.

Apăsaţi pe obiectul Fontwork. Bara de unelte Formatare (Formatting) se va schimba pentru a 
afişa opţiunile corespunzătoare obiectului selectat. (De exemplu, bara de unelte din Imaginea
263 va apare atunci când veţi selecta un obiect Fontwork în Writer.)

Pe bara Formatare aveţi o gama foarte largă de opţiuni pentru personalizarea obiectului 
dumneavoastră. Aceste opţiuni sunt similare cu cele pentru obiectele desenate. Puteţi citi mai 
mult despre acestea din urmă în Ghidul Draw (Draw Guide).
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Imaginea 263. Bara de unelte Formatare din Writer când este selectat un obiect Fontwork.

Op iunile Linieţ

Pictograma Linie: Deschide un dialog (Imaginea 264) cu trei categorii: Linie (Line), Stiluri 
linie (Line Styles), Stiluri săgeată (Arrow Styles).

• Folosiţi categoria Linie pentru a edita caracteristicile comune ale liniilor din jurul 
obiectului Fontwork selectat, alegând dintre atributele predefinite privind stilul liniei, 
culoarea liniei şi stilurile săgeţii.

• Folosiţi categoriile Stilul liniei şi Stilul săgeţii pentru a edita caracteristicile stilurilor 
de linie şi săgeată şi pentru a defini noi stiluri.

Pictograma Stilul săgeţii: Alegeţi dintre stiluri diferite de săgeată.

Căsuţa Stilul liniei:  Alegeţi dintre stilurile disponibile de linie.

Căsuţa Lăţimea liniei: Stabiliţi lăţimea liniei.

Căsuţa Culoarea liniei: Selectaţi culoarea liniei.
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Imaginea 264. Dialogul cu opţiunile pentru linii.

Op iunile Zonţ ă

Pictograma Zonă: Deschide un dialog (Imaginea 265) cu şapte categorii: Zonă (Area), 
Umbră (Shadow), Transparenţă (Transparency), Culori (Colors), Gradiente (Gradients), 
Haşurare (Hatching), Bitmapuri (Bitmaps). 

• Categoria Zonă: Alegeţi din lista predefinită o culoare, o imagine bitmap, un gradient 
sau un model de haşură pentru a-l aplica obiectului selectat.

• Categoria Umbră: Stabiliţi caracteristicile umbrei obiectului selectat.

• Categoria Transparenţă: Stabiliţi  caracteristicile transparenţei obiectului selectat.

• Categoria Culori: Modificaţi culorile disponibile sau adăugaţi noi culori care să apară 
în categoria Arie.

• Categoria Gradiente: Modificaţi gradientele disponibile sau adăugaţi noi gradiente care 
să apară în categoria Zonă.

• Categoria Haşurare: Modificaţi modelele de haşură disponibile sau adăugaţi altele noi 
care să apară în categoria Zonă.

• Categoria Bitmapuri: Creaţi modele simple în format bitmap sau importaţi bitmapuri, 
pentru a le avea disponibile în categoria Zonă.

Căsuţele Stilul zonei / Umplere (Area Style / Filling): Selectaţi tipul umplerii obiectului 
selectat. Pentru detalii, folosiţi pictograma Zonă.
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Imaginea 265. Dialogul privind opţiunile Zonă.

Op iunile ţ Pozi ionareţ

Pictograma Rotire (Rotate) : Roteşte obiectul selectat în funcţie de mişcarea mausului, deci 
manual.

Pictograma Aduce deasupra (To Foreground) : Mută obiectul selectat deasupra textului.

Pictograma Mută dedesubt (To Background) : Mută obiectul selectat în spatele textului.

Pictograma Aliniere (Alignment) : Modifică alinierea obiectelor selectate.

Pictograma Aduce în faţă (Bring to front) : Mută obiectul selectat în faţa celorlalte.

Pictograma Mută în spate (Send to back) : Mută obiectul selectat în spatele celorlalte.

Pictograma Schimbă ancora (Change Anchor): Alegeţi dintre opţiunile de ancorare:

• La pagină (To Page) - Obiectul reţine aceeaşi poziţie faţă de marginile paginii. Nu se va 
deplasa dacă adăugaţi sau ştergeţi text.

• La paragraf (To Paragraph) - Obiectul este asociat cu un paragraf şi se va deplasa odată 
cu acesta. Poate fi plasat în margine sau oriunde altundeva.

• La caracter (To Character) - Obiectul este asociat cu un caracter, dar nu va fi parte din 
secvenţa de text. Se va mişca odată cu paragraful dar poate fi plasat în margine sau în 
altă parte. Această metodă este similară cu ancorarea faţă de paragraf.
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• Ca un caracter (As Character) - Obiectul este introdus în document ca orice alt caracter 
şi se va deplasa o dată cu paragraful pe măsură ce adăugaţi sau ştergeţi textul de 
dinaintea sa.

Pictograma Separă (Ungroup) : De-grupează obiectele selectate, astfel încât veţi lucra cu ele 
în mod individual.

Pictograma Grupează (Group): Grupează obiectele selectate, astfel încât veţi lucra cu ele ca 
şi cu un singur obiect.

Utilizarea op iunilor din meniuriţ

Puteţi utiliza şi unele opţiuni din meniul Format (Formatare) pentru a ancora, a alinia, a 
aranja şi a grupa obiectele Fontwork selectate, a stabili curgerea textului pe lângă ele şi a le 
răsturna orizontal şi vertical.

Puteţi de asemenea da clic-dreapta pe un obiect Fontwork şi să alegeţi opţiunile dorite din 
meniul contextual. În plus, meniul contextual vă oferă o metodă rapida de acces la dialogurile 
Linie, Arie, Text, Poziţie şi dimensiune. Dialogurile Linie şi Arie sunt descrise pe paginile 298 
şi 299. Dialogul Text oferă numai vreo două opţiuni pentru obiectele Fontwork şi nu este 
discutat aici.

Pe dialogul Poziţie şi dimensiune (Position and Size) (Imaginea 261), puteţi introduce valorile 
exacte de mărime şi poziţionare. Pentru mai multe informaţii consultaţi Ghidul Draw (Draw 
Guide).

Imaginea 266. Dialogul Poziţie şi dimensiune (Position and Size).
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Mutarea şi redimensionarea obiectelor 
Fontwork

Când selectaţi un obiect Fontwork apar opt pătrăţele albastre (denumite mânere) pe marginea 
obiectului, după cum se vede în Imaginea 258. Puteţi trage de aceste mânere pentru a 
redimensiona obiectul.

De asemenea, un punct galben apare pe obiect. Acesta nu are un loc fix; poate fi atât pe 
margine cât şi în altă parte. Priviţi Imaginea 262 pentru un exemplu. Dacă poziţionaţi cursorul 
mausului deasupra acestui punct galben, acesta (cursorul) se va transforma în simbolul unei 
mâini. Puteţi trage punctul în diferite direcţii pentru a distorsiona obiectul.

Imaginea 267. Punctul 
galben.

Suprapunerea cursorului mausului peste restul obiectului Fontwork îl va transforma  în 
simbolul obişnuit pentru tragerea obiectelor pe pagină.

Pentru un control precis al poziţionării şi mărimii obiectului va trebui să folosiţi dialogul 
Poziţie şi dimensiune (Position and Size) (Imaginea 261).
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Introducere

Introducere

Acest capitol descrie cum să salvaţi documente sub formă de pagini Web din Writer, Calc, 
Draw şi Impress. 

Notă Referinţele încrucişate nu devin hiperlegaturi într-un document HTML.

Inserarea hiperleg turiloră

Când tastaţi text (cum ar fi o adresă web sau un URL5) care poate fi interpretat ca o 
hiperlegătură, OOo creează o hiperlegătură, o formatează automat ca atare şi îi aplică culoarea 
de text specifică şi subliniere. Dacă nu se întâmplă aşa puteţi activa această facilitate de la 
Unelte > AutoCorectare > Opţiuni (Tools > AutoCorrect > Options) şi bifaţi Recunoaştere 
URL (URL Recognition).

Ponturi Dacă nu doriţi ca OOo să convertească un anumit text URL ca hiperlegătură, selectaţi 
Editare > Anulează inserarea (Edit > Undo Insert) din bara de meniu sau apăsaţi 
Control+Z imediat după ce a fost aplicată formatarea.

Pentru a schimba culoarea hiperlegăturilor mergeţi la Unelte > Opţiuni > 
OpenOffice.org > Afişare  (Tools > Options > OpenOffice.org > Appearance), 
derulaţi până la Legături nevizitate (Unvisited links) şi/ sau Legături vizitate (Visited 
links), bifaţi căsuţele, alegeţi noile culori şi apăsaţi OK. Atenţie: aceasta va afecta 
culorile pentru toate hiperlegăturile în toate componentele din OpenOffice.org—s-ar 
putea să nu fie ceea ce doriţi.

În Writer şi Calc (dar nu şi în Draw ori Impress), puteţi modifica stilul de caracter 
Internet link sau să vă definiţi propriul stil, pe care să îl aplicaţi dumneavoastră textelor 
respective.

Puteţi de asemenea insera şi modifica legături folosind dialogul Hiperlegătură (Hyperlink) 

(Imaginea 268). Pentru a afişa dialogul apăsaţi pictograma Hiperlegătură (Hyperlink)  pe 
bara de unelte Standard sau selectaţi Inserare > Hiperlegătură (Insert > Hyperlink) din bara 
de meniu. Pentru a trata textul existent ca pe o hiperlegătură, selectaţi-l înainte de a deschide 
dialogul Hiperlegătură.

Pe partea din stânga, selectaţi unul din cele 4 tipuri de hiperlegături:

• Internet: o adresă web, care de obicei începe cu http://

• Mail & News: de exemplu o adresă de email.

• Document: hiperlegătura indică un alt document sau un alt moment din prezentare.

• Document nou (New document): hiperlegătura creează un document nou.

Partea din dreapta-sus a dialogului se va modifica conform tipului de hiperlegătuă. O 
descrierea completă a tuturor opţiunilor, şi a interacţiunilor, este dincolo de scopul acestui 
capitol. Mai jos este un sumar a celor mai des folosite opţiuni.

5 URL reprezintă abrevierea de la Uniform Resource Locator, ce este o convenţie pentru scrierea adresei oricărui 
lucru în Internet. (n.tr.)
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Pentru o hiperlegătură de tipul Internet, alegeţi tipul hiperlegăturii (alegeţi între Web, FTP şi 
Telnet), şi introduceţi adresa respectivă de web (URL). 

Pentru o hiperlegătură de tipul Mail and News, specificaţi dacă este o legătură pentru email sau 
pentru ştiri (news), adresa destinatarului şi cea de email, şi subiectul.

Imaginea 268. Dialogul Hiperlegătură (Hyperlink) pentru legăturile de tip Internet.

Pentru o hiperlegătură de tipul Document, specificaţi calea către document (butonul Deschide 
fişier (Open File) va deschide navigatorul de fişiere); lăsaţi calea neprecizată dacă doriţi să 
specificaţi un document din aceeaşi prezentare. Puteţi să specificaţi ca destinaţie şi un loc din 
cadrul documentului (de exemplu, un anume diapozitiv în cazul unei prezentări). Apăsaţi 
pictograma Destinaţie (Target) pentru a deschide Navigatorul de unde veţi putea selecta 
destinaţia, iar dacă deja îi ştiţi numele, tastaţi-l în casetă.

Pentru o hiperlegătură de tipul Document nou (New Document), specificaţi dacă doriţi să 
editaţi noul document imediat sau ulterior, acesta fiind acum doar creat (Editare ulterioară 
(Edit later)), precum şi tipul de document care să fie creat (text, foaie de calcul, etc.). Pentru o 
prezentare probabil că veţi alege Editare ulterioară. Butonul Selectare cale (Select path) 
deschide un navigator de unde selectaţi un director.

Secţiunea Setări avansate (Further settings) din partea dreapta-jos a dislogului este comună 
tuturor tipurilor de hiperlegături, deşi unele opţiuni sunt mai relevante unora dintre tipurile de 
legături decât altora.

• Stabiliţi o valoare pentru Cadru (Frame) pentru a determina modul în care va fi 
deschisă hiperlegătura. Aceasta are sens pentru documentele care se vor deschide într-un 
navigator Web.

• Formular (Form) specifică dacă legătura va fi prezentată ca text sau ca un buton.

• Text specifică textul care va fi afişat.
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• Nume (Name) este aplicabil în cazul documentelor HTML, şi specifică textul care va fi 
adăugat ca atributul NAME în codul HTML corespunzător hiperlegăturii.

• Butonul Eveniment (Event): acest buton va fi activat pentru a permite OOo să răspundă 
evenimentelor pentru care utilizatorul a scris o funcţie (macro). Această facilitate nu este 
descrisă în această carte.

Editarea hiperleg turiloră

Pentru a edita o legătură existentă:

1) Fie deplasaţi cursorul în cadrul legăturii utilizând săgeţile de pe tastatură, fie apăsaţi 
literele HYP din bara de stare (de la baza ferestrei OOo) pentru a o comuta în SEL (după 
cum se vede în Imaginea 269) şi folosiţi mausul pentru a poziţiona cursorul.

Imaginea 269. Bara de statut din 
Writer.

2) Apăsaţi Editare > Hiperlegătură (Edit > Hyperlink). Dialogul Hiperlegătură 
(Hyperlink) (Imaginea 268) se deschide.

Pont Dacă vă este necesar să editaţi mai multe hiperlegături, puteţi lăsa dialogul 
Hiperlegătură deschis şi să le editaţi pe toate. Aveţi grijă să apăsaţi Aplică (Apply) 
după editarea fiecăreia. Când veţi termina apăsaţi Închide (Close).

Salvarea documentelor Writer ca pagini web

Facilitaţile HTML din Writer includ salvarea documentelor deja existente în formatul HTML, 
crearea de documente noi în acest format şi crearea mai multor tipuri de pagini web folosind un 
vrăjitor.

Cel mai uşor mod de a crea documente HTML este de a începe cu un document Writer 
existent. Puteţi să previzualizaţi cum va arăta ca pagină web folosind Vizualizare > Aspect 
Web (View > Web Layout).

Salvarea unui document ca o singur  ă pagin  Webă

Pentru a salva un document ca o singură pagină Web (în format HTML), selectaţi Salvează ca 
(Save As) din meniul Fişier şi specificaţi HTML Document ca tip de fişier.

Notă Writer nu înlocuieşte spaţiile multiple (consecutive) din documentul original cu codul 
HTML pentru spaţii continue (non-breaking spaces). Dacă doriţi spaţii suplimentare în 

306 Capitolul 16  Crearea paginilor Web

HYP or SEL



Salvarea documentelor Writer ca pagini web

fişierul HTML sau în pagina Web trebuie să inseraţi spaţii continue şi în OOo. Pentru 
aceasta, apăsaţi Control+Spaţiu în loc doar de Spaţiu (Spacebar).

Salvarea documentului ca o serie de pagini Web
Writer poate salva un document mare ca o serie de pagini Web (fişiere HTML) cu o pagină pe 
rolul de Cuprins. Pentru a face aceasta:

1) Decideţi care dintre paragrafe vor începe pe o pagină nouă şi atribuiţi titlurilor 
respective acelaşi stil (de exemplu, Heading 1).

2) Selectaţi Fişier > Trimite (File > Send) şi apăsaţi pe Creează document HTML 
(Create HTML Document).

3) În dialog (Imaginea 270) introduceţi numele fişierului sub care doriti sa salvati paginile. 
Specificaţi şi stilul care indică o pagină nouă (şi pe care l-aţi ales la pasul 1).

4) Apăsaţi Salvează (Save) pentru a crea un document HTML multi-pagină. (Pentru cei 
interesaţi, fişierele HTML generate respectă standardul HTML 4 Transitional.)

Imaginea 270. Crearea unei serii de pagini Web dintr-un singur document.

Crearea paginilor web folosind Vr jitorulă

Vrăjitorul Web din OOo  vă permite să creaţi câteva tipuri standard de pagini Web. Pentru a-l 
utiliza:

1) Selectaţi Fişier > Vrăjitori > Pagină Web (File > Wizards > Web Page). Pe prima 
pagină din Vrăjitor (Imaginea 271) alegeţi opţiunile dorite şi apăsaţi Următorul (Next).

Notă Dacă este prima dumneavoastră pagină Web singura opţiune pentru vrăjitor este 
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Implicit (Default)

Imaginea 271. Primul pas din Vrăjitorul de pagini Web.

2) Alegeţi sau răsfoiţi pentru a găsi documentul pe care doriţi să îl formataţi şi adăugaţi 
informaţiile privind Titul (Title), Descriere (Summary) şi Autor (Author) după cum se 
vede în Imaginea 272. Apăsaţi Următorul (Next).

Imaginea 272. Pasul al doilea din Vrăjitorul de pagini Web.
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3) Alegeţi un aspect pentru saitul web apăsând pe una dintre casetele exemplificative din 
Imaginea 273. Apăsaţi Următorul (Next).

Imaginea 273. Pasul al treilea din Vrăjitorul de pagini Web.

4) Alegeţi informaţiile care doriţi să fie listate şi rezoluţia ecranului, ca în Imaginea 274. 
Apăsaţi Următorul (Next).

Imaginea 274. Pasul 4 din Vrăjitorul de pagini Web.
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5) Selectaţi un stil pentru pagină. Folosiţi lista derulantă, arătată în Imaginea 275, pentru a 
selecta dintre stilurile şi combinaţiile coloristice prezentate. Puteţi căuta o imagine de 
fundal şi un set de pictograme din Galerie. Apăsaţi Următorul (Next).

Imaginea 275. Pasul 5 din Vrăjitorul de pagini Web.

6) Introduceţi informaţii generale ca Titlu (Title) şi informaţii HTML Metadata în dialogul 
din Imaginea 276. Apăsaţi Următorul (Next).

Imaginea 276. Pasul 6 din Vrăjitorul de pagini Web.
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7) Alegeţi unde să salvaţi fişierul şi dacă doriţi puteţi şi să previzualizaţi pagina, aşa cum 
se vede în Imaginea 277. Apăsaţi Încheiere (Finish).

Imaginea 277. Pasul 7 din Vrăjitorul de pagini Web.

Pentru a edita sau a vizualiza codul HTML generat în fisier apăsaţi Vizualizare > Sursa 

HTML (View > HTML-Source) sau apăsaţi pictograma Sursa HTML (HTML Source)  

de pe bara de unelte principală (Main).

Salvarea foilor de calcul Calc ca pagini Web

Calc poate salva fişierele ca documente HTML. Ca şi pentru Writer, folosiţi Fişier > Salvează 
ca (File > Save As) şi selectaţi HTML Document, sau Fişier > Vrăjitori > Pagină Web (File 
> Wizards > Web Page).

Dacă fişierul conţine mai mult de o singură foaie, foile suplimentare vor urma una după alta în 
fişierul HTML. Legături către fiecare foaie vor fi introduse la începutul documentului HTML. 
Calc vă permite de asemenea inserarea de legaturi direct în foile de calcul folosind dialogul 
Hiperlegătură (Hyperlink).

Salvarea prezent rilor Impressă  ca pagini Web

Puteţi exporta prezentările ca fişiere Macromedia Flash: selectaţi Fişier > Export (File > 
Export) şi alegeţi ca tip de fişier Macromedia Flash.

Puteţi de asemenea converti prezentările într-o serie de pagini web, ca mai jos.

Notă La salvarea ca pagini Web (format HTML) nu se vor păstra animaţia şi nici efectele de 
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tranziţie între diapozitive.

1) Selectaţi Fişier > Export (File > Export) şi selectaţi HTML Document ca tip de fişier.

2) Alegeţi destinaţia pentru fişier, furnizaţi un nume pentru fişierul HTML care va rezulta, 
şi apăsaţi Salvează (Save). Se va deschide Vrăjitorul Export HTML.

Notă În funcţie de dimensiunea prezentării şi de numărul de imagini pe care îl conţine, 
funcţia de export HTML va crea multe fişiere HTML, JPG şi GIF. Dacă le veţi salva 
pe desktop (sau nu veţi alege un director special pentru acestea) vă veţi încurca în ele 
(iar desktopul se va umple), aşa că amintiţi-vă să creaţi un director special şi salvaţi-
le acolo.

3) Selectaţi ce aspect veţi folosi pentru paginile web, fie unul deja existent fie să creaţi 
unul nou.

Dacă nu aţi mai creat un aspect, opţiunea Aspect existent (Existing Design) nu este 
disponibilă.

4) Apăsaţi Următorul (Next) pentru a selecta tipul de pagini web care să fie create. 

• Standard HTML: va genera o serie de pagini, fiecare continând un diapozitiv. Sunt 
disponibile legături pentru a naviga de la un diapozitiv la altul.

• Standard HTML cu cadre (Standard HTML with frames): o pagină cu un cadru cu 
legături de navigare în stânga; va folosi titlurile diapozitivelor ca legături. Apăsaţi pe 
legături pentru a afişa paginile (diapozitivele) în partea din dreapta.

• Automatic: generează o serie de pagini, câte una pentru fiecare diapozitiv, fiecare 
având inclusă (ca etichetă meta) instrucţiunea Refresh, ceea ce va determina 
browserul să cicleze automat prin fiecare pagină web.
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• WebCast: generează o aplicaţie ASP sau Perl pentru a afişa diapozitivele. Din păcate 
OOo încă nu are suport direct pentru PHP.

5) Selectaţi cum să fie salvate imaginile, în format GIF sau JPG, şi ce rezoluţie să fie 
folosită.

Când alegeţi rezoluţia luaţi în considerare cam ce rezoluţii au monitoarele utilizatorilor. 
Dacă veţi folosi o rezoluţie ridicată, utilizatorii cu monitoare cu rezoluţii medii s-ar 
putea să fie nevoiţi să deruleze pagina pentru a vedea întregul diapozitiv, ceea ce nu este 
de dorit.

6) Dacă opţiunea Creează o pagină de titlu (Create a title page) a fost aleasă la pasul 3 de 
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mai sus, furnizaţi informaţiile necesare pe următoarea pagină. Titlul conţine numele 
autorului, adresa email şi pagina pe Internet, putând sa furnizaţi şi informaţii de contact 
adiţionale.

Această pagină din Vrăjitor nu va fi afişată decât dacă aţi ales Creează o pagină de titlu.

7) Alegeţi butoanele de navigare grafice pentru navigarea între pagini. Dacă nu doriţi 
butoane grafice OOo poate să creeze doar o navigare text.
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8) Selectaţi paleta de culori pentru paginile web. Printre paletele disponibile sunt cea 
folosita în documentul curent, una bazată pe culorile din browser, şi una complet 
definită de utilizator. Puteţi salva o nouă paletă ce va fi afişată pe prima pagină a 
Vrăjitorului de export HTML.

9) Apăsaţi butonul Creează (Create) pentru a genera fişierele HTML. Dacă acesta este un 
nou tip de aspect va fi afişat un mic dialog. Dacă veţi dori ca pe viitor să realizaţi şi alte 
pagini web cu acest aspect, puteţi să îl denumiţi şi să îl salvaţi. Dacă nu, apăsaţi Nu 
salva (Do Not Save).

Salvarea documentelor Draw ca pagini Web

Exportarea desenelor din aplicaţia OOo Draw este similară cu exportarea prezentărilor din 
Impress. Folosiţi Fişier > Export (File > Export) şi selectaţi HTML Document ca tip de 
fişier.

Când folosiţi vrăjitorul puteţi creea oricând (la orice pas al acestuia) pagina web apăsând 
butonul Creează (Create).
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Primul macro propriu

Un macro reprezintă o secvenţă de comenzi sau apăsări de taste înregistrată pentru o folosire 
ulterioară. Un exemplu de macro foarte simplu este cel care vă "tastează" adresa. Limbajul 
macro din OpenOffice.org este foarte flexibil, permiţând automatizarea nu numai a soluţiilor 
simple, cât şi a celor complexe. Macro este în mod special folositor când trebuie să faceţi 
acelaşi lucru de (foarte) multe ori.

Macrourile OpenOffice.org sunt scrise de obicei în limbajul denumit StarBasic, sau pe scurt 
Basic. Deşi puteţi învăţa Basic şi vă puteţi apuca de scris macrouri curba învăţării de la zero 
este prea abruptă pentru o urca. Metoda uzuală pentru începători este de a folosi înregistrarea 
macro inclusă în OOo, care înregistrează tastele pe care apăsaţi şi pe salvează pentru refolosire 
ulterioară.

Cele mai multe sarcini din OpenOffice.org sunt realizate prin trimiterea unei comenzi, care 
este interceptată şi utilizată. Înregistrarea macro se referă la înregistrarea comenzilor trimise 
(citiţi “Mecanismul de expediere” la pagina 327).

Crearea unui macro simplu
Imaginaţi-vă introducând informaţii simple. Deşi le puteţi stoca în clipbord6 vor fi şterse dacă 
veţi folosi clipbordul pentru altceva. Stocarea acestora ca macro este o soluţie simplă. (În unele 
cazuri, incluzând exemplul folosit aici, cel mai bine este să folosiţi AutoText.)

10)Utilizaţi Unelte > Macrouri > Înregistrare macro (Tools > Macros > Record 
Macro) pentru a începe să înregistraţi un macro. O mică fereastră va fi afişată astfel 
încât să şiti că OpenOffice.org tocmai înregistrează.

11)În continuare tastaţi informaţiile dorite sau efectuaţi operaţiunile dorite. În acest caz, 
tastaţi numele autorului acestui capitol, Andrew Pitonyak.

12)Apăsaţi butonul Opreşte înregistrarea (Stop Recording) pentru a opri înregistrarea, a 
salva macroul şi a afişa dialogul OpenOffice.org Basic Macros (vedeţi Imaginea 278).

6 clipbord (din en. clipboard) zonă de memorie unde se reţin temporar anumite date, de obicei pentru transferul între 
aplicaţii sau pentru a fi refolosite; de exemplu foloseşte la copierea şi lipirea datelor. (n.tr.)

318 Capitolul 17  Ini iere în limbajul macroţ



Primul macro propriu

Imaginea 278: Dialogul OOo Organizator Macro, este selectată biblioteca 
DBInspection.

13)Asiguraţi-vă că aţi deschis containerul de biblioteci denumit My Macros. Găsiţi 
biblioteca denumită Standard sub My Macros. Atenţie, fiecare container de biblioteci 
are una denumită Standard. Selectaţi biblioteca Standard şi apăsaţi Modul nou (New 
Module) pentru a crea un nou modul care va conţine macroul.

Imaginea 279: Daţi un nume sugestiv modulului creat.

14)Numele propus este Module1; alegeţi unul mai bun. Deşi nu este descriptiv, autorul a 
ales Recorded. Tastaţi un nume descriptiv şi apăsaţi OK pentru a crea modulul. 
Dialogul OpenOffice.org Basic Macros va fi afişat din nou, arătând şi noul modul.

15)Selectaţi proaspăt creatul modul. În colţul stânga-sus tastaţi numele macroului, de 
exemplu “EnterMyname”, şi apoi apăsaţi Salvează (Save) pentru a salva macroul.

Dacă aţi urmat paşii ar trebui ca acum biblioteca Standard să conţină un modul denumit 
Recorded, care conţine macroul EnterMyName, după cum se vede în Imaginea 280. Când OOo 
creează un modul nou adaugă automat şi macroul denumit Main; puteţi vedea în Imaginea 280.

Executarea macroului
Folosiţi Unelte > Macrouri > Rulează macro (Tools > Macros > Run Macro) pentru a 
deschide dialogul Selectare macro (Macro Selector) (vedeţi Imaginea 280). Selectaţi macroul 
proaspăt creat şi apăsaţi Rulează (Run).
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Imaginea 280: Selectaţi-vă macroul şi apăsaţi Rulează (Run).

Sunt şi alte metode pentru a rula un macro. De exemplu, folosiţi Unelte > Macrouri > 
Organizare macrouri > OpenOffice.org Basic (Tools > Macros > Organize Macros > 
OpenOffice.org Basic) pentru a deschide administratorul de macrouri, care conţine de 
asemenea un buton Rulează (Run). Autorul, care este un utilizator asiduu de macrouri, preferă 
această modalitate deoarece acest dialog se deschide de obicei mai repede, dar s-ar putea să 
selectaţi mai greu macroul pe care îl doriţi.

Vizualizarea şi editarea macroului
Puteţi vizualiza şi edita macroul tocmai creat. Folosiţi Unelte > Macrouri > Organizare 
macrouri > OpenOffice.org Basic (Tools > Macros > Organize Macros > OpenOffice.org 
Basic) pentru a deschide dialogul OpenOffice.org Basic Macros (vedeţi Imaginea 280). 
Selectaţi nou macro şi apăsaţi Editare (Edit) pentru a deschide macroul în Basic IDE (IDE 
este acronimul de la Integrated Development Environment, respectiv Mediu de dezvoltare 
integrat).

Listarea 1: Cum a fost generat macroul “EnterMyname”.

REM  *****  BASIC  *****
Sub Main

End Sub

sub EnterMyName
rem ----------------------------------------------------------------------
rem define variables
dim document   as object
dim dispatcher as object
rem ----------------------------------------------------------------------
rem get access to the document
document   = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

rem ----------------------------------------------------------------------
dim args1(0) as new com.sun.star.beans.PropertyValue
args1(0).Name = "Text"
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args1(0).Value = "Andrew Pitonyak"

dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args1())
end sub

Macroul din Listarea 1 nu este chiar atât de complicat cum ar putea părea. Învăţarea câtorva 
lucruri vă vor ajuta semnificativ în înţelegerea comenzilor macrourilor. Vom începe cu primele 
elemente din listing şi le vom descrie. Dacă doriţi să săriţi peste detalii, înlocuiţi textul 
“Andrew Pitonyak” cu ceea ce doriţi dumneavoastră să se insereze în document la poziţia 
cursorului.

Commentariile încep cu REM

Cuvântul-cheie REM, prescurtarea de la remark7, începe un comentariu inclus în macro. Restul 
liniei care începere cu REM va fi ignorat. La fel dar mai scurt poate fi folosit şi apostroful.

Pont StarBasic nu este sensibil la capitalizarea cuvintelor-cheie, astfel încât REM, Rem şi 
rem denotă, toate, un comentariu. Dacă veţi folosi constante simbolice definite de API 
este mai sigur să presupuneţi că numele sunt sensibile la capitalizare—dar dacă aţi 
ajuns la aceste probleme, sunteţi deja prea avansat pentru acest capitol.

Definirea subrutinelor cu SUB

Macrourile individuale sunt stocate în subrutine definite cu cuvântul-cheie SUB. O subrutină 
se termină cu cuvintele END SUB. Macroul debutează prin a defini subrutina denumită Main, 
care este goală şi nu face nimic. Următoarea subrutină, EnterMyName, este cea care ne 
interesează, şi conţine codul tocmai generat.

Pont OpenOffice.org creează o subrutină goală denumită Main la crearea modului.

Sunt şi câteva lucruri care depăşesc cadrul acestui capitol, dar est bine să ştiţi despre ce este 
vorba:

• Puteţi să scrieţi o subrutină astfel încât valorile să fie expediate într-un macro atunci 
când acesta este apelat din alt macro. Macrourile înregistrate nu acceptă argumente din 
alte macrouri.

• Un alt tip de subrutină este funcţia. O funcţie este o subrutină are poate returna o 
valoare către macroul care a apelat-o. Pentru a defini o funcţie este utilizat cuvântul-
cheie FUNCTION în loc de SUB. Macrourile generate de OOo sunt întotdeauna de tipul 
SUB.

Definirea variabilelor folosind DIM

Un macro foarte simplu poate utiliza valori memorate chiar în codul său pentru orice. Din 
păcate, chiar şi macrourile foarte simple, dacă interacţionează cu OpenOffice.org vor trebui să 
stocheze diverse variabile, adică valori intermediare. Stocarea unei valori intermediare este 
sinonim cu a scrie informaţia pe o bucăţică de hârtie, astfel încât să aveţi de unde o lua mai 
târziu. Declaraţia DIM este o operaţiune similară cu o pune deoparte o bucăţică de hârtie, care 
ulterior va fi folosită pentru stocarea unui mesaj sau a unei note.

7 Remark (en.) Comentariu, remarcă. (n.tr.)
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Macroul EnterMyName defineşte variabilele document şi dispatcher de tipul object. Alte tipuri 
de variabile includ string, integer şi date. O a treia variabilă denumită args1 este şi ea definită. 
Args1 este de un tip foarte complicat; este un tablou (array) de valori. O variabilă de tipul 
array permite ca o singură variabilă să conţină valori multiple, similar cu a stoca pagini 
multiple într-o singură carte. Valorile dintr-un tablou sunt numerotate în ordine, de obicei 
începând de la zero. Numărul dintre paranteze indică numărul maxim de valori ce pot fi stocate 
în tablou, minus 1 (deoarece începe de la 0). În acest exemplu este necesară o singură valoare, 
numerotată cu zero. Poate suna confuz, dar ignoraţi acum problema deoarece exemplele 
următoare vă vor lămuri.

Asamblarea macroului

Următoarele detalii sunt complete; nu este necesar să înţelegeţi totul. Primele linii definesc 
începutul macroului.

sub EnterMyName

Se declară 2 variabile:

dim document   as object
dim dispatcher as object

ThisComponent se referă la document curent.

Prin proprietatea documentului denumită CurrentController ne referim la un serviciu care 
"controlează" documentul. De exemplu, atunci când tastaţi, semnalele se duc la "current 
controller". Acesta le trimite mai departe în cadrul documentului.

Proprietatea Frame a unui controller returnează cadrul principal al documentului. Astfel, 
variabila denumită document ajunge să se refere la cadrul documentului, care va primi 
comenzile expediate.

document = ThisComponent.CurrentController.Frame

Cele mai multe sarcini în OpenOffice.org sunt efectuate expediind comenzi. Începând cu OOo 
versiunea 2.0, există un obiect denumit dispatch helper, care facilitează în mod deosebit 
executarea comenzilor trimise de macrouri. Metoda CreateUnoService acceptă numele unui 
serviciu şi încearcă să îl instanţieze (să îl creeze). În caz de reuşită, variabila dispatcher va 
conţine o referinţă la DispatchHelper.

dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

Se declară un tablou (array) de proprietăţi. Fiecare proprietate este de fapt o pereche de un 
nume şi o valoare. Tabloul creat are o singură proprietate la indexul zero.

dim args1(0) as new com.sun.star.beans.PropertyValue

Se dă proprietăţii numele “Text” şi valoarea “Andrew Pitonyak”, ceea ce este tocmai textul ce 
va fi introdus când macroul va fi rulat.

args1(0).Name = "Text"
args1(0).Value = "Andrew Pitonyak"

Aici se petrec lucrurile. Dispatch helper-ul trimite o comandă în cadrul documentului 
(identificat de variabila denumită document); aceasta este “.uno:InsertText”. Următoarele două 
argumente, frame name şi search flags, nu are sens să le explicăm aici. Ultimul argument este 
tabloul de proprietăţi ce conţine valorile folosite de comanda InsertText.

dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args1())

La final, se declară sfârşitul subrutinei.

end sub
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Crearea unui macro

Un macro înregistrat face acelaşi lucru la nesfârşit. Înainte de a crea un macro, îmi pun de 
obicei 2 întrebări:

1) Poate sarcina să fie descrisă / realizată printr-un set de comenzi care să nu se schimbe?

2) Pot fi paşii de execuţie astfel aranjaţi încât ultima comendă să lase cursorul pregătit 
pentru execuţia comenzii următoare?

Un exemplu complicat
Copiez frecvent rânduri şi coloane de date dintr-un sait web şi le formatez sub formă de tabel 
într-un document text. În primul rând, copiez tabelul de pe sait în clipbord. Pentru a evita 
formatări ciudate şi fonturi exotice, lipesc textul în Writer ca Text neformatat (Unformatted 
text). Reformatez textul cu taburi între coloane astfel încât să pot utiliza Tabel > Conversie > 
Text în tabel (Table > Convert > Text to Table) pentru a-l converti într-un tabel.

Inspectex textul ca să verific dacă pot înregistra un macro pentru a formata textul (amintiţi-că 
cele 2 întrebări de mai sus). De exemplu, am copiat grupul de constante FontWeight de pe aitul 
web al OpenOffice.org. Prima coloană indică numele constantei. Fiecare nume este urmat de 
un spaţiu şi de un tab.

DONTKNOW The font weight is not specified/known.  

THIN specifies a 50% font weight.  

ULTRALIGHT specifies a 60% font weight.  

LIGHT specifies a 75% font weight.  

SEMILIGHT specifies a 90% font weight.  

NORMAL specifies a normal font weight.  

SEMIBOLD specifies a 110% font weight.  

BOLD specifies a 150% font weight.  

ULTRABOLD specifies a 175% font weight.  

BLACK specifies a 200% font weight.

Doresc ca prima coloană să conţină o valoare numerică, cea de a doua numele, iar cea de a treia 
descrierea. Munca dorită este similară pentru fiecare rând cu excepţia DONTKNOW şi 
NORMAL, care u conţin calori numerice—dar ştiu că acele valori sunt 0 şi 100, pe care le voi 
introduce manual.
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Datele pot fi ajustate în diverse moduri—toate cu uşurinţă. Primul exemplu foloseşte apăsări 
de taste care presupun ca cursorul să fie la începutul liniei cu textul THIN.

1) Folosiţi Unelte > Macrouri > Înregistrare macro (Tools > Macros > Record Macro) 
pentru a începe înregistrarea.

2) Apăsaţi Ctrl+Săgeată dreapta pentru a muta cursorul la începutul cuvântului 
“specifies”.

3) Apăsaţi Backspace de 2 ori pentru a şterge tabul şi spaţiul.

4) Apăsaţi Tab pentru a adăuga un tab fără spaţiu după numele constantei.

5) Apăsaţi Delete pentru a şterge minuscula "s" şi apoi apăsaţi S pentru a scrie o majusculă 
"S".

6) Apăsaţi Ctrl+Săgeată dreapta de 2 ori ca să numaţi cursorul la începutul numărului.

7) Apăsaţi Ctrl+Shift+Săgeată dreapta pentru a selecta şi a muta cursorul înainte de 
semnul %.

8) Apăsaţi Ctrl+C pentru a copia textul selectat în clipbord.

9) Apăsaţi End pentru a muta cursorul la sfârşitul liniei.

10)Apăsaţi Backspace de 2 ori pentru a şterge cele 2 spaţii de la final.

11)Apăsaţi Home pentru a muta cursorul la începutul liniei.

12)Apăsaţi Ctrl+V pentru a lipi numărul selectat la începutul liniei.

13)Valoarea a fost lipită şi i-a fost adăugat la final un spaţiu suplimentar, aşa că apăsaţi 
Backspace pentru a-l şterge.

14)Apăsaţi Tab pentru a insera un tab între număr şi nume.

15)Apăsaţi Home pentru a vă muta la începutul liniei.

16)Apăsaţi Săgeată jos pentru a vă muta la linia următoare.

17)Opriţi înregistrarea macroului şi salvaţi-l.

Vă ia mai mult să citiţi şi să scrieţi paşii decât să înregistraţi macroul. Lucraţi lent şi încercaţi 
să înţelegeţi fiecare pas. După ce veţi lucra frecvent nu vă veţi mai gândi.

Macroul generat a fost modificat astfel încât să conţină ca şi comentariu numărul fiecărui pas, 
corespunzător paşilor de mai sus.

Listarea 2: Copierea valorii numerice la începutul fiecărei coloane.

sub CopyNumToCol1
rem ----------------------------------------------------------------------
rem define variables
dim document   as object
dim dispatcher as object
rem ----------------------------------------------------------------------
rem get access to the document
document   = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")
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rem (2) Press Ctrl+Right Arrow to move the cursor to the start of “specifies”.
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())

rem (3) Press Backspace twice to remove the tab and the space.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

rem ----------------------------------------------------------------------
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

rem (4) Press Tab to add the tab without the space after the constant name.
dim args4(0) as new com.sun.star.beans.PropertyValue
args4(0).Name = "Text"
args4(0).Value = CHR$(9)

dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args4())

rem (5) Press Delete to delete the lower case s ....
dispatcher.executeDispatch(document, ".uno:Delete", "", 0, Array())

rem (5) ... and then press S to add an upper case S.
dim args6(0) as new com.sun.star.beans.PropertyValue
args6(0).Name = "Text"
args6(0).Value = "S"

dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args6())

rem (6) Press Ctrl+Right Arrow twice to move the cursor to the number.
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())

rem ----------------------------------------------------------------------
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())

rem (7) Press Ctrl+Shift+Right Arrow to select the number.
dispatcher.executeDispatch(document, ".uno:WordRightSel", "", 0, Array())

rem (8) Press Ctrl+C to copy the selected text to the clipboard.
dispatcher.executeDispatch(document, ".uno:Copy", "", 0, Array())

rem (9) Press End to move the cursor to the end of the line.
dispatcher.executeDispatch(document, ".uno:GoToEndOfLine", "", 0, Array())

rem (10) Press Backspace twice to remove the two trailing spaces.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

rem ----------------------------------------------------------------------
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

rem (11) Press Home to move the cursor to the start of the line.
dispatcher.executeDispatch(document, ".uno:GoToStartOfLine", "", 0, Array())

rem (12) Press Ctrl+V to paste the selected number to the start of the line.
dispatcher.executeDispatch(document, ".uno:Paste", "", 0, Array())

rem (13) Press Backspace to remove the extra space.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

rem (14) Press Tab to insert a tab between the number and the name.
dim args17(0) as new com.sun.star.beans.PropertyValue
args17(0).Name = "Text"
args17(0).Value = CHR$(9)
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dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args17())

rem (15) Press Home to move to the start of the line.
dispatcher.executeDispatch(document, ".uno:GoToStartOfLine", "", 0, Array())

rem (16) Press down arrow to move to the next line.
dim args19(1) as new com.sun.star.beans.PropertyValue
args19(0).Name = "Count"
args19(0).Value = 1
args19(1).Name = "Select"
args19(1).Value = false

dispatcher.executeDispatch(document, ".uno:GoDown", "", 0, args19())
end sub

Mişcările cursorului sunt utilizate pentru toate operaţiile (spre deosebire de căutare). Dacă veţi 
rula macroul pe rândul DONTKNOW, cuvântul weight va fi mutat la începutul liniei, iar 
primul “The” este schimbat în “She”. Aceasta nu este corect, dar nu trebuia să rulaţi macroul 
macroul decât pe liniile care au formatul corect; celelalte vor fi aranjate manual.

Rularea rapid  a macrouluiă

Este enervant să tot rulaţi macroul folosind Unelte > Macrouri > Rulează macro (Tools > 
Macros > Run Macro) (vedeţi Imaginea 280). Macroul poate fi rulat din IDE. Folosiţi Unelte 
> Macrouri > Organizare macrouri > OpenOffice.org Basic (Tools > Macros > Organize 
Macros > OpenOffice.org Basic) pentru a deschide dialogul Basic Macro. Selectaţi macroul 
dumneavoastră şi apăsaţi Editare (Edit) pentru a deschide macroul în IDE.

În IDE există în bara de unelte o pictogramă Rulează BASIC (Run Basic) care rulează primul 
macro din IDE. Dacă nu aţi modificat ceva, este vorba de primul macro denumit Main. 
Modificaţi Main ca mai jos, în Listarea 3.

Listarea 3: Modificaţi Main pentru a apela funcţia CopyNumToCol1.

Sub Main
  CopyNumToCol1
End Sub

Acum puteţu rula CopyNumToCol1 în mod repetat apăsând pictograma Rulează BASIC de pe 
bara de unelte din IDE. Aceasta este foarte rapid şi facil, în mod special pentru macrourile 
temporare, folosite de câteva ori şi apoi aruncate.
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Uneori înregistrarea macro eşuează

Se întâmplă, şi chiar frecvent, ca înregistrarea macro să eşueze. Pentru a face faţă acestei 
situaţii trebuie să învăţaţi modul în care lucrează intern OpenOffice.org. Problemele sunt 
generate de modul în care lucrează mecanismul de expediere de mesaje şi de modul în care 
interacţionează cu înregistrarea macro.

Mecanismul de expediere
Scopul mecanismului de expediere este să permită un acces uniform la componente 
(documente) pentru comenzile corespunzătoare opţiunilor din meniuri. Astfel, pot alege dintr-
un meniu Fişier > Salvează (File > Save), pot apăsa combinaţia de taste rapide  Ctrl+S sau pot 
apăsa pe bara de unelte pe pictograma Salvează (Save). Toate aceste acţiuni sunt traduse şi 
generează o singură comandă, care este expediată documentului curent.

Mecanismul de expediere poate să livreze mesaje şi înapoi către UI (interfaţa utilizator). De 
exemplu, după ce salvaţi documentul, comanda Salvează fişier (File Save) este dezactivată. 
Aceasta va fi reactivată imediat ce documentul va fi modificat.

Dacă vedem o comandă, este vorba de un text ca de exemplu .uno:InsertObject sau 
.uno:GoToStartOfLine. Comanda este trimisă în cadrul documentului, iar acesta identifică 
obiectul din cadrul documentului care o va executa.

Cum interac ioneaz  înregistrarea macro cuţ ă  
mecanismul de expediere
Înregistrarea macro înregistrează comenzile expediate. Programul este relativ simplu de 
implementat iar comenzile expediate sunt simultan înregistrate pentru reutilizare ulterioară. 
Problema care apare este că nu toate comenzile expediate sunt complete. De exemplu, 
inserarea unui obiect generează codul următor:

dispatcher.executeDispatch(document, ".uno:InsertObject", "", 0, Array())

Nu este posibil a se specifica ce tip de obiect va fi creat sau inserat. Dacă obiectul este preluat 
dintr-un fişier, nu este posibil de a se specifica ce fişier să fie folosit.

Am înregistrat un macro şi am utilizat Unelte > Opţiuni (Tools > Options) pentru a deschide 
şi a modifica opţiuni de configurare. Macroul generat nu înregistrează nici una dintre 
modificările de configuraţie; de fapt, codul genrat este chiar scris ca un comentariu, astfel încât 
la rularea macroului nu se va executa nimic.

rem dispatcher.executeDispatch(document, ".uno:OptionsTreeDialog", "", 0, 
Array())
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Dacă este deschis un dialog probabl se va geenra comanda de deschidere a dialogului. Însă, 
modificările din cadrul dialogului nu vor fi înregistrate. Exemplele includ dialogurile de 
administrare a macrourilor, inserarea caracterelor speciale, alte tipuri de dialoguri. Alte 
probleme ce pot să apară se referă la inserarea formulelor, opţiunili utilizator, stabilirea de 
filtre în Calc, acţiuni în formulare din bazele de date şi exportarea unui document într-un fişier 
PDF criptat. Este bine însă să încercaţi în prealabil cam tot ce veţi înregistra deoarece nu se ştie 
niciodată ce nu va merge, din păcate. Comenzile din dialogul de căutare sunt corect înregistate, 
de exemplu.

Alte op iuniţ

Când înregistrarea macro nu este capabilă să soluţioneze o anumită problemă, soluţia uzuală 
este să scrieţi cod care să utilizeze obiectele OpenOffice.org. Din păcate, aveţi cam mult de 
învăţat până să pueţi face aceasta. Este mai uşor să începeţi cu exemple simple şi să le 
dezvoltaţi în timp. În acest sens, a învăţa să citiţi codul generat este un bun loc de început.

Dacă înregistraţi macrouri pentru Calc, şi acestea sunt generate corect, există un software 
suplimentar creat de Paolo Mantovani, care converteşte macrourile Calc pe măsură ce sunt 
înregistrate. Codul final manipulează obiectele OpenOffice.org în loc de a genera comenzi. 
Aceasta este foarte util pentru a învăţa să manipulaţi direct obiectele OOo.

Puteţi să descărcaţi programul de înregistare macro direct de pe saitul web al lui Paolo sau de 
pe cel al OOo Macros. Ar fi bine să verificaţi în ambele locuri şi să luaţi versiunea cea mai 
recentă.

http://www.paolo-mantovani.org/downloads/DispatchToApiRecorder/ 

http://www.ooomacros.org/user.php 

Administrarea Macro

În OpenOffice.org, macrorile sunt grupate în module, modulele sunt grupate în biblioteci 
(library), iar bibliotecile sunt grupate în containere de bilioteci. O biliotecă este folosită de 
obicei pentru a grupa funcţiile fie aparţinând unei întregi categorii funcţionale, fie unei 
aplicaţii. Modulele împart de obicei funcţiile după funcţionalitate, ca de exemplu interacţiunea 
cu utilizatorul sau calcule. Macrourile individuale sunt subrutine şi funcţii.
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Imaginea 281: Ierarhia unei biblioteci macro.

Utilizaţi Unelte > Macrouri > Organizare macrouri > OpenOffice.org Basic (Tools > 
Macros > Organize Macros > OpenOffice.org Basic) pentru a deschide dialogul 
OpenOffice.org Basic Macros (vedeţi Imaginea 282). Toate containere de biblioteci disponibile 
sunt listate în lista Macro din (Macro from). Fiecare document este un container de biblioteci, 
capabil să conţină mai multe biblioteci. Aplicaţia însăşi conţine două containere, unul pentru 
macrourile distribuite împreună cu OpenOffice.org denumit OpenOffice.org Macros, şi altul 
pentru macrourile personale denumit My Macros. După cum se vede în Imaginea 282, numai 
două documente sunt deschise în acest moment.

Imaginea 282: Containerele de biblioteci sunt afişate în partea stângă.

Macrourile OpenOffice.org sunt stocate împreună cu codul aplicaţiilor OOo, astfel încât s-ar 
putea să nu fie editabile dacă nu aveţi drepturi de administrator. Aceasta nu reprezintă o 
problemă deoarece aceste macrouri se presupune că nu este necesar să le modificaţi şi oricum 
nu vă veţi stoca propriile macrouri în acest container al OOo.

În afară de cazul în care macrourile dumneavoastră sunt aplicabile numai unui singur 
document, probabil că le veţi stoca în containerul My Macros. Acesta este localizat în 
directorul dumneavoastră personal sau în zona ce vă este rezervată de către sistemul de 
operare.
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Dacă un macro este conţinut într-un document atunci acesta va încerca să ruleze pe acel 
document, deoarece se adresează prin obiectul “ThisComponent” pentru a-şi îndeplini 
acţiunile.

Fiecare container de biblioteci conţine o bibliotecă denumită Standard. Este mai bine să vă 
creaţi propriile biblioteci cu nume sugestive decât să o folosiţi pe aceasta. Nu numai că numele 
vă vor ajuta să administraţi totul, dar acestea pot fi importate în alte containere, pe când 
biblioteca Standard nu.

Aten ieţ OpenOffice.org vă permite să importaţi biblioteci într-un container, dar nu vă permite 
să suprascrieţi biblioteca Standard. Pe cale de consecinţă, dacă vă stocaţi macrourile 
în această bibliotecă, nu le veţi putea importa în alt container.

La fel ca şi la biblioteci, este prudent să daţi nume sugestive modulelor. Implicit, 
OpenOffice.org oferă denumri ca de exemplu Module1. Puteţi însă să alegeţi orice nume 
doriţi.

Pe măsură ce vă creaţi propriile macrouri trebuie să vă decideţi unde le veţi stoca. Le puteţu 
pune în documentul care le utilizează, ceea ce este o idee bună dacă documentul va fi transmis 
şi altora şi doriţi ca macroul să fie inclus în document. Macrourile stocate în containerul de 
biblioteci al aplicaţiei, denumit My Macros, sunt însă disponibile pentru toate documentele.

Macrorile nu sunt disponibile până când nu este încărcată biblioteca ce le conţine. Sunt 
încărcate în mod automat bibliotecile Standard şi Template. O bibliotecă încărcată este afişată 
diferit faţă de celelalte, neîncărcate. Pentru a încărca o bibliotecă daţi dublu-clic pe aceasta.

Unde sunt stocate macrourile?
OpenOffice.org depozitează datele utilizatorului într-un director localizat în directorul personal 
al respectivului utilizator. De exemplu, pe Windows acesta este  C:\Documents and 
Settings\<name>\Application Data. Macrourile utilizator sunt stocate în 
OpenOffice.org2\user\basic. Fiecare bibliotecă este stocată în propriul ei director.

Pentru o utilizare normală nu este necesar să cunoaşteţi unde sunt stocate macrourile. Aceasta 
este necesar dacă doriţi să faceţi o copie de siguranţă, să le transmiteţi şi altora sau să le 
verificaţi pentru eventuale erori. De exemplu, puteţi avea surpriza ca în urma unei reinstalări a 
OpenOffice.org să fie şterse macrourile existente anterior, sau să nu fie copiate în noile 
directoare. În acest ultim caz soluţia este să importaţi macrourile în noua instalare.

Folosiţi Unelte > Macrouri > Organizare (Tools > Macros > Organize Dialogs) pentru a 
deschide dialogul OpenOffice.org Basic Macro Organizer. O altă metodă obişnuită de a 
deschide acest dialog este de a folosi Unelte > Macrouri > Organizare macrouri > 
OpenOffice.org Basic (Tools > Macros > Organize Macros > OpenOffice.org Basic) 
pentru a deschide dialogul OpenOffice.org Macros, urmând ca apoi să apăsaţi butonul 
Organizare (Organizer) (vedeţi Imaginea 283).
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Imaginea 283: Dialogul OOo Basic Organizare 
macrouri.

Dialogul Organizare macrouri (Macro Organizer) din OpenOffice.org  vă permite să creaţi, să 
ştergeţi şi să redenumiţi biblioteci, module şi dialoguri. Selectaţi containerul de biblioteci dorit 
şi apăsaţi butonul Import pentru a importa biblioteci (vedeţi Imaginea 284). 

Pont Nu puteţi importa biblioteca denumită Standard.

Pont Pe Linux, fişierele specifice ale OpenOffice.org sunt depozitate într-un director a 
cărui denumire începe cu un punct. Directoarele şi fişierele a căror denumire începe 
cu un punct nu sunt arătate în dialogul uzual de selecţie fişiere. Pentru a deschide 
acest director, am mers la directorul rădăcină, am introdus numele .openoffice.org2, şi 
apoi am apăsat Deschide (Open). Astfel se va deschide acest director, care iniţial nu 
era afişat.

Imaginea 284: Selectaţi o bibliotecă de macrouri pentru a o importa.

Mergeţi în directorul ce conţine biblioteca pe care doriţi a o importa. Sunt de obicei 2 fişiere 
dintre care să alegeţi, dialog.xlb şi script.xlb. Nu contează pe care dintre acestea îl veţi selecta; 
vor fi importate ambele. Selectaţi unul dintre ele şi apăsaţi Deschide (Open) pentru a continua 
(vedeţi Imaginea 285).

Capitolul 17  Ini iere în limbajul macroţ 331



Administrarea Macro

Imaginea 285: Alegeţi opţiunile pentru importul 
bibliotecii.

Dacă biblioteca există deja nu va fi înlocuită decât dacă este bifat Înlocuieşte bibliotecile 
existente (Replace existing libraries). Dacă este bifat Inserare ca referinţă (Insert as 
reference) se va adăuga doar o referinţă la biblioteca care va rămâne în locaţia curentă şi care 
nu va putea fi editată. Dacă nu este bifată această opţiune biblioteca va fi copiată în directorul 
personal pentru macrouri al utilizatorului.

Macrourile pot fi stocate în biblioteci conţinute în documentele OpenOffice.org. Selectaţi un 
document în loc de un director de pe disk (ca în Imaginea 284) pentru a importa bibliotecile 
conţinute în acesta.

Desc rcarea macrourilor pentru a le importaă

Macrorile sunt disponibile pentru descărcare. Unele sunt conţinute în documente, altele ca 
fişiere obişnuite pe care trebuie să le selectaţi şi să le importaţi, şi unele ca text macro care 
trebuie copiat şi lipit în Basic IDE; folosiţi Unelte > Macrouri > Organizare macrouri > 
OpenOffice.org Basic (Tools > Macros > Organize Macros > OpenOffice.org Basic) 
pentru a deschide dialogul OpenOffice.org Macros, alegeţi macroul pe care doriţi să îl editaţi şi 
apoi apăsaţi Editare (Edit) pentru a deschide macroul în Basic IDE.

Unele macrouri sunt disponibile pe Internet pentru descărcare gratuită (citiţi Tabelul 3).

Tabelul 3. Saituri cu exemple de macrouri.

Adresă Descriere

http://www.ooomacros.org/ O colecţie excelentă de pachete  de macrouri.

http://www.pitonyak.org/oo.php Materiale privind macrourile.

http://www.pitonyak.org/database/ Materiale privind macrourile specifice bazelor 
de date.

http://development.openoffice.org/ Legături către orice.

http://www.oooforum.org/ Multe exemple şi informaţii de ajutor.
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Cum s  ă rula i un macroţ

O modalitate tipică pentru a rula un macro este următoarea:

1) Folosiţi Unelte > Macrouri > Rulează macro (Tools > Macros > Run Macro) pentru 
a deschide dialogul Selectare macro (Macro Selector) (vedeţi Imaginea 286). 

2) Selectaţi biblioteca şi modulul din lista Bibliotecă (Library) (pe partea din stânga). 

3) Selectaţi macroul din lista Nume macro (Macro name) (pe partea din dreapta).

4) Apăsaţi Rulează (Run) pentru a executa macroul.

Imaginea 286. Utilizarea dialogului Selectare macro (Macro Selector) pentru a 
rula macrouri.

Deşi puteţi folosi Unelte > Macrouri > Rulează macro (Tools > Macros > Run Macro) 
pentru a executa toate macrourile, aceasta nu este eficient pentru macrourile executate frecvent. 
Mult mai comod este să atribuiţi unui macro un buton de pe bara de unelte, un element din 
meniu, o combinaţie de taste rapide sau un buton inclus în document. Pentru a alege cea mai 
bună metodă reflectaţi la următoarele aspecte:

• Macroul va fi disponibil numai pentru un singur document, sau în mod global pentru 
toate documentele?

• Macroul este specific unui anumit tip de documente, ca de exemplu documentelor Calc?

• Cât de frecvent va fi utilizat macroul?

Răspunsurile vă vor arăta unde să stocaţi macroul şi cum să fie acesta accesat. De exemplu, 
probabil că nu veţi adăuga un macro foarte rar folosit la bara de unelte. Pentru a vă uşura 
alegerea, citiţi Tabelul 4.

Tabelul 4. Metode pentru rularea unui macro.

Tip OpenOffice.org Tip document Document

Bară de unelte Nu Da Da
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Tip OpenOffice.org Tip document Document

Meniu Nu Da Da

Tastă rapidă Da Da Nu

Eveniment Da Nu Da

Pentru a adăuga un  element de meniu, o tastă rapidă sau un o pictogramă pe bara de unelte ce 
rulează un macro folosiţi dialogul Personalizare (Customize) (vedeţi Imaginea 287). Puteţi să 
deschideţi acest dialog în două moduri:

• Alegeţi Unelte > Personalizare (Tools > Customize) din bara principală de meniu.

• Fiecare bară de unelte are o pictogramă  care deschide un meniu; alegeţi opţiunea 
Personalizare bară de unelte (Customize Toolbar).

Imaginea 287: Dialogul Personalizare (Customize) din OpenOffice.org.

Pont O descriere completă a dialogului Personalizare este dincolo de scopul acestui capitol. 
Apăsaţi butonul Ajutor (Help) pentru a accesa paginile de ajutor include în 
OpenOffice.org.

Dialogul Personalizare conţine categorii pentru a configura meniurile, asocierile de taste, 
barele de unelte şi evenimentele.
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Bare de unelte (Toolbars)
Macrourile pot fi adăugate barelor de unelte. Pentru mai multe informaţii citiţi capitolul 4 
(Meniuri şi bare de unelte).

Meniuri (Menus)
Folosiţi Unelte > Personalizare (Tools > Customize) pentru a deschide dialogul Personalizare 
(Customize), şi selectaţi categoria Meniuri (Menus). Puteţi modifica un meniu existent sau să 
creaţi noi meniuri ce apelează macrouri. Pentru a afla mai mult despre modificarea meniurilor 
consultaţi capitolul 4 (Meniuri şi bare de unelte).

Taste rapide
Folosiţi Unelte > Personalizare (Tools > Customize) pentru a deschide dialogul Personalizare 
(Customize), şi selectaţi categoria Tastatură (Keyboard). Desemnarea tastelor rapide este 
detaliată în Anexa A (Taste rapide).

Evenimente (Events)
În OpenOffice.org, atunci când se întâmplă ceva, spunem că a apărut un eveniment. De 
exmplu, deschiderea unui document, apăsarea unei taste sau mişcarea mausului sunt toate 
evenimente. OpenOffice.org permite ca la apariţia unui eveniment să fie rulat un macro; acel 
macro este denumit utilizatorul evenimentului (event handler). Descrierea extensivă a acestui 
mecanism depăşeşte scopul acestui document, dar trebuie să ştiţi câte ceva.

Aten ieţ Fiţi atent atunci când configuraţi un utilizator de evenimente. De exemplu, să 
presupunem că scrieţi un utilizator de evenimente care este apelat de fiecare dată 
când este apăsată o tastă, dar comiteţi o greşeală aşa încât evenimentul nu este trat 
corect. Un posibil rezultat poate fi că utilizatorul va intercepta toate tastele apăsate şi 
vă va forţa să închideţi OpenOffice.org.

Folosiţi Unelte > Personalizare (Tools > Customize) pentru a deschide dialogul Personalizare 
(Customize), şi selectaţi categoria Evenimente (Events) (vedeţi Imaginea 288). Evenimentele 
din dialogul Personalizare se referă şi la întreaga aplicaţie şi la documente specifice. Folosiţi 
caseta Salvează în (Save In) pentru a selecta între OpenOffice.org şi un document specific.
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Imaginea 288: Atribuirea unui macro pentru un eveniment al 
aplicaţiei.

O utilizare comună este să atribuiţi evenimentul Open Document (Deschidere document) unui 
anumit macro. Acesta va efectua astfel anumite lucrări pregătitoare deschiderii documentului. 
Selectaţi evenimentul dorit şi apăsaţi butonul Macro pentru a deschide dialogul Selectare 
macro  (Macro Selector) (vedeţi Imaginea 281).

Selectaţi macroul dorit şi apăsaţi OK pentru a atribui macroul către eveniment. Categoria 
Evenimente (Events) arată că evenimentul este legat de macro (vedeţi Imaginea 279). Când se 
va deschide documentul va fi rulat macroul PrintHello.

Imaginea 289: Atribuirea unui macro pentru evenimentul Open 
Document.
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Imaginea 290: PrintHello este atribuit evenimentului Open Document.

Multe obiecte dintr-un document pot fi configurate să apeleze macrouri când apar evenimente. 
Cel mai obişnuit este să adăugaţi un control, cum ar fi un buton, într-un document. Chiar şi 
dublu-clic pe o imagine deschide un dialog cu categoria Macrouri (Macros) ce vă permite 
atribuirea unui macro la un eveniment.

Extensii

O extensie este un pachet ce poate fi instalat în OpenOffice.org pentru a adăuga noi 
funcţionalităţi sau facilităţi. Extensiile pot fi scrise în orice limbaj de programare şi pot fi 
simple sau oricât de sofisticate. Extensiile pot fi grupate în mai multe tipuri:

• Calc Add-Ins, care adaugă funcţionalitate pentru Calc, incluzând noi funcţii ce se 
comportă ca şi cele existente deja în aplicaţie.

• Noi componente şi facilităţi, care includ un anumit nivel de integrare în interfaţa grafică 
a OOo sub forma de noi meniuri şi bare de unelte.

• Noi datapilot pentru a fi utilizaţi direct în Calc

• Chart Add-Ins cu noi tipuri de grafice

• Componente lingvistice ca de exemplu verificatoarele ortografice

• Şabloane de documente şi imagini

Deşi extensii individuale pot fi găsite în multe locuri există o arhivă la: 
http://wiki.services.openoffice.org/wiki/Extensions_repository. Pentru a afla mai multe despre 
extensii , citiţi capitolul 12 (Lucrul cu şabloane).

Scrierea macrourilor f r  înregistrareă ă

Exemplele din acest capitol au fost create folosind înregistrarea macro şi mecanismul de 
expediere de comenzi. Puteţi însă să scrieţi care accesează direct obiectele ce compun 
OpenOffice.org. Cu alte cuvinte, puteţi manipula în mod direct şi nemijlocit un document.

Manipularea directă a obiectelor interne ale OOo este o tehnică avansată ce excede acestui 
capitol. Un exemplu totuşi simplu vă va arăta însă cum funcţionează acest sistem.

Listarea 4: Adăugarea textului “Hello” în documentul curent.

Sub AppendHello
  Dim oDoc
  Dim sTextService$
  Dim oCurs
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  REM ThisComponent se referă la documentul care este acum activ.
  oDoc = ThisComponent

  REM Verifică faptul că este un document text
  sTextService = "com.sun.star.text.TextDocument"
  If NOT oDoc.supportsService(sTextService) Then
    MsgBox "This macro only works with a text document"
    Exit Sub
  End If
  
  REM Obţine cursorul din controlorul curent.
  oCurs = oDoc.currentController.getViewCursor()
  
  REM Delasează cursorul la finalul documentului
  oCurs.gotoEnd(False)
  
  REM Inserează textul "Hello" la finalul documentului
  oCurs.Text.insertString(oCurs, "Hello", False)  
End Sub

Mai multe informa iiţ

Numeroase resurse sunt disponibile pentru a vă oferi ajutor în a scrie macrouri. Folosiţi Ajutor 
> Ajutor OpenOffice.org (Help > OpenOffice.org Help) pentru a deschide paginile de ajutor 
din OOo. Colţul din stânga-sus din sistemul de ajutor al OOo conţine o listă derulantă ce 
determină la ce se referă ajutorul. Pentru a citi ajutorul referitor la Basic, selectaţi din listă 
Ajutor despre OpenOffice.org Basic (Help about OpenOffice.org Basic).

Materialul inclus
Multe macrouri excelente sunt deja incluse în OOo. Folosiţi Unelte > Macrouri > Organizare 
macrouri > OpenOffice.org Basic (Tools > Macros > Organize Macros > OpenOffice.org 
Basic) pentru a deschide dialogul Macro. Expandaţi biblioteca Tools din containerul 
OpenOffice.org. Uitaţi-vă în modulul Debug (Depanare) — sunt exemple bune ce includ 
WritedbgInfo(document) şi printdbgInfo(foaie de calcul).

Resurse online 
Următoarele legături şireferinţe conţin informaţii despre programarea macro:

• http://www.openoffice.org (legătura principală)

• http://codesnippets.services.openoffice.org/ (exemple pe categorii)

• http://www.oooforum.org (dacă aveţi nevoie de ajutor puteţi întreba aici, este probabil 
cel mai bun forum OOo de pe web)

• http://api.openoffice.org/docs/common/ref/com/sun/star/module-ix.html (referinţa 
oficială IDL, aici veţi găsi toate comenzile cu descrierea aferentă)
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• http://api.openoffice.org/DevelopersGuide/DevelopersGuide.html (documentaţia focială 
care conţine explicaţii detaliate)

• http://www.pitonyak.org/oo.php (pagina despre macrouri a lui Andrew Pitonyak)

• http://www.pitonyak.org/AndrewMacro.odt (numeroase exemple de macrouri)

• http://www.pitonyak.org/book/ (Andrew Pitonyak a scris o carte despre macrouri)

• http://www.pitonyak.org/database/ (numeroase exemple  pentru Base)

• http://docs.sun.com/app/docs (Sun a scris o carte despre programarea macro — foarte 
bine scrisă şi structurată)

• http://documentation.openoffice.org (conţine şi informaţii despre macrouri)

• http://ooextras.sourceforge.net/ (exemple)

• http://sourceforge.net/project/showfiles.php?group_id=43716 (exemple)

• http://homepages.paradise.net.nz/hillview/OOo/ (numeroase macrouri excelente, 
inclusiv macrouri ce afişează diversele coduri, şi informaţii despre conversiile cu 
formatele MS Office)

Material tip rită

Următoarele lucrări tipărite conţin exemple macro. Cel mai bun exemplu este documentaţia 
elaborată de Sun. Începeţi cu saitul de documentaţie al Sun http://docs.sun.com/app/docs şi 
căutaţi documentaţie pentru StarOffice.

Andrew Pitonyak a scris o carte intitulată OpenOffice.org Macros Explained. Două capitole pot 
fi descărcare direct de la el. Vedeţi http://www.pitonyak.org/book/.

Dr. Mark Alexander Bain a scris Learn OpenOffice.org Spreadsheet Macro Programming 
(vedeţi http://www.packtpub.com/openoffice-ooobasic-calc-automation/book).

Capitolul 17  Ini iere în limbajul macroţ 339

http://www.packtpub.com/openoffice-ooobasic-calc-automation/book
http://www.pitonyak.org/book/
http://docs.sun.com/app/docs
http://homepages.paradise.net.nz/hillview/OOo/
http://sourceforge.net/project/showfiles.php?group_id=43716
http://ooextras.sourceforge.net/
http://documentation.openoffice.org/
http://docs.sun.com/app/docs
http://www.pitonyak.org/database/
http://www.pitonyak.org/book/
http://www.pitonyak.org/AndrewMacro.odt
http://www.pitonyak.org/oo.php
http://api.openoffice.org/DevelopersGuide/DevelopersGuide.html




Iniţiere

Anexa AA
 Taste rapide



Introducere

Introducere

Puteţi utiliza OpenOffice.org (OOo) fără a recurge la maus sau derivatele sale, folosindu-vă de 
tastele rapide. Operaţiuni variate şi compleze de genul andocării şi dez-andocării barelor de 
unelte sau a ferestrelor, sau redimensionarea şi mutarea obiectelor, toate pot fi realizate numai 
cu tastatura.

OOo are un set general de taste rapide, disponibil în toate componentele, şi un set specific 
fiecărei componente conceput special pentru genul de activităţi din acea componentă (Writer, 
Calc, Impress, Draw şi Base). Acest document descrie setul genral: tastele rapide specifice 
fiecărei componente vor fi descrise în ghidul corespunzător fiecăreia.

Pentru ajutor despre tastele rapide din OOo şi utilizarea acestora, sau utilizarea OOo numai cu 
tastatura, căutaţi în Ajutorul OOo (Help) folosind cuvintele-cheie "tastă rapidă" (“shortcut”) 
sau "accesibilitate" (“accessibility”).

Asocierea tastelor rapide

Suplimentar tastelor rapide definite deja din fabrică (şi pe care le găsiţi pe paginile următoare) 
vi le puteţi defini şi pe ale dumneavoastră. Puteţi asocia taste rapide funcţiilor obişnuite din 
OOo sau macrourilor create de dumneavoastră şi să le salvaţi pentru utilizare împreună cu toate 
aplicaţiile OpenOffice.org.

Aten ieţ Fiţi grijuliu atunci când reasociaţi tastele rapide ce erau deja definite de OOo sau 
chiar de către sistemul de operare. Multe combinaţii au semnificaţii universale, ca 
de exemplu F1 pentru Ajutor (Help), şi astfel sunt întotdeauna presupuse a avea 
asocierea respectivă. Deşi puteţi oricând reveni la setările OOo aceste modificări 
pot crea confuzie, frustrări şi posibile pierderi de date, mai ales atunci când nu 
sunteţi singurul utilizator al calculatorului.

Pentru a adapta tastele rapide nevoilor dumneavoastră folosiţi dialogul Personalizare 
(Customize), după cum veţi citi mai jos.

5) Selectaţi Unelte > Personalizare > Tastatură (Tools > Customize > Keyboard). Se va 
deschide dialogul Personalizare (Imaginea 291).

6) Pentru ca tastele rapide să fie disponibile în toate componentele din OpenOffice.org 
selectaţi butonul OpenOffice.org.

7) În continuare selectaţi funcţia necesară din listele Categorie (Category) şi Funcţie 
(Function).

8) Acum selectaţi combinaţia de taste dorită ca taste rapide în lista Taste rapide (Shortcut 
keys) şi apăsaţi butonul Modifică (Modify) din dreapta-sus.

9) Apăsaţi OK pentru a opera modificările. Acum combinaţia de taste va executa funcţia 
aleasă la pasul 3 de mai sus ori de câte ori este apăsată.
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Note 1. Toate tastele rapide pentru Funcţia (Function) selectată la un moment dat sunt 
listate în caseta de selectare Taste (Keys). Dacă lista Taste este vidă înseamnă că 
respectiva combinaţie nu are asociată nici o funcţie. Dacă ar fi invers, şi dacă 
totuşi aţi dori ca să asociaţi respectiva combinaţie deşi este deja utilizată, va 
trebui mai întâi să ştergeţi (butonul Şterge - Delete ) Tasta (Key) existentă.

2. Tastele rapide care sunt colorate în gri deschis în lista din dialogul Personalizare, 
cum sunt de exemplu F1 şi F10, nu pot fi asociate.

Imaginea 291: Dialogul Personalizare (Customize).

Salvarea modific rilor într-un fişieră

Modificările aduse asocierilor de taste rapide (ca şi a altor configurări) pot fi salvate într-un 
fişier de configurare a tastaturii pentru a fi utilizat ulterior, putând astfel crea şi aplica diverse 
configuraţii după cum este nevoie. Pentru a salva tastele rapide într-un fişier:

1) După ce definiţi toate asocierile dorite, apăsaţi butonul Salvează (Save) din partae 
dreapta-jos a dialogului Personalizare (Customize) (Imaginea 291).
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2) În dialogul Salvare configuraţie tastatură (Save Keyboard Configuration) selectaţi Toate 
fişierele (All files) din lista from the Salvează de tipul (Save as Type).

3) În continuare introduceţi un nume pentru fişierul ce va conţine configuraţia tastaturii în 
caseta Nume fişier (File name), sau selectaţi un nume deja existent dis listă. Dacă este 
necesar, navigaţi până în alt director pentru a găsi fişierul dorit.

4) Apăsaţi Salvează (Save). Va fi afişat un dialog de confirmare în cazul în care urmează a 
fi suprascris un fişier existent, altminteri fişierul va fi salvat fără alte incidente.

Înc rcarea unei configura ii salvate de tastatură ţ ă

Pentru a încărca o configuraţie salvată de tastatură care să o înlocuiască pe cea în uz, apăsaţi 
butonul Încarcă (Load) din partea dreapta-jos a dialogului Personalizare (Customize) 
(Imaginea 291), şi apoi selectaţi fişierul cu configuraţia din dialogul Încărcare configuraţie 
tastatură (Load Keyboard Configuration).

Resetarea tastelor rapide
Pentru a reseta toate tastele rapide la configuraţia iniţială apăsaţi butonul Resetare (Reset) din 
partea din dreapta-jos a dialogului Personalizare (Imaginea 291). Folociţi această facilitate cu 
atenţie, deoarece nu va fi afişat nici un dialog de confirmare; modificarea asignării tastelor va 
opera imediat şi fără nici un alt avertisment.

Rularea macrourilor
Puteţi de asemenea să definiţi taste rapide care să ruleze macrouri. Aceste taste rapide sunt 
definite numai de utilizator; nu există nici una predefinită din fabrică. Pentru informaţii despre 
macrouri, citiţi capitolul 17 (Iniţiere în limbajul macro).

Taste rapide generale în OpenOffice.org

Taste rapide Rezultat

tasta Enter Activează butonul selectat dintr-un dialog.
Esc Termină acţiunea sau dialogul. În OpenOffice.org Ajutor (Help): 

mergeţi în sus un nivel.
Tasta Spaţiu Comută bifat/ nebifat bifele dintr-un dialog.
Tastele săgeată Într-o secţiune de opţiuni din cadrul unui dialog selectează un alt 

câmp activ.
Tab Deplasează focusul la următoarea secţiune sau element din dialog.
Shift + Tab Deplasează focusul la secţiunea sau elementul anterior din dialog.
Alt+Săgeată jos Deschide lista derulantă a câmpului care este selectat dintr-un 

dialog, sau a pictogramei dacă are aşa ceva. Închideţi lista cu tasta 
Escape.
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Taste rapide Rezultat

Del Şterge (mută elementele selectate în coşul de gunoi digital - recycle 
bin).

Shift+Del Şterge definitiv elementele selectate (nu mai sunt mutate în coş). 
Backspace Dacă este afişat un folder: în sus cu un nivel în ierarhie (sau merge 

înapoi).
Ctrl+Shift+Space Şterge formatarea aplicată textului sau obiectelor selectare (ca la 

Formatare > Formatare obişnuită - Format > Default Formatting).
Ctrl + Tab Este inserat un tab dacă este poziţionat la începutul unui antet.
Enter (dacă este 
selectat un obiect OLE)

Activează obiectul OLE selectat.

Enter (dacă este 
selectat un obiect desen 
sau text)

Activează modul de introducere text.

Ctrl + O Deschide un document.
Ctrl + S Salvează documentul curent.
Ctrl + N Creează un document nou.
Shift+Ctrl+N Deschide dialogul Şabloane şi documente - Templates and 

Documents.
Ctrl + P Imprimă documentul.
Ctrl + Q Părăseşte aplicaţia (închide toate ferestrele).
Ctrl + X Taie elementele selectate.
Ctrl + C Copiază elementele selectate.
Ctrl + V Lipeşte din clipbord.
Ctrl + Shift + V Deschide dialogul Lipire specială - Paste Special.
Ctrl + A Selectează tot.
Ctrl + Z Reface înainte de ultima modificare.
Ctrl + Y Repetă ultima modificare.
Ctrl+F Apelează dialogul Găseşte şi înlocuieşte - Find & Replace.
Ctrl+Shift+F Caută din nou ultimul termen ce fusese căutat.
Ctrl+Shift+J Comută între vizualizarea pe tot ecranul (fullscreen) şi cea normală 

în Writer şi Calc.
Ctrl+Shift+R Reafişează documentul.
Shift+Ctrl+I Activează sau dezactivează cursorul de selecţie atunci când textul 

este numai-citire (read-only).
Ctrl+I Aplică formatarea Cursiv (Italic) textului selectat sau în continuare. 

Dacă nu este selectat text iar cursorul este în mijlocul unui cuvânt 
formatarea este aplicată cuvântului.

Ctrl+B Aplică formatarea Aldin (Bold) textului selectat sau în continuare. 
Dacă nu este selectat text iar cursorul este în mijlocul unui cuvânt 
formatarea este aplicată cuvântului.

Ctrl+U Aplică formatarea Subliniat (Underlined) textului selectat sau în 
continuare. Dacă nu este selectat text iar cursorul este în mijlocul 
unui cuvânt formatarea este aplicată cuvântului.
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Taste rapide cu tastele Func ieţ

Taste rapide cu tastele Func ieţ

Taste rapide Rezultat
F1 Deschide OOo Ajutor (OpenOffice.org Help).

În OpenOffice.org Ajutor: merge la pagina de ajutor principală.
Shift + F1 Activează Ponturi extinse (Extended Tips) pentru cursorul 

mausului, care devine un semn de întrebare. Deplasaţi cursorul 
deasupra unui element din interfaţă (comandă, pictogramă sau 
control) pentru a fi afişat pontul extins.

Shift+F2 Afişează pontul extins pentru elementul selectat cu tastatura.
Ctrl+F4 sau Alt+F4 Închide documentul curent (închide şi OpenOffice.org dacă este 

singurul document în uz).
F6 Deplasează focusul în următoarea sub-fereastră (de exemplu, 

vizualizarea document/sursă date).
Shift+F6 Deplasează focusul în sub-fereastra anterioară.
F10 Activează primul meniu (meniul Fişier - File).
Shift+F10 Deschide meniul contextual.
Ctrl+F11 Deschide Catalogul stil (Style Catalog).

Taste rapide în Galerie

Taste rapide Rezultat
Tab Mută cursorul între zone.
Shift+Tab Mută cursorul între zone (înapoi).

Taste rapide în zona din Galerie Tem  nou  (Newă ă  
Theme)

Taste rapide Rezultat
Săgeată sus Mută selecţia în sus.
Săgeată jos Mută selecţia în jos.
Ctrl+Enter Deschide dialogul Proprietăţi 

(Properties).
Shift+F10 Deschie meniul contextual.
Ctrl+U Reafişează tema selectată.
Ctrl+R Deschide dialogul Introduce titlu (Enter 

Title).
Ctrl+D Şterge tema selectată.
Insert Inserează o nouă temă.
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Taste rapide în Galerie

Taste rapide în Galerie, zona previzualizare

Taste rapide Rezultat
Home Sare la primul element.
End Sare la ultimul element.
Săgeată stânga Selectează următorul element din Gallery din stânga.
Săgeată dreapta Selectează următorul element din Gallery din dreapta.
Săgeată sus Selectează următorul element din Gallery de sus.
Săgeată jos Selectează următorul element din Gallery de jos.
Page Up Derulează în sus un ecran.
Page Down Derulează în jos un ecran.
Ctrl+Shift+Insert Inserează în documentul curent obiectul selectat, ca referinţă.
Ctrl+I Inserează în documentul curent o copie a obiectului selectat.
Ctrl+T Deschide dialogul Introduce titlu (Enter Title).
Ctrl+P Comută între vizualizare temă şi vizualizare obiect.
Spacebar Comută între vizualizare temă şi vizualizare obiect.
Enter Comută între vizualizare temă şi vizualizare obiect.
Pas înapoi Comută înapoi la vizualizarea principală (numai din vizualizare 

obiect).

Selectarea rândurilor şi coloanelor dintr-un 
tabel

Taste rapide Rezultat
Tasta spaţiu Comută selectarea rândului, cu excepţia când rândul este în 

mod editare.
Ctrl+Tasta spaţiu Comută selectarea rândului.
Shift+Tasta spaţiu Selectează coloana curentă.

Taste rapide pentru obiecte Desen

Taste rapide Rezultat
Selectaţi bara de unelte cu 
F6. Folosiţi Săgeată jos şi  
Săgeată dreapta pentru a 
selecta pictograma dorită de  
pe bara de unelte şi apoi 
apăsaţi Ctrl+Enter

Inserează un obiect Desen (Drawing).

Selectaţi documentul cu 
Ctrl+F6 şi apăsaţi Tab

Selectează un obiect Desen (Drawing).

Tab Selectează următorul obiect Desen (Drawing).
Shift+Tab Selectează obiectul Desen (Drawing) anterior.
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Taste rapide pentru obiecte Desen

Ctrl+Home Selectează primul obiect Desen (Drawing).
Ctrl+End Selectează ultimul obiect Desen (Drawing).
Esc Deselectează obiectul Desen (Drawing).
Esc (în modul Selectare cu 
mâner)

Iese din modul Selectare cu mâner şi revine în modul 
Selectare obiect.

Săgeată sus/ jos/ stânga/  
dreapta

Mută punctul selectat (agăţarea la grilă este temporar 
dezactivată, dar punctele finale se vor agăţa unele de altele).

Alt+Săgeată  
Up/Down/Left/Right Arrow

Mută obiectul Desen (Drawing) selectat un pixel (în modul 
Selectare).

Redimensionează un obiect Desen (în modul Selectare cu 
mâner).

Roteşte un obiect Desen (în modul Rotire).

Deschide dialogul proprietăţi al unui obiect Desen.

Activează modul Selectare punct pentru obiectul desen 
selectat.

Tasta spaţiu Selectează un punct dintr-un obiect desen (în modul Selectare 
punct) sau anulează selecţia.

Punctul selectat clipeşte o dată pe secundă.
Shift+Tasta spaţiu Selectează un punct suplimentar în modul Selectare punct
Ctrl+Tab Selectează următorul punct al unui obiect desen (modul 

Selectare punct).

În modul Rotire, poate fi selectat şi centrul rotaţiei.
Shift+Ctrl+Tab Selectează punctul anterior al unui obiect desen (modul 

Selectare punct).
Ctrl+Enter Poziţionează un nou obiect desen cu mărimea implicită în 

centrul vizualizării curente.
Ctrl+Enter la pictograma 
Selectare (Selection)

Activează primul obiect desen din document.

Esc Abandonează modul Selectare punct. Este selectat obiectul 
desen.

Editează un punct din obiectul desen (modul Editare punct).
Orice tastă literă sau 
numerică

Dacă este selectat un obiect desen comută în modul editare şi 
poziţionează cursorul la sfârşitul textului în cadrul acestuia. 
Este inserat caracterul tipăribil corespunzător tastei apăsate.
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