log4net Namespace

log4net Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | AssemblyInfo | Provides information about the environment the assembly has been built for.
Public class | GlobalContext | The log4net Global Context.
Public class | LogicalThreadContext | The log4net Logical Thread Context.
Public class | LogManager | This class is used by client applications to request logger instances.
Public class | MDC | Implementation of Mapped Diagnostic Contexts.
Public class | NDC | Implementation of Nested Diagnostic Contexts.
Public class | ThreadContext | The log4net Thread Context.
Interfaces
 | Interface | Description
Public interface | ILog | The ILog interface is use by application to log messages into the log4net framework.

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)

Send Feedback on this topic to http://logging.apache.org/log4net/mail-lists.html.


AssemblyInfo Class

AssemblyInfo Class Apache log4net™ SDK Documentation
Provides information about the environment the assembly has been built for.
Inheritance Hierarchy
Online System Object
log4net AssemblyInfo

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class AssemblyInfo
public sealed class AssemblyInfo
Public NotInheritable Class AssemblyInfo
Public NotInheritable Class AssemblyInfo
public ref class AssemblyInfo sealed
public ref class AssemblyInfo sealed
See Also
AssemblyInfo Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AssemblyInfo Members

AssemblyInfo Members Apache log4net™ SDK Documentation
The AssemblyInfo type exposes the following members.
Constructors
 | Name | Description
Public method | AssemblyInfo | Initializes a new instance of the AssemblyInfo class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
ClientProfile | Does it target a client profile?
TargetFramework | Type of framework targeted
TargetFrameworkVersion | Version of the framework targeted
Version | Version of the assembly
Back to Top
Properties
Name | Description
Info | Identifies the version and target for this assembly.
Back to Top
See Also
AssemblyInfo Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AssemblyInfo Constructor

AssemblyInfo Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the AssemblyInfo class

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AssemblyInfo()
public AssemblyInfo()
Public Sub New
Public Sub New
public:
AssemblyInfo()
public:
AssemblyInfo()
See Also
AssemblyInfo Class
AssemblyInfo Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AssemblyInfo Fields

AssemblyInfo Fields Apache log4net™ SDK Documentation
The AssemblyInfo type exposes the following members.
Fields
Name | Description
ClientProfile | Does it target a client profile?
TargetFramework | Type of framework targeted
TargetFrameworkVersion | Version of the framework targeted
Version | Version of the assembly
Back to Top
See Also
AssemblyInfo Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AssemblyInfo.ClientProfile Field

AssemblyInfo ClientProfile Field Apache log4net™ SDK Documentation
Does it target a client profile?

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const bool ClientProfile
public const bool ClientProfile
Public Const ClientProfile As Boolean
Public Const ClientProfile As Boolean
public:
literal bool ClientProfile
public:
literal bool ClientProfile
Field Value
Type:   Online Boolean
See Also
AssemblyInfo Class
AssemblyInfo Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AssemblyInfo.TargetFramework Field

AssemblyInfo TargetFramework Field Apache log4net™ SDK Documentation
Type of framework targeted

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TargetFramework
public const string TargetFramework
Public Const TargetFramework As String
Public Const TargetFramework As String
public:
literal String^ TargetFramework
public:
literal String^ TargetFramework
Field Value
Type:   Online String
See Also
AssemblyInfo Class
AssemblyInfo Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AssemblyInfo.TargetFrameworkVersion Field

AssemblyInfo TargetFrameworkVersion Field Apache log4net™ SDK Documentation
Version of the framework targeted

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly decimal TargetFrameworkVersion
public static readonly decimal TargetFrameworkVersion
Public Shared ReadOnly TargetFrameworkVersion As Decimal
Public Shared ReadOnly TargetFrameworkVersion As Decimal
public:
static initonly Decimal TargetFrameworkVersion
public:
static initonly Decimal TargetFrameworkVersion
Field Value
Type:   Online Decimal
See Also
AssemblyInfo Class
AssemblyInfo Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AssemblyInfo.Version Field

AssemblyInfo Version Field Apache log4net™ SDK Documentation
Version of the assembly

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string Version
public const string Version
Public Const Version As String
Public Const Version As String
public:
literal String^ Version
public:
literal String^ Version
Field Value
Type:   Online String
See Also
AssemblyInfo Class
AssemblyInfo Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AssemblyInfo Methods

AssemblyInfo Methods Apache log4net™ SDK Documentation
The AssemblyInfo type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AssemblyInfo Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AssemblyInfo Properties

AssemblyInfo Properties Apache log4net™ SDK Documentation
The AssemblyInfo type exposes the following members.
Properties
Name | Description
Info | Identifies the version and target for this assembly.
Back to Top
See Also
AssemblyInfo Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AssemblyInfo.Info Property

AssemblyInfo Info Property Apache log4net™ SDK Documentation
Identifies the version and target for this assembly.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Info { get; }
public static string Info { get; }
Public Shared ReadOnly Property Info As String
    Get
Public Shared ReadOnly Property Info As String
    Get
public:
static property String^ Info {
    String^ get ();
}
public:
static property String^ Info {
    String^ get ();
}
Property Value
Type:   Online String
See Also
AssemblyInfo Class
AssemblyInfo Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


GlobalContext Class

GlobalContext Class Apache log4net™ SDK Documentation
The log4net Global Context.
Inheritance Hierarchy
Online System Object
log4net GlobalContext

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class GlobalContext
public sealed class GlobalContext
Public NotInheritable Class GlobalContext
Public NotInheritable Class GlobalContext
public ref class GlobalContext sealed
public ref class GlobalContext sealed
Remarks

            The GlobalContext provides a location for global debugging
            information to be stored.

            The global context has a properties map and these properties can
            be included in the output of log messages. The PatternLayout
            supports selecting and outputing these properties.

            By default the log4net:HostName property is set to the name of
            the current machine.

Examples
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalContext.Properties["hostname"] = Environment.MachineName;
GlobalContext.Properties["hostname"] = Environment.MachineName;
Thread Safety
Static members of this type are safe for multi-threaded operations. Instance members of this type are safe for multi-threaded operations.
See Also
GlobalContext Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


GlobalContext Members

GlobalContext Members Apache log4net™ SDK Documentation
The GlobalContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
Name | Description
Properties | The global properties map.
Back to Top
See Also
GlobalContext Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


GlobalContext Methods

GlobalContext Methods Apache log4net™ SDK Documentation
The GlobalContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
GlobalContext Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


GlobalContext Properties

GlobalContext Properties Apache log4net™ SDK Documentation
The GlobalContext type exposes the following members.
Properties
Name | Description
Properties | The global properties map.
Back to Top
See Also
GlobalContext Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


GlobalContext.Properties Property

GlobalContext Properties Property Apache log4net™ SDK Documentation
The global properties map.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static GlobalContextProperties Properties { get; }
public static GlobalContextProperties Properties { get; }
Public Shared ReadOnly Property Properties As GlobalContextProperties
    Get
Public Shared ReadOnly Property Properties As GlobalContextProperties
    Get
public:
static property GlobalContextProperties^ Properties {
    GlobalContextProperties^ get ();
}
public:
static property GlobalContextProperties^ Properties {
    GlobalContextProperties^ get ();
}
Property Value
Type: GlobalContextProperties

            The global properties map.

Remarks

            The global properties map.

See Also
GlobalContext Class
GlobalContext Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog Interface

ILog Interface Apache log4net™ SDK Documentation
The ILog interface is use by application to log messages into the log4net framework.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILog : ILoggerWrapper
public interface ILog : ILoggerWrapper
Public Interface ILog
    Inherits ILoggerWrapper
Public Interface ILog
    Inherits ILoggerWrapper
public interface class ILog : ILoggerWrapper
public interface class ILog : ILoggerWrapper
Remarks

            Use the LogManager to obtain logger instances
            that implement this interface. The GetLogger(Assembly, Type)
            static method is used to get logger instances.

            This class contains methods for logging at different levels and also
            has properties for determining if those logging levels are
            enabled in the current configuration.

            This interface can be implemented in different ways. This documentation
            specifies reasonable behavior that a caller can expect from the actual
            implementation, however different implementations reserve the right to
            do things differently.

Examples
Simple example of logging messages

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILog log = LogManager.GetLogger("application-log");

log.Info("Application Start");
log.Debug("This is a debug message");

if (log.IsDebugEnabled)
{
    log.Debug("This is another debug message");
}
ILog log = LogManager.GetLogger("application-log");

log.Info("Application Start");
log.Debug("This is a debug message");

if (log.IsDebugEnabled)
{
    log.Debug("This is another debug message");
}
See Also
ILog Members
log4net Namespace
log4net LogManager
[M:LogManager.GetLogger(Assembly, Type)]
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog Members

ILog Members Apache log4net™ SDK Documentation
The ILog type exposes the following members.
Methods
 | Name | Description
Public method | Debug(Object) | Log a message object with the Debug level.
Public method | Debug(Object, Exception) | Log a message object with the Debug level including the stack trace of the Online Exception passed as a parameter.
Public method | DebugFormat(String, Object) | Logs a formatted message string with the Debug level.
Public method | DebugFormat(String, Object ) | Logs a formatted message string with the Debug level.
Public method | DebugFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Debug level.
Public method | DebugFormat(String, Object, Object) | Logs a formatted message string with the Debug level.
Public method | DebugFormat(String, Object, Object, Object) | Logs a formatted message string with the Debug level.
Public method | Error(Object) | Logs a message object with the Error level.
Public method | Error(Object, Exception) | Log a message object with the Error level including the stack trace of the Online Exception passed as a parameter.
Public method | ErrorFormat(String, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object ) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object, Object, Object) | Logs a formatted message string with the Error level.
Public method | Fatal(Object) | Log a message object with the Fatal level.
Public method | Fatal(Object, Exception) | Log a message object with the Fatal level including the stack trace of the Online Exception passed as a parameter.
Public method | FatalFormat(String, Object) | Logs a formatted message string with the Fatal level.
Public method | FatalFormat(String, Object ) | Logs a formatted message string with the Fatal level.
Public method | FatalFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Fatal level.
Public method | FatalFormat(String, Object, Object) | Logs a formatted message string with the Fatal level.
Public method | FatalFormat(String, Object, Object, Object) | Logs a formatted message string with the Fatal level.
Public method | Info(Object) | Logs a message object with the Info level.
Public method | Info(Object, Exception) | Logs a message object with the INFO level including the stack trace of the Online Exception passed as a parameter.
Public method | InfoFormat(String, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object ) | Logs a formatted message string with the Info level.
Public method | InfoFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object, Object, Object) | Logs a formatted message string with the Info level.
Public method | Warn(Object) | Log a message object with the Warn level.
Public method | Warn(Object, Exception) | Log a message object with the Warn level including the stack trace of the Online Exception passed as a parameter.
Public method | WarnFormat(String, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object ) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object, Object, Object) | Logs a formatted message string with the Warn level.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | DebugExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | DebugExt(Object) | Overloaded. Log a message object with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | DebugExt(Object, Exception) | Overloaded. Log a message object with the Debug level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Object) | Overloaded. Log a message object with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Object, Exception) | Overloaded. Log a message object with the Error level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Object) | Overloaded. Log a message object with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Object, Exception) | Overloaded. Log a message object with the Fatal level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Object) | Overloaded. Log a message object with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Object, Exception) | Overloaded. Log a message object with the Info level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Object) | Overloaded. Log a message object with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Object, Exception) | Overloaded. Log a message object with the Warn level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsDebugEnabled | Checks if this logger is enabled for the Debug level.
Public property | IsErrorEnabled | Checks if this logger is enabled for the Error level.
Public property | IsFatalEnabled | Checks if this logger is enabled for the Fatal level.
Public property | IsInfoEnabled | Checks if this logger is enabled for the Info level.
Public property | IsWarnEnabled | Checks if this logger is enabled for the Warn level.
Public property | Logger | Get the implementation behind this wrapper object. (Inherited from ILoggerWrapper.)
Back to Top
See Also
ILog Interface
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog Methods

ILog Methods Apache log4net™ SDK Documentation
The ILog type exposes the following members.
Methods
 | Name | Description
Public method | Debug(Object) | Log a message object with the Debug level.
Public method | Debug(Object, Exception) | Log a message object with the Debug level including the stack trace of the Online Exception passed as a parameter.
Public method | DebugFormat(String, Object) | Logs a formatted message string with the Debug level.
Public method | DebugFormat(String, Object ) | Logs a formatted message string with the Debug level.
Public method | DebugFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Debug level.
Public method | DebugFormat(String, Object, Object) | Logs a formatted message string with the Debug level.
Public method | DebugFormat(String, Object, Object, Object) | Logs a formatted message string with the Debug level.
Public method | Error(Object) | Logs a message object with the Error level.
Public method | Error(Object, Exception) | Log a message object with the Error level including the stack trace of the Online Exception passed as a parameter.
Public method | ErrorFormat(String, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object ) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object, Object, Object) | Logs a formatted message string with the Error level.
Public method | Fatal(Object) | Log a message object with the Fatal level.
Public method | Fatal(Object, Exception) | Log a message object with the Fatal level including the stack trace of the Online Exception passed as a parameter.
Public method | FatalFormat(String, Object) | Logs a formatted message string with the Fatal level.
Public method | FatalFormat(String, Object ) | Logs a formatted message string with the Fatal level.
Public method | FatalFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Fatal level.
Public method | FatalFormat(String, Object, Object) | Logs a formatted message string with the Fatal level.
Public method | FatalFormat(String, Object, Object, Object) | Logs a formatted message string with the Fatal level.
Public method | Info(Object) | Logs a message object with the Info level.
Public method | Info(Object, Exception) | Logs a message object with the INFO level including the stack trace of the Online Exception passed as a parameter.
Public method | InfoFormat(String, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object ) | Logs a formatted message string with the Info level.
Public method | InfoFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object, Object, Object) | Logs a formatted message string with the Info level.
Public method | Warn(Object) | Log a message object with the Warn level.
Public method | Warn(Object, Exception) | Log a message object with the Warn level including the stack trace of the Online Exception passed as a parameter.
Public method | WarnFormat(String, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object ) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object, Object, Object) | Logs a formatted message string with the Warn level.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | DebugExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | DebugExt(Object) | Overloaded. Log a message object with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | DebugExt(Object, Exception) | Overloaded. Log a message object with the Debug level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Object) | Overloaded. Log a message object with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Object, Exception) | Overloaded. Log a message object with the Error level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Object) | Overloaded. Log a message object with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Object, Exception) | Overloaded. Log a message object with the Fatal level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Object) | Overloaded. Log a message object with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Object, Exception) | Overloaded. Log a message object with the Info level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Object) | Overloaded. Log a message object with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Object, Exception) | Overloaded. Log a message object with the Warn level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Back to Top
See Also
ILog Interface
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Debug Method

ILog Debug Method Apache log4net™ SDK Documentation
Log a message object with the Debug level.
Overload List
 | Name | Description
Public method | Debug(Object) | Log a message object with the Debug level.
Public method | Debug(Object, Exception) | Log a message object with the Debug level including the stack trace of the Online Exception passed as a parameter.
Back to Top
See Also
ILog Interface
ILog Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Debug Method (Object)

ILog Debug Method (Object) Apache log4net™ SDK Documentation
Log a message object with the Debug level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Debug(
    Object message
)
void Debug(
    Object message
)
Sub Debug (
    message As Object
)
Sub Debug (
    message As Object
)
void Debug(
    Object^ message
)
void Debug(
    Object^ message
)
Parameters
message
Type:   Online System Object
The message object to log.
Remarks

            This method first checks if this logger is DEBUG
            enabled by comparing the level of this logger with the
            Debug level. If this logger is
            DEBUG enabled, then it converts the message object
            (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger
            and also higher in the hierarchy depending on the value of
            the additivity flag.

WARNING Note that passing an   Online Exception
            to this method will print the name of the   Online Exception
            but no stack trace. To print a stack trace use the
            [M:Debug(object,Exception)] form instead.

See Also
ILog Interface
ILog Members
Debug Overload
log4net Namespace
[M:Debug(object,Exception)]
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Debug Method (Object, Exception)

ILog Debug Method (Object, Exception) Apache log4net™ SDK Documentation
Log a message object with the Debug level including the stack trace of the Online Exception passed as a parameter.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Debug(
    Object message,
    Exception exception
)
void Debug(
    Object message,
    Exception exception
)
Sub Debug (
    message As Object,
    exception As Exception
)
Sub Debug (
    message As Object,
    exception As Exception
)
void Debug(
    Object^ message,
    Exception^ exception
)
void Debug(
    Object^ message,
    Exception^ exception
)
Parameters
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Remarks

            See the [M:Debug(object)] form for more detailed information.

See Also
ILog Interface
ILog Members
Debug Overload
log4net Namespace
[M:Debug(object)]
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.DebugFormat Method

ILog DebugFormat Method Apache log4net™ SDK Documentation
Log a formatted string with the Debug level.
Overload List
 | Name | Description
Public method | DebugFormat(String, Object) | Logs a formatted message string with the Debug level.
Public method | DebugFormat(String, Object ) | Logs a formatted message string with the Debug level.
Public method | DebugFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Debug level.
Public method | DebugFormat(String, Object, Object) | Logs a formatted message string with the Debug level.
Public method | DebugFormat(String, Object, Object, Object) | Logs a formatted message string with the Debug level.
Back to Top
See Also
ILog Interface
ILog Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.DebugFormat Method (String, Object)

ILog DebugFormat Method (String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Debug level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void DebugFormat(
    string format,
    Object arg0
)
void DebugFormat(
    string format,
    Object arg0
)
Sub DebugFormat (
    format As String,
    arg0 As Object
)
Sub DebugFormat (
    format As String,
    arg0 As Object
)
void DebugFormat(
    String^ format,
    Object^ arg0
)
void DebugFormat(
    String^ format,
    Object^ arg0
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Debug(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
DebugFormat Overload
log4net Namespace
[M:Debug(object)]
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.DebugFormat Method (String, Object[])

ILog DebugFormat Method (String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Debug level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void DebugFormat(
    string format,
    params Object[] args
)
void DebugFormat(
    string format,
    params Object[] args
)
Sub DebugFormat (
    format As String,
    ParamArray args As Object()
)
Sub DebugFormat (
    format As String,
    ParamArray args As Object()
)
void DebugFormat(
    String^ format,
    ... array<Object^>^ args
)
void DebugFormat(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Debug(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
DebugFormat Overload
log4net Namespace
[M:Debug(object)]
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.DebugFormat Method (IFormatProvider, String, Object[])

ILog DebugFormat Method (IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Debug level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void DebugFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
void DebugFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
Sub DebugFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
Sub DebugFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
void DebugFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
void DebugFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Debug(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
DebugFormat Overload
log4net Namespace
[M:Debug(object)]
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.DebugFormat Method (String, Object, Object)

ILog DebugFormat Method (String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Debug level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void DebugFormat(
    string format,
    Object arg0,
    Object arg1
)
void DebugFormat(
    string format,
    Object arg0,
    Object arg1
)
Sub DebugFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
Sub DebugFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
void DebugFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
void DebugFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Debug(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
DebugFormat Overload
log4net Namespace
[M:Debug(object)]
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.DebugFormat Method (String, Object, Object, Object)

ILog DebugFormat Method (String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Debug level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void DebugFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
void DebugFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
Sub DebugFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
Sub DebugFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
void DebugFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
void DebugFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Debug(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
DebugFormat Overload
log4net Namespace
[M:Debug(object)]
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Error Method

ILog Error Method Apache log4net™ SDK Documentation
Log a message object with the Error level.
Overload List
 | Name | Description
Public method | Error(Object) | Logs a message object with the Error level.
Public method | Error(Object, Exception) | Log a message object with the Error level including the stack trace of the Online Exception passed as a parameter.
Back to Top
See Also
ILog Interface
ILog Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Error Method (Object)

ILog Error Method (Object) Apache log4net™ SDK Documentation
Logs a message object with the Error level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Error(
    Object message
)
void Error(
    Object message
)
Sub Error (
    message As Object
)
Sub Error (
    message As Object
)
void Error(
    Object^ message
)
void Error(
    Object^ message
)
Parameters
message
Type:   Online System Object
The message object to log.
Remarks

            This method first checks if this logger is ERROR
            enabled by comparing the level of this logger with the
            Error level. If this logger is
            ERROR enabled, then it converts the message object
            (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger
            and also higher in the hierarchy depending on the value of the
            additivity flag.

WARNING Note that passing an   Online Exception
            to this method will print the name of the   Online Exception
            but no stack trace. To print a stack trace use the
            [M:Error(object,Exception)] form instead.

See Also
ILog Interface
ILog Members
Error Overload
log4net Namespace
[M:Error(object,Exception)]
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Error Method (Object, Exception)

ILog Error Method (Object, Exception) Apache log4net™ SDK Documentation
Log a message object with the Error level including the stack trace of the Online Exception passed as a parameter.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Error(
    Object message,
    Exception exception
)
void Error(
    Object message,
    Exception exception
)
Sub Error (
    message As Object,
    exception As Exception
)
Sub Error (
    message As Object,
    exception As Exception
)
void Error(
    Object^ message,
    Exception^ exception
)
void Error(
    Object^ message,
    Exception^ exception
)
Parameters
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Remarks

            See the [M:Error(object)] form for more detailed information.

See Also
ILog Interface
ILog Members
Error Overload
log4net Namespace
[M:Error(object)]
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.ErrorFormat Method

ILog ErrorFormat Method Apache log4net™ SDK Documentation
Log a formatted message string with the Error level.
Overload List
 | Name | Description
Public method | ErrorFormat(String, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object ) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object, Object, Object) | Logs a formatted message string with the Error level.
Back to Top
See Also
ILog Interface
ILog Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.ErrorFormat Method (String, Object)

ILog ErrorFormat Method (String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Error level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ErrorFormat(
    string format,
    Object arg0
)
void ErrorFormat(
    string format,
    Object arg0
)
Sub ErrorFormat (
    format As String,
    arg0 As Object
)
Sub ErrorFormat (
    format As String,
    arg0 As Object
)
void ErrorFormat(
    String^ format,
    Object^ arg0
)
void ErrorFormat(
    String^ format,
    Object^ arg0
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Error(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
ErrorFormat Overload
log4net Namespace
[M:Error(object)]
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.ErrorFormat Method (String, Object[])

ILog ErrorFormat Method (String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Error level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ErrorFormat(
    string format,
    params Object[] args
)
void ErrorFormat(
    string format,
    params Object[] args
)
Sub ErrorFormat (
    format As String,
    ParamArray args As Object()
)
Sub ErrorFormat (
    format As String,
    ParamArray args As Object()
)
void ErrorFormat(
    String^ format,
    ... array<Object^>^ args
)
void ErrorFormat(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Error(object)]
            methods instead.

See Also
ILog Interface
ILog Members
ErrorFormat Overload
log4net Namespace
[M:Error(object,Exception)]
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.ErrorFormat Method (IFormatProvider, String, Object[])

ILog ErrorFormat Method (IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Error level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ErrorFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
void ErrorFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
Sub ErrorFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
Sub ErrorFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
void ErrorFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
void ErrorFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Error(object)]
            methods instead.

See Also
ILog Interface
ILog Members
ErrorFormat Overload
log4net Namespace
[M:Error(object,Exception)]
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.ErrorFormat Method (String, Object, Object)

ILog ErrorFormat Method (String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Error level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ErrorFormat(
    string format,
    Object arg0,
    Object arg1
)
void ErrorFormat(
    string format,
    Object arg0,
    Object arg1
)
Sub ErrorFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
Sub ErrorFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
void ErrorFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
void ErrorFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Error(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
ErrorFormat Overload
log4net Namespace
[M:Error(object)]
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.ErrorFormat Method (String, Object, Object, Object)

ILog ErrorFormat Method (String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Error level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ErrorFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
void ErrorFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
Sub ErrorFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
Sub ErrorFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
void ErrorFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
void ErrorFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Error(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
ErrorFormat Overload
log4net Namespace
[M:Error(object)]
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Fatal Method

ILog Fatal Method Apache log4net™ SDK Documentation
Log a message object with the Fatal level.
Overload List
 | Name | Description
Public method | Fatal(Object) | Log a message object with the Fatal level.
Public method | Fatal(Object, Exception) | Log a message object with the Fatal level including the stack trace of the Online Exception passed as a parameter.
Back to Top
See Also
ILog Interface
ILog Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Fatal Method (Object)

ILog Fatal Method (Object) Apache log4net™ SDK Documentation
Log a message object with the Fatal level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Fatal(
    Object message
)
void Fatal(
    Object message
)
Sub Fatal (
    message As Object
)
Sub Fatal (
    message As Object
)
void Fatal(
    Object^ message
)
void Fatal(
    Object^ message
)
Parameters
message
Type:   Online System Object
The message object to log.
Remarks

            This method first checks if this logger is FATAL
            enabled by comparing the level of this logger with the
            Fatal level. If this logger is
            FATAL enabled, then it converts the message object
            (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger
            and also higher in the hierarchy depending on the value of the
            additivity flag.

WARNING Note that passing an   Online Exception
            to this method will print the name of the   Online Exception
            but no stack trace. To print a stack trace use the
            [M:Fatal(object,Exception)] form instead.

See Also
ILog Interface
ILog Members
Fatal Overload
log4net Namespace
[M:Fatal(object,Exception)]
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Fatal Method (Object, Exception)

ILog Fatal Method (Object, Exception) Apache log4net™ SDK Documentation
Log a message object with the Fatal level including the stack trace of the Online Exception passed as a parameter.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Fatal(
    Object message,
    Exception exception
)
void Fatal(
    Object message,
    Exception exception
)
Sub Fatal (
    message As Object,
    exception As Exception
)
Sub Fatal (
    message As Object,
    exception As Exception
)
void Fatal(
    Object^ message,
    Exception^ exception
)
void Fatal(
    Object^ message,
    Exception^ exception
)
Parameters
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Remarks

            See the [M:Fatal(object)] form for more detailed information.

See Also
ILog Interface
ILog Members
Fatal Overload
log4net Namespace
[M:Fatal(object)]
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.FatalFormat Method

ILog FatalFormat Method Apache log4net™ SDK Documentation
Log a formatted message string with the Fatal level.
Overload List
 | Name | Description
Public method | FatalFormat(String, Object) | Logs a formatted message string with the Fatal level.
Public method | FatalFormat(String, Object ) | Logs a formatted message string with the Fatal level.
Public method | FatalFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Fatal level.
Public method | FatalFormat(String, Object, Object) | Logs a formatted message string with the Fatal level.
Public method | FatalFormat(String, Object, Object, Object) | Logs a formatted message string with the Fatal level.
Back to Top
See Also
ILog Interface
ILog Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.FatalFormat Method (String, Object)

ILog FatalFormat Method (String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Fatal level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void FatalFormat(
    string format,
    Object arg0
)
void FatalFormat(
    string format,
    Object arg0
)
Sub FatalFormat (
    format As String,
    arg0 As Object
)
Sub FatalFormat (
    format As String,
    arg0 As Object
)
void FatalFormat(
    String^ format,
    Object^ arg0
)
void FatalFormat(
    String^ format,
    Object^ arg0
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Fatal(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
FatalFormat Overload
log4net Namespace
[M:Fatal(object)]
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.FatalFormat Method (String, Object[])

ILog FatalFormat Method (String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Fatal level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void FatalFormat(
    string format,
    params Object[] args
)
void FatalFormat(
    string format,
    params Object[] args
)
Sub FatalFormat (
    format As String,
    ParamArray args As Object()
)
Sub FatalFormat (
    format As String,
    ParamArray args As Object()
)
void FatalFormat(
    String^ format,
    ... array<Object^>^ args
)
void FatalFormat(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Fatal(object)]
            methods instead.

See Also
ILog Interface
ILog Members
FatalFormat Overload
log4net Namespace
[M:Fatal(object,Exception)]
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.FatalFormat Method (IFormatProvider, String, Object[])

ILog FatalFormat Method (IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Fatal level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void FatalFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
void FatalFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
Sub FatalFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
Sub FatalFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
void FatalFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
void FatalFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Fatal(object)]
            methods instead.

See Also
ILog Interface
ILog Members
FatalFormat Overload
log4net Namespace
[M:Fatal(object,Exception)]
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.FatalFormat Method (String, Object, Object)

ILog FatalFormat Method (String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Fatal level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void FatalFormat(
    string format,
    Object arg0,
    Object arg1
)
void FatalFormat(
    string format,
    Object arg0,
    Object arg1
)
Sub FatalFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
Sub FatalFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
void FatalFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
void FatalFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Fatal(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
FatalFormat Overload
log4net Namespace
[M:Fatal(object)]
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.FatalFormat Method (String, Object, Object, Object)

ILog FatalFormat Method (String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Fatal level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void FatalFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
void FatalFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
Sub FatalFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
Sub FatalFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
void FatalFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
void FatalFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Fatal(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
FatalFormat Overload
log4net Namespace
[M:Fatal(object)]
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Info Method

ILog Info Method Apache log4net™ SDK Documentation
Log a message object with the Info level.
Overload List
 | Name | Description
Public method | Info(Object) | Logs a message object with the Info level.
Public method | Info(Object, Exception) | Logs a message object with the INFO level including the stack trace of the Online Exception passed as a parameter.
Back to Top
See Also
ILog Interface
ILog Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Info Method (Object)

ILog Info Method (Object) Apache log4net™ SDK Documentation
Logs a message object with the Info level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Info(
    Object message
)
void Info(
    Object message
)
Sub Info (
    message As Object
)
Sub Info (
    message As Object
)
void Info(
    Object^ message
)
void Info(
    Object^ message
)
Parameters
message
Type:   Online System Object
The message object to log.
Remarks

            This method first checks if this logger is INFO
            enabled by comparing the level of this logger with the
            Info level. If this logger is
            INFO enabled, then it converts the message object
            (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger
            and also higher in the hierarchy depending on the value of the
            additivity flag.

WARNING Note that passing an   Online Exception
            to this method will print the name of the   Online Exception
            but no stack trace. To print a stack trace use the
            [M:Info(object,Exception)] form instead.

See Also
ILog Interface
ILog Members
Info Overload
log4net Namespace
[M:Info(object,Exception)]
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Info Method (Object, Exception)

ILog Info Method (Object, Exception) Apache log4net™ SDK Documentation
Logs a message object with the INFO level including the stack trace of the Online Exception passed as a parameter.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Info(
    Object message,
    Exception exception
)
void Info(
    Object message,
    Exception exception
)
Sub Info (
    message As Object,
    exception As Exception
)
Sub Info (
    message As Object,
    exception As Exception
)
void Info(
    Object^ message,
    Exception^ exception
)
void Info(
    Object^ message,
    Exception^ exception
)
Parameters
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Remarks

            See the [M:Info(object)] form for more detailed information.

See Also
ILog Interface
ILog Members
Info Overload
log4net Namespace
[M:Info(object)]
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.InfoFormat Method

ILog InfoFormat Method Apache log4net™ SDK Documentation
Log a formatted message string with the Info level.
Overload List
 | Name | Description
Public method | InfoFormat(String, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object ) | Logs a formatted message string with the Info level.
Public method | InfoFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object, Object, Object) | Logs a formatted message string with the Info level.
Back to Top
See Also
ILog Interface
ILog Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.InfoFormat Method (String, Object)

ILog InfoFormat Method (String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Info level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void InfoFormat(
    string format,
    Object arg0
)
void InfoFormat(
    string format,
    Object arg0
)
Sub InfoFormat (
    format As String,
    arg0 As Object
)
Sub InfoFormat (
    format As String,
    arg0 As Object
)
void InfoFormat(
    String^ format,
    Object^ arg0
)
void InfoFormat(
    String^ format,
    Object^ arg0
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Info(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
InfoFormat Overload
log4net Namespace
[M:Info(object)]
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.InfoFormat Method (String, Object[])

ILog InfoFormat Method (String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Info level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void InfoFormat(
    string format,
    params Object[] args
)
void InfoFormat(
    string format,
    params Object[] args
)
Sub InfoFormat (
    format As String,
    ParamArray args As Object()
)
Sub InfoFormat (
    format As String,
    ParamArray args As Object()
)
void InfoFormat(
    String^ format,
    ... array<Object^>^ args
)
void InfoFormat(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Info(object)]
            methods instead.

See Also
ILog Interface
ILog Members
InfoFormat Overload
log4net Namespace
[M:Info(object,Exception)]
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.InfoFormat Method (IFormatProvider, String, Object[])

ILog InfoFormat Method (IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Info level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void InfoFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
void InfoFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
Sub InfoFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
Sub InfoFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
void InfoFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
void InfoFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Info(object)]
            methods instead.

See Also
ILog Interface
ILog Members
InfoFormat Overload
log4net Namespace
[M:Info(object,Exception)]
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.InfoFormat Method (String, Object, Object)

ILog InfoFormat Method (String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Info level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void InfoFormat(
    string format,
    Object arg0,
    Object arg1
)
void InfoFormat(
    string format,
    Object arg0,
    Object arg1
)
Sub InfoFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
Sub InfoFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
void InfoFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
void InfoFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Info(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
InfoFormat Overload
log4net Namespace
[M:Info(object)]
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.InfoFormat Method (String, Object, Object, Object)

ILog InfoFormat Method (String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Info level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void InfoFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
void InfoFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
Sub InfoFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
Sub InfoFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
void InfoFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
void InfoFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Info(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
InfoFormat Overload
log4net Namespace
[M:Info(object)]
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Warn Method

ILog Warn Method Apache log4net™ SDK Documentation
Log a message object with the Warn level.
Overload List
 | Name | Description
Public method | Warn(Object) | Log a message object with the Warn level.
Public method | Warn(Object, Exception) | Log a message object with the Warn level including the stack trace of the Online Exception passed as a parameter.
Back to Top
See Also
ILog Interface
ILog Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Warn Method (Object)

ILog Warn Method (Object) Apache log4net™ SDK Documentation
Log a message object with the Warn level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Warn(
    Object message
)
void Warn(
    Object message
)
Sub Warn (
    message As Object
)
Sub Warn (
    message As Object
)
void Warn(
    Object^ message
)
void Warn(
    Object^ message
)
Parameters
message
Type:   Online System Object
The message object to log.
Remarks

            This method first checks if this logger is WARN
            enabled by comparing the level of this logger with the
            Warn level. If this logger is
            WARN enabled, then it converts the message object
            (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger
            and also higher in the hierarchy depending on the value of the
            additivity flag.

WARNING Note that passing an   Online Exception
            to this method will print the name of the   Online Exception
            but no stack trace. To print a stack trace use the
            [M:Warn(object,Exception)] form instead.

See Also
ILog Interface
ILog Members
Warn Overload
log4net Namespace
[M:Warn(object,Exception)]
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.Warn Method (Object, Exception)

ILog Warn Method (Object, Exception) Apache log4net™ SDK Documentation
Log a message object with the Warn level including the stack trace of the Online Exception passed as a parameter.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Warn(
    Object message,
    Exception exception
)
void Warn(
    Object message,
    Exception exception
)
Sub Warn (
    message As Object,
    exception As Exception
)
Sub Warn (
    message As Object,
    exception As Exception
)
void Warn(
    Object^ message,
    Exception^ exception
)
void Warn(
    Object^ message,
    Exception^ exception
)
Parameters
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Remarks

            See the [M:Warn(object)] form for more detailed information.

See Also
ILog Interface
ILog Members
Warn Overload
log4net Namespace
[M:Warn(object)]
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.WarnFormat Method

ILog WarnFormat Method Apache log4net™ SDK Documentation
Log a formatted message string with the Warn level.
Overload List
 | Name | Description
Public method | WarnFormat(String, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object ) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object, Object, Object) | Logs a formatted message string with the Warn level.
Back to Top
See Also
ILog Interface
ILog Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.WarnFormat Method (String, Object)

ILog WarnFormat Method (String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Warn level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void WarnFormat(
    string format,
    Object arg0
)
void WarnFormat(
    string format,
    Object arg0
)
Sub WarnFormat (
    format As String,
    arg0 As Object
)
Sub WarnFormat (
    format As String,
    arg0 As Object
)
void WarnFormat(
    String^ format,
    Object^ arg0
)
void WarnFormat(
    String^ format,
    Object^ arg0
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Warn(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
WarnFormat Overload
log4net Namespace
[M:Warn(object)]
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.WarnFormat Method (String, Object[])

ILog WarnFormat Method (String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Warn level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void WarnFormat(
    string format,
    params Object[] args
)
void WarnFormat(
    string format,
    params Object[] args
)
Sub WarnFormat (
    format As String,
    ParamArray args As Object()
)
Sub WarnFormat (
    format As String,
    ParamArray args As Object()
)
void WarnFormat(
    String^ format,
    ... array<Object^>^ args
)
void WarnFormat(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Warn(object)]
            methods instead.

See Also
ILog Interface
ILog Members
WarnFormat Overload
log4net Namespace
[M:Warn(object,Exception)]
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.WarnFormat Method (IFormatProvider, String, Object[])

ILog WarnFormat Method (IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Warn level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void WarnFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
void WarnFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
Sub WarnFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
Sub WarnFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
void WarnFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
void WarnFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Warn(object)]
            methods instead.

See Also
ILog Interface
ILog Members
WarnFormat Overload
log4net Namespace
[M:Warn(object,Exception)]
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.WarnFormat Method (String, Object, Object)

ILog WarnFormat Method (String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Warn level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void WarnFormat(
    string format,
    Object arg0,
    Object arg1
)
void WarnFormat(
    string format,
    Object arg0,
    Object arg1
)
Sub WarnFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
Sub WarnFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
void WarnFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
void WarnFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Warn(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
WarnFormat Overload
log4net Namespace
[M:Warn(object)]
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.WarnFormat Method (String, Object, Object, Object)

ILog WarnFormat Method (String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Warn level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void WarnFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
void WarnFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
Sub WarnFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
Sub WarnFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
void WarnFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
void WarnFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Remarks

            The message is formatted using the String.Format method. See
            [M:String.Format(string, object[])] for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Warn(object,Exception)]
            methods instead.

See Also
ILog Interface
ILog Members
WarnFormat Overload
log4net Namespace
[M:Warn(object)]
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog Properties

ILog Properties Apache log4net™ SDK Documentation
The ILog type exposes the following members.
Properties
 | Name | Description
Public property | IsDebugEnabled | Checks if this logger is enabled for the Debug level.
Public property | IsErrorEnabled | Checks if this logger is enabled for the Error level.
Public property | IsFatalEnabled | Checks if this logger is enabled for the Fatal level.
Public property | IsInfoEnabled | Checks if this logger is enabled for the Info level.
Public property | IsWarnEnabled | Checks if this logger is enabled for the Warn level.
Public property | Logger | Get the implementation behind this wrapper object. (Inherited from ILoggerWrapper.)
Back to Top
See Also
ILog Interface
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.IsDebugEnabled Property

ILog IsDebugEnabled Property Apache log4net™ SDK Documentation
Checks if this logger is enabled for the Debug level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsDebugEnabled { get; }
bool IsDebugEnabled { get; }
ReadOnly Property IsDebugEnabled As Boolean
    Get
ReadOnly Property IsDebugEnabled As Boolean
    Get
property bool IsDebugEnabled {
    bool get ();
}
property bool IsDebugEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if this logger is enabled for Debug events, false otherwise.

Remarks

            This function is intended to lessen the computational cost of
            disabled log debug statements.

 For some ILog interface log, when you write:
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
log.Debug("This is entry number: " + i );
log.Debug("This is entry number: " + i );

            You incur the cost constructing the message, string construction and concatenation in
            this case, regardless of whether the message is logged or not.

            If you are worried about speed (who isn't), then you should write:

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
if (log.IsDebugEnabled)
{
    log.Debug("This is entry number: " + i );
}
if (log.IsDebugEnabled)
{
    log.Debug("This is entry number: " + i );
}

            This way you will not incur the cost of parameter
            construction if debugging is disabled for log. On
            the other hand, if the log is debug enabled, you
            will incur the cost of evaluating whether the logger is debug
            enabled twice. Once in IsDebugEnabled and once in
            the [M:Debug(object)].  This is an insignificant overhead
            since evaluating a logger takes about 1% of the time it
            takes to actually log. This is the preferred style of logging.

Alternatively if your logger is available statically then the is debug
            enabled state can be stored in a static variable like this:

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
private static readonly bool isDebugEnabled = log.IsDebugEnabled;
private static readonly bool isDebugEnabled = log.IsDebugEnabled;

            Then when you come to log you can write:

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
if (isDebugEnabled)
{
    log.Debug("This is entry number: " + i );
}
if (isDebugEnabled)
{
    log.Debug("This is entry number: " + i );
}

            This way the debug enabled state is only queried once
            when the class is loaded. Using a private static readonly
            variable is the most efficient because it is a run time constant
            and can be heavily optimized by the JIT compiler.

            Of course if you use a static readonly variable to
            hold the enabled state of the logger then you cannot
            change the enabled state at runtime to vary the logging
            that is produced. You have to decide if you need absolute
            speed or runtime flexibility.

See Also
ILog Interface
ILog Members
log4net Namespace
[M:Debug(object)]
[M:DebugFormat(IFormatProvider, string, object[])]
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.IsErrorEnabled Property

ILog IsErrorEnabled Property Apache log4net™ SDK Documentation
Checks if this logger is enabled for the Error level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsErrorEnabled { get; }
bool IsErrorEnabled { get; }
ReadOnly Property IsErrorEnabled As Boolean
    Get
ReadOnly Property IsErrorEnabled As Boolean
    Get
property bool IsErrorEnabled {
    bool get ();
}
property bool IsErrorEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if this logger is enabled for Error events, false otherwise.

Remarks

            For more information see IsDebugEnabled.

See Also
ILog Interface
ILog Members
log4net Namespace
[M:Error(object)]
[M:ErrorFormat(IFormatProvider, string, object[])]
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.IsFatalEnabled Property

ILog IsFatalEnabled Property Apache log4net™ SDK Documentation
Checks if this logger is enabled for the Fatal level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsFatalEnabled { get; }
bool IsFatalEnabled { get; }
ReadOnly Property IsFatalEnabled As Boolean
    Get
ReadOnly Property IsFatalEnabled As Boolean
    Get
property bool IsFatalEnabled {
    bool get ();
}
property bool IsFatalEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if this logger is enabled for Fatal events, false otherwise.

Remarks

            For more information see IsDebugEnabled.

See Also
ILog Interface
ILog Members
log4net Namespace
[M:Fatal(object)]
[M:FatalFormat(IFormatProvider, string, object[])]
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.IsInfoEnabled Property

ILog IsInfoEnabled Property Apache log4net™ SDK Documentation
Checks if this logger is enabled for the Info level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsInfoEnabled { get; }
bool IsInfoEnabled { get; }
ReadOnly Property IsInfoEnabled As Boolean
    Get
ReadOnly Property IsInfoEnabled As Boolean
    Get
property bool IsInfoEnabled {
    bool get ();
}
property bool IsInfoEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if this logger is enabled for Info events, false otherwise.

Remarks

            For more information see IsDebugEnabled.

See Also
ILog Interface
ILog Members
log4net Namespace
[M:Info(object)]
[M:InfoFormat(IFormatProvider, string, object[])]
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILog.IsWarnEnabled Property

ILog IsWarnEnabled Property Apache log4net™ SDK Documentation
Checks if this logger is enabled for the Warn level.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsWarnEnabled { get; }
bool IsWarnEnabled { get; }
ReadOnly Property IsWarnEnabled As Boolean
    Get
ReadOnly Property IsWarnEnabled As Boolean
    Get
property bool IsWarnEnabled {
    bool get ();
}
property bool IsWarnEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if this logger is enabled for Warn events, false otherwise.

Remarks

            For more information see IsDebugEnabled.

See Also
ILog Interface
ILog Members
log4net Namespace
[M:Warn(object)]
[M:WarnFormat(IFormatProvider, string, object[])]
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContext Class

LogicalThreadContext Class Apache log4net™ SDK Documentation
The log4net Logical Thread Context.
Inheritance Hierarchy
Online System Object
log4net LogicalThreadContext

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LogicalThreadContext
public sealed class LogicalThreadContext
Public NotInheritable Class LogicalThreadContext
Public NotInheritable Class LogicalThreadContext
public ref class LogicalThreadContext sealed
public ref class LogicalThreadContext sealed
Remarks

            The LogicalThreadContext provides a location for   Online CallContext specific debugging
            information to be stored.
            The LogicalThreadContext properties override any ThreadContext or GlobalContext
            properties with the same name.

            The Logical Thread Context has a properties map and a stack.
            The properties and stack can
            be included in the output of log messages. The PatternLayout
            supports selecting and outputting these properties.

            The Logical Thread Context provides a diagnostic context for the current call context.
            This is an instrument for distinguishing interleaved log
            output from different sources. Log output is typically interleaved
            when a server handles multiple clients near-simultaneously.

            The Logical Thread Context is managed on a per   Online CallContext basis.

            The   Online CallContext requires a link time
              Online SecurityPermission for the
              Online Infrastructure.
            If the calling code does not have this permission then this context will be disabled.
            It will not store any property values set on it.

Examples
Example of using the thread context properties to store a username.

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
LogicalThreadContext.Properties["user"] = userName;
log.Info("This log message has a LogicalThreadContext Property called 'user'");
LogicalThreadContext.Properties["user"] = userName;
log.Info("This log message has a LogicalThreadContext Property called 'user'");
Examples
Example of how to push a message into the context stack

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
using(LogicalThreadContext.Stacks["LDC"].Push("my context message"))
{
    log.Info("This log message has a LogicalThreadContext Stack message that includes 'my context message'");

} // at the end of the using block the message is automatically popped
using(LogicalThreadContext.Stacks["LDC"].Push("my context message"))
{
    log.Info("This log message has a LogicalThreadContext Stack message that includes 'my context message'");

} // at the end of the using block the message is automatically popped
Thread Safety
Static members of this type are safe for multi-threaded operations. Instance members of this type are safe for multi-threaded operations.
See Also
LogicalThreadContext Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContext Members

LogicalThreadContext Members Apache log4net™ SDK Documentation
The LogicalThreadContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
Name | Description
Properties | The thread properties map
Stacks | The thread stacks
Back to Top
See Also
LogicalThreadContext Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContext Methods

LogicalThreadContext Methods Apache log4net™ SDK Documentation
The LogicalThreadContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LogicalThreadContext Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContext Properties

LogicalThreadContext Properties Apache log4net™ SDK Documentation
The LogicalThreadContext type exposes the following members.
Properties
Name | Description
Properties | The thread properties map
Stacks | The thread stacks
Back to Top
See Also
LogicalThreadContext Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContext.Properties Property

LogicalThreadContext Properties Property Apache log4net™ SDK Documentation
The thread properties map

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static LogicalThreadContextProperties Properties { get; }
public static LogicalThreadContextProperties Properties { get; }
Public Shared ReadOnly Property Properties As LogicalThreadContextProperties
    Get
Public Shared ReadOnly Property Properties As LogicalThreadContextProperties
    Get
public:
static property LogicalThreadContextProperties^ Properties {
    LogicalThreadContextProperties^ get ();
}
public:
static property LogicalThreadContextProperties^ Properties {
    LogicalThreadContextProperties^ get ();
}
Property Value
Type: LogicalThreadContextProperties

            The thread properties map

Remarks

            The LogicalThreadContext properties override any ThreadContext
            or GlobalContext properties with the same name.

See Also
LogicalThreadContext Class
LogicalThreadContext Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContext.Stacks Property

LogicalThreadContext Stacks Property Apache log4net™ SDK Documentation
The thread stacks

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static LogicalThreadContextStacks Stacks { get; }
public static LogicalThreadContextStacks Stacks { get; }
Public Shared ReadOnly Property Stacks As LogicalThreadContextStacks
    Get
Public Shared ReadOnly Property Stacks As LogicalThreadContextStacks
    Get
public:
static property LogicalThreadContextStacks^ Stacks {
    LogicalThreadContextStacks^ get ();
}
public:
static property LogicalThreadContextStacks^ Stacks {
    LogicalThreadContextStacks^ get ();
}
Property Value
Type: LogicalThreadContextStacks

            stack map

Remarks

            The logical thread stacks.

See Also
LogicalThreadContext Class
LogicalThreadContext Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager Class

LogManager Class Apache log4net™ SDK Documentation
This class is used by client applications to request logger instances.
Inheritance Hierarchy
Online System Object
log4net LogManager

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LogManager
public sealed class LogManager
Public NotInheritable Class LogManager
Public NotInheritable Class LogManager
public ref class LogManager sealed
public ref class LogManager sealed
Remarks

            This class has static methods that are used by a client to request
            a logger instance. The [M:GetLogger(string)] method is
            used to retrieve a logger.

            See the ILog interface for more details.

Examples
Simple example of logging messages

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILog log = LogManager.GetLogger("application-log");

log.Info("Application Start");
log.Debug("This is a debug message");

if (log.IsDebugEnabled)
{
    log.Debug("This is another debug message");
}
ILog log = LogManager.GetLogger("application-log");

log.Info("Application Start");
log.Debug("This is a debug message");

if (log.IsDebugEnabled)
{
    log.Debug("This is another debug message");
}
Thread Safety
Static members of this type are safe for multi-threaded operations. Instance members of this type are safe for multi-threaded operations.
See Also
LogManager Members
log4net Namespace
log4net ILog
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager Members

LogManager Members Apache log4net™ SDK Documentation
The LogManager type exposes the following members.
Methods
 | Name | Description
 | CreateDomain(String) | Obsolete. Creates a repository with the specified name.
 | CreateDomain(Type) | Obsolete. Creates a repository with the specified repository type.
 | CreateDomain(Assembly, Type) | Obsolete. Creates a repository for the specified assembly and repository type.
 | CreateDomain(String, Type) | Obsolete. Creates a repository with the specified name and repository type.
 | CreateRepository(String) | Creates a repository with the specified name.
 | CreateRepository(Type) | Creates a repository with the specified repository type.
 | CreateRepository(Assembly, Type) | Creates a repository for the specified assembly and repository type.
 | CreateRepository(String, Type) | Creates a repository with the specified name and repository type.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | Exists(String) | Returns the named logger if it exists.
 | Exists(Assembly, String) | Returns the named logger if it exists.
 | Exists(String, String) | Returns the named logger if it exists.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetAllRepositories | Gets the list of currently defined repositories.
 | GetCurrentLoggers | Returns all the currently defined loggers in the default repository.
 | GetCurrentLoggers(Assembly) | Returns all the currently defined loggers in the specified assembly's repository.
 | GetCurrentLoggers(String) | Returns all the currently defined loggers in the specified repository.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetLogger(String) | Retrieves or creates a named logger.
 | GetLogger(Type) | Shorthand for GetLogger(string).
 | GetLogger(Assembly, String) | Retrieves or creates a named logger.
 | GetLogger(Assembly, Type) | Shorthand for GetLogger(string).
 | GetLogger(String, String) | Retrieves or creates a named logger.
 | GetLogger(String, Type) | Shorthand for GetLogger(string).
 | GetLoggerRepository | Obsolete. Returns the default ILoggerRepository instance.
 | GetLoggerRepository(Assembly) | Obsolete. Returns the default ILoggerRepository instance.
 | GetLoggerRepository(String) | Obsolete. Returns the default ILoggerRepository instance.
 | GetRepository | Returns the default ILoggerRepository instance.
 | GetRepository(Assembly) | Returns the default ILoggerRepository instance.
 | GetRepository(String) | Returns the default ILoggerRepository instance.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ResetConfiguration | Resets all values contained in this repository instance to their defaults.
 | ResetConfiguration(Assembly) | Resets all values contained in this repository instance to their defaults.
 | ResetConfiguration(String) | Resets all values contained in this repository instance to their defaults.
 | Shutdown | Shuts down the log4net system.
 | ShutdownRepository | Shuts down the default repository.
 | ShutdownRepository(Assembly) | Shuts down the repository specified.
 | ShutdownRepository(String) | Shuts down the repository for the repository specified.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LogManager Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager Methods

LogManager Methods Apache log4net™ SDK Documentation
The LogManager type exposes the following members.
Methods
 | Name | Description
 | CreateDomain(String) | Obsolete. Creates a repository with the specified name.
 | CreateDomain(Type) | Obsolete. Creates a repository with the specified repository type.
 | CreateDomain(Assembly, Type) | Obsolete. Creates a repository for the specified assembly and repository type.
 | CreateDomain(String, Type) | Obsolete. Creates a repository with the specified name and repository type.
 | CreateRepository(String) | Creates a repository with the specified name.
 | CreateRepository(Type) | Creates a repository with the specified repository type.
 | CreateRepository(Assembly, Type) | Creates a repository for the specified assembly and repository type.
 | CreateRepository(String, Type) | Creates a repository with the specified name and repository type.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | Exists(String) | Returns the named logger if it exists.
 | Exists(Assembly, String) | Returns the named logger if it exists.
 | Exists(String, String) | Returns the named logger if it exists.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetAllRepositories | Gets the list of currently defined repositories.
 | GetCurrentLoggers | Returns all the currently defined loggers in the default repository.
 | GetCurrentLoggers(Assembly) | Returns all the currently defined loggers in the specified assembly's repository.
 | GetCurrentLoggers(String) | Returns all the currently defined loggers in the specified repository.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetLogger(String) | Retrieves or creates a named logger.
 | GetLogger(Type) | Shorthand for GetLogger(string).
 | GetLogger(Assembly, String) | Retrieves or creates a named logger.
 | GetLogger(Assembly, Type) | Shorthand for GetLogger(string).
 | GetLogger(String, String) | Retrieves or creates a named logger.
 | GetLogger(String, Type) | Shorthand for GetLogger(string).
 | GetLoggerRepository | Obsolete. Returns the default ILoggerRepository instance.
 | GetLoggerRepository(Assembly) | Obsolete. Returns the default ILoggerRepository instance.
 | GetLoggerRepository(String) | Obsolete. Returns the default ILoggerRepository instance.
 | GetRepository | Returns the default ILoggerRepository instance.
 | GetRepository(Assembly) | Returns the default ILoggerRepository instance.
 | GetRepository(String) | Returns the default ILoggerRepository instance.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ResetConfiguration | Resets all values contained in this repository instance to their defaults.
 | ResetConfiguration(Assembly) | Resets all values contained in this repository instance to their defaults.
 | ResetConfiguration(String) | Resets all values contained in this repository instance to their defaults.
 | Shutdown | Shuts down the log4net system.
 | ShutdownRepository | Shuts down the default repository.
 | ShutdownRepository(Assembly) | Shuts down the repository specified.
 | ShutdownRepository(String) | Shuts down the repository for the repository specified.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LogManager Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.CreateDomain Method

LogManager CreateDomain Method Apache log4net™ SDK Documentation
Create a domain
Overload List
Name | Description
CreateDomain(String) | Obsolete. Creates a repository with the specified name.
CreateDomain(Type) | Obsolete. Creates a repository with the specified repository type.
CreateDomain(Assembly, Type) | Obsolete. Creates a repository for the specified assembly and repository type.
CreateDomain(String, Type) | Obsolete. Creates a repository with the specified name and repository type.
Back to Top
See Also
LogManager Class
LogManager Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.CreateDomain Method (String)

LogManager CreateDomain Method (String) Apache log4net™ SDK Documentation
Creates a repository with the specified name.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    string repository
)
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    string repository
)
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repository As String
) As ILoggerRepository
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repository As String
) As ILoggerRepository
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    String^ repository
)
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    String^ repository
)
Parameters
repository
Type:   Online System String
The name of the repository, this must be unique amongst repositories.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Exceptions
Exception | Condition
log4net.Core LogException | The specified repository already exists.
Remarks
CreateDomain is obsolete. Use CreateRepository instead of CreateDomain.

            Creates the default type of ILoggerRepository which is a
            Hierarchy object.

            The repository name must be unique. Repositories cannot be redefined.
            An   Online Exception will be thrown if the repository already exists.

See Also
LogManager Class
LogManager Members
CreateDomain Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.CreateDomain Method (Type)

LogManager CreateDomain Method (Type) Apache log4net™ SDK Documentation
Creates a repository with the specified repository type.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    Type repositoryType
)
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    Type repositoryType
)
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repositoryType As Type
) As ILoggerRepository
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repositoryType As Type
) As ILoggerRepository
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    Type^ repositoryType
)
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    Type^ repositoryType
)
Parameters
repositoryType
Type:   Online System Type
A   Online Type that implements ILoggerRepository
            and has a no arg constructor. An instance of this type will be created to act
            as the ILoggerRepository for the repository specified.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Remarks
CreateDomain is obsolete. Use CreateRepository instead of CreateDomain.

            The ILoggerRepository created will be associated with the repository
            specified such that a call to [M:GetRepository()] will return
            the same repository instance.

See Also
LogManager Class
LogManager Members
CreateDomain Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.CreateDomain Method (Assembly, Type)

LogManager CreateDomain Method (Assembly, Type) Apache log4net™ SDK Documentation
Creates a repository for the specified assembly and repository type.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    Assembly repositoryAssembly,
    Type repositoryType
)
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    Assembly repositoryAssembly,
    Type repositoryType
)
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repositoryAssembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repositoryAssembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    Assembly^ repositoryAssembly,
    Type^ repositoryType
)
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    Assembly^ repositoryAssembly,
    Type^ repositoryType
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to get the name of the repository.
repositoryType
Type:   Online System Type
A   Online Type that implements ILoggerRepository
            and has a no arg constructor. An instance of this type will be created to act
            as the ILoggerRepository for the repository specified.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Remarks
CreateDomain is obsolete. Use CreateRepository instead of CreateDomain.

            The ILoggerRepository created will be associated with the repository
            specified such that a call to [M:GetRepository(Assembly)] with the
            same assembly specified will return the same repository instance.

See Also
LogManager Class
LogManager Members
CreateDomain Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.CreateDomain Method (String, Type)

LogManager CreateDomain Method (String, Type) Apache log4net™ SDK Documentation
Creates a repository with the specified name and repository type.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    string repository,
    Type repositoryType
)
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    string repository,
    Type repositoryType
)
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repository As String,
    repositoryType As Type
) As ILoggerRepository
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repository As String,
    repositoryType As Type
) As ILoggerRepository
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    String^ repository,
    Type^ repositoryType
)
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    String^ repository,
    Type^ repositoryType
)
Parameters
repository
Type:   Online System String
The name of the repository, this must be unique to the repository.
repositoryType
Type:   Online System Type
A   Online Type that implements ILoggerRepository
            and has a no arg constructor. An instance of this type will be created to act
            as the ILoggerRepository for the repository specified.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Exceptions
Exception | Condition
log4net.Core LogException | The specified repository already exists.
Remarks
CreateDomain is obsolete. Use CreateRepository instead of CreateDomain.

            The repository name must be unique. Repositories cannot be redefined.
            An   Online Exception will be thrown if the repository already exists.

See Also
LogManager Class
LogManager Members
CreateDomain Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.CreateRepository Method

LogManager CreateRepository Method Apache log4net™ SDK Documentation
Create a logger repository.
Overload List
Name | Description
CreateRepository(String) | Creates a repository with the specified name.
CreateRepository(Type) | Creates a repository with the specified repository type.
CreateRepository(Assembly, Type) | Creates a repository for the specified assembly and repository type.
CreateRepository(String, Type) | Creates a repository with the specified name and repository type.
Back to Top
See Also
LogManager Class
LogManager Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.CreateRepository Method (String)

LogManager CreateRepository Method (String) Apache log4net™ SDK Documentation
Creates a repository with the specified name.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository CreateRepository(
    string repository
)
public static ILoggerRepository CreateRepository(
    string repository
)
Public Shared Function CreateRepository (
    repository As String
) As ILoggerRepository
Public Shared Function CreateRepository (
    repository As String
) As ILoggerRepository
public:
static ILoggerRepository^ CreateRepository(
    String^ repository
)
public:
static ILoggerRepository^ CreateRepository(
    String^ repository
)
Parameters
repository
Type:   Online System String
The name of the repository, this must be unique amongst repositories.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Exceptions
Exception | Condition
log4net.Core LogException | The specified repository already exists.
Remarks

            Creates the default type of ILoggerRepository which is a
            Hierarchy object.

            The repository name must be unique. Repositories cannot be redefined.
            An   Online Exception will be thrown if the repository already exists.

See Also
LogManager Class
LogManager Members
CreateRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.CreateRepository Method (Type)

LogManager CreateRepository Method (Type) Apache log4net™ SDK Documentation
Creates a repository with the specified repository type.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository CreateRepository(
    Type repositoryType
)
public static ILoggerRepository CreateRepository(
    Type repositoryType
)
Public Shared Function CreateRepository (
    repositoryType As Type
) As ILoggerRepository
Public Shared Function CreateRepository (
    repositoryType As Type
) As ILoggerRepository
public:
static ILoggerRepository^ CreateRepository(
    Type^ repositoryType
)
public:
static ILoggerRepository^ CreateRepository(
    Type^ repositoryType
)
Parameters
repositoryType
Type:   Online System Type
A   Online Type that implements ILoggerRepository
            and has a no arg constructor. An instance of this type will be created to act
            as the ILoggerRepository for the repository specified.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Remarks

            The ILoggerRepository created will be associated with the repository
            specified such that a call to [M:GetRepository()] will return
            the same repository instance.

See Also
LogManager Class
LogManager Members
CreateRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.CreateRepository Method (Assembly, Type)

LogManager CreateRepository Method (Assembly, Type) Apache log4net™ SDK Documentation
Creates a repository for the specified assembly and repository type.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository CreateRepository(
    Assembly repositoryAssembly,
    Type repositoryType
)
public static ILoggerRepository CreateRepository(
    Assembly repositoryAssembly,
    Type repositoryType
)
Public Shared Function CreateRepository (
    repositoryAssembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
Public Shared Function CreateRepository (
    repositoryAssembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
public:
static ILoggerRepository^ CreateRepository(
    Assembly^ repositoryAssembly,
    Type^ repositoryType
)
public:
static ILoggerRepository^ CreateRepository(
    Assembly^ repositoryAssembly,
    Type^ repositoryType
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to get the name of the repository.
repositoryType
Type:   Online System Type
A   Online Type that implements ILoggerRepository
            and has a no arg constructor. An instance of this type will be created to act
            as the ILoggerRepository for the repository specified.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Remarks

            The ILoggerRepository created will be associated with the repository
            specified such that a call to [M:GetRepository(Assembly)] with the
            same assembly specified will return the same repository instance.

See Also
LogManager Class
LogManager Members
CreateRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.CreateRepository Method (String, Type)

LogManager CreateRepository Method (String, Type) Apache log4net™ SDK Documentation
Creates a repository with the specified name and repository type.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository CreateRepository(
    string repository,
    Type repositoryType
)
public static ILoggerRepository CreateRepository(
    string repository,
    Type repositoryType
)
Public Shared Function CreateRepository (
    repository As String,
    repositoryType As Type
) As ILoggerRepository
Public Shared Function CreateRepository (
    repository As String,
    repositoryType As Type
) As ILoggerRepository
public:
static ILoggerRepository^ CreateRepository(
    String^ repository,
    Type^ repositoryType
)
public:
static ILoggerRepository^ CreateRepository(
    String^ repository,
    Type^ repositoryType
)
Parameters
repository
Type:   Online System String
The name of the repository, this must be unique to the repository.
repositoryType
Type:   Online System Type
A   Online Type that implements ILoggerRepository
            and has a no arg constructor. An instance of this type will be created to act
            as the ILoggerRepository for the repository specified.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Exceptions
Exception | Condition
log4net.Core LogException | The specified repository already exists.
Remarks

            The repository name must be unique. Repositories cannot be redefined.
            An   Online Exception will be thrown if the repository already exists.

See Also
LogManager Class
LogManager Members
CreateRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.Exists Method

LogManager Exists Method Apache log4net™ SDK Documentation
Returns the named logger if it exists.
Overload List
Name | Description
Exists(String) | Returns the named logger if it exists.
Exists(Assembly, String) | Returns the named logger if it exists.
Exists(String, String) | Returns the named logger if it exists.
Back to Top
See Also
LogManager Class
LogManager Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.Exists Method (String)

LogManager Exists Method (String) Apache log4net™ SDK Documentation
Returns the named logger if it exists.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog Exists(
    string name
)
public static ILog Exists(
    string name
)
Public Shared Function Exists (
    name As String
) As ILog
Public Shared Function Exists (
    name As String
) As ILog
public:
static ILog^ Exists(
    String^ name
)
public:
static ILog^ Exists(
    String^ name
)
Parameters
name
Type:   Online System String
The fully qualified logger name to look for.
Return Value
Type: ILog
The logger found, or null if no logger could be found.
Remarks

            If the named logger exists (in the default repository) then it
            returns a reference to the logger, otherwise it returns null.

See Also
LogManager Class
LogManager Members
Exists Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.Exists Method (Assembly, String)

LogManager Exists Method (Assembly, String) Apache log4net™ SDK Documentation
Returns the named logger if it exists.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog Exists(
    Assembly repositoryAssembly,
    string name
)
public static ILog Exists(
    Assembly repositoryAssembly,
    string name
)
Public Shared Function Exists (
    repositoryAssembly As Assembly,
    name As String
) As ILog
Public Shared Function Exists (
    repositoryAssembly As Assembly,
    name As String
) As ILog
public:
static ILog^ Exists(
    Assembly^ repositoryAssembly,
    String^ name
)
public:
static ILog^ Exists(
    Assembly^ repositoryAssembly,
    String^ name
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
name
Type:   Online System String
The fully qualified logger name to look for.
Return Value
Type: ILog

            The logger, or null if the logger doesn't exist in the specified
            assembly's repository.

Remarks

            If the named logger exists (in the repository for the specified assembly) then it
            returns a reference to the logger, otherwise it returns
            null.

See Also
LogManager Class
LogManager Members
Exists Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.Exists Method (String, String)

LogManager Exists Method (String, String) Apache log4net™ SDK Documentation
Returns the named logger if it exists.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog Exists(
    string repository,
    string name
)
public static ILog Exists(
    string repository,
    string name
)
Public Shared Function Exists (
    repository As String,
    name As String
) As ILog
Public Shared Function Exists (
    repository As String,
    name As String
) As ILog
public:
static ILog^ Exists(
    String^ repository,
    String^ name
)
public:
static ILog^ Exists(
    String^ repository,
    String^ name
)
Parameters
repository
Type:   Online System String
The repository to lookup in.
name
Type:   Online System String
The fully qualified logger name to look for.
Return Value
Type: ILog

            The logger found, or null if the logger doesn't exist in the specified
            repository.

Remarks

            If the named logger exists (in the specified repository) then it
            returns a reference to the logger, otherwise it returns
            null.

See Also
LogManager Class
LogManager Members
Exists Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetAllRepositories Method

LogManager GetAllRepositories Method Apache log4net™ SDK Documentation
Gets the list of currently defined repositories.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository[] GetAllRepositories()
public static ILoggerRepository[] GetAllRepositories()
Public Shared Function GetAllRepositories As ILoggerRepository()
Public Shared Function GetAllRepositories As ILoggerRepository()
public:
static array<ILoggerRepository^>^ GetAllRepositories()
public:
static array<ILoggerRepository^>^ GetAllRepositories()
Return Value
Type:  ILoggerRepository
An array of all the known ILoggerRepository objects.
Remarks

            Get an array of all the ILoggerRepository objects that have been created.

See Also
LogManager Class
LogManager Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetCurrentLoggers Method

LogManager GetCurrentLoggers Method Apache log4net™ SDK Documentation
Get the currently defined loggers.
Overload List
Name | Description
GetCurrentLoggers | Returns all the currently defined loggers in the default repository.
GetCurrentLoggers(Assembly) | Returns all the currently defined loggers in the specified assembly's repository.
GetCurrentLoggers(String) | Returns all the currently defined loggers in the specified repository.
Back to Top
See Also
LogManager Class
LogManager Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetCurrentLoggers Method

LogManager GetCurrentLoggers Method Apache log4net™ SDK Documentation
Returns all the currently defined loggers in the default repository.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog[] GetCurrentLoggers()
public static ILog[] GetCurrentLoggers()
Public Shared Function GetCurrentLoggers As ILog()
Public Shared Function GetCurrentLoggers As ILog()
public:
static array<ILog^>^ GetCurrentLoggers()
public:
static array<ILog^>^ GetCurrentLoggers()
Return Value
Type:  ILog
All the defined loggers.
Remarks
The root logger is not included in the returned array.
See Also
LogManager Class
LogManager Members
GetCurrentLoggers Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetCurrentLoggers Method (Assembly)

LogManager GetCurrentLoggers Method (Assembly) Apache log4net™ SDK Documentation
Returns all the currently defined loggers in the specified assembly's repository.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog[] GetCurrentLoggers(
    Assembly repositoryAssembly
)
public static ILog[] GetCurrentLoggers(
    Assembly repositoryAssembly
)
Public Shared Function GetCurrentLoggers (
    repositoryAssembly As Assembly
) As ILog()
Public Shared Function GetCurrentLoggers (
    repositoryAssembly As Assembly
) As ILog()
public:
static array<ILog^>^ GetCurrentLoggers(
    Assembly^ repositoryAssembly
)
public:
static array<ILog^>^ GetCurrentLoggers(
    Assembly^ repositoryAssembly
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
Return Value
Type:  ILog
All the defined loggers.
Remarks

            The root logger is not included in the returned array.

See Also
LogManager Class
LogManager Members
GetCurrentLoggers Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetCurrentLoggers Method (String)

LogManager GetCurrentLoggers Method (String) Apache log4net™ SDK Documentation
Returns all the currently defined loggers in the specified repository.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog[] GetCurrentLoggers(
    string repository
)
public static ILog[] GetCurrentLoggers(
    string repository
)
Public Shared Function GetCurrentLoggers (
    repository As String
) As ILog()
Public Shared Function GetCurrentLoggers (
    repository As String
) As ILog()
public:
static array<ILog^>^ GetCurrentLoggers(
    String^ repository
)
public:
static array<ILog^>^ GetCurrentLoggers(
    String^ repository
)
Parameters
repository
Type:   Online System String
The repository to lookup in.
Return Value
Type:  ILog
All the defined loggers.
Remarks

            The root logger is not included in the returned array.

See Also
LogManager Class
LogManager Members
GetCurrentLoggers Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetLogger Method

LogManager GetLogger Method Apache log4net™ SDK Documentation
Get or create a logger.
Overload List
Name | Description
GetLogger(String) | Retrieves or creates a named logger.
GetLogger(Type) | Shorthand for GetLogger(string).
GetLogger(Assembly, String) | Retrieves or creates a named logger.
GetLogger(Assembly, Type) | Shorthand for GetLogger(string).
GetLogger(String, String) | Retrieves or creates a named logger.
GetLogger(String, Type) | Shorthand for GetLogger(string).
Back to Top
See Also
LogManager Class
LogManager Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetLogger Method (String)

LogManager GetLogger Method (String) Apache log4net™ SDK Documentation
Retrieves or creates a named logger.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog GetLogger(
    string name
)
public static ILog GetLogger(
    string name
)
Public Shared Function GetLogger (
    name As String
) As ILog
Public Shared Function GetLogger (
    name As String
) As ILog
public:
static ILog^ GetLogger(
    String^ name
)
public:
static ILog^ GetLogger(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the logger to retrieve.
Return Value
Type: ILog
The logger with the name specified.
Remarks

            Retrieves a logger named as the name
            parameter. If the named logger already exists, then the
            existing instance will be returned. Otherwise, a new instance is
            created.

By default, loggers do not have a set level but inherit
            it from the hierarchy. This is one of the central features of
            log4net.

See Also
LogManager Class
LogManager Members
GetLogger Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetLogger Method (Type)

LogManager GetLogger Method (Type) Apache log4net™ SDK Documentation
Shorthand for GetLogger(string).

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog GetLogger(
    Type type
)
public static ILog GetLogger(
    Type type
)
Public Shared Function GetLogger (
    type As Type
) As ILog
Public Shared Function GetLogger (
    type As Type
) As ILog
public:
static ILog^ GetLogger(
    Type^ type
)
public:
static ILog^ GetLogger(
    Type^ type
)
Parameters
type
Type:   Online System Type
The full name of type will be used as the name of the logger to retrieve.
Return Value
Type: ILog
The logger with the name specified.
Remarks

            Get the logger for the fully qualified name of the type specified.

See Also
LogManager Class
LogManager Members
GetLogger Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetLogger Method (Assembly, String)

LogManager GetLogger Method (Assembly, String) Apache log4net™ SDK Documentation
Retrieves or creates a named logger.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog GetLogger(
    Assembly repositoryAssembly,
    string name
)
public static ILog GetLogger(
    Assembly repositoryAssembly,
    string name
)
Public Shared Function GetLogger (
    repositoryAssembly As Assembly,
    name As String
) As ILog
Public Shared Function GetLogger (
    repositoryAssembly As Assembly,
    name As String
) As ILog
public:
static ILog^ GetLogger(
    Assembly^ repositoryAssembly,
    String^ name
)
public:
static ILog^ GetLogger(
    Assembly^ repositoryAssembly,
    String^ name
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
name
Type:   Online System String
The name of the logger to retrieve.
Return Value
Type: ILog
The logger with the name specified.
Remarks

            Retrieve a logger named as the name
            parameter. If the named logger already exists, then the
            existing instance will be returned. Otherwise, a new instance is
            created.

            By default, loggers do not have a set level but inherit
            it from the hierarchy. This is one of the central features of
            log4net.

See Also
LogManager Class
LogManager Members
GetLogger Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetLogger Method (Assembly, Type)

LogManager GetLogger Method (Assembly, Type) Apache log4net™ SDK Documentation
Shorthand for GetLogger(string).

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog GetLogger(
    Assembly repositoryAssembly,
    Type type
)
public static ILog GetLogger(
    Assembly repositoryAssembly,
    Type type
)
Public Shared Function GetLogger (
    repositoryAssembly As Assembly,
    type As Type
) As ILog
Public Shared Function GetLogger (
    repositoryAssembly As Assembly,
    type As Type
) As ILog
public:
static ILog^ GetLogger(
    Assembly^ repositoryAssembly,
    Type^ type
)
public:
static ILog^ GetLogger(
    Assembly^ repositoryAssembly,
    Type^ type
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
type
Type:   Online System Type
The full name of type will be used as the name of the logger to retrieve.
Return Value
Type: ILog
The logger with the name specified.
Remarks

            Gets the logger for the fully qualified name of the type specified.

See Also
LogManager Class
LogManager Members
GetLogger Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetLogger Method (String, String)

LogManager GetLogger Method (String, String) Apache log4net™ SDK Documentation
Retrieves or creates a named logger.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog GetLogger(
    string repository,
    string name
)
public static ILog GetLogger(
    string repository,
    string name
)
Public Shared Function GetLogger (
    repository As String,
    name As String
) As ILog
Public Shared Function GetLogger (
    repository As String,
    name As String
) As ILog
public:
static ILog^ GetLogger(
    String^ repository,
    String^ name
)
public:
static ILog^ GetLogger(
    String^ repository,
    String^ name
)
Parameters
repository
Type:   Online System String
The repository to lookup in.
name
Type:   Online System String
The name of the logger to retrieve.
Return Value
Type: ILog
The logger with the name specified.
Remarks

            Retrieve a logger named as the name
            parameter. If the named logger already exists, then the
            existing instance will be returned. Otherwise, a new instance is
            created.

            By default, loggers do not have a set level but inherit
            it from the hierarchy. This is one of the central features of
            log4net.

See Also
LogManager Class
LogManager Members
GetLogger Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetLogger Method (String, Type)

LogManager GetLogger Method (String, Type) Apache log4net™ SDK Documentation
Shorthand for GetLogger(string).

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog GetLogger(
    string repository,
    Type type
)
public static ILog GetLogger(
    string repository,
    Type type
)
Public Shared Function GetLogger (
    repository As String,
    type As Type
) As ILog
Public Shared Function GetLogger (
    repository As String,
    type As Type
) As ILog
public:
static ILog^ GetLogger(
    String^ repository,
    Type^ type
)
public:
static ILog^ GetLogger(
    String^ repository,
    Type^ type
)
Parameters
repository
Type:   Online System String
The repository to lookup in.
type
Type:   Online System Type
The full name of type will be used as the name of the logger to retrieve.
Return Value
Type: ILog
The logger with the name specified.
Remarks

            Gets the logger for the fully qualified name of the type specified.

See Also
LogManager Class
LogManager Members
GetLogger Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetLoggerRepository Method

LogManager GetLoggerRepository Method Apache log4net™ SDK Documentation
Get the logger repository.
Overload List
Name | Description
GetLoggerRepository | Obsolete. Returns the default ILoggerRepository instance.
GetLoggerRepository(Assembly) | Obsolete. Returns the default ILoggerRepository instance.
GetLoggerRepository(String) | Obsolete. Returns the default ILoggerRepository instance.
Back to Top
See Also
LogManager Class
LogManager Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetLoggerRepository Method

LogManager GetLoggerRepository Method Apache log4net™ SDK Documentation
Returns the default ILoggerRepository instance.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")]
public static ILoggerRepository GetLoggerRepository()
[ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")]
public static ILoggerRepository GetLoggerRepository()
<ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")>
Public Shared Function GetLoggerRepository As ILoggerRepository
<ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")>
Public Shared Function GetLoggerRepository As ILoggerRepository
public:
[ObsoleteAttribute(L"Use GetRepository instead of GetLoggerRepository")]
static ILoggerRepository^ GetLoggerRepository()
public:
[ObsoleteAttribute(L"Use GetRepository instead of GetLoggerRepository")]
static ILoggerRepository^ GetLoggerRepository()
Return Value
Type: ILoggerRepository
The ILoggerRepository instance for the default repository.
Remarks

            Gets the ILoggerRepository for the repository specified
            by the callers assembly ([M:Assembly.GetCallingAssembly()]).

See Also
LogManager Class
LogManager Members
GetLoggerRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetLoggerRepository Method (Assembly)

LogManager GetLoggerRepository Method (Assembly) Apache log4net™ SDK Documentation
Returns the default ILoggerRepository instance.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")]
public static ILoggerRepository GetLoggerRepository(
    Assembly repositoryAssembly
)
[ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")]
public static ILoggerRepository GetLoggerRepository(
    Assembly repositoryAssembly
)
<ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")>
Public Shared Function GetLoggerRepository (
    repositoryAssembly As Assembly
) As ILoggerRepository
<ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")>
Public Shared Function GetLoggerRepository (
    repositoryAssembly As Assembly
) As ILoggerRepository
public:
[ObsoleteAttribute(L"Use GetRepository instead of GetLoggerRepository")]
static ILoggerRepository^ GetLoggerRepository(
    Assembly^ repositoryAssembly
)
public:
[ObsoleteAttribute(L"Use GetRepository instead of GetLoggerRepository")]
static ILoggerRepository^ GetLoggerRepository(
    Assembly^ repositoryAssembly
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
Return Value
Type: ILoggerRepository
The default ILoggerRepository instance.
Remarks

            Gets the ILoggerRepository for the repository specified
            by the repositoryAssembly argument.

See Also
LogManager Class
LogManager Members
GetLoggerRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetLoggerRepository Method (String)

LogManager GetLoggerRepository Method (String) Apache log4net™ SDK Documentation
Returns the default ILoggerRepository instance.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")]
public static ILoggerRepository GetLoggerRepository(
    string repository
)
[ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")]
public static ILoggerRepository GetLoggerRepository(
    string repository
)
<ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")>
Public Shared Function GetLoggerRepository (
    repository As String
) As ILoggerRepository
<ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")>
Public Shared Function GetLoggerRepository (
    repository As String
) As ILoggerRepository
public:
[ObsoleteAttribute(L"Use GetRepository instead of GetLoggerRepository")]
static ILoggerRepository^ GetLoggerRepository(
    String^ repository
)
public:
[ObsoleteAttribute(L"Use GetRepository instead of GetLoggerRepository")]
static ILoggerRepository^ GetLoggerRepository(
    String^ repository
)
Parameters
repository
Type:   Online System String
The repository to lookup in.
Return Value
Type: ILoggerRepository
The default ILoggerRepository instance.
Remarks

            Gets the ILoggerRepository for the repository specified
            by the repository argument.

See Also
LogManager Class
LogManager Members
GetLoggerRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetRepository Method

LogManager GetRepository Method Apache log4net™ SDK Documentation
Get a logger repository.
Overload List
Name | Description
GetRepository | Returns the default ILoggerRepository instance.
GetRepository(Assembly) | Returns the default ILoggerRepository instance.
GetRepository(String) | Returns the default ILoggerRepository instance.
Back to Top
See Also
LogManager Class
LogManager Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetRepository Method

LogManager GetRepository Method Apache log4net™ SDK Documentation
Returns the default ILoggerRepository instance.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository GetRepository()
public static ILoggerRepository GetRepository()
Public Shared Function GetRepository As ILoggerRepository
Public Shared Function GetRepository As ILoggerRepository
public:
static ILoggerRepository^ GetRepository()
public:
static ILoggerRepository^ GetRepository()
Return Value
Type: ILoggerRepository
The ILoggerRepository instance for the default repository.
Remarks

            Gets the ILoggerRepository for the repository specified
            by the callers assembly ([M:Assembly.GetCallingAssembly()]).

See Also
LogManager Class
LogManager Members
GetRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetRepository Method (Assembly)

LogManager GetRepository Method (Assembly) Apache log4net™ SDK Documentation
Returns the default ILoggerRepository instance.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository GetRepository(
    Assembly repositoryAssembly
)
public static ILoggerRepository GetRepository(
    Assembly repositoryAssembly
)
Public Shared Function GetRepository (
    repositoryAssembly As Assembly
) As ILoggerRepository
Public Shared Function GetRepository (
    repositoryAssembly As Assembly
) As ILoggerRepository
public:
static ILoggerRepository^ GetRepository(
    Assembly^ repositoryAssembly
)
public:
static ILoggerRepository^ GetRepository(
    Assembly^ repositoryAssembly
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
Return Value
Type: ILoggerRepository
The default ILoggerRepository instance.
Remarks

            Gets the ILoggerRepository for the repository specified
            by the repositoryAssembly argument.

See Also
LogManager Class
LogManager Members
GetRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.GetRepository Method (String)

LogManager GetRepository Method (String) Apache log4net™ SDK Documentation
Returns the default ILoggerRepository instance.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository GetRepository(
    string repository
)
public static ILoggerRepository GetRepository(
    string repository
)
Public Shared Function GetRepository (
    repository As String
) As ILoggerRepository
Public Shared Function GetRepository (
    repository As String
) As ILoggerRepository
public:
static ILoggerRepository^ GetRepository(
    String^ repository
)
public:
static ILoggerRepository^ GetRepository(
    String^ repository
)
Parameters
repository
Type:   Online System String
The repository to lookup in.
Return Value
Type: ILoggerRepository
The default ILoggerRepository instance.
Remarks

            Gets the ILoggerRepository for the repository specified
            by the repository argument.

See Also
LogManager Class
LogManager Members
GetRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.ResetConfiguration Method

LogManager ResetConfiguration Method Apache log4net™ SDK Documentation
Reset the configuration of a repository
Overload List
Name | Description
ResetConfiguration | Resets all values contained in this repository instance to their defaults.
ResetConfiguration(Assembly) | Resets all values contained in this repository instance to their defaults.
ResetConfiguration(String) | Resets all values contained in this repository instance to their defaults.
Back to Top
See Also
LogManager Class
LogManager Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.ResetConfiguration Method

LogManager ResetConfiguration Method Apache log4net™ SDK Documentation
Resets all values contained in this repository instance to their defaults.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ResetConfiguration()
public static void ResetConfiguration()
Public Shared Sub ResetConfiguration
Public Shared Sub ResetConfiguration
public:
static void ResetConfiguration()
public:
static void ResetConfiguration()
Remarks

            Resets all values contained in the repository instance to their
            defaults.  This removes all appenders from all loggers, sets
            the level of all non-root loggers to null,
            sets their additivity flag to true and sets the level
            of the root logger to Debug. Moreover,
            message disabling is set to its default "off" value.

See Also
LogManager Class
LogManager Members
ResetConfiguration Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.ResetConfiguration Method (Assembly)

LogManager ResetConfiguration Method (Assembly) Apache log4net™ SDK Documentation
Resets all values contained in this repository instance to their defaults.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ResetConfiguration(
    Assembly repositoryAssembly
)
public static void ResetConfiguration(
    Assembly repositoryAssembly
)
Public Shared Sub ResetConfiguration (
    repositoryAssembly As Assembly
)
Public Shared Sub ResetConfiguration (
    repositoryAssembly As Assembly
)
public:
static void ResetConfiguration(
    Assembly^ repositoryAssembly
)
public:
static void ResetConfiguration(
    Assembly^ repositoryAssembly
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository to reset.
Remarks

            Reset all values contained in the repository instance to their
            defaults.  This removes all appenders from all loggers, sets
            the level of all non-root loggers to null,
            sets their additivity flag to true and sets the level
            of the root logger to Debug. Moreover,
            message disabling is set to its default "off" value.

See Also
LogManager Class
LogManager Members
ResetConfiguration Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.ResetConfiguration Method (String)

LogManager ResetConfiguration Method (String) Apache log4net™ SDK Documentation
Resets all values contained in this repository instance to their defaults.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ResetConfiguration(
    string repository
)
public static void ResetConfiguration(
    string repository
)
Public Shared Sub ResetConfiguration (
    repository As String
)
Public Shared Sub ResetConfiguration (
    repository As String
)
public:
static void ResetConfiguration(
    String^ repository
)
public:
static void ResetConfiguration(
    String^ repository
)
Parameters
repository
Type:   Online System String
The repository to reset.
Remarks

            Reset all values contained in the repository instance to their
            defaults.  This removes all appenders from all loggers, sets
            the level of all non-root loggers to null,
            sets their additivity flag to true and sets the level
            of the root logger to Debug. Moreover,
            message disabling is set to its default "off" value.

See Also
LogManager Class
LogManager Members
ResetConfiguration Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.Shutdown Method

LogManager Shutdown Method Apache log4net™ SDK Documentation
Shuts down the log4net system.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Shutdown()
public static void Shutdown()
Public Shared Sub Shutdown
Public Shared Sub Shutdown
public:
static void Shutdown()
public:
static void Shutdown()
Remarks

            Calling this method will safely close and remove all
            appenders in all the loggers including root contained in all the
            default repositories.

            Some appenders need to be closed before the application exists.
            Otherwise, pending logging events might be lost.

The shutdown method is careful to close nested
            appenders before closing regular appenders. This is allows
            configurations where a regular appender is attached to a logger
            and again to a nested appender.

See Also
LogManager Class
LogManager Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.ShutdownRepository Method

LogManager ShutdownRepository Method Apache log4net™ SDK Documentation
Shutdown a logger repository.
Overload List
Name | Description
ShutdownRepository | Shuts down the default repository.
ShutdownRepository(Assembly) | Shuts down the repository specified.
ShutdownRepository(String) | Shuts down the repository for the repository specified.
Back to Top
See Also
LogManager Class
LogManager Members
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.ShutdownRepository Method

LogManager ShutdownRepository Method Apache log4net™ SDK Documentation
Shuts down the default repository.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ShutdownRepository()
public static void ShutdownRepository()
Public Shared Sub ShutdownRepository
Public Shared Sub ShutdownRepository
public:
static void ShutdownRepository()
public:
static void ShutdownRepository()
Remarks

            Calling this method will safely close and remove all
            appenders in all the loggers including root contained in the
            default repository.

Some appenders need to be closed before the application exists.
            Otherwise, pending logging events might be lost.

The shutdown method is careful to close nested
            appenders before closing regular appenders. This is allows
            configurations where a regular appender is attached to a logger
            and again to a nested appender.

See Also
LogManager Class
LogManager Members
ShutdownRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.ShutdownRepository Method (Assembly)

LogManager ShutdownRepository Method (Assembly) Apache log4net™ SDK Documentation
Shuts down the repository specified.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ShutdownRepository(
    Assembly repositoryAssembly
)
public static void ShutdownRepository(
    Assembly repositoryAssembly
)
Public Shared Sub ShutdownRepository (
    repositoryAssembly As Assembly
)
Public Shared Sub ShutdownRepository (
    repositoryAssembly As Assembly
)
public:
static void ShutdownRepository(
    Assembly^ repositoryAssembly
)
public:
static void ShutdownRepository(
    Assembly^ repositoryAssembly
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
Remarks

            Calling this method will safely close and remove all
            appenders in all the loggers including root contained in the
            repository. The repository is looked up using
            the repositoryAssembly specified.

            Some appenders need to be closed before the application exists.
            Otherwise, pending logging events might be lost.

            The shutdown method is careful to close nested
            appenders before closing regular appenders. This is allows
            configurations where a regular appender is attached to a logger
            and again to a nested appender.

See Also
LogManager Class
LogManager Members
ShutdownRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogManager.ShutdownRepository Method (String)

LogManager ShutdownRepository Method (String) Apache log4net™ SDK Documentation
Shuts down the repository for the repository specified.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ShutdownRepository(
    string repository
)
public static void ShutdownRepository(
    string repository
)
Public Shared Sub ShutdownRepository (
    repository As String
)
Public Shared Sub ShutdownRepository (
    repository As String
)
public:
static void ShutdownRepository(
    String^ repository
)
public:
static void ShutdownRepository(
    String^ repository
)
Parameters
repository
Type:   Online System String
The repository to shutdown.
Remarks

            Calling this method will safely close and remove all
            appenders in all the loggers including root contained in the
            repository specified.

            Some appenders need to be closed before the application exists.
            Otherwise, pending logging events might be lost.

The shutdown method is careful to close nested
            appenders before closing regular appenders. This is allows
            configurations where a regular appender is attached to a logger
            and again to a nested appender.

See Also
LogManager Class
LogManager Members
ShutdownRepository Overload
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MDC Class

MDC Class Apache log4net™ SDK Documentation
Implementation of Mapped Diagnostic Contexts.
Inheritance Hierarchy
Online System Object
log4net MDC

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MDC
public sealed class MDC
Public NotInheritable Class MDC
Public NotInheritable Class MDC
public ref class MDC sealed
public ref class MDC sealed
Remarks
  Note  Note

            The MDC is deprecated and has been replaced by the Properties.
            The current MDC implementation forwards to the ThreadContext.Properties.

            The MDC class is similar to the NDC class except that it is
            based on a map instead of a stack. It provides mapped
            diagnostic contexts. A Mapped Diagnostic Context, or
            MDC in short, is an instrument for distinguishing interleaved log
            output from different sources. Log output is typically interleaved
            when a server handles multiple clients near-simultaneously.

            The MDC is managed on a per thread basis.

Thread Safety
Static members of this type are safe for multi-threaded operations. Instance members of this type are safe for multi-threaded operations.
See Also
MDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MDC Members

MDC Members Apache log4net™ SDK Documentation
The MDC type exposes the following members.
Methods
 | Name | Description
 | Clear | Clear all entries in the MDC
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | Get | Gets the context value identified by the key parameter.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Remove | Removes the key value mapping for the key specified.
 | Set | Add an entry to the MDC
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MDC Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MDC Methods

MDC Methods Apache log4net™ SDK Documentation
The MDC type exposes the following members.
Methods
 | Name | Description
 | Clear | Clear all entries in the MDC
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | Get | Gets the context value identified by the key parameter.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Remove | Removes the key value mapping for the key specified.
 | Set | Add an entry to the MDC
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MDC Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MDC.Clear Method

MDC Clear Method Apache log4net™ SDK Documentation
Clear all entries in the MDC

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Clear()
public static void Clear()
Public Shared Sub Clear
Public Shared Sub Clear
public:
static void Clear()
public:
static void Clear()
Remarks
  Note  Note

            The MDC is deprecated and has been replaced by the Properties.
            The current MDC implementation forwards to the ThreadContext.Properties.

            Remove all the entries from this thread's MDC

See Also
MDC Class
MDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MDC.Get Method

MDC Get Method Apache log4net™ SDK Documentation
Gets the context value identified by the key parameter.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Get(
    string key
)
public static string Get(
    string key
)
Public Shared Function Get (
    key As String
) As String
Public Shared Function Get (
    key As String
) As String
public:
static String^ Get(
    String^ key
)
public:
static String^ Get(
    String^ key
)
Parameters
key
Type:   Online System String
The key to lookup in the MDC.
Return Value
Type:   Online String
The string value held for the key, or a null reference if no corresponding value is found.
Remarks
  Note  Note

            The MDC is deprecated and has been replaced by the Properties.
            The current MDC implementation forwards to the ThreadContext.Properties.

            If the key parameter does not look up to a
            previously defined context then null will be returned.

See Also
MDC Class
MDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MDC.Remove Method

MDC Remove Method Apache log4net™ SDK Documentation
Removes the key value mapping for the key specified.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Remove(
    string key
)
public static void Remove(
    string key
)
Public Shared Sub Remove (
    key As String
)
Public Shared Sub Remove (
    key As String
)
public:
static void Remove(
    String^ key
)
public:
static void Remove(
    String^ key
)
Parameters
key
Type:   Online System String
The key to remove.
Remarks
  Note  Note

            The MDC is deprecated and has been replaced by the Properties.
            The current MDC implementation forwards to the ThreadContext.Properties.

            Remove the specified entry from this thread's MDC

See Also
MDC Class
MDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MDC.Set Method

MDC Set Method Apache log4net™ SDK Documentation
Add an entry to the MDC

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Set(
    string key,
    string value
)
public static void Set(
    string key,
    string value
)
Public Shared Sub Set (
    key As String,
    value As String
)
Public Shared Sub Set (
    key As String,
    value As String
)
public:
static void Set(
    String^ key,
    String^ value
)
public:
static void Set(
    String^ key,
    String^ value
)
Parameters
key
Type:   Online System String
The key to store the value under.
value
Type:   Online System String
The value to store.
Remarks
  Note  Note

            The MDC is deprecated and has been replaced by the Properties.
            The current MDC implementation forwards to the ThreadContext.Properties.

            Puts a context value (the value parameter) as identified
            with the key parameter into the current thread's
            context map.

            If a value is already defined for the key
            specified then the value will be replaced. If the value
            is specified as null then the key value mapping will be removed.

See Also
MDC Class
MDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NDC Class

NDC Class Apache log4net™ SDK Documentation
Implementation of Nested Diagnostic Contexts.
Inheritance Hierarchy
Online System Object
log4net NDC

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NDC
public sealed class NDC
Public NotInheritable Class NDC
Public NotInheritable Class NDC
public ref class NDC sealed
public ref class NDC sealed
Remarks
  Note  Note

            The NDC is deprecated and has been replaced by the Stacks.
            The current NDC implementation forwards to the ThreadContext.Stacks["NDC"].

            A Nested Diagnostic Context, or NDC in short, is an instrument
            to distinguish interleaved log output from different sources. Log
            output is typically interleaved when a server handles multiple
            clients near-simultaneously.

            Interleaved log output can still be meaningful if each log entry
            from different contexts had a distinctive stamp. This is where NDCs
            come into play.

            Note that NDCs are managed on a per thread basis. The NDC class
            is made up of static methods that operate on the context of the
            calling thread.

Examples
How to push a message into the context

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
using(NDC.Push("my context message"))
{
    ... all log calls will have 'my context message' included ...

} // at the end of the using block the message is automatically removed
using(NDC.Push("my context message"))
{
    ... all log calls will have 'my context message' included ...

} // at the end of the using block the message is automatically removed
Thread Safety
Static members of this type are safe for multi-threaded operations. Instance members of this type are safe for multi-threaded operations.
See Also
NDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NDC Members

NDC Members Apache log4net™ SDK Documentation
The NDC type exposes the following members.
Methods
 | Name | Description
 | Clear | Clears all the contextual information held on the current thread.
 | CloneStack | Creates a clone of the stack of context information.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Inherit | Inherits the contextual information from another thread.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Pop | Removes the top context from the stack.
 | Push | Pushes a new context message.
 | Remove | Removes the context information for this thread. It is not required to call this method.
 | SetMaxDepth | Forces the stack depth to be at most maxDepth.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
Name | Description
Depth | Gets the current context depth.
Back to Top
See Also
NDC Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NDC Methods

NDC Methods Apache log4net™ SDK Documentation
The NDC type exposes the following members.
Methods
 | Name | Description
 | Clear | Clears all the contextual information held on the current thread.
 | CloneStack | Creates a clone of the stack of context information.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Inherit | Inherits the contextual information from another thread.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Pop | Removes the top context from the stack.
 | Push | Pushes a new context message.
 | Remove | Removes the context information for this thread. It is not required to call this method.
 | SetMaxDepth | Forces the stack depth to be at most maxDepth.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NDC Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NDC.Clear Method

NDC Clear Method Apache log4net™ SDK Documentation
Clears all the contextual information held on the current thread.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Clear()
public static void Clear()
Public Shared Sub Clear
Public Shared Sub Clear
public:
static void Clear()
public:
static void Clear()
Remarks
  Note  Note

            The NDC is deprecated and has been replaced by the Stacks.
            The current NDC implementation forwards to the ThreadContext.Stacks["NDC"].

            Clears the stack of NDC data held on the current thread.

See Also
NDC Class
NDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NDC.CloneStack Method

NDC CloneStack Method Apache log4net™ SDK Documentation
Creates a clone of the stack of context information.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Stack CloneStack()
public static Stack CloneStack()
Public Shared Function CloneStack As Stack
Public Shared Function CloneStack As Stack
public:
static Stack^ CloneStack()
public:
static Stack^ CloneStack()
Return Value
Type:   Online Stack
A clone of the context info for this thread.
Remarks
  Note  Note

            The NDC is deprecated and has been replaced by the Stacks.
            The current NDC implementation forwards to the ThreadContext.Stacks["NDC"].

            The results of this method can be passed to the Inherit(Stack)
            method to allow child threads to inherit the context of their
            parent thread.

See Also
NDC Class
NDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NDC.Inherit Method

NDC Inherit Method Apache log4net™ SDK Documentation
Inherits the contextual information from another thread.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Inherit(
    Stack stack
)
public static void Inherit(
    Stack stack
)
Public Shared Sub Inherit (
    stack As Stack
)
Public Shared Sub Inherit (
    stack As Stack
)
public:
static void Inherit(
    Stack^ stack
)
public:
static void Inherit(
    Stack^ stack
)
Parameters
stack
Type:   Online System.Collections Stack
The context stack to inherit.
Remarks
  Note  Note

            The NDC is deprecated and has been replaced by the Stacks.
            The current NDC implementation forwards to the ThreadContext.Stacks["NDC"].

            This thread will use the context information from the stack
            supplied. This can be used to initialize child threads with
            the same contextual information as their parent threads. These
            contexts will NOT be shared. Any further contexts that
            are pushed onto the stack will not be visible to the other.
            Call CloneStack  to obtain a stack to pass to
            this method.

See Also
NDC Class
NDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NDC.Pop Method

NDC Pop Method Apache log4net™ SDK Documentation
Removes the top context from the stack.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Pop()
public static string Pop()
Public Shared Function Pop As String
Public Shared Function Pop As String
public:
static String^ Pop()
public:
static String^ Pop()
Return Value
Type:   Online String

            The message in the context that was removed from the top
            of the stack.

Remarks
  Note  Note

            The NDC is deprecated and has been replaced by the Stacks.
            The current NDC implementation forwards to the ThreadContext.Stacks["NDC"].

            Remove the top context from the stack, and return
            it to the caller. If the stack is empty then an
            empty string (not null) is returned.

See Also
NDC Class
NDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NDC.Push Method

NDC Push Method Apache log4net™ SDK Documentation
Pushes a new context message.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IDisposable Push(
    string message
)
public static IDisposable Push(
    string message
)
Public Shared Function Push (
    message As String
) As IDisposable
Public Shared Function Push (
    message As String
) As IDisposable
public:
static IDisposable^ Push(
    String^ message
)
public:
static IDisposable^ Push(
    String^ message
)
Parameters
message
Type:   Online System String
The new context message.
Return Value
Type:   Online IDisposable

            An   Online IDisposable that can be used to clean up
            the context stack.

Remarks
  Note  Note

            The NDC is deprecated and has been replaced by the Stacks.
            The current NDC implementation forwards to the ThreadContext.Stacks["NDC"].

            Pushes a new context onto the context stack. An   Online IDisposable
            is returned that can be used to clean up the context stack. This
            can be easily combined with the using keyword to scope the
            context.

Examples
Simple example of using the Push method with the using keyword.

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
using(log4net.NDC.Push("NDC_Message"))
{
    log.Warn("This should have an NDC message");
}
using(log4net.NDC.Push("NDC_Message"))
{
    log.Warn("This should have an NDC message");
}
See Also
NDC Class
NDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NDC.Remove Method

NDC Remove Method Apache log4net™ SDK Documentation
Removes the context information for this thread. It is not required to call this method.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Remove()
public static void Remove()
Public Shared Sub Remove
Public Shared Sub Remove
public:
static void Remove()
public:
static void Remove()
Remarks
  Note  Note

            The NDC is deprecated and has been replaced by the Stacks.
            The current NDC implementation forwards to the ThreadContext.Stacks["NDC"].

            This method is not implemented.

See Also
NDC Class
NDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NDC.SetMaxDepth Method

NDC SetMaxDepth Method Apache log4net™ SDK Documentation
Forces the stack depth to be at most maxDepth.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void SetMaxDepth(
    int maxDepth
)
public static void SetMaxDepth(
    int maxDepth
)
Public Shared Sub SetMaxDepth (
    maxDepth As Integer
)
Public Shared Sub SetMaxDepth (
    maxDepth As Integer
)
public:
static void SetMaxDepth(
    int maxDepth
)
public:
static void SetMaxDepth(
    int maxDepth
)
Parameters
maxDepth
Type:   Online System Int32
The maximum depth of the stack
Remarks
  Note  Note

            The NDC is deprecated and has been replaced by the Stacks.
            The current NDC implementation forwards to the ThreadContext.Stacks["NDC"].

            Forces the stack depth to be at most maxDepth.
            This may truncate the head of the stack. This only affects the
            stack in the current thread. Also it does not prevent it from
            growing, it only sets the maximum depth at the time of the
            call. This can be used to return to a known context depth.

See Also
NDC Class
NDC Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NDC Properties

NDC Properties Apache log4net™ SDK Documentation
The NDC type exposes the following members.
Properties
Name | Description
Depth | Gets the current context depth.
Back to Top
See Also
NDC Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NDC.Depth Property

NDC Depth Property Apache log4net™ SDK Documentation
Gets the current context depth.

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Depth { get; }
public static int Depth { get; }
Public Shared ReadOnly Property Depth As Integer
    Get
Public Shared ReadOnly Property Depth As Integer
    Get
public:
static property int Depth {
    int get ();
}
public:
static property int Depth {
    int get ();
}
Property Value
Type:   Online Int32
The current context depth.
Remarks
  Note  Note

            The NDC is deprecated and has been replaced by the Stacks.
            The current NDC implementation forwards to the ThreadContext.Stacks["NDC"].

            The number of context values pushed onto the context stack.

            Used to record the current depth of the context. This can then
            be restored using the SetMaxDepth(Int32) method.

See Also
NDC Class
NDC Members
log4net Namespace
NDC SetMaxDepth(Int32)
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContext Class

ThreadContext Class Apache log4net™ SDK Documentation
The log4net Thread Context.
Inheritance Hierarchy
Online System Object
log4net ThreadContext

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ThreadContext
public sealed class ThreadContext
Public NotInheritable Class ThreadContext
Public NotInheritable Class ThreadContext
public ref class ThreadContext sealed
public ref class ThreadContext sealed
Remarks

            The ThreadContext provides a location for thread specific debugging
            information to be stored.
            The ThreadContext properties override any GlobalContext
            properties with the same name.

            The thread context has a properties map and a stack.
            The properties and stack can
            be included in the output of log messages. The PatternLayout
            supports selecting and outputting these properties.

            The Thread Context provides a diagnostic context for the current thread.
            This is an instrument for distinguishing interleaved log
            output from different sources. Log output is typically interleaved
            when a server handles multiple clients near-simultaneously.

            The Thread Context is managed on a per thread basis.

Examples
Example of using the thread context properties to store a username.

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ThreadContext.Properties["user"] = userName;
log.Info("This log message has a ThreadContext Property called 'user'");
ThreadContext.Properties["user"] = userName;
log.Info("This log message has a ThreadContext Property called 'user'");
Examples
Example of how to push a message into the context stack

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
using(ThreadContext.Stacks["NDC"].Push("my context message"))
{
    log.Info("This log message has a ThreadContext Stack message that includes 'my context message'");

} // at the end of the using block the message is automatically popped
using(ThreadContext.Stacks["NDC"].Push("my context message"))
{
    log.Info("This log message has a ThreadContext Stack message that includes 'my context message'");

} // at the end of the using block the message is automatically popped
Thread Safety
Static members of this type are safe for multi-threaded operations. Instance members of this type are safe for multi-threaded operations.
See Also
ThreadContext Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContext Members

ThreadContext Members Apache log4net™ SDK Documentation
The ThreadContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
Name | Description
Properties | The thread properties map
Stacks | The thread stacks
Back to Top
See Also
ThreadContext Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContext Methods

ThreadContext Methods Apache log4net™ SDK Documentation
The ThreadContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ThreadContext Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContext Properties

ThreadContext Properties Apache log4net™ SDK Documentation
The ThreadContext type exposes the following members.
Properties
Name | Description
Properties | The thread properties map
Stacks | The thread stacks
Back to Top
See Also
ThreadContext Class
log4net Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContext.Properties Property

ThreadContext Properties Property Apache log4net™ SDK Documentation
The thread properties map

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ThreadContextProperties Properties { get; }
public static ThreadContextProperties Properties { get; }
Public Shared ReadOnly Property Properties As ThreadContextProperties
    Get
Public Shared ReadOnly Property Properties As ThreadContextProperties
    Get
public:
static property ThreadContextProperties^ Properties {
    ThreadContextProperties^ get ();
}
public:
static property ThreadContextProperties^ Properties {
    ThreadContextProperties^ get ();
}
Property Value
Type: ThreadContextProperties

            The thread properties map

Remarks

            The ThreadContext properties override any GlobalContext
            properties with the same name.

See Also
ThreadContext Class
ThreadContext Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContext.Stacks Property

ThreadContext Stacks Property Apache log4net™ SDK Documentation
The thread stacks

Namespace: log4net
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ThreadContextStacks Stacks { get; }
public static ThreadContextStacks Stacks { get; }
Public Shared ReadOnly Property Stacks As ThreadContextStacks
    Get
Public Shared ReadOnly Property Stacks As ThreadContextStacks
    Get
public:
static property ThreadContextStacks^ Stacks {
    ThreadContextStacks^ get ();
}
public:
static property ThreadContextStacks^ Stacks {
    ThreadContextStacks^ get ();
}
Property Value
Type: ThreadContextStacks

            stack map

Remarks

            The thread local stacks.

See Also
ThreadContext Class
ThreadContext Members
log4net Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.Appender Namespace

log4net.Appender Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | AdoNetAppender | Appender that logs to a database.
Public class | AdoNetAppenderParameter | Parameter type used by the AdoNetAppender.
Public class | AnsiColorTerminalAppender | Appends logging events to the terminal using ANSI color escape sequences.
Public class | AnsiColorTerminalAppender LevelColors | A class to act as a mapping between the level that a logging call is made at and the color it should be displayed as.
Public class | AppenderCollection | A strongly-typed collection of IAppender objects.
Public class | AppenderSkeleton | Abstract base class implementation of IAppender.
Public class | AspNetTraceAppender | Appends log events to the ASP.NET Online TraceContext system.
Public class | BufferingAppenderSkeleton | Abstract base class implementation of IAppender that buffers events in a fixed size buffer.
Public class | BufferingForwardingAppender | Buffers events and then forwards them to attached appenders.
Public class | ColoredConsoleAppender | Appends logging events to the console.
Public class | ColoredConsoleAppender LevelColors | A class to act as a mapping between the level that a logging call is made at and the color it should be displayed as.
Public class | ConsoleAppender | Appends logging events to the console.
Public class | DebugAppender | Appends log events to the Online Debug system.
Public class | EventLogAppender | Writes events to the system event log.
Public class | EventLogAppender Level2EventLogEntryType | A class to act as a mapping between the level that a logging call is made at and the color it should be displayed as.
Public class | FileAppender | Appends logging events to a file.
Public class | FileAppender ExclusiveLock | Hold an exclusive lock on the output file
Public class | FileAppender InterProcessLock | Provides cross-process file locking.
Public class | FileAppender LockingModelBase | Locking model base class
Public class | FileAppender MinimalLock | Acquires the file lock for each write
Public class | ForwardingAppender | This appender forwards logging events to attached appenders.
Public class | LocalSyslogAppender | Logs events to a local syslog service.
Public class | LocalSyslogAppender LevelSeverity | A class to act as a mapping between the level that a logging call is made at and the syslog severity that is should be logged at.
Public class | ManagedColoredConsoleAppender | Appends colorful logging events to the console, using the .NET 2 built-in capabilities.
Public class | ManagedColoredConsoleAppender LevelColors | A class to act as a mapping between the level that a logging call is made at and the color it should be displayed as.
Public class | MemoryAppender | Stores logging events in an array.
Public class | NetSendAppender | Logs entries by sending network messages using the NetMessageBufferSend(String, String, String, String, Int32) native function.
Public class | OutputDebugStringAppender | Appends log events to the OutputDebugString system.
Public class | RemoteSyslogAppender | Logs events to a remote syslog daemon.
Public class | RemoteSyslogAppender LevelSeverity | A class to act as a mapping between the level that a logging call is made at and the syslog severity that is should be logged at.
Public class | RemotingAppender | Delivers logging events to a remote logging sink.
Public class | RollingFileAppender | Appender that rolls log files based on size or date or both.
Public class | SmtpAppender | Send an e-mail when a specific logging event occurs, typically on errors or fatal errors.
Public class | SmtpPickupDirAppender | Send an email when a specific logging event occurs, typically on errors or fatal errors. Rather than sending via smtp it writes a file into the directory specified by PickupDir. This allows services such as the IIS SMTP agent to manage sending the messages.
Public class | TelnetAppender | Appender that allows clients to connect via Telnet to receive log messages
Protected class | TelnetAppender SocketHandler | Helper class to manage connected clients
Protected class | TelnetAppender SocketHandler SocketClient | Class that represents a client connected to this handler
Public class | TextWriterAppender | Sends logging events to a Online TextWriter.
Public class | TraceAppender | Appends log events to the Online Trace system.
Public class | UdpAppender | Sends logging events as connectionless UDP datagrams to a remote host or a multicast group using an Online UdpClient.
Interfaces
 | Interface | Description
Public interface | IAppender | Implement this interface for your own strategies for printing log statements.
Public interface | IBulkAppender | Interface for appenders that support bulk logging.
Public interface | RemotingAppender IRemoteLoggingSink | Interface used to deliver LoggingEvent objects to a remote sink.
Public interface | RollingFileAppender IDateTime | This interface is used to supply Date/Time information to the RollingFileAppender.
Enumerations
 | Enumeration | Description
Public enumeration | AnsiColorTerminalAppender AnsiAttributes | The enum of possible display attributes
Public enumeration | AnsiColorTerminalAppender AnsiColor | The enum of possible foreground or background color values for use with the color mapping method
Public enumeration | ColoredConsoleAppender Colors | The enum of possible color values for use with the color mapping method
Public enumeration | LocalSyslogAppender SyslogFacility | syslog facilities
Public enumeration | LocalSyslogAppender SyslogSeverity | syslog severities
Public enumeration | RemoteSyslogAppender SyslogFacility | syslog facilities
Public enumeration | RemoteSyslogAppender SyslogSeverity | syslog severities
Public enumeration | RollingFileAppender RollingMode | Style of rolling to use
Protected enumeration | RollingFileAppender RollPoint | The code assumes that the following 'time' constants are in a increasing sequence.
Public enumeration | SmtpAppender SmtpAuthentication | Values for the Authentication property.

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender Class

AdoNetAppender Class Apache log4net™ SDK Documentation
Appender that logs to a database.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender BufferingAppenderSkeleton
log4net.Appender AdoNetAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AdoNetAppender : BufferingAppenderSkeleton
public class AdoNetAppender : BufferingAppenderSkeleton
Public Class AdoNetAppender
    Inherits BufferingAppenderSkeleton
Public Class AdoNetAppender
    Inherits BufferingAppenderSkeleton
public ref class AdoNetAppender : public BufferingAppenderSkeleton
public ref class AdoNetAppender : public BufferingAppenderSkeleton
Remarks
AdoNetAppender appends logging events to a table within a
            database. The appender can be configured to specify the connection
            string by setting the ConnectionString property.
            The connection type (provider) can be specified by setting the ConnectionType
            property. For more information on database connection strings for
            your specific database see   Online http://www.connectionstrings.com/.

            Records are written into the database either using a prepared
            statement or a stored procedure. The CommandType property
            is set to   Online Text (System.Data.CommandType.Text) to specify a prepared statement
            or to   Online StoredProcedure (System.Data.CommandType.StoredProcedure) to specify a stored
            procedure.

            The prepared statement text or the name of the stored procedure
            must be set in the CommandText property.

            The prepared statement or stored procedure can take a number
            of parameters. Parameters are added using the AddParameter(AdoNetAppenderParameter)
            method. This adds a single AdoNetAppenderParameter to the
            ordered list of parameters. The AdoNetAppenderParameter
            type may be subclassed if required to provide database specific
            functionality. The AdoNetAppenderParameter specifies
            the parameter name, database type, size, and how the value should
            be generated using a ILayout.

Examples

            An example of a SQL Server table that could be logged to:

SQL
View Colorized Copy to Clipboard Print
CREATE TABLE [dbo].[Log] (
  [ID] [int] IDENTITY (1, 1) NOT NULL ,
  [Date] [datetime] NOT NULL ,
  [Thread] [varchar] (255) NOT NULL ,
  [Level] [varchar] (20) NOT NULL ,
  [Logger] [varchar] (255) NOT NULL ,
  [Message] [varchar] (4000) NOT NULL
) ON [PRIMARY]
CREATE TABLE [dbo].[Log] (
  [ID] [int] IDENTITY (1, 1) NOT NULL ,
  [Date] [datetime] NOT NULL ,
  [Thread] [varchar] (255) NOT NULL ,
  [Level] [varchar] (20) NOT NULL ,
  [Logger] [varchar] (255) NOT NULL ,
  [Message] [varchar] (4000) NOT NULL
) ON [PRIMARY]
Examples

            An example configuration to log to the above table:

XML
View Colorized Copy to Clipboard Print
<appender name="AdoNetAppender_SqlServer" type="log4net.Appender.AdoNetAppender"><connectionType value="System.Data.SqlClient.SqlConnection, System.Data, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" /><connectionString value="data source=SQLSVR;initial catalog=test_log4net;integrated security=false;persist security info=True;User ID=sa;Password=sa" /><commandText value="INSERT INTO Log ([Date],[Thread],[Level],[Logger],[Message]) VALUES (@log_date, @thread, @log_level, @logger, @message)" /><parameter><parameterName value="@log_date" /><dbType value="DateTime" /><layout type="log4net.Layout.PatternLayout" value="%date{yyyy'-'MM'-'dd HH':'mm':'ss'.'fff}" /></parameter><parameter><parameterName value="@thread" /><dbType value="String" /><size value="255" /><layout type="log4net.Layout.PatternLayout" value="%thread" /></parameter><parameter><parameterName value="@log_level" /><dbType value="String" /><size value="50" /><layout type="log4net.Layout.PatternLayout" value="%level" /></parameter><parameter><parameterName value="@logger" /><dbType value="String" /><size value="255" /><layout type="log4net.Layout.PatternLayout" value="%logger" /></parameter><parameter><parameterName value="@message" /><dbType value="String" /><size value="4000" /><layout type="log4net.Layout.PatternLayout" value="%message" /></parameter></appender>
<appender name="AdoNetAppender_SqlServer" type="log4net.Appender.AdoNetAppender"><connectionType value="System.Data.SqlClient.SqlConnection, System.Data, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" /><connectionString value="data source=SQLSVR;initial catalog=test_log4net;integrated security=false;persist security info=True;User ID=sa;Password=sa" /><commandText value="INSERT INTO Log ([Date],[Thread],[Level],[Logger],[Message]) VALUES (@log_date, @thread, @log_level, @logger, @message)" /><parameter><parameterName value="@log_date" /><dbType value="DateTime" /><layout type="log4net.Layout.PatternLayout" value="%date{yyyy'-'MM'-'dd HH':'mm':'ss'.'fff}" /></parameter><parameter><parameterName value="@thread" /><dbType value="String" /><size value="255" /><layout type="log4net.Layout.PatternLayout" value="%thread" /></parameter><parameter><parameterName value="@log_level" /><dbType value="String" /><size value="50" /><layout type="log4net.Layout.PatternLayout" value="%level" /></parameter><parameter><parameterName value="@logger" /><dbType value="String" /><size value="255" /><layout type="log4net.Layout.PatternLayout" value="%logger" /></parameter><parameter><parameterName value="@message" /><dbType value="String" /><size value="4000" /><layout type="log4net.Layout.PatternLayout" value="%message" /></parameter></appender>
See Also
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender Members

AdoNetAppender Members Apache log4net™ SDK Documentation
The AdoNetAppender type exposes the following members.
Constructors
 | Name | Description
Public method | AdoNetAppender | Initializes a new instance of the AdoNetAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Overrides BufferingAppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddParameter | Adds a parameter to the command.
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Inherited from BufferingAppenderSkeleton.)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Protected method | CreateConnection | Creates an Online IDbConnection instance used to connect to the database.
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Flush | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Flush(Boolean) | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetLogStatement | Formats the log message into database statement text.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Override the parent method to close the database (Overrides BufferingAppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | ResolveConnectionString | Resolves the connection string from the ConnectionString, ConnectionStringName, or AppSettingsKey property.
Protected method | ResolveConnectionType | Retrieves the class type of the ADO.NET provider.
Protected method | SendBuffer( LoggingEvent ) | Inserts the events into the database. (Overrides BufferingAppenderSkeleton SendBuffer( LoggingEvent ).)
Protected method | SendBuffer(IDbTransaction, LoggingEvent ) | Writes the events to the database using the transaction specified.
Protected method | SendFromBuffer | Sends the contents of the buffer. (Inherited from BufferingAppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | m_parameters | The list of AdoNetAppenderParameter objects.
Back to Top
Properties
 | Name | Description
Public property | AppSettingsKey | The appSettings key from App.Config that contains the connection string.
Public property | BufferSize | Gets or sets the size of the cyclic buffer used to hold the logging events. (Inherited from BufferingAppenderSkeleton.)
Public property | CommandText | Gets or sets the command text that is used to insert logging events into the database.
Public property | CommandType | Gets or sets the command type to execute.
Protected property | Connection | Gets or sets the underlying Online IDbConnection.
Public property | ConnectionString | Gets or sets the database connection string that is used to connect to the database.
Public property | ConnectionStringName | The connectionStrings key from App.Config that contains the connection string.
Public property | ConnectionType | Gets or sets the type name of the Online IDbConnection connection that should be created.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Evaluator | Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately. (Inherited from BufferingAppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets a the fields that will be fixed in the event (Inherited from BufferingAppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Lossy | Gets or sets a value that indicates whether the appender is lossy. (Inherited from BufferingAppenderSkeleton.)
Public property | LossyEvaluator | Gets or sets the value of the ITriggeringEventEvaluator to use. (Inherited from BufferingAppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating if only part of the logging event data should be fixed. (Inherited from BufferingAppenderSkeleton.)
Public property | ReconnectOnError | Should this appender try to reconnect to the database on error.
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set. (Inherited from AppenderSkeleton.)
Public property | SecurityContext | Gets or sets the SecurityContext used to call the NetSend method.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Public property | UseTransactions | Should transactions be used to insert logging events in the database.
Back to Top
See Also
AdoNetAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender Constructor

AdoNetAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the AdoNetAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AdoNetAppender()
public AdoNetAppender()
Public Sub New
Public Sub New
public:
AdoNetAppender()
public:
AdoNetAppender()
Remarks

            Public default constructor to initialize a new instance of this class.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender Fields

AdoNetAppender Fields Apache log4net™ SDK Documentation
The AdoNetAppender type exposes the following members.
Fields
 | Name | Description
Protected field | m_parameters | The list of AdoNetAppenderParameter objects.
Back to Top
See Also
AdoNetAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.m_parameters Field

AdoNetAppender m_parameters Field Apache log4net™ SDK Documentation
The list of AdoNetAppenderParameter objects.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ArrayList m_parameters
protected ArrayList m_parameters
Protected m_parameters As ArrayList
Protected m_parameters As ArrayList
protected:
ArrayList^ m_parameters
protected:
ArrayList^ m_parameters
Field Value
Type:   Online ArrayList
Remarks

            The list of AdoNetAppenderParameter objects.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender Methods

AdoNetAppender Methods Apache log4net™ SDK Documentation
The AdoNetAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Overrides BufferingAppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddParameter | Adds a parameter to the command.
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Inherited from BufferingAppenderSkeleton.)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Protected method | CreateConnection | Creates an Online IDbConnection instance used to connect to the database.
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Flush | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Flush(Boolean) | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetLogStatement | Formats the log message into database statement text.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Override the parent method to close the database (Overrides BufferingAppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | ResolveConnectionString | Resolves the connection string from the ConnectionString, ConnectionStringName, or AppSettingsKey property.
Protected method | ResolveConnectionType | Retrieves the class type of the ADO.NET provider.
Protected method | SendBuffer( LoggingEvent ) | Inserts the events into the database. (Overrides BufferingAppenderSkeleton SendBuffer( LoggingEvent ).)
Protected method | SendBuffer(IDbTransaction, LoggingEvent ) | Writes the events to the database using the transaction specified.
Protected method | SendFromBuffer | Sends the contents of the buffer. (Inherited from BufferingAppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AdoNetAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.ActivateOptions Method

AdoNetAppender ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the appender based on the options set

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.AddParameter Method

AdoNetAppender AddParameter Method Apache log4net™ SDK Documentation
Adds a parameter to the command.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddParameter(
    AdoNetAppenderParameter parameter
)
public void AddParameter(
    AdoNetAppenderParameter parameter
)
Public Sub AddParameter (
    parameter As AdoNetAppenderParameter
)
Public Sub AddParameter (
    parameter As AdoNetAppenderParameter
)
public:
void AddParameter(
    AdoNetAppenderParameter^ parameter
)
public:
void AddParameter(
    AdoNetAppenderParameter^ parameter
)
Parameters
parameter
Type: log4net.Appender AdoNetAppenderParameter
The parameter to add to the command.
Remarks

            Adds a parameter to the ordered list of command parameters.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.CreateConnection Method

AdoNetAppender CreateConnection Method Apache log4net™ SDK Documentation
Creates an Online IDbConnection instance used to connect to the database.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual IDbConnection CreateConnection(
    Type connectionType,
    string connectionString
)
protected virtual IDbConnection CreateConnection(
    Type connectionType,
    string connectionString
)
Protected Overridable Function CreateConnection (
    connectionType As Type,
    connectionString As String
) As IDbConnection
Protected Overridable Function CreateConnection (
    connectionType As Type,
    connectionString As String
) As IDbConnection
protected:
virtual IDbConnection^ CreateConnection(
    Type^ connectionType,
    String^ connectionString
)
protected:
virtual IDbConnection^ CreateConnection(
    Type^ connectionType,
    String^ connectionString
)
Parameters
connectionType
Type:   Online System Type
The   Online Type of the   Online IDbConnection object.
connectionString
Type:   Online System String
The connectionString output from the ResolveConnectionString method.
Return Value
Type:   Online IDbConnection
An   Online IDbConnection instance with a valid connection string.
Remarks

            This method is called whenever a new IDbConnection is needed (i.e. when a reconnect is necessary).

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.GetLogStatement Method

AdoNetAppender GetLogStatement Method Apache log4net™ SDK Documentation
Formats the log message into database statement text.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string GetLogStatement(
    LoggingEvent logEvent
)
protected virtual string GetLogStatement(
    LoggingEvent logEvent
)
Protected Overridable Function GetLogStatement (
    logEvent As LoggingEvent
) As String
Protected Overridable Function GetLogStatement (
    logEvent As LoggingEvent
) As String
protected:
virtual String^ GetLogStatement(
    LoggingEvent^ logEvent
)
protected:
virtual String^ GetLogStatement(
    LoggingEvent^ logEvent
)
Parameters
logEvent
Type: log4net.Core LoggingEvent
The event being logged.
Return Value
Type:   Online String

            Text that can be passed to a   Online IDbCommand.

Remarks

            This method can be overridden by subclasses to provide
            more control over the format of the database statement.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.OnClose Method

AdoNetAppender OnClose Method Apache log4net™ SDK Documentation
Override the parent method to close the database

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void OnClose()
protected override void OnClose()
Protected Overrides Sub OnClose
Protected Overrides Sub OnClose
protected:
virtual void OnClose() override
protected:
virtual void OnClose() override
Remarks

            Closes the database command and database connection.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.ResolveConnectionString Method

AdoNetAppender ResolveConnectionString Method Apache log4net™ SDK Documentation
Resolves the connection string from the ConnectionString, ConnectionStringName, or AppSettingsKey property.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string ResolveConnectionString(
    out string connectionStringContext
)
protected virtual string ResolveConnectionString(
    out string connectionStringContext
)
Protected Overridable Function ResolveConnectionString (
    <OutAttribute> ByRef connectionStringContext As String
) As String
Protected Overridable Function ResolveConnectionString (
    <OutAttribute> ByRef connectionStringContext As String
) As String
protected:
virtual String^ ResolveConnectionString(
    [OutAttribute] String^% connectionStringContext
)
protected:
virtual String^ ResolveConnectionString(
    [OutAttribute] String^% connectionStringContext
)
Parameters
connectionStringContext
Type:   Online System String
Additional information describing the connection string.
Return Value
Type:   Online String
A connection string used to connect to the database.
Remarks

            ConnectiongStringName is only supported on .NET 2.0 and higher.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.ResolveConnectionType Method

AdoNetAppender ResolveConnectionType Method Apache log4net™ SDK Documentation
Retrieves the class type of the ADO.NET provider.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Type ResolveConnectionType()
protected virtual Type ResolveConnectionType()
Protected Overridable Function ResolveConnectionType As Type
Protected Overridable Function ResolveConnectionType As Type
protected:
virtual Type^ ResolveConnectionType()
protected:
virtual Type^ ResolveConnectionType()
Return Value
Type:   Online Type
The   Online Type of the ADO.NET provider
Remarks

            Gets the Type of the ADO.NET provider to use to connect to the
            database. This method resolves the type specified in the
            ConnectionType property.

            Subclasses can override this method to return a different type
            if necessary.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.SendBuffer Method

AdoNetAppender SendBuffer Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | SendBuffer( LoggingEvent ) | Inserts the events into the database. (Overrides BufferingAppenderSkeleton SendBuffer( LoggingEvent ).)
Protected method | SendBuffer(IDbTransaction, LoggingEvent ) | Writes the events to the database using the transaction specified.
Back to Top
See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.SendBuffer Method (LoggingEvent[])

AdoNetAppender SendBuffer Method ( LoggingEvent ) Apache log4net™ SDK Documentation
Inserts the events into the database.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void SendBuffer(
    LoggingEvent[] events
)
protected override void SendBuffer(
    LoggingEvent[] events
)
Protected Overrides Sub SendBuffer (
    events As LoggingEvent()
)
Protected Overrides Sub SendBuffer (
    events As LoggingEvent()
)
protected:
virtual void SendBuffer(
    array<LoggingEvent^>^ events
) override
protected:
virtual void SendBuffer(
    array<LoggingEvent^>^ events
) override
Parameters
events
Type:  log4net.Core LoggingEvent
The events to insert into the database.
Remarks

            Insert all the events specified in the events
            array into the database.

See Also
AdoNetAppender Class
AdoNetAppender Members
SendBuffer Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.SendBuffer Method (IDbTransaction, LoggingEvent[])

AdoNetAppender SendBuffer Method (IDbTransaction, LoggingEvent ) Apache log4net™ SDK Documentation
Writes the events to the database using the transaction specified.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void SendBuffer(
    IDbTransaction dbTran,
    LoggingEvent[] events
)
protected virtual void SendBuffer(
    IDbTransaction dbTran,
    LoggingEvent[] events
)
Protected Overridable Sub SendBuffer (
    dbTran As IDbTransaction,
    events As LoggingEvent()
)
Protected Overridable Sub SendBuffer (
    dbTran As IDbTransaction,
    events As LoggingEvent()
)
protected:
virtual void SendBuffer(
    IDbTransaction^ dbTran,
    array<LoggingEvent^>^ events
)
protected:
virtual void SendBuffer(
    IDbTransaction^ dbTran,
    array<LoggingEvent^>^ events
)
Parameters
dbTran
Type:   Online System.Data IDbTransaction
The transaction that the events will be executed under.
events
Type:  log4net.Core LoggingEvent
The array of events to insert into the database.
Remarks

            The transaction argument can be null if the appender has been
            configured not to use transactions. See UseTransactions
            property for more information.

See Also
AdoNetAppender Class
AdoNetAppender Members
SendBuffer Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender Properties

AdoNetAppender Properties Apache log4net™ SDK Documentation
The AdoNetAppender type exposes the following members.
Properties
 | Name | Description
Public property | AppSettingsKey | The appSettings key from App.Config that contains the connection string.
Public property | BufferSize | Gets or sets the size of the cyclic buffer used to hold the logging events. (Inherited from BufferingAppenderSkeleton.)
Public property | CommandText | Gets or sets the command text that is used to insert logging events into the database.
Public property | CommandType | Gets or sets the command type to execute.
Protected property | Connection | Gets or sets the underlying Online IDbConnection.
Public property | ConnectionString | Gets or sets the database connection string that is used to connect to the database.
Public property | ConnectionStringName | The connectionStrings key from App.Config that contains the connection string.
Public property | ConnectionType | Gets or sets the type name of the Online IDbConnection connection that should be created.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Evaluator | Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately. (Inherited from BufferingAppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets a the fields that will be fixed in the event (Inherited from BufferingAppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Lossy | Gets or sets a value that indicates whether the appender is lossy. (Inherited from BufferingAppenderSkeleton.)
Public property | LossyEvaluator | Gets or sets the value of the ITriggeringEventEvaluator to use. (Inherited from BufferingAppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating if only part of the logging event data should be fixed. (Inherited from BufferingAppenderSkeleton.)
Public property | ReconnectOnError | Should this appender try to reconnect to the database on error.
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set. (Inherited from AppenderSkeleton.)
Public property | SecurityContext | Gets or sets the SecurityContext used to call the NetSend method.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Public property | UseTransactions | Should transactions be used to insert logging events in the database.
Back to Top
See Also
AdoNetAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.AppSettingsKey Property

AdoNetAppender AppSettingsKey Property Apache log4net™ SDK Documentation
The appSettings key from App.Config that contains the connection string.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AppSettingsKey { get; set; }
public string AppSettingsKey { get; set; }
Public Property AppSettingsKey As String
    Get
    Set
Public Property AppSettingsKey As String
    Get
    Set
public:
property String^ AppSettingsKey {
    String^ get ();
    void set (String^ value);
}
public:
property String^ AppSettingsKey {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.CommandText Property

AdoNetAppender CommandText Property Apache log4net™ SDK Documentation
Gets or sets the command text that is used to insert logging events into the database.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CommandText { get; set; }
public string CommandText { get; set; }
Public Property CommandText As String
    Get
    Set
Public Property CommandText As String
    Get
    Set
public:
property String^ CommandText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CommandText {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The command text used to insert logging events into the database.

Remarks

            Either the text of the prepared statement or the
            name of the stored procedure to execute to write into
            the database.

            The CommandType property determines if
            this text is a prepared statement or a stored procedure.

            If this property is not set, the command text is retrieved by invoking
            GetLogStatement(LoggingEvent).

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.CommandType Property

AdoNetAppender CommandType Property Apache log4net™ SDK Documentation
Gets or sets the command type to execute.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CommandType CommandType { get; set; }
public CommandType CommandType { get; set; }
Public Property CommandType As CommandType
    Get
    Set
Public Property CommandType As CommandType
    Get
    Set
public:
property CommandType CommandType {
    CommandType get ();
    void set (CommandType value);
}
public:
property CommandType CommandType {
    CommandType get ();
    void set (CommandType value);
}
Property Value
Type:   Online CommandType

            The command type to execute.

Remarks

            This value may be either   Online Text (System.Data.CommandType.Text) to specify
            that the CommandText is a prepared statement to execute,
            or   Online StoredProcedure (System.Data.CommandType.StoredProcedure) to specify that the
            CommandText property is the name of a stored procedure
            to execute.

            The default value is   Online Text (System.Data.CommandType.Text).

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.Connection Property

AdoNetAppender Connection Property Apache log4net™ SDK Documentation
Gets or sets the underlying Online IDbConnection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IDbConnection Connection { get; set; }
protected IDbConnection Connection { get; set; }
Protected Property Connection As IDbConnection
    Get
    Set
Protected Property Connection As IDbConnection
    Get
    Set
protected:
property IDbConnection^ Connection {
    IDbConnection^ get ();
    void set (IDbConnection^ value);
}
protected:
property IDbConnection^ Connection {
    IDbConnection^ get ();
    void set (IDbConnection^ value);
}
Property Value
Type:   Online IDbConnection

            The underlying   Online IDbConnection.

Remarks
AdoNetAppender creates a   Online IDbConnection to insert
            logging events into a database.  Classes deriving from AdoNetAppender
            can use this property to get or set this   Online IDbConnection.  Use the
            underlying   Online IDbConnection returned from Connection if
            you require access beyond that which AdoNetAppender provides.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.ConnectionString Property

AdoNetAppender ConnectionString Property Apache log4net™ SDK Documentation
Gets or sets the database connection string that is used to connect to the database.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ConnectionString { get; set; }
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set
Public Property ConnectionString As String
    Get
    Set
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The database connection string used to connect to the database.

Remarks

            The connections string is specific to the connection type.
            See ConnectionType for more information.

Examples
Connection string for MS Access via ODBC:

View Colorized Copy to Clipboard Print
"DSN=MS Access Database;UID=admin;PWD=;SystemDB=C:\data\System.mdw;SafeTransactions = 0;FIL=MS Access;DriverID = 25;DBQ=C:\data\train33.mdb"
"DSN=MS Access Database;UID=admin;PWD=;SystemDB=C:\data\System.mdw;SafeTransactions = 0;FIL=MS Access;DriverID = 25;DBQ=C:\data\train33.mdb"
Examples
Another connection string for MS Access via ODBC:

View Colorized Copy to Clipboard Print
"Driver={Microsoft Access Driver (*.mdb)};DBQ=C:\Work\cvs_root\log4net-1.2\access.mdb;UID=;PWD=;"
"Driver={Microsoft Access Driver (*.mdb)};DBQ=C:\Work\cvs_root\log4net-1.2\access.mdb;UID=;PWD=;"
Examples
Connection string for MS Access via OLE DB:

View Colorized Copy to Clipboard Print
"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Work\cvs_root\log4net-1.2\access.mdb;User Id=;Password=;"
"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Work\cvs_root\log4net-1.2\access.mdb;User Id=;Password=;"
See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.ConnectionStringName Property

AdoNetAppender ConnectionStringName Property Apache log4net™ SDK Documentation
The connectionStrings key from App.Config that contains the connection string.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ConnectionStringName { get; set; }
public string ConnectionStringName { get; set; }
Public Property ConnectionStringName As String
    Get
    Set
Public Property ConnectionStringName As String
    Get
    Set
public:
property String^ ConnectionStringName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ConnectionStringName {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            This property requires at least .NET 2.0.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.ConnectionType Property

AdoNetAppender ConnectionType Property Apache log4net™ SDK Documentation
Gets or sets the type name of the Online IDbConnection connection that should be created.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ConnectionType { get; set; }
public string ConnectionType { get; set; }
Public Property ConnectionType As String
    Get
    Set
Public Property ConnectionType As String
    Get
    Set
public:
property String^ ConnectionType {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ConnectionType {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The type name of the   Online IDbConnection connection.

Remarks

            The type name of the ADO.NET provider to use.

            The default is to use the OLE DB provider.

Examples
Use the OLE DB Provider. This is the default value.

View Colorized Copy to Clipboard Print
System.Data.OleDb.OleDbConnection, System.Data, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
System.Data.OleDb.OleDbConnection, System.Data, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
Examples
Use the MS SQL Server Provider.

View Colorized Copy to Clipboard Print
System.Data.SqlClient.SqlConnection, System.Data, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
System.Data.SqlClient.SqlConnection, System.Data, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
Examples
Use the ODBC Provider.

View Colorized Copy to Clipboard Print
Microsoft.Data.Odbc.OdbcConnection,Microsoft.Data.Odbc,version=1.0.3300.0,publicKeyToken=b77a5c561934e089,culture=neutral
Microsoft.Data.Odbc.OdbcConnection,Microsoft.Data.Odbc,version=1.0.3300.0,publicKeyToken=b77a5c561934e089,culture=neutral

            This is an optional package that you can download from
              Online http://msdn.microsoft.com/downloads
            search for ODBC .NET Data Provider.

Examples
Use the Oracle Provider.

View Colorized Copy to Clipboard Print
System.Data.OracleClient.OracleConnection, System.Data.OracleClient, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
System.Data.OracleClient.OracleConnection, System.Data.OracleClient, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

            This is an optional package that you can download from
              Online http://msdn.microsoft.com/downloads
            search for .NET Managed Provider for Oracle.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.ReconnectOnError Property

AdoNetAppender ReconnectOnError Property Apache log4net™ SDK Documentation
Should this appender try to reconnect to the database on error.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ReconnectOnError { get; set; }
public bool ReconnectOnError { get; set; }
Public Property ReconnectOnError As Boolean
    Get
    Set
Public Property ReconnectOnError As Boolean
    Get
    Set
public:
property bool ReconnectOnError {
    bool get ();
    void set (bool value);
}
public:
property bool ReconnectOnError {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if the appender should try to reconnect to the database after an
            error has occurred, otherwise false. The default value is false,
            i.e. not to try to reconnect.

Remarks

            The default behaviour is for the appender not to try to reconnect to the
            database if an error occurs. Subsequent logging events are discarded.

            To force the appender to attempt to reconnect to the database set this
            property to true.

  Note  Note

            When the appender attempts to connect to the database there may be a
            delay of up to the connection timeout specified in the connection string.
            This delay will block the calling application's thread.
            Until the connection can be reestablished this potential delay may occur multiple times.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.SecurityContext Property

AdoNetAppender SecurityContext Property Apache log4net™ SDK Documentation
Gets or sets the SecurityContext used to call the NetSend method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityContext SecurityContext { get; set; }
public SecurityContext SecurityContext { get; set; }
Public Property SecurityContext As SecurityContext
    Get
    Set
Public Property SecurityContext As SecurityContext
    Get
    Set
public:
property SecurityContext^ SecurityContext {
    SecurityContext^ get ();
    void set (SecurityContext^ value);
}
public:
property SecurityContext^ SecurityContext {
    SecurityContext^ get ();
    void set (SecurityContext^ value);
}
Property Value
Type: SecurityContext

            The SecurityContext used to call the NetSend method.

Remarks

            Unless a SecurityContext specified here for this appender
            the DefaultProvider is queried for the
            security context to use. The default behavior is to use the security context
            of the current thread.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppender.UseTransactions Property

AdoNetAppender UseTransactions Property Apache log4net™ SDK Documentation
Should transactions be used to insert logging events in the database.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UseTransactions { get; set; }
public bool UseTransactions { get; set; }
Public Property UseTransactions As Boolean
    Get
    Set
Public Property UseTransactions As Boolean
    Get
    Set
public:
property bool UseTransactions {
    bool get ();
    void set (bool value);
}
public:
property bool UseTransactions {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if transactions should be used to insert logging events in
            the database, otherwise false. The default value is true.

Remarks

            Gets or sets a value that indicates whether transactions should be used
            to insert logging events in the database.

            When set a single transaction will be used to insert the buffered events
            into the database. Otherwise each event will be inserted without using
            an explicit transaction.

See Also
AdoNetAppender Class
AdoNetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter Class

AdoNetAppenderParameter Class Apache log4net™ SDK Documentation
Parameter type used by the AdoNetAppender.
Inheritance Hierarchy
Online System Object
log4net.Appender AdoNetAppenderParameter

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AdoNetAppenderParameter
public class AdoNetAppenderParameter
Public Class AdoNetAppenderParameter
Public Class AdoNetAppenderParameter
public ref class AdoNetAppenderParameter
public ref class AdoNetAppenderParameter
Remarks

            This class provides the basic database parameter properties
            as defined by the   Online IDbDataParameter interface.

This type can be subclassed to provide database specific
            functionality. The two methods that are called externally are
            Prepare(IDbCommand) and FormatValue(IDbCommand, LoggingEvent).

See Also
AdoNetAppenderParameter Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter Members

AdoNetAppenderParameter Members Apache log4net™ SDK Documentation
The AdoNetAppenderParameter type exposes the following members.
Constructors
 | Name | Description
Public method | AdoNetAppenderParameter | Initializes a new instance of the AdoNetAppenderParameter class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormatValue | Renders the logging event and set the parameter value in the command.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Prepare | Prepare the specified database command object.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | DbType | Gets or sets the database type for this parameter.
Public property | Layout | Gets or sets the IRawLayout to use to render the logging event into an object for this parameter.
Public property | ParameterName | Gets or sets the name of this parameter.
Public property | Precision | Gets or sets the precision for this parameter.
Public property | Scale | Gets or sets the scale for this parameter.
Public property | Size | Gets or sets the size for this parameter.
Back to Top
See Also
AdoNetAppenderParameter Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter Constructor

AdoNetAppenderParameter Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the AdoNetAppenderParameter class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AdoNetAppenderParameter()
public AdoNetAppenderParameter()
Public Sub New
Public Sub New
public:
AdoNetAppenderParameter()
public:
AdoNetAppenderParameter()
Remarks

            Default constructor for the AdoNetAppenderParameter class.

See Also
AdoNetAppenderParameter Class
AdoNetAppenderParameter Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter Methods

AdoNetAppenderParameter Methods Apache log4net™ SDK Documentation
The AdoNetAppenderParameter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormatValue | Renders the logging event and set the parameter value in the command.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Prepare | Prepare the specified database command object.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AdoNetAppenderParameter Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter.FormatValue Method

AdoNetAppenderParameter FormatValue Method Apache log4net™ SDK Documentation
Renders the logging event and set the parameter value in the command.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FormatValue(
    IDbCommand command,
    LoggingEvent loggingEvent
)
public virtual void FormatValue(
    IDbCommand command,
    LoggingEvent loggingEvent
)
Public Overridable Sub FormatValue (
    command As IDbCommand,
    loggingEvent As LoggingEvent
)
Public Overridable Sub FormatValue (
    command As IDbCommand,
    loggingEvent As LoggingEvent
)
public:
virtual void FormatValue(
    IDbCommand^ command,
    LoggingEvent^ loggingEvent
)
public:
virtual void FormatValue(
    IDbCommand^ command,
    LoggingEvent^ loggingEvent
)
Parameters
command
Type:   Online System.Data IDbCommand
The command containing the parameter.
loggingEvent
Type: log4net.Core LoggingEvent
The event to be rendered.
Remarks

            Renders the logging event using this parameters layout
            object. Sets the value of the parameter on the command object.

See Also
AdoNetAppenderParameter Class
AdoNetAppenderParameter Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter.Prepare Method

AdoNetAppenderParameter Prepare Method Apache log4net™ SDK Documentation
Prepare the specified database command object.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Prepare(
    IDbCommand command
)
public virtual void Prepare(
    IDbCommand command
)
Public Overridable Sub Prepare (
    command As IDbCommand
)
Public Overridable Sub Prepare (
    command As IDbCommand
)
public:
virtual void Prepare(
    IDbCommand^ command
)
public:
virtual void Prepare(
    IDbCommand^ command
)
Parameters
command
Type:   Online System.Data IDbCommand
The command to prepare.
Remarks

            Prepares the database command object by adding
            this parameter to its collection of parameters.

See Also
AdoNetAppenderParameter Class
AdoNetAppenderParameter Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter Properties

AdoNetAppenderParameter Properties Apache log4net™ SDK Documentation
The AdoNetAppenderParameter type exposes the following members.
Properties
 | Name | Description
Public property | DbType | Gets or sets the database type for this parameter.
Public property | Layout | Gets or sets the IRawLayout to use to render the logging event into an object for this parameter.
Public property | ParameterName | Gets or sets the name of this parameter.
Public property | Precision | Gets or sets the precision for this parameter.
Public property | Scale | Gets or sets the scale for this parameter.
Public property | Size | Gets or sets the size for this parameter.
Back to Top
See Also
AdoNetAppenderParameter Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter.DbType Property

AdoNetAppenderParameter DbType Property Apache log4net™ SDK Documentation
Gets or sets the database type for this parameter.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DbType DbType { get; set; }
public DbType DbType { get; set; }
Public Property DbType As DbType
    Get
    Set
Public Property DbType As DbType
    Get
    Set
public:
property DbType DbType {
    DbType get ();
    void set (DbType value);
}
public:
property DbType DbType {
    DbType get ();
    void set (DbType value);
}
Property Value
Type:   Online DbType

            The database type for this parameter.

Remarks

            The database type for this parameter. This property should
            be set to the database type from the DbType
            enumeration. See   Online DbType.

            This property is optional. If not specified the ADO.NET provider
            will attempt to infer the type from the value.

See Also
AdoNetAppenderParameter Class
AdoNetAppenderParameter Members
log4net.Appender Namespace
  Online IDataParameter DbType
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter.Layout Property

AdoNetAppenderParameter Layout Property Apache log4net™ SDK Documentation
Gets or sets the IRawLayout to use to render the logging event into an object for this parameter.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRawLayout Layout { get; set; }
public IRawLayout Layout { get; set; }
Public Property Layout As IRawLayout
    Get
    Set
Public Property Layout As IRawLayout
    Get
    Set
public:
property IRawLayout^ Layout {
    IRawLayout^ get ();
    void set (IRawLayout^ value);
}
public:
property IRawLayout^ Layout {
    IRawLayout^ get ();
    void set (IRawLayout^ value);
}
Property Value
Type: IRawLayout

            The IRawLayout used to render the
            logging event into an object for this parameter.

Remarks

            The IRawLayout that renders the value for this
            parameter.

            The RawLayoutConverter can be used to adapt
            any ILayout into a IRawLayout
            for use in the property.

See Also
AdoNetAppenderParameter Class
AdoNetAppenderParameter Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter.ParameterName Property

AdoNetAppenderParameter ParameterName Property Apache log4net™ SDK Documentation
Gets or sets the name of this parameter.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ParameterName { get; set; }
public string ParameterName { get; set; }
Public Property ParameterName As String
    Get
    Set
Public Property ParameterName As String
    Get
    Set
public:
property String^ ParameterName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ParameterName {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The name of this parameter.

Remarks

            The name of this parameter. The parameter name
            must match up to a named parameter to the SQL stored procedure
            or prepared statement.

See Also
AdoNetAppenderParameter Class
AdoNetAppenderParameter Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter.Precision Property

AdoNetAppenderParameter Precision Property Apache log4net™ SDK Documentation
Gets or sets the precision for this parameter.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte Precision { get; set; }
public byte Precision { get; set; }
Public Property Precision As Byte
    Get
    Set
Public Property Precision As Byte
    Get
    Set
public:
property unsigned char Precision {
    unsigned char get ();
    void set (unsigned char value);
}
public:
property unsigned char Precision {
    unsigned char get ();
    void set (unsigned char value);
}
Property Value
Type:   Online Byte

            The precision for this parameter.

Remarks

            The maximum number of digits used to represent the Value.

            This property is optional. If not specified the ADO.NET provider
            will attempt to infer the precision from the value.

See Also
AdoNetAppenderParameter Class
AdoNetAppenderParameter Members
log4net.Appender Namespace
  Online IDbDataParameter Precision
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter.Scale Property

AdoNetAppenderParameter Scale Property Apache log4net™ SDK Documentation
Gets or sets the scale for this parameter.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte Scale { get; set; }
public byte Scale { get; set; }
Public Property Scale As Byte
    Get
    Set
Public Property Scale As Byte
    Get
    Set
public:
property unsigned char Scale {
    unsigned char get ();
    void set (unsigned char value);
}
public:
property unsigned char Scale {
    unsigned char get ();
    void set (unsigned char value);
}
Property Value
Type:   Online Byte

            The scale for this parameter.

Remarks

            The number of decimal places to which Value is resolved.

            This property is optional. If not specified the ADO.NET provider
            will attempt to infer the scale from the value.

See Also
AdoNetAppenderParameter Class
AdoNetAppenderParameter Members
log4net.Appender Namespace
  Online IDbDataParameter Scale
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AdoNetAppenderParameter.Size Property

AdoNetAppenderParameter Size Property Apache log4net™ SDK Documentation
Gets or sets the size for this parameter.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Size { get; set; }
public int Size { get; set; }
Public Property Size As Integer
    Get
    Set
Public Property Size As Integer
    Get
    Set
public:
property int Size {
    int get ();
    void set (int value);
}
public:
property int Size {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32

            The size for this parameter.

Remarks

            The maximum size, in bytes, of the data within the column.

            This property is optional. If not specified the ADO.NET provider
            will attempt to infer the size from the value.

            For BLOB data types like VARCHAR(max) it may be impossible to infer the value automatically, use -1 as the size in this case.

See Also
AdoNetAppenderParameter Class
AdoNetAppenderParameter Members
log4net.Appender Namespace
  Online IDbDataParameter Size
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender Class

AnsiColorTerminalAppender Class Apache log4net™ SDK Documentation
Appends logging events to the terminal using ANSI color escape sequences.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender AnsiColorTerminalAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AnsiColorTerminalAppender : AppenderSkeleton
public class AnsiColorTerminalAppender : AppenderSkeleton
Public Class AnsiColorTerminalAppender
    Inherits AppenderSkeleton
Public Class AnsiColorTerminalAppender
    Inherits AppenderSkeleton
public ref class AnsiColorTerminalAppender : public AppenderSkeleton
public ref class AnsiColorTerminalAppender : public AppenderSkeleton
Remarks

            AnsiColorTerminalAppender appends log events to the standard output stream
            or the error output stream using a layout specified by the
            user. It also allows the color of a specific level of message to be set.

  Note  Note

            This appender expects the terminal to understand the VT100 control set
            in order to interpret the color codes. If the terminal or console does not
            understand the control codes the behavior is not defined.

            By default, all output is written to the console's standard output stream.
            The Target property can be set to direct the output to the
            error stream.

            NOTE: This appender writes each message to the System.Console.Out or
            System.Console.Error that is set at the time the event is appended.
            Therefore it is possible to programmatically redirect the output of this appender
            (for example NUnit does this to capture program output). While this is the desired
            behavior of this appender it may have security implications in your application.

            When configuring the ANSI colored terminal appender, a mapping should be
            specified to map a logging level to a color. For example:

XML
View Colorized Copy to Clipboard Print
<mapping><level value="ERROR" /><foreColor value="White" /><backColor value="Red" /><attributes value="Bright,Underscore" /></mapping><mapping><level value="DEBUG" /><backColor value="Green" /></mapping>
<mapping><level value="ERROR" /><foreColor value="White" /><backColor value="Red" /><attributes value="Bright,Underscore" /></mapping><mapping><level value="DEBUG" /><backColor value="Green" /></mapping>

            The Level is the standard log4net logging level and ForeColor and BackColor can be any
            of the following values:

  • Blue
  • Green
  • Red
  • White
  • Yellow
  • Purple
  • Cyan

            These color values cannot be combined together to make new colors.

            The attributes can be any combination of the following:

  • Bright
    foreground is brighter
  • Dim
    foreground is dimmer
  • Underscore
    message is underlined
  • Blink
    foreground is blinking (does not work on all terminals)
  • Reverse
    foreground and background are reversed
  • Hidden
    output is hidden
  • Strikethrough
    message has a line through it

            While any of these attributes may be combined together not all combinations
            work well together, for example setting both Bright and Dim attributes makes
            no sense.

See Also
AnsiColorTerminalAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender Members

AnsiColorTerminalAppender Members Apache log4net™ SDK Documentation
The AnsiColorTerminalAppender type exposes the following members.
Constructors
 | Name | Description
Public method | AnsiColorTerminalAppender | Initializes a new instance of the AnsiColorTerminalAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the options for this appender (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddMapping | Add a mapping of level to color
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
ConsoleError | The Target to use when writing to the Console standard error output stream.
ConsoleOut | The Target to use when writing to the Console standard output stream.
Back to Top
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Target | Target is the value of the console output stream.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
AnsiColorTerminalAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender Constructor

AnsiColorTerminalAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the AnsiColorTerminalAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AnsiColorTerminalAppender()
public AnsiColorTerminalAppender()
Public Sub New
Public Sub New
public:
AnsiColorTerminalAppender()
public:
AnsiColorTerminalAppender()
Remarks

            The instance of the AnsiColorTerminalAppender class is set up to write
            to the standard output stream.

See Also
AnsiColorTerminalAppender Class
AnsiColorTerminalAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender Fields

AnsiColorTerminalAppender Fields Apache log4net™ SDK Documentation
The AnsiColorTerminalAppender type exposes the following members.
Fields
Name | Description
ConsoleError | The Target to use when writing to the Console standard error output stream.
ConsoleOut | The Target to use when writing to the Console standard output stream.
Back to Top
See Also
AnsiColorTerminalAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.ConsoleError Field

AnsiColorTerminalAppender ConsoleError Field Apache log4net™ SDK Documentation
The Target to use when writing to the Console standard error output stream.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ConsoleError
public const string ConsoleError
Public Const ConsoleError As String
Public Const ConsoleError As String
public:
literal String^ ConsoleError
public:
literal String^ ConsoleError
Field Value
Type:   Online String
Remarks

            The Target to use when writing to the Console
            standard error output stream.

See Also
AnsiColorTerminalAppender Class
AnsiColorTerminalAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.ConsoleOut Field

AnsiColorTerminalAppender ConsoleOut Field Apache log4net™ SDK Documentation
The Target to use when writing to the Console standard output stream.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ConsoleOut
public const string ConsoleOut
Public Const ConsoleOut As String
Public Const ConsoleOut As String
public:
literal String^ ConsoleOut
public:
literal String^ ConsoleOut
Field Value
Type:   Online String
Remarks

            The Target to use when writing to the Console
            standard output stream.

See Also
AnsiColorTerminalAppender Class
AnsiColorTerminalAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender Methods

AnsiColorTerminalAppender Methods Apache log4net™ SDK Documentation
The AnsiColorTerminalAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the options for this appender (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddMapping | Add a mapping of level to color
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AnsiColorTerminalAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.ActivateOptions Method

AnsiColorTerminalAppender ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the options for this appender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            Initialize the level to color mappings set on this appender.

See Also
AnsiColorTerminalAppender Class
AnsiColorTerminalAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.AddMapping Method

AnsiColorTerminalAppender AddMapping Method Apache log4net™ SDK Documentation
Add a mapping of level to color

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddMapping(
    AnsiColorTerminalAppender..::..LevelColors mapping
)
public void AddMapping(
    AnsiColorTerminalAppender..::..LevelColors mapping
)
Public Sub AddMapping (
    mapping As AnsiColorTerminalAppender..::..LevelColors
)
Public Sub AddMapping (
    mapping As AnsiColorTerminalAppender..::..LevelColors
)
public:
void AddMapping(
    AnsiColorTerminalAppender..::..LevelColors^ mapping
)
public:
void AddMapping(
    AnsiColorTerminalAppender..::..LevelColors^ mapping
)
Parameters
mapping
Type: log4net.Appender AnsiColorTerminalAppender LevelColors
The mapping to add
Remarks

            Add a AnsiColorTerminalAppender LevelColors mapping to this appender.
            Each mapping defines the foreground and background colours
            for a level.

See Also
AnsiColorTerminalAppender Class
AnsiColorTerminalAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.Append Method

AnsiColorTerminalAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Back to Top
See Also
AnsiColorTerminalAppender Class
AnsiColorTerminalAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.Append Method (LoggingEvent)

AnsiColorTerminalAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Writes the event to the console.

            The format of the output will depend on the appender's layout.

See Also
AnsiColorTerminalAppender Class
AnsiColorTerminalAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender Properties

AnsiColorTerminalAppender Properties Apache log4net™ SDK Documentation
The AnsiColorTerminalAppender type exposes the following members.
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Target | Target is the value of the console output stream.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
AnsiColorTerminalAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.RequiresLayout Property

AnsiColorTerminalAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
AnsiColorTerminalAppender Class
AnsiColorTerminalAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.Target Property

AnsiColorTerminalAppender Target Property Apache log4net™ SDK Documentation
Target is the value of the console output stream.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Target { get; set; }
public virtual string Target { get; set; }
Public Overridable Property Target As String
    Get
    Set
Public Overridable Property Target As String
    Get
    Set
public:
virtual property String^ Target {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Target {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            Target is the value of the console output stream.
            This is either "Console.Out" or "Console.Error".

Remarks

            Target is the value of the console output stream.
            This is either "Console.Out" or "Console.Error".

See Also
AnsiColorTerminalAppender Class
AnsiColorTerminalAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.AnsiAttributes Enumeration

AnsiColorTerminalAppender AnsiAttributes Enumeration Apache log4net™ SDK Documentation
The enum of possible display attributes

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum AnsiAttributes
[FlagsAttribute]
public enum AnsiAttributes
<FlagsAttribute>
Public Enumeration AnsiAttributes
<FlagsAttribute>
Public Enumeration AnsiAttributes
[FlagsAttribute]
public enum class AnsiAttributes
[FlagsAttribute]
public enum class AnsiAttributes
Members
Member name | Value | Description
Bright | 1 | text is bright
Dim | 2 | text is dim
Underscore | 4 | text is underlined
Blink | 8 | text is blinking
Reverse | 16 | text and background colors are reversed
Hidden | 32 | text is hidden
Strikethrough | 64 | text is displayed with a strikethrough
Light | 128 | text color is light
Remarks

            The following flags can be combined together to
            form the ANSI color attributes.

See Also
log4net.Appender Namespace
log4net.Appender AnsiColorTerminalAppender
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.AnsiColor Enumeration

AnsiColorTerminalAppender AnsiColor Enumeration Apache log4net™ SDK Documentation
The enum of possible foreground or background color values for use with the color mapping method

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum AnsiColor
public enum AnsiColor
Public Enumeration AnsiColor
Public Enumeration AnsiColor
public enum class AnsiColor
public enum class AnsiColor
Members
Member name | Value | Description
Black | 0 | color is black
Red | 1 | color is red
Green | 2 | color is green
Yellow | 3 | color is yellow
Blue | 4 | color is blue
Magenta | 5 | color is magenta
Cyan | 6 | color is cyan
White | 7 | color is white
Remarks

            The output can be in one for the following ANSI colors.

See Also
log4net.Appender Namespace
log4net.Appender AnsiColorTerminalAppender
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.LevelColors Class

AnsiColorTerminalAppender LevelColors Class Apache log4net™ SDK Documentation
A class to act as a mapping between the level that a logging call is made at and the color it should be displayed as.
Inheritance Hierarchy
Online System Object
log4net.Util LevelMappingEntry
log4net.Appender AnsiColorTerminalAppender LevelColors

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LevelColors : LevelMappingEntry
public class LevelColors : LevelMappingEntry
Public Class LevelColors
    Inherits LevelMappingEntry
Public Class LevelColors
    Inherits LevelMappingEntry
public ref class LevelColors : public LevelMappingEntry
public ref class LevelColors : public LevelMappingEntry
Remarks

            Defines the mapping between a level and the color it should be displayed in.

See Also
AnsiColorTerminalAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.LevelColors Members

AnsiColorTerminalAppender LevelColors Members Apache log4net™ SDK Documentation
The AnsiColorTerminalAppender LevelColors type exposes the following members.
Constructors
 | Name | Description
Public method | AnsiColorTerminalAppender LevelColors | Initializes a new instance of the AnsiColorTerminalAppender LevelColors class
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the options for the object (Overrides LevelMappingEntry ActivateOptions .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Attributes | The color attributes for the specified level
Public property | BackColor | The mapped background color for the specified level
Public property | ForeColor | The mapped foreground color for the specified level
Public property | Level | The level that is the key for this mapping (Inherited from LevelMappingEntry.)
Back to Top
See Also
AnsiColorTerminalAppender LevelColors Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.LevelColors Constructor

AnsiColorTerminalAppender LevelColors Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the AnsiColorTerminalAppender LevelColors class

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelColors()
public LevelColors()
Public Sub New
Public Sub New
public:
LevelColors()
public:
LevelColors()
See Also
AnsiColorTerminalAppender LevelColors Class
AnsiColorTerminalAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.LevelColors Methods

AnsiColorTerminalAppender LevelColors Methods Apache log4net™ SDK Documentation
The AnsiColorTerminalAppender LevelColors type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the options for the object (Overrides LevelMappingEntry ActivateOptions .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AnsiColorTerminalAppender LevelColors Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.LevelColors.ActivateOptions Method

AnsiColorTerminalAppender LevelColors ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the options for the object

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            Combine the ForeColor and BackColor together
            and append the attributes.

See Also
AnsiColorTerminalAppender LevelColors Class
AnsiColorTerminalAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.LevelColors Properties

AnsiColorTerminalAppender LevelColors Properties Apache log4net™ SDK Documentation
The AnsiColorTerminalAppender LevelColors type exposes the following members.
Properties
 | Name | Description
Public property | Attributes | The color attributes for the specified level
Public property | BackColor | The mapped background color for the specified level
Public property | ForeColor | The mapped foreground color for the specified level
Public property | Level | The level that is the key for this mapping (Inherited from LevelMappingEntry.)
Back to Top
See Also
AnsiColorTerminalAppender LevelColors Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.LevelColors.Attributes Property

AnsiColorTerminalAppender LevelColors Attributes Property Apache log4net™ SDK Documentation
The color attributes for the specified level

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AnsiColorTerminalAppender..::..AnsiAttributes Attributes { get; set; }
public AnsiColorTerminalAppender..::..AnsiAttributes Attributes { get; set; }
Public Property Attributes As AnsiColorTerminalAppender..::..AnsiAttributes
    Get
    Set
Public Property Attributes As AnsiColorTerminalAppender..::..AnsiAttributes
    Get
    Set
public:
property AnsiColorTerminalAppender..::..AnsiAttributes Attributes {
    AnsiColorTerminalAppender..::..AnsiAttributes get ();
    void set (AnsiColorTerminalAppender..::..AnsiAttributes value);
}
public:
property AnsiColorTerminalAppender..::..AnsiAttributes Attributes {
    AnsiColorTerminalAppender..::..AnsiAttributes get ();
    void set (AnsiColorTerminalAppender..::..AnsiAttributes value);
}
Property Value
Type: AnsiColorTerminalAppender AnsiAttributes
Remarks

            Required property.
            The color attributes for the specified level

See Also
AnsiColorTerminalAppender LevelColors Class
AnsiColorTerminalAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.LevelColors.BackColor Property

AnsiColorTerminalAppender LevelColors BackColor Property Apache log4net™ SDK Documentation
The mapped background color for the specified level

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AnsiColorTerminalAppender..::..AnsiColor BackColor { get; set; }
public AnsiColorTerminalAppender..::..AnsiColor BackColor { get; set; }
Public Property BackColor As AnsiColorTerminalAppender..::..AnsiColor
    Get
    Set
Public Property BackColor As AnsiColorTerminalAppender..::..AnsiColor
    Get
    Set
public:
property AnsiColorTerminalAppender..::..AnsiColor BackColor {
    AnsiColorTerminalAppender..::..AnsiColor get ();
    void set (AnsiColorTerminalAppender..::..AnsiColor value);
}
public:
property AnsiColorTerminalAppender..::..AnsiColor BackColor {
    AnsiColorTerminalAppender..::..AnsiColor get ();
    void set (AnsiColorTerminalAppender..::..AnsiColor value);
}
Property Value
Type: AnsiColorTerminalAppender AnsiColor
Remarks

            Required property.
            The mapped background color for the specified level

See Also
AnsiColorTerminalAppender LevelColors Class
AnsiColorTerminalAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AnsiColorTerminalAppender.LevelColors.ForeColor Property

AnsiColorTerminalAppender LevelColors ForeColor Property Apache log4net™ SDK Documentation
The mapped foreground color for the specified level

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AnsiColorTerminalAppender..::..AnsiColor ForeColor { get; set; }
public AnsiColorTerminalAppender..::..AnsiColor ForeColor { get; set; }
Public Property ForeColor As AnsiColorTerminalAppender..::..AnsiColor
    Get
    Set
Public Property ForeColor As AnsiColorTerminalAppender..::..AnsiColor
    Get
    Set
public:
property AnsiColorTerminalAppender..::..AnsiColor ForeColor {
    AnsiColorTerminalAppender..::..AnsiColor get ();
    void set (AnsiColorTerminalAppender..::..AnsiColor value);
}
public:
property AnsiColorTerminalAppender..::..AnsiColor ForeColor {
    AnsiColorTerminalAppender..::..AnsiColor get ();
    void set (AnsiColorTerminalAppender..::..AnsiColor value);
}
Property Value
Type: AnsiColorTerminalAppender AnsiColor
Remarks

            Required property.
            The mapped foreground color for the specified level

See Also
AnsiColorTerminalAppender LevelColors Class
AnsiColorTerminalAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection Class

AppenderCollection Class Apache log4net™ SDK Documentation
A strongly-typed collection of IAppender objects.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderCollection

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AppenderCollection : IList,
    ICollection, IEnumerable, ICloneable
public class AppenderCollection : IList,
    ICollection, IEnumerable, ICloneable
Public Class AppenderCollection
    Implements IList, ICollection, IEnumerable, ICloneable
Public Class AppenderCollection
    Implements IList, ICollection, IEnumerable, ICloneable
public ref class AppenderCollection : IList,
    ICollection, IEnumerable, ICloneable
public ref class AppenderCollection : IList,
    ICollection, IEnumerable, ICloneable
See Also
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection Members

AppenderCollection Members Apache log4net™ SDK Documentation
The AppenderCollection type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds a IAppender to the end of the AppenderCollection.
Public method | AddRange(ICollection) | Adds the elements of a IAppender collection to the current AppenderCollection.
Public method | AddRange(AppenderCollection) | Adds the elements of another AppenderCollection to the current AppenderCollection.
Public method | AddRange( IAppender ) | Adds the elements of a IAppender array to the current AppenderCollection.
Public method | Clear | Removes all elements from the AppenderCollection.
Public method | Clone | Creates a shallow copy of the AppenderCollection.
Public method | Contains | Determines whether a given IAppender is in the AppenderCollection.
Public method | CopyTo( IAppender ) | Copies the entire AppenderCollection to a one-dimensional IAppender array.
Public method | CopyTo( IAppender , Int32) | Copies the entire AppenderCollection to a one-dimensional IAppender array, starting at the specified index of the target array.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | Returns an enumerator that can iterate through the AppenderCollection.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a IAppender in the AppenderCollection.
Public method | Insert | Inserts an element into the AppenderCollection at the specified index.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ReadOnly | Creates a read-only wrapper for a AppenderCollection instance.
Public method | Remove | Removes the first occurrence of a specific IAppender from the AppenderCollection.
Public method | RemoveAt | Removes the element at the specified index of the AppenderCollection.
Public method | ToArray | Return the collection elements as an array
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements.
Back to Top
Fields
Name | Description
EmptyCollection | An empty readonly static AppenderCollection
Back to Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements the AppenderCollection can contain.
Public property | Count | Gets the number of elements actually contained in the AppenderCollection.
Public property | IsFixedSize | Gets a value indicating whether the collection has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public property | Item | Gets or sets the IAppender at the specified index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Back to Top
See Also
AppenderCollection Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection Fields

AppenderCollection Fields Apache log4net™ SDK Documentation
The AppenderCollection type exposes the following members.
Fields
Name | Description
EmptyCollection | An empty readonly static AppenderCollection
Back to Top
See Also
AppenderCollection Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.EmptyCollection Field

AppenderCollection EmptyCollection Field Apache log4net™ SDK Documentation
An empty readonly static AppenderCollection

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly AppenderCollection EmptyCollection
public static readonly AppenderCollection EmptyCollection
Public Shared ReadOnly EmptyCollection As AppenderCollection
Public Shared ReadOnly EmptyCollection As AppenderCollection
public:
static initonly AppenderCollection^ EmptyCollection
public:
static initonly AppenderCollection^ EmptyCollection
Field Value
Type: AppenderCollection
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection Methods

AppenderCollection Methods Apache log4net™ SDK Documentation
The AppenderCollection type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds a IAppender to the end of the AppenderCollection.
Public method | AddRange(ICollection) | Adds the elements of a IAppender collection to the current AppenderCollection.
Public method | AddRange(AppenderCollection) | Adds the elements of another AppenderCollection to the current AppenderCollection.
Public method | AddRange( IAppender ) | Adds the elements of a IAppender array to the current AppenderCollection.
Public method | Clear | Removes all elements from the AppenderCollection.
Public method | Clone | Creates a shallow copy of the AppenderCollection.
Public method | Contains | Determines whether a given IAppender is in the AppenderCollection.
Public method | CopyTo( IAppender ) | Copies the entire AppenderCollection to a one-dimensional IAppender array.
Public method | CopyTo( IAppender , Int32) | Copies the entire AppenderCollection to a one-dimensional IAppender array, starting at the specified index of the target array.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | Returns an enumerator that can iterate through the AppenderCollection.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a IAppender in the AppenderCollection.
Public method | Insert | Inserts an element into the AppenderCollection at the specified index.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ReadOnly | Creates a read-only wrapper for a AppenderCollection instance.
Public method | Remove | Removes the first occurrence of a specific IAppender from the AppenderCollection.
Public method | RemoveAt | Removes the element at the specified index of the AppenderCollection.
Public method | ToArray | Return the collection elements as an array
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements.
Back to Top
See Also
AppenderCollection Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.Add Method

AppenderCollection Add Method Apache log4net™ SDK Documentation
Adds a IAppender to the end of the AppenderCollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Add(
    IAppender item
)
public virtual int Add(
    IAppender item
)
Public Overridable Function Add (
    item As IAppender
) As Integer
Public Overridable Function Add (
    item As IAppender
) As Integer
public:
virtual int Add(
    IAppender^ item
)
public:
virtual int Add(
    IAppender^ item
)
Parameters
item
Type: log4net.Appender IAppender
The IAppender to be added to the end of the AppenderCollection.
Return Value
Type:   Online Int32
The index at which the value has been added.
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.AddRange Method

AppenderCollection AddRange Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | AddRange(ICollection) | Adds the elements of a IAppender collection to the current AppenderCollection.
Public method | AddRange(AppenderCollection) | Adds the elements of another AppenderCollection to the current AppenderCollection.
Public method | AddRange( IAppender ) | Adds the elements of a IAppender array to the current AppenderCollection.
Back to Top
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.AddRange Method (ICollection)

AppenderCollection AddRange Method (ICollection) Apache log4net™ SDK Documentation
Adds the elements of a IAppender collection to the current AppenderCollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int AddRange(
    ICollection col
)
public virtual int AddRange(
    ICollection col
)
Public Overridable Function AddRange (
    col As ICollection
) As Integer
Public Overridable Function AddRange (
    col As ICollection
) As Integer
public:
virtual int AddRange(
    ICollection^ col
)
public:
virtual int AddRange(
    ICollection^ col
)
Parameters
col
Type:   Online System.Collections ICollection
The IAppender collection whose elements should be added to the end of the AppenderCollection.
Return Value
Type:   Online Int32
The new Count of the AppenderCollection.
See Also
AppenderCollection Class
AppenderCollection Members
AddRange Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.AddRange Method (AppenderCollection)

AppenderCollection AddRange Method (AppenderCollection) Apache log4net™ SDK Documentation
Adds the elements of another AppenderCollection to the current AppenderCollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int AddRange(
    AppenderCollection x
)
public virtual int AddRange(
    AppenderCollection x
)
Public Overridable Function AddRange (
    x As AppenderCollection
) As Integer
Public Overridable Function AddRange (
    x As AppenderCollection
) As Integer
public:
virtual int AddRange(
    AppenderCollection^ x
)
public:
virtual int AddRange(
    AppenderCollection^ x
)
Parameters
x
Type: log4net.Appender AppenderCollection
The AppenderCollection whose elements should be added to the end of the current AppenderCollection.
Return Value
Type:   Online Int32
The new Count of the AppenderCollection.
See Also
AppenderCollection Class
AppenderCollection Members
AddRange Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.AddRange Method (IAppender[])

AppenderCollection AddRange Method ( IAppender ) Apache log4net™ SDK Documentation
Adds the elements of a IAppender array to the current AppenderCollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int AddRange(
    IAppender[] x
)
public virtual int AddRange(
    IAppender[] x
)
Public Overridable Function AddRange (
    x As IAppender()
) As Integer
Public Overridable Function AddRange (
    x As IAppender()
) As Integer
public:
virtual int AddRange(
    array<IAppender^>^ x
)
public:
virtual int AddRange(
    array<IAppender^>^ x
)
Parameters
x
Type:  log4net.Appender IAppender
The IAppender array whose elements should be added to the end of the AppenderCollection.
Return Value
Type:   Online Int32
The new Count of the AppenderCollection.
See Also
AppenderCollection Class
AppenderCollection Members
AddRange Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.Clear Method

AppenderCollection Clear Method Apache log4net™ SDK Documentation
Removes all elements from the AppenderCollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Clear()
public virtual void Clear()
Public Overridable Sub Clear
Public Overridable Sub Clear
public:
virtual void Clear()
public:
virtual void Clear()
Implements
  Online IList Clear
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.Clone Method

AppenderCollection Clone Method Apache log4net™ SDK Documentation
Creates a shallow copy of the AppenderCollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Clone()
public virtual Object Clone()
Public Overridable Function Clone As Object
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
public:
virtual Object^ Clone()
Return Value
Type:   Online Object
A new AppenderCollection with a shallow copy of the collection data.
Implements
  Online ICloneable Clone
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.Contains Method

AppenderCollection Contains Method Apache log4net™ SDK Documentation
Determines whether a given IAppender is in the AppenderCollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Contains(
    IAppender item
)
public virtual bool Contains(
    IAppender item
)
Public Overridable Function Contains (
    item As IAppender
) As Boolean
Public Overridable Function Contains (
    item As IAppender
) As Boolean
public:
virtual bool Contains(
    IAppender^ item
)
public:
virtual bool Contains(
    IAppender^ item
)
Parameters
item
Type: log4net.Appender IAppender
The IAppender to check for.
Return Value
Type:   Online Boolean
true if item is found in the AppenderCollection; otherwise, false.
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.CopyTo Method

AppenderCollection CopyTo Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | CopyTo( IAppender ) | Copies the entire AppenderCollection to a one-dimensional IAppender array.
Public method | CopyTo( IAppender , Int32) | Copies the entire AppenderCollection to a one-dimensional IAppender array, starting at the specified index of the target array.
Back to Top
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.CopyTo Method (IAppender[])

AppenderCollection CopyTo Method ( IAppender ) Apache log4net™ SDK Documentation
Copies the entire AppenderCollection to a one-dimensional IAppender array.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void CopyTo(
    IAppender[] array
)
public virtual void CopyTo(
    IAppender[] array
)
Public Overridable Sub CopyTo (
    array As IAppender()
)
Public Overridable Sub CopyTo (
    array As IAppender()
)
public:
virtual void CopyTo(
    array<IAppender^>^ array
)
public:
virtual void CopyTo(
    array<IAppender^>^ array
)
Parameters
array
Type:  log4net.Appender IAppender
The one-dimensional IAppender array to copy to.
See Also
AppenderCollection Class
AppenderCollection Members
CopyTo Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.CopyTo Method (IAppender[], Int32)

AppenderCollection CopyTo Method ( IAppender , Int32) Apache log4net™ SDK Documentation
Copies the entire AppenderCollection to a one-dimensional IAppender array, starting at the specified index of the target array.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void CopyTo(
    IAppender[] array,
    int start
)
public virtual void CopyTo(
    IAppender[] array,
    int start
)
Public Overridable Sub CopyTo (
    array As IAppender(),
    start As Integer
)
Public Overridable Sub CopyTo (
    array As IAppender(),
    start As Integer
)
public:
virtual void CopyTo(
    array<IAppender^>^ array,
    int start
)
public:
virtual void CopyTo(
    array<IAppender^>^ array,
    int start
)
Parameters
array
Type:  log4net.Appender IAppender
The one-dimensional IAppender array to copy to.
start
Type:   Online System Int32
The zero-based index in array at which copying begins.
See Also
AppenderCollection Class
AppenderCollection Members
CopyTo Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.GetEnumerator Method

AppenderCollection GetEnumerator Method Apache log4net™ SDK Documentation
Returns an enumerator that can iterate through the AppenderCollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IAppenderCollectionEnumerator GetEnumerator()
public virtual IAppenderCollectionEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IAppenderCollectionEnumerator
Public Overridable Function GetEnumerator As IAppenderCollectionEnumerator
public:
virtual IAppenderCollectionEnumerator^ GetEnumerator()
public:
virtual IAppenderCollectionEnumerator^ GetEnumerator()
Return Value
Type: IAppenderCollectionEnumerator
An Enumerator for the entire AppenderCollection.
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.IndexOf Method

AppenderCollection IndexOf Method Apache log4net™ SDK Documentation
Returns the zero-based index of the first occurrence of a IAppender in the AppenderCollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int IndexOf(
    IAppender item
)
public virtual int IndexOf(
    IAppender item
)
Public Overridable Function IndexOf (
    item As IAppender
) As Integer
Public Overridable Function IndexOf (
    item As IAppender
) As Integer
public:
virtual int IndexOf(
    IAppender^ item
)
public:
virtual int IndexOf(
    IAppender^ item
)
Parameters
item
Type: log4net.Appender IAppender
The IAppender to locate in the AppenderCollection.
Return Value
Type:   Online Int32

            The zero-based index of the first occurrence of item
            in the entire AppenderCollection, if found; otherwise, -1.

See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.Insert Method

AppenderCollection Insert Method Apache log4net™ SDK Documentation
Inserts an element into the AppenderCollection at the specified index.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Insert(
    int index,
    IAppender item
)
public virtual void Insert(
    int index,
    IAppender item
)
Public Overridable Sub Insert (
    index As Integer,
    item As IAppender
)
Public Overridable Sub Insert (
    index As Integer,
    item As IAppender
)
public:
virtual void Insert(
    int index,
    IAppender^ item
)
public:
virtual void Insert(
    int index,
    IAppender^ item
)
Parameters
index
Type:   Online System Int32
The zero-based index at which item should be inserted.
item
Type: log4net.Appender IAppender
The IAppender to insert.
Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.ReadOnly Method

AppenderCollection ReadOnly Method Apache log4net™ SDK Documentation
Creates a read-only wrapper for a AppenderCollection instance.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static AppenderCollection ReadOnly(
    AppenderCollection list
)
public static AppenderCollection ReadOnly(
    AppenderCollection list
)
Public Shared Function ReadOnly (
    list As AppenderCollection
) As AppenderCollection
Public Shared Function ReadOnly (
    list As AppenderCollection
) As AppenderCollection
public:
static AppenderCollection^ ReadOnly(
    AppenderCollection^ list
)
public:
static AppenderCollection^ ReadOnly(
    AppenderCollection^ list
)
Parameters
list
Type: log4net.Appender AppenderCollection
list to create a readonly wrapper arround
Return Value
Type: AppenderCollection

            An AppenderCollection wrapper that is read-only.

See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.Remove Method

AppenderCollection Remove Method Apache log4net™ SDK Documentation
Removes the first occurrence of a specific IAppender from the AppenderCollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Remove(
    IAppender item
)
public virtual void Remove(
    IAppender item
)
Public Overridable Sub Remove (
    item As IAppender
)
Public Overridable Sub Remove (
    item As IAppender
)
public:
virtual void Remove(
    IAppender^ item
)
public:
virtual void Remove(
    IAppender^ item
)
Parameters
item
Type: log4net.Appender IAppender
The IAppender to remove from the AppenderCollection.
Exceptions
Exception | Condition
Online System ArgumentException | The specified IAppender was not found in the AppenderCollection.
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.RemoveAt Method

AppenderCollection RemoveAt Method Apache log4net™ SDK Documentation
Removes the element at the specified index of the AppenderCollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void RemoveAt(
    int index
)
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)
Public Overridable Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
)
public:
virtual void RemoveAt(
    int index
)
Parameters
index
Type:   Online System Int32
The zero-based index of the element to remove.
Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.ToArray Method

AppenderCollection ToArray Method Apache log4net™ SDK Documentation
Return the collection elements as an array

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IAppender[] ToArray()
public virtual IAppender[] ToArray()
Public Overridable Function ToArray As IAppender()
Public Overridable Function ToArray As IAppender()
public:
virtual array<IAppender^>^ ToArray()
public:
virtual array<IAppender^>^ ToArray()
Return Value
Type:  IAppender
the array
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.TrimToSize Method

AppenderCollection TrimToSize Method Apache log4net™ SDK Documentation
Sets the capacity to the actual number of elements.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void TrimToSize()
public virtual void TrimToSize()
Public Overridable Sub TrimToSize
Public Overridable Sub TrimToSize
public:
virtual void TrimToSize()
public:
virtual void TrimToSize()
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection Properties

AppenderCollection Properties Apache log4net™ SDK Documentation
The AppenderCollection type exposes the following members.
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements the AppenderCollection can contain.
Public property | Count | Gets the number of elements actually contained in the AppenderCollection.
Public property | IsFixedSize | Gets a value indicating whether the collection has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public property | Item | Gets or sets the IAppender at the specified index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Back to Top
See Also
AppenderCollection Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.Capacity Property

AppenderCollection Capacity Property Apache log4net™ SDK Documentation
Gets or sets the number of elements the AppenderCollection can contain.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Capacity { get; set; }
public virtual int Capacity { get; set; }
Public Overridable Property Capacity As Integer
    Get
    Set
Public Overridable Property Capacity As Integer
    Get
    Set
public:
virtual property int Capacity {
    int get ();
    void set (int value);
}
public:
virtual property int Capacity {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.Count Property

AppenderCollection Count Property Apache log4net™ SDK Documentation
Gets the number of elements actually contained in the AppenderCollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Count { get; }
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
public:
virtual property int Count {
    int get ();
}
Property Value
Type:   Online Int32
Implements
  Online ICollection Count
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.IsFixedSize Property

AppenderCollection IsFixedSize Property Apache log4net™ SDK Documentation
Gets a value indicating whether the collection has a fixed size.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsFixedSize { get; }
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}
public:
virtual property bool IsFixedSize {
    bool get ();
}
Property Value
Type:   Online Boolean
true if the collection has a fixed size; otherwise, false. The default is false
Implements
  Online IList IsFixedSize
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.IsReadOnly Property

AppenderCollection IsReadOnly Property Apache log4net™ SDK Documentation
Gets a value indicating whether the IList is read-only.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsReadOnly { get; }
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}
public:
virtual property bool IsReadOnly {
    bool get ();
}
Property Value
Type:   Online Boolean
true if the collection is read-only; otherwise, false. The default is false
Implements
  Online IList IsReadOnly
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.IsSynchronized Property

AppenderCollection IsSynchronized Property Apache log4net™ SDK Documentation
Gets a value indicating whether access to the collection is synchronized (thread-safe).

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsSynchronized { get; }
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}
public:
virtual property bool IsSynchronized {
    bool get ();
}
Return Value
Type:   Online Boolean
true if access to the ICollection is synchronized (thread-safe); otherwise, false.
Implements
  Online ICollection IsSynchronized
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.Item Property

AppenderCollection Item Property Apache log4net™ SDK Documentation
Gets or sets the IAppender at the specified index.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IAppender this[
    int index
] { get; set; }
public virtual IAppender this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As IAppender
    Get
    Set
Public Overridable Default Property Item (
    index As Integer
) As IAppender
    Get
    Set
public:
virtual property IAppender^ default[int index] {
    IAppender^ get (int index);
    void set (int index, IAppender^ value);
}
public:
virtual property IAppender^ default[int index] {
    IAppender^ get (int index);
    void set (int index, IAppender^ value);
}
Parameters
index
Type:   Online System Int32
The zero-based index of the element to get or set.
Property Value
Type: IAppender
Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderCollection.SyncRoot Property

AppenderCollection SyncRoot Property Apache log4net™ SDK Documentation
Gets an object that can be used to synchronize access to the collection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object SyncRoot { get; }
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}
Property Value
Type:   Online Object
Implements
  Online ICollection SyncRoot
See Also
AppenderCollection Class
AppenderCollection Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton Class

AppenderSkeleton Class Apache log4net™ SDK Documentation
Abstract base class implementation of IAppender.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender AnsiColorTerminalAppender
log4net.Appender AspNetTraceAppender
log4net.Appender BufferingAppenderSkeleton
log4net.Appender ColoredConsoleAppender
log4net.Appender ConsoleAppender
log4net.Appender DebugAppender
log4net.Appender EventLogAppender
log4net.Appender ForwardingAppender
log4net.Appender LocalSyslogAppender
log4net.Appender ManagedColoredConsoleAppender
log4net.Appender MemoryAppender
log4net.Appender NetSendAppender
log4net.Appender OutputDebugStringAppender
log4net.Appender TelnetAppender
log4net.Appender TextWriterAppender
log4net.Appender TraceAppender
log4net.Appender UdpAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class AppenderSkeleton : IBulkAppender,
    IAppender, IOptionHandler
public abstract class AppenderSkeleton : IBulkAppender,
    IAppender, IOptionHandler
Public MustInherit Class AppenderSkeleton
    Implements IBulkAppender, IAppender, IOptionHandler
Public MustInherit Class AppenderSkeleton
    Implements IBulkAppender, IAppender, IOptionHandler
public ref class AppenderSkeleton abstract : IBulkAppender,
    IAppender, IOptionHandler
public ref class AppenderSkeleton abstract : IBulkAppender,
    IAppender, IOptionHandler
Remarks

            This class provides the code for common functionality, such
            as support for threshold filtering and support for general filters.

            Appenders can also implement the IOptionHandler interface. Therefore
            they would require that the [M:IOptionHandler.ActivateOptions()] method
            be called after the appenders properties have been configured.

See Also
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton Members

AppenderSkeleton Members Apache log4net™ SDK Documentation
The AppenderSkeleton type exposes the following members.
Constructors
 | Name | Description
Protected method | AppenderSkeleton | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set
Public method | AddFilter | Adds a filter to the end of the filter chain.
Protected method | Append(LoggingEvent) | Subclasses of AppenderSkeleton should implement this method to perform actual logging.
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events.
Public method | ClearFilters | Clears the filter list for this appender.
Public method | Close | Closes the appender and release resources.
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method.
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Overrides Online Object Finalize .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released.
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition.
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string.
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender.
Public property | FilterHead | The filter chain.
Public property | Layout | Gets or sets the ILayout for this appender.
Public property | Name | Gets or sets the name of this appender.
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set.
Public property | Threshold | Gets or sets the threshold Level of this appender.
Back to Top
See Also
AppenderSkeleton Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton Constructor

AppenderSkeleton Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AppenderSkeleton()
protected AppenderSkeleton()
Protected Sub New
Protected Sub New
protected:
AppenderSkeleton()
protected:
AppenderSkeleton()
Remarks
Empty default constructor
See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton Methods

AppenderSkeleton Methods Apache log4net™ SDK Documentation
The AppenderSkeleton type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set
Public method | AddFilter | Adds a filter to the end of the filter chain.
Protected method | Append(LoggingEvent) | Subclasses of AppenderSkeleton should implement this method to perform actual logging.
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events.
Public method | ClearFilters | Clears the filter list for this appender.
Public method | Close | Closes the appender and release resources.
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method.
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Overrides Online Object Finalize .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released.
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition.
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string.
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AppenderSkeleton Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.ActivateOptions Method

AppenderSkeleton ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the appender based on the options set

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ActivateOptions()
public virtual void ActivateOptions()
Public Overridable Sub ActivateOptions
Public Overridable Sub ActivateOptions
public:
virtual void ActivateOptions()
public:
virtual void ActivateOptions()
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.AddFilter Method

AppenderSkeleton AddFilter Method Apache log4net™ SDK Documentation
Adds a filter to the end of the filter chain.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddFilter(
    IFilter filter
)
public virtual void AddFilter(
    IFilter filter
)
Public Overridable Sub AddFilter (
    filter As IFilter
)
Public Overridable Sub AddFilter (
    filter As IFilter
)
public:
virtual void AddFilter(
    IFilter^ filter
)
public:
virtual void AddFilter(
    IFilter^ filter
)
Parameters
filter
Type: log4net.Filter IFilter
the filter to add to this appender
Remarks

            The Filters are organized in a linked list.

            Setting this property causes the new filter to be pushed onto the
            back of the filter chain.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.Append Method

AppenderSkeleton Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append(LoggingEvent) | Subclasses of AppenderSkeleton should implement this method to perform actual logging.
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events.
Back to Top
See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.Append Method (LoggingEvent)

AppenderSkeleton Append Method (LoggingEvent) Apache log4net™ SDK Documentation
Subclasses of AppenderSkeleton should implement this method to perform actual logging.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Append(
    LoggingEvent loggingEvent
)
protected abstract void Append(
    LoggingEvent loggingEvent
)
Protected MustOverride Sub Append (
    loggingEvent As LoggingEvent
)
Protected MustOverride Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) abstract
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) abstract
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to append.
Remarks

            A subclass must implement this method to perform
            logging of the loggingEvent.

This method will be called by [M:DoAppend(LoggingEvent)]
            if all the conditions listed for that method are met.

            To restrict the logging of events in the appender
            override the [M:PreAppendCheck()] method.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.Append Method (LoggingEvent[])

AppenderSkeleton Append Method ( LoggingEvent ) Apache log4net™ SDK Documentation
Append a bulk array of logging events.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void Append(
    LoggingEvent[] loggingEvents
)
protected virtual void Append(
    LoggingEvent[] loggingEvents
)
Protected Overridable Sub Append (
    loggingEvents As LoggingEvent()
)
Protected Overridable Sub Append (
    loggingEvents As LoggingEvent()
)
protected:
virtual void Append(
    array<LoggingEvent^>^ loggingEvents
)
protected:
virtual void Append(
    array<LoggingEvent^>^ loggingEvents
)
Parameters
loggingEvents
Type:  log4net.Core LoggingEvent
the array of logging events
Remarks

            This base class implementation calls the [M:Append(LoggingEvent)]
            method for each element in the bulk array.

            A sub class that can better process a bulk array of events should
            override this method in addition to [M:Append(LoggingEvent)].

See Also
AppenderSkeleton Class
AppenderSkeleton Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.ClearFilters Method

AppenderSkeleton ClearFilters Method Apache log4net™ SDK Documentation
Clears the filter list for this appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ClearFilters()
public virtual void ClearFilters()
Public Overridable Sub ClearFilters
Public Overridable Sub ClearFilters
public:
virtual void ClearFilters()
public:
virtual void ClearFilters()
Remarks

            Clears the filter list for this appender.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.Close Method

AppenderSkeleton Close Method Apache log4net™ SDK Documentation
Closes the appender and release resources.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Close()
public void Close()
Public Sub Close
Public Sub Close
public:
virtual void Close() sealed
public:
virtual void Close() sealed
Implements
IAppender Close
Remarks

            Release any resources allocated within the appender such as file handles,
            network connections, etc.

            It is a programming error to append to a closed appender.

            This method cannot be overridden by subclasses. This method
            delegates the closing of the appender to the OnClose
            method which must be overridden in the subclass.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.DoAppend Method

AppenderSkeleton DoAppend Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method.
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method.
Back to Top
See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.DoAppend Method (LoggingEvent)

AppenderSkeleton DoAppend Method (LoggingEvent) Apache log4net™ SDK Documentation
Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DoAppend(
    LoggingEvent loggingEvent
)
public void DoAppend(
    LoggingEvent loggingEvent
)
Public Sub DoAppend (
    loggingEvent As LoggingEvent
)
Public Sub DoAppend (
    loggingEvent As LoggingEvent
)
public:
virtual void DoAppend(
    LoggingEvent^ loggingEvent
) sealed
public:
virtual void DoAppend(
    LoggingEvent^ loggingEvent
) sealed
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Implements
IAppender DoAppend(LoggingEvent)
Remarks

            This method cannot be overridden by derived classes. A
            derived class should override the [M:Append(LoggingEvent)] method
            which is called by this method.

            The implementation of this method is as follows:

  •
                    Checks that the severity of the loggingEvent
                    is greater than or equal to the Threshold of this
                    appender.
  •
                    Checks that the IFilter chain accepts the
                    loggingEvent.

  •
                    Calls [M:PreAppendCheck()] and checks that
                    it returns true.

            If all of the above steps succeed then the loggingEvent
            will be passed to the abstract [M:Append(LoggingEvent)] method.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
DoAppend Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.DoAppend Method (LoggingEvent[])

AppenderSkeleton DoAppend Method ( LoggingEvent ) Apache log4net™ SDK Documentation
Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DoAppend(
    LoggingEvent[] loggingEvents
)
public void DoAppend(
    LoggingEvent[] loggingEvents
)
Public Sub DoAppend (
    loggingEvents As LoggingEvent()
)
Public Sub DoAppend (
    loggingEvents As LoggingEvent()
)
public:
virtual void DoAppend(
    array<LoggingEvent^>^ loggingEvents
) sealed
public:
virtual void DoAppend(
    array<LoggingEvent^>^ loggingEvents
) sealed
Parameters
loggingEvents
Type:  log4net.Core LoggingEvent
The array of events to log.
Implements
IBulkAppender DoAppend( LoggingEvent )
Remarks

            This method cannot be overridden by derived classes. A
            derived class should override the [M:Append(LoggingEvent[])] method
            which is called by this method.

            The implementation of this method is as follows:

  •
                    Checks that the severity of the loggingEvents
                    is greater than or equal to the Threshold of this
                    appender.
  •
                    Checks that the IFilter chain accepts the
                    loggingEvents.

  •
                    Calls [M:PreAppendCheck()] and checks that
                    it returns true.

            If all of the above steps succeed then the loggingEvents
            will be passed to the [M:Append(LoggingEvent[])] method.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
DoAppend Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.FilterEvent Method

AppenderSkeleton FilterEvent Method Apache log4net™ SDK Documentation
Test if the logging event should we output by this appender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool FilterEvent(
    LoggingEvent loggingEvent
)
protected virtual bool FilterEvent(
    LoggingEvent loggingEvent
)
Protected Overridable Function FilterEvent (
    loggingEvent As LoggingEvent
) As Boolean
Protected Overridable Function FilterEvent (
    loggingEvent As LoggingEvent
) As Boolean
protected:
virtual bool FilterEvent(
    LoggingEvent^ loggingEvent
)
protected:
virtual bool FilterEvent(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the event to test
Return Value
Type:   Online Boolean
true if the event should be output, false if the event should be ignored
Remarks

            This method checks the logging event against the threshold level set
            on this appender and also against the filters specified on this
            appender.

            The implementation of this method is as follows:

  •
                    Checks that the severity of the loggingEvent
                    is greater than or equal to the Threshold of this
                    appender.
  •
                    Checks that the IFilter chain accepts the
                    loggingEvent.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.Finalize Method

AppenderSkeleton Finalize Method Apache log4net™ SDK Documentation
Finalizes this appender by calling the implementation's Close method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Finalize()
protected override void Finalize()
Protected Overrides Sub Finalize
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
protected:
virtual void Finalize() override
Remarks

            If this appender has not been closed then the Finalize method
            will call Close .

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.IsAsSevereAsThreshold Method

AppenderSkeleton IsAsSevereAsThreshold Method Apache log4net™ SDK Documentation
Checks if the message level is below this appender's threshold.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool IsAsSevereAsThreshold(
    Level level
)
protected virtual bool IsAsSevereAsThreshold(
    Level level
)
Protected Overridable Function IsAsSevereAsThreshold (
    level As Level
) As Boolean
Protected Overridable Function IsAsSevereAsThreshold (
    level As Level
) As Boolean
protected:
virtual bool IsAsSevereAsThreshold(
    Level^ level
)
protected:
virtual bool IsAsSevereAsThreshold(
    Level^ level
)
Parameters
level
Type: log4net.Core Level
Level to test against.
Return Value
Type:   Online Boolean
true if the level meets the Threshold
            requirements of this appender.

Remarks

            If there is no threshold set, then the return value is always true.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.OnClose Method

AppenderSkeleton OnClose Method Apache log4net™ SDK Documentation
Is called when the appender is closed. Derived classes should override this method if resources need to be released.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void OnClose()
protected virtual void OnClose()
Protected Overridable Sub OnClose
Protected Overridable Sub OnClose
protected:
virtual void OnClose()
protected:
virtual void OnClose()
Remarks

            Releases any resources allocated within the appender such as file handles,
            network connections, etc.

            It is a programming error to append to a closed appender.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.PreAppendCheck Method

AppenderSkeleton PreAppendCheck Method Apache log4net™ SDK Documentation
Called before [M:Append(LoggingEvent)] as a precondition.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool PreAppendCheck()
protected virtual bool PreAppendCheck()
Protected Overridable Function PreAppendCheck As Boolean
Protected Overridable Function PreAppendCheck As Boolean
protected:
virtual bool PreAppendCheck()
protected:
virtual bool PreAppendCheck()
Return Value
Type:   Online Boolean
true if the call to [M:Append(LoggingEvent)] should proceed.
Remarks

            This method is called by [M:DoAppend(LoggingEvent)]
            before the call to the abstract [M:Append(LoggingEvent)] method.

            This method can be overridden in a subclass to extend the checks
            made before the event is passed to the [M:Append(LoggingEvent)] method.

            A subclass should ensure that they delegate this call to
            this base class if it is overridden.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.RenderLoggingEvent Method

AppenderSkeleton RenderLoggingEvent Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string.
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string.
Back to Top
See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.RenderLoggingEvent Method (LoggingEvent)

AppenderSkeleton RenderLoggingEvent Method (LoggingEvent) Apache log4net™ SDK Documentation
Renders the LoggingEvent to a string.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string RenderLoggingEvent(
    LoggingEvent loggingEvent
)
protected string RenderLoggingEvent(
    LoggingEvent loggingEvent
)
Protected Function RenderLoggingEvent (
    loggingEvent As LoggingEvent
) As String
Protected Function RenderLoggingEvent (
    loggingEvent As LoggingEvent
) As String
protected:
String^ RenderLoggingEvent(
    LoggingEvent^ loggingEvent
)
protected:
String^ RenderLoggingEvent(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to render.
Return Value
Type:   Online String
The event rendered as a string.
Remarks

            Helper method to render a LoggingEvent to
            a string. This appender must have a Layout
            set to render the loggingEvent to
            a string.

If there is exception data in the logging event and
            the layout does not process the exception, this method
            will append the exception text to the rendered string.

            Where possible use the alternative version of this method
            [M:RenderLoggingEvent(TextWriter,LoggingEvent)].
            That method streams the rendering onto an existing Writer
            which can give better performance if the caller already has
            a   Online TextWriter open and ready for writing.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
RenderLoggingEvent Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.RenderLoggingEvent Method (TextWriter, LoggingEvent)

AppenderSkeleton RenderLoggingEvent Method (TextWriter, LoggingEvent) Apache log4net™ SDK Documentation
Renders the LoggingEvent to a string.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void RenderLoggingEvent(
    TextWriter writer,
    LoggingEvent loggingEvent
)
protected void RenderLoggingEvent(
    TextWriter writer,
    LoggingEvent loggingEvent
)
Protected Sub RenderLoggingEvent (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
Protected Sub RenderLoggingEvent (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
protected:
void RenderLoggingEvent(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
)
protected:
void RenderLoggingEvent(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
)
Parameters
writer
Type:   Online System.IO TextWriter
The TextWriter to write the formatted event to
loggingEvent
Type: log4net.Core LoggingEvent
The event to render.
Remarks

            Helper method to render a LoggingEvent to
            a string. This appender must have a Layout
            set to render the loggingEvent to
            a string.

If there is exception data in the logging event and
            the layout does not process the exception, this method
            will append the exception text to the rendered string.

            Use this method in preference to [M:RenderLoggingEvent(LoggingEvent)]
            where possible. If, however, the caller needs to render the event
            to a string then [M:RenderLoggingEvent(LoggingEvent)] does
            provide an efficient mechanism for doing so.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
RenderLoggingEvent Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton Properties

AppenderSkeleton Properties Apache log4net™ SDK Documentation
The AppenderSkeleton type exposes the following members.
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender.
Public property | FilterHead | The filter chain.
Public property | Layout | Gets or sets the ILayout for this appender.
Public property | Name | Gets or sets the name of this appender.
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set.
Public property | Threshold | Gets or sets the threshold Level of this appender.
Back to Top
See Also
AppenderSkeleton Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.ErrorHandler Property

AppenderSkeleton ErrorHandler Property Apache log4net™ SDK Documentation
Gets or sets the IErrorHandler for this appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IErrorHandler ErrorHandler { get; set; }
public virtual IErrorHandler ErrorHandler { get; set; }
Public Overridable Property ErrorHandler As IErrorHandler
    Get
    Set
Public Overridable Property ErrorHandler As IErrorHandler
    Get
    Set
public:
virtual property IErrorHandler^ ErrorHandler {
    IErrorHandler^ get ();
    void set (IErrorHandler^ value);
}
public:
virtual property IErrorHandler^ ErrorHandler {
    IErrorHandler^ get ();
    void set (IErrorHandler^ value);
}
Property Value
Type: IErrorHandler
The IErrorHandler of the appender
Remarks

            The AppenderSkeleton provides a default
            implementation for the ErrorHandler property.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.FilterHead Property

AppenderSkeleton FilterHead Property Apache log4net™ SDK Documentation
The filter chain.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IFilter FilterHead { get; }
public virtual IFilter FilterHead { get; }
Public Overridable ReadOnly Property FilterHead As IFilter
    Get
Public Overridable ReadOnly Property FilterHead As IFilter
    Get
public:
virtual property IFilter^ FilterHead {
    IFilter^ get ();
}
public:
virtual property IFilter^ FilterHead {
    IFilter^ get ();
}
Property Value
Type: IFilter
The head of the filter chain filter chain.
Remarks

            Returns the head Filter. The Filters are organized in a linked list
            and so all Filters on this Appender are available through the result.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.Layout Property

AppenderSkeleton Layout Property Apache log4net™ SDK Documentation
Gets or sets the ILayout for this appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ILayout Layout { get; set; }
public virtual ILayout Layout { get; set; }
Public Overridable Property Layout As ILayout
    Get
    Set
Public Overridable Property Layout As ILayout
    Get
    Set
public:
virtual property ILayout^ Layout {
    ILayout^ get ();
    void set (ILayout^ value);
}
public:
virtual property ILayout^ Layout {
    ILayout^ get ();
    void set (ILayout^ value);
}
Property Value
Type: ILayout
The layout of the appender.
Remarks

            See RequiresLayout for more information.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
AppenderSkeleton RequiresLayout
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.Name Property

AppenderSkeleton Name Property Apache log4net™ SDK Documentation
Gets or sets the name of this appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Property Value
Type:   Online String
The name of the appender.
Implements
IAppender Name
Remarks

            The name uniquely identifies the appender.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.RequiresLayout Property

AppenderSkeleton RequiresLayout Property Apache log4net™ SDK Documentation
Tests if this appender requires a Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool RequiresLayout { get; }
protected virtual bool RequiresLayout { get; }
Protected Overridable ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overridable ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get ();
}
protected:
virtual property bool RequiresLayout {
    bool get ();
}
Return Value
Type:   Online Boolean
true if the appender requires a layout object, otherwise false.

Remarks

            In the rather exceptional case, where the appender
            implementation admits a layout but can also work without it,
            then the appender should return true.

            This default implementation always returns false.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderSkeleton.Threshold Property

AppenderSkeleton Threshold Property Apache log4net™ SDK Documentation
Gets or sets the threshold Level of this appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level Threshold { get; set; }
public Level Threshold { get; set; }
Public Property Threshold As Level
    Get
    Set
Public Property Threshold As Level
    Get
    Set
public:
property Level^ Threshold {
    Level^ get ();
    void set (Level^ value);
}
public:
property Level^ Threshold {
    Level^ get ();
    void set (Level^ value);
}
Property Value
Type: Level

            The threshold Level of the appender.

Remarks

            All log events with lower level than the threshold level are ignored
            by the appender.

            In configuration files this option is specified by setting the
            value of the Threshold option to a level
            string, such as "DEBUG", "INFO" and so on.

See Also
AppenderSkeleton Class
AppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AspNetTraceAppender Class

AspNetTraceAppender Class Apache log4net™ SDK Documentation

Appends log events to the ASP.NET Online TraceContext system.

Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender AspNetTraceAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AspNetTraceAppender : AppenderSkeleton
public class AspNetTraceAppender : AppenderSkeleton
Public Class AspNetTraceAppender
    Inherits AppenderSkeleton
Public Class AspNetTraceAppender
    Inherits AppenderSkeleton
public ref class AspNetTraceAppender : public AppenderSkeleton
public ref class AspNetTraceAppender : public AppenderSkeleton
Remarks

            Diagnostic information and tracing messages that you specify are appended to the output
            of the page that is sent to the requesting browser. Optionally, you can view this information
            from a separate trace viewer (Trace.axd) that displays trace information for every page in a
            given application.

            Trace statements are processed and displayed only when tracing is enabled. You can control
            whether tracing is displayed to a page, to the trace viewer, or both.

            The logging event is passed to the Write(string) or
            Warn(string) method depending on the level of the logging event.
            The event's logger name is the default value for the category parameter of the Write/Warn method.

See Also
AspNetTraceAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AspNetTraceAppender Members

AspNetTraceAppender Members Apache log4net™ SDK Documentation
The AspNetTraceAppender type exposes the following members.
Constructors
 | Name | Description
Public method | AspNetTraceAppender | Initializes a new instance of the AspNetTraceAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Write the logging event to the ASP.NET trace (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Category | The category parameter sent to the Trace method.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
AspNetTraceAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AspNetTraceAppender Constructor

AspNetTraceAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the AspNetTraceAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AspNetTraceAppender()
public AspNetTraceAppender()
Public Sub New
Public Sub New
public:
AspNetTraceAppender()
public:
AspNetTraceAppender()
Remarks

            Default constructor.

See Also
AspNetTraceAppender Class
AspNetTraceAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AspNetTraceAppender Methods

AspNetTraceAppender Methods Apache log4net™ SDK Documentation
The AspNetTraceAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Write the logging event to the ASP.NET trace (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AspNetTraceAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AspNetTraceAppender.Append Method

AspNetTraceAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Write the logging event to the ASP.NET trace (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
AspNetTraceAppender Class
AspNetTraceAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AspNetTraceAppender.Append Method (LoggingEvent)

AspNetTraceAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
Write the logging event to the ASP.NET trace

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the event to log
Remarks

            Write the logging event to the ASP.NET trace
            HttpContext.Current.Trace
            (  Online TraceContext).

See Also
AspNetTraceAppender Class
AspNetTraceAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AspNetTraceAppender Properties

AspNetTraceAppender Properties Apache log4net™ SDK Documentation
The AspNetTraceAppender type exposes the following members.
Properties
 | Name | Description
Public property | Category | The category parameter sent to the Trace method.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
AspNetTraceAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AspNetTraceAppender.Category Property

AspNetTraceAppender Category Property Apache log4net™ SDK Documentation
The category parameter sent to the Trace method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PatternLayout Category { get; set; }
public PatternLayout Category { get; set; }
Public Property Category As PatternLayout
    Get
    Set
Public Property Category As PatternLayout
    Get
    Set
public:
property PatternLayout^ Category {
    PatternLayout^ get ();
    void set (PatternLayout^ value);
}
public:
property PatternLayout^ Category {
    PatternLayout^ get ();
    void set (PatternLayout^ value);
}
Property Value
Type: PatternLayout
Remarks

            Defaults to %logger which will use the logger name of the current
            LoggingEvent as the category parameter.

See Also
AspNetTraceAppender Class
AspNetTraceAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AspNetTraceAppender.RequiresLayout Property

AspNetTraceAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
AspNetTraceAppender Class
AspNetTraceAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton Class

BufferingAppenderSkeleton Class Apache log4net™ SDK Documentation
Abstract base class implementation of IAppender that buffers events in a fixed size buffer.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender BufferingAppenderSkeleton
log4net.Appender AdoNetAppender
log4net.Appender BufferingForwardingAppender
log4net.Appender RemotingAppender
log4net.Appender SmtpAppender
log4net.Appender SmtpPickupDirAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class BufferingAppenderSkeleton : AppenderSkeleton
public abstract class BufferingAppenderSkeleton : AppenderSkeleton
Public MustInherit Class BufferingAppenderSkeleton
    Inherits AppenderSkeleton
Public MustInherit Class BufferingAppenderSkeleton
    Inherits AppenderSkeleton
public ref class BufferingAppenderSkeleton abstract : public AppenderSkeleton
public ref class BufferingAppenderSkeleton abstract : public AppenderSkeleton
Remarks

            This base class should be used by appenders that need to buffer a
            number of events before logging them. For example the AdoNetAppender
            buffers events and then submits the entire contents of the buffer to
            the underlying database in one go.

            Subclasses should override the [M:SendBuffer(LoggingEvent[])]
            method to deliver the buffered events.

The BufferingAppenderSkeleton maintains a fixed size cyclic
            buffer of events. The size of the buffer is set using
            the BufferSize property.

A ITriggeringEventEvaluator is used to inspect
            each event as it arrives in the appender. If the Evaluator
            triggers, then the current buffer is sent immediately
            (see [M:SendBuffer(LoggingEvent[])]). Otherwise the event
            is stored in the buffer. For example, an evaluator can be used to
            deliver the events immediately when an ERROR event arrives.

            The buffering appender can be configured in a Lossy mode.
            By default the appender is NOT lossy. When the buffer is full all
            the buffered events are sent with [M:SendBuffer(LoggingEvent[])].
            If the Lossy property is set to true then the
            buffer will not be sent when it is full, and new events arriving
            in the appender will overwrite the oldest event in the buffer.
            In lossy mode the buffer will only be sent when the Evaluator
            triggers. This can be useful behavior when you need to know about
            ERROR events but not about events with a lower level, configure an
            evaluator that will trigger when an ERROR event arrives, the whole
            buffer will be sent which gives a history of events leading up to
            the ERROR event.

See Also
BufferingAppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton Members

BufferingAppenderSkeleton Members Apache log4net™ SDK Documentation
The BufferingAppenderSkeleton type exposes the following members.
Constructors
 | Name | Description
Protected method | BufferingAppenderSkeleton | Initializes a new instance of the BufferingAppenderSkeleton class.
Protected method | BufferingAppenderSkeleton(Boolean) | Initializes a new instance of the BufferingAppenderSkeleton class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Flush | Flush the currently buffered events
Public method | Flush(Boolean) | Flush the currently buffered events
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Close this appender instance. (Overrides AppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | SendBuffer | Sends the events.
Protected method | SendFromBuffer | Sends the contents of the buffer.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | BufferSize | Gets or sets the size of the cyclic buffer used to hold the logging events.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Evaluator | Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately.
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets a the fields that will be fixed in the event
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Lossy | Gets or sets a value that indicates whether the appender is lossy.
Public property | LossyEvaluator | Gets or sets the value of the ITriggeringEventEvaluator to use.
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating if only part of the logging event data should be fixed.
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set. (Inherited from AppenderSkeleton.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
BufferingAppenderSkeleton Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton Constructor

BufferingAppenderSkeleton Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | BufferingAppenderSkeleton | Initializes a new instance of the BufferingAppenderSkeleton class.
Protected method | BufferingAppenderSkeleton(Boolean) | Initializes a new instance of the BufferingAppenderSkeleton class.
Back to Top
See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton Constructor

BufferingAppenderSkeleton Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the BufferingAppenderSkeleton class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BufferingAppenderSkeleton()
protected BufferingAppenderSkeleton()
Protected Sub New
Protected Sub New
protected:
BufferingAppenderSkeleton()
protected:
BufferingAppenderSkeleton()
Remarks

            Protected default constructor to allow subclassing.

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
BufferingAppenderSkeleton Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton Constructor (Boolean)

BufferingAppenderSkeleton Constructor (Boolean) Apache log4net™ SDK Documentation
Initializes a new instance of the BufferingAppenderSkeleton class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BufferingAppenderSkeleton(
    bool eventMustBeFixed
)
protected BufferingAppenderSkeleton(
    bool eventMustBeFixed
)
Protected Sub New (
    eventMustBeFixed As Boolean
)
Protected Sub New (
    eventMustBeFixed As Boolean
)
protected:
BufferingAppenderSkeleton(
    bool eventMustBeFixed
)
protected:
BufferingAppenderSkeleton(
    bool eventMustBeFixed
)
Parameters
eventMustBeFixed
Type:   Online System Boolean
the events passed through this appender must be
            fixed by the time that they arrive in the derived class' SendBuffer method.
Remarks

            Protected constructor to allow subclassing.

            The eventMustBeFixed should be set if the subclass
            expects the events delivered to be fixed even if the
            BufferSize is set to zero, i.e. when no buffering occurs.

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
BufferingAppenderSkeleton Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton Methods

BufferingAppenderSkeleton Methods Apache log4net™ SDK Documentation
The BufferingAppenderSkeleton type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Flush | Flush the currently buffered events
Public method | Flush(Boolean) | Flush the currently buffered events
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Close this appender instance. (Overrides AppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | SendBuffer | Sends the events.
Protected method | SendFromBuffer | Sends the contents of the buffer.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BufferingAppenderSkeleton Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.ActivateOptions Method

BufferingAppenderSkeleton ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the appender based on the options set

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.Append Method

BufferingAppenderSkeleton Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.Append Method (LoggingEvent)

BufferingAppenderSkeleton Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the event to log
Remarks

            Stores the loggingEvent in the cyclic buffer.

            The buffer will be sent (i.e. passed to the SendBuffer( LoggingEvent )
            method) if one of the following conditions is met:

  • The cyclic buffer is full and this appender is
                    marked as not lossy (see Lossy)
  • An Evaluator is set and
                    it is triggered for the loggingEvent
                    specified.

            Before the event is stored in the buffer it is fixed
            (see FixVolatileData(FixFlags)) to ensure that
            any data referenced by the event will be valid when the buffer
            is processed.

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.Flush Method

BufferingAppenderSkeleton Flush Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Flush | Flush the currently buffered events
Public method | Flush(Boolean) | Flush the currently buffered events
Back to Top
See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.Flush Method

BufferingAppenderSkeleton Flush Method Apache log4net™ SDK Documentation
Flush the currently buffered events

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Flush()
public virtual void Flush()
Public Overridable Sub Flush
Public Overridable Sub Flush
public:
virtual void Flush()
public:
virtual void Flush()
Remarks

            Flushes any events that have been buffered.

            If the appender is buffering in Lossy mode then the contents
            of the buffer will NOT be flushed to the appender.

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
Flush Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.Flush Method (Boolean)

BufferingAppenderSkeleton Flush Method (Boolean) Apache log4net™ SDK Documentation
Flush the currently buffered events

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Flush(
    bool flushLossyBuffer
)
public virtual void Flush(
    bool flushLossyBuffer
)
Public Overridable Sub Flush (
    flushLossyBuffer As Boolean
)
Public Overridable Sub Flush (
    flushLossyBuffer As Boolean
)
public:
virtual void Flush(
    bool flushLossyBuffer
)
public:
virtual void Flush(
    bool flushLossyBuffer
)
Parameters
flushLossyBuffer
Type:   Online System Boolean
set to true to flush the buffer of lossy events
Remarks

            Flushes events that have been buffered. If flushLossyBuffer is
            false then events will only be flushed if this buffer is non-lossy mode.

            If the appender is buffering in Lossy mode then the contents
            of the buffer will only be flushed if flushLossyBuffer is true.
            In this case the contents of the buffer will be tested against the
            LossyEvaluator and if triggering will be output. All other buffered
            events will be discarded.

            If flushLossyBuffer is true then the buffer will always
            be emptied by calling this method.

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
Flush Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.OnClose Method

BufferingAppenderSkeleton OnClose Method Apache log4net™ SDK Documentation
Close this appender instance.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void OnClose()
protected override void OnClose()
Protected Overrides Sub OnClose
Protected Overrides Sub OnClose
protected:
virtual void OnClose() override
protected:
virtual void OnClose() override
Remarks

            Close this appender instance. If this appender is marked
            as not Lossy then the remaining events in
            the buffer must be sent when the appender is closed.

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.SendBuffer Method

BufferingAppenderSkeleton SendBuffer Method Apache log4net™ SDK Documentation
Sends the events.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void SendBuffer(
    LoggingEvent[] events
)
protected abstract void SendBuffer(
    LoggingEvent[] events
)
Protected MustOverride Sub SendBuffer (
    events As LoggingEvent()
)
Protected MustOverride Sub SendBuffer (
    events As LoggingEvent()
)
protected:
virtual void SendBuffer(
    array<LoggingEvent^>^ events
) abstract
protected:
virtual void SendBuffer(
    array<LoggingEvent^>^ events
) abstract
Parameters
events
Type:  log4net.Core LoggingEvent
The events that need to be send.
Remarks

            The subclass must override this method to process the buffered events.

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.SendFromBuffer Method

BufferingAppenderSkeleton SendFromBuffer Method Apache log4net™ SDK Documentation
Sends the contents of the buffer.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void SendFromBuffer(
    LoggingEvent firstLoggingEvent,
    CyclicBuffer buffer
)
protected virtual void SendFromBuffer(
    LoggingEvent firstLoggingEvent,
    CyclicBuffer buffer
)
Protected Overridable Sub SendFromBuffer (
    firstLoggingEvent As LoggingEvent,
    buffer As CyclicBuffer
)
Protected Overridable Sub SendFromBuffer (
    firstLoggingEvent As LoggingEvent,
    buffer As CyclicBuffer
)
protected:
virtual void SendFromBuffer(
    LoggingEvent^ firstLoggingEvent,
    CyclicBuffer^ buffer
)
protected:
virtual void SendFromBuffer(
    LoggingEvent^ firstLoggingEvent,
    CyclicBuffer^ buffer
)
Parameters
firstLoggingEvent
Type: log4net.Core LoggingEvent
The first logging event.
buffer
Type: log4net.Util CyclicBuffer
The buffer containing the events that need to be send.
Remarks

            The subclass must override [M:SendBuffer(LoggingEvent[])].

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton Properties

BufferingAppenderSkeleton Properties Apache log4net™ SDK Documentation
The BufferingAppenderSkeleton type exposes the following members.
Properties
 | Name | Description
Public property | BufferSize | Gets or sets the size of the cyclic buffer used to hold the logging events.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Evaluator | Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately.
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets a the fields that will be fixed in the event
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Lossy | Gets or sets a value that indicates whether the appender is lossy.
Public property | LossyEvaluator | Gets or sets the value of the ITriggeringEventEvaluator to use.
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating if only part of the logging event data should be fixed.
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set. (Inherited from AppenderSkeleton.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
BufferingAppenderSkeleton Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.BufferSize Property

BufferingAppenderSkeleton BufferSize Property Apache log4net™ SDK Documentation
Gets or sets the size of the cyclic buffer used to hold the logging events.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int BufferSize { get; set; }
public int BufferSize { get; set; }
Public Property BufferSize As Integer
    Get
    Set
Public Property BufferSize As Integer
    Get
    Set
public:
property int BufferSize {
    int get ();
    void set (int value);
}
public:
property int BufferSize {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32

            The size of the cyclic buffer used to hold the logging events.

Remarks

            The BufferSize option takes a positive integer
            representing the maximum number of logging events to collect in
            a cyclic buffer. When the BufferSize is reached,
            oldest events are deleted as new events are added to the
            buffer. By default the size of the cyclic buffer is 512 events.

            If the BufferSize is set to a value less than
            or equal to 1 then no buffering will occur. The logging event
            will be delivered synchronously (depending on the Lossy
            and Evaluator properties). Otherwise the event will
            be buffered.

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.Evaluator Property

BufferingAppenderSkeleton Evaluator Property Apache log4net™ SDK Documentation
Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ITriggeringEventEvaluator Evaluator { get; set; }
public ITriggeringEventEvaluator Evaluator { get; set; }
Public Property Evaluator As ITriggeringEventEvaluator
    Get
    Set
Public Property Evaluator As ITriggeringEventEvaluator
    Get
    Set
public:
property ITriggeringEventEvaluator^ Evaluator {
    ITriggeringEventEvaluator^ get ();
    void set (ITriggeringEventEvaluator^ value);
}
public:
property ITriggeringEventEvaluator^ Evaluator {
    ITriggeringEventEvaluator^ get ();
    void set (ITriggeringEventEvaluator^ value);
}
Property Value
Type: ITriggeringEventEvaluator

            The ITriggeringEventEvaluator that causes the buffer to be
            sent immediately.

Remarks

            The evaluator will be called for each event that is appended to this
            appender. If the evaluator triggers then the current buffer will
            immediately be sent (see [M:SendBuffer(LoggingEvent[])]).

If Lossy is set to true then an
            Evaluator must be specified.
See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.Fix Property

BufferingAppenderSkeleton Fix Property Apache log4net™ SDK Documentation
Gets or sets a the fields that will be fixed in the event

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual FixFlags Fix { get; set; }
public virtual FixFlags Fix { get; set; }
Public Overridable Property Fix As FixFlags
    Get
    Set
Public Overridable Property Fix As FixFlags
    Get
    Set
public:
virtual property FixFlags Fix {
    FixFlags get ();
    void set (FixFlags value);
}
public:
virtual property FixFlags Fix {
    FixFlags get ();
    void set (FixFlags value);
}
Property Value
Type: FixFlags

            The event fields that will be fixed before the event is buffered

Remarks

            The logging event needs to have certain thread specific values
            captured before it can be buffered. See Fix
            for details.

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace
LoggingEvent Fix
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.Lossy Property

BufferingAppenderSkeleton Lossy Property Apache log4net™ SDK Documentation
Gets or sets a value that indicates whether the appender is lossy.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Lossy { get; set; }
public bool Lossy { get; set; }
Public Property Lossy As Boolean
    Get
    Set
Public Property Lossy As Boolean
    Get
    Set
public:
property bool Lossy {
    bool get ();
    void set (bool value);
}
public:
property bool Lossy {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if the appender is lossy, otherwise false. The default is false.

Remarks

            This appender uses a buffer to store logging events before
            delivering them. A triggering event causes the whole buffer
            to be send to the remote sink. If the buffer overruns before
            a triggering event then logging events could be lost. Set
            Lossy to false to prevent logging events
            from being lost.

If Lossy is set to true then an
            Evaluator must be specified.
See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.LossyEvaluator Property

BufferingAppenderSkeleton LossyEvaluator Property Apache log4net™ SDK Documentation
Gets or sets the value of the ITriggeringEventEvaluator to use.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ITriggeringEventEvaluator LossyEvaluator { get; set; }
public ITriggeringEventEvaluator LossyEvaluator { get; set; }
Public Property LossyEvaluator As ITriggeringEventEvaluator
    Get
    Set
Public Property LossyEvaluator As ITriggeringEventEvaluator
    Get
    Set
public:
property ITriggeringEventEvaluator^ LossyEvaluator {
    ITriggeringEventEvaluator^ get ();
    void set (ITriggeringEventEvaluator^ value);
}
public:
property ITriggeringEventEvaluator^ LossyEvaluator {
    ITriggeringEventEvaluator^ get ();
    void set (ITriggeringEventEvaluator^ value);
}
Property Value
Type: ITriggeringEventEvaluator

            The value of the ITriggeringEventEvaluator to use.

Remarks

            The evaluator will be called for each event that is discarded from this
            appender. If the evaluator triggers then the current buffer will immediately
            be sent (see [M:SendBuffer(LoggingEvent[])]).

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingAppenderSkeleton.OnlyFixPartialEventData Property

BufferingAppenderSkeleton OnlyFixPartialEventData Property Apache log4net™ SDK Documentation
Gets or sets a value indicating if only part of the logging event data should be fixed.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Fix property")]
public virtual bool OnlyFixPartialEventData { get; set; }
[ObsoleteAttribute("Use Fix property")]
public virtual bool OnlyFixPartialEventData { get; set; }
<ObsoleteAttribute("Use Fix property")>
Public Overridable Property OnlyFixPartialEventData As Boolean
    Get
    Set
<ObsoleteAttribute("Use Fix property")>
Public Overridable Property OnlyFixPartialEventData As Boolean
    Get
    Set
public:
[ObsoleteAttribute(L"Use Fix property")]
virtual property bool OnlyFixPartialEventData {
    bool get ();
    void set (bool value);
}
public:
[ObsoleteAttribute(L"Use Fix property")]
virtual property bool OnlyFixPartialEventData {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if the appender should only fix part of the logging event
            data, otherwise false. The default is false.

Remarks

            Setting this property to true will cause only part of the
            event data to be fixed and serialized. This will improve performance.

            See FixVolatileData(FixFlags) for more information.

See Also
BufferingAppenderSkeleton Class
BufferingAppenderSkeleton Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender Class

BufferingForwardingAppender Class Apache log4net™ SDK Documentation
Buffers events and then forwards them to attached appenders.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender BufferingAppenderSkeleton
log4net.Appender BufferingForwardingAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BufferingForwardingAppender : BufferingAppenderSkeleton,
    IAppenderAttachable
public class BufferingForwardingAppender : BufferingAppenderSkeleton,
    IAppenderAttachable
Public Class BufferingForwardingAppender
    Inherits BufferingAppenderSkeleton
    Implements IAppenderAttachable
Public Class BufferingForwardingAppender
    Inherits BufferingAppenderSkeleton
    Implements IAppenderAttachable
public ref class BufferingForwardingAppender : public BufferingAppenderSkeleton,
    IAppenderAttachable
public ref class BufferingForwardingAppender : public BufferingAppenderSkeleton,
    IAppenderAttachable
Remarks

            The events are buffered in this appender until conditions are
            met to allow the appender to deliver the events to the attached
            appenders. See BufferingAppenderSkeleton for the
            conditions that cause the buffer to be sent.

The forwarding appender can be used to specify different
            thresholds and filters for the same appender at different locations
            within the hierarchy.

See Also
BufferingForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender Members

BufferingForwardingAppender Members Apache log4net™ SDK Documentation
The BufferingForwardingAppender type exposes the following members.
Constructors
 | Name | Description
Public method | BufferingForwardingAppender | Initializes a new instance of the BufferingForwardingAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from BufferingAppenderSkeleton.)
Public method | AddAppender | Adds an IAppender to the list of appenders of this instance.
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Inherited from BufferingAppenderSkeleton.)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Flush | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Flush(Boolean) | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | GetAppender | Looks for the appender with the specified name.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Closes the appender and releases resources. (Overrides BufferingAppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Public method | RemoveAllAppenders | Removes all previously added appenders from this appender.
Public method | RemoveAppender(String) | Removes the appender with the specified name from the list of appenders.
Public method | RemoveAppender(IAppender) | Removes the specified appender from the list of appenders.
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | SendBuffer | Send the events. (Overrides BufferingAppenderSkeleton SendBuffer( LoggingEvent ).)
Protected method | SendFromBuffer | Sends the contents of the buffer. (Inherited from BufferingAppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Appenders | Gets the appenders contained in this appender as an Online ICollection.
Public property | BufferSize | Gets or sets the size of the cyclic buffer used to hold the logging events. (Inherited from BufferingAppenderSkeleton.)
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Evaluator | Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately. (Inherited from BufferingAppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets a the fields that will be fixed in the event (Inherited from BufferingAppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Lossy | Gets or sets a value that indicates whether the appender is lossy. (Inherited from BufferingAppenderSkeleton.)
Public property | LossyEvaluator | Gets or sets the value of the ITriggeringEventEvaluator to use. (Inherited from BufferingAppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating if only part of the logging event data should be fixed. (Inherited from BufferingAppenderSkeleton.)
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set. (Inherited from AppenderSkeleton.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
BufferingForwardingAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender Constructor

BufferingForwardingAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the BufferingForwardingAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BufferingForwardingAppender()
public BufferingForwardingAppender()
Public Sub New
Public Sub New
public:
BufferingForwardingAppender()
public:
BufferingForwardingAppender()
Remarks

            Default constructor.

See Also
BufferingForwardingAppender Class
BufferingForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender Methods

BufferingForwardingAppender Methods Apache log4net™ SDK Documentation
The BufferingForwardingAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from BufferingAppenderSkeleton.)
Public method | AddAppender | Adds an IAppender to the list of appenders of this instance.
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Inherited from BufferingAppenderSkeleton.)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Flush | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Flush(Boolean) | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | GetAppender | Looks for the appender with the specified name.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Closes the appender and releases resources. (Overrides BufferingAppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Public method | RemoveAllAppenders | Removes all previously added appenders from this appender.
Public method | RemoveAppender(String) | Removes the appender with the specified name from the list of appenders.
Public method | RemoveAppender(IAppender) | Removes the specified appender from the list of appenders.
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | SendBuffer | Send the events. (Overrides BufferingAppenderSkeleton SendBuffer( LoggingEvent ).)
Protected method | SendFromBuffer | Sends the contents of the buffer. (Inherited from BufferingAppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BufferingForwardingAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender.AddAppender Method

BufferingForwardingAppender AddAppender Method Apache log4net™ SDK Documentation
Adds an IAppender to the list of appenders of this instance.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddAppender(
    IAppender newAppender
)
public virtual void AddAppender(
    IAppender newAppender
)
Public Overridable Sub AddAppender (
    newAppender As IAppender
)
Public Overridable Sub AddAppender (
    newAppender As IAppender
)
public:
virtual void AddAppender(
    IAppender^ newAppender
)
public:
virtual void AddAppender(
    IAppender^ newAppender
)
Parameters
newAppender
Type: log4net.Appender IAppender
The IAppender to add to this appender.
Implements
IAppenderAttachable AddAppender(IAppender)
Remarks

            If the specified IAppender is already in the list of
            appenders, then it won't be added again.

See Also
BufferingForwardingAppender Class
BufferingForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender.GetAppender Method

BufferingForwardingAppender GetAppender Method Apache log4net™ SDK Documentation
Looks for the appender with the specified name.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IAppender GetAppender(
    string name
)
public virtual IAppender GetAppender(
    string name
)
Public Overridable Function GetAppender (
    name As String
) As IAppender
Public Overridable Function GetAppender (
    name As String
) As IAppender
public:
virtual IAppender^ GetAppender(
    String^ name
)
public:
virtual IAppender^ GetAppender(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the appender to lookup.
Return Value
Type: IAppender

            The appender with the specified name, or null.

Implements
IAppenderAttachable GetAppender(String)
Remarks

            Get the named appender attached to this buffering appender.

See Also
BufferingForwardingAppender Class
BufferingForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender.OnClose Method

BufferingForwardingAppender OnClose Method Apache log4net™ SDK Documentation
Closes the appender and releases resources.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void OnClose()
protected override void OnClose()
Protected Overrides Sub OnClose
Protected Overrides Sub OnClose
protected:
virtual void OnClose() override
protected:
virtual void OnClose() override
Remarks

            Releases any resources allocated within the appender such as file handles,
            network connections, etc.

            It is a programming error to append to a closed appender.

See Also
BufferingForwardingAppender Class
BufferingForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender.RemoveAllAppenders Method

BufferingForwardingAppender RemoveAllAppenders Method Apache log4net™ SDK Documentation
Removes all previously added appenders from this appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void RemoveAllAppenders()
public virtual void RemoveAllAppenders()
Public Overridable Sub RemoveAllAppenders
Public Overridable Sub RemoveAllAppenders
public:
virtual void RemoveAllAppenders()
public:
virtual void RemoveAllAppenders()
Implements
IAppenderAttachable RemoveAllAppenders
Remarks

            This is useful when re-reading configuration information.

See Also
BufferingForwardingAppender Class
BufferingForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender.RemoveAppender Method

BufferingForwardingAppender RemoveAppender Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | RemoveAppender(String) | Removes the appender with the specified name from the list of appenders.
Public method | RemoveAppender(IAppender) | Removes the specified appender from the list of appenders.
Back to Top
See Also
BufferingForwardingAppender Class
BufferingForwardingAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender.RemoveAppender Method (String)

BufferingForwardingAppender RemoveAppender Method (String) Apache log4net™ SDK Documentation
Removes the appender with the specified name from the list of appenders.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IAppender RemoveAppender(
    string name
)
public virtual IAppender RemoveAppender(
    string name
)
Public Overridable Function RemoveAppender (
    name As String
) As IAppender
Public Overridable Function RemoveAppender (
    name As String
) As IAppender
public:
virtual IAppender^ RemoveAppender(
    String^ name
)
public:
virtual IAppender^ RemoveAppender(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the appender to remove.
Return Value
Type: IAppender
The appender removed from the list
Implements
IAppenderAttachable RemoveAppender(String)
Remarks

            The appender removed is not closed.
            If you are discarding the appender you must call
            Close  on the appender removed.

See Also
BufferingForwardingAppender Class
BufferingForwardingAppender Members
RemoveAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender.RemoveAppender Method (IAppender)

BufferingForwardingAppender RemoveAppender Method (IAppender) Apache log4net™ SDK Documentation
Removes the specified appender from the list of appenders.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IAppender RemoveAppender(
    IAppender appender
)
public virtual IAppender RemoveAppender(
    IAppender appender
)
Public Overridable Function RemoveAppender (
    appender As IAppender
) As IAppender
Public Overridable Function RemoveAppender (
    appender As IAppender
) As IAppender
public:
virtual IAppender^ RemoveAppender(
    IAppender^ appender
)
public:
virtual IAppender^ RemoveAppender(
    IAppender^ appender
)
Parameters
appender
Type: log4net.Appender IAppender
The appender to remove.
Return Value
Type: IAppender
The appender removed from the list
Implements
IAppenderAttachable RemoveAppender(IAppender)
Remarks

            The appender removed is not closed.
            If you are discarding the appender you must call
            Close  on the appender removed.

See Also
BufferingForwardingAppender Class
BufferingForwardingAppender Members
RemoveAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender.SendBuffer Method

BufferingForwardingAppender SendBuffer Method Apache log4net™ SDK Documentation
Send the events.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void SendBuffer(
    LoggingEvent[] events
)
protected override void SendBuffer(
    LoggingEvent[] events
)
Protected Overrides Sub SendBuffer (
    events As LoggingEvent()
)
Protected Overrides Sub SendBuffer (
    events As LoggingEvent()
)
protected:
virtual void SendBuffer(
    array<LoggingEvent^>^ events
) override
protected:
virtual void SendBuffer(
    array<LoggingEvent^>^ events
) override
Parameters
events
Type:  log4net.Core LoggingEvent
The events that need to be send.
Remarks

            Forwards the events to the attached appenders.

See Also
BufferingForwardingAppender Class
BufferingForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender Properties

BufferingForwardingAppender Properties Apache log4net™ SDK Documentation
The BufferingForwardingAppender type exposes the following members.
Properties
 | Name | Description
Public property | Appenders | Gets the appenders contained in this appender as an Online ICollection.
Public property | BufferSize | Gets or sets the size of the cyclic buffer used to hold the logging events. (Inherited from BufferingAppenderSkeleton.)
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Evaluator | Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately. (Inherited from BufferingAppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets a the fields that will be fixed in the event (Inherited from BufferingAppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Lossy | Gets or sets a value that indicates whether the appender is lossy. (Inherited from BufferingAppenderSkeleton.)
Public property | LossyEvaluator | Gets or sets the value of the ITriggeringEventEvaluator to use. (Inherited from BufferingAppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating if only part of the logging event data should be fixed. (Inherited from BufferingAppenderSkeleton.)
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set. (Inherited from AppenderSkeleton.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
BufferingForwardingAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BufferingForwardingAppender.Appenders Property

BufferingForwardingAppender Appenders Property Apache log4net™ SDK Documentation
Gets the appenders contained in this appender as an Online ICollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual AppenderCollection Appenders { get; }
public virtual AppenderCollection Appenders { get; }
Public Overridable ReadOnly Property Appenders As AppenderCollection
    Get
Public Overridable ReadOnly Property Appenders As AppenderCollection
    Get
public:
virtual property AppenderCollection^ Appenders {
    AppenderCollection^ get ();
}
public:
virtual property AppenderCollection^ Appenders {
    AppenderCollection^ get ();
}
Return Value
Type: AppenderCollection

            A collection of the appenders in this appender.

Implements
IAppenderAttachable Appenders
Remarks

            If no appenders can be found, then an EmptyCollection
            is returned.

See Also
BufferingForwardingAppender Class
BufferingForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender Class

ColoredConsoleAppender Class Apache log4net™ SDK Documentation
Appends logging events to the console.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender ColoredConsoleAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ColoredConsoleAppender : AppenderSkeleton
public class ColoredConsoleAppender : AppenderSkeleton
Public Class ColoredConsoleAppender
    Inherits AppenderSkeleton
Public Class ColoredConsoleAppender
    Inherits AppenderSkeleton
public ref class ColoredConsoleAppender : public AppenderSkeleton
public ref class ColoredConsoleAppender : public AppenderSkeleton
Remarks

            ColoredConsoleAppender appends log events to the standard output stream
            or the error output stream using a layout specified by the
            user. It also allows the color of a specific type of message to be set.

            By default, all output is written to the console's standard output stream.
            The Target property can be set to direct the output to the
            error stream.

            NOTE: This appender writes directly to the application's attached console
            not to the System.Console.Out or System.Console.ErrorTextWriter.
            The System.Console.Out and System.Console.Error streams can be
            programmatically redirected (for example NUnit does this to capture program output).
            This appender will ignore these redirections because it needs to use Win32
            API calls to colorize the output. To respect these redirections the ConsoleAppender
            must be used.

            When configuring the colored console appender, mapping should be
            specified to map a logging level to a color. For example:

XML
View Colorized Copy to Clipboard Print
<mapping><level value="ERROR" /><foreColor value="White" /><backColor value="Red, HighIntensity" /></mapping><mapping><level value="DEBUG" /><backColor value="Green" /></mapping>
<mapping><level value="ERROR" /><foreColor value="White" /><backColor value="Red, HighIntensity" /></mapping><mapping><level value="DEBUG" /><backColor value="Green" /></mapping>

            The Level is the standard log4net logging level and ForeColor and BackColor can be any
            combination of the following values:

  • Blue
  • Green
  • Red
  • White
  • Yellow
  • Purple
  • Cyan
  • HighIntensity
See Also
ColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender Members

ColoredConsoleAppender Members Apache log4net™ SDK Documentation
The ColoredConsoleAppender type exposes the following members.
Constructors
 | Name | Description
Public method | ColoredConsoleAppender | Initializes a new instance of the ColoredConsoleAppender class.
Public method | ColoredConsoleAppender(ILayout) | Obsolete. Initializes a new instance of the ColoredConsoleAppender class with the specified layout.
Public method | ColoredConsoleAppender(ILayout, Boolean) | Obsolete. Initializes a new instance of the ColoredConsoleAppender class with the specified layout.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the options for this appender (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddMapping | Add a mapping of level to color - done by the config file
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
ConsoleError | The Target to use when writing to the Console standard error output stream.
ConsoleOut | The Target to use when writing to the Console standard output stream.
Back to Top
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Target | Target is the value of the console output stream. This is either "Console.Out" or "Console.Error".
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
ColoredConsoleAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender Constructor

ColoredConsoleAppender Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | ColoredConsoleAppender | Initializes a new instance of the ColoredConsoleAppender class.
Public method | ColoredConsoleAppender(ILayout) | Obsolete. Initializes a new instance of the ColoredConsoleAppender class with the specified layout.
Public method | ColoredConsoleAppender(ILayout, Boolean) | Obsolete. Initializes a new instance of the ColoredConsoleAppender class with the specified layout.
Back to Top
See Also
ColoredConsoleAppender Class
ColoredConsoleAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender Constructor

ColoredConsoleAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the ColoredConsoleAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ColoredConsoleAppender()
public ColoredConsoleAppender()
Public Sub New
Public Sub New
public:
ColoredConsoleAppender()
public:
ColoredConsoleAppender()
Remarks

            The instance of the ColoredConsoleAppender class is set up to write
            to the standard output stream.

See Also
ColoredConsoleAppender Class
ColoredConsoleAppender Members
ColoredConsoleAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender Constructor (ILayout)

ColoredConsoleAppender Constructor (ILayout) Apache log4net™ SDK Documentation
Initializes a new instance of the ColoredConsoleAppender class with the specified layout.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Instead use the default constructor and set the Layout property")]
public ColoredConsoleAppender(
    ILayout layout
)
[ObsoleteAttribute("Instead use the default constructor and set the Layout property")]
public ColoredConsoleAppender(
    ILayout layout
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout property")>
Public Sub New (
    layout As ILayout
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout property")>
Public Sub New (
    layout As ILayout
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout property")]
ColoredConsoleAppender(
    ILayout^ layout
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout property")]
ColoredConsoleAppender(
    ILayout^ layout
)
Parameters
layout
Type: log4net.Layout ILayout
the layout to use for this appender
Remarks

            The instance of the ColoredConsoleAppender class is set up to write
            to the standard output stream.

See Also
ColoredConsoleAppender Class
ColoredConsoleAppender Members
ColoredConsoleAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender Constructor (ILayout, Boolean)

ColoredConsoleAppender Constructor (ILayout, Boolean) Apache log4net™ SDK Documentation
Initializes a new instance of the ColoredConsoleAppender class with the specified layout.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Instead use the default constructor and set the Layout & Target properties")]
public ColoredConsoleAppender(
    ILayout layout,
    bool writeToErrorStream
)
[ObsoleteAttribute("Instead use the default constructor and set the Layout & Target properties")]
public ColoredConsoleAppender(
    ILayout layout,
    bool writeToErrorStream
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout & Target properties")>
Public Sub New (
    layout As ILayout,
    writeToErrorStream As Boolean
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout & Target properties")>
Public Sub New (
    layout As ILayout,
    writeToErrorStream As Boolean
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout & Target properties")]
ColoredConsoleAppender(
    ILayout^ layout,
    bool writeToErrorStream
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout & Target properties")]
ColoredConsoleAppender(
    ILayout^ layout,
    bool writeToErrorStream
)
Parameters
layout
Type: log4net.Layout ILayout
the layout to use for this appender
writeToErrorStream
Type:   Online System Boolean
flag set to true to write to the console error stream
Remarks

            When writeToErrorStream is set to true, output is written to
            the standard error output stream.  Otherwise, output is written to the standard
            output stream.

See Also
ColoredConsoleAppender Class
ColoredConsoleAppender Members
ColoredConsoleAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender Fields

ColoredConsoleAppender Fields Apache log4net™ SDK Documentation
The ColoredConsoleAppender type exposes the following members.
Fields
Name | Description
ConsoleError | The Target to use when writing to the Console standard error output stream.
ConsoleOut | The Target to use when writing to the Console standard output stream.
Back to Top
See Also
ColoredConsoleAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.ConsoleError Field

ColoredConsoleAppender ConsoleError Field Apache log4net™ SDK Documentation
The Target to use when writing to the Console standard error output stream.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ConsoleError
public const string ConsoleError
Public Const ConsoleError As String
Public Const ConsoleError As String
public:
literal String^ ConsoleError
public:
literal String^ ConsoleError
Field Value
Type:   Online String
Remarks

            The Target to use when writing to the Console
            standard error output stream.

See Also
ColoredConsoleAppender Class
ColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.ConsoleOut Field

ColoredConsoleAppender ConsoleOut Field Apache log4net™ SDK Documentation
The Target to use when writing to the Console standard output stream.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ConsoleOut
public const string ConsoleOut
Public Const ConsoleOut As String
Public Const ConsoleOut As String
public:
literal String^ ConsoleOut
public:
literal String^ ConsoleOut
Field Value
Type:   Online String
Remarks

            The Target to use when writing to the Console
            standard output stream.

See Also
ColoredConsoleAppender Class
ColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender Methods

ColoredConsoleAppender Methods Apache log4net™ SDK Documentation
The ColoredConsoleAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the options for this appender (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddMapping | Add a mapping of level to color - done by the config file
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ColoredConsoleAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.ActivateOptions Method

ColoredConsoleAppender ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the options for this appender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            Initialize the level to color mappings set on this appender.

See Also
ColoredConsoleAppender Class
ColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.AddMapping Method

ColoredConsoleAppender AddMapping Method Apache log4net™ SDK Documentation
Add a mapping of level to color - done by the config file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddMapping(
    ColoredConsoleAppender..::..LevelColors mapping
)
public void AddMapping(
    ColoredConsoleAppender..::..LevelColors mapping
)
Public Sub AddMapping (
    mapping As ColoredConsoleAppender..::..LevelColors
)
Public Sub AddMapping (
    mapping As ColoredConsoleAppender..::..LevelColors
)
public:
void AddMapping(
    ColoredConsoleAppender..::..LevelColors^ mapping
)
public:
void AddMapping(
    ColoredConsoleAppender..::..LevelColors^ mapping
)
Parameters
mapping
Type: log4net.Appender ColoredConsoleAppender LevelColors
The mapping to add
Remarks

            Add a ColoredConsoleAppender LevelColors mapping to this appender.
            Each mapping defines the foreground and background colors
            for a level.

See Also
ColoredConsoleAppender Class
ColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.Append Method

ColoredConsoleAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
ColoredConsoleAppender Class
ColoredConsoleAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.Append Method (LoggingEvent)

ColoredConsoleAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Writes the event to the console.

            The format of the output will depend on the appender's layout.

See Also
ColoredConsoleAppender Class
ColoredConsoleAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender Properties

ColoredConsoleAppender Properties Apache log4net™ SDK Documentation
The ColoredConsoleAppender type exposes the following members.
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Target | Target is the value of the console output stream. This is either "Console.Out" or "Console.Error".
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
ColoredConsoleAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.RequiresLayout Property

ColoredConsoleAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
ColoredConsoleAppender Class
ColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.Target Property

ColoredConsoleAppender Target Property Apache log4net™ SDK Documentation
Target is the value of the console output stream. This is either "Console.Out" or "Console.Error".

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Target { get; set; }
public virtual string Target { get; set; }
Public Overridable Property Target As String
    Get
    Set
Public Overridable Property Target As String
    Get
    Set
public:
virtual property String^ Target {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Target {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            Target is the value of the console output stream.
            This is either "Console.Out" or "Console.Error".

Remarks

            Target is the value of the console output stream.
            This is either "Console.Out" or "Console.Error".

See Also
ColoredConsoleAppender Class
ColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.Colors Enumeration

ColoredConsoleAppender Colors Enumeration Apache log4net™ SDK Documentation
The enum of possible color values for use with the color mapping method

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum Colors
[FlagsAttribute]
public enum Colors
<FlagsAttribute>
Public Enumeration Colors
<FlagsAttribute>
Public Enumeration Colors
[FlagsAttribute]
public enum class Colors
[FlagsAttribute]
public enum class Colors
Members
Member name | Value | Description
Blue | 1 | color is blue
Green | 2 | color is green
Red | 4 | color is red
White | 7 | color is white
Yellow | 6 | color is yellow
Purple | 5 | color is purple
Cyan | 3 | color is cyan
HighIntensity | 8 | color is intensified
Remarks

            The following flags can be combined together to
            form the colors.

See Also
log4net.Appender Namespace
log4net.Appender ColoredConsoleAppender
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.LevelColors Class

ColoredConsoleAppender LevelColors Class Apache log4net™ SDK Documentation
A class to act as a mapping between the level that a logging call is made at and the color it should be displayed as.
Inheritance Hierarchy
Online System Object
log4net.Util LevelMappingEntry
log4net.Appender ColoredConsoleAppender LevelColors

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LevelColors : LevelMappingEntry
public class LevelColors : LevelMappingEntry
Public Class LevelColors
    Inherits LevelMappingEntry
Public Class LevelColors
    Inherits LevelMappingEntry
public ref class LevelColors : public LevelMappingEntry
public ref class LevelColors : public LevelMappingEntry
Remarks

            Defines the mapping between a level and the color it should be displayed in.

See Also
ColoredConsoleAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.LevelColors Members

ColoredConsoleAppender LevelColors Members Apache log4net™ SDK Documentation
The ColoredConsoleAppender LevelColors type exposes the following members.
Constructors
 | Name | Description
Public method | ColoredConsoleAppender LevelColors | Initializes a new instance of the ColoredConsoleAppender LevelColors class
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the options for the object (Overrides LevelMappingEntry ActivateOptions .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | BackColor | The mapped background color for the specified level
Public property | ForeColor | The mapped foreground color for the specified level
Public property | Level | The level that is the key for this mapping (Inherited from LevelMappingEntry.)
Back to Top
See Also
ColoredConsoleAppender LevelColors Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.LevelColors Constructor

ColoredConsoleAppender LevelColors Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the ColoredConsoleAppender LevelColors class

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelColors()
public LevelColors()
Public Sub New
Public Sub New
public:
LevelColors()
public:
LevelColors()
See Also
ColoredConsoleAppender LevelColors Class
ColoredConsoleAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.LevelColors Methods

ColoredConsoleAppender LevelColors Methods Apache log4net™ SDK Documentation
The ColoredConsoleAppender LevelColors type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the options for the object (Overrides LevelMappingEntry ActivateOptions .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ColoredConsoleAppender LevelColors Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.LevelColors.ActivateOptions Method

ColoredConsoleAppender LevelColors ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the options for the object

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            Combine the ForeColor and BackColor together.

See Also
ColoredConsoleAppender LevelColors Class
ColoredConsoleAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.LevelColors Properties

ColoredConsoleAppender LevelColors Properties Apache log4net™ SDK Documentation
The ColoredConsoleAppender LevelColors type exposes the following members.
Properties
 | Name | Description
Public property | BackColor | The mapped background color for the specified level
Public property | ForeColor | The mapped foreground color for the specified level
Public property | Level | The level that is the key for this mapping (Inherited from LevelMappingEntry.)
Back to Top
See Also
ColoredConsoleAppender LevelColors Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.LevelColors.BackColor Property

ColoredConsoleAppender LevelColors BackColor Property Apache log4net™ SDK Documentation
The mapped background color for the specified level

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ColoredConsoleAppender..::..Colors BackColor { get; set; }
public ColoredConsoleAppender..::..Colors BackColor { get; set; }
Public Property BackColor As ColoredConsoleAppender..::..Colors
    Get
    Set
Public Property BackColor As ColoredConsoleAppender..::..Colors
    Get
    Set
public:
property ColoredConsoleAppender..::..Colors BackColor {
    ColoredConsoleAppender..::..Colors get ();
    void set (ColoredConsoleAppender..::..Colors value);
}
public:
property ColoredConsoleAppender..::..Colors BackColor {
    ColoredConsoleAppender..::..Colors get ();
    void set (ColoredConsoleAppender..::..Colors value);
}
Property Value
Type: ColoredConsoleAppender Colors
Remarks

            Required property.
            The mapped background color for the specified level.

See Also
ColoredConsoleAppender LevelColors Class
ColoredConsoleAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ColoredConsoleAppender.LevelColors.ForeColor Property

ColoredConsoleAppender LevelColors ForeColor Property Apache log4net™ SDK Documentation
The mapped foreground color for the specified level

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ColoredConsoleAppender..::..Colors ForeColor { get; set; }
public ColoredConsoleAppender..::..Colors ForeColor { get; set; }
Public Property ForeColor As ColoredConsoleAppender..::..Colors
    Get
    Set
Public Property ForeColor As ColoredConsoleAppender..::..Colors
    Get
    Set
public:
property ColoredConsoleAppender..::..Colors ForeColor {
    ColoredConsoleAppender..::..Colors get ();
    void set (ColoredConsoleAppender..::..Colors value);
}
public:
property ColoredConsoleAppender..::..Colors ForeColor {
    ColoredConsoleAppender..::..Colors get ();
    void set (ColoredConsoleAppender..::..Colors value);
}
Property Value
Type: ColoredConsoleAppender Colors
Remarks

            Required property.
            The mapped foreground color for the specified level.

See Also
ColoredConsoleAppender LevelColors Class
ColoredConsoleAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender Class

ConsoleAppender Class Apache log4net™ SDK Documentation
Appends logging events to the console.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender ConsoleAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ConsoleAppender : AppenderSkeleton
public class ConsoleAppender : AppenderSkeleton
Public Class ConsoleAppender
    Inherits AppenderSkeleton
Public Class ConsoleAppender
    Inherits AppenderSkeleton
public ref class ConsoleAppender : public AppenderSkeleton
public ref class ConsoleAppender : public AppenderSkeleton
Remarks

            ConsoleAppender appends log events to the standard output stream
            or the error output stream using a layout specified by the
            user.

            By default, all output is written to the console's standard output stream.
            The Target property can be set to direct the output to the
            error stream.

            NOTE: This appender writes each message to the System.Console.Out or
            System.Console.Error that is set at the time the event is appended.
            Therefore it is possible to programmatically redirect the output of this appender
            (for example NUnit does this to capture program output). While this is the desired
            behavior of this appender it may have security implications in your application.

See Also
ConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender Members

ConsoleAppender Members Apache log4net™ SDK Documentation
The ConsoleAppender type exposes the following members.
Constructors
 | Name | Description
Public method | ConsoleAppender | Initializes a new instance of the ConsoleAppender class.
Public method | ConsoleAppender(ILayout) | Obsolete. Initializes a new instance of the ConsoleAppender class with the specified layout.
Public method | ConsoleAppender(ILayout, Boolean) | Obsolete. Initializes a new instance of the ConsoleAppender class with the specified layout.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
ConsoleError | The Target to use when writing to the Console standard error output stream.
ConsoleOut | The Target to use when writing to the Console standard output stream.
Back to Top
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Target | Target is the value of the console output stream. This is either "Console.Out" or "Console.Error".
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
ConsoleAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender Constructor

ConsoleAppender Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | ConsoleAppender | Initializes a new instance of the ConsoleAppender class.
Public method | ConsoleAppender(ILayout) | Obsolete. Initializes a new instance of the ConsoleAppender class with the specified layout.
Public method | ConsoleAppender(ILayout, Boolean) | Obsolete. Initializes a new instance of the ConsoleAppender class with the specified layout.
Back to Top
See Also
ConsoleAppender Class
ConsoleAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender Constructor

ConsoleAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the ConsoleAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConsoleAppender()
public ConsoleAppender()
Public Sub New
Public Sub New
public:
ConsoleAppender()
public:
ConsoleAppender()
Remarks

            The instance of the ConsoleAppender class is set up to write
            to the standard output stream.

See Also
ConsoleAppender Class
ConsoleAppender Members
ConsoleAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender Constructor (ILayout)

ConsoleAppender Constructor (ILayout) Apache log4net™ SDK Documentation
Initializes a new instance of the ConsoleAppender class with the specified layout.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Instead use the default constructor and set the Layout property")]
public ConsoleAppender(
    ILayout layout
)
[ObsoleteAttribute("Instead use the default constructor and set the Layout property")]
public ConsoleAppender(
    ILayout layout
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout property")>
Public Sub New (
    layout As ILayout
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout property")>
Public Sub New (
    layout As ILayout
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout property")]
ConsoleAppender(
    ILayout^ layout
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout property")]
ConsoleAppender(
    ILayout^ layout
)
Parameters
layout
Type: log4net.Layout ILayout
the layout to use for this appender
Remarks

            The instance of the ConsoleAppender class is set up to write
            to the standard output stream.

See Also
ConsoleAppender Class
ConsoleAppender Members
ConsoleAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender Constructor (ILayout, Boolean)

ConsoleAppender Constructor (ILayout, Boolean) Apache log4net™ SDK Documentation
Initializes a new instance of the ConsoleAppender class with the specified layout.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Instead use the default constructor and set the Layout & Target properties")]
public ConsoleAppender(
    ILayout layout,
    bool writeToErrorStream
)
[ObsoleteAttribute("Instead use the default constructor and set the Layout & Target properties")]
public ConsoleAppender(
    ILayout layout,
    bool writeToErrorStream
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout & Target properties")>
Public Sub New (
    layout As ILayout,
    writeToErrorStream As Boolean
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout & Target properties")>
Public Sub New (
    layout As ILayout,
    writeToErrorStream As Boolean
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout & Target properties")]
ConsoleAppender(
    ILayout^ layout,
    bool writeToErrorStream
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout & Target properties")]
ConsoleAppender(
    ILayout^ layout,
    bool writeToErrorStream
)
Parameters
layout
Type: log4net.Layout ILayout
the layout to use for this appender
writeToErrorStream
Type:   Online System Boolean
flag set to true to write to the console error stream
Remarks

            When writeToErrorStream is set to true, output is written to
            the standard error output stream.  Otherwise, output is written to the standard
            output stream.

See Also
ConsoleAppender Class
ConsoleAppender Members
ConsoleAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender Fields

ConsoleAppender Fields Apache log4net™ SDK Documentation
The ConsoleAppender type exposes the following members.
Fields
Name | Description
ConsoleError | The Target to use when writing to the Console standard error output stream.
ConsoleOut | The Target to use when writing to the Console standard output stream.
Back to Top
See Also
ConsoleAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender.ConsoleError Field

ConsoleAppender ConsoleError Field Apache log4net™ SDK Documentation
The Target to use when writing to the Console standard error output stream.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ConsoleError
public const string ConsoleError
Public Const ConsoleError As String
Public Const ConsoleError As String
public:
literal String^ ConsoleError
public:
literal String^ ConsoleError
Field Value
Type:   Online String
Remarks

            The Target to use when writing to the Console
            standard error output stream.

See Also
ConsoleAppender Class
ConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender.ConsoleOut Field

ConsoleAppender ConsoleOut Field Apache log4net™ SDK Documentation
The Target to use when writing to the Console standard output stream.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ConsoleOut
public const string ConsoleOut
Public Const ConsoleOut As String
Public Const ConsoleOut As String
public:
literal String^ ConsoleOut
public:
literal String^ ConsoleOut
Field Value
Type:   Online String
Remarks

            The Target to use when writing to the Console
            standard output stream.

See Also
ConsoleAppender Class
ConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender Methods

ConsoleAppender Methods Apache log4net™ SDK Documentation
The ConsoleAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ConsoleAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender.Append Method

ConsoleAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
ConsoleAppender Class
ConsoleAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender.Append Method (LoggingEvent)

ConsoleAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Writes the event to the console.

            The format of the output will depend on the appender's layout.

See Also
ConsoleAppender Class
ConsoleAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender Properties

ConsoleAppender Properties Apache log4net™ SDK Documentation
The ConsoleAppender type exposes the following members.
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Target | Target is the value of the console output stream. This is either "Console.Out" or "Console.Error".
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
ConsoleAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender.RequiresLayout Property

ConsoleAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
ConsoleAppender Class
ConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConsoleAppender.Target Property

ConsoleAppender Target Property Apache log4net™ SDK Documentation
Target is the value of the console output stream. This is either "Console.Out" or "Console.Error".

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Target { get; set; }
public virtual string Target { get; set; }
Public Overridable Property Target As String
    Get
    Set
Public Overridable Property Target As String
    Get
    Set
public:
virtual property String^ Target {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Target {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            Target is the value of the console output stream.
            This is either "Console.Out" or "Console.Error".

Remarks

            Target is the value of the console output stream.
            This is either "Console.Out" or "Console.Error".

See Also
ConsoleAppender Class
ConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DebugAppender Class

DebugAppender Class Apache log4net™ SDK Documentation
Appends log events to the Online Debug system.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender DebugAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DebugAppender : AppenderSkeleton
public class DebugAppender : AppenderSkeleton
Public Class DebugAppender
    Inherits AppenderSkeleton
Public Class DebugAppender
    Inherits AppenderSkeleton
public ref class DebugAppender : public AppenderSkeleton
public ref class DebugAppender : public AppenderSkeleton
Remarks

            The application configuration file can be used to control what listeners
            are actually used. See the MSDN documentation for the
              Online Debug class for details on configuring the
            debug system.

            Events are written using the Write(string, string)
            method. The event's logger name is passed as the value for the category name to the Write method.

See Also
DebugAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DebugAppender Members

DebugAppender Members Apache log4net™ SDK Documentation
The DebugAppender type exposes the following members.
Constructors
 | Name | Description
Public method | DebugAppender | Initializes a new instance of the DebugAppender.
Public method | DebugAppender(ILayout) | Obsolete. Initializes a new instance of the DebugAppender with a specified layout.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Writes the logging event to the Online Debug system. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | ImmediateFlush | Gets or sets a value that indicates whether the appender will flush at the end of each write.
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
DebugAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DebugAppender Constructor

DebugAppender Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | DebugAppender | Initializes a new instance of the DebugAppender.
Public method | DebugAppender(ILayout) | Obsolete. Initializes a new instance of the DebugAppender with a specified layout.
Back to Top
See Also
DebugAppender Class
DebugAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DebugAppender Constructor

DebugAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the DebugAppender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DebugAppender()
public DebugAppender()
Public Sub New
Public Sub New
public:
DebugAppender()
public:
DebugAppender()
Remarks

            Default constructor.

See Also
DebugAppender Class
DebugAppender Members
DebugAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DebugAppender Constructor (ILayout)

DebugAppender Constructor (ILayout) Apache log4net™ SDK Documentation
Initializes a new instance of the DebugAppender with a specified layout.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Instead use the default constructor and set the Layout property")]
public DebugAppender(
    ILayout layout
)
[ObsoleteAttribute("Instead use the default constructor and set the Layout property")]
public DebugAppender(
    ILayout layout
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout property")>
Public Sub New (
    layout As ILayout
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout property")>
Public Sub New (
    layout As ILayout
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout property")]
DebugAppender(
    ILayout^ layout
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout property")]
DebugAppender(
    ILayout^ layout
)
Parameters
layout
Type: log4net.Layout ILayout
The layout to use with this appender.
Remarks

            Obsolete constructor.

See Also
DebugAppender Class
DebugAppender Members
DebugAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DebugAppender Methods

DebugAppender Methods Apache log4net™ SDK Documentation
The DebugAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Writes the logging event to the Online Debug system. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DebugAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DebugAppender.Append Method

DebugAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Writes the logging event to the Online Debug system. (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
DebugAppender Class
DebugAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DebugAppender.Append Method (LoggingEvent)

DebugAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
Writes the logging event to the Online Debug system.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Writes the logging event to the   Online Debug system.
            If ImmediateFlush is true then the   Online Flush
            is called.

See Also
DebugAppender Class
DebugAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DebugAppender Properties

DebugAppender Properties Apache log4net™ SDK Documentation
The DebugAppender type exposes the following members.
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | ImmediateFlush | Gets or sets a value that indicates whether the appender will flush at the end of each write.
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
DebugAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DebugAppender.ImmediateFlush Property

DebugAppender ImmediateFlush Property Apache log4net™ SDK Documentation
Gets or sets a value that indicates whether the appender will flush at the end of each write.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ImmediateFlush { get; set; }
public bool ImmediateFlush { get; set; }
Public Property ImmediateFlush As Boolean
    Get
    Set
Public Property ImmediateFlush As Boolean
    Get
    Set
public:
property bool ImmediateFlush {
    bool get ();
    void set (bool value);
}
public:
property bool ImmediateFlush {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
Remarks
The default behavior is to flush at the end of each
            write. If the option is set tofalse, then the underlying
            stream can defer writing to physical medium to a later time.

            Avoiding the flush operation at the end of each append results
            in a performance gain of 10 to 20 percent. However, there is safety
            trade-off involved in skipping flushing. Indeed, when flushing is
            skipped, then it is likely that the last few log events will not
            be recorded on disk when the application exits. This is a high
            price to pay even for a 20% performance gain.

See Also
DebugAppender Class
DebugAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DebugAppender.RequiresLayout Property

DebugAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
DebugAppender Class
DebugAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender Class

EventLogAppender Class Apache log4net™ SDK Documentation
Writes events to the system event log.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender EventLogAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class EventLogAppender : AppenderSkeleton
public class EventLogAppender : AppenderSkeleton
Public Class EventLogAppender
    Inherits AppenderSkeleton
Public Class EventLogAppender
    Inherits AppenderSkeleton
public ref class EventLogAppender : public AppenderSkeleton
public ref class EventLogAppender : public AppenderSkeleton
Remarks

            The appender will fail if you try to write using an event source that doesn't exist unless it is running with local administrator privileges.
            See also http://logging.apache.org/log4net/release/faq.html#trouble-EventLog

            The EventID of the event log entry can be
            set using the EventID property (Properties)
            on the LoggingEvent.

            The Category of the event log entry can be
            set using the Category property (Properties)
            on the LoggingEvent.

            There is a limit of 32K characters for an event log message

            When configuring the EventLogAppender a mapping can be
            specified to map a logging level to an event log entry type. For example:

XML
View Colorized Copy to Clipboard Print
<mapping>
    <level value="ERROR" />
    <eventLogEntryType value="Error" />
</mapping>
<mapping>
    <level value="DEBUG" />
    <eventLogEntryType value="Information" />
</mapping>
<mapping>
    <level value="ERROR" />
    <eventLogEntryType value="Error" />
</mapping>
<mapping>
    <level value="DEBUG" />
    <eventLogEntryType value="Information" />
</mapping>

            The Level is the standard log4net logging level and eventLogEntryType can be any value
            from the   Online EventLogEntryType enum, i.e.:

  • Error
    an error event
  • Warning
    a warning event
  • Information
    an informational event
See Also
EventLogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender Members

EventLogAppender Members Apache log4net™ SDK Documentation
The EventLogAppender type exposes the following members.
Constructors
 | Name | Description
Public method | EventLogAppender | Initializes a new instance of the EventLogAppender class.
Public method | EventLogAppender(ILayout) | Obsolete. Initializes a new instance of the EventLogAppender class with the specified ILayout.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddMapping | Add a mapping of level to Online EventLogEntryType - done by the config file
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Protected method | GetEntryType | Get the equivalent Online EventLogEntryType for a Level level
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationName | Property used to set the Application name. This appears in the event logs when logging.
Public property | Category | Gets or sets the Category to use unless one is explicitly specified via the LoggingEvent's properties.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | EventId | Gets or sets the EventId to use unless one is explicitly specified via the LoggingEvent's properties.
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | LogName | The name of the log where messages will be stored.
Public property | MachineName | This property is used to return the name of the computer to use when accessing the event logs. Currently, this is the current computer, denoted by a dot "."
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | SecurityContext | Gets or sets the SecurityContext used to write to the EventLog.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
EventLogAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender Constructor

EventLogAppender Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | EventLogAppender | Initializes a new instance of the EventLogAppender class.
Public method | EventLogAppender(ILayout) | Obsolete. Initializes a new instance of the EventLogAppender class with the specified ILayout.
Back to Top
See Also
EventLogAppender Class
EventLogAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender Constructor

EventLogAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the EventLogAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventLogAppender()
public EventLogAppender()
Public Sub New
Public Sub New
public:
EventLogAppender()
public:
EventLogAppender()
Remarks

            Default constructor.

See Also
EventLogAppender Class
EventLogAppender Members
EventLogAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender Constructor (ILayout)

EventLogAppender Constructor (ILayout) Apache log4net™ SDK Documentation
Initializes a new instance of the EventLogAppender class with the specified ILayout.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Instead use the default constructor and set the Layout property")]
public EventLogAppender(
    ILayout layout
)
[ObsoleteAttribute("Instead use the default constructor and set the Layout property")]
public EventLogAppender(
    ILayout layout
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout property")>
Public Sub New (
    layout As ILayout
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout property")>
Public Sub New (
    layout As ILayout
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout property")]
EventLogAppender(
    ILayout^ layout
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout property")]
EventLogAppender(
    ILayout^ layout
)
Parameters
layout
Type: log4net.Layout ILayout
The ILayout to use with this appender.
Remarks

            Obsolete constructor.

See Also
EventLogAppender Class
EventLogAppender Members
EventLogAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender Methods

EventLogAppender Methods Apache log4net™ SDK Documentation
The EventLogAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddMapping | Add a mapping of level to Online EventLogEntryType - done by the config file
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Protected method | GetEntryType | Get the equivalent Online EventLogEntryType for a Level level
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
EventLogAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.ActivateOptions Method

EventLogAppender ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the appender based on the options set

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
EventLogAppender Class
EventLogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.AddMapping Method

EventLogAppender AddMapping Method Apache log4net™ SDK Documentation
Add a mapping of level to Online EventLogEntryType - done by the config file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddMapping(
    EventLogAppender..::..Level2EventLogEntryType mapping
)
public void AddMapping(
    EventLogAppender..::..Level2EventLogEntryType mapping
)
Public Sub AddMapping (
    mapping As EventLogAppender..::..Level2EventLogEntryType
)
Public Sub AddMapping (
    mapping As EventLogAppender..::..Level2EventLogEntryType
)
public:
void AddMapping(
    EventLogAppender..::..Level2EventLogEntryType^ mapping
)
public:
void AddMapping(
    EventLogAppender..::..Level2EventLogEntryType^ mapping
)
Parameters
mapping
Type: log4net.Appender EventLogAppender Level2EventLogEntryType
The mapping to add
Remarks

            Add a EventLogAppender Level2EventLogEntryType mapping to this appender.
            Each mapping defines the event log entry type for a level.

See Also
EventLogAppender Class
EventLogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.Append Method

EventLogAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
EventLogAppender Class
EventLogAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.Append Method (LoggingEvent)

EventLogAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the event to log
Remarks
Writes the event to the system event log using the
            ApplicationName.
If the event has an EventID property (see Properties)
            set then this integer will be used as the event log event id.

            There is a limit of 32K characters for an event log message

See Also
EventLogAppender Class
EventLogAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.GetEntryType Method

EventLogAppender GetEntryType Method Apache log4net™ SDK Documentation
Get the equivalent Online EventLogEntryType for a Level level

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual EventLogEntryType GetEntryType(
    Level level
)
protected virtual EventLogEntryType GetEntryType(
    Level level
)
Protected Overridable Function GetEntryType (
    level As Level
) As EventLogEntryType
Protected Overridable Function GetEntryType (
    level As Level
) As EventLogEntryType
protected:
virtual EventLogEntryType GetEntryType(
    Level^ level
)
protected:
virtual EventLogEntryType GetEntryType(
    Level^ level
)
Parameters
level
Type: log4net.Core Level
the Level to convert to an EventLogEntryType
Return Value
Type:   Online EventLogEntryType
The equivalent   Online EventLogEntryType for a Level level
Remarks

            Because there are fewer applicable   Online EventLogEntryType
            values to use in logging levels than there are in the
            Level this is a one way mapping. There is
            a loss of information during the conversion.

See Also
EventLogAppender Class
EventLogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender Properties

EventLogAppender Properties Apache log4net™ SDK Documentation
The EventLogAppender type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationName | Property used to set the Application name. This appears in the event logs when logging.
Public property | Category | Gets or sets the Category to use unless one is explicitly specified via the LoggingEvent's properties.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | EventId | Gets or sets the EventId to use unless one is explicitly specified via the LoggingEvent's properties.
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | LogName | The name of the log where messages will be stored.
Public property | MachineName | This property is used to return the name of the computer to use when accessing the event logs. Currently, this is the current computer, denoted by a dot "."
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | SecurityContext | Gets or sets the SecurityContext used to write to the EventLog.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
EventLogAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.ApplicationName Property

EventLogAppender ApplicationName Property Apache log4net™ SDK Documentation
Property used to set the Application name. This appears in the event logs when logging.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ApplicationName { get; set; }
public string ApplicationName { get; set; }
Public Property ApplicationName As String
    Get
    Set
Public Property ApplicationName As String
    Get
    Set
public:
property String^ ApplicationName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ApplicationName {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The string used to distinguish events from different sources.

Remarks

            Sets the event log source property.

See Also
EventLogAppender Class
EventLogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.Category Property

EventLogAppender Category Property Apache log4net™ SDK Documentation
Gets or sets the Category to use unless one is explicitly specified via the LoggingEvent's properties.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public short Category { get; set; }
public short Category { get; set; }
Public Property Category As Short
    Get
    Set
Public Property Category As Short
    Get
    Set
public:
property short Category {
    short get ();
    void set (short value);
}
public:
property short Category {
    short get ();
    void set (short value);
}
Property Value
Type:   Online Int16
Remarks

            The Category of the event log entry will normally be
            set using the Category property (Properties)
            on the LoggingEvent.
            This property provides the fallback value which defaults to 0.

See Also
EventLogAppender Class
EventLogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.EventId Property

EventLogAppender EventId Property Apache log4net™ SDK Documentation
Gets or sets the EventId to use unless one is explicitly specified via the LoggingEvent's properties.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int EventId { get; set; }
public int EventId { get; set; }
Public Property EventId As Integer
    Get
    Set
Public Property EventId As Integer
    Get
    Set
public:
property int EventId {
    int get ();
    void set (int value);
}
public:
property int EventId {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32
Remarks

            The EventID of the event log entry will normally be
            set using the EventID property (Properties)
            on the LoggingEvent.
            This property provides the fallback value which defaults to 0.

See Also
EventLogAppender Class
EventLogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.LogName Property

EventLogAppender LogName Property Apache log4net™ SDK Documentation
The name of the log where messages will be stored.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LogName { get; set; }
public string LogName { get; set; }
Public Property LogName As String
    Get
    Set
Public Property LogName As String
    Get
    Set
public:
property String^ LogName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ LogName {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The string name of the log where messages will be stored.

Remarks
This is the name of the log as it appears in the Event Viewer
            tree. The default value is to log into the Application
            log, this is where most applications write their events. However
            if you need a separate log for your application (or applications)
            then you should set the LogName appropriately.
This should not be used to distinguish your event log messages
            from those of other applications, the ApplicationName
            property should be used to distinguish events. This property should be
            used to group together events into a single log.

See Also
EventLogAppender Class
EventLogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.MachineName Property

EventLogAppender MachineName Property Apache log4net™ SDK Documentation
This property is used to return the name of the computer to use when accessing the event logs. Currently, this is the current computer, denoted by a dot "."

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MachineName { get; set; }
public string MachineName { get; set; }
Public Property MachineName As String
    Get
    Set
Public Property MachineName As String
    Get
    Set
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The string name of the machine holding the event log that
            will be logged into.

Remarks

            This property cannot be changed. It is currently set to '.'
            i.e. the local machine. This may be changed in future.

See Also
EventLogAppender Class
EventLogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.RequiresLayout Property

EventLogAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
EventLogAppender Class
EventLogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.SecurityContext Property

EventLogAppender SecurityContext Property Apache log4net™ SDK Documentation
Gets or sets the SecurityContext used to write to the EventLog.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityContext SecurityContext { get; set; }
public SecurityContext SecurityContext { get; set; }
Public Property SecurityContext As SecurityContext
    Get
    Set
Public Property SecurityContext As SecurityContext
    Get
    Set
public:
property SecurityContext^ SecurityContext {
    SecurityContext^ get ();
    void set (SecurityContext^ value);
}
public:
property SecurityContext^ SecurityContext {
    SecurityContext^ get ();
    void set (SecurityContext^ value);
}
Property Value
Type: SecurityContext

            The SecurityContext used to write to the EventLog.

Remarks

            The system security context used to write to the EventLog.

            Unless a SecurityContext specified here for this appender
            the DefaultProvider is queried for the
            security context to use. The default behavior is to use the security context
            of the current thread.

See Also
EventLogAppender Class
EventLogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.Level2EventLogEntryType Class

EventLogAppender Level2EventLogEntryType Class Apache log4net™ SDK Documentation
A class to act as a mapping between the level that a logging call is made at and the color it should be displayed as.
Inheritance Hierarchy
Online System Object
log4net.Util LevelMappingEntry
log4net.Appender EventLogAppender Level2EventLogEntryType

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Level2EventLogEntryType : LevelMappingEntry
public class Level2EventLogEntryType : LevelMappingEntry
Public Class Level2EventLogEntryType
    Inherits LevelMappingEntry
Public Class Level2EventLogEntryType
    Inherits LevelMappingEntry
public ref class Level2EventLogEntryType : public LevelMappingEntry
public ref class Level2EventLogEntryType : public LevelMappingEntry
Remarks

            Defines the mapping between a level and its event log entry type.

See Also
EventLogAppender Level2EventLogEntryType Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.Level2EventLogEntryType Members

EventLogAppender Level2EventLogEntryType Members Apache log4net™ SDK Documentation
The EventLogAppender Level2EventLogEntryType type exposes the following members.
Constructors
 | Name | Description
Public method | EventLogAppender Level2EventLogEntryType | Initializes a new instance of the EventLogAppender Level2EventLogEntryType class
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize any options defined on this entry (Inherited from LevelMappingEntry.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | EventLogEntryType | The EventLogEntryType for this entry
Public property | Level | The level that is the key for this mapping (Inherited from LevelMappingEntry.)
Back to Top
See Also
EventLogAppender Level2EventLogEntryType Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.Level2EventLogEntryType Constructor

EventLogAppender Level2EventLogEntryType Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the EventLogAppender Level2EventLogEntryType class

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level2EventLogEntryType()
public Level2EventLogEntryType()
Public Sub New
Public Sub New
public:
Level2EventLogEntryType()
public:
Level2EventLogEntryType()
See Also
EventLogAppender Level2EventLogEntryType Class
EventLogAppender Level2EventLogEntryType Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.Level2EventLogEntryType Methods

EventLogAppender Level2EventLogEntryType Methods Apache log4net™ SDK Documentation
The EventLogAppender Level2EventLogEntryType type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize any options defined on this entry (Inherited from LevelMappingEntry.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
EventLogAppender Level2EventLogEntryType Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.Level2EventLogEntryType Properties

EventLogAppender Level2EventLogEntryType Properties Apache log4net™ SDK Documentation
The EventLogAppender Level2EventLogEntryType type exposes the following members.
Properties
 | Name | Description
Public property | EventLogEntryType | The EventLogEntryType for this entry
Public property | Level | The level that is the key for this mapping (Inherited from LevelMappingEntry.)
Back to Top
See Also
EventLogAppender Level2EventLogEntryType Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EventLogAppender.Level2EventLogEntryType.EventLogEntryType Property

EventLogAppender Level2EventLogEntryType EventLogEntryType Property Apache log4net™ SDK Documentation
The EventLogEntryType for this entry

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventLogEntryType EventLogEntryType { get; set; }
public EventLogEntryType EventLogEntryType { get; set; }
Public Property EventLogEntryType As EventLogEntryType
    Get
    Set
Public Property EventLogEntryType As EventLogEntryType
    Get
    Set
public:
property EventLogEntryType EventLogEntryType {
    EventLogEntryType get ();
    void set (EventLogEntryType value);
}
public:
property EventLogEntryType EventLogEntryType {
    EventLogEntryType get ();
    void set (EventLogEntryType value);
}
Property Value
Type:   Online EventLogEntryType
Remarks

            Required property.
            The EventLogEntryType for this entry

See Also
EventLogAppender Level2EventLogEntryType Class
EventLogAppender Level2EventLogEntryType Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender Class

FileAppender Class Apache log4net™ SDK Documentation
Appends logging events to a file.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender TextWriterAppender
log4net.Appender FileAppender
log4net.Appender RollingFileAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FileAppender : TextWriterAppender
public class FileAppender : TextWriterAppender
Public Class FileAppender
    Inherits TextWriterAppender
Public Class FileAppender
    Inherits TextWriterAppender
public ref class FileAppender : public TextWriterAppender
public ref class FileAppender : public TextWriterAppender
Remarks

            Logging events are sent to the file specified by
            the File property.

            The file can be opened in either append or overwrite mode
            by specifying the AppendToFile property.
            If the file path is relative it is taken as relative from
            the application base directory. The file encoding can be
            specified by setting the Encoding property.

            The layout's Header and Footer
            values will be written each time the file is opened and closed
            respectively. If the AppendToFile property is
            then the file may contain multiple copies of the header and footer.

            This appender will first try to open the file for writing when ActivateOptions
            is called. This will typically be during configuration.
            If the file cannot be opened for writing the appender will attempt
            to open the file again each time a message is logged to the appender.
            If the file cannot be opened for writing when a message is logged then
            the message will be discarded by this appender.

            The FileAppender supports pluggable file locking models via
            the LockingModel property.
            The default behavior, implemented by FileAppender ExclusiveLock
            is to obtain an exclusive write lock on the file until this appender is closed.
            The alternative models only hold a
            write lock while the appender is writing a logging event (FileAppender MinimalLock)
            or synchronize by using a named system wide Mutex (FileAppender InterProcessLock).

            All locking strategies have issues and you should seriously consider using a different strategy that
            avoids having multiple processes logging to the same file.

See Also
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender Members

FileAppender Members Apache log4net™ SDK Documentation
The FileAppender type exposes the following members.
Constructors
 | Name | Description
Public method | FileAppender | Default constructor
Public method | FileAppender(ILayout, String) | Obsolete. Construct a new appender using the layout and file specified. The file will be appended to.
Public method | FileAppender(ILayout, String, Boolean) | Obsolete. Construct a new appender using the layout, file and append mode.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Activate the options on the file appender. (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides TextWriterAppender Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | This method is called by the DoAppend( LoggingEvent ) method. (Overrides TextWriterAppender Append( LoggingEvent ).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Protected method | CloseFile | Closes the previously opened file.
Protected method | CloseWriter | Closes the underlying Online TextWriter. (Overrides TextWriterAppender CloseWriter .)
 | ConvertToFullPath | Convert a path into a fully qualified path.
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Close this appender instance. The underlying stream or writer is also closed. (Inherited from TextWriterAppender.)
Protected method | OpenFile | Sets and opens the file where the log output will go. The specified file must be writable.
Protected method | PreAppendCheck | This method determines if there is a sense in attempting to append. (Inherited from TextWriterAppender.)
Protected method | PrepareWriter | Called to initialize the file writer (Overrides TextWriterAppender PrepareWriter .)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | Reset | Closes any previously opened file and calls the parent's Reset . (Overrides TextWriterAppender Reset .)
Protected method | SafeOpenFile | Sets and opens the file where the log output will go. The specified file must be writable.
Protected method | SetQWForFiles(Stream) | Sets the quiet writer used for file output
Protected method | SetQWForFiles(TextWriter) | Sets the quiet writer being used.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Protected method | WriteFooter | Writes a footer as produced by the embedded layout's Footer property. (Overrides TextWriterAppender WriteFooter .)
Protected method | WriteFooterAndCloseWriter | Writes the footer and closes the underlying Online TextWriter. (Inherited from TextWriterAppender.)
Protected method | WriteHeader | Writes a header produced by the embedded layout's Header property. (Overrides TextWriterAppender WriteHeader .)
Back to Top
Properties
 | Name | Description
Public property | AppendToFile | Gets or sets a flag that indicates whether the file should be appended to or overwritten.
Public property | Encoding | Gets or sets Encoding used to write to the file.
Public property | ErrorHandler | Gets or set the IErrorHandler and the underlying QuietTextWriter, if any, for this appender. (Inherited from TextWriterAppender.)
Public property | File | Gets or sets the path to the file that logging will be written to.
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | ImmediateFlush | Gets or set whether the appender will flush at the end of each append operation. (Inherited from TextWriterAppender.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | LockingModel | Gets or sets the LockingModel used to handle locking of the file.
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | QuietWriter | Gets or sets the QuietTextWriter where logging events will be written to. (Inherited from TextWriterAppender.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Inherited from TextWriterAppender.)
Public property | SecurityContext | Gets or sets the SecurityContext used to write to the file.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Public property | Writer | Sets the Online TextWriter where the log output will go. (Inherited from TextWriterAppender.)
Back to Top
See Also
FileAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender Constructor

FileAppender Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | FileAppender | Default constructor
Public method | FileAppender(ILayout, String) | Obsolete. Construct a new appender using the layout and file specified. The file will be appended to.
Public method | FileAppender(ILayout, String, Boolean) | Obsolete. Construct a new appender using the layout, file and append mode.
Back to Top
See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender Constructor

FileAppender Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileAppender()
public FileAppender()
Public Sub New
Public Sub New
public:
FileAppender()
public:
FileAppender()
Remarks

            Default constructor

See Also
FileAppender Class
FileAppender Members
FileAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender Constructor (ILayout, String)

FileAppender Constructor (ILayout, String) Apache log4net™ SDK Documentation
Construct a new appender using the layout and file specified. The file will be appended to.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Instead use the default constructor and set the Layout & File properties")]
public FileAppender(
    ILayout layout,
    string filename
)
[ObsoleteAttribute("Instead use the default constructor and set the Layout & File properties")]
public FileAppender(
    ILayout layout,
    string filename
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout & File properties")>
Public Sub New (
    layout As ILayout,
    filename As String
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout & File properties")>
Public Sub New (
    layout As ILayout,
    filename As String
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout & File properties")]
FileAppender(
    ILayout^ layout,
    String^ filename
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout & File properties")]
FileAppender(
    ILayout^ layout,
    String^ filename
)
Parameters
layout
Type: log4net.Layout ILayout
the layout to use with this appender
filename
Type:   Online System String
the full path to the file to write to
Remarks

            Obsolete constructor.

See Also
FileAppender Class
FileAppender Members
FileAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender Constructor (ILayout, String, Boolean)

FileAppender Constructor (ILayout, String, Boolean) Apache log4net™ SDK Documentation
Construct a new appender using the layout, file and append mode.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Instead use the default constructor and set the Layout, File & AppendToFile properties")]
public FileAppender(
    ILayout layout,
    string filename,
    bool append
)
[ObsoleteAttribute("Instead use the default constructor and set the Layout, File & AppendToFile properties")]
public FileAppender(
    ILayout layout,
    string filename,
    bool append
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout, File & AppendToFile properties")>
Public Sub New (
    layout As ILayout,
    filename As String,
    append As Boolean
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout, File & AppendToFile properties")>
Public Sub New (
    layout As ILayout,
    filename As String,
    append As Boolean
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout, File & AppendToFile properties")]
FileAppender(
    ILayout^ layout,
    String^ filename,
    bool append
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout, File & AppendToFile properties")]
FileAppender(
    ILayout^ layout,
    String^ filename,
    bool append
)
Parameters
layout
Type: log4net.Layout ILayout
the layout to use with this appender
filename
Type:   Online System String
the full path to the file to write to
append
Type:   Online System Boolean
flag to indicate if the file should be appended to
Remarks

            Obsolete constructor.

See Also
FileAppender Class
FileAppender Members
FileAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender Methods

FileAppender Methods Apache log4net™ SDK Documentation
The FileAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Activate the options on the file appender. (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides TextWriterAppender Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | This method is called by the DoAppend( LoggingEvent ) method. (Overrides TextWriterAppender Append( LoggingEvent ).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Protected method | CloseFile | Closes the previously opened file.
Protected method | CloseWriter | Closes the underlying Online TextWriter. (Overrides TextWriterAppender CloseWriter .)
 | ConvertToFullPath | Convert a path into a fully qualified path.
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Close this appender instance. The underlying stream or writer is also closed. (Inherited from TextWriterAppender.)
Protected method | OpenFile | Sets and opens the file where the log output will go. The specified file must be writable.
Protected method | PreAppendCheck | This method determines if there is a sense in attempting to append. (Inherited from TextWriterAppender.)
Protected method | PrepareWriter | Called to initialize the file writer (Overrides TextWriterAppender PrepareWriter .)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | Reset | Closes any previously opened file and calls the parent's Reset . (Overrides TextWriterAppender Reset .)
Protected method | SafeOpenFile | Sets and opens the file where the log output will go. The specified file must be writable.
Protected method | SetQWForFiles(Stream) | Sets the quiet writer used for file output
Protected method | SetQWForFiles(TextWriter) | Sets the quiet writer being used.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Protected method | WriteFooter | Writes a footer as produced by the embedded layout's Footer property. (Overrides TextWriterAppender WriteFooter .)
Protected method | WriteFooterAndCloseWriter | Writes the footer and closes the underlying Online TextWriter. (Inherited from TextWriterAppender.)
Protected method | WriteHeader | Writes a header produced by the embedded layout's Header property. (Overrides TextWriterAppender WriteHeader .)
Back to Top
See Also
FileAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.ActivateOptions Method

FileAppender ActivateOptions Method Apache log4net™ SDK Documentation
Activate the options on the file appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

            This will cause the file to be opened.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.Append Method

FileAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides TextWriterAppender Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | This method is called by the DoAppend( LoggingEvent ) method. (Overrides TextWriterAppender Append( LoggingEvent ).)
Back to Top
See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.Append Method (LoggingEvent)

FileAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Writes a log statement to the output stream if the output stream exists
            and is writable.

            The format of the output will depend on the appender's layout.

See Also
FileAppender Class
FileAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.Append Method (LoggingEvent[])

FileAppender Append Method ( LoggingEvent ) Apache log4net™ SDK Documentation
This method is called by the DoAppend( LoggingEvent ) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent[] loggingEvents
)
protected override void Append(
    LoggingEvent[] loggingEvents
)
Protected Overrides Sub Append (
    loggingEvents As LoggingEvent()
)
Protected Overrides Sub Append (
    loggingEvents As LoggingEvent()
)
protected:
virtual void Append(
    array<LoggingEvent^>^ loggingEvents
) override
protected:
virtual void Append(
    array<LoggingEvent^>^ loggingEvents
) override
Parameters
loggingEvents
Type:  log4net.Core LoggingEvent
The array of events to log.
Remarks

            Acquires the output file locks once before writing all the events to
            the stream.

See Also
FileAppender Class
FileAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.CloseFile Method

FileAppender CloseFile Method Apache log4net™ SDK Documentation
Closes the previously opened file.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void CloseFile()
protected void CloseFile()
Protected Sub CloseFile
Protected Sub CloseFile
protected:
void CloseFile()
protected:
void CloseFile()
Remarks

            Writes the Footer to the file and then
            closes the file.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.CloseWriter Method

FileAppender CloseWriter Method Apache log4net™ SDK Documentation
Closes the underlying Online TextWriter.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void CloseWriter()
protected override void CloseWriter()
Protected Overrides Sub CloseWriter
Protected Overrides Sub CloseWriter
protected:
virtual void CloseWriter() override
protected:
virtual void CloseWriter() override
Remarks

            Closes the underlying   Online TextWriter.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.ConvertToFullPath Method

FileAppender ConvertToFullPath Method Apache log4net™ SDK Documentation
Convert a path into a fully qualified path.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static string ConvertToFullPath(
    string path
)
protected static string ConvertToFullPath(
    string path
)
Protected Shared Function ConvertToFullPath (
    path As String
) As String
Protected Shared Function ConvertToFullPath (
    path As String
) As String
protected:
static String^ ConvertToFullPath(
    String^ path
)
protected:
static String^ ConvertToFullPath(
    String^ path
)
Parameters
path
Type:   Online System String
The path to convert.
Return Value
Type:   Online String
The fully qualified path.
Remarks

            Converts the path specified to a fully
            qualified path. If the path is relative it is
            taken as relative from the application base
            directory.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.OpenFile Method

FileAppender OpenFile Method Apache log4net™ SDK Documentation
Sets and opens the file where the log output will go. The specified file must be writable.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void OpenFile(
    string fileName,
    bool append
)
protected virtual void OpenFile(
    string fileName,
    bool append
)
Protected Overridable Sub OpenFile (
    fileName As String,
    append As Boolean
)
Protected Overridable Sub OpenFile (
    fileName As String,
    append As Boolean
)
protected:
virtual void OpenFile(
    String^ fileName,
    bool append
)
protected:
virtual void OpenFile(
    String^ fileName,
    bool append
)
Parameters
fileName
Type:   Online System String
The path to the log file. Must be a fully qualified path.
append
Type:   Online System Boolean
If true will append to fileName. Otherwise will truncate fileName
Remarks

            If there was already an opened file, then the previous file
            is closed first.

            This method will ensure that the directory structure
            for the fileName specified exists.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.PrepareWriter Method

FileAppender PrepareWriter Method Apache log4net™ SDK Documentation
Called to initialize the file writer

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void PrepareWriter()
protected override void PrepareWriter()
Protected Overrides Sub PrepareWriter
Protected Overrides Sub PrepareWriter
protected:
virtual void PrepareWriter() override
protected:
virtual void PrepareWriter() override
Remarks

            Will be called for each logged message until the file is
            successfully opened.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.Reset Method

FileAppender Reset Method Apache log4net™ SDK Documentation
Closes any previously opened file and calls the parent's Reset .

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Reset()
protected override void Reset()
Protected Overrides Sub Reset
Protected Overrides Sub Reset
protected:
virtual void Reset() override
protected:
virtual void Reset() override
Remarks

            Resets the filename and the file stream.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.SafeOpenFile Method

FileAppender SafeOpenFile Method Apache log4net™ SDK Documentation
Sets and opens the file where the log output will go. The specified file must be writable.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void SafeOpenFile(
    string fileName,
    bool append
)
protected virtual void SafeOpenFile(
    string fileName,
    bool append
)
Protected Overridable Sub SafeOpenFile (
    fileName As String,
    append As Boolean
)
Protected Overridable Sub SafeOpenFile (
    fileName As String,
    append As Boolean
)
protected:
virtual void SafeOpenFile(
    String^ fileName,
    bool append
)
protected:
virtual void SafeOpenFile(
    String^ fileName,
    bool append
)
Parameters
fileName
Type:   Online System String
The path to the log file. Must be a fully qualified path.
append
Type:   Online System Boolean
If true will append to fileName. Otherwise will truncate fileName
Remarks

            Calls OpenFile(String, Boolean) but guarantees not to throw an exception.
            Errors are passed to the ErrorHandler.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.SetQWForFiles Method

FileAppender SetQWForFiles Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | SetQWForFiles(Stream) | Sets the quiet writer used for file output
Protected method | SetQWForFiles(TextWriter) | Sets the quiet writer being used.
Back to Top
See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.SetQWForFiles Method (Stream)

FileAppender SetQWForFiles Method (Stream) Apache log4net™ SDK Documentation
Sets the quiet writer used for file output

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void SetQWForFiles(
    Stream fileStream
)
protected virtual void SetQWForFiles(
    Stream fileStream
)
Protected Overridable Sub SetQWForFiles (
    fileStream As Stream
)
Protected Overridable Sub SetQWForFiles (
    fileStream As Stream
)
protected:
virtual void SetQWForFiles(
    Stream^ fileStream
)
protected:
virtual void SetQWForFiles(
    Stream^ fileStream
)
Parameters
fileStream
Type:   Online System.IO Stream
the file stream that has been opened for writing
Remarks

            This implementation of [M:SetQWForFiles(Stream)] creates a   Online StreamWriter
            over the fileStream and passes it to the
            [M:SetQWForFiles(TextWriter)] method.

            This method can be overridden by sub classes that want to wrap the
              Online Stream in some way, for example to encrypt the output
            data using a System.Security.Cryptography.CryptoStream.

See Also
FileAppender Class
FileAppender Members
SetQWForFiles Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.SetQWForFiles Method (TextWriter)

FileAppender SetQWForFiles Method (TextWriter) Apache log4net™ SDK Documentation
Sets the quiet writer being used.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void SetQWForFiles(
    TextWriter writer
)
protected virtual void SetQWForFiles(
    TextWriter writer
)
Protected Overridable Sub SetQWForFiles (
    writer As TextWriter
)
Protected Overridable Sub SetQWForFiles (
    writer As TextWriter
)
protected:
virtual void SetQWForFiles(
    TextWriter^ writer
)
protected:
virtual void SetQWForFiles(
    TextWriter^ writer
)
Parameters
writer
Type:   Online System.IO TextWriter
the writer over the file stream that has been opened for writing
Remarks

            This method can be overridden by sub classes that want to
            wrap the   Online TextWriter in some way.

See Also
FileAppender Class
FileAppender Members
SetQWForFiles Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.WriteFooter Method

FileAppender WriteFooter Method Apache log4net™ SDK Documentation
Writes a footer as produced by the embedded layout's Footer property.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void WriteFooter()
protected override void WriteFooter()
Protected Overrides Sub WriteFooter
Protected Overrides Sub WriteFooter
protected:
virtual void WriteFooter() override
protected:
virtual void WriteFooter() override
Remarks

            Writes a footer as produced by the embedded layout's Footer property.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.WriteHeader Method

FileAppender WriteHeader Method Apache log4net™ SDK Documentation
Writes a header produced by the embedded layout's Header property.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void WriteHeader()
protected override void WriteHeader()
Protected Overrides Sub WriteHeader
Protected Overrides Sub WriteHeader
protected:
virtual void WriteHeader() override
protected:
virtual void WriteHeader() override
Remarks

            Writes a header produced by the embedded layout's Header property.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender Properties

FileAppender Properties Apache log4net™ SDK Documentation
The FileAppender type exposes the following members.
Properties
 | Name | Description
Public property | AppendToFile | Gets or sets a flag that indicates whether the file should be appended to or overwritten.
Public property | Encoding | Gets or sets Encoding used to write to the file.
Public property | ErrorHandler | Gets or set the IErrorHandler and the underlying QuietTextWriter, if any, for this appender. (Inherited from TextWriterAppender.)
Public property | File | Gets or sets the path to the file that logging will be written to.
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | ImmediateFlush | Gets or set whether the appender will flush at the end of each append operation. (Inherited from TextWriterAppender.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | LockingModel | Gets or sets the LockingModel used to handle locking of the file.
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | QuietWriter | Gets or sets the QuietTextWriter where logging events will be written to. (Inherited from TextWriterAppender.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Inherited from TextWriterAppender.)
Public property | SecurityContext | Gets or sets the SecurityContext used to write to the file.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Public property | Writer | Sets the Online TextWriter where the log output will go. (Inherited from TextWriterAppender.)
Back to Top
See Also
FileAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.AppendToFile Property

FileAppender AppendToFile Property Apache log4net™ SDK Documentation
Gets or sets a flag that indicates whether the file should be appended to or overwritten.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AppendToFile { get; set; }
public bool AppendToFile { get; set; }
Public Property AppendToFile As Boolean
    Get
    Set
Public Property AppendToFile As Boolean
    Get
    Set
public:
property bool AppendToFile {
    bool get ();
    void set (bool value);
}
public:
property bool AppendToFile {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean

            Indicates whether the file should be appended to or overwritten.

Remarks

            If the value is set to false then the file will be overwritten, if
            it is set to true then the file will be appended to.

            The default value is true.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.Encoding Property

FileAppender Encoding Property Apache log4net™ SDK Documentation
Gets or sets Encoding used to write to the file.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Encoding Encoding { get; set; }
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set
Public Property Encoding As Encoding
    Get
    Set
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
Property Value
Type:   Online Encoding

            The Encoding used to write to the file.

Remarks

            The default encoding set is   Online Default
            which is the encoding for the system's current ANSI code page.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.File Property

FileAppender File Property Apache log4net™ SDK Documentation
Gets or sets the path to the file that logging will be written to.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string File { get; set; }
public virtual string File { get; set; }
Public Overridable Property File As String
    Get
    Set
Public Overridable Property File As String
    Get
    Set
public:
virtual property String^ File {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ File {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The path to the file that logging will be written to.

Remarks

            If the path is relative it is taken as relative from
            the application base directory.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModel Property

FileAppender LockingModel Property Apache log4net™ SDK Documentation
Gets or sets the LockingModel used to handle locking of the file.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileAppender..::..LockingModelBase LockingModel { get; set; }
public FileAppender..::..LockingModelBase LockingModel { get; set; }
Public Property LockingModel As FileAppender..::..LockingModelBase
    Get
    Set
Public Property LockingModel As FileAppender..::..LockingModelBase
    Get
    Set
public:
property FileAppender..::..LockingModelBase^ LockingModel {
    FileAppender..::..LockingModelBase^ get ();
    void set (FileAppender..::..LockingModelBase^ value);
}
public:
property FileAppender..::..LockingModelBase^ LockingModel {
    FileAppender..::..LockingModelBase^ get ();
    void set (FileAppender..::..LockingModelBase^ value);
}
Property Value
Type: FileAppender LockingModelBase

            The LockingModel used to lock the file.

Remarks

            Gets or sets the LockingModel used to handle locking of the file.

            There are three built in locking models, FileAppender ExclusiveLock, FileAppender MinimalLock and FileAppender InterProcessLock .
            The first locks the file from the start of logging to the end, the
            second locks only for the minimal amount of time when logging each message
            and the last synchronizes processes using a named system wide Mutex.

            The default locking model is the FileAppender ExclusiveLock.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.SecurityContext Property

FileAppender SecurityContext Property Apache log4net™ SDK Documentation
Gets or sets the SecurityContext used to write to the file.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityContext SecurityContext { get; set; }
public SecurityContext SecurityContext { get; set; }
Public Property SecurityContext As SecurityContext
    Get
    Set
Public Property SecurityContext As SecurityContext
    Get
    Set
public:
property SecurityContext^ SecurityContext {
    SecurityContext^ get ();
    void set (SecurityContext^ value);
}
public:
property SecurityContext^ SecurityContext {
    SecurityContext^ get ();
    void set (SecurityContext^ value);
}
Property Value
Type: SecurityContext

            The SecurityContext used to write to the file.

Remarks

            Unless a SecurityContext specified here for this appender
            the DefaultProvider is queried for the
            security context to use. The default behavior is to use the security context
            of the current thread.

See Also
FileAppender Class
FileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.ExclusiveLock Class

FileAppender ExclusiveLock Class Apache log4net™ SDK Documentation
Hold an exclusive lock on the output file
Inheritance Hierarchy
Online System Object
log4net.Appender FileAppender LockingModelBase
log4net.Appender FileAppender ExclusiveLock

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ExclusiveLock : FileAppender..::..LockingModelBase
public class ExclusiveLock : FileAppender..::..LockingModelBase
Public Class ExclusiveLock
    Inherits FileAppender..::..LockingModelBase
Public Class ExclusiveLock
    Inherits FileAppender..::..LockingModelBase
public ref class ExclusiveLock : public FileAppender..::..LockingModelBase
public ref class ExclusiveLock : public FileAppender..::..LockingModelBase
Remarks

            Open the file once for writing and hold it open until CloseFile  is called.
            Maintains an exclusive lock on the file during this time.

See Also
FileAppender ExclusiveLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.ExclusiveLock Members

FileAppender ExclusiveLock Members Apache log4net™ SDK Documentation
The FileAppender ExclusiveLock type exposes the following members.
Constructors
 | Name | Description
Public method | FileAppender ExclusiveLock | Initializes a new instance of the FileAppender ExclusiveLock class
Back to Top
Methods
 | Name | Description
Public method | AcquireLock | Acquire the lock on the file (Overrides FileAppender LockingModelBase AcquireLock .)
Public method | CloseFile | Close the file (Overrides FileAppender LockingModelBase CloseFile .)
Protected method | CloseStream | Helper method to close stream under CurrentAppender's SecurityContext. (Inherited from FileAppender LockingModelBase.)
Protected method | CreateStream | Helper method that creates a FileStream under CurrentAppender's SecurityContext. (Inherited from FileAppender LockingModelBase.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenFile | Open the file specified and prepare for logging. (Overrides FileAppender LockingModelBase OpenFile(String, Boolean, Encoding).)
Public method | ReleaseLock | Release the lock on the file (Overrides FileAppender LockingModelBase ReleaseLock .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | CurrentAppender | Gets or sets the FileAppender for this LockingModel (Inherited from FileAppender LockingModelBase.)
Back to Top
See Also
FileAppender ExclusiveLock Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.ExclusiveLock Constructor

FileAppender ExclusiveLock Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the FileAppender ExclusiveLock class

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExclusiveLock()
public ExclusiveLock()
Public Sub New
Public Sub New
public:
ExclusiveLock()
public:
ExclusiveLock()
See Also
FileAppender ExclusiveLock Class
FileAppender ExclusiveLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.ExclusiveLock Methods

FileAppender ExclusiveLock Methods Apache log4net™ SDK Documentation
The FileAppender ExclusiveLock type exposes the following members.
Methods
 | Name | Description
Public method | AcquireLock | Acquire the lock on the file (Overrides FileAppender LockingModelBase AcquireLock .)
Public method | CloseFile | Close the file (Overrides FileAppender LockingModelBase CloseFile .)
Protected method | CloseStream | Helper method to close stream under CurrentAppender's SecurityContext. (Inherited from FileAppender LockingModelBase.)
Protected method | CreateStream | Helper method that creates a FileStream under CurrentAppender's SecurityContext. (Inherited from FileAppender LockingModelBase.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenFile | Open the file specified and prepare for logging. (Overrides FileAppender LockingModelBase OpenFile(String, Boolean, Encoding).)
Public method | ReleaseLock | Release the lock on the file (Overrides FileAppender LockingModelBase ReleaseLock .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FileAppender ExclusiveLock Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.ExclusiveLock.AcquireLock Method

FileAppender ExclusiveLock AcquireLock Method Apache log4net™ SDK Documentation
Acquire the lock on the file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Stream AcquireLock()
public override Stream AcquireLock()
Public Overrides Function AcquireLock As Stream
Public Overrides Function AcquireLock As Stream
public:
virtual Stream^ AcquireLock() override
public:
virtual Stream^ AcquireLock() override
Return Value
Type:   Online Stream
A stream that is ready to be written to.
Remarks

            Does nothing. The lock is already taken

See Also
FileAppender ExclusiveLock Class
FileAppender ExclusiveLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.ExclusiveLock.CloseFile Method

FileAppender ExclusiveLock CloseFile Method Apache log4net™ SDK Documentation
Close the file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void CloseFile()
public override void CloseFile()
Public Overrides Sub CloseFile
Public Overrides Sub CloseFile
public:
virtual void CloseFile() override
public:
virtual void CloseFile() override
Remarks

            Close the file. No further writes will be made.

See Also
FileAppender ExclusiveLock Class
FileAppender ExclusiveLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.ExclusiveLock.OpenFile Method

FileAppender ExclusiveLock OpenFile Method Apache log4net™ SDK Documentation
Open the file specified and prepare for logging.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void OpenFile(
    string filename,
    bool append,
    Encoding encoding
)
public override void OpenFile(
    string filename,
    bool append,
    Encoding encoding
)
Public Overrides Sub OpenFile (
    filename As String,
    append As Boolean,
    encoding As Encoding
)
Public Overrides Sub OpenFile (
    filename As String,
    append As Boolean,
    encoding As Encoding
)
public:
virtual void OpenFile(
    String^ filename,
    bool append,
    Encoding^ encoding
) override
public:
virtual void OpenFile(
    String^ filename,
    bool append,
    Encoding^ encoding
) override
Parameters
filename
Type:   Online System String
The filename to use
append
Type:   Online System Boolean
Whether to append to the file, or overwrite
encoding
Type:   Online System.Text Encoding
The encoding to use
Remarks

            Open the file specified and prepare for logging.
            No writes will be made until AcquireLock  is called.
            Must be called before any calls to AcquireLock ,
            ReleaseLock  and CloseFile .

See Also
FileAppender ExclusiveLock Class
FileAppender ExclusiveLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.ExclusiveLock.ReleaseLock Method

FileAppender ExclusiveLock ReleaseLock Method Apache log4net™ SDK Documentation
Release the lock on the file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ReleaseLock()
public override void ReleaseLock()
Public Overrides Sub ReleaseLock
Public Overrides Sub ReleaseLock
public:
virtual void ReleaseLock() override
public:
virtual void ReleaseLock() override
Remarks

            Does nothing. The lock will be released when the file is closed.

See Also
FileAppender ExclusiveLock Class
FileAppender ExclusiveLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.ExclusiveLock Properties

FileAppender ExclusiveLock Properties Apache log4net™ SDK Documentation
The FileAppender ExclusiveLock type exposes the following members.
Properties
 | Name | Description
Public property | CurrentAppender | Gets or sets the FileAppender for this LockingModel (Inherited from FileAppender LockingModelBase.)
Back to Top
See Also
FileAppender ExclusiveLock Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.InterProcessLock Class

FileAppender InterProcessLock Class Apache log4net™ SDK Documentation
Provides cross-process file locking.
Inheritance Hierarchy
Online System Object
log4net.Appender FileAppender LockingModelBase
log4net.Appender FileAppender InterProcessLock

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class InterProcessLock : FileAppender..::..LockingModelBase
public class InterProcessLock : FileAppender..::..LockingModelBase
Public Class InterProcessLock
    Inherits FileAppender..::..LockingModelBase
Public Class InterProcessLock
    Inherits FileAppender..::..LockingModelBase
public ref class InterProcessLock : public FileAppender..::..LockingModelBase
public ref class InterProcessLock : public FileAppender..::..LockingModelBase
See Also
FileAppender InterProcessLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.InterProcessLock Members

FileAppender InterProcessLock Members Apache log4net™ SDK Documentation
The FileAppender InterProcessLock type exposes the following members.
Constructors
 | Name | Description
Public method | FileAppender InterProcessLock | Initializes a new instance of the FileAppender InterProcessLock class
Back to Top
Methods
 | Name | Description
Public method | AcquireLock | Acquire the lock on the file (Overrides FileAppender LockingModelBase AcquireLock .)
Public method | CloseFile | Close the file (Overrides FileAppender LockingModelBase CloseFile .)
Protected method | CloseStream | Helper method to close stream under CurrentAppender's SecurityContext. (Inherited from FileAppender LockingModelBase.)
Protected method | CreateStream | Helper method that creates a FileStream under CurrentAppender's SecurityContext. (Inherited from FileAppender LockingModelBase.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenFile | Open the file specified and prepare for logging. (Overrides FileAppender LockingModelBase OpenFile(String, Boolean, Encoding).)
Public method | ReleaseLock | Releases the lock and allows others to acquire a lock. (Overrides FileAppender LockingModelBase ReleaseLock .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | CurrentAppender | Gets or sets the FileAppender for this LockingModel (Inherited from FileAppender LockingModelBase.)
Back to Top
See Also
FileAppender InterProcessLock Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.InterProcessLock Constructor

FileAppender InterProcessLock Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the FileAppender InterProcessLock class

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InterProcessLock()
public InterProcessLock()
Public Sub New
Public Sub New
public:
InterProcessLock()
public:
InterProcessLock()
See Also
FileAppender InterProcessLock Class
FileAppender InterProcessLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.InterProcessLock Methods

FileAppender InterProcessLock Methods Apache log4net™ SDK Documentation
The FileAppender InterProcessLock type exposes the following members.
Methods
 | Name | Description
Public method | AcquireLock | Acquire the lock on the file (Overrides FileAppender LockingModelBase AcquireLock .)
Public method | CloseFile | Close the file (Overrides FileAppender LockingModelBase CloseFile .)
Protected method | CloseStream | Helper method to close stream under CurrentAppender's SecurityContext. (Inherited from FileAppender LockingModelBase.)
Protected method | CreateStream | Helper method that creates a FileStream under CurrentAppender's SecurityContext. (Inherited from FileAppender LockingModelBase.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenFile | Open the file specified and prepare for logging. (Overrides FileAppender LockingModelBase OpenFile(String, Boolean, Encoding).)
Public method | ReleaseLock | Releases the lock and allows others to acquire a lock. (Overrides FileAppender LockingModelBase ReleaseLock .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FileAppender InterProcessLock Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.InterProcessLock.AcquireLock Method

FileAppender InterProcessLock AcquireLock Method Apache log4net™ SDK Documentation
Acquire the lock on the file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Stream AcquireLock()
public override Stream AcquireLock()
Public Overrides Function AcquireLock As Stream
Public Overrides Function AcquireLock As Stream
public:
virtual Stream^ AcquireLock() override
public:
virtual Stream^ AcquireLock() override
Return Value
Type:   Online Stream
A stream that is ready to be written to.
Remarks

            Does nothing. The lock is already taken

See Also
FileAppender InterProcessLock Class
FileAppender InterProcessLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.InterProcessLock.CloseFile Method

FileAppender InterProcessLock CloseFile Method Apache log4net™ SDK Documentation
Close the file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void CloseFile()
public override void CloseFile()
Public Overrides Sub CloseFile
Public Overrides Sub CloseFile
public:
virtual void CloseFile() override
public:
virtual void CloseFile() override
Remarks

            Close the file. No further writes will be made.

See Also
FileAppender InterProcessLock Class
FileAppender InterProcessLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.InterProcessLock.OpenFile Method

FileAppender InterProcessLock OpenFile Method Apache log4net™ SDK Documentation
Open the file specified and prepare for logging.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void OpenFile(
    string filename,
    bool append,
    Encoding encoding
)
public override void OpenFile(
    string filename,
    bool append,
    Encoding encoding
)
Public Overrides Sub OpenFile (
    filename As String,
    append As Boolean,
    encoding As Encoding
)
Public Overrides Sub OpenFile (
    filename As String,
    append As Boolean,
    encoding As Encoding
)
public:
virtual void OpenFile(
    String^ filename,
    bool append,
    Encoding^ encoding
) override
public:
virtual void OpenFile(
    String^ filename,
    bool append,
    Encoding^ encoding
) override
Parameters
filename
Type:   Online System String
The filename to use
append
Type:   Online System Boolean
Whether to append to the file, or overwrite
encoding
Type:   Online System.Text Encoding
The encoding to use
Remarks

            Open the file specified and prepare for logging.
            No writes will be made until AcquireLock  is called.
            Must be called before any calls to AcquireLock ,
            -ReleaseLock  and CloseFile .

See Also
FileAppender InterProcessLock Class
FileAppender InterProcessLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.InterProcessLock.ReleaseLock Method

FileAppender InterProcessLock ReleaseLock Method Apache log4net™ SDK Documentation
Releases the lock and allows others to acquire a lock.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ReleaseLock()
public override void ReleaseLock()
Public Overrides Sub ReleaseLock
Public Overrides Sub ReleaseLock
public:
virtual void ReleaseLock() override
public:
virtual void ReleaseLock() override
See Also
FileAppender InterProcessLock Class
FileAppender InterProcessLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.InterProcessLock Properties

FileAppender InterProcessLock Properties Apache log4net™ SDK Documentation
The FileAppender InterProcessLock type exposes the following members.
Properties
 | Name | Description
Public property | CurrentAppender | Gets or sets the FileAppender for this LockingModel (Inherited from FileAppender LockingModelBase.)
Back to Top
See Also
FileAppender InterProcessLock Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModelBase Class

FileAppender LockingModelBase Class Apache log4net™ SDK Documentation
Locking model base class
Inheritance Hierarchy
Online System Object
log4net.Appender FileAppender LockingModelBase
log4net.Appender FileAppender ExclusiveLock
log4net.Appender FileAppender InterProcessLock
log4net.Appender FileAppender MinimalLock

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class LockingModelBase
public abstract class LockingModelBase
Public MustInherit Class LockingModelBase
Public MustInherit Class LockingModelBase
public ref class LockingModelBase abstract
public ref class LockingModelBase abstract
Remarks

            Base class for the locking models available to the FileAppender derived loggers.

See Also
FileAppender LockingModelBase Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModelBase Members

FileAppender LockingModelBase Members Apache log4net™ SDK Documentation
The FileAppender LockingModelBase type exposes the following members.
Constructors
 | Name | Description
Protected method | FileAppender LockingModelBase | Initializes a new instance of the FileAppender LockingModelBase class
Back to Top
Methods
 | Name | Description
Public method | AcquireLock | Acquire the lock on the file
Public method | CloseFile | Close the file
Protected method | CloseStream | Helper method to close stream under CurrentAppender's SecurityContext.
Protected method | CreateStream | Helper method that creates a FileStream under CurrentAppender's SecurityContext.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenFile | Open the output file
Public method | ReleaseLock | Release the lock on the file
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | CurrentAppender | Gets or sets the FileAppender for this LockingModel
Back to Top
See Also
FileAppender LockingModelBase Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModelBase Constructor

FileAppender LockingModelBase Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the FileAppender LockingModelBase class

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LockingModelBase()
protected LockingModelBase()
Protected Sub New
Protected Sub New
protected:
LockingModelBase()
protected:
LockingModelBase()
See Also
FileAppender LockingModelBase Class
FileAppender LockingModelBase Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModelBase Methods

FileAppender LockingModelBase Methods Apache log4net™ SDK Documentation
The FileAppender LockingModelBase type exposes the following members.
Methods
 | Name | Description
Public method | AcquireLock | Acquire the lock on the file
Public method | CloseFile | Close the file
Protected method | CloseStream | Helper method to close stream under CurrentAppender's SecurityContext.
Protected method | CreateStream | Helper method that creates a FileStream under CurrentAppender's SecurityContext.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenFile | Open the output file
Public method | ReleaseLock | Release the lock on the file
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FileAppender LockingModelBase Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModelBase.AcquireLock Method

FileAppender LockingModelBase AcquireLock Method Apache log4net™ SDK Documentation
Acquire the lock on the file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Stream AcquireLock()
public abstract Stream AcquireLock()
Public MustOverride Function AcquireLock As Stream
Public MustOverride Function AcquireLock As Stream
public:
virtual Stream^ AcquireLock() abstract
public:
virtual Stream^ AcquireLock() abstract
Return Value
Type:   Online Stream
A stream that is ready to be written to.
Remarks

            Acquire the lock on the file in preparation for writing to it.
            Return a stream pointing to the file. ReleaseLock
            must be called to release the lock on the output file.

See Also
FileAppender LockingModelBase Class
FileAppender LockingModelBase Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModelBase.CloseFile Method

FileAppender LockingModelBase CloseFile Method Apache log4net™ SDK Documentation
Close the file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void CloseFile()
public abstract void CloseFile()
Public MustOverride Sub CloseFile
Public MustOverride Sub CloseFile
public:
virtual void CloseFile() abstract
public:
virtual void CloseFile() abstract
Remarks

            Close the file. No further writes will be made.

See Also
FileAppender LockingModelBase Class
FileAppender LockingModelBase Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModelBase.CloseStream Method

FileAppender LockingModelBase CloseStream Method Apache log4net™ SDK Documentation
Helper method to close stream under CurrentAppender's SecurityContext.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void CloseStream(
    Stream stream
)
protected void CloseStream(
    Stream stream
)
Protected Sub CloseStream (
    stream As Stream
)
Protected Sub CloseStream (
    stream As Stream
)
protected:
void CloseStream(
    Stream^ stream
)
protected:
void CloseStream(
    Stream^ stream
)
Parameters
stream
Type:   Online System.IO Stream
[Missing <param name="stream"/> documentation for "M:log4net.Appender.FileAppender.LockingModelBase.CloseStream(System.IO.Stream)"]
Remarks

            Does not set stream to null.

See Also
FileAppender LockingModelBase Class
FileAppender LockingModelBase Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModelBase.CreateStream Method

FileAppender LockingModelBase CreateStream Method Apache log4net™ SDK Documentation
Helper method that creates a FileStream under CurrentAppender's SecurityContext.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Stream CreateStream(
    string filename,
    bool append,
    FileShare fileShare
)
protected Stream CreateStream(
    string filename,
    bool append,
    FileShare fileShare
)
Protected Function CreateStream (
    filename As String,
    append As Boolean,
    fileShare As FileShare
) As Stream
Protected Function CreateStream (
    filename As String,
    append As Boolean,
    fileShare As FileShare
) As Stream
protected:
Stream^ CreateStream(
    String^ filename,
    bool append,
    FileShare fileShare
)
protected:
Stream^ CreateStream(
    String^ filename,
    bool append,
    FileShare fileShare
)
Parameters
filename
Type:   Online System String
[Missing <param name="filename"/> documentation for "M:log4net.Appender.FileAppender.LockingModelBase.CreateStream(System.String,System.Boolean,System.IO.FileShare)"]
append
Type:   Online System Boolean
[Missing <param name="append"/> documentation for "M:log4net.Appender.FileAppender.LockingModelBase.CreateStream(System.String,System.Boolean,System.IO.FileShare)"]
fileShare
Type:   Online System.IO FileShare
[Missing <param name="fileShare"/> documentation for "M:log4net.Appender.FileAppender.LockingModelBase.CreateStream(System.String,System.Boolean,System.IO.FileShare)"]
Return Value
Type:   Online Stream
[Missing <returns> documentation for "M:log4net.Appender.FileAppender.LockingModelBase.CreateStream(System.String,System.Boolean,System.IO.FileShare)"]
Remarks

            Typically called during OpenFile or AcquireLock.

            If the directory portion of the filename does not exist, it is created
            via Directory.CreateDirecctory.

See Also
FileAppender LockingModelBase Class
FileAppender LockingModelBase Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModelBase.OpenFile Method

FileAppender LockingModelBase OpenFile Method Apache log4net™ SDK Documentation
Open the output file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void OpenFile(
    string filename,
    bool append,
    Encoding encoding
)
public abstract void OpenFile(
    string filename,
    bool append,
    Encoding encoding
)
Public MustOverride Sub OpenFile (
    filename As String,
    append As Boolean,
    encoding As Encoding
)
Public MustOverride Sub OpenFile (
    filename As String,
    append As Boolean,
    encoding As Encoding
)
public:
virtual void OpenFile(
    String^ filename,
    bool append,
    Encoding^ encoding
) abstract
public:
virtual void OpenFile(
    String^ filename,
    bool append,
    Encoding^ encoding
) abstract
Parameters
filename
Type:   Online System String
The filename to use
append
Type:   Online System Boolean
Whether to append to the file, or overwrite
encoding
Type:   Online System.Text Encoding
The encoding to use
Remarks

            Open the file specified and prepare for logging.
            No writes will be made until AcquireLock  is called.
            Must be called before any calls to AcquireLock ,
            ReleaseLock  and CloseFile .

See Also
FileAppender LockingModelBase Class
FileAppender LockingModelBase Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModelBase.ReleaseLock Method

FileAppender LockingModelBase ReleaseLock Method Apache log4net™ SDK Documentation
Release the lock on the file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void ReleaseLock()
public abstract void ReleaseLock()
Public MustOverride Sub ReleaseLock
Public MustOverride Sub ReleaseLock
public:
virtual void ReleaseLock() abstract
public:
virtual void ReleaseLock() abstract
Remarks

            Release the lock on the file. No further writes will be made to the
            stream until AcquireLock  is called again.

See Also
FileAppender LockingModelBase Class
FileAppender LockingModelBase Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModelBase Properties

FileAppender LockingModelBase Properties Apache log4net™ SDK Documentation
The FileAppender LockingModelBase type exposes the following members.
Properties
 | Name | Description
Public property | CurrentAppender | Gets or sets the FileAppender for this LockingModel
Back to Top
See Also
FileAppender LockingModelBase Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.LockingModelBase.CurrentAppender Property

FileAppender LockingModelBase CurrentAppender Property Apache log4net™ SDK Documentation
Gets or sets the FileAppender for this LockingModel

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileAppender CurrentAppender { get; set; }
public FileAppender CurrentAppender { get; set; }
Public Property CurrentAppender As FileAppender
    Get
    Set
Public Property CurrentAppender As FileAppender
    Get
    Set
public:
property FileAppender^ CurrentAppender {
    FileAppender^ get ();
    void set (FileAppender^ value);
}
public:
property FileAppender^ CurrentAppender {
    FileAppender^ get ();
    void set (FileAppender^ value);
}
Property Value
Type: FileAppender

            The FileAppender for this LockingModel

Remarks

            The file appender this locking model is attached to and working on
            behalf of.

            The file appender is used to locate the security context and the error handler to use.

            The value of this property will be set before OpenFile(String, Boolean, Encoding) is
            called.

See Also
FileAppender LockingModelBase Class
FileAppender LockingModelBase Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.MinimalLock Class

FileAppender MinimalLock Class Apache log4net™ SDK Documentation
Acquires the file lock for each write
Inheritance Hierarchy
Online System Object
log4net.Appender FileAppender LockingModelBase
log4net.Appender FileAppender MinimalLock

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MinimalLock : FileAppender..::..LockingModelBase
public class MinimalLock : FileAppender..::..LockingModelBase
Public Class MinimalLock
    Inherits FileAppender..::..LockingModelBase
Public Class MinimalLock
    Inherits FileAppender..::..LockingModelBase
public ref class MinimalLock : public FileAppender..::..LockingModelBase
public ref class MinimalLock : public FileAppender..::..LockingModelBase
Remarks

            Opens the file once for each AcquireLock /ReleaseLock  cycle,
            thus holding the lock for the minimal amount of time. This method of locking
            is considerably slower than FileAppender ExclusiveLock but allows
            other processes to move/delete the log file whilst logging continues.

See Also
FileAppender MinimalLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.MinimalLock Members

FileAppender MinimalLock Members Apache log4net™ SDK Documentation
The FileAppender MinimalLock type exposes the following members.
Constructors
 | Name | Description
Public method | FileAppender MinimalLock | Initializes a new instance of the FileAppender MinimalLock class
Back to Top
Methods
 | Name | Description
Public method | AcquireLock | Acquire the lock on the file (Overrides FileAppender LockingModelBase AcquireLock .)
Public method | CloseFile | Close the file (Overrides FileAppender LockingModelBase CloseFile .)
Protected method | CloseStream | Helper method to close stream under CurrentAppender's SecurityContext. (Inherited from FileAppender LockingModelBase.)
Protected method | CreateStream | Helper method that creates a FileStream under CurrentAppender's SecurityContext. (Inherited from FileAppender LockingModelBase.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenFile | Prepares to open the file when the first message is logged. (Overrides FileAppender LockingModelBase OpenFile(String, Boolean, Encoding).)
Public method | ReleaseLock | Release the lock on the file (Overrides FileAppender LockingModelBase ReleaseLock .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | CurrentAppender | Gets or sets the FileAppender for this LockingModel (Inherited from FileAppender LockingModelBase.)
Back to Top
See Also
FileAppender MinimalLock Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.MinimalLock Constructor

FileAppender MinimalLock Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the FileAppender MinimalLock class

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MinimalLock()
public MinimalLock()
Public Sub New
Public Sub New
public:
MinimalLock()
public:
MinimalLock()
See Also
FileAppender MinimalLock Class
FileAppender MinimalLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.MinimalLock Methods

FileAppender MinimalLock Methods Apache log4net™ SDK Documentation
The FileAppender MinimalLock type exposes the following members.
Methods
 | Name | Description
Public method | AcquireLock | Acquire the lock on the file (Overrides FileAppender LockingModelBase AcquireLock .)
Public method | CloseFile | Close the file (Overrides FileAppender LockingModelBase CloseFile .)
Protected method | CloseStream | Helper method to close stream under CurrentAppender's SecurityContext. (Inherited from FileAppender LockingModelBase.)
Protected method | CreateStream | Helper method that creates a FileStream under CurrentAppender's SecurityContext. (Inherited from FileAppender LockingModelBase.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenFile | Prepares to open the file when the first message is logged. (Overrides FileAppender LockingModelBase OpenFile(String, Boolean, Encoding).)
Public method | ReleaseLock | Release the lock on the file (Overrides FileAppender LockingModelBase ReleaseLock .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FileAppender MinimalLock Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.MinimalLock.AcquireLock Method

FileAppender MinimalLock AcquireLock Method Apache log4net™ SDK Documentation
Acquire the lock on the file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Stream AcquireLock()
public override Stream AcquireLock()
Public Overrides Function AcquireLock As Stream
Public Overrides Function AcquireLock As Stream
public:
virtual Stream^ AcquireLock() override
public:
virtual Stream^ AcquireLock() override
Return Value
Type:   Online Stream
A stream that is ready to be written to.
Remarks

            Acquire the lock on the file in preparation for writing to it.
            Return a stream pointing to the file. ReleaseLock
            must be called to release the lock on the output file.

See Also
FileAppender MinimalLock Class
FileAppender MinimalLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.MinimalLock.CloseFile Method

FileAppender MinimalLock CloseFile Method Apache log4net™ SDK Documentation
Close the file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void CloseFile()
public override void CloseFile()
Public Overrides Sub CloseFile
Public Overrides Sub CloseFile
public:
virtual void CloseFile() override
public:
virtual void CloseFile() override
Remarks

            Close the file. No further writes will be made.

See Also
FileAppender MinimalLock Class
FileAppender MinimalLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.MinimalLock.OpenFile Method

FileAppender MinimalLock OpenFile Method Apache log4net™ SDK Documentation
Prepares to open the file when the first message is logged.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void OpenFile(
    string filename,
    bool append,
    Encoding encoding
)
public override void OpenFile(
    string filename,
    bool append,
    Encoding encoding
)
Public Overrides Sub OpenFile (
    filename As String,
    append As Boolean,
    encoding As Encoding
)
Public Overrides Sub OpenFile (
    filename As String,
    append As Boolean,
    encoding As Encoding
)
public:
virtual void OpenFile(
    String^ filename,
    bool append,
    Encoding^ encoding
) override
public:
virtual void OpenFile(
    String^ filename,
    bool append,
    Encoding^ encoding
) override
Parameters
filename
Type:   Online System String
The filename to use
append
Type:   Online System Boolean
Whether to append to the file, or overwrite
encoding
Type:   Online System.Text Encoding
The encoding to use
Remarks

            Open the file specified and prepare for logging.
            No writes will be made until AcquireLock  is called.
            Must be called before any calls to AcquireLock ,
            ReleaseLock  and CloseFile .

See Also
FileAppender MinimalLock Class
FileAppender MinimalLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.MinimalLock.ReleaseLock Method

FileAppender MinimalLock ReleaseLock Method Apache log4net™ SDK Documentation
Release the lock on the file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ReleaseLock()
public override void ReleaseLock()
Public Overrides Sub ReleaseLock
Public Overrides Sub ReleaseLock
public:
virtual void ReleaseLock() override
public:
virtual void ReleaseLock() override
Remarks

            Release the lock on the file. No further writes will be made to the
            stream until AcquireLock  is called again.

See Also
FileAppender MinimalLock Class
FileAppender MinimalLock Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FileAppender.MinimalLock Properties

FileAppender MinimalLock Properties Apache log4net™ SDK Documentation
The FileAppender MinimalLock type exposes the following members.
Properties
 | Name | Description
Public property | CurrentAppender | Gets or sets the FileAppender for this LockingModel (Inherited from FileAppender LockingModelBase.)
Back to Top
See Also
FileAppender MinimalLock Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender Class

ForwardingAppender Class Apache log4net™ SDK Documentation
This appender forwards logging events to attached appenders.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender ForwardingAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ForwardingAppender : AppenderSkeleton,
    IAppenderAttachable
public class ForwardingAppender : AppenderSkeleton,
    IAppenderAttachable
Public Class ForwardingAppender
    Inherits AppenderSkeleton
    Implements IAppenderAttachable
Public Class ForwardingAppender
    Inherits AppenderSkeleton
    Implements IAppenderAttachable
public ref class ForwardingAppender : public AppenderSkeleton,
    IAppenderAttachable
public ref class ForwardingAppender : public AppenderSkeleton,
    IAppenderAttachable
Remarks

            The forwarding appender can be used to specify different thresholds
            and filters for the same appender at different locations within the hierarchy.

See Also
ForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender Members

ForwardingAppender Members Apache log4net™ SDK Documentation
The ForwardingAppender type exposes the following members.
Constructors
 | Name | Description
Public method | ForwardingAppender | Initializes a new instance of the ForwardingAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddAppender | Adds an IAppender to the list of appenders of this instance.
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Forward the logging event to the attached appenders (Overrides AppenderSkeleton Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | Forward the logging events to the attached appenders (Overrides AppenderSkeleton Append( LoggingEvent ).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | GetAppender | Looks for the appender with the specified name.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Closes the appender and releases resources. (Overrides AppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Public method | RemoveAllAppenders | Removes all previously added appenders from this appender.
Public method | RemoveAppender(String) | Removes the appender with the specified name from the list of appenders.
Public method | RemoveAppender(IAppender) | Removes the specified appender from the list of appenders.
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Appenders | Gets the appenders contained in this appender as an Online ICollection.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set. (Inherited from AppenderSkeleton.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
ForwardingAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender Constructor

ForwardingAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the ForwardingAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ForwardingAppender()
public ForwardingAppender()
Public Sub New
Public Sub New
public:
ForwardingAppender()
public:
ForwardingAppender()
Remarks

            Default constructor.

See Also
ForwardingAppender Class
ForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender Methods

ForwardingAppender Methods Apache log4net™ SDK Documentation
The ForwardingAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddAppender | Adds an IAppender to the list of appenders of this instance.
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Forward the logging event to the attached appenders (Overrides AppenderSkeleton Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | Forward the logging events to the attached appenders (Overrides AppenderSkeleton Append( LoggingEvent ).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | GetAppender | Looks for the appender with the specified name.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Closes the appender and releases resources. (Overrides AppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Public method | RemoveAllAppenders | Removes all previously added appenders from this appender.
Public method | RemoveAppender(String) | Removes the appender with the specified name from the list of appenders.
Public method | RemoveAppender(IAppender) | Removes the specified appender from the list of appenders.
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ForwardingAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender.AddAppender Method

ForwardingAppender AddAppender Method Apache log4net™ SDK Documentation
Adds an IAppender to the list of appenders of this instance.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddAppender(
    IAppender newAppender
)
public virtual void AddAppender(
    IAppender newAppender
)
Public Overridable Sub AddAppender (
    newAppender As IAppender
)
Public Overridable Sub AddAppender (
    newAppender As IAppender
)
public:
virtual void AddAppender(
    IAppender^ newAppender
)
public:
virtual void AddAppender(
    IAppender^ newAppender
)
Parameters
newAppender
Type: log4net.Appender IAppender
The IAppender to add to this appender.
Implements
IAppenderAttachable AddAppender(IAppender)
Remarks

            If the specified IAppender is already in the list of
            appenders, then it won't be added again.

See Also
ForwardingAppender Class
ForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender.Append Method

ForwardingAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append(LoggingEvent) | Forward the logging event to the attached appenders (Overrides AppenderSkeleton Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | Forward the logging events to the attached appenders (Overrides AppenderSkeleton Append( LoggingEvent ).)
Back to Top
See Also
ForwardingAppender Class
ForwardingAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender.Append Method (LoggingEvent)

ForwardingAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
Forward the logging event to the attached appenders

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Delivers the logging event to all the attached appenders.

See Also
ForwardingAppender Class
ForwardingAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender.Append Method (LoggingEvent[])

ForwardingAppender Append Method ( LoggingEvent ) Apache log4net™ SDK Documentation
Forward the logging events to the attached appenders

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent[] loggingEvents
)
protected override void Append(
    LoggingEvent[] loggingEvents
)
Protected Overrides Sub Append (
    loggingEvents As LoggingEvent()
)
Protected Overrides Sub Append (
    loggingEvents As LoggingEvent()
)
protected:
virtual void Append(
    array<LoggingEvent^>^ loggingEvents
) override
protected:
virtual void Append(
    array<LoggingEvent^>^ loggingEvents
) override
Parameters
loggingEvents
Type:  log4net.Core LoggingEvent
The array of events to log.
Remarks

            Delivers the logging events to all the attached appenders.

See Also
ForwardingAppender Class
ForwardingAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender.GetAppender Method

ForwardingAppender GetAppender Method Apache log4net™ SDK Documentation
Looks for the appender with the specified name.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IAppender GetAppender(
    string name
)
public virtual IAppender GetAppender(
    string name
)
Public Overridable Function GetAppender (
    name As String
) As IAppender
Public Overridable Function GetAppender (
    name As String
) As IAppender
public:
virtual IAppender^ GetAppender(
    String^ name
)
public:
virtual IAppender^ GetAppender(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the appender to lookup.
Return Value
Type: IAppender

            The appender with the specified name, or null.

Implements
IAppenderAttachable GetAppender(String)
Remarks

            Get the named appender attached to this appender.

See Also
ForwardingAppender Class
ForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender.OnClose Method

ForwardingAppender OnClose Method Apache log4net™ SDK Documentation
Closes the appender and releases resources.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void OnClose()
protected override void OnClose()
Protected Overrides Sub OnClose
Protected Overrides Sub OnClose
protected:
virtual void OnClose() override
protected:
virtual void OnClose() override
Remarks

            Releases any resources allocated within the appender such as file handles,
            network connections, etc.

            It is a programming error to append to a closed appender.

See Also
ForwardingAppender Class
ForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender.RemoveAllAppenders Method

ForwardingAppender RemoveAllAppenders Method Apache log4net™ SDK Documentation
Removes all previously added appenders from this appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void RemoveAllAppenders()
public virtual void RemoveAllAppenders()
Public Overridable Sub RemoveAllAppenders
Public Overridable Sub RemoveAllAppenders
public:
virtual void RemoveAllAppenders()
public:
virtual void RemoveAllAppenders()
Implements
IAppenderAttachable RemoveAllAppenders
Remarks

            This is useful when re-reading configuration information.

See Also
ForwardingAppender Class
ForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender.RemoveAppender Method

ForwardingAppender RemoveAppender Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | RemoveAppender(String) | Removes the appender with the specified name from the list of appenders.
Public method | RemoveAppender(IAppender) | Removes the specified appender from the list of appenders.
Back to Top
See Also
ForwardingAppender Class
ForwardingAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender.RemoveAppender Method (String)

ForwardingAppender RemoveAppender Method (String) Apache log4net™ SDK Documentation
Removes the appender with the specified name from the list of appenders.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IAppender RemoveAppender(
    string name
)
public virtual IAppender RemoveAppender(
    string name
)
Public Overridable Function RemoveAppender (
    name As String
) As IAppender
Public Overridable Function RemoveAppender (
    name As String
) As IAppender
public:
virtual IAppender^ RemoveAppender(
    String^ name
)
public:
virtual IAppender^ RemoveAppender(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the appender to remove.
Return Value
Type: IAppender
The appender removed from the list
Implements
IAppenderAttachable RemoveAppender(String)
Remarks

            The appender removed is not closed.
            If you are discarding the appender you must call
            Close  on the appender removed.

See Also
ForwardingAppender Class
ForwardingAppender Members
RemoveAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender.RemoveAppender Method (IAppender)

ForwardingAppender RemoveAppender Method (IAppender) Apache log4net™ SDK Documentation
Removes the specified appender from the list of appenders.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IAppender RemoveAppender(
    IAppender appender
)
public virtual IAppender RemoveAppender(
    IAppender appender
)
Public Overridable Function RemoveAppender (
    appender As IAppender
) As IAppender
Public Overridable Function RemoveAppender (
    appender As IAppender
) As IAppender
public:
virtual IAppender^ RemoveAppender(
    IAppender^ appender
)
public:
virtual IAppender^ RemoveAppender(
    IAppender^ appender
)
Parameters
appender
Type: log4net.Appender IAppender
The appender to remove.
Return Value
Type: IAppender
The appender removed from the list
Implements
IAppenderAttachable RemoveAppender(IAppender)
Remarks

            The appender removed is not closed.
            If you are discarding the appender you must call
            Close  on the appender removed.

See Also
ForwardingAppender Class
ForwardingAppender Members
RemoveAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender Properties

ForwardingAppender Properties Apache log4net™ SDK Documentation
The ForwardingAppender type exposes the following members.
Properties
 | Name | Description
Public property | Appenders | Gets the appenders contained in this appender as an Online ICollection.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set. (Inherited from AppenderSkeleton.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
ForwardingAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ForwardingAppender.Appenders Property

ForwardingAppender Appenders Property Apache log4net™ SDK Documentation
Gets the appenders contained in this appender as an Online ICollection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual AppenderCollection Appenders { get; }
public virtual AppenderCollection Appenders { get; }
Public Overridable ReadOnly Property Appenders As AppenderCollection
    Get
Public Overridable ReadOnly Property Appenders As AppenderCollection
    Get
public:
virtual property AppenderCollection^ Appenders {
    AppenderCollection^ get ();
}
public:
virtual property AppenderCollection^ Appenders {
    AppenderCollection^ get ();
}
Return Value
Type: AppenderCollection

            A collection of the appenders in this appender.

Implements
IAppenderAttachable Appenders
Remarks

            If no appenders can be found, then an EmptyCollection
            is returned.

See Also
ForwardingAppender Class
ForwardingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppender Interface

IAppender Interface Apache log4net™ SDK Documentation
Implement this interface for your own strategies for printing log statements.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAppender
public interface IAppender
Public Interface IAppender
Public Interface IAppender
public interface class IAppender
public interface class IAppender
Remarks

            Implementors should consider extending the AppenderSkeleton
            class which provides a default implementation of this interface.

            Appenders can also implement the IOptionHandler interface. Therefore
            they would require that the [M:IOptionHandler.ActivateOptions()] method
            be called after the appenders properties have been configured.

See Also
IAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppender Members

IAppender Members Apache log4net™ SDK Documentation
The IAppender type exposes the following members.
Methods
 | Name | Description
Public method | Close | Closes the appender and releases resources.
Public method | DoAppend | Log the logging event in Appender specific way.
Back to Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of this appender.
Back to Top
See Also
IAppender Interface
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppender Methods

IAppender Methods Apache log4net™ SDK Documentation
The IAppender type exposes the following members.
Methods
 | Name | Description
Public method | Close | Closes the appender and releases resources.
Public method | DoAppend | Log the logging event in Appender specific way.
Back to Top
See Also
IAppender Interface
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppender.Close Method

IAppender Close Method Apache log4net™ SDK Documentation
Closes the appender and releases resources.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Close()
void Close()
Sub Close
Sub Close
void Close()
void Close()
Remarks

            Releases any resources allocated within the appender such as file handles,
            network connections, etc.

            It is a programming error to append to a closed appender.

See Also
IAppender Interface
IAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppender.DoAppend Method

IAppender DoAppend Method Apache log4net™ SDK Documentation
Log the logging event in Appender specific way.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void DoAppend(
    LoggingEvent loggingEvent
)
void DoAppend(
    LoggingEvent loggingEvent
)
Sub DoAppend (
    loggingEvent As LoggingEvent
)
Sub DoAppend (
    loggingEvent As LoggingEvent
)
void DoAppend(
    LoggingEvent^ loggingEvent
)
void DoAppend(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log
Remarks

            This method is called to log a message into this appender.

See Also
IAppender Interface
IAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppender Properties

IAppender Properties Apache log4net™ SDK Documentation
The IAppender type exposes the following members.
Properties
 | Name | Description
Public property | Name | Gets or sets the name of this appender.
Back to Top
See Also
IAppender Interface
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppender.Name Property

IAppender Name Property Apache log4net™ SDK Documentation
Gets or sets the name of this appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Name { get; set; }
string Name { get; set; }
Property Name As String
    Get
    Set
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
The name of the appender.
Remarks
The name uniquely identifies the appender.
See Also
IAppender Interface
IAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IBulkAppender Interface

IBulkAppender Interface Apache log4net™ SDK Documentation
Interface for appenders that support bulk logging.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IBulkAppender : IAppender
public interface IBulkAppender : IAppender
Public Interface IBulkAppender
    Inherits IAppender
Public Interface IBulkAppender
    Inherits IAppender
public interface class IBulkAppender : IAppender
public interface class IBulkAppender : IAppender
Remarks

            This interface extends the IAppender interface to
            support bulk logging of LoggingEvent objects. Appenders
            should only implement this interface if they can bulk log efficiently.

See Also
IBulkAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IBulkAppender Members

IBulkAppender Members Apache log4net™ SDK Documentation
The IBulkAppender type exposes the following members.
Methods
 | Name | Description
Public method | Close | Closes the appender and releases resources. (Inherited from IAppender.)
Public method | DoAppend(LoggingEvent) | Log the logging event in Appender specific way. (Inherited from IAppender.)
Public method | DoAppend( LoggingEvent ) | Log the array of logging events in Appender specific way.
Back to Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of this appender. (Inherited from IAppender.)
Back to Top
See Also
IBulkAppender Interface
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IBulkAppender Methods

IBulkAppender Methods Apache log4net™ SDK Documentation
The IBulkAppender type exposes the following members.
Methods
 | Name | Description
Public method | Close | Closes the appender and releases resources. (Inherited from IAppender.)
Public method | DoAppend(LoggingEvent) | Log the logging event in Appender specific way. (Inherited from IAppender.)
Public method | DoAppend( LoggingEvent ) | Log the array of logging events in Appender specific way.
Back to Top
See Also
IBulkAppender Interface
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IBulkAppender.DoAppend Method

IBulkAppender DoAppend Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | DoAppend(LoggingEvent) | Log the logging event in Appender specific way. (Inherited from IAppender.)
Public method | DoAppend( LoggingEvent ) | Log the array of logging events in Appender specific way.
Back to Top
See Also
IBulkAppender Interface
IBulkAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IBulkAppender.DoAppend Method (LoggingEvent[])

IBulkAppender DoAppend Method ( LoggingEvent ) Apache log4net™ SDK Documentation
Log the array of logging events in Appender specific way.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void DoAppend(
    LoggingEvent[] loggingEvents
)
void DoAppend(
    LoggingEvent[] loggingEvents
)
Sub DoAppend (
    loggingEvents As LoggingEvent()
)
Sub DoAppend (
    loggingEvents As LoggingEvent()
)
void DoAppend(
    array<LoggingEvent^>^ loggingEvents
)
void DoAppend(
    array<LoggingEvent^>^ loggingEvents
)
Parameters
loggingEvents
Type:  log4net.Core LoggingEvent
The events to log
Remarks

            This method is called to log an array of events into this appender.

See Also
IBulkAppender Interface
IBulkAppender Members
DoAppend Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IBulkAppender Properties

IBulkAppender Properties Apache log4net™ SDK Documentation
The IBulkAppender type exposes the following members.
Properties
 | Name | Description
Public property | Name | Gets or sets the name of this appender. (Inherited from IAppender.)
Back to Top
See Also
IBulkAppender Interface
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender Class

LocalSyslogAppender Class Apache log4net™ SDK Documentation
Logs events to a local syslog service.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender LocalSyslogAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LocalSyslogAppender : AppenderSkeleton
public class LocalSyslogAppender : AppenderSkeleton
Public Class LocalSyslogAppender
    Inherits AppenderSkeleton
Public Class LocalSyslogAppender
    Inherits AppenderSkeleton
public ref class LocalSyslogAppender : public AppenderSkeleton
public ref class LocalSyslogAppender : public AppenderSkeleton
Remarks
  Note  Note

            This appender uses the POSIX libc library functions openlog, syslog, and closelog.
            If these functions are not available on the local system then this appender will not work!

            The functions openlog, syslog, and closelog are specified in SUSv2 and
            POSIX 1003.1-2001 standards. These are used to log messages to the local syslog service.

            This appender talks to a local syslog service. If you need to log to a remote syslog
            daemon and you cannot configure your local syslog service to do this you may be
            able to use the RemoteSyslogAppender to log via UDP.

            Syslog messages must have a facility and and a severity. The severity
            is derived from the Level of the logging event.
            The facility must be chosen from the set of defined syslog
            LocalSyslogAppender SyslogFacility values. The facilities list is predefined
            and cannot be extended.

            An identifier is specified with each log message. This can be specified
            by setting the Identity property. The identity (also know
            as the tag) must not contain white space. The default value for the
            identity is the application name (from ApplicationFriendlyName).

See Also
LocalSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender Members

LocalSyslogAppender Members Apache log4net™ SDK Documentation
The LocalSyslogAppender type exposes the following members.
Constructors
 | Name | Description
Public method | LocalSyslogAppender | Initializes a new instance of the LocalSyslogAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set. (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddMapping | Add a mapping of level to severity
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetSeverity | Translates a log4net level to a syslog severity.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Close the syslog when the appender is closed (Overrides AppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Facility | Syslog facility
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Identity | Message identity
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
LocalSyslogAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender Constructor

LocalSyslogAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the LocalSyslogAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalSyslogAppender()
public LocalSyslogAppender()
Public Sub New
Public Sub New
public:
LocalSyslogAppender()
public:
LocalSyslogAppender()
Remarks

            This instance of the LocalSyslogAppender class is set up to write
            to a local syslog service.

See Also
LocalSyslogAppender Class
LocalSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender Methods

LocalSyslogAppender Methods Apache log4net™ SDK Documentation
The LocalSyslogAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set. (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddMapping | Add a mapping of level to severity
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetSeverity | Translates a log4net level to a syslog severity.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Close the syslog when the appender is closed (Overrides AppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LocalSyslogAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.ActivateOptions Method

LocalSyslogAppender ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the appender based on the options set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
LocalSyslogAppender Class
LocalSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.AddMapping Method

LocalSyslogAppender AddMapping Method Apache log4net™ SDK Documentation
Add a mapping of level to severity

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddMapping(
    LocalSyslogAppender..::..LevelSeverity mapping
)
public void AddMapping(
    LocalSyslogAppender..::..LevelSeverity mapping
)
Public Sub AddMapping (
    mapping As LocalSyslogAppender..::..LevelSeverity
)
Public Sub AddMapping (
    mapping As LocalSyslogAppender..::..LevelSeverity
)
public:
void AddMapping(
    LocalSyslogAppender..::..LevelSeverity^ mapping
)
public:
void AddMapping(
    LocalSyslogAppender..::..LevelSeverity^ mapping
)
Parameters
mapping
Type: log4net.Appender LocalSyslogAppender LevelSeverity
The mapping to add
Remarks

            Adds a LocalSyslogAppender LevelSeverity to this appender.

See Also
LocalSyslogAppender Class
LocalSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.Append Method

LocalSyslogAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
LocalSyslogAppender Class
LocalSyslogAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.Append Method (LoggingEvent)

LocalSyslogAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Writes the event to a remote syslog daemon.

            The format of the output will depend on the appender's layout.

See Also
LocalSyslogAppender Class
LocalSyslogAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.GetSeverity Method

LocalSyslogAppender GetSeverity Method Apache log4net™ SDK Documentation
Translates a log4net level to a syslog severity.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual LocalSyslogAppender..::..SyslogSeverity GetSeverity(
    Level level
)
protected virtual LocalSyslogAppender..::..SyslogSeverity GetSeverity(
    Level level
)
Protected Overridable Function GetSeverity (
    level As Level
) As LocalSyslogAppender..::..SyslogSeverity
Protected Overridable Function GetSeverity (
    level As Level
) As LocalSyslogAppender..::..SyslogSeverity
protected:
virtual LocalSyslogAppender..::..SyslogSeverity GetSeverity(
    Level^ level
)
protected:
virtual LocalSyslogAppender..::..SyslogSeverity GetSeverity(
    Level^ level
)
Parameters
level
Type: log4net.Core Level
A log4net level.
Return Value
Type: LocalSyslogAppender SyslogSeverity
A syslog severity.
Remarks

            Translates a log4net level to a syslog severity.

See Also
LocalSyslogAppender Class
LocalSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.OnClose Method

LocalSyslogAppender OnClose Method Apache log4net™ SDK Documentation
Close the syslog when the appender is closed

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void OnClose()
protected override void OnClose()
Protected Overrides Sub OnClose
Protected Overrides Sub OnClose
protected:
virtual void OnClose() override
protected:
virtual void OnClose() override
Remarks

            Close the syslog when the appender is closed

See Also
LocalSyslogAppender Class
LocalSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender Properties

LocalSyslogAppender Properties Apache log4net™ SDK Documentation
The LocalSyslogAppender type exposes the following members.
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Facility | Syslog facility
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Identity | Message identity
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
LocalSyslogAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.Facility Property

LocalSyslogAppender Facility Property Apache log4net™ SDK Documentation
Syslog facility

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalSyslogAppender..::..SyslogFacility Facility { get; set; }
public LocalSyslogAppender..::..SyslogFacility Facility { get; set; }
Public Property Facility As LocalSyslogAppender..::..SyslogFacility
    Get
    Set
Public Property Facility As LocalSyslogAppender..::..SyslogFacility
    Get
    Set
public:
property LocalSyslogAppender..::..SyslogFacility Facility {
    LocalSyslogAppender..::..SyslogFacility get ();
    void set (LocalSyslogAppender..::..SyslogFacility value);
}
public:
property LocalSyslogAppender..::..SyslogFacility Facility {
    LocalSyslogAppender..::..SyslogFacility get ();
    void set (LocalSyslogAppender..::..SyslogFacility value);
}
Property Value
Type: LocalSyslogAppender SyslogFacility
Remarks

            Set to one of the LocalSyslogAppender SyslogFacility values. The list of
            facilities is predefined and cannot be extended. The default value
            is User.

See Also
LocalSyslogAppender Class
LocalSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.Identity Property

LocalSyslogAppender Identity Property Apache log4net™ SDK Documentation
Message identity

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Identity { get; set; }
public string Identity { get; set; }
Public Property Identity As String
    Get
    Set
Public Property Identity As String
    Get
    Set
public:
property String^ Identity {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Identity {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            An identifier is specified with each log message. This can be specified
            by setting the Identity property. The identity (also know
            as the tag) must not contain white space. The default value for the
            identity is the application name (from ApplicationFriendlyName).

See Also
LocalSyslogAppender Class
LocalSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.RequiresLayout Property

LocalSyslogAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a Layout to be set.

See Also
LocalSyslogAppender Class
LocalSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.LevelSeverity Class

LocalSyslogAppender LevelSeverity Class Apache log4net™ SDK Documentation
A class to act as a mapping between the level that a logging call is made at and the syslog severity that is should be logged at.
Inheritance Hierarchy
Online System Object
log4net.Util LevelMappingEntry
log4net.Appender LocalSyslogAppender LevelSeverity

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LevelSeverity : LevelMappingEntry
public class LevelSeverity : LevelMappingEntry
Public Class LevelSeverity
    Inherits LevelMappingEntry
Public Class LevelSeverity
    Inherits LevelMappingEntry
public ref class LevelSeverity : public LevelMappingEntry
public ref class LevelSeverity : public LevelMappingEntry
Remarks

            A class to act as a mapping between the level that a logging call is made at and
            the syslog severity that is should be logged at.

See Also
LocalSyslogAppender LevelSeverity Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.LevelSeverity Members

LocalSyslogAppender LevelSeverity Members Apache log4net™ SDK Documentation
The LocalSyslogAppender LevelSeverity type exposes the following members.
Constructors
 | Name | Description
Public method | LocalSyslogAppender LevelSeverity | Initializes a new instance of the LocalSyslogAppender LevelSeverity class
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize any options defined on this entry (Inherited from LevelMappingEntry.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Level | The level that is the key for this mapping (Inherited from LevelMappingEntry.)
Public property | Severity | The mapped syslog severity for the specified level
Back to Top
See Also
LocalSyslogAppender LevelSeverity Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.LevelSeverity Constructor

LocalSyslogAppender LevelSeverity Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the LocalSyslogAppender LevelSeverity class

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelSeverity()
public LevelSeverity()
Public Sub New
Public Sub New
public:
LevelSeverity()
public:
LevelSeverity()
See Also
LocalSyslogAppender LevelSeverity Class
LocalSyslogAppender LevelSeverity Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.LevelSeverity Methods

LocalSyslogAppender LevelSeverity Methods Apache log4net™ SDK Documentation
The LocalSyslogAppender LevelSeverity type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize any options defined on this entry (Inherited from LevelMappingEntry.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LocalSyslogAppender LevelSeverity Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.LevelSeverity Properties

LocalSyslogAppender LevelSeverity Properties Apache log4net™ SDK Documentation
The LocalSyslogAppender LevelSeverity type exposes the following members.
Properties
 | Name | Description
Public property | Level | The level that is the key for this mapping (Inherited from LevelMappingEntry.)
Public property | Severity | The mapped syslog severity for the specified level
Back to Top
See Also
LocalSyslogAppender LevelSeverity Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.LevelSeverity.Severity Property

LocalSyslogAppender LevelSeverity Severity Property Apache log4net™ SDK Documentation
The mapped syslog severity for the specified level

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalSyslogAppender..::..SyslogSeverity Severity { get; set; }
public LocalSyslogAppender..::..SyslogSeverity Severity { get; set; }
Public Property Severity As LocalSyslogAppender..::..SyslogSeverity
    Get
    Set
Public Property Severity As LocalSyslogAppender..::..SyslogSeverity
    Get
    Set
public:
property LocalSyslogAppender..::..SyslogSeverity Severity {
    LocalSyslogAppender..::..SyslogSeverity get ();
    void set (LocalSyslogAppender..::..SyslogSeverity value);
}
public:
property LocalSyslogAppender..::..SyslogSeverity Severity {
    LocalSyslogAppender..::..SyslogSeverity get ();
    void set (LocalSyslogAppender..::..SyslogSeverity value);
}
Property Value
Type: LocalSyslogAppender SyslogSeverity
Remarks

            Required property.
            The mapped syslog severity for the specified level

See Also
LocalSyslogAppender LevelSeverity Class
LocalSyslogAppender LevelSeverity Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.SyslogFacility Enumeration

LocalSyslogAppender SyslogFacility Enumeration Apache log4net™ SDK Documentation
syslog facilities

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum SyslogFacility
public enum SyslogFacility
Public Enumeration SyslogFacility
Public Enumeration SyslogFacility
public enum class SyslogFacility
public enum class SyslogFacility
Members
Member name | Value | Description
Kernel | 0 | kernel messages
User | 1 | random user-level messages
Mail | 2 | mail system
Daemons | 3 | system daemons
Authorization | 4 | security/authorization messages
Syslog | 5 | messages generated internally by syslogd
Printer | 6 | line printer subsystem
News | 7 | network news subsystem
Uucp | 8 | UUCP subsystem
Clock | 9 | clock (cron/at) daemon
Authorization2 | 10 | security/authorization messages (private)
Ftp | 11 | ftp daemon
Ntp | 12 | NTP subsystem
Audit | 13 | log audit
Alert | 14 | log alert
Clock2 | 15 | clock daemon
Local0 | 16 | reserved for local use
Local1 | 17 | reserved for local use
Local2 | 18 | reserved for local use
Local3 | 19 | reserved for local use
Local4 | 20 | reserved for local use
Local5 | 21 | reserved for local use
Local6 | 22 | reserved for local use
Local7 | 23 | reserved for local use
Remarks

            The syslog facility defines which subsystem the logging comes from.
            This is set on the Facility property.

See Also
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocalSyslogAppender.SyslogSeverity Enumeration

LocalSyslogAppender SyslogSeverity Enumeration Apache log4net™ SDK Documentation
syslog severities

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum SyslogSeverity
public enum SyslogSeverity
Public Enumeration SyslogSeverity
Public Enumeration SyslogSeverity
public enum class SyslogSeverity
public enum class SyslogSeverity
Members
Member name | Value | Description
Emergency | 0 | system is unusable
Alert | 1 | action must be taken immediately
Critical | 2 | critical conditions
Error | 3 | error conditions
Warning | 4 | warning conditions
Notice | 5 | normal but significant condition
Informational | 6 | informational
Debug | 7 | debug-level messages
Remarks

            The log4net Level maps to a syslog severity using the
            AddMapping(LocalSyslogAppender LevelSeverity) method and the LocalSyslogAppender LevelSeverity
            class. The severity is set on Severity.

See Also
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender Class

ManagedColoredConsoleAppender Class Apache log4net™ SDK Documentation
Appends colorful logging events to the console, using the .NET 2 built-in capabilities.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender ManagedColoredConsoleAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ManagedColoredConsoleAppender : AppenderSkeleton
public class ManagedColoredConsoleAppender : AppenderSkeleton
Public Class ManagedColoredConsoleAppender
    Inherits AppenderSkeleton
Public Class ManagedColoredConsoleAppender
    Inherits AppenderSkeleton
public ref class ManagedColoredConsoleAppender : public AppenderSkeleton
public ref class ManagedColoredConsoleAppender : public AppenderSkeleton
Remarks

            ManagedColoredConsoleAppender appends log events to the standard output stream
            or the error output stream using a layout specified by the
            user. It also allows the color of a specific type of message to be set.

            By default, all output is written to the console's standard output stream.
            The Target property can be set to direct the output to the
            error stream.

            When configuring the colored console appender, mappings should be
            specified to map logging levels to colors. For example:

XML
View Colorized Copy to Clipboard Print
<mapping><level value="ERROR" /><foreColor value="DarkRed" /><backColor value="White" /></mapping><mapping><level value="WARN" /><foreColor value="Yellow" /></mapping><mapping><level value="INFO" /><foreColor value="White" /></mapping><mapping><level value="DEBUG" /><foreColor value="Blue" /></mapping>
<mapping><level value="ERROR" /><foreColor value="DarkRed" /><backColor value="White" /></mapping><mapping><level value="WARN" /><foreColor value="Yellow" /></mapping><mapping><level value="INFO" /><foreColor value="White" /></mapping><mapping><level value="DEBUG" /><foreColor value="Blue" /></mapping>

            The Level is the standard log4net logging level while
            ForeColor and BackColor are the values of   Online ConsoleColor
            enumeration.

            Based on the ColoredConsoleAppender

See Also
ManagedColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender Members

ManagedColoredConsoleAppender Members Apache log4net™ SDK Documentation
The ManagedColoredConsoleAppender type exposes the following members.
Constructors
 | Name | Description
Public method | ManagedColoredConsoleAppender | Initializes a new instance of the ManagedColoredConsoleAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the options for this appender (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddMapping | Add a mapping of level to color - done by the config file
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
ConsoleError | The Target to use when writing to the Console standard error output stream.
ConsoleOut | The Target to use when writing to the Console standard output stream.
Back to Top
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Target | Target is the value of the console output stream. This is either "Console.Out" or "Console.Error".
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
ManagedColoredConsoleAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender Constructor

ManagedColoredConsoleAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the ManagedColoredConsoleAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ManagedColoredConsoleAppender()
public ManagedColoredConsoleAppender()
Public Sub New
Public Sub New
public:
ManagedColoredConsoleAppender()
public:
ManagedColoredConsoleAppender()
Remarks

            The instance of the ManagedColoredConsoleAppender class is set up to write
            to the standard output stream.

See Also
ManagedColoredConsoleAppender Class
ManagedColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender Fields

ManagedColoredConsoleAppender Fields Apache log4net™ SDK Documentation
The ManagedColoredConsoleAppender type exposes the following members.
Fields
Name | Description
ConsoleError | The Target to use when writing to the Console standard error output stream.
ConsoleOut | The Target to use when writing to the Console standard output stream.
Back to Top
See Also
ManagedColoredConsoleAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.ConsoleError Field

ManagedColoredConsoleAppender ConsoleError Field Apache log4net™ SDK Documentation
The Target to use when writing to the Console standard error output stream.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ConsoleError
public const string ConsoleError
Public Const ConsoleError As String
Public Const ConsoleError As String
public:
literal String^ ConsoleError
public:
literal String^ ConsoleError
Field Value
Type:   Online String
Remarks

            The Target to use when writing to the Console
            standard error output stream.

See Also
ManagedColoredConsoleAppender Class
ManagedColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.ConsoleOut Field

ManagedColoredConsoleAppender ConsoleOut Field Apache log4net™ SDK Documentation
The Target to use when writing to the Console standard output stream.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ConsoleOut
public const string ConsoleOut
Public Const ConsoleOut As String
Public Const ConsoleOut As String
public:
literal String^ ConsoleOut
public:
literal String^ ConsoleOut
Field Value
Type:   Online String
Remarks

            The Target to use when writing to the Console
            standard output stream.

See Also
ManagedColoredConsoleAppender Class
ManagedColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender Methods

ManagedColoredConsoleAppender Methods Apache log4net™ SDK Documentation
The ManagedColoredConsoleAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the options for this appender (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddMapping | Add a mapping of level to color - done by the config file
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ManagedColoredConsoleAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.ActivateOptions Method

ManagedColoredConsoleAppender ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the options for this appender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            Initialize the level to color mappings set on this appender.

See Also
ManagedColoredConsoleAppender Class
ManagedColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.AddMapping Method

ManagedColoredConsoleAppender AddMapping Method Apache log4net™ SDK Documentation
Add a mapping of level to color - done by the config file

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddMapping(
    ManagedColoredConsoleAppender..::..LevelColors mapping
)
public void AddMapping(
    ManagedColoredConsoleAppender..::..LevelColors mapping
)
Public Sub AddMapping (
    mapping As ManagedColoredConsoleAppender..::..LevelColors
)
Public Sub AddMapping (
    mapping As ManagedColoredConsoleAppender..::..LevelColors
)
public:
void AddMapping(
    ManagedColoredConsoleAppender..::..LevelColors^ mapping
)
public:
void AddMapping(
    ManagedColoredConsoleAppender..::..LevelColors^ mapping
)
Parameters
mapping
Type: log4net.Appender ManagedColoredConsoleAppender LevelColors
The mapping to add
Remarks

            Add a ManagedColoredConsoleAppender LevelColors mapping to this appender.
            Each mapping defines the foreground and background colors
            for a level.

See Also
ManagedColoredConsoleAppender Class
ManagedColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.Append Method

ManagedColoredConsoleAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
ManagedColoredConsoleAppender Class
ManagedColoredConsoleAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.Append Method (LoggingEvent)

ManagedColoredConsoleAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Writes the event to the console.

            The format of the output will depend on the appender's layout.

See Also
ManagedColoredConsoleAppender Class
ManagedColoredConsoleAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender Properties

ManagedColoredConsoleAppender Properties Apache log4net™ SDK Documentation
The ManagedColoredConsoleAppender type exposes the following members.
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Target | Target is the value of the console output stream. This is either "Console.Out" or "Console.Error".
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
ManagedColoredConsoleAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.RequiresLayout Property

ManagedColoredConsoleAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
ManagedColoredConsoleAppender Class
ManagedColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.Target Property

ManagedColoredConsoleAppender Target Property Apache log4net™ SDK Documentation
Target is the value of the console output stream. This is either "Console.Out" or "Console.Error".

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Target { get; set; }
public virtual string Target { get; set; }
Public Overridable Property Target As String
    Get
    Set
Public Overridable Property Target As String
    Get
    Set
public:
virtual property String^ Target {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Target {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            Target is the value of the console output stream.
            This is either "Console.Out" or "Console.Error".

Remarks

            Target is the value of the console output stream.
            This is either "Console.Out" or "Console.Error".

See Also
ManagedColoredConsoleAppender Class
ManagedColoredConsoleAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.LevelColors Class

ManagedColoredConsoleAppender LevelColors Class Apache log4net™ SDK Documentation
A class to act as a mapping between the level that a logging call is made at and the color it should be displayed as.
Inheritance Hierarchy
Online System Object
log4net.Util LevelMappingEntry
log4net.Appender ManagedColoredConsoleAppender LevelColors

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LevelColors : LevelMappingEntry
public class LevelColors : LevelMappingEntry
Public Class LevelColors
    Inherits LevelMappingEntry
Public Class LevelColors
    Inherits LevelMappingEntry
public ref class LevelColors : public LevelMappingEntry
public ref class LevelColors : public LevelMappingEntry
Remarks

            Defines the mapping between a level and the color it should be displayed in.

See Also
ManagedColoredConsoleAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.LevelColors Members

ManagedColoredConsoleAppender LevelColors Members Apache log4net™ SDK Documentation
The ManagedColoredConsoleAppender LevelColors type exposes the following members.
Constructors
 | Name | Description
Public method | ManagedColoredConsoleAppender LevelColors | Initializes a new instance of the ManagedColoredConsoleAppender LevelColors class
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize any options defined on this entry (Inherited from LevelMappingEntry.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | BackColor | The mapped background color for the specified level
Public property | ForeColor | The mapped foreground color for the specified level
Public property | Level | The level that is the key for this mapping (Inherited from LevelMappingEntry.)
Back to Top
See Also
ManagedColoredConsoleAppender LevelColors Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.LevelColors Constructor

ManagedColoredConsoleAppender LevelColors Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the ManagedColoredConsoleAppender LevelColors class

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelColors()
public LevelColors()
Public Sub New
Public Sub New
public:
LevelColors()
public:
LevelColors()
See Also
ManagedColoredConsoleAppender LevelColors Class
ManagedColoredConsoleAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.LevelColors Methods

ManagedColoredConsoleAppender LevelColors Methods Apache log4net™ SDK Documentation
The ManagedColoredConsoleAppender LevelColors type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize any options defined on this entry (Inherited from LevelMappingEntry.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ManagedColoredConsoleAppender LevelColors Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.LevelColors Properties

ManagedColoredConsoleAppender LevelColors Properties Apache log4net™ SDK Documentation
The ManagedColoredConsoleAppender LevelColors type exposes the following members.
Properties
 | Name | Description
Public property | BackColor | The mapped background color for the specified level
Public property | ForeColor | The mapped foreground color for the specified level
Public property | Level | The level that is the key for this mapping (Inherited from LevelMappingEntry.)
Back to Top
See Also
ManagedColoredConsoleAppender LevelColors Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.LevelColors.BackColor Property

ManagedColoredConsoleAppender LevelColors BackColor Property Apache log4net™ SDK Documentation
The mapped background color for the specified level

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConsoleColor BackColor { get; set; }
public ConsoleColor BackColor { get; set; }
Public Property BackColor As ConsoleColor
    Get
    Set
Public Property BackColor As ConsoleColor
    Get
    Set
public:
property ConsoleColor BackColor {
    ConsoleColor get ();
    void set (ConsoleColor value);
}
public:
property ConsoleColor BackColor {
    ConsoleColor get ();
    void set (ConsoleColor value);
}
Property Value
Type:   Online ConsoleColor
Remarks

            Required property.
            The mapped background color for the specified level.

See Also
ManagedColoredConsoleAppender LevelColors Class
ManagedColoredConsoleAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ManagedColoredConsoleAppender.LevelColors.ForeColor Property

ManagedColoredConsoleAppender LevelColors ForeColor Property Apache log4net™ SDK Documentation
The mapped foreground color for the specified level

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConsoleColor ForeColor { get; set; }
public ConsoleColor ForeColor { get; set; }
Public Property ForeColor As ConsoleColor
    Get
    Set
Public Property ForeColor As ConsoleColor
    Get
    Set
public:
property ConsoleColor ForeColor {
    ConsoleColor get ();
    void set (ConsoleColor value);
}
public:
property ConsoleColor ForeColor {
    ConsoleColor get ();
    void set (ConsoleColor value);
}
Property Value
Type:   Online ConsoleColor
Remarks

            Required property.
            The mapped foreground color for the specified level.

See Also
ManagedColoredConsoleAppender LevelColors Class
ManagedColoredConsoleAppender LevelColors Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender Class

MemoryAppender Class Apache log4net™ SDK Documentation
Stores logging events in an array.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender MemoryAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MemoryAppender : AppenderSkeleton
public class MemoryAppender : AppenderSkeleton
Public Class MemoryAppender
    Inherits AppenderSkeleton
Public Class MemoryAppender
    Inherits AppenderSkeleton
public ref class MemoryAppender : public AppenderSkeleton
public ref class MemoryAppender : public AppenderSkeleton
Remarks

            The memory appender stores all the logging events
            that are appended in an in-memory array.

            Use the [M:PopAllEvents()] method to get
            and clear the current list of events that have been appended.

            Use the [M:GetEvents()] method to get the current
            list of events that have been appended.  Note there is a
            race-condition when calling [M:GetEvents()] and
            [M:Clear()] in pairs, you better use  in that case.

            Use the [M:Clear()] method to clear the
            current list of events.  Note there is a
            race-condition when calling [M:GetEvents()] and
            [M:Clear()] in pairs, you better use  in that case.

See Also
MemoryAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender Members

MemoryAppender Members Apache log4net™ SDK Documentation
The MemoryAppender type exposes the following members.
Constructors
 | Name | Description
Public method | MemoryAppender | Initializes a new instance of the MemoryAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | Clear | Clear the list of events
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | GetEvents | Gets the events that have been logged.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Public method | PopAllEvents | Gets the events that have been logged and clears the list of events.
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | m_eventsList | The list of events that have been appended.
Protected field | m_fixFlags | Value indicating which fields in the event should be fixed
Back to Top
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets the fields that will be fixed in the event
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating whether only part of the logging event data should be fixed.
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set. (Inherited from AppenderSkeleton.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
MemoryAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender Constructor

MemoryAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the MemoryAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MemoryAppender()
public MemoryAppender()
Public Sub New
Public Sub New
public:
MemoryAppender()
public:
MemoryAppender()
Remarks

            Default constructor.

See Also
MemoryAppender Class
MemoryAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender Fields

MemoryAppender Fields Apache log4net™ SDK Documentation
The MemoryAppender type exposes the following members.
Fields
 | Name | Description
Protected field | m_eventsList | The list of events that have been appended.
Protected field | m_fixFlags | Value indicating which fields in the event should be fixed
Back to Top
See Also
MemoryAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender.m_eventsList Field

MemoryAppender m_eventsList Field Apache log4net™ SDK Documentation
The list of events that have been appended.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ArrayList m_eventsList
protected ArrayList m_eventsList
Protected m_eventsList As ArrayList
Protected m_eventsList As ArrayList
protected:
ArrayList^ m_eventsList
protected:
ArrayList^ m_eventsList
Field Value
Type:   Online ArrayList
See Also
MemoryAppender Class
MemoryAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender.m_fixFlags Field

MemoryAppender m_fixFlags Field Apache log4net™ SDK Documentation
Value indicating which fields in the event should be fixed

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FixFlags m_fixFlags
protected FixFlags m_fixFlags
Protected m_fixFlags As FixFlags
Protected m_fixFlags As FixFlags
protected:
FixFlags m_fixFlags
protected:
FixFlags m_fixFlags
Field Value
Type: FixFlags
Remarks

            By default all fields are fixed

See Also
MemoryAppender Class
MemoryAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender Methods

MemoryAppender Methods Apache log4net™ SDK Documentation
The MemoryAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | Clear | Clear the list of events
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | GetEvents | Gets the events that have been logged.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Public method | PopAllEvents | Gets the events that have been logged and clears the list of events.
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MemoryAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender.Append Method

MemoryAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
MemoryAppender Class
MemoryAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender.Append Method (LoggingEvent)

MemoryAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the event to log
Remarks
Stores the loggingEvent in the events list.
See Also
MemoryAppender Class
MemoryAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender.Clear Method

MemoryAppender Clear Method Apache log4net™ SDK Documentation
Clear the list of events

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Clear()
public virtual void Clear()
Public Overridable Sub Clear
Public Overridable Sub Clear
public:
virtual void Clear()
public:
virtual void Clear()
Remarks

            Clear the list of events

See Also
MemoryAppender Class
MemoryAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender.GetEvents Method

MemoryAppender GetEvents Method Apache log4net™ SDK Documentation
Gets the events that have been logged.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual LoggingEvent[] GetEvents()
public virtual LoggingEvent[] GetEvents()
Public Overridable Function GetEvents As LoggingEvent()
Public Overridable Function GetEvents As LoggingEvent()
public:
virtual array<LoggingEvent^>^ GetEvents()
public:
virtual array<LoggingEvent^>^ GetEvents()
Return Value
Type:  LoggingEvent
The events that have been logged
Remarks

            Gets the events that have been logged.

See Also
MemoryAppender Class
MemoryAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender.PopAllEvents Method

MemoryAppender PopAllEvents Method Apache log4net™ SDK Documentation
Gets the events that have been logged and clears the list of events.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual LoggingEvent[] PopAllEvents()
public virtual LoggingEvent[] PopAllEvents()
Public Overridable Function PopAllEvents As LoggingEvent()
Public Overridable Function PopAllEvents As LoggingEvent()
public:
virtual array<LoggingEvent^>^ PopAllEvents()
public:
virtual array<LoggingEvent^>^ PopAllEvents()
Return Value
Type:  LoggingEvent
The events that have been logged
Remarks

            Gets the events that have been logged and clears the list of events.

See Also
MemoryAppender Class
MemoryAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender Properties

MemoryAppender Properties Apache log4net™ SDK Documentation
The MemoryAppender type exposes the following members.
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets the fields that will be fixed in the event
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating whether only part of the logging event data should be fixed.
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set. (Inherited from AppenderSkeleton.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
MemoryAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender.Fix Property

MemoryAppender Fix Property Apache log4net™ SDK Documentation
Gets or sets the fields that will be fixed in the event

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual FixFlags Fix { get; set; }
public virtual FixFlags Fix { get; set; }
Public Overridable Property Fix As FixFlags
    Get
    Set
Public Overridable Property Fix As FixFlags
    Get
    Set
public:
virtual property FixFlags Fix {
    FixFlags get ();
    void set (FixFlags value);
}
public:
virtual property FixFlags Fix {
    FixFlags get ();
    void set (FixFlags value);
}
Property Value
Type: FixFlags
Remarks

            The logging event needs to have certain thread specific values
            captured before it can be buffered. See Fix
            for details.

See Also
MemoryAppender Class
MemoryAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MemoryAppender.OnlyFixPartialEventData Property

MemoryAppender OnlyFixPartialEventData Property Apache log4net™ SDK Documentation
Gets or sets a value indicating whether only part of the logging event data should be fixed.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Fix property")]
public virtual bool OnlyFixPartialEventData { get; set; }
[ObsoleteAttribute("Use Fix property")]
public virtual bool OnlyFixPartialEventData { get; set; }
<ObsoleteAttribute("Use Fix property")>
Public Overridable Property OnlyFixPartialEventData As Boolean
    Get
    Set
<ObsoleteAttribute("Use Fix property")>
Public Overridable Property OnlyFixPartialEventData As Boolean
    Get
    Set
public:
[ObsoleteAttribute(L"Use Fix property")]
virtual property bool OnlyFixPartialEventData {
    bool get ();
    void set (bool value);
}
public:
[ObsoleteAttribute(L"Use Fix property")]
virtual property bool OnlyFixPartialEventData {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if the appender should only fix part of the logging event
            data, otherwise false. The default is false.

Remarks

            Setting this property to true will cause only part of the event
            data to be fixed and stored in the appender, hereby improving performance.

            See FixVolatileData(bool) for more information.

See Also
MemoryAppender Class
MemoryAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender Class

NetSendAppender Class Apache log4net™ SDK Documentation
Logs entries by sending network messages using the NetMessageBufferSend(String, String, String, String, Int32) native function.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender NetSendAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NetSendAppender : AppenderSkeleton
public class NetSendAppender : AppenderSkeleton
Public Class NetSendAppender
    Inherits AppenderSkeleton
Public Class NetSendAppender
    Inherits AppenderSkeleton
public ref class NetSendAppender : public AppenderSkeleton
public ref class NetSendAppender : public AppenderSkeleton
Remarks

            You can send messages only to names that are active
            on the network. If you send the message to a user name,
            that user must be logged on and running the Messenger
            service to receive the message.

            The receiver will get a top most window displaying the
            messages one at a time, therefore this appender should
            not be used to deliver a high volume of messages.

            The following table lists some possible uses for this appender :

Action | Property Value(s)
Send a message to a user account on the local machine | Server = <name of the local machine> Recipient = <user name>
Send a message to a user account on a remote machine | Server = <name of the remote machine> Recipient = <user name>
Send a message to a domain user account | Server = <name of a domain controller | uninitialized> Recipient = <user name>
Send a message to all the names in a workgroup or domain | Recipient = <workgroup name | domain name>*
Send a message from the local machine to a remote machine | Server = <name of the local machine | uninitialized> Recipient = <name of the remote machine>
Note : security restrictions apply for sending
            network messages, see NetMessageBufferSend(String, String, String, String, Int32)
            for more information.

Examples

            An example configuration section to log information
            using this appender from the local machine, named
            LOCAL_PC, to machine OPERATOR_PC :

XML
View Colorized Copy to Clipboard Print
<appender name="NetSendAppender_Operator" type="log4net.Appender.NetSendAppender"><server value="LOCAL_PC" /><recipient value="OPERATOR_PC" /><layout type="log4net.Layout.PatternLayout" value="%-5p %c [%x] - %m%n" /></appender>
<appender name="NetSendAppender_Operator" type="log4net.Appender.NetSendAppender"><server value="LOCAL_PC" /><recipient value="OPERATOR_PC" /><layout type="log4net.Layout.PatternLayout" value="%-5p %c [%x] - %m%n" /></appender>
See Also
NetSendAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender Members

NetSendAppender Members Apache log4net™ SDK Documentation
The NetSendAppender type exposes the following members.
Constructors
 | Name | Description
Public method | NetSendAppender | Initializes the appender.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set. (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NetMessageBufferSend | Sends a buffer of information to a registered message alias.
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | Recipient | Gets or sets the message alias to which the message should be sent.
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | SecurityContext | Gets or sets the SecurityContext used to call the NetSend method.
Public property | Sender | Gets or sets the sender of the message.
Public property | Server | Gets or sets the DNS or NetBIOS name of the remote server on which the function is to execute.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
NetSendAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender Constructor

NetSendAppender Constructor Apache log4net™ SDK Documentation
Initializes the appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetSendAppender()
public NetSendAppender()
Public Sub New
Public Sub New
public:
NetSendAppender()
public:
NetSendAppender()
Remarks

            The default constructor initializes all fields to their default values.

See Also
NetSendAppender Class
NetSendAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender Methods

NetSendAppender Methods Apache log4net™ SDK Documentation
The NetSendAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set. (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NetMessageBufferSend | Sends a buffer of information to a registered message alias.
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NetSendAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender.ActivateOptions Method

NetSendAppender ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the appender based on the options set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Exceptions
Exception | Condition
Online System ArgumentNullException | The required property Recipient was not specified.
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

            The appender will be ignored if no Recipient was specified.

See Also
NetSendAppender Class
NetSendAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender.Append Method

NetSendAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
NetSendAppender Class
NetSendAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender.Append Method (LoggingEvent)

NetSendAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Sends the event using a network message.

See Also
NetSendAppender Class
NetSendAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender.NetMessageBufferSend Method

NetSendAppender NetMessageBufferSend Method Apache log4net™ SDK Documentation
Sends a buffer of information to a registered message alias.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static int NetMessageBufferSend(
    string serverName,
    string msgName,
    string fromName,
    string buffer,
    int bufferSize
)
protected static int NetMessageBufferSend(
    string serverName,
    string msgName,
    string fromName,
    string buffer,
    int bufferSize
)
Protected Shared Function NetMessageBufferSend (
    serverName As String,
    msgName As String,
    fromName As String,
    buffer As String,
    bufferSize As Integer
) As Integer
Protected Shared Function NetMessageBufferSend (
    serverName As String,
    msgName As String,
    fromName As String,
    buffer As String,
    bufferSize As Integer
) As Integer
protected:
static int NetMessageBufferSend(
    String^ serverName,
    String^ msgName,
    String^ fromName,
    String^ buffer,
    int bufferSize
)
protected:
static int NetMessageBufferSend(
    String^ serverName,
    String^ msgName,
    String^ fromName,
    String^ buffer,
    int bufferSize
)
Parameters
serverName
Type:   Online System String
The DNS or NetBIOS name of the server on which the function is to execute.
msgName
Type:   Online System String
The message alias to which the message buffer should be sent
fromName
Type:   Online System String
The originator of the message.
buffer
Type:   Online System String
The message text.
bufferSize
Type:   Online System Int32
The length, in bytes, of the message text.
Return Value
Type:   Online Int32

            If the function succeeds, the return value is zero.

Remarks

            The following restrictions apply for sending network messages:

Platform | Requirements
Windows NT | No special group membership is required to send a network message. Admin, Accounts, Print, or Server Operator group membership is required to successfully send a network message on a remote server.
Windows 2000 or later | If you send a message on a domain controller that is running Active Directory, access is allowed or denied based on the access control list (ACL) for the securable object. The default ACL permits only Domain Admins and Account Operators to send a network message. On a member server or workstation, only Administrators and Server Operators can send a network message.

            For more information see   Online Security Requirements for the Network Management Functions.

See Also
NetSendAppender Class
NetSendAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender Properties

NetSendAppender Properties Apache log4net™ SDK Documentation
The NetSendAppender type exposes the following members.
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | Recipient | Gets or sets the message alias to which the message should be sent.
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | SecurityContext | Gets or sets the SecurityContext used to call the NetSend method.
Public property | Sender | Gets or sets the sender of the message.
Public property | Server | Gets or sets the DNS or NetBIOS name of the remote server on which the function is to execute.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
NetSendAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender.Recipient Property

NetSendAppender Recipient Property Apache log4net™ SDK Documentation
Gets or sets the message alias to which the message should be sent.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Recipient { get; set; }
public string Recipient { get; set; }
Public Property Recipient As String
    Get
    Set
Public Property Recipient As String
    Get
    Set
public:
property String^ Recipient {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Recipient {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The recipient of the message.

Remarks

            This property should always be specified in order to send a message.

See Also
NetSendAppender Class
NetSendAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender.RequiresLayout Property

NetSendAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
NetSendAppender Class
NetSendAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender.SecurityContext Property

NetSendAppender SecurityContext Property Apache log4net™ SDK Documentation
Gets or sets the SecurityContext used to call the NetSend method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityContext SecurityContext { get; set; }
public SecurityContext SecurityContext { get; set; }
Public Property SecurityContext As SecurityContext
    Get
    Set
Public Property SecurityContext As SecurityContext
    Get
    Set
public:
property SecurityContext^ SecurityContext {
    SecurityContext^ get ();
    void set (SecurityContext^ value);
}
public:
property SecurityContext^ SecurityContext {
    SecurityContext^ get ();
    void set (SecurityContext^ value);
}
Property Value
Type: SecurityContext

            The SecurityContext used to call the NetSend method.

Remarks

            Unless a SecurityContext specified here for this appender
            the DefaultProvider is queried for the
            security context to use. The default behavior is to use the security context
            of the current thread.

See Also
NetSendAppender Class
NetSendAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender.Sender Property

NetSendAppender Sender Property Apache log4net™ SDK Documentation
Gets or sets the sender of the message.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Sender { get; set; }
public string Sender { get; set; }
Public Property Sender As String
    Get
    Set
Public Property Sender As String
    Get
    Set
public:
property String^ Sender {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Sender {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The sender of the message.

Remarks

            If this property is not specified, the message is sent from the local computer.

See Also
NetSendAppender Class
NetSendAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NetSendAppender.Server Property

NetSendAppender Server Property Apache log4net™ SDK Documentation
Gets or sets the DNS or NetBIOS name of the remote server on which the function is to execute.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Server { get; set; }
public string Server { get; set; }
Public Property Server As String
    Get
    Set
Public Property Server As String
    Get
    Set
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            DNS or NetBIOS name of the remote server on which the function is to execute.

Remarks

            For Windows NT 4.0 and earlier, the string should begin with \\.

            If this property is not specified, the local computer is used.

See Also
NetSendAppender Class
NetSendAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OutputDebugStringAppender Class

OutputDebugStringAppender Class Apache log4net™ SDK Documentation
Appends log events to the OutputDebugString system.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender OutputDebugStringAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class OutputDebugStringAppender : AppenderSkeleton
public class OutputDebugStringAppender : AppenderSkeleton
Public Class OutputDebugStringAppender
    Inherits AppenderSkeleton
Public Class OutputDebugStringAppender
    Inherits AppenderSkeleton
public ref class OutputDebugStringAppender : public AppenderSkeleton
public ref class OutputDebugStringAppender : public AppenderSkeleton
Remarks

            OutputDebugStringAppender appends log events to the
            OutputDebugString system.

            The string is passed to the native OutputDebugString
            function.

See Also
OutputDebugStringAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OutputDebugStringAppender Members

OutputDebugStringAppender Members Apache log4net™ SDK Documentation
The OutputDebugStringAppender type exposes the following members.
Constructors
 | Name | Description
Public method | OutputDebugStringAppender | Initializes a new instance of the OutputDebugStringAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Write the logging event to the output debug string API (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
 | OutputDebugString | Stub for OutputDebugString native method
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
OutputDebugStringAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OutputDebugStringAppender Constructor

OutputDebugStringAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the OutputDebugStringAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OutputDebugStringAppender()
public OutputDebugStringAppender()
Public Sub New
Public Sub New
public:
OutputDebugStringAppender()
public:
OutputDebugStringAppender()
Remarks

            Default constructor.

See Also
OutputDebugStringAppender Class
OutputDebugStringAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OutputDebugStringAppender Methods

OutputDebugStringAppender Methods Apache log4net™ SDK Documentation
The OutputDebugStringAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Write the logging event to the output debug string API (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
 | OutputDebugString | Stub for OutputDebugString native method
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
OutputDebugStringAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OutputDebugStringAppender.Append Method

OutputDebugStringAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Write the logging event to the output debug string API (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
OutputDebugStringAppender Class
OutputDebugStringAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OutputDebugStringAppender.Append Method (LoggingEvent)

OutputDebugStringAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
Write the logging event to the output debug string API

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the event to log
Remarks

            Write the logging event to the output debug string API

See Also
OutputDebugStringAppender Class
OutputDebugStringAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OutputDebugStringAppender.OutputDebugString Method

OutputDebugStringAppender OutputDebugString Method Apache log4net™ SDK Documentation
Stub for OutputDebugString native method

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static void OutputDebugString(
    string message
)
protected static void OutputDebugString(
    string message
)
Protected Shared Sub OutputDebugString (
    message As String
)
Protected Shared Sub OutputDebugString (
    message As String
)
protected:
static void OutputDebugString(
    String^ message
)
protected:
static void OutputDebugString(
    String^ message
)
Parameters
message
Type:   Online System String
the string to output
Remarks

            Stub for OutputDebugString native method

See Also
OutputDebugStringAppender Class
OutputDebugStringAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OutputDebugStringAppender Properties

OutputDebugStringAppender Properties Apache log4net™ SDK Documentation
The OutputDebugStringAppender type exposes the following members.
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
OutputDebugStringAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OutputDebugStringAppender.RequiresLayout Property

OutputDebugStringAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
OutputDebugStringAppender Class
OutputDebugStringAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender Class

RemoteSyslogAppender Class Apache log4net™ SDK Documentation
Logs events to a remote syslog daemon.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender UdpAppender
log4net.Appender RemoteSyslogAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RemoteSyslogAppender : UdpAppender
public class RemoteSyslogAppender : UdpAppender
Public Class RemoteSyslogAppender
    Inherits UdpAppender
Public Class RemoteSyslogAppender
    Inherits UdpAppender
public ref class RemoteSyslogAppender : public UdpAppender
public ref class RemoteSyslogAppender : public UdpAppender
Remarks

            The BSD syslog protocol is used to remotely log to
            a syslog daemon. The syslogd listens for for messages
            on UDP port 514.

            The syslog UDP protocol is not authenticated. Most syslog daemons
            do not accept remote log messages because of the security implications.
            You may be able to use the LocalSyslogAppender to talk to a local
            syslog service.

            There is an RFC 3164 that claims to document the BSD Syslog Protocol.
            This RFC can be seen here: http://www.faqs.org/rfcs/rfc3164.html.
            This appender generates what the RFC calls an "Original Device Message",
            i.e. does not include the TIMESTAMP or HOSTNAME fields. By observation
            this format of message will be accepted by all current syslog daemon
            implementations. The daemon will attach the current time and the source
            hostname or IP address to any messages received.

            Syslog messages must have a facility and and a severity. The severity
            is derived from the Level of the logging event.
            The facility must be chosen from the set of defined syslog
            RemoteSyslogAppender SyslogFacility values. The facilities list is predefined
            and cannot be extended.

            An identifier is specified with each log message. This can be specified
            by setting the Identity property. The identity (also know
            as the tag) must not contain white space. The default value for the
            identity is the application name (from Domain).

See Also
RemoteSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender Members

RemoteSyslogAppender Members Apache log4net™ SDK Documentation
The RemoteSyslogAppender type exposes the following members.
Constructors
 | Name | Description
Public method | RemoteSyslogAppender | Initializes a new instance of the RemoteSyslogAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the options for this appender (Overrides UdpAppender ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddMapping | Add a mapping of level to severity
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides UdpAppender Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
 | GeneratePriority | Generate a syslog priority.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetSeverity | Translates a log4net level to a syslog severity.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitializeClientConnection | Initializes the underlying Online UdpClient connection. (Inherited from UdpAppender.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Closes the UDP connection and releases all resources associated with this UdpAppender instance. (Inherited from UdpAppender.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Protected property | Client | Gets or sets the underlying Online UdpClient. (Inherited from UdpAppender.)
Public property | Encoding | Gets or sets Encoding used to write the packets. (Inherited from UdpAppender.)
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Facility | Syslog facility
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Identity | Message identity
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | LocalPort | Gets or sets the TCP port number from which the underlying Online UdpClient will communicate. (Inherited from UdpAppender.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | RemoteAddress | Gets or sets the IP address of the remote host or multicast group to which the underlying Online UdpClient should sent the logging event. (Inherited from UdpAppender.)
Protected property | RemoteEndPoint | Gets or sets the cached remote endpoint to which the logging events should be sent. (Inherited from UdpAppender.)
Public property | RemotePort | Gets or sets the TCP port number of the remote host or multicast group to which the underlying Online UdpClient should sent the logging event. (Inherited from UdpAppender.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Inherited from UdpAppender.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
RemoteSyslogAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender Constructor

RemoteSyslogAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the RemoteSyslogAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RemoteSyslogAppender()
public RemoteSyslogAppender()
Public Sub New
Public Sub New
public:
RemoteSyslogAppender()
public:
RemoteSyslogAppender()
Remarks

            This instance of the RemoteSyslogAppender class is set up to write
            to a remote syslog daemon.

See Also
RemoteSyslogAppender Class
RemoteSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender Methods

RemoteSyslogAppender Methods Apache log4net™ SDK Documentation
The RemoteSyslogAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the options for this appender (Overrides UdpAppender ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Public method | AddMapping | Add a mapping of level to severity
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides UdpAppender Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
 | GeneratePriority | Generate a syslog priority.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetSeverity | Translates a log4net level to a syslog severity.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitializeClientConnection | Initializes the underlying Online UdpClient connection. (Inherited from UdpAppender.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Closes the UDP connection and releases all resources associated with this UdpAppender instance. (Inherited from UdpAppender.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RemoteSyslogAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.ActivateOptions Method

RemoteSyslogAppender ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the options for this appender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            Initialize the level to syslog severity mappings set on this appender.

See Also
RemoteSyslogAppender Class
RemoteSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.AddMapping Method

RemoteSyslogAppender AddMapping Method Apache log4net™ SDK Documentation
Add a mapping of level to severity

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddMapping(
    RemoteSyslogAppender..::..LevelSeverity mapping
)
public void AddMapping(
    RemoteSyslogAppender..::..LevelSeverity mapping
)
Public Sub AddMapping (
    mapping As RemoteSyslogAppender..::..LevelSeverity
)
Public Sub AddMapping (
    mapping As RemoteSyslogAppender..::..LevelSeverity
)
public:
void AddMapping(
    RemoteSyslogAppender..::..LevelSeverity^ mapping
)
public:
void AddMapping(
    RemoteSyslogAppender..::..LevelSeverity^ mapping
)
Parameters
mapping
Type: log4net.Appender RemoteSyslogAppender LevelSeverity
The mapping to add
Remarks

            Add a RemoteSyslogAppender LevelSeverity mapping to this appender.

See Also
RemoteSyslogAppender Class
RemoteSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.Append Method

RemoteSyslogAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides UdpAppender Append(LoggingEvent).)
Back to Top
See Also
RemoteSyslogAppender Class
RemoteSyslogAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.Append Method (LoggingEvent)

RemoteSyslogAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Writes the event to a remote syslog daemon.

            The format of the output will depend on the appender's layout.

See Also
RemoteSyslogAppender Class
RemoteSyslogAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.GeneratePriority Method

RemoteSyslogAppender GeneratePriority Method Apache log4net™ SDK Documentation
Generate a syslog priority.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GeneratePriority(
    RemoteSyslogAppender..::..SyslogFacility facility,
    RemoteSyslogAppender..::..SyslogSeverity severity
)
public static int GeneratePriority(
    RemoteSyslogAppender..::..SyslogFacility facility,
    RemoteSyslogAppender..::..SyslogSeverity severity
)
Public Shared Function GeneratePriority (
    facility As RemoteSyslogAppender..::..SyslogFacility,
    severity As RemoteSyslogAppender..::..SyslogSeverity
) As Integer
Public Shared Function GeneratePriority (
    facility As RemoteSyslogAppender..::..SyslogFacility,
    severity As RemoteSyslogAppender..::..SyslogSeverity
) As Integer
public:
static int GeneratePriority(
    RemoteSyslogAppender..::..SyslogFacility facility,
    RemoteSyslogAppender..::..SyslogSeverity severity
)
public:
static int GeneratePriority(
    RemoteSyslogAppender..::..SyslogFacility facility,
    RemoteSyslogAppender..::..SyslogSeverity severity
)
Parameters
facility
Type: log4net.Appender RemoteSyslogAppender SyslogFacility
The syslog facility.
severity
Type: log4net.Appender RemoteSyslogAppender SyslogSeverity
The syslog severity.
Return Value
Type:   Online Int32
A syslog priority.
Remarks

            Generate a syslog priority.

See Also
RemoteSyslogAppender Class
RemoteSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.GetSeverity Method

RemoteSyslogAppender GetSeverity Method Apache log4net™ SDK Documentation
Translates a log4net level to a syslog severity.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual RemoteSyslogAppender..::..SyslogSeverity GetSeverity(
    Level level
)
protected virtual RemoteSyslogAppender..::..SyslogSeverity GetSeverity(
    Level level
)
Protected Overridable Function GetSeverity (
    level As Level
) As RemoteSyslogAppender..::..SyslogSeverity
Protected Overridable Function GetSeverity (
    level As Level
) As RemoteSyslogAppender..::..SyslogSeverity
protected:
virtual RemoteSyslogAppender..::..SyslogSeverity GetSeverity(
    Level^ level
)
protected:
virtual RemoteSyslogAppender..::..SyslogSeverity GetSeverity(
    Level^ level
)
Parameters
level
Type: log4net.Core Level
A log4net level.
Return Value
Type: RemoteSyslogAppender SyslogSeverity
A syslog severity.
Remarks

            Translates a log4net level to a syslog severity.

See Also
RemoteSyslogAppender Class
RemoteSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender Properties

RemoteSyslogAppender Properties Apache log4net™ SDK Documentation
The RemoteSyslogAppender type exposes the following members.
Properties
 | Name | Description
Protected property | Client | Gets or sets the underlying Online UdpClient. (Inherited from UdpAppender.)
Public property | Encoding | Gets or sets Encoding used to write the packets. (Inherited from UdpAppender.)
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Facility | Syslog facility
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Identity | Message identity
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | LocalPort | Gets or sets the TCP port number from which the underlying Online UdpClient will communicate. (Inherited from UdpAppender.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | RemoteAddress | Gets or sets the IP address of the remote host or multicast group to which the underlying Online UdpClient should sent the logging event. (Inherited from UdpAppender.)
Protected property | RemoteEndPoint | Gets or sets the cached remote endpoint to which the logging events should be sent. (Inherited from UdpAppender.)
Public property | RemotePort | Gets or sets the TCP port number of the remote host or multicast group to which the underlying Online UdpClient should sent the logging event. (Inherited from UdpAppender.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Inherited from UdpAppender.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
RemoteSyslogAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.Facility Property

RemoteSyslogAppender Facility Property Apache log4net™ SDK Documentation
Syslog facility

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RemoteSyslogAppender..::..SyslogFacility Facility { get; set; }
public RemoteSyslogAppender..::..SyslogFacility Facility { get; set; }
Public Property Facility As RemoteSyslogAppender..::..SyslogFacility
    Get
    Set
Public Property Facility As RemoteSyslogAppender..::..SyslogFacility
    Get
    Set
public:
property RemoteSyslogAppender..::..SyslogFacility Facility {
    RemoteSyslogAppender..::..SyslogFacility get ();
    void set (RemoteSyslogAppender..::..SyslogFacility value);
}
public:
property RemoteSyslogAppender..::..SyslogFacility Facility {
    RemoteSyslogAppender..::..SyslogFacility get ();
    void set (RemoteSyslogAppender..::..SyslogFacility value);
}
Property Value
Type: RemoteSyslogAppender SyslogFacility
Remarks

            Set to one of the RemoteSyslogAppender SyslogFacility values. The list of
            facilities is predefined and cannot be extended. The default value
            is User.

See Also
RemoteSyslogAppender Class
RemoteSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.Identity Property

RemoteSyslogAppender Identity Property Apache log4net™ SDK Documentation
Message identity

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PatternLayout Identity { get; set; }
public PatternLayout Identity { get; set; }
Public Property Identity As PatternLayout
    Get
    Set
Public Property Identity As PatternLayout
    Get
    Set
public:
property PatternLayout^ Identity {
    PatternLayout^ get ();
    void set (PatternLayout^ value);
}
public:
property PatternLayout^ Identity {
    PatternLayout^ get ();
    void set (PatternLayout^ value);
}
Property Value
Type: PatternLayout
Remarks

            An identifier is specified with each log message. This can be specified
            by setting the Identity property. The identity (also know
            as the tag) must not contain white space. The default value for the
            identity is the application name (from Domain).

See Also
RemoteSyslogAppender Class
RemoteSyslogAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.LevelSeverity Class

RemoteSyslogAppender LevelSeverity Class Apache log4net™ SDK Documentation
A class to act as a mapping between the level that a logging call is made at and the syslog severity that is should be logged at.
Inheritance Hierarchy
Online System Object
log4net.Util LevelMappingEntry
log4net.Appender RemoteSyslogAppender LevelSeverity

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LevelSeverity : LevelMappingEntry
public class LevelSeverity : LevelMappingEntry
Public Class LevelSeverity
    Inherits LevelMappingEntry
Public Class LevelSeverity
    Inherits LevelMappingEntry
public ref class LevelSeverity : public LevelMappingEntry
public ref class LevelSeverity : public LevelMappingEntry
Remarks

            A class to act as a mapping between the level that a logging call is made at and
            the syslog severity that is should be logged at.

See Also
RemoteSyslogAppender LevelSeverity Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.LevelSeverity Members

RemoteSyslogAppender LevelSeverity Members Apache log4net™ SDK Documentation
The RemoteSyslogAppender LevelSeverity type exposes the following members.
Constructors
 | Name | Description
Public method | RemoteSyslogAppender LevelSeverity | Initializes a new instance of the RemoteSyslogAppender LevelSeverity class
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize any options defined on this entry (Inherited from LevelMappingEntry.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Level | The level that is the key for this mapping (Inherited from LevelMappingEntry.)
Public property | Severity | The mapped syslog severity for the specified level
Back to Top
See Also
RemoteSyslogAppender LevelSeverity Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.LevelSeverity Constructor

RemoteSyslogAppender LevelSeverity Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the RemoteSyslogAppender LevelSeverity class

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelSeverity()
public LevelSeverity()
Public Sub New
Public Sub New
public:
LevelSeverity()
public:
LevelSeverity()
See Also
RemoteSyslogAppender LevelSeverity Class
RemoteSyslogAppender LevelSeverity Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.LevelSeverity Methods

RemoteSyslogAppender LevelSeverity Methods Apache log4net™ SDK Documentation
The RemoteSyslogAppender LevelSeverity type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize any options defined on this entry (Inherited from LevelMappingEntry.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RemoteSyslogAppender LevelSeverity Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.LevelSeverity Properties

RemoteSyslogAppender LevelSeverity Properties Apache log4net™ SDK Documentation
The RemoteSyslogAppender LevelSeverity type exposes the following members.
Properties
 | Name | Description
Public property | Level | The level that is the key for this mapping (Inherited from LevelMappingEntry.)
Public property | Severity | The mapped syslog severity for the specified level
Back to Top
See Also
RemoteSyslogAppender LevelSeverity Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.LevelSeverity.Severity Property

RemoteSyslogAppender LevelSeverity Severity Property Apache log4net™ SDK Documentation
The mapped syslog severity for the specified level

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RemoteSyslogAppender..::..SyslogSeverity Severity { get; set; }
public RemoteSyslogAppender..::..SyslogSeverity Severity { get; set; }
Public Property Severity As RemoteSyslogAppender..::..SyslogSeverity
    Get
    Set
Public Property Severity As RemoteSyslogAppender..::..SyslogSeverity
    Get
    Set
public:
property RemoteSyslogAppender..::..SyslogSeverity Severity {
    RemoteSyslogAppender..::..SyslogSeverity get ();
    void set (RemoteSyslogAppender..::..SyslogSeverity value);
}
public:
property RemoteSyslogAppender..::..SyslogSeverity Severity {
    RemoteSyslogAppender..::..SyslogSeverity get ();
    void set (RemoteSyslogAppender..::..SyslogSeverity value);
}
Property Value
Type: RemoteSyslogAppender SyslogSeverity
Remarks

            Required property.
            The mapped syslog severity for the specified level

See Also
RemoteSyslogAppender LevelSeverity Class
RemoteSyslogAppender LevelSeverity Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.SyslogFacility Enumeration

RemoteSyslogAppender SyslogFacility Enumeration Apache log4net™ SDK Documentation
syslog facilities

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum SyslogFacility
public enum SyslogFacility
Public Enumeration SyslogFacility
Public Enumeration SyslogFacility
public enum class SyslogFacility
public enum class SyslogFacility
Members
Member name | Value | Description
Kernel | 0 | kernel messages
User | 1 | random user-level messages
Mail | 2 | mail system
Daemons | 3 | system daemons
Authorization | 4 | security/authorization messages
Syslog | 5 | messages generated internally by syslogd
Printer | 6 | line printer subsystem
News | 7 | network news subsystem
Uucp | 8 | UUCP subsystem
Clock | 9 | clock (cron/at) daemon
Authorization2 | 10 | security/authorization messages (private)
Ftp | 11 | ftp daemon
Ntp | 12 | NTP subsystem
Audit | 13 | log audit
Alert | 14 | log alert
Clock2 | 15 | clock daemon
Local0 | 16 | reserved for local use
Local1 | 17 | reserved for local use
Local2 | 18 | reserved for local use
Local3 | 19 | reserved for local use
Local4 | 20 | reserved for local use
Local5 | 21 | reserved for local use
Local6 | 22 | reserved for local use
Local7 | 23 | reserved for local use
Remarks

            The syslog facilities

See Also
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteSyslogAppender.SyslogSeverity Enumeration

RemoteSyslogAppender SyslogSeverity Enumeration Apache log4net™ SDK Documentation
syslog severities

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum SyslogSeverity
public enum SyslogSeverity
Public Enumeration SyslogSeverity
Public Enumeration SyslogSeverity
public enum class SyslogSeverity
public enum class SyslogSeverity
Members
Member name | Value | Description
Emergency | 0 | system is unusable
Alert | 1 | action must be taken immediately
Critical | 2 | critical conditions
Error | 3 | error conditions
Warning | 4 | warning conditions
Notice | 5 | normal but significant condition
Informational | 6 | informational
Debug | 7 | debug-level messages
Remarks

            The syslog severities.

See Also
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender Class

RemotingAppender Class Apache log4net™ SDK Documentation
Delivers logging events to a remote logging sink.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender BufferingAppenderSkeleton
log4net.Appender RemotingAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RemotingAppender : BufferingAppenderSkeleton
public class RemotingAppender : BufferingAppenderSkeleton
Public Class RemotingAppender
    Inherits BufferingAppenderSkeleton
Public Class RemotingAppender
    Inherits BufferingAppenderSkeleton
public ref class RemotingAppender : public BufferingAppenderSkeleton
public ref class RemotingAppender : public BufferingAppenderSkeleton
Remarks

            This Appender is designed to deliver events to a remote sink.
            That is any object that implements the RemotingAppender IRemoteLoggingSink
            interface. It delivers the events using .NET remoting. The
            object to deliver events to is specified by setting the
            appenders Sink property.

            The RemotingAppender buffers events before sending them. This allows it to
            make more efficient use of the remoting infrastructure.

            Once the buffer is full the events are still not sent immediately.
            They are scheduled to be sent using a pool thread. The effect is that
            the send occurs asynchronously. This is very important for a
            number of non obvious reasons. The remoting infrastructure will
            flow thread local variables (stored in the   Online CallContext),
            if they are marked as   Online ILogicalThreadAffinative, across the
            remoting boundary. If the server is not contactable then
            the remoting infrastructure will clear the   Online ILogicalThreadAffinative
            objects from the   Online CallContext. To prevent a logging failure from
            having side effects on the calling application the remoting call must be made
            from a separate thread to the one used by the application. A   Online ThreadPool
            thread is used for this. If no   Online ThreadPool thread is available then
            the events will block in the thread pool manager until a thread is available.

            Because the events are sent asynchronously using pool threads it is possible to close
            this appender before all the queued events have been sent.
            When closing the appender attempts to wait until all the queued events have been sent, but
            this will timeout after 30 seconds regardless.

            If this appender is being closed because the   Online ProcessExit
            event has fired it may not be possible to send all the queued events. During process
            exit the runtime limits the time that a   Online ProcessExit
            event handler is allowed to run for. If the runtime terminates the threads before
            the queued events have been sent then they will be lost. To ensure that all events
            are sent the appender must be closed before the application exits. See
            Shutdown  for details on how to shutdown
            log4net programmatically.
See Also
RemotingAppender Members
log4net.Appender Namespace
log4net.Appender RemotingAppender IRemoteLoggingSink
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender Members

RemotingAppender Members Apache log4net™ SDK Documentation
The RemotingAppender type exposes the following members.
Constructors
 | Name | Description
Public method | RemotingAppender | Initializes a new instance of the RemotingAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Overrides BufferingAppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Inherited from BufferingAppenderSkeleton.)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Flush | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Flush(Boolean) | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Override base class close. (Overrides BufferingAppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | SendBuffer | Send the contents of the buffer to the remote sink. (Overrides BufferingAppenderSkeleton SendBuffer( LoggingEvent ).)
Protected method | SendFromBuffer | Sends the contents of the buffer. (Inherited from BufferingAppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | BufferSize | Gets or sets the size of the cyclic buffer used to hold the logging events. (Inherited from BufferingAppenderSkeleton.)
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Evaluator | Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately. (Inherited from BufferingAppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets a the fields that will be fixed in the event (Inherited from BufferingAppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Lossy | Gets or sets a value that indicates whether the appender is lossy. (Inherited from BufferingAppenderSkeleton.)
Public property | LossyEvaluator | Gets or sets the value of the ITriggeringEventEvaluator to use. (Inherited from BufferingAppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating if only part of the logging event data should be fixed. (Inherited from BufferingAppenderSkeleton.)
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set. (Inherited from AppenderSkeleton.)
Public property | Sink | Gets or sets the URL of the well-known object that will accept the logging events.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
RemotingAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender Constructor

RemotingAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the RemotingAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RemotingAppender()
public RemotingAppender()
Public Sub New
Public Sub New
public:
RemotingAppender()
public:
RemotingAppender()
Remarks

            Default constructor.

See Also
RemotingAppender Class
RemotingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender Methods

RemotingAppender Methods Apache log4net™ SDK Documentation
The RemotingAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Overrides BufferingAppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Inherited from BufferingAppenderSkeleton.)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Flush | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Flush(Boolean) | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Override base class close. (Overrides BufferingAppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | SendBuffer | Send the contents of the buffer to the remote sink. (Overrides BufferingAppenderSkeleton SendBuffer( LoggingEvent ).)
Protected method | SendFromBuffer | Sends the contents of the buffer. (Inherited from BufferingAppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RemotingAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender.ActivateOptions Method

RemotingAppender ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the appender based on the options set

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
RemotingAppender Class
RemotingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender.OnClose Method

RemotingAppender OnClose Method Apache log4net™ SDK Documentation
Override base class close.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void OnClose()
protected override void OnClose()
Protected Overrides Sub OnClose
Protected Overrides Sub OnClose
protected:
virtual void OnClose() override
protected:
virtual void OnClose() override
Remarks

            This method waits while there are queued work items. The events are
            sent asynchronously using   Online ThreadPool work items. These items
            will be sent once a thread pool thread is available to send them, therefore
            it is possible to close the appender before all the queued events have been
            sent.

            This method attempts to wait until all the queued events have been sent, but this
            method will timeout after 30 seconds regardless.

            If the appender is being closed because the   Online ProcessExit
            event has fired it may not be possible to send all the queued events. During process
            exit the runtime limits the time that a   Online ProcessExit
            event handler is allowed to run for.
See Also
RemotingAppender Class
RemotingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender.SendBuffer Method

RemotingAppender SendBuffer Method Apache log4net™ SDK Documentation
Send the contents of the buffer to the remote sink.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void SendBuffer(
    LoggingEvent[] events
)
protected override void SendBuffer(
    LoggingEvent[] events
)
Protected Overrides Sub SendBuffer (
    events As LoggingEvent()
)
Protected Overrides Sub SendBuffer (
    events As LoggingEvent()
)
protected:
virtual void SendBuffer(
    array<LoggingEvent^>^ events
) override
protected:
virtual void SendBuffer(
    array<LoggingEvent^>^ events
) override
Parameters
events
Type:  log4net.Core LoggingEvent
The events to send.
Remarks

            The events are not sent immediately. They are scheduled to be sent
            using a pool thread. The effect is that the send occurs asynchronously.
            This is very important for a number of non obvious reasons. The remoting
            infrastructure will flow thread local variables (stored in the   Online CallContext),
            if they are marked as   Online ILogicalThreadAffinative, across the
            remoting boundary. If the server is not contactable then
            the remoting infrastructure will clear the   Online ILogicalThreadAffinative
            objects from the   Online CallContext. To prevent a logging failure from
            having side effects on the calling application the remoting call must be made
            from a separate thread to the one used by the application. A   Online ThreadPool
            thread is used for this. If no   Online ThreadPool thread is available then
            the events will block in the thread pool manager until a thread is available.

See Also
RemotingAppender Class
RemotingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender Properties

RemotingAppender Properties Apache log4net™ SDK Documentation
The RemotingAppender type exposes the following members.
Properties
 | Name | Description
Public property | BufferSize | Gets or sets the size of the cyclic buffer used to hold the logging events. (Inherited from BufferingAppenderSkeleton.)
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Evaluator | Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately. (Inherited from BufferingAppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets a the fields that will be fixed in the event (Inherited from BufferingAppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Lossy | Gets or sets a value that indicates whether the appender is lossy. (Inherited from BufferingAppenderSkeleton.)
Public property | LossyEvaluator | Gets or sets the value of the ITriggeringEventEvaluator to use. (Inherited from BufferingAppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating if only part of the logging event data should be fixed. (Inherited from BufferingAppenderSkeleton.)
Protected property | RequiresLayout | Tests if this appender requires a Layout to be set. (Inherited from AppenderSkeleton.)
Public property | Sink | Gets or sets the URL of the well-known object that will accept the logging events.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
RemotingAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender.Sink Property

RemotingAppender Sink Property Apache log4net™ SDK Documentation
Gets or sets the URL of the well-known object that will accept the logging events.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Sink { get; set; }
public string Sink { get; set; }
Public Property Sink As String
    Get
    Set
Public Property Sink As String
    Get
    Set
public:
property String^ Sink {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Sink {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The well-known URL of the remote sink.

Remarks

            The URL of the remoting sink that will accept logging events.
            The sink must implement the RemotingAppender IRemoteLoggingSink
            interface.

See Also
RemotingAppender Class
RemotingAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender.IRemoteLoggingSink Interface

RemotingAppender IRemoteLoggingSink Interface Apache log4net™ SDK Documentation
Interface used to deliver LoggingEvent objects to a remote sink.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IRemoteLoggingSink
public interface IRemoteLoggingSink
Public Interface IRemoteLoggingSink
Public Interface IRemoteLoggingSink
public interface class IRemoteLoggingSink
public interface class IRemoteLoggingSink
Remarks

            This interface must be implemented by a remoting sink
            if the RemotingAppender is to be used
            to deliver logging events to the sink.

See Also
RemotingAppender IRemoteLoggingSink Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender.IRemoteLoggingSink Members

RemotingAppender IRemoteLoggingSink Members Apache log4net™ SDK Documentation
The RemotingAppender IRemoteLoggingSink type exposes the following members.
Methods
 | Name | Description
Public method | LogEvents | Delivers logging events to the remote sink
Back to Top
See Also
RemotingAppender IRemoteLoggingSink Interface
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender.IRemoteLoggingSink Methods

RemotingAppender IRemoteLoggingSink Methods Apache log4net™ SDK Documentation
The RemotingAppender IRemoteLoggingSink type exposes the following members.
Methods
 | Name | Description
Public method | LogEvents | Delivers logging events to the remote sink
Back to Top
See Also
RemotingAppender IRemoteLoggingSink Interface
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemotingAppender.IRemoteLoggingSink.LogEvents Method

RemotingAppender IRemoteLoggingSink LogEvents Method Apache log4net™ SDK Documentation
Delivers logging events to the remote sink

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void LogEvents(
    LoggingEvent[] events
)
void LogEvents(
    LoggingEvent[] events
)
Sub LogEvents (
    events As LoggingEvent()
)
Sub LogEvents (
    events As LoggingEvent()
)
void LogEvents(
    array<LoggingEvent^>^ events
)
void LogEvents(
    array<LoggingEvent^>^ events
)
Parameters
events
Type:  log4net.Core LoggingEvent
Array of events to log.
Remarks

            Delivers logging events to the remote sink

See Also
RemotingAppender IRemoteLoggingSink Interface
RemotingAppender IRemoteLoggingSink Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender Class

RollingFileAppender Class Apache log4net™ SDK Documentation
Appender that rolls log files based on size or date or both.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender TextWriterAppender
log4net.Appender FileAppender
log4net.Appender RollingFileAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RollingFileAppender : FileAppender
public class RollingFileAppender : FileAppender
Public Class RollingFileAppender
    Inherits FileAppender
Public Class RollingFileAppender
    Inherits FileAppender
public ref class RollingFileAppender : public FileAppender
public ref class RollingFileAppender : public FileAppender
Remarks

            RollingFileAppender can roll log files based on size or date or both
            depending on the setting of the RollingStyle property.
            When set to Size the log file will be rolled
            once its size exceeds the MaximumFileSize.
            When set to Date the log file will be rolled
            once the date boundary specified in the DatePattern property
            is crossed.
            When set to Composite the log file will be
            rolled once the date boundary specified in the DatePattern property
            is crossed, but within a date boundary the file will also be rolled
            once its size exceeds the MaximumFileSize.
            When set to Once the log file will be rolled when
            the appender is configured. This effectively means that the log file can be
            rolled once per program execution.

            A of few additional optional features have been added:

  • Attach date pattern for current log file StaticLogFileName
  • Backup number increments for newer files CountDirection
  • Infinite number of backups by file size MaxSizeRollBackups
  Note  Note

            For large or infinite numbers of backup files a CountDirection
            greater than zero is highly recommended, otherwise all the backup files need
            to be renamed each time a new backup is created.

            When Date/Time based rolling is used setting StaticLogFileName
            to   will reduce the number of file renamings to few or none.

  Caution note  Caution

            Changing StaticLogFileName or CountDirection without clearing
            the log file directory of backup files will cause unexpected and unwanted side effects.

            If Date/Time based rolling is enabled this appender will attempt to roll existing files
            in the directory without a Date/Time tag based on the last write date of the base log file.
            The appender only rolls the log file when a message is logged. If Date/Time based rolling
            is enabled then the appender will not roll the log file at the Date/Time boundary but
            at the point when the next message is logged after the boundary has been crossed.

            The RollingFileAppender extends the FileAppender and
            has the same behavior when opening the log file.
            The appender will first try to open the file for writing when ActivateOptions
            is called. This will typically be during configuration.
            If the file cannot be opened for writing the appender will attempt
            to open the file again each time a message is logged to the appender.
            If the file cannot be opened for writing when a message is logged then
            the message will be discarded by this appender.

            When rolling a backup file necessitates deleting an older backup file the
            file to be deleted is moved to a temporary name before being deleted.

  Caution note  Caution

            A maximum number of backup files when rolling on date/time boundaries is not supported.

See Also
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender Members

RollingFileAppender Members Apache log4net™ SDK Documentation
The RollingFileAppender type exposes the following members.
Constructors
 | Name | Description
Public method | RollingFileAppender | Initializes a new instance of the RollingFileAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Overrides FileAppender ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | AdjustFileBeforeAppend | Performs any required rolling before outputting the next event
Protected method | Append(LoggingEvent) | Write out a logging event. (Overrides FileAppender Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | Write out an array of logging events. (Overrides FileAppender Append( LoggingEvent ).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Protected method | CloseFile | Closes the previously opened file. (Inherited from FileAppender.)
Protected method | CloseWriter | Closes the underlying Online TextWriter. (Inherited from FileAppender.)
Protected method | DeleteFile | Deletes the specified file if it exists.
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | ExistingInit | Initializes based on existing conditions at time of ActivateOptions .
Protected method | FileExists | Test if a file exists at a specified path
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Cleans up all resources used by this appender. (Overrides AppenderSkeleton Finalize .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetNextOutputFileName | Get the current output file name
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | NextCheckDate | Get the start time of the next window for the current rollpoint
Protected method | OnClose | Close this appender instance. The underlying stream or writer is also closed. (Inherited from TextWriterAppender.)
Protected method | OpenFile | Creates and opens the file for logging. If StaticLogFileName is false then the fully qualified name is determined and used. (Overrides FileAppender OpenFile(String, Boolean).)
Protected method | PreAppendCheck | This method determines if there is a sense in attempting to append. (Inherited from TextWriterAppender.)
Protected method | PrepareWriter | Called to initialize the file writer (Inherited from FileAppender.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | Reset | Closes any previously opened file and calls the parent's Reset . (Inherited from FileAppender.)
Protected method | RollFile | Renames file fromFile to file toFile.
Protected method | RollOverRenameFiles | Implements file roll.
Protected method | RollOverSize | Implements file roll base on file size.
Protected method | RollOverTime | Rollover the file(s) to date/time tagged file(s).
Protected method | SafeOpenFile | Sets and opens the file where the log output will go. The specified file must be writable. (Inherited from FileAppender.)
Protected method | SetQWForFiles(Stream) | Sets the quiet writer used for file output (Inherited from FileAppender.)
Protected method | SetQWForFiles(TextWriter) | Sets the quiet writer being used. (Overrides FileAppender SetQWForFiles(TextWriter).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Protected method | WriteFooter | Writes a footer as produced by the embedded layout's Footer property. (Inherited from FileAppender.)
Protected method | WriteFooterAndCloseWriter | Writes the footer and closes the underlying Online TextWriter. (Inherited from TextWriterAppender.)
Protected method | WriteHeader | Writes a header produced by the embedded layout's Header property. (Inherited from FileAppender.)
Back to Top
Properties
 | Name | Description
Public property | AppendToFile | Gets or sets a flag that indicates whether the file should be appended to or overwritten. (Inherited from FileAppender.)
Public property | CountDirection | Gets or sets the rolling file count direction.
Public property | DatePattern | Gets or sets the date pattern to be used for generating file names when rolling over on date.
Public property | DateTimeStrategy | Gets or sets the strategy for determining the current date and time. The default implementation is to use LocalDateTime which internally calls through to DateTime.Now. DateTime.UtcNow may be used on frameworks newer than .NET 1.0 by specifying UniversalDateTime.
Public property | Encoding | Gets or sets Encoding used to write to the file. (Inherited from FileAppender.)
Public property | ErrorHandler | Gets or set the IErrorHandler and the underlying QuietTextWriter, if any, for this appender. (Inherited from TextWriterAppender.)
Public property | File | Gets or sets the path to the file that logging will be written to. (Inherited from FileAppender.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | ImmediateFlush | Gets or set whether the appender will flush at the end of each append operation. (Inherited from TextWriterAppender.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | LockingModel | Gets or sets the LockingModel used to handle locking of the file. (Inherited from FileAppender.)
Public property | MaxFileSize | Gets or sets the maximum size that the output file is allowed to reach before being rolled over to backup files.
Public property | MaximumFileSize | Gets or sets the maximum size that the output file is allowed to reach before being rolled over to backup files.
Public property | MaxSizeRollBackups | Gets or sets the maximum number of backup files that are kept before the oldest is erased.
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | PreserveLogFileNameExtension | Gets or sets a value indicating whether to preserve the file name extension when rolling.
Protected property | QuietWriter | Gets or sets the QuietTextWriter where logging events will be written to. (Inherited from TextWriterAppender.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Inherited from TextWriterAppender.)
Public property | RollingStyle | Gets or sets the rolling style.
Public property | SecurityContext | Gets or sets the SecurityContext used to write to the file. (Inherited from FileAppender.)
Public property | StaticLogFileName | Gets or sets a value indicating whether to always log to the same file.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Public property | Writer | Sets the Online TextWriter where the log output will go. (Inherited from TextWriterAppender.)
Back to Top
See Also
RollingFileAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender Constructor

RollingFileAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the RollingFileAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RollingFileAppender()
public RollingFileAppender()
Public Sub New
Public Sub New
public:
RollingFileAppender()
public:
RollingFileAppender()
Remarks

            Default constructor.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender Methods

RollingFileAppender Methods Apache log4net™ SDK Documentation
The RollingFileAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Overrides FileAppender ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | AdjustFileBeforeAppend | Performs any required rolling before outputting the next event
Protected method | Append(LoggingEvent) | Write out a logging event. (Overrides FileAppender Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | Write out an array of logging events. (Overrides FileAppender Append( LoggingEvent ).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Protected method | CloseFile | Closes the previously opened file. (Inherited from FileAppender.)
Protected method | CloseWriter | Closes the underlying Online TextWriter. (Inherited from FileAppender.)
Protected method | DeleteFile | Deletes the specified file if it exists.
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | ExistingInit | Initializes based on existing conditions at time of ActivateOptions .
Protected method | FileExists | Test if a file exists at a specified path
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Cleans up all resources used by this appender. (Overrides AppenderSkeleton Finalize .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetNextOutputFileName | Get the current output file name
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | NextCheckDate | Get the start time of the next window for the current rollpoint
Protected method | OnClose | Close this appender instance. The underlying stream or writer is also closed. (Inherited from TextWriterAppender.)
Protected method | OpenFile | Creates and opens the file for logging. If StaticLogFileName is false then the fully qualified name is determined and used. (Overrides FileAppender OpenFile(String, Boolean).)
Protected method | PreAppendCheck | This method determines if there is a sense in attempting to append. (Inherited from TextWriterAppender.)
Protected method | PrepareWriter | Called to initialize the file writer (Inherited from FileAppender.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | Reset | Closes any previously opened file and calls the parent's Reset . (Inherited from FileAppender.)
Protected method | RollFile | Renames file fromFile to file toFile.
Protected method | RollOverRenameFiles | Implements file roll.
Protected method | RollOverSize | Implements file roll base on file size.
Protected method | RollOverTime | Rollover the file(s) to date/time tagged file(s).
Protected method | SafeOpenFile | Sets and opens the file where the log output will go. The specified file must be writable. (Inherited from FileAppender.)
Protected method | SetQWForFiles(Stream) | Sets the quiet writer used for file output (Inherited from FileAppender.)
Protected method | SetQWForFiles(TextWriter) | Sets the quiet writer being used. (Overrides FileAppender SetQWForFiles(TextWriter).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Protected method | WriteFooter | Writes a footer as produced by the embedded layout's Footer property. (Inherited from FileAppender.)
Protected method | WriteFooterAndCloseWriter | Writes the footer and closes the underlying Online TextWriter. (Inherited from TextWriterAppender.)
Protected method | WriteHeader | Writes a header produced by the embedded layout's Header property. (Inherited from FileAppender.)
Back to Top
See Also
RollingFileAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.ActivateOptions Method

RollingFileAppender ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the appender based on the options set

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

            Sets initial conditions including date/time roll over information, first check,
            scheduledFilename, and calls ExistingInit  to initialize
            the current number of backups.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.AdjustFileBeforeAppend Method

RollingFileAppender AdjustFileBeforeAppend Method Apache log4net™ SDK Documentation
Performs any required rolling before outputting the next event

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void AdjustFileBeforeAppend()
protected virtual void AdjustFileBeforeAppend()
Protected Overridable Sub AdjustFileBeforeAppend
Protected Overridable Sub AdjustFileBeforeAppend
protected:
virtual void AdjustFileBeforeAppend()
protected:
virtual void AdjustFileBeforeAppend()
Remarks

            Handles append time behavior for RollingFileAppender.  This checks
            if a roll over either by date (checked first) or time (checked second)
            is need and then appends to the file last.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.Append Method

RollingFileAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append(LoggingEvent) | Write out a logging event. (Overrides FileAppender Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | Write out an array of logging events. (Overrides FileAppender Append( LoggingEvent ).)
Back to Top
See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.Append Method (LoggingEvent)

RollingFileAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
Write out a logging event.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the event to write to file.
Remarks

            Handles append time behavior for RollingFileAppender.  This checks
            if a roll over either by date (checked first) or time (checked second)
            is need and then appends to the file last.

See Also
RollingFileAppender Class
RollingFileAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.Append Method (LoggingEvent[])

RollingFileAppender Append Method ( LoggingEvent ) Apache log4net™ SDK Documentation
Write out an array of logging events.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent[] loggingEvents
)
protected override void Append(
    LoggingEvent[] loggingEvents
)
Protected Overrides Sub Append (
    loggingEvents As LoggingEvent()
)
Protected Overrides Sub Append (
    loggingEvents As LoggingEvent()
)
protected:
virtual void Append(
    array<LoggingEvent^>^ loggingEvents
) override
protected:
virtual void Append(
    array<LoggingEvent^>^ loggingEvents
) override
Parameters
loggingEvents
Type:  log4net.Core LoggingEvent
the events to write to file.
Remarks

            Handles append time behavior for RollingFileAppender.  This checks
            if a roll over either by date (checked first) or time (checked second)
            is need and then appends to the file last.

See Also
RollingFileAppender Class
RollingFileAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.DeleteFile Method

RollingFileAppender DeleteFile Method Apache log4net™ SDK Documentation
Deletes the specified file if it exists.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void DeleteFile(
    string fileName
)
protected void DeleteFile(
    string fileName
)
Protected Sub DeleteFile (
    fileName As String
)
Protected Sub DeleteFile (
    fileName As String
)
protected:
void DeleteFile(
    String^ fileName
)
protected:
void DeleteFile(
    String^ fileName
)
Parameters
fileName
Type:   Online System String
The file to delete.
Remarks

            Delete a file if is exists.
            The file is first moved to a new filename then deleted.
            This allows the file to be removed even when it cannot
            be deleted, but it still can be moved.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.ExistingInit Method

RollingFileAppender ExistingInit Method Apache log4net™ SDK Documentation
Initializes based on existing conditions at time of ActivateOptions .

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void ExistingInit()
protected void ExistingInit()
Protected Sub ExistingInit
Protected Sub ExistingInit
protected:
void ExistingInit()
protected:
void ExistingInit()
Remarks

            Initializes based on existing conditions at time of ActivateOptions .
            The following is done

  • determine curSizeRollBackups (only within the current roll point)
  • initiates a roll over if needed for crossing a date boundary since the last run.
See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.FileExists Method

RollingFileAppender FileExists Method Apache log4net™ SDK Documentation
Test if a file exists at a specified path

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool FileExists(
    string path
)
protected bool FileExists(
    string path
)
Protected Function FileExists (
    path As String
) As Boolean
Protected Function FileExists (
    path As String
) As Boolean
protected:
bool FileExists(
    String^ path
)
protected:
bool FileExists(
    String^ path
)
Parameters
path
Type:   Online System String
the path to the file
Return Value
Type:   Online Boolean
true if the file exists
Remarks

            Test if a file exists at a specified path

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.Finalize Method

RollingFileAppender Finalize Method Apache log4net™ SDK Documentation
Cleans up all resources used by this appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Finalize()
protected override void Finalize()
Protected Overrides Sub Finalize
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
protected:
virtual void Finalize() override
See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.GetNextOutputFileName Method

RollingFileAppender GetNextOutputFileName Method Apache log4net™ SDK Documentation
Get the current output file name

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string GetNextOutputFileName(
    string fileName
)
protected string GetNextOutputFileName(
    string fileName
)
Protected Function GetNextOutputFileName (
    fileName As String
) As String
Protected Function GetNextOutputFileName (
    fileName As String
) As String
protected:
String^ GetNextOutputFileName(
    String^ fileName
)
protected:
String^ GetNextOutputFileName(
    String^ fileName
)
Parameters
fileName
Type:   Online System String
the base file name
Return Value
Type:   Online String
the output file name
Remarks

            The output file name is based on the base fileName specified.
            If StaticLogFileName is set then the output
            file name is the same as the base file passed in. Otherwise
            the output file depends on the date pattern, on the count
            direction or both.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.NextCheckDate Method

RollingFileAppender NextCheckDate Method Apache log4net™ SDK Documentation
Get the start time of the next window for the current rollpoint

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DateTime NextCheckDate(
    DateTime currentDateTime,
    RollingFileAppender..::..RollPoint rollPoint
)
protected DateTime NextCheckDate(
    DateTime currentDateTime,
    RollingFileAppender..::..RollPoint rollPoint
)
Protected Function NextCheckDate (
    currentDateTime As DateTime,
    rollPoint As RollingFileAppender..::..RollPoint
) As DateTime
Protected Function NextCheckDate (
    currentDateTime As DateTime,
    rollPoint As RollingFileAppender..::..RollPoint
) As DateTime
protected:
DateTime NextCheckDate(
    DateTime currentDateTime,
    RollingFileAppender..::..RollPoint rollPoint
)
protected:
DateTime NextCheckDate(
    DateTime currentDateTime,
    RollingFileAppender..::..RollPoint rollPoint
)
Parameters
currentDateTime
Type:   Online System DateTime
the current date
rollPoint
Type: log4net.Appender RollingFileAppender RollPoint
the type of roll point we are working with
Return Value
Type:   Online DateTime
the start time for the next roll point an interval after the currentDateTime date
Remarks

            Returns the date of the next roll point after the currentDateTime date passed to the method.

            The basic strategy is to subtract the time parts that are less significant
            than the rollpoint from the current time. This should roll the time back to
            the start of the time window for the current rollpoint. Then we add 1 window
            worth of time and get the start time of the next window for the rollpoint.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.OpenFile Method

RollingFileAppender OpenFile Method Apache log4net™ SDK Documentation
Creates and opens the file for logging. If StaticLogFileName is false then the fully qualified name is determined and used.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void OpenFile(
    string fileName,
    bool append
)
protected override void OpenFile(
    string fileName,
    bool append
)
Protected Overrides Sub OpenFile (
    fileName As String,
    append As Boolean
)
Protected Overrides Sub OpenFile (
    fileName As String,
    append As Boolean
)
protected:
virtual void OpenFile(
    String^ fileName,
    bool append
) override
protected:
virtual void OpenFile(
    String^ fileName,
    bool append
) override
Parameters
fileName
Type:   Online System String
the name of the file to open
append
Type:   Online System Boolean
true to append to existing file
Remarks
This method will ensure that the directory structure
            for the fileName specified exists.
See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.RollFile Method

RollingFileAppender RollFile Method Apache log4net™ SDK Documentation
Renames file fromFile to file toFile.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void RollFile(
    string fromFile,
    string toFile
)
protected void RollFile(
    string fromFile,
    string toFile
)
Protected Sub RollFile (
    fromFile As String,
    toFile As String
)
Protected Sub RollFile (
    fromFile As String,
    toFile As String
)
protected:
void RollFile(
    String^ fromFile,
    String^ toFile
)
protected:
void RollFile(
    String^ fromFile,
    String^ toFile
)
Parameters
fromFile
Type:   Online System String
Name of existing file to roll.
toFile
Type:   Online System String
New name for file.
Remarks

            Renames file fromFile to file toFile. It
            also checks for existence of target file and deletes if it does.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.RollOverRenameFiles Method

RollingFileAppender RollOverRenameFiles Method Apache log4net™ SDK Documentation
Implements file roll.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void RollOverRenameFiles(
    string baseFileName
)
protected void RollOverRenameFiles(
    string baseFileName
)
Protected Sub RollOverRenameFiles (
    baseFileName As String
)
Protected Sub RollOverRenameFiles (
    baseFileName As String
)
protected:
void RollOverRenameFiles(
    String^ baseFileName
)
protected:
void RollOverRenameFiles(
    String^ baseFileName
)
Parameters
baseFileName
Type:   Online System String
the base name to rename
Remarks

            If the maximum number of size based backups is reached
            (curSizeRollBackups == maxSizeRollBackups) then the oldest
            file is deleted -- its index determined by the sign of countDirection.
            If countDirection < 0, then files
            {File.1, ..., File.curSizeRollBackups -1}
            are renamed to {File.2, ...,
            File.curSizeRollBackups}.

            If maxSizeRollBackups is equal to zero, then the
            File is truncated with no backup files created.

            If maxSizeRollBackups < 0, then File is
            renamed if needed and no files are deleted.

            This is called by RollOverSize  to rename the files.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.RollOverSize Method

RollingFileAppender RollOverSize Method Apache log4net™ SDK Documentation
Implements file roll base on file size.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void RollOverSize()
protected void RollOverSize()
Protected Sub RollOverSize
Protected Sub RollOverSize
protected:
void RollOverSize()
protected:
void RollOverSize()
Remarks

            If the maximum number of size based backups is reached
            (curSizeRollBackups == maxSizeRollBackups) then the oldest
            file is deleted -- its index determined by the sign of countDirection.
            If countDirection < 0, then files
            {File.1, ..., File.curSizeRollBackups -1}
            are renamed to {File.2, ...,
            File.curSizeRollBackups}. Moreover, File is
            renamed File.1 and closed.

            A new file is created to receive further log output.

            If maxSizeRollBackups is equal to zero, then the
            File is truncated with no backup files created.

            If maxSizeRollBackups < 0, then File is
            renamed if needed and no files are deleted.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.RollOverTime Method

RollingFileAppender RollOverTime Method Apache log4net™ SDK Documentation
Rollover the file(s) to date/time tagged file(s).

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void RollOverTime(
    bool fileIsOpen
)
protected void RollOverTime(
    bool fileIsOpen
)
Protected Sub RollOverTime (
    fileIsOpen As Boolean
)
Protected Sub RollOverTime (
    fileIsOpen As Boolean
)
protected:
void RollOverTime(
    bool fileIsOpen
)
protected:
void RollOverTime(
    bool fileIsOpen
)
Parameters
fileIsOpen
Type:   Online System Boolean
set to true if the file to be rolled is currently open
Remarks

            Rollover the file(s) to date/time tagged file(s).
            Resets curSizeRollBackups.
            If fileIsOpen is set then the new file is opened (through SafeOpenFile).

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.SetQWForFiles Method

RollingFileAppender SetQWForFiles Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | SetQWForFiles(Stream) | Sets the quiet writer used for file output (Inherited from FileAppender.)
Protected method | SetQWForFiles(TextWriter) | Sets the quiet writer being used. (Overrides FileAppender SetQWForFiles(TextWriter).)
Back to Top
See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.SetQWForFiles Method (TextWriter)

RollingFileAppender SetQWForFiles Method (TextWriter) Apache log4net™ SDK Documentation
Sets the quiet writer being used.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void SetQWForFiles(
    TextWriter writer
)
protected override void SetQWForFiles(
    TextWriter writer
)
Protected Overrides Sub SetQWForFiles (
    writer As TextWriter
)
Protected Overrides Sub SetQWForFiles (
    writer As TextWriter
)
protected:
virtual void SetQWForFiles(
    TextWriter^ writer
) override
protected:
virtual void SetQWForFiles(
    TextWriter^ writer
) override
Parameters
writer
Type:   Online System.IO TextWriter
the writer to set
Remarks

            This method can be overridden by sub classes.

See Also
RollingFileAppender Class
RollingFileAppender Members
SetQWForFiles Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender Properties

RollingFileAppender Properties Apache log4net™ SDK Documentation
The RollingFileAppender type exposes the following members.
Properties
 | Name | Description
Public property | AppendToFile | Gets or sets a flag that indicates whether the file should be appended to or overwritten. (Inherited from FileAppender.)
Public property | CountDirection | Gets or sets the rolling file count direction.
Public property | DatePattern | Gets or sets the date pattern to be used for generating file names when rolling over on date.
Public property | DateTimeStrategy | Gets or sets the strategy for determining the current date and time. The default implementation is to use LocalDateTime which internally calls through to DateTime.Now. DateTime.UtcNow may be used on frameworks newer than .NET 1.0 by specifying UniversalDateTime.
Public property | Encoding | Gets or sets Encoding used to write to the file. (Inherited from FileAppender.)
Public property | ErrorHandler | Gets or set the IErrorHandler and the underlying QuietTextWriter, if any, for this appender. (Inherited from TextWriterAppender.)
Public property | File | Gets or sets the path to the file that logging will be written to. (Inherited from FileAppender.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | ImmediateFlush | Gets or set whether the appender will flush at the end of each append operation. (Inherited from TextWriterAppender.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | LockingModel | Gets or sets the LockingModel used to handle locking of the file. (Inherited from FileAppender.)
Public property | MaxFileSize | Gets or sets the maximum size that the output file is allowed to reach before being rolled over to backup files.
Public property | MaximumFileSize | Gets or sets the maximum size that the output file is allowed to reach before being rolled over to backup files.
Public property | MaxSizeRollBackups | Gets or sets the maximum number of backup files that are kept before the oldest is erased.
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | PreserveLogFileNameExtension | Gets or sets a value indicating whether to preserve the file name extension when rolling.
Protected property | QuietWriter | Gets or sets the QuietTextWriter where logging events will be written to. (Inherited from TextWriterAppender.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Inherited from TextWriterAppender.)
Public property | RollingStyle | Gets or sets the rolling style.
Public property | SecurityContext | Gets or sets the SecurityContext used to write to the file. (Inherited from FileAppender.)
Public property | StaticLogFileName | Gets or sets a value indicating whether to always log to the same file.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Public property | Writer | Sets the Online TextWriter where the log output will go. (Inherited from TextWriterAppender.)
Back to Top
See Also
RollingFileAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.CountDirection Property

RollingFileAppender CountDirection Property Apache log4net™ SDK Documentation
Gets or sets the rolling file count direction.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CountDirection { get; set; }
public int CountDirection { get; set; }
Public Property CountDirection As Integer
    Get
    Set
Public Property CountDirection As Integer
    Get
    Set
public:
property int CountDirection {
    int get ();
    void set (int value);
}
public:
property int CountDirection {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32

            The rolling file count direction.

Remarks

            Indicates if the current file is the lowest numbered file or the
            highest numbered file.

            By default newer files have lower numbers (CountDirection < 0),
            i.e. log.1 is most recent, log.5 is the 5th backup, etc...

CountDirection >= 0 does the opposite i.e.
            log.1 is the first backup made, log.5 is the 5th backup made, etc.
            For infinite backups use CountDirection >= 0 to reduce
            rollover costs.

The default file count direction is -1.
See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.DatePattern Property

RollingFileAppender DatePattern Property Apache log4net™ SDK Documentation
Gets or sets the date pattern to be used for generating file names when rolling over on date.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DatePattern { get; set; }
public string DatePattern { get; set; }
Public Property DatePattern As String
    Get
    Set
Public Property DatePattern As String
    Get
    Set
public:
property String^ DatePattern {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DatePattern {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The date pattern to be used for generating file names when rolling
            over on date.

Remarks

            Takes a string in the same format as expected by
            SimpleDateFormatter.

            This property determines the rollover schedule when rolling over
            on date.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.DateTimeStrategy Property

RollingFileAppender DateTimeStrategy Property Apache log4net™ SDK Documentation
Gets or sets the strategy for determining the current date and time. The default implementation is to use LocalDateTime which internally calls through to DateTime.Now. DateTime.UtcNow may be used on frameworks newer than .NET 1.0 by specifying UniversalDateTime.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RollingFileAppender..::..IDateTime DateTimeStrategy { get; set; }
public RollingFileAppender..::..IDateTime DateTimeStrategy { get; set; }
Public Property DateTimeStrategy As RollingFileAppender..::..IDateTime
    Get
    Set
Public Property DateTimeStrategy As RollingFileAppender..::..IDateTime
    Get
    Set
public:
property RollingFileAppender..::..IDateTime^ DateTimeStrategy {
    RollingFileAppender..::..IDateTime^ get ();
    void set (RollingFileAppender..::..IDateTime^ value);
}
public:
property RollingFileAppender..::..IDateTime^ DateTimeStrategy {
    RollingFileAppender..::..IDateTime^ get ();
    void set (RollingFileAppender..::..IDateTime^ value);
}
Property Value
Type: RollingFileAppender IDateTime

            An implementation of the RollingFileAppender IDateTime interface which returns the current date and time.

Remarks

            Gets or sets the RollingFileAppender IDateTime used to return the current date and time.

            There are two built strategies for determining the current date and time,
            LocalDateTime
            and UniversalDateTime.

            The default strategy is LocalDateTime.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.MaxFileSize Property

RollingFileAppender MaxFileSize Property Apache log4net™ SDK Documentation
Gets or sets the maximum size that the output file is allowed to reach before being rolled over to backup files.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long MaxFileSize { get; set; }
public long MaxFileSize { get; set; }
Public Property MaxFileSize As Long
    Get
    Set
Public Property MaxFileSize As Long
    Get
    Set
public:
property long long MaxFileSize {
    long long get ();
    void set (long long value);
}
public:
property long long MaxFileSize {
    long long get ();
    void set (long long value);
}
Property Value
Type:   Online Int64

            The maximum size in bytes that the output file is allowed to reach before being
            rolled over to backup files.

Remarks

            This property is equivalent to MaximumFileSize except
            that it is required for differentiating the setter taking a
              Online Int64 argument from the setter taking a   Online String
            argument.

            The default maximum file size is 10MB (10*1024*1024).

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.MaximumFileSize Property

RollingFileAppender MaximumFileSize Property Apache log4net™ SDK Documentation
Gets or sets the maximum size that the output file is allowed to reach before being rolled over to backup files.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MaximumFileSize { get; set; }
public string MaximumFileSize { get; set; }
Public Property MaximumFileSize As String
    Get
    Set
Public Property MaximumFileSize As String
    Get
    Set
public:
property String^ MaximumFileSize {
    String^ get ();
    void set (String^ value);
}
public:
property String^ MaximumFileSize {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The maximum size that the output file is allowed to reach before being
            rolled over to backup files.

Remarks

            This property allows you to specify the maximum size with the
            suffixes "KB", "MB" or "GB" so that the size is interpreted being
            expressed respectively in kilobytes, megabytes or gigabytes.

            For example, the value "10KB" will be interpreted as 10240 bytes.

            The default maximum file size is 10MB.

            If you have the option to set the maximum file size programmatically
            consider using the MaxFileSize property instead as this
            allows you to set the size in bytes as a   Online Int64.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.MaxSizeRollBackups Property

RollingFileAppender MaxSizeRollBackups Property Apache log4net™ SDK Documentation
Gets or sets the maximum number of backup files that are kept before the oldest is erased.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxSizeRollBackups { get; set; }
public int MaxSizeRollBackups { get; set; }
Public Property MaxSizeRollBackups As Integer
    Get
    Set
Public Property MaxSizeRollBackups As Integer
    Get
    Set
public:
property int MaxSizeRollBackups {
    int get ();
    void set (int value);
}
public:
property int MaxSizeRollBackups {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32

            The maximum number of backup files that are kept before the oldest is
            erased.

Remarks

            If set to zero, then there will be no backup files and the log file
            will be truncated when it reaches MaxFileSize.

            If a negative number is supplied then no deletions will be made.  Note
            that this could result in very slow performance as a large number of
            files are rolled over unless CountDirection is used.

            The maximum applies to each time based group of files and
            not the total.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.PreserveLogFileNameExtension Property

RollingFileAppender PreserveLogFileNameExtension Property Apache log4net™ SDK Documentation
Gets or sets a value indicating whether to preserve the file name extension when rolling.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool PreserveLogFileNameExtension { get; set; }
public bool PreserveLogFileNameExtension { get; set; }
Public Property PreserveLogFileNameExtension As Boolean
    Get
    Set
Public Property PreserveLogFileNameExtension As Boolean
    Get
    Set
public:
property bool PreserveLogFileNameExtension {
    bool get ();
    void set (bool value);
}
public:
property bool PreserveLogFileNameExtension {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if the file name extension should be preserved.

Remarks

            By default file.log is rolled to file.log.yyyy-MM-dd or file.log.curSizeRollBackup.
            However, under Windows the new file name will loose any program associations as the
            extension is changed. Optionally file.log can be renamed to file.yyyy-MM-dd.log or
            file.curSizeRollBackup.log to maintain any program associations.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.RollingStyle Property

RollingFileAppender RollingStyle Property Apache log4net™ SDK Documentation
Gets or sets the rolling style.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RollingFileAppender..::..RollingMode RollingStyle { get; set; }
public RollingFileAppender..::..RollingMode RollingStyle { get; set; }
Public Property RollingStyle As RollingFileAppender..::..RollingMode
    Get
    Set
Public Property RollingStyle As RollingFileAppender..::..RollingMode
    Get
    Set
public:
property RollingFileAppender..::..RollingMode RollingStyle {
    RollingFileAppender..::..RollingMode get ();
    void set (RollingFileAppender..::..RollingMode value);
}
public:
property RollingFileAppender..::..RollingMode RollingStyle {
    RollingFileAppender..::..RollingMode get ();
    void set (RollingFileAppender..::..RollingMode value);
}
Property Value
Type: RollingFileAppender RollingMode
The rolling style.
Remarks

            The default rolling style is Composite.

            When set to Once this appender's
            AppendToFile property is set to false, otherwise
            the appender would append to a single file rather than rolling
            the file each time it is opened.

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.StaticLogFileName Property

RollingFileAppender StaticLogFileName Property Apache log4net™ SDK Documentation
Gets or sets a value indicating whether to always log to the same file.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool StaticLogFileName { get; set; }
public bool StaticLogFileName { get; set; }
Public Property StaticLogFileName As Boolean
    Get
    Set
Public Property StaticLogFileName As Boolean
    Get
    Set
public:
property bool StaticLogFileName {
    bool get ();
    void set (bool value);
}
public:
property bool StaticLogFileName {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if always should be logged to the same file, otherwise false.

Remarks

            By default file.log is always the current file.  Optionally
            file.log.yyyy-mm-dd for current formatted datePattern can by the currently
            logging file (or file.log.curSizeRollBackup or even
            file.log.yyyy-mm-dd.curSizeRollBackup).

            This will make time based rollovers with a large number of backups
            much faster as the appender it won't have to rename all the backups!

See Also
RollingFileAppender Class
RollingFileAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.IDateTime Interface

RollingFileAppender IDateTime Interface Apache log4net™ SDK Documentation
This interface is used to supply Date/Time information to the RollingFileAppender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDateTime
public interface IDateTime
Public Interface IDateTime
Public Interface IDateTime
public interface class IDateTime
public interface class IDateTime
Remarks

            This interface is used to supply Date/Time information to the RollingFileAppender.
            Used primarily to allow test classes to plug themselves in so they can
            supply test date/times.

See Also
RollingFileAppender IDateTime Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.IDateTime Members

RollingFileAppender IDateTime Members Apache log4net™ SDK Documentation
The RollingFileAppender IDateTime type exposes the following members.
Properties
 | Name | Description
Public property | Now | Gets the current time.
Back to Top
See Also
RollingFileAppender IDateTime Interface
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.IDateTime Properties

RollingFileAppender IDateTime Properties Apache log4net™ SDK Documentation
The RollingFileAppender IDateTime type exposes the following members.
Properties
 | Name | Description
Public property | Now | Gets the current time.
Back to Top
See Also
RollingFileAppender IDateTime Interface
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.IDateTime.Now Property

RollingFileAppender IDateTime Now Property Apache log4net™ SDK Documentation
Gets the current time.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime Now { get; }
DateTime Now { get; }
ReadOnly Property Now As DateTime
    Get
ReadOnly Property Now As DateTime
    Get
property DateTime Now {
    DateTime get ();
}
property DateTime Now {
    DateTime get ();
}
Property Value
Type:   Online DateTime
The current time.
Remarks

            Gets the current time.

See Also
RollingFileAppender IDateTime Interface
RollingFileAppender IDateTime Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.RollingMode Enumeration

RollingFileAppender RollingMode Enumeration Apache log4net™ SDK Documentation
Style of rolling to use

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum RollingMode
public enum RollingMode
Public Enumeration RollingMode
Public Enumeration RollingMode
public enum class RollingMode
public enum class RollingMode
Members
Member name | Value | Description
Once | 0 | Roll files once per program execution
Size | 1 | Roll files based only on the size of the file
Date | 2 | Roll files based only on the date
Composite | 3 | Roll files based on both the size and date of the file
Remarks

            Style of rolling to use

See Also
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RollingFileAppender.RollPoint Enumeration

RollingFileAppender RollPoint Enumeration Apache log4net™ SDK Documentation
The code assumes that the following 'time' constants are in a increasing sequence.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected enum RollPoint
protected enum RollPoint
Protected Enumeration RollPoint
Protected Enumeration RollPoint
protected enum class RollPoint
protected enum class RollPoint
Members
Member name | Value | Description
InvalidRollPoint | -1 | Roll the log not based on the date
TopOfMinute | 0 | Roll the log for each minute
TopOfHour | 1 | Roll the log for each hour
HalfDay | 2 | Roll the log twice a day (midday and midnight)
TopOfDay | 3 | Roll the log each day (midnight)
TopOfWeek | 4 | Roll the log each week
TopOfMonth | 5 | Roll the log each month
Remarks

            The code assumes that the following 'time' constants are in a increasing sequence.

See Also
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender Class

SmtpAppender Class Apache log4net™ SDK Documentation
Send an e-mail when a specific logging event occurs, typically on errors or fatal errors.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender BufferingAppenderSkeleton
log4net.Appender SmtpAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SmtpAppender : BufferingAppenderSkeleton
public class SmtpAppender : BufferingAppenderSkeleton
Public Class SmtpAppender
    Inherits BufferingAppenderSkeleton
Public Class SmtpAppender
    Inherits BufferingAppenderSkeleton
public ref class SmtpAppender : public BufferingAppenderSkeleton
public ref class SmtpAppender : public BufferingAppenderSkeleton
Remarks

            The number of logging events delivered in this e-mail depend on
            the value of BufferSize option. The
            SmtpAppender keeps only the last
            BufferSize logging events in its
            cyclic buffer. This keeps memory requirements at a reasonable level while
            still delivering useful application context.

  Caution note  Caution

            Authentication and setting the server Port are only available on the MS .NET 1.1 runtime.
            For these features to be enabled you need to ensure that you are using a version of
            the log4net assembly that is built against the MS .NET 1.1 framework and that you are
            running the your application on the MS .NET 1.1 runtime. On all other platforms only sending
            unauthenticated messages to a server listening on port 25 (the default) is supported.

            Authentication is supported by setting the Authentication property to
            either Basic or Ntlm.
            If using Basic authentication then the Username
            and Password properties must also be set.

            To set the SMTP server port use the Port property. The default port is 25.

See Also
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender Members

SmtpAppender Members Apache log4net™ SDK Documentation
The SmtpAppender type exposes the following members.
Constructors
 | Name | Description
Public method | SmtpAppender | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from BufferingAppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Inherited from BufferingAppenderSkeleton.)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Flush | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Flush(Boolean) | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Close this appender instance. (Inherited from BufferingAppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | SendBuffer | Sends the contents of the cyclic buffer as an e-mail message. (Overrides BufferingAppenderSkeleton SendBuffer( LoggingEvent ).)
Protected method | SendEmail | Send the email message
Protected method | SendFromBuffer | Sends the contents of the buffer. (Inherited from BufferingAppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Authentication | The mode to use to authentication with the SMTP server
Public property | Bcc | Gets or sets a semicolon-delimited list of recipient e-mail addresses that will be blind carbon copied.
Public property | BodyEncoding | Gets or sets the body encoding to be used.
Public property | BufferSize | Gets or sets the size of the cyclic buffer used to hold the logging events. (Inherited from BufferingAppenderSkeleton.)
Public property | Cc | Gets or sets a comma- or semicolon-delimited list of recipient e-mail addresses that will be carbon copied (use semicolon on .NET 1.1 and comma for later versions).
Public property | EnableSsl | Enable or disable use of SSL when sending e-mail message
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Evaluator | Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately. (Inherited from BufferingAppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets a the fields that will be fixed in the event (Inherited from BufferingAppenderSkeleton.)
Public property | From | Gets or sets the e-mail address of the sender.
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | LocationInfo | Obsolete. Obsolete
Public property | Lossy | Gets or sets a value that indicates whether the appender is lossy. (Inherited from BufferingAppenderSkeleton.)
Public property | LossyEvaluator | Gets or sets the value of the ITriggeringEventEvaluator to use. (Inherited from BufferingAppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating if only part of the logging event data should be fixed. (Inherited from BufferingAppenderSkeleton.)
Public property | Password | The password to use to authenticate with the SMTP server
Public property | Port | The port on which the SMTP server is listening
Public property | Priority | Gets or sets the priority of the e-mail message
Public property | ReplyTo | Gets or sets the reply-to e-mail address.
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | SmtpHost | Gets or sets the name of the SMTP relay mail server to use to send the e-mail messages.
Public property | Subject | Gets or sets the subject line of the e-mail message.
Public property | SubjectEncoding | Gets or sets the subject encoding to be used.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Public property | To | Gets or sets a comma- or semicolon-delimited list of recipient e-mail addresses (use semicolon on .NET 1.1 and comma for later versions).
Public property | Username | The username to use to authenticate with the SMTP server
Back to Top
See Also
SmtpAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender Constructor

SmtpAppender Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SmtpAppender()
public SmtpAppender()
Public Sub New
Public Sub New
public:
SmtpAppender()
public:
SmtpAppender()
Remarks

            Default constructor

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender Methods

SmtpAppender Methods Apache log4net™ SDK Documentation
The SmtpAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from BufferingAppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Inherited from BufferingAppenderSkeleton.)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Flush | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Flush(Boolean) | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Close this appender instance. (Inherited from BufferingAppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | SendBuffer | Sends the contents of the cyclic buffer as an e-mail message. (Overrides BufferingAppenderSkeleton SendBuffer( LoggingEvent ).)
Protected method | SendEmail | Send the email message
Protected method | SendFromBuffer | Sends the contents of the buffer. (Inherited from BufferingAppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SmtpAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.SendBuffer Method

SmtpAppender SendBuffer Method Apache log4net™ SDK Documentation
Sends the contents of the cyclic buffer as an e-mail message.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void SendBuffer(
    LoggingEvent[] events
)
protected override void SendBuffer(
    LoggingEvent[] events
)
Protected Overrides Sub SendBuffer (
    events As LoggingEvent()
)
Protected Overrides Sub SendBuffer (
    events As LoggingEvent()
)
protected:
virtual void SendBuffer(
    array<LoggingEvent^>^ events
) override
protected:
virtual void SendBuffer(
    array<LoggingEvent^>^ events
) override
Parameters
events
Type:  log4net.Core LoggingEvent
The logging events to send.
See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.SendEmail Method

SmtpAppender SendEmail Method Apache log4net™ SDK Documentation
Send the email message

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void SendEmail(
    string messageBody
)
protected virtual void SendEmail(
    string messageBody
)
Protected Overridable Sub SendEmail (
    messageBody As String
)
Protected Overridable Sub SendEmail (
    messageBody As String
)
protected:
virtual void SendEmail(
    String^ messageBody
)
protected:
virtual void SendEmail(
    String^ messageBody
)
Parameters
messageBody
Type:   Online System String
the body text to include in the mail
See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender Properties

SmtpAppender Properties Apache log4net™ SDK Documentation
The SmtpAppender type exposes the following members.
Properties
 | Name | Description
Public property | Authentication | The mode to use to authentication with the SMTP server
Public property | Bcc | Gets or sets a semicolon-delimited list of recipient e-mail addresses that will be blind carbon copied.
Public property | BodyEncoding | Gets or sets the body encoding to be used.
Public property | BufferSize | Gets or sets the size of the cyclic buffer used to hold the logging events. (Inherited from BufferingAppenderSkeleton.)
Public property | Cc | Gets or sets a comma- or semicolon-delimited list of recipient e-mail addresses that will be carbon copied (use semicolon on .NET 1.1 and comma for later versions).
Public property | EnableSsl | Enable or disable use of SSL when sending e-mail message
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Evaluator | Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately. (Inherited from BufferingAppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets a the fields that will be fixed in the event (Inherited from BufferingAppenderSkeleton.)
Public property | From | Gets or sets the e-mail address of the sender.
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | LocationInfo | Obsolete. Obsolete
Public property | Lossy | Gets or sets a value that indicates whether the appender is lossy. (Inherited from BufferingAppenderSkeleton.)
Public property | LossyEvaluator | Gets or sets the value of the ITriggeringEventEvaluator to use. (Inherited from BufferingAppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating if only part of the logging event data should be fixed. (Inherited from BufferingAppenderSkeleton.)
Public property | Password | The password to use to authenticate with the SMTP server
Public property | Port | The port on which the SMTP server is listening
Public property | Priority | Gets or sets the priority of the e-mail message
Public property | ReplyTo | Gets or sets the reply-to e-mail address.
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | SmtpHost | Gets or sets the name of the SMTP relay mail server to use to send the e-mail messages.
Public property | Subject | Gets or sets the subject line of the e-mail message.
Public property | SubjectEncoding | Gets or sets the subject encoding to be used.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Public property | To | Gets or sets a comma- or semicolon-delimited list of recipient e-mail addresses (use semicolon on .NET 1.1 and comma for later versions).
Public property | Username | The username to use to authenticate with the SMTP server
Back to Top
See Also
SmtpAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.Authentication Property

SmtpAppender Authentication Property Apache log4net™ SDK Documentation
The mode to use to authentication with the SMTP server

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SmtpAppender..::..SmtpAuthentication Authentication { get; set; }
public SmtpAppender..::..SmtpAuthentication Authentication { get; set; }
Public Property Authentication As SmtpAppender..::..SmtpAuthentication
    Get
    Set
Public Property Authentication As SmtpAppender..::..SmtpAuthentication
    Get
    Set
public:
property SmtpAppender..::..SmtpAuthentication Authentication {
    SmtpAppender..::..SmtpAuthentication get ();
    void set (SmtpAppender..::..SmtpAuthentication value);
}
public:
property SmtpAppender..::..SmtpAuthentication Authentication {
    SmtpAppender..::..SmtpAuthentication get ();
    void set (SmtpAppender..::..SmtpAuthentication value);
}
Property Value
Type: SmtpAppender SmtpAuthentication
Remarks
  Caution note  Caution
Authentication is only available on the MS .NET 1.1 runtime.

            Valid Authentication mode values are: None,
            Basic, and Ntlm.
            The default value is None. When using
            Basic you must specify the Username
            and Password to use to authenticate.
            When using Ntlm the Windows credentials for the current
            thread, if impersonating, or the process will be used to authenticate.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.Bcc Property

SmtpAppender Bcc Property Apache log4net™ SDK Documentation
Gets or sets a semicolon-delimited list of recipient e-mail addresses that will be blind carbon copied.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Bcc { get; set; }
public string Bcc { get; set; }
Public Property Bcc As String
    Get
    Set
Public Property Bcc As String
    Get
    Set
public:
property String^ Bcc {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Bcc {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            A semicolon-delimited list of e-mail addresses.

Remarks

            A semicolon-delimited list of recipient e-mail addresses.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.BodyEncoding Property

SmtpAppender BodyEncoding Property Apache log4net™ SDK Documentation
Gets or sets the body encoding to be used.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Encoding BodyEncoding { get; set; }
public Encoding BodyEncoding { get; set; }
Public Property BodyEncoding As Encoding
    Get
    Set
Public Property BodyEncoding As Encoding
    Get
    Set
public:
property Encoding^ BodyEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
public:
property Encoding^ BodyEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
Property Value
Type:   Online Encoding
Remarks

            The default encoding is the operating system's current ANSI codepage.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.Cc Property

SmtpAppender Cc Property Apache log4net™ SDK Documentation
Gets or sets a comma- or semicolon-delimited list of recipient e-mail addresses that will be carbon copied (use semicolon on .NET 1.1 and comma for later versions).

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Cc { get; set; }
public string Cc { get; set; }
Public Property Cc As String
    Get
    Set
Public Property Cc As String
    Get
    Set
public:
property String^ Cc {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Cc {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            For .NET 1.1 (System.Web.Mail): A semicolon-delimited list of e-mail addresses.

            For .NET 2.0 (System.Net.Mail): A comma-delimited list of e-mail addresses.

Remarks

            For .NET 1.1 (System.Web.Mail): A semicolon-delimited list of e-mail addresses.

            For .NET 2.0 (System.Net.Mail): A comma-delimited list of e-mail addresses.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.EnableSsl Property

SmtpAppender EnableSsl Property Apache log4net™ SDK Documentation
Enable or disable use of SSL when sending e-mail message

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool EnableSsl { get; set; }
public bool EnableSsl { get; set; }
Public Property EnableSsl As Boolean
    Get
    Set
Public Property EnableSsl As Boolean
    Get
    Set
public:
property bool EnableSsl {
    bool get ();
    void set (bool value);
}
public:
property bool EnableSsl {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
Remarks

            This is available on MS .NET 2.0 runtime and higher

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.From Property

SmtpAppender From Property Apache log4net™ SDK Documentation
Gets or sets the e-mail address of the sender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string From { get; set; }
public string From { get; set; }
Public Property From As String
    Get
    Set
Public Property From As String
    Get
    Set
public:
property String^ From {
    String^ get ();
    void set (String^ value);
}
public:
property String^ From {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The e-mail address of the sender.

Remarks

            The e-mail address of the sender.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.LocationInfo Property

SmtpAppender LocationInfo Property Apache log4net™ SDK Documentation
Obsolete

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use the BufferingAppenderSkeleton Fix methods")]
public bool LocationInfo { get; set; }
[ObsoleteAttribute("Use the BufferingAppenderSkeleton Fix methods")]
public bool LocationInfo { get; set; }
<ObsoleteAttribute("Use the BufferingAppenderSkeleton Fix methods")>
Public Property LocationInfo As Boolean
    Get
    Set
<ObsoleteAttribute("Use the BufferingAppenderSkeleton Fix methods")>
Public Property LocationInfo As Boolean
    Get
    Set
public:
[ObsoleteAttribute(L"Use the BufferingAppenderSkeleton Fix methods")]
property bool LocationInfo {
    bool get ();
    void set (bool value);
}
public:
[ObsoleteAttribute(L"Use the BufferingAppenderSkeleton Fix methods")]
property bool LocationInfo {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
Remarks

            Use the BufferingAppenderSkeleton Fix methods instead

Remarks

            Obsolete property.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.Password Property

SmtpAppender Password Property Apache log4net™ SDK Documentation
The password to use to authenticate with the SMTP server

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Password { get; set; }
public string Password { get; set; }
Public Property Password As String
    Get
    Set
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks
  Caution note  Caution
Authentication is only available on the MS .NET 1.1 runtime.

            A Username and Password must be specified when
            Authentication is set to Basic,
            otherwise the password will be ignored.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.Port Property

SmtpAppender Port Property Apache log4net™ SDK Documentation
The port on which the SMTP server is listening

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Port { get; set; }
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}
public:
property int Port {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32
Remarks
  Caution note  Caution
Server Port is only available on the MS .NET 1.1 runtime.

            The port on which the SMTP server is listening. The default
            port is 25. The Port can only be changed when running on
            the MS .NET 1.1 runtime.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.Priority Property

SmtpAppender Priority Property Apache log4net™ SDK Documentation
Gets or sets the priority of the e-mail message

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MailPriority Priority { get; set; }
public MailPriority Priority { get; set; }
Public Property Priority As MailPriority
    Get
    Set
Public Property Priority As MailPriority
    Get
    Set
public:
property MailPriority Priority {
    MailPriority get ();
    void set (MailPriority value);
}
public:
property MailPriority Priority {
    MailPriority get ();
    void set (MailPriority value);
}
Property Value
Type:   Online MailPriority

            One of the   Online MailPriority values.

Remarks

            Sets the priority of the e-mails generated by this
            appender. The default priority is   Online Normal.

            If you are using this appender to report errors then
            you may want to set the priority to   Online High.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.ReplyTo Property

SmtpAppender ReplyTo Property Apache log4net™ SDK Documentation
Gets or sets the reply-to e-mail address.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ReplyTo { get; set; }
public string ReplyTo { get; set; }
Public Property ReplyTo As String
    Get
    Set
Public Property ReplyTo As String
    Get
    Set
public:
property String^ ReplyTo {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ReplyTo {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            This is available on MS .NET 2.0 runtime and higher

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.RequiresLayout Property

SmtpAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.SmtpHost Property

SmtpAppender SmtpHost Property Apache log4net™ SDK Documentation
Gets or sets the name of the SMTP relay mail server to use to send the e-mail messages.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SmtpHost { get; set; }
public string SmtpHost { get; set; }
Public Property SmtpHost As String
    Get
    Set
Public Property SmtpHost As String
    Get
    Set
public:
property String^ SmtpHost {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SmtpHost {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The name of the e-mail relay server. If SmtpServer is not set, the
            name of the local SMTP server is used.

Remarks

            The name of the e-mail relay server. If SmtpServer is not set, the
            name of the local SMTP server is used.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.Subject Property

SmtpAppender Subject Property Apache log4net™ SDK Documentation
Gets or sets the subject line of the e-mail message.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Subject { get; set; }
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
Public Property Subject As String
    Get
    Set
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The subject line of the e-mail message.

Remarks

            The subject line of the e-mail message.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.SubjectEncoding Property

SmtpAppender SubjectEncoding Property Apache log4net™ SDK Documentation
Gets or sets the subject encoding to be used.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Encoding SubjectEncoding { get; set; }
public Encoding SubjectEncoding { get; set; }
Public Property SubjectEncoding As Encoding
    Get
    Set
Public Property SubjectEncoding As Encoding
    Get
    Set
public:
property Encoding^ SubjectEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
public:
property Encoding^ SubjectEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
Property Value
Type:   Online Encoding
Remarks

            The default encoding is the operating system's current ANSI codepage.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.To Property

SmtpAppender To Property Apache log4net™ SDK Documentation
Gets or sets a comma- or semicolon-delimited list of recipient e-mail addresses (use semicolon on .NET 1.1 and comma for later versions).

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string To { get; set; }
public string To { get; set; }
Public Property To As String
    Get
    Set
Public Property To As String
    Get
    Set
public:
property String^ To {
    String^ get ();
    void set (String^ value);
}
public:
property String^ To {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            For .NET 1.1 (System.Web.Mail): A semicolon-delimited list of e-mail addresses.

            For .NET 2.0 (System.Net.Mail): A comma-delimited list of e-mail addresses.

Remarks

            For .NET 1.1 (System.Web.Mail): A semicolon-delimited list of e-mail addresses.

            For .NET 2.0 (System.Net.Mail): A comma-delimited list of e-mail addresses.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.Username Property

SmtpAppender Username Property Apache log4net™ SDK Documentation
The username to use to authenticate with the SMTP server

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Username { get; set; }
public string Username { get; set; }
Public Property Username As String
    Get
    Set
Public Property Username As String
    Get
    Set
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks
  Caution note  Caution
Authentication is only available on the MS .NET 1.1 runtime.

            A Username and Password must be specified when
            Authentication is set to Basic,
            otherwise the username will be ignored.

See Also
SmtpAppender Class
SmtpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpAppender.SmtpAuthentication Enumeration

SmtpAppender SmtpAuthentication Enumeration Apache log4net™ SDK Documentation
Values for the Authentication property.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum SmtpAuthentication
public enum SmtpAuthentication
Public Enumeration SmtpAuthentication
Public Enumeration SmtpAuthentication
public enum class SmtpAuthentication
public enum class SmtpAuthentication
Members
Member name | Value | Description
None | 0 | No authentication
Basic | 1 | Basic authentication.
Ntlm | 2 | Integrated authentication
Remarks

            SMTP authentication modes.

See Also
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender Class

SmtpPickupDirAppender Class Apache log4net™ SDK Documentation
Send an email when a specific logging event occurs, typically on errors or fatal errors. Rather than sending via smtp it writes a file into the directory specified by PickupDir. This allows services such as the IIS SMTP agent to manage sending the messages.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender BufferingAppenderSkeleton
log4net.Appender SmtpPickupDirAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SmtpPickupDirAppender : BufferingAppenderSkeleton
public class SmtpPickupDirAppender : BufferingAppenderSkeleton
Public Class SmtpPickupDirAppender
    Inherits BufferingAppenderSkeleton
Public Class SmtpPickupDirAppender
    Inherits BufferingAppenderSkeleton
public ref class SmtpPickupDirAppender : public BufferingAppenderSkeleton
public ref class SmtpPickupDirAppender : public BufferingAppenderSkeleton
Remarks

            The configuration for this appender is identical to that of the SMTPAppender,
            except that instead of specifying the SMTPAppender.SMTPHost you specify
            PickupDir.

            The number of logging events delivered in this e-mail depend on
            the value of BufferSize option. The
            SmtpPickupDirAppender keeps only the last
            BufferSize logging events in its
            cyclic buffer. This keeps memory requirements at a reasonable level while
            still delivering useful application context.

See Also
SmtpPickupDirAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender Members

SmtpPickupDirAppender Members Apache log4net™ SDK Documentation
The SmtpPickupDirAppender type exposes the following members.
Constructors
 | Name | Description
Public method | SmtpPickupDirAppender | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Activate the options on this appender. (Overrides BufferingAppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Inherited from BufferingAppenderSkeleton.)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
 | ConvertToFullPath | Convert a path into a fully qualified path.
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Flush | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Flush(Boolean) | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Close this appender instance. (Inherited from BufferingAppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | SendBuffer | Sends the contents of the cyclic buffer as an e-mail message. (Overrides BufferingAppenderSkeleton SendBuffer( LoggingEvent ).)
Protected method | SendFromBuffer | Sends the contents of the buffer. (Inherited from BufferingAppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | BufferSize | Gets or sets the size of the cyclic buffer used to hold the logging events. (Inherited from BufferingAppenderSkeleton.)
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Evaluator | Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately. (Inherited from BufferingAppenderSkeleton.)
Public property | FileExtension | Gets or sets the file extension for the generated files
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets a the fields that will be fixed in the event (Inherited from BufferingAppenderSkeleton.)
Public property | From | Gets or sets the e-mail address of the sender.
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Lossy | Gets or sets a value that indicates whether the appender is lossy. (Inherited from BufferingAppenderSkeleton.)
Public property | LossyEvaluator | Gets or sets the value of the ITriggeringEventEvaluator to use. (Inherited from BufferingAppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating if only part of the logging event data should be fixed. (Inherited from BufferingAppenderSkeleton.)
Public property | PickupDir | Gets or sets the path to write the messages to.
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | SecurityContext | Gets or sets the SecurityContext used to write to the pickup directory.
Public property | Subject | Gets or sets the subject line of the e-mail message.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Public property | To | Gets or sets a semicolon-delimited list of recipient e-mail addresses.
Back to Top
See Also
SmtpPickupDirAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender Constructor

SmtpPickupDirAppender Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SmtpPickupDirAppender()
public SmtpPickupDirAppender()
Public Sub New
Public Sub New
public:
SmtpPickupDirAppender()
public:
SmtpPickupDirAppender()
Remarks

            Default constructor

See Also
SmtpPickupDirAppender Class
SmtpPickupDirAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender Methods

SmtpPickupDirAppender Methods Apache log4net™ SDK Documentation
The SmtpPickupDirAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Activate the options on this appender. (Overrides BufferingAppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Inherited from BufferingAppenderSkeleton.)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
 | ConvertToFullPath | Convert a path into a fully qualified path.
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Flush | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Flush(Boolean) | Flush the currently buffered events (Inherited from BufferingAppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Close this appender instance. (Inherited from BufferingAppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | SendBuffer | Sends the contents of the cyclic buffer as an e-mail message. (Overrides BufferingAppenderSkeleton SendBuffer( LoggingEvent ).)
Protected method | SendFromBuffer | Sends the contents of the buffer. (Inherited from BufferingAppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SmtpPickupDirAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender.ActivateOptions Method

SmtpPickupDirAppender ActivateOptions Method Apache log4net™ SDK Documentation
Activate the options on this appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
SmtpPickupDirAppender Class
SmtpPickupDirAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender.ConvertToFullPath Method

SmtpPickupDirAppender ConvertToFullPath Method Apache log4net™ SDK Documentation
Convert a path into a fully qualified path.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static string ConvertToFullPath(
    string path
)
protected static string ConvertToFullPath(
    string path
)
Protected Shared Function ConvertToFullPath (
    path As String
) As String
Protected Shared Function ConvertToFullPath (
    path As String
) As String
protected:
static String^ ConvertToFullPath(
    String^ path
)
protected:
static String^ ConvertToFullPath(
    String^ path
)
Parameters
path
Type:   Online System String
The path to convert.
Return Value
Type:   Online String
The fully qualified path.
Remarks

            Converts the path specified to a fully
            qualified path. If the path is relative it is
            taken as relative from the application base
            directory.

See Also
SmtpPickupDirAppender Class
SmtpPickupDirAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender.SendBuffer Method

SmtpPickupDirAppender SendBuffer Method Apache log4net™ SDK Documentation
Sends the contents of the cyclic buffer as an e-mail message.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void SendBuffer(
    LoggingEvent[] events
)
protected override void SendBuffer(
    LoggingEvent[] events
)
Protected Overrides Sub SendBuffer (
    events As LoggingEvent()
)
Protected Overrides Sub SendBuffer (
    events As LoggingEvent()
)
protected:
virtual void SendBuffer(
    array<LoggingEvent^>^ events
) override
protected:
virtual void SendBuffer(
    array<LoggingEvent^>^ events
) override
Parameters
events
Type:  log4net.Core LoggingEvent
The logging events to send.
Remarks

            Sends the contents of the cyclic buffer as an e-mail message.

See Also
SmtpPickupDirAppender Class
SmtpPickupDirAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender Properties

SmtpPickupDirAppender Properties Apache log4net™ SDK Documentation
The SmtpPickupDirAppender type exposes the following members.
Properties
 | Name | Description
Public property | BufferSize | Gets or sets the size of the cyclic buffer used to hold the logging events. (Inherited from BufferingAppenderSkeleton.)
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | Evaluator | Gets or sets the ITriggeringEventEvaluator that causes the buffer to be sent immediately. (Inherited from BufferingAppenderSkeleton.)
Public property | FileExtension | Gets or sets the file extension for the generated files
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Fix | Gets or sets a the fields that will be fixed in the event (Inherited from BufferingAppenderSkeleton.)
Public property | From | Gets or sets the e-mail address of the sender.
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Lossy | Gets or sets a value that indicates whether the appender is lossy. (Inherited from BufferingAppenderSkeleton.)
Public property | LossyEvaluator | Gets or sets the value of the ITriggeringEventEvaluator to use. (Inherited from BufferingAppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | OnlyFixPartialEventData | Obsolete. Gets or sets a value indicating if only part of the logging event data should be fixed. (Inherited from BufferingAppenderSkeleton.)
Public property | PickupDir | Gets or sets the path to write the messages to.
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | SecurityContext | Gets or sets the SecurityContext used to write to the pickup directory.
Public property | Subject | Gets or sets the subject line of the e-mail message.
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Public property | To | Gets or sets a semicolon-delimited list of recipient e-mail addresses.
Back to Top
See Also
SmtpPickupDirAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender.FileExtension Property

SmtpPickupDirAppender FileExtension Property Apache log4net™ SDK Documentation
Gets or sets the file extension for the generated files

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FileExtension { get; set; }
public string FileExtension { get; set; }
Public Property FileExtension As String
    Get
    Set
Public Property FileExtension As String
    Get
    Set
public:
property String^ FileExtension {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FileExtension {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The file extension for the generated files

Remarks

            The file extension for the generated files

See Also
SmtpPickupDirAppender Class
SmtpPickupDirAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender.From Property

SmtpPickupDirAppender From Property Apache log4net™ SDK Documentation
Gets or sets the e-mail address of the sender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string From { get; set; }
public string From { get; set; }
Public Property From As String
    Get
    Set
Public Property From As String
    Get
    Set
public:
property String^ From {
    String^ get ();
    void set (String^ value);
}
public:
property String^ From {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The e-mail address of the sender.

Remarks

            The e-mail address of the sender.

See Also
SmtpPickupDirAppender Class
SmtpPickupDirAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender.PickupDir Property

SmtpPickupDirAppender PickupDir Property Apache log4net™ SDK Documentation
Gets or sets the path to write the messages to.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PickupDir { get; set; }
public string PickupDir { get; set; }
Public Property PickupDir As String
    Get
    Set
Public Property PickupDir As String
    Get
    Set
public:
property String^ PickupDir {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PickupDir {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            Gets or sets the path to write the messages to. This should be the same
            as that used by the agent sending the messages.

See Also
SmtpPickupDirAppender Class
SmtpPickupDirAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender.RequiresLayout Property

SmtpPickupDirAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
SmtpPickupDirAppender Class
SmtpPickupDirAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender.SecurityContext Property

SmtpPickupDirAppender SecurityContext Property Apache log4net™ SDK Documentation
Gets or sets the SecurityContext used to write to the pickup directory.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityContext SecurityContext { get; set; }
public SecurityContext SecurityContext { get; set; }
Public Property SecurityContext As SecurityContext
    Get
    Set
Public Property SecurityContext As SecurityContext
    Get
    Set
public:
property SecurityContext^ SecurityContext {
    SecurityContext^ get ();
    void set (SecurityContext^ value);
}
public:
property SecurityContext^ SecurityContext {
    SecurityContext^ get ();
    void set (SecurityContext^ value);
}
Property Value
Type: SecurityContext

            The SecurityContext used to write to the pickup directory.

Remarks

            Unless a SecurityContext specified here for this appender
            the DefaultProvider is queried for the
            security context to use. The default behavior is to use the security context
            of the current thread.

See Also
SmtpPickupDirAppender Class
SmtpPickupDirAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender.Subject Property

SmtpPickupDirAppender Subject Property Apache log4net™ SDK Documentation
Gets or sets the subject line of the e-mail message.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Subject { get; set; }
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
Public Property Subject As String
    Get
    Set
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The subject line of the e-mail message.

Remarks

            The subject line of the e-mail message.

See Also
SmtpPickupDirAppender Class
SmtpPickupDirAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SmtpPickupDirAppender.To Property

SmtpPickupDirAppender To Property Apache log4net™ SDK Documentation
Gets or sets a semicolon-delimited list of recipient e-mail addresses.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string To { get; set; }
public string To { get; set; }
Public Property To As String
    Get
    Set
Public Property To As String
    Get
    Set
public:
property String^ To {
    String^ get ();
    void set (String^ value);
}
public:
property String^ To {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            A semicolon-delimited list of e-mail addresses.

Remarks

            A semicolon-delimited list of e-mail addresses.

See Also
SmtpPickupDirAppender Class
SmtpPickupDirAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender Class

TelnetAppender Class Apache log4net™ SDK Documentation
Appender that allows clients to connect via Telnet to receive log messages
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender TelnetAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TelnetAppender : AppenderSkeleton
public class TelnetAppender : AppenderSkeleton
Public Class TelnetAppender
    Inherits AppenderSkeleton
Public Class TelnetAppender
    Inherits AppenderSkeleton
public ref class TelnetAppender : public AppenderSkeleton
public ref class TelnetAppender : public AppenderSkeleton
Remarks

            The TelnetAppender accepts socket connections and streams logging messages
            back to the client.
            The output is provided in a telnet-friendly way so that a log can be monitored
            over a TCP/IP socket.
            This allows simple remote monitoring of application logging.

            The default Port is 23 (the telnet port).

See Also
TelnetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender Members

TelnetAppender Members Apache log4net™ SDK Documentation
The TelnetAppender type exposes the following members.
Constructors
 | Name | Description
Public method | TelnetAppender | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set. (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Writes the logging event to each connected client. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Overrides the parent method to close the socket handler (Overrides AppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | Port | Gets or sets the TCP port number on which this TelnetAppender will listen for connections.
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
TelnetAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender Constructor

TelnetAppender Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TelnetAppender()
public TelnetAppender()
Public Sub New
Public Sub New
public:
TelnetAppender()
public:
TelnetAppender()
Remarks

            Default constructor

See Also
TelnetAppender Class
TelnetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender Methods

TelnetAppender Methods Apache log4net™ SDK Documentation
The TelnetAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set. (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Writes the logging event to each connected client. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Overrides the parent method to close the socket handler (Overrides AppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TelnetAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.ActivateOptions Method

TelnetAppender ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the appender based on the options set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

            Create the socket handler and wait for connections

See Also
TelnetAppender Class
TelnetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.Append Method

TelnetAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Writes the logging event to each connected client. (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
TelnetAppender Class
TelnetAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.Append Method (LoggingEvent)

TelnetAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
Writes the logging event to each connected client.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Writes the logging event to each connected client.

See Also
TelnetAppender Class
TelnetAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.OnClose Method

TelnetAppender OnClose Method Apache log4net™ SDK Documentation
Overrides the parent method to close the socket handler

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void OnClose()
protected override void OnClose()
Protected Overrides Sub OnClose
Protected Overrides Sub OnClose
protected:
virtual void OnClose() override
protected:
virtual void OnClose() override
Remarks

            Closes all the outstanding connections.

See Also
TelnetAppender Class
TelnetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender Properties

TelnetAppender Properties Apache log4net™ SDK Documentation
The TelnetAppender type exposes the following members.
Properties
 | Name | Description
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | Port | Gets or sets the TCP port number on which this TelnetAppender will listen for connections.
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
TelnetAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.Port Property

TelnetAppender Port Property Apache log4net™ SDK Documentation
Gets or sets the TCP port number on which this TelnetAppender will listen for connections.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Port { get; set; }
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}
public:
property int Port {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32

            An integer value in the range   Online MinPort to   Online MaxPort
            indicating the TCP port number on which this TelnetAppender will listen for connections.

Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | The value specified is less than Online MinPort or greater than Online MaxPort.
Remarks

            The default value is 23 (the telnet port).

See Also
TelnetAppender Class
TelnetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.RequiresLayout Property

TelnetAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
TelnetAppender Class
TelnetAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler Class

TelnetAppender SocketHandler Class Apache log4net™ SDK Documentation
Helper class to manage connected clients
Inheritance Hierarchy
Online System Object
log4net.Appender TelnetAppender SocketHandler

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected class SocketHandler : IDisposable
protected class SocketHandler : IDisposable
Protected Class SocketHandler
    Implements IDisposable
Protected Class SocketHandler
    Implements IDisposable
protected ref class SocketHandler : IDisposable
protected ref class SocketHandler : IDisposable
Remarks

            The SocketHandler class is used to accept connections from
            clients.  It is threaded so that clients can connect/disconnect
            asynchronously.

See Also
TelnetAppender SocketHandler Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler Members

TelnetAppender SocketHandler Members Apache log4net™ SDK Documentation
The TelnetAppender SocketHandler type exposes the following members.
Constructors
 | Name | Description
Public method | TelnetAppender SocketHandler | Opens a new server port on
Back to Top
Methods
 | Name | Description
Public method | Dispose | Close all network connections
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Send | Sends a string message to each of the connected clients
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | HasConnections | Test if this handler has active connections
Back to Top
See Also
TelnetAppender SocketHandler Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler Constructor

TelnetAppender SocketHandler Constructor Apache log4net™ SDK Documentation
Opens a new server port on

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocketHandler(
    int port
)
public SocketHandler(
    int port
)
Public Sub New (
    port As Integer
)
Public Sub New (
    port As Integer
)
public:
SocketHandler(
    int port
)
public:
SocketHandler(
    int port
)
Parameters
port
Type:   Online System Int32
the local port to listen on for connections
Remarks

            Creates a socket handler on the specified local server port.

See Also
TelnetAppender SocketHandler Class
TelnetAppender SocketHandler Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler Methods

TelnetAppender SocketHandler Methods Apache log4net™ SDK Documentation
The TelnetAppender SocketHandler type exposes the following members.
Methods
 | Name | Description
Public method | Dispose | Close all network connections
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Send | Sends a string message to each of the connected clients
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TelnetAppender SocketHandler Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler.Dispose Method

TelnetAppender SocketHandler Dispose Method Apache log4net™ SDK Documentation
Close all network connections

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
Remarks

            Make sure we close all network connections

See Also
TelnetAppender SocketHandler Class
TelnetAppender SocketHandler Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler.Send Method

TelnetAppender SocketHandler Send Method Apache log4net™ SDK Documentation
Sends a string message to each of the connected clients

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Send(
    string message
)
public void Send(
    string message
)
Public Sub Send (
    message As String
)
Public Sub Send (
    message As String
)
public:
void Send(
    String^ message
)
public:
void Send(
    String^ message
)
Parameters
message
Type:   Online System String
the text to send
Remarks

            Sends a string message to each of the connected clients

See Also
TelnetAppender SocketHandler Class
TelnetAppender SocketHandler Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler Properties

TelnetAppender SocketHandler Properties Apache log4net™ SDK Documentation
The TelnetAppender SocketHandler type exposes the following members.
Properties
 | Name | Description
Public property | HasConnections | Test if this handler has active connections
Back to Top
See Also
TelnetAppender SocketHandler Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler.HasConnections Property

TelnetAppender SocketHandler HasConnections Property Apache log4net™ SDK Documentation
Test if this handler has active connections

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasConnections { get; }
public bool HasConnections { get; }
Public ReadOnly Property HasConnections As Boolean
    Get
Public ReadOnly Property HasConnections As Boolean
    Get
public:
property bool HasConnections {
    bool get ();
}
public:
property bool HasConnections {
    bool get ();
}
Property Value
Type:   Online Boolean
true if this handler has active connections

Remarks

            This property will be true while this handler has
            active connections, that is at least one connection that
            the handler will attempt to send a message to.

See Also
TelnetAppender SocketHandler Class
TelnetAppender SocketHandler Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler.SocketClient Class

TelnetAppender SocketHandler SocketClient Class Apache log4net™ SDK Documentation
Class that represents a client connected to this handler
Inheritance Hierarchy
Online System Object
log4net.Appender TelnetAppender SocketHandler SocketClient

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected class SocketClient : IDisposable
protected class SocketClient : IDisposable
Protected Class SocketClient
    Implements IDisposable
Protected Class SocketClient
    Implements IDisposable
protected ref class SocketClient : IDisposable
protected ref class SocketClient : IDisposable
Remarks

            Class that represents a client connected to this handler

See Also
TelnetAppender SocketHandler SocketClient Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler.SocketClient Members

TelnetAppender SocketHandler SocketClient Members Apache log4net™ SDK Documentation
The TelnetAppender SocketHandler SocketClient type exposes the following members.
Constructors
 | Name | Description
Public method | TelnetAppender SocketHandler SocketClient | Create this TelnetAppender SocketHandler SocketClient for the specified Online Socket
Back to Top
Methods
 | Name | Description
Public method | Dispose | Cleanup the clients connection
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Send | Write a string to the client
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TelnetAppender SocketHandler SocketClient Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler.SocketClient Constructor

TelnetAppender SocketHandler SocketClient Constructor Apache log4net™ SDK Documentation
Create this TelnetAppender SocketHandler SocketClient for the specified Online Socket

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocketClient(
    Socket socket
)
public SocketClient(
    Socket socket
)
Public Sub New (
    socket As Socket
)
Public Sub New (
    socket As Socket
)
public:
SocketClient(
    Socket^ socket
)
public:
SocketClient(
    Socket^ socket
)
Parameters
socket
Type:   Online System.Net.Sockets Socket
the client's socket
Remarks

            Opens a stream writer on the socket.

See Also
TelnetAppender SocketHandler SocketClient Class
TelnetAppender SocketHandler SocketClient Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler.SocketClient Methods

TelnetAppender SocketHandler SocketClient Methods Apache log4net™ SDK Documentation
The TelnetAppender SocketHandler SocketClient type exposes the following members.
Methods
 | Name | Description
Public method | Dispose | Cleanup the clients connection
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Send | Write a string to the client
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TelnetAppender SocketHandler SocketClient Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler.SocketClient.Dispose Method

TelnetAppender SocketHandler SocketClient Dispose Method Apache log4net™ SDK Documentation
Cleanup the clients connection

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
Remarks

            Close the socket connection.

See Also
TelnetAppender SocketHandler SocketClient Class
TelnetAppender SocketHandler SocketClient Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TelnetAppender.SocketHandler.SocketClient.Send Method

TelnetAppender SocketHandler SocketClient Send Method Apache log4net™ SDK Documentation
Write a string to the client

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Send(
    string message
)
public void Send(
    string message
)
Public Sub Send (
    message As String
)
Public Sub Send (
    message As String
)
public:
void Send(
    String^ message
)
public:
void Send(
    String^ message
)
Parameters
message
Type:   Online System String
string to send
Remarks

            Write a string to the client

See Also
TelnetAppender SocketHandler SocketClient Class
TelnetAppender SocketHandler SocketClient Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender Class

TextWriterAppender Class Apache log4net™ SDK Documentation
Sends logging events to a Online TextWriter.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender TextWriterAppender
log4net.Appender FileAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TextWriterAppender : AppenderSkeleton
public class TextWriterAppender : AppenderSkeleton
Public Class TextWriterAppender
    Inherits AppenderSkeleton
Public Class TextWriterAppender
    Inherits AppenderSkeleton
public ref class TextWriterAppender : public AppenderSkeleton
public ref class TextWriterAppender : public AppenderSkeleton
Remarks

            An Appender that writes to a   Online TextWriter.

            This appender may be used stand alone if initialized with an appropriate
            writer, however it is typically used as a base class for an appender that
            can open a   Online TextWriter to write to.

See Also
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender Members

TextWriterAppender Members Apache log4net™ SDK Documentation
The TextWriterAppender type exposes the following members.
Constructors
 | Name | Description
Public method | TextWriterAppender | Initializes a new instance of the TextWriterAppender class.
Public method | TextWriterAppender(ILayout, Stream) | Obsolete. Initializes a new instance of the TextWriterAppender class and sets the output destination to a new Online StreamWriter initialized with the specified Online Stream.
Public method | TextWriterAppender(ILayout, TextWriter) | Obsolete. Initializes a new instance of the TextWriterAppender class and sets the output destination to the specified Online StreamWriter.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | This method is called by the DoAppend( LoggingEvent ) method. (Overrides AppenderSkeleton Append( LoggingEvent ).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Protected method | CloseWriter | Closes the underlying Online TextWriter.
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Close this appender instance. The underlying stream or writer is also closed. (Overrides AppenderSkeleton OnClose .)
Protected method | PreAppendCheck | This method determines if there is a sense in attempting to append. (Overrides AppenderSkeleton PreAppendCheck .)
Protected method | PrepareWriter | Called to allow a subclass to lazily initialize the writer
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | Reset | Clears internal references to the underlying Online TextWriter and other variables.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Protected method | WriteFooter | Writes a footer as produced by the embedded layout's Footer property.
Protected method | WriteFooterAndCloseWriter | Writes the footer and closes the underlying Online TextWriter.
Protected method | WriteHeader | Writes a header produced by the embedded layout's Header property.
Back to Top
Properties
 | Name | Description
Public property | ErrorHandler | Gets or set the IErrorHandler and the underlying QuietTextWriter, if any, for this appender. (Overrides AppenderSkeleton ErrorHandler.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | ImmediateFlush | Gets or set whether the appender will flush at the end of each append operation.
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | QuietWriter | Gets or sets the QuietTextWriter where logging events will be written to.
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Public property | Writer | Sets the Online TextWriter where the log output will go.
Back to Top
See Also
TextWriterAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender Constructor

TextWriterAppender Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | TextWriterAppender | Initializes a new instance of the TextWriterAppender class.
Public method | TextWriterAppender(ILayout, Stream) | Obsolete. Initializes a new instance of the TextWriterAppender class and sets the output destination to a new Online StreamWriter initialized with the specified Online Stream.
Public method | TextWriterAppender(ILayout, TextWriter) | Obsolete. Initializes a new instance of the TextWriterAppender class and sets the output destination to the specified Online StreamWriter.
Back to Top
See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender Constructor

TextWriterAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the TextWriterAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextWriterAppender()
public TextWriterAppender()
Public Sub New
Public Sub New
public:
TextWriterAppender()
public:
TextWriterAppender()
Remarks

            Default constructor.

See Also
TextWriterAppender Class
TextWriterAppender Members
TextWriterAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender Constructor (ILayout, Stream)

TextWriterAppender Constructor (ILayout, Stream) Apache log4net™ SDK Documentation
Initializes a new instance of the TextWriterAppender class and sets the output destination to a new Online StreamWriter initialized with the specified Online Stream.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Instead use the default constructor and set the Layout & Writer properties")]
public TextWriterAppender(
    ILayout layout,
    Stream os
)
[ObsoleteAttribute("Instead use the default constructor and set the Layout & Writer properties")]
public TextWriterAppender(
    ILayout layout,
    Stream os
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout & Writer properties")>
Public Sub New (
    layout As ILayout,
    os As Stream
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout & Writer properties")>
Public Sub New (
    layout As ILayout,
    os As Stream
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout & Writer properties")]
TextWriterAppender(
    ILayout^ layout,
    Stream^ os
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout & Writer properties")]
TextWriterAppender(
    ILayout^ layout,
    Stream^ os
)
Parameters
layout
Type: log4net.Layout ILayout
The layout to use with this appender.
os
Type:   Online System.IO Stream
The   Online Stream to output to.
Remarks

            Obsolete constructor.

See Also
TextWriterAppender Class
TextWriterAppender Members
TextWriterAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender Constructor (ILayout, TextWriter)

TextWriterAppender Constructor (ILayout, TextWriter) Apache log4net™ SDK Documentation
Initializes a new instance of the TextWriterAppender class and sets the output destination to the specified Online StreamWriter.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Instead use the default constructor and set the Layout & Writer properties")]
public TextWriterAppender(
    ILayout layout,
    TextWriter writer
)
[ObsoleteAttribute("Instead use the default constructor and set the Layout & Writer properties")]
public TextWriterAppender(
    ILayout layout,
    TextWriter writer
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout & Writer properties")>
Public Sub New (
    layout As ILayout,
    writer As TextWriter
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout & Writer properties")>
Public Sub New (
    layout As ILayout,
    writer As TextWriter
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout & Writer properties")]
TextWriterAppender(
    ILayout^ layout,
    TextWriter^ writer
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout & Writer properties")]
TextWriterAppender(
    ILayout^ layout,
    TextWriter^ writer
)
Parameters
layout
Type: log4net.Layout ILayout
The layout to use with this appender
writer
Type:   Online System.IO TextWriter
The   Online TextWriter to output to
Remarks

            The   Online TextWriter must have been previously opened.

Remarks

            Obsolete constructor.

See Also
TextWriterAppender Class
TextWriterAppender Members
TextWriterAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender Methods

TextWriterAppender Methods Apache log4net™ SDK Documentation
The TextWriterAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | This method is called by the DoAppend( LoggingEvent ) method. (Overrides AppenderSkeleton Append( LoggingEvent ).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Protected method | CloseWriter | Closes the underlying Online TextWriter.
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Close this appender instance. The underlying stream or writer is also closed. (Overrides AppenderSkeleton OnClose .)
Protected method | PreAppendCheck | This method determines if there is a sense in attempting to append. (Overrides AppenderSkeleton PreAppendCheck .)
Protected method | PrepareWriter | Called to allow a subclass to lazily initialize the writer
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | Reset | Clears internal references to the underlying Online TextWriter and other variables.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Protected method | WriteFooter | Writes a footer as produced by the embedded layout's Footer property.
Protected method | WriteFooterAndCloseWriter | Writes the footer and closes the underlying Online TextWriter.
Protected method | WriteHeader | Writes a header produced by the embedded layout's Header property.
Back to Top
See Also
TextWriterAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.Append Method

TextWriterAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Protected method | Append( LoggingEvent ) | This method is called by the DoAppend( LoggingEvent ) method. (Overrides AppenderSkeleton Append( LoggingEvent ).)
Back to Top
See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.Append Method (LoggingEvent)

TextWriterAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Writes a log statement to the output stream if the output stream exists
            and is writable.

            The format of the output will depend on the appender's layout.

See Also
TextWriterAppender Class
TextWriterAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.Append Method (LoggingEvent[])

TextWriterAppender Append Method ( LoggingEvent ) Apache log4net™ SDK Documentation
This method is called by the DoAppend( LoggingEvent ) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent[] loggingEvents
)
protected override void Append(
    LoggingEvent[] loggingEvents
)
Protected Overrides Sub Append (
    loggingEvents As LoggingEvent()
)
Protected Overrides Sub Append (
    loggingEvents As LoggingEvent()
)
protected:
virtual void Append(
    array<LoggingEvent^>^ loggingEvents
) override
protected:
virtual void Append(
    array<LoggingEvent^>^ loggingEvents
) override
Parameters
loggingEvents
Type:  log4net.Core LoggingEvent
The array of events to log.
Remarks

            This method writes all the bulk logged events to the output writer
            before flushing the stream.

See Also
TextWriterAppender Class
TextWriterAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.CloseWriter Method

TextWriterAppender CloseWriter Method Apache log4net™ SDK Documentation
Closes the underlying Online TextWriter.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void CloseWriter()
protected virtual void CloseWriter()
Protected Overridable Sub CloseWriter
Protected Overridable Sub CloseWriter
protected:
virtual void CloseWriter()
protected:
virtual void CloseWriter()
Remarks

            Closes the underlying   Online TextWriter.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.OnClose Method

TextWriterAppender OnClose Method Apache log4net™ SDK Documentation
Close this appender instance. The underlying stream or writer is also closed.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void OnClose()
protected override void OnClose()
Protected Overrides Sub OnClose
Protected Overrides Sub OnClose
protected:
virtual void OnClose() override
protected:
virtual void OnClose() override
Remarks

            Closed appenders cannot be reused.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.PreAppendCheck Method

TextWriterAppender PreAppendCheck Method Apache log4net™ SDK Documentation
This method determines if there is a sense in attempting to append.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool PreAppendCheck()
protected override bool PreAppendCheck()
Protected Overrides Function PreAppendCheck As Boolean
Protected Overrides Function PreAppendCheck As Boolean
protected:
virtual bool PreAppendCheck() override
protected:
virtual bool PreAppendCheck() override
Return Value
Type:   Online Boolean
false if any of the preconditions fail.
Remarks

            This method checks if an output target has been set and if a
            layout has been set.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.PrepareWriter Method

TextWriterAppender PrepareWriter Method Apache log4net™ SDK Documentation
Called to allow a subclass to lazily initialize the writer

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void PrepareWriter()
protected virtual void PrepareWriter()
Protected Overridable Sub PrepareWriter
Protected Overridable Sub PrepareWriter
protected:
virtual void PrepareWriter()
protected:
virtual void PrepareWriter()
Remarks

            This method is called when an event is logged and the Writer or
            QuietWriter have not been set. This allows a subclass to
            attempt to initialize the writer multiple times.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.Reset Method

TextWriterAppender Reset Method Apache log4net™ SDK Documentation
Clears internal references to the underlying Online TextWriter and other variables.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void Reset()
protected virtual void Reset()
Protected Overridable Sub Reset
Protected Overridable Sub Reset
protected:
virtual void Reset()
protected:
virtual void Reset()
Remarks

            Subclasses can override this method for an alternate closing behavior.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.WriteFooter Method

TextWriterAppender WriteFooter Method Apache log4net™ SDK Documentation
Writes a footer as produced by the embedded layout's Footer property.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void WriteFooter()
protected virtual void WriteFooter()
Protected Overridable Sub WriteFooter
Protected Overridable Sub WriteFooter
protected:
virtual void WriteFooter()
protected:
virtual void WriteFooter()
Remarks

            Writes a footer as produced by the embedded layout's Footer property.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.WriteFooterAndCloseWriter Method

TextWriterAppender WriteFooterAndCloseWriter Method Apache log4net™ SDK Documentation
Writes the footer and closes the underlying Online TextWriter.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void WriteFooterAndCloseWriter()
protected virtual void WriteFooterAndCloseWriter()
Protected Overridable Sub WriteFooterAndCloseWriter
Protected Overridable Sub WriteFooterAndCloseWriter
protected:
virtual void WriteFooterAndCloseWriter()
protected:
virtual void WriteFooterAndCloseWriter()
Remarks

            Writes the footer and closes the underlying   Online TextWriter.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.WriteHeader Method

TextWriterAppender WriteHeader Method Apache log4net™ SDK Documentation
Writes a header produced by the embedded layout's Header property.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void WriteHeader()
protected virtual void WriteHeader()
Protected Overridable Sub WriteHeader
Protected Overridable Sub WriteHeader
protected:
virtual void WriteHeader()
protected:
virtual void WriteHeader()
Remarks

            Writes a header produced by the embedded layout's Header property.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender Properties

TextWriterAppender Properties Apache log4net™ SDK Documentation
The TextWriterAppender type exposes the following members.
Properties
 | Name | Description
Public property | ErrorHandler | Gets or set the IErrorHandler and the underlying QuietTextWriter, if any, for this appender. (Overrides AppenderSkeleton ErrorHandler.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | ImmediateFlush | Gets or set whether the appender will flush at the end of each append operation.
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | QuietWriter | Gets or sets the QuietTextWriter where logging events will be written to.
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Public property | Writer | Sets the Online TextWriter where the log output will go.
Back to Top
See Also
TextWriterAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.ErrorHandler Property

TextWriterAppender ErrorHandler Property Apache log4net™ SDK Documentation
Gets or set the IErrorHandler and the underlying QuietTextWriter, if any, for this appender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IErrorHandler ErrorHandler { get; set; }
public override IErrorHandler ErrorHandler { get; set; }
Public Overrides Property ErrorHandler As IErrorHandler
    Get
    Set
Public Overrides Property ErrorHandler As IErrorHandler
    Get
    Set
public:
virtual property IErrorHandler^ ErrorHandler {
    IErrorHandler^ get () override;
    void set (IErrorHandler^ value) override;
}
public:
virtual property IErrorHandler^ ErrorHandler {
    IErrorHandler^ get () override;
    void set (IErrorHandler^ value) override;
}
Property Value
Type: IErrorHandler

            The IErrorHandler for this appender.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.ImmediateFlush Property

TextWriterAppender ImmediateFlush Property Apache log4net™ SDK Documentation
Gets or set whether the appender will flush at the end of each append operation.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ImmediateFlush { get; set; }
public bool ImmediateFlush { get; set; }
Public Property ImmediateFlush As Boolean
    Get
    Set
Public Property ImmediateFlush As Boolean
    Get
    Set
public:
property bool ImmediateFlush {
    bool get ();
    void set (bool value);
}
public:
property bool ImmediateFlush {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean

            The default behavior is to flush at the end of each
            append operation.

            If this option is set to false, then the underlying
            stream can defer persisting the logging event to a later
            time.

Remarks

            Avoiding the flush operation at the end of each append results in
            a performance gain of 10 to 20 percent. However, there is safety
            trade-off involved in skipping flushing. Indeed, when flushing is
            skipped, then it is likely that the last few log events will not
            be recorded on disk when the application exits. This is a high
            price to pay even for a 20% performance gain.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.QuietWriter Property

TextWriterAppender QuietWriter Property Apache log4net™ SDK Documentation
Gets or sets the QuietTextWriter where logging events will be written to.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected QuietTextWriter QuietWriter { get; set; }
protected QuietTextWriter QuietWriter { get; set; }
Protected Property QuietWriter As QuietTextWriter
    Get
    Set
Protected Property QuietWriter As QuietTextWriter
    Get
    Set
protected:
property QuietTextWriter^ QuietWriter {
    QuietTextWriter^ get ();
    void set (QuietTextWriter^ value);
}
protected:
property QuietTextWriter^ QuietWriter {
    QuietTextWriter^ get ();
    void set (QuietTextWriter^ value);
}
Property Value
Type: QuietTextWriter

            The QuietTextWriter where logging events are written.

Remarks

            This is the QuietTextWriter where logging events
            will be written to.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.RequiresLayout Property

TextWriterAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAppender.Writer Property

TextWriterAppender Writer Property Apache log4net™ SDK Documentation
Sets the Online TextWriter where the log output will go.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TextWriter Writer { get; set; }
public virtual TextWriter Writer { get; set; }
Public Overridable Property Writer As TextWriter
    Get
    Set
Public Overridable Property Writer As TextWriter
    Get
    Set
public:
virtual property TextWriter^ Writer {
    TextWriter^ get ();
    void set (TextWriter^ value);
}
public:
virtual property TextWriter^ Writer {
    TextWriter^ get ();
    void set (TextWriter^ value);
}
Property Value
Type:   Online TextWriter
Remarks

            The specified   Online TextWriter must be open and writable.

            The   Online TextWriter will be closed when the appender
            instance is closed.

Note: Logging to an unopened   Online TextWriter will fail.

See Also
TextWriterAppender Class
TextWriterAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TraceAppender Class

TraceAppender Class Apache log4net™ SDK Documentation
Appends log events to the Online Trace system.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender TraceAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TraceAppender : AppenderSkeleton
public class TraceAppender : AppenderSkeleton
Public Class TraceAppender
    Inherits AppenderSkeleton
Public Class TraceAppender
    Inherits AppenderSkeleton
public ref class TraceAppender : public AppenderSkeleton
public ref class TraceAppender : public AppenderSkeleton
Remarks

            The application configuration file can be used to control what listeners
            are actually used. See the MSDN documentation for the
              Online Trace class for details on configuring the
            trace system.

            Events are written using the System.Diagnostics.Trace.Write(string,string)
            method. The event's logger name is the default value for the category parameter
            of the Write method.

Compact Framework

            The Compact Framework does not support the   Online Trace
            class for any operation except Assert. When using the Compact Framework this
            appender will write to the   Online Debug system rather than
            the Trace system. This appender will therefore behave like the DebugAppender.

See Also
TraceAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TraceAppender Members

TraceAppender Members Apache log4net™ SDK Documentation
The TraceAppender type exposes the following members.
Constructors
 | Name | Description
Public method | TraceAppender | Initializes a new instance of the TraceAppender.
Public method | TraceAppender(ILayout) | Obsolete. Initializes a new instance of the TraceAppender with a specified layout.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Writes the logging event to the Online Trace system. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Category | The category parameter sent to the Trace method.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | ImmediateFlush | Gets or sets a value that indicates whether the appender will flush at the end of each write.
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
TraceAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TraceAppender Constructor

TraceAppender Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | TraceAppender | Initializes a new instance of the TraceAppender.
Public method | TraceAppender(ILayout) | Obsolete. Initializes a new instance of the TraceAppender with a specified layout.
Back to Top
See Also
TraceAppender Class
TraceAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TraceAppender Constructor

TraceAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the TraceAppender.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TraceAppender()
public TraceAppender()
Public Sub New
Public Sub New
public:
TraceAppender()
public:
TraceAppender()
Remarks

            Default constructor.

See Also
TraceAppender Class
TraceAppender Members
TraceAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TraceAppender Constructor (ILayout)

TraceAppender Constructor (ILayout) Apache log4net™ SDK Documentation
Initializes a new instance of the TraceAppender with a specified layout.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Instead use the default constructor and set the Layout property")]
public TraceAppender(
    ILayout layout
)
[ObsoleteAttribute("Instead use the default constructor and set the Layout property")]
public TraceAppender(
    ILayout layout
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout property")>
Public Sub New (
    layout As ILayout
)
<ObsoleteAttribute("Instead use the default constructor and set the Layout property")>
Public Sub New (
    layout As ILayout
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout property")]
TraceAppender(
    ILayout^ layout
)
public:
[ObsoleteAttribute(L"Instead use the default constructor and set the Layout property")]
TraceAppender(
    ILayout^ layout
)
Parameters
layout
Type: log4net.Layout ILayout
The layout to use with this appender.
Remarks

            Obsolete constructor.

See Also
TraceAppender Class
TraceAppender Members
TraceAppender Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TraceAppender Methods

TraceAppender Methods Apache log4net™ SDK Documentation
The TraceAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set (Inherited from AppenderSkeleton.)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Writes the logging event to the Online Trace system. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Is called when the appender is closed. Derived classes should override this method if resources need to be released. (Inherited from AppenderSkeleton.)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TraceAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TraceAppender.Append Method

TraceAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | Writes the logging event to the Online Trace system. (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
TraceAppender Class
TraceAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TraceAppender.Append Method (LoggingEvent)

TraceAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
Writes the logging event to the Online Trace system.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Writes the logging event to the   Online Trace system.

See Also
TraceAppender Class
TraceAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TraceAppender Properties

TraceAppender Properties Apache log4net™ SDK Documentation
The TraceAppender type exposes the following members.
Properties
 | Name | Description
Public property | Category | The category parameter sent to the Trace method.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | ImmediateFlush | Gets or sets a value that indicates whether the appender will flush at the end of each write.
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
TraceAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TraceAppender.Category Property

TraceAppender Category Property Apache log4net™ SDK Documentation
The category parameter sent to the Trace method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PatternLayout Category { get; set; }
public PatternLayout Category { get; set; }
Public Property Category As PatternLayout
    Get
    Set
Public Property Category As PatternLayout
    Get
    Set
public:
property PatternLayout^ Category {
    PatternLayout^ get ();
    void set (PatternLayout^ value);
}
public:
property PatternLayout^ Category {
    PatternLayout^ get ();
    void set (PatternLayout^ value);
}
Property Value
Type: PatternLayout
Remarks

            Defaults to %logger which will use the logger name of the current
            LoggingEvent as the category parameter.

See Also
TraceAppender Class
TraceAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TraceAppender.ImmediateFlush Property

TraceAppender ImmediateFlush Property Apache log4net™ SDK Documentation
Gets or sets a value that indicates whether the appender will flush at the end of each write.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ImmediateFlush { get; set; }
public bool ImmediateFlush { get; set; }
Public Property ImmediateFlush As Boolean
    Get
    Set
Public Property ImmediateFlush As Boolean
    Get
    Set
public:
property bool ImmediateFlush {
    bool get ();
    void set (bool value);
}
public:
property bool ImmediateFlush {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
Remarks
The default behavior is to flush at the end of each
            write. If the option is set tofalse, then the underlying
            stream can defer writing to physical medium to a later time.

            Avoiding the flush operation at the end of each append results
            in a performance gain of 10 to 20 percent. However, there is safety
            trade-off involved in skipping flushing. Indeed, when flushing is
            skipped, then it is likely that the last few log events will not
            be recorded on disk when the application exits. This is a high
            price to pay even for a 20% performance gain.

See Also
TraceAppender Class
TraceAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TraceAppender.RequiresLayout Property

TraceAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
TraceAppender Class
TraceAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender Class

UdpAppender Class Apache log4net™ SDK Documentation
Sends logging events as connectionless UDP datagrams to a remote host or a multicast group using an Online UdpClient.
Inheritance Hierarchy
Online System Object
log4net.Appender AppenderSkeleton
log4net.Appender UdpAppender
log4net.Appender RemoteSyslogAppender

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class UdpAppender : AppenderSkeleton
public class UdpAppender : AppenderSkeleton
Public Class UdpAppender
    Inherits AppenderSkeleton
Public Class UdpAppender
    Inherits AppenderSkeleton
public ref class UdpAppender : public AppenderSkeleton
public ref class UdpAppender : public AppenderSkeleton
Remarks

             UDP guarantees neither that messages arrive, nor that they arrive in the correct order.

             To view the logging results, a custom application can be developed that listens for logging
             events.

             When decoding events send via this appender remember to use the same encoding
             to decode the events as was used to send the events. See the Encoding
             property to specify the encoding to use.

Examples

             This example shows how to log receive logging events that are sent
             on IP address 244.0.0.1 and port 8080 to the console. The event is
             encoded in the packet as a unicode string and it is decoded as such.

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IPEndPoint remoteEndPoint = new IPEndPoint(IPAddress.Any, 0);
UdpClient udpClient;
byte[] buffer;
string loggingEvent;

try
{
    udpClient = new UdpClient(8080);

    while(true)
    {
        buffer = udpClient.Receive(ref remoteEndPoint);
        loggingEvent = System.Text.Encoding.Unicode.GetString(buffer);
        Console.WriteLine(loggingEvent);
    }
}
catch(Exception e)
{
    Console.WriteLine(e.ToString());
}
IPEndPoint remoteEndPoint = new IPEndPoint(IPAddress.Any, 0);
UdpClient udpClient;
byte[] buffer;
string loggingEvent;

try
{
    udpClient = new UdpClient(8080);

    while(true)
    {
        buffer = udpClient.Receive(ref remoteEndPoint);
        loggingEvent = System.Text.Encoding.Unicode.GetString(buffer);
        Console.WriteLine(loggingEvent);
    }
}
catch(Exception e)
{
    Console.WriteLine(e.ToString());
}
View Colorized Copy to Clipboard Print
Dim remoteEndPoint as IPEndPoint
Dim udpClient as UdpClient
Dim buffer as Byte()
Dim loggingEvent as String

Try
    remoteEndPoint = new IPEndPoint(IPAddress.Any, 0)
    udpClient = new UdpClient(8080)

    While True
        buffer = udpClient.Receive(ByRef remoteEndPoint)
        loggingEvent = System.Text.Encoding.Unicode.GetString(buffer)
        Console.WriteLine(loggingEvent)
    Wend
Catch e As Exception
    Console.WriteLine(e.ToString())
End Try
Dim remoteEndPoint as IPEndPoint
Dim udpClient as UdpClient
Dim buffer as Byte()
Dim loggingEvent as String

Try
    remoteEndPoint = new IPEndPoint(IPAddress.Any, 0)
    udpClient = new UdpClient(8080)

    While True
        buffer = udpClient.Receive(ByRef remoteEndPoint)
        loggingEvent = System.Text.Encoding.Unicode.GetString(buffer)
        Console.WriteLine(loggingEvent)
    Wend
Catch e As Exception
    Console.WriteLine(e.ToString())
End Try

             An example configuration section to log information using this appender to the
             IP 224.0.0.1 on port 8080:

XML
View Colorized Copy to Clipboard Print
<appender name="UdpAppender" type="log4net.Appender.UdpAppender"><remoteAddress value="224.0.0.1" /><remotePort value="8080" /><layout type="log4net.Layout.PatternLayout" value="%-5level %logger [%ndc] - %message%newline" /></appender>
<appender name="UdpAppender" type="log4net.Appender.UdpAppender"><remoteAddress value="224.0.0.1" /><remotePort value="8080" /><layout type="log4net.Layout.PatternLayout" value="%-5level %logger [%ndc] - %message%newline" /></appender>
See Also
UdpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender Members

UdpAppender Members Apache log4net™ SDK Documentation
The UdpAppender type exposes the following members.
Constructors
 | Name | Description
Public method | UdpAppender | Initializes a new instance of the UdpAppender class.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set. (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitializeClientConnection | Initializes the underlying Online UdpClient connection.
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Closes the UDP connection and releases all resources associated with this UdpAppender instance. (Overrides AppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Protected property | Client | Gets or sets the underlying Online UdpClient.
Public property | Encoding | Gets or sets Encoding used to write the packets.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | LocalPort | Gets or sets the TCP port number from which the underlying Online UdpClient will communicate.
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | RemoteAddress | Gets or sets the IP address of the remote host or multicast group to which the underlying Online UdpClient should sent the logging event.
Protected property | RemoteEndPoint | Gets or sets the cached remote endpoint to which the logging events should be sent.
Public property | RemotePort | Gets or sets the TCP port number of the remote host or multicast group to which the underlying Online UdpClient should sent the logging event.
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
UdpAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender Constructor

UdpAppender Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the UdpAppender class.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UdpAppender()
public UdpAppender()
Public Sub New
Public Sub New
public:
UdpAppender()
public:
UdpAppender()
Remarks

            The default constructor initializes all fields to their default values.

See Also
UdpAppender Class
UdpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender Methods

UdpAppender Methods Apache log4net™ SDK Documentation
The UdpAppender type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the appender based on the options set. (Overrides AppenderSkeleton ActivateOptions .)
Public method | AddFilter | Adds a filter to the end of the filter chain. (Inherited from AppenderSkeleton.)
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Public method | ClearFilters | Clears the filter list for this appender. (Inherited from AppenderSkeleton.)
Public method | Close | Closes the appender and release resources. (Inherited from AppenderSkeleton.)
Public method | DoAppend(LoggingEvent) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent)] method. (Inherited from AppenderSkeleton.)
Public method | DoAppend( LoggingEvent ) | Performs threshold checks and invokes filters before delegating actual logging to the subclasses specific [M:Append(LoggingEvent[])] method. (Inherited from AppenderSkeleton.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | FilterEvent | Test if the logging event should we output by this appender (Inherited from AppenderSkeleton.)
Protected method | Finalize | Finalizes this appender by calling the implementation's Close method. (Inherited from AppenderSkeleton.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitializeClientConnection | Initializes the underlying Online UdpClient connection.
Protected method | IsAsSevereAsThreshold | Checks if the message level is below this appender's threshold. (Inherited from AppenderSkeleton.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnClose | Closes the UDP connection and releases all resources associated with this UdpAppender instance. (Overrides AppenderSkeleton OnClose .)
Protected method | PreAppendCheck | Called before [M:Append(LoggingEvent)] as a precondition. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Protected method | RenderLoggingEvent(TextWriter, LoggingEvent) | Renders the LoggingEvent to a string. (Inherited from AppenderSkeleton.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
UdpAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender.ActivateOptions Method

UdpAppender ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the appender based on the options set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Exceptions
Exception | Condition
Online System ArgumentNullException | The required property RemoteAddress was not specified.
Online System ArgumentOutOfRangeException | The TCP port number assigned to LocalPort or RemotePort is less than Online MinPort or greater than Online MaxPort.
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

            The appender will be ignored if no RemoteAddress was specified or
            an invalid remote or local TCP port number was specified.

See Also
UdpAppender Class
UdpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender.Append Method

UdpAppender Append Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Append( LoggingEvent ) | Append a bulk array of logging events. (Inherited from AppenderSkeleton.)
Protected method | Append(LoggingEvent) | This method is called by the DoAppend(LoggingEvent) method. (Overrides AppenderSkeleton Append(LoggingEvent).)
Back to Top
See Also
UdpAppender Class
UdpAppender Members
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender.Append Method (LoggingEvent)

UdpAppender Append Method (LoggingEvent) Apache log4net™ SDK Documentation
This method is called by the DoAppend(LoggingEvent) method.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Append(
    LoggingEvent loggingEvent
)
protected override void Append(
    LoggingEvent loggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
Protected Overrides Sub Append (
    loggingEvent As LoggingEvent
)
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
protected:
virtual void Append(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Sends the event using an UDP datagram.

            Exceptions are passed to the ErrorHandler.

See Also
UdpAppender Class
UdpAppender Members
Append Overload
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender.InitializeClientConnection Method

UdpAppender InitializeClientConnection Method Apache log4net™ SDK Documentation
Initializes the underlying Online UdpClient connection.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void InitializeClientConnection()
protected virtual void InitializeClientConnection()
Protected Overridable Sub InitializeClientConnection
Protected Overridable Sub InitializeClientConnection
protected:
virtual void InitializeClientConnection()
protected:
virtual void InitializeClientConnection()
Remarks

            The underlying   Online UdpClient is initialized and binds to the
            port number from which you intend to communicate.

            Exceptions are passed to the ErrorHandler.

See Also
UdpAppender Class
UdpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender.OnClose Method

UdpAppender OnClose Method Apache log4net™ SDK Documentation
Closes the UDP connection and releases all resources associated with this UdpAppender instance.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void OnClose()
protected override void OnClose()
Protected Overrides Sub OnClose
Protected Overrides Sub OnClose
protected:
virtual void OnClose() override
protected:
virtual void OnClose() override
Remarks

            Disables the underlying   Online UdpClient and releases all managed
            and unmanaged resources associated with the UdpAppender.

See Also
UdpAppender Class
UdpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender Properties

UdpAppender Properties Apache log4net™ SDK Documentation
The UdpAppender type exposes the following members.
Properties
 | Name | Description
Protected property | Client | Gets or sets the underlying Online UdpClient.
Public property | Encoding | Gets or sets Encoding used to write the packets.
Public property | ErrorHandler | Gets or sets the IErrorHandler for this appender. (Inherited from AppenderSkeleton.)
Public property | FilterHead | The filter chain. (Inherited from AppenderSkeleton.)
Public property | Layout | Gets or sets the ILayout for this appender. (Inherited from AppenderSkeleton.)
Public property | LocalPort | Gets or sets the TCP port number from which the underlying Online UdpClient will communicate.
Public property | Name | Gets or sets the name of this appender. (Inherited from AppenderSkeleton.)
Public property | RemoteAddress | Gets or sets the IP address of the remote host or multicast group to which the underlying Online UdpClient should sent the logging event.
Protected property | RemoteEndPoint | Gets or sets the cached remote endpoint to which the logging events should be sent.
Public property | RemotePort | Gets or sets the TCP port number of the remote host or multicast group to which the underlying Online UdpClient should sent the logging event.
Protected property | RequiresLayout | This appender requires a log4net.Layout to be set. (Overrides AppenderSkeleton RequiresLayout.)
Public property | Threshold | Gets or sets the threshold Level of this appender. (Inherited from AppenderSkeleton.)
Back to Top
See Also
UdpAppender Class
log4net.Appender Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender.Client Property

UdpAppender Client Property Apache log4net™ SDK Documentation
Gets or sets the underlying Online UdpClient.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected UdpClient Client { get; set; }
protected UdpClient Client { get; set; }
Protected Property Client As UdpClient
    Get
    Set
Protected Property Client As UdpClient
    Get
    Set
protected:
property UdpClient^ Client {
    UdpClient^ get ();
    void set (UdpClient^ value);
}
protected:
property UdpClient^ Client {
    UdpClient^ get ();
    void set (UdpClient^ value);
}
Property Value
Type:   Online UdpClient

            The underlying   Online UdpClient.

Remarks
UdpAppender creates a   Online UdpClient to send logging events
            over a network.  Classes deriving from UdpAppender can use this
            property to get or set this   Online UdpClient.  Use the underlying   Online UdpClient
            returned from Client if you require access beyond that which
            UdpAppender provides.

See Also
UdpAppender Class
UdpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender.Encoding Property

UdpAppender Encoding Property Apache log4net™ SDK Documentation
Gets or sets Encoding used to write the packets.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Encoding Encoding { get; set; }
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set
Public Property Encoding As Encoding
    Get
    Set
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
Property Value
Type:   Online Encoding

            The Encoding used to write the packets.

Remarks

            The Encoding used to write the packets.

See Also
UdpAppender Class
UdpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender.LocalPort Property

UdpAppender LocalPort Property Apache log4net™ SDK Documentation
Gets or sets the TCP port number from which the underlying Online UdpClient will communicate.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int LocalPort { get; set; }
public int LocalPort { get; set; }
Public Property LocalPort As Integer
    Get
    Set
Public Property LocalPort As Integer
    Get
    Set
public:
property int LocalPort {
    int get ();
    void set (int value);
}
public:
property int LocalPort {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32

            An integer value in the range   Online MinPort to   Online MaxPort
            indicating the TCP port number from which the underlying   Online UdpClient will communicate.

Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | The value specified is less than Online MinPort or greater than Online MaxPort.
Remarks

            The underlying   Online UdpClient will bind to this port for sending messages.

            Setting the value to 0 (the default) will cause the udp client not to bind to
            a local port.

See Also
UdpAppender Class
UdpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender.RemoteAddress Property

UdpAppender RemoteAddress Property Apache log4net™ SDK Documentation
Gets or sets the IP address of the remote host or multicast group to which the underlying Online UdpClient should sent the logging event.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPAddress RemoteAddress { get; set; }
public IPAddress RemoteAddress { get; set; }
Public Property RemoteAddress As IPAddress
    Get
    Set
Public Property RemoteAddress As IPAddress
    Get
    Set
public:
property IPAddress^ RemoteAddress {
    IPAddress^ get ();
    void set (IPAddress^ value);
}
public:
property IPAddress^ RemoteAddress {
    IPAddress^ get ();
    void set (IPAddress^ value);
}
Property Value
Type:   Online IPAddress

            The IP address of the remote host or multicast group to which the logging event
            will be sent.

Remarks

            Multicast addresses are identified by IP class D addresses (in the range 224.0.0.0 to
            239.255.255.255).  Multicast packets can pass across different networks through routers, so
            it is possible to use multicasts in an Internet scenario as long as your network provider
            supports multicasting.

            Hosts that want to receive particular multicast messages must register their interest by joining
            the multicast group.  Multicast messages are not sent to networks where no host has joined
            the multicast group.  Class D IP addresses are used for multicast groups, to differentiate
            them from normal host addresses, allowing nodes to easily detect if a message is of interest.

            Static multicast addresses that are needed globally are assigned by IANA.  A few examples are listed in the table below:

IP Address | Description
224.0.0.1 | Sends a message to all system on the subnet.
224.0.0.2 | Sends a message to all routers on the subnet.
224.0.0.12 | The DHCP server answers messages on the IP address 224.0.0.12, but only on a subnet.

            A complete list of actually reserved multicast addresses and their owners in the ranges
            defined by RFC 3171 can be found at the IANA web site.

            The address range 239.0.0.0 to 239.255.255.255 is reserved for administrative scope-relative
            addresses.  These addresses can be reused with other local groups.  Routers are typically
            configured with filters to prevent multicast traffic in this range from flowing outside
            of the local network.

See Also
UdpAppender Class
UdpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender.RemoteEndPoint Property

UdpAppender RemoteEndPoint Property Apache log4net™ SDK Documentation
Gets or sets the cached remote endpoint to which the logging events should be sent.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IPEndPoint RemoteEndPoint { get; set; }
protected IPEndPoint RemoteEndPoint { get; set; }
Protected Property RemoteEndPoint As IPEndPoint
    Get
    Set
Protected Property RemoteEndPoint As IPEndPoint
    Get
    Set
protected:
property IPEndPoint^ RemoteEndPoint {
    IPEndPoint^ get ();
    void set (IPEndPoint^ value);
}
protected:
property IPEndPoint^ RemoteEndPoint {
    IPEndPoint^ get ();
    void set (IPEndPoint^ value);
}
Property Value
Type:   Online IPEndPoint

            The cached remote endpoint to which the logging events will be sent.

Remarks

            The ActivateOptions  method will initialize the remote endpoint
            with the values of the RemoteAddress and RemotePort
            properties.

See Also
UdpAppender Class
UdpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender.RemotePort Property

UdpAppender RemotePort Property Apache log4net™ SDK Documentation
Gets or sets the TCP port number of the remote host or multicast group to which the underlying Online UdpClient should sent the logging event.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int RemotePort { get; set; }
public int RemotePort { get; set; }
Public Property RemotePort As Integer
    Get
    Set
Public Property RemotePort As Integer
    Get
    Set
public:
property int RemotePort {
    int get ();
    void set (int value);
}
public:
property int RemotePort {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32

            An integer value in the range   Online MinPort to   Online MaxPort
            indicating the TCP port number of the remote host or multicast group to which the logging event
            will be sent.

Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | The value specified is less than Online MinPort or greater than Online MaxPort.
Remarks

            The underlying   Online UdpClient will send messages to this TCP port number
            on the remote host or multicast group.

See Also
UdpAppender Class
UdpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


UdpAppender.RequiresLayout Property

UdpAppender RequiresLayout Property Apache log4net™ SDK Documentation
This appender requires a log4net.Layout to be set.

Namespace: log4net.Appender
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool RequiresLayout { get; }
protected override bool RequiresLayout { get; }
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
Protected Overrides ReadOnly Property RequiresLayout As Boolean
    Get
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
protected:
virtual property bool RequiresLayout {
    bool get () override;
}
Property Value
Type:   Online Boolean
true
Remarks

            This appender requires a log4net.Layout to be set.

See Also
UdpAppender Class
UdpAppender Members
log4net.Appender Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.Config Namespace

log4net.Config Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | AliasDomainAttribute | Obsolete. Assembly level attribute that specifies a domain to alias to this assembly's repository.
Public class | AliasRepositoryAttribute | Assembly level attribute that specifies a repository to alias to this assembly's repository.
Public class | BasicConfigurator | Use this class to quickly configure a Hierarchy.
Public class | ConfiguratorAttribute | Base class for all log4net configuration attributes.
Public class | DomainAttribute | Obsolete. Assembly level attribute that specifies the logging domain for the assembly.
Public class | DOMConfigurator | Obsolete. Use this class to initialize the log4net environment using an Xml tree.
Public class | DOMConfiguratorAttribute | Obsolete. Assembly level attribute to configure the XmlConfigurator.
Public class | Log4NetConfigurationSectionHandler | Class to register for the log4net section of the configuration file
Public class | PluginAttribute | Assembly level attribute that specifies a plugin to attach to the repository.
Public class | RepositoryAttribute | Assembly level attribute that specifies the logging repository for the assembly.
Public class | SecurityContextProviderAttribute | Assembly level attribute to configure the SecurityContextProvider.
Public class | XmlConfigurator | Use this class to initialize the log4net environment using an Xml tree.
Public class | XmlConfiguratorAttribute | Assembly level attribute to configure the XmlConfigurator.

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AliasDomainAttribute Class

AliasDomainAttribute Class Apache log4net™ SDK Documentation
Assembly level attribute that specifies a domain to alias to this assembly's repository.
Inheritance Hierarchy
Online System Object
Online System Attribute
log4net.Config AliasRepositoryAttribute
log4net.Config AliasDomainAttribute

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
[ObsoleteAttribute("Use AliasRepositoryAttribute instead of AliasDomainAttribute")]
public sealed class AliasDomainAttribute : AliasRepositoryAttribute
[SerializableAttribute]
[ObsoleteAttribute("Use AliasRepositoryAttribute instead of AliasDomainAttribute")]
public sealed class AliasDomainAttribute : AliasRepositoryAttribute
<SerializableAttribute>
<ObsoleteAttribute("Use AliasRepositoryAttribute instead of AliasDomainAttribute")>
Public NotInheritable Class AliasDomainAttribute
    Inherits AliasRepositoryAttribute
<SerializableAttribute>
<ObsoleteAttribute("Use AliasRepositoryAttribute instead of AliasDomainAttribute")>
Public NotInheritable Class AliasDomainAttribute
    Inherits AliasRepositoryAttribute
[SerializableAttribute]
[ObsoleteAttribute(L"Use AliasRepositoryAttribute instead of AliasDomainAttribute")]
public ref class AliasDomainAttribute sealed : public AliasRepositoryAttribute
[SerializableAttribute]
[ObsoleteAttribute(L"Use AliasRepositoryAttribute instead of AliasDomainAttribute")]
public ref class AliasDomainAttribute sealed : public AliasRepositoryAttribute
Remarks
AliasDomainAttribute is obsolete. Use AliasRepositoryAttribute instead of AliasDomainAttribute.

            An assembly's logger repository is defined by its DomainAttribute,
            however this can be overridden by an assembly loaded before the target assembly.

            An assembly can alias another assembly's domain to its repository by
            specifying this attribute with the name of the target domain.

            This attribute can only be specified on the assembly and may be used
            as many times as necessary to alias all the required domains.

See Also
AliasDomainAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AliasDomainAttribute Members

AliasDomainAttribute Members Apache log4net™ SDK Documentation
The AliasDomainAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | AliasDomainAttribute | Initializes a new instance of the AliasDomainAttribute class with the specified domain to alias to this assembly's repository.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Name | Gets or sets the repository to alias to this assemby's repository. (Inherited from AliasRepositoryAttribute.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
AliasDomainAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AliasDomainAttribute Constructor

AliasDomainAttribute Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the AliasDomainAttribute class with the specified domain to alias to this assembly's repository.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AliasDomainAttribute(
    string name
)
public AliasDomainAttribute(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
AliasDomainAttribute(
    String^ name
)
public:
AliasDomainAttribute(
    String^ name
)
Parameters
name
Type:   Online System String
The domain to alias to this assemby's repository.
Remarks

            Obsolete. Use AliasRepositoryAttribute instead of AliasDomainAttribute.

See Also
AliasDomainAttribute Class
AliasDomainAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AliasDomainAttribute Methods

AliasDomainAttribute Methods Apache log4net™ SDK Documentation
The AliasDomainAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AliasDomainAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AliasDomainAttribute Properties

AliasDomainAttribute Properties Apache log4net™ SDK Documentation
The AliasDomainAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Name | Gets or sets the repository to alias to this assemby's repository. (Inherited from AliasRepositoryAttribute.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
AliasDomainAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AliasRepositoryAttribute Class

AliasRepositoryAttribute Class Apache log4net™ SDK Documentation
Assembly level attribute that specifies a repository to alias to this assembly's repository.
Inheritance Hierarchy
Online System Object
Online System Attribute
log4net.Config AliasRepositoryAttribute
log4net.Config AliasDomainAttribute

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AliasRepositoryAttribute : Attribute
[SerializableAttribute]
public class AliasRepositoryAttribute : Attribute
<SerializableAttribute>
Public Class AliasRepositoryAttribute
    Inherits Attribute
<SerializableAttribute>
Public Class AliasRepositoryAttribute
    Inherits Attribute
[SerializableAttribute]
public ref class AliasRepositoryAttribute : public Attribute
[SerializableAttribute]
public ref class AliasRepositoryAttribute : public Attribute
Remarks

            An assembly's logger repository is defined by its RepositoryAttribute,
            however this can be overridden by an assembly loaded before the target assembly.

            An assembly can alias another assembly's repository to its repository by
            specifying this attribute with the name of the target repository.

            This attribute can only be specified on the assembly and may be used
            as many times as necessary to alias all the required repositories.

See Also
AliasRepositoryAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AliasRepositoryAttribute Members

AliasRepositoryAttribute Members Apache log4net™ SDK Documentation
The AliasRepositoryAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | AliasRepositoryAttribute | Initializes a new instance of the AliasRepositoryAttribute class with the specified repository to alias to this assembly's repository.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Name | Gets or sets the repository to alias to this assemby's repository.
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
AliasRepositoryAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AliasRepositoryAttribute Constructor

AliasRepositoryAttribute Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the AliasRepositoryAttribute class with the specified repository to alias to this assembly's repository.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AliasRepositoryAttribute(
    string name
)
public AliasRepositoryAttribute(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
AliasRepositoryAttribute(
    String^ name
)
public:
AliasRepositoryAttribute(
    String^ name
)
Parameters
name
Type:   Online System String
The repository to alias to this assemby's repository.
Remarks

            Initializes a new instance of the AliasRepositoryAttribute class with
            the specified repository to alias to this assembly's repository.

See Also
AliasRepositoryAttribute Class
AliasRepositoryAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AliasRepositoryAttribute Methods

AliasRepositoryAttribute Methods Apache log4net™ SDK Documentation
The AliasRepositoryAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AliasRepositoryAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AliasRepositoryAttribute Properties

AliasRepositoryAttribute Properties Apache log4net™ SDK Documentation
The AliasRepositoryAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Name | Gets or sets the repository to alias to this assemby's repository.
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
AliasRepositoryAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AliasRepositoryAttribute.Name Property

AliasRepositoryAttribute Name Property Apache log4net™ SDK Documentation
Gets or sets the repository to alias to this assemby's repository.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The repository to alias to this assemby's repository.

Remarks

            The name of the repository to alias to this assemby's repository.

See Also
AliasRepositoryAttribute Class
AliasRepositoryAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BasicConfigurator Class

BasicConfigurator Class Apache log4net™ SDK Documentation
Use this class to quickly configure a Hierarchy.
Inheritance Hierarchy
Online System Object
log4net.Config BasicConfigurator

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BasicConfigurator
public sealed class BasicConfigurator
Public NotInheritable Class BasicConfigurator
Public NotInheritable Class BasicConfigurator
public ref class BasicConfigurator sealed
public ref class BasicConfigurator sealed
Remarks

            Allows very simple programmatic configuration of log4net.

            Only one appender can be configured using this configurator.
            The appender is set at the root of the hierarchy and all logging
            events will be delivered to that appender.

            Appenders can also implement the IOptionHandler interface. Therefore
            they would require that the [M:log4net.Core.IOptionHandler.ActivateOptions()] method
            be called after the appenders properties have been configured.

See Also
BasicConfigurator Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BasicConfigurator Members

BasicConfigurator Members Apache log4net™ SDK Documentation
The BasicConfigurator type exposes the following members.
Methods
 | Name | Description
 | Configure | Initializes the log4net system with a default configuration.
 | Configure(IAppender) | Initializes the log4net system using the specified appender.
 | Configure( IAppender ) | Initializes the log4net system using the specified appenders.
 | Configure(ILoggerRepository) | Initializes the ILoggerRepository with a default configuration.
 | Configure(ILoggerRepository, IAppender) | Initializes the ILoggerRepository using the specified appender.
 | Configure(ILoggerRepository, IAppender ) | Initializes the ILoggerRepository using the specified appenders.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BasicConfigurator Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BasicConfigurator Methods

BasicConfigurator Methods Apache log4net™ SDK Documentation
The BasicConfigurator type exposes the following members.
Methods
 | Name | Description
 | Configure | Initializes the log4net system with a default configuration.
 | Configure(IAppender) | Initializes the log4net system using the specified appender.
 | Configure( IAppender ) | Initializes the log4net system using the specified appenders.
 | Configure(ILoggerRepository) | Initializes the ILoggerRepository with a default configuration.
 | Configure(ILoggerRepository, IAppender) | Initializes the ILoggerRepository using the specified appender.
 | Configure(ILoggerRepository, IAppender ) | Initializes the ILoggerRepository using the specified appenders.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BasicConfigurator Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BasicConfigurator.Configure Method

BasicConfigurator Configure Method Apache log4net™ SDK Documentation
Overload List
Name | Description
Configure | Initializes the log4net system with a default configuration.
Configure(IAppender) | Initializes the log4net system using the specified appender.
Configure( IAppender ) | Initializes the log4net system using the specified appenders.
Configure(ILoggerRepository) | Initializes the ILoggerRepository with a default configuration.
Configure(ILoggerRepository, IAppender) | Initializes the ILoggerRepository using the specified appender.
Configure(ILoggerRepository, IAppender ) | Initializes the ILoggerRepository using the specified appenders.
Back to Top
See Also
BasicConfigurator Class
BasicConfigurator Members
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BasicConfigurator.Configure Method

BasicConfigurator Configure Method Apache log4net™ SDK Documentation
Initializes the log4net system with a default configuration.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure()
public static ICollection Configure()
Public Shared Function Configure As ICollection
Public Shared Function Configure As ICollection
public:
static ICollection^ Configure()
public:
static ICollection^ Configure()
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.BasicConfigurator.Configure"]
Remarks

            Initializes the log4net logging system using a ConsoleAppender
            that will write to Console.Out. The log messages are
            formatted using the PatternLayout layout object
            with the DetailConversionPattern
            layout style.

See Also
BasicConfigurator Class
BasicConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BasicConfigurator.Configure Method (IAppender)

BasicConfigurator Configure Method (IAppender) Apache log4net™ SDK Documentation
Initializes the log4net system using the specified appender.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    IAppender appender
)
public static ICollection Configure(
    IAppender appender
)
Public Shared Function Configure (
    appender As IAppender
) As ICollection
Public Shared Function Configure (
    appender As IAppender
) As ICollection
public:
static ICollection^ Configure(
    IAppender^ appender
)
public:
static ICollection^ Configure(
    IAppender^ appender
)
Parameters
appender
Type: log4net.Appender IAppender
The appender to use to log all logging events.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.BasicConfigurator.Configure(log4net.Appender.IAppender)"]
Remarks

            Initializes the log4net system using the specified appender.

See Also
BasicConfigurator Class
BasicConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BasicConfigurator.Configure Method (IAppender[])

BasicConfigurator Configure Method ( IAppender ) Apache log4net™ SDK Documentation
Initializes the log4net system using the specified appenders.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    params IAppender[] appenders
)
public static ICollection Configure(
    params IAppender[] appenders
)
Public Shared Function Configure (
    ParamArray appenders As IAppender()
) As ICollection
Public Shared Function Configure (
    ParamArray appenders As IAppender()
) As ICollection
public:
static ICollection^ Configure(
    ... array<IAppender^>^ appenders
)
public:
static ICollection^ Configure(
    ... array<IAppender^>^ appenders
)
Parameters
appenders
Type:  log4net.Appender IAppender
The appenders to use to log all logging events.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.BasicConfigurator.Configure(log4net.Appender.IAppender[])"]
Remarks

            Initializes the log4net system using the specified appenders.

See Also
BasicConfigurator Class
BasicConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BasicConfigurator.Configure Method (ILoggerRepository)

BasicConfigurator Configure Method (ILoggerRepository) Apache log4net™ SDK Documentation
Initializes the ILoggerRepository with a default configuration.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    ILoggerRepository repository
)
public static ICollection Configure(
    ILoggerRepository repository
)
Public Shared Function Configure (
    repository As ILoggerRepository
) As ICollection
Public Shared Function Configure (
    repository As ILoggerRepository
) As ICollection
public:
static ICollection^ Configure(
    ILoggerRepository^ repository
)
public:
static ICollection^ Configure(
    ILoggerRepository^ repository
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.BasicConfigurator.Configure(log4net.Repository.ILoggerRepository)"]
Remarks

            Initializes the specified repository using a ConsoleAppender
            that will write to Console.Out. The log messages are
            formatted using the PatternLayout layout object
            with the DetailConversionPattern
            layout style.

See Also
BasicConfigurator Class
BasicConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BasicConfigurator.Configure Method (ILoggerRepository, IAppender)

BasicConfigurator Configure Method (ILoggerRepository, IAppender) Apache log4net™ SDK Documentation
Initializes the ILoggerRepository using the specified appender.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    ILoggerRepository repository,
    IAppender appender
)
public static ICollection Configure(
    ILoggerRepository repository,
    IAppender appender
)
Public Shared Function Configure (
    repository As ILoggerRepository,
    appender As IAppender
) As ICollection
Public Shared Function Configure (
    repository As ILoggerRepository,
    appender As IAppender
) As ICollection
public:
static ICollection^ Configure(
    ILoggerRepository^ repository,
    IAppender^ appender
)
public:
static ICollection^ Configure(
    ILoggerRepository^ repository,
    IAppender^ appender
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
appender
Type: log4net.Appender IAppender
The appender to use to log all logging events.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.BasicConfigurator.Configure(log4net.Repository.ILoggerRepository,log4net.Appender.IAppender)"]
Remarks

            Initializes the ILoggerRepository using the specified appender.

See Also
BasicConfigurator Class
BasicConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


BasicConfigurator.Configure Method (ILoggerRepository, IAppender[])

BasicConfigurator Configure Method (ILoggerRepository, IAppender ) Apache log4net™ SDK Documentation
Initializes the ILoggerRepository using the specified appenders.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    ILoggerRepository repository,
    params IAppender[] appenders
)
public static ICollection Configure(
    ILoggerRepository repository,
    params IAppender[] appenders
)
Public Shared Function Configure (
    repository As ILoggerRepository,
    ParamArray appenders As IAppender()
) As ICollection
Public Shared Function Configure (
    repository As ILoggerRepository,
    ParamArray appenders As IAppender()
) As ICollection
public:
static ICollection^ Configure(
    ILoggerRepository^ repository,
    ... array<IAppender^>^ appenders
)
public:
static ICollection^ Configure(
    ILoggerRepository^ repository,
    ... array<IAppender^>^ appenders
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
appenders
Type:  log4net.Appender IAppender
The appenders to use to log all logging events.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.BasicConfigurator.Configure(log4net.Repository.ILoggerRepository,log4net.Appender.IAppender[])"]
Remarks

            Initializes the ILoggerRepository using the specified appender.

See Also
BasicConfigurator Class
BasicConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfiguratorAttribute Class

ConfiguratorAttribute Class Apache log4net™ SDK Documentation
Base class for all log4net configuration attributes.
Inheritance Hierarchy
Online System Object
Online System Attribute
log4net.Config ConfiguratorAttribute
log4net.Config SecurityContextProviderAttribute
log4net.Config XmlConfiguratorAttribute

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ConfiguratorAttribute : Attribute,
    IComparable
public abstract class ConfiguratorAttribute : Attribute,
    IComparable
Public MustInherit Class ConfiguratorAttribute
    Inherits Attribute
    Implements IComparable
Public MustInherit Class ConfiguratorAttribute
    Inherits Attribute
    Implements IComparable
public ref class ConfiguratorAttribute abstract : public Attribute,
    IComparable
public ref class ConfiguratorAttribute abstract : public Attribute,
    IComparable
Remarks

            This is an abstract class that must be extended by
            specific configurators. This attribute allows the
            configurator to be parameterized by an assembly level
            attribute.

See Also
ConfiguratorAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfiguratorAttribute Members

ConfiguratorAttribute Members Apache log4net™ SDK Documentation
The ConfiguratorAttribute type exposes the following members.
Constructors
 | Name | Description
Protected method | ConfiguratorAttribute | Constructor used by subclasses.
Back to Top
Methods
 | Name | Description
Public method | CompareTo | Compare this instance to another ConfiguratorAttribute
Public method | Configure | Configures the ILoggerRepository for the specified assembly.
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ConfiguratorAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfiguratorAttribute Constructor

ConfiguratorAttribute Constructor Apache log4net™ SDK Documentation
Constructor used by subclasses.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ConfiguratorAttribute(
    int priority
)
protected ConfiguratorAttribute(
    int priority
)
Protected Sub New (
    priority As Integer
)
Protected Sub New (
    priority As Integer
)
protected:
ConfiguratorAttribute(
    int priority
)
protected:
ConfiguratorAttribute(
    int priority
)
Parameters
priority
Type:   Online System Int32
the ordering priority for this configurator
Remarks

            The priority is used to order the configurator
            attributes before they are invoked. Higher priority configurators are executed
            before lower priority ones.

See Also
ConfiguratorAttribute Class
ConfiguratorAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfiguratorAttribute Methods

ConfiguratorAttribute Methods Apache log4net™ SDK Documentation
The ConfiguratorAttribute type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo | Compare this instance to another ConfiguratorAttribute
Public method | Configure | Configures the ILoggerRepository for the specified assembly.
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ConfiguratorAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfiguratorAttribute.CompareTo Method

ConfiguratorAttribute CompareTo Method Apache log4net™ SDK Documentation
Compare this instance to another ConfiguratorAttribute

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
Parameters
obj
Type:   Online System Object
the object to compare to
Return Value
Type:   Online Int32
see   Online CompareTo(Object)
Implements
  Online IComparable CompareTo(Object)
Remarks

            Compares the priorities of the two ConfiguratorAttribute instances.
            Sorts by priority in descending order. Objects with the same priority are
            randomly ordered.

See Also
ConfiguratorAttribute Class
ConfiguratorAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfiguratorAttribute.Configure Method

ConfiguratorAttribute Configure Method Apache log4net™ SDK Documentation
Configures the ILoggerRepository for the specified assembly.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Configure(
    Assembly sourceAssembly,
    ILoggerRepository targetRepository
)
public abstract void Configure(
    Assembly sourceAssembly,
    ILoggerRepository targetRepository
)
Public MustOverride Sub Configure (
    sourceAssembly As Assembly,
    targetRepository As ILoggerRepository
)
Public MustOverride Sub Configure (
    sourceAssembly As Assembly,
    targetRepository As ILoggerRepository
)
public:
virtual void Configure(
    Assembly^ sourceAssembly,
    ILoggerRepository^ targetRepository
) abstract
public:
virtual void Configure(
    Assembly^ sourceAssembly,
    ILoggerRepository^ targetRepository
) abstract
Parameters
sourceAssembly
Type:   Online System.Reflection Assembly
The assembly that this attribute was defined on.
targetRepository
Type: log4net.Repository ILoggerRepository
The repository to configure.
Remarks

            Abstract method implemented by a subclass. When this method is called
            the subclass should configure the targetRepository.

See Also
ConfiguratorAttribute Class
ConfiguratorAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfiguratorAttribute Properties

ConfiguratorAttribute Properties Apache log4net™ SDK Documentation
The ConfiguratorAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ConfiguratorAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DomainAttribute Class

DomainAttribute Class Apache log4net™ SDK Documentation
Assembly level attribute that specifies the logging domain for the assembly.
Inheritance Hierarchy
Online System Object
Online System Attribute
log4net.Config RepositoryAttribute
log4net.Config DomainAttribute

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
[ObsoleteAttribute("Use RepositoryAttribute instead of DomainAttribute")]
public sealed class DomainAttribute : RepositoryAttribute
[SerializableAttribute]
[ObsoleteAttribute("Use RepositoryAttribute instead of DomainAttribute")]
public sealed class DomainAttribute : RepositoryAttribute
<SerializableAttribute>
<ObsoleteAttribute("Use RepositoryAttribute instead of DomainAttribute")>
Public NotInheritable Class DomainAttribute
    Inherits RepositoryAttribute
<SerializableAttribute>
<ObsoleteAttribute("Use RepositoryAttribute instead of DomainAttribute")>
Public NotInheritable Class DomainAttribute
    Inherits RepositoryAttribute
[SerializableAttribute]
[ObsoleteAttribute(L"Use RepositoryAttribute instead of DomainAttribute")]
public ref class DomainAttribute sealed : public RepositoryAttribute
[SerializableAttribute]
[ObsoleteAttribute(L"Use RepositoryAttribute instead of DomainAttribute")]
public ref class DomainAttribute sealed : public RepositoryAttribute
Remarks
DomainAttribute is obsolete. Use RepositoryAttribute instead of DomainAttribute.

            Assemblies are mapped to logging domains. Each domain has its own
            logging repository. This attribute specified on the assembly controls
            the configuration of the domain. The Name property specifies the name
            of the domain that this assembly is a part of. The RepositoryType
            specifies the type of the repository objects to create for the domain. If
            this attribute is not specified and a Name is not specified
            then the assembly will be part of the default shared logging domain.

            This attribute can only be specified on the assembly and may only be used
            once per assembly.

See Also
DomainAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DomainAttribute Members

DomainAttribute Members Apache log4net™ SDK Documentation
The DomainAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | DomainAttribute | Initializes a new instance of the DomainAttribute class.
Public method | DomainAttribute(String) | Initialize a new instance of the DomainAttribute class with the name of the domain.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the logging repository. (Inherited from RepositoryAttribute.)
Public property | RepositoryType | Gets or sets the type of repository to create for this assembly. (Inherited from RepositoryAttribute.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
DomainAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DomainAttribute Constructor

DomainAttribute Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | DomainAttribute | Initializes a new instance of the DomainAttribute class.
Public method | DomainAttribute(String) | Initialize a new instance of the DomainAttribute class with the name of the domain.
Back to Top
See Also
DomainAttribute Class
DomainAttribute Members
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DomainAttribute Constructor

DomainAttribute Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the DomainAttribute class.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DomainAttribute()
public DomainAttribute()
Public Sub New
Public Sub New
public:
DomainAttribute()
public:
DomainAttribute()
Remarks

            Obsolete. Use RepositoryAttribute instead of DomainAttribute.

See Also
DomainAttribute Class
DomainAttribute Members
DomainAttribute Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DomainAttribute Constructor (String)

DomainAttribute Constructor (String) Apache log4net™ SDK Documentation
Initialize a new instance of the DomainAttribute class with the name of the domain.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DomainAttribute(
    string name
)
public DomainAttribute(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
DomainAttribute(
    String^ name
)
public:
DomainAttribute(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the domain.
Remarks

            Obsolete. Use RepositoryAttribute instead of DomainAttribute.

See Also
DomainAttribute Class
DomainAttribute Members
DomainAttribute Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DomainAttribute Methods

DomainAttribute Methods Apache log4net™ SDK Documentation
The DomainAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DomainAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DomainAttribute Properties

DomainAttribute Properties Apache log4net™ SDK Documentation
The DomainAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the logging repository. (Inherited from RepositoryAttribute.)
Public property | RepositoryType | Gets or sets the type of repository to create for this assembly. (Inherited from RepositoryAttribute.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
DomainAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator Class

DOMConfigurator Class Apache log4net™ SDK Documentation
Use this class to initialize the log4net environment using an Xml tree.
Inheritance Hierarchy
Online System Object
log4net.Config DOMConfigurator

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use XmlConfigurator instead of DOMConfigurator")]
public sealed class DOMConfigurator
[ObsoleteAttribute("Use XmlConfigurator instead of DOMConfigurator")]
public sealed class DOMConfigurator
<ObsoleteAttribute("Use XmlConfigurator instead of DOMConfigurator")>
Public NotInheritable Class DOMConfigurator
<ObsoleteAttribute("Use XmlConfigurator instead of DOMConfigurator")>
Public NotInheritable Class DOMConfigurator
[ObsoleteAttribute(L"Use XmlConfigurator instead of DOMConfigurator")]
public ref class DOMConfigurator sealed
[ObsoleteAttribute(L"Use XmlConfigurator instead of DOMConfigurator")]
public ref class DOMConfigurator sealed
Remarks
DOMConfigurator is obsolete. Use XmlConfigurator instead of DOMConfigurator.

            Configures a ILoggerRepository using an Xml tree.

See Also
DOMConfigurator Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator Members

DOMConfigurator Members Apache log4net™ SDK Documentation
The DOMConfigurator type exposes the following members.
Methods
 | Name | Description
 | Configure | Obsolete. Automatically configures the log4net system based on the application's configuration settings.
 | Configure(FileInfo) | Obsolete. Configures log4net using the specified configuration file.
 | Configure(Stream) | Obsolete. Configures log4net using the specified configuration file.
 | Configure(XmlElement) | Obsolete. Configures log4net using a log4net element
 | Configure(ILoggerRepository) | Obsolete. Automatically configures the ILoggerRepository using settings stored in the application's configuration file.
 | Configure(ILoggerRepository, FileInfo) | Obsolete. Configures the ILoggerRepository using the specified configuration file.
 | Configure(ILoggerRepository, Stream) | Obsolete. Configures the ILoggerRepository using the specified configuration file.
 | Configure(ILoggerRepository, XmlElement) | Obsolete. Configures the ILoggerRepository using the specified XML element.
 | ConfigureAndWatch(FileInfo) | Obsolete. Configures log4net using the file specified, monitors the file for changes and reloads the configuration if a change is detected.
 | ConfigureAndWatch(ILoggerRepository, FileInfo) | Obsolete. Configures the ILoggerRepository using the file specified, monitors the file for changes and reloads the configuration if a change is detected.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DOMConfigurator Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator Methods

DOMConfigurator Methods Apache log4net™ SDK Documentation
The DOMConfigurator type exposes the following members.
Methods
 | Name | Description
 | Configure | Obsolete. Automatically configures the log4net system based on the application's configuration settings.
 | Configure(FileInfo) | Obsolete. Configures log4net using the specified configuration file.
 | Configure(Stream) | Obsolete. Configures log4net using the specified configuration file.
 | Configure(XmlElement) | Obsolete. Configures log4net using a log4net element
 | Configure(ILoggerRepository) | Obsolete. Automatically configures the ILoggerRepository using settings stored in the application's configuration file.
 | Configure(ILoggerRepository, FileInfo) | Obsolete. Configures the ILoggerRepository using the specified configuration file.
 | Configure(ILoggerRepository, Stream) | Obsolete. Configures the ILoggerRepository using the specified configuration file.
 | Configure(ILoggerRepository, XmlElement) | Obsolete. Configures the ILoggerRepository using the specified XML element.
 | ConfigureAndWatch(FileInfo) | Obsolete. Configures log4net using the file specified, monitors the file for changes and reloads the configuration if a change is detected.
 | ConfigureAndWatch(ILoggerRepository, FileInfo) | Obsolete. Configures the ILoggerRepository using the file specified, monitors the file for changes and reloads the configuration if a change is detected.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DOMConfigurator Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator.Configure Method

DOMConfigurator Configure Method Apache log4net™ SDK Documentation
Overload List
Name | Description
Configure | Obsolete. Automatically configures the log4net system based on the application's configuration settings.
Configure(FileInfo) | Obsolete. Configures log4net using the specified configuration file.
Configure(Stream) | Obsolete. Configures log4net using the specified configuration file.
Configure(XmlElement) | Obsolete. Configures log4net using a log4net element
Configure(ILoggerRepository) | Obsolete. Automatically configures the ILoggerRepository using settings stored in the application's configuration file.
Configure(ILoggerRepository, FileInfo) | Obsolete. Configures the ILoggerRepository using the specified configuration file.
Configure(ILoggerRepository, Stream) | Obsolete. Configures the ILoggerRepository using the specified configuration file.
Configure(ILoggerRepository, XmlElement) | Obsolete. Configures the ILoggerRepository using the specified XML element.
Back to Top
See Also
DOMConfigurator Class
DOMConfigurator Members
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator.Configure Method

DOMConfigurator Configure Method Apache log4net™ SDK Documentation
Automatically configures the log4net system based on the application's configuration settings.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure()
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure()
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure()
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure()
Remarks
DOMConfigurator is obsolete. Use XmlConfigurator instead of DOMConfigurator.

            Each application has a configuration file. This has the
            same name as the application with '.config' appended.
            This file is XML and calling this function prompts the
            configurator to look in that file for a section called
            log4net that contains the configuration data.

See Also
DOMConfigurator Class
DOMConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator.Configure Method (FileInfo)

DOMConfigurator Configure Method (FileInfo) Apache log4net™ SDK Documentation
Configures log4net using the specified configuration file.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    FileInfo configFile
)
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    FileInfo configFile
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    configFile As FileInfo
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    configFile As FileInfo
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    FileInfo^ configFile
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    FileInfo^ configFile
)
Parameters
configFile
Type:   Online System.IO FileInfo
The XML file to load the configuration from.
Remarks
DOMConfigurator is obsolete. Use XmlConfigurator instead of DOMConfigurator.

            The configuration file must be valid XML. It must contain
            at least one element called log4net that holds
            the log4net configuration data.

            The log4net configuration file can possible be specified in the application's
            configuration file (either MyAppName.exe.config for a
            normal application on Web.config for an ASP.NET application).

Examples

            The following example configures log4net using a configuration file, of which the
            location is stored in the application's configuration file :

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
using log4net.Config;
using System.IO;
using System.Configuration;

...

DOMConfigurator.Configure(new FileInfo(ConfigurationSettings.AppSettings["log4net-config-file"]));
using log4net.Config;
using System.IO;
using System.Configuration;

...

DOMConfigurator.Configure(new FileInfo(ConfigurationSettings.AppSettings["log4net-config-file"]));

            In the .config file, the path to the log4net can be specified like this :

XML
View Colorized Copy to Clipboard Print
<configuration><appSettings><add key="log4net-config-file" value="log.config" /></appSettings></configuration>
<configuration><appSettings><add key="log4net-config-file" value="log.config" /></appSettings></configuration>
See Also
DOMConfigurator Class
DOMConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator.Configure Method (Stream)

DOMConfigurator Configure Method (Stream) Apache log4net™ SDK Documentation
Configures log4net using the specified configuration file.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    Stream configStream
)
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    Stream configStream
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    configStream As Stream
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    configStream As Stream
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    Stream^ configStream
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    Stream^ configStream
)
Parameters
configStream
Type:   Online System.IO Stream
A stream to load the XML configuration from.
Remarks
DOMConfigurator is obsolete. Use XmlConfigurator instead of DOMConfigurator.

            The configuration data must be valid XML. It must contain
            at least one element called log4net that holds
            the log4net configuration data.

            Note that this method will NOT close the stream parameter.

See Also
DOMConfigurator Class
DOMConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator.Configure Method (XmlElement)

DOMConfigurator Configure Method (XmlElement) Apache log4net™ SDK Documentation
Configures log4net using a log4net element

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    XmlElement element
)
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    XmlElement element
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    element As XmlElement
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    element As XmlElement
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    XmlElement^ element
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    XmlElement^ element
)
Parameters
element
Type:   Online System.Xml XmlElement
The element to parse.
Remarks
DOMConfigurator is obsolete. Use XmlConfigurator instead of DOMConfigurator.

            Loads the log4net configuration from the XML element
            supplied as element.

See Also
DOMConfigurator Class
DOMConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator.Configure Method (ILoggerRepository)

DOMConfigurator Configure Method (ILoggerRepository) Apache log4net™ SDK Documentation
Automatically configures the ILoggerRepository using settings stored in the application's configuration file.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    ILoggerRepository repository
)
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    ILoggerRepository repository
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    repository As ILoggerRepository
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    repository As ILoggerRepository
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    ILoggerRepository^ repository
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    ILoggerRepository^ repository
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
Remarks
DOMConfigurator is obsolete. Use XmlConfigurator instead of DOMConfigurator.

            Each application has a configuration file. This has the
            same name as the application with '.config' appended.
            This file is XML and calling this function prompts the
            configurator to look in that file for a section called
            log4net that contains the configuration data.

See Also
DOMConfigurator Class
DOMConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator.Configure Method (ILoggerRepository, FileInfo)

DOMConfigurator Configure Method (ILoggerRepository, FileInfo) Apache log4net™ SDK Documentation
Configures the ILoggerRepository using the specified configuration file.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    ILoggerRepository repository,
    FileInfo configFile
)
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    ILoggerRepository repository,
    FileInfo configFile
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    repository As ILoggerRepository,
    configFile As FileInfo
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    repository As ILoggerRepository,
    configFile As FileInfo
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    ILoggerRepository^ repository,
    FileInfo^ configFile
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    ILoggerRepository^ repository,
    FileInfo^ configFile
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
configFile
Type:   Online System.IO FileInfo
The XML file to load the configuration from.
Remarks
DOMConfigurator is obsolete. Use XmlConfigurator instead of DOMConfigurator.

            The configuration file must be valid XML. It must contain
            at least one element called log4net that holds
            the configuration data.

            The log4net configuration file can possible be specified in the application's
            configuration file (either MyAppName.exe.config for a
            normal application on Web.config for an ASP.NET application).

Examples

            The following example configures log4net using a configuration file, of which the
            location is stored in the application's configuration file :

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
using log4net.Config;
using System.IO;
using System.Configuration;

...

DOMConfigurator.Configure(new FileInfo(ConfigurationSettings.AppSettings["log4net-config-file"]));
using log4net.Config;
using System.IO;
using System.Configuration;

...

DOMConfigurator.Configure(new FileInfo(ConfigurationSettings.AppSettings["log4net-config-file"]));

            In the .config file, the path to the log4net can be specified like this :

XML
View Colorized Copy to Clipboard Print
<configuration><appSettings><add key="log4net-config-file" value="log.config" /></appSettings></configuration>
<configuration><appSettings><add key="log4net-config-file" value="log.config" /></appSettings></configuration>
See Also
DOMConfigurator Class
DOMConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator.Configure Method (ILoggerRepository, Stream)

DOMConfigurator Configure Method (ILoggerRepository, Stream) Apache log4net™ SDK Documentation
Configures the ILoggerRepository using the specified configuration file.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    ILoggerRepository repository,
    Stream configStream
)
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    ILoggerRepository repository,
    Stream configStream
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    repository As ILoggerRepository,
    configStream As Stream
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    repository As ILoggerRepository,
    configStream As Stream
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    ILoggerRepository^ repository,
    Stream^ configStream
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    ILoggerRepository^ repository,
    Stream^ configStream
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
configStream
Type:   Online System.IO Stream
The stream to load the XML configuration from.
Remarks
DOMConfigurator is obsolete. Use XmlConfigurator instead of DOMConfigurator.

            The configuration data must be valid XML. It must contain
            at least one element called log4net that holds
            the configuration data.

            Note that this method will NOT close the stream parameter.

See Also
DOMConfigurator Class
DOMConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator.Configure Method (ILoggerRepository, XmlElement)

DOMConfigurator Configure Method (ILoggerRepository, XmlElement) Apache log4net™ SDK Documentation
Configures the ILoggerRepository using the specified XML element.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    ILoggerRepository repository,
    XmlElement element
)
[ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
public static void Configure(
    ILoggerRepository repository,
    XmlElement element
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    repository As ILoggerRepository,
    element As XmlElement
)
<ObsoleteAttribute("Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")>
Public Shared Sub Configure (
    repository As ILoggerRepository,
    element As XmlElement
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    ILoggerRepository^ repository,
    XmlElement^ element
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.Configure instead of DOMConfigurator.Configure")]
static void Configure(
    ILoggerRepository^ repository,
    XmlElement^ element
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
element
Type:   Online System.Xml XmlElement
The element to parse.
Remarks
DOMConfigurator is obsolete. Use XmlConfigurator instead of DOMConfigurator.

            Loads the log4net configuration from the XML element
            supplied as element.

See Also
DOMConfigurator Class
DOMConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator.ConfigureAndWatch Method

DOMConfigurator ConfigureAndWatch Method Apache log4net™ SDK Documentation
Overload List
Name | Description
ConfigureAndWatch(FileInfo) | Obsolete. Configures log4net using the file specified, monitors the file for changes and reloads the configuration if a change is detected.
ConfigureAndWatch(ILoggerRepository, FileInfo) | Obsolete. Configures the ILoggerRepository using the file specified, monitors the file for changes and reloads the configuration if a change is detected.
Back to Top
See Also
DOMConfigurator Class
DOMConfigurator Members
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator.ConfigureAndWatch Method (FileInfo)

DOMConfigurator ConfigureAndWatch Method (FileInfo) Apache log4net™ SDK Documentation
Configures log4net using the file specified, monitors the file for changes and reloads the configuration if a change is detected.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use XmlConfigurator.ConfigureAndWatch instead of DOMConfigurator.ConfigureAndWatch")]
public static void ConfigureAndWatch(
    FileInfo configFile
)
[ObsoleteAttribute("Use XmlConfigurator.ConfigureAndWatch instead of DOMConfigurator.ConfigureAndWatch")]
public static void ConfigureAndWatch(
    FileInfo configFile
)
<ObsoleteAttribute("Use XmlConfigurator.ConfigureAndWatch instead of DOMConfigurator.ConfigureAndWatch")>
Public Shared Sub ConfigureAndWatch (
    configFile As FileInfo
)
<ObsoleteAttribute("Use XmlConfigurator.ConfigureAndWatch instead of DOMConfigurator.ConfigureAndWatch")>
Public Shared Sub ConfigureAndWatch (
    configFile As FileInfo
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.ConfigureAndWatch instead of DOMConfigurator.ConfigureAndWatch")]
static void ConfigureAndWatch(
    FileInfo^ configFile
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.ConfigureAndWatch instead of DOMConfigurator.ConfigureAndWatch")]
static void ConfigureAndWatch(
    FileInfo^ configFile
)
Parameters
configFile
Type:   Online System.IO FileInfo
The XML file to load the configuration from.
Remarks
DOMConfigurator is obsolete. Use XmlConfigurator instead of DOMConfigurator.

            The configuration file must be valid XML. It must contain
            at least one element called log4net that holds
            the configuration data.

            The configuration file will be monitored using a   Online FileSystemWatcher
            and depends on the behavior of that class.

            For more information on how to configure log4net using
            a separate configuration file, see [M:Configure(FileInfo)].

See Also
DOMConfigurator Class
DOMConfigurator Members
ConfigureAndWatch Overload
log4net.Config Namespace
[M:Configure(FileInfo)]
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfigurator.ConfigureAndWatch Method (ILoggerRepository, FileInfo)

DOMConfigurator ConfigureAndWatch Method (ILoggerRepository, FileInfo) Apache log4net™ SDK Documentation
Configures the ILoggerRepository using the file specified, monitors the file for changes and reloads the configuration if a change is detected.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use XmlConfigurator.ConfigureAndWatch instead of DOMConfigurator.ConfigureAndWatch")]
public static void ConfigureAndWatch(
    ILoggerRepository repository,
    FileInfo configFile
)
[ObsoleteAttribute("Use XmlConfigurator.ConfigureAndWatch instead of DOMConfigurator.ConfigureAndWatch")]
public static void ConfigureAndWatch(
    ILoggerRepository repository,
    FileInfo configFile
)
<ObsoleteAttribute("Use XmlConfigurator.ConfigureAndWatch instead of DOMConfigurator.ConfigureAndWatch")>
Public Shared Sub ConfigureAndWatch (
    repository As ILoggerRepository,
    configFile As FileInfo
)
<ObsoleteAttribute("Use XmlConfigurator.ConfigureAndWatch instead of DOMConfigurator.ConfigureAndWatch")>
Public Shared Sub ConfigureAndWatch (
    repository As ILoggerRepository,
    configFile As FileInfo
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.ConfigureAndWatch instead of DOMConfigurator.ConfigureAndWatch")]
static void ConfigureAndWatch(
    ILoggerRepository^ repository,
    FileInfo^ configFile
)
public:
[ObsoleteAttribute(L"Use XmlConfigurator.ConfigureAndWatch instead of DOMConfigurator.ConfigureAndWatch")]
static void ConfigureAndWatch(
    ILoggerRepository^ repository,
    FileInfo^ configFile
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
configFile
Type:   Online System.IO FileInfo
The XML file to load the configuration from.
Remarks
DOMConfigurator is obsolete. Use XmlConfigurator instead of DOMConfigurator.

            The configuration file must be valid XML. It must contain
            at least one element called log4net that holds
            the configuration data.

            The configuration file will be monitored using a   Online FileSystemWatcher
            and depends on the behavior of that class.

            For more information on how to configure log4net using
            a separate configuration file, see [M:Configure(FileInfo)].

See Also
DOMConfigurator Class
DOMConfigurator Members
ConfigureAndWatch Overload
log4net.Config Namespace
[M:Configure(FileInfo)]
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfiguratorAttribute Class

DOMConfiguratorAttribute Class Apache log4net™ SDK Documentation
Assembly level attribute to configure the XmlConfigurator.
Inheritance Hierarchy
Online System Object
Online System Attribute
log4net.Config ConfiguratorAttribute
log4net.Config XmlConfiguratorAttribute
log4net.Config DOMConfiguratorAttribute

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
[ObsoleteAttribute("Use XmlConfiguratorAttribute instead of DOMConfiguratorAttribute")]
public sealed class DOMConfiguratorAttribute : XmlConfiguratorAttribute
[SerializableAttribute]
[ObsoleteAttribute("Use XmlConfiguratorAttribute instead of DOMConfiguratorAttribute")]
public sealed class DOMConfiguratorAttribute : XmlConfiguratorAttribute
<SerializableAttribute>
<ObsoleteAttribute("Use XmlConfiguratorAttribute instead of DOMConfiguratorAttribute")>
Public NotInheritable Class DOMConfiguratorAttribute
    Inherits XmlConfiguratorAttribute
<SerializableAttribute>
<ObsoleteAttribute("Use XmlConfiguratorAttribute instead of DOMConfiguratorAttribute")>
Public NotInheritable Class DOMConfiguratorAttribute
    Inherits XmlConfiguratorAttribute
[SerializableAttribute]
[ObsoleteAttribute(L"Use XmlConfiguratorAttribute instead of DOMConfiguratorAttribute")]
public ref class DOMConfiguratorAttribute sealed : public XmlConfiguratorAttribute
[SerializableAttribute]
[ObsoleteAttribute(L"Use XmlConfiguratorAttribute instead of DOMConfiguratorAttribute")]
public ref class DOMConfiguratorAttribute sealed : public XmlConfiguratorAttribute
Remarks
AliasDomainAttribute is obsolete. Use AliasRepositoryAttribute instead of AliasDomainAttribute.

            This attribute may only be used at the assembly scope and can only
            be used once per assembly.

            Use this attribute to configure the XmlConfigurator
            without calling one of the [M:XmlConfigurator.Configure()]
            methods.

See Also
DOMConfiguratorAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfiguratorAttribute Members

DOMConfiguratorAttribute Members Apache log4net™ SDK Documentation
The DOMConfiguratorAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | DOMConfiguratorAttribute | Initializes a new instance of the DOMConfiguratorAttribute class
Back to Top
Methods
 | Name | Description
Public method | CompareTo | Compare this instance to another ConfiguratorAttribute (Inherited from ConfiguratorAttribute.)
Public method | Configure | Configures the ILoggerRepository for the specified assembly. (Inherited from XmlConfiguratorAttribute.)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ConfigFile | Gets or sets the filename of the configuration file. (Inherited from XmlConfiguratorAttribute.)
Public property | ConfigFileExtension | Gets or sets the extension of the configuration file. (Inherited from XmlConfiguratorAttribute.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Public property | Watch | Gets or sets a value indicating whether to watch the configuration file. (Inherited from XmlConfiguratorAttribute.)
Back to Top
See Also
DOMConfiguratorAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfiguratorAttribute Constructor

DOMConfiguratorAttribute Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the DOMConfiguratorAttribute class

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DOMConfiguratorAttribute()
public DOMConfiguratorAttribute()
Public Sub New
Public Sub New
public:
DOMConfiguratorAttribute()
public:
DOMConfiguratorAttribute()
See Also
DOMConfiguratorAttribute Class
DOMConfiguratorAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfiguratorAttribute Methods

DOMConfiguratorAttribute Methods Apache log4net™ SDK Documentation
The DOMConfiguratorAttribute type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo | Compare this instance to another ConfiguratorAttribute (Inherited from ConfiguratorAttribute.)
Public method | Configure | Configures the ILoggerRepository for the specified assembly. (Inherited from XmlConfiguratorAttribute.)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DOMConfiguratorAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DOMConfiguratorAttribute Properties

DOMConfiguratorAttribute Properties Apache log4net™ SDK Documentation
The DOMConfiguratorAttribute type exposes the following members.
Properties
 | Name | Description
Public property | ConfigFile | Gets or sets the filename of the configuration file. (Inherited from XmlConfiguratorAttribute.)
Public property | ConfigFileExtension | Gets or sets the extension of the configuration file. (Inherited from XmlConfiguratorAttribute.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Public property | Watch | Gets or sets a value indicating whether to watch the configuration file. (Inherited from XmlConfiguratorAttribute.)
Back to Top
See Also
DOMConfiguratorAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Log4NetConfigurationSectionHandler Class

Log4NetConfigurationSectionHandler Class Apache log4net™ SDK Documentation
Class to register for the log4net section of the configuration file
Inheritance Hierarchy
Online System Object
log4net.Config Log4NetConfigurationSectionHandler

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Log4NetConfigurationSectionHandler : IConfigurationSectionHandler
public class Log4NetConfigurationSectionHandler : IConfigurationSectionHandler
Public Class Log4NetConfigurationSectionHandler
    Implements IConfigurationSectionHandler
Public Class Log4NetConfigurationSectionHandler
    Implements IConfigurationSectionHandler
public ref class Log4NetConfigurationSectionHandler : IConfigurationSectionHandler
public ref class Log4NetConfigurationSectionHandler : IConfigurationSectionHandler
Remarks

            The log4net section of the configuration file needs to have a section
            handler registered. This is the section handler used. It simply returns
            the XML element that is the root of the section.

Examples

            Example of registering the log4net section handler :

XML
View Colorized Copy to Clipboard Print
<configuration><configSections><section name="log4net" type="log4net.Config.Log4NetConfigurationSectionHandler, log4net" /></configSections><log4net>
                    log4net configuration XML goes here
                </log4net></configuration>
<configuration><configSections><section name="log4net" type="log4net.Config.Log4NetConfigurationSectionHandler, log4net" /></configSections><log4net>
                    log4net configuration XML goes here
                </log4net></configuration>
See Also
Log4NetConfigurationSectionHandler Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Log4NetConfigurationSectionHandler Members

Log4NetConfigurationSectionHandler Members Apache log4net™ SDK Documentation
The Log4NetConfigurationSectionHandler type exposes the following members.
Constructors
 | Name | Description
Public method | Log4NetConfigurationSectionHandler | Initializes a new instance of the Log4NetConfigurationSectionHandler class.
Back to Top
Methods
 | Name | Description
Public method | Create | Parses the configuration section.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Log4NetConfigurationSectionHandler Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Log4NetConfigurationSectionHandler Constructor

Log4NetConfigurationSectionHandler Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the Log4NetConfigurationSectionHandler class.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Log4NetConfigurationSectionHandler()
public Log4NetConfigurationSectionHandler()
Public Sub New
Public Sub New
public:
Log4NetConfigurationSectionHandler()
public:
Log4NetConfigurationSectionHandler()
Remarks

            Default constructor.

See Also
Log4NetConfigurationSectionHandler Class
Log4NetConfigurationSectionHandler Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Log4NetConfigurationSectionHandler Methods

Log4NetConfigurationSectionHandler Methods Apache log4net™ SDK Documentation
The Log4NetConfigurationSectionHandler type exposes the following members.
Methods
 | Name | Description
Public method | Create | Parses the configuration section.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Log4NetConfigurationSectionHandler Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Log4NetConfigurationSectionHandler.Create Method

Log4NetConfigurationSectionHandler Create Method Apache log4net™ SDK Documentation
Parses the configuration section.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Create(
    Object parent,
    Object configContext,
    XmlNode section
)
public Object Create(
    Object parent,
    Object configContext,
    XmlNode section
)
Public Function Create (
    parent As Object,
    configContext As Object,
    section As XmlNode
) As Object
Public Function Create (
    parent As Object,
    configContext As Object,
    section As XmlNode
) As Object
public:
virtual Object^ Create(
    Object^ parent,
    Object^ configContext,
    XmlNode^ section
) sealed
public:
virtual Object^ Create(
    Object^ parent,
    Object^ configContext,
    XmlNode^ section
) sealed
Parameters
parent
Type:   Online System Object
The configuration settings in a corresponding parent configuration section.
configContext
Type:   Online System Object
The configuration context when called from the ASP.NET configuration system. Otherwise, this parameter is reserved and is a null reference.
section
Type:   Online System.Xml XmlNode
The   Online XmlNode for the log4net section.
Return Value
Type:   Online Object
The   Online XmlNode for the log4net section.
Implements
  Online IConfigurationSectionHandler Create(Object, Object, XmlNode)
Remarks

            Returns the   Online XmlNode containing the configuration data,

See Also
Log4NetConfigurationSectionHandler Class
Log4NetConfigurationSectionHandler Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginAttribute Class

PluginAttribute Class Apache log4net™ SDK Documentation
Assembly level attribute that specifies a plugin to attach to the repository.
Inheritance Hierarchy
Online System Object
Online System Attribute
log4net.Config PluginAttribute

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class PluginAttribute : Attribute,
    IPluginFactory
[SerializableAttribute]
public sealed class PluginAttribute : Attribute,
    IPluginFactory
<SerializableAttribute>
Public NotInheritable Class PluginAttribute
    Inherits Attribute
    Implements IPluginFactory
<SerializableAttribute>
Public NotInheritable Class PluginAttribute
    Inherits Attribute
    Implements IPluginFactory
[SerializableAttribute]
public ref class PluginAttribute sealed : public Attribute,
    IPluginFactory
[SerializableAttribute]
public ref class PluginAttribute sealed : public Attribute,
    IPluginFactory
Remarks

            Specifies the type of a plugin to create and attach to the
            assembly's repository. The plugin type must implement the
            IPlugin interface.

See Also
PluginAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginAttribute Members

PluginAttribute Members Apache log4net™ SDK Documentation
The PluginAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | PluginAttribute(String) | Initializes a new instance of the PluginAttribute class with the specified type.
Public method | PluginAttribute(Type) | Initializes a new instance of the PluginAttribute class with the specified type.
Back to Top
Methods
 | Name | Description
Public method | CreatePlugin | Creates the plugin object defined by this attribute.
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a representation of the properties of this object. (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Type | Gets or sets the type for the plugin.
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Public property | TypeName | Gets or sets the type name for the plugin.
Back to Top
See Also
PluginAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginAttribute Constructor

PluginAttribute Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | PluginAttribute(String) | Initializes a new instance of the PluginAttribute class with the specified type.
Public method | PluginAttribute(Type) | Initializes a new instance of the PluginAttribute class with the specified type.
Back to Top
See Also
PluginAttribute Class
PluginAttribute Members
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginAttribute Constructor (String)

PluginAttribute Constructor (String) Apache log4net™ SDK Documentation
Initializes a new instance of the PluginAttribute class with the specified type.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PluginAttribute(
    string typeName
)
public PluginAttribute(
    string typeName
)
Public Sub New (
    typeName As String
)
Public Sub New (
    typeName As String
)
public:
PluginAttribute(
    String^ typeName
)
public:
PluginAttribute(
    String^ typeName
)
Parameters
typeName
Type:   Online System String
The type name of plugin to create.
Remarks

            Create the attribute with the plugin type specified.

            Where possible use the constructor that takes a   Online Type.

See Also
PluginAttribute Class
PluginAttribute Members
PluginAttribute Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginAttribute Constructor (Type)

PluginAttribute Constructor (Type) Apache log4net™ SDK Documentation
Initializes a new instance of the PluginAttribute class with the specified type.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PluginAttribute(
    Type type
)
public PluginAttribute(
    Type type
)
Public Sub New (
    type As Type
)
Public Sub New (
    type As Type
)
public:
PluginAttribute(
    Type^ type
)
public:
PluginAttribute(
    Type^ type
)
Parameters
type
Type:   Online System Type
The type of plugin to create.
Remarks

            Create the attribute with the plugin type specified.

See Also
PluginAttribute Class
PluginAttribute Members
PluginAttribute Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginAttribute Methods

PluginAttribute Methods Apache log4net™ SDK Documentation
The PluginAttribute type exposes the following members.
Methods
 | Name | Description
Public method | CreatePlugin | Creates the plugin object defined by this attribute.
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a representation of the properties of this object. (Overrides Online Object ToString .)
Back to Top
See Also
PluginAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginAttribute.CreatePlugin Method

PluginAttribute CreatePlugin Method Apache log4net™ SDK Documentation
Creates the plugin object defined by this attribute.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPlugin CreatePlugin()
public IPlugin CreatePlugin()
Public Function CreatePlugin As IPlugin
Public Function CreatePlugin As IPlugin
public:
virtual IPlugin^ CreatePlugin() sealed
public:
virtual IPlugin^ CreatePlugin() sealed
Return Value
Type: IPlugin
The plugin object.
Implements
IPluginFactory CreatePlugin
Remarks

            Creates the instance of the IPlugin object as
            specified by this attribute.

See Also
PluginAttribute Class
PluginAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginAttribute.ToString Method

PluginAttribute ToString Method Apache log4net™ SDK Documentation
Returns a representation of the properties of this object.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value
Type:   Online String
A representation of the properties of this object
Remarks

            Overrides base class [M:Object.ToString()] method to
            return a representation of the properties of this object.

See Also
PluginAttribute Class
PluginAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginAttribute Properties

PluginAttribute Properties Apache log4net™ SDK Documentation
The PluginAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Type | Gets or sets the type for the plugin.
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Public property | TypeName | Gets or sets the type name for the plugin.
Back to Top
See Also
PluginAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginAttribute.Type Property

PluginAttribute Type Property Apache log4net™ SDK Documentation
Gets or sets the type for the plugin.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type Type { get; set; }
public Type Type { get; set; }
Public Property Type As Type
    Get
    Set
Public Property Type As Type
    Get
    Set
public:
property Type^ Type {
    Type^ get ();
    void set (Type^ value);
}
public:
property Type^ Type {
    Type^ get ();
    void set (Type^ value);
}
Property Value
Type:   Online Type

            The type for the plugin.

Remarks

            The type for the plugin.

See Also
PluginAttribute Class
PluginAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginAttribute.TypeName Property

PluginAttribute TypeName Property Apache log4net™ SDK Documentation
Gets or sets the type name for the plugin.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TypeName { get; set; }
public string TypeName { get; set; }
Public Property TypeName As String
    Get
    Set
Public Property TypeName As String
    Get
    Set
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The type name for the plugin.

Remarks

            The type name for the plugin.

            Where possible use the Type property instead.

See Also
PluginAttribute Class
PluginAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RepositoryAttribute Class

RepositoryAttribute Class Apache log4net™ SDK Documentation
Assembly level attribute that specifies the logging repository for the assembly.
Inheritance Hierarchy
Online System Object
Online System Attribute
log4net.Config RepositoryAttribute
log4net.Config DomainAttribute

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class RepositoryAttribute : Attribute
[SerializableAttribute]
public class RepositoryAttribute : Attribute
<SerializableAttribute>
Public Class RepositoryAttribute
    Inherits Attribute
<SerializableAttribute>
Public Class RepositoryAttribute
    Inherits Attribute
[SerializableAttribute]
public ref class RepositoryAttribute : public Attribute
[SerializableAttribute]
public ref class RepositoryAttribute : public Attribute
Remarks

            Assemblies are mapped to logging repository. This attribute specified
            on the assembly controls
            the configuration of the repository. The Name property specifies the name
            of the repository that this assembly is a part of. The RepositoryType
            specifies the type of the ILoggerRepository object
            to create for the assembly. If this attribute is not specified or a Name
            is not specified then the assembly will be part of the default shared logging repository.

            This attribute can only be specified on the assembly and may only be used
            once per assembly.

See Also
RepositoryAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RepositoryAttribute Members

RepositoryAttribute Members Apache log4net™ SDK Documentation
The RepositoryAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | RepositoryAttribute | Initializes a new instance of the RepositoryAttribute class.
Public method | RepositoryAttribute(String) | Initialize a new instance of the RepositoryAttribute class with the name of the repository.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the logging repository.
Public property | RepositoryType | Gets or sets the type of repository to create for this assembly.
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
RepositoryAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RepositoryAttribute Constructor

RepositoryAttribute Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | RepositoryAttribute | Initializes a new instance of the RepositoryAttribute class.
Public method | RepositoryAttribute(String) | Initialize a new instance of the RepositoryAttribute class with the name of the repository.
Back to Top
See Also
RepositoryAttribute Class
RepositoryAttribute Members
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RepositoryAttribute Constructor

RepositoryAttribute Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the RepositoryAttribute class.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RepositoryAttribute()
public RepositoryAttribute()
Public Sub New
Public Sub New
public:
RepositoryAttribute()
public:
RepositoryAttribute()
Remarks

            Default constructor.

See Also
RepositoryAttribute Class
RepositoryAttribute Members
RepositoryAttribute Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RepositoryAttribute Constructor (String)

RepositoryAttribute Constructor (String) Apache log4net™ SDK Documentation
Initialize a new instance of the RepositoryAttribute class with the name of the repository.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RepositoryAttribute(
    string name
)
public RepositoryAttribute(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
RepositoryAttribute(
    String^ name
)
public:
RepositoryAttribute(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the repository.
Remarks

            Initialize the attribute with the name for the assembly's repository.

See Also
RepositoryAttribute Class
RepositoryAttribute Members
RepositoryAttribute Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RepositoryAttribute Methods

RepositoryAttribute Methods Apache log4net™ SDK Documentation
The RepositoryAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RepositoryAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RepositoryAttribute Properties

RepositoryAttribute Properties Apache log4net™ SDK Documentation
The RepositoryAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the logging repository.
Public property | RepositoryType | Gets or sets the type of repository to create for this assembly.
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
RepositoryAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RepositoryAttribute.Name Property

RepositoryAttribute Name Property Apache log4net™ SDK Documentation
Gets or sets the name of the logging repository.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The string name to use as the name of the repository associated with this
            assembly.

Remarks

            This value does not have to be unique. Several assemblies can share the
            same repository. They will share the logging configuration of the repository.

See Also
RepositoryAttribute Class
RepositoryAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RepositoryAttribute.RepositoryType Property

RepositoryAttribute RepositoryType Property Apache log4net™ SDK Documentation
Gets or sets the type of repository to create for this assembly.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type RepositoryType { get; set; }
public Type RepositoryType { get; set; }
Public Property RepositoryType As Type
    Get
    Set
Public Property RepositoryType As Type
    Get
    Set
public:
property Type^ RepositoryType {
    Type^ get ();
    void set (Type^ value);
}
public:
property Type^ RepositoryType {
    Type^ get ();
    void set (Type^ value);
}
Property Value
Type:   Online Type

            The type of repository to create for this assembly.

Remarks

            The type of the repository to create for the assembly.
            The type must implement the ILoggerRepository
            interface.

            This will be the type of repository created when
            the repository is created. If multiple assemblies reference the
            same repository then the repository is only created once using the
            RepositoryType of the first assembly to call into the
            repository.

See Also
RepositoryAttribute Class
RepositoryAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProviderAttribute Class

SecurityContextProviderAttribute Class Apache log4net™ SDK Documentation
Assembly level attribute to configure the SecurityContextProvider.
Inheritance Hierarchy
Online System Object
Online System Attribute
log4net.Config ConfiguratorAttribute
log4net.Config SecurityContextProviderAttribute

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class SecurityContextProviderAttribute : ConfiguratorAttribute
[SerializableAttribute]
public sealed class SecurityContextProviderAttribute : ConfiguratorAttribute
<SerializableAttribute>
Public NotInheritable Class SecurityContextProviderAttribute
    Inherits ConfiguratorAttribute
<SerializableAttribute>
Public NotInheritable Class SecurityContextProviderAttribute
    Inherits ConfiguratorAttribute
[SerializableAttribute]
public ref class SecurityContextProviderAttribute sealed : public ConfiguratorAttribute
[SerializableAttribute]
public ref class SecurityContextProviderAttribute sealed : public ConfiguratorAttribute
Remarks

            This attribute may only be used at the assembly scope and can only
            be used once per assembly.

            Use this attribute to configure the XmlConfigurator
            without calling one of the [M:XmlConfigurator.Configure()]
            methods.

See Also
SecurityContextProviderAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProviderAttribute Members

SecurityContextProviderAttribute Members Apache log4net™ SDK Documentation
The SecurityContextProviderAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | SecurityContextProviderAttribute | Construct provider attribute with type specified
Back to Top
Methods
 | Name | Description
Public method | CompareTo | Compare this instance to another ConfiguratorAttribute (Inherited from ConfiguratorAttribute.)
Public method | Configure | Configures the SecurityContextProvider (Overrides ConfiguratorAttribute Configure(Assembly, ILoggerRepository).)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ProviderType | Gets or sets the type of the provider to use.
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
SecurityContextProviderAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProviderAttribute Constructor

SecurityContextProviderAttribute Constructor Apache log4net™ SDK Documentation
Construct provider attribute with type specified

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityContextProviderAttribute(
    Type providerType
)
public SecurityContextProviderAttribute(
    Type providerType
)
Public Sub New (
    providerType As Type
)
Public Sub New (
    providerType As Type
)
public:
SecurityContextProviderAttribute(
    Type^ providerType
)
public:
SecurityContextProviderAttribute(
    Type^ providerType
)
Parameters
providerType
Type:   Online System Type
the type of the provider to use
Remarks

            The provider specified must subclass the SecurityContextProvider
            class.

See Also
SecurityContextProviderAttribute Class
SecurityContextProviderAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProviderAttribute Methods

SecurityContextProviderAttribute Methods Apache log4net™ SDK Documentation
The SecurityContextProviderAttribute type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo | Compare this instance to another ConfiguratorAttribute (Inherited from ConfiguratorAttribute.)
Public method | Configure | Configures the SecurityContextProvider (Overrides ConfiguratorAttribute Configure(Assembly, ILoggerRepository).)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SecurityContextProviderAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProviderAttribute.Configure Method

SecurityContextProviderAttribute Configure Method Apache log4net™ SDK Documentation
Configures the SecurityContextProvider

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Configure(
    Assembly sourceAssembly,
    ILoggerRepository targetRepository
)
public override void Configure(
    Assembly sourceAssembly,
    ILoggerRepository targetRepository
)
Public Overrides Sub Configure (
    sourceAssembly As Assembly,
    targetRepository As ILoggerRepository
)
Public Overrides Sub Configure (
    sourceAssembly As Assembly,
    targetRepository As ILoggerRepository
)
public:
virtual void Configure(
    Assembly^ sourceAssembly,
    ILoggerRepository^ targetRepository
) override
public:
virtual void Configure(
    Assembly^ sourceAssembly,
    ILoggerRepository^ targetRepository
) override
Parameters
sourceAssembly
Type:   Online System.Reflection Assembly
The assembly that this attribute was defined on.
targetRepository
Type: log4net.Repository ILoggerRepository
The repository to configure.
Remarks

            Creates a provider instance from the ProviderType specified.
            Sets this as the default security context provider DefaultProvider.

See Also
SecurityContextProviderAttribute Class
SecurityContextProviderAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProviderAttribute Properties

SecurityContextProviderAttribute Properties Apache log4net™ SDK Documentation
The SecurityContextProviderAttribute type exposes the following members.
Properties
 | Name | Description
Public property | ProviderType | Gets or sets the type of the provider to use.
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
SecurityContextProviderAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProviderAttribute.ProviderType Property

SecurityContextProviderAttribute ProviderType Property Apache log4net™ SDK Documentation
Gets or sets the type of the provider to use.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type ProviderType { get; set; }
public Type ProviderType { get; set; }
Public Property ProviderType As Type
    Get
    Set
Public Property ProviderType As Type
    Get
    Set
public:
property Type^ ProviderType {
    Type^ get ();
    void set (Type^ value);
}
public:
property Type^ ProviderType {
    Type^ get ();
    void set (Type^ value);
}
Property Value
Type:   Online Type

            the type of the provider to use.

Remarks

            The provider specified must subclass the SecurityContextProvider
            class.

See Also
SecurityContextProviderAttribute Class
SecurityContextProviderAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator Class

XmlConfigurator Class Apache log4net™ SDK Documentation
Use this class to initialize the log4net environment using an Xml tree.
Inheritance Hierarchy
Online System Object
log4net.Config XmlConfigurator

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class XmlConfigurator
public sealed class XmlConfigurator
Public NotInheritable Class XmlConfigurator
Public NotInheritable Class XmlConfigurator
public ref class XmlConfigurator sealed
public ref class XmlConfigurator sealed
Remarks

            Configures a ILoggerRepository using an Xml tree.

See Also
XmlConfigurator Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator Members

XmlConfigurator Members Apache log4net™ SDK Documentation
The XmlConfigurator type exposes the following members.
Methods
 | Name | Description
 | Configure | Automatically configures the log4net system based on the application's configuration settings.
 | Configure(FileInfo) | Configures log4net using the specified configuration file.
 | Configure(Stream) | Configures log4net using the specified configuration data stream.
 | Configure(Uri) | Configures log4net using the specified configuration URI.
 | Configure(XmlElement) | Configures log4net using a log4net element
 | Configure(ILoggerRepository) | Automatically configures the ILoggerRepository using settings stored in the application's configuration file.
 | Configure(ILoggerRepository, FileInfo) | Configures the ILoggerRepository using the specified configuration file.
 | Configure(ILoggerRepository, Stream) | Configures the ILoggerRepository using the specified configuration file.
 | Configure(ILoggerRepository, Uri) | Configures the ILoggerRepository using the specified configuration URI.
 | Configure(ILoggerRepository, XmlElement) | Configures the ILoggerRepository using the specified XML element.
 | ConfigureAndWatch(FileInfo) | Configures log4net using the file specified, monitors the file for changes and reloads the configuration if a change is detected.
 | ConfigureAndWatch(ILoggerRepository, FileInfo) | Configures the ILoggerRepository using the file specified, monitors the file for changes and reloads the configuration if a change is detected.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
XmlConfigurator Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator Methods

XmlConfigurator Methods Apache log4net™ SDK Documentation
The XmlConfigurator type exposes the following members.
Methods
 | Name | Description
 | Configure | Automatically configures the log4net system based on the application's configuration settings.
 | Configure(FileInfo) | Configures log4net using the specified configuration file.
 | Configure(Stream) | Configures log4net using the specified configuration data stream.
 | Configure(Uri) | Configures log4net using the specified configuration URI.
 | Configure(XmlElement) | Configures log4net using a log4net element
 | Configure(ILoggerRepository) | Automatically configures the ILoggerRepository using settings stored in the application's configuration file.
 | Configure(ILoggerRepository, FileInfo) | Configures the ILoggerRepository using the specified configuration file.
 | Configure(ILoggerRepository, Stream) | Configures the ILoggerRepository using the specified configuration file.
 | Configure(ILoggerRepository, Uri) | Configures the ILoggerRepository using the specified configuration URI.
 | Configure(ILoggerRepository, XmlElement) | Configures the ILoggerRepository using the specified XML element.
 | ConfigureAndWatch(FileInfo) | Configures log4net using the file specified, monitors the file for changes and reloads the configuration if a change is detected.
 | ConfigureAndWatch(ILoggerRepository, FileInfo) | Configures the ILoggerRepository using the file specified, monitors the file for changes and reloads the configuration if a change is detected.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
XmlConfigurator Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.Configure Method

XmlConfigurator Configure Method Apache log4net™ SDK Documentation
Overload List
Name | Description
Configure | Automatically configures the log4net system based on the application's configuration settings.
Configure(FileInfo) | Configures log4net using the specified configuration file.
Configure(Stream) | Configures log4net using the specified configuration data stream.
Configure(Uri) | Configures log4net using the specified configuration URI.
Configure(XmlElement) | Configures log4net using a log4net element
Configure(ILoggerRepository) | Automatically configures the ILoggerRepository using settings stored in the application's configuration file.
Configure(ILoggerRepository, FileInfo) | Configures the ILoggerRepository using the specified configuration file.
Configure(ILoggerRepository, Stream) | Configures the ILoggerRepository using the specified configuration file.
Configure(ILoggerRepository, Uri) | Configures the ILoggerRepository using the specified configuration URI.
Configure(ILoggerRepository, XmlElement) | Configures the ILoggerRepository using the specified XML element.
Back to Top
See Also
XmlConfigurator Class
XmlConfigurator Members
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.Configure Method

XmlConfigurator Configure Method Apache log4net™ SDK Documentation
Automatically configures the log4net system based on the application's configuration settings.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure()
public static ICollection Configure()
Public Shared Function Configure As ICollection
Public Shared Function Configure As ICollection
public:
static ICollection^ Configure()
public:
static ICollection^ Configure()
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.XmlConfigurator.Configure"]
Remarks

            Each application has a configuration file. This has the
            same name as the application with '.config' appended.
            This file is XML and calling this function prompts the
            configurator to look in that file for a section called
            log4net that contains the configuration data.

            To use this method to configure log4net you must specify
            the Log4NetConfigurationSectionHandler section
            handler for the log4net configuration section. See the
            Log4NetConfigurationSectionHandler for an example.

See Also
XmlConfigurator Class
XmlConfigurator Members
Configure Overload
log4net.Config Namespace
log4net.Config Log4NetConfigurationSectionHandler
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.Configure Method (FileInfo)

XmlConfigurator Configure Method (FileInfo) Apache log4net™ SDK Documentation
Configures log4net using the specified configuration file.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    FileInfo configFile
)
public static ICollection Configure(
    FileInfo configFile
)
Public Shared Function Configure (
    configFile As FileInfo
) As ICollection
Public Shared Function Configure (
    configFile As FileInfo
) As ICollection
public:
static ICollection^ Configure(
    FileInfo^ configFile
)
public:
static ICollection^ Configure(
    FileInfo^ configFile
)
Parameters
configFile
Type:   Online System.IO FileInfo
The XML file to load the configuration from.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.XmlConfigurator.Configure(System.IO.FileInfo)"]
Remarks

            The configuration file must be valid XML. It must contain
            at least one element called log4net that holds
            the log4net configuration data.

            The log4net configuration file can possible be specified in the application's
            configuration file (either MyAppName.exe.config for a
            normal application on Web.config for an ASP.NET application).

            The first element matching <configuration> will be read as the
            configuration. If this file is also a .NET .config file then you must specify
            a configuration section for the log4net element otherwise .NET will
            complain. Set the type for the section handler to   Online IgnoreSectionHandler, for example:

XML
View Colorized Copy to Clipboard Print
<configSections><section name="log4net" type="System.Configuration.IgnoreSectionHandler" /></configSections>
<configSections><section name="log4net" type="System.Configuration.IgnoreSectionHandler" /></configSections>
Examples

            The following example configures log4net using a configuration file, of which the
            location is stored in the application's configuration file :

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
using log4net.Config;
using System.IO;
using System.Configuration;

...

XmlConfigurator.Configure(new FileInfo(ConfigurationSettings.AppSettings["log4net-config-file"]));
using log4net.Config;
using System.IO;
using System.Configuration;

...

XmlConfigurator.Configure(new FileInfo(ConfigurationSettings.AppSettings["log4net-config-file"]));

            In the .config file, the path to the log4net can be specified like this :

XML
View Colorized Copy to Clipboard Print
<configuration><appSettings><add key="log4net-config-file" value="log.config" /></appSettings></configuration>
<configuration><appSettings><add key="log4net-config-file" value="log.config" /></appSettings></configuration>
See Also
XmlConfigurator Class
XmlConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.Configure Method (Stream)

XmlConfigurator Configure Method (Stream) Apache log4net™ SDK Documentation
Configures log4net using the specified configuration data stream.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    Stream configStream
)
public static ICollection Configure(
    Stream configStream
)
Public Shared Function Configure (
    configStream As Stream
) As ICollection
Public Shared Function Configure (
    configStream As Stream
) As ICollection
public:
static ICollection^ Configure(
    Stream^ configStream
)
public:
static ICollection^ Configure(
    Stream^ configStream
)
Parameters
configStream
Type:   Online System.IO Stream
A stream to load the XML configuration from.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.XmlConfigurator.Configure(System.IO.Stream)"]
Remarks

            The configuration data must be valid XML. It must contain
            at least one element called log4net that holds
            the log4net configuration data.

            Note that this method will NOT close the stream parameter.

See Also
XmlConfigurator Class
XmlConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.Configure Method (Uri)

XmlConfigurator Configure Method (Uri) Apache log4net™ SDK Documentation
Configures log4net using the specified configuration URI.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    Uri configUri
)
public static ICollection Configure(
    Uri configUri
)
Public Shared Function Configure (
    configUri As Uri
) As ICollection
Public Shared Function Configure (
    configUri As Uri
) As ICollection
public:
static ICollection^ Configure(
    Uri^ configUri
)
public:
static ICollection^ Configure(
    Uri^ configUri
)
Parameters
configUri
Type:   Online System Uri
A URI to load the XML configuration from.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.XmlConfigurator.Configure(System.Uri)"]
Remarks

            The configuration data must be valid XML. It must contain
            at least one element called log4net that holds
            the log4net configuration data.

            The   Online WebRequest must support the URI scheme specified.

See Also
XmlConfigurator Class
XmlConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.Configure Method (XmlElement)

XmlConfigurator Configure Method (XmlElement) Apache log4net™ SDK Documentation
Configures log4net using a log4net element

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    XmlElement element
)
public static ICollection Configure(
    XmlElement element
)
Public Shared Function Configure (
    element As XmlElement
) As ICollection
Public Shared Function Configure (
    element As XmlElement
) As ICollection
public:
static ICollection^ Configure(
    XmlElement^ element
)
public:
static ICollection^ Configure(
    XmlElement^ element
)
Parameters
element
Type:   Online System.Xml XmlElement
The element to parse.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.XmlConfigurator.Configure(System.Xml.XmlElement)"]
Remarks

            Loads the log4net configuration from the XML element
            supplied as element.

See Also
XmlConfigurator Class
XmlConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.Configure Method (ILoggerRepository)

XmlConfigurator Configure Method (ILoggerRepository) Apache log4net™ SDK Documentation
Automatically configures the ILoggerRepository using settings stored in the application's configuration file.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    ILoggerRepository repository
)
public static ICollection Configure(
    ILoggerRepository repository
)
Public Shared Function Configure (
    repository As ILoggerRepository
) As ICollection
Public Shared Function Configure (
    repository As ILoggerRepository
) As ICollection
public:
static ICollection^ Configure(
    ILoggerRepository^ repository
)
public:
static ICollection^ Configure(
    ILoggerRepository^ repository
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.XmlConfigurator.Configure(log4net.Repository.ILoggerRepository)"]
Remarks

            Each application has a configuration file. This has the
            same name as the application with '.config' appended.
            This file is XML and calling this function prompts the
            configurator to look in that file for a section called
            log4net that contains the configuration data.

            To use this method to configure log4net you must specify
            the Log4NetConfigurationSectionHandler section
            handler for the log4net configuration section. See the
            Log4NetConfigurationSectionHandler for an example.

See Also
XmlConfigurator Class
XmlConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.Configure Method (ILoggerRepository, FileInfo)

XmlConfigurator Configure Method (ILoggerRepository, FileInfo) Apache log4net™ SDK Documentation
Configures the ILoggerRepository using the specified configuration file.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    ILoggerRepository repository,
    FileInfo configFile
)
public static ICollection Configure(
    ILoggerRepository repository,
    FileInfo configFile
)
Public Shared Function Configure (
    repository As ILoggerRepository,
    configFile As FileInfo
) As ICollection
Public Shared Function Configure (
    repository As ILoggerRepository,
    configFile As FileInfo
) As ICollection
public:
static ICollection^ Configure(
    ILoggerRepository^ repository,
    FileInfo^ configFile
)
public:
static ICollection^ Configure(
    ILoggerRepository^ repository,
    FileInfo^ configFile
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
configFile
Type:   Online System.IO FileInfo
The XML file to load the configuration from.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.XmlConfigurator.Configure(log4net.Repository.ILoggerRepository,System.IO.FileInfo)"]
Remarks

            The configuration file must be valid XML. It must contain
            at least one element called log4net that holds
            the configuration data.

            The log4net configuration file can possible be specified in the application's
            configuration file (either MyAppName.exe.config for a
            normal application on Web.config for an ASP.NET application).

            The first element matching <configuration> will be read as the
            configuration. If this file is also a .NET .config file then you must specify
            a configuration section for the log4net element otherwise .NET will
            complain. Set the type for the section handler to   Online IgnoreSectionHandler, for example:

XML
View Colorized Copy to Clipboard Print
<configSections><section name="log4net" type="System.Configuration.IgnoreSectionHandler" /></configSections>
<configSections><section name="log4net" type="System.Configuration.IgnoreSectionHandler" /></configSections>
Examples

            The following example configures log4net using a configuration file, of which the
            location is stored in the application's configuration file :

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
using log4net.Config;
using System.IO;
using System.Configuration;

...

XmlConfigurator.Configure(new FileInfo(ConfigurationSettings.AppSettings["log4net-config-file"]));
using log4net.Config;
using System.IO;
using System.Configuration;

...

XmlConfigurator.Configure(new FileInfo(ConfigurationSettings.AppSettings["log4net-config-file"]));

            In the .config file, the path to the log4net can be specified like this :

XML
View Colorized Copy to Clipboard Print
<configuration><appSettings><add key="log4net-config-file" value="log.config" /></appSettings></configuration>
<configuration><appSettings><add key="log4net-config-file" value="log.config" /></appSettings></configuration>
See Also
XmlConfigurator Class
XmlConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.Configure Method (ILoggerRepository, Stream)

XmlConfigurator Configure Method (ILoggerRepository, Stream) Apache log4net™ SDK Documentation
Configures the ILoggerRepository using the specified configuration file.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    ILoggerRepository repository,
    Stream configStream
)
public static ICollection Configure(
    ILoggerRepository repository,
    Stream configStream
)
Public Shared Function Configure (
    repository As ILoggerRepository,
    configStream As Stream
) As ICollection
Public Shared Function Configure (
    repository As ILoggerRepository,
    configStream As Stream
) As ICollection
public:
static ICollection^ Configure(
    ILoggerRepository^ repository,
    Stream^ configStream
)
public:
static ICollection^ Configure(
    ILoggerRepository^ repository,
    Stream^ configStream
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
configStream
Type:   Online System.IO Stream
The stream to load the XML configuration from.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.XmlConfigurator.Configure(log4net.Repository.ILoggerRepository,System.IO.Stream)"]
Remarks

            The configuration data must be valid XML. It must contain
            at least one element called log4net that holds
            the configuration data.

            Note that this method will NOT close the stream parameter.

See Also
XmlConfigurator Class
XmlConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.Configure Method (ILoggerRepository, Uri)

XmlConfigurator Configure Method (ILoggerRepository, Uri) Apache log4net™ SDK Documentation
Configures the ILoggerRepository using the specified configuration URI.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    ILoggerRepository repository,
    Uri configUri
)
public static ICollection Configure(
    ILoggerRepository repository,
    Uri configUri
)
Public Shared Function Configure (
    repository As ILoggerRepository,
    configUri As Uri
) As ICollection
Public Shared Function Configure (
    repository As ILoggerRepository,
    configUri As Uri
) As ICollection
public:
static ICollection^ Configure(
    ILoggerRepository^ repository,
    Uri^ configUri
)
public:
static ICollection^ Configure(
    ILoggerRepository^ repository,
    Uri^ configUri
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
configUri
Type:   Online System Uri
A URI to load the XML configuration from.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.XmlConfigurator.Configure(log4net.Repository.ILoggerRepository,System.Uri)"]
Remarks

            The configuration data must be valid XML. It must contain
            at least one element called log4net that holds
            the configuration data.

            The   Online WebRequest must support the URI scheme specified.

See Also
XmlConfigurator Class
XmlConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.Configure Method (ILoggerRepository, XmlElement)

XmlConfigurator Configure Method (ILoggerRepository, XmlElement) Apache log4net™ SDK Documentation
Configures the ILoggerRepository using the specified XML element.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection Configure(
    ILoggerRepository repository,
    XmlElement element
)
public static ICollection Configure(
    ILoggerRepository repository,
    XmlElement element
)
Public Shared Function Configure (
    repository As ILoggerRepository,
    element As XmlElement
) As ICollection
Public Shared Function Configure (
    repository As ILoggerRepository,
    element As XmlElement
) As ICollection
public:
static ICollection^ Configure(
    ILoggerRepository^ repository,
    XmlElement^ element
)
public:
static ICollection^ Configure(
    ILoggerRepository^ repository,
    XmlElement^ element
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
element
Type:   Online System.Xml XmlElement
The element to parse.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.XmlConfigurator.Configure(log4net.Repository.ILoggerRepository,System.Xml.XmlElement)"]
Remarks

            Loads the log4net configuration from the XML element
            supplied as element.

See Also
XmlConfigurator Class
XmlConfigurator Members
Configure Overload
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.ConfigureAndWatch Method

XmlConfigurator ConfigureAndWatch Method Apache log4net™ SDK Documentation
Overload List
Name | Description
ConfigureAndWatch(FileInfo) | Configures log4net using the file specified, monitors the file for changes and reloads the configuration if a change is detected.
ConfigureAndWatch(ILoggerRepository, FileInfo) | Configures the ILoggerRepository using the file specified, monitors the file for changes and reloads the configuration if a change is detected.
Back to Top
See Also
XmlConfigurator Class
XmlConfigurator Members
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.ConfigureAndWatch Method (FileInfo)

XmlConfigurator ConfigureAndWatch Method (FileInfo) Apache log4net™ SDK Documentation
Configures log4net using the file specified, monitors the file for changes and reloads the configuration if a change is detected.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection ConfigureAndWatch(
    FileInfo configFile
)
public static ICollection ConfigureAndWatch(
    FileInfo configFile
)
Public Shared Function ConfigureAndWatch (
    configFile As FileInfo
) As ICollection
Public Shared Function ConfigureAndWatch (
    configFile As FileInfo
) As ICollection
public:
static ICollection^ ConfigureAndWatch(
    FileInfo^ configFile
)
public:
static ICollection^ ConfigureAndWatch(
    FileInfo^ configFile
)
Parameters
configFile
Type:   Online System.IO FileInfo
The XML file to load the configuration from.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.XmlConfigurator.ConfigureAndWatch(System.IO.FileInfo)"]
Remarks

            The configuration file must be valid XML. It must contain
            at least one element called log4net that holds
            the configuration data.

            The configuration file will be monitored using a   Online FileSystemWatcher
            and depends on the behavior of that class.

            For more information on how to configure log4net using
            a separate configuration file, see [M:Configure(FileInfo)].

See Also
XmlConfigurator Class
XmlConfigurator Members
ConfigureAndWatch Overload
log4net.Config Namespace
[M:Configure(FileInfo)]
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfigurator.ConfigureAndWatch Method (ILoggerRepository, FileInfo)

XmlConfigurator ConfigureAndWatch Method (ILoggerRepository, FileInfo) Apache log4net™ SDK Documentation
Configures the ILoggerRepository using the file specified, monitors the file for changes and reloads the configuration if a change is detected.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection ConfigureAndWatch(
    ILoggerRepository repository,
    FileInfo configFile
)
public static ICollection ConfigureAndWatch(
    ILoggerRepository repository,
    FileInfo configFile
)
Public Shared Function ConfigureAndWatch (
    repository As ILoggerRepository,
    configFile As FileInfo
) As ICollection
Public Shared Function ConfigureAndWatch (
    repository As ILoggerRepository,
    configFile As FileInfo
) As ICollection
public:
static ICollection^ ConfigureAndWatch(
    ILoggerRepository^ repository,
    FileInfo^ configFile
)
public:
static ICollection^ ConfigureAndWatch(
    ILoggerRepository^ repository,
    FileInfo^ configFile
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository to configure.
configFile
Type:   Online System.IO FileInfo
The XML file to load the configuration from.
Return Value
Type:   Online ICollection
[Missing <returns> documentation for "M:log4net.Config.XmlConfigurator.ConfigureAndWatch(log4net.Repository.ILoggerRepository,System.IO.FileInfo)"]
Remarks

            The configuration file must be valid XML. It must contain
            at least one element called log4net that holds
            the configuration data.

            The configuration file will be monitored using a   Online FileSystemWatcher
            and depends on the behavior of that class.

            For more information on how to configure log4net using
            a separate configuration file, see [M:Configure(FileInfo)].

See Also
XmlConfigurator Class
XmlConfigurator Members
ConfigureAndWatch Overload
log4net.Config Namespace
[M:Configure(FileInfo)]
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfiguratorAttribute Class

XmlConfiguratorAttribute Class Apache log4net™ SDK Documentation
Assembly level attribute to configure the XmlConfigurator.
Inheritance Hierarchy
Online System Object
Online System Attribute
log4net.Config ConfiguratorAttribute
log4net.Config XmlConfiguratorAttribute
log4net.Config DOMConfiguratorAttribute

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class XmlConfiguratorAttribute : ConfiguratorAttribute
[SerializableAttribute]
public class XmlConfiguratorAttribute : ConfiguratorAttribute
<SerializableAttribute>
Public Class XmlConfiguratorAttribute
    Inherits ConfiguratorAttribute
<SerializableAttribute>
Public Class XmlConfiguratorAttribute
    Inherits ConfiguratorAttribute
[SerializableAttribute]
public ref class XmlConfiguratorAttribute : public ConfiguratorAttribute
[SerializableAttribute]
public ref class XmlConfiguratorAttribute : public ConfiguratorAttribute
Remarks

            This attribute may only be used at the assembly scope and can only
            be used once per assembly.

            Use this attribute to configure the XmlConfigurator
            without calling one of the [M:XmlConfigurator.Configure()]
            methods.

            If neither of the ConfigFile or ConfigFileExtension
            properties are set the configuration is loaded from the application's .config file.
            If set the ConfigFile property takes priority over the
            ConfigFileExtension property. The ConfigFile property
            specifies a path to a file to load the config from. The path is relative to the
            application's base directory;   Online BaseDirectory.
            The ConfigFileExtension property is used as a postfix to the assembly file name.
            The config file must be located in the  application's base directory;   Online BaseDirectory.
            For example in a console application setting the ConfigFileExtension to
            config has the same effect as not specifying the ConfigFile or
            ConfigFileExtension properties.

            The Watch property can be set to cause the XmlConfigurator
            to watch the configuration file for changes.

  Note  Note

            Log4net will only look for assembly level configuration attributes once.
            When using the log4net assembly level attributes to control the configuration
            of log4net you must ensure that the first call to any of the
            LoggerManager methods is made from the assembly with the configuration
            attributes.

            If you cannot guarantee the order in which log4net calls will be made from
            different assemblies you must use programmatic configuration instead, i.e.
            call the [M:XmlConfigurator.Configure()] method directly.

See Also
XmlConfiguratorAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfiguratorAttribute Members

XmlConfiguratorAttribute Members Apache log4net™ SDK Documentation
The XmlConfiguratorAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | XmlConfiguratorAttribute | Default constructor
Back to Top
Methods
 | Name | Description
Public method | CompareTo | Compare this instance to another ConfiguratorAttribute (Inherited from ConfiguratorAttribute.)
Public method | Configure | Configures the ILoggerRepository for the specified assembly. (Overrides ConfiguratorAttribute Configure(Assembly, ILoggerRepository).)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ConfigFile | Gets or sets the filename of the configuration file.
Public property | ConfigFileExtension | Gets or sets the extension of the configuration file.
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Public property | Watch | Gets or sets a value indicating whether to watch the configuration file.
Back to Top
See Also
XmlConfiguratorAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfiguratorAttribute Constructor

XmlConfiguratorAttribute Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public XmlConfiguratorAttribute()
public XmlConfiguratorAttribute()
Public Sub New
Public Sub New
public:
XmlConfiguratorAttribute()
public:
XmlConfiguratorAttribute()
Remarks

            Default constructor

See Also
XmlConfiguratorAttribute Class
XmlConfiguratorAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfiguratorAttribute Methods

XmlConfiguratorAttribute Methods Apache log4net™ SDK Documentation
The XmlConfiguratorAttribute type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo | Compare this instance to another ConfiguratorAttribute (Inherited from ConfiguratorAttribute.)
Public method | Configure | Configures the ILoggerRepository for the specified assembly. (Overrides ConfiguratorAttribute Configure(Assembly, ILoggerRepository).)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
XmlConfiguratorAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfiguratorAttribute.Configure Method

XmlConfiguratorAttribute Configure Method Apache log4net™ SDK Documentation
Configures the ILoggerRepository for the specified assembly.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Configure(
    Assembly sourceAssembly,
    ILoggerRepository targetRepository
)
public override void Configure(
    Assembly sourceAssembly,
    ILoggerRepository targetRepository
)
Public Overrides Sub Configure (
    sourceAssembly As Assembly,
    targetRepository As ILoggerRepository
)
Public Overrides Sub Configure (
    sourceAssembly As Assembly,
    targetRepository As ILoggerRepository
)
public:
virtual void Configure(
    Assembly^ sourceAssembly,
    ILoggerRepository^ targetRepository
) override
public:
virtual void Configure(
    Assembly^ sourceAssembly,
    ILoggerRepository^ targetRepository
) override
Parameters
sourceAssembly
Type:   Online System.Reflection Assembly
The assembly that this attribute was defined on.
targetRepository
Type: log4net.Repository ILoggerRepository
The repository to configure.
Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | The targetRepository does not extend Hierarchy.
Remarks

            Configure the repository using the XmlConfigurator.
            The targetRepository specified must extend the Hierarchy
            class otherwise the XmlConfigurator will not be able to
            configure it.

See Also
XmlConfiguratorAttribute Class
XmlConfiguratorAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfiguratorAttribute Properties

XmlConfiguratorAttribute Properties Apache log4net™ SDK Documentation
The XmlConfiguratorAttribute type exposes the following members.
Properties
 | Name | Description
Public property | ConfigFile | Gets or sets the filename of the configuration file.
Public property | ConfigFileExtension | Gets or sets the extension of the configuration file.
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Public property | Watch | Gets or sets a value indicating whether to watch the configuration file.
Back to Top
See Also
XmlConfiguratorAttribute Class
log4net.Config Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfiguratorAttribute.ConfigFile Property

XmlConfiguratorAttribute ConfigFile Property Apache log4net™ SDK Documentation
Gets or sets the filename of the configuration file.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ConfigFile { get; set; }
public string ConfigFile { get; set; }
Public Property ConfigFile As String
    Get
    Set
Public Property ConfigFile As String
    Get
    Set
public:
property String^ ConfigFile {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ConfigFile {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The filename of the configuration file.

Remarks

            If specified, this is the name of the configuration file to use with
            the XmlConfigurator. This file path is relative to the
            application base directory (  Online BaseDirectory).

            The ConfigFile takes priority over the ConfigFileExtension.

See Also
XmlConfiguratorAttribute Class
XmlConfiguratorAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfiguratorAttribute.ConfigFileExtension Property

XmlConfiguratorAttribute ConfigFileExtension Property Apache log4net™ SDK Documentation
Gets or sets the extension of the configuration file.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ConfigFileExtension { get; set; }
public string ConfigFileExtension { get; set; }
Public Property ConfigFileExtension As String
    Get
    Set
Public Property ConfigFileExtension As String
    Get
    Set
public:
property String^ ConfigFileExtension {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ConfigFileExtension {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The extension of the configuration file.

Remarks

            If specified this is the extension for the configuration file.
            The path to the config file is built by using the application
            base directory (  Online BaseDirectory),
            the assembly file name and the config file extension.

            If the ConfigFileExtension is set to MyExt then
            possible config file names would be: MyConsoleApp.exe.MyExt or
            MyClassLibrary.dll.MyExt.

            The ConfigFile takes priority over the ConfigFileExtension.

See Also
XmlConfiguratorAttribute Class
XmlConfiguratorAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlConfiguratorAttribute.Watch Property

XmlConfiguratorAttribute Watch Property Apache log4net™ SDK Documentation
Gets or sets a value indicating whether to watch the configuration file.

Namespace: log4net.Config
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Watch { get; set; }
public bool Watch { get; set; }
Public Property Watch As Boolean
    Get
    Set
Public Property Watch As Boolean
    Get
    Set
public:
property bool Watch {
    bool get ();
    void set (bool value);
}
public:
property bool Watch {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if the configuration should be watched, false otherwise.

Remarks

            If this flag is specified and set to true then the framework
            will watch the configuration file and will reload the config each time
            the file is modified.

            The config file can only be watched if it is loaded from local disk.
            In a No-Touch (Smart Client) deployment where the application is downloaded
            from a web server the config file may not reside on the local disk
            and therefore it may not be able to watch it.

  Note  Note

            Watching configuration is not supported on the SSCLI.

See Also
XmlConfiguratorAttribute Class
XmlConfiguratorAttribute Members
log4net.Config Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.Core Namespace

log4net.Core Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | CompactRepositorySelector | The implementation of the IRepositorySelector interface suitable for use with the compact framework
Public class | DefaultRepositorySelector | The default implementation of the IRepositorySelector interface.
Public class | ExceptionEvaluator | An evaluator that triggers on an Exception type
Public class | Level | Defines the default set of levels recognized by the system.
Public class | LevelCollection | A strongly-typed collection of Level objects.
Public class | LevelEvaluator | An evaluator that triggers at a threshold level
Public class | LevelMap | Mapping between string name and Level object
Public class | LocationInfo | The internal representation of caller location information.
Public class | LogException | Exception base type for log4net.
Public class | LoggerManager | Static manager that controls the creation of repositories
Public class | LoggerRepositoryCreationEventArgs | Provides data for the LoggerRepositoryCreatedEvent event.
Public class | LoggerWrapperImpl | Implementation of the ILoggerWrapper interface.
Public class | LoggingEvent | The internal representation of logging events.
Public class | LogImpl | Implementation of ILog wrapper interface.
Public class | MethodItem | provides method information without actually referencing a System.Reflection.MethodBase as that would require that the containing assembly is loaded.
Public class | SecurityContext | A SecurityContext used by log4net when interacting with protected resources
Public class | SecurityContextProvider | The SecurityContextProvider providers default SecurityContext instances.
Public class | StackFrameItem | provides stack frame information without actually referencing a System.Diagnostics.StackFrame as that would require that the containing assembly is loaded.
Public class | TimeEvaluator | An evaluator that triggers after specified number of seconds.
Public class | WrapperMap | Maps between logger objects and wrapper objects.
Structures
 | Structure | Description
Public structure | LoggingEventData | Portable data structure used by LoggingEvent
Interfaces
 | Interface | Description
Public interface | IAppenderAttachable | Interface for attaching appenders to objects.
Public interface | IErrorHandler | Appenders may delegate their error handling to an IErrorHandler.
Public interface | IFixingRequired | Interface for objects that require fixing.
Public interface | ILogger | Interface that all loggers implement
Public interface | ILoggerWrapper | Base interface for all wrappers
Public interface | IOptionHandler | Interface used to delay activate a configured object.
Public interface | IRepositorySelector | Interface used by the LogManager to select the ILoggerRepository.
Public interface | ITriggeringEventEvaluator | Test if an LoggingEvent triggers an action
Public interface | LevelCollection ILevelCollectionEnumerator | Supports type-safe iteration over a LevelCollection.
Delegates
 | Delegate | Description
Public delegate | LoggerRepositoryCreationEventHandler | Delegate used to handle logger repository creation event notifications
Public delegate | WrapperCreationHandler | Delegate used to handle creation of new wrappers.
Enumerations
 | Enumeration | Description
Public enumeration | ErrorCode | Defined error codes that can be passed to the [M:IErrorHandler.Error(string, Exception, ErrorCode)] method.
Public enumeration | FixFlags | Flags passed to the Fix property
Protected enumeration | LevelCollection Tag | Type visible only to our subclasses Used to access protected constructor

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector Class

CompactRepositorySelector Class Apache log4net™ SDK Documentation
The implementation of the IRepositorySelector interface suitable for use with the compact framework
Inheritance Hierarchy
Online System Object
log4net.Core CompactRepositorySelector

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CompactRepositorySelector : IRepositorySelector
public class CompactRepositorySelector : IRepositorySelector
Public Class CompactRepositorySelector
    Implements IRepositorySelector
Public Class CompactRepositorySelector
    Implements IRepositorySelector
public ref class CompactRepositorySelector : IRepositorySelector
public ref class CompactRepositorySelector : IRepositorySelector
Remarks

            This IRepositorySelector implementation is a simple
            mapping between repository name and ILoggerRepository
            object.

            The .NET Compact Framework 1.0 does not support retrieving assembly
            level attributes therefore unlike the DefaultRepositorySelector
            this selector does not examine the calling assembly for attributes.

See Also
CompactRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector Members

CompactRepositorySelector Members Apache log4net™ SDK Documentation
The CompactRepositorySelector type exposes the following members.
Constructors
 | Name | Description
Public method | CompactRepositorySelector | Create a new repository selector
Back to Top
Methods
 | Name | Description
Public method | CreateRepository(Assembly, Type) | Create a new repository for the assembly specified
Public method | CreateRepository(String, Type) | Create a new repository for the repository specified
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | ExistsRepository | Test if a named repository exists
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAllRepositories | Gets a list of ILoggerRepository objects
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetRepository(Assembly) | Get the ILoggerRepository for the specified assembly
Public method | GetRepository(String) | Get the named ILoggerRepository
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnLoggerRepositoryCreatedEvent | Notify the registered listeners that the repository has been created
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Events
 | Name | Description
Public event | LoggerRepositoryCreatedEvent | Event to notify that a logger repository has been created.
Back to Top
See Also
CompactRepositorySelector Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector Constructor

CompactRepositorySelector Constructor Apache log4net™ SDK Documentation
Create a new repository selector

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompactRepositorySelector(
    Type defaultRepositoryType
)
public CompactRepositorySelector(
    Type defaultRepositoryType
)
Public Sub New (
    defaultRepositoryType As Type
)
Public Sub New (
    defaultRepositoryType As Type
)
public:
CompactRepositorySelector(
    Type^ defaultRepositoryType
)
public:
CompactRepositorySelector(
    Type^ defaultRepositoryType
)
Parameters
defaultRepositoryType
Type:   Online System Type
the type of the repositories to create, must implement ILoggerRepository
Exceptions
Exception | Condition
Online System ArgumentNullException | throw if defaultRepositoryType is null
Online System ArgumentOutOfRangeException | throw if defaultRepositoryType does not implement ILoggerRepository
Remarks

            Create an new compact repository selector.
            The default type for repositories must be specified,
            an appropriate value would be Hierarchy.

See Also
CompactRepositorySelector Class
CompactRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector Methods

CompactRepositorySelector Methods Apache log4net™ SDK Documentation
The CompactRepositorySelector type exposes the following members.
Methods
 | Name | Description
Public method | CreateRepository(Assembly, Type) | Create a new repository for the assembly specified
Public method | CreateRepository(String, Type) | Create a new repository for the repository specified
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | ExistsRepository | Test if a named repository exists
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAllRepositories | Gets a list of ILoggerRepository objects
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetRepository(Assembly) | Get the ILoggerRepository for the specified assembly
Public method | GetRepository(String) | Get the named ILoggerRepository
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnLoggerRepositoryCreatedEvent | Notify the registered listeners that the repository has been created
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CompactRepositorySelector Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector.CreateRepository Method

CompactRepositorySelector CreateRepository Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | CreateRepository(Assembly, Type) | Create a new repository for the assembly specified
Public method | CreateRepository(String, Type) | Create a new repository for the repository specified
Back to Top
See Also
CompactRepositorySelector Class
CompactRepositorySelector Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector.CreateRepository Method (Assembly, Type)

CompactRepositorySelector CreateRepository Method (Assembly, Type) Apache log4net™ SDK Documentation
Create a new repository for the assembly specified

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository CreateRepository(
    Assembly assembly,
    Type repositoryType
)
public ILoggerRepository CreateRepository(
    Assembly assembly,
    Type repositoryType
)
Public Function CreateRepository (
    assembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
Public Function CreateRepository (
    assembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
public:
virtual ILoggerRepository^ CreateRepository(
    Assembly^ assembly,
    Type^ repositoryType
) sealed
public:
virtual ILoggerRepository^ CreateRepository(
    Assembly^ assembly,
    Type^ repositoryType
) sealed
Parameters
assembly
Type:   Online System.Reflection Assembly
not used
repositoryType
Type:   Online System Type
the type of repository to create, must implement ILoggerRepository
Return Value
Type: ILoggerRepository
the repository created
Implements
IRepositorySelector CreateRepository(Assembly, Type)
Remarks

            The assembly argument is not used. This selector does not create a
            separate repository for each assembly.

            If the repositoryType is null then the
            default repository type specified to the constructor is used.

            As a named repository is not specified the default repository is
            returned. The default repository is named log4net-default-repository.

See Also
CompactRepositorySelector Class
CompactRepositorySelector Members
CreateRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector.CreateRepository Method (String, Type)

CompactRepositorySelector CreateRepository Method (String, Type) Apache log4net™ SDK Documentation
Create a new repository for the repository specified

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository CreateRepository(
    string repositoryName,
    Type repositoryType
)
public ILoggerRepository CreateRepository(
    string repositoryName,
    Type repositoryType
)
Public Function CreateRepository (
    repositoryName As String,
    repositoryType As Type
) As ILoggerRepository
Public Function CreateRepository (
    repositoryName As String,
    repositoryType As Type
) As ILoggerRepository
public:
virtual ILoggerRepository^ CreateRepository(
    String^ repositoryName,
    Type^ repositoryType
) sealed
public:
virtual ILoggerRepository^ CreateRepository(
    String^ repositoryName,
    Type^ repositoryType
) sealed
Parameters
repositoryName
Type:   Online System String
the repository to associate with the ILoggerRepository
repositoryType
Type:   Online System Type
the type of repository to create, must implement ILoggerRepository.
            If this param is null then the default repository type is used.
Return Value
Type: ILoggerRepository
the repository created
Implements
IRepositorySelector CreateRepository(String, Type)
Exceptions
Exception | Condition
Online System ArgumentNullException | throw if repositoryName is null
log4net.Core LogException | throw if the repositoryName already exists
Remarks

            The ILoggerRepository created will be associated with the repository
            specified such that a call to [M:GetRepository(string)] with the
            same repository specified will return the same repository instance.

            If the named repository already exists an exception will be thrown.

            If repositoryType is null then the default
            repository type specified to the constructor is used.

See Also
CompactRepositorySelector Class
CompactRepositorySelector Members
CreateRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector.ExistsRepository Method

CompactRepositorySelector ExistsRepository Method Apache log4net™ SDK Documentation
Test if a named repository exists

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExistsRepository(
    string repositoryName
)
public bool ExistsRepository(
    string repositoryName
)
Public Function ExistsRepository (
    repositoryName As String
) As Boolean
Public Function ExistsRepository (
    repositoryName As String
) As Boolean
public:
virtual bool ExistsRepository(
    String^ repositoryName
) sealed
public:
virtual bool ExistsRepository(
    String^ repositoryName
) sealed
Parameters
repositoryName
Type:   Online System String
the named repository to check
Return Value
Type:   Online Boolean
true if the repository exists
Implements
IRepositorySelector ExistsRepository(String)
Remarks

            Test if a named repository exists. Use [M:CreateRepository(string, Type)]
            to create a new repository and [M:GetRepository(string)] to retrieve
            a repository.

See Also
CompactRepositorySelector Class
CompactRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector.GetAllRepositories Method

CompactRepositorySelector GetAllRepositories Method Apache log4net™ SDK Documentation
Gets a list of ILoggerRepository objects

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository[] GetAllRepositories()
public ILoggerRepository[] GetAllRepositories()
Public Function GetAllRepositories As ILoggerRepository()
Public Function GetAllRepositories As ILoggerRepository()
public:
virtual array<ILoggerRepository^>^ GetAllRepositories() sealed
public:
virtual array<ILoggerRepository^>^ GetAllRepositories() sealed
Return Value
Type:  ILoggerRepository
an array of all known ILoggerRepository objects
Implements
IRepositorySelector GetAllRepositories
Remarks

            Gets an array of all of the repositories created by this selector.

See Also
CompactRepositorySelector Class
CompactRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector.GetRepository Method

CompactRepositorySelector GetRepository Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | GetRepository(Assembly) | Get the ILoggerRepository for the specified assembly
Public method | GetRepository(String) | Get the named ILoggerRepository
Back to Top
See Also
CompactRepositorySelector Class
CompactRepositorySelector Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector.GetRepository Method (Assembly)

CompactRepositorySelector GetRepository Method (Assembly) Apache log4net™ SDK Documentation
Get the ILoggerRepository for the specified assembly

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository GetRepository(
    Assembly assembly
)
public ILoggerRepository GetRepository(
    Assembly assembly
)
Public Function GetRepository (
    assembly As Assembly
) As ILoggerRepository
Public Function GetRepository (
    assembly As Assembly
) As ILoggerRepository
public:
virtual ILoggerRepository^ GetRepository(
    Assembly^ assembly
) sealed
public:
virtual ILoggerRepository^ GetRepository(
    Assembly^ assembly
) sealed
Parameters
assembly
Type:   Online System.Reflection Assembly
not used
Return Value
Type: ILoggerRepository
The default ILoggerRepository
Implements
IRepositorySelector GetRepository(Assembly)
Remarks

            The assembly argument is not used. This selector does not create a
            separate repository for each assembly.

            As a named repository is not specified the default repository is
            returned. The default repository is named log4net-default-repository.

See Also
CompactRepositorySelector Class
CompactRepositorySelector Members
GetRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector.GetRepository Method (String)

CompactRepositorySelector GetRepository Method (String) Apache log4net™ SDK Documentation
Get the named ILoggerRepository

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository GetRepository(
    string repositoryName
)
public ILoggerRepository GetRepository(
    string repositoryName
)
Public Function GetRepository (
    repositoryName As String
) As ILoggerRepository
Public Function GetRepository (
    repositoryName As String
) As ILoggerRepository
public:
virtual ILoggerRepository^ GetRepository(
    String^ repositoryName
) sealed
public:
virtual ILoggerRepository^ GetRepository(
    String^ repositoryName
) sealed
Parameters
repositoryName
Type:   Online System String
the name of the repository to lookup
Return Value
Type: ILoggerRepository
The named ILoggerRepository
Implements
IRepositorySelector GetRepository(String)
Exceptions
Exception | Condition
Online System ArgumentNullException | throw if repositoryName is null
log4net.Core LogException | throw if the repositoryName does not exist
Remarks

            Get the named ILoggerRepository. The default
            repository is log4net-default-repository. Other repositories
            must be created using the [M:CreateRepository(string, Type)].
            If the named repository does not exist an exception is thrown.

See Also
CompactRepositorySelector Class
CompactRepositorySelector Members
GetRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector.OnLoggerRepositoryCreatedEvent Method

CompactRepositorySelector OnLoggerRepositoryCreatedEvent Method Apache log4net™ SDK Documentation
Notify the registered listeners that the repository has been created

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void OnLoggerRepositoryCreatedEvent(
    ILoggerRepository repository
)
protected virtual void OnLoggerRepositoryCreatedEvent(
    ILoggerRepository repository
)
Protected Overridable Sub OnLoggerRepositoryCreatedEvent (
    repository As ILoggerRepository
)
Protected Overridable Sub OnLoggerRepositoryCreatedEvent (
    repository As ILoggerRepository
)
protected:
virtual void OnLoggerRepositoryCreatedEvent(
    ILoggerRepository^ repository
)
protected:
virtual void OnLoggerRepositoryCreatedEvent(
    ILoggerRepository^ repository
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository that has been created
Remarks

            Raises the LoggerRepositoryCreatedEvent
            event.

See Also
CompactRepositorySelector Class
CompactRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector Events

CompactRepositorySelector Events Apache log4net™ SDK Documentation
The CompactRepositorySelector type exposes the following members.
Events
 | Name | Description
Public event | LoggerRepositoryCreatedEvent | Event to notify that a logger repository has been created.
Back to Top
See Also
CompactRepositorySelector Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompactRepositorySelector.LoggerRepositoryCreatedEvent Event

CompactRepositorySelector LoggerRepositoryCreatedEvent Event Apache log4net™ SDK Documentation
Event to notify that a logger repository has been created.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event LoggerRepositoryCreationEventHandler LoggerRepositoryCreatedEvent
public event LoggerRepositoryCreationEventHandler LoggerRepositoryCreatedEvent
Public Event LoggerRepositoryCreatedEvent As LoggerRepositoryCreationEventHandler
Public Event LoggerRepositoryCreatedEvent As LoggerRepositoryCreationEventHandler
public:
virtual  event LoggerRepositoryCreationEventHandler^ LoggerRepositoryCreatedEvent {
    void add (LoggerRepositoryCreationEventHandler^ value);
    void remove (LoggerRepositoryCreationEventHandler^ value);
}
public:
virtual  event LoggerRepositoryCreationEventHandler^ LoggerRepositoryCreatedEvent {
    void add (LoggerRepositoryCreationEventHandler^ value);
    void remove (LoggerRepositoryCreationEventHandler^ value);
}
Field Value
Type:

            Event to notify that a logger repository has been created.

Implements
IRepositorySelector LoggerRepositoryCreatedEvent
Remarks

            Event raised when a new repository is created.
            The event source will be this selector. The event args will
            be a LoggerRepositoryCreationEventArgs which
            holds the newly created ILoggerRepository.

See Also
CompactRepositorySelector Class
CompactRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector Class

DefaultRepositorySelector Class Apache log4net™ SDK Documentation
The default implementation of the IRepositorySelector interface.
Inheritance Hierarchy
Online System Object
log4net.Core DefaultRepositorySelector

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DefaultRepositorySelector : IRepositorySelector
public class DefaultRepositorySelector : IRepositorySelector
Public Class DefaultRepositorySelector
    Implements IRepositorySelector
Public Class DefaultRepositorySelector
    Implements IRepositorySelector
public ref class DefaultRepositorySelector : IRepositorySelector
public ref class DefaultRepositorySelector : IRepositorySelector
Remarks

            Uses attributes defined on the calling assembly to determine how to
            configure the hierarchy for the repository.

See Also
DefaultRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector Members

DefaultRepositorySelector Members Apache log4net™ SDK Documentation
The DefaultRepositorySelector type exposes the following members.
Constructors
 | Name | Description
Public method | DefaultRepositorySelector | Creates a new repository selector.
Back to Top
Methods
 | Name | Description
Public method | AliasRepository | Aliases a repository to an existing repository.
Public method | CreateRepository(Assembly, Type) | Create a new repository for the assembly specified
Public method | CreateRepository(String, Type) | Creates a new repository for the specified repository.
Public method | CreateRepository(Assembly, Type, String, Boolean) | Creates a new repository for the assembly specified.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | ExistsRepository | Test if a named repository exists
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAllRepositories | Gets a list of ILoggerRepository objects
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetRepository(Assembly) | Gets the ILoggerRepository for the specified assembly.
Public method | GetRepository(String) | Gets the ILoggerRepository for the specified repository.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnLoggerRepositoryCreatedEvent | Notifies the registered listeners that the repository has been created.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Events
 | Name | Description
Public event | LoggerRepositoryCreatedEvent | Event to notify that a logger repository has been created.
Back to Top
See Also
DefaultRepositorySelector Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector Constructor

DefaultRepositorySelector Constructor Apache log4net™ SDK Documentation
Creates a new repository selector.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DefaultRepositorySelector(
    Type defaultRepositoryType
)
public DefaultRepositorySelector(
    Type defaultRepositoryType
)
Public Sub New (
    defaultRepositoryType As Type
)
Public Sub New (
    defaultRepositoryType As Type
)
public:
DefaultRepositorySelector(
    Type^ defaultRepositoryType
)
public:
DefaultRepositorySelector(
    Type^ defaultRepositoryType
)
Parameters
defaultRepositoryType
Type:   Online System Type
The type of the repositories to create, must implement ILoggerRepository
Exceptions
Exception | Condition
Online System ArgumentNullException | defaultRepositoryType is .
Online System ArgumentOutOfRangeException | defaultRepositoryType does not implement ILoggerRepository.
Remarks

            Create an new repository selector.
            The default type for repositories must be specified,
            an appropriate value would be Hierarchy.

See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector Methods

DefaultRepositorySelector Methods Apache log4net™ SDK Documentation
The DefaultRepositorySelector type exposes the following members.
Methods
 | Name | Description
Public method | AliasRepository | Aliases a repository to an existing repository.
Public method | CreateRepository(Assembly, Type) | Create a new repository for the assembly specified
Public method | CreateRepository(String, Type) | Creates a new repository for the specified repository.
Public method | CreateRepository(Assembly, Type, String, Boolean) | Creates a new repository for the assembly specified.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | ExistsRepository | Test if a named repository exists
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAllRepositories | Gets a list of ILoggerRepository objects
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetRepository(Assembly) | Gets the ILoggerRepository for the specified assembly.
Public method | GetRepository(String) | Gets the ILoggerRepository for the specified repository.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnLoggerRepositoryCreatedEvent | Notifies the registered listeners that the repository has been created.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DefaultRepositorySelector Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector.AliasRepository Method

DefaultRepositorySelector AliasRepository Method Apache log4net™ SDK Documentation
Aliases a repository to an existing repository.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AliasRepository(
    string repositoryAlias,
    ILoggerRepository repositoryTarget
)
public void AliasRepository(
    string repositoryAlias,
    ILoggerRepository repositoryTarget
)
Public Sub AliasRepository (
    repositoryAlias As String,
    repositoryTarget As ILoggerRepository
)
Public Sub AliasRepository (
    repositoryAlias As String,
    repositoryTarget As ILoggerRepository
)
public:
void AliasRepository(
    String^ repositoryAlias,
    ILoggerRepository^ repositoryTarget
)
public:
void AliasRepository(
    String^ repositoryAlias,
    ILoggerRepository^ repositoryTarget
)
Parameters
repositoryAlias
Type:   Online System String
The repository to alias.
repositoryTarget
Type: log4net.Repository ILoggerRepository
The repository that the repository is aliased to.
Exceptions
Exception | Condition
Online System ArgumentNullException | repositoryAlias is . -or- repositoryTarget is .
Remarks

            The repository specified will be aliased to the repository when created.
            The repository must not already exist.

            When the repository is created it must utilize the same repository type as
            the repository it is aliased to, otherwise the aliasing will fail.

See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector.CreateRepository Method

DefaultRepositorySelector CreateRepository Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | CreateRepository(Assembly, Type) | Create a new repository for the assembly specified
Public method | CreateRepository(String, Type) | Creates a new repository for the specified repository.
Public method | CreateRepository(Assembly, Type, String, Boolean) | Creates a new repository for the assembly specified.
Back to Top
See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector.CreateRepository Method (Assembly, Type)

DefaultRepositorySelector CreateRepository Method (Assembly, Type) Apache log4net™ SDK Documentation
Create a new repository for the assembly specified

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository CreateRepository(
    Assembly repositoryAssembly,
    Type repositoryType
)
public ILoggerRepository CreateRepository(
    Assembly repositoryAssembly,
    Type repositoryType
)
Public Function CreateRepository (
    repositoryAssembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
Public Function CreateRepository (
    repositoryAssembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
public:
virtual ILoggerRepository^ CreateRepository(
    Assembly^ repositoryAssembly,
    Type^ repositoryType
) sealed
public:
virtual ILoggerRepository^ CreateRepository(
    Assembly^ repositoryAssembly,
    Type^ repositoryType
) sealed
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
the assembly to use to create the repository to associate with the ILoggerRepository.
repositoryType
Type:   Online System Type
The type of repository to create, must implement ILoggerRepository.
Return Value
Type: ILoggerRepository
The repository created.
Implements
IRepositorySelector CreateRepository(Assembly, Type)
Exceptions
Exception | Condition
Online System ArgumentNullException | repositoryAssembly is .
Remarks

            The ILoggerRepository created will be associated with the repository
            specified such that a call to [M:GetRepository(Assembly)] with the
            same assembly specified will return the same repository instance.

            The type of the ILoggerRepository created and
            the repository to create can be overridden by specifying the
            RepositoryAttribute attribute on the
            repositoryAssembly.  The default values are to use the
            repositoryType implementation of the
            ILoggerRepository interface and to use the
              Online Name as the name of the repository.

            The ILoggerRepository created will be automatically
            configured using any ConfiguratorAttribute
            attributes defined on the repositoryAssembly.

            If a repository for the repositoryAssembly already exists
            that repository will be returned. An error will not be raised and that
            repository may be of a different type to that specified in repositoryType.
            Also the RepositoryAttribute attribute on the
            assembly may be used to override the repository type specified in
            repositoryType.

See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
CreateRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector.CreateRepository Method (String, Type)

DefaultRepositorySelector CreateRepository Method (String, Type) Apache log4net™ SDK Documentation
Creates a new repository for the specified repository.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository CreateRepository(
    string repositoryName,
    Type repositoryType
)
public ILoggerRepository CreateRepository(
    string repositoryName,
    Type repositoryType
)
Public Function CreateRepository (
    repositoryName As String,
    repositoryType As Type
) As ILoggerRepository
Public Function CreateRepository (
    repositoryName As String,
    repositoryType As Type
) As ILoggerRepository
public:
virtual ILoggerRepository^ CreateRepository(
    String^ repositoryName,
    Type^ repositoryType
) sealed
public:
virtual ILoggerRepository^ CreateRepository(
    String^ repositoryName,
    Type^ repositoryType
) sealed
Parameters
repositoryName
Type:   Online System String
The repository to associate with the ILoggerRepository.
repositoryType
Type:   Online System Type
The type of repository to create, must implement ILoggerRepository.
            If this param is   then the default repository type is used.
Return Value
Type: ILoggerRepository
The new repository.
Implements
IRepositorySelector CreateRepository(String, Type)
Exceptions
Exception | Condition
Online System ArgumentNullException | repositoryName is .
log4net.Core LogException | repositoryName already exists.
Remarks

            The ILoggerRepository created will be associated with the repository
            specified such that a call to [M:GetRepository(string)] with the
            same repository specified will return the same repository instance.

See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
CreateRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector.CreateRepository Method (Assembly, Type, String, Boolean)

DefaultRepositorySelector CreateRepository Method (Assembly, Type, String, Boolean) Apache log4net™ SDK Documentation
Creates a new repository for the assembly specified.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository CreateRepository(
    Assembly repositoryAssembly,
    Type repositoryType,
    string repositoryName,
    bool readAssemblyAttributes
)
public ILoggerRepository CreateRepository(
    Assembly repositoryAssembly,
    Type repositoryType,
    string repositoryName,
    bool readAssemblyAttributes
)
Public Function CreateRepository (
    repositoryAssembly As Assembly,
    repositoryType As Type,
    repositoryName As String,
    readAssemblyAttributes As Boolean
) As ILoggerRepository
Public Function CreateRepository (
    repositoryAssembly As Assembly,
    repositoryType As Type,
    repositoryName As String,
    readAssemblyAttributes As Boolean
) As ILoggerRepository
public:
ILoggerRepository^ CreateRepository(
    Assembly^ repositoryAssembly,
    Type^ repositoryType,
    String^ repositoryName,
    bool readAssemblyAttributes
)
public:
ILoggerRepository^ CreateRepository(
    Assembly^ repositoryAssembly,
    Type^ repositoryType,
    String^ repositoryName,
    bool readAssemblyAttributes
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
the assembly to use to create the repository to associate with the ILoggerRepository.
repositoryType
Type:   Online System Type
The type of repository to create, must implement ILoggerRepository.
repositoryName
Type:   Online System String
The name to assign to the created repository
readAssemblyAttributes
Type:   Online System Boolean
Set to true to read and apply the assembly attributes
Return Value
Type: ILoggerRepository
The repository created.
Exceptions
Exception | Condition
Online System ArgumentNullException | repositoryAssembly is .
Remarks

            The ILoggerRepository created will be associated with the repository
            specified such that a call to [M:GetRepository(Assembly)] with the
            same assembly specified will return the same repository instance.

            The type of the ILoggerRepository created and
            the repository to create can be overridden by specifying the
            RepositoryAttribute attribute on the
            repositoryAssembly.  The default values are to use the
            repositoryType implementation of the
            ILoggerRepository interface and to use the
              Online Name as the name of the repository.

            The ILoggerRepository created will be automatically
            configured using any ConfiguratorAttribute
            attributes defined on the repositoryAssembly.

            If a repository for the repositoryAssembly already exists
            that repository will be returned. An error will not be raised and that
            repository may be of a different type to that specified in repositoryType.
            Also the RepositoryAttribute attribute on the
            assembly may be used to override the repository type specified in
            repositoryType.

See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
CreateRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector.ExistsRepository Method

DefaultRepositorySelector ExistsRepository Method Apache log4net™ SDK Documentation
Test if a named repository exists

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExistsRepository(
    string repositoryName
)
public bool ExistsRepository(
    string repositoryName
)
Public Function ExistsRepository (
    repositoryName As String
) As Boolean
Public Function ExistsRepository (
    repositoryName As String
) As Boolean
public:
virtual bool ExistsRepository(
    String^ repositoryName
) sealed
public:
virtual bool ExistsRepository(
    String^ repositoryName
) sealed
Parameters
repositoryName
Type:   Online System String
the named repository to check
Return Value
Type:   Online Boolean
true if the repository exists
Implements
IRepositorySelector ExistsRepository(String)
Remarks

            Test if a named repository exists. Use [M:CreateRepository(string, Type)]
            to create a new repository and [M:GetRepository(string)] to retrieve
            a repository.

See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector.GetAllRepositories Method

DefaultRepositorySelector GetAllRepositories Method Apache log4net™ SDK Documentation
Gets a list of ILoggerRepository objects

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository[] GetAllRepositories()
public ILoggerRepository[] GetAllRepositories()
Public Function GetAllRepositories As ILoggerRepository()
Public Function GetAllRepositories As ILoggerRepository()
public:
virtual array<ILoggerRepository^>^ GetAllRepositories() sealed
public:
virtual array<ILoggerRepository^>^ GetAllRepositories() sealed
Return Value
Type:  ILoggerRepository
an array of all known ILoggerRepository objects
Implements
IRepositorySelector GetAllRepositories
Remarks

            Gets an array of all of the repositories created by this selector.

See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector.GetRepository Method

DefaultRepositorySelector GetRepository Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | GetRepository(Assembly) | Gets the ILoggerRepository for the specified assembly.
Public method | GetRepository(String) | Gets the ILoggerRepository for the specified repository.
Back to Top
See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector.GetRepository Method (Assembly)

DefaultRepositorySelector GetRepository Method (Assembly) Apache log4net™ SDK Documentation
Gets the ILoggerRepository for the specified assembly.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository GetRepository(
    Assembly repositoryAssembly
)
public ILoggerRepository GetRepository(
    Assembly repositoryAssembly
)
Public Function GetRepository (
    repositoryAssembly As Assembly
) As ILoggerRepository
Public Function GetRepository (
    repositoryAssembly As Assembly
) As ILoggerRepository
public:
virtual ILoggerRepository^ GetRepository(
    Assembly^ repositoryAssembly
) sealed
public:
virtual ILoggerRepository^ GetRepository(
    Assembly^ repositoryAssembly
) sealed
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly use to lookup the ILoggerRepository.
Return Value
Type: ILoggerRepository
The ILoggerRepository for the assembly
Implements
IRepositorySelector GetRepository(Assembly)
Exceptions
Exception | Condition
Online System ArgumentNullException | repositoryAssembly is .
Remarks

            The type of the ILoggerRepository created and the repository
            to create can be overridden by specifying the RepositoryAttribute
            attribute on the repositoryAssembly.

            The default values are to use the Hierarchy
            implementation of the ILoggerRepository interface and to use the
              Online Name as the name of the repository.

            The ILoggerRepository created will be automatically configured using
            any ConfiguratorAttribute attributes defined on
            the repositoryAssembly.

See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
GetRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector.GetRepository Method (String)

DefaultRepositorySelector GetRepository Method (String) Apache log4net™ SDK Documentation
Gets the ILoggerRepository for the specified repository.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository GetRepository(
    string repositoryName
)
public ILoggerRepository GetRepository(
    string repositoryName
)
Public Function GetRepository (
    repositoryName As String
) As ILoggerRepository
Public Function GetRepository (
    repositoryName As String
) As ILoggerRepository
public:
virtual ILoggerRepository^ GetRepository(
    String^ repositoryName
) sealed
public:
virtual ILoggerRepository^ GetRepository(
    String^ repositoryName
) sealed
Parameters
repositoryName
Type:   Online System String
The repository to use to lookup the ILoggerRepository.
Return Value
Type: ILoggerRepository
The ILoggerRepository for the specified repository.
Implements
IRepositorySelector GetRepository(String)
Exceptions
Exception | Condition
Online System ArgumentNullException | repositoryName is .
log4net.Core LogException | repositoryName does not exist.
Remarks

            Returns the named repository. If repositoryName is null
            a   Online ArgumentNullException is thrown. If the repository
            does not exist a LogException is thrown.

            Use [M:CreateRepository(string, Type)] to create a repository.

See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
GetRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector.OnLoggerRepositoryCreatedEvent Method

DefaultRepositorySelector OnLoggerRepositoryCreatedEvent Method Apache log4net™ SDK Documentation
Notifies the registered listeners that the repository has been created.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void OnLoggerRepositoryCreatedEvent(
    ILoggerRepository repository
)
protected virtual void OnLoggerRepositoryCreatedEvent(
    ILoggerRepository repository
)
Protected Overridable Sub OnLoggerRepositoryCreatedEvent (
    repository As ILoggerRepository
)
Protected Overridable Sub OnLoggerRepositoryCreatedEvent (
    repository As ILoggerRepository
)
protected:
virtual void OnLoggerRepositoryCreatedEvent(
    ILoggerRepository^ repository
)
protected:
virtual void OnLoggerRepositoryCreatedEvent(
    ILoggerRepository^ repository
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository that has been created.
Remarks

            Raises the LoggerRepositoryCreatedEvent event.

See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector Events

DefaultRepositorySelector Events Apache log4net™ SDK Documentation
The DefaultRepositorySelector type exposes the following members.
Events
 | Name | Description
Public event | LoggerRepositoryCreatedEvent | Event to notify that a logger repository has been created.
Back to Top
See Also
DefaultRepositorySelector Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRepositorySelector.LoggerRepositoryCreatedEvent Event

DefaultRepositorySelector LoggerRepositoryCreatedEvent Event Apache log4net™ SDK Documentation
Event to notify that a logger repository has been created.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event LoggerRepositoryCreationEventHandler LoggerRepositoryCreatedEvent
public event LoggerRepositoryCreationEventHandler LoggerRepositoryCreatedEvent
Public Event LoggerRepositoryCreatedEvent As LoggerRepositoryCreationEventHandler
Public Event LoggerRepositoryCreatedEvent As LoggerRepositoryCreationEventHandler
public:
virtual  event LoggerRepositoryCreationEventHandler^ LoggerRepositoryCreatedEvent {
    void add (LoggerRepositoryCreationEventHandler^ value);
    void remove (LoggerRepositoryCreationEventHandler^ value);
}
public:
virtual  event LoggerRepositoryCreationEventHandler^ LoggerRepositoryCreatedEvent {
    void add (LoggerRepositoryCreationEventHandler^ value);
    void remove (LoggerRepositoryCreationEventHandler^ value);
}
Field Value
Type:

            Event to notify that a logger repository has been created.

Implements
IRepositorySelector LoggerRepositoryCreatedEvent
Remarks

            Event raised when a new repository is created.
            The event source will be this selector. The event args will
            be a LoggerRepositoryCreationEventArgs which
            holds the newly created ILoggerRepository.

See Also
DefaultRepositorySelector Class
DefaultRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ErrorCode Enumeration

ErrorCode Enumeration Apache log4net™ SDK Documentation
Defined error codes that can be passed to the [M:IErrorHandler.Error(string, Exception, ErrorCode)] method.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ErrorCode
public enum ErrorCode
Public Enumeration ErrorCode
Public Enumeration ErrorCode
public enum class ErrorCode
public enum class ErrorCode
Members
Member name | Value | Description
GenericFailure | 0 | A general error
WriteFailure | 1 | Error while writing output
FlushFailure | 2 | Failed to flush file
CloseFailure | 3 | Failed to close file
FileOpenFailure | 4 | Unable to open output file
MissingLayout | 5 | No layout specified
AddressParseFailure | 6 | Failed to parse address
Remarks

            Values passed to the [M:IErrorHandler.Error(string, Exception, ErrorCode)] method.

See Also
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionEvaluator Class

ExceptionEvaluator Class Apache log4net™ SDK Documentation
An evaluator that triggers on an Exception type
Inheritance Hierarchy
Online System Object
log4net.Core ExceptionEvaluator

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ExceptionEvaluator : ITriggeringEventEvaluator
public class ExceptionEvaluator : ITriggeringEventEvaluator
Public Class ExceptionEvaluator
    Implements ITriggeringEventEvaluator
Public Class ExceptionEvaluator
    Implements ITriggeringEventEvaluator
public ref class ExceptionEvaluator : ITriggeringEventEvaluator
public ref class ExceptionEvaluator : ITriggeringEventEvaluator
Remarks

            This evaluator will trigger if the type of the Exception
            passed to [M:IsTriggeringEvent(LoggingEvent)]
            is equal to a Type in ExceptionType.    ///

See Also
ExceptionEvaluator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionEvaluator Members

ExceptionEvaluator Members Apache log4net™ SDK Documentation
The ExceptionEvaluator type exposes the following members.
Constructors
 | Name | Description
Public method | ExceptionEvaluator | Default ctor to allow dynamic creation through a configurator.
Public method | ExceptionEvaluator(Type, Boolean) | Constructs an evaluator and initializes to trigger on exType
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsTriggeringEvent | Is this loggingEvent the triggering event?
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ExceptionType | The type that triggers this evaluator.
Public property | TriggerOnSubclass | If true, this evaluator will trigger on subclasses of ExceptionType.
Back to Top
See Also
ExceptionEvaluator Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionEvaluator Constructor

ExceptionEvaluator Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | ExceptionEvaluator | Default ctor to allow dynamic creation through a configurator.
Public method | ExceptionEvaluator(Type, Boolean) | Constructs an evaluator and initializes to trigger on exType
Back to Top
See Also
ExceptionEvaluator Class
ExceptionEvaluator Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionEvaluator Constructor

ExceptionEvaluator Constructor Apache log4net™ SDK Documentation
Default ctor to allow dynamic creation through a configurator.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExceptionEvaluator()
public ExceptionEvaluator()
Public Sub New
Public Sub New
public:
ExceptionEvaluator()
public:
ExceptionEvaluator()
See Also
ExceptionEvaluator Class
ExceptionEvaluator Members
ExceptionEvaluator Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionEvaluator Constructor (Type, Boolean)

ExceptionEvaluator Constructor (Type, Boolean) Apache log4net™ SDK Documentation
Constructs an evaluator and initializes to trigger on exType

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExceptionEvaluator(
    Type exType,
    bool triggerOnSubClass
)
public ExceptionEvaluator(
    Type exType,
    bool triggerOnSubClass
)
Public Sub New (
    exType As Type,
    triggerOnSubClass As Boolean
)
Public Sub New (
    exType As Type,
    triggerOnSubClass As Boolean
)
public:
ExceptionEvaluator(
    Type^ exType,
    bool triggerOnSubClass
)
public:
ExceptionEvaluator(
    Type^ exType,
    bool triggerOnSubClass
)
Parameters
exType
Type:   Online System Type
the type that triggers this evaluator.
triggerOnSubClass
Type:   Online System Boolean
If true, this evaluator will trigger on subclasses of ExceptionType.
See Also
ExceptionEvaluator Class
ExceptionEvaluator Members
ExceptionEvaluator Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionEvaluator Methods

ExceptionEvaluator Methods Apache log4net™ SDK Documentation
The ExceptionEvaluator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsTriggeringEvent | Is this loggingEvent the triggering event?
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ExceptionEvaluator Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionEvaluator.IsTriggeringEvent Method

ExceptionEvaluator IsTriggeringEvent Method Apache log4net™ SDK Documentation
Is this loggingEvent the triggering event?

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsTriggeringEvent(
    LoggingEvent loggingEvent
)
public bool IsTriggeringEvent(
    LoggingEvent loggingEvent
)
Public Function IsTriggeringEvent (
    loggingEvent As LoggingEvent
) As Boolean
Public Function IsTriggeringEvent (
    loggingEvent As LoggingEvent
) As Boolean
public:
virtual bool IsTriggeringEvent(
    LoggingEvent^ loggingEvent
) sealed
public:
virtual bool IsTriggeringEvent(
    LoggingEvent^ loggingEvent
) sealed
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to check
Return Value
Type:   Online Boolean
This method returns true, if the logging event Exception
            Type is ExceptionType.
            Otherwise it returns false
Implements
ITriggeringEventEvaluator IsTriggeringEvent(LoggingEvent)
Remarks

            This evaluator will trigger if the Exception Type of the event
            passed to [M:IsTriggeringEvent(LoggingEvent)]
            is ExceptionType.

See Also
ExceptionEvaluator Class
ExceptionEvaluator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionEvaluator Properties

ExceptionEvaluator Properties Apache log4net™ SDK Documentation
The ExceptionEvaluator type exposes the following members.
Properties
 | Name | Description
Public property | ExceptionType | The type that triggers this evaluator.
Public property | TriggerOnSubclass | If true, this evaluator will trigger on subclasses of ExceptionType.
Back to Top
See Also
ExceptionEvaluator Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionEvaluator.ExceptionType Property

ExceptionEvaluator ExceptionType Property Apache log4net™ SDK Documentation
The type that triggers this evaluator.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type ExceptionType { get; set; }
public Type ExceptionType { get; set; }
Public Property ExceptionType As Type
    Get
    Set
Public Property ExceptionType As Type
    Get
    Set
public:
property Type^ ExceptionType {
    Type^ get ();
    void set (Type^ value);
}
public:
property Type^ ExceptionType {
    Type^ get ();
    void set (Type^ value);
}
Property Value
Type:   Online Type
See Also
ExceptionEvaluator Class
ExceptionEvaluator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionEvaluator.TriggerOnSubclass Property

ExceptionEvaluator TriggerOnSubclass Property Apache log4net™ SDK Documentation
If true, this evaluator will trigger on subclasses of ExceptionType.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TriggerOnSubclass { get; set; }
public bool TriggerOnSubclass { get; set; }
Public Property TriggerOnSubclass As Boolean
    Get
    Set
Public Property TriggerOnSubclass As Boolean
    Get
    Set
public:
property bool TriggerOnSubclass {
    bool get ();
    void set (bool value);
}
public:
property bool TriggerOnSubclass {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
See Also
ExceptionEvaluator Class
ExceptionEvaluator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FixFlags Enumeration

FixFlags Enumeration Apache log4net™ SDK Documentation
Flags passed to the Fix property

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum FixFlags
[FlagsAttribute]
public enum FixFlags
<FlagsAttribute>
Public Enumeration FixFlags
<FlagsAttribute>
Public Enumeration FixFlags
[FlagsAttribute]
public enum class FixFlags
[FlagsAttribute]
public enum class FixFlags
Members
Member name | Value | Description
Mdc | 1 | Obsolete. Fix the MDC
Ndc | 2 | Fix the NDC
Message | 4 | Fix the rendered message
ThreadName | 8 | Fix the thread name
LocationInfo | 16 | Fix the callers location information
UserName | 32 | Fix the callers windows user name
Domain | 64 | Fix the domain friendly name
Identity | 128 | Fix the callers principal name
Exception | 256 | Fix the exception text
Properties | 512 | Fix the event properties. Active properties must implement IFixingRequired in order to be eligible for fixing.
None | 0 | No fields fixed
All | 268435455 | All fields fixed
Partial | 844 | Partial fields fixed
Remarks

            Flags passed to the Fix property

See Also
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppenderAttachable Interface

IAppenderAttachable Interface Apache log4net™ SDK Documentation
Interface for attaching appenders to objects.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAppenderAttachable
public interface IAppenderAttachable
Public Interface IAppenderAttachable
Public Interface IAppenderAttachable
public interface class IAppenderAttachable
public interface class IAppenderAttachable
Remarks

            Interface for attaching, removing and retrieving appenders.

See Also
IAppenderAttachable Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppenderAttachable Members

IAppenderAttachable Members Apache log4net™ SDK Documentation
The IAppenderAttachable type exposes the following members.
Methods
 | Name | Description
Public method | AddAppender | Attaches an appender.
Public method | GetAppender | Gets an attached appender with the specified name.
Public method | RemoveAllAppenders | Removes all attached appenders.
Public method | RemoveAppender(String) | Removes the appender with the specified name from the list of appenders.
Public method | RemoveAppender(IAppender) | Removes the specified appender from the list of attached appenders.
Back to Top
Properties
 | Name | Description
Public property | Appenders | Gets all attached appenders.
Back to Top
See Also
IAppenderAttachable Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppenderAttachable Methods

IAppenderAttachable Methods Apache log4net™ SDK Documentation
The IAppenderAttachable type exposes the following members.
Methods
 | Name | Description
Public method | AddAppender | Attaches an appender.
Public method | GetAppender | Gets an attached appender with the specified name.
Public method | RemoveAllAppenders | Removes all attached appenders.
Public method | RemoveAppender(String) | Removes the appender with the specified name from the list of appenders.
Public method | RemoveAppender(IAppender) | Removes the specified appender from the list of attached appenders.
Back to Top
See Also
IAppenderAttachable Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppenderAttachable.AddAppender Method

IAppenderAttachable AddAppender Method Apache log4net™ SDK Documentation
Attaches an appender.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void AddAppender(
    IAppender appender
)
void AddAppender(
    IAppender appender
)
Sub AddAppender (
    appender As IAppender
)
Sub AddAppender (
    appender As IAppender
)
void AddAppender(
    IAppender^ appender
)
void AddAppender(
    IAppender^ appender
)
Parameters
appender
Type: log4net.Appender IAppender
The appender to add.
Remarks

            Add the specified appender. The implementation may
            choose to allow or deny duplicate appenders.

See Also
IAppenderAttachable Interface
IAppenderAttachable Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppenderAttachable.GetAppender Method

IAppenderAttachable GetAppender Method Apache log4net™ SDK Documentation
Gets an attached appender with the specified name.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IAppender GetAppender(
    string name
)
IAppender GetAppender(
    string name
)
Function GetAppender (
    name As String
) As IAppender
Function GetAppender (
    name As String
) As IAppender
IAppender^ GetAppender(
    String^ name
)
IAppender^ GetAppender(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the appender to get.
Return Value
Type: IAppender

            The appender with the name specified, or null if no appender with the
            specified name is found.

Remarks

            Returns an attached appender with the name specified.
            If no appender with the specified name is found null will be
            returned.

See Also
IAppenderAttachable Interface
IAppenderAttachable Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppenderAttachable.RemoveAllAppenders Method

IAppenderAttachable RemoveAllAppenders Method Apache log4net™ SDK Documentation
Removes all attached appenders.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RemoveAllAppenders()
void RemoveAllAppenders()
Sub RemoveAllAppenders
Sub RemoveAllAppenders
void RemoveAllAppenders()
void RemoveAllAppenders()
Remarks

            Removes and closes all attached appenders

See Also
IAppenderAttachable Interface
IAppenderAttachable Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppenderAttachable.RemoveAppender Method

IAppenderAttachable RemoveAppender Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | RemoveAppender(String) | Removes the appender with the specified name from the list of appenders.
Public method | RemoveAppender(IAppender) | Removes the specified appender from the list of attached appenders.
Back to Top
See Also
IAppenderAttachable Interface
IAppenderAttachable Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppenderAttachable.RemoveAppender Method (String)

IAppenderAttachable RemoveAppender Method (String) Apache log4net™ SDK Documentation
Removes the appender with the specified name from the list of appenders.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IAppender RemoveAppender(
    string name
)
IAppender RemoveAppender(
    string name
)
Function RemoveAppender (
    name As String
) As IAppender
Function RemoveAppender (
    name As String
) As IAppender
IAppender^ RemoveAppender(
    String^ name
)
IAppender^ RemoveAppender(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the appender to remove.
Return Value
Type: IAppender
The appender removed from the list
Remarks

            The appender removed is not closed.
            If you are discarding the appender you must call
            Close  on the appender removed.

See Also
IAppenderAttachable Interface
IAppenderAttachable Members
RemoveAppender Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppenderAttachable.RemoveAppender Method (IAppender)

IAppenderAttachable RemoveAppender Method (IAppender) Apache log4net™ SDK Documentation
Removes the specified appender from the list of attached appenders.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IAppender RemoveAppender(
    IAppender appender
)
IAppender RemoveAppender(
    IAppender appender
)
Function RemoveAppender (
    appender As IAppender
) As IAppender
Function RemoveAppender (
    appender As IAppender
) As IAppender
IAppender^ RemoveAppender(
    IAppender^ appender
)
IAppender^ RemoveAppender(
    IAppender^ appender
)
Parameters
appender
Type: log4net.Appender IAppender
The appender to remove.
Return Value
Type: IAppender
The appender removed from the list
Remarks

            The appender removed is not closed.
            If you are discarding the appender you must call
            Close  on the appender removed.

See Also
IAppenderAttachable Interface
IAppenderAttachable Members
RemoveAppender Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppenderAttachable Properties

IAppenderAttachable Properties Apache log4net™ SDK Documentation
The IAppenderAttachable type exposes the following members.
Properties
 | Name | Description
Public property | Appenders | Gets all attached appenders.
Back to Top
See Also
IAppenderAttachable Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IAppenderAttachable.Appenders Property

IAppenderAttachable Appenders Property Apache log4net™ SDK Documentation
Gets all attached appenders.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
AppenderCollection Appenders { get; }
AppenderCollection Appenders { get; }
ReadOnly Property Appenders As AppenderCollection
    Get
ReadOnly Property Appenders As AppenderCollection
    Get
property AppenderCollection^ Appenders {
    AppenderCollection^ get ();
}
property AppenderCollection^ Appenders {
    AppenderCollection^ get ();
}
Property Value
Type: AppenderCollection

            A collection of attached appenders.

Remarks

            Gets a collection of attached appenders.
            If there are no attached appenders the
            implementation should return an empty
            collection rather than null.

See Also
IAppenderAttachable Interface
IAppenderAttachable Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IErrorHandler Interface

IErrorHandler Interface Apache log4net™ SDK Documentation
Appenders may delegate their error handling to an IErrorHandler.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IErrorHandler
public interface IErrorHandler
Public Interface IErrorHandler
Public Interface IErrorHandler
public interface class IErrorHandler
public interface class IErrorHandler
Remarks

            Error handling is a particularly tedious to get right because by
            definition errors are hard to predict and to reproduce.

See Also
IErrorHandler Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IErrorHandler Members

IErrorHandler Members Apache log4net™ SDK Documentation
Methods
 | Name | Description
Public method | Error(String) | Prints the error message passed as a parameter.
Public method | Error(String, Exception) | Prints the error message passed as a parameter.
Public method | Error(String, Exception, ErrorCode) | Handles the error and information about the error condition is passed as a parameter.
Back to Top
See Also
IErrorHandler Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IErrorHandler Methods

IErrorHandler Methods Apache log4net™ SDK Documentation
Methods
 | Name | Description
Public method | Error(String) | Prints the error message passed as a parameter.
Public method | Error(String, Exception) | Prints the error message passed as a parameter.
Public method | Error(String, Exception, ErrorCode) | Handles the error and information about the error condition is passed as a parameter.
Back to Top
See Also
IErrorHandler Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IErrorHandler.Error Method

IErrorHandler Error Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Error(String) | Prints the error message passed as a parameter.
Public method | Error(String, Exception) | Prints the error message passed as a parameter.
Public method | Error(String, Exception, ErrorCode) | Handles the error and information about the error condition is passed as a parameter.
Back to Top
See Also
IErrorHandler Interface
IErrorHandler Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IErrorHandler.Error Method (String)

IErrorHandler Error Method (String) Apache log4net™ SDK Documentation
Prints the error message passed as a parameter.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Error(
    string message
)
void Error(
    string message
)
Sub Error (
    message As String
)
Sub Error (
    message As String
)
void Error(
    String^ message
)
void Error(
    String^ message
)
Parameters
message
Type:   Online System String
The message associated with the error.
Remarks

            See [M:Error(string,Exception,ErrorCode)].

See Also
IErrorHandler Interface
IErrorHandler Members
Error Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IErrorHandler.Error Method (String, Exception)

IErrorHandler Error Method (String, Exception) Apache log4net™ SDK Documentation
Prints the error message passed as a parameter.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Error(
    string message,
    Exception e
)
void Error(
    string message,
    Exception e
)
Sub Error (
    message As String,
    e As Exception
)
Sub Error (
    message As String,
    e As Exception
)
void Error(
    String^ message,
    Exception^ e
)
void Error(
    String^ message,
    Exception^ e
)
Parameters
message
Type:   Online System String
The message associated with the error.
e
Type:   Online System Exception
The   Online Exception that was thrown when the error occurred.
Remarks

            See [M:Error(string,Exception,ErrorCode)].

See Also
IErrorHandler Interface
IErrorHandler Members
Error Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IErrorHandler.Error Method (String, Exception, ErrorCode)

IErrorHandler Error Method (String, Exception, ErrorCode) Apache log4net™ SDK Documentation
Handles the error and information about the error condition is passed as a parameter.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Error(
    string message,
    Exception e,
    ErrorCode errorCode
)
void Error(
    string message,
    Exception e,
    ErrorCode errorCode
)
Sub Error (
    message As String,
    e As Exception,
    errorCode As ErrorCode
)
Sub Error (
    message As String,
    e As Exception,
    errorCode As ErrorCode
)
void Error(
    String^ message,
    Exception^ e,
    ErrorCode errorCode
)
void Error(
    String^ message,
    Exception^ e,
    ErrorCode errorCode
)
Parameters
message
Type:   Online System String
The message associated with the error.
e
Type:   Online System Exception
The   Online Exception that was thrown when the error occurred.
errorCode
Type: log4net.Core ErrorCode
The error code associated with the error.
Remarks

            Handles the error and information about the error condition is passed as
            a parameter.

See Also
IErrorHandler Interface
IErrorHandler Members
Error Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IFixingRequired Interface

IFixingRequired Interface Apache log4net™ SDK Documentation
Interface for objects that require fixing.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IFixingRequired
public interface IFixingRequired
Public Interface IFixingRequired
Public Interface IFixingRequired
public interface class IFixingRequired
public interface class IFixingRequired
Remarks

            Interface that indicates that the object requires fixing before it
            can be taken outside the context of the appender's
            DoAppend(LoggingEvent) method.

            When objects that implement this interface are stored
            in the context properties maps GlobalContext Properties and ThreadContext Properties are fixed
            (see Fix) the GetFixedObject
            method will be called.

See Also
IFixingRequired Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IFixingRequired Members

IFixingRequired Members Apache log4net™ SDK Documentation
The IFixingRequired type exposes the following members.
Methods
 | Name | Description
Public method | GetFixedObject | Get a portable version of this object
Back to Top
See Also
IFixingRequired Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IFixingRequired Methods

IFixingRequired Methods Apache log4net™ SDK Documentation
The IFixingRequired type exposes the following members.
Methods
 | Name | Description
Public method | GetFixedObject | Get a portable version of this object
Back to Top
See Also
IFixingRequired Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IFixingRequired.GetFixedObject Method

IFixingRequired GetFixedObject Method Apache log4net™ SDK Documentation
Get a portable version of this object

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object GetFixedObject()
Object GetFixedObject()
Function GetFixedObject As Object
Function GetFixedObject As Object
Object^ GetFixedObject()
Object^ GetFixedObject()
Return Value
Type:   Online Object
the portable instance of this object
Remarks

            Get a portable instance object that represents the current
            state of this object. The portable object can be stored
            and logged from any thread with identical results.

See Also
IFixingRequired Interface
IFixingRequired Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogger Interface

ILogger Interface Apache log4net™ SDK Documentation
Interface that all loggers implement

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILogger
public interface ILogger
Public Interface ILogger
Public Interface ILogger
public interface class ILogger
public interface class ILogger
Remarks

            This interface supports logging events and testing if a level
            is enabled for logging.

            These methods will not throw exceptions. Note to implementor, ensure
            that the implementation of these methods cannot allow an exception
            to be thrown to the caller.

See Also
ILogger Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogger Members

ILogger Members Apache log4net™ SDK Documentation
The ILogger type exposes the following members.
Methods
 | Name | Description
Public method | IsEnabledFor | Checks if this logger is enabled for a given Level passed as parameter.
Public method | Log(LoggingEvent) | This is the most generic printing method that is intended to be used by wrappers.
Public method | Log(Type, Level, Object, Exception) | This generic form is intended to be used by wrappers.
Back to Top
Properties
 | Name | Description
Public property | Name | Gets the name of the logger.
Public property | Repository | Gets the ILoggerRepository where this Logger instance is attached to.
Back to Top
See Also
ILogger Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogger Methods

ILogger Methods Apache log4net™ SDK Documentation
The ILogger type exposes the following members.
Methods
 | Name | Description
Public method | IsEnabledFor | Checks if this logger is enabled for a given Level passed as parameter.
Public method | Log(LoggingEvent) | This is the most generic printing method that is intended to be used by wrappers.
Public method | Log(Type, Level, Object, Exception) | This generic form is intended to be used by wrappers.
Back to Top
See Also
ILogger Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogger.IsEnabledFor Method

ILogger IsEnabledFor Method Apache log4net™ SDK Documentation
Checks if this logger is enabled for a given Level passed as parameter.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsEnabledFor(
    Level level
)
bool IsEnabledFor(
    Level level
)
Function IsEnabledFor (
    level As Level
) As Boolean
Function IsEnabledFor (
    level As Level
) As Boolean
bool IsEnabledFor(
    Level^ level
)
bool IsEnabledFor(
    Level^ level
)
Parameters
level
Type: log4net.Core Level
The level to check.
Return Value
Type:   Online Boolean
true if this logger is enabled for level, otherwise false.

Remarks

            Test if this logger is going to log events of the specified level.

See Also
ILogger Interface
ILogger Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogger.Log Method

ILogger Log Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Log(LoggingEvent) | This is the most generic printing method that is intended to be used by wrappers.
Public method | Log(Type, Level, Object, Exception) | This generic form is intended to be used by wrappers.
Back to Top
See Also
ILogger Interface
ILogger Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogger.Log Method (LoggingEvent)

ILogger Log Method (LoggingEvent) Apache log4net™ SDK Documentation
This is the most generic printing method that is intended to be used by wrappers.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Log(
    LoggingEvent logEvent
)
void Log(
    LoggingEvent logEvent
)
Sub Log (
    logEvent As LoggingEvent
)
Sub Log (
    logEvent As LoggingEvent
)
void Log(
    LoggingEvent^ logEvent
)
void Log(
    LoggingEvent^ logEvent
)
Parameters
logEvent
Type: log4net.Core LoggingEvent
The event being logged.
Remarks

            Logs the specified logging event through this logger.

See Also
ILogger Interface
ILogger Members
Log Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogger.Log Method (Type, Level, Object, Exception)

ILogger Log Method (Type, Level, Object, Exception) Apache log4net™ SDK Documentation
This generic form is intended to be used by wrappers.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Log(
    Type callerStackBoundaryDeclaringType,
    Level level,
    Object message,
    Exception exception
)
void Log(
    Type callerStackBoundaryDeclaringType,
    Level level,
    Object message,
    Exception exception
)
Sub Log (
    callerStackBoundaryDeclaringType As Type,
    level As Level,
    message As Object,
    exception As Exception
)
Sub Log (
    callerStackBoundaryDeclaringType As Type,
    level As Level,
    message As Object,
    exception As Exception
)
void Log(
    Type^ callerStackBoundaryDeclaringType,
    Level^ level,
    Object^ message,
    Exception^ exception
)
void Log(
    Type^ callerStackBoundaryDeclaringType,
    Level^ level,
    Object^ message,
    Exception^ exception
)
Parameters
callerStackBoundaryDeclaringType
Type:   Online System Type
The declaring type of the method that is
            the stack boundary into the logging system for this call.
level
Type: log4net.Core Level
The level of the message to be logged.
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
the exception to log, including its stack trace. Pass null to not log an exception.
Remarks

            Generates a logging event for the specified level using
            the message and exception.

See Also
ILogger Interface
ILogger Members
Log Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogger Properties

ILogger Properties Apache log4net™ SDK Documentation
The ILogger type exposes the following members.
Properties
 | Name | Description
Public property | Name | Gets the name of the logger.
Public property | Repository | Gets the ILoggerRepository where this Logger instance is attached to.
Back to Top
See Also
ILogger Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogger.Name Property

ILogger Name Property Apache log4net™ SDK Documentation
Gets the name of the logger.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Name { get; }
string Name { get; }
ReadOnly Property Name As String
    Get
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
property String^ Name {
    String^ get ();
}
Property Value
Type:   Online String

            The name of the logger.

Remarks

            The name of this logger

See Also
ILogger Interface
ILogger Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogger.Repository Property

ILogger Repository Property Apache log4net™ SDK Documentation
Gets the ILoggerRepository where this Logger instance is attached to.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILoggerRepository Repository { get; }
ILoggerRepository Repository { get; }
ReadOnly Property Repository As ILoggerRepository
    Get
ReadOnly Property Repository As ILoggerRepository
    Get
property ILoggerRepository^ Repository {
    ILoggerRepository^ get ();
}
property ILoggerRepository^ Repository {
    ILoggerRepository^ get ();
}
Property Value
Type: ILoggerRepository

            The ILoggerRepository that this logger belongs to.

Remarks

            Gets the ILoggerRepository where this
            Logger instance is attached to.

See Also
ILogger Interface
ILogger Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerWrapper Interface

ILoggerWrapper Interface Apache log4net™ SDK Documentation
Base interface for all wrappers

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILoggerWrapper
public interface ILoggerWrapper
Public Interface ILoggerWrapper
Public Interface ILoggerWrapper
public interface class ILoggerWrapper
public interface class ILoggerWrapper
Remarks

            Base interface for all wrappers.

            All wrappers must implement this interface.

See Also
ILoggerWrapper Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerWrapper Members

ILoggerWrapper Members Apache log4net™ SDK Documentation
The ILoggerWrapper type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Get the implementation behind this wrapper object.
Back to Top
See Also
ILoggerWrapper Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerWrapper Properties

ILoggerWrapper Properties Apache log4net™ SDK Documentation
The ILoggerWrapper type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Get the implementation behind this wrapper object.
Back to Top
See Also
ILoggerWrapper Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerWrapper.Logger Property

ILoggerWrapper Logger Property Apache log4net™ SDK Documentation
Get the implementation behind this wrapper object.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILogger Logger { get; }
ILogger Logger { get; }
ReadOnly Property Logger As ILogger
    Get
ReadOnly Property Logger As ILogger
    Get
property ILogger^ Logger {
    ILogger^ get ();
}
property ILogger^ Logger {
    ILogger^ get ();
}
Property Value
Type: ILogger

            The ILogger object that in implementing this object.

Remarks

            The ILogger object that in implementing this
            object. The Logger object may not
            be the same object as this object because of logger decorators.
            This gets the actual underlying objects that is used to process
            the log events.

See Also
ILoggerWrapper Interface
ILoggerWrapper Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IOptionHandler Interface

IOptionHandler Interface Apache log4net™ SDK Documentation
Interface used to delay activate a configured object.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IOptionHandler
public interface IOptionHandler
Public Interface IOptionHandler
Public Interface IOptionHandler
public interface class IOptionHandler
public interface class IOptionHandler
Remarks

            This allows an object to defer activation of its options until all
            options have been set. This is required for components which have
            related options that remain ambiguous until all are set.

            If a component implements this interface then the ActivateOptions  method
            must be called by the container after its all the configured properties have been set
            and before the component can be used.

See Also
IOptionHandler Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IOptionHandler Members

IOptionHandler Members Apache log4net™ SDK Documentation
The IOptionHandler type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Activate the options that were previously set with calls to properties.
Back to Top
See Also
IOptionHandler Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IOptionHandler Methods

IOptionHandler Methods Apache log4net™ SDK Documentation
The IOptionHandler type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Activate the options that were previously set with calls to properties.
Back to Top
See Also
IOptionHandler Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IOptionHandler.ActivateOptions Method

IOptionHandler ActivateOptions Method Apache log4net™ SDK Documentation
Activate the options that were previously set with calls to properties.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ActivateOptions()
void ActivateOptions()
Sub ActivateOptions
Sub ActivateOptions
void ActivateOptions()
void ActivateOptions()
Remarks

            This allows an object to defer activation of its options until all
            options have been set. This is required for components which have
            related options that remain ambiguous until all are set.

            If a component implements this interface then this method must be called
            after its properties have been set before the component can be used.

See Also
IOptionHandler Interface
IOptionHandler Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector Interface

IRepositorySelector Interface Apache log4net™ SDK Documentation
Interface used by the LogManager to select the ILoggerRepository.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IRepositorySelector
public interface IRepositorySelector
Public Interface IRepositorySelector
Public Interface IRepositorySelector
public interface class IRepositorySelector
public interface class IRepositorySelector
Remarks

            The LogManager uses a IRepositorySelector
            to specify the policy for selecting the correct ILoggerRepository
            to return to the caller.

See Also
IRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector Members

IRepositorySelector Members Apache log4net™ SDK Documentation
The IRepositorySelector type exposes the following members.
Methods
 | Name | Description
Public method | CreateRepository(Assembly, Type) | Creates a new repository for the assembly specified.
Public method | CreateRepository(String, Type) | Creates a new repository with the name specified.
Public method | ExistsRepository | Test if a named repository exists
Public method | GetAllRepositories | Gets an array of all currently defined repositories.
Public method | GetRepository(Assembly) | Gets the ILoggerRepository for the specified assembly.
Public method | GetRepository(String) | Gets the named ILoggerRepository.
Back to Top
Events
 | Name | Description
Public event | LoggerRepositoryCreatedEvent | Event to notify that a logger repository has been created.
Back to Top
See Also
IRepositorySelector Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector Methods

IRepositorySelector Methods Apache log4net™ SDK Documentation
The IRepositorySelector type exposes the following members.
Methods
 | Name | Description
Public method | CreateRepository(Assembly, Type) | Creates a new repository for the assembly specified.
Public method | CreateRepository(String, Type) | Creates a new repository with the name specified.
Public method | ExistsRepository | Test if a named repository exists
Public method | GetAllRepositories | Gets an array of all currently defined repositories.
Public method | GetRepository(Assembly) | Gets the ILoggerRepository for the specified assembly.
Public method | GetRepository(String) | Gets the named ILoggerRepository.
Back to Top
See Also
IRepositorySelector Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector.CreateRepository Method

IRepositorySelector CreateRepository Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | CreateRepository(Assembly, Type) | Creates a new repository for the assembly specified.
Public method | CreateRepository(String, Type) | Creates a new repository with the name specified.
Back to Top
See Also
IRepositorySelector Interface
IRepositorySelector Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector.CreateRepository Method (Assembly, Type)

IRepositorySelector CreateRepository Method (Assembly, Type) Apache log4net™ SDK Documentation
Creates a new repository for the assembly specified.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILoggerRepository CreateRepository(
    Assembly assembly,
    Type repositoryType
)
ILoggerRepository CreateRepository(
    Assembly assembly,
    Type repositoryType
)
Function CreateRepository (
    assembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
Function CreateRepository (
    assembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
ILoggerRepository^ CreateRepository(
    Assembly^ assembly,
    Type^ repositoryType
)
ILoggerRepository^ CreateRepository(
    Assembly^ assembly,
    Type^ repositoryType
)
Parameters
assembly
Type:   Online System.Reflection Assembly
The assembly to use to create the domain to associate with the ILoggerRepository.
repositoryType
Type:   Online System Type
The type of repository to create, must implement ILoggerRepository.
Return Value
Type: ILoggerRepository
The repository created.
Remarks

            The ILoggerRepository created will be associated with the domain
            specified such that a call to [M:GetRepository(Assembly)] with the
            same assembly specified will return the same repository instance.

            How the association between   Online Assembly and ILoggerRepository
            is made is not defined. The implementation may choose any method for
            this association.

See Also
IRepositorySelector Interface
IRepositorySelector Members
CreateRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector.CreateRepository Method (String, Type)

IRepositorySelector CreateRepository Method (String, Type) Apache log4net™ SDK Documentation
Creates a new repository with the name specified.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILoggerRepository CreateRepository(
    string repositoryName,
    Type repositoryType
)
ILoggerRepository CreateRepository(
    string repositoryName,
    Type repositoryType
)
Function CreateRepository (
    repositoryName As String,
    repositoryType As Type
) As ILoggerRepository
Function CreateRepository (
    repositoryName As String,
    repositoryType As Type
) As ILoggerRepository
ILoggerRepository^ CreateRepository(
    String^ repositoryName,
    Type^ repositoryType
)
ILoggerRepository^ CreateRepository(
    String^ repositoryName,
    Type^ repositoryType
)
Parameters
repositoryName
Type:   Online System String
The name to associate with the ILoggerRepository.
repositoryType
Type:   Online System Type
The type of repository to create, must implement ILoggerRepository.
Return Value
Type: ILoggerRepository
The repository created.
Remarks

            The ILoggerRepository created will be associated with the name
            specified such that a call to [M:GetRepository(string)] with the
            same name will return the same repository instance.

See Also
IRepositorySelector Interface
IRepositorySelector Members
CreateRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector.ExistsRepository Method

IRepositorySelector ExistsRepository Method Apache log4net™ SDK Documentation
Test if a named repository exists

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ExistsRepository(
    string repositoryName
)
bool ExistsRepository(
    string repositoryName
)
Function ExistsRepository (
    repositoryName As String
) As Boolean
Function ExistsRepository (
    repositoryName As String
) As Boolean
bool ExistsRepository(
    String^ repositoryName
)
bool ExistsRepository(
    String^ repositoryName
)
Parameters
repositoryName
Type:   Online System String
the named repository to check
Return Value
Type:   Online Boolean
true if the repository exists
Remarks

            Test if a named repository exists. Use [M:CreateRepository(Assembly, Type)]
            to create a new repository and [M:GetRepository(Assembly)] to retrieve
            a repository.

See Also
IRepositorySelector Interface
IRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector.GetAllRepositories Method

IRepositorySelector GetAllRepositories Method Apache log4net™ SDK Documentation
Gets an array of all currently defined repositories.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILoggerRepository[] GetAllRepositories()
ILoggerRepository[] GetAllRepositories()
Function GetAllRepositories As ILoggerRepository()
Function GetAllRepositories As ILoggerRepository()
array<ILoggerRepository^>^ GetAllRepositories()
array<ILoggerRepository^>^ GetAllRepositories()
Return Value
Type:  ILoggerRepository

            An array of the ILoggerRepository instances created by
            this IRepositorySelector.
Remarks

            Gets an array of all of the repositories created by this selector.

See Also
IRepositorySelector Interface
IRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector.GetRepository Method

IRepositorySelector GetRepository Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | GetRepository(Assembly) | Gets the ILoggerRepository for the specified assembly.
Public method | GetRepository(String) | Gets the named ILoggerRepository.
Back to Top
See Also
IRepositorySelector Interface
IRepositorySelector Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector.GetRepository Method (Assembly)

IRepositorySelector GetRepository Method (Assembly) Apache log4net™ SDK Documentation
Gets the ILoggerRepository for the specified assembly.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILoggerRepository GetRepository(
    Assembly assembly
)
ILoggerRepository GetRepository(
    Assembly assembly
)
Function GetRepository (
    assembly As Assembly
) As ILoggerRepository
Function GetRepository (
    assembly As Assembly
) As ILoggerRepository
ILoggerRepository^ GetRepository(
    Assembly^ assembly
)
ILoggerRepository^ GetRepository(
    Assembly^ assembly
)
Parameters
assembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup to the ILoggerRepository
Return Value
Type: ILoggerRepository
The ILoggerRepository for the assembly.
Remarks

            Gets the ILoggerRepository for the specified assembly.

            How the association between   Online Assembly and ILoggerRepository
            is made is not defined. The implementation may choose any method for
            this association. The results of this method must be repeatable, i.e.
            when called again with the same arguments the result must be the
            save value.

See Also
IRepositorySelector Interface
IRepositorySelector Members
GetRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector.GetRepository Method (String)

IRepositorySelector GetRepository Method (String) Apache log4net™ SDK Documentation
Gets the named ILoggerRepository.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILoggerRepository GetRepository(
    string repositoryName
)
ILoggerRepository GetRepository(
    string repositoryName
)
Function GetRepository (
    repositoryName As String
) As ILoggerRepository
Function GetRepository (
    repositoryName As String
) As ILoggerRepository
ILoggerRepository^ GetRepository(
    String^ repositoryName
)
ILoggerRepository^ GetRepository(
    String^ repositoryName
)
Parameters
repositoryName
Type:   Online System String
The name to use to lookup to the ILoggerRepository.
Return Value
Type: ILoggerRepository
The named ILoggerRepository
Remarks

            Lookup a named ILoggerRepository. This is the repository created by
            calling [M:CreateRepository(string,Type)].

See Also
IRepositorySelector Interface
IRepositorySelector Members
GetRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector Events

IRepositorySelector Events Apache log4net™ SDK Documentation
The IRepositorySelector type exposes the following members.
Events
 | Name | Description
Public event | LoggerRepositoryCreatedEvent | Event to notify that a logger repository has been created.
Back to Top
See Also
IRepositorySelector Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRepositorySelector.LoggerRepositoryCreatedEvent Event

IRepositorySelector LoggerRepositoryCreatedEvent Event Apache log4net™ SDK Documentation
Event to notify that a logger repository has been created.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
event LoggerRepositoryCreationEventHandler LoggerRepositoryCreatedEvent
event LoggerRepositoryCreationEventHandler LoggerRepositoryCreatedEvent
Event LoggerRepositoryCreatedEvent As LoggerRepositoryCreationEventHandler
Event LoggerRepositoryCreatedEvent As LoggerRepositoryCreationEventHandler
 event LoggerRepositoryCreationEventHandler^ LoggerRepositoryCreatedEvent {
    void add (LoggerRepositoryCreationEventHandler^ value);
    void remove (LoggerRepositoryCreationEventHandler^ value);
}
 event LoggerRepositoryCreationEventHandler^ LoggerRepositoryCreatedEvent {
    void add (LoggerRepositoryCreationEventHandler^ value);
    void remove (LoggerRepositoryCreationEventHandler^ value);
}
Field Value
Type:

            Event to notify that a logger repository has been created.

Remarks

            Event raised when a new repository is created.
            The event source will be this selector. The event args will
            be a LoggerRepositoryCreationEventArgs which
            holds the newly created ILoggerRepository.

See Also
IRepositorySelector Interface
IRepositorySelector Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ITriggeringEventEvaluator Interface

ITriggeringEventEvaluator Interface Apache log4net™ SDK Documentation
Test if an LoggingEvent triggers an action

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITriggeringEventEvaluator
public interface ITriggeringEventEvaluator
Public Interface ITriggeringEventEvaluator
Public Interface ITriggeringEventEvaluator
public interface class ITriggeringEventEvaluator
public interface class ITriggeringEventEvaluator
Remarks

            Implementations of this interface allow certain appenders to decide
            when to perform an appender specific action.

            The action or behavior triggered is defined by the implementation.

See Also
ITriggeringEventEvaluator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ITriggeringEventEvaluator Members

ITriggeringEventEvaluator Members Apache log4net™ SDK Documentation
The ITriggeringEventEvaluator type exposes the following members.
Methods
 | Name | Description
Public method | IsTriggeringEvent | Test if this event triggers the action
Back to Top
See Also
ITriggeringEventEvaluator Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ITriggeringEventEvaluator Methods

ITriggeringEventEvaluator Methods Apache log4net™ SDK Documentation
The ITriggeringEventEvaluator type exposes the following members.
Methods
 | Name | Description
Public method | IsTriggeringEvent | Test if this event triggers the action
Back to Top
See Also
ITriggeringEventEvaluator Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ITriggeringEventEvaluator.IsTriggeringEvent Method

ITriggeringEventEvaluator IsTriggeringEvent Method Apache log4net™ SDK Documentation
Test if this event triggers the action

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsTriggeringEvent(
    LoggingEvent loggingEvent
)
bool IsTriggeringEvent(
    LoggingEvent loggingEvent
)
Function IsTriggeringEvent (
    loggingEvent As LoggingEvent
) As Boolean
Function IsTriggeringEvent (
    loggingEvent As LoggingEvent
) As Boolean
bool IsTriggeringEvent(
    LoggingEvent^ loggingEvent
)
bool IsTriggeringEvent(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to check
Return Value
Type:   Online Boolean
true if this event triggers the action, otherwise false
Remarks

            Return true if this event triggers the action

See Also
ITriggeringEventEvaluator Interface
ITriggeringEventEvaluator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level Class

Level Class Apache log4net™ SDK Documentation
Defines the default set of levels recognized by the system.
Inheritance Hierarchy
Online System Object
log4net.Core Level

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class Level : IComparable
[SerializableAttribute]
public sealed class Level : IComparable
<SerializableAttribute>
Public NotInheritable Class Level
    Implements IComparable
<SerializableAttribute>
Public NotInheritable Class Level
    Implements IComparable
[SerializableAttribute]
public ref class Level sealed : IComparable
[SerializableAttribute]
public ref class Level sealed : IComparable
Remarks

            Each LoggingEvent has an associated Level.

            Levels have a numeric Value that defines the relative
            ordering between levels. Two Levels with the same Value
            are deemed to be equivalent.

            The levels that are recognized by log4net are set for each ILoggerRepository
            and each repository can have different levels defined. The levels are stored
            in the LevelMap on the repository. Levels are
            looked up by name from the LevelMap.

            When logging at level INFO the actual level used is not Info but
            the value of LoggerRepository.LevelMap["INFO"]. The default value for this is
            Info, but this can be changed by reconfiguring the level map.

            Each level has a DisplayName in addition to its Name. The
            DisplayName is the string that is written into the output log. By default
            the display name is the same as the level name, but this can be used to alias levels
            or to localize the log output.

            Some of the predefined levels recognized by the system are:

  • Off.
  • Fatal.
  • Error.
  • Warn.
  • Info.
  • Debug.
  • All.
See Also
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level Members

Level Members Apache log4net™ SDK Documentation
The Level type exposes the following members.
Constructors
 | Name | Description
Public method | Level(Int32, String) | Constructor
Public method | Level(Int32, String, String) | Constructor
Back to Top
Methods
 | Name | Description
 | Compare | Compares two specified Level instances.
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values.
Public method | Equals | Compares levels. (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns the Online String representation of the current Level. (Overrides Online Object ToString .)
Back to Top
Operators
Name | Description
Equality | Returns a value indicating whether two specified Level objects have the same value.
GreaterThan | Returns a value indicating whether a specified Level is greater than another specified Level.
GreaterThanOrEqual | Returns a value indicating whether a specified Level is greater than or equal to another specified Level.
Inequality | Returns a value indicating whether two specified Level objects have different values.
LessThan | Returns a value indicating whether a specified Level is less than another specified Level.
LessThanOrEqual | Returns a value indicating whether a specified Level is less than or equal to another specified Level.
Back to Top
Fields
Name | Description
Alert | The Alert level designates very severe error events. Take immediate action, alerts.
All | The All level designates the lowest level possible.
Critical | The Critical level designates very severe error events. Critical condition, critical.
Debug | The Debug level designates fine-grained informational events that are most useful to debug an application.
Emergency | The Emergency level designates very severe error events. System unusable, emergencies.
Error | The Error level designates error events that might still allow the application to continue running.
Fatal | The Fatal level designates very severe error events that will presumably lead the application to abort.
Fine | The Fine level designates fine-grained informational events that are most useful to debug an application.
Finer | The Finer level designates fine-grained informational events that are most useful to debug an application.
Finest | The Finest level designates fine-grained informational events that are most useful to debug an application.
Info | The Info level designates informational messages that highlight the progress of the application at coarse-grained level.
Log4Net_Debug | The Emergency level designates very severe error events. System unusable, emergencies.
Notice | The Notice level designates informational messages that highlight the progress of the application at the highest level.
Off | The Off level designates a higher level than all the rest.
Severe | The Severe level designates very severe error events.
Trace | The Trace level designates fine-grained informational events that are most useful to debug an application.
Verbose | The Verbose level designates fine-grained informational events that are most useful to debug an application.
Warn | The Warn level designates potentially harmful situations.
Back to Top
Properties
 | Name | Description
Public property | DisplayName | Gets the display name of this level.
Public property | Name | Gets the name of this level.
Public property | Value | Gets the value of this level.
Back to Top
See Also
Level Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level Constructor

Level Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Level(Int32, String) | Constructor
Public method | Level(Int32, String, String) | Constructor
Back to Top
See Also
Level Class
Level Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level Constructor (Int32, String)

Level Constructor (Int32, String) Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level(
    int level,
    string levelName
)
public Level(
    int level,
    string levelName
)
Public Sub New (
    level As Integer,
    levelName As String
)
Public Sub New (
    level As Integer,
    levelName As String
)
public:
Level(
    int level,
    String^ levelName
)
public:
Level(
    int level,
    String^ levelName
)
Parameters
level
Type:   Online System Int32
Integer value for this level, higher values represent more severe levels.
levelName
Type:   Online System String
The string name of this level.
Remarks

            Initializes a new instance of the Level class with
            the specified level name and value.

See Also
Level Class
Level Members
Level Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level Constructor (Int32, String, String)

Level Constructor (Int32, String, String) Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level(
    int level,
    string levelName,
    string displayName
)
public Level(
    int level,
    string levelName,
    string displayName
)
Public Sub New (
    level As Integer,
    levelName As String,
    displayName As String
)
Public Sub New (
    level As Integer,
    levelName As String,
    displayName As String
)
public:
Level(
    int level,
    String^ levelName,
    String^ displayName
)
public:
Level(
    int level,
    String^ levelName,
    String^ displayName
)
Parameters
level
Type:   Online System Int32
Integer value for this level, higher values represent more severe levels.
levelName
Type:   Online System String
The string name of this level.
displayName
Type:   Online System String
The display name for this level. This may be localized or otherwise different from the name
Remarks

            Initializes a new instance of the Level class with
            the specified level name and value.

See Also
Level Class
Level Members
Level Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level Fields

Level Fields Apache log4net™ SDK Documentation
The Level type exposes the following members.
Fields
Name | Description
Alert | The Alert level designates very severe error events. Take immediate action, alerts.
All | The All level designates the lowest level possible.
Critical | The Critical level designates very severe error events. Critical condition, critical.
Debug | The Debug level designates fine-grained informational events that are most useful to debug an application.
Emergency | The Emergency level designates very severe error events. System unusable, emergencies.
Error | The Error level designates error events that might still allow the application to continue running.
Fatal | The Fatal level designates very severe error events that will presumably lead the application to abort.
Fine | The Fine level designates fine-grained informational events that are most useful to debug an application.
Finer | The Finer level designates fine-grained informational events that are most useful to debug an application.
Finest | The Finest level designates fine-grained informational events that are most useful to debug an application.
Info | The Info level designates informational messages that highlight the progress of the application at coarse-grained level.
Log4Net_Debug | The Emergency level designates very severe error events. System unusable, emergencies.
Notice | The Notice level designates informational messages that highlight the progress of the application at the highest level.
Off | The Off level designates a higher level than all the rest.
Severe | The Severe level designates very severe error events.
Trace | The Trace level designates fine-grained informational events that are most useful to debug an application.
Verbose | The Verbose level designates fine-grained informational events that are most useful to debug an application.
Warn | The Warn level designates potentially harmful situations.
Back to Top
See Also
Level Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Alert Field

Level Alert Field Apache log4net™ SDK Documentation
The Alert level designates very severe error events. Take immediate action, alerts.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Alert
public static readonly Level Alert
Public Shared ReadOnly Alert As Level
Public Shared ReadOnly Alert As Level
public:
static initonly Level^ Alert
public:
static initonly Level^ Alert
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.All Field

Level All Field Apache log4net™ SDK Documentation
The All level designates the lowest level possible.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level All
public static readonly Level All
Public Shared ReadOnly All As Level
Public Shared ReadOnly All As Level
public:
static initonly Level^ All
public:
static initonly Level^ All
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Critical Field

Level Critical Field Apache log4net™ SDK Documentation
The Critical level designates very severe error events. Critical condition, critical.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Critical
public static readonly Level Critical
Public Shared ReadOnly Critical As Level
Public Shared ReadOnly Critical As Level
public:
static initonly Level^ Critical
public:
static initonly Level^ Critical
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Debug Field

Level Debug Field Apache log4net™ SDK Documentation
The Debug level designates fine-grained informational events that are most useful to debug an application.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Debug
public static readonly Level Debug
Public Shared ReadOnly Debug As Level
Public Shared ReadOnly Debug As Level
public:
static initonly Level^ Debug
public:
static initonly Level^ Debug
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Emergency Field

Level Emergency Field Apache log4net™ SDK Documentation
The Emergency level designates very severe error events. System unusable, emergencies.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Emergency
public static readonly Level Emergency
Public Shared ReadOnly Emergency As Level
Public Shared ReadOnly Emergency As Level
public:
static initonly Level^ Emergency
public:
static initonly Level^ Emergency
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Error Field

Level Error Field Apache log4net™ SDK Documentation
The Error level designates error events that might still allow the application to continue running.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Error
public static readonly Level Error
Public Shared ReadOnly Error As Level
Public Shared ReadOnly Error As Level
public:
static initonly Level^ Error
public:
static initonly Level^ Error
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Fatal Field

Level Fatal Field Apache log4net™ SDK Documentation
The Fatal level designates very severe error events that will presumably lead the application to abort.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Fatal
public static readonly Level Fatal
Public Shared ReadOnly Fatal As Level
Public Shared ReadOnly Fatal As Level
public:
static initonly Level^ Fatal
public:
static initonly Level^ Fatal
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Fine Field

Level Fine Field Apache log4net™ SDK Documentation
The Fine level designates fine-grained informational events that are most useful to debug an application.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Fine
public static readonly Level Fine
Public Shared ReadOnly Fine As Level
Public Shared ReadOnly Fine As Level
public:
static initonly Level^ Fine
public:
static initonly Level^ Fine
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Finer Field

Level Finer Field Apache log4net™ SDK Documentation
The Finer level designates fine-grained informational events that are most useful to debug an application.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Finer
public static readonly Level Finer
Public Shared ReadOnly Finer As Level
Public Shared ReadOnly Finer As Level
public:
static initonly Level^ Finer
public:
static initonly Level^ Finer
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Finest Field

Level Finest Field Apache log4net™ SDK Documentation
The Finest level designates fine-grained informational events that are most useful to debug an application.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Finest
public static readonly Level Finest
Public Shared ReadOnly Finest As Level
Public Shared ReadOnly Finest As Level
public:
static initonly Level^ Finest
public:
static initonly Level^ Finest
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Info Field

Level Info Field Apache log4net™ SDK Documentation
The Info level designates informational messages that highlight the progress of the application at coarse-grained level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Info
public static readonly Level Info
Public Shared ReadOnly Info As Level
Public Shared ReadOnly Info As Level
public:
static initonly Level^ Info
public:
static initonly Level^ Info
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Log4Net_Debug Field

Level Log4Net_Debug Field Apache log4net™ SDK Documentation
The Emergency level designates very severe error events. System unusable, emergencies.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Log4Net_Debug
public static readonly Level Log4Net_Debug
Public Shared ReadOnly Log4Net_Debug As Level
Public Shared ReadOnly Log4Net_Debug As Level
public:
static initonly Level^ Log4Net_Debug
public:
static initonly Level^ Log4Net_Debug
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Notice Field

Level Notice Field Apache log4net™ SDK Documentation
The Notice level designates informational messages that highlight the progress of the application at the highest level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Notice
public static readonly Level Notice
Public Shared ReadOnly Notice As Level
Public Shared ReadOnly Notice As Level
public:
static initonly Level^ Notice
public:
static initonly Level^ Notice
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Off Field

Level Off Field Apache log4net™ SDK Documentation
The Off level designates a higher level than all the rest.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Off
public static readonly Level Off
Public Shared ReadOnly Off As Level
Public Shared ReadOnly Off As Level
public:
static initonly Level^ Off
public:
static initonly Level^ Off
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Severe Field

Level Severe Field Apache log4net™ SDK Documentation
The Severe level designates very severe error events.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Severe
public static readonly Level Severe
Public Shared ReadOnly Severe As Level
Public Shared ReadOnly Severe As Level
public:
static initonly Level^ Severe
public:
static initonly Level^ Severe
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Trace Field

Level Trace Field Apache log4net™ SDK Documentation
The Trace level designates fine-grained informational events that are most useful to debug an application.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Trace
public static readonly Level Trace
Public Shared ReadOnly Trace As Level
Public Shared ReadOnly Trace As Level
public:
static initonly Level^ Trace
public:
static initonly Level^ Trace
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Verbose Field

Level Verbose Field Apache log4net™ SDK Documentation
The Verbose level designates fine-grained informational events that are most useful to debug an application.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Verbose
public static readonly Level Verbose
Public Shared ReadOnly Verbose As Level
Public Shared ReadOnly Verbose As Level
public:
static initonly Level^ Verbose
public:
static initonly Level^ Verbose
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Warn Field

Level Warn Field Apache log4net™ SDK Documentation
The Warn level designates potentially harmful situations.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Level Warn
public static readonly Level Warn
Public Shared ReadOnly Warn As Level
Public Shared ReadOnly Warn As Level
public:
static initonly Level^ Warn
public:
static initonly Level^ Warn
Field Value
Type: Level
See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level Methods

Level Methods Apache log4net™ SDK Documentation
The Level type exposes the following members.
Methods
 | Name | Description
 | Compare | Compares two specified Level instances.
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values.
Public method | Equals | Compares levels. (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns the Online String representation of the current Level. (Overrides Online Object ToString .)
Back to Top
See Also
Level Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Compare Method

Level Compare Method Apache log4net™ SDK Documentation
Compares two specified Level instances.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Compare(
    Level l,
    Level r
)
public static int Compare(
    Level l,
    Level r
)
Public Shared Function Compare (
    l As Level,
    r As Level
) As Integer
Public Shared Function Compare (
    l As Level,
    r As Level
) As Integer
public:
static int Compare(
    Level^ l,
    Level^ r
)
public:
static int Compare(
    Level^ l,
    Level^ r
)
Parameters
l
Type: log4net.Core Level
The first Level to compare.
r
Type: log4net.Core Level
The second Level to compare.
Return Value
Type:   Online Int32

            A 32-bit signed integer that indicates the relative order of the
            two values compared. The return value has these meanings:

Value | Meaning
Less than zero | l is less than r.
Zero | l is equal to r.
Greater than zero | l is greater than r.
Remarks

            Compares two levels.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.CompareTo Method

Level CompareTo Method Apache log4net™ SDK Documentation
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object r
)
public int CompareTo(
    Object r
)
Public Function CompareTo (
    r As Object
) As Integer
Public Function CompareTo (
    r As Object
) As Integer
public:
virtual int CompareTo(
    Object^ r
) sealed
public:
virtual int CompareTo(
    Object^ r
) sealed
Parameters
r
Type:   Online System Object
A Level instance or   to compare with this instance.
Return Value
Type:   Online Int32

            A 32-bit signed integer that indicates the relative order of the
            values compared. The return value has these meanings:

Value | Meaning
Less than zero | This instance is less than r.
Zero | This instance is equal to r.
Greater than zero | This instance is greater than r. -or- r is .
Implements
  Online IComparable CompareTo(Object)
Exceptions
Exception | Condition
Online System ArgumentException | r is not a Level.
Remarks
r must be an instance of Level
            or  ; otherwise, an exception is thrown.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Equals Method

Level Equals Method Apache log4net™ SDK Documentation
Compares levels.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
The object to compare against.
Return Value
Type:   Online Boolean
true if the objects are equal.
Remarks

            Compares the levels of Level instances, and
            defers to base class if the target object is not a Level
            instance.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.GetHashCode Method

Level GetHashCode Method Apache log4net™ SDK Documentation
Returns a hash code

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
Return Value
Type:   Online Int32
A hash code for the current Level.
Remarks

            Returns a hash code suitable for use in hashing algorithms and data
            structures like a hash table.

            Returns the hash code of the level Value.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.ToString Method

Level ToString Method Apache log4net™ SDK Documentation
Returns the Online String representation of the current Level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value
Type:   Online String

            A   Online String representation of the current Level.

Remarks

            Returns the level Name.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level Operators

Level Operators Apache log4net™ SDK Documentation
The Level type exposes the following members.
Operators
Name | Description
Equality | Returns a value indicating whether two specified Level objects have the same value.
GreaterThan | Returns a value indicating whether a specified Level is greater than another specified Level.
GreaterThanOrEqual | Returns a value indicating whether a specified Level is greater than or equal to another specified Level.
Inequality | Returns a value indicating whether two specified Level objects have different values.
LessThan | Returns a value indicating whether a specified Level is less than another specified Level.
LessThanOrEqual | Returns a value indicating whether a specified Level is less than or equal to another specified Level.
Back to Top
See Also
Level Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Equality Operator

Level Equality Operator Apache log4net™ SDK Documentation
Returns a value indicating whether two specified Level objects have the same value.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    Level l,
    Level r
)
public static bool operator ==(
    Level l,
    Level r
)
Public Shared Operator = (
    l As Level,
    r As Level
) As Boolean
Public Shared Operator = (
    l As Level,
    r As Level
) As Boolean
public:
static bool operator ==(
    Level^ l,
    Level^ r
)
public:
static bool operator ==(
    Level^ l,
    Level^ r
)
Parameters
l
Type: log4net.Core Level
A Level or  .
r
Type: log4net.Core Level
A Level or  .
Return Value
Type:   Online Boolean
true if the value of l is the same as the
            value of r; otherwise, false.

Remarks

            Compares two levels.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.GreaterThan Operator

Level GreaterThan Operator Apache log4net™ SDK Documentation
Returns a value indicating whether a specified Level is greater than another specified Level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator >(
    Level l,
    Level r
)
public static bool operator >(
    Level l,
    Level r
)
Public Shared Operator > (
    l As Level,
    r As Level
) As Boolean
Public Shared Operator > (
    l As Level,
    r As Level
) As Boolean
public:
static bool operator >(
    Level^ l,
    Level^ r
)
public:
static bool operator >(
    Level^ l,
    Level^ r
)
Parameters
l
Type: log4net.Core Level
A Level
r
Type: log4net.Core Level
A Level
Return Value
Type:   Online Boolean
true if l is greater than
            r; otherwise, false.

Remarks

            Compares two levels.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.GreaterThanOrEqual Operator

Level GreaterThanOrEqual Operator Apache log4net™ SDK Documentation
Returns a value indicating whether a specified Level is greater than or equal to another specified Level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator >=(
    Level l,
    Level r
)
public static bool operator >=(
    Level l,
    Level r
)
Public Shared Operator >= (
    l As Level,
    r As Level
) As Boolean
Public Shared Operator >= (
    l As Level,
    r As Level
) As Boolean
public:
static bool operator >=(
    Level^ l,
    Level^ r
)
public:
static bool operator >=(
    Level^ l,
    Level^ r
)
Parameters
l
Type: log4net.Core Level
A Level
r
Type: log4net.Core Level
A Level
Return Value
Type:   Online Boolean
true if l is greater than or equal to
            r; otherwise, false.

Remarks

            Compares two levels.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Inequality Operator

Level Inequality Operator Apache log4net™ SDK Documentation
Returns a value indicating whether two specified Level objects have different values.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    Level l,
    Level r
)
public static bool operator !=(
    Level l,
    Level r
)
Public Shared Operator <> (
    l As Level,
    r As Level
) As Boolean
Public Shared Operator <> (
    l As Level,
    r As Level
) As Boolean
public:
static bool operator !=(
    Level^ l,
    Level^ r
)
public:
static bool operator !=(
    Level^ l,
    Level^ r
)
Parameters
l
Type: log4net.Core Level
A Level or  .
r
Type: log4net.Core Level
A Level or  .
Return Value
Type:   Online Boolean
true if the value of l is different from
            the value of r; otherwise, false.

Remarks

            Compares two levels.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.LessThan Operator

Level LessThan Operator Apache log4net™ SDK Documentation
Returns a value indicating whether a specified Level is less than another specified Level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator <(
    Level l,
    Level r
)
public static bool operator <(
    Level l,
    Level r
)
Public Shared Operator < (
    l As Level,
    r As Level
) As Boolean
Public Shared Operator < (
    l As Level,
    r As Level
) As Boolean
public:
static bool operator <(
    Level^ l,
    Level^ r
)
public:
static bool operator <(
    Level^ l,
    Level^ r
)
Parameters
l
Type: log4net.Core Level
A Level
r
Type: log4net.Core Level
A Level
Return Value
Type:   Online Boolean
true if l is less than
            r; otherwise, false.

Remarks

            Compares two levels.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.LessThanOrEqual Operator

Level LessThanOrEqual Operator Apache log4net™ SDK Documentation
Returns a value indicating whether a specified Level is less than or equal to another specified Level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator <=(
    Level l,
    Level r
)
public static bool operator <=(
    Level l,
    Level r
)
Public Shared Operator <= (
    l As Level,
    r As Level
) As Boolean
Public Shared Operator <= (
    l As Level,
    r As Level
) As Boolean
public:
static bool operator <=(
    Level^ l,
    Level^ r
)
public:
static bool operator <=(
    Level^ l,
    Level^ r
)
Parameters
l
Type: log4net.Core Level
A Level
r
Type: log4net.Core Level
A Level
Return Value
Type:   Online Boolean
true if l is less than or equal to
            r; otherwise, false.

Remarks

            Compares two levels.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level Properties

Level Properties Apache log4net™ SDK Documentation
The Level type exposes the following members.
Properties
 | Name | Description
Public property | DisplayName | Gets the display name of this level.
Public property | Name | Gets the name of this level.
Public property | Value | Gets the value of this level.
Back to Top
See Also
Level Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.DisplayName Property

Level DisplayName Property Apache log4net™ SDK Documentation
Gets the display name of this level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DisplayName { get; }
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}
public:
property String^ DisplayName {
    String^ get ();
}
Property Value
Type:   Online String

            The display name of this level.

Remarks

            Gets the display name of this level.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Name Property

Level Name Property Apache log4net™ SDK Documentation
Gets the name of this level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
public:
property String^ Name {
    String^ get ();
}
Property Value
Type:   Online String

            The name of this level.

Remarks

            Gets the name of this level.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Level.Value Property

Level Value Property Apache log4net™ SDK Documentation
Gets the value of this level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Value { get; }
public int Value { get; }
Public ReadOnly Property Value As Integer
    Get
Public ReadOnly Property Value As Integer
    Get
public:
property int Value {
    int get ();
}
public:
property int Value {
    int get ();
}
Property Value
Type:   Online Int32

            The value of this level.

Remarks

            Gets the value of this level.

See Also
Level Class
Level Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection Class

LevelCollection Class Apache log4net™ SDK Documentation
A strongly-typed collection of Level objects.
Inheritance Hierarchy
Online System Object
log4net.Core LevelCollection

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LevelCollection : IList,
    ICollection, IEnumerable, ICloneable
public class LevelCollection : IList,
    ICollection, IEnumerable, ICloneable
Public Class LevelCollection
    Implements IList, ICollection, IEnumerable, ICloneable
Public Class LevelCollection
    Implements IList, ICollection, IEnumerable, ICloneable
public ref class LevelCollection : IList,
    ICollection, IEnumerable, ICloneable
public ref class LevelCollection : IList,
    ICollection, IEnumerable, ICloneable
See Also
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection Members

LevelCollection Members Apache log4net™ SDK Documentation
The LevelCollection type exposes the following members.
Constructors
 | Name | Description
Public method | LevelCollection | Initializes a new instance of the LevelCollection class that is empty and has the default initial capacity.
Public method | LevelCollection(ICollection) | Initializes a new instance of the LevelCollection class that contains elements copied from the specified Level collection.
Public method | LevelCollection(Int32) | Initializes a new instance of the LevelCollection class that has the specified initial capacity.
Public method | LevelCollection( Level ) | Initializes a new instance of the LevelCollection class that contains elements copied from the specified Level array.
Public method | LevelCollection(LevelCollection) | Initializes a new instance of the LevelCollection class that contains elements copied from the specified LevelCollection.
Protected method | LevelCollection(LevelCollection Tag) | Allow subclasses to avoid our default constructors
Back to Top
Methods
 | Name | Description
Public method | Add | Adds a Level to the end of the LevelCollection.
Public method | AddRange(ICollection) | Adds the elements of a Level collection to the current LevelCollection.
Public method | AddRange( Level ) | Adds the elements of a Level array to the current LevelCollection.
Public method | AddRange(LevelCollection) | Adds the elements of another LevelCollection to the current LevelCollection.
Public method | Clear | Removes all elements from the LevelCollection.
Public method | Clone | Creates a shallow copy of the LevelCollection.
Public method | Contains | Determines whether a given Level is in the LevelCollection.
Public method | CopyTo( Level ) | Copies the entire LevelCollection to a one-dimensional Level array.
Public method | CopyTo( Level , Int32) | Copies the entire LevelCollection to a one-dimensional Level array, starting at the specified index of the target array.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | Returns an enumerator that can iterate through the LevelCollection.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a Level in the LevelCollection.
Public method | Insert | Inserts an element into the LevelCollection at the specified index.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ReadOnly | Creates a read-only wrapper for a LevelCollection instance.
Public method | Remove | Removes the first occurrence of a specific Level from the LevelCollection.
Public method | RemoveAt | Removes the element at the specified index of the LevelCollection.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements.
Back to Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements the LevelCollection can contain.
Public property | Count | Gets the number of elements actually contained in the LevelCollection.
Public property | IsFixedSize | Gets a value indicating whether the collection has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public property | Item | Gets or sets the Level at the specified index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Back to Top
See Also
LevelCollection Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection Constructor

LevelCollection Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | LevelCollection | Initializes a new instance of the LevelCollection class that is empty and has the default initial capacity.
Public method | LevelCollection(ICollection) | Initializes a new instance of the LevelCollection class that contains elements copied from the specified Level collection.
Public method | LevelCollection(Int32) | Initializes a new instance of the LevelCollection class that has the specified initial capacity.
Public method | LevelCollection( Level ) | Initializes a new instance of the LevelCollection class that contains elements copied from the specified Level array.
Public method | LevelCollection(LevelCollection) | Initializes a new instance of the LevelCollection class that contains elements copied from the specified LevelCollection.
Protected method | LevelCollection(LevelCollection Tag) | Allow subclasses to avoid our default constructors
Back to Top
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection Constructor

LevelCollection Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the LevelCollection class that is empty and has the default initial capacity.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelCollection()
public LevelCollection()
Public Sub New
Public Sub New
public:
LevelCollection()
public:
LevelCollection()
See Also
LevelCollection Class
LevelCollection Members
LevelCollection Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection Constructor (ICollection)

LevelCollection Constructor (ICollection) Apache log4net™ SDK Documentation
Initializes a new instance of the LevelCollection class that contains elements copied from the specified Level collection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelCollection(
    ICollection col
)
public LevelCollection(
    ICollection col
)
Public Sub New (
    col As ICollection
)
Public Sub New (
    col As ICollection
)
public:
LevelCollection(
    ICollection^ col
)
public:
LevelCollection(
    ICollection^ col
)
Parameters
col
Type:   Online System.Collections ICollection
The Level collection whose elements are copied to the new list.
See Also
LevelCollection Class
LevelCollection Members
LevelCollection Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection Constructor (Int32)

LevelCollection Constructor (Int32) Apache log4net™ SDK Documentation
Initializes a new instance of the LevelCollection class that has the specified initial capacity.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelCollection(
    int capacity
)
public LevelCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)
Public Sub New (
    capacity As Integer
)
public:
LevelCollection(
    int capacity
)
public:
LevelCollection(
    int capacity
)
Parameters
capacity
Type:   Online System Int32

            The number of elements that the new LevelCollection is initially capable of storing.

See Also
LevelCollection Class
LevelCollection Members
LevelCollection Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection Constructor (Level[])

LevelCollection Constructor ( Level ) Apache log4net™ SDK Documentation
Initializes a new instance of the LevelCollection class that contains elements copied from the specified Level array.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelCollection(
    Level[] a
)
public LevelCollection(
    Level[] a
)
Public Sub New (
    a As Level()
)
Public Sub New (
    a As Level()
)
public:
LevelCollection(
    array<Level^>^ a
)
public:
LevelCollection(
    array<Level^>^ a
)
Parameters
a
Type:  log4net.Core Level
The Level array whose elements are copied to the new list.
See Also
LevelCollection Class
LevelCollection Members
LevelCollection Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection Constructor (LevelCollection)

LevelCollection Constructor (LevelCollection) Apache log4net™ SDK Documentation
Initializes a new instance of the LevelCollection class that contains elements copied from the specified LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelCollection(
    LevelCollection c
)
public LevelCollection(
    LevelCollection c
)
Public Sub New (
    c As LevelCollection
)
Public Sub New (
    c As LevelCollection
)
public:
LevelCollection(
    LevelCollection^ c
)
public:
LevelCollection(
    LevelCollection^ c
)
Parameters
c
Type: log4net.Core LevelCollection
The LevelCollection whose elements are copied to the new collection.
See Also
LevelCollection Class
LevelCollection Members
LevelCollection Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection Constructor (LevelCollection.Tag)

LevelCollection Constructor (LevelCollection Tag) Apache log4net™ SDK Documentation
Allow subclasses to avoid our default constructors

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal LevelCollection(
    LevelCollection..::..Tag tag
)
protected internal LevelCollection(
    LevelCollection..::..Tag tag
)
Protected Friend Sub New (
    tag As LevelCollection..::..Tag
)
Protected Friend Sub New (
    tag As LevelCollection..::..Tag
)
protected public:
LevelCollection(
    LevelCollection..::..Tag tag
)
protected public:
LevelCollection(
    LevelCollection..::..Tag tag
)
Parameters
tag
Type: log4net.Core LevelCollection Tag
[Missing <param name="tag"/> documentation for "M:log4net.Core.LevelCollection.#ctor(log4net.Core.LevelCollection.Tag)"]
See Also
LevelCollection Class
LevelCollection Members
LevelCollection Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection Methods

LevelCollection Methods Apache log4net™ SDK Documentation
The LevelCollection type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds a Level to the end of the LevelCollection.
Public method | AddRange(ICollection) | Adds the elements of a Level collection to the current LevelCollection.
Public method | AddRange( Level ) | Adds the elements of a Level array to the current LevelCollection.
Public method | AddRange(LevelCollection) | Adds the elements of another LevelCollection to the current LevelCollection.
Public method | Clear | Removes all elements from the LevelCollection.
Public method | Clone | Creates a shallow copy of the LevelCollection.
Public method | Contains | Determines whether a given Level is in the LevelCollection.
Public method | CopyTo( Level ) | Copies the entire LevelCollection to a one-dimensional Level array.
Public method | CopyTo( Level , Int32) | Copies the entire LevelCollection to a one-dimensional Level array, starting at the specified index of the target array.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | Returns an enumerator that can iterate through the LevelCollection.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a Level in the LevelCollection.
Public method | Insert | Inserts an element into the LevelCollection at the specified index.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ReadOnly | Creates a read-only wrapper for a LevelCollection instance.
Public method | Remove | Removes the first occurrence of a specific Level from the LevelCollection.
Public method | RemoveAt | Removes the element at the specified index of the LevelCollection.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements.
Back to Top
See Also
LevelCollection Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.Add Method

LevelCollection Add Method Apache log4net™ SDK Documentation
Adds a Level to the end of the LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Add(
    Level item
)
public virtual int Add(
    Level item
)
Public Overridable Function Add (
    item As Level
) As Integer
Public Overridable Function Add (
    item As Level
) As Integer
public:
virtual int Add(
    Level^ item
)
public:
virtual int Add(
    Level^ item
)
Parameters
item
Type: log4net.Core Level
The Level to be added to the end of the LevelCollection.
Return Value
Type:   Online Int32
The index at which the value has been added.
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.AddRange Method

LevelCollection AddRange Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | AddRange(ICollection) | Adds the elements of a Level collection to the current LevelCollection.
Public method | AddRange( Level ) | Adds the elements of a Level array to the current LevelCollection.
Public method | AddRange(LevelCollection) | Adds the elements of another LevelCollection to the current LevelCollection.
Back to Top
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.AddRange Method (ICollection)

LevelCollection AddRange Method (ICollection) Apache log4net™ SDK Documentation
Adds the elements of a Level collection to the current LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int AddRange(
    ICollection col
)
public virtual int AddRange(
    ICollection col
)
Public Overridable Function AddRange (
    col As ICollection
) As Integer
Public Overridable Function AddRange (
    col As ICollection
) As Integer
public:
virtual int AddRange(
    ICollection^ col
)
public:
virtual int AddRange(
    ICollection^ col
)
Parameters
col
Type:   Online System.Collections ICollection
The Level collection whose elements should be added to the end of the LevelCollection.
Return Value
Type:   Online Int32
The new Count of the LevelCollection.
See Also
LevelCollection Class
LevelCollection Members
AddRange Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.AddRange Method (Level[])

LevelCollection AddRange Method ( Level ) Apache log4net™ SDK Documentation
Adds the elements of a Level array to the current LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int AddRange(
    Level[] x
)
public virtual int AddRange(
    Level[] x
)
Public Overridable Function AddRange (
    x As Level()
) As Integer
Public Overridable Function AddRange (
    x As Level()
) As Integer
public:
virtual int AddRange(
    array<Level^>^ x
)
public:
virtual int AddRange(
    array<Level^>^ x
)
Parameters
x
Type:  log4net.Core Level
The Level array whose elements should be added to the end of the LevelCollection.
Return Value
Type:   Online Int32
The new Count of the LevelCollection.
See Also
LevelCollection Class
LevelCollection Members
AddRange Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.AddRange Method (LevelCollection)

LevelCollection AddRange Method (LevelCollection) Apache log4net™ SDK Documentation
Adds the elements of another LevelCollection to the current LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int AddRange(
    LevelCollection x
)
public virtual int AddRange(
    LevelCollection x
)
Public Overridable Function AddRange (
    x As LevelCollection
) As Integer
Public Overridable Function AddRange (
    x As LevelCollection
) As Integer
public:
virtual int AddRange(
    LevelCollection^ x
)
public:
virtual int AddRange(
    LevelCollection^ x
)
Parameters
x
Type: log4net.Core LevelCollection
The LevelCollection whose elements should be added to the end of the current LevelCollection.
Return Value
Type:   Online Int32
The new Count of the LevelCollection.
See Also
LevelCollection Class
LevelCollection Members
AddRange Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.Clear Method

LevelCollection Clear Method Apache log4net™ SDK Documentation
Removes all elements from the LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Clear()
public virtual void Clear()
Public Overridable Sub Clear
Public Overridable Sub Clear
public:
virtual void Clear()
public:
virtual void Clear()
Implements
  Online IList Clear
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.Clone Method

LevelCollection Clone Method Apache log4net™ SDK Documentation
Creates a shallow copy of the LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Clone()
public virtual Object Clone()
Public Overridable Function Clone As Object
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
public:
virtual Object^ Clone()
Return Value
Type:   Online Object
A new LevelCollection with a shallow copy of the collection data.
Implements
  Online ICloneable Clone
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.Contains Method

LevelCollection Contains Method Apache log4net™ SDK Documentation
Determines whether a given Level is in the LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Contains(
    Level item
)
public virtual bool Contains(
    Level item
)
Public Overridable Function Contains (
    item As Level
) As Boolean
Public Overridable Function Contains (
    item As Level
) As Boolean
public:
virtual bool Contains(
    Level^ item
)
public:
virtual bool Contains(
    Level^ item
)
Parameters
item
Type: log4net.Core Level
The Level to check for.
Return Value
Type:   Online Boolean
true if item is found in the LevelCollection; otherwise, false.
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.CopyTo Method

LevelCollection CopyTo Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | CopyTo( Level ) | Copies the entire LevelCollection to a one-dimensional Level array.
Public method | CopyTo( Level , Int32) | Copies the entire LevelCollection to a one-dimensional Level array, starting at the specified index of the target array.
Back to Top
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.CopyTo Method (Level[])

LevelCollection CopyTo Method ( Level ) Apache log4net™ SDK Documentation
Copies the entire LevelCollection to a one-dimensional Level array.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void CopyTo(
    Level[] array
)
public virtual void CopyTo(
    Level[] array
)
Public Overridable Sub CopyTo (
    array As Level()
)
Public Overridable Sub CopyTo (
    array As Level()
)
public:
virtual void CopyTo(
    array<Level^>^ array
)
public:
virtual void CopyTo(
    array<Level^>^ array
)
Parameters
array
Type:  log4net.Core Level
The one-dimensional Level array to copy to.
See Also
LevelCollection Class
LevelCollection Members
CopyTo Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.CopyTo Method (Level[], Int32)

LevelCollection CopyTo Method ( Level , Int32) Apache log4net™ SDK Documentation
Copies the entire LevelCollection to a one-dimensional Level array, starting at the specified index of the target array.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void CopyTo(
    Level[] array,
    int start
)
public virtual void CopyTo(
    Level[] array,
    int start
)
Public Overridable Sub CopyTo (
    array As Level(),
    start As Integer
)
Public Overridable Sub CopyTo (
    array As Level(),
    start As Integer
)
public:
virtual void CopyTo(
    array<Level^>^ array,
    int start
)
public:
virtual void CopyTo(
    array<Level^>^ array,
    int start
)
Parameters
array
Type:  log4net.Core Level
The one-dimensional Level array to copy to.
start
Type:   Online System Int32
The zero-based index in array at which copying begins.
See Also
LevelCollection Class
LevelCollection Members
CopyTo Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.GetEnumerator Method

LevelCollection GetEnumerator Method Apache log4net™ SDK Documentation
Returns an enumerator that can iterate through the LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual LevelCollection..::..ILevelCollectionEnumerator GetEnumerator()
public virtual LevelCollection..::..ILevelCollectionEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As LevelCollection..::..ILevelCollectionEnumerator
Public Overridable Function GetEnumerator As LevelCollection..::..ILevelCollectionEnumerator
public:
virtual LevelCollection..::..ILevelCollectionEnumerator^ GetEnumerator()
public:
virtual LevelCollection..::..ILevelCollectionEnumerator^ GetEnumerator()
Return Value
Type: LevelCollection ILevelCollectionEnumerator
An Enumerator for the entire LevelCollection.
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.IndexOf Method

LevelCollection IndexOf Method Apache log4net™ SDK Documentation
Returns the zero-based index of the first occurrence of a Level in the LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int IndexOf(
    Level item
)
public virtual int IndexOf(
    Level item
)
Public Overridable Function IndexOf (
    item As Level
) As Integer
Public Overridable Function IndexOf (
    item As Level
) As Integer
public:
virtual int IndexOf(
    Level^ item
)
public:
virtual int IndexOf(
    Level^ item
)
Parameters
item
Type: log4net.Core Level
The Level to locate in the LevelCollection.
Return Value
Type:   Online Int32

            The zero-based index of the first occurrence of item
            in the entire LevelCollection, if found; otherwise, -1.

See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.Insert Method

LevelCollection Insert Method Apache log4net™ SDK Documentation
Inserts an element into the LevelCollection at the specified index.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Insert(
    int index,
    Level item
)
public virtual void Insert(
    int index,
    Level item
)
Public Overridable Sub Insert (
    index As Integer,
    item As Level
)
Public Overridable Sub Insert (
    index As Integer,
    item As Level
)
public:
virtual void Insert(
    int index,
    Level^ item
)
public:
virtual void Insert(
    int index,
    Level^ item
)
Parameters
index
Type:   Online System Int32
The zero-based index at which item should be inserted.
item
Type: log4net.Core Level
The Level to insert.
Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.ReadOnly Method

LevelCollection ReadOnly Method Apache log4net™ SDK Documentation
Creates a read-only wrapper for a LevelCollection instance.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static LevelCollection ReadOnly(
    LevelCollection list
)
public static LevelCollection ReadOnly(
    LevelCollection list
)
Public Shared Function ReadOnly (
    list As LevelCollection
) As LevelCollection
Public Shared Function ReadOnly (
    list As LevelCollection
) As LevelCollection
public:
static LevelCollection^ ReadOnly(
    LevelCollection^ list
)
public:
static LevelCollection^ ReadOnly(
    LevelCollection^ list
)
Parameters
list
Type: log4net.Core LevelCollection
list to create a readonly wrapper arround
Return Value
Type: LevelCollection

            A LevelCollection wrapper that is read-only.

See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.Remove Method

LevelCollection Remove Method Apache log4net™ SDK Documentation
Removes the first occurrence of a specific Level from the LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Remove(
    Level item
)
public virtual void Remove(
    Level item
)
Public Overridable Sub Remove (
    item As Level
)
Public Overridable Sub Remove (
    item As Level
)
public:
virtual void Remove(
    Level^ item
)
public:
virtual void Remove(
    Level^ item
)
Parameters
item
Type: log4net.Core Level
The Level to remove from the LevelCollection.
Exceptions
Exception | Condition
Online System ArgumentException | The specified Level was not found in the LevelCollection.
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.RemoveAt Method

LevelCollection RemoveAt Method Apache log4net™ SDK Documentation
Removes the element at the specified index of the LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void RemoveAt(
    int index
)
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)
Public Overridable Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
)
public:
virtual void RemoveAt(
    int index
)
Parameters
index
Type:   Online System Int32
The zero-based index of the element to remove.
Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.TrimToSize Method

LevelCollection TrimToSize Method Apache log4net™ SDK Documentation
Sets the capacity to the actual number of elements.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void TrimToSize()
public virtual void TrimToSize()
Public Overridable Sub TrimToSize
Public Overridable Sub TrimToSize
public:
virtual void TrimToSize()
public:
virtual void TrimToSize()
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection Properties

LevelCollection Properties Apache log4net™ SDK Documentation
The LevelCollection type exposes the following members.
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements the LevelCollection can contain.
Public property | Count | Gets the number of elements actually contained in the LevelCollection.
Public property | IsFixedSize | Gets a value indicating whether the collection has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public property | Item | Gets or sets the Level at the specified index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Back to Top
See Also
LevelCollection Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.Capacity Property

LevelCollection Capacity Property Apache log4net™ SDK Documentation
Gets or sets the number of elements the LevelCollection can contain.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Capacity { get; set; }
public virtual int Capacity { get; set; }
Public Overridable Property Capacity As Integer
    Get
    Set
Public Overridable Property Capacity As Integer
    Get
    Set
public:
virtual property int Capacity {
    int get ();
    void set (int value);
}
public:
virtual property int Capacity {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.Count Property

LevelCollection Count Property Apache log4net™ SDK Documentation
Gets the number of elements actually contained in the LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Count { get; }
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
public:
virtual property int Count {
    int get ();
}
Property Value
Type:   Online Int32
Implements
  Online ICollection Count
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.IsFixedSize Property

LevelCollection IsFixedSize Property Apache log4net™ SDK Documentation
Gets a value indicating whether the collection has a fixed size.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsFixedSize { get; }
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}
public:
virtual property bool IsFixedSize {
    bool get ();
}
Property Value
Type:   Online Boolean
true if the collection has a fixed size; otherwise, false. The default is false
Implements
  Online IList IsFixedSize
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.IsReadOnly Property

LevelCollection IsReadOnly Property Apache log4net™ SDK Documentation
Gets a value indicating whether the IList is read-only.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsReadOnly { get; }
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}
public:
virtual property bool IsReadOnly {
    bool get ();
}
Property Value
Type:   Online Boolean
true if the collection is read-only; otherwise, false. The default is false
Implements
  Online IList IsReadOnly
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.IsSynchronized Property

LevelCollection IsSynchronized Property Apache log4net™ SDK Documentation
Gets a value indicating whether access to the collection is synchronized (thread-safe).

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsSynchronized { get; }
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}
public:
virtual property bool IsSynchronized {
    bool get ();
}
Property Value
Type:   Online Boolean
true if access to the ICollection is synchronized (thread-safe); otherwise, false.
Implements
  Online ICollection IsSynchronized
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.Item Property

LevelCollection Item Property Apache log4net™ SDK Documentation
Gets or sets the Level at the specified index.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Level this[
    int index
] { get; set; }
public virtual Level this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As Level
    Get
    Set
Public Overridable Default Property Item (
    index As Integer
) As Level
    Get
    Set
public:
virtual property Level^ default[int index] {
    Level^ get (int index);
    void set (int index, Level^ value);
}
public:
virtual property Level^ default[int index] {
    Level^ get (int index);
    void set (int index, Level^ value);
}
Parameters
index
Type:   Online System Int32
The zero-based index of the element to get or set.
Property Value
Type: Level
Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.SyncRoot Property

LevelCollection SyncRoot Property Apache log4net™ SDK Documentation
Gets an object that can be used to synchronize access to the collection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object SyncRoot { get; }
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}
Property Value
Type:   Online Object
Implements
  Online ICollection SyncRoot
See Also
LevelCollection Class
LevelCollection Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.ILevelCollectionEnumerator Interface

LevelCollection ILevelCollectionEnumerator Interface Apache log4net™ SDK Documentation
Supports type-safe iteration over a LevelCollection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILevelCollectionEnumerator
public interface ILevelCollectionEnumerator
Public Interface ILevelCollectionEnumerator
Public Interface ILevelCollectionEnumerator
public interface class ILevelCollectionEnumerator
public interface class ILevelCollectionEnumerator
See Also
LevelCollection ILevelCollectionEnumerator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.ILevelCollectionEnumerator Members

LevelCollection ILevelCollectionEnumerator Members Apache log4net™ SDK Documentation
The LevelCollection ILevelCollectionEnumerator type exposes the following members.
Methods
 | Name | Description
Public method | MoveNext | Advances the enumerator to the next element in the collection.
Public method | Reset | Sets the enumerator to its initial position, before the first element in the collection.
Back to Top
Properties
 | Name | Description
Public property | Current | Gets the current element in the collection.
Back to Top
See Also
LevelCollection ILevelCollectionEnumerator Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.ILevelCollectionEnumerator Methods

LevelCollection ILevelCollectionEnumerator Methods Apache log4net™ SDK Documentation
The LevelCollection ILevelCollectionEnumerator type exposes the following members.
Methods
 | Name | Description
Public method | MoveNext | Advances the enumerator to the next element in the collection.
Public method | Reset | Sets the enumerator to its initial position, before the first element in the collection.
Back to Top
See Also
LevelCollection ILevelCollectionEnumerator Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.ILevelCollectionEnumerator.MoveNext Method

LevelCollection ILevelCollectionEnumerator MoveNext Method Apache log4net™ SDK Documentation
Advances the enumerator to the next element in the collection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool MoveNext()
bool MoveNext()
Function MoveNext As Boolean
Function MoveNext As Boolean
bool MoveNext()
bool MoveNext()
Return Value
Type:   Online Boolean
true if the enumerator was successfully advanced to the next element;
            false if the enumerator has passed the end of the collection.

Exceptions
Exception | Condition
Online System InvalidOperationException | The collection was modified after the enumerator was created.
See Also
LevelCollection ILevelCollectionEnumerator Interface
LevelCollection ILevelCollectionEnumerator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.ILevelCollectionEnumerator.Reset Method

LevelCollection ILevelCollectionEnumerator Reset Method Apache log4net™ SDK Documentation
Sets the enumerator to its initial position, before the first element in the collection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Reset()
void Reset()
Sub Reset
Sub Reset
void Reset()
void Reset()
See Also
LevelCollection ILevelCollectionEnumerator Interface
LevelCollection ILevelCollectionEnumerator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.ILevelCollectionEnumerator Properties

LevelCollection ILevelCollectionEnumerator Properties Apache log4net™ SDK Documentation
The LevelCollection ILevelCollectionEnumerator type exposes the following members.
Properties
 | Name | Description
Public property | Current | Gets the current element in the collection.
Back to Top
See Also
LevelCollection ILevelCollectionEnumerator Interface
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.ILevelCollectionEnumerator.Current Property

LevelCollection ILevelCollectionEnumerator Current Property Apache log4net™ SDK Documentation
Gets the current element in the collection.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Level Current { get; }
Level Current { get; }
ReadOnly Property Current As Level
    Get
ReadOnly Property Current As Level
    Get
property Level^ Current {
    Level^ get ();
}
property Level^ Current {
    Level^ get ();
}
Property Value
Type: Level
See Also
LevelCollection ILevelCollectionEnumerator Interface
LevelCollection ILevelCollectionEnumerator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelCollection.Tag Enumeration

LevelCollection Tag Enumeration Apache log4net™ SDK Documentation
Type visible only to our subclasses Used to access protected constructor

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal enum Tag
protected internal enum Tag
Protected Friend Enumeration Tag
Protected Friend Enumeration Tag
protected public enum class Tag
protected public enum class Tag
Members
Member name | Value | Description
Default | 0 | A value
See Also
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelEvaluator Class

LevelEvaluator Class Apache log4net™ SDK Documentation
An evaluator that triggers at a threshold level
Inheritance Hierarchy
Online System Object
log4net.Core LevelEvaluator

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LevelEvaluator : ITriggeringEventEvaluator
public class LevelEvaluator : ITriggeringEventEvaluator
Public Class LevelEvaluator
    Implements ITriggeringEventEvaluator
Public Class LevelEvaluator
    Implements ITriggeringEventEvaluator
public ref class LevelEvaluator : ITriggeringEventEvaluator
public ref class LevelEvaluator : ITriggeringEventEvaluator
Remarks

            This evaluator will trigger if the level of the event
            passed to [M:IsTriggeringEvent(LoggingEvent)]
            is equal to or greater than the Threshold
            level.

See Also
LevelEvaluator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelEvaluator Members

LevelEvaluator Members Apache log4net™ SDK Documentation
The LevelEvaluator type exposes the following members.
Constructors
 | Name | Description
Public method | LevelEvaluator | Create a new evaluator using the Off threshold.
Public method | LevelEvaluator(Level) | Create a new evaluator using the specified Level threshold.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsTriggeringEvent | Is this loggingEvent the triggering event?
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Threshold | the threshold to trigger at
Back to Top
See Also
LevelEvaluator Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelEvaluator Constructor

LevelEvaluator Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | LevelEvaluator | Create a new evaluator using the Off threshold.
Public method | LevelEvaluator(Level) | Create a new evaluator using the specified Level threshold.
Back to Top
See Also
LevelEvaluator Class
LevelEvaluator Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelEvaluator Constructor

LevelEvaluator Constructor Apache log4net™ SDK Documentation
Create a new evaluator using the Off threshold.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelEvaluator()
public LevelEvaluator()
Public Sub New
Public Sub New
public:
LevelEvaluator()
public:
LevelEvaluator()
Remarks

            Create a new evaluator using the Off threshold.

            This evaluator will trigger if the level of the event
            passed to [M:IsTriggeringEvent(LoggingEvent)]
            is equal to or greater than the Threshold
            level.

See Also
LevelEvaluator Class
LevelEvaluator Members
LevelEvaluator Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelEvaluator Constructor (Level)

LevelEvaluator Constructor (Level) Apache log4net™ SDK Documentation
Create a new evaluator using the specified Level threshold.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelEvaluator(
    Level threshold
)
public LevelEvaluator(
    Level threshold
)
Public Sub New (
    threshold As Level
)
Public Sub New (
    threshold As Level
)
public:
LevelEvaluator(
    Level^ threshold
)
public:
LevelEvaluator(
    Level^ threshold
)
Parameters
threshold
Type: log4net.Core Level
the threshold to trigger at
Remarks

            Create a new evaluator using the specified Level threshold.

            This evaluator will trigger if the level of the event
            passed to [M:IsTriggeringEvent(LoggingEvent)]
            is equal to or greater than the Threshold
            level.

See Also
LevelEvaluator Class
LevelEvaluator Members
LevelEvaluator Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelEvaluator Methods

LevelEvaluator Methods Apache log4net™ SDK Documentation
The LevelEvaluator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsTriggeringEvent | Is this loggingEvent the triggering event?
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LevelEvaluator Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelEvaluator.IsTriggeringEvent Method

LevelEvaluator IsTriggeringEvent Method Apache log4net™ SDK Documentation
Is this loggingEvent the triggering event?

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsTriggeringEvent(
    LoggingEvent loggingEvent
)
public bool IsTriggeringEvent(
    LoggingEvent loggingEvent
)
Public Function IsTriggeringEvent (
    loggingEvent As LoggingEvent
) As Boolean
Public Function IsTriggeringEvent (
    loggingEvent As LoggingEvent
) As Boolean
public:
virtual bool IsTriggeringEvent(
    LoggingEvent^ loggingEvent
) sealed
public:
virtual bool IsTriggeringEvent(
    LoggingEvent^ loggingEvent
) sealed
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to check
Return Value
Type:   Online Boolean
This method returns true, if the event level
            is equal or higher than the Threshold.
            Otherwise it returns false
Implements
ITriggeringEventEvaluator IsTriggeringEvent(LoggingEvent)
Remarks

            This evaluator will trigger if the level of the event
            passed to [M:IsTriggeringEvent(LoggingEvent)]
            is equal to or greater than the Threshold
            level.

See Also
LevelEvaluator Class
LevelEvaluator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelEvaluator Properties

LevelEvaluator Properties Apache log4net™ SDK Documentation
The LevelEvaluator type exposes the following members.
Properties
 | Name | Description
Public property | Threshold | the threshold to trigger at
Back to Top
See Also
LevelEvaluator Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelEvaluator.Threshold Property

LevelEvaluator Threshold Property Apache log4net™ SDK Documentation
the threshold to trigger at

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level Threshold { get; set; }
public Level Threshold { get; set; }
Public Property Threshold As Level
    Get
    Set
Public Property Threshold As Level
    Get
    Set
public:
property Level^ Threshold {
    Level^ get ();
    void set (Level^ value);
}
public:
property Level^ Threshold {
    Level^ get ();
    void set (Level^ value);
}
Property Value
Type: Level

            The Level that will cause this evaluator to trigger

Remarks

            This evaluator will trigger if the level of the event
            passed to [M:IsTriggeringEvent(LoggingEvent)]
            is equal to or greater than the Threshold
            level.

See Also
LevelEvaluator Class
LevelEvaluator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap Class

LevelMap Class Apache log4net™ SDK Documentation
Mapping between string name and Level object
Inheritance Hierarchy
Online System Object
log4net.Core LevelMap

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LevelMap
public sealed class LevelMap
Public NotInheritable Class LevelMap
Public NotInheritable Class LevelMap
public ref class LevelMap sealed
public ref class LevelMap sealed
Remarks

            Mapping between string name and Level object.
            This mapping is held separately for each ILoggerRepository.
            The level name is case insensitive.

See Also
LevelMap Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap Members

LevelMap Members Apache log4net™ SDK Documentation
The LevelMap type exposes the following members.
Constructors
 | Name | Description
Public method | LevelMap | Construct the level map
Back to Top
Methods
 | Name | Description
Public method | Add(Level) | Add a Level to the map
Public method | Add(String, Int32) | Create a new Level and add it to the map
Public method | Add(String, Int32, String) | Create a new Level and add it to the map
Public method | Clear | Clear the internal maps of all levels
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LookupWithDefault | Lookup a named level from the map
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AllLevels | Return all possible levels as a list of Level objects.
Public property | Item | Lookup a Level by name
Back to Top
See Also
LevelMap Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap Constructor

LevelMap Constructor Apache log4net™ SDK Documentation
Construct the level map

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelMap()
public LevelMap()
Public Sub New
Public Sub New
public:
LevelMap()
public:
LevelMap()
Remarks

            Construct the level map.

See Also
LevelMap Class
LevelMap Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap Methods

LevelMap Methods Apache log4net™ SDK Documentation
The LevelMap type exposes the following members.
Methods
 | Name | Description
Public method | Add(Level) | Add a Level to the map
Public method | Add(String, Int32) | Create a new Level and add it to the map
Public method | Add(String, Int32, String) | Create a new Level and add it to the map
Public method | Clear | Clear the internal maps of all levels
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LookupWithDefault | Lookup a named level from the map
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LevelMap Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap.Add Method

LevelMap Add Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Add(Level) | Add a Level to the map
Public method | Add(String, Int32) | Create a new Level and add it to the map
Public method | Add(String, Int32, String) | Create a new Level and add it to the map
Back to Top
See Also
LevelMap Class
LevelMap Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap.Add Method (Level)

LevelMap Add Method (Level) Apache log4net™ SDK Documentation
Add a Level to the map

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    Level level
)
public void Add(
    Level level
)
Public Sub Add (
    level As Level
)
Public Sub Add (
    level As Level
)
public:
void Add(
    Level^ level
)
public:
void Add(
    Level^ level
)
Parameters
level
Type: log4net.Core Level
the Level to add
Remarks

            Add a Level to the map

See Also
LevelMap Class
LevelMap Members
Add Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap.Add Method (String, Int32)

LevelMap Add Method (String, Int32) Apache log4net™ SDK Documentation
Create a new Level and add it to the map

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    string name,
    int value
)
public void Add(
    string name,
    int value
)
Public Sub Add (
    name As String,
    value As Integer
)
Public Sub Add (
    name As String,
    value As Integer
)
public:
void Add(
    String^ name,
    int value
)
public:
void Add(
    String^ name,
    int value
)
Parameters
name
Type:   Online System String
the string to display for the Level
value
Type:   Online System Int32
the level value to give to the Level
Remarks

            Create a new Level and add it to the map

See Also
LevelMap Class
LevelMap Members
Add Overload
log4net.Core Namespace
[M:Add(string,int,string)]
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap.Add Method (String, Int32, String)

LevelMap Add Method (String, Int32, String) Apache log4net™ SDK Documentation
Create a new Level and add it to the map

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    string name,
    int value,
    string displayName
)
public void Add(
    string name,
    int value,
    string displayName
)
Public Sub Add (
    name As String,
    value As Integer,
    displayName As String
)
Public Sub Add (
    name As String,
    value As Integer,
    displayName As String
)
public:
void Add(
    String^ name,
    int value,
    String^ displayName
)
public:
void Add(
    String^ name,
    int value,
    String^ displayName
)
Parameters
name
Type:   Online System String
the string to display for the Level
value
Type:   Online System Int32
the level value to give to the Level
displayName
Type:   Online System String
the display name to give to the Level
Remarks

            Create a new Level and add it to the map

See Also
LevelMap Class
LevelMap Members
Add Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap.Clear Method

LevelMap Clear Method Apache log4net™ SDK Documentation
Clear the internal maps of all levels

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
Remarks

            Clear the internal maps of all levels

See Also
LevelMap Class
LevelMap Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap.LookupWithDefault Method

LevelMap LookupWithDefault Method Apache log4net™ SDK Documentation
Lookup a named level from the map

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level LookupWithDefault(
    Level defaultLevel
)
public Level LookupWithDefault(
    Level defaultLevel
)
Public Function LookupWithDefault (
    defaultLevel As Level
) As Level
Public Function LookupWithDefault (
    defaultLevel As Level
) As Level
public:
Level^ LookupWithDefault(
    Level^ defaultLevel
)
public:
Level^ LookupWithDefault(
    Level^ defaultLevel
)
Parameters
defaultLevel
Type: log4net.Core Level
the name of the level to lookup is taken from this level.
            If the level is not set on the map then this level is added
Return Value
Type: Level
the level in the map with the name specified
Remarks

            Lookup a named level from the map. The name of the level to lookup is taken
            from the Name property of the defaultLevel
            argument.

            If no level with the specified name is found then the
            defaultLevel argument is added to the level map
            and returned.

See Also
LevelMap Class
LevelMap Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap Properties

LevelMap Properties Apache log4net™ SDK Documentation
The LevelMap type exposes the following members.
Properties
 | Name | Description
Public property | AllLevels | Return all possible levels as a list of Level objects.
Public property | Item | Lookup a Level by name
Back to Top
See Also
LevelMap Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap.AllLevels Property

LevelMap AllLevels Property Apache log4net™ SDK Documentation
Return all possible levels as a list of Level objects.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelCollection AllLevels { get; }
public LevelCollection AllLevels { get; }
Public ReadOnly Property AllLevels As LevelCollection
    Get
Public ReadOnly Property AllLevels As LevelCollection
    Get
public:
property LevelCollection^ AllLevels {
    LevelCollection^ get ();
}
public:
property LevelCollection^ AllLevels {
    LevelCollection^ get ();
}
Return Value
Type: LevelCollection
all possible levels as a list of Level objects
Remarks

            Return all possible levels as a list of Level objects.

See Also
LevelMap Class
LevelMap Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMap.Item Property

LevelMap Item Property Apache log4net™ SDK Documentation
Lookup a Level by name

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level this[
    string name
] { get; }
public Level this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As Level
    Get
Public ReadOnly Default Property Item (
    name As String
) As Level
    Get
public:
property Level^ default[String^ name] {
    Level^ get (String^ name);
}
public:
property Level^ default[String^ name] {
    Level^ get (String^ name);
}
Parameters
name
Type:   Online System String
The name of the Level to lookup
Return Value
Type: Level
a Level from the map with the name specified
Remarks

            Returns the Level from the
            map with the name specified. If the no level is
            found then null is returned.

See Also
LevelMap Class
LevelMap Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo Class

LocationInfo Class Apache log4net™ SDK Documentation
The internal representation of caller location information.
Inheritance Hierarchy
Online System Object
log4net.Core LocationInfo

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class LocationInfo
[SerializableAttribute]
public class LocationInfo
<SerializableAttribute>
Public Class LocationInfo
<SerializableAttribute>
Public Class LocationInfo
[SerializableAttribute]
public ref class LocationInfo
[SerializableAttribute]
public ref class LocationInfo
Remarks

            This class uses the System.Diagnostics.StackTrace class to generate
            a call stack. The caller's information is then extracted from this stack.

            The System.Diagnostics.StackTrace class is not supported on the
            .NET Compact Framework 1.0 therefore caller location information is not
            available on that framework.

            The System.Diagnostics.StackTrace class has this to say about Release builds:

            "StackTrace information will be most informative with Debug build configurations.
            By default, Debug builds include debug symbols, while Release builds do not. The
            debug symbols contain most of the file, method name, line number, and column
            information used in constructing StackFrame and StackTrace objects. StackTrace
            might not report as many method calls as expected, due to code transformations
            that occur during optimization."

            This means that in a Release build the caller information may be incomplete or may
            not exist at all! Therefore caller location information cannot be relied upon in a Release build.

See Also
LocationInfo Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo Members

LocationInfo Members Apache log4net™ SDK Documentation
The LocationInfo type exposes the following members.
Constructors
 | Name | Description
Public method | LocationInfo(Type) | Constructor
Public method | LocationInfo(String, String, String, String) | Constructor
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ClassName | Gets the fully qualified class name of the caller making the logging request.
Public property | FileName | Gets the file name of the caller.
Public property | FullInfo | Gets all available caller information
Public property | LineNumber | Gets the line number of the caller.
Public property | MethodName | Gets the method name of the caller.
Public property | StackFrames | Gets the stack frames from the stack trace of the caller making the log request
Back to Top
See Also
LocationInfo Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo Constructor

LocationInfo Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | LocationInfo(Type) | Constructor
Public method | LocationInfo(String, String, String, String) | Constructor
Back to Top
See Also
LocationInfo Class
LocationInfo Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo Constructor (Type)

LocationInfo Constructor (Type) Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocationInfo(
    Type callerStackBoundaryDeclaringType
)
public LocationInfo(
    Type callerStackBoundaryDeclaringType
)
Public Sub New (
    callerStackBoundaryDeclaringType As Type
)
Public Sub New (
    callerStackBoundaryDeclaringType As Type
)
public:
LocationInfo(
    Type^ callerStackBoundaryDeclaringType
)
public:
LocationInfo(
    Type^ callerStackBoundaryDeclaringType
)
Parameters
callerStackBoundaryDeclaringType
Type:   Online System Type
The declaring type of the method that is
            the stack boundary into the logging system for this call.
Remarks

            Initializes a new instance of the LocationInfo
            class based on the current thread.

See Also
LocationInfo Class
LocationInfo Members
LocationInfo Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo Constructor (String, String, String, String)

LocationInfo Constructor (String, String, String, String) Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocationInfo(
    string className,
    string methodName,
    string fileName,
    string lineNumber
)
public LocationInfo(
    string className,
    string methodName,
    string fileName,
    string lineNumber
)
Public Sub New (
    className As String,
    methodName As String,
    fileName As String,
    lineNumber As String
)
Public Sub New (
    className As String,
    methodName As String,
    fileName As String,
    lineNumber As String
)
public:
LocationInfo(
    String^ className,
    String^ methodName,
    String^ fileName,
    String^ lineNumber
)
public:
LocationInfo(
    String^ className,
    String^ methodName,
    String^ fileName,
    String^ lineNumber
)
Parameters
className
Type:   Online System String
The fully qualified class name.
methodName
Type:   Online System String
The method name.
fileName
Type:   Online System String
The file name.
lineNumber
Type:   Online System String
The line number of the method within the file.
Remarks

            Initializes a new instance of the LocationInfo
            class with the specified data.

See Also
LocationInfo Class
LocationInfo Members
LocationInfo Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo Methods

LocationInfo Methods Apache log4net™ SDK Documentation
The LocationInfo type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LocationInfo Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo Properties

LocationInfo Properties Apache log4net™ SDK Documentation
The LocationInfo type exposes the following members.
Properties
 | Name | Description
Public property | ClassName | Gets the fully qualified class name of the caller making the logging request.
Public property | FileName | Gets the file name of the caller.
Public property | FullInfo | Gets all available caller information
Public property | LineNumber | Gets the line number of the caller.
Public property | MethodName | Gets the method name of the caller.
Public property | StackFrames | Gets the stack frames from the stack trace of the caller making the log request
Back to Top
See Also
LocationInfo Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo.ClassName Property

LocationInfo ClassName Property Apache log4net™ SDK Documentation
Gets the fully qualified class name of the caller making the logging request.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ClassName { get; }
public string ClassName { get; }
Public ReadOnly Property ClassName As String
    Get
Public ReadOnly Property ClassName As String
    Get
public:
property String^ ClassName {
    String^ get ();
}
public:
property String^ ClassName {
    String^ get ();
}
Property Value
Type:   Online String

            The fully qualified class name of the caller making the logging
            request.

Remarks

            Gets the fully qualified class name of the caller making the logging
            request.

See Also
LocationInfo Class
LocationInfo Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo.FileName Property

LocationInfo FileName Property Apache log4net™ SDK Documentation
Gets the file name of the caller.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FileName { get; }
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
public:
property String^ FileName {
    String^ get ();
}
Property Value
Type:   Online String

            The file name of the caller.

Remarks

            Gets the file name of the caller.

See Also
LocationInfo Class
LocationInfo Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo.FullInfo Property

LocationInfo FullInfo Property Apache log4net™ SDK Documentation
Gets all available caller information

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FullInfo { get; }
public string FullInfo { get; }
Public ReadOnly Property FullInfo As String
    Get
Public ReadOnly Property FullInfo As String
    Get
public:
property String^ FullInfo {
    String^ get ();
}
public:
property String^ FullInfo {
    String^ get ();
}
Property Value
Type:   Online String

            All available caller information, in the format
            fully.qualified.classname.of.caller.methodName(Filename:line)
Remarks

            Gets all available caller information, in the format
            fully.qualified.classname.of.caller.methodName(Filename:line)
See Also
LocationInfo Class
LocationInfo Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo.LineNumber Property

LocationInfo LineNumber Property Apache log4net™ SDK Documentation
Gets the line number of the caller.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LineNumber { get; }
public string LineNumber { get; }
Public ReadOnly Property LineNumber As String
    Get
Public ReadOnly Property LineNumber As String
    Get
public:
property String^ LineNumber {
    String^ get ();
}
public:
property String^ LineNumber {
    String^ get ();
}
Property Value
Type:   Online String

            The line number of the caller.

Remarks

            Gets the line number of the caller.

See Also
LocationInfo Class
LocationInfo Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo.MethodName Property

LocationInfo MethodName Property Apache log4net™ SDK Documentation
Gets the method name of the caller.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MethodName { get; }
public string MethodName { get; }
Public ReadOnly Property MethodName As String
    Get
Public ReadOnly Property MethodName As String
    Get
public:
property String^ MethodName {
    String^ get ();
}
public:
property String^ MethodName {
    String^ get ();
}
Property Value
Type:   Online String

            The method name of the caller.

Remarks

            Gets the method name of the caller.

See Also
LocationInfo Class
LocationInfo Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LocationInfo.StackFrames Property

LocationInfo StackFrames Property Apache log4net™ SDK Documentation
Gets the stack frames from the stack trace of the caller making the log request

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StackFrameItem[] StackFrames { get; }
public StackFrameItem[] StackFrames { get; }
Public ReadOnly Property StackFrames As StackFrameItem()
    Get
Public ReadOnly Property StackFrames As StackFrameItem()
    Get
public:
property array<StackFrameItem^>^ StackFrames {
    array<StackFrameItem^>^ get ();
}
public:
property array<StackFrameItem^>^ StackFrames {
    array<StackFrameItem^>^ get ();
}
Property Value
Type:  StackFrameItem
See Also
LocationInfo Class
LocationInfo Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogException Class

LogException Class Apache log4net™ SDK Documentation
Exception base type for log4net.
Inheritance Hierarchy
Online System Object
Online System Exception
Online System ApplicationException
log4net.Core LogException

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class LogException : ApplicationException
[SerializableAttribute]
public class LogException : ApplicationException
<SerializableAttribute>
Public Class LogException
    Inherits ApplicationException
<SerializableAttribute>
Public Class LogException
    Inherits ApplicationException
[SerializableAttribute]
public ref class LogException : public ApplicationException
[SerializableAttribute]
public ref class LogException : public ApplicationException
Remarks

            This type extends   Online ApplicationException. It
            does not add any new functionality but does differentiate the
            type of exception being thrown.

See Also
LogException Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogException Members

LogException Members Apache log4net™ SDK Documentation
The LogException type exposes the following members.
Constructors
 | Name | Description
Public method | LogException | Constructor
Public method | LogException(String) | Constructor
Protected method | LogException(SerializationInfo, StreamingContext) | Serialization constructor
Public method | LogException(String, Exception) | Constructor
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
LogException Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogException Constructor

LogException Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | LogException | Constructor
Public method | LogException(String) | Constructor
Protected method | LogException(SerializationInfo, StreamingContext) | Serialization constructor
Public method | LogException(String, Exception) | Constructor
Back to Top
See Also
LogException Class
LogException Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogException Constructor

LogException Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogException()
public LogException()
Public Sub New
Public Sub New
public:
LogException()
public:
LogException()
Remarks

            Initializes a new instance of the LogException class.

See Also
LogException Class
LogException Members
LogException Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogException Constructor (String)

LogException Constructor (String) Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogException(
    string message
)
public LogException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
LogException(
    String^ message
)
public:
LogException(
    String^ message
)
Parameters
message
Type:   Online System String
A message to include with the exception.
Remarks

            Initializes a new instance of the LogException class with
            the specified message.

See Also
LogException Class
LogException Members
LogException Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogException Constructor (SerializationInfo, StreamingContext)

LogException Constructor (SerializationInfo, StreamingContext) Apache log4net™ SDK Documentation
Serialization constructor

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LogException(
    SerializationInfo info,
    StreamingContext context
)
protected LogException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
LogException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
LogException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The   Online SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type:   Online System.Runtime.Serialization StreamingContext
The   Online StreamingContext that contains contextual information about the source or destination.
Remarks

            Initializes a new instance of the LogException class
            with serialized data.

See Also
LogException Class
LogException Members
LogException Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogException Constructor (String, Exception)

LogException Constructor (String, Exception) Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogException(
    string message,
    Exception innerException
)
public LogException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
Public Sub New (
    message As String,
    innerException As Exception
)
public:
LogException(
    String^ message,
    Exception^ innerException
)
public:
LogException(
    String^ message,
    Exception^ innerException
)
Parameters
message
Type:   Online System String
A message to include with the exception.
innerException
Type:   Online System Exception
A nested exception to include.
Remarks

            Initializes a new instance of the LogException class
            with the specified message and inner exception.

See Also
LogException Class
LogException Members
LogException Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogException Methods

LogException Methods Apache log4net™ SDK Documentation
The LogException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
LogException Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogException Properties

LogException Properties Apache log4net™ SDK Documentation
The LogException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
LogException Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager Class

LoggerManager Class Apache log4net™ SDK Documentation
Static manager that controls the creation of repositories
Inheritance Hierarchy
Online System Object
log4net.Core LoggerManager

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LoggerManager
public sealed class LoggerManager
Public NotInheritable Class LoggerManager
Public NotInheritable Class LoggerManager
public ref class LoggerManager sealed
public ref class LoggerManager sealed
Remarks

            Static manager that controls the creation of repositories

            This class is used by the wrapper managers (e.g. LogManager)
            to provide access to the ILogger objects.

            This manager also holds the IRepositorySelector that is used to
            lookup and create repositories. The selector can be set either programmatically using
            the RepositorySelector property, or by setting the log4net.RepositorySelector
            AppSetting in the applications config file to the fully qualified type name of the
            selector to use.

See Also
LoggerManager Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager Members

LoggerManager Members Apache log4net™ SDK Documentation
The LoggerManager type exposes the following members.
Methods
 | Name | Description
 | CreateDomain(String) | Obsolete. Creates a repository with the specified name.
 | CreateDomain(Assembly, Type) | Obsolete. Creates a repository for the specified assembly and repository type.
 | CreateDomain(String, Type) | Obsolete. Creates a repository with the specified name and repository type.
 | CreateRepository(String) | Creates a repository with the specified name.
 | CreateRepository(Assembly, Type) | Creates a repository for the specified assembly and repository type.
 | CreateRepository(String, Type) | Creates a repository with the specified name and repository type.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | Exists(Assembly, String) | Returns the named logger if it exists.
 | Exists(String, String) | Returns the named logger if it exists.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetAllRepositories | Gets an array of all currently defined repositories.
 | GetCurrentLoggers(Assembly) | Returns all the currently defined loggers in the specified assembly's repository.
 | GetCurrentLoggers(String) | Returns all the currently defined loggers in the specified repository.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetLogger(Assembly, String) | Retrieves or creates a named logger.
 | GetLogger(Assembly, Type) | Shorthand for GetLogger(string).
 | GetLogger(String, String) | Retrieves or creates a named logger.
 | GetLogger(String, Type) | Shorthand for GetLogger(string).
 | GetLoggerRepository(Assembly) | Obsolete. Returns the default ILoggerRepository instance.
 | GetLoggerRepository(String) | Obsolete. Return the default ILoggerRepository instance.
 | GetRepository(Assembly) | Returns the default ILoggerRepository instance.
 | GetRepository(String) | Return the default ILoggerRepository instance.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ResetConfiguration(Assembly) | Resets all values contained in this repository instance to their defaults.
 | ResetConfiguration(String) | Resets all values contained in this repository instance to their defaults.
 | Shutdown | Shuts down the log4net system.
 | ShutdownRepository(Assembly) | Shuts down the repository for the repository specified.
 | ShutdownRepository(String) | Shuts down the repository for the repository specified.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
Name | Description
RepositorySelector | Gets or sets the repository selector used by the LogManager.
Back to Top
See Also
LoggerManager Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager Methods

LoggerManager Methods Apache log4net™ SDK Documentation
The LoggerManager type exposes the following members.
Methods
 | Name | Description
 | CreateDomain(String) | Obsolete. Creates a repository with the specified name.
 | CreateDomain(Assembly, Type) | Obsolete. Creates a repository for the specified assembly and repository type.
 | CreateDomain(String, Type) | Obsolete. Creates a repository with the specified name and repository type.
 | CreateRepository(String) | Creates a repository with the specified name.
 | CreateRepository(Assembly, Type) | Creates a repository for the specified assembly and repository type.
 | CreateRepository(String, Type) | Creates a repository with the specified name and repository type.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | Exists(Assembly, String) | Returns the named logger if it exists.
 | Exists(String, String) | Returns the named logger if it exists.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetAllRepositories | Gets an array of all currently defined repositories.
 | GetCurrentLoggers(Assembly) | Returns all the currently defined loggers in the specified assembly's repository.
 | GetCurrentLoggers(String) | Returns all the currently defined loggers in the specified repository.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetLogger(Assembly, String) | Retrieves or creates a named logger.
 | GetLogger(Assembly, Type) | Shorthand for GetLogger(string).
 | GetLogger(String, String) | Retrieves or creates a named logger.
 | GetLogger(String, Type) | Shorthand for GetLogger(string).
 | GetLoggerRepository(Assembly) | Obsolete. Returns the default ILoggerRepository instance.
 | GetLoggerRepository(String) | Obsolete. Return the default ILoggerRepository instance.
 | GetRepository(Assembly) | Returns the default ILoggerRepository instance.
 | GetRepository(String) | Return the default ILoggerRepository instance.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ResetConfiguration(Assembly) | Resets all values contained in this repository instance to their defaults.
 | ResetConfiguration(String) | Resets all values contained in this repository instance to their defaults.
 | Shutdown | Shuts down the log4net system.
 | ShutdownRepository(Assembly) | Shuts down the repository for the repository specified.
 | ShutdownRepository(String) | Shuts down the repository for the repository specified.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LoggerManager Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.CreateDomain Method

LoggerManager CreateDomain Method Apache log4net™ SDK Documentation
Overload List
Name | Description
CreateDomain(String) | Obsolete. Creates a repository with the specified name.
CreateDomain(Assembly, Type) | Obsolete. Creates a repository for the specified assembly and repository type.
CreateDomain(String, Type) | Obsolete. Creates a repository with the specified name and repository type.
Back to Top
See Also
LoggerManager Class
LoggerManager Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.CreateDomain Method (String)

LoggerManager CreateDomain Method (String) Apache log4net™ SDK Documentation
Creates a repository with the specified name.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    string repository
)
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    string repository
)
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repository As String
) As ILoggerRepository
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repository As String
) As ILoggerRepository
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    String^ repository
)
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    String^ repository
)
Parameters
repository
Type:   Online System String
The name of the repository, this must be unique amongst repositories.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Exceptions
Exception | Condition
log4net.Core LogException | The specified repository already exists.
Remarks
CreateDomain is obsolete. Use CreateRepository instead of CreateDomain.

            Creates the default type of ILoggerRepository which is a
            Hierarchy object.

            The repository name must be unique. Repositories cannot be redefined.
            An   Online Exception will be thrown if the repository already exists.

See Also
LoggerManager Class
LoggerManager Members
CreateDomain Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.CreateDomain Method (Assembly, Type)

LoggerManager CreateDomain Method (Assembly, Type) Apache log4net™ SDK Documentation
Creates a repository for the specified assembly and repository type.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    Assembly repositoryAssembly,
    Type repositoryType
)
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    Assembly repositoryAssembly,
    Type repositoryType
)
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repositoryAssembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repositoryAssembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    Assembly^ repositoryAssembly,
    Type^ repositoryType
)
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    Assembly^ repositoryAssembly,
    Type^ repositoryType
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to get the name of the repository.
repositoryType
Type:   Online System Type
A   Online Type that implements ILoggerRepository
            and has a no arg constructor. An instance of this type will be created to act
            as the ILoggerRepository for the repository specified.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Remarks
CreateDomain is obsolete. Use CreateRepository instead of CreateDomain.

            The ILoggerRepository created will be associated with the repository
            specified such that a call to [M:GetRepository(Assembly)] with the
            same assembly specified will return the same repository instance.

See Also
LoggerManager Class
LoggerManager Members
CreateDomain Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.CreateDomain Method (String, Type)

LoggerManager CreateDomain Method (String, Type) Apache log4net™ SDK Documentation
Creates a repository with the specified name and repository type.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    string repository,
    Type repositoryType
)
[ObsoleteAttribute("Use CreateRepository instead of CreateDomain")]
public static ILoggerRepository CreateDomain(
    string repository,
    Type repositoryType
)
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repository As String,
    repositoryType As Type
) As ILoggerRepository
<ObsoleteAttribute("Use CreateRepository instead of CreateDomain")>
Public Shared Function CreateDomain (
    repository As String,
    repositoryType As Type
) As ILoggerRepository
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    String^ repository,
    Type^ repositoryType
)
public:
[ObsoleteAttribute(L"Use CreateRepository instead of CreateDomain")]
static ILoggerRepository^ CreateDomain(
    String^ repository,
    Type^ repositoryType
)
Parameters
repository
Type:   Online System String
The name of the repository, this must be unique to the repository.
repositoryType
Type:   Online System Type
A   Online Type that implements ILoggerRepository
            and has a no arg constructor. An instance of this type will be created to act
            as the ILoggerRepository for the repository specified.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Exceptions
Exception | Condition
log4net.Core LogException | The specified repository already exists.
Remarks
CreateDomain is obsolete. Use CreateRepository instead of CreateDomain.

            The repository name must be unique. Repositories cannot be redefined.
            An Exception will be thrown if the repository already exists.

See Also
LoggerManager Class
LoggerManager Members
CreateDomain Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.CreateRepository Method

LoggerManager CreateRepository Method Apache log4net™ SDK Documentation
Overload List
Name | Description
CreateRepository(String) | Creates a repository with the specified name.
CreateRepository(Assembly, Type) | Creates a repository for the specified assembly and repository type.
CreateRepository(String, Type) | Creates a repository with the specified name and repository type.
Back to Top
See Also
LoggerManager Class
LoggerManager Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.CreateRepository Method (String)

LoggerManager CreateRepository Method (String) Apache log4net™ SDK Documentation
Creates a repository with the specified name.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository CreateRepository(
    string repository
)
public static ILoggerRepository CreateRepository(
    string repository
)
Public Shared Function CreateRepository (
    repository As String
) As ILoggerRepository
Public Shared Function CreateRepository (
    repository As String
) As ILoggerRepository
public:
static ILoggerRepository^ CreateRepository(
    String^ repository
)
public:
static ILoggerRepository^ CreateRepository(
    String^ repository
)
Parameters
repository
Type:   Online System String
The name of the repository, this must be unique amongst repositories.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Exceptions
Exception | Condition
log4net.Core LogException | The specified repository already exists.
Remarks

            Creates the default type of ILoggerRepository which is a
            Hierarchy object.

            The repository name must be unique. Repositories cannot be redefined.
            An   Online Exception will be thrown if the repository already exists.

See Also
LoggerManager Class
LoggerManager Members
CreateRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.CreateRepository Method (Assembly, Type)

LoggerManager CreateRepository Method (Assembly, Type) Apache log4net™ SDK Documentation
Creates a repository for the specified assembly and repository type.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository CreateRepository(
    Assembly repositoryAssembly,
    Type repositoryType
)
public static ILoggerRepository CreateRepository(
    Assembly repositoryAssembly,
    Type repositoryType
)
Public Shared Function CreateRepository (
    repositoryAssembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
Public Shared Function CreateRepository (
    repositoryAssembly As Assembly,
    repositoryType As Type
) As ILoggerRepository
public:
static ILoggerRepository^ CreateRepository(
    Assembly^ repositoryAssembly,
    Type^ repositoryType
)
public:
static ILoggerRepository^ CreateRepository(
    Assembly^ repositoryAssembly,
    Type^ repositoryType
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to get the name of the repository.
repositoryType
Type:   Online System Type
A   Online Type that implements ILoggerRepository
            and has a no arg constructor. An instance of this type will be created to act
            as the ILoggerRepository for the repository specified.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Remarks

            The ILoggerRepository created will be associated with the repository
            specified such that a call to [M:GetRepository(Assembly)] with the
            same assembly specified will return the same repository instance.

See Also
LoggerManager Class
LoggerManager Members
CreateRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.CreateRepository Method (String, Type)

LoggerManager CreateRepository Method (String, Type) Apache log4net™ SDK Documentation
Creates a repository with the specified name and repository type.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository CreateRepository(
    string repository,
    Type repositoryType
)
public static ILoggerRepository CreateRepository(
    string repository,
    Type repositoryType
)
Public Shared Function CreateRepository (
    repository As String,
    repositoryType As Type
) As ILoggerRepository
Public Shared Function CreateRepository (
    repository As String,
    repositoryType As Type
) As ILoggerRepository
public:
static ILoggerRepository^ CreateRepository(
    String^ repository,
    Type^ repositoryType
)
public:
static ILoggerRepository^ CreateRepository(
    String^ repository,
    Type^ repositoryType
)
Parameters
repository
Type:   Online System String
The name of the repository, this must be unique to the repository.
repositoryType
Type:   Online System Type
A   Online Type that implements ILoggerRepository
            and has a no arg constructor. An instance of this type will be created to act
            as the ILoggerRepository for the repository specified.
Return Value
Type: ILoggerRepository
The ILoggerRepository created for the repository.
Exceptions
Exception | Condition
log4net.Core LogException | The specified repository already exists.
Remarks

            The repository name must be unique. Repositories cannot be redefined.
            An Exception will be thrown if the repository already exists.

See Also
LoggerManager Class
LoggerManager Members
CreateRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.Exists Method

LoggerManager Exists Method Apache log4net™ SDK Documentation
Overload List
Name | Description
Exists(Assembly, String) | Returns the named logger if it exists.
Exists(String, String) | Returns the named logger if it exists.
Back to Top
See Also
LoggerManager Class
LoggerManager Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.Exists Method (Assembly, String)

LoggerManager Exists Method (Assembly, String) Apache log4net™ SDK Documentation
Returns the named logger if it exists.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILogger Exists(
    Assembly repositoryAssembly,
    string name
)
public static ILogger Exists(
    Assembly repositoryAssembly,
    string name
)
Public Shared Function Exists (
    repositoryAssembly As Assembly,
    name As String
) As ILogger
Public Shared Function Exists (
    repositoryAssembly As Assembly,
    name As String
) As ILogger
public:
static ILogger^ Exists(
    Assembly^ repositoryAssembly,
    String^ name
)
public:
static ILogger^ Exists(
    Assembly^ repositoryAssembly,
    String^ name
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
name
Type:   Online System String
The fully qualified logger name to look for.
Return Value
Type: ILogger

            The logger found, or null if the named logger does not exist in the
            specified assembly's repository.

Remarks

            If the named logger exists (in the specified assembly's repository) then it
            returns a reference to the logger, otherwise it returns
            null.

See Also
LoggerManager Class
LoggerManager Members
Exists Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.Exists Method (String, String)

LoggerManager Exists Method (String, String) Apache log4net™ SDK Documentation
Returns the named logger if it exists.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILogger Exists(
    string repository,
    string name
)
public static ILogger Exists(
    string repository,
    string name
)
Public Shared Function Exists (
    repository As String,
    name As String
) As ILogger
Public Shared Function Exists (
    repository As String,
    name As String
) As ILogger
public:
static ILogger^ Exists(
    String^ repository,
    String^ name
)
public:
static ILogger^ Exists(
    String^ repository,
    String^ name
)
Parameters
repository
Type:   Online System String
The repository to lookup in.
name
Type:   Online System String
The fully qualified logger name to look for.
Return Value
Type: ILogger

            The logger found, or null if the named logger does not exist in the
            specified repository.

Remarks

            If the named logger exists (in the specified repository) then it
            returns a reference to the logger, otherwise it returns
            null.

See Also
LoggerManager Class
LoggerManager Members
Exists Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetAllRepositories Method

LoggerManager GetAllRepositories Method Apache log4net™ SDK Documentation
Gets an array of all currently defined repositories.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository[] GetAllRepositories()
public static ILoggerRepository[] GetAllRepositories()
Public Shared Function GetAllRepositories As ILoggerRepository()
Public Shared Function GetAllRepositories As ILoggerRepository()
public:
static array<ILoggerRepository^>^ GetAllRepositories()
public:
static array<ILoggerRepository^>^ GetAllRepositories()
Return Value
Type:  ILoggerRepository
An array of all the known ILoggerRepository objects.
Remarks

            Gets an array of all currently defined repositories.

See Also
LoggerManager Class
LoggerManager Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetCurrentLoggers Method

LoggerManager GetCurrentLoggers Method Apache log4net™ SDK Documentation
Overload List
Name | Description
GetCurrentLoggers(Assembly) | Returns all the currently defined loggers in the specified assembly's repository.
GetCurrentLoggers(String) | Returns all the currently defined loggers in the specified repository.
Back to Top
See Also
LoggerManager Class
LoggerManager Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetCurrentLoggers Method (Assembly)

LoggerManager GetCurrentLoggers Method (Assembly) Apache log4net™ SDK Documentation
Returns all the currently defined loggers in the specified assembly's repository.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILogger[] GetCurrentLoggers(
    Assembly repositoryAssembly
)
public static ILogger[] GetCurrentLoggers(
    Assembly repositoryAssembly
)
Public Shared Function GetCurrentLoggers (
    repositoryAssembly As Assembly
) As ILogger()
Public Shared Function GetCurrentLoggers (
    repositoryAssembly As Assembly
) As ILogger()
public:
static array<ILogger^>^ GetCurrentLoggers(
    Assembly^ repositoryAssembly
)
public:
static array<ILogger^>^ GetCurrentLoggers(
    Assembly^ repositoryAssembly
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
Return Value
Type:  ILogger
All the defined loggers.
Remarks

            The root logger is not included in the returned array.

See Also
LoggerManager Class
LoggerManager Members
GetCurrentLoggers Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetCurrentLoggers Method (String)

LoggerManager GetCurrentLoggers Method (String) Apache log4net™ SDK Documentation
Returns all the currently defined loggers in the specified repository.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILogger[] GetCurrentLoggers(
    string repository
)
public static ILogger[] GetCurrentLoggers(
    string repository
)
Public Shared Function GetCurrentLoggers (
    repository As String
) As ILogger()
Public Shared Function GetCurrentLoggers (
    repository As String
) As ILogger()
public:
static array<ILogger^>^ GetCurrentLoggers(
    String^ repository
)
public:
static array<ILogger^>^ GetCurrentLoggers(
    String^ repository
)
Parameters
repository
Type:   Online System String
The repository to lookup in.
Return Value
Type:  ILogger
All the defined loggers.
Remarks

            The root logger is not included in the returned array.

See Also
LoggerManager Class
LoggerManager Members
GetCurrentLoggers Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetLogger Method

LoggerManager GetLogger Method Apache log4net™ SDK Documentation
Overload List
Name | Description
GetLogger(Assembly, String) | Retrieves or creates a named logger.
GetLogger(Assembly, Type) | Shorthand for GetLogger(string).
GetLogger(String, String) | Retrieves or creates a named logger.
GetLogger(String, Type) | Shorthand for GetLogger(string).
Back to Top
See Also
LoggerManager Class
LoggerManager Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetLogger Method (Assembly, String)

LoggerManager GetLogger Method (Assembly, String) Apache log4net™ SDK Documentation
Retrieves or creates a named logger.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILogger GetLogger(
    Assembly repositoryAssembly,
    string name
)
public static ILogger GetLogger(
    Assembly repositoryAssembly,
    string name
)
Public Shared Function GetLogger (
    repositoryAssembly As Assembly,
    name As String
) As ILogger
Public Shared Function GetLogger (
    repositoryAssembly As Assembly,
    name As String
) As ILogger
public:
static ILogger^ GetLogger(
    Assembly^ repositoryAssembly,
    String^ name
)
public:
static ILogger^ GetLogger(
    Assembly^ repositoryAssembly,
    String^ name
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
name
Type:   Online System String
The name of the logger to retrieve.
Return Value
Type: ILogger
The logger with the name specified.
Remarks

            Retrieves a logger named as the name
            parameter. If the named logger already exists, then the
            existing instance will be returned. Otherwise, a new instance is
            created.

            By default, loggers do not have a set level but inherit
            it from the hierarchy. This is one of the central features of
            log4net.

See Also
LoggerManager Class
LoggerManager Members
GetLogger Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetLogger Method (Assembly, Type)

LoggerManager GetLogger Method (Assembly, Type) Apache log4net™ SDK Documentation
Shorthand for GetLogger(string).

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILogger GetLogger(
    Assembly repositoryAssembly,
    Type type
)
public static ILogger GetLogger(
    Assembly repositoryAssembly,
    Type type
)
Public Shared Function GetLogger (
    repositoryAssembly As Assembly,
    type As Type
) As ILogger
Public Shared Function GetLogger (
    repositoryAssembly As Assembly,
    type As Type
) As ILogger
public:
static ILogger^ GetLogger(
    Assembly^ repositoryAssembly,
    Type^ type
)
public:
static ILogger^ GetLogger(
    Assembly^ repositoryAssembly,
    Type^ type
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
the assembly to use to lookup the repository
type
Type:   Online System Type
The type of which the fullname will be used as the name of the logger to retrieve.
Return Value
Type: ILogger
The logger with the name specified.
Remarks

            Gets the logger for the fully qualified name of the type specified.

See Also
LoggerManager Class
LoggerManager Members
GetLogger Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetLogger Method (String, String)

LoggerManager GetLogger Method (String, String) Apache log4net™ SDK Documentation
Retrieves or creates a named logger.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILogger GetLogger(
    string repository,
    string name
)
public static ILogger GetLogger(
    string repository,
    string name
)
Public Shared Function GetLogger (
    repository As String,
    name As String
) As ILogger
Public Shared Function GetLogger (
    repository As String,
    name As String
) As ILogger
public:
static ILogger^ GetLogger(
    String^ repository,
    String^ name
)
public:
static ILogger^ GetLogger(
    String^ repository,
    String^ name
)
Parameters
repository
Type:   Online System String
The repository to lookup in.
name
Type:   Online System String
The name of the logger to retrieve.
Return Value
Type: ILogger
The logger with the name specified.
Remarks

            Retrieves a logger named as the name
            parameter. If the named logger already exists, then the
            existing instance will be returned. Otherwise, a new instance is
            created.

            By default, loggers do not have a set level but inherit
            it from the hierarchy. This is one of the central features of
            log4net.

See Also
LoggerManager Class
LoggerManager Members
GetLogger Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetLogger Method (String, Type)

LoggerManager GetLogger Method (String, Type) Apache log4net™ SDK Documentation
Shorthand for GetLogger(string).

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILogger GetLogger(
    string repository,
    Type type
)
public static ILogger GetLogger(
    string repository,
    Type type
)
Public Shared Function GetLogger (
    repository As String,
    type As Type
) As ILogger
Public Shared Function GetLogger (
    repository As String,
    type As Type
) As ILogger
public:
static ILogger^ GetLogger(
    String^ repository,
    Type^ type
)
public:
static ILogger^ GetLogger(
    String^ repository,
    Type^ type
)
Parameters
repository
Type:   Online System String
The repository to lookup in.
type
Type:   Online System Type
The type of which the fullname will be used as the name of the logger to retrieve.
Return Value
Type: ILogger
The logger with the name specified.
Remarks

            Gets the logger for the fully qualified name of the type specified.

See Also
LoggerManager Class
LoggerManager Members
GetLogger Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetLoggerRepository Method

LoggerManager GetLoggerRepository Method Apache log4net™ SDK Documentation
Overload List
Name | Description
GetLoggerRepository(Assembly) | Obsolete. Returns the default ILoggerRepository instance.
GetLoggerRepository(String) | Obsolete. Return the default ILoggerRepository instance.
Back to Top
See Also
LoggerManager Class
LoggerManager Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetLoggerRepository Method (Assembly)

LoggerManager GetLoggerRepository Method (Assembly) Apache log4net™ SDK Documentation
Returns the default ILoggerRepository instance.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")]
public static ILoggerRepository GetLoggerRepository(
    Assembly repositoryAssembly
)
[ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")]
public static ILoggerRepository GetLoggerRepository(
    Assembly repositoryAssembly
)
<ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")>
Public Shared Function GetLoggerRepository (
    repositoryAssembly As Assembly
) As ILoggerRepository
<ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")>
Public Shared Function GetLoggerRepository (
    repositoryAssembly As Assembly
) As ILoggerRepository
public:
[ObsoleteAttribute(L"Use GetRepository instead of GetLoggerRepository")]
static ILoggerRepository^ GetLoggerRepository(
    Assembly^ repositoryAssembly
)
public:
[ObsoleteAttribute(L"Use GetRepository instead of GetLoggerRepository")]
static ILoggerRepository^ GetLoggerRepository(
    Assembly^ repositoryAssembly
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
Return Value
Type: ILoggerRepository
The default ILoggerRepository instance.
See Also
LoggerManager Class
LoggerManager Members
GetLoggerRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetLoggerRepository Method (String)

LoggerManager GetLoggerRepository Method (String) Apache log4net™ SDK Documentation
Return the default ILoggerRepository instance.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")]
public static ILoggerRepository GetLoggerRepository(
    string repository
)
[ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")]
public static ILoggerRepository GetLoggerRepository(
    string repository
)
<ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")>
Public Shared Function GetLoggerRepository (
    repository As String
) As ILoggerRepository
<ObsoleteAttribute("Use GetRepository instead of GetLoggerRepository")>
Public Shared Function GetLoggerRepository (
    repository As String
) As ILoggerRepository
public:
[ObsoleteAttribute(L"Use GetRepository instead of GetLoggerRepository")]
static ILoggerRepository^ GetLoggerRepository(
    String^ repository
)
public:
[ObsoleteAttribute(L"Use GetRepository instead of GetLoggerRepository")]
static ILoggerRepository^ GetLoggerRepository(
    String^ repository
)
Parameters
repository
Type:   Online System String
the repository to lookup in
Return Value
Type: ILoggerRepository
Return the default ILoggerRepository instance
Remarks

            Gets the ILoggerRepository for the repository specified
            by the repository argument.

See Also
LoggerManager Class
LoggerManager Members
GetLoggerRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetRepository Method

LoggerManager GetRepository Method Apache log4net™ SDK Documentation
Overload List
Name | Description
GetRepository(Assembly) | Returns the default ILoggerRepository instance.
GetRepository(String) | Return the default ILoggerRepository instance.
Back to Top
See Also
LoggerManager Class
LoggerManager Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetRepository Method (Assembly)

LoggerManager GetRepository Method (Assembly) Apache log4net™ SDK Documentation
Returns the default ILoggerRepository instance.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository GetRepository(
    Assembly repositoryAssembly
)
public static ILoggerRepository GetRepository(
    Assembly repositoryAssembly
)
Public Shared Function GetRepository (
    repositoryAssembly As Assembly
) As ILoggerRepository
Public Shared Function GetRepository (
    repositoryAssembly As Assembly
) As ILoggerRepository
public:
static ILoggerRepository^ GetRepository(
    Assembly^ repositoryAssembly
)
public:
static ILoggerRepository^ GetRepository(
    Assembly^ repositoryAssembly
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
Return Value
Type: ILoggerRepository
The default ILoggerRepository instance.
Remarks

            Returns the default ILoggerRepository instance.

See Also
LoggerManager Class
LoggerManager Members
GetRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.GetRepository Method (String)

LoggerManager GetRepository Method (String) Apache log4net™ SDK Documentation
Return the default ILoggerRepository instance.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILoggerRepository GetRepository(
    string repository
)
public static ILoggerRepository GetRepository(
    string repository
)
Public Shared Function GetRepository (
    repository As String
) As ILoggerRepository
Public Shared Function GetRepository (
    repository As String
) As ILoggerRepository
public:
static ILoggerRepository^ GetRepository(
    String^ repository
)
public:
static ILoggerRepository^ GetRepository(
    String^ repository
)
Parameters
repository
Type:   Online System String
the repository to lookup in
Return Value
Type: ILoggerRepository
Return the default ILoggerRepository instance
Remarks

            Gets the ILoggerRepository for the repository specified
            by the repository argument.

See Also
LoggerManager Class
LoggerManager Members
GetRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.ResetConfiguration Method

LoggerManager ResetConfiguration Method Apache log4net™ SDK Documentation
Overload List
Name | Description
ResetConfiguration(Assembly) | Resets all values contained in this repository instance to their defaults.
ResetConfiguration(String) | Resets all values contained in this repository instance to their defaults.
Back to Top
See Also
LoggerManager Class
LoggerManager Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.ResetConfiguration Method (Assembly)

LoggerManager ResetConfiguration Method (Assembly) Apache log4net™ SDK Documentation
Resets all values contained in this repository instance to their defaults.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ResetConfiguration(
    Assembly repositoryAssembly
)
public static void ResetConfiguration(
    Assembly repositoryAssembly
)
Public Shared Sub ResetConfiguration (
    repositoryAssembly As Assembly
)
Public Shared Sub ResetConfiguration (
    repositoryAssembly As Assembly
)
public:
static void ResetConfiguration(
    Assembly^ repositoryAssembly
)
public:
static void ResetConfiguration(
    Assembly^ repositoryAssembly
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository to reset.
Remarks

            Resets all values contained in the repository instance to their
            defaults.  This removes all appenders from all loggers, sets
            the level of all non-root loggers to null,
            sets their additivity flag to true and sets the level
            of the root logger to Debug. Moreover,
            message disabling is set its default "off" value.

See Also
LoggerManager Class
LoggerManager Members
ResetConfiguration Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.ResetConfiguration Method (String)

LoggerManager ResetConfiguration Method (String) Apache log4net™ SDK Documentation
Resets all values contained in this repository instance to their defaults.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ResetConfiguration(
    string repository
)
public static void ResetConfiguration(
    string repository
)
Public Shared Sub ResetConfiguration (
    repository As String
)
Public Shared Sub ResetConfiguration (
    repository As String
)
public:
static void ResetConfiguration(
    String^ repository
)
public:
static void ResetConfiguration(
    String^ repository
)
Parameters
repository
Type:   Online System String
The repository to reset.
Remarks

            Resets all values contained in the repository instance to their
            defaults.  This removes all appenders from all loggers, sets
            the level of all non-root loggers to null,
            sets their additivity flag to true and sets the level
            of the root logger to Debug. Moreover,
            message disabling is set its default "off" value.

See Also
LoggerManager Class
LoggerManager Members
ResetConfiguration Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.Shutdown Method

LoggerManager Shutdown Method Apache log4net™ SDK Documentation
Shuts down the log4net system.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Shutdown()
public static void Shutdown()
Public Shared Sub Shutdown
Public Shared Sub Shutdown
public:
static void Shutdown()
public:
static void Shutdown()
Remarks

            Calling this method will safely close and remove all
            appenders in all the loggers including root contained in all the
            default repositories.

            Some appenders need to be closed before the application exists.
            Otherwise, pending logging events might be lost.

            The shutdown method is careful to close nested
            appenders before closing regular appenders. This is allows
            configurations where a regular appender is attached to a logger
            and again to a nested appender.

See Also
LoggerManager Class
LoggerManager Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.ShutdownRepository Method

LoggerManager ShutdownRepository Method Apache log4net™ SDK Documentation
Overload List
Name | Description
ShutdownRepository(Assembly) | Shuts down the repository for the repository specified.
ShutdownRepository(String) | Shuts down the repository for the repository specified.
Back to Top
See Also
LoggerManager Class
LoggerManager Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.ShutdownRepository Method (Assembly)

LoggerManager ShutdownRepository Method (Assembly) Apache log4net™ SDK Documentation
Shuts down the repository for the repository specified.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ShutdownRepository(
    Assembly repositoryAssembly
)
public static void ShutdownRepository(
    Assembly repositoryAssembly
)
Public Shared Sub ShutdownRepository (
    repositoryAssembly As Assembly
)
Public Shared Sub ShutdownRepository (
    repositoryAssembly As Assembly
)
public:
static void ShutdownRepository(
    Assembly^ repositoryAssembly
)
public:
static void ShutdownRepository(
    Assembly^ repositoryAssembly
)
Parameters
repositoryAssembly
Type:   Online System.Reflection Assembly
The assembly to use to lookup the repository.
Remarks

            Calling this method will safely close and remove all
            appenders in all the loggers including root contained in the
            repository for the repository. The repository is looked up using
            the repositoryAssembly specified.

            Some appenders need to be closed before the application exists.
            Otherwise, pending logging events might be lost.

            The shutdown method is careful to close nested
            appenders before closing regular appenders. This is allows
            configurations where a regular appender is attached to a logger
            and again to a nested appender.

See Also
LoggerManager Class
LoggerManager Members
ShutdownRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.ShutdownRepository Method (String)

LoggerManager ShutdownRepository Method (String) Apache log4net™ SDK Documentation
Shuts down the repository for the repository specified.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ShutdownRepository(
    string repository
)
public static void ShutdownRepository(
    string repository
)
Public Shared Sub ShutdownRepository (
    repository As String
)
Public Shared Sub ShutdownRepository (
    repository As String
)
public:
static void ShutdownRepository(
    String^ repository
)
public:
static void ShutdownRepository(
    String^ repository
)
Parameters
repository
Type:   Online System String
The repository to shutdown.
Remarks

            Calling this method will safely close and remove all
            appenders in all the loggers including root contained in the
            repository for the repository specified.

            Some appenders need to be closed before the application exists.
            Otherwise, pending logging events might be lost.

            The shutdown method is careful to close nested
            appenders before closing regular appenders. This is allows
            configurations where a regular appender is attached to a logger
            and again to a nested appender.

See Also
LoggerManager Class
LoggerManager Members
ShutdownRepository Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager Properties

LoggerManager Properties Apache log4net™ SDK Documentation
The LoggerManager type exposes the following members.
Properties
Name | Description
RepositorySelector | Gets or sets the repository selector used by the LogManager.
Back to Top
See Also
LoggerManager Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerManager.RepositorySelector Property

LoggerManager RepositorySelector Property Apache log4net™ SDK Documentation
Gets or sets the repository selector used by the LogManager.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IRepositorySelector RepositorySelector { get; set; }
public static IRepositorySelector RepositorySelector { get; set; }
Public Shared Property RepositorySelector As IRepositorySelector
    Get
    Set
Public Shared Property RepositorySelector As IRepositorySelector
    Get
    Set
public:
static property IRepositorySelector^ RepositorySelector {
    IRepositorySelector^ get ();
    void set (IRepositorySelector^ value);
}
public:
static property IRepositorySelector^ RepositorySelector {
    IRepositorySelector^ get ();
    void set (IRepositorySelector^ value);
}
Property Value
Type: IRepositorySelector

            The repository selector used by the LogManager.

Remarks

            The repository selector (IRepositorySelector) is used by
            the LogManager to create and select repositories
            (ILoggerRepository).

            The caller to LogManager supplies either a string name
            or an assembly (if not supplied the assembly is inferred using
            [M:Assembly.GetCallingAssembly()]).

            This context is used by the selector to lookup a specific repository.

            For the full .NET Framework, the default repository is DefaultRepositorySelector;
            for the .NET Compact Framework CompactRepositorySelector is the default
            repository.

See Also
LoggerManager Class
LoggerManager Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositoryCreationEventArgs Class

LoggerRepositoryCreationEventArgs Class Apache log4net™ SDK Documentation
Provides data for the LoggerRepositoryCreatedEvent event.
Inheritance Hierarchy
Online System Object
Online System EventArgs
log4net.Core LoggerRepositoryCreationEventArgs

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LoggerRepositoryCreationEventArgs : EventArgs
public class LoggerRepositoryCreationEventArgs : EventArgs
Public Class LoggerRepositoryCreationEventArgs
    Inherits EventArgs
Public Class LoggerRepositoryCreationEventArgs
    Inherits EventArgs
public ref class LoggerRepositoryCreationEventArgs : public EventArgs
public ref class LoggerRepositoryCreationEventArgs : public EventArgs
Remarks

            A LoggerRepositoryCreatedEvent
            event is raised every time a ILoggerRepository is created.

See Also
LoggerRepositoryCreationEventArgs Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositoryCreationEventArgs Members

LoggerRepositoryCreationEventArgs Members Apache log4net™ SDK Documentation
The LoggerRepositoryCreationEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | LoggerRepositoryCreationEventArgs | Construct instance using ILoggerRepository specified
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | LoggerRepository | The ILoggerRepository that has been created
Back to Top
See Also
LoggerRepositoryCreationEventArgs Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositoryCreationEventArgs Constructor

LoggerRepositoryCreationEventArgs Constructor Apache log4net™ SDK Documentation
Construct instance using ILoggerRepository specified

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggerRepositoryCreationEventArgs(
    ILoggerRepository repository
)
public LoggerRepositoryCreationEventArgs(
    ILoggerRepository repository
)
Public Sub New (
    repository As ILoggerRepository
)
Public Sub New (
    repository As ILoggerRepository
)
public:
LoggerRepositoryCreationEventArgs(
    ILoggerRepository^ repository
)
public:
LoggerRepositoryCreationEventArgs(
    ILoggerRepository^ repository
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
the ILoggerRepository that has been created
Remarks

            Construct instance using ILoggerRepository specified

See Also
LoggerRepositoryCreationEventArgs Class
LoggerRepositoryCreationEventArgs Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositoryCreationEventArgs Methods

LoggerRepositoryCreationEventArgs Methods Apache log4net™ SDK Documentation
The LoggerRepositoryCreationEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LoggerRepositoryCreationEventArgs Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositoryCreationEventArgs Properties

LoggerRepositoryCreationEventArgs Properties Apache log4net™ SDK Documentation
The LoggerRepositoryCreationEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | LoggerRepository | The ILoggerRepository that has been created
Back to Top
See Also
LoggerRepositoryCreationEventArgs Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositoryCreationEventArgs.LoggerRepository Property

LoggerRepositoryCreationEventArgs LoggerRepository Property Apache log4net™ SDK Documentation
The ILoggerRepository that has been created

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository LoggerRepository { get; }
public ILoggerRepository LoggerRepository { get; }
Public ReadOnly Property LoggerRepository As ILoggerRepository
    Get
Public ReadOnly Property LoggerRepository As ILoggerRepository
    Get
public:
property ILoggerRepository^ LoggerRepository {
    ILoggerRepository^ get ();
}
public:
property ILoggerRepository^ LoggerRepository {
    ILoggerRepository^ get ();
}
Property Value
Type: ILoggerRepository

            The ILoggerRepository that has been created

Remarks

            The ILoggerRepository that has been created

See Also
LoggerRepositoryCreationEventArgs Class
LoggerRepositoryCreationEventArgs Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositoryCreationEventHandler Delegate

LoggerRepositoryCreationEventHandler Delegate Apache log4net™ SDK Documentation
Delegate used to handle logger repository creation event notifications

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void LoggerRepositoryCreationEventHandler(
    Object sender,
    LoggerRepositoryCreationEventArgs e
)
public delegate void LoggerRepositoryCreationEventHandler(
    Object sender,
    LoggerRepositoryCreationEventArgs e
)
Public Delegate Sub LoggerRepositoryCreationEventHandler (
    sender As Object,
    e As LoggerRepositoryCreationEventArgs
)
Public Delegate Sub LoggerRepositoryCreationEventHandler (
    sender As Object,
    e As LoggerRepositoryCreationEventArgs
)
public delegate void LoggerRepositoryCreationEventHandler(
    Object^ sender,
    LoggerRepositoryCreationEventArgs^ e
)
public delegate void LoggerRepositoryCreationEventHandler(
    Object^ sender,
    LoggerRepositoryCreationEventArgs^ e
)
Parameters
sender
Type:   Online System Object
The IRepositorySelector which created the repository.
e
Type: log4net.Core LoggerRepositoryCreationEventArgs
The LoggerRepositoryCreationEventArgs event args
            that holds the ILoggerRepository instance that has been created.
Remarks

            Delegate used to handle logger repository creation event notifications.

See Also
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerWrapperImpl Class

LoggerWrapperImpl Class Apache log4net™ SDK Documentation
Implementation of the ILoggerWrapper interface.
Inheritance Hierarchy
Online System Object
log4net.Core LoggerWrapperImpl
log4net.Core LogImpl

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class LoggerWrapperImpl : ILoggerWrapper
public abstract class LoggerWrapperImpl : ILoggerWrapper
Public MustInherit Class LoggerWrapperImpl
    Implements ILoggerWrapper
Public MustInherit Class LoggerWrapperImpl
    Implements ILoggerWrapper
public ref class LoggerWrapperImpl abstract : ILoggerWrapper
public ref class LoggerWrapperImpl abstract : ILoggerWrapper
Remarks

            This class should be used as the base for all wrapper implementations.

See Also
LoggerWrapperImpl Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerWrapperImpl Members

LoggerWrapperImpl Members Apache log4net™ SDK Documentation
The LoggerWrapperImpl type exposes the following members.
Constructors
 | Name | Description
Protected method | LoggerWrapperImpl | Constructs a new wrapper for the specified logger.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Logger | Gets the implementation behind this wrapper object.
Back to Top
See Also
LoggerWrapperImpl Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerWrapperImpl Constructor

LoggerWrapperImpl Constructor Apache log4net™ SDK Documentation
Constructs a new wrapper for the specified logger.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LoggerWrapperImpl(
    ILogger logger
)
protected LoggerWrapperImpl(
    ILogger logger
)
Protected Sub New (
    logger As ILogger
)
Protected Sub New (
    logger As ILogger
)
protected:
LoggerWrapperImpl(
    ILogger^ logger
)
protected:
LoggerWrapperImpl(
    ILogger^ logger
)
Parameters
logger
Type: log4net.Core ILogger
The logger to wrap.
Remarks

            Constructs a new wrapper for the specified logger.

See Also
LoggerWrapperImpl Class
LoggerWrapperImpl Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerWrapperImpl Methods

LoggerWrapperImpl Methods Apache log4net™ SDK Documentation
The LoggerWrapperImpl type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LoggerWrapperImpl Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerWrapperImpl Properties

LoggerWrapperImpl Properties Apache log4net™ SDK Documentation
The LoggerWrapperImpl type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets the implementation behind this wrapper object.
Back to Top
See Also
LoggerWrapperImpl Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerWrapperImpl.Logger Property

LoggerWrapperImpl Logger Property Apache log4net™ SDK Documentation
Gets the implementation behind this wrapper object.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ILogger Logger { get; }
public virtual ILogger Logger { get; }
Public Overridable ReadOnly Property Logger As ILogger
    Get
Public Overridable ReadOnly Property Logger As ILogger
    Get
public:
virtual property ILogger^ Logger {
    ILogger^ get ();
}
public:
virtual property ILogger^ Logger {
    ILogger^ get ();
}
Property Value
Type: ILogger

            The ILogger object that this object is implementing.

Implements
ILoggerWrapper Logger
Remarks

            The Logger object may not be the same object as this object
            because of logger decorators.

            This gets the actual underlying objects that is used to process
            the log events.

See Also
LoggerWrapperImpl Class
LoggerWrapperImpl Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent Class

LoggingEvent Class Apache log4net™ SDK Documentation
The internal representation of logging events.
Inheritance Hierarchy
Online System Object
log4net.Core LoggingEvent

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class LoggingEvent : ISerializable
[SerializableAttribute]
public class LoggingEvent : ISerializable
<SerializableAttribute>
Public Class LoggingEvent
    Implements ISerializable
<SerializableAttribute>
Public Class LoggingEvent
    Implements ISerializable
[SerializableAttribute]
public ref class LoggingEvent : ISerializable
[SerializableAttribute]
public ref class LoggingEvent : ISerializable
Remarks

            When an affirmative decision is made to log then a
            LoggingEvent instance is created. This instance
            is passed around to the different log4net components.

            This class is of concern to those wishing to extend log4net.

            Some of the values in instances of LoggingEvent
            are considered volatile, that is the values are correct at the
            time the event is delivered to appenders, but will not be consistent
            at any time afterwards. If an event is to be stored and then processed
            at a later time these volatile values must be fixed by calling
            [M:FixVolatileData()]. There is a performance penalty
            for incurred by calling [M:FixVolatileData()] but it
            is essential to maintaining data consistency.

See Also
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent Members

LoggingEvent Members Apache log4net™ SDK Documentation
The LoggingEvent type exposes the following members.
Constructors
 | Name | Description
Public method | LoggingEvent(LoggingEventData) | Initializes a new instance of the LoggingEvent class using specific data.
Protected method | LoggingEvent(SerializationInfo, StreamingContext) | Serialization constructor
Public method | LoggingEvent(Type, ILoggerRepository, LoggingEventData) | Initializes a new instance of the LoggingEvent class using specific data.
Public method | LoggingEvent(Type, ILoggerRepository, LoggingEventData, FixFlags) | Initializes a new instance of the LoggingEvent class using specific data.
Public method | LoggingEvent(Type, ILoggerRepository, String, Level, Object, Exception) | Initializes a new instance of the LoggingEvent class from the supplied parameters.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FixVolatileData | Obsolete. Fix instance fields that hold volatile data.
Public method | FixVolatileData(Boolean) | Obsolete. Fixes instance fields that hold volatile data.
Protected method | FixVolatileData(FixFlags) | Fix the fields specified by the FixFlags parameter
Public method | GetExceptionString | Returns this event's exception's rendered using the RendererMap.
Public method | GetExceptionStrRep | Obsolete. Returns this event's exception's rendered using the RendererMap.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLoggingEventData | Gets the portable data for this LoggingEvent.
Public method | GetLoggingEventData(FixFlags) | Gets the portable data for this LoggingEvent.
Public method | GetObjectData | Serializes this object into the Online SerializationInfo provided.
Public method | GetProperties | Get all the composite properties in this event
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LookupProperty | Lookup a composite property in this event
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteRenderedMessage | Write the rendered message to a TextWriter
Back to Top
Fields
Name | Description
HostNameProperty | The key into the Properties map for the host name value.
IdentityProperty | The key into the Properties map for the thread identity value.
UserNameProperty | The key into the Properties map for the user name value.
Back to Top
Properties
 | Name | Description
Public property | Domain | Gets the AppDomain friendly name.
Public property | ExceptionObject | Gets the exception object used to initialize this event.
Public property | Fix | The fixed fields in this event
Public property | Identity | Gets the identity of the current thread principal.
Public property | Level | Gets the Level of the logging event.
Public property | LocationInformation | Gets the location information for this logging event.
Public property | LoggerName | Gets the name of the logger that logged the event.
Public property | MessageObject | Gets the message object used to initialize this event.
Public property | Properties | Additional event specific properties.
Public property | RenderedMessage | Gets the message, rendered through the RendererMap.
Public property | Repository | The ILoggerRepository that this event was created in.
 | StartTime | Gets the time when the current process started.
Public property | ThreadName | Gets the name of the current thread.
Public property | TimeStamp | Gets the time of the logging event.
Public property | UserName | Gets the name of the current user.
Back to Top
See Also
LoggingEvent Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent Constructor

LoggingEvent Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | LoggingEvent(LoggingEventData) | Initializes a new instance of the LoggingEvent class using specific data.
Protected method | LoggingEvent(SerializationInfo, StreamingContext) | Serialization constructor
Public method | LoggingEvent(Type, ILoggerRepository, LoggingEventData) | Initializes a new instance of the LoggingEvent class using specific data.
Public method | LoggingEvent(Type, ILoggerRepository, LoggingEventData, FixFlags) | Initializes a new instance of the LoggingEvent class using specific data.
Public method | LoggingEvent(Type, ILoggerRepository, String, Level, Object, Exception) | Initializes a new instance of the LoggingEvent class from the supplied parameters.
Back to Top
See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent Constructor (LoggingEventData)

LoggingEvent Constructor (LoggingEventData) Apache log4net™ SDK Documentation
Initializes a new instance of the LoggingEvent class using specific data.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingEvent(
    LoggingEventData data
)
public LoggingEvent(
    LoggingEventData data
)
Public Sub New (
    data As LoggingEventData
)
Public Sub New (
    data As LoggingEventData
)
public:
LoggingEvent(
    LoggingEventData data
)
public:
LoggingEvent(
    LoggingEventData data
)
Parameters
data
Type: log4net.Core LoggingEventData
Data used to initialize the logging event.
Remarks

            This constructor is provided to allow a LoggingEvent
            to be created independently of the log4net framework. This can
            be useful if you require a custom serialization scheme.

            Use the [M:GetLoggingEventData(FixFlags)] method to obtain an
            instance of the LoggingEventData class.

            This constructor sets this objects Fix flags to All,
            this assumes that all the data relating to this event is passed in via the data
            parameter and no other data should be captured from the environment.

See Also
LoggingEvent Class
LoggingEvent Members
LoggingEvent Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent Constructor (SerializationInfo, StreamingContext)

LoggingEvent Constructor (SerializationInfo, StreamingContext) Apache log4net™ SDK Documentation
Serialization constructor

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LoggingEvent(
    SerializationInfo info,
    StreamingContext context
)
protected LoggingEvent(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
LoggingEvent(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
LoggingEvent(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The   Online SerializationInfo that holds the serialized object data.
context
Type:   Online System.Runtime.Serialization StreamingContext
The   Online StreamingContext that contains contextual information about the source or destination.
Remarks

            Initializes a new instance of the LoggingEvent class
            with serialized data.

See Also
LoggingEvent Class
LoggingEvent Members
LoggingEvent Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent Constructor (Type, ILoggerRepository, LoggingEventData)

LoggingEvent Constructor (Type, ILoggerRepository, LoggingEventData) Apache log4net™ SDK Documentation
Initializes a new instance of the LoggingEvent class using specific data.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingEvent(
    Type callerStackBoundaryDeclaringType,
    ILoggerRepository repository,
    LoggingEventData data
)
public LoggingEvent(
    Type callerStackBoundaryDeclaringType,
    ILoggerRepository repository,
    LoggingEventData data
)
Public Sub New (
    callerStackBoundaryDeclaringType As Type,
    repository As ILoggerRepository,
    data As LoggingEventData
)
Public Sub New (
    callerStackBoundaryDeclaringType As Type,
    repository As ILoggerRepository,
    data As LoggingEventData
)
public:
LoggingEvent(
    Type^ callerStackBoundaryDeclaringType,
    ILoggerRepository^ repository,
    LoggingEventData data
)
public:
LoggingEvent(
    Type^ callerStackBoundaryDeclaringType,
    ILoggerRepository^ repository,
    LoggingEventData data
)
Parameters
callerStackBoundaryDeclaringType
Type:   Online System Type
The declaring type of the method that is
            the stack boundary into the logging system for this call.
repository
Type: log4net.Repository ILoggerRepository
The repository this event is logged in.
data
Type: log4net.Core LoggingEventData
Data used to initialize the logging event.
Remarks

            This constructor is provided to allow a LoggingEvent
            to be created independently of the log4net framework. This can
            be useful if you require a custom serialization scheme.

            Use the [M:GetLoggingEventData(FixFlags)] method to obtain an
            instance of the LoggingEventData class.

            This constructor sets this objects Fix flags to All,
            this assumes that all the data relating to this event is passed in via the data
            parameter and no other data should be captured from the environment.

See Also
LoggingEvent Class
LoggingEvent Members
LoggingEvent Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent Constructor (Type, ILoggerRepository, LoggingEventData, FixFlags)

LoggingEvent Constructor (Type, ILoggerRepository, LoggingEventData, FixFlags) Apache log4net™ SDK Documentation
Initializes a new instance of the LoggingEvent class using specific data.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingEvent(
    Type callerStackBoundaryDeclaringType,
    ILoggerRepository repository,
    LoggingEventData data,
    FixFlags fixedData
)
public LoggingEvent(
    Type callerStackBoundaryDeclaringType,
    ILoggerRepository repository,
    LoggingEventData data,
    FixFlags fixedData
)
Public Sub New (
    callerStackBoundaryDeclaringType As Type,
    repository As ILoggerRepository,
    data As LoggingEventData,
    fixedData As FixFlags
)
Public Sub New (
    callerStackBoundaryDeclaringType As Type,
    repository As ILoggerRepository,
    data As LoggingEventData,
    fixedData As FixFlags
)
public:
LoggingEvent(
    Type^ callerStackBoundaryDeclaringType,
    ILoggerRepository^ repository,
    LoggingEventData data,
    FixFlags fixedData
)
public:
LoggingEvent(
    Type^ callerStackBoundaryDeclaringType,
    ILoggerRepository^ repository,
    LoggingEventData data,
    FixFlags fixedData
)
Parameters
callerStackBoundaryDeclaringType
Type:   Online System Type
The declaring type of the method that is
            the stack boundary into the logging system for this call.
repository
Type: log4net.Repository ILoggerRepository
The repository this event is logged in.
data
Type: log4net.Core LoggingEventData
Data used to initialize the logging event.
fixedData
Type: log4net.Core FixFlags
The fields in the  struct that have already been fixed.
Remarks

            This constructor is provided to allow a LoggingEvent
            to be created independently of the log4net framework. This can
            be useful if you require a custom serialization scheme.

            Use the [M:GetLoggingEventData(FixFlags)] method to obtain an
            instance of the LoggingEventData class.

            The fixedData parameter should be used to specify which fields in the
            data struct have been preset. Fields not specified in the fixedData
            will be captured from the environment if requested or fixed.

See Also
LoggingEvent Class
LoggingEvent Members
LoggingEvent Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent Constructor (Type, ILoggerRepository, String, Level, Object, Exception)

LoggingEvent Constructor (Type, ILoggerRepository, String, Level, Object, Exception) Apache log4net™ SDK Documentation
Initializes a new instance of the LoggingEvent class from the supplied parameters.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingEvent(
    Type callerStackBoundaryDeclaringType,
    ILoggerRepository repository,
    string loggerName,
    Level level,
    Object message,
    Exception exception
)
public LoggingEvent(
    Type callerStackBoundaryDeclaringType,
    ILoggerRepository repository,
    string loggerName,
    Level level,
    Object message,
    Exception exception
)
Public Sub New (
    callerStackBoundaryDeclaringType As Type,
    repository As ILoggerRepository,
    loggerName As String,
    level As Level,
    message As Object,
    exception As Exception
)
Public Sub New (
    callerStackBoundaryDeclaringType As Type,
    repository As ILoggerRepository,
    loggerName As String,
    level As Level,
    message As Object,
    exception As Exception
)
public:
LoggingEvent(
    Type^ callerStackBoundaryDeclaringType,
    ILoggerRepository^ repository,
    String^ loggerName,
    Level^ level,
    Object^ message,
    Exception^ exception
)
public:
LoggingEvent(
    Type^ callerStackBoundaryDeclaringType,
    ILoggerRepository^ repository,
    String^ loggerName,
    Level^ level,
    Object^ message,
    Exception^ exception
)
Parameters
callerStackBoundaryDeclaringType
Type:   Online System Type
The declaring type of the method that is
            the stack boundary into the logging system for this call.
repository
Type: log4net.Repository ILoggerRepository
The repository this event is logged in.
loggerName
Type:   Online System String
The name of the logger of this event.
level
Type: log4net.Core Level
The level of this event.
message
Type:   Online System Object
The message of this event.
exception
Type:   Online System Exception
The exception for this event.
Remarks

            Except TimeStamp, Level and LoggerName,
            all fields of LoggingEvent are filled when actually needed. Call
            [M:FixVolatileData()] to cache all data locally
            to prevent inconsistencies.

This method is called by the log4net framework
            to create a logging event.

See Also
LoggingEvent Class
LoggingEvent Members
LoggingEvent Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent Fields

LoggingEvent Fields Apache log4net™ SDK Documentation
The LoggingEvent type exposes the following members.
Fields
Name | Description
HostNameProperty | The key into the Properties map for the host name value.
IdentityProperty | The key into the Properties map for the thread identity value.
UserNameProperty | The key into the Properties map for the user name value.
Back to Top
See Also
LoggingEvent Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.HostNameProperty Field

LoggingEvent HostNameProperty Field Apache log4net™ SDK Documentation
The key into the Properties map for the host name value.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HostNameProperty
public const string HostNameProperty
Public Const HostNameProperty As String
Public Const HostNameProperty As String
public:
literal String^ HostNameProperty
public:
literal String^ HostNameProperty
Field Value
Type:   Online String
See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.IdentityProperty Field

LoggingEvent IdentityProperty Field Apache log4net™ SDK Documentation
The key into the Properties map for the thread identity value.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string IdentityProperty
public const string IdentityProperty
Public Const IdentityProperty As String
Public Const IdentityProperty As String
public:
literal String^ IdentityProperty
public:
literal String^ IdentityProperty
Field Value
Type:   Online String
See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.UserNameProperty Field

LoggingEvent UserNameProperty Field Apache log4net™ SDK Documentation
The key into the Properties map for the user name value.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UserNameProperty
public const string UserNameProperty
Public Const UserNameProperty As String
Public Const UserNameProperty As String
public:
literal String^ UserNameProperty
public:
literal String^ UserNameProperty
Field Value
Type:   Online String
See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent Methods

LoggingEvent Methods Apache log4net™ SDK Documentation
The LoggingEvent type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FixVolatileData | Obsolete. Fix instance fields that hold volatile data.
Public method | FixVolatileData(Boolean) | Obsolete. Fixes instance fields that hold volatile data.
Protected method | FixVolatileData(FixFlags) | Fix the fields specified by the FixFlags parameter
Public method | GetExceptionString | Returns this event's exception's rendered using the RendererMap.
Public method | GetExceptionStrRep | Obsolete. Returns this event's exception's rendered using the RendererMap.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLoggingEventData | Gets the portable data for this LoggingEvent.
Public method | GetLoggingEventData(FixFlags) | Gets the portable data for this LoggingEvent.
Public method | GetObjectData | Serializes this object into the Online SerializationInfo provided.
Public method | GetProperties | Get all the composite properties in this event
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LookupProperty | Lookup a composite property in this event
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteRenderedMessage | Write the rendered message to a TextWriter
Back to Top
See Also
LoggingEvent Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.FixVolatileData Method

LoggingEvent FixVolatileData Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | FixVolatileData | Obsolete. Fix instance fields that hold volatile data.
Public method | FixVolatileData(Boolean) | Obsolete. Fixes instance fields that hold volatile data.
Protected method | FixVolatileData(FixFlags) | Fix the fields specified by the FixFlags parameter
Back to Top
See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.FixVolatileData Method

LoggingEvent FixVolatileData Method Apache log4net™ SDK Documentation
Fix instance fields that hold volatile data.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Fix property")]
public void FixVolatileData()
[ObsoleteAttribute("Use Fix property")]
public void FixVolatileData()
<ObsoleteAttribute("Use Fix property")>
Public Sub FixVolatileData
<ObsoleteAttribute("Use Fix property")>
Public Sub FixVolatileData
public:
[ObsoleteAttribute(L"Use Fix property")]
void FixVolatileData()
public:
[ObsoleteAttribute(L"Use Fix property")]
void FixVolatileData()
Remarks

            Some of the values in instances of LoggingEvent
            are considered volatile, that is the values are correct at the
            time the event is delivered to appenders, but will not be consistent
            at any time afterwards. If an event is to be stored and then processed
            at a later time these volatile values must be fixed by calling
            [M:FixVolatileData()]. There is a performance penalty
            incurred by calling [M:FixVolatileData()] but it
            is essential to maintaining data consistency.

            Calling [M:FixVolatileData()] is equivalent to
            calling [M:FixVolatileData(bool)] passing the parameter
            false.

            See [M:FixVolatileData(bool)] for more
            information.

See Also
LoggingEvent Class
LoggingEvent Members
FixVolatileData Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.FixVolatileData Method (Boolean)

LoggingEvent FixVolatileData Method (Boolean) Apache log4net™ SDK Documentation
Fixes instance fields that hold volatile data.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Fix property")]
public void FixVolatileData(
    bool fastButLoose
)
[ObsoleteAttribute("Use Fix property")]
public void FixVolatileData(
    bool fastButLoose
)
<ObsoleteAttribute("Use Fix property")>
Public Sub FixVolatileData (
    fastButLoose As Boolean
)
<ObsoleteAttribute("Use Fix property")>
Public Sub FixVolatileData (
    fastButLoose As Boolean
)
public:
[ObsoleteAttribute(L"Use Fix property")]
void FixVolatileData(
    bool fastButLoose
)
public:
[ObsoleteAttribute(L"Use Fix property")]
void FixVolatileData(
    bool fastButLoose
)
Parameters
fastButLoose
Type:   Online System Boolean
Set to true to not fix data that takes a long time to fix.
Remarks

            Some of the values in instances of LoggingEvent
            are considered volatile, that is the values are correct at the
            time the event is delivered to appenders, but will not be consistent
            at any time afterwards. If an event is to be stored and then processed
            at a later time these volatile values must be fixed by calling
            [M:FixVolatileData()]. There is a performance penalty
            for incurred by calling [M:FixVolatileData()] but it
            is essential to maintaining data consistency.

            The fastButLoose param controls the data that
            is fixed. Some of the data that can be fixed takes a long time to
            generate, therefore if you do not require those settings to be fixed
            they can be ignored by setting the fastButLoose param
            to true. This setting will ignore the LocationInformation
            and UserName settings.

            Set fastButLoose to false to ensure that all
            settings are fixed.

See Also
LoggingEvent Class
LoggingEvent Members
FixVolatileData Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.FixVolatileData Method (FixFlags)

LoggingEvent FixVolatileData Method (FixFlags) Apache log4net™ SDK Documentation
Fix the fields specified by the FixFlags parameter

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void FixVolatileData(
    FixFlags flags
)
protected void FixVolatileData(
    FixFlags flags
)
Protected Sub FixVolatileData (
    flags As FixFlags
)
Protected Sub FixVolatileData (
    flags As FixFlags
)
protected:
void FixVolatileData(
    FixFlags flags
)
protected:
void FixVolatileData(
    FixFlags flags
)
Parameters
flags
Type: log4net.Core FixFlags
the fields to fix
Remarks

            Only fields specified in the flags will be fixed.
            Fields will not be fixed if they have previously been fixed.
            It is not possible to 'unfix' a field.

See Also
LoggingEvent Class
LoggingEvent Members
FixVolatileData Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.GetExceptionString Method

LoggingEvent GetExceptionString Method Apache log4net™ SDK Documentation
Returns this event's exception's rendered using the RendererMap.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetExceptionString()
public string GetExceptionString()
Public Function GetExceptionString As String
Public Function GetExceptionString As String
public:
String^ GetExceptionString()
public:
String^ GetExceptionString()
Return Value
Type:   Online String

            This event's exception's rendered using the RendererMap.

Remarks

            Returns this event's exception's rendered using the
            RendererMap.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.GetExceptionStrRep Method

LoggingEvent GetExceptionStrRep Method Apache log4net™ SDK Documentation
Returns this event's exception's rendered using the RendererMap.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use GetExceptionString instead")]
public string GetExceptionStrRep()
[ObsoleteAttribute("Use GetExceptionString instead")]
public string GetExceptionStrRep()
<ObsoleteAttribute("Use GetExceptionString instead")>
Public Function GetExceptionStrRep As String
<ObsoleteAttribute("Use GetExceptionString instead")>
Public Function GetExceptionStrRep As String
public:
[ObsoleteAttribute(L"Use GetExceptionString instead")]
String^ GetExceptionStrRep()
public:
[ObsoleteAttribute(L"Use GetExceptionString instead")]
String^ GetExceptionStrRep()
Return Value
Type:   Online String

            This event's exception's rendered using the RendererMap.

Remarks
Obsolete. Use GetExceptionString  instead.
See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.GetLoggingEventData Method

LoggingEvent GetLoggingEventData Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | GetLoggingEventData | Gets the portable data for this LoggingEvent.
Public method | GetLoggingEventData(FixFlags) | Gets the portable data for this LoggingEvent.
Back to Top
See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.GetLoggingEventData Method

LoggingEvent GetLoggingEventData Method Apache log4net™ SDK Documentation
Gets the portable data for this LoggingEvent.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingEventData GetLoggingEventData()
public LoggingEventData GetLoggingEventData()
Public Function GetLoggingEventData As LoggingEventData
Public Function GetLoggingEventData As LoggingEventData
public:
LoggingEventData GetLoggingEventData()
public:
LoggingEventData GetLoggingEventData()
Return Value
Type: LoggingEventData
The LoggingEventData for this event.
Remarks

            A new LoggingEvent can be constructed using a
            LoggingEventData instance.

            Does a Partial fix of the data
            in the logging event before returning the event data.

See Also
LoggingEvent Class
LoggingEvent Members
GetLoggingEventData Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.GetLoggingEventData Method (FixFlags)

LoggingEvent GetLoggingEventData Method (FixFlags) Apache log4net™ SDK Documentation
Gets the portable data for this LoggingEvent.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingEventData GetLoggingEventData(
    FixFlags fixFlags
)
public LoggingEventData GetLoggingEventData(
    FixFlags fixFlags
)
Public Function GetLoggingEventData (
    fixFlags As FixFlags
) As LoggingEventData
Public Function GetLoggingEventData (
    fixFlags As FixFlags
) As LoggingEventData
public:
LoggingEventData GetLoggingEventData(
    FixFlags fixFlags
)
public:
LoggingEventData GetLoggingEventData(
    FixFlags fixFlags
)
Parameters
fixFlags
Type: log4net.Core FixFlags
The set of data to ensure is fixed in the LoggingEventData
Return Value
Type: LoggingEventData
The LoggingEventData for this event.
Remarks

            A new LoggingEvent can be constructed using a
            LoggingEventData instance.

See Also
LoggingEvent Class
LoggingEvent Members
GetLoggingEventData Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.GetObjectData Method

LoggingEvent GetObjectData Method Apache log4net™ SDK Documentation
Serializes this object into the Online SerializationInfo provided.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The   Online SerializationInfo to populate with data.
context
Type:   Online System.Runtime.Serialization StreamingContext
The destination for this serialization.
Implements
  Online ISerializable GetObjectData(SerializationInfo, StreamingContext)
Remarks

            The data in this event must be fixed before it can be serialized.

            The [M:FixVolatileData()] method must be called during the
            DoAppend(LoggingEvent) method call if this event
            is to be used outside that method.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.GetProperties Method

LoggingEvent GetProperties Method Apache log4net™ SDK Documentation
Get all the composite properties in this event

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PropertiesDictionary GetProperties()
public PropertiesDictionary GetProperties()
Public Function GetProperties As PropertiesDictionary
Public Function GetProperties As PropertiesDictionary
public:
PropertiesDictionary^ GetProperties()
public:
PropertiesDictionary^ GetProperties()
Return Value
Type: PropertiesDictionary
the PropertiesDictionary containing all the properties
Remarks

            See LookupProperty(String) for details of the composite properties
            stored by the event.

            This method returns a single PropertiesDictionary containing all the
            properties defined for this event.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.LookupProperty Method

LoggingEvent LookupProperty Method Apache log4net™ SDK Documentation
Lookup a composite property in this event

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object LookupProperty(
    string key
)
public Object LookupProperty(
    string key
)
Public Function LookupProperty (
    key As String
) As Object
Public Function LookupProperty (
    key As String
) As Object
public:
Object^ LookupProperty(
    String^ key
)
public:
Object^ LookupProperty(
    String^ key
)
Parameters
key
Type:   Online System String
the key for the property to lookup
Return Value
Type:   Online Object
the value for the property
Remarks

            This event has composite properties that combine together properties from
            several different contexts in the following order:

this events properties

                    This event has Properties that can be set. These
                    properties are specific to this event only.

the thread properties

                    The Properties that are set on the current
                    thread. These properties are shared by all events logged on this thread.

the global properties

                    The Properties that are set globally. These
                    properties are shared by all the threads in the AppDomain.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.WriteRenderedMessage Method

LoggingEvent WriteRenderedMessage Method Apache log4net™ SDK Documentation
Write the rendered message to a TextWriter

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteRenderedMessage(
    TextWriter writer
)
public void WriteRenderedMessage(
    TextWriter writer
)
Public Sub WriteRenderedMessage (
    writer As TextWriter
)
Public Sub WriteRenderedMessage (
    writer As TextWriter
)
public:
void WriteRenderedMessage(
    TextWriter^ writer
)
public:
void WriteRenderedMessage(
    TextWriter^ writer
)
Parameters
writer
Type:   Online System.IO TextWriter
the writer to write the message to
Remarks

            Unlike the RenderedMessage property this method
            does store the message data in the internal cache. Therefore
            if called only once this method should be faster than the
            RenderedMessage property, however if the message is
            to be accessed multiple times then the property will be more efficient.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent Properties

LoggingEvent Properties Apache log4net™ SDK Documentation
The LoggingEvent type exposes the following members.
Properties
 | Name | Description
Public property | Domain | Gets the AppDomain friendly name.
Public property | ExceptionObject | Gets the exception object used to initialize this event.
Public property | Fix | The fixed fields in this event
Public property | Identity | Gets the identity of the current thread principal.
Public property | Level | Gets the Level of the logging event.
Public property | LocationInformation | Gets the location information for this logging event.
Public property | LoggerName | Gets the name of the logger that logged the event.
Public property | MessageObject | Gets the message object used to initialize this event.
Public property | Properties | Additional event specific properties.
Public property | RenderedMessage | Gets the message, rendered through the RendererMap.
Public property | Repository | The ILoggerRepository that this event was created in.
 | StartTime | Gets the time when the current process started.
Public property | ThreadName | Gets the name of the current thread.
Public property | TimeStamp | Gets the time of the logging event.
Public property | UserName | Gets the name of the current user.
Back to Top
See Also
LoggingEvent Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.Domain Property

LoggingEvent Domain Property Apache log4net™ SDK Documentation
Gets the AppDomain friendly name.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Domain { get; }
public string Domain { get; }
Public ReadOnly Property Domain As String
    Get
Public ReadOnly Property Domain As String
    Get
public:
property String^ Domain {
    String^ get ();
}
public:
property String^ Domain {
    String^ get ();
}
Property Value
Type:   Online String

            The AppDomain friendly name.

Remarks

            Gets the AppDomain friendly name.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.ExceptionObject Property

LoggingEvent ExceptionObject Property Apache log4net™ SDK Documentation
Gets the exception object used to initialize this event.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception ExceptionObject { get; }
public Exception ExceptionObject { get; }
Public ReadOnly Property ExceptionObject As Exception
    Get
Public ReadOnly Property ExceptionObject As Exception
    Get
public:
property Exception^ ExceptionObject {
    Exception^ get ();
}
public:
property Exception^ ExceptionObject {
    Exception^ get ();
}
Property Value
Type:   Online Exception

            The exception object used to initialize this event.

Remarks

            Gets the exception object used to initialize this event.
            Note that this event may not have a valid exception object.
            If the event is serialized the exception object will not
            be transferred. To get the text of the exception the
            GetExceptionString  method must be used
            not this property.

            If there is no defined exception object for this event then
            null will be returned.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.Fix Property

LoggingEvent Fix Property Apache log4net™ SDK Documentation
The fixed fields in this event

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FixFlags Fix { get; set; }
public FixFlags Fix { get; set; }
Public Property Fix As FixFlags
    Get
    Set
Public Property Fix As FixFlags
    Get
    Set
public:
property FixFlags Fix {
    FixFlags get ();
    void set (FixFlags value);
}
public:
property FixFlags Fix {
    FixFlags get ();
    void set (FixFlags value);
}
Property Value
Type: FixFlags

            The set of fields that are fixed in this event

Remarks

            Fields will not be fixed if they have previously been fixed.
            It is not possible to 'unfix' a field.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.Identity Property

LoggingEvent Identity Property Apache log4net™ SDK Documentation
Gets the identity of the current thread principal.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Identity { get; }
public string Identity { get; }
Public ReadOnly Property Identity As String
    Get
Public ReadOnly Property Identity As String
    Get
public:
property String^ Identity {
    String^ get ();
}
public:
property String^ Identity {
    String^ get ();
}
Property Value
Type:   Online String

            The string name of the identity of the current thread principal.

Remarks

            Calls System.Threading.Thread.CurrentPrincipal.Identity.Name to get
            the name of the current thread principal.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.Level Property

LoggingEvent Level Property Apache log4net™ SDK Documentation
Gets the Level of the logging event.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level Level { get; }
public Level Level { get; }
Public ReadOnly Property Level As Level
    Get
Public ReadOnly Property Level As Level
    Get
public:
property Level^ Level {
    Level^ get ();
}
public:
property Level^ Level {
    Level^ get ();
}
Property Value
Type: Level

            The Level of the logging event.

Remarks

            Gets the Level of the logging event.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.LocationInformation Property

LoggingEvent LocationInformation Property Apache log4net™ SDK Documentation
Gets the location information for this logging event.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocationInfo LocationInformation { get; }
public LocationInfo LocationInformation { get; }
Public ReadOnly Property LocationInformation As LocationInfo
    Get
Public ReadOnly Property LocationInformation As LocationInfo
    Get
public:
property LocationInfo^ LocationInformation {
    LocationInfo^ get ();
}
public:
property LocationInfo^ LocationInformation {
    LocationInfo^ get ();
}
Property Value
Type: LocationInfo

            The location information for this logging event.

Remarks

            The collected information is cached for future use.

            See the LocationInfo class for more information on
            supported frameworks and the different behavior in Debug and
            Release builds.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.LoggerName Property

LoggingEvent LoggerName Property Apache log4net™ SDK Documentation
Gets the name of the logger that logged the event.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LoggerName { get; }
public string LoggerName { get; }
Public ReadOnly Property LoggerName As String
    Get
Public ReadOnly Property LoggerName As String
    Get
public:
property String^ LoggerName {
    String^ get ();
}
public:
property String^ LoggerName {
    String^ get ();
}
Property Value
Type:   Online String

            The name of the logger that logged the event.

Remarks

            Gets the name of the logger that logged the event.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.MessageObject Property

LoggingEvent MessageObject Property Apache log4net™ SDK Documentation
Gets the message object used to initialize this event.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object MessageObject { get; }
public Object MessageObject { get; }
Public ReadOnly Property MessageObject As Object
    Get
Public ReadOnly Property MessageObject As Object
    Get
public:
property Object^ MessageObject {
    Object^ get ();
}
public:
property Object^ MessageObject {
    Object^ get ();
}
Property Value
Type:   Online Object

            The message object used to initialize this event.

Remarks

            Gets the message object used to initialize this event.
            Note that this event may not have a valid message object.
            If the event is serialized the message object will not
            be transferred. To get the text of the message the
            RenderedMessage property must be used
            not this property.

            If there is no defined message object for this event then
            null will be returned.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.Properties Property

LoggingEvent Properties Property Apache log4net™ SDK Documentation
Additional event specific properties.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PropertiesDictionary Properties { get; }
public PropertiesDictionary Properties { get; }
Public ReadOnly Property Properties As PropertiesDictionary
    Get
Public ReadOnly Property Properties As PropertiesDictionary
    Get
public:
property PropertiesDictionary^ Properties {
    PropertiesDictionary^ get ();
}
public:
property PropertiesDictionary^ Properties {
    PropertiesDictionary^ get ();
}
Property Value
Type: PropertiesDictionary

            Additional event specific properties.

Remarks

            A logger or an appender may attach additional
            properties to specific events. These properties
            have a string key and an object value.

            This property is for events that have been added directly to
            this event. The aggregate properties (which include these
            event properties) can be retrieved using LookupProperty(String)
            and GetProperties .

            Once the properties have been fixed Fix this property
            returns the combined cached properties. This ensures that updates to
            this property are always reflected in the underlying storage. When
            returning the combined properties there may be more keys in the
            Dictionary than expected.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.RenderedMessage Property

LoggingEvent RenderedMessage Property Apache log4net™ SDK Documentation
Gets the message, rendered through the RendererMap.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RenderedMessage { get; }
public string RenderedMessage { get; }
Public ReadOnly Property RenderedMessage As String
    Get
Public ReadOnly Property RenderedMessage As String
    Get
public:
property String^ RenderedMessage {
    String^ get ();
}
public:
property String^ RenderedMessage {
    String^ get ();
}
Property Value
Type:   Online String

            The message rendered through the RendererMap.

Remarks

            The collected information is cached for future use.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.Repository Property

LoggingEvent Repository Property Apache log4net™ SDK Documentation
The ILoggerRepository that this event was created in.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository Repository { get; }
public ILoggerRepository Repository { get; }
Public ReadOnly Property Repository As ILoggerRepository
    Get
Public ReadOnly Property Repository As ILoggerRepository
    Get
public:
property ILoggerRepository^ Repository {
    ILoggerRepository^ get ();
}
public:
property ILoggerRepository^ Repository {
    ILoggerRepository^ get ();
}
Property Value
Type: ILoggerRepository
Remarks

            The ILoggerRepository that this event was created in.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.StartTime Property

LoggingEvent StartTime Property Apache log4net™ SDK Documentation
Gets the time when the current process started.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime StartTime { get; }
public static DateTime StartTime { get; }
Public Shared ReadOnly Property StartTime As DateTime
    Get
Public Shared ReadOnly Property StartTime As DateTime
    Get
public:
static property DateTime StartTime {
    DateTime get ();
}
public:
static property DateTime StartTime {
    DateTime get ();
}
Property Value
Type:   Online DateTime

            This is the time when this process started.

Remarks

            The TimeStamp is stored in the local time zone for this computer.

            Tries to get the start time for the current process.
            Failing that it returns the time of the first call to
            this property.

            Note that AppDomains may be loaded and unloaded within the
            same process without the process terminating and therefore
            without the process start time being reset.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.ThreadName Property

LoggingEvent ThreadName Property Apache log4net™ SDK Documentation
Gets the name of the current thread.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ThreadName { get; }
public string ThreadName { get; }
Public ReadOnly Property ThreadName As String
    Get
Public ReadOnly Property ThreadName As String
    Get
public:
property String^ ThreadName {
    String^ get ();
}
public:
property String^ ThreadName {
    String^ get ();
}
Property Value
Type:   Online String

            The name of the current thread, or the thread ID when
            the name is not available.

Remarks

            The collected information is cached for future use.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.TimeStamp Property

LoggingEvent TimeStamp Property Apache log4net™ SDK Documentation
Gets the time of the logging event.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime TimeStamp { get; }
public DateTime TimeStamp { get; }
Public ReadOnly Property TimeStamp As DateTime
    Get
Public ReadOnly Property TimeStamp As DateTime
    Get
public:
property DateTime TimeStamp {
    DateTime get ();
}
public:
property DateTime TimeStamp {
    DateTime get ();
}
Property Value
Type:   Online DateTime

            The time of the logging event.

Remarks

            The TimeStamp is stored in the local time zone for this computer.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEvent.UserName Property

LoggingEvent UserName Property Apache log4net™ SDK Documentation
Gets the name of the current user.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UserName { get; }
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get
Public ReadOnly Property UserName As String
    Get
public:
property String^ UserName {
    String^ get ();
}
public:
property String^ UserName {
    String^ get ();
}
Property Value
Type:   Online String

            The name of the current user, or NOT AVAILABLE when the
            underlying runtime has no support for retrieving the name of the
            current user.

Remarks

            Calls WindowsIdentity.GetCurrent().Name to get the name of
            the current windows user.

            To improve performance, we could cache the string representation of
            the name, and reuse that as long as the identity stayed constant.
            Once the identity changed, we would need to re-assign and re-render
            the string.

            However, the WindowsIdentity.GetCurrent() call seems to
            return different objects every time, so the current implementation
            doesn't do this type of caching.

            Timing for these operations:

Method | Results
WindowsIdentity.GetCurrent() | 10000 loops, 00:00:00.2031250 seconds
WindowsIdentity.GetCurrent().Name | 10000 loops, 00:00:08.0468750 seconds

            This means we could speed things up almost 40 times by caching the
            value of the WindowsIdentity.GetCurrent().Name property, since
            this takes (8.04-0.20) = 7.84375 seconds.

See Also
LoggingEvent Class
LoggingEvent Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData Structure

LoggingEventData Structure Apache log4net™ SDK Documentation
Portable data structure used by LoggingEvent

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct LoggingEventData
public struct LoggingEventData
Public Structure LoggingEventData
Public Structure LoggingEventData
public value class LoggingEventData
public value class LoggingEventData
Remarks

            Portable data structure used by LoggingEvent
See Also
LoggingEventData Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData Members

LoggingEventData Members Apache log4net™ SDK Documentation
The LoggingEventData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Fields
 | Name | Description
Public field | Domain | String representation of the AppDomain.
Public field | ExceptionString | The string representation of the exception
Public field | Identity | String representation of the identity.
Public field | Level | Level of logging event.
Public field | LocationInfo | Location information for the caller.
Public field | LoggerName | The logger name.
Public field | Message | The application supplied message.
Public field | Properties | Additional event specific properties
Public field | ThreadName | The name of thread
Public field | TimeStamp | The time the event was logged
Public field | UserName | String representation of the user
Back to Top
See Also
LoggingEventData Structure
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData Fields

LoggingEventData Fields Apache log4net™ SDK Documentation
The LoggingEventData type exposes the following members.
Fields
 | Name | Description
Public field | Domain | String representation of the AppDomain.
Public field | ExceptionString | The string representation of the exception
Public field | Identity | String representation of the identity.
Public field | Level | Level of logging event.
Public field | LocationInfo | Location information for the caller.
Public field | LoggerName | The logger name.
Public field | Message | The application supplied message.
Public field | Properties | Additional event specific properties
Public field | ThreadName | The name of thread
Public field | TimeStamp | The time the event was logged
Public field | UserName | String representation of the user
Back to Top
See Also
LoggingEventData Structure
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData.Domain Field

LoggingEventData Domain Field Apache log4net™ SDK Documentation
String representation of the AppDomain.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Domain
public string Domain
Public Domain As String
Public Domain As String
public:
String^ Domain
public:
String^ Domain
Field Value
Type:   Online String
Remarks

            String representation of the AppDomain.

See Also
LoggingEventData Structure
LoggingEventData Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData.ExceptionString Field

LoggingEventData ExceptionString Field Apache log4net™ SDK Documentation
The string representation of the exception

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ExceptionString
public string ExceptionString
Public ExceptionString As String
Public ExceptionString As String
public:
String^ ExceptionString
public:
String^ ExceptionString
Field Value
Type:   Online String
Remarks

            The string representation of the exception

See Also
LoggingEventData Structure
LoggingEventData Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData.Identity Field

LoggingEventData Identity Field Apache log4net™ SDK Documentation
String representation of the identity.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Identity
public string Identity
Public Identity As String
Public Identity As String
public:
String^ Identity
public:
String^ Identity
Field Value
Type:   Online String
Remarks

            String representation of the current thread's principal identity.

See Also
LoggingEventData Structure
LoggingEventData Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData.Level Field

LoggingEventData Level Field Apache log4net™ SDK Documentation
Level of logging event.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level Level
public Level Level
Public Level As Level
Public Level As Level
public:
Level^ Level
public:
Level^ Level
Field Value
Type: Level
Remarks

            Level of logging event. Level cannot be Serializable
            because it is a flyweight.  Due to its special serialization it
            cannot be declared final either.

See Also
LoggingEventData Structure
LoggingEventData Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData.LocationInfo Field

LoggingEventData LocationInfo Field Apache log4net™ SDK Documentation
Location information for the caller.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocationInfo LocationInfo
public LocationInfo LocationInfo
Public LocationInfo As LocationInfo
Public LocationInfo As LocationInfo
public:
LocationInfo^ LocationInfo
public:
LocationInfo^ LocationInfo
Field Value
Type: LocationInfo
Remarks

            Location information for the caller.

See Also
LoggingEventData Structure
LoggingEventData Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData.LoggerName Field

LoggingEventData LoggerName Field Apache log4net™ SDK Documentation
The logger name.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LoggerName
public string LoggerName
Public LoggerName As String
Public LoggerName As String
public:
String^ LoggerName
public:
String^ LoggerName
Field Value
Type:   Online String
Remarks

            The logger name.

See Also
LoggingEventData Structure
LoggingEventData Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData.Message Field

LoggingEventData Message Field Apache log4net™ SDK Documentation
The application supplied message.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Message
public string Message
Public Message As String
Public Message As String
public:
String^ Message
public:
String^ Message
Field Value
Type:   Online String
Remarks

            The application supplied message of logging event.

See Also
LoggingEventData Structure
LoggingEventData Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData.Properties Field

LoggingEventData Properties Field Apache log4net™ SDK Documentation
Additional event specific properties

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PropertiesDictionary Properties
public PropertiesDictionary Properties
Public Properties As PropertiesDictionary
Public Properties As PropertiesDictionary
public:
PropertiesDictionary^ Properties
public:
PropertiesDictionary^ Properties
Field Value
Type: PropertiesDictionary
Remarks

            A logger or an appender may attach additional
            properties to specific events. These properties
            have a string key and an object value.

See Also
LoggingEventData Structure
LoggingEventData Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData.ThreadName Field

LoggingEventData ThreadName Field Apache log4net™ SDK Documentation
The name of thread

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ThreadName
public string ThreadName
Public ThreadName As String
Public ThreadName As String
public:
String^ ThreadName
public:
String^ ThreadName
Field Value
Type:   Online String
Remarks

            The name of thread in which this logging event was generated

See Also
LoggingEventData Structure
LoggingEventData Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData.TimeStamp Field

LoggingEventData TimeStamp Field Apache log4net™ SDK Documentation
The time the event was logged

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime TimeStamp
public DateTime TimeStamp
Public TimeStamp As DateTime
Public TimeStamp As DateTime
public:
DateTime TimeStamp
public:
DateTime TimeStamp
Field Value
Type:   Online DateTime
Remarks

            The TimeStamp is stored in the local time zone for this computer.

See Also
LoggingEventData Structure
LoggingEventData Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData.UserName Field

LoggingEventData UserName Field Apache log4net™ SDK Documentation
String representation of the user

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UserName
public string UserName
Public UserName As String
Public UserName As String
public:
String^ UserName
public:
String^ UserName
Field Value
Type:   Online String
Remarks

            String representation of the user's windows name,
            like DOMAIN\username

See Also
LoggingEventData Structure
LoggingEventData Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggingEventData Methods

LoggingEventData Methods Apache log4net™ SDK Documentation
The LoggingEventData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
See Also
LoggingEventData Structure
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl Class

LogImpl Class Apache log4net™ SDK Documentation
Implementation of ILog wrapper interface.
Inheritance Hierarchy
Online System Object
log4net.Core LoggerWrapperImpl
log4net.Core LogImpl

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LogImpl : LoggerWrapperImpl, ILog,
    ILoggerWrapper
public class LogImpl : LoggerWrapperImpl, ILog,
    ILoggerWrapper
Public Class LogImpl
    Inherits LoggerWrapperImpl
    Implements ILog, ILoggerWrapper
Public Class LogImpl
    Inherits LoggerWrapperImpl
    Implements ILog, ILoggerWrapper
public ref class LogImpl : public LoggerWrapperImpl,
    ILog, ILoggerWrapper
public ref class LogImpl : public LoggerWrapperImpl,
    ILog, ILoggerWrapper
Remarks

            This implementation of the ILog interface
            forwards to the ILogger held by the base class.

            This logger has methods to allow the caller to log at the following
            levels:

DEBUG

                The [M:Debug(object)] and [M:DebugFormat(string, object[])] methods log messages
                at the DEBUG level. That is the level with that name defined in the
                repositories LevelMap. The default value
                for this level is Debug. The IsDebugEnabled
                property tests if this level is enabled for logging.

INFO

                The [M:Info(object)] and [M:InfoFormat(string, object[])] methods log messages
                at the INFO level. That is the level with that name defined in the
                repositories LevelMap. The default value
                for this level is Info. The IsInfoEnabled
                property tests if this level is enabled for logging.

WARN

                The [M:Warn(object)] and [M:WarnFormat(string, object[])] methods log messages
                at the WARN level. That is the level with that name defined in the
                repositories LevelMap. The default value
                for this level is Warn. The IsWarnEnabled
                property tests if this level is enabled for logging.

ERROR

                The [M:Error(object)] and [M:ErrorFormat(string, object[])] methods log messages
                at the ERROR level. That is the level with that name defined in the
                repositories LevelMap. The default value
                for this level is Error. The IsErrorEnabled
                property tests if this level is enabled for logging.

FATAL

                The [M:Fatal(object)] and [M:FatalFormat(string, object[])] methods log messages
                at the FATAL level. That is the level with that name defined in the
                repositories LevelMap. The default value
                for this level is Fatal. The IsFatalEnabled
                property tests if this level is enabled for logging.

            The values for these levels and their semantic meanings can be changed by
            configuring the LevelMap for the repository.

See Also
LogImpl Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl Members

LogImpl Members Apache log4net™ SDK Documentation
The LogImpl type exposes the following members.
Constructors
 | Name | Description
Public method | LogImpl | Construct a new wrapper for the specified logger.
Back to Top
Methods
 | Name | Description
Public method | Debug(Object) | Logs a message object with the DEBUG level.
Public method | Debug(Object, Exception) | Logs a message object with the DEBUG level
Public method | DebugFormat(String, Object) | Logs a formatted message string with the DEBUG level.
Public method | DebugFormat(String, Object ) | Logs a formatted message string with the DEBUG level.
Public method | DebugFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the DEBUG level.
Public method | DebugFormat(String, Object, Object) | Logs a formatted message string with the DEBUG level.
Public method | DebugFormat(String, Object, Object, Object) | Logs a formatted message string with the DEBUG level.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Error(Object) | Logs a message object with the ERROR level.
Public method | Error(Object, Exception) | Logs a message object with the ERROR level
Public method | ErrorFormat(String, Object) | Logs a formatted message string with the ERROR level.
Public method | ErrorFormat(String, Object ) | Logs a formatted message string with the ERROR level.
Public method | ErrorFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the ERROR level.
Public method | ErrorFormat(String, Object, Object) | Logs a formatted message string with the ERROR level.
Public method | ErrorFormat(String, Object, Object, Object) | Logs a formatted message string with the ERROR level.
Public method | Fatal(Object) | Logs a message object with the FATAL level.
Public method | Fatal(Object, Exception) | Logs a message object with the FATAL level
Public method | FatalFormat(String, Object) | Logs a formatted message string with the FATAL level.
Public method | FatalFormat(String, Object ) | Logs a formatted message string with the FATAL level.
Public method | FatalFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the FATAL level.
Public method | FatalFormat(String, Object, Object) | Logs a formatted message string with the FATAL level.
Public method | FatalFormat(String, Object, Object, Object) | Logs a formatted message string with the FATAL level.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Info(Object) | Logs a message object with the INFO level.
Public method | Info(Object, Exception) | Logs a message object with the INFO level.
Public method | InfoFormat(String, Object) | Logs a formatted message string with the INFO level.
Public method | InfoFormat(String, Object ) | Logs a formatted message string with the INFO level.
Public method | InfoFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the INFO level.
Public method | InfoFormat(String, Object, Object) | Logs a formatted message string with the INFO level.
Public method | InfoFormat(String, Object, Object, Object) | Logs a formatted message string with the INFO level.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReloadLevels | Virtual method called when the configuration of the repository changes
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Warn(Object) | Logs a message object with the WARN level.
Public method | Warn(Object, Exception) | Logs a message object with the WARN level
Public method | WarnFormat(String, Object) | Logs a formatted message string with the WARN level.
Public method | WarnFormat(String, Object ) | Logs a formatted message string with the WARN level.
Public method | WarnFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the WARN level.
Public method | WarnFormat(String, Object, Object) | Logs a formatted message string with the WARN level.
Public method | WarnFormat(String, Object, Object, Object) | Logs a formatted message string with the WARN level.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | DebugExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | DebugExt(Object) | Overloaded. Log a message object with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | DebugExt(Object, Exception) | Overloaded. Log a message object with the Debug level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Object) | Overloaded. Log a message object with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Object, Exception) | Overloaded. Log a message object with the Error level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Object) | Overloaded. Log a message object with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Object, Exception) | Overloaded. Log a message object with the Fatal level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Object) | Overloaded. Log a message object with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Object, Exception) | Overloaded. Log a message object with the Info level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Object) | Overloaded. Log a message object with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Object, Exception) | Overloaded. Log a message object with the Warn level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsDebugEnabled | Checks if this logger is enabled for the DEBUG level.
Public property | IsErrorEnabled | Checks if this logger is enabled for the ERROR level.
Public property | IsFatalEnabled | Checks if this logger is enabled for the FATAL level.
Public property | IsInfoEnabled | Checks if this logger is enabled for the INFO level.
Public property | IsWarnEnabled | Checks if this logger is enabled for the WARN level.
Public property | Logger | Gets the implementation behind this wrapper object. (Inherited from LoggerWrapperImpl.)
Back to Top
See Also
LogImpl Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl Constructor

LogImpl Constructor Apache log4net™ SDK Documentation
Construct a new wrapper for the specified logger.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogImpl(
    ILogger logger
)
public LogImpl(
    ILogger logger
)
Public Sub New (
    logger As ILogger
)
Public Sub New (
    logger As ILogger
)
public:
LogImpl(
    ILogger^ logger
)
public:
LogImpl(
    ILogger^ logger
)
Parameters
logger
Type: log4net.Core ILogger
The logger to wrap.
Remarks

            Construct a new wrapper for the specified logger.

See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl Methods

LogImpl Methods Apache log4net™ SDK Documentation
The LogImpl type exposes the following members.
Methods
 | Name | Description
Public method | Debug(Object) | Logs a message object with the DEBUG level.
Public method | Debug(Object, Exception) | Logs a message object with the DEBUG level
Public method | DebugFormat(String, Object) | Logs a formatted message string with the DEBUG level.
Public method | DebugFormat(String, Object ) | Logs a formatted message string with the DEBUG level.
Public method | DebugFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the DEBUG level.
Public method | DebugFormat(String, Object, Object) | Logs a formatted message string with the DEBUG level.
Public method | DebugFormat(String, Object, Object, Object) | Logs a formatted message string with the DEBUG level.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Error(Object) | Logs a message object with the ERROR level.
Public method | Error(Object, Exception) | Logs a message object with the ERROR level
Public method | ErrorFormat(String, Object) | Logs a formatted message string with the ERROR level.
Public method | ErrorFormat(String, Object ) | Logs a formatted message string with the ERROR level.
Public method | ErrorFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the ERROR level.
Public method | ErrorFormat(String, Object, Object) | Logs a formatted message string with the ERROR level.
Public method | ErrorFormat(String, Object, Object, Object) | Logs a formatted message string with the ERROR level.
Public method | Fatal(Object) | Logs a message object with the FATAL level.
Public method | Fatal(Object, Exception) | Logs a message object with the FATAL level
Public method | FatalFormat(String, Object) | Logs a formatted message string with the FATAL level.
Public method | FatalFormat(String, Object ) | Logs a formatted message string with the FATAL level.
Public method | FatalFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the FATAL level.
Public method | FatalFormat(String, Object, Object) | Logs a formatted message string with the FATAL level.
Public method | FatalFormat(String, Object, Object, Object) | Logs a formatted message string with the FATAL level.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Info(Object) | Logs a message object with the INFO level.
Public method | Info(Object, Exception) | Logs a message object with the INFO level.
Public method | InfoFormat(String, Object) | Logs a formatted message string with the INFO level.
Public method | InfoFormat(String, Object ) | Logs a formatted message string with the INFO level.
Public method | InfoFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the INFO level.
Public method | InfoFormat(String, Object, Object) | Logs a formatted message string with the INFO level.
Public method | InfoFormat(String, Object, Object, Object) | Logs a formatted message string with the INFO level.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReloadLevels | Virtual method called when the configuration of the repository changes
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Warn(Object) | Logs a message object with the WARN level.
Public method | Warn(Object, Exception) | Logs a message object with the WARN level
Public method | WarnFormat(String, Object) | Logs a formatted message string with the WARN level.
Public method | WarnFormat(String, Object ) | Logs a formatted message string with the WARN level.
Public method | WarnFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the WARN level.
Public method | WarnFormat(String, Object, Object) | Logs a formatted message string with the WARN level.
Public method | WarnFormat(String, Object, Object, Object) | Logs a formatted message string with the WARN level.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | DebugExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | DebugExt(Object) | Overloaded. Log a message object with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | DebugExt(Object, Exception) | Overloaded. Log a message object with the Debug level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | DebugFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Debug level. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Object) | Overloaded. Log a message object with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | ErrorExt(Object, Exception) | Overloaded. Log a message object with the Error level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | ErrorFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Error level. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Object) | Overloaded. Log a message object with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | FatalExt(Object, Exception) | Overloaded. Log a message object with the Fatal level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | FatalFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Fatal level. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Object) | Overloaded. Log a message object with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | InfoExt(Object, Exception) | Overloaded. Log a message object with the Info level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | InfoFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Info level. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Func TResult ) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Object) | Overloaded. Log a message object with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Func TResult , Void) | Overloaded. (Defined by ILogExtensions.)
Public Extension Method | WarnExt(Object, Exception) | Overloaded. Log a message object with the Warn level including the stack trace of the Online Exception passed as a parameter. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object ) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(IFormatProvider, String, Object ) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object, Object) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Public Extension Method | WarnFormatExt(String, Object, Object, Object) | Overloaded. Logs a formatted message string with the Warn level. (Defined by ILogExtensions.)
Back to Top
See Also
LogImpl Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Debug Method

LogImpl Debug Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Debug(Object) | Logs a message object with the DEBUG level.
Public method | Debug(Object, Exception) | Logs a message object with the DEBUG level
Back to Top
See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Debug Method (Object)

LogImpl Debug Method (Object) Apache log4net™ SDK Documentation
Logs a message object with the DEBUG level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Debug(
    Object message
)
public virtual void Debug(
    Object message
)
Public Overridable Sub Debug (
    message As Object
)
Public Overridable Sub Debug (
    message As Object
)
public:
virtual void Debug(
    Object^ message
)
public:
virtual void Debug(
    Object^ message
)
Parameters
message
Type:   Online System Object
The message object to log.
Implements
ILog Debug(Object)
Remarks

            This method first checks if this logger is DEBUG
            enabled by comparing the level of this logger with the
            DEBUG level. If this logger is
            DEBUG enabled, then it converts the message object
            (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger
            and also higher in the hierarchy depending on the value of the
            additivity flag.

WARNING Note that passing an   Online Exception
            to this method will print the name of the   Online Exception
            but no stack trace. To print a stack trace use the
            [M:Debug(object,Exception)] form instead.

See Also
LogImpl Class
LogImpl Members
Debug Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Debug Method (Object, Exception)

LogImpl Debug Method (Object, Exception) Apache log4net™ SDK Documentation
Logs a message object with the DEBUG level

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Debug(
    Object message,
    Exception exception
)
public virtual void Debug(
    Object message,
    Exception exception
)
Public Overridable Sub Debug (
    message As Object,
    exception As Exception
)
Public Overridable Sub Debug (
    message As Object,
    exception As Exception
)
public:
virtual void Debug(
    Object^ message,
    Exception^ exception
)
public:
virtual void Debug(
    Object^ message,
    Exception^ exception
)
Parameters
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Implements
ILog Debug(Object, Exception)
Remarks

            Logs a message object with the DEBUG level including
            the stack trace of the   Online Exception exception passed
            as a parameter.

            See the [M:Debug(object)] form for more detailed information.

See Also
LogImpl Class
LogImpl Members
Debug Overload
log4net.Core Namespace
[M:Debug(object)]
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.DebugFormat Method

LogImpl DebugFormat Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | DebugFormat(String, Object) | Logs a formatted message string with the DEBUG level.
Public method | DebugFormat(String, Object ) | Logs a formatted message string with the DEBUG level.
Public method | DebugFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the DEBUG level.
Public method | DebugFormat(String, Object, Object) | Logs a formatted message string with the DEBUG level.
Public method | DebugFormat(String, Object, Object, Object) | Logs a formatted message string with the DEBUG level.
Back to Top
See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.DebugFormat Method (String, Object)

LogImpl DebugFormat Method (String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the DEBUG level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DebugFormat(
    string format,
    Object arg0
)
public virtual void DebugFormat(
    string format,
    Object arg0
)
Public Overridable Sub DebugFormat (
    format As String,
    arg0 As Object
)
Public Overridable Sub DebugFormat (
    format As String,
    arg0 As Object
)
public:
virtual void DebugFormat(
    String^ format,
    Object^ arg0
)
public:
virtual void DebugFormat(
    String^ format,
    Object^ arg0
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Implements
ILog DebugFormat(String, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:DebugFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Debug(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
DebugFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.DebugFormat Method (String, Object[])

LogImpl DebugFormat Method (String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the DEBUG level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DebugFormat(
    string format,
    params Object[] args
)
public virtual void DebugFormat(
    string format,
    params Object[] args
)
Public Overridable Sub DebugFormat (
    format As String,
    ParamArray args As Object()
)
Public Overridable Sub DebugFormat (
    format As String,
    ParamArray args As Object()
)
public:
virtual void DebugFormat(
    String^ format,
    ... array<Object^>^ args
)
public:
virtual void DebugFormat(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Implements
ILog DebugFormat(String,  Object )
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:DebugFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Debug(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
DebugFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.DebugFormat Method (IFormatProvider, String, Object[])

LogImpl DebugFormat Method (IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the DEBUG level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DebugFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
public virtual void DebugFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
Public Overridable Sub DebugFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
Public Overridable Sub DebugFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
public:
virtual void DebugFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
public:
virtual void DebugFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Implements
ILog DebugFormat(IFormatProvider, String,  Object )
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Debug(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
DebugFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.DebugFormat Method (String, Object, Object)

LogImpl DebugFormat Method (String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the DEBUG level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DebugFormat(
    string format,
    Object arg0,
    Object arg1
)
public virtual void DebugFormat(
    string format,
    Object arg0,
    Object arg1
)
Public Overridable Sub DebugFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
Public Overridable Sub DebugFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
public:
virtual void DebugFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
public:
virtual void DebugFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Implements
ILog DebugFormat(String, Object, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:DebugFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Debug(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
DebugFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.DebugFormat Method (String, Object, Object, Object)

LogImpl DebugFormat Method (String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the DEBUG level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DebugFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
public virtual void DebugFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
Public Overridable Sub DebugFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
Public Overridable Sub DebugFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
public:
virtual void DebugFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
public:
virtual void DebugFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Implements
ILog DebugFormat(String, Object, Object, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:DebugFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Debug(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
DebugFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Error Method

LogImpl Error Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Error(Object) | Logs a message object with the ERROR level.
Public method | Error(Object, Exception) | Logs a message object with the ERROR level
Back to Top
See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Error Method (Object)

LogImpl Error Method (Object) Apache log4net™ SDK Documentation
Logs a message object with the ERROR level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Error(
    Object message
)
public virtual void Error(
    Object message
)
Public Overridable Sub Error (
    message As Object
)
Public Overridable Sub Error (
    message As Object
)
public:
virtual void Error(
    Object^ message
)
public:
virtual void Error(
    Object^ message
)
Parameters
message
Type:   Online System Object
The message object to log.
Implements
ILog Error(Object)
Remarks

            This method first checks if this logger is ERROR
            enabled by comparing the level of this logger with the
            ERROR level. If this logger is
            ERROR enabled, then it converts the message object
            (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger and
            also higher in the hierarchy depending on the value of the
            additivity flag.

WARNING Note that passing an   Online Exception to this
            method will print the name of the   Online Exception but no
            stack trace. To print a stack trace use the
            [M:Error(object,Exception)] form instead.

See Also
LogImpl Class
LogImpl Members
Error Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Error Method (Object, Exception)

LogImpl Error Method (Object, Exception) Apache log4net™ SDK Documentation
Logs a message object with the ERROR level

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Error(
    Object message,
    Exception exception
)
public virtual void Error(
    Object message,
    Exception exception
)
Public Overridable Sub Error (
    message As Object,
    exception As Exception
)
Public Overridable Sub Error (
    message As Object,
    exception As Exception
)
public:
virtual void Error(
    Object^ message,
    Exception^ exception
)
public:
virtual void Error(
    Object^ message,
    Exception^ exception
)
Parameters
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Implements
ILog Error(Object, Exception)
Remarks

            Logs a message object with the ERROR level including
            the stack trace of the   Online Exception exception
            passed as a parameter.

            See the [M:Error(object)] form for more detailed information.

See Also
LogImpl Class
LogImpl Members
Error Overload
log4net.Core Namespace
[M:Error(object)]
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.ErrorFormat Method

LogImpl ErrorFormat Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | ErrorFormat(String, Object) | Logs a formatted message string with the ERROR level.
Public method | ErrorFormat(String, Object ) | Logs a formatted message string with the ERROR level.
Public method | ErrorFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the ERROR level.
Public method | ErrorFormat(String, Object, Object) | Logs a formatted message string with the ERROR level.
Public method | ErrorFormat(String, Object, Object, Object) | Logs a formatted message string with the ERROR level.
Back to Top
See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.ErrorFormat Method (String, Object)

LogImpl ErrorFormat Method (String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the ERROR level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ErrorFormat(
    string format,
    Object arg0
)
public virtual void ErrorFormat(
    string format,
    Object arg0
)
Public Overridable Sub ErrorFormat (
    format As String,
    arg0 As Object
)
Public Overridable Sub ErrorFormat (
    format As String,
    arg0 As Object
)
public:
virtual void ErrorFormat(
    String^ format,
    Object^ arg0
)
public:
virtual void ErrorFormat(
    String^ format,
    Object^ arg0
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Implements
ILog ErrorFormat(String, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:ErrorFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Error(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
ErrorFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.ErrorFormat Method (String, Object[])

LogImpl ErrorFormat Method (String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the ERROR level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ErrorFormat(
    string format,
    params Object[] args
)
public virtual void ErrorFormat(
    string format,
    params Object[] args
)
Public Overridable Sub ErrorFormat (
    format As String,
    ParamArray args As Object()
)
Public Overridable Sub ErrorFormat (
    format As String,
    ParamArray args As Object()
)
public:
virtual void ErrorFormat(
    String^ format,
    ... array<Object^>^ args
)
public:
virtual void ErrorFormat(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Implements
ILog ErrorFormat(String,  Object )
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:ErrorFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Error(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
ErrorFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.ErrorFormat Method (IFormatProvider, String, Object[])

LogImpl ErrorFormat Method (IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the ERROR level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ErrorFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
public virtual void ErrorFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
Public Overridable Sub ErrorFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
Public Overridable Sub ErrorFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
public:
virtual void ErrorFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
public:
virtual void ErrorFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Implements
ILog ErrorFormat(IFormatProvider, String,  Object )
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Error(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
ErrorFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.ErrorFormat Method (String, Object, Object)

LogImpl ErrorFormat Method (String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the ERROR level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ErrorFormat(
    string format,
    Object arg0,
    Object arg1
)
public virtual void ErrorFormat(
    string format,
    Object arg0,
    Object arg1
)
Public Overridable Sub ErrorFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
Public Overridable Sub ErrorFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
public:
virtual void ErrorFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
public:
virtual void ErrorFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Implements
ILog ErrorFormat(String, Object, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:ErrorFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Error(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
ErrorFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.ErrorFormat Method (String, Object, Object, Object)

LogImpl ErrorFormat Method (String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the ERROR level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ErrorFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
public virtual void ErrorFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
Public Overridable Sub ErrorFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
Public Overridable Sub ErrorFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
public:
virtual void ErrorFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
public:
virtual void ErrorFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Implements
ILog ErrorFormat(String, Object, Object, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:ErrorFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Error(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
ErrorFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Fatal Method

LogImpl Fatal Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Fatal(Object) | Logs a message object with the FATAL level.
Public method | Fatal(Object, Exception) | Logs a message object with the FATAL level
Back to Top
See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Fatal Method (Object)

LogImpl Fatal Method (Object) Apache log4net™ SDK Documentation
Logs a message object with the FATAL level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Fatal(
    Object message
)
public virtual void Fatal(
    Object message
)
Public Overridable Sub Fatal (
    message As Object
)
Public Overridable Sub Fatal (
    message As Object
)
public:
virtual void Fatal(
    Object^ message
)
public:
virtual void Fatal(
    Object^ message
)
Parameters
message
Type:   Online System Object
The message object to log.
Implements
ILog Fatal(Object)
Remarks

            This method first checks if this logger is FATAL
            enabled by comparing the level of this logger with the
            FATAL level. If this logger is
            FATAL enabled, then it converts the message object
            (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger and
            also higher in the hierarchy depending on the value of the
            additivity flag.

WARNING Note that passing an   Online Exception to this
            method will print the name of the   Online Exception but no
            stack trace. To print a stack trace use the
            [M:Fatal(object,Exception)] form instead.

See Also
LogImpl Class
LogImpl Members
Fatal Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Fatal Method (Object, Exception)

LogImpl Fatal Method (Object, Exception) Apache log4net™ SDK Documentation
Logs a message object with the FATAL level

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Fatal(
    Object message,
    Exception exception
)
public virtual void Fatal(
    Object message,
    Exception exception
)
Public Overridable Sub Fatal (
    message As Object,
    exception As Exception
)
Public Overridable Sub Fatal (
    message As Object,
    exception As Exception
)
public:
virtual void Fatal(
    Object^ message,
    Exception^ exception
)
public:
virtual void Fatal(
    Object^ message,
    Exception^ exception
)
Parameters
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Implements
ILog Fatal(Object, Exception)
Remarks

            Logs a message object with the FATAL level including
            the stack trace of the   Online Exception exception
            passed as a parameter.

            See the [M:Fatal(object)] form for more detailed information.

See Also
LogImpl Class
LogImpl Members
Fatal Overload
log4net.Core Namespace
[M:Fatal(object)]
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.FatalFormat Method

LogImpl FatalFormat Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | FatalFormat(String, Object) | Logs a formatted message string with the FATAL level.
Public method | FatalFormat(String, Object ) | Logs a formatted message string with the FATAL level.
Public method | FatalFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the FATAL level.
Public method | FatalFormat(String, Object, Object) | Logs a formatted message string with the FATAL level.
Public method | FatalFormat(String, Object, Object, Object) | Logs a formatted message string with the FATAL level.
Back to Top
See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.FatalFormat Method (String, Object)

LogImpl FatalFormat Method (String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the FATAL level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FatalFormat(
    string format,
    Object arg0
)
public virtual void FatalFormat(
    string format,
    Object arg0
)
Public Overridable Sub FatalFormat (
    format As String,
    arg0 As Object
)
Public Overridable Sub FatalFormat (
    format As String,
    arg0 As Object
)
public:
virtual void FatalFormat(
    String^ format,
    Object^ arg0
)
public:
virtual void FatalFormat(
    String^ format,
    Object^ arg0
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Implements
ILog FatalFormat(String, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:FatalFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Fatal(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
FatalFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.FatalFormat Method (String, Object[])

LogImpl FatalFormat Method (String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the FATAL level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FatalFormat(
    string format,
    params Object[] args
)
public virtual void FatalFormat(
    string format,
    params Object[] args
)
Public Overridable Sub FatalFormat (
    format As String,
    ParamArray args As Object()
)
Public Overridable Sub FatalFormat (
    format As String,
    ParamArray args As Object()
)
public:
virtual void FatalFormat(
    String^ format,
    ... array<Object^>^ args
)
public:
virtual void FatalFormat(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Implements
ILog FatalFormat(String,  Object )
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:FatalFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Fatal(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
FatalFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.FatalFormat Method (IFormatProvider, String, Object[])

LogImpl FatalFormat Method (IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the FATAL level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FatalFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
public virtual void FatalFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
Public Overridable Sub FatalFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
Public Overridable Sub FatalFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
public:
virtual void FatalFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
public:
virtual void FatalFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Implements
ILog FatalFormat(IFormatProvider, String,  Object )
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Fatal(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
FatalFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.FatalFormat Method (String, Object, Object)

LogImpl FatalFormat Method (String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the FATAL level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FatalFormat(
    string format,
    Object arg0,
    Object arg1
)
public virtual void FatalFormat(
    string format,
    Object arg0,
    Object arg1
)
Public Overridable Sub FatalFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
Public Overridable Sub FatalFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
public:
virtual void FatalFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
public:
virtual void FatalFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Implements
ILog FatalFormat(String, Object, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:FatalFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Fatal(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
FatalFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.FatalFormat Method (String, Object, Object, Object)

LogImpl FatalFormat Method (String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the FATAL level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FatalFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
public virtual void FatalFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
Public Overridable Sub FatalFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
Public Overridable Sub FatalFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
public:
virtual void FatalFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
public:
virtual void FatalFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Implements
ILog FatalFormat(String, Object, Object, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:FatalFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Fatal(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
FatalFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Info Method

LogImpl Info Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Info(Object) | Logs a message object with the INFO level.
Public method | Info(Object, Exception) | Logs a message object with the INFO level.
Back to Top
See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Info Method (Object)

LogImpl Info Method (Object) Apache log4net™ SDK Documentation
Logs a message object with the INFO level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Info(
    Object message
)
public virtual void Info(
    Object message
)
Public Overridable Sub Info (
    message As Object
)
Public Overridable Sub Info (
    message As Object
)
public:
virtual void Info(
    Object^ message
)
public:
virtual void Info(
    Object^ message
)
Parameters
message
Type:   Online System Object
The message object to log.
Implements
ILog Info(Object)
Remarks

            This method first checks if this logger is INFO
            enabled by comparing the level of this logger with the
            INFO level. If this logger is
            INFO enabled, then it converts the message object
            (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger
            and also higher in the hierarchy depending on the value of
            the additivity flag.

WARNING Note that passing an   Online Exception
            to this method will print the name of the   Online Exception
            but no stack trace. To print a stack trace use the
            [M:Info(object,Exception)] form instead.

See Also
LogImpl Class
LogImpl Members
Info Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Info Method (Object, Exception)

LogImpl Info Method (Object, Exception) Apache log4net™ SDK Documentation
Logs a message object with the INFO level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Info(
    Object message,
    Exception exception
)
public virtual void Info(
    Object message,
    Exception exception
)
Public Overridable Sub Info (
    message As Object,
    exception As Exception
)
Public Overridable Sub Info (
    message As Object,
    exception As Exception
)
public:
virtual void Info(
    Object^ message,
    Exception^ exception
)
public:
virtual void Info(
    Object^ message,
    Exception^ exception
)
Parameters
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Implements
ILog Info(Object, Exception)
Remarks

            Logs a message object with the INFO level including
            the stack trace of the   Online Exception exception
            passed as a parameter.

            See the [M:Info(object)] form for more detailed information.

See Also
LogImpl Class
LogImpl Members
Info Overload
log4net.Core Namespace
[M:Info(object)]
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.InfoFormat Method

LogImpl InfoFormat Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | InfoFormat(String, Object) | Logs a formatted message string with the INFO level.
Public method | InfoFormat(String, Object ) | Logs a formatted message string with the INFO level.
Public method | InfoFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the INFO level.
Public method | InfoFormat(String, Object, Object) | Logs a formatted message string with the INFO level.
Public method | InfoFormat(String, Object, Object, Object) | Logs a formatted message string with the INFO level.
Back to Top
See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.InfoFormat Method (String, Object)

LogImpl InfoFormat Method (String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the INFO level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void InfoFormat(
    string format,
    Object arg0
)
public virtual void InfoFormat(
    string format,
    Object arg0
)
Public Overridable Sub InfoFormat (
    format As String,
    arg0 As Object
)
Public Overridable Sub InfoFormat (
    format As String,
    arg0 As Object
)
public:
virtual void InfoFormat(
    String^ format,
    Object^ arg0
)
public:
virtual void InfoFormat(
    String^ format,
    Object^ arg0
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Implements
ILog InfoFormat(String, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:InfoFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Info(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
InfoFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.InfoFormat Method (String, Object[])

LogImpl InfoFormat Method (String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the INFO level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void InfoFormat(
    string format,
    params Object[] args
)
public virtual void InfoFormat(
    string format,
    params Object[] args
)
Public Overridable Sub InfoFormat (
    format As String,
    ParamArray args As Object()
)
Public Overridable Sub InfoFormat (
    format As String,
    ParamArray args As Object()
)
public:
virtual void InfoFormat(
    String^ format,
    ... array<Object^>^ args
)
public:
virtual void InfoFormat(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Implements
ILog InfoFormat(String,  Object )
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:InfoFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Info(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
InfoFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.InfoFormat Method (IFormatProvider, String, Object[])

LogImpl InfoFormat Method (IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the INFO level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void InfoFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
public virtual void InfoFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
Public Overridable Sub InfoFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
Public Overridable Sub InfoFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
public:
virtual void InfoFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
public:
virtual void InfoFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Implements
ILog InfoFormat(IFormatProvider, String,  Object )
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Info(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
InfoFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.InfoFormat Method (String, Object, Object)

LogImpl InfoFormat Method (String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the INFO level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void InfoFormat(
    string format,
    Object arg0,
    Object arg1
)
public virtual void InfoFormat(
    string format,
    Object arg0,
    Object arg1
)
Public Overridable Sub InfoFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
Public Overridable Sub InfoFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
public:
virtual void InfoFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
public:
virtual void InfoFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Implements
ILog InfoFormat(String, Object, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:InfoFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Info(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
InfoFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.InfoFormat Method (String, Object, Object, Object)

LogImpl InfoFormat Method (String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the INFO level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void InfoFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
public virtual void InfoFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
Public Overridable Sub InfoFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
Public Overridable Sub InfoFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
public:
virtual void InfoFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
public:
virtual void InfoFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Implements
ILog InfoFormat(String, Object, Object, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:InfoFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Info(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
InfoFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.ReloadLevels Method

LogImpl ReloadLevels Method Apache log4net™ SDK Documentation
Virtual method called when the configuration of the repository changes

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void ReloadLevels(
    ILoggerRepository repository
)
protected virtual void ReloadLevels(
    ILoggerRepository repository
)
Protected Overridable Sub ReloadLevels (
    repository As ILoggerRepository
)
Protected Overridable Sub ReloadLevels (
    repository As ILoggerRepository
)
protected:
virtual void ReloadLevels(
    ILoggerRepository^ repository
)
protected:
virtual void ReloadLevels(
    ILoggerRepository^ repository
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
the repository holding the levels
Remarks

            Virtual method called when the configuration of the repository changes

See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Warn Method

LogImpl Warn Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Warn(Object) | Logs a message object with the WARN level.
Public method | Warn(Object, Exception) | Logs a message object with the WARN level
Back to Top
See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Warn Method (Object)

LogImpl Warn Method (Object) Apache log4net™ SDK Documentation
Logs a message object with the WARN level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Warn(
    Object message
)
public virtual void Warn(
    Object message
)
Public Overridable Sub Warn (
    message As Object
)
Public Overridable Sub Warn (
    message As Object
)
public:
virtual void Warn(
    Object^ message
)
public:
virtual void Warn(
    Object^ message
)
Parameters
message
Type:   Online System Object
the message object to log
Implements
ILog Warn(Object)
Remarks

            This method first checks if this logger is WARN
            enabled by comparing the level of this logger with the
            WARN level. If this logger is
            WARN enabled, then it converts the message object
            (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger and
            also higher in the hierarchy depending on the value of the
            additivity flag.

WARNING Note that passing an   Online Exception to this
            method will print the name of the   Online Exception but no
            stack trace. To print a stack trace use the
            [M:Warn(object,Exception)] form instead.

See Also
LogImpl Class
LogImpl Members
Warn Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.Warn Method (Object, Exception)

LogImpl Warn Method (Object, Exception) Apache log4net™ SDK Documentation
Logs a message object with the WARN level

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Warn(
    Object message,
    Exception exception
)
public virtual void Warn(
    Object message,
    Exception exception
)
Public Overridable Sub Warn (
    message As Object,
    exception As Exception
)
Public Overridable Sub Warn (
    message As Object,
    exception As Exception
)
public:
virtual void Warn(
    Object^ message,
    Exception^ exception
)
public:
virtual void Warn(
    Object^ message,
    Exception^ exception
)
Parameters
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Implements
ILog Warn(Object, Exception)
Remarks

            Logs a message object with the WARN level including
            the stack trace of the   Online Exception exception
            passed as a parameter.

            See the [M:Warn(object)] form for more detailed information.

See Also
LogImpl Class
LogImpl Members
Warn Overload
log4net.Core Namespace
[M:Warn(object)]
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.WarnFormat Method

LogImpl WarnFormat Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | WarnFormat(String, Object) | Logs a formatted message string with the WARN level.
Public method | WarnFormat(String, Object ) | Logs a formatted message string with the WARN level.
Public method | WarnFormat(IFormatProvider, String, Object ) | Logs a formatted message string with the WARN level.
Public method | WarnFormat(String, Object, Object) | Logs a formatted message string with the WARN level.
Public method | WarnFormat(String, Object, Object, Object) | Logs a formatted message string with the WARN level.
Back to Top
See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.WarnFormat Method (String, Object)

LogImpl WarnFormat Method (String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the WARN level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WarnFormat(
    string format,
    Object arg0
)
public virtual void WarnFormat(
    string format,
    Object arg0
)
Public Overridable Sub WarnFormat (
    format As String,
    arg0 As Object
)
Public Overridable Sub WarnFormat (
    format As String,
    arg0 As Object
)
public:
virtual void WarnFormat(
    String^ format,
    Object^ arg0
)
public:
virtual void WarnFormat(
    String^ format,
    Object^ arg0
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Implements
ILog WarnFormat(String, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:WarnFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Warn(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
WarnFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.WarnFormat Method (String, Object[])

LogImpl WarnFormat Method (String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the WARN level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WarnFormat(
    string format,
    params Object[] args
)
public virtual void WarnFormat(
    string format,
    params Object[] args
)
Public Overridable Sub WarnFormat (
    format As String,
    ParamArray args As Object()
)
Public Overridable Sub WarnFormat (
    format As String,
    ParamArray args As Object()
)
public:
virtual void WarnFormat(
    String^ format,
    ... array<Object^>^ args
)
public:
virtual void WarnFormat(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Implements
ILog WarnFormat(String,  Object )
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:WarnFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Warn(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
WarnFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.WarnFormat Method (IFormatProvider, String, Object[])

LogImpl WarnFormat Method (IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the WARN level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WarnFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
public virtual void WarnFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
Public Overridable Sub WarnFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
Public Overridable Sub WarnFormat (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
public:
virtual void WarnFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
public:
virtual void WarnFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Implements
ILog WarnFormat(IFormatProvider, String,  Object )
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Warn(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
WarnFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.WarnFormat Method (String, Object, Object)

LogImpl WarnFormat Method (String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the WARN level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WarnFormat(
    string format,
    Object arg0,
    Object arg1
)
public virtual void WarnFormat(
    string format,
    Object arg0,
    Object arg1
)
Public Overridable Sub WarnFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
Public Overridable Sub WarnFormat (
    format As String,
    arg0 As Object,
    arg1 As Object
)
public:
virtual void WarnFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
public:
virtual void WarnFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Implements
ILog WarnFormat(String, Object, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:WarnFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Warn(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
WarnFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.WarnFormat Method (String, Object, Object, Object)

LogImpl WarnFormat Method (String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the WARN level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WarnFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
public virtual void WarnFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
Public Overridable Sub WarnFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
Public Overridable Sub WarnFormat (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
public:
virtual void WarnFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
public:
virtual void WarnFormat(
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Implements
ILog WarnFormat(String, Object, Object, Object)
Remarks

            The message is formatted using the [M:String.Format(IFormatProvider, string, object[])] method. See
            String.Format for details of the syntax of the format string and the behavior
            of the formatting.

            The string is formatted using the   Online InvariantCulture
            format provider. To specify a localized provider use the
            [M:WarnFormat(IFormatProvider,string,object[])] method.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the [M:Warn(object)]
            methods instead.

See Also
LogImpl Class
LogImpl Members
WarnFormat Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl Properties

LogImpl Properties Apache log4net™ SDK Documentation
The LogImpl type exposes the following members.
Properties
 | Name | Description
Public property | IsDebugEnabled | Checks if this logger is enabled for the DEBUG level.
Public property | IsErrorEnabled | Checks if this logger is enabled for the ERROR level.
Public property | IsFatalEnabled | Checks if this logger is enabled for the FATAL level.
Public property | IsInfoEnabled | Checks if this logger is enabled for the INFO level.
Public property | IsWarnEnabled | Checks if this logger is enabled for the WARN level.
Public property | Logger | Gets the implementation behind this wrapper object. (Inherited from LoggerWrapperImpl.)
Back to Top
See Also
LogImpl Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.IsDebugEnabled Property

LogImpl IsDebugEnabled Property Apache log4net™ SDK Documentation
Checks if this logger is enabled for the DEBUG level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsDebugEnabled { get; }
public virtual bool IsDebugEnabled { get; }
Public Overridable ReadOnly Property IsDebugEnabled As Boolean
    Get
Public Overridable ReadOnly Property IsDebugEnabled As Boolean
    Get
public:
virtual property bool IsDebugEnabled {
    bool get ();
}
public:
virtual property bool IsDebugEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if this logger is enabled for DEBUG events,
            false otherwise.

Implements
ILog IsDebugEnabled
Remarks

            This function is intended to lessen the computational cost of
            disabled log debug statements.

            For some log Logger object, when you write:

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
log.Debug("This is entry number: " + i );
log.Debug("This is entry number: " + i );

            You incur the cost constructing the message, concatenation in
            this case, regardless of whether the message is logged or not.

            If you are worried about speed, then you should write:

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
if (log.IsDebugEnabled())
{
 log.Debug("This is entry number: " + i );
}
if (log.IsDebugEnabled())
{
 log.Debug("This is entry number: " + i );
}

            This way you will not incur the cost of parameter
            construction if debugging is disabled for log. On
            the other hand, if the log is debug enabled, you
            will incur the cost of evaluating whether the logger is debug
            enabled twice. Once in IsDebugEnabled and once in
            the Debug.  This is an insignificant overhead
            since evaluating a logger takes about 1% of the time it
            takes to actually log.

See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.IsErrorEnabled Property

LogImpl IsErrorEnabled Property Apache log4net™ SDK Documentation
Checks if this logger is enabled for the ERROR level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsErrorEnabled { get; }
public virtual bool IsErrorEnabled { get; }
Public Overridable ReadOnly Property IsErrorEnabled As Boolean
    Get
Public Overridable ReadOnly Property IsErrorEnabled As Boolean
    Get
public:
virtual property bool IsErrorEnabled {
    bool get ();
}
public:
virtual property bool IsErrorEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if this logger is enabled for ERROR events,
            false otherwise.

Implements
ILog IsErrorEnabled
Remarks

            See IsDebugEnabled for more information and examples of using this method.

See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.IsFatalEnabled Property

LogImpl IsFatalEnabled Property Apache log4net™ SDK Documentation
Checks if this logger is enabled for the FATAL level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsFatalEnabled { get; }
public virtual bool IsFatalEnabled { get; }
Public Overridable ReadOnly Property IsFatalEnabled As Boolean
    Get
Public Overridable ReadOnly Property IsFatalEnabled As Boolean
    Get
public:
virtual property bool IsFatalEnabled {
    bool get ();
}
public:
virtual property bool IsFatalEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if this logger is enabled for FATAL events,
            false otherwise.

Implements
ILog IsFatalEnabled
Remarks

            See IsDebugEnabled for more information and examples of using this method.

See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.IsInfoEnabled Property

LogImpl IsInfoEnabled Property Apache log4net™ SDK Documentation
Checks if this logger is enabled for the INFO level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsInfoEnabled { get; }
public virtual bool IsInfoEnabled { get; }
Public Overridable ReadOnly Property IsInfoEnabled As Boolean
    Get
Public Overridable ReadOnly Property IsInfoEnabled As Boolean
    Get
public:
virtual property bool IsInfoEnabled {
    bool get ();
}
public:
virtual property bool IsInfoEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if this logger is enabled for INFO events,
            false otherwise.

Implements
ILog IsInfoEnabled
Remarks

            See IsDebugEnabled for more information and examples
            of using this method.

See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace
LogImpl IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogImpl.IsWarnEnabled Property

LogImpl IsWarnEnabled Property Apache log4net™ SDK Documentation
Checks if this logger is enabled for the WARN level.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsWarnEnabled { get; }
public virtual bool IsWarnEnabled { get; }
Public Overridable ReadOnly Property IsWarnEnabled As Boolean
    Get
Public Overridable ReadOnly Property IsWarnEnabled As Boolean
    Get
public:
virtual property bool IsWarnEnabled {
    bool get ();
}
public:
virtual property bool IsWarnEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if this logger is enabled for WARN events,
            false otherwise.

Implements
ILog IsWarnEnabled
Remarks

            See IsDebugEnabled for more information and examples
            of using this method.

See Also
LogImpl Class
LogImpl Members
log4net.Core Namespace
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MethodItem Class

MethodItem Class Apache log4net™ SDK Documentation
provides method information without actually referencing a System.Reflection.MethodBase as that would require that the containing assembly is loaded.
Inheritance Hierarchy
Online System Object
log4net.Core MethodItem

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MethodItem
[SerializableAttribute]
public class MethodItem
<SerializableAttribute>
Public Class MethodItem
<SerializableAttribute>
Public Class MethodItem
[SerializableAttribute]
public ref class MethodItem
[SerializableAttribute]
public ref class MethodItem
See Also
MethodItem Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MethodItem Members

MethodItem Members Apache log4net™ SDK Documentation
The MethodItem type exposes the following members.
Constructors
 | Name | Description
Public method | MethodItem | constructs a method item for an unknown method.
Public method | MethodItem(MethodBase) | constructs a method item from a method base by determining the method name and its parameters.
Public method | MethodItem(String) | constructs a method item from the name of the method.
Public method | MethodItem(String, String ) | constructs a method item from the name of the method and its parameters.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Name | Gets the method name of the caller making the logging request.
Public property | Parameters | Gets the method parameters of the caller making the logging request.
Back to Top
See Also
MethodItem Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MethodItem Constructor

MethodItem Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | MethodItem | constructs a method item for an unknown method.
Public method | MethodItem(MethodBase) | constructs a method item from a method base by determining the method name and its parameters.
Public method | MethodItem(String) | constructs a method item from the name of the method.
Public method | MethodItem(String, String ) | constructs a method item from the name of the method and its parameters.
Back to Top
See Also
MethodItem Class
MethodItem Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MethodItem Constructor

MethodItem Constructor Apache log4net™ SDK Documentation
constructs a method item for an unknown method.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodItem()
public MethodItem()
Public Sub New
Public Sub New
public:
MethodItem()
public:
MethodItem()
See Also
MethodItem Class
MethodItem Members
MethodItem Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MethodItem Constructor (MethodBase)

MethodItem Constructor (MethodBase) Apache log4net™ SDK Documentation
constructs a method item from a method base by determining the method name and its parameters.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodItem(
    MethodBase methodBase
)
public MethodItem(
    MethodBase methodBase
)
Public Sub New (
    methodBase As MethodBase
)
Public Sub New (
    methodBase As MethodBase
)
public:
MethodItem(
    MethodBase^ methodBase
)
public:
MethodItem(
    MethodBase^ methodBase
)
Parameters
methodBase
Type:   Online System.Reflection MethodBase
[Missing <param name="methodBase"/> documentation for "M:log4net.Core.MethodItem.#ctor(System.Reflection.MethodBase)"]
See Also
MethodItem Class
MethodItem Members
MethodItem Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MethodItem Constructor (String)

MethodItem Constructor (String) Apache log4net™ SDK Documentation
constructs a method item from the name of the method.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodItem(
    string name
)
public MethodItem(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
MethodItem(
    String^ name
)
public:
MethodItem(
    String^ name
)
Parameters
name
Type:   Online System String
[Missing <param name="name"/> documentation for "M:log4net.Core.MethodItem.#ctor(System.String)"]
See Also
MethodItem Class
MethodItem Members
MethodItem Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MethodItem Constructor (String, String[])

MethodItem Constructor (String, String ) Apache log4net™ SDK Documentation
constructs a method item from the name of the method and its parameters.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodItem(
    string name,
    string[] parameters
)
public MethodItem(
    string name,
    string[] parameters
)
Public Sub New (
    name As String,
    parameters As String()
)
Public Sub New (
    name As String,
    parameters As String()
)
public:
MethodItem(
    String^ name,
    array<String^>^ parameters
)
public:
MethodItem(
    String^ name,
    array<String^>^ parameters
)
Parameters
name
Type:   Online System String
[Missing <param name="name"/> documentation for "M:log4net.Core.MethodItem.#ctor(System.String,System.String[])"]
parameters
Type:    Online System String
[Missing <param name="parameters"/> documentation for "M:log4net.Core.MethodItem.#ctor(System.String,System.String[])"]
See Also
MethodItem Class
MethodItem Members
MethodItem Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MethodItem Methods

MethodItem Methods Apache log4net™ SDK Documentation
The MethodItem type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MethodItem Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MethodItem Properties

MethodItem Properties Apache log4net™ SDK Documentation
The MethodItem type exposes the following members.
Properties
 | Name | Description
Public property | Name | Gets the method name of the caller making the logging request.
Public property | Parameters | Gets the method parameters of the caller making the logging request.
Back to Top
See Also
MethodItem Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MethodItem.Name Property

MethodItem Name Property Apache log4net™ SDK Documentation
Gets the method name of the caller making the logging request.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
public:
property String^ Name {
    String^ get ();
}
Property Value
Type:   Online String

            The method name of the caller making the logging
            request.

Remarks

            Gets the method name of the caller making the logging
            request.

See Also
MethodItem Class
MethodItem Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MethodItem.Parameters Property

MethodItem Parameters Property Apache log4net™ SDK Documentation
Gets the method parameters of the caller making the logging request.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string[] Parameters { get; }
public string[] Parameters { get; }
Public ReadOnly Property Parameters As String()
    Get
Public ReadOnly Property Parameters As String()
    Get
public:
property array<String^>^ Parameters {
    array<String^>^ get ();
}
public:
property array<String^>^ Parameters {
    array<String^>^ get ();
}
Property Value
Type:    Online String

            The method parameters of the caller making
            the logging request

Remarks

            Gets the method parameters of the caller making
            the logging request.

See Also
MethodItem Class
MethodItem Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContext Class

SecurityContext Class Apache log4net™ SDK Documentation
A SecurityContext used by log4net when interacting with protected resources
Inheritance Hierarchy
Online System Object
log4net.Core SecurityContext
log4net.Util NullSecurityContext
log4net.Util WindowsSecurityContext

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class SecurityContext
public abstract class SecurityContext
Public MustInherit Class SecurityContext
Public MustInherit Class SecurityContext
public ref class SecurityContext abstract
public ref class SecurityContext abstract
Remarks

            A SecurityContext used by log4net when interacting with protected resources
            for example with operating system services. This can be used to impersonate
            a principal that has been granted privileges on the system resources.

See Also
SecurityContext Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContext Members

SecurityContext Members Apache log4net™ SDK Documentation
The SecurityContext type exposes the following members.
Constructors
 | Name | Description
Protected method | SecurityContext | Initializes a new instance of the SecurityContext class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Impersonate | Impersonate this SecurityContext
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SecurityContext Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContext Constructor

SecurityContext Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the SecurityContext class

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SecurityContext()
protected SecurityContext()
Protected Sub New
Protected Sub New
protected:
SecurityContext()
protected:
SecurityContext()
See Also
SecurityContext Class
SecurityContext Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContext Methods

SecurityContext Methods Apache log4net™ SDK Documentation
The SecurityContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Impersonate | Impersonate this SecurityContext
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SecurityContext Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContext.Impersonate Method

SecurityContext Impersonate Method Apache log4net™ SDK Documentation
Impersonate this SecurityContext

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IDisposable Impersonate(
    Object state
)
public abstract IDisposable Impersonate(
    Object state
)
Public MustOverride Function Impersonate (
    state As Object
) As IDisposable
Public MustOverride Function Impersonate (
    state As Object
) As IDisposable
public:
virtual IDisposable^ Impersonate(
    Object^ state
) abstract
public:
virtual IDisposable^ Impersonate(
    Object^ state
) abstract
Parameters
state
Type:   Online System Object
State supplied by the caller
Return Value
Type:   Online IDisposable
An   Online IDisposable instance that will
            revoke the impersonation of this SecurityContext, or null
Remarks

            Impersonate this security context. Further calls on the current
            thread should now be made in the security context provided
            by this object. When the   Online IDisposable result
              Online Dispose  method is called the security
            context of the thread should be reverted to the state it was in
            before Impersonate(Object) was called.

See Also
SecurityContext Class
SecurityContext Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProvider Class

SecurityContextProvider Class Apache log4net™ SDK Documentation
The SecurityContextProvider providers default SecurityContext instances.
Inheritance Hierarchy
Online System Object
log4net.Core SecurityContextProvider

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SecurityContextProvider
public class SecurityContextProvider
Public Class SecurityContextProvider
Public Class SecurityContextProvider
public ref class SecurityContextProvider
public ref class SecurityContextProvider
Remarks

            A configured component that interacts with potentially protected system
            resources uses a SecurityContext to provide the elevated
            privileges required. If the SecurityContext object has
            been not been explicitly provided to the component then the component
            will request one from this SecurityContextProvider.

            By default the DefaultProvider is
            an instance of SecurityContextProvider which returns only
            NullSecurityContext objects. This is a reasonable default
            where the privileges required are not know by the system.

            This default behavior can be overridden by subclassing the SecurityContextProvider
            and overriding the CreateSecurityContext(Object) method to return
            the desired SecurityContext objects. The default provider
            can be replaced by programmatically setting the value of the
            DefaultProvider property.

            An alternative is to use the log4net.Config.SecurityContextProviderAttribute
            This attribute can be applied to an assembly in the same way as the
            log4net.Config.XmlConfiguratorAttribute". The attribute takes
            the type to use as the SecurityContextProvider as an argument.

See Also
SecurityContextProvider Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProvider Members

SecurityContextProvider Members Apache log4net™ SDK Documentation
The SecurityContextProvider type exposes the following members.
Constructors
 | Name | Description
Protected method | SecurityContextProvider | Protected default constructor to allow subclassing
Back to Top
Methods
 | Name | Description
Public method | CreateSecurityContext | Create a SecurityContext for a consumer
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
Name | Description
DefaultProvider | Gets or sets the default SecurityContextProvider
Back to Top
See Also
SecurityContextProvider Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProvider Constructor

SecurityContextProvider Constructor Apache log4net™ SDK Documentation
Protected default constructor to allow subclassing

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SecurityContextProvider()
protected SecurityContextProvider()
Protected Sub New
Protected Sub New
protected:
SecurityContextProvider()
protected:
SecurityContextProvider()
Remarks

            Protected default constructor to allow subclassing

See Also
SecurityContextProvider Class
SecurityContextProvider Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProvider Methods

SecurityContextProvider Methods Apache log4net™ SDK Documentation
The SecurityContextProvider type exposes the following members.
Methods
 | Name | Description
Public method | CreateSecurityContext | Create a SecurityContext for a consumer
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SecurityContextProvider Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProvider.CreateSecurityContext Method

SecurityContextProvider CreateSecurityContext Method Apache log4net™ SDK Documentation
Create a SecurityContext for a consumer

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual SecurityContext CreateSecurityContext(
    Object consumer
)
public virtual SecurityContext CreateSecurityContext(
    Object consumer
)
Public Overridable Function CreateSecurityContext (
    consumer As Object
) As SecurityContext
Public Overridable Function CreateSecurityContext (
    consumer As Object
) As SecurityContext
public:
virtual SecurityContext^ CreateSecurityContext(
    Object^ consumer
)
public:
virtual SecurityContext^ CreateSecurityContext(
    Object^ consumer
)
Parameters
consumer
Type:   Online System Object
The consumer requesting the SecurityContext
Return Value
Type: SecurityContext
An impersonation context
Remarks

            The default implementation is to return a NullSecurityContext.

            Subclasses should override this method to provide their own
            behavior.

See Also
SecurityContextProvider Class
SecurityContextProvider Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProvider Properties

SecurityContextProvider Properties Apache log4net™ SDK Documentation
The SecurityContextProvider type exposes the following members.
Properties
Name | Description
DefaultProvider | Gets or sets the default SecurityContextProvider
Back to Top
See Also
SecurityContextProvider Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SecurityContextProvider.DefaultProvider Property

SecurityContextProvider DefaultProvider Property Apache log4net™ SDK Documentation
Gets or sets the default SecurityContextProvider

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static SecurityContextProvider DefaultProvider { get; set; }
public static SecurityContextProvider DefaultProvider { get; set; }
Public Shared Property DefaultProvider As SecurityContextProvider
    Get
    Set
Public Shared Property DefaultProvider As SecurityContextProvider
    Get
    Set
public:
static property SecurityContextProvider^ DefaultProvider {
    SecurityContextProvider^ get ();
    void set (SecurityContextProvider^ value);
}
public:
static property SecurityContextProvider^ DefaultProvider {
    SecurityContextProvider^ get ();
    void set (SecurityContextProvider^ value);
}
Property Value
Type: SecurityContextProvider

            The default SecurityContextProvider

Remarks

            The default provider is used by configured components that
            require a SecurityContext and have not had one
            given to them.

            By default this is an instance of SecurityContextProvider
            that returns NullSecurityContext objects.

            The default provider can be set programmatically by setting
            the value of this property to a sub class of SecurityContextProvider
            that has the desired behavior.

See Also
SecurityContextProvider Class
SecurityContextProvider Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StackFrameItem Class

StackFrameItem Class Apache log4net™ SDK Documentation
provides stack frame information without actually referencing a System.Diagnostics.StackFrame as that would require that the containing assembly is loaded.
Inheritance Hierarchy
Online System Object
log4net.Core StackFrameItem

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class StackFrameItem
[SerializableAttribute]
public class StackFrameItem
<SerializableAttribute>
Public Class StackFrameItem
<SerializableAttribute>
Public Class StackFrameItem
[SerializableAttribute]
public ref class StackFrameItem
[SerializableAttribute]
public ref class StackFrameItem
See Also
StackFrameItem Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StackFrameItem Members

StackFrameItem Members Apache log4net™ SDK Documentation
The StackFrameItem type exposes the following members.
Constructors
 | Name | Description
Public method | StackFrameItem | returns a stack frame item from a stack frame. This
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ClassName | Gets the fully qualified class name of the caller making the logging request.
Public property | FileName | Gets the file name of the caller.
Public property | FullInfo | Gets all available caller information
Public property | LineNumber | Gets the line number of the caller.
Public property | Method | Gets the method name of the caller.
Back to Top
See Also
StackFrameItem Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StackFrameItem Constructor

StackFrameItem Constructor Apache log4net™ SDK Documentation
returns a stack frame item from a stack frame. This

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StackFrameItem(
    StackFrame frame
)
public StackFrameItem(
    StackFrame frame
)
Public Sub New (
    frame As StackFrame
)
Public Sub New (
    frame As StackFrame
)
public:
StackFrameItem(
    StackFrame^ frame
)
public:
StackFrameItem(
    StackFrame^ frame
)
Parameters
frame
Type:   Online System.Diagnostics StackFrame
[Missing <param name="frame"/> documentation for "M:log4net.Core.StackFrameItem.#ctor(System.Diagnostics.StackFrame)"]
Return Value
Type:
See Also
StackFrameItem Class
StackFrameItem Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StackFrameItem Methods

StackFrameItem Methods Apache log4net™ SDK Documentation
The StackFrameItem type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
StackFrameItem Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StackFrameItem Properties

StackFrameItem Properties Apache log4net™ SDK Documentation
The StackFrameItem type exposes the following members.
Properties
 | Name | Description
Public property | ClassName | Gets the fully qualified class name of the caller making the logging request.
Public property | FileName | Gets the file name of the caller.
Public property | FullInfo | Gets all available caller information
Public property | LineNumber | Gets the line number of the caller.
Public property | Method | Gets the method name of the caller.
Back to Top
See Also
StackFrameItem Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StackFrameItem.ClassName Property

StackFrameItem ClassName Property Apache log4net™ SDK Documentation
Gets the fully qualified class name of the caller making the logging request.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ClassName { get; }
public string ClassName { get; }
Public ReadOnly Property ClassName As String
    Get
Public ReadOnly Property ClassName As String
    Get
public:
property String^ ClassName {
    String^ get ();
}
public:
property String^ ClassName {
    String^ get ();
}
Property Value
Type:   Online String

            The fully qualified class name of the caller making the logging
            request.

Remarks

            Gets the fully qualified class name of the caller making the logging
            request.

See Also
StackFrameItem Class
StackFrameItem Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StackFrameItem.FileName Property

StackFrameItem FileName Property Apache log4net™ SDK Documentation
Gets the file name of the caller.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FileName { get; }
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
public:
property String^ FileName {
    String^ get ();
}
Property Value
Type:   Online String

            The file name of the caller.

Remarks

            Gets the file name of the caller.

See Also
StackFrameItem Class
StackFrameItem Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StackFrameItem.FullInfo Property

StackFrameItem FullInfo Property Apache log4net™ SDK Documentation
Gets all available caller information

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FullInfo { get; }
public string FullInfo { get; }
Public ReadOnly Property FullInfo As String
    Get
Public ReadOnly Property FullInfo As String
    Get
public:
property String^ FullInfo {
    String^ get ();
}
public:
property String^ FullInfo {
    String^ get ();
}
Property Value
Type:   Online String

            All available caller information, in the format
            fully.qualified.classname.of.caller.methodName(Filename:line)
Remarks

            Gets all available caller information, in the format
            fully.qualified.classname.of.caller.methodName(Filename:line)
See Also
StackFrameItem Class
StackFrameItem Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StackFrameItem.LineNumber Property

StackFrameItem LineNumber Property Apache log4net™ SDK Documentation
Gets the line number of the caller.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LineNumber { get; }
public string LineNumber { get; }
Public ReadOnly Property LineNumber As String
    Get
Public ReadOnly Property LineNumber As String
    Get
public:
property String^ LineNumber {
    String^ get ();
}
public:
property String^ LineNumber {
    String^ get ();
}
Property Value
Type:   Online String

            The line number of the caller.

Remarks

            Gets the line number of the caller.

See Also
StackFrameItem Class
StackFrameItem Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StackFrameItem.Method Property

StackFrameItem Method Property Apache log4net™ SDK Documentation
Gets the method name of the caller.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodItem Method { get; }
public MethodItem Method { get; }
Public ReadOnly Property Method As MethodItem
    Get
Public ReadOnly Property Method As MethodItem
    Get
public:
property MethodItem^ Method {
    MethodItem^ get ();
}
public:
property MethodItem^ Method {
    MethodItem^ get ();
}
Property Value
Type: MethodItem

            The method name of the caller.

Remarks

            Gets the method name of the caller.

See Also
StackFrameItem Class
StackFrameItem Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TimeEvaluator Class

TimeEvaluator Class Apache log4net™ SDK Documentation
An evaluator that triggers after specified number of seconds.
Inheritance Hierarchy
Online System Object
log4net.Core TimeEvaluator

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimeEvaluator : ITriggeringEventEvaluator
public class TimeEvaluator : ITriggeringEventEvaluator
Public Class TimeEvaluator
    Implements ITriggeringEventEvaluator
Public Class TimeEvaluator
    Implements ITriggeringEventEvaluator
public ref class TimeEvaluator : ITriggeringEventEvaluator
public ref class TimeEvaluator : ITriggeringEventEvaluator
Remarks

            This evaluator will trigger if the specified time period
            Interval has passed since last check.

See Also
TimeEvaluator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TimeEvaluator Members

TimeEvaluator Members Apache log4net™ SDK Documentation
The TimeEvaluator type exposes the following members.
Constructors
 | Name | Description
Public method | TimeEvaluator | Create a new evaluator using the DEFAULT_INTERVAL time threshold in seconds.
Public method | TimeEvaluator(Int32) | Create a new evaluator using the specified time threshold in seconds.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsTriggeringEvent | Is this loggingEvent the triggering event?
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Interval | The time threshold in seconds to trigger after
Back to Top
See Also
TimeEvaluator Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TimeEvaluator Constructor

TimeEvaluator Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | TimeEvaluator | Create a new evaluator using the DEFAULT_INTERVAL time threshold in seconds.
Public method | TimeEvaluator(Int32) | Create a new evaluator using the specified time threshold in seconds.
Back to Top
See Also
TimeEvaluator Class
TimeEvaluator Members
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TimeEvaluator Constructor

TimeEvaluator Constructor Apache log4net™ SDK Documentation
Create a new evaluator using the DEFAULT_INTERVAL time threshold in seconds.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeEvaluator()
public TimeEvaluator()
Public Sub New
Public Sub New
public:
TimeEvaluator()
public:
TimeEvaluator()
Remarks

            Create a new evaluator using the DEFAULT_INTERVAL time threshold in seconds.

            This evaluator will trigger if the specified time period
            Interval has passed since last check.

See Also
TimeEvaluator Class
TimeEvaluator Members
TimeEvaluator Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TimeEvaluator Constructor (Int32)

TimeEvaluator Constructor (Int32) Apache log4net™ SDK Documentation
Create a new evaluator using the specified time threshold in seconds.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeEvaluator(
    int interval
)
public TimeEvaluator(
    int interval
)
Public Sub New (
    interval As Integer
)
Public Sub New (
    interval As Integer
)
public:
TimeEvaluator(
    int interval
)
public:
TimeEvaluator(
    int interval
)
Parameters
interval
Type:   Online System Int32

            The time threshold in seconds to trigger after.
            Zero means it won't trigger at all.

Remarks

            Create a new evaluator using the specified time threshold in seconds.

            This evaluator will trigger if the specified time period
            Interval has passed since last check.

See Also
TimeEvaluator Class
TimeEvaluator Members
TimeEvaluator Overload
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TimeEvaluator Methods

TimeEvaluator Methods Apache log4net™ SDK Documentation
The TimeEvaluator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsTriggeringEvent | Is this loggingEvent the triggering event?
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TimeEvaluator Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TimeEvaluator.IsTriggeringEvent Method

TimeEvaluator IsTriggeringEvent Method Apache log4net™ SDK Documentation
Is this loggingEvent the triggering event?

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsTriggeringEvent(
    LoggingEvent loggingEvent
)
public bool IsTriggeringEvent(
    LoggingEvent loggingEvent
)
Public Function IsTriggeringEvent (
    loggingEvent As LoggingEvent
) As Boolean
Public Function IsTriggeringEvent (
    loggingEvent As LoggingEvent
) As Boolean
public:
virtual bool IsTriggeringEvent(
    LoggingEvent^ loggingEvent
) sealed
public:
virtual bool IsTriggeringEvent(
    LoggingEvent^ loggingEvent
) sealed
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to check
Return Value
Type:   Online Boolean
This method returns true, if the specified time period
            Interval has passed since last check..
            Otherwise it returns false
Implements
ITriggeringEventEvaluator IsTriggeringEvent(LoggingEvent)
Remarks

            This evaluator will trigger if the specified time period
            Interval has passed since last check.

See Also
TimeEvaluator Class
TimeEvaluator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TimeEvaluator Properties

TimeEvaluator Properties Apache log4net™ SDK Documentation
The TimeEvaluator type exposes the following members.
Properties
 | Name | Description
Public property | Interval | The time threshold in seconds to trigger after
Back to Top
See Also
TimeEvaluator Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TimeEvaluator.Interval Property

TimeEvaluator Interval Property Apache log4net™ SDK Documentation
The time threshold in seconds to trigger after

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Interval { get; set; }
public int Interval { get; set; }
Public Property Interval As Integer
    Get
    Set
Public Property Interval As Integer
    Get
    Set
public:
property int Interval {
    int get ();
    void set (int value);
}
public:
property int Interval {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32

            The time threshold in seconds to trigger after.
            Zero means it won't trigger at all.

Remarks

            This evaluator will trigger if the specified time period
            Interval has passed since last check.

See Also
TimeEvaluator Class
TimeEvaluator Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WrapperCreationHandler Delegate

WrapperCreationHandler Delegate Apache log4net™ SDK Documentation
Delegate used to handle creation of new wrappers.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate ILoggerWrapper WrapperCreationHandler(
    ILogger logger
)
public delegate ILoggerWrapper WrapperCreationHandler(
    ILogger logger
)
Public Delegate Function WrapperCreationHandler (
    logger As ILogger
) As ILoggerWrapper
Public Delegate Function WrapperCreationHandler (
    logger As ILogger
) As ILoggerWrapper
public delegate ILoggerWrapper^ WrapperCreationHandler(
    ILogger^ logger
)
public delegate ILoggerWrapper^ WrapperCreationHandler(
    ILogger^ logger
)
Parameters
logger
Type: log4net.Core ILogger
The logger to wrap in a wrapper.
Return Value
Type: ILoggerWrapper
Remarks

            Delegate used to handle creation of new wrappers. This delegate
            is called from the CreateNewWrapperObject(ILogger)
            method to construct the wrapper for the specified logger.

            The delegate to use is supplied to the WrapperMap
            constructor.

See Also
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WrapperMap Class

WrapperMap Class Apache log4net™ SDK Documentation
Maps between logger objects and wrapper objects.
Inheritance Hierarchy
Online System Object
log4net.Core WrapperMap

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WrapperMap
public class WrapperMap
Public Class WrapperMap
Public Class WrapperMap
public ref class WrapperMap
public ref class WrapperMap
Remarks

            This class maintains a mapping between ILogger objects and
            ILoggerWrapper objects. Use the GetWrapper(ILogger) method to
            lookup the ILoggerWrapper for the specified ILogger.

            New wrapper instances are created by the CreateNewWrapperObject(ILogger)
            method. The default behavior is for this method to delegate construction
            of the wrapper to the WrapperCreationHandler delegate supplied
            to the constructor. This allows specialization of the behavior without
            requiring subclassing of this type.

See Also
WrapperMap Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WrapperMap Members

WrapperMap Members Apache log4net™ SDK Documentation
The WrapperMap type exposes the following members.
Constructors
 | Name | Description
Public method | WrapperMap | Initializes a new instance of the WrapperMap
Back to Top
Methods
 | Name | Description
Protected method | CreateNewWrapperObject | Creates the wrapper object for the specified logger.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWrapper | Gets the wrapper object for the specified logger.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | RepositoryShutdown | Called when a monitored repository shutdown event is received.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Protected property | Repositories | Gets the map of logger repositories.
Back to Top
See Also
WrapperMap Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WrapperMap Constructor

WrapperMap Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the WrapperMap

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WrapperMap(
    WrapperCreationHandler createWrapperHandler
)
public WrapperMap(
    WrapperCreationHandler createWrapperHandler
)
Public Sub New (
    createWrapperHandler As WrapperCreationHandler
)
Public Sub New (
    createWrapperHandler As WrapperCreationHandler
)
public:
WrapperMap(
    WrapperCreationHandler^ createWrapperHandler
)
public:
WrapperMap(
    WrapperCreationHandler^ createWrapperHandler
)
Parameters
createWrapperHandler
Type: log4net.Core WrapperCreationHandler
The handler to use to create the wrapper objects.
Remarks

            Initializes a new instance of the WrapperMap class with
            the specified handler to create the wrapper objects.

See Also
WrapperMap Class
WrapperMap Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WrapperMap Methods

WrapperMap Methods Apache log4net™ SDK Documentation
The WrapperMap type exposes the following members.
Methods
 | Name | Description
Protected method | CreateNewWrapperObject | Creates the wrapper object for the specified logger.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWrapper | Gets the wrapper object for the specified logger.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | RepositoryShutdown | Called when a monitored repository shutdown event is received.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
WrapperMap Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WrapperMap.CreateNewWrapperObject Method

WrapperMap CreateNewWrapperObject Method Apache log4net™ SDK Documentation
Creates the wrapper object for the specified logger.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual ILoggerWrapper CreateNewWrapperObject(
    ILogger logger
)
protected virtual ILoggerWrapper CreateNewWrapperObject(
    ILogger logger
)
Protected Overridable Function CreateNewWrapperObject (
    logger As ILogger
) As ILoggerWrapper
Protected Overridable Function CreateNewWrapperObject (
    logger As ILogger
) As ILoggerWrapper
protected:
virtual ILoggerWrapper^ CreateNewWrapperObject(
    ILogger^ logger
)
protected:
virtual ILoggerWrapper^ CreateNewWrapperObject(
    ILogger^ logger
)
Parameters
logger
Type: log4net.Core ILogger
The logger to wrap in a wrapper.
Return Value
Type: ILoggerWrapper
The wrapper object for the logger.
Remarks

            This implementation uses the WrapperCreationHandler
            passed to the constructor to create the wrapper. This method
            can be overridden in a subclass.

See Also
WrapperMap Class
WrapperMap Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WrapperMap.GetWrapper Method

WrapperMap GetWrapper Method Apache log4net™ SDK Documentation
Gets the wrapper object for the specified logger.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ILoggerWrapper GetWrapper(
    ILogger logger
)
public virtual ILoggerWrapper GetWrapper(
    ILogger logger
)
Public Overridable Function GetWrapper (
    logger As ILogger
) As ILoggerWrapper
Public Overridable Function GetWrapper (
    logger As ILogger
) As ILoggerWrapper
public:
virtual ILoggerWrapper^ GetWrapper(
    ILogger^ logger
)
public:
virtual ILoggerWrapper^ GetWrapper(
    ILogger^ logger
)
Parameters
logger
Type: log4net.Core ILogger
[Missing <param name="logger"/> documentation for "M:log4net.Core.WrapperMap.GetWrapper(log4net.Core.ILogger)"]
Return Value
Type: ILoggerWrapper
The wrapper object for the specified logger
Remarks

            If the logger is null then the corresponding wrapper is null.

            Looks up the wrapper it it has previously been requested and
            returns it. If the wrapper has never been requested before then
            the CreateNewWrapperObject(ILogger) virtual method is
            called.

See Also
WrapperMap Class
WrapperMap Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WrapperMap.RepositoryShutdown Method

WrapperMap RepositoryShutdown Method Apache log4net™ SDK Documentation
Called when a monitored repository shutdown event is received.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void RepositoryShutdown(
    ILoggerRepository repository
)
protected virtual void RepositoryShutdown(
    ILoggerRepository repository
)
Protected Overridable Sub RepositoryShutdown (
    repository As ILoggerRepository
)
Protected Overridable Sub RepositoryShutdown (
    repository As ILoggerRepository
)
protected:
virtual void RepositoryShutdown(
    ILoggerRepository^ repository
)
protected:
virtual void RepositoryShutdown(
    ILoggerRepository^ repository
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The ILoggerRepository that is shutting down
Remarks

            This method is called when a ILoggerRepository that this
            WrapperMap is holding loggers for has signaled its shutdown
            event ShutdownEvent. The default
            behavior of this method is to release the references to the loggers
            and their wrappers generated for this repository.

See Also
WrapperMap Class
WrapperMap Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WrapperMap Properties

WrapperMap Properties Apache log4net™ SDK Documentation
The WrapperMap type exposes the following members.
Properties
 | Name | Description
Protected property | Repositories | Gets the map of logger repositories.
Back to Top
See Also
WrapperMap Class
log4net.Core Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WrapperMap.Repositories Property

WrapperMap Repositories Property Apache log4net™ SDK Documentation
Gets the map of logger repositories.

Namespace: log4net.Core
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Hashtable Repositories { get; }
protected Hashtable Repositories { get; }
Protected ReadOnly Property Repositories As Hashtable
    Get
Protected ReadOnly Property Repositories As Hashtable
    Get
protected:
property Hashtable^ Repositories {
    Hashtable^ get ();
}
protected:
property Hashtable^ Repositories {
    Hashtable^ get ();
}
Property Value
Type:   Online Hashtable

            Map of logger repositories.

Remarks

            Gets the hashtable that is keyed on ILoggerRepository. The
            values are hashtables keyed on ILogger with the
            value being the corresponding ILoggerWrapper.

See Also
WrapperMap Class
WrapperMap Members
log4net.Core Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.DateFormatter Namespace

log4net.DateFormatter Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | AbsoluteTimeDateFormatter | Formats a Online DateTime as "HH:mm:ss,fff".
Public class | DateTimeDateFormatter | Formats a Online DateTime as "dd MMM yyyy HH:mm:ss,fff"
Public class | Iso8601DateFormatter | Formats the Online DateTime as "yyyy-MM-dd HH:mm:ss,fff".
Public class | SimpleDateFormatter | Formats the Online DateTime using the [M:DateTime.ToString(string, IFormatProvider)] method.
Interfaces
 | Interface | Description
Public interface | IDateFormatter | Render a Online DateTime as a string.

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AbsoluteTimeDateFormatter Class

AbsoluteTimeDateFormatter Class Apache log4net™ SDK Documentation
Formats a Online DateTime as "HH:mm:ss,fff".
Inheritance Hierarchy
Online System Object
log4net.DateFormatter AbsoluteTimeDateFormatter
log4net.DateFormatter DateTimeDateFormatter
log4net.DateFormatter Iso8601DateFormatter

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AbsoluteTimeDateFormatter : IDateFormatter
public class AbsoluteTimeDateFormatter : IDateFormatter
Public Class AbsoluteTimeDateFormatter
    Implements IDateFormatter
Public Class AbsoluteTimeDateFormatter
    Implements IDateFormatter
public ref class AbsoluteTimeDateFormatter : IDateFormatter
public ref class AbsoluteTimeDateFormatter : IDateFormatter
Remarks

            Formats a   Online DateTime in the format "HH:mm:ss,fff" for example, "15:49:37,459".

See Also
AbsoluteTimeDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AbsoluteTimeDateFormatter Members

AbsoluteTimeDateFormatter Members Apache log4net™ SDK Documentation
The AbsoluteTimeDateFormatter type exposes the following members.
Constructors
 | Name | Description
Public method | AbsoluteTimeDateFormatter | Initializes a new instance of the AbsoluteTimeDateFormatter class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormatDate | Renders the date into a string. Format is "HH:mm:ss,fff".
Protected method | FormatDateWithoutMillis | Renders the date into a string. Format is "HH:mm:ss".
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
AbsoluteTimeDateFormat | String constant used to specify AbsoluteTimeDateFormat in layouts. Current value is ABSOLUTE.
DateAndTimeDateFormat | String constant used to specify DateTimeDateFormat in layouts. Current value is DATE.
Iso8601TimeDateFormat | String constant used to specify ISO8601DateFormat in layouts. Current value is ISO8601.
Back to Top
See Also
AbsoluteTimeDateFormatter Class
log4net.DateFormatter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AbsoluteTimeDateFormatter Constructor

AbsoluteTimeDateFormatter Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the AbsoluteTimeDateFormatter class

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AbsoluteTimeDateFormatter()
public AbsoluteTimeDateFormatter()
Public Sub New
Public Sub New
public:
AbsoluteTimeDateFormatter()
public:
AbsoluteTimeDateFormatter()
See Also
AbsoluteTimeDateFormatter Class
AbsoluteTimeDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AbsoluteTimeDateFormatter Fields

AbsoluteTimeDateFormatter Fields Apache log4net™ SDK Documentation
The AbsoluteTimeDateFormatter type exposes the following members.
Fields
Name | Description
AbsoluteTimeDateFormat | String constant used to specify AbsoluteTimeDateFormat in layouts. Current value is ABSOLUTE.
DateAndTimeDateFormat | String constant used to specify DateTimeDateFormat in layouts. Current value is DATE.
Iso8601TimeDateFormat | String constant used to specify ISO8601DateFormat in layouts. Current value is ISO8601.
Back to Top
See Also
AbsoluteTimeDateFormatter Class
log4net.DateFormatter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AbsoluteTimeDateFormatter.AbsoluteTimeDateFormat Field

AbsoluteTimeDateFormatter AbsoluteTimeDateFormat Field Apache log4net™ SDK Documentation
String constant used to specify AbsoluteTimeDateFormat in layouts. Current value is ABSOLUTE.

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AbsoluteTimeDateFormat
public const string AbsoluteTimeDateFormat
Public Const AbsoluteTimeDateFormat As String
Public Const AbsoluteTimeDateFormat As String
public:
literal String^ AbsoluteTimeDateFormat
public:
literal String^ AbsoluteTimeDateFormat
Field Value
Type:   Online String
See Also
AbsoluteTimeDateFormatter Class
AbsoluteTimeDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AbsoluteTimeDateFormatter.DateAndTimeDateFormat Field

AbsoluteTimeDateFormatter DateAndTimeDateFormat Field Apache log4net™ SDK Documentation
String constant used to specify DateTimeDateFormat in layouts. Current value is DATE.

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DateAndTimeDateFormat
public const string DateAndTimeDateFormat
Public Const DateAndTimeDateFormat As String
Public Const DateAndTimeDateFormat As String
public:
literal String^ DateAndTimeDateFormat
public:
literal String^ DateAndTimeDateFormat
Field Value
Type:   Online String
See Also
AbsoluteTimeDateFormatter Class
AbsoluteTimeDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AbsoluteTimeDateFormatter.Iso8601TimeDateFormat Field

AbsoluteTimeDateFormatter Iso8601TimeDateFormat Field Apache log4net™ SDK Documentation
String constant used to specify ISO8601DateFormat in layouts. Current value is ISO8601.

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string Iso8601TimeDateFormat
public const string Iso8601TimeDateFormat
Public Const Iso8601TimeDateFormat As String
Public Const Iso8601TimeDateFormat As String
public:
literal String^ Iso8601TimeDateFormat
public:
literal String^ Iso8601TimeDateFormat
Field Value
Type:   Online String
See Also
AbsoluteTimeDateFormatter Class
AbsoluteTimeDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AbsoluteTimeDateFormatter Methods

AbsoluteTimeDateFormatter Methods Apache log4net™ SDK Documentation
The AbsoluteTimeDateFormatter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormatDate | Renders the date into a string. Format is "HH:mm:ss,fff".
Protected method | FormatDateWithoutMillis | Renders the date into a string. Format is "HH:mm:ss".
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AbsoluteTimeDateFormatter Class
log4net.DateFormatter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AbsoluteTimeDateFormatter.FormatDate Method

AbsoluteTimeDateFormatter FormatDate Method Apache log4net™ SDK Documentation
Renders the date into a string. Format is "HH:mm:ss,fff".

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FormatDate(
    DateTime dateToFormat,
    TextWriter writer
)
public virtual void FormatDate(
    DateTime dateToFormat,
    TextWriter writer
)
Public Overridable Sub FormatDate (
    dateToFormat As DateTime,
    writer As TextWriter
)
Public Overridable Sub FormatDate (
    dateToFormat As DateTime,
    writer As TextWriter
)
public:
virtual void FormatDate(
    DateTime dateToFormat,
    TextWriter^ writer
)
public:
virtual void FormatDate(
    DateTime dateToFormat,
    TextWriter^ writer
)
Parameters
dateToFormat
Type:   Online System DateTime
The date to render into a string.
writer
Type:   Online System.IO TextWriter
The writer to write to.
Implements
IDateFormatter FormatDate(DateTime, TextWriter)
Remarks

            Uses the FormatDateWithoutMillis(DateTime, StringBuilder) method to generate the
            time string up to the seconds and then appends the current
            milliseconds. The results from FormatDateWithoutMillis(DateTime, StringBuilder) are
            cached and FormatDateWithoutMillis(DateTime, StringBuilder) is called at most once
            per second.

            Sub classes should override FormatDateWithoutMillis(DateTime, StringBuilder)
            rather than FormatDate(DateTime, TextWriter).

See Also
AbsoluteTimeDateFormatter Class
AbsoluteTimeDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AbsoluteTimeDateFormatter.FormatDateWithoutMillis Method

AbsoluteTimeDateFormatter FormatDateWithoutMillis Method Apache log4net™ SDK Documentation
Renders the date into a string. Format is "HH:mm:ss".

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void FormatDateWithoutMillis(
    DateTime dateToFormat,
    StringBuilder buffer
)
protected virtual void FormatDateWithoutMillis(
    DateTime dateToFormat,
    StringBuilder buffer
)
Protected Overridable Sub FormatDateWithoutMillis (
    dateToFormat As DateTime,
    buffer As StringBuilder
)
Protected Overridable Sub FormatDateWithoutMillis (
    dateToFormat As DateTime,
    buffer As StringBuilder
)
protected:
virtual void FormatDateWithoutMillis(
    DateTime dateToFormat,
    StringBuilder^ buffer
)
protected:
virtual void FormatDateWithoutMillis(
    DateTime dateToFormat,
    StringBuilder^ buffer
)
Parameters
dateToFormat
Type:   Online System DateTime
The date to render into a string.
buffer
Type:   Online System.Text StringBuilder
The string builder to write to.
Remarks

            Subclasses should override this method to render the date
            into a string using a precision up to the second. This method
            will be called at most once per second and the result will be
            reused if it is needed again during the same second.

See Also
AbsoluteTimeDateFormatter Class
AbsoluteTimeDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DateTimeDateFormatter Class

DateTimeDateFormatter Class Apache log4net™ SDK Documentation
Formats a Online DateTime as "dd MMM yyyy HH:mm:ss,fff"
Inheritance Hierarchy
Online System Object
log4net.DateFormatter AbsoluteTimeDateFormatter
log4net.DateFormatter DateTimeDateFormatter

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DateTimeDateFormatter : AbsoluteTimeDateFormatter
public class DateTimeDateFormatter : AbsoluteTimeDateFormatter
Public Class DateTimeDateFormatter
    Inherits AbsoluteTimeDateFormatter
Public Class DateTimeDateFormatter
    Inherits AbsoluteTimeDateFormatter
public ref class DateTimeDateFormatter : public AbsoluteTimeDateFormatter
public ref class DateTimeDateFormatter : public AbsoluteTimeDateFormatter
Remarks

            Formats a   Online DateTime in the format
            "dd MMM yyyy HH:mm:ss,fff" for example,
            "06 Nov 1994 15:49:37,459".

See Also
DateTimeDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DateTimeDateFormatter Members

DateTimeDateFormatter Members Apache log4net™ SDK Documentation
The DateTimeDateFormatter type exposes the following members.
Constructors
 | Name | Description
Public method | DateTimeDateFormatter | Default constructor.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormatDate | Renders the date into a string. Format is "HH:mm:ss,fff". (Inherited from AbsoluteTimeDateFormatter.)
Protected method | FormatDateWithoutMillis | Formats the date without the milliseconds part (Overrides AbsoluteTimeDateFormatter FormatDateWithoutMillis(DateTime, StringBuilder).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DateTimeDateFormatter Class
log4net.DateFormatter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DateTimeDateFormatter Constructor

DateTimeDateFormatter Constructor Apache log4net™ SDK Documentation
Default constructor.

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTimeDateFormatter()
public DateTimeDateFormatter()
Public Sub New
Public Sub New
public:
DateTimeDateFormatter()
public:
DateTimeDateFormatter()
Remarks

            Initializes a new instance of the DateTimeDateFormatter class.

See Also
DateTimeDateFormatter Class
DateTimeDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DateTimeDateFormatter Methods

DateTimeDateFormatter Methods Apache log4net™ SDK Documentation
The DateTimeDateFormatter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormatDate | Renders the date into a string. Format is "HH:mm:ss,fff". (Inherited from AbsoluteTimeDateFormatter.)
Protected method | FormatDateWithoutMillis | Formats the date without the milliseconds part (Overrides AbsoluteTimeDateFormatter FormatDateWithoutMillis(DateTime, StringBuilder).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DateTimeDateFormatter Class
log4net.DateFormatter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DateTimeDateFormatter.FormatDateWithoutMillis Method

DateTimeDateFormatter FormatDateWithoutMillis Method Apache log4net™ SDK Documentation
Formats the date without the milliseconds part

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void FormatDateWithoutMillis(
    DateTime dateToFormat,
    StringBuilder buffer
)
protected override void FormatDateWithoutMillis(
    DateTime dateToFormat,
    StringBuilder buffer
)
Protected Overrides Sub FormatDateWithoutMillis (
    dateToFormat As DateTime,
    buffer As StringBuilder
)
Protected Overrides Sub FormatDateWithoutMillis (
    dateToFormat As DateTime,
    buffer As StringBuilder
)
protected:
virtual void FormatDateWithoutMillis(
    DateTime dateToFormat,
    StringBuilder^ buffer
) override
protected:
virtual void FormatDateWithoutMillis(
    DateTime dateToFormat,
    StringBuilder^ buffer
) override
Parameters
dateToFormat
Type:   Online System DateTime
The date to format.
buffer
Type:   Online System.Text StringBuilder
The string builder to write to.
Remarks

            Formats a DateTime in the format "dd MMM yyyy HH:mm:ss"
            for example, "06 Nov 1994 15:49:37".

            The base class will append the ",fff" milliseconds section.
            This method will only be called at most once per second.

See Also
DateTimeDateFormatter Class
DateTimeDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IDateFormatter Interface

IDateFormatter Interface Apache log4net™ SDK Documentation
Render a Online DateTime as a string.

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDateFormatter
public interface IDateFormatter
Public Interface IDateFormatter
Public Interface IDateFormatter
public interface class IDateFormatter
public interface class IDateFormatter
Remarks

            Interface to abstract the rendering of a   Online DateTime
            instance into a string.

            The FormatDate(DateTime, TextWriter) method is used to render the
            date to a text writer.

See Also
IDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IDateFormatter Members

IDateFormatter Members Apache log4net™ SDK Documentation
The IDateFormatter type exposes the following members.
Methods
 | Name | Description
Public method | FormatDate | Formats the specified date as a string.
Back to Top
See Also
IDateFormatter Interface
log4net.DateFormatter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IDateFormatter Methods

IDateFormatter Methods Apache log4net™ SDK Documentation
The IDateFormatter type exposes the following members.
Methods
 | Name | Description
Public method | FormatDate | Formats the specified date as a string.
Back to Top
See Also
IDateFormatter Interface
log4net.DateFormatter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IDateFormatter.FormatDate Method

IDateFormatter FormatDate Method Apache log4net™ SDK Documentation
Formats the specified date as a string.

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void FormatDate(
    DateTime dateToFormat,
    TextWriter writer
)
void FormatDate(
    DateTime dateToFormat,
    TextWriter writer
)
Sub FormatDate (
    dateToFormat As DateTime,
    writer As TextWriter
)
Sub FormatDate (
    dateToFormat As DateTime,
    writer As TextWriter
)
void FormatDate(
    DateTime dateToFormat,
    TextWriter^ writer
)
void FormatDate(
    DateTime dateToFormat,
    TextWriter^ writer
)
Parameters
dateToFormat
Type:   Online System DateTime
The date to format.
writer
Type:   Online System.IO TextWriter
The writer to write to.
Remarks

            Format the   Online DateTime as a string and write it
            to the   Online TextWriter provided.

See Also
IDateFormatter Interface
IDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Iso8601DateFormatter Class

Iso8601DateFormatter Class Apache log4net™ SDK Documentation
Formats the Online DateTime as "yyyy-MM-dd HH:mm:ss,fff".
Inheritance Hierarchy
Online System Object
log4net.DateFormatter AbsoluteTimeDateFormatter
log4net.DateFormatter Iso8601DateFormatter

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Iso8601DateFormatter : AbsoluteTimeDateFormatter
public class Iso8601DateFormatter : AbsoluteTimeDateFormatter
Public Class Iso8601DateFormatter
    Inherits AbsoluteTimeDateFormatter
Public Class Iso8601DateFormatter
    Inherits AbsoluteTimeDateFormatter
public ref class Iso8601DateFormatter : public AbsoluteTimeDateFormatter
public ref class Iso8601DateFormatter : public AbsoluteTimeDateFormatter
Remarks

            Formats the   Online DateTime specified as a string: "yyyy-MM-dd HH:mm:ss,fff".

See Also
Iso8601DateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Iso8601DateFormatter Members

Iso8601DateFormatter Members Apache log4net™ SDK Documentation
The Iso8601DateFormatter type exposes the following members.
Constructors
 | Name | Description
Public method | Iso8601DateFormatter | Default constructor
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormatDate | Renders the date into a string. Format is "HH:mm:ss,fff". (Inherited from AbsoluteTimeDateFormatter.)
Protected method | FormatDateWithoutMillis | Formats the date without the milliseconds part (Overrides AbsoluteTimeDateFormatter FormatDateWithoutMillis(DateTime, StringBuilder).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Iso8601DateFormatter Class
log4net.DateFormatter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Iso8601DateFormatter Constructor

Iso8601DateFormatter Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Iso8601DateFormatter()
public Iso8601DateFormatter()
Public Sub New
Public Sub New
public:
Iso8601DateFormatter()
public:
Iso8601DateFormatter()
Remarks

            Initializes a new instance of the Iso8601DateFormatter class.

See Also
Iso8601DateFormatter Class
Iso8601DateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Iso8601DateFormatter Methods

Iso8601DateFormatter Methods Apache log4net™ SDK Documentation
The Iso8601DateFormatter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormatDate | Renders the date into a string. Format is "HH:mm:ss,fff". (Inherited from AbsoluteTimeDateFormatter.)
Protected method | FormatDateWithoutMillis | Formats the date without the milliseconds part (Overrides AbsoluteTimeDateFormatter FormatDateWithoutMillis(DateTime, StringBuilder).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Iso8601DateFormatter Class
log4net.DateFormatter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Iso8601DateFormatter.FormatDateWithoutMillis Method

Iso8601DateFormatter FormatDateWithoutMillis Method Apache log4net™ SDK Documentation
Formats the date without the milliseconds part

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void FormatDateWithoutMillis(
    DateTime dateToFormat,
    StringBuilder buffer
)
protected override void FormatDateWithoutMillis(
    DateTime dateToFormat,
    StringBuilder buffer
)
Protected Overrides Sub FormatDateWithoutMillis (
    dateToFormat As DateTime,
    buffer As StringBuilder
)
Protected Overrides Sub FormatDateWithoutMillis (
    dateToFormat As DateTime,
    buffer As StringBuilder
)
protected:
virtual void FormatDateWithoutMillis(
    DateTime dateToFormat,
    StringBuilder^ buffer
) override
protected:
virtual void FormatDateWithoutMillis(
    DateTime dateToFormat,
    StringBuilder^ buffer
) override
Parameters
dateToFormat
Type:   Online System DateTime
The date to format.
buffer
Type:   Online System.Text StringBuilder
The string builder to write to.
Remarks

            Formats the date specified as a string: "yyyy-MM-dd HH:mm:ss".

            The base class will append the ",fff" milliseconds section.
            This method will only be called at most once per second.

See Also
Iso8601DateFormatter Class
Iso8601DateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleDateFormatter Class

SimpleDateFormatter Class Apache log4net™ SDK Documentation
Formats the Online DateTime using the [M:DateTime.ToString(string, IFormatProvider)] method.
Inheritance Hierarchy
Online System Object
log4net.DateFormatter SimpleDateFormatter

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SimpleDateFormatter : IDateFormatter
public class SimpleDateFormatter : IDateFormatter
Public Class SimpleDateFormatter
    Implements IDateFormatter
Public Class SimpleDateFormatter
    Implements IDateFormatter
public ref class SimpleDateFormatter : IDateFormatter
public ref class SimpleDateFormatter : IDateFormatter
Remarks

            Formats the   Online DateTime using the   Online DateTime [M:DateTime.ToString(string, IFormatProvider)] method.

See Also
SimpleDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleDateFormatter Members

SimpleDateFormatter Members Apache log4net™ SDK Documentation
The SimpleDateFormatter type exposes the following members.
Constructors
 | Name | Description
Public method | SimpleDateFormatter | Constructor
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormatDate | Formats the date using [M:DateTime.ToString(string, IFormatProvider)].
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleDateFormatter Class
log4net.DateFormatter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleDateFormatter Constructor

SimpleDateFormatter Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleDateFormatter(
    string format
)
public SimpleDateFormatter(
    string format
)
Public Sub New (
    format As String
)
Public Sub New (
    format As String
)
public:
SimpleDateFormatter(
    String^ format
)
public:
SimpleDateFormatter(
    String^ format
)
Parameters
format
Type:   Online System String
The format string.
Remarks

            Initializes a new instance of the SimpleDateFormatter class
            with the specified format string.

            The format string must be compatible with the options
            that can be supplied to [M:DateTime.ToString(string, IFormatProvider)].

See Also
SimpleDateFormatter Class
SimpleDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleDateFormatter Methods

SimpleDateFormatter Methods Apache log4net™ SDK Documentation
The SimpleDateFormatter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormatDate | Formats the date using [M:DateTime.ToString(string, IFormatProvider)].
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleDateFormatter Class
log4net.DateFormatter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleDateFormatter.FormatDate Method

SimpleDateFormatter FormatDate Method Apache log4net™ SDK Documentation
Formats the date using [M:DateTime.ToString(string, IFormatProvider)].

Namespace: log4net.DateFormatter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FormatDate(
    DateTime dateToFormat,
    TextWriter writer
)
public virtual void FormatDate(
    DateTime dateToFormat,
    TextWriter writer
)
Public Overridable Sub FormatDate (
    dateToFormat As DateTime,
    writer As TextWriter
)
Public Overridable Sub FormatDate (
    dateToFormat As DateTime,
    writer As TextWriter
)
public:
virtual void FormatDate(
    DateTime dateToFormat,
    TextWriter^ writer
)
public:
virtual void FormatDate(
    DateTime dateToFormat,
    TextWriter^ writer
)
Parameters
dateToFormat
Type:   Online System DateTime
The date to convert to a string.
writer
Type:   Online System.IO TextWriter
The writer to write to.
Implements
IDateFormatter FormatDate(DateTime, TextWriter)
Remarks

            Uses the date format string supplied to the constructor to call
            the [M:DateTime.ToString(string, IFormatProvider)] method to format the date.

See Also
SimpleDateFormatter Class
SimpleDateFormatter Members
log4net.DateFormatter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.Filter Namespace

log4net.Filter Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | DenyAllFilter | This filter drops all LoggingEvent.
Public class | FilterSkeleton | Subclass this type to implement customized logging event filtering
Public class | LevelMatchFilter | This is a very simple filter based on Level matching.
Public class | LevelRangeFilter | This is a simple filter based on Level matching.
Public class | LoggerMatchFilter | Simple filter to match a string in the event's logger name.
Public class | MdcFilter | Simple filter to match a keyed string in the MDC
Public class | NdcFilter | Simple filter to match a string in the NDC
Public class | PropertyFilter | Simple filter to match a string an event property
Public class | StringMatchFilter | Simple filter to match a string in the rendered message
Interfaces
 | Interface | Description
Public interface | IFilter | Implement this interface to provide customized logging event filtering
Enumerations
 | Enumeration | Description
Public enumeration | FilterDecision | The return result from Decide(LoggingEvent)

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DenyAllFilter Class

DenyAllFilter Class Apache log4net™ SDK Documentation
This filter drops all LoggingEvent.
Inheritance Hierarchy
Online System Object
log4net.Filter FilterSkeleton
log4net.Filter DenyAllFilter

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class DenyAllFilter : FilterSkeleton
public sealed class DenyAllFilter : FilterSkeleton
Public NotInheritable Class DenyAllFilter
    Inherits FilterSkeleton
Public NotInheritable Class DenyAllFilter
    Inherits FilterSkeleton
public ref class DenyAllFilter sealed : public FilterSkeleton
public ref class DenyAllFilter sealed : public FilterSkeleton
Remarks

            You can add this filter to the end of a filter chain to
            switch from the default "accept all unless instructed otherwise"
            filtering behavior to a "deny all unless instructed otherwise"
            behavior.

See Also
DenyAllFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DenyAllFilter Members

DenyAllFilter Members Apache log4net™ SDK Documentation
The DenyAllFilter type exposes the following members.
Constructors
 | Name | Description
Public method | DenyAllFilter | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the filter with the options set (Inherited from FilterSkeleton.)
Public method | Decide | Always returns the integer constant Deny (Overrides FilterSkeleton Decide(LoggingEvent).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Back to Top
See Also
DenyAllFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DenyAllFilter Constructor

DenyAllFilter Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DenyAllFilter()
public DenyAllFilter()
Public Sub New
Public Sub New
public:
DenyAllFilter()
public:
DenyAllFilter()
See Also
DenyAllFilter Class
DenyAllFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DenyAllFilter Methods

DenyAllFilter Methods Apache log4net™ SDK Documentation
The DenyAllFilter type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the filter with the options set (Inherited from FilterSkeleton.)
Public method | Decide | Always returns the integer constant Deny (Overrides FilterSkeleton Decide(LoggingEvent).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DenyAllFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DenyAllFilter.Decide Method

DenyAllFilter Decide Method Apache log4net™ SDK Documentation
Always returns the integer constant Deny

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FilterDecision Decide(
    LoggingEvent loggingEvent
)
public override FilterDecision Decide(
    LoggingEvent loggingEvent
)
Public Overrides Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
Public Overrides Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) override
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the LoggingEvent to filter
Return Value
Type: FilterDecision
Always returns Deny
Implements
IFilter Decide(LoggingEvent)
Remarks

            Ignores the event being logged and just returns
            Deny. This can be used to change the default filter
            chain behavior from Accept to Deny. This filter
            should only be used as the last filter in the chain
            as any further filters will be ignored!

See Also
DenyAllFilter Class
DenyAllFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DenyAllFilter Properties

DenyAllFilter Properties Apache log4net™ SDK Documentation
The DenyAllFilter type exposes the following members.
Properties
 | Name | Description
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Back to Top
See Also
DenyAllFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FilterDecision Enumeration

FilterDecision Enumeration Apache log4net™ SDK Documentation
The return result from Decide(LoggingEvent)

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum FilterDecision
public enum FilterDecision
Public Enumeration FilterDecision
Public Enumeration FilterDecision
public enum class FilterDecision
public enum class FilterDecision
Members
Member name | Value | Description
Deny | -1 | The log event must be dropped immediately without consulting with the remaining filters, if any, in the chain.
Neutral | 0 | This filter is neutral with respect to the log event. The remaining filters, if any, should be consulted for a final decision.
Accept | 1 | The log event must be logged immediately without consulting with the remaining filters, if any, in the chain.
Remarks

            The return result from Decide(LoggingEvent)
See Also
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FilterSkeleton Class

FilterSkeleton Class Apache log4net™ SDK Documentation
Subclass this type to implement customized logging event filtering
Inheritance Hierarchy
Online System Object
log4net.Filter FilterSkeleton
log4net.Filter DenyAllFilter
log4net.Filter LevelMatchFilter
log4net.Filter LevelRangeFilter
log4net.Filter LoggerMatchFilter
log4net.Filter StringMatchFilter

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FilterSkeleton : IFilter,
    IOptionHandler
public abstract class FilterSkeleton : IFilter,
    IOptionHandler
Public MustInherit Class FilterSkeleton
    Implements IFilter, IOptionHandler
Public MustInherit Class FilterSkeleton
    Implements IFilter, IOptionHandler
public ref class FilterSkeleton abstract : IFilter,
    IOptionHandler
public ref class FilterSkeleton abstract : IFilter,
    IOptionHandler
Remarks

            Users should extend this class to implement customized logging
            event filtering. Note that Logger and
            AppenderSkeleton, the parent class of all standard
            appenders, have built-in filtering rules. It is suggested that you
            first use and understand the built-in rules before rushing to write
            your own custom filters.

            This abstract class assumes and also imposes that filters be
            organized in a linear chain. The Decide(LoggingEvent)
            method of each filter is called sequentially, in the order of their
            addition to the chain.

            The Decide(LoggingEvent) method must return one
            of the integer constants Deny,
            Neutral or Accept.

            If the value Deny is returned, then the log event is dropped
            immediately without consulting with the remaining filters.

            If the value Neutral is returned, then the next filter
            in the chain is consulted. If there are no more filters in the
            chain, then the log event is logged. Thus, in the presence of no
            filters, the default behavior is to log all logging events.

            If the value Accept is returned, then the log
            event is logged without consulting the remaining filters.

            The philosophy of log4net filters is largely inspired from the
            Linux ipchains.

See Also
FilterSkeleton Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FilterSkeleton Members

FilterSkeleton Members Apache log4net™ SDK Documentation
The FilterSkeleton type exposes the following members.
Constructors
 | Name | Description
Protected method | FilterSkeleton | Initializes a new instance of the FilterSkeleton class
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the filter with the options set
Public method | Decide | Decide if the LoggingEvent should be logged through an appender.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Next | Property to get and set the next filter
Back to Top
See Also
FilterSkeleton Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FilterSkeleton Constructor

FilterSkeleton Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the FilterSkeleton class

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FilterSkeleton()
protected FilterSkeleton()
Protected Sub New
Protected Sub New
protected:
FilterSkeleton()
protected:
FilterSkeleton()
See Also
FilterSkeleton Class
FilterSkeleton Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FilterSkeleton Methods

FilterSkeleton Methods Apache log4net™ SDK Documentation
The FilterSkeleton type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the filter with the options set
Public method | Decide | Decide if the LoggingEvent should be logged through an appender.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FilterSkeleton Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FilterSkeleton.ActivateOptions Method

FilterSkeleton ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the filter with the options set

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ActivateOptions()
public virtual void ActivateOptions()
Public Overridable Sub ActivateOptions
Public Overridable Sub ActivateOptions
public:
virtual void ActivateOptions()
public:
virtual void ActivateOptions()
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

            Typically filter's options become active immediately on set,
            however this method must still be called.

See Also
FilterSkeleton Class
FilterSkeleton Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FilterSkeleton.Decide Method

FilterSkeleton Decide Method Apache log4net™ SDK Documentation
Decide if the LoggingEvent should be logged through an appender.

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract FilterDecision Decide(
    LoggingEvent loggingEvent
)
public abstract FilterDecision Decide(
    LoggingEvent loggingEvent
)
Public MustOverride Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
Public MustOverride Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) abstract
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) abstract
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The LoggingEvent to decide upon
Return Value
Type: FilterDecision
The decision of the filter
Implements
IFilter Decide(LoggingEvent)
Remarks

            If the decision is Deny, then the event will be
            dropped. If the decision is Neutral, then the next
            filter, if any, will be invoked. If the decision is Accept then
            the event will be logged without consulting with other filters in
            the chain.

            This method is marked abstract and must be implemented
            in a subclass.

See Also
FilterSkeleton Class
FilterSkeleton Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FilterSkeleton Properties

FilterSkeleton Properties Apache log4net™ SDK Documentation
The FilterSkeleton type exposes the following members.
Properties
 | Name | Description
Public property | Next | Property to get and set the next filter
Back to Top
See Also
FilterSkeleton Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FilterSkeleton.Next Property

FilterSkeleton Next Property Apache log4net™ SDK Documentation
Property to get and set the next filter

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFilter Next { get; set; }
public IFilter Next { get; set; }
Public Property Next As IFilter
    Get
    Set
Public Property Next As IFilter
    Get
    Set
public:
virtual property IFilter^ Next {
    IFilter^ get () sealed;
    void set (IFilter^ value) sealed;
}
public:
virtual property IFilter^ Next {
    IFilter^ get () sealed;
    void set (IFilter^ value) sealed;
}
Property Value
Type: IFilter

            The next filter in the chain

Implements
IFilter Next
Remarks

            Filters are typically composed into chains. This property allows the next filter in
            the chain to be accessed.

See Also
FilterSkeleton Class
FilterSkeleton Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IFilter Interface

IFilter Interface Apache log4net™ SDK Documentation
Implement this interface to provide customized logging event filtering

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IFilter : IOptionHandler
public interface IFilter : IOptionHandler
Public Interface IFilter
    Inherits IOptionHandler
Public Interface IFilter
    Inherits IOptionHandler
public interface class IFilter : IOptionHandler
public interface class IFilter : IOptionHandler
Remarks

            Users should implement this interface to implement customized logging
            event filtering. Note that Logger and
            AppenderSkeleton, the parent class of all standard
            appenders, have built-in filtering rules. It is suggested that you
            first use and understand the built-in rules before rushing to write
            your own custom filters.

            This abstract class assumes and also imposes that filters be
            organized in a linear chain. The Decide(LoggingEvent)
            method of each filter is called sequentially, in the order of their
            addition to the chain.

            The Decide(LoggingEvent) method must return one
            of the integer constants Deny,
            Neutral or Accept.

            If the value Deny is returned, then the log event is dropped
            immediately without consulting with the remaining filters.

            If the value Neutral is returned, then the next filter
            in the chain is consulted. If there are no more filters in the
            chain, then the log event is logged. Thus, in the presence of no
            filters, the default behavior is to log all logging events.

            If the value Accept is returned, then the log
            event is logged without consulting the remaining filters.

            The philosophy of log4net filters is largely inspired from the
            Linux ipchains.

See Also
IFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IFilter Members

IFilter Members Apache log4net™ SDK Documentation
The IFilter type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Activate the options that were previously set with calls to properties. (Inherited from IOptionHandler.)
Public method | Decide | Decide if the logging event should be logged through an appender.
Back to Top
Properties
 | Name | Description
Public property | Next | Property to get and set the next filter
Back to Top
See Also
IFilter Interface
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IFilter Methods

IFilter Methods Apache log4net™ SDK Documentation
The IFilter type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Activate the options that were previously set with calls to properties. (Inherited from IOptionHandler.)
Public method | Decide | Decide if the logging event should be logged through an appender.
Back to Top
See Also
IFilter Interface
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IFilter.Decide Method

IFilter Decide Method Apache log4net™ SDK Documentation
Decide if the logging event should be logged through an appender.

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
FilterDecision Decide(
    LoggingEvent loggingEvent
)
FilterDecision Decide(
    LoggingEvent loggingEvent
)
Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
FilterDecision Decide(
    LoggingEvent^ loggingEvent
)
FilterDecision Decide(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The LoggingEvent to decide upon
Return Value
Type: FilterDecision
The decision of the filter
Remarks

            If the decision is Deny, then the event will be
            dropped. If the decision is Neutral, then the next
            filter, if any, will be invoked. If the decision is Accept then
            the event will be logged without consulting with other filters in
            the chain.

See Also
IFilter Interface
IFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IFilter Properties

IFilter Properties Apache log4net™ SDK Documentation
The IFilter type exposes the following members.
Properties
 | Name | Description
Public property | Next | Property to get and set the next filter
Back to Top
See Also
IFilter Interface
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IFilter.Next Property

IFilter Next Property Apache log4net™ SDK Documentation
Property to get and set the next filter

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IFilter Next { get; set; }
IFilter Next { get; set; }
Property Next As IFilter
    Get
    Set
Property Next As IFilter
    Get
    Set
property IFilter^ Next {
    IFilter^ get ();
    void set (IFilter^ value);
}
property IFilter^ Next {
    IFilter^ get ();
    void set (IFilter^ value);
}
Property Value
Type: IFilter

            The next filter in the chain

Remarks

            Filters are typically composed into chains. This property allows the next filter in
            the chain to be accessed.

See Also
IFilter Interface
IFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMatchFilter Class

LevelMatchFilter Class Apache log4net™ SDK Documentation
This is a very simple filter based on Level matching.
Inheritance Hierarchy
Online System Object
log4net.Filter FilterSkeleton
log4net.Filter LevelMatchFilter

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LevelMatchFilter : FilterSkeleton
public class LevelMatchFilter : FilterSkeleton
Public Class LevelMatchFilter
    Inherits FilterSkeleton
Public Class LevelMatchFilter
    Inherits FilterSkeleton
public ref class LevelMatchFilter : public FilterSkeleton
public ref class LevelMatchFilter : public FilterSkeleton
Remarks

            The filter admits two options LevelToMatch and
            AcceptOnMatch. If there is an exact match between the value
            of the LevelToMatch option and the Level of the
            LoggingEvent, then the Decide(LoggingEvent) method returns Accept in
            case the AcceptOnMatch option value is set
            to true, if it is false then
            Deny is returned. If the Level does not match then
            the result will be Neutral.

See Also
LevelMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMatchFilter Members

LevelMatchFilter Members Apache log4net™ SDK Documentation
The LevelMatchFilter type exposes the following members.
Constructors
 | Name | Description
Public method | LevelMatchFilter | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the filter with the options set (Inherited from FilterSkeleton.)
Public method | Decide | Tests if the Level of the logging event matches that of the filter (Overrides FilterSkeleton Decide(LoggingEvent).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching LevelToMatch
Public property | LevelToMatch | The Level that the filter will match
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Back to Top
See Also
LevelMatchFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMatchFilter Constructor

LevelMatchFilter Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelMatchFilter()
public LevelMatchFilter()
Public Sub New
Public Sub New
public:
LevelMatchFilter()
public:
LevelMatchFilter()
See Also
LevelMatchFilter Class
LevelMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMatchFilter Methods

LevelMatchFilter Methods Apache log4net™ SDK Documentation
The LevelMatchFilter type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the filter with the options set (Inherited from FilterSkeleton.)
Public method | Decide | Tests if the Level of the logging event matches that of the filter (Overrides FilterSkeleton Decide(LoggingEvent).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LevelMatchFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMatchFilter.Decide Method

LevelMatchFilter Decide Method Apache log4net™ SDK Documentation
Tests if the Level of the logging event matches that of the filter

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FilterDecision Decide(
    LoggingEvent loggingEvent
)
public override FilterDecision Decide(
    LoggingEvent loggingEvent
)
Public Overrides Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
Public Overrides Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) override
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the event to filter
Return Value
Type: FilterDecision
see remarks
Implements
IFilter Decide(LoggingEvent)
Remarks

            If the Level of the event matches the level of the
            filter then the result of the function depends on the
            value of AcceptOnMatch. If it is true then
            the function will return Accept, it it is false then it
            will return Deny. If the Level does not match then
            the result will be Neutral.

See Also
LevelMatchFilter Class
LevelMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMatchFilter Properties

LevelMatchFilter Properties Apache log4net™ SDK Documentation
The LevelMatchFilter type exposes the following members.
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching LevelToMatch
Public property | LevelToMatch | The Level that the filter will match
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Back to Top
See Also
LevelMatchFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMatchFilter.AcceptOnMatch Property

LevelMatchFilter AcceptOnMatch Property Apache log4net™ SDK Documentation
Accept when matching LevelToMatch

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AcceptOnMatch { get; set; }
public bool AcceptOnMatch { get; set; }
Public Property AcceptOnMatch As Boolean
    Get
    Set
Public Property AcceptOnMatch As Boolean
    Get
    Set
public:
property bool AcceptOnMatch {
    bool get ();
    void set (bool value);
}
public:
property bool AcceptOnMatch {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
Remarks

            The AcceptOnMatch property is a flag that determines
            the behavior when a matching Level is found. If the
            flag is set to true then the filter will Accept the
            logging event, otherwise it will Deny the event.

            The default is true i.e. to Accept the event.

See Also
LevelMatchFilter Class
LevelMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMatchFilter.LevelToMatch Property

LevelMatchFilter LevelToMatch Property Apache log4net™ SDK Documentation
The Level that the filter will match

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level LevelToMatch { get; set; }
public Level LevelToMatch { get; set; }
Public Property LevelToMatch As Level
    Get
    Set
Public Property LevelToMatch As Level
    Get
    Set
public:
property Level^ LevelToMatch {
    Level^ get ();
    void set (Level^ value);
}
public:
property Level^ LevelToMatch {
    Level^ get ();
    void set (Level^ value);
}
Property Value
Type: Level
Remarks

            The level that this filter will attempt to match against the
            LoggingEvent level. If a match is found then
            the result depends on the value of AcceptOnMatch.

See Also
LevelMatchFilter Class
LevelMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelRangeFilter Class

LevelRangeFilter Class Apache log4net™ SDK Documentation
This is a simple filter based on Level matching.
Inheritance Hierarchy
Online System Object
log4net.Filter FilterSkeleton
log4net.Filter LevelRangeFilter

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LevelRangeFilter : FilterSkeleton
public class LevelRangeFilter : FilterSkeleton
Public Class LevelRangeFilter
    Inherits FilterSkeleton
Public Class LevelRangeFilter
    Inherits FilterSkeleton
public ref class LevelRangeFilter : public FilterSkeleton
public ref class LevelRangeFilter : public FilterSkeleton
Remarks

            The filter admits three options LevelMin and LevelMax
            that determine the range of priorities that are matched, and
            AcceptOnMatch. If there is a match between the range
            of priorities and the Level of the LoggingEvent, then the
            Decide(LoggingEvent) method returns Accept in case the AcceptOnMatch
            option value is set to true, if it is false
            then Deny is returned. If there is no match, Deny is returned.

See Also
LevelRangeFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelRangeFilter Members

LevelRangeFilter Members Apache log4net™ SDK Documentation
The LevelRangeFilter type exposes the following members.
Constructors
 | Name | Description
Public method | LevelRangeFilter | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the filter with the options set (Inherited from FilterSkeleton.)
Public method | Decide | Check if the event should be logged. (Overrides FilterSkeleton Decide(LoggingEvent).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching LevelMin and LevelMax
Public property | LevelMax | Sets the maximum matched Level
Public property | LevelMin | Set the minimum matched Level
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Back to Top
See Also
LevelRangeFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelRangeFilter Constructor

LevelRangeFilter Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelRangeFilter()
public LevelRangeFilter()
Public Sub New
Public Sub New
public:
LevelRangeFilter()
public:
LevelRangeFilter()
See Also
LevelRangeFilter Class
LevelRangeFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelRangeFilter Methods

LevelRangeFilter Methods Apache log4net™ SDK Documentation
The LevelRangeFilter type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the filter with the options set (Inherited from FilterSkeleton.)
Public method | Decide | Check if the event should be logged. (Overrides FilterSkeleton Decide(LoggingEvent).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LevelRangeFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelRangeFilter.Decide Method

LevelRangeFilter Decide Method Apache log4net™ SDK Documentation
Check if the event should be logged.

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FilterDecision Decide(
    LoggingEvent loggingEvent
)
public override FilterDecision Decide(
    LoggingEvent loggingEvent
)
Public Overrides Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
Public Overrides Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) override
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the logging event to check
Return Value
Type: FilterDecision
see remarks
Implements
IFilter Decide(LoggingEvent)
Remarks

            If the Level of the logging event is outside the range
            matched by this filter then Deny
            is returned. If the Level is matched then the value of
            AcceptOnMatch is checked. If it is true then
            Accept is returned, otherwise
            Neutral is returned.

See Also
LevelRangeFilter Class
LevelRangeFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelRangeFilter Properties

LevelRangeFilter Properties Apache log4net™ SDK Documentation
The LevelRangeFilter type exposes the following members.
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching LevelMin and LevelMax
Public property | LevelMax | Sets the maximum matched Level
Public property | LevelMin | Set the minimum matched Level
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Back to Top
See Also
LevelRangeFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelRangeFilter.AcceptOnMatch Property

LevelRangeFilter AcceptOnMatch Property Apache log4net™ SDK Documentation
Accept when matching LevelMin and LevelMax

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AcceptOnMatch { get; set; }
public bool AcceptOnMatch { get; set; }
Public Property AcceptOnMatch As Boolean
    Get
    Set
Public Property AcceptOnMatch As Boolean
    Get
    Set
public:
property bool AcceptOnMatch {
    bool get ();
    void set (bool value);
}
public:
property bool AcceptOnMatch {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
Remarks

            The AcceptOnMatch property is a flag that determines
            the behavior when a matching Level is found. If the
            flag is set to true then the filter will Accept the
            logging event, otherwise it will Neutral the event.

            The default is true i.e. to Accept the event.

See Also
LevelRangeFilter Class
LevelRangeFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelRangeFilter.LevelMax Property

LevelRangeFilter LevelMax Property Apache log4net™ SDK Documentation
Sets the maximum matched Level

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level LevelMax { get; set; }
public Level LevelMax { get; set; }
Public Property LevelMax As Level
    Get
    Set
Public Property LevelMax As Level
    Get
    Set
public:
property Level^ LevelMax {
    Level^ get ();
    void set (Level^ value);
}
public:
property Level^ LevelMax {
    Level^ get ();
    void set (Level^ value);
}
Property Value
Type: Level
Remarks

            The maximum level that this filter will attempt to match against the
            LoggingEvent level. If a match is found then
            the result depends on the value of AcceptOnMatch.

See Also
LevelRangeFilter Class
LevelRangeFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelRangeFilter.LevelMin Property

LevelRangeFilter LevelMin Property Apache log4net™ SDK Documentation
Set the minimum matched Level

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level LevelMin { get; set; }
public Level LevelMin { get; set; }
Public Property LevelMin As Level
    Get
    Set
Public Property LevelMin As Level
    Get
    Set
public:
property Level^ LevelMin {
    Level^ get ();
    void set (Level^ value);
}
public:
property Level^ LevelMin {
    Level^ get ();
    void set (Level^ value);
}
Property Value
Type: Level
Remarks

            The minimum level that this filter will attempt to match against the
            LoggingEvent level. If a match is found then
            the result depends on the value of AcceptOnMatch.

See Also
LevelRangeFilter Class
LevelRangeFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerMatchFilter Class

LoggerMatchFilter Class Apache log4net™ SDK Documentation
Simple filter to match a string in the event's logger name.
Inheritance Hierarchy
Online System Object
log4net.Filter FilterSkeleton
log4net.Filter LoggerMatchFilter

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LoggerMatchFilter : FilterSkeleton
public class LoggerMatchFilter : FilterSkeleton
Public Class LoggerMatchFilter
    Inherits FilterSkeleton
Public Class LoggerMatchFilter
    Inherits FilterSkeleton
public ref class LoggerMatchFilter : public FilterSkeleton
public ref class LoggerMatchFilter : public FilterSkeleton
Remarks

            The works very similar to the LevelMatchFilter. It admits two
            options LoggerToMatch and AcceptOnMatch. If the
            LoggerName of the LoggingEvent starts
            with the value of the LoggerToMatch option, then the
            Decide(LoggingEvent) method returns Accept in
            case the AcceptOnMatch option value is set to true,
            if it is false then Deny is returned.

See Also
LoggerMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerMatchFilter Members

LoggerMatchFilter Members Apache log4net™ SDK Documentation
The LoggerMatchFilter type exposes the following members.
Constructors
 | Name | Description
Public method | LoggerMatchFilter | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the filter with the options set (Inherited from FilterSkeleton.)
Public method | Decide | Check if this filter should allow the event to be logged (Overrides FilterSkeleton Decide(LoggingEvent).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching LoggerToMatch
Public property | LoggerToMatch | The LoggerName that the filter will match
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Back to Top
See Also
LoggerMatchFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerMatchFilter Constructor

LoggerMatchFilter Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggerMatchFilter()
public LoggerMatchFilter()
Public Sub New
Public Sub New
public:
LoggerMatchFilter()
public:
LoggerMatchFilter()
See Also
LoggerMatchFilter Class
LoggerMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerMatchFilter Methods

LoggerMatchFilter Methods Apache log4net™ SDK Documentation
The LoggerMatchFilter type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the filter with the options set (Inherited from FilterSkeleton.)
Public method | Decide | Check if this filter should allow the event to be logged (Overrides FilterSkeleton Decide(LoggingEvent).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LoggerMatchFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerMatchFilter.Decide Method

LoggerMatchFilter Decide Method Apache log4net™ SDK Documentation
Check if this filter should allow the event to be logged

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FilterDecision Decide(
    LoggingEvent loggingEvent
)
public override FilterDecision Decide(
    LoggingEvent loggingEvent
)
Public Overrides Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
Public Overrides Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) override
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the event being logged
Return Value
Type: FilterDecision
see remarks
Implements
IFilter Decide(LoggingEvent)
Remarks

            The rendered message is matched against the LoggerToMatch.
            If the LoggerToMatch equals the beginning of
            the incoming LoggerName (StartsWith(string))
            then a match will have occurred. If no match occurs
            this function will return Neutral
            allowing other filters to check the event. If a match occurs then
            the value of AcceptOnMatch is checked. If it is
            true then Accept is returned otherwise
            Deny is returned.

See Also
LoggerMatchFilter Class
LoggerMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerMatchFilter Properties

LoggerMatchFilter Properties Apache log4net™ SDK Documentation
The LoggerMatchFilter type exposes the following members.
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching LoggerToMatch
Public property | LoggerToMatch | The LoggerName that the filter will match
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Back to Top
See Also
LoggerMatchFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerMatchFilter.AcceptOnMatch Property

LoggerMatchFilter AcceptOnMatch Property Apache log4net™ SDK Documentation
Accept when matching LoggerToMatch

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AcceptOnMatch { get; set; }
public bool AcceptOnMatch { get; set; }
Public Property AcceptOnMatch As Boolean
    Get
    Set
Public Property AcceptOnMatch As Boolean
    Get
    Set
public:
property bool AcceptOnMatch {
    bool get ();
    void set (bool value);
}
public:
property bool AcceptOnMatch {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
Remarks

            The AcceptOnMatch property is a flag that determines
            the behavior when a matching Level is found. If the
            flag is set to true then the filter will Accept the
            logging event, otherwise it will Deny the event.

            The default is true i.e. to Accept the event.

See Also
LoggerMatchFilter Class
LoggerMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerMatchFilter.LoggerToMatch Property

LoggerMatchFilter LoggerToMatch Property Apache log4net™ SDK Documentation
The LoggerName that the filter will match

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LoggerToMatch { get; set; }
public string LoggerToMatch { get; set; }
Public Property LoggerToMatch As String
    Get
    Set
Public Property LoggerToMatch As String
    Get
    Set
public:
property String^ LoggerToMatch {
    String^ get ();
    void set (String^ value);
}
public:
property String^ LoggerToMatch {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            This filter will attempt to match this value against logger name in
            the following way. The match will be done against the beginning of the
            logger name (using StartsWith(string)). The match is
            case sensitive. If a match is found then
            the result depends on the value of AcceptOnMatch.

See Also
LoggerMatchFilter Class
LoggerMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MdcFilter Class

MdcFilter Class Apache log4net™ SDK Documentation
Simple filter to match a keyed string in the MDC
Inheritance Hierarchy
Online System Object
log4net.Filter FilterSkeleton
log4net.Filter StringMatchFilter
log4net.Filter PropertyFilter
log4net.Filter MdcFilter

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MdcFilter : PropertyFilter
public class MdcFilter : PropertyFilter
Public Class MdcFilter
    Inherits PropertyFilter
Public Class MdcFilter
    Inherits PropertyFilter
public ref class MdcFilter : public PropertyFilter
public ref class MdcFilter : public PropertyFilter
Remarks

            Simple filter to match a keyed string in the MDC

            As the MDC has been replaced with layered properties the
            PropertyFilter should be used instead.

See Also
MdcFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MdcFilter Members

MdcFilter Members Apache log4net™ SDK Documentation
The MdcFilter type exposes the following members.
Constructors
 | Name | Description
Public method | MdcFilter | Initializes a new instance of the MdcFilter class
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize and precompile the Regex if required (Inherited from StringMatchFilter.)
Public method | Decide | Check if this filter should allow the event to be logged (Inherited from PropertyFilter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | m_acceptOnMatch | Flag to indicate the behavior when we have a match (Inherited from StringMatchFilter.)
Protected field | m_regexToMatch | A regex object to match (generated from m_stringRegexToMatch) (Inherited from StringMatchFilter.)
Protected field | m_stringRegexToMatch | A string regex to match (Inherited from StringMatchFilter.)
Protected field | m_stringToMatch | The string to substring match against the message (Inherited from StringMatchFilter.)
Back to Top
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching StringToMatch or RegexToMatch (Inherited from StringMatchFilter.)
Public property | Key | The key to lookup in the event properties and then match against. (Inherited from PropertyFilter.)
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Public property | RegexToMatch | Sets the regular expression to match (Inherited from StringMatchFilter.)
Public property | StringToMatch | Sets the static string to match (Inherited from StringMatchFilter.)
Back to Top
See Also
MdcFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MdcFilter Constructor

MdcFilter Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the MdcFilter class

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MdcFilter()
public MdcFilter()
Public Sub New
Public Sub New
public:
MdcFilter()
public:
MdcFilter()
See Also
MdcFilter Class
MdcFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MdcFilter Fields

MdcFilter Fields Apache log4net™ SDK Documentation
The MdcFilter type exposes the following members.
Fields
 | Name | Description
Protected field | m_acceptOnMatch | Flag to indicate the behavior when we have a match (Inherited from StringMatchFilter.)
Protected field | m_regexToMatch | A regex object to match (generated from m_stringRegexToMatch) (Inherited from StringMatchFilter.)
Protected field | m_stringRegexToMatch | A string regex to match (Inherited from StringMatchFilter.)
Protected field | m_stringToMatch | The string to substring match against the message (Inherited from StringMatchFilter.)
Back to Top
See Also
MdcFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MdcFilter Methods

MdcFilter Methods Apache log4net™ SDK Documentation
The MdcFilter type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize and precompile the Regex if required (Inherited from StringMatchFilter.)
Public method | Decide | Check if this filter should allow the event to be logged (Inherited from PropertyFilter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MdcFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


MdcFilter Properties

MdcFilter Properties Apache log4net™ SDK Documentation
The MdcFilter type exposes the following members.
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching StringToMatch or RegexToMatch (Inherited from StringMatchFilter.)
Public property | Key | The key to lookup in the event properties and then match against. (Inherited from PropertyFilter.)
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Public property | RegexToMatch | Sets the regular expression to match (Inherited from StringMatchFilter.)
Public property | StringToMatch | Sets the static string to match (Inherited from StringMatchFilter.)
Back to Top
See Also
MdcFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NdcFilter Class

NdcFilter Class Apache log4net™ SDK Documentation
Simple filter to match a string in the NDC
Inheritance Hierarchy
Online System Object
log4net.Filter FilterSkeleton
log4net.Filter StringMatchFilter
log4net.Filter PropertyFilter
log4net.Filter NdcFilter

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NdcFilter : PropertyFilter
public class NdcFilter : PropertyFilter
Public Class NdcFilter
    Inherits PropertyFilter
Public Class NdcFilter
    Inherits PropertyFilter
public ref class NdcFilter : public PropertyFilter
public ref class NdcFilter : public PropertyFilter
Remarks

            Simple filter to match a string in the NDC

            As the MDC has been replaced with named stacks stored in the
            properties collections the PropertyFilter should
            be used instead.

See Also
NdcFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NdcFilter Members

NdcFilter Members Apache log4net™ SDK Documentation
The NdcFilter type exposes the following members.
Constructors
 | Name | Description
Public method | NdcFilter | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize and precompile the Regex if required (Inherited from StringMatchFilter.)
Public method | Decide | Check if this filter should allow the event to be logged (Inherited from PropertyFilter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | m_acceptOnMatch | Flag to indicate the behavior when we have a match (Inherited from StringMatchFilter.)
Protected field | m_regexToMatch | A regex object to match (generated from m_stringRegexToMatch) (Inherited from StringMatchFilter.)
Protected field | m_stringRegexToMatch | A string regex to match (Inherited from StringMatchFilter.)
Protected field | m_stringToMatch | The string to substring match against the message (Inherited from StringMatchFilter.)
Back to Top
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching StringToMatch or RegexToMatch (Inherited from StringMatchFilter.)
Public property | Key | The key to lookup in the event properties and then match against. (Inherited from PropertyFilter.)
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Public property | RegexToMatch | Sets the regular expression to match (Inherited from StringMatchFilter.)
Public property | StringToMatch | Sets the static string to match (Inherited from StringMatchFilter.)
Back to Top
See Also
NdcFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NdcFilter Constructor

NdcFilter Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NdcFilter()
public NdcFilter()
Public Sub New
Public Sub New
public:
NdcFilter()
public:
NdcFilter()
Remarks

            Sets the Key to "NDC".

See Also
NdcFilter Class
NdcFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NdcFilter Fields

NdcFilter Fields Apache log4net™ SDK Documentation
The NdcFilter type exposes the following members.
Fields
 | Name | Description
Protected field | m_acceptOnMatch | Flag to indicate the behavior when we have a match (Inherited from StringMatchFilter.)
Protected field | m_regexToMatch | A regex object to match (generated from m_stringRegexToMatch) (Inherited from StringMatchFilter.)
Protected field | m_stringRegexToMatch | A string regex to match (Inherited from StringMatchFilter.)
Protected field | m_stringToMatch | The string to substring match against the message (Inherited from StringMatchFilter.)
Back to Top
See Also
NdcFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NdcFilter Methods

NdcFilter Methods Apache log4net™ SDK Documentation
The NdcFilter type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize and precompile the Regex if required (Inherited from StringMatchFilter.)
Public method | Decide | Check if this filter should allow the event to be logged (Inherited from PropertyFilter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NdcFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NdcFilter Properties

NdcFilter Properties Apache log4net™ SDK Documentation
The NdcFilter type exposes the following members.
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching StringToMatch or RegexToMatch (Inherited from StringMatchFilter.)
Public property | Key | The key to lookup in the event properties and then match against. (Inherited from PropertyFilter.)
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Public property | RegexToMatch | Sets the regular expression to match (Inherited from StringMatchFilter.)
Public property | StringToMatch | Sets the static string to match (Inherited from StringMatchFilter.)
Back to Top
See Also
NdcFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyFilter Class

PropertyFilter Class Apache log4net™ SDK Documentation
Simple filter to match a string an event property
Inheritance Hierarchy
Online System Object
log4net.Filter FilterSkeleton
log4net.Filter StringMatchFilter
log4net.Filter PropertyFilter
log4net.Filter MdcFilter
log4net.Filter NdcFilter

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PropertyFilter : StringMatchFilter
public class PropertyFilter : StringMatchFilter
Public Class PropertyFilter
    Inherits StringMatchFilter
Public Class PropertyFilter
    Inherits StringMatchFilter
public ref class PropertyFilter : public StringMatchFilter
public ref class PropertyFilter : public StringMatchFilter
Remarks

            Simple filter to match a string in the value for a
            specific event property

See Also
PropertyFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyFilter Members

PropertyFilter Members Apache log4net™ SDK Documentation
The PropertyFilter type exposes the following members.
Constructors
 | Name | Description
Public method | PropertyFilter | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize and precompile the Regex if required (Inherited from StringMatchFilter.)
Public method | Decide | Check if this filter should allow the event to be logged (Overrides StringMatchFilter Decide(LoggingEvent).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | m_acceptOnMatch | Flag to indicate the behavior when we have a match (Inherited from StringMatchFilter.)
Protected field | m_regexToMatch | A regex object to match (generated from m_stringRegexToMatch) (Inherited from StringMatchFilter.)
Protected field | m_stringRegexToMatch | A string regex to match (Inherited from StringMatchFilter.)
Protected field | m_stringToMatch | The string to substring match against the message (Inherited from StringMatchFilter.)
Back to Top
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching StringToMatch or RegexToMatch (Inherited from StringMatchFilter.)
Public property | Key | The key to lookup in the event properties and then match against.
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Public property | RegexToMatch | Sets the regular expression to match (Inherited from StringMatchFilter.)
Public property | StringToMatch | Sets the static string to match (Inherited from StringMatchFilter.)
Back to Top
See Also
PropertyFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyFilter Constructor

PropertyFilter Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PropertyFilter()
public PropertyFilter()
Public Sub New
Public Sub New
public:
PropertyFilter()
public:
PropertyFilter()
See Also
PropertyFilter Class
PropertyFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyFilter Fields

PropertyFilter Fields Apache log4net™ SDK Documentation
The PropertyFilter type exposes the following members.
Fields
 | Name | Description
Protected field | m_acceptOnMatch | Flag to indicate the behavior when we have a match (Inherited from StringMatchFilter.)
Protected field | m_regexToMatch | A regex object to match (generated from m_stringRegexToMatch) (Inherited from StringMatchFilter.)
Protected field | m_stringRegexToMatch | A string regex to match (Inherited from StringMatchFilter.)
Protected field | m_stringToMatch | The string to substring match against the message (Inherited from StringMatchFilter.)
Back to Top
See Also
PropertyFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyFilter Methods

PropertyFilter Methods Apache log4net™ SDK Documentation
The PropertyFilter type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize and precompile the Regex if required (Inherited from StringMatchFilter.)
Public method | Decide | Check if this filter should allow the event to be logged (Overrides StringMatchFilter Decide(LoggingEvent).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PropertyFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyFilter.Decide Method

PropertyFilter Decide Method Apache log4net™ SDK Documentation
Check if this filter should allow the event to be logged

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FilterDecision Decide(
    LoggingEvent loggingEvent
)
public override FilterDecision Decide(
    LoggingEvent loggingEvent
)
Public Overrides Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
Public Overrides Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) override
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the event being logged
Return Value
Type: FilterDecision
see remarks
Implements
IFilter Decide(LoggingEvent)
Remarks

            The event property for the Key is matched against
            the StringToMatch.
            If the StringToMatch occurs as a substring within
            the property value then a match will have occurred. If no match occurs
            this function will return Neutral
            allowing other filters to check the event. If a match occurs then
            the value of AcceptOnMatch is checked. If it is
            true then Accept is returned otherwise
            Deny is returned.

See Also
PropertyFilter Class
PropertyFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyFilter Properties

PropertyFilter Properties Apache log4net™ SDK Documentation
The PropertyFilter type exposes the following members.
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching StringToMatch or RegexToMatch (Inherited from StringMatchFilter.)
Public property | Key | The key to lookup in the event properties and then match against.
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Public property | RegexToMatch | Sets the regular expression to match (Inherited from StringMatchFilter.)
Public property | StringToMatch | Sets the static string to match (Inherited from StringMatchFilter.)
Back to Top
See Also
PropertyFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyFilter.Key Property

PropertyFilter Key Property Apache log4net™ SDK Documentation
The key to lookup in the event properties and then match against.

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; set; }
public string Key { get; set; }
Public Property Key As String
    Get
    Set
Public Property Key As String
    Get
    Set
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            The key name to use to lookup in the properties map of the
            LoggingEvent. The match will be performed against
            the value of this property if it exists.

See Also
PropertyFilter Class
PropertyFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter Class

StringMatchFilter Class Apache log4net™ SDK Documentation
Simple filter to match a string in the rendered message
Inheritance Hierarchy
Online System Object
log4net.Filter FilterSkeleton
log4net.Filter StringMatchFilter
log4net.Filter PropertyFilter

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StringMatchFilter : FilterSkeleton
public class StringMatchFilter : FilterSkeleton
Public Class StringMatchFilter
    Inherits FilterSkeleton
Public Class StringMatchFilter
    Inherits FilterSkeleton
public ref class StringMatchFilter : public FilterSkeleton
public ref class StringMatchFilter : public FilterSkeleton
Remarks

            Simple filter to match a string in the rendered message

See Also
StringMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter Members

StringMatchFilter Members Apache log4net™ SDK Documentation
The StringMatchFilter type exposes the following members.
Constructors
 | Name | Description
Public method | StringMatchFilter | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize and precompile the Regex if required (Overrides FilterSkeleton ActivateOptions .)
Public method | Decide | Check if this filter should allow the event to be logged (Overrides FilterSkeleton Decide(LoggingEvent).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | m_acceptOnMatch | Flag to indicate the behavior when we have a match
Protected field | m_regexToMatch | A regex object to match (generated from m_stringRegexToMatch)
Protected field | m_stringRegexToMatch | A string regex to match
Protected field | m_stringToMatch | The string to substring match against the message
Back to Top
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching StringToMatch or RegexToMatch
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Public property | RegexToMatch | Sets the regular expression to match
Public property | StringToMatch | Sets the static string to match
Back to Top
See Also
StringMatchFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter Constructor

StringMatchFilter Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringMatchFilter()
public StringMatchFilter()
Public Sub New
Public Sub New
public:
StringMatchFilter()
public:
StringMatchFilter()
See Also
StringMatchFilter Class
StringMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter Fields

StringMatchFilter Fields Apache log4net™ SDK Documentation
The StringMatchFilter type exposes the following members.
Fields
 | Name | Description
Protected field | m_acceptOnMatch | Flag to indicate the behavior when we have a match
Protected field | m_regexToMatch | A regex object to match (generated from m_stringRegexToMatch)
Protected field | m_stringRegexToMatch | A string regex to match
Protected field | m_stringToMatch | The string to substring match against the message
Back to Top
See Also
StringMatchFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter.m_acceptOnMatch Field

StringMatchFilter m_acceptOnMatch Field Apache log4net™ SDK Documentation
Flag to indicate the behavior when we have a match

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool m_acceptOnMatch
protected bool m_acceptOnMatch
Protected m_acceptOnMatch As Boolean
Protected m_acceptOnMatch As Boolean
protected:
bool m_acceptOnMatch
protected:
bool m_acceptOnMatch
Field Value
Type:   Online Boolean
See Also
StringMatchFilter Class
StringMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter.m_regexToMatch Field

StringMatchFilter m_regexToMatch Field Apache log4net™ SDK Documentation
A regex object to match (generated from m_stringRegexToMatch)

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Regex m_regexToMatch
protected Regex m_regexToMatch
Protected m_regexToMatch As Regex
Protected m_regexToMatch As Regex
protected:
Regex^ m_regexToMatch
protected:
Regex^ m_regexToMatch
Field Value
Type:   Online Regex
See Also
StringMatchFilter Class
StringMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter.m_stringRegexToMatch Field

StringMatchFilter m_stringRegexToMatch Field Apache log4net™ SDK Documentation
A string regex to match

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string m_stringRegexToMatch
protected string m_stringRegexToMatch
Protected m_stringRegexToMatch As String
Protected m_stringRegexToMatch As String
protected:
String^ m_stringRegexToMatch
protected:
String^ m_stringRegexToMatch
Field Value
Type:   Online String
See Also
StringMatchFilter Class
StringMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter.m_stringToMatch Field

StringMatchFilter m_stringToMatch Field Apache log4net™ SDK Documentation
The string to substring match against the message

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string m_stringToMatch
protected string m_stringToMatch
Protected m_stringToMatch As String
Protected m_stringToMatch As String
protected:
String^ m_stringToMatch
protected:
String^ m_stringToMatch
Field Value
Type:   Online String
See Also
StringMatchFilter Class
StringMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter Methods

StringMatchFilter Methods Apache log4net™ SDK Documentation
The StringMatchFilter type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize and precompile the Regex if required (Overrides FilterSkeleton ActivateOptions .)
Public method | Decide | Check if this filter should allow the event to be logged (Overrides FilterSkeleton Decide(LoggingEvent).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
StringMatchFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter.ActivateOptions Method

StringMatchFilter ActivateOptions Method Apache log4net™ SDK Documentation
Initialize and precompile the Regex if required

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
StringMatchFilter Class
StringMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter.Decide Method

StringMatchFilter Decide Method Apache log4net™ SDK Documentation
Check if this filter should allow the event to be logged

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FilterDecision Decide(
    LoggingEvent loggingEvent
)
public override FilterDecision Decide(
    LoggingEvent loggingEvent
)
Public Overrides Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
Public Overrides Function Decide (
    loggingEvent As LoggingEvent
) As FilterDecision
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) override
public:
virtual FilterDecision Decide(
    LoggingEvent^ loggingEvent
) override
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the event being logged
Return Value
Type: FilterDecision
see remarks
Implements
IFilter Decide(LoggingEvent)
Remarks

            The rendered message is matched against the StringToMatch.
            If the StringToMatch occurs as a substring within
            the message then a match will have occurred. If no match occurs
            this function will return Neutral
            allowing other filters to check the event. If a match occurs then
            the value of AcceptOnMatch is checked. If it is
            true then Accept is returned otherwise
            Deny is returned.

See Also
StringMatchFilter Class
StringMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter Properties

StringMatchFilter Properties Apache log4net™ SDK Documentation
The StringMatchFilter type exposes the following members.
Properties
 | Name | Description
Public property | AcceptOnMatch | Accept when matching StringToMatch or RegexToMatch
Public property | Next | Property to get and set the next filter (Inherited from FilterSkeleton.)
Public property | RegexToMatch | Sets the regular expression to match
Public property | StringToMatch | Sets the static string to match
Back to Top
See Also
StringMatchFilter Class
log4net.Filter Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter.AcceptOnMatch Property

StringMatchFilter AcceptOnMatch Property Apache log4net™ SDK Documentation
Accept when matching StringToMatch or RegexToMatch

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AcceptOnMatch { get; set; }
public bool AcceptOnMatch { get; set; }
Public Property AcceptOnMatch As Boolean
    Get
    Set
Public Property AcceptOnMatch As Boolean
    Get
    Set
public:
property bool AcceptOnMatch {
    bool get ();
    void set (bool value);
}
public:
property bool AcceptOnMatch {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
Remarks

            The AcceptOnMatch property is a flag that determines
            the behavior when a matching Level is found. If the
            flag is set to true then the filter will Accept the
            logging event, otherwise it will Neutral the event.

            The default is true i.e. to Accept the event.

See Also
StringMatchFilter Class
StringMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter.RegexToMatch Property

StringMatchFilter RegexToMatch Property Apache log4net™ SDK Documentation
Sets the regular expression to match

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RegexToMatch { get; set; }
public string RegexToMatch { get; set; }
Public Property RegexToMatch As String
    Get
    Set
Public Property RegexToMatch As String
    Get
    Set
public:
property String^ RegexToMatch {
    String^ get ();
    void set (String^ value);
}
public:
property String^ RegexToMatch {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            The regular expression pattern that will be matched against
            the rendered message. If the message matches this
            pattern then the filter will match. If a match is found then
            the result depends on the value of AcceptOnMatch.

            One of StringToMatch or RegexToMatch
            must be specified.

See Also
StringMatchFilter Class
StringMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


StringMatchFilter.StringToMatch Property

StringMatchFilter StringToMatch Property Apache log4net™ SDK Documentation
Sets the static string to match

Namespace: log4net.Filter
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string StringToMatch { get; set; }
public string StringToMatch { get; set; }
Public Property StringToMatch As String
    Get
    Set
Public Property StringToMatch As String
    Get
    Set
public:
property String^ StringToMatch {
    String^ get ();
    void set (String^ value);
}
public:
property String^ StringToMatch {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            The string that will be substring matched against
            the rendered message. If the message contains this
            string then the filter will match. If a match is found then
            the result depends on the value of AcceptOnMatch.

            One of StringToMatch or RegexToMatch
            must be specified.

See Also
StringMatchFilter Class
StringMatchFilter Members
log4net.Filter Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.Layout Namespace

log4net.Layout Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | DynamicPatternLayout | A flexible layout configurable with pattern string that re-evaluates on each call.
Public class | ExceptionLayout | A Layout that renders only the Exception text from the logging event
Public class | Layout2RawLayoutAdapter | Adapts any ILayout to a IRawLayout
Public class | LayoutSkeleton | Extend this abstract class to create your own log layout format.
Public class | PatternLayout | A flexible layout configurable with pattern string.
Public class | RawLayoutConverter | Type converter for the IRawLayout interface
Public class | RawPropertyLayout | Extract the value of a property from the LoggingEvent
Public class | RawTimeStampLayout | Extract the date from the LoggingEvent
Public class | RawUtcTimeStampLayout | Extract the date from the LoggingEvent
Public class | SimpleLayout | A very simple layout
Public class | XmlLayout | Layout that formats the log events as XML elements.
Public class | XmlLayoutBase | Layout that formats the log events as XML elements.
Public class | XmlLayoutSchemaLog4j | Layout that formats the log events as XML elements compatible with the log4j schema
Interfaces
 | Interface | Description
Public interface | ILayout | Interface implemented by layout objects
Public interface | IRawLayout | Interface for raw layout objects

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DynamicPatternLayout Class

DynamicPatternLayout Class Apache log4net™ SDK Documentation
A flexible layout configurable with pattern string that re-evaluates on each call.
Inheritance Hierarchy
Online System Object
log4net.Layout LayoutSkeleton
log4net.Layout PatternLayout
log4net.Layout DynamicPatternLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DynamicPatternLayout : PatternLayout
public class DynamicPatternLayout : PatternLayout
Public Class DynamicPatternLayout
    Inherits PatternLayout
Public Class DynamicPatternLayout
    Inherits PatternLayout
public ref class DynamicPatternLayout : public PatternLayout
public ref class DynamicPatternLayout : public PatternLayout
Remarks
This class is built on PatternLayout and provides all the
            features and capabilities of PatternLayout.  PatternLayout is a 'static' class
            in that its layout is done once at configuration time.  This class will recreate
            the layout on each reference.
One important difference between PatternLayout and DynamicPatternLayout is the
            treatment of the Header and Footer parameters in the configuration.  The Header and Footer
            parameters for DynamicPatternLayout must be syntactically in the form of a PatternString,
            but should not be marked as type log4net.Util.PatternString.  Doing so causes the
            pattern to be statically converted at configuration time and causes DynamicPatternLayout
            to perform the same as PatternLayout.
Please see PatternLayout for complete documentation.
Examples

            <layout type="log4net.Layout.DynamicPatternLayout">
              <param name="Header" value="%newline**** Trace Opened     Local: %date{yyyy-MM-dd HH:mm:ss.fff}     UTC: %utcdate{yyyy-MM-dd HH:mm:ss.fff} ****%newline" />
              <param name="Footer" value="**** Trace Closed %date{yyyy-MM-dd HH:mm:ss.fff} ****%newline" />
            </layout>

See Also
DynamicPatternLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DynamicPatternLayout Members

DynamicPatternLayout Members Apache log4net™ SDK Documentation
The DynamicPatternLayout type exposes the following members.
Constructors
 | Name | Description
Public method | DynamicPatternLayout | Constructs a DynamicPatternLayout using the DefaultConversionPattern
Public method | DynamicPatternLayout(String) | Constructs a DynamicPatternLayout using the supplied conversion pattern
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize layout options (Inherited from PatternLayout.)
Public method | AddConverter(ConverterInfo) | Add a converter to this PatternLayout (Inherited from PatternLayout.)
Public method | AddConverter(String, Type) | Add a converter to this PatternLayout (Inherited from PatternLayout.)
Protected method | CreatePatternParser | Create the pattern parser instance (Inherited from PatternLayout.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a formatted string as specified by the conversion pattern. (Inherited from PatternLayout.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ContentType | The content type output by this layout. (Inherited from LayoutSkeleton.)
Public property | ConversionPattern | The pattern formatting string (Inherited from PatternLayout.)
Public property | Footer | The footer for the layout format. (Overrides LayoutSkeleton Footer.)
Public property | Header | The header for the layout format. (Overrides LayoutSkeleton Header.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Back to Top
See Also
DynamicPatternLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DynamicPatternLayout Constructor

DynamicPatternLayout Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | DynamicPatternLayout | Constructs a DynamicPatternLayout using the DefaultConversionPattern
Public method | DynamicPatternLayout(String) | Constructs a DynamicPatternLayout using the supplied conversion pattern
Back to Top
See Also
DynamicPatternLayout Class
DynamicPatternLayout Members
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DynamicPatternLayout Constructor

DynamicPatternLayout Constructor Apache log4net™ SDK Documentation
Constructs a DynamicPatternLayout using the DefaultConversionPattern

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DynamicPatternLayout()
public DynamicPatternLayout()
Public Sub New
Public Sub New
public:
DynamicPatternLayout()
public:
DynamicPatternLayout()
Remarks

            The default pattern just produces the application supplied message.

See Also
DynamicPatternLayout Class
DynamicPatternLayout Members
DynamicPatternLayout Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DynamicPatternLayout Constructor (String)

DynamicPatternLayout Constructor (String) Apache log4net™ SDK Documentation
Constructs a DynamicPatternLayout using the supplied conversion pattern

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DynamicPatternLayout(
    string pattern
)
public DynamicPatternLayout(
    string pattern
)
Public Sub New (
    pattern As String
)
Public Sub New (
    pattern As String
)
public:
DynamicPatternLayout(
    String^ pattern
)
public:
DynamicPatternLayout(
    String^ pattern
)
Parameters
pattern
Type:   Online System String
the pattern to use
Remarks
See Also
DynamicPatternLayout Class
DynamicPatternLayout Members
DynamicPatternLayout Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DynamicPatternLayout Methods

DynamicPatternLayout Methods Apache log4net™ SDK Documentation
The DynamicPatternLayout type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize layout options (Inherited from PatternLayout.)
Public method | AddConverter(ConverterInfo) | Add a converter to this PatternLayout (Inherited from PatternLayout.)
Public method | AddConverter(String, Type) | Add a converter to this PatternLayout (Inherited from PatternLayout.)
Protected method | CreatePatternParser | Create the pattern parser instance (Inherited from PatternLayout.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a formatted string as specified by the conversion pattern. (Inherited from PatternLayout.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DynamicPatternLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DynamicPatternLayout Properties

DynamicPatternLayout Properties Apache log4net™ SDK Documentation
The DynamicPatternLayout type exposes the following members.
Properties
 | Name | Description
Public property | ContentType | The content type output by this layout. (Inherited from LayoutSkeleton.)
Public property | ConversionPattern | The pattern formatting string (Inherited from PatternLayout.)
Public property | Footer | The footer for the layout format. (Overrides LayoutSkeleton Footer.)
Public property | Header | The header for the layout format. (Overrides LayoutSkeleton Header.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Back to Top
See Also
DynamicPatternLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DynamicPatternLayout.Footer Property

DynamicPatternLayout Footer Property Apache log4net™ SDK Documentation
The footer for the layout format.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Footer { get; set; }
public override string Footer { get; set; }
Public Overrides Property Footer As String
    Get
    Set
Public Overrides Property Footer As String
    Get
    Set
public:
virtual property String^ Footer {
    String^ get () override;
    void set (String^ value) override;
}
public:
virtual property String^ Footer {
    String^ get () override;
    void set (String^ value) override;
}
Property Value
Type:   Online String
the layout footer
Implements
ILayout Footer
Remarks

            The Footer text will be appended after all the logging events
            have been formatted and appended.

            The pattern will be formatted on each get operation.

See Also
DynamicPatternLayout Class
DynamicPatternLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DynamicPatternLayout.Header Property

DynamicPatternLayout Header Property Apache log4net™ SDK Documentation
The header for the layout format.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Header { get; set; }
public override string Header { get; set; }
Public Overrides Property Header As String
    Get
    Set
Public Overrides Property Header As String
    Get
    Set
public:
virtual property String^ Header {
    String^ get () override;
    void set (String^ value) override;
}
public:
virtual property String^ Header {
    String^ get () override;
    void set (String^ value) override;
}
Property Value
Type:   Online String
the layout header
Implements
ILayout Header
Remarks

            The Header text will be appended before any logging events
            are formatted and appended.

            The pattern will be formatted on each get operation.

See Also
DynamicPatternLayout Class
DynamicPatternLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionLayout Class

ExceptionLayout Class Apache log4net™ SDK Documentation
A Layout that renders only the Exception text from the logging event
Inheritance Hierarchy
Online System Object
log4net.Layout LayoutSkeleton
log4net.Layout ExceptionLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ExceptionLayout : LayoutSkeleton
public class ExceptionLayout : LayoutSkeleton
Public Class ExceptionLayout
    Inherits LayoutSkeleton
Public Class ExceptionLayout
    Inherits LayoutSkeleton
public ref class ExceptionLayout : public LayoutSkeleton
public ref class ExceptionLayout : public LayoutSkeleton
Remarks

            A Layout that renders only the Exception text from the logging event.

            This Layout should only be used with appenders that utilize multiple
            layouts (e.g. AdoNetAppender).

See Also
ExceptionLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionLayout Members

ExceptionLayout Members Apache log4net™ SDK Documentation
The ExceptionLayout type exposes the following members.
Constructors
 | Name | Description
Public method | ExceptionLayout | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Activate component options (Overrides LayoutSkeleton ActivateOptions .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Gets the exception text from the logging event (Overrides LayoutSkeleton Format(TextWriter, LoggingEvent).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ContentType | The content type output by this layout. (Inherited from LayoutSkeleton.)
Public property | Footer | The footer for the layout format. (Inherited from LayoutSkeleton.)
Public property | Header | The header for the layout format. (Inherited from LayoutSkeleton.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Back to Top
See Also
ExceptionLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionLayout Constructor

ExceptionLayout Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExceptionLayout()
public ExceptionLayout()
Public Sub New
Public Sub New
public:
ExceptionLayout()
public:
ExceptionLayout()
Remarks

            Constructs a ExceptionLayout

See Also
ExceptionLayout Class
ExceptionLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionLayout Methods

ExceptionLayout Methods Apache log4net™ SDK Documentation
The ExceptionLayout type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Activate component options (Overrides LayoutSkeleton ActivateOptions .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Gets the exception text from the logging event (Overrides LayoutSkeleton Format(TextWriter, LoggingEvent).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ExceptionLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionLayout.ActivateOptions Method

ExceptionLayout ActivateOptions Method Apache log4net™ SDK Documentation
Activate component options

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            Part of the IOptionHandler component activation
            framework.

            This method does nothing as options become effective immediately.

See Also
ExceptionLayout Class
ExceptionLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionLayout.Format Method

ExceptionLayout Format Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Gets the exception text from the logging event (Overrides LayoutSkeleton Format(TextWriter, LoggingEvent).)
Back to Top
See Also
ExceptionLayout Class
ExceptionLayout Members
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionLayout.Format Method (TextWriter, LoggingEvent)

ExceptionLayout Format Method (TextWriter, LoggingEvent) Apache log4net™ SDK Documentation
Gets the exception text from the logging event

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Format(
    TextWriter writer,
    LoggingEvent loggingEvent
)
public override void Format(
    TextWriter writer,
    LoggingEvent loggingEvent
)
Public Overrides Sub Format (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
Public Overrides Sub Format (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
public:
virtual void Format(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) override
public:
virtual void Format(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) override
Parameters
writer
Type:   Online System.IO TextWriter
The TextWriter to write the formatted event to
loggingEvent
Type: log4net.Core LoggingEvent
the event being logged
Implements
ILayout Format(TextWriter, LoggingEvent)
Remarks

            Write the exception string to the   Online TextWriter.
            The exception string is retrieved from [M:LoggingEvent.GetExceptionString()].

See Also
ExceptionLayout Class
ExceptionLayout Members
Format Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ExceptionLayout Properties

ExceptionLayout Properties Apache log4net™ SDK Documentation
The ExceptionLayout type exposes the following members.
Properties
 | Name | Description
Public property | ContentType | The content type output by this layout. (Inherited from LayoutSkeleton.)
Public property | Footer | The footer for the layout format. (Inherited from LayoutSkeleton.)
Public property | Header | The header for the layout format. (Inherited from LayoutSkeleton.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Back to Top
See Also
ExceptionLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILayout Interface

ILayout Interface Apache log4net™ SDK Documentation
Interface implemented by layout objects

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILayout
public interface ILayout
Public Interface ILayout
Public Interface ILayout
public interface class ILayout
public interface class ILayout
Remarks

            An ILayout object is used to format a LoggingEvent
            as text. The [M:Format(TextWriter,LoggingEvent)] method is called by an
            appender to transform the LoggingEvent into a string.

            The layout can also supply Header and Footer
            text that is appender before any events and after all the events respectively.

See Also
ILayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILayout Members

ILayout Members Apache log4net™ SDK Documentation
The ILayout type exposes the following members.
Methods
 | Name | Description
Public method | Format | Implement this method to create your own layout format.
Back to Top
Properties
 | Name | Description
Public property | ContentType | The content type output by this layout.
Public property | Footer | The footer for the layout format.
Public property | Header | The header for the layout format.
Public property | IgnoresException | Flag indicating if this layout handle exceptions
Back to Top
See Also
ILayout Interface
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILayout Methods

ILayout Methods Apache log4net™ SDK Documentation
The ILayout type exposes the following members.
Methods
 | Name | Description
Public method | Format | Implement this method to create your own layout format.
Back to Top
See Also
ILayout Interface
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILayout.Format Method

ILayout Format Method Apache log4net™ SDK Documentation
Implement this method to create your own layout format.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Format(
    TextWriter writer,
    LoggingEvent loggingEvent
)
void Format(
    TextWriter writer,
    LoggingEvent loggingEvent
)
Sub Format (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
Sub Format (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
void Format(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
)
void Format(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
)
Parameters
writer
Type:   Online System.IO TextWriter
The TextWriter to write the formatted event to
loggingEvent
Type: log4net.Core LoggingEvent
The event to format
Remarks

            This method is called by an appender to format
            the loggingEvent as text and output to a writer.

            If the caller does not have a   Online TextWriter and prefers the
            event to be formatted as a   Online String then the following
            code can be used to format the event into a   Online StringWriter.

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
StringWriter writer = new StringWriter();
Layout.Format(writer, loggingEvent);
string formattedEvent = writer.ToString();
StringWriter writer = new StringWriter();
Layout.Format(writer, loggingEvent);
string formattedEvent = writer.ToString();
See Also
ILayout Interface
ILayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILayout Properties

ILayout Properties Apache log4net™ SDK Documentation
The ILayout type exposes the following members.
Properties
 | Name | Description
Public property | ContentType | The content type output by this layout.
Public property | Footer | The footer for the layout format.
Public property | Header | The header for the layout format.
Public property | IgnoresException | Flag indicating if this layout handle exceptions
Back to Top
See Also
ILayout Interface
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILayout.ContentType Property

ILayout ContentType Property Apache log4net™ SDK Documentation
The content type output by this layout.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ContentType { get; }
string ContentType { get; }
ReadOnly Property ContentType As String
    Get
ReadOnly Property ContentType As String
    Get
property String^ ContentType {
    String^ get ();
}
property String^ ContentType {
    String^ get ();
}
Property Value
Type:   Online String
The content type
Remarks

            The content type output by this layout.

            This is a MIME type e.g. "text/plain".

See Also
ILayout Interface
ILayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILayout.Footer Property

ILayout Footer Property Apache log4net™ SDK Documentation
The footer for the layout format.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Footer { get; }
string Footer { get; }
ReadOnly Property Footer As String
    Get
ReadOnly Property Footer As String
    Get
property String^ Footer {
    String^ get ();
}
property String^ Footer {
    String^ get ();
}
Property Value
Type:   Online String
the layout footer
Remarks

            The Footer text will be appended after all the logging events
            have been formatted and appended.

See Also
ILayout Interface
ILayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILayout.Header Property

ILayout Header Property Apache log4net™ SDK Documentation
The header for the layout format.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Header { get; }
string Header { get; }
ReadOnly Property Header As String
    Get
ReadOnly Property Header As String
    Get
property String^ Header {
    String^ get ();
}
property String^ Header {
    String^ get ();
}
Property Value
Type:   Online String
the layout header
Remarks

            The Header text will be appended before any logging events
            are formatted and appended.

See Also
ILayout Interface
ILayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILayout.IgnoresException Property

ILayout IgnoresException Property Apache log4net™ SDK Documentation
Flag indicating if this layout handle exceptions

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IgnoresException { get; }
bool IgnoresException { get; }
ReadOnly Property IgnoresException As Boolean
    Get
ReadOnly Property IgnoresException As Boolean
    Get
property bool IgnoresException {
    bool get ();
}
property bool IgnoresException {
    bool get ();
}
Property Value
Type:   Online Boolean
false if this layout handles exceptions
Remarks

            If this layout handles the exception object contained within
            LoggingEvent, then the layout should return
            false. Otherwise, if the layout ignores the exception
            object, then the layout should return true.

See Also
ILayout Interface
ILayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRawLayout Interface

IRawLayout Interface Apache log4net™ SDK Documentation
Interface for raw layout objects

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IRawLayout
public interface IRawLayout
Public Interface IRawLayout
Public Interface IRawLayout
public interface class IRawLayout
public interface class IRawLayout
Remarks

            Interface used to format a LoggingEvent
            to an object.

            This interface should not be confused with the
            ILayout interface. This interface is used in
            only certain specialized situations where a raw object is
            required rather than a formatted string. The ILayout
            is not generally useful than this interface.

See Also
IRawLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRawLayout Members

IRawLayout Members Apache log4net™ SDK Documentation
The IRawLayout type exposes the following members.
Methods
 | Name | Description
Public method | Format | Implement this method to create your own layout format.
Back to Top
See Also
IRawLayout Interface
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRawLayout Methods

IRawLayout Methods Apache log4net™ SDK Documentation
The IRawLayout type exposes the following members.
Methods
 | Name | Description
Public method | Format | Implement this method to create your own layout format.
Back to Top
See Also
IRawLayout Interface
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IRawLayout.Format Method

IRawLayout Format Method Apache log4net™ SDK Documentation
Implement this method to create your own layout format.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Format(
    LoggingEvent loggingEvent
)
Object Format(
    LoggingEvent loggingEvent
)
Function Format (
    loggingEvent As LoggingEvent
) As Object
Function Format (
    loggingEvent As LoggingEvent
) As Object
Object^ Format(
    LoggingEvent^ loggingEvent
)
Object^ Format(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to format
Return Value
Type:   Online Object
returns the formatted event
Remarks

            Implement this method to create your own layout format.

See Also
IRawLayout Interface
IRawLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Layout2RawLayoutAdapter Class

Layout2RawLayoutAdapter Class Apache log4net™ SDK Documentation
Adapts any ILayout to a IRawLayout
Inheritance Hierarchy
Online System Object
log4net.Layout Layout2RawLayoutAdapter

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Layout2RawLayoutAdapter : IRawLayout
public class Layout2RawLayoutAdapter : IRawLayout
Public Class Layout2RawLayoutAdapter
    Implements IRawLayout
Public Class Layout2RawLayoutAdapter
    Implements IRawLayout
public ref class Layout2RawLayoutAdapter : IRawLayout
public ref class Layout2RawLayoutAdapter : IRawLayout
Remarks

            Where an IRawLayout is required this adapter
            allows a ILayout to be specified.

See Also
Layout2RawLayoutAdapter Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Layout2RawLayoutAdapter Members

Layout2RawLayoutAdapter Members Apache log4net™ SDK Documentation
The Layout2RawLayoutAdapter type exposes the following members.
Constructors
 | Name | Description
Public method | Layout2RawLayoutAdapter | Construct a new adapter
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Format the logging event as an object.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Layout2RawLayoutAdapter Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Layout2RawLayoutAdapter Constructor

Layout2RawLayoutAdapter Constructor Apache log4net™ SDK Documentation
Construct a new adapter

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Layout2RawLayoutAdapter(
    ILayout layout
)
public Layout2RawLayoutAdapter(
    ILayout layout
)
Public Sub New (
    layout As ILayout
)
Public Sub New (
    layout As ILayout
)
public:
Layout2RawLayoutAdapter(
    ILayout^ layout
)
public:
Layout2RawLayoutAdapter(
    ILayout^ layout
)
Parameters
layout
Type: log4net.Layout ILayout
the layout to adapt
Remarks

            Create the adapter for the specified layout.

See Also
Layout2RawLayoutAdapter Class
Layout2RawLayoutAdapter Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Layout2RawLayoutAdapter Methods

Layout2RawLayoutAdapter Methods Apache log4net™ SDK Documentation
The Layout2RawLayoutAdapter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Format the logging event as an object.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Layout2RawLayoutAdapter Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Layout2RawLayoutAdapter.Format Method

Layout2RawLayoutAdapter Format Method Apache log4net™ SDK Documentation
Format the logging event as an object.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Format(
    LoggingEvent loggingEvent
)
public virtual Object Format(
    LoggingEvent loggingEvent
)
Public Overridable Function Format (
    loggingEvent As LoggingEvent
) As Object
Public Overridable Function Format (
    loggingEvent As LoggingEvent
) As Object
public:
virtual Object^ Format(
    LoggingEvent^ loggingEvent
)
public:
virtual Object^ Format(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to format
Return Value
Type:   Online Object
returns the formatted event
Implements
IRawLayout Format(LoggingEvent)
Remarks

            Format the logging event as an object.

            Uses the ILayout object supplied to
            the constructor to perform the formatting.

See Also
Layout2RawLayoutAdapter Class
Layout2RawLayoutAdapter Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton Class

LayoutSkeleton Class Apache log4net™ SDK Documentation
Extend this abstract class to create your own log layout format.
Inheritance Hierarchy
Online System Object
log4net.Layout LayoutSkeleton
log4net.Layout ExceptionLayout
log4net.Layout PatternLayout
log4net.Layout SimpleLayout
log4net.Layout XmlLayoutBase

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class LayoutSkeleton : ILayout,
    IOptionHandler
public abstract class LayoutSkeleton : ILayout,
    IOptionHandler
Public MustInherit Class LayoutSkeleton
    Implements ILayout, IOptionHandler
Public MustInherit Class LayoutSkeleton
    Implements ILayout, IOptionHandler
public ref class LayoutSkeleton abstract : ILayout,
    IOptionHandler
public ref class LayoutSkeleton abstract : ILayout,
    IOptionHandler
Remarks

            This is the base implementation of the ILayout
            interface. Most layout objects should extend this class.

Remarks
  Note  Note

            Subclasses must implement the [M:Format(TextWriter,LoggingEvent)]
            method.

            Subclasses should set the IgnoresException in their default
            constructor.

See Also
LayoutSkeleton Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton Members

LayoutSkeleton Members Apache log4net™ SDK Documentation
The LayoutSkeleton type exposes the following members.
Constructors
 | Name | Description
Protected method | LayoutSkeleton | Empty default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Activate component options
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable.
Public method | Format(TextWriter, LoggingEvent) | Implement this method to create your own layout format.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ContentType | The content type output by this layout.
Public property | Footer | The footer for the layout format.
Public property | Header | The header for the layout format.
Public property | IgnoresException | Flag indicating if this layout handles exceptions
Back to Top
See Also
LayoutSkeleton Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton Constructor

LayoutSkeleton Constructor Apache log4net™ SDK Documentation
Empty default constructor

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LayoutSkeleton()
protected LayoutSkeleton()
Protected Sub New
Protected Sub New
protected:
LayoutSkeleton()
protected:
LayoutSkeleton()
Remarks

            Empty default constructor

See Also
LayoutSkeleton Class
LayoutSkeleton Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton Methods

LayoutSkeleton Methods Apache log4net™ SDK Documentation
The LayoutSkeleton type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Activate component options
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable.
Public method | Format(TextWriter, LoggingEvent) | Implement this method to create your own layout format.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LayoutSkeleton Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton.ActivateOptions Method

LayoutSkeleton ActivateOptions Method Apache log4net™ SDK Documentation
Activate component options

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void ActivateOptions()
public abstract void ActivateOptions()
Public MustOverride Sub ActivateOptions
Public MustOverride Sub ActivateOptions
public:
virtual void ActivateOptions() abstract
public:
virtual void ActivateOptions() abstract
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

            This method must be implemented by the subclass.

See Also
LayoutSkeleton Class
LayoutSkeleton Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton.Format Method

LayoutSkeleton Format Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable.
Public method | Format(TextWriter, LoggingEvent) | Implement this method to create your own layout format.
Back to Top
See Also
LayoutSkeleton Class
LayoutSkeleton Members
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton.Format Method (LoggingEvent)

LayoutSkeleton Format Method (LoggingEvent) Apache log4net™ SDK Documentation
Convenience method for easily formatting the logging event into a string variable.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Format(
    LoggingEvent loggingEvent
)
public string Format(
    LoggingEvent loggingEvent
)
Public Function Format (
    loggingEvent As LoggingEvent
) As String
Public Function Format (
    loggingEvent As LoggingEvent
) As String
public:
String^ Format(
    LoggingEvent^ loggingEvent
)
public:
String^ Format(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
[Missing <param name="loggingEvent"/> documentation for "M:log4net.Layout.LayoutSkeleton.Format(log4net.Core.LoggingEvent)"]
Return Value
Type:   Online String
[Missing <returns> documentation for "M:log4net.Layout.LayoutSkeleton.Format(log4net.Core.LoggingEvent)"]
Remarks

            Creates a new StringWriter instance to store the formatted logging event.

See Also
LayoutSkeleton Class
LayoutSkeleton Members
Format Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton.Format Method (TextWriter, LoggingEvent)

LayoutSkeleton Format Method (TextWriter, LoggingEvent) Apache log4net™ SDK Documentation
Implement this method to create your own layout format.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Format(
    TextWriter writer,
    LoggingEvent loggingEvent
)
public abstract void Format(
    TextWriter writer,
    LoggingEvent loggingEvent
)
Public MustOverride Sub Format (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
Public MustOverride Sub Format (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
public:
virtual void Format(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) abstract
public:
virtual void Format(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) abstract
Parameters
writer
Type:   Online System.IO TextWriter
The TextWriter to write the formatted event to
loggingEvent
Type: log4net.Core LoggingEvent
The event to format
Implements
ILayout Format(TextWriter, LoggingEvent)
Remarks

            This method is called by an appender to format
            the loggingEvent as text.

See Also
LayoutSkeleton Class
LayoutSkeleton Members
Format Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton Properties

LayoutSkeleton Properties Apache log4net™ SDK Documentation
The LayoutSkeleton type exposes the following members.
Properties
 | Name | Description
Public property | ContentType | The content type output by this layout.
Public property | Footer | The footer for the layout format.
Public property | Header | The header for the layout format.
Public property | IgnoresException | Flag indicating if this layout handles exceptions
Back to Top
See Also
LayoutSkeleton Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton.ContentType Property

LayoutSkeleton ContentType Property Apache log4net™ SDK Documentation
The content type output by this layout.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string ContentType { get; }
public virtual string ContentType { get; }
Public Overridable ReadOnly Property ContentType As String
    Get
Public Overridable ReadOnly Property ContentType As String
    Get
public:
virtual property String^ ContentType {
    String^ get ();
}
public:
virtual property String^ ContentType {
    String^ get ();
}
Property Value
Type:   Online String
The content type is "text/plain"
Implements
ILayout ContentType
Remarks

            The content type output by this layout.

            This base class uses the value "text/plain".
            To change this value a subclass must override this
            property.

See Also
LayoutSkeleton Class
LayoutSkeleton Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton.Footer Property

LayoutSkeleton Footer Property Apache log4net™ SDK Documentation
The footer for the layout format.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Footer { get; set; }
public virtual string Footer { get; set; }
Public Overridable Property Footer As String
    Get
    Set
Public Overridable Property Footer As String
    Get
    Set
public:
virtual property String^ Footer {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Footer {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
the layout footer
Implements
ILayout Footer
Remarks

            The Footer text will be appended after all the logging events
            have been formatted and appended.

See Also
LayoutSkeleton Class
LayoutSkeleton Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton.Header Property

LayoutSkeleton Header Property Apache log4net™ SDK Documentation
The header for the layout format.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Header { get; set; }
public virtual string Header { get; set; }
Public Overridable Property Header As String
    Get
    Set
Public Overridable Property Header As String
    Get
    Set
public:
virtual property String^ Header {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Header {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
the layout header
Implements
ILayout Header
Remarks

            The Header text will be appended before any logging events
            are formatted and appended.

See Also
LayoutSkeleton Class
LayoutSkeleton Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LayoutSkeleton.IgnoresException Property

LayoutSkeleton IgnoresException Property Apache log4net™ SDK Documentation
Flag indicating if this layout handles exceptions

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IgnoresException { get; set; }
public virtual bool IgnoresException { get; set; }
Public Overridable Property IgnoresException As Boolean
    Get
    Set
Public Overridable Property IgnoresException As Boolean
    Get
    Set
public:
virtual property bool IgnoresException {
    bool get ();
    void set (bool value);
}
public:
virtual property bool IgnoresException {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
false if this layout handles exceptions
Implements
ILayout IgnoresException
Remarks

            If this layout handles the exception object contained within
            LoggingEvent, then the layout should return
            false. Otherwise, if the layout ignores the exception
            object, then the layout should return true.

            Set this value to override a this default setting. The default
            value is true, this layout does not handle the exception.

See Also
LayoutSkeleton Class
LayoutSkeleton Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout Class

PatternLayout Class Apache log4net™ SDK Documentation
A flexible layout configurable with pattern string.
Inheritance Hierarchy
Online System Object
log4net.Layout LayoutSkeleton
log4net.Layout PatternLayout
log4net.Layout DynamicPatternLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PatternLayout : LayoutSkeleton
public class PatternLayout : LayoutSkeleton
Public Class PatternLayout
    Inherits LayoutSkeleton
Public Class PatternLayout
    Inherits LayoutSkeleton
public ref class PatternLayout : public LayoutSkeleton
public ref class PatternLayout : public LayoutSkeleton
Remarks

            The goal of this class is to Format(TextWriter, LoggingEvent) a
            LoggingEvent as a string. The results
            depend on the conversion pattern.

            The conversion pattern is closely related to the conversion
            pattern of the printf function in C. A conversion pattern is
            composed of literal text and format control expressions called
            conversion specifiers.

You are free to insert any literal text within the conversion
            pattern.

            Each conversion specifier starts with a percent sign (%) and is
            followed by optional format modifiers and a conversion
            pattern name. The conversion pattern name specifies the type of
            data, e.g. logger, level, date, thread name. The format
            modifiers control such things as field width, padding, left and
            right justification. The following is a simple example.

            Let the conversion pattern be "%-5level [%thread]: %message%newline" and assume
            that the log4net environment was set to use a PatternLayout. Then the
            statements

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILog log = LogManager.GetLogger(typeof(TestApp));
log.Debug("Message 1");
log.Warn("Message 2");
ILog log = LogManager.GetLogger(typeof(TestApp));
log.Debug("Message 1");
log.Warn("Message 2");
would yield the output
View Colorized Copy to Clipboard Print
DEBUG [main]: Message 1
WARN  [main]: Message 2
DEBUG [main]: Message 1
WARN  [main]: Message 2

            Note that there is no explicit separator between text and
            conversion specifiers. The pattern parser knows when it has reached
            the end of a conversion specifier when it reads a conversion
            character. In the example above the conversion specifier
            %-5level means the level of the logging event should be left
            justified to a width of five characters.

            The recognized conversion pattern names are:

Conversion Pattern Name  | Effect
a  | Equivalent to appdomain
appdomain  |
                        Used to output the friendly name of the AppDomain where the
                        logging event was generated.

aspnet-cache
                        Used to output all cache items in the case of %aspnet-cache or just one named item if used as %aspnet-cache{key}

                        This pattern is not available for Compact Framework or Client Profile assemblies.

aspnet-context
                        Used to output all context items in the case of %aspnet-context or just one named item if used as %aspnet-context{key}

                        This pattern is not available for Compact Framework or Client Profile assemblies.

aspnet-request
                        Used to output all request parameters in the case of %aspnet-request or just one named param if used as %aspnet-request{key}

                        This pattern is not available for Compact Framework or Client Profile assemblies.

aspnet-session
                        Used to output all session items in the case of %aspnet-session or just one named item if used as %aspnet-session{key}

                        This pattern is not available for Compact Framework or Client Profile assemblies.

c  | Equivalent to logger
C  | Equivalent to type
class  | Equivalent to type
d  | Equivalent to date
date
                        Used to output the date of the logging event in the local time zone.
                        To output the date in universal time use the %utcdate pattern.
                        The date conversion
                        specifier may be followed by a date format specifier enclosed
                        between braces. For example, %date{HH:mm:ss,fff} or
                        %date{dd MMM yyyy HH:mm:ss,fff}.  If no date format specifier is
                        given then ISO8601 format is
                        assumed (Iso8601DateFormatter).

                        The date format specifier admits the same syntax as the
                        time pattern string of the ToString(string).

                        For better results it is recommended to use the log4net date
                        formatters. These can be specified using one of the strings
                        "ABSOLUTE", "DATE" and "ISO8601" for specifying
                        AbsoluteTimeDateFormatter,
                        DateTimeDateFormatter and respectively
                        Iso8601DateFormatter. For example,
                        %date{ISO8601} or %date{ABSOLUTE}.

                        These dedicated date formatters perform significantly
                        better than ToString(string).

exception
                        Used to output the exception passed in with the log message.

                        If an exception object is stored in the logging event
                        it will be rendered into the pattern output with a
                        trailing newline.
                        If there is no exception then nothing will be output
                        and no trailing newline will be appended.
                        It is typical to put a newline before the exception
                        and to have the exception as the last data in the pattern.

F  | Equivalent to file
file
                        Used to output the file name where the logging request was
                        issued.

WARNING Generating caller location information is
                        extremely slow. Its use should be avoided unless execution speed
                        is not an issue.

                        See the note below on the availability of caller location information.

identity
                        Used to output the user name for the currently active user
                        (Principal.Identity.Name).

WARNING Generating caller information is
                        extremely slow. Its use should be avoided unless execution speed
                        is not an issue.

l  | Equivalent to location
L  | Equivalent to line
location
                        Used to output location information of the caller which generated
                        the logging event.

                        The location information depends on the CLI implementation but
                        usually consists of the fully qualified name of the calling
                        method followed by the callers source the file name and line
                        number between parentheses.

                        The location information can be very useful. However, its
                        generation is extremely slow. Its use should be avoided
                        unless execution speed is not an issue.

                        See the note below on the availability of caller location information.

level  |
                        Used to output the level of the logging event.

line
                        Used to output the line number from where the logging request
                        was issued.

WARNING Generating caller location information is
                        extremely slow. Its use should be avoided unless execution speed
                        is not an issue.

                        See the note below on the availability of caller location information.

logger
                        Used to output the logger of the logging event. The
                        logger conversion specifier can be optionally followed by
                        precision specifier, that is a decimal constant in
                        brackets.

                        If a precision specifier is given, then only the corresponding
                        number of right most components of the logger name will be
                        printed. By default the logger name is printed in full.

                        For example, for the logger name "a.b.c" the pattern
                        %logger{2} will output "b.c".

m  | Equivalent to message
M  | Equivalent to method
message  |
                        Used to output the application supplied message associated with
                        the logging event.

mdc  |
                        The MDC (old name for the ThreadContext.Properties) is now part of the
                        combined event properties. This pattern is supported for compatibility
                        but is equivalent to property.

method
                        Used to output the method name where the logging request was
                        issued.

WARNING Generating caller location information is
                        extremely slow. Its use should be avoided unless execution speed
                        is not an issue.

                        See the note below on the availability of caller location information.

n  | Equivalent to newline
newline
                        Outputs the platform dependent line separator character or
                        characters.

                        This conversion pattern offers the same performance as using
                        non-portable line separator strings such as	"\n", or "\r\n".
                        Thus, it is the preferred way of specifying a line separator.

ndc  |
                        Used to output the NDC (nested diagnostic context) associated
                        with the thread that generated the logging event.

p  | Equivalent to level
P  | Equivalent to property
properties  | Equivalent to property
property
                        Used to output the an event specific property. The key to
                        lookup must be specified within braces and directly following the
                        pattern specifier, e.g. %property{user} would include the value
                        from the property that is keyed by the string 'user'. Each property value
                        that is to be included in the log must be specified separately.
                        Properties are added to events by loggers or appenders. By default
                        the log4net:HostName property is set to the name of machine on
                        which the event was originally logged.

                        If no key is specified, e.g. %property then all the keys and their
                        values are printed in a comma separated list.

                        The properties of an event are combined from a number of different
                        contexts. These are listed below in the order in which they are searched.

the event properties

                                The event has Properties that can be set. These
                                properties are specific to this event only.

the thread properties

                                The Properties that are set on the current
                                thread. These properties are shared by all events logged on this thread.

the global properties

                                The Properties that are set globally. These
                                properties are shared by all the threads in the AppDomain.

r  | Equivalent to timestamp
stacktrace
                        Used to output the stack trace of the logging event
                        The stack trace level specifier may be enclosed
                        between braces. For example, %stacktrace{level}.
                        If no stack trace level specifier is given then 1 is assumed

                        Output uses the format:
                        type3.MethodCall3 > type2.MethodCall2 > type1.MethodCall1

                        This pattern is not available for Compact Framework assemblies.

stacktracedetail
                        Used to output the stack trace of the logging event
                        The stack trace level specifier may be enclosed
                        between braces. For example, %stacktracedetail{level}.
                        If no stack trace level specifier is given then 1 is assumed

                        Output uses the format:
                        type3.MethodCall3(type param,...) > type2.MethodCall2(type param,...) > type1.MethodCall1(type param,...)

                        This pattern is not available for Compact Framework assemblies.

t  | Equivalent to thread
timestamp  |
                        Used to output the number of milliseconds elapsed since the start
                        of the application until the creation of the logging event.

thread  |
                        Used to output the name of the thread that generated the
                        logging event. Uses the thread number if no name is available.

type
                        Used to output the fully qualified type name of the caller
                        issuing the logging request. This conversion specifier
                        can be optionally followed by precision specifier, that
                        is a decimal constant in brackets.

                        If a precision specifier is given, then only the corresponding
                        number of right most components of the class name will be
                        printed. By default the class name is output in fully qualified form.

                        For example, for the class name "log4net.Layout.PatternLayout", the
                        pattern %type{1} will output "PatternLayout".

WARNING Generating the caller class information is
                        slow. Thus, its use should be avoided unless execution speed is
                        not an issue.

                        See the note below on the availability of caller location information.

u  | Equivalent to identity
username
                        Used to output the WindowsIdentity for the currently
                        active user.

WARNING Generating caller WindowsIdentity information is
                        extremely slow. Its use should be avoided unless execution speed
                        is not an issue.

utcdate
                        Used to output the date of the logging event in universal time.
                        The date conversion
                        specifier may be followed by a date format specifier enclosed
                        between braces. For example, %utcdate{HH:mm:ss,fff} or
                        %utcdate{dd MMM yyyy HH:mm:ss,fff}.  If no date format specifier is
                        given then ISO8601 format is
                        assumed (Iso8601DateFormatter).

                        The date format specifier admits the same syntax as the
                        time pattern string of the ToString(string).

                        For better results it is recommended to use the log4net date
                        formatters. These can be specified using one of the strings
                        "ABSOLUTE", "DATE" and "ISO8601" for specifying
                        AbsoluteTimeDateFormatter,
                        DateTimeDateFormatter and respectively
                        Iso8601DateFormatter. For example,
                        %utcdate{ISO8601} or %utcdate{ABSOLUTE}.

                        These dedicated date formatters perform significantly
                        better than ToString(string).

w  | Equivalent to username
x  | Equivalent to ndc
X  | Equivalent to mdc
%
                        The sequence %% outputs a single percent sign.

            The single letter patterns are deprecated in favor of the
            longer more descriptive pattern names.

            By default the relevant information is output as is. However,
            with the aid of format modifiers it is possible to change the
            minimum field width, the maximum field width and justification.

            The optional format modifier is placed between the percent sign
            and the conversion pattern name.

            The first optional format modifier is the left justification
            flag which is just the minus (-) character. Then comes the
            optional minimum field width modifier. This is a decimal
            constant that represents the minimum number of characters to
            output. If the data item requires fewer characters, it is padded on
            either the left or the right until the minimum width is
            reached. The default is to pad on the left (right justify) but you
            can specify right padding with the left justification flag. The
            padding character is space. If the data item is larger than the
            minimum field width, the field is expanded to accommodate the
            data. The value is never truncated.

            This behavior can be changed using the maximum field
            width modifier which is designated by a period followed by a
            decimal constant. If the data item is longer than the maximum
            field, then the extra characters are removed from the
            beginning of the data item and not from the end. For
            example, it the maximum field width is eight and the data item is
            ten characters long, then the first two characters of the data item
            are dropped. This behavior deviates from the printf function in C
            where truncation is done from the end.

            Below are various format modifier examples for the logger
            conversion specifier.

Format modifier | left justify | minimum width | maximum width | comment
%20logger | false | 20 | none | Left pad with spaces if the logger name is less than 20 characters long.
%-20logger | true | 20 | none | Right pad with spaces if the logger name is less than 20 characters long.
%.30logger | NA | none | 30 | Truncate from the beginning if the logger name is longer than 30 characters.
%20.30logger | false | 20 | 30 | Left pad with spaces if the logger name is shorter than 20 characters. However, if logger name is longer than 30 characters, then truncate from the beginning.
%-20.30logger | true | 20 | 30 | Right pad with spaces if the logger name is shorter than 20 characters. However, if logger name is longer than 30 characters, then truncate from the beginning.
Note about caller location information.

            The following patterns %type %file %line %method %location %class %C %F %L %l %M
            all generate caller location information.
            Location information uses the System.Diagnostics.StackTrace class to generate
            a call stack. The caller's information is then extracted from this stack.

  Caution note  Caution

            The System.Diagnostics.StackTrace class is not supported on the
            .NET Compact Framework 1.0 therefore caller location information is not
            available on that framework.

  Caution note  Caution

            The System.Diagnostics.StackTrace class has this to say about Release builds:

            "StackTrace information will be most informative with Debug build configurations.
            By default, Debug builds include debug symbols, while Release builds do not. The
            debug symbols contain most of the file, method name, line number, and column
            information used in constructing StackFrame and StackTrace objects. StackTrace
            might not report as many method calls as expected, due to code transformations
            that occur during optimization."

            This means that in a Release build the caller information may be incomplete or may
            not exist at all! Therefore caller location information cannot be relied upon in a Release build.

            Additional pattern converters may be registered with a specific PatternLayout
            instance using the [M:AddConverter(string, Type)] method.

Examples

            This is a more detailed pattern.

View Colorized Copy to Clipboard Print
<b>%timestamp [%thread] %level %logger %ndc - %message%newline</b>
<b>%timestamp [%thread] %level %logger %ndc - %message%newline</b>
Examples

            A similar pattern except that the relative time is
            right padded if less than 6 digits, thread name is right padded if
            less than 15 characters and truncated if longer and the logger
            name is left padded if shorter than 30 characters and truncated if
            longer.

View Colorized Copy to Clipboard Print
<b>%-6timestamp [%15.15thread] %-5level %30.30logger %ndc - %message%newline</b>
<b>%-6timestamp [%15.15thread] %-5level %30.30logger %ndc - %message%newline</b>
See Also
PatternLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout Members

PatternLayout Members Apache log4net™ SDK Documentation
The PatternLayout type exposes the following members.
Constructors
 | Name | Description
Public method | PatternLayout | Constructs a PatternLayout using the DefaultConversionPattern
Public method | PatternLayout(String) | Constructs a PatternLayout using the supplied conversion pattern
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize layout options (Overrides LayoutSkeleton ActivateOptions .)
Public method | AddConverter(ConverterInfo) | Add a converter to this PatternLayout
Public method | AddConverter(String, Type) | Add a converter to this PatternLayout
Protected method | CreatePatternParser | Create the pattern parser instance
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a formatted string as specified by the conversion pattern. (Overrides LayoutSkeleton Format(TextWriter, LoggingEvent).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
DefaultConversionPattern | Default pattern string for log output.
DetailConversionPattern | A detailed conversion pattern
Back to Top
Properties
 | Name | Description
Public property | ContentType | The content type output by this layout. (Inherited from LayoutSkeleton.)
Public property | ConversionPattern | The pattern formatting string
Public property | Footer | The footer for the layout format. (Inherited from LayoutSkeleton.)
Public property | Header | The header for the layout format. (Inherited from LayoutSkeleton.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Back to Top
See Also
PatternLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout Constructor

PatternLayout Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | PatternLayout | Constructs a PatternLayout using the DefaultConversionPattern
Public method | PatternLayout(String) | Constructs a PatternLayout using the supplied conversion pattern
Back to Top
See Also
PatternLayout Class
PatternLayout Members
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout Constructor

PatternLayout Constructor Apache log4net™ SDK Documentation
Constructs a PatternLayout using the DefaultConversionPattern

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PatternLayout()
public PatternLayout()
Public Sub New
Public Sub New
public:
PatternLayout()
public:
PatternLayout()
Remarks

            The default pattern just produces the application supplied message.

            Note to Inheritors: This constructor calls the virtual method
            CreatePatternParser(String). If you override this method be
            aware that it will be called before your is called constructor.

            As per the IOptionHandler contract the ActivateOptions
            method must be called after the properties on this object have been
            configured.

See Also
PatternLayout Class
PatternLayout Members
PatternLayout Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout Constructor (String)

PatternLayout Constructor (String) Apache log4net™ SDK Documentation
Constructs a PatternLayout using the supplied conversion pattern

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PatternLayout(
    string pattern
)
public PatternLayout(
    string pattern
)
Public Sub New (
    pattern As String
)
Public Sub New (
    pattern As String
)
public:
PatternLayout(
    String^ pattern
)
public:
PatternLayout(
    String^ pattern
)
Parameters
pattern
Type:   Online System String
the pattern to use
Remarks

            Note to Inheritors: This constructor calls the virtual method
            CreatePatternParser(String). If you override this method be
            aware that it will be called before your is called constructor.

            When using this constructor the ActivateOptions  method
            need not be called. This may not be the case when using a subclass.

See Also
PatternLayout Class
PatternLayout Members
PatternLayout Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout Fields

PatternLayout Fields Apache log4net™ SDK Documentation
The PatternLayout type exposes the following members.
Fields
Name | Description
DefaultConversionPattern | Default pattern string for log output.
DetailConversionPattern | A detailed conversion pattern
Back to Top
See Also
PatternLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout.DefaultConversionPattern Field

PatternLayout DefaultConversionPattern Field Apache log4net™ SDK Documentation
Default pattern string for log output.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DefaultConversionPattern
public const string DefaultConversionPattern
Public Const DefaultConversionPattern As String
Public Const DefaultConversionPattern As String
public:
literal String^ DefaultConversionPattern
public:
literal String^ DefaultConversionPattern
Field Value
Type:   Online String
Remarks

            Default pattern string for log output.
            Currently set to the string "%message%newline"
            which just prints the application supplied message.

See Also
PatternLayout Class
PatternLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout.DetailConversionPattern Field

PatternLayout DetailConversionPattern Field Apache log4net™ SDK Documentation
A detailed conversion pattern

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DetailConversionPattern
public const string DetailConversionPattern
Public Const DetailConversionPattern As String
Public Const DetailConversionPattern As String
public:
literal String^ DetailConversionPattern
public:
literal String^ DetailConversionPattern
Field Value
Type:   Online String
Remarks

            A conversion pattern which includes Time, Thread, Logger, and Nested Context.
            Current value is %timestamp [%thread] %level %logger %ndc - %message%newline.

See Also
PatternLayout Class
PatternLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout Methods

PatternLayout Methods Apache log4net™ SDK Documentation
The PatternLayout type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize layout options (Overrides LayoutSkeleton ActivateOptions .)
Public method | AddConverter(ConverterInfo) | Add a converter to this PatternLayout
Public method | AddConverter(String, Type) | Add a converter to this PatternLayout
Protected method | CreatePatternParser | Create the pattern parser instance
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a formatted string as specified by the conversion pattern. (Overrides LayoutSkeleton Format(TextWriter, LoggingEvent).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PatternLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout.ActivateOptions Method

PatternLayout ActivateOptions Method Apache log4net™ SDK Documentation
Initialize layout options

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
PatternLayout Class
PatternLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout.AddConverter Method

PatternLayout AddConverter Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | AddConverter(ConverterInfo) | Add a converter to this PatternLayout
Public method | AddConverter(String, Type) | Add a converter to this PatternLayout
Back to Top
See Also
PatternLayout Class
PatternLayout Members
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout.AddConverter Method (ConverterInfo)

PatternLayout AddConverter Method (ConverterInfo) Apache log4net™ SDK Documentation
Add a converter to this PatternLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddConverter(
    ConverterInfo converterInfo
)
public void AddConverter(
    ConverterInfo converterInfo
)
Public Sub AddConverter (
    converterInfo As ConverterInfo
)
Public Sub AddConverter (
    converterInfo As ConverterInfo
)
public:
void AddConverter(
    ConverterInfo^ converterInfo
)
public:
void AddConverter(
    ConverterInfo^ converterInfo
)
Parameters
converterInfo
Type: log4net.Util ConverterInfo
the converter info
Remarks

            This version of the method is used by the configurator.
            Programmatic users should use the alternative [M:AddConverter(string,Type)] method.

See Also
PatternLayout Class
PatternLayout Members
AddConverter Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout.AddConverter Method (String, Type)

PatternLayout AddConverter Method (String, Type) Apache log4net™ SDK Documentation
Add a converter to this PatternLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddConverter(
    string name,
    Type type
)
public void AddConverter(
    string name,
    Type type
)
Public Sub AddConverter (
    name As String,
    type As Type
)
Public Sub AddConverter (
    name As String,
    type As Type
)
public:
void AddConverter(
    String^ name,
    Type^ type
)
public:
void AddConverter(
    String^ name,
    Type^ type
)
Parameters
name
Type:   Online System String
the name of the conversion pattern for this converter
type
Type:   Online System Type
the type of the converter
Remarks

            Add a named pattern converter to this instance. This
            converter will be used in the formatting of the event.
            This method must be called before ActivateOptions .

            The type specified must extend the
            PatternConverter type.

See Also
PatternLayout Class
PatternLayout Members
AddConverter Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout.CreatePatternParser Method

PatternLayout CreatePatternParser Method Apache log4net™ SDK Documentation
Create the pattern parser instance

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual PatternParser CreatePatternParser(
    string pattern
)
protected virtual PatternParser CreatePatternParser(
    string pattern
)
Protected Overridable Function CreatePatternParser (
    pattern As String
) As PatternParser
Protected Overridable Function CreatePatternParser (
    pattern As String
) As PatternParser
protected:
virtual PatternParser^ CreatePatternParser(
    String^ pattern
)
protected:
virtual PatternParser^ CreatePatternParser(
    String^ pattern
)
Parameters
pattern
Type:   Online System String
the pattern to parse
Return Value
Type: PatternParser
The PatternParser that will format the event
Remarks

            Creates the PatternParser used to parse the conversion string. Sets the
            global and instance rules on the PatternParser.

See Also
PatternLayout Class
PatternLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout.Format Method

PatternLayout Format Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a formatted string as specified by the conversion pattern. (Overrides LayoutSkeleton Format(TextWriter, LoggingEvent).)
Back to Top
See Also
PatternLayout Class
PatternLayout Members
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout.Format Method (TextWriter, LoggingEvent)

PatternLayout Format Method (TextWriter, LoggingEvent) Apache log4net™ SDK Documentation
Produces a formatted string as specified by the conversion pattern.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Format(
    TextWriter writer,
    LoggingEvent loggingEvent
)
public override void Format(
    TextWriter writer,
    LoggingEvent loggingEvent
)
Public Overrides Sub Format (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
Public Overrides Sub Format (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
public:
virtual void Format(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) override
public:
virtual void Format(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) override
Parameters
writer
Type:   Online System.IO TextWriter
The TextWriter to write the formatted event to
loggingEvent
Type: log4net.Core LoggingEvent
the event being logged
Implements
ILayout Format(TextWriter, LoggingEvent)
Remarks

            Parse the LoggingEvent using the patter format
            specified in the ConversionPattern property.

See Also
PatternLayout Class
PatternLayout Members
Format Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout Properties

PatternLayout Properties Apache log4net™ SDK Documentation
The PatternLayout type exposes the following members.
Properties
 | Name | Description
Public property | ContentType | The content type output by this layout. (Inherited from LayoutSkeleton.)
Public property | ConversionPattern | The pattern formatting string
Public property | Footer | The footer for the layout format. (Inherited from LayoutSkeleton.)
Public property | Header | The header for the layout format. (Inherited from LayoutSkeleton.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Back to Top
See Also
PatternLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayout.ConversionPattern Property

PatternLayout ConversionPattern Property Apache log4net™ SDK Documentation
The pattern formatting string

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ConversionPattern { get; set; }
public string ConversionPattern { get; set; }
Public Property ConversionPattern As String
    Get
    Set
Public Property ConversionPattern As String
    Get
    Set
public:
property String^ ConversionPattern {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ConversionPattern {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            The ConversionPattern option. This is the string which
            controls formatting and consists of a mix of literal content and
            conversion specifiers.

See Also
PatternLayout Class
PatternLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawLayoutConverter Class

RawLayoutConverter Class Apache log4net™ SDK Documentation
Type converter for the IRawLayout interface
Inheritance Hierarchy
Online System Object
log4net.Layout RawLayoutConverter

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RawLayoutConverter : IConvertFrom
public class RawLayoutConverter : IConvertFrom
Public Class RawLayoutConverter
    Implements IConvertFrom
Public Class RawLayoutConverter
    Implements IConvertFrom
public ref class RawLayoutConverter : IConvertFrom
public ref class RawLayoutConverter : IConvertFrom
Remarks

            Used to convert objects to the IRawLayout interface.
            Supports converting from the ILayout interface to
            the IRawLayout interface using the Layout2RawLayoutAdapter.

See Also
RawLayoutConverter Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawLayoutConverter Members

RawLayoutConverter Members Apache log4net™ SDK Documentation
The RawLayoutConverter type exposes the following members.
Constructors
 | Name | Description
Public method | RawLayoutConverter | Initializes a new instance of the RawLayoutConverter class
Back to Top
Methods
 | Name | Description
Public method | CanConvertFrom | Can the sourceType be converted to an IRawLayout
Public method | ConvertFrom | Convert the value to a IRawLayout object
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RawLayoutConverter Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawLayoutConverter Constructor

RawLayoutConverter Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the RawLayoutConverter class

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RawLayoutConverter()
public RawLayoutConverter()
Public Sub New
Public Sub New
public:
RawLayoutConverter()
public:
RawLayoutConverter()
See Also
RawLayoutConverter Class
RawLayoutConverter Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawLayoutConverter Methods

RawLayoutConverter Methods Apache log4net™ SDK Documentation
The RawLayoutConverter type exposes the following members.
Methods
 | Name | Description
Public method | CanConvertFrom | Can the sourceType be converted to an IRawLayout
Public method | ConvertFrom | Convert the value to a IRawLayout object
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RawLayoutConverter Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawLayoutConverter.CanConvertFrom Method

RawLayoutConverter CanConvertFrom Method Apache log4net™ SDK Documentation
Can the sourceType be converted to an IRawLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CanConvertFrom(
    Type sourceType
)
public bool CanConvertFrom(
    Type sourceType
)
Public Function CanConvertFrom (
    sourceType As Type
) As Boolean
Public Function CanConvertFrom (
    sourceType As Type
) As Boolean
public:
virtual bool CanConvertFrom(
    Type^ sourceType
) sealed
public:
virtual bool CanConvertFrom(
    Type^ sourceType
) sealed
Parameters
sourceType
Type:   Online System Type
the source to be to be converted
Return Value
Type:   Online Boolean
true if the source type can be converted to IRawLayout
Implements
IConvertFrom CanConvertFrom(Type)
Remarks

            Test if the sourceType can be converted to a
            IRawLayout. Only ILayout is supported
            as the sourceType.

See Also
RawLayoutConverter Class
RawLayoutConverter Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawLayoutConverter.ConvertFrom Method

RawLayoutConverter ConvertFrom Method Apache log4net™ SDK Documentation
Convert the value to a IRawLayout object

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ConvertFrom(
    Object source
)
public Object ConvertFrom(
    Object source
)
Public Function ConvertFrom (
    source As Object
) As Object
Public Function ConvertFrom (
    source As Object
) As Object
public:
virtual Object^ ConvertFrom(
    Object^ source
) sealed
public:
virtual Object^ ConvertFrom(
    Object^ source
) sealed
Parameters
source
Type:   Online System Object
the value to convert
Return Value
Type:   Online Object
the IRawLayout object
Implements
IConvertFrom ConvertFrom(Object)
Remarks

            Convert the source object to a
            IRawLayout object. If the source object
            is a ILayout then the Layout2RawLayoutAdapter
            is used to adapt between the two interfaces, otherwise an
            exception is thrown.

See Also
RawLayoutConverter Class
RawLayoutConverter Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawPropertyLayout Class

RawPropertyLayout Class Apache log4net™ SDK Documentation
Extract the value of a property from the LoggingEvent
Inheritance Hierarchy
Online System Object
log4net.Layout RawPropertyLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RawPropertyLayout : IRawLayout
public class RawPropertyLayout : IRawLayout
Public Class RawPropertyLayout
    Implements IRawLayout
Public Class RawPropertyLayout
    Implements IRawLayout
public ref class RawPropertyLayout : IRawLayout
public ref class RawPropertyLayout : IRawLayout
Remarks

            Extract the value of a property from the LoggingEvent
See Also
RawPropertyLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawPropertyLayout Members

RawPropertyLayout Members Apache log4net™ SDK Documentation
The RawPropertyLayout type exposes the following members.
Constructors
 | Name | Description
Public method | RawPropertyLayout | Constructs a RawPropertyLayout
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Lookup the property for Key
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Key | The name of the value to lookup in the LoggingEvent Properties collection.
Back to Top
See Also
RawPropertyLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawPropertyLayout Constructor

RawPropertyLayout Constructor Apache log4net™ SDK Documentation
Constructs a RawPropertyLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RawPropertyLayout()
public RawPropertyLayout()
Public Sub New
Public Sub New
public:
RawPropertyLayout()
public:
RawPropertyLayout()
See Also
RawPropertyLayout Class
RawPropertyLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawPropertyLayout Methods

RawPropertyLayout Methods Apache log4net™ SDK Documentation
The RawPropertyLayout type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Lookup the property for Key
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RawPropertyLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawPropertyLayout.Format Method

RawPropertyLayout Format Method Apache log4net™ SDK Documentation
Lookup the property for Key

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Format(
    LoggingEvent loggingEvent
)
public virtual Object Format(
    LoggingEvent loggingEvent
)
Public Overridable Function Format (
    loggingEvent As LoggingEvent
) As Object
Public Overridable Function Format (
    loggingEvent As LoggingEvent
) As Object
public:
virtual Object^ Format(
    LoggingEvent^ loggingEvent
)
public:
virtual Object^ Format(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to format
Return Value
Type:   Online Object
returns property value
Implements
IRawLayout Format(LoggingEvent)
Remarks

            Looks up and returns the object value of the property
            named Key. If there is no property defined
            with than name then null will be returned.

See Also
RawPropertyLayout Class
RawPropertyLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawPropertyLayout Properties

RawPropertyLayout Properties Apache log4net™ SDK Documentation
The RawPropertyLayout type exposes the following members.
Properties
 | Name | Description
Public property | Key | The name of the value to lookup in the LoggingEvent Properties collection.
Back to Top
See Also
RawPropertyLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawPropertyLayout.Key Property

RawPropertyLayout Key Property Apache log4net™ SDK Documentation
The name of the value to lookup in the LoggingEvent Properties collection.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; set; }
public string Key { get; set; }
Public Property Key As String
    Get
    Set
Public Property Key As String
    Get
    Set
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            Value to lookup in the LoggingEvent Properties collection

Remarks

            String name of the property to lookup in the LoggingEvent.

See Also
RawPropertyLayout Class
RawPropertyLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawTimeStampLayout Class

RawTimeStampLayout Class Apache log4net™ SDK Documentation
Extract the date from the LoggingEvent
Inheritance Hierarchy
Online System Object
log4net.Layout RawTimeStampLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RawTimeStampLayout : IRawLayout
public class RawTimeStampLayout : IRawLayout
Public Class RawTimeStampLayout
    Implements IRawLayout
Public Class RawTimeStampLayout
    Implements IRawLayout
public ref class RawTimeStampLayout : IRawLayout
public ref class RawTimeStampLayout : IRawLayout
Remarks

            Extract the date from the LoggingEvent
See Also
RawTimeStampLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawTimeStampLayout Members

RawTimeStampLayout Members Apache log4net™ SDK Documentation
The RawTimeStampLayout type exposes the following members.
Constructors
 | Name | Description
Public method | RawTimeStampLayout | Constructs a RawTimeStampLayout
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Gets the TimeStamp as a Online DateTime.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RawTimeStampLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawTimeStampLayout Constructor

RawTimeStampLayout Constructor Apache log4net™ SDK Documentation
Constructs a RawTimeStampLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RawTimeStampLayout()
public RawTimeStampLayout()
Public Sub New
Public Sub New
public:
RawTimeStampLayout()
public:
RawTimeStampLayout()
See Also
RawTimeStampLayout Class
RawTimeStampLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawTimeStampLayout Methods

RawTimeStampLayout Methods Apache log4net™ SDK Documentation
The RawTimeStampLayout type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Gets the TimeStamp as a Online DateTime.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RawTimeStampLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawTimeStampLayout.Format Method

RawTimeStampLayout Format Method Apache log4net™ SDK Documentation
Gets the TimeStamp as a Online DateTime.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Format(
    LoggingEvent loggingEvent
)
public virtual Object Format(
    LoggingEvent loggingEvent
)
Public Overridable Function Format (
    loggingEvent As LoggingEvent
) As Object
Public Overridable Function Format (
    loggingEvent As LoggingEvent
) As Object
public:
virtual Object^ Format(
    LoggingEvent^ loggingEvent
)
public:
virtual Object^ Format(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to format
Return Value
Type:   Online Object
returns the time stamp
Implements
IRawLayout Format(LoggingEvent)
Remarks

            Gets the TimeStamp as a   Online DateTime.

            The time stamp is in local time. To format the time stamp
            in universal time use RawUtcTimeStampLayout.

See Also
RawTimeStampLayout Class
RawTimeStampLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawUtcTimeStampLayout Class

RawUtcTimeStampLayout Class Apache log4net™ SDK Documentation
Extract the date from the LoggingEvent
Inheritance Hierarchy
Online System Object
log4net.Layout RawUtcTimeStampLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RawUtcTimeStampLayout : IRawLayout
public class RawUtcTimeStampLayout : IRawLayout
Public Class RawUtcTimeStampLayout
    Implements IRawLayout
Public Class RawUtcTimeStampLayout
    Implements IRawLayout
public ref class RawUtcTimeStampLayout : IRawLayout
public ref class RawUtcTimeStampLayout : IRawLayout
Remarks

            Extract the date from the LoggingEvent
See Also
RawUtcTimeStampLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawUtcTimeStampLayout Members

RawUtcTimeStampLayout Members Apache log4net™ SDK Documentation
The RawUtcTimeStampLayout type exposes the following members.
Constructors
 | Name | Description
Public method | RawUtcTimeStampLayout | Constructs a RawUtcTimeStampLayout
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Gets the TimeStamp as a Online DateTime.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RawUtcTimeStampLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawUtcTimeStampLayout Constructor

RawUtcTimeStampLayout Constructor Apache log4net™ SDK Documentation
Constructs a RawUtcTimeStampLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RawUtcTimeStampLayout()
public RawUtcTimeStampLayout()
Public Sub New
Public Sub New
public:
RawUtcTimeStampLayout()
public:
RawUtcTimeStampLayout()
See Also
RawUtcTimeStampLayout Class
RawUtcTimeStampLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawUtcTimeStampLayout Methods

RawUtcTimeStampLayout Methods Apache log4net™ SDK Documentation
The RawUtcTimeStampLayout type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Gets the TimeStamp as a Online DateTime.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RawUtcTimeStampLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RawUtcTimeStampLayout.Format Method

RawUtcTimeStampLayout Format Method Apache log4net™ SDK Documentation
Gets the TimeStamp as a Online DateTime.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Format(
    LoggingEvent loggingEvent
)
public virtual Object Format(
    LoggingEvent loggingEvent
)
Public Overridable Function Format (
    loggingEvent As LoggingEvent
) As Object
Public Overridable Function Format (
    loggingEvent As LoggingEvent
) As Object
public:
virtual Object^ Format(
    LoggingEvent^ loggingEvent
)
public:
virtual Object^ Format(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to format
Return Value
Type:   Online Object
returns the time stamp
Implements
IRawLayout Format(LoggingEvent)
Remarks

            Gets the TimeStamp as a   Online DateTime.

            The time stamp is in universal time. To format the time stamp
            in local time use RawTimeStampLayout.

See Also
RawUtcTimeStampLayout Class
RawUtcTimeStampLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleLayout Class

SimpleLayout Class Apache log4net™ SDK Documentation
A very simple layout
Inheritance Hierarchy
Online System Object
log4net.Layout LayoutSkeleton
log4net.Layout SimpleLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SimpleLayout : LayoutSkeleton
public class SimpleLayout : LayoutSkeleton
Public Class SimpleLayout
    Inherits LayoutSkeleton
Public Class SimpleLayout
    Inherits LayoutSkeleton
public ref class SimpleLayout : public LayoutSkeleton
public ref class SimpleLayout : public LayoutSkeleton
Remarks

            SimpleLayout consists of the level of the log statement,
            followed by " - " and then the log message itself. For example,

View Colorized Copy to Clipboard Print
DEBUG - Hello world
DEBUG - Hello world
See Also
SimpleLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleLayout Members

SimpleLayout Members Apache log4net™ SDK Documentation
The SimpleLayout type exposes the following members.
Constructors
 | Name | Description
Public method | SimpleLayout | Constructs a SimpleLayout
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize layout options (Overrides LayoutSkeleton ActivateOptions .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a simple formatted output. (Overrides LayoutSkeleton Format(TextWriter, LoggingEvent).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ContentType | The content type output by this layout. (Inherited from LayoutSkeleton.)
Public property | Footer | The footer for the layout format. (Inherited from LayoutSkeleton.)
Public property | Header | The header for the layout format. (Inherited from LayoutSkeleton.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Back to Top
See Also
SimpleLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleLayout Constructor

SimpleLayout Constructor Apache log4net™ SDK Documentation
Constructs a SimpleLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleLayout()
public SimpleLayout()
Public Sub New
Public Sub New
public:
SimpleLayout()
public:
SimpleLayout()
See Also
SimpleLayout Class
SimpleLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleLayout Methods

SimpleLayout Methods Apache log4net™ SDK Documentation
The SimpleLayout type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize layout options (Overrides LayoutSkeleton ActivateOptions .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a simple formatted output. (Overrides LayoutSkeleton Format(TextWriter, LoggingEvent).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleLayout.ActivateOptions Method

SimpleLayout ActivateOptions Method Apache log4net™ SDK Documentation
Initialize layout options

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
SimpleLayout Class
SimpleLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleLayout.Format Method

SimpleLayout Format Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a simple formatted output. (Overrides LayoutSkeleton Format(TextWriter, LoggingEvent).)
Back to Top
See Also
SimpleLayout Class
SimpleLayout Members
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleLayout.Format Method (TextWriter, LoggingEvent)

SimpleLayout Format Method (TextWriter, LoggingEvent) Apache log4net™ SDK Documentation
Produces a simple formatted output.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Format(
    TextWriter writer,
    LoggingEvent loggingEvent
)
public override void Format(
    TextWriter writer,
    LoggingEvent loggingEvent
)
Public Overrides Sub Format (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
Public Overrides Sub Format (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
public:
virtual void Format(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) override
public:
virtual void Format(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) override
Parameters
writer
Type:   Online System.IO TextWriter
The TextWriter to write the formatted event to
loggingEvent
Type: log4net.Core LoggingEvent
the event being logged
Implements
ILayout Format(TextWriter, LoggingEvent)
Remarks

            Formats the event as the level of the even,
            followed by " - " and then the log message itself. The
            output is terminated by a newline.

See Also
SimpleLayout Class
SimpleLayout Members
Format Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SimpleLayout Properties

SimpleLayout Properties Apache log4net™ SDK Documentation
The SimpleLayout type exposes the following members.
Properties
 | Name | Description
Public property | ContentType | The content type output by this layout. (Inherited from LayoutSkeleton.)
Public property | Footer | The footer for the layout format. (Inherited from LayoutSkeleton.)
Public property | Header | The header for the layout format. (Inherited from LayoutSkeleton.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Back to Top
See Also
SimpleLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayout Class

XmlLayout Class Apache log4net™ SDK Documentation
Layout that formats the log events as XML elements.
Inheritance Hierarchy
Online System Object
log4net.Layout LayoutSkeleton
log4net.Layout XmlLayoutBase
log4net.Layout XmlLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class XmlLayout : XmlLayoutBase
public class XmlLayout : XmlLayoutBase
Public Class XmlLayout
    Inherits XmlLayoutBase
Public Class XmlLayout
    Inherits XmlLayoutBase
public ref class XmlLayout : public XmlLayoutBase
public ref class XmlLayout : public XmlLayoutBase
Remarks

             The output of the XmlLayout consists of a series of
             log4net:event elements. It does not output a complete well-formed XML
             file. The output is designed to be included as an external entity
             in a separate file to form a correct XML file.

             For example, if abc is the name of the file where
             the XmlLayout output goes, then a well-formed XML file would
             be:

XML
View Colorized Copy to Clipboard Print
<?xml version="1.0" ?>

<!DOCTYPE log4net:events SYSTEM "log4net-events.dtd" [<!ENTITY data SYSTEM "abc">]>

<log4net:events version="1.2" xmlns:log4net=http://logging.apache.orglog4net/schemaslog4net-events-1.2>
    &data;
</log4net:events>
<?xml version="1.0" ?>

<!DOCTYPE log4net:events SYSTEM "log4net-events.dtd" [<!ENTITY data SYSTEM "abc">]>

<log4net:events version="1.2" xmlns:log4net=http://logging.apache.orglog4net/schemaslog4net-events-1.2>
    &data;
</log4net:events>

             This approach enforces the independence of the XmlLayout
             and the appender where it is embedded.

             The version attribute helps components to correctly
             interpret output generated by XmlLayout. The value of
             this attribute should be "1.2" for release 1.2 and later.

             Alternatively the Header and Footer properties can be
             configured to output the correct XML header, open tag and close tag.
             When setting the Header and Footer properties it is essential
             that the underlying data store not be appendable otherwise the data
             will become invalid XML.

See Also
XmlLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayout Members

XmlLayout Members Apache log4net™ SDK Documentation
The XmlLayout type exposes the following members.
Constructors
 | Name | Description
Public method | XmlLayout | Constructs an XmlLayout
Public method | XmlLayout(Boolean) | Constructs an XmlLayout.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize layout options (Overrides XmlLayoutBase ActivateOptions .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a formatted string. (Inherited from XmlLayoutBase.)
Protected method | FormatXml | Does the actual writing of the XML. (Overrides XmlLayoutBase FormatXml(XmlWriter, LoggingEvent).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Base64EncodeMessage | Set whether or not to base64 encode the message.
Public property | Base64EncodeProperties | Set whether or not to base64 encode the property values.
Public property | ContentType | Gets the content type output by this layout. (Inherited from XmlLayoutBase.)
Public property | Footer | The footer for the layout format. (Inherited from LayoutSkeleton.)
Public property | Header | The header for the layout format. (Inherited from LayoutSkeleton.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Public property | InvalidCharReplacement | The string to replace characters that can not be expressed in XML with. Remarks Not all characters may be expressed in XML. This property contains the string to replace those that can not with. This defaults to a ?. Set it to the empty string to simply remove offending characters. For more details on the allowed character ranges see http://www.w3.org/TR/REC-xml/#charsets Character replacement will occur in the log message, the property names and the property values. (Inherited from XmlLayoutBase.)
Public property | LocationInfo | Gets a value indicating whether to include location information in the XML events. (Inherited from XmlLayoutBase.)
Public property | Prefix | The prefix to use for all element names
Back to Top
See Also
XmlLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayout Constructor

XmlLayout Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | XmlLayout | Constructs an XmlLayout
Public method | XmlLayout(Boolean) | Constructs an XmlLayout.
Back to Top
See Also
XmlLayout Class
XmlLayout Members
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayout Constructor

XmlLayout Constructor Apache log4net™ SDK Documentation
Constructs an XmlLayout

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public XmlLayout()
public XmlLayout()
Public Sub New
Public Sub New
public:
XmlLayout()
public:
XmlLayout()
See Also
XmlLayout Class
XmlLayout Members
XmlLayout Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayout Constructor (Boolean)

XmlLayout Constructor (Boolean) Apache log4net™ SDK Documentation
Constructs an XmlLayout.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public XmlLayout(
    bool locationInfo
)
public XmlLayout(
    bool locationInfo
)
Public Sub New (
    locationInfo As Boolean
)
Public Sub New (
    locationInfo As Boolean
)
public:
XmlLayout(
    bool locationInfo
)
public:
XmlLayout(
    bool locationInfo
)
Parameters
locationInfo
Type:   Online System Boolean
[Missing <param name="locationInfo"/> documentation for "M:log4net.Layout.XmlLayout.#ctor(System.Boolean)"]
Remarks

            The LocationInfo option takes a boolean value. By
            default, it is set to false which means there will be no location
            information output by this layout. If the the option is set to
            true, then the file name and line number of the statement
            at the origin of the log statement will be output.

            If you are embedding this layout within an SmtpAppender
            then make sure to set the LocationInfo option of that
            appender as well.

See Also
XmlLayout Class
XmlLayout Members
XmlLayout Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayout Methods

XmlLayout Methods Apache log4net™ SDK Documentation
The XmlLayout type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize layout options (Overrides XmlLayoutBase ActivateOptions .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a formatted string. (Inherited from XmlLayoutBase.)
Protected method | FormatXml | Does the actual writing of the XML. (Overrides XmlLayoutBase FormatXml(XmlWriter, LoggingEvent).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
XmlLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayout.ActivateOptions Method

XmlLayout ActivateOptions Method Apache log4net™ SDK Documentation
Initialize layout options

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

            Builds a cache of the element names

See Also
XmlLayout Class
XmlLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayout.FormatXml Method

XmlLayout FormatXml Method Apache log4net™ SDK Documentation
Does the actual writing of the XML.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void FormatXml(
    XmlWriter writer,
    LoggingEvent loggingEvent
)
protected override void FormatXml(
    XmlWriter writer,
    LoggingEvent loggingEvent
)
Protected Overrides Sub FormatXml (
    writer As XmlWriter,
    loggingEvent As LoggingEvent
)
Protected Overrides Sub FormatXml (
    writer As XmlWriter,
    loggingEvent As LoggingEvent
)
protected:
virtual void FormatXml(
    XmlWriter^ writer,
    LoggingEvent^ loggingEvent
) override
protected:
virtual void FormatXml(
    XmlWriter^ writer,
    LoggingEvent^ loggingEvent
) override
Parameters
writer
Type:   Online System.Xml XmlWriter
The writer to use to output the event to.
loggingEvent
Type: log4net.Core LoggingEvent
The event to write.
Remarks

            Override the base class FormatXml(XmlWriter, LoggingEvent) method
            to write the LoggingEvent to the   Online XmlWriter.

See Also
XmlLayout Class
XmlLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayout Properties

XmlLayout Properties Apache log4net™ SDK Documentation
The XmlLayout type exposes the following members.
Properties
 | Name | Description
Public property | Base64EncodeMessage | Set whether or not to base64 encode the message.
Public property | Base64EncodeProperties | Set whether or not to base64 encode the property values.
Public property | ContentType | Gets the content type output by this layout. (Inherited from XmlLayoutBase.)
Public property | Footer | The footer for the layout format. (Inherited from LayoutSkeleton.)
Public property | Header | The header for the layout format. (Inherited from LayoutSkeleton.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Public property | InvalidCharReplacement | The string to replace characters that can not be expressed in XML with. Remarks Not all characters may be expressed in XML. This property contains the string to replace those that can not with. This defaults to a ?. Set it to the empty string to simply remove offending characters. For more details on the allowed character ranges see http://www.w3.org/TR/REC-xml/#charsets Character replacement will occur in the log message, the property names and the property values. (Inherited from XmlLayoutBase.)
Public property | LocationInfo | Gets a value indicating whether to include location information in the XML events. (Inherited from XmlLayoutBase.)
Public property | Prefix | The prefix to use for all element names
Back to Top
See Also
XmlLayout Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayout.Base64EncodeMessage Property

XmlLayout Base64EncodeMessage Property Apache log4net™ SDK Documentation
Set whether or not to base64 encode the message.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Base64EncodeMessage { get; set; }
public bool Base64EncodeMessage { get; set; }
Public Property Base64EncodeMessage As Boolean
    Get
    Set
Public Property Base64EncodeMessage As Boolean
    Get
    Set
public:
property bool Base64EncodeMessage {
    bool get ();
    void set (bool value);
}
public:
property bool Base64EncodeMessage {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
Remarks

            By default the log message will be written as text to the xml
            output. This can cause problems when the message contains binary
            data. By setting this to true the contents of the message will be
            base64 encoded. If this is set then invalid character replacement
            (see InvalidCharReplacement) will not be performed
            on the log message.

See Also
XmlLayout Class
XmlLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayout.Base64EncodeProperties Property

XmlLayout Base64EncodeProperties Property Apache log4net™ SDK Documentation
Set whether or not to base64 encode the property values.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Base64EncodeProperties { get; set; }
public bool Base64EncodeProperties { get; set; }
Public Property Base64EncodeProperties As Boolean
    Get
    Set
Public Property Base64EncodeProperties As Boolean
    Get
    Set
public:
property bool Base64EncodeProperties {
    bool get ();
    void set (bool value);
}
public:
property bool Base64EncodeProperties {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
Remarks

            By default the properties will be written as text to the xml
            output. This can cause problems when one or more properties contain
            binary data. By setting this to true the values of the properties
            will be base64 encoded. If this is set then invalid character replacement
            (see InvalidCharReplacement) will not be performed
            on the property values.

See Also
XmlLayout Class
XmlLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayout.Prefix Property

XmlLayout Prefix Property Apache log4net™ SDK Documentation
The prefix to use for all element names

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Prefix { get; set; }
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            The default prefix is log4net. Set this property
            to change the prefix. If the prefix is set to an empty string
            then no prefix will be written.

See Also
XmlLayout Class
XmlLayout Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase Class

XmlLayoutBase Class Apache log4net™ SDK Documentation
Layout that formats the log events as XML elements.
Inheritance Hierarchy
Online System Object
log4net.Layout LayoutSkeleton
log4net.Layout XmlLayoutBase
log4net.Layout XmlLayout
log4net.Layout XmlLayoutSchemaLog4j

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class XmlLayoutBase : LayoutSkeleton
public abstract class XmlLayoutBase : LayoutSkeleton
Public MustInherit Class XmlLayoutBase
    Inherits LayoutSkeleton
Public MustInherit Class XmlLayoutBase
    Inherits LayoutSkeleton
public ref class XmlLayoutBase abstract : public LayoutSkeleton
public ref class XmlLayoutBase abstract : public LayoutSkeleton
Remarks

            This is an abstract class that must be subclassed by an implementation
            to conform to a specific schema.

            Deriving classes must implement the FormatXml(XmlWriter, LoggingEvent) method.

See Also
XmlLayoutBase Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase Members

XmlLayoutBase Members Apache log4net™ SDK Documentation
The XmlLayoutBase type exposes the following members.
Constructors
 | Name | Description
Protected method | XmlLayoutBase | Protected constructor to support subclasses
Protected method | XmlLayoutBase(Boolean) | Protected constructor to support subclasses
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize layout options (Overrides LayoutSkeleton ActivateOptions .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a formatted string. (Overrides LayoutSkeleton Format(TextWriter, LoggingEvent).)
Protected method | FormatXml | Does the actual writing of the XML.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ContentType | Gets the content type output by this layout. (Overrides LayoutSkeleton ContentType.)
Public property | Footer | The footer for the layout format. (Inherited from LayoutSkeleton.)
Public property | Header | The header for the layout format. (Inherited from LayoutSkeleton.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Public property | InvalidCharReplacement | The string to replace characters that can not be expressed in XML with. Remarks Not all characters may be expressed in XML. This property contains the string to replace those that can not with. This defaults to a ?. Set it to the empty string to simply remove offending characters. For more details on the allowed character ranges see http://www.w3.org/TR/REC-xml/#charsets Character replacement will occur in the log message, the property names and the property values.
Public property | LocationInfo | Gets a value indicating whether to include location information in the XML events.
Back to Top
See Also
XmlLayoutBase Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase Constructor

XmlLayoutBase Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | XmlLayoutBase | Protected constructor to support subclasses
Protected method | XmlLayoutBase(Boolean) | Protected constructor to support subclasses
Back to Top
See Also
XmlLayoutBase Class
XmlLayoutBase Members
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase Constructor

XmlLayoutBase Constructor Apache log4net™ SDK Documentation
Protected constructor to support subclasses

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected XmlLayoutBase()
protected XmlLayoutBase()
Protected Sub New
Protected Sub New
protected:
XmlLayoutBase()
protected:
XmlLayoutBase()
Remarks

            Initializes a new instance of the XmlLayoutBase class
            with no location info.

See Also
XmlLayoutBase Class
XmlLayoutBase Members
XmlLayoutBase Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase Constructor (Boolean)

XmlLayoutBase Constructor (Boolean) Apache log4net™ SDK Documentation
Protected constructor to support subclasses

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected XmlLayoutBase(
    bool locationInfo
)
protected XmlLayoutBase(
    bool locationInfo
)
Protected Sub New (
    locationInfo As Boolean
)
Protected Sub New (
    locationInfo As Boolean
)
protected:
XmlLayoutBase(
    bool locationInfo
)
protected:
XmlLayoutBase(
    bool locationInfo
)
Parameters
locationInfo
Type:   Online System Boolean
[Missing <param name="locationInfo"/> documentation for "M:log4net.Layout.XmlLayoutBase.#ctor(System.Boolean)"]
Remarks

            The locationInfo parameter determines whether
            location information will be output by the layout. If
            locationInfo is set to true, then the
            file name and line number of the statement at the origin of the log
            statement will be output.

            If you are embedding this layout within an SMTPAppender
            then make sure to set the LocationInfo option of that
            appender as well.

See Also
XmlLayoutBase Class
XmlLayoutBase Members
XmlLayoutBase Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase Methods

XmlLayoutBase Methods Apache log4net™ SDK Documentation
The XmlLayoutBase type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize layout options (Overrides LayoutSkeleton ActivateOptions .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a formatted string. (Overrides LayoutSkeleton Format(TextWriter, LoggingEvent).)
Protected method | FormatXml | Does the actual writing of the XML.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
XmlLayoutBase Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase.ActivateOptions Method

XmlLayoutBase ActivateOptions Method Apache log4net™ SDK Documentation
Initialize layout options

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ActivateOptions()
public override void ActivateOptions()
Public Overrides Sub ActivateOptions
Public Overrides Sub ActivateOptions
public:
virtual void ActivateOptions() override
public:
virtual void ActivateOptions() override
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
XmlLayoutBase Class
XmlLayoutBase Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase.Format Method

XmlLayoutBase Format Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a formatted string. (Overrides LayoutSkeleton Format(TextWriter, LoggingEvent).)
Back to Top
See Also
XmlLayoutBase Class
XmlLayoutBase Members
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase.Format Method (TextWriter, LoggingEvent)

XmlLayoutBase Format Method (TextWriter, LoggingEvent) Apache log4net™ SDK Documentation
Produces a formatted string.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Format(
    TextWriter writer,
    LoggingEvent loggingEvent
)
public override void Format(
    TextWriter writer,
    LoggingEvent loggingEvent
)
Public Overrides Sub Format (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
Public Overrides Sub Format (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
public:
virtual void Format(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) override
public:
virtual void Format(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) override
Parameters
writer
Type:   Online System.IO TextWriter
The TextWriter to write the formatted event to
loggingEvent
Type: log4net.Core LoggingEvent
The event being logged.
Implements
ILayout Format(TextWriter, LoggingEvent)
Remarks

            Format the LoggingEvent and write it to the   Online TextWriter.

            This method creates an   Online XmlTextWriter that writes to the
            writer. The   Online XmlTextWriter is passed
            to the FormatXml(XmlWriter, LoggingEvent) method. Subclasses should override the
            FormatXml(XmlWriter, LoggingEvent) method rather than this method.

See Also
XmlLayoutBase Class
XmlLayoutBase Members
Format Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase.FormatXml Method

XmlLayoutBase FormatXml Method Apache log4net™ SDK Documentation
Does the actual writing of the XML.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void FormatXml(
    XmlWriter writer,
    LoggingEvent loggingEvent
)
protected abstract void FormatXml(
    XmlWriter writer,
    LoggingEvent loggingEvent
)
Protected MustOverride Sub FormatXml (
    writer As XmlWriter,
    loggingEvent As LoggingEvent
)
Protected MustOverride Sub FormatXml (
    writer As XmlWriter,
    loggingEvent As LoggingEvent
)
protected:
virtual void FormatXml(
    XmlWriter^ writer,
    LoggingEvent^ loggingEvent
) abstract
protected:
virtual void FormatXml(
    XmlWriter^ writer,
    LoggingEvent^ loggingEvent
) abstract
Parameters
writer
Type:   Online System.Xml XmlWriter
The writer to use to output the event to.
loggingEvent
Type: log4net.Core LoggingEvent
The event to write.
Remarks

            Subclasses should override this method to format
            the LoggingEvent as XML.

See Also
XmlLayoutBase Class
XmlLayoutBase Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase Properties

XmlLayoutBase Properties Apache log4net™ SDK Documentation
The XmlLayoutBase type exposes the following members.
Properties
 | Name | Description
Public property | ContentType | Gets the content type output by this layout. (Overrides LayoutSkeleton ContentType.)
Public property | Footer | The footer for the layout format. (Inherited from LayoutSkeleton.)
Public property | Header | The header for the layout format. (Inherited from LayoutSkeleton.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Public property | InvalidCharReplacement | The string to replace characters that can not be expressed in XML with. Remarks Not all characters may be expressed in XML. This property contains the string to replace those that can not with. This defaults to a ?. Set it to the empty string to simply remove offending characters. For more details on the allowed character ranges see http://www.w3.org/TR/REC-xml/#charsets Character replacement will occur in the log message, the property names and the property values.
Public property | LocationInfo | Gets a value indicating whether to include location information in the XML events.
Back to Top
See Also
XmlLayoutBase Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase.ContentType Property

XmlLayoutBase ContentType Property Apache log4net™ SDK Documentation
Gets the content type output by this layout.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ContentType { get; }
public override string ContentType { get; }
Public Overrides ReadOnly Property ContentType As String
    Get
Public Overrides ReadOnly Property ContentType As String
    Get
public:
virtual property String^ ContentType {
    String^ get () override;
}
public:
virtual property String^ ContentType {
    String^ get () override;
}
Property Value
Type:   Online String

            As this is the XML layout, the value is always "text/xml".

Implements
ILayout ContentType
Remarks

            As this is the XML layout, the value is always "text/xml".

See Also
XmlLayoutBase Class
XmlLayoutBase Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase.InvalidCharReplacement Property

XmlLayoutBase InvalidCharReplacement Property Apache log4net™ SDK Documentation
The string to replace characters that can not be expressed in XML with.
Remarks

Not all characters may be expressed in XML. This property contains the string to replace those that can not with. This defaults to a ?. Set it to the empty string to simply remove offending characters. For more details on the allowed character ranges see http://www.w3.org/TR/REC-xml/#charsets Character replacement will occur in the log message, the property names and the property values.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string InvalidCharReplacement { get; set; }
public string InvalidCharReplacement { get; set; }
Public Property InvalidCharReplacement As String
    Get
    Set
Public Property InvalidCharReplacement As String
    Get
    Set
public:
property String^ InvalidCharReplacement {
    String^ get ();
    void set (String^ value);
}
public:
property String^ InvalidCharReplacement {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
See Also
XmlLayoutBase Class
XmlLayoutBase Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutBase.LocationInfo Property

XmlLayoutBase LocationInfo Property Apache log4net™ SDK Documentation
Gets a value indicating whether to include location information in the XML events.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool LocationInfo { get; set; }
public bool LocationInfo { get; set; }
Public Property LocationInfo As Boolean
    Get
    Set
Public Property LocationInfo As Boolean
    Get
    Set
public:
property bool LocationInfo {
    bool get ();
    void set (bool value);
}
public:
property bool LocationInfo {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if location information should be included in the XML
            events; otherwise, false.

Remarks

            If LocationInfo is set to true, then the file
            name and line number of the statement at the origin of the log
            statement will be output.

            If you are embedding this layout within an SMTPAppender
            then make sure to set the LocationInfo option of that
            appender as well.

See Also
XmlLayoutBase Class
XmlLayoutBase Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutSchemaLog4j Class

XmlLayoutSchemaLog4j Class Apache log4net™ SDK Documentation
Layout that formats the log events as XML elements compatible with the log4j schema
Inheritance Hierarchy
Online System Object
log4net.Layout LayoutSkeleton
log4net.Layout XmlLayoutBase
log4net.Layout XmlLayoutSchemaLog4j

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class XmlLayoutSchemaLog4j : XmlLayoutBase
public class XmlLayoutSchemaLog4j : XmlLayoutBase
Public Class XmlLayoutSchemaLog4j
    Inherits XmlLayoutBase
Public Class XmlLayoutSchemaLog4j
    Inherits XmlLayoutBase
public ref class XmlLayoutSchemaLog4j : public XmlLayoutBase
public ref class XmlLayoutSchemaLog4j : public XmlLayoutBase
Remarks

            Formats the log events according to the http://logging.apache.org/log4j schema.

See Also
XmlLayoutSchemaLog4j Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutSchemaLog4j Members

XmlLayoutSchemaLog4j Members Apache log4net™ SDK Documentation
The XmlLayoutSchemaLog4j type exposes the following members.
Constructors
 | Name | Description
Public method | XmlLayoutSchemaLog4j | Constructs an XMLLayoutSchemaLog4j
Public method | XmlLayoutSchemaLog4j(Boolean) | Constructs an XMLLayoutSchemaLog4j.
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize layout options (Inherited from XmlLayoutBase.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a formatted string. (Inherited from XmlLayoutBase.)
Protected method | FormatXml | Actually do the writing of the xml (Overrides XmlLayoutBase FormatXml(XmlWriter, LoggingEvent).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ContentType | Gets the content type output by this layout. (Inherited from XmlLayoutBase.)
Public property | Footer | The footer for the layout format. (Inherited from LayoutSkeleton.)
Public property | Header | The header for the layout format. (Inherited from LayoutSkeleton.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Public property | InvalidCharReplacement | The string to replace characters that can not be expressed in XML with. Remarks Not all characters may be expressed in XML. This property contains the string to replace those that can not with. This defaults to a ?. Set it to the empty string to simply remove offending characters. For more details on the allowed character ranges see http://www.w3.org/TR/REC-xml/#charsets Character replacement will occur in the log message, the property names and the property values. (Inherited from XmlLayoutBase.)
Public property | LocationInfo | Gets a value indicating whether to include location information in the XML events. (Inherited from XmlLayoutBase.)
Public property | Version | The version of the log4j schema to use.
Back to Top
See Also
XmlLayoutSchemaLog4j Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutSchemaLog4j Constructor

XmlLayoutSchemaLog4j Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | XmlLayoutSchemaLog4j | Constructs an XMLLayoutSchemaLog4j
Public method | XmlLayoutSchemaLog4j(Boolean) | Constructs an XMLLayoutSchemaLog4j.
Back to Top
See Also
XmlLayoutSchemaLog4j Class
XmlLayoutSchemaLog4j Members
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutSchemaLog4j Constructor

XmlLayoutSchemaLog4j Constructor Apache log4net™ SDK Documentation
Constructs an XMLLayoutSchemaLog4j

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public XmlLayoutSchemaLog4j()
public XmlLayoutSchemaLog4j()
Public Sub New
Public Sub New
public:
XmlLayoutSchemaLog4j()
public:
XmlLayoutSchemaLog4j()
See Also
XmlLayoutSchemaLog4j Class
XmlLayoutSchemaLog4j Members
XmlLayoutSchemaLog4j Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutSchemaLog4j Constructor (Boolean)

XmlLayoutSchemaLog4j Constructor (Boolean) Apache log4net™ SDK Documentation
Constructs an XMLLayoutSchemaLog4j.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public XmlLayoutSchemaLog4j(
    bool locationInfo
)
public XmlLayoutSchemaLog4j(
    bool locationInfo
)
Public Sub New (
    locationInfo As Boolean
)
Public Sub New (
    locationInfo As Boolean
)
public:
XmlLayoutSchemaLog4j(
    bool locationInfo
)
public:
XmlLayoutSchemaLog4j(
    bool locationInfo
)
Parameters
locationInfo
Type:   Online System Boolean
[Missing <param name="locationInfo"/> documentation for "M:log4net.Layout.XmlLayoutSchemaLog4j.#ctor(System.Boolean)"]
Remarks

            The LocationInfo option takes a boolean value. By
            default, it is set to false which means there will be no location
            information output by this layout. If the the option is set to
            true, then the file name and line number of the statement
            at the origin of the log statement will be output.

            If you are embedding this layout within an SMTPAppender
            then make sure to set the LocationInfo option of that
            appender as well.

See Also
XmlLayoutSchemaLog4j Class
XmlLayoutSchemaLog4j Members
XmlLayoutSchemaLog4j Overload
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutSchemaLog4j Methods

XmlLayoutSchemaLog4j Methods Apache log4net™ SDK Documentation
The XmlLayoutSchemaLog4j type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize layout options (Inherited from XmlLayoutBase.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format(LoggingEvent) | Convenience method for easily formatting the logging event into a string variable. (Inherited from LayoutSkeleton.)
Public method | Format(TextWriter, LoggingEvent) | Produces a formatted string. (Inherited from XmlLayoutBase.)
Protected method | FormatXml | Actually do the writing of the xml (Overrides XmlLayoutBase FormatXml(XmlWriter, LoggingEvent).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
XmlLayoutSchemaLog4j Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutSchemaLog4j.FormatXml Method

XmlLayoutSchemaLog4j FormatXml Method Apache log4net™ SDK Documentation
Actually do the writing of the xml

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void FormatXml(
    XmlWriter writer,
    LoggingEvent loggingEvent
)
protected override void FormatXml(
    XmlWriter writer,
    LoggingEvent loggingEvent
)
Protected Overrides Sub FormatXml (
    writer As XmlWriter,
    loggingEvent As LoggingEvent
)
Protected Overrides Sub FormatXml (
    writer As XmlWriter,
    loggingEvent As LoggingEvent
)
protected:
virtual void FormatXml(
    XmlWriter^ writer,
    LoggingEvent^ loggingEvent
) override
protected:
virtual void FormatXml(
    XmlWriter^ writer,
    LoggingEvent^ loggingEvent
) override
Parameters
writer
Type:   Online System.Xml XmlWriter
the writer to use
loggingEvent
Type: log4net.Core LoggingEvent
the event to write
Remarks

            Generate XML that is compatible with the log4j schema.

See Also
XmlLayoutSchemaLog4j Class
XmlLayoutSchemaLog4j Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutSchemaLog4j Properties

XmlLayoutSchemaLog4j Properties Apache log4net™ SDK Documentation
The XmlLayoutSchemaLog4j type exposes the following members.
Properties
 | Name | Description
Public property | ContentType | Gets the content type output by this layout. (Inherited from XmlLayoutBase.)
Public property | Footer | The footer for the layout format. (Inherited from LayoutSkeleton.)
Public property | Header | The header for the layout format. (Inherited from LayoutSkeleton.)
Public property | IgnoresException | Flag indicating if this layout handles exceptions (Inherited from LayoutSkeleton.)
Public property | InvalidCharReplacement | The string to replace characters that can not be expressed in XML with. Remarks Not all characters may be expressed in XML. This property contains the string to replace those that can not with. This defaults to a ?. Set it to the empty string to simply remove offending characters. For more details on the allowed character ranges see http://www.w3.org/TR/REC-xml/#charsets Character replacement will occur in the log message, the property names and the property values. (Inherited from XmlLayoutBase.)
Public property | LocationInfo | Gets a value indicating whether to include location information in the XML events. (Inherited from XmlLayoutBase.)
Public property | Version | The version of the log4j schema to use.
Back to Top
See Also
XmlLayoutSchemaLog4j Class
log4net.Layout Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlLayoutSchemaLog4j.Version Property

XmlLayoutSchemaLog4j Version Property Apache log4net™ SDK Documentation
The version of the log4j schema to use.

Namespace: log4net.Layout
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Version { get; set; }
public string Version { get; set; }
Public Property Version As String
    Get
    Set
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            Only version 1.2 of the log4j schema is supported.

See Also
XmlLayoutSchemaLog4j Class
XmlLayoutSchemaLog4j Members
log4net.Layout Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.Layout.Pattern Namespace

log4net.Layout.Pattern Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | NamedPatternConverter | Converter to output and truncate '.' separated strings
Public class | PatternLayoutConverter | Abstract class that provides the formatting functionality that derived classes need.

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NamedPatternConverter Class

NamedPatternConverter Class Apache log4net™ SDK Documentation
Converter to output and truncate '.' separated strings
Inheritance Hierarchy
Online System Object
log4net.Util PatternConverter
log4net.Layout.Pattern PatternLayoutConverter
log4net.Layout.Pattern NamedPatternConverter

Namespace: log4net.Layout.Pattern
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class NamedPatternConverter : PatternLayoutConverter,
    IOptionHandler
public abstract class NamedPatternConverter : PatternLayoutConverter,
    IOptionHandler
Public MustInherit Class NamedPatternConverter
    Inherits PatternLayoutConverter
    Implements IOptionHandler
Public MustInherit Class NamedPatternConverter
    Inherits PatternLayoutConverter
    Implements IOptionHandler
public ref class NamedPatternConverter abstract : public PatternLayoutConverter,
    IOptionHandler
public ref class NamedPatternConverter abstract : public PatternLayoutConverter,
    IOptionHandler
Remarks

            This abstract class supports truncating a '.' separated string
            to show a specified number of elements from the right hand side.
            This is used to truncate class names that are fully qualified.

            Subclasses should override the GetFullyQualifiedName(LoggingEvent) method to
            return the fully qualified string.

See Also
NamedPatternConverter Members
log4net.Layout.Pattern Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NamedPatternConverter Members

NamedPatternConverter Members Apache log4net™ SDK Documentation
The NamedPatternConverter type exposes the following members.
Constructors
 | Name | Description
Protected method | NamedPatternConverter | Initializes a new instance of the NamedPatternConverter class
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the converter
Protected method | Convert(TextWriter, LoggingEvent) | Convert the pattern to the rendered message (Overrides PatternLayoutConverter Convert(TextWriter, LoggingEvent).)
Protected method | Convert(TextWriter, Object) | Derived pattern converters must override this method in order to convert conversion specifiers in the correct way. (Inherited from PatternLayoutConverter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Write the pattern converter to the writer with appropriate formatting (Inherited from PatternConverter.)
Protected method | GetFullyQualifiedName | Get the fully qualified string data
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetNext | Set the next pattern converter in the chains (Inherited from PatternConverter.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | FormattingInfo | Gets or sets the formatting info for this converter (Inherited from PatternConverter.)
Public property | IgnoresException | Flag indicating if this converter handles the logging event exception (Inherited from PatternLayoutConverter.)
Public property | Next | Get the next pattern converter in the chain (Inherited from PatternConverter.)
Public property | Option | Gets or sets the option value for this converter (Inherited from PatternConverter.)
Public property | Properties | (Inherited from PatternConverter.)
Back to Top
See Also
NamedPatternConverter Class
log4net.Layout.Pattern Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NamedPatternConverter Constructor

NamedPatternConverter Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the NamedPatternConverter class

Namespace: log4net.Layout.Pattern
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected NamedPatternConverter()
protected NamedPatternConverter()
Protected Sub New
Protected Sub New
protected:
NamedPatternConverter()
protected:
NamedPatternConverter()
See Also
NamedPatternConverter Class
NamedPatternConverter Members
log4net.Layout.Pattern Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NamedPatternConverter Methods

NamedPatternConverter Methods Apache log4net™ SDK Documentation
The NamedPatternConverter type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the converter
Protected method | Convert(TextWriter, LoggingEvent) | Convert the pattern to the rendered message (Overrides PatternLayoutConverter Convert(TextWriter, LoggingEvent).)
Protected method | Convert(TextWriter, Object) | Derived pattern converters must override this method in order to convert conversion specifiers in the correct way. (Inherited from PatternLayoutConverter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Write the pattern converter to the writer with appropriate formatting (Inherited from PatternConverter.)
Protected method | GetFullyQualifiedName | Get the fully qualified string data
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetNext | Set the next pattern converter in the chains (Inherited from PatternConverter.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NamedPatternConverter Class
log4net.Layout.Pattern Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NamedPatternConverter.ActivateOptions Method

NamedPatternConverter ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the converter

Namespace: log4net.Layout.Pattern
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ActivateOptions()
public void ActivateOptions()
Public Sub ActivateOptions
Public Sub ActivateOptions
public:
virtual void ActivateOptions() sealed
public:
virtual void ActivateOptions() sealed
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
NamedPatternConverter Class
NamedPatternConverter Members
log4net.Layout.Pattern Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NamedPatternConverter.Convert Method

NamedPatternConverter Convert Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Convert(TextWriter, LoggingEvent) | Convert the pattern to the rendered message (Overrides PatternLayoutConverter Convert(TextWriter, LoggingEvent).)
Protected method | Convert(TextWriter, Object) | Derived pattern converters must override this method in order to convert conversion specifiers in the correct way. (Inherited from PatternLayoutConverter.)
Back to Top
See Also
NamedPatternConverter Class
NamedPatternConverter Members
log4net.Layout.Pattern Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NamedPatternConverter.Convert Method (TextWriter, LoggingEvent)

NamedPatternConverter Convert Method (TextWriter, LoggingEvent) Apache log4net™ SDK Documentation
Convert the pattern to the rendered message

Namespace: log4net.Layout.Pattern
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override sealed void Convert(
    TextWriter writer,
    LoggingEvent loggingEvent
)
protected override sealed void Convert(
    TextWriter writer,
    LoggingEvent loggingEvent
)
Protected Overrides NotOverridable Sub Convert (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
Protected Overrides NotOverridable Sub Convert (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
protected:
virtual void Convert(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) override sealed
protected:
virtual void Convert(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) override sealed
Parameters
writer
Type:   Online System.IO TextWriter
  Online TextWriter that will receive the formatted result.
loggingEvent
Type: log4net.Core LoggingEvent
the event being logged
Remarks

            Render the GetFullyQualifiedName(LoggingEvent) to the precision
            specified by the Option property.

See Also
NamedPatternConverter Class
NamedPatternConverter Members
Convert Overload
log4net.Layout.Pattern Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NamedPatternConverter.GetFullyQualifiedName Method

NamedPatternConverter GetFullyQualifiedName Method Apache log4net™ SDK Documentation
Get the fully qualified string data

Namespace: log4net.Layout.Pattern
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract string GetFullyQualifiedName(
    LoggingEvent loggingEvent
)
protected abstract string GetFullyQualifiedName(
    LoggingEvent loggingEvent
)
Protected MustOverride Function GetFullyQualifiedName (
    loggingEvent As LoggingEvent
) As String
Protected MustOverride Function GetFullyQualifiedName (
    loggingEvent As LoggingEvent
) As String
protected:
virtual String^ GetFullyQualifiedName(
    LoggingEvent^ loggingEvent
) abstract
protected:
virtual String^ GetFullyQualifiedName(
    LoggingEvent^ loggingEvent
) abstract
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
the event being logged
Return Value
Type:   Online String
the fully qualified name
Remarks

            Overridden by subclasses to get the fully qualified name before the
            precision is applied to it.

            Return the fully qualified '.' (dot/period) separated string.

See Also
NamedPatternConverter Class
NamedPatternConverter Members
log4net.Layout.Pattern Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NamedPatternConverter Properties

NamedPatternConverter Properties Apache log4net™ SDK Documentation
The NamedPatternConverter type exposes the following members.
Properties
 | Name | Description
Public property | FormattingInfo | Gets or sets the formatting info for this converter (Inherited from PatternConverter.)
Public property | IgnoresException | Flag indicating if this converter handles the logging event exception (Inherited from PatternLayoutConverter.)
Public property | Next | Get the next pattern converter in the chain (Inherited from PatternConverter.)
Public property | Option | Gets or sets the option value for this converter (Inherited from PatternConverter.)
Public property | Properties | (Inherited from PatternConverter.)
Back to Top
See Also
NamedPatternConverter Class
log4net.Layout.Pattern Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayoutConverter Class

PatternLayoutConverter Class Apache log4net™ SDK Documentation
Abstract class that provides the formatting functionality that derived classes need.
Inheritance Hierarchy
Online System Object
log4net.Util PatternConverter
log4net.Layout.Pattern PatternLayoutConverter
log4net.Layout.Pattern NamedPatternConverter

Namespace: log4net.Layout.Pattern
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PatternLayoutConverter : PatternConverter
public abstract class PatternLayoutConverter : PatternConverter
Public MustInherit Class PatternLayoutConverter
    Inherits PatternConverter
Public MustInherit Class PatternLayoutConverter
    Inherits PatternConverter
public ref class PatternLayoutConverter abstract : public PatternConverter
public ref class PatternLayoutConverter abstract : public PatternConverter
Remarks

            Conversion specifiers in a conversion patterns are parsed to
            individual PatternConverters. Each of which is responsible for
            converting a logging event in a converter specific manner.

See Also
PatternLayoutConverter Members
log4net.Layout.Pattern Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayoutConverter Members

PatternLayoutConverter Members Apache log4net™ SDK Documentation
The PatternLayoutConverter type exposes the following members.
Constructors
 | Name | Description
Protected method | PatternLayoutConverter | Initializes a new instance of the PatternLayoutConverter class.
Back to Top
Methods
 | Name | Description
Protected method | Convert(TextWriter, LoggingEvent) | Derived pattern converters must override this method in order to convert conversion specifiers in the correct way.
Protected method | Convert(TextWriter, Object) | Derived pattern converters must override this method in order to convert conversion specifiers in the correct way. (Overrides PatternConverter Convert(TextWriter, Object).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Write the pattern converter to the writer with appropriate formatting (Inherited from PatternConverter.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetNext | Set the next pattern converter in the chains (Inherited from PatternConverter.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | FormattingInfo | Gets or sets the formatting info for this converter (Inherited from PatternConverter.)
Public property | IgnoresException | Flag indicating if this converter handles the logging event exception
Public property | Next | Get the next pattern converter in the chain (Inherited from PatternConverter.)
Public property | Option | Gets or sets the option value for this converter (Inherited from PatternConverter.)
Public property | Properties | (Inherited from PatternConverter.)
Back to Top
See Also
PatternLayoutConverter Class
log4net.Layout.Pattern Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayoutConverter Constructor

PatternLayoutConverter Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the PatternLayoutConverter class.

Namespace: log4net.Layout.Pattern
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PatternLayoutConverter()
protected PatternLayoutConverter()
Protected Sub New
Protected Sub New
protected:
PatternLayoutConverter()
protected:
PatternLayoutConverter()
See Also
PatternLayoutConverter Class
PatternLayoutConverter Members
log4net.Layout.Pattern Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayoutConverter Methods

PatternLayoutConverter Methods Apache log4net™ SDK Documentation
The PatternLayoutConverter type exposes the following members.
Methods
 | Name | Description
Protected method | Convert(TextWriter, LoggingEvent) | Derived pattern converters must override this method in order to convert conversion specifiers in the correct way.
Protected method | Convert(TextWriter, Object) | Derived pattern converters must override this method in order to convert conversion specifiers in the correct way. (Overrides PatternConverter Convert(TextWriter, Object).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Write the pattern converter to the writer with appropriate formatting (Inherited from PatternConverter.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetNext | Set the next pattern converter in the chains (Inherited from PatternConverter.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PatternLayoutConverter Class
log4net.Layout.Pattern Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayoutConverter.Convert Method

PatternLayoutConverter Convert Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | Convert(TextWriter, LoggingEvent) | Derived pattern converters must override this method in order to convert conversion specifiers in the correct way.
Protected method | Convert(TextWriter, Object) | Derived pattern converters must override this method in order to convert conversion specifiers in the correct way. (Overrides PatternConverter Convert(TextWriter, Object).)
Back to Top
See Also
PatternLayoutConverter Class
PatternLayoutConverter Members
log4net.Layout.Pattern Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayoutConverter.Convert Method (TextWriter, LoggingEvent)

PatternLayoutConverter Convert Method (TextWriter, LoggingEvent) Apache log4net™ SDK Documentation
Derived pattern converters must override this method in order to convert conversion specifiers in the correct way.

Namespace: log4net.Layout.Pattern
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Convert(
    TextWriter writer,
    LoggingEvent loggingEvent
)
protected abstract void Convert(
    TextWriter writer,
    LoggingEvent loggingEvent
)
Protected MustOverride Sub Convert (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
Protected MustOverride Sub Convert (
    writer As TextWriter,
    loggingEvent As LoggingEvent
)
protected:
virtual void Convert(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) abstract
protected:
virtual void Convert(
    TextWriter^ writer,
    LoggingEvent^ loggingEvent
) abstract
Parameters
writer
Type:   Online System.IO TextWriter
  Online TextWriter that will receive the formatted result.
loggingEvent
Type: log4net.Core LoggingEvent
The LoggingEvent on which the pattern converter should be executed.
See Also
PatternLayoutConverter Class
PatternLayoutConverter Members
Convert Overload
log4net.Layout.Pattern Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayoutConverter.Convert Method (TextWriter, Object)

PatternLayoutConverter Convert Method (TextWriter, Object) Apache log4net™ SDK Documentation
Derived pattern converters must override this method in order to convert conversion specifiers in the correct way.

Namespace: log4net.Layout.Pattern
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Convert(
    TextWriter writer,
    Object state
)
protected override void Convert(
    TextWriter writer,
    Object state
)
Protected Overrides Sub Convert (
    writer As TextWriter,
    state As Object
)
Protected Overrides Sub Convert (
    writer As TextWriter,
    state As Object
)
protected:
virtual void Convert(
    TextWriter^ writer,
    Object^ state
) override
protected:
virtual void Convert(
    TextWriter^ writer,
    Object^ state
) override
Parameters
writer
Type:   Online System.IO TextWriter
  Online TextWriter that will receive the formatted result.
state
Type:   Online System Object
The state object on which the pattern converter should be executed.
See Also
PatternLayoutConverter Class
PatternLayoutConverter Members
Convert Overload
log4net.Layout.Pattern Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayoutConverter Properties

PatternLayoutConverter Properties Apache log4net™ SDK Documentation
The PatternLayoutConverter type exposes the following members.
Properties
 | Name | Description
Public property | FormattingInfo | Gets or sets the formatting info for this converter (Inherited from PatternConverter.)
Public property | IgnoresException | Flag indicating if this converter handles the logging event exception
Public property | Next | Get the next pattern converter in the chain (Inherited from PatternConverter.)
Public property | Option | Gets or sets the option value for this converter (Inherited from PatternConverter.)
Public property | Properties | (Inherited from PatternConverter.)
Back to Top
See Also
PatternLayoutConverter Class
log4net.Layout.Pattern Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternLayoutConverter.IgnoresException Property

PatternLayoutConverter IgnoresException Property Apache log4net™ SDK Documentation
Flag indicating if this converter handles the logging event exception

Namespace: log4net.Layout.Pattern
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IgnoresException { get; set; }
public virtual bool IgnoresException { get; set; }
Public Overridable Property IgnoresException As Boolean
    Get
    Set
Public Overridable Property IgnoresException As Boolean
    Get
    Set
public:
virtual property bool IgnoresException {
    bool get ();
    void set (bool value);
}
public:
virtual property bool IgnoresException {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
false if this converter handles the logging event exception
Remarks

            If this converter handles the exception object contained within
            LoggingEvent, then this property should be set to
            false. Otherwise, if the layout ignores the exception
            object, then the property should be set to true.

            Set this value to override a this default setting. The default
            value is true, this converter does not handle the exception.

See Also
PatternLayoutConverter Class
PatternLayoutConverter Members
log4net.Layout.Pattern Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.ObjectRenderer Namespace

log4net.ObjectRenderer Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | DefaultRenderer | The default object Renderer.
Public class | RendererMap | Map class objects to an IObjectRenderer.
Interfaces
 | Interface | Description
Public interface | IObjectRenderer | Implement this interface in order to render objects as strings

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRenderer Class

DefaultRenderer Class Apache log4net™ SDK Documentation
The default object Renderer.
Inheritance Hierarchy
Online System Object
log4net.ObjectRenderer DefaultRenderer

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class DefaultRenderer : IObjectRenderer
public sealed class DefaultRenderer : IObjectRenderer
Public NotInheritable Class DefaultRenderer
    Implements IObjectRenderer
Public NotInheritable Class DefaultRenderer
    Implements IObjectRenderer
public ref class DefaultRenderer sealed : IObjectRenderer
public ref class DefaultRenderer sealed : IObjectRenderer
Remarks

            The default renderer supports rendering objects and collections to strings.

            See the RenderObject(RendererMap, Object, TextWriter) method for details of the output.

See Also
DefaultRenderer Members
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRenderer Members

DefaultRenderer Members Apache log4net™ SDK Documentation
The DefaultRenderer type exposes the following members.
Constructors
 | Name | Description
Public method | DefaultRenderer | Default constructor
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RenderObject | Render the object obj to a string
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DefaultRenderer Class
log4net.ObjectRenderer Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRenderer Constructor

DefaultRenderer Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DefaultRenderer()
public DefaultRenderer()
Public Sub New
Public Sub New
public:
DefaultRenderer()
public:
DefaultRenderer()
Remarks

            Default constructor

See Also
DefaultRenderer Class
DefaultRenderer Members
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRenderer Methods

DefaultRenderer Methods Apache log4net™ SDK Documentation
The DefaultRenderer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RenderObject | Render the object obj to a string
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DefaultRenderer Class
log4net.ObjectRenderer Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


DefaultRenderer.RenderObject Method

DefaultRenderer RenderObject Method Apache log4net™ SDK Documentation
Render the object obj to a string

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RenderObject(
    RendererMap rendererMap,
    Object obj,
    TextWriter writer
)
public void RenderObject(
    RendererMap rendererMap,
    Object obj,
    TextWriter writer
)
Public Sub RenderObject (
    rendererMap As RendererMap,
    obj As Object,
    writer As TextWriter
)
Public Sub RenderObject (
    rendererMap As RendererMap,
    obj As Object,
    writer As TextWriter
)
public:
virtual void RenderObject(
    RendererMap^ rendererMap,
    Object^ obj,
    TextWriter^ writer
) sealed
public:
virtual void RenderObject(
    RendererMap^ rendererMap,
    Object^ obj,
    TextWriter^ writer
) sealed
Parameters
rendererMap
Type: log4net.ObjectRenderer RendererMap
The map used to lookup renderers
obj
Type:   Online System Object
The object to render
writer
Type:   Online System.IO TextWriter
The writer to render to
Implements
IObjectRenderer RenderObject(RendererMap, Object, TextWriter)
Remarks

            Render the object obj to a string.

            The rendererMap parameter is
            provided to lookup and render other objects. This is
            very useful where obj contains
            nested objects of unknown type. The FindAndRender(object)
            method can be used to render these objects.

            The default renderer supports rendering objects to strings as follows:

Value | Rendered String
null | "(null)"
Online Array | For a one dimensional array this is the array type name, an open brace, followed by a comma separated list of the elements (using the appropriate renderer), followed by a close brace. For example: int[] {1, 2, 3}. If the array is not one dimensional the Array.ToString() is returned.
Online IEnumerable, Online ICollection & Online IEnumerator | Rendered as an open brace, followed by a comma separated list of the elements (using the appropriate renderer), followed by a close brace. For example: {a, b, c}. All collection classes that implement Online ICollection its subclasses, or generic equivalents all implement the Online IEnumerable interface.
Online DictionaryEntry | Rendered as the key, an equals sign ('='), and the value (using the appropriate renderer). For example: key=value.
other | Object.ToString()
See Also
DefaultRenderer Class
DefaultRenderer Members
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IObjectRenderer Interface

IObjectRenderer Interface Apache log4net™ SDK Documentation
Implement this interface in order to render objects as strings

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IObjectRenderer
public interface IObjectRenderer
Public Interface IObjectRenderer
Public Interface IObjectRenderer
public interface class IObjectRenderer
public interface class IObjectRenderer
Remarks

            Certain types require special case conversion to
            string form. This conversion is done by an object renderer.
            Object renderers implement the IObjectRenderer
            interface.

See Also
IObjectRenderer Members
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IObjectRenderer Members

IObjectRenderer Members Apache log4net™ SDK Documentation
The IObjectRenderer type exposes the following members.
Methods
 | Name | Description
Public method | RenderObject | Render the object obj to a string
Back to Top
See Also
IObjectRenderer Interface
log4net.ObjectRenderer Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IObjectRenderer Methods

IObjectRenderer Methods Apache log4net™ SDK Documentation
The IObjectRenderer type exposes the following members.
Methods
 | Name | Description
Public method | RenderObject | Render the object obj to a string
Back to Top
See Also
IObjectRenderer Interface
log4net.ObjectRenderer Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IObjectRenderer.RenderObject Method

IObjectRenderer RenderObject Method Apache log4net™ SDK Documentation
Render the object obj to a string

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RenderObject(
    RendererMap rendererMap,
    Object obj,
    TextWriter writer
)
void RenderObject(
    RendererMap rendererMap,
    Object obj,
    TextWriter writer
)
Sub RenderObject (
    rendererMap As RendererMap,
    obj As Object,
    writer As TextWriter
)
Sub RenderObject (
    rendererMap As RendererMap,
    obj As Object,
    writer As TextWriter
)
void RenderObject(
    RendererMap^ rendererMap,
    Object^ obj,
    TextWriter^ writer
)
void RenderObject(
    RendererMap^ rendererMap,
    Object^ obj,
    TextWriter^ writer
)
Parameters
rendererMap
Type: log4net.ObjectRenderer RendererMap
The map used to lookup renderers
obj
Type:   Online System Object
The object to render
writer
Type:   Online System.IO TextWriter
The writer to render to
Remarks

            Render the object obj to a
            string.

            The rendererMap parameter is
            provided to lookup and render other objects. This is
            very useful where obj contains
            nested objects of unknown type. The [M:RendererMap.FindAndRender(object, TextWriter)]
            method can be used to render these objects.

See Also
IObjectRenderer Interface
IObjectRenderer Members
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap Class

RendererMap Class Apache log4net™ SDK Documentation
Map class objects to an IObjectRenderer.
Inheritance Hierarchy
Online System Object
log4net.ObjectRenderer RendererMap

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RendererMap
public class RendererMap
Public Class RendererMap
Public Class RendererMap
public ref class RendererMap
public ref class RendererMap
Remarks

            Maintains a mapping between types that require special
            rendering and the IObjectRenderer that
            is used to render them.

            The [M:FindAndRender(object)] method is used to render an
            object using the appropriate renderers defined in this map.

See Also
RendererMap Members
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap Members

RendererMap Members Apache log4net™ SDK Documentation
The RendererMap type exposes the following members.
Constructors
 | Name | Description
Public method | RendererMap | Default Constructor
Back to Top
Methods
 | Name | Description
Public method | Clear | Clear the map of renderers
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindAndRender(Object) | Render obj using the appropriate renderer.
Public method | FindAndRender(Object, TextWriter) | Render obj using the appropriate renderer.
Public method | Get(Object) | Gets the renderer for the specified object type
Public method | Get(Type) | Gets the renderer for the specified type
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put | Register an IObjectRenderer for typeToRender.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | DefaultRenderer | Get the default renderer instance
Back to Top
See Also
RendererMap Class
log4net.ObjectRenderer Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap Constructor

RendererMap Constructor Apache log4net™ SDK Documentation
Default Constructor

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RendererMap()
public RendererMap()
Public Sub New
Public Sub New
public:
RendererMap()
public:
RendererMap()
Remarks

            Default constructor.

See Also
RendererMap Class
RendererMap Members
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap Methods

RendererMap Methods Apache log4net™ SDK Documentation
The RendererMap type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Clear the map of renderers
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindAndRender(Object) | Render obj using the appropriate renderer.
Public method | FindAndRender(Object, TextWriter) | Render obj using the appropriate renderer.
Public method | Get(Object) | Gets the renderer for the specified object type
Public method | Get(Type) | Gets the renderer for the specified type
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put | Register an IObjectRenderer for typeToRender.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RendererMap Class
log4net.ObjectRenderer Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap.Clear Method

RendererMap Clear Method Apache log4net™ SDK Documentation
Clear the map of renderers

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
Remarks

            Clear the custom renderers defined by using
            Put(Type, IObjectRenderer). The DefaultRenderer
            cannot be removed.

See Also
RendererMap Class
RendererMap Members
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap.FindAndRender Method

RendererMap FindAndRender Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | FindAndRender(Object) | Render obj using the appropriate renderer.
Public method | FindAndRender(Object, TextWriter) | Render obj using the appropriate renderer.
Back to Top
See Also
RendererMap Class
RendererMap Members
log4net.ObjectRenderer Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap.FindAndRender Method (Object)

RendererMap FindAndRender Method (Object) Apache log4net™ SDK Documentation
Render obj using the appropriate renderer.

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FindAndRender(
    Object obj
)
public string FindAndRender(
    Object obj
)
Public Function FindAndRender (
    obj As Object
) As String
Public Function FindAndRender (
    obj As Object
) As String
public:
String^ FindAndRender(
    Object^ obj
)
public:
String^ FindAndRender(
    Object^ obj
)
Parameters
obj
Type:   Online System Object
the object to render to a string
Return Value
Type:   Online String
the object rendered as a string
Remarks

            This is a convenience method used to render an object to a string.
            The alternative method [M:FindAndRender(object,TextWriter)]
            should be used when streaming output to a   Online TextWriter.

See Also
RendererMap Class
RendererMap Members
FindAndRender Overload
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap.FindAndRender Method (Object, TextWriter)

RendererMap FindAndRender Method (Object, TextWriter) Apache log4net™ SDK Documentation
Render obj using the appropriate renderer.

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void FindAndRender(
    Object obj,
    TextWriter writer
)
public void FindAndRender(
    Object obj,
    TextWriter writer
)
Public Sub FindAndRender (
    obj As Object,
    writer As TextWriter
)
Public Sub FindAndRender (
    obj As Object,
    writer As TextWriter
)
public:
void FindAndRender(
    Object^ obj,
    TextWriter^ writer
)
public:
void FindAndRender(
    Object^ obj,
    TextWriter^ writer
)
Parameters
obj
Type:   Online System Object
the object to render to a string
writer
Type:   Online System.IO TextWriter
The writer to render to
Remarks

            Find the appropriate renderer for the type of the
            obj parameter. This is accomplished by calling the
            [M:Get(Type)] method. Once a renderer is found, it is
            applied on the object obj and the result is returned
            as a   Online String.

See Also
RendererMap Class
RendererMap Members
FindAndRender Overload
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap.Get Method

RendererMap Get Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Get(Object) | Gets the renderer for the specified object type
Public method | Get(Type) | Gets the renderer for the specified type
Back to Top
See Also
RendererMap Class
RendererMap Members
log4net.ObjectRenderer Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap.Get Method (Object)

RendererMap Get Method (Object) Apache log4net™ SDK Documentation
Gets the renderer for the specified object type

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IObjectRenderer Get(
    Object obj
)
public IObjectRenderer Get(
    Object obj
)
Public Function Get (
    obj As Object
) As IObjectRenderer
Public Function Get (
    obj As Object
) As IObjectRenderer
public:
IObjectRenderer^ Get(
    Object^ obj
)
public:
IObjectRenderer^ Get(
    Object^ obj
)
Parameters
obj
Type:   Online System Object
the object to lookup the renderer for
Return Value
Type: IObjectRenderer
the renderer for obj
Remarks

            Gets the renderer for the specified object type.

            Syntactic sugar method that calls [M:Get(Type)]
            with the type of the object parameter.

See Also
RendererMap Class
RendererMap Members
Get Overload
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap.Get Method (Type)

RendererMap Get Method (Type) Apache log4net™ SDK Documentation
Gets the renderer for the specified type

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IObjectRenderer Get(
    Type type
)
public IObjectRenderer Get(
    Type type
)
Public Function Get (
    type As Type
) As IObjectRenderer
Public Function Get (
    type As Type
) As IObjectRenderer
public:
IObjectRenderer^ Get(
    Type^ type
)
public:
IObjectRenderer^ Get(
    Type^ type
)
Parameters
type
Type:   Online System Type
the type to lookup the renderer for
Return Value
Type: IObjectRenderer
the renderer for the specified type
Remarks

            Returns the renderer for the specified type.
            If no specific renderer has been defined the
            DefaultRenderer will be returned.

See Also
RendererMap Class
RendererMap Members
Get Overload
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap.Put Method

RendererMap Put Method Apache log4net™ SDK Documentation
Register an IObjectRenderer for typeToRender.

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Put(
    Type typeToRender,
    IObjectRenderer renderer
)
public void Put(
    Type typeToRender,
    IObjectRenderer renderer
)
Public Sub Put (
    typeToRender As Type,
    renderer As IObjectRenderer
)
Public Sub Put (
    typeToRender As Type,
    renderer As IObjectRenderer
)
public:
void Put(
    Type^ typeToRender,
    IObjectRenderer^ renderer
)
public:
void Put(
    Type^ typeToRender,
    IObjectRenderer^ renderer
)
Parameters
typeToRender
Type:   Online System Type
the type that will be rendered by renderer
renderer
Type: log4net.ObjectRenderer IObjectRenderer
the renderer for typeToRender
Remarks

            Register an object renderer for a specific source type.
            This renderer will be returned from a call to [M:Get(Type)]
            specifying the same typeToRender as an argument.

See Also
RendererMap Class
RendererMap Members
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap Properties

RendererMap Properties Apache log4net™ SDK Documentation
The RendererMap type exposes the following members.
Properties
 | Name | Description
Public property | DefaultRenderer | Get the default renderer instance
Back to Top
See Also
RendererMap Class
log4net.ObjectRenderer Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RendererMap.DefaultRenderer Property

RendererMap DefaultRenderer Property Apache log4net™ SDK Documentation
Get the default renderer instance

Namespace: log4net.ObjectRenderer
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IObjectRenderer DefaultRenderer { get; }
public IObjectRenderer DefaultRenderer { get; }
Public ReadOnly Property DefaultRenderer As IObjectRenderer
    Get
Public ReadOnly Property DefaultRenderer As IObjectRenderer
    Get
public:
property IObjectRenderer^ DefaultRenderer {
    IObjectRenderer^ get ();
}
public:
property IObjectRenderer^ DefaultRenderer {
    IObjectRenderer^ get ();
}
Property Value
Type: IObjectRenderer
the default renderer
Remarks

            Get the default renderer

See Also
RendererMap Class
RendererMap Members
log4net.ObjectRenderer Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.Plugin Namespace

log4net.Plugin Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | PluginCollection | A strongly-typed collection of IPlugin objects.
Public class | PluginMap | Map of repository plugins.
Public class | PluginSkeleton | Base implementation of IPlugin
Public class | RemoteLoggingServerPlugin | Plugin that listens for events from the RemotingAppender
Interfaces
 | Interface | Description
Public interface | IPlugin | Interface implemented by logger repository plugins.
Public interface | IPluginFactory | Interface used to create plugins.

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IPlugin Interface

IPlugin Interface Apache log4net™ SDK Documentation
Interface implemented by logger repository plugins.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPlugin
public interface IPlugin
Public Interface IPlugin
Public Interface IPlugin
public interface class IPlugin
public interface class IPlugin
Remarks

            Plugins define additional behavior that can be associated
            with a ILoggerRepository.
            The PluginMap held by the PluginMap
            property is used to store the plugins for a repository.

            The log4net.Config.PluginAttribute can be used to
            attach plugins to repositories created using configuration
            attributes.

See Also
IPlugin Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IPlugin Members

IPlugin Members Apache log4net™ SDK Documentation
The IPlugin type exposes the following members.
Methods
 | Name | Description
Public method | Attach | Attaches the plugin to the specified ILoggerRepository.
Public method | Shutdown | Is called when the plugin is to shutdown.
Back to Top
Properties
 | Name | Description
Public property | Name | Gets the name of the plugin.
Back to Top
See Also
IPlugin Interface
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IPlugin Methods

IPlugin Methods Apache log4net™ SDK Documentation
The IPlugin type exposes the following members.
Methods
 | Name | Description
Public method | Attach | Attaches the plugin to the specified ILoggerRepository.
Public method | Shutdown | Is called when the plugin is to shutdown.
Back to Top
See Also
IPlugin Interface
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IPlugin.Attach Method

IPlugin Attach Method Apache log4net™ SDK Documentation
Attaches the plugin to the specified ILoggerRepository.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Attach(
    ILoggerRepository repository
)
void Attach(
    ILoggerRepository repository
)
Sub Attach (
    repository As ILoggerRepository
)
Sub Attach (
    repository As ILoggerRepository
)
void Attach(
    ILoggerRepository^ repository
)
void Attach(
    ILoggerRepository^ repository
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The ILoggerRepository that this plugin should be attached to.
Remarks

            A plugin may only be attached to a single repository.

            This method is called when the plugin is attached to the repository.

See Also
IPlugin Interface
IPlugin Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IPlugin.Shutdown Method

IPlugin Shutdown Method Apache log4net™ SDK Documentation
Is called when the plugin is to shutdown.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Shutdown()
void Shutdown()
Sub Shutdown
Sub Shutdown
void Shutdown()
void Shutdown()
Remarks

            This method is called to notify the plugin that
            it should stop operating and should detach from
            the repository.

See Also
IPlugin Interface
IPlugin Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IPlugin Properties

IPlugin Properties Apache log4net™ SDK Documentation
The IPlugin type exposes the following members.
Properties
 | Name | Description
Public property | Name | Gets the name of the plugin.
Back to Top
See Also
IPlugin Interface
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IPlugin.Name Property

IPlugin Name Property Apache log4net™ SDK Documentation
Gets the name of the plugin.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Name { get; }
string Name { get; }
ReadOnly Property Name As String
    Get
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
property String^ Name {
    String^ get ();
}
Property Value
Type:   Online String

            The name of the plugin.

Remarks

            Plugins are stored in the PluginMap
            keyed by name. Each plugin instance attached to a
            repository must be a unique name.

See Also
IPlugin Interface
IPlugin Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IPluginFactory Interface

IPluginFactory Interface Apache log4net™ SDK Documentation
Interface used to create plugins.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPluginFactory
public interface IPluginFactory
Public Interface IPluginFactory
Public Interface IPluginFactory
public interface class IPluginFactory
public interface class IPluginFactory
Remarks

            Interface used to create  a plugin.

See Also
IPluginFactory Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IPluginFactory Members

IPluginFactory Members Apache log4net™ SDK Documentation
The IPluginFactory type exposes the following members.
Methods
 | Name | Description
Public method | CreatePlugin | Creates the plugin object.
Back to Top
See Also
IPluginFactory Interface
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IPluginFactory Methods

IPluginFactory Methods Apache log4net™ SDK Documentation
The IPluginFactory type exposes the following members.
Methods
 | Name | Description
Public method | CreatePlugin | Creates the plugin object.
Back to Top
See Also
IPluginFactory Interface
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IPluginFactory.CreatePlugin Method

IPluginFactory CreatePlugin Method Apache log4net™ SDK Documentation
Creates the plugin object.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IPlugin CreatePlugin()
IPlugin CreatePlugin()
Function CreatePlugin As IPlugin
Function CreatePlugin As IPlugin
IPlugin^ CreatePlugin()
IPlugin^ CreatePlugin()
Return Value
Type: IPlugin
the new plugin instance
Remarks

            Create and return a new plugin instance.

See Also
IPluginFactory Interface
IPluginFactory Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection Class

PluginCollection Class Apache log4net™ SDK Documentation
A strongly-typed collection of IPlugin objects.
Inheritance Hierarchy
Online System Object
log4net.Plugin PluginCollection

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PluginCollection : IList,
    ICollection, IEnumerable, ICloneable
public class PluginCollection : IList,
    ICollection, IEnumerable, ICloneable
Public Class PluginCollection
    Implements IList, ICollection, IEnumerable, ICloneable
Public Class PluginCollection
    Implements IList, ICollection, IEnumerable, ICloneable
public ref class PluginCollection : IList,
    ICollection, IEnumerable, ICloneable
public ref class PluginCollection : IList,
    ICollection, IEnumerable, ICloneable
See Also
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection Members

PluginCollection Members Apache log4net™ SDK Documentation
The PluginCollection type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds a IPlugin to the end of the PluginCollection.
Public method | AddRange(ICollection) | Adds the elements of a IPlugin collection to the current PluginCollection.
Public method | AddRange( IPlugin ) | Adds the elements of a IPlugin array to the current PluginCollection.
Public method | AddRange(PluginCollection) | Adds the elements of another PluginCollection to the current PluginCollection.
Public method | Clear | Removes all elements from the PluginCollection.
Public method | Clone | Creates a shallow copy of the PluginCollection.
Public method | Contains | Determines whether a given IPlugin is in the PluginCollection.
Public method | CopyTo( IPlugin ) | Copies the entire PluginCollection to a one-dimensional IPlugin array.
Public method | CopyTo( IPlugin , Int32) | Copies the entire PluginCollection to a one-dimensional IPlugin array, starting at the specified index of the target array.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | Returns an enumerator that can iterate through the PluginCollection.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a IPlugin in the PluginCollection.
Public method | Insert | Inserts an element into the PluginCollection at the specified index.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ReadOnly | Creates a read-only wrapper for a PluginCollection instance.
Public method | Remove | Removes the first occurrence of a specific IPlugin from the PluginCollection.
Public method | RemoveAt | Removes the element at the specified index of the PluginCollection.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements.
Back to Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements the PluginCollection can contain.
Public property | Count | Gets the number of elements actually contained in the PluginCollection.
Public property | IsFixedSize | Gets a value indicating whether the collection has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public property | Item | Gets or sets the IPlugin at the specified index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Back to Top
See Also
PluginCollection Class
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection Methods

PluginCollection Methods Apache log4net™ SDK Documentation
The PluginCollection type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds a IPlugin to the end of the PluginCollection.
Public method | AddRange(ICollection) | Adds the elements of a IPlugin collection to the current PluginCollection.
Public method | AddRange( IPlugin ) | Adds the elements of a IPlugin array to the current PluginCollection.
Public method | AddRange(PluginCollection) | Adds the elements of another PluginCollection to the current PluginCollection.
Public method | Clear | Removes all elements from the PluginCollection.
Public method | Clone | Creates a shallow copy of the PluginCollection.
Public method | Contains | Determines whether a given IPlugin is in the PluginCollection.
Public method | CopyTo( IPlugin ) | Copies the entire PluginCollection to a one-dimensional IPlugin array.
Public method | CopyTo( IPlugin , Int32) | Copies the entire PluginCollection to a one-dimensional IPlugin array, starting at the specified index of the target array.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | Returns an enumerator that can iterate through the PluginCollection.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a IPlugin in the PluginCollection.
Public method | Insert | Inserts an element into the PluginCollection at the specified index.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ReadOnly | Creates a read-only wrapper for a PluginCollection instance.
Public method | Remove | Removes the first occurrence of a specific IPlugin from the PluginCollection.
Public method | RemoveAt | Removes the element at the specified index of the PluginCollection.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements.
Back to Top
See Also
PluginCollection Class
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.Add Method

PluginCollection Add Method Apache log4net™ SDK Documentation
Adds a IPlugin to the end of the PluginCollection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Add(
    IPlugin item
)
public virtual int Add(
    IPlugin item
)
Public Overridable Function Add (
    item As IPlugin
) As Integer
Public Overridable Function Add (
    item As IPlugin
) As Integer
public:
virtual int Add(
    IPlugin^ item
)
public:
virtual int Add(
    IPlugin^ item
)
Parameters
item
Type: log4net.Plugin IPlugin
The IPlugin to be added to the end of the PluginCollection.
Return Value
Type:   Online Int32
The index at which the value has been added.
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.AddRange Method

PluginCollection AddRange Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | AddRange(ICollection) | Adds the elements of a IPlugin collection to the current PluginCollection.
Public method | AddRange( IPlugin ) | Adds the elements of a IPlugin array to the current PluginCollection.
Public method | AddRange(PluginCollection) | Adds the elements of another PluginCollection to the current PluginCollection.
Back to Top
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.AddRange Method (ICollection)

PluginCollection AddRange Method (ICollection) Apache log4net™ SDK Documentation
Adds the elements of a IPlugin collection to the current PluginCollection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int AddRange(
    ICollection col
)
public virtual int AddRange(
    ICollection col
)
Public Overridable Function AddRange (
    col As ICollection
) As Integer
Public Overridable Function AddRange (
    col As ICollection
) As Integer
public:
virtual int AddRange(
    ICollection^ col
)
public:
virtual int AddRange(
    ICollection^ col
)
Parameters
col
Type:   Online System.Collections ICollection
The IPlugin collection whose elements should be added to the end of the PluginCollection.
Return Value
Type:   Online Int32
The new Count of the PluginCollection.
See Also
PluginCollection Class
PluginCollection Members
AddRange Overload
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.AddRange Method (IPlugin[])

PluginCollection AddRange Method ( IPlugin ) Apache log4net™ SDK Documentation
Adds the elements of a IPlugin array to the current PluginCollection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int AddRange(
    IPlugin[] x
)
public virtual int AddRange(
    IPlugin[] x
)
Public Overridable Function AddRange (
    x As IPlugin()
) As Integer
Public Overridable Function AddRange (
    x As IPlugin()
) As Integer
public:
virtual int AddRange(
    array<IPlugin^>^ x
)
public:
virtual int AddRange(
    array<IPlugin^>^ x
)
Parameters
x
Type:  log4net.Plugin IPlugin
The IPlugin array whose elements should be added to the end of the PluginCollection.
Return Value
Type:   Online Int32
The new Count of the PluginCollection.
See Also
PluginCollection Class
PluginCollection Members
AddRange Overload
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.AddRange Method (PluginCollection)

PluginCollection AddRange Method (PluginCollection) Apache log4net™ SDK Documentation
Adds the elements of another PluginCollection to the current PluginCollection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int AddRange(
    PluginCollection x
)
public virtual int AddRange(
    PluginCollection x
)
Public Overridable Function AddRange (
    x As PluginCollection
) As Integer
Public Overridable Function AddRange (
    x As PluginCollection
) As Integer
public:
virtual int AddRange(
    PluginCollection^ x
)
public:
virtual int AddRange(
    PluginCollection^ x
)
Parameters
x
Type: log4net.Plugin PluginCollection
The PluginCollection whose elements should be added to the end of the current PluginCollection.
Return Value
Type:   Online Int32
The new Count of the PluginCollection.
See Also
PluginCollection Class
PluginCollection Members
AddRange Overload
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.Clear Method

PluginCollection Clear Method Apache log4net™ SDK Documentation
Removes all elements from the PluginCollection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Clear()
public virtual void Clear()
Public Overridable Sub Clear
Public Overridable Sub Clear
public:
virtual void Clear()
public:
virtual void Clear()
Implements
  Online IList Clear
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.Clone Method

PluginCollection Clone Method Apache log4net™ SDK Documentation
Creates a shallow copy of the PluginCollection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Clone()
public virtual Object Clone()
Public Overridable Function Clone As Object
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
public:
virtual Object^ Clone()
Return Value
Type:   Online Object
A new PluginCollection with a shallow copy of the collection data.
Implements
  Online ICloneable Clone
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.Contains Method

PluginCollection Contains Method Apache log4net™ SDK Documentation
Determines whether a given IPlugin is in the PluginCollection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Contains(
    IPlugin item
)
public virtual bool Contains(
    IPlugin item
)
Public Overridable Function Contains (
    item As IPlugin
) As Boolean
Public Overridable Function Contains (
    item As IPlugin
) As Boolean
public:
virtual bool Contains(
    IPlugin^ item
)
public:
virtual bool Contains(
    IPlugin^ item
)
Parameters
item
Type: log4net.Plugin IPlugin
The IPlugin to check for.
Return Value
Type:   Online Boolean
true if item is found in the PluginCollection; otherwise, false.
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.CopyTo Method

PluginCollection CopyTo Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | CopyTo( IPlugin ) | Copies the entire PluginCollection to a one-dimensional IPlugin array.
Public method | CopyTo( IPlugin , Int32) | Copies the entire PluginCollection to a one-dimensional IPlugin array, starting at the specified index of the target array.
Back to Top
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.CopyTo Method (IPlugin[])

PluginCollection CopyTo Method ( IPlugin ) Apache log4net™ SDK Documentation
Copies the entire PluginCollection to a one-dimensional IPlugin array.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void CopyTo(
    IPlugin[] array
)
public virtual void CopyTo(
    IPlugin[] array
)
Public Overridable Sub CopyTo (
    array As IPlugin()
)
Public Overridable Sub CopyTo (
    array As IPlugin()
)
public:
virtual void CopyTo(
    array<IPlugin^>^ array
)
public:
virtual void CopyTo(
    array<IPlugin^>^ array
)
Parameters
array
Type:  log4net.Plugin IPlugin
The one-dimensional IPlugin array to copy to.
See Also
PluginCollection Class
PluginCollection Members
CopyTo Overload
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.CopyTo Method (IPlugin[], Int32)

PluginCollection CopyTo Method ( IPlugin , Int32) Apache log4net™ SDK Documentation
Copies the entire PluginCollection to a one-dimensional IPlugin array, starting at the specified index of the target array.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void CopyTo(
    IPlugin[] array,
    int start
)
public virtual void CopyTo(
    IPlugin[] array,
    int start
)
Public Overridable Sub CopyTo (
    array As IPlugin(),
    start As Integer
)
Public Overridable Sub CopyTo (
    array As IPlugin(),
    start As Integer
)
public:
virtual void CopyTo(
    array<IPlugin^>^ array,
    int start
)
public:
virtual void CopyTo(
    array<IPlugin^>^ array,
    int start
)
Parameters
array
Type:  log4net.Plugin IPlugin
The one-dimensional IPlugin array to copy to.
start
Type:   Online System Int32
The zero-based index in array at which copying begins.
See Also
PluginCollection Class
PluginCollection Members
CopyTo Overload
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.GetEnumerator Method

PluginCollection GetEnumerator Method Apache log4net™ SDK Documentation
Returns an enumerator that can iterate through the PluginCollection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IPluginCollectionEnumerator GetEnumerator()
public virtual IPluginCollectionEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IPluginCollectionEnumerator
Public Overridable Function GetEnumerator As IPluginCollectionEnumerator
public:
virtual IPluginCollectionEnumerator^ GetEnumerator()
public:
virtual IPluginCollectionEnumerator^ GetEnumerator()
Return Value
Type: IPluginCollectionEnumerator
An Enumerator for the entire PluginCollection.
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.IndexOf Method

PluginCollection IndexOf Method Apache log4net™ SDK Documentation
Returns the zero-based index of the first occurrence of a IPlugin in the PluginCollection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int IndexOf(
    IPlugin item
)
public virtual int IndexOf(
    IPlugin item
)
Public Overridable Function IndexOf (
    item As IPlugin
) As Integer
Public Overridable Function IndexOf (
    item As IPlugin
) As Integer
public:
virtual int IndexOf(
    IPlugin^ item
)
public:
virtual int IndexOf(
    IPlugin^ item
)
Parameters
item
Type: log4net.Plugin IPlugin
The IPlugin to locate in the PluginCollection.
Return Value
Type:   Online Int32

            The zero-based index of the first occurrence of item
            in the entire PluginCollection, if found; otherwise, -1.

See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.Insert Method

PluginCollection Insert Method Apache log4net™ SDK Documentation
Inserts an element into the PluginCollection at the specified index.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Insert(
    int index,
    IPlugin item
)
public virtual void Insert(
    int index,
    IPlugin item
)
Public Overridable Sub Insert (
    index As Integer,
    item As IPlugin
)
Public Overridable Sub Insert (
    index As Integer,
    item As IPlugin
)
public:
virtual void Insert(
    int index,
    IPlugin^ item
)
public:
virtual void Insert(
    int index,
    IPlugin^ item
)
Parameters
index
Type:   Online System Int32
The zero-based index at which item should be inserted.
item
Type: log4net.Plugin IPlugin
The IPlugin to insert.
Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.ReadOnly Method

PluginCollection ReadOnly Method Apache log4net™ SDK Documentation
Creates a read-only wrapper for a PluginCollection instance.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PluginCollection ReadOnly(
    PluginCollection list
)
public static PluginCollection ReadOnly(
    PluginCollection list
)
Public Shared Function ReadOnly (
    list As PluginCollection
) As PluginCollection
Public Shared Function ReadOnly (
    list As PluginCollection
) As PluginCollection
public:
static PluginCollection^ ReadOnly(
    PluginCollection^ list
)
public:
static PluginCollection^ ReadOnly(
    PluginCollection^ list
)
Parameters
list
Type: log4net.Plugin PluginCollection
list to create a readonly wrapper arround
Return Value
Type: PluginCollection

            A PluginCollection wrapper that is read-only.

See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.Remove Method

PluginCollection Remove Method Apache log4net™ SDK Documentation
Removes the first occurrence of a specific IPlugin from the PluginCollection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Remove(
    IPlugin item
)
public virtual void Remove(
    IPlugin item
)
Public Overridable Sub Remove (
    item As IPlugin
)
Public Overridable Sub Remove (
    item As IPlugin
)
public:
virtual void Remove(
    IPlugin^ item
)
public:
virtual void Remove(
    IPlugin^ item
)
Parameters
item
Type: log4net.Plugin IPlugin
The IPlugin to remove from the PluginCollection.
Exceptions
Exception | Condition
Online System ArgumentException | The specified IPlugin was not found in the PluginCollection.
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.RemoveAt Method

PluginCollection RemoveAt Method Apache log4net™ SDK Documentation
Removes the element at the specified index of the PluginCollection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void RemoveAt(
    int index
)
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)
Public Overridable Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
)
public:
virtual void RemoveAt(
    int index
)
Parameters
index
Type:   Online System Int32
The zero-based index of the element to remove.
Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.TrimToSize Method

PluginCollection TrimToSize Method Apache log4net™ SDK Documentation
Sets the capacity to the actual number of elements.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void TrimToSize()
public virtual void TrimToSize()
Public Overridable Sub TrimToSize
Public Overridable Sub TrimToSize
public:
virtual void TrimToSize()
public:
virtual void TrimToSize()
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection Properties

PluginCollection Properties Apache log4net™ SDK Documentation
The PluginCollection type exposes the following members.
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements the PluginCollection can contain.
Public property | Count | Gets the number of elements actually contained in the PluginCollection.
Public property | IsFixedSize | Gets a value indicating whether the collection has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public property | Item | Gets or sets the IPlugin at the specified index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Back to Top
See Also
PluginCollection Class
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.Capacity Property

PluginCollection Capacity Property Apache log4net™ SDK Documentation
Gets or sets the number of elements the PluginCollection can contain.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Capacity { get; set; }
public virtual int Capacity { get; set; }
Public Overridable Property Capacity As Integer
    Get
    Set
Public Overridable Property Capacity As Integer
    Get
    Set
public:
virtual property int Capacity {
    int get ();
    void set (int value);
}
public:
virtual property int Capacity {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32

            The number of elements the PluginCollection can contain.

See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.Count Property

PluginCollection Count Property Apache log4net™ SDK Documentation
Gets the number of elements actually contained in the PluginCollection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Count { get; }
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
public:
virtual property int Count {
    int get ();
}
Property Value
Type:   Online Int32
Implements
  Online ICollection Count
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.IsFixedSize Property

PluginCollection IsFixedSize Property Apache log4net™ SDK Documentation
Gets a value indicating whether the collection has a fixed size.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsFixedSize { get; }
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}
public:
virtual property bool IsFixedSize {
    bool get ();
}
Property Value
Type:   Online Boolean
true if the collection has a fixed size; otherwise, false. The default is false.
Implements
  Online IList IsFixedSize
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.IsReadOnly Property

PluginCollection IsReadOnly Property Apache log4net™ SDK Documentation
Gets a value indicating whether the IList is read-only.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsReadOnly { get; }
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}
public:
virtual property bool IsReadOnly {
    bool get ();
}
Property Value
Type:   Online Boolean
true if the collection is read-only; otherwise, false. The default is false.
Implements
  Online IList IsReadOnly
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.IsSynchronized Property

PluginCollection IsSynchronized Property Apache log4net™ SDK Documentation
Gets a value indicating whether access to the collection is synchronized (thread-safe).

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsSynchronized { get; }
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}
public:
virtual property bool IsSynchronized {
    bool get ();
}
Return Value
Type:   Online Boolean
true if access to the ICollection is synchronized (thread-safe); otherwise, false.
Implements
  Online ICollection IsSynchronized
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.Item Property

PluginCollection Item Property Apache log4net™ SDK Documentation
Gets or sets the IPlugin at the specified index.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IPlugin this[
    int index
] { get; set; }
public virtual IPlugin this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As IPlugin
    Get
    Set
Public Overridable Default Property Item (
    index As Integer
) As IPlugin
    Get
    Set
public:
virtual property IPlugin^ default[int index] {
    IPlugin^ get (int index);
    void set (int index, IPlugin^ value);
}
public:
virtual property IPlugin^ default[int index] {
    IPlugin^ get (int index);
    void set (int index, IPlugin^ value);
}
Parameters
index
Type:   Online System Int32
The zero-based index of the element to get or set.
Property Value
Type: IPlugin

            The IPlugin at the specified index.

Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginCollection.SyncRoot Property

PluginCollection SyncRoot Property Apache log4net™ SDK Documentation
Gets an object that can be used to synchronize access to the collection.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object SyncRoot { get; }
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}
Property Value
Type:   Online Object

            An object that can be used to synchronize access to the collection.

Implements
  Online ICollection SyncRoot
See Also
PluginCollection Class
PluginCollection Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginMap Class

PluginMap Class Apache log4net™ SDK Documentation
Map of repository plugins.
Inheritance Hierarchy
Online System Object
log4net.Plugin PluginMap

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class PluginMap
public sealed class PluginMap
Public NotInheritable Class PluginMap
Public NotInheritable Class PluginMap
public ref class PluginMap sealed
public ref class PluginMap sealed
Remarks

            This class is a name keyed map of the plugins that are
            attached to a repository.

See Also
PluginMap Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginMap Members

PluginMap Members Apache log4net™ SDK Documentation
The PluginMap type exposes the following members.
Constructors
 | Name | Description
Public method | PluginMap | Constructor
Back to Top
Methods
 | Name | Description
Public method | Add | Adds a IPlugin to the map.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Removes a IPlugin from the map.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AllPlugins | Gets all possible plugins as a list of IPlugin objects.
Public property | Item | Gets a IPlugin by name.
Back to Top
See Also
PluginMap Class
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginMap Constructor

PluginMap Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PluginMap(
    ILoggerRepository repository
)
public PluginMap(
    ILoggerRepository repository
)
Public Sub New (
    repository As ILoggerRepository
)
Public Sub New (
    repository As ILoggerRepository
)
public:
PluginMap(
    ILoggerRepository^ repository
)
public:
PluginMap(
    ILoggerRepository^ repository
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The repository that the plugins should be attached to.
Remarks

            Initialize a new instance of the PluginMap class with a
            repository that the plugins should be attached to.

See Also
PluginMap Class
PluginMap Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginMap Methods

PluginMap Methods Apache log4net™ SDK Documentation
The PluginMap type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds a IPlugin to the map.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Removes a IPlugin from the map.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PluginMap Class
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginMap.Add Method

PluginMap Add Method Apache log4net™ SDK Documentation
Adds a IPlugin to the map.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    IPlugin plugin
)
public void Add(
    IPlugin plugin
)
Public Sub Add (
    plugin As IPlugin
)
Public Sub Add (
    plugin As IPlugin
)
public:
void Add(
    IPlugin^ plugin
)
public:
void Add(
    IPlugin^ plugin
)
Parameters
plugin
Type: log4net.Plugin IPlugin
The IPlugin to add to the map.
Remarks

            The IPlugin will be attached to the repository when added.

            If there already exists a plugin with the same name
            attached to the repository then the old plugin will
            be Shutdown  and replaced with
            the new plugin.

See Also
PluginMap Class
PluginMap Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginMap.Remove Method

PluginMap Remove Method Apache log4net™ SDK Documentation
Removes a IPlugin from the map.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Remove(
    IPlugin plugin
)
public void Remove(
    IPlugin plugin
)
Public Sub Remove (
    plugin As IPlugin
)
Public Sub Remove (
    plugin As IPlugin
)
public:
void Remove(
    IPlugin^ plugin
)
public:
void Remove(
    IPlugin^ plugin
)
Parameters
plugin
Type: log4net.Plugin IPlugin
The IPlugin to remove from the map.
Remarks

            Remove a specific plugin from this map.

See Also
PluginMap Class
PluginMap Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginMap Properties

PluginMap Properties Apache log4net™ SDK Documentation
The PluginMap type exposes the following members.
Properties
 | Name | Description
Public property | AllPlugins | Gets all possible plugins as a list of IPlugin objects.
Public property | Item | Gets a IPlugin by name.
Back to Top
See Also
PluginMap Class
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginMap.AllPlugins Property

PluginMap AllPlugins Property Apache log4net™ SDK Documentation
Gets all possible plugins as a list of IPlugin objects.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PluginCollection AllPlugins { get; }
public PluginCollection AllPlugins { get; }
Public ReadOnly Property AllPlugins As PluginCollection
    Get
Public ReadOnly Property AllPlugins As PluginCollection
    Get
public:
property PluginCollection^ AllPlugins {
    PluginCollection^ get ();
}
public:
property PluginCollection^ AllPlugins {
    PluginCollection^ get ();
}
Property Value
Type: PluginCollection
All possible plugins as a list of IPlugin objects.
Remarks

            Get a collection of all the plugins defined in this map.

See Also
PluginMap Class
PluginMap Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginMap.Item Property

PluginMap Item Property Apache log4net™ SDK Documentation
Gets a IPlugin by name.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPlugin this[
    string name
] { get; }
public IPlugin this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As IPlugin
    Get
Public ReadOnly Default Property Item (
    name As String
) As IPlugin
    Get
public:
property IPlugin^ default[String^ name] {
    IPlugin^ get (String^ name);
}
public:
property IPlugin^ default[String^ name] {
    IPlugin^ get (String^ name);
}
Parameters
name
Type:   Online System String
The name of the IPlugin to lookup.
Return Value
Type: IPlugin

            The IPlugin from the map with the name specified, or
            null if no plugin is found.

Remarks

            Lookup a plugin by name. If the plugin is not found null
            will be returned.

See Also
PluginMap Class
PluginMap Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginSkeleton Class

PluginSkeleton Class Apache log4net™ SDK Documentation
Base implementation of IPlugin
Inheritance Hierarchy
Online System Object
log4net.Plugin PluginSkeleton
log4net.Plugin RemoteLoggingServerPlugin

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PluginSkeleton : IPlugin
public abstract class PluginSkeleton : IPlugin
Public MustInherit Class PluginSkeleton
    Implements IPlugin
Public MustInherit Class PluginSkeleton
    Implements IPlugin
public ref class PluginSkeleton abstract : IPlugin
public ref class PluginSkeleton abstract : IPlugin
Remarks

            Default abstract implementation of the IPlugin
            interface. This base class can be used by implementors
            of the IPlugin interface.

See Also
PluginSkeleton Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginSkeleton Members

PluginSkeleton Members Apache log4net™ SDK Documentation
The PluginSkeleton type exposes the following members.
Constructors
 | Name | Description
Protected method | PluginSkeleton | Constructor
Back to Top
Methods
 | Name | Description
Public method | Attach | Attaches this plugin to a ILoggerRepository.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Shutdown | Is called when the plugin is to shutdown.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Protected property | LoggerRepository | The repository for this plugin
Public property | Name | Gets or sets the name of the plugin.
Back to Top
See Also
PluginSkeleton Class
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginSkeleton Constructor

PluginSkeleton Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PluginSkeleton(
    string name
)
protected PluginSkeleton(
    string name
)
Protected Sub New (
    name As String
)
Protected Sub New (
    name As String
)
protected:
PluginSkeleton(
    String^ name
)
protected:
PluginSkeleton(
    String^ name
)
Parameters
name
Type:   Online System String
the name of the plugin
Remarks

            Initializes a new Plugin with the specified name.

See Also
PluginSkeleton Class
PluginSkeleton Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginSkeleton Methods

PluginSkeleton Methods Apache log4net™ SDK Documentation
The PluginSkeleton type exposes the following members.
Methods
 | Name | Description
Public method | Attach | Attaches this plugin to a ILoggerRepository.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Shutdown | Is called when the plugin is to shutdown.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PluginSkeleton Class
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginSkeleton.Attach Method

PluginSkeleton Attach Method Apache log4net™ SDK Documentation
Attaches this plugin to a ILoggerRepository.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Attach(
    ILoggerRepository repository
)
public virtual void Attach(
    ILoggerRepository repository
)
Public Overridable Sub Attach (
    repository As ILoggerRepository
)
Public Overridable Sub Attach (
    repository As ILoggerRepository
)
public:
virtual void Attach(
    ILoggerRepository^ repository
)
public:
virtual void Attach(
    ILoggerRepository^ repository
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The ILoggerRepository that this plugin should be attached to.
Implements
IPlugin Attach(ILoggerRepository)
Remarks

            A plugin may only be attached to a single repository.

            This method is called when the plugin is attached to the repository.

See Also
PluginSkeleton Class
PluginSkeleton Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginSkeleton.Shutdown Method

PluginSkeleton Shutdown Method Apache log4net™ SDK Documentation
Is called when the plugin is to shutdown.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Shutdown()
public virtual void Shutdown()
Public Overridable Sub Shutdown
Public Overridable Sub Shutdown
public:
virtual void Shutdown()
public:
virtual void Shutdown()
Implements
IPlugin Shutdown
Remarks

            This method is called to notify the plugin that
            it should stop operating and should detach from
            the repository.

See Also
PluginSkeleton Class
PluginSkeleton Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginSkeleton Properties

PluginSkeleton Properties Apache log4net™ SDK Documentation
The PluginSkeleton type exposes the following members.
Properties
 | Name | Description
Protected property | LoggerRepository | The repository for this plugin
Public property | Name | Gets or sets the name of the plugin.
Back to Top
See Also
PluginSkeleton Class
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginSkeleton.LoggerRepository Property

PluginSkeleton LoggerRepository Property Apache log4net™ SDK Documentation
The repository for this plugin

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual ILoggerRepository LoggerRepository { get; set; }
protected virtual ILoggerRepository LoggerRepository { get; set; }
Protected Overridable Property LoggerRepository As ILoggerRepository
    Get
    Set
Protected Overridable Property LoggerRepository As ILoggerRepository
    Get
    Set
protected:
virtual property ILoggerRepository^ LoggerRepository {
    ILoggerRepository^ get ();
    void set (ILoggerRepository^ value);
}
protected:
virtual property ILoggerRepository^ LoggerRepository {
    ILoggerRepository^ get ();
    void set (ILoggerRepository^ value);
}
Property Value
Type: ILoggerRepository

            The ILoggerRepository that this plugin is attached to.

Remarks

            Gets or sets the ILoggerRepository that this plugin is
            attached to.

See Also
PluginSkeleton Class
PluginSkeleton Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PluginSkeleton.Name Property

PluginSkeleton Name Property Apache log4net™ SDK Documentation
Gets or sets the name of the plugin.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Name { get; set; }
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The name of the plugin.

Implements
IPlugin Name
Remarks

            Plugins are stored in the PluginMap
            keyed by name. Each plugin instance attached to a
            repository must be a unique name.

            The name of the plugin must not change one the
            plugin has been attached to a repository.

See Also
PluginSkeleton Class
PluginSkeleton Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteLoggingServerPlugin Class

RemoteLoggingServerPlugin Class Apache log4net™ SDK Documentation
Plugin that listens for events from the RemotingAppender
Inheritance Hierarchy
Online System Object
log4net.Plugin PluginSkeleton
log4net.Plugin RemoteLoggingServerPlugin

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RemoteLoggingServerPlugin : PluginSkeleton
public class RemoteLoggingServerPlugin : PluginSkeleton
Public Class RemoteLoggingServerPlugin
    Inherits PluginSkeleton
Public Class RemoteLoggingServerPlugin
    Inherits PluginSkeleton
public ref class RemoteLoggingServerPlugin : public PluginSkeleton
public ref class RemoteLoggingServerPlugin : public PluginSkeleton
Remarks

            This plugin publishes an instance of RemotingAppender IRemoteLoggingSink
            on a specified SinkUri. This listens for logging events delivered from
            a remote RemotingAppender.

            When an event is received it is relogged within the attached repository
            as if it had been raised locally.

See Also
RemoteLoggingServerPlugin Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteLoggingServerPlugin Members

RemoteLoggingServerPlugin Members Apache log4net™ SDK Documentation
The RemoteLoggingServerPlugin type exposes the following members.
Constructors
 | Name | Description
Public method | RemoteLoggingServerPlugin | Default constructor
Public method | RemoteLoggingServerPlugin(String) | Construct with sink Uri.
Back to Top
Methods
 | Name | Description
Public method | Attach | Attaches this plugin to a ILoggerRepository. (Overrides PluginSkeleton Attach(ILoggerRepository).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Shutdown | Is called when the plugin is to shutdown. (Overrides PluginSkeleton Shutdown .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Protected property | LoggerRepository | The repository for this plugin (Inherited from PluginSkeleton.)
Public property | Name | Gets or sets the name of the plugin. (Inherited from PluginSkeleton.)
Public property | SinkUri | Gets or sets the URI of this sink.
Back to Top
See Also
RemoteLoggingServerPlugin Class
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteLoggingServerPlugin Constructor

RemoteLoggingServerPlugin Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | RemoteLoggingServerPlugin | Default constructor
Public method | RemoteLoggingServerPlugin(String) | Construct with sink Uri.
Back to Top
See Also
RemoteLoggingServerPlugin Class
RemoteLoggingServerPlugin Members
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteLoggingServerPlugin Constructor

RemoteLoggingServerPlugin Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RemoteLoggingServerPlugin()
public RemoteLoggingServerPlugin()
Public Sub New
Public Sub New
public:
RemoteLoggingServerPlugin()
public:
RemoteLoggingServerPlugin()
Remarks

            Initializes a new instance of the RemoteLoggingServerPlugin class.

            The SinkUri property must be set.

See Also
RemoteLoggingServerPlugin Class
RemoteLoggingServerPlugin Members
RemoteLoggingServerPlugin Overload
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteLoggingServerPlugin Constructor (String)

RemoteLoggingServerPlugin Constructor (String) Apache log4net™ SDK Documentation
Construct with sink Uri.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RemoteLoggingServerPlugin(
    string sinkUri
)
public RemoteLoggingServerPlugin(
    string sinkUri
)
Public Sub New (
    sinkUri As String
)
Public Sub New (
    sinkUri As String
)
public:
RemoteLoggingServerPlugin(
    String^ sinkUri
)
public:
RemoteLoggingServerPlugin(
    String^ sinkUri
)
Parameters
sinkUri
Type:   Online System String
The name to publish the sink under in the remoting infrastructure.
            See SinkUri for more details.
Remarks

            Initializes a new instance of the RemoteLoggingServerPlugin class
            with specified name.

See Also
RemoteLoggingServerPlugin Class
RemoteLoggingServerPlugin Members
RemoteLoggingServerPlugin Overload
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteLoggingServerPlugin Methods

RemoteLoggingServerPlugin Methods Apache log4net™ SDK Documentation
The RemoteLoggingServerPlugin type exposes the following members.
Methods
 | Name | Description
Public method | Attach | Attaches this plugin to a ILoggerRepository. (Overrides PluginSkeleton Attach(ILoggerRepository).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Shutdown | Is called when the plugin is to shutdown. (Overrides PluginSkeleton Shutdown .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RemoteLoggingServerPlugin Class
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteLoggingServerPlugin.Attach Method

RemoteLoggingServerPlugin Attach Method Apache log4net™ SDK Documentation
Attaches this plugin to a ILoggerRepository.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Attach(
    ILoggerRepository repository
)
public override void Attach(
    ILoggerRepository repository
)
Public Overrides Sub Attach (
    repository As ILoggerRepository
)
Public Overrides Sub Attach (
    repository As ILoggerRepository
)
public:
virtual void Attach(
    ILoggerRepository^ repository
) override
public:
virtual void Attach(
    ILoggerRepository^ repository
) override
Parameters
repository
Type: log4net.Repository ILoggerRepository
The ILoggerRepository that this plugin should be attached to.
Implements
IPlugin Attach(ILoggerRepository)
Remarks

            A plugin may only be attached to a single repository.

            This method is called when the plugin is attached to the repository.

See Also
RemoteLoggingServerPlugin Class
RemoteLoggingServerPlugin Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteLoggingServerPlugin.Shutdown Method

RemoteLoggingServerPlugin Shutdown Method Apache log4net™ SDK Documentation
Is called when the plugin is to shutdown.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Shutdown()
public override void Shutdown()
Public Overrides Sub Shutdown
Public Overrides Sub Shutdown
public:
virtual void Shutdown() override
public:
virtual void Shutdown() override
Implements
IPlugin Shutdown
Remarks

            When the plugin is shutdown the remote logging
            sink is disconnected.

See Also
RemoteLoggingServerPlugin Class
RemoteLoggingServerPlugin Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteLoggingServerPlugin Properties

RemoteLoggingServerPlugin Properties Apache log4net™ SDK Documentation
The RemoteLoggingServerPlugin type exposes the following members.
Properties
 | Name | Description
Protected property | LoggerRepository | The repository for this plugin (Inherited from PluginSkeleton.)
Public property | Name | Gets or sets the name of the plugin. (Inherited from PluginSkeleton.)
Public property | SinkUri | Gets or sets the URI of this sink.
Back to Top
See Also
RemoteLoggingServerPlugin Class
log4net.Plugin Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RemoteLoggingServerPlugin.SinkUri Property

RemoteLoggingServerPlugin SinkUri Property Apache log4net™ SDK Documentation
Gets or sets the URI of this sink.

Namespace: log4net.Plugin
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string SinkUri { get; set; }
public virtual string SinkUri { get; set; }
Public Overridable Property SinkUri As String
    Get
    Set
Public Overridable Property SinkUri As String
    Get
    Set
public:
virtual property String^ SinkUri {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ SinkUri {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The URI of this sink.

Remarks

            This is the name under which the object is marshaled.
            Marshal(MarshalByRefObject, String, Type)
See Also
RemoteLoggingServerPlugin Class
RemoteLoggingServerPlugin Members
log4net.Plugin Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.Repository Namespace

log4net.Repository Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | ConfigurationChangedEventArgs |
Public class | LoggerRepositorySkeleton | Base implementation of ILoggerRepository
Interfaces
 | Interface | Description
Public interface | IBasicRepositoryConfigurator | Basic Configurator interface for repositories
Public interface | ILoggerRepository | Interface implemented by logger repositories.
Public interface | IXmlRepositoryConfigurator | Configure repository using XML
Delegates
 | Delegate | Description
Public delegate | LoggerRepositoryConfigurationChangedEventHandler | Delegate used to handle event notifications for logger repository configuration changes.
Public delegate | LoggerRepositoryConfigurationResetEventHandler | Delegate used to handle logger repository configuration reset event notifications
Public delegate | LoggerRepositoryShutdownEventHandler | Delegate used to handle logger repository shutdown event notifications

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfigurationChangedEventArgs Class

ConfigurationChangedEventArgs Class Apache log4net™ SDK Documentation

[Missing <summary> documentation for "T:log4net.Repository.ConfigurationChangedEventArgs"]

Inheritance Hierarchy
Online System Object
Online System EventArgs
log4net.Repository ConfigurationChangedEventArgs

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ConfigurationChangedEventArgs : EventArgs
public class ConfigurationChangedEventArgs : EventArgs
Public Class ConfigurationChangedEventArgs
    Inherits EventArgs
Public Class ConfigurationChangedEventArgs
    Inherits EventArgs
public ref class ConfigurationChangedEventArgs : public EventArgs
public ref class ConfigurationChangedEventArgs : public EventArgs
See Also
ConfigurationChangedEventArgs Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfigurationChangedEventArgs Members

ConfigurationChangedEventArgs Members Apache log4net™ SDK Documentation
The ConfigurationChangedEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | ConfigurationChangedEventArgs | Initializes a new instance of the ConfigurationChangedEventArgs class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ConfigurationMessages |
Back to Top
See Also
ConfigurationChangedEventArgs Class
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfigurationChangedEventArgs Constructor

ConfigurationChangedEventArgs Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the ConfigurationChangedEventArgs class

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigurationChangedEventArgs(
    ICollection configurationMessages
)
public ConfigurationChangedEventArgs(
    ICollection configurationMessages
)
Public Sub New (
    configurationMessages As ICollection
)
Public Sub New (
    configurationMessages As ICollection
)
public:
ConfigurationChangedEventArgs(
    ICollection^ configurationMessages
)
public:
ConfigurationChangedEventArgs(
    ICollection^ configurationMessages
)
Parameters
configurationMessages
Type:   Online System.Collections ICollection
[Missing <param name="configurationMessages"/> documentation for "M:log4net.Repository.ConfigurationChangedEventArgs.#ctor(System.Collections.ICollection)"]
See Also
ConfigurationChangedEventArgs Class
ConfigurationChangedEventArgs Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfigurationChangedEventArgs Methods

ConfigurationChangedEventArgs Methods Apache log4net™ SDK Documentation
The ConfigurationChangedEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ConfigurationChangedEventArgs Class
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfigurationChangedEventArgs Properties

ConfigurationChangedEventArgs Properties Apache log4net™ SDK Documentation
The ConfigurationChangedEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | ConfigurationMessages |
Back to Top
See Also
ConfigurationChangedEventArgs Class
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConfigurationChangedEventArgs.ConfigurationMessages Property

ConfigurationChangedEventArgs ConfigurationMessages Property Apache log4net™ SDK Documentation

[Missing <summary> documentation for "P:log4net.Repository.ConfigurationChangedEventArgs.ConfigurationMessages"]

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection ConfigurationMessages { get; }
public ICollection ConfigurationMessages { get; }
Public ReadOnly Property ConfigurationMessages As ICollection
    Get
Public ReadOnly Property ConfigurationMessages As ICollection
    Get
public:
property ICollection^ ConfigurationMessages {
    ICollection^ get ();
}
public:
property ICollection^ ConfigurationMessages {
    ICollection^ get ();
}
Property Value
Type:   Online ICollection
See Also
ConfigurationChangedEventArgs Class
ConfigurationChangedEventArgs Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IBasicRepositoryConfigurator Interface

IBasicRepositoryConfigurator Interface Apache log4net™ SDK Documentation
Basic Configurator interface for repositories

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IBasicRepositoryConfigurator
public interface IBasicRepositoryConfigurator
Public Interface IBasicRepositoryConfigurator
Public Interface IBasicRepositoryConfigurator
public interface class IBasicRepositoryConfigurator
public interface class IBasicRepositoryConfigurator
Remarks

            Interface used by basic configurator to configure a ILoggerRepository
            with a default IAppender.

            A ILoggerRepository should implement this interface to support
            configuration by the BasicConfigurator.

See Also
IBasicRepositoryConfigurator Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IBasicRepositoryConfigurator Members

IBasicRepositoryConfigurator Members Apache log4net™ SDK Documentation
Methods
 | Name | Description
Public method | Configure(IAppender) | Initialize the repository using the specified appender
Public method | Configure( IAppender ) | Initialize the repository using the specified appenders
Back to Top
See Also
IBasicRepositoryConfigurator Interface
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IBasicRepositoryConfigurator Methods

IBasicRepositoryConfigurator Methods Apache log4net™ SDK Documentation
Methods
 | Name | Description
Public method | Configure(IAppender) | Initialize the repository using the specified appender
Public method | Configure( IAppender ) | Initialize the repository using the specified appenders
Back to Top
See Also
IBasicRepositoryConfigurator Interface
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IBasicRepositoryConfigurator.Configure Method

IBasicRepositoryConfigurator Configure Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Configure(IAppender) | Initialize the repository using the specified appender
Public method | Configure( IAppender ) | Initialize the repository using the specified appenders
Back to Top
See Also
IBasicRepositoryConfigurator Interface
IBasicRepositoryConfigurator Members
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IBasicRepositoryConfigurator.Configure Method (IAppender)

IBasicRepositoryConfigurator Configure Method (IAppender) Apache log4net™ SDK Documentation
Initialize the repository using the specified appender

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Configure(
    IAppender appender
)
void Configure(
    IAppender appender
)
Sub Configure (
    appender As IAppender
)
Sub Configure (
    appender As IAppender
)
void Configure(
    IAppender^ appender
)
void Configure(
    IAppender^ appender
)
Parameters
appender
Type: log4net.Appender IAppender
the appender to use to log all logging events
Remarks

            Configure the repository to route all logging events to the
            specified appender.

See Also
IBasicRepositoryConfigurator Interface
IBasicRepositoryConfigurator Members
Configure Overload
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IBasicRepositoryConfigurator.Configure Method (IAppender[])

IBasicRepositoryConfigurator Configure Method ( IAppender ) Apache log4net™ SDK Documentation
Initialize the repository using the specified appenders

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Configure(
    params IAppender[] appenders
)
void Configure(
    params IAppender[] appenders
)
Sub Configure (
    ParamArray appenders As IAppender()
)
Sub Configure (
    ParamArray appenders As IAppender()
)
void Configure(
    ... array<IAppender^>^ appenders
)
void Configure(
    ... array<IAppender^>^ appenders
)
Parameters
appenders
Type:  log4net.Appender IAppender
the appenders to use to log all logging events
Remarks

            Configure the repository to route all logging events to the
            specified appenders.

See Also
IBasicRepositoryConfigurator Interface
IBasicRepositoryConfigurator Members
Configure Overload
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository Interface

ILoggerRepository Interface Apache log4net™ SDK Documentation
Interface implemented by logger repositories.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILoggerRepository
public interface ILoggerRepository
Public Interface ILoggerRepository
Public Interface ILoggerRepository
public interface class ILoggerRepository
public interface class ILoggerRepository
Remarks

            This interface is implemented by logger repositories. e.g.
            log4net.Repository.Hierarchy.

            This interface is used by the LogManager
            to obtain ILog interfaces.

See Also
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository Members

ILoggerRepository Members Apache log4net™ SDK Documentation
The ILoggerRepository type exposes the following members.
Methods
 | Name | Description
Public method | Exists | Check if the named logger exists in the repository. If so return its reference, otherwise returns null.
Public method | GetAppenders | Returns all the Appenders that are configured as an Array.
Public method | GetCurrentLoggers | Returns all the currently defined loggers as an Array.
Public method | GetLogger | Returns a named logger instance
Public method | Log | Log the LoggingEvent through this repository.
Public method | ResetConfiguration | Reset the repositories configuration to a default state
Public method | Shutdown | Shutdown the repository
Back to Top
Properties
 | Name | Description
Public property | ConfigurationMessages | Collection of internal messages captured during the most recent configuration process.
Public property | Configured | Flag indicates if this repository has been configured.
Public property | LevelMap | Get the level map for the Repository.
Public property | Name | The name of the repository
Public property | PluginMap | The plugin map for this repository.
Public property | Properties | Repository specific properties
Public property | RendererMap | RendererMap accesses the object renderer map for this repository.
Public property | Threshold | The threshold for all events in this repository
Back to Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event to notify that the repository has had its configuration changed.
Public event | ConfigurationReset | Event to notify that the repository has had its configuration reset.
Public event | ShutdownEvent | Event to notify that the repository has been shutdown.
Back to Top
See Also
ILoggerRepository Interface
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository Methods

ILoggerRepository Methods Apache log4net™ SDK Documentation
The ILoggerRepository type exposes the following members.
Methods
 | Name | Description
Public method | Exists | Check if the named logger exists in the repository. If so return its reference, otherwise returns null.
Public method | GetAppenders | Returns all the Appenders that are configured as an Array.
Public method | GetCurrentLoggers | Returns all the currently defined loggers as an Array.
Public method | GetLogger | Returns a named logger instance
Public method | Log | Log the LoggingEvent through this repository.
Public method | ResetConfiguration | Reset the repositories configuration to a default state
Public method | Shutdown | Shutdown the repository
Back to Top
See Also
ILoggerRepository Interface
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.Exists Method

ILoggerRepository Exists Method Apache log4net™ SDK Documentation
Check if the named logger exists in the repository. If so return its reference, otherwise returns null.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILogger Exists(
    string name
)
ILogger Exists(
    string name
)
Function Exists (
    name As String
) As ILogger
Function Exists (
    name As String
) As ILogger
ILogger^ Exists(
    String^ name
)
ILogger^ Exists(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the logger to lookup
Return Value
Type: ILogger
The Logger object with the name specified
Remarks

            If the names logger exists it is returned, otherwise
            null is returned.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.GetAppenders Method

ILoggerRepository GetAppenders Method Apache log4net™ SDK Documentation
Returns all the Appenders that are configured as an Array.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IAppender[] GetAppenders()
IAppender[] GetAppenders()
Function GetAppenders As IAppender()
Function GetAppenders As IAppender()
array<IAppender^>^ GetAppenders()
array<IAppender^>^ GetAppenders()
Return Value
Type:  IAppender
All the Appenders
Remarks

            Returns all the Appenders that are configured as an Array.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.GetCurrentLoggers Method

ILoggerRepository GetCurrentLoggers Method Apache log4net™ SDK Documentation
Returns all the currently defined loggers as an Array.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILogger[] GetCurrentLoggers()
ILogger[] GetCurrentLoggers()
Function GetCurrentLoggers As ILogger()
Function GetCurrentLoggers As ILogger()
array<ILogger^>^ GetCurrentLoggers()
array<ILogger^>^ GetCurrentLoggers()
Return Value
Type:  ILogger
All the defined loggers
Remarks

            Returns all the currently defined loggers as an Array.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.GetLogger Method

ILoggerRepository GetLogger Method Apache log4net™ SDK Documentation
Returns a named logger instance

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILogger GetLogger(
    string name
)
ILogger GetLogger(
    string name
)
Function GetLogger (
    name As String
) As ILogger
Function GetLogger (
    name As String
) As ILogger
ILogger^ GetLogger(
    String^ name
)
ILogger^ GetLogger(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the logger to retrieve
Return Value
Type: ILogger
The logger object with the name specified
Remarks

            Returns a named logger instance.

            If a logger of that name already exists, then it will be
            returned.  Otherwise, a new logger will be instantiated and
            then linked with its existing ancestors as well as children.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.Log Method

ILoggerRepository Log Method Apache log4net™ SDK Documentation
Log the LoggingEvent through this repository.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Log(
    LoggingEvent logEvent
)
void Log(
    LoggingEvent logEvent
)
Sub Log (
    logEvent As LoggingEvent
)
Sub Log (
    logEvent As LoggingEvent
)
void Log(
    LoggingEvent^ logEvent
)
void Log(
    LoggingEvent^ logEvent
)
Parameters
logEvent
Type: log4net.Core LoggingEvent
the event to log
Remarks

            This method should not normally be used to log.
            The ILog interface should be used
            for routine logging. This interface can be obtained
            using the GetLogger(string) method.

            The logEvent is delivered to the appropriate logger and
            that logger is then responsible for logging the event.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.ResetConfiguration Method

ILoggerRepository ResetConfiguration Method Apache log4net™ SDK Documentation
Reset the repositories configuration to a default state

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ResetConfiguration()
void ResetConfiguration()
Sub ResetConfiguration
Sub ResetConfiguration
void ResetConfiguration()
void ResetConfiguration()
Remarks

            Reset all values contained in this instance to their
            default state.

            Existing loggers are not removed. They are just reset.

            This method should be used sparingly and with care as it will
            block all logging until it is completed.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.Shutdown Method

ILoggerRepository Shutdown Method Apache log4net™ SDK Documentation
Shutdown the repository

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Shutdown()
void Shutdown()
Sub Shutdown
Sub Shutdown
void Shutdown()
void Shutdown()
Remarks

            Shutting down a repository will safely close and remove
            all appenders in all loggers including the root logger.

            Some appenders need to be closed before the
            application exists. Otherwise, pending logging events might be
            lost.

            The [M:Shutdown()] method is careful to close nested
            appenders before closing regular appenders. This is allows
            configurations where a regular appender is attached to a logger
            and again to a nested appender.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository Properties

ILoggerRepository Properties Apache log4net™ SDK Documentation
The ILoggerRepository type exposes the following members.
Properties
 | Name | Description
Public property | ConfigurationMessages | Collection of internal messages captured during the most recent configuration process.
Public property | Configured | Flag indicates if this repository has been configured.
Public property | LevelMap | Get the level map for the Repository.
Public property | Name | The name of the repository
Public property | PluginMap | The plugin map for this repository.
Public property | Properties | Repository specific properties
Public property | RendererMap | RendererMap accesses the object renderer map for this repository.
Public property | Threshold | The threshold for all events in this repository
Back to Top
See Also
ILoggerRepository Interface
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.ConfigurationMessages Property

ILoggerRepository ConfigurationMessages Property Apache log4net™ SDK Documentation
Collection of internal messages captured during the most recent configuration process.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICollection ConfigurationMessages { get; set; }
ICollection ConfigurationMessages { get; set; }
Property ConfigurationMessages As ICollection
    Get
    Set
Property ConfigurationMessages As ICollection
    Get
    Set
property ICollection^ ConfigurationMessages {
    ICollection^ get ();
    void set (ICollection^ value);
}
property ICollection^ ConfigurationMessages {
    ICollection^ get ();
    void set (ICollection^ value);
}
Property Value
Type:   Online ICollection
See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.Configured Property

ILoggerRepository Configured Property Apache log4net™ SDK Documentation
Flag indicates if this repository has been configured.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Configured { get; set; }
bool Configured { get; set; }
Property Configured As Boolean
    Get
    Set
Property Configured As Boolean
    Get
    Set
property bool Configured {
    bool get ();
    void set (bool value);
}
property bool Configured {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean

            Flag indicates if this repository has been configured.

Remarks

            Flag indicates if this repository has been configured.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.LevelMap Property

ILoggerRepository LevelMap Property Apache log4net™ SDK Documentation
Get the level map for the Repository.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
LevelMap LevelMap { get; }
LevelMap LevelMap { get; }
ReadOnly Property LevelMap As LevelMap
    Get
ReadOnly Property LevelMap As LevelMap
    Get
property LevelMap^ LevelMap {
    LevelMap^ get ();
}
property LevelMap^ LevelMap {
    LevelMap^ get ();
}
Property Value
Type: LevelMap
Remarks

            Get the level map for the Repository.

            The level map defines the mappings between
            level names and Level objects in
            this repository.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.Name Property

ILoggerRepository Name Property Apache log4net™ SDK Documentation
The name of the repository

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Name { get; set; }
string Name { get; set; }
Property Name As String
    Get
    Set
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The name of the repository

Remarks

            The name of the repository.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.PluginMap Property

ILoggerRepository PluginMap Property Apache log4net™ SDK Documentation
The plugin map for this repository.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
PluginMap PluginMap { get; }
PluginMap PluginMap { get; }
ReadOnly Property PluginMap As PluginMap
    Get
ReadOnly Property PluginMap As PluginMap
    Get
property PluginMap^ PluginMap {
    PluginMap^ get ();
}
property PluginMap^ PluginMap {
    PluginMap^ get ();
}
Property Value
Type: PluginMap

            The plugin map for this repository.

Remarks

            The plugin map holds the IPlugin instances
            that have been attached to this repository.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.Properties Property

ILoggerRepository Properties Property Apache log4net™ SDK Documentation
Repository specific properties

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
PropertiesDictionary Properties { get; }
PropertiesDictionary Properties { get; }
ReadOnly Property Properties As PropertiesDictionary
    Get
ReadOnly Property Properties As PropertiesDictionary
    Get
property PropertiesDictionary^ Properties {
    PropertiesDictionary^ get ();
}
property PropertiesDictionary^ Properties {
    PropertiesDictionary^ get ();
}
Property Value
Type: PropertiesDictionary

            Repository specific properties

Remarks

            These properties can be specified on a repository specific basis.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.RendererMap Property

ILoggerRepository RendererMap Property Apache log4net™ SDK Documentation
RendererMap accesses the object renderer map for this repository.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
RendererMap RendererMap { get; }
RendererMap RendererMap { get; }
ReadOnly Property RendererMap As RendererMap
    Get
ReadOnly Property RendererMap As RendererMap
    Get
property RendererMap^ RendererMap {
    RendererMap^ get ();
}
property RendererMap^ RendererMap {
    RendererMap^ get ();
}
Property Value
Type: RendererMap

            RendererMap accesses the object renderer map for this repository.

Remarks

            RendererMap accesses the object renderer map for this repository.

            The RendererMap holds a mapping between types and
            IObjectRenderer objects.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.Threshold Property

ILoggerRepository Threshold Property Apache log4net™ SDK Documentation
The threshold for all events in this repository

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Level Threshold { get; set; }
Level Threshold { get; set; }
Property Threshold As Level
    Get
    Set
Property Threshold As Level
    Get
    Set
property Level^ Threshold {
    Level^ get ();
    void set (Level^ value);
}
property Level^ Threshold {
    Level^ get ();
    void set (Level^ value);
}
Property Value
Type: Level

            The threshold for all events in this repository

Remarks

            The threshold for all events in this repository.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository Events

ILoggerRepository Events Apache log4net™ SDK Documentation
The ILoggerRepository type exposes the following members.
Events
 | Name | Description
Public event | ConfigurationChanged | Event to notify that the repository has had its configuration changed.
Public event | ConfigurationReset | Event to notify that the repository has had its configuration reset.
Public event | ShutdownEvent | Event to notify that the repository has been shutdown.
Back to Top
See Also
ILoggerRepository Interface
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.ConfigurationChanged Event

ILoggerRepository ConfigurationChanged Event Apache log4net™ SDK Documentation
Event to notify that the repository has had its configuration changed.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
event LoggerRepositoryConfigurationChangedEventHandler ConfigurationChanged
event LoggerRepositoryConfigurationChangedEventHandler ConfigurationChanged
Event ConfigurationChanged As LoggerRepositoryConfigurationChangedEventHandler
Event ConfigurationChanged As LoggerRepositoryConfigurationChangedEventHandler
 event LoggerRepositoryConfigurationChangedEventHandler^ ConfigurationChanged {
    void add (LoggerRepositoryConfigurationChangedEventHandler^ value);
    void remove (LoggerRepositoryConfigurationChangedEventHandler^ value);
}
 event LoggerRepositoryConfigurationChangedEventHandler^ ConfigurationChanged {
    void add (LoggerRepositoryConfigurationChangedEventHandler^ value);
    void remove (LoggerRepositoryConfigurationChangedEventHandler^ value);
}
Field Value
Type:

            Event to notify that the repository has had its configuration changed.

Remarks

            Event raised when the repository's configuration has been changed.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.ConfigurationReset Event

ILoggerRepository ConfigurationReset Event Apache log4net™ SDK Documentation
Event to notify that the repository has had its configuration reset.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
event LoggerRepositoryConfigurationResetEventHandler ConfigurationReset
event LoggerRepositoryConfigurationResetEventHandler ConfigurationReset
Event ConfigurationReset As LoggerRepositoryConfigurationResetEventHandler
Event ConfigurationReset As LoggerRepositoryConfigurationResetEventHandler
 event LoggerRepositoryConfigurationResetEventHandler^ ConfigurationReset {
    void add (LoggerRepositoryConfigurationResetEventHandler^ value);
    void remove (LoggerRepositoryConfigurationResetEventHandler^ value);
}
 event LoggerRepositoryConfigurationResetEventHandler^ ConfigurationReset {
    void add (LoggerRepositoryConfigurationResetEventHandler^ value);
    void remove (LoggerRepositoryConfigurationResetEventHandler^ value);
}
Field Value
Type:

            Event to notify that the repository has had its configuration reset.

Remarks

            Event raised when the repository's configuration has been
            reset to default.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerRepository.ShutdownEvent Event

ILoggerRepository ShutdownEvent Event Apache log4net™ SDK Documentation
Event to notify that the repository has been shutdown.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
event LoggerRepositoryShutdownEventHandler ShutdownEvent
event LoggerRepositoryShutdownEventHandler ShutdownEvent
Event ShutdownEvent As LoggerRepositoryShutdownEventHandler
Event ShutdownEvent As LoggerRepositoryShutdownEventHandler
 event LoggerRepositoryShutdownEventHandler^ ShutdownEvent {
    void add (LoggerRepositoryShutdownEventHandler^ value);
    void remove (LoggerRepositoryShutdownEventHandler^ value);
}
 event LoggerRepositoryShutdownEventHandler^ ShutdownEvent {
    void add (LoggerRepositoryShutdownEventHandler^ value);
    void remove (LoggerRepositoryShutdownEventHandler^ value);
}
Field Value
Type:

            Event to notify that the repository has been shutdown.

Remarks

            Event raised when the repository has been shutdown.

See Also
ILoggerRepository Interface
ILoggerRepository Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IXmlRepositoryConfigurator Interface

IXmlRepositoryConfigurator Interface Apache log4net™ SDK Documentation
Configure repository using XML

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IXmlRepositoryConfigurator
public interface IXmlRepositoryConfigurator
Public Interface IXmlRepositoryConfigurator
Public Interface IXmlRepositoryConfigurator
public interface class IXmlRepositoryConfigurator
public interface class IXmlRepositoryConfigurator
Remarks

            Interface used by Xml configurator to configure a ILoggerRepository.

            A ILoggerRepository should implement this interface to support
            configuration by the XmlConfigurator.

See Also
IXmlRepositoryConfigurator Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IXmlRepositoryConfigurator Members

IXmlRepositoryConfigurator Members Apache log4net™ SDK Documentation
The IXmlRepositoryConfigurator type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Initialize the repository using the specified config
Back to Top
See Also
IXmlRepositoryConfigurator Interface
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IXmlRepositoryConfigurator Methods

IXmlRepositoryConfigurator Methods Apache log4net™ SDK Documentation
The IXmlRepositoryConfigurator type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Initialize the repository using the specified config
Back to Top
See Also
IXmlRepositoryConfigurator Interface
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IXmlRepositoryConfigurator.Configure Method

IXmlRepositoryConfigurator Configure Method Apache log4net™ SDK Documentation
Initialize the repository using the specified config

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Configure(
    XmlElement element
)
void Configure(
    XmlElement element
)
Sub Configure (
    element As XmlElement
)
Sub Configure (
    element As XmlElement
)
void Configure(
    XmlElement^ element
)
void Configure(
    XmlElement^ element
)
Parameters
element
Type:   Online System.Xml XmlElement
the element containing the root of the config
Remarks

            The schema for the XML configuration data is defined by
            the implementation.

See Also
IXmlRepositoryConfigurator Interface
IXmlRepositoryConfigurator Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositoryConfigurationChangedEventHandler Delegate

LoggerRepositoryConfigurationChangedEventHandler Delegate Apache log4net™ SDK Documentation
Delegate used to handle event notifications for logger repository configuration changes.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void LoggerRepositoryConfigurationChangedEventHandler(
    Object sender,
    EventArgs e
)
public delegate void LoggerRepositoryConfigurationChangedEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub LoggerRepositoryConfigurationChangedEventHandler (
    sender As Object,
    e As EventArgs
)
Public Delegate Sub LoggerRepositoryConfigurationChangedEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void LoggerRepositoryConfigurationChangedEventHandler(
    Object^ sender,
    EventArgs^ e
)
public delegate void LoggerRepositoryConfigurationChangedEventHandler(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender
Type:   Online System Object
The ILoggerRepository that has had its configuration changed.
e
Type:   Online System EventArgs
Empty event arguments.
Remarks

            Delegate used to handle event notifications for logger repository configuration changes.

See Also
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositoryConfigurationResetEventHandler Delegate

LoggerRepositoryConfigurationResetEventHandler Delegate Apache log4net™ SDK Documentation
Delegate used to handle logger repository configuration reset event notifications

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void LoggerRepositoryConfigurationResetEventHandler(
    Object sender,
    EventArgs e
)
public delegate void LoggerRepositoryConfigurationResetEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub LoggerRepositoryConfigurationResetEventHandler (
    sender As Object,
    e As EventArgs
)
Public Delegate Sub LoggerRepositoryConfigurationResetEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void LoggerRepositoryConfigurationResetEventHandler(
    Object^ sender,
    EventArgs^ e
)
public delegate void LoggerRepositoryConfigurationResetEventHandler(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender
Type:   Online System Object
The ILoggerRepository that has had its configuration reset.
e
Type:   Online System EventArgs
Empty event args
Remarks

            Delegate used to handle logger repository configuration reset event notifications.

See Also
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositoryShutdownEventHandler Delegate

LoggerRepositoryShutdownEventHandler Delegate Apache log4net™ SDK Documentation
Delegate used to handle logger repository shutdown event notifications

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void LoggerRepositoryShutdownEventHandler(
    Object sender,
    EventArgs e
)
public delegate void LoggerRepositoryShutdownEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub LoggerRepositoryShutdownEventHandler (
    sender As Object,
    e As EventArgs
)
Public Delegate Sub LoggerRepositoryShutdownEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void LoggerRepositoryShutdownEventHandler(
    Object^ sender,
    EventArgs^ e
)
public delegate void LoggerRepositoryShutdownEventHandler(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender
Type:   Online System Object
The ILoggerRepository that is shutting down.
e
Type:   Online System EventArgs
Empty event args
Remarks

            Delegate used to handle logger repository shutdown event notifications.

See Also
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton Class

LoggerRepositorySkeleton Class Apache log4net™ SDK Documentation
Base implementation of ILoggerRepository
Inheritance Hierarchy
Online System Object
log4net.Repository LoggerRepositorySkeleton
log4net.Repository.Hierarchy Hierarchy

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class LoggerRepositorySkeleton : ILoggerRepository
public abstract class LoggerRepositorySkeleton : ILoggerRepository
Public MustInherit Class LoggerRepositorySkeleton
    Implements ILoggerRepository
Public MustInherit Class LoggerRepositorySkeleton
    Implements ILoggerRepository
public ref class LoggerRepositorySkeleton abstract : ILoggerRepository
public ref class LoggerRepositorySkeleton abstract : ILoggerRepository
Remarks

            Default abstract implementation of the ILoggerRepository interface.

            Skeleton implementation of the ILoggerRepository interface.
            All ILoggerRepository types can extend this type.

See Also
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton Members

LoggerRepositorySkeleton Members Apache log4net™ SDK Documentation
The LoggerRepositorySkeleton type exposes the following members.
Constructors
 | Name | Description
Protected method | LoggerRepositorySkeleton | Default Constructor
Protected method | LoggerRepositorySkeleton(PropertiesDictionary) | Construct the repository using specific properties
Back to Top
Methods
 | Name | Description
Public method | AddRenderer | Adds an object renderer for a specific class.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Exists | Test if logger exists
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAppenders | Returns all the Appenders that are configured as an Array.
Public method | GetCurrentLoggers | Returns all the currently defined loggers in the repository
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLogger | Return a new logger instance
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Log | Log the logEvent through this repository.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnConfigurationChanged | Notify the registered listeners that the repository has had its configuration changed
Protected method | OnConfigurationReset | Notify the registered listeners that the repository has had its configuration reset
Protected method | OnShutdown | Notify the registered listeners that the repository is shutting down
Public method | RaiseConfigurationChanged | Raise a configuration changed event on this repository
Public method | ResetConfiguration | Reset the repositories configuration to a default state
Public method | Shutdown | Shutdown the repository
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ConfigurationMessages | Contains a list of internal messages captures during the last configuration.
Public property | Configured | Flag indicates if this repository has been configured.
Public property | LevelMap | Get the level map for the Repository.
Public property | Name | The name of the repository
Public property | PluginMap | The plugin map for this repository.
Public property | Properties | Repository specific properties
Public property | RendererMap | RendererMap accesses the object renderer map for this repository.
Public property | Threshold | The threshold for all events in this repository
Back to Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event to notify that the repository has had its configuration changed.
Public event | ConfigurationReset | Event to notify that the repository has had its configuration reset.
Public event | ShutdownEvent | Event to notify that the repository has been shutdown.
Back to Top
See Also
LoggerRepositorySkeleton Class
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton Constructor

LoggerRepositorySkeleton Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | LoggerRepositorySkeleton | Default Constructor
Protected method | LoggerRepositorySkeleton(PropertiesDictionary) | Construct the repository using specific properties
Back to Top
See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton Constructor

LoggerRepositorySkeleton Constructor Apache log4net™ SDK Documentation
Default Constructor

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LoggerRepositorySkeleton()
protected LoggerRepositorySkeleton()
Protected Sub New
Protected Sub New
protected:
LoggerRepositorySkeleton()
protected:
LoggerRepositorySkeleton()
Remarks

            Initializes the repository with default (empty) properties.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
LoggerRepositorySkeleton Overload
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton Constructor (PropertiesDictionary)

LoggerRepositorySkeleton Constructor (PropertiesDictionary) Apache log4net™ SDK Documentation
Construct the repository using specific properties

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LoggerRepositorySkeleton(
    PropertiesDictionary properties
)
protected LoggerRepositorySkeleton(
    PropertiesDictionary properties
)
Protected Sub New (
    properties As PropertiesDictionary
)
Protected Sub New (
    properties As PropertiesDictionary
)
protected:
LoggerRepositorySkeleton(
    PropertiesDictionary^ properties
)
protected:
LoggerRepositorySkeleton(
    PropertiesDictionary^ properties
)
Parameters
properties
Type: log4net.Util PropertiesDictionary
the properties to set for this repository
Remarks

            Initializes the repository with specified properties.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
LoggerRepositorySkeleton Overload
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton Methods

LoggerRepositorySkeleton Methods Apache log4net™ SDK Documentation
The LoggerRepositorySkeleton type exposes the following members.
Methods
 | Name | Description
Public method | AddRenderer | Adds an object renderer for a specific class.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Exists | Test if logger exists
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAppenders | Returns all the Appenders that are configured as an Array.
Public method | GetCurrentLoggers | Returns all the currently defined loggers in the repository
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLogger | Return a new logger instance
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Log | Log the logEvent through this repository.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnConfigurationChanged | Notify the registered listeners that the repository has had its configuration changed
Protected method | OnConfigurationReset | Notify the registered listeners that the repository has had its configuration reset
Protected method | OnShutdown | Notify the registered listeners that the repository is shutting down
Public method | RaiseConfigurationChanged | Raise a configuration changed event on this repository
Public method | ResetConfiguration | Reset the repositories configuration to a default state
Public method | Shutdown | Shutdown the repository
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LoggerRepositorySkeleton Class
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.AddRenderer Method

LoggerRepositorySkeleton AddRenderer Method Apache log4net™ SDK Documentation
Adds an object renderer for a specific class.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddRenderer(
    Type typeToRender,
    IObjectRenderer rendererInstance
)
public virtual void AddRenderer(
    Type typeToRender,
    IObjectRenderer rendererInstance
)
Public Overridable Sub AddRenderer (
    typeToRender As Type,
    rendererInstance As IObjectRenderer
)
Public Overridable Sub AddRenderer (
    typeToRender As Type,
    rendererInstance As IObjectRenderer
)
public:
virtual void AddRenderer(
    Type^ typeToRender,
    IObjectRenderer^ rendererInstance
)
public:
virtual void AddRenderer(
    Type^ typeToRender,
    IObjectRenderer^ rendererInstance
)
Parameters
typeToRender
Type:   Online System Type
The type that will be rendered by the renderer supplied.
rendererInstance
Type: log4net.ObjectRenderer IObjectRenderer
The object renderer used to render the object.
Remarks

            Adds an object renderer for a specific class.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.Exists Method

LoggerRepositorySkeleton Exists Method Apache log4net™ SDK Documentation
Test if logger exists

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ILogger Exists(
    string name
)
public abstract ILogger Exists(
    string name
)
Public MustOverride Function Exists (
    name As String
) As ILogger
Public MustOverride Function Exists (
    name As String
) As ILogger
public:
virtual ILogger^ Exists(
    String^ name
) abstract
public:
virtual ILogger^ Exists(
    String^ name
) abstract
Parameters
name
Type:   Online System String
The name of the logger to lookup
Return Value
Type: ILogger
The Logger object with the name specified
Implements
ILoggerRepository Exists(String)
Remarks

            Check if the named logger exists in the repository. If so return
            its reference, otherwise returns null.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.GetAppenders Method

LoggerRepositorySkeleton GetAppenders Method Apache log4net™ SDK Documentation
Returns all the Appenders that are configured as an Array.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IAppender[] GetAppenders()
public abstract IAppender[] GetAppenders()
Public MustOverride Function GetAppenders As IAppender()
Public MustOverride Function GetAppenders As IAppender()
public:
virtual array<IAppender^>^ GetAppenders() abstract
public:
virtual array<IAppender^>^ GetAppenders() abstract
Return Value
Type:  IAppender
All the Appenders
Implements
ILoggerRepository GetAppenders
Remarks

            Returns all the Appenders that are configured as an Array.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.GetCurrentLoggers Method

LoggerRepositorySkeleton GetCurrentLoggers Method Apache log4net™ SDK Documentation
Returns all the currently defined loggers in the repository

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ILogger[] GetCurrentLoggers()
public abstract ILogger[] GetCurrentLoggers()
Public MustOverride Function GetCurrentLoggers As ILogger()
Public MustOverride Function GetCurrentLoggers As ILogger()
public:
virtual array<ILogger^>^ GetCurrentLoggers() abstract
public:
virtual array<ILogger^>^ GetCurrentLoggers() abstract
Return Value
Type:  ILogger
All the defined loggers
Implements
ILoggerRepository GetCurrentLoggers
Remarks

            Returns all the currently defined loggers in the repository as an Array.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.GetLogger Method

LoggerRepositorySkeleton GetLogger Method Apache log4net™ SDK Documentation
Return a new logger instance

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ILogger GetLogger(
    string name
)
public abstract ILogger GetLogger(
    string name
)
Public MustOverride Function GetLogger (
    name As String
) As ILogger
Public MustOverride Function GetLogger (
    name As String
) As ILogger
public:
virtual ILogger^ GetLogger(
    String^ name
) abstract
public:
virtual ILogger^ GetLogger(
    String^ name
) abstract
Parameters
name
Type:   Online System String
The name of the logger to retrieve
Return Value
Type: ILogger
The logger object with the name specified
Implements
ILoggerRepository GetLogger(String)
Remarks

            Return a new logger instance.

            If a logger of that name already exists, then it will be
            returned. Otherwise, a new logger will be instantiated and
            then linked with its existing ancestors as well as children.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.Log Method

LoggerRepositorySkeleton Log Method Apache log4net™ SDK Documentation
Log the logEvent through this repository.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Log(
    LoggingEvent logEvent
)
public abstract void Log(
    LoggingEvent logEvent
)
Public MustOverride Sub Log (
    logEvent As LoggingEvent
)
Public MustOverride Sub Log (
    logEvent As LoggingEvent
)
public:
virtual void Log(
    LoggingEvent^ logEvent
) abstract
public:
virtual void Log(
    LoggingEvent^ logEvent
) abstract
Parameters
logEvent
Type: log4net.Core LoggingEvent
the event to log
Implements
ILoggerRepository Log(LoggingEvent)
Remarks

            This method should not normally be used to log.
            The ILog interface should be used
            for routine logging. This interface can be obtained
            using the GetLogger(string) method.

            The logEvent is delivered to the appropriate logger and
            that logger is then responsible for logging the event.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.OnConfigurationChanged Method

LoggerRepositorySkeleton OnConfigurationChanged Method Apache log4net™ SDK Documentation
Notify the registered listeners that the repository has had its configuration changed

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void OnConfigurationChanged(
    EventArgs e
)
protected virtual void OnConfigurationChanged(
    EventArgs e
)
Protected Overridable Sub OnConfigurationChanged (
    e As EventArgs
)
Protected Overridable Sub OnConfigurationChanged (
    e As EventArgs
)
protected:
virtual void OnConfigurationChanged(
    EventArgs^ e
)
protected:
virtual void OnConfigurationChanged(
    EventArgs^ e
)
Parameters
e
Type:   Online System EventArgs
Empty EventArgs
Remarks

            Notify any listeners that this repository's configuration has changed.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.OnConfigurationReset Method

LoggerRepositorySkeleton OnConfigurationReset Method Apache log4net™ SDK Documentation
Notify the registered listeners that the repository has had its configuration reset

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void OnConfigurationReset(
    EventArgs e
)
protected virtual void OnConfigurationReset(
    EventArgs e
)
Protected Overridable Sub OnConfigurationReset (
    e As EventArgs
)
Protected Overridable Sub OnConfigurationReset (
    e As EventArgs
)
protected:
virtual void OnConfigurationReset(
    EventArgs^ e
)
protected:
virtual void OnConfigurationReset(
    EventArgs^ e
)
Parameters
e
Type:   Online System EventArgs
Empty EventArgs
Remarks

            Notify any listeners that this repository's configuration has been reset.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.OnShutdown Method

LoggerRepositorySkeleton OnShutdown Method Apache log4net™ SDK Documentation
Notify the registered listeners that the repository is shutting down

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void OnShutdown(
    EventArgs e
)
protected virtual void OnShutdown(
    EventArgs e
)
Protected Overridable Sub OnShutdown (
    e As EventArgs
)
Protected Overridable Sub OnShutdown (
    e As EventArgs
)
protected:
virtual void OnShutdown(
    EventArgs^ e
)
protected:
virtual void OnShutdown(
    EventArgs^ e
)
Parameters
e
Type:   Online System EventArgs
Empty EventArgs
Remarks

            Notify any listeners that this repository is shutting down.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.RaiseConfigurationChanged Method

LoggerRepositorySkeleton RaiseConfigurationChanged Method Apache log4net™ SDK Documentation
Raise a configuration changed event on this repository

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RaiseConfigurationChanged(
    EventArgs e
)
public void RaiseConfigurationChanged(
    EventArgs e
)
Public Sub RaiseConfigurationChanged (
    e As EventArgs
)
Public Sub RaiseConfigurationChanged (
    e As EventArgs
)
public:
void RaiseConfigurationChanged(
    EventArgs^ e
)
public:
void RaiseConfigurationChanged(
    EventArgs^ e
)
Parameters
e
Type:   Online System EventArgs
EventArgs.Empty
Remarks

            Applications that programmatically change the configuration of the repository should
            raise this event notification to notify listeners.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.ResetConfiguration Method

LoggerRepositorySkeleton ResetConfiguration Method Apache log4net™ SDK Documentation
Reset the repositories configuration to a default state

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ResetConfiguration()
public virtual void ResetConfiguration()
Public Overridable Sub ResetConfiguration
Public Overridable Sub ResetConfiguration
public:
virtual void ResetConfiguration()
public:
virtual void ResetConfiguration()
Implements
ILoggerRepository ResetConfiguration
Remarks

            Reset all values contained in this instance to their
            default state.

            Existing loggers are not removed. They are just reset.

            This method should be used sparingly and with care as it will
            block all logging until it is completed.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.Shutdown Method

LoggerRepositorySkeleton Shutdown Method Apache log4net™ SDK Documentation
Shutdown the repository

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Shutdown()
public virtual void Shutdown()
Public Overridable Sub Shutdown
Public Overridable Sub Shutdown
public:
virtual void Shutdown()
public:
virtual void Shutdown()
Implements
ILoggerRepository Shutdown
Remarks

            Shutdown the repository. Can be overridden in a subclass.
            This base class implementation notifies the ShutdownEvent
            listeners and all attached plugins of the shutdown event.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton Properties

LoggerRepositorySkeleton Properties Apache log4net™ SDK Documentation
The LoggerRepositorySkeleton type exposes the following members.
Properties
 | Name | Description
Public property | ConfigurationMessages | Contains a list of internal messages captures during the last configuration.
Public property | Configured | Flag indicates if this repository has been configured.
Public property | LevelMap | Get the level map for the Repository.
Public property | Name | The name of the repository
Public property | PluginMap | The plugin map for this repository.
Public property | Properties | Repository specific properties
Public property | RendererMap | RendererMap accesses the object renderer map for this repository.
Public property | Threshold | The threshold for all events in this repository
Back to Top
See Also
LoggerRepositorySkeleton Class
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.ConfigurationMessages Property

LoggerRepositorySkeleton ConfigurationMessages Property Apache log4net™ SDK Documentation
Contains a list of internal messages captures during the last configuration.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ICollection ConfigurationMessages { get; set; }
public virtual ICollection ConfigurationMessages { get; set; }
Public Overridable Property ConfigurationMessages As ICollection
    Get
    Set
Public Overridable Property ConfigurationMessages As ICollection
    Get
    Set
public:
virtual property ICollection^ ConfigurationMessages {
    ICollection^ get ();
    void set (ICollection^ value);
}
public:
virtual property ICollection^ ConfigurationMessages {
    ICollection^ get ();
    void set (ICollection^ value);
}
Property Value
Type:   Online ICollection
Implements
ILoggerRepository ConfigurationMessages
See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.Configured Property

LoggerRepositorySkeleton Configured Property Apache log4net™ SDK Documentation
Flag indicates if this repository has been configured.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Configured { get; set; }
public virtual bool Configured { get; set; }
Public Overridable Property Configured As Boolean
    Get
    Set
Public Overridable Property Configured As Boolean
    Get
    Set
public:
virtual property bool Configured {
    bool get ();
    void set (bool value);
}
public:
virtual property bool Configured {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean

            Flag indicates if this repository has been configured.

Implements
ILoggerRepository Configured
Remarks

            Flag indicates if this repository has been configured.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.LevelMap Property

LoggerRepositorySkeleton LevelMap Property Apache log4net™ SDK Documentation
Get the level map for the Repository.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual LevelMap LevelMap { get; }
public virtual LevelMap LevelMap { get; }
Public Overridable ReadOnly Property LevelMap As LevelMap
    Get
Public Overridable ReadOnly Property LevelMap As LevelMap
    Get
public:
virtual property LevelMap^ LevelMap {
    LevelMap^ get ();
}
public:
virtual property LevelMap^ LevelMap {
    LevelMap^ get ();
}
Property Value
Type: LevelMap
Implements
ILoggerRepository LevelMap
Remarks

            Get the level map for the Repository.

            The level map defines the mappings between
            level names and Level objects in
            this repository.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.Name Property

LoggerRepositorySkeleton Name Property Apache log4net™ SDK Documentation
The name of the repository

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Name { get; set; }
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The string name of the repository

Implements
ILoggerRepository Name
Remarks

            The name of this repository. The name is
            used to store and lookup the repositories
            stored by the IRepositorySelector.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.PluginMap Property

LoggerRepositorySkeleton PluginMap Property Apache log4net™ SDK Documentation
The plugin map for this repository.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual PluginMap PluginMap { get; }
public virtual PluginMap PluginMap { get; }
Public Overridable ReadOnly Property PluginMap As PluginMap
    Get
Public Overridable ReadOnly Property PluginMap As PluginMap
    Get
public:
virtual property PluginMap^ PluginMap {
    PluginMap^ get ();
}
public:
virtual property PluginMap^ PluginMap {
    PluginMap^ get ();
}
Property Value
Type: PluginMap

            The plugin map for this repository.

Implements
ILoggerRepository PluginMap
Remarks

            The plugin map holds the IPlugin instances
            that have been attached to this repository.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.Properties Property

LoggerRepositorySkeleton Properties Property Apache log4net™ SDK Documentation
Repository specific properties

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PropertiesDictionary Properties { get; }
public PropertiesDictionary Properties { get; }
Public ReadOnly Property Properties As PropertiesDictionary
    Get
Public ReadOnly Property Properties As PropertiesDictionary
    Get
public:
virtual property PropertiesDictionary^ Properties {
    PropertiesDictionary^ get () sealed;
}
public:
virtual property PropertiesDictionary^ Properties {
    PropertiesDictionary^ get () sealed;
}
Property Value
Type: PropertiesDictionary

            Repository specific properties

Implements
ILoggerRepository Properties
Remarks

            These properties can be specified on a repository specific basis

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.RendererMap Property

LoggerRepositorySkeleton RendererMap Property Apache log4net™ SDK Documentation
RendererMap accesses the object renderer map for this repository.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual RendererMap RendererMap { get; }
public virtual RendererMap RendererMap { get; }
Public Overridable ReadOnly Property RendererMap As RendererMap
    Get
Public Overridable ReadOnly Property RendererMap As RendererMap
    Get
public:
virtual property RendererMap^ RendererMap {
    RendererMap^ get ();
}
public:
virtual property RendererMap^ RendererMap {
    RendererMap^ get ();
}
Property Value
Type: RendererMap

            RendererMap accesses the object renderer map for this repository.

Implements
ILoggerRepository RendererMap
Remarks

            RendererMap accesses the object renderer map for this repository.

            The RendererMap holds a mapping between types and
            IObjectRenderer objects.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.Threshold Property

LoggerRepositorySkeleton Threshold Property Apache log4net™ SDK Documentation
The threshold for all events in this repository

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Level Threshold { get; set; }
public virtual Level Threshold { get; set; }
Public Overridable Property Threshold As Level
    Get
    Set
Public Overridable Property Threshold As Level
    Get
    Set
public:
virtual property Level^ Threshold {
    Level^ get ();
    void set (Level^ value);
}
public:
virtual property Level^ Threshold {
    Level^ get ();
    void set (Level^ value);
}
Property Value
Type: Level

            The threshold for all events in this repository

Implements
ILoggerRepository Threshold
Remarks

            The threshold for all events in this repository

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton Events

LoggerRepositorySkeleton Events Apache log4net™ SDK Documentation
The LoggerRepositorySkeleton type exposes the following members.
Events
 | Name | Description
Public event | ConfigurationChanged | Event to notify that the repository has had its configuration changed.
Public event | ConfigurationReset | Event to notify that the repository has had its configuration reset.
Public event | ShutdownEvent | Event to notify that the repository has been shutdown.
Back to Top
See Also
LoggerRepositorySkeleton Class
log4net.Repository Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.ConfigurationChanged Event

LoggerRepositorySkeleton ConfigurationChanged Event Apache log4net™ SDK Documentation
Event to notify that the repository has had its configuration changed.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event LoggerRepositoryConfigurationChangedEventHandler ConfigurationChanged
public event LoggerRepositoryConfigurationChangedEventHandler ConfigurationChanged
Public Event ConfigurationChanged As LoggerRepositoryConfigurationChangedEventHandler
Public Event ConfigurationChanged As LoggerRepositoryConfigurationChangedEventHandler
public:
virtual  event LoggerRepositoryConfigurationChangedEventHandler^ ConfigurationChanged {
    void add (LoggerRepositoryConfigurationChangedEventHandler^ value);
    void remove (LoggerRepositoryConfigurationChangedEventHandler^ value);
}
public:
virtual  event LoggerRepositoryConfigurationChangedEventHandler^ ConfigurationChanged {
    void add (LoggerRepositoryConfigurationChangedEventHandler^ value);
    void remove (LoggerRepositoryConfigurationChangedEventHandler^ value);
}
Field Value
Type:

            Event to notify that the repository has had its configuration changed.

Implements
ILoggerRepository ConfigurationChanged
Remarks

            Event raised when the repository's configuration has been changed.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.ConfigurationReset Event

LoggerRepositorySkeleton ConfigurationReset Event Apache log4net™ SDK Documentation
Event to notify that the repository has had its configuration reset.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event LoggerRepositoryConfigurationResetEventHandler ConfigurationReset
public event LoggerRepositoryConfigurationResetEventHandler ConfigurationReset
Public Event ConfigurationReset As LoggerRepositoryConfigurationResetEventHandler
Public Event ConfigurationReset As LoggerRepositoryConfigurationResetEventHandler
public:
virtual  event LoggerRepositoryConfigurationResetEventHandler^ ConfigurationReset {
    void add (LoggerRepositoryConfigurationResetEventHandler^ value);
    void remove (LoggerRepositoryConfigurationResetEventHandler^ value);
}
public:
virtual  event LoggerRepositoryConfigurationResetEventHandler^ ConfigurationReset {
    void add (LoggerRepositoryConfigurationResetEventHandler^ value);
    void remove (LoggerRepositoryConfigurationResetEventHandler^ value);
}
Field Value
Type:

            Event to notify that the repository has had its configuration reset.

Implements
ILoggerRepository ConfigurationReset
Remarks

            Event raised when the repository's configuration has been
            reset to default.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerRepositorySkeleton.ShutdownEvent Event

LoggerRepositorySkeleton ShutdownEvent Event Apache log4net™ SDK Documentation
Event to notify that the repository has been shutdown.

Namespace: log4net.Repository
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event LoggerRepositoryShutdownEventHandler ShutdownEvent
public event LoggerRepositoryShutdownEventHandler ShutdownEvent
Public Event ShutdownEvent As LoggerRepositoryShutdownEventHandler
Public Event ShutdownEvent As LoggerRepositoryShutdownEventHandler
public:
virtual  event LoggerRepositoryShutdownEventHandler^ ShutdownEvent {
    void add (LoggerRepositoryShutdownEventHandler^ value);
    void remove (LoggerRepositoryShutdownEventHandler^ value);
}
public:
virtual  event LoggerRepositoryShutdownEventHandler^ ShutdownEvent {
    void add (LoggerRepositoryShutdownEventHandler^ value);
    void remove (LoggerRepositoryShutdownEventHandler^ value);
}
Field Value
Type:

            Event to notify that the repository has been shutdown.

Implements
ILoggerRepository ShutdownEvent
Remarks

            Event raised when the repository has been shutdown.

See Also
LoggerRepositorySkeleton Class
LoggerRepositorySkeleton Members
log4net.Repository Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.Repository.Hierarchy Namespace

log4net.Repository.Hierarchy Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | Hierarchy | Hierarchical organization of loggers
Public class | Logger | Implementation of ILogger used by Hierarchy
Public class | LoggerCreationEventArgs | Provides data for the LoggerCreatedEvent event.
Public class | RootLogger | The RootLogger sits at the root of the logger hierarchy tree.
Public class | XmlHierarchyConfigurator | Initializes the log4net environment using an XML DOM.
Interfaces
 | Interface | Description
Public interface | ILoggerFactory | Interface abstracts creation of Logger instances
Delegates
 | Delegate | Description
Public delegate | LoggerCreationEventHandler | Delegate used to handle logger creation event notifications.

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy Class

Hierarchy Class Apache log4net™ SDK Documentation
Hierarchical organization of loggers
Inheritance Hierarchy
Online System Object
log4net.Repository LoggerRepositorySkeleton
log4net.Repository.Hierarchy Hierarchy

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Hierarchy : LoggerRepositorySkeleton, IBasicRepositoryConfigurator,
    IXmlRepositoryConfigurator
public class Hierarchy : LoggerRepositorySkeleton, IBasicRepositoryConfigurator,
    IXmlRepositoryConfigurator
Public Class Hierarchy
    Inherits LoggerRepositorySkeleton
    Implements IBasicRepositoryConfigurator, IXmlRepositoryConfigurator
Public Class Hierarchy
    Inherits LoggerRepositorySkeleton
    Implements IBasicRepositoryConfigurator, IXmlRepositoryConfigurator
public ref class Hierarchy : public LoggerRepositorySkeleton,
    IBasicRepositoryConfigurator, IXmlRepositoryConfigurator
public ref class Hierarchy : public LoggerRepositorySkeleton,
    IBasicRepositoryConfigurator, IXmlRepositoryConfigurator
Remarks
The casual user should not have to deal with this class
            directly.

            This class is specialized in retrieving loggers by name and
            also maintaining the logger hierarchy. Implements the
            ILoggerRepository interface.

            The structure of the logger hierarchy is maintained by the
            [M:GetLogger(string)] method. The hierarchy is such that children
            link to their parent but parents do not have any references to their
            children. Moreover, loggers can be instantiated in any order, in
            particular descendant before ancestor.

            In case a descendant is created before a particular ancestor,
            then it creates a provision node for the ancestor and adds itself
            to the provision node. Other descendants of the same ancestor add
            themselves to the previously created provision node.

See Also
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy Members

Hierarchy Members Apache log4net™ SDK Documentation
The Hierarchy type exposes the following members.
Constructors
 | Name | Description
Public method | Hierarchy | Default constructor
Public method | Hierarchy(ILoggerFactory) | Construct with a logger factory
Public method | Hierarchy(PropertiesDictionary) | Construct with properties
Public method | Hierarchy(PropertiesDictionary, ILoggerFactory) | Construct with properties and a logger factory
Back to Top
Methods
 | Name | Description
Public method | AddRenderer | Adds an object renderer for a specific class. (Inherited from LoggerRepositorySkeleton.)
Protected method | BasicRepositoryConfigure | Initialize the log4net system using the specified appenders
Public method | Clear | Clear all logger definitions from the internal hashtable
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Exists | Test if a logger exists (Overrides LoggerRepositorySkeleton Exists(String).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAppenders | Returns all the Appenders that are currently configured (Overrides LoggerRepositorySkeleton GetAppenders .)
Public method | GetCurrentLoggers | Returns all the currently defined loggers in the hierarchy as an Array (Overrides LoggerRepositorySkeleton GetCurrentLoggers .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLogger(String) | Return a new logger instance named as the first parameter using the default factory. (Overrides LoggerRepositorySkeleton GetLogger(String).)
Public method | GetLogger(String, ILoggerFactory) | Return a new logger instance named as the first parameter using factory.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsDisabled | Test if this hierarchy is disabled for the specified Level.
Public method | Log | Log the logEvent through this hierarchy. (Overrides LoggerRepositorySkeleton Log(LoggingEvent).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnConfigurationChanged | Notify the registered listeners that the repository has had its configuration changed (Inherited from LoggerRepositorySkeleton.)
Protected method | OnConfigurationReset | Notify the registered listeners that the repository has had its configuration reset (Inherited from LoggerRepositorySkeleton.)
Protected method | OnLoggerCreationEvent | Sends a logger creation event to all registered listeners
Protected method | OnShutdown | Notify the registered listeners that the repository is shutting down (Inherited from LoggerRepositorySkeleton.)
Public method | RaiseConfigurationChanged | Raise a configuration changed event on this repository (Inherited from LoggerRepositorySkeleton.)
Public method | ResetConfiguration | Reset all values contained in this hierarchy instance to their default. (Overrides LoggerRepositorySkeleton ResetConfiguration .)
Public method | Shutdown | Shutting down a hierarchy will safely close and remove all appenders in all loggers including the root logger. (Overrides LoggerRepositorySkeleton Shutdown .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Protected method | XmlRepositoryConfigure | Initialize the log4net system using the specified config
Back to Top
Properties
 | Name | Description
Public property | ConfigurationMessages | Contains a list of internal messages captures during the last configuration. (Inherited from LoggerRepositorySkeleton.)
Public property | Configured | Flag indicates if this repository has been configured. (Inherited from LoggerRepositorySkeleton.)
Public property | EmittedNoAppenderWarning | Has no appender warning been emitted
Public property | LevelMap | Get the level map for the Repository. (Inherited from LoggerRepositorySkeleton.)
Public property | LoggerFactory | Gets or sets the default ILoggerFactory instance.
Public property | Name | The name of the repository (Inherited from LoggerRepositorySkeleton.)
Public property | PluginMap | The plugin map for this repository. (Inherited from LoggerRepositorySkeleton.)
Public property | Properties | Repository specific properties (Inherited from LoggerRepositorySkeleton.)
Public property | RendererMap | RendererMap accesses the object renderer map for this repository. (Inherited from LoggerRepositorySkeleton.)
Public property | Root | Get the root of this hierarchy
Public property | Threshold | The threshold for all events in this repository (Inherited from LoggerRepositorySkeleton.)
Back to Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event to notify that the repository has had its configuration changed. (Inherited from LoggerRepositorySkeleton.)
Public event | ConfigurationReset | Event to notify that the repository has had its configuration reset. (Inherited from LoggerRepositorySkeleton.)
Public event | LoggerCreatedEvent | Event used to notify that a logger has been created.
Public event | ShutdownEvent | Event to notify that the repository has been shutdown. (Inherited from LoggerRepositorySkeleton.)
Back to Top
See Also
Hierarchy Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy Constructor

Hierarchy Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Hierarchy | Default constructor
Public method | Hierarchy(ILoggerFactory) | Construct with a logger factory
Public method | Hierarchy(PropertiesDictionary) | Construct with properties
Public method | Hierarchy(PropertiesDictionary, ILoggerFactory) | Construct with properties and a logger factory
Back to Top
See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy Constructor

Hierarchy Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Hierarchy()
public Hierarchy()
Public Sub New
Public Sub New
public:
Hierarchy()
public:
Hierarchy()
Remarks

            Initializes a new instance of the Hierarchy class.

See Also
Hierarchy Class
Hierarchy Members
Hierarchy Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy Constructor (ILoggerFactory)

Hierarchy Constructor (ILoggerFactory) Apache log4net™ SDK Documentation
Construct with a logger factory

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Hierarchy(
    ILoggerFactory loggerFactory
)
public Hierarchy(
    ILoggerFactory loggerFactory
)
Public Sub New (
    loggerFactory As ILoggerFactory
)
Public Sub New (
    loggerFactory As ILoggerFactory
)
public:
Hierarchy(
    ILoggerFactory^ loggerFactory
)
public:
Hierarchy(
    ILoggerFactory^ loggerFactory
)
Parameters
loggerFactory
Type: log4net.Repository.Hierarchy ILoggerFactory
The factory to use to create new logger instances.
Remarks

            Initializes a new instance of the Hierarchy class with
            the specified ILoggerFactory.

See Also
Hierarchy Class
Hierarchy Members
Hierarchy Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy Constructor (PropertiesDictionary)

Hierarchy Constructor (PropertiesDictionary) Apache log4net™ SDK Documentation
Construct with properties

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Hierarchy(
    PropertiesDictionary properties
)
public Hierarchy(
    PropertiesDictionary properties
)
Public Sub New (
    properties As PropertiesDictionary
)
Public Sub New (
    properties As PropertiesDictionary
)
public:
Hierarchy(
    PropertiesDictionary^ properties
)
public:
Hierarchy(
    PropertiesDictionary^ properties
)
Parameters
properties
Type: log4net.Util PropertiesDictionary
The properties to pass to this repository.
Remarks

            Initializes a new instance of the Hierarchy class.

See Also
Hierarchy Class
Hierarchy Members
Hierarchy Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy Constructor (PropertiesDictionary, ILoggerFactory)

Hierarchy Constructor (PropertiesDictionary, ILoggerFactory) Apache log4net™ SDK Documentation
Construct with properties and a logger factory

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Hierarchy(
    PropertiesDictionary properties,
    ILoggerFactory loggerFactory
)
public Hierarchy(
    PropertiesDictionary properties,
    ILoggerFactory loggerFactory
)
Public Sub New (
    properties As PropertiesDictionary,
    loggerFactory As ILoggerFactory
)
Public Sub New (
    properties As PropertiesDictionary,
    loggerFactory As ILoggerFactory
)
public:
Hierarchy(
    PropertiesDictionary^ properties,
    ILoggerFactory^ loggerFactory
)
public:
Hierarchy(
    PropertiesDictionary^ properties,
    ILoggerFactory^ loggerFactory
)
Parameters
properties
Type: log4net.Util PropertiesDictionary
The properties to pass to this repository.
loggerFactory
Type: log4net.Repository.Hierarchy ILoggerFactory
The factory to use to create new logger instances.
Remarks

            Initializes a new instance of the Hierarchy class with
            the specified ILoggerFactory.

See Also
Hierarchy Class
Hierarchy Members
Hierarchy Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy Methods

Hierarchy Methods Apache log4net™ SDK Documentation
The Hierarchy type exposes the following members.
Methods
 | Name | Description
Public method | AddRenderer | Adds an object renderer for a specific class. (Inherited from LoggerRepositorySkeleton.)
Protected method | BasicRepositoryConfigure | Initialize the log4net system using the specified appenders
Public method | Clear | Clear all logger definitions from the internal hashtable
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Exists | Test if a logger exists (Overrides LoggerRepositorySkeleton Exists(String).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAppenders | Returns all the Appenders that are currently configured (Overrides LoggerRepositorySkeleton GetAppenders .)
Public method | GetCurrentLoggers | Returns all the currently defined loggers in the hierarchy as an Array (Overrides LoggerRepositorySkeleton GetCurrentLoggers .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLogger(String) | Return a new logger instance named as the first parameter using the default factory. (Overrides LoggerRepositorySkeleton GetLogger(String).)
Public method | GetLogger(String, ILoggerFactory) | Return a new logger instance named as the first parameter using factory.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsDisabled | Test if this hierarchy is disabled for the specified Level.
Public method | Log | Log the logEvent through this hierarchy. (Overrides LoggerRepositorySkeleton Log(LoggingEvent).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnConfigurationChanged | Notify the registered listeners that the repository has had its configuration changed (Inherited from LoggerRepositorySkeleton.)
Protected method | OnConfigurationReset | Notify the registered listeners that the repository has had its configuration reset (Inherited from LoggerRepositorySkeleton.)
Protected method | OnLoggerCreationEvent | Sends a logger creation event to all registered listeners
Protected method | OnShutdown | Notify the registered listeners that the repository is shutting down (Inherited from LoggerRepositorySkeleton.)
Public method | RaiseConfigurationChanged | Raise a configuration changed event on this repository (Inherited from LoggerRepositorySkeleton.)
Public method | ResetConfiguration | Reset all values contained in this hierarchy instance to their default. (Overrides LoggerRepositorySkeleton ResetConfiguration .)
Public method | Shutdown | Shutting down a hierarchy will safely close and remove all appenders in all loggers including the root logger. (Overrides LoggerRepositorySkeleton Shutdown .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Protected method | XmlRepositoryConfigure | Initialize the log4net system using the specified config
Back to Top
See Also
Hierarchy Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.BasicRepositoryConfigure Method

Hierarchy BasicRepositoryConfigure Method Apache log4net™ SDK Documentation
Initialize the log4net system using the specified appenders

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void BasicRepositoryConfigure(
    params IAppender[] appenders
)
protected void BasicRepositoryConfigure(
    params IAppender[] appenders
)
Protected Sub BasicRepositoryConfigure (
    ParamArray appenders As IAppender()
)
Protected Sub BasicRepositoryConfigure (
    ParamArray appenders As IAppender()
)
protected:
void BasicRepositoryConfigure(
    ... array<IAppender^>^ appenders
)
protected:
void BasicRepositoryConfigure(
    ... array<IAppender^>^ appenders
)
Parameters
appenders
Type:  log4net.Appender IAppender
the appenders to use to log all logging events
Remarks

            This method provides the same functionality as the
            Configure(IAppender) method implemented
            on this object, but it is protected and therefore can be called by subclasses.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.Clear Method

Hierarchy Clear Method Apache log4net™ SDK Documentation
Clear all logger definitions from the internal hashtable

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
Remarks

            This call will clear all logger definitions from the internal
            hashtable. Invoking this method will irrevocably mess up the
            logger hierarchy.

            You should really know what you are doing before
            invoking this method.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.Exists Method

Hierarchy Exists Method Apache log4net™ SDK Documentation
Test if a logger exists

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ILogger Exists(
    string name
)
public override ILogger Exists(
    string name
)
Public Overrides Function Exists (
    name As String
) As ILogger
Public Overrides Function Exists (
    name As String
) As ILogger
public:
virtual ILogger^ Exists(
    String^ name
) override
public:
virtual ILogger^ Exists(
    String^ name
) override
Parameters
name
Type:   Online System String
The name of the logger to lookup
Return Value
Type: ILogger
The Logger object with the name specified
Implements
ILoggerRepository Exists(String)
Remarks

            Check if the named logger exists in the hierarchy. If so return
            its reference, otherwise returns null.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.GetAppenders Method

Hierarchy GetAppenders Method Apache log4net™ SDK Documentation
Returns all the Appenders that are currently configured

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IAppender[] GetAppenders()
public override IAppender[] GetAppenders()
Public Overrides Function GetAppenders As IAppender()
Public Overrides Function GetAppenders As IAppender()
public:
virtual array<IAppender^>^ GetAppenders() override
public:
virtual array<IAppender^>^ GetAppenders() override
Return Value
Type:  IAppender
An array containing all the currently configured appenders
Implements
ILoggerRepository GetAppenders
Remarks

            Returns all the IAppender instances that are currently configured.
            All the loggers are searched for appenders. The appenders may also be containers
            for appenders and these are also searched for additional loggers.

            The list returned is unordered but does not contain duplicates.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.GetCurrentLoggers Method

Hierarchy GetCurrentLoggers Method Apache log4net™ SDK Documentation
Returns all the currently defined loggers in the hierarchy as an Array

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ILogger[] GetCurrentLoggers()
public override ILogger[] GetCurrentLoggers()
Public Overrides Function GetCurrentLoggers As ILogger()
Public Overrides Function GetCurrentLoggers As ILogger()
public:
virtual array<ILogger^>^ GetCurrentLoggers() override
public:
virtual array<ILogger^>^ GetCurrentLoggers() override
Return Value
Type:  ILogger
All the defined loggers
Implements
ILoggerRepository GetCurrentLoggers
Remarks

            Returns all the currently defined loggers in the hierarchy as an Array.
            The root logger is not included in the returned
            enumeration.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.GetLogger Method

Hierarchy GetLogger Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | GetLogger(String) | Return a new logger instance named as the first parameter using the default factory. (Overrides LoggerRepositorySkeleton GetLogger(String).)
Public method | GetLogger(String, ILoggerFactory) | Return a new logger instance named as the first parameter using factory.
Back to Top
See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.GetLogger Method (String)

Hierarchy GetLogger Method (String) Apache log4net™ SDK Documentation
Return a new logger instance named as the first parameter using the default factory.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ILogger GetLogger(
    string name
)
public override ILogger GetLogger(
    string name
)
Public Overrides Function GetLogger (
    name As String
) As ILogger
Public Overrides Function GetLogger (
    name As String
) As ILogger
public:
virtual ILogger^ GetLogger(
    String^ name
) override
public:
virtual ILogger^ GetLogger(
    String^ name
) override
Parameters
name
Type:   Online System String
The name of the logger to retrieve
Return Value
Type: ILogger
The logger object with the name specified
Implements
ILoggerRepository GetLogger(String)
Remarks

            Return a new logger instance named as the first parameter using
            the default factory.

            If a logger of that name already exists, then it will be
            returned.  Otherwise, a new logger will be instantiated and
            then linked with its existing ancestors as well as children.

See Also
Hierarchy Class
Hierarchy Members
GetLogger Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.GetLogger Method (String, ILoggerFactory)

Hierarchy GetLogger Method (String, ILoggerFactory) Apache log4net™ SDK Documentation
Return a new logger instance named as the first parameter using factory.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Logger GetLogger(
    string name,
    ILoggerFactory factory
)
public Logger GetLogger(
    string name,
    ILoggerFactory factory
)
Public Function GetLogger (
    name As String,
    factory As ILoggerFactory
) As Logger
Public Function GetLogger (
    name As String,
    factory As ILoggerFactory
) As Logger
public:
Logger^ GetLogger(
    String^ name,
    ILoggerFactory^ factory
)
public:
Logger^ GetLogger(
    String^ name,
    ILoggerFactory^ factory
)
Parameters
name
Type:   Online System String
The name of the logger to retrieve
factory
Type: log4net.Repository.Hierarchy ILoggerFactory
The factory that will make the new logger instance
Return Value
Type: Logger
The logger object with the name specified
Remarks

            If a logger of that name already exists, then it will be
            returned. Otherwise, a new logger will be instantiated by the
            factory parameter and linked with its existing
            ancestors as well as children.

See Also
Hierarchy Class
Hierarchy Members
GetLogger Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.IsDisabled Method

Hierarchy IsDisabled Method Apache log4net™ SDK Documentation
Test if this hierarchy is disabled for the specified Level.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsDisabled(
    Level level
)
public bool IsDisabled(
    Level level
)
Public Function IsDisabled (
    level As Level
) As Boolean
Public Function IsDisabled (
    level As Level
) As Boolean
public:
bool IsDisabled(
    Level^ level
)
public:
bool IsDisabled(
    Level^ level
)
Parameters
level
Type: log4net.Core Level
The level to check against.
Return Value
Type:   Online Boolean
true if the repository is disabled for the level argument, false otherwise.

Remarks

            If this hierarchy has not been configured then this method will
            always return true.

            This method will return true if this repository is
            disabled for level object passed as parameter and
            false otherwise.

            See also the Threshold property.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.Log Method

Hierarchy Log Method Apache log4net™ SDK Documentation
Log the logEvent through this hierarchy.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Log(
    LoggingEvent logEvent
)
public override void Log(
    LoggingEvent logEvent
)
Public Overrides Sub Log (
    logEvent As LoggingEvent
)
Public Overrides Sub Log (
    logEvent As LoggingEvent
)
public:
virtual void Log(
    LoggingEvent^ logEvent
) override
public:
virtual void Log(
    LoggingEvent^ logEvent
) override
Parameters
logEvent
Type: log4net.Core LoggingEvent
the event to log
Implements
ILoggerRepository Log(LoggingEvent)
Remarks

            This method should not normally be used to log.
            The ILog interface should be used
            for routine logging. This interface can be obtained
            using the GetLogger(string) method.

            The logEvent is delivered to the appropriate logger and
            that logger is then responsible for logging the event.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.OnLoggerCreationEvent Method

Hierarchy OnLoggerCreationEvent Method Apache log4net™ SDK Documentation
Sends a logger creation event to all registered listeners

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void OnLoggerCreationEvent(
    Logger logger
)
protected virtual void OnLoggerCreationEvent(
    Logger logger
)
Protected Overridable Sub OnLoggerCreationEvent (
    logger As Logger
)
Protected Overridable Sub OnLoggerCreationEvent (
    logger As Logger
)
protected:
virtual void OnLoggerCreationEvent(
    Logger^ logger
)
protected:
virtual void OnLoggerCreationEvent(
    Logger^ logger
)
Parameters
logger
Type: log4net.Repository.Hierarchy Logger
The newly created logger
Remarks

            Raises the logger creation event.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.ResetConfiguration Method

Hierarchy ResetConfiguration Method Apache log4net™ SDK Documentation
Reset all values contained in this hierarchy instance to their default.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ResetConfiguration()
public override void ResetConfiguration()
Public Overrides Sub ResetConfiguration
Public Overrides Sub ResetConfiguration
public:
virtual void ResetConfiguration() override
public:
virtual void ResetConfiguration() override
Implements
ILoggerRepository ResetConfiguration
Remarks

            Reset all values contained in this hierarchy instance to their
            default.  This removes all appenders from all loggers, sets
            the level of all non-root loggers to null,
            sets their additivity flag to true and sets the level
            of the root logger to Debug. Moreover,
            message disabling is set its default "off" value.

            Existing loggers are not removed. They are just reset.

            This method should be used sparingly and with care as it will
            block all logging until it is completed.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.Shutdown Method

Hierarchy Shutdown Method Apache log4net™ SDK Documentation
Shutting down a hierarchy will safely close and remove all appenders in all loggers including the root logger.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Shutdown()
public override void Shutdown()
Public Overrides Sub Shutdown
Public Overrides Sub Shutdown
public:
virtual void Shutdown() override
public:
virtual void Shutdown() override
Implements
ILoggerRepository Shutdown
Remarks

            Shutting down a hierarchy will safely close and remove
            all appenders in all loggers including the root logger.

            Some appenders need to be closed before the
            application exists. Otherwise, pending logging events might be
            lost.

            The Shutdown method is careful to close nested
            appenders before closing regular appenders. This is allows
            configurations where a regular appender is attached to a logger
            and again to a nested appender.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.XmlRepositoryConfigure Method

Hierarchy XmlRepositoryConfigure Method Apache log4net™ SDK Documentation
Initialize the log4net system using the specified config

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void XmlRepositoryConfigure(
    XmlElement element
)
protected void XmlRepositoryConfigure(
    XmlElement element
)
Protected Sub XmlRepositoryConfigure (
    element As XmlElement
)
Protected Sub XmlRepositoryConfigure (
    element As XmlElement
)
protected:
void XmlRepositoryConfigure(
    XmlElement^ element
)
protected:
void XmlRepositoryConfigure(
    XmlElement^ element
)
Parameters
element
Type:   Online System.Xml XmlElement
the element containing the root of the config
Remarks

            This method provides the same functionality as the
            Configure(IAppender) method implemented
            on this object, but it is protected and therefore can be called by subclasses.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy Properties

Hierarchy Properties Apache log4net™ SDK Documentation
The Hierarchy type exposes the following members.
Properties
 | Name | Description
Public property | ConfigurationMessages | Contains a list of internal messages captures during the last configuration. (Inherited from LoggerRepositorySkeleton.)
Public property | Configured | Flag indicates if this repository has been configured. (Inherited from LoggerRepositorySkeleton.)
Public property | EmittedNoAppenderWarning | Has no appender warning been emitted
Public property | LevelMap | Get the level map for the Repository. (Inherited from LoggerRepositorySkeleton.)
Public property | LoggerFactory | Gets or sets the default ILoggerFactory instance.
Public property | Name | The name of the repository (Inherited from LoggerRepositorySkeleton.)
Public property | PluginMap | The plugin map for this repository. (Inherited from LoggerRepositorySkeleton.)
Public property | Properties | Repository specific properties (Inherited from LoggerRepositorySkeleton.)
Public property | RendererMap | RendererMap accesses the object renderer map for this repository. (Inherited from LoggerRepositorySkeleton.)
Public property | Root | Get the root of this hierarchy
Public property | Threshold | The threshold for all events in this repository (Inherited from LoggerRepositorySkeleton.)
Back to Top
See Also
Hierarchy Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.EmittedNoAppenderWarning Property

Hierarchy EmittedNoAppenderWarning Property Apache log4net™ SDK Documentation
Has no appender warning been emitted

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool EmittedNoAppenderWarning { get; set; }
public bool EmittedNoAppenderWarning { get; set; }
Public Property EmittedNoAppenderWarning As Boolean
    Get
    Set
Public Property EmittedNoAppenderWarning As Boolean
    Get
    Set
public:
property bool EmittedNoAppenderWarning {
    bool get ();
    void set (bool value);
}
public:
property bool EmittedNoAppenderWarning {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
Remarks

            Flag to indicate if we have already issued a warning
            about not having an appender warning.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.LoggerFactory Property

Hierarchy LoggerFactory Property Apache log4net™ SDK Documentation
Gets or sets the default ILoggerFactory instance.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerFactory LoggerFactory { get; set; }
public ILoggerFactory LoggerFactory { get; set; }
Public Property LoggerFactory As ILoggerFactory
    Get
    Set
Public Property LoggerFactory As ILoggerFactory
    Get
    Set
public:
property ILoggerFactory^ LoggerFactory {
    ILoggerFactory^ get ();
    void set (ILoggerFactory^ value);
}
public:
property ILoggerFactory^ LoggerFactory {
    ILoggerFactory^ get ();
    void set (ILoggerFactory^ value);
}
Property Value
Type: ILoggerFactory
The default ILoggerFactory
Remarks

            The logger factory is used to create logger instances.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.Root Property

Hierarchy Root Property Apache log4net™ SDK Documentation
Get the root of this hierarchy

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Logger Root { get; }
public Logger Root { get; }
Public ReadOnly Property Root As Logger
    Get
Public ReadOnly Property Root As Logger
    Get
public:
property Logger^ Root {
    Logger^ get ();
}
public:
property Logger^ Root {
    Logger^ get ();
}
Property Value
Type: Logger
Remarks

            Get the root of this hierarchy.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy Events

Hierarchy Events Apache log4net™ SDK Documentation
The Hierarchy type exposes the following members.
Events
 | Name | Description
Public event | ConfigurationChanged | Event to notify that the repository has had its configuration changed. (Inherited from LoggerRepositorySkeleton.)
Public event | ConfigurationReset | Event to notify that the repository has had its configuration reset. (Inherited from LoggerRepositorySkeleton.)
Public event | LoggerCreatedEvent | Event used to notify that a logger has been created.
Public event | ShutdownEvent | Event to notify that the repository has been shutdown. (Inherited from LoggerRepositorySkeleton.)
Back to Top
See Also
Hierarchy Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Hierarchy.LoggerCreatedEvent Event

Hierarchy LoggerCreatedEvent Event Apache log4net™ SDK Documentation
Event used to notify that a logger has been created.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event LoggerCreationEventHandler LoggerCreatedEvent
public event LoggerCreationEventHandler LoggerCreatedEvent
Public Event LoggerCreatedEvent As LoggerCreationEventHandler
Public Event LoggerCreatedEvent As LoggerCreationEventHandler
public:
 event LoggerCreationEventHandler^ LoggerCreatedEvent {
    void add (LoggerCreationEventHandler^ value);
    void remove (LoggerCreationEventHandler^ value);
}
public:
 event LoggerCreationEventHandler^ LoggerCreatedEvent {
    void add (LoggerCreationEventHandler^ value);
    void remove (LoggerCreationEventHandler^ value);
}
Value
Type: log4net.Repository.Hierarchy LoggerCreationEventHandler
Remarks

            Event raised when a logger is created.

See Also
Hierarchy Class
Hierarchy Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerFactory Interface

ILoggerFactory Interface Apache log4net™ SDK Documentation
Interface abstracts creation of Logger instances

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILoggerFactory
public interface ILoggerFactory
Public Interface ILoggerFactory
Public Interface ILoggerFactory
public interface class ILoggerFactory
public interface class ILoggerFactory
Remarks

            This interface is used by the Hierarchy to
            create new Logger objects.

            The CreateLogger(ILoggerRepository, String) method is called
            to create a named Logger.

            Implement this interface to create new subclasses of Logger.

See Also
ILoggerFactory Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerFactory Members

ILoggerFactory Members Apache log4net™ SDK Documentation
The ILoggerFactory type exposes the following members.
Methods
 | Name | Description
Public method | CreateLogger | Create a new Logger instance
Back to Top
See Also
ILoggerFactory Interface
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerFactory Methods

ILoggerFactory Methods Apache log4net™ SDK Documentation
The ILoggerFactory type exposes the following members.
Methods
 | Name | Description
Public method | CreateLogger | Create a new Logger instance
Back to Top
See Also
ILoggerFactory Interface
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILoggerFactory.CreateLogger Method

ILoggerFactory CreateLogger Method Apache log4net™ SDK Documentation
Create a new Logger instance

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Logger CreateLogger(
    ILoggerRepository repository,
    string name
)
Logger CreateLogger(
    ILoggerRepository repository,
    string name
)
Function CreateLogger (
    repository As ILoggerRepository,
    name As String
) As Logger
Function CreateLogger (
    repository As ILoggerRepository,
    name As String
) As Logger
Logger^ CreateLogger(
    ILoggerRepository^ repository,
    String^ name
)
Logger^ CreateLogger(
    ILoggerRepository^ repository,
    String^ name
)
Parameters
repository
Type: log4net.Repository ILoggerRepository
The ILoggerRepository that will own the Logger.
name
Type:   Online System String
The name of the Logger.
Return Value
Type: Logger
The Logger instance for the specified name.
Remarks

            Create a new Logger instance with the
            specified name.

            Called by the Hierarchy to create
            new named Logger instances.

            If the name is null then the root logger
            must be returned.

See Also
ILoggerFactory Interface
ILoggerFactory Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger Class

Logger Class Apache log4net™ SDK Documentation
Implementation of ILogger used by Hierarchy
Inheritance Hierarchy
Online System Object
log4net.Repository.Hierarchy Logger
log4net.Repository.Hierarchy RootLogger

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Logger : IAppenderAttachable,
    ILogger
public abstract class Logger : IAppenderAttachable,
    ILogger
Public MustInherit Class Logger
    Implements IAppenderAttachable, ILogger
Public MustInherit Class Logger
    Implements IAppenderAttachable, ILogger
public ref class Logger abstract : IAppenderAttachable,
    ILogger
public ref class Logger abstract : IAppenderAttachable,
    ILogger
Remarks

            Internal class used to provide implementation of ILogger
            interface. Applications should use LogManager to get
            logger instances.

            This is one of the central classes in the log4net implementation. One of the
            distinctive features of log4net are hierarchical loggers and their
            evaluation. The Hierarchy organizes the Logger
            instances into a rooted tree hierarchy.

            The Logger class is abstract. Only concrete subclasses of
            Logger can be created. The ILoggerFactory
            is used to create instances of this type for the Hierarchy.

See Also
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger Members

Logger Members Apache log4net™ SDK Documentation
The Logger type exposes the following members.
Constructors
 | Name | Description
Protected method | Logger | This constructor created a new Logger instance and sets its name.
Back to Top
Methods
 | Name | Description
Public method | AddAppender | Add newAppender to the list of appenders of this Logger instance.
Protected method | CallAppenders | Deliver the LoggingEvent to the attached appenders.
Public method | CloseNestedAppenders | Closes all attached appenders implementing the IAppenderAttachable interface.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | ForcedLog(LoggingEvent) | Creates a new logging event and logs the event without further checks.
Protected method | ForcedLog(Type, Level, Object, Exception) | Creates a new logging event and logs the event without further checks.
Public method | GetAppender | Look for the appender named as name
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsEnabledFor | Checks if this logger is enabled for a given Level passed as parameter.
Public method | Log(LoggingEvent) | This is the most generic printing method that is intended to be used by wrappers.
Public method | Log(Level, Object, Exception) | This is the most generic printing method. This generic form is intended to be used by wrappers
Public method | Log(Type, Level, Object, Exception) | This generic form is intended to be used by wrappers.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveAllAppenders | Remove all previously added appenders from this Logger instance.
Public method | RemoveAppender(String) | Remove the appender passed as parameter form the list of appenders.
Public method | RemoveAppender(IAppender) | Remove the appender passed as parameter form the list of appenders.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Additivity | Gets or sets a value indicating if child loggers inherit their parent's appenders.
Public property | Appenders | Get the appenders contained in this logger as an Online ICollection.
Public property | EffectiveLevel | Gets the effective level for this logger.
Public property | Hierarchy | Gets or sets the Hierarchy where this Logger instance is attached to.
Public property | Level | Gets or sets the assigned Level, if any, for this Logger.
Public property | Name | Gets the logger name.
Public property | Parent | Gets or sets the parent logger in the hierarchy.
Public property | Repository | Gets the ILoggerRepository where this Logger instance is attached to.
Back to Top
See Also
Logger Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger Constructor

Logger Constructor Apache log4net™ SDK Documentation
This constructor created a new Logger instance and sets its name.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Logger(
    string name
)
protected Logger(
    string name
)
Protected Sub New (
    name As String
)
Protected Sub New (
    name As String
)
protected:
Logger(
    String^ name
)
protected:
Logger(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the Logger.
Remarks

            This constructor is protected and designed to be used by
            a subclass that is not abstract.

            Loggers are constructed by ILoggerFactory
            objects. See DefaultLoggerFactory for the default
            logger creator.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger Methods

Logger Methods Apache log4net™ SDK Documentation
The Logger type exposes the following members.
Methods
 | Name | Description
Public method | AddAppender | Add newAppender to the list of appenders of this Logger instance.
Protected method | CallAppenders | Deliver the LoggingEvent to the attached appenders.
Public method | CloseNestedAppenders | Closes all attached appenders implementing the IAppenderAttachable interface.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | ForcedLog(LoggingEvent) | Creates a new logging event and logs the event without further checks.
Protected method | ForcedLog(Type, Level, Object, Exception) | Creates a new logging event and logs the event without further checks.
Public method | GetAppender | Look for the appender named as name
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsEnabledFor | Checks if this logger is enabled for a given Level passed as parameter.
Public method | Log(LoggingEvent) | This is the most generic printing method that is intended to be used by wrappers.
Public method | Log(Level, Object, Exception) | This is the most generic printing method. This generic form is intended to be used by wrappers
Public method | Log(Type, Level, Object, Exception) | This generic form is intended to be used by wrappers.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveAllAppenders | Remove all previously added appenders from this Logger instance.
Public method | RemoveAppender(String) | Remove the appender passed as parameter form the list of appenders.
Public method | RemoveAppender(IAppender) | Remove the appender passed as parameter form the list of appenders.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Logger Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.AddAppender Method

Logger AddAppender Method Apache log4net™ SDK Documentation
Add newAppender to the list of appenders of this Logger instance.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddAppender(
    IAppender newAppender
)
public virtual void AddAppender(
    IAppender newAppender
)
Public Overridable Sub AddAppender (
    newAppender As IAppender
)
Public Overridable Sub AddAppender (
    newAppender As IAppender
)
public:
virtual void AddAppender(
    IAppender^ newAppender
)
public:
virtual void AddAppender(
    IAppender^ newAppender
)
Parameters
newAppender
Type: log4net.Appender IAppender
An appender to add to this logger
Implements
IAppenderAttachable AddAppender(IAppender)
Remarks

            Add newAppender to the list of appenders of this
            Logger instance.

            If newAppender is already in the list of
            appenders, then it won't be added again.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.CallAppenders Method

Logger CallAppenders Method Apache log4net™ SDK Documentation
Deliver the LoggingEvent to the attached appenders.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void CallAppenders(
    LoggingEvent loggingEvent
)
protected virtual void CallAppenders(
    LoggingEvent loggingEvent
)
Protected Overridable Sub CallAppenders (
    loggingEvent As LoggingEvent
)
Protected Overridable Sub CallAppenders (
    loggingEvent As LoggingEvent
)
protected:
virtual void CallAppenders(
    LoggingEvent^ loggingEvent
)
protected:
virtual void CallAppenders(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to log.
Remarks

            Call the appenders in the hierarchy starting at
            this. If no appenders could be found, emit a
            warning.

            This method calls all the appenders inherited from the
            hierarchy circumventing any evaluation of whether to log or not
            to log the particular log request.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.CloseNestedAppenders Method

Logger CloseNestedAppenders Method Apache log4net™ SDK Documentation
Closes all attached appenders implementing the IAppenderAttachable interface.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void CloseNestedAppenders()
public virtual void CloseNestedAppenders()
Public Overridable Sub CloseNestedAppenders
Public Overridable Sub CloseNestedAppenders
public:
virtual void CloseNestedAppenders()
public:
virtual void CloseNestedAppenders()
Remarks

            Used to ensure that the appenders are correctly shutdown.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.ForcedLog Method

Logger ForcedLog Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Protected method | ForcedLog(LoggingEvent) | Creates a new logging event and logs the event without further checks.
Protected method | ForcedLog(Type, Level, Object, Exception) | Creates a new logging event and logs the event without further checks.
Back to Top
See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.ForcedLog Method (LoggingEvent)

Logger ForcedLog Method (LoggingEvent) Apache log4net™ SDK Documentation
Creates a new logging event and logs the event without further checks.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void ForcedLog(
    LoggingEvent logEvent
)
protected virtual void ForcedLog(
    LoggingEvent logEvent
)
Protected Overridable Sub ForcedLog (
    logEvent As LoggingEvent
)
Protected Overridable Sub ForcedLog (
    logEvent As LoggingEvent
)
protected:
virtual void ForcedLog(
    LoggingEvent^ logEvent
)
protected:
virtual void ForcedLog(
    LoggingEvent^ logEvent
)
Parameters
logEvent
Type: log4net.Core LoggingEvent
The event being logged.
Remarks

            Delivers the logging event to the attached appenders.

See Also
Logger Class
Logger Members
ForcedLog Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.ForcedLog Method (Type, Level, Object, Exception)

Logger ForcedLog Method (Type, Level, Object, Exception) Apache log4net™ SDK Documentation
Creates a new logging event and logs the event without further checks.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void ForcedLog(
    Type callerStackBoundaryDeclaringType,
    Level level,
    Object message,
    Exception exception
)
protected virtual void ForcedLog(
    Type callerStackBoundaryDeclaringType,
    Level level,
    Object message,
    Exception exception
)
Protected Overridable Sub ForcedLog (
    callerStackBoundaryDeclaringType As Type,
    level As Level,
    message As Object,
    exception As Exception
)
Protected Overridable Sub ForcedLog (
    callerStackBoundaryDeclaringType As Type,
    level As Level,
    message As Object,
    exception As Exception
)
protected:
virtual void ForcedLog(
    Type^ callerStackBoundaryDeclaringType,
    Level^ level,
    Object^ message,
    Exception^ exception
)
protected:
virtual void ForcedLog(
    Type^ callerStackBoundaryDeclaringType,
    Level^ level,
    Object^ message,
    Exception^ exception
)
Parameters
callerStackBoundaryDeclaringType
Type:   Online System Type
The declaring type of the method that is
            the stack boundary into the logging system for this call.
level
Type: log4net.Core Level
The level of the message to be logged.
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Remarks

            Generates a logging event and delivers it to the attached
            appenders.

See Also
Logger Class
Logger Members
ForcedLog Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.GetAppender Method

Logger GetAppender Method Apache log4net™ SDK Documentation
Look for the appender named as name

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IAppender GetAppender(
    string name
)
public virtual IAppender GetAppender(
    string name
)
Public Overridable Function GetAppender (
    name As String
) As IAppender
Public Overridable Function GetAppender (
    name As String
) As IAppender
public:
virtual IAppender^ GetAppender(
    String^ name
)
public:
virtual IAppender^ GetAppender(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the appender to lookup
Return Value
Type: IAppender
The appender with the name specified, or null.
Implements
IAppenderAttachable GetAppender(String)
Remarks

            Returns the named appender, or null if the appender is not found.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.IsEnabledFor Method

Logger IsEnabledFor Method Apache log4net™ SDK Documentation
Checks if this logger is enabled for a given Level passed as parameter.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsEnabledFor(
    Level level
)
public virtual bool IsEnabledFor(
    Level level
)
Public Overridable Function IsEnabledFor (
    level As Level
) As Boolean
Public Overridable Function IsEnabledFor (
    level As Level
) As Boolean
public:
virtual bool IsEnabledFor(
    Level^ level
)
public:
virtual bool IsEnabledFor(
    Level^ level
)
Parameters
level
Type: log4net.Core Level
The level to check.
Return Value
Type:   Online Boolean
true if this logger is enabled for level, otherwise false.

Implements
ILogger IsEnabledFor(Level)
Remarks

            Test if this logger is going to log events of the specified level.

            This method must not throw any exception to the caller.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.Log Method

Logger Log Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Log(LoggingEvent) | This is the most generic printing method that is intended to be used by wrappers.
Public method | Log(Level, Object, Exception) | This is the most generic printing method. This generic form is intended to be used by wrappers
Public method | Log(Type, Level, Object, Exception) | This generic form is intended to be used by wrappers.
Back to Top
See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.Log Method (LoggingEvent)

Logger Log Method (LoggingEvent) Apache log4net™ SDK Documentation
This is the most generic printing method that is intended to be used by wrappers.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Log(
    LoggingEvent logEvent
)
public virtual void Log(
    LoggingEvent logEvent
)
Public Overridable Sub Log (
    logEvent As LoggingEvent
)
Public Overridable Sub Log (
    logEvent As LoggingEvent
)
public:
virtual void Log(
    LoggingEvent^ logEvent
)
public:
virtual void Log(
    LoggingEvent^ logEvent
)
Parameters
logEvent
Type: log4net.Core LoggingEvent
The event being logged.
Implements
ILogger Log(LoggingEvent)
Remarks

            Logs the specified logging event through this logger.

            This method must not throw any exception to the caller.

See Also
Logger Class
Logger Members
Log Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.Log Method (Level, Object, Exception)

Logger Log Method (Level, Object, Exception) Apache log4net™ SDK Documentation
This is the most generic printing method. This generic form is intended to be used by wrappers

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Log(
    Level level,
    Object message,
    Exception exception
)
public virtual void Log(
    Level level,
    Object message,
    Exception exception
)
Public Overridable Sub Log (
    level As Level,
    message As Object,
    exception As Exception
)
Public Overridable Sub Log (
    level As Level,
    message As Object,
    exception As Exception
)
public:
virtual void Log(
    Level^ level,
    Object^ message,
    Exception^ exception
)
public:
virtual void Log(
    Level^ level,
    Object^ message,
    Exception^ exception
)
Parameters
level
Type: log4net.Core Level
The level of the message to be logged.
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Remarks

            Generate a logging event for the specified level using
            the message.

See Also
Logger Class
Logger Members
Log Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.Log Method (Type, Level, Object, Exception)

Logger Log Method (Type, Level, Object, Exception) Apache log4net™ SDK Documentation
This generic form is intended to be used by wrappers.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Log(
    Type callerStackBoundaryDeclaringType,
    Level level,
    Object message,
    Exception exception
)
public virtual void Log(
    Type callerStackBoundaryDeclaringType,
    Level level,
    Object message,
    Exception exception
)
Public Overridable Sub Log (
    callerStackBoundaryDeclaringType As Type,
    level As Level,
    message As Object,
    exception As Exception
)
Public Overridable Sub Log (
    callerStackBoundaryDeclaringType As Type,
    level As Level,
    message As Object,
    exception As Exception
)
public:
virtual void Log(
    Type^ callerStackBoundaryDeclaringType,
    Level^ level,
    Object^ message,
    Exception^ exception
)
public:
virtual void Log(
    Type^ callerStackBoundaryDeclaringType,
    Level^ level,
    Object^ message,
    Exception^ exception
)
Parameters
callerStackBoundaryDeclaringType
Type:   Online System Type
The declaring type of the method that is
            the stack boundary into the logging system for this call.
level
Type: log4net.Core Level
The level of the message to be logged.
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Implements
ILogger Log(Type, Level, Object, Exception)
Remarks

            Generate a logging event for the specified level using
            the message and exception.

            This method must not throw any exception to the caller.

See Also
Logger Class
Logger Members
Log Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.RemoveAllAppenders Method

Logger RemoveAllAppenders Method Apache log4net™ SDK Documentation
Remove all previously added appenders from this Logger instance.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void RemoveAllAppenders()
public virtual void RemoveAllAppenders()
Public Overridable Sub RemoveAllAppenders
Public Overridable Sub RemoveAllAppenders
public:
virtual void RemoveAllAppenders()
public:
virtual void RemoveAllAppenders()
Implements
IAppenderAttachable RemoveAllAppenders
Remarks

            Remove all previously added appenders from this Logger instance.

            This is useful when re-reading configuration information.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.RemoveAppender Method

Logger RemoveAppender Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | RemoveAppender(String) | Remove the appender passed as parameter form the list of appenders.
Public method | RemoveAppender(IAppender) | Remove the appender passed as parameter form the list of appenders.
Back to Top
See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.RemoveAppender Method (String)

Logger RemoveAppender Method (String) Apache log4net™ SDK Documentation
Remove the appender passed as parameter form the list of appenders.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IAppender RemoveAppender(
    string name
)
public virtual IAppender RemoveAppender(
    string name
)
Public Overridable Function RemoveAppender (
    name As String
) As IAppender
Public Overridable Function RemoveAppender (
    name As String
) As IAppender
public:
virtual IAppender^ RemoveAppender(
    String^ name
)
public:
virtual IAppender^ RemoveAppender(
    String^ name
)
Parameters
name
Type:   Online System String
The name of the appender to remove
Return Value
Type: IAppender
The appender removed from the list
Implements
IAppenderAttachable RemoveAppender(String)
Remarks

            Remove the named appender passed as parameter form the list of appenders.
            The appender removed is not closed.
            If you are discarding the appender you must call
            Close  on the appender removed.

See Also
Logger Class
Logger Members
RemoveAppender Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.RemoveAppender Method (IAppender)

Logger RemoveAppender Method (IAppender) Apache log4net™ SDK Documentation
Remove the appender passed as parameter form the list of appenders.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IAppender RemoveAppender(
    IAppender appender
)
public virtual IAppender RemoveAppender(
    IAppender appender
)
Public Overridable Function RemoveAppender (
    appender As IAppender
) As IAppender
Public Overridable Function RemoveAppender (
    appender As IAppender
) As IAppender
public:
virtual IAppender^ RemoveAppender(
    IAppender^ appender
)
public:
virtual IAppender^ RemoveAppender(
    IAppender^ appender
)
Parameters
appender
Type: log4net.Appender IAppender
The appender to remove
Return Value
Type: IAppender
The appender removed from the list
Implements
IAppenderAttachable RemoveAppender(IAppender)
Remarks

            Remove the appender passed as parameter form the list of appenders.
            The appender removed is not closed.
            If you are discarding the appender you must call
            Close  on the appender removed.

See Also
Logger Class
Logger Members
RemoveAppender Overload
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger Properties

Logger Properties Apache log4net™ SDK Documentation
The Logger type exposes the following members.
Properties
 | Name | Description
Public property | Additivity | Gets or sets a value indicating if child loggers inherit their parent's appenders.
Public property | Appenders | Get the appenders contained in this logger as an Online ICollection.
Public property | EffectiveLevel | Gets the effective level for this logger.
Public property | Hierarchy | Gets or sets the Hierarchy where this Logger instance is attached to.
Public property | Level | Gets or sets the assigned Level, if any, for this Logger.
Public property | Name | Gets the logger name.
Public property | Parent | Gets or sets the parent logger in the hierarchy.
Public property | Repository | Gets the ILoggerRepository where this Logger instance is attached to.
Back to Top
See Also
Logger Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.Additivity Property

Logger Additivity Property Apache log4net™ SDK Documentation
Gets or sets a value indicating if child loggers inherit their parent's appenders.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Additivity { get; set; }
public virtual bool Additivity { get; set; }
Public Overridable Property Additivity As Boolean
    Get
    Set
Public Overridable Property Additivity As Boolean
    Get
    Set
public:
virtual property bool Additivity {
    bool get ();
    void set (bool value);
}
public:
virtual property bool Additivity {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if child loggers inherit their parent's appenders.

Remarks

            Additivity is set to true by default, that is children inherit
            the appenders of their ancestors by default. If this variable is
            set to false then the appenders found in the
            ancestors of this logger are not used. However, the children
            of this logger will inherit its appenders, unless the children
            have their additivity flag set to false too. See
            the user manual for more details.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.Appenders Property

Logger Appenders Property Apache log4net™ SDK Documentation
Get the appenders contained in this logger as an Online ICollection.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual AppenderCollection Appenders { get; }
public virtual AppenderCollection Appenders { get; }
Public Overridable ReadOnly Property Appenders As AppenderCollection
    Get
Public Overridable ReadOnly Property Appenders As AppenderCollection
    Get
public:
virtual property AppenderCollection^ Appenders {
    AppenderCollection^ get ();
}
public:
virtual property AppenderCollection^ Appenders {
    AppenderCollection^ get ();
}
Return Value
Type: AppenderCollection
A collection of the appenders in this logger
Implements
IAppenderAttachable Appenders
Remarks

            Get the appenders contained in this logger as an
              Online ICollection. If no appenders
            can be found, then a EmptyCollection is returned.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.EffectiveLevel Property

Logger EffectiveLevel Property Apache log4net™ SDK Documentation
Gets the effective level for this logger.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Level EffectiveLevel { get; }
public virtual Level EffectiveLevel { get; }
Public Overridable ReadOnly Property EffectiveLevel As Level
    Get
Public Overridable ReadOnly Property EffectiveLevel As Level
    Get
public:
virtual property Level^ EffectiveLevel {
    Level^ get ();
}
public:
virtual property Level^ EffectiveLevel {
    Level^ get ();
}
Return Value
Type: Level
The nearest level in the logger hierarchy.
Remarks

            Starting from this logger, searches the logger hierarchy for a
            non-null level and returns it. Otherwise, returns the level of the
            root logger.

The Logger class is designed so that this method executes as
            quickly as possible.
See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.Hierarchy Property

Logger Hierarchy Property Apache log4net™ SDK Documentation
Gets or sets the Hierarchy where this Logger instance is attached to.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Hierarchy Hierarchy { get; set; }
public virtual Hierarchy Hierarchy { get; set; }
Public Overridable Property Hierarchy As Hierarchy
    Get
    Set
Public Overridable Property Hierarchy As Hierarchy
    Get
    Set
public:
virtual property Hierarchy^ Hierarchy {
    Hierarchy^ get ();
    void set (Hierarchy^ value);
}
public:
virtual property Hierarchy^ Hierarchy {
    Hierarchy^ get ();
    void set (Hierarchy^ value);
}
Property Value
Type: Hierarchy
The hierarchy that this logger belongs to.
Remarks

            This logger must be attached to a single Hierarchy.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.Level Property

Logger Level Property Apache log4net™ SDK Documentation
Gets or sets the assigned Level, if any, for this Logger.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Level Level { get; set; }
public virtual Level Level { get; set; }
Public Overridable Property Level As Level
    Get
    Set
Public Overridable Property Level As Level
    Get
    Set
public:
virtual property Level^ Level {
    Level^ get ();
    void set (Level^ value);
}
public:
virtual property Level^ Level {
    Level^ get ();
    void set (Level^ value);
}
Property Value
Type: Level

            The Level of this logger.

Remarks

            The assigned Level can be null.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.Name Property

Logger Name Property Apache log4net™ SDK Documentation
Gets the logger name.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Name { get; }
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}
public:
virtual property String^ Name {
    String^ get ();
}
Property Value
Type:   Online String

            The name of the logger.

Implements
ILogger Name
Remarks

            The name of this logger

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.Parent Property

Logger Parent Property Apache log4net™ SDK Documentation
Gets or sets the parent logger in the hierarchy.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Logger Parent { get; set; }
public virtual Logger Parent { get; set; }
Public Overridable Property Parent As Logger
    Get
    Set
Public Overridable Property Parent As Logger
    Get
    Set
public:
virtual property Logger^ Parent {
    Logger^ get ();
    void set (Logger^ value);
}
public:
virtual property Logger^ Parent {
    Logger^ get ();
    void set (Logger^ value);
}
Property Value
Type: Logger

            The parent logger in the hierarchy.

Remarks

            Part of the Composite pattern that makes the hierarchy.
            The hierarchy is parent linked rather than child linked.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Logger.Repository Property

Logger Repository Property Apache log4net™ SDK Documentation
Gets the ILoggerRepository where this Logger instance is attached to.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILoggerRepository Repository { get; }
public ILoggerRepository Repository { get; }
Public ReadOnly Property Repository As ILoggerRepository
    Get
Public ReadOnly Property Repository As ILoggerRepository
    Get
public:
virtual property ILoggerRepository^ Repository {
    ILoggerRepository^ get () sealed;
}
public:
virtual property ILoggerRepository^ Repository {
    ILoggerRepository^ get () sealed;
}
Property Value
Type: ILoggerRepository

            The ILoggerRepository that this logger belongs to.

Implements
ILogger Repository
Remarks

            Gets the ILoggerRepository where this
            Logger instance is attached to.

See Also
Logger Class
Logger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerCreationEventArgs Class

LoggerCreationEventArgs Class Apache log4net™ SDK Documentation
Provides data for the LoggerCreatedEvent event.
Inheritance Hierarchy
Online System Object
Online System EventArgs
log4net.Repository.Hierarchy LoggerCreationEventArgs

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LoggerCreationEventArgs : EventArgs
public class LoggerCreationEventArgs : EventArgs
Public Class LoggerCreationEventArgs
    Inherits EventArgs
Public Class LoggerCreationEventArgs
    Inherits EventArgs
public ref class LoggerCreationEventArgs : public EventArgs
public ref class LoggerCreationEventArgs : public EventArgs
Remarks

            A LoggerCreatedEvent event is raised every time a
            Logger is created.

See Also
LoggerCreationEventArgs Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerCreationEventArgs Members

LoggerCreationEventArgs Members Apache log4net™ SDK Documentation
The LoggerCreationEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | LoggerCreationEventArgs | Constructor
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Logger | Gets the Logger that has been created.
Back to Top
See Also
LoggerCreationEventArgs Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerCreationEventArgs Constructor

LoggerCreationEventArgs Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggerCreationEventArgs(
    Logger log
)
public LoggerCreationEventArgs(
    Logger log
)
Public Sub New (
    log As Logger
)
Public Sub New (
    log As Logger
)
public:
LoggerCreationEventArgs(
    Logger^ log
)
public:
LoggerCreationEventArgs(
    Logger^ log
)
Parameters
log
Type: log4net.Repository.Hierarchy Logger
The Logger that has been created.
Remarks

            Initializes a new instance of the LoggerCreationEventArgs event argument
            class,with the specified Logger.

See Also
LoggerCreationEventArgs Class
LoggerCreationEventArgs Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerCreationEventArgs Methods

LoggerCreationEventArgs Methods Apache log4net™ SDK Documentation
The LoggerCreationEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LoggerCreationEventArgs Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerCreationEventArgs Properties

LoggerCreationEventArgs Properties Apache log4net™ SDK Documentation
The LoggerCreationEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets the Logger that has been created.
Back to Top
See Also
LoggerCreationEventArgs Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerCreationEventArgs.Logger Property

LoggerCreationEventArgs Logger Property Apache log4net™ SDK Documentation
Gets the Logger that has been created.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Logger Logger { get; }
public Logger Logger { get; }
Public ReadOnly Property Logger As Logger
    Get
Public ReadOnly Property Logger As Logger
    Get
public:
property Logger^ Logger {
    Logger^ get ();
}
public:
property Logger^ Logger {
    Logger^ get ();
}
Property Value
Type: Logger

            The Logger that has been created.

Remarks

            The Logger that has been created.

See Also
LoggerCreationEventArgs Class
LoggerCreationEventArgs Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LoggerCreationEventHandler Delegate

LoggerCreationEventHandler Delegate Apache log4net™ SDK Documentation
Delegate used to handle logger creation event notifications.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void LoggerCreationEventHandler(
    Object sender,
    LoggerCreationEventArgs e
)
public delegate void LoggerCreationEventHandler(
    Object sender,
    LoggerCreationEventArgs e
)
Public Delegate Sub LoggerCreationEventHandler (
    sender As Object,
    e As LoggerCreationEventArgs
)
Public Delegate Sub LoggerCreationEventHandler (
    sender As Object,
    e As LoggerCreationEventArgs
)
public delegate void LoggerCreationEventHandler(
    Object^ sender,
    LoggerCreationEventArgs^ e
)
public delegate void LoggerCreationEventHandler(
    Object^ sender,
    LoggerCreationEventArgs^ e
)
Parameters
sender
Type:   Online System Object
The Hierarchy in which the Logger has been created.
e
Type: log4net.Repository.Hierarchy LoggerCreationEventArgs
The LoggerCreationEventArgs event args that hold the Logger instance that has been created.
Remarks

            Delegate used to handle logger creation event notifications.

See Also
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RootLogger Class

RootLogger Class Apache log4net™ SDK Documentation
The RootLogger sits at the root of the logger hierarchy tree.
Inheritance Hierarchy
Online System Object
log4net.Repository.Hierarchy Logger
log4net.Repository.Hierarchy RootLogger

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RootLogger : Logger
public class RootLogger : Logger
Public Class RootLogger
    Inherits Logger
Public Class RootLogger
    Inherits Logger
public ref class RootLogger : public Logger
public ref class RootLogger : public Logger
Remarks

            The RootLogger is a regular Logger except
            that it provides several guarantees.

            First, it cannot be assigned a null
            level. Second, since the root logger cannot have a parent, the
            EffectiveLevel property always returns the value of the
            level field without walking the hierarchy.

See Also
RootLogger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RootLogger Members

RootLogger Members Apache log4net™ SDK Documentation
The RootLogger type exposes the following members.
Constructors
 | Name | Description
Public method | RootLogger | Construct a RootLogger
Back to Top
Methods
 | Name | Description
Public method | AddAppender | Add newAppender to the list of appenders of this Logger instance. (Inherited from Logger.)
Protected method | CallAppenders | Deliver the LoggingEvent to the attached appenders. (Inherited from Logger.)
Public method | CloseNestedAppenders | Closes all attached appenders implementing the IAppenderAttachable interface. (Inherited from Logger.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | ForcedLog(LoggingEvent) | Creates a new logging event and logs the event without further checks. (Inherited from Logger.)
Protected method | ForcedLog(Type, Level, Object, Exception) | Creates a new logging event and logs the event without further checks. (Inherited from Logger.)
Public method | GetAppender | Look for the appender named as name (Inherited from Logger.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsEnabledFor | Checks if this logger is enabled for a given Level passed as parameter. (Inherited from Logger.)
Public method | Log(LoggingEvent) | This is the most generic printing method that is intended to be used by wrappers. (Inherited from Logger.)
Public method | Log(Level, Object, Exception) | This is the most generic printing method. This generic form is intended to be used by wrappers (Inherited from Logger.)
Public method | Log(Type, Level, Object, Exception) | This generic form is intended to be used by wrappers. (Inherited from Logger.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveAllAppenders | Remove all previously added appenders from this Logger instance. (Inherited from Logger.)
Public method | RemoveAppender(String) | Remove the appender passed as parameter form the list of appenders. (Inherited from Logger.)
Public method | RemoveAppender(IAppender) | Remove the appender passed as parameter form the list of appenders. (Inherited from Logger.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Additivity | Gets or sets a value indicating if child loggers inherit their parent's appenders. (Inherited from Logger.)
Public property | Appenders | Get the appenders contained in this logger as an Online ICollection. (Inherited from Logger.)
Public property | EffectiveLevel | Gets the assigned level value without walking the logger hierarchy. (Overrides Logger EffectiveLevel.)
Public property | Hierarchy | Gets or sets the Hierarchy where this Logger instance is attached to. (Inherited from Logger.)
Public property | Level | Gets or sets the assigned Level for the root logger. (Overrides Logger Level.)
Public property | Name | Gets the logger name. (Inherited from Logger.)
Public property | Parent | Gets or sets the parent logger in the hierarchy. (Inherited from Logger.)
Public property | Repository | Gets the ILoggerRepository where this Logger instance is attached to. (Inherited from Logger.)
Back to Top
See Also
RootLogger Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RootLogger Constructor

RootLogger Constructor Apache log4net™ SDK Documentation
Construct a RootLogger

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RootLogger(
    Level level
)
public RootLogger(
    Level level
)
Public Sub New (
    level As Level
)
Public Sub New (
    level As Level
)
public:
RootLogger(
    Level^ level
)
public:
RootLogger(
    Level^ level
)
Parameters
level
Type: log4net.Core Level
The level to assign to the root logger.
Remarks

            Initializes a new instance of the RootLogger class with
            the specified logging level.

            The root logger names itself as "root". However, the root
            logger cannot be retrieved by name.

See Also
RootLogger Class
RootLogger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RootLogger Methods

RootLogger Methods Apache log4net™ SDK Documentation
The RootLogger type exposes the following members.
Methods
 | Name | Description
Public method | AddAppender | Add newAppender to the list of appenders of this Logger instance. (Inherited from Logger.)
Protected method | CallAppenders | Deliver the LoggingEvent to the attached appenders. (Inherited from Logger.)
Public method | CloseNestedAppenders | Closes all attached appenders implementing the IAppenderAttachable interface. (Inherited from Logger.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | ForcedLog(LoggingEvent) | Creates a new logging event and logs the event without further checks. (Inherited from Logger.)
Protected method | ForcedLog(Type, Level, Object, Exception) | Creates a new logging event and logs the event without further checks. (Inherited from Logger.)
Public method | GetAppender | Look for the appender named as name (Inherited from Logger.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsEnabledFor | Checks if this logger is enabled for a given Level passed as parameter. (Inherited from Logger.)
Public method | Log(LoggingEvent) | This is the most generic printing method that is intended to be used by wrappers. (Inherited from Logger.)
Public method | Log(Level, Object, Exception) | This is the most generic printing method. This generic form is intended to be used by wrappers (Inherited from Logger.)
Public method | Log(Type, Level, Object, Exception) | This generic form is intended to be used by wrappers. (Inherited from Logger.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveAllAppenders | Remove all previously added appenders from this Logger instance. (Inherited from Logger.)
Public method | RemoveAppender(String) | Remove the appender passed as parameter form the list of appenders. (Inherited from Logger.)
Public method | RemoveAppender(IAppender) | Remove the appender passed as parameter form the list of appenders. (Inherited from Logger.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RootLogger Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RootLogger Properties

RootLogger Properties Apache log4net™ SDK Documentation
The RootLogger type exposes the following members.
Properties
 | Name | Description
Public property | Additivity | Gets or sets a value indicating if child loggers inherit their parent's appenders. (Inherited from Logger.)
Public property | Appenders | Get the appenders contained in this logger as an Online ICollection. (Inherited from Logger.)
Public property | EffectiveLevel | Gets the assigned level value without walking the logger hierarchy. (Overrides Logger EffectiveLevel.)
Public property | Hierarchy | Gets or sets the Hierarchy where this Logger instance is attached to. (Inherited from Logger.)
Public property | Level | Gets or sets the assigned Level for the root logger. (Overrides Logger Level.)
Public property | Name | Gets the logger name. (Inherited from Logger.)
Public property | Parent | Gets or sets the parent logger in the hierarchy. (Inherited from Logger.)
Public property | Repository | Gets the ILoggerRepository where this Logger instance is attached to. (Inherited from Logger.)
Back to Top
See Also
RootLogger Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RootLogger.EffectiveLevel Property

RootLogger EffectiveLevel Property Apache log4net™ SDK Documentation
Gets the assigned level value without walking the logger hierarchy.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Level EffectiveLevel { get; }
public override Level EffectiveLevel { get; }
Public Overrides ReadOnly Property EffectiveLevel As Level
    Get
Public Overrides ReadOnly Property EffectiveLevel As Level
    Get
public:
virtual property Level^ EffectiveLevel {
    Level^ get () override;
}
public:
virtual property Level^ EffectiveLevel {
    Level^ get () override;
}
Property Value
Type: Level
The assigned level value without walking the logger hierarchy.
Remarks

            Because the root logger cannot have a parent and its level
            must not be null this property just returns the
            value of Level.

See Also
RootLogger Class
RootLogger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


RootLogger.Level Property

RootLogger Level Property Apache log4net™ SDK Documentation
Gets or sets the assigned Level for the root logger.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Level Level { get; set; }
public override Level Level { get; set; }
Public Overrides Property Level As Level
    Get
    Set
Public Overrides Property Level As Level
    Get
    Set
public:
virtual property Level^ Level {
    Level^ get () override;
    void set (Level^ value) override;
}
public:
virtual property Level^ Level {
    Level^ get () override;
    void set (Level^ value) override;
}
Property Value
Type: Level

            The Level of the root logger.

Remarks

            Setting the level of the root logger to a null reference
            may have catastrophic results. We prevent this here.

See Also
RootLogger Class
RootLogger Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator Class

XmlHierarchyConfigurator Class Apache log4net™ SDK Documentation
Initializes the log4net environment using an XML DOM.
Inheritance Hierarchy
Online System Object
log4net.Repository.Hierarchy XmlHierarchyConfigurator

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class XmlHierarchyConfigurator
public class XmlHierarchyConfigurator
Public Class XmlHierarchyConfigurator
Public Class XmlHierarchyConfigurator
public ref class XmlHierarchyConfigurator
public ref class XmlHierarchyConfigurator
Remarks

            Configures a Hierarchy using an XML DOM.

See Also
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator Members

XmlHierarchyConfigurator Members Apache log4net™ SDK Documentation
The XmlHierarchyConfigurator type exposes the following members.
Constructors
 | Name | Description
Public method | XmlHierarchyConfigurator | Construct the configurator for a hierarchy
Back to Top
Methods
 | Name | Description
Public method | Configure | Configure the hierarchy by parsing a DOM tree of XML elements.
Protected method | ConvertStringTo | Converts a string value to a target type.
Protected method | CreateObjectFromXml | Creates an object as specified in XML.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | FindAppenderByReference | Parse appenders by IDREF.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ParseAppender | Parses an appender element.
Protected method | ParseChildrenOfLoggerElement | Parses the children of a logger element.
Protected method | ParseLevel | Parses a level element.
Protected method | ParseLogger | Parses a logger element.
Protected method | ParseRenderer | Parses an object renderer.
Protected method | ParseRoot | Parses the root logger element.
Protected method | SetParameter | Sets a parameter on an object.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
XmlHierarchyConfigurator Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator Constructor

XmlHierarchyConfigurator Constructor Apache log4net™ SDK Documentation
Construct the configurator for a hierarchy

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public XmlHierarchyConfigurator(
    Hierarchy hierarchy
)
public XmlHierarchyConfigurator(
    Hierarchy hierarchy
)
Public Sub New (
    hierarchy As Hierarchy
)
Public Sub New (
    hierarchy As Hierarchy
)
public:
XmlHierarchyConfigurator(
    Hierarchy^ hierarchy
)
public:
XmlHierarchyConfigurator(
    Hierarchy^ hierarchy
)
Parameters
hierarchy
Type: log4net.Repository.Hierarchy Hierarchy
The hierarchy to build.
Remarks

            Initializes a new instance of the XmlHierarchyConfigurator class
            with the specified Hierarchy.

See Also
XmlHierarchyConfigurator Class
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator Methods

XmlHierarchyConfigurator Methods Apache log4net™ SDK Documentation
The XmlHierarchyConfigurator type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configure the hierarchy by parsing a DOM tree of XML elements.
Protected method | ConvertStringTo | Converts a string value to a target type.
Protected method | CreateObjectFromXml | Creates an object as specified in XML.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | FindAppenderByReference | Parse appenders by IDREF.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ParseAppender | Parses an appender element.
Protected method | ParseChildrenOfLoggerElement | Parses the children of a logger element.
Protected method | ParseLevel | Parses a level element.
Protected method | ParseLogger | Parses a logger element.
Protected method | ParseRenderer | Parses an object renderer.
Protected method | ParseRoot | Parses the root logger element.
Protected method | SetParameter | Sets a parameter on an object.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
XmlHierarchyConfigurator Class
log4net.Repository.Hierarchy Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator.Configure Method

XmlHierarchyConfigurator Configure Method Apache log4net™ SDK Documentation
Configure the hierarchy by parsing a DOM tree of XML elements.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    XmlElement element
)
public void Configure(
    XmlElement element
)
Public Sub Configure (
    element As XmlElement
)
Public Sub Configure (
    element As XmlElement
)
public:
void Configure(
    XmlElement^ element
)
public:
void Configure(
    XmlElement^ element
)
Parameters
element
Type:   Online System.Xml XmlElement
The root element to parse.
Remarks

            Configure the hierarchy by parsing a DOM tree of XML elements.

See Also
XmlHierarchyConfigurator Class
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator.ConvertStringTo Method

XmlHierarchyConfigurator ConvertStringTo Method Apache log4net™ SDK Documentation
Converts a string value to a target type.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Object ConvertStringTo(
    Type type,
    string value
)
protected Object ConvertStringTo(
    Type type,
    string value
)
Protected Function ConvertStringTo (
    type As Type,
    value As String
) As Object
Protected Function ConvertStringTo (
    type As Type,
    value As String
) As Object
protected:
Object^ ConvertStringTo(
    Type^ type,
    String^ value
)
protected:
Object^ ConvertStringTo(
    Type^ type,
    String^ value
)
Parameters
type
Type:   Online System Type
The type of object to convert the string to.
value
Type:   Online System String
The string value to use as the value of the object.
Return Value
Type:   Online Object

            An object of type type with value value or
            null when the conversion could not be performed.

See Also
XmlHierarchyConfigurator Class
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator.CreateObjectFromXml Method

XmlHierarchyConfigurator CreateObjectFromXml Method Apache log4net™ SDK Documentation
Creates an object as specified in XML.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Object CreateObjectFromXml(
    XmlElement element,
    Type defaultTargetType,
    Type typeConstraint
)
protected Object CreateObjectFromXml(
    XmlElement element,
    Type defaultTargetType,
    Type typeConstraint
)
Protected Function CreateObjectFromXml (
    element As XmlElement,
    defaultTargetType As Type,
    typeConstraint As Type
) As Object
Protected Function CreateObjectFromXml (
    element As XmlElement,
    defaultTargetType As Type,
    typeConstraint As Type
) As Object
protected:
Object^ CreateObjectFromXml(
    XmlElement^ element,
    Type^ defaultTargetType,
    Type^ typeConstraint
)
protected:
Object^ CreateObjectFromXml(
    XmlElement^ element,
    Type^ defaultTargetType,
    Type^ typeConstraint
)
Parameters
element
Type:   Online System.Xml XmlElement
The XML element that contains the definition of the object.
defaultTargetType
Type:   Online System Type
The object type to use if not explicitly specified.
typeConstraint
Type:   Online System Type
The type that the returned object must be or must inherit from.
Return Value
Type:   Online Object
The object or null
Remarks

            Parse an XML element and create an object instance based on the configuration
            data.

            The type of the instance may be specified in the XML. If not
            specified then the defaultTargetType is used
            as the type. However the type is specified it must support the
            typeConstraint type.

See Also
XmlHierarchyConfigurator Class
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator.FindAppenderByReference Method

XmlHierarchyConfigurator FindAppenderByReference Method Apache log4net™ SDK Documentation
Parse appenders by IDREF.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IAppender FindAppenderByReference(
    XmlElement appenderRef
)
protected IAppender FindAppenderByReference(
    XmlElement appenderRef
)
Protected Function FindAppenderByReference (
    appenderRef As XmlElement
) As IAppender
Protected Function FindAppenderByReference (
    appenderRef As XmlElement
) As IAppender
protected:
IAppender^ FindAppenderByReference(
    XmlElement^ appenderRef
)
protected:
IAppender^ FindAppenderByReference(
    XmlElement^ appenderRef
)
Parameters
appenderRef
Type:   Online System.Xml XmlElement
The appender ref element.
Return Value
Type: IAppender
The instance of the appender that the ref refers to.
Remarks

            Parse an XML element that represents an appender and return
            the appender.

See Also
XmlHierarchyConfigurator Class
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator.ParseAppender Method

XmlHierarchyConfigurator ParseAppender Method Apache log4net™ SDK Documentation
Parses an appender element.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IAppender ParseAppender(
    XmlElement appenderElement
)
protected IAppender ParseAppender(
    XmlElement appenderElement
)
Protected Function ParseAppender (
    appenderElement As XmlElement
) As IAppender
Protected Function ParseAppender (
    appenderElement As XmlElement
) As IAppender
protected:
IAppender^ ParseAppender(
    XmlElement^ appenderElement
)
protected:
IAppender^ ParseAppender(
    XmlElement^ appenderElement
)
Parameters
appenderElement
Type:   Online System.Xml XmlElement
The appender element.
Return Value
Type: IAppender
The appender instance or null when parsing failed.
Remarks

            Parse an XML element that represents an appender and return
            the appender instance.

See Also
XmlHierarchyConfigurator Class
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator.ParseChildrenOfLoggerElement Method

XmlHierarchyConfigurator ParseChildrenOfLoggerElement Method Apache log4net™ SDK Documentation
Parses the children of a logger element.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void ParseChildrenOfLoggerElement(
    XmlElement catElement,
    Logger log,
    bool isRoot
)
protected void ParseChildrenOfLoggerElement(
    XmlElement catElement,
    Logger log,
    bool isRoot
)
Protected Sub ParseChildrenOfLoggerElement (
    catElement As XmlElement,
    log As Logger,
    isRoot As Boolean
)
Protected Sub ParseChildrenOfLoggerElement (
    catElement As XmlElement,
    log As Logger,
    isRoot As Boolean
)
protected:
void ParseChildrenOfLoggerElement(
    XmlElement^ catElement,
    Logger^ log,
    bool isRoot
)
protected:
void ParseChildrenOfLoggerElement(
    XmlElement^ catElement,
    Logger^ log,
    bool isRoot
)
Parameters
catElement
Type:   Online System.Xml XmlElement
The category element.
log
Type: log4net.Repository.Hierarchy Logger
The logger instance.
isRoot
Type:   Online System Boolean
Flag to indicate if the logger is the root logger.
Remarks

            Parse the child elements of a <logger> element.

See Also
XmlHierarchyConfigurator Class
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator.ParseLevel Method

XmlHierarchyConfigurator ParseLevel Method Apache log4net™ SDK Documentation
Parses a level element.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void ParseLevel(
    XmlElement element,
    Logger log,
    bool isRoot
)
protected void ParseLevel(
    XmlElement element,
    Logger log,
    bool isRoot
)
Protected Sub ParseLevel (
    element As XmlElement,
    log As Logger,
    isRoot As Boolean
)
Protected Sub ParseLevel (
    element As XmlElement,
    log As Logger,
    isRoot As Boolean
)
protected:
void ParseLevel(
    XmlElement^ element,
    Logger^ log,
    bool isRoot
)
protected:
void ParseLevel(
    XmlElement^ element,
    Logger^ log,
    bool isRoot
)
Parameters
element
Type:   Online System.Xml XmlElement
The level element.
log
Type: log4net.Repository.Hierarchy Logger
The logger object to set the level on.
isRoot
Type:   Online System Boolean
Flag to indicate if the logger is the root logger.
Remarks

            Parse an XML element that represents a level.

See Also
XmlHierarchyConfigurator Class
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator.ParseLogger Method

XmlHierarchyConfigurator ParseLogger Method Apache log4net™ SDK Documentation
Parses a logger element.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void ParseLogger(
    XmlElement loggerElement
)
protected void ParseLogger(
    XmlElement loggerElement
)
Protected Sub ParseLogger (
    loggerElement As XmlElement
)
Protected Sub ParseLogger (
    loggerElement As XmlElement
)
protected:
void ParseLogger(
    XmlElement^ loggerElement
)
protected:
void ParseLogger(
    XmlElement^ loggerElement
)
Parameters
loggerElement
Type:   Online System.Xml XmlElement
The logger element.
Remarks

            Parse an XML element that represents a logger.

See Also
XmlHierarchyConfigurator Class
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator.ParseRenderer Method

XmlHierarchyConfigurator ParseRenderer Method Apache log4net™ SDK Documentation
Parses an object renderer.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void ParseRenderer(
    XmlElement element
)
protected void ParseRenderer(
    XmlElement element
)
Protected Sub ParseRenderer (
    element As XmlElement
)
Protected Sub ParseRenderer (
    element As XmlElement
)
protected:
void ParseRenderer(
    XmlElement^ element
)
protected:
void ParseRenderer(
    XmlElement^ element
)
Parameters
element
Type:   Online System.Xml XmlElement
The renderer element.
Remarks

            Parse an XML element that represents a renderer.

See Also
XmlHierarchyConfigurator Class
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator.ParseRoot Method

XmlHierarchyConfigurator ParseRoot Method Apache log4net™ SDK Documentation
Parses the root logger element.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void ParseRoot(
    XmlElement rootElement
)
protected void ParseRoot(
    XmlElement rootElement
)
Protected Sub ParseRoot (
    rootElement As XmlElement
)
Protected Sub ParseRoot (
    rootElement As XmlElement
)
protected:
void ParseRoot(
    XmlElement^ rootElement
)
protected:
void ParseRoot(
    XmlElement^ rootElement
)
Parameters
rootElement
Type:   Online System.Xml XmlElement
The root element.
Remarks

            Parse an XML element that represents the root logger.

See Also
XmlHierarchyConfigurator Class
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


XmlHierarchyConfigurator.SetParameter Method

XmlHierarchyConfigurator SetParameter Method Apache log4net™ SDK Documentation
Sets a parameter on an object.

Namespace: log4net.Repository.Hierarchy
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void SetParameter(
    XmlElement element,
    Object target
)
protected void SetParameter(
    XmlElement element,
    Object target
)
Protected Sub SetParameter (
    element As XmlElement,
    target As Object
)
Protected Sub SetParameter (
    element As XmlElement,
    target As Object
)
protected:
void SetParameter(
    XmlElement^ element,
    Object^ target
)
protected:
void SetParameter(
    XmlElement^ element,
    Object^ target
)
Parameters
element
Type:   Online System.Xml XmlElement
The parameter element.
target
Type:   Online System Object
The object to set the parameter on.
Remarks

            The parameter name must correspond to a writable property
            on the object. The value of the parameter is a string,
            therefore this function will attempt to set a string
            property first. If unable to set a string property it
            will inspect the property and its argument type. It will
            attempt to call a static method called Parse on the
            type of the property. This method will take a single
            string argument and return a value that can be used to
            set the property.

See Also
XmlHierarchyConfigurator Class
XmlHierarchyConfigurator Members
log4net.Repository.Hierarchy Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.Util Namespace

log4net.Util Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | AppenderAttachedImpl | A straightforward implementation of the IAppenderAttachable interface.
Public class | CompositeProperties | This class aggregates several PropertiesDictionary collections together.
Public class | ContextPropertiesBase | Base class for Context Properties implementations
Public class | ConverterInfo | Wrapper class used to map converter names to converter types
Public class | CountingQuietTextWriter | Subclass of QuietTextWriter that maintains a count of the number of bytes written.
Public class | CyclicBuffer | A fixed size rolling buffer of logging events.
Public class | EmptyCollection | An always empty Online ICollection.
Public class | EmptyDictionary | An always empty Online IDictionary.
Public class | FormattingInfo | Contain the information obtained when parsing formatting modifiers in conversion modifiers.
Public class | GlobalContextProperties | Implementation of Properties collection for the GlobalContext
Public class | ILogExtensions | The static class ILogExtensions contains a set of widely used methods that ease the interaction with the ILog interface implementations.
Public class | LevelMapping | Manages a mapping from levels to LevelMappingEntry
Public class | LevelMappingEntry | An entry in the LevelMapping
Public class | LogicalThreadContextProperties | Implementation of Properties collection for the LogicalThreadContext
Public class | LogicalThreadContextStack | Implementation of Stack for the LogicalThreadContext
Public class | LogicalThreadContextStacks | Implementation of Stacks collection for the LogicalThreadContext
Public class | LogLog | Outputs log statements from within the log4net assembly.
Public class | LogLog LogReceivedAdapter | Subscribes to the LogLog.LogReceived event and stores messages to the supplied IList instance.
Public class | LogReceivedEventArgs |
Public class | NativeError | Represents a native error code and message.
Public class | NullDictionaryEnumerator | An always empty Online IDictionaryEnumerator.
Public class | NullEnumerator | An always empty Online IEnumerator.
Public class | NullSecurityContext | A SecurityContext used when a SecurityContext is not required
Public class | OnlyOnceErrorHandler | Implements log4net's default error handling policy which consists of emitting a message for the first error in an appender and ignoring all subsequent errors.
Public class | OptionConverter | A convenience class to convert property values to specific types.
Public class | PatternConverter | Abstract class that provides the formatting functionality that derived classes need.
Public class | PatternParser | Most of the work of the PatternLayout class is delegated to the PatternParser class.
Public class | PatternString | This class implements a patterned string.
Public class | PropertiesDictionary | String keyed object map.
Public class | PropertyEntry | A class to hold the key and data for a property set in the config file
Public class | ProtectCloseTextWriter | A Online TextWriter that ignores the Close message
Public class | QuietTextWriter | Online TextWriter that does not leak exceptions
Public class | ReaderWriterLock | Defines a lock that supports single writers and multiple readers
Public class | ReadOnlyPropertiesDictionary | String keyed object map that is read only.
Public class | ReusableStringWriter | A Online StringWriter that can be Reset(Int32, Int32) and reused
Public class | SystemInfo | Utility class for system specific information.
Public class | SystemStringFormat | Utility class that represents a format string.
Public class | TextWriterAdapter | Adapter that extends Online TextWriter and forwards all messages to an instance of Online TextWriter.
Public class | ThreadContextProperties | Implementation of Properties collection for the ThreadContext
Public class | ThreadContextStack | Implementation of Stack for the ThreadContext
Public class | ThreadContextStacks | Implementation of Stacks collection for the ThreadContext
Public class | Transform | Utility class for transforming strings.
Public class | WindowsSecurityContext | Impersonate a Windows Account
Delegates
 | Delegate | Description
Public delegate | LogReceivedEventHandler |
Public delegate | TwoArgAction T1, T2 | Delegate type used for LogicalThreadContextStack's callbacks.
Enumerations
 | Enumeration | Description
Public enumeration | WindowsSecurityContext ImpersonationMode | The impersonation modes for the WindowsSecurityContext

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl Class

AppenderAttachedImpl Class Apache log4net™ SDK Documentation
A straightforward implementation of the IAppenderAttachable interface.
Inheritance Hierarchy
Online System Object
log4net.Util AppenderAttachedImpl

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AppenderAttachedImpl : IAppenderAttachable
public class AppenderAttachedImpl : IAppenderAttachable
Public Class AppenderAttachedImpl
    Implements IAppenderAttachable
Public Class AppenderAttachedImpl
    Implements IAppenderAttachable
public ref class AppenderAttachedImpl : IAppenderAttachable
public ref class AppenderAttachedImpl : IAppenderAttachable
Remarks

            This is the default implementation of the IAppenderAttachable
            interface. Implementors of the IAppenderAttachable interface
            should aggregate an instance of this type.

See Also
AppenderAttachedImpl Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl Members

AppenderAttachedImpl Members Apache log4net™ SDK Documentation
The AppenderAttachedImpl type exposes the following members.
Constructors
 | Name | Description
Public method | AppenderAttachedImpl | Constructor
Back to Top
Methods
 | Name | Description
Public method | AddAppender | Attaches an appender.
Public method | AppendLoopOnAppenders(LoggingEvent) | Append on on all attached appenders.
Public method | AppendLoopOnAppenders( LoggingEvent ) | Append on on all attached appenders.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAppender | Gets an attached appender with the specified name.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveAllAppenders | Removes all attached appenders.
Public method | RemoveAppender(String) | Removes the appender with the specified name from the list of appenders.
Public method | RemoveAppender(IAppender) | Removes the specified appender from the list of attached appenders.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Appenders | Gets all attached appenders.
Back to Top
See Also
AppenderAttachedImpl Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl Constructor

AppenderAttachedImpl Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AppenderAttachedImpl()
public AppenderAttachedImpl()
Public Sub New
Public Sub New
public:
AppenderAttachedImpl()
public:
AppenderAttachedImpl()
Remarks

            Initializes a new instance of the AppenderAttachedImpl class.

See Also
AppenderAttachedImpl Class
AppenderAttachedImpl Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl Methods

AppenderAttachedImpl Methods Apache log4net™ SDK Documentation
The AppenderAttachedImpl type exposes the following members.
Methods
 | Name | Description
Public method | AddAppender | Attaches an appender.
Public method | AppendLoopOnAppenders(LoggingEvent) | Append on on all attached appenders.
Public method | AppendLoopOnAppenders( LoggingEvent ) | Append on on all attached appenders.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAppender | Gets an attached appender with the specified name.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveAllAppenders | Removes all attached appenders.
Public method | RemoveAppender(String) | Removes the appender with the specified name from the list of appenders.
Public method | RemoveAppender(IAppender) | Removes the specified appender from the list of attached appenders.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AppenderAttachedImpl Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl.AddAppender Method

AppenderAttachedImpl AddAppender Method Apache log4net™ SDK Documentation
Attaches an appender.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddAppender(
    IAppender newAppender
)
public void AddAppender(
    IAppender newAppender
)
Public Sub AddAppender (
    newAppender As IAppender
)
Public Sub AddAppender (
    newAppender As IAppender
)
public:
virtual void AddAppender(
    IAppender^ newAppender
) sealed
public:
virtual void AddAppender(
    IAppender^ newAppender
) sealed
Parameters
newAppender
Type: log4net.Appender IAppender
The appender to add.
Implements
IAppenderAttachable AddAppender(IAppender)
Remarks

            If the appender is already in the list it won't be added again.

See Also
AppenderAttachedImpl Class
AppenderAttachedImpl Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl.AppendLoopOnAppenders Method

AppenderAttachedImpl AppendLoopOnAppenders Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | AppendLoopOnAppenders(LoggingEvent) | Append on on all attached appenders.
Public method | AppendLoopOnAppenders( LoggingEvent ) | Append on on all attached appenders.
Back to Top
See Also
AppenderAttachedImpl Class
AppenderAttachedImpl Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl.AppendLoopOnAppenders Method (LoggingEvent)

AppenderAttachedImpl AppendLoopOnAppenders Method (LoggingEvent) Apache log4net™ SDK Documentation
Append on on all attached appenders.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int AppendLoopOnAppenders(
    LoggingEvent loggingEvent
)
public int AppendLoopOnAppenders(
    LoggingEvent loggingEvent
)
Public Function AppendLoopOnAppenders (
    loggingEvent As LoggingEvent
) As Integer
Public Function AppendLoopOnAppenders (
    loggingEvent As LoggingEvent
) As Integer
public:
int AppendLoopOnAppenders(
    LoggingEvent^ loggingEvent
)
public:
int AppendLoopOnAppenders(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event being logged.
Return Value
Type:   Online Int32
The number of appenders called.
Remarks

            Calls the DoAppend(LoggingEvent) method on all
            attached appenders.

See Also
AppenderAttachedImpl Class
AppenderAttachedImpl Members
AppendLoopOnAppenders Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl.AppendLoopOnAppenders Method (LoggingEvent[])

AppenderAttachedImpl AppendLoopOnAppenders Method ( LoggingEvent ) Apache log4net™ SDK Documentation
Append on on all attached appenders.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int AppendLoopOnAppenders(
    LoggingEvent[] loggingEvents
)
public int AppendLoopOnAppenders(
    LoggingEvent[] loggingEvents
)
Public Function AppendLoopOnAppenders (
    loggingEvents As LoggingEvent()
) As Integer
Public Function AppendLoopOnAppenders (
    loggingEvents As LoggingEvent()
) As Integer
public:
int AppendLoopOnAppenders(
    array<LoggingEvent^>^ loggingEvents
)
public:
int AppendLoopOnAppenders(
    array<LoggingEvent^>^ loggingEvents
)
Parameters
loggingEvents
Type:  log4net.Core LoggingEvent
The array of events being logged.
Return Value
Type:   Online Int32
The number of appenders called.
Remarks

            Calls the DoAppend(LoggingEvent) method on all
            attached appenders.

See Also
AppenderAttachedImpl Class
AppenderAttachedImpl Members
AppendLoopOnAppenders Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl.GetAppender Method

AppenderAttachedImpl GetAppender Method Apache log4net™ SDK Documentation
Gets an attached appender with the specified name.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IAppender GetAppender(
    string name
)
public IAppender GetAppender(
    string name
)
Public Function GetAppender (
    name As String
) As IAppender
Public Function GetAppender (
    name As String
) As IAppender
public:
virtual IAppender^ GetAppender(
    String^ name
) sealed
public:
virtual IAppender^ GetAppender(
    String^ name
) sealed
Parameters
name
Type:   Online System String
The name of the appender to get.
Return Value
Type: IAppender

            The appender with the name specified, or null if no appender with the
            specified name is found.

Implements
IAppenderAttachable GetAppender(String)
Remarks

            Lookup an attached appender by name.

See Also
AppenderAttachedImpl Class
AppenderAttachedImpl Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl.RemoveAllAppenders Method

AppenderAttachedImpl RemoveAllAppenders Method Apache log4net™ SDK Documentation
Removes all attached appenders.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RemoveAllAppenders()
public void RemoveAllAppenders()
Public Sub RemoveAllAppenders
Public Sub RemoveAllAppenders
public:
virtual void RemoveAllAppenders() sealed
public:
virtual void RemoveAllAppenders() sealed
Implements
IAppenderAttachable RemoveAllAppenders
Remarks

            Removes and closes all attached appenders

See Also
AppenderAttachedImpl Class
AppenderAttachedImpl Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl.RemoveAppender Method

AppenderAttachedImpl RemoveAppender Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | RemoveAppender(String) | Removes the appender with the specified name from the list of appenders.
Public method | RemoveAppender(IAppender) | Removes the specified appender from the list of attached appenders.
Back to Top
See Also
AppenderAttachedImpl Class
AppenderAttachedImpl Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl.RemoveAppender Method (String)

AppenderAttachedImpl RemoveAppender Method (String) Apache log4net™ SDK Documentation
Removes the appender with the specified name from the list of appenders.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IAppender RemoveAppender(
    string name
)
public IAppender RemoveAppender(
    string name
)
Public Function RemoveAppender (
    name As String
) As IAppender
Public Function RemoveAppender (
    name As String
) As IAppender
public:
virtual IAppender^ RemoveAppender(
    String^ name
) sealed
public:
virtual IAppender^ RemoveAppender(
    String^ name
) sealed
Parameters
name
Type:   Online System String
The name of the appender to remove.
Return Value
Type: IAppender
The appender removed from the list
Implements
IAppenderAttachable RemoveAppender(String)
Remarks

            The appender removed is not closed.
            If you are discarding the appender you must call
            Close  on the appender removed.

See Also
AppenderAttachedImpl Class
AppenderAttachedImpl Members
RemoveAppender Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl.RemoveAppender Method (IAppender)

AppenderAttachedImpl RemoveAppender Method (IAppender) Apache log4net™ SDK Documentation
Removes the specified appender from the list of attached appenders.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IAppender RemoveAppender(
    IAppender appender
)
public IAppender RemoveAppender(
    IAppender appender
)
Public Function RemoveAppender (
    appender As IAppender
) As IAppender
Public Function RemoveAppender (
    appender As IAppender
) As IAppender
public:
virtual IAppender^ RemoveAppender(
    IAppender^ appender
) sealed
public:
virtual IAppender^ RemoveAppender(
    IAppender^ appender
) sealed
Parameters
appender
Type: log4net.Appender IAppender
The appender to remove.
Return Value
Type: IAppender
The appender removed from the list
Implements
IAppenderAttachable RemoveAppender(IAppender)
Remarks

            The appender removed is not closed.
            If you are discarding the appender you must call
            Close  on the appender removed.

See Also
AppenderAttachedImpl Class
AppenderAttachedImpl Members
RemoveAppender Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl Properties

AppenderAttachedImpl Properties Apache log4net™ SDK Documentation
The AppenderAttachedImpl type exposes the following members.
Properties
 | Name | Description
Public property | Appenders | Gets all attached appenders.
Back to Top
See Also
AppenderAttachedImpl Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


AppenderAttachedImpl.Appenders Property

AppenderAttachedImpl Appenders Property Apache log4net™ SDK Documentation
Gets all attached appenders.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AppenderCollection Appenders { get; }
public AppenderCollection Appenders { get; }
Public ReadOnly Property Appenders As AppenderCollection
    Get
Public ReadOnly Property Appenders As AppenderCollection
    Get
public:
virtual property AppenderCollection^ Appenders {
    AppenderCollection^ get () sealed;
}
public:
virtual property AppenderCollection^ Appenders {
    AppenderCollection^ get () sealed;
}
Return Value
Type: AppenderCollection

            A collection of attached appenders, or null if there
            are no attached appenders.

Implements
IAppenderAttachable Appenders
Remarks

            The read only collection of all currently attached appenders.

See Also
AppenderAttachedImpl Class
AppenderAttachedImpl Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompositeProperties Class

CompositeProperties Class Apache log4net™ SDK Documentation
This class aggregates several PropertiesDictionary collections together.
Inheritance Hierarchy
Online System Object
log4net.Util CompositeProperties

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CompositeProperties
public sealed class CompositeProperties
Public NotInheritable Class CompositeProperties
Public NotInheritable Class CompositeProperties
public ref class CompositeProperties sealed
public ref class CompositeProperties sealed
Remarks

            Provides a dictionary style lookup over an ordered list of
            PropertiesDictionary collections.

See Also
CompositeProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompositeProperties Members

CompositeProperties Members Apache log4net™ SDK Documentation
The CompositeProperties type exposes the following members.
Methods
 | Name | Description
Public method | Add | Add a Properties Dictionary to this composite collection
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flatten | Flatten this composite collection into a single properties dictionary
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | Gets the value of a property
Back to Top
See Also
CompositeProperties Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompositeProperties Methods

CompositeProperties Methods Apache log4net™ SDK Documentation
The CompositeProperties type exposes the following members.
Methods
 | Name | Description
Public method | Add | Add a Properties Dictionary to this composite collection
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flatten | Flatten this composite collection into a single properties dictionary
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CompositeProperties Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompositeProperties.Add Method

CompositeProperties Add Method Apache log4net™ SDK Documentation
Add a Properties Dictionary to this composite collection

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    ReadOnlyPropertiesDictionary properties
)
public void Add(
    ReadOnlyPropertiesDictionary properties
)
Public Sub Add (
    properties As ReadOnlyPropertiesDictionary
)
Public Sub Add (
    properties As ReadOnlyPropertiesDictionary
)
public:
void Add(
    ReadOnlyPropertiesDictionary^ properties
)
public:
void Add(
    ReadOnlyPropertiesDictionary^ properties
)
Parameters
properties
Type: log4net.Util ReadOnlyPropertiesDictionary
the properties to add
Remarks

            Properties dictionaries added first take precedence over dictionaries added
            later.

See Also
CompositeProperties Class
CompositeProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompositeProperties.Flatten Method

CompositeProperties Flatten Method Apache log4net™ SDK Documentation
Flatten this composite collection into a single properties dictionary

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PropertiesDictionary Flatten()
public PropertiesDictionary Flatten()
Public Function Flatten As PropertiesDictionary
Public Function Flatten As PropertiesDictionary
public:
PropertiesDictionary^ Flatten()
public:
PropertiesDictionary^ Flatten()
Return Value
Type: PropertiesDictionary
the flattened dictionary
Remarks

            Reduces the collection of ordered dictionaries to a single dictionary
            containing the resultant values for the keys.

See Also
CompositeProperties Class
CompositeProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompositeProperties Properties

CompositeProperties Properties Apache log4net™ SDK Documentation
The CompositeProperties type exposes the following members.
Properties
 | Name | Description
Public property | Item | Gets the value of a property
Back to Top
See Also
CompositeProperties Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CompositeProperties.Item Property

CompositeProperties Item Property Apache log4net™ SDK Documentation
Gets the value of a property

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object this[
    string key
] { get; }
public Object this[
    string key
] { get; }
Public ReadOnly Default Property Item (
    key As String
) As Object
    Get
Public ReadOnly Default Property Item (
    key As String
) As Object
    Get
public:
property Object^ default[String^ key] {
    Object^ get (String^ key);
}
public:
property Object^ default[String^ key] {
    Object^ get (String^ key);
}
Parameters
key
Type:   Online System String
Property Value
Type:   Online Object

            The value for the property with the specified key

Remarks

            Looks up the value for the key specified.
            The PropertiesDictionary collections are searched
            in the order in which they were added to this collection. The value
            returned is the value held by the first collection that contains
            the specified key.

            If none of the collections contain the specified key then
            null is returned.

See Also
CompositeProperties Class
CompositeProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ContextPropertiesBase Class

ContextPropertiesBase Class Apache log4net™ SDK Documentation
Base class for Context Properties implementations
Inheritance Hierarchy
Online System Object
log4net.Util ContextPropertiesBase
log4net.Util GlobalContextProperties
log4net.Util LogicalThreadContextProperties
log4net.Util ThreadContextProperties

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ContextPropertiesBase
public abstract class ContextPropertiesBase
Public MustInherit Class ContextPropertiesBase
Public MustInherit Class ContextPropertiesBase
public ref class ContextPropertiesBase abstract
public ref class ContextPropertiesBase abstract
Remarks

            This class defines a basic property get set accessor

See Also
ContextPropertiesBase Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ContextPropertiesBase Members

ContextPropertiesBase Members Apache log4net™ SDK Documentation
The ContextPropertiesBase type exposes the following members.
Constructors
 | Name | Description
Protected method | ContextPropertiesBase | Initializes a new instance of the ContextPropertiesBase class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | Gets or sets the value of a property
Back to Top
See Also
ContextPropertiesBase Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ContextPropertiesBase Constructor

ContextPropertiesBase Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the ContextPropertiesBase class

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ContextPropertiesBase()
protected ContextPropertiesBase()
Protected Sub New
Protected Sub New
protected:
ContextPropertiesBase()
protected:
ContextPropertiesBase()
See Also
ContextPropertiesBase Class
ContextPropertiesBase Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ContextPropertiesBase Methods

ContextPropertiesBase Methods Apache log4net™ SDK Documentation
The ContextPropertiesBase type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ContextPropertiesBase Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ContextPropertiesBase Properties

ContextPropertiesBase Properties Apache log4net™ SDK Documentation
The ContextPropertiesBase type exposes the following members.
Properties
 | Name | Description
Public property | Item | Gets or sets the value of a property
Back to Top
See Also
ContextPropertiesBase Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ContextPropertiesBase.Item Property

ContextPropertiesBase Item Property Apache log4net™ SDK Documentation
Gets or sets the value of a property

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object this[
    string key
] { get; set; }
public abstract Object this[
    string key
] { get; set; }
Public MustOverride Default Property Item (
    key As String
) As Object
    Get
    Set
Public MustOverride Default Property Item (
    key As String
) As Object
    Get
    Set
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key) abstract;
    void set (String^ key, Object^ value) abstract;
}
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key) abstract;
    void set (String^ key, Object^ value) abstract;
}
Parameters
key
Type:   Online System String
Property Value
Type:   Online Object

            The value for the property with the specified key

Remarks

            Gets or sets the value of a property

See Also
ContextPropertiesBase Class
ContextPropertiesBase Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterInfo Class

ConverterInfo Class Apache log4net™ SDK Documentation
Wrapper class used to map converter names to converter types
Inheritance Hierarchy
Online System Object
log4net.Util ConverterInfo

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ConverterInfo
public sealed class ConverterInfo
Public NotInheritable Class ConverterInfo
Public NotInheritable Class ConverterInfo
public ref class ConverterInfo sealed
public ref class ConverterInfo sealed
Remarks

            Pattern converter info class used during configuration by custom
            PatternString and PatternLayer converters.

See Also
ConverterInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterInfo Members

ConverterInfo Members Apache log4net™ SDK Documentation
The ConverterInfo type exposes the following members.
Constructors
 | Name | Description
Public method | ConverterInfo | default constructor
Back to Top
Methods
 | Name | Description
Public method | AddProperty |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the conversion pattern
Public property | Properties |
Public property | Type | Gets or sets the type of the converter
Back to Top
See Also
ConverterInfo Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterInfo Constructor

ConverterInfo Constructor Apache log4net™ SDK Documentation
default constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConverterInfo()
public ConverterInfo()
Public Sub New
Public Sub New
public:
ConverterInfo()
public:
ConverterInfo()
See Also
ConverterInfo Class
ConverterInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterInfo Methods

ConverterInfo Methods Apache log4net™ SDK Documentation
The ConverterInfo type exposes the following members.
Methods
 | Name | Description
Public method | AddProperty |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ConverterInfo Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterInfo.AddProperty Method

ConverterInfo AddProperty Method Apache log4net™ SDK Documentation

[Missing <summary> documentation for "M:log4net.Util.ConverterInfo.AddProperty(log4net.Util.PropertyEntry)"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddProperty(
    PropertyEntry entry
)
public void AddProperty(
    PropertyEntry entry
)
Public Sub AddProperty (
    entry As PropertyEntry
)
Public Sub AddProperty (
    entry As PropertyEntry
)
public:
void AddProperty(
    PropertyEntry^ entry
)
public:
void AddProperty(
    PropertyEntry^ entry
)
Parameters
entry
Type: log4net.Util PropertyEntry
[Missing <param name="entry"/> documentation for "M:log4net.Util.ConverterInfo.AddProperty(log4net.Util.PropertyEntry)"]
See Also
ConverterInfo Class
ConverterInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterInfo Properties

ConverterInfo Properties Apache log4net™ SDK Documentation
The ConverterInfo type exposes the following members.
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the conversion pattern
Public property | Properties |
Public property | Type | Gets or sets the type of the converter
Back to Top
See Also
ConverterInfo Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterInfo.Name Property

ConverterInfo Name Property Apache log4net™ SDK Documentation
Gets or sets the name of the conversion pattern

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            The name of the pattern in the format string

See Also
ConverterInfo Class
ConverterInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterInfo.Properties Property

ConverterInfo Properties Property Apache log4net™ SDK Documentation

[Missing <summary> documentation for "P:log4net.Util.ConverterInfo.Properties"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PropertiesDictionary Properties { get; }
public PropertiesDictionary Properties { get; }
Public ReadOnly Property Properties As PropertiesDictionary
    Get
Public ReadOnly Property Properties As PropertiesDictionary
    Get
public:
property PropertiesDictionary^ Properties {
    PropertiesDictionary^ get ();
}
public:
property PropertiesDictionary^ Properties {
    PropertiesDictionary^ get ();
}
Property Value
Type: PropertiesDictionary
See Also
ConverterInfo Class
ConverterInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterInfo.Type Property

ConverterInfo Type Property Apache log4net™ SDK Documentation
Gets or sets the type of the converter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type Type { get; set; }
public Type Type { get; set; }
Public Property Type As Type
    Get
    Set
Public Property Type As Type
    Get
    Set
public:
property Type^ Type {
    Type^ get ();
    void set (Type^ value);
}
public:
property Type^ Type {
    Type^ get ();
    void set (Type^ value);
}
Property Value
Type:   Online Type
Remarks

            The value specified must extend the
            PatternConverter type.

See Also
ConverterInfo Class
ConverterInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CountingQuietTextWriter Class

CountingQuietTextWriter Class Apache log4net™ SDK Documentation
Subclass of QuietTextWriter that maintains a count of the number of bytes written.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO TextWriter
log4net.Util TextWriterAdapter
log4net.Util QuietTextWriter
log4net.Util CountingQuietTextWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CountingQuietTextWriter : QuietTextWriter
public class CountingQuietTextWriter : QuietTextWriter
Public Class CountingQuietTextWriter
    Inherits QuietTextWriter
Public Class CountingQuietTextWriter
    Inherits QuietTextWriter
public ref class CountingQuietTextWriter : public QuietTextWriter
public ref class CountingQuietTextWriter : public QuietTextWriter
Remarks

            This writer counts the number of bytes written.

See Also
CountingQuietTextWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CountingQuietTextWriter Members

CountingQuietTextWriter Members Apache log4net™ SDK Documentation
The CountingQuietTextWriter type exposes the following members.
Constructors
 | Name | Description
Public method | CountingQuietTextWriter | Constructor
Back to Top
Methods
 | Name | Description
Public method | Close | Closes the underlying output writer. (Inherited from QuietTextWriter.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online TextWriter object. (Inherited from Online TextWriter.)
Protected method | Dispose(Boolean) | Dispose this writer (Inherited from TextWriterAdapter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Flushes any buffered output (Inherited from TextWriterAdapter.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Write(Char) | Writes a character to the underlying writer and counts the number of bytes written. (Overrides QuietTextWriter Write(Char).)
Public method | Write(String) | Writes a string to the output and counts the number of bytes written. (Overrides QuietTextWriter Write(String).)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Write( Char , Int32, Int32) | Writes a buffer to the underlying writer and counts the number of bytes written. (Overrides QuietTextWriter Write( Char , Int32, Int32).)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine | Writes a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char ) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object ) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char , Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
Fields
 | Name | Description
Protected field | Online CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from Online TextWriter.)
Back to Top
Properties
 | Name | Description
Public property | Closed | Gets a value indicating whether this writer is closed. (Inherited from QuietTextWriter.)
Public property | Count | Gets or sets the total number of bytes written.
Public property | Encoding | The Encoding in which the output is written (Inherited from TextWriterAdapter.)
Public property | ErrorHandler | Gets or sets the error handler that all errors are passed to. (Inherited from QuietTextWriter.)
Public property | FormatProvider | Gets an object that controls formatting (Inherited from TextWriterAdapter.)
Public property | NewLine | Gets or sets the line terminator string used by the TextWriter (Inherited from TextWriterAdapter.)
Protected property | Writer | Gets or sets the underlying Online TextWriter. (Inherited from TextWriterAdapter.)
Back to Top
See Also
CountingQuietTextWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CountingQuietTextWriter Constructor

CountingQuietTextWriter Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CountingQuietTextWriter(
    TextWriter writer,
    IErrorHandler errorHandler
)
public CountingQuietTextWriter(
    TextWriter writer,
    IErrorHandler errorHandler
)
Public Sub New (
    writer As TextWriter,
    errorHandler As IErrorHandler
)
Public Sub New (
    writer As TextWriter,
    errorHandler As IErrorHandler
)
public:
CountingQuietTextWriter(
    TextWriter^ writer,
    IErrorHandler^ errorHandler
)
public:
CountingQuietTextWriter(
    TextWriter^ writer,
    IErrorHandler^ errorHandler
)
Parameters
writer
Type:   Online System.IO TextWriter
The   Online TextWriter to actually write to.
errorHandler
Type: log4net.Core IErrorHandler
The IErrorHandler to report errors to.
Remarks

            Creates a new instance of the CountingQuietTextWriter class
            with the specified   Online TextWriter and IErrorHandler.

See Also
CountingQuietTextWriter Class
CountingQuietTextWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CountingQuietTextWriter Fields

CountingQuietTextWriter Fields Apache log4net™ SDK Documentation
The CountingQuietTextWriter type exposes the following members.
Fields
 | Name | Description
Protected field | Online CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from Online TextWriter.)
Back to Top
See Also
CountingQuietTextWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CountingQuietTextWriter Methods

CountingQuietTextWriter Methods Apache log4net™ SDK Documentation
The CountingQuietTextWriter type exposes the following members.
Methods
 | Name | Description
Public method | Close | Closes the underlying output writer. (Inherited from QuietTextWriter.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online TextWriter object. (Inherited from Online TextWriter.)
Protected method | Dispose(Boolean) | Dispose this writer (Inherited from TextWriterAdapter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Flushes any buffered output (Inherited from TextWriterAdapter.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Write(Char) | Writes a character to the underlying writer and counts the number of bytes written. (Overrides QuietTextWriter Write(Char).)
Public method | Write(String) | Writes a string to the output and counts the number of bytes written. (Overrides QuietTextWriter Write(String).)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Write( Char , Int32, Int32) | Writes a buffer to the underlying writer and counts the number of bytes written. (Overrides QuietTextWriter Write( Char , Int32, Int32).)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine | Writes a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char ) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object ) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char , Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
See Also
CountingQuietTextWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CountingQuietTextWriter.Write Method

CountingQuietTextWriter Write Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Write(Char) | Writes a character to the underlying writer and counts the number of bytes written. (Overrides QuietTextWriter Write(Char).)
Public method | Write(String) | Writes a string to the output and counts the number of bytes written. (Overrides QuietTextWriter Write(String).)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Write( Char , Int32, Int32) | Writes a buffer to the underlying writer and counts the number of bytes written. (Overrides QuietTextWriter Write( Char , Int32, Int32).)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
See Also
CountingQuietTextWriter Class
CountingQuietTextWriter Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CountingQuietTextWriter.Write Method (Char)

CountingQuietTextWriter Write Method (Char) Apache log4net™ SDK Documentation
Writes a character to the underlying writer and counts the number of bytes written.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    char value
)
public override void Write(
    char value
)
Public Overrides Sub Write (
    value As Char
)
Public Overrides Sub Write (
    value As Char
)
public:
virtual void Write(
    wchar_t value
) override
public:
virtual void Write(
    wchar_t value
) override
Parameters
value
Type:   Online System Char
the char to write
Remarks

            Overrides implementation of QuietTextWriter. Counts
            the number of bytes written.

See Also
CountingQuietTextWriter Class
CountingQuietTextWriter Members
Write Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CountingQuietTextWriter.Write Method (String)

CountingQuietTextWriter Write Method (String) Apache log4net™ SDK Documentation
Writes a string to the output and counts the number of bytes written.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    string str
)
public override void Write(
    string str
)
Public Overrides Sub Write (
    str As String
)
Public Overrides Sub Write (
    str As String
)
public:
virtual void Write(
    String^ str
) override
public:
virtual void Write(
    String^ str
) override
Parameters
str
Type:   Online System String
The string data to write to the output.
Remarks

            Overrides implementation of QuietTextWriter. Counts
            the number of bytes written.

See Also
CountingQuietTextWriter Class
CountingQuietTextWriter Members
Write Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CountingQuietTextWriter.Write Method (Char[], Int32, Int32)

CountingQuietTextWriter Write Method ( Char , Int32, Int32) Apache log4net™ SDK Documentation
Writes a buffer to the underlying writer and counts the number of bytes written.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    char[] buffer,
    int index,
    int count
)
public override void Write(
    char[] buffer,
    int index,
    int count
)
Public Overrides Sub Write (
    buffer As Char(),
    index As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Char(),
    index As Integer,
    count As Integer
)
public:
virtual void Write(
    array<wchar_t>^ buffer,
    int index,
    int count
) override
public:
virtual void Write(
    array<wchar_t>^ buffer,
    int index,
    int count
) override
Parameters
buffer
Type:    Online System Char
the buffer to write
index
Type:   Online System Int32
the start index to write from
count
Type:   Online System Int32
the number of characters to write
Remarks

            Overrides implementation of QuietTextWriter. Counts
            the number of bytes written.

See Also
CountingQuietTextWriter Class
CountingQuietTextWriter Members
Write Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CountingQuietTextWriter Properties

CountingQuietTextWriter Properties Apache log4net™ SDK Documentation
The CountingQuietTextWriter type exposes the following members.
Properties
 | Name | Description
Public property | Closed | Gets a value indicating whether this writer is closed. (Inherited from QuietTextWriter.)
Public property | Count | Gets or sets the total number of bytes written.
Public property | Encoding | The Encoding in which the output is written (Inherited from TextWriterAdapter.)
Public property | ErrorHandler | Gets or sets the error handler that all errors are passed to. (Inherited from QuietTextWriter.)
Public property | FormatProvider | Gets an object that controls formatting (Inherited from TextWriterAdapter.)
Public property | NewLine | Gets or sets the line terminator string used by the TextWriter (Inherited from TextWriterAdapter.)
Protected property | Writer | Gets or sets the underlying Online TextWriter. (Inherited from TextWriterAdapter.)
Back to Top
See Also
CountingQuietTextWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CountingQuietTextWriter.Count Property

CountingQuietTextWriter Count Property Apache log4net™ SDK Documentation
Gets or sets the total number of bytes written.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long Count { get; set; }
public long Count { get; set; }
Public Property Count As Long
    Get
    Set
Public Property Count As Long
    Get
    Set
public:
property long long Count {
    long long get ();
    void set (long long value);
}
public:
property long long Count {
    long long get ();
    void set (long long value);
}
Property Value
Type:   Online Int64

            The total number of bytes written.

Remarks

            Gets or sets the total number of bytes written.

See Also
CountingQuietTextWriter Class
CountingQuietTextWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CyclicBuffer Class

CyclicBuffer Class Apache log4net™ SDK Documentation
A fixed size rolling buffer of logging events.
Inheritance Hierarchy
Online System Object
log4net.Util CyclicBuffer

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CyclicBuffer
public class CyclicBuffer
Public Class CyclicBuffer
Public Class CyclicBuffer
public ref class CyclicBuffer
public ref class CyclicBuffer
Remarks

            An array backed fixed size leaky bucket.

See Also
CyclicBuffer Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CyclicBuffer Members

CyclicBuffer Members Apache log4net™ SDK Documentation
The CyclicBuffer type exposes the following members.
Constructors
 | Name | Description
Public method | CyclicBuffer | Constructor
Back to Top
Methods
 | Name | Description
Public method | Append | Appends a loggingEvent to the buffer.
Public method | Clear | Clear the buffer
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PopAll | Pops all the logging events from the buffer into an array.
Public method | PopOldest | Get and remove the oldest event in the buffer.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | Gets the ith oldest event currently in the buffer.
Public property | Length | Gets the number of logging events in the buffer.
Public property | MaxSize | Gets the maximum size of the buffer.
Back to Top
See Also
CyclicBuffer Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CyclicBuffer Constructor

CyclicBuffer Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CyclicBuffer(
    int maxSize
)
public CyclicBuffer(
    int maxSize
)
Public Sub New (
    maxSize As Integer
)
Public Sub New (
    maxSize As Integer
)
public:
CyclicBuffer(
    int maxSize
)
public:
CyclicBuffer(
    int maxSize
)
Parameters
maxSize
Type:   Online System Int32
The maximum number of logging events in the buffer.
Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | The maxSize argument is not a positive integer.
Remarks

            Initializes a new instance of the CyclicBuffer class with
            the specified maximum number of buffered logging events.

See Also
CyclicBuffer Class
CyclicBuffer Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CyclicBuffer Methods

CyclicBuffer Methods Apache log4net™ SDK Documentation
The CyclicBuffer type exposes the following members.
Methods
 | Name | Description
Public method | Append | Appends a loggingEvent to the buffer.
Public method | Clear | Clear the buffer
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PopAll | Pops all the logging events from the buffer into an array.
Public method | PopOldest | Get and remove the oldest event in the buffer.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CyclicBuffer Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CyclicBuffer.Append Method

CyclicBuffer Append Method Apache log4net™ SDK Documentation
Appends a loggingEvent to the buffer.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingEvent Append(
    LoggingEvent loggingEvent
)
public LoggingEvent Append(
    LoggingEvent loggingEvent
)
Public Function Append (
    loggingEvent As LoggingEvent
) As LoggingEvent
Public Function Append (
    loggingEvent As LoggingEvent
) As LoggingEvent
public:
LoggingEvent^ Append(
    LoggingEvent^ loggingEvent
)
public:
LoggingEvent^ Append(
    LoggingEvent^ loggingEvent
)
Parameters
loggingEvent
Type: log4net.Core LoggingEvent
The event to append to the buffer.
Return Value
Type: LoggingEvent
The event discarded from the buffer, if the buffer is full, otherwise null.
Remarks

            Append an event to the buffer. If the buffer still contains free space then
            null is returned. If the buffer is full then an event will be dropped
            to make space for the new event, the event dropped is returned.

See Also
CyclicBuffer Class
CyclicBuffer Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CyclicBuffer.Clear Method

CyclicBuffer Clear Method Apache log4net™ SDK Documentation
Clear the buffer

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
Remarks

            Clear the buffer of all events. The events in the buffer are lost.

See Also
CyclicBuffer Class
CyclicBuffer Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CyclicBuffer.PopAll Method

CyclicBuffer PopAll Method Apache log4net™ SDK Documentation
Pops all the logging events from the buffer into an array.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingEvent[] PopAll()
public LoggingEvent[] PopAll()
Public Function PopAll As LoggingEvent()
Public Function PopAll As LoggingEvent()
public:
array<LoggingEvent^>^ PopAll()
public:
array<LoggingEvent^>^ PopAll()
Return Value
Type:  LoggingEvent
An array of all the logging events in the buffer.
Remarks

            Get all the events in the buffer and clear the buffer.

See Also
CyclicBuffer Class
CyclicBuffer Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CyclicBuffer.PopOldest Method

CyclicBuffer PopOldest Method Apache log4net™ SDK Documentation
Get and remove the oldest event in the buffer.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingEvent PopOldest()
public LoggingEvent PopOldest()
Public Function PopOldest As LoggingEvent
Public Function PopOldest As LoggingEvent
public:
LoggingEvent^ PopOldest()
public:
LoggingEvent^ PopOldest()
Return Value
Type: LoggingEvent
The oldest logging event in the buffer
Remarks

            Gets the oldest (first) logging event in the buffer and removes it
            from the buffer.

See Also
CyclicBuffer Class
CyclicBuffer Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CyclicBuffer Properties

CyclicBuffer Properties Apache log4net™ SDK Documentation
The CyclicBuffer type exposes the following members.
Properties
 | Name | Description
Public property | Item | Gets the ith oldest event currently in the buffer.
Public property | Length | Gets the number of logging events in the buffer.
Public property | MaxSize | Gets the maximum size of the buffer.
Back to Top
See Also
CyclicBuffer Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CyclicBuffer.Item Property

CyclicBuffer Item Property Apache log4net™ SDK Documentation
Gets the ith oldest event currently in the buffer.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingEvent this[
    int i
] { get; }
public LoggingEvent this[
    int i
] { get; }
Public ReadOnly Default Property Item (
    i As Integer
) As LoggingEvent
    Get
Public ReadOnly Default Property Item (
    i As Integer
) As LoggingEvent
    Get
public:
property LoggingEvent^ default[int i] {
    LoggingEvent^ get (int i);
}
public:
property LoggingEvent^ default[int i] {
    LoggingEvent^ get (int i);
}
Parameters
i
Type:   Online System Int32
Property Value
Type: LoggingEvent
The ith oldest event currently in the buffer.
Remarks

            If i is outside the range 0 to the number of events
            currently in the buffer, then null is returned.

See Also
CyclicBuffer Class
CyclicBuffer Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CyclicBuffer.Length Property

CyclicBuffer Length Property Apache log4net™ SDK Documentation
Gets the number of logging events in the buffer.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Length { get; }
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
public:
property int Length {
    int get ();
}
Property Value
Type:   Online Int32
The number of logging events in the buffer.
Remarks

            This number is guaranteed to be in the range 0 to MaxSize
            (inclusive).

See Also
CyclicBuffer Class
CyclicBuffer Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


CyclicBuffer.MaxSize Property

CyclicBuffer MaxSize Property Apache log4net™ SDK Documentation
Gets the maximum size of the buffer.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxSize { get; }
public int MaxSize { get; }
Public ReadOnly Property MaxSize As Integer
    Get
Public ReadOnly Property MaxSize As Integer
    Get
public:
property int MaxSize {
    int get ();
}
public:
property int MaxSize {
    int get ();
}
Property Value
Type:   Online Int32
The maximum size of the buffer.
Remarks

            Gets the maximum size of the buffer

See Also
CyclicBuffer Class
CyclicBuffer Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyCollection Class

EmptyCollection Class Apache log4net™ SDK Documentation
An always empty Online ICollection.
Inheritance Hierarchy
Online System Object
log4net.Util EmptyCollection

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class EmptyCollection : ICollection,
    IEnumerable
[SerializableAttribute]
public sealed class EmptyCollection : ICollection,
    IEnumerable
<SerializableAttribute>
Public NotInheritable Class EmptyCollection
    Implements ICollection, IEnumerable
<SerializableAttribute>
Public NotInheritable Class EmptyCollection
    Implements ICollection, IEnumerable
[SerializableAttribute]
public ref class EmptyCollection sealed : ICollection,
    IEnumerable
[SerializableAttribute]
public ref class EmptyCollection sealed : ICollection,
    IEnumerable
Remarks

            A singleton implementation of the   Online ICollection
            interface that always represents an empty collection.

See Also
EmptyCollection Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyCollection Members

EmptyCollection Members Apache log4net™ SDK Documentation
The EmptyCollection type exposes the following members.
Methods
 | Name | Description
Public method | CopyTo | Copies the elements of the Online ICollection to an Online Array, starting at a particular Array index.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the Online ICollection.
 | Instance | Gets the singleton instance of the empty collection.
Public property | IsSynchronized | Gets a value indicating if access to the Online ICollection is synchronized (thread-safe).
Public property | SyncRoot | Gets an object that can be used to synchronize access to the Online ICollection.
Back to Top
See Also
EmptyCollection Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyCollection Methods

EmptyCollection Methods Apache log4net™ SDK Documentation
The EmptyCollection type exposes the following members.
Methods
 | Name | Description
Public method | CopyTo | Copies the elements of the Online ICollection to an Online Array, starting at a particular Array index.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
EmptyCollection Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyCollection.CopyTo Method

EmptyCollection CopyTo Method Apache log4net™ SDK Documentation
Copies the elements of the Online ICollection to an Online Array, starting at a particular Array index.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CopyTo(
    Array array,
    int index
)
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed
Parameters
array
Type:   Online System Array
The one-dimensional   Online Array
            that is the destination of the elements copied from
              Online ICollection. The Array must have zero-based
            indexing.
index
Type:   Online System Int32
The zero-based index in array at which
            copying begins.
Implements
  Online ICollection CopyTo(Array, Int32)
Remarks

            As the collection is empty no values are copied into the array.

See Also
EmptyCollection Class
EmptyCollection Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyCollection.GetEnumerator Method

EmptyCollection GetEnumerator Method Apache log4net™ SDK Documentation
Returns an enumerator that can iterate through a collection.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator GetEnumerator()
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
public:
virtual IEnumerator^ GetEnumerator() sealed
Return Value
Type:   Online IEnumerator

            An   Online IEnumerator that can be used to
            iterate through the collection.

Implements
  Online IEnumerable GetEnumerator
Remarks

            As the collection is empty a NullEnumerator is returned.

See Also
EmptyCollection Class
EmptyCollection Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyCollection Properties

EmptyCollection Properties Apache log4net™ SDK Documentation
The EmptyCollection type exposes the following members.
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the Online ICollection.
 | Instance | Gets the singleton instance of the empty collection.
Public property | IsSynchronized | Gets a value indicating if access to the Online ICollection is synchronized (thread-safe).
Public property | SyncRoot | Gets an object that can be used to synchronize access to the Online ICollection.
Back to Top
See Also
EmptyCollection Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyCollection.Count Property

EmptyCollection Count Property Apache log4net™ SDK Documentation
Gets the number of elements contained in the Online ICollection.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
public:
virtual property int Count {
    int get () sealed;
}
Property Value
Type:   Online Int32

            The number of elements contained in the   Online ICollection.

Implements
  Online ICollection Count
Remarks

            As the collection is empty the Count is always 0.

See Also
EmptyCollection Class
EmptyCollection Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyCollection.Instance Property

EmptyCollection Instance Property Apache log4net™ SDK Documentation
Gets the singleton instance of the empty collection.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static EmptyCollection Instance { get; }
public static EmptyCollection Instance { get; }
Public Shared ReadOnly Property Instance As EmptyCollection
    Get
Public Shared ReadOnly Property Instance As EmptyCollection
    Get
public:
static property EmptyCollection^ Instance {
    EmptyCollection^ get ();
}
public:
static property EmptyCollection^ Instance {
    EmptyCollection^ get ();
}
Return Value
Type: EmptyCollection
The singleton instance of the empty collection.
Remarks

            Gets the singleton instance of the empty collection.

See Also
EmptyCollection Class
EmptyCollection Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyCollection.IsSynchronized Property

EmptyCollection IsSynchronized Property Apache log4net™ SDK Documentation
Gets a value indicating if access to the Online ICollection is synchronized (thread-safe).

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsSynchronized { get; }
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}
Property Value
Type:   Online Boolean
true if access to the   Online ICollection is synchronized (thread-safe); otherwise, false.

Implements
  Online ICollection IsSynchronized
Remarks

            For the EmptyCollection this property is always true.

See Also
EmptyCollection Class
EmptyCollection Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyCollection.SyncRoot Property

EmptyCollection SyncRoot Property Apache log4net™ SDK Documentation
Gets an object that can be used to synchronize access to the Online ICollection.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object SyncRoot { get; }
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
Public ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}
Property Value
Type:   Online Object

            An object that can be used to synchronize access to the   Online ICollection.

Implements
  Online ICollection SyncRoot
Remarks

            As the collection is empty and thread safe and synchronized this instance is also
            the SyncRoot object.

See Also
EmptyCollection Class
EmptyCollection Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary Class

EmptyDictionary Class Apache log4net™ SDK Documentation
An always empty Online IDictionary.
Inheritance Hierarchy
Online System Object
log4net.Util EmptyDictionary

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class EmptyDictionary : IDictionary,
    ICollection, IEnumerable
[SerializableAttribute]
public sealed class EmptyDictionary : IDictionary,
    ICollection, IEnumerable
<SerializableAttribute>
Public NotInheritable Class EmptyDictionary
    Implements IDictionary, ICollection, IEnumerable
<SerializableAttribute>
Public NotInheritable Class EmptyDictionary
    Implements IDictionary, ICollection, IEnumerable
[SerializableAttribute]
public ref class EmptyDictionary sealed : IDictionary,
    ICollection, IEnumerable
[SerializableAttribute]
public ref class EmptyDictionary sealed : IDictionary,
    ICollection, IEnumerable
Remarks

            A singleton implementation of the   Online IDictionary
            interface that always represents an empty collection.

See Also
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary Members

EmptyDictionary Members Apache log4net™ SDK Documentation
The EmptyDictionary type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds an element with the provided key and value to the EmptyDictionary.
Public method | Clear | Removes all elements from the EmptyDictionary.
Public method | Contains | Determines whether the EmptyDictionary contains an element with the specified key.
Public method | CopyTo | Copies the elements of the Online ICollection to an Online Array, starting at a particular Array index.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Removes the element with the specified key from the EmptyDictionary.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the Online ICollection
 | Instance | Gets the singleton instance of the EmptyDictionary.
Public property | IsFixedSize | Gets a value indicating whether the EmptyDictionary has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the EmptyDictionary is read-only.
Public property | IsSynchronized | Gets a value indicating if access to the Online ICollection is synchronized (thread-safe).
Public property | Item | Gets or sets the element with the specified key.
Public property | Keys | Gets an Online ICollection containing the keys of the EmptyDictionary.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the Online ICollection.
Public property | Values | Gets an Online ICollection containing the values of the EmptyDictionary.
Back to Top
See Also
EmptyDictionary Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary Methods

EmptyDictionary Methods Apache log4net™ SDK Documentation
The EmptyDictionary type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds an element with the provided key and value to the EmptyDictionary.
Public method | Clear | Removes all elements from the EmptyDictionary.
Public method | Contains | Determines whether the EmptyDictionary contains an element with the specified key.
Public method | CopyTo | Copies the elements of the Online ICollection to an Online Array, starting at a particular Array index.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Removes the element with the specified key from the EmptyDictionary.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
EmptyDictionary Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.Add Method

EmptyDictionary Add Method Apache log4net™ SDK Documentation
Adds an element with the provided key and value to the EmptyDictionary.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    Object key,
    Object value
)
public void Add(
    Object key,
    Object value
)
Public Sub Add (
    key As Object,
    value As Object
)
Public Sub Add (
    key As Object,
    value As Object
)
public:
virtual void Add(
    Object^ key,
    Object^ value
) sealed
public:
virtual void Add(
    Object^ key,
    Object^ value
) sealed
Parameters
key
Type:   Online System Object
The   Online Object to use as the key of the element to add.
value
Type:   Online System Object
The   Online Object to use as the value of the element to add.
Implements
  Online IDictionary Add(Object, Object)
Exceptions
Exception | Condition
Online System InvalidOperationException | This dictionary is always empty and cannot be modified.
Remarks

            As the collection is empty no new values can be added. A   Online InvalidOperationException
            is thrown if this method is called.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.Clear Method

EmptyDictionary Clear Method Apache log4net™ SDK Documentation
Removes all elements from the EmptyDictionary.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
virtual void Clear() sealed
public:
virtual void Clear() sealed
Implements
  Online IDictionary Clear
Exceptions
Exception | Condition
Online System InvalidOperationException | This dictionary is always empty and cannot be modified.
Remarks

            As the collection is empty no values can be removed. A   Online InvalidOperationException
            is thrown if this method is called.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.Contains Method

EmptyDictionary Contains Method Apache log4net™ SDK Documentation
Determines whether the EmptyDictionary contains an element with the specified key.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Contains(
    Object key
)
public bool Contains(
    Object key
)
Public Function Contains (
    key As Object
) As Boolean
Public Function Contains (
    key As Object
) As Boolean
public:
virtual bool Contains(
    Object^ key
) sealed
public:
virtual bool Contains(
    Object^ key
) sealed
Parameters
key
Type:   Online System Object
The key to locate in the EmptyDictionary.
Return Value
Type:   Online Boolean
false
Implements
  Online IDictionary Contains(Object)
Remarks

            As the collection is empty the Contains(Object) method always returns false.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.CopyTo Method

EmptyDictionary CopyTo Method Apache log4net™ SDK Documentation
Copies the elements of the Online ICollection to an Online Array, starting at a particular Array index.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CopyTo(
    Array array,
    int index
)
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed
Parameters
array
Type:   Online System Array
The one-dimensional   Online Array
            that is the destination of the elements copied from
              Online ICollection. The Array must have zero-based
            indexing.
index
Type:   Online System Int32
The zero-based index in array at which
            copying begins.
Implements
  Online ICollection CopyTo(Array, Int32)
Remarks

            As the collection is empty no values are copied into the array.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.GetEnumerator Method

EmptyDictionary GetEnumerator Method Apache log4net™ SDK Documentation
Returns an enumerator that can iterate through a collection.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionaryEnumerator GetEnumerator()
public IDictionaryEnumerator GetEnumerator()
Public Function GetEnumerator As IDictionaryEnumerator
Public Function GetEnumerator As IDictionaryEnumerator
public:
virtual IDictionaryEnumerator^ GetEnumerator() sealed
public:
virtual IDictionaryEnumerator^ GetEnumerator() sealed
Return Value
Type:   Online IDictionaryEnumerator

            An   Online IEnumerator that can be used to
            iterate through the collection.

Implements
  Online IDictionary GetEnumerator
Remarks

            As the collection is empty a NullEnumerator is returned.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.Remove Method

EmptyDictionary Remove Method Apache log4net™ SDK Documentation
Removes the element with the specified key from the EmptyDictionary.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Remove(
    Object key
)
public void Remove(
    Object key
)
Public Sub Remove (
    key As Object
)
Public Sub Remove (
    key As Object
)
public:
virtual void Remove(
    Object^ key
) sealed
public:
virtual void Remove(
    Object^ key
) sealed
Parameters
key
Type:   Online System Object
The key of the element to remove.
Implements
  Online IDictionary Remove(Object)
Exceptions
Exception | Condition
Online System InvalidOperationException | This dictionary is always empty and cannot be modified.
Remarks

            As the collection is empty no values can be removed. A   Online InvalidOperationException
            is thrown if this method is called.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary Properties

EmptyDictionary Properties Apache log4net™ SDK Documentation
The EmptyDictionary type exposes the following members.
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the Online ICollection
 | Instance | Gets the singleton instance of the EmptyDictionary.
Public property | IsFixedSize | Gets a value indicating whether the EmptyDictionary has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the EmptyDictionary is read-only.
Public property | IsSynchronized | Gets a value indicating if access to the Online ICollection is synchronized (thread-safe).
Public property | Item | Gets or sets the element with the specified key.
Public property | Keys | Gets an Online ICollection containing the keys of the EmptyDictionary.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the Online ICollection.
Public property | Values | Gets an Online ICollection containing the values of the EmptyDictionary.
Back to Top
See Also
EmptyDictionary Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.Count Property

EmptyDictionary Count Property Apache log4net™ SDK Documentation
Gets the number of elements contained in the Online ICollection

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
public:
virtual property int Count {
    int get () sealed;
}
Property Value
Type:   Online Int32

            The number of elements contained in the   Online ICollection.

Implements
  Online ICollection Count
Remarks

            As the collection is empty the Count is always 0.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.Instance Property

EmptyDictionary Instance Property Apache log4net™ SDK Documentation
Gets the singleton instance of the EmptyDictionary.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static EmptyDictionary Instance { get; }
public static EmptyDictionary Instance { get; }
Public Shared ReadOnly Property Instance As EmptyDictionary
    Get
Public Shared ReadOnly Property Instance As EmptyDictionary
    Get
public:
static property EmptyDictionary^ Instance {
    EmptyDictionary^ get ();
}
public:
static property EmptyDictionary^ Instance {
    EmptyDictionary^ get ();
}
Return Value
Type: EmptyDictionary
The singleton instance of the EmptyDictionary.
Remarks

            Gets the singleton instance of the EmptyDictionary.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.IsFixedSize Property

EmptyDictionary IsFixedSize Property Apache log4net™ SDK Documentation
Gets a value indicating whether the EmptyDictionary has a fixed size.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsFixedSize { get; }
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get () sealed;
}
public:
virtual property bool IsFixedSize {
    bool get () sealed;
}
Property Value
Type:   Online Boolean
true
Implements
  Online IDictionary IsFixedSize
Remarks

            As the collection is empty IsFixedSize always returns true.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.IsReadOnly Property

EmptyDictionary IsReadOnly Property Apache log4net™ SDK Documentation
Gets a value indicating whether the EmptyDictionary is read-only.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadOnly { get; }
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
Property Value
Type:   Online Boolean
true
Implements
  Online IDictionary IsReadOnly
Remarks

            As the collection is empty IsReadOnly always returns true.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.IsSynchronized Property

EmptyDictionary IsSynchronized Property Apache log4net™ SDK Documentation
Gets a value indicating if access to the Online ICollection is synchronized (thread-safe).

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsSynchronized { get; }
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}
Property Value
Type:   Online Boolean
true if access to the   Online ICollection is synchronized (thread-safe); otherwise, false.

Implements
  Online ICollection IsSynchronized
Remarks

            For the EmptyCollection this property is always true.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.Item Property

EmptyDictionary Item Property Apache log4net™ SDK Documentation
Gets or sets the element with the specified key.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object this[
    Object key
] { get; set; }
public Object this[
    Object key
] { get; set; }
Public Default Property Item (
    key As Object
) As Object
    Get
    Set
Public Default Property Item (
    key As Object
) As Object
    Get
    Set
public:
virtual property Object^ default[Object^ key] {
    Object^ get (Object^ key) sealed;
    void set (Object^ key, Object^ value) sealed;
}
public:
virtual property Object^ default[Object^ key] {
    Object^ get (Object^ key) sealed;
    void set (Object^ key, Object^ value) sealed;
}
Parameters
key
Type:   Online System Object
The key of the element to get or set.
Property Value
Type:   Online Object
null
Implements
  Online IDictionary Item Object
Exceptions
Exception | Condition
Online System InvalidOperationException | This dictionary is always empty and cannot be modified.
Remarks

            As the collection is empty no values can be looked up or stored.
            If the index getter is called then null is returned.
            A   Online InvalidOperationException is thrown if the setter is called.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.Keys Property

EmptyDictionary Keys Property Apache log4net™ SDK Documentation
Gets an Online ICollection containing the keys of the EmptyDictionary.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection Keys { get; }
public ICollection Keys { get; }
Public ReadOnly Property Keys As ICollection
    Get
Public ReadOnly Property Keys As ICollection
    Get
public:
virtual property ICollection^ Keys {
    ICollection^ get () sealed;
}
public:
virtual property ICollection^ Keys {
    ICollection^ get () sealed;
}
Property Value
Type:   Online ICollection
An   Online ICollection containing the keys of the EmptyDictionary.
Implements
  Online IDictionary Keys
Remarks

            As the collection is empty a EmptyCollection is returned.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.SyncRoot Property

EmptyDictionary SyncRoot Property Apache log4net™ SDK Documentation
Gets an object that can be used to synchronize access to the Online ICollection.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object SyncRoot { get; }
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
Public ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}
Property Value
Type:   Online Object

            An object that can be used to synchronize access to the   Online ICollection.

Implements
  Online ICollection SyncRoot
Remarks

            As the collection is empty and thread safe and synchronized this instance is also
            the SyncRoot object.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


EmptyDictionary.Values Property

EmptyDictionary Values Property Apache log4net™ SDK Documentation
Gets an Online ICollection containing the values of the EmptyDictionary.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection Values { get; }
public ICollection Values { get; }
Public ReadOnly Property Values As ICollection
    Get
Public ReadOnly Property Values As ICollection
    Get
public:
virtual property ICollection^ Values {
    ICollection^ get () sealed;
}
public:
virtual property ICollection^ Values {
    ICollection^ get () sealed;
}
Property Value
Type:   Online ICollection
An   Online ICollection containing the values of the EmptyDictionary.
Implements
  Online IDictionary Values
Remarks

            As the collection is empty a EmptyCollection is returned.

See Also
EmptyDictionary Class
EmptyDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FormattingInfo Class

FormattingInfo Class Apache log4net™ SDK Documentation
Contain the information obtained when parsing formatting modifiers in conversion modifiers.
Inheritance Hierarchy
Online System Object
log4net.Util FormattingInfo

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FormattingInfo
public class FormattingInfo
Public Class FormattingInfo
Public Class FormattingInfo
public ref class FormattingInfo
public ref class FormattingInfo
Remarks

            Holds the formatting information extracted from the format string by
            the PatternParser. This is used by the PatternConverter
            objects when rendering the output.

See Also
FormattingInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FormattingInfo Members

FormattingInfo Members Apache log4net™ SDK Documentation
The FormattingInfo type exposes the following members.
Constructors
 | Name | Description
Public method | FormattingInfo | Defaut Constructor
Public method | FormattingInfo(Int32, Int32, Boolean) | Constructor
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | LeftAlign | Gets or sets a flag indicating whether left align is enabled or not.
Public property | Max | Gets or sets the maximum value.
Public property | Min | Gets or sets the minimum value.
Back to Top
See Also
FormattingInfo Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FormattingInfo Constructor

FormattingInfo Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | FormattingInfo | Defaut Constructor
Public method | FormattingInfo(Int32, Int32, Boolean) | Constructor
Back to Top
See Also
FormattingInfo Class
FormattingInfo Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FormattingInfo Constructor

FormattingInfo Constructor Apache log4net™ SDK Documentation
Defaut Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FormattingInfo()
public FormattingInfo()
Public Sub New
Public Sub New
public:
FormattingInfo()
public:
FormattingInfo()
Remarks

            Initializes a new instance of the FormattingInfo class.

See Also
FormattingInfo Class
FormattingInfo Members
FormattingInfo Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FormattingInfo Constructor (Int32, Int32, Boolean)

FormattingInfo Constructor (Int32, Int32, Boolean) Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FormattingInfo(
    int min,
    int max,
    bool leftAlign
)
public FormattingInfo(
    int min,
    int max,
    bool leftAlign
)
Public Sub New (
    min As Integer,
    max As Integer,
    leftAlign As Boolean
)
Public Sub New (
    min As Integer,
    max As Integer,
    leftAlign As Boolean
)
public:
FormattingInfo(
    int min,
    int max,
    bool leftAlign
)
public:
FormattingInfo(
    int min,
    int max,
    bool leftAlign
)
Parameters
min
Type:   Online System Int32
[Missing <param name="min"/> documentation for "M:log4net.Util.FormattingInfo.#ctor(System.Int32,System.Int32,System.Boolean)"]
max
Type:   Online System Int32
[Missing <param name="max"/> documentation for "M:log4net.Util.FormattingInfo.#ctor(System.Int32,System.Int32,System.Boolean)"]
leftAlign
Type:   Online System Boolean
[Missing <param name="leftAlign"/> documentation for "M:log4net.Util.FormattingInfo.#ctor(System.Int32,System.Int32,System.Boolean)"]
Remarks

            Initializes a new instance of the FormattingInfo class
            with the specified parameters.

See Also
FormattingInfo Class
FormattingInfo Members
FormattingInfo Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FormattingInfo Methods

FormattingInfo Methods Apache log4net™ SDK Documentation
The FormattingInfo type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FormattingInfo Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FormattingInfo Properties

FormattingInfo Properties Apache log4net™ SDK Documentation
The FormattingInfo type exposes the following members.
Properties
 | Name | Description
Public property | LeftAlign | Gets or sets a flag indicating whether left align is enabled or not.
Public property | Max | Gets or sets the maximum value.
Public property | Min | Gets or sets the minimum value.
Back to Top
See Also
FormattingInfo Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FormattingInfo.LeftAlign Property

FormattingInfo LeftAlign Property Apache log4net™ SDK Documentation
Gets or sets a flag indicating whether left align is enabled or not.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool LeftAlign { get; set; }
public bool LeftAlign { get; set; }
Public Property LeftAlign As Boolean
    Get
    Set
Public Property LeftAlign As Boolean
    Get
    Set
public:
property bool LeftAlign {
    bool get ();
    void set (bool value);
}
public:
property bool LeftAlign {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean

            A flag indicating whether left align is enabled or not.

Remarks

            Gets or sets a flag indicating whether left align is enabled or not.

See Also
FormattingInfo Class
FormattingInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FormattingInfo.Max Property

FormattingInfo Max Property Apache log4net™ SDK Documentation
Gets or sets the maximum value.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Max { get; set; }
public int Max { get; set; }
Public Property Max As Integer
    Get
    Set
Public Property Max As Integer
    Get
    Set
public:
property int Max {
    int get ();
    void set (int value);
}
public:
property int Max {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32

            The maximum value.

Remarks

            Gets or sets the maximum value.

See Also
FormattingInfo Class
FormattingInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


FormattingInfo.Min Property

FormattingInfo Min Property Apache log4net™ SDK Documentation
Gets or sets the minimum value.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Min { get; set; }
public int Min { get; set; }
Public Property Min As Integer
    Get
    Set
Public Property Min As Integer
    Get
    Set
public:
property int Min {
    int get ();
    void set (int value);
}
public:
property int Min {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32

            The minimum value.

Remarks

            Gets or sets the minimum value.

See Also
FormattingInfo Class
FormattingInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


GlobalContextProperties Class

GlobalContextProperties Class Apache log4net™ SDK Documentation
Implementation of Properties collection for the GlobalContext
Inheritance Hierarchy
Online System Object
log4net.Util ContextPropertiesBase
log4net.Util GlobalContextProperties

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class GlobalContextProperties : ContextPropertiesBase
public sealed class GlobalContextProperties : ContextPropertiesBase
Public NotInheritable Class GlobalContextProperties
    Inherits ContextPropertiesBase
Public NotInheritable Class GlobalContextProperties
    Inherits ContextPropertiesBase
public ref class GlobalContextProperties sealed : public ContextPropertiesBase
public ref class GlobalContextProperties sealed : public ContextPropertiesBase
Remarks

            This class implements a properties collection that is thread safe and supports both
            storing properties and capturing a read only copy of the current propertied.

            This class is optimized to the scenario where the properties are read frequently
            and are modified infrequently.

See Also
GlobalContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


GlobalContextProperties Members

GlobalContextProperties Members Apache log4net™ SDK Documentation
The GlobalContextProperties type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Clear the global context properties
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Remove a property from the global context
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | Gets or sets the value of a property (Overrides ContextPropertiesBase Item String .)
Back to Top
See Also
GlobalContextProperties Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


GlobalContextProperties Methods

GlobalContextProperties Methods Apache log4net™ SDK Documentation
The GlobalContextProperties type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Clear the global context properties
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Remove a property from the global context
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
GlobalContextProperties Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


GlobalContextProperties.Clear Method

GlobalContextProperties Clear Method Apache log4net™ SDK Documentation
Clear the global context properties

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
See Also
GlobalContextProperties Class
GlobalContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


GlobalContextProperties.Remove Method

GlobalContextProperties Remove Method Apache log4net™ SDK Documentation
Remove a property from the global context

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Remove(
    string key
)
public void Remove(
    string key
)
Public Sub Remove (
    key As String
)
Public Sub Remove (
    key As String
)
public:
void Remove(
    String^ key
)
public:
void Remove(
    String^ key
)
Parameters
key
Type:   Online System String
the key for the entry to remove
Remarks

            Removing an entry from the global context properties is relatively expensive compared
            with reading a value.

See Also
GlobalContextProperties Class
GlobalContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


GlobalContextProperties Properties

GlobalContextProperties Properties Apache log4net™ SDK Documentation
The GlobalContextProperties type exposes the following members.
Properties
 | Name | Description
Public property | Item | Gets or sets the value of a property (Overrides ContextPropertiesBase Item String .)
Back to Top
See Also
GlobalContextProperties Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


GlobalContextProperties.Item Property

GlobalContextProperties Item Property Apache log4net™ SDK Documentation
Gets or sets the value of a property

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object this[
    string key
] { get; set; }
public override Object this[
    string key
] { get; set; }
Public Overrides Default Property Item (
    key As String
) As Object
    Get
    Set
Public Overrides Default Property Item (
    key As String
) As Object
    Get
    Set
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key) override;
    void set (String^ key, Object^ value) override;
}
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key) override;
    void set (String^ key, Object^ value) override;
}
Parameters
key
Type:   Online System String
Property Value
Type:   Online Object

            The value for the property with the specified key

Remarks

            Reading the value for a key is faster than setting the value.
            When the value is written a new read only copy of
            the properties is created.

See Also
GlobalContextProperties Class
GlobalContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions Class

ILogExtensions Class Apache log4net™ SDK Documentation
The static class ILogExtensions contains a set of widely used methods that ease the interaction with the ILog interface implementations.
Inheritance Hierarchy
Online System Object
log4net.Util ILogExtensions

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ILogExtensions
public static class ILogExtensions
<ExtensionAttribute>
Public NotInheritable Class ILogExtensions
<ExtensionAttribute>
Public NotInheritable Class ILogExtensions
[ExtensionAttribute]
public ref class ILogExtensions abstract sealed
[ExtensionAttribute]
public ref class ILogExtensions abstract sealed
Remarks

            This class contains methods for logging at different levels and checks the
            properties for determining if those logging levels are enabled in the current
            configuration.

Examples
Simple example of logging messages

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
using log4net.Util;

ILog log = LogManager.GetLogger("application-log");

log.InfoExt("Application Start");
log.DebugExt("This is a debug message");
using log4net.Util;

ILog log = LogManager.GetLogger("application-log");

log.InfoExt("Application Start");
log.DebugExt("This is a debug message");
See Also
ILogExtensions Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions Members

ILogExtensions Members Apache log4net™ SDK Documentation
Methods
Name | Description
DebugExt(ILog, Func TResult ) |
DebugExt(ILog, Object) | Log a message object with the Debug level.
DebugExt(ILog, Func TResult , Void) |
DebugExt(ILog, Object, Exception) | Log a message object with the Debug level including the stack trace of the Online Exception passed as a parameter.
DebugFormatExt(ILog, String, Object) | Logs a formatted message string with the Debug level.
DebugFormatExt(ILog, String, Object ) | Logs a formatted message string with the Debug level.
DebugFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Debug level.
DebugFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Debug level.
DebugFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Debug level.
ErrorExt(ILog, Func TResult ) |
ErrorExt(ILog, Object) | Log a message object with the Error level.
ErrorExt(ILog, Func TResult , Void) |
ErrorExt(ILog, Object, Exception) | Log a message object with the Error level including the stack trace of the Online Exception passed as a parameter.
ErrorFormatExt(ILog, String, Object) | Logs a formatted message string with the Error level.
ErrorFormatExt(ILog, String, Object ) | Logs a formatted message string with the Error level.
ErrorFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Error level.
ErrorFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Error level.
ErrorFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Error level.
FatalExt(ILog, Func TResult ) |
FatalExt(ILog, Object) | Log a message object with the Fatal level.
FatalExt(ILog, Func TResult , Void) |
FatalExt(ILog, Object, Exception) | Log a message object with the Fatal level including the stack trace of the Online Exception passed as a parameter.
FatalFormatExt(ILog, String, Object) | Logs a formatted message string with the Fatal level.
FatalFormatExt(ILog, String, Object ) | Logs a formatted message string with the Fatal level.
FatalFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Fatal level.
FatalFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Fatal level.
FatalFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Fatal level.
InfoExt(ILog, Func TResult ) |
InfoExt(ILog, Object) | Log a message object with the Info level.
InfoExt(ILog, Func TResult , Void) |
InfoExt(ILog, Object, Exception) | Log a message object with the Info level including the stack trace of the Online Exception passed as a parameter.
InfoFormatExt(ILog, String, Object) | Logs a formatted message string with the Info level.
InfoFormatExt(ILog, String, Object ) | Logs a formatted message string with the Info level.
InfoFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Info level.
InfoFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Info level.
InfoFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Info level.
WarnExt(ILog, Func TResult ) |
WarnExt(ILog, Object) | Log a message object with the Warn level.
WarnExt(ILog, Func TResult , Void) |
WarnExt(ILog, Object, Exception) | Log a message object with the Warn level including the stack trace of the Online Exception passed as a parameter.
WarnFormatExt(ILog, String, Object) | Logs a formatted message string with the Warn level.
WarnFormatExt(ILog, String, Object ) | Logs a formatted message string with the Warn level.
WarnFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Warn level.
WarnFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Warn level.
WarnFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Warn level.
Back to Top
See Also
ILogExtensions Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions Methods

ILogExtensions Methods Apache log4net™ SDK Documentation
Methods
Name | Description
DebugExt(ILog, Func TResult ) |
DebugExt(ILog, Object) | Log a message object with the Debug level.
DebugExt(ILog, Func TResult , Void) |
DebugExt(ILog, Object, Exception) | Log a message object with the Debug level including the stack trace of the Online Exception passed as a parameter.
DebugFormatExt(ILog, String, Object) | Logs a formatted message string with the Debug level.
DebugFormatExt(ILog, String, Object ) | Logs a formatted message string with the Debug level.
DebugFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Debug level.
DebugFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Debug level.
DebugFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Debug level.
ErrorExt(ILog, Func TResult ) |
ErrorExt(ILog, Object) | Log a message object with the Error level.
ErrorExt(ILog, Func TResult , Void) |
ErrorExt(ILog, Object, Exception) | Log a message object with the Error level including the stack trace of the Online Exception passed as a parameter.
ErrorFormatExt(ILog, String, Object) | Logs a formatted message string with the Error level.
ErrorFormatExt(ILog, String, Object ) | Logs a formatted message string with the Error level.
ErrorFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Error level.
ErrorFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Error level.
ErrorFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Error level.
FatalExt(ILog, Func TResult ) |
FatalExt(ILog, Object) | Log a message object with the Fatal level.
FatalExt(ILog, Func TResult , Void) |
FatalExt(ILog, Object, Exception) | Log a message object with the Fatal level including the stack trace of the Online Exception passed as a parameter.
FatalFormatExt(ILog, String, Object) | Logs a formatted message string with the Fatal level.
FatalFormatExt(ILog, String, Object ) | Logs a formatted message string with the Fatal level.
FatalFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Fatal level.
FatalFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Fatal level.
FatalFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Fatal level.
InfoExt(ILog, Func TResult ) |
InfoExt(ILog, Object) | Log a message object with the Info level.
InfoExt(ILog, Func TResult , Void) |
InfoExt(ILog, Object, Exception) | Log a message object with the Info level including the stack trace of the Online Exception passed as a parameter.
InfoFormatExt(ILog, String, Object) | Logs a formatted message string with the Info level.
InfoFormatExt(ILog, String, Object ) | Logs a formatted message string with the Info level.
InfoFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Info level.
InfoFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Info level.
InfoFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Info level.
WarnExt(ILog, Func TResult ) |
WarnExt(ILog, Object) | Log a message object with the Warn level.
WarnExt(ILog, Func TResult , Void) |
WarnExt(ILog, Object, Exception) | Log a message object with the Warn level including the stack trace of the Online Exception passed as a parameter.
WarnFormatExt(ILog, String, Object) | Logs a formatted message string with the Warn level.
WarnFormatExt(ILog, String, Object ) | Logs a formatted message string with the Warn level.
WarnFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Warn level.
WarnFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Warn level.
WarnFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Warn level.
Back to Top
See Also
ILogExtensions Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.DebugExt Method

ILogExtensions DebugExt Method Apache log4net™ SDK Documentation
Log a message object with the Debug level.
Overload List
Name | Description
DebugExt(ILog, Func TResult ) |
DebugExt(ILog, Object) | Log a message object with the Debug level.
DebugExt(ILog, Func TResult , Void) |
DebugExt(ILog, Object, Exception) | Log a message object with the Debug level including the stack trace of the Online Exception passed as a parameter.
Back to Top
See Also
ILogExtensions Class
ILogExtensions Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.DebugExt Method (ILog, Func)

ILogExtensions DebugExt Method (ILog, Func) Apache log4net™ SDK Documentation

[Missing <summary> documentation for "M:log4net.Util.ILogExtensions.DebugExt(log4net.ILog,System.Func`1)"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DebugExt(
    this ILog logger,
    Func callback
)
public static void DebugExt(
    this ILog logger,
    Func callback
)
<ExtensionAttribute>
Public Shared Sub DebugExt (
    logger As ILog,
    callback As Func
)
<ExtensionAttribute>
Public Shared Sub DebugExt (
    logger As ILog,
    callback As Func
)
public:
[ExtensionAttribute]
static void DebugExt(
    ILog^ logger,
    Func^ callback
)
public:
[ExtensionAttribute]
static void DebugExt(
    ILog^ logger,
    Func^ callback
)
Parameters
logger
Type: log4net ILog
[Missing <param name="logger"/> documentation for "M:log4net.Util.ILogExtensions.DebugExt(log4net.ILog,System.Func`1)"]
callback
Type:   Online System Func TResult
[Missing <param name="callback"/> documentation for "M:log4net.Util.ILogExtensions.DebugExt(log4net.ILog,System.Func`1)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
ILogExtensions Class
ILogExtensions Members
DebugExt Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.DebugExt Method (ILog, Object)

ILogExtensions DebugExt Method (ILog, Object) Apache log4net™ SDK Documentation
Log a message object with the Debug level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DebugExt(
    this ILog logger,
    Object message
)
public static void DebugExt(
    this ILog logger,
    Object message
)
<ExtensionAttribute>
Public Shared Sub DebugExt (
    logger As ILog,
    message As Object
)
<ExtensionAttribute>
Public Shared Sub DebugExt (
    logger As ILog,
    message As Object
)
public:
[ExtensionAttribute]
static void DebugExt(
    ILog^ logger,
    Object^ message
)
public:
[ExtensionAttribute]
static void DebugExt(
    ILog^ logger,
    Object^ message
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
message
Type:   Online System Object
The message object to log.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            This method first checks if this logger is INFO
            enabled by reading the value  property.
            This check happens always and does not depend on the
            implementation. If this logger is INFO enabled, then it converts
            the message object (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger
            and also higher in the hierarchy depending on the value of
            the additivity flag.

WARNING Note that passing an   Online Exception
            to this method will print the name of the   Online Exception
            but no stack trace. To print a stack trace use the
            DebugExt(ILog, Object, Exception) form instead.

See Also
ILogExtensions Class
ILogExtensions Members
DebugExt Overload
log4net.Util Namespace
ILog IsDebugEnabled
log4net ILog
ILog Debug(Object)
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.DebugExt Method (ILog, Func, Void)

ILogExtensions DebugExt Method (ILog, Func, Void) Apache log4net™ SDK Documentation

[Missing <summary> documentation for "M:log4net.Util.ILogExtensions.DebugExt(log4net.ILog,System.Func`1,System.Void)"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DebugExt(
    this ILog logger,
    Func callback,
    void exception
)
public static void DebugExt(
    this ILog logger,
    Func callback,
    void exception
)
<ExtensionAttribute>
Public Shared Sub DebugExt (
    logger As ILog,
    callback As Func,
    exception As Void
)
<ExtensionAttribute>
Public Shared Sub DebugExt (
    logger As ILog,
    callback As Func,
    exception As Void
)
public:
[ExtensionAttribute]
static void DebugExt(
    ILog^ logger,
    Func^ callback,
    void exception
)
public:
[ExtensionAttribute]
static void DebugExt(
    ILog^ logger,
    Func^ callback,
    void exception
)
Parameters
logger
Type: log4net ILog
[Missing <param name="logger"/> documentation for "M:log4net.Util.ILogExtensions.DebugExt(log4net.ILog,System.Func`1,System.Void)"]
callback
Type:   Online System Func TResult
[Missing <param name="callback"/> documentation for "M:log4net.Util.ILogExtensions.DebugExt(log4net.ILog,System.Func`1,System.Void)"]
exception
Type:   Online System Void
[Missing <param name="exception"/> documentation for "M:log4net.Util.ILogExtensions.DebugExt(log4net.ILog,System.Func`1,System.Void)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
ILogExtensions Class
ILogExtensions Members
DebugExt Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.DebugExt Method (ILog, Object, Exception)

ILogExtensions DebugExt Method (ILog, Object, Exception) Apache log4net™ SDK Documentation
Log a message object with the Debug level including the stack trace of the Online Exception passed as a parameter.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DebugExt(
    this ILog logger,
    Object message,
    Exception exception
)
public static void DebugExt(
    this ILog logger,
    Object message,
    Exception exception
)
<ExtensionAttribute>
Public Shared Sub DebugExt (
    logger As ILog,
    message As Object,
    exception As Exception
)
<ExtensionAttribute>
Public Shared Sub DebugExt (
    logger As ILog,
    message As Object,
    exception As Exception
)
public:
[ExtensionAttribute]
static void DebugExt(
    ILog^ logger,
    Object^ message,
    Exception^ exception
)
public:
[ExtensionAttribute]
static void DebugExt(
    ILog^ logger,
    Object^ message,
    Exception^ exception
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            See the DebugExt(ILog, Object) form for more detailed information.

See Also
ILogExtensions Class
ILogExtensions Members
DebugExt Overload
log4net.Util Namespace
ILog Debug(Object)
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.DebugFormatExt Method

ILogExtensions DebugFormatExt Method Apache log4net™ SDK Documentation
Overload List
Name | Description
DebugFormatExt(ILog, String, Object) | Logs a formatted message string with the Debug level.
DebugFormatExt(ILog, String, Object ) | Logs a formatted message string with the Debug level.
DebugFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Debug level.
DebugFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Debug level.
DebugFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Debug level.
Back to Top
See Also
ILogExtensions Class
ILogExtensions Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.DebugFormatExt Method (ILog, String, Object)

ILogExtensions DebugFormatExt Method (ILog, String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Debug level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DebugFormatExt(
    this ILog logger,
    string format,
    Object arg0
)
public static void DebugFormatExt(
    this ILog logger,
    string format,
    Object arg0
)
<ExtensionAttribute>
Public Shared Sub DebugFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object
)
<ExtensionAttribute>
Public Shared Sub DebugFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object
)
public:
[ExtensionAttribute]
static void DebugFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0
)
public:
[ExtensionAttribute]
static void DebugFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the DebugExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
DebugFormatExt Overload
log4net.Util Namespace
ILog Debug(Object)
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.DebugFormatExt Method (ILog, String, Object[])

ILogExtensions DebugFormatExt Method (ILog, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Debug level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DebugFormatExt(
    this ILog logger,
    string format,
    params Object[] args
)
public static void DebugFormatExt(
    this ILog logger,
    string format,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Sub DebugFormatExt (
    logger As ILog,
    format As String,
    ParamArray args As Object()
)
<ExtensionAttribute>
Public Shared Sub DebugFormatExt (
    logger As ILog,
    format As String,
    ParamArray args As Object()
)
public:
[ExtensionAttribute]
static void DebugFormatExt(
    ILog^ logger,
    String^ format,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static void DebugFormatExt(
    ILog^ logger,
    String^ format,
    ... array<Object^>^ args
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the DebugExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
DebugFormatExt Overload
log4net.Util Namespace
ILog Debug(Object)
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.DebugFormatExt Method (ILog, IFormatProvider, String, Object[])

ILogExtensions DebugFormatExt Method (ILog, IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Debug level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DebugFormatExt(
    this ILog logger,
    IFormatProvider provider,
    string format,
    params Object[] args
)
public static void DebugFormatExt(
    this ILog logger,
    IFormatProvider provider,
    string format,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Sub DebugFormatExt (
    logger As ILog,
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
<ExtensionAttribute>
Public Shared Sub DebugFormatExt (
    logger As ILog,
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
public:
[ExtensionAttribute]
static void DebugFormatExt(
    ILog^ logger,
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static void DebugFormatExt(
    ILog^ logger,
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the DebugExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
DebugFormatExt Overload
log4net.Util Namespace
ILog Debug(Object)
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.DebugFormatExt Method (ILog, String, Object, Object)

ILogExtensions DebugFormatExt Method (ILog, String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Debug level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DebugFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1
)
public static void DebugFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1
)
<ExtensionAttribute>
Public Shared Sub DebugFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object
)
<ExtensionAttribute>
Public Shared Sub DebugFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object
)
public:
[ExtensionAttribute]
static void DebugFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1
)
public:
[ExtensionAttribute]
static void DebugFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the DebugExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
DebugFormatExt Overload
log4net.Util Namespace
ILog Debug(Object)
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.DebugFormatExt Method (ILog, String, Object, Object, Object)

ILogExtensions DebugFormatExt Method (ILog, String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Debug level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DebugFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
public static void DebugFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
<ExtensionAttribute>
Public Shared Sub DebugFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
<ExtensionAttribute>
Public Shared Sub DebugFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
public:
[ExtensionAttribute]
static void DebugFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
public:
[ExtensionAttribute]
static void DebugFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the DebugExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
DebugFormatExt Overload
log4net.Util Namespace
ILog Debug(Object)
ILog IsDebugEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.ErrorExt Method

ILogExtensions ErrorExt Method Apache log4net™ SDK Documentation
Log a message object with the Error level.
Overload List
Name | Description
ErrorExt(ILog, Func TResult ) |
ErrorExt(ILog, Object) | Log a message object with the Error level.
ErrorExt(ILog, Func TResult , Void) |
ErrorExt(ILog, Object, Exception) | Log a message object with the Error level including the stack trace of the Online Exception passed as a parameter.
Back to Top
See Also
ILogExtensions Class
ILogExtensions Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.ErrorExt Method (ILog, Func)

ILogExtensions ErrorExt Method (ILog, Func) Apache log4net™ SDK Documentation

[Missing <summary> documentation for "M:log4net.Util.ILogExtensions.ErrorExt(log4net.ILog,System.Func`1)"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ErrorExt(
    this ILog logger,
    Func callback
)
public static void ErrorExt(
    this ILog logger,
    Func callback
)
<ExtensionAttribute>
Public Shared Sub ErrorExt (
    logger As ILog,
    callback As Func
)
<ExtensionAttribute>
Public Shared Sub ErrorExt (
    logger As ILog,
    callback As Func
)
public:
[ExtensionAttribute]
static void ErrorExt(
    ILog^ logger,
    Func^ callback
)
public:
[ExtensionAttribute]
static void ErrorExt(
    ILog^ logger,
    Func^ callback
)
Parameters
logger
Type: log4net ILog
[Missing <param name="logger"/> documentation for "M:log4net.Util.ILogExtensions.ErrorExt(log4net.ILog,System.Func`1)"]
callback
Type:   Online System Func TResult
[Missing <param name="callback"/> documentation for "M:log4net.Util.ILogExtensions.ErrorExt(log4net.ILog,System.Func`1)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
ILogExtensions Class
ILogExtensions Members
ErrorExt Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.ErrorExt Method (ILog, Object)

ILogExtensions ErrorExt Method (ILog, Object) Apache log4net™ SDK Documentation
Log a message object with the Error level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ErrorExt(
    this ILog logger,
    Object message
)
public static void ErrorExt(
    this ILog logger,
    Object message
)
<ExtensionAttribute>
Public Shared Sub ErrorExt (
    logger As ILog,
    message As Object
)
<ExtensionAttribute>
Public Shared Sub ErrorExt (
    logger As ILog,
    message As Object
)
public:
[ExtensionAttribute]
static void ErrorExt(
    ILog^ logger,
    Object^ message
)
public:
[ExtensionAttribute]
static void ErrorExt(
    ILog^ logger,
    Object^ message
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
message
Type:   Online System Object
The message object to log.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            This method first checks if this logger is ERROR
            enabled by reading the value  property.
            This check happens always and does not depend on the
            implementation. If this logger is ERROR enabled, then it converts
            the message object (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger
            and also higher in the hierarchy depending on the value of
            the additivity flag.

WARNING Note that passing an   Online Exception
            to this method will print the name of the   Online Exception
            but no stack trace. To print a stack trace use the
            ErrorExt(ILog, Object, Exception) form instead.

See Also
ILogExtensions Class
ILogExtensions Members
ErrorExt Overload
log4net.Util Namespace
ILog IsErrorEnabled
log4net ILog
ILog Error(Object)
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.ErrorExt Method (ILog, Func, Void)

ILogExtensions ErrorExt Method (ILog, Func, Void) Apache log4net™ SDK Documentation

[Missing <summary> documentation for "M:log4net.Util.ILogExtensions.ErrorExt(log4net.ILog,System.Func`1,System.Void)"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ErrorExt(
    this ILog logger,
    Func callback,
    void exception
)
public static void ErrorExt(
    this ILog logger,
    Func callback,
    void exception
)
<ExtensionAttribute>
Public Shared Sub ErrorExt (
    logger As ILog,
    callback As Func,
    exception As Void
)
<ExtensionAttribute>
Public Shared Sub ErrorExt (
    logger As ILog,
    callback As Func,
    exception As Void
)
public:
[ExtensionAttribute]
static void ErrorExt(
    ILog^ logger,
    Func^ callback,
    void exception
)
public:
[ExtensionAttribute]
static void ErrorExt(
    ILog^ logger,
    Func^ callback,
    void exception
)
Parameters
logger
Type: log4net ILog
[Missing <param name="logger"/> documentation for "M:log4net.Util.ILogExtensions.ErrorExt(log4net.ILog,System.Func`1,System.Void)"]
callback
Type:   Online System Func TResult
[Missing <param name="callback"/> documentation for "M:log4net.Util.ILogExtensions.ErrorExt(log4net.ILog,System.Func`1,System.Void)"]
exception
Type:   Online System Void
[Missing <param name="exception"/> documentation for "M:log4net.Util.ILogExtensions.ErrorExt(log4net.ILog,System.Func`1,System.Void)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
ILogExtensions Class
ILogExtensions Members
ErrorExt Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.ErrorExt Method (ILog, Object, Exception)

ILogExtensions ErrorExt Method (ILog, Object, Exception) Apache log4net™ SDK Documentation
Log a message object with the Error level including the stack trace of the Online Exception passed as a parameter.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ErrorExt(
    this ILog logger,
    Object message,
    Exception exception
)
public static void ErrorExt(
    this ILog logger,
    Object message,
    Exception exception
)
<ExtensionAttribute>
Public Shared Sub ErrorExt (
    logger As ILog,
    message As Object,
    exception As Exception
)
<ExtensionAttribute>
Public Shared Sub ErrorExt (
    logger As ILog,
    message As Object,
    exception As Exception
)
public:
[ExtensionAttribute]
static void ErrorExt(
    ILog^ logger,
    Object^ message,
    Exception^ exception
)
public:
[ExtensionAttribute]
static void ErrorExt(
    ILog^ logger,
    Object^ message,
    Exception^ exception
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            See the ErrorExt(ILog, Object) form for more detailed information.

See Also
ILogExtensions Class
ILogExtensions Members
ErrorExt Overload
log4net.Util Namespace
ILog Error(Object)
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.ErrorFormatExt Method

ILogExtensions ErrorFormatExt Method Apache log4net™ SDK Documentation
Overload List
Name | Description
ErrorFormatExt(ILog, String, Object) | Logs a formatted message string with the Error level.
ErrorFormatExt(ILog, String, Object ) | Logs a formatted message string with the Error level.
ErrorFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Error level.
ErrorFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Error level.
ErrorFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Error level.
Back to Top
See Also
ILogExtensions Class
ILogExtensions Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.ErrorFormatExt Method (ILog, String, Object)

ILogExtensions ErrorFormatExt Method (ILog, String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Error level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ErrorFormatExt(
    this ILog logger,
    string format,
    Object arg0
)
public static void ErrorFormatExt(
    this ILog logger,
    string format,
    Object arg0
)
<ExtensionAttribute>
Public Shared Sub ErrorFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object
)
<ExtensionAttribute>
Public Shared Sub ErrorFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object
)
public:
[ExtensionAttribute]
static void ErrorFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0
)
public:
[ExtensionAttribute]
static void ErrorFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the ErrorExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
ErrorFormatExt Overload
log4net.Util Namespace
ILog Error(Object)
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.ErrorFormatExt Method (ILog, String, Object[])

ILogExtensions ErrorFormatExt Method (ILog, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Error level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ErrorFormatExt(
    this ILog logger,
    string format,
    params Object[] args
)
public static void ErrorFormatExt(
    this ILog logger,
    string format,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Sub ErrorFormatExt (
    logger As ILog,
    format As String,
    ParamArray args As Object()
)
<ExtensionAttribute>
Public Shared Sub ErrorFormatExt (
    logger As ILog,
    format As String,
    ParamArray args As Object()
)
public:
[ExtensionAttribute]
static void ErrorFormatExt(
    ILog^ logger,
    String^ format,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static void ErrorFormatExt(
    ILog^ logger,
    String^ format,
    ... array<Object^>^ args
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the ErrorExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
ErrorFormatExt Overload
log4net.Util Namespace
ILog Error(Object)
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.ErrorFormatExt Method (ILog, IFormatProvider, String, Object[])

ILogExtensions ErrorFormatExt Method (ILog, IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Error level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ErrorFormatExt(
    this ILog logger,
    IFormatProvider provider,
    string format,
    params Object[] args
)
public static void ErrorFormatExt(
    this ILog logger,
    IFormatProvider provider,
    string format,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Sub ErrorFormatExt (
    logger As ILog,
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
<ExtensionAttribute>
Public Shared Sub ErrorFormatExt (
    logger As ILog,
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
public:
[ExtensionAttribute]
static void ErrorFormatExt(
    ILog^ logger,
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static void ErrorFormatExt(
    ILog^ logger,
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the ErrorExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
ErrorFormatExt Overload
log4net.Util Namespace
ILog Error(Object)
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.ErrorFormatExt Method (ILog, String, Object, Object)

ILogExtensions ErrorFormatExt Method (ILog, String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Error level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ErrorFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1
)
public static void ErrorFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1
)
<ExtensionAttribute>
Public Shared Sub ErrorFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object
)
<ExtensionAttribute>
Public Shared Sub ErrorFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object
)
public:
[ExtensionAttribute]
static void ErrorFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1
)
public:
[ExtensionAttribute]
static void ErrorFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the ErrorExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
ErrorFormatExt Overload
log4net.Util Namespace
ILog Error(Object)
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.ErrorFormatExt Method (ILog, String, Object, Object, Object)

ILogExtensions ErrorFormatExt Method (ILog, String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Error level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ErrorFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
public static void ErrorFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
<ExtensionAttribute>
Public Shared Sub ErrorFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
<ExtensionAttribute>
Public Shared Sub ErrorFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
public:
[ExtensionAttribute]
static void ErrorFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
public:
[ExtensionAttribute]
static void ErrorFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the ErrorExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
ErrorFormatExt Overload
log4net.Util Namespace
ILog Error(Object)
ILog IsErrorEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.FatalExt Method

ILogExtensions FatalExt Method Apache log4net™ SDK Documentation
Log a message object with the Fatal level.
Overload List
Name | Description
FatalExt(ILog, Func TResult ) |
FatalExt(ILog, Object) | Log a message object with the Fatal level.
FatalExt(ILog, Func TResult , Void) |
FatalExt(ILog, Object, Exception) | Log a message object with the Fatal level including the stack trace of the Online Exception passed as a parameter.
Back to Top
See Also
ILogExtensions Class
ILogExtensions Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.FatalExt Method (ILog, Func)

ILogExtensions FatalExt Method (ILog, Func) Apache log4net™ SDK Documentation

[Missing <summary> documentation for "M:log4net.Util.ILogExtensions.FatalExt(log4net.ILog,System.Func`1)"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void FatalExt(
    this ILog logger,
    Func callback
)
public static void FatalExt(
    this ILog logger,
    Func callback
)
<ExtensionAttribute>
Public Shared Sub FatalExt (
    logger As ILog,
    callback As Func
)
<ExtensionAttribute>
Public Shared Sub FatalExt (
    logger As ILog,
    callback As Func
)
public:
[ExtensionAttribute]
static void FatalExt(
    ILog^ logger,
    Func^ callback
)
public:
[ExtensionAttribute]
static void FatalExt(
    ILog^ logger,
    Func^ callback
)
Parameters
logger
Type: log4net ILog
[Missing <param name="logger"/> documentation for "M:log4net.Util.ILogExtensions.FatalExt(log4net.ILog,System.Func`1)"]
callback
Type:   Online System Func TResult
[Missing <param name="callback"/> documentation for "M:log4net.Util.ILogExtensions.FatalExt(log4net.ILog,System.Func`1)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
ILogExtensions Class
ILogExtensions Members
FatalExt Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.FatalExt Method (ILog, Object)

ILogExtensions FatalExt Method (ILog, Object) Apache log4net™ SDK Documentation
Log a message object with the Fatal level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void FatalExt(
    this ILog logger,
    Object message
)
public static void FatalExt(
    this ILog logger,
    Object message
)
<ExtensionAttribute>
Public Shared Sub FatalExt (
    logger As ILog,
    message As Object
)
<ExtensionAttribute>
Public Shared Sub FatalExt (
    logger As ILog,
    message As Object
)
public:
[ExtensionAttribute]
static void FatalExt(
    ILog^ logger,
    Object^ message
)
public:
[ExtensionAttribute]
static void FatalExt(
    ILog^ logger,
    Object^ message
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
message
Type:   Online System Object
The message object to log.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            This method first checks if this logger is FATAL
            enabled by reading the value  property.
            This check happens always and does not depend on the
            implementation. If this logger is FATAL enabled, then it converts
            the message object (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger
            and also higher in the hierarchy depending on the value of
            the additivity flag.

WARNING Note that passing an   Online Exception
            to this method will print the name of the   Online Exception
            but no stack trace. To print a stack trace use the
            FatalExt(ILog, Object, Exception) form instead.

See Also
ILogExtensions Class
ILogExtensions Members
FatalExt Overload
log4net.Util Namespace
ILog IsFatalEnabled
log4net ILog
ILog Fatal(Object)
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.FatalExt Method (ILog, Func, Void)

ILogExtensions FatalExt Method (ILog, Func, Void) Apache log4net™ SDK Documentation

[Missing <summary> documentation for "M:log4net.Util.ILogExtensions.FatalExt(log4net.ILog,System.Func`1,System.Void)"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void FatalExt(
    this ILog logger,
    Func callback,
    void exception
)
public static void FatalExt(
    this ILog logger,
    Func callback,
    void exception
)
<ExtensionAttribute>
Public Shared Sub FatalExt (
    logger As ILog,
    callback As Func,
    exception As Void
)
<ExtensionAttribute>
Public Shared Sub FatalExt (
    logger As ILog,
    callback As Func,
    exception As Void
)
public:
[ExtensionAttribute]
static void FatalExt(
    ILog^ logger,
    Func^ callback,
    void exception
)
public:
[ExtensionAttribute]
static void FatalExt(
    ILog^ logger,
    Func^ callback,
    void exception
)
Parameters
logger
Type: log4net ILog
[Missing <param name="logger"/> documentation for "M:log4net.Util.ILogExtensions.FatalExt(log4net.ILog,System.Func`1,System.Void)"]
callback
Type:   Online System Func TResult
[Missing <param name="callback"/> documentation for "M:log4net.Util.ILogExtensions.FatalExt(log4net.ILog,System.Func`1,System.Void)"]
exception
Type:   Online System Void
[Missing <param name="exception"/> documentation for "M:log4net.Util.ILogExtensions.FatalExt(log4net.ILog,System.Func`1,System.Void)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
ILogExtensions Class
ILogExtensions Members
FatalExt Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.FatalExt Method (ILog, Object, Exception)

ILogExtensions FatalExt Method (ILog, Object, Exception) Apache log4net™ SDK Documentation
Log a message object with the Fatal level including the stack trace of the Online Exception passed as a parameter.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void FatalExt(
    this ILog logger,
    Object message,
    Exception exception
)
public static void FatalExt(
    this ILog logger,
    Object message,
    Exception exception
)
<ExtensionAttribute>
Public Shared Sub FatalExt (
    logger As ILog,
    message As Object,
    exception As Exception
)
<ExtensionAttribute>
Public Shared Sub FatalExt (
    logger As ILog,
    message As Object,
    exception As Exception
)
public:
[ExtensionAttribute]
static void FatalExt(
    ILog^ logger,
    Object^ message,
    Exception^ exception
)
public:
[ExtensionAttribute]
static void FatalExt(
    ILog^ logger,
    Object^ message,
    Exception^ exception
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            See the FatalExt(ILog, Object) form for more detailed information.

See Also
ILogExtensions Class
ILogExtensions Members
FatalExt Overload
log4net.Util Namespace
ILog Fatal(Object)
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.FatalFormatExt Method

ILogExtensions FatalFormatExt Method Apache log4net™ SDK Documentation
Overload List
Name | Description
FatalFormatExt(ILog, String, Object) | Logs a formatted message string with the Fatal level.
FatalFormatExt(ILog, String, Object ) | Logs a formatted message string with the Fatal level.
FatalFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Fatal level.
FatalFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Fatal level.
FatalFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Fatal level.
Back to Top
See Also
ILogExtensions Class
ILogExtensions Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.FatalFormatExt Method (ILog, String, Object)

ILogExtensions FatalFormatExt Method (ILog, String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Fatal level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void FatalFormatExt(
    this ILog logger,
    string format,
    Object arg0
)
public static void FatalFormatExt(
    this ILog logger,
    string format,
    Object arg0
)
<ExtensionAttribute>
Public Shared Sub FatalFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object
)
<ExtensionAttribute>
Public Shared Sub FatalFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object
)
public:
[ExtensionAttribute]
static void FatalFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0
)
public:
[ExtensionAttribute]
static void FatalFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the FatalExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
FatalFormatExt Overload
log4net.Util Namespace
ILog Fatal(Object)
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.FatalFormatExt Method (ILog, String, Object[])

ILogExtensions FatalFormatExt Method (ILog, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Fatal level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void FatalFormatExt(
    this ILog logger,
    string format,
    params Object[] args
)
public static void FatalFormatExt(
    this ILog logger,
    string format,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Sub FatalFormatExt (
    logger As ILog,
    format As String,
    ParamArray args As Object()
)
<ExtensionAttribute>
Public Shared Sub FatalFormatExt (
    logger As ILog,
    format As String,
    ParamArray args As Object()
)
public:
[ExtensionAttribute]
static void FatalFormatExt(
    ILog^ logger,
    String^ format,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static void FatalFormatExt(
    ILog^ logger,
    String^ format,
    ... array<Object^>^ args
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the FatalExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
FatalFormatExt Overload
log4net.Util Namespace
ILog Fatal(Object)
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.FatalFormatExt Method (ILog, IFormatProvider, String, Object[])

ILogExtensions FatalFormatExt Method (ILog, IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Fatal level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void FatalFormatExt(
    this ILog logger,
    IFormatProvider provider,
    string format,
    params Object[] args
)
public static void FatalFormatExt(
    this ILog logger,
    IFormatProvider provider,
    string format,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Sub FatalFormatExt (
    logger As ILog,
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
<ExtensionAttribute>
Public Shared Sub FatalFormatExt (
    logger As ILog,
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
public:
[ExtensionAttribute]
static void FatalFormatExt(
    ILog^ logger,
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static void FatalFormatExt(
    ILog^ logger,
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the FatalExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
FatalFormatExt Overload
log4net.Util Namespace
ILog Fatal(Object)
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.FatalFormatExt Method (ILog, String, Object, Object)

ILogExtensions FatalFormatExt Method (ILog, String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Fatal level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void FatalFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1
)
public static void FatalFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1
)
<ExtensionAttribute>
Public Shared Sub FatalFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object
)
<ExtensionAttribute>
Public Shared Sub FatalFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object
)
public:
[ExtensionAttribute]
static void FatalFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1
)
public:
[ExtensionAttribute]
static void FatalFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the FatalExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
FatalFormatExt Overload
log4net.Util Namespace
ILog Fatal(Object)
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.FatalFormatExt Method (ILog, String, Object, Object, Object)

ILogExtensions FatalFormatExt Method (ILog, String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Fatal level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void FatalFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
public static void FatalFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
<ExtensionAttribute>
Public Shared Sub FatalFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
<ExtensionAttribute>
Public Shared Sub FatalFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
public:
[ExtensionAttribute]
static void FatalFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
public:
[ExtensionAttribute]
static void FatalFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the FatalExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
FatalFormatExt Overload
log4net.Util Namespace
ILog Fatal(Object)
ILog IsFatalEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.InfoExt Method

ILogExtensions InfoExt Method Apache log4net™ SDK Documentation
Log a message object with the Info level.
Overload List
Name | Description
InfoExt(ILog, Func TResult ) |
InfoExt(ILog, Object) | Log a message object with the Info level.
InfoExt(ILog, Func TResult , Void) |
InfoExt(ILog, Object, Exception) | Log a message object with the Info level including the stack trace of the Online Exception passed as a parameter.
Back to Top
See Also
ILogExtensions Class
ILogExtensions Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.InfoExt Method (ILog, Func)

ILogExtensions InfoExt Method (ILog, Func) Apache log4net™ SDK Documentation

[Missing <summary> documentation for "M:log4net.Util.ILogExtensions.InfoExt(log4net.ILog,System.Func`1)"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void InfoExt(
    this ILog logger,
    Func callback
)
public static void InfoExt(
    this ILog logger,
    Func callback
)
<ExtensionAttribute>
Public Shared Sub InfoExt (
    logger As ILog,
    callback As Func
)
<ExtensionAttribute>
Public Shared Sub InfoExt (
    logger As ILog,
    callback As Func
)
public:
[ExtensionAttribute]
static void InfoExt(
    ILog^ logger,
    Func^ callback
)
public:
[ExtensionAttribute]
static void InfoExt(
    ILog^ logger,
    Func^ callback
)
Parameters
logger
Type: log4net ILog
[Missing <param name="logger"/> documentation for "M:log4net.Util.ILogExtensions.InfoExt(log4net.ILog,System.Func`1)"]
callback
Type:   Online System Func TResult
[Missing <param name="callback"/> documentation for "M:log4net.Util.ILogExtensions.InfoExt(log4net.ILog,System.Func`1)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
ILogExtensions Class
ILogExtensions Members
InfoExt Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.InfoExt Method (ILog, Object)

ILogExtensions InfoExt Method (ILog, Object) Apache log4net™ SDK Documentation
Log a message object with the Info level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void InfoExt(
    this ILog logger,
    Object message
)
public static void InfoExt(
    this ILog logger,
    Object message
)
<ExtensionAttribute>
Public Shared Sub InfoExt (
    logger As ILog,
    message As Object
)
<ExtensionAttribute>
Public Shared Sub InfoExt (
    logger As ILog,
    message As Object
)
public:
[ExtensionAttribute]
static void InfoExt(
    ILog^ logger,
    Object^ message
)
public:
[ExtensionAttribute]
static void InfoExt(
    ILog^ logger,
    Object^ message
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
message
Type:   Online System Object
The message object to log.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            This method first checks if this logger is INFO
            enabled by reading the value  property.
            This check happens always and does not depend on the
            implementation. If this logger is INFO enabled, then it converts
            the message object (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger
            and also higher in the hierarchy depending on the value of
            the additivity flag.

WARNING Note that passing an   Online Exception
            to this method will print the name of the   Online Exception
            but no stack trace. To print a stack trace use the
            InfoExt(ILog, Object, Exception) form instead.

See Also
ILogExtensions Class
ILogExtensions Members
InfoExt Overload
log4net.Util Namespace
ILog IsInfoEnabled
log4net ILog
ILog Info(Object)
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.InfoExt Method (ILog, Func, Void)

ILogExtensions InfoExt Method (ILog, Func, Void) Apache log4net™ SDK Documentation

[Missing <summary> documentation for "M:log4net.Util.ILogExtensions.InfoExt(log4net.ILog,System.Func`1,System.Void)"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void InfoExt(
    this ILog logger,
    Func callback,
    void exception
)
public static void InfoExt(
    this ILog logger,
    Func callback,
    void exception
)
<ExtensionAttribute>
Public Shared Sub InfoExt (
    logger As ILog,
    callback As Func,
    exception As Void
)
<ExtensionAttribute>
Public Shared Sub InfoExt (
    logger As ILog,
    callback As Func,
    exception As Void
)
public:
[ExtensionAttribute]
static void InfoExt(
    ILog^ logger,
    Func^ callback,
    void exception
)
public:
[ExtensionAttribute]
static void InfoExt(
    ILog^ logger,
    Func^ callback,
    void exception
)
Parameters
logger
Type: log4net ILog
[Missing <param name="logger"/> documentation for "M:log4net.Util.ILogExtensions.InfoExt(log4net.ILog,System.Func`1,System.Void)"]
callback
Type:   Online System Func TResult
[Missing <param name="callback"/> documentation for "M:log4net.Util.ILogExtensions.InfoExt(log4net.ILog,System.Func`1,System.Void)"]
exception
Type:   Online System Void
[Missing <param name="exception"/> documentation for "M:log4net.Util.ILogExtensions.InfoExt(log4net.ILog,System.Func`1,System.Void)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
ILogExtensions Class
ILogExtensions Members
InfoExt Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.InfoExt Method (ILog, Object, Exception)

ILogExtensions InfoExt Method (ILog, Object, Exception) Apache log4net™ SDK Documentation
Log a message object with the Info level including the stack trace of the Online Exception passed as a parameter.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void InfoExt(
    this ILog logger,
    Object message,
    Exception exception
)
public static void InfoExt(
    this ILog logger,
    Object message,
    Exception exception
)
<ExtensionAttribute>
Public Shared Sub InfoExt (
    logger As ILog,
    message As Object,
    exception As Exception
)
<ExtensionAttribute>
Public Shared Sub InfoExt (
    logger As ILog,
    message As Object,
    exception As Exception
)
public:
[ExtensionAttribute]
static void InfoExt(
    ILog^ logger,
    Object^ message,
    Exception^ exception
)
public:
[ExtensionAttribute]
static void InfoExt(
    ILog^ logger,
    Object^ message,
    Exception^ exception
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            See the InfoExt(ILog, Object) form for more detailed information.

See Also
ILogExtensions Class
ILogExtensions Members
InfoExt Overload
log4net.Util Namespace
ILog Info(Object)
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.InfoFormatExt Method

ILogExtensions InfoFormatExt Method Apache log4net™ SDK Documentation
Overload List
Name | Description
InfoFormatExt(ILog, String, Object) | Logs a formatted message string with the Info level.
InfoFormatExt(ILog, String, Object ) | Logs a formatted message string with the Info level.
InfoFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Info level.
InfoFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Info level.
InfoFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Info level.
Back to Top
See Also
ILogExtensions Class
ILogExtensions Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.InfoFormatExt Method (ILog, String, Object)

ILogExtensions InfoFormatExt Method (ILog, String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Info level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void InfoFormatExt(
    this ILog logger,
    string format,
    Object arg0
)
public static void InfoFormatExt(
    this ILog logger,
    string format,
    Object arg0
)
<ExtensionAttribute>
Public Shared Sub InfoFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object
)
<ExtensionAttribute>
Public Shared Sub InfoFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object
)
public:
[ExtensionAttribute]
static void InfoFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0
)
public:
[ExtensionAttribute]
static void InfoFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the InfoExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
InfoFormatExt Overload
log4net.Util Namespace
ILog Info(Object)
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.InfoFormatExt Method (ILog, String, Object[])

ILogExtensions InfoFormatExt Method (ILog, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Info level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void InfoFormatExt(
    this ILog logger,
    string format,
    params Object[] args
)
public static void InfoFormatExt(
    this ILog logger,
    string format,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Sub InfoFormatExt (
    logger As ILog,
    format As String,
    ParamArray args As Object()
)
<ExtensionAttribute>
Public Shared Sub InfoFormatExt (
    logger As ILog,
    format As String,
    ParamArray args As Object()
)
public:
[ExtensionAttribute]
static void InfoFormatExt(
    ILog^ logger,
    String^ format,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static void InfoFormatExt(
    ILog^ logger,
    String^ format,
    ... array<Object^>^ args
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the InfoExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
InfoFormatExt Overload
log4net.Util Namespace
ILog Info(Object)
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.InfoFormatExt Method (ILog, IFormatProvider, String, Object[])

ILogExtensions InfoFormatExt Method (ILog, IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Info level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void InfoFormatExt(
    this ILog logger,
    IFormatProvider provider,
    string format,
    params Object[] args
)
public static void InfoFormatExt(
    this ILog logger,
    IFormatProvider provider,
    string format,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Sub InfoFormatExt (
    logger As ILog,
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
<ExtensionAttribute>
Public Shared Sub InfoFormatExt (
    logger As ILog,
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
public:
[ExtensionAttribute]
static void InfoFormatExt(
    ILog^ logger,
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static void InfoFormatExt(
    ILog^ logger,
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the InfoExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
InfoFormatExt Overload
log4net.Util Namespace
ILog Info(Object)
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.InfoFormatExt Method (ILog, String, Object, Object)

ILogExtensions InfoFormatExt Method (ILog, String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Info level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void InfoFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1
)
public static void InfoFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1
)
<ExtensionAttribute>
Public Shared Sub InfoFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object
)
<ExtensionAttribute>
Public Shared Sub InfoFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object
)
public:
[ExtensionAttribute]
static void InfoFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1
)
public:
[ExtensionAttribute]
static void InfoFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the InfoExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
InfoFormatExt Overload
log4net.Util Namespace
ILog Info(Object)
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.InfoFormatExt Method (ILog, String, Object, Object, Object)

ILogExtensions InfoFormatExt Method (ILog, String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Info level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void InfoFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
public static void InfoFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
<ExtensionAttribute>
Public Shared Sub InfoFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
<ExtensionAttribute>
Public Shared Sub InfoFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
public:
[ExtensionAttribute]
static void InfoFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
public:
[ExtensionAttribute]
static void InfoFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the InfoExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
InfoFormatExt Overload
log4net.Util Namespace
ILog Info(Object)
ILog IsInfoEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.WarnExt Method

ILogExtensions WarnExt Method Apache log4net™ SDK Documentation
Log a message object with the Warn level.
Overload List
Name | Description
WarnExt(ILog, Func TResult ) |
WarnExt(ILog, Object) | Log a message object with the Warn level.
WarnExt(ILog, Func TResult , Void) |
WarnExt(ILog, Object, Exception) | Log a message object with the Warn level including the stack trace of the Online Exception passed as a parameter.
Back to Top
See Also
ILogExtensions Class
ILogExtensions Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.WarnExt Method (ILog, Func)

ILogExtensions WarnExt Method (ILog, Func) Apache log4net™ SDK Documentation

[Missing <summary> documentation for "M:log4net.Util.ILogExtensions.WarnExt(log4net.ILog,System.Func`1)"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WarnExt(
    this ILog logger,
    Func callback
)
public static void WarnExt(
    this ILog logger,
    Func callback
)
<ExtensionAttribute>
Public Shared Sub WarnExt (
    logger As ILog,
    callback As Func
)
<ExtensionAttribute>
Public Shared Sub WarnExt (
    logger As ILog,
    callback As Func
)
public:
[ExtensionAttribute]
static void WarnExt(
    ILog^ logger,
    Func^ callback
)
public:
[ExtensionAttribute]
static void WarnExt(
    ILog^ logger,
    Func^ callback
)
Parameters
logger
Type: log4net ILog
[Missing <param name="logger"/> documentation for "M:log4net.Util.ILogExtensions.WarnExt(log4net.ILog,System.Func`1)"]
callback
Type:   Online System Func TResult
[Missing <param name="callback"/> documentation for "M:log4net.Util.ILogExtensions.WarnExt(log4net.ILog,System.Func`1)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
ILogExtensions Class
ILogExtensions Members
WarnExt Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.WarnExt Method (ILog, Object)

ILogExtensions WarnExt Method (ILog, Object) Apache log4net™ SDK Documentation
Log a message object with the Warn level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WarnExt(
    this ILog logger,
    Object message
)
public static void WarnExt(
    this ILog logger,
    Object message
)
<ExtensionAttribute>
Public Shared Sub WarnExt (
    logger As ILog,
    message As Object
)
<ExtensionAttribute>
Public Shared Sub WarnExt (
    logger As ILog,
    message As Object
)
public:
[ExtensionAttribute]
static void WarnExt(
    ILog^ logger,
    Object^ message
)
public:
[ExtensionAttribute]
static void WarnExt(
    ILog^ logger,
    Object^ message
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
message
Type:   Online System Object
The message object to log.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            This method first checks if this logger is WARN
            enabled by reading the value  property.
            This check happens always and does not depend on the
            implementation. If this logger is WARN enabled, then it converts
            the message object (passed as parameter) to a string by invoking the appropriate
            IObjectRenderer. It then
            proceeds to call all the registered appenders in this logger
            and also higher in the hierarchy depending on the value of
            the additivity flag.

WARNING Note that passing an   Online Exception
            to this method will print the name of the   Online Exception
            but no stack trace. To print a stack trace use the
            WarnExt(ILog, Object, Exception) form instead.

See Also
ILogExtensions Class
ILogExtensions Members
WarnExt Overload
log4net.Util Namespace
ILog IsWarnEnabled
log4net ILog
ILog Warn(Object)
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.WarnExt Method (ILog, Func, Void)

ILogExtensions WarnExt Method (ILog, Func, Void) Apache log4net™ SDK Documentation

[Missing <summary> documentation for "M:log4net.Util.ILogExtensions.WarnExt(log4net.ILog,System.Func`1,System.Void)"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WarnExt(
    this ILog logger,
    Func callback,
    void exception
)
public static void WarnExt(
    this ILog logger,
    Func callback,
    void exception
)
<ExtensionAttribute>
Public Shared Sub WarnExt (
    logger As ILog,
    callback As Func,
    exception As Void
)
<ExtensionAttribute>
Public Shared Sub WarnExt (
    logger As ILog,
    callback As Func,
    exception As Void
)
public:
[ExtensionAttribute]
static void WarnExt(
    ILog^ logger,
    Func^ callback,
    void exception
)
public:
[ExtensionAttribute]
static void WarnExt(
    ILog^ logger,
    Func^ callback,
    void exception
)
Parameters
logger
Type: log4net ILog
[Missing <param name="logger"/> documentation for "M:log4net.Util.ILogExtensions.WarnExt(log4net.ILog,System.Func`1,System.Void)"]
callback
Type:   Online System Func TResult
[Missing <param name="callback"/> documentation for "M:log4net.Util.ILogExtensions.WarnExt(log4net.ILog,System.Func`1,System.Void)"]
exception
Type:   Online System Void
[Missing <param name="exception"/> documentation for "M:log4net.Util.ILogExtensions.WarnExt(log4net.ILog,System.Func`1,System.Void)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
ILogExtensions Class
ILogExtensions Members
WarnExt Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.WarnExt Method (ILog, Object, Exception)

ILogExtensions WarnExt Method (ILog, Object, Exception) Apache log4net™ SDK Documentation
Log a message object with the Warn level including the stack trace of the Online Exception passed as a parameter.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WarnExt(
    this ILog logger,
    Object message,
    Exception exception
)
public static void WarnExt(
    this ILog logger,
    Object message,
    Exception exception
)
<ExtensionAttribute>
Public Shared Sub WarnExt (
    logger As ILog,
    message As Object,
    exception As Exception
)
<ExtensionAttribute>
Public Shared Sub WarnExt (
    logger As ILog,
    message As Object,
    exception As Exception
)
public:
[ExtensionAttribute]
static void WarnExt(
    ILog^ logger,
    Object^ message,
    Exception^ exception
)
public:
[ExtensionAttribute]
static void WarnExt(
    ILog^ logger,
    Object^ message,
    Exception^ exception
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
message
Type:   Online System Object
The message object to log.
exception
Type:   Online System Exception
The exception to log, including its stack trace.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            See the WarnExt(ILog, Object) form for more detailed information.

See Also
ILogExtensions Class
ILogExtensions Members
WarnExt Overload
log4net.Util Namespace
ILog Warn(Object)
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.WarnFormatExt Method

ILogExtensions WarnFormatExt Method Apache log4net™ SDK Documentation
Overload List
Name | Description
WarnFormatExt(ILog, String, Object) | Logs a formatted message string with the Warn level.
WarnFormatExt(ILog, String, Object ) | Logs a formatted message string with the Warn level.
WarnFormatExt(ILog, IFormatProvider, String, Object ) | Logs a formatted message string with the Warn level.
WarnFormatExt(ILog, String, Object, Object) | Logs a formatted message string with the Warn level.
WarnFormatExt(ILog, String, Object, Object, Object) | Logs a formatted message string with the Warn level.
Back to Top
See Also
ILogExtensions Class
ILogExtensions Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.WarnFormatExt Method (ILog, String, Object)

ILogExtensions WarnFormatExt Method (ILog, String, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Warn level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WarnFormatExt(
    this ILog logger,
    string format,
    Object arg0
)
public static void WarnFormatExt(
    this ILog logger,
    string format,
    Object arg0
)
<ExtensionAttribute>
Public Shared Sub WarnFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object
)
<ExtensionAttribute>
Public Shared Sub WarnFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object
)
public:
[ExtensionAttribute]
static void WarnFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0
)
public:
[ExtensionAttribute]
static void WarnFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the WarnExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
WarnFormatExt Overload
log4net.Util Namespace
ILog Warn(Object)
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.WarnFormatExt Method (ILog, String, Object[])

ILogExtensions WarnFormatExt Method (ILog, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Warn level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WarnFormatExt(
    this ILog logger,
    string format,
    params Object[] args
)
public static void WarnFormatExt(
    this ILog logger,
    string format,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Sub WarnFormatExt (
    logger As ILog,
    format As String,
    ParamArray args As Object()
)
<ExtensionAttribute>
Public Shared Sub WarnFormatExt (
    logger As ILog,
    format As String,
    ParamArray args As Object()
)
public:
[ExtensionAttribute]
static void WarnFormatExt(
    ILog^ logger,
    String^ format,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static void WarnFormatExt(
    ILog^ logger,
    String^ format,
    ... array<Object^>^ args
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the WarnExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
WarnFormatExt Overload
log4net.Util Namespace
ILog Warn(Object)
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.WarnFormatExt Method (ILog, IFormatProvider, String, Object[])

ILogExtensions WarnFormatExt Method (ILog, IFormatProvider, String, Object ) Apache log4net™ SDK Documentation
Logs a formatted message string with the Warn level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WarnFormatExt(
    this ILog logger,
    IFormatProvider provider,
    string format,
    params Object[] args
)
public static void WarnFormatExt(
    this ILog logger,
    IFormatProvider provider,
    string format,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Sub WarnFormatExt (
    logger As ILog,
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
<ExtensionAttribute>
Public Shared Sub WarnFormatExt (
    logger As ILog,
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
public:
[ExtensionAttribute]
static void WarnFormatExt(
    ILog^ logger,
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static void WarnFormatExt(
    ILog^ logger,
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information
format
Type:   Online System String
A String containing zero or more format items
args
Type:    Online System Object
An Object array containing zero or more objects to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the WarnExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
WarnFormatExt Overload
log4net.Util Namespace
ILog Warn(Object)
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.WarnFormatExt Method (ILog, String, Object, Object)

ILogExtensions WarnFormatExt Method (ILog, String, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Warn level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WarnFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1
)
public static void WarnFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1
)
<ExtensionAttribute>
Public Shared Sub WarnFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object
)
<ExtensionAttribute>
Public Shared Sub WarnFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object
)
public:
[ExtensionAttribute]
static void WarnFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1
)
public:
[ExtensionAttribute]
static void WarnFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the WarnExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
WarnFormatExt Overload
log4net.Util Namespace
ILog Warn(Object)
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ILogExtensions.WarnFormatExt Method (ILog, String, Object, Object, Object)

ILogExtensions WarnFormatExt Method (ILog, String, Object, Object, Object) Apache log4net™ SDK Documentation
Logs a formatted message string with the Warn level.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WarnFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
public static void WarnFormatExt(
    this ILog logger,
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
<ExtensionAttribute>
Public Shared Sub WarnFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
<ExtensionAttribute>
Public Shared Sub WarnFormatExt (
    logger As ILog,
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)
public:
[ExtensionAttribute]
static void WarnFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
public:
[ExtensionAttribute]
static void WarnFormatExt(
    ILog^ logger,
    String^ format,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
Parameters
logger
Type: log4net ILog
The logger on which the message is logged.
format
Type:   Online System String
A String containing zero or more format items
arg0
Type:   Online System Object
An Object to format
arg1
Type:   Online System Object
An Object to format
arg2
Type:   Online System Object
An Object to format
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Remarks

            The message is formatted using the String.Format method. See
              Online Format(String,  Object ) for details of the syntax of the format string and the behavior
            of the formatting.

            This method does not take an   Online Exception object to include in the
            log event. To pass an   Online Exception use one of the WarnExt(ILog, Object, Exception)
            methods instead.

See Also
ILogExtensions Class
ILogExtensions Members
WarnFormatExt Overload
log4net.Util Namespace
ILog Warn(Object)
ILog IsWarnEnabled
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMapping Class

LevelMapping Class Apache log4net™ SDK Documentation
Manages a mapping from levels to LevelMappingEntry
Inheritance Hierarchy
Online System Object
log4net.Util LevelMapping

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LevelMapping : IOptionHandler
public sealed class LevelMapping : IOptionHandler
Public NotInheritable Class LevelMapping
    Implements IOptionHandler
Public NotInheritable Class LevelMapping
    Implements IOptionHandler
public ref class LevelMapping sealed : IOptionHandler
public ref class LevelMapping sealed : IOptionHandler
Remarks

            Manages an ordered mapping from Level instances
            to LevelMappingEntry subclasses.

See Also
LevelMapping Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMapping Members

LevelMapping Members Apache log4net™ SDK Documentation
The LevelMapping type exposes the following members.
Constructors
 | Name | Description
Public method | LevelMapping | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize options
Public method | Add | Add a LevelMappingEntry to this mapping
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Lookup | Lookup the mapping for the specified level
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LevelMapping Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMapping Constructor

LevelMapping Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelMapping()
public LevelMapping()
Public Sub New
Public Sub New
public:
LevelMapping()
public:
LevelMapping()
Remarks

            Initialise a new instance of LevelMapping.

See Also
LevelMapping Class
LevelMapping Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMapping Methods

LevelMapping Methods Apache log4net™ SDK Documentation
The LevelMapping type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize options
Public method | Add | Add a LevelMappingEntry to this mapping
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Lookup | Lookup the mapping for the specified level
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LevelMapping Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMapping.ActivateOptions Method

LevelMapping ActivateOptions Method Apache log4net™ SDK Documentation
Initialize options

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ActivateOptions()
public void ActivateOptions()
Public Sub ActivateOptions
Public Sub ActivateOptions
public:
virtual void ActivateOptions() sealed
public:
virtual void ActivateOptions() sealed
Implements
IOptionHandler ActivateOptions
Remarks

            Caches the sorted list of LevelMappingEntry in an array

See Also
LevelMapping Class
LevelMapping Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMapping.Add Method

LevelMapping Add Method Apache log4net™ SDK Documentation
Add a LevelMappingEntry to this mapping

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    LevelMappingEntry entry
)
public void Add(
    LevelMappingEntry entry
)
Public Sub Add (
    entry As LevelMappingEntry
)
Public Sub Add (
    entry As LevelMappingEntry
)
public:
void Add(
    LevelMappingEntry^ entry
)
public:
void Add(
    LevelMappingEntry^ entry
)
Parameters
entry
Type: log4net.Util LevelMappingEntry
the entry to add
Remarks

            If a LevelMappingEntry has previously been added
            for the same Level then that entry will be
            overwritten.

See Also
LevelMapping Class
LevelMapping Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMapping.Lookup Method

LevelMapping Lookup Method Apache log4net™ SDK Documentation
Lookup the mapping for the specified level

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelMappingEntry Lookup(
    Level level
)
public LevelMappingEntry Lookup(
    Level level
)
Public Function Lookup (
    level As Level
) As LevelMappingEntry
Public Function Lookup (
    level As Level
) As LevelMappingEntry
public:
LevelMappingEntry^ Lookup(
    Level^ level
)
public:
LevelMappingEntry^ Lookup(
    Level^ level
)
Parameters
level
Type: log4net.Core Level
the level to lookup
Return Value
Type: LevelMappingEntry
the LevelMappingEntry for the level or null if no mapping found
Remarks

            Lookup the value for the specified level. Finds the nearest
            mapping value for the level that is equal to or less than the
            level specified.

            If no mapping could be found then null is returned.

See Also
LevelMapping Class
LevelMapping Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMappingEntry Class

LevelMappingEntry Class Apache log4net™ SDK Documentation
An entry in the LevelMapping
Inheritance Hierarchy
Online System Object
log4net.Util LevelMappingEntry
log4net.Appender AnsiColorTerminalAppender LevelColors
log4net.Appender ColoredConsoleAppender LevelColors
log4net.Appender EventLogAppender Level2EventLogEntryType
log4net.Appender LocalSyslogAppender LevelSeverity
log4net.Appender ManagedColoredConsoleAppender LevelColors
log4net.Appender RemoteSyslogAppender LevelSeverity

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class LevelMappingEntry : IOptionHandler
public abstract class LevelMappingEntry : IOptionHandler
Public MustInherit Class LevelMappingEntry
    Implements IOptionHandler
Public MustInherit Class LevelMappingEntry
    Implements IOptionHandler
public ref class LevelMappingEntry abstract : IOptionHandler
public ref class LevelMappingEntry abstract : IOptionHandler
Remarks

            This is an abstract base class for types that are stored in the
            LevelMapping object.

See Also
LevelMappingEntry Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMappingEntry Members

LevelMappingEntry Members Apache log4net™ SDK Documentation
The LevelMappingEntry type exposes the following members.
Constructors
 | Name | Description
Protected method | LevelMappingEntry | Default protected constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize any options defined on this entry
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Level | The level that is the key for this mapping
Back to Top
See Also
LevelMappingEntry Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMappingEntry Constructor

LevelMappingEntry Constructor Apache log4net™ SDK Documentation
Default protected constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LevelMappingEntry()
protected LevelMappingEntry()
Protected Sub New
Protected Sub New
protected:
LevelMappingEntry()
protected:
LevelMappingEntry()
Remarks

            Default protected constructor

See Also
LevelMappingEntry Class
LevelMappingEntry Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMappingEntry Methods

LevelMappingEntry Methods Apache log4net™ SDK Documentation
The LevelMappingEntry type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize any options defined on this entry
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LevelMappingEntry Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMappingEntry.ActivateOptions Method

LevelMappingEntry ActivateOptions Method Apache log4net™ SDK Documentation
Initialize any options defined on this entry

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ActivateOptions()
public virtual void ActivateOptions()
Public Overridable Sub ActivateOptions
Public Overridable Sub ActivateOptions
public:
virtual void ActivateOptions()
public:
virtual void ActivateOptions()
Implements
IOptionHandler ActivateOptions
Remarks

            Should be overridden by any classes that need to initialise based on their options

See Also
LevelMappingEntry Class
LevelMappingEntry Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMappingEntry Properties

LevelMappingEntry Properties Apache log4net™ SDK Documentation
The LevelMappingEntry type exposes the following members.
Properties
 | Name | Description
Public property | Level | The level that is the key for this mapping
Back to Top
See Also
LevelMappingEntry Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LevelMappingEntry.Level Property

LevelMappingEntry Level Property Apache log4net™ SDK Documentation
The level that is the key for this mapping

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Level Level { get; set; }
public Level Level { get; set; }
Public Property Level As Level
    Get
    Set
Public Property Level As Level
    Get
    Set
public:
property Level^ Level {
    Level^ get ();
    void set (Level^ value);
}
public:
property Level^ Level {
    Level^ get ();
    void set (Level^ value);
}
Property Value
Type: Level

            The Level that is the key for this mapping

Remarks

            Get or set the Level that is the key for this
            mapping subclass.

See Also
LevelMappingEntry Class
LevelMappingEntry Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextProperties Class

LogicalThreadContextProperties Class Apache log4net™ SDK Documentation
Implementation of Properties collection for the LogicalThreadContext
Inheritance Hierarchy
Online System Object
log4net.Util ContextPropertiesBase
log4net.Util LogicalThreadContextProperties

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LogicalThreadContextProperties : ContextPropertiesBase
public sealed class LogicalThreadContextProperties : ContextPropertiesBase
Public NotInheritable Class LogicalThreadContextProperties
    Inherits ContextPropertiesBase
Public NotInheritable Class LogicalThreadContextProperties
    Inherits ContextPropertiesBase
public ref class LogicalThreadContextProperties sealed : public ContextPropertiesBase
public ref class LogicalThreadContextProperties sealed : public ContextPropertiesBase
Remarks

            Class implements a collection of properties that is specific to each thread.
            The class is not synchronized as each thread has its own PropertiesDictionary.

            This class stores its properties in a slot on the   Online CallContext named
            log4net.Util.LogicalThreadContextProperties.

            The   Online CallContext requires a link time
              Online SecurityPermission for the
              Online Infrastructure.
            If the calling code does not have this permission then this context will be disabled.
            It will not store any property values set on it.

See Also
LogicalThreadContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextProperties Members

LogicalThreadContextProperties Members Apache log4net™ SDK Documentation
The LogicalThreadContextProperties type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Clear all the context properties
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Remove a property
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | Gets or sets the value of a property (Overrides ContextPropertiesBase Item String .)
Back to Top
See Also
LogicalThreadContextProperties Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextProperties Methods

LogicalThreadContextProperties Methods Apache log4net™ SDK Documentation
The LogicalThreadContextProperties type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Clear all the context properties
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Remove a property
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LogicalThreadContextProperties Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextProperties.Clear Method

LogicalThreadContextProperties Clear Method Apache log4net™ SDK Documentation
Clear all the context properties

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
Remarks

            Clear all the context properties

See Also
LogicalThreadContextProperties Class
LogicalThreadContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextProperties.Remove Method

LogicalThreadContextProperties Remove Method Apache log4net™ SDK Documentation
Remove a property

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Remove(
    string key
)
public void Remove(
    string key
)
Public Sub Remove (
    key As String
)
Public Sub Remove (
    key As String
)
public:
void Remove(
    String^ key
)
public:
void Remove(
    String^ key
)
Parameters
key
Type:   Online System String
the key for the entry to remove
Remarks

            Remove the value for the specified key from the context.

See Also
LogicalThreadContextProperties Class
LogicalThreadContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextProperties Properties

LogicalThreadContextProperties Properties Apache log4net™ SDK Documentation
The LogicalThreadContextProperties type exposes the following members.
Properties
 | Name | Description
Public property | Item | Gets or sets the value of a property (Overrides ContextPropertiesBase Item String .)
Back to Top
See Also
LogicalThreadContextProperties Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextProperties.Item Property

LogicalThreadContextProperties Item Property Apache log4net™ SDK Documentation
Gets or sets the value of a property

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object this[
    string key
] { get; set; }
public override Object this[
    string key
] { get; set; }
Public Overrides Default Property Item (
    key As String
) As Object
    Get
    Set
Public Overrides Default Property Item (
    key As String
) As Object
    Get
    Set
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key) override;
    void set (String^ key, Object^ value) override;
}
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key) override;
    void set (String^ key, Object^ value) override;
}
Parameters
key
Type:   Online System String
Property Value
Type:   Online Object

            The value for the property with the specified key

Remarks

            Get or set the property value for the key specified.

See Also
LogicalThreadContextProperties Class
LogicalThreadContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStack Class

LogicalThreadContextStack Class Apache log4net™ SDK Documentation
Implementation of Stack for the LogicalThreadContext
Inheritance Hierarchy
Online System Object
log4net.Util LogicalThreadContextStack

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LogicalThreadContextStack : IFixingRequired
public sealed class LogicalThreadContextStack : IFixingRequired
Public NotInheritable Class LogicalThreadContextStack
    Implements IFixingRequired
Public NotInheritable Class LogicalThreadContextStack
    Implements IFixingRequired
public ref class LogicalThreadContextStack sealed : IFixingRequired
public ref class LogicalThreadContextStack sealed : IFixingRequired
Remarks

            Implementation of Stack for the LogicalThreadContext
See Also
LogicalThreadContextStack Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStack Members

LogicalThreadContextStack Members Apache log4net™ SDK Documentation
The LogicalThreadContextStack type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Clears all the contextual information held in this stack.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Pop | Removes the top context from this stack.
Public method | Push | Pushes a new context message into this stack.
Public method | ToString | Gets the current context information for this stack. (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Count | The number of messages in the stack
Back to Top
See Also
LogicalThreadContextStack Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStack Methods

LogicalThreadContextStack Methods Apache log4net™ SDK Documentation
The LogicalThreadContextStack type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Clears all the contextual information held in this stack.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Pop | Removes the top context from this stack.
Public method | Push | Pushes a new context message into this stack.
Public method | ToString | Gets the current context information for this stack. (Overrides Online Object ToString .)
Back to Top
See Also
LogicalThreadContextStack Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStack.Clear Method

LogicalThreadContextStack Clear Method Apache log4net™ SDK Documentation
Clears all the contextual information held in this stack.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
Remarks

            Clears all the contextual information held in this stack.
            Only call this if you think that this thread is being reused after
            a previous call execution which may not have completed correctly.
            You do not need to use this method if you always guarantee to call
            the   Online Dispose  method of the   Online IDisposable
            returned from Push(String) even in exceptional circumstances,
            for example by using the using(log4net.LogicalThreadContext.Stacks["NDC"].Push("Stack_Message"))
            syntax.

See Also
LogicalThreadContextStack Class
LogicalThreadContextStack Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStack.Pop Method

LogicalThreadContextStack Pop Method Apache log4net™ SDK Documentation
Removes the top context from this stack.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Pop()
public string Pop()
Public Function Pop As String
Public Function Pop As String
public:
String^ Pop()
public:
String^ Pop()
Return Value
Type:   Online String
The message in the context that was removed from the top of this stack.
Remarks

            Remove the top context from this stack, and return
            it to the caller. If this stack is empty then an
            empty string (not  ) is returned.

See Also
LogicalThreadContextStack Class
LogicalThreadContextStack Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStack.Push Method

LogicalThreadContextStack Push Method Apache log4net™ SDK Documentation
Pushes a new context message into this stack.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDisposable Push(
    string message
)
public IDisposable Push(
    string message
)
Public Function Push (
    message As String
) As IDisposable
Public Function Push (
    message As String
) As IDisposable
public:
IDisposable^ Push(
    String^ message
)
public:
IDisposable^ Push(
    String^ message
)
Parameters
message
Type:   Online System String
The new context message.
Return Value
Type:   Online IDisposable

            An   Online IDisposable that can be used to clean up the context stack.

Remarks

            Pushes a new context onto this stack. An   Online IDisposable
            is returned that can be used to clean up this stack. This
            can be easily combined with the using keyword to scope the
            context.

Examples
Simple example of using the Push method with the using keyword.

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
using(log4net.LogicalThreadContext.Stacks["NDC"].Push("Stack_Message"))
{
    log.Warn("This should have an ThreadContext Stack message");
}
using(log4net.LogicalThreadContext.Stacks["NDC"].Push("Stack_Message"))
{
    log.Warn("This should have an ThreadContext Stack message");
}
See Also
LogicalThreadContextStack Class
LogicalThreadContextStack Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStack.ToString Method

LogicalThreadContextStack ToString Method Apache log4net™ SDK Documentation
Gets the current context information for this stack.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value
Type:   Online String
Gets the current context information
Remarks

            Gets the current context information for this stack.

See Also
LogicalThreadContextStack Class
LogicalThreadContextStack Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStack Properties

LogicalThreadContextStack Properties Apache log4net™ SDK Documentation
The LogicalThreadContextStack type exposes the following members.
Properties
 | Name | Description
Public property | Count | The number of messages in the stack
Back to Top
See Also
LogicalThreadContextStack Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStack.Count Property

LogicalThreadContextStack Count Property Apache log4net™ SDK Documentation
The number of messages in the stack

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
Property Value
Type:   Online Int32

            The current number of messages in the stack

Remarks

            The current number of messages in the stack. That is
            the number of times Push(String) has been called
            minus the number of times Pop  has been called.

See Also
LogicalThreadContextStack Class
LogicalThreadContextStack Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStacks Class

LogicalThreadContextStacks Class Apache log4net™ SDK Documentation
Implementation of Stacks collection for the LogicalThreadContext
Inheritance Hierarchy
Online System Object
log4net.Util LogicalThreadContextStacks

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LogicalThreadContextStacks
public sealed class LogicalThreadContextStacks
Public NotInheritable Class LogicalThreadContextStacks
Public NotInheritable Class LogicalThreadContextStacks
public ref class LogicalThreadContextStacks sealed
public ref class LogicalThreadContextStacks sealed
Remarks

            Implementation of Stacks collection for the LogicalThreadContext
See Also
LogicalThreadContextStacks Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStacks Members

LogicalThreadContextStacks Members Apache log4net™ SDK Documentation
The LogicalThreadContextStacks type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | Gets the named thread context stack
Back to Top
See Also
LogicalThreadContextStacks Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStacks Methods

LogicalThreadContextStacks Methods Apache log4net™ SDK Documentation
The LogicalThreadContextStacks type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LogicalThreadContextStacks Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStacks Properties

LogicalThreadContextStacks Properties Apache log4net™ SDK Documentation
The LogicalThreadContextStacks type exposes the following members.
Properties
 | Name | Description
Public property | Item | Gets the named thread context stack
Back to Top
See Also
LogicalThreadContextStacks Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogicalThreadContextStacks.Item Property

LogicalThreadContextStacks Item Property Apache log4net™ SDK Documentation
Gets the named thread context stack

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogicalThreadContextStack this[
    string key
] { get; }
public LogicalThreadContextStack this[
    string key
] { get; }
Public ReadOnly Default Property Item (
    key As String
) As LogicalThreadContextStack
    Get
Public ReadOnly Default Property Item (
    key As String
) As LogicalThreadContextStack
    Get
public:
property LogicalThreadContextStack^ default[String^ key] {
    LogicalThreadContextStack^ get (String^ key);
}
public:
property LogicalThreadContextStack^ default[String^ key] {
    LogicalThreadContextStack^ get (String^ key);
}
Parameters
key
Type:   Online System String
Property Value
Type: LogicalThreadContextStack

            The named stack

Remarks

            Gets the named thread context stack

See Also
LogicalThreadContextStacks Class
LogicalThreadContextStacks Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog Class

LogLog Class Apache log4net™ SDK Documentation
Outputs log statements from within the log4net assembly.
Inheritance Hierarchy
Online System Object
log4net.Util LogLog

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LogLog
public sealed class LogLog
Public NotInheritable Class LogLog
Public NotInheritable Class LogLog
public ref class LogLog sealed
public ref class LogLog sealed
Remarks

            Log4net components cannot make log4net logging calls. However, it is
            sometimes useful for the user to learn about what log4net is
            doing.

            All log4net internal debug calls go to the standard output stream
            whereas internal error messages are sent to the standard error output
            stream.

See Also
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog Members

LogLog Members Apache log4net™ SDK Documentation
The LogLog type exposes the following members.
Constructors
 | Name | Description
Public method | LogLog | Initializes a new instance of the LogLog class.
Back to Top
Methods
 | Name | Description
 | Debug(Type, String) | Writes log4net internal debug messages to the standard output stream.
 | Debug(Type, String, Exception) | Writes log4net internal debug messages to the standard output stream.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | Error(Type, String) | Writes log4net internal error messages to the standard error stream.
 | Error(Type, String, Exception) | Writes log4net internal error messages to the standard error stream.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | OnLogReceived | Raises the LogReceived event when an internal messages is received.
Public method | ToString | Formats Prefix, Source, and Message in the same format as the value sent to Console.Out and Trace.Write. (Overrides Online Object ToString .)
 | Warn(Type, String) | Writes log4net internal warning messages to the standard error stream.
 | Warn(Type, String, Exception) | Writes log4net internal warning messages to the standard error stream.
Back to Top
Properties
 | Name | Description
 | EmitInternalMessages |
Public property | Exception | The Exception related to the message.
 | InternalDebugging | Gets or sets a value indicating whether log4net internal logging is enabled or disabled.
 | IsDebugEnabled | Test if LogLog.Debug is enabled for output.
 | IsErrorEnabled | Test if LogLog.Error is enabled for output.
 | IsWarnEnabled | Test if LogLog.Warn is enabled for output.
Public property | Message | The internal log message.
Public property | Prefix | A string indicating the severity of the internal message.
 | QuietMode | Gets or sets a value indicating whether log4net should generate no output from internal logging, not even for errors.
Public property | Source | The Type that generated the internal message.
Public property | TimeStamp | The DateTime stamp of when the internal message was received.
Back to Top
Events
Name | Description
LogReceived | The event raised when an internal message has been received.
Back to Top
See Also
LogLog Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog Constructor

LogLog Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the LogLog class.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogLog(
    Type source,
    string prefix,
    string message,
    Exception exception
)
public LogLog(
    Type source,
    string prefix,
    string message,
    Exception exception
)
Public Sub New (
    source As Type,
    prefix As String,
    message As String,
    exception As Exception
)
Public Sub New (
    source As Type,
    prefix As String,
    message As String,
    exception As Exception
)
public:
LogLog(
    Type^ source,
    String^ prefix,
    String^ message,
    Exception^ exception
)
public:
LogLog(
    Type^ source,
    String^ prefix,
    String^ message,
    Exception^ exception
)
Parameters
source
Type:   Online System Type
[Missing <param name="source"/> documentation for "M:log4net.Util.LogLog.#ctor(System.Type,System.String,System.String,System.Exception)"]
prefix
Type:   Online System String
[Missing <param name="prefix"/> documentation for "M:log4net.Util.LogLog.#ctor(System.Type,System.String,System.String,System.Exception)"]
message
Type:   Online System String
[Missing <param name="message"/> documentation for "M:log4net.Util.LogLog.#ctor(System.Type,System.String,System.String,System.Exception)"]
exception
Type:   Online System Exception
[Missing <param name="exception"/> documentation for "M:log4net.Util.LogLog.#ctor(System.Type,System.String,System.String,System.Exception)"]
See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog Methods

LogLog Methods Apache log4net™ SDK Documentation
The LogLog type exposes the following members.
Methods
 | Name | Description
 | Debug(Type, String) | Writes log4net internal debug messages to the standard output stream.
 | Debug(Type, String, Exception) | Writes log4net internal debug messages to the standard output stream.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | Error(Type, String) | Writes log4net internal error messages to the standard error stream.
 | Error(Type, String, Exception) | Writes log4net internal error messages to the standard error stream.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | OnLogReceived | Raises the LogReceived event when an internal messages is received.
Public method | ToString | Formats Prefix, Source, and Message in the same format as the value sent to Console.Out and Trace.Write. (Overrides Online Object ToString .)
 | Warn(Type, String) | Writes log4net internal warning messages to the standard error stream.
 | Warn(Type, String, Exception) | Writes log4net internal warning messages to the standard error stream.
Back to Top
See Also
LogLog Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Debug Method

LogLog Debug Method Apache log4net™ SDK Documentation
Overload List
Name | Description
Debug(Type, String) | Writes log4net internal debug messages to the standard output stream.
Debug(Type, String, Exception) | Writes log4net internal debug messages to the standard output stream.
Back to Top
See Also
LogLog Class
LogLog Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Debug Method (Type, String)

LogLog Debug Method (Type, String) Apache log4net™ SDK Documentation
Writes log4net internal debug messages to the standard output stream.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Debug(
    Type source,
    string message
)
public static void Debug(
    Type source,
    string message
)
Public Shared Sub Debug (
    source As Type,
    message As String
)
Public Shared Sub Debug (
    source As Type,
    message As String
)
public:
static void Debug(
    Type^ source,
    String^ message
)
public:
static void Debug(
    Type^ source,
    String^ message
)
Parameters
source
Type:   Online System Type
[Missing <param name="source"/> documentation for "M:log4net.Util.LogLog.Debug(System.Type,System.String)"]
message
Type:   Online System String
The message to log.
Remarks

            All internal debug messages are prepended with
            the string "log4net: ".

See Also
LogLog Class
LogLog Members
Debug Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Debug Method (Type, String, Exception)

LogLog Debug Method (Type, String, Exception) Apache log4net™ SDK Documentation
Writes log4net internal debug messages to the standard output stream.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Debug(
    Type source,
    string message,
    Exception exception
)
public static void Debug(
    Type source,
    string message,
    Exception exception
)
Public Shared Sub Debug (
    source As Type,
    message As String,
    exception As Exception
)
Public Shared Sub Debug (
    source As Type,
    message As String,
    exception As Exception
)
public:
static void Debug(
    Type^ source,
    String^ message,
    Exception^ exception
)
public:
static void Debug(
    Type^ source,
    String^ message,
    Exception^ exception
)
Parameters
source
Type:   Online System Type
The Type that generated this message.
message
Type:   Online System String
The message to log.
exception
Type:   Online System Exception
An exception to log.
Remarks

            All internal debug messages are prepended with
            the string "log4net: ".

See Also
LogLog Class
LogLog Members
Debug Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Error Method

LogLog Error Method Apache log4net™ SDK Documentation
Overload List
Name | Description
Error(Type, String) | Writes log4net internal error messages to the standard error stream.
Error(Type, String, Exception) | Writes log4net internal error messages to the standard error stream.
Back to Top
See Also
LogLog Class
LogLog Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Error Method (Type, String)

LogLog Error Method (Type, String) Apache log4net™ SDK Documentation
Writes log4net internal error messages to the standard error stream.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Error(
    Type source,
    string message
)
public static void Error(
    Type source,
    string message
)
Public Shared Sub Error (
    source As Type,
    message As String
)
Public Shared Sub Error (
    source As Type,
    message As String
)
public:
static void Error(
    Type^ source,
    String^ message
)
public:
static void Error(
    Type^ source,
    String^ message
)
Parameters
source
Type:   Online System Type
The Type that generated this message.
message
Type:   Online System String
The message to log.
Remarks

            All internal error messages are prepended with
            the string "log4net:ERROR ".

See Also
LogLog Class
LogLog Members
Error Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Error Method (Type, String, Exception)

LogLog Error Method (Type, String, Exception) Apache log4net™ SDK Documentation
Writes log4net internal error messages to the standard error stream.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Error(
    Type source,
    string message,
    Exception exception
)
public static void Error(
    Type source,
    string message,
    Exception exception
)
Public Shared Sub Error (
    source As Type,
    message As String,
    exception As Exception
)
Public Shared Sub Error (
    source As Type,
    message As String,
    exception As Exception
)
public:
static void Error(
    Type^ source,
    String^ message,
    Exception^ exception
)
public:
static void Error(
    Type^ source,
    String^ message,
    Exception^ exception
)
Parameters
source
Type:   Online System Type
The Type that generated this message.
message
Type:   Online System String
The message to log.
exception
Type:   Online System Exception
An exception to log.
Remarks

            All internal debug messages are prepended with
            the string "log4net:ERROR ".

See Also
LogLog Class
LogLog Members
Error Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.OnLogReceived Method

LogLog OnLogReceived Method Apache log4net™ SDK Documentation
Raises the LogReceived event when an internal messages is received.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void OnLogReceived(
    Type source,
    string prefix,
    string message,
    Exception exception
)
public static void OnLogReceived(
    Type source,
    string prefix,
    string message,
    Exception exception
)
Public Shared Sub OnLogReceived (
    source As Type,
    prefix As String,
    message As String,
    exception As Exception
)
Public Shared Sub OnLogReceived (
    source As Type,
    prefix As String,
    message As String,
    exception As Exception
)
public:
static void OnLogReceived(
    Type^ source,
    String^ prefix,
    String^ message,
    Exception^ exception
)
public:
static void OnLogReceived(
    Type^ source,
    String^ prefix,
    String^ message,
    Exception^ exception
)
Parameters
source
Type:   Online System Type
[Missing <param name="source"/> documentation for "M:log4net.Util.LogLog.OnLogReceived(System.Type,System.String,System.String,System.Exception)"]
prefix
Type:   Online System String
[Missing <param name="prefix"/> documentation for "M:log4net.Util.LogLog.OnLogReceived(System.Type,System.String,System.String,System.Exception)"]
message
Type:   Online System String
[Missing <param name="message"/> documentation for "M:log4net.Util.LogLog.OnLogReceived(System.Type,System.String,System.String,System.Exception)"]
exception
Type:   Online System Exception
[Missing <param name="exception"/> documentation for "M:log4net.Util.LogLog.OnLogReceived(System.Type,System.String,System.String,System.Exception)"]
See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.ToString Method

LogLog ToString Method Apache log4net™ SDK Documentation
Formats Prefix, Source, and Message in the same format as the value sent to Console.Out and Trace.Write.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value
Type:   Online String
[Missing <returns> documentation for "M:log4net.Util.LogLog.ToString"]
See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Warn Method

LogLog Warn Method Apache log4net™ SDK Documentation
Overload List
Name | Description
Warn(Type, String) | Writes log4net internal warning messages to the standard error stream.
Warn(Type, String, Exception) | Writes log4net internal warning messages to the standard error stream.
Back to Top
See Also
LogLog Class
LogLog Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Warn Method (Type, String)

LogLog Warn Method (Type, String) Apache log4net™ SDK Documentation
Writes log4net internal warning messages to the standard error stream.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Warn(
    Type source,
    string message
)
public static void Warn(
    Type source,
    string message
)
Public Shared Sub Warn (
    source As Type,
    message As String
)
Public Shared Sub Warn (
    source As Type,
    message As String
)
public:
static void Warn(
    Type^ source,
    String^ message
)
public:
static void Warn(
    Type^ source,
    String^ message
)
Parameters
source
Type:   Online System Type
The Type that generated this message.
message
Type:   Online System String
The message to log.
Remarks

            All internal warning messages are prepended with
            the string "log4net:WARN ".

See Also
LogLog Class
LogLog Members
Warn Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Warn Method (Type, String, Exception)

LogLog Warn Method (Type, String, Exception) Apache log4net™ SDK Documentation
Writes log4net internal warning messages to the standard error stream.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Warn(
    Type source,
    string message,
    Exception exception
)
public static void Warn(
    Type source,
    string message,
    Exception exception
)
Public Shared Sub Warn (
    source As Type,
    message As String,
    exception As Exception
)
Public Shared Sub Warn (
    source As Type,
    message As String,
    exception As Exception
)
public:
static void Warn(
    Type^ source,
    String^ message,
    Exception^ exception
)
public:
static void Warn(
    Type^ source,
    String^ message,
    Exception^ exception
)
Parameters
source
Type:   Online System Type
The Type that generated this message.
message
Type:   Online System String
The message to log.
exception
Type:   Online System Exception
An exception to log.
Remarks

            All internal warning messages are prepended with
            the string "log4net:WARN ".

See Also
LogLog Class
LogLog Members
Warn Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog Properties

LogLog Properties Apache log4net™ SDK Documentation
The LogLog type exposes the following members.
Properties
 | Name | Description
 | EmitInternalMessages |
Public property | Exception | The Exception related to the message.
 | InternalDebugging | Gets or sets a value indicating whether log4net internal logging is enabled or disabled.
 | IsDebugEnabled | Test if LogLog.Debug is enabled for output.
 | IsErrorEnabled | Test if LogLog.Error is enabled for output.
 | IsWarnEnabled | Test if LogLog.Warn is enabled for output.
Public property | Message | The internal log message.
Public property | Prefix | A string indicating the severity of the internal message.
 | QuietMode | Gets or sets a value indicating whether log4net should generate no output from internal logging, not even for errors.
Public property | Source | The Type that generated the internal message.
Public property | TimeStamp | The DateTime stamp of when the internal message was received.
Back to Top
See Also
LogLog Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.EmitInternalMessages Property

LogLog EmitInternalMessages Property Apache log4net™ SDK Documentation

[Missing <summary> documentation for "P:log4net.Util.LogLog.EmitInternalMessages"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool EmitInternalMessages { get; set; }
public static bool EmitInternalMessages { get; set; }
Public Shared Property EmitInternalMessages As Boolean
    Get
    Set
Public Shared Property EmitInternalMessages As Boolean
    Get
    Set
public:
static property bool EmitInternalMessages {
    bool get ();
    void set (bool value);
}
public:
static property bool EmitInternalMessages {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Exception Property

LogLog Exception Property Apache log4net™ SDK Documentation
The Exception related to the message.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception Exception { get; }
public Exception Exception { get; }
Public ReadOnly Property Exception As Exception
    Get
Public ReadOnly Property Exception As Exception
    Get
public:
property Exception^ Exception {
    Exception^ get ();
}
public:
property Exception^ Exception {
    Exception^ get ();
}
Property Value
Type:   Online Exception
Remarks

            Optional. Will be null if no Exception was passed.

See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.InternalDebugging Property

LogLog InternalDebugging Property Apache log4net™ SDK Documentation
Gets or sets a value indicating whether log4net internal logging is enabled or disabled.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool InternalDebugging { get; set; }
public static bool InternalDebugging { get; set; }
Public Shared Property InternalDebugging As Boolean
    Get
    Set
Public Shared Property InternalDebugging As Boolean
    Get
    Set
public:
static property bool InternalDebugging {
    bool get ();
    void set (bool value);
}
public:
static property bool InternalDebugging {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if log4net internal logging is enabled, otherwise
            false.

Remarks

            When set to true, internal debug level logging will be
            displayed.

            This value can be set by setting the application setting
            log4net.Internal.Debug in the application configuration
            file.

            The default value is false, i.e. debugging is
            disabled.

Examples

            The following example enables internal debugging using the
            application configuration file :

XML
View Colorized Copy to Clipboard Print
<configuration><appSettings><add key="log4net.Internal.Debug" value="true" /></appSettings></configuration>
<configuration><appSettings><add key="log4net.Internal.Debug" value="true" /></appSettings></configuration>
See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.IsDebugEnabled Property

LogLog IsDebugEnabled Property Apache log4net™ SDK Documentation
Test if LogLog.Debug is enabled for output.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsDebugEnabled { get; }
public static bool IsDebugEnabled { get; }
Public Shared ReadOnly Property IsDebugEnabled As Boolean
    Get
Public Shared ReadOnly Property IsDebugEnabled As Boolean
    Get
public:
static property bool IsDebugEnabled {
    bool get ();
}
public:
static property bool IsDebugEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if Debug is enabled

Remarks

            Test if LogLog.Debug is enabled for output.

See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.IsErrorEnabled Property

LogLog IsErrorEnabled Property Apache log4net™ SDK Documentation
Test if LogLog.Error is enabled for output.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsErrorEnabled { get; }
public static bool IsErrorEnabled { get; }
Public Shared ReadOnly Property IsErrorEnabled As Boolean
    Get
Public Shared ReadOnly Property IsErrorEnabled As Boolean
    Get
public:
static property bool IsErrorEnabled {
    bool get ();
}
public:
static property bool IsErrorEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if Error is enabled

Remarks

            Test if LogLog.Error is enabled for output.

See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.IsWarnEnabled Property

LogLog IsWarnEnabled Property Apache log4net™ SDK Documentation
Test if LogLog.Warn is enabled for output.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsWarnEnabled { get; }
public static bool IsWarnEnabled { get; }
Public Shared ReadOnly Property IsWarnEnabled As Boolean
    Get
Public Shared ReadOnly Property IsWarnEnabled As Boolean
    Get
public:
static property bool IsWarnEnabled {
    bool get ();
}
public:
static property bool IsWarnEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
true if Warn is enabled

Remarks

            Test if LogLog.Warn is enabled for output.

See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Message Property

LogLog Message Property Apache log4net™ SDK Documentation
The internal log message.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Message { get; }
public string Message { get; }
Public ReadOnly Property Message As String
    Get
Public ReadOnly Property Message As String
    Get
public:
property String^ Message {
    String^ get ();
}
public:
property String^ Message {
    String^ get ();
}
Property Value
Type:   Online String
See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Prefix Property

LogLog Prefix Property Apache log4net™ SDK Documentation
A string indicating the severity of the internal message.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Prefix { get; }
public string Prefix { get; }
Public ReadOnly Property Prefix As String
    Get
Public ReadOnly Property Prefix As String
    Get
public:
property String^ Prefix {
    String^ get ();
}
public:
property String^ Prefix {
    String^ get ();
}
Property Value
Type:   Online String
Remarks

            "log4net: ",
            "log4net:ERROR ",
            "log4net:WARN "

See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.QuietMode Property

LogLog QuietMode Property Apache log4net™ SDK Documentation
Gets or sets a value indicating whether log4net should generate no output from internal logging, not even for errors.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool QuietMode { get; set; }
public static bool QuietMode { get; set; }
Public Shared Property QuietMode As Boolean
    Get
    Set
Public Shared Property QuietMode As Boolean
    Get
    Set
public:
static property bool QuietMode {
    bool get ();
    void set (bool value);
}
public:
static property bool QuietMode {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if log4net should generate no output at all from internal
            logging, otherwise false.

Remarks

            When set to true will cause internal logging at all levels to be
            suppressed. This means that no warning or error reports will be logged.
            This option overrides the InternalDebugging setting and
            disables all debug also.

This value can be set by setting the application setting
            log4net.Internal.Quiet in the application configuration file.

            The default value is false, i.e. internal logging is not
            disabled.

Examples

            The following example disables internal logging using the
            application configuration file :

XML
View Colorized Copy to Clipboard Print
<configuration><appSettings><add key="log4net.Internal.Quiet" value="true" /></appSettings></configuration>
<configuration><appSettings><add key="log4net.Internal.Quiet" value="true" /></appSettings></configuration>
See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.Source Property

LogLog Source Property Apache log4net™ SDK Documentation
The Type that generated the internal message.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type Source { get; }
public Type Source { get; }
Public ReadOnly Property Source As Type
    Get
Public ReadOnly Property Source As Type
    Get
public:
property Type^ Source {
    Type^ get ();
}
public:
property Type^ Source {
    Type^ get ();
}
Property Value
Type:   Online Type
See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.TimeStamp Property

LogLog TimeStamp Property Apache log4net™ SDK Documentation
The DateTime stamp of when the internal message was received.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime TimeStamp { get; }
public DateTime TimeStamp { get; }
Public ReadOnly Property TimeStamp As DateTime
    Get
Public ReadOnly Property TimeStamp As DateTime
    Get
public:
property DateTime TimeStamp {
    DateTime get ();
}
public:
property DateTime TimeStamp {
    DateTime get ();
}
Property Value
Type:   Online DateTime
See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog Events

LogLog Events Apache log4net™ SDK Documentation
The LogLog type exposes the following members.
Events
Name | Description
LogReceived | The event raised when an internal message has been received.
Back to Top
See Also
LogLog Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.LogReceived Event

LogLog LogReceived Event Apache log4net™ SDK Documentation
The event raised when an internal message has been received.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static event LogReceivedEventHandler LogReceived
public static event LogReceivedEventHandler LogReceived
Public Shared Event LogReceived As LogReceivedEventHandler
Public Shared Event LogReceived As LogReceivedEventHandler
public:
static  event LogReceivedEventHandler^ LogReceived {
    void add (LogReceivedEventHandler^ value);
    void remove (LogReceivedEventHandler^ value);
}
public:
static  event LogReceivedEventHandler^ LogReceived {
    void add (LogReceivedEventHandler^ value);
    void remove (LogReceivedEventHandler^ value);
}
Value
Type: log4net.Util LogReceivedEventHandler
See Also
LogLog Class
LogLog Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.LogReceivedAdapter Class

LogLog LogReceivedAdapter Class Apache log4net™ SDK Documentation
Subscribes to the LogLog.LogReceived event and stores messages to the supplied IList instance.
Inheritance Hierarchy
Online System Object
log4net.Util LogLog LogReceivedAdapter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LogReceivedAdapter : IDisposable
public class LogReceivedAdapter : IDisposable
Public Class LogReceivedAdapter
    Implements IDisposable
Public Class LogReceivedAdapter
    Implements IDisposable
public ref class LogReceivedAdapter : IDisposable
public ref class LogReceivedAdapter : IDisposable
See Also
LogLog LogReceivedAdapter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.LogReceivedAdapter Members

LogLog LogReceivedAdapter Members Apache log4net™ SDK Documentation
The LogLog LogReceivedAdapter type exposes the following members.
Constructors
 | Name | Description
Public method | LogLog LogReceivedAdapter | Initializes a new instance of the LogLog LogReceivedAdapter class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LogLog LogReceivedAdapter
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Items |
Back to Top
See Also
LogLog LogReceivedAdapter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.LogReceivedAdapter Constructor

LogLog LogReceivedAdapter Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the LogLog LogReceivedAdapter class

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogReceivedAdapter(
    IList items
)
public LogReceivedAdapter(
    IList items
)
Public Sub New (
    items As IList
)
Public Sub New (
    items As IList
)
public:
LogReceivedAdapter(
    IList^ items
)
public:
LogReceivedAdapter(
    IList^ items
)
Parameters
items
Type:   Online System.Collections IList
[Missing <param name="items"/> documentation for "M:log4net.Util.LogLog.LogReceivedAdapter.#ctor(System.Collections.IList)"]
See Also
LogLog LogReceivedAdapter Class
LogLog LogReceivedAdapter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.LogReceivedAdapter Methods

LogLog LogReceivedAdapter Methods Apache log4net™ SDK Documentation
The LogLog LogReceivedAdapter type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LogLog LogReceivedAdapter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.LogReceivedAdapter.Dispose Method

LogLog LogReceivedAdapter Dispose Method Apache log4net™ SDK Documentation
Releases all resources used by the LogLog LogReceivedAdapter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
LogLog LogReceivedAdapter Class
LogLog LogReceivedAdapter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.LogReceivedAdapter Properties

LogLog LogReceivedAdapter Properties Apache log4net™ SDK Documentation
The LogLog LogReceivedAdapter type exposes the following members.
Properties
 | Name | Description
Public property | Items |
Back to Top
See Also
LogLog LogReceivedAdapter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogLog.LogReceivedAdapter.Items Property

LogLog LogReceivedAdapter Items Property Apache log4net™ SDK Documentation

[Missing <summary> documentation for "P:log4net.Util.LogLog.LogReceivedAdapter.Items"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList Items { get; }
public IList Items { get; }
Public ReadOnly Property Items As IList
    Get
Public ReadOnly Property Items As IList
    Get
public:
property IList^ Items {
    IList^ get ();
}
public:
property IList^ Items {
    IList^ get ();
}
Property Value
Type:   Online IList
See Also
LogLog LogReceivedAdapter Class
LogLog LogReceivedAdapter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogReceivedEventArgs Class

LogReceivedEventArgs Class Apache log4net™ SDK Documentation

[Missing <summary> documentation for "T:log4net.Util.LogReceivedEventArgs"]

Inheritance Hierarchy
Online System Object
Online System EventArgs
log4net.Util LogReceivedEventArgs

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LogReceivedEventArgs : EventArgs
public class LogReceivedEventArgs : EventArgs
Public Class LogReceivedEventArgs
    Inherits EventArgs
Public Class LogReceivedEventArgs
    Inherits EventArgs
public ref class LogReceivedEventArgs : public EventArgs
public ref class LogReceivedEventArgs : public EventArgs
See Also
LogReceivedEventArgs Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogReceivedEventArgs Members

LogReceivedEventArgs Members Apache log4net™ SDK Documentation
The LogReceivedEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | LogReceivedEventArgs | Initializes a new instance of the LogReceivedEventArgs class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | LogLog |
Back to Top
See Also
LogReceivedEventArgs Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogReceivedEventArgs Constructor

LogReceivedEventArgs Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the LogReceivedEventArgs class

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogReceivedEventArgs(
    LogLog loglog
)
public LogReceivedEventArgs(
    LogLog loglog
)
Public Sub New (
    loglog As LogLog
)
Public Sub New (
    loglog As LogLog
)
public:
LogReceivedEventArgs(
    LogLog^ loglog
)
public:
LogReceivedEventArgs(
    LogLog^ loglog
)
Parameters
loglog
Type: log4net.Util LogLog
[Missing <param name="loglog"/> documentation for "M:log4net.Util.LogReceivedEventArgs.#ctor(log4net.Util.LogLog)"]
See Also
LogReceivedEventArgs Class
LogReceivedEventArgs Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogReceivedEventArgs Methods

LogReceivedEventArgs Methods Apache log4net™ SDK Documentation
The LogReceivedEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LogReceivedEventArgs Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogReceivedEventArgs Properties

LogReceivedEventArgs Properties Apache log4net™ SDK Documentation
The LogReceivedEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | LogLog |
Back to Top
See Also
LogReceivedEventArgs Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogReceivedEventArgs.LogLog Property

LogReceivedEventArgs LogLog Property Apache log4net™ SDK Documentation

[Missing <summary> documentation for "P:log4net.Util.LogReceivedEventArgs.LogLog"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogLog LogLog { get; }
public LogLog LogLog { get; }
Public ReadOnly Property LogLog As LogLog
    Get
Public ReadOnly Property LogLog As LogLog
    Get
public:
property LogLog^ LogLog {
    LogLog^ get ();
}
public:
property LogLog^ LogLog {
    LogLog^ get ();
}
Property Value
Type: LogLog
See Also
LogReceivedEventArgs Class
LogReceivedEventArgs Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


LogReceivedEventHandler Delegate

LogReceivedEventHandler Delegate Apache log4net™ SDK Documentation

[Missing <summary> documentation for "T:log4net.Util.LogReceivedEventHandler"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void LogReceivedEventHandler(
    Object source,
    LogReceivedEventArgs e
)
public delegate void LogReceivedEventHandler(
    Object source,
    LogReceivedEventArgs e
)
Public Delegate Sub LogReceivedEventHandler (
    source As Object,
    e As LogReceivedEventArgs
)
Public Delegate Sub LogReceivedEventHandler (
    source As Object,
    e As LogReceivedEventArgs
)
public delegate void LogReceivedEventHandler(
    Object^ source,
    LogReceivedEventArgs^ e
)
public delegate void LogReceivedEventHandler(
    Object^ source,
    LogReceivedEventArgs^ e
)
Parameters
source
Type:   Online System Object
e
Type: log4net.Util LogReceivedEventArgs
See Also
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NativeError Class

NativeError Class Apache log4net™ SDK Documentation
Represents a native error code and message.
Inheritance Hierarchy
Online System Object
log4net.Util NativeError

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NativeError
public sealed class NativeError
Public NotInheritable Class NativeError
Public NotInheritable Class NativeError
public ref class NativeError sealed
public ref class NativeError sealed
Remarks

            Represents a Win32 platform native error.

See Also
NativeError Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NativeError Members

NativeError Members Apache log4net™ SDK Documentation
The NativeError type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetError | Create a new instance of the NativeError class.
 | GetErrorMessage | Retrieves the message corresponding with a Win32 message identifier.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetLastError | Create a new instance of the NativeError class for the last Windows error.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Return error information string (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Message | Gets the message of the native error.
Public property | Number | Gets the number of the native error.
Back to Top
See Also
NativeError Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NativeError Methods

NativeError Methods Apache log4net™ SDK Documentation
The NativeError type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetError | Create a new instance of the NativeError class.
 | GetErrorMessage | Retrieves the message corresponding with a Win32 message identifier.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetLastError | Create a new instance of the NativeError class for the last Windows error.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Return error information string (Overrides Online Object ToString .)
Back to Top
See Also
NativeError Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NativeError.GetError Method

NativeError GetError Method Apache log4net™ SDK Documentation
Create a new instance of the NativeError class.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NativeError GetError(
    int number
)
public static NativeError GetError(
    int number
)
Public Shared Function GetError (
    number As Integer
) As NativeError
Public Shared Function GetError (
    number As Integer
) As NativeError
public:
static NativeError^ GetError(
    int number
)
public:
static NativeError^ GetError(
    int number
)
Parameters
number
Type:   Online System Int32
the error number for the native error
Return Value
Type: NativeError

            An instance of the NativeError class for the specified
            error number.

Remarks

            The message for the specified error number is lookup up using the
            native Win32 FormatMessage function.

See Also
NativeError Class
NativeError Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NativeError.GetErrorMessage Method

NativeError GetErrorMessage Method Apache log4net™ SDK Documentation
Retrieves the message corresponding with a Win32 message identifier.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetErrorMessage(
    int messageId
)
public static string GetErrorMessage(
    int messageId
)
Public Shared Function GetErrorMessage (
    messageId As Integer
) As String
Public Shared Function GetErrorMessage (
    messageId As Integer
) As String
public:
static String^ GetErrorMessage(
    int messageId
)
public:
static String^ GetErrorMessage(
    int messageId
)
Parameters
messageId
Type:   Online System Int32
Message identifier for the requested message.
Return Value
Type:   Online String

            The message corresponding with the specified message identifier.

Remarks

            The message will be searched for in system message-table resource(s)
            using the native FormatMessage function.

See Also
NativeError Class
NativeError Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NativeError.GetLastError Method

NativeError GetLastError Method Apache log4net™ SDK Documentation
Create a new instance of the NativeError class for the last Windows error.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NativeError GetLastError()
public static NativeError GetLastError()
Public Shared Function GetLastError As NativeError
Public Shared Function GetLastError As NativeError
public:
static NativeError^ GetLastError()
public:
static NativeError^ GetLastError()
Return Value
Type: NativeError

            An instance of the NativeError class for the last windows error.

Remarks

            The message for the   Online GetLastWin32Error  error number is lookup up using the
            native Win32 FormatMessage function.

See Also
NativeError Class
NativeError Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NativeError.ToString Method

NativeError ToString Method Apache log4net™ SDK Documentation
Return error information string

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value
Type:   Online String
error information string
Remarks

            Return error information string

See Also
NativeError Class
NativeError Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NativeError Properties

NativeError Properties Apache log4net™ SDK Documentation
The NativeError type exposes the following members.
Properties
 | Name | Description
Public property | Message | Gets the message of the native error.
Public property | Number | Gets the number of the native error.
Back to Top
See Also
NativeError Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NativeError.Message Property

NativeError Message Property Apache log4net™ SDK Documentation
Gets the message of the native error.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Message { get; }
public string Message { get; }
Public ReadOnly Property Message As String
    Get
Public ReadOnly Property Message As String
    Get
public:
property String^ Message {
    String^ get ();
}
public:
property String^ Message {
    String^ get ();
}
Property Value
Type:   Online String

            The message of the native error.

Remarks

            Gets the message of the native error.

See Also
NativeError Class
NativeError Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NativeError.Number Property

NativeError Number Property Apache log4net™ SDK Documentation
Gets the number of the native error.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Number { get; }
public int Number { get; }
Public ReadOnly Property Number As Integer
    Get
Public ReadOnly Property Number As Integer
    Get
public:
property int Number {
    int get ();
}
public:
property int Number {
    int get ();
}
Property Value
Type:   Online Int32

            The number of the native error.

Remarks

            Gets the number of the native error.

See Also
NativeError Class
NativeError Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullDictionaryEnumerator Class

NullDictionaryEnumerator Class Apache log4net™ SDK Documentation
An always empty Online IDictionaryEnumerator.
Inheritance Hierarchy
Online System Object
log4net.Util NullDictionaryEnumerator

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NullDictionaryEnumerator : IDictionaryEnumerator,
    IEnumerator
public sealed class NullDictionaryEnumerator : IDictionaryEnumerator,
    IEnumerator
Public NotInheritable Class NullDictionaryEnumerator
    Implements IDictionaryEnumerator, IEnumerator
Public NotInheritable Class NullDictionaryEnumerator
    Implements IDictionaryEnumerator, IEnumerator
public ref class NullDictionaryEnumerator sealed : IDictionaryEnumerator,
    IEnumerator
public ref class NullDictionaryEnumerator sealed : IDictionaryEnumerator,
    IEnumerator
Remarks

            A singleton implementation of the   Online IDictionaryEnumerator over a collection
            that is empty and not modifiable.

See Also
NullDictionaryEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullDictionaryEnumerator Members

NullDictionaryEnumerator Members Apache log4net™ SDK Documentation
The NullDictionaryEnumerator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext | Test if the enumerator can advance, if so advance.
Public method | Reset | Resets the enumerator back to the start.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Current | Gets the current object from the enumerator.
Public property | Entry | Gets the current entry from the enumerator.
 | Instance | Gets the singleton instance of the NullDictionaryEnumerator.
Public property | Key | Gets the current key from the enumerator.
Public property | Value | Gets the current value from the enumerator.
Back to Top
See Also
NullDictionaryEnumerator Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullDictionaryEnumerator Methods

NullDictionaryEnumerator Methods Apache log4net™ SDK Documentation
The NullDictionaryEnumerator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext | Test if the enumerator can advance, if so advance.
Public method | Reset | Resets the enumerator back to the start.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NullDictionaryEnumerator Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullDictionaryEnumerator.MoveNext Method

NullDictionaryEnumerator MoveNext Method Apache log4net™ SDK Documentation
Test if the enumerator can advance, if so advance.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MoveNext()
public bool MoveNext()
Public Function MoveNext As Boolean
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed
public:
virtual bool MoveNext() sealed
Return Value
Type:   Online Boolean
false as the NullDictionaryEnumerator cannot advance.
Implements
  Online IEnumerator MoveNext
Remarks

            As the enumerator is over an empty collection its Current
            value cannot be moved over a valid position, therefore MoveNext
            will always return false.

See Also
NullDictionaryEnumerator Class
NullDictionaryEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullDictionaryEnumerator.Reset Method

NullDictionaryEnumerator Reset Method Apache log4net™ SDK Documentation
Resets the enumerator back to the start.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
virtual void Reset() sealed
public:
virtual void Reset() sealed
Implements
  Online IEnumerator Reset
Remarks

            As the enumerator is over an empty collection Reset  does nothing.

See Also
NullDictionaryEnumerator Class
NullDictionaryEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullDictionaryEnumerator Properties

NullDictionaryEnumerator Properties Apache log4net™ SDK Documentation
The NullDictionaryEnumerator type exposes the following members.
Properties
 | Name | Description
Public property | Current | Gets the current object from the enumerator.
Public property | Entry | Gets the current entry from the enumerator.
 | Instance | Gets the singleton instance of the NullDictionaryEnumerator.
Public property | Key | Gets the current key from the enumerator.
Public property | Value | Gets the current value from the enumerator.
Back to Top
See Also
NullDictionaryEnumerator Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullDictionaryEnumerator.Current Property

NullDictionaryEnumerator Current Property Apache log4net™ SDK Documentation
Gets the current object from the enumerator.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Current { get; }
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Public ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get () sealed;
}
public:
virtual property Object^ Current {
    Object^ get () sealed;
}
Property Value
Type:   Online Object
Implements
  Online IEnumerator Current
Exceptions
Exception | Condition
Online System InvalidOperationException | The collection is empty and Current cannot be positioned over a valid location.
Remarks

            Throws an   Online InvalidOperationException because the
            NullDictionaryEnumerator never has a current value.

Remarks

            As the enumerator is over an empty collection its Current
            value cannot be moved over a valid position, therefore Current
            will throw an   Online InvalidOperationException.

See Also
NullDictionaryEnumerator Class
NullDictionaryEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullDictionaryEnumerator.Entry Property

NullDictionaryEnumerator Entry Property Apache log4net™ SDK Documentation
Gets the current entry from the enumerator.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DictionaryEntry Entry { get; }
public DictionaryEntry Entry { get; }
Public ReadOnly Property Entry As DictionaryEntry
    Get
Public ReadOnly Property Entry As DictionaryEntry
    Get
public:
virtual property DictionaryEntry Entry {
    DictionaryEntry get () sealed;
}
public:
virtual property DictionaryEntry Entry {
    DictionaryEntry get () sealed;
}
Property Value
Type:   Online DictionaryEntry
Implements
  Online IDictionaryEnumerator Entry
Exceptions
Exception | Condition
Online System InvalidOperationException | The collection is empty and Current cannot be positioned over a valid location.
Remarks

            Throws an   Online InvalidOperationException because the
            NullDictionaryEnumerator never has a current entry.

Remarks

            As the enumerator is over an empty collection its Current
            value cannot be moved over a valid position, therefore Entry
            will throw an   Online InvalidOperationException.

See Also
NullDictionaryEnumerator Class
NullDictionaryEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullDictionaryEnumerator.Instance Property

NullDictionaryEnumerator Instance Property Apache log4net™ SDK Documentation
Gets the singleton instance of the NullDictionaryEnumerator.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NullDictionaryEnumerator Instance { get; }
public static NullDictionaryEnumerator Instance { get; }
Public Shared ReadOnly Property Instance As NullDictionaryEnumerator
    Get
Public Shared ReadOnly Property Instance As NullDictionaryEnumerator
    Get
public:
static property NullDictionaryEnumerator^ Instance {
    NullDictionaryEnumerator^ get ();
}
public:
static property NullDictionaryEnumerator^ Instance {
    NullDictionaryEnumerator^ get ();
}
Return Value
Type: NullDictionaryEnumerator
The singleton instance of the NullDictionaryEnumerator.
Remarks

            Gets the singleton instance of the NullDictionaryEnumerator.

See Also
NullDictionaryEnumerator Class
NullDictionaryEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullDictionaryEnumerator.Key Property

NullDictionaryEnumerator Key Property Apache log4net™ SDK Documentation
Gets the current key from the enumerator.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Key { get; }
public Object Key { get; }
Public ReadOnly Property Key As Object
    Get
Public ReadOnly Property Key As Object
    Get
public:
virtual property Object^ Key {
    Object^ get () sealed;
}
public:
virtual property Object^ Key {
    Object^ get () sealed;
}
Property Value
Type:   Online Object
Implements
  Online IDictionaryEnumerator Key
Exceptions
Exception | Condition
Online System InvalidOperationException | The collection is empty and Current cannot be positioned over a valid location.
Remarks

            Throws an exception because the NullDictionaryEnumerator
            never has a current value.

Remarks

            As the enumerator is over an empty collection its Current
            value cannot be moved over a valid position, therefore Key
            will throw an   Online InvalidOperationException.

See Also
NullDictionaryEnumerator Class
NullDictionaryEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullDictionaryEnumerator.Value Property

NullDictionaryEnumerator Value Property Apache log4net™ SDK Documentation
Gets the current value from the enumerator.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Value { get; }
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get
Public ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get () sealed;
}
public:
virtual property Object^ Value {
    Object^ get () sealed;
}
Property Value
Type:   Online Object
The current value from the enumerator.
Implements
  Online IDictionaryEnumerator Value
Exceptions
Exception | Condition
Online System InvalidOperationException | The collection is empty and Current cannot be positioned over a valid location.
Remarks

            Throws an   Online InvalidOperationException because the
            NullDictionaryEnumerator never has a current value.

Remarks

            As the enumerator is over an empty collection its Current
            value cannot be moved over a valid position, therefore Value
            will throw an   Online InvalidOperationException.

See Also
NullDictionaryEnumerator Class
NullDictionaryEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullEnumerator Class

NullEnumerator Class Apache log4net™ SDK Documentation
An always empty Online IEnumerator.
Inheritance Hierarchy
Online System Object
log4net.Util NullEnumerator

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NullEnumerator : IEnumerator
public sealed class NullEnumerator : IEnumerator
Public NotInheritable Class NullEnumerator
    Implements IEnumerator
Public NotInheritable Class NullEnumerator
    Implements IEnumerator
public ref class NullEnumerator sealed : IEnumerator
public ref class NullEnumerator sealed : IEnumerator
Remarks

            A singleton implementation of the   Online IEnumerator over a collection
            that is empty and not modifiable.

See Also
NullEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullEnumerator Members

NullEnumerator Members Apache log4net™ SDK Documentation
The NullEnumerator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext | Test if the enumerator can advance, if so advance
Public method | Reset | Resets the enumerator back to the start.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Current | Gets the current object from the enumerator.
 | Instance | Get the singleton instance of the NullEnumerator.
Back to Top
See Also
NullEnumerator Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullEnumerator Methods

NullEnumerator Methods Apache log4net™ SDK Documentation
The NullEnumerator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext | Test if the enumerator can advance, if so advance
Public method | Reset | Resets the enumerator back to the start.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NullEnumerator Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullEnumerator.MoveNext Method

NullEnumerator MoveNext Method Apache log4net™ SDK Documentation
Test if the enumerator can advance, if so advance

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MoveNext()
public bool MoveNext()
Public Function MoveNext As Boolean
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed
public:
virtual bool MoveNext() sealed
Return Value
Type:   Online Boolean
false as the NullEnumerator cannot advance.
Implements
  Online IEnumerator MoveNext
Remarks

            As the enumerator is over an empty collection its Current
            value cannot be moved over a valid position, therefore MoveNext
            will always return false.

See Also
NullEnumerator Class
NullEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullEnumerator.Reset Method

NullEnumerator Reset Method Apache log4net™ SDK Documentation
Resets the enumerator back to the start.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
virtual void Reset() sealed
public:
virtual void Reset() sealed
Implements
  Online IEnumerator Reset
Remarks

            As the enumerator is over an empty collection Reset  does nothing.

See Also
NullEnumerator Class
NullEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullEnumerator Properties

NullEnumerator Properties Apache log4net™ SDK Documentation
The NullEnumerator type exposes the following members.
Properties
 | Name | Description
Public property | Current | Gets the current object from the enumerator.
 | Instance | Get the singleton instance of the NullEnumerator.
Back to Top
See Also
NullEnumerator Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullEnumerator.Current Property

NullEnumerator Current Property Apache log4net™ SDK Documentation
Gets the current object from the enumerator.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Current { get; }
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Public ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get () sealed;
}
public:
virtual property Object^ Current {
    Object^ get () sealed;
}
Property Value
Type:   Online Object
Implements
  Online IEnumerator Current
Exceptions
Exception | Condition
Online System InvalidOperationException | The collection is empty and Current cannot be positioned over a valid location.
Remarks

            Throws an   Online InvalidOperationException because the
            NullDictionaryEnumerator never has a current value.

Remarks

            As the enumerator is over an empty collection its Current
            value cannot be moved over a valid position, therefore Current
            will throw an   Online InvalidOperationException.

See Also
NullEnumerator Class
NullEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullEnumerator.Instance Property

NullEnumerator Instance Property Apache log4net™ SDK Documentation
Get the singleton instance of the NullEnumerator.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NullEnumerator Instance { get; }
public static NullEnumerator Instance { get; }
Public Shared ReadOnly Property Instance As NullEnumerator
    Get
Public Shared ReadOnly Property Instance As NullEnumerator
    Get
public:
static property NullEnumerator^ Instance {
    NullEnumerator^ get ();
}
public:
static property NullEnumerator^ Instance {
    NullEnumerator^ get ();
}
Return Value
Type: NullEnumerator
The singleton instance of the NullEnumerator.
Remarks

            Gets the singleton instance of the NullEnumerator.

See Also
NullEnumerator Class
NullEnumerator Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullSecurityContext Class

NullSecurityContext Class Apache log4net™ SDK Documentation
A SecurityContext used when a SecurityContext is not required
Inheritance Hierarchy
Online System Object
log4net.Core SecurityContext
log4net.Util NullSecurityContext

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NullSecurityContext : SecurityContext
public sealed class NullSecurityContext : SecurityContext
Public NotInheritable Class NullSecurityContext
    Inherits SecurityContext
Public NotInheritable Class NullSecurityContext
    Inherits SecurityContext
public ref class NullSecurityContext sealed : public SecurityContext
public ref class NullSecurityContext sealed : public SecurityContext
Remarks

            The NullSecurityContext is a no-op implementation of the
            SecurityContext base class. It is used where a SecurityContext
            is required but one has not been provided.

See Also
NullSecurityContext Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullSecurityContext Members

NullSecurityContext Members Apache log4net™ SDK Documentation
The NullSecurityContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Impersonate | Impersonate this SecurityContext (Overrides SecurityContext Impersonate(Object).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Instance | Singleton instance of NullSecurityContext
Back to Top
See Also
NullSecurityContext Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullSecurityContext Fields

NullSecurityContext Fields Apache log4net™ SDK Documentation
The NullSecurityContext type exposes the following members.
Fields
Name | Description
Instance | Singleton instance of NullSecurityContext
Back to Top
See Also
NullSecurityContext Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullSecurityContext.Instance Field

NullSecurityContext Instance Field Apache log4net™ SDK Documentation
Singleton instance of NullSecurityContext

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly NullSecurityContext Instance
public static readonly NullSecurityContext Instance
Public Shared ReadOnly Instance As NullSecurityContext
Public Shared ReadOnly Instance As NullSecurityContext
public:
static initonly NullSecurityContext^ Instance
public:
static initonly NullSecurityContext^ Instance
Field Value
Type: NullSecurityContext
Remarks

            Singleton instance of NullSecurityContext
See Also
NullSecurityContext Class
NullSecurityContext Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullSecurityContext Methods

NullSecurityContext Methods Apache log4net™ SDK Documentation
The NullSecurityContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Impersonate | Impersonate this SecurityContext (Overrides SecurityContext Impersonate(Object).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NullSecurityContext Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


NullSecurityContext.Impersonate Method

NullSecurityContext Impersonate Method Apache log4net™ SDK Documentation
Impersonate this SecurityContext

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IDisposable Impersonate(
    Object state
)
public override IDisposable Impersonate(
    Object state
)
Public Overrides Function Impersonate (
    state As Object
) As IDisposable
Public Overrides Function Impersonate (
    state As Object
) As IDisposable
public:
virtual IDisposable^ Impersonate(
    Object^ state
) override
public:
virtual IDisposable^ Impersonate(
    Object^ state
) override
Parameters
state
Type:   Online System Object
State supplied by the caller
Return Value
Type:   Online IDisposable
null
Remarks

            No impersonation is done and null is always returned.

See Also
NullSecurityContext Class
NullSecurityContext Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler Class

OnlyOnceErrorHandler Class Apache log4net™ SDK Documentation
Implements log4net's default error handling policy which consists of emitting a message for the first error in an appender and ignoring all subsequent errors.
Inheritance Hierarchy
Online System Object
log4net.Util OnlyOnceErrorHandler

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class OnlyOnceErrorHandler : IErrorHandler
public class OnlyOnceErrorHandler : IErrorHandler
Public Class OnlyOnceErrorHandler
    Implements IErrorHandler
Public Class OnlyOnceErrorHandler
    Implements IErrorHandler
public ref class OnlyOnceErrorHandler : IErrorHandler
public ref class OnlyOnceErrorHandler : IErrorHandler
Remarks

            The error message is processed using the LogLog sub-system by default.

            This policy aims at protecting an otherwise working application
            from being flooded with error messages when logging fails.

See Also
OnlyOnceErrorHandler Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler Members

OnlyOnceErrorHandler Members Apache log4net™ SDK Documentation
The OnlyOnceErrorHandler type exposes the following members.
Constructors
 | Name | Description
Public method | OnlyOnceErrorHandler | Default Constructor
Public method | OnlyOnceErrorHandler(String) | Constructor
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Error(String) | Log an error
Public method | Error(String, Exception) | Log an Error
Public method | Error(String, Exception, ErrorCode) | Log an Error
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FirstError | Log the very first error
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the error handler back to its initial disabled state.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | EnabledDate | The date the first error that trigged this error handler occured.
Public property | ErrorCode | The error code from the first error that trigged this error handler.
Public property | ErrorMessage | The message from the first error that trigged this error handler.
Public property | Exception | The exception from the first error that trigged this error handler.
Public property | IsEnabled | Is error logging enabled
Back to Top
See Also
OnlyOnceErrorHandler Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler Constructor

OnlyOnceErrorHandler Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | OnlyOnceErrorHandler | Default Constructor
Public method | OnlyOnceErrorHandler(String) | Constructor
Back to Top
See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler Constructor

OnlyOnceErrorHandler Constructor Apache log4net™ SDK Documentation
Default Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OnlyOnceErrorHandler()
public OnlyOnceErrorHandler()
Public Sub New
Public Sub New
public:
OnlyOnceErrorHandler()
public:
OnlyOnceErrorHandler()
Remarks

            Initializes a new instance of the OnlyOnceErrorHandler class.

See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
OnlyOnceErrorHandler Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler Constructor (String)

OnlyOnceErrorHandler Constructor (String) Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OnlyOnceErrorHandler(
    string prefix
)
public OnlyOnceErrorHandler(
    string prefix
)
Public Sub New (
    prefix As String
)
Public Sub New (
    prefix As String
)
public:
OnlyOnceErrorHandler(
    String^ prefix
)
public:
OnlyOnceErrorHandler(
    String^ prefix
)
Parameters
prefix
Type:   Online System String
The prefix to use for each message.
Remarks

            Initializes a new instance of the OnlyOnceErrorHandler class
            with the specified prefix.

See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
OnlyOnceErrorHandler Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler Methods

OnlyOnceErrorHandler Methods Apache log4net™ SDK Documentation
The OnlyOnceErrorHandler type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Error(String) | Log an error
Public method | Error(String, Exception) | Log an Error
Public method | Error(String, Exception, ErrorCode) | Log an Error
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FirstError | Log the very first error
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the error handler back to its initial disabled state.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
OnlyOnceErrorHandler Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler.Error Method

OnlyOnceErrorHandler Error Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Error(String) | Log an error
Public method | Error(String, Exception) | Log an Error
Public method | Error(String, Exception, ErrorCode) | Log an Error
Back to Top
See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler.Error Method (String)

OnlyOnceErrorHandler Error Method (String) Apache log4net™ SDK Documentation
Log an error

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Error(
    string message
)
public void Error(
    string message
)
Public Sub Error (
    message As String
)
Public Sub Error (
    message As String
)
public:
virtual void Error(
    String^ message
) sealed
public:
virtual void Error(
    String^ message
) sealed
Parameters
message
Type:   Online System String
The error message.
Implements
IErrorHandler Error(String)
Remarks

            Invokes FirstError(String, Exception, ErrorCode) if and only if this is the first error or the first error after Reset  has been called.

See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
Error Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler.Error Method (String, Exception)

OnlyOnceErrorHandler Error Method (String, Exception) Apache log4net™ SDK Documentation
Log an Error

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Error(
    string message,
    Exception e
)
public void Error(
    string message,
    Exception e
)
Public Sub Error (
    message As String,
    e As Exception
)
Public Sub Error (
    message As String,
    e As Exception
)
public:
virtual void Error(
    String^ message,
    Exception^ e
) sealed
public:
virtual void Error(
    String^ message,
    Exception^ e
) sealed
Parameters
message
Type:   Online System String
The error message.
e
Type:   Online System Exception
The exception.
Implements
IErrorHandler Error(String, Exception)
Remarks

            Invokes FirstError(String, Exception, ErrorCode) if and only if this is the first error or the first error after Reset  has been called.

See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
Error Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler.Error Method (String, Exception, ErrorCode)

OnlyOnceErrorHandler Error Method (String, Exception, ErrorCode) Apache log4net™ SDK Documentation
Log an Error

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Error(
    string message,
    Exception e,
    ErrorCode errorCode
)
public void Error(
    string message,
    Exception e,
    ErrorCode errorCode
)
Public Sub Error (
    message As String,
    e As Exception,
    errorCode As ErrorCode
)
Public Sub Error (
    message As String,
    e As Exception,
    errorCode As ErrorCode
)
public:
virtual void Error(
    String^ message,
    Exception^ e,
    ErrorCode errorCode
) sealed
public:
virtual void Error(
    String^ message,
    Exception^ e,
    ErrorCode errorCode
) sealed
Parameters
message
Type:   Online System String
The error message.
e
Type:   Online System Exception
The exception.
errorCode
Type: log4net.Core ErrorCode
The internal error code.
Implements
IErrorHandler Error(String, Exception, ErrorCode)
Remarks

            Invokes FirstError(String, Exception, ErrorCode) if and only if this is the first error or the first error after Reset  has been called.

See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
Error Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler.FirstError Method

OnlyOnceErrorHandler FirstError Method Apache log4net™ SDK Documentation
Log the very first error

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FirstError(
    string message,
    Exception e,
    ErrorCode errorCode
)
public virtual void FirstError(
    string message,
    Exception e,
    ErrorCode errorCode
)
Public Overridable Sub FirstError (
    message As String,
    e As Exception,
    errorCode As ErrorCode
)
Public Overridable Sub FirstError (
    message As String,
    e As Exception,
    errorCode As ErrorCode
)
public:
virtual void FirstError(
    String^ message,
    Exception^ e,
    ErrorCode errorCode
)
public:
virtual void FirstError(
    String^ message,
    Exception^ e,
    ErrorCode errorCode
)
Parameters
message
Type:   Online System String
The error message.
e
Type:   Online System Exception
The exception.
errorCode
Type: log4net.Core ErrorCode
The internal error code.
Remarks

            Sends the error information to LogLog's Error method.

See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler.Reset Method

OnlyOnceErrorHandler Reset Method Apache log4net™ SDK Documentation
Reset the error handler back to its initial disabled state.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
void Reset()
public:
void Reset()
See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler Properties

OnlyOnceErrorHandler Properties Apache log4net™ SDK Documentation
The OnlyOnceErrorHandler type exposes the following members.
Properties
 | Name | Description
Public property | EnabledDate | The date the first error that trigged this error handler occured.
Public property | ErrorCode | The error code from the first error that trigged this error handler.
Public property | ErrorMessage | The message from the first error that trigged this error handler.
Public property | Exception | The exception from the first error that trigged this error handler.
Public property | IsEnabled | Is error logging enabled
Back to Top
See Also
OnlyOnceErrorHandler Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler.EnabledDate Property

OnlyOnceErrorHandler EnabledDate Property Apache log4net™ SDK Documentation
The date the first error that trigged this error handler occured.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime EnabledDate { get; }
public DateTime EnabledDate { get; }
Public ReadOnly Property EnabledDate As DateTime
    Get
Public ReadOnly Property EnabledDate As DateTime
    Get
public:
property DateTime EnabledDate {
    DateTime get ();
}
public:
property DateTime EnabledDate {
    DateTime get ();
}
Property Value
Type:   Online DateTime
See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler.ErrorCode Property

OnlyOnceErrorHandler ErrorCode Property Apache log4net™ SDK Documentation
The error code from the first error that trigged this error handler.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErrorCode ErrorCode { get; }
public ErrorCode ErrorCode { get; }
Public ReadOnly Property ErrorCode As ErrorCode
    Get
Public ReadOnly Property ErrorCode As ErrorCode
    Get
public:
property ErrorCode ErrorCode {
    ErrorCode get ();
}
public:
property ErrorCode ErrorCode {
    ErrorCode get ();
}
Property Value
Type: ErrorCode
Remarks

            Defaults to GenericFailure
See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler.ErrorMessage Property

OnlyOnceErrorHandler ErrorMessage Property Apache log4net™ SDK Documentation
The message from the first error that trigged this error handler.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ErrorMessage { get; }
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get
Public ReadOnly Property ErrorMessage As String
    Get
public:
property String^ ErrorMessage {
    String^ get ();
}
public:
property String^ ErrorMessage {
    String^ get ();
}
Property Value
Type:   Online String
See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler.Exception Property

OnlyOnceErrorHandler Exception Property Apache log4net™ SDK Documentation
The exception from the first error that trigged this error handler.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception Exception { get; }
public Exception Exception { get; }
Public ReadOnly Property Exception As Exception
    Get
Public ReadOnly Property Exception As Exception
    Get
public:
property Exception^ Exception {
    Exception^ get ();
}
public:
property Exception^ Exception {
    Exception^ get ();
}
Property Value
Type:   Online Exception
Remarks

            May be  .

See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OnlyOnceErrorHandler.IsEnabled Property

OnlyOnceErrorHandler IsEnabled Property Apache log4net™ SDK Documentation
Is error logging enabled

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEnabled { get; }
public bool IsEnabled { get; }
Public ReadOnly Property IsEnabled As Boolean
    Get
Public ReadOnly Property IsEnabled As Boolean
    Get
public:
property bool IsEnabled {
    bool get ();
}
public:
property bool IsEnabled {
    bool get ();
}
Property Value
Type:   Online Boolean
Remarks

            Is error logging enabled. Logging is only enabled for the
            first error delivered to the OnlyOnceErrorHandler.

See Also
OnlyOnceErrorHandler Class
OnlyOnceErrorHandler Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OptionConverter Class

OptionConverter Class Apache log4net™ SDK Documentation
A convenience class to convert property values to specific types.
Inheritance Hierarchy
Online System Object
log4net.Util OptionConverter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class OptionConverter
public sealed class OptionConverter
Public NotInheritable Class OptionConverter
Public NotInheritable Class OptionConverter
public ref class OptionConverter sealed
public ref class OptionConverter sealed
Remarks

            Utility functions for converting types and parsing values.

See Also
OptionConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OptionConverter Members

OptionConverter Members Apache log4net™ SDK Documentation
The OptionConverter type exposes the following members.
Methods
 | Name | Description
 | CanConvertTypeTo | Checks if there is an appropriate type conversion from the source type to the target type.
 | ConvertStringTo | Converts a string to an object.
 | ConvertTypeTo | Converts an object to the target type.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | InstantiateByClassName | Instantiates an object given a class name.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | SubstituteVariables | Performs variable substitution in string value from the values of keys found in props.
 | ToBoolean | Converts a string to a Online Boolean value.
 | ToFileSize | Parses a file size into a number.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
OptionConverter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OptionConverter Methods

OptionConverter Methods Apache log4net™ SDK Documentation
The OptionConverter type exposes the following members.
Methods
 | Name | Description
 | CanConvertTypeTo | Checks if there is an appropriate type conversion from the source type to the target type.
 | ConvertStringTo | Converts a string to an object.
 | ConvertTypeTo | Converts an object to the target type.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | InstantiateByClassName | Instantiates an object given a class name.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | SubstituteVariables | Performs variable substitution in string value from the values of keys found in props.
 | ToBoolean | Converts a string to a Online Boolean value.
 | ToFileSize | Parses a file size into a number.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
OptionConverter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OptionConverter.CanConvertTypeTo Method

OptionConverter CanConvertTypeTo Method Apache log4net™ SDK Documentation
Checks if there is an appropriate type conversion from the source type to the target type.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool CanConvertTypeTo(
    Type sourceType,
    Type targetType
)
public static bool CanConvertTypeTo(
    Type sourceType,
    Type targetType
)
Public Shared Function CanConvertTypeTo (
    sourceType As Type,
    targetType As Type
) As Boolean
Public Shared Function CanConvertTypeTo (
    sourceType As Type,
    targetType As Type
) As Boolean
public:
static bool CanConvertTypeTo(
    Type^ sourceType,
    Type^ targetType
)
public:
static bool CanConvertTypeTo(
    Type^ sourceType,
    Type^ targetType
)
Parameters
sourceType
Type:   Online System Type
The type to convert from.
targetType
Type:   Online System Type
The type to convert to.
Return Value
Type:   Online Boolean
true if there is a conversion from the source type to the target type.
Remarks

            Checks if there is an appropriate type conversion from the source type to the target type.

See Also
OptionConverter Class
OptionConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OptionConverter.ConvertStringTo Method

OptionConverter ConvertStringTo Method Apache log4net™ SDK Documentation
Converts a string to an object.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object ConvertStringTo(
    Type target,
    string txt
)
public static Object ConvertStringTo(
    Type target,
    string txt
)
Public Shared Function ConvertStringTo (
    target As Type,
    txt As String
) As Object
Public Shared Function ConvertStringTo (
    target As Type,
    txt As String
) As Object
public:
static Object^ ConvertStringTo(
    Type^ target,
    String^ txt
)
public:
static Object^ ConvertStringTo(
    Type^ target,
    String^ txt
)
Parameters
target
Type:   Online System Type
The target type to convert to.
txt
Type:   Online System String
The string to convert to an object.
Return Value
Type:   Online Object

            The object converted from a string or null when the
            conversion failed.

Remarks

            Converts a string to an object. Uses the converter registry to try
            to convert the string value into the specified target type.

See Also
OptionConverter Class
OptionConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OptionConverter.ConvertTypeTo Method

OptionConverter ConvertTypeTo Method Apache log4net™ SDK Documentation
Converts an object to the target type.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object ConvertTypeTo(
    Object sourceInstance,
    Type targetType
)
public static Object ConvertTypeTo(
    Object sourceInstance,
    Type targetType
)
Public Shared Function ConvertTypeTo (
    sourceInstance As Object,
    targetType As Type
) As Object
Public Shared Function ConvertTypeTo (
    sourceInstance As Object,
    targetType As Type
) As Object
public:
static Object^ ConvertTypeTo(
    Object^ sourceInstance,
    Type^ targetType
)
public:
static Object^ ConvertTypeTo(
    Object^ sourceInstance,
    Type^ targetType
)
Parameters
sourceInstance
Type:   Online System Object
The object to convert to the target type.
targetType
Type:   Online System Type
The type to convert to.
Return Value
Type:   Online Object
The converted object.
Remarks

            Converts an object to the target type.

See Also
OptionConverter Class
OptionConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OptionConverter.InstantiateByClassName Method

OptionConverter InstantiateByClassName Method Apache log4net™ SDK Documentation
Instantiates an object given a class name.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object InstantiateByClassName(
    string className,
    Type superClass,
    Object defaultValue
)
public static Object InstantiateByClassName(
    string className,
    Type superClass,
    Object defaultValue
)
Public Shared Function InstantiateByClassName (
    className As String,
    superClass As Type,
    defaultValue As Object
) As Object
Public Shared Function InstantiateByClassName (
    className As String,
    superClass As Type,
    defaultValue As Object
) As Object
public:
static Object^ InstantiateByClassName(
    String^ className,
    Type^ superClass,
    Object^ defaultValue
)
public:
static Object^ InstantiateByClassName(
    String^ className,
    Type^ superClass,
    Object^ defaultValue
)
Parameters
className
Type:   Online System String
The fully qualified class name of the object to instantiate.
superClass
Type:   Online System Type
The class to which the new object should belong.
defaultValue
Type:   Online System Object
The object to return in case of non-fulfillment.
Return Value
Type:   Online Object

            An instance of the className or defaultValue
            if the object could not be instantiated.

Remarks

            Checks that the className is a subclass of
            superClass. If that test fails or the object could
            not be instantiated, then defaultValue is returned.

See Also
OptionConverter Class
OptionConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OptionConverter.SubstituteVariables Method

OptionConverter SubstituteVariables Method Apache log4net™ SDK Documentation
Performs variable substitution in string value from the values of keys found in props.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string SubstituteVariables(
    string value,
    IDictionary props
)
public static string SubstituteVariables(
    string value,
    IDictionary props
)
Public Shared Function SubstituteVariables (
    value As String,
    props As IDictionary
) As String
Public Shared Function SubstituteVariables (
    value As String,
    props As IDictionary
) As String
public:
static String^ SubstituteVariables(
    String^ value,
    IDictionary^ props
)
public:
static String^ SubstituteVariables(
    String^ value,
    IDictionary^ props
)
Parameters
value
Type:   Online System String
The string on which variable substitution is performed.
props
Type:   Online System.Collections IDictionary
The dictionary to use to lookup variables.
Return Value
Type:   Online String
The result of the substitutions.
Remarks

            The variable substitution delimiters are ${ and }.

            For example, if props contains key=value, then the call

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string s = OptionConverter.SubstituteVariables("Value of key is ${key}.");
string s = OptionConverter.SubstituteVariables("Value of key is ${key}.");

            will set the variable s to "Value of key is value.".

            If no value could be found for the specified key, then substitution
            defaults to an empty string.

            For example, if system properties contains no value for the key
            "nonExistentKey", then the call

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string s = OptionConverter.SubstituteVariables("Value of nonExistentKey is [${nonExistentKey}]");
string s = OptionConverter.SubstituteVariables("Value of nonExistentKey is [${nonExistentKey}]");

            will set s to "Value of nonExistentKey is []".

            An Exception is thrown if value contains a start
            delimiter "${" which is not balanced by a stop delimiter "}".

See Also
OptionConverter Class
OptionConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OptionConverter.ToBoolean Method

OptionConverter ToBoolean Method Apache log4net™ SDK Documentation
Converts a string to a Online Boolean value.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool ToBoolean(
    string argValue,
    bool defaultValue
)
public static bool ToBoolean(
    string argValue,
    bool defaultValue
)
Public Shared Function ToBoolean (
    argValue As String,
    defaultValue As Boolean
) As Boolean
Public Shared Function ToBoolean (
    argValue As String,
    defaultValue As Boolean
) As Boolean
public:
static bool ToBoolean(
    String^ argValue,
    bool defaultValue
)
public:
static bool ToBoolean(
    String^ argValue,
    bool defaultValue
)
Parameters
argValue
Type:   Online System String
String to convert.
defaultValue
Type:   Online System Boolean
The default value.
Return Value
Type:   Online Boolean
The   Online Boolean value of argValue.
Remarks

            If argValue is "true", then true is returned.
            If argValue is "false", then false is returned.
            Otherwise, defaultValue is returned.

See Also
OptionConverter Class
OptionConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


OptionConverter.ToFileSize Method

OptionConverter ToFileSize Method Apache log4net™ SDK Documentation
Parses a file size into a number.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ToFileSize(
    string argValue,
    long defaultValue
)
public static long ToFileSize(
    string argValue,
    long defaultValue
)
Public Shared Function ToFileSize (
    argValue As String,
    defaultValue As Long
) As Long
Public Shared Function ToFileSize (
    argValue As String,
    defaultValue As Long
) As Long
public:
static long long ToFileSize(
    String^ argValue,
    long long defaultValue
)
public:
static long long ToFileSize(
    String^ argValue,
    long long defaultValue
)
Parameters
argValue
Type:   Online System String
String to parse.
defaultValue
Type:   Online System Int64
The default value.
Return Value
Type:   Online Int64
The   Online Int64 value of argValue.
Remarks

            Parses a file size of the form: number[KB|MB|GB] into a
            long value. It is scaled with the appropriate multiplier.

defaultValue is returned when argValue
            cannot be converted to a   Online Int64 value.

See Also
OptionConverter Class
OptionConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter Class

PatternConverter Class Apache log4net™ SDK Documentation
Abstract class that provides the formatting functionality that derived classes need.
Inheritance Hierarchy
Online System Object
log4net.Util PatternConverter
log4net.Layout.Pattern PatternLayoutConverter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PatternConverter
public abstract class PatternConverter
Public MustInherit Class PatternConverter
Public MustInherit Class PatternConverter
public ref class PatternConverter abstract
public ref class PatternConverter abstract
Remarks

            Conversion specifiers in a conversion patterns are parsed to
            individual PatternConverters. Each of which is responsible for
            converting a logging event in a converter specific manner.

See Also
PatternConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter Members

PatternConverter Members Apache log4net™ SDK Documentation
The PatternConverter type exposes the following members.
Constructors
 | Name | Description
Protected method | PatternConverter | Protected constructor
Back to Top
Methods
 | Name | Description
Protected method | Convert | Evaluate this pattern converter and write the output to a writer.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Write the pattern converter to the writer with appropriate formatting
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetNext | Set the next pattern converter in the chains
 | SpacePad | Fast space padding method.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | WriteDictionary(TextWriter, ILoggerRepository, IDictionary) | Write an dictionary to a Online TextWriter
 | WriteDictionary(TextWriter, ILoggerRepository, IDictionaryEnumerator) | Write an dictionary to a Online TextWriter
 | WriteObject | Write an object to a Online TextWriter
Back to Top
Properties
 | Name | Description
Public property | FormattingInfo | Gets or sets the formatting info for this converter
Public property | Next | Get the next pattern converter in the chain
Public property | Option | Gets or sets the option value for this converter
Public property | Properties |
Back to Top
See Also
PatternConverter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter Constructor

PatternConverter Constructor Apache log4net™ SDK Documentation
Protected constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PatternConverter()
protected PatternConverter()
Protected Sub New
Protected Sub New
protected:
PatternConverter()
protected:
PatternConverter()
Remarks

            Initializes a new instance of the PatternConverter class.

See Also
PatternConverter Class
PatternConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter Methods

PatternConverter Methods Apache log4net™ SDK Documentation
The PatternConverter type exposes the following members.
Methods
 | Name | Description
Protected method | Convert | Evaluate this pattern converter and write the output to a writer.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Write the pattern converter to the writer with appropriate formatting
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetNext | Set the next pattern converter in the chains
 | SpacePad | Fast space padding method.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | WriteDictionary(TextWriter, ILoggerRepository, IDictionary) | Write an dictionary to a Online TextWriter
 | WriteDictionary(TextWriter, ILoggerRepository, IDictionaryEnumerator) | Write an dictionary to a Online TextWriter
 | WriteObject | Write an object to a Online TextWriter
Back to Top
See Also
PatternConverter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter.Convert Method

PatternConverter Convert Method Apache log4net™ SDK Documentation
Evaluate this pattern converter and write the output to a writer.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Convert(
    TextWriter writer,
    Object state
)
protected abstract void Convert(
    TextWriter writer,
    Object state
)
Protected MustOverride Sub Convert (
    writer As TextWriter,
    state As Object
)
Protected MustOverride Sub Convert (
    writer As TextWriter,
    state As Object
)
protected:
virtual void Convert(
    TextWriter^ writer,
    Object^ state
) abstract
protected:
virtual void Convert(
    TextWriter^ writer,
    Object^ state
) abstract
Parameters
writer
Type:   Online System.IO TextWriter
  Online TextWriter that will receive the formatted result.
state
Type:   Online System Object
The state object on which the pattern converter should be executed.
Remarks

            Derived pattern converters must override this method in order to
            convert conversion specifiers in the appropriate way.

See Also
PatternConverter Class
PatternConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter.Format Method

PatternConverter Format Method Apache log4net™ SDK Documentation
Write the pattern converter to the writer with appropriate formatting

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Format(
    TextWriter writer,
    Object state
)
public virtual void Format(
    TextWriter writer,
    Object state
)
Public Overridable Sub Format (
    writer As TextWriter,
    state As Object
)
Public Overridable Sub Format (
    writer As TextWriter,
    state As Object
)
public:
virtual void Format(
    TextWriter^ writer,
    Object^ state
)
public:
virtual void Format(
    TextWriter^ writer,
    Object^ state
)
Parameters
writer
Type:   Online System.IO TextWriter
  Online TextWriter that will receive the formatted result.
state
Type:   Online System Object
The state object on which the pattern converter should be executed.
Remarks

            This method calls Convert(TextWriter, Object) to allow the subclass to perform
            appropriate conversion of the pattern converter. If formatting options have
            been specified via the FormattingInfo then this method will
            apply those formattings before writing the output.

See Also
PatternConverter Class
PatternConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter.SetNext Method

PatternConverter SetNext Method Apache log4net™ SDK Documentation
Set the next pattern converter in the chains

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual PatternConverter SetNext(
    PatternConverter patternConverter
)
public virtual PatternConverter SetNext(
    PatternConverter patternConverter
)
Public Overridable Function SetNext (
    patternConverter As PatternConverter
) As PatternConverter
Public Overridable Function SetNext (
    patternConverter As PatternConverter
) As PatternConverter
public:
virtual PatternConverter^ SetNext(
    PatternConverter^ patternConverter
)
public:
virtual PatternConverter^ SetNext(
    PatternConverter^ patternConverter
)
Parameters
patternConverter
Type: log4net.Util PatternConverter
the pattern converter that should follow this converter in the chain
Return Value
Type: PatternConverter
the next converter
Remarks

            The PatternConverter can merge with its neighbor during this method (or a sub class).
            Therefore the return value may or may not be the value of the argument passed in.

See Also
PatternConverter Class
PatternConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter.SpacePad Method

PatternConverter SpacePad Method Apache log4net™ SDK Documentation
Fast space padding method.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static void SpacePad(
    TextWriter writer,
    int length
)
protected static void SpacePad(
    TextWriter writer,
    int length
)
Protected Shared Sub SpacePad (
    writer As TextWriter,
    length As Integer
)
Protected Shared Sub SpacePad (
    writer As TextWriter,
    length As Integer
)
protected:
static void SpacePad(
    TextWriter^ writer,
    int length
)
protected:
static void SpacePad(
    TextWriter^ writer,
    int length
)
Parameters
writer
Type:   Online System.IO TextWriter
  Online TextWriter to which the spaces will be appended.
length
Type:   Online System Int32
The number of spaces to be padded.
Remarks

            Fast space padding method.

See Also
PatternConverter Class
PatternConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter.WriteDictionary Method

PatternConverter WriteDictionary Method Apache log4net™ SDK Documentation
Overload List
Name | Description
WriteDictionary(TextWriter, ILoggerRepository, IDictionary) | Write an dictionary to a Online TextWriter
WriteDictionary(TextWriter, ILoggerRepository, IDictionaryEnumerator) | Write an dictionary to a Online TextWriter
Back to Top
See Also
PatternConverter Class
PatternConverter Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter.WriteDictionary Method (TextWriter, ILoggerRepository, IDictionary)

PatternConverter WriteDictionary Method (TextWriter, ILoggerRepository, IDictionary) Apache log4net™ SDK Documentation
Write an dictionary to a Online TextWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static void WriteDictionary(
    TextWriter writer,
    ILoggerRepository repository,
    IDictionary value
)
protected static void WriteDictionary(
    TextWriter writer,
    ILoggerRepository repository,
    IDictionary value
)
Protected Shared Sub WriteDictionary (
    writer As TextWriter,
    repository As ILoggerRepository,
    value As IDictionary
)
Protected Shared Sub WriteDictionary (
    writer As TextWriter,
    repository As ILoggerRepository,
    value As IDictionary
)
protected:
static void WriteDictionary(
    TextWriter^ writer,
    ILoggerRepository^ repository,
    IDictionary^ value
)
protected:
static void WriteDictionary(
    TextWriter^ writer,
    ILoggerRepository^ repository,
    IDictionary^ value
)
Parameters
writer
Type:   Online System.IO TextWriter
the writer to write to
repository
Type: log4net.Repository ILoggerRepository
a ILoggerRepository to use for object conversion
value
Type:   Online System.Collections IDictionary
the value to write to the writer
Remarks

            Writes the   Online IDictionary to a writer in the form:

View Colorized Copy to Clipboard Print
{key1=value1, key2=value2, key3=value3}
{key1=value1, key2=value2, key3=value3}

            If the ILoggerRepository specified
            is not null then it is used to render the key and value to text, otherwise
            the object's ToString method is called.

See Also
PatternConverter Class
PatternConverter Members
WriteDictionary Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter.WriteDictionary Method (TextWriter, ILoggerRepository, IDictionaryEnumerator)

PatternConverter WriteDictionary Method (TextWriter, ILoggerRepository, IDictionaryEnumerator) Apache log4net™ SDK Documentation
Write an dictionary to a Online TextWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static void WriteDictionary(
    TextWriter writer,
    ILoggerRepository repository,
    IDictionaryEnumerator value
)
protected static void WriteDictionary(
    TextWriter writer,
    ILoggerRepository repository,
    IDictionaryEnumerator value
)
Protected Shared Sub WriteDictionary (
    writer As TextWriter,
    repository As ILoggerRepository,
    value As IDictionaryEnumerator
)
Protected Shared Sub WriteDictionary (
    writer As TextWriter,
    repository As ILoggerRepository,
    value As IDictionaryEnumerator
)
protected:
static void WriteDictionary(
    TextWriter^ writer,
    ILoggerRepository^ repository,
    IDictionaryEnumerator^ value
)
protected:
static void WriteDictionary(
    TextWriter^ writer,
    ILoggerRepository^ repository,
    IDictionaryEnumerator^ value
)
Parameters
writer
Type:   Online System.IO TextWriter
the writer to write to
repository
Type: log4net.Repository ILoggerRepository
a ILoggerRepository to use for object conversion
value
Type:   Online System.Collections IDictionaryEnumerator
the value to write to the writer
Remarks

            Writes the   Online IDictionaryEnumerator to a writer in the form:

View Colorized Copy to Clipboard Print
{key1=value1, key2=value2, key3=value3}
{key1=value1, key2=value2, key3=value3}

            If the ILoggerRepository specified
            is not null then it is used to render the key and value to text, otherwise
            the object's ToString method is called.

See Also
PatternConverter Class
PatternConverter Members
WriteDictionary Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter.WriteObject Method

PatternConverter WriteObject Method Apache log4net™ SDK Documentation
Write an object to a Online TextWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static void WriteObject(
    TextWriter writer,
    ILoggerRepository repository,
    Object value
)
protected static void WriteObject(
    TextWriter writer,
    ILoggerRepository repository,
    Object value
)
Protected Shared Sub WriteObject (
    writer As TextWriter,
    repository As ILoggerRepository,
    value As Object
)
Protected Shared Sub WriteObject (
    writer As TextWriter,
    repository As ILoggerRepository,
    value As Object
)
protected:
static void WriteObject(
    TextWriter^ writer,
    ILoggerRepository^ repository,
    Object^ value
)
protected:
static void WriteObject(
    TextWriter^ writer,
    ILoggerRepository^ repository,
    Object^ value
)
Parameters
writer
Type:   Online System.IO TextWriter
the writer to write to
repository
Type: log4net.Repository ILoggerRepository
a ILoggerRepository to use for object conversion
value
Type:   Online System Object
the value to write to the writer
Remarks

            Writes the Object to a writer. If the ILoggerRepository specified
            is not null then it is used to render the object to text, otherwise
            the object's ToString method is called.

See Also
PatternConverter Class
PatternConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter Properties

PatternConverter Properties Apache log4net™ SDK Documentation
The PatternConverter type exposes the following members.
Properties
 | Name | Description
Public property | FormattingInfo | Gets or sets the formatting info for this converter
Public property | Next | Get the next pattern converter in the chain
Public property | Option | Gets or sets the option value for this converter
Public property | Properties |
Back to Top
See Also
PatternConverter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter.FormattingInfo Property

PatternConverter FormattingInfo Property Apache log4net™ SDK Documentation
Gets or sets the formatting info for this converter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual FormattingInfo FormattingInfo { get; set; }
public virtual FormattingInfo FormattingInfo { get; set; }
Public Overridable Property FormattingInfo As FormattingInfo
    Get
    Set
Public Overridable Property FormattingInfo As FormattingInfo
    Get
    Set
public:
virtual property FormattingInfo^ FormattingInfo {
    FormattingInfo^ get ();
    void set (FormattingInfo^ value);
}
public:
virtual property FormattingInfo^ FormattingInfo {
    FormattingInfo^ get ();
    void set (FormattingInfo^ value);
}
Property Value
Type: FormattingInfo

            The formatting info for this converter

Remarks

            Gets or sets the formatting info for this converter

See Also
PatternConverter Class
PatternConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter.Next Property

PatternConverter Next Property Apache log4net™ SDK Documentation
Get the next pattern converter in the chain

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual PatternConverter Next { get; }
public virtual PatternConverter Next { get; }
Public Overridable ReadOnly Property Next As PatternConverter
    Get
Public Overridable ReadOnly Property Next As PatternConverter
    Get
public:
virtual property PatternConverter^ Next {
    PatternConverter^ get ();
}
public:
virtual property PatternConverter^ Next {
    PatternConverter^ get ();
}
Property Value
Type: PatternConverter

            the next pattern converter in the chain

Remarks

            Get the next pattern converter in the chain

See Also
PatternConverter Class
PatternConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter.Option Property

PatternConverter Option Property Apache log4net™ SDK Documentation
Gets or sets the option value for this converter
The option for this converter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Option { get; set; }
public virtual string Option { get; set; }
Public Overridable Property Option As String
    Get
    Set
Public Overridable Property Option As String
    Get
    Set
public:
virtual property String^ Option {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Option {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            Gets or sets the option value for this converter

See Also
PatternConverter Class
PatternConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternConverter.Properties Property

PatternConverter Properties Property Apache log4net™ SDK Documentation

[Missing <summary> documentation for "P:log4net.Util.PatternConverter.Properties"]

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PropertiesDictionary Properties { get; set; }
public PropertiesDictionary Properties { get; set; }
Public Property Properties As PropertiesDictionary
    Get
    Set
Public Property Properties As PropertiesDictionary
    Get
    Set
public:
property PropertiesDictionary^ Properties {
    PropertiesDictionary^ get ();
    void set (PropertiesDictionary^ value);
}
public:
property PropertiesDictionary^ Properties {
    PropertiesDictionary^ get ();
    void set (PropertiesDictionary^ value);
}
Property Value
Type: PropertiesDictionary
See Also
PatternConverter Class
PatternConverter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternParser Class

PatternParser Class Apache log4net™ SDK Documentation
Most of the work of the PatternLayout class is delegated to the PatternParser class.
Inheritance Hierarchy
Online System Object
log4net.Util PatternParser

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class PatternParser
public sealed class PatternParser
Public NotInheritable Class PatternParser
Public NotInheritable Class PatternParser
public ref class PatternParser sealed
public ref class PatternParser sealed
Remarks

            The PatternParser processes a pattern string and
            returns a chain of PatternConverter objects.

See Also
PatternParser Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternParser Members

PatternParser Members Apache log4net™ SDK Documentation
The PatternParser type exposes the following members.
Constructors
 | Name | Description
Public method | PatternParser | Constructor
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Parse | Parses the pattern into a chain of pattern converters.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | PatternConverters | Get the converter registry used by this parser
Back to Top
See Also
PatternParser Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternParser Constructor

PatternParser Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PatternParser(
    string pattern
)
public PatternParser(
    string pattern
)
Public Sub New (
    pattern As String
)
Public Sub New (
    pattern As String
)
public:
PatternParser(
    String^ pattern
)
public:
PatternParser(
    String^ pattern
)
Parameters
pattern
Type:   Online System String
The pattern to parse.
Remarks

            Initializes a new instance of the PatternParser class
            with the specified pattern string.

See Also
PatternParser Class
PatternParser Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternParser Methods

PatternParser Methods Apache log4net™ SDK Documentation
The PatternParser type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Parse | Parses the pattern into a chain of pattern converters.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PatternParser Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternParser.Parse Method

PatternParser Parse Method Apache log4net™ SDK Documentation
Parses the pattern into a chain of pattern converters.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PatternConverter Parse()
public PatternConverter Parse()
Public Function Parse As PatternConverter
Public Function Parse As PatternConverter
public:
PatternConverter^ Parse()
public:
PatternConverter^ Parse()
Return Value
Type: PatternConverter
The head of a chain of pattern converters.
Remarks

            Parses the pattern into a chain of pattern converters.

See Also
PatternParser Class
PatternParser Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternParser Properties

PatternParser Properties Apache log4net™ SDK Documentation
The PatternParser type exposes the following members.
Properties
 | Name | Description
Public property | PatternConverters | Get the converter registry used by this parser
Back to Top
See Also
PatternParser Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternParser.PatternConverters Property

PatternParser PatternConverters Property Apache log4net™ SDK Documentation
Get the converter registry used by this parser

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Hashtable PatternConverters { get; }
public Hashtable PatternConverters { get; }
Public ReadOnly Property PatternConverters As Hashtable
    Get
Public ReadOnly Property PatternConverters As Hashtable
    Get
public:
property Hashtable^ PatternConverters {
    Hashtable^ get ();
}
public:
property Hashtable^ PatternConverters {
    Hashtable^ get ();
}
Property Value
Type:   Online Hashtable

            The converter registry used by this parser

Remarks

            Get the converter registry used by this parser

See Also
PatternParser Class
PatternParser Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString Class

PatternString Class Apache log4net™ SDK Documentation
This class implements a patterned string.
Inheritance Hierarchy
Online System Object
log4net.Util PatternString

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PatternString : IOptionHandler
public class PatternString : IOptionHandler
Public Class PatternString
    Implements IOptionHandler
Public Class PatternString
    Implements IOptionHandler
public ref class PatternString : IOptionHandler
public ref class PatternString : IOptionHandler
Remarks

            This string has embedded patterns that are resolved and expanded
            when the string is formatted.

            This class functions similarly to the PatternLayout
            in that it accepts a pattern and renders it to a string. Unlike the
            PatternLayout however the PatternString
            does not render the properties of a specific LoggingEvent but
            of the process in general.

            The recognized conversion pattern names are:

Conversion Pattern Name  | Effect
appdomain  |
                        Used to output the friendly name of the current AppDomain.

date
                        Used to output the current date and time in the local time zone.
                        To output the date in universal time use the %utcdate pattern.
                        The date conversion
                        specifier may be followed by a date format specifier enclosed
                        between braces. For example, %date{HH:mm:ss,fff} or
                        %date{dd MMM yyyy HH:mm:ss,fff}.  If no date format specifier is
                        given then ISO8601 format is
                        assumed (Iso8601DateFormatter).

                        The date format specifier admits the same syntax as the
                        time pattern string of the ToString(string).

                        For better results it is recommended to use the log4net date
                        formatters. These can be specified using one of the strings
                        "ABSOLUTE", "DATE" and "ISO8601" for specifying
                        AbsoluteTimeDateFormatter,
                        DateTimeDateFormatter and respectively
                        Iso8601DateFormatter. For example,
                        %date{ISO8601} or %date{ABSOLUTE}.

                        These dedicated date formatters perform significantly
                        better than ToString(string).

env
                        Used to output the a specific environment variable. The key to
                        lookup must be specified within braces and directly following the
                        pattern specifier, e.g. %env{COMPUTERNAME} would include the value
                        of the COMPUTERNAME environment variable.

                        The env pattern is not supported on the .NET Compact Framework.

identity  |
                        Used to output the user name for the currently active user
                        (Principal.Identity.Name).

newline
                        Outputs the platform dependent line separator character or
                        characters.

                        This conversion pattern name offers the same performance as using
                        non-portable line separator strings such as	"\n", or "\r\n".
                        Thus, it is the preferred way of specifying a line separator.

processid  |
                        Used to output the system process ID for the current process.

property
                        Used to output a specific context property. The key to
                        lookup must be specified within braces and directly following the
                        pattern specifier, e.g. %property{user} would include the value
                        from the property that is keyed by the string 'user'. Each property value
                        that is to be included in the log must be specified separately.
                        Properties are stored in logging contexts. By default
                        the log4net:HostName property is set to the name of machine on
                        which the event was originally logged.

                        If no key is specified, e.g. %property then all the keys and their
                        values are printed in a comma separated list.

                        The properties of an event are combined from a number of different
                        contexts. These are listed below in the order in which they are searched.

the thread properties

                                The Properties that are set on the current
                                thread. These properties are shared by all events logged on this thread.

the global properties

                                The Properties that are set globally. These
                                properties are shared by all the threads in the AppDomain.

random  |
                        Used to output a random string of characters. The string is made up of
                        uppercase letters and numbers. By default the string is 4 characters long.
                        The length of the string can be specified within braces directly following the
                        pattern specifier, e.g. %random{8} would output an 8 character string.

username  |
                        Used to output the WindowsIdentity for the currently
                        active user.

utcdate
                        Used to output the date of the logging event in universal time.
                        The date conversion
                        specifier may be followed by a date format specifier enclosed
                        between braces. For example, %utcdate{HH:mm:ss,fff} or
                        %utcdate{dd MMM yyyy HH:mm:ss,fff}.  If no date format specifier is
                        given then ISO8601 format is
                        assumed (Iso8601DateFormatter).

                        The date format specifier admits the same syntax as the
                        time pattern string of the ToString(string).

                        For better results it is recommended to use the log4net date
                        formatters. These can be specified using one of the strings
                        "ABSOLUTE", "DATE" and "ISO8601" for specifying
                        AbsoluteTimeDateFormatter,
                        DateTimeDateFormatter and respectively
                        Iso8601DateFormatter. For example,
                        %utcdate{ISO8601} or %utcdate{ABSOLUTE}.

                        These dedicated date formatters perform significantly
                        better than ToString(string).

%
                        The sequence %% outputs a single percent sign.

            Additional pattern converters may be registered with a specific PatternString
            instance using [M:AddConverter(ConverterInfo)] or
            [M:AddConverter(string, Type)].

            See the PatternLayout for details on the
            format modifiers supported by the patterns.

See Also
PatternString Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString Members

PatternString Members Apache log4net™ SDK Documentation
The PatternString type exposes the following members.
Constructors
 | Name | Description
Public method | PatternString | Default constructor
Public method | PatternString(String) | Constructs a PatternString
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize object options
Public method | AddConverter(ConverterInfo) | Add a converter to this PatternString
Public method | AddConverter(String, Type) | Add a converter to this PatternString
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Format the pattern as a string
Public method | Format(TextWriter) | Produces a formatted string as specified by the conversion pattern.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ConversionPattern | Gets or sets the pattern formatting string
Back to Top
See Also
PatternString Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString Constructor

PatternString Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | PatternString | Default constructor
Public method | PatternString(String) | Constructs a PatternString
Back to Top
See Also
PatternString Class
PatternString Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString Constructor

PatternString Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PatternString()
public PatternString()
Public Sub New
Public Sub New
public:
PatternString()
public:
PatternString()
Remarks

            Initialize a new instance of PatternString
See Also
PatternString Class
PatternString Members
PatternString Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString Constructor (String)

PatternString Constructor (String) Apache log4net™ SDK Documentation
Constructs a PatternString

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PatternString(
    string pattern
)
public PatternString(
    string pattern
)
Public Sub New (
    pattern As String
)
Public Sub New (
    pattern As String
)
public:
PatternString(
    String^ pattern
)
public:
PatternString(
    String^ pattern
)
Parameters
pattern
Type:   Online System String
The pattern to use with this PatternString
Remarks

            Initialize a new instance of PatternString with the pattern specified.

See Also
PatternString Class
PatternString Members
PatternString Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString Methods

PatternString Methods Apache log4net™ SDK Documentation
The PatternString type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize object options
Public method | AddConverter(ConverterInfo) | Add a converter to this PatternString
Public method | AddConverter(String, Type) | Add a converter to this PatternString
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Format | Format the pattern as a string
Public method | Format(TextWriter) | Produces a formatted string as specified by the conversion pattern.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PatternString Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString.ActivateOptions Method

PatternString ActivateOptions Method Apache log4net™ SDK Documentation
Initialize object options

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ActivateOptions()
public virtual void ActivateOptions()
Public Overridable Sub ActivateOptions
Public Overridable Sub ActivateOptions
public:
virtual void ActivateOptions()
public:
virtual void ActivateOptions()
Implements
IOptionHandler ActivateOptions
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

See Also
PatternString Class
PatternString Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString.AddConverter Method

PatternString AddConverter Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | AddConverter(ConverterInfo) | Add a converter to this PatternString
Public method | AddConverter(String, Type) | Add a converter to this PatternString
Back to Top
See Also
PatternString Class
PatternString Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString.AddConverter Method (ConverterInfo)

PatternString AddConverter Method (ConverterInfo) Apache log4net™ SDK Documentation
Add a converter to this PatternString

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddConverter(
    ConverterInfo converterInfo
)
public void AddConverter(
    ConverterInfo converterInfo
)
Public Sub AddConverter (
    converterInfo As ConverterInfo
)
Public Sub AddConverter (
    converterInfo As ConverterInfo
)
public:
void AddConverter(
    ConverterInfo^ converterInfo
)
public:
void AddConverter(
    ConverterInfo^ converterInfo
)
Parameters
converterInfo
Type: log4net.Util ConverterInfo
the converter info
Remarks

            This version of the method is used by the configurator.
            Programmatic users should use the alternative [M:AddConverter(string,Type)] method.

See Also
PatternString Class
PatternString Members
AddConverter Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString.AddConverter Method (String, Type)

PatternString AddConverter Method (String, Type) Apache log4net™ SDK Documentation
Add a converter to this PatternString

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddConverter(
    string name,
    Type type
)
public void AddConverter(
    string name,
    Type type
)
Public Sub AddConverter (
    name As String,
    type As Type
)
Public Sub AddConverter (
    name As String,
    type As Type
)
public:
void AddConverter(
    String^ name,
    Type^ type
)
public:
void AddConverter(
    String^ name,
    Type^ type
)
Parameters
name
Type:   Online System String
the name of the conversion pattern for this converter
type
Type:   Online System Type
the type of the converter
Remarks

            Add a converter to this PatternString

See Also
PatternString Class
PatternString Members
AddConverter Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString.Format Method

PatternString Format Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Format | Format the pattern as a string
Public method | Format(TextWriter) | Produces a formatted string as specified by the conversion pattern.
Back to Top
See Also
PatternString Class
PatternString Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString.Format Method

PatternString Format Method Apache log4net™ SDK Documentation
Format the pattern as a string

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Format()
public string Format()
Public Function Format As String
Public Function Format As String
public:
String^ Format()
public:
String^ Format()
Return Value
Type:   Online String
the pattern formatted as a string
Remarks

            Format the pattern to a string.

See Also
PatternString Class
PatternString Members
Format Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString.Format Method (TextWriter)

PatternString Format Method (TextWriter) Apache log4net™ SDK Documentation
Produces a formatted string as specified by the conversion pattern.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Format(
    TextWriter writer
)
public void Format(
    TextWriter writer
)
Public Sub Format (
    writer As TextWriter
)
Public Sub Format (
    writer As TextWriter
)
public:
void Format(
    TextWriter^ writer
)
public:
void Format(
    TextWriter^ writer
)
Parameters
writer
Type:   Online System.IO TextWriter
The TextWriter to write the formatted event to
Remarks

            Format the pattern to the writer.

See Also
PatternString Class
PatternString Members
Format Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString Properties

PatternString Properties Apache log4net™ SDK Documentation
The PatternString type exposes the following members.
Properties
 | Name | Description
Public property | ConversionPattern | Gets or sets the pattern formatting string
Back to Top
See Also
PatternString Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PatternString.ConversionPattern Property

PatternString ConversionPattern Property Apache log4net™ SDK Documentation
Gets or sets the pattern formatting string

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ConversionPattern { get; set; }
public string ConversionPattern { get; set; }
Public Property ConversionPattern As String
    Get
    Set
Public Property ConversionPattern As String
    Get
    Set
public:
property String^ ConversionPattern {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ConversionPattern {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The pattern formatting string

Remarks

            The ConversionPattern option. This is the string which
            controls formatting and consists of a mix of literal content and
            conversion specifiers.

See Also
PatternString Class
PatternString Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertiesDictionary Class

PropertiesDictionary Class Apache log4net™ SDK Documentation
String keyed object map.
Inheritance Hierarchy
Online System Object
log4net.Util ReadOnlyPropertiesDictionary
log4net.Util PropertiesDictionary

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class PropertiesDictionary : ReadOnlyPropertiesDictionary,
    ISerializable, IDictionary, ICollection, IEnumerable
[SerializableAttribute]
public sealed class PropertiesDictionary : ReadOnlyPropertiesDictionary,
    ISerializable, IDictionary, ICollection, IEnumerable
<SerializableAttribute>
Public NotInheritable Class PropertiesDictionary
    Inherits ReadOnlyPropertiesDictionary
    Implements ISerializable, IDictionary, ICollection, IEnumerable
<SerializableAttribute>
Public NotInheritable Class PropertiesDictionary
    Inherits ReadOnlyPropertiesDictionary
    Implements ISerializable, IDictionary, ICollection, IEnumerable
[SerializableAttribute]
public ref class PropertiesDictionary sealed : public ReadOnlyPropertiesDictionary,
    ISerializable, IDictionary, ICollection, IEnumerable
[SerializableAttribute]
public ref class PropertiesDictionary sealed : public ReadOnlyPropertiesDictionary,
    ISerializable, IDictionary, ICollection, IEnumerable
Remarks

            While this collection is serializable only member
            objects that are serializable will
            be serialized along with this collection.

See Also
PropertiesDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertiesDictionary Members

PropertiesDictionary Members Apache log4net™ SDK Documentation
The PropertiesDictionary type exposes the following members.
Constructors
 | Name | Description
Public method | PropertiesDictionary | Constructor
Public method | PropertiesDictionary(ReadOnlyPropertiesDictionary) | Constructor
Back to Top
Methods
 | Name | Description
Public method | Clear | Remove all properties from the properties collection (Overrides ReadOnlyPropertiesDictionary Clear .)
Public method | Contains | Test if the dictionary contains a specified key (Inherited from ReadOnlyPropertiesDictionary.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetKeys | Gets the key names. (Inherited from ReadOnlyPropertiesDictionary.)
Public method | GetObjectData | Serializes this object into the Online SerializationInfo provided. (Inherited from ReadOnlyPropertiesDictionary.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Remove the entry with the specified key from this dictionary
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Count | The number of properties in this collection (Inherited from ReadOnlyPropertiesDictionary.)
Protected property | InnerHashtable | The hashtable used to store the properties (Inherited from ReadOnlyPropertiesDictionary.)
Public property | Item | Gets or sets the value of the property with the specified key. (Overrides ReadOnlyPropertiesDictionary Item String .)
Back to Top
See Also
PropertiesDictionary Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertiesDictionary Constructor

PropertiesDictionary Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | PropertiesDictionary | Constructor
Public method | PropertiesDictionary(ReadOnlyPropertiesDictionary) | Constructor
Back to Top
See Also
PropertiesDictionary Class
PropertiesDictionary Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertiesDictionary Constructor

PropertiesDictionary Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PropertiesDictionary()
public PropertiesDictionary()
Public Sub New
Public Sub New
public:
PropertiesDictionary()
public:
PropertiesDictionary()
Remarks

            Initializes a new instance of the PropertiesDictionary class.

See Also
PropertiesDictionary Class
PropertiesDictionary Members
PropertiesDictionary Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertiesDictionary Constructor (ReadOnlyPropertiesDictionary)

PropertiesDictionary Constructor (ReadOnlyPropertiesDictionary) Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PropertiesDictionary(
    ReadOnlyPropertiesDictionary propertiesDictionary
)
public PropertiesDictionary(
    ReadOnlyPropertiesDictionary propertiesDictionary
)
Public Sub New (
    propertiesDictionary As ReadOnlyPropertiesDictionary
)
Public Sub New (
    propertiesDictionary As ReadOnlyPropertiesDictionary
)
public:
PropertiesDictionary(
    ReadOnlyPropertiesDictionary^ propertiesDictionary
)
public:
PropertiesDictionary(
    ReadOnlyPropertiesDictionary^ propertiesDictionary
)
Parameters
propertiesDictionary
Type: log4net.Util ReadOnlyPropertiesDictionary
properties to copy
Remarks

            Initializes a new instance of the PropertiesDictionary class.

See Also
PropertiesDictionary Class
PropertiesDictionary Members
PropertiesDictionary Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertiesDictionary Methods

PropertiesDictionary Methods Apache log4net™ SDK Documentation
The PropertiesDictionary type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Remove all properties from the properties collection (Overrides ReadOnlyPropertiesDictionary Clear .)
Public method | Contains | Test if the dictionary contains a specified key (Inherited from ReadOnlyPropertiesDictionary.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetKeys | Gets the key names. (Inherited from ReadOnlyPropertiesDictionary.)
Public method | GetObjectData | Serializes this object into the Online SerializationInfo provided. (Inherited from ReadOnlyPropertiesDictionary.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Remove the entry with the specified key from this dictionary
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PropertiesDictionary Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertiesDictionary.Clear Method

PropertiesDictionary Clear Method Apache log4net™ SDK Documentation
Remove all properties from the properties collection

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Clear()
public override void Clear()
Public Overrides Sub Clear
Public Overrides Sub Clear
public:
virtual void Clear() override
public:
virtual void Clear() override
Implements
  Online IDictionary Clear
  Online IDictionary Clear
Remarks

            Remove all properties from the properties collection

See Also
PropertiesDictionary Class
PropertiesDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertiesDictionary.Remove Method

PropertiesDictionary Remove Method Apache log4net™ SDK Documentation
Remove the entry with the specified key from this dictionary

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Remove(
    string key
)
public void Remove(
    string key
)
Public Sub Remove (
    key As String
)
Public Sub Remove (
    key As String
)
public:
void Remove(
    String^ key
)
public:
void Remove(
    String^ key
)
Parameters
key
Type:   Online System String
the key for the entry to remove
Remarks

            Remove the entry with the specified key from this dictionary

See Also
PropertiesDictionary Class
PropertiesDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertiesDictionary Properties

PropertiesDictionary Properties Apache log4net™ SDK Documentation
The PropertiesDictionary type exposes the following members.
Properties
 | Name | Description
Public property | Count | The number of properties in this collection (Inherited from ReadOnlyPropertiesDictionary.)
Protected property | InnerHashtable | The hashtable used to store the properties (Inherited from ReadOnlyPropertiesDictionary.)
Public property | Item | Gets or sets the value of the property with the specified key. (Overrides ReadOnlyPropertiesDictionary Item String .)
Back to Top
See Also
PropertiesDictionary Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertiesDictionary.Item Property

PropertiesDictionary Item Property Apache log4net™ SDK Documentation
Gets or sets the value of the property with the specified key.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object this[
    string key
] { get; set; }
public override Object this[
    string key
] { get; set; }
Public Overrides Default Property Item (
    key As String
) As Object
    Get
    Set
Public Overrides Default Property Item (
    key As String
) As Object
    Get
    Set
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key) override;
    void set (String^ key, Object^ value) override;
}
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key) override;
    void set (String^ key, Object^ value) override;
}
Parameters
key
Type:   Online System String
The key of the property to get or set.
Property Value
Type:   Online Object

            The value of the property with the specified key.

Remarks

            The property value will only be serialized if it is serializable.
            If it cannot be serialized it will be silently ignored if
            a serialization operation is performed.

See Also
PropertiesDictionary Class
PropertiesDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyEntry Class

PropertyEntry Class Apache log4net™ SDK Documentation
A class to hold the key and data for a property set in the config file
Inheritance Hierarchy
Online System Object
log4net.Util PropertyEntry

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PropertyEntry
public class PropertyEntry
Public Class PropertyEntry
Public Class PropertyEntry
public ref class PropertyEntry
public ref class PropertyEntry
Remarks

            A class to hold the key and data for a property set in the config file

See Also
PropertyEntry Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyEntry Members

PropertyEntry Members Apache log4net™ SDK Documentation
The PropertyEntry type exposes the following members.
Constructors
 | Name | Description
Public method | PropertyEntry | Initializes a new instance of the PropertyEntry class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Override Object.ToString to return sensible debug info (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Key | Property Key
Public property | Value | Property Value
Back to Top
See Also
PropertyEntry Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyEntry Constructor

PropertyEntry Constructor Apache log4net™ SDK Documentation
Initializes a new instance of the PropertyEntry class

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PropertyEntry()
public PropertyEntry()
Public Sub New
Public Sub New
public:
PropertyEntry()
public:
PropertyEntry()
See Also
PropertyEntry Class
PropertyEntry Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyEntry Methods

PropertyEntry Methods Apache log4net™ SDK Documentation
The PropertyEntry type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Override Object.ToString to return sensible debug info (Overrides Online Object ToString .)
Back to Top
See Also
PropertyEntry Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyEntry.ToString Method

PropertyEntry ToString Method Apache log4net™ SDK Documentation
Override Object.ToString to return sensible debug info

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value
Type:   Online String
string info about this object
See Also
PropertyEntry Class
PropertyEntry Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyEntry Properties

PropertyEntry Properties Apache log4net™ SDK Documentation
The PropertyEntry type exposes the following members.
Properties
 | Name | Description
Public property | Key | Property Key
Public property | Value | Property Value
Back to Top
See Also
PropertyEntry Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyEntry.Key Property

PropertyEntry Key Property Apache log4net™ SDK Documentation
Property Key

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; set; }
public string Key { get; set; }
Public Property Key As String
    Get
    Set
Public Property Key As String
    Get
    Set
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            Property Key

Remarks

            Property Key.

See Also
PropertyEntry Class
PropertyEntry Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


PropertyEntry.Value Property

PropertyEntry Value Property Apache log4net™ SDK Documentation
Property Value

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Value { get; set; }
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
Property Value
Type:   Online Object

            Property Value

Remarks

            Property Value.

See Also
PropertyEntry Class
PropertyEntry Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ProtectCloseTextWriter Class

ProtectCloseTextWriter Class Apache log4net™ SDK Documentation
A Online TextWriter that ignores the Close message
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO TextWriter
log4net.Util TextWriterAdapter
log4net.Util ProtectCloseTextWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ProtectCloseTextWriter : TextWriterAdapter
public class ProtectCloseTextWriter : TextWriterAdapter
Public Class ProtectCloseTextWriter
    Inherits TextWriterAdapter
Public Class ProtectCloseTextWriter
    Inherits TextWriterAdapter
public ref class ProtectCloseTextWriter : public TextWriterAdapter
public ref class ProtectCloseTextWriter : public TextWriterAdapter
Remarks

            This writer is used in special cases where it is necessary
            to protect a writer from being closed by a client.

See Also
ProtectCloseTextWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ProtectCloseTextWriter Members

ProtectCloseTextWriter Members Apache log4net™ SDK Documentation
The ProtectCloseTextWriter type exposes the following members.
Constructors
 | Name | Description
Public method | ProtectCloseTextWriter | Constructor
Back to Top
Methods
 | Name | Description
Public method | Attach | Attach this instance to a different underlying Online TextWriter
Public method | Close | Does not close the underlying output writer. (Overrides TextWriterAdapter Close .)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online TextWriter object. (Inherited from Online TextWriter.)
Protected method | Dispose(Boolean) | Dispose this writer (Inherited from TextWriterAdapter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Flushes any buffered output (Inherited from TextWriterAdapter.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Write(Char) | Writes a character to the wrapped TextWriter (Inherited from TextWriterAdapter.)
Public method | Write(String) | Writes a string to the wrapped TextWriter (Inherited from TextWriterAdapter.)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Write( Char , Int32, Int32) | Writes a character buffer to the wrapped TextWriter (Inherited from TextWriterAdapter.)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine | Writes a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char ) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object ) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char , Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
Fields
 | Name | Description
Protected field | Online CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from Online TextWriter.)
Back to Top
Properties
 | Name | Description
Public property | Encoding | The Encoding in which the output is written (Inherited from TextWriterAdapter.)
Public property | FormatProvider | Gets an object that controls formatting (Inherited from TextWriterAdapter.)
Public property | NewLine | Gets or sets the line terminator string used by the TextWriter (Inherited from TextWriterAdapter.)
Protected property | Writer | Gets or sets the underlying Online TextWriter. (Inherited from TextWriterAdapter.)
Back to Top
See Also
ProtectCloseTextWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ProtectCloseTextWriter Constructor

ProtectCloseTextWriter Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ProtectCloseTextWriter(
    TextWriter writer
)
public ProtectCloseTextWriter(
    TextWriter writer
)
Public Sub New (
    writer As TextWriter
)
Public Sub New (
    writer As TextWriter
)
public:
ProtectCloseTextWriter(
    TextWriter^ writer
)
public:
ProtectCloseTextWriter(
    TextWriter^ writer
)
Parameters
writer
Type:   Online System.IO TextWriter
the writer to actually write to
Remarks

            Create a new ProtectCloseTextWriter using a writer

See Also
ProtectCloseTextWriter Class
ProtectCloseTextWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ProtectCloseTextWriter Fields

ProtectCloseTextWriter Fields Apache log4net™ SDK Documentation
The ProtectCloseTextWriter type exposes the following members.
Fields
 | Name | Description
Protected field | Online CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from Online TextWriter.)
Back to Top
See Also
ProtectCloseTextWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ProtectCloseTextWriter Methods

ProtectCloseTextWriter Methods Apache log4net™ SDK Documentation
The ProtectCloseTextWriter type exposes the following members.
Methods
 | Name | Description
Public method | Attach | Attach this instance to a different underlying Online TextWriter
Public method | Close | Does not close the underlying output writer. (Overrides TextWriterAdapter Close .)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online TextWriter object. (Inherited from Online TextWriter.)
Protected method | Dispose(Boolean) | Dispose this writer (Inherited from TextWriterAdapter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Flushes any buffered output (Inherited from TextWriterAdapter.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Write(Char) | Writes a character to the wrapped TextWriter (Inherited from TextWriterAdapter.)
Public method | Write(String) | Writes a string to the wrapped TextWriter (Inherited from TextWriterAdapter.)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Write( Char , Int32, Int32) | Writes a character buffer to the wrapped TextWriter (Inherited from TextWriterAdapter.)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine | Writes a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char ) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object ) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char , Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
See Also
ProtectCloseTextWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ProtectCloseTextWriter.Attach Method

ProtectCloseTextWriter Attach Method Apache log4net™ SDK Documentation
Attach this instance to a different underlying Online TextWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Attach(
    TextWriter writer
)
public void Attach(
    TextWriter writer
)
Public Sub Attach (
    writer As TextWriter
)
Public Sub Attach (
    writer As TextWriter
)
public:
void Attach(
    TextWriter^ writer
)
public:
void Attach(
    TextWriter^ writer
)
Parameters
writer
Type:   Online System.IO TextWriter
the writer to attach to
Remarks

            Attach this instance to a different underlying   Online TextWriter
See Also
ProtectCloseTextWriter Class
ProtectCloseTextWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ProtectCloseTextWriter.Close Method

ProtectCloseTextWriter Close Method Apache log4net™ SDK Documentation
Does not close the underlying output writer.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
Remarks

            Does not close the underlying output writer.
            This method does nothing.

See Also
ProtectCloseTextWriter Class
ProtectCloseTextWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ProtectCloseTextWriter Properties

ProtectCloseTextWriter Properties Apache log4net™ SDK Documentation
The ProtectCloseTextWriter type exposes the following members.
Properties
 | Name | Description
Public property | Encoding | The Encoding in which the output is written (Inherited from TextWriterAdapter.)
Public property | FormatProvider | Gets an object that controls formatting (Inherited from TextWriterAdapter.)
Public property | NewLine | Gets or sets the line terminator string used by the TextWriter (Inherited from TextWriterAdapter.)
Protected property | Writer | Gets or sets the underlying Online TextWriter. (Inherited from TextWriterAdapter.)
Back to Top
See Also
ProtectCloseTextWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter Class

QuietTextWriter Class Apache log4net™ SDK Documentation
Online TextWriter that does not leak exceptions
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO TextWriter
log4net.Util TextWriterAdapter
log4net.Util QuietTextWriter
log4net.Util CountingQuietTextWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class QuietTextWriter : TextWriterAdapter
public class QuietTextWriter : TextWriterAdapter
Public Class QuietTextWriter
    Inherits TextWriterAdapter
Public Class QuietTextWriter
    Inherits TextWriterAdapter
public ref class QuietTextWriter : public TextWriterAdapter
public ref class QuietTextWriter : public TextWriterAdapter
Remarks
QuietTextWriter does not throw exceptions when things go wrong.
            Instead, it delegates error handling to its IErrorHandler.

See Also
QuietTextWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter Members

QuietTextWriter Members Apache log4net™ SDK Documentation
The QuietTextWriter type exposes the following members.
Constructors
 | Name | Description
Public method | QuietTextWriter | Constructor
Back to Top
Methods
 | Name | Description
Public method | Close | Closes the underlying output writer. (Overrides TextWriterAdapter Close .)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online TextWriter object. (Inherited from Online TextWriter.)
Protected method | Dispose(Boolean) | Dispose this writer (Inherited from TextWriterAdapter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Flushes any buffered output (Inherited from TextWriterAdapter.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Write(Char) | Writes a character to the underlying writer (Overrides TextWriterAdapter Write(Char).)
Public method | Write(String) | Writes a string to the output. (Overrides TextWriterAdapter Write(String).)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Write( Char , Int32, Int32) | Writes a buffer to the underlying writer (Overrides TextWriterAdapter Write( Char , Int32, Int32).)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine | Writes a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char ) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object ) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char , Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
Fields
 | Name | Description
Protected field | Online CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from Online TextWriter.)
Back to Top
Properties
 | Name | Description
Public property | Closed | Gets a value indicating whether this writer is closed.
Public property | Encoding | The Encoding in which the output is written (Inherited from TextWriterAdapter.)
Public property | ErrorHandler | Gets or sets the error handler that all errors are passed to.
Public property | FormatProvider | Gets an object that controls formatting (Inherited from TextWriterAdapter.)
Public property | NewLine | Gets or sets the line terminator string used by the TextWriter (Inherited from TextWriterAdapter.)
Protected property | Writer | Gets or sets the underlying Online TextWriter. (Inherited from TextWriterAdapter.)
Back to Top
See Also
QuietTextWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter Constructor

QuietTextWriter Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QuietTextWriter(
    TextWriter writer,
    IErrorHandler errorHandler
)
public QuietTextWriter(
    TextWriter writer,
    IErrorHandler errorHandler
)
Public Sub New (
    writer As TextWriter,
    errorHandler As IErrorHandler
)
Public Sub New (
    writer As TextWriter,
    errorHandler As IErrorHandler
)
public:
QuietTextWriter(
    TextWriter^ writer,
    IErrorHandler^ errorHandler
)
public:
QuietTextWriter(
    TextWriter^ writer,
    IErrorHandler^ errorHandler
)
Parameters
writer
Type:   Online System.IO TextWriter
the writer to actually write to
errorHandler
Type: log4net.Core IErrorHandler
the error handler to report error to
Remarks

            Create a new QuietTextWriter using a writer and error handler

See Also
QuietTextWriter Class
QuietTextWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter Fields

QuietTextWriter Fields Apache log4net™ SDK Documentation
The QuietTextWriter type exposes the following members.
Fields
 | Name | Description
Protected field | Online CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from Online TextWriter.)
Back to Top
See Also
QuietTextWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter Methods

QuietTextWriter Methods Apache log4net™ SDK Documentation
The QuietTextWriter type exposes the following members.
Methods
 | Name | Description
Public method | Close | Closes the underlying output writer. (Overrides TextWriterAdapter Close .)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online TextWriter object. (Inherited from Online TextWriter.)
Protected method | Dispose(Boolean) | Dispose this writer (Inherited from TextWriterAdapter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Flushes any buffered output (Inherited from TextWriterAdapter.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Write(Char) | Writes a character to the underlying writer (Overrides TextWriterAdapter Write(Char).)
Public method | Write(String) | Writes a string to the output. (Overrides TextWriterAdapter Write(String).)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Write( Char , Int32, Int32) | Writes a buffer to the underlying writer (Overrides TextWriterAdapter Write( Char , Int32, Int32).)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine | Writes a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char ) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object ) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char , Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
See Also
QuietTextWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter.Close Method

QuietTextWriter Close Method Apache log4net™ SDK Documentation
Closes the underlying output writer.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
Remarks

            Closes the underlying output writer.

See Also
QuietTextWriter Class
QuietTextWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter.Write Method

QuietTextWriter Write Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Write(Char) | Writes a character to the underlying writer (Overrides TextWriterAdapter Write(Char).)
Public method | Write(String) | Writes a string to the output. (Overrides TextWriterAdapter Write(String).)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Write( Char , Int32, Int32) | Writes a buffer to the underlying writer (Overrides TextWriterAdapter Write( Char , Int32, Int32).)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
See Also
QuietTextWriter Class
QuietTextWriter Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter.Write Method (Char)

QuietTextWriter Write Method (Char) Apache log4net™ SDK Documentation
Writes a character to the underlying writer

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    char value
)
public override void Write(
    char value
)
Public Overrides Sub Write (
    value As Char
)
Public Overrides Sub Write (
    value As Char
)
public:
virtual void Write(
    wchar_t value
) override
public:
virtual void Write(
    wchar_t value
) override
Parameters
value
Type:   Online System Char
the char to write
Remarks

            Writes a character to the underlying writer

See Also
QuietTextWriter Class
QuietTextWriter Members
Write Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter.Write Method (String)

QuietTextWriter Write Method (String) Apache log4net™ SDK Documentation
Writes a string to the output.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    string value
)
public override void Write(
    string value
)
Public Overrides Sub Write (
    value As String
)
Public Overrides Sub Write (
    value As String
)
public:
virtual void Write(
    String^ value
) override
public:
virtual void Write(
    String^ value
) override
Parameters
value
Type:   Online System String
The string data to write to the output.
Remarks

            Writes a string to the output.

See Also
QuietTextWriter Class
QuietTextWriter Members
Write Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter.Write Method (Char[], Int32, Int32)

QuietTextWriter Write Method ( Char , Int32, Int32) Apache log4net™ SDK Documentation
Writes a buffer to the underlying writer

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    char[] buffer,
    int index,
    int count
)
public override void Write(
    char[] buffer,
    int index,
    int count
)
Public Overrides Sub Write (
    buffer As Char(),
    index As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Char(),
    index As Integer,
    count As Integer
)
public:
virtual void Write(
    array<wchar_t>^ buffer,
    int index,
    int count
) override
public:
virtual void Write(
    array<wchar_t>^ buffer,
    int index,
    int count
) override
Parameters
buffer
Type:    Online System Char
the buffer to write
index
Type:   Online System Int32
the start index to write from
count
Type:   Online System Int32
the number of characters to write
Remarks

            Writes a buffer to the underlying writer

See Also
QuietTextWriter Class
QuietTextWriter Members
Write Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter Properties

QuietTextWriter Properties Apache log4net™ SDK Documentation
The QuietTextWriter type exposes the following members.
Properties
 | Name | Description
Public property | Closed | Gets a value indicating whether this writer is closed.
Public property | Encoding | The Encoding in which the output is written (Inherited from TextWriterAdapter.)
Public property | ErrorHandler | Gets or sets the error handler that all errors are passed to.
Public property | FormatProvider | Gets an object that controls formatting (Inherited from TextWriterAdapter.)
Public property | NewLine | Gets or sets the line terminator string used by the TextWriter (Inherited from TextWriterAdapter.)
Protected property | Writer | Gets or sets the underlying Online TextWriter. (Inherited from TextWriterAdapter.)
Back to Top
See Also
QuietTextWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter.Closed Property

QuietTextWriter Closed Property Apache log4net™ SDK Documentation
Gets a value indicating whether this writer is closed.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Closed { get; }
public bool Closed { get; }
Public ReadOnly Property Closed As Boolean
    Get
Public ReadOnly Property Closed As Boolean
    Get
public:
property bool Closed {
    bool get ();
}
public:
property bool Closed {
    bool get ();
}
Property Value
Type:   Online Boolean
true if this writer is closed, otherwise false.

Remarks

            Gets a value indicating whether this writer is closed.

See Also
QuietTextWriter Class
QuietTextWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


QuietTextWriter.ErrorHandler Property

QuietTextWriter ErrorHandler Property Apache log4net™ SDK Documentation
Gets or sets the error handler that all errors are passed to.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErrorHandler ErrorHandler { get; set; }
public IErrorHandler ErrorHandler { get; set; }
Public Property ErrorHandler As IErrorHandler
    Get
    Set
Public Property ErrorHandler As IErrorHandler
    Get
    Set
public:
property IErrorHandler^ ErrorHandler {
    IErrorHandler^ get ();
    void set (IErrorHandler^ value);
}
public:
property IErrorHandler^ ErrorHandler {
    IErrorHandler^ get ();
    void set (IErrorHandler^ value);
}
Property Value
Type: IErrorHandler

            The error handler that all errors are passed to.

Remarks

            Gets or sets the error handler that all errors are passed to.

See Also
QuietTextWriter Class
QuietTextWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReaderWriterLock Class

ReaderWriterLock Class Apache log4net™ SDK Documentation
Defines a lock that supports single writers and multiple readers
Inheritance Hierarchy
Online System Object
log4net.Util ReaderWriterLock

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ReaderWriterLock
public sealed class ReaderWriterLock
Public NotInheritable Class ReaderWriterLock
Public NotInheritable Class ReaderWriterLock
public ref class ReaderWriterLock sealed
public ref class ReaderWriterLock sealed
Remarks
ReaderWriterLock is used to synchronize access to a resource.
            At any given time, it allows either concurrent read access for
            multiple threads, or write access for a single thread. In a
            situation where a resource is changed infrequently, a
            ReaderWriterLock provides better throughput than a simple
            one-at-a-time lock, such as   Online Monitor.

            If a platform does not support a System.Threading.ReaderWriterLock
            implementation then all readers and writers are serialized. Therefore
            the caller must not rely on multiple simultaneous readers.

See Also
ReaderWriterLock Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReaderWriterLock Members

ReaderWriterLock Members Apache log4net™ SDK Documentation
The ReaderWriterLock type exposes the following members.
Constructors
 | Name | Description
Public method | ReaderWriterLock | Constructor
Back to Top
Methods
 | Name | Description
Public method | AcquireReaderLock | Acquires a reader lock
Public method | AcquireWriterLock | Acquires the writer lock
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReleaseReaderLock | Decrements the lock count
Public method | ReleaseWriterLock | Decrements the lock count on the writer lock
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ReaderWriterLock Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReaderWriterLock Constructor

ReaderWriterLock Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReaderWriterLock()
public ReaderWriterLock()
Public Sub New
Public Sub New
public:
ReaderWriterLock()
public:
ReaderWriterLock()
Remarks

            Initializes a new instance of the ReaderWriterLock class.

See Also
ReaderWriterLock Class
ReaderWriterLock Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReaderWriterLock Methods

ReaderWriterLock Methods Apache log4net™ SDK Documentation
The ReaderWriterLock type exposes the following members.
Methods
 | Name | Description
Public method | AcquireReaderLock | Acquires a reader lock
Public method | AcquireWriterLock | Acquires the writer lock
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReleaseReaderLock | Decrements the lock count
Public method | ReleaseWriterLock | Decrements the lock count on the writer lock
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ReaderWriterLock Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReaderWriterLock.AcquireReaderLock Method

ReaderWriterLock AcquireReaderLock Method Apache log4net™ SDK Documentation
Acquires a reader lock

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AcquireReaderLock()
public void AcquireReaderLock()
Public Sub AcquireReaderLock
Public Sub AcquireReaderLock
public:
void AcquireReaderLock()
public:
void AcquireReaderLock()
Remarks
AcquireReaderLock  blocks if a different thread has the writer
            lock, or if at least one thread is waiting for the writer lock.

See Also
ReaderWriterLock Class
ReaderWriterLock Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReaderWriterLock.AcquireWriterLock Method

ReaderWriterLock AcquireWriterLock Method Apache log4net™ SDK Documentation
Acquires the writer lock

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AcquireWriterLock()
public void AcquireWriterLock()
Public Sub AcquireWriterLock
Public Sub AcquireWriterLock
public:
void AcquireWriterLock()
public:
void AcquireWriterLock()
Remarks

            This method blocks if another thread has a reader lock or writer lock.

See Also
ReaderWriterLock Class
ReaderWriterLock Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReaderWriterLock.ReleaseReaderLock Method

ReaderWriterLock ReleaseReaderLock Method Apache log4net™ SDK Documentation
Decrements the lock count

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReleaseReaderLock()
public void ReleaseReaderLock()
Public Sub ReleaseReaderLock
Public Sub ReleaseReaderLock
public:
void ReleaseReaderLock()
public:
void ReleaseReaderLock()
Remarks
ReleaseReaderLock  decrements the lock count. When the count
            reaches zero, the lock is released.

See Also
ReaderWriterLock Class
ReaderWriterLock Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReaderWriterLock.ReleaseWriterLock Method

ReaderWriterLock ReleaseWriterLock Method Apache log4net™ SDK Documentation
Decrements the lock count on the writer lock

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReleaseWriterLock()
public void ReleaseWriterLock()
Public Sub ReleaseWriterLock
Public Sub ReleaseWriterLock
public:
void ReleaseWriterLock()
public:
void ReleaseWriterLock()
Remarks

            ReleaseWriterLock decrements the writer lock count.
            When the count reaches zero, the writer lock is released.

See Also
ReaderWriterLock Class
ReaderWriterLock Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary Class

ReadOnlyPropertiesDictionary Class Apache log4net™ SDK Documentation
String keyed object map that is read only.
Inheritance Hierarchy
Online System Object
log4net.Util ReadOnlyPropertiesDictionary
log4net.Util PropertiesDictionary

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ReadOnlyPropertiesDictionary : ISerializable,
    IDictionary, ICollection, IEnumerable
[SerializableAttribute]
public class ReadOnlyPropertiesDictionary : ISerializable,
    IDictionary, ICollection, IEnumerable
<SerializableAttribute>
Public Class ReadOnlyPropertiesDictionary
    Implements ISerializable, IDictionary, ICollection, IEnumerable
<SerializableAttribute>
Public Class ReadOnlyPropertiesDictionary
    Implements ISerializable, IDictionary, ICollection, IEnumerable
[SerializableAttribute]
public ref class ReadOnlyPropertiesDictionary : ISerializable,
    IDictionary, ICollection, IEnumerable
[SerializableAttribute]
public ref class ReadOnlyPropertiesDictionary : ISerializable,
    IDictionary, ICollection, IEnumerable
Remarks

            This collection is readonly and cannot be modified.

            While this collection is serializable only member
            objects that are serializable will
            be serialized along with this collection.

See Also
ReadOnlyPropertiesDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary Members

ReadOnlyPropertiesDictionary Members Apache log4net™ SDK Documentation
The ReadOnlyPropertiesDictionary type exposes the following members.
Constructors
 | Name | Description
Public method | ReadOnlyPropertiesDictionary | Constructor
Public method | ReadOnlyPropertiesDictionary(ReadOnlyPropertiesDictionary) | Copy Constructor
Protected method | ReadOnlyPropertiesDictionary(SerializationInfo, StreamingContext) | Deserialization constructor
Back to Top
Methods
 | Name | Description
Public method | Clear | Remove all properties from the properties collection
Public method | Contains | Test if the dictionary contains a specified key
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetKeys | Gets the key names.
Public method | GetObjectData | Serializes this object into the Online SerializationInfo provided.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Count | The number of properties in this collection
Protected property | InnerHashtable | The hashtable used to store the properties
Public property | Item | Gets or sets the value of the property with the specified key.
Back to Top
See Also
ReadOnlyPropertiesDictionary Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary Constructor

ReadOnlyPropertiesDictionary Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | ReadOnlyPropertiesDictionary | Constructor
Public method | ReadOnlyPropertiesDictionary(ReadOnlyPropertiesDictionary) | Copy Constructor
Protected method | ReadOnlyPropertiesDictionary(SerializationInfo, StreamingContext) | Deserialization constructor
Back to Top
See Also
ReadOnlyPropertiesDictionary Class
ReadOnlyPropertiesDictionary Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary Constructor

ReadOnlyPropertiesDictionary Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReadOnlyPropertiesDictionary()
public ReadOnlyPropertiesDictionary()
Public Sub New
Public Sub New
public:
ReadOnlyPropertiesDictionary()
public:
ReadOnlyPropertiesDictionary()
Remarks

            Initializes a new instance of the ReadOnlyPropertiesDictionary class.

See Also
ReadOnlyPropertiesDictionary Class
ReadOnlyPropertiesDictionary Members
ReadOnlyPropertiesDictionary Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary Constructor (ReadOnlyPropertiesDictionary)

ReadOnlyPropertiesDictionary Constructor (ReadOnlyPropertiesDictionary) Apache log4net™ SDK Documentation
Copy Constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReadOnlyPropertiesDictionary(
    ReadOnlyPropertiesDictionary propertiesDictionary
)
public ReadOnlyPropertiesDictionary(
    ReadOnlyPropertiesDictionary propertiesDictionary
)
Public Sub New (
    propertiesDictionary As ReadOnlyPropertiesDictionary
)
Public Sub New (
    propertiesDictionary As ReadOnlyPropertiesDictionary
)
public:
ReadOnlyPropertiesDictionary(
    ReadOnlyPropertiesDictionary^ propertiesDictionary
)
public:
ReadOnlyPropertiesDictionary(
    ReadOnlyPropertiesDictionary^ propertiesDictionary
)
Parameters
propertiesDictionary
Type: log4net.Util ReadOnlyPropertiesDictionary
properties to copy
Remarks

            Initializes a new instance of the ReadOnlyPropertiesDictionary class.

See Also
ReadOnlyPropertiesDictionary Class
ReadOnlyPropertiesDictionary Members
ReadOnlyPropertiesDictionary Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary Constructor (SerializationInfo, StreamingContext)

ReadOnlyPropertiesDictionary Constructor (SerializationInfo, StreamingContext) Apache log4net™ SDK Documentation
Deserialization constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ReadOnlyPropertiesDictionary(
    SerializationInfo info,
    StreamingContext context
)
protected ReadOnlyPropertiesDictionary(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ReadOnlyPropertiesDictionary(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ReadOnlyPropertiesDictionary(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The   Online SerializationInfo that holds the serialized object data.
context
Type:   Online System.Runtime.Serialization StreamingContext
The   Online StreamingContext that contains contextual information about the source or destination.
Remarks

            Initializes a new instance of the ReadOnlyPropertiesDictionary class
            with serialized data.

See Also
ReadOnlyPropertiesDictionary Class
ReadOnlyPropertiesDictionary Members
ReadOnlyPropertiesDictionary Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary Methods

ReadOnlyPropertiesDictionary Methods Apache log4net™ SDK Documentation
The ReadOnlyPropertiesDictionary type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Remove all properties from the properties collection
Public method | Contains | Test if the dictionary contains a specified key
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetKeys | Gets the key names.
Public method | GetObjectData | Serializes this object into the Online SerializationInfo provided.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ReadOnlyPropertiesDictionary Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary.Clear Method

ReadOnlyPropertiesDictionary Clear Method Apache log4net™ SDK Documentation
Remove all properties from the properties collection

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Clear()
public virtual void Clear()
Public Overridable Sub Clear
Public Overridable Sub Clear
public:
virtual void Clear()
public:
virtual void Clear()
Implements
  Online IDictionary Clear
See Also
ReadOnlyPropertiesDictionary Class
ReadOnlyPropertiesDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary.Contains Method

ReadOnlyPropertiesDictionary Contains Method Apache log4net™ SDK Documentation
Test if the dictionary contains a specified key

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Contains(
    string key
)
public bool Contains(
    string key
)
Public Function Contains (
    key As String
) As Boolean
Public Function Contains (
    key As String
) As Boolean
public:
bool Contains(
    String^ key
)
public:
bool Contains(
    String^ key
)
Parameters
key
Type:   Online System String
the key to look for
Return Value
Type:   Online Boolean
true if the dictionary contains the specified key
Remarks

            Test if the dictionary contains a specified key

See Also
ReadOnlyPropertiesDictionary Class
ReadOnlyPropertiesDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary.GetKeys Method

ReadOnlyPropertiesDictionary GetKeys Method Apache log4net™ SDK Documentation
Gets the key names.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string[] GetKeys()
public string[] GetKeys()
Public Function GetKeys As String()
Public Function GetKeys As String()
public:
array<String^>^ GetKeys()
public:
array<String^>^ GetKeys()
Return Value
Type:    Online String
An array of all the keys.
Remarks

            Gets the key names.

See Also
ReadOnlyPropertiesDictionary Class
ReadOnlyPropertiesDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary.GetObjectData Method

ReadOnlyPropertiesDictionary GetObjectData Method Apache log4net™ SDK Documentation
Serializes this object into the Online SerializationInfo provided.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The   Online SerializationInfo to populate with data.
context
Type:   Online System.Runtime.Serialization StreamingContext
The destination for this serialization.
Implements
  Online ISerializable GetObjectData(SerializationInfo, StreamingContext)
Remarks

            Serializes this object into the   Online SerializationInfo provided.

See Also
ReadOnlyPropertiesDictionary Class
ReadOnlyPropertiesDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary Properties

ReadOnlyPropertiesDictionary Properties Apache log4net™ SDK Documentation
The ReadOnlyPropertiesDictionary type exposes the following members.
Properties
 | Name | Description
Public property | Count | The number of properties in this collection
Protected property | InnerHashtable | The hashtable used to store the properties
Public property | Item | Gets or sets the value of the property with the specified key.
Back to Top
See Also
ReadOnlyPropertiesDictionary Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary.Count Property

ReadOnlyPropertiesDictionary Count Property Apache log4net™ SDK Documentation
The number of properties in this collection

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
public:
virtual property int Count {
    int get () sealed;
}
Property Value
Type:   Online Int32
Implements
  Online ICollection Count
See Also
ReadOnlyPropertiesDictionary Class
ReadOnlyPropertiesDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary.InnerHashtable Property

ReadOnlyPropertiesDictionary InnerHashtable Property Apache log4net™ SDK Documentation
The hashtable used to store the properties

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Hashtable InnerHashtable { get; }
protected Hashtable InnerHashtable { get; }
Protected ReadOnly Property InnerHashtable As Hashtable
    Get
Protected ReadOnly Property InnerHashtable As Hashtable
    Get
protected:
property Hashtable^ InnerHashtable {
    Hashtable^ get ();
}
protected:
property Hashtable^ InnerHashtable {
    Hashtable^ get ();
}
Property Value
Type:   Online Hashtable

            The internal collection used to store the properties

Remarks

            The hashtable used to store the properties

See Also
ReadOnlyPropertiesDictionary Class
ReadOnlyPropertiesDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReadOnlyPropertiesDictionary.Item Property

ReadOnlyPropertiesDictionary Item Property Apache log4net™ SDK Documentation
Gets or sets the value of the property with the specified key.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object this[
    string key
] { get; set; }
public virtual Object this[
    string key
] { get; set; }
Public Overridable Default Property Item (
    key As String
) As Object
    Get
    Set
Public Overridable Default Property Item (
    key As String
) As Object
    Get
    Set
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key);
    void set (String^ key, Object^ value);
}
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key);
    void set (String^ key, Object^ value);
}
Parameters
key
Type:   Online System String
The key of the property to get or set.
Property Value
Type:   Online Object

            The value of the property with the specified key.

Remarks

            The property value will only be serialized if it is serializable.
            If it cannot be serialized it will be silently ignored if
            a serialization operation is performed.

See Also
ReadOnlyPropertiesDictionary Class
ReadOnlyPropertiesDictionary Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReusableStringWriter Class

ReusableStringWriter Class Apache log4net™ SDK Documentation
A Online StringWriter that can be Reset(Int32, Int32) and reused
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO TextWriter
Online System.IO StringWriter
log4net.Util ReusableStringWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ReusableStringWriter : StringWriter
public class ReusableStringWriter : StringWriter
Public Class ReusableStringWriter
    Inherits StringWriter
Public Class ReusableStringWriter
    Inherits StringWriter
public ref class ReusableStringWriter : public StringWriter
public ref class ReusableStringWriter : public StringWriter
Remarks

            A   Online StringWriter that can be Reset(Int32, Int32) and reused.
            This uses a single buffer for string operations.

See Also
ReusableStringWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReusableStringWriter Members

ReusableStringWriter Members Apache log4net™ SDK Documentation
The ReusableStringWriter type exposes the following members.
Constructors
 | Name | Description
Public method | ReusableStringWriter | Create an instance of ReusableStringWriter
Back to Top
Methods
 | Name | Description
Public method | Online Close | Closes the current Online StringWriter and the underlying stream. (Inherited from Online StringWriter.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online TextWriter object. (Inherited from Online TextWriter.)
Protected method | Dispose(Boolean) | Override Dispose to prevent closing of writer (Overrides Online StringWriter Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from Online TextWriter.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetStringBuilder | Returns the underlying Online StringBuilder. (Inherited from Online StringWriter.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Reset | Reset this string writer so that it can be reused.
Public method | Online ToString | Returns a string containing the characters written to the current StringWriter so far. (Inherited from Online StringWriter.)
Public method | Online Write(Char) | Writes a character to this instance of the StringWriter. (Inherited from Online StringWriter.)
Public method | Online Write(String) | Writes a string to this instance of the StringWriter. (Inherited from Online StringWriter.)
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write( Char , Int32, Int32) | Writes the specified region of a character array to this instance of the StringWriter. (Inherited from Online StringWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine | Writes a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char ) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object ) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char , Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
Fields
 | Name | Description
Protected field | Online CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from Online TextWriter.)
Back to Top
Properties
 | Name | Description
Public property | Online Encoding | Gets the Online Encoding in which the output is written. (Inherited from Online StringWriter.)
Public property | Online FormatProvider | Gets an object that controls formatting. (Inherited from Online TextWriter.)
Public property | Online NewLine | Gets or sets the line terminator string used by the current TextWriter. (Inherited from Online TextWriter.)
Back to Top
See Also
ReusableStringWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReusableStringWriter Constructor

ReusableStringWriter Constructor Apache log4net™ SDK Documentation
Create an instance of ReusableStringWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReusableStringWriter(
    IFormatProvider formatProvider
)
public ReusableStringWriter(
    IFormatProvider formatProvider
)
Public Sub New (
    formatProvider As IFormatProvider
)
Public Sub New (
    formatProvider As IFormatProvider
)
public:
ReusableStringWriter(
    IFormatProvider^ formatProvider
)
public:
ReusableStringWriter(
    IFormatProvider^ formatProvider
)
Parameters
formatProvider
Type:   Online System IFormatProvider
the format provider to use
Remarks

            Create an instance of ReusableStringWriter
See Also
ReusableStringWriter Class
ReusableStringWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReusableStringWriter Fields

ReusableStringWriter Fields Apache log4net™ SDK Documentation
The ReusableStringWriter type exposes the following members.
Fields
 | Name | Description
Protected field | Online CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from Online TextWriter.)
Back to Top
See Also
ReusableStringWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReusableStringWriter Methods

ReusableStringWriter Methods Apache log4net™ SDK Documentation
The ReusableStringWriter type exposes the following members.
Methods
 | Name | Description
Public method | Online Close | Closes the current Online StringWriter and the underlying stream. (Inherited from Online StringWriter.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online TextWriter object. (Inherited from Online TextWriter.)
Protected method | Dispose(Boolean) | Override Dispose to prevent closing of writer (Overrides Online StringWriter Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from Online TextWriter.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetStringBuilder | Returns the underlying Online StringBuilder. (Inherited from Online StringWriter.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Reset | Reset this string writer so that it can be reused.
Public method | Online ToString | Returns a string containing the characters written to the current StringWriter so far. (Inherited from Online StringWriter.)
Public method | Online Write(Char) | Writes a character to this instance of the StringWriter. (Inherited from Online StringWriter.)
Public method | Online Write(String) | Writes a string to this instance of the StringWriter. (Inherited from Online StringWriter.)
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write( Char , Int32, Int32) | Writes the specified region of a character array to this instance of the StringWriter. (Inherited from Online StringWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine | Writes a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char ) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object ) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char , Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
See Also
ReusableStringWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReusableStringWriter.Dispose Method

ReusableStringWriter Dispose Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Online Dispose | Releases all resources used by the Online TextWriter object. (Inherited from Online TextWriter.)
Protected method | Dispose(Boolean) | Override Dispose to prevent closing of writer (Overrides Online StringWriter Dispose(Boolean).)
Back to Top
See Also
ReusableStringWriter Class
ReusableStringWriter Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReusableStringWriter.Dispose Method (Boolean)

ReusableStringWriter Dispose Method (Boolean) Apache log4net™ SDK Documentation
Override Dispose to prevent closing of writer

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
flag
Remarks

            Override Dispose to prevent closing of writer

See Also
ReusableStringWriter Class
ReusableStringWriter Members
Dispose Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReusableStringWriter.Reset Method

ReusableStringWriter Reset Method Apache log4net™ SDK Documentation
Reset this string writer so that it can be reused.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset(
    int maxCapacity,
    int defaultSize
)
public void Reset(
    int maxCapacity,
    int defaultSize
)
Public Sub Reset (
    maxCapacity As Integer,
    defaultSize As Integer
)
Public Sub Reset (
    maxCapacity As Integer,
    defaultSize As Integer
)
public:
void Reset(
    int maxCapacity,
    int defaultSize
)
public:
void Reset(
    int maxCapacity,
    int defaultSize
)
Parameters
maxCapacity
Type:   Online System Int32
the maximum buffer capacity before it is trimmed
defaultSize
Type:   Online System Int32
the default size to make the buffer
Remarks

            Reset this string writer so that it can be reused.
            The internal buffers are cleared and reset.

See Also
ReusableStringWriter Class
ReusableStringWriter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ReusableStringWriter Properties

ReusableStringWriter Properties Apache log4net™ SDK Documentation
The ReusableStringWriter type exposes the following members.
Properties
 | Name | Description
Public property | Online Encoding | Gets the Online Encoding in which the output is written. (Inherited from Online StringWriter.)
Public property | Online FormatProvider | Gets an object that controls formatting. (Inherited from Online TextWriter.)
Public property | Online NewLine | Gets or sets the line terminator string used by the current TextWriter. (Inherited from Online TextWriter.)
Back to Top
See Also
ReusableStringWriter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo Class

SystemInfo Class Apache log4net™ SDK Documentation
Utility class for system specific information.
Inheritance Hierarchy
Online System Object
log4net.Util SystemInfo

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SystemInfo
public sealed class SystemInfo
Public NotInheritable Class SystemInfo
Public NotInheritable Class SystemInfo
public ref class SystemInfo sealed
public ref class SystemInfo sealed
Remarks

            Utility class of static methods for system specific information.

See Also
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo Members

SystemInfo Members Apache log4net™ SDK Documentation
The SystemInfo type exposes the following members.
Methods
 | Name | Description
 | AssemblyFileName | Gets the file name portion of the Online Assembly, including the extension.
 | AssemblyLocationInfo | Gets the assembly location path for the specified assembly.
 | AssemblyQualifiedName | Gets the fully qualified name of the Online Type, including the name of the assembly from which the Online Type was loaded.
 | AssemblyShortName | Gets the short name of the Online Assembly.
 | ConvertToFullPath | Convert a path into a fully qualified local file path.
 | CreateArgumentOutOfRangeException | Create an Online ArgumentOutOfRangeException
 | CreateCaseInsensitiveHashtable | Creates a new case-insensitive instance of the Online Hashtable class with the default initial capacity.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetAppSetting | Lookup an application setting
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GetTypeFromString(String, Boolean, Boolean) | Loads the type specified in the type string.
 | GetTypeFromString(Assembly, String, Boolean, Boolean) | Loads the type specified in the type string.
 | GetTypeFromString(Type, String, Boolean, Boolean) | Loads the type specified in the type string.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NewGuid | Generate a new guid
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | TryParse(String, Int16 ) | Parse a string into an Online Int16 value
 | TryParse(String, Int32 ) | Parse a string into an Online Int32 value
 | TryParse(String, Int64 ) | Parse a string into an Online Int64 value
Back to Top
Fields
Name | Description
EmptyTypes | Gets an empty array of types.
Back to Top
Properties
Name | Description
ApplicationBaseDirectory | Gets the base directory for this Online AppDomain.
ApplicationFriendlyName | Get this application's friendly name
ConfigurationFileLocation | Gets the path to the configuration file for the current Online AppDomain.
CurrentThreadId | Gets the ID of the current thread.
EntryAssemblyLocation | Gets the path to the file that first executed in the current Online AppDomain.
HostName | Get the host name or machine name for the current machine
NewLine | Gets the system dependent line terminator.
NotAvailableText | Text to output when an unsupported feature is requested.
NullText | Text to output when a null is encountered.
ProcessStartTime | Get the start time for the current process.
Back to Top
See Also
SystemInfo Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo Fields

SystemInfo Fields Apache log4net™ SDK Documentation
The SystemInfo type exposes the following members.
Fields
Name | Description
EmptyTypes | Gets an empty array of types.
Back to Top
See Also
SystemInfo Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.EmptyTypes Field

SystemInfo EmptyTypes Field Apache log4net™ SDK Documentation
Gets an empty array of types.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Type[] EmptyTypes
public static readonly Type[] EmptyTypes
Public Shared ReadOnly EmptyTypes As Type()
Public Shared ReadOnly EmptyTypes As Type()
public:
static initonly array<Type^>^ EmptyTypes
public:
static initonly array<Type^>^ EmptyTypes
Field Value
Type:    Online Type
Remarks

            The Type.EmptyTypes field is not available on
            the .NET Compact Framework 1.0.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo Methods

SystemInfo Methods Apache log4net™ SDK Documentation
The SystemInfo type exposes the following members.
Methods
 | Name | Description
 | AssemblyFileName | Gets the file name portion of the Online Assembly, including the extension.
 | AssemblyLocationInfo | Gets the assembly location path for the specified assembly.
 | AssemblyQualifiedName | Gets the fully qualified name of the Online Type, including the name of the assembly from which the Online Type was loaded.
 | AssemblyShortName | Gets the short name of the Online Assembly.
 | ConvertToFullPath | Convert a path into a fully qualified local file path.
 | CreateArgumentOutOfRangeException | Create an Online ArgumentOutOfRangeException
 | CreateCaseInsensitiveHashtable | Creates a new case-insensitive instance of the Online Hashtable class with the default initial capacity.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetAppSetting | Lookup an application setting
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GetTypeFromString(String, Boolean, Boolean) | Loads the type specified in the type string.
 | GetTypeFromString(Assembly, String, Boolean, Boolean) | Loads the type specified in the type string.
 | GetTypeFromString(Type, String, Boolean, Boolean) | Loads the type specified in the type string.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NewGuid | Generate a new guid
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | TryParse(String, Int16 ) | Parse a string into an Online Int16 value
 | TryParse(String, Int32 ) | Parse a string into an Online Int32 value
 | TryParse(String, Int64 ) | Parse a string into an Online Int64 value
Back to Top
See Also
SystemInfo Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.AssemblyFileName Method

SystemInfo AssemblyFileName Method Apache log4net™ SDK Documentation
Gets the file name portion of the Online Assembly, including the extension.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string AssemblyFileName(
    Assembly myAssembly
)
public static string AssemblyFileName(
    Assembly myAssembly
)
Public Shared Function AssemblyFileName (
    myAssembly As Assembly
) As String
Public Shared Function AssemblyFileName (
    myAssembly As Assembly
) As String
public:
static String^ AssemblyFileName(
    Assembly^ myAssembly
)
public:
static String^ AssemblyFileName(
    Assembly^ myAssembly
)
Parameters
myAssembly
Type:   Online System.Reflection Assembly
The   Online Assembly to get the file name for.
Return Value
Type:   Online String
The file name of the assembly.
Remarks

            Gets the file name portion of the   Online Assembly, including the extension.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.AssemblyLocationInfo Method

SystemInfo AssemblyLocationInfo Method Apache log4net™ SDK Documentation
Gets the assembly location path for the specified assembly.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string AssemblyLocationInfo(
    Assembly myAssembly
)
public static string AssemblyLocationInfo(
    Assembly myAssembly
)
Public Shared Function AssemblyLocationInfo (
    myAssembly As Assembly
) As String
Public Shared Function AssemblyLocationInfo (
    myAssembly As Assembly
) As String
public:
static String^ AssemblyLocationInfo(
    Assembly^ myAssembly
)
public:
static String^ AssemblyLocationInfo(
    Assembly^ myAssembly
)
Parameters
myAssembly
Type:   Online System.Reflection Assembly
The assembly to get the location for.
Return Value
Type:   Online String
The location of the assembly.
Remarks

            This method does not guarantee to return the correct path
            to the assembly. If only tries to give an indication as to
            where the assembly was loaded from.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.AssemblyQualifiedName Method

SystemInfo AssemblyQualifiedName Method Apache log4net™ SDK Documentation
Gets the fully qualified name of the Online Type, including the name of the assembly from which the Online Type was loaded.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string AssemblyQualifiedName(
    Type type
)
public static string AssemblyQualifiedName(
    Type type
)
Public Shared Function AssemblyQualifiedName (
    type As Type
) As String
Public Shared Function AssemblyQualifiedName (
    type As Type
) As String
public:
static String^ AssemblyQualifiedName(
    Type^ type
)
public:
static String^ AssemblyQualifiedName(
    Type^ type
)
Parameters
type
Type:   Online System Type
The   Online Type to get the fully qualified name for.
Return Value
Type:   Online String
The fully qualified name for the   Online Type.
Remarks

            This is equivalent to the Type.AssemblyQualifiedName property,
            but this method works on the .NET Compact Framework 1.0 as well as
            the full .NET runtime.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.AssemblyShortName Method

SystemInfo AssemblyShortName Method Apache log4net™ SDK Documentation
Gets the short name of the Online Assembly.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string AssemblyShortName(
    Assembly myAssembly
)
public static string AssemblyShortName(
    Assembly myAssembly
)
Public Shared Function AssemblyShortName (
    myAssembly As Assembly
) As String
Public Shared Function AssemblyShortName (
    myAssembly As Assembly
) As String
public:
static String^ AssemblyShortName(
    Assembly^ myAssembly
)
public:
static String^ AssemblyShortName(
    Assembly^ myAssembly
)
Parameters
myAssembly
Type:   Online System.Reflection Assembly
The   Online Assembly to get the name for.
Return Value
Type:   Online String
The short name of the   Online Assembly.
Remarks

            The short name of the assembly is the   Online FullName
            without the version, culture, or public key. i.e. it is just the
            assembly's file name without the extension.

            Use this rather than Assembly.GetName().Name because that
            is not available on the Compact Framework.

            Because of a FileIOPermission security demand we cannot do
            the obvious Assembly.GetName().Name. We are allowed to get
            the   Online FullName of the assembly so we
            start from there and strip out just the assembly name.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.ConvertToFullPath Method

SystemInfo ConvertToFullPath Method Apache log4net™ SDK Documentation
Convert a path into a fully qualified local file path.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ConvertToFullPath(
    string path
)
public static string ConvertToFullPath(
    string path
)
Public Shared Function ConvertToFullPath (
    path As String
) As String
Public Shared Function ConvertToFullPath (
    path As String
) As String
public:
static String^ ConvertToFullPath(
    String^ path
)
public:
static String^ ConvertToFullPath(
    String^ path
)
Parameters
path
Type:   Online System String
The path to convert.
Return Value
Type:   Online String
The fully qualified path.
Remarks

            Converts the path specified to a fully
            qualified path. If the path is relative it is
            taken as relative from the application base
            directory.

            The path specified must be a local file path, a URI is not supported.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.CreateArgumentOutOfRangeException Method

SystemInfo CreateArgumentOutOfRangeException Method Apache log4net™ SDK Documentation
Create an Online ArgumentOutOfRangeException

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ArgumentOutOfRangeException CreateArgumentOutOfRangeException(
    string parameterName,
    Object actualValue,
    string message
)
public static ArgumentOutOfRangeException CreateArgumentOutOfRangeException(
    string parameterName,
    Object actualValue,
    string message
)
Public Shared Function CreateArgumentOutOfRangeException (
    parameterName As String,
    actualValue As Object,
    message As String
) As ArgumentOutOfRangeException
Public Shared Function CreateArgumentOutOfRangeException (
    parameterName As String,
    actualValue As Object,
    message As String
) As ArgumentOutOfRangeException
public:
static ArgumentOutOfRangeException^ CreateArgumentOutOfRangeException(
    String^ parameterName,
    Object^ actualValue,
    String^ message
)
public:
static ArgumentOutOfRangeException^ CreateArgumentOutOfRangeException(
    String^ parameterName,
    Object^ actualValue,
    String^ message
)
Parameters
parameterName
Type:   Online System String
The name of the parameter that caused the exception
actualValue
Type:   Online System Object
The value of the argument that causes this exception
message
Type:   Online System String
The message that describes the error
Return Value
Type:   Online ArgumentOutOfRangeException
the ArgumentOutOfRangeException object
Remarks

            Create a new instance of the   Online ArgumentOutOfRangeException class
            with a specified error message, the parameter name, and the value
            of the argument.

            The Compact Framework does not support the 3 parameter constructor for the
              Online ArgumentOutOfRangeException type. This method provides an
            implementation that works for all platforms.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.CreateCaseInsensitiveHashtable Method

SystemInfo CreateCaseInsensitiveHashtable Method Apache log4net™ SDK Documentation
Creates a new case-insensitive instance of the Online Hashtable class with the default initial capacity.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Hashtable CreateCaseInsensitiveHashtable()
public static Hashtable CreateCaseInsensitiveHashtable()
Public Shared Function CreateCaseInsensitiveHashtable As Hashtable
Public Shared Function CreateCaseInsensitiveHashtable As Hashtable
public:
static Hashtable^ CreateCaseInsensitiveHashtable()
public:
static Hashtable^ CreateCaseInsensitiveHashtable()
Return Value
Type:   Online Hashtable
A new case-insensitive instance of the   Online Hashtable class with the default initial capacity
Remarks

            The new Hashtable instance uses the default load factor, the CaseInsensitiveHashCodeProvider, and the CaseInsensitiveComparer.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.GetAppSetting Method

SystemInfo GetAppSetting Method Apache log4net™ SDK Documentation
Lookup an application setting

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetAppSetting(
    string key
)
public static string GetAppSetting(
    string key
)
Public Shared Function GetAppSetting (
    key As String
) As String
Public Shared Function GetAppSetting (
    key As String
) As String
public:
static String^ GetAppSetting(
    String^ key
)
public:
static String^ GetAppSetting(
    String^ key
)
Parameters
key
Type:   Online System String
the application settings key to lookup
Return Value
Type:   Online String
the value for the key, or null
Remarks

            Configuration APIs are not supported under the Compact Framework

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.GetTypeFromString Method

SystemInfo GetTypeFromString Method Apache log4net™ SDK Documentation
Overload List
Name | Description
GetTypeFromString(String, Boolean, Boolean) | Loads the type specified in the type string.
GetTypeFromString(Assembly, String, Boolean, Boolean) | Loads the type specified in the type string.
GetTypeFromString(Type, String, Boolean, Boolean) | Loads the type specified in the type string.
Back to Top
See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.GetTypeFromString Method (String, Boolean, Boolean)

SystemInfo GetTypeFromString Method (String, Boolean, Boolean) Apache log4net™ SDK Documentation
Loads the type specified in the type string.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Type GetTypeFromString(
    string typeName,
    bool throwOnError,
    bool ignoreCase
)
public static Type GetTypeFromString(
    string typeName,
    bool throwOnError,
    bool ignoreCase
)
Public Shared Function GetTypeFromString (
    typeName As String,
    throwOnError As Boolean,
    ignoreCase As Boolean
) As Type
Public Shared Function GetTypeFromString (
    typeName As String,
    throwOnError As Boolean,
    ignoreCase As Boolean
) As Type
public:
static Type^ GetTypeFromString(
    String^ typeName,
    bool throwOnError,
    bool ignoreCase
)
public:
static Type^ GetTypeFromString(
    String^ typeName,
    bool throwOnError,
    bool ignoreCase
)
Parameters
typeName
Type:   Online System String
The name of the type to load.
throwOnError
Type:   Online System Boolean
Flag set to true to throw an exception if the type cannot be loaded.
ignoreCase
Type:   Online System Boolean
true to ignore the case of the type name; otherwise, false
Return Value
Type:   Online Type
The type loaded or null if it could not be loaded.
Remarks

            If the type name is fully qualified, i.e. if contains an assembly name in
            the type name, the type will be loaded from the system using
            GetType(string, bool).

            If the type name is not fully qualified it will be loaded from the
            assembly that is directly calling this method. If the type is not found
            in the assembly then all the loaded assemblies will be searched for the type.

See Also
SystemInfo Class
SystemInfo Members
GetTypeFromString Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.GetTypeFromString Method (Assembly, String, Boolean, Boolean)

SystemInfo GetTypeFromString Method (Assembly, String, Boolean, Boolean) Apache log4net™ SDK Documentation
Loads the type specified in the type string.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Type GetTypeFromString(
    Assembly relativeAssembly,
    string typeName,
    bool throwOnError,
    bool ignoreCase
)
public static Type GetTypeFromString(
    Assembly relativeAssembly,
    string typeName,
    bool throwOnError,
    bool ignoreCase
)
Public Shared Function GetTypeFromString (
    relativeAssembly As Assembly,
    typeName As String,
    throwOnError As Boolean,
    ignoreCase As Boolean
) As Type
Public Shared Function GetTypeFromString (
    relativeAssembly As Assembly,
    typeName As String,
    throwOnError As Boolean,
    ignoreCase As Boolean
) As Type
public:
static Type^ GetTypeFromString(
    Assembly^ relativeAssembly,
    String^ typeName,
    bool throwOnError,
    bool ignoreCase
)
public:
static Type^ GetTypeFromString(
    Assembly^ relativeAssembly,
    String^ typeName,
    bool throwOnError,
    bool ignoreCase
)
Parameters
relativeAssembly
Type:   Online System.Reflection Assembly
An assembly to load the type from.
typeName
Type:   Online System String
The name of the type to load.
throwOnError
Type:   Online System Boolean
Flag set to true to throw an exception if the type cannot be loaded.
ignoreCase
Type:   Online System Boolean
true to ignore the case of the type name; otherwise, false
Return Value
Type:   Online Type
The type loaded or null if it could not be loaded.
Remarks

            If the type name is fully qualified, i.e. if contains an assembly name in
            the type name, the type will be loaded from the system using
            GetType(string, bool).

            If the type name is not fully qualified it will be loaded from the specified
            assembly. If the type is not found in the assembly then all the loaded assemblies
            will be searched for the type.

See Also
SystemInfo Class
SystemInfo Members
GetTypeFromString Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.GetTypeFromString Method (Type, String, Boolean, Boolean)

SystemInfo GetTypeFromString Method (Type, String, Boolean, Boolean) Apache log4net™ SDK Documentation
Loads the type specified in the type string.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Type GetTypeFromString(
    Type relativeType,
    string typeName,
    bool throwOnError,
    bool ignoreCase
)
public static Type GetTypeFromString(
    Type relativeType,
    string typeName,
    bool throwOnError,
    bool ignoreCase
)
Public Shared Function GetTypeFromString (
    relativeType As Type,
    typeName As String,
    throwOnError As Boolean,
    ignoreCase As Boolean
) As Type
Public Shared Function GetTypeFromString (
    relativeType As Type,
    typeName As String,
    throwOnError As Boolean,
    ignoreCase As Boolean
) As Type
public:
static Type^ GetTypeFromString(
    Type^ relativeType,
    String^ typeName,
    bool throwOnError,
    bool ignoreCase
)
public:
static Type^ GetTypeFromString(
    Type^ relativeType,
    String^ typeName,
    bool throwOnError,
    bool ignoreCase
)
Parameters
relativeType
Type:   Online System Type
A sibling type to use to load the type.
typeName
Type:   Online System String
The name of the type to load.
throwOnError
Type:   Online System Boolean
Flag set to true to throw an exception if the type cannot be loaded.
ignoreCase
Type:   Online System Boolean
true to ignore the case of the type name; otherwise, false
Return Value
Type:   Online Type
The type loaded or null if it could not be loaded.
Remarks

            If the type name is fully qualified, i.e. if contains an assembly name in
            the type name, the type will be loaded from the system using
            GetType(string, bool).

            If the type name is not fully qualified, it will be loaded from the assembly
            containing the specified relative type. If the type is not found in the assembly
            then all the loaded assemblies will be searched for the type.

See Also
SystemInfo Class
SystemInfo Members
GetTypeFromString Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.NewGuid Method

SystemInfo NewGuid Method Apache log4net™ SDK Documentation
Generate a new guid

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Guid NewGuid()
public static Guid NewGuid()
Public Shared Function NewGuid As Guid
Public Shared Function NewGuid As Guid
public:
static Guid NewGuid()
public:
static Guid NewGuid()
Return Value
Type:   Online Guid
A new Guid
Remarks

            Generate a new guid

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.TryParse Method

SystemInfo TryParse Method Apache log4net™ SDK Documentation
Overload List
Name | Description
TryParse(String, Int16 ) | Parse a string into an Online Int16 value
TryParse(String, Int32 ) | Parse a string into an Online Int32 value
TryParse(String, Int64 ) | Parse a string into an Online Int64 value
Back to Top
See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.TryParse Method (String, Int16)

SystemInfo TryParse Method (String, Int16 ) Apache log4net™ SDK Documentation
Parse a string into an Online Int16 value

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    string s,
    out short val
)
public static bool TryParse(
    string s,
    out short val
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef val As Short
) As Boolean
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef val As Short
) As Boolean
public:
static bool TryParse(
    String^ s,
    [OutAttribute] short% val
)
public:
static bool TryParse(
    String^ s,
    [OutAttribute] short% val
)
Parameters
s
Type:   Online System String
the string to parse
val
Type:   Online System Int16
out param where the parsed value is placed
Return Value
Type:   Online Boolean
true if the string was able to be parsed into an integer
Remarks

            Attempts to parse the string into an integer. If the string cannot
            be parsed then this method returns false. The method does not throw an exception.

See Also
SystemInfo Class
SystemInfo Members
TryParse Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.TryParse Method (String, Int32)

SystemInfo TryParse Method (String, Int32 ) Apache log4net™ SDK Documentation
Parse a string into an Online Int32 value

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    string s,
    out int val
)
public static bool TryParse(
    string s,
    out int val
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef val As Integer
) As Boolean
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef val As Integer
) As Boolean
public:
static bool TryParse(
    String^ s,
    [OutAttribute] int% val
)
public:
static bool TryParse(
    String^ s,
    [OutAttribute] int% val
)
Parameters
s
Type:   Online System String
the string to parse
val
Type:   Online System Int32
out param where the parsed value is placed
Return Value
Type:   Online Boolean
true if the string was able to be parsed into an integer
Remarks

            Attempts to parse the string into an integer. If the string cannot
            be parsed then this method returns false. The method does not throw an exception.

See Also
SystemInfo Class
SystemInfo Members
TryParse Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.TryParse Method (String, Int64)

SystemInfo TryParse Method (String, Int64 ) Apache log4net™ SDK Documentation
Parse a string into an Online Int64 value

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    string s,
    out long val
)
public static bool TryParse(
    string s,
    out long val
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef val As Long
) As Boolean
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef val As Long
) As Boolean
public:
static bool TryParse(
    String^ s,
    [OutAttribute] long long% val
)
public:
static bool TryParse(
    String^ s,
    [OutAttribute] long long% val
)
Parameters
s
Type:   Online System String
the string to parse
val
Type:   Online System Int64
out param where the parsed value is placed
Return Value
Type:   Online Boolean
true if the string was able to be parsed into an integer
Remarks

            Attempts to parse the string into an integer. If the string cannot
            be parsed then this method returns false. The method does not throw an exception.

See Also
SystemInfo Class
SystemInfo Members
TryParse Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo Properties

SystemInfo Properties Apache log4net™ SDK Documentation
The SystemInfo type exposes the following members.
Properties
Name | Description
ApplicationBaseDirectory | Gets the base directory for this Online AppDomain.
ApplicationFriendlyName | Get this application's friendly name
ConfigurationFileLocation | Gets the path to the configuration file for the current Online AppDomain.
CurrentThreadId | Gets the ID of the current thread.
EntryAssemblyLocation | Gets the path to the file that first executed in the current Online AppDomain.
HostName | Get the host name or machine name for the current machine
NewLine | Gets the system dependent line terminator.
NotAvailableText | Text to output when an unsupported feature is requested.
NullText | Text to output when a null is encountered.
ProcessStartTime | Get the start time for the current process.
Back to Top
See Also
SystemInfo Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.ApplicationBaseDirectory Property

SystemInfo ApplicationBaseDirectory Property Apache log4net™ SDK Documentation
Gets the base directory for this Online AppDomain.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ApplicationBaseDirectory { get; }
public static string ApplicationBaseDirectory { get; }
Public Shared ReadOnly Property ApplicationBaseDirectory As String
    Get
Public Shared ReadOnly Property ApplicationBaseDirectory As String
    Get
public:
static property String^ ApplicationBaseDirectory {
    String^ get ();
}
public:
static property String^ ApplicationBaseDirectory {
    String^ get ();
}
Property Value
Type:   Online String
The base directory path for the current   Online AppDomain.
Remarks

            Gets the base directory for this   Online AppDomain.

            The value returned may be either a local file path or a URI.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.ApplicationFriendlyName Property

SystemInfo ApplicationFriendlyName Property Apache log4net™ SDK Documentation
Get this application's friendly name

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ApplicationFriendlyName { get; }
public static string ApplicationFriendlyName { get; }
Public Shared ReadOnly Property ApplicationFriendlyName As String
    Get
Public Shared ReadOnly Property ApplicationFriendlyName As String
    Get
public:
static property String^ ApplicationFriendlyName {
    String^ get ();
}
public:
static property String^ ApplicationFriendlyName {
    String^ get ();
}
Property Value
Type:   Online String

            The friendly name of this application as a string

Remarks

            If available the name of the application is retrieved from
            the AppDomain using AppDomain.CurrentDomain.FriendlyName.

            Otherwise the file name of the entry assembly is used.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.ConfigurationFileLocation Property

SystemInfo ConfigurationFileLocation Property Apache log4net™ SDK Documentation
Gets the path to the configuration file for the current Online AppDomain.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ConfigurationFileLocation { get; }
public static string ConfigurationFileLocation { get; }
Public Shared ReadOnly Property ConfigurationFileLocation As String
    Get
Public Shared ReadOnly Property ConfigurationFileLocation As String
    Get
public:
static property String^ ConfigurationFileLocation {
    String^ get ();
}
public:
static property String^ ConfigurationFileLocation {
    String^ get ();
}
Property Value
Type:   Online String
The path to the configuration file for the current   Online AppDomain.
Remarks

            The .NET Compact Framework 1.0 does not have a concept of a configuration
            file. For this runtime, we use the entry assembly location as the root for
            the configuration file name.

            The value returned may be either a local file path or a URI.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.CurrentThreadId Property

SystemInfo CurrentThreadId Property Apache log4net™ SDK Documentation
Gets the ID of the current thread.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int CurrentThreadId { get; }
public static int CurrentThreadId { get; }
Public Shared ReadOnly Property CurrentThreadId As Integer
    Get
Public Shared ReadOnly Property CurrentThreadId As Integer
    Get
public:
static property int CurrentThreadId {
    int get ();
}
public:
static property int CurrentThreadId {
    int get ();
}
Property Value
Type:   Online Int32
The ID of the current thread.
Remarks

            On the .NET framework, the AppDomain.GetCurrentThreadId method
            is used to obtain the thread ID for the current thread. This is the
            operating system ID for the thread.

            On the .NET Compact Framework 1.0 it is not possible to get the
            operating system thread ID for the current thread. The native method
            GetCurrentThreadId is implemented inline in a header file
            and cannot be called.

            On the .NET Framework 2.0 the Thread.ManagedThreadId is used as this
            gives a stable id unrelated to the operating system thread ID which may
            change if the runtime is using fibers.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.EntryAssemblyLocation Property

SystemInfo EntryAssemblyLocation Property Apache log4net™ SDK Documentation
Gets the path to the file that first executed in the current Online AppDomain.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string EntryAssemblyLocation { get; }
public static string EntryAssemblyLocation { get; }
Public Shared ReadOnly Property EntryAssemblyLocation As String
    Get
Public Shared ReadOnly Property EntryAssemblyLocation As String
    Get
public:
static property String^ EntryAssemblyLocation {
    String^ get ();
}
public:
static property String^ EntryAssemblyLocation {
    String^ get ();
}
Property Value
Type:   Online String
The path to the entry assembly.
Remarks

            Gets the path to the file that first executed in the current   Online AppDomain.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.HostName Property

SystemInfo HostName Property Apache log4net™ SDK Documentation
Get the host name or machine name for the current machine

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string HostName { get; }
public static string HostName { get; }
Public Shared ReadOnly Property HostName As String
    Get
Public Shared ReadOnly Property HostName As String
    Get
public:
static property String^ HostName {
    String^ get ();
}
public:
static property String^ HostName {
    String^ get ();
}
Property Value
Type:   Online String

            The hostname or machine name

Remarks

            Get the host name or machine name for the current machine

            The host name (  Online GetHostName ) or
            the machine name (Environment.MachineName) for
            the current machine, or if neither of these are available
            then NOT AVAILABLE is returned.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.NewLine Property

SystemInfo NewLine Property Apache log4net™ SDK Documentation
Gets the system dependent line terminator.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string NewLine { get; }
public static string NewLine { get; }
Public Shared ReadOnly Property NewLine As String
    Get
Public Shared ReadOnly Property NewLine As String
    Get
public:
static property String^ NewLine {
    String^ get ();
}
public:
static property String^ NewLine {
    String^ get ();
}
Property Value
Type:   Online String

            The system dependent line terminator.

Remarks

            Gets the system dependent line terminator.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.NotAvailableText Property

SystemInfo NotAvailableText Property Apache log4net™ SDK Documentation
Text to output when an unsupported feature is requested.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string NotAvailableText { get; set; }
public static string NotAvailableText { get; set; }
Public Shared Property NotAvailableText As String
    Get
    Set
Public Shared Property NotAvailableText As String
    Get
    Set
public:
static property String^ NotAvailableText {
    String^ get ();
    void set (String^ value);
}
public:
static property String^ NotAvailableText {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            Use this value when an unsupported feature is requested.

            The default value is NOT AVAILABLE. This value can be overridden by specifying
            a value for the log4net.NotAvailableText appSetting in the application's
            .config file.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.NullText Property

SystemInfo NullText Property Apache log4net™ SDK Documentation
Text to output when a null is encountered.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string NullText { get; set; }
public static string NullText { get; set; }
Public Shared Property NullText As String
    Get
    Set
Public Shared Property NullText As String
    Get
    Set
public:
static property String^ NullText {
    String^ get ();
    void set (String^ value);
}
public:
static property String^ NullText {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
Remarks

            Use this value to indicate a null has been encountered while
            outputting a string representation of an item.

            The default value is (null). This value can be overridden by specifying
            a value for the log4net.NullText appSetting in the application's
            .config file.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemInfo.ProcessStartTime Property

SystemInfo ProcessStartTime Property Apache log4net™ SDK Documentation
Get the start time for the current process.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime ProcessStartTime { get; }
public static DateTime ProcessStartTime { get; }
Public Shared ReadOnly Property ProcessStartTime As DateTime
    Get
Public Shared ReadOnly Property ProcessStartTime As DateTime
    Get
public:
static property DateTime ProcessStartTime {
    DateTime get ();
}
public:
static property DateTime ProcessStartTime {
    DateTime get ();
}
Property Value
Type:   Online DateTime
Remarks

            This is the time at which the log4net library was loaded into the
            AppDomain. Due to reports of a hang in the call to System.Diagnostics.Process.StartTime
            this is not the start time for the current process.

            The log4net library should be loaded by an application early during its
            startup, therefore this start time should be a good approximation for
            the actual start time.

            Note that AppDomains may be loaded and unloaded within the
            same process without the process terminating, however this start time
            will be set per AppDomain.

See Also
SystemInfo Class
SystemInfo Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemStringFormat Class

SystemStringFormat Class Apache log4net™ SDK Documentation
Utility class that represents a format string.
Inheritance Hierarchy
Online System Object
log4net.Util SystemStringFormat

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SystemStringFormat
public sealed class SystemStringFormat
Public NotInheritable Class SystemStringFormat
Public NotInheritable Class SystemStringFormat
public ref class SystemStringFormat sealed
public ref class SystemStringFormat sealed
Remarks

            Utility class that represents a format string.

See Also
SystemStringFormat Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemStringFormat Members

SystemStringFormat Members Apache log4net™ SDK Documentation
The SystemStringFormat type exposes the following members.
Constructors
 | Name | Description
Public method | SystemStringFormat | Initialise the SystemStringFormat
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Format the string and arguments (Overrides Online Object ToString .)
Back to Top
See Also
SystemStringFormat Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemStringFormat Constructor

SystemStringFormat Constructor Apache log4net™ SDK Documentation
Initialise the SystemStringFormat

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SystemStringFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
public SystemStringFormat(
    IFormatProvider provider,
    string format,
    params Object[] args
)
Public Sub New (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
Public Sub New (
    provider As IFormatProvider,
    format As String,
    ParamArray args As Object()
)
public:
SystemStringFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
public:
SystemStringFormat(
    IFormatProvider^ provider,
    String^ format,
    ... array<Object^>^ args
)
Parameters
provider
Type:   Online System IFormatProvider
An   Online IFormatProvider that supplies culture-specific formatting information.
format
Type:   Online System String
A   Online String containing zero or more format items.
args
Type:    Online System Object
An   Online Object array containing zero or more objects to format.
See Also
SystemStringFormat Class
SystemStringFormat Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemStringFormat Methods

SystemStringFormat Methods Apache log4net™ SDK Documentation
The SystemStringFormat type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Format the string and arguments (Overrides Online Object ToString .)
Back to Top
See Also
SystemStringFormat Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


SystemStringFormat.ToString Method

SystemStringFormat ToString Method Apache log4net™ SDK Documentation
Format the string and arguments

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value
Type:   Online String
the formatted string
See Also
SystemStringFormat Class
SystemStringFormat Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter Class

TextWriterAdapter Class Apache log4net™ SDK Documentation
Adapter that extends Online TextWriter and forwards all messages to an instance of Online TextWriter.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO TextWriter
log4net.Util TextWriterAdapter
log4net.Util ProtectCloseTextWriter
log4net.Util QuietTextWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TextWriterAdapter : TextWriter
public abstract class TextWriterAdapter : TextWriter
Public MustInherit Class TextWriterAdapter
    Inherits TextWriter
Public MustInherit Class TextWriterAdapter
    Inherits TextWriter
public ref class TextWriterAdapter abstract : public TextWriter
public ref class TextWriterAdapter abstract : public TextWriter
Remarks

            Adapter that extends   Online TextWriter and forwards all
            messages to an instance of   Online TextWriter.

See Also
TextWriterAdapter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter Members

TextWriterAdapter Members Apache log4net™ SDK Documentation
The TextWriterAdapter type exposes the following members.
Constructors
 | Name | Description
Protected method | TextWriterAdapter | Create an instance of TextWriterAdapter that forwards all messages to a Online TextWriter.
Back to Top
Methods
 | Name | Description
Public method | Close | Closes the writer and releases any system resources associated with the writer (Overrides Online TextWriter Close .)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online TextWriter object. (Inherited from Online TextWriter.)
Protected method | Dispose(Boolean) | Dispose this writer (Overrides Online TextWriter Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Flushes any buffered output (Overrides Online TextWriter Flush .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Write(Char) | Writes a character to the wrapped TextWriter (Overrides Online TextWriter Write(Char).)
Public method | Write(String) | Writes a string to the wrapped TextWriter (Overrides Online TextWriter Write(String).)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Write( Char , Int32, Int32) | Writes a character buffer to the wrapped TextWriter (Overrides Online TextWriter Write( Char , Int32, Int32).)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine | Writes a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char ) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object ) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char , Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
Fields
 | Name | Description
Protected field | Online CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from Online TextWriter.)
Back to Top
Properties
 | Name | Description
Public property | Encoding | The Encoding in which the output is written (Overrides Online TextWriter Encoding.)
Public property | FormatProvider | Gets an object that controls formatting (Overrides Online TextWriter FormatProvider.)
Public property | NewLine | Gets or sets the line terminator string used by the TextWriter (Overrides Online TextWriter NewLine.)
Protected property | Writer | Gets or sets the underlying Online TextWriter.
Back to Top
See Also
TextWriterAdapter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter Constructor

TextWriterAdapter Constructor Apache log4net™ SDK Documentation
Create an instance of TextWriterAdapter that forwards all messages to a Online TextWriter.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TextWriterAdapter(
    TextWriter writer
)
protected TextWriterAdapter(
    TextWriter writer
)
Protected Sub New (
    writer As TextWriter
)
Protected Sub New (
    writer As TextWriter
)
protected:
TextWriterAdapter(
    TextWriter^ writer
)
protected:
TextWriterAdapter(
    TextWriter^ writer
)
Parameters
writer
Type:   Online System.IO TextWriter
The   Online TextWriter to forward to
Remarks

            Create an instance of TextWriterAdapter that forwards all
            messages to a   Online TextWriter.

See Also
TextWriterAdapter Class
TextWriterAdapter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter Fields

TextWriterAdapter Fields Apache log4net™ SDK Documentation
The TextWriterAdapter type exposes the following members.
Fields
 | Name | Description
Protected field | Online CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from Online TextWriter.)
Back to Top
See Also
TextWriterAdapter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter Methods

TextWriterAdapter Methods Apache log4net™ SDK Documentation
The TextWriterAdapter type exposes the following members.
Methods
 | Name | Description
Public method | Close | Closes the writer and releases any system resources associated with the writer (Overrides Online TextWriter Close .)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online TextWriter object. (Inherited from Online TextWriter.)
Protected method | Dispose(Boolean) | Dispose this writer (Overrides Online TextWriter Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Flushes any buffered output (Overrides Online TextWriter Flush .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Write(Char) | Writes a character to the wrapped TextWriter (Overrides Online TextWriter Write(Char).)
Public method | Write(String) | Writes a string to the wrapped TextWriter (Overrides Online TextWriter Write(String).)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Write( Char , Int32, Int32) | Writes a character buffer to the wrapped TextWriter (Overrides Online TextWriter Write( Char , Int32, Int32).)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine | Writes a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char ) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object ) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine( Char , Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
See Also
TextWriterAdapter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter.Close Method

TextWriterAdapter Close Method Apache log4net™ SDK Documentation
Closes the writer and releases any system resources associated with the writer

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
Remarks
See Also
TextWriterAdapter Class
TextWriterAdapter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter.Dispose Method

TextWriterAdapter Dispose Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Online Dispose | Releases all resources used by the Online TextWriter object. (Inherited from Online TextWriter.)
Protected method | Dispose(Boolean) | Dispose this writer (Overrides Online TextWriter Dispose(Boolean).)
Back to Top
See Also
TextWriterAdapter Class
TextWriterAdapter Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter.Dispose Method (Boolean)

TextWriterAdapter Dispose Method (Boolean) Apache log4net™ SDK Documentation
Dispose this writer

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
flag indicating if we are being disposed
Remarks

            Dispose this writer

See Also
TextWriterAdapter Class
TextWriterAdapter Members
Dispose Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter.Flush Method

TextWriterAdapter Flush Method Apache log4net™ SDK Documentation
Flushes any buffered output

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
Remarks

            Clears all buffers for the writer and causes any buffered data to be written
            to the underlying device

See Also
TextWriterAdapter Class
TextWriterAdapter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter.Write Method

TextWriterAdapter Write Method Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | Online Write( Char ) | Writes a character array to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from Online TextWriter.)
Public method | Online Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from Online TextWriter.)
Public method | Write(Char) | Writes a character to the wrapped TextWriter (Overrides Online TextWriter Write(Char).)
Public method | Write(String) | Writes a string to the wrapped TextWriter (Overrides Online TextWriter Write(String).)
Public method | Online Write(String, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object ) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Online Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Public method | Write( Char , Int32, Int32) | Writes a character buffer to the wrapped TextWriter (Overrides Online TextWriter Write( Char , Int32, Int32).)
Public method | Online Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Online Format(String, Object). (Inherited from Online TextWriter.)
Back to Top
See Also
TextWriterAdapter Class
TextWriterAdapter Members
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter.Write Method (Char)

TextWriterAdapter Write Method (Char) Apache log4net™ SDK Documentation
Writes a character to the wrapped TextWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    char value
)
public override void Write(
    char value
)
Public Overrides Sub Write (
    value As Char
)
Public Overrides Sub Write (
    value As Char
)
public:
virtual void Write(
    wchar_t value
) override
public:
virtual void Write(
    wchar_t value
) override
Parameters
value
Type:   Online System Char
the value to write to the TextWriter
Remarks

            Writes a character to the wrapped TextWriter

See Also
TextWriterAdapter Class
TextWriterAdapter Members
Write Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter.Write Method (String)

TextWriterAdapter Write Method (String) Apache log4net™ SDK Documentation
Writes a string to the wrapped TextWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    string value
)
public override void Write(
    string value
)
Public Overrides Sub Write (
    value As String
)
Public Overrides Sub Write (
    value As String
)
public:
virtual void Write(
    String^ value
) override
public:
virtual void Write(
    String^ value
) override
Parameters
value
Type:   Online System String
the value to write to the TextWriter
Remarks

            Writes a string to the wrapped TextWriter

See Also
TextWriterAdapter Class
TextWriterAdapter Members
Write Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter.Write Method (Char[], Int32, Int32)

TextWriterAdapter Write Method ( Char , Int32, Int32) Apache log4net™ SDK Documentation
Writes a character buffer to the wrapped TextWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    char[] buffer,
    int index,
    int count
)
public override void Write(
    char[] buffer,
    int index,
    int count
)
Public Overrides Sub Write (
    buffer As Char(),
    index As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Char(),
    index As Integer,
    count As Integer
)
public:
virtual void Write(
    array<wchar_t>^ buffer,
    int index,
    int count
) override
public:
virtual void Write(
    array<wchar_t>^ buffer,
    int index,
    int count
) override
Parameters
buffer
Type:    Online System Char
the data buffer
index
Type:   Online System Int32
the start index
count
Type:   Online System Int32
the number of characters to write
Remarks

            Writes a character buffer to the wrapped TextWriter

See Also
TextWriterAdapter Class
TextWriterAdapter Members
Write Overload
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter Properties

TextWriterAdapter Properties Apache log4net™ SDK Documentation
The TextWriterAdapter type exposes the following members.
Properties
 | Name | Description
Public property | Encoding | The Encoding in which the output is written (Overrides Online TextWriter Encoding.)
Public property | FormatProvider | Gets an object that controls formatting (Overrides Online TextWriter FormatProvider.)
Public property | NewLine | Gets or sets the line terminator string used by the TextWriter (Overrides Online TextWriter NewLine.)
Protected property | Writer | Gets or sets the underlying Online TextWriter.
Back to Top
See Also
TextWriterAdapter Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter.Encoding Property

TextWriterAdapter Encoding Property Apache log4net™ SDK Documentation
The Encoding in which the output is written

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Encoding Encoding { get; }
public override Encoding Encoding { get; }
Public Overrides ReadOnly Property Encoding As Encoding
    Get
Public Overrides ReadOnly Property Encoding As Encoding
    Get
public:
virtual property Encoding^ Encoding {
    Encoding^ get () override;
}
public:
virtual property Encoding^ Encoding {
    Encoding^ get () override;
}
Property Value
Type:   Online Encoding

            The Encoding
Remarks

            The Encoding in which the output is written

See Also
TextWriterAdapter Class
TextWriterAdapter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter.FormatProvider Property

TextWriterAdapter FormatProvider Property Apache log4net™ SDK Documentation
Gets an object that controls formatting

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IFormatProvider FormatProvider { get; }
public override IFormatProvider FormatProvider { get; }
Public Overrides ReadOnly Property FormatProvider As IFormatProvider
    Get
Public Overrides ReadOnly Property FormatProvider As IFormatProvider
    Get
public:
virtual property IFormatProvider^ FormatProvider {
    IFormatProvider^ get () override;
}
public:
virtual property IFormatProvider^ FormatProvider {
    IFormatProvider^ get () override;
}
Property Value
Type:   Online IFormatProvider

            The format provider

Remarks

            Gets an object that controls formatting

See Also
TextWriterAdapter Class
TextWriterAdapter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter.NewLine Property

TextWriterAdapter NewLine Property Apache log4net™ SDK Documentation
Gets or sets the line terminator string used by the TextWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string NewLine { get; set; }
public override string NewLine { get; set; }
Public Overrides Property NewLine As String
    Get
    Set
Public Overrides Property NewLine As String
    Get
    Set
public:
virtual property String^ NewLine {
    String^ get () override;
    void set (String^ value) override;
}
public:
virtual property String^ NewLine {
    String^ get () override;
    void set (String^ value) override;
}
Property Value
Type:   Online String

            The line terminator to use

Remarks

            Gets or sets the line terminator string used by the TextWriter

See Also
TextWriterAdapter Class
TextWriterAdapter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TextWriterAdapter.Writer Property

TextWriterAdapter Writer Property Apache log4net™ SDK Documentation
Gets or sets the underlying Online TextWriter.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TextWriter Writer { get; set; }
protected TextWriter Writer { get; set; }
Protected Property Writer As TextWriter
    Get
    Set
Protected Property Writer As TextWriter
    Get
    Set
protected:
property TextWriter^ Writer {
    TextWriter^ get ();
    void set (TextWriter^ value);
}
protected:
property TextWriter^ Writer {
    TextWriter^ get ();
    void set (TextWriter^ value);
}
Property Value
Type:   Online TextWriter

            The underlying   Online TextWriter.

Remarks

            Gets or sets the underlying   Online TextWriter.

See Also
TextWriterAdapter Class
TextWriterAdapter Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextProperties Class

ThreadContextProperties Class Apache log4net™ SDK Documentation
Implementation of Properties collection for the ThreadContext
Inheritance Hierarchy
Online System Object
log4net.Util ContextPropertiesBase
log4net.Util ThreadContextProperties

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ThreadContextProperties : ContextPropertiesBase
public sealed class ThreadContextProperties : ContextPropertiesBase
Public NotInheritable Class ThreadContextProperties
    Inherits ContextPropertiesBase
Public NotInheritable Class ThreadContextProperties
    Inherits ContextPropertiesBase
public ref class ThreadContextProperties sealed : public ContextPropertiesBase
public ref class ThreadContextProperties sealed : public ContextPropertiesBase
Remarks

            Class implements a collection of properties that is specific to each thread.
            The class is not synchronized as each thread has its own PropertiesDictionary.

See Also
ThreadContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextProperties Members

ThreadContextProperties Members Apache log4net™ SDK Documentation
The ThreadContextProperties type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Clear all properties
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetKeys | Get the keys stored in the properties.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Remove a property
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | Gets or sets the value of a property (Overrides ContextPropertiesBase Item String .)
Back to Top
See Also
ThreadContextProperties Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextProperties Methods

ThreadContextProperties Methods Apache log4net™ SDK Documentation
The ThreadContextProperties type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Clear all properties
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetKeys | Get the keys stored in the properties.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Remove a property
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ThreadContextProperties Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextProperties.Clear Method

ThreadContextProperties Clear Method Apache log4net™ SDK Documentation
Clear all properties

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
Remarks

            Clear all properties

See Also
ThreadContextProperties Class
ThreadContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextProperties.GetKeys Method

ThreadContextProperties GetKeys Method Apache log4net™ SDK Documentation
Get the keys stored in the properties.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string[] GetKeys()
public string[] GetKeys()
Public Function GetKeys As String()
Public Function GetKeys As String()
public:
array<String^>^ GetKeys()
public:
array<String^>^ GetKeys()
Return Value
Type:    Online String
a set of the defined keys
See Also
ThreadContextProperties Class
ThreadContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextProperties.Remove Method

ThreadContextProperties Remove Method Apache log4net™ SDK Documentation
Remove a property

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Remove(
    string key
)
public void Remove(
    string key
)
Public Sub Remove (
    key As String
)
Public Sub Remove (
    key As String
)
public:
void Remove(
    String^ key
)
public:
void Remove(
    String^ key
)
Parameters
key
Type:   Online System String
the key for the entry to remove
Remarks

            Remove a property

See Also
ThreadContextProperties Class
ThreadContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextProperties Properties

ThreadContextProperties Properties Apache log4net™ SDK Documentation
The ThreadContextProperties type exposes the following members.
Properties
 | Name | Description
Public property | Item | Gets or sets the value of a property (Overrides ContextPropertiesBase Item String .)
Back to Top
See Also
ThreadContextProperties Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextProperties.Item Property

ThreadContextProperties Item Property Apache log4net™ SDK Documentation
Gets or sets the value of a property

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object this[
    string key
] { get; set; }
public override Object this[
    string key
] { get; set; }
Public Overrides Default Property Item (
    key As String
) As Object
    Get
    Set
Public Overrides Default Property Item (
    key As String
) As Object
    Get
    Set
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key) override;
    void set (String^ key, Object^ value) override;
}
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key) override;
    void set (String^ key, Object^ value) override;
}
Parameters
key
Type:   Online System String
Property Value
Type:   Online Object

            The value for the property with the specified key

Remarks

            Gets or sets the value of a property

See Also
ThreadContextProperties Class
ThreadContextProperties Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStack Class

ThreadContextStack Class Apache log4net™ SDK Documentation
Implementation of Stack for the ThreadContext
Inheritance Hierarchy
Online System Object
log4net.Util ThreadContextStack

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ThreadContextStack : IFixingRequired
public sealed class ThreadContextStack : IFixingRequired
Public NotInheritable Class ThreadContextStack
    Implements IFixingRequired
Public NotInheritable Class ThreadContextStack
    Implements IFixingRequired
public ref class ThreadContextStack sealed : IFixingRequired
public ref class ThreadContextStack sealed : IFixingRequired
Remarks

            Implementation of Stack for the ThreadContext
See Also
ThreadContextStack Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStack Members

ThreadContextStack Members Apache log4net™ SDK Documentation
The ThreadContextStack type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Clears all the contextual information held in this stack.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Pop | Removes the top context from this stack.
Public method | Push | Pushes a new context message into this stack.
Public method | ToString | Gets the current context information for this stack. (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Count | The number of messages in the stack
Back to Top
See Also
ThreadContextStack Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStack Methods

ThreadContextStack Methods Apache log4net™ SDK Documentation
The ThreadContextStack type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Clears all the contextual information held in this stack.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Pop | Removes the top context from this stack.
Public method | Push | Pushes a new context message into this stack.
Public method | ToString | Gets the current context information for this stack. (Overrides Online Object ToString .)
Back to Top
See Also
ThreadContextStack Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStack.Clear Method

ThreadContextStack Clear Method Apache log4net™ SDK Documentation
Clears all the contextual information held in this stack.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
Remarks

            Clears all the contextual information held in this stack.
            Only call this if you think that this tread is being reused after
            a previous call execution which may not have completed correctly.
            You do not need to use this method if you always guarantee to call
            the   Online Dispose  method of the   Online IDisposable
            returned from Push(String) even in exceptional circumstances,
            for example by using the using(log4net.ThreadContext.Stacks["NDC"].Push("Stack_Message"))
            syntax.

See Also
ThreadContextStack Class
ThreadContextStack Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStack.Pop Method

ThreadContextStack Pop Method Apache log4net™ SDK Documentation
Removes the top context from this stack.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Pop()
public string Pop()
Public Function Pop As String
Public Function Pop As String
public:
String^ Pop()
public:
String^ Pop()
Return Value
Type:   Online String
The message in the context that was removed from the top of this stack.
Remarks

            Remove the top context from this stack, and return
            it to the caller. If this stack is empty then an
            empty string (not  ) is returned.

See Also
ThreadContextStack Class
ThreadContextStack Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStack.Push Method

ThreadContextStack Push Method Apache log4net™ SDK Documentation
Pushes a new context message into this stack.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDisposable Push(
    string message
)
public IDisposable Push(
    string message
)
Public Function Push (
    message As String
) As IDisposable
Public Function Push (
    message As String
) As IDisposable
public:
IDisposable^ Push(
    String^ message
)
public:
IDisposable^ Push(
    String^ message
)
Parameters
message
Type:   Online System String
The new context message.
Return Value
Type:   Online IDisposable

            An   Online IDisposable that can be used to clean up the context stack.

Remarks

            Pushes a new context onto this stack. An   Online IDisposable
            is returned that can be used to clean up this stack. This
            can be easily combined with the using keyword to scope the
            context.

Examples
Simple example of using the Push method with the using keyword.

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
using(log4net.ThreadContext.Stacks["NDC"].Push("Stack_Message"))
{
    log.Warn("This should have an ThreadContext Stack message");
}
using(log4net.ThreadContext.Stacks["NDC"].Push("Stack_Message"))
{
    log.Warn("This should have an ThreadContext Stack message");
}
See Also
ThreadContextStack Class
ThreadContextStack Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStack.ToString Method

ThreadContextStack ToString Method Apache log4net™ SDK Documentation
Gets the current context information for this stack.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value
Type:   Online String
Gets the current context information
Remarks

            Gets the current context information for this stack.

See Also
ThreadContextStack Class
ThreadContextStack Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStack Properties

ThreadContextStack Properties Apache log4net™ SDK Documentation
The ThreadContextStack type exposes the following members.
Properties
 | Name | Description
Public property | Count | The number of messages in the stack
Back to Top
See Also
ThreadContextStack Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStack.Count Property

ThreadContextStack Count Property Apache log4net™ SDK Documentation
The number of messages in the stack

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
Property Value
Type:   Online Int32

            The current number of messages in the stack

Remarks

            The current number of messages in the stack. That is
            the number of times Push(String) has been called
            minus the number of times Pop  has been called.

See Also
ThreadContextStack Class
ThreadContextStack Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStacks Class

ThreadContextStacks Class Apache log4net™ SDK Documentation
Implementation of Stacks collection for the ThreadContext
Inheritance Hierarchy
Online System Object
log4net.Util ThreadContextStacks

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ThreadContextStacks
public sealed class ThreadContextStacks
Public NotInheritable Class ThreadContextStacks
Public NotInheritable Class ThreadContextStacks
public ref class ThreadContextStacks sealed
public ref class ThreadContextStacks sealed
Remarks

            Implementation of Stacks collection for the ThreadContext
See Also
ThreadContextStacks Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStacks Members

ThreadContextStacks Members Apache log4net™ SDK Documentation
The ThreadContextStacks type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | Gets the named thread context stack
Back to Top
See Also
ThreadContextStacks Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStacks Methods

ThreadContextStacks Methods Apache log4net™ SDK Documentation
The ThreadContextStacks type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ThreadContextStacks Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStacks Properties

ThreadContextStacks Properties Apache log4net™ SDK Documentation
The ThreadContextStacks type exposes the following members.
Properties
 | Name | Description
Public property | Item | Gets the named thread context stack
Back to Top
See Also
ThreadContextStacks Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ThreadContextStacks.Item Property

ThreadContextStacks Item Property Apache log4net™ SDK Documentation
Gets the named thread context stack

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ThreadContextStack this[
    string key
] { get; }
public ThreadContextStack this[
    string key
] { get; }
Public ReadOnly Default Property Item (
    key As String
) As ThreadContextStack
    Get
Public ReadOnly Default Property Item (
    key As String
) As ThreadContextStack
    Get
public:
property ThreadContextStack^ default[String^ key] {
    ThreadContextStack^ get (String^ key);
}
public:
property ThreadContextStack^ default[String^ key] {
    ThreadContextStack^ get (String^ key);
}
Parameters
key
Type:   Online System String
Property Value
Type: ThreadContextStack

            The named stack

Remarks

            Gets the named thread context stack

See Also
ThreadContextStacks Class
ThreadContextStacks Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Transform Class

Transform Class Apache log4net™ SDK Documentation
Utility class for transforming strings.
Inheritance Hierarchy
Online System Object
log4net.Util Transform

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Transform
public sealed class Transform
Public NotInheritable Class Transform
Public NotInheritable Class Transform
public ref class Transform sealed
public ref class Transform sealed
Remarks

            Utility class for transforming strings.

See Also
Transform Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Transform Members

Transform Members Apache log4net™ SDK Documentation
The Transform type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | MaskXmlInvalidCharacters | Replace invalid XML characters in text string
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | WriteEscapedXmlString | Write a string to an Online XmlWriter
Back to Top
See Also
Transform Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Transform Methods

Transform Methods Apache log4net™ SDK Documentation
The Transform type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | MaskXmlInvalidCharacters | Replace invalid XML characters in text string
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | WriteEscapedXmlString | Write a string to an Online XmlWriter
Back to Top
See Also
Transform Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Transform.MaskXmlInvalidCharacters Method

Transform MaskXmlInvalidCharacters Method Apache log4net™ SDK Documentation
Replace invalid XML characters in text string

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string MaskXmlInvalidCharacters(
    string textData,
    string mask
)
public static string MaskXmlInvalidCharacters(
    string textData,
    string mask
)
Public Shared Function MaskXmlInvalidCharacters (
    textData As String,
    mask As String
) As String
Public Shared Function MaskXmlInvalidCharacters (
    textData As String,
    mask As String
) As String
public:
static String^ MaskXmlInvalidCharacters(
    String^ textData,
    String^ mask
)
public:
static String^ MaskXmlInvalidCharacters(
    String^ textData,
    String^ mask
)
Parameters
textData
Type:   Online System String
the XML text input string
mask
Type:   Online System String
the string to use in place of invalid characters
Return Value
Type:   Online String
A string that does not contain invalid XML characters.
Remarks

            Certain Unicode code points are not allowed in the XML InfoSet, for
            details see:   Online http://www.w3.org/TR/REC-xml/#charsets.

            This method replaces any illegal characters in the input string
            with the mask string specified.

See Also
Transform Class
Transform Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


Transform.WriteEscapedXmlString Method

Transform WriteEscapedXmlString Method Apache log4net™ SDK Documentation
Write a string to an Online XmlWriter

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteEscapedXmlString(
    XmlWriter writer,
    string textData,
    string invalidCharReplacement
)
public static void WriteEscapedXmlString(
    XmlWriter writer,
    string textData,
    string invalidCharReplacement
)
Public Shared Sub WriteEscapedXmlString (
    writer As XmlWriter,
    textData As String,
    invalidCharReplacement As String
)
Public Shared Sub WriteEscapedXmlString (
    writer As XmlWriter,
    textData As String,
    invalidCharReplacement As String
)
public:
static void WriteEscapedXmlString(
    XmlWriter^ writer,
    String^ textData,
    String^ invalidCharReplacement
)
public:
static void WriteEscapedXmlString(
    XmlWriter^ writer,
    String^ textData,
    String^ invalidCharReplacement
)
Parameters
writer
Type:   Online System.Xml XmlWriter
the writer to write to
textData
Type:   Online System String
the string to write
invalidCharReplacement
Type:   Online System String
The string to replace non XML compliant chars with
Remarks

            The test is escaped either using XML escape entities
            or using CDATA sections.

See Also
Transform Class
Transform Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TwoArgAction(T1, T2) Delegate

TwoArgAction T1, T2 Delegate Apache log4net™ SDK Documentation
Delegate type used for LogicalThreadContextStack's callbacks.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void TwoArgAction<T1, T2>(
    T1 t1,
    T2 t2
)
public delegate void TwoArgAction<T1, T2>(
    T1 t1,
    T2 t2
)
Public Delegate Sub TwoArgAction(Of T1, T2) (
    t1 As T1,
    t2 As T2
)
Public Delegate Sub TwoArgAction(Of T1, T2) (
    t1 As T1,
    t2 As T2
)
generic<typename T1, typename T2>
public delegate void TwoArgAction(
    T1 t1,
    T2 t2
)
generic<typename T1, typename T2>
public delegate void TwoArgAction(
    T1 t1,
    T2 t2
)
Parameters
t1
Type: T1
t2
Type: T2
Type Parameters
T1
[Missing <typeparam name="T1"/> documentation for "T:log4net.Util.TwoArgAction`2"]
T2
[Missing <typeparam name="T2"/> documentation for "T:log4net.Util.TwoArgAction`2"]
See Also
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WindowsSecurityContext Class

WindowsSecurityContext Class Apache log4net™ SDK Documentation
Impersonate a Windows Account
Inheritance Hierarchy
Online System Object
log4net.Core SecurityContext
log4net.Util WindowsSecurityContext

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WindowsSecurityContext : SecurityContext,
    IOptionHandler
public class WindowsSecurityContext : SecurityContext,
    IOptionHandler
Public Class WindowsSecurityContext
    Inherits SecurityContext
    Implements IOptionHandler
Public Class WindowsSecurityContext
    Inherits SecurityContext
    Implements IOptionHandler
public ref class WindowsSecurityContext : public SecurityContext,
    IOptionHandler
public ref class WindowsSecurityContext : public SecurityContext,
    IOptionHandler
Remarks

            This SecurityContext impersonates a Windows account.

            How the impersonation is done depends on the value of Impersonate(Object).
            This allows the context to either impersonate a set of user credentials specified
            using username, domain name and password or to revert to the process credentials.

See Also
WindowsSecurityContext Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WindowsSecurityContext Members

WindowsSecurityContext Members Apache log4net™ SDK Documentation
The WindowsSecurityContext type exposes the following members.
Constructors
 | Name | Description
Public method | WindowsSecurityContext | Default constructor
Back to Top
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the SecurityContext based on the options set.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Impersonate | Impersonate the Windows account specified by the UserName and DomainName properties. (Overrides SecurityContext Impersonate(Object).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the impersonation mode for this security context
Public property | DomainName | Gets or sets the Windows domain name for this security context
Public property | Password | Sets the password for the Windows account specified by the UserName and DomainName properties.
Public property | UserName | Gets or sets the Windows username for this security context
Back to Top
See Also
WindowsSecurityContext Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WindowsSecurityContext Constructor

WindowsSecurityContext Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WindowsSecurityContext()
public WindowsSecurityContext()
Public Sub New
Public Sub New
public:
WindowsSecurityContext()
public:
WindowsSecurityContext()
Remarks

            Default constructor

See Also
WindowsSecurityContext Class
WindowsSecurityContext Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WindowsSecurityContext Methods

WindowsSecurityContext Methods Apache log4net™ SDK Documentation
The WindowsSecurityContext type exposes the following members.
Methods
 | Name | Description
Public method | ActivateOptions | Initialize the SecurityContext based on the options set.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Impersonate | Impersonate the Windows account specified by the UserName and DomainName properties. (Overrides SecurityContext Impersonate(Object).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
WindowsSecurityContext Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WindowsSecurityContext.ActivateOptions Method

WindowsSecurityContext ActivateOptions Method Apache log4net™ SDK Documentation
Initialize the SecurityContext based on the options set.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ActivateOptions()
public void ActivateOptions()
Public Sub ActivateOptions
Public Sub ActivateOptions
public:
virtual void ActivateOptions() sealed
public:
virtual void ActivateOptions() sealed
Implements
IOptionHandler ActivateOptions
Exceptions
Exception | Condition
Online System ArgumentNullException | The required UserName, DomainName or Password properties were not specified.
Remarks

            This is part of the IOptionHandler delayed object
            activation scheme. The ActivateOptions  method must
            be called on this object after the configuration properties have
            been set. Until ActivateOptions  is called this
            object is in an undefined state and must not be used.

            If any of the configuration properties are modified then
            ActivateOptions  must be called again.

            The security context will try to Logon the specified user account and
            capture a primary token for impersonation.

See Also
WindowsSecurityContext Class
WindowsSecurityContext Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WindowsSecurityContext.Impersonate Method

WindowsSecurityContext Impersonate Method Apache log4net™ SDK Documentation
Impersonate the Windows account specified by the UserName and DomainName properties.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IDisposable Impersonate(
    Object state
)
public override IDisposable Impersonate(
    Object state
)
Public Overrides Function Impersonate (
    state As Object
) As IDisposable
Public Overrides Function Impersonate (
    state As Object
) As IDisposable
public:
virtual IDisposable^ Impersonate(
    Object^ state
) override
public:
virtual IDisposable^ Impersonate(
    Object^ state
) override
Parameters
state
Type:   Online System Object
caller provided state
Return Value
Type:   Online IDisposable

            An   Online IDisposable instance that will revoke the impersonation of this SecurityContext

Remarks

            Depending on the Credentials property either
            impersonate a user using credentials supplied or revert
            to the process credentials.

See Also
WindowsSecurityContext Class
WindowsSecurityContext Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WindowsSecurityContext Properties

WindowsSecurityContext Properties Apache log4net™ SDK Documentation
The WindowsSecurityContext type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Gets or sets the impersonation mode for this security context
Public property | DomainName | Gets or sets the Windows domain name for this security context
Public property | Password | Sets the password for the Windows account specified by the UserName and DomainName properties.
Public property | UserName | Gets or sets the Windows username for this security context
Back to Top
See Also
WindowsSecurityContext Class
log4net.Util Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WindowsSecurityContext.Credentials Property

WindowsSecurityContext Credentials Property Apache log4net™ SDK Documentation
Gets or sets the impersonation mode for this security context

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WindowsSecurityContext..::..ImpersonationMode Credentials { get; set; }
public WindowsSecurityContext..::..ImpersonationMode Credentials { get; set; }
Public Property Credentials As WindowsSecurityContext..::..ImpersonationMode
    Get
    Set
Public Property Credentials As WindowsSecurityContext..::..ImpersonationMode
    Get
    Set
public:
property WindowsSecurityContext..::..ImpersonationMode Credentials {
    WindowsSecurityContext..::..ImpersonationMode get ();
    void set (WindowsSecurityContext..::..ImpersonationMode value);
}
public:
property WindowsSecurityContext..::..ImpersonationMode Credentials {
    WindowsSecurityContext..::..ImpersonationMode get ();
    void set (WindowsSecurityContext..::..ImpersonationMode value);
}
Property Value
Type: WindowsSecurityContext ImpersonationMode

            The impersonation mode for this security context

Remarks

            Impersonate either a user with user credentials or
            revert this thread to the credentials of the process.
            The value is one of the WindowsSecurityContext ImpersonationMode
            enum.

            The default value is User

            When the mode is set to User
            the user's credentials are established using the
            UserName, DomainName and Password
            values.

            When the mode is set to Process
            no other properties need to be set. If the calling thread is
            impersonating then it will be reverted back to the process credentials.

See Also
WindowsSecurityContext Class
WindowsSecurityContext Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WindowsSecurityContext.DomainName Property

WindowsSecurityContext DomainName Property Apache log4net™ SDK Documentation
Gets or sets the Windows domain name for this security context

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DomainName { get; set; }
public string DomainName { get; set; }
Public Property DomainName As String
    Get
    Set
Public Property DomainName As String
    Get
    Set
public:
property String^ DomainName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DomainName {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The Windows domain name for this security context

Remarks

            The default value for DomainName is the local machine name
            taken from the   Online MachineName property.

            This property must be set if Credentials
            is set to User (the default setting).

See Also
WindowsSecurityContext Class
WindowsSecurityContext Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WindowsSecurityContext.Password Property

WindowsSecurityContext Password Property Apache log4net™ SDK Documentation
Sets the password for the Windows account specified by the UserName and DomainName properties.

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Password { set; }
public string Password { set; }
Public WriteOnly Property Password As String
    Set
Public WriteOnly Property Password As String
    Set
public:
property String^ Password {
    void set (String^ value);
}
public:
property String^ Password {
    void set (String^ value);
}
Property Value
Type:   Online String

            The password for the Windows account specified by the UserName and DomainName properties.

Remarks

            This property must be set if Credentials
            is set to User (the default setting).

See Also
WindowsSecurityContext Class
WindowsSecurityContext Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WindowsSecurityContext.UserName Property

WindowsSecurityContext UserName Property Apache log4net™ SDK Documentation
Gets or sets the Windows username for this security context

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UserName { get; set; }
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The Windows username for this security context

Remarks

            This property must be set if Credentials
            is set to User (the default setting).

See Also
WindowsSecurityContext Class
WindowsSecurityContext Members
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


WindowsSecurityContext.ImpersonationMode Enumeration

WindowsSecurityContext ImpersonationMode Enumeration Apache log4net™ SDK Documentation
The impersonation modes for the WindowsSecurityContext

Namespace: log4net.Util
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ImpersonationMode
public enum ImpersonationMode
Public Enumeration ImpersonationMode
Public Enumeration ImpersonationMode
public enum class ImpersonationMode
public enum class ImpersonationMode
Members
Member name | Value | Description
User | 0 | Impersonate a user using the credentials supplied
Process | 1 | Revert this the thread to the credentials of the process
Remarks

            See the Credentials property for
            details.

See Also
log4net.Util Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


log4net.Util.TypeConverters Namespace

log4net.Util.TypeConverters Namespace Apache log4net™ SDK Documentation
Classes
 | Class | Description
Public class | ConversionNotSupportedException | Exception base type for conversion errors.
Public class | ConverterRegistry | Register of type converters for specific types.
Public class | TypeConverterAttribute | Attribute used to associate a type converter
Interfaces
 | Interface | Description
Public interface | IConvertFrom | Interface supported by type converters
Public interface | IConvertTo | Interface supported by type converters

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConversionNotSupportedException Class

ConversionNotSupportedException Class Apache log4net™ SDK Documentation
Exception base type for conversion errors.
Inheritance Hierarchy
Online System Object
Online System Exception
Online System ApplicationException
log4net.Util.TypeConverters ConversionNotSupportedException

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ConversionNotSupportedException : ApplicationException
[SerializableAttribute]
public class ConversionNotSupportedException : ApplicationException
<SerializableAttribute>
Public Class ConversionNotSupportedException
    Inherits ApplicationException
<SerializableAttribute>
Public Class ConversionNotSupportedException
    Inherits ApplicationException
[SerializableAttribute]
public ref class ConversionNotSupportedException : public ApplicationException
[SerializableAttribute]
public ref class ConversionNotSupportedException : public ApplicationException
Remarks

            This type extends   Online ApplicationException. It
            does not add any new functionality but does differentiate the
            type of exception being thrown.

See Also
ConversionNotSupportedException Members
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConversionNotSupportedException Members

ConversionNotSupportedException Members Apache log4net™ SDK Documentation
The ConversionNotSupportedException type exposes the following members.
Constructors
 | Name | Description
Public method | ConversionNotSupportedException | Constructor
Public method | ConversionNotSupportedException(String) | Constructor
Protected method | ConversionNotSupportedException(SerializationInfo, StreamingContext) | Serialization constructor
Public method | ConversionNotSupportedException(String, Exception) | Constructor
Back to Top
Methods
 | Name | Description
 | Create(Type, Object) | Creates a new instance of the ConversionNotSupportedException class.
 | Create(Type, Object, Exception) | Creates a new instance of the ConversionNotSupportedException class.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ConversionNotSupportedException Class
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConversionNotSupportedException Constructor

ConversionNotSupportedException Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | ConversionNotSupportedException | Constructor
Public method | ConversionNotSupportedException(String) | Constructor
Protected method | ConversionNotSupportedException(SerializationInfo, StreamingContext) | Serialization constructor
Public method | ConversionNotSupportedException(String, Exception) | Constructor
Back to Top
See Also
ConversionNotSupportedException Class
ConversionNotSupportedException Members
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConversionNotSupportedException Constructor

ConversionNotSupportedException Constructor Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConversionNotSupportedException()
public ConversionNotSupportedException()
Public Sub New
Public Sub New
public:
ConversionNotSupportedException()
public:
ConversionNotSupportedException()
Remarks

            Initializes a new instance of the ConversionNotSupportedException class.

See Also
ConversionNotSupportedException Class
ConversionNotSupportedException Members
ConversionNotSupportedException Overload
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConversionNotSupportedException Constructor (String)

ConversionNotSupportedException Constructor (String) Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConversionNotSupportedException(
    string message
)
public ConversionNotSupportedException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
ConversionNotSupportedException(
    String^ message
)
public:
ConversionNotSupportedException(
    String^ message
)
Parameters
message
Type:   Online System String
A message to include with the exception.
Remarks

            Initializes a new instance of the ConversionNotSupportedException class
            with the specified message.

See Also
ConversionNotSupportedException Class
ConversionNotSupportedException Members
ConversionNotSupportedException Overload
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConversionNotSupportedException Constructor (SerializationInfo, StreamingContext)

ConversionNotSupportedException Constructor (SerializationInfo, StreamingContext) Apache log4net™ SDK Documentation
Serialization constructor

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ConversionNotSupportedException(
    SerializationInfo info,
    StreamingContext context
)
protected ConversionNotSupportedException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ConversionNotSupportedException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ConversionNotSupportedException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The   Online SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type:   Online System.Runtime.Serialization StreamingContext
The   Online StreamingContext that contains contextual information about the source or destination.
Remarks

            Initializes a new instance of the ConversionNotSupportedException class
            with serialized data.

See Also
ConversionNotSupportedException Class
ConversionNotSupportedException Members
ConversionNotSupportedException Overload
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConversionNotSupportedException Constructor (String, Exception)

ConversionNotSupportedException Constructor (String, Exception) Apache log4net™ SDK Documentation
Constructor

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConversionNotSupportedException(
    string message,
    Exception innerException
)
public ConversionNotSupportedException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
Public Sub New (
    message As String,
    innerException As Exception
)
public:
ConversionNotSupportedException(
    String^ message,
    Exception^ innerException
)
public:
ConversionNotSupportedException(
    String^ message,
    Exception^ innerException
)
Parameters
message
Type:   Online System String
A message to include with the exception.
innerException
Type:   Online System Exception
A nested exception to include.
Remarks

            Initializes a new instance of the ConversionNotSupportedException class
            with the specified message and inner exception.

See Also
ConversionNotSupportedException Class
ConversionNotSupportedException Members
ConversionNotSupportedException Overload
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConversionNotSupportedException Methods

ConversionNotSupportedException Methods Apache log4net™ SDK Documentation
The ConversionNotSupportedException type exposes the following members.
Methods
 | Name | Description
 | Create(Type, Object) | Creates a new instance of the ConversionNotSupportedException class.
 | Create(Type, Object, Exception) | Creates a new instance of the ConversionNotSupportedException class.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ConversionNotSupportedException Class
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConversionNotSupportedException.Create Method

ConversionNotSupportedException Create Method Apache log4net™ SDK Documentation
Overload List
Name | Description
Create(Type, Object) | Creates a new instance of the ConversionNotSupportedException class.
Create(Type, Object, Exception) | Creates a new instance of the ConversionNotSupportedException class.
Back to Top
See Also
ConversionNotSupportedException Class
ConversionNotSupportedException Members
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConversionNotSupportedException.Create Method (Type, Object)

ConversionNotSupportedException Create Method (Type, Object) Apache log4net™ SDK Documentation
Creates a new instance of the ConversionNotSupportedException class.

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ConversionNotSupportedException Create(
    Type destinationType,
    Object sourceValue
)
public static ConversionNotSupportedException Create(
    Type destinationType,
    Object sourceValue
)
Public Shared Function Create (
    destinationType As Type,
    sourceValue As Object
) As ConversionNotSupportedException
Public Shared Function Create (
    destinationType As Type,
    sourceValue As Object
) As ConversionNotSupportedException
public:
static ConversionNotSupportedException^ Create(
    Type^ destinationType,
    Object^ sourceValue
)
public:
static ConversionNotSupportedException^ Create(
    Type^ destinationType,
    Object^ sourceValue
)
Parameters
destinationType
Type:   Online System Type
The conversion destination type.
sourceValue
Type:   Online System Object
The value to convert.
Return Value
Type: ConversionNotSupportedException
An instance of the ConversionNotSupportedException.
Remarks

            Creates a new instance of the ConversionNotSupportedException class.

See Also
ConversionNotSupportedException Class
ConversionNotSupportedException Members
Create Overload
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConversionNotSupportedException.Create Method (Type, Object, Exception)

ConversionNotSupportedException Create Method (Type, Object, Exception) Apache log4net™ SDK Documentation
Creates a new instance of the ConversionNotSupportedException class.

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ConversionNotSupportedException Create(
    Type destinationType,
    Object sourceValue,
    Exception innerException
)
public static ConversionNotSupportedException Create(
    Type destinationType,
    Object sourceValue,
    Exception innerException
)
Public Shared Function Create (
    destinationType As Type,
    sourceValue As Object,
    innerException As Exception
) As ConversionNotSupportedException
Public Shared Function Create (
    destinationType As Type,
    sourceValue As Object,
    innerException As Exception
) As ConversionNotSupportedException
public:
static ConversionNotSupportedException^ Create(
    Type^ destinationType,
    Object^ sourceValue,
    Exception^ innerException
)
public:
static ConversionNotSupportedException^ Create(
    Type^ destinationType,
    Object^ sourceValue,
    Exception^ innerException
)
Parameters
destinationType
Type:   Online System Type
The conversion destination type.
sourceValue
Type:   Online System Object
The value to convert.
innerException
Type:   Online System Exception
A nested exception to include.
Return Value
Type: ConversionNotSupportedException
An instance of the ConversionNotSupportedException.
Remarks

            Creates a new instance of the ConversionNotSupportedException class.

See Also
ConversionNotSupportedException Class
ConversionNotSupportedException Members
Create Overload
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConversionNotSupportedException Properties

ConversionNotSupportedException Properties Apache log4net™ SDK Documentation
The ConversionNotSupportedException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ConversionNotSupportedException Class
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterRegistry Class

ConverterRegistry Class Apache log4net™ SDK Documentation
Register of type converters for specific types.
Inheritance Hierarchy
Online System Object
log4net.Util.TypeConverters ConverterRegistry

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ConverterRegistry
public sealed class ConverterRegistry
Public NotInheritable Class ConverterRegistry
Public NotInheritable Class ConverterRegistry
public ref class ConverterRegistry sealed
public ref class ConverterRegistry sealed
Remarks

            Maintains a registry of type converters used to convert between
            types.

            Use the [M:AddConverter(Type, object)] and
            [M:AddConverter(Type, Type)] methods to register new converters.
            The GetConvertTo(Type, Type) and GetConvertFrom(Type) methods
            lookup appropriate converters to use.

See Also
ConverterRegistry Members
log4net.Util.TypeConverters Namespace
log4net.Util.TypeConverters IConvertFrom
log4net.Util.TypeConverters IConvertTo
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterRegistry Members

ConverterRegistry Members Apache log4net™ SDK Documentation
The ConverterRegistry type exposes the following members.
Methods
 | Name | Description
 | AddConverter(Type, Object) | Adds a converter for a specific type.
 | AddConverter(Type, Type) | Adds a converter for a specific type.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetConvertFrom | Gets the type converter to use to convert values to the destination type.
 | GetConvertTo | Gets the type converter to use to convert values to the destination type.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ConverterRegistry Class
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterRegistry Methods

ConverterRegistry Methods Apache log4net™ SDK Documentation
The ConverterRegistry type exposes the following members.
Methods
 | Name | Description
 | AddConverter(Type, Object) | Adds a converter for a specific type.
 | AddConverter(Type, Type) | Adds a converter for a specific type.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetConvertFrom | Gets the type converter to use to convert values to the destination type.
 | GetConvertTo | Gets the type converter to use to convert values to the destination type.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ConverterRegistry Class
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterRegistry.AddConverter Method

ConverterRegistry AddConverter Method Apache log4net™ SDK Documentation
Overload List
Name | Description
AddConverter(Type, Object) | Adds a converter for a specific type.
AddConverter(Type, Type) | Adds a converter for a specific type.
Back to Top
See Also
ConverterRegistry Class
ConverterRegistry Members
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterRegistry.AddConverter Method (Type, Object)

ConverterRegistry AddConverter Method (Type, Object) Apache log4net™ SDK Documentation
Adds a converter for a specific type.

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AddConverter(
    Type destinationType,
    Object converter
)
public static void AddConverter(
    Type destinationType,
    Object converter
)
Public Shared Sub AddConverter (
    destinationType As Type,
    converter As Object
)
Public Shared Sub AddConverter (
    destinationType As Type,
    converter As Object
)
public:
static void AddConverter(
    Type^ destinationType,
    Object^ converter
)
public:
static void AddConverter(
    Type^ destinationType,
    Object^ converter
)
Parameters
destinationType
Type:   Online System Type
The type being converted to.
converter
Type:   Online System Object
The type converter to use to convert to the destination type.
Remarks

            Adds a converter instance for a specific type.

See Also
ConverterRegistry Class
ConverterRegistry Members
AddConverter Overload
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterRegistry.AddConverter Method (Type, Type)

ConverterRegistry AddConverter Method (Type, Type) Apache log4net™ SDK Documentation
Adds a converter for a specific type.

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AddConverter(
    Type destinationType,
    Type converterType
)
public static void AddConverter(
    Type destinationType,
    Type converterType
)
Public Shared Sub AddConverter (
    destinationType As Type,
    converterType As Type
)
Public Shared Sub AddConverter (
    destinationType As Type,
    converterType As Type
)
public:
static void AddConverter(
    Type^ destinationType,
    Type^ converterType
)
public:
static void AddConverter(
    Type^ destinationType,
    Type^ converterType
)
Parameters
destinationType
Type:   Online System Type
The type being converted to.
converterType
Type:   Online System Type
The type of the type converter to use to convert to the destination type.
Remarks

            Adds a converter   Online Type for a specific type.

See Also
ConverterRegistry Class
ConverterRegistry Members
AddConverter Overload
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterRegistry.GetConvertFrom Method

ConverterRegistry GetConvertFrom Method Apache log4net™ SDK Documentation
Gets the type converter to use to convert values to the destination type.

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IConvertFrom GetConvertFrom(
    Type destinationType
)
public static IConvertFrom GetConvertFrom(
    Type destinationType
)
Public Shared Function GetConvertFrom (
    destinationType As Type
) As IConvertFrom
Public Shared Function GetConvertFrom (
    destinationType As Type
) As IConvertFrom
public:
static IConvertFrom^ GetConvertFrom(
    Type^ destinationType
)
public:
static IConvertFrom^ GetConvertFrom(
    Type^ destinationType
)
Parameters
destinationType
Type:   Online System Type
The type being converted to.
Return Value
Type: IConvertFrom

            The type converter instance to use for type conversions or null
            if no type converter is found.

Remarks

            Gets the type converter to use to convert values to the destination type.

See Also
ConverterRegistry Class
ConverterRegistry Members
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


ConverterRegistry.GetConvertTo Method

ConverterRegistry GetConvertTo Method Apache log4net™ SDK Documentation
Gets the type converter to use to convert values to the destination type.

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IConvertTo GetConvertTo(
    Type sourceType,
    Type destinationType
)
public static IConvertTo GetConvertTo(
    Type sourceType,
    Type destinationType
)
Public Shared Function GetConvertTo (
    sourceType As Type,
    destinationType As Type
) As IConvertTo
Public Shared Function GetConvertTo (
    sourceType As Type,
    destinationType As Type
) As IConvertTo
public:
static IConvertTo^ GetConvertTo(
    Type^ sourceType,
    Type^ destinationType
)
public:
static IConvertTo^ GetConvertTo(
    Type^ sourceType,
    Type^ destinationType
)
Parameters
sourceType
Type:   Online System Type
The type being converted from.
destinationType
Type:   Online System Type
The type being converted to.
Return Value
Type: IConvertTo

            The type converter instance to use for type conversions or null
            if no type converter is found.

Remarks

            Gets the type converter to use to convert values to the destination type.

See Also
ConverterRegistry Class
ConverterRegistry Members
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IConvertFrom Interface

IConvertFrom Interface Apache log4net™ SDK Documentation
Interface supported by type converters

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConvertFrom
public interface IConvertFrom
Public Interface IConvertFrom
Public Interface IConvertFrom
public interface class IConvertFrom
public interface class IConvertFrom
Remarks

            This interface supports conversion from arbitrary types
            to a single target type. See TypeConverterAttribute.

See Also
IConvertFrom Members
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IConvertFrom Members

IConvertFrom Members Apache log4net™ SDK Documentation
The IConvertFrom type exposes the following members.
Methods
 | Name | Description
Public method | CanConvertFrom | Can the source type be converted to the type supported by this object
Public method | ConvertFrom | Convert the source object to the type supported by this object
Back to Top
See Also
IConvertFrom Interface
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IConvertFrom Methods

IConvertFrom Methods Apache log4net™ SDK Documentation
The IConvertFrom type exposes the following members.
Methods
 | Name | Description
Public method | CanConvertFrom | Can the source type be converted to the type supported by this object
Public method | ConvertFrom | Convert the source object to the type supported by this object
Back to Top
See Also
IConvertFrom Interface
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IConvertFrom.CanConvertFrom Method

IConvertFrom CanConvertFrom Method Apache log4net™ SDK Documentation
Can the source type be converted to the type supported by this object

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool CanConvertFrom(
    Type sourceType
)
bool CanConvertFrom(
    Type sourceType
)
Function CanConvertFrom (
    sourceType As Type
) As Boolean
Function CanConvertFrom (
    sourceType As Type
) As Boolean
bool CanConvertFrom(
    Type^ sourceType
)
bool CanConvertFrom(
    Type^ sourceType
)
Parameters
sourceType
Type:   Online System Type
the type to convert
Return Value
Type:   Online Boolean
true if the conversion is possible
Remarks

            Test if the sourceType can be converted to the
            type supported by this converter.

See Also
IConvertFrom Interface
IConvertFrom Members
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IConvertFrom.ConvertFrom Method

IConvertFrom ConvertFrom Method Apache log4net™ SDK Documentation
Convert the source object to the type supported by this object

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ConvertFrom(
    Object source
)
Object ConvertFrom(
    Object source
)
Function ConvertFrom (
    source As Object
) As Object
Function ConvertFrom (
    source As Object
) As Object
Object^ ConvertFrom(
    Object^ source
)
Object^ ConvertFrom(
    Object^ source
)
Parameters
source
Type:   Online System Object
the object to convert
Return Value
Type:   Online Object
the converted object
Remarks

            Converts the source to the type supported
            by this converter.

See Also
IConvertFrom Interface
IConvertFrom Members
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IConvertTo Interface

IConvertTo Interface Apache log4net™ SDK Documentation
Interface supported by type converters

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConvertTo
public interface IConvertTo
Public Interface IConvertTo
Public Interface IConvertTo
public interface class IConvertTo
public interface class IConvertTo
Remarks

            This interface supports conversion from a single type to arbitrary types.
            See TypeConverterAttribute.

See Also
IConvertTo Members
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IConvertTo Members

IConvertTo Members Apache log4net™ SDK Documentation
The IConvertTo type exposes the following members.
Methods
 | Name | Description
Public method | CanConvertTo | Returns whether this converter can convert the object to the specified type
Public method | ConvertTo | Converts the given value object to the specified type, using the arguments
Back to Top
See Also
IConvertTo Interface
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IConvertTo Methods

IConvertTo Methods Apache log4net™ SDK Documentation
The IConvertTo type exposes the following members.
Methods
 | Name | Description
Public method | CanConvertTo | Returns whether this converter can convert the object to the specified type
Public method | ConvertTo | Converts the given value object to the specified type, using the arguments
Back to Top
See Also
IConvertTo Interface
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IConvertTo.CanConvertTo Method

IConvertTo CanConvertTo Method Apache log4net™ SDK Documentation
Returns whether this converter can convert the object to the specified type

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool CanConvertTo(
    Type targetType
)
bool CanConvertTo(
    Type targetType
)
Function CanConvertTo (
    targetType As Type
) As Boolean
Function CanConvertTo (
    targetType As Type
) As Boolean
bool CanConvertTo(
    Type^ targetType
)
bool CanConvertTo(
    Type^ targetType
)
Parameters
targetType
Type:   Online System Type
A Type that represents the type you want to convert to
Return Value
Type:   Online Boolean
true if the conversion is possible
Remarks

            Test if the type supported by this converter can be converted to the
            targetType.

See Also
IConvertTo Interface
IConvertTo Members
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


IConvertTo.ConvertTo Method

IConvertTo ConvertTo Method Apache log4net™ SDK Documentation
Converts the given value object to the specified type, using the arguments

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ConvertTo(
    Object source,
    Type targetType
)
Object ConvertTo(
    Object source,
    Type targetType
)
Function ConvertTo (
    source As Object,
    targetType As Type
) As Object
Function ConvertTo (
    source As Object,
    targetType As Type
) As Object
Object^ ConvertTo(
    Object^ source,
    Type^ targetType
)
Object^ ConvertTo(
    Object^ source,
    Type^ targetType
)
Parameters
source
Type:   Online System Object
the object to convert
targetType
Type:   Online System Type
The Type to convert the value parameter to
Return Value
Type:   Online Object
the converted object
Remarks

            Converts the source (which must be of the type supported
            by this converter) to the targetType specified..

See Also
IConvertTo Interface
IConvertTo Members
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TypeConverterAttribute Class

TypeConverterAttribute Class Apache log4net™ SDK Documentation
Attribute used to associate a type converter
Inheritance Hierarchy
Online System Object
Online System Attribute
log4net.Util.TypeConverters TypeConverterAttribute

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TypeConverterAttribute : Attribute
public sealed class TypeConverterAttribute : Attribute
Public NotInheritable Class TypeConverterAttribute
    Inherits Attribute
Public NotInheritable Class TypeConverterAttribute
    Inherits Attribute
public ref class TypeConverterAttribute sealed : public Attribute
public ref class TypeConverterAttribute sealed : public Attribute
Remarks

            Class and Interface level attribute that specifies a type converter
            to use with the associated type.

            To associate a type converter with a target type apply a
            TypeConverterAttribute to the target type. Specify the
            type of the type converter on the attribute.

See Also
TypeConverterAttribute Members
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TypeConverterAttribute Members

TypeConverterAttribute Members Apache log4net™ SDK Documentation
The TypeConverterAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | TypeConverterAttribute | Default constructor
Public method | TypeConverterAttribute(String) | Create a new type converter attribute for the specified type name
Public method | TypeConverterAttribute(Type) | Create a new type converter attribute for the specified type
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ConverterTypeName | The string type name of the type converter
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
TypeConverterAttribute Class
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TypeConverterAttribute Constructor

TypeConverterAttribute Constructor Apache log4net™ SDK Documentation
Overload List
 | Name | Description
Public method | TypeConverterAttribute | Default constructor
Public method | TypeConverterAttribute(String) | Create a new type converter attribute for the specified type name
Public method | TypeConverterAttribute(Type) | Create a new type converter attribute for the specified type
Back to Top
See Also
TypeConverterAttribute Class
TypeConverterAttribute Members
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TypeConverterAttribute Constructor

TypeConverterAttribute Constructor Apache log4net™ SDK Documentation
Default constructor

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeConverterAttribute()
public TypeConverterAttribute()
Public Sub New
Public Sub New
public:
TypeConverterAttribute()
public:
TypeConverterAttribute()
Remarks

            Default constructor

See Also
TypeConverterAttribute Class
TypeConverterAttribute Members
TypeConverterAttribute Overload
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TypeConverterAttribute Constructor (String)

TypeConverterAttribute Constructor (String) Apache log4net™ SDK Documentation
Create a new type converter attribute for the specified type name

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeConverterAttribute(
    string typeName
)
public TypeConverterAttribute(
    string typeName
)
Public Sub New (
    typeName As String
)
Public Sub New (
    typeName As String
)
public:
TypeConverterAttribute(
    String^ typeName
)
public:
TypeConverterAttribute(
    String^ typeName
)
Parameters
typeName
Type:   Online System String
The string type name of the type converter
Remarks

            The type specified must implement the IConvertFrom
            or the IConvertTo interfaces.

See Also
TypeConverterAttribute Class
TypeConverterAttribute Members
TypeConverterAttribute Overload
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TypeConverterAttribute Constructor (Type)

TypeConverterAttribute Constructor (Type) Apache log4net™ SDK Documentation
Create a new type converter attribute for the specified type

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeConverterAttribute(
    Type converterType
)
public TypeConverterAttribute(
    Type converterType
)
Public Sub New (
    converterType As Type
)
Public Sub New (
    converterType As Type
)
public:
TypeConverterAttribute(
    Type^ converterType
)
public:
TypeConverterAttribute(
    Type^ converterType
)
Parameters
converterType
Type:   Online System Type
The type of the type converter
Remarks

            The type specified must implement the IConvertFrom
            or the IConvertTo interfaces.

See Also
TypeConverterAttribute Class
TypeConverterAttribute Members
TypeConverterAttribute Overload
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TypeConverterAttribute Methods

TypeConverterAttribute Methods Apache log4net™ SDK Documentation
The TypeConverterAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TypeConverterAttribute Class
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TypeConverterAttribute Properties

TypeConverterAttribute Properties Apache log4net™ SDK Documentation
The TypeConverterAttribute type exposes the following members.
Properties
 | Name | Description
Public property | ConverterTypeName | The string type name of the type converter
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
TypeConverterAttribute Class
log4net.Util.TypeConverters Namespace

Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.

Online Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)


TypeConverterAttribute.ConverterTypeName Property

TypeConverterAttribute ConverterTypeName Property Apache log4net™ SDK Documentation
The string type name of the type converter

Namespace: log4net.Util.TypeConverters
Assembly: log4net (in log4net.dll) Version: 1.2.14.0 (1.2.14.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ConverterTypeName { get; set; }
public string ConverterTypeName { get; set; }
Public Property ConverterTypeName As String
    Get
    Set
Public Property ConverterTypeName As String
    Get
    Set
public:
property String^ ConverterTypeName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ConverterTypeName {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The string type name of the type converter

Remarks

            The type specified must implement the IConvertFrom
            or the IConvertTo interfaces.

See Also
TypeConverterAttribute Class
TypeConverterAttribute Members
log4net.Util.TypeConverters Namespace
Apache log4net, Apache and log4net are trademarks of The Apache Software Foundation.
  Online
                        Copyright 2004-2015 The Apache Software Foundation (http://logging.apache.org/log4net/)