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Why Social Matters in Business
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1. China — 1.3 billion

2. India — 1.2 billion

4. USA — 310 million

5. Indonesia — 239 million

... it would be the 3" largest in the world!



Defining Social

« Definition: The use of web-based and mobile technologies
to turn communication into interactive dialogue

Connections Facebook

LinkedIn \—/

Google+

M
-~ Twitter

Foursgaure
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Social is Based on the Network

The value of social software increases exponentially when people can connect to
their social networks at anytime and from anywhere allowing users to share and
empowers business professionals to be more innovative and productive

Purpose: Connecting People to People

eyt i Fwnien

Example: Visualization of
LinkedIln Users’ Network




EUrope
ber 2012

Sinsheim, Germany Sth—8th Novem

OpenSocial

opensoctal

* A public specification that defines a component hosting
environment (container)

* A set of common application programming interfaces (APIs)
for web-based applications

* With OpenSocial APl users can access the Social services
from their application easily

 OpenSocial SNS:
http://www.opensocial.org

e Discussion Forums
http://groups.google.com/group/opensocial

For Business

it e e -



OpenSocial Supporting Products
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Thinking

 How to use social services to improve your
productivity when do office documents
editing?

 How to share your document or content to
your social network easily?
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Apache OpenOffice

* An open-source office productivity software suite containing word processor,
spreadsheet, presentation, graphics, formula editor, and database
management applications. It is distributed under the Apache License.

Apache OpenOffice 3
‘E Text Document

g Spreadsheet

Formula

E| & ] Templates...
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OpenSocial Connectors for AOO

* Provide AOO linked value with social and cloud applications.

Connections

* Friendly user interface

e Light to user

Facebook

LinkedIn

Apache OpenOffice”

@

Twitter

opensocial
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Social Services
-IBM Connections
-Facebook
-LinkedIn

YApadhe Chemistry

Apache OpenOffice Extensions
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Output Extensions

«  High Fidelity | . \cl;lew
« Extension API Comment | = Comment £
Task ° Task ‘
l I Upload File
= Get profile Share File ODF Save File
I n Get File = Public to wiki OOXML Edit File
Get Template = Public Blog MS Binary
L 4 / \
opensocial @
Google* Profile, Community, File, wiki, Blog, Activity, Mail 40
MySapce \ ‘ J

IBM Connections Extension
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Sample: IBM Connections Connector

WikiUtil

omis
SERVICE

Provide

SoOMmmon
100)S




Which Is better?
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Dialogs Model Tasks Panel Model

__® OpenOfficeorg  File Edit  View

 Untitled 1 - OpenOffice.org Writer B-EHs [ BS Y Ko
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Demos

« 1.Share your files to others. (Dialog Model)

o 2.Get comments form your network. (Tasks Panel Model)
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How we build this sample

e Tools
- Netbean + OpenOffice API plugin
 http://netbeans.org/downloads/index.html

- Apache OpenOffice SDK
« http://www.openoffice.org/download/sdk/

- AOQO Developer's Guide - Extensions

 http://wiki.openoffice.org/wiki/MediaWiki:Collections/Dev
eloper%27s_Guide - Extensions

- IBM Social SDK Toolkit
» https://greenhouse.lotus.com/llapiexplorer/

- OpenSocial API
 http://www.opensocial.org

- Apache Chemistry CMIS library
 http://chemistry.apache.org


http://netbeans.org/downloads/index.html
http://www.openoffice.org/download/sdk/
http://wiki.openoffice.org/wiki/MediaWiki:Collections/Developer%27s_Guide_-_Extensions
http://wiki.openoffice.org/wiki/MediaWiki:Collections/Developer%27s_Guide_-_Extensions
https://greenhouse.lotus.com/llapiexplorer/IBM
http://www.opensocial.org/
http://chemistry.apache.org/
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Configure your IDE

« Make sure that you have configured a valid OpenOffice.org and
OpenOffice.org SDK installation under Tools > Options >
Miscellaneous > OOo API Plugin

E] NetBeans IDE 6.8 = el | a2 ]
@ w D TH >PBR-@- (@ [Searen e |
sl [z |[EmE = ] =] =]

] Options

@/}.—

-, = %
: &=
General Editor Fonts & Colors Keymap Miscellaneous

| ant | Appearance | Diff | Files | GuI Builder | 1ssue Tracking | Java Debugger | Javascript | Maven | ©O0 AP Flugin | profiler | Tasks | versioning

OpenOffice.org Settings | Log [)1_.|t|:u_.|t|

-

OpenOffice.org API plugin is developed by Sun Microsystem, Inc.

The OpenOffice.org API plugin must be configured when it is used for the first time. Please specify the
. path to a valid OpenOffice.org and a walid OpenOffice.org SDE installation.
<M

> S1412

mik c'as_-,-stems x
Copyright {c) 2007 Sun Microsystems, Inc. All rights reserved.

Use is subject to license terms.

m

COpenOffice.org Settings

OpenOffice.org Installation: {C;\Program Fi-Ies (}(éﬁj‘-l,Dper:lD#hce.org 3

EBrowse

OpenOffice.org SDK Installation: '-C: YProgram Files (x86)\OpenOffice.org 3'\Basis\sdk Browse

[ Export |[ Import ]

[ Ok ][ Cancel ][ Help ]
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Create a OpenOffice Addon Project

e Choose File > New Project > OpenOffice.org > OpenOffice.org
Add-on.

[ E:] MNew Project Iﬁ

Steps Choose Project
1. Choose Project Categories: Projects: ||
T Qb Java f=" 3 CpenCffice, org Add-On
[0} Maven & OpenOffice.org Calc Add-In
' L MetBeans Modules & Dpenﬂgce.nrg Crmpnner;.t g
1, Samples é_:;- OpenOfhce.org Client Application
) OpenOffice.org
Description:
A OpenODifice.org Add-0On i= an external UND component providing one or more functions 5
through the user interface of OpenOffice.org. A typical Add-0On is available as a UMD package
e for easier deployment with the pkgchk tool. In addition to an ordinary UNO package, an Add-0On |:|
- ,?x package contains configuration files which specify the user interface, registration for a protocol
A schema, and first-time instantiation. >
/, i ST -
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Specify the project information.

* The Project name, Main Class Name, with menus / toolbar

 The extension description files and core source file will be

created automatically.
(e . LNNNNRERAL .. ==

[}

Steps Define Add-0n Name and Location

1. Choose Project

2. Define Add-On Name and Project Mame: SodalConnector

Location

3. Define User Commands Main Class Mame: SodalConnector

4.  Create UI structure
Java Package: com.my.sodalconnector
Project Location: C:\Users\IBM_ADMIM\Documents\NetBeansProjects
Project Eolder: C:Wsers\IBM_ADMIM'DocumentsMetBeansProjects\SodalConnector

Create Menu
Create Toolbar

Created Files: srcfcom fexample SocalConnector . java
srcfuno-extension-manifest, xml
registry /dataorgfopenoffice /Office ProtocolHandler. xou
reqgistry /data /orgfopenoffice /O ffice fAddons. xcu

I T

< Back H MNext = Einish Cancel H Help




Define User Commands

« The commands will be used by the Ul.
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Steps Define Functions and Description with Localization
1. Choose Project = ;
= rt Add Command
2. Define Add-On Mame and AddOn i SRR Fi E] [ =
i iles
Location - @  Profiles i [ Delete
Pyl el e )
L 5
4. Create Ul structure £ Icon, High Contrast, E]
Icon, High Contrast, E]
Icon, Low Contrast, E]
Icon, Low Contrast, E]
[=I DisplayMame - Localized Property
English(en} Files ™
Files ]
[ Add Language. ..
[ Delete Language. ..
E;&"\—:.' -
< Back ] [ Mext = Einish Cancel ] [ Help
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Create Ul structure

e Show the Commands in which component

v B B
L] New Project i - LY - @
Steps Define Functions and Description with Localization
1. Choose Project BT "all -y
2. Define Add-On Mame and . .
Location =
Add M
3. Define User Commands AddOn ElProperties = [:] [ cem ]
4. Create UI structure Name iles
= <AddOn Menu =
E' [ Context [ i Sepennic ]
i @ Profiles e
v Bibilography [ Add Command ]
Chart
Database [ Delete ]
Draw
Formula

Presentation
Spreadsheet
Writer
Global

HEEEEEEEE

A
v

-F'tl:es o

< Back ] [ Mext = Einish Cancel ] [ Help
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Configure the classpath for the project.
« Extend project tree > Right Click on Libraries >Add Jar/Folder...

i:] SocialConnector - MetBeans IDE 6.8 b —— - =|E&] ¥ |

File Edit WView Mawvigate Source Refactor Run Debug Profile Team Tools Window Help
']JF_—] % ] -:-‘-';L_-l j::defaultmnﬁg:> v_- ? % [> - @ - éleESearch {Ctrl+I) |

: Projects <0 2 | Files : B
EI@ SocialConnector
-- {8 Source Packages

- | Test Packages

T
Test Libraries

- ] Add JAR/Folder
Lockin: | |, lib - | £§
T T Size 1 Reference as
=5 = :
ko =] asm-util-3.2 jar 356KB . - 55 s B
| HEEEELELE chemistry-opencmis-client-api-0.7.... 295 KB .
- |=| cher'n?str_',r—opencm?s—cl?ent—?}inding... 260 KB |E| Paith Fon Varichie=
: Navigator . |Z| chemistry-opencmis-client-impl-0.7... 124 KB — r - - 3
Desktop 2% chemistry-opencmis-commons-api... 89.2 KB . =no suitable variable > :]
- |2 chemistry-opencmis-commons-im... 445 KB . @ Absolute Path:
£~. |2 chemistry-opencmis-test-tck-0.7.0.jar 154 KB - - -
! |2#| chemistry-opencmis-workbench-0.... 364 KB . T Sechieun=hchenmes ey DR coes; i)
My Docurnents a | m | r
[I-ﬁ’—h-.,'l File name: chemistry-opencmis-dient-api-0.7.0.jar
Computer Files of type: Classpam Entry (folder, ZIP or JAR file)

<no tasks> in all opened projects




Start Coding

« Add your own codes at the main java class
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r‘j SocialConnector - _ .El&u

Eile Edit View Navigate Source Refactor Bun Debug Profile Team Tocols Window Help

R & 5 @ [ehutone

-0 E D@

:[Qr| Search (Cirl+) |

iProj.. 4 ®|:Files RS

£-& SocialConnector
L‘;}--IE Source Packages

[&£]? SocialConnectorjava = |

L= =)

| BR-E- AT FP SR

EX=1

[

a defaul s @ public wvoid dispatch( com.sun.star.util.URL aURL, i
BEB efault package > 56 com. sun.star.beans.PropertyValue[] afrgumen
i description. xml 7@ :
! uno-extension-manifest.ml 58 if ( aURL.Protocol.campareTo ("com.my.socialconnector.socialco
=-E5 com.my.sodalconnector - ‘
' é’""@&Ce”ta'p‘egiwaﬁ"”c'ass'ja“a &0 if ( aURL.Path.compareTo("Profiles") = 0 }
@&SodaIConnector Java a1 :
[#- | f5 TestPackages 62 add vou r own code here H
G- Ubraries [*Y rofilesDialog. Openi) :
-l g TestLibraries £l return:
G- 1 OXT a5 3
L if { aURL.Path.compareTo("File=") == 0 }
. - &7
: dizpatch - Havigator qa = ez ¢ o )
add your own code here
Members View - w ret;rn .
-~ (O dispatch(URL aURL, PropertyValue[] adn - 70 3 :
- (3 getlmplementationName() : String 71 3
- () getSupportedServiceMames() : String[] aa| L N b
- () initialize(Cbject]] object) 4 m *
~ {3 gueryDispatch(URL aURL, String sTarget : Tasks S
- (3 queryDispatches(DispatchDescriptor[] se|= D
- () removeStatuslistener(XStatuslistener x(
- (0 supportsService(String sService) : boole: D
%]] m_implementationMame : String -J <no tasks>
@Tl m_serviceNames : String[] il | P
< | T} = » ['?,]
-
5 o, I E
% @ 45 %ﬁ <no tasks> in all opened projects
| 63117 |Ins
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Test your first Add-on

* Right Click on Project Name > Debug Extension in target OpenOffice.org

[ £2) Untitled 1 - OpenOffice.org Writer ! ESRE=E >k
File Edit Wiew Insert Format Table Tools IAdanMem.lJ Window Help = (1
e Zoo v BER S| Eos h-of - @a-
: Files
lg  Default [~ |Times New Rormam Indiigme -] B 7 U E
El eEeei S aoei e I
L]}
M

—

T : i | L
Pagel /1 | Default | English (USA) |INSRT |sTD | | | | B BA Y | @ — &
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Summary

OpenSocial Connector
- A set of Extensions

- Provide AOO linked value with social and
cloud applications.

- Sample extensions Available at

» http://extensions.openoffice.org/en/project/IBMConnections
» http://extensions.openoffice.org/en/project/smartcloud


http://extensions.openoffice.org/en/project/IBMConnections
http://extensions.openoffice.org/en/project/smartcloud

Sinsheim, Germany Sth—8th Neovember 2012

Configure your IDE

« Make sure that you have configured a valid OpenOffice.org and
OpenOffice.org SDK installation under Tools > Options >
Miscellaneous > OOo API Plugin

E] NetBeans IDE 6.8 = el | a2 ]
@ w D TH >PBR-@- (@ [Searen e |
sl [z |[EmE = ] =] =]

] Options

@/}.—

-, = %
: &=
General Editor Fonts & Colors Keymap Miscellaneous

| ant | Appearance | Diff | Files | GuI Builder | 1ssue Tracking | Java Debugger | Javascript | Maven | ©O0 AP Flugin | profiler | Tasks | versioning

OpenOffice.org Settings | Log [)1_.|t|:u_.|t|

-

OpenOffice.org API plugin is developed by Sun Microsystem, Inc.

The OpenOffice.org API plugin must be configured when it is used for the first time. Please specify the
. path to a valid OpenOffice.org and a walid OpenOffice.org SDE installation.
<M

> S1412

mik c'as_-,-stems x
Copyright {c) 2007 Sun Microsystems, Inc. All rights reserved.

Use is subject to license terms.

m

COpenOffice.org Settings

OpenOffice.org Installation: {C;\Program Fi-Ies (}(éﬁj‘-l,Dper:lD#hce.org 3

EBrowse

OpenOffice.org SDK Installation: '-C: YProgram Files (x86)\OpenOffice.org 3'\Basis\sdk Browse

[ Export |[ Import ]

[ Ok ][ Cancel ][ Help ]
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