Click on the commit message for inspecting the diff
and how the code has been rewritten.
Command line:
svn log -r31996:487 https://svn.osgeo.org/geotools/trunk/modules/library/metadata/src/main/java/org/geotools/util/Utilities.java
Rev. | Date | Author | Message |
---|---|---|---|
30792 | 2008-06-23 | desruisseaux | Synchronized the collections used in metadata. Javadoc cleanup. |
30640 | 2008-06-12 | acuster | Copyright headers: lib/metadata, this time with feeling (and the el in Toolkit) |
30637 | 2008-06-12 | acuster | Copyright headers: lib/metadata, now normalized to LGPL v2.1 only |
30519 | 2008-06-05 | acuster | Metadata header cleanup and copyright review. |
30425 | 2008-05-26 | desruisseaux | Added tip in javadoc about proposed initial seed for hash code calculation. |
30421 | 2008-05-26 | danieler | -fixed typo in Utilities.java--removed superseeded HashCodeUtil.java --removed superseeded EqualsUtil.java |
30313 | 2008-05-16 | desruisseaux | Changed my mind about Utilities.shallowEquals(Object,Object) and renamed it as equals, since a few tests show that the compiler always select the best overloaded flavor working on primitive types (except if an argument is a boolean and the other a different primitive type). Updated a few references. Fixed a few javadoc warnings by explicit declaration of parameter and return values. |
30290 | 2008-05-15 | desruisseaux | Proposed a Utilities class in org.geotools.util in replacement of EqualsUtil and HashCodeUtil and the class in org.geotools.resources. This is an attempt to keep those utility methods in a central place and avoid redundancies. |
30258 | 2008-05-08 | acuster | Reshuffle the top level repo: drop uDig, move up trunk, tags, and branches. |
30257 | 2008-05-08 | acuster | Move trunk/gt/ directory contents up to trunk/ and drop gt |
29825 | 2008-04-07 | desruisseaux | Added synchronized statements. While the old approach was not exactly the deprecated double-check idiom, it was too close of that. A few unsynchronized blocks still exist which may need to be revisited later. |
28922 | 2008-01-24 | acuster | Bump the (at)since version to 2.5 since WKTParser was cut from 2.4 |
28669 | 2008-01-09 | desruisseaux | Removed deprecated DataSource interface in order to simplify the EPSG factory code, for making debugging easier. Fixed a bug in the search for authority name as a side effect of GEOT-1659 investigation. Code formatting. |
28540 | 2007-12-29 | acuster | Hide buttons which are not yet used |
28391 | 2007-12-16 | desruisseaux | Attempt to make FactoryCreator more tolerant to dependencies that can't be fetched for a given set of hints (GEOT-1618). Also cleaned a little bit of calls to 'unexpectedException' as a side effect. |
28252 | 2007-12-04 | desruisseaux | More MosaicImageReader work. As a side effect, moved Utilities.getShort[Class]Name in a separated utilities class named 'Classes'. Also added a couple of @Override annotations. |
28233 | 2007-12-02 | desruisseaux | More work on MosaicImageReader - not yet tested. |
28198 | 2007-11-30 | desruisseaux | Covariant return type for NumberRange. |
28180 | 2007-11-30 | desruisseaux | Use 'Utilities.deepEquals' only when needed. |
28159 | 2007-11-29 | jgarnett | commit enough equals magic, and fixes to style object that shapefile renderer can draw something |
28156 | 2007-11-29 | jgarnett | Added float array equals method check to Utilities so we can start to check dashArray and dashOffset for StrokeImpl |
28081 | 2007-11-27 | desruisseaux | Java 5 constructs: replaced some StringBuffer by StringBuilder in order to avoid unecessary synchronisation; rely on auto-boxing in order to give a chance to the JVM to reuse its cached values. |
27983 | 2007-11-22 | desruisseaux | Use more Java 5 constructs for safety. |
27856 | 2007-11-12 | desruisseaux | Replaced 'Logger.getLogger(...)' calls by 'Logging.getLogger(...)' (GEOT-1545). |
27575 | 2007-10-22 | desruisseaux | Converted Java source files from ISO-LATIN-1 encoding to UTF-8 (GEOT-1516). |
27500 | 2007-10-15 | desruisseaux | First round of Java 5 generic types applied to org.geotools.resources and org.geotools.util packages. As a side effect, removed the deprecated org.geotools.resources.TestData class (moved to org.geotools.test). |
23635 | 2007-01-01 | desruisseaux | Uses fully-qualified class name (instead of last name only) in logging. More work on versioned URN:OGC:DEF factory. |
22931 | 2006-11-23 | desruisseaux | Added a convenience method for logging exceptions, as a proposed approach for the 'Do not return null' wiki page. |
22443 | 2006-10-27 | desruisseaux | Splitted referencing, extracting metadata in their own module (GEOT-983). As a side effect, replaced some calls of CRSUtilities.foo(...) by CRS.foo(...). |
22327 | 2006-10-23 | desruisseaux | GEOT-982: regroup 'module', 'plugin', 'ext' and 'unsupported' in a common directory. |
22315 | 2006-10-22 | desruisseaux | Reorganisation of directory tree structure (GEOT-982) phase 1: moved 'src' to 'src/main/java'. |
20874 | 2006-08-07 | jgarnett | ip review |
20483 | 2006-07-11 | desruisseaux | Documentation fixes / avoid usage of deprecated methods. |
19941 | 2006-06-13 | desruisseaux | Implemented CRS.decode(String) on top of AllAuthoritiesFactory. |
17672 | 2006-01-19 | desruisseaux | Added @source tag. |
17660 | 2006-01-18 | desruisseaux | Fixed SVN attributes, including the addition of URL attribute. |
15840 | 2005-09-24 | desruisseaux | Added a convenience DataSource for EPSG factory, using a properties file. |
15350 | 2005-08-16 | desruisseaux | Merged the 'split-main' branch to trunk (GEOT-662) |
15256 | 2005-08-09 | desruisseaux | Extraction of referencing module from main |
15255 | 2005-08-09 | desruisseaux | Prepare branch for splitting main |
14834 | 2005-07-20 | desruisseaux | Reorganized I18N resources |
13925 | 2005-05-30 | desruisseaux | Added @since javadoc tag |
11100 | 2005-02-04 | desruisseaux | More tests and bug fixes in CRS |
11001 | 2005-02-02 | desruisseaux | Fixed wrong encoding in main/src |
10796 | 2005-01-28 | dzwiers | imports cleaned |
8218 | 2004-09-27 | desruisseaux | Back to work: clean up |
6575 | 2004-06-27 | desruisseaux | MatrixParameters now uses ParameterRealValue / In providers, moved parameters in a static field. |
6207 | 2004-05-27 | desruisseaux | Javadoc fixes |
6050 | 2004-05-23 | jgarnett | merge resources into main |
6046 | 2004-05-23 | jgarnett | Moved over to main for manual merge |
5774 | 2004-05-23 | jgarnett | geotools-src serves as the start of our new module directory (the data access modules will escape off to plugin directory soon) |
5769 | 2004-05-23 | jgarnett | Project renamed to gt |
5619 | 2004-05-13 | (pas d'auteur) | Move repository under gt. |
3607 | 2003-08-04 | desruisseaux | PMD fixes |
2858 | 2003-05-13 | desruisseaux | Added PMC owner to copyright notice |
1289 | 2002-07-27 | desruisseaux | Improved formatting of classname for arrays |
486 | 2002-05-21 | jmacgill | readed Linda's javadoc improvements |
484 | 2002-05-21 | jmacgill | moved out of the swinggui module |
392 | 2002-05-10 | jmacgill | Support files for new zoompaneOnce needed by other modules these should be split out of swinggui and moved into their own support module I18N related files also need to move, but the exact structure is not yet clear. |