PixelTranslation history

Click on the commit message for inspecting the diff and how the code has been rewritten.

Command line:

svn log -r31996:1 https://svn.osgeo.org/geotools/trunk/modules/library/referencing/src/main/java/org/geotools/metadata/iso/spatial/PixelTranslation.java
Rev. Date Author Message
306412008-06-12acusterCopyright headers: lib/referencing, this time with feeling (and the el in Toolkit)
306392008-06-12acusterCopyright headers: cleanup library/referencing
305212008-06-05acusterCopyright: Update referencing headers
303132008-05-16desruisseauxChanged my mind about Utilities.shallowEquals(Object,Object) and renamed it as equals, since a few tests show that the compiler always select the best overloaded flavor working on primitive types (except if an argument is a boolean and the other a different primitive type). Updated a few references. Fixed a few javadoc warnings by explicit declaration of parameter and return values.
302582008-05-08acusterReshuffle the top level repo: drop uDig, move up trunk, tags, and branches.
302572008-05-08acusterMove trunk/gt/ directory contents up to trunk/ and drop gt
298262008-04-07desruisseauxMore support for PixelOrientation in GridGeometry construction and queries. A side effect of this work is the refactoring of GridGeometry2D translation method into a separated PixelTranslation class.
298062008-04-04desruisseauxAdded the capability to use a custom DimensionFilter on GridGeometry2D construction.
297462008-03-31desruisseauxRemoved the getGridSize2D() method in order to keep the API simplier - this somewhat trivial method doesn't seem to worth its weight.
297442008-03-31desruisseauxAdded a GridGeometry2D.getSize2D() convenience method.
290012008-01-30desruisseauxA few bug fixes, especially in Resampler2D including a workaround for a JAI 1.1.3 bug. For other files, replaced Hints.OVERVIEW_POLICY values from String to OverviewPolicy enum.
289372008-01-25desruisseauxReverted the whole trunk to revision 28921.
289262008-01-24acusterRevert geotools trunk to reversion 29822, hopefully.
289232008-01-24acusterMerge from gtbranches
289222008-01-24acusterBump the (at)since version to 2.5 since WKTParser was cut from 2.4
288462008-01-20desruisseauxCovariant return type for inverse() method in MathTransform1D and MathTransform2D. Also javadoc fixes and Java 5 type safety. Changed ViewType to an enum and initial implementation of GridCoverageViews (not yet connected to GridCoverage2D).
285402007-12-29acusterHide buttons which are not yet used
285272007-12-28desruisseauxGridCoverage2D.evaluate(DirectPosition) now reprojects on the fly if the DirectPosition CRS is different than the GridCoverage CRS.
285002007-12-24desruisseauxAdded a new GridGeometry implementation (ImageGeometry) has a lightweight placeholder for 'gridRange' as a Rectangle and 'gridToCRS' as an AffineTransform. Used by TileBuilder.
283842007-12-15desruisseauxTry to make Resample operation a little bit more tolerant to the reduction of CRS dimension.
283742007-12-14desruisseauxUse some java 5 features. Added javadoc. Removed AbstractCoverage.dispose() deprecated method (replaced by dispose(boolean)). Cleaning.
282672007-12-06desruisseauxGeoTools trunk now build against GeoAPI 2.2-SNAPSHOT.
282522007-12-04desruisseauxMore MosaicImageReader work. As a side effect, moved Utilities.getShort[Class]Name in a separated utilities class named 'Classes'. Also added a couple of @Override annotations.
279952007-11-22desruisseauxMore generics type, and moved two methods from ReferencingFactoryContainer to GeoAPI MathTransformFactory interface. Note that the build fails in the arcsde module for a reason that seems unrelated to this work.
275752007-10-22desruisseauxConverted Java source files from ISO-LATIN-1 encoding to UTF-8 (GEOT-1516).
270942007-09-20desruisseauxMerged changes from 2.4 branch.
249252007-03-27jgarnettchange to org.opengis.geometry
228262006-11-20desruisseauxMinor bug fixes. Removed deprecated methods in GeneralGridGeometry. Added a 'toBackingFactoryCode' method in AuthorityFactoryAdapter.
228172006-11-17desruisseauxFixed SVN properties for all Java files.
227152006-11-14desruisseauxAdded GridToEnvelopeMapper implementation as a proposed replacement for GeneralGridGeometry.getTransform static method.
227102006-11-12desruisseauxReview of coverage branch merge: In 'CategoryList', check for the 'no data' category name only if the geophysics value is some NaN value. Moved XAffineTransform to a public place and added methods for testing axis swapping, as a proposed replacement for 'GeneralGridGeometry.swapXY(CoordinateSystem)' (replacement not yet done; waiting for the okay from the mailing list). In GeneralGridGeometry, added methods for returning a math transform relative to some pixel corner instead of pixel center, as a proposed replacement for the 'getTransform(...)' public static methods (I would like to remove those static methods in order to keep the API a little bit more orthogonal).
224522006-10-28desruisseauxMoved some methods from CRSUtilities to CRS (GEOT-547).
223272006-10-23desruisseauxGEOT-982: regroup 'module', 'plugin', 'ext' and 'unsupported' in a common directory.
223152006-10-22desruisseauxReorganisation of directory tree structure (GEOT-982) phase 1: moved 'src' to 'src/main/java'.
209702006-08-11jgarnettIP review.txt updated, along with headers
201672006-06-23desruisseauxGEOT-873: partial merge of ImageUtilities to trunk. Not yet finished, since I'm refactoring the new code in the process.
197552006-05-31desruisseauxAdded FORCE_LONGITUDE_FIRST_AXIS_ORDER hint (GEOT-858). This work implied a large amount of work, hunting for infinite recursive method calls in many places.
176722006-01-19desruisseauxAdded @source tag.
176602006-01-18desruisseauxFixed SVN attributes, including the addition of URL attribute.
165722005-11-02desruisseauxMoved coverage implementation to its own module (GEOT-745)
165362005-10-28desruisseauxAdded a 'Default CRS' hint for GridCoverageFactory (post GEOT-701 cleaning) + javadoc fixes.
165262005-10-27desruisseauxMore responsabilities moved from GridCoverage2D to GridGeometry2D (GEOT-701). This refactoring had a significant impact on Resample2D; the rest of the code should stay neutral.
158032005-09-22desruisseauxBux fix in automatic axis swapping during GridCoverage(..., Envelope, ...) construction.
157362005-09-19desruisseauxAdded convenience methods or constructors
155562005-08-30desruisseauxBug fix in 'createTransformedShape' / Clarification in the way a GridCoverage2D convenience constructor handle axis
148342005-07-20desruisseauxReorganized I18N resources
139252005-05-30desruisseauxAdded @since javadoc tag
131292005-04-15desruisseauxName change: removed 'GT' suffix in org.geotools.coverage implementations. Some on them were replaced by 'General' prefix for consistency with 'GeneralEnvelope' and 'GeneralDirectPosition'. In this context 'General' means "Can work with an arbitrary number of dimension". Other name changes in org.geotools.referencing and org.geotools.metadata are pending the choice between 'Default' prefix and 'Impl' suffix
120202005-03-11desruisseauxFirst working version of Resampler2D port (side effect: GEOT-390 fix)
119602005-03-10desruisseauxFirst draft of GridCoverage 'resampler' operation port
117752005-03-04desruisseauxPartial port of the Interpolation method
117602005-03-03desruisseauxPorted JAI operators from 'legacy' to 'main'
117382005-03-02desruisseauxFirst working version of GridCoverage2D
117222005-03-01desruisseauxPartial port of GridCoverage2D
116542005-02-25desruisseauxGridGeometry work, which includes a first working version of DimensionFilter
115722005-02-23desruisseauxInitial port of sub-transform, required for some grid coverages
115492005-02-22desruisseauxInitial cleaning for restarting GridCoverage work
111862005-02-08rgouldAttempts to get GridCoverage to work. Made GridGeometry implement the GeoAPI GridGeometry interface. Added GridGeometry support to GridCoverageImpl. Added GridCoverage into GridCoverageRenderer.
110012005-02-02desruisseauxFixed wrong encoding in main/src
109442005-02-01desruisseauxBug fix in ProjectedCRS: axis swapping and units conversion were not correctly handled
108672005-01-31dzwiersdep fix
107962005-01-28dzwiersimports cleaned
65362004-06-25desruisseauxAdded SingleCRS class / Renamed ObliqueCartesianCS as AffineCS / Moved Position as super-interface for DirectPosition and Point
63622004-06-08desruisseauxInitial work for an OperationProvider
63332004-06-06desruisseauxContinuing CRS implementation
63012004-06-03desruisseauxRefactored basic transform in their own package
62952004-06-02desruisseauxPartial port of GridRange and GridGeometry implementations