Click on the commit message for inspecting the diff
and how the code has been rewritten.
Command line:
svn log -r31996:1 https://svn.osgeo.org/geotools/trunk/modules/library/coverage/src/main/java/org/geotools/coverage/grid/GeneralGridGeometry.java
Rev. | Date | Author | Message |
---|---|---|---|
30776 | 2008-06-20 | desruisseaux | GeoTools implementation update for GeoAPI change (GEO-136): Envelope.getCenter renamed as getMedian and getLength renamed as getSpan. Deprecated GridRange, to be replaced by GridEnvelope. |
30643 | 2008-06-12 | acuster | Copyright headers: lib/coverage, this time with feeling (and the el in Toolkit) |
30541 | 2008-06-06 | acuster | Copyright review: update headers on lib/coverage |
30313 | 2008-05-16 | desruisseaux | Changed my mind about Utilities.shallowEquals(Object,Object) and renamed it as equals, since a few tests show that the compiler always select the best overloaded flavor working on primitive types (except if an argument is a boolean and the other a different primitive type). Updated a few references. Fixed a few javadoc warnings by explicit declaration of parameter and return values. |
30258 | 2008-05-08 | acuster | Reshuffle the top level repo: drop uDig, move up trunk, tags, and branches. |
30257 | 2008-05-08 | acuster | Move trunk/gt/ directory contents up to trunk/ and drop gt |
29962 | 2008-04-17 | simboss | -typos |
29829 | 2008-04-07 | desruisseaux | Inside synchronized blocks, avoid to call methods that user could override. |
29826 | 2008-04-07 | desruisseaux | More support for PixelOrientation in GridGeometry construction and queries. A side effect of this work is the refactoring of GridGeometry2D translation method into a separated PixelTranslation class. |
29744 | 2008-03-31 | desruisseaux | Added a GridGeometry2D.getSize2D() convenience method. |
28937 | 2008-01-25 | desruisseaux | Reverted the whole trunk to revision 28921. |
28926 | 2008-01-24 | acuster | Revert geotools trunk to reversion 29822, hopefully. |
28923 | 2008-01-24 | acuster | Merge from gtbranches |
28922 | 2008-01-24 | acuster | Bump the (at)since version to 2.5 since WKTParser was cut from 2.4 |
28801 | 2008-01-17 | desruisseaux | Made CoverageStack more tolerant to heterogenous CRS (unfinished work). Some Java 5 type safety added. |
28540 | 2007-12-29 | acuster | Hide buttons which are not yet used |
28500 | 2007-12-24 | desruisseaux | Added a new GridGeometry implementation (ImageGeometry) has a lightweight placeholder for 'gridRange' as a Rectangle and 'gridToCRS' as an AffineTransform. Used by TileBuilder. |
28496 | 2007-12-24 | desruisseaux | Avoid usage of deprecated methods. |
28374 | 2007-12-14 | desruisseaux | Use some java 5 features. Added javadoc. Removed AbstractCoverage.dispose() deprecated method (replaced by dispose(boolean)). Cleaning. |
28252 | 2007-12-04 | desruisseaux | More MosaicImageReader work. As a side effect, moved Utilities.getShort[Class]Name in a separated utilities class named 'Classes'. Also added a couple of @Override annotations. |
28081 | 2007-11-27 | desruisseaux | Java 5 constructs: replaced some StringBuffer by StringBuilder in order to avoid unecessary synchronisation; rely on auto-boxing in order to give a chance to the JVM to reuse its cached values. |
27575 | 2007-10-22 | desruisseaux | Converted Java source files from ISO-LATIN-1 encoding to UTF-8 (GEOT-1516). |
27094 | 2007-09-20 | desruisseaux | Merged changes from 2.4 branch. |
24925 | 2007-03-27 | jgarnett | change to org.opengis.geometry |
22959 | 2006-11-24 | desruisseaux | Aligned Geotools build along latest GeoAPI interfaces (2.1-SNAPSHOT). |
22826 | 2006-11-20 | desruisseaux | Minor bug fixes. Removed deprecated methods in GeneralGridGeometry. Added a 'toBackingFactoryCode' method in AuthorityFactoryAdapter. |
22817 | 2006-11-17 | desruisseaux | Fixed SVN properties for all Java files. |
22715 | 2006-11-14 | desruisseaux | Added GridToEnvelopeMapper implementation as a proposed replacement for GeneralGridGeometry.getTransform static method. |
22711 | 2006-11-12 | desruisseaux | Moved the GeneralGridGeometry.getEnvelope(...) static method as a GeneralEnvelope constructor. |
22710 | 2006-11-12 | desruisseaux | Review of coverage branch merge: In 'CategoryList', check for the 'no data' category name only if the geophysics value is some NaN value. Moved XAffineTransform to a public place and added methods for testing axis swapping, as a proposed replacement for 'GeneralGridGeometry.swapXY(CoordinateSystem)' (replacement not yet done; waiting for the okay from the mailing list). In GeneralGridGeometry, added methods for returning a math transform relative to some pixel corner instead of pixel center, as a proposed replacement for the 'getTransform(...)' public static methods (I would like to remove those static methods in order to keep the API a little bit more orthogonal). |
22452 | 2006-10-28 | desruisseaux | Moved some methods from CRSUtilities to CRS (GEOT-547). |
22327 | 2006-10-23 | desruisseaux | GEOT-982: regroup 'module', 'plugin', 'ext' and 'unsupported' in a common directory. |
22315 | 2006-10-22 | desruisseaux | Reorganisation of directory tree structure (GEOT-982) phase 1: moved 'src' to 'src/main/java'. |
22226 | 2006-10-18 | acuster | Javadoc: purge the @params |
20970 | 2006-08-11 | jgarnett | IP review.txt updated, along with headers |
20600 | 2006-07-18 | simboss | -committing first bunch of changes from the coverage branch. Modules involved are*api *referencing *coverage *main *renderer *shaperenderer |
20243 | 2006-06-30 | desruisseaux | Javadoc fixes. Factored out icon management in a small IconFactory class. |
20167 | 2006-06-23 | desruisseaux | GEOT-873: partial merge of ImageUtilities to trunk. Not yet finished, since I'm refactoring the new code in the process. |
17672 | 2006-01-19 | desruisseaux | Added @source tag. |
17660 | 2006-01-18 | desruisseaux | Fixed SVN attributes, including the addition of URL attribute. |
16572 | 2005-11-02 | desruisseaux | Moved coverage implementation to its own module (GEOT-745) |
16536 | 2005-10-28 | desruisseaux | Added a 'Default CRS' hint for GridCoverageFactory (post GEOT-701 cleaning) + javadoc fixes. |
16529 | 2005-10-27 | afabiani | Very small bug fixes for Java 1.4 compiler plus first RasterSymbolizer implementation |
16526 | 2005-10-27 | desruisseaux | More responsabilities moved from GridCoverage2D to GridGeometry2D (GEOT-701). This refactoring had a significant impact on Resample2D; the rest of the code should stay neutral. |
15803 | 2005-09-22 | desruisseaux | Bux fix in automatic axis swapping during GridCoverage(..., Envelope, ...) construction. |
15736 | 2005-09-19 | desruisseaux | Added convenience methods or constructors |
15556 | 2005-08-30 | desruisseaux | Bug fix in 'createTransformedShape' / Clarification in the way a GridCoverage2D convenience constructor handle axis |
15350 | 2005-08-16 | desruisseaux | Merged the 'split-main' branch to trunk (GEOT-662) |
14834 | 2005-07-20 | desruisseaux | Reorganized I18N resources |
13925 | 2005-05-30 | desruisseaux | Added @since javadoc tag |
13129 | 2005-04-15 | desruisseaux | Name change: removed 'GT' suffix in org.geotools.coverage implementations. Some on them were replaced by 'General' prefix for consistency with 'GeneralEnvelope' and 'GeneralDirectPosition'. In this context 'General' means "Can work with an arbitrary number of dimension". Other name changes in org.geotools.referencing and org.geotools.metadata are pending the choice between 'Default' prefix and 'Impl' suffix |
11738 | 2005-03-02 | desruisseaux | First working version of GridCoverage2D |
11654 | 2005-02-25 | desruisseaux | GridGeometry work, which includes a first working version of DimensionFilter |
11572 | 2005-02-23 | desruisseaux | Initial port of sub-transform, required for some grid coverages |
11549 | 2005-02-22 | desruisseaux | Initial cleaning for restarting GridCoverage work |
11186 | 2005-02-08 | rgould | Attempts to get GridCoverage to work. Made GridGeometry implement the GeoAPI GridGeometry interface. Added GridGeometry support to GridCoverageImpl. Added GridCoverage into GridCoverageRenderer. |
11001 | 2005-02-02 | desruisseaux | Fixed wrong encoding in main/src |
10944 | 2005-02-01 | desruisseaux | Bug fix in ProjectedCRS: axis swapping and units conversion were not correctly handled |
10867 | 2005-01-31 | dzwiers | dep fix |
10796 | 2005-01-28 | dzwiers | imports cleaned |
6536 | 2004-06-25 | desruisseaux | Added SingleCRS class / Renamed ObliqueCartesianCS as AffineCS / Moved Position as super-interface for DirectPosition and Point |
6362 | 2004-06-08 | desruisseaux | Initial work for an OperationProvider |
6333 | 2004-06-06 | desruisseaux | Continuing CRS implementation |
6301 | 2004-06-03 | desruisseaux | Refactored basic transform in their own package |
6295 | 2004-06-02 | desruisseaux | Partial port of GridRange and GridGeometry implementations |