Click on the commit message for inspecting the diff
and how the code has been rewritten.
Command line:
svn log -r31996:1 https://svn.osgeo.org/geotools/trunk/modules/library/coverage/src/main/java/org/geotools/coverage/CategoryList.java
Rev. | Date | Author | Message |
---|---|---|---|
31549 | 2008-09-18 | desruisseaux | Anticipating GEO-143. |
30760 | 2008-06-18 | desruisseaux | Upgrated from JSR-108 to JSR-275 (GEOT-1266). Some opportunist javadoc fixes and @Override annotations in the process. |
30643 | 2008-06-12 | acuster | Copyright headers: lib/coverage, this time with feeling (and the el in Toolkit) |
30541 | 2008-06-06 | acuster | Copyright review: update headers on lib/coverage |
30313 | 2008-05-16 | desruisseaux | Changed my mind about Utilities.shallowEquals(Object,Object) and renamed it as equals, since a few tests show that the compiler always select the best overloaded flavor working on primitive types (except if an argument is a boolean and the other a different primitive type). Updated a few references. Fixed a few javadoc warnings by explicit declaration of parameter and return values. |
30258 | 2008-05-08 | acuster | Reshuffle the top level repo: drop uDig, move up trunk, tags, and branches. |
30257 | 2008-05-08 | acuster | Move trunk/gt/ directory contents up to trunk/ and drop gt |
29356 | 2008-02-18 | desruisseaux | Bug fixes: new working version of TileBuilder. |
29093 | 2008-02-05 | desruisseaux | First draft of a test suite for ViewsManager in an attempt to understand why our "Piecewise" operation produces different results than what we would expect. Some bug fixes. |
29052 | 2008-02-01 | desruisseaux | More information in GridCoverage2D.toString(). Attempt to enable "Piecewise" JAI operation when converting from packed to geophysics (not finished). Bug fix in Resampler2D when the only work to do is a Crop. |
29023 | 2008-01-31 | desruisseaux | GridSampleDimension.toString() now includes the description given at construction time. |
28922 | 2008-01-24 | acuster | Bump the (at)since version to 2.5 since WKTParser was cut from 2.4 |
28852 | 2008-01-21 | desruisseaux | Reverted back "view(ViewType)" methods to "geophysics(boolean)" in Category and GridSampleDimension because views other than "geophysics" and "packed" don't make sense in current design. However those various views still in GridCoverage2D, which can support a richer set including "photographic" because it know about all bands together (as opposite to Category/GridSampleDimension which don't know what the other bands are). Also removed a few deprecated constructors and changed ViewType constants. |
28846 | 2008-01-20 | desruisseaux | Covariant return type for inverse() method in MathTransform1D and MathTransform2D. Also javadoc fixes and Java 5 type safety. Changed ViewType to an enum and initial implementation of GridCoverageViews (not yet connected to GridCoverage2D). |
28821 | 2008-01-18 | desruisseaux | Covariant return type on GridCoverage2D.getSampleDimension(int). |
28540 | 2007-12-29 | acuster | Hide buttons which are not yet used |
28464 | 2007-12-21 | desruisseaux | First draft of a TileCollection helper class. Not yet tested. |
28252 | 2007-12-04 | desruisseaux | More MosaicImageReader work. As a side effect, moved Utilities.getShort[Class]Name in a separated utilities class named 'Classes'. Also added a couple of @Override annotations. |
28198 | 2007-11-30 | desruisseaux | Covariant return type for NumberRange. |
28081 | 2007-11-27 | desruisseaux | Java 5 constructs: replaced some StringBuffer by StringBuilder in order to avoid unecessary synchronisation; rely on auto-boxing in order to give a chance to the JVM to reuse its cached values. |
27575 | 2007-10-22 | desruisseaux | Converted Java source files from ISO-LATIN-1 encoding to UTF-8 (GEOT-1516). |
25449 | 2007-05-07 | desruisseaux | Reformatted code (especially Resample2D) in a way closer to the way it was at revision 17672. The purpose it to make easier to spot with 'svn diff' the changes applied since that time. Revision 17672 was just before significant work were commited by a new contributor and we would like to compare with original code with less distriction caused by reformatting. This commit should not bring any functionality change. |
24925 | 2007-03-27 | jgarnett | change to org.opengis.geometry |
24607 | 2007-02-26 | desruisseaux | Avoid UnformattableObjectException for 'LOCAL_CS' and 'VERT_CS' WKT elements. Try to provides some hints about the cause for the other cases of unformattable WKT. |
23632 | 2006-12-29 | desruisseaux | GEOT-859: Refactored the URN syntax adapter for CRS factories. The adapter now apply to any factory. Some progress toward version management (but not yet there). NOTE: this new implementation forces axis order "as specified in the database", which is different from the original "URNEPSGAdapter" implementation which used (x,y) order. Various changes in many corners of "org.geotools.referencing.factory" as a side-effect of this work. Minor opportunist javadoc fixes in other modules. |
22997 | 2006-11-26 | desruisseaux | Replaced the use of some deprecated methods (MonolineFormatter.initGeotools --> Logging.forceMonolineConsoleOutput; Utilities.unexpectedException --> Logging.unexpectedException; GeneralEnvelope.getCoordinateReferenceSystem --> Envelope.getCoordinateReferenceSystem). |
22817 | 2006-11-17 | desruisseaux | Fixed SVN properties for all Java files. |
22710 | 2006-11-12 | desruisseaux | Review of coverage branch merge: In 'CategoryList', check for the 'no data' category name only if the geophysics value is some NaN value. Moved XAffineTransform to a public place and added methods for testing axis swapping, as a proposed replacement for 'GeneralGridGeometry.swapXY(CoordinateSystem)' (replacement not yet done; waiting for the okay from the mailing list). In GeneralGridGeometry, added methods for returning a math transform relative to some pixel corner instead of pixel center, as a proposed replacement for the 'getTransform(...)' public static methods (I would like to remove those static methods in order to keep the API a little bit more orthogonal). |
22327 | 2006-10-23 | desruisseaux | GEOT-982: regroup 'module', 'plugin', 'ext' and 'unsupported' in a common directory. |
22315 | 2006-10-22 | desruisseaux | Reorganisation of directory tree structure (GEOT-982) phase 1: moved 'src' to 'src/main/java'. |
20970 | 2006-08-11 | jgarnett | IP review.txt updated, along with headers |
20600 | 2006-07-18 | simboss | -committing first bunch of changes from the coverage branch. Modules involved are*api *referencing *coverage *main *renderer *shaperenderer |
20167 | 2006-06-23 | desruisseaux | GEOT-873: partial merge of ImageUtilities to trunk. Not yet finished, since I'm refactoring the new code in the process. |
17672 | 2006-01-19 | desruisseaux | Added @source tag. |
17660 | 2006-01-18 | desruisseaux | Fixed SVN attributes, including the addition of URL attribute. |
16572 | 2005-11-02 | desruisseaux | Moved coverage implementation to its own module (GEOT-745) |
15803 | 2005-09-22 | desruisseaux | Bux fix in automatic axis swapping during GridCoverage(..., Envelope, ...) construction. |
15736 | 2005-09-19 | desruisseaux | Added convenience methods or constructors |
15350 | 2005-08-16 | desruisseaux | Merged the 'split-main' branch to trunk (GEOT-662) |
14834 | 2005-07-20 | desruisseaux | Reorganized I18N resources |
14608 | 2005-06-25 | desruisseaux | EPSG authority factory now uses path informations for ConcatenatedOperation object creations / Added PostgreSQL plugin (mostly as a demo) / Javadoc fixes |
13925 | 2005-05-30 | desruisseaux | Added @since javadoc tag |
13129 | 2005-04-15 | desruisseaux | Name change: removed 'GT' suffix in org.geotools.coverage implementations. Some on them were replaced by 'General' prefix for consistency with 'GeneralEnvelope' and 'GeneralDirectPosition'. In this context 'General' means "Can work with an arbitrary number of dimension". Other name changes in org.geotools.referencing and org.geotools.metadata are pending the choice between 'Default' prefix and 'Impl' suffix |
11738 | 2005-03-02 | desruisseaux | First working version of GridCoverage2D |
11549 | 2005-02-22 | desruisseaux | Initial cleaning for restarting GridCoverage work |
11001 | 2005-02-02 | desruisseaux | Fixed wrong encoding in main/src |
10906 | 2005-01-31 | dzwiers | compile errors - maven |
10826 | 2005-01-28 | rgould | Fixed import |
10796 | 2005-01-28 | dzwiers | imports cleaned |
10253 | 2005-01-05 | desruisseaux | Fixed compiler error caused by a change in MathTransform API |
8521 | 2004-10-11 | desruisseaux | Fixed compilation errors caused by latest CRS commit |
6565 | 2004-06-26 | desruisseaux | First draft of a MapProjection port |
6538 | 2004-06-25 | desruisseaux | Fixed broken build |
6375 | 2004-06-10 | desruisseaux | Work on parameters handling |
6333 | 2004-06-06 | desruisseaux | Continuing CRS implementation |
6259 | 2004-05-31 | desruisseaux | Added more implementations for Coverage support |