Click on the commit message for inspecting the diff
and how the code has been rewritten.
Command line:
svn log -r31996:1 https://svn.osgeo.org/geotools/trunk/modules/library/referencing/src/main/java/org/geotools/referencing/AbstractIdentifiedObject.java
Rev. | Date | Author | Message |
---|---|---|---|
31445 | 2008-09-07 | desruisseaux | GEOT-1667: Need to invoke LogRecord.setLoggerName(String) before Logger.log(LogRecord). |
31148 | 2008-08-07 | desruisseaux | Renamed GenericName.name() as tip(). The old method still around as a deprecated one. |
31139 | 2008-08-06 | desruisseaux | Avoid usage of deprecated methods from the org.opengis.util.GenericName interface. |
31132 | 2008-08-05 | desruisseaux | As a side effect of "geotidy" work, ported a few bug fixes in metadata. Avoid usage of deprecated GeneralName.getScope() method, replaced by scope(). |
30760 | 2008-06-18 | desruisseaux | Upgrated from JSR-108 to JSR-275 (GEOT-1266). Some opportunist javadoc fixes and @Override annotations in the process. |
30641 | 2008-06-12 | acuster | Copyright headers: lib/referencing, this time with feeling (and the el in Toolkit) |
30521 | 2008-06-05 | acuster | Copyright: Update referencing headers |
30313 | 2008-05-16 | desruisseaux | Changed my mind about Utilities.shallowEquals(Object,Object) and renamed it as equals, since a few tests show that the compiler always select the best overloaded flavor working on primitive types (except if an argument is a boolean and the other a different primitive type). Updated a few references. Fixed a few javadoc warnings by explicit declaration of parameter and return values. |
30258 | 2008-05-08 | acuster | Reshuffle the top level repo: drop uDig, move up trunk, tags, and branches. |
30257 | 2008-05-08 | acuster | Move trunk/gt/ directory contents up to trunk/ and drop gt |
29870 | 2008-04-09 | desruisseaux | Bug fixes and Java 5 leveraging. |
28922 | 2008-01-24 | acuster | Bump the (at)since version to 2.5 since WKTParser was cut from 2.4 |
28790 | 2008-01-16 | desruisseaux | Renamed resources.i18n.Logging as resources.i18n.Loggings (with an s) for avoiding name clash with util.logging.Logging. The name clash would not have been an issue if those two classes were not typically used together... Also performed a few javadoc fixes in DirectPosition2D. |
28540 | 2007-12-29 | acuster | Hide buttons which are not yet used |
28521 | 2007-12-27 | desruisseaux | Type safety. |
28107 | 2007-11-28 | desruisseaux | Updated for recent changes in GeoAPI interfaces. |
28030 | 2007-11-23 | desruisseaux | More Java 5 generics. Added implementation for three new GeoAPI methods for alignment with RFC 07-073r1. |
27995 | 2007-11-22 | desruisseaux | More generics type, and moved two methods from ReferencingFactoryContainer to GeoAPI MathTransformFactory interface. Note that the build fails in the arcsde module for a reason that seems unrelated to this work. |
27857 | 2007-11-12 | desruisseaux | Replaced a few missed Logger.getLogger(...) by Logging.getLogger(...) - GEOT-1545. |
27856 | 2007-11-12 | desruisseaux | Replaced 'Logger.getLogger(...)' calls by 'Logging.getLogger(...)' (GEOT-1545). |
27575 | 2007-10-22 | desruisseaux | Converted Java source files from ISO-LATIN-1 encoding to UTF-8 (GEOT-1516). |
26709 | 2007-08-27 | desruisseaux | Merged the unsupported/coverageio work from the 2.4 branch. |
25398 | 2007-05-02 | desruisseaux | Cleanup. Also renamed some classes in unsupported/epsg-extension. |
25397 | 2007-05-01 | desruisseaux | GEOT-1160: AllAuthoritiesFactory now work. It was the last step for making the connection with CRS.lookupIdentifier(...). |
25262 | 2007-04-23 | desruisseaux | Finished review of metadata and factory hints change. Fixed a potential glitch in parameter names handling (some code were disabled in AbstractIdentifiedObject apparently in order to avoid a ClassCastException caused by the spit of org.opengis.metadata.Identifier in two interfaces, Identifier and ReferenceIdentifier. Fixed the exception and reenabled the code). Not sure yet what the consequence was. It may help for the stereographic projection issue, but need to check. |
24973 | 2007-03-30 | chorner | GEO-93: GeoTools/GeoAPI ISO 19115 Metadata synchronization |
24384 | 2007-02-14 | desruisseaux | GEOT-1160: First working implementation of AbstractAuthorityFactory.find(IdentifiedObject). This includes a package-privated AuthorityFactoryProxy class, together with many fix in the code base in order to get CRS.equalsIgnoreCase to work in the ProjectedCRS case. |
23632 | 2006-12-29 | desruisseaux | GEOT-859: Refactored the URN syntax adapter for CRS factories. The adapter now apply to any factory. Some progress toward version management (but not yet there). NOTE: this new implementation forces axis order "as specified in the database", which is different from the original "URNEPSGAdapter" implementation which used (x,y) order. Various changes in many corners of "org.geotools.referencing.factory" as a side-effect of this work. Minor opportunist javadoc fixes in other modules. |
22327 | 2006-10-23 | desruisseaux | GEOT-982: regroup 'module', 'plugin', 'ext' and 'unsupported' in a common directory. |
22315 | 2006-10-22 | desruisseaux | Reorganisation of directory tree structure (GEOT-982) phase 1: moved 'src' to 'src/main/java'. |
20874 | 2006-08-07 | jgarnett | ip review |
19643 | 2006-05-24 | desruisseaux | First fix attempt for GEOT-854: CRS with modified axis order now preserve the metadata, including the authority code. The dangerous thing is that two CRS may now have the same authority code while being really different CRS. It caused an infinite loop in AuthorityBackedFactory, which was fixed in this commit as well. However, there is a risk that similar problems appear in user's code as well. |
19557 | 2006-05-18 | desruisseaux | AuthorityBackedFactory now take inverse transform in account. Improved pseudo-WKT formatting for CoordinateOperation. |
17672 | 2006-01-19 | desruisseaux | Added @source tag. |
17660 | 2006-01-18 | desruisseaux | Fixed SVN attributes, including the addition of URL attribute. |
17038 | 2005-11-28 | desruisseaux | Copied the AutoTest. Tuned AutoCRSFactory implementation (GEOT-773) |
16983 | 2005-11-25 | desruisseaux | Replaced references to static fields and methods of CitationImpl.* by Citations.* |
16942 | 2005-11-23 | desruisseaux | First draft of OrderedAxisAuthorityFactory (GEOT-694) |
15350 | 2005-08-16 | desruisseaux | Merged the 'split-main' branch to trunk (GEOT-662) |
15256 | 2005-08-09 | desruisseaux | Extraction of referencing module from main |
15255 | 2005-08-09 | desruisseaux | Prepare branch for splitting main |
15150 | 2005-08-05 | desruisseaux | Added more localizations / Bug fix in image sample values table widget |
14834 | 2005-07-20 | desruisseaux | Reorganized I18N resources |
14657 | 2005-07-01 | desruisseaux | Ongoing work for the port of grid coverage operations from 'legacy' to 'main' (GEOT-413): ported SampleDimensionSelect |
14608 | 2005-06-25 | desruisseaux | EPSG authority factory now uses path informations for ConcatenatedOperation object creations / Added PostgreSQL plugin (mostly as a demo) / Javadoc fixes |
14564 | 2005-06-20 | desruisseaux | Initial implementation of GEOT-589. Partially tested, more tests to come |
14550 | 2005-06-16 | desruisseaux | Removed deprecated fields and methods |
14545 | 2005-06-15 | desruisseaux | Initial port of coverage I/O helper classes (work in progress) |
14235 | 2005-06-10 | desruisseaux | Replaced _PROPERTY suffix by _KEY as of GEOT-577 |
14205 | 2005-06-09 | desruisseaux | Updated to GeoAPI 2.0 final release |
13925 | 2005-05-30 | desruisseaux | Added @since javadoc tag |
13907 | 2005-05-28 | desruisseaux | More additions of 'Default' prefix in CRS package |
13906 | 2005-05-28 | desruisseaux | Renamed some 'Default' prefix as 'Abstract' |
13869 | 2005-05-27 | desruisseaux | Added 'Default' or 'Abstract' prefix in CRS's 'datum' and 'cs' packages |
13836 | 2005-05-26 | desruisseaux | Added 'Default' suffix to some CRS implementations: partial work |
13762 | 2005-05-24 | desruisseaux | Added DefiningConversion |
13387 | 2005-05-06 | desruisseaux | Added Hints.LENIENT_DATUM_SHIFT and the necessary mechanic to honor it |
13361 | 2005-05-03 | desruisseaux | First part of LocalizationGrid refactoring work (explanation email to be sent shortly) |
12212 | 2005-03-15 | desruisseaux | First working version of DatumAliases as a DatumFactory |
11816 | 2005-03-07 | desruisseaux | First draft of GridCoverage operation port |
11698 | 2005-02-28 | desruisseaux | Moved tests from legacy to main module |
11371 | 2005-02-14 | desruisseaux | Renamed DefaultObjectFactory as GeotoolsFactory (GEOT-420, now closed) |
11174 | 2005-02-08 | desruisseaux | CoordinateOperationFactory now make use of 'Molodenski' transform (GEOT-399) |
11144 | 2005-02-07 | desruisseaux | Fixed GEOT-400 (create appropriate instance of Operation subclasses) |
11001 | 2005-02-02 | desruisseaux | Fixed wrong encoding in main/src |
10796 | 2005-01-28 | dzwiers | imports cleaned |
10105 | 2004-12-30 | desruisseaux | Improved Console implementation / Fixed erroneous conversion of dimensionless unit / Javadoc fixes |
9346 | 2004-11-30 | desruisseaux | First working version of CoordinateOperationFactory |
9243 | 2004-11-22 | desruisseaux | Tuned WKT parsing and formatting |
9220 | 2004-11-21 | desruisseaux | WKT bug fixes |
9118 | 2004-11-14 | desruisseaux | Mercator projection port completed (but untested) as a use case for other projection ports |
9117 | 2004-11-13 | desruisseaux | Added the capability to list all available MathTransforms |
8796 | 2004-10-22 | desruisseaux | Cleaning referencing's operation basic package |
8518 | 2004-10-11 | desruisseaux | Apply changes voted in OGC meeting at Southampton: use of Identifier and GenericName |
7857 | 2004-09-09 | jgarnett | name to getName().toString( null ) |
7848 | 2004-09-08 | jgarnett | round 2 of sync with geoapi |
7712 | 2004-08-31 | jgarnett | Intergrate ParameterValueGroup / ParameterGroupDescriptor and InternationalString |
7013 | 2004-07-19 | desruisseaux | Slight adjustement after GeoAPI changes in metadata |
6888 | 2004-07-14 | desruisseaux | Update for GeoAPI changes (Info --> IdentifiedObject) |