Click on the commit message for inspecting the diff
and how the code has been rewritten.
Command line:
svn log -r31996:1 https://svn.osgeo.org/geotools/trunk/modules/library/referencing/src/main/java/org/geotools/geometry/AbstractEnvelope.java
Rev. | Date | Author | Message |
---|---|---|---|
30892 | 2008-07-04 | desruisseaux | Compatible GeoAPI change: DirectPosition.getCoordinates() made singular (GEO-135). |
30641 | 2008-06-12 | acuster | Copyright headers: lib/referencing, this time with feeling (and the el in Toolkit) |
30521 | 2008-06-05 | acuster | Copyright: Update referencing headers |
30313 | 2008-05-16 | desruisseaux | Changed my mind about Utilities.shallowEquals(Object,Object) and renamed it as equals, since a few tests show that the compiler always select the best overloaded flavor working on primitive types (except if an argument is a boolean and the other a different primitive type). Updated a few references. Fixed a few javadoc warnings by explicit declaration of parameter and return values. |
30258 | 2008-05-08 | acuster | Reshuffle the top level repo: drop uDig, move up trunk, tags, and branches. |
30257 | 2008-05-08 | acuster | Move trunk/gt/ directory contents up to trunk/ and drop gt |
29092 | 2008-02-05 | desruisseaux | Documentation updates. Java 5 type safety mostly in EPSG factories. LogarithmicTransform1D optimization by using the new (and presumably more accurate) Java 5 Math.log10(double) method. |
28922 | 2008-01-24 | acuster | Bump the (at)since version to 2.5 since WKTParser was cut from 2.4 |
28540 | 2007-12-29 | acuster | Hide buttons which are not yet used |
28252 | 2007-12-04 | desruisseaux | More MosaicImageReader work. As a side effect, moved Utilities.getShort[Class]Name in a separated utilities class named 'Classes'. Also added a couple of @Override annotations. |
28081 | 2007-11-27 | desruisseaux | Java 5 constructs: replaced some StringBuffer by StringBuilder in order to avoid unecessary synchronisation; rely on auto-boxing in order to give a chance to the JVM to reuse its cached values. |
27575 | 2007-10-22 | desruisseaux | Converted Java source files from ISO-LATIN-1 encoding to UTF-8 (GEOT-1516). |
26137 | 2007-07-03 | desruisseaux | Image I/O GeographicMetadata should now supports read and write operations for most attributes. More tests needed. |
25779 | 2007-06-08 | desruisseaux | Added CRS.transform(CoordinateOperation, ...) methods, which are able to handle the special cases where the source envelope contains a singularity like a pole or the 180� longitude. As a side effect, changed Envelope.toString() to a more straightforward formatting, easier for debugging. |
25001 | 2007-04-03 | chorner | switched back to geoapi 2.1-SNAPSHOT; reverted GeographicBoundingBox |
24973 | 2007-03-30 | chorner | GEO-93: GeoTools/GeoAPI ISO 19115 Metadata synchronization |
24925 | 2007-03-27 | jgarnett | change to org.opengis.geometry |
24510 | 2007-02-19 | desruisseaux | Moved 'isIdentity(double tolerance)' method from AbstractMathTransform to LinearTransform interface. |
24485 | 2007-02-16 | simboss | -first bunch of changes for the alignment of trunk with 2.3.x |
24140 | 2007-02-01 | desruisseaux | Grouped coverage-related hints together. Edition in javadoc and code formatting. |
24116 | 2007-01-31 | simboss | -added more general method for comparing envelopes with tolerance |
22997 | 2006-11-26 | desruisseaux | Replaced the use of some deprecated methods (MonolineFormatter.initGeotools --> Logging.forceMonolineConsoleOutput; Utilities.unexpectedException --> Logging.unexpectedException; GeneralEnvelope.getCoordinateReferenceSystem --> Envelope.getCoordinateReferenceSystem). |
22711 | 2006-11-12 | desruisseaux | Moved the GeneralGridGeometry.getEnvelope(...) static method as a GeneralEnvelope constructor. |
22710 | 2006-11-12 | desruisseaux | Review of coverage branch merge: In 'CategoryList', check for the 'no data' category name only if the geophysics value is some NaN value. Moved XAffineTransform to a public place and added methods for testing axis swapping, as a proposed replacement for 'GeneralGridGeometry.swapXY(CoordinateSystem)' (replacement not yet done; waiting for the okay from the mailing list). In GeneralGridGeometry, added methods for returning a math transform relative to some pixel corner instead of pixel center, as a proposed replacement for the 'getTransform(...)' public static methods (I would like to remove those static methods in order to keep the API a little bit more orthogonal). |
22646 | 2006-11-08 | desruisseaux | Completed (but not yet tested) a first implementation of MathTransformBuilder.getTransformation(). |
22443 | 2006-10-27 | desruisseaux | Splitted referencing, extracting metadata in their own module (GEOT-983). As a side effect, replaced some calls of CRSUtilities.foo(...) by CRS.foo(...). |
22327 | 2006-10-23 | desruisseaux | GEOT-982: regroup 'module', 'plugin', 'ext' and 'unsupported' in a common directory. |
22315 | 2006-10-22 | desruisseaux | Reorganisation of directory tree structure (GEOT-982) phase 1: moved 'src' to 'src/main/java'. |
20874 | 2006-08-07 | jgarnett | ip review |
20652 | 2006-07-21 | desruisseaux | Renamed some resources. Changed exception type. |
20139 | 2006-06-22 | desruisseaux | Merging the coverage branch to trunk: the main change (the only one?) in the referencing module seem to be the GeneralEnvelope.equals(...) method. |
18374 | 2006-03-01 | desruisseaux | One more CRS test. Addition of GeneralEnvelope.equals(Envelope, double epsilon) method. |
17934 | 2006-02-09 | desruisseaux | Additional testing in GO-1 initial implementation (GEOT-415). |
17916 | 2006-02-08 | desruisseaux | Moved the basic graphic primitive framework to the 'canvas' package in order to get access to protected methods. Initial test suite. Bug fixes (GEOT-415). |
17890 | 2006-02-06 | desruisseaux | First draft of a partial port of J2D-renderer to a GO-1 implementation. |
17720 | 2006-01-24 | desruisseaux | Method signature change in GeneraleEnvelope before 2.2-RC1 release. This is a compatible change if the user recompile its code. |
17672 | 2006-01-19 | desruisseaux | Added @source tag. |
17660 | 2006-01-18 | desruisseaux | Fixed SVN attributes, including the addition of URL attribute. |
17588 | 2006-01-13 | desruisseaux | Added plugin dependencies management in Maven 2 build (GEOT-691). Added a first draft of javadoc plugin with custom taglets. |
17460 | 2006-01-05 | desruisseaux | Added support classes for GO-1 implementation. Partial Maven 2 fixes for the new module/renderer module. |
16526 | 2005-10-27 | desruisseaux | More responsabilities moved from GridCoverage2D to GridGeometry2D (GEOT-701). This refactoring had a significant impact on Resample2D; the rest of the code should stay neutral. |
16172 | 2005-10-10 | desruisseaux | Moved a JTS dependency from the CRS class to the JTS class (GEOT-716) |
15736 | 2005-09-19 | desruisseaux | Added convenience methods or constructors |
15350 | 2005-08-16 | desruisseaux | Merged the 'split-main' branch to trunk (GEOT-662) |
15256 | 2005-08-09 | desruisseaux | Extraction of referencing module from main |
15255 | 2005-08-09 | desruisseaux | Prepare branch for splitting main |
14834 | 2005-07-20 | desruisseaux | Reorganized I18N resources |
14549 | 2005-06-16 | desruisseaux | Renamed PropertyParser as MetadataBuilder; renamed as well their related classes. |
13925 | 2005-05-30 | desruisseaux | Added @since javadoc tag |
13046 | 2005-04-10 | desruisseaux | First "should be working" (translation: "not yet tested") version of CoverageStack. |
13045 | 2005-04-10 | desruisseaux | More CoverageStack work |
12985 | 2005-04-06 | desruisseaux | First draft of CoverageStack |
12960 | 2005-04-04 | desruisseaux | Added convenience wrapper methods |
11960 | 2005-03-10 | desruisseaux | First draft of GridCoverage 'resampler' operation port |
11001 | 2005-02-02 | desruisseaux | Fixed wrong encoding in main/src |
10796 | 2005-01-28 | dzwiers | imports cleaned |
6333 | 2004-06-06 | desruisseaux | Continuing CRS implementation |