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Introduction
This chapter describes how to format the graphic objects created with 
the drawing tools described in Chapter 5.

The formatting of each graphic object, in addition to its size, rotation 
and position on the slide, is determined by a number of attributes that 
define the line, text and area fill of each object. These attributes 
(among others) also contribute to form a graphics style, so although 
this chapter discusses the formatting when applied manually to an 
object, you can use the same methods to build a collection of graphics 
styles.

Using graphics styles to format graphics
In many situations where a presentation contains only a few graphic 
objects, manual formatting can be an efficient way to change their 
appearance. However, when you want to achieve consistency in the 
style across the slides of your presentation (or your presentations 
portfolio), or simply when you want to apply the same formatting to a 
large number of objects, the best approach is to use graphics styles.

Graphics styles are the equivalent for graphic objects to the 
presentation styles for text. A graphics style groups all the formatting 
attributes that a graphic object could have and associates this set to a 
name, making them quickly reusable. If a style is modified (for 
example, by changing the area transparency), the changes are 
automatically applied to all the graphics with that style.

Using the inheritance properties of styles also achieves professional 
results in a short time. For example, if multiple lines change in color 
but are otherwise identically formatted, the best way to proceed is to 
define a generic style for the line and a number of hierarchically 
dependent styles which only differ in the line color attribute. If later 
you need to change the arrowhead style or the thickness of the lines, it 
is sufficient to change the parent style and all the other styles will 
change accordingly.

When creating several presentations, a library of well-defined graphics 
styles is an invaluable tool for speeding up the process of formatting a 
new presentation while achieving the desired appearance.
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To create a new style, follow the procedures outlined in Chapter 2. As 
shown in Figure 1, the dialog box to create a graphics style consists of 
15 pages (14 if Asian Typography has not been enabled).

• The Organizer page, which contains a summary of the style and 
its hierarchical position, is discussed in Chapter 2.

• The Font, Font Effects, Indents & Spacing, Alignment, Tabs and 
Asian typography pages, which set the properties of the text and 
are shared with presentation styles, are discussed in detail in 
Chapter 3.

• The Dimensioning page is used to set the style of dimension lines 
and it is not normally used in presentations. For further details 
refer to the Draw Guide.

• The remaining pages (Text, Text animation, Connector, Line, Area, 
Shadowing, and Transparency) contain the same options as the 
dialogs for manual formatting of the Line, Area, Text and 
Connectors; they are discussed in this chapter.

Note
In most of the cases you will not need to configure the 
parameters of every page; for example, to create a simple line 
style you will probably only use 3 of the 15 pages.

Figure 1: The dialog box for defining a custom 
graphics style
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To apply a style, select the object (or objects) and click on the style 
from the Styles and Formatting window. If the window is not showing, 
press F11, or click the Styles and Formatting icon at the left-hand end 
of the formatting bar, or select Format > Styles and Formatting 
from the menu bar. Press F11 again when the dialog box is not needed, 
to maximize the workspace area.

Formatting lines and shapes
Use the Format menu to modify lines and shapes.

1) Click on the shape or line to select it.
2) Click Format in the menu bar. Some of the options may not be 

available (grayed out) because of the type of object selected. For 
example, if the object is a simple line, the Area choice will be 
unavailable because a line does not have an area to fill.

3) Select one of the formatting options:
• Line to set the characteristics of the line, including the border 

of an area (see “Formatting lines” on page 11).
• Area to format the fill, or interior, of an object. This includes 

color, transparency, and pattern (see “Formatting areas“ on 
page 14).

• Position and Size to move, rotate, and manipulate an object 
according to specified measurements (see “Moving, resizing
and rotating a graphic object” on page 6).

• Text to format the appearance of the text that can be added to 
any shape or line (see “Formatting text“ on page 27).

Most of these commands are also available for selection in the pop-up 
menu that appears by right-clicking on the object.

Moving, resizing and rotating a graphic 
object
This section describes the mechanisms that are available in Impress to 
move, resize and rotate a graphic object. Note that the same 
procedures can be applied equally to a picture (see Chapter 4) and to a 
graphic (see Chapter 5).
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Moving graphic objects
1) Click the graphic object, if necessary, to show the green resizing 

handles.
2) Move the pointer over the graphic object until the pointer 

changes shape. On most operating systems, the cursor associated 
with moving objects is a four-headed arrow, but it may also be a 
hand or some other symbol.

3) Click and drag the graphic object to the desired position.
4) Release the mouse button.

For a more accurate placement of the graphic object, use the Position 
and Size dialog box shown in Figure 2. To open this dialog box, first 
select the graphic object by clicking on it; when the resizing green 
handles are displayed, either press F4 or select Format > Position 
and Size from the menu bar.

Use the Position section of the dialog box to specify the X (horizontal) 
and Y (vertical) position of the graphic object. The values represent the 
distance of the base point (selected  on the right hand side of the 
dialog box) relative to the top left corner of the slide.

To prevent accidental modification of the position of the graphic object, 
select the Position option in the Protect section (bottom left) of the 
dialog box.

The unit of measurement for this and the other dialog boxes in this 
section is set in Tools > Options > OpenOffice.org Impress > 
General.
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Figure 2: Fine adjustment of position and size of the 
graphic object

Resizing graphic objects
1) Click the graphic object, if necessary, to show the green resizing 

handles.
2) Position the pointer over one of the green resizing handles. The 

pointer changes shape, giving a graphical representation of the 
direction of the resizing.

3) Click and drag to resize the graphic object.
4) Release the mouse button when satisfied with the new size.

The corner handles resize both the width and the height of the graphic 
object simultaneously, while the other four handles only resize one 
dimension at a time.

Tip
To retain the original proportions of the graphic, Shift+click one 
of the corner handles, then drag. Be sure to release the mouse 
button before releasing the Shift key.

For more accurate resizing of the graphic object, use the Position and 
Size dialog box (Figure 2). Select as the base point the part of the 
graphic object that you would like to anchor to the page. The default 
setting (top left corner) means that the when resizing the area, the 
position of the top left corner of the area will not change. Now modify 
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either the Width value or the Height value of the object. To maintain 
the proportions between width and height, select the Keep ratio 
option before modifying any value. Notice that when the option is 
selected both dimensions change simultaneously.

To prevent accidental modifications of the size, make sure that the 
Size option is selected in the Protect section in the bottom left part of 
the dialog box.

Rotating graphic objects
As for the position and the size, rotation of an object can be done 
manually or using a dedicated dialog box. To rotate a graphic manually, 
do as follows:

1) Select the graphic object if necessary so that the green handles 
around it show.

2) Click the Rotate button  on the Drawing toolbar. This toolbar 
is usually located at the bottom the screen, but it can be 
undocked and used as a floating toolbar. If the toolbar is not 
showing, select View > Toolbars > Drawing. The Drawing 
toolbar is discussed in detail in Chapter 5.

Note

The icons representing the functions in the toolbars are different 
depending on the operating system used and on whether OOo 
has been customized for the Linux distribution in use or not. 
When in doubt, hover the mouse over the icons and wait for the 
tooltip to appear showing the name of the button.

3) Eight red handles replace the green square handles, as shown in 
Figure 3. Move the mouse over one of the corner handles and the 
mouse cursor shape will change. Click the mouse and move in the 
direction in which you want to rotate the graphic object.

4) When satisfied release the mouse button.

Figure 3: Shape showing the 
red rotating handles. Only 
the corner ones are active.
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At step 2) a black crosshair with a circle appears in the middle of the 
picture: this represents the pivot point for the rotation. Normally the 
center of the picture will be just fine, but on some occasions you may 
wish to rotate around a corner or even around a point outside the 
picture; to do that, click on the crosshair and drag it to the desired 
position.

To restrict the rotation angles to multiples of 15 degrees, press the 
Shift key while rotating the graphic. This is very handy to rotate 
pictures of right angles, for example from portrait to landscape or vice 
versa.

Instead of rotating a graphic object manually, you can use the 
Rotation dialog box shown in Figure 4. To display this dialog box, 
select the graphic object so that the green resizing handles are shown, 
then press F4 or select Format > Position and Size and select the 
Rotation page.

Figure 4: The Rotation page of the Position and Size 
dialog box

In the top part of the dialog box, select the position of the pivot point 
relative to the top left corner of the page. The default position of the 
pivot point is the center of the figure.

In the lower part of the dialog box select the angle by which to rotate 
the graphic object. On the right hand side 8 default rotation values are 
easily configurable by selecting the desired button.
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Formatting lines
The dialog box to format the line properties is shown in Figure 5. It 
contains three pages.

The Line page is further subdivided into four parts handling different 
aspects of the line.

The Line Properties section (left side) is the most important. It includes 
the following parameters:

• Line style: a variety of line styles is available in the drop-down 
list, but more can be defined if needed.

• Color: pick among the already defined colors. If a color not in the 
list is needed, refer to “Creating colors” on page 15 to create a 
new one.

• Width: specifies the thickness of the line.
• Transparency: sets the transparency value of the line, a useful 

property when you do not want to hide completely what is under 
the line.

Figure 5: Main line formatting dialog box

The Arrow styles section of this page is only applicable to line 
segments; it has no effect on the line that forms the border of a shape 
or of a polygon. Use this section to set the styles of the two ends of the 
segment. You can configure independently the two ends, selecting for 
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each of them the arrow shape (Style drop-down menu), the Width, and 
the termination style (Center option). Selecting the Center option 
moves the center of the arrowheads to the end point of the line. If the 
two ends should be identical, select the Synchronize ends option. To 
create new arrowheads, use the Arrow styles page, as described in the 
following section.

Use the Corner style section of this page to choose how the connection 
between two segments should look. There are four available options in 
the drop-down menu. To appreciate the difference between corner 
styles, choose a thick line style and observe how the preview changes.

The bottom part of the page shows a preview of the applied style and a 
preview of two corners so that the corner style choice can be quickly 
evaluated. 

Creating line styles
Use the Line Styles page of the Line dialog box (shown in Figure 6) to 
create new line styles and load previously saved line styles. Normally it 
is not a good practice to modify the predefined styles; instead, create 
new ones when necessary.

Figure 6: Advanced options for creating line styles

To create a new line style:
1) Choose Format > Line from the menu bar.
2) Select from the Line style drop-down menu a style similar to the 

desired one.
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3) Click Add. On the pop-up dialog box, type a name for the new line 
style and click OK.

4) Now define the new style. Start by selecting the line type for the 
new style. To alternate two line types (for example, dashes and 
dots) within a single line, select different types in the two Type 
boxes.

5) Specify the number and length (not available for dot style) of each 
of the types of line selected, set the spacing between the various 
elements, and decide if the style should fit to the line width 
(length).

The new line style is available only in the current presentation. If you 
want to reuse the line style in other presentations, click the Save Line 
Styles icon and type a memorable name. This saves all of the line 
styles in this presentation. (Saved styles have a file extension of .sod.)

To make previously saved line styles available in the current 
presentation, click the Load Line Styles icon, select the saved list of 
styles, and click Open.

Use the Modify button to change the name of the style. Recommended 
only for custom line styles, not the built-in ones.

Creating arrow styles
Use the third page of the Line dialog box to create new arrow styles, 
modify existing arrow styles, or load previously saved arrow styles.

1) The first step is to draw a curve with the shape you want for the 
arrowhead.

Note
The arrowhead must be a curve. A curve is something you could 
draw without lifting a pencil. For example,  is a curve but  is 
not a curve.

2) Select the curve. With the resizing handles showing, select 
Format > Line from the menu bar, or right-click and choose Line 
from the pop-up menu.

3) Go to the Arrow styles page (Figure 7), click the Add button, type 
a name for the new arrow style, and click OK.

4) Now you can access the new style from the Arrow style list. When 
you select the name of the new style, it is shown at the bottom of 
the dialog box.
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Figure 7: Advanced options for creating arrow styles

Formatting areas
Impress offers many different options for formatting the fill of an area.

1) Start by selecting the object to which the formatting will be 
applied.

2) When the resizing handles appear, select Format > Area from 
the menu bar. The dialog box shown in Figure 8 is displayed.

Figure 8: Area page of the area formatting dialog box
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3) Select the desired type of fill from the drop-down list. The Area 
page changes to display the choices available for that fill style, as 
described on the following pages.

4) Select the required fill and its parameters, and then click OK to 
close the dialog box and apply your selection.

Picking the type of fill from the five available choices (None, Color, 
Gradient, Hatching, and Bitmap) modifies the entries in the list below 
and makes some new options appear in the Area page. The list is 
populated with the default choices for the selected fill type. For more 
options you can use the settings on  the page with the corresponding 
name in the same dialog box.

Creating area fills
Impress comes with many pre-defined area fills in four categories: 
colors, gradients, hatching patterns, and bitmaps. If none of the 
provided fills is satisfactory, you can fully customize them and create 
new fills. The following sections describe how to create new fills and 
how to apply them.

On each page of the Area dialog box, to modify the characteristics of 
an existing fill, change those characteristics in the dialog box and then 
click the Modify button. (In some cases, you can also change the name 
of the fill in the same step.) However, it is recommended to create new 
fills or modify custom fills, and not change the pre-defined ones.

Colors
For color fills, select one from the list on the Area page, as shown in 
Figure 8.

Creating colors
On the Colors page, shown in Figure 9, you can modify existing colors 
or create your own.

Every color is specified by a combination of the three primary colors 
(Red, Green and Blue), hence the notation RGB. To create a new color:

1) Enter the name for the color in the Name box.
2) Specify the red, green and blue component on a 0 to 255 scale. 

Alternatively specify the Cyan, Magenta, Yellow and black (K) 
components, from 0% to 100%.

3) Click the Add button. The color is now added to the list on the 
Area page.
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Figure 9: A custom color has been added to the list

To modify a color:
1) Select the color to modify from the list.
2) Enter the new values that define the color (if necessary change 

the settings from RGB to CMYK or viceversa).
3) Modify the name as required.
4) Click the Modify button.

Alternatively, use the Edit button (this will open a new dialog box), 
modify the color components as required and click OK to exit the 
dialog box.

Tip

You can also add custom colors using Tools > Options > 
OpenOffice.org > Colors. This method makes the color 
available to all components of OOo, whereas colors created 
using Format > Area > Colors are only available for Impress.

Gradients
A gradient fill provides a smooth transition from one color to another. 
The transition pattern may vary from a simple linear transition to a 
more complex radial transition.

If the predefined gradients are not satisfactory, you can create a new 
gradient or modify an existing one.
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Select Gradient in the drop-down list on the Area page and pick the 
gradient from the list (see Figure 10). To manually input the number of 
steps (increments) that should be applied, deselect the Automatic 
option and enter the number of steps required.

Figure 10: Selecting a gradient fill

Creating gradients
To create a new gradient or to modify an existing one, select the 
Gradients page from the Area dialog box (shown in Figure 11). Several 
types of gradients are predefined and in most cases changing the From 
and To colors will be sufficient to obtain the desired result.

Figure 11: The Gradients page of the Area dialog box
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It is highly recommended to create a new gradient even if you just 
want to change the two colors rather than modifying the predefined 
ones which should only be used as starting points.

To create a new gradient:
1) First choose the From and To colors (Figure 12).

Figure 12: Gradient transition color 
selection

2) Then choose a type of gradient from the list: Linear, Axial, Radial, 
Ellipsoid, Square or Rectangular.
A preview of the gradient type is shown under the available 
gradients list in the middle of the dialog box. Figure 11 shows an 
example.

Figure 13: Center option in a radial 
gradient

3) Depending on the chosen type some options will be grayed out. 
Set all the properties as desired (very often the default values will 
work well). The properties to set to create a gradient are 
summarized in Table 1.

4) Click the Add button to add the newly created gradient to the list. 
The gradient is now available to all the OOo components and also 
for future presentations. It pays to give it a memorable name.
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Table 1: Gradient properties

Property Meaning

Center X For Radial, Ellipsoid, Square and Rectangular gradients, 
modify these values to set the horizontal offset of the 
gradient center. 

Center Y For Radial, Ellipsoid, Square and Rectangular gradients, 
modify these values to set the vertical offset of the gradient 
center. 

Angle Specifies for all the gradient types the angle of the gradient 
axis

Border Increase this value to make the gradient start further away 
from the border of the shape

From Set here the start color for the gradient. In the edit box 
below enter the intensity of the color: 0% corresponds to 
black, 100% to the full color.

To Set here the end color for the gradient. In the edit box 
below enter the intensity of the color: 0% corresponds to 
black, 100% to the full color.

Hatching
A hatching fill is a pattern of lines that is repeated throughout the 
area. 

To apply a hatching pattern to an area, go to the Area page, select 
Hatching from the drop-down list and then select the desired hatching 
from the list (Figure 14). To apply a background color to the hatching 
pattern, selecting the Background color option and choose a color 
from the drop-down list.

As for gradients and colors, if the predefined patterns are not 
satisfactory, you can create a new pattern or modify a predefined one.

Creating hatching patterns
You can create new hatching patterns or modify existing ones. Start by 
selecting the Hatching page of the Area dialog box. This is shown in 
Figure 15.

As for gradients and colors, if the predefined patterns are not 
satisfactory, it is recommended to create a new pattern rather than 
modify a predefined one.
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Figure 14: Selecting a hatching fill pattern

To do so:
1) Select a pattern similar to the one that will be created as a 

starting point.
2) Modify the properties of the lines forming the pattern. A preview 

is displayed in the window below the available patterns.
3) Click the Add button and choose a name for the newly created 

hatching.

The properties that can be set for a hatching pattern are shown in 
Table 2.

Figure 15: The Hatching fill dialog box
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Table 2: Properties of hatching patterns

Property Meaning

Spacing Determines the spacing between two lines of the pattern. 
As the value is changed the preview window is updated. 

Angle Use the mini map below the numerical value to quickly set 
the angle formed by the line to multiples of 45 degrees. If 
the required angle is not a multiple of 45 degrees, just 
enter the desired value in the edit box.

Line type Set single, double or triple line for the style of the pattern.

Line color Use the list to select the color of the lines that will form the 
pattern.

Bitmaps
The last type of fill for an area is the bitmap fill.

On the Area page, chose Bitmap from the drop-down list. Select from 
the list of bitmaps the one to be used to fill the area. Note that any 
imported bitmaps should be available in the list.

Set the size, position and offset parameters (as applicable) in the right 
hand side of the page, and then click OK to close the dialog box.

As Figure 16 shows, when using a bitmap fill there are quite a number 
of parameters to be configured. These are described in Table 3.

Figure 16: Advanced formatting for bitmap fill
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Table 3: Bitmap fill properties

Property Meaning

Size – Original Select this box to retain the original size of the 
bitmap.

Size – Relative To rescale the object deselect the Original option and 
select this one. The Width and Height edit boxes are 
enabled.

Size – Width When Relative is selected 100% means that the 
bitmap original width will be resized to occupy the 
whole fill area width, 50% means that the width of 
the bitmap will be half that of the fill area.

Size – Height When Relative is selected 100% means that the 
bitmap original height will be resized to occupy the 
whole fill area height, 50% means that the height of 
the bitmap will be half that of the fill area.

Position – Anchor 
Map

Select from the map the place of the area where the 
bitmap should be anchored to.

Position – X offset When tiling is enabled, enter in this box the offset for 
the width of the bitmap in percentage values. 50% 
offset means that at the anchor point of the bitmap 
OOo will place the middle part of the bitmap and 
start tiling from there.

Position – Y offset This will have the same effect of the X offset, but will 
work on the height of the bitmap.

Position – Tile When this option is selected the bitmap will be tiled 
to fill the area. The size of the bitmap used for the 
tiling is determined by the Size settings.

Position – Autofit Stretches the bitmap to fill the whole area. Selecting 
this option disables all the size settings.

Offset – Row If tiling is enabled offsets the rows of tiled bitmaps 
by the percentage entered in the box so that two 
subsequent rows are not aligned.

Offset – Column If tiling is enabled, offsets the columns of tiled 
bitmaps by the percentage entered in the box so that 
two subsequent columns of bitmaps are not aligned.

The way some of these parameters work is difficult to describe; the 
best way to understand them is to use them. Some examples of bitmap 
fills are given in Figure 17 along with the parameters used.
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Figure 17: Some examples of bitmap fill

Creating and importing bitmaps
As for the other types of fill, OOo comes with a number of predefined 
bitmaps, but you can also add (import) new ones or to create your own 
pattern on a 8x8 grid, using the Bitmaps page of the Area dialog box 
(shown in Figure 18).

To create a bitmap fill:
1) Start with the Blank bitmap type on top of the list to activate the 

Pattern editor.
2) Select the Foreground and Background colors.
3) Start creating the pattern by clicking with the left mouse button 

the squares (pixels) that you want to be painted in the foreground 
color. Use the right mouse button to apply the background color. 
Check the preview window to see if the desired effect is achieved.

4) When done, click Add to save the pattern.
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Figure 18: The Bitmaps page of the Area fill dialog 
box.

To import a bitmap created in Draw or another program:
1) Click the Import button.
2) A file picker dialog box is displayed. Browse to the directory 

containing the bitmap file and select it, then click Open.
3) Type a name for the imported bitmap and click OK.

Formatting shadows
Shadowing can be applied to both lines and areas. To apply a shadow 
to an area, first select the object to which shadowing should be 
applied, then select Format > Area.

Shadows can also be applied to lines, but it is not very obvious how to 
do it. One way is to click the Shadow icon on the Line and Filling 
toolbar (see the last tool in Figure 19). The other way is to apply a style 
to the line that uses a shadow (see “Using graphics styles to format
graphics” on page 4 for additional information on using styles). 

Figure 19: The Line and Filling toolbar provides quick access 
to many common formatting tools
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Using the first method, you cannot customize the shadow; it is applied 
according to the default settings. The second method offers full 
flexibility to configure the shadow properties. If the Line and Filling 
toolbar is not shown when selecting an object, open it using View > 
Toolbars on the menu bar.

The dialog box to customize a shadow is shown in Figure 20.

Figure 20: Dialog box for customizing the shadowing of 
graphic objects

When the Use shadow option is selected, the following parameters 
can be set:

• Position: the selected point in the mini map determines the 
direction in which the shadow is cast.

• Distance: determines the distance between the object and the 
shadow.

• Color: sets the color of the shadow.
• Transparency: determines the amount of transparency for the 

shadow.

Tip
By setting the transparency value above 0%, the objects below 
the shadow are not completely hidden by the shadow. This 
produces a pleasant visual effect, as shown in Figure 21.
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Figure 21: Shadow with 50% 
transparency

Transparency formatting
Transparency is applicable to lines, areas, and shadows. To apply 
transparency to lines, refer to “Formatting lines” on page 11; for 
shadows, refer to “Formatting shadows” on page 24.

To apply transparency to areas, select Format > Area and then go to 
the Transparency page shown in Figure 22.

Figure 22: Setting the object transparency

There are two types of transparency: one which is uniformly applied to 
all the area of the object, and the gradient one. To obtain a uniform 
transparency, select Transparency and then select the percentage of 
transparency required. For a gradient transparency so that the area 
becomes gradually transparent, select Gradient and then set the 
parameters of the gradient:

• Type: pick between Linear, Axial, Radial, Ellipsoid, Quadratic or 
Square.
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• Center X, Y: for some types of gradient, you can specify the 
position of the center in percentage points.

• Angle: the angle of the gradient, applicable to all but the radial 
type of gradients.

• Border: the percentage of the shape (measured from the edge) 
that is not subject to the gradient settings.

• Start value: the transparency value of the start point of the 
gradient: 0% is fully opaque, 100% means fully transparent.

• End value: the transparency value of the end point of the 
gradient: 0% is fully opaque, 100% fully transparent.

Formatting text
Impress provides two separate dialog boxes related to text formatting.

• To modify the formatting such as font, font effects and so on, 
select the text in the shape and then go to Format > Character. 
This is covered in Chapter 3.

• To determine how the text which is added to a line or a shape 
behaves, use the settings on the Text dialog box, as described in 
this section.

Before formatting text, add it to the object (a shape or a line):
1) Select the object to which text will be added.
2) With the green (or blue) resizing handles showing, double-click on 

the object and wait for the cursor to become an I-beam or just 
start typing.

3) Type the text. When finished, click somewhere outside the object 
or press Esc.

To format the text in a shape:
1) Select the object to which text was added.
2) Select Format > Text or right-click on the shape and select Text 

from the pop-up menu. The Text dialog box (Figure 23) is 
displayed.
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Figure 23: Main dialog box to set the text properties

The top section of the dialog box offers several options in the form of 
options. Some of the options will be grayed out, depending on the 
object to which the text will be attached.

• Select Fit width to text to expand the width of the shape or line 
if the text is longer than it.

• Select Word wrap text in shape to automatically start a new line 
when the edge of the shape is reached.

• Select Fit height to text to expand the object height whenever it 
is smaller than the text (set by default for lines.

• Select Resize shape to fit text to expand a custom shape when 
the text inserted in the shape is too large.

• Select Fit to frame to expand the text so that it fills all the 
available space.

• Select Adjust to contour to make the text follow a curved line.

In the Spacing to borders section, specify the amount of space to be 
left between the border of the shape or line and the text; this is similar 
to the settings for indentation and spacing for paragraphs.

The text anchor grid is used to decide where to anchor the text. The 
Full width option determines if the anchoring should be performed to 
the full width of the shape.
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Text animation
Use this page to specify special effects applied to the text. Choose 
between four options in the list and where applicable the direction of 
the effect picking one of the four arrow buttons to the right. The 
available effects are:

• Blink: the text will blink on the screen.
• Scroll through: the text will move into the shape and then out 

following the chosen direction.
• Scroll back and forth: the text will not exit the shape border 

and move first in the chosen direction.
• Scroll in: the text will scroll in towards the given direction 

starting from the edge of the shape.

By default no animation is applied.

The other properties that can be set are:
• Start inside option: when set the animation will start from inside 

the shape.
• Text visible when editing option: set this box to see the text 

while editing.
• Animation cycles: includes three further options to set the 

frequency of the animation, the increments between two positions 
of the animation and finally the delay before the animation starts.

To see some of the animations in action, it is necessary to start the 
presentation. Press F9 or select Slide Show > Slide Show from the 
main menu. To return to the edit mode, press Esc.

Formatting connectors
Connectors are lines that join two shapes. Connectors stem from a 
glue point of the shape. Refer to Chapter 5 (Creating Graphic 
Objects) for a description of the usage of connectors.

Connector properties can be accessed and modified in two ways:
• Manual formatting: right-click on the connector line and select 

Connector in the pop-up menu.
• Style-based formatting: select one of the available graphics styles 

or create a new one as discussed in “Using graphics styles to
format graphics” on page 4.

Both methods open the Connector dialog box (shown in Figure 24) 
where you can set the style of the connectors. Choose between 
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Standard (the default), Line, Straight, and Curved connector. 
Whenever multiple connectors overlap, use the Line skew section of 
the dialog box to distance the lines. It is possible to customize the 
distance between 4 different lines.

In the Line spacing section of the dialog box, set the horizontal and 
vertical space between the connector and the object at each end of the 
connector.

Figure 24: Setting up the connector properties
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