
Calc Guide

Chapter 3
 Creating Charts and 

Graphs
Presenting information visually

This PDF is designed to be read onscreen, two pages at a 
time. If you want to print a copy, your PDF viewer should 
have an option for printing two pages on one sheet of 
paper, but you may need to start with page 2 to get it to 
print facing pages correctly. (Print this cover page 
separately.)



Copyright
This document is Copyright © 2009 by its contributors as listed in the 
section titled Authors. You may distribute it and/or modify it under the 
terms of either the GNU General Public License, version 3 or later, or 
the Creative Commons Attribution License, version 3.0 or later.

All trademarks within this guide belong to their legitimate owners.

Authors
Richard Barnes
John Kane
Peter Kupfer
Shelagh Manton
Alexandre Martins
Jean Hollis Weber
Linda Worthington

Feedback
Please direct any comments or suggestions about this document to: 
authors@user-faq.openoffice.org

Acknowledgments
Shelagh Manton and Jean Hollis Weber updated the OOo2.x chapter 
written by the other authors.

Publication date and software version
Published 17 May 2009. Based on OpenOffice.org 3.1.

You can download
 an editable version of this document from

 http://oooauthors.org/en/authors/userguide3/published/

http://oooauthors.org/en/authors/userguide3/published/
mailto:authors@user-faq.openoffice.org
http://creativecommons.org/licenses/by/3.0/
http://www.gnu.org/licenses/gpl.html


Contents
Copyright...............................................................................................2

Introduction...........................................................................................5

Creating a chart.....................................................................................5

Choosing a chart type.........................................................................8

Changing data ranges and axes labels................................................8

Selecting data series...........................................................................9

Adding or changing titles, legend, and grids....................................10

Editing charts.......................................................................................11

Changing the chart type...................................................................11

Adding or removing chart elements..................................................11

Data labels.....................................................................................13

Trend lines.....................................................................................14

Mean value lines............................................................................16

Y error bars....................................................................................16

Formatting charts................................................................................17

Moving chart elements.....................................................................18

Changing the chart area background...............................................19

Changing the chart graphic background..........................................20

Changing colors................................................................................20

Formatting 3D charts...........................................................................20

Rotation and perspective..................................................................20

Appearance.......................................................................................21

Illumination.......................................................................................22

Rotating 3D charts interactively.......................................................23

Using the Object Properties dialog......................................................23

Scaling axes......................................................................................24

Formatting data labels and axis labels..............................................24

Choosing and formatting symbols.....................................................25

Resizing and moving the chart.............................................................26

Using the Position and Size dialog....................................................27

Creating Charts and Graphs 3



Gallery of chart types...........................................................................28

Column charts...................................................................................28

Bar charts.........................................................................................28

Pie charts..........................................................................................29

Donut charts.....................................................................................30

Area charts.......................................................................................31

Line charts........................................................................................32

Scatter or XY charts..........................................................................33

Net charts.........................................................................................34

Stock charts......................................................................................35

Column and line charts.....................................................................35

4 Creating Charts and Graphs



Introduction
Charts and graphs can be powerful ways to convey information to the 
reader. OpenOffice.org Calc offers a variety of different chart and 
graph formats for your data.

Using Calc, you can customize charts and graphs to a considerable 
extent. Many of these options enable you to present your information 
in the best and clearest manner.

For readers who are interested in effective ways to present information 
graphically, two excellent introductions to the topic are William S. 
Cleveland’s The elements of graphing data, 2nd edition, Hobart Press 
(1994) and Edward R. Tufte’s The Visual Display of Quantitative 
Information, 2nd edition, Graphics Press (2001).

Creating a chart
To demonstrate the process of making charts and graphs in Calc, we 
will use the small table of data in Figure 1.

Figure 1: Table of data for charting examples

To create a chart, first highlight (select) the data to be included in the 
chart. The selection does not need to be in a single block, as shown in 
Figure 2; you can also choose individual cells or groups of cells 
(columns or rows). See Chapter 1 (Introducing Calc) for more about 
selecting cells and ranges of cells. 
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Figure 2: Selecting data for plotting

Next, open the Chart Wizard dialog using one of two methods.

•  Select Insert > Chart from the menu bar as shown in Figure 3.

Figure 3: Insert chart from menu bar

• Or, click the Chart icon on the main toolbar (Figure 4).
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Figure 4: Insert chart from main toolbar

Either method inserts a sample chart on the worksheet, opens the 
Formatting toolbar, and opens the Chart Wizard, as shown in Figure 5.

Tip

If you place the cursor anywhere in the area of the data, the 
Chart Wizard will do a fairly good job of guessing the range of 
the data. Just be careful that you have not included the title of 
your chart.

Figure 5: Chart Wizard, Step 1—Choose a chart type
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Choosing a chart type
The Chart Wizard includes a sample chart with your data all ready to 
work with. This sample chart updates to reflect the changes you make 
in the Chart Wizard.

The Chart Wizard has three main parts: a list of the steps involved in 
setting up the chart, the list of chart types, and the options for each 
chart type. At any time you can go back to a previous step and change 
selections.

Calc offers a choice of 9 basic chart types, with a few options for each 
type of chart, giving you a choice of up to 30 charts. Different chart 
types have their own set of appropriate options.

The first tier of choice is for two-dimensional (2D) charts, with only 
those types which are suitable for 3D (Column, Bar, Pie, and Area) 
giving you an option to select a 3D look.

On the Choose a chart type page (Figure 5), select one by clicking on 
its icon. The preview updates every time you select a different type of 
chart, and provides a good idea of what the finished chart will look 
like.

The current selection is highlighted (shown with a surrounding box) on 
the Choose a chart type page. The chart’s name is shown just below 
the icons. For the moment, we will stick with the Column chart and 
click on Next again.

Changing data ranges and axes labels
In Step 2, Data Range (Figure 6), you can manually correct any 
mistakes you have made in selecting the data.

On this page you can also change the way you are plotting the data by 
using the rows—rather than the columns—as data series. This is useful 
if you use a style of chart such as Donut or Pie to display your data.

Lastly, you can choose whether to use the first row or first column, or 
both, as labels on the axes of the chart.

You can accept what you have done so far by clicking the Finish 
button, or click Next to change some more details of the chart. 

We will click Next to see what we can do to our chart using the other 
pages of the Wizard.
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Figure 6: Changing data ranges and axes labels

Selecting data series

Figure 7: Amending data series and ranges

On the Data Series page, you can fine tune the data that you want to 
include in the chart. Perhaps you have decided that you do not want to 
include the data for canoes. If so, highlight Canoes in the Data series 
box and click on Remove. Each named data series has its ranges and 
its individual Y-values listed. This is useful if you have very specific 
requirements for data in your chart, as you can include or leave out 
these ranges.
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Tip
You can click the Shrink button next to the Range for Name 
box to work on the spreadsheet itself. This is handy if your data 
ranges are larger than ours and the Chart Wizard is in the way.

Another way to plot any unconnected columns of data is to select the 
first data series and then select the next series while holding down the 
Ctrl key. Or you can type the columns in the text boxes. The columns 
must be separated by semi-colons. Thus, to plot B3:B11 against 
G3:G11, type the selection range as B3:B11;G3:G11.

The two data series you are selecting must be in separate columns or 
rows. Otherwise Calc will assume that you are adding to the same data 
series.

Click Next to deal with titles, grids, and legends.

Adding or changing titles, legend, and grids

Figure 8: Titles, grids and legends

On the Chart Elements page, you can give your chart a title and, if 
desired, a subtitle. Use a title that draws the viewers’ attention to the 
purpose of the chart: what you want them to see. For example, a better 
title for this chart might be The Performance of Motor and Other 
Rental Boats.

It may be of benefit to have labels for the x axis or the y axis. This is 
where you give people an idea as to the proportion of your data. For 
example, if we put Thousands in the y axis label of our graph, it 
changes the scope of the chart entirely. For ease of estimating data you 
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can also display the x or y axis grids by selecting the Display grids 
options.

You can leave out the legend or include it and place it to the left, right, 
top or bottom.

To finish the chart, click Finish.

Editing charts
After you have created a chart, you may find things you would like to 
change. Calc provides tools for changing the chart type, chart 
elements, data ranges, fonts, colors, and many other options, through 
the Insert and Format menus, the right-click (context) menu, and the 
Chart toolbar.

Changing the chart type
You can change the chart type at any time. To do so:

1) First select the chart by double-clicking on it. The chart should 
now be surrounded by a gray border.

2) Then do one of the following:
• Choose Format > Chart Type from the menu bar.

• Click the chart type icon  on the Formatting toolbar.
• Right-click on the chart and choose Chart Type.

In each case, a dialog similar to the one in Figure 5 opens. See page 8 
for more information.

Adding or removing chart elements
Figures 9 and 10 show the elements of 2D and 3D charts.

The default 2D chart includes only two of these elements:

• Chart wall contains the graphic of the chart displaying the data.
• Chart area is the area surrounding the chart graphic. The 

(optional) chart title and the legend (key) are in the chart area.

The default 3D chart also has the chart floor, which is not available in 
2D charts.
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Figure 9: Elements of 2D chart

Figure 10: Elements of 3D chart

You can add other elements using the Insert menu, as shown in Figure
11. The various choices open dialogs in which you can specify details.

First select the chart by double-clicking on it.

12 Creating Charts and Graphs

Chart area

Chart wall

Chart title

Legend

Axis labels

Chart floor



Figure 11: Insert menu for charts

The dialogs for Title, Axes, Grids, and Legend are self-explanatory. The 
others are a bit more complicated, so we’ll take a look at them here.

Data labels
Data labels put information about each data point on the chart. They 
can be very useful for presenting detailed information, but you need to 
be careful to not create a chart that is too cluttered to read.

Figure 12: Data Labels dialog

The options on the Data Labels dialog are as follows.

Show value as number
Displays the numeric values of the data points. When selected, this 
option activates the Number format button.
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Number format
Opens the Number Format dialog, where you can select the number 
format. This dialog is very similar to the one for formatting numbers 
in cells, described in Chapter 2 (Entering, Editing, and Formatting 
Data).

Show value as percentage
Displays the percentage value of the data points in each column. 
When selected, this option activates the Percentage format button.

Percentage format
Opens the Number Format dialog, where you can select the 
percentage format.

Show category
Shows the data point text labels.

Show legend key
Displays the legend icons next to each data point label.

Separator
Selects the separator between multiple text strings for the same 
object.

Placement
Selects the placement of data labels relative to the objects.

Figure 25 on page 30 shows examples of values as text (neither Show 
value as number nor Show value as percentage selected) and values as 
percentages, as well as when data values are used as substitutes for 
legends or in conjunction with them.

Trend lines
When you have a scattered grouping of points in a graph, you may 
want to show the relationship of the points. A trend line is what you 
need. Calc has a good selection of regression types you can use for 
trend lines: linear, logarithm, exponential, and power. Choose the type 
that comes closest to passing through all of the points.

To insert trend lines for all data series, double-click the chart to enter 
edit mode. Choose Insert > Trend Lines, then select the type of trend 
line from None, Linear, Logarithmic, Exponential, or Power.

To insert a trend line for a single data series, select the data series in 
the chart, right-click to open the context menu, and choose Insert > 
Trend Line.
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To delete a single trend line or mean value line, click the line, then 
press the Del key.

To delete all trend lines, choose Insert > Trend Lines, then select 
None.

A trend line is shown in the legend automatically.

Figure 13: Trend Lines dialog

If you insert a trend line on a chart type that uses categories, such as 
Line or Column, then the numbers 1, 2, 3, … are used as x-values to 
calculate the trend line.

The trend line has the same color as the corresponding data series. To 
change the line properties, select the trend line and choose Format > 
Object Properties > Line.

To show the trend line equation, select the trend line in the chart, 
right-click to open the context menu, and choose Insert Trend Line 
Equation.

When the chart is in edit mode, OpenOffice.org gives you the equation 
of the trend line and the correlation coefficient. Click on the trend line 
to see the information in the status bar. To show the equation and the 
correlation coefficient, select the regression curve and choose Format 
> Object Properties > Equation.

For more detail on the regression equations, see the topic Trend lines 
in charts in the Help.
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Mean value lines
If you select mean value lines, Calc calculates the average of each 
selected data series and places a colored line at the correct level in the 
chart. 

Y error bars
If you are presenting data which has a known possibility of error, such 
as social surveys using a particular sampling method, or you want to 
show the measuring accuracy of the tool you used, you may wish to 
show error bars on the chart. 

Several options are provided on the Y Error Bars dialog (Figure 14). 
You can only choose one option at a time. You can also choose whether 
the error indicator shows both positive and negative errors, or only 
positive or only negative.

Figure 14: Specifying the parameters of error bars

• Constant value – you can have separate positive and negative 
values.

• Percentage – choose the error as a percentage of the data points.
• In the drop-down list: 

– Standard error 
– Variance – shows an error calculated on the size of the biggest 

and smallest data points. 
– Standard deviation – shows error calculated on standard 

deviation.
– Error margin – you designate the error
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• Cell range – calculates the error based on cell ranges you select. 
The Parameters section at the bottom of the dialog changes to 
allow selection of the cell ranges.

Formatting charts
The Format menu has many options for formatting and fine-tuning the 
appearance of your charts.

Double-click the chart so that it is enclosed by a gray border indicating 
edit mode. Click Format in the main menu. See Figure 15.

Figure 15: Chart format menu

• Object Properties opens a dialog in which you can specify the 
area fill, borders, transparency, characters, font effects, and other 
attributes of the selected element of the chart (see page 23).

• Position and Size opens a dialog (see page 27).
• Arrangement provides two choices: Bring Forward and Send 

Backward, of which only one may be active for some items. Use 
these choices to arrange overlapping data series.

• Title formats the titles of the chart and its axes.
• Axis formats the lines that create the chart as well as the font of 

the text that appears on both the X and Y axes.
• Grid formats the lines that create a grid for the chart.
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• Legend formats the location, borders, background, and type of 
the legend.

• Chart Wall, Chart Floor, and Chart Area are described in the 
following sections.

• Chart Type changes what kind of chart is displayed and whether 
it is two- or three-dimensional.

• 3D View formats 3D charts (see page 20).

Note
Chart Floor and 3D View are only available for a 3D chart. 
These options are unavailable (grayed out) if a 2D chart is 
selected.

In most cases you need to make sure to select the exact element you 
want to format. Sometimes this can be tricky to do with the mouse, if 
the chart has many elements, especially if some of them are small or 
overlapping. If you have Tooltips turned on, then as you move the 
mouse over each element, its name appears in the tooltip. Once you 
have selected one element, you can press Tab to move through the 
other elements until you find the one you want. The name of the 
selected element appears in the Status Bar.

Moving chart elements
You may wish to move or resize individual elements of a chart, 
independent of other chart elements. For example, you may wish to 
move the legend to a different place. Pie charts allow moving of 
individual wedges of the pie (in addition to the choice of “exploding” 
the entire pie).

1) Double-click the chart so that is enclosed by a gray border.
2) Click any of the elements—the title, the legend, or the chart 

graphic—to select it. Green resizing handles appear.
3) Move the pointer over the selected element. When it changes 

shape, click and drag to move the element.
4) Release the mouse button when the element is in the desired 

position.

Note

If your graphic is 3D, round red handles appear which control 
the three-dimensional angle of the graphic. You cannot resize or 
reposition the graphic while the round red handles are showing. 
With the round red handles showing, Shift + Click to get the 
green resizing handles. You can now resize and reposition your 
3D chart graphic. See the following tip.

18 Creating Charts and Graphs



Tip
You can resize the chart graphic using its green resizing handles 
(Shift + Click, then drag a corner handle to maintain the 
proportions). However, you cannot resize the title or the key.

Changing the chart area background
The chart area is the area surrounding the chart graphic, including the 
(optional) main title and key.

1) Double-click the chart so that it is enclosed by a gray border.
2) Select Format > Chart Area. The Chart Area window appears. 

See Figure 16.
3) Choose the desired format settings.

Figure 16: Chart Area dialog

On the Area tab, you can change the color, or choose a hatch pattern, 
bitmap or some preset gradients. Click on the drop-down box to see 
the options. Patterns are probably more useful than color if you have to 
print out your chart in black and white.

You can also use the Transparency tab to change the area’s 
transparency. If you used a preset gradient from the Area tab, you can 
see the different parameters that made it.

Formatting charts 19



Changing the chart graphic background
The chart wall is the area that contains the chart graphic.

1) Double-click the chart so that it is enclosed by a gray border.
2) Select Format > Chart Wall. The Chart Wall window appears. 

It has the same formatting options as described in “Changing the
chart area background” above.

3) Choose your settings and click OK.

Changing colors
If you need a different color scheme from the default for the charts in 
all your documents, go to Tools > Options > Charts > Colors, where 
you have a much wider range of colors to choose from. This dialog 
changes the default chart colors for any chart you make in future.

Formatting 3D charts
Use Format > 3D view to fine tune 3D charts. The 3D View dialog has 
three pages, where you can change the perspective of the chart, 
whether the chart uses the simple or realistic schemes, or your own 
custom scheme, and the illumination which controls where the 
shadows will fall. 

Rotation and perspective
To rotate a 3D chart or view it in perspective, enter the required values 
on the Perspective page of the 3D View dialog (Figure 17). You can also 
rotate 3D charts interactively; see page 23.

Some hints for using the Perspective page:

• Set all angles to 0 for a front view of the chart. Pie charts and 
donut charts are shown as circles.

• With Right-angled axes enabled, you can rotate the chart contents 
only in the X and Y direction; that is, parallel to the chart borders.

• An x value of 90, with y and z set to 0, provides a view from the 
top of the chart. With x set to –90, the view is from the bottom of 
the chart.

• The rotations are applied in the order x first, then y, and z last.
• When shading is enabled and you rotate a chart, the lights are 

rotated as if they are fixed to the chart.
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Figure 17: Rotating a chart

• The rotation axes always relate to the page, not to the chart’s 
axes. This is different from some other chart programs.

• Select the Perspective option to view the chart in central 
perspective as through a camera lens instead of using a parallel 
projection.
Set the focus length with the spin button or type a number in the 
box. 100% gives a perspective view where a far edge in the chart 
looks approximately half as big as a near edge.
Note: Older versions of OpenOffice.org cannot display the 
percentage of perspective the same way as the current version.

Appearance
Use the Appearance page (Figure 18) to modify some aspects of a 3D 
chart’s appearance.

Select a scheme from the list box. When you select a scheme, the 
options and the light sources are set accordingly. If you mark or 
unmark a combination of options that is not given by the Realistic or 
Simple schemes, you create a Custom scheme.

Select Shading to use the Gouraud method for rendering the surface, 
otherwise a flat method is used. The flat method sets a single color and 
brightness for each polygon. The edges are visible, soft gradients and 
spot lights are not possible. The Gouraud method applies gradients for 
a smoother, more realistic look. Refer to the Draw Guide for more 
details on shading.

Formatting 3D charts 21



Figure 18: Modifying appearance of 3D chart

Select Object Borders to draw lines along the edges.

Select Rounded Edges to smooth the edges of box shapes. In some 
cases this option is not available.

Illumination
Use the Illumination page (Figure 19) to set the light sources for the 
3D view. Refer to the Draw Guide for more details on setting the 
illumination.

Figure 19: Setting the illumination
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Click any of the eight buttons to switch a directed light source on or 
off. By default, the second light source is switched on. It is the first of 
seven normal, uniform light sources. The first light source projects a 
specular light with highlights.

For the selected light source, you can then choose a color and intensity 
in the list just below the eight buttons. The brightness values of all 
lights are added, so use dark colors when you enable multiple lights.

The small preview inside this page has two sliders to set the vertical 
and horizontal position of the selected light source. The light source 
always aims to the middle of the object.

The button in the corner of the small preview switches the internal 
illumination model between a sphere and a cube.

Use the Ambient light list to define the ambient light which shines with 
a uniform intensity from all directions.

Rotating 3D charts interactively
In addition to using the Perspective page of the 3D View dialog to 
rotate 3D charts, you can also rotate them interactively.

Select the Chart Wall, then hover the mouse pointer over a corner 
handle or the rotation symbol found somewhere on the chart. The 
cursor changes to a rotation icon.

Press and hold the left mouse button and drag the corner in the 
direction you wish. A dashed outline of the chart is visible during 
dragging, to help you see how the result will look.

Using the Object Properties dialog
Depending on what purpose your document has, as a screen 
presentation, or a printed document for a black and white publication, 
you might find the granular control over the different chart elements 
that the Object Properties dialog gives you is what you need.

To access the Object Properties dialog, left-click on the element that 
you wish to change. It will be highlighted with green squares. Right-
click and choose Object Properties from the pop-up menu. Each chart 
element has its own selection of tabs. In the next few sections we 
explore some of the options in the Object Properties dialog.
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Scaling axes
Sometimes you need to have a special scale for one of the axes of your 
chart. After highlighting the axis you wish to change, right-click and 
choose Object Properties. On the Scale tab (Figure 20), you can 
decide if you need a logarithmic or linear scale (default), how many 
marks you need on the line, where the marks are to appear, and the 
increments (intervals) of the scale.

You must first deselect the Automatic option in order to modify the 
value for any scale.

Figure 20: Axis scales

Formatting data labels and axis labels
There are also object properties for the labels of the chart elements. 
Carefully click on the chart element and access the object properties 
dialog, where you can change the color of the label text, the size of the 
font, and other attributes.

On the Data Labels tab, you can choose whether to:

• Show the labels as text
• Show numeric values as a percentage or a number
• Include the legend box as part of the label
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These choices are the same as those shown in Figure 12 on page 13.

The text for labels is taken from the column labels and it cannot be 
changed here. If the text needs to be abbreviated, or if it did not label 
your graph as you were expecting, it is not possible to change it in the 
Object properties dialog. You need to change it in the original data 
table.

Axis labels have different choices. The Label tab of the object 
properties is shown in Figure 21.

Figure 21:Axes label dialog page

Choosing and formatting symbols
In line and scatter charts the symbols representing the points can be 
changed to a different symbol shape or color through the object 
properties dialog. 

On the Line tab of the Data Series object properties dialog, in the Icon 
section, choose from the drop-down list Select > Symbols. Here you 
can choose no symbol, a symbol from an inbuilt selection, a more 
exciting range from the gallery, or if you have pictures you need to use 
instead, you can insert them using Select > From file.
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Figure 22: Symbol selection

Resizing and moving the chart
You can resize or move all elements of a chart at the same time, in two 
ways: interactively, or by using the Position and Size dialog box. You 
may wish to use a combination of both methods: interactive for quick 
and easy change, then the dialog box for precise sizing and positioning.

To resize a chart interactively:
1) Click once on the chart to select it. Green sizing handles appear 

around the chart.
2) To increase or decrease the size of the chart, click and drag one 

of the markers in one of the four corners of the chart. To maintain 
the correct ratio of the sides, hold the Shift key down while you 
click and drag.

To move a chart interactively:
1) Click on the chart to select it. Green sizing handles appear around 

the chart.
2) Hover the mouse pointer anywhere over the chart. When it 

changes shape, click and drag the chart to its new location.
3) Release the mouse button when the element is in the desired 

position.
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Using the Position and Size dialog
To resize or move a chart using the Position and Size dialog:

1) Click on the chart to select it. Green sizing handles appear around 
the chart.

2) Right-click and choose Position and Size from the pop-up menu.
3) Make your choices on the Position and Size page of this dialog. 

The Rotation and Slant & Corner Radius tabs are not active.

Figure 23: Defining the position and size of an object

Position is defined as an X,Y coordinate relative to a fixed point (the 
base point), typically located at the upper left of the drawing area. If 
desired, you can temporarily change this base point to make 
positioning or dimensioning simpler (click on the radio button 
corresponding to the location of the base point in either of the two 
selection windows on the right side of the dialog—upper for positioning 
or lower for dimensioning). 

The possible base point positions correspond to the handles on the 
selection frame plus a central point. The change in position lasts only 
as long as you have the dialog open; when you close this dialog, Calc 
resets the base point to the standard position.
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Tip
The Keep ratio checkbox is very useful. Click it to keep the ratio 
of width to height fixed while you change the size of an object.

Either or both the size and position can be protected so that they 
cannot be inadvertently changed. Select the appropriate options to 
achieve this.

Tip
If you cannot move an object, check to see if the position is 
protected!

Gallery of chart types
Its important to remember that while your data can be presented with 
a number of different charts, the message you want to convey to your 
audience dictates the chart you ultimately use. The following sections 
present examples of the types of charts that Calc provides, with some 
of the tweaks that each sort can have and some notes as to what 
purpose you might have for that chart type. For details, see the Help.

Column charts
Column charts are commonly used for data that shows trends over 
time. They are best for charts that have a relatively small number of 
data points. (For large time series a line chart would be better.) It is 
the default chart type, as it is one of the most useful charts and the 
easiest to understand.

Bar charts

Figure 24: Three bar graph treatments.
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Bar charts are excellent for giving an immediate visual impact for data 
comparison where time is not important, for example to compare the 
popularity of a few products in a marketplace.

• Graph one is achieved quite simply by using the chart wizard with 
Insert > Grids, deselect y-axis, and Insert > Mean Value 
Lines.

• Graph two is the 3D option in the chart wizard with a simple 
border and the 3D chart area twisted around.

• The third graph is an attempt to get rid of the legend and put 
labels showing the names of the companies on the axis instead. 
We also changed the colors to a hatch pattern.

Pie charts
Pie charts are excellent when you need to compare proportions. For 
example, comparisons of departmental spending: what the department 
spent on different items or what different departments spent. They 
work best with smaller numbers of values, about half a dozen; more 
than this and the visual impact begins to fade.

As the Chart Wizard guesses the series that you wish to include in your 
pie chart, you might need to adjust this initially on the Wizard’s Data 
Ranges page if you know you want a pie chart, or by using the Format 
> Data Ranges > Data Series dialog.

There are a couple of interesting things you can do with pie charts. 
This is one of the charts which can profitably be made into a 3D chart. 
It can then be tilted, given shadows, and generally turned into a work 
of art. Just don’t clutter it so much that your message is lost.

You can choose in the Chart Wizard to explode the pie chart, but this is 
an all or nothing option. If your aim is to accentuate one piece of the 
pie, you can separate out one piece by carefully highlighting it after 
you have finished with the Chart Wizard, and dragging it out of the pie 
plate. When you do this you might need to enlarge the chart area again 
to regain the original size of the pieces.

Gallery of chart types 29



Figure 25: Pie charts

• 2D pie chart in Chart Wizard. Choose Insert > Legend and 
uncheck the Display legend box. Choose Insert > Data Labels 
and choose Show value as number. Then carefully select the piece 
of pie you wish to highlight. The best way is to move the cursor to 
the edge of the piece and click; the piece will have nine green 
highlight squares to mark it. Then drag it out from the rest of the 
pieces. You will find the actual pieces will decrease in size and you 
will need to highlight the chart wall and drag it at a corner to 
increase the size.

• 3D pie chart with realistic schema and illumination adjusted by 
going to Format > 3D view > Illumination where you can 
change the direction of the light, the color of the ambient light, 
and the depth of the shade. We also adjusted the 3D angle of the 
disc in the Perspective dialog on the same set of tabs.

Fortunately the chart updates as you make changes, so you can 
see the effects you are having. 

If you want to separate out one of the pieces, click on it carefully; 
you should see a wire frame highlight. Drag it out with the mouse 
and like the 2D chart you need to increase the size of the chart 
wall.

• 3D pie chart and Insert > Data labels, show data labels as 
percentage. Then carefully select each of the pieces so that it has 
a wire frame highlight and right-click to get the object properties 
dialog and choose the Area tab. For one we chose a bitmap, for 
another a gradient and for the third we used the Transparency tab 
and adjusted the transparency to 50%.

Donut charts
If you want to show the proportional nature of your data but want to 
include more than one data series, a donut chart is your best option. 
The extra layer attempts to give pies another dimension of time. 
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However, two or three data series are all you can include before it 
becomes meaningless. The extra layer attempts to give pies another 
dimension of time.

As with pie chart, you can explode the pieces of the donut chart. You 
can also separate individual pieces as in pie charts.

Figure 26: Donut charts

As in pie charts, data labeling may be used a substitute for the legend, 
not an addition to it.

Area charts
An area chart is a version of a line or column graph. It may be useful 
where you wish to emphasize volume of change. Area charts have a 
greater visual impact than a line chart, but the data you use will make 
a difference.

Figure 27: Area charts—the good, the bad, and the ugly

As shown in Figure 27, an area chart is sometimes tricky to use. This 
may be one good reason to use transparency values in an area chart.

• Chart wizard > no y-grids. As the data overlaps, some of it is 
missing behind the first data series. This is not what you want. A 
better solution is Chart 2.
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• Chart wizard > no y-grids > Object Properties > Area > 50% 
Transparency; Labels > Tile 55° . The transparency makes it 
easy to see the data hidden behind the first data series.

• Chart wizard > 3D > realistic > no y-grids > Object 
Properties > Area > 50% transparency. We also twisted the 
chart area around and gave the chart wall a picture of the sky. As 
you can see, the legend turns into labels on the z-axis. But overall, 
though it is visually more appealing, it is more difficult to see the 
point you are trying to make with the data.

Other ways of visualizing the same data series are represented by the 
stacked area chart or the percentage stacked area chart. The first does 
what it says, each number of each series is added to the others so that 
it shows an overall volume not a comparison of the data. The 
percentage stacked chart shows each value in the series as a part of 
the whole. For example in June all three values are added together and 
that number represents 100%. The individual values are a percentage 
of that. Many charts have varieties which have this option.

Figure 28: Stacked and percentage stacked area charts

Line charts
A line chart is a time series with a progression. It is ideal for raw data, 
and useful for charts with plentiful data that shows trends or changes 
over time where you want to emphasize continuity. On line charts, the 
x-axis is ideal to represent time series data.

Things to do with lines: thicken them up, make them 3D, smooth the 
contours, just use points.

3D lines confuse the viewer, so just using a thicker line often works 
better.
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Figure 29: Line charts

Scatter or XY charts
Scatter charts are great for visualizing data that you have not had time 
to analyze, and they may be the best for data when you have a constant 
value with which to compare the data; for example, weather data, 
reactions under different acidity levels, conditions at altitude, or any 
data which matches two series of numeric data. In contrast to line 
charts, the x-axis are the left to right labels which usually indicate a 
time series.

Figure 30: A particularly volatile time in the world currency market.

There is a catch with scatter charts that may surprise those unfamiliar 
with how they work. One data series represents the x-axis and the next 
represents the y-axis. The chart becomes a Cartesian map with each 
point showing the (x,y) point of each pair of data. Thus you may be 
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hoping for a chart with two series of points, as you would get in a line 
chart, and only have one unexpectedly twisted line. Each additional 
series of data is matched against the original series. Figure 30 shows a 
comparison of three currencies with the Japanese Yen. Even though the 
table presents the monthly series, the chart does not. In fact the 
Japanese Yen does not appear; it is merely used as the constant series 
that all the other data series are compared to.

Net charts
A net chart is similar to polar or radar graphs. They are useful for 
comparing data that are not time series, but show different 
circumstances, such as variables in a scientific experiment or 
direction. The poles of the net chart are the y-axes of other charts. 
Generally, between three and eight axes are best, any more and this 
type of chart becomes confusing. Before and after can be plotted on 
the same chart, or perhaps expected and real results, so that 
differences can be compared.

Figure 31: Two net diagrams showing totally fabricated data from 
totally fictional experiments.

• Plain net chart without grids and with just points no lines.
• Net chart with lines and points and grid. axes colors changed as 

well as labels. chart area color = gradient quadrant and the 
points changed to fancy 3D ones.

There are also varieties of net chart that show the data series as 
stacked numbers or stacked percentages.
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Stock charts
A stock chart is a specialized column graph specifically for stocks and 
shares. You can choose traditional lines, candlestick, and two-column 
type charts. The data required for these charts is quite specialized, 
with series for opening price, closing price, and high and low prices. Of 
course the x-axis represents a time series.

When you set up a stock chart in the Chart Wizard, the Data Series 
dialog is very important. You need to tell it which series is for the 
opening price, closing price, high and low price of the stock, or else 
the chart may be indecipherable. The sample table for this chapter 
needed to be changed to fit the data series. See Figure 32.

Figure 32: Adjusting data series for stock charts.

A nice touch is that OpenOffice.org Chart color-codes the rising and 
falling shares: white for rising and black for falling in the candlestick 
chart, and red and blue in the traditional line chart.

Column and line charts
A column and line chart is a combination of two other chart types. It is 
useful for combining two distinct but related data series, for example 
sales over time (column) and the profit margin trends (line).

You can choose the number of columns and lines in the Chart Wizard. 
So for example you might have two columns with two lines to 
represent two product lines with the sales figures and profit margins of 
both (see Figure 33).
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Figure 33: Column and line chart

The chart has data for two products, manufacturing costs and profits 
over a period of time, in this case, six months in 2007. We highlighted 
the table and started the Chart Wizard. We chose the Column and Line 
chart type with two lines and the data series in rows. Then we gave it a 
title to highlight the aspect we want to show. The lines are different 
colors at this stage and don’t reflect the product relationships. When 
we finished with the Chart Wizard, we highlighted the chart, clicked on 
the line, right-clicked, and chose Object properties > Line.

On this tab there are a few things to change, first the color to match 
the products, so both Ark Manufacturing and profit are blue and Prall 
is red. I think the lines need to be more noticeable so I made the lines 
thicker by increasing the width to .08.

The background is done by highlighting the chart wall and right-
clicking, choosing Object Properties > Area, and changing the drop-
down box to show Gradient. We chose one of the preset gradient 
patterns and made it lighter by going to the Transparency tab and 
making the gradient 50% transparent.

We also decided that the chart looked cleaner without the grid so we 
went to Insert > Grids and unchecked the X-axis option.
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