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What is Math?

Math is OpenOffice.org (O0Oo0)’s component for writing mathematical
equations. It is most commonly used as an equation editor for text
documents, but it can also be used with other types of documents or
stand-alone. When used inside Writer, the equation is treated as an
object inside the text document.

The equation editor is for writing equations in symbolic form (as
Note in equation 1). If you want to evaluate a numeric value, see the
Calc Guide.

=In(x)+tan ' (x°) (1)

Getting started
To insert an equation, go to Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating
Selection window appears. You will also see a small box (with a gray
border) in your document, where the formula will be displayed, as
shown in Figure 1.

n E Ugieiel=ell o €)=l 0)ffia= rige) Y einare ! EB
File Edit WView Format Tools Window Help
£-cHa 88 & @ . =,

Selection
% ﬂ.ib aed -F(:o:} ZQ
a o (&) %

+4 -4 *a ¥4 4

A4 0 kA

a+b a-b axb axb asb

a-b % azb a/b avb

asb

4 L4

Figure 1. Equation Editor, Selection window, and
location of resulting equation.
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The equation editor uses a markup language to represent formulas. For
example, %beta creates the Greek character beta (). This markup is
designed to read similar to English whenever possible. For example, a

. a
over b produces a fraction: 3

Entering a formula

There are three ways to enter a formula:
« Select a symbol from the Selection window.

« Right-click on the equation editor and select the symbol from the
context menu.

« Type markup in the equation editor.

The context menu and the Selection window insert the markup
corresponding to a symbol. Incidentally, this provides a convenient way
to learn the OOoMath markup.

Click on the document body to exit the formula editor.

Note Double-click on a formula to enter the formula editor again.

The Selection window

The simplest method for entering a formula is the Selection window,
shown in Figure 1.

n n e T ﬂ
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Symbols
a-b % azb a/b avb
a=b

Figure 2. Symbols are divided into categories

The Selection window is divided into two main portions.

« The top shows the symbol categories. Click on these to change
the list of symbols.

« The bottom shows the symbols available in the current category.
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You can hide (or unhide) the Selection window with View >

Tip Selection.

Example 1: 5x4

For this example we will enter a simple formula: 5x4 On the Selection
window:

1) Select the top-left button of the categories (top) section
(Figure 3).

2) Click on the multiplication symbol (shown in Figure 3).

Unary/binary operators

/

nn /_{alaction ﬂ
+a /
/41 asb aed f) Za

—»

a & |Multiplication

+4 -a HZA
a+b a-b axb axb anrb

a-b {% azb a/b avb

asb

Figure 3. Unary/binary operators
When you select the multiplication symbol on the Selection window,
two things happen:
« The equation editor shows the markup: <?> fimes <?>

« The body of the document shows a gray box with the figure:
U

ST

A kA

4 3

<7 times <7 | -

-

4 3

Figure 4. The multiplication symbol

The <?> symbols (Figure 4) are placeholders that you can replace by
other text. The equation will update automatically, and the result
should resemble Figure 5.
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Figure 5. Result of entering 5 and 4 next to the
times operator

To keep the equation from updating automatically, select View

Tip
Update.

>AutoUpdate display.
To update a formula manually, press F9 or select View >

Right-click menu

Another way to access mathematical symbols is to right-click on the
equation editor. This produces a menu as shown in Figure 6.

5 times 4]

Unary/Binary Operators
Relations

Set Operations
Functions

Operators

Aftributes

Brackets

Formats

Others

Figure 6. Right-click menu

- w v v v v v ¥ |¥v

-+a
a+b
a-b
a cdot b

atimesb |
a*b

a over b

adivb

alb

acirc b

a wideslash b
a widebslash b

Note

The entries in this menu correspond exactly to those in the
Selection window.
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Markup

You can type the markup directly on the equation editor. For example,
you can type 5 times 4 to obtain 5x4. If you know the markup, this
can be the fastest way to enter a formula.

As a mnemonic, the formula markup resembles the way the

Tip formula reads in English.

Below is a short list of common equations and their corresponding
markup.

Display Command Display Command
a=b a=b Ja sqrt {a}
a’ a~2 a, an
f £(x)dx int f(x) dx D a, sum a n
a<b a<=b 00 infinity
aXb a times b Xy x cdot y

Greek characters

Greek characters («,B,y, 0, etc) are common in mathematical
formulas. These characters are not available in the selection box or the
right-click menu. Fortunately, the markup for Greek characters is
simple: Type a % sign followed the name of the character, in English.

« To write a lowercase character, type the name of the character in
lowercase.

- To write an uppercase character, type the name of the character
in uppercase.

See the table below for some examples.

Lowercase Uppercase

%salpha —» « SALPHA — 4
Sbeta — B %BETA — B
%gamma — vy %GAMMA — I
%psi - Y %PSI i 4
Ssphi — ¢ SPHI —> &
%theta —» 0 STHETA — @
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Note A complete table of Greek characters is provided on page 27.

Another way to enter Greek characters is by using the catalog window.
Go to Tools > Catalog. The catalog window is shown in Figure 7.

Under Symbol Set, select Greek and double-click on a Greek letter
from the list.

v ][] Y015 B
Symboaol set Insert
Greek =

Close
A B X A EHT I K A*
MNQoO®IDIV¥ pXT Edit...
oy = zfs x 5 ¢
¥y Lok A opowv o woo o
Wwop o T 8 v o @ W@ g
¢ & EC
alpha

Figure 7. Catalog - used for entering Greek characters

Example 2: ™ =~ 3.14159
For this example we will suppose that:

« We want to enter the above formula (the value of pi rounded to 5
decimal places).

« We know the name of the Greek character (pi).
« But we do not know the markup associated with the ~ symbol.

Step 1: Type % followed by the text pi. This displays the Greek
character .

Step 2: Open the Selection window (View > Selection).

Step 3: The = symbol is a relation, so we click on the relations button

asb_ If you hover the mouse over this button you see the tooltip
Relations (Figure 8).
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BB s52l-d00 B
—+ o] a A
ad a = 4
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a+b a-b axb axb asb

a-b % azb a/b avb

Figure 8. Tooltip indicates
the "Relations" button.

Step 4: Delete the <?> text and add 3.14159 at the end of the
equation. Hence we end up with the markup %pi simeq 3.14159. The
result is shown in Figure 9.

s m=314159 -

MDA

4 L4

i simeq 3.14159] -

4 .4

Figure 9. Final result

Customizations

Formula editor as a floating window

As seen in Figure 2, the formula editor can cover a large part of the
Writer window. To turn the formula editor into a floating window, do
this:
1) Hover the mouse over the editor frame, as shown in Figure 10.
2) Hold down the Control key and double-click.
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E=m B

Figure 10. Hold down the Control key and
double-click on the border of the math editor
to turn it into a floating window.

Figure 11 shows the result. You can make the floating window back
into an embedded frame, using the same steps. Hold down the Control
key and double-click the window frame.

n n ST ETES E E

=mc™2 -

-

4 k

Figure 11. Equation editor as a floating window

How can | make a formula bigger?

This is one of the most common questions people ask about OOoMath.
The answer is simple, but not intuitive:

1) Start the formula editor and go to Format > Font size.

Customizations 11
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File Edit View | Format | Tools Window Help

4

B = = Fonts... 5 - @ ):
i Font Size... i =
- T 7-:.8.9-:10:11 12,
Spacing...
. . ., Alignment...
sr=3.14159 «
.ﬂr . . Text Mode

L= |

Yapi simeq 3.14159

Figure 12. Changing the font size for a formula

2) Select a larger font size under Base size (top-most entry), as

shown in Figure 12.

v) FONESTZES B

Base size hﬁpt - oK

Relative sizes cancel
L= 100% -
Indexes 60% = Default
Functions 100% -
Operators 100% -
Limits 60% =

Figure 13. Edit Base size (top) to make
a formula bigger.

The result of this change is illustrated in Figure 13.

Before: m=3 14139

After: m=3.14159

Figure 14. Result of changing
the base font size.
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Formula layout

The most difficult part of using OOoMath comes when writing
complicated equations. This section provides some advice about
writing complex formulas.

Brackets are your friends

OOoMath knows nothing about order of operation. You must use
brackets to state the order of operations explicitly. Consider the
following example:

Markup Result

2 over x + 1 %4‘1

2 over {x + 1} 1

Equations over more than one line

Suppose you want to type an equation covering more than one line. For

x=3

example: = _ 1

Your first reaction would be to simply press the Enter key. However, if

you press the Enter key, though the markup goes to a new line, the
resulting equation does not. You must type the newline command
explicitly. This is illustrated in the table below.

Markup Result

X = 3

y =1 x=3y=1
X = 3 newline x=3
y=1 y=1

Formula layout
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Common problem areas

How do | add limits to my sum/integral?

The sum and int commands can (optionally) take the parameters from
and to. These are used for lower and upper limits respectively. These
parameters can be used singly or together. Limits for integrals are
usually treated as subscripts and superscripts.

Markup Result

sum from k = 1 to n a_k Zak
k=1

int from 0 to x f(t) dt
or
int 0°x f(t) dt

f(¢)dt or f:f(t)dt

;. o%k

f

int from Re f

—-n

M =
\9)

sum to infinity 2°{-n}

Note For more details on integrals and sums, see page 21.

Brackets with matrices look ugly!
For background, we start with an overview of the matrix command:

Result

a b

matrix { a # b # c # d } . d

Rows are separated by two #’s and entries within each row are

Note separated by one #.

The first problem people have with matrices is that brackets do not
scale with the matrix:

Result

( matrix { a# b #t c#d} ) (@ b

14 Math Objects



OOoMath provides scalable brackets. That is, the brackets grow in size
to match the size of their contents. Use the commands Jleft( and right)
to make scalable brackets.

Result

a b
c d

left( matrix { a # b ## c #d } right)

Tip Use left/ and right] to obtain square brackets.

How do | make a derivative?

Making derivatives essentially comes down to one trick: Tell OOo it’s a
fraction.

In other words, you have to use the over command. Combine this with
either the letter d (for a total derivative) or the partial command (for a
partial derivative) to achieve the effect of a derivative.

Markup Result

df

{df} over {dx} —
{partial f} over {partial y} oy
; N . A azf
{partial~2 f} over {partial t"2} e

Notice that we had to use squiggly brackets to make the

Note derivative.

Numbering equations

Equation numbering is one of OOoMath’s best hidden features. The
steps are simple, but obscure:

1) Start a new line.
2) Type fn and then press F3.

The fn is replaced by a numbered formula:

E=mc’ 2)
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Now you can double-click on the formula to edit it. For example, here
is the Riemann Zeta function:

C<Z)=iiz (3)

n=1 N

You can reference an equation (“as shown in Equation (2)”) with these
steps:

1) Insert > Cross-reference..

2) Click on the References tab (Figure 14).

3) Under Type, select Text.

4) Under Selection, pick the equation number.

5) Under Format, choose Reference.

6) Click Insert.
Done! If you later add more equations to the paper before the

referenced equation, all the equations will automatically renumber and
the cross-references will update.

L w1

Fields

Document |Cross-references | Functions | DocInformation | Variables | Database

Tvpe Selection
Set Reference (1
Insert Reference el
Headings 03

Mumbered Paragraphs
Texk

Figure

Bookmarks

Insert reference to

Pane [z
Chapter

Reference

AbioveBelow

Az Page Shyle

Categary and Mumber

Zaption Text

Mumbering

[ Insert H Close H Help ]

Figure 15. Inserting a cross-reference to an equation number

Tip To insert the equation number without parenthesis around it,
choose Numbering instead of Reference under Format.
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Math commands - Reference

Unary / binary operators

Operation

+sign

-sign

+/- sign

-/+ sign

Boolean not
Addition +
Multiplication dot
Multiplication (X)
Multiplication (*)
Boolean and

Subtraction (-)
Division (fraction)

Division (operand)
Division (slash)
Boolean or

Concatenate

Command
+1

-1

+-1

4+

neg a
a+b
acdotb
a times b
a*b
aandb
a-b
aoverb
adivb
a/b

aorb

a circ b

Display

alb
aVvb

aob

Math commands - Reference
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Relational operators

Operation

Is equal

Is not equal
Approximately

Divides

Does not divide

Less than

Greater than

Similar to or equal
Parallel

Orthogonal to

Less than or equal to
Greater than or equal to
Similar to

Congruent

Less than or equal to
Greater than or equal to
Proportional

Toward

Arrow left

Double arrow left and right

Arrow right

Command
a=>b
a<>bhb

a approx 2
a divides b
a ndivides b
a<?2

a>2

a simeq b

a parallel b
aorthob

a leslant b
a geslant b
asimb

a equiv b
a<=b
a>=Dhb
apropb

a toward b
a dlarrow b
a dlrarrow b

a drarrow b

Display

alb

18
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Set operations

Operation

Is in

Is not in

Owns

Empty set
Intersection

Union

Difference

Quotient

Aleph

Subset

Subset or equal to
Superset

Superset or equal to
Not subset

Not subset or equal
Not superset

Not superset or equal
Set of natural numbers
Set of integers

Set of rational numbers
Set of real numbers

Set of complex numbers

Command
ain B

a notin B

A owns b
emptyset

A intersection B
A union B

A setminus B
A slash B
aleph

A subset B

A subseteq B
A supset B

A supseteq B
A nsubset B

A nsubseteq B
A nsupset B

A nsupseteq B
setN

setZ

setQ

setR

setC

Math commands - Reference
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Functions

Operation Command Display
Exponential func e™ {a} e’
Natural logarithm In(a) In(a)
Exponential function exp(a) exp(a)
Logarithm log(a) log(a)
Power a”~{b} a’
Sine sin(a) sin(a)
Cosine cos(a) cos(a)
Tangent tan(a) tan(a)
Cotangent cot(a) cot(a)
Square root sqrt{a} Va
Arcsine arcsin(a) arcsin (a )
Arc cosine arccos(a) arccos(a)
Arctangent arctan(a) arctan (a)
Arc cotangent arccot(a) arccot(a)
n root nroot{a}{b} 4b
Hyperbolic sine sinh(a) sinh (a)
Hyperbolic cosine cosh(a) cosh(a)
Hyperbolic tangent tanh(a) tanh(a)
Hyperbolic cotangent coth(a) coth (a)
Absolute value abs{a} d
Arc hyperbolic sine arsinh(a) arsinh (a )
Arc hyperbolic cosine arccosh(a) arcosh (a)
Arc hyperbolic tangent arctanh(a) artanh (a)
Arc hyperbolic cotangent arccoth(a) arcoth (a)
Factorial fact{a} a!
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Operators

All operators can be used with the limit functions (“from” and “to”).

Operation
Limit

Sum
Product
Coproduct

Upper and lower bounds
shown with integral

Integral
Double integral
Triple integral

Lower bound shown with
summation symbol

Contour integral
Double curved integral
Triple curved integral

Upper bound shown with
product symbol

Command

lim{a}

sum{a}

prod{a}

coprod{a}

int from {r 0} to {r t} a

int{a}
iint{a}
iiint{a}

sum from{3}b

lint a

llint a

lllint a

prod to{3}r

Display

lima

Math commands - Reference
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Attributes

Operation Command Display

Acute accent
Grave accent
Reverse circumflex
Breve

Circle

Vector arrow
Tilde

Circumflex

Line above

Dot

Wide vector arrow
Wide tilde

Wide circumflex
Double dot

Line over

Line under

Line through
Triple dot

Transparent (useful to get a
placeholder of a given size)

Bold font

Italic fontl

Resize font

Following item in sans serif font2
Following item in serif font

Following item in fixed font

acute a

grave a
check a
breve a

circle a

vec a

tilde a

hat a

bar a

dot a
widevec abc
widetilde abc
widehat abc
ddot a
overline abc
underline abc
overstrike abc
dddot a

phantom a
bold a
ital “a”
size 16 qv

font sans qv
font serif qv

font fixed qv

a

Qo Q¢ N«

QU

qv
qv
qv
qv

1 Unquoted text that is not a command is considered to be a variable. Variables are, by

default, italicized.

2 There are three custom fonts: sans serif (without kicks), serifs (with kicks), and fixed
(non-proportional). To change the actual fonts used for custom fonts and the fonts
used for variables (unquoted text), numbers and functions, use Format > Fonts.

22
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Operation Command Display

Make color of following text cyan3 color cyan qv qv
Make color of following text yellow color yellow qv

Make color of following text white color white qv

Make color of following text green color green qv qv
Make color of following text blue color blue qv qv
Make color of following text red color red qv qv
Make color green returns to default color green X qv Xqv
color black

Brace items to change color of more color green {X qv} Xqv
than one item

3 For all coloring, the color will apply only to the text immediately following the
command until the next space is encountered. In order to have the color apply to
more characters, place the text you want in color in curly brackets.
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Miscellaneous

Operation
Infinity

Partial

Nabla

There exists
For all

H bar

Lambda bar
Real part
Imaginary part
Weierstrass p
Left arrow
Right arrow
Up arrow
Down arrow
Dots at bottom
Dots at middle
Dots vertical

Dots diagonal upward

Dots diagonal downward

Command
infinity
partial
nabla
exists
forall

hbar
lambdabar
re

im

wp
leftarrow
rightarrow
uparrow
downarrow
dotslow
dotsaxis
dotsvert
dotsup

dotsdown

Display

I T 3

— -
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Brackets

Operation

Round Brackets

Square Brackets
Double Square Brackets
Single line

Double line

Braces

Angle Brackets
Operator Brackets

Group brackets (used for
program control)

Scalable round brackets
(add the word “left before a
left bracket and “right”
before a right bracket)

Square brackets scalable
(as above)

Double square brackets
scalable

Line scalable
Double line scalable
Brace scalable

Angle bracket scalable

Operator brackets scalable
Over brace scalable

Under brace scalable

Command

(@)

[b]

ldbracket c rdbracket
lline a rline

ldline a rdline

lbrace w rbrace
langle d rangle

langle a mline b rangle

{a}

left ( stack{a # b # z}
right )

left [ stack{ x # y} right ]

left 1dbracket c right
rdbracket

left lline a right rline
left 1dline d right rdline
left lbrace e right rbrace
left langle f right rangle

left langle g mline h right
rangle

{The brace is above}
overbrace a

{the brace is
below }underbrace {f}

Display

a

The braceis above

the braceis below
f

Math commands - Reference

25



Formats

Operation
Left superscript

Center superscript

Right superscript
Left subscript

Center subscript

Right subscript

Align character to left (text
is aligned center by default)

Align character to center
Align character to right

Vertical stack of 2

Vertical stack, more than 2

Matrix stack

Common mathematical
arrangement

New line

Small gap (grave)
Large gap (tilde)

Command
a Isup{b}

a csup{b}
a”~{b}

a lsub{b}
a csub{b}

a_{b}

stack { Hello world # alignl
(@) }

stack{Hello world #
alignc(a)}

stack { Hello world #
alignr(a) }

binom{a}{b}

stack{a # b # z}

matrix{a # b ## c # d}

matrix{a # "="b ## {} #
II=IIC}

asldkfjo newline sadkfj

stuff " stuff
stuff~stuff

Helloworld

(a)

Hello world
(a)

Helloworld
(a)

Q >

o)

N

a b

c d

a =b
=c

asldkfio
sadkfj

stuff  stuff
stuff  stuff

26
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Characters - Greek

%ALPHA A| %BETA B | %CHI X | %DELTA A | %EPSILON F
%ETA H| %9GAMMA I' | %I0TA I | %KAPPA K| %LAMBDA A
%MU M| %NU N| %OMEGA Q| %OMICRON O | %PHI )
%P1 I1| %PSI ¥ | %RHO P | %SIGMA X | %THETA e
%UPSILON Y | %XI Z | %ZETA Z

%alpha o | %beta B | %chi X | %delta 5 | %epsilon €
%eta n | %ogamma y | %iota ¢ | %kappa k | %lambda A
%mu %nu v | Yoomega w | Y%0micron o | %phi b
%pi | %rho p | %sigma o | %tau T | %theta 0
%upsilon v | %varepsilon ¢ | %varphi ¢ | Y%varpi w | %varrho 0
Y%varsigma ¢ | %ovartheta 9 | %xi & | Y%zeta '
Characters - Special

%and A %angle < %element € %identical =
%infinite oo %noelement ¢& %notequal # %or V
%perthousand %o | %strictlygreaterthan > | %strictlylessthan < | %tendto —
Math commands - Reference 27
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