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Introduction

This chapter describes how to save documents as web pages from
Writer, Calc, Draw and Impress.

Cross references do not become hyperlinks in an HTML

Note document.

Inserting hyperlinks

When you type text (such as a website addresses or URL) that can be
used as a hyperlink, OOo formats it automatically, creating the
hyperlink and applying to the text a color and underlining. If this does
not happen, you can enable this feature using Tools > AutoCorrect >
Options and selecting URL Recognition.

If you do not want OOo to convert a specific URL to a hyperlink,
select Edit > Undo Insert from the menu bar or press
Control+Z immediately after the formatting has been applied.
To change the color of hyperlinks, go to Tools > Options >
OpenOffice.org > Appearance, scroll to Unvisited links

Tips and/or Visited links, pick the new colors and click OK. Caution:
this will change the color for all hyperlinks in all components of
OpenOffice.org—this may not be what you want.
In Writer and Calc (but not Draw or Impress), you can also
change the Internet link character style or define and apply
new styles to selected links.

You can also insert and modify links using the Hyperlink dialog
(Figure 1). To display the dialog, click the Hyperlink icon (& on the

Standard toolbar or select Insert > Hyperlink from the menu bar. To
turn existing text into a link, highlight it before opening the Hyperlink
dialog.
On the left hand side, select one of the four types of hyperlinks:

« Internet: a web address, normally starting with http://

« Mail & News: for example an email address.

« Document: the hyperlink points to another document or to
another place in the presentation.

« New document: the hyperlink creates a new document.
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Figure 1. Hyperlink dialog showing details for Internet links

The top right part of the dialog changes according to the choice made
for the hyperlink type. A full description of all the choices, and their
interactions, is beyond the scope of this chapter. Here is a summary of
the most common choices used in presentations.

For an Internet type hyperlink, choose the type of hyperlink (choose
between Web, FTP or Telnet), and enter the required web address
(URL).

For a Mail and News type hyperlink, specify whether it is a mail or
news link, the receiver address and for email, also the subject.

For a Document type hyperlink, specify the document path (the Open
File button opens a file browser); leave this blank if you want to link to
a target in the same presentation. Optionally specify the target in the
document (for example a specific slide). Click on the Target icon to
open the Navigator where you can select the target, or if you know the
name of the target, you can type it into the box.

For a New Document type hyperlink, specify whether to edit the newly
created document immediately or just create it (Edit later) and the
type of document to create (text, spreadsheet, etc.). For a presentation,
Edit now is the more likely choice. The Select path button opens a
directory picker.

The Further settings section in the bottom right part of the dialog is
common to all the hyperlink types, although some choices are more
relevant to some types of links.

« Set the value of Frame to determine how the hyperlink will open.
This applies to documents that open in a Web browser.
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« Form specifies if the link is to be presented as text or as a button.
« Text specifies the text that will be visible to the user.

« Name is applicable to HTML documents. It specifies text that will
be added as a NAME attribute in the HTML code behind the
hyperlink.

« Event button: this button will be activated to allow OOo to react
to events for which the user has written some code (macro). This
function is not covered in this book.

Editing hyperlinks

To edit an existing link, place the cursor anywhere in the link and click
Edit > Hyperlink. The Hyperlink dialog (Figure 1) opens. Make your
changes and click Apply. If you need to edit several hyperlinks, you
can leave the Hyperlink dialog open until you have edited all of them.
Be sure to click Apply after each one. When you are finished, click
Close.

The standard (default) behavior for activating hyperlinks is to use
Ctri+click. This behavior can be changed in Tools > Options >
OpenOffice.org > Security > Options, by deselecting the option
Ctrl-click required to follow hyperlinks. If clicking in your links
activates them, check that page to see if the option has been
deselected.

Saving Writer documents as web pages

Writer’s HTML capabilities include saving existing documents in HTML
format, creating new documents as HTML and creating several
different types of web pages using a wizard.

The easiest way to create HTML documents is to start with an existing
Writer document. You can view it as it will appear on a web page by
using View > Web Layout.

Saving a document as a single web page

To save a document as a single web page (HTML format), select Save
As from the File menu and specify HTML Document as the file type.
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Note

Writer does not replace multiple spaces in the original
document with the HTML code for non-breaking spaces. If you
want to have extra spaces in your HTML file or web page, you
need to insert non-breaking spaces in OOo. To do this, press
Control+Spacebar instead of just Spacebar.

Saving a document as a series of web pages

Writer can save a large document as a series of web pages (HTML
files) with a table of contents page. To do this:

1) Decide which headings in the document should start on a new
page and make sure all those headings have the same style (for
example, Heading 1).

2)
3)

Select File > Send and click on Create HTML Document.
In the dialog (Figure 2), enter the file name to save the pages

under. Also specify which style indicates a new page (as decided
in step 1).

4)

Click Save to create the multi-page HTML document. (For those

who may be interested, the resulting HTML files conform to the
HTML 4 Transitional.)
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Figure 2. Creating a series of web pages from one document
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Creating web pages using a Wizard

OO0o0’s Web wizard allows you to create several types of standard web
pages. To use it:

1) Select File > Wizards > Web Page. On the first page of the
Wizard, choose settings and click Next.

Not If this is your first web page, the only settings option is
ote Default.

Web Wizard

Steps Introduction

This Web \Wizard is ta aid wou in publishing documents on the Internet.

2. Docurnents It will corvert the documents so that they can be viewed by a web browser, In addition, it
will generate a Table of Contents page with links For easy access ko the documments, The
Web Wizard will also allow wou bo customize the design and layout of wour web site,

You will be able ko keep the documents you have published on the web up-to-date and add
ar remaove docurments ak any kime.

Choose settings For the Web Wizard

<default= »

2) Choose or browse to the document you would like to format. The
Title, Summary and Author information is picked up from the
document’s properties; if necessary, edit it. Click Next.

Steps Select the documents you want to publish

1. Introduction Weh sike content Export bo File Farmat:

2 Documents 0117G5-CreatingWebPages. sxw HTML w
3. Main layaut

. Document information
4, Layout details

7. Preview

[ add, ] [ Remoye

Tikle:
5. Style Creating Web Pages
&, Web site information SUMMAary:
Fields ko edit:

Zhapter Title : Description
tab = Title
i"hantar SikkiHe | lcer Nafined

Author:
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3) Chose a layout for the web site by clicking on the layout boxes.

Click Next.

7 -
Web Wizard
Steps Choose alayout for the table of contents of your web site
1. Introduction Layouks:

2. Documents — —_— _
0= o= o= o= | o=
3. Main lavouk HS MS U= S | | EE M
0= 0= 0= o= o= o=
4. Layout details — — =
o= o= 0= O= o= ‘
o= = |
5, Style o= =
6. Weh site information = =
7. Preview
Simple

o )]

4) Chose the information to be listed and the screen resolution. Click

Next.
7 S

Web Wizard
Steps Customize the selected layout

1. Introduction Include the Following infarmation For each docurment in the table of contents:

2. Documents

_ [ Eile name [ File Farmat
3. Main layout Description File Format icon
4, [] authar [ ] Mumber of pages
[] creation date Size in KB

[] Last change date

6. Web site information

7. Preview Cptirize the layout For screen resolukion:

() B40x480
(%) g00x600
() 1024768

T -
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5) Select a style for the page. Use the drop-down list to choose
different styles and color combinations. You can browse to a
background image and icon set from the Gallery. Click Next.

-
Web Wizard
Steps Select a style for the table of contents page
1. Introduction Style: Water ]
2. Docurnents Background image: <no background image =
3. Main layout -

4, Layout details ] ] o
The icon set is used for presentations in HTML Format,

6. ‘Weh site information

7. Preview

Document
Creation Date
Last Change Date
Filename

T Err—

6) Enter general information such as Title and HTML Metadata
information. Click Next.

-

Web Wizard
Steps Enter general information for your web site
1. Introduction Title: Test Website

2. Documents

3. Main lavout HTML Metadata
4, Layout details Description: Test Data
5. Style E-mail:

6. Web site information ) )
Copyright nokice:

7. Preview
Created: 2605/05 |

Madified: 26/05/05 =

e I

7) Chose where to save the file and preview the page if you wish.
Click Finish.
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Web Wizard
Steps Where do you want to publish your weh site?
1. Introduction Click 'Preview' to see a preview in vour browser:
3. Main layout Publish the new web sike:
4, Lavout details To & local folder
C\Documents and Settingsi Jean Hollis Weber\My Documentst My Websites
5. Skyle
[] 7o a ZIP archive
&, wWeb site information E]
¥ Preview
Publishing wia FTP Prosy is nok supported,
Save setkings {recommended)
Save gs: Web Wizard Setkings1 w
o) o]

To edit or view the document’s underlying HTML code, click View >
HTML Source or click the HTML Source icon on the Main
toolbar.

Saving Calc spreadsheets as web pages

Calc can save files as HTML documents. As for Writer, use File > Save
As and select HTML Document, or File > Wizards > Web Page.

If the file contains more than one sheet, the additional sheets will
follow one another in the HTML file. Links to each sheet will be placed
at the top of the document. Calc also allows the insertion of links
directly into the spreadsheet using the Hyperlink dialog.

Saving Impress presentations as web
pages

You can export presentations as Macromedia Flash files: select File >
Export and choose Macromedia Flash for the file type.

You can also convert presentations into a series of web pages, as
described below.

Saving as web pages (HTML format) does not retain animation

Note and slide transitions.
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1) To begin, select File > Export and choose HTML Document as
the file type.

2) Create a folder for the files, supply a name for the resulting
HTML file, and click Save. The HTML Export Wizard opens.

Depending on the size of your presentation and the number of
graphics it contains, the HTML export function creates many
HTML, JPG, and GIF files. If you simply save to your desktop
(not in a specific folder), these separate HTML and graphics
files will be all over your desktop. So be sure to create a folder
to hold all the files.

Note

3) Choose the design for all of the pages, either from an existing
design or by creating a new one. If you have not previously saved
a design, the Existing Design choice is not available.

HTML Export

Aszsign design

{*) Mew design
) Existing Design

= LT i

Select an existing design or create a new one

[ EEUF' ] [ Cancel ] [ Mext == ] [ Create ]

4) Click Next to select the type of web pages to create.

« Standard HTML: one page for each slide, with navigation links
to move from slide to slide.

« Standard HTML with frames: one page with a navigation bar
on the left-hand side; uses slide title as navigation links. Click
on links to display pages in right-hand side.

« Automatic: one page for each slide, with each page set with
the Refresh meta tag so a browser automatically cycles from
one page to the next.
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WebCast: generates an ASP or Perl application to display the
slides. Unfortunately OOo has no direct support for PHP as

yet.

HTML Export

LIS

Publication type Options
'f?_,' Standard HTML format Create title page
() standard HTML with frames [ &8how notes:
{:} Automatic

) WebCast

[ Help ] [ Cancel ] [ << Back ] [ Mext == l [ Create

]

5) Decide how the images will be saved (PNG, GIF, or JPG) and what

resolution to use.

When choosing a resolution, consider what the majority of your
viewers might have. If you use a high resolution, then a viewer
with a medium-resolution monitor will have to scroll sideways to

see the entire slide—probably not desirable.

e

Save graphics as Monitor resoclution
® PNG & Low resolution (640x480 pixels)
O GIF & Medium resolution (B00x600 pixels)
O PG (2 High resolution (1024x768 pixels)

B Quality

Effects
Export sounds when slide advances

6) If Create title page was chosen in step 4, supply the information
for it on the next page. The title contains an author name, e-mail
address and home page, along with any additional information

you want to include.

Saving Impress presentations as web pages
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This page of the Wizard does not display if Create title page was

not chosen.

IS

Information for the title page
Author

E-mail address
Your homepage

Additional information

e/
G

Peter Hillier-Brook

[ ] Link to a copy of the original presentation

_:;;ﬁf

J

[ Help

Cancel

J I

<< Back

Mext ==

Create

I

]

7) Choose the navigation button style to use to move from one page
to another. If you do not choose any, OOo will create a text

navigator.
LIS S
Select button style

[ Text only
clololelE[E]ElE |
(4940 %) ) () () (=) ()
QOO0
(< (€ B = = i

l Help l [ Cancel l [ << Back l MNext == [ Create ]

8) Select the color scheme for the web pages. Available schemes
include the document’s existing scheme, one based upon browser
colors, and a completely user-defined scheme. You can save a new
scheme so that it will appear on the first page of the HTML export

wizard.

14
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HTML Export

_IS

Select color scheme
%) Apply color scheme from document

) Use browser colors

") Use custom color scheme

[ Text

Text

]
[ Hyperlink ] Hyperlink
[ Active Link ] Active link
[ visited Link ] Visited link
[ Help ] [ Cancel ] [ << Back ]

[

9) Click Create to generate the HTML files. If this is a new design, a

small dialog pops up. If you might want to reuse this design, you
can give it a name and save it. Otherwise, click Do Not Save.

Hame HTML Design

-,

| Da Mot Save

Saving Draw documents as web pages

Exporting drawings from OpenOffice.org’s Draw application is similar

to exporting a presentation from Impress. Use File > Export and

select HTML Document as the file type.

When using the wizard, you can choose to create the web page at any
time by clicking the Create button.

Saving Draw documents as web pages
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