Using with Maven 3.8.x

Since version 1.7.0, Maven Resolver requires Java 8 to run and a brand new default sync context factory has been implemented. Both are not compatible with Maven 3.8.x anymore which still requires Java 7 to run. Maven 3.8.x will continue to use version 1.6.x which you can find here. This also means that you cannot make use of the features provided by version 1.7.0 and later. If you require the changes from this version, but must or want to use Maven 3.8.x, you can build yourself an adapted version of Maven from the branches maven-3.8.x-resolver-1.8.x or maven-3.8.x-resolver-1.9.x with Java 8 requirement or use signed binaries and source from the dev dist area for maven-3.8.x-resolver-1.8.x or maven-3.8.x-resolver-1.9.x and use it as if you would use Maven 3.9.x or later.