(global)

An NDoc Documented Class Library

(global) Namespace

Namespace hierarchy

Classes

Class | Description
SupportClass | Contains conversion support elements such as classes, interfaces and static methods.
SupportClass.AppSettings |
SupportClass.Character | Mimics Java's Character class.
SupportClass.Date |
SupportClass.Number | A simple class for number conversions.
SupportClass.Single |
SupportClass.ThreadClass | Support class used to handle threads

Interfaces

Interface | Description
IThreadRunnable | This interface should be implemented by any class whose instances are intended to be executed by a thread.


IThreadRunnable Interface

This interface should be implemented by any class whose instances are intended to be executed by a thread.

For a list of all members of this type, see IThreadRunnable Members.

public interface IThreadRunnable

Types that implement IThreadRunnable

Type | Description
SupportClass.ThreadClass | Support class used to handle threads

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IThreadRunnable Members | (global) Namespace


IThreadRunnable Members

IThreadRunnable overview

Public Instance Methods

Run This method has to be implemented in order that starting of the thread causes the object's run method to be called in that separately executing thread.

See Also

IThreadRunnable Interface | (global) Namespace


IThreadRunnable Methods

The methods of the IThreadRunnable interface are listed below. For a complete list of IThreadRunnable interface members, see the IThreadRunnable Members topic.

Public Instance Methods

Run This method has to be implemented in order that starting of the thread causes the object's run method to be called in that separately executing thread.

See Also

IThreadRunnable Interface | (global) Namespace


IThreadRunnable.Run Method

This method has to be implemented in order that starting of the thread causes the object's run method to be called in that separately executing thread.

void Run();

See Also

IThreadRunnable Interface | (global) Namespace


SupportClass Class

Contains conversion support elements such as classes, interfaces and static methods.

For a list of all members of this type, see SupportClass Members.

System.Object
SupportClass

public class SupportClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass Members | (global) Namespace


SupportClass Members

SupportClass overview

Public Instance Constructors

SupportClass Constructor Initializes a new instance of the SupportClass class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass Class | (global) Namespace


SupportClass Constructor

Initializes a new instance of the SupportClass class.

public SupportClass();

See Also

SupportClass Class | (global) Namespace


SupportClass.AppSettings Class

For a list of all members of this type, see SupportClass.AppSettings Members.

System.Object
SupportClass.AppSettings

public class SupportClass.AppSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.AppSettings Members | (global) Namespace


SupportClass.AppSettings Members

SupportClass.AppSettings overview

Public Static Methods

Get Overloaded.

Public Instance Constructors

SupportClass.AppSettings Constructor Initializes a new instance of the SupportClass.AppSettings class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.AppSettings Class | (global) Namespace


SupportClass.AppSettings Constructor

Initializes a new instance of the SupportClass.AppSettings class.

public SupportClass.AppSettings();

See Also

SupportClass.AppSettings Class | (global) Namespace


SupportClass.AppSettings Methods

The methods of the SupportClass.AppSettings class are listed below. For a complete list of SupportClass.AppSettings class members, see the SupportClass.AppSettings Members topic.

Public Static Methods

Get Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.AppSettings Class | (global) Namespace


Get Method

An NDoc Documented Class Library

SupportClass.AppSettings.Get Method

Overload List

public static int Get(string,int);

public static long Get(string,long);

public static string Get(string,string);

See Also

SupportClass.AppSettings Class | (global) Namespace


SupportClass.AppSettings.Get Method (String, Int32)

public static int Get(
string key,
int defValue
);

Parameters

key
defValue

Return Value

See Also

SupportClass.AppSettings Class | (global) Namespace | SupportClass.AppSettings.Get Overload List


SupportClass.AppSettings.Get Method (String, Int64)

public static long Get(
string key,
long defValue
);

Parameters

key
defValue

Return Value

See Also

SupportClass.AppSettings Class | (global) Namespace | SupportClass.AppSettings.Get Overload List


SupportClass.AppSettings.Get Method (String, String)

public static string Get(
string key,
string defValue
);

Parameters

key
defValue

Return Value

See Also

SupportClass.AppSettings Class | (global) Namespace | SupportClass.AppSettings.Get Overload List


SupportClass.Character Class

Mimics Java's Character class.

For a list of all members of this type, see SupportClass.Character Members.

System.Object
SupportClass.Character

public class SupportClass.Character

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.Character Members | (global) Namespace


SupportClass.Character Members

SupportClass.Character overview

Public Static Properties

MAX_RADIX
MIN_RADIX

Public Static Methods

ForDigit

Public Instance Constructors

SupportClass.Character Constructor Initializes a new instance of the SupportClass.Character class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Character Class | (global) Namespace


SupportClass.Character Constructor

Initializes a new instance of the SupportClass.Character class.

public SupportClass.Character();

See Also

SupportClass.Character Class | (global) Namespace


SupportClass.Character Properties

The properties of the SupportClass.Character class are listed below. For a complete list of SupportClass.Character class members, see the SupportClass.Character Members topic.

Public Static Properties

MAX_RADIX
MIN_RADIX

See Also

SupportClass.Character Class | (global) Namespace


MAX_RADIX Property

An NDoc Documented Class Library

SupportClass.Character.MAX_RADIX Property

public static int MAX_RADIX {get;}

See Also

SupportClass.Character Class | (global) Namespace


MIN_RADIX Property

An NDoc Documented Class Library

SupportClass.Character.MIN_RADIX Property

public static int MIN_RADIX {get;}

See Also

SupportClass.Character Class | (global) Namespace


SupportClass.Character Methods

The methods of the SupportClass.Character class are listed below. For a complete list of SupportClass.Character class members, see the SupportClass.Character Members topic.

Public Static Methods

ForDigit

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Character Class | (global) Namespace


SupportClass.Character.ForDigit Method

public static char ForDigit(
int digit,
int radix
);

Parameters

digit
radix

Return Value

See Also

SupportClass.Character Class | (global) Namespace


SupportClass.Date Class

For a list of all members of this type, see SupportClass.Date Members.

System.Object
SupportClass.Date

public class SupportClass.Date

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.Date Members | (global) Namespace


SupportClass.Date Members

SupportClass.Date overview

Public Static Methods

GetTime

Public Instance Constructors

SupportClass.Date Constructor Initializes a new instance of the SupportClass.Date class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Date Class | (global) Namespace


SupportClass.Date Constructor

Initializes a new instance of the SupportClass.Date class.

public SupportClass.Date();

See Also

SupportClass.Date Class | (global) Namespace


SupportClass.Date Methods

The methods of the SupportClass.Date class are listed below. For a complete list of SupportClass.Date class members, see the SupportClass.Date Members topic.

Public Static Methods

GetTime

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Date Class | (global) Namespace


SupportClass.Date.GetTime Method

public static long GetTime(
DateTime dateTime
);

Parameters

dateTime

Return Value

See Also

SupportClass.Date Class | (global) Namespace


SupportClass.Number Class

A simple class for number conversions.

For a list of all members of this type, see SupportClass.Number Members.

System.Object
SupportClass.Number

public class SupportClass.Number

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.Number Members | (global) Namespace


SupportClass.Number Members

SupportClass.Number overview

Public Static Fields

MAX_RADIX | Max radix value.
MIN_RADIX | Min radix value.

Public Static Methods

Parse | Parses a number in the specified radix.
ToString | Overloaded.

Public Instance Constructors

SupportClass.Number Constructor Initializes a new instance of the SupportClass.Number class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number Constructor

Initializes a new instance of the SupportClass.Number class.

public SupportClass.Number();

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number Fields

The fields of the SupportClass.Number class are listed below. For a complete list of SupportClass.Number class members, see the SupportClass.Number Members topic.

Public Static Fields

MAX_RADIX | Max radix value.
MIN_RADIX | Min radix value.

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number.MAX_RADIX Field

Max radix value.

public const int MAX_RADIX = 36;

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number.MIN_RADIX Field

Min radix value.

public const int MIN_RADIX = 2;

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number Methods

The methods of the SupportClass.Number class are listed below. For a complete list of SupportClass.Number class members, see the SupportClass.Number Members topic.

Public Static Methods

Parse | Parses a number in the specified radix.
ToString | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number.Parse Method

Parses a number in the specified radix.

public static long Parse(
string s,
int radix
);

Parameters

s
An input System.String.
radix
A radix.

Return Value

The parsed number in the specified radix.

See Also

SupportClass.Number Class | (global) Namespace


ToString Method

An NDoc Documented Class Library

SupportClass.Number.ToString Method

Converts a number to System.String in the specified radix.

Overload List

Inherited from Object.

public virtual string ToString();

Converts a number to System.String in the specified radix.

public static string ToString(long,int);

public static string ToString(float);

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number.ToString Method (Int64, Int32)

Converts a number to System.String in the specified radix.

public static string ToString(
long i,
int radix
);

Parameters

i
A number to be converted.
radix
A radix.

Return Value

A System.String representation of the number in the specified redix.

See Also

SupportClass.Number Class | (global) Namespace | SupportClass.Number.ToString Overload List


SupportClass.Number.ToString Method (Single)

public static string ToString(
float f
);

See Also

SupportClass.Number Class | (global) Namespace | SupportClass.Number.ToString Overload List


SupportClass.Single Class

For a list of all members of this type, see SupportClass.Single Members.

System.Object
SupportClass.Single

public class SupportClass.Single

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.Single Members | (global) Namespace


SupportClass.Single Members

SupportClass.Single overview

Public Static Methods

Parse Overloaded.

Public Instance Constructors

SupportClass.Single Constructor Initializes a new instance of the SupportClass.Single class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Single Class | (global) Namespace


SupportClass.Single Constructor

Initializes a new instance of the SupportClass.Single class.

public SupportClass.Single();

See Also

SupportClass.Single Class | (global) Namespace


SupportClass.Single Methods

The methods of the SupportClass.Single class are listed below. For a complete list of SupportClass.Single class members, see the SupportClass.Single Members topic.

Public Static Methods

Parse Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Single Class | (global) Namespace


Parse Method

An NDoc Documented Class Library

SupportClass.Single.Parse Method

Overload List

public static float Parse(string);

public static float Parse(string,NumberStyles);

public static float Parse(string,NumberStyles,IFormatProvider);

public static float Parse(string,IFormatProvider);

See Also

SupportClass.Single Class | (global) Namespace


SupportClass.Single.Parse Method (String)

public static float Parse(
string s
);

Parameters

s

Return Value

See Also

SupportClass.Single Class | (global) Namespace | SupportClass.Single.Parse Overload List


SupportClass.Single.Parse Method (String, NumberStyles)

public static float Parse(
string s,
NumberStyles style
);

Parameters

s
style

Return Value

See Also

SupportClass.Single Class | (global) Namespace | SupportClass.Single.Parse Overload List


SupportClass.Single.Parse Method (String, NumberStyles, IFormatProvider)

public static float Parse(
string s,
NumberStyles style,
IFormatProvider provider
);

Parameters

s
style
provider

Return Value

See Also

SupportClass.Single Class | (global) Namespace | SupportClass.Single.Parse Overload List


SupportClass.Single.Parse Method (String, IFormatProvider)

public static float Parse(
string s,
IFormatProvider provider
);

Parameters

s
provider

Return Value

See Also

SupportClass.Single Class | (global) Namespace | SupportClass.Single.Parse Overload List


SupportClass.ThreadClass Class

Support class used to handle threads

For a list of all members of this type, see SupportClass.ThreadClass Members.

System.Object
SupportClass.ThreadClass

public class SupportClass.ThreadClass : IThreadRunnable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.ThreadClass Members | (global) Namespace


SupportClass.ThreadClass Members

SupportClass.ThreadClass overview

Public Static Methods

Current Gets the currently running thread

Public Instance Constructors

SupportClass.ThreadClass Overloaded. Initializes a new instance of the SupportClass.ThreadClass class.

Public Instance Properties

Instance | Gets the current thread instance
IsAlive | Gets a value indicating the execution status of the current thread
IsBackground | Gets or sets a value indicating whether or not a thread is a background thread.
Name | Gets or sets the name of the thread
Priority | Gets or sets a value indicating the scheduling priority of a thread

Public Instance Methods

Abort | Overloaded. Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interrupt | Interrupts a thread that is in the WaitSleepJoin thread state
Join | Overloaded. Blocks the calling thread until a thread terminates
Resume | Resumes a thread that has been suspended
Run | This method has no functionality unless the method is overridden
Start | Causes the operating system to change the state of the current thread instance to ThreadState.Running
Suspend | Suspends the thread, if the thread is already suspended it has no effect
ToString | Obtain a String that represents the current Object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass Constructor

Initializes a new instance of the ThreadClass class

Overload List

Initializes a new instance of the ThreadClass class

public SupportClass.ThreadClass();

Initializes a new instance of the Thread class.

public SupportClass.ThreadClass(string);

Initializes a new instance of the Thread class.

public SupportClass.ThreadClass(ThreadStart);

Initializes a new instance of the Thread class.

public SupportClass.ThreadClass(ThreadStart,string);

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass Constructor ()

Initializes a new instance of the ThreadClass class

public SupportClass.ThreadClass();

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass Constructor Overload List


SupportClass.ThreadClass Constructor (String)

Initializes a new instance of the Thread class.

public SupportClass.ThreadClass(
string Name
);

Parameters

Name
The name of the thread

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass Constructor Overload List


SupportClass.ThreadClass Constructor (ThreadStart)

Initializes a new instance of the Thread class.

public SupportClass.ThreadClass(
ThreadStart Start
);

Parameters

Start
A ThreadStart delegate that references the methods to be invoked when this thread begins executing

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass Constructor Overload List


SupportClass.ThreadClass Constructor (ThreadStart, String)

Initializes a new instance of the Thread class.

public SupportClass.ThreadClass(
ThreadStart Start,
string Name
);

Parameters

Start
A ThreadStart delegate that references the methods to be invoked when this thread begins executing
Name
The name of the thread

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass Constructor Overload List


SupportClass.ThreadClass Properties

The properties of the SupportClass.ThreadClass class are listed below. For a complete list of SupportClass.ThreadClass class members, see the SupportClass.ThreadClass Members topic.

Public Instance Properties

Instance | Gets the current thread instance
IsAlive | Gets a value indicating the execution status of the current thread
IsBackground | Gets or sets a value indicating whether or not a thread is a background thread.
Name | Gets or sets the name of the thread
Priority | Gets or sets a value indicating the scheduling priority of a thread

See Also

SupportClass.ThreadClass Class | (global) Namespace


Instance Property

An NDoc Documented Class Library

SupportClass.ThreadClass.Instance Property

Gets the current thread instance

public System.Threading.Thread Instance {get; set;}

See Also

SupportClass.ThreadClass Class | (global) Namespace


IsAlive Property

An NDoc Documented Class Library

SupportClass.ThreadClass.IsAlive Property

Gets a value indicating the execution status of the current thread

public bool IsAlive {get;}

See Also

SupportClass.ThreadClass Class | (global) Namespace


IsBackground Property

An NDoc Documented Class Library

SupportClass.ThreadClass.IsBackground Property

Gets or sets a value indicating whether or not a thread is a background thread.

public bool IsBackground {get; set;}

See Also

SupportClass.ThreadClass Class | (global) Namespace


Name Property

An NDoc Documented Class Library

SupportClass.ThreadClass.Name Property

Gets or sets the name of the thread

public string Name {get; set;}

See Also

SupportClass.ThreadClass Class | (global) Namespace


Priority Property

An NDoc Documented Class Library

SupportClass.ThreadClass.Priority Property

Gets or sets a value indicating the scheduling priority of a thread

public System.Threading.ThreadPriority Priority {get; set;}

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass Methods

The methods of the SupportClass.ThreadClass class are listed below. For a complete list of SupportClass.ThreadClass class members, see the SupportClass.ThreadClass Members topic.

Public Static Methods

Current Gets the currently running thread

Public Instance Methods

Abort | Overloaded. Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interrupt | Interrupts a thread that is in the WaitSleepJoin thread state
Join | Overloaded. Blocks the calling thread until a thread terminates
Resume | Resumes a thread that has been suspended
Run | This method has no functionality unless the method is overridden
Start | Causes the operating system to change the state of the current thread instance to ThreadState.Running
Suspend | Suspends the thread, if the thread is already suspended it has no effect
ToString | Obtain a String that represents the current Object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.ThreadClass Class | (global) Namespace


Abort Method

An NDoc Documented Class Library

SupportClass.ThreadClass.Abort Method

Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread

Overload List

Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread

public void Abort();

Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread while also providing exception information about the thread termination. Calling this method usually terminates the thread.

public void Abort(object);

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Abort Method ()

Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread

public void Abort();

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass.Abort Overload List


SupportClass.ThreadClass.Abort Method (Object)

Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread while also providing exception information about the thread termination. Calling this method usually terminates the thread.

public void Abort(
object stateInfo
);

Parameters

stateInfo
An object that contains application-specific information, such as state, which can be used by the thread being aborted

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass.Abort Overload List


SupportClass.ThreadClass.Current Method

Gets the currently running thread

public static ThreadClass Current();

Return Value

The currently running thread

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Interrupt Method

Interrupts a thread that is in the WaitSleepJoin thread state

public virtual void Interrupt();

See Also

SupportClass.ThreadClass Class | (global) Namespace


Join Method

An NDoc Documented Class Library

SupportClass.ThreadClass.Join Method

Blocks the calling thread until a thread terminates

Overload List

Blocks the calling thread until a thread terminates

public void Join();

Blocks the calling thread until a thread terminates or the specified time elapses

public void Join(long);

Blocks the calling thread until a thread terminates or the specified time elapses

public void Join(long,int);

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Join Method ()

Blocks the calling thread until a thread terminates

public void Join();

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass.Join Overload List


SupportClass.ThreadClass.Join Method (Int64)

Blocks the calling thread until a thread terminates or the specified time elapses

public void Join(
long MiliSeconds
);

Parameters

MiliSeconds
Time of wait in milliseconds

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass.Join Overload List


SupportClass.ThreadClass.Join Method (Int64, Int32)

Blocks the calling thread until a thread terminates or the specified time elapses

public void Join(
long MiliSeconds,
int NanoSeconds
);

Parameters

MiliSeconds
Time of wait in milliseconds
NanoSeconds
Time of wait in nanoseconds

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass.Join Overload List


SupportClass.ThreadClass.Resume Method

Resumes a thread that has been suspended

public void Resume();

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Run Method

This method has no functionality unless the method is overridden

public virtual void Run();

Implements

IThreadRunnable.Run

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Start Method

Causes the operating system to change the state of the current thread instance to ThreadState.Running

public virtual void Start();

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Suspend Method

Suspends the thread, if the thread is already suspended it has no effect

public void Suspend();

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.ToString Method

Obtain a String that represents the current Object

public override string ToString();

Return Value

A String that represents the current Object

See Also

SupportClass.ThreadClass Class | (global) Namespace


Lucene.Net.Analysis

An NDoc Documented Class Library

Lucene.Net.Analysis Namespace

Namespace hierarchy

Classes

Class | Description
Analyzer An Analyzer builds TokenStreams, which analyze text. It thus represents a policy for extracting index terms from text.

Typical implementations first build a Tokenizer, which breaks the stream of characters from the Reader into raw Tokens. One or more TokenFilters may then be applied to the output of the Tokenizer.

WARNING: You must override one of the methods defined by this class in your subclass or the Analyzer will enter an infinite loop.

CharTokenizer | An abstract base class for simple, character-oriented tokenizers.
LetterTokenizer | A LetterTokenizer is a tokenizer that divides text at non-letters. That's to say, it defines tokens as maximal strings of adjacent letters, as defined by java.lang.Character.isLetter() predicate. Note: this does a decent job for most European languages, but does a terrible job for some Asian languages, where words are not separated by spaces.
LowerCaseFilter | Normalizes token text to lower case.
LowerCaseTokenizer
PerFieldAnalyzerWrapper | This analyzer is used to facilitate scenarios where different fields require different analysis techniques. Use {@link #addAnalyzer} to add a non-default analyzer on a Field name basis. See TestPerFieldAnalyzerWrapper.java for example usage.
PorterStemFilter
SimpleAnalyzer | An Analyzer that filters LetterTokenizer with LowerCaseFilter.
StopAnalyzer | Filters LetterTokenizer with LowerCaseFilter and StopFilter.
StopFilter | Removes stop words from a token stream.
Token | A Token is an occurence of a term from the text of a Field. It consists of a term's text, the start and end offset of the term in the text of the Field, and a type string. The start and end offsets permit applications to re-associate a token with its source text, e.g., to display highlighted query terms in a document browser, or to show matching text fragments in a KWIC (KeyWord In Context) display, etc. The type is an interned string, assigned by a lexical analyzer (a.k.a. tokenizer), naming the lexical or syntactic class that the token belongs to. For example an end of sentence marker token might be implemented with type "eos". The default token type is "word".
TokenFilter
Tokenizer
TokenStream
WhitespaceAnalyzer | An Analyzer that uses WhitespaceTokenizer.
WhitespaceTokenizer | A WhitespaceTokenizer is a tokenizer that divides text at whitespace. Adjacent sequences of non-Whitespace characters form tokens.


Analyzer Class

An Analyzer builds TokenStreams, which analyze text. It thus represents a policy for extracting index terms from text.

Typical implementations first build a Tokenizer, which breaks the stream of characters from the Reader into raw Tokens. One or more TokenFilters may then be applied to the output of the Tokenizer.

WARNING: You must override one of the methods defined by this class in your subclass or the Analyzer will enter an infinite loop.

For a list of all members of this type, see Analyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Derived types

public abstract class Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Analyzer Members | Lucene.Net.Analysis Namespace


Analyzer Members

Analyzer overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Analyzer Constructor Initializes a new instance of the Analyzer class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Analyzer Class | Lucene.Net.Analysis Namespace


Analyzer Constructor

Initializes a new instance of the Analyzer class.

protected Analyzer();

See Also

Analyzer Class | Lucene.Net.Analysis Namespace


Analyzer Methods

The methods of the Analyzer class are listed below. For a complete list of Analyzer class members, see the Analyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Analyzer Class | Lucene.Net.Analysis Namespace


TokenStream Method

An NDoc Documented Class Library

Analyzer.TokenStream Method

Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.

Overload List

Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.

public virtual TokenStream TokenStream(TextReader);

Creates a TokenStream which tokenizes all the text in the provided Reader. Default implementation forwards to tokenStream(Reader) for compatibility with older version. Override to allow Analyzer to choose strategy based on document and/or Field. Must be able to handle null Field name for backward compatibility.

public virtual TokenStream TokenStream(string,TextReader);

See Also

Analyzer Class | Lucene.Net.Analysis Namespace | Reader)


Analyzer.TokenStream Method (TextReader)

Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.

public virtual TokenStream TokenStream(
TextReader reader
);

See Also

Analyzer Class | Lucene.Net.Analysis Namespace | Analyzer.TokenStream Overload List | Reader)


Analyzer.TokenStream Method (String, TextReader)

Creates a TokenStream which tokenizes all the text in the provided Reader. Default implementation forwards to tokenStream(Reader) for compatibility with older version. Override to allow Analyzer to choose strategy based on document and/or Field. Must be able to handle null Field name for backward compatibility.

public virtual TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

Analyzer Class | Lucene.Net.Analysis Namespace | Analyzer.TokenStream Overload List


CharTokenizer Class

An abstract base class for simple, character-oriented tokenizers.

For a list of all members of this type, see CharTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.LetterTokenizer
Lucene.Net.Analysis.RU.RussianLetterTokenizer
Lucene.Net.Analysis.WhitespaceTokenizer

public abstract class CharTokenizer : Tokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CharTokenizer Members | Lucene.Net.Analysis Namespace


CharTokenizer Members

CharTokenizer overview

Public Instance Constructors

CharTokenizer Constructor

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

Protected Internal Instance Methods

IsTokenChar | Returns true iff a character should be included in a token. This tokenizer generates as tokens adjacent sequences of characters which satisfy this predicate. Characters for which this is false are used to define token boundaries and are not included in tokens.
Normalize | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


CharTokenizer Constructor

public CharTokenizer(
TextReader input
);

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


CharTokenizer Methods

The methods of the CharTokenizer class are listed below. For a complete list of CharTokenizer class members, see the CharTokenizer Members topic.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

IsTokenChar | Returns true iff a character should be included in a token. This tokenizer generates as tokens adjacent sequences of characters which satisfy this predicate. Characters for which this is false are used to define token boundaries and are not included in tokens.
Normalize | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


CharTokenizer.IsTokenChar Method

Returns true iff a character should be included in a token. This tokenizer generates as tokens adjacent sequences of characters which satisfy this predicate. Characters for which this is false are used to define token boundaries and are not included in tokens.

protected internal abstract bool IsTokenChar(
char c
);

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


CharTokenizer.Next Method

Returns the next token in the stream, or null at EOS.

public override Token Next();

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


CharTokenizer.Normalize Method

Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

protected internal virtual char Normalize(
char c
);

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


LetterTokenizer Class

A LetterTokenizer is a tokenizer that divides text at non-letters. That's to say, it defines tokens as maximal strings of adjacent letters, as defined by java.lang.Character.isLetter() predicate. Note: this does a decent job for most European languages, but does a terrible job for some Asian languages, where words are not separated by spaces.

For a list of all members of this type, see LetterTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.LetterTokenizer
Lucene.Net.Analysis.LowerCaseTokenizer

public class LetterTokenizer : CharTokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LetterTokenizer Members | Lucene.Net.Analysis Namespace


LetterTokenizer Members

LetterTokenizer overview

Public Instance Constructors

LetterTokenizer Constructor Construct a new LetterTokenizer.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

Protected Internal Instance Methods

IsTokenChar | Collects only characters which satisfy {@link Character#isLetter(char)}.
Normalize (inherited from CharTokenizer) | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

LetterTokenizer Class | Lucene.Net.Analysis Namespace


LetterTokenizer Constructor

Construct a new LetterTokenizer.

public LetterTokenizer(
TextReader in_Renamed
);

See Also

LetterTokenizer Class | Lucene.Net.Analysis Namespace


LetterTokenizer Methods

The methods of the LetterTokenizer class are listed below. For a complete list of LetterTokenizer class members, see the LetterTokenizer Members topic.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

IsTokenChar | Collects only characters which satisfy {@link Character#isLetter(char)}.
Normalize (inherited from CharTokenizer) | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

LetterTokenizer Class | Lucene.Net.Analysis Namespace


LetterTokenizer.IsTokenChar Method

Collects only characters which satisfy {@link Character#isLetter(char)}.

protected internal override bool IsTokenChar(
char c
);

See Also

LetterTokenizer Class | Lucene.Net.Analysis Namespace


LowerCaseFilter Class

Normalizes token text to lower case.

For a list of all members of this type, see LowerCaseFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.LowerCaseFilter

public sealed class LowerCaseFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LowerCaseFilter Members | Lucene.Net.Analysis Namespace


LowerCaseFilter Members

LowerCaseFilter overview

Public Instance Constructors

LowerCaseFilter Constructor

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

LowerCaseFilter Class | Lucene.Net.Analysis Namespace


LowerCaseFilter Constructor

public LowerCaseFilter(
TokenStream in_Renamed
);

See Also

LowerCaseFilter Class | Lucene.Net.Analysis Namespace


LowerCaseFilter Methods

The methods of the LowerCaseFilter class are listed below. For a complete list of LowerCaseFilter class members, see the LowerCaseFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LowerCaseFilter Class | Lucene.Net.Analysis Namespace


LowerCaseFilter.Next Method

public override Token Next();

See Also

LowerCaseFilter Class | Lucene.Net.Analysis Namespace


LowerCaseTokenizer Class

For a list of all members of this type, see LowerCaseTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.LetterTokenizer
Lucene.Net.Analysis.LowerCaseTokenizer

public sealed class LowerCaseTokenizer : LetterTokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LowerCaseTokenizer Members | Lucene.Net.Analysis Namespace


LowerCaseTokenizer Members

LowerCaseTokenizer overview

Public Instance Constructors

LowerCaseTokenizer Constructor Construct a new LowerCaseTokenizer.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

Protected Internal Instance Methods

IsTokenChar (inherited from LetterTokenizer) | Collects only characters which satisfy {@link Character#isLetter(char)}.
Normalize | Collects only characters which satisfy {@link Character#isLetter(char)}.

See Also

LowerCaseTokenizer Class | Lucene.Net.Analysis Namespace


LowerCaseTokenizer Constructor

Construct a new LowerCaseTokenizer.

public LowerCaseTokenizer(
TextReader in_Renamed
);

See Also

LowerCaseTokenizer Class | Lucene.Net.Analysis Namespace


LowerCaseTokenizer Methods

The methods of the LowerCaseTokenizer class are listed below. For a complete list of LowerCaseTokenizer class members, see the LowerCaseTokenizer Members topic.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

IsTokenChar (inherited from LetterTokenizer) | Collects only characters which satisfy {@link Character#isLetter(char)}.
Normalize | Collects only characters which satisfy {@link Character#isLetter(char)}.

See Also

LowerCaseTokenizer Class | Lucene.Net.Analysis Namespace


LowerCaseTokenizer.Normalize Method

Collects only characters which satisfy {@link Character#isLetter(char)}.

protected internal override char Normalize(
char c
);

See Also

LowerCaseTokenizer Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Class

This analyzer is used to facilitate scenarios where different fields require different analysis techniques. Use {@link #addAnalyzer} to add a non-default analyzer on a Field name basis. See TestPerFieldAnalyzerWrapper.java for example usage.

For a list of all members of this type, see PerFieldAnalyzerWrapper Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.PerFieldAnalyzerWrapper

public class PerFieldAnalyzerWrapper : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PerFieldAnalyzerWrapper Members | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Members

PerFieldAnalyzerWrapper overview

Public Instance Constructors

PerFieldAnalyzerWrapper Constructor Constructs with default analyzer.

Public Instance Methods

AddAnalyzer | Defines an analyzer to use for the specified Field.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Constructor

Constructs with default analyzer.

public PerFieldAnalyzerWrapper(
Analyzer defaultAnalyzer
);

Parameters

defaultAnalyzer
Any fields not specifically defined to use a different analyzer will use the one provided here.

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Methods

The methods of the PerFieldAnalyzerWrapper class are listed below. For a complete list of PerFieldAnalyzerWrapper class members, see the PerFieldAnalyzerWrapper Members topic.

Public Instance Methods

AddAnalyzer | Defines an analyzer to use for the specified Field.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper.AddAnalyzer Method

Defines an analyzer to use for the specified Field.

public virtual void AddAnalyzer(
string fieldName,
Analyzer analyzer
);

Parameters

fieldName
Field name requiring a non-default analyzer.
analyzer
non-default analyzer to use for Field

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


TokenStream Method

An NDoc Documented Class Library

PerFieldAnalyzerWrapper.TokenStream Method

Overload List

Inherited from Analyzer.

public virtual TokenStream TokenStream(TextReader);

public override TokenStream TokenStream(string,TextReader);

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper.TokenStream Method (String, TextReader)

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace | PerFieldAnalyzerWrapper.TokenStream Overload List


PorterStemFilter Class

For a list of all members of this type, see PorterStemFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.PorterStemFilter

public sealed class PorterStemFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PorterStemFilter Members | Lucene.Net.Analysis Namespace


PorterStemFilter Members

PorterStemFilter overview

Public Instance Constructors

PorterStemFilter Constructor

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Returns the next input Token, after being stemmed
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

PorterStemFilter Class | Lucene.Net.Analysis Namespace


PorterStemFilter Constructor

public PorterStemFilter(
TokenStream in_Renamed
);

See Also

PorterStemFilter Class | Lucene.Net.Analysis Namespace


PorterStemFilter Methods

The methods of the PorterStemFilter class are listed below. For a complete list of PorterStemFilter class members, see the PorterStemFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Returns the next input Token, after being stemmed
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PorterStemFilter Class | Lucene.Net.Analysis Namespace


PorterStemFilter.Next Method

Returns the next input Token, after being stemmed

public override Token Next();

See Also

PorterStemFilter Class | Lucene.Net.Analysis Namespace


SimpleAnalyzer Class

An Analyzer that filters LetterTokenizer with LowerCaseFilter.

For a list of all members of this type, see SimpleAnalyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.SimpleAnalyzer

public sealed class SimpleAnalyzer : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SimpleAnalyzer Members | Lucene.Net.Analysis Namespace


SimpleAnalyzer Members

SimpleAnalyzer overview

Public Instance Constructors

SimpleAnalyzer Constructor Initializes a new instance of the SimpleAnalyzer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SimpleAnalyzer Class | Lucene.Net.Analysis Namespace


SimpleAnalyzer Constructor

Initializes a new instance of the SimpleAnalyzer class.

public SimpleAnalyzer();

See Also

SimpleAnalyzer Class | Lucene.Net.Analysis Namespace


SimpleAnalyzer Methods

The methods of the SimpleAnalyzer class are listed below. For a complete list of SimpleAnalyzer class members, see the SimpleAnalyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SimpleAnalyzer Class | Lucene.Net.Analysis Namespace


TokenStream Method

An NDoc Documented Class Library

SimpleAnalyzer.TokenStream Method

Overload List

Inherited from Analyzer.

public virtual TokenStream TokenStream(TextReader);

public override TokenStream TokenStream(string,TextReader);

See Also

SimpleAnalyzer Class | Lucene.Net.Analysis Namespace


SimpleAnalyzer.TokenStream Method (String, TextReader)

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

SimpleAnalyzer Class | Lucene.Net.Analysis Namespace | SimpleAnalyzer.TokenStream Overload List


StopAnalyzer Class

Filters LetterTokenizer with LowerCaseFilter and StopFilter.

For a list of all members of this type, see StopAnalyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.StopAnalyzer

public sealed class StopAnalyzer : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StopAnalyzer Members | Lucene.Net.Analysis Namespace


StopAnalyzer Members

StopAnalyzer overview

Public Static Fields

ENGLISH_STOP_WORDS An array containing some common English words that are not usually useful for searching.

Public Instance Constructors

StopAnalyzer Overloaded. Initializes a new instance of the StopAnalyzer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded. Filters LowerCaseTokenizer with StopFilter.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


StopAnalyzer Constructor

Builds an analyzer which removes words in ENGLISH_STOP_WORDS.

Overload List

Builds an analyzer which removes words in ENGLISH_STOP_WORDS.

public StopAnalyzer();

Builds an analyzer which removes words in the provided array.

public StopAnalyzer(string[]);

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


StopAnalyzer Constructor ()

Builds an analyzer which removes words in ENGLISH_STOP_WORDS.

public StopAnalyzer();

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace | StopAnalyzer Constructor Overload List


StopAnalyzer Constructor (String[])

Builds an analyzer which removes words in the provided array.

public StopAnalyzer(
string[] stopWords
);

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace | StopAnalyzer Constructor Overload List


StopAnalyzer Fields

The fields of the StopAnalyzer class are listed below. For a complete list of StopAnalyzer class members, see the StopAnalyzer Members topic.

Public Static Fields

ENGLISH_STOP_WORDS An array containing some common English words that are not usually useful for searching.

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


StopAnalyzer.ENGLISH_STOP_WORDS Field

An array containing some common English words that are not usually useful for searching.

public static readonly string[] ENGLISH_STOP_WORDS;

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


StopAnalyzer Methods

The methods of the StopAnalyzer class are listed below. For a complete list of StopAnalyzer class members, see the StopAnalyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded. Filters LowerCaseTokenizer with StopFilter.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


TokenStream Method

An NDoc Documented Class Library

StopAnalyzer.TokenStream Method

Filters LowerCaseTokenizer with StopFilter.

Overload List

Inherited from Analyzer.

public virtual TokenStream TokenStream(TextReader);

Filters LowerCaseTokenizer with StopFilter.

public override TokenStream TokenStream(string,TextReader);

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


StopAnalyzer.TokenStream Method (String, TextReader)

Filters LowerCaseTokenizer with StopFilter.

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace | StopAnalyzer.TokenStream Overload List


StopFilter Class

Removes stop words from a token stream.

For a list of all members of this type, see StopFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.StopFilter

public sealed class StopFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StopFilter Members | Lucene.Net.Analysis Namespace


StopFilter Members

StopFilter overview

Public Static Methods

MakeStopSet | Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
MakeStopTable | Builds a Hashtable from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this table construction to be cached once when an Analyzer is constructed.

Public Instance Constructors

StopFilter Overloaded. Initializes a new instance of the StopFilter class.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Returns the next input Token whose termText() is not a stop word.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

StopFilter Class | Lucene.Net.Analysis Namespace


StopFilter Constructor

Constructs a filter which removes words from the input TokenStream that are named in the array of words.

Overload List

Constructs a filter which removes words from the input TokenStream that are named in the Hashtable.

public StopFilter(TokenStream,Hashtable);

Constructs a filter which removes words from the input TokenStream that are named in the array of words.

public StopFilter(TokenStream,string[]);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace


StopFilter Constructor (TokenStream, String[])

Constructs a filter which removes words from the input TokenStream that are named in the array of words.

public StopFilter(
TokenStream in_Renamed,
string[] stopWords
);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace | StopFilter Constructor Overload List


StopFilter Constructor (TokenStream, Hashtable)

Constructs a filter which removes words from the input TokenStream that are named in the Hashtable.

public StopFilter(
TokenStream in_Renamed,
Hashtable stopTable
);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace | StopFilter Constructor Overload List


StopFilter Methods

The methods of the StopFilter class are listed below. For a complete list of StopFilter class members, see the StopFilter Members topic.

Public Static Methods

MakeStopSet | Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
MakeStopTable | Builds a Hashtable from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this table construction to be cached once when an Analyzer is constructed.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Returns the next input Token whose termText() is not a stop word.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StopFilter Class | Lucene.Net.Analysis Namespace


StopFilter.MakeStopSet Method

Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.

public static Hashtable MakeStopSet(
string[] stopWords
);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace


StopFilter.MakeStopTable Method

Builds a Hashtable from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this table construction to be cached once when an Analyzer is constructed.

public static Hashtable MakeStopTable(
string[] stopWords
);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace


StopFilter.Next Method

Returns the next input Token whose termText() is not a stop word.

public override Token Next();

See Also

StopFilter Class | Lucene.Net.Analysis Namespace


Token Class

A Token is an occurence of a term from the text of a Field. It consists of a term's text, the start and end offset of the term in the text of the Field, and a type string. The start and end offsets permit applications to re-associate a token with its source text, e.g., to display highlighted query terms in a document browser, or to show matching text fragments in a KWIC (KeyWord In Context) display, etc. The type is an interned string, assigned by a lexical analyzer (a.k.a. tokenizer), naming the lexical or syntactic class that the token belongs to. For example an end of sentence marker token might be implemented with type "eos". The default token type is "word".

For a list of all members of this type, see Token Members.

System.Object
Lucene.Net.Analysis.Token

public sealed class Token

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Token Members | Lucene.Net.Analysis Namespace


Token Members

Token overview

Public Instance Constructors

Token Overloaded. Initializes a new instance of the Token class.

Public Instance Methods

EndOffset | Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrement | Returns the position increment of this Token.
GetType (inherited from Object) | Gets the Type of the current instance.
SetPositionIncrement |
StartOffset | Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.
TermText | Returns the Token's term text.
ToString (inherited from Object) | Returns a String that represents the current Object.
Type | Returns this Token's lexical type. Defaults to "word".

See Also

Token Class | Lucene.Net.Analysis Namespace


Token Constructor

Overload List

public Token(string,int,int);

public Token(string,int,int,string);

See Also

Token Class | Lucene.Net.Analysis Namespace


Token Constructor (String, Int32, Int32)

public Token(
string text,
int start,
int end
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token Constructor Overload List


Token Constructor (String, Int32, Int32, String)

public Token(
string text,
int start,
int end,
string typ
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token Constructor Overload List


Token Methods

The methods of the Token class are listed below. For a complete list of Token class members, see the Token Members topic.

Public Instance Methods

EndOffset | Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrement | Returns the position increment of this Token.
GetType (inherited from Object) | Gets the Type of the current instance.
SetPositionIncrement |
StartOffset | Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.
TermText | Returns the Token's term text.
ToString (inherited from Object) | Returns a String that represents the current Object.
Type | Returns this Token's lexical type. Defaults to "word".

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.EndOffset Method

Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text.

public int EndOffset();

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.GetPositionIncrement Method

Returns the position increment of this Token.

public int GetPositionIncrement();

See Also

Token Class | Lucene.Net.Analysis Namespace | #setPositionIncrement


Token.SetPositionIncrement Method

public void SetPositionIncrement(
int positionIncrement
);

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.StartOffset Method

Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.

public int StartOffset();

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.TermText Method

Returns the Token's term text.

public string TermText();

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.Type Method

Returns this Token's lexical type. Defaults to "word".

public string Type();

See Also

Token Class | Lucene.Net.Analysis Namespace


TokenFilter Class

For a list of all members of this type, see TokenFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Derived types

public abstract class TokenFilter : TokenStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TokenFilter Members | Lucene.Net.Analysis Namespace


TokenFilter Members

TokenFilter overview

Public Instance Methods

Close | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from TokenStream) | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

TokenFilter Overloaded. Initializes a new instance of the TokenFilter class.

Protected Internal Instance Fields

input The source of tokens for this filter.

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


TokenFilter Constructor

Call TokenFilter(TokenStream) instead.

Overload List

Call TokenFilter(TokenStream) instead.

protected internal TokenFilter();

Construct a token stream filtering the given input.

protected internal TokenFilter(TokenStream);

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


TokenFilter Constructor ()

Call TokenFilter(TokenStream) instead.

protected internal TokenFilter();

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace | TokenFilter Constructor Overload List


TokenFilter Constructor (TokenStream)

Construct a token stream filtering the given input.

protected internal TokenFilter(
TokenStream input
);

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace | TokenFilter Constructor Overload List


TokenFilter Fields

The fields of the TokenFilter class are listed below. For a complete list of TokenFilter class members, see the TokenFilter Members topic.

Protected Internal Instance Fields

input The source of tokens for this filter.

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


TokenFilter.input Field

The source of tokens for this filter.

protected internal TokenStream input;

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


TokenFilter Methods

The methods of the TokenFilter class are listed below. For a complete list of TokenFilter class members, see the TokenFilter Members topic.

Public Instance Methods

Close | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from TokenStream) | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


TokenFilter.Close Method

Close the input TokenStream.

public override void Close();

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


Tokenizer Class

For a list of all members of this type, see Tokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.Standard.StandardTokenizer

public abstract class Tokenizer : TokenStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Tokenizer Members | Lucene.Net.Analysis Namespace


Tokenizer Members

Tokenizer overview

Public Instance Methods

Close | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from TokenStream) | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

Tokenizer Overloaded. Initializes a new instance of the Tokenizer class.

Protected Internal Instance Fields

input The text source for this Tokenizer.

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


Tokenizer Constructor

Construct a tokenizer with null input.

Overload List

Construct a tokenizer with null input.

protected internal Tokenizer();

Construct a token stream processing the given input.

protected internal Tokenizer(TextReader);

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


Tokenizer Constructor ()

Construct a tokenizer with null input.

protected internal Tokenizer();

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace | Tokenizer Constructor Overload List


Tokenizer Constructor (TextReader)

Construct a token stream processing the given input.

protected internal Tokenizer(
TextReader input
);

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace | Tokenizer Constructor Overload List


Tokenizer Fields

The fields of the Tokenizer class are listed below. For a complete list of Tokenizer class members, see the Tokenizer Members topic.

Protected Internal Instance Fields

input The text source for this Tokenizer.

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


Tokenizer.input Field

The text source for this Tokenizer.

protected internal TextReader input;

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


Tokenizer Methods

The methods of the Tokenizer class are listed below. For a complete list of Tokenizer class members, see the Tokenizer Members topic.

Public Instance Methods

Close | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from TokenStream) | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


Tokenizer.Close Method

By default, closes the input Reader.

public override void Close();

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


TokenStream Class

For a list of all members of this type, see TokenStream Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.Tokenizer

public abstract class TokenStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TokenStream Members | Lucene.Net.Analysis Namespace


TokenStream Members

TokenStream overview

Public Instance Methods

Close | Releases resources associated with this stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

TokenStream Constructor Initializes a new instance of the TokenStream class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TokenStream Class | Lucene.Net.Analysis Namespace


TokenStream Constructor

Initializes a new instance of the TokenStream class.

protected TokenStream();

See Also

TokenStream Class | Lucene.Net.Analysis Namespace


TokenStream Methods

The methods of the TokenStream class are listed below. For a complete list of TokenStream class members, see the TokenStream Members topic.

Public Instance Methods

Close | Releases resources associated with this stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TokenStream Class | Lucene.Net.Analysis Namespace


TokenStream.Close Method

Releases resources associated with this stream.

public virtual void Close();

See Also

TokenStream Class | Lucene.Net.Analysis Namespace


TokenStream.Next Method

Returns the next token in the stream, or null at EOS.

public abstract Token Next();

See Also

TokenStream Class | Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Class

An Analyzer that uses WhitespaceTokenizer.

For a list of all members of this type, see WhitespaceAnalyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.WhitespaceAnalyzer

public sealed class WhitespaceAnalyzer : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

WhitespaceAnalyzer Members | Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Members

WhitespaceAnalyzer overview

Public Instance Constructors

WhitespaceAnalyzer Constructor Initializes a new instance of the WhitespaceAnalyzer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WhitespaceAnalyzer Class | Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Constructor

Initializes a new instance of the WhitespaceAnalyzer class.

public WhitespaceAnalyzer();

See Also

WhitespaceAnalyzer Class | Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Methods

The methods of the WhitespaceAnalyzer class are listed below. For a complete list of WhitespaceAnalyzer class members, see the WhitespaceAnalyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WhitespaceAnalyzer Class | Lucene.Net.Analysis Namespace


TokenStream Method

An NDoc Documented Class Library

WhitespaceAnalyzer.TokenStream Method

Overload List

Inherited from Analyzer.

public virtual TokenStream TokenStream(TextReader);

public override TokenStream TokenStream(string,TextReader);

See Also

WhitespaceAnalyzer Class | Lucene.Net.Analysis Namespace


WhitespaceAnalyzer.TokenStream Method (String, TextReader)

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

WhitespaceAnalyzer Class | Lucene.Net.Analysis Namespace | WhitespaceAnalyzer.TokenStream Overload List


WhitespaceTokenizer Class

A WhitespaceTokenizer is a tokenizer that divides text at whitespace. Adjacent sequences of non-Whitespace characters form tokens.

For a list of all members of this type, see WhitespaceTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.WhitespaceTokenizer

public class WhitespaceTokenizer : CharTokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

WhitespaceTokenizer Members | Lucene.Net.Analysis Namespace


WhitespaceTokenizer Members

WhitespaceTokenizer overview

Public Instance Constructors

WhitespaceTokenizer Constructor Construct a new WhitespaceTokenizer.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

Protected Internal Instance Methods

IsTokenChar | Collects only characters which do not satisfy {@link Character#isWhitespace(char)}.
Normalize (inherited from CharTokenizer) | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

WhitespaceTokenizer Class | Lucene.Net.Analysis Namespace


WhitespaceTokenizer Constructor

Construct a new WhitespaceTokenizer.

public WhitespaceTokenizer(
TextReader in_Renamed
);

See Also

WhitespaceTokenizer Class | Lucene.Net.Analysis Namespace


WhitespaceTokenizer Methods

The methods of the WhitespaceTokenizer class are listed below. For a complete list of WhitespaceTokenizer class members, see the WhitespaceTokenizer Members topic.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

IsTokenChar | Collects only characters which do not satisfy {@link Character#isWhitespace(char)}.
Normalize (inherited from CharTokenizer) | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

WhitespaceTokenizer Class | Lucene.Net.Analysis Namespace


WhitespaceTokenizer.IsTokenChar Method

Collects only characters which do not satisfy {@link Character#isWhitespace(char)}.

protected internal override bool IsTokenChar(
char c
);

See Also

WhitespaceTokenizer Class | Lucene.Net.Analysis Namespace


Lucene.Net.Analysis.DE

An NDoc Documented Class Library

Lucene.Net.Analysis.DE Namespace

Namespace hierarchy

Classes

Class | Description
GermanAnalyzer | Analyzer for German language. Supports an external list of stopwords (words that will not be indexed at all) and an external list of exclusions (word that will not be stemmed, but indexed). A default set of stopwords is used unless an alternative list is specified, the exclusion list is empty by default.
GermanStemFilter | A filter that stems German words. It supports a table of words that should not be stemmed at all. The stemmer used can be changed at runtime after the filter object is created (as long as it is a GermanStemmer).
GermanStemmer | A stemmer for German words. The algorithm is based on the report "A Fast and Simple Stemming Algorithm for German Words" by Jörg Caumanns (joerg.caumanns@isst.fhg.de).
WordlistLoader | Loader for text files that represent a list of stopwords.


GermanAnalyzer Class

Analyzer for German language. Supports an external list of stopwords (words that will not be indexed at all) and an external list of exclusions (word that will not be stemmed, but indexed). A default set of stopwords is used unless an alternative list is specified, the exclusion list is empty by default.

For a list of all members of this type, see GermanAnalyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.DE.GermanAnalyzer

public class GermanAnalyzer : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.DE

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

GermanAnalyzer Members | Lucene.Net.Analysis.DE Namespace


GermanAnalyzer Members

GermanAnalyzer overview

Public Instance Constructors

GermanAnalyzer Overloaded. Initializes a new instance of the GermanAnalyzer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetStemExclusionTable | Overloaded. Builds an exclusionlist from the words contained in the given file.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace


GermanAnalyzer Constructor

Builds an analyzer.

Overload List

Builds an analyzer.

public GermanAnalyzer();

Builds an analyzer with the given stop words.

public GermanAnalyzer(Hashtable);

Builds an analyzer with the given stop words.

public GermanAnalyzer(FileInfo);

Builds an analyzer with the given stop words.

public GermanAnalyzer(string[]);

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace


GermanAnalyzer Constructor ()

Builds an analyzer.

public GermanAnalyzer();

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace | GermanAnalyzer Constructor Overload List


GermanAnalyzer Constructor (String[])

Builds an analyzer with the given stop words.

public GermanAnalyzer(
string[] stopwords
);

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace | GermanAnalyzer Constructor Overload List


GermanAnalyzer Constructor (Hashtable)

Builds an analyzer with the given stop words.

public GermanAnalyzer(
Hashtable stopwords
);

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace | GermanAnalyzer Constructor Overload List


GermanAnalyzer Constructor (FileInfo)

Builds an analyzer with the given stop words.

public GermanAnalyzer(
FileInfo stopwords
);

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace | GermanAnalyzer Constructor Overload List


GermanAnalyzer Methods

The methods of the GermanAnalyzer class are listed below. For a complete list of GermanAnalyzer class members, see the GermanAnalyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetStemExclusionTable | Overloaded. Builds an exclusionlist from the words contained in the given file.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace


SetStemExclusionTable Method

An NDoc Documented Class Library

GermanAnalyzer.SetStemExclusionTable Method

Builds an exclusionlist from a Hashtable.

Overload List

Builds an exclusionlist from a Hashtable.

public virtual void SetStemExclusionTable(Hashtable);

Builds an exclusionlist from the words contained in the given file.

public virtual void SetStemExclusionTable(FileInfo);

Builds an exclusionlist from an array of Strings.

public virtual void SetStemExclusionTable(string[]);

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace


GermanAnalyzer.SetStemExclusionTable Method (Hashtable)

Builds an exclusionlist from a Hashtable.

public virtual void SetStemExclusionTable(
Hashtable exclusionlist
);

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace | GermanAnalyzer.SetStemExclusionTable Overload List


GermanAnalyzer.SetStemExclusionTable Method (FileInfo)

Builds an exclusionlist from the words contained in the given file.

public virtual void SetStemExclusionTable(
FileInfo exclusionlist
);

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace | GermanAnalyzer.SetStemExclusionTable Overload List


GermanAnalyzer.SetStemExclusionTable Method (String[])

Builds an exclusionlist from an array of Strings.

public virtual void SetStemExclusionTable(
string[] exclusionlist
);

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace | GermanAnalyzer.SetStemExclusionTable Overload List


TokenStream Method

An NDoc Documented Class Library

GermanAnalyzer.TokenStream Method

Creates a TokenStream which tokenizes all the text in the provided Reader.

Overload List

Inherited from Analyzer.

public virtual TokenStream TokenStream(TextReader);

Creates a TokenStream which tokenizes all the text in the provided Reader.

public override TokenStream TokenStream(string,TextReader);

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace


GermanAnalyzer.TokenStream Method (String, TextReader)

Creates a TokenStream which tokenizes all the text in the provided Reader.

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

Return Value

A TokenStream build from a StandardTokenizer filtered with StandardFilter, LowerCaseFilter, StopFilter, GermanStemFilter

See Also

GermanAnalyzer Class | Lucene.Net.Analysis.DE Namespace | GermanAnalyzer.TokenStream Overload List


GermanStemFilter Class

A filter that stems German words. It supports a table of words that should not be stemmed at all. The stemmer used can be changed at runtime after the filter object is created (as long as it is a GermanStemmer).

For a list of all members of this type, see GermanStemFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.DE.GermanStemFilter

public sealed class GermanStemFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.DE

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

GermanStemFilter Members | Lucene.Net.Analysis.DE Namespace


GermanStemFilter Members

GermanStemFilter overview

Public Instance Constructors

GermanStemFilter Overloaded. Initializes a new instance of the GermanStemFilter class.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
SetExclusionSet | Set an alternative exclusion list for this filter.
SetExclusionTable | Set an alternative exclusion list for this filter.
SetStemmer | Set a alternative/custom GermanStemmer for this filter.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

GermanStemFilter Class | Lucene.Net.Analysis.DE Namespace


GermanStemFilter Constructor

Overload List

public GermanStemFilter(TokenStream);

Builds a GermanStemFilter that uses an exclusiontable.

public GermanStemFilter(TokenStream,Hashtable);

See Also

GermanStemFilter Class | Lucene.Net.Analysis.DE Namespace


GermanStemFilter Constructor (TokenStream)

public GermanStemFilter(
TokenStream in_Renamed
);

See Also

GermanStemFilter Class | Lucene.Net.Analysis.DE Namespace | GermanStemFilter Constructor Overload List


GermanStemFilter Constructor (TokenStream, Hashtable)

Builds a GermanStemFilter that uses an exclusiontable.

public GermanStemFilter(
TokenStream in_Renamed,
Hashtable exclusiontable
);

See Also

GermanStemFilter Class | Lucene.Net.Analysis.DE Namespace | GermanStemFilter Constructor Overload List


GermanStemFilter Methods

The methods of the GermanStemFilter class are listed below. For a complete list of GermanStemFilter class members, see the GermanStemFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
SetExclusionSet | Set an alternative exclusion list for this filter.
SetExclusionTable | Set an alternative exclusion list for this filter.
SetStemmer | Set a alternative/custom GermanStemmer for this filter.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GermanStemFilter Class | Lucene.Net.Analysis.DE Namespace


GermanStemFilter.Next Method

public override Token Next();

Return Value

Returns the next token in the stream, or null at EOS

See Also

GermanStemFilter Class | Lucene.Net.Analysis.DE Namespace


GermanStemFilter.SetExclusionSet Method

Set an alternative exclusion list for this filter.

public void SetExclusionSet(
Hashtable exclusionSet
);

See Also

GermanStemFilter Class | Lucene.Net.Analysis.DE Namespace


GermanStemFilter.SetExclusionTable Method

Set an alternative exclusion list for this filter.

public void SetExclusionTable(
Hashtable exclusiontable
);

See Also

GermanStemFilter Class | Lucene.Net.Analysis.DE Namespace


GermanStemFilter.SetStemmer Method

Set a alternative/custom GermanStemmer for this filter.

public void SetStemmer(
GermanStemmer stemmer
);

See Also

GermanStemFilter Class | Lucene.Net.Analysis.DE Namespace


GermanStemmer Class

A stemmer for German words. The algorithm is based on the report "A Fast and Simple Stemming Algorithm for German Words" by Jörg Caumanns (joerg.caumanns@isst.fhg.de).

For a list of all members of this type, see GermanStemmer Members.

System.Object
Lucene.Net.Analysis.DE.GermanStemmer

public class GermanStemmer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.DE

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

GermanStemmer Members | Lucene.Net.Analysis.DE Namespace


GermanStemmer Members

GermanStemmer overview

Public Instance Constructors

GermanStemmer Constructor Initializes a new instance of the GermanStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Stem Stemms the given term to an unique discriminator.

See Also

GermanStemmer Class | Lucene.Net.Analysis.DE Namespace


GermanStemmer Constructor

Initializes a new instance of the GermanStemmer class.

public GermanStemmer();

See Also

GermanStemmer Class | Lucene.Net.Analysis.DE Namespace


GermanStemmer Methods

The methods of the GermanStemmer class are listed below. For a complete list of GermanStemmer class members, see the GermanStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Stem Stemms the given term to an unique discriminator.

See Also

GermanStemmer Class | Lucene.Net.Analysis.DE Namespace


GermanStemmer.Stem Method

Stemms the given term to an unique discriminator.

protected internal virtual string Stem(
string term
);

Parameters

term
The term that should be stemmed.

Return Value

Discriminator for term

See Also

GermanStemmer Class | Lucene.Net.Analysis.DE Namespace


WordlistLoader Class

Loader for text files that represent a list of stopwords.

For a list of all members of this type, see WordlistLoader Members.

System.Object
Lucene.Net.Analysis.DE.WordlistLoader

public class WordlistLoader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.DE

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

WordlistLoader Members | Lucene.Net.Analysis.DE Namespace


WordlistLoader Members

WordlistLoader overview

Public Static Methods

GetWordSet | Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like GermanAnalyzer).
GetWordtable | Overloaded.

Public Instance Constructors

WordlistLoader Constructor Initializes a new instance of the WordlistLoader class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WordlistLoader Class | Lucene.Net.Analysis.DE Namespace


WordlistLoader Constructor

Initializes a new instance of the WordlistLoader class.

public WordlistLoader();

See Also

WordlistLoader Class | Lucene.Net.Analysis.DE Namespace


WordlistLoader Methods

The methods of the WordlistLoader class are listed below. For a complete list of WordlistLoader class members, see the WordlistLoader Members topic.

Public Static Methods

GetWordSet | Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like GermanAnalyzer).
GetWordtable | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WordlistLoader Class | Lucene.Net.Analysis.DE Namespace


WordlistLoader.GetWordSet Method

Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like GermanAnalyzer).

public static Hashtable GetWordSet(
FileInfo wordfile
);

Parameters

wordfile
File containing the wordlist

Return Value

A HashSet with the file's words

See Also

WordlistLoader Class | Lucene.Net.Analysis.DE Namespace


GetWordtable Method

An NDoc Documented Class Library

WordlistLoader.GetWordtable Method

Overload List

public static Hashtable GetWordtable(FileInfo);

public static Hashtable GetWordtable(string);

public static Hashtable GetWordtable(string,string);

See Also

WordlistLoader Class | Lucene.Net.Analysis.DE Namespace


WordlistLoader.GetWordtable Method (FileInfo)

public static Hashtable GetWordtable(
FileInfo wordfile
);

Parameters

wordfile
File object that points to the wordlist

See Also

WordlistLoader Class | Lucene.Net.Analysis.DE Namespace | WordlistLoader.GetWordtable Overload List


WordlistLoader.GetWordtable Method (String)

public static Hashtable GetWordtable(
string wordfile
);

Parameters

wordfile
Complete path to the wordlist

See Also

WordlistLoader Class | Lucene.Net.Analysis.DE Namespace | WordlistLoader.GetWordtable Overload List


WordlistLoader.GetWordtable Method (String, String)

public static Hashtable GetWordtable(
string path,
string wordfile
);

Parameters

path
Path to the wordlist
wordfile
Name of the wordlist

See Also

WordlistLoader Class | Lucene.Net.Analysis.DE Namespace | WordlistLoader.GetWordtable Overload List


Lucene.Net.Analysis.RU

An NDoc Documented Class Library

Lucene.Net.Analysis.RU Namespace

Namespace hierarchy

Classes

Class | Description
RussianAnalyzer | Analyzer for Russian language. Supports an external list of stopwords (words that will not be indexed at all). A default set of stopwords is used unless an alternative list is specified.
RussianCharsets | RussianCharsets class contains encodings schemes (charsets) and toLowerCase() method implementation for russian characters in Unicode, KOI8 and CP1252. Each encoding scheme contains lowercase (positions 0-31) and uppercase (position 32-63) characters. One should be able to add other encoding schemes (like ISO-8859-5 or customized) by adding a new charset and adding logic to toLowerCase() method for that charset.
RussianLetterTokenizer | A RussianLetterTokenizer is a tokenizer that extends LetterTokenizer by additionally looking up letters in a given "russian charset". The problem with LeterTokenizer is that it uses Character.isLetter() method, which doesn't know how to detect letters in encodings like CP1252 and KOI8 (well-known problems with 0xD7 and 0xF7 chars)
RussianLowerCaseFilter | Normalizes token text to lower case, analyzing given ("russian") charset.
RussianStemFilter | A filter that stems Russian words. The implementation was inspired by GermanStemFilter. The input should be filtered by RussianLowerCaseFilter before passing it to RussianStemFilter , because RussianStemFilter only works with lowercase part of any "russian" charset.
RussianStemmer | Russian stemming algorithm implementation (see http://snowball.sourceforge.net for detailed description).


RussianAnalyzer Class

Analyzer for Russian language. Supports an external list of stopwords (words that will not be indexed at all). A default set of stopwords is used unless an alternative list is specified.

For a list of all members of this type, see RussianAnalyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.RU.RussianAnalyzer

public sealed class RussianAnalyzer : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.RU

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RussianAnalyzer Members | Lucene.Net.Analysis.RU Namespace


RussianAnalyzer Members

RussianAnalyzer overview

Public Instance Constructors

RussianAnalyzer Overloaded. Initializes a new instance of the RussianAnalyzer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RussianAnalyzer Class | Lucene.Net.Analysis.RU Namespace


RussianAnalyzer Constructor

Initializes a new instance of the RussianAnalyzer class.

Overload List

Initializes a new instance of the RussianAnalyzer class.

public RussianAnalyzer();

Builds an analyzer.

public RussianAnalyzer(char[]);

Builds an analyzer with the given stop words.

public RussianAnalyzer(char[],Hashtable);

Builds an analyzer with the given stop words.

public RussianAnalyzer(char[],string[]);

See Also

RussianAnalyzer Class | Lucene.Net.Analysis.RU Namespace


RussianAnalyzer Constructor ()

Initializes a new instance of the RussianAnalyzer class.

public RussianAnalyzer();

See Also

RussianAnalyzer Class | Lucene.Net.Analysis.RU Namespace | RussianAnalyzer Constructor Overload List


RussianAnalyzer Constructor (Char[])

Builds an analyzer.

public RussianAnalyzer(
char[] charset
);

See Also

RussianAnalyzer Class | Lucene.Net.Analysis.RU Namespace | RussianAnalyzer Constructor Overload List


RussianAnalyzer Constructor (Char[], String[])

Builds an analyzer with the given stop words.

public RussianAnalyzer(
char[] charset,
string[] stopwords
);

See Also

RussianAnalyzer Class | Lucene.Net.Analysis.RU Namespace | RussianAnalyzer Constructor Overload List


RussianAnalyzer Constructor (Char[], Hashtable)

Builds an analyzer with the given stop words.

public RussianAnalyzer(
char[] charset,
Hashtable stopwords
);

See Also

RussianAnalyzer Class | Lucene.Net.Analysis.RU Namespace | RussianAnalyzer Constructor Overload List


RussianAnalyzer Methods

The methods of the RussianAnalyzer class are listed below. For a complete list of RussianAnalyzer class members, see the RussianAnalyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RussianAnalyzer Class | Lucene.Net.Analysis.RU Namespace


TokenStream Method

An NDoc Documented Class Library

RussianAnalyzer.TokenStream Method

Creates a TokenStream which tokenizes all the text in the provided Reader.

Overload List

Inherited from Analyzer.

public virtual TokenStream TokenStream(TextReader);

Creates a TokenStream which tokenizes all the text in the provided Reader.

public override TokenStream TokenStream(string,TextReader);

See Also

RussianAnalyzer Class | Lucene.Net.Analysis.RU Namespace


RussianAnalyzer.TokenStream Method (String, TextReader)

Creates a TokenStream which tokenizes all the text in the provided Reader.

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

Return Value

A TokenStream build from a RussianLetterTokenizer filtered with RussianLowerCaseFilter, StopFilter, and RussianStemFilter

See Also

RussianAnalyzer Class | Lucene.Net.Analysis.RU Namespace | RussianAnalyzer.TokenStream Overload List


RussianCharsets Class

RussianCharsets class contains encodings schemes (charsets) and toLowerCase() method implementation for russian characters in Unicode, KOI8 and CP1252. Each encoding scheme contains lowercase (positions 0-31) and uppercase (position 32-63) characters. One should be able to add other encoding schemes (like ISO-8859-5 or customized) by adding a new charset and adding logic to toLowerCase() method for that charset.

For a list of all members of this type, see RussianCharsets Members.

System.Object
Lucene.Net.Analysis.RU.RussianCharsets

public class RussianCharsets

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.RU

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RussianCharsets Members | Lucene.Net.Analysis.RU Namespace


RussianCharsets Members

RussianCharsets overview

Public Static Fields

CP1251
KOI8
UnicodeRussian

Public Static Methods

ToLowerCase

Public Instance Constructors

RussianCharsets Constructor Initializes a new instance of the RussianCharsets class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RussianCharsets Class | Lucene.Net.Analysis.RU Namespace


RussianCharsets Constructor

Initializes a new instance of the RussianCharsets class.

public RussianCharsets();

See Also

RussianCharsets Class | Lucene.Net.Analysis.RU Namespace


RussianCharsets Fields

The fields of the RussianCharsets class are listed below. For a complete list of RussianCharsets class members, see the RussianCharsets Members topic.

Public Static Fields

CP1251
KOI8
UnicodeRussian

See Also

RussianCharsets Class | Lucene.Net.Analysis.RU Namespace


RussianCharsets.CP1251 Field

public static char[] CP1251;

See Also

RussianCharsets Class | Lucene.Net.Analysis.RU Namespace


RussianCharsets.KOI8 Field

public static char[] KOI8;

See Also

RussianCharsets Class | Lucene.Net.Analysis.RU Namespace


RussianCharsets.UnicodeRussian Field

public static char[] UnicodeRussian;

See Also

RussianCharsets Class | Lucene.Net.Analysis.RU Namespace


RussianCharsets Methods

The methods of the RussianCharsets class are listed below. For a complete list of RussianCharsets class members, see the RussianCharsets Members topic.

Public Static Methods

ToLowerCase

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RussianCharsets Class | Lucene.Net.Analysis.RU Namespace


RussianCharsets.ToLowerCase Method

public static char ToLowerCase(
char letter,
char[] charset
);

See Also

RussianCharsets Class | Lucene.Net.Analysis.RU Namespace


RussianLetterTokenizer Class

A RussianLetterTokenizer is a tokenizer that extends LetterTokenizer by additionally looking up letters in a given "russian charset". The problem with LeterTokenizer is that it uses Character.isLetter() method, which doesn't know how to detect letters in encodings like CP1252 and KOI8 (well-known problems with 0xD7 and 0xF7 chars)

For a list of all members of this type, see RussianLetterTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.RU.RussianLetterTokenizer

public class RussianLetterTokenizer : CharTokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.RU

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RussianLetterTokenizer Members | Lucene.Net.Analysis.RU Namespace


RussianLetterTokenizer Members

RussianLetterTokenizer overview

Public Instance Constructors

RussianLetterTokenizer Constructor

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

Protected Internal Instance Methods

IsTokenChar | Collects only characters which satisfy {@link Character#isLetter(char)}.
Normalize (inherited from CharTokenizer) | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

RussianLetterTokenizer Class | Lucene.Net.Analysis.RU Namespace


RussianLetterTokenizer Constructor

public RussianLetterTokenizer(
TextReader in_Renamed,
char[] charset
);

See Also

RussianLetterTokenizer Class | Lucene.Net.Analysis.RU Namespace


RussianLetterTokenizer Methods

The methods of the RussianLetterTokenizer class are listed below. For a complete list of RussianLetterTokenizer class members, see the RussianLetterTokenizer Members topic.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Returns the next token in the stream, or null at EOS.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

IsTokenChar | Collects only characters which satisfy {@link Character#isLetter(char)}.
Normalize (inherited from CharTokenizer) | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

RussianLetterTokenizer Class | Lucene.Net.Analysis.RU Namespace


RussianLetterTokenizer.IsTokenChar Method

Collects only characters which satisfy {@link Character#isLetter(char)}.

protected internal override bool IsTokenChar(
char c
);

See Also

RussianLetterTokenizer Class | Lucene.Net.Analysis.RU Namespace


RussianLowerCaseFilter Class

Normalizes token text to lower case, analyzing given ("russian") charset.

For a list of all members of this type, see RussianLowerCaseFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.RU.RussianLowerCaseFilter

public sealed class RussianLowerCaseFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.RU

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RussianLowerCaseFilter Members | Lucene.Net.Analysis.RU Namespace


RussianLowerCaseFilter Members

RussianLowerCaseFilter overview

Public Instance Constructors

RussianLowerCaseFilter Constructor

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

RussianLowerCaseFilter Class | Lucene.Net.Analysis.RU Namespace


RussianLowerCaseFilter Constructor

public RussianLowerCaseFilter(
TokenStream in_Renamed,
char[] charset
);

See Also

RussianLowerCaseFilter Class | Lucene.Net.Analysis.RU Namespace


RussianLowerCaseFilter Methods

The methods of the RussianLowerCaseFilter class are listed below. For a complete list of RussianLowerCaseFilter class members, see the RussianLowerCaseFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RussianLowerCaseFilter Class | Lucene.Net.Analysis.RU Namespace


RussianLowerCaseFilter.Next Method

public override Token Next();

See Also

RussianLowerCaseFilter Class | Lucene.Net.Analysis.RU Namespace


RussianStemFilter Class

A filter that stems Russian words. The implementation was inspired by GermanStemFilter. The input should be filtered by RussianLowerCaseFilter before passing it to RussianStemFilter , because RussianStemFilter only works with lowercase part of any "russian" charset.

For a list of all members of this type, see RussianStemFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.RU.RussianStemFilter

public sealed class RussianStemFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.RU

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RussianStemFilter Members | Lucene.Net.Analysis.RU Namespace


RussianStemFilter Members

RussianStemFilter overview

Public Instance Constructors

RussianStemFilter Constructor

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
SetStemmer | Set a alternative/custom RussianStemmer for this filter.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

RussianStemFilter Class | Lucene.Net.Analysis.RU Namespace


RussianStemFilter Constructor

public RussianStemFilter(
TokenStream in_Renamed,
char[] charset
);

See Also

RussianStemFilter Class | Lucene.Net.Analysis.RU Namespace


RussianStemFilter Methods

The methods of the RussianStemFilter class are listed below. For a complete list of RussianStemFilter class members, see the RussianStemFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
SetStemmer | Set a alternative/custom RussianStemmer for this filter.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RussianStemFilter Class | Lucene.Net.Analysis.RU Namespace


RussianStemFilter.Next Method

public override Token Next();

Return Value

Returns the next token in the stream, or null at EOS

See Also

RussianStemFilter Class | Lucene.Net.Analysis.RU Namespace


RussianStemFilter.SetStemmer Method

Set a alternative/custom RussianStemmer for this filter.

public void SetStemmer(
RussianStemmer stemmer
);

See Also

RussianStemFilter Class | Lucene.Net.Analysis.RU Namespace


RussianStemmer Class

Russian stemming algorithm implementation (see http://snowball.sourceforge.net for detailed description).

For a list of all members of this type, see RussianStemmer Members.

System.Object
Lucene.Net.Analysis.RU.RussianStemmer

public class RussianStemmer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.RU

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RussianStemmer Members | Lucene.Net.Analysis.RU Namespace


RussianStemmer Members

RussianStemmer overview

Public Static Methods

Stem Overloaded. Static method for stemming with different charsets

Public Instance Constructors

RussianStemmer Overloaded. Initializes a new instance of the RussianStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCharset | Insert the method's description here. Creation date: (16/03/2002 10:58:42 PM)
Stem | Overloaded. Finds the stem for given Russian word. Creation date: (16/03/2002 3:36:48 PM)
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RussianStemmer Class | Lucene.Net.Analysis.RU Namespace


RussianStemmer Constructor

RussianStemmer constructor comment.

Overload List

RussianStemmer constructor comment.

public RussianStemmer();

RussianStemmer constructor comment.

public RussianStemmer(char[]);

See Also

RussianStemmer Class | Lucene.Net.Analysis.RU Namespace


RussianStemmer Constructor ()

RussianStemmer constructor comment.

public RussianStemmer();

See Also

RussianStemmer Class | Lucene.Net.Analysis.RU Namespace | RussianStemmer Constructor Overload List


RussianStemmer Constructor (Char[])

RussianStemmer constructor comment.

public RussianStemmer(
char[] charset
);

See Also

RussianStemmer Class | Lucene.Net.Analysis.RU Namespace | RussianStemmer Constructor Overload List


RussianStemmer Methods

The methods of the RussianStemmer class are listed below. For a complete list of RussianStemmer class members, see the RussianStemmer Members topic.

Public Static Methods

Stem Overloaded. Static method for stemming with different charsets

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCharset | Insert the method's description here. Creation date: (16/03/2002 10:58:42 PM)
Stem | Overloaded. Finds the stem for given Russian word. Creation date: (16/03/2002 3:36:48 PM)
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RussianStemmer Class | Lucene.Net.Analysis.RU Namespace


RussianStemmer.SetCharset Method

Insert the method's description here. Creation date: (16/03/2002 10:58:42 PM)

public virtual void SetCharset(
char[] newCharset
);

Parameters

newCharset
char[]

See Also

RussianStemmer Class | Lucene.Net.Analysis.RU Namespace


Stem Method

An NDoc Documented Class Library

RussianStemmer.Stem Method

Finds the stem for given Russian word. Creation date: (16/03/2002 3:36:48 PM)

Overload List

Finds the stem for given Russian word. Creation date: (16/03/2002 3:36:48 PM)

public virtual string Stem(string);

Static method for stemming with different charsets

public static string Stem(string,char[]);

See Also

RussianStemmer Class | Lucene.Net.Analysis.RU Namespace


RussianStemmer.Stem Method (String)

Finds the stem for given Russian word. Creation date: (16/03/2002 3:36:48 PM)

public virtual string Stem(
string input
);

Parameters

input
java.lang.String

Return Value

java.lang.String

See Also

RussianStemmer Class | Lucene.Net.Analysis.RU Namespace | RussianStemmer.Stem Overload List


RussianStemmer.Stem Method (String, Char[])

Static method for stemming with different charsets

public static string Stem(
string theWord,
char[] charset
);

See Also

RussianStemmer Class | Lucene.Net.Analysis.RU Namespace | RussianStemmer.Stem Overload List


Lucene.Net.Analysis.Standard

An NDoc Documented Class Library

Lucene.Net.Analysis.Standard Namespace

Namespace hierarchy

Classes

Class | Description
FastCharStream |
ParseException | This exception is thrown when parse errors are encountered. You can explicitly create objects of this exception type by calling the method generateParseException in the generated parser. You can modify this class to customize your error reporting mechanisms so long as you retain the public fields.
StandardAnalyzer | Filters {@link StandardTokenizer} with {@link StandardFilter}, {@link LowerCaseFilter} and {@link StopFilter}.
StandardFilter | Normalizes tokens extracted with {@link StandardTokenizer}.
StandardTokenizer |
StandardTokenizerConstants |
StandardTokenizerTokenManager |
Token | Describes the input token stream.
TokenMgrError |

Interfaces

Interface | Description
CharStream |


CharStream Interface

For a list of all members of this type, see CharStream Members.

public interface CharStream

Types that implement CharStream

Type | Description
FastCharStream |

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CharStream Members | Lucene.Net.Analysis.Standard Namespace


CharStream Members

CharStream overview

Public Instance Methods

Backup | Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.
BeginToken | Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.
Done | The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.
GetBeginColumn | Returns the column number of the first character for current token (being matched after the last call to BeginTOken).
GetBeginLine | Returns the line number of the first character for current token (being matched after the last call to BeginTOken).
GetColumn | Returns the column position of the character last read.
GetEndColumn | Returns the column number of the last character for current token (being matched after the last call to BeginTOken).
GetEndLine | Returns the line number of the last character for current token (being matched after the last call to BeginTOken).
GetImage | Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.
GetLine | Returns the line number of the character last read.
GetSuffix | Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }
ReadChar | Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace


CharStream Methods

The methods of the CharStream interface are listed below. For a complete list of CharStream interface members, see the CharStream Members topic.

Public Instance Methods

Backup | Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.
BeginToken | Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.
Done | The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.
GetBeginColumn | Returns the column number of the first character for current token (being matched after the last call to BeginTOken).
GetBeginLine | Returns the line number of the first character for current token (being matched after the last call to BeginTOken).
GetColumn | Returns the column position of the character last read.
GetEndColumn | Returns the column number of the last character for current token (being matched after the last call to BeginTOken).
GetEndLine | Returns the line number of the last character for current token (being matched after the last call to BeginTOken).
GetImage | Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.
GetLine | Returns the line number of the character last read.
GetSuffix | Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }
ReadChar | Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace


CharStream.Backup Method

Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.

void Backup(
int amount
);

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace


CharStream.BeginToken Method

Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.

char BeginToken();

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace


CharStream.Done Method

The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.

void Done();

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace


CharStream.GetBeginColumn Method

Returns the column number of the first character for current token (being matched after the last call to BeginTOken).

int GetBeginColumn();

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace


CharStream.GetBeginLine Method

Returns the line number of the first character for current token (being matched after the last call to BeginTOken).

int GetBeginLine();

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace


CharStream.GetColumn Method

Returns the column position of the character last read.

int GetColumn();

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace | #getEndColumn


CharStream.GetEndColumn Method

Returns the column number of the last character for current token (being matched after the last call to BeginTOken).

int GetEndColumn();

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace


CharStream.GetEndLine Method

Returns the line number of the last character for current token (being matched after the last call to BeginTOken).

int GetEndLine();

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace


CharStream.GetImage Method

Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.

string GetImage();

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace


CharStream.GetLine Method

Returns the line number of the character last read.

int GetLine();

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace | #getEndLine


CharStream.GetSuffix Method

Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }

char[] GetSuffix(
int len
);

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace


CharStream.ReadChar Method

Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

char ReadChar();

See Also

CharStream Interface | Lucene.Net.Analysis.Standard Namespace


FastCharStream Class

For a list of all members of this type, see FastCharStream Members.

System.Object
Lucene.Net.Analysis.Standard.FastCharStream

public sealed class FastCharStream : CharStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FastCharStream Members | Lucene.Net.Analysis.Standard Namespace


FastCharStream Members

FastCharStream overview

Public Instance Constructors

FastCharStream Constructor Constructs from a Reader.

Public Instance Methods

Backup |
BeginToken |
Done |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBeginColumn |
GetBeginLine |
GetColumn |
GetEndColumn |
GetEndLine |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetImage |
GetLine |
GetSuffix |
GetType (inherited from Object) | Gets the Type of the current instance.
ReadChar |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream Constructor

Constructs from a Reader.

public FastCharStream(
TextReader r
);

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream Methods

The methods of the FastCharStream class are listed below. For a complete list of FastCharStream class members, see the FastCharStream Members topic.

Public Instance Methods

Backup |
BeginToken |
Done |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBeginColumn |
GetBeginLine |
GetColumn |
GetEndColumn |
GetEndLine |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetImage |
GetLine |
GetSuffix |
GetType (inherited from Object) | Gets the Type of the current instance.
ReadChar |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream.Backup Method

public void Backup(
int amount
);

Implements

CharStream.Backup

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream.BeginToken Method

public char BeginToken();

Implements

CharStream.BeginToken

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream.Done Method

public void Done();

Implements

CharStream.Done

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream.GetBeginColumn Method

public int GetBeginColumn();

Implements

CharStream.GetBeginColumn

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream.GetBeginLine Method

public int GetBeginLine();

Implements

CharStream.GetBeginLine

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream.GetColumn Method

public int GetColumn();

Implements

CharStream.GetColumn

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream.GetEndColumn Method

public int GetEndColumn();

Implements

CharStream.GetEndColumn

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream.GetEndLine Method

public int GetEndLine();

Implements

CharStream.GetEndLine

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream.GetImage Method

public string GetImage();

Implements

CharStream.GetImage

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream.GetLine Method

public int GetLine();

Implements

CharStream.GetLine

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream.GetSuffix Method

public char[] GetSuffix(
int len
);

Implements

CharStream.GetSuffix

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


FastCharStream.ReadChar Method

public char ReadChar();

Implements

CharStream.ReadChar

See Also

FastCharStream Class | Lucene.Net.Analysis.Standard Namespace


ParseException Class

This exception is thrown when parse errors are encountered. You can explicitly create objects of this exception type by calling the method generateParseException in the generated parser. You can modify this class to customize your error reporting mechanisms so long as you retain the public fields.

For a list of all members of this type, see ParseException Members.

System.Object
System.Exception
System.SystemException
System.IO.IOException
Lucene.Net.Analysis.Standard.ParseException

public class ParseException : IOException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ParseException Members | Lucene.Net.Analysis.Standard Namespace


ParseException Members

ParseException overview

Public Instance Constructors

ParseException Overloaded. Initializes a new instance of the ParseException class.

Public Instance Fields

currentToken | This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.
expectedTokenSequences | Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.
tokenImage | This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

eol | The end of line string for this machine.
specialConstructor | This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).

Protected Internal Instance Methods

Add_escapes Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace


ParseException Constructor

This constructor is used by the method "generateParseException" in the generated parser. Calling this constructor generates a new object of this type with the fields "currentToken", "expectedTokenSequences", and "tokenImage" set. The boolean flag "specialConstructor" is also set to true to indicate that this constructor was used to create this object. This constructor calls its super class with the empty string to force the "toString" method of parent class "Throwable" to print the error message in the form: ParseException: <result of getMessage>

Overload List

The following constructors are for use by you for whatever purpose you can think of. Constructing the exception in this manner makes the exception behave in the normal way - i.e., as documented in the class "Throwable". The fields "errorToken", "expectedTokenSequences", and "tokenImage" do not contain relevant information. The JavaCC generated code does not use these constructors.

public ParseException();

This constructor is used by the method "generateParseException" in the generated parser. Calling this constructor generates a new object of this type with the fields "currentToken", "expectedTokenSequences", and "tokenImage" set. The boolean flag "specialConstructor" is also set to true to indicate that this constructor was used to create this object. This constructor calls its super class with the empty string to force the "toString" method of parent class "Throwable" to print the error message in the form: ParseException: <result of getMessage>

public ParseException(Token,int[][],string[]);

public ParseException(string);

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace


ParseException Constructor (Token, Int32[][], String[])

This constructor is used by the method "generateParseException" in the generated parser. Calling this constructor generates a new object of this type with the fields "currentToken", "expectedTokenSequences", and "tokenImage" set. The boolean flag "specialConstructor" is also set to true to indicate that this constructor was used to create this object. This constructor calls its super class with the empty string to force the "toString" method of parent class "Throwable" to print the error message in the form: ParseException: <result of getMessage>

public ParseException(
Token currentTokenVal,
int[][] expectedTokenSequencesVal,
string[] tokenImageVal
);

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace | ParseException Constructor Overload List


ParseException Constructor ()

The following constructors are for use by you for whatever purpose you can think of. Constructing the exception in this manner makes the exception behave in the normal way - i.e., as documented in the class "Throwable". The fields "errorToken", "expectedTokenSequences", and "tokenImage" do not contain relevant information. The JavaCC generated code does not use these constructors.

public ParseException();

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace | ParseException Constructor Overload List


ParseException Constructor (String)

public ParseException(
string message
);

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace | ParseException Constructor Overload List


ParseException Fields

The fields of the ParseException class are listed below. For a complete list of ParseException class members, see the ParseException Members topic.

Public Instance Fields

currentToken | This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.
expectedTokenSequences | Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.
tokenImage | This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

Protected Internal Instance Fields

eol | The end of line string for this machine.
specialConstructor | This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace


ParseException.currentToken Field

This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.

public Token currentToken;

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace


ParseException.eol Field

The end of line string for this machine.

protected internal string eol;

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace


ParseException.expectedTokenSequences Field

Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.

public int[][] expectedTokenSequences;

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace


ParseException.specialConstructor Field

This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).

protected internal bool specialConstructor;

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace


ParseException.tokenImage Field

This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

public string[] tokenImage;

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace


ParseException Properties

The properties of the ParseException class are listed below. For a complete list of ParseException class members, see the ParseException Members topic.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace


Message Property

An NDoc Documented Class Library

ParseException.Message Property

This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed.

public override string Message {get;}

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace


ParseException Methods

The methods of the ParseException class are listed below. For a complete list of ParseException class members, see the ParseException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Add_escapes Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace


ParseException.Add_escapes Method

Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.

protected internal virtual string Add_escapes(
string str
);

See Also

ParseException Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Class

Filters {@link StandardTokenizer} with {@link StandardFilter}, {@link LowerCaseFilter} and {@link StopFilter}.

For a list of all members of this type, see StandardAnalyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.Standard.StandardAnalyzer

public class StandardAnalyzer : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StandardAnalyzer Members | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Members

StandardAnalyzer overview

Public Static Fields

STOP_WORDS An array containing some common English words that are usually not useful for searching.

Public Instance Constructors

StandardAnalyzer Overloaded. Initializes a new instance of the StandardAnalyzer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded. Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor

Builds an analyzer.

Overload List

Builds an analyzer.

public StandardAnalyzer();

Builds an analyzer with the given stop words.

public StandardAnalyzer(string[]);

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor ()

Builds an analyzer.

public StandardAnalyzer();

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer Constructor Overload List


StandardAnalyzer Constructor (String[])

Builds an analyzer with the given stop words.

public StandardAnalyzer(
string[] stopWords
);

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer Constructor Overload List


StandardAnalyzer Fields

The fields of the StandardAnalyzer class are listed below. For a complete list of StandardAnalyzer class members, see the StandardAnalyzer Members topic.

Public Static Fields

STOP_WORDS An array containing some common English words that are usually not useful for searching.

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer.STOP_WORDS Field

An array containing some common English words that are usually not useful for searching.

public static readonly string[] STOP_WORDS;

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Methods

The methods of the StandardAnalyzer class are listed below. For a complete list of StandardAnalyzer class members, see the StandardAnalyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream (inherited from Analyzer) | Overloaded. Creates a TokenStream which tokenizes all the text in the provided Reader. Provided for backward compatibility only.
TokenStream | Overloaded. Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


TokenStream Method

An NDoc Documented Class Library

StandardAnalyzer.TokenStream Method

Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.

Overload List

Inherited from Analyzer.

public virtual TokenStream TokenStream(TextReader);

Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.

public override TokenStream TokenStream(string,TextReader);

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer.TokenStream Method (String, TextReader)

Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer.TokenStream Overload List


StandardFilter Class

Normalizes tokens extracted with {@link StandardTokenizer}.

For a list of all members of this type, see StandardFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.Standard.StandardFilter

public sealed class StandardFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StandardFilter Members | Lucene.Net.Analysis.Standard Namespace


StandardFilter Members

StandardFilter overview

Public Instance Constructors

StandardFilter Constructor Construct filtering in.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

StandardFilter Class | Lucene.Net.Analysis.Standard Namespace


StandardFilter Constructor

Construct filtering in.

public StandardFilter(
TokenStream in_Renamed
);

See Also

StandardFilter Class | Lucene.Net.Analysis.Standard Namespace


StandardFilter Methods

The methods of the StandardFilter class are listed below. For a complete list of StandardFilter class members, see the StandardFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StandardFilter Class | Lucene.Net.Analysis.Standard Namespace


StandardFilter.Next Method

public override Token Next();

See Also

StandardFilter Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Class

For a list of all members of this type, see StandardTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.Standard.StandardTokenizer

public class StandardTokenizer : Tokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StandardTokenizer Members | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Members

StandardTokenizer overview

Public Instance Constructors

StandardTokenizer Overloaded. Initializes a new instance of the StandardTokenizer class.

Public Instance Fields

jj_nt
token
token_source

Public Instance Methods

Close | By default, closes the input Reader.
Disable_tracing |
Enable_tracing |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateParseException |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextToken |
GetToken |
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
ReInit | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Constructor

Constructs a tokenizer for this Reader.

Overload List

public StandardTokenizer(CharStream);

public StandardTokenizer(StandardTokenizerTokenManager);

Constructs a tokenizer for this Reader.

public StandardTokenizer(TextReader);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Constructor (TextReader)

Constructs a tokenizer for this Reader.

public StandardTokenizer(
TextReader reader
);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizer Constructor Overload List


StandardTokenizer Constructor (CharStream)

public StandardTokenizer(
CharStream stream
);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizer Constructor Overload List


StandardTokenizer Constructor (StandardTokenizerTokenManager)

public StandardTokenizer(
StandardTokenizerTokenManager tm
);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizer Constructor Overload List


StandardTokenizer Fields

The fields of the StandardTokenizer class are listed below. For a complete list of StandardTokenizer class members, see the StandardTokenizer Members topic.

Public Instance Fields

jj_nt
token
token_source

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.jj_nt Field

public Token jj_nt;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.token Field

public Token token;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.token_source Field

public StandardTokenizerTokenManager token_source;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Methods

The methods of the StandardTokenizer class are listed below. For a complete list of StandardTokenizer class members, see the StandardTokenizer Members topic.

Public Instance Methods

Close | By default, closes the input Reader.
Disable_tracing |
Enable_tracing |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateParseException |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextToken |
GetToken |
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
ReInit | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.Close Method

By default, closes the input Reader.

public override void Close();

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.Disable_tracing Method

public void Disable_tracing();

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.Enable_tracing Method

public void Enable_tracing();

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.GenerateParseException Method

public virtual ParseException GenerateParseException();

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.GetNextToken Method

public Token GetNextToken();

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.GetToken Method

public Token GetToken(
int index
);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.Next Method

public override Token Next();

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


ReInit Method

An NDoc Documented Class Library

StandardTokenizer.ReInit Method

Overload List

public virtual void ReInit(CharStream);

public virtual void ReInit(StandardTokenizerTokenManager);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.ReInit Method (CharStream)

public virtual void ReInit(
CharStream stream
);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizer.ReInit Overload List


StandardTokenizer.ReInit Method (StandardTokenizerTokenManager)

public virtual void ReInit(
StandardTokenizerTokenManager tm
);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizer.ReInit Overload List


StandardTokenizerConstants Class

For a list of all members of this type, see StandardTokenizerConstants Members.

System.Object
Lucene.Net.Analysis.Standard.StandardTokenizerConstants
Lucene.Net.Analysis.Standard.StandardTokenizerTokenManager

public class StandardTokenizerConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StandardTokenizerConstants Members | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants Members

StandardTokenizerConstants overview

Public Static Fields

ACRONYM
ALPHA
ALPHANUM
APOSTROPHE
CJK
COMPANY
DEFAULT
DIGIT
EMAIL
EOF
HAS_DIGIT
HOST
LETTER
NOISE
NUM
P
tokenImage

Public Instance Constructors

StandardTokenizerConstants Constructor Initializes a new instance of the StandardTokenizerConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants Constructor

Initializes a new instance of the StandardTokenizerConstants class.

public StandardTokenizerConstants();

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants Fields

The fields of the StandardTokenizerConstants class are listed below. For a complete list of StandardTokenizerConstants class members, see the StandardTokenizerConstants Members topic.

Public Static Fields

ACRONYM
ALPHA
ALPHANUM
APOSTROPHE
CJK
COMPANY
DEFAULT
DIGIT
EMAIL
EOF
HAS_DIGIT
HOST
LETTER
NOISE
NUM
P
tokenImage

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.ACRONYM Field

public const int ACRONYM = 3;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.ALPHA Field

public const int ALPHA = 10;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.ALPHANUM Field

public const int ALPHANUM = 1;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.APOSTROPHE Field

public const int APOSTROPHE = 2;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.CJK Field

public const int CJK = 12;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.COMPANY Field

public const int COMPANY = 4;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.DEFAULT Field

public const int DEFAULT = 0;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.DIGIT Field

public const int DIGIT = 13;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.EMAIL Field

public const int EMAIL = 5;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.EOF Field

public const int EOF = 0;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.HAS_DIGIT Field

public const int HAS_DIGIT = 9;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.HOST Field

public const int HOST = 6;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.LETTER Field

public const int LETTER = 11;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.NOISE Field

public const int NOISE = 14;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.NUM Field

public const int NUM = 7;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.P Field

public const int P = 8;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerConstants.tokenImage Field

public static string[] tokenImage;

See Also

StandardTokenizerConstants Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager Class

For a list of all members of this type, see StandardTokenizerTokenManager Members.

System.Object
Lucene.Net.Analysis.Standard.StandardTokenizerConstants
Lucene.Net.Analysis.Standard.StandardTokenizerTokenManager

public class StandardTokenizerTokenManager : StandardTokenizerConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StandardTokenizerTokenManager Members | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager Members

StandardTokenizerTokenManager overview

Public Static Fields

jjstrLiteralImages
lexStateNames

Public Instance Constructors

StandardTokenizerTokenManager Overloaded. Initializes a new instance of the StandardTokenizerTokenManager class.

Public Instance Fields

debugStream

Public Instance Methods

Close | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextToken |
GetType (inherited from Object) | Gets the Type of the current instance.
ReInit | Overloaded.
SetDebugStream |
SwitchTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

curChar
input_stream

Protected Internal Instance Methods

JjFillToken

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager Constructor

Overload List

public StandardTokenizerTokenManager(CharStream);

public StandardTokenizerTokenManager(CharStream,int);

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager Constructor (CharStream)

public StandardTokenizerTokenManager(
CharStream stream
);

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizerTokenManager Constructor Overload List


StandardTokenizerTokenManager Constructor (CharStream, Int32)

public StandardTokenizerTokenManager(
CharStream stream,
int lexState
);

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizerTokenManager Constructor Overload List


StandardTokenizerTokenManager Fields

The fields of the StandardTokenizerTokenManager class are listed below. For a complete list of StandardTokenizerTokenManager class members, see the StandardTokenizerTokenManager Members topic.

Public Static Fields

jjstrLiteralImages
lexStateNames

Public Instance Fields

debugStream

Protected Internal Instance Fields

curChar
input_stream

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager.curChar Field

protected internal char curChar;

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager.debugStream Field

public StreamWriter debugStream;

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager.input_stream Field

protected internal CharStream input_stream;

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager.jjstrLiteralImages Field

public static readonly string[] jjstrLiteralImages;

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager.lexStateNames Field

public static readonly string[] lexStateNames;

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager Methods

The methods of the StandardTokenizerTokenManager class are listed below. For a complete list of StandardTokenizerTokenManager class members, see the StandardTokenizerTokenManager Members topic.

Public Instance Methods

Close | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextToken |
GetType (inherited from Object) | Gets the Type of the current instance.
ReInit | Overloaded.
SetDebugStream |
SwitchTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

JjFillToken

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager.Close Method

By default, closes the input Reader.

public void Close();

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager.GetNextToken Method

public virtual Token GetNextToken();

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager.JjFillToken Method

protected internal virtual Token JjFillToken();

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


ReInit Method

An NDoc Documented Class Library

StandardTokenizerTokenManager.ReInit Method

Overload List

public virtual void ReInit(CharStream);

public virtual void ReInit(CharStream,int);

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager.ReInit Method (CharStream)

public virtual void ReInit(
CharStream stream
);

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizerTokenManager.ReInit Overload List


StandardTokenizerTokenManager.ReInit Method (CharStream, Int32)

public virtual void ReInit(
CharStream stream,
int lexState
);

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizerTokenManager.ReInit Overload List


StandardTokenizerTokenManager.SetDebugStream Method

public virtual void SetDebugStream(
StreamWriter ds
);

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizerTokenManager.SwitchTo Method

public virtual void SwitchTo(
int lexState
);

See Also

StandardTokenizerTokenManager Class | Lucene.Net.Analysis.Standard Namespace


Token Class

Describes the input token stream.

For a list of all members of this type, see Token Members.

System.Object
Lucene.Net.Analysis.Standard.Token

public class Token

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Token Members | Lucene.Net.Analysis.Standard Namespace


Token Members

Token overview

Public Static Methods

NewToken Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simlpy add something like : case MyParserConstants.ID : return new IDToken(); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use it in your lexical actions.

Public Instance Constructors

Token Constructor Initializes a new instance of the Token class.

Public Instance Fields

beginColumn | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
beginLine | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
endColumn | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
endLine | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
image | The string image of the token.
kind | An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.
next | A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this Field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this Field.
specialToken | This Field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this Field is set to null. When there are more than one such special token, this Field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken Field, and so on until the first special token (whose specialToken Field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this Field is null.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the image.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token Constructor

Initializes a new instance of the Token class.

public Token();

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token Fields

The fields of the Token class are listed below. For a complete list of Token class members, see the Token Members topic.

Public Instance Fields

beginColumn | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
beginLine | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
endColumn | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
endLine | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
image | The string image of the token.
kind | An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.
next | A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this Field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this Field.
specialToken | This Field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this Field is set to null. When there are more than one such special token, this Field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken Field, and so on until the first special token (whose specialToken Field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this Field is null.

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token.beginColumn Field

beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.

public int beginColumn;

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token.beginLine Field

beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.

public int beginLine;

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token.endColumn Field

beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.

public int endColumn;

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token.endLine Field

beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.

public int endLine;

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token.image Field

The string image of the token.

public string image;

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token.kind Field

An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.

public int kind;

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token.next Field

A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this Field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this Field.

public Token next;

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token.specialToken Field

This Field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this Field is set to null. When there are more than one such special token, this Field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken Field, and so on until the first special token (whose specialToken Field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this Field is null.

public Token specialToken;

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token Methods

The methods of the Token class are listed below. For a complete list of Token class members, see the Token Members topic.

Public Static Methods

NewToken Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simlpy add something like : case MyParserConstants.ID : return new IDToken(); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use it in your lexical actions.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the image.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token.NewToken Method

Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simlpy add something like : case MyParserConstants.ID : return new IDToken(); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use it in your lexical actions.

public static Token NewToken(
int ofKind
);

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


Token.ToString Method

Returns the image.

public override string ToString();

See Also

Token Class | Lucene.Net.Analysis.Standard Namespace


TokenMgrError Class

For a list of all members of this type, see TokenMgrError Members.

System.Object
System.Exception
System.ApplicationException
Lucene.Net.Analysis.Standard.TokenMgrError

public class TokenMgrError : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TokenMgrError Members | Lucene.Net.Analysis.Standard Namespace


TokenMgrError Members

TokenMgrError overview

Protected Internal Static Methods

addEscapes | Replaces unprintable characters by their espaced (or unicode escaped) equivalents in the given string
LexicalError | Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexicl error curLexState : lexical state in which this error occured errorLine : line number when the error occured errorColumn : column number when the error occured errorAfter : prefix that was seen before this error occured curchar : the offending character Note: You can customize the lexical error message by modifying this method.

Public Instance Constructors

TokenMgrError Overloaded. Initializes a new instance of the TokenMgrError class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TokenMgrError Class | Lucene.Net.Analysis.Standard Namespace


TokenMgrError Constructor

Initializes a new instance of the TokenMgrError class.

Overload List

Initializes a new instance of the TokenMgrError class.

public TokenMgrError();

public TokenMgrError(bool,int,int,int,string,char,int);

public TokenMgrError(string,int);

See Also

TokenMgrError Class | Lucene.Net.Analysis.Standard Namespace


TokenMgrError Constructor ()

Initializes a new instance of the TokenMgrError class.

public TokenMgrError();

See Also

TokenMgrError Class | Lucene.Net.Analysis.Standard Namespace | TokenMgrError Constructor Overload List


TokenMgrError Constructor (String, Int32)

public TokenMgrError(
string message,
int reason
);

See Also

TokenMgrError Class | Lucene.Net.Analysis.Standard Namespace | TokenMgrError Constructor Overload List


TokenMgrError Constructor (Boolean, Int32, Int32, Int32, String, Char, Int32)

public TokenMgrError(
bool EOFSeen,
int lexState,
int errorLine,
int errorColumn,
string errorAfter,
char curChar,
int reason
);

See Also

TokenMgrError Class | Lucene.Net.Analysis.Standard Namespace | TokenMgrError Constructor Overload List


TokenMgrError Properties

The properties of the TokenMgrError class are listed below. For a complete list of TokenMgrError class members, see the TokenMgrError Members topic.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

TokenMgrError Class | Lucene.Net.Analysis.Standard Namespace


Message Property

An NDoc Documented Class Library

TokenMgrError.Message Property

You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser.

public override string Message {get;}

See Also

TokenMgrError Class | Lucene.Net.Analysis.Standard Namespace


TokenMgrError Methods

The methods of the TokenMgrError class are listed below. For a complete list of TokenMgrError class members, see the TokenMgrError Members topic.

Protected Internal Static Methods

addEscapes | Replaces unprintable characters by their espaced (or unicode escaped) equivalents in the given string
LexicalError | Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexicl error curLexState : lexical state in which this error occured errorLine : line number when the error occured errorColumn : column number when the error occured errorAfter : prefix that was seen before this error occured curchar : the offending character Note: You can customize the lexical error message by modifying this method.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TokenMgrError Class | Lucene.Net.Analysis.Standard Namespace


TokenMgrError.addEscapes Method

Replaces unprintable characters by their espaced (or unicode escaped) equivalents in the given string

protected internal static string addEscapes(
string str
);

See Also

TokenMgrError Class | Lucene.Net.Analysis.Standard Namespace


TokenMgrError.LexicalError Method

Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexicl error curLexState : lexical state in which this error occured errorLine : line number when the error occured errorColumn : column number when the error occured errorAfter : prefix that was seen before this error occured curchar : the offending character Note: You can customize the lexical error message by modifying this method.

protected internal static string LexicalError(
bool EOFSeen,
int lexState,
int errorLine,
int errorColumn,
string errorAfter,
char curChar
);

See Also

TokenMgrError Class | Lucene.Net.Analysis.Standard Namespace


Lucene.Net.Documents

An NDoc Documented Class Library

Lucene.Net.Documents Namespace

Namespace hierarchy

Classes

Class | Description
DateField |
Document |
Field | A Field is a section of a Document. Each Field has two parts, a name and a value. Values may be free text, provided as a String or as a Reader, or they may be atomic keywords, which are not further processed. Such keywords may be used to represent dates, urls, etc. Fields are optionally stored in the index, so that they may be returned with hits on the document.


DateField Class

For a list of all members of this type, see DateField Members.

System.Object
Lucene.Net.Documents.DateField

public class DateField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DateField Members | Lucene.Net.Documents Namespace


DateField Members

DateField overview

Public Static Methods

DateToString | Converts a Date to a string suitable for indexing.
MAX_DATE_STRING |
MIN_DATE_STRING |
StringToDate | Converts a string-encoded date into a Date object.
StringToTime | Converts a string-encoded date into a millisecond time.
TimeToString | Converts a millisecond time to a string suitable for indexing.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField Methods

The methods of the DateField class are listed below. For a complete list of DateField class members, see the DateField Members topic.

Public Static Methods

DateToString | Converts a Date to a string suitable for indexing.
MAX_DATE_STRING |
MIN_DATE_STRING |
StringToDate | Converts a string-encoded date into a Date object.
StringToTime | Converts a string-encoded date into a millisecond time.
TimeToString | Converts a millisecond time to a string suitable for indexing.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField.DateToString Method

Converts a Date to a string suitable for indexing.

public static string DateToString(
DateTime date
);

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField.MAX_DATE_STRING Method

public static string MAX_DATE_STRING();

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField.MIN_DATE_STRING Method

public static string MIN_DATE_STRING();

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField.StringToDate Method

Converts a string-encoded date into a Date object.

public static DateTime StringToDate(
string s
);

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField.StringToTime Method

Converts a string-encoded date into a millisecond time.

public static long StringToTime(
string s
);

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField.TimeToString Method

Converts a millisecond time to a string suitable for indexing.

public static string TimeToString(
long time
);

See Also

DateField Class | Lucene.Net.Documents Namespace


Document Class

For a list of all members of this type, see Document Members.

System.Object
Lucene.Net.Documents.Document

public sealed class Document

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Document Members | Lucene.Net.Documents Namespace


Document Members

Document overview

Public Instance Constructors

Document Constructor Constructs a new document with no fields.

Public Instance Fields

fields

Public Instance Methods

Add | Adds a Field to a document. Several fields may be added with the same name. In this case, if the fields are indexed, their text is treated as though appended for the purposes of search. Note that add like the removeField(s) methods only makes sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Fields | Returns an Enumeration of all the fields in a document.
Get | Returns the string value of the Field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added.
GetBoost
GetField | Returns a Field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added.
GetFields Returns an array of {@link Field}s with the given name. This method can return
null
.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues Returns an array of values of the Field specified as the method parameter. This method can return
null
.
RemoveField | Removes Field with the specified name from the document. If multiple fields exist with this name, this method removes the first Field that has been added. If there is no Field with the specified name, the document remains unchanged. Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
RemoveFields | Removes all fields with the given name from the document. If there is no Field with the specified name, the document remains unchanged. Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
SetBoost
ToString | Prints the fields of a document for human consumption.

See Also

Document Class | Lucene.Net.Documents Namespace


Document Constructor

Constructs a new document with no fields.

public Document();

See Also

Document Class | Lucene.Net.Documents Namespace


Document Fields

The fields of the Document class are listed below. For a complete list of Document class members, see the Document Members topic.

Public Instance Fields

fields

See Also

Document Class | Lucene.Net.Documents Namespace


Document.Fields Method

Returns an Enumeration of all the fields in a document.

public IEnumerable Fields();

See Also

Document Class | Lucene.Net.Documents Namespace


Document Methods

The methods of the Document class are listed below. For a complete list of Document class members, see the Document Members topic.

Public Instance Methods

Add | Adds a Field to a document. Several fields may be added with the same name. In this case, if the fields are indexed, their text is treated as though appended for the purposes of search. Note that add like the removeField(s) methods only makes sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Fields | Returns an Enumeration of all the fields in a document.
Get | Returns the string value of the Field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added.
GetBoost
GetField | Returns a Field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added.
GetFields Returns an array of {@link Field}s with the given name. This method can return
null
.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues Returns an array of values of the Field specified as the method parameter. This method can return
null
.
RemoveField | Removes Field with the specified name from the document. If multiple fields exist with this name, this method removes the first Field that has been added. If there is no Field with the specified name, the document remains unchanged. Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
RemoveFields | Removes all fields with the given name from the document. If there is no Field with the specified name, the document remains unchanged. Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
SetBoost
ToString | Prints the fields of a document for human consumption.

See Also

Document Class | Lucene.Net.Documents Namespace


Document.Add Method

Adds a Field to a document. Several fields may be added with the same name. In this case, if the fields are indexed, their text is treated as though appended for the purposes of search.

Note that add like the removeField(s) methods only makes sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

public void Add(
Field field
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.Get Method

Returns the string value of the Field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added.

public string Get(
string name
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.GetBoost Method

public float GetBoost();

See Also

Document Class | Lucene.Net.Documents Namespace


Document.GetField Method

Returns a Field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added.

public Field GetField(
string name
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.GetFields Method

Returns an array of {@link Field}s with the given name. This method can return

null
.

public Field[] GetFields(
string name
);

Parameters

name
the name of the Field

Return Value

a

Field[]
array

See Also

Document Class | Lucene.Net.Documents Namespace


Document.GetValues Method

Returns an array of values of the Field specified as the method parameter. This method can return

null
.

public string[] GetValues(
string name
);

Parameters

name
the name of the Field

Return Value

a

String[]
of Field values

See Also

Document Class | Lucene.Net.Documents Namespace


Document.RemoveField Method

Removes Field with the specified name from the document. If multiple fields exist with this name, this method removes the first Field that has been added. If there is no Field with the specified name, the document remains unchanged.

Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

public void RemoveField(
string name
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.RemoveFields Method

Removes all fields with the given name from the document. If there is no Field with the specified name, the document remains unchanged.

Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

public void RemoveFields(
string name
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.SetBoost Method

public void SetBoost(
float boost
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.ToString Method

Prints the fields of a document for human consumption.

public override string ToString();

See Also

Document Class | Lucene.Net.Documents Namespace


Field Class

A Field is a section of a Document. Each Field has two parts, a name and a value. Values may be free text, provided as a String or as a Reader, or they may be atomic keywords, which are not further processed. Such keywords may be used to represent dates, urls, etc. Fields are optionally stored in the index, so that they may be returned with hits on the document.

For a list of all members of this type, see Field Members.

System.Object
Lucene.Net.Documents.Field

public sealed class Field

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Field Members | Lucene.Net.Documents Namespace


Field Members

Field overview

Public Static Methods

Keyword | Overloaded. Constructs a String-valued Field that is not tokenized, but is indexed and stored. Useful for non-text fields, e.g. date or url.
Text | Overloaded. Constructs a String-valued Field that is tokenized and indexed, and is stored in the index, for return with hits. Useful for short text fields, like "title" or "subject". Term vector will not be stored for this Field.
UnIndexed | Constructs a String-valued Field that is not tokenized nor indexed, but is stored in the index, for return with hits.
UnStored | Overloaded. Constructs a String-valued Field that is tokenized and indexed, but that is not stored in the index. Term vector will not be stored for this Field.

Public Instance Constructors

Field Overloaded. Initializes a new instance of the Field class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIndexed | True iff the value of the Field is to be indexed, so that it may be searched on.
IsStored | True iff the value of the Field is to be stored in the index for return with search hits. It is an error for this to be true if a Field is Reader-valued.
IsTermVectorStored True iff the term or terms used to index this Field are stored as a term vector, available from {@link IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the Field, only to terms used to index it. If the original content must be preserved, use the
stored
attribute instead.
IsTokenized | True iff the value of the Field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Name | The name of the Field (e.g., "date", "subject", "title", or "body") as an interned string.
ReaderValue | The value of the Field as a Reader, or null. If null, the String value is used. Exactly one of stringValue() and readerValue() must be set.
SetBoost
StringValue | The value of the Field as a String, or null. If null, the Reader value is used. Exactly one of stringValue() and readerValue() must be set.
ToString | Prints a Field for human consumption.

See Also

Field Class | Lucene.Net.Documents Namespace


Field Constructor

Create a Field by specifying all parameters except for

storeTermVector
, which is set to
false
.

Overload List

Create a Field by specifying all parameters except for

storeTermVector
, which is set to
false
.

public Field(string,string,bool,bool,bool);

public Field(string,string,bool,bool,bool,bool);

See Also

Field Class | Lucene.Net.Documents Namespace


Field Constructor (String, String, Boolean, Boolean, Boolean)

Create a Field by specifying all parameters except for

storeTermVector
, which is set to
false
.

public Field(
string name,
string string_Renamed,
bool store,
bool index,
bool token
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field Constructor Overload List


Field Constructor (String, String, Boolean, Boolean, Boolean, Boolean)

public Field(
string name,
string string_Renamed,
bool store,
bool index,
bool token,
bool storeTermVector
);

Parameters

name
The name of the Field
string_Renamed
store
true if the Field should store the string
index
true if the Field should be indexed
token
true if the Field should be tokenized
storeTermVector
true if we should store the Term Vector info

See Also

Field Class | Lucene.Net.Documents Namespace | Field Constructor Overload List


Field Methods

The methods of the Field class are listed below. For a complete list of Field class members, see the Field Members topic.

Public Static Methods

Keyword | Overloaded. Constructs a String-valued Field that is not tokenized, but is indexed and stored. Useful for non-text fields, e.g. date or url.
Text | Overloaded. Constructs a String-valued Field that is tokenized and indexed, and is stored in the index, for return with hits. Useful for short text fields, like "title" or "subject". Term vector will not be stored for this Field.
UnIndexed | Constructs a String-valued Field that is not tokenized nor indexed, but is stored in the index, for return with hits.
UnStored | Overloaded. Constructs a String-valued Field that is tokenized and indexed, but that is not stored in the index. Term vector will not be stored for this Field.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIndexed | True iff the value of the Field is to be indexed, so that it may be searched on.
IsStored | True iff the value of the Field is to be stored in the index for return with search hits. It is an error for this to be true if a Field is Reader-valued.
IsTermVectorStored True iff the term or terms used to index this Field are stored as a term vector, available from {@link IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the Field, only to terms used to index it. If the original content must be preserved, use the
stored
attribute instead.
IsTokenized | True iff the value of the Field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Name | The name of the Field (e.g., "date", "subject", "title", or "body") as an interned string.
ReaderValue | The value of the Field as a Reader, or null. If null, the String value is used. Exactly one of stringValue() and readerValue() must be set.
SetBoost
StringValue | The value of the Field as a String, or null. If null, the Reader value is used. Exactly one of stringValue() and readerValue() must be set.
ToString | Prints a Field for human consumption.

See Also

Field Class | Lucene.Net.Documents Namespace


Field.GetBoost Method

public float GetBoost();

See Also

Field Class | Lucene.Net.Documents Namespace


Field.IsIndexed Method

True iff the value of the Field is to be indexed, so that it may be searched on.

public bool IsIndexed();

See Also

Field Class | Lucene.Net.Documents Namespace


Field.IsStored Method

True iff the value of the Field is to be stored in the index for return with search hits. It is an error for this to be true if a Field is Reader-valued.

public bool IsStored();

See Also

Field Class | Lucene.Net.Documents Namespace


Field.IsTermVectorStored Method

True iff the term or terms used to index this Field are stored as a term vector, available from {@link IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the Field, only to terms used to index it. If the original content must be preserved, use the

stored
attribute instead.

public bool IsTermVectorStored();

See Also

Field Class | Lucene.Net.Documents Namespace | String)


Field.IsTokenized Method

True iff the value of the Field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.

public bool IsTokenized();

See Also

Field Class | Lucene.Net.Documents Namespace


Keyword Method

An NDoc Documented Class Library

Field.Keyword Method

Constructs a Date-valued Field that is not tokenized and is indexed, and stored in the index, for return with hits.

Overload List

Constructs a Date-valued Field that is not tokenized and is indexed, and stored in the index, for return with hits.

public static Field Keyword(string,DateTime);

Constructs a String-valued Field that is not tokenized, but is indexed and stored. Useful for non-text fields, e.g. date or url.

public static Field Keyword(string,string);

See Also

Field Class | Lucene.Net.Documents Namespace


Field.Keyword Method (String, DateTime)

Constructs a Date-valued Field that is not tokenized and is indexed, and stored in the index, for return with hits.

public static Field Keyword(
string name,
DateTime value_Renamed
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.Keyword Overload List


Field.Keyword Method (String, String)

Constructs a String-valued Field that is not tokenized, but is indexed and stored. Useful for non-text fields, e.g. date or url.

public static Field Keyword(
string name,
string value_Renamed
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.Keyword Overload List


Field.Name Method

The name of the Field (e.g., "date", "subject", "title", or "body") as an interned string.

public string Name();

See Also

Field Class | Lucene.Net.Documents Namespace


Field.ReaderValue Method

The value of the Field as a Reader, or null. If null, the String value is used. Exactly one of stringValue() and readerValue() must be set.

public TextReader ReaderValue();

See Also

Field Class | Lucene.Net.Documents Namespace


Field.SetBoost Method

public void SetBoost(
float boost
);

See Also

Field Class | Lucene.Net.Documents Namespace


Field.StringValue Method

The value of the Field as a String, or null. If null, the Reader value is used. Exactly one of stringValue() and readerValue() must be set.

public string StringValue();

See Also

Field Class | Lucene.Net.Documents Namespace


Text Method

An NDoc Documented Class Library

Field.Text Method

Constructs a Reader-valued Field that is tokenized and indexed, but is not stored in the index verbatim. Useful for longer text fields, like "body". Term vector will not be stored for this Field.

Overload List

Constructs a Reader-valued Field that is tokenized and indexed, but is not stored in the index verbatim. Useful for longer text fields, like "body". Term vector will not be stored for this Field.

public static Field Text(string,TextReader);

Constructs a Reader-valued Field that is tokenized and indexed, but is not stored in the index verbatim. Useful for longer text fields, like "body".

public static Field Text(string,TextReader,bool);

Constructs a String-valued Field that is tokenized and indexed, and is stored in the index, for return with hits. Useful for short text fields, like "title" or "subject". Term vector will not be stored for this Field.

public static Field Text(string,string);

Constructs a String-valued Field that is tokenized and indexed, and is stored in the index, for return with hits. Useful for short text fields, like "title" or "subject".

public static Field Text(string,string,bool);

See Also

Field Class | Lucene.Net.Documents Namespace


Field.Text Method (String, TextReader)

Constructs a Reader-valued Field that is tokenized and indexed, but is not stored in the index verbatim. Useful for longer text fields, like "body". Term vector will not be stored for this Field.

public static Field Text(
string name,
TextReader value_Renamed
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.Text Overload List


Field.Text Method (String, TextReader, Boolean)

Constructs a Reader-valued Field that is tokenized and indexed, but is not stored in the index verbatim. Useful for longer text fields, like "body".

public static Field Text(
string name,
TextReader value_Renamed,
bool storeTermVector
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.Text Overload List


Field.Text Method (String, String)

Constructs a String-valued Field that is tokenized and indexed, and is stored in the index, for return with hits. Useful for short text fields, like "title" or "subject". Term vector will not be stored for this Field.

public static Field Text(
string name,
string value_Renamed
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.Text Overload List


Field.Text Method (String, String, Boolean)

Constructs a String-valued Field that is tokenized and indexed, and is stored in the index, for return with hits. Useful for short text fields, like "title" or "subject".

public static Field Text(
string name,
string value_Renamed,
bool storeTermVector
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.Text Overload List


Field.ToString Method

Prints a Field for human consumption.

public override string ToString();

See Also

Field Class | Lucene.Net.Documents Namespace


Field.UnIndexed Method

Constructs a String-valued Field that is not tokenized nor indexed, but is stored in the index, for return with hits.

public static Field UnIndexed(
string name,
string value_Renamed
);

See Also

Field Class | Lucene.Net.Documents Namespace


UnStored Method

An NDoc Documented Class Library

Field.UnStored Method

Constructs a String-valued Field that is tokenized and indexed, but that is not stored in the index. Term vector will not be stored for this Field.

Overload List

Constructs a String-valued Field that is tokenized and indexed, but that is not stored in the index. Term vector will not be stored for this Field.

public static Field UnStored(string,string);

Constructs a String-valued Field that is tokenized and indexed, but that is not stored in the index.

public static Field UnStored(string,string,bool);

See Also

Field Class | Lucene.Net.Documents Namespace


Field.UnStored Method (String, String)

Constructs a String-valued Field that is tokenized and indexed, but that is not stored in the index. Term vector will not be stored for this Field.

public static Field UnStored(
string name,
string value_Renamed
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.UnStored Overload List


Field.UnStored Method (String, String, Boolean)

Constructs a String-valued Field that is tokenized and indexed, but that is not stored in the index.

public static Field UnStored(
string name,
string value_Renamed,
bool storeTermVector
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.UnStored Overload List


Lucene.Net.Index

An NDoc Documented Class Library

Lucene.Net.Index Namespace

Namespace hierarchy

Classes

Class | Description
CompoundFileReader | Class for accessing a compound stream. This class implements a directory, but is limited to only read operations. Directory methods that would normally modify data throw an exception.
CompoundFileReader.CSInputStream | Implementation of an InputStream that reads from a portion of the compound file. The visibility is left as "package" *only* because this helps with testing since JUnit test cases in a different class can then access package fields of this class.
CompoundFileWriter
DocumentWriter
FieldInfo
FieldInfos | Access to the Field Info file that describes document fields and whether or not they are indexed. Each segment has a separate Field Info file. Objects of this class are thread-safe for multiple readers, but only one thread can be adding documents at a time, with no other reader or writer threads accessing this object.
FieldsReader | Class responsible for access to stored document fields. It uses <segment>.fdt and <segment>.fdx; files.
FilterIndexReader A
FilterIndexReader
contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class
FilterIndexReader
itself simply implements all abstract methods of
IndexReader
with versions that pass all requests to the contained index reader. Subclasses of
FilterIndexReader
may further override some of these methods and may also provide additional methods and fields.
FilterIndexReader.FilterTermDocs | Base class for filtering {@link TermDocs} implementations.
FilterIndexReader.FilterTermEnum | Base class for filtering {@link TermEnum} implementations.
FilterIndexReader.FilterTermPositions | Base class for filtering {@link TermPositions} implementations.
IndexReader
IndexWriter | An IndexWriter creates and maintains an index. The third argument to the constructor determines whether a new index is created, or whether an existing index is opened for the addition of new documents. In either case, documents are added with the addDocument method. When finished adding documents, close should be called. If an index will not have more documents added for a while and optimal search performance is desired, then the optimize method should be called before the index is closed.
MultipleTermPositions Describe class
MultipleTermPositions
here.
MultiReader | An IndexReader which reads multiple indexes, appending their content.
SegmentInfo
SegmentInfos
SegmentMerger
SegmentReader FIXME: Describe class
SegmentReader
here.
SegmentTermDocs
SegmentTermEnum
Term | A Term represents a word from text. This is the unit of search. It is composed of two elements, the text of the word, as a string, and the name of the Field that the text occured in, an interned string. Note that terms may represent more than words from text fields, but also things like dates, email addresses, urls, etc.
TermEnum
TermInfo | A TermInfo is the record of information stored for a term.
TermInfosReader
TermInfosWriter
TermVectorsReader | TODO: relax synchro!
TermVectorsWriter | Writer works by opening a document and then opening the fields within the document and then writing out the vectors for each Field. Rough usage: for each document { writer.openDocument(); for each Field on the document { writer.openField(Field); for all of the terms { writer.addTerm(...) } writer.closeField } writer.closeDocument() }

Interfaces

Interface | Description
TermDocs
TermFreqVector | Provides access to stored term vector of a document Field.
TermPositions
TermPositionVector Extends
TermFreqVector
to provide additional information about positions in which each of the terms is found.


CompoundFileReader Class

Class for accessing a compound stream. This class implements a directory, but is limited to only read operations. Directory methods that would normally modify data throw an exception.

For a list of all members of this type, see CompoundFileReader Members.

System.Object
Lucene.Net.Store.Directory
Lucene.Net.Index.CompoundFileReader

public class CompoundFileReader : Directory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CompoundFileReader Members | Lucene.Net.Index Namespace


CompoundFileReader Members

CompoundFileReader overview

Public Instance Constructors

CompoundFileReader Constructor

Public Instance Methods

Close |
CreateFile | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff a file with the given name exists.
FileLength | Returns the length of a file in the directory.
FileModified | Returns the time the named file was last modified.
GetDirectory |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetName |
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory.
MakeLock | Construct a {@link Lock}.
OpenFile |
RenameFile | Renames an existing file in the directory. If a file already exists with the new name, then it is replaced. This replacement should be atomic.
ToString (inherited from Object) | Returns a String that represents the current Object.
TouchFile | Set the modified time of an existing file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader Constructor

public CompoundFileReader(
Directory dir,
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader Methods

The methods of the CompoundFileReader class are listed below. For a complete list of CompoundFileReader class members, see the CompoundFileReader Members topic.

Public Instance Methods

Close |
CreateFile | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff a file with the given name exists.
FileLength | Returns the length of a file in the directory.
FileModified | Returns the time the named file was last modified.
GetDirectory |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetName |
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory.
MakeLock | Construct a {@link Lock}.
OpenFile |
RenameFile | Renames an existing file in the directory. If a file already exists with the new name, then it is replaced. This replacement should be atomic.
ToString (inherited from Object) | Returns a String that represents the current Object.
TouchFile | Set the modified time of an existing file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.Close Method

public override void Close();

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.CreateFile Method

Creates a new, empty file in the directory with the given name. Returns a stream writing this file.

public override OutputStream CreateFile(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.DeleteFile Method

Removes an existing file in the directory.

public override void DeleteFile(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.FileExists Method

Returns true iff a file with the given name exists.

public override bool FileExists(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.FileLength Method

Returns the length of a file in the directory.

public override long FileLength(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.FileModified Method

Returns the time the named file was last modified.

public override long FileModified(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.GetDirectory Method

public virtual Directory GetDirectory();

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.GetName Method

public virtual string GetName();

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.List Method

Returns an array of strings, one for each file in the directory.

public override string[] List();

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.MakeLock Method

Construct a {@link Lock}.

public override Lock MakeLock(
string name
);

Parameters

name
the name of the lock file

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.OpenFile Method

public override InputStream OpenFile(
string id
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.RenameFile Method

Renames an existing file in the directory. If a file already exists with the new name, then it is replaced. This replacement should be atomic.

public override void RenameFile(
string from,
string to
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.TouchFile Method

Set the modified time of an existing file to now.

public override void TouchFile(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.CSInputStream Class

Implementation of an InputStream that reads from a portion of the compound file. The visibility is left as "package" *only* because this helps with testing since JUnit test cases in a different class can then access package fields of this class.

For a list of all members of this type, see CompoundFileReader.CSInputStream Members.

System.Object
Lucene.Net.Store.InputStream
Lucene.Net.Index.CompoundFileReader.CSInputStream

public sealed class CompoundFileReader.CSInputStream : InputStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CompoundFileReader.CSInputStream Members | Lucene.Net.Index Namespace


CompoundFileReader.CSInputStream Members

CompoundFileReader.CSInputStream overview

Public Instance Fields

base_Renamed

Public Instance Methods

Clone (inherited from InputStream) |
Close | Closes the stream to futher operations.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilePointer (inherited from InputStream) | Returns the current position in this file, where the next read will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length (inherited from InputStream) | The number of bytes in the file.
ReadByte (inherited from InputStream) | Reads and returns a single byte.
ReadBytes (inherited from InputStream) | Reads a specified number of bytes into an array at the specified offset.
ReadChars (inherited from InputStream) | Reads UTF-8 encoded characters into an array.
ReadInt (inherited from InputStream) | Reads four bytes and returns an int.
ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input.
ReadLong (inherited from InputStream) | Reads eight bytes and returns a long.
ReadString (inherited from InputStream) | Reads a string.
ReadVInt (inherited from InputStream) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from InputStream) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek (inherited from InputStream) | Sets current position in this file, where the next read will occur.
SeekInternal | Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

length (inherited from InputStream)

See Also

CompoundFileReader.CSInputStream Class | Lucene.Net.Index Namespace


CompoundFileReader.CSInputStream Fields

The fields of the CompoundFileReader.CSInputStream class are listed below. For a complete list of CompoundFileReader.CSInputStream class members, see the CompoundFileReader.CSInputStream Members topic.

Public Instance Fields

base_Renamed

Protected Internal Instance Fields

length (inherited from InputStream)

See Also

CompoundFileReader.CSInputStream Class | Lucene.Net.Index Namespace


CompoundFileReader.CSInputStream.base_Renamed Field

public InputStream base_Renamed;

See Also

CompoundFileReader.CSInputStream Class | Lucene.Net.Index Namespace


CompoundFileReader.CSInputStream Methods

The methods of the CompoundFileReader.CSInputStream class are listed below. For a complete list of CompoundFileReader.CSInputStream class members, see the CompoundFileReader.CSInputStream Members topic.

Public Instance Methods

Clone (inherited from InputStream) |
Close | Closes the stream to futher operations.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilePointer (inherited from InputStream) | Returns the current position in this file, where the next read will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length (inherited from InputStream) | The number of bytes in the file.
ReadByte (inherited from InputStream) | Reads and returns a single byte.
ReadBytes (inherited from InputStream) | Reads a specified number of bytes into an array at the specified offset.
ReadChars (inherited from InputStream) | Reads UTF-8 encoded characters into an array.
ReadInt (inherited from InputStream) | Reads four bytes and returns an int.
ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input.
ReadLong (inherited from InputStream) | Reads eight bytes and returns a long.
ReadString (inherited from InputStream) | Reads a string.
ReadVInt (inherited from InputStream) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from InputStream) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek (inherited from InputStream) | Sets current position in this file, where the next read will occur.
SeekInternal | Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CompoundFileReader.CSInputStream Class | Lucene.Net.Index Namespace


CompoundFileReader.CSInputStream.Close Method

Closes the stream to futher operations.

public override void Close();

See Also

CompoundFileReader.CSInputStream Class | Lucene.Net.Index Namespace


CompoundFileReader.CSInputStream.ReadInternal Method

Expert: implements buffer refill. Reads bytes from the current position in the input.

public override void ReadInternal(
byte[] b,
int offset,
int len
);

Parameters

b
the array to read bytes into
offset
the offset in the array to start storing bytes
len

See Also

CompoundFileReader.CSInputStream Class | Lucene.Net.Index Namespace


CompoundFileReader.CSInputStream.SeekInternal Method

Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.

public override void SeekInternal(
long pos
);

See Also

CompoundFileReader.CSInputStream Class | Lucene.Net.Index Namespace | #ReadInternal


CompoundFileWriter Class

For a list of all members of this type, see CompoundFileWriter Members.

System.Object
Lucene.Net.Index.CompoundFileWriter

public sealed class CompoundFileWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CompoundFileWriter Members | Lucene.Net.Index Namespace


CompoundFileWriter Members

CompoundFileWriter overview

Public Instance Constructors

CompoundFileWriter Constructor Create the compound stream in the specified file. The file name is the entire name (no extensions are added).

Public Instance Methods

AddFile | Add a source stream. If sourceDir is null, it is set to the same value as the directory where this compound stream exists. The id is the string by which the sub-stream will be know in the compound stream. The caller must ensure that the ID is unique. If the id is null, it is set to the name of the source file.
Close | Merge files with the extensions added up to now. All files with these extensions are combined sequentially into the compound stream. After successful merge, the source files are deleted.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDirectory | Returns the directory of the compound file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetName | Returns the name of the compound file.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


CompoundFileWriter Constructor

Create the compound stream in the specified file. The file name is the entire name (no extensions are added).

public CompoundFileWriter(
Directory dir,
string name
);

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


CompoundFileWriter Methods

The methods of the CompoundFileWriter class are listed below. For a complete list of CompoundFileWriter class members, see the CompoundFileWriter Members topic.

Public Instance Methods

AddFile | Add a source stream. If sourceDir is null, it is set to the same value as the directory where this compound stream exists. The id is the string by which the sub-stream will be know in the compound stream. The caller must ensure that the ID is unique. If the id is null, it is set to the name of the source file.
Close | Merge files with the extensions added up to now. All files with these extensions are combined sequentially into the compound stream. After successful merge, the source files are deleted.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDirectory | Returns the directory of the compound file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetName | Returns the name of the compound file.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


CompoundFileWriter.AddFile Method

Add a source stream. If sourceDir is null, it is set to the same value as the directory where this compound stream exists. The id is the string by which the sub-stream will be know in the compound stream. The caller must ensure that the ID is unique. If the id is null, it is set to the name of the source file.

public void AddFile(
string file
);

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


CompoundFileWriter.Close Method

Merge files with the extensions added up to now. All files with these extensions are combined sequentially into the compound stream. After successful merge, the source files are deleted.

public void Close();

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


CompoundFileWriter.GetDirectory Method

Returns the directory of the compound file.

public Directory GetDirectory();

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


CompoundFileWriter.GetName Method

Returns the name of the compound file.

public string GetName();

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


DocumentWriter Class

For a list of all members of this type, see DocumentWriter Members.

System.Object
Lucene.Net.Index.DocumentWriter

public sealed class DocumentWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DocumentWriter Members | Lucene.Net.Index Namespace


DocumentWriter Members

DocumentWriter overview

Public Instance Constructors

DocumentWriter Constructor

Public Instance Methods

AddDocument |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DocumentWriter Class | Lucene.Net.Index Namespace


DocumentWriter Constructor

public DocumentWriter(
Directory directory,
Analyzer analyzer,
Similarity similarity,
int maxFieldLength
);

Parameters

directory
The directory to write the document information to
analyzer
The analyzer to use for the document
similarity
The Similarity function
maxFieldLength
The maximum number of tokens a Field may have

See Also

DocumentWriter Class | Lucene.Net.Index Namespace


DocumentWriter Methods

The methods of the DocumentWriter class are listed below. For a complete list of DocumentWriter class members, see the DocumentWriter Members topic.

Public Instance Methods

AddDocument |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DocumentWriter Class | Lucene.Net.Index Namespace


DocumentWriter.AddDocument Method

public void AddDocument(
string segment,
Document doc
);

See Also

DocumentWriter Class | Lucene.Net.Index Namespace


FieldInfo Class

For a list of all members of this type, see FieldInfo Members.

System.Object
Lucene.Net.Index.FieldInfo

public sealed class FieldInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldInfo Members | Lucene.Net.Index Namespace


FieldInfo Members

FieldInfo overview

Public Instance Fields

storeTermVector

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfo Fields

The fields of the FieldInfo class are listed below. For a complete list of FieldInfo class members, see the FieldInfo Members topic.

Public Instance Fields

storeTermVector

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfo.storeTermVector Field

public bool storeTermVector;

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfos Class

Access to the Field Info file that describes document fields and whether or not they are indexed. Each segment has a separate Field Info file. Objects of this class are thread-safe for multiple readers, but only one thread can be adding documents at a time, with no other reader or writer threads accessing this object.

For a list of all members of this type, see FieldInfos Members.

System.Object
Lucene.Net.Index.FieldInfos

public sealed class FieldInfos

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldInfos Members | Lucene.Net.Index Namespace


FieldInfos Members

FieldInfos overview

Public Instance Constructors

FieldInfos Overloaded. Initializes a new instance of the FieldInfos class.

Public Instance Methods

Add | Overloaded. Adds Field info for a Document.
AddIndexed |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FieldInfo | Overloaded.
FieldName |
FieldNumber |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVectors |
Size |
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded.

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos Constructor

Initializes a new instance of the FieldInfos class.

Overload List

Initializes a new instance of the FieldInfos class.

public FieldInfos();

Construct a FieldInfos object using the directory and the name of the file InputStream

public FieldInfos(Directory,string);

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos Constructor ()

Initializes a new instance of the FieldInfos class.

public FieldInfos();

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos Constructor Overload List


FieldInfos Constructor (Directory, String)

Construct a FieldInfos object using the directory and the name of the file InputStream

public FieldInfos(
Directory d,
string name
);

Parameters

d
The directory to open the InputStream from
name
The name of the file to open the InputStream from in the Directory

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos Constructor Overload List | #read


FieldInfos Methods

The methods of the FieldInfos class are listed below. For a complete list of FieldInfos class members, see the FieldInfos Members topic.

Public Instance Methods

Add | Overloaded. Adds Field info for a Document.
AddIndexed |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FieldInfo | Overloaded.
FieldName |
FieldNumber |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVectors |
Size |
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded.

See Also

FieldInfos Class | Lucene.Net.Index Namespace


Add Method

An NDoc Documented Class Library

FieldInfos.Add Method

Adds Field info for a Document.

Overload List

Adds Field info for a Document.

public void Add(Document);

Assumes the Field is not storing term vectors

public void Add(ICollection,bool);

Calls three parameter add with false for the storeTermVector parameter

public void Add(string,bool);

If the Field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this Field. If not - marks it as being indexed. Same goes for storeTermVector

public void Add(string,bool,bool);

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.Add Method (Document)

Adds Field info for a Document.

public void Add(
Document doc
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Add Overload List


FieldInfos.Add Method (ICollection, Boolean)

Assumes the Field is not storing term vectors

public void Add(
ICollection names,
bool isIndexed
);

Parameters

names
The names of the fields
isIndexed
Whether the fields are indexed or not

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Add Overload List | boolean)


FieldInfos.Add Method (String, Boolean)

Calls three parameter add with false for the storeTermVector parameter

public void Add(
string name,
bool isIndexed
);

Parameters

name
The name of the Field
isIndexed
true if the Field is indexed

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Add Overload List | boolean, boolean)


FieldInfos.Add Method (String, Boolean, Boolean)

If the Field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this Field. If not - marks it as being indexed. Same goes for storeTermVector

public void Add(
string name,
bool isIndexed,
bool storeTermVector
);

Parameters

name
The name of the Field
isIndexed
true if the Field is indexed
storeTermVector
true if the term vector should be stored

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Add Overload List


FieldInfos.AddIndexed Method

public void AddIndexed(
ICollection names,
bool storeTermVectors
);

Parameters

names
The names of the fields
storeTermVectors
Whether the fields store term vectors or not

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfo Method

An NDoc Documented Class Library

FieldInfos.FieldInfo Method

Overload List

public FieldInfo FieldInfo(int);

public FieldInfo FieldInfo(string);

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.FieldInfo Method (Int32)

public FieldInfo FieldInfo(
int fieldNumber
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.FieldInfo Overload List


FieldInfos.FieldInfo Method (String)

public FieldInfo FieldInfo(
string fieldName
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.FieldInfo Overload List


FieldInfos.FieldName Method

public string FieldName(
int fieldNumber
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.FieldNumber Method

public int FieldNumber(
string fieldName
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.HasVectors Method

public bool HasVectors();

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.Size Method

public int Size();

See Also

FieldInfos Class | Lucene.Net.Index Namespace


Write Method

An NDoc Documented Class Library

FieldInfos.Write Method

Overload List

public void Write(Directory,string);

public void Write(OutputStream);

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.Write Method (Directory, String)

public void Write(
Directory d,
string name
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Write Overload List


FieldInfos.Write Method (OutputStream)

public void Write(
OutputStream output
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Write Overload List


FieldsReader Class

Class responsible for access to stored document fields. It uses <segment>.fdt and <segment>.fdx; files.

For a list of all members of this type, see FieldsReader Members.

System.Object
Lucene.Net.Index.FieldsReader

public sealed class FieldsReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldsReader Members | Lucene.Net.Index Namespace


FieldsReader Members

FieldsReader overview

Public Instance Constructors

FieldsReader Constructor

Public Instance Methods

Close |
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Size |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FieldsReader Class | Lucene.Net.Index Namespace


FieldsReader Constructor

public FieldsReader(
Directory d,
string segment,
FieldInfos fn
);

See Also

FieldsReader Class | Lucene.Net.Index Namespace


FieldsReader Methods

The methods of the FieldsReader class are listed below. For a complete list of FieldsReader class members, see the FieldsReader Members topic.

Public Instance Methods

Close |
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Size |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FieldsReader Class | Lucene.Net.Index Namespace


FieldsReader.Close Method

public void Close();

See Also

FieldsReader Class | Lucene.Net.Index Namespace


FieldsReader.Doc Method

public Document Doc(
int n
);

See Also

FieldsReader Class | Lucene.Net.Index Namespace


FieldsReader.Size Method

public int Size();

See Also

FieldsReader Class | Lucene.Net.Index Namespace


FilterIndexReader Class

A

FilterIndexReader
contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class
FilterIndexReader
itself simply implements all abstract methods of
IndexReader
with versions that pass all requests to the contained index reader. Subclasses of
FilterIndexReader
may further override some of these methods and may also provide additional methods and fields.

For a list of all members of this type, see FilterIndexReader Members.

System.Object
Lucene.Net.Index.IndexReader
Lucene.Net.Index.FilterIndexReader

public class FilterIndexReader : IndexReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilterIndexReader Members | Lucene.Net.Index Namespace


FilterIndexReader Members

FilterIndexReader overview

Public Instance Constructors

FilterIndexReader Constructor

Construct a FilterIndexReader based on the specified base reader. Directory locking for delete, undeleteAll, and setNorm operations is left to the base reader.

Note that base reader is closed if this FilterIndexReader is closed.

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Delete (inherited from IndexReader) Overloaded. Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its Field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
Directory (inherited from IndexReader) | Returns the directory this index resides in.
DocFreq
Document
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFieldNames | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIndexedFieldNames
GetTermFreqVector
GetTermFreqVectors
GetType (inherited from Object) | Gets the Type of the current instance.
HasDeletions
IsDeleted
MaxDoc
Norms | Overloaded.
NumDocs
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named Field of the named document.
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from IndexReader) | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

in_Renamed

Protected Internal Instance Methods

Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations
DoClose |
DoCommit |
DoDelete |
DoSetNorm |
DoUndeleteAll |

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader Constructor

Construct a FilterIndexReader based on the specified base reader. Directory locking for delete, undeleteAll, and setNorm operations is left to the base reader.

Note that base reader is closed if this FilterIndexReader is closed.

public FilterIndexReader(
IndexReader in_Renamed
);

Parameters

in_Renamed

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader Fields

The fields of the FilterIndexReader class are listed below. For a complete list of FilterIndexReader class members, see the FilterIndexReader Members topic.

Protected Internal Instance Fields

in_Renamed

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.in_Renamed Field

protected internal IndexReader in_Renamed;

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader Methods

The methods of the FilterIndexReader class are listed below. For a complete list of FilterIndexReader class members, see the FilterIndexReader Members topic.

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Delete (inherited from IndexReader) Overloaded. Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its Field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
Directory (inherited from IndexReader) | Returns the directory this index resides in.
DocFreq
Document
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFieldNames | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIndexedFieldNames
GetTermFreqVector
GetTermFreqVectors
GetType (inherited from Object) | Gets the Type of the current instance.
HasDeletions
IsDeleted
MaxDoc
Norms | Overloaded.
NumDocs
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named Field of the named document.
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from IndexReader) | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations
DoClose |
DoCommit |
DoDelete |
DoSetNorm |
DoUndeleteAll |

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.DocFreq Method

public override int DocFreq(
Term t
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.DoClose Method

protected internal override void DoClose();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.DoCommit Method

protected internal override void DoCommit();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.Document Method

public override Document Document(
int n
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.DoDelete Method

protected internal override void DoDelete(
int n
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.DoSetNorm Method

protected internal override void DoSetNorm(
int d,
string f,
byte b
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.DoUndeleteAll Method

protected internal override void DoUndeleteAll();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


GetFieldNames Method

An NDoc Documented Class Library

FilterIndexReader.GetFieldNames Method

Overload List

public override ICollection GetFieldNames();

public override ICollection GetFieldNames(bool);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.GetFieldNames Method ()

public override ICollection GetFieldNames();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.GetFieldNames Overload List


FilterIndexReader.GetFieldNames Method (Boolean)

public override ICollection GetFieldNames(
bool indexed
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.GetFieldNames Overload List


FilterIndexReader.GetIndexedFieldNames Method

public override ICollection GetIndexedFieldNames(
bool storedTermVector
);

Parameters

storedTermVector
if true, returns only Indexed fields that have term vector info, else only indexed fields without term vector info

Return Value

Collection of Strings indicating the names of the fields

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.GetTermFreqVector Method

public override TermFreqVector GetTermFreqVector(
int docNumber,
string field
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.GetTermFreqVectors Method

public override TermFreqVector[] GetTermFreqVectors(
int docNumber
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.HasDeletions Method

public override bool HasDeletions();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.IsDeleted Method

public override bool IsDeleted(
int n
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.MaxDoc Method

public override int MaxDoc();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


Norms Method

An NDoc Documented Class Library

FilterIndexReader.Norms Method

Overload List

public override byte[] Norms(string);

public override void Norms(string,byte[],int);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.Norms Method (String)

public override byte[] Norms(
string f
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.Norms Overload List


FilterIndexReader.Norms Method (String, Byte[], Int32)

public override void Norms(
string f,
byte[] bytes,
int offset
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.Norms Overload List


FilterIndexReader.NumDocs Method

public override int NumDocs();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


TermDocs Method

An NDoc Documented Class Library

FilterIndexReader.TermDocs Method

Overload List

public override TermDocs TermDocs();

Inherited from IndexReader.

public virtual TermDocs TermDocs(Term);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.TermDocs Method ()

public override TermDocs TermDocs();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.TermDocs Overload List


TermPositions Method

An NDoc Documented Class Library

FilterIndexReader.TermPositions Method

Overload List

public override TermPositions TermPositions();

Inherited from IndexReader.

public virtual TermPositions TermPositions(Term);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.TermPositions Method ()

public override TermPositions TermPositions();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.TermPositions Overload List


Terms Method

An NDoc Documented Class Library

FilterIndexReader.Terms Method

Overload List

public override TermEnum Terms();

public override TermEnum Terms(Term);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.Terms Method ()

public override TermEnum Terms();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.Terms Overload List


FilterIndexReader.Terms Method (Term)

public override TermEnum Terms(
Term t
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.Terms Overload List


FilterIndexReader.FilterTermDocs Class

Base class for filtering {@link TermDocs} implementations.

For a list of all members of this type, see FilterIndexReader.FilterTermDocs Members.

System.Object
Lucene.Net.Index.FilterIndexReader.FilterTermDocs
Lucene.Net.Index.FilterIndexReader.FilterTermPositions

public class FilterIndexReader.FilterTermDocs : TermDocs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilterIndexReader.FilterTermDocs Members | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Members

FilterIndexReader.FilterTermDocs overview

Public Instance Constructors

FilterIndexReader.FilterTermDocs Constructor

Public Instance Methods

Close |
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Read |
Seek | Overloaded.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

in_Renamed

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Constructor

public FilterIndexReader.FilterTermDocs(
TermDocs in_Renamed
);

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Fields

The fields of the FilterIndexReader.FilterTermDocs class are listed below. For a complete list of FilterIndexReader.FilterTermDocs class members, see the FilterIndexReader.FilterTermDocs Members topic.

Protected Internal Instance Fields

in_Renamed

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.in_Renamed Field

protected internal TermDocs in_Renamed;

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Methods

The methods of the FilterIndexReader.FilterTermDocs class are listed below. For a complete list of FilterIndexReader.FilterTermDocs class members, see the FilterIndexReader.FilterTermDocs Members topic.

Public Instance Methods

Close |
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Read |
Seek | Overloaded.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.Close Method

public virtual void Close();

Implements

TermDocs.Close

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.Doc Method

public virtual int Doc();

Implements

TermDocs.Doc

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.Freq Method

public virtual int Freq();

Implements

TermDocs.Freq

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.Next Method

public virtual bool Next();

Implements

TermDocs.Next

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.Read Method

public virtual int Read(
int[] docs,
int[] freqs
);

Implements

TermDocs.Read

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


Seek Method

An NDoc Documented Class Library

FilterIndexReader.FilterTermDocs.Seek Method

Overload List

public virtual void Seek(Term);

public virtual void Seek(TermEnum);

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.Seek Method (Term)

public virtual void Seek(
Term term
);

Implements

TermDocs.Seek

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace | FilterIndexReader.FilterTermDocs.Seek Overload List


FilterIndexReader.FilterTermDocs.Seek Method (TermEnum)

public virtual void Seek(
TermEnum termEnum
);

Implements

TermDocs.Seek

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace | FilterIndexReader.FilterTermDocs.Seek Overload List


FilterIndexReader.FilterTermDocs.SkipTo Method

public virtual bool SkipTo(
int i
);

Implements

TermDocs.SkipTo

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Class

Base class for filtering {@link TermEnum} implementations.

For a list of all members of this type, see FilterIndexReader.FilterTermEnum Members.

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Index.FilterIndexReader.FilterTermEnum

public class FilterIndexReader.FilterTermEnum : TermEnum

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilterIndexReader.FilterTermEnum Members | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Members

FilterIndexReader.FilterTermEnum overview

Public Instance Constructors

FilterIndexReader.FilterTermEnum Constructor

Public Instance Methods

Close |
DocFreq |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
SkipTo (inherited from TermEnum) |
Term |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

in_Renamed

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Constructor

public FilterIndexReader.FilterTermEnum(
TermEnum in_Renamed
);

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Fields

The fields of the FilterIndexReader.FilterTermEnum class are listed below. For a complete list of FilterIndexReader.FilterTermEnum class members, see the FilterIndexReader.FilterTermEnum Members topic.

Protected Internal Instance Fields

in_Renamed

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum.in_Renamed Field

protected internal TermEnum in_Renamed;

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Methods

The methods of the FilterIndexReader.FilterTermEnum class are listed below. For a complete list of FilterIndexReader.FilterTermEnum class members, see the FilterIndexReader.FilterTermEnum Members topic.

Public Instance Methods

Close |
DocFreq |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
SkipTo (inherited from TermEnum) |
Term |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum.Close Method

public override void Close();

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum.DocFreq Method

public override int DocFreq();

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum.Next Method

public override bool Next();

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum.Term Method

public override Term Term();

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Class

Base class for filtering {@link TermPositions} implementations.

For a list of all members of this type, see FilterIndexReader.FilterTermPositions Members.

System.Object
Lucene.Net.Index.FilterIndexReader.FilterTermDocs
Lucene.Net.Index.FilterIndexReader.FilterTermPositions

public class FilterIndexReader.FilterTermPositions : FilterTermDocs, TermPositions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilterIndexReader.FilterTermPositions Members | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Members

FilterIndexReader.FilterTermPositions overview

Public Instance Constructors

FilterIndexReader.FilterTermPositions Constructor

Public Instance Methods

Close (inherited from FilterTermDocs) |
Doc (inherited from FilterTermDocs) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq (inherited from FilterTermDocs) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from FilterTermDocs) |
NextPosition |
Read (inherited from FilterTermDocs) |
Seek (inherited from FilterTermDocs) | Overloaded.
SkipTo (inherited from FilterTermDocs) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

in_Renamed (inherited from FilterTermDocs)

See Also

FilterIndexReader.FilterTermPositions Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Constructor

public FilterIndexReader.FilterTermPositions(
TermPositions in_Renamed
);

See Also

FilterIndexReader.FilterTermPositions Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Methods

The methods of the FilterIndexReader.FilterTermPositions class are listed below. For a complete list of FilterIndexReader.FilterTermPositions class members, see the FilterIndexReader.FilterTermPositions Members topic.

Public Instance Methods

Close (inherited from FilterTermDocs) |
Doc (inherited from FilterTermDocs) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq (inherited from FilterTermDocs) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from FilterTermDocs) |
NextPosition |
Read (inherited from FilterTermDocs) |
Seek (inherited from FilterTermDocs) | Overloaded.
SkipTo (inherited from FilterTermDocs) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterIndexReader.FilterTermPositions Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions.NextPosition Method

public virtual int NextPosition();

Implements

TermPositions.NextPosition

See Also

FilterIndexReader.FilterTermPositions Class | Lucene.Net.Index Namespace


IndexReader Class

For a list of all members of this type, see IndexReader Members.

System.Object
Lucene.Net.Index.IndexReader
Lucene.Net.Index.FilterIndexReader
Lucene.Net.Index.MultiReader
Lucene.Net.Index.SegmentReader

public abstract class IndexReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexReader Members | Lucene.Net.Index Namespace


IndexReader Members

IndexReader overview

Public Static Methods

GetCurrentVersion | Overloaded. Reads version number from segments files. The version number counts the number of changes of the index.
IndexExists Overloaded. Returns
true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
false
is returned.
IsLocked Overloaded. Returns
true
iff the index in the named directory is currently locked.
LastModified | Overloaded. Returns the time the index in the named directory was last modified. Synchronization of IndexReader and IndexWriter instances is no longer done via time stamps of the segments file since the time resolution depends on the hardware platform. Instead, a version number is maintained within the segments file, which is incremented everytime when the index is changed.
Open | Overloaded. Returns an IndexReader reading the index in an FSDirectory in the named path.
Unlock

Public Instance Methods

Close | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Delete Overloaded. Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its Field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
Directory | Returns the directory this index resides in.
DocFreq Returns the number of documents containing the term
t
.
Document Returns the stored fields of the
n
th
Document
in this index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFieldNames | Overloaded. Returns a list of all unique Field names that exist in the index pointed to by this IndexReader. The boolean argument specifies whether the fields returned are indexed or not.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIndexedFieldNames
GetTermFreqVector | Return a term frequency vector for the specified document and Field. The vector returned contains terms and frequencies for those terms in the specified Field of this document, if the Field had storeTermVector flag set. If the flag was not set, the method returns null.
GetTermFreqVectors | Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized Field in the document. Each vector contains terms and frequencies for all terms in a given vectorized Field. If no such fields existed, the method returns null.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDeletions | Returns true if any documents have been deleted
IsDeleted | Returns true if document n has been deleted
MaxDoc | Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.
Norms | Overloaded. Reads the byte-encoded normalization factor for the named Field of every document. This is used by the search code to score documents.
NumDocs | Returns the number of documents in this index.
SetNorm | Overloaded. Expert: Resets the normalization factor for the named Field of the named document.
TermDocs | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded. Returns an enumeration of all terms after a given term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

IndexReader Constructor Constructor used if IndexReader is not owner of its directory. This is used for IndexReaders that are used within other IndexReaders that take care or locking directories.

Protected Internal Instance Methods

Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations
DoClose | Implements close.
DoCommit | Implements commit.
DoDelete Implements deletion of the document numbered
docNum
. Applications should call {@link #Delete(int)} or {@link #Delete(Term)}.
DoSetNorm | Implements setNorm in subclass.
DoUndeleteAll | Implements actual undeleteAll() in subclass.

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader Constructor

Constructor used if IndexReader is not owner of its directory. This is used for IndexReaders that are used within other IndexReaders that take care or locking directories.

protected internal IndexReader(
Directory directory
);

Parameters

directory
Directory where IndexReader files reside.

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader Methods

The methods of the IndexReader class are listed below. For a complete list of IndexReader class members, see the IndexReader Members topic.

Public Static Methods

GetCurrentVersion | Overloaded. Reads version number from segments files. The version number counts the number of changes of the index.
IndexExists Overloaded. Returns
true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
false
is returned.
IsLocked Overloaded. Returns
true
iff the index in the named directory is currently locked.
LastModified | Overloaded. Returns the time the index in the named directory was last modified. Synchronization of IndexReader and IndexWriter instances is no longer done via time stamps of the segments file since the time resolution depends on the hardware platform. Instead, a version number is maintained within the segments file, which is incremented everytime when the index is changed.
Open | Overloaded. Returns an IndexReader reading the index in an FSDirectory in the named path.
Unlock

Public Instance Methods

Close | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Delete Overloaded. Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its Field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
Directory | Returns the directory this index resides in.
DocFreq Returns the number of documents containing the term
t
.
Document Returns the stored fields of the
n
th
Document
in this index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFieldNames | Overloaded. Returns a list of all unique Field names that exist in the index pointed to by this IndexReader. The boolean argument specifies whether the fields returned are indexed or not.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIndexedFieldNames
GetTermFreqVector | Return a term frequency vector for the specified document and Field. The vector returned contains terms and frequencies for those terms in the specified Field of this document, if the Field had storeTermVector flag set. If the flag was not set, the method returns null.
GetTermFreqVectors | Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized Field in the document. Each vector contains terms and frequencies for all terms in a given vectorized Field. If no such fields existed, the method returns null.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDeletions | Returns true if any documents have been deleted
IsDeleted | Returns true if document n has been deleted
MaxDoc | Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.
Norms | Overloaded. Reads the byte-encoded normalization factor for the named Field of every document. This is used by the search code to score documents.
NumDocs | Returns the number of documents in this index.
SetNorm | Overloaded. Expert: Resets the normalization factor for the named Field of the named document.
TermDocs | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded. Returns an enumeration of all terms after a given term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations
DoClose | Implements close.
DoCommit | Implements commit.
DoDelete Implements deletion of the document numbered
docNum
. Applications should call {@link #Delete(int)} or {@link #Delete(Term)}.
DoSetNorm | Implements setNorm in subclass.
DoUndeleteAll | Implements actual undeleteAll() in subclass.

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Close Method

Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.

public void Close();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Commit Method

Commit changes resulting from delete, undeleteAll, or setNorm operations

protected internal void Commit();

See Also

IndexReader Class | Lucene.Net.Index Namespace


Delete Method

An NDoc Documented Class Library

IndexReader.Delete Method

Deletes all documents containing

term
. This is useful if one uses a document Field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate Field and the unique ID string as its text and passes it to this method. Returns the number of documents deleted.

Overload List

Deletes all documents containing

term
. This is useful if one uses a document Field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate Field and the unique ID string as its text and passes it to this method. Returns the number of documents deleted.

public int Delete(Term);

Deletes the document numbered

docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its Field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.

public void Delete(int);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Delete Method (Term)

Deletes all documents containing

term
. This is useful if one uses a document Field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate Field and the unique ID string as its text and passes it to this method. Returns the number of documents deleted.

public int Delete(
Term term
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Delete Overload List


IndexReader.Delete Method (Int32)

Deletes the document numbered

docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its Field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.

public void Delete(
int docNum
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Delete Overload List


IndexReader.Directory Method

Returns the directory this index resides in.

public virtual Directory Directory();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DocFreq Method

Returns the number of documents containing the term

t
.

public abstract int DocFreq(
Term t
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DoClose Method

Implements close.

protected internal abstract void DoClose();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DoCommit Method

Implements commit.

protected internal abstract void DoCommit();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Document Method

Returns the stored fields of the

n
th
Document
in this index.

public abstract Document Document(
int n
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DoDelete Method

Implements deletion of the document numbered

docNum
. Applications should call {@link #Delete(int)} or {@link #Delete(Term)}.

protected internal abstract void DoDelete(
int docNum
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DoSetNorm Method

Implements setNorm in subclass.

protected internal abstract void DoSetNorm(
int doc,
string field,
byte value_Renamed
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DoUndeleteAll Method

Implements actual undeleteAll() in subclass.

protected internal abstract void DoUndeleteAll();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Finalize Method

Release the write lock, if needed.

protected override void Finalize();

See Also

IndexReader Class | Lucene.Net.Index Namespace


GetCurrentVersion Method

An NDoc Documented Class Library

IndexReader.GetCurrentVersion Method

Reads version number from segments files. The version number counts the number of changes of the index.

Overload List

Reads version number from segments files. The version number counts the number of changes of the index.

public static long GetCurrentVersion(Directory);

Reads version number from segments files. The version number counts the number of changes of the index.

public static long GetCurrentVersion(FileInfo);

Reads version number from segments files. The version number counts the number of changes of the index.

public static long GetCurrentVersion(string);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.GetCurrentVersion Method (Directory)

Reads version number from segments files. The version number counts the number of changes of the index.

public static long GetCurrentVersion(
Directory directory
);

Parameters

directory
where the index resides.

Return Value

version number.

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.GetCurrentVersion Overload List


IndexReader.GetCurrentVersion Method (FileInfo)

Reads version number from segments files. The version number counts the number of changes of the index.

public static long GetCurrentVersion(
FileInfo directory
);

Parameters

directory
where the index resides.

Return Value

version number.

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.GetCurrentVersion Overload List


IndexReader.GetCurrentVersion Method (String)

Reads version number from segments files. The version number counts the number of changes of the index.

public static long GetCurrentVersion(
string directory
);

Parameters

directory
where the index resides.

Return Value

version number.

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.GetCurrentVersion Overload List


GetFieldNames Method

An NDoc Documented Class Library

IndexReader.GetFieldNames Method

Returns a list of all unique Field names that exist in the index pointed to by this IndexReader.

Overload List

Returns a list of all unique Field names that exist in the index pointed to by this IndexReader.

public abstract ICollection GetFieldNames();

Returns a list of all unique Field names that exist in the index pointed to by this IndexReader. The boolean argument specifies whether the fields returned are indexed or not.

public abstract ICollection GetFieldNames(bool);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.GetFieldNames Method ()

Returns a list of all unique Field names that exist in the index pointed to by this IndexReader.

public abstract ICollection GetFieldNames();

Return Value

Collection of Strings indicating the names of the fields

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.GetFieldNames Overload List


IndexReader.GetFieldNames Method (Boolean)

Returns a list of all unique Field names that exist in the index pointed to by this IndexReader. The boolean argument specifies whether the fields returned are indexed or not.

public abstract ICollection GetFieldNames(
bool indexed
);

Parameters

indexed
true
if only indexed fields should be returned;
false
if only unindexed fields should be returned.

Return Value

Collection of Strings indicating the names of the fields

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.GetFieldNames Overload List


IndexReader.GetIndexedFieldNames Method

public abstract ICollection GetIndexedFieldNames(
bool storedTermVector
);

Parameters

storedTermVector
if true, returns only Indexed fields that have term vector info, else only indexed fields without term vector info

Return Value

Collection of Strings indicating the names of the fields

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.GetTermFreqVector Method

Return a term frequency vector for the specified document and Field. The vector returned contains terms and frequencies for those terms in the specified Field of this document, if the Field had storeTermVector flag set. If the flag was not set, the method returns null.

public abstract TermFreqVector GetTermFreqVector(
int docNumber,
string field
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | Field#IsTermVectorStored


IndexReader.GetTermFreqVectors Method

Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized Field in the document. Each vector contains terms and frequencies for all terms in a given vectorized Field. If no such fields existed, the method returns null.

public abstract TermFreqVector[] GetTermFreqVectors(
int docNumber
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | Field#IsTermVectorStored


IndexReader.HasDeletions Method

Returns true if any documents have been deleted

public abstract bool HasDeletions();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexExists Method

An NDoc Documented Class Library

IndexReader.IndexExists Method

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

Overload List

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

public static bool IndexExists(Directory);

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

public static bool IndexExists(FileInfo);

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
false
is returned.

public static bool IndexExists(string);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.IndexExists Method (Directory)

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

public static bool IndexExists(
Directory directory
);

Parameters

directory
the directory to check for an index

Return Value

true
if an index exists;
false
otherwise

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.IndexExists Overload List


IndexReader.IndexExists Method (FileInfo)

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

public static bool IndexExists(
FileInfo directory
);

Parameters

directory
the directory to check for an index

Return Value

true
if an index exists;
false
otherwise

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.IndexExists Overload List


IndexReader.IndexExists Method (String)

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
false
is returned.

public static bool IndexExists(
string directory
);

Parameters

directory
the directory to check for an index

Return Value

true
if an index exists;
false
otherwise

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.IndexExists Overload List


IndexReader.IsDeleted Method

Returns true if document n has been deleted

public abstract bool IsDeleted(
int n
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IsLocked Method

An NDoc Documented Class Library

IndexReader.IsLocked Method

Returns

true
iff the index in the named directory is currently locked.

Overload List

Returns

true
iff the index in the named directory is currently locked.

public static bool IsLocked(Directory);

Returns

true
iff the index in the named directory is currently locked.

public static bool IsLocked(string);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.IsLocked Method (Directory)

Returns

true
iff the index in the named directory is currently locked.

public static bool IsLocked(
Directory directory
);

Parameters

directory
the directory to check for a lock

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.IsLocked Overload List


IndexReader.IsLocked Method (String)

Returns

true
iff the index in the named directory is currently locked.

public static bool IsLocked(
string directory
);

Parameters

directory
the directory to check for a lock

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.IsLocked Overload List


LastModified Method

An NDoc Documented Class Library

IndexReader.LastModified Method

Returns the time the index in the named directory was last modified.

Synchronization of IndexReader and IndexWriter instances is no longer done via time stamps of the segments file since the time resolution depends on the hardware platform. Instead, a version number is maintained within the segments file, which is incremented everytime when the index is changed.

Overload List

Returns the time the index in the named directory was last modified. Synchronization of IndexReader and IndexWriter instances is no longer done via time stamps of the segments file since the time resolution depends on the hardware platform. Instead, a version number is maintained within the segments file, which is incremented everytime when the index is changed.

public static long LastModified(Directory);

Returns the time the index in the named directory was last modified. Synchronization of IndexReader and IndexWriter instances is no longer done via time stamps of the segments file since the time resolution depends on the hardware platform. Instead, a version number is maintained within the segments file, which is incremented everytime when the index is changed.

public static long LastModified(FileInfo);

Returns the time the index in the named directory was last modified. Synchronization of IndexReader and IndexWriter instances is no longer done via time stamps of the segments file since the time resolution depends on the hardware platform. Instead, a version number is maintained within the segments file, which is incremented everytime when the index is changed.

public static long LastModified(string);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.LastModified Method (Directory)

Returns the time the index in the named directory was last modified.

Synchronization of IndexReader and IndexWriter instances is no longer done via time stamps of the segments file since the time resolution depends on the hardware platform. Instead, a version number is maintained within the segments file, which is incremented everytime when the index is changed.

public static long LastModified(
Directory directory
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.LastModified Overload List


IndexReader.LastModified Method (FileInfo)

Returns the time the index in the named directory was last modified.

Synchronization of IndexReader and IndexWriter instances is no longer done via time stamps of the segments file since the time resolution depends on the hardware platform. Instead, a version number is maintained within the segments file, which is incremented everytime when the index is changed.

public static long LastModified(
FileInfo directory
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.LastModified Overload List


IndexReader.LastModified Method (String)

Returns the time the index in the named directory was last modified.

Synchronization of IndexReader and IndexWriter instances is no longer done via time stamps of the segments file since the time resolution depends on the hardware platform. Instead, a version number is maintained within the segments file, which is incremented everytime when the index is changed.

public static long LastModified(
string directory
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.LastModified Overload List


IndexReader.MaxDoc Method

Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.

public abstract int MaxDoc();

See Also

IndexReader Class | Lucene.Net.Index Namespace


Norms Method

An NDoc Documented Class Library

IndexReader.Norms Method

Returns the byte-encoded normalization factor for the named Field of every document. This is used by the search code to score documents.

Overload List

Returns the byte-encoded normalization factor for the named Field of every document. This is used by the search code to score documents.

public abstract byte[] Norms(string);

Reads the byte-encoded normalization factor for the named Field of every document. This is used by the search code to score documents.

public abstract void Norms(string,byte[],int);

See Also

IndexReader Class | Lucene.Net.Index Namespace | Field#SetBoost


IndexReader.Norms Method (String)

Returns the byte-encoded normalization factor for the named Field of every document. This is used by the search code to score documents.

public abstract byte[] Norms(
string field
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Norms Overload List | Field#SetBoost


IndexReader.Norms Method (String, Byte[], Int32)

Reads the byte-encoded normalization factor for the named Field of every document. This is used by the search code to score documents.

public abstract void Norms(
string field,
byte[] bytes,
int offset
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Norms Overload List | Field#SetBoost


IndexReader.NumDocs Method

Returns the number of documents in this index.

public abstract int NumDocs();

See Also

IndexReader Class | Lucene.Net.Index Namespace


Open Method

An NDoc Documented Class Library

IndexReader.Open Method

Returns an IndexReader reading the index in the given Directory.

Overload List

Returns an IndexReader reading the index in the given Directory.

public static IndexReader Open(Directory);

Returns an IndexReader reading the index in an FSDirectory in the named path.

public static IndexReader Open(FileInfo);

Returns an IndexReader reading the index in an FSDirectory in the named path.

public static IndexReader Open(string);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Open Method (Directory)

Returns an IndexReader reading the index in the given Directory.

public static IndexReader Open(
Directory directory
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Open Overload List


IndexReader.Open Method (FileInfo)

Returns an IndexReader reading the index in an FSDirectory in the named path.

public static IndexReader Open(
FileInfo path
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Open Overload List


IndexReader.Open Method (String)

Returns an IndexReader reading the index in an FSDirectory in the named path.

public static IndexReader Open(
string path
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Open Overload List


SetNorm Method

An NDoc Documented Class Library

IndexReader.SetNorm Method

Expert: Resets the normalization factor for the named Field of the named document. The norm represents the product of the Field's {@link Field#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.

Overload List

Expert: Resets the normalization factor for the named Field of the named document. The norm represents the product of the Field's {@link Field#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.

public void SetNorm(int,string,byte);

Expert: Resets the normalization factor for the named Field of the named document.

public virtual void SetNorm(int,string,float);

See Also

IndexReader Class | Lucene.Net.Index Namespace | #Norms | Similarity#DecodeNorm


IndexReader.SetNorm Method (Int32, String, Byte)

Expert: Resets the normalization factor for the named Field of the named document. The norm represents the product of the Field's {@link Field#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.

public void SetNorm(
int doc,
string field,
byte value_Renamed
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.SetNorm Overload List | #Norms | Similarity#DecodeNorm


IndexReader.SetNorm Method (Int32, String, Single)

Expert: Resets the normalization factor for the named Field of the named document.

public virtual void SetNorm(
int doc,
string field,
float value_Renamed
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.SetNorm Overload List | #Norms | Similarity#DecodeNorm


TermDocs Method

An NDoc Documented Class Library

IndexReader.TermDocs Method

Returns an unpositioned {@link TermDocs} enumerator.

Overload List

Returns an unpositioned {@link TermDocs} enumerator.

public abstract TermDocs TermDocs();

public virtual TermDocs TermDocs(Term);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.TermDocs Method ()

Returns an unpositioned {@link TermDocs} enumerator.

public abstract TermDocs TermDocs();

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.TermDocs Overload List


IndexReader.TermDocs Method (Term)

public virtual TermDocs TermDocs(
Term term
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.TermDocs Overload List


TermPositions Method

An NDoc Documented Class Library

IndexReader.TermPositions Method

Returns an unpositioned {@link TermPositions} enumerator.

Overload List

Returns an unpositioned {@link TermPositions} enumerator.

public abstract TermPositions TermPositions();

public virtual TermPositions TermPositions(Term);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.TermPositions Method ()

Returns an unpositioned {@link TermPositions} enumerator.

public abstract TermPositions TermPositions();

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.TermPositions Overload List


IndexReader.TermPositions Method (Term)

public virtual TermPositions TermPositions(
Term term
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.TermPositions Overload List


Terms Method

An NDoc Documented Class Library

IndexReader.Terms Method

Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.

Overload List

Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.

public abstract TermEnum Terms();

Returns an enumeration of all terms after a given term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.

public abstract TermEnum Terms(Term);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Terms Method ()

Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.

public abstract TermEnum Terms();

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Terms Overload List


IndexReader.Terms Method (Term)

Returns an enumeration of all terms after a given term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.

public abstract TermEnum Terms(
Term t
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Terms Overload List


IndexReader.UndeleteAll Method

Undeletes all documents currently marked as deleted in this index.

public void UndeleteAll();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Unlock Method

public static void Unlock(
Directory directory
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexWriter Class

An IndexWriter creates and maintains an index. The third argument to the constructor determines whether a new index is created, or whether an existing index is opened for the addition of new documents. In either case, documents are added with the addDocument method. When finished adding documents, close should be called. If an index will not have more documents added for a while and optimal search performance is desired, then the optimize method should be called before the index is closed.

For a list of all members of this type, see IndexWriter Members.

System.Object
Lucene.Net.Index.IndexWriter

public class IndexWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexWriter Members | Lucene.Net.Index Namespace


IndexWriter Members

IndexWriter overview

Public Static Fields

COMMIT_LOCK_NAME
COMMIT_LOCK_TIMEOUT Default value is 10000. Use
Lucene.Net.commitLockTimeout
system property to override.
DEFAULT_MAX_FIELD_LENGTH Default value is 10000. Use
Lucene.Net.maxFieldLength
system property to override.
DEFAULT_MAX_MERGE_DOCS Default value is {@link Integer#MAX_VALUE}. Use
Lucene.Net.maxMergeDocs
system property to override.
DEFAULT_MERGE_FACTOR Default value is 10. Use
Lucene.Net.mergeFactor
system property to override.
DEFAULT_MIN_MERGE_DOCS Default value is 10. Use
Lucene.Net.minMergeDocs
system property to override.
WRITE_LOCK_NAME
WRITE_LOCK_TIMEOUT Default value is 1000. Use
Lucene.Net.writeLockTimeout
system property to override.

Public Instance Constructors

IndexWriter Overloaded. Initializes a new instance of the IndexWriter class.

Public Instance Fields

infoStream | If non-null, information about merges will be printed to this.
maxFieldLength | The maximum number of terms that will be indexed for a single Field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. Note that this effectively truncates large documents, excluding from the index terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError. By default, no more than 10,000 terms will be indexed for a Field.
maxMergeDocs |
mergeFactor |
minMergeDocs |

Public Instance Methods

AddDocument | Overloaded. Adds a document to this index, using the provided analyzer instead of the value of {@link #GetAnalyzer()}. If the document contains more than {@link #maxFieldLength} terms for a given Field, the remainder are discarded.
AddIndexes | Overloaded. Merges the provided indexes into this index. After this completes, the index is optimized. The provided IndexReaders are not closed.
Close | Flushes all changes to an index and closes all associated files.
DocCount | Returns the number of documents currently in this index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAnalyzer | Returns the analyzer used by this index.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity |
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundFile | Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file once the segment creation is finished. This is done regardless of what directory is in use.
Optimize | Merges all segments together into a single segment, optimizing an index for search.
SetSimilarity | Expert: Set the Similarity implementation used by this IndexWriter.
SetUseCompoundFile | Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file once the segment creation is finished. This is done regardless of what directory is in use.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter Constructor

Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any.

Overload List

Constructs an IndexWriter for the index in

d
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
d
, replacing the index already there, if any.

public IndexWriter(Directory,Analyzer,bool);

Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any.

public IndexWriter(FileInfo,Analyzer,bool);

Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any.

public IndexWriter(string,Analyzer,bool);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter Constructor (String, Analyzer, Boolean)

Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any.

public IndexWriter(
string path,
Analyzer a,
bool create
);

Parameters

path
the path to the index directory
a
the analyzer to use
create
true
to create the index or overwrite the existing one;
false
to append to the existing index

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (FileInfo, Analyzer, Boolean)

Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any.

public IndexWriter(
FileInfo path,
Analyzer a,
bool create
);

Parameters

path
the path to the index directory
a
the analyzer to use
create
true
to create the index or overwrite the existing one;
false
to append to the existing index

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (Directory, Analyzer, Boolean)

Constructs an IndexWriter for the index in

d
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
d
, replacing the index already there, if any.

public IndexWriter(
Directory d,
Analyzer a,
bool create
);

Parameters

d
the index directory
a
the analyzer to use
create
true
to create the index or overwrite the existing one;
false
to append to the existing index

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Fields

The fields of the IndexWriter class are listed below. For a complete list of IndexWriter class members, see the IndexWriter Members topic.

Public Static Fields

COMMIT_LOCK_NAME
COMMIT_LOCK_TIMEOUT Default value is 10000. Use
Lucene.Net.commitLockTimeout
system property to override.
DEFAULT_MAX_FIELD_LENGTH Default value is 10000. Use
Lucene.Net.maxFieldLength
system property to override.
DEFAULT_MAX_MERGE_DOCS Default value is {@link Integer#MAX_VALUE}. Use
Lucene.Net.maxMergeDocs
system property to override.
DEFAULT_MERGE_FACTOR Default value is 10. Use
Lucene.Net.mergeFactor
system property to override.
DEFAULT_MIN_MERGE_DOCS Default value is 10. Use
Lucene.Net.minMergeDocs
system property to override.
WRITE_LOCK_NAME
WRITE_LOCK_TIMEOUT Default value is 1000. Use
Lucene.Net.writeLockTimeout
system property to override.

Public Instance Fields

infoStream | If non-null, information about merges will be printed to this.
maxFieldLength | The maximum number of terms that will be indexed for a single Field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. Note that this effectively truncates large documents, excluding from the index terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError. By default, no more than 10,000 terms will be indexed for a Field.
maxMergeDocs |
mergeFactor |
minMergeDocs |

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.COMMIT_LOCK_NAME Field

public const string COMMIT_LOCK_NAME = "commit.lock";

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.COMMIT_LOCK_TIMEOUT Field

Default value is 10000. Use

Lucene.Net.commitLockTimeout
system property to override.

public static long COMMIT_LOCK_TIMEOUT;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DEFAULT_MAX_FIELD_LENGTH Field

Default value is 10000. Use

Lucene.Net.maxFieldLength
system property to override.

public static readonly int DEFAULT_MAX_FIELD_LENGTH;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DEFAULT_MAX_MERGE_DOCS Field

Default value is {@link Integer#MAX_VALUE}. Use

Lucene.Net.maxMergeDocs
system property to override.

public static readonly int DEFAULT_MAX_MERGE_DOCS;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DEFAULT_MERGE_FACTOR Field

Default value is 10. Use

Lucene.Net.mergeFactor
system property to override.

public static readonly int DEFAULT_MERGE_FACTOR;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DEFAULT_MIN_MERGE_DOCS Field

Default value is 10. Use

Lucene.Net.minMergeDocs
system property to override.

public static readonly int DEFAULT_MIN_MERGE_DOCS;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.infoStream Field

If non-null, information about merges will be printed to this.

public TextWriter infoStream;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.maxFieldLength Field

The maximum number of terms that will be indexed for a single Field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory.

Note that this effectively truncates large documents, excluding from the index terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError.

By default, no more than 10,000 terms will be indexed for a Field.
public int maxFieldLength;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.maxMergeDocs Field

public int maxMergeDocs;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.mergeFactor Field

public int mergeFactor;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.minMergeDocs Field

public int minMergeDocs;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.WRITE_LOCK_NAME Field

public const string WRITE_LOCK_NAME = "write.lock";

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.WRITE_LOCK_TIMEOUT Field

Default value is 1000. Use

Lucene.Net.writeLockTimeout
system property to override.

public static long WRITE_LOCK_TIMEOUT;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter Methods

The methods of the IndexWriter class are listed below. For a complete list of IndexWriter class members, see the IndexWriter Members topic.

Public Instance Methods

AddDocument | Overloaded. Adds a document to this index, using the provided analyzer instead of the value of {@link #GetAnalyzer()}. If the document contains more than {@link #maxFieldLength} terms for a given Field, the remainder are discarded.
AddIndexes | Overloaded. Merges the provided indexes into this index. After this completes, the index is optimized. The provided IndexReaders are not closed.
Close | Flushes all changes to an index and closes all associated files.
DocCount | Returns the number of documents currently in this index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAnalyzer | Returns the analyzer used by this index.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity |
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundFile | Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file once the segment creation is finished. This is done regardless of what directory is in use.
Optimize | Merges all segments together into a single segment, optimizing an index for search.
SetSimilarity | Expert: Set the Similarity implementation used by this IndexWriter.
SetUseCompoundFile | Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file once the segment creation is finished. This is done regardless of what directory is in use.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexWriter Class | Lucene.Net.Index Namespace


AddDocument Method

An NDoc Documented Class Library

IndexWriter.AddDocument Method

Adds a document to this index. If the document contains more than {@link #maxFieldLength} terms for a given Field, the remainder are discarded.

Overload List

Adds a document to this index. If the document contains more than {@link #maxFieldLength} terms for a given Field, the remainder are discarded.

public virtual void AddDocument(Document);

Adds a document to this index, using the provided analyzer instead of the value of {@link #GetAnalyzer()}. If the document contains more than {@link #maxFieldLength} terms for a given Field, the remainder are discarded.

public virtual void AddDocument(Document,Analyzer);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.AddDocument Method (Document)

Adds a document to this index. If the document contains more than {@link #maxFieldLength} terms for a given Field, the remainder are discarded.

public virtual void AddDocument(
Document doc
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.AddDocument Overload List


IndexWriter.AddDocument Method (Document, Analyzer)

Adds a document to this index, using the provided analyzer instead of the value of {@link #GetAnalyzer()}. If the document contains more than {@link #maxFieldLength} terms for a given Field, the remainder are discarded.

public virtual void AddDocument(
Document doc,
Analyzer analyzer
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.AddDocument Overload List


AddIndexes Method

An NDoc Documented Class Library

IndexWriter.AddIndexes Method

Merges the provided indexes into this index.

After this completes, the index is optimized.

The provided IndexReaders are not closed.

Overload List

Merges the provided indexes into this index. After this completes, the index is optimized. The provided IndexReaders are not closed.

public virtual void AddIndexes(IndexReader[]);

public virtual void AddIndexes(Directory[]);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.AddIndexes Method (IndexReader[])

Merges the provided indexes into this index.

After this completes, the index is optimized.

The provided IndexReaders are not closed.

public virtual void AddIndexes(
IndexReader[] readers
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.AddIndexes Overload List


IndexWriter.AddIndexes Method (Directory[])

public virtual void AddIndexes(
Directory[] dirs
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.AddIndexes Overload List


IndexWriter.Close Method

Flushes all changes to an index and closes all associated files.

public virtual void Close();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DocCount Method

Returns the number of documents currently in this index.

public virtual int DocCount();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.Finalize Method

Release the write lock, if needed.

protected override void Finalize();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetAnalyzer Method

Returns the analyzer used by this index.

public virtual Analyzer GetAnalyzer();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetSimilarity Method

public virtual Similarity GetSimilarity();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetUseCompoundFile Method

Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file once the segment creation is finished. This is done regardless of what directory is in use.

public virtual bool GetUseCompoundFile();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.Optimize Method

Merges all segments together into a single segment, optimizing an index for search.

public virtual void Optimize();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SetSimilarity Method

Expert: Set the Similarity implementation used by this IndexWriter.

public virtual void SetSimilarity(
Similarity similarity
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | Similarity#SetDefault


IndexWriter.SetUseCompoundFile Method

Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file once the segment creation is finished. This is done regardless of what directory is in use.

public virtual void SetUseCompoundFile(
bool value_Renamed
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


MultipleTermPositions Class

Describe class

MultipleTermPositions
here.

For a list of all members of this type, see MultipleTermPositions Members.

System.Object
Lucene.Net.Index.MultipleTermPositions

public class MultipleTermPositions : TermPositions, TermDocs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MultipleTermPositions Members | Lucene.Net.Index Namespace


MultipleTermPositions Members

MultipleTermPositions overview

Public Instance Constructors

MultipleTermPositions Constructor Creates a new
MultipleTermPositions
instance.

Public Instance Methods

Close Describe
close
method here.
Doc Describe
doc
method here.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq Describe
freq
method here.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next Describe
next
method here.
NextPosition Describe
nextPosition
method here.
Read Describe
read
method here.
Seek | Overloaded.
SkipTo Describe
skipTo
method here.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions Constructor

Creates a new

MultipleTermPositions
instance.

public MultipleTermPositions(
IndexReader indexReader,
Term[] terms
);

Parameters

indexReader
an
IndexReader
value
terms
a
Term[]
value

Exceptions

Exception Type | Condition
 | IOException if an error occurs

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions Methods

The methods of the MultipleTermPositions class are listed below. For a complete list of MultipleTermPositions class members, see the MultipleTermPositions Members topic.

Public Instance Methods

Close Describe
close
method here.
Doc Describe
doc
method here.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq Describe
freq
method here.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next Describe
next
method here.
NextPosition Describe
nextPosition
method here.
Read Describe
read
method here.
Seek | Overloaded.
SkipTo Describe
skipTo
method here.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions.Close Method

Describe

close
method here.

public void Close();

Implements

TermDocs.Close

Exceptions

Exception Type | Condition
 | IOException if an error occurs

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace | TermDocs#Close


MultipleTermPositions.Doc Method

Describe

doc
method here.

public int Doc();

Return Value

an

int
value

Implements

TermDocs.Doc

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace | TermDocs#Doc


MultipleTermPositions.Freq Method

Describe

freq
method here.

public int Freq();

Return Value

an

int
value

Implements

TermDocs.Freq

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace | TermDocs#Freq


MultipleTermPositions.Next Method

Describe

next
method here.

public bool Next();

Return Value

a

boolean
value

Implements

TermDocs.Next

Exceptions

Exception Type | Condition
 | IOException if an error occurs

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace | TermDocs#Next


MultipleTermPositions.NextPosition Method

Describe

nextPosition
method here.

public int NextPosition();

Return Value

an

int
value

Implements

TermPositions.NextPosition

Exceptions

Exception Type | Condition
 | IOException if an error occurs

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace | TermPositions#NextPosition


MultipleTermPositions.Read Method

Describe

read
method here.

public virtual int Read(
int[] arg0,
int[] arg1
);

Parameters

arg0
an
int[]
value
arg1
an
int[]
value

Return Value

an

int
value

Implements

TermDocs.Read

Exceptions

Exception Type | Condition
 | IOException if an error occurs

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace | int[])


Seek Method

An NDoc Documented Class Library

MultipleTermPositions.Seek Method

Describe

seek
method here.

Overload List

Describe

seek
method here.

public virtual void Seek(Term);

public virtual void Seek(TermEnum);

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace | TermDocs#Seek


MultipleTermPositions.Seek Method (Term)

Describe

seek
method here.

public virtual void Seek(
Term arg0
);

Parameters

arg0
a
Term
value

Implements

TermDocs.Seek

Exceptions

Exception Type | Condition
 | IOException if an error occurs

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace | MultipleTermPositions.Seek Overload List | TermDocs#Seek


MultipleTermPositions.Seek Method (TermEnum)

public virtual void Seek(
TermEnum termEnum
);

Implements

TermDocs.Seek

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace | MultipleTermPositions.Seek Overload List


MultipleTermPositions.SkipTo Method

Describe

skipTo
method here.

public bool SkipTo(
int target
);

Parameters

target
an
int
value

Return Value

a

boolean
value

Implements

TermDocs.SkipTo

Exceptions

Exception Type | Condition
 | IOException if an error occurs

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace | TermDocs#SkipTo


MultiReader Class

An IndexReader which reads multiple indexes, appending their content.

For a list of all members of this type, see MultiReader Members.

System.Object
Lucene.Net.Index.IndexReader
Lucene.Net.Index.MultiReader

public class MultiReader : IndexReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MultiReader Members | Lucene.Net.Index Namespace


MultiReader Members

MultiReader overview

Public Instance Constructors

MultiReader Overloaded. Initializes a new instance of the MultiReader class.

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Delete (inherited from IndexReader) Overloaded. Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its Field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
Directory (inherited from IndexReader) | Returns the directory this index resides in.
DocFreq
Document
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFieldNames | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIndexedFieldNames
GetTermFreqVector
GetTermFreqVectors | Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized Field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized Field. If no such fields existed, the method returns null.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDeletions
IsDeleted
MaxDoc
Norms | Overloaded.
NumDocs
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named Field of the named document.
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from IndexReader) | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations
DoClose |
DoCommit |
DoDelete |
DoSetNorm |
DoUndeleteAll |

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader Constructor

Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.

Note that all subreaders are closed if this Multireader is closed.

Overload List

Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders. Note that all subreaders are closed if this Multireader is closed.

public MultiReader(IndexReader[]);

Construct reading the named set of readers.

public MultiReader(Directory,SegmentInfos,bool,IndexReader[]);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader Constructor (IndexReader[])

Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.

Note that all subreaders are closed if this Multireader is closed.

public MultiReader(
IndexReader[] subReaders
);

Parameters

subReaders
set of (sub)readers

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader Constructor Overload List


MultiReader Constructor (Directory, SegmentInfos, Boolean, IndexReader[])

Construct reading the named set of readers.

public MultiReader(
Directory directory,
SegmentInfos sis,
bool closeDirectory,
IndexReader[] subReaders
);

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader Constructor Overload List


MultiReader Methods

The methods of the MultiReader class are listed below. For a complete list of MultiReader class members, see the MultiReader Members topic.

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Delete (inherited from IndexReader) Overloaded. Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its Field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
Directory (inherited from IndexReader) | Returns the directory this index resides in.
DocFreq
Document
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFieldNames | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIndexedFieldNames
GetTermFreqVector
GetTermFreqVectors | Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized Field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized Field. If no such fields existed, the method returns null.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDeletions
IsDeleted
MaxDoc
Norms | Overloaded.
NumDocs
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named Field of the named document.
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from IndexReader) | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations
DoClose |
DoCommit |
DoDelete |
DoSetNorm |
DoUndeleteAll |

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.DocFreq Method

public override int DocFreq(
Term t
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.DoClose Method

protected internal override void DoClose();

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.DoCommit Method

protected internal override void DoCommit();

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.Document Method

public override Document Document(
int n
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.DoDelete Method

protected internal override void DoDelete(
int n
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.DoSetNorm Method

protected internal override void DoSetNorm(
int n,
string field,
byte value_Renamed
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.DoUndeleteAll Method

protected internal override void DoUndeleteAll();

See Also

MultiReader Class | Lucene.Net.Index Namespace


GetFieldNames Method

An NDoc Documented Class Library

MultiReader.GetFieldNames Method

Overload List

public override ICollection GetFieldNames();

public override ICollection GetFieldNames(bool);

See Also

MultiReader Class | Lucene.Net.Index Namespace | IndexReader#GetFieldNames


MultiReader.GetFieldNames Method ()

public override ICollection GetFieldNames();

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.GetFieldNames Overload List | IndexReader#GetFieldNames


MultiReader.GetFieldNames Method (Boolean)

public override ICollection GetFieldNames(
bool indexed
);

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.GetFieldNames Overload List | IndexReader#GetFieldNames


MultiReader.GetIndexedFieldNames Method

public override ICollection GetIndexedFieldNames(
bool storedTermVector
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.GetTermFreqVector Method

public override TermFreqVector GetTermFreqVector(
int n,
string field
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.GetTermFreqVectors Method

Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized Field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized Field. If no such fields existed, the method returns null.

public override TermFreqVector[] GetTermFreqVectors(
int n
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.HasDeletions Method

public override bool HasDeletions();

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.IsDeleted Method

public override bool IsDeleted(
int n
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.MaxDoc Method

public override int MaxDoc();

See Also

MultiReader Class | Lucene.Net.Index Namespace


Norms Method

An NDoc Documented Class Library

MultiReader.Norms Method

Overload List

public override byte[] Norms(string);

public override void Norms(string,byte[],int);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.Norms Method (String)

public override byte[] Norms(
string field
);

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.Norms Overload List


MultiReader.Norms Method (String, Byte[], Int32)

public override void Norms(
string field,
byte[] result,
int offset
);

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.Norms Overload List


MultiReader.NumDocs Method

public override int NumDocs();

See Also

MultiReader Class | Lucene.Net.Index Namespace


TermDocs Method

An NDoc Documented Class Library

MultiReader.TermDocs Method

Overload List

public override TermDocs TermDocs();

Inherited from IndexReader.

public virtual TermDocs TermDocs(Term);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.TermDocs Method ()

public override TermDocs TermDocs();

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.TermDocs Overload List


TermPositions Method

An NDoc Documented Class Library

MultiReader.TermPositions Method

Overload List

public override TermPositions TermPositions();

Inherited from IndexReader.

public virtual TermPositions TermPositions(Term);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.TermPositions Method ()

public override TermPositions TermPositions();

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.TermPositions Overload List


Terms Method

An NDoc Documented Class Library

MultiReader.Terms Method

Overload List

public override TermEnum Terms();

public override TermEnum Terms(Term);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.Terms Method ()

public override TermEnum Terms();

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.Terms Overload List


MultiReader.Terms Method (Term)

public override TermEnum Terms(
Term term
);

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.Terms Overload List


SegmentInfo Class

For a list of all members of this type, see SegmentInfo Members.

System.Object
Lucene.Net.Index.SegmentInfo

public sealed class SegmentInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentInfo Members | Lucene.Net.Index Namespace


SegmentInfo Members

SegmentInfo overview

Public Instance Constructors

SegmentInfo Constructor

Public Instance Fields

dir
docCount
name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo Constructor

public SegmentInfo(
string name,
int docCount,
Directory dir
);

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo Fields

The fields of the SegmentInfo class are listed below. For a complete list of SegmentInfo class members, see the SegmentInfo Members topic.

Public Instance Fields

dir
docCount
name

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.dir Field

public Directory dir;

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.docCount Field

public int docCount;

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.name Field

public string name;

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfos Class

For a list of all members of this type, see SegmentInfos Members.

System.Object
System.Collections.ArrayList
Lucene.Net.Index.SegmentInfos

public sealed class SegmentInfos : ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentInfos Members | Lucene.Net.Index Namespace


SegmentInfos Members

SegmentInfos overview

Public Static Fields

FORMAT The file format version, a negative number.

Public Static Methods

ReadCurrentVersion Current version number from segments file.

Public Instance Constructors

SegmentInfos Constructor Initializes a new instance of the SegmentInfos class.

Public Instance Fields

counter

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add (inherited from ArrayList) | Adds an object to the end of the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | version number when this SegmentInfos was generated.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Info |
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Read |
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.
Write |

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos Constructor

Initializes a new instance of the SegmentInfos class.

public SegmentInfos();

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos Fields

The fields of the SegmentInfos class are listed below. For a complete list of SegmentInfos class members, see the SegmentInfos Members topic.

Public Static Fields

FORMAT The file format version, a negative number.

Public Instance Fields

counter

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.counter Field

public int counter;

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.FORMAT Field

The file format version, a negative number.

public const int FORMAT = -1;

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos Methods

The methods of the SegmentInfos class are listed below. For a complete list of SegmentInfos class members, see the SegmentInfos Members topic.

Public Static Methods

ReadCurrentVersion Current version number from segments file.

Public Instance Methods

Add (inherited from ArrayList) | Adds an object to the end of the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | version number when this SegmentInfos was generated.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Info |
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Read |
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.
Write |

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.GetVersion Method

version number when this SegmentInfos was generated.

public long GetVersion();

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.Info Method

public SegmentInfo Info(
int i
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.Read Method

public void Read(
Directory directory
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.ReadCurrentVersion Method

Current version number from segments file.

public static long ReadCurrentVersion(
Directory directory
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.Write Method

public void Write(
Directory directory
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentMerger Class

For a list of all members of this type, see SegmentMerger Members.

System.Object
Lucene.Net.Index.SegmentMerger

public sealed class SegmentMerger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentMerger Members | Lucene.Net.Index Namespace


SegmentMerger Members

SegmentMerger overview

Public Instance Constructors

SegmentMerger Constructor

Public Instance Methods

Add | Add an IndexReader to the collection of readers that are to be merged
CloseReaders | close all IndexReaders that have been added. Should not be called before merge().
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Merges the readers specified by the {@link #add} method into the directory passed to the constructor
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentMerger Constructor

public SegmentMerger(
Directory dir,
string name,
bool compoundFile
);

Parameters

dir
The Directory to merge the other segments into
name
The name of the new segment
compoundFile
true if the new segment should use a compoundFile

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentMerger Methods

The methods of the SegmentMerger class are listed below. For a complete list of SegmentMerger class members, see the SegmentMerger Members topic.

Public Instance Methods

Add | Add an IndexReader to the collection of readers that are to be merged
CloseReaders | close all IndexReaders that have been added. Should not be called before merge().
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Merges the readers specified by the {@link #add} method into the directory passed to the constructor
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentMerger.Add Method

Add an IndexReader to the collection of readers that are to be merged

public void Add(
IndexReader reader
);

Parameters

reader

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentMerger.CloseReaders Method

close all IndexReaders that have been added. Should not be called before merge().

public void CloseReaders();

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentMerger.Merge Method

Merges the readers specified by the {@link #add} method into the directory passed to the constructor

public int Merge();

Return Value

The number of documents that were merged

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentReader Class

FIXME: Describe class

SegmentReader
here.

For a list of all members of this type, see SegmentReader Members.

System.Object
Lucene.Net.Index.IndexReader
Lucene.Net.Index.SegmentReader

public sealed class SegmentReader : IndexReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentReader Members | Lucene.Net.Index Namespace


SegmentReader Members

SegmentReader overview

Public Instance Constructors

SegmentReader Overloaded. Initializes a new instance of the SegmentReader class.

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Delete (inherited from IndexReader) Overloaded. Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its Field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
Directory (inherited from IndexReader) | Returns the directory this index resides in.
DocFreq
Document
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFieldNames | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIndexedFieldNames
GetTermFreqVector | Return a term frequency vector for the specified document and Field. The vector returned contains term numbers and frequencies for all terms in the specified Field of this document, if the Field had storeTermVector flag set. If the flag was not set, the method returns null.
GetTermFreqVectors | Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized Field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized Field. If no such fields existed, the method returns null.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDeletions
IsDeleted
MaxDoc
Norms | Overloaded. Read norms into a pre-allocated array.
NumDocs
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named Field of the named document.
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Internal Instance Methods

Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations
DoClose |
DoCommit |
DoDelete |
DoSetNorm |
DoUndeleteAll |

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader Constructor

Overload List

public SegmentReader(SegmentInfo);

public SegmentReader(SegmentInfos,SegmentInfo,bool);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader Constructor (SegmentInfos, SegmentInfo, Boolean)

public SegmentReader(
SegmentInfos sis,
SegmentInfo si,
bool closeDir
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader Constructor Overload List


SegmentReader Constructor (SegmentInfo)

public SegmentReader(
SegmentInfo si
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader Constructor Overload List


SegmentReader Methods

The methods of the SegmentReader class are listed below. For a complete list of SegmentReader class members, see the SegmentReader Members topic.

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Delete (inherited from IndexReader) Overloaded. Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its Field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
Directory (inherited from IndexReader) | Returns the directory this index resides in.
DocFreq
Document
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFieldNames | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIndexedFieldNames
GetTermFreqVector | Return a term frequency vector for the specified document and Field. The vector returned contains term numbers and frequencies for all terms in the specified Field of this document, if the Field had storeTermVector flag set. If the flag was not set, the method returns null.
GetTermFreqVectors | Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized Field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized Field. If no such fields existed, the method returns null.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDeletions
IsDeleted
MaxDoc
Norms | Overloaded. Read norms into a pre-allocated array.
NumDocs
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named Field of the named document.
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Internal Instance Methods

Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations
DoClose |
DoCommit |
DoDelete |
DoSetNorm |
DoUndeleteAll |

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.DocFreq Method

public override int DocFreq(
Term t
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.DoClose Method

protected internal override void DoClose();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.DoCommit Method

protected internal override void DoCommit();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.Document Method

public override Document Document(
int n
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.DoDelete Method

protected internal override void DoDelete(
int docNum
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.DoSetNorm Method

protected internal override void DoSetNorm(
int doc,
string field,
byte value_Renamed
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.DoUndeleteAll Method

protected internal override void DoUndeleteAll();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


GetFieldNames Method

An NDoc Documented Class Library

SegmentReader.GetFieldNames Method

Overload List

public override ICollection GetFieldNames();

public override ICollection GetFieldNames(bool);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | IndexReader#GetFieldNames


SegmentReader.GetFieldNames Method ()

public override ICollection GetFieldNames();

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.GetFieldNames Overload List | IndexReader#GetFieldNames


SegmentReader.GetFieldNames Method (Boolean)

public override ICollection GetFieldNames(
bool indexed
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.GetFieldNames Overload List | IndexReader#GetFieldNames


SegmentReader.GetIndexedFieldNames Method

public override ICollection GetIndexedFieldNames(
bool storedTermVector
);

Parameters

storedTermVector
if true, returns only Indexed fields that have term vector info, else only indexed fields without term vector info

Return Value

Collection of Strings indicating the names of the fields

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.GetTermFreqVector Method

Return a term frequency vector for the specified document and Field. The vector returned contains term numbers and frequencies for all terms in the specified Field of this document, if the Field had storeTermVector flag set. If the flag was not set, the method returns null.

public override TermFreqVector GetTermFreqVector(
int docNumber,
string field
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.GetTermFreqVectors Method

Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized Field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized Field. If no such fields existed, the method returns null.

public override TermFreqVector[] GetTermFreqVectors(
int docNumber
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.HasDeletions Method

public override bool HasDeletions();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.IsDeleted Method

public override bool IsDeleted(
int n
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.MaxDoc Method

public override int MaxDoc();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


Norms Method

An NDoc Documented Class Library

SegmentReader.Norms Method

Overload List

public override byte[] Norms(string);

Read norms into a pre-allocated array.

public override void Norms(string,byte[],int);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.Norms Method (String)

public override byte[] Norms(
string field
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Norms Overload List


SegmentReader.Norms Method (String, Byte[], Int32)

Read norms into a pre-allocated array.

public override void Norms(
string field,
byte[] bytes,
int offset
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Norms Overload List


SegmentReader.NumDocs Method

public override int NumDocs();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


TermDocs Method

An NDoc Documented Class Library

SegmentReader.TermDocs Method

Overload List

public override TermDocs TermDocs();

Inherited from IndexReader.

public virtual TermDocs TermDocs(Term);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.TermDocs Method ()

public override TermDocs TermDocs();

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.TermDocs Overload List


TermPositions Method

An NDoc Documented Class Library

SegmentReader.TermPositions Method

Overload List

public override TermPositions TermPositions();

Inherited from IndexReader.

public virtual TermPositions TermPositions(Term);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.TermPositions Method ()

public override TermPositions TermPositions();

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.TermPositions Overload List


Terms Method

An NDoc Documented Class Library

SegmentReader.Terms Method

Overload List

public override TermEnum Terms();

public override TermEnum Terms(Term);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.Terms Method ()

public override TermEnum Terms();

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Terms Overload List


SegmentReader.Terms Method (Term)

public override TermEnum Terms(
Term t
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Terms Overload List


SegmentTermDocs Class

For a list of all members of this type, see SegmentTermDocs Members.

System.Object
Lucene.Net.Index.SegmentTermDocs

public class SegmentTermDocs : TermDocs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentTermDocs Members | Lucene.Net.Index Namespace


SegmentTermDocs Members

SegmentTermDocs overview

Public Instance Constructors

SegmentTermDocs Constructor

Public Instance Methods

Close |
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Read | Optimized implementation.
Seek | Overloaded.
SkipTo | Optimized implementation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

parent

Protected Internal Instance Methods

SkippingDoc |
SkipProx | Overridden by SegmentTermPositions to skip in prox stream.

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs Constructor

public SegmentTermDocs(
SegmentReader parent
);

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs Fields

The fields of the SegmentTermDocs class are listed below. For a complete list of SegmentTermDocs class members, see the SegmentTermDocs Members topic.

Protected Internal Instance Fields

parent

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.parent Field

protected internal SegmentReader parent;

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs Methods

The methods of the SegmentTermDocs class are listed below. For a complete list of SegmentTermDocs class members, see the SegmentTermDocs Members topic.

Public Instance Methods

Close |
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Read | Optimized implementation.
Seek | Overloaded.
SkipTo | Optimized implementation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SkippingDoc |
SkipProx | Overridden by SegmentTermPositions to skip in prox stream.

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.Close Method

public virtual void Close();

Implements

TermDocs.Close

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.Doc Method

public int Doc();

Implements

TermDocs.Doc

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.Freq Method

public int Freq();

Implements

TermDocs.Freq

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.Next Method

public virtual bool Next();

Implements

TermDocs.Next

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.Read Method

Optimized implementation.

public virtual int Read(
int[] docs,
int[] freqs
);

Implements

TermDocs.Read

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


Seek Method

An NDoc Documented Class Library

SegmentTermDocs.Seek Method

Overload List

public virtual void Seek(Term);

public virtual void Seek(TermEnum);

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.Seek Method (Term)

public virtual void Seek(
Term term
);

Implements

TermDocs.Seek

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace | SegmentTermDocs.Seek Overload List


SegmentTermDocs.Seek Method (TermEnum)

public virtual void Seek(
TermEnum termEnum
);

Implements

TermDocs.Seek

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace | SegmentTermDocs.Seek Overload List


SegmentTermDocs.SkippingDoc Method

protected internal virtual void SkippingDoc();

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.SkipProx Method

Overridden by SegmentTermPositions to skip in prox stream.

protected internal virtual void SkipProx(
long proxPointer
);

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.SkipTo Method

Optimized implementation.

public virtual bool SkipTo(
int target
);

Implements

TermDocs.SkipTo

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermEnum Class

For a list of all members of this type, see SegmentTermEnum Members.

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Index.SegmentTermEnum

public sealed class SegmentTermEnum : TermEnum, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentTermEnum Members | Lucene.Net.Index Namespace


SegmentTermEnum Members

SegmentTermEnum overview

Public Instance Methods

Clone |
Close | Closes the enumeration to further activity, freeing resources.
DocFreq | Returns the docFreq from the current TermInfo in the enumeration. Initially invalid, valid after next() called for the first time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term | Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
TermInfo | Returns the current TermInfo in the enumeration. Initially invalid, valid after next() called for the first time.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum Methods

The methods of the SegmentTermEnum class are listed below. For a complete list of SegmentTermEnum class members, see the SegmentTermEnum Members topic.

Public Instance Methods

Clone |
Close | Closes the enumeration to further activity, freeing resources.
DocFreq | Returns the docFreq from the current TermInfo in the enumeration. Initially invalid, valid after next() called for the first time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term | Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
TermInfo | Returns the current TermInfo in the enumeration. Initially invalid, valid after next() called for the first time.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum.Clone Method

public object Clone();

Implements

ICloneable.Clone

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum.Close Method

Closes the enumeration to further activity, freeing resources.

public override void Close();

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum.DocFreq Method

Returns the docFreq from the current TermInfo in the enumeration. Initially invalid, valid after next() called for the first time.

public override int DocFreq();

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum.Next Method

Increments the enumeration to the next element. True if one exists.

public override bool Next();

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum.Term Method

Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.

public override Term Term();

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum.TermInfo Method

Returns the current TermInfo in the enumeration. Initially invalid, valid after next() called for the first time.

public TermInfo TermInfo();

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


Term Class

A Term represents a word from text. This is the unit of search. It is composed of two elements, the text of the word, as a string, and the name of the Field that the text occured in, an interned string. Note that terms may represent more than words from text fields, but also things like dates, email addresses, urls, etc.

For a list of all members of this type, see Term Members.

System.Object
Lucene.Net.Index.Term

public sealed class Term : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Term Members | Lucene.Net.Index Namespace


Term Members

Term overview

Public Instance Constructors

Term Constructor Constructs a Term with the given Field and text.

Public Instance Fields

text

Public Instance Methods

CompareTo | Overloaded.
Equals | Compares two terms, returning true iff they have the same Field and text.
Field | Returns the Field of this term, an interned string. The Field indicates the part of a document which this term came from.
GetHashCode | Combines the hashCode() of the Field and the text.
GetType (inherited from Object) | Gets the Type of the current instance.
Text | Returns the text of this term. In the case of words, this is simply the text of the word. In the case of dates and other types, this is an encoding of the object as a string.
ToString |

See Also

Term Class | Lucene.Net.Index Namespace


Term Constructor

Constructs a Term with the given Field and text.

public Term(
string fld,
string txt
);

See Also

Term Class | Lucene.Net.Index Namespace


Term Fields

The fields of the Term class are listed below. For a complete list of Term class members, see the Term Members topic.

Public Instance Fields

text

See Also

Term Class | Lucene.Net.Index Namespace


Term.Text Method

Returns the text of this term. In the case of words, this is simply the text of the word. In the case of dates and other types, this is an encoding of the object as a string.

public string Text();

See Also

Term Class | Lucene.Net.Index Namespace


Term Methods

The methods of the Term class are listed below. For a complete list of Term class members, see the Term Members topic.

Public Instance Methods

CompareTo | Overloaded.
Equals | Compares two terms, returning true iff they have the same Field and text.
Field | Returns the Field of this term, an interned string. The Field indicates the part of a document which this term came from.
GetHashCode | Combines the hashCode() of the Field and the text.
GetType (inherited from Object) | Gets the Type of the current instance.
Text | Returns the text of this term. In the case of words, this is simply the text of the word. In the case of dates and other types, this is an encoding of the object as a string.
ToString |

See Also

Term Class | Lucene.Net.Index Namespace


CompareTo Method

An NDoc Documented Class Library

Term.CompareTo Method

Compares two terms, returning an integer which is less than zero iff this term belongs after the argument, equal zero iff this term is equal to the argument, and greater than zero iff this term belongs after the argument. The ordering of terms is first by Field, then by text.

Overload List

Compares two terms, returning an integer which is less than zero iff this term belongs after the argument, equal zero iff this term is equal to the argument, and greater than zero iff this term belongs after the argument. The ordering of terms is first by Field, then by text.

public int CompareTo(Term);

public int CompareTo(object);

See Also

Term Class | Lucene.Net.Index Namespace


Term.CompareTo Method (Term)

Compares two terms, returning an integer which is less than zero iff this term belongs after the argument, equal zero iff this term is equal to the argument, and greater than zero iff this term belongs after the argument. The ordering of terms is first by Field, then by text.

public int CompareTo(
Term other
);

See Also

Term Class | Lucene.Net.Index Namespace | Term.CompareTo Overload List


Term.CompareTo Method (Object)

public int CompareTo(
object other
);

Implements

IComparable.CompareTo

See Also

Term Class | Lucene.Net.Index Namespace | Term.CompareTo Overload List


Term.Equals Method

Compares two terms, returning true iff they have the same Field and text.

public override bool Equals(
object o
);

See Also

Term Class | Lucene.Net.Index Namespace


Term.Field Method

Returns the Field of this term, an interned string. The Field indicates the part of a document which this term came from.

public string Field();

See Also

Term Class | Lucene.Net.Index Namespace


Term.GetHashCode Method

Combines the hashCode() of the Field and the text.

public override int GetHashCode();

See Also

Term Class | Lucene.Net.Index Namespace


Term.ToString Method

public override string ToString();

See Also

Term Class | Lucene.Net.Index Namespace


TermDocs Interface

For a list of all members of this type, see TermDocs Members.

Lucene.Net.Index.TermDocs
Lucene.Net.Index.TermPositions

public interface TermDocs

Types that implement TermDocs

Type | Description
FilterIndexReader.FilterTermDocs | Base class for filtering {@link TermDocs} implementations.
FilterIndexReader.FilterTermPositions | Base class for filtering {@link TermPositions} implementations.
MultipleTermPositions Describe class
MultipleTermPositions
here.
SegmentTermDocs

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermDocs Members | Lucene.Net.Index Namespace


TermDocs Members

TermDocs overview

Public Instance Methods

Close | Frees associated resources.
Doc |
Freq |
Next |
Read |
Seek | Overloaded. Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations.
SkipTo |

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs Methods

The methods of the TermDocs interface are listed below. For a complete list of TermDocs interface members, see the TermDocs Members topic.

Public Instance Methods

Close | Frees associated resources.
Doc |
Freq |
Next |
Read |
Seek | Overloaded. Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations.
SkipTo |

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs.Close Method

Frees associated resources.

void Close();

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs.Doc Method

int Doc();

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs.Freq Method

int Freq();

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs.Next Method

bool Next();

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs.Read Method

int Read(
int[] docs,
int[] freqs
);

See Also

TermDocs Interface | Lucene.Net.Index Namespace


Seek Method

An NDoc Documented Class Library

TermDocs.Seek Method

Sets this to the data for a term. The enumeration is reset to the start of the data for this term.

Overload List

Sets this to the data for a term. The enumeration is reset to the start of the data for this term.

void Seek(Term);

Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations.

void Seek(TermEnum);

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs.Seek Method (Term)

Sets this to the data for a term. The enumeration is reset to the start of the data for this term.

void Seek(
Term term
);

See Also

TermDocs Interface | Lucene.Net.Index Namespace | TermDocs.Seek Overload List


TermDocs.Seek Method (TermEnum)

Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations.

void Seek(
TermEnum termEnum
);

See Also

TermDocs Interface | Lucene.Net.Index Namespace | TermDocs.Seek Overload List


TermDocs.SkipTo Method

bool SkipTo(
int target
);

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermEnum Class

For a list of all members of this type, see TermEnum Members.

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Index.FilterIndexReader.FilterTermEnum
Lucene.Net.Index.SegmentTermEnum
Lucene.Net.Search.FilteredTermEnum

public abstract class TermEnum

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermEnum Members | Lucene.Net.Index Namespace


TermEnum Members

TermEnum overview

Public Instance Methods

Close | Closes the enumeration to further activity, freeing resources.
DocFreq | Returns the docFreq of the current Term in the enumeration.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Increments the enumeration to the next element. True if one exists.
SkipTo |
Term | Returns the current Term in the enumeration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

TermEnum Constructor Initializes a new instance of the TermEnum class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum Constructor

Initializes a new instance of the TermEnum class.

protected TermEnum();

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum Methods

The methods of the TermEnum class are listed below. For a complete list of TermEnum class members, see the TermEnum Members topic.

Public Instance Methods

Close | Closes the enumeration to further activity, freeing resources.
DocFreq | Returns the docFreq of the current Term in the enumeration.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Increments the enumeration to the next element. True if one exists.
SkipTo |
Term | Returns the current Term in the enumeration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum.Close Method

Closes the enumeration to further activity, freeing resources.

public abstract void Close();

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum.DocFreq Method

Returns the docFreq of the current Term in the enumeration.

public abstract int DocFreq();

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum.Next Method

Increments the enumeration to the next element. True if one exists.

public abstract bool Next();

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum.SkipTo Method

public virtual bool SkipTo(
Term target
);

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum.Term Method

Returns the current Term in the enumeration.

public abstract Term Term();

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermFreqVector Interface

Provides access to stored term vector of a document Field.

For a list of all members of this type, see TermFreqVector Members.

Lucene.Net.Index.TermFreqVector
Lucene.Net.Index.TermPositionVector

public interface TermFreqVector

Types that implement TermFreqVector

Type | Description
QueryTermVector |

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermFreqVector Members | Lucene.Net.Index Namespace


TermFreqVector Members

TermFreqVector overview

Public Instance Methods

GetField
GetTermFrequencies Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from
getTerms
method. Each location in the array contains the number of times this term occurs in the document or the document Field.
GetTerms
IndexesOf Just like
indexOf(int)
but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.
IndexOf Return an index in the term numbers array returned from
getTerms
at which the term with the specified
term
appears. If this term does not appear in the array, return -1.
Size

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector Methods

The methods of the TermFreqVector interface are listed below. For a complete list of TermFreqVector interface members, see the TermFreqVector Members topic.

Public Instance Methods

GetField
GetTermFrequencies Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from
getTerms
method. Each location in the array contains the number of times this term occurs in the document or the document Field.
GetTerms
IndexesOf Just like
indexOf(int)
but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.
IndexOf Return an index in the term numbers array returned from
getTerms
at which the term with the specified
term
appears. If this term does not appear in the array, return -1.
Size

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector.GetField Method

string GetField();

Return Value

The Field this vector is associated with.

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector.GetTermFrequencies Method

Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from

getTerms
method. Each location in the array contains the number of times this term occurs in the document or the document Field.

int[] GetTermFrequencies();

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector.GetTerms Method

string[] GetTerms();

Return Value

An Array of term texts in ascending order.

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector.IndexesOf Method

Just like

indexOf(int)
but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.

int[] IndexesOf(
string[] terms,
int start,
int len
);

Parameters

terms
array containing terms to look for
start
index in the array where the list of terms starts
len
the number of terms in the list

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector.IndexOf Method

Return an index in the term numbers array returned from

getTerms
at which the term with the specified
term
appears. If this term does not appear in the array, return -1.

int IndexOf(
string term
);

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector.Size Method

int Size();

Return Value

The number of terms in the term vector.

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermInfo Class

A TermInfo is the record of information stored for a term.

For a list of all members of this type, see TermInfo Members.

System.Object
Lucene.Net.Index.TermInfo

public sealed class TermInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermInfo Members | Lucene.Net.Index Namespace


TermInfo Members

TermInfo overview

Public Instance Constructors

TermInfo Constructor

Public Instance Fields

docFreq | The number of documents which contain the term.
freqPointer |
proxPointer |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermInfo Class | Lucene.Net.Index Namespace


TermInfo Constructor

public TermInfo(
int df,
long fp,
long pp
);

See Also

TermInfo Class | Lucene.Net.Index Namespace


TermInfo Fields

The fields of the TermInfo class are listed below. For a complete list of TermInfo class members, see the TermInfo Members topic.

Public Instance Fields

docFreq | The number of documents which contain the term.
freqPointer |
proxPointer |

See Also

TermInfo Class | Lucene.Net.Index Namespace


TermInfo.docFreq Field

The number of documents which contain the term.

public int docFreq;

See Also

TermInfo Class | Lucene.Net.Index Namespace


TermInfo.freqPointer Field

public long freqPointer;

See Also

TermInfo Class | Lucene.Net.Index Namespace


TermInfo.proxPointer Field

public long proxPointer;

See Also

TermInfo Class | Lucene.Net.Index Namespace


TermInfosReader Class

For a list of all members of this type, see TermInfosReader Members.

System.Object
Lucene.Net.Index.TermInfosReader

public sealed class TermInfosReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermInfosReader Members | Lucene.Net.Index Namespace


TermInfosReader Members

TermInfosReader overview

Public Instance Constructors

TermInfosReader Constructor

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Returns the TermInfo for a Term in the set, or null.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSkipInterval |
GetType (inherited from Object) | Gets the Type of the current instance.
Terms | Overloaded. Returns an enumeration of all the Terms and TermInfos in the set.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader Constructor

public TermInfosReader(
Directory dir,
string seg,
FieldInfos fis
);

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader Methods

The methods of the TermInfosReader class are listed below. For a complete list of TermInfosReader class members, see the TermInfosReader Members topic.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Returns the TermInfo for a Term in the set, or null.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSkipInterval |
GetType (inherited from Object) | Gets the Type of the current instance.
Terms | Overloaded. Returns an enumeration of all the Terms and TermInfos in the set.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader.Close Method

public void Close();

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader.Get Method

Returns the TermInfo for a Term in the set, or null.

public TermInfo Get(
Term term
);

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader.GetSkipInterval Method

public int GetSkipInterval();

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


Terms Method

An NDoc Documented Class Library

TermInfosReader.Terms Method

Returns an enumeration of all the Terms and TermInfos in the set.

Overload List

Returns an enumeration of all the Terms and TermInfos in the set.

public SegmentTermEnum Terms();

Returns an enumeration of terms starting at or after the named term.

public SegmentTermEnum Terms(Term);

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader.Terms Method ()

Returns an enumeration of all the Terms and TermInfos in the set.

public SegmentTermEnum Terms();

See Also

TermInfosReader Class | Lucene.Net.Index Namespace | TermInfosReader.Terms Overload List


TermInfosReader.Terms Method (Term)

Returns an enumeration of terms starting at or after the named term.

public SegmentTermEnum Terms(
Term term
);

See Also

TermInfosReader Class | Lucene.Net.Index Namespace | TermInfosReader.Terms Overload List


TermInfosWriter Class

For a list of all members of this type, see TermInfosWriter Members.

System.Object
Lucene.Net.Index.TermInfosWriter

public sealed class TermInfosWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermInfosWriter Members | Lucene.Net.Index Namespace


TermInfosWriter Members

TermInfosWriter overview

Public Static Fields

FORMAT The file format version, a negative number.

Public Instance Constructors

TermInfosWriter Constructor

Public Instance Methods

Add |
Close | Called to complete TermInfos creation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermInfosWriter Constructor

public TermInfosWriter(
Directory directory,
string segment,
FieldInfos fis
);

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermInfosWriter Fields

The fields of the TermInfosWriter class are listed below. For a complete list of TermInfosWriter class members, see the TermInfosWriter Members topic.

Public Static Fields

FORMAT The file format version, a negative number.

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermInfosWriter.FORMAT Field

The file format version, a negative number.

public const int FORMAT = -2;

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermInfosWriter Methods

The methods of the TermInfosWriter class are listed below. For a complete list of TermInfosWriter class members, see the TermInfosWriter Members topic.

Public Instance Methods

Add |
Close | Called to complete TermInfos creation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermInfosWriter.Add Method

public void Add(
Term term,
TermInfo ti
);

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermInfosWriter.Close Method

Called to complete TermInfos creation.

public void Close();

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermPositions Interface

For a list of all members of this type, see TermPositions Members.

public interface TermPositions : TermDocs

Types that implement TermPositions

Type | Description
FilterIndexReader.FilterTermPositions | Base class for filtering {@link TermPositions} implementations.
MultipleTermPositions Describe class
MultipleTermPositions
here.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermPositions Members | Lucene.Net.Index Namespace


TermPositions Members

TermPositions overview

Public Instance Methods

NextPosition

See Also

TermPositions Interface | Lucene.Net.Index Namespace


TermPositions Methods

The methods of the TermPositions interface are listed below. For a complete list of TermPositions interface members, see the TermPositions Members topic.

Public Instance Methods

NextPosition

See Also

TermPositions Interface | Lucene.Net.Index Namespace


TermPositions.NextPosition Method

int NextPosition();

See Also

TermPositions Interface | Lucene.Net.Index Namespace


TermPositionVector Interface

Extends

TermFreqVector
to provide additional information about positions in which each of the terms is found.

For a list of all members of this type, see TermPositionVector Members.

public interface TermPositionVector : TermFreqVector

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermPositionVector Members | Lucene.Net.Index Namespace


TermPositionVector Members

TermPositionVector overview

Public Instance Methods

GetTermPositions Returns an array of positions in which the term is found. Terms are identified by the index at which its number appears in the term number array obtained from
getTermNumbers
method.

See Also

TermPositionVector Interface | Lucene.Net.Index Namespace


TermPositionVector Methods

The methods of the TermPositionVector interface are listed below. For a complete list of TermPositionVector interface members, see the TermPositionVector Members topic.

Public Instance Methods

GetTermPositions Returns an array of positions in which the term is found. Terms are identified by the index at which its number appears in the term number array obtained from
getTermNumbers
method.

See Also

TermPositionVector Interface | Lucene.Net.Index Namespace


TermPositionVector.GetTermPositions Method

Returns an array of positions in which the term is found. Terms are identified by the index at which its number appears in the term number array obtained from

getTermNumbers
method.

int[] GetTermPositions(
int index
);

See Also

TermPositionVector Interface | Lucene.Net.Index Namespace


TermVectorsReader Class

TODO: relax synchro!

For a list of all members of this type, see TermVectorsReader Members.

System.Object
Lucene.Net.Index.TermVectorsReader

public class TermVectorsReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermVectorsReader Members | Lucene.Net.Index Namespace


TermVectorsReader Members

TermVectorsReader overview

Public Instance Constructors

TermVectorsReader Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Retrieve the term vector for the given document and Field
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace


TermVectorsReader Constructor

public TermVectorsReader(
Directory d,
string segment,
FieldInfos fieldInfos
);

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace


TermVectorsReader Methods

The methods of the TermVectorsReader class are listed below. For a complete list of TermVectorsReader class members, see the TermVectorsReader Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Retrieve the term vector for the given document and Field
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace


TermVectorsReader.Get Method

Retrieve the term vector for the given document and Field

public virtual TermFreqVector Get(
int docNum,
string field
);

Parameters

docNum
The document number to retrieve the vector for
field

Return Value

The TermFreqVector for the document and Field or null

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace


TermVectorsWriter Class

Writer works by opening a document and then opening the fields within the document and then writing out the vectors for each Field. Rough usage: for each document { writer.openDocument(); for each Field on the document { writer.openField(Field); for all of the terms { writer.addTerm(...) } writer.closeField } writer.closeDocument() }

For a list of all members of this type, see TermVectorsWriter Members.

System.Object
Lucene.Net.Index.TermVectorsWriter

public sealed class TermVectorsWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermVectorsWriter Members | Lucene.Net.Index Namespace


TermVectorsWriter Members

TermVectorsWriter overview

Public Static Fields

FORMAT_SIZE
FORMAT_VERSION
TVD_EXTENSION
TVF_EXTENSION
TVX_EXTENSION

Public Instance Constructors

TermVectorsWriter Constructor Create term vectors writer for the specified segment in specified directory. A new TermVectorsWriter should be created for each segment. The parameter
maxFields
indicates how many total fields are found in this document. Not all of these fields may require termvectors to be stored, so the number of calls to
openField
is less or equal to this number.

Public Instance Methods

AddTerm | Add term to the Field's term vector. Field must already be open of NullPointerException is thrown. Terms should be added in increasing order of terms, one call per unique termNum. ProxPointer is a pointer into the TermPosition file (prx). Freq is the number of times this term appears in this Field, in this document.
AddTermFreqVector Add specified vector to the document. Document must be open but no Field should be open or exception is thrown. The same document can have
addTerm
and
addVectors
calls mixed, however a given Field must either be populated with
addTerm
or with
addVector
. *
AddVectors | Add specified vectors to the document.
Close | Close all streams.
CloseDocument
CloseField | Finished processing current Field. This should be followed by a call to openField before future calls to addTerm.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDocumentOpen
IsFieldOpen | Return true if a Field is currently open.
OpenDocument
OpenField | Start processing a Field. This can be followed by a number of calls to addTerm, and a final call to closeField to indicate the end of processing of this Field. If a Field was previously open, it is closed automatically.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter Constructor

Create term vectors writer for the specified segment in specified directory. A new TermVectorsWriter should be created for each segment. The parameter

maxFields
indicates how many total fields are found in this document. Not all of these fields may require termvectors to be stored, so the number of calls to
openField
is less or equal to this number.

public TermVectorsWriter(
Directory directory,
string segment,
FieldInfos fieldInfos
);

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter Fields

The fields of the TermVectorsWriter class are listed below. For a complete list of TermVectorsWriter class members, see the TermVectorsWriter Members topic.

Public Static Fields

FORMAT_SIZE
FORMAT_VERSION
TVD_EXTENSION
TVF_EXTENSION
TVX_EXTENSION

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.FORMAT_SIZE Field

public const int FORMAT_SIZE = 4;

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.FORMAT_VERSION Field

public const int FORMAT_VERSION = 1;

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.TVD_EXTENSION Field

public const string TVD_EXTENSION = ".tvd";

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.TVF_EXTENSION Field

public const string TVF_EXTENSION = ".tvf";

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.TVX_EXTENSION Field

public const string TVX_EXTENSION = ".tvx";

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter Methods

The methods of the TermVectorsWriter class are listed below. For a complete list of TermVectorsWriter class members, see the TermVectorsWriter Members topic.

Public Instance Methods

AddTerm | Add term to the Field's term vector. Field must already be open of NullPointerException is thrown. Terms should be added in increasing order of terms, one call per unique termNum. ProxPointer is a pointer into the TermPosition file (prx). Freq is the number of times this term appears in this Field, in this document.
AddTermFreqVector Add specified vector to the document. Document must be open but no Field should be open or exception is thrown. The same document can have
addTerm
and
addVectors
calls mixed, however a given Field must either be populated with
addTerm
or with
addVector
. *
AddVectors | Add specified vectors to the document.
Close | Close all streams.
CloseDocument
CloseField | Finished processing current Field. This should be followed by a call to openField before future calls to addTerm.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDocumentOpen
IsFieldOpen | Return true if a Field is currently open.
OpenDocument
OpenField | Start processing a Field. This can be followed by a number of calls to addTerm, and a final call to closeField to indicate the end of processing of this Field. If a Field was previously open, it is closed automatically.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.AddTerm Method

Add term to the Field's term vector. Field must already be open of NullPointerException is thrown. Terms should be added in increasing order of terms, one call per unique termNum. ProxPointer is a pointer into the TermPosition file (prx). Freq is the number of times this term appears in this Field, in this document.

public void AddTerm(
string termText,
int freq
);

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.AddTermFreqVector Method

Add specified vector to the document. Document must be open but no Field should be open or exception is thrown. The same document can have

addTerm
and
addVectors
calls mixed, however a given Field must either be populated with
addTerm
or with
addVector
. *

public void AddTermFreqVector(
TermFreqVector vector
);

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.AddVectors Method

Add specified vectors to the document.

public void AddVectors(
TermFreqVector[] vectors
);

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.Close Method

Close all streams.

public void Close();

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.CloseDocument Method

public void CloseDocument();

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.CloseField Method

Finished processing current Field. This should be followed by a call to openField before future calls to addTerm.

public void CloseField();

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.IsDocumentOpen Method

public bool IsDocumentOpen();

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.IsFieldOpen Method

Return true if a Field is currently open.

public bool IsFieldOpen();

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.OpenDocument Method

public void OpenDocument();

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.OpenField Method

Start processing a Field. This can be followed by a number of calls to addTerm, and a final call to closeField to indicate the end of processing of this Field. If a Field was previously open, it is closed automatically.

public void OpenField(
string field
);

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


Lucene.Net.QueryParsers

An NDoc Documented Class Library

Lucene.Net.QueryParsers Namespace

Namespace hierarchy

Classes

Class | Description
FastCharStream |
MultiFieldQueryParser | A QueryParser which constructs queries to search multiple fields.
ParseException | This exception is thrown when parse errors are encountered. You can explicitly create objects of this exception type by calling the method generateParseException in the generated parser. You can modify this class to customize your error reporting mechanisms so long as you retain the public fields.
QueryParser |
QueryParserConstants |
QueryParserTokenManager |
Token | Describes the input token stream.
TokenMgrError |

Interfaces

Interface | Description
CharStream | This interface describes a character stream that maintains line and column number positions of the characters. It also has the capability to backup the stream to some extent. An implementation of this interface is used in the TokenManager implementation generated by JavaCCParser. All the methods except backup can be implemented in any fashion. backup needs to be implemented correctly for the correct operation of the lexer. Rest of the methods are all used to get information like line number, column number and the String that constitutes a token and are not used by the lexer. Hence their implementation won't affect the generated lexer's operation.


CharStream Interface

This interface describes a character stream that maintains line and column number positions of the characters. It also has the capability to backup the stream to some extent. An implementation of this interface is used in the TokenManager implementation generated by JavaCCParser. All the methods except backup can be implemented in any fashion. backup needs to be implemented correctly for the correct operation of the lexer. Rest of the methods are all used to get information like line number, column number and the String that constitutes a token and are not used by the lexer. Hence their implementation won't affect the generated lexer's operation.

For a list of all members of this type, see CharStream Members.

public interface CharStream

Types that implement CharStream

Type | Description
FastCharStream |

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CharStream Members | Lucene.Net.QueryParsers Namespace


CharStream Members

CharStream overview

Public Instance Methods

Backup | Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.
BeginToken | Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.
Done | The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.
GetBeginColumn | Returns the column number of the first character for current token (being matched after the last call to BeginTOken).
GetBeginLine | Returns the line number of the first character for current token (being matched after the last call to BeginTOken).
GetColumn | Returns the column position of the character last read.
GetEndColumn | Returns the column number of the last character for current token (being matched after the last call to BeginTOken).
GetEndLine | Returns the line number of the last character for current token (being matched after the last call to BeginTOken).
GetImage | Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.
GetLine | Returns the line number of the character last read.
GetSuffix | Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }
ReadChar | Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream Methods

The methods of the CharStream interface are listed below. For a complete list of CharStream interface members, see the CharStream Members topic.

Public Instance Methods

Backup | Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.
BeginToken | Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.
Done | The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.
GetBeginColumn | Returns the column number of the first character for current token (being matched after the last call to BeginTOken).
GetBeginLine | Returns the line number of the first character for current token (being matched after the last call to BeginTOken).
GetColumn | Returns the column position of the character last read.
GetEndColumn | Returns the column number of the last character for current token (being matched after the last call to BeginTOken).
GetEndLine | Returns the line number of the last character for current token (being matched after the last call to BeginTOken).
GetImage | Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.
GetLine | Returns the line number of the character last read.
GetSuffix | Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }
ReadChar | Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.Backup Method

Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.

void Backup(
int amount
);

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.BeginToken Method

Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.

char BeginToken();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.Done Method

The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.

void Done();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.GetBeginColumn Method

Returns the column number of the first character for current token (being matched after the last call to BeginTOken).

int GetBeginColumn();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.GetBeginLine Method

Returns the line number of the first character for current token (being matched after the last call to BeginTOken).

int GetBeginLine();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.GetColumn Method

Returns the column position of the character last read.

int GetColumn();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace | #getEndColumn


CharStream.GetEndColumn Method

Returns the column number of the last character for current token (being matched after the last call to BeginTOken).

int GetEndColumn();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.GetEndLine Method

Returns the line number of the last character for current token (being matched after the last call to BeginTOken).

int GetEndLine();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.GetImage Method

Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.

string GetImage();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.GetLine Method

Returns the line number of the character last read.

int GetLine();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace | #getEndLine


CharStream.GetSuffix Method

Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }

char[] GetSuffix(
int len
);

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.ReadChar Method

Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

char ReadChar();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


FastCharStream Class

For a list of all members of this type, see FastCharStream Members.

System.Object
Lucene.Net.QueryParsers.FastCharStream

public sealed class FastCharStream : CharStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FastCharStream Members | Lucene.Net.QueryParsers Namespace


FastCharStream Members

FastCharStream overview

Public Instance Constructors

FastCharStream Constructor Constructs from a Reader.

Public Instance Methods

Backup |
BeginToken |
Done |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBeginColumn |
GetBeginLine |
GetColumn |
GetEndColumn |
GetEndLine |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetImage |
GetLine |
GetSuffix |
GetType (inherited from Object) | Gets the Type of the current instance.
ReadChar |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream Constructor

Constructs from a Reader.

public FastCharStream(
TextReader r
);

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream Methods

The methods of the FastCharStream class are listed below. For a complete list of FastCharStream class members, see the FastCharStream Members topic.

Public Instance Methods

Backup |
BeginToken |
Done |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBeginColumn |
GetBeginLine |
GetColumn |
GetEndColumn |
GetEndLine |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetImage |
GetLine |
GetSuffix |
GetType (inherited from Object) | Gets the Type of the current instance.
ReadChar |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.Backup Method

public void Backup(
int amount
);

Implements

CharStream.Backup

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.BeginToken Method

public char BeginToken();

Implements

CharStream.BeginToken

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.Done Method

public void Done();

Implements

CharStream.Done

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetBeginColumn Method

public int GetBeginColumn();

Implements

CharStream.GetBeginColumn

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetBeginLine Method

public int GetBeginLine();

Implements

CharStream.GetBeginLine

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetColumn Method

public int GetColumn();

Implements

CharStream.GetColumn

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetEndColumn Method

public int GetEndColumn();

Implements

CharStream.GetEndColumn

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetEndLine Method

public int GetEndLine();

Implements

CharStream.GetEndLine

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetImage Method

public string GetImage();

Implements

CharStream.GetImage

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetLine Method

public int GetLine();

Implements

CharStream.GetLine

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetSuffix Method

public char[] GetSuffix(
int len
);

Implements

CharStream.GetSuffix

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.ReadChar Method

public char ReadChar();

Implements

CharStream.ReadChar

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Class

A QueryParser which constructs queries to search multiple fields.

For a list of all members of this type, see MultiFieldQueryParser Members.

System.Object
Lucene.Net.QueryParsers.QueryParserConstants
Lucene.Net.QueryParsers.QueryParser
Lucene.Net.QueryParsers.MultiFieldQueryParser

public class MultiFieldQueryParser : QueryParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MultiFieldQueryParser Members | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Members

MultiFieldQueryParser overview

Public Static Fields

NORMAL_FIELD
PROHIBITED_FIELD
REQUIRED_FIELD

Public Static Methods

Parse Overloaded.

Public Instance Constructors

MultiFieldQueryParser Overloaded. Initializes a new instance of the MultiFieldQueryParser class.

Public Instance Fields

jj_nt (inherited from QueryParser)
lookingAhead (inherited from QueryParser)
token (inherited from QueryParser)
token_source (inherited from QueryParser)

Public Instance Methods

Clause (inherited from QueryParser)
Conjunction (inherited from QueryParser)
Disable_tracing (inherited from QueryParser)
Enable_tracing (inherited from QueryParser)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateParseException (inherited from QueryParser)
GetAnalyzer (inherited from QueryParser)
GetField (inherited from QueryParser)
GetFuzzyMinSim (inherited from QueryParser) | Get the default minimal similarity for fuzzy queries.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLocale (inherited from QueryParser) | Returns current locale, allowing access by subclasses.
GetLowercaseWildcardTerms (inherited from QueryParser)
GetNextToken (inherited from QueryParser)
GetOperator (inherited from QueryParser) | Gets implicit operator setting, which will be either DEFAULT_OPERATOR_AND or DEFAULT_OPERATOR_OR.
GetPhraseSlop (inherited from QueryParser) | Gets the default slop for phrases.
GetToken (inherited from QueryParser)
GetType (inherited from Object) | Gets the Type of the current instance.
Modifiers (inherited from QueryParser)
Parse (inherited from QueryParser) | Overloaded. Parses a query string, returning a Query.
Query (inherited from QueryParser)
ReInit (inherited from QueryParser) | Overloaded.
SetFuzzyMinSim (inherited from QueryParser) | Set the default minimum similarity for fuzzy queries.
SetLocale (inherited from QueryParser) | Set locale used by date range parsing.
SetLowercaseWildcardTerms (inherited from QueryParser)
SetOperator (inherited from QueryParser) Sets the boolean operator of the QueryParser. In classic mode (
DEFAULT_OPERATOR_OR
) terms without any modifiers are considered optional: for example
capital of Hungary
is equal to
capital OR of OR Hungary
.
In
DEFAULT_OPERATOR_AND
terms are considered to be in conjuction: the above mentioned query is parsed as
capital AND of AND Hungary
SetPhraseSlop (inherited from QueryParser) | Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
Term (inherited from QueryParser)
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

AddClause (inherited from QueryParser) |
GetBooleanQuery (inherited from QueryParser) | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
GetFieldQuery (inherited from QueryParser) | Overloaded. Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.
GetFuzzyQuery (inherited from QueryParser) | Overloaded. Factory method for generating a query (similar to ({@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~floatNumber) appended.
GetPrefixQuery (inherited from QueryParser) |
GetRangeQuery (inherited from QueryParser) | Overloaded. Note that parameter analyzer is ignored. Calls inside the parser always use class member analyser. This method will be deprecated and substituted by {@link #GetRangeQuery(String, String, String, boolean)} in future versions of Lucene. Currently overwriting either of these methods works.
GetWildcardQuery (inherited from QueryParser) |

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Constructor

Overload List

public MultiFieldQueryParser(CharStream);

public MultiFieldQueryParser(QueryParserTokenManager);

public MultiFieldQueryParser(string,Analyzer);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Constructor (QueryParserTokenManager)

public MultiFieldQueryParser(
QueryParserTokenManager tm
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace | MultiFieldQueryParser Constructor Overload List


MultiFieldQueryParser Constructor (CharStream)

public MultiFieldQueryParser(
CharStream stream
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace | MultiFieldQueryParser Constructor Overload List


MultiFieldQueryParser Constructor (String, Analyzer)

public MultiFieldQueryParser(
string f,
Analyzer a
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace | MultiFieldQueryParser Constructor Overload List


MultiFieldQueryParser Fields

The fields of the MultiFieldQueryParser class are listed below. For a complete list of MultiFieldQueryParser class members, see the MultiFieldQueryParser Members topic.

Public Static Fields

NORMAL_FIELD
PROHIBITED_FIELD
REQUIRED_FIELD

Public Instance Fields

jj_nt (inherited from QueryParser)
lookingAhead (inherited from QueryParser)
token (inherited from QueryParser)
token_source (inherited from QueryParser)

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser.NORMAL_FIELD Field

public const int NORMAL_FIELD = 0;

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser.PROHIBITED_FIELD Field

public const int PROHIBITED_FIELD = 2;

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser.REQUIRED_FIELD Field

public const int REQUIRED_FIELD = 1;

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Methods

The methods of the MultiFieldQueryParser class are listed below. For a complete list of MultiFieldQueryParser class members, see the MultiFieldQueryParser Members topic.

Public Static Methods

Parse Overloaded.

Public Instance Methods

Clause (inherited from QueryParser)
Conjunction (inherited from QueryParser)
Disable_tracing (inherited from QueryParser)
Enable_tracing (inherited from QueryParser)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateParseException (inherited from QueryParser)
GetAnalyzer (inherited from QueryParser)
GetField (inherited from QueryParser)
GetFuzzyMinSim (inherited from QueryParser) | Get the default minimal similarity for fuzzy queries.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLocale (inherited from QueryParser) | Returns current locale, allowing access by subclasses.
GetLowercaseWildcardTerms (inherited from QueryParser)
GetNextToken (inherited from QueryParser)
GetOperator (inherited from QueryParser) | Gets implicit operator setting, which will be either DEFAULT_OPERATOR_AND or DEFAULT_OPERATOR_OR.
GetPhraseSlop (inherited from QueryParser) | Gets the default slop for phrases.
GetToken (inherited from QueryParser)
GetType (inherited from Object) | Gets the Type of the current instance.
Modifiers (inherited from QueryParser)
Parse (inherited from QueryParser) | Overloaded. Parses a query string, returning a Query.
Query (inherited from QueryParser)
ReInit (inherited from QueryParser) | Overloaded.
SetFuzzyMinSim (inherited from QueryParser) | Set the default minimum similarity for fuzzy queries.
SetLocale (inherited from QueryParser) | Set locale used by date range parsing.
SetLowercaseWildcardTerms (inherited from QueryParser)
SetOperator (inherited from QueryParser) Sets the boolean operator of the QueryParser. In classic mode (
DEFAULT_OPERATOR_OR
) terms without any modifiers are considered optional: for example
capital of Hungary
is equal to
capital OR of OR Hungary
.
In
DEFAULT_OPERATOR_AND
terms are considered to be in conjuction: the above mentioned query is parsed as
capital AND of AND Hungary
SetPhraseSlop (inherited from QueryParser) | Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
Term (inherited from QueryParser)
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

AddClause (inherited from QueryParser) |
GetBooleanQuery (inherited from QueryParser) | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
GetFieldQuery (inherited from QueryParser) | Overloaded. Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.
GetFuzzyQuery (inherited from QueryParser) | Overloaded. Factory method for generating a query (similar to ({@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~floatNumber) appended.
GetPrefixQuery (inherited from QueryParser) |
GetRangeQuery (inherited from QueryParser) | Overloaded. Note that parameter analyzer is ignored. Calls inside the parser always use class member analyser. This method will be deprecated and substituted by {@link #GetRangeQuery(String, String, String, boolean)} in future versions of Lucene. Currently overwriting either of these methods works.
GetWildcardQuery (inherited from QueryParser) |

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


Parse Method

An NDoc Documented Class Library

MultiFieldQueryParser.Parse Method

Overload List

Inherited from QueryParser.

public virtual Query Parse(string);

public static Query Parse(string,string[],Analyzer);

public static Query Parse(string,string[],int[],Analyzer);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser.Parse Method (String, String[], Analyzer)

public static Query Parse(
string query,
string[] fields,
Analyzer analyzer
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace | MultiFieldQueryParser.Parse Overload List


MultiFieldQueryParser.Parse Method (String, String[], Int32[], Analyzer)

public static Query Parse(
string query,
string[] fields,
int[] flags,
Analyzer analyzer
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace | MultiFieldQueryParser.Parse Overload List


ParseException Class

This exception is thrown when parse errors are encountered. You can explicitly create objects of this exception type by calling the method generateParseException in the generated parser. You can modify this class to customize your error reporting mechanisms so long as you retain the public fields.

For a list of all members of this type, see ParseException Members.

System.Object
System.Exception
Lucene.Net.QueryParsers.ParseException

public class ParseException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ParseException Members | Lucene.Net.QueryParsers Namespace


ParseException Members

ParseException overview

Public Instance Constructors

ParseException Overloaded. Initializes a new instance of the ParseException class.

Public Instance Fields

currentToken | This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.
expectedTokenSequences | Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.
tokenImage | This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

eol | The end of line string for this machine.
specialConstructor | This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).

Protected Internal Instance Methods

Add_escapes Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException Constructor

Overload List

The following constructors are for use by you for whatever purpose you can think of. Constructing the exception in this manner makes the exception behave in the normal way - i.e., as documented in the class "Throwable". The fields "errorToken", "expectedTokenSequences", and "tokenImage" do not contain relevant information. The JavaCC generated code does not use these constructors.

public ParseException();

public ParseException(Token,int[][],string[]);

public ParseException(string);

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException Constructor (Token, Int32[][], String[])

public ParseException(
Token currentTokenVal,
int[][] expectedTokenSequencesVal,
string[] tokenImageVal
);

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace | ParseException Constructor Overload List


ParseException Constructor ()

The following constructors are for use by you for whatever purpose you can think of. Constructing the exception in this manner makes the exception behave in the normal way - i.e., as documented in the class "Throwable". The fields "errorToken", "expectedTokenSequences", and "tokenImage" do not contain relevant information. The JavaCC generated code does not use these constructors.

public ParseException();

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace | ParseException Constructor Overload List


ParseException Constructor (String)

public ParseException(
string message
);

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace | ParseException Constructor Overload List


ParseException Fields

The fields of the ParseException class are listed below. For a complete list of ParseException class members, see the ParseException Members topic.

Public Instance Fields

currentToken | This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.
expectedTokenSequences | Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.
tokenImage | This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

Protected Internal Instance Fields

eol | The end of line string for this machine.
specialConstructor | This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException.currentToken Field

This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.

public Token currentToken;

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException.eol Field

The end of line string for this machine.

protected internal string eol;

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException.expectedTokenSequences Field

Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.

public int[][] expectedTokenSequences;

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException.specialConstructor Field

This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).

protected internal bool specialConstructor;

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException.tokenImage Field

This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

public string[] tokenImage;

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException Properties

The properties of the ParseException class are listed below. For a complete list of ParseException class members, see the ParseException Members topic.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


Message Property

An NDoc Documented Class Library

ParseException.Message Property

This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed.

public override string Message {get;}

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException Methods

The methods of the ParseException class are listed below. For a complete list of ParseException class members, see the ParseException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Add_escapes Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException.Add_escapes Method

Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.

protected internal virtual string Add_escapes(
string str
);

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


QueryParser Class

For a list of all members of this type, see QueryParser Members.

System.Object
Lucene.Net.QueryParsers.QueryParserConstants
Lucene.Net.QueryParsers.QueryParser
Lucene.Net.QueryParsers.MultiFieldQueryParser

public class QueryParser : QueryParserConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

QueryParser Members | Lucene.Net.QueryParsers Namespace


QueryParser Members

QueryParser overview

Public Static Fields

DEFAULT_OPERATOR_AND
DEFAULT_OPERATOR_OR

Public Static Methods

Escape Returns a String where those characters that QueryParser expects to be escaped are escaped, i.e. preceded by a
\
.
Main
Parse Overloaded. Parses a query string, returning a {@link Lucene.Net.Search.Query}.

Public Instance Constructors

QueryParser Overloaded. Initializes a new instance of the QueryParser class.

Public Instance Fields

jj_nt
lookingAhead
token
token_source

Public Instance Methods

Clause
Conjunction
Disable_tracing
Enable_tracing
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateParseException
GetAnalyzer
GetField
GetFuzzyMinSim | Get the default minimal similarity for fuzzy queries.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLocale | Returns current locale, allowing access by subclasses.
GetLowercaseWildcardTerms
GetNextToken
GetOperator | Gets implicit operator setting, which will be either DEFAULT_OPERATOR_AND or DEFAULT_OPERATOR_OR.
GetPhraseSlop | Gets the default slop for phrases.
GetToken
GetType (inherited from Object) | Gets the Type of the current instance.
Modifiers
Parse | Overloaded. Parses a query string, returning a Query.
Query
ReInit | Overloaded.
SetFuzzyMinSim | Set the default minimum similarity for fuzzy queries.
SetLocale | Set locale used by date range parsing.
SetLowercaseWildcardTerms
SetOperator Sets the boolean operator of the QueryParser. In classic mode (
DEFAULT_OPERATOR_OR
) terms without any modifiers are considered optional: for example
capital of Hungary
is equal to
capital OR of OR Hungary
.
In
DEFAULT_OPERATOR_AND
terms are considered to be in conjuction: the above mentioned query is parsed as
capital AND of AND Hungary
SetPhraseSlop | Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
Term
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

AddClause |
GetBooleanQuery | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
GetFieldQuery | Overloaded. Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.
GetFuzzyQuery | Overloaded. Factory method for generating a query (similar to ({@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~floatNumber) appended.
GetPrefixQuery |
GetRangeQuery | Overloaded.
GetWildcardQuery |

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser Constructor

Constructs a query parser.

Overload List

public QueryParser(CharStream);

public QueryParser(QueryParserTokenManager);

Constructs a query parser.

public QueryParser(string,Analyzer);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser Constructor (String, Analyzer)

Constructs a query parser.

public QueryParser(
string f,
Analyzer a
);

Parameters

f
the default Field for query terms.
a
used to find terms in the query text.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser Constructor Overload List


QueryParser Constructor (CharStream)

public QueryParser(
CharStream stream
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser Constructor Overload List


QueryParser Constructor (QueryParserTokenManager)

public QueryParser(
QueryParserTokenManager tm
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser Constructor Overload List


QueryParser Fields

The fields of the QueryParser class are listed below. For a complete list of QueryParser class members, see the QueryParser Members topic.

Public Static Fields

DEFAULT_OPERATOR_AND
DEFAULT_OPERATOR_OR

Public Instance Fields

jj_nt
lookingAhead
token
token_source

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.DEFAULT_OPERATOR_AND Field

public const int DEFAULT_OPERATOR_AND = 1;

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.DEFAULT_OPERATOR_OR Field

public const int DEFAULT_OPERATOR_OR = 0;

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.jj_nt Field

public Token jj_nt;

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.lookingAhead Field

public bool lookingAhead;

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.token Field

public Token token;

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.token_source Field

public QueryParserTokenManager token_source;

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser Methods

The methods of the QueryParser class are listed below. For a complete list of QueryParser class members, see the QueryParser Members topic.

Public Static Methods

Escape Returns a String where those characters that QueryParser expects to be escaped are escaped, i.e. preceded by a
\
.
Main
Parse Overloaded. Parses a query string, returning a {@link Lucene.Net.Search.Query}.

Public Instance Methods

Clause
Conjunction
Disable_tracing
Enable_tracing
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateParseException
GetAnalyzer
GetField
GetFuzzyMinSim | Get the default minimal similarity for fuzzy queries.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLocale | Returns current locale, allowing access by subclasses.
GetLowercaseWildcardTerms
GetNextToken
GetOperator | Gets implicit operator setting, which will be either DEFAULT_OPERATOR_AND or DEFAULT_OPERATOR_OR.
GetPhraseSlop | Gets the default slop for phrases.
GetToken
GetType (inherited from Object) | Gets the Type of the current instance.
Modifiers
Parse | Overloaded. Parses a query string, returning a Query.
Query
ReInit | Overloaded.
SetFuzzyMinSim | Set the default minimum similarity for fuzzy queries.
SetLocale | Set locale used by date range parsing.
SetLowercaseWildcardTerms
SetOperator Sets the boolean operator of the QueryParser. In classic mode (
DEFAULT_OPERATOR_OR
) terms without any modifiers are considered optional: for example
capital of Hungary
is equal to
capital OR of OR Hungary
.
In
DEFAULT_OPERATOR_AND
terms are considered to be in conjuction: the above mentioned query is parsed as
capital AND of AND Hungary
SetPhraseSlop | Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
Term
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

AddClause |
GetBooleanQuery | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
GetFieldQuery | Overloaded. Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.
GetFuzzyQuery | Overloaded. Factory method for generating a query (similar to ({@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~floatNumber) appended.
GetPrefixQuery |
GetRangeQuery | Overloaded.
GetWildcardQuery |

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.AddClause Method

protected internal virtual void AddClause(
ArrayList clauses,
int conj,
int mods,
Query q
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Clause Method

public Query Clause(
string field
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Conjunction Method

public int Conjunction();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Disable_tracing Method

public void Disable_tracing();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Enable_tracing Method

public void Enable_tracing();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Escape Method

Returns a String where those characters that QueryParser expects to be escaped are escaped, i.e. preceded by a

\
.

public static string Escape(
string s
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GenerateParseException Method

public virtual ParseException GenerateParseException();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetAnalyzer Method

public virtual Analyzer GetAnalyzer();

Return Value

Returns the analyzer.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetBooleanQuery Method

Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

protected internal virtual Query GetBooleanQuery(
ArrayList clauses
);

Parameters

clauses
Vector that contains {@link BooleanClause} instances to join.

Return Value

Resulting {@link Query} object.

Exceptions

Exception Type | Condition
 | ParseException throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetField Method

public virtual string GetField();

Return Value

Returns the field.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


GetFieldQuery Method

An NDoc Documented Class Library

QueryParser.GetFieldQuery Method

Note that parameter analyzer is ignored. Calls inside the parser always use class member analyser. This method will be deprecated and substituted by {@link #GetFieldQuery(String, String)} in future versions of Lucene. Currently overwriting either of these methods works.

Overload List

Note that parameter analyzer is ignored. Calls inside the parser always use class member analyser. This method will be deprecated and substituted by {@link #GetFieldQuery(String, String)} in future versions of Lucene. Currently overwriting either of these methods works.

protected internal virtual Query GetFieldQuery(string,Analyzer,string);

Base implementation delegates to {@link #GetFieldQuery(String, Analyzer, String)}. This method may be overwritten, for example, to return a SpanNearQuery instead of a PhraseQuery. Note that parameter analyzer is ignored. Calls inside the parser always use class member analyser. This method will be deprecated and substituted by {@link #GetFieldQuery(String, String, int)} in future versions of Lucene. Currently overwriting either of these methods works.

protected internal virtual Query GetFieldQuery(string,Analyzer,string,int);

protected internal virtual Query GetFieldQuery(string,string);

Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.

protected internal virtual Query GetFieldQuery(string,string,int);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetFieldQuery Method (String, Analyzer, String)

Note that parameter analyzer is ignored. Calls inside the parser always use class member analyser. This method will be deprecated and substituted by {@link #GetFieldQuery(String, String)} in future versions of Lucene. Currently overwriting either of these methods works.

protected internal virtual Query GetFieldQuery(
string field,
Analyzer analyzer,
string queryText
);

Exceptions

Exception Type | Condition
 | ParseException throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.GetFieldQuery Overload List


QueryParser.GetFieldQuery Method (String, Analyzer, String, Int32)

Base implementation delegates to {@link #GetFieldQuery(String, Analyzer, String)}. This method may be overwritten, for example, to return a SpanNearQuery instead of a PhraseQuery. Note that parameter analyzer is ignored. Calls inside the parser always use class member analyser. This method will be deprecated and substituted by {@link #GetFieldQuery(String, String, int)} in future versions of Lucene. Currently overwriting either of these methods works.

protected internal virtual Query GetFieldQuery(
string field,
Analyzer analyzer,
string queryText,
int slop
);

Exceptions

Exception Type | Condition
 | ParseException throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.GetFieldQuery Overload List


QueryParser.GetFieldQuery Method (String, String)

protected internal virtual Query GetFieldQuery(
string field,
string queryText
);

Exceptions

Exception Type | Condition
 | ParseException throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.GetFieldQuery Overload List


QueryParser.GetFieldQuery Method (String, String, Int32)

Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.

protected internal virtual Query GetFieldQuery(
string field,
string queryText,
int slop
);

Exceptions

Exception Type | Condition
 | ParseException throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.GetFieldQuery Overload List


QueryParser.GetFuzzyMinSim Method

Get the default minimal similarity for fuzzy queries.

public virtual float GetFuzzyMinSim();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


GetFuzzyQuery Method

An NDoc Documented Class Library

QueryParser.GetFuzzyQuery Method

Factory method for generating a query (similar to ({@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~) appended.

Overload List

Factory method for generating a query (similar to ({@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~) appended.

protected internal virtual Query GetFuzzyQuery(string,string);

Factory method for generating a query (similar to ({@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~floatNumber) appended.

protected internal virtual Query GetFuzzyQuery(string,string,float);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetFuzzyQuery Method (String, String)

Factory method for generating a query (similar to ({@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~) appended.

protected internal virtual Query GetFuzzyQuery(
string field,
string termStr
);

Parameters

field
Name of the field query will use.
termStr
Term token to use for building term for the query

Return Value

Resulting {@link Query} built for the term

Exceptions

Exception Type | Condition
 | ParseException throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.GetFuzzyQuery Overload List


QueryParser.GetFuzzyQuery Method (String, String, Single)

Factory method for generating a query (similar to ({@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~floatNumber) appended.

protected internal virtual Query GetFuzzyQuery(
string field,
string termStr,
float minSimilarity
);

Parameters

field
Name of the field query will use.
termStr
Term token to use for building term for the query
minSimilarity
the minimum similarity required for a fuzzy match

Return Value

Resulting {@link Query} built for the term

Exceptions

Exception Type | Condition
 | ParseException throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.GetFuzzyQuery Overload List


QueryParser.GetLocale Method

Returns current locale, allowing access by subclasses.

public virtual CultureInfo GetLocale();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetLowercaseWildcardTerms Method

public virtual bool GetLowercaseWildcardTerms();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetNextToken Method

public Token GetNextToken();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetOperator Method

Gets implicit operator setting, which will be either DEFAULT_OPERATOR_AND or DEFAULT_OPERATOR_OR.

public virtual int GetOperator();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetPhraseSlop Method

Gets the default slop for phrases.

public virtual int GetPhraseSlop();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetPrefixQuery Method

protected internal virtual Query GetPrefixQuery(
string field,
string termStr
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


GetRangeQuery Method

An NDoc Documented Class Library

QueryParser.GetRangeQuery Method

Note that parameter analyzer is ignored. Calls inside the parser always use class member analyser. This method will be deprecated and substituted by {@link #GetRangeQuery(String, String, String, boolean)} in future versions of Lucene. Currently overwriting either of these methods works.

Overload List

Note that parameter analyzer is ignored. Calls inside the parser always use class member analyser. This method will be deprecated and substituted by {@link #GetRangeQuery(String, String, String, boolean)} in future versions of Lucene. Currently overwriting either of these methods works.

protected internal virtual Query GetRangeQuery(string,Analyzer,string,string,bool);

protected internal virtual Query GetRangeQuery(string,string,string,bool);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetRangeQuery Method (String, Analyzer, String, String, Boolean)

Note that parameter analyzer is ignored. Calls inside the parser always use class member analyser. This method will be deprecated and substituted by {@link #GetRangeQuery(String, String, String, boolean)} in future versions of Lucene. Currently overwriting either of these methods works.

protected internal virtual Query GetRangeQuery(
string field,
Analyzer analyzer,
string part1,
string part2,
bool inclusive
);

Exceptions

Exception Type | Condition
 | ParseException throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.GetRangeQuery Overload List


QueryParser.GetRangeQuery Method (String, String, String, Boolean)

protected internal virtual Query GetRangeQuery(
string field,
string part1,
string part2,
bool inclusive
);

Exceptions

Exception Type | Condition
 | ParseException throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.GetRangeQuery Overload List


QueryParser.GetToken Method

public Token GetToken(
int index
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetWildcardQuery Method

protected internal virtual Query GetWildcardQuery(
string field,
string termStr
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Main Method

public static void Main(
string[] args
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Modifiers Method

public int Modifiers();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


Parse Method

An NDoc Documented Class Library

QueryParser.Parse Method

Parses a query string, returning a Query.

Overload List

Parses a query string, returning a Query.

public virtual Query Parse(string);

Parses a query string, returning a {@link Lucene.Net.Search.Query}.

public static Query Parse(string,string,Analyzer);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Parse Method (String)

Parses a query string, returning a Query.

public virtual Query Parse(
string query
);

Parameters

query
the query string to be parsed.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.Parse Overload List


QueryParser.Parse Method (String, String, Analyzer)

Parses a query string, returning a {@link Lucene.Net.Search.Query}.

public static Query Parse(
string query,
string field,
Analyzer analyzer
);

Parameters

query
the query string to be parsed.
field
the default Field for query terms.
analyzer
used to find terms in the query text.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.Parse Overload List


QueryParser.Query Method

public Query Query(
string field
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


ReInit Method

An NDoc Documented Class Library

QueryParser.ReInit Method

Overload List

public virtual void ReInit(CharStream);

public virtual void ReInit(QueryParserTokenManager);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.ReInit Method (CharStream)

public virtual void ReInit(
CharStream stream
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.ReInit Overload List


QueryParser.ReInit Method (QueryParserTokenManager)

public virtual void ReInit(
QueryParserTokenManager tm
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.ReInit Overload List


QueryParser.SetFuzzyMinSim Method

Set the default minimum similarity for fuzzy queries.

public virtual void SetFuzzyMinSim(
float fuzzyMinSim
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetLocale Method

Set locale used by date range parsing.

public virtual void SetLocale(
CultureInfo locale
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetLowercaseWildcardTerms Method

public virtual void SetLowercaseWildcardTerms(
bool lowercaseWildcardTerms
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetOperator Method

Sets the boolean operator of the QueryParser. In classic mode (

DEFAULT_OPERATOR_OR
) terms without any modifiers are considered optional: for example
capital of Hungary
is equal to
capital OR of OR Hungary
.
In
DEFAULT_OPERATOR_AND
terms are considered to be in conjuction: the above mentioned query is parsed as
capital AND of AND Hungary

public virtual void SetOperator(
int operator_Renamed
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetPhraseSlop Method

Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.

public virtual void SetPhraseSlop(
int phraseSlop
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Term Method

public Query Term(
string field
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants Class

For a list of all members of this type, see QueryParserConstants Members.

System.Object
Lucene.Net.QueryParsers.QueryParserConstants
Lucene.Net.QueryParsers.QueryParser
Lucene.Net.QueryParsers.QueryParserTokenManager

public class QueryParserConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

QueryParserConstants Members | Lucene.Net.QueryParsers Namespace


QueryParserConstants Members

QueryParserConstants overview

Public Static Fields

_ESCAPED_CHAR
_NUM_CHAR
_TERM_CHAR
_TERM_START_CHAR
_WHITESPACE
AND
Boost
CARAT
COLON
DEFAULT
EOF
FUZZY_SLOP
LPAREN
MINUS
NOT
NUMBER
OR
PLUS
PREFIXTERM
QUOTED
RangeEx
RANGEEX_END
RANGEEX_GOOP
RANGEEX_QUOTED
RANGEEX_START
RANGEEX_TO
RangeIn
RANGEIN_END
RANGEIN_GOOP
RANGEIN_QUOTED
RANGEIN_START
RANGEIN_TO
RPAREN
TERM
tokenImage
WILDTERM

Public Instance Constructors

QueryParserConstants Constructor Initializes a new instance of the QueryParserConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants Constructor

Initializes a new instance of the QueryParserConstants class.

public QueryParserConstants();

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants Fields

The fields of the QueryParserConstants class are listed below. For a complete list of QueryParserConstants class members, see the QueryParserConstants Members topic.

Public Static Fields

_ESCAPED_CHAR
_NUM_CHAR
_TERM_CHAR
_TERM_START_CHAR
_WHITESPACE
AND
Boost
CARAT
COLON
DEFAULT
EOF
FUZZY_SLOP
LPAREN
MINUS
NOT
NUMBER
OR
PLUS
PREFIXTERM
QUOTED
RangeEx
RANGEEX_END
RANGEEX_GOOP
RANGEEX_QUOTED
RANGEEX_START
RANGEEX_TO
RangeIn
RANGEIN_END
RANGEIN_GOOP
RANGEIN_QUOTED
RANGEIN_START
RANGEIN_TO
RPAREN
TERM
tokenImage
WILDTERM

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants._ESCAPED_CHAR Field

public const int _ESCAPED_CHAR = 2;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants._NUM_CHAR Field

public const int _NUM_CHAR = 1;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants._TERM_CHAR Field

public const int _TERM_CHAR = 4;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants._TERM_START_CHAR Field

public const int _TERM_START_CHAR = 3;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants._WHITESPACE Field

public const int _WHITESPACE = 5;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.AND Field

public const int AND = 7;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.Boost Field

public const int Boost = 0;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.CARAT Field

public const int CARAT = 15;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.COLON Field

public const int COLON = 14;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.DEFAULT Field

public const int DEFAULT = 3;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.EOF Field

public const int EOF = 0;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.FUZZY_SLOP Field

public const int FUZZY_SLOP = 18;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.LPAREN Field

public const int LPAREN = 12;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.MINUS Field

public const int MINUS = 11;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.NOT Field

public const int NOT = 9;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.NUMBER Field

public const int NUMBER = 23;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.OR Field

public const int OR = 8;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.PLUS Field

public const int PLUS = 10;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.PREFIXTERM Field

public const int PREFIXTERM = 19;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.QUOTED Field

public const int QUOTED = 16;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RangeEx Field

public const int RangeEx = 1;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEEX_END Field

public const int RANGEEX_END = 29;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEEX_GOOP Field

public const int RANGEEX_GOOP = 31;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEEX_QUOTED Field

public const int RANGEEX_QUOTED = 30;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEEX_START Field

public const int RANGEEX_START = 22;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEEX_TO Field

public const int RANGEEX_TO = 28;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RangeIn Field

public const int RangeIn = 2;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEIN_END Field

public const int RANGEIN_END = 25;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEIN_GOOP Field

public const int RANGEIN_GOOP = 27;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEIN_QUOTED Field

public const int RANGEIN_QUOTED = 26;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEIN_START Field

public const int RANGEIN_START = 21;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEIN_TO Field

public const int RANGEIN_TO = 24;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RPAREN Field

public const int RPAREN = 13;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.TERM Field

public const int TERM = 17;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.tokenImage Field

public static string[] tokenImage;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.WILDTERM Field

public const int WILDTERM = 20;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Class

For a list of all members of this type, see QueryParserTokenManager Members.

System.Object
Lucene.Net.QueryParsers.QueryParserConstants
Lucene.Net.QueryParsers.QueryParserTokenManager

public class QueryParserTokenManager : QueryParserConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

QueryParserTokenManager Members | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Members

QueryParserTokenManager overview

Public Static Fields

jjnewLexState
jjstrLiteralImages
lexStateNames

Public Instance Constructors

QueryParserTokenManager Overloaded. Initializes a new instance of the QueryParserTokenManager class.

Public Instance Fields

debugStream

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextToken |
GetType (inherited from Object) | Gets the Type of the current instance.
ReInit | Overloaded.
SetDebugStream |
SwitchTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

curChar
input_stream

Protected Internal Instance Methods

JjFillToken

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Constructor

Overload List

public QueryParserTokenManager(CharStream);

public QueryParserTokenManager(CharStream,int);

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Constructor (CharStream)

public QueryParserTokenManager(
CharStream stream
);

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace | QueryParserTokenManager Constructor Overload List


QueryParserTokenManager Constructor (CharStream, Int32)

public QueryParserTokenManager(
CharStream stream,
int lexState
);

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace | QueryParserTokenManager Constructor Overload List


QueryParserTokenManager Fields

The fields of the QueryParserTokenManager class are listed below. For a complete list of QueryParserTokenManager class members, see the QueryParserTokenManager Members topic.

Public Static Fields

jjnewLexState
jjstrLiteralImages
lexStateNames

Public Instance Fields

debugStream

Protected Internal Instance Fields

curChar
input_stream

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.curChar Field

protected internal char curChar;

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.debugStream Field

public StreamWriter debugStream;

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.input_stream Field

protected internal CharStream input_stream;

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.jjnewLexState Field

public static readonly int[] jjnewLexState;

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.jjstrLiteralImages Field

public static readonly string[] jjstrLiteralImages;

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.lexStateNames Field

public static readonly string[] lexStateNames;

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Methods

The methods of the QueryParserTokenManager class are listed below. For a complete list of QueryParserTokenManager class members, see the QueryParserTokenManager Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextToken |
GetType (inherited from Object) | Gets the Type of the current instance.
ReInit | Overloaded.
SetDebugStream |
SwitchTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

JjFillToken

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.GetNextToken Method

public virtual Token GetNextToken();

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.JjFillToken Method

protected internal virtual Token JjFillToken();

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


ReInit Method

An NDoc Documented Class Library

QueryParserTokenManager.ReInit Method

Overload List

public virtual void ReInit(CharStream);

public virtual void ReInit(CharStream,int);

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.ReInit Method (CharStream)

public virtual void ReInit(
CharStream stream
);

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace | QueryParserTokenManager.ReInit Overload List


QueryParserTokenManager.ReInit Method (CharStream, Int32)

public virtual void ReInit(
CharStream stream,
int lexState
);

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace | QueryParserTokenManager.ReInit Overload List


QueryParserTokenManager.SetDebugStream Method

public virtual void SetDebugStream(
StreamWriter ds
);

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.SwitchTo Method

public virtual void SwitchTo(
int lexState
);

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


Token Class

Describes the input token stream.

For a list of all members of this type, see Token Members.

System.Object
Lucene.Net.QueryParsers.Token

public class Token

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Token Members | Lucene.Net.QueryParsers Namespace


Token Members

Token overview

Public Static Methods

NewToken Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simlpy add something like : case MyParserConstants.ID : return new IDToken(); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use it in your lexical actions.

Public Instance Constructors

Token Constructor Initializes a new instance of the Token class.

Public Instance Fields

beginColumn | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
beginLine | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
endColumn | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
endLine | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
image | The string image of the token.
kind | An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.
next | A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this Field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this Field.
specialToken | This Field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this Field is set to null. When there are more than one such special token, this Field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken Field, and so on until the first special token (whose specialToken Field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this Field is null.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the image.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token Constructor

Initializes a new instance of the Token class.

public Token();

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token Fields

The fields of the Token class are listed below. For a complete list of Token class members, see the Token Members topic.

Public Instance Fields

beginColumn | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
beginLine | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
endColumn | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
endLine | beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.
image | The string image of the token.
kind | An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.
next | A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this Field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this Field.
specialToken | This Field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this Field is set to null. When there are more than one such special token, this Field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken Field, and so on until the first special token (whose specialToken Field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this Field is null.

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.beginColumn Field

beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.

public int beginColumn;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.beginLine Field

beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.

public int beginLine;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.endColumn Field

beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.

public int endColumn;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.endLine Field

beginLine and beginColumn describe the position of the first character of this token; endLine and endColumn describe the position of the last character of this token.

public int endLine;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.image Field

The string image of the token.

public string image;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.kind Field

An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.

public int kind;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.next Field

A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this Field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this Field.

public Token next;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.specialToken Field

This Field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this Field is set to null. When there are more than one such special token, this Field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken Field, and so on until the first special token (whose specialToken Field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this Field is null.

public Token specialToken;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token Methods

The methods of the Token class are listed below. For a complete list of Token class members, see the Token Members topic.

Public Static Methods

NewToken Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simlpy add something like : case MyParserConstants.ID : return new IDToken(); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use it in your lexical actions.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the image.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.NewToken Method

Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simlpy add something like : case MyParserConstants.ID : return new IDToken(); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use it in your lexical actions.

public static Token NewToken(
int ofKind
);

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.ToString Method

Returns the image.

public override string ToString();

See Also

Token Class | Lucene.Net.QueryParsers Namespace


TokenMgrError Class

For a list of all members of this type, see TokenMgrError Members.

System.Object
System.Exception
System.ApplicationException
Lucene.Net.QueryParsers.TokenMgrError

public class TokenMgrError : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TokenMgrError Members | Lucene.Net.QueryParsers Namespace


TokenMgrError Members

TokenMgrError overview

Protected Internal Static Methods

addEscapes | Replaces unprintable characters by their espaced (or unicode escaped) equivalents in the given string
LexicalError | Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexicl error curLexState : lexical state in which this error occured errorLine : line number when the error occured errorColumn : column number when the error occured errorAfter : prefix that was seen before this error occured curchar : the offending character Note: You can customize the lexical error message by modifying this method.

Public Instance Constructors

TokenMgrError Overloaded. Initializes a new instance of the TokenMgrError class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


TokenMgrError Constructor

Initializes a new instance of the TokenMgrError class.

Overload List

Initializes a new instance of the TokenMgrError class.

public TokenMgrError();

public TokenMgrError(bool,int,int,int,string,char,int);

public TokenMgrError(string,int);

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


TokenMgrError Constructor ()

Initializes a new instance of the TokenMgrError class.

public TokenMgrError();

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace | TokenMgrError Constructor Overload List


TokenMgrError Constructor (String, Int32)

public TokenMgrError(
string message,
int reason
);

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace | TokenMgrError Constructor Overload List


TokenMgrError Constructor (Boolean, Int32, Int32, Int32, String, Char, Int32)

public TokenMgrError(
bool EOFSeen,
int lexState,
int errorLine,
int errorColumn,
string errorAfter,
char curChar,
int reason
);

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace | TokenMgrError Constructor Overload List


TokenMgrError Properties

The properties of the TokenMgrError class are listed below. For a complete list of TokenMgrError class members, see the TokenMgrError Members topic.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


Message Property

An NDoc Documented Class Library

TokenMgrError.Message Property

You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser.

public override string Message {get;}

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


TokenMgrError Methods

The methods of the TokenMgrError class are listed below. For a complete list of TokenMgrError class members, see the TokenMgrError Members topic.

Protected Internal Static Methods

addEscapes | Replaces unprintable characters by their espaced (or unicode escaped) equivalents in the given string
LexicalError | Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexicl error curLexState : lexical state in which this error occured errorLine : line number when the error occured errorColumn : column number when the error occured errorAfter : prefix that was seen before this error occured curchar : the offending character Note: You can customize the lexical error message by modifying this method.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


TokenMgrError.addEscapes Method

Replaces unprintable characters by their espaced (or unicode escaped) equivalents in the given string

protected internal static string addEscapes(
string str
);

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


TokenMgrError.LexicalError Method

Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexicl error curLexState : lexical state in which this error occured errorLine : line number when the error occured errorColumn : column number when the error occured errorAfter : prefix that was seen before this error occured curchar : the offending character Note: You can customize the lexical error message by modifying this method.

protected internal static string LexicalError(
bool EOFSeen,
int lexState,
int errorLine,
int errorColumn,
string errorAfter,
char curChar
);

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


Lucene.Net.Search

An NDoc Documented Class Library

Lucene.Net.Search Namespace

Namespace hierarchy

Classes

Class | Description
AnonymousClassScoreDocComparator
AnonymousClassScoreDocComparator1
BooleanClause | A clause in a BooleanQuery.
BooleanQuery | A Query that matches documents matching boolean combinations of other queries, typically {@link TermQuery}s or {@link PhraseQuery}s.
BooleanQuery.TooManyClauses | Thrown when an attempt is made to add more than {@link #GetMaxClauseCount()} clauses.
CachingWrapperFilter | Wraps another filters result and caches it. The caching behavior is like {@link QueryFilter}. The purpose is to allow filters to simply filter, and then wrap with this class to add caching, keeping the two concerns decoupled yet composable.
DateFilter
DefaultSimilarity | Expert: Default scoring implementation.
Explanation | Expert: Describes the score computation for document and query.
FieldDoc
Filter | Abstract base class providing a mechanism to restrict searches to a subset of an index.
FilteredQuery
FilteredTermEnum
FuzzyQuery | Implements the fuzzy search query. The similiarity measurement is based on the Levenshtein (edit distance) algorithm.
FuzzyTermEnum
HitCollector | Lower-level search API.
Hits | A ranked list of documents, used to hold search results.
IndexSearcher
MultiSearcher
MultiTermQuery
ParallelMultiSearcher
PhrasePrefixQuery | PhrasePrefixQuery is a generalized version of PhraseQuery, with an added method {@link #Add(Term[])}. To use this class, to search for the phrase "Microsoft app*" first use add(Term) on the term "Microsoft", then find all terms that has "app" as prefix using IndexReader.terms(Term), and use PhrasePrefixQuery.add(Term[] terms) to add them to the query.
PhraseQuery | A Query that matches documents containing a particular sequence of terms. This may be combined with other terms with a {@link BooleanQuery}.
PrefixQuery | A Query that matches documents containing terms with a specified prefix.
Query
QueryFilter
QueryTermVector
RangeQuery | A Query that matches documents within an exclusive range.
RemoteSearchable | A remote searchable implementation.
ScoreDoc | Expert: Returned by low-level search implementations.
Scorer | Expert: Implements scoring for a class of queries.
Searcher | An abstract base class for search implementations. Implements some common utility methods.
Similarity
Sort
SortComparator
SortField
StringIndex
TermQuery | A Query that matches documents containing a term. This may be combined with other terms with a {@link BooleanQuery}.
TopDocs | Expert: Returned by low-level search implementations.
TopFieldDocs
WildcardQuery Implements the wildcard search query. Supported wildcards are
*
, which matches any character sequence (including the empty one), and
?
, which matches any single character. Note this query can be slow, as it needs to iterate over all terms. In order to prevent extremely slow WildcardQueries, a Wildcard term must not start with one of the wildcards
*
or
?
.
WildcardTermEnum

Interfaces

Interface | Description
FieldCache |
ScoreDocComparator |
Searchable |
SortComparatorSource |
Weight |

Structures

Structure | Description
FieldCache_Fields |
ScoreDocComparator_Fields |


AnonymousClassScoreDocComparator Class

For a list of all members of this type, see AnonymousClassScoreDocComparator Members.

System.Object
Lucene.Net.Search.AnonymousClassScoreDocComparator

public class AnonymousClassScoreDocComparator : ScoreDocComparator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

AnonymousClassScoreDocComparator Members | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator Members

AnonymousClassScoreDocComparator overview

Public Instance Constructors

AnonymousClassScoreDocComparator Constructor Initializes a new instance of the AnonymousClassScoreDocComparator class.

Public Instance Methods

Compare |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SortType |
SortValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AnonymousClassScoreDocComparator Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator Constructor

Initializes a new instance of the AnonymousClassScoreDocComparator class.

public AnonymousClassScoreDocComparator();

See Also

AnonymousClassScoreDocComparator Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator Methods

The methods of the AnonymousClassScoreDocComparator class are listed below. For a complete list of AnonymousClassScoreDocComparator class members, see the AnonymousClassScoreDocComparator Members topic.

Public Instance Methods

Compare |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SortType |
SortValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AnonymousClassScoreDocComparator Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator.Compare Method

public virtual int Compare(
ScoreDoc i,
ScoreDoc j
);

Implements

ScoreDocComparator.Compare

See Also

AnonymousClassScoreDocComparator Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator.SortType Method

public virtual int SortType();

Implements

ScoreDocComparator.SortType

See Also

AnonymousClassScoreDocComparator Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator.SortValue Method

public virtual IComparable SortValue(
ScoreDoc i
);

Implements

ScoreDocComparator.SortValue

See Also

AnonymousClassScoreDocComparator Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1 Class

For a list of all members of this type, see AnonymousClassScoreDocComparator1 Members.

System.Object
Lucene.Net.Search.AnonymousClassScoreDocComparator1

public class AnonymousClassScoreDocComparator1 : ScoreDocComparator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

AnonymousClassScoreDocComparator1 Members | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1 Members

AnonymousClassScoreDocComparator1 overview

Public Instance Constructors

AnonymousClassScoreDocComparator1 Constructor Initializes a new instance of the AnonymousClassScoreDocComparator1 class.

Public Instance Methods

Compare |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SortType |
SortValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AnonymousClassScoreDocComparator1 Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1 Constructor

Initializes a new instance of the AnonymousClassScoreDocComparator1 class.

public AnonymousClassScoreDocComparator1();

See Also

AnonymousClassScoreDocComparator1 Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1 Methods

The methods of the AnonymousClassScoreDocComparator1 class are listed below. For a complete list of AnonymousClassScoreDocComparator1 class members, see the AnonymousClassScoreDocComparator1 Members topic.

Public Instance Methods

Compare |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SortType |
SortValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AnonymousClassScoreDocComparator1 Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1.Compare Method

public virtual int Compare(
ScoreDoc i,
ScoreDoc j
);

Implements

ScoreDocComparator.Compare

See Also

AnonymousClassScoreDocComparator1 Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1.SortType Method

public virtual int SortType();

Implements

ScoreDocComparator.SortType

See Also

AnonymousClassScoreDocComparator1 Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1.SortValue Method

public virtual IComparable SortValue(
ScoreDoc i
);

Implements

ScoreDocComparator.SortValue

See Also

AnonymousClassScoreDocComparator1 Class | Lucene.Net.Search Namespace


BooleanClause Class

A clause in a BooleanQuery.

For a list of all members of this type, see BooleanClause Members.

System.Object
Lucene.Net.Search.BooleanClause

public class BooleanClause

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BooleanClause Members | Lucene.Net.Search Namespace


BooleanClause Members

BooleanClause overview

Public Instance Constructors

BooleanClause Constructor Constructs a BooleanClause with query
q
, required
r
and prohibited
p
.

Public Instance Fields

prohibited | If true, documents documents which do match this sub-query will not match the boolean query.
query | The query whose matching documents are combined by the boolean query.
required | If true, documents documents which do not match this sub-query will not match the boolean query.

Public Instance Methods

Equals Returns true iff
o
is equal to this.
GetHashCode | Returns a hash code value for this object.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause Constructor

Constructs a BooleanClause with query

q
, required
r
and prohibited
p
.

public BooleanClause(
Query q,
bool r,
bool p
);

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause Fields

The fields of the BooleanClause class are listed below. For a complete list of BooleanClause class members, see the BooleanClause Members topic.

Public Instance Fields

prohibited | If true, documents documents which do match this sub-query will not match the boolean query.
query | The query whose matching documents are combined by the boolean query.
required | If true, documents documents which do not match this sub-query will not match the boolean query.

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.prohibited Field

If true, documents documents which do match this sub-query will not match the boolean query.

public bool prohibited;

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.query Field

The query whose matching documents are combined by the boolean query.

public Query query;

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.required Field

If true, documents documents which do not match this sub-query will not match the boolean query.

public bool required;

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause Methods

The methods of the BooleanClause class are listed below. For a complete list of BooleanClause class members, see the BooleanClause Members topic.

Public Instance Methods

Equals Returns true iff
o
is equal to this.
GetHashCode | Returns a hash code value for this object.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanQuery Class

A Query that matches documents matching boolean combinations of other queries, typically {@link TermQuery}s or {@link PhraseQuery}s.

For a list of all members of this type, see BooleanQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.BooleanQuery

public class BooleanQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BooleanQuery Members | Lucene.Net.Search Namespace


BooleanQuery Members

BooleanQuery overview

Public Static Fields

maxClauseCount Default value is 1024. Use
Lucene.Net.maxClauseCount
system property to override.

Public Static Methods

GetMaxClauseCount | Return the maximum number of clauses permitted, 1024 by default. Attempts to add more than the permitted number of clauses cause {@link TooManyClauses} to be thrown.
SetMaxClauseCount | Set the maximum number of clauses permitted.

Public Instance Constructors

BooleanQuery Constructor Constructs an empty boolean query.

Public Instance Methods

Add | Overloaded. Adds a clause to a boolean query.
Clone
Combine (inherited from Query)
Equals Returns true iff
o
is equal to this.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetClauses | Returns the set of clauses in this query.
GetHashCode | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery Constructor

Constructs an empty boolean query.

public BooleanQuery();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery Fields

The fields of the BooleanQuery class are listed below. For a complete list of BooleanQuery class members, see the BooleanQuery Members topic.

Public Static Fields

maxClauseCount Default value is 1024. Use
Lucene.Net.maxClauseCount
system property to override.

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.maxClauseCount Field

Default value is 1024. Use

Lucene.Net.maxClauseCount
system property to override.

public static int maxClauseCount;

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery Methods

The methods of the BooleanQuery class are listed below. For a complete list of BooleanQuery class members, see the BooleanQuery Members topic.

Public Static Methods

GetMaxClauseCount | Return the maximum number of clauses permitted, 1024 by default. Attempts to add more than the permitted number of clauses cause {@link TooManyClauses} to be thrown.
SetMaxClauseCount | Set the maximum number of clauses permitted.

Public Instance Methods

Add | Overloaded. Adds a clause to a boolean query.
Clone
Combine (inherited from Query)
Equals Returns true iff
o
is equal to this.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetClauses | Returns the set of clauses in this query.
GetHashCode | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


Add Method

An NDoc Documented Class Library

BooleanQuery.Add Method

Adds a clause to a boolean query.

Overload List

Adds a clause to a boolean query.

public virtual void Add(BooleanClause);

public virtual void Add(Query,bool,bool);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | #GetMaxClauseCount


BooleanQuery.Add Method (BooleanClause)

Adds a clause to a boolean query.

public virtual void Add(
BooleanClause clause
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | BooleanQuery.Add Overload List | #GetMaxClauseCount


BooleanQuery.Add Method (Query, Boolean, Boolean)

public virtual void Add(
Query query,
bool required,
bool prohibited
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | BooleanQuery.Add Overload List


BooleanQuery.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.GetClauses Method

Returns the set of clauses in this query.

public virtual BooleanClause[] GetClauses();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.GetMaxClauseCount Method

Return the maximum number of clauses permitted, 1024 by default. Attempts to add more than the permitted number of clauses cause {@link TooManyClauses} to be thrown.

public static int GetMaxClauseCount();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.SetMaxClauseCount Method

Set the maximum number of clauses permitted.

public static void SetMaxClauseCount(
int maxClauseCount
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


ToString Method

An NDoc Documented Class Library

BooleanQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string field
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | BooleanQuery.ToString Overload List


BooleanQuery.TooManyClauses Class

Thrown when an attempt is made to add more than {@link #GetMaxClauseCount()} clauses.

For a list of all members of this type, see BooleanQuery.TooManyClauses Members.

System.Object
System.Exception
System.SystemException
Lucene.Net.Search.BooleanQuery.TooManyClauses

public class BooleanQuery.TooManyClauses : SystemException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BooleanQuery.TooManyClauses Members | Lucene.Net.Search Namespace


BooleanQuery.TooManyClauses Members

BooleanQuery.TooManyClauses overview

Public Instance Constructors

BooleanQuery.TooManyClauses Constructor Initializes a new instance of the BooleanQuery.TooManyClauses class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BooleanQuery.TooManyClauses Class | Lucene.Net.Search Namespace


BooleanQuery.TooManyClauses Constructor

Initializes a new instance of the BooleanQuery.TooManyClauses class.

public BooleanQuery.TooManyClauses();

See Also

BooleanQuery.TooManyClauses Class | Lucene.Net.Search Namespace


CachingWrapperFilter Class

Wraps another filters result and caches it. The caching behavior is like {@link QueryFilter}. The purpose is to allow filters to simply filter, and then wrap with this class to add caching, keeping the two concerns decoupled yet composable.

For a list of all members of this type, see CachingWrapperFilter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.CachingWrapperFilter

public class CachingWrapperFilter : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CachingWrapperFilter Members | Lucene.Net.Search Namespace


CachingWrapperFilter Members

CachingWrapperFilter overview

Public Instance Constructors

CachingWrapperFilter Constructor

Public Instance Methods

Bits |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter Constructor

public CachingWrapperFilter(
Filter filter
);

Parameters

filter
Filter to cache results of

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter Methods

The methods of the CachingWrapperFilter class are listed below. For a complete list of CachingWrapperFilter class members, see the CachingWrapperFilter Members topic.

Public Instance Methods

Bits |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter.Bits Method

public override BitArray Bits(
IndexReader reader
);

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter.ToString Method

public override string ToString();

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


DateFilter Class

For a list of all members of this type, see DateFilter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.DateFilter

public class DateFilter : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DateFilter Members | Lucene.Net.Search Namespace


DateFilter Members

DateFilter overview

Public Static Methods

After Overloaded. Constructs a filter for Field
f
matching dates on or after
date
.
Before Overloaded. Constructs a filter for Field
f
matching dates on or before before
date
.

Public Instance Constructors

DateFilter Overloaded. Initializes a new instance of the DateFilter class.

Public Instance Methods

Bits | Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateFilter Class | Lucene.Net.Search Namespace


DateFilter Constructor

Constructs a filter for Field

f
matching dates between
from
and
to
inclusively.

Overload List

Constructs a filter for Field

f
matching dates between
from
and
to
inclusively.

public DateFilter(string,DateTime,DateTime);

Constructs a filter for Field

f
matching times between
from
and
to
inclusively.

public DateFilter(string,long,long);

See Also

DateFilter Class | Lucene.Net.Search Namespace


DateFilter Constructor (String, DateTime, DateTime)

Constructs a filter for Field

f
matching dates between
from
and
to
inclusively.

public DateFilter(
string f,
DateTime from,
DateTime to
);

See Also

DateFilter Class | Lucene.Net.Search Namespace | DateFilter Constructor Overload List


DateFilter Constructor (String, Int64, Int64)

Constructs a filter for Field

f
matching times between
from
and
to
inclusively.

public DateFilter(
string f,
long from,
long to
);

See Also

DateFilter Class | Lucene.Net.Search Namespace | DateFilter Constructor Overload List


DateFilter Methods

The methods of the DateFilter class are listed below. For a complete list of DateFilter class members, see the DateFilter Members topic.

Public Static Methods

After Overloaded. Constructs a filter for Field
f
matching dates on or after
date
.
Before Overloaded. Constructs a filter for Field
f
matching dates on or before before
date
.

Public Instance Methods

Bits | Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateFilter Class | Lucene.Net.Search Namespace


After Method

An NDoc Documented Class Library

DateFilter.After Method

Constructs a filter for Field

f
matching dates on or after
date
.

Overload List

Constructs a filter for Field

f
matching dates on or after
date
.

public static DateFilter After(string,DateTime);

Constructs a filter for Field

f
matching times on or after
time
.

public static DateFilter After(string,long);

See Also

DateFilter Class | Lucene.Net.Search Namespace


DateFilter.After Method (String, DateTime)

Constructs a filter for Field

f
matching dates on or after
date
.

public static DateFilter After(
string field,
DateTime date
);

See Also

DateFilter Class | Lucene.Net.Search Namespace | DateFilter.After Overload List


DateFilter.After Method (String, Int64)

Constructs a filter for Field

f
matching times on or after
time
.

public static DateFilter After(
string field,
long time
);

See Also

DateFilter Class | Lucene.Net.Search Namespace | DateFilter.After Overload List


Before Method

An NDoc Documented Class Library

DateFilter.Before Method

Constructs a filter for Field

f
matching dates on or before before
date
.

Overload List

Constructs a filter for Field

f
matching dates on or before before
date
.

public static DateFilter Before(string,DateTime);

Constructs a filter for Field

f
matching times on or before
time
.

public static DateFilter Before(string,long);

See Also

DateFilter Class | Lucene.Net.Search Namespace


DateFilter.Before Method (String, DateTime)

Constructs a filter for Field

f
matching dates on or before before
date
.

public static DateFilter Before(
string field,
DateTime date
);

See Also

DateFilter Class | Lucene.Net.Search Namespace | DateFilter.Before Overload List


DateFilter.Before Method (String, Int64)

Constructs a filter for Field

f
matching times on or before
time
.

public static DateFilter Before(
string field,
long time
);

See Also

DateFilter Class | Lucene.Net.Search Namespace | DateFilter.Before Overload List


DateFilter.Bits Method

Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.

public override BitArray Bits(
IndexReader reader
);

See Also

DateFilter Class | Lucene.Net.Search Namespace


DateFilter.ToString Method

public override string ToString();

See Also

DateFilter Class | Lucene.Net.Search Namespace


DefaultSimilarity Class

Expert: Default scoring implementation.

For a list of all members of this type, see DefaultSimilarity Members.

System.Object
Lucene.Net.Search.Similarity
Lucene.Net.Search.DefaultSimilarity

public class DefaultSimilarity : Similarity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DefaultSimilarity Members | Lucene.Net.Search Namespace


DefaultSimilarity Members

DefaultSimilarity overview

Public Instance Constructors

DefaultSimilarity Constructor Initializes a new instance of the DefaultSimilarity class.

Public Instance Methods

Coord Implemented as
overlap / maxOverlap
.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Idf Overloaded. Implemented as
log(numDocs/(docFreq+1)) + 1
.
Idf (inherited from Similarity) | Overloaded.
LengthNorm Implemented as
1/sqrt(numTerms)
.
QueryNorm Implemented as
1/sqrt(sumOfSquaredWeights)
.
SloppyFreq Implemented as
1 / (distance + 1)
.
Tf Overloaded. Implemented as
sqrt(freq)
.
Tf (inherited from Similarity) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity Constructor

Initializes a new instance of the DefaultSimilarity class.

public DefaultSimilarity();

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity Methods

The methods of the DefaultSimilarity class are listed below. For a complete list of DefaultSimilarity class members, see the DefaultSimilarity Members topic.

Public Instance Methods

Coord Implemented as
overlap / maxOverlap
.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Idf Overloaded. Implemented as
log(numDocs/(docFreq+1)) + 1
.
Idf (inherited from Similarity) | Overloaded.
LengthNorm Implemented as
1/sqrt(numTerms)
.
QueryNorm Implemented as
1/sqrt(sumOfSquaredWeights)
.
SloppyFreq Implemented as
1 / (distance + 1)
.
Tf Overloaded. Implemented as
sqrt(freq)
.
Tf (inherited from Similarity) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity.Coord Method

Implemented as

overlap / maxOverlap
.

public override float Coord(
int overlap,
int maxOverlap
);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


Idf Method

An NDoc Documented Class Library

DefaultSimilarity.Idf Method

Implemented as

log(numDocs/(docFreq+1)) + 1
.

Overload List

Inherited from Similarity.

public virtual float Idf(Term,Searcher);

Inherited from Similarity.

public virtual float Idf(ICollection,Searcher);

Implemented as

log(numDocs/(docFreq+1)) + 1
.

public override float Idf(int,int);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity.Idf Method (Int32, Int32)

Implemented as

log(numDocs/(docFreq+1)) + 1
.

public override float Idf(
int docFreq,
int numDocs
);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace | DefaultSimilarity.Idf Overload List


DefaultSimilarity.LengthNorm Method

Implemented as

1/sqrt(numTerms)
.

public override float LengthNorm(
string fieldName,
int numTerms
);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity.QueryNorm Method

Implemented as

1/sqrt(sumOfSquaredWeights)
.

public override float QueryNorm(
float sumOfSquaredWeights
);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity.SloppyFreq Method

Implemented as

1 / (distance + 1)
.

public override float SloppyFreq(
int distance
);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


Tf Method

An NDoc Documented Class Library

DefaultSimilarity.Tf Method

Implemented as

sqrt(freq)
.

Overload List

Inherited from Similarity.

public virtual float Tf(int);

Implemented as

sqrt(freq)
.

public override float Tf(float);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity.Tf Method (Single)

Implemented as

sqrt(freq)
.

public override float Tf(
float freq
);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace | DefaultSimilarity.Tf Overload List


Explanation Class

Expert: Describes the score computation for document and query.

For a list of all members of this type, see Explanation Members.

System.Object
Lucene.Net.Search.Explanation

public class Explanation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Explanation Members | Lucene.Net.Search Namespace


Explanation Members

Explanation overview

Public Instance Constructors

Explanation Overloaded. Initializes a new instance of the Explanation class.

Public Instance Methods

AddDetail | Adds a sub-node to this explanation node.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDescription | A description of this explanation node.
GetDetails | The sub-nodes of this explanation node.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | The value assigned to this explanation node.
SetDescription | Sets the description of this explanation node.
SetValue | Sets the value assigned to this explanation node.
ToHtml | Render an explanation as HTML.
ToString | Render an explanation as text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation Constructor

Initializes a new instance of the Explanation class.

Overload List

Initializes a new instance of the Explanation class.

public Explanation();

public Explanation(float,string);

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation Constructor ()

Initializes a new instance of the Explanation class.

public Explanation();

See Also

Explanation Class | Lucene.Net.Search Namespace | Explanation Constructor Overload List


Explanation Constructor (Single, String)

public Explanation(
float value_Renamed,
string description
);

See Also

Explanation Class | Lucene.Net.Search Namespace | Explanation Constructor Overload List


Explanation Methods

The methods of the Explanation class are listed below. For a complete list of Explanation class members, see the Explanation Members topic.

Public Instance Methods

AddDetail | Adds a sub-node to this explanation node.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDescription | A description of this explanation node.
GetDetails | The sub-nodes of this explanation node.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | The value assigned to this explanation node.
SetDescription | Sets the description of this explanation node.
SetValue | Sets the value assigned to this explanation node.
ToHtml | Render an explanation as HTML.
ToString | Render an explanation as text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.AddDetail Method

Adds a sub-node to this explanation node.

public virtual void AddDetail(
Explanation detail
);

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.GetDescription Method

A description of this explanation node.

public virtual string GetDescription();

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.GetDetails Method

The sub-nodes of this explanation node.

public virtual Explanation[] GetDetails();

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.GetValue Method

The value assigned to this explanation node.

public virtual float GetValue();

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.SetDescription Method

Sets the description of this explanation node.

public virtual void SetDescription(
string description
);

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.SetValue Method

Sets the value assigned to this explanation node.

public virtual void SetValue(
float value_Renamed
);

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.ToHtml Method

Render an explanation as HTML.

public virtual string ToHtml();

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.ToString Method

Render an explanation as text.

public override string ToString();

See Also

Explanation Class | Lucene.Net.Search Namespace


FieldCache Interface

For a list of all members of this type, see FieldCache Members.

public interface FieldCache

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldCache Members | Lucene.Net.Search Namespace


FieldCache Members

FieldCache overview

Public Instance Methods

GetAuto Checks the internal cache for an appropriate entry, and if none is found reads
Field
to see if it contains integers, floats or strings, and then calls one of the other methods in this class to get the values. For string values, a StringIndex is returned. After calling this method, there is an entry in the cache for both type
AUTO
and the actual found type.
GetCustom Checks the internal cache for an appropriate entry, and if none is found reads the terms out of
Field
and calls the given SortComparator to get the sort values. A hit in the cache will happen if
reader
,
Field
, and
comparator
are the same (using
equals()
) as a previous call to this method.
GetFloats Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
Field
as floats and returns an array of size
reader.maxDoc()
of the value each document has in the given Field.
GetInts Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
Field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given Field.
GetStringIndex Checks the internal cache for an appropriate entry, and if none is found reads the term values in
Field
and returns an array of them in natural order, along with an array telling which element in the term array each document uses.
GetStrings Checks the internal cache for an appropriate entry, and if none is found, reads the term values in
Field
and returns an array of size
reader.maxDoc()
containing the value each document has in the given Field.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache Methods

The methods of the FieldCache interface are listed below. For a complete list of FieldCache interface members, see the FieldCache Members topic.

Public Instance Methods

GetAuto Checks the internal cache for an appropriate entry, and if none is found reads
Field
to see if it contains integers, floats or strings, and then calls one of the other methods in this class to get the values. For string values, a StringIndex is returned. After calling this method, there is an entry in the cache for both type
AUTO
and the actual found type.
GetCustom Checks the internal cache for an appropriate entry, and if none is found reads the terms out of
Field
and calls the given SortComparator to get the sort values. A hit in the cache will happen if
reader
,
Field
, and
comparator
are the same (using
equals()
) as a previous call to this method.
GetFloats Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
Field
as floats and returns an array of size
reader.maxDoc()
of the value each document has in the given Field.
GetInts Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
Field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given Field.
GetStringIndex Checks the internal cache for an appropriate entry, and if none is found reads the term values in
Field
and returns an array of them in natural order, along with an array telling which element in the term array each document uses.
GetStrings Checks the internal cache for an appropriate entry, and if none is found, reads the term values in
Field
and returns an array of size
reader.maxDoc()
containing the value each document has in the given Field.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache.GetAuto Method

Checks the internal cache for an appropriate entry, and if none is found reads

Field
to see if it contains integers, floats or strings, and then calls one of the other methods in this class to get the values. For string values, a StringIndex is returned. After calling this method, there is an entry in the cache for both type
AUTO
and the actual found type.

object GetAuto(
IndexReader reader,
string field
);

Parameters

reader
Used to get Field values.
field

Return Value

int[], float[] or StringIndex.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache.GetCustom Method

Checks the internal cache for an appropriate entry, and if none is found reads the terms out of

Field
and calls the given SortComparator to get the sort values. A hit in the cache will happen if
reader
,
Field
, and
comparator
are the same (using
equals()
) as a previous call to this method.

IComparable[] GetCustom(
IndexReader reader,
string field,
SortComparator comparator
);

Parameters

reader
Used to get Field values.
field
comparator
Used to convert terms into something to sort by.

Return Value

Array of sort objects, one for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache.GetFloats Method

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

Field
as floats and returns an array of size
reader.maxDoc()
of the value each document has in the given Field.

float[] GetFloats(
IndexReader reader,
string field
);

Parameters

reader
Used to get Field values.
field

Return Value

The values in the given Field for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache.GetInts Method

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

Field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given Field.

int[] GetInts(
IndexReader reader,
string field
);

Parameters

reader
Used to get Field values.
field

Return Value

The values in the given Field for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache.GetStringIndex Method

Checks the internal cache for an appropriate entry, and if none is found reads the term values in

Field
and returns an array of them in natural order, along with an array telling which element in the term array each document uses.

StringIndex GetStringIndex(
IndexReader reader,
string field
);

Parameters

reader
Used to get Field values.
field

Return Value

Array of terms and index into the array for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache.GetStrings Method

Checks the internal cache for an appropriate entry, and if none is found, reads the term values in

Field
and returns an array of size
reader.maxDoc()
containing the value each document has in the given Field.

string[] GetStrings(
IndexReader reader,
string field
);

Parameters

reader
Used to get Field values.
field

Return Value

The values in the given Field for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache_Fields Structure

For a list of all members of this type, see FieldCache_Fields Members.

System.Object
System.ValueType
Lucene.Net.Search.FieldCache_Fields

public struct FieldCache_Fields

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldCache_Fields Members | Lucene.Net.Search Namespace


FieldCache_Fields Members

FieldCache_Fields overview

Public Static Fields

DEFAULT | Expert: The cache used internally by sorting and range query classes.
STRING_INDEX | Indicator for StringIndex values in the cache.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

FieldCache_Fields Class | Lucene.Net.Search Namespace


FieldCache_Fields Fields

The fields of the FieldCache_Fields structure are listed below. For a complete list of FieldCache_Fields structure members, see the FieldCache_Fields Members topic.

Public Static Fields

DEFAULT | Expert: The cache used internally by sorting and range query classes.
STRING_INDEX | Indicator for StringIndex values in the cache.

See Also

FieldCache_Fields Class | Lucene.Net.Search Namespace


FieldCache_Fields.DEFAULT Field

Expert: The cache used internally by sorting and range query classes.

public static readonly FieldCache DEFAULT;

See Also

FieldCache_Fields Class | Lucene.Net.Search Namespace


FieldCache_Fields.STRING_INDEX Field

Indicator for StringIndex values in the cache.

public static readonly int STRING_INDEX;

See Also

FieldCache_Fields Class | Lucene.Net.Search Namespace


FieldDoc Class

For a list of all members of this type, see FieldDoc Members.

System.Object
Lucene.Net.Search.ScoreDoc
Lucene.Net.Search.FieldDoc

public class FieldDoc : ScoreDoc

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldDoc Members | Lucene.Net.Search Namespace


FieldDoc Members

FieldDoc overview

Public Instance Constructors

FieldDoc Overloaded. Initializes a new instance of the FieldDoc class.

Public Instance Fields

doc (inherited from ScoreDoc) | Expert: A hit document's number.
fields | Expert: The values which are used to sort the referenced document. The order of these will match the original sort criteria given by a Sort object. Each Object will be either an Integer, Float or String, depending on the type of values in the terms of the original Field.
score (inherited from ScoreDoc) | Expert: The score of this document for the query.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldDoc Class | Lucene.Net.Search Namespace


FieldDoc Constructor

Expert: Creates one of these objects with empty sort information.

Overload List

Expert: Creates one of these objects with empty sort information.

public FieldDoc(int,float);

Expert: Creates one of these objects with the given sort information.

public FieldDoc(int,float,IComparable[]);

See Also

FieldDoc Class | Lucene.Net.Search Namespace


FieldDoc Constructor (Int32, Single)

Expert: Creates one of these objects with empty sort information.

public FieldDoc(
int doc,
float score
);

See Also

FieldDoc Class | Lucene.Net.Search Namespace | FieldDoc Constructor Overload List


FieldDoc Constructor (Int32, Single, IComparable[])

Expert: Creates one of these objects with the given sort information.

public FieldDoc(
int doc,
float score,
IComparable[] fields
);

See Also

FieldDoc Class | Lucene.Net.Search Namespace | FieldDoc Constructor Overload List


FieldDoc Fields

The fields of the FieldDoc class are listed below. For a complete list of FieldDoc class members, see the FieldDoc Members topic.

Public Instance Fields

doc (inherited from ScoreDoc) | Expert: A hit document's number.
fields | Expert: The values which are used to sort the referenced document. The order of these will match the original sort criteria given by a Sort object. Each Object will be either an Integer, Float or String, depending on the type of values in the terms of the original Field.
score (inherited from ScoreDoc) | Expert: The score of this document for the query.

See Also

FieldDoc Class | Lucene.Net.Search Namespace


FieldDoc.fields Field

Expert: The values which are used to sort the referenced document. The order of these will match the original sort criteria given by a Sort object. Each Object will be either an Integer, Float or String, depending on the type of values in the terms of the original Field.

public IComparable[] fields;

See Also

FieldDoc Class | Lucene.Net.Search Namespace | | Searchable#Search


Filter Class

Abstract base class providing a mechanism to restrict searches to a subset of an index.

For a list of all members of this type, see Filter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.CachingWrapperFilter
Lucene.Net.Search.DateFilter
Lucene.Net.Search.QueryFilter

public abstract class Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Filter Members | Lucene.Net.Search Namespace


Filter Members

Filter overview

Public Instance Methods

Bits | Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Filter Constructor Initializes a new instance of the Filter class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Filter Class | Lucene.Net.Search Namespace


Filter Constructor

Initializes a new instance of the Filter class.

protected Filter();

See Also

Filter Class | Lucene.Net.Search Namespace


Filter Methods

The methods of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Instance Methods

Bits | Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Filter Class | Lucene.Net.Search Namespace


Filter.Bits Method

Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.

public abstract BitArray Bits(
IndexReader reader
);

See Also

Filter Class | Lucene.Net.Search Namespace


FilteredQuery Class

For a list of all members of this type, see FilteredQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.FilteredQuery

public class FilteredQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilteredQuery Members | Lucene.Net.Search Namespace


FilteredQuery Members

FilteredQuery overview

Public Instance Constructors

FilteredQuery Constructor Constructs a new query which applies a filter to the results of the original query. Filter.bits() will be called every time this query is used in a search.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals Returns true iff
o
is equal to this.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetQuery
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite | Rewrites the wrapped query.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight Returns a Weight that applies the filter to the enclosed query's Weight. This is accomplished by overriding the Scorer returned by the Weight.

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery Constructor

Constructs a new query which applies a filter to the results of the original query. Filter.bits() will be called every time this query is used in a search.

public FilteredQuery(
Query query,
Filter filter
);

Parameters

query
Query to be filtered, cannot be
null
.
filter
Filter to apply to query results, cannot be
null
.

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery Methods

The methods of the FilteredQuery class are listed below. For a complete list of FilteredQuery class members, see the FilteredQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals Returns true iff
o
is equal to this.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetQuery
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite | Rewrites the wrapped query.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight Returns a Weight that applies the filter to the enclosed query's Weight. This is accomplished by overriding the Scorer returned by the Weight.

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.CreateWeight Method

Returns a Weight that applies the filter to the enclosed query's Weight. This is accomplished by overriding the Scorer returned by the Weight.

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.GetQuery Method

public virtual Query GetQuery();

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.Rewrite Method

Rewrites the wrapped query.

public override Query Rewrite(
IndexReader reader
);

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


ToString Method

An NDoc Documented Class Library

FilteredQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string s
);

See Also

FilteredQuery Class | Lucene.Net.Search Namespace | FilteredQuery.ToString Overload List


FilteredTermEnum Class

For a list of all members of this type, see FilteredTermEnum Members.

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Search.FilteredTermEnum
Lucene.Net.Search.FuzzyTermEnum
Lucene.Net.Search.WildcardTermEnum

public abstract class FilteredTermEnum : TermEnum

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilteredTermEnum Members | Lucene.Net.Search Namespace


FilteredTermEnum Members

FilteredTermEnum overview

Public Instance Constructors

FilteredTermEnum Constructor Initializes a new instance of the FilteredTermEnum class.

Public Instance Methods

Close | Closes the enumeration to further activity, freeing resources.
Difference | Equality measure on the term
DocFreq | Returns the docFreq of the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
EndEnum | Indiciates the end of the enumeration has been reached
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term | Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SetEnum |
TermCompare | Equality compare on the term

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum Constructor

Initializes a new instance of the FilteredTermEnum class.

public FilteredTermEnum();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum Methods

The methods of the FilteredTermEnum class are listed below. For a complete list of FilteredTermEnum class members, see the FilteredTermEnum Members topic.

Public Instance Methods

Close | Closes the enumeration to further activity, freeing resources.
Difference | Equality measure on the term
DocFreq | Returns the docFreq of the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
EndEnum | Indiciates the end of the enumeration has been reached
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term | Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SetEnum |
TermCompare | Equality compare on the term

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.Close Method

Closes the enumeration to further activity, freeing resources.

public override void Close();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.Difference Method

Equality measure on the term

public abstract float Difference();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.DocFreq Method

Returns the docFreq of the current Term in the enumeration. Initially invalid, valid after next() called for the first time.

public override int DocFreq();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.EndEnum Method

Indiciates the end of the enumeration has been reached

public abstract bool EndEnum();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.Next Method

Increments the enumeration to the next element. True if one exists.

public override bool Next();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.SetEnum Method

protected internal virtual void SetEnum(
TermEnum actualEnum
);

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.Term Method

Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.

public override Term Term();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.TermCompare Method

Equality compare on the term

protected internal abstract bool TermCompare(
Term term
);

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FuzzyQuery Class

Implements the fuzzy search query. The similiarity measurement is based on the Levenshtein (edit distance) algorithm.

For a list of all members of this type, see FuzzyQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.MultiTermQuery
Lucene.Net.Search.FuzzyQuery

public sealed class FuzzyQuery : MultiTermQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FuzzyQuery Members | Lucene.Net.Search Namespace


FuzzyQuery Members

FuzzyQuery overview

Public Static Fields

defaultMinSimilarity

Public Instance Constructors

FuzzyQuery Overloaded. Initializes a new instance of the FuzzyQuery class.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from MultiTermQuery)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMinSimilarity | Returns the minimum similarity that is required for this query to match.
GetPrefixLength | Returns the prefix length, i.e. the number of characters at the start of a term that must be identical (not fuzzy) to the query term if the query is to match that term.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm (inherited from MultiTermQuery) | Returns the pattern term.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from MultiTermQuery)
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Internal Instance Methods

CreateWeight (inherited from Query)
GetEnum

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery Constructor

Create a new FuzzyQuery that will match terms with a similarity of at least

minimumSimilarity
to
term
. If a
prefixLength
> 0 is specified, a common prefix of that length is also required.

Overload List

Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, 0.5f, 0)}.

public FuzzyQuery(Term);

Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, minimumSimilarity, 0)}.

public FuzzyQuery(Term,float);

Create a new FuzzyQuery that will match terms with a similarity of at least

minimumSimilarity
to
term
. If a
prefixLength
> 0 is specified, a common prefix of that length is also required.

public FuzzyQuery(Term,float,int);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery Constructor (Term, Single, Int32)

Create a new FuzzyQuery that will match terms with a similarity of at least

minimumSimilarity
to
term
. If a
prefixLength
> 0 is specified, a common prefix of that length is also required.

public FuzzyQuery(
Term term,
float minimumSimilarity,
int prefixLength
);

Parameters

term
the term to search for
minimumSimilarity
a value between 0 and 1 to set the required similarity between the query term and the matching terms. For example, for a
minimumSimilarity
of
0.5
a term of the same length as the query term is considered similar to the query term if the edit distance between both terms is less than
length(term)*0.5
prefixLength
length of common (non-fuzzy) prefix

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace | FuzzyQuery Constructor Overload List


FuzzyQuery Constructor (Term, Single)

Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, minimumSimilarity, 0)}.

public FuzzyQuery(
Term term,
float minimumSimilarity
);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace | FuzzyQuery Constructor Overload List


FuzzyQuery Constructor (Term)

Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, 0.5f, 0)}.

public FuzzyQuery(
Term term
);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace | FuzzyQuery Constructor Overload List


FuzzyQuery Fields

The fields of the FuzzyQuery class are listed below. For a complete list of FuzzyQuery class members, see the FuzzyQuery Members topic.

Public Static Fields

defaultMinSimilarity

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.defaultMinSimilarity Field

public const float defaultMinSimilarity = 0.5;

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery Methods

The methods of the FuzzyQuery class are listed below. For a complete list of FuzzyQuery class members, see the FuzzyQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from MultiTermQuery)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMinSimilarity | Returns the minimum similarity that is required for this query to match.
GetPrefixLength | Returns the prefix length, i.e. the number of characters at the start of a term that must be identical (not fuzzy) to the query term if the query is to match that term.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm (inherited from MultiTermQuery) | Returns the pattern term.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from MultiTermQuery)
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Internal Instance Methods

CreateWeight (inherited from Query)
GetEnum

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.GetEnum Method

protected internal override FilteredTermEnum GetEnum(
IndexReader reader
);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.GetMinSimilarity Method

Returns the minimum similarity that is required for this query to match.

public float GetMinSimilarity();

Return Value

float value between 0.0 and 1.0

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.GetPrefixLength Method

Returns the prefix length, i.e. the number of characters at the start of a term that must be identical (not fuzzy) to the query term if the query is to match that term.

public int GetPrefixLength();

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


ToString Method

An NDoc Documented Class Library

FuzzyQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace | FuzzyQuery.ToString Overload List


FuzzyTermEnum Class

For a list of all members of this type, see FuzzyTermEnum Members.

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Search.FilteredTermEnum
Lucene.Net.Search.FuzzyTermEnum

public sealed class FuzzyTermEnum : FilteredTermEnum

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FuzzyTermEnum Members | Lucene.Net.Search Namespace


FuzzyTermEnum Members

FuzzyTermEnum overview

Public Instance Constructors

FuzzyTermEnum Overloaded. Initializes a new instance of the FuzzyTermEnum class.

Public Instance Methods

Close |
Difference |
DocFreq (inherited from FilteredTermEnum) | Returns the docFreq of the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
EndEnum |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from FilteredTermEnum) | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term (inherited from FilteredTermEnum) | Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

SetEnum (inherited from FilteredTermEnum) |
TermCompare | The termCompare method in FuzzyTermEnum uses Levenshtein distance to calculate the distance between the given term and the comparing term.

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


FuzzyTermEnum Constructor

Empty prefix and minSimilarity of 0.5f are used.

Overload List

Empty prefix and minSimilarity of 0.5f are used.

public FuzzyTermEnum(IndexReader,Term);

This is the standard FuzzyTermEnum with an empty prefix.

public FuzzyTermEnum(IndexReader,Term,float);

Constructor for enumeration of all terms from specified

reader
which share a prefix of length
prefixLength
with
term
and which have a fuzzy similarity >
minSimilarity
.

public FuzzyTermEnum(IndexReader,Term,float,int);

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace | Term, float, int)


FuzzyTermEnum Constructor (IndexReader, Term)

Empty prefix and minSimilarity of 0.5f are used.

public FuzzyTermEnum(
IndexReader reader,
Term term
);

Parameters

reader
term

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace | FuzzyTermEnum Constructor Overload List | Term, float, int)


FuzzyTermEnum Constructor (IndexReader, Term, Single)

This is the standard FuzzyTermEnum with an empty prefix.

public FuzzyTermEnum(
IndexReader reader,
Term term,
float minSimilarity
);

Parameters

reader
term
minSimilarity

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace | FuzzyTermEnum Constructor Overload List | Term, float, int)


FuzzyTermEnum Constructor (IndexReader, Term, Single, Int32)

Constructor for enumeration of all terms from specified

reader
which share a prefix of length
prefixLength
with
term
and which have a fuzzy similarity >
minSimilarity
.

public FuzzyTermEnum(
IndexReader reader,
Term term,
float minSimilarity,
int prefixLength
);

Parameters

reader
Delivers terms.
term
Pattern term.
minSimilarity
Minimum required similarity for terms from the reader. Default value is 0.5f.
prefixLength
Length of required common prefix. Default value is 0.

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace | FuzzyTermEnum Constructor Overload List


FuzzyTermEnum Methods

The methods of the FuzzyTermEnum class are listed below. For a complete list of FuzzyTermEnum class members, see the FuzzyTermEnum Members topic.

Public Instance Methods

Close |
Difference |
DocFreq (inherited from FilteredTermEnum) | Returns the docFreq of the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
EndEnum |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from FilteredTermEnum) | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term (inherited from FilteredTermEnum) | Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

SetEnum (inherited from FilteredTermEnum) |
TermCompare | The termCompare method in FuzzyTermEnum uses Levenshtein distance to calculate the distance between the given term and the comparing term.

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


FuzzyTermEnum.Close Method

public override void Close();

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


FuzzyTermEnum.Difference Method

public override float Difference();

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


FuzzyTermEnum.EndEnum Method

public override bool EndEnum();

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


FuzzyTermEnum.TermCompare Method

The termCompare method in FuzzyTermEnum uses Levenshtein distance to calculate the distance between the given term and the comparing term.

protected internal override bool TermCompare(
Term term
);

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


HitCollector Class

Lower-level search API.

For a list of all members of this type, see HitCollector Members.

System.Object
Lucene.Net.Search.HitCollector

public abstract class HitCollector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

HitCollector Members | Lucene.Net.Search Namespace | Searcher#Search


HitCollector Members

HitCollector overview

Public Instance Methods

Collect |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

HitCollector Constructor Initializes a new instance of the HitCollector class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HitCollector Class | Lucene.Net.Search Namespace | Searcher#Search


HitCollector Constructor

Initializes a new instance of the HitCollector class.

protected HitCollector();

See Also

HitCollector Class | Lucene.Net.Search Namespace


HitCollector Methods

The methods of the HitCollector class are listed below. For a complete list of HitCollector class members, see the HitCollector Members topic.

Public Instance Methods

Collect |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HitCollector Class | Lucene.Net.Search Namespace | Searcher#Search


HitCollector.Collect Method

public abstract void Collect(
int doc,
float score
);

See Also

HitCollector Class | Lucene.Net.Search Namespace


Hits Class

A ranked list of documents, used to hold search results.

For a list of all members of this type, see Hits Members.

System.Object
Lucene.Net.Search.Hits

public sealed class Hits

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Hits Members | Lucene.Net.Search Namespace


Hits Members

Hits overview

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Id | Returns the id for the nth document in this set.
Length | Returns the total number of hits available in this set.
Score | Returns the score for the nth document in this set.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Hits Class | Lucene.Net.Search Namespace


Hits Methods

The methods of the Hits class are listed below. For a complete list of Hits class members, see the Hits Members topic.

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Id | Returns the id for the nth document in this set.
Length | Returns the total number of hits available in this set.
Score | Returns the score for the nth document in this set.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Hits Class | Lucene.Net.Search Namespace


Hits.Doc Method

public Document Doc(
int n
);

See Also

Hits Class | Lucene.Net.Search Namespace


Hits.Id Method

Returns the id for the nth document in this set.

public int Id(
int n
);

See Also

Hits Class | Lucene.Net.Search Namespace


Hits.Length Method

Returns the total number of hits available in this set.

public int Length();

See Also

Hits Class | Lucene.Net.Search Namespace


Hits.Score Method

Returns the score for the nth document in this set.

public float Score(
int n
);

See Also

Hits Class | Lucene.Net.Search Namespace


IndexSearcher Class

For a list of all members of this type, see IndexSearcher Members.

System.Object
Lucene.Net.Search.Searcher
Lucene.Net.Search.IndexSearcher

public class IndexSearcher : Searcher

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexSearcher Members | Lucene.Net.Search Namespace


IndexSearcher Members

IndexSearcher overview

Public Instance Constructors

IndexSearcher Overloaded. Initializes a new instance of the IndexSearcher class.

Public Instance Fields

reader

Public Instance Methods

Close | Note that the underlying IndexReader is not closed, if IndexSearcher was constructed with IndexSearcher(IndexReader r). If the IndexReader was supplied implicitly by specifying a directory, then the IndexReader gets closed.
Doc
DocFreq
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Searcher)
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc
Rewrite
Search | Overloaded.
Search (inherited from Searcher) Overloaded. Returns documents matching
query
and
filter
, sorted by
sort
.
SetSimilarity (inherited from Searcher) | Expert: Set the Similarity implementation used by this Searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher Constructor

Creates a searcher searching the index in the named directory.

Overload List

Creates a searcher searching the provided index.

public IndexSearcher(IndexReader);

Creates a searcher searching the index in the provided directory.

public IndexSearcher(Directory);

Creates a searcher searching the index in the named directory.

public IndexSearcher(string);

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher Constructor (String)

Creates a searcher searching the index in the named directory.

public IndexSearcher(
string path
);

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher Constructor Overload List


IndexSearcher Constructor (Directory)

Creates a searcher searching the index in the provided directory.

public IndexSearcher(
Directory directory
);

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher Constructor Overload List


IndexSearcher Constructor (IndexReader)

Creates a searcher searching the provided index.

public IndexSearcher(
IndexReader r
);

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher Constructor Overload List


IndexSearcher Fields

The fields of the IndexSearcher class are listed below. For a complete list of IndexSearcher class members, see the IndexSearcher Members topic.

Public Instance Fields

reader

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.reader Field

public IndexReader reader;

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher Methods

The methods of the IndexSearcher class are listed below. For a complete list of IndexSearcher class members, see the IndexSearcher Members topic.

Public Instance Methods

Close | Note that the underlying IndexReader is not closed, if IndexSearcher was constructed with IndexSearcher(IndexReader r). If the IndexReader was supplied implicitly by specifying a directory, then the IndexReader gets closed.
Doc
DocFreq
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Searcher)
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc
Rewrite
Search | Overloaded.
Search (inherited from Searcher) Overloaded. Returns documents matching
query
and
filter
, sorted by
sort
.
SetSimilarity (inherited from Searcher) | Expert: Set the Similarity implementation used by this Searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.Close Method

Note that the underlying IndexReader is not closed, if IndexSearcher was constructed with IndexSearcher(IndexReader r). If the IndexReader was supplied implicitly by specifying a directory, then the IndexReader gets closed.

public override void Close();

Implements

Searchable.Close

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.Doc Method

public override Document Doc(
int i
);

Implements

Searchable.Doc

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.DocFreq Method

public override int DocFreq(
Term term
);

Implements

Searchable.DocFreq

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.Explain Method

public override Explanation Explain(
Query query,
int doc
);

Implements

Searchable.Explain

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.MaxDoc Method

public override int MaxDoc();

Implements

Searchable.MaxDoc

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.Rewrite Method

public override Query Rewrite(
Query original
);

Implements

Searchable.Rewrite

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


Search Method

An NDoc Documented Class Library

IndexSearcher.Search Method

Overload List

Inherited from Searcher.

public Hits Search(Query);

Inherited from Searcher.

public virtual Hits Search(Query,Filter);

public override void Search(Query,Filter,HitCollector);

Inherited from Searcher.

public virtual Hits Search(Query,Filter,Sort);

public override TopDocs Search(Query,Filter,int);

public override TopFieldDocs Search(Query,Filter,int,Sort);

Inherited from Searcher.

public virtual void Search(Query,HitCollector);

Inherited from Searcher.

public virtual Hits Search(Query,Sort);

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.Search Method (Query, Filter, HitCollector)

public override void Search(
Query query,
Filter filter,
HitCollector results
);

Implements

Searchable.Search

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher.Search Overload List


IndexSearcher.Search Method (Query, Filter, Int32)

public override TopDocs Search(
Query query,
Filter filter,
int nDocs
);

Implements

Searchable.Search

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher.Search Overload List


IndexSearcher.Search Method (Query, Filter, Int32, Sort)

public override TopFieldDocs Search(
Query query,
Filter filter,
int nDocs,
Sort sort
);

Implements

Searchable.Search

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher.Search Overload List


MultiSearcher Class

For a list of all members of this type, see MultiSearcher Members.

System.Object
Lucene.Net.Search.Searcher
Lucene.Net.Search.MultiSearcher
Lucene.Net.Search.ParallelMultiSearcher

public class MultiSearcher : Searcher

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MultiSearcher Members | Lucene.Net.Search Namespace


MultiSearcher Members

MultiSearcher overview

Public Instance Constructors

MultiSearcher Constructor Creates a searcher which searches searchables.

Public Instance Methods

Close
Doc
DocFreq
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Searcher)
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc
Rewrite
Search | Overloaded.
Search (inherited from Searcher) Overloaded. Returns documents matching
query
and
filter
, sorted by
sort
.
SearcherIndex | Call {@link #subSearcher} instead.
SetSimilarity (inherited from Searcher) | Expert: Set the Similarity implementation used by this Searcher.
SubDoc Returns the document number of document
n
within its sub-index.
SubSearcher Returns index of the searcher for document
n
in the array used to construct this searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetStarts

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher Constructor

Creates a searcher which searches searchables.

public MultiSearcher(
Searchable[] searchables
);

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher Methods

The methods of the MultiSearcher class are listed below. For a complete list of MultiSearcher class members, see the MultiSearcher Members topic.

Public Instance Methods

Close
Doc
DocFreq
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Searcher)
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc
Rewrite
Search | Overloaded.
Search (inherited from Searcher) Overloaded. Returns documents matching
query
and
filter
, sorted by
sort
.
SearcherIndex | Call {@link #subSearcher} instead.
SetSimilarity (inherited from Searcher) | Expert: Set the Similarity implementation used by this Searcher.
SubDoc Returns the document number of document
n
within its sub-index.
SubSearcher Returns index of the searcher for document
n
in the array used to construct this searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetStarts

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.Close Method

public override void Close();

Implements

Searchable.Close

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.Doc Method

public override Document Doc(
int n
);

Implements

Searchable.Doc

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.DocFreq Method

public override int DocFreq(
Term term
);

Implements

Searchable.DocFreq

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.Explain Method

public override Explanation Explain(
Query query,
int doc
);

Implements

Searchable.Explain

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.GetStarts Method

protected internal virtual int[] GetStarts();

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.MaxDoc Method

public override int MaxDoc();

Implements

Searchable.MaxDoc

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.Rewrite Method

public override Query Rewrite(
Query original
);

Implements

Searchable.Rewrite

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


Search Method

An NDoc Documented Class Library

MultiSearcher.Search Method

Overload List

Inherited from Searcher.

public Hits Search(Query);

Inherited from Searcher.

public virtual Hits Search(Query,Filter);

public override void Search(Query,Filter,HitCollector);

Inherited from Searcher.

public virtual Hits Search(Query,Filter,Sort);

public override TopDocs Search(Query,Filter,int);

public override TopFieldDocs Search(Query,Filter,int,Sort);

Inherited from Searcher.

public virtual void Search(Query,HitCollector);

Inherited from Searcher.

public virtual Hits Search(Query,Sort);

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.Search Method (Query, Filter, HitCollector)

public override void Search(
Query query,
Filter filter,
HitCollector results
);

Implements

Searchable.Search

See Also

MultiSearcher Class | Lucene.Net.Search Namespace | MultiSearcher.Search Overload List


MultiSearcher.Search Method (Query, Filter, Int32)

public override TopDocs Search(
Query query,
Filter filter,
int nDocs
);

Implements

Searchable.Search

See Also

MultiSearcher Class | Lucene.Net.Search Namespace | MultiSearcher.Search Overload List


MultiSearcher.Search Method (Query, Filter, Int32, Sort)

public override TopFieldDocs Search(
Query query,
Filter filter,
int n,
Sort sort
);

Implements

Searchable.Search

See Also

MultiSearcher Class | Lucene.Net.Search Namespace | MultiSearcher.Search Overload List


MultiSearcher.SearcherIndex Method

Call {@link #subSearcher} instead.

public virtual int SearcherIndex(
int n
);

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.SubDoc Method

Returns the document number of document

n
within its sub-index.

public virtual int SubDoc(
int n
);

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.SubSearcher Method

Returns index of the searcher for document

n
in the array used to construct this searcher.

public virtual int SubSearcher(
int n
);

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiTermQuery Class

For a list of all members of this type, see MultiTermQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.MultiTermQuery
Lucene.Net.Search.FuzzyQuery
Lucene.Net.Search.WildcardQuery

public abstract class MultiTermQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MultiTermQuery Members | Lucene.Net.Search Namespace


MultiTermQuery Members

MultiTermQuery overview

Public Instance Constructors

MultiTermQuery Constructor Constructs a query for terms matching
term
.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm | Returns the pattern term.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query) |
GetEnum | Construct the enumeration to be used, expanding the pattern term.

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery Constructor

Constructs a query for terms matching

term
.

public MultiTermQuery(
Term term
);

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery Methods

The methods of the MultiTermQuery class are listed below. For a complete list of MultiTermQuery class members, see the MultiTermQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm | Returns the pattern term.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query) |
GetEnum | Construct the enumeration to be used, expanding the pattern term.

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery.Combine Method

public override Query Combine(
Query[] queries
);

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery.GetEnum Method

Construct the enumeration to be used, expanding the pattern term.

protected internal abstract FilteredTermEnum GetEnum(
IndexReader reader
);

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery.GetTerm Method

Returns the pattern term.

public virtual Term GetTerm();

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


ToString Method

An NDoc Documented Class Library

MultiTermQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string field
);

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace | MultiTermQuery.ToString Overload List


ParallelMultiSearcher Class

For a list of all members of this type, see ParallelMultiSearcher Members.

System.Object
Lucene.Net.Search.Searcher
Lucene.Net.Search.MultiSearcher
Lucene.Net.Search.ParallelMultiSearcher

public class ParallelMultiSearcher : MultiSearcher

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ParallelMultiSearcher Members | Lucene.Net.Search Namespace


ParallelMultiSearcher Members

ParallelMultiSearcher overview

Public Instance Constructors

ParallelMultiSearcher Constructor Creates a searcher which searches searchables.

Public Instance Methods

Close (inherited from MultiSearcher)
Doc (inherited from MultiSearcher)
DocFreq | TODO: parallelize this one too
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain (inherited from MultiSearcher)
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Searcher)
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc (inherited from MultiSearcher)
Rewrite
Search | Overloaded. A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.
Search (inherited from Searcher) Overloaded. Returns documents matching
query
and
filter
, sorted by
sort
.
SearcherIndex (inherited from MultiSearcher) | Call {@link #subSearcher} instead.
SetSimilarity (inherited from Searcher) | Expert: Set the Similarity implementation used by this Searcher.
SubDoc (inherited from MultiSearcher) Returns the document number of document
n
within its sub-index.
SubSearcher (inherited from MultiSearcher) Returns index of the searcher for document
n
in the array used to construct this searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetStarts (inherited from MultiSearcher)

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace


ParallelMultiSearcher Constructor

Creates a searcher which searches searchables.

public ParallelMultiSearcher(
Searchable[] searchables
);

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace


ParallelMultiSearcher Methods

The methods of the ParallelMultiSearcher class are listed below. For a complete list of ParallelMultiSearcher class members, see the ParallelMultiSearcher Members topic.

Public Instance Methods

Close (inherited from MultiSearcher)
Doc (inherited from MultiSearcher)
DocFreq | TODO: parallelize this one too
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain (inherited from MultiSearcher)
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Searcher)
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc (inherited from MultiSearcher)
Rewrite
Search | Overloaded. A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.
Search (inherited from Searcher) Overloaded. Returns documents matching
query
and
filter
, sorted by
sort
.
SearcherIndex (inherited from MultiSearcher) | Call {@link #subSearcher} instead.
SetSimilarity (inherited from Searcher) | Expert: Set the Similarity implementation used by this Searcher.
SubDoc (inherited from MultiSearcher) Returns the document number of document
n
within its sub-index.
SubSearcher (inherited from MultiSearcher) Returns index of the searcher for document
n
in the array used to construct this searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetStarts (inherited from MultiSearcher)

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace


ParallelMultiSearcher.DocFreq Method

TODO: parallelize this one too

public override int DocFreq(
Term term
);

Implements

Searchable.DocFreq

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace


ParallelMultiSearcher.Rewrite Method

public override Query Rewrite(
Query original
);

Implements

Searchable.Rewrite

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace


Search Method

An NDoc Documented Class Library

ParallelMultiSearcher.Search Method

Overload List

Inherited from Searcher.

public Hits Search(Query);

Inherited from Searcher.

public virtual Hits Search(Query,Filter);

public override void Search(Query,Filter,HitCollector);

Inherited from Searcher.

public virtual Hits Search(Query,Filter,Sort);

A search implementation which spans a new thread for each Searchable, waits for each search to complete and merge the results back together.

public override TopDocs Search(Query,Filter,int);

A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.

public override TopFieldDocs Search(Query,Filter,int,Sort);

Inherited from Searcher.

public virtual void Search(Query,HitCollector);

Inherited from Searcher.

public virtual Hits Search(Query,Sort);

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace


ParallelMultiSearcher.Search Method (Query, Filter, HitCollector)

public override void Search(
Query query,
Filter filter,
HitCollector results
);

Implements

Searchable.Search

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace | ParallelMultiSearcher.Search Overload List


ParallelMultiSearcher.Search Method (Query, Filter, Int32)

A search implementation which spans a new thread for each Searchable, waits for each search to complete and merge the results back together.

public override TopDocs Search(
Query query,
Filter filter,
int nDocs
);

Implements

Searchable.Search

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace | ParallelMultiSearcher.Search Overload List


ParallelMultiSearcher.Search Method (Query, Filter, Int32, Sort)

A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.

public override TopFieldDocs Search(
Query query,
Filter filter,
int nDocs,
Sort sort
);

Implements

Searchable.Search

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace | ParallelMultiSearcher.Search Overload List


PhrasePrefixQuery Class

PhrasePrefixQuery is a generalized version of PhraseQuery, with an added method {@link #Add(Term[])}. To use this class, to search for the phrase "Microsoft app*" first use add(Term) on the term "Microsoft", then find all terms that has "app" as prefix using IndexReader.terms(Term), and use PhrasePrefixQuery.add(Term[] terms) to add them to the query.

For a list of all members of this type, see PhrasePrefixQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.PhrasePrefixQuery

public class PhrasePrefixQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PhrasePrefixQuery Members | Lucene.Net.Search Namespace


PhrasePrefixQuery Members

PhrasePrefixQuery overview

Public Instance Constructors

PhrasePrefixQuery Constructor Initializes a new instance of the PhrasePrefixQuery class.

Public Instance Methods

Add | Overloaded. Allows to specify the relative position of terms within the phrase.
Clone
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPositions | Returns the relative positions of terms in this phrase.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSlop | Sets the phrase slop for this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
SetSlop | Sets the phrase slop for this query.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace


PhrasePrefixQuery Constructor

Initializes a new instance of the PhrasePrefixQuery class.

public PhrasePrefixQuery();

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace


PhrasePrefixQuery Methods

The methods of the PhrasePrefixQuery class are listed below. For a complete list of PhrasePrefixQuery class members, see the PhrasePrefixQuery Members topic.

Public Instance Methods

Add | Overloaded. Allows to specify the relative position of terms within the phrase.
Clone
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPositions | Returns the relative positions of terms in this phrase.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSlop | Sets the phrase slop for this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
SetSlop | Sets the phrase slop for this query.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace


Add Method

An NDoc Documented Class Library

PhrasePrefixQuery.Add Method

Add a single term at the next position in the phrase.

Overload List

Add a single term at the next position in the phrase.

public virtual void Add(Term);

Add multiple terms at the next position in the phrase. Any of the terms may match.

public virtual void Add(Term[]);

Allows to specify the relative position of terms within the phrase.

public virtual void Add(Term[],int);

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace | PhraseQuery#Add


PhrasePrefixQuery.Add Method (Term)

Add a single term at the next position in the phrase.

public virtual void Add(
Term term
);

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace | PhrasePrefixQuery.Add Overload List | PhraseQuery#Add


PhrasePrefixQuery.Add Method (Term[])

Add multiple terms at the next position in the phrase. Any of the terms may match.

public virtual void Add(
Term[] terms
);

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace | PhrasePrefixQuery.Add Overload List | PhraseQuery#Add


PhrasePrefixQuery.Add Method (Term[], Int32)

Allows to specify the relative position of terms within the phrase.

public virtual void Add(
Term[] terms,
int position
);

Parameters

terms
position

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace | PhrasePrefixQuery.Add Overload List | int)


PhrasePrefixQuery.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace


PhrasePrefixQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace


PhrasePrefixQuery.GetPositions Method

Returns the relative positions of terms in this phrase.

public virtual int[] GetPositions();

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace


PhrasePrefixQuery.GetSlop Method

Sets the phrase slop for this query.

public virtual int GetSlop();

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace | PhraseQuery#GetSlop


PhrasePrefixQuery.SetSlop Method

Sets the phrase slop for this query.

public virtual void SetSlop(
int s
);

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace | PhraseQuery#SetSlop


ToString Method

An NDoc Documented Class Library

PhrasePrefixQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace


PhrasePrefixQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string f
);

See Also

PhrasePrefixQuery Class | Lucene.Net.Search Namespace | PhrasePrefixQuery.ToString Overload List


PhraseQuery Class

A Query that matches documents containing a particular sequence of terms. This may be combined with other terms with a {@link BooleanQuery}.

For a list of all members of this type, see PhraseQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.PhraseQuery

public class PhraseQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PhraseQuery Members | Lucene.Net.Search Namespace


PhraseQuery Members

PhraseQuery overview

Public Instance Constructors

PhraseQuery Constructor Constructs an empty phrase query.

Public Instance Methods

Add | Overloaded. Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).
Clone
Combine (inherited from Query)
Equals Returns true iff
o
is equal to this.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetPositions | Returns the relative positions of terms in this phrase.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSlop | Returns the slop. See setSlop().
GetTerms | Returns the set of terms in this phrase.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
SetSlop
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery Constructor

Constructs an empty phrase query.

public PhraseQuery();

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery Methods

The methods of the PhraseQuery class are listed below. For a complete list of PhraseQuery class members, see the PhraseQuery Members topic.

Public Instance Methods

Add | Overloaded. Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).
Clone
Combine (inherited from Query)
Equals Returns true iff
o
is equal to this.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetPositions | Returns the relative positions of terms in this phrase.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSlop | Returns the slop. See setSlop().
GetTerms | Returns the set of terms in this phrase.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
SetSlop
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


Add Method

An NDoc Documented Class Library

PhraseQuery.Add Method

Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.

Overload List

Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.

public virtual void Add(Term);

Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).

public virtual void Add(Term,int);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.Add Method (Term)

Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.

public virtual void Add(
Term term
);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace | PhraseQuery.Add Overload List


PhraseQuery.Add Method (Term, Int32)

Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).

public virtual void Add(
Term term,
int position
);

Parameters

term
position

See Also

PhraseQuery Class | Lucene.Net.Search Namespace | PhraseQuery.Add Overload List


PhraseQuery.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.GetPositions Method

Returns the relative positions of terms in this phrase.

public virtual int[] GetPositions();

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.GetSlop Method

Returns the slop. See setSlop().

public virtual int GetSlop();

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.GetTerms Method

Returns the set of terms in this phrase.

public virtual Term[] GetTerms();

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.SetSlop Method

public virtual void SetSlop(
int s
);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


ToString Method

An NDoc Documented Class Library

PhraseQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string f
);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace | PhraseQuery.ToString Overload List


PrefixQuery Class

A Query that matches documents containing terms with a specified prefix.

For a list of all members of this type, see PrefixQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.PrefixQuery

public class PrefixQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PrefixQuery Members | Lucene.Net.Search Namespace


PrefixQuery Members

PrefixQuery overview

Public Instance Constructors

PrefixQuery Constructor Constructs a query for terms starting with
prefix
.

Public Instance Methods

Clone
Combine
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPrefix | Returns the prefix of this query.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery Constructor

Constructs a query for terms starting with

prefix
.

public PrefixQuery(
Term prefix
);

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery Methods

The methods of the PrefixQuery class are listed below. For a complete list of PrefixQuery class members, see the PrefixQuery Members topic.

Public Instance Methods

Clone
Combine
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPrefix | Returns the prefix of this query.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery.Combine Method

public override Query Combine(
Query[] queries
);

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery.GetPrefix Method

Returns the prefix of this query.

public virtual Term GetPrefix();

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


ToString Method

An NDoc Documented Class Library

PrefixQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string field
);

See Also

PrefixQuery Class | Lucene.Net.Search Namespace | PrefixQuery.ToString Overload List


Query Class

For a list of all members of this type, see Query Members.

System.Object
Lucene.Net.Search.Query
Derived types

public abstract class Query : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Query Members | Lucene.Net.Search Namespace


Query Members

Query overview

Public Static Methods

MergeBooleanQueries

Public Instance Methods

Clone | Returns a clone of this query.
Combine
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite | Expert: called to re-write queries into primitive queries.
SetBoost Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
Weight | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Constructors

Query Constructor Initializes a new instance of the Query class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

Query Class | Lucene.Net.Search Namespace


Query Constructor

Initializes a new instance of the Query class.

protected Query();

See Also

Query Class | Lucene.Net.Search Namespace


Query Methods

The methods of the Query class are listed below. For a complete list of Query class members, see the Query Members topic.

Public Static Methods

MergeBooleanQueries

Public Instance Methods

Clone | Returns a clone of this query.
Combine
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite | Expert: called to re-write queries into primitive queries.
SetBoost Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
Weight | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

Query Class | Lucene.Net.Search Namespace


Query.Clone Method

Returns a clone of this query.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

Query Class | Lucene.Net.Search Namespace


Query.Combine Method

public virtual Query Combine(
Query[] queries
);

See Also

Query Class | Lucene.Net.Search Namespace


Query.CreateWeight Method

protected internal virtual Weight CreateWeight(
Searcher searcher
);

See Also

Query Class | Lucene.Net.Search Namespace


Query.GetBoost Method

Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by

b
. The boost is 1.0 by default.

public virtual float GetBoost();

See Also

Query Class | Lucene.Net.Search Namespace


Query.GetSimilarity Method

Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.

public virtual Similarity GetSimilarity(
Searcher searcher
);

See Also

Query Class | Lucene.Net.Search Namespace


Query.MergeBooleanQueries Method

public static Query MergeBooleanQueries(
Query[] queries
);

See Also

Query Class | Lucene.Net.Search Namespace


Query.Rewrite Method

Expert: called to re-write queries into primitive queries.

public virtual Query Rewrite(
IndexReader reader
);

See Also

Query Class | Lucene.Net.Search Namespace


Query.SetBoost Method

Sets the boost for this query clause to

b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.

public virtual void SetBoost(
float b
);

See Also

Query Class | Lucene.Net.Search Namespace


ToString Method

An NDoc Documented Class Library

Query.ToString Method

Prints a query to a string.

Overload List

Prints a query to a string.

public override string ToString();

public abstract string ToString(string);

See Also

Query Class | Lucene.Net.Search Namespace


Query.ToString Method ()

Prints a query to a string.

public override string ToString();

See Also

Query Class | Lucene.Net.Search Namespace | Query.ToString Overload List


Query.ToString Method (String)

public abstract string ToString(
string field
);

See Also

Query Class | Lucene.Net.Search Namespace | Query.ToString Overload List


Query.Weight Method

Expert: Constructs an initializes a Weight for a top-level query.

public virtual Weight Weight(
Searcher searcher
);

See Also

Query Class | Lucene.Net.Search Namespace


QueryFilter Class

For a list of all members of this type, see QueryFilter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.QueryFilter

public class QueryFilter : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

QueryFilter Members | Lucene.Net.Search Namespace


QueryFilter Members

QueryFilter overview

Public Instance Constructors

QueryFilter Constructor Constructs a filter which only matches documents matching
query
.

Public Instance Methods

Bits |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryFilter Class | Lucene.Net.Search Namespace


QueryFilter Constructor

Constructs a filter which only matches documents matching

query
.

public QueryFilter(
Query query
);

See Also

QueryFilter Class | Lucene.Net.Search Namespace


QueryFilter Methods

The methods of the QueryFilter class are listed below. For a complete list of QueryFilter class members, see the QueryFilter Members topic.

Public Instance Methods

Bits |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryFilter Class | Lucene.Net.Search Namespace


QueryFilter.Bits Method

public override BitArray Bits(
IndexReader reader
);

See Also

QueryFilter Class | Lucene.Net.Search Namespace


QueryFilter.ToString Method

public override string ToString();

See Also

QueryFilter Class | Lucene.Net.Search Namespace


QueryTermVector Class

For a list of all members of this type, see QueryTermVector Members.

System.Object
Lucene.Net.Search.QueryTermVector

public class QueryTermVector : TermFreqVector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

QueryTermVector Members | Lucene.Net.Search Namespace


QueryTermVector Members

QueryTermVector overview

Public Instance Constructors

QueryTermVector Overloaded. Initializes a new instance of the QueryTermVector class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetField |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTermFrequencies |
GetTerms |
GetType (inherited from Object) | Gets the Type of the current instance.
IndexesOf |
IndexOf |
Size |
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector Constructor

Overload List

public QueryTermVector(string,Analyzer);

public QueryTermVector(string[]);

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector Constructor (String[])

public QueryTermVector(
string[] queryTerms
);

Parameters

queryTerms
The original list of terms from the query, can contain duplicates

See Also

QueryTermVector Class | Lucene.Net.Search Namespace | QueryTermVector Constructor Overload List


QueryTermVector Constructor (String, Analyzer)

public QueryTermVector(
string queryString,
Analyzer analyzer
);

See Also

QueryTermVector Class | Lucene.Net.Search Namespace | QueryTermVector Constructor Overload List


QueryTermVector Methods

The methods of the QueryTermVector class are listed below. For a complete list of QueryTermVector class members, see the QueryTermVector Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetField |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTermFrequencies |
GetTerms |
GetType (inherited from Object) | Gets the Type of the current instance.
IndexesOf |
IndexOf |
Size |
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.GetField Method

public virtual string GetField();

Implements

TermFreqVector.GetField

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.GetTermFrequencies Method

public virtual int[] GetTermFrequencies();

Implements

TermFreqVector.GetTermFrequencies

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.GetTerms Method

public virtual string[] GetTerms();

Implements

TermFreqVector.GetTerms

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.IndexesOf Method

public virtual int[] IndexesOf(
string[] terms,
int start,
int len
);

Implements

TermFreqVector.IndexesOf

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.IndexOf Method

public virtual int IndexOf(
string term
);

Implements

TermFreqVector.IndexOf

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.Size Method

public virtual int Size();

Implements

TermFreqVector.Size

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.ToString Method

public override string ToString();

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


RangeQuery Class

A Query that matches documents within an exclusive range.

For a list of all members of this type, see RangeQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.RangeQuery

public class RangeQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RangeQuery Members | Lucene.Net.Search Namespace


RangeQuery Members

RangeQuery overview

Public Instance Constructors

RangeQuery Constructor Constructs a query selecting all terms greater than
lowerTerm
but less than
upperTerm
. There must be at least one term and either term may be null, in which case there is no bound on that side, but if there are two terms, both terms must be for the same Field.

Public Instance Methods

Clone
Combine
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField | Returns the Field name for this query
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLowerTerm | Returns the lower term of this range query
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUpperTerm | Returns the upper term of this range query
IsInclusive Returns
true
if the range query is inclusive
Rewrite FIXME: Describe
rewrite
method here.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery Constructor

Constructs a query selecting all terms greater than

lowerTerm
but less than
upperTerm
. There must be at least one term and either term may be null, in which case there is no bound on that side, but if there are two terms, both terms must be for the same Field.

public RangeQuery(
Term lowerTerm,
Term upperTerm,
bool inclusive
);

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery Methods

The methods of the RangeQuery class are listed below. For a complete list of RangeQuery class members, see the RangeQuery Members topic.

Public Instance Methods

Clone
Combine
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField | Returns the Field name for this query
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLowerTerm | Returns the lower term of this range query
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUpperTerm | Returns the upper term of this range query
IsInclusive Returns
true
if the range query is inclusive
Rewrite FIXME: Describe
rewrite
method here.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.Combine Method

public override Query Combine(
Query[] queries
);

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.GetField Method

Returns the Field name for this query

public virtual string GetField();

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.GetLowerTerm Method

Returns the lower term of this range query

public virtual Term GetLowerTerm();

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.GetUpperTerm Method

Returns the upper term of this range query

public virtual Term GetUpperTerm();

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.IsInclusive Method

Returns

true
if the range query is inclusive

public virtual bool IsInclusive();

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.Rewrite Method

FIXME: Describe

rewrite
method here.

public override Query Rewrite(
IndexReader reader
);

Parameters

reader
an
IndexReader
value

Return Value

a

Query
value

Exceptions

Exception Type | Condition
 | IOException if an error occurs

See Also

RangeQuery Class | Lucene.Net.Search Namespace


ToString Method

An NDoc Documented Class Library

RangeQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string field
);

See Also

RangeQuery Class | Lucene.Net.Search Namespace | RangeQuery.ToString Overload List


RemoteSearchable Class

A remote searchable implementation.

For a list of all members of this type, see RemoteSearchable Members.

System.Object
System.MarshalByRefObject
Lucene.Net.Search.RemoteSearchable

public class RemoteSearchable : MarshalByRefObject, Searchable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RemoteSearchable Members | Lucene.Net.Search Namespace


RemoteSearchable Members

RemoteSearchable overview

Public Static Methods

Main Exports a searcher for the index in args[0] named "//localhost/Searchable".

Public Instance Constructors

RemoteSearchable Constructor Constructs and exports a remote searcher.

Public Instance Methods

Close |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Doc |
DocFreq |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService |
MaxDoc |
Rewrite |
Search | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable Constructor

Constructs and exports a remote searcher.

public RemoteSearchable(
Searchable local
);

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable Methods

The methods of the RemoteSearchable class are listed below. For a complete list of RemoteSearchable class members, see the RemoteSearchable Members topic.

Public Static Methods

Main Exports a searcher for the index in args[0] named "//localhost/Searchable".

Public Instance Methods

Close |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Doc |
DocFreq |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService |
MaxDoc |
Rewrite |
Search | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.Close Method

public virtual void Close();

Implements

Searchable.Close

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.Doc Method

public virtual Document Doc(
int i
);

Implements

Searchable.Doc

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.DocFreq Method

public virtual int DocFreq(
Term term
);

Implements

Searchable.DocFreq

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.Explain Method

public virtual Explanation Explain(
Query query,
int doc
);

Implements

Searchable.Explain

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.InitializeLifetimeService Method

public override object InitializeLifetimeService();

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.Main Method

Exports a searcher for the index in args[0] named "//localhost/Searchable".

public static void Main(
string[] args
);

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.MaxDoc Method

public virtual int MaxDoc();

Implements

Searchable.MaxDoc

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.Rewrite Method

public virtual Query Rewrite(
Query original
);

Implements

Searchable.Rewrite

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


Search Method

An NDoc Documented Class Library

RemoteSearchable.Search Method

Overload List

public virtual void Search(Query,Filter,HitCollector);

public virtual TopDocs Search(Query,Filter,int);

public virtual TopFieldDocs Search(Query,Filter,int,Sort);

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.Search Method (Query, Filter, HitCollector)

public virtual void Search(
Query query,
Filter filter,
HitCollector results
);

Implements

Searchable.Search

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace | RemoteSearchable.Search Overload List


RemoteSearchable.Search Method (Query, Filter, Int32)

public virtual TopDocs Search(
Query query,
Filter filter,
int n
);

Implements

Searchable.Search

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace | RemoteSearchable.Search Overload List


RemoteSearchable.Search Method (Query, Filter, Int32, Sort)

public virtual TopFieldDocs Search(
Query query,
Filter filter,
int n,
Sort sort
);

Implements

Searchable.Search

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace | RemoteSearchable.Search Overload List


ScoreDoc Class

Expert: Returned by low-level search implementations.

For a list of all members of this type, see ScoreDoc Members.

System.Object
Lucene.Net.Search.ScoreDoc
Lucene.Net.Search.FieldDoc

public class ScoreDoc

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ScoreDoc Members | Lucene.Net.Search Namespace |


ScoreDoc Members

ScoreDoc overview

Public Instance Constructors

ScoreDoc Constructor Expert: Constructs a ScoreDoc.

Public Instance Fields

doc | Expert: A hit document's number.
score | Expert: The score of this document for the query.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScoreDoc Class | Lucene.Net.Search Namespace |


ScoreDoc Constructor

Expert: Constructs a ScoreDoc.

public ScoreDoc(
int doc,
float score
);

See Also

ScoreDoc Class | Lucene.Net.Search Namespace


ScoreDoc Fields

The fields of the ScoreDoc class are listed below. For a complete list of ScoreDoc class members, see the ScoreDoc Members topic.

Public Instance Fields

doc | Expert: A hit document's number.
score | Expert: The score of this document for the query.

See Also

ScoreDoc Class | Lucene.Net.Search Namespace |


ScoreDoc.doc Field

Expert: A hit document's number.

public int doc;

See Also

ScoreDoc Class | Lucene.Net.Search Namespace | Searcher#Doc


ScoreDoc.score Field

Expert: The score of this document for the query.

public float score;

See Also

ScoreDoc Class | Lucene.Net.Search Namespace


ScoreDocComparator Interface

For a list of all members of this type, see ScoreDocComparator Members.

public interface ScoreDocComparator

Types that implement ScoreDocComparator

Type | Description
AnonymousClassScoreDocComparator |
AnonymousClassScoreDocComparator1 |

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ScoreDocComparator Members | Lucene.Net.Search Namespace


ScoreDocComparator Members

ScoreDocComparator overview

Public Instance Methods

Compare
SortType Returns the type of sort. Should return
SortField.SCORE
,
SortField.DOC
,
SortField.STRING
,
SortField.INTEGER
,
SortField.FLOAT
or
SortField.CUSTOM
. It is not valid to return
SortField.AUTO
. This is used by multisearchers to determine how to collate results from their searchers.
SortValue Returns the value used to sort the given document. The object returned must implement the java.io.Serializable interface. This is used by multisearchers to determine how to collate results from their searchers.

See Also

ScoreDocComparator Interface | Lucene.Net.Search Namespace


ScoreDocComparator Methods

The methods of the ScoreDocComparator interface are listed below. For a complete list of ScoreDocComparator interface members, see the ScoreDocComparator Members topic.

Public Instance Methods

Compare
SortType Returns the type of sort. Should return
SortField.SCORE
,
SortField.DOC
,
SortField.STRING
,
SortField.INTEGER
,
SortField.FLOAT
or
SortField.CUSTOM
. It is not valid to return
SortField.AUTO
. This is used by multisearchers to determine how to collate results from their searchers.
SortValue Returns the value used to sort the given document. The object returned must implement the java.io.Serializable interface. This is used by multisearchers to determine how to collate results from their searchers.

See Also

ScoreDocComparator Interface | Lucene.Net.Search Namespace


ScoreDocComparator.Compare Method

int Compare(
ScoreDoc i,
ScoreDoc j
);

See Also

ScoreDocComparator Interface | Lucene.Net.Search Namespace


ScoreDocComparator.SortType Method

Returns the type of sort. Should return

SortField.SCORE
,
SortField.DOC
,
SortField.STRING
,
SortField.INTEGER
,
SortField.FLOAT
or
SortField.CUSTOM
. It is not valid to return
SortField.AUTO
. This is used by multisearchers to determine how to collate results from their searchers.

int SortType();

Return Value

One of the constants in SortField.

See Also

ScoreDocComparator Interface | Lucene.Net.Search Namespace |


ScoreDocComparator.SortValue Method

Returns the value used to sort the given document. The object returned must implement the java.io.Serializable interface. This is used by multisearchers to determine how to collate results from their searchers.

IComparable SortValue(
ScoreDoc i
);

Parameters

i
Document

Return Value

Serializable object

See Also

ScoreDocComparator Interface | Lucene.Net.Search Namespace |


ScoreDocComparator_Fields Structure

For a list of all members of this type, see ScoreDocComparator_Fields Members.

System.Object
System.ValueType
Lucene.Net.Search.ScoreDocComparator_Fields

public struct ScoreDocComparator_Fields

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ScoreDocComparator_Fields Members | Lucene.Net.Search Namespace


ScoreDocComparator_Fields Members

ScoreDocComparator_Fields overview

Public Static Fields

INDEXORDER | Special comparator for sorting hits according to index order (document number).
RELEVANCE | Special comparator for sorting hits according to computed relevance (document score).

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ScoreDocComparator_Fields Class | Lucene.Net.Search Namespace


ScoreDocComparator_Fields Fields

The fields of the ScoreDocComparator_Fields structure are listed below. For a complete list of ScoreDocComparator_Fields structure members, see the ScoreDocComparator_Fields Members topic.

Public Static Fields

INDEXORDER | Special comparator for sorting hits according to index order (document number).
RELEVANCE | Special comparator for sorting hits according to computed relevance (document score).

See Also

ScoreDocComparator_Fields Class | Lucene.Net.Search Namespace


ScoreDocComparator_Fields.INDEXORDER Field

Special comparator for sorting hits according to index order (document number).

public static readonly ScoreDocComparator INDEXORDER;

See Also

ScoreDocComparator_Fields Class | Lucene.Net.Search Namespace


ScoreDocComparator_Fields.RELEVANCE Field

Special comparator for sorting hits according to computed relevance (document score).

public static readonly ScoreDocComparator RELEVANCE;

See Also

ScoreDocComparator_Fields Class | Lucene.Net.Search Namespace


Scorer Class

Expert: Implements scoring for a class of queries.

For a list of all members of this type, see Scorer Members.

System.Object
Lucene.Net.Search.Scorer

public abstract class Scorer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Scorer Members | Lucene.Net.Search Namespace


Scorer Members

Scorer overview

Public Instance Methods

Doc | Returns the current document number. Initially invalid, until {@link #Next()} is called the first time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain Returns an explanation of the score for
doc
.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Advance to the next document matching the query. Returns true iff there is another match.
Score | Overloaded. Returns the score of the current document. Initially invalid, until {@link #Next()} is called the first time.
SkipTo
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

Scorer Constructor Constructs a Scorer.

See Also

Scorer Class | Lucene.Net.Search Namespace


Scorer Constructor

Constructs a Scorer.

protected internal Scorer(
Similarity similarity
);

See Also

Scorer Class | Lucene.Net.Search Namespace


Scorer Methods

The methods of the Scorer class are listed below. For a complete list of Scorer class members, see the Scorer Members topic.

Public Instance Methods

Doc | Returns the current document number. Initially invalid, until {@link #Next()} is called the first time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain Returns an explanation of the score for
doc
.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Advance to the next document matching the query. Returns true iff there is another match.
Score | Overloaded. Returns the score of the current document. Initially invalid, until {@link #Next()} is called the first time.
SkipTo
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Scorer Class | Lucene.Net.Search Namespace


Scorer.Doc Method

Returns the current document number. Initially invalid, until {@link #Next()} is called the first time.

public abstract int Doc();

See Also

Scorer Class | Lucene.Net.Search Namespace


Scorer.Explain Method

Returns an explanation of the score for

doc
.

public abstract Explanation Explain(
int doc
);

See Also

Scorer Class | Lucene.Net.Search Namespace


Scorer.GetSimilarity Method

Returns the Similarity implementation used by this scorer.

public virtual Similarity GetSimilarity();

See Also

Scorer Class | Lucene.Net.Search Namespace


Scorer.Next Method

Advance to the next document matching the query. Returns true iff there is another match.

public abstract bool Next();

See Also

Scorer Class | Lucene.Net.Search Namespace


Score Method

An NDoc Documented Class Library

Scorer.Score Method

Returns the score of the current document. Initially invalid, until {@link #Next()} is called the first time.

Overload List

Returns the score of the current document. Initially invalid, until {@link #Next()} is called the first time.

public abstract float Score();

Scores all documents and passes them to a collector.

public virtual void Score(HitCollector);

See Also

Scorer Class | Lucene.Net.Search Namespace


Scorer.Score Method ()

Returns the score of the current document. Initially invalid, until {@link #Next()} is called the first time.

public abstract float Score();

See Also

Scorer Class | Lucene.Net.Search Namespace | Scorer.Score Overload List


Scorer.Score Method (HitCollector)

Scores all documents and passes them to a collector.

public virtual void Score(
HitCollector hc
);

See Also

Scorer Class | Lucene.Net.Search Namespace | Scorer.Score Overload List


Scorer.SkipTo Method

public abstract bool SkipTo(
int target
);

See Also

Scorer Class | Lucene.Net.Search Namespace


Searchable Interface

For a list of all members of this type, see Searchable Members.

public interface Searchable

Types that implement Searchable

Type | Description
IndexSearcher |
MultiSearcher |
ParallelMultiSearcher |
RemoteSearchable | A remote searchable implementation.
Searcher | An abstract base class for search implementations. Implements some common utility methods.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Searchable Members | Lucene.Net.Search Namespace


Searchable Members

Searchable overview

Public Instance Methods

Close | Frees resources associated with this Searcher. Be careful not to call this method while you are still using objects like {@link Hits}.
Doc Expert: Returns the stored fields of document
i
. Called by {@link HitCollector} implementations.
DocFreq Expert: Returns the number of documents containing
term
. Called by search code to compute term weights.
Explain
MaxDoc | Expert: Returns one greater than the largest possible document number. Called by search code to compute term weights.
Rewrite | Expert: called to re-write queries into primitive queries.
Search | Overloaded.

See Also

Searchable Interface | Lucene.Net.Search Namespace


Searchable Methods

The methods of the Searchable interface are listed below. For a complete list of Searchable interface members, see the Searchable Members topic.

Public Instance Methods

Close | Frees resources associated with this Searcher. Be careful not to call this method while you are still using objects like {@link Hits}.
Doc Expert: Returns the stored fields of document
i
. Called by {@link HitCollector} implementations.
DocFreq Expert: Returns the number of documents containing
term
. Called by search code to compute term weights.
Explain
MaxDoc | Expert: Returns one greater than the largest possible document number. Called by search code to compute term weights.
Rewrite | Expert: called to re-write queries into primitive queries.
Search | Overloaded.

See Also

Searchable Interface | Lucene.Net.Search Namespace


Searchable.Close Method

Frees resources associated with this Searcher. Be careful not to call this method while you are still using objects like {@link Hits}.

void Close();

See Also

Searchable Interface | Lucene.Net.Search Namespace


Searchable.Doc Method

Expert: Returns the stored fields of document

i
. Called by {@link HitCollector} implementations.

Document Doc(
int i
);

See Also

Searchable Interface | Lucene.Net.Search Namespace | IndexReader#document


Searchable.DocFreq Method

Expert: Returns the number of documents containing

term
. Called by search code to compute term weights.

int DocFreq(
Term term
);

See Also

Searchable Interface | Lucene.Net.Search Namespace | IndexReader#docFreq


Searchable.Explain Method

Explanation Explain(
Query query,
int doc
);

See Also

Searchable Interface | Lucene.Net.Search Namespace


Searchable.MaxDoc Method

Expert: Returns one greater than the largest possible document number. Called by search code to compute term weights.

int MaxDoc();

See Also

Searchable Interface | Lucene.Net.Search Namespace | IndexReader#maxDoc


Searchable.Rewrite Method

Expert: called to re-write queries into primitive queries.

Query Rewrite(
Query query
);

See Also

Searchable Interface | Lucene.Net.Search Namespace


Search Method

An NDoc Documented Class Library

Searchable.Search Method

Overload List

void Search(Query,Filter,HitCollector);

TopDocs Search(Query,Filter,int);

TopFieldDocs Search(Query,Filter,int,Sort);

See Also

Searchable Interface | Lucene.Net.Search Namespace


Searchable.Search Method (Query, Filter, HitCollector)

void Search(
Query query,
Filter filter,
HitCollector results
);

See Also

Searchable Interface | Lucene.Net.Search Namespace | Searchable.Search Overload List


Searchable.Search Method (Query, Filter, Int32)

TopDocs Search(
Query query,
Filter filter,
int n
);

See Also

Searchable Interface | Lucene.Net.Search Namespace | Searchable.Search Overload List


Searchable.Search Method (Query, Filter, Int32, Sort)

TopFieldDocs Search(
Query query,
Filter filter,
int n,
Sort sort
);

See Also

Searchable Interface | Lucene.Net.Search Namespace | Searchable.Search Overload List


Searcher Class

An abstract base class for search implementations. Implements some common utility methods.

For a list of all members of this type, see Searcher Members.

System.Object
Lucene.Net.Search.Searcher
Lucene.Net.Search.IndexSearcher
Lucene.Net.Search.MultiSearcher

public abstract class Searcher : Searchable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Searcher Members | Lucene.Net.Search Namespace


Searcher Members

Searcher overview

Public Instance Constructors

Searcher Constructor Initializes a new instance of the Searcher class.

Public Instance Methods

Close |
Doc |
DocFreq |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity |
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc |
Rewrite |
Search | Overloaded.
SetSimilarity | Expert: Set the Similarity implementation used by this Searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher Constructor

Initializes a new instance of the Searcher class.

public Searcher();

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher Methods

The methods of the Searcher class are listed below. For a complete list of Searcher class members, see the Searcher Members topic.

Public Instance Methods

Close |
Doc |
DocFreq |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity |
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc |
Rewrite |
Search | Overloaded.
SetSimilarity | Expert: Set the Similarity implementation used by this Searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.Close Method

public abstract void Close();

Implements

Searchable.Close

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.Doc Method

public abstract Document Doc(
int param1
);

Implements

Searchable.Doc

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.DocFreq Method

public abstract int DocFreq(
Term param1
);

Implements

Searchable.DocFreq

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.Explain Method

public abstract Explanation Explain(
Query param1,
int param2
);

Implements

Searchable.Explain

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.GetSimilarity Method

public virtual Similarity GetSimilarity();

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.MaxDoc Method

public abstract int MaxDoc();

Implements

Searchable.MaxDoc

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.Rewrite Method

public abstract Query Rewrite(
Query param1
);

Implements

Searchable.Rewrite

See Also

Searcher Class | Lucene.Net.Search Namespace


Search Method

An NDoc Documented Class Library

Searcher.Search Method

Returns the documents matching

query
.

Overload List

Returns the documents matching

query
.

public Hits Search(Query);

Returns the documents matching

query
and
filter
.

public virtual Hits Search(Query,Filter);

public abstract void Search(Query,Filter,HitCollector);

Returns documents matching

query
and
filter
, sorted by
sort
.

public virtual Hits Search(Query,Filter,Sort);

public abstract TopDocs Search(Query,Filter,int);

public abstract TopFieldDocs Search(Query,Filter,int,Sort);

public virtual void Search(Query,HitCollector);

Returns documents matching

query
sorted by
sort
.

public virtual Hits Search(Query,Sort);

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.Search Method (Query)

Returns the documents matching

query
.

public Hits Search(
Query query
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Filter)

Returns the documents matching

query
and
filter
.

public virtual Hits Search(
Query query,
Filter filter
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Filter, HitCollector)

public abstract void Search(
Query param1,
Filter param2,
HitCollector param3
);

Implements

Searchable.Search

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Filter, Sort)

Returns documents matching

query
and
filter
, sorted by
sort
.

public virtual Hits Search(
Query query,
Filter filter,
Sort sort
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Filter, Int32)

public abstract TopDocs Search(
Query param1,
Filter param2,
int param3
);

Implements

Searchable.Search

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Filter, Int32, Sort)

public abstract TopFieldDocs Search(
Query param1,
Filter param2,
int param3,
Sort param4
);

Implements

Searchable.Search

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, HitCollector)

public virtual void Search(
Query query,
HitCollector results
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Sort)

Returns documents matching

query
sorted by
sort
.

public virtual Hits Search(
Query query,
Sort sort
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.SetSimilarity Method

Expert: Set the Similarity implementation used by this Searcher.

public virtual void SetSimilarity(
Similarity similarity
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Similarity#SetDefault


Similarity Class

For a list of all members of this type, see Similarity Members.

System.Object
Lucene.Net.Search.Similarity
Lucene.Net.Search.DefaultSimilarity

public abstract class Similarity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Similarity Members | Lucene.Net.Search Namespace


Similarity Members

Similarity overview

Public Static Methods

DecodeNorm | Decodes a normalization factor stored in an index.
EncodeNorm |
GetDefault |
SetDefault | Set the default Similarity implementation used by indexing and search code.

Public Instance Methods

Coord |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Idf | Overloaded.
LengthNorm |
QueryNorm |
SloppyFreq |
Tf | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Similarity Constructor Initializes a new instance of the Similarity class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity Constructor

Initializes a new instance of the Similarity class.

protected Similarity();

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity Methods

The methods of the Similarity class are listed below. For a complete list of Similarity class members, see the Similarity Members topic.

Public Static Methods

DecodeNorm | Decodes a normalization factor stored in an index.
EncodeNorm |
GetDefault |
SetDefault | Set the default Similarity implementation used by indexing and search code.

Public Instance Methods

Coord |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Idf | Overloaded.
LengthNorm |
QueryNorm |
SloppyFreq |
Tf | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.Coord Method

public abstract float Coord(
int overlap,
int maxOverlap
);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.DecodeNorm Method

Decodes a normalization factor stored in an index.

public static float DecodeNorm(
byte b
);

See Also

Similarity Class | Lucene.Net.Search Namespace | #EncodeNorm


Similarity.EncodeNorm Method

public static byte EncodeNorm(
float f
);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.GetDefault Method

public static Similarity GetDefault();

See Also

Similarity Class | Lucene.Net.Search Namespace


Idf Method

An NDoc Documented Class Library

Similarity.Idf Method

Overload List

public virtual float Idf(Term,Searcher);

public virtual float Idf(ICollection,Searcher);

public abstract float Idf(int,int);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.Idf Method (Term, Searcher)

public virtual float Idf(
Term term,
Searcher searcher
);

See Also

Similarity Class | Lucene.Net.Search Namespace | Similarity.Idf Overload List


Similarity.Idf Method (ICollection, Searcher)

public virtual float Idf(
ICollection terms,
Searcher searcher
);

See Also

Similarity Class | Lucene.Net.Search Namespace | Similarity.Idf Overload List


Similarity.Idf Method (Int32, Int32)

public abstract float Idf(
int docFreq,
int numDocs
);

See Also

Similarity Class | Lucene.Net.Search Namespace | Similarity.Idf Overload List


Similarity.LengthNorm Method

public abstract float LengthNorm(
string fieldName,
int numTokens
);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.QueryNorm Method

public abstract float QueryNorm(
float sumOfSquaredWeights
);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.SetDefault Method

Set the default Similarity implementation used by indexing and search code.

public static void SetDefault(
Similarity similarity
);

See Also

Similarity Class | Lucene.Net.Search Namespace | Searcher#SetSimilarity | IndexWriter#SetSimilarity


Similarity.SloppyFreq Method

public abstract float SloppyFreq(
int distance
);

See Also

Similarity Class | Lucene.Net.Search Namespace


Tf Method

An NDoc Documented Class Library

Similarity.Tf Method

Overload List

public virtual float Tf(int);

public abstract float Tf(float);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.Tf Method (Int32)

public virtual float Tf(
int freq
);

See Also

Similarity Class | Lucene.Net.Search Namespace | Similarity.Tf Overload List


Similarity.Tf Method (Single)

public abstract float Tf(
float freq
);

See Also

Similarity Class | Lucene.Net.Search Namespace | Similarity.Tf Overload List


Sort Class

For a list of all members of this type, see Sort Members.

System.Object
Lucene.Net.Search.Sort

public class Sort

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Sort Members | Lucene.Net.Search Namespace


Sort Members

Sort overview

Public Static Fields

INDEXORDER | Represents sorting by index order.
RELEVANCE | Represents sorting by computed relevance. Using this sort criteria returns the same results as calling {@link Searcher#Search(Query) Searcher#search()} without a sort criteria, only with slightly more overhead.

Public Instance Constructors

Sort Overloaded. Initializes a new instance of the Sort class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetSort | Overloaded. Sets the sort to the given criteria in succession.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Sort Class | Lucene.Net.Search Namespace


Sort Constructor

Sorts by computed relevance. This is the same sort criteria as calling {@link Searcher#Search(Query) Searcher#search()} without a sort criteria, only with slightly more overhead.

Overload List

Sorts by computed relevance. This is the same sort criteria as calling {@link Searcher#Search(Query) Searcher#search()} without a sort criteria, only with slightly more overhead.

public Sort();

Sorts by the criteria in the given SortField.

public Sort(SortField);

Sorts in succession by the criteria in each SortField.

public Sort(SortField[]);

Sorts by the terms in

Field
then by index order (document number). The type of value in
Field
is determined automatically.

public Sort(string);

Sorts possibly in reverse by the terms in

Field
then by index order (document number). The type of value in
Field
is determined automatically.

public Sort(string,bool);

Sorts in succession by the terms in each Field. The type of value in

Field
is determined automatically.

public Sort(string[]);

See Also

Sort Class | Lucene.Net.Search Namespace


Sort Constructor ()

Sorts by computed relevance. This is the same sort criteria as calling {@link Searcher#Search(Query) Searcher#search()} without a sort criteria, only with slightly more overhead.

public Sort();

See Also

Sort Class | Lucene.Net.Search Namespace | Sort Constructor Overload List


Sort Constructor (String)

Sorts by the terms in

Field
then by index order (document number). The type of value in
Field
is determined automatically.

public Sort(
string field
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort Constructor Overload List | SortField#AUTO


Sort Constructor (String, Boolean)

Sorts possibly in reverse by the terms in

Field
then by index order (document number). The type of value in
Field
is determined automatically.

public Sort(
string field,
bool reverse
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort Constructor Overload List | SortField#AUTO


Sort Constructor (String[])

Sorts in succession by the terms in each Field. The type of value in

Field
is determined automatically.

public Sort(
string[] fields
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort Constructor Overload List | SortField#AUTO


Sort Constructor (SortField)

Sorts by the criteria in the given SortField.

public Sort(
SortField field
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort Constructor Overload List


Sort Constructor (SortField[])

Sorts in succession by the criteria in each SortField.

public Sort(
SortField[] fields
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort Constructor Overload List


Sort Fields

The fields of the Sort class are listed below. For a complete list of Sort class members, see the Sort Members topic.

Public Static Fields

INDEXORDER | Represents sorting by index order.
RELEVANCE | Represents sorting by computed relevance. Using this sort criteria returns the same results as calling {@link Searcher#Search(Query) Searcher#search()} without a sort criteria, only with slightly more overhead.

See Also

Sort Class | Lucene.Net.Search Namespace


Sort.INDEXORDER Field

Represents sorting by index order.

public static readonly Sort INDEXORDER;

See Also

Sort Class | Lucene.Net.Search Namespace


Sort.RELEVANCE Field

Represents sorting by computed relevance. Using this sort criteria returns the same results as calling {@link Searcher#Search(Query) Searcher#search()} without a sort criteria, only with slightly more overhead.

public static readonly Sort RELEVANCE;

See Also

Sort Class | Lucene.Net.Search Namespace


Sort Methods

The methods of the Sort class are listed below. For a complete list of Sort class members, see the Sort Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetSort | Overloaded. Sets the sort to the given criteria in succession.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Sort Class | Lucene.Net.Search Namespace


SetSort Method

An NDoc Documented Class Library

Sort.SetSort Method

Sets the sort to the given criteria.

Overload List

Sets the sort to the given criteria.

public virtual void SetSort(SortField);

Sets the sort to the given criteria in succession.

public virtual void SetSort(SortField[]);

Sets the sort to the terms in

Field
then by index order (document number).

public void SetSort(string);

Sets the sort to the terms in

Field
possibly in reverse, then by index order (document number).

public virtual void SetSort(string,bool);

Sets the sort to the terms in each Field in succession.

public virtual void SetSort(string[]);

See Also

Sort Class | Lucene.Net.Search Namespace


Sort.SetSort Method (SortField)

Sets the sort to the given criteria.

public virtual void SetSort(
SortField field
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort.SetSort Overload List


Sort.SetSort Method (SortField[])

Sets the sort to the given criteria in succession.

public virtual void SetSort(
SortField[] fields
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort.SetSort Overload List


Sort.SetSort Method (String)

Sets the sort to the terms in

Field
then by index order (document number).

public void SetSort(
string field
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort.SetSort Overload List


Sort.SetSort Method (String, Boolean)

Sets the sort to the terms in

Field
possibly in reverse, then by index order (document number).

public virtual void SetSort(
string field,
bool reverse
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort.SetSort Overload List


Sort.SetSort Method (String[])

Sets the sort to the terms in each Field in succession.

public virtual void SetSort(
string[] fieldnames
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort.SetSort Overload List


Sort.ToString Method

public override string ToString();

See Also

Sort Class | Lucene.Net.Search Namespace


SortComparator Class

For a list of all members of this type, see SortComparator Members.

System.Object
Lucene.Net.Search.SortComparator

public abstract class SortComparator : SortComparatorSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SortComparator Members | Lucene.Net.Search Namespace


SortComparator Members

SortComparator overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetComparable |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NewComparator |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

SortComparator Constructor Initializes a new instance of the SortComparator class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortComparator Class | Lucene.Net.Search Namespace


SortComparator Constructor

Initializes a new instance of the SortComparator class.

protected SortComparator();

See Also

SortComparator Class | Lucene.Net.Search Namespace


SortComparator Methods

The methods of the SortComparator class are listed below. For a complete list of SortComparator class members, see the SortComparator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetComparable |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NewComparator |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortComparator Class | Lucene.Net.Search Namespace


SortComparator.GetComparable Method

public abstract IComparable GetComparable(
string termtext
);

See Also

SortComparator Class | Lucene.Net.Search Namespace


SortComparator.NewComparator Method

public virtual ScoreDocComparator NewComparator(
IndexReader reader,
string fieldname
);

Implements

SortComparatorSource.NewComparator

See Also

SortComparator Class | Lucene.Net.Search Namespace


SortComparatorSource Interface

For a list of all members of this type, see SortComparatorSource Members.

public interface SortComparatorSource

Types that implement SortComparatorSource

Type | Description
SortComparator |

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SortComparatorSource Members | Lucene.Net.Search Namespace


SortComparatorSource Members

SortComparatorSource overview

Public Instance Methods

NewComparator Creates a comparator for the Field in the given index.

See Also

SortComparatorSource Interface | Lucene.Net.Search Namespace


SortComparatorSource Methods

The methods of the SortComparatorSource interface are listed below. For a complete list of SortComparatorSource interface members, see the SortComparatorSource Members topic.

Public Instance Methods

NewComparator Creates a comparator for the Field in the given index.

See Also

SortComparatorSource Interface | Lucene.Net.Search Namespace


SortComparatorSource.NewComparator Method

Creates a comparator for the Field in the given index.

ScoreDocComparator NewComparator(
IndexReader reader,
string fieldname
);

Parameters

reader
Index to create comparator for.
fieldname
Field to create comparator for.

Return Value

Comparator of ScoreDoc objects.

See Also

SortComparatorSource Interface | Lucene.Net.Search Namespace


SortField Class

For a list of all members of this type, see SortField Members.

System.Object
Lucene.Net.Search.SortField

public class SortField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SortField Members | Lucene.Net.Search Namespace


SortField Members

SortField overview

Public Static Fields

AUTO | Guess type of sort based on Field contents. A regular expression is used to look at the first term indexed for the Field and determine if it represents an integer number, a floating point number, or just arbitrary string characters.
CUSTOM | Sort using a custom Comparator. Sort values are any Comparable and sorting is done according to natural order.
DOC | Sort by document number (index order). Sort values are Integer and lower values are at the front.
FIELD_DOC | Represents sorting by document number (index order).
FIELD_SCORE | Represents sorting by document score (relevancy).
FLOAT | Sort using term values as encoded Floats. Sort values are Float and lower values are at the front.
INT | Sort using term values as encoded Integers. Sort values are Integer and lower values are at the front.
SCORE | Sort by document score (relevancy). Sort values are Float and higher values are at the front.
STRING | Sort using term values as Strings. Sort values are String and lower values are at the front.

Public Instance Constructors

SortField Overloaded. Initializes a new instance of the SortField class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFactory
GetField Returns the name of the Field. Could return
null
if the sort is by SCORE or DOC.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLocale Returns the Locale by which term values are interpreted. May return
null
if no Locale was specified.
GetReverse | Returns whether the sort should be reversed.
GetType | Returns the type of contents in the Field.
ToString

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortField Class | Lucene.Net.Search Namespace


SortField Constructor

Creates a sort by terms in the given Field where the type of term value is determined dynamically ({@link #AUTO AUTO}).

Overload List

Creates a sort by terms in the given Field where the type of term value is determined dynamically ({@link #AUTO AUTO}).

public SortField(string);

Creates a sort with a custom comparison function.

public SortField(string,SortComparatorSource);

Creates a sort, possibly in reverse, with a custom comparison function.

public SortField(string,SortComparatorSource,bool);

Creates a sort, possibly in reverse, by terms in the given Field where the type of term value is determined dynamically ({@link #AUTO AUTO}).

public SortField(string,bool);

Creates a sort by terms in the given Field sorted according to the given locale.

public SortField(string,CultureInfo);

Creates a sort, possibly in reverse, by terms in the given Field sorted according to the given locale.

public SortField(string,CultureInfo,bool);

Creates a sort by terms in the given Field with the type of term values explicitly given.

public SortField(string,int);

Creates a sort, possibly in reverse, by terms in the given Field with the type of term values explicitly given.

public SortField(string,int,bool);

See Also

SortField Class | Lucene.Net.Search Namespace


SortField Constructor (String)

Creates a sort by terms in the given Field where the type of term value is determined dynamically ({@link #AUTO AUTO}).

public SortField(
string field
);

Parameters

field

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, Boolean)

Creates a sort, possibly in reverse, by terms in the given Field where the type of term value is determined dynamically ({@link #AUTO AUTO}).

public SortField(
string field,
bool reverse
);

Parameters

field
reverse
True if natural order should be reversed.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, Int32)

Creates a sort by terms in the given Field with the type of term values explicitly given.

public SortField(
string field,
int type
);

Parameters

field
type
Type of values in the terms.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, Int32, Boolean)

Creates a sort, possibly in reverse, by terms in the given Field with the type of term values explicitly given.

public SortField(
string field,
int type,
bool reverse
);

Parameters

field
type
Type of values in the terms.
reverse
True if natural order should be reversed.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, CultureInfo)

Creates a sort by terms in the given Field sorted according to the given locale.

public SortField(
string field,
CultureInfo locale
);

Parameters

field
locale
Locale of values in the Field.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, CultureInfo, Boolean)

Creates a sort, possibly in reverse, by terms in the given Field sorted according to the given locale.

public SortField(
string field,
CultureInfo locale,
bool reverse
);

Parameters

field
locale
Locale of values in the Field.
reverse

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, SortComparatorSource)

Creates a sort with a custom comparison function.

public SortField(
string field,
SortComparatorSource comparator
);

Parameters

field
comparator
Returns a comparator for sorting hits.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, SortComparatorSource, Boolean)

Creates a sort, possibly in reverse, with a custom comparison function.

public SortField(
string field,
SortComparatorSource comparator,
bool reverse
);

Parameters

field
comparator
Returns a comparator for sorting hits.
reverse
True if natural order should be reversed.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Fields

The fields of the SortField class are listed below. For a complete list of SortField class members, see the SortField Members topic.

Public Static Fields

AUTO | Guess type of sort based on Field contents. A regular expression is used to look at the first term indexed for the Field and determine if it represents an integer number, a floating point number, or just arbitrary string characters.
CUSTOM | Sort using a custom Comparator. Sort values are any Comparable and sorting is done according to natural order.
DOC | Sort by document number (index order). Sort values are Integer and lower values are at the front.
FIELD_DOC | Represents sorting by document number (index order).
FIELD_SCORE | Represents sorting by document score (relevancy).
FLOAT | Sort using term values as encoded Floats. Sort values are Float and lower values are at the front.
INT | Sort using term values as encoded Integers. Sort values are Integer and lower values are at the front.
SCORE | Sort by document score (relevancy). Sort values are Float and higher values are at the front.
STRING | Sort using term values as Strings. Sort values are String and lower values are at the front.

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.AUTO Field

Guess type of sort based on Field contents. A regular expression is used to look at the first term indexed for the Field and determine if it represents an integer number, a floating point number, or just arbitrary string characters.

public const int AUTO = 2;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.CUSTOM Field

Sort using a custom Comparator. Sort values are any Comparable and sorting is done according to natural order.

public const int CUSTOM = 9;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.DOC Field

Sort by document number (index order). Sort values are Integer and lower values are at the front.

public const int DOC = 1;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.FIELD_DOC Field

Represents sorting by document number (index order).

public static readonly SortField FIELD_DOC;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.FIELD_SCORE Field

Represents sorting by document score (relevancy).

public static readonly SortField FIELD_SCORE;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.FLOAT Field

Sort using term values as encoded Floats. Sort values are Float and lower values are at the front.

public const int FLOAT = 5;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.INT Field

Sort using term values as encoded Integers. Sort values are Integer and lower values are at the front.

public const int INT = 4;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.SCORE Field

Sort by document score (relevancy). Sort values are Float and higher values are at the front.

public const int SCORE = 0;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.STRING Field

Sort using term values as Strings. Sort values are String and lower values are at the front.

public const int STRING = 3;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField Methods

The methods of the SortField class are listed below. For a complete list of SortField class members, see the SortField Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFactory
GetField Returns the name of the Field. Could return
null
if the sort is by SCORE or DOC.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLocale Returns the Locale by which term values are interpreted. May return
null
if no Locale was specified.
GetReverse | Returns whether the sort should be reversed.
GetType | Returns the type of contents in the Field.
ToString

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.GetFactory Method

public virtual SortComparatorSource GetFactory();

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.GetField Method

Returns the name of the Field. Could return

null
if the sort is by SCORE or DOC.

public virtual string GetField();

Return Value

Name of Field, possibly

null
.

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.GetLocale Method

Returns the Locale by which term values are interpreted. May return

null
if no Locale was specified.

public virtual CultureInfo GetLocale();

Return Value

Locale, or

null
.

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.GetReverse Method

Returns whether the sort should be reversed.

public virtual bool GetReverse();

Return Value

True if natural order should be reversed.

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.GetType Method

Returns the type of contents in the Field.

new public virtual int GetType();

Return Value

One of the constants SCORE, DOC, AUTO, STRING, INT or FLOAT.

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.ToString Method

public override string ToString();

See Also

SortField Class | Lucene.Net.Search Namespace


StringIndex Class

For a list of all members of this type, see StringIndex Members.

System.Object
Lucene.Net.Search.StringIndex

public class StringIndex

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StringIndex Members | Lucene.Net.Search Namespace


StringIndex Members

StringIndex overview

Public Instance Constructors

StringIndex Constructor Creates one of these objects

Public Instance Fields

lookup | All the term values, in natural order.
order | For each document, an index into the lookup array.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringIndex Class | Lucene.Net.Search Namespace


StringIndex Constructor

Creates one of these objects

public StringIndex(
int[] values,
string[] lookup
);

See Also

StringIndex Class | Lucene.Net.Search Namespace


StringIndex Fields

The fields of the StringIndex class are listed below. For a complete list of StringIndex class members, see the StringIndex Members topic.

Public Instance Fields

lookup | All the term values, in natural order.
order | For each document, an index into the lookup array.

See Also

StringIndex Class | Lucene.Net.Search Namespace


StringIndex.lookup Field

All the term values, in natural order.

public string[] lookup;

See Also

StringIndex Class | Lucene.Net.Search Namespace


StringIndex.order Field

For each document, an index into the lookup array.

public int[] order;

See Also

StringIndex Class | Lucene.Net.Search Namespace


TermQuery Class

A Query that matches documents containing a term. This may be combined with other terms with a {@link BooleanQuery}.

For a list of all members of this type, see TermQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.TermQuery

public class TermQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermQuery Members | Lucene.Net.Search Namespace


TermQuery Members

TermQuery overview

Public Instance Constructors

TermQuery Constructor Constructs a query for the term
t
.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals Returns true iff
o
is equal to this.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm | Returns the term of this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery Constructor

Constructs a query for the term

t
.

public TermQuery(
Term t
);

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery Methods

The methods of the TermQuery class are listed below. For a complete list of TermQuery class members, see the TermQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals Returns true iff
o
is equal to this.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm | Returns the term of this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery.GetTerm Method

Returns the term of this query.

public virtual Term GetTerm();

See Also

TermQuery Class | Lucene.Net.Search Namespace


ToString Method

An NDoc Documented Class Library

TermQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string field
);

See Also

TermQuery Class | Lucene.Net.Search Namespace | TermQuery.ToString Overload List


TopDocs Class

Expert: Returned by low-level search implementations.

For a list of all members of this type, see TopDocs Members.

System.Object
Lucene.Net.Search.TopDocs
Lucene.Net.Search.TopFieldDocs

public class TopDocs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TopDocs Members | Lucene.Net.Search Namespace | Searcher#Search


TopDocs Members

TopDocs overview

Public Instance Fields

scoreDocs | Expert: The top hits for the query.
totalHits | Expert: The total number of hits for the query.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TopDocs Class | Lucene.Net.Search Namespace | Searcher#Search


TopDocs Fields

The fields of the TopDocs class are listed below. For a complete list of TopDocs class members, see the TopDocs Members topic.

Public Instance Fields

scoreDocs | Expert: The top hits for the query.
totalHits | Expert: The total number of hits for the query.

See Also

TopDocs Class | Lucene.Net.Search Namespace | Searcher#Search


TopDocs.scoreDocs Field

Expert: The top hits for the query.

public ScoreDoc[] scoreDocs;

See Also

TopDocs Class | Lucene.Net.Search Namespace


TopDocs.totalHits Field

Expert: The total number of hits for the query.

public int totalHits;

See Also

TopDocs Class | Lucene.Net.Search Namespace | Hits#Length


TopFieldDocs Class

For a list of all members of this type, see TopFieldDocs Members.

System.Object
Lucene.Net.Search.TopDocs
Lucene.Net.Search.TopFieldDocs

public class TopFieldDocs : TopDocs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TopFieldDocs Members | Lucene.Net.Search Namespace


TopFieldDocs Members

TopFieldDocs overview

Public Instance Fields

fields | The fields which were used to sort results by.
scoreDocs (inherited from TopDocs) | Expert: The top hits for the query.
totalHits (inherited from TopDocs) | Expert: The total number of hits for the query.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TopFieldDocs Class | Lucene.Net.Search Namespace


TopFieldDocs Fields

The fields of the TopFieldDocs class are listed below. For a complete list of TopFieldDocs class members, see the TopFieldDocs Members topic.

Public Instance Fields

fields | The fields which were used to sort results by.
scoreDocs (inherited from TopDocs) | Expert: The top hits for the query.
totalHits (inherited from TopDocs) | Expert: The total number of hits for the query.

See Also

TopFieldDocs Class | Lucene.Net.Search Namespace


TopFieldDocs.fields Field

The fields which were used to sort results by.

public SortField[] fields;

See Also

TopFieldDocs Class | Lucene.Net.Search Namespace


Weight Interface

For a list of all members of this type, see Weight Members.

public interface Weight

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Weight Members | Lucene.Net.Search Namespace


Weight Members

Weight overview

Public Instance Properties

Query | The query that this concerns.
Value | The weight for this query.

Public Instance Methods

Explain | An explanation of the score computation for the named document.
Normalize | Assigns the query normalization factor to this.
Scorer | Constructs a scorer for this.
SumOfSquaredWeights | The sum of squared weights of contained query clauses.

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight Properties

The properties of the Weight interface are listed below. For a complete list of Weight interface members, see the Weight Members topic.

Public Instance Properties

Query | The query that this concerns.
Value | The weight for this query.

See Also

Weight Interface | Lucene.Net.Search Namespace


Query Property

An NDoc Documented Class Library

Weight.Query Property

The query that this concerns.

Query Query {get;}

See Also

Weight Interface | Lucene.Net.Search Namespace


Value Property

An NDoc Documented Class Library

Weight.Value Property

The weight for this query.

float Value {get;}

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight Methods

The methods of the Weight interface are listed below. For a complete list of Weight interface members, see the Weight Members topic.

Public Instance Methods

Explain | An explanation of the score computation for the named document.
Normalize | Assigns the query normalization factor to this.
Scorer | Constructs a scorer for this.
SumOfSquaredWeights | The sum of squared weights of contained query clauses.

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight.Explain Method

An explanation of the score computation for the named document.

Explanation Explain(
IndexReader reader,
int doc
);

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight.Normalize Method

Assigns the query normalization factor to this.

void Normalize(
float norm
);

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight.Scorer Method

Constructs a scorer for this.

Scorer Scorer(
IndexReader reader
);

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight.SumOfSquaredWeights Method

The sum of squared weights of contained query clauses.

float SumOfSquaredWeights();

See Also

Weight Interface | Lucene.Net.Search Namespace


WildcardQuery Class

Implements the wildcard search query. Supported wildcards are

*
, which matches any character sequence (including the empty one), and
?
, which matches any single character. Note this query can be slow, as it needs to iterate over all terms. In order to prevent extremely slow WildcardQueries, a Wildcard term must not start with one of the wildcards
*
or
?
.

For a list of all members of this type, see WildcardQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.MultiTermQuery
Lucene.Net.Search.WildcardQuery

public class WildcardQuery : MultiTermQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

WildcardQuery Members | Lucene.Net.Search Namespace |


WildcardQuery Members

WildcardQuery overview

Public Instance Constructors

WildcardQuery Constructor

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from MultiTermQuery)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm (inherited from MultiTermQuery) | Returns the pattern term.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from MultiTermQuery)
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString (inherited from MultiTermQuery) | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)
GetEnum

See Also

WildcardQuery Class | Lucene.Net.Search Namespace |


WildcardQuery Constructor

public WildcardQuery(
Term term
);

See Also

WildcardQuery Class | Lucene.Net.Search Namespace


WildcardQuery Methods

The methods of the WildcardQuery class are listed below. For a complete list of WildcardQuery class members, see the WildcardQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from MultiTermQuery)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm (inherited from MultiTermQuery) | Returns the pattern term.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from MultiTermQuery)
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString (inherited from MultiTermQuery) | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)
GetEnum

See Also

WildcardQuery Class | Lucene.Net.Search Namespace |


WildcardQuery.GetEnum Method

protected internal override FilteredTermEnum GetEnum(
IndexReader reader
);

See Also

WildcardQuery Class | Lucene.Net.Search Namespace


WildcardTermEnum Class

For a list of all members of this type, see WildcardTermEnum Members.

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Search.FilteredTermEnum
Lucene.Net.Search.WildcardTermEnum

public class WildcardTermEnum : FilteredTermEnum

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

WildcardTermEnum Members | Lucene.Net.Search Namespace


WildcardTermEnum Members

WildcardTermEnum overview

Public Static Fields

WILDCARD_CHAR |
WILDCARD_STRING | ***************************************** String equality with support for wildcards ******************************************

Public Static Methods

WildcardEquals Determines if a word matches a wildcard pattern. Work released by Granta Design Ltd after originally being done on company time.

Public Instance Constructors

WildcardTermEnum Constructor Creates a new
WildcardTermEnum
. Passing in a {@link Lucene.Net.Index.Term Term} that does not contain a
WILDCARD_CHAR
will cause an exception to be thrown.

Public Instance Methods

Close |
Difference |
DocFreq (inherited from FilteredTermEnum) | Returns the docFreq of the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
EndEnum |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from FilteredTermEnum) | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term (inherited from FilteredTermEnum) | Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SetEnum (inherited from FilteredTermEnum)
TermCompare

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum Constructor

Creates a new

WildcardTermEnum
. Passing in a {@link Lucene.Net.Index.Term Term} that does not contain a
WILDCARD_CHAR
will cause an exception to be thrown.

public WildcardTermEnum(
IndexReader reader,
Term term
);

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum Fields

The fields of the WildcardTermEnum class are listed below. For a complete list of WildcardTermEnum class members, see the WildcardTermEnum Members topic.

Public Static Fields

WILDCARD_CHAR |
WILDCARD_STRING | ***************************************** String equality with support for wildcards ******************************************

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.WILDCARD_CHAR Field

public const char WILDCARD_CHAR = ?;

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.WILDCARD_STRING Field

***************************************** String equality with support for wildcards ******************************************

public const char WILDCARD_STRING = *;

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum Methods

The methods of the WildcardTermEnum class are listed below. For a complete list of WildcardTermEnum class members, see the WildcardTermEnum Members topic.

Public Static Methods

WildcardEquals Determines if a word matches a wildcard pattern. Work released by Granta Design Ltd after originally being done on company time.

Public Instance Methods

Close |
Difference |
DocFreq (inherited from FilteredTermEnum) | Returns the docFreq of the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
EndEnum |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from FilteredTermEnum) | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term (inherited from FilteredTermEnum) | Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SetEnum (inherited from FilteredTermEnum)
TermCompare

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.Close Method

public override void Close();

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.Difference Method

public override float Difference();

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.EndEnum Method

public override bool EndEnum();

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.TermCompare Method

protected internal override bool TermCompare(
Term term
);

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.WildcardEquals Method

Determines if a word matches a wildcard pattern. Work released by Granta Design Ltd after originally being done on company time.

public static bool WildcardEquals(
string pattern,
int patternIdx,
string string_Renamed,
int stringIdx
);

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


Lucene.Net.Search.Spans

An NDoc Documented Class Library

Lucene.Net.Search.Spans Namespace

Namespace hierarchy

Classes

Class | Description
SpanFirstQuery | Matches spans near the beginning of a Field.
SpanNearQuery | Matches spans which are near one another. One can specify slop, the maximum number of intervening unmatched positions, as well as whether matches are required to be in-order.
SpanNotQuery | Removes matches which overlap with another SpanQuery.
SpanOrQuery | Matches the union of its clauses.
SpanQuery | Base class for span-based queries.
SpanTermQuery | Matches spans containing a term.

Interfaces

Interface | Description
Spans | Expert: an enumeration of span matches. Used to implement span searching. Each span represents a range of term positions within a document. Matches are enumerated in order, by increasing document number, within that by increasing start position and finally by increasing end position.


SpanFirstQuery Class

Matches spans near the beginning of a Field.

For a list of all members of this type, see SpanFirstQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanFirstQuery

public class SpanFirstQuery : SpanQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanFirstQuery Members | Lucene.Net.Search.Spans Namespace


SpanFirstQuery Members

SpanFirstQuery overview

Public Instance Constructors

SpanFirstQuery Constructor Construct a SpanFirstQuery matching spans in
match
whose end position is less than or equal to
end
.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetEnd | Return the maximum end position permitted in a match.
GetField
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMatch | Return the SpanQuery whose matches are filtered.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerms
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery Constructor

Construct a SpanFirstQuery matching spans in

match
whose end position is less than or equal to
end
.

public SpanFirstQuery(
SpanQuery match,
int end
);

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery Methods

The methods of the SpanFirstQuery class are listed below. For a complete list of SpanFirstQuery class members, see the SpanFirstQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetEnd | Return the maximum end position permitted in a match.
GetField
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMatch | Return the SpanQuery whose matches are filtered.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerms
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.GetEnd Method

Return the maximum end position permitted in a match.

public virtual int GetEnd();

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.GetField Method

public override string GetField();

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.GetMatch Method

Return the SpanQuery whose matches are filtered.

public virtual SpanQuery GetMatch();

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.GetSpans Method

public override Spans GetSpans(
IndexReader reader
);

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.GetTerms Method

public override ICollection GetTerms();

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


ToString Method

An NDoc Documented Class Library

SpanFirstQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace | SpanFirstQuery.ToString Overload List


SpanNearQuery Class

Matches spans which are near one another. One can specify slop, the maximum number of intervening unmatched positions, as well as whether matches are required to be in-order.

For a list of all members of this type, see SpanNearQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanNearQuery

public class SpanNearQuery : SpanQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanNearQuery Members | Lucene.Net.Search.Spans Namespace


SpanNearQuery Members

SpanNearQuery overview

Public Instance Constructors

SpanNearQuery Constructor Construct a SpanNearQuery. Matches spans matching a span from each clause, with up to
slop
total unmatched positions between them. * When
inOrder
is true, the spans from each clause must be * ordered as in
clauses
.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetClauses | Return the clauses whose spans are matched.
GetField
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSlop | Return the maximum number of intervening unmatched positions permitted.
GetSpans
GetTerms
GetType (inherited from Object) | Gets the Type of the current instance.
IsInOrder | Return true if matches are required to be in-order.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery Constructor

Construct a SpanNearQuery. Matches spans matching a span from each clause, with up to

slop
total unmatched positions between them. * When
inOrder
is true, the spans from each clause must be * ordered as in
clauses
.

public SpanNearQuery(
SpanQuery[] clauses,
int slop,
bool inOrder
);

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery Methods

The methods of the SpanNearQuery class are listed below. For a complete list of SpanNearQuery class members, see the SpanNearQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetClauses | Return the clauses whose spans are matched.
GetField
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSlop | Return the maximum number of intervening unmatched positions permitted.
GetSpans
GetTerms
GetType (inherited from Object) | Gets the Type of the current instance.
IsInOrder | Return true if matches are required to be in-order.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.GetClauses Method

Return the clauses whose spans are matched.

public virtual SpanQuery[] GetClauses();

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.GetField Method

public override string GetField();

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.GetSlop Method

Return the maximum number of intervening unmatched positions permitted.

public virtual int GetSlop();

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.GetSpans Method

public override Spans GetSpans(
IndexReader reader
);

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.GetTerms Method

public override ICollection GetTerms();

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.IsInOrder Method

Return true if matches are required to be in-order.

public virtual bool IsInOrder();

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


ToString Method

An NDoc Documented Class Library

SpanNearQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace | SpanNearQuery.ToString Overload List


SpanNotQuery Class

Removes matches which overlap with another SpanQuery.

For a list of all members of this type, see SpanNotQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanNotQuery

public class SpanNotQuery : SpanQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanNotQuery Members | Lucene.Net.Search.Spans Namespace


SpanNotQuery Members

SpanNotQuery overview

Public Instance Constructors

SpanNotQuery Constructor Construct a SpanNotQuery matching spans from
include
which have no overlap with spans from
exclude
.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetExclude | Return the SpanQuery whose matches must not overlap those returned.
GetField
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInclude | Return the SpanQuery whose matches are filtered.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerms
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery Constructor

Construct a SpanNotQuery matching spans from

include
which have no overlap with spans from
exclude
.

public SpanNotQuery(
SpanQuery include,
SpanQuery exclude
);

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery Methods

The methods of the SpanNotQuery class are listed below. For a complete list of SpanNotQuery class members, see the SpanNotQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetExclude | Return the SpanQuery whose matches must not overlap those returned.
GetField
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInclude | Return the SpanQuery whose matches are filtered.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerms
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.GetExclude Method

Return the SpanQuery whose matches must not overlap those returned.

public virtual SpanQuery GetExclude();

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.GetField Method

public override string GetField();

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.GetInclude Method

Return the SpanQuery whose matches are filtered.

public virtual SpanQuery GetInclude();

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.GetSpans Method

public override Spans GetSpans(
IndexReader reader
);

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.GetTerms Method

public override ICollection GetTerms();

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


ToString Method

An NDoc Documented Class Library

SpanNotQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace | SpanNotQuery.ToString Overload List


SpanOrQuery Class

Matches the union of its clauses.

For a list of all members of this type, see SpanOrQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanOrQuery

public class SpanOrQuery : SpanQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanOrQuery Members | Lucene.Net.Search.Spans Namespace


SpanOrQuery Members

SpanOrQuery overview

Public Instance Constructors

SpanOrQuery Constructor Construct a SpanOrQuery merging the provided clauses.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetClauses | Return the clauses whose spans are matched.
GetField
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerms
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery Constructor

Construct a SpanOrQuery merging the provided clauses.

public SpanOrQuery(
SpanQuery[] clauses
);

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery Methods

The methods of the SpanOrQuery class are listed below. For a complete list of SpanOrQuery class members, see the SpanOrQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetClauses | Return the clauses whose spans are matched.
GetField
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerms
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.GetClauses Method

Return the clauses whose spans are matched.

public virtual SpanQuery[] GetClauses();

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.GetField Method

public override string GetField();

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.GetSpans Method

public override Spans GetSpans(
IndexReader reader
);

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.GetTerms Method

public override ICollection GetTerms();

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


ToString Method

An NDoc Documented Class Library

SpanOrQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace | SpanOrQuery.ToString Overload List


SpanQuery Class

Base class for span-based queries.

For a list of all members of this type, see SpanQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanFirstQuery
Lucene.Net.Search.Spans.SpanNearQuery
Lucene.Net.Search.Spans.SpanNotQuery
Lucene.Net.Search.Spans.SpanOrQuery
Lucene.Net.Search.Spans.SpanTermQuery

public abstract class SpanQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanQuery Members | Lucene.Net.Search.Spans Namespace


SpanQuery Members

SpanQuery overview

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField | Returns the name of the Field matched by this query.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans | Expert: Returns the matches for this query in an index. Used internally to search for spans.
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Constructors

SpanQuery Constructor Initializes a new instance of the SpanQuery class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery Constructor

Initializes a new instance of the SpanQuery class.

protected SpanQuery();

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery Methods

The methods of the SpanQuery class are listed below. For a complete list of SpanQuery class members, see the SpanQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField | Returns the name of the Field matched by this query.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans | Expert: Returns the matches for this query in an index. Used internally to search for spans.
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery.GetField Method

Returns the name of the Field matched by this query.

public abstract string GetField();

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery.GetSpans Method

Expert: Returns the matches for this query in an index. Used internally to search for spans.

public abstract Spans GetSpans(
IndexReader reader
);

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery.GetTerms Method

Returns a collection of all terms matched by this query.

public abstract ICollection GetTerms();

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


Spans Interface

Expert: an enumeration of span matches. Used to implement span searching. Each span represents a range of term positions within a document. Matches are enumerated in order, by increasing document number, within that by increasing start position and finally by increasing end position.

For a list of all members of this type, see Spans Members.

public interface Spans

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Spans Members | Lucene.Net.Search.Spans Namespace


Spans Members

Spans overview

Public Instance Methods

Doc | Returns the document number of the current match. Initially invalid.
End | Returns the end position of the current match. Initially invalid.
Next | Move to the next match, returning true iff any such exists.
SkipTo |
Start | Returns the start position of the current match. Initially invalid.

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


Spans Methods

The methods of the Spans interface are listed below. For a complete list of Spans interface members, see the Spans Members topic.

Public Instance Methods

Doc | Returns the document number of the current match. Initially invalid.
End | Returns the end position of the current match. Initially invalid.
Next | Move to the next match, returning true iff any such exists.
SkipTo |
Start | Returns the start position of the current match. Initially invalid.

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


Spans.Doc Method

Returns the document number of the current match. Initially invalid.

int Doc();

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


Spans.End Method

Returns the end position of the current match. Initially invalid.

int End();

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


Spans.Next Method

Move to the next match, returning true iff any such exists.

bool Next();

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


Spans.SkipTo Method

bool SkipTo(
int target
);

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


Spans.Start Method

Returns the start position of the current match. Initially invalid.

int Start();

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


SpanTermQuery Class

Matches spans containing a term.

For a list of all members of this type, see SpanTermQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanTermQuery

public class SpanTermQuery : SpanQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanTermQuery Members | Lucene.Net.Search.Spans Namespace


SpanTermQuery Members

SpanTermQuery overview

Public Instance Constructors

SpanTermQuery Constructor Construct a SpanTermQuery matching the named term's spans.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerm | Return the term whose spans are matched.
GetTerms
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery Constructor

Construct a SpanTermQuery matching the named term's spans.

public SpanTermQuery(
Term term
);

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery Methods

The methods of the SpanTermQuery class are listed below. For a complete list of SpanTermQuery class members, see the SpanTermQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerm | Return the term whose spans are matched.
GetTerms
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs an initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.GetField Method

public override string GetField();

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.GetSpans Method

public override Spans GetSpans(
IndexReader reader
);

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.GetTerm Method

Return the term whose spans are matched.

public virtual Term GetTerm();

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.GetTerms Method

public override ICollection GetTerms();

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


ToString Method

An NDoc Documented Class Library

SpanTermQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace | SpanTermQuery.ToString Overload List


Lucene.Net.Store

An NDoc Documented Class Library

Lucene.Net.Store Namespace

Namespace hierarchy

Classes

Class | Description
Directory |
FSDirectory |
FSInputStream |
InputStream | Abstract base class for input from a file in a {@link Directory}. A random-access input stream. Used for all Lucene index input operations.
Lock |
Lock.With | Utility class for executing code with exclusive access.
OutputStream | Abstract class for output to a file in a Directory. A random-access output stream. Used for all Lucene index output operations.
RAMDirectory | A memory-resident {@link Directory} implementation.
RAMOutputStream | A memory-resident {@link OutputStream} implementation.


Directory Class

For a list of all members of this type, see Directory Members.

System.Object
Lucene.Net.Store.Directory
Lucene.Net.Index.CompoundFileReader
Lucene.Net.Store.FSDirectory
Lucene.Net.Store.RAMDirectory

public abstract class Directory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Directory Members | Lucene.Net.Store Namespace


Directory Members

Directory overview

Public Instance Methods

Close | Closes the store.
CreateFile | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff a file with the given name exists.
FileLength | Returns the length of a file in the directory.
FileModified | Returns the time the named file was last modified.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory.
MakeLock | Construct a {@link Lock}.
OpenFile | Returns a stream reading an existing file.
RenameFile | Renames an existing file in the directory. If a file already exists with the new name, then it is replaced. This replacement should be atomic.
ToString (inherited from Object) | Returns a String that represents the current Object.
TouchFile | Set the modified time of an existing file to now.

Protected Instance Constructors

Directory Constructor Initializes a new instance of the Directory class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Directory Class | Lucene.Net.Store Namespace


Directory Constructor

Initializes a new instance of the Directory class.

protected Directory();

See Also

Directory Class | Lucene.Net.Store Namespace


Directory Methods

The methods of the Directory class are listed below. For a complete list of Directory class members, see the Directory Members topic.

Public Instance Methods

Close | Closes the store.
CreateFile | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff a file with the given name exists.
FileLength | Returns the length of a file in the directory.
FileModified | Returns the time the named file was last modified.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory.
MakeLock | Construct a {@link Lock}.
OpenFile | Returns a stream reading an existing file.
RenameFile | Renames an existing file in the directory. If a file already exists with the new name, then it is replaced. This replacement should be atomic.
ToString (inherited from Object) | Returns a String that represents the current Object.
TouchFile | Set the modified time of an existing file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.Close Method

Closes the store.

public abstract void Close();

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.CreateFile Method

Creates a new, empty file in the directory with the given name. Returns a stream writing this file.

public abstract OutputStream CreateFile(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.DeleteFile Method

Removes an existing file in the directory.

public abstract void DeleteFile(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.FileExists Method

Returns true iff a file with the given name exists.

public abstract bool FileExists(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.FileLength Method

Returns the length of a file in the directory.

public abstract long FileLength(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.FileModified Method

Returns the time the named file was last modified.

public abstract long FileModified(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.List Method

Returns an array of strings, one for each file in the directory.

public abstract string[] List();

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.MakeLock Method

Construct a {@link Lock}.

public abstract Lock MakeLock(
string name
);

Parameters

name
the name of the lock file

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.OpenFile Method

Returns a stream reading an existing file.

public abstract InputStream OpenFile(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.RenameFile Method

Renames an existing file in the directory. If a file already exists with the new name, then it is replaced. This replacement should be atomic.

public abstract void RenameFile(
string from,
string to
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.TouchFile Method

Set the modified time of an existing file to now.

public abstract void TouchFile(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


FSDirectory Class

For a list of all members of this type, see FSDirectory Members.

System.Object
Lucene.Net.Store.Directory
Lucene.Net.Store.FSDirectory

public sealed class FSDirectory : Directory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FSDirectory Members | Lucene.Net.Store Namespace


FSDirectory Members

FSDirectory overview

Public Static Fields

LOCK_DIR Directory specified by
Lucene.Net.lockdir
or
java.io.tmpdir
system property

Public Static Methods

FileModified | Overloaded. Returns the time the named file was last modified.
GetDirectory | Overloaded.

Public Instance Methods

Close | Closes the store to future operations.
CreateFile | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff a file with the given name exists.
FileLength | Returns the length in bytes of a file in the directory.
FileModified | Overloaded. Returns the time the named file was last modified.
GetFile |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory.
MakeLock |
OpenFile | Returns a stream reading an existing file.
RenameFile | Renames an existing file in the directory.
ToString | For debug output.
TouchFile | Set the modified time of an existing file to now.

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory Fields

The fields of the FSDirectory class are listed below. For a complete list of FSDirectory class members, see the FSDirectory Members topic.

Public Static Fields

LOCK_DIR Directory specified by
Lucene.Net.lockdir
or
java.io.tmpdir
system property

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.LOCK_DIR Field

Directory specified by

Lucene.Net.lockdir
or
java.io.tmpdir
system property

public static readonly string LOCK_DIR;

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory Methods

The methods of the FSDirectory class are listed below. For a complete list of FSDirectory class members, see the FSDirectory Members topic.

Public Static Methods

FileModified | Overloaded. Returns the time the named file was last modified.
GetDirectory | Overloaded.

Public Instance Methods

Close | Closes the store to future operations.
CreateFile | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff a file with the given name exists.
FileLength | Returns the length in bytes of a file in the directory.
FileModified | Overloaded. Returns the time the named file was last modified.
GetFile |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory.
MakeLock |
OpenFile | Returns a stream reading an existing file.
RenameFile | Renames an existing file in the directory.
ToString | For debug output.
TouchFile | Set the modified time of an existing file to now.

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.Close Method

Closes the store to future operations.

public override void Close();

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.CreateFile Method

Creates a new, empty file in the directory with the given name. Returns a stream writing this file.

public override OutputStream CreateFile(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.DeleteFile Method

Removes an existing file in the directory.

public override void DeleteFile(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.FileExists Method

Returns true iff a file with the given name exists.

public override bool FileExists(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.FileLength Method

Returns the length in bytes of a file in the directory.

public override long FileLength(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FileModified Method

An NDoc Documented Class Library

FSDirectory.FileModified Method

Returns the time the named file was last modified.

Overload List

Returns the time the named file was last modified.

public static long FileModified(FileInfo,string);

Returns the time the named file was last modified.

public override long FileModified(string);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.FileModified Method (FileInfo, String)

Returns the time the named file was last modified.

public static long FileModified(
FileInfo directory,
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.FileModified Overload List


FSDirectory.FileModified Method (String)

Returns the time the named file was last modified.

public override long FileModified(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.FileModified Overload List


GetDirectory Method

An NDoc Documented Class Library

FSDirectory.GetDirectory Method

Overload List

public static FSDirectory GetDirectory(FileInfo,bool);

public static FSDirectory GetDirectory(string,bool);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.GetDirectory Method (FileInfo, Boolean)

public static FSDirectory GetDirectory(
FileInfo file,
bool create
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.GetDirectory Overload List


FSDirectory.GetDirectory Method (String, Boolean)

public static FSDirectory GetDirectory(
string path,
bool create
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.GetDirectory Overload List


FSDirectory.GetFile Method

public FileInfo GetFile();

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.List Method

Returns an array of strings, one for each file in the directory.

public override string[] List();

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.MakeLock Method

public override Lock MakeLock(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.OpenFile Method

Returns a stream reading an existing file.

public override InputStream OpenFile(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.RenameFile Method

Renames an existing file in the directory.

public override void RenameFile(
string from,
string to
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.ToString Method

For debug output.

public override string ToString();

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.TouchFile Method

Set the modified time of an existing file to now.

public override void TouchFile(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSInputStream Class

For a list of all members of this type, see FSInputStream Members.

System.Object
Lucene.Net.Store.InputStream
Lucene.Net.Store.FSInputStream

public sealed class FSInputStream : InputStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FSInputStream Members | Lucene.Net.Store Namespace


FSInputStream Members

FSInputStream overview

Public Instance Constructors

FSInputStream Constructor

Public Instance Fields

isClone

Public Instance Methods

Clone |
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilePointer (inherited from InputStream) | Returns the current position in this file, where the next read will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsFDValid | Method used for testing. Returns true if the underlying file descriptor is valid.
Length (inherited from InputStream) | The number of bytes in the file.
ReadByte (inherited from InputStream) | Reads and returns a single byte.
ReadBytes (inherited from InputStream) | Reads a specified number of bytes into an array at the specified offset.
ReadChars (inherited from InputStream) | Reads UTF-8 encoded characters into an array.
ReadInt (inherited from InputStream) | Reads four bytes and returns an int.
ReadInternal | InputStream methods
ReadLong (inherited from InputStream) | Reads eight bytes and returns a long.
ReadString (inherited from InputStream) | Reads a string.
ReadVInt (inherited from InputStream) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from InputStream) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek (inherited from InputStream) | Sets current position in this file, where the next read will occur.
SeekInternal | Random-access methods
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

length (inherited from InputStream)

See Also

FSInputStream Class | Lucene.Net.Store Namespace


FSInputStream Constructor

public FSInputStream(
FileInfo path
);

See Also

FSInputStream Class | Lucene.Net.Store Namespace


FSInputStream Fields

The fields of the FSInputStream class are listed below. For a complete list of FSInputStream class members, see the FSInputStream Members topic.

Public Instance Fields

isClone

Protected Internal Instance Fields

length (inherited from InputStream)

See Also

FSInputStream Class | Lucene.Net.Store Namespace


FSInputStream.isClone Field

public bool isClone;

See Also

FSInputStream Class | Lucene.Net.Store Namespace


FSInputStream Methods

The methods of the FSInputStream class are listed below. For a complete list of FSInputStream class members, see the FSInputStream Members topic.

Public Instance Methods

Clone |
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilePointer (inherited from InputStream) | Returns the current position in this file, where the next read will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsFDValid | Method used for testing. Returns true if the underlying file descriptor is valid.
Length (inherited from InputStream) | The number of bytes in the file.
ReadByte (inherited from InputStream) | Reads and returns a single byte.
ReadBytes (inherited from InputStream) | Reads a specified number of bytes into an array at the specified offset.
ReadChars (inherited from InputStream) | Reads UTF-8 encoded characters into an array.
ReadInt (inherited from InputStream) | Reads four bytes and returns an int.
ReadInternal | InputStream methods
ReadLong (inherited from InputStream) | Reads eight bytes and returns a long.
ReadString (inherited from InputStream) | Reads a string.
ReadVInt (inherited from InputStream) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from InputStream) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek (inherited from InputStream) | Sets current position in this file, where the next read will occur.
SeekInternal | Random-access methods
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FSInputStream Class | Lucene.Net.Store Namespace


FSInputStream.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

FSInputStream Class | Lucene.Net.Store Namespace


FSInputStream.Close Method

public override void Close();

See Also

FSInputStream Class | Lucene.Net.Store Namespace


FSInputStream.IsFDValid Method

Method used for testing. Returns true if the underlying file descriptor is valid.

public bool IsFDValid();

See Also

FSInputStream Class | Lucene.Net.Store Namespace


FSInputStream.ReadInternal Method

InputStream methods

public override void ReadInternal(
byte[] b,
int offset,
int len
);

See Also

FSInputStream Class | Lucene.Net.Store Namespace


FSInputStream.SeekInternal Method

Random-access methods

public override void SeekInternal(
long position
);

See Also

FSInputStream Class | Lucene.Net.Store Namespace


InputStream Class

Abstract base class for input from a file in a {@link Directory}. A random-access input stream. Used for all Lucene index input operations.

For a list of all members of this type, see InputStream Members.

System.Object
Lucene.Net.Store.InputStream
Lucene.Net.Index.CompoundFileReader.CSInputStream
Lucene.Net.Store.FSInputStream

public abstract class InputStream : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

InputStream Members | Lucene.Net.Store Namespace | |


InputStream Members

InputStream overview

Public Instance Methods

Clone |
Close | Closes the stream to futher operations.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilePointer | Returns the current position in this file, where the next read will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length | The number of bytes in the file.
ReadByte | Reads and returns a single byte.
ReadBytes | Reads a specified number of bytes into an array at the specified offset.
ReadChars | Reads UTF-8 encoded characters into an array.
ReadInt | Reads four bytes and returns an int.
ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input.
ReadLong | Reads eight bytes and returns a long.
ReadString | Reads a string.
ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek | Sets current position in this file, where the next read will occur.
SeekInternal | Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

InputStream Constructor Initializes a new instance of the InputStream class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

length

See Also

InputStream Class | Lucene.Net.Store Namespace | |


InputStream Constructor

Initializes a new instance of the InputStream class.

protected InputStream();

See Also

InputStream Class | Lucene.Net.Store Namespace


InputStream Fields

The fields of the InputStream class are listed below. For a complete list of InputStream class members, see the InputStream Members topic.

Protected Internal Instance Fields

length

See Also

InputStream Class | Lucene.Net.Store Namespace | |


InputStream.Length Method

The number of bytes in the file.

public long Length();

See Also

InputStream Class | Lucene.Net.Store Namespace


InputStream Methods

The methods of the InputStream class are listed below. For a complete list of InputStream class members, see the InputStream Members topic.

Public Instance Methods

Clone |
Close | Closes the stream to futher operations.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilePointer | Returns the current position in this file, where the next read will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length | The number of bytes in the file.
ReadByte | Reads and returns a single byte.
ReadBytes | Reads a specified number of bytes into an array at the specified offset.
ReadChars | Reads UTF-8 encoded characters into an array.
ReadInt | Reads four bytes and returns an int.
ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input.
ReadLong | Reads eight bytes and returns a long.
ReadString | Reads a string.
ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek | Sets current position in this file, where the next read will occur.
SeekInternal | Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InputStream Class | Lucene.Net.Store Namespace | |


InputStream.Clone Method

public virtual object Clone();

Implements

ICloneable.Clone

See Also

InputStream Class | Lucene.Net.Store Namespace


InputStream.Close Method

Closes the stream to futher operations.

public abstract void Close();

See Also

InputStream Class | Lucene.Net.Store Namespace


InputStream.GetFilePointer Method

Returns the current position in this file, where the next read will occur.

public long GetFilePointer();

See Also

InputStream Class | Lucene.Net.Store Namespace | #Seek


InputStream.ReadByte Method

Reads and returns a single byte.

public byte ReadByte();

See Also

InputStream Class | Lucene.Net.Store Namespace | OutputStream#WriteByte


InputStream.ReadBytes Method

Reads a specified number of bytes into an array at the specified offset.

public void ReadBytes(
byte[] b,
int offset,
int len
);

Parameters

b
the array to read bytes into
offset
the offset in the array to start storing bytes
len
the number of bytes to read

See Also

InputStream Class | Lucene.Net.Store Namespace | OutputStream#WriteBytes


InputStream.ReadChars Method

Reads UTF-8 encoded characters into an array.

public void ReadChars(
char[] buffer,
int start,
int length
);

Parameters

buffer
the array to read characters into
start
the offset in the array to start storing characters
length
the number of characters to read

See Also

InputStream Class | Lucene.Net.Store Namespace | OutputStream#WriteChars


InputStream.ReadInt Method

Reads four bytes and returns an int.

public int ReadInt();

See Also

InputStream Class | Lucene.Net.Store Namespace | OutputStream#WriteInt


InputStream.ReadInternal Method

Expert: implements buffer refill. Reads bytes from the current position in the input.

public abstract void ReadInternal(
byte[] b,
int offset,
int length
);

Parameters

b
the array to read bytes into
offset
the offset in the array to start storing bytes
length
the number of bytes to read

See Also

InputStream Class | Lucene.Net.Store Namespace


InputStream.ReadLong Method

Reads eight bytes and returns a long.

public long ReadLong();

See Also

InputStream Class | Lucene.Net.Store Namespace | OutputStream#WriteLong


InputStream.ReadString Method

Reads a string.

public string ReadString();

See Also

InputStream Class | Lucene.Net.Store Namespace | OutputStream#WriteString


InputStream.ReadVInt Method

Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

public int ReadVInt();

See Also

InputStream Class | Lucene.Net.Store Namespace | OutputStream#WriteVInt


InputStream.ReadVLong Method

Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.

public long ReadVLong();

See Also

InputStream Class | Lucene.Net.Store Namespace


InputStream.Seek Method

Sets current position in this file, where the next read will occur.

public void Seek(
long pos
);

See Also

InputStream Class | Lucene.Net.Store Namespace | #GetFilePointer


InputStream.SeekInternal Method

Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.

public abstract void SeekInternal(
long pos
);

See Also

InputStream Class | Lucene.Net.Store Namespace | #ReadInternal


Lock Class

For a list of all members of this type, see Lock Members.

System.Object
Lucene.Net.Store.Lock

public abstract class Lock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Lock Members | Lucene.Net.Store Namespace


Lock Members

Lock overview

Public Static Fields

LOCK_POLL_INTERVAL

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLocked | Returns true if the resource is currently locked. Note that one must still call {@link #Obtain()} before using the resource.
Obtain | Overloaded. Attempts to obtain an exclusive lock within amount of time given. Currently polls once per second until lockWaitTimeout is passed.
Release | Releases exclusive access.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Lock Constructor Initializes a new instance of the Lock class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Lock Class | Lucene.Net.Store Namespace


Lock Constructor

Initializes a new instance of the Lock class.

protected Lock();

See Also

Lock Class | Lucene.Net.Store Namespace


Lock Fields

The fields of the Lock class are listed below. For a complete list of Lock class members, see the Lock Members topic.

Public Static Fields

LOCK_POLL_INTERVAL

See Also

Lock Class | Lucene.Net.Store Namespace


Lock.LOCK_POLL_INTERVAL Field

public static long LOCK_POLL_INTERVAL;

See Also

Lock Class | Lucene.Net.Store Namespace


Lock Methods

The methods of the Lock class are listed below. For a complete list of Lock class members, see the Lock Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLocked | Returns true if the resource is currently locked. Note that one must still call {@link #Obtain()} before using the resource.
Obtain | Overloaded. Attempts to obtain an exclusive lock within amount of time given. Currently polls once per second until lockWaitTimeout is passed.
Release | Releases exclusive access.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Lock Class | Lucene.Net.Store Namespace


Lock.IsLocked Method

Returns true if the resource is currently locked. Note that one must still call {@link #Obtain()} before using the resource.

public abstract bool IsLocked();

See Also

Lock Class | Lucene.Net.Store Namespace


Obtain Method

An NDoc Documented Class Library

Lock.Obtain Method

Attempts to obtain exclusive access and immediately return upon success or failure.

Overload List

Attempts to obtain exclusive access and immediately return upon success or failure.

public abstract bool Obtain();

Attempts to obtain an exclusive lock within amount of time given. Currently polls once per second until lockWaitTimeout is passed.

public virtual bool Obtain(long);

See Also

Lock Class | Lucene.Net.Store Namespace


Lock.Obtain Method ()

Attempts to obtain exclusive access and immediately return upon success or failure.

public abstract bool Obtain();

Return Value

true iff exclusive access is obtained

See Also

Lock Class | Lucene.Net.Store Namespace | Lock.Obtain Overload List


Lock.Obtain Method (Int64)

Attempts to obtain an exclusive lock within amount of time given. Currently polls once per second until lockWaitTimeout is passed.

public virtual bool Obtain(
long lockWaitTimeout
);

Parameters

lockWaitTimeout
length of time to wait in ms

Return Value

true if lock was obtained

See Also

Lock Class | Lucene.Net.Store Namespace | Lock.Obtain Overload List


Lock.Release Method

Releases exclusive access.

public abstract void Release();

See Also

Lock Class | Lucene.Net.Store Namespace


Lock.With Class

Utility class for executing code with exclusive access.

For a list of all members of this type, see Lock.With Members.

System.Object
Lucene.Net.Store.Lock.With

public abstract class Lock.With

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Lock.With Members | Lucene.Net.Store Namespace


Lock.With Members

Lock.With overview

Public Instance Constructors

Lock.With Overloaded. Initializes a new instance of the Lock.With class.

Public Instance Methods

DoBody | Code to execute with exclusive access.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Calls {@link #doBody} while lock is obtained. Blocks if lock cannot be obtained immediately. Retries to obtain lock once per second until it is obtained, or until it has tried ten times. Lock is released when {@link #doBody} exits.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Lock.With Class | Lucene.Net.Store Namespace


Lock.With Constructor

Constructs an executor that will grab the named lock. Defaults lockWaitTimeout to Lock.COMMIT_LOCK_TIMEOUT.

Overload List

Constructs an executor that will grab the named lock. Defaults lockWaitTimeout to Lock.COMMIT_LOCK_TIMEOUT.

public Lock.With(Lock);

Constructs an executor that will grab the named lock.

public Lock.With(Lock,long);

See Also

Lock.With Class | Lucene.Net.Store Namespace


Lock.With Constructor (Lock)

Constructs an executor that will grab the named lock. Defaults lockWaitTimeout to Lock.COMMIT_LOCK_TIMEOUT.

public Lock.With(
Lock lock_Renamed
);

See Also

Lock.With Class | Lucene.Net.Store Namespace | Lock.With Constructor Overload List


Lock.With Constructor (Lock, Int64)

Constructs an executor that will grab the named lock.

public Lock.With(
Lock lock_Renamed,
long lockWaitTimeout
);

See Also

Lock.With Class | Lucene.Net.Store Namespace | Lock.With Constructor Overload List


Lock.With Methods

The methods of the Lock.With class are listed below. For a complete list of Lock.With class members, see the Lock.With Members topic.

Public Instance Methods

DoBody | Code to execute with exclusive access.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Calls {@link #doBody} while lock is obtained. Blocks if lock cannot be obtained immediately. Retries to obtain lock once per second until it is obtained, or until it has tried ten times. Lock is released when {@link #doBody} exits.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Lock.With Class | Lucene.Net.Store Namespace


Lock.With.DoBody Method

Code to execute with exclusive access.

public abstract object DoBody();

See Also

Lock.With Class | Lucene.Net.Store Namespace


Lock.With.Run Method

Calls {@link #doBody} while lock is obtained. Blocks if lock cannot be obtained immediately. Retries to obtain lock once per second until it is obtained, or until it has tried ten times. Lock is released when {@link #doBody} exits.

public virtual object Run();

See Also

Lock.With Class | Lucene.Net.Store Namespace


OutputStream Class

Abstract class for output to a file in a Directory. A random-access output stream. Used for all Lucene index output operations.

For a list of all members of this type, see OutputStream Members.

System.Object
Lucene.Net.Store.OutputStream
Lucene.Net.Store.RAMOutputStream

public abstract class OutputStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

OutputStream Members | Lucene.Net.Store Namespace | |


OutputStream Members

OutputStream overview

Public Instance Methods

Close | Closes this stream to further operations.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FlushBuffer | Expert: implements buffer write. Writes bytes at the current position in the output.
GetFilePointer | Returns the current position in this file, where the next write will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length | The number of bytes in the file.
Seek | Sets current position in this file, where the next write will occur.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte | Writes a single byte.
WriteBytes | Writes an array of bytes.
WriteChars | Writes a sequence of UTF-8 encoded characters from a string.
WriteInt | Writes an int as four bytes.
WriteLong | Writes a long as eight bytes.
WriteString | Writes a string.
WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Constructors

OutputStream Constructor Initializes a new instance of the OutputStream class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Flush Forces any buffered output to be written.

See Also

OutputStream Class | Lucene.Net.Store Namespace | |


OutputStream Constructor

Initializes a new instance of the OutputStream class.

protected OutputStream();

See Also

OutputStream Class | Lucene.Net.Store Namespace


OutputStream Methods

The methods of the OutputStream class are listed below. For a complete list of OutputStream class members, see the OutputStream Members topic.

Public Instance Methods

Close | Closes this stream to further operations.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FlushBuffer | Expert: implements buffer write. Writes bytes at the current position in the output.
GetFilePointer | Returns the current position in this file, where the next write will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length | The number of bytes in the file.
Seek | Sets current position in this file, where the next write will occur.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte | Writes a single byte.
WriteBytes | Writes an array of bytes.
WriteChars | Writes a sequence of UTF-8 encoded characters from a string.
WriteInt | Writes an int as four bytes.
WriteLong | Writes a long as eight bytes.
WriteString | Writes a string.
WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Flush Forces any buffered output to be written.

See Also

OutputStream Class | Lucene.Net.Store Namespace | |


OutputStream.Close Method

Closes this stream to further operations.

public virtual void Close();

See Also

OutputStream Class | Lucene.Net.Store Namespace


OutputStream.Flush Method

Forces any buffered output to be written.

protected internal void Flush();

See Also

OutputStream Class | Lucene.Net.Store Namespace


OutputStream.FlushBuffer Method

Expert: implements buffer write. Writes bytes at the current position in the output.

public abstract void FlushBuffer(
byte[] b,
int len
);

Parameters

b
the bytes to write
len
the number of bytes to write

See Also

OutputStream Class | Lucene.Net.Store Namespace


OutputStream.GetFilePointer Method

Returns the current position in this file, where the next write will occur.

public long GetFilePointer();

See Also

OutputStream Class | Lucene.Net.Store Namespace | #Seek


OutputStream.Length Method

The number of bytes in the file.

public abstract long Length();

See Also

OutputStream Class | Lucene.Net.Store Namespace


OutputStream.Seek Method

Sets current position in this file, where the next write will occur.

public virtual void Seek(
long pos
);

See Also

OutputStream Class | Lucene.Net.Store Namespace | #GetFilePointer


OutputStream.WriteByte Method

Writes a single byte.

public void WriteByte(
byte b
);

See Also

OutputStream Class | Lucene.Net.Store Namespace | InputStream#ReadByte


OutputStream.WriteBytes Method

Writes an array of bytes.

public void WriteBytes(
byte[] b,
int length
);

Parameters

b
the bytes to write
length
the number of bytes to write

See Also

OutputStream Class | Lucene.Net.Store Namespace | InputStream#ReadBytes


OutputStream.WriteChars Method

Writes a sequence of UTF-8 encoded characters from a string.

public void WriteChars(
string s,
int start,
int length
);

Parameters

s
the source of the characters
start
the first character in the sequence
length
the number of characters in the sequence

See Also

OutputStream Class | Lucene.Net.Store Namespace | InputStream#ReadChars


OutputStream.WriteInt Method

Writes an int as four bytes.

public void WriteInt(
int i
);

See Also

OutputStream Class | Lucene.Net.Store Namespace | InputStream#ReadInt


OutputStream.WriteLong Method

Writes a long as eight bytes.

public void WriteLong(
long i
);

See Also

OutputStream Class | Lucene.Net.Store Namespace | InputStream#ReadLong


OutputStream.WriteString Method

Writes a string.

public void WriteString(
string s
);

See Also

OutputStream Class | Lucene.Net.Store Namespace | InputStream#ReadString


OutputStream.WriteVInt Method

Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

public void WriteVInt(
int i
);

See Also

OutputStream Class | Lucene.Net.Store Namespace | InputStream#ReadVInt


OutputStream.WriteVLong Method

Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

public void WriteVLong(
long i
);

See Also

OutputStream Class | Lucene.Net.Store Namespace | InputStream#ReadVLong


RAMDirectory Class

A memory-resident {@link Directory} implementation.

For a list of all members of this type, see RAMDirectory Members.

System.Object
Lucene.Net.Store.Directory
Lucene.Net.Store.RAMDirectory

public sealed class RAMDirectory : Directory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RAMDirectory Members | Lucene.Net.Store Namespace


RAMDirectory Members

RAMDirectory overview

Public Instance Constructors

RAMDirectory Overloaded. Initializes a new instance of the RAMDirectory class.

Public Instance Methods

Close | Closes the store to future operations.
CreateFile | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff the named file exists in this directory.
FileLength | Returns the length in bytes of a file in the directory.
FileModified | Returns the time the named file was last modified.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory.
MakeLock | Construct a {@link Lock}.
OpenFile | Returns a stream reading an existing file.
RenameFile | Removes an existing file in the directory.
ToString (inherited from Object) | Returns a String that represents the current Object.
TouchFile | Set the modified time of an existing file to now.

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory Constructor

Constructs an empty {@link Directory}.

Overload List

Constructs an empty {@link Directory}.

public RAMDirectory();

public RAMDirectory(Directory);

Creates a new

RAMDirectory
instance from the {@link FSDirectory}.

public RAMDirectory(FileInfo);

Creates a new

RAMDirectory
instance from the {@link FSDirectory}.

public RAMDirectory(string);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory Constructor ()

Constructs an empty {@link Directory}.

public RAMDirectory();

See Also

RAMDirectory Class | Lucene.Net.Store Namespace | RAMDirectory Constructor Overload List


RAMDirectory Constructor (Directory)

public RAMDirectory(
Directory dir
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace | RAMDirectory Constructor Overload List


RAMDirectory Constructor (FileInfo)

Creates a new

RAMDirectory
instance from the {@link FSDirectory}.

public RAMDirectory(
FileInfo dir
);

Parameters

dir
a
File
specifying the index directory

See Also

RAMDirectory Class | Lucene.Net.Store Namespace | RAMDirectory Constructor Overload List


RAMDirectory Constructor (String)

Creates a new

RAMDirectory
instance from the {@link FSDirectory}.

public RAMDirectory(
string dir
);

Parameters

dir
a
String
specifying the full index directory path

See Also

RAMDirectory Class | Lucene.Net.Store Namespace | RAMDirectory Constructor Overload List


RAMDirectory Methods

The methods of the RAMDirectory class are listed below. For a complete list of RAMDirectory class members, see the RAMDirectory Members topic.

Public Instance Methods

Close | Closes the store to future operations.
CreateFile | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff the named file exists in this directory.
FileLength | Returns the length in bytes of a file in the directory.
FileModified | Returns the time the named file was last modified.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory.
MakeLock | Construct a {@link Lock}.
OpenFile | Returns a stream reading an existing file.
RenameFile | Removes an existing file in the directory.
ToString (inherited from Object) | Returns a String that represents the current Object.
TouchFile | Set the modified time of an existing file to now.

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.Close Method

Closes the store to future operations.

public override void Close();

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.CreateFile Method

Creates a new, empty file in the directory with the given name. Returns a stream writing this file.

public override OutputStream CreateFile(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.DeleteFile Method

Removes an existing file in the directory.

public override void DeleteFile(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.FileExists Method

Returns true iff the named file exists in this directory.

public override bool FileExists(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.FileLength Method

Returns the length in bytes of a file in the directory.

public override long FileLength(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.FileModified Method

Returns the time the named file was last modified.

public override long FileModified(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.List Method

Returns an array of strings, one for each file in the directory.

public override string[] List();

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.MakeLock Method

Construct a {@link Lock}.

public override Lock MakeLock(
string name
);

Parameters

name
the name of the lock file

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.OpenFile Method

Returns a stream reading an existing file.

public override InputStream OpenFile(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.RenameFile Method

Removes an existing file in the directory.

public override void RenameFile(
string from,
string to
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.TouchFile Method

Set the modified time of an existing file to now.

public override void TouchFile(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMOutputStream Class

A memory-resident {@link OutputStream} implementation.

For a list of all members of this type, see RAMOutputStream Members.

System.Object
Lucene.Net.Store.OutputStream
Lucene.Net.Store.RAMOutputStream

public class RAMOutputStream : OutputStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RAMOutputStream Members | Lucene.Net.Store Namespace


RAMOutputStream Members

RAMOutputStream overview

Public Instance Constructors

RAMOutputStream Constructor Construct an empty output buffer.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FlushBuffer |
GetFilePointer (inherited from OutputStream) | Returns the current position in this file, where the next write will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
Leset | Resets this to an empty buffer.
Seek |
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte (inherited from OutputStream) | Writes a single byte.
WriteBytes (inherited from OutputStream) | Writes an array of bytes.
WriteChars (inherited from OutputStream) | Writes a sequence of UTF-8 encoded characters from a string.
WriteInt (inherited from OutputStream) | Writes an int as four bytes.
WriteLong (inherited from OutputStream) | Writes a long as eight bytes.
WriteString (inherited from OutputStream) | Writes a string.
WriteTo | Copy the current contents of this buffer to the named output.
WriteVInt (inherited from OutputStream) | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong (inherited from OutputStream) | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Flush (inherited from OutputStream) Forces any buffered output to be written.

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream Constructor

Construct an empty output buffer.

public RAMOutputStream();

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream Methods

The methods of the RAMOutputStream class are listed below. For a complete list of RAMOutputStream class members, see the RAMOutputStream Members topic.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FlushBuffer |
GetFilePointer (inherited from OutputStream) | Returns the current position in this file, where the next write will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
Leset | Resets this to an empty buffer.
Seek |
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte (inherited from OutputStream) | Writes a single byte.
WriteBytes (inherited from OutputStream) | Writes an array of bytes.
WriteChars (inherited from OutputStream) | Writes a sequence of UTF-8 encoded characters from a string.
WriteInt (inherited from OutputStream) | Writes an int as four bytes.
WriteLong (inherited from OutputStream) | Writes a long as eight bytes.
WriteString (inherited from OutputStream) | Writes a string.
WriteTo | Copy the current contents of this buffer to the named output.
WriteVInt (inherited from OutputStream) | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong (inherited from OutputStream) | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Flush (inherited from OutputStream) Forces any buffered output to be written.

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.Close Method

public override void Close();

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.FlushBuffer Method

public override void FlushBuffer(
byte[] src,
int len
);

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.Length Method

public override long Length();

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.Leset Method

Resets this to an empty buffer.

public virtual void Leset();

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.Seek Method

public override void Seek(
long pos
);

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.WriteTo Method

Copy the current contents of this buffer to the named output.

public virtual void WriteTo(
OutputStream out_Renamed
);

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


Lucene.Net.Util

An NDoc Documented Class Library

Lucene.Net.Util Namespace

Namespace hierarchy

Classes

Class | Description
BitVector Optimized implementation of a vector of bits. This is more-or-less like java.util.BitSet, but also includes the following:
  • a count() method, which efficiently computes the number of one bits;
  • optimized read from and write to disk;
  • inlinable get() method;
Constants | Some useful constants.
PriorityQueue | A PriorityQueue maintains a partial ordering of its elements such that the least element can always be found in constant time. Put()'s and pop()'s require log(size) time.
StringHelper | Methods for manipulating strings. $Id: StringHelper.java,v 1.2 2004/03/25 13:39:59 otis Exp $


BitVector Class

Optimized implementation of a vector of bits. This is more-or-less like java.util.BitSet, but also includes the following:

  • a count() method, which efficiently computes the number of one bits;
  • optimized read from and write to disk;
  • inlinable get() method;

For a list of all members of this type, see BitVector Members.

System.Object
Lucene.Net.Util.BitVector

public sealed class BitVector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BitVector Members | Lucene.Net.Util Namespace


BitVector Members

BitVector overview

Public Instance Constructors

BitVector Overloaded. Initializes a new instance of the BitVector class.

Public Instance Methods

Clear Sets the value of
bit
to zero.
Count | Returns the total number of one bits in this vector. This is efficiently computed and cached, so that, if the vector is not changed, no recomputation is done for repeated calls.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get Returns
true
if
bit
is one and
false
if it is zero.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Set Sets the value of
bit
to one.
Size | Returns the number of bits in this vector. This is also one greater than the number of the largest valid bit number.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write Writes this vector to the file
name
in Directory
d
, in a format that can be read by the constructor {@link #BitVector(Directory, String)}.

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector Constructor

Constructs a vector capable of holding

n
bits.

Overload List

Constructs a bit vector from the file

name
in Directory
d
, as written by the {@link #write} method.

public BitVector(Directory,string);

Constructs a vector capable of holding

n
bits.

public BitVector(int);

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector Constructor (Int32)

Constructs a vector capable of holding

n
bits.

public BitVector(
int n
);

See Also

BitVector Class | Lucene.Net.Util Namespace | BitVector Constructor Overload List


BitVector Constructor (Directory, String)

Constructs a bit vector from the file

name
in Directory
d
, as written by the {@link #write} method.

public BitVector(
Directory d,
string name
);

See Also

BitVector Class | Lucene.Net.Util Namespace | BitVector Constructor Overload List


BitVector Methods

The methods of the BitVector class are listed below. For a complete list of BitVector class members, see the BitVector Members topic.

Public Instance Methods

Clear Sets the value of
bit
to zero.
Count | Returns the total number of one bits in this vector. This is efficiently computed and cached, so that, if the vector is not changed, no recomputation is done for repeated calls.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get Returns
true
if
bit
is one and
false
if it is zero.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Set Sets the value of
bit
to one.
Size | Returns the number of bits in this vector. This is also one greater than the number of the largest valid bit number.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write Writes this vector to the file
name
in Directory
d
, in a format that can be read by the constructor {@link #BitVector(Directory, String)}.

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.Clear Method

Sets the value of

bit
to zero.

public void Clear(
int bit
);

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.Count Method

Returns the total number of one bits in this vector. This is efficiently computed and cached, so that, if the vector is not changed, no recomputation is done for repeated calls.

public int Count();

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.Get Method

Returns

true
if
bit
is one and
false
if it is zero.

public bool Get(
int bit
);

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.Set Method

Sets the value of

bit
to one.

public void Set(
int bit
);

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.Size Method

Returns the number of bits in this vector. This is also one greater than the number of the largest valid bit number.

public int Size();

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.Write Method

Writes this vector to the file

name
in Directory
d
, in a format that can be read by the constructor {@link #BitVector(Directory, String)}.

public void Write(
Directory d,
string name
);

See Also

BitVector Class | Lucene.Net.Util Namespace


Constants Class

Some useful constants.

For a list of all members of this type, see Constants Members.

System.Object
Lucene.Net.Util.Constants

public sealed class Constants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Constants Members | Lucene.Net.Util Namespace


Constants Members

Constants overview

Public Static Fields

JAVA_1_1 | True iff this is Java version 1.1.
JAVA_1_2 | True iff this is Java version 1.2.
JAVA_1_3 | True iff this is Java version 1.3.
JAVA_VERSION |
LINUX | True iff running on Linux.
OS_NAME |
SUN_OS | True iff running on SunOS.
WINDOWS | True iff running on Windows.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Constants Class | Lucene.Net.Util Namespace


Constants Fields

The fields of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Fields

JAVA_1_1 | True iff this is Java version 1.1.
JAVA_1_2 | True iff this is Java version 1.2.
JAVA_1_3 | True iff this is Java version 1.3.
JAVA_VERSION |
LINUX | True iff running on Linux.
OS_NAME |
SUN_OS | True iff running on SunOS.
WINDOWS | True iff running on Windows.

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.JAVA_1_1 Field

True iff this is Java version 1.1.

public static readonly bool JAVA_1_1;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.JAVA_1_2 Field

True iff this is Java version 1.2.

public static readonly bool JAVA_1_2;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.JAVA_1_3 Field

True iff this is Java version 1.3.

public static readonly bool JAVA_1_3;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.JAVA_VERSION Field

public static readonly string JAVA_VERSION;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.LINUX Field

True iff running on Linux.

public static readonly bool LINUX;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.OS_NAME Field

public static readonly string OS_NAME;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.SUN_OS Field

True iff running on SunOS.

public static readonly bool SUN_OS;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.WINDOWS Field

True iff running on Windows.

public static readonly bool WINDOWS;

See Also

Constants Class | Lucene.Net.Util Namespace


PriorityQueue Class

A PriorityQueue maintains a partial ordering of its elements such that the least element can always be found in constant time. Put()'s and pop()'s require log(size) time.

For a list of all members of this type, see PriorityQueue Members.

System.Object
Lucene.Net.Util.PriorityQueue

public abstract class PriorityQueue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PriorityQueue Members | Lucene.Net.Util Namespace


PriorityQueue Members

PriorityQueue overview

Public Instance Methods

AdjustTop Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }
Clear | Removes all entries from the PriorityQueue.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
LessThan | Determines the ordering of objects in this priority queue. Subclasses must define this one method.
Pop | Removes and returns the least element of the PriorityQueue in log(size) time.
Put | Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Size | Returns the number of elements currently stored in the PriorityQueue.
Top | Returns the least element of the PriorityQueue in constant time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

PriorityQueue Constructor Initializes a new instance of the PriorityQueue class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Initialize Subclass constructors must call this.

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue Constructor

Initializes a new instance of the PriorityQueue class.

protected PriorityQueue();

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue Methods

The methods of the PriorityQueue class are listed below. For a complete list of PriorityQueue class members, see the PriorityQueue Members topic.

Public Instance Methods

AdjustTop Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }
Clear | Removes all entries from the PriorityQueue.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
LessThan | Determines the ordering of objects in this priority queue. Subclasses must define this one method.
Pop | Removes and returns the least element of the PriorityQueue in log(size) time.
Put | Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Size | Returns the number of elements currently stored in the PriorityQueue.
Top | Returns the least element of the PriorityQueue in constant time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Initialize Subclass constructors must call this.

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.AdjustTop Method

Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to

 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }

public void AdjustTop();

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Clear Method

Removes all entries from the PriorityQueue.

public void Clear();

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Initialize Method

Subclass constructors must call this.

protected internal void Initialize(
int maxSize
);

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Insert Method

Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).

public virtual bool Insert(
object element
);

Parameters

element

Return Value

true if element is added, false otherwise.

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.LessThan Method

Determines the ordering of objects in this priority queue. Subclasses must define this one method.

public abstract bool LessThan(
object a,
object b
);

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Pop Method

Removes and returns the least element of the PriorityQueue in log(size) time.

public object Pop();

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Put Method

Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.

public void Put(
object element
);

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Size Method

Returns the number of elements currently stored in the PriorityQueue.

public int Size();

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Top Method

Returns the least element of the PriorityQueue in constant time.

public object Top();

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


StringHelper Class

Methods for manipulating strings. $Id: StringHelper.java,v 1.2 2004/03/25 13:39:59 otis Exp $

For a list of all members of this type, see StringHelper Members.

System.Object
Lucene.Net.Util.StringHelper

public abstract class StringHelper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StringHelper Members | Lucene.Net.Util Namespace


StringHelper Members

StringHelper overview

Public Static Methods

StringDifference Compares two strings, character by character, and returns the first position where the two strings differ from one another.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringHelper Class | Lucene.Net.Util Namespace


StringHelper Methods

The methods of the StringHelper class are listed below. For a complete list of StringHelper class members, see the StringHelper Members topic.

Public Static Methods

StringDifference Compares two strings, character by character, and returns the first position where the two strings differ from one another.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringHelper Class | Lucene.Net.Util Namespace


StringHelper.StringDifference Method

Compares two strings, character by character, and returns the first position where the two strings differ from one another.

public static int StringDifference(
string s1,
string s2
);

Parameters

s1
The first string to compare
s2
The second string to compare

Return Value

The first position where the two strings differ.

See Also

StringHelper Class | Lucene.Net.Util Namespace


(global)Hierarchy

An NDoc Documented Class Library

(global) Hierarchy

System.Object
IThreadRunnable
SupportClass
SupportClass.AppSettings
SupportClass.Character
SupportClass.Date
SupportClass.Number
SupportClass.Single
SupportClass.ThreadClass ---- IThreadRunnable

See Also

(global) Namespace


Analyzer Hierarchy

System.Object
Analyzer
GermanAnalyzer
PerFieldAnalyzerWrapper
RussianAnalyzer
SimpleAnalyzer
StandardAnalyzer
StopAnalyzer
WhitespaceAnalyzer

See Also

Analyzer Class | Analyzer Members | Lucene.Net.Analysis Namespace


Lucene.Net.Analysis.DEHierarchy

An NDoc Documented Class Library

Lucene.Net.Analysis.DE Hierarchy

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.DE.GermanAnalyzer
Lucene.Net.Analysis.DE.GermanStemmer
Lucene.Net.Analysis.DE.WordlistLoader
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.DE.GermanStemFilter

See Also

Lucene.Net.Analysis.DE Namespace


Lucene.Net.Analysis.RUHierarchy

An NDoc Documented Class Library

Lucene.Net.Analysis.RU Hierarchy

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.RU.RussianAnalyzer
Lucene.Net.Analysis.RU.RussianCharsets
Lucene.Net.Analysis.RU.RussianStemmer
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.RU.RussianLowerCaseFilter
Lucene.Net.Analysis.RU.RussianStemFilter
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.RU.RussianLetterTokenizer

See Also

Lucene.Net.Analysis.RU Namespace


Lucene.Net.Analysis.StandardHierarchy

An NDoc Documented Class Library

Lucene.Net.Analysis.Standard Hierarchy

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.Standard.StandardAnalyzer
Lucene.Net.Analysis.Standard.CharStream
Lucene.Net.Analysis.Standard.FastCharStream ---- Lucene.Net.Analysis.Standard.CharStream
Lucene.Net.Analysis.Standard.StandardTokenizerConstants
Lucene.Net.Analysis.Standard.StandardTokenizerTokenManager
Lucene.Net.Analysis.Standard.Token
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.Standard.StandardFilter
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.Standard.StandardTokenizer
System.Exception ---- System.Runtime.Serialization.ISerializable
System.ApplicationException
Lucene.Net.Analysis.Standard.TokenMgrError
System.SystemException
System.IO.IOException
Lucene.Net.Analysis.Standard.ParseException

See Also

Lucene.Net.Analysis.Standard Namespace


TokenFilter Hierarchy

System.Object
TokenStream
TokenFilter
GermanStemFilter
LowerCaseFilter
PorterStemFilter
RussianLowerCaseFilter
RussianStemFilter
StandardFilter
StopFilter

See Also

TokenFilter Class | TokenFilter Members | Lucene.Net.Analysis Namespace


Lucene.Net.AnalysisHierarchy

An NDoc Documented Class Library

Lucene.Net.Analysis Hierarchy

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.PerFieldAnalyzerWrapper
Lucene.Net.Analysis.SimpleAnalyzer
Lucene.Net.Analysis.StopAnalyzer
Lucene.Net.Analysis.WhitespaceAnalyzer
Lucene.Net.Analysis.Token
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.LowerCaseFilter
Lucene.Net.Analysis.PorterStemFilter
Lucene.Net.Analysis.StopFilter
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.LetterTokenizer
Lucene.Net.Analysis.LowerCaseTokenizer
Lucene.Net.Analysis.WhitespaceTokenizer

See Also

Lucene.Net.Analysis Namespace


Lucene.Net.DocumentsHierarchy

An NDoc Documented Class Library

Lucene.Net.Documents Hierarchy

System.Object
Lucene.Net.Documents.DateField
Lucene.Net.Documents.Document
Lucene.Net.Documents.Field

See Also

Lucene.Net.Documents Namespace


Lucene.Net.IndexHierarchy

An NDoc Documented Class Library

Lucene.Net.Index Hierarchy

System.Object
Lucene.Net.Index.CompoundFileWriter
Lucene.Net.Index.DocumentWriter
Lucene.Net.Index.FieldInfo
Lucene.Net.Index.FieldInfos
Lucene.Net.Index.FieldsReader
Lucene.Net.Index.FilterIndexReader.FilterTermDocs ---- Lucene.Net.Index.TermDocs
Lucene.Net.Index.FilterIndexReader.FilterTermPositions ---- Lucene.Net.Index.TermPositions
Lucene.Net.Index.IndexReader
Lucene.Net.Index.FilterIndexReader
Lucene.Net.Index.MultiReader
Lucene.Net.Index.SegmentReader
Lucene.Net.Index.IndexWriter
Lucene.Net.Index.MultipleTermPositions ---- Lucene.Net.Index.TermDocs, Lucene.Net.Index.TermPositions
Lucene.Net.Index.SegmentInfo
Lucene.Net.Index.SegmentMerger
Lucene.Net.Index.SegmentTermDocs ---- Lucene.Net.Index.TermDocs
Lucene.Net.Index.Term ---- System.IComparable
Lucene.Net.Index.TermDocs
Lucene.Net.Index.TermEnum
Lucene.Net.Index.FilterIndexReader.FilterTermEnum
Lucene.Net.Index.SegmentTermEnum ---- System.ICloneable
Lucene.Net.Index.TermFreqVector
Lucene.Net.Index.TermInfo
Lucene.Net.Index.TermInfosReader
Lucene.Net.Index.TermInfosWriter
Lucene.Net.Index.TermPositions ---- Lucene.Net.Index.TermDocs
Lucene.Net.Index.TermPositionVector ---- Lucene.Net.Index.TermFreqVector
Lucene.Net.Index.TermVectorsReader
Lucene.Net.Index.TermVectorsWriter
Lucene.Net.Store.Directory
Lucene.Net.Index.CompoundFileReader
Lucene.Net.Store.InputStream ---- System.ICloneable
Lucene.Net.Index.CompoundFileReader.CSInputStream
System.Collections.ArrayList ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
Lucene.Net.Index.SegmentInfos

See Also

Lucene.Net.Index Namespace


Lucene.Net.QueryParsersHierarchy

An NDoc Documented Class Library

Lucene.Net.QueryParsers Hierarchy

System.Object
Lucene.Net.QueryParsers.CharStream
Lucene.Net.QueryParsers.FastCharStream ---- Lucene.Net.QueryParsers.CharStream
Lucene.Net.QueryParsers.QueryParserConstants
Lucene.Net.QueryParsers.QueryParser
Lucene.Net.QueryParsers.MultiFieldQueryParser
Lucene.Net.QueryParsers.QueryParserTokenManager
Lucene.Net.QueryParsers.Token
System.Exception ---- System.Runtime.Serialization.ISerializable
Lucene.Net.QueryParsers.ParseException
System.ApplicationException
Lucene.Net.QueryParsers.TokenMgrError

See Also

Lucene.Net.QueryParsers Namespace


Query Hierarchy

System.Object
Query
BooleanQuery
FilteredQuery
MultiTermQuery
PhrasePrefixQuery
PhraseQuery
PrefixQuery
RangeQuery
SpanQuery
TermQuery

See Also

Query Class | Query Members | Lucene.Net.Search Namespace


Lucene.Net.Search.SpansHierarchy

An NDoc Documented Class Library

Lucene.Net.Search.Spans Hierarchy

System.Object
Lucene.Net.Search.Query ---- System.ICloneable
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanFirstQuery
Lucene.Net.Search.Spans.SpanNearQuery
Lucene.Net.Search.Spans.SpanNotQuery
Lucene.Net.Search.Spans.SpanOrQuery
Lucene.Net.Search.Spans.SpanTermQuery
Lucene.Net.Search.Spans.Spans

See Also

Lucene.Net.Search.Spans Namespace


Lucene.Net.SearchHierarchy

An NDoc Documented Class Library

Lucene.Net.Search Hierarchy

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Search.FilteredTermEnum
Lucene.Net.Search.FuzzyTermEnum
Lucene.Net.Search.WildcardTermEnum
Lucene.Net.Search.AnonymousClassScoreDocComparator ---- Lucene.Net.Search.ScoreDocComparator
Lucene.Net.Search.AnonymousClassScoreDocComparator1 ---- Lucene.Net.Search.ScoreDocComparator
Lucene.Net.Search.BooleanClause
Lucene.Net.Search.Explanation
Lucene.Net.Search.FieldCache
Lucene.Net.Search.Filter
Lucene.Net.Search.CachingWrapperFilter
Lucene.Net.Search.DateFilter
Lucene.Net.Search.QueryFilter
Lucene.Net.Search.HitCollector
Lucene.Net.Search.Hits
Lucene.Net.Search.Query ---- System.ICloneable
Lucene.Net.Search.BooleanQuery
Lucene.Net.Search.FilteredQuery
Lucene.Net.Search.MultiTermQuery
Lucene.Net.Search.FuzzyQuery
Lucene.Net.Search.WildcardQuery
Lucene.Net.Search.PhrasePrefixQuery
Lucene.Net.Search.PhraseQuery
Lucene.Net.Search.PrefixQuery
Lucene.Net.Search.RangeQuery
Lucene.Net.Search.TermQuery
Lucene.Net.Search.QueryTermVector ---- Lucene.Net.Index.TermFreqVector
Lucene.Net.Search.ScoreDoc
Lucene.Net.Search.FieldDoc
Lucene.Net.Search.ScoreDocComparator
Lucene.Net.Search.Scorer
Lucene.Net.Search.Searchable
Lucene.Net.Search.Searcher ---- Lucene.Net.Search.Searchable
Lucene.Net.Search.IndexSearcher
Lucene.Net.Search.MultiSearcher
Lucene.Net.Search.ParallelMultiSearcher
Lucene.Net.Search.Similarity
Lucene.Net.Search.DefaultSimilarity
Lucene.Net.Search.Sort
Lucene.Net.Search.SortComparator ---- Lucene.Net.Search.SortComparatorSource
Lucene.Net.Search.SortComparatorSource
Lucene.Net.Search.SortField
Lucene.Net.Search.StringIndex
Lucene.Net.Search.TopDocs
Lucene.Net.Search.TopFieldDocs
Lucene.Net.Search.Weight
System.Exception ---- System.Runtime.Serialization.ISerializable
System.SystemException
Lucene.Net.Search.BooleanQuery.TooManyClauses
System.MarshalByRefObject
Lucene.Net.Search.RemoteSearchable ---- Lucene.Net.Search.Searchable
System.ValueType
Lucene.Net.Search.FieldCache_Fields
Lucene.Net.Search.ScoreDocComparator_Fields

See Also

Lucene.Net.Search Namespace


Lucene.Net.StoreHierarchy

An NDoc Documented Class Library

Lucene.Net.Store Hierarchy

System.Object
Lucene.Net.Store.Directory
Lucene.Net.Store.FSDirectory
Lucene.Net.Store.RAMDirectory
Lucene.Net.Store.InputStream ---- System.ICloneable
Lucene.Net.Store.FSInputStream
Lucene.Net.Store.Lock
Lucene.Net.Store.Lock.With
Lucene.Net.Store.OutputStream
Lucene.Net.Store.RAMOutputStream

See Also

Lucene.Net.Store Namespace


Lucene.Net.UtilHierarchy

An NDoc Documented Class Library

Lucene.Net.Util Hierarchy

System.Object
Lucene.Net.Util.BitVector
Lucene.Net.Util.Constants
Lucene.Net.Util.PriorityQueue
Lucene.Net.Util.StringHelper

See Also

Lucene.Net.Util Namespace