(global)

Apache Lucene.Net 2.4.0 Class Library API

(global) Namespace

Namespace hierarchy

Classes

Class | Description
NIOFSDirectory |
SupportClass | Contains conversion support elements such as classes, interfaces and static methods.
SupportClass.AppSettings |
SupportClass.BitSetSupport | This class provides supporting methods of java.util.BitSet that are not present in System.Collections.BitArray.
SupportClass.Character | Mimics Java's Character class.
SupportClass.CollectionsSupport |
SupportClass.CollectionsSupport.BitSet |
SupportClass.Compare | Summary description for TestSupportClass.
SupportClass.CompressionSupport | Use for .NET 1.1 Framework only.
SupportClass.CRC32 |
SupportClass.Cryptography |
SupportClass.Date |
SupportClass.FileStream |
SupportClass.FileSupport | Represents the methods to support some operations over files.
SupportClass.Number | A simple class for number conversions.
SupportClass.Single |
SupportClass.TextSupport |
SupportClass.ThreadClass | Support class used to handle threads
SupportClass.WeakHashTable | A Hashtable which holds weak references to its keys so they can be collected during GC.

Interfaces

Interface | Description
IThreadRunnable | This interface should be implemented by any class whose instances are intended to be executed by a thread.
SupportClass.Checksum |
SupportClass.CompressionSupport.ICompressionAdapter |


IThreadRunnable Interface

This interface should be implemented by any class whose instances are intended to be executed by a thread.

For a list of all members of this type, see IThreadRunnable Members.

public interface IThreadRunnable

Types that implement IThreadRunnable

Type | Description
ConcurrentMergeScheduler.MergeThread |
FilterManager.FilterCleaner | Keeps the cache from getting too big. If we were using Java 1.5, we could use LinkedHashMap and we would not need this thread to clean out the cache. The SortedSet sortedFilterItems is used only to sort the items from the cache, so when it's time to clean up we have the TreeSet sort the FilterItems by timestamp. Removes 1.5 * the numbers of items to make the cache smaller. For example: If cache clean size is 10, and the cache is at 15, we would remove (15 - 10) * 1.5 = 7.5 round up to 8. This way we clean the cache a bit more, and avoid having the cache cleaner having to do it frequently.
SupportClass.ThreadClass | Support class used to handle threads

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IThreadRunnable Members | (global) Namespace

Generated from assembly Lucene.Net [2.4.0.2]


IThreadRunnable Members

IThreadRunnable overview

Public Instance Methods

Run This method has to be implemented in order that starting of the thread causes the object's run method to be called in that separately executing thread.

See Also

IThreadRunnable Interface | (global) Namespace


IThreadRunnable Methods

The methods of the IThreadRunnable interface are listed below. For a complete list of IThreadRunnable interface members, see the IThreadRunnable Members topic.

Public Instance Methods

Run This method has to be implemented in order that starting of the thread causes the object's run method to be called in that separately executing thread.

See Also

IThreadRunnable Interface | (global) Namespace


IThreadRunnable.Run Method

This method has to be implemented in order that starting of the thread causes the object's run method to be called in that separately executing thread.

void Run();

See Also

IThreadRunnable Interface | (global) Namespace


NIOFSDirectory Class

For a list of all members of this type, see NIOFSDirectory Members.

System.Object
Lucene.Net.Store.Directory
Lucene.Net.Store.FSDirectory
NIOFSDirectory

public class NIOFSDirectory : FSDirectory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

NIOFSDirectory Members | (global) Namespace


NIOFSDirectory Members

NIOFSDirectory overview

Public Instance Constructors

NIOFSDirectory Constructor Initializes a new instance of the NIOFSDirectory class.

Public Instance Methods

ClearLock (inherited from Directory) | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Close (inherited from FSDirectory) | Closes the store to future operations.
CreateOutput (inherited from FSDirectory) | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile (inherited from FSDirectory) | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists (inherited from FSDirectory) | Returns true iff a file with the given name exists.
FileLength (inherited from FSDirectory) | Returns the length in bytes of a file in the directory.
FileModified (inherited from FSDirectory) | Returns the time the named file was last modified.
GetFile (inherited from FSDirectory) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockFactory (inherited from Directory) | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
GetLockID (inherited from FSDirectory) |
GetType (inherited from Object) | Gets the Type of the current instance.
List (inherited from FSDirectory) | Returns an array of strings, one for each Lucene index file in the directory.
MakeLock (inherited from Directory) | Construct a {@link Lock}.
OpenInput (inherited from FSDirectory) | Overloaded.
RenameFile (inherited from FSDirectory) | Renames an existing file in the directory. Warning: This is not atomic.
SetLockFactory (inherited from Directory) | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Sync (inherited from FSDirectory) |
ToString (inherited from FSDirectory) | For debug output.
TouchFile (inherited from FSDirectory) | Set the modified time of an existing file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

isOpen (inherited from Directory) |
lockFactory (inherited from Directory) | Holds the LockFactory instance (implements locking for this Directory instance).

Protected Internal Instance Methods

EnsureOpen (inherited from Directory) Throws AlreadyClosedException if this Directory is closed.

See Also

NIOFSDirectory Class | (global) Namespace


NIOFSDirectory Constructor

Initializes a new instance of the NIOFSDirectory class.

public NIOFSDirectory();

See Also

NIOFSDirectory Class | (global) Namespace


SupportClass Class

Contains conversion support elements such as classes, interfaces and static methods.

For a list of all members of this type, see SupportClass Members.

System.Object
SupportClass

public class SupportClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass Members | (global) Namespace


SupportClass Members

SupportClass overview

Public Instance Constructors

SupportClass Constructor Initializes a new instance of the SupportClass class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass Class | (global) Namespace


SupportClass Constructor

Initializes a new instance of the SupportClass class.

public SupportClass();

See Also

SupportClass Class | (global) Namespace


SupportClass.AppSettings Class

For a list of all members of this type, see SupportClass.AppSettings Members.

System.Object
SupportClass.AppSettings

public class SupportClass.AppSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.AppSettings Members | (global) Namespace


SupportClass.AppSettings Members

SupportClass.AppSettings overview

Public Static Methods

Get | Overloaded.
Set | Overloaded.

Public Instance Constructors

SupportClass.AppSettings Constructor Initializes a new instance of the SupportClass.AppSettings class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.AppSettings Class | (global) Namespace


SupportClass.AppSettings Constructor

Initializes a new instance of the SupportClass.AppSettings class.

public SupportClass.AppSettings();

See Also

SupportClass.AppSettings Class | (global) Namespace


SupportClass.AppSettings Methods

The methods of the SupportClass.AppSettings class are listed below. For a complete list of SupportClass.AppSettings class members, see the SupportClass.AppSettings Members topic.

Public Static Methods

Get | Overloaded.
Set | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.AppSettings Class | (global) Namespace


Get Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.AppSettings.Get Method

Overload List

public static bool Get(string,bool);

public static int Get(string,int);

public static long Get(string,long);

public static string Get(string,string);

See Also

SupportClass.AppSettings Class | (global) Namespace


SupportClass.AppSettings.Get Method (String, Boolean)

public static bool Get(
string key,
bool defValue
);

See Also

SupportClass.AppSettings Class | (global) Namespace | SupportClass.AppSettings.Get Overload List


SupportClass.AppSettings.Get Method (String, Int32)

public static int Get(
string key,
int defValue
);

Parameters

key
defValue

Return Value

See Also

SupportClass.AppSettings Class | (global) Namespace | SupportClass.AppSettings.Get Overload List


SupportClass.AppSettings.Get Method (String, Int64)

public static long Get(
string key,
long defValue
);

Parameters

key
defValue

Return Value

See Also

SupportClass.AppSettings Class | (global) Namespace | SupportClass.AppSettings.Get Overload List


SupportClass.AppSettings.Get Method (String, String)

public static string Get(
string key,
string defValue
);

Parameters

key
defValue

Return Value

See Also

SupportClass.AppSettings Class | (global) Namespace | SupportClass.AppSettings.Get Overload List


Set Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.AppSettings.Set Method

Overload List

public static void Set(string,bool);

public static void Set(string,int);

public static void Set(string,long);

public static void Set(string,string);

See Also

SupportClass.AppSettings Class | (global) Namespace


SupportClass.AppSettings.Set Method (String, Boolean)

public static void Set(
string key,
bool defValue
);

Parameters

key
defValue

See Also

SupportClass.AppSettings Class | (global) Namespace | SupportClass.AppSettings.Set Overload List


SupportClass.AppSettings.Set Method (String, Int32)

public static void Set(
string key,
int defValue
);

Parameters

key
defValue

See Also

SupportClass.AppSettings Class | (global) Namespace | SupportClass.AppSettings.Set Overload List


SupportClass.AppSettings.Set Method (String, Int64)

public static void Set(
string key,
long defValue
);

Parameters

key
defValue

See Also

SupportClass.AppSettings Class | (global) Namespace | SupportClass.AppSettings.Set Overload List


SupportClass.AppSettings.Set Method (String, String)

public static void Set(
string key,
string defValue
);

Parameters

key
defValue

See Also

SupportClass.AppSettings Class | (global) Namespace | SupportClass.AppSettings.Set Overload List


SupportClass.BitSetSupport Class

This class provides supporting methods of java.util.BitSet that are not present in System.Collections.BitArray.

For a list of all members of this type, see SupportClass.BitSetSupport Members.

System.Object
SupportClass.BitSetSupport

public class SupportClass.BitSetSupport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.BitSetSupport Members | (global) Namespace


SupportClass.BitSetSupport Members

SupportClass.BitSetSupport overview

Public Static Methods

NextSetBit Returns the next set bit at or after docId, or -1 if no such bit exists.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.BitSetSupport Class | (global) Namespace


SupportClass.BitSetSupport Methods

The methods of the SupportClass.BitSetSupport class are listed below. For a complete list of SupportClass.BitSetSupport class members, see the SupportClass.BitSetSupport Members topic.

Public Static Methods

NextSetBit Returns the next set bit at or after docId, or -1 if no such bit exists.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.BitSetSupport Class | (global) Namespace


SupportClass.BitSetSupport.NextSetBit Method

Returns the next set bit at or after docId, or -1 if no such bit exists.

public static int NextSetBit(
BitArray bitArray,
int docId
);

Parameters

bitArray
docId
the index of bit array at which to start checking

Return Value

the next set bit or -1

See Also

SupportClass.BitSetSupport Class | (global) Namespace


SupportClass.Character Class

Mimics Java's Character class.

For a list of all members of this type, see SupportClass.Character Members.

System.Object
SupportClass.Character

public class SupportClass.Character

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.Character Members | (global) Namespace


SupportClass.Character Members

SupportClass.Character overview

Public Static Properties

MAX_RADIX
MIN_RADIX

Public Static Methods

ForDigit

Public Instance Constructors

SupportClass.Character Constructor Initializes a new instance of the SupportClass.Character class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Character Class | (global) Namespace


SupportClass.Character Constructor

Initializes a new instance of the SupportClass.Character class.

public SupportClass.Character();

See Also

SupportClass.Character Class | (global) Namespace


SupportClass.Character Properties

The properties of the SupportClass.Character class are listed below. For a complete list of SupportClass.Character class members, see the SupportClass.Character Members topic.

Public Static Properties

MAX_RADIX
MIN_RADIX

See Also

SupportClass.Character Class | (global) Namespace


MAX_RADIX Property

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.Character.MAX_RADIX Property

public static int MAX_RADIX {get;}

See Also

SupportClass.Character Class | (global) Namespace


MIN_RADIX Property

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.Character.MIN_RADIX Property

public static int MIN_RADIX {get;}

See Also

SupportClass.Character Class | (global) Namespace


SupportClass.Character Methods

The methods of the SupportClass.Character class are listed below. For a complete list of SupportClass.Character class members, see the SupportClass.Character Members topic.

Public Static Methods

ForDigit

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Character Class | (global) Namespace


SupportClass.Character.ForDigit Method

public static char ForDigit(
int digit,
int radix
);

Parameters

digit
radix

Return Value

See Also

SupportClass.Character Class | (global) Namespace


SupportClass.Checksum Interface

For a list of all members of this type, see SupportClass.Checksum Members.

public interface SupportClass.Checksum

Types that implement SupportClass.Checksum

Type | Description
SupportClass.CRC32 |

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.Checksum Members | (global) Namespace


SupportClass.Checksum Members

SupportClass.Checksum overview

Public Instance Methods

getValue |
reset |
update | Overloaded.

See Also

SupportClass.Checksum Interface | (global) Namespace


SupportClass.Checksum Methods

The methods of the SupportClass.Checksum interface are listed below. For a complete list of SupportClass.Checksum interface members, see the SupportClass.Checksum Members topic.

Public Instance Methods

getValue |
reset |
update | Overloaded.

See Also

SupportClass.Checksum Interface | (global) Namespace


SupportClass.Checksum.getValue Method

long getValue();

See Also

SupportClass.Checksum Interface | (global) Namespace


SupportClass.Checksum.reset Method

void reset();

See Also

SupportClass.Checksum Interface | (global) Namespace


update Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.Checksum.update Method

Overload List

void update(byte[]);

void update(byte[],int,int);

void update(int);

See Also

SupportClass.Checksum Interface | (global) Namespace


SupportClass.Checksum.update Method (Byte[])

void update(
byte[] b
);

See Also

SupportClass.Checksum Interface | (global) Namespace | SupportClass.Checksum.update Overload List


SupportClass.Checksum.update Method (Byte[], Int32, Int32)

void update(
byte[] b,
int offset,
int length
);

See Also

SupportClass.Checksum Interface | (global) Namespace | SupportClass.Checksum.update Overload List


SupportClass.Checksum.update Method (Int32)

void update(
int b
);

See Also

SupportClass.Checksum Interface | (global) Namespace | SupportClass.Checksum.update Overload List


SupportClass.CollectionsSupport Class

For a list of all members of this type, see SupportClass.CollectionsSupport Members.

System.Object
SupportClass.CollectionsSupport

public class SupportClass.CollectionsSupport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.CollectionsSupport Members | (global) Namespace


SupportClass.CollectionsSupport Members

SupportClass.CollectionsSupport overview

Public Static Methods

AddAll | Overloaded.
ArrayFill | Overloaded.
PutAll | Overloaded.
TailMap |

Public Instance Constructors

SupportClass.CollectionsSupport Constructor Initializes a new instance of the SupportClass.CollectionsSupport class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.CollectionsSupport Class | (global) Namespace


SupportClass.CollectionsSupport Constructor

Initializes a new instance of the SupportClass.CollectionsSupport class.

public SupportClass.CollectionsSupport();

See Also

SupportClass.CollectionsSupport Class | (global) Namespace


SupportClass.CollectionsSupport Methods

The methods of the SupportClass.CollectionsSupport class are listed below. For a complete list of SupportClass.CollectionsSupport class members, see the SupportClass.CollectionsSupport Members topic.

Public Static Methods

AddAll | Overloaded.
ArrayFill | Overloaded.
PutAll | Overloaded.
TailMap |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.CollectionsSupport Class | (global) Namespace


AddAll Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.CollectionsSupport.AddAll Method

Overload List

public static void AddAll(0, Culture=neutral, PublicKeyToken=b77a5c561934e089]],0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]);

public static void AddAll(0, Culture=neutral, PublicKeyToken=b77a5c561934e089]],0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]);

public static void AddAll(0, Culture=neutral, PublicKeyToken=b77a5c561934e089]],0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace


SupportClass.CollectionsSupport.AddAll Method (0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])

public static void AddAll(
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] source,
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] destination
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.AddAll Overload List


ArrayFill Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.CollectionsSupport.ArrayFill Method

Overload List

public static void ArrayFill(byte[],byte);

public static void ArrayFill(byte[],int,int,byte);

public static void ArrayFill(char[],char);

public static void ArrayFill(char[],int,int,char);

public static void ArrayFill(int[],int);

public static void ArrayFill(int[],int,int,int);

public static void ArrayFill(long[],int,int,long);

public static void ArrayFill(long[],long);

public static void ArrayFill(object[],int,int,object);

public static void ArrayFill(object[],object);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace


SupportClass.CollectionsSupport.ArrayFill Method (Byte[], Byte)

public static void ArrayFill(
byte[] array,
byte fillValue
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.ArrayFill Overload List


SupportClass.CollectionsSupport.ArrayFill Method (Byte[], Int32, Int32, Byte)

public static void ArrayFill(
byte[] array,
int from,
int to,
byte fillValue
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.ArrayFill Overload List


SupportClass.CollectionsSupport.ArrayFill Method (Char[], Char)

public static void ArrayFill(
char[] array,
char fillValue
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.ArrayFill Overload List


SupportClass.CollectionsSupport.ArrayFill Method (Char[], Int32, Int32, Char)

public static void ArrayFill(
char[] array,
int from,
int to,
char fillValue
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.ArrayFill Overload List


SupportClass.CollectionsSupport.ArrayFill Method (Int32[], Int32)

public static void ArrayFill(
int[] array,
int fillValue
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.ArrayFill Overload List


SupportClass.CollectionsSupport.ArrayFill Method (Int32[], Int32, Int32, Int32)

public static void ArrayFill(
int[] array,
int from,
int to,
int fillValue
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.ArrayFill Overload List


SupportClass.CollectionsSupport.ArrayFill Method (Int64[], Int32, Int32, Int64)

public static void ArrayFill(
long[] array,
int from,
int to,
long fillValue
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.ArrayFill Overload List


SupportClass.CollectionsSupport.ArrayFill Method (Int64[], Int64)

public static void ArrayFill(
long[] array,
long fillValue
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.ArrayFill Overload List


SupportClass.CollectionsSupport.ArrayFill Method (Object[], Int32, Int32, Object)

public static void ArrayFill(
object[] array,
int from,
int to,
object fillValue
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.ArrayFill Overload List


SupportClass.CollectionsSupport.ArrayFill Method (Object[], Object)

public static void ArrayFill(
object[] array,
object fillValue
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.ArrayFill Overload List


PutAll Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.CollectionsSupport.PutAll Method

Overload List

public static void PutAll(0, Culture=neutral, PublicKeyToken=b77a5c561934e089]],0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]);

public static void PutAll(IDictionary,IDictionary);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace


SupportClass.CollectionsSupport.PutAll Method (0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])

public static void PutAll(
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] source,
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] destination
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.PutAll Overload List


SupportClass.CollectionsSupport.PutAll Method (IDictionary, IDictionary)

public static void PutAll(
IDictionary source,
IDictionary destination
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace | SupportClass.CollectionsSupport.PutAll Overload List


SupportClass.CollectionsSupport.TailMap Method

public static 2, Culture=neutral, PublicKeyToken=null]] TailMap(
2, Culture=neutral, PublicKeyToken=null]] map,
string fromKey
);

See Also

SupportClass.CollectionsSupport Class | (global) Namespace


SupportClass.CollectionsSupport.BitSet Class

For a list of all members of this type, see SupportClass.CollectionsSupport.BitSet Members.

System.Object
SupportClass.CollectionsSupport.BitSet

public class SupportClass.CollectionsSupport.BitSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.CollectionsSupport.BitSet Members | (global) Namespace


SupportClass.CollectionsSupport.BitSet Members

SupportClass.CollectionsSupport.BitSet overview

Public Instance Constructors

SupportClass.CollectionsSupport.BitSet Overloaded. Initializes a new instance of the SupportClass.CollectionsSupport.BitSet class.

Public Instance Methods

Cardinality |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NextSetBit | Returns the next set bit at or index, or -1 if no such bit exists.
Set |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.CollectionsSupport.BitSet Class | (global) Namespace


SupportClass.CollectionsSupport.BitSet Constructor

Initializes a new instance of the SupportClass.CollectionsSupport.BitSet class.

Overload List

Initializes a new instance of the SupportClass.CollectionsSupport.BitSet class.

public SupportClass.CollectionsSupport.BitSet();

public SupportClass.CollectionsSupport.BitSet(int);

See Also

SupportClass.CollectionsSupport.BitSet Class | (global) Namespace


SupportClass.CollectionsSupport.BitSet Constructor ()

Initializes a new instance of the SupportClass.CollectionsSupport.BitSet class.

public SupportClass.CollectionsSupport.BitSet();

See Also

SupportClass.CollectionsSupport.BitSet Class | (global) Namespace | SupportClass.CollectionsSupport.BitSet Constructor Overload List


SupportClass.CollectionsSupport.BitSet Constructor (Int32)

public SupportClass.CollectionsSupport.BitSet(
int size
);

See Also

SupportClass.CollectionsSupport.BitSet Class | (global) Namespace | SupportClass.CollectionsSupport.BitSet Constructor Overload List


SupportClass.CollectionsSupport.BitSet Methods

The methods of the SupportClass.CollectionsSupport.BitSet class are listed below. For a complete list of SupportClass.CollectionsSupport.BitSet class members, see the SupportClass.CollectionsSupport.BitSet Members topic.

Public Instance Methods

Cardinality |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NextSetBit | Returns the next set bit at or index, or -1 if no such bit exists.
Set |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.CollectionsSupport.BitSet Class | (global) Namespace


SupportClass.CollectionsSupport.BitSet.Cardinality Method

public int Cardinality();

See Also

SupportClass.CollectionsSupport.BitSet Class | (global) Namespace


SupportClass.CollectionsSupport.BitSet.NextSetBit Method

Returns the next set bit at or index, or -1 if no such bit exists.

public int NextSetBit(
int index
);

Parameters

index
the index of the bit at which to start checking

Return Value

the next set bit or -1

See Also

SupportClass.CollectionsSupport.BitSet Class | (global) Namespace


SupportClass.CollectionsSupport.BitSet.Set Method

public void Set(
int index
);

See Also

SupportClass.CollectionsSupport.BitSet Class | (global) Namespace


SupportClass.Compare Class

Summary description for TestSupportClass.

For a list of all members of this type, see SupportClass.Compare Members.

System.Object
SupportClass.Compare

public class SupportClass.Compare

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.Compare Members | (global) Namespace


SupportClass.Compare Members

SupportClass.Compare overview

Public Static Methods

CompareStringArrays | Compares two string arrays for equality.
CompareTermArrays | Compares two Term arrays for equality.

Public Instance Constructors

SupportClass.Compare Constructor Initializes a new instance of the SupportClass.Compare class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Compare Class | (global) Namespace


SupportClass.Compare Constructor

Initializes a new instance of the SupportClass.Compare class.

public SupportClass.Compare();

See Also

SupportClass.Compare Class | (global) Namespace


SupportClass.Compare Methods

The methods of the SupportClass.Compare class are listed below. For a complete list of SupportClass.Compare class members, see the SupportClass.Compare Members topic.

Public Static Methods

CompareStringArrays | Compares two string arrays for equality.
CompareTermArrays | Compares two Term arrays for equality.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Compare Class | (global) Namespace


SupportClass.Compare.CompareStringArrays Method

Compares two string arrays for equality.

public static bool CompareStringArrays(
string[] l1,
string[] l2
);

Parameters

l1
First string array list to compare
l2
Second string array list to compare

Return Value

true if the strings are equal in both arrays, false otherwise

See Also

SupportClass.Compare Class | (global) Namespace


SupportClass.Compare.CompareTermArrays Method

Compares two Term arrays for equality.

public static bool CompareTermArrays(
Term[] t1,
Term[] t2
);

Parameters

t1
First Term array to compare
t2
Second Term array to compare

Return Value

true if the Terms are equal in both arrays, false otherwise

See Also

SupportClass.Compare Class | (global) Namespace


SupportClass.CompressionSupport Class

Use for .NET 1.1 Framework only.

For a list of all members of this type, see SupportClass.CompressionSupport Members.

System.Object
SupportClass.CompressionSupport

public class SupportClass.CompressionSupport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.CompressionSupport Members | (global) Namespace


SupportClass.CompressionSupport Members

SupportClass.CompressionSupport overview

Public Static Methods

Compress
Uncompress

Public Instance Constructors

SupportClass.CompressionSupport Constructor Initializes a new instance of the SupportClass.CompressionSupport class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.CompressionSupport Class | (global) Namespace


SupportClass.CompressionSupport Constructor

Initializes a new instance of the SupportClass.CompressionSupport class.

public SupportClass.CompressionSupport();

See Also

SupportClass.CompressionSupport Class | (global) Namespace


SupportClass.CompressionSupport Methods

The methods of the SupportClass.CompressionSupport class are listed below. For a complete list of SupportClass.CompressionSupport class members, see the SupportClass.CompressionSupport Members topic.

Public Static Methods

Compress
Uncompress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.CompressionSupport Class | (global) Namespace


SupportClass.CompressionSupport.Compress Method

public static byte[] Compress(
byte[] input,
int offset,
int length
);

See Also

SupportClass.CompressionSupport Class | (global) Namespace


SupportClass.CompressionSupport.Uncompress Method

public static byte[] Uncompress(
byte[] input
);

See Also

SupportClass.CompressionSupport Class | (global) Namespace


SupportClass.CompressionSupport.ICompressionAdapter Interface

For a list of all members of this type, see SupportClass.CompressionSupport.ICompressionAdapter Members.

public interface SupportClass.CompressionSupport.ICompressionAdapter

Types that implement SupportClass.CompressionSupport.ICompressionAdapter

Type | Description
SharpZipLibAdapter |

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.CompressionSupport.ICompressionAdapter Members | (global) Namespace


SupportClass.CompressionSupport.ICompressionAdapter Members

SupportClass.CompressionSupport.ICompressionAdapter overview

Public Instance Methods

Compress
Uncompress

See Also

SupportClass.CompressionSupport.ICompressionAdapter Interface | (global) Namespace


SupportClass.CompressionSupport.ICompressionAdapter Methods

The methods of the SupportClass.CompressionSupport.ICompressionAdapter interface are listed below. For a complete list of SupportClass.CompressionSupport.ICompressionAdapter interface members, see the SupportClass.CompressionSupport.ICompressionAdapter Members topic.

Public Instance Methods

Compress
Uncompress

See Also

SupportClass.CompressionSupport.ICompressionAdapter Interface | (global) Namespace


SupportClass.CompressionSupport.ICompressionAdapter.Compress Method

byte[] Compress(
byte[] input,
int offset,
int length
);

See Also

SupportClass.CompressionSupport.ICompressionAdapter Interface | (global) Namespace


SupportClass.CompressionSupport.ICompressionAdapter.Uncompress Method

byte[] Uncompress(
byte[] input
);

See Also

SupportClass.CompressionSupport.ICompressionAdapter Interface | (global) Namespace


SupportClass.CRC32 Class

For a list of all members of this type, see SupportClass.CRC32 Members.

System.Object
SupportClass.CRC32

public class SupportClass.CRC32 : Checksum

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.CRC32 Members | (global) Namespace


SupportClass.CRC32 Members

SupportClass.CRC32 overview

Public Instance Constructors

SupportClass.CRC32 Constructor Initializes a new instance of the SupportClass.CRC32 class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
getValue |
reset |
ToString (inherited from Object) | Returns a String that represents the current Object.
update | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.CRC32 Class | (global) Namespace


SupportClass.CRC32 Constructor

Initializes a new instance of the SupportClass.CRC32 class.

public SupportClass.CRC32();

See Also

SupportClass.CRC32 Class | (global) Namespace


SupportClass.CRC32 Methods

The methods of the SupportClass.CRC32 class are listed below. For a complete list of SupportClass.CRC32 class members, see the SupportClass.CRC32 Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
getValue |
reset |
ToString (inherited from Object) | Returns a String that represents the current Object.
update | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.CRC32 Class | (global) Namespace


SupportClass.CRC32.getValue Method

public long getValue();

Implements

Checksum.getValue

See Also

SupportClass.CRC32 Class | (global) Namespace


SupportClass.CRC32.reset Method

public void reset();

Implements

Checksum.reset

See Also

SupportClass.CRC32 Class | (global) Namespace


update Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.CRC32.update Method

Overload List

public void update(byte[]);

public void update(byte[],int,int);

public void update(int);

See Also

SupportClass.CRC32 Class | (global) Namespace


SupportClass.CRC32.update Method (Byte[])

public void update(
byte[] buf
);

Implements

Checksum.update

See Also

SupportClass.CRC32 Class | (global) Namespace | SupportClass.CRC32.update Overload List


SupportClass.CRC32.update Method (Byte[], Int32, Int32)

public void update(
byte[] buf,
int off,
int len
);

Implements

Checksum.update

See Also

SupportClass.CRC32 Class | (global) Namespace | SupportClass.CRC32.update Overload List


SupportClass.CRC32.update Method (Int32)

public void update(
int bval
);

Implements

Checksum.update

See Also

SupportClass.CRC32 Class | (global) Namespace | SupportClass.CRC32.update Overload List


SupportClass.Cryptography Class

For a list of all members of this type, see SupportClass.Cryptography Members.

System.Object
SupportClass.Cryptography

public class SupportClass.Cryptography

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.Cryptography Members | (global) Namespace


SupportClass.Cryptography Members

SupportClass.Cryptography overview

Public Static Fields

FIPSCompliant

Public Static Methods

GetHashAlgorithm

Public Instance Constructors

SupportClass.Cryptography Constructor Initializes a new instance of the SupportClass.Cryptography class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Cryptography Class | (global) Namespace


SupportClass.Cryptography Constructor

Initializes a new instance of the SupportClass.Cryptography class.

public SupportClass.Cryptography();

See Also

SupportClass.Cryptography Class | (global) Namespace


SupportClass.Cryptography Fields

The fields of the SupportClass.Cryptography class are listed below. For a complete list of SupportClass.Cryptography class members, see the SupportClass.Cryptography Members topic.

Public Static Fields

FIPSCompliant

See Also

SupportClass.Cryptography Class | (global) Namespace


SupportClass.Cryptography.FIPSCompliant Field

public static bool FIPSCompliant;

See Also

SupportClass.Cryptography Class | (global) Namespace


SupportClass.Cryptography Methods

The methods of the SupportClass.Cryptography class are listed below. For a complete list of SupportClass.Cryptography class members, see the SupportClass.Cryptography Members topic.

Public Static Methods

GetHashAlgorithm

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Cryptography Class | (global) Namespace


SupportClass.Cryptography.GetHashAlgorithm Method

public static HashAlgorithm GetHashAlgorithm();

See Also

SupportClass.Cryptography Class | (global) Namespace


SupportClass.Date Class

For a list of all members of this type, see SupportClass.Date Members.

System.Object
SupportClass.Date

public class SupportClass.Date

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.Date Members | (global) Namespace


SupportClass.Date Members

SupportClass.Date overview

Public Static Methods

GetTime

Public Instance Constructors

SupportClass.Date Constructor Initializes a new instance of the SupportClass.Date class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Date Class | (global) Namespace


SupportClass.Date Constructor

Initializes a new instance of the SupportClass.Date class.

public SupportClass.Date();

See Also

SupportClass.Date Class | (global) Namespace


SupportClass.Date Methods

The methods of the SupportClass.Date class are listed below. For a complete list of SupportClass.Date class members, see the SupportClass.Date Members topic.

Public Static Methods

GetTime

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Date Class | (global) Namespace


SupportClass.Date.GetTime Method

public static long GetTime(
DateTime dateTime
);

Parameters

dateTime

Return Value

See Also

SupportClass.Date Class | (global) Namespace


SupportClass.FileStream Class

For a list of all members of this type, see SupportClass.FileStream Members.

System.Object
SupportClass.FileStream

public class SupportClass.FileStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.FileStream Members | (global) Namespace


SupportClass.FileStream Members

SupportClass.FileStream overview

Public Static Methods

Sync

Public Instance Constructors

SupportClass.FileStream Constructor Initializes a new instance of the SupportClass.FileStream class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.FileStream Class | (global) Namespace


SupportClass.FileStream Constructor

Initializes a new instance of the SupportClass.FileStream class.

public SupportClass.FileStream();

See Also

SupportClass.FileStream Class | (global) Namespace


SupportClass.FileStream Methods

The methods of the SupportClass.FileStream class are listed below. For a complete list of SupportClass.FileStream class members, see the SupportClass.FileStream Members topic.

Public Static Methods

Sync

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.FileStream Class | (global) Namespace


SupportClass.FileStream.Sync Method

public static void Sync(
FileStream fs
);

See Also

SupportClass.FileStream Class | (global) Namespace


SupportClass.FileSupport Class

Represents the methods to support some operations over files.

For a list of all members of this type, see SupportClass.FileSupport Members.

System.Object
SupportClass.FileSupport

public class SupportClass.FileSupport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.FileSupport Members | (global) Namespace


SupportClass.FileSupport Members

SupportClass.FileSupport overview

Public Static Methods

GetFiles | Returns an array of abstract pathnames representing the files and directories of the specified path.
GetLuceneIndexFiles | Returns a list of files in a give directory.

Public Instance Constructors

SupportClass.FileSupport Constructor Initializes a new instance of the SupportClass.FileSupport class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.FileSupport Class | (global) Namespace


SupportClass.FileSupport Constructor

Initializes a new instance of the SupportClass.FileSupport class.

public SupportClass.FileSupport();

See Also

SupportClass.FileSupport Class | (global) Namespace


SupportClass.FileSupport Methods

The methods of the SupportClass.FileSupport class are listed below. For a complete list of SupportClass.FileSupport class members, see the SupportClass.FileSupport Members topic.

Public Static Methods

GetFiles | Returns an array of abstract pathnames representing the files and directories of the specified path.
GetLuceneIndexFiles | Returns a list of files in a give directory.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.FileSupport Class | (global) Namespace


SupportClass.FileSupport.GetFiles Method

Returns an array of abstract pathnames representing the files and directories of the specified path.

public static FileInfo[] GetFiles(
FileInfo path
);

Parameters

path
The abstract pathname to list it childs.

Return Value

An array of abstract pathnames childs of the path specified or null if the path is not a directory

See Also

SupportClass.FileSupport Class | (global) Namespace


SupportClass.FileSupport.GetLuceneIndexFiles Method

Returns a list of files in a give directory.

public static string[] GetLuceneIndexFiles(
string fullName,
IndexFileNameFilter indexFileNameFilter
);

Parameters

fullName
The full path name to the directory.
indexFileNameFilter

Return Value

An array containing the files.

See Also

SupportClass.FileSupport Class | (global) Namespace


SupportClass.Number Class

A simple class for number conversions.

For a list of all members of this type, see SupportClass.Number Members.

System.Object
SupportClass.Number

public class SupportClass.Number

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.Number Members | (global) Namespace


SupportClass.Number Members

SupportClass.Number overview

Public Static Fields

MAX_RADIX | Max radix value.
MIN_RADIX | Min radix value.

Public Static Methods

Cardinality | Returns the number of bits set to true in this BitSet.
NextSetBit | Returns the index of the first bit that is set to true that occurs on or after the specified starting index. If no such bit exists then -1 is returned.
Parse | Parses a number in the specified radix.
ToInt64 | Converts a System.String number to long.
ToString | Overloaded. Converts a number to System.String.
URShift | Overloaded. Performs an unsigned bitwise right shift with the specified number

Public Instance Constructors

SupportClass.Number Constructor Initializes a new instance of the SupportClass.Number class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number Constructor

Initializes a new instance of the SupportClass.Number class.

public SupportClass.Number();

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number Fields

The fields of the SupportClass.Number class are listed below. For a complete list of SupportClass.Number class members, see the SupportClass.Number Members topic.

Public Static Fields

MAX_RADIX | Max radix value.
MIN_RADIX | Min radix value.

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number.MAX_RADIX Field

Max radix value.

public const int MAX_RADIX = 36;

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number.MIN_RADIX Field

Min radix value.

public const int MIN_RADIX = 2;

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number Methods

The methods of the SupportClass.Number class are listed below. For a complete list of SupportClass.Number class members, see the SupportClass.Number Members topic.

Public Static Methods

Cardinality | Returns the number of bits set to true in this BitSet.
NextSetBit | Returns the index of the first bit that is set to true that occurs on or after the specified starting index. If no such bit exists then -1 is returned.
Parse | Parses a number in the specified radix.
ToInt64 | Converts a System.String number to long.
ToString | Overloaded. Converts a number to System.String.
URShift | Overloaded. Performs an unsigned bitwise right shift with the specified number

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number.Cardinality Method

Returns the number of bits set to true in this BitSet.

public static int Cardinality(
BitArray bits
);

Parameters

bits
The BitArray object.

Return Value

The number of bits set to true in this BitSet.

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number.NextSetBit Method

Returns the index of the first bit that is set to true that occurs on or after the specified starting index. If no such bit exists then -1 is returned.

public static int NextSetBit(
BitArray bits,
int fromIndex
);

Parameters

bits
The BitArray object.
fromIndex
The index to start checking from (inclusive).

Return Value

The index of the next set bit.

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number.Parse Method

Parses a number in the specified radix.

public static long Parse(
string s,
int radix
);

Parameters

s
An input System.String.
radix
A radix.

Return Value

The parsed number in the specified radix.

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number.ToInt64 Method

Converts a System.String number to long.

public static long ToInt64(
string s
);

Parameters

s

Return Value

See Also

SupportClass.Number Class | (global) Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.Number.ToString Method

Converts a number to System.String.

Overload List

Inherited from Object.

public virtual string ToString();

Converts a number to System.String.

public static string ToString(long);

Converts a number to System.String in the specified radix.

public static string ToString(long,int);

Converts a number to System.String.

public static string ToString(float);

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number.ToString Method (Int64)

Converts a number to System.String.

public static string ToString(
long number
);

Parameters

number

Return Value

See Also

SupportClass.Number Class | (global) Namespace | SupportClass.Number.ToString Overload List


SupportClass.Number.ToString Method (Int64, Int32)

Converts a number to System.String in the specified radix.

public static string ToString(
long i,
int radix
);

Parameters

i
A number to be converted.
radix
A radix.

Return Value

A System.String representation of the number in the specified redix.

See Also

SupportClass.Number Class | (global) Namespace | SupportClass.Number.ToString Overload List


SupportClass.Number.ToString Method (Single)

Converts a number to System.String.

public static string ToString(
float f
);

Parameters

f

Return Value

See Also

SupportClass.Number Class | (global) Namespace | SupportClass.Number.ToString Overload List


URShift Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.Number.URShift Method

Performs an unsigned bitwise right shift with the specified number

Overload List

Performs an unsigned bitwise right shift with the specified number

public static int URShift(int,int);

Performs an unsigned bitwise right shift with the specified number

public static long URShift(long,int);

See Also

SupportClass.Number Class | (global) Namespace


SupportClass.Number.URShift Method (Int32, Int32)

Performs an unsigned bitwise right shift with the specified number

public static int URShift(
int number,
int bits
);

Parameters

number
Number to operate on
bits
Ammount of bits to shift

Return Value

The resulting number from the shift operation

See Also

SupportClass.Number Class | (global) Namespace | SupportClass.Number.URShift Overload List


SupportClass.Number.URShift Method (Int64, Int32)

Performs an unsigned bitwise right shift with the specified number

public static long URShift(
long number,
int bits
);

Parameters

number
Number to operate on
bits
Ammount of bits to shift

Return Value

The resulting number from the shift operation

See Also

SupportClass.Number Class | (global) Namespace | SupportClass.Number.URShift Overload List


SupportClass.Single Class

For a list of all members of this type, see SupportClass.Single Members.

System.Object
SupportClass.Single

public class SupportClass.Single

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.Single Members | (global) Namespace


SupportClass.Single Members

SupportClass.Single overview

Public Static Methods

Parse | Overloaded.
ToString | Overloaded.
TryParse |

Public Instance Constructors

SupportClass.Single Constructor Initializes a new instance of the SupportClass.Single class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Single Class | (global) Namespace


SupportClass.Single Constructor

Initializes a new instance of the SupportClass.Single class.

public SupportClass.Single();

See Also

SupportClass.Single Class | (global) Namespace


SupportClass.Single Methods

The methods of the SupportClass.Single class are listed below. For a complete list of SupportClass.Single class members, see the SupportClass.Single Members topic.

Public Static Methods

Parse | Overloaded.
ToString | Overloaded.
TryParse |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.Single Class | (global) Namespace


Parse Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.Single.Parse Method

Overload List

public static float Parse(string);

public static float Parse(string,NumberStyles);

public static float Parse(string,NumberStyles,IFormatProvider);

public static float Parse(string,IFormatProvider);

See Also

SupportClass.Single Class | (global) Namespace


SupportClass.Single.Parse Method (String)

public static float Parse(
string s
);

Parameters

s

Return Value

See Also

SupportClass.Single Class | (global) Namespace | SupportClass.Single.Parse Overload List


SupportClass.Single.Parse Method (String, NumberStyles)

public static float Parse(
string s,
NumberStyles style
);

Parameters

s
style

Return Value

See Also

SupportClass.Single Class | (global) Namespace | SupportClass.Single.Parse Overload List


SupportClass.Single.Parse Method (String, NumberStyles, IFormatProvider)

public static float Parse(
string s,
NumberStyles style,
IFormatProvider provider
);

Parameters

s
style
provider

Return Value

See Also

SupportClass.Single Class | (global) Namespace | SupportClass.Single.Parse Overload List


SupportClass.Single.Parse Method (String, IFormatProvider)

public static float Parse(
string s,
IFormatProvider provider
);

Parameters

s
provider

Return Value

See Also

SupportClass.Single Class | (global) Namespace | SupportClass.Single.Parse Overload List


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.Single.ToString Method

Overload List

Inherited from Object.

public virtual string ToString();

public static string ToString(float);

public static string ToString(float,string);

See Also

SupportClass.Single Class | (global) Namespace


SupportClass.Single.ToString Method (Single)

public static string ToString(
float f
);

Parameters

f

Return Value

See Also

SupportClass.Single Class | (global) Namespace | SupportClass.Single.ToString Overload List


SupportClass.Single.ToString Method (Single, String)

public static string ToString(
float f,
string format
);

Parameters

f
format

Return Value

See Also

SupportClass.Single Class | (global) Namespace | SupportClass.Single.ToString Overload List


SupportClass.Single.TryParse Method

public static bool TryParse(
string s,
out float f
);

See Also

SupportClass.Single Class | (global) Namespace


SupportClass.TextSupport Class

For a list of all members of this type, see SupportClass.TextSupport Members.

System.Object
SupportClass.TextSupport

public class SupportClass.TextSupport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.TextSupport Members | (global) Namespace


SupportClass.TextSupport Members

SupportClass.TextSupport overview

Public Static Methods

GetCharsFromString Copies an array of chars obtained from a String into a specified array of chars

Public Instance Constructors

SupportClass.TextSupport Constructor Initializes a new instance of the SupportClass.TextSupport class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.TextSupport Class | (global) Namespace


SupportClass.TextSupport Constructor

Initializes a new instance of the SupportClass.TextSupport class.

public SupportClass.TextSupport();

See Also

SupportClass.TextSupport Class | (global) Namespace


SupportClass.TextSupport Methods

The methods of the SupportClass.TextSupport class are listed below. For a complete list of SupportClass.TextSupport class members, see the SupportClass.TextSupport Members topic.

Public Static Methods

GetCharsFromString Copies an array of chars obtained from a String into a specified array of chars

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.TextSupport Class | (global) Namespace


SupportClass.TextSupport.GetCharsFromString Method

Copies an array of chars obtained from a String into a specified array of chars

public static void GetCharsFromString(
string sourceString,
int sourceStart,
int sourceEnd,
char[] destinationArray,
int destinationStart
);

Parameters

sourceString
The String to get the chars from
sourceStart
Position of the String to start getting the chars
sourceEnd
Position of the String to end getting the chars
destinationArray
Array to return the chars
destinationStart
Position of the destination array of chars to start storing the chars

Return Value

An array of chars

See Also

SupportClass.TextSupport Class | (global) Namespace


SupportClass.ThreadClass Class

Support class used to handle threads

For a list of all members of this type, see SupportClass.ThreadClass Members.

System.Object
SupportClass.ThreadClass
Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread

public class SupportClass.ThreadClass : IThreadRunnable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.ThreadClass Members | (global) Namespace


SupportClass.ThreadClass Members

SupportClass.ThreadClass overview

Public Static Methods

Current | Gets the currently running thread
CurrentThread |
Sleep |

Public Instance Constructors

SupportClass.ThreadClass Overloaded. Initializes a new instance of the SupportClass.ThreadClass class.

Public Instance Properties

Instance | Gets the current thread instance
IsAlive | Gets a value indicating the execution status of the current thread
IsBackground | Gets or sets a value indicating whether or not a thread is a background thread.
Name | Gets or sets the name of the thread
Priority | Gets or sets a value indicating the scheduling priority of a thread

Public Instance Methods

Abort | Overloaded. Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interrupt | Interrupts a thread that is in the WaitSleepJoin thread state
Join | Overloaded. Blocks the calling thread until a thread terminates
Resume | Resumes a thread that has been suspended
Run | This method has no functionality unless the method is overridden
SetDaemon |
Start | Causes the operating system to change the state of the current thread instance to ThreadState.Running
Suspend | Suspends the thread, if the thread is already suspended it has no effect
ToString | Obtain a String that represents the current object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass Constructor

Initializes a new instance of the ThreadClass class

Overload List

Initializes a new instance of the ThreadClass class

public SupportClass.ThreadClass();

Initializes a new instance of the Thread class.

public SupportClass.ThreadClass(string);

Initializes a new instance of the Thread class.

public SupportClass.ThreadClass(ThreadStart);

Initializes a new instance of the Thread class.

public SupportClass.ThreadClass(ThreadStart,string);

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass Constructor ()

Initializes a new instance of the ThreadClass class

public SupportClass.ThreadClass();

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass Constructor Overload List


SupportClass.ThreadClass Constructor (String)

Initializes a new instance of the Thread class.

public SupportClass.ThreadClass(
string Name
);

Parameters

Name
The name of the thread

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass Constructor Overload List


SupportClass.ThreadClass Constructor (ThreadStart)

Initializes a new instance of the Thread class.

public SupportClass.ThreadClass(
ThreadStart Start
);

Parameters

Start
A ThreadStart delegate that references the methods to be invoked when this thread begins executing

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass Constructor Overload List


SupportClass.ThreadClass Constructor (ThreadStart, String)

Initializes a new instance of the Thread class.

public SupportClass.ThreadClass(
ThreadStart Start,
string Name
);

Parameters

Start
A ThreadStart delegate that references the methods to be invoked when this thread begins executing
Name
The name of the thread

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass Constructor Overload List


SupportClass.ThreadClass Properties

The properties of the SupportClass.ThreadClass class are listed below. For a complete list of SupportClass.ThreadClass class members, see the SupportClass.ThreadClass Members topic.

Public Instance Properties

Instance | Gets the current thread instance
IsAlive | Gets a value indicating the execution status of the current thread
IsBackground | Gets or sets a value indicating whether or not a thread is a background thread.
Name | Gets or sets the name of the thread
Priority | Gets or sets a value indicating the scheduling priority of a thread

See Also

SupportClass.ThreadClass Class | (global) Namespace


Instance Property

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.ThreadClass.Instance Property

Gets the current thread instance

public System.Threading.Thread Instance {get; set;}

See Also

SupportClass.ThreadClass Class | (global) Namespace


IsAlive Property

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.ThreadClass.IsAlive Property

Gets a value indicating the execution status of the current thread

public bool IsAlive {get;}

See Also

SupportClass.ThreadClass Class | (global) Namespace


IsBackground Property

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.ThreadClass.IsBackground Property

Gets or sets a value indicating whether or not a thread is a background thread.

public bool IsBackground {get; set;}

See Also

SupportClass.ThreadClass Class | (global) Namespace


Name Property

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.ThreadClass.Name Property

Gets or sets the name of the thread

public string Name {get; set;}

See Also

SupportClass.ThreadClass Class | (global) Namespace


Priority Property

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.ThreadClass.Priority Property

Gets or sets a value indicating the scheduling priority of a thread

public System.Threading.ThreadPriority Priority {get; set;}

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass Methods

The methods of the SupportClass.ThreadClass class are listed below. For a complete list of SupportClass.ThreadClass class members, see the SupportClass.ThreadClass Members topic.

Public Static Methods

Current | Gets the currently running thread
CurrentThread |
Sleep |

Public Instance Methods

Abort | Overloaded. Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interrupt | Interrupts a thread that is in the WaitSleepJoin thread state
Join | Overloaded. Blocks the calling thread until a thread terminates
Resume | Resumes a thread that has been suspended
Run | This method has no functionality unless the method is overridden
SetDaemon |
Start | Causes the operating system to change the state of the current thread instance to ThreadState.Running
Suspend | Suspends the thread, if the thread is already suspended it has no effect
ToString | Obtain a String that represents the current object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.ThreadClass Class | (global) Namespace


Abort Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.ThreadClass.Abort Method

Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread

Overload List

Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread

public void Abort();

Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread while also providing exception information about the thread termination. Calling this method usually terminates the thread.

public void Abort(object);

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Abort Method ()

Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread

public void Abort();

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass.Abort Overload List


SupportClass.ThreadClass.Abort Method (Object)

Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread while also providing exception information about the thread termination. Calling this method usually terminates the thread.

public void Abort(
object stateInfo
);

Parameters

stateInfo
An object that contains application-specific information, such as state, which can be used by the thread being aborted

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass.Abort Overload List


SupportClass.ThreadClass.Current Method

Gets the currently running thread

public static ThreadClass Current();

Return Value

The currently running thread

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.CurrentThread Method

public static ThreadClass CurrentThread();

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Interrupt Method

Interrupts a thread that is in the WaitSleepJoin thread state

public virtual void Interrupt();

See Also

SupportClass.ThreadClass Class | (global) Namespace


Join Method

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.ThreadClass.Join Method

Blocks the calling thread until a thread terminates

Overload List

Blocks the calling thread until a thread terminates

public void Join();

Blocks the calling thread until a thread terminates or the specified time elapses

public void Join(long);

Blocks the calling thread until a thread terminates or the specified time elapses

public void Join(long,int);

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Join Method ()

Blocks the calling thread until a thread terminates

public void Join();

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass.Join Overload List


SupportClass.ThreadClass.Join Method (Int64)

Blocks the calling thread until a thread terminates or the specified time elapses

public void Join(
long MiliSeconds
);

Parameters

MiliSeconds
Time of wait in milliseconds

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass.Join Overload List


SupportClass.ThreadClass.Join Method (Int64, Int32)

Blocks the calling thread until a thread terminates or the specified time elapses

public void Join(
long MiliSeconds,
int NanoSeconds
);

Parameters

MiliSeconds
Time of wait in milliseconds
NanoSeconds
Time of wait in nanoseconds

See Also

SupportClass.ThreadClass Class | (global) Namespace | SupportClass.ThreadClass.Join Overload List


SupportClass.ThreadClass.Resume Method

Resumes a thread that has been suspended

public void Resume();

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Run Method

This method has no functionality unless the method is overridden

public virtual void Run();

Implements

IThreadRunnable.Run

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.SetDaemon Method

public void SetDaemon(
bool isDaemon
);

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Sleep Method

public static void Sleep(
long ms
);

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Start Method

Causes the operating system to change the state of the current thread instance to ThreadState.Running

public virtual void Start();

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.Suspend Method

Suspends the thread, if the thread is already suspended it has no effect

public void Suspend();

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.ThreadClass.ToString Method

Obtain a String that represents the current object

public override string ToString();

Return Value

A String that represents the current object

See Also

SupportClass.ThreadClass Class | (global) Namespace


SupportClass.WeakHashTable Class

A Hashtable which holds weak references to its keys so they can be collected during GC.

For a list of all members of this type, see SupportClass.WeakHashTable Members.

System.Object
System.Collections.Hashtable
SupportClass.WeakHashTable

public class SupportClass.WeakHashTable : Hashtable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: (global)

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SupportClass.WeakHashTable Members | (global) Namespace


SupportClass.WeakHashTable Members

SupportClass.WeakHashTable overview

Public Instance Constructors

SupportClass.WeakHashTable Constructor Initializes a new instance of the SupportClass.WeakHashTable class.

Public Instance Properties

Count |
IsFixedSize (inherited from Hashtable) | Gets a value indicating whether the Hashtable has a fixed size.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread safe).
Item |
Keys | Create a temporary copy of the real keys and return that
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

Public Instance Methods

Add | Wrap each key with a WeakKey and add it to the hashtable
Clear (inherited from Hashtable) | Removes all elements from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsKey (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines whether the Hashtable contains a specific value.
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Hashtable) | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from Hashtable) | Removes the element with the specified key from the Hashtable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

comparer (inherited from Hashtable) | Obsolete. Gets or sets the IComparer to use for the Hashtable.
EqualityComparer (inherited from Hashtable) | Gets the IEqualityComparer to use for the Hashtable.
hcp (inherited from Hashtable) | Obsolete. Gets or sets the object that can dispense hash codes.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHash |
KeyEquals | Customize the hashtable lookup process by overriding KeyEquals. KeyEquals will compare both WeakKey to WeakKey and WeakKey to real keys
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.WeakHashTable Class | (global) Namespace


SupportClass.WeakHashTable Constructor

Initializes a new instance of the SupportClass.WeakHashTable class.

public SupportClass.WeakHashTable();

See Also

SupportClass.WeakHashTable Class | (global) Namespace


SupportClass.WeakHashTable Properties

The properties of the SupportClass.WeakHashTable class are listed below. For a complete list of SupportClass.WeakHashTable class members, see the SupportClass.WeakHashTable Members topic.

Public Instance Properties

Count |
IsFixedSize (inherited from Hashtable) | Gets a value indicating whether the Hashtable has a fixed size.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread safe).
Item |
Keys | Create a temporary copy of the real keys and return that
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

Protected Instance Properties

comparer (inherited from Hashtable) | Obsolete. Gets or sets the IComparer to use for the Hashtable.
EqualityComparer (inherited from Hashtable) | Gets the IEqualityComparer to use for the Hashtable.
hcp (inherited from Hashtable) | Obsolete. Gets or sets the object that can dispense hash codes.

See Also

SupportClass.WeakHashTable Class | (global) Namespace


Count Property

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.WeakHashTable.Count Property

public override int Count {get;}

Implements

ICollection.Count

See Also

SupportClass.WeakHashTable Class | (global) Namespace


Item Property

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.WeakHashTable.Item Property

public override object this[
object key
] {get; set;}

Implements

IDictionary.Item

See Also

SupportClass.WeakHashTable Class | (global) Namespace


Keys Property

Apache Lucene.Net 2.4.0 Class Library API

SupportClass.WeakHashTable.Keys Property

Create a temporary copy of the real keys and return that

public override System.Collections.ICollection Keys {get;}

Implements

IDictionary.Keys

See Also

SupportClass.WeakHashTable Class | (global) Namespace


SupportClass.WeakHashTable Methods

The methods of the SupportClass.WeakHashTable class are listed below. For a complete list of SupportClass.WeakHashTable class members, see the SupportClass.WeakHashTable Members topic.

Public Instance Methods

Add | Wrap each key with a WeakKey and add it to the hashtable
Clear (inherited from Hashtable) | Removes all elements from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsKey (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines whether the Hashtable contains a specific value.
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Hashtable) | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from Hashtable) | Removes the element with the specified key from the Hashtable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHash |
KeyEquals | Customize the hashtable lookup process by overriding KeyEquals. KeyEquals will compare both WeakKey to WeakKey and WeakKey to real keys
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SupportClass.WeakHashTable Class | (global) Namespace


SupportClass.WeakHashTable.Add Method

Wrap each key with a WeakKey and add it to the hashtable

public override void Add(
object key,
object value
);

Implements

IDictionary.Add

See Also

SupportClass.WeakHashTable Class | (global) Namespace


SupportClass.WeakHashTable.CopyTo Method

public override void CopyTo(
Array array,
int index
);

Implements

ICollection.CopyTo

See Also

SupportClass.WeakHashTable Class | (global) Namespace


SupportClass.WeakHashTable.GetEnumerator Method

public override IDictionaryEnumerator GetEnumerator();

Implements

IDictionary.GetEnumerator

See Also

SupportClass.WeakHashTable Class | (global) Namespace


SupportClass.WeakHashTable.GetHash Method

protected override int GetHash(
object key
);

See Also

SupportClass.WeakHashTable Class | (global) Namespace


SupportClass.WeakHashTable.KeyEquals Method

Customize the hashtable lookup process by overriding KeyEquals. KeyEquals will compare both WeakKey to WeakKey and WeakKey to real keys

protected override bool KeyEquals(
object x,
object y
);

See Also

SupportClass.WeakHashTable Class | (global) Namespace


Lucene.Net

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net Namespace

Namespace hierarchy

Classes

Class | Description
LucenePackage | Lucene's package information, including version. *


LucenePackage Class

Lucene's package information, including version. *

For a list of all members of this type, see LucenePackage Members.

System.Object
Lucene.Net.LucenePackage

public sealed class LucenePackage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LucenePackage Members | Lucene.Net Namespace


LucenePackage Members

LucenePackage overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LucenePackage Class | Lucene.Net Namespace


Lucene.Net.Analysis

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Analysis Namespace

Namespace hierarchy

Classes

Class | Description
Analyzer
CachingTokenFilter | This class can be used if the Tokens of a TokenStream are intended to be consumed more than once. It caches all Tokens locally in a List. CachingTokenFilter implements the optional method {@link TokenStream#Reset()}, which repositions the stream to the first Token.
CharArraySet | A simple class that stores Strings as char[]'s in a hash table. Note that this is not a general purpose class. For example, it cannot remove items from the set, nor does it resize its hash table to be smaller, etc. It is designed to be quick to test if a char[] is in the set without the necessity of converting it to a String first.
CharArraySet.CharArraySetIterator
CharTokenizer | An abstract base class for simple, character-oriented tokenizers.
ISOLatin1AccentFilter
KeywordAnalyzer | "Tokenizes" the entire stream as a single token. This is useful for data like zip codes, ids, and some product names.
KeywordTokenizer | Emits the entire input as a single token.
LengthFilter | Removes words that are too long and too short from the stream.
LetterTokenizer | A LetterTokenizer is a tokenizer that divides text at non-letters. That's to say, it defines tokens as maximal strings of adjacent letters, as defined by java.lang.Character.isLetter() predicate. Note: this does a decent job for most European languages, but does a terrible job for some Asian languages, where words are not separated by spaces.
LowerCaseFilter | Normalizes token text to lower case.
LowerCaseTokenizer
PerFieldAnalyzerWrapper
PorterStemFilter
SimpleAnalyzer | An Analyzer that filters LetterTokenizer with LowerCaseFilter.
SinkTokenizer | A SinkTokenizer can be used to cache Tokens for use in an Analyzer
StopAnalyzer | Filters LetterTokenizer with LowerCaseFilter and StopFilter.
StopFilter | Removes stop words from a token stream.
TeeTokenFilter Works in conjunction with the SinkTokenizer to provide the ability to set aside tokens that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.
 SinkTokenizer sink1 = new SinkTokenizer(null); SinkTokenizer sink2 = new SinkTokenizer(null); TokenStream source1 = new TeeTokenFilter(new TeeTokenFilter(new WhitespaceTokenizer(reader1), sink1), sink2); TokenStream source2 = new TeeTokenFilter(new TeeTokenFilter(new WhitespaceTokenizer(reader2), sink1), sink2); TokenStream final1 = new LowerCaseFilter(source1); TokenStream final2 = source2; TokenStream final3 = new EntityDetect(sink1); TokenStream final4 = new URLDetect(sink2); d.add(new Field("f1", final1)); d.add(new Field("f2", final2)); d.add(new Field("f3", final3)); d.add(new Field("f4", final4));
In this example, sink1 and sink2 will both get tokens from both reader1 and reader2 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene

See http://issues.apache.org/jira/browse/LUCENE-1058
Token
TokenFilter
Tokenizer
TokenStream
WhitespaceAnalyzer | An Analyzer that uses WhitespaceTokenizer.
WhitespaceTokenizer | A WhitespaceTokenizer is a tokenizer that divides text at whitespace. Adjacent sequences of non-Whitespace characters form tokens.
WordlistLoader | Loader for text files that represent a list of stopwords.


Analyzer Class

For a list of all members of this type, see Analyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Derived types

public abstract class Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Analyzer Members | Lucene.Net.Analysis Namespace


Analyzer Members

Analyzer overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
GetType (inherited from Object) | Gets the Type of the current instance.
ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance.
TokenStream | Creates a TokenStream which tokenizes all the text in the provided Reader. Must be able to handle null field name for backward compatibility.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Analyzer Constructor Initializes a new instance of the Analyzer class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

Analyzer Class | Lucene.Net.Analysis Namespace


Analyzer Constructor

Initializes a new instance of the Analyzer class.

protected Analyzer();

See Also

Analyzer Class | Lucene.Net.Analysis Namespace


Analyzer Methods

The methods of the Analyzer class are listed below. For a complete list of Analyzer class members, see the Analyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
GetType (inherited from Object) | Gets the Type of the current instance.
ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance.
TokenStream | Creates a TokenStream which tokenizes all the text in the provided Reader. Must be able to handle null field name for backward compatibility.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

Analyzer Class | Lucene.Net.Analysis Namespace


Analyzer.GetPositionIncrementGap Method

Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.

public virtual int GetPositionIncrementGap(
string fieldName
);

Parameters

fieldName
Fieldable name being indexed.

Return Value

position increment gap, added to the next token emitted from {@link #TokenStream(String,Reader)}

See Also

Analyzer Class | Lucene.Net.Analysis Namespace


Analyzer.GetPreviousTokenStream Method

Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.

protected internal virtual object GetPreviousTokenStream();

See Also

Analyzer Class | Lucene.Net.Analysis Namespace


Analyzer.ReusableTokenStream Method

Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance.

public virtual TokenStream ReusableTokenStream(
string fieldName,
TextReader reader
);

See Also

Analyzer Class | Lucene.Net.Analysis Namespace


Analyzer.SetPreviousTokenStream Method

Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

protected internal virtual void SetPreviousTokenStream(
object obj
);

See Also

Analyzer Class | Lucene.Net.Analysis Namespace


Analyzer.TokenStream Method

Creates a TokenStream which tokenizes all the text in the provided Reader. Must be able to handle null field name for backward compatibility.

public abstract TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

Analyzer Class | Lucene.Net.Analysis Namespace


CachingTokenFilter Class

This class can be used if the Tokens of a TokenStream are intended to be consumed more than once. It caches all Tokens locally in a List. CachingTokenFilter implements the optional method {@link TokenStream#Reset()}, which repositions the stream to the first Token.

For a list of all members of this type, see CachingTokenFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.CachingTokenFilter

public class CachingTokenFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CachingTokenFilter Members | Lucene.Net.Analysis Namespace


CachingTokenFilter Members

CachingTokenFilter overview

Public Instance Constructors

CachingTokenFilter Constructor

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

CachingTokenFilter Class | Lucene.Net.Analysis Namespace


CachingTokenFilter Constructor

public CachingTokenFilter(
TokenStream input
);

See Also

CachingTokenFilter Class | Lucene.Net.Analysis Namespace


CachingTokenFilter Methods

The methods of the CachingTokenFilter class are listed below. For a complete list of CachingTokenFilter class members, see the CachingTokenFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CachingTokenFilter Class | Lucene.Net.Analysis Namespace


Next Method

Apache Lucene.Net 2.4.0 Class Library API

CachingTokenFilter.Next Method

Overload List

Inherited from TokenStream.

public virtual Token Next();

public override Token Next(Token);

See Also

CachingTokenFilter Class | Lucene.Net.Analysis Namespace


CachingTokenFilter.Next Method (Token)

public override Token Next(
Token reusableToken
);

See Also

CachingTokenFilter Class | Lucene.Net.Analysis Namespace | CachingTokenFilter.Next Overload List


CachingTokenFilter.Reset Method

public override void Reset();

See Also

CachingTokenFilter Class | Lucene.Net.Analysis Namespace


CharArraySet Class

A simple class that stores Strings as char[]'s in a hash table. Note that this is not a general purpose class. For example, it cannot remove items from the set, nor does it resize its hash table to be smaller, etc. It is designed to be quick to test if a char[] is in the set without the necessity of converting it to a String first.

For a list of all members of this type, see CharArraySet Members.

System.Object
System.Collections.Hashtable
Lucene.Net.Analysis.CharArraySet

public class CharArraySet : Hashtable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CharArraySet Members | Lucene.Net.Analysis Namespace


CharArraySet Members

CharArraySet overview

Public Instance Constructors

CharArraySet Overloaded. Initializes a new instance of the CharArraySet class.

Public Instance Properties

Count |
IsFixedSize (inherited from Hashtable) | Gets a value indicating whether the Hashtable has a fixed size.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread safe).
Item (inherited from Hashtable) | Gets or sets the value associated with the specified key.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

Public Instance Methods

Add | Overloaded. Add this String into the set
Add (inherited from Hashtable) | Overloaded. Adds an element with the specified key and value into the Hashtable.
Clear (inherited from Hashtable) | Removes all elements from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains Overloaded. true if the
len
chars of
text
starting at
off
are in the set
ContainsKey (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines whether the Hashtable contains a specific value.
CopyTo (inherited from Hashtable) | Copies the Hashtable elements to a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Hashtable) | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEmpty
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from Hashtable) | Removes the element with the specified key from the Hashtable.
Size
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

comparer (inherited from Hashtable) | Obsolete. Gets or sets the IComparer to use for the Hashtable.
EqualityComparer (inherited from Hashtable) | Gets the IEqualityComparer to use for the Hashtable.
hcp (inherited from Hashtable) | Obsolete. Gets or sets the object that can dispense hash codes.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHash (inherited from Hashtable) | Returns the hash code for the specified key.
KeyEquals (inherited from Hashtable) | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace


CharArraySet Constructor

Create set with enough capacity to hold startSize terms

Overload List

Create set from a Collection of char[] or String

public CharArraySet(ICollection,bool);

Create set with enough capacity to hold startSize terms

public CharArraySet(int,bool);

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace


CharArraySet Constructor (Int32, Boolean)

Create set with enough capacity to hold startSize terms

public CharArraySet(
int startSize,
bool ignoreCase
);

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace | CharArraySet Constructor Overload List


CharArraySet Constructor (ICollection, Boolean)

Create set from a Collection of char[] or String

public CharArraySet(
ICollection c,
bool ignoreCase
);

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace | CharArraySet Constructor Overload List


CharArraySet Properties

The properties of the CharArraySet class are listed below. For a complete list of CharArraySet class members, see the CharArraySet Members topic.

Public Instance Properties

Count |
IsFixedSize (inherited from Hashtable) | Gets a value indicating whether the Hashtable has a fixed size.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread safe).
Item (inherited from Hashtable) | Gets or sets the value associated with the specified key.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

Protected Instance Properties

comparer (inherited from Hashtable) | Obsolete. Gets or sets the IComparer to use for the Hashtable.
EqualityComparer (inherited from Hashtable) | Gets the IEqualityComparer to use for the Hashtable.
hcp (inherited from Hashtable) | Obsolete. Gets or sets the object that can dispense hash codes.

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace


Count Property

Apache Lucene.Net 2.4.0 Class Library API

CharArraySet.Count Property

public override int Count {get;}

Implements

ICollection.Count

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace


CharArraySet Methods

The methods of the CharArraySet class are listed below. For a complete list of CharArraySet class members, see the CharArraySet Members topic.

Public Instance Methods

Add | Overloaded. Add this String into the set
Add (inherited from Hashtable) | Overloaded. Adds an element with the specified key and value into the Hashtable.
Clear (inherited from Hashtable) | Removes all elements from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains Overloaded. true if the
len
chars of
text
starting at
off
are in the set
ContainsKey (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines whether the Hashtable contains a specific value.
CopyTo (inherited from Hashtable) | Copies the Hashtable elements to a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Hashtable) | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEmpty
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from Hashtable) | Removes the element with the specified key from the Hashtable.
Size
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHash (inherited from Hashtable) | Returns the hash code for the specified key.
KeyEquals (inherited from Hashtable) | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace


Add Method

Apache Lucene.Net 2.4.0 Class Library API

CharArraySet.Add Method

Add this char[] directly to the set. If ignoreCase is true for this Set, the text array will be directly modified. The user should never modify this text array after calling this method.

Overload List

Add this char[] directly to the set. If ignoreCase is true for this Set, the text array will be directly modified. The user should never modify this text array after calling this method.

public virtual bool Add(char[]);

public virtual bool Add(object);

Inherited from Hashtable.

public virtual void Add(object,object);

Add this String into the set

public virtual bool Add(string);

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace


CharArraySet.Add Method (Char[])

Add this char[] directly to the set. If ignoreCase is true for this Set, the text array will be directly modified. The user should never modify this text array after calling this method.

public virtual bool Add(
char[] text
);

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace | CharArraySet.Add Overload List


CharArraySet.Add Method (Object)

public virtual bool Add(
object o
);

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace | CharArraySet.Add Overload List


CharArraySet.Add Method (String)

Add this String into the set

public virtual bool Add(
string text
);

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace | CharArraySet.Add Overload List


Contains Method

Apache Lucene.Net 2.4.0 Class Library API

CharArraySet.Contains Method

true if the

len
chars of
text
starting at
off
are in the set

Overload List

true if the

len
chars of
text
starting at
off
are in the set

public virtual bool Contains(char[],int,int);

public override bool Contains(object);

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace


CharArraySet.Contains Method (Char[], Int32, Int32)

true if the

len
chars of
text
starting at
off
are in the set

public virtual bool Contains(
char[] text,
int off,
int len
);

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace | CharArraySet.Contains Overload List


CharArraySet.Contains Method (Object)

public override bool Contains(
object o
);

Implements

IDictionary.Contains

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace | CharArraySet.Contains Overload List


CharArraySet.GetEnumerator Method

new public IEnumerator GetEnumerator();

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace


CharArraySet.IsEmpty Method

public virtual bool IsEmpty();

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace


CharArraySet.Size Method

public virtual int Size();

See Also

CharArraySet Class | Lucene.Net.Analysis Namespace


CharArraySet.CharArraySetIterator Class

For a list of all members of this type, see CharArraySet.CharArraySetIterator Members.

System.Object
Lucene.Net.Analysis.CharArraySet.CharArraySetIterator

public class CharArraySet.CharArraySetIterator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CharArraySet.CharArraySetIterator Members | Lucene.Net.Analysis Namespace


CharArraySet.CharArraySetIterator Members

CharArraySet.CharArraySetIterator overview

Public Instance Properties

Current
Enclosing_Instance

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
NextCharArray | do not modify the returned char[]
Remove |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CharArraySet.CharArraySetIterator Class | Lucene.Net.Analysis Namespace


CharArraySet.CharArraySetIterator Properties

The properties of the CharArraySet.CharArraySetIterator class are listed below. For a complete list of CharArraySet.CharArraySetIterator class members, see the CharArraySet.CharArraySetIterator Members topic.

Public Instance Properties

Current
Enclosing_Instance

See Also

CharArraySet.CharArraySetIterator Class | Lucene.Net.Analysis Namespace


Current Property

Apache Lucene.Net 2.4.0 Class Library API

CharArraySet.CharArraySetIterator.Current Property

public virtual object Current {get;}

Implements

IEnumerator.Current

See Also

CharArraySet.CharArraySetIterator Class | Lucene.Net.Analysis Namespace


Enclosing_Instance Property

Apache Lucene.Net 2.4.0 Class Library API

CharArraySet.CharArraySetIterator.Enclosing_Instance Property

public CharArraySet Enclosing_Instance {get;}

See Also

CharArraySet.CharArraySetIterator Class | Lucene.Net.Analysis Namespace


CharArraySet.CharArraySetIterator Methods

The methods of the CharArraySet.CharArraySetIterator class are listed below. For a complete list of CharArraySet.CharArraySetIterator class members, see the CharArraySet.CharArraySetIterator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
NextCharArray | do not modify the returned char[]
Remove |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CharArraySet.CharArraySetIterator Class | Lucene.Net.Analysis Namespace


CharArraySet.CharArraySetIterator.MoveNext Method

public virtual bool MoveNext();

Implements

IEnumerator.MoveNext

See Also

CharArraySet.CharArraySetIterator Class | Lucene.Net.Analysis Namespace


CharArraySet.CharArraySetIterator.NextCharArray Method

do not modify the returned char[]

public virtual char[] NextCharArray();

See Also

CharArraySet.CharArraySetIterator Class | Lucene.Net.Analysis Namespace


CharArraySet.CharArraySetIterator.Remove Method

public virtual void Remove();

See Also

CharArraySet.CharArraySetIterator Class | Lucene.Net.Analysis Namespace


CharArraySet.CharArraySetIterator.Reset Method

public virtual void Reset();

Implements

IEnumerator.Reset

See Also

CharArraySet.CharArraySetIterator Class | Lucene.Net.Analysis Namespace


CharTokenizer Class

An abstract base class for simple, character-oriented tokenizers.

For a list of all members of this type, see CharTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.LetterTokenizer
Lucene.Net.Analysis.WhitespaceTokenizer

public abstract class CharTokenizer : Tokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CharTokenizer Members | Lucene.Net.Analysis Namespace


CharTokenizer Members

CharTokenizer overview

Public Instance Constructors

CharTokenizer Constructor

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Overloaded.
Reset (inherited from TokenStream) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

Protected Internal Instance Methods

IsTokenChar | Returns true iff a character should be included in a token. This tokenizer generates as tokens adjacent sequences of characters which satisfy this predicate. Characters for which this is false are used to define token boundaries and are not included in tokens.
Normalize | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


CharTokenizer Constructor

public CharTokenizer(
TextReader input
);

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


CharTokenizer Methods

The methods of the CharTokenizer class are listed below. For a complete list of CharTokenizer class members, see the CharTokenizer Members topic.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Overloaded.
Reset (inherited from TokenStream) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

IsTokenChar | Returns true iff a character should be included in a token. This tokenizer generates as tokens adjacent sequences of characters which satisfy this predicate. Characters for which this is false are used to define token boundaries and are not included in tokens.
Normalize | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


CharTokenizer.IsTokenChar Method

Returns true iff a character should be included in a token. This tokenizer generates as tokens adjacent sequences of characters which satisfy this predicate. Characters for which this is false are used to define token boundaries and are not included in tokens.

protected internal abstract bool IsTokenChar(
char c
);

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


Next Method

Apache Lucene.Net 2.4.0 Class Library API

CharTokenizer.Next Method

Overload List

Inherited from TokenStream.

public virtual Token Next();

public override Token Next(Token);

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


CharTokenizer.Next Method (Token)

public override Token Next(
Token reusableToken
);

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace | CharTokenizer.Next Overload List


CharTokenizer.Normalize Method

Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

protected internal virtual char Normalize(
char c
);

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


Reset Method

Apache Lucene.Net 2.4.0 Class Library API

CharTokenizer.Reset Method

Overload List

Inherited from TokenStream.

public virtual void Reset();

public override void Reset(TextReader);

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace


CharTokenizer.Reset Method (TextReader)

public override void Reset(
TextReader input
);

See Also

CharTokenizer Class | Lucene.Net.Analysis Namespace | CharTokenizer.Reset Overload List


ISOLatin1AccentFilter Class

For a list of all members of this type, see ISOLatin1AccentFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.ISOLatin1AccentFilter

public class ISOLatin1AccentFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ISOLatin1AccentFilter Members | Lucene.Net.Analysis Namespace


ISOLatin1AccentFilter Members

ISOLatin1AccentFilter overview

Public Instance Constructors

ISOLatin1AccentFilter Constructor

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
RemoveAccents | To replace accented characters in a String by unaccented equivalents.
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

ISOLatin1AccentFilter Class | Lucene.Net.Analysis Namespace


ISOLatin1AccentFilter Constructor

public ISOLatin1AccentFilter(
TokenStream input
);

See Also

ISOLatin1AccentFilter Class | Lucene.Net.Analysis Namespace


ISOLatin1AccentFilter Methods

The methods of the ISOLatin1AccentFilter class are listed below. For a complete list of ISOLatin1AccentFilter class members, see the ISOLatin1AccentFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
RemoveAccents | To replace accented characters in a String by unaccented equivalents.
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ISOLatin1AccentFilter Class | Lucene.Net.Analysis Namespace


Next Method

Apache Lucene.Net 2.4.0 Class Library API

ISOLatin1AccentFilter.Next Method

Overload List

Inherited from TokenStream.

public virtual Token Next();

public override Token Next(Token);

See Also

ISOLatin1AccentFilter Class | Lucene.Net.Analysis Namespace


ISOLatin1AccentFilter.Next Method (Token)

public override Token Next(
Token reusableToken
);

See Also

ISOLatin1AccentFilter Class | Lucene.Net.Analysis Namespace | ISOLatin1AccentFilter.Next Overload List


ISOLatin1AccentFilter.RemoveAccents Method

To replace accented characters in a String by unaccented equivalents.

public void RemoveAccents(
char[] input,
int length
);

See Also

ISOLatin1AccentFilter Class | Lucene.Net.Analysis Namespace


KeywordAnalyzer Class

"Tokenizes" the entire stream as a single token. This is useful for data like zip codes, ids, and some product names.

For a list of all members of this type, see KeywordAnalyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.KeywordAnalyzer

public class KeywordAnalyzer : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

KeywordAnalyzer Members | Lucene.Net.Analysis Namespace


KeywordAnalyzer Members

KeywordAnalyzer overview

Public Instance Constructors

KeywordAnalyzer Constructor Initializes a new instance of the KeywordAnalyzer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap (inherited from Analyzer) | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
GetType (inherited from Object) | Gets the Type of the current instance.
ReusableTokenStream |
TokenStream |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

KeywordAnalyzer Class | Lucene.Net.Analysis Namespace


KeywordAnalyzer Constructor

Initializes a new instance of the KeywordAnalyzer class.

public KeywordAnalyzer();

See Also

KeywordAnalyzer Class | Lucene.Net.Analysis Namespace


KeywordAnalyzer Methods

The methods of the KeywordAnalyzer class are listed below. For a complete list of KeywordAnalyzer class members, see the KeywordAnalyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap (inherited from Analyzer) | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
GetType (inherited from Object) | Gets the Type of the current instance.
ReusableTokenStream |
TokenStream |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

KeywordAnalyzer Class | Lucene.Net.Analysis Namespace


KeywordAnalyzer.ReusableTokenStream Method

public override TokenStream ReusableTokenStream(
string fieldName,
TextReader reader
);

See Also

KeywordAnalyzer Class | Lucene.Net.Analysis Namespace


KeywordAnalyzer.TokenStream Method

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

KeywordAnalyzer Class | Lucene.Net.Analysis Namespace


KeywordTokenizer Class

Emits the entire input as a single token.

For a list of all members of this type, see KeywordTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.KeywordTokenizer

public class KeywordTokenizer : Tokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

KeywordTokenizer Members | Lucene.Net.Analysis Namespace


KeywordTokenizer Members

KeywordTokenizer overview

Public Instance Constructors

KeywordTokenizer Overloaded. Initializes a new instance of the KeywordTokenizer class.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Overloaded.
Reset (inherited from TokenStream) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

See Also

KeywordTokenizer Class | Lucene.Net.Analysis Namespace


KeywordTokenizer Constructor

Overload List

public KeywordTokenizer(TextReader);

public KeywordTokenizer(TextReader,int);

See Also

KeywordTokenizer Class | Lucene.Net.Analysis Namespace


KeywordTokenizer Constructor (TextReader)

public KeywordTokenizer(
TextReader input
);

See Also

KeywordTokenizer Class | Lucene.Net.Analysis Namespace | KeywordTokenizer Constructor Overload List


KeywordTokenizer Constructor (TextReader, Int32)

public KeywordTokenizer(
TextReader input,
int bufferSize
);

See Also

KeywordTokenizer Class | Lucene.Net.Analysis Namespace | KeywordTokenizer Constructor Overload List


KeywordTokenizer Methods

The methods of the KeywordTokenizer class are listed below. For a complete list of KeywordTokenizer class members, see the KeywordTokenizer Members topic.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Overloaded.
Reset (inherited from TokenStream) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

KeywordTokenizer Class | Lucene.Net.Analysis Namespace


Next Method

Apache Lucene.Net 2.4.0 Class Library API

KeywordTokenizer.Next Method

Overload List

Inherited from TokenStream.

public virtual Token Next();

public override Token Next(Token);

See Also

KeywordTokenizer Class | Lucene.Net.Analysis Namespace


KeywordTokenizer.Next Method (Token)

public override Token Next(
Token reusableToken
);

See Also

KeywordTokenizer Class | Lucene.Net.Analysis Namespace | KeywordTokenizer.Next Overload List


Reset Method

Apache Lucene.Net 2.4.0 Class Library API

KeywordTokenizer.Reset Method

Overload List

Inherited from TokenStream.

public virtual void Reset();

public override void Reset(TextReader);

See Also

KeywordTokenizer Class | Lucene.Net.Analysis Namespace


KeywordTokenizer.Reset Method (TextReader)

public override void Reset(
TextReader input
);

See Also

KeywordTokenizer Class | Lucene.Net.Analysis Namespace | KeywordTokenizer.Reset Overload List


LengthFilter Class

Removes words that are too long and too short from the stream.

For a list of all members of this type, see LengthFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.LengthFilter

public sealed class LengthFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LengthFilter Members | Lucene.Net.Analysis Namespace


LengthFilter Members

LengthFilter overview

Public Instance Constructors

LengthFilter Constructor Build a filter that removes words that are too long or too short from the text.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded. Returns the next input Token whose term() is the right len
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

LengthFilter Class | Lucene.Net.Analysis Namespace


LengthFilter Constructor

Build a filter that removes words that are too long or too short from the text.

public LengthFilter(
TokenStream in_Renamed,
int min,
int max
);

See Also

LengthFilter Class | Lucene.Net.Analysis Namespace


LengthFilter Methods

The methods of the LengthFilter class are listed below. For a complete list of LengthFilter class members, see the LengthFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded. Returns the next input Token whose term() is the right len
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LengthFilter Class | Lucene.Net.Analysis Namespace


Next Method

Apache Lucene.Net 2.4.0 Class Library API

LengthFilter.Next Method

Returns the next input Token whose term() is the right len

Overload List

Inherited from TokenStream.

public virtual Token Next();

Returns the next input Token whose term() is the right len

public override Token Next(Token);

See Also

LengthFilter Class | Lucene.Net.Analysis Namespace


LengthFilter.Next Method (Token)

Returns the next input Token whose term() is the right len

public override Token Next(
Token reusableToken
);

See Also

LengthFilter Class | Lucene.Net.Analysis Namespace | LengthFilter.Next Overload List


LetterTokenizer Class

A LetterTokenizer is a tokenizer that divides text at non-letters. That's to say, it defines tokens as maximal strings of adjacent letters, as defined by java.lang.Character.isLetter() predicate. Note: this does a decent job for most European languages, but does a terrible job for some Asian languages, where words are not separated by spaces.

For a list of all members of this type, see LetterTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.LetterTokenizer
Lucene.Net.Analysis.LowerCaseTokenizer

public class LetterTokenizer : CharTokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LetterTokenizer Members | Lucene.Net.Analysis Namespace


LetterTokenizer Members

LetterTokenizer overview

Public Instance Constructors

LetterTokenizer Constructor Construct a new LetterTokenizer.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from CharTokenizer) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
Reset (inherited from TokenStream) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

Protected Internal Instance Methods

IsTokenChar | Collects only characters which satisfy {@link Character#isLetter(char)}.
Normalize (inherited from CharTokenizer) | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

LetterTokenizer Class | Lucene.Net.Analysis Namespace


LetterTokenizer Constructor

Construct a new LetterTokenizer.

public LetterTokenizer(
TextReader in_Renamed
);

See Also

LetterTokenizer Class | Lucene.Net.Analysis Namespace


LetterTokenizer Methods

The methods of the LetterTokenizer class are listed below. For a complete list of LetterTokenizer class members, see the LetterTokenizer Members topic.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from CharTokenizer) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
Reset (inherited from TokenStream) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

IsTokenChar | Collects only characters which satisfy {@link Character#isLetter(char)}.
Normalize (inherited from CharTokenizer) | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

LetterTokenizer Class | Lucene.Net.Analysis Namespace


LetterTokenizer.IsTokenChar Method

Collects only characters which satisfy {@link Character#isLetter(char)}.

protected internal override bool IsTokenChar(
char c
);

See Also

LetterTokenizer Class | Lucene.Net.Analysis Namespace


LowerCaseFilter Class

Normalizes token text to lower case.

For a list of all members of this type, see LowerCaseFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.LowerCaseFilter

public sealed class LowerCaseFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LowerCaseFilter Members | Lucene.Net.Analysis Namespace


LowerCaseFilter Members

LowerCaseFilter overview

Public Instance Constructors

LowerCaseFilter Constructor

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

LowerCaseFilter Class | Lucene.Net.Analysis Namespace


LowerCaseFilter Constructor

public LowerCaseFilter(
TokenStream in_Renamed
);

See Also

LowerCaseFilter Class | Lucene.Net.Analysis Namespace


LowerCaseFilter Methods

The methods of the LowerCaseFilter class are listed below. For a complete list of LowerCaseFilter class members, see the LowerCaseFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LowerCaseFilter Class | Lucene.Net.Analysis Namespace


Next Method

Apache Lucene.Net 2.4.0 Class Library API

LowerCaseFilter.Next Method

Overload List

Inherited from TokenStream.

public virtual Token Next();

public override Token Next(Token);

See Also

LowerCaseFilter Class | Lucene.Net.Analysis Namespace


LowerCaseFilter.Next Method (Token)

public override Token Next(
Token reusableToken
);

See Also

LowerCaseFilter Class | Lucene.Net.Analysis Namespace | LowerCaseFilter.Next Overload List


LowerCaseTokenizer Class

For a list of all members of this type, see LowerCaseTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.LetterTokenizer
Lucene.Net.Analysis.LowerCaseTokenizer

public sealed class LowerCaseTokenizer : LetterTokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LowerCaseTokenizer Members | Lucene.Net.Analysis Namespace


LowerCaseTokenizer Members

LowerCaseTokenizer overview

Public Instance Constructors

LowerCaseTokenizer Constructor Construct a new LowerCaseTokenizer.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from CharTokenizer) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
Reset (inherited from TokenStream) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

Protected Internal Instance Methods

IsTokenChar (inherited from LetterTokenizer) | Collects only characters which satisfy {@link Character#isLetter(char)}.
Normalize | Collects only characters which satisfy {@link Character#isLetter(char)}.

See Also

LowerCaseTokenizer Class | Lucene.Net.Analysis Namespace


LowerCaseTokenizer Constructor

Construct a new LowerCaseTokenizer.

public LowerCaseTokenizer(
TextReader in_Renamed
);

See Also

LowerCaseTokenizer Class | Lucene.Net.Analysis Namespace


LowerCaseTokenizer Methods

The methods of the LowerCaseTokenizer class are listed below. For a complete list of LowerCaseTokenizer class members, see the LowerCaseTokenizer Members topic.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from CharTokenizer) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
Reset (inherited from TokenStream) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

IsTokenChar (inherited from LetterTokenizer) | Collects only characters which satisfy {@link Character#isLetter(char)}.
Normalize | Collects only characters which satisfy {@link Character#isLetter(char)}.

See Also

LowerCaseTokenizer Class | Lucene.Net.Analysis Namespace


LowerCaseTokenizer.Normalize Method

Collects only characters which satisfy {@link Character#isLetter(char)}.

protected internal override char Normalize(
char c
);

See Also

LowerCaseTokenizer Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Class

For a list of all members of this type, see PerFieldAnalyzerWrapper Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.PerFieldAnalyzerWrapper

public class PerFieldAnalyzerWrapper : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PerFieldAnalyzerWrapper Members | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Members

PerFieldAnalyzerWrapper overview

Public Instance Constructors

PerFieldAnalyzerWrapper Constructor Constructs with default analyzer.

Public Instance Methods

AddAnalyzer | Defines an analyzer to use for the specified field.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap | Return the positionIncrementGap from the analyzer assigned to fieldName
GetType (inherited from Object) | Gets the Type of the current instance.
ReusableTokenStream |
TokenStream |
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Constructor

Constructs with default analyzer.

public PerFieldAnalyzerWrapper(
Analyzer defaultAnalyzer
);

Parameters

defaultAnalyzer
Any fields not specifically defined to use a different analyzer will use the one provided here.

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Methods

The methods of the PerFieldAnalyzerWrapper class are listed below. For a complete list of PerFieldAnalyzerWrapper class members, see the PerFieldAnalyzerWrapper Members topic.

Public Instance Methods

AddAnalyzer | Defines an analyzer to use for the specified field.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap | Return the positionIncrementGap from the analyzer assigned to fieldName
GetType (inherited from Object) | Gets the Type of the current instance.
ReusableTokenStream |
TokenStream |
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper.AddAnalyzer Method

Defines an analyzer to use for the specified field.

public virtual void AddAnalyzer(
string fieldName,
Analyzer analyzer
);

Parameters

fieldName
field name requiring a non-default analyzer
analyzer
non-default analyzer to use for field

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper.GetPositionIncrementGap Method

Return the positionIncrementGap from the analyzer assigned to fieldName

public override int GetPositionIncrementGap(
string fieldName
);

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper.ReusableTokenStream Method

public override TokenStream ReusableTokenStream(
string fieldName,
TextReader reader
);

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper.TokenStream Method

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper.ToString Method

public override string ToString();

See Also

PerFieldAnalyzerWrapper Class | Lucene.Net.Analysis Namespace


PorterStemFilter Class

For a list of all members of this type, see PorterStemFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.PorterStemFilter

public sealed class PorterStemFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PorterStemFilter Members | Lucene.Net.Analysis Namespace


PorterStemFilter Members

PorterStemFilter overview

Public Instance Constructors

PorterStemFilter Constructor

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

PorterStemFilter Class | Lucene.Net.Analysis Namespace


PorterStemFilter Constructor

public PorterStemFilter(
TokenStream in_Renamed
);

See Also

PorterStemFilter Class | Lucene.Net.Analysis Namespace


PorterStemFilter Methods

The methods of the PorterStemFilter class are listed below. For a complete list of PorterStemFilter class members, see the PorterStemFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PorterStemFilter Class | Lucene.Net.Analysis Namespace


Next Method

Apache Lucene.Net 2.4.0 Class Library API

PorterStemFilter.Next Method

Overload List

Inherited from TokenStream.

public virtual Token Next();

public override Token Next(Token);

See Also

PorterStemFilter Class | Lucene.Net.Analysis Namespace


PorterStemFilter.Next Method (Token)

public override Token Next(
Token reusableToken
);

See Also

PorterStemFilter Class | Lucene.Net.Analysis Namespace | PorterStemFilter.Next Overload List


SimpleAnalyzer Class

An Analyzer that filters LetterTokenizer with LowerCaseFilter.

For a list of all members of this type, see SimpleAnalyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.SimpleAnalyzer

public sealed class SimpleAnalyzer : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SimpleAnalyzer Members | Lucene.Net.Analysis Namespace


SimpleAnalyzer Members

SimpleAnalyzer overview

Public Instance Constructors

SimpleAnalyzer Constructor Initializes a new instance of the SimpleAnalyzer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap (inherited from Analyzer) | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
GetType (inherited from Object) | Gets the Type of the current instance.
ReusableTokenStream |
TokenStream |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

SimpleAnalyzer Class | Lucene.Net.Analysis Namespace


SimpleAnalyzer Constructor

Initializes a new instance of the SimpleAnalyzer class.

public SimpleAnalyzer();

See Also

SimpleAnalyzer Class | Lucene.Net.Analysis Namespace


SimpleAnalyzer Methods

The methods of the SimpleAnalyzer class are listed below. For a complete list of SimpleAnalyzer class members, see the SimpleAnalyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap (inherited from Analyzer) | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
GetType (inherited from Object) | Gets the Type of the current instance.
ReusableTokenStream |
TokenStream |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

SimpleAnalyzer Class | Lucene.Net.Analysis Namespace


SimpleAnalyzer.ReusableTokenStream Method

public override TokenStream ReusableTokenStream(
string fieldName,
TextReader reader
);

See Also

SimpleAnalyzer Class | Lucene.Net.Analysis Namespace


SimpleAnalyzer.TokenStream Method

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

SimpleAnalyzer Class | Lucene.Net.Analysis Namespace


SinkTokenizer Class

A SinkTokenizer can be used to cache Tokens for use in an Analyzer

For a list of all members of this type, see SinkTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.SinkTokenizer

public class SinkTokenizer : Tokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SinkTokenizer Members | Lucene.Net.Analysis Namespace |


SinkTokenizer Members

SinkTokenizer overview

Public Instance Constructors

SinkTokenizer Overloaded. Initializes a new instance of the SinkTokenizer class.

Public Instance Methods

Add | Override this method to cache only certain tokens, or new tokens based on the old tokens.
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTokens | Get the tokens in the internal List. WARNING: Adding tokens to this list requires the {@link #Reset()} method to be called in order for them to be made available. Also, this Tokenizer does nothing to protect against {@link java.util.ConcurrentModificationException}s in the case of adds happening while {@link #Next(Lucene.Net.Analysis.Token)} is being called. WARNING: Since this SinkTokenizer can be reset and the cached tokens made available again, do not modify them. Modify clones instead.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded. Returns the next token out of the list of cached tokens
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Overloaded. Reset the internal data structures to the start at the front of the list of tokens. Should be called if tokens were added to the list after an invocation of {@link #Next(Token)}
Reset (inherited from Tokenizer) | Overloaded. Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) | The text source for this Tokenizer.
iter |
lst |

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace |


SinkTokenizer Constructor

Overload List

Initializes a new instance of the SinkTokenizer class.

public SinkTokenizer();

public SinkTokenizer(IList);

public SinkTokenizer(int);

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace


SinkTokenizer Constructor (IList)

public SinkTokenizer(
IList input
);

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace | SinkTokenizer Constructor Overload List


SinkTokenizer Constructor ()

Initializes a new instance of the SinkTokenizer class.

public SinkTokenizer();

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace | SinkTokenizer Constructor Overload List


SinkTokenizer Constructor (Int32)

public SinkTokenizer(
int initCap
);

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace | SinkTokenizer Constructor Overload List


SinkTokenizer Fields

The fields of the SinkTokenizer class are listed below. For a complete list of SinkTokenizer class members, see the SinkTokenizer Members topic.

Protected Internal Instance Fields

input (inherited from Tokenizer) | The text source for this Tokenizer.
iter |
lst |

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace |


SinkTokenizer.iter Field

protected internal IEnumerator iter;

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace


SinkTokenizer.lst Field

protected internal IList lst;

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace


SinkTokenizer Methods

The methods of the SinkTokenizer class are listed below. For a complete list of SinkTokenizer class members, see the SinkTokenizer Members topic.

Public Instance Methods

Add | Override this method to cache only certain tokens, or new tokens based on the old tokens.
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTokens | Get the tokens in the internal List. WARNING: Adding tokens to this list requires the {@link #Reset()} method to be called in order for them to be made available. Also, this Tokenizer does nothing to protect against {@link java.util.ConcurrentModificationException}s in the case of adds happening while {@link #Next(Lucene.Net.Analysis.Token)} is being called. WARNING: Since this SinkTokenizer can be reset and the cached tokens made available again, do not modify them. Modify clones instead.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded. Returns the next token out of the list of cached tokens
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Overloaded. Reset the internal data structures to the start at the front of the list of tokens. Should be called if tokens were added to the list after an invocation of {@link #Next(Token)}
Reset (inherited from Tokenizer) | Overloaded. Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace |


SinkTokenizer.Add Method

Override this method to cache only certain tokens, or new tokens based on the old tokens.

public virtual void Add(
Token t
);

Parameters

t
The {@link Lucene.Net.Analysis.Token} to add to the sink

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace


SinkTokenizer.Close Method

public override void Close();

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace


SinkTokenizer.GetTokens Method

Get the tokens in the internal List.

WARNING: Adding tokens to this list requires the {@link #Reset()} method to be called in order for them to be made available. Also, this Tokenizer does nothing to protect against {@link java.util.ConcurrentModificationException}s in the case of adds happening while {@link #Next(Lucene.Net.Analysis.Token)} is being called.

WARNING: Since this SinkTokenizer can be reset and the cached tokens made available again, do not modify them. Modify clones instead.
public virtual IList GetTokens();

Return Value

A List of {@link Lucene.Net.Analysis.Token}s

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace


Next Method

Apache Lucene.Net 2.4.0 Class Library API

SinkTokenizer.Next Method

Returns the next token out of the list of cached tokens

Overload List

Inherited from TokenStream.

public virtual Token Next();

Returns the next token out of the list of cached tokens

public override Token Next(Token);

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace


SinkTokenizer.Next Method (Token)

Returns the next token out of the list of cached tokens

public override Token Next(
Token reusableToken
);

Return Value

The next {@link Lucene.Net.Analysis.Token} in the Sink.

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace | SinkTokenizer.Next Overload List


Reset Method

Apache Lucene.Net 2.4.0 Class Library API

SinkTokenizer.Reset Method

Reset the internal data structures to the start at the front of the list of tokens. Should be called if tokens were added to the list after an invocation of {@link #Next(Token)}

Overload List

Reset the internal data structures to the start at the front of the list of tokens. Should be called if tokens were added to the list after an invocation of {@link #Next(Token)}

public override void Reset();

Inherited from Tokenizer.

public virtual void Reset(TextReader);

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace


SinkTokenizer.Reset Method ()

Reset the internal data structures to the start at the front of the list of tokens. Should be called if tokens were added to the list after an invocation of {@link #Next(Token)}

public override void Reset();

See Also

SinkTokenizer Class | Lucene.Net.Analysis Namespace | SinkTokenizer.Reset Overload List


StopAnalyzer Class

Filters LetterTokenizer with LowerCaseFilter and StopFilter.

For a list of all members of this type, see StopAnalyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.StopAnalyzer

public sealed class StopAnalyzer : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StopAnalyzer Members | Lucene.Net.Analysis Namespace


StopAnalyzer Members

StopAnalyzer overview

Public Static Fields

ENGLISH_STOP_WORDS An array containing some common English words that are not usually useful for searching.

Public Instance Constructors

StopAnalyzer Overloaded. Initializes a new instance of the StopAnalyzer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap (inherited from Analyzer) | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
GetType (inherited from Object) | Gets the Type of the current instance.
ReusableTokenStream |
TokenStream | Filters LowerCaseTokenizer with StopFilter.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


StopAnalyzer Constructor

Builds an analyzer which removes words in ENGLISH_STOP_WORDS.

Overload List

Builds an analyzer which removes words in ENGLISH_STOP_WORDS.

public StopAnalyzer();

Builds an analyzer with the stop words from the given set.

public StopAnalyzer(Hashtable);

Builds an analyzer with the stop words from the given file.

public StopAnalyzer(FileInfo);

Builds an analyzer with the stop words from the given reader.

public StopAnalyzer(TextReader);

Builds an analyzer which removes words in the provided array.

public StopAnalyzer(string[]);

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


StopAnalyzer Constructor ()

Builds an analyzer which removes words in ENGLISH_STOP_WORDS.

public StopAnalyzer();

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace | StopAnalyzer Constructor Overload List


StopAnalyzer Constructor (Hashtable)

Builds an analyzer with the stop words from the given set.

public StopAnalyzer(
Hashtable stopWords
);

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace | StopAnalyzer Constructor Overload List


StopAnalyzer Constructor (String[])

Builds an analyzer which removes words in the provided array.

public StopAnalyzer(
string[] stopWords
);

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace | StopAnalyzer Constructor Overload List


StopAnalyzer Constructor (FileInfo)

Builds an analyzer with the stop words from the given file.

public StopAnalyzer(
FileInfo stopwordsFile
);

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace | StopAnalyzer Constructor Overload List | GetWordSet


StopAnalyzer Constructor (TextReader)

Builds an analyzer with the stop words from the given reader.

public StopAnalyzer(
TextReader stopwords
);

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace | StopAnalyzer Constructor Overload List | GetWordSet


StopAnalyzer Fields

The fields of the StopAnalyzer class are listed below. For a complete list of StopAnalyzer class members, see the StopAnalyzer Members topic.

Public Static Fields

ENGLISH_STOP_WORDS An array containing some common English words that are not usually useful for searching.

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


StopAnalyzer.ENGLISH_STOP_WORDS Field

An array containing some common English words that are not usually useful for searching.

public static readonly string[] ENGLISH_STOP_WORDS;

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


StopAnalyzer Methods

The methods of the StopAnalyzer class are listed below. For a complete list of StopAnalyzer class members, see the StopAnalyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap (inherited from Analyzer) | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
GetType (inherited from Object) | Gets the Type of the current instance.
ReusableTokenStream |
TokenStream | Filters LowerCaseTokenizer with StopFilter.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


StopAnalyzer.ReusableTokenStream Method

public override TokenStream ReusableTokenStream(
string fieldName,
TextReader reader
);

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


StopAnalyzer.TokenStream Method

Filters LowerCaseTokenizer with StopFilter.

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

StopAnalyzer Class | Lucene.Net.Analysis Namespace


StopFilter Class

Removes stop words from a token stream.

For a list of all members of this type, see StopFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.StopFilter

public sealed class StopFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StopFilter Members | Lucene.Net.Analysis Namespace


StopFilter Members

StopFilter overview

Public Static Methods

GetEnablePositionIncrementsDefault |
MakeStopSet | Overloaded. Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
SetEnablePositionIncrementsDefault |

Public Instance Constructors

StopFilter Overloaded. Initializes a new instance of the StopFilter class.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnablePositionIncrements |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded. Returns the next input Token whose term() is not a stop word.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
SetEnablePositionIncrements |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

StopFilter Class | Lucene.Net.Analysis Namespace


StopFilter Constructor

Construct a token stream filtering the given input.

Overload List

Constructs a filter which removes words from the input TokenStream that are named in the Set.

public StopFilter(TokenStream,Hashtable);

Construct a token stream filtering the given input. If

stopWords
is an instance of {@link CharArraySet} (true if
makeStopSet()
was used to construct the set) it will be directly used and
ignoreCase
will be ignored since
CharArraySet
directly controls case sensitivity. If
stopWords
is not an instance of {@link CharArraySet}, a new CharArraySet will be constructed and
ignoreCase
will be used to specify the case sensitivity of that set.

public StopFilter(TokenStream,Hashtable,bool);

Construct a token stream filtering the given input.

public StopFilter(TokenStream,string[]);

Constructs a filter which removes words from the input TokenStream that are named in the array of words.

public StopFilter(TokenStream,string[],bool);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace


StopFilter Constructor (TokenStream, String[])

Construct a token stream filtering the given input.

public StopFilter(
TokenStream input,
string[] stopWords
);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace | StopFilter Constructor Overload List


StopFilter Constructor (TokenStream, String[], Boolean)

Constructs a filter which removes words from the input TokenStream that are named in the array of words.

public StopFilter(
TokenStream in_Renamed,
string[] stopWords,
bool ignoreCase
);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace | StopFilter Constructor Overload List


StopFilter Constructor (TokenStream, Hashtable, Boolean)

Construct a token stream filtering the given input. If
stopWords
is an instance of {@link CharArraySet} (true if
makeStopSet()
was used to construct the set) it will be directly used and
ignoreCase
will be ignored since
CharArraySet
directly controls case sensitivity.

If
stopWords
is not an instance of {@link CharArraySet}, a new CharArraySet will be constructed and
ignoreCase
will be used to specify the case sensitivity of that set.
public StopFilter(
TokenStream input,
Hashtable stopWords,
bool ignoreCase
);

Parameters

input
stopWords
The set of Stop Words.
ignoreCase
-Ignore case when stopping.

See Also

StopFilter Class | Lucene.Net.Analysis Namespace | StopFilter Constructor Overload List


StopFilter Constructor (TokenStream, Hashtable)

Constructs a filter which removes words from the input TokenStream that are named in the Set.

public StopFilter(
TokenStream in_Renamed,
Hashtable stopWords
);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace | StopFilter Constructor Overload List | MakeStopSet


StopFilter Methods

The methods of the StopFilter class are listed below. For a complete list of StopFilter class members, see the StopFilter Members topic.

Public Static Methods

GetEnablePositionIncrementsDefault |
MakeStopSet | Overloaded. Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
SetEnablePositionIncrementsDefault |

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnablePositionIncrements |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded. Returns the next input Token whose term() is not a stop word.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
SetEnablePositionIncrements |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StopFilter Class | Lucene.Net.Analysis Namespace


StopFilter.GetEnablePositionIncrements Method

public bool GetEnablePositionIncrements();

See Also

StopFilter Class | Lucene.Net.Analysis Namespace | setEnablePositionIncrements


StopFilter.GetEnablePositionIncrementsDefault Method

public static bool GetEnablePositionIncrementsDefault();

See Also

StopFilter Class | Lucene.Net.Analysis Namespace | setEnablePositionIncrementsDefault


MakeStopSet Method

Apache Lucene.Net 2.4.0 Class Library API

StopFilter.MakeStopSet Method

Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.

Overload List

Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.

public static Hashtable MakeStopSet(string[]);

public static Hashtable MakeStopSet(string[],bool);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace | MakeStopSet


StopFilter.MakeStopSet Method (String[])

Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.

public static Hashtable MakeStopSet(
string[] stopWords
);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace | StopFilter.MakeStopSet Overload List | MakeStopSet


StopFilter.MakeStopSet Method (String[], Boolean)

public static Hashtable MakeStopSet(
string[] stopWords,
bool ignoreCase
);

Parameters

stopWords
ignoreCase
If true, all words are lower cased first.

Return Value

a Set containing the words

See Also

StopFilter Class | Lucene.Net.Analysis Namespace | StopFilter.MakeStopSet Overload List


Next Method

Apache Lucene.Net 2.4.0 Class Library API

StopFilter.Next Method

Returns the next input Token whose term() is not a stop word.

Overload List

Inherited from TokenStream.

public virtual Token Next();

Returns the next input Token whose term() is not a stop word.

public override Token Next(Token);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace


StopFilter.Next Method (Token)

Returns the next input Token whose term() is not a stop word.

public override Token Next(
Token reusableToken
);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace | StopFilter.Next Overload List


StopFilter.SetEnablePositionIncrements Method

public void SetEnablePositionIncrements(
bool enable
);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace


StopFilter.SetEnablePositionIncrementsDefault Method

public static void SetEnablePositionIncrementsDefault(
bool defaultValue
);

See Also

StopFilter Class | Lucene.Net.Analysis Namespace


TeeTokenFilter Class

Works in conjunction with the SinkTokenizer to provide the ability to set aside tokens that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.
 SinkTokenizer sink1 = new SinkTokenizer(null); SinkTokenizer sink2 = new SinkTokenizer(null); TokenStream source1 = new TeeTokenFilter(new TeeTokenFilter(new WhitespaceTokenizer(reader1), sink1), sink2); TokenStream source2 = new TeeTokenFilter(new TeeTokenFilter(new WhitespaceTokenizer(reader2), sink1), sink2); TokenStream final1 = new LowerCaseFilter(source1); TokenStream final2 = source2; TokenStream final3 = new EntityDetect(sink1); TokenStream final4 = new URLDetect(sink2); d.add(new Field("f1", final1)); d.add(new Field("f2", final2)); d.add(new Field("f3", final3)); d.add(new Field("f4", final4));
In this example, sink1 and sink2 will both get tokens from both reader1 and reader2 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene

See http://issues.apache.org/jira/browse/LUCENE-1058

For a list of all members of this type, see TeeTokenFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.TeeTokenFilter

public class TeeTokenFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TeeTokenFilter Members | Lucene.Net.Analysis Namespace |


TeeTokenFilter Members

TeeTokenFilter overview

Public Instance Constructors

TeeTokenFilter Constructor

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

TeeTokenFilter Class | Lucene.Net.Analysis Namespace |


TeeTokenFilter Constructor

public TeeTokenFilter(
TokenStream input,
SinkTokenizer sink
);

See Also

TeeTokenFilter Class | Lucene.Net.Analysis Namespace


TeeTokenFilter Methods

The methods of the TeeTokenFilter class are listed below. For a complete list of TeeTokenFilter class members, see the TeeTokenFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TeeTokenFilter Class | Lucene.Net.Analysis Namespace |


Next Method

Apache Lucene.Net 2.4.0 Class Library API

TeeTokenFilter.Next Method

Overload List

Inherited from TokenStream.

public virtual Token Next();

public override Token Next(Token);

See Also

TeeTokenFilter Class | Lucene.Net.Analysis Namespace


TeeTokenFilter.Next Method (Token)

public override Token Next(
Token reusableToken
);

See Also

TeeTokenFilter Class | Lucene.Net.Analysis Namespace | TeeTokenFilter.Next Overload List


Token Class

For a list of all members of this type, see Token Members.

System.Object
Lucene.Net.Analysis.Token

public class Token : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Token Members | Lucene.Net.Analysis Namespace


Token Members

Token overview

Public Static Fields

DEFAULT_TYPE

Public Instance Constructors

Token Overloaded. Initializes a new instance of the Token class.

Public Instance Methods

Clear | Resets the term text, payload, and positionIncrement to default. Other fields such as startOffset, endOffset and the token type are not reset since they are normally overwritten by the tokenizer.
Clone | Overloaded.
EndOffset | Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Equals |
GetFlags | EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long. Get the bitset for any bits that have been set. This is completely distinct from {@link #type()}, although they do share similar purposes. The flags can be used to encode information about the token for use by other {@link org.apache.lucene.analysis.TokenFilter}s.
GetHashCode |
GetPayload | Returns this Token's payload.
GetPositionIncrement | Returns the position increment of this Token.
GetType (inherited from Object) | Gets the Type of the current instance.
Reinit | Overloaded.
ResizeTermBuffer | Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use {@link #setTermBuffer(char[], int, int)}, {@link #setTermBuffer(String)}, or {@link #setTermBuffer(String, int, int)}, to optimally combine the resize with the setting of the termBuffer.
SetEndOffset | Set the ending offset.
SetFlags |
SetPayload | Sets this Token's payload.
SetPositionIncrement |
SetStartOffset | Set the starting offset.
SetTermBuffer | Overloaded. Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
SetTermLength | Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array use {@link #resizeTermBuffer(int)} first.
SetTermText | Sets the Token's term text. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
SetType | Set the lexical type.
StartOffset | Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.
Term | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #termBuffer()} and {@link #termLength()} directly instead. If you really need a string, use this method which is nothing more than a convenience cal to new String(token.TermBuffer(), o, token.TermLength()).
TermBuffer | Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use {@link #ResizeTermBuffer(int)} to increase it. After altering the buffer be sure to call {@link #setTermLength} to record the number of valid characters that were placed into the termBuffer.
TermLength | Return number of valid characters (length of the term) in the termBuffer array.
TermText | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #termBuffer()} and {@link #termLength()} directly instead. If you really need a string, use {@link #Term()}.
ToString |
Type | Returns this Token's lexical type. Defaults to "word".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Token Class | Lucene.Net.Analysis Namespace


Token Constructor

Constructs a Token will null text.

Overload List

Constructs a Token will null text.

public Token();

Constructs a Token with the given term buffer (offset and length), start and end offsets.

public Token(char[],int,int,int,int);

public Token(int,int);

public Token(int,int,int);

public Token(int,int,string);

Constructs a Token with the given term text, and start and end offsets. The type defaults to "word." NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

public Token(string,int,int);

Constructs a Token with the given term text, start and end offsets, and flags. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

public Token(string,int,int,int);

Constructs a Token with the given term text, start and end offsets, and type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

public Token(string,int,int,string);

See Also

Token Class | Lucene.Net.Analysis Namespace


Token Constructor ()

Constructs a Token will null text.

public Token();

See Also

Token Class | Lucene.Net.Analysis Namespace | Token Constructor Overload List


Token Constructor (Int32, Int32)

public Token(
int start,
int end
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token Constructor Overload List


Token Constructor (Int32, Int32, String)

public Token(
int start,
int end,
string typ
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token Constructor Overload List


Token Constructor (Int32, Int32, Int32)

public Token(
int start,
int end,
int flags
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token Constructor Overload List


Token Constructor (String, Int32, Int32)

Constructs a Token with the given term text, and start and end offsets. The type defaults to "word." NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

public Token(
string text,
int start,
int end
);

Parameters

text
term text
start
start offset
end
end offset

See Also

Token Class | Lucene.Net.Analysis Namespace | Token Constructor Overload List


Token Constructor (String, Int32, Int32, String)

Constructs a Token with the given term text, start and end offsets, and type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

public Token(
string text,
int start,
int end,
string typ
);

Parameters

text
term text
start
start offset
end
end offset
typ
token type

See Also

Token Class | Lucene.Net.Analysis Namespace | Token Constructor Overload List


Token Constructor (String, Int32, Int32, Int32)

Constructs a Token with the given term text, start and end offsets, and flags. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

public Token(
string text,
int start,
int end,
int flags
);

Parameters

text
term text
start
start offset
end
end offset
flags
the bits to set for this Token

See Also

Token Class | Lucene.Net.Analysis Namespace | Token Constructor Overload List


Token Constructor (Char[], Int32, Int32, Int32, Int32)

Constructs a Token with the given term buffer (offset and length), start and end offsets.

public Token(
char[] startTermBuffer,
int termBufferOffset,
int termBufferLength,
int start,
int end
);

Parameters

startTermBuffer
termBufferOffset
termBufferLength
start
end

See Also

Token Class | Lucene.Net.Analysis Namespace | Token Constructor Overload List


Token Fields

The fields of the Token class are listed below. For a complete list of Token class members, see the Token Members topic.

Public Static Fields

DEFAULT_TYPE

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.DEFAULT_TYPE Field

public const string DEFAULT_TYPE = "word";

See Also

Token Class | Lucene.Net.Analysis Namespace


Token Methods

The methods of the Token class are listed below. For a complete list of Token class members, see the Token Members topic.

Public Instance Methods

Clear | Resets the term text, payload, and positionIncrement to default. Other fields such as startOffset, endOffset and the token type are not reset since they are normally overwritten by the tokenizer.
Clone | Overloaded.
EndOffset | Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Equals |
GetFlags | EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long. Get the bitset for any bits that have been set. This is completely distinct from {@link #type()}, although they do share similar purposes. The flags can be used to encode information about the token for use by other {@link org.apache.lucene.analysis.TokenFilter}s.
GetHashCode |
GetPayload | Returns this Token's payload.
GetPositionIncrement | Returns the position increment of this Token.
GetType (inherited from Object) | Gets the Type of the current instance.
Reinit | Overloaded.
ResizeTermBuffer | Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use {@link #setTermBuffer(char[], int, int)}, {@link #setTermBuffer(String)}, or {@link #setTermBuffer(String, int, int)}, to optimally combine the resize with the setting of the termBuffer.
SetEndOffset | Set the ending offset.
SetFlags |
SetPayload | Sets this Token's payload.
SetPositionIncrement |
SetStartOffset | Set the starting offset.
SetTermBuffer | Overloaded. Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
SetTermLength | Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array use {@link #resizeTermBuffer(int)} first.
SetTermText | Sets the Token's term text. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
SetType | Set the lexical type.
StartOffset | Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.
Term | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #termBuffer()} and {@link #termLength()} directly instead. If you really need a string, use this method which is nothing more than a convenience cal to new String(token.TermBuffer(), o, token.TermLength()).
TermBuffer | Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use {@link #ResizeTermBuffer(int)} to increase it. After altering the buffer be sure to call {@link #setTermLength} to record the number of valid characters that were placed into the termBuffer.
TermLength | Return number of valid characters (length of the term) in the termBuffer array.
TermText | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #termBuffer()} and {@link #termLength()} directly instead. If you really need a string, use {@link #Term()}.
ToString |
Type | Returns this Token's lexical type. Defaults to "word".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.Clear Method

Resets the term text, payload, and positionIncrement to default. Other fields such as startOffset, endOffset and the token type are not reset since they are normally overwritten by the tokenizer.

public virtual void Clear();

See Also

Token Class | Lucene.Net.Analysis Namespace


Clone Method

Apache Lucene.Net 2.4.0 Class Library API

Token.Clone Method

Overload List

public virtual object Clone();

public Token Clone(char[],int,int,int,int);

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.Clone Method ()

public virtual object Clone();

Implements

ICloneable.Clone

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.Clone Overload List


Token.Clone Method (Char[], Int32, Int32, Int32, Int32)

public Token Clone(
char[] newTermBuffer,
int newTermOffset,
int newTermLength,
int newStartOffset,
int newEndOffset
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.Clone Overload List


Token.EndOffset Method

Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).

public int EndOffset();

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.Equals Method

public override bool Equals(
object obj
);

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.GetFlags Method

EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long. Get the bitset for any bits that have been set. This is completely distinct from {@link #type()}, although they do share similar purposes. The flags can be used to encode information about the token for use by other {@link org.apache.lucene.analysis.TokenFilter}s.

public int GetFlags();

Return Value

The bits

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.GetHashCode Method

public override int GetHashCode();

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.GetPayload Method

Returns this Token's payload.

public virtual Payload GetPayload();

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.GetPositionIncrement Method

Returns the position increment of this Token.

public virtual int GetPositionIncrement();

See Also

Token Class | Lucene.Net.Analysis Namespace | setPositionIncrement


Reinit Method

Apache Lucene.Net 2.4.0 Class Library API

Token.Reinit Method

Overload List

public void Reinit(Token);

public void Reinit(Token,char[],int,int);

public void Reinit(Token,string);

public Token Reinit(char[],int,int,int,int);

public Token Reinit(char[],int,int,int,int,string);

public Token Reinit(string,int,int);

public Token Reinit(string,int,int,int,int);

public Token Reinit(string,int,int,int,int,string);

public Token Reinit(string,int,int,string);

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.Reinit Method (Token)

public void Reinit(
Token prototype
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.Reinit Overload List


Token.Reinit Method (Token, Char[], Int32, Int32)

public void Reinit(
Token prototype,
char[] newTermBuffer,
int offset,
int length
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.Reinit Overload List


Token.Reinit Method (Token, String)

public void Reinit(
Token prototype,
string newTerm
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.Reinit Overload List


Token.Reinit Method (Char[], Int32, Int32, Int32, Int32)

public Token Reinit(
char[] newTermBuffer,
int newTermOffset,
int newTermLength,
int newStartOffset,
int newEndOffset
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.Reinit Overload List


Token.Reinit Method (Char[], Int32, Int32, Int32, Int32, String)

public Token Reinit(
char[] newTermBuffer,
int newTermOffset,
int newTermLength,
int newStartOffset,
int newEndOffset,
string newType
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.Reinit Overload List


Token.Reinit Method (String, Int32, Int32)

public Token Reinit(
string newTerm,
int newStartOffset,
int newEndOffset
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.Reinit Overload List


Token.Reinit Method (String, Int32, Int32, Int32, Int32)

public Token Reinit(
string newTerm,
int newTermOffset,
int newTermLength,
int newStartOffset,
int newEndOffset
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.Reinit Overload List


Token.Reinit Method (String, Int32, Int32, Int32, Int32, String)

public Token Reinit(
string newTerm,
int newTermOffset,
int newTermLength,
int newStartOffset,
int newEndOffset,
string newType
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.Reinit Overload List


Token.Reinit Method (String, Int32, Int32, String)

public Token Reinit(
string newTerm,
int newStartOffset,
int newEndOffset,
string newType
);

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.Reinit Overload List


Token.ResizeTermBuffer Method

Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use {@link #setTermBuffer(char[], int, int)}, {@link #setTermBuffer(String)}, or {@link #setTermBuffer(String, int, int)}, to optimally combine the resize with the setting of the termBuffer.

public virtual char[] ResizeTermBuffer(
int newSize
);

Parameters

newSize
minimum size of the new termBuffer

Return Value

newly created termBuffer with length >= newSize

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.SetEndOffset Method

Set the ending offset.

public virtual void SetEndOffset(
int offset
);

See Also

Token Class | Lucene.Net.Analysis Namespace |


Token.SetFlags Method

public void SetFlags(
int flags
);

See Also

Token Class | Lucene.Net.Analysis Namespace | GetFlags


Token.SetPayload Method

Sets this Token's payload.

public virtual void SetPayload(
Payload payload
);

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.SetPositionIncrement Method

public virtual void SetPositionIncrement(
int positionIncrement
);

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.SetStartOffset Method

Set the starting offset.

public virtual void SetStartOffset(
int offset
);

See Also

Token Class | Lucene.Net.Analysis Namespace |


SetTermBuffer Method

Apache Lucene.Net 2.4.0 Class Library API

Token.SetTermBuffer Method

Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

Overload List

Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

public void SetTermBuffer(char[],int,int);

Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

public void SetTermBuffer(string);

Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

public void SetTermBuffer(string,int,int);

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.SetTermBuffer Method (Char[], Int32, Int32)

Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

public void SetTermBuffer(
char[] buffer,
int offset,
int length
);

Parameters

buffer
offset
length

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.SetTermBuffer Overload List


Token.SetTermBuffer Method (String)

Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

public void SetTermBuffer(
string buffer
);

Parameters

buffer

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.SetTermBuffer Overload List


Token.SetTermBuffer Method (String, Int32, Int32)

Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

public void SetTermBuffer(
string buffer,
int offset,
int length
);

Parameters

buffer
offset
length

See Also

Token Class | Lucene.Net.Analysis Namespace | Token.SetTermBuffer Overload List


Token.SetTermLength Method

Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array use {@link #resizeTermBuffer(int)} first.

public void SetTermLength(
int length
);

Parameters

length
the truncated length

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.SetTermText Method

Sets the Token's term text. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

public virtual void SetTermText(
string text
);

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.SetType Method

Set the lexical type.

public void SetType(
string type
);

See Also

Token Class | Lucene.Net.Analysis Namespace |


Token.StartOffset Method

Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.

public int StartOffset();

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.Term Method

Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #termBuffer()} and {@link #termLength()} directly instead. If you really need a string, use this method which is nothing more than a convenience cal to new String(token.TermBuffer(), o, token.TermLength()).

public string Term();

Return Value

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.TermBuffer Method

Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use {@link #ResizeTermBuffer(int)} to increase it. After altering the buffer be sure to call {@link #setTermLength} to record the number of valid characters that were placed into the termBuffer.

public char[] TermBuffer();

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.TermLength Method

Return number of valid characters (length of the term) in the termBuffer array.

public int TermLength();

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.TermText Method

Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #termBuffer()} and {@link #termLength()} directly instead. If you really need a string, use {@link #Term()}.

public string TermText();

Return Value

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.ToString Method

public override string ToString();

See Also

Token Class | Lucene.Net.Analysis Namespace


Token.Type Method

Returns this Token's lexical type. Defaults to "word".

public string Type();

See Also

Token Class | Lucene.Net.Analysis Namespace


TokenFilter Class

For a list of all members of this type, see TokenFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Derived types

public abstract class TokenFilter : TokenStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TokenFilter Members | Lucene.Net.Analysis Namespace


TokenFilter Members

TokenFilter overview

Public Instance Methods

Close | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

TokenFilter Constructor Construct a token stream filtering the given input.

Protected Internal Instance Fields

input The source of tokens for this filter.

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


TokenFilter Constructor

Construct a token stream filtering the given input.

protected internal TokenFilter(
TokenStream input
);

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


TokenFilter Fields

The fields of the TokenFilter class are listed below. For a complete list of TokenFilter class members, see the TokenFilter Members topic.

Protected Internal Instance Fields

input The source of tokens for this filter.

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


TokenFilter.input Field

The source of tokens for this filter.

protected internal TokenStream input;

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


TokenFilter Methods

The methods of the TokenFilter class are listed below. For a complete list of TokenFilter class members, see the TokenFilter Members topic.

Public Instance Methods

Close | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


TokenFilter.Close Method

Close the input TokenStream.

public override void Close();

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


TokenFilter.Reset Method

Reset the filter as well as the input TokenStream.

public override void Reset();

See Also

TokenFilter Class | Lucene.Net.Analysis Namespace


Tokenizer Class

For a list of all members of this type, see Tokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.KeywordTokenizer
Lucene.Net.Analysis.SinkTokenizer
Lucene.Net.Analysis.Standard.StandardTokenizer

public abstract class Tokenizer : TokenStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Tokenizer Members | Lucene.Net.Analysis Namespace


Tokenizer Members

Tokenizer overview

Public Instance Methods

Close | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Overloaded. Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
Reset (inherited from TokenStream) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

Tokenizer Overloaded. Initializes a new instance of the Tokenizer class.

Protected Internal Instance Fields

input The text source for this Tokenizer.

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


Tokenizer Constructor

Construct a tokenizer with null input.

Overload List

Construct a tokenizer with null input.

protected internal Tokenizer();

Construct a token stream processing the given input.

protected internal Tokenizer(TextReader);

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


Tokenizer Constructor ()

Construct a tokenizer with null input.

protected internal Tokenizer();

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace | Tokenizer Constructor Overload List


Tokenizer Constructor (TextReader)

Construct a token stream processing the given input.

protected internal Tokenizer(
TextReader input
);

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace | Tokenizer Constructor Overload List


Tokenizer Fields

The fields of the Tokenizer class are listed below. For a complete list of Tokenizer class members, see the Tokenizer Members topic.

Protected Internal Instance Fields

input The text source for this Tokenizer.

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


Tokenizer.input Field

The text source for this Tokenizer.

protected internal TextReader input;

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


Tokenizer Methods

The methods of the Tokenizer class are listed below. For a complete list of Tokenizer class members, see the Tokenizer Members topic.

Public Instance Methods

Close | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Overloaded. Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
Reset (inherited from TokenStream) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


Tokenizer.Close Method

By default, closes the input Reader.

public override void Close();

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


Reset Method

Apache Lucene.Net 2.4.0 Class Library API

Tokenizer.Reset Method

Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.

Overload List

Inherited from TokenStream.

public virtual void Reset();

Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.

public virtual void Reset(TextReader);

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace


Tokenizer.Reset Method (TextReader)

Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.

public virtual void Reset(
TextReader input
);

See Also

Tokenizer Class | Lucene.Net.Analysis Namespace | Tokenizer.Reset Overload List


TokenStream Class

For a list of all members of this type, see TokenStream Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.Tokenizer

public abstract class TokenStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TokenStream Members | Lucene.Net.Analysis Namespace


TokenStream Members

TokenStream overview

Public Instance Methods

Close | Releases resources associated with this stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

TokenStream Constructor Initializes a new instance of the TokenStream class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TokenStream Class | Lucene.Net.Analysis Namespace


TokenStream Constructor

Initializes a new instance of the TokenStream class.

protected TokenStream();

See Also

TokenStream Class | Lucene.Net.Analysis Namespace


TokenStream Methods

The methods of the TokenStream class are listed below. For a complete list of TokenStream class members, see the TokenStream Members topic.

Public Instance Methods

Close | Releases resources associated with this stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TokenStream Class | Lucene.Net.Analysis Namespace


TokenStream.Close Method

Releases resources associated with this stream.

public virtual void Close();

See Also

TokenStream Class | Lucene.Net.Analysis Namespace


Next Method

Apache Lucene.Net 2.4.0 Class Library API

TokenStream.Next Method

Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..

Overload List

Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..

public virtual Token Next();

public virtual Token Next(Token);

See Also

TokenStream Class | Lucene.Net.Analysis Namespace


TokenStream.Next Method ()

Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..

public virtual Token Next();

See Also

TokenStream Class | Lucene.Net.Analysis Namespace | TokenStream.Next Overload List


TokenStream.Next Method (Token)

public virtual Token Next(
Token reusableToken
);

See Also

TokenStream Class | Lucene.Net.Analysis Namespace | TokenStream.Next Overload List


TokenStream.Reset Method

Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).

public virtual void Reset();

See Also

TokenStream Class | Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Class

An Analyzer that uses WhitespaceTokenizer.

For a list of all members of this type, see WhitespaceAnalyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.WhitespaceAnalyzer

public sealed class WhitespaceAnalyzer : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

WhitespaceAnalyzer Members | Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Members

WhitespaceAnalyzer overview

Public Instance Constructors

WhitespaceAnalyzer Constructor Initializes a new instance of the WhitespaceAnalyzer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap (inherited from Analyzer) | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
GetType (inherited from Object) | Gets the Type of the current instance.
ReusableTokenStream |
TokenStream |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

WhitespaceAnalyzer Class | Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Constructor

Initializes a new instance of the WhitespaceAnalyzer class.

public WhitespaceAnalyzer();

See Also

WhitespaceAnalyzer Class | Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Methods

The methods of the WhitespaceAnalyzer class are listed below. For a complete list of WhitespaceAnalyzer class members, see the WhitespaceAnalyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap (inherited from Analyzer) | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
GetType (inherited from Object) | Gets the Type of the current instance.
ReusableTokenStream |
TokenStream |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

WhitespaceAnalyzer Class | Lucene.Net.Analysis Namespace


WhitespaceAnalyzer.ReusableTokenStream Method

public override TokenStream ReusableTokenStream(
string fieldName,
TextReader reader
);

See Also

WhitespaceAnalyzer Class | Lucene.Net.Analysis Namespace


WhitespaceAnalyzer.TokenStream Method

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

WhitespaceAnalyzer Class | Lucene.Net.Analysis Namespace


WhitespaceTokenizer Class

A WhitespaceTokenizer is a tokenizer that divides text at whitespace. Adjacent sequences of non-Whitespace characters form tokens.

For a list of all members of this type, see WhitespaceTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.WhitespaceTokenizer

public class WhitespaceTokenizer : CharTokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

WhitespaceTokenizer Members | Lucene.Net.Analysis Namespace


WhitespaceTokenizer Members

WhitespaceTokenizer overview

Public Instance Constructors

WhitespaceTokenizer Constructor Construct a new WhitespaceTokenizer.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from CharTokenizer) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
Reset (inherited from TokenStream) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

Protected Internal Instance Methods

IsTokenChar | Collects only characters which do not satisfy {@link Character#isWhitespace(char)}.
Normalize (inherited from CharTokenizer) | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

WhitespaceTokenizer Class | Lucene.Net.Analysis Namespace


WhitespaceTokenizer Constructor

Construct a new WhitespaceTokenizer.

public WhitespaceTokenizer(
TextReader in_Renamed
);

See Also

WhitespaceTokenizer Class | Lucene.Net.Analysis Namespace


WhitespaceTokenizer Methods

The methods of the WhitespaceTokenizer class are listed below. For a complete list of WhitespaceTokenizer class members, see the WhitespaceTokenizer Members topic.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from CharTokenizer) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from CharTokenizer) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
Reset (inherited from TokenStream) | Overloaded. Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset() is not needed for the standard indexing process. However, if the Tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement reset(). once, it is necessary to implement reset(). Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after reset()).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

IsTokenChar | Collects only characters which do not satisfy {@link Character#isWhitespace(char)}.
Normalize (inherited from CharTokenizer) | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

See Also

WhitespaceTokenizer Class | Lucene.Net.Analysis Namespace


WhitespaceTokenizer.IsTokenChar Method

Collects only characters which do not satisfy {@link Character#isWhitespace(char)}.

protected internal override bool IsTokenChar(
char c
);

See Also

WhitespaceTokenizer Class | Lucene.Net.Analysis Namespace


WordlistLoader Class

Loader for text files that represent a list of stopwords.

For a list of all members of this type, see WordlistLoader Members.

System.Object
Lucene.Net.Analysis.WordlistLoader

public class WordlistLoader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

WordlistLoader Members | Lucene.Net.Analysis Namespace


WordlistLoader Members

WordlistLoader overview

Public Static Methods

GetStemDict Reads a stem dictionary. Each line contains:
word\tstem
(i.e. two tab seperated words)
GetWordSet Overloaded. Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

Public Instance Constructors

WordlistLoader Constructor Initializes a new instance of the WordlistLoader class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WordlistLoader Class | Lucene.Net.Analysis Namespace


WordlistLoader Constructor

Initializes a new instance of the WordlistLoader class.

public WordlistLoader();

See Also

WordlistLoader Class | Lucene.Net.Analysis Namespace


WordlistLoader Methods

The methods of the WordlistLoader class are listed below. For a complete list of WordlistLoader class members, see the WordlistLoader Members topic.

Public Static Methods

GetStemDict Reads a stem dictionary. Each line contains:
word\tstem
(i.e. two tab seperated words)
GetWordSet Overloaded. Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WordlistLoader Class | Lucene.Net.Analysis Namespace


WordlistLoader.GetStemDict Method

Reads a stem dictionary. Each line contains:

word\tstem
(i.e. two tab seperated words)

public static Hashtable GetStemDict(
FileInfo wordstemfile
);

Return Value

stem dictionary that overrules the stemming algorithm

See Also

WordlistLoader Class | Lucene.Net.Analysis Namespace


GetWordSet Method

Apache Lucene.Net 2.4.0 Class Library API

WordlistLoader.GetWordSet Method

Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

Overload List

Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

public static Hashtable GetWordSet(FileInfo);

Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

public static Hashtable GetWordSet(TextReader);

See Also

WordlistLoader Class | Lucene.Net.Analysis Namespace


WordlistLoader.GetWordSet Method (FileInfo)

Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

public static Hashtable GetWordSet(
FileInfo wordfile
);

Parameters

wordfile
File containing the wordlist

Return Value

A HashSet with the file's words

See Also

WordlistLoader Class | Lucene.Net.Analysis Namespace | WordlistLoader.GetWordSet Overload List


WordlistLoader.GetWordSet Method (TextReader)

Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

public static Hashtable GetWordSet(
TextReader reader
);

Parameters

reader
Reader containing the wordlist

Return Value

A HashSet with the reader's words

See Also

WordlistLoader Class | Lucene.Net.Analysis Namespace | WordlistLoader.GetWordSet Overload List


Lucene.Net.Analysis.Standard

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Analysis.Standard Namespace

Namespace hierarchy

Classes

Class | Description
StandardAnalyzer | Filters {@link StandardTokenizer} with {@link StandardFilter}, {@link LowerCaseFilter} and {@link StopFilter}, using a list of English stop words.
StandardFilter | Normalizes tokens extracted with {@link StandardTokenizer}.
StandardTokenizer |


StandardAnalyzer Class

Filters {@link StandardTokenizer} with {@link StandardFilter}, {@link LowerCaseFilter} and {@link StopFilter}, using a list of English stop words.

For a list of all members of this type, see StandardAnalyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.Standard.StandardAnalyzer

public class StandardAnalyzer : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StandardAnalyzer Members | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Members

StandardAnalyzer overview

Public Static Fields

DEFAULT_MAX_TOKEN_LENGTH | Default maximum allowed token length
STOP_WORDS | An array containing some common English words that are usually not useful for searching.

Public Static Methods

GetDefaultReplaceInvalidAcronym | see https://issues.apache.org/jira/browse/LUCENE-1068
SetDefaultReplaceInvalidAcronym | set to true to have new instances of StandardTokenizer replace mischaracerized acronyms by default. Set to false to preserve the previous (before 2.4) buggy behavior. Alternatively, set the system property Lucene.Net.Analysis.Standard.StandardAnalyzer.replaceInvalidAcronym to false.

Public Instance Constructors

StandardAnalyzer Overloaded. Initializes a new instance of the StandardAnalyzer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxTokenLength |
GetPositionIncrementGap (inherited from Analyzer) | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReplaceInvalidAcronym |
ReusableTokenStream |
SetMaxTokenLength | Set maximum allowed token length. If a token is seen that exceeds this length then it is discarded. This setting only takes effect the next time tokenStream or reusableTokenStream is called.
SetReplaceInvalidAcronym |
TokenStream | Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor

Builds an analyzer with the default stop words ({@link #STOP_WORDS}).

Overload List

Builds an analyzer with the default stop words ({@link #STOP_WORDS}).

public StandardAnalyzer();

public StandardAnalyzer(bool);

Builds an analyzer with the given stop words.

public StandardAnalyzer(Hashtable);

public StandardAnalyzer(Hashtable,bool);

Builds an analyzer with the stop words from the given file.

public StandardAnalyzer(FileInfo);

public StandardAnalyzer(FileInfo,bool);

Builds an analyzer with the stop words from the given reader.

public StandardAnalyzer(TextReader);

public StandardAnalyzer(TextReader,bool);

Builds an analyzer with the given stop words.

public StandardAnalyzer(string[]);

public StandardAnalyzer(string[],bool);

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor ()

Builds an analyzer with the default stop words ({@link #STOP_WORDS}).

public StandardAnalyzer();

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer Constructor Overload List


StandardAnalyzer Constructor (Hashtable)

Builds an analyzer with the given stop words.

public StandardAnalyzer(
Hashtable stopWords
);

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer Constructor Overload List


StandardAnalyzer Constructor (String[])

Builds an analyzer with the given stop words.

public StandardAnalyzer(
string[] stopWords
);

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer Constructor Overload List


StandardAnalyzer Constructor (FileInfo)

Builds an analyzer with the stop words from the given file.

public StandardAnalyzer(
FileInfo stopwords
);

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer Constructor Overload List | GetWordSet


StandardAnalyzer Constructor (TextReader)

Builds an analyzer with the stop words from the given reader.

public StandardAnalyzer(
TextReader stopwords
);

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer Constructor Overload List | GetWordSet


StandardAnalyzer Constructor (Boolean)

public StandardAnalyzer(
bool replaceInvalidAcronym
);

Parameters

replaceInvalidAcronym
Set to true if this analyzer should replace mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer Constructor Overload List


StandardAnalyzer Constructor (TextReader, Boolean)

public StandardAnalyzer(
TextReader stopwords,
bool replaceInvalidAcronym
);

Parameters

stopwords
The stopwords to use
replaceInvalidAcronym
Set to true if this analyzer should replace mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer Constructor Overload List


StandardAnalyzer Constructor (FileInfo, Boolean)

public StandardAnalyzer(
FileInfo stopwords,
bool replaceInvalidAcronym
);

Parameters

stopwords
The stopwords to use
replaceInvalidAcronym
Set to true if this analyzer should replace mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer Constructor Overload List


StandardAnalyzer Constructor (String[], Boolean)

public StandardAnalyzer(
string[] stopwords,
bool replaceInvalidAcronym
);

Parameters

stopwords
The stopwords to use
replaceInvalidAcronym
Set to true if this analyzer should replace mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer Constructor Overload List


StandardAnalyzer Constructor (Hashtable, Boolean)

public StandardAnalyzer(
Hashtable stopwords,
bool replaceInvalidAcronym
);

Parameters

stopwords
The stopwords to use
replaceInvalidAcronym
Set to true if this analyzer should replace mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | StandardAnalyzer Constructor Overload List


StandardAnalyzer Fields

The fields of the StandardAnalyzer class are listed below. For a complete list of StandardAnalyzer class members, see the StandardAnalyzer Members topic.

Public Static Fields

DEFAULT_MAX_TOKEN_LENGTH | Default maximum allowed token length
STOP_WORDS | An array containing some common English words that are usually not useful for searching.

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer.DEFAULT_MAX_TOKEN_LENGTH Field

Default maximum allowed token length

public const int DEFAULT_MAX_TOKEN_LENGTH = 255;

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer.STOP_WORDS Field

An array containing some common English words that are usually not useful for searching.

public static readonly string[] STOP_WORDS;

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Methods

The methods of the StandardAnalyzer class are listed below. For a complete list of StandardAnalyzer class members, see the StandardAnalyzer Members topic.

Public Static Methods

GetDefaultReplaceInvalidAcronym | see https://issues.apache.org/jira/browse/LUCENE-1068
SetDefaultReplaceInvalidAcronym | set to true to have new instances of StandardTokenizer replace mischaracerized acronyms by default. Set to false to preserve the previous (before 2.4) buggy behavior. Alternatively, set the system property Lucene.Net.Analysis.Standard.StandardAnalyzer.replaceInvalidAcronym to false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxTokenLength |
GetPositionIncrementGap (inherited from Analyzer) | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReplaceInvalidAcronym |
ReusableTokenStream |
SetMaxTokenLength | Set maximum allowed token length. If a token is seen that exceeds this length then it is discarded. This setting only takes effect the next time tokenStream or reusableTokenStream is called.
SetReplaceInvalidAcronym |
TokenStream | Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
SetPreviousTokenStream (inherited from Analyzer) | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer.GetDefaultReplaceInvalidAcronym Method

see https://issues.apache.org/jira/browse/LUCENE-1068

public static bool GetDefaultReplaceInvalidAcronym();

Return Value

true if new instances of StandardTokenizer will replace mischaracterized acronyms

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer.GetMaxTokenLength Method

public virtual int GetMaxTokenLength();

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace | setMaxTokenLength


StandardAnalyzer.IsReplaceInvalidAcronym Method

public virtual bool IsReplaceInvalidAcronym();

Return Value

true if this Analyzer is replacing mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer.ReusableTokenStream Method

public override TokenStream ReusableTokenStream(
string fieldName,
TextReader reader
);

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer.SetDefaultReplaceInvalidAcronym Method

set to true to have new instances of StandardTokenizer replace mischaracerized acronyms by default. Set to false to preserve the previous (before 2.4) buggy behavior. Alternatively, set the system property Lucene.Net.Analysis.Standard.StandardAnalyzer.replaceInvalidAcronym to false.

public static void SetDefaultReplaceInvalidAcronym(
bool replaceInvalidAcronym
);

Parameters

replaceInvalidAcronym

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer.SetMaxTokenLength Method

Set maximum allowed token length. If a token is seen that exceeds this length then it is discarded. This setting only takes effect the next time tokenStream or reusableTokenStream is called.

public virtual void SetMaxTokenLength(
int length
);

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer.SetReplaceInvalidAcronym Method

public virtual void SetReplaceInvalidAcronym(
bool replaceInvalidAcronym
);

Parameters

replaceInvalidAcronym
Set to true if this Analyzer is replacing mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer.TokenStream Method

Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

StandardAnalyzer Class | Lucene.Net.Analysis.Standard Namespace


StandardFilter Class

Normalizes tokens extracted with {@link StandardTokenizer}.

For a list of all members of this type, see StandardFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.Standard.StandardFilter

public sealed class StandardFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StandardFilter Members | Lucene.Net.Analysis.Standard Namespace


StandardFilter Members

StandardFilter overview

Public Instance Constructors

StandardFilter Constructor Construct filtering in.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

input (inherited from TokenFilter) The source of tokens for this filter.

See Also

StandardFilter Class | Lucene.Net.Analysis.Standard Namespace


StandardFilter Constructor

Construct filtering in.

public StandardFilter(
TokenStream in_Renamed
);

See Also

StandardFilter Class | Lucene.Net.Analysis.Standard Namespace


StandardFilter Methods

The methods of the StandardFilter class are listed below. For a complete list of StandardFilter class members, see the StandardFilter Members topic.

Public Instance Methods

Close (inherited from TokenFilter) | Close the input TokenStream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset (inherited from TokenFilter) | Reset the filter as well as the input TokenStream.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StandardFilter Class | Lucene.Net.Analysis.Standard Namespace


Next Method

Apache Lucene.Net 2.4.0 Class Library API

StandardFilter.Next Method

Overload List

Inherited from TokenStream.

public virtual Token Next();

public override Token Next(Token);

See Also

StandardFilter Class | Lucene.Net.Analysis.Standard Namespace


StandardFilter.Next Method (Token)

public override Token Next(
Token reusableToken
);

See Also

StandardFilter Class | Lucene.Net.Analysis.Standard Namespace | StandardFilter.Next Overload List


StandardTokenizer Class

For a list of all members of this type, see StandardTokenizer Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.Standard.StandardTokenizer

public class StandardTokenizer : Tokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Standard

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StandardTokenizer Members | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Members

StandardTokenizer overview

Public Static Fields

ACRONYM
ACRONYM_DEP
ALPHANUM
APOSTROPHE
CJ
COMPANY
EMAIL
HOST
NUM
TOKEN_TYPES
tokenImage

Public Instance Constructors

StandardTokenizer Overloaded. Initializes a new instance of the StandardTokenizer class.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxTokenLength |
GetType (inherited from Object) | Gets the Type of the current instance.
IsReplaceInvalidAcronym | Prior to https://issues.apache.org/jira/browse/LUCENE-1068, StandardTokenizer mischaracterized as acronyms tokens like www.abc.com when they should have been labeled as hosts instead.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Overloaded.
SetMaxTokenLength | Set the max allowed token length. Any token longer than this is skipped.
SetReplaceInvalidAcronym |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Constructor

Creates a new instance of the {@link StandardTokenizer}. Attaches the

input
to a newly created JFlex scanner.

Overload List

Creates a new instance of the {@link StandardTokenizer}. Attaches the

input
to a newly created JFlex scanner.

public StandardTokenizer(TextReader);

Creates a new instance of the {@link Lucene.Net.Analysis.Standard.StandardTokenizer}. Attaches the

input
to the newly created JFlex scanner.

public StandardTokenizer(TextReader,bool);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Constructor (TextReader)

Creates a new instance of the {@link StandardTokenizer}. Attaches the

input
to a newly created JFlex scanner.

public StandardTokenizer(
TextReader input
);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizer Constructor Overload List


StandardTokenizer Constructor (TextReader, Boolean)

Creates a new instance of the {@link Lucene.Net.Analysis.Standard.StandardTokenizer}. Attaches the

input
to the newly created JFlex scanner.

public StandardTokenizer(
TextReader input,
bool replaceInvalidAcronym
);

Parameters

input
The input reader
replaceInvalidAcronym
Set to true to replace mischaracterized acronyms with HOST. See http://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizer Constructor Overload List


StandardTokenizer Fields

The fields of the StandardTokenizer class are listed below. For a complete list of StandardTokenizer class members, see the StandardTokenizer Members topic.

Public Static Fields

ACRONYM
ACRONYM_DEP
ALPHANUM
APOSTROPHE
CJ
COMPANY
EMAIL
HOST
NUM
TOKEN_TYPES
tokenImage

Protected Internal Instance Fields

input (inherited from Tokenizer) The text source for this Tokenizer.

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.ACRONYM Field

public const int ACRONYM = 2;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.ACRONYM_DEP Field

public const int ACRONYM_DEP = 8;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.ALPHANUM Field

public const int ALPHANUM = 0;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.APOSTROPHE Field

public const int APOSTROPHE = 1;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.CJ Field

public const int CJ = 7;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.COMPANY Field

public const int COMPANY = 3;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.EMAIL Field

public const int EMAIL = 4;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.HOST Field

public const int HOST = 5;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.NUM Field

public const int NUM = 6;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.TOKEN_TYPES Field

public static readonly string[] TOKEN_TYPES;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.tokenImage Field

public static readonly string[] tokenImage;

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Methods

The methods of the StandardTokenizer class are listed below. For a complete list of StandardTokenizer class members, see the StandardTokenizer Members topic.

Public Instance Methods

Close (inherited from Tokenizer) | By default, closes the input Reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxTokenLength |
GetType (inherited from Object) | Gets the Type of the current instance.
IsReplaceInvalidAcronym | Prior to https://issues.apache.org/jira/browse/LUCENE-1068, StandardTokenizer mischaracterized as acronyms tokens like www.abc.com when they should have been labeled as hosts instead.
Next | Overloaded.
Next (inherited from TokenStream) | Overloaded. Returns the next token in the stream, or null at EOS. @deprecated The returned Token is a "full private copy" (not re-used across calls to next()) but will be slower than calling {@link #Next(Token)} instead..
Reset | Overloaded.
SetMaxTokenLength | Set the max allowed token length. Any token longer than this is skipped.
SetReplaceInvalidAcronym |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.GetMaxTokenLength Method

public virtual int GetMaxTokenLength();

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace | setMaxTokenLength


StandardTokenizer.IsReplaceInvalidAcronym Method

Prior to https://issues.apache.org/jira/browse/LUCENE-1068, StandardTokenizer mischaracterized as acronyms tokens like www.abc.com when they should have been labeled as hosts instead.

public virtual bool IsReplaceInvalidAcronym();

Return Value

true if StandardTokenizer now returns these tokens as Hosts, otherwise false

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


Next Method

Apache Lucene.Net 2.4.0 Class Library API

StandardTokenizer.Next Method

Overload List

Inherited from TokenStream.

public virtual Token Next();

public override Token Next(Token);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.Next Method (Token)

public override Token Next(
Token reusableToken
);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizer.Next Overload List


Reset Method

Apache Lucene.Net 2.4.0 Class Library API

StandardTokenizer.Reset Method

Overload List

public override void Reset();

public override void Reset(TextReader);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.Reset Method ()

public override void Reset();

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizer.Reset Overload List


StandardTokenizer.Reset Method (TextReader)

public override void Reset(
TextReader reader
);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace | StandardTokenizer.Reset Overload List


StandardTokenizer.SetMaxTokenLength Method

Set the max allowed token length. Any token longer than this is skipped.

public virtual void SetMaxTokenLength(
int length
);

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


StandardTokenizer.SetReplaceInvalidAcronym Method

public virtual void SetReplaceInvalidAcronym(
bool replaceInvalidAcronym
);

Parameters

replaceInvalidAcronym
Set to true to replace mischaracterized acronyms as HOST.

See Also

StandardTokenizer Class | Lucene.Net.Analysis.Standard Namespace


Lucene.Net.Documents

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Documents Namespace

Namespace hierarchy

Classes

Class | Description
AbstractField |
DateField |
DateTools |
DateTools.Resolution | Specifies the time granularity.
Document |
Field | A field is a section of a Document. Each field has two parts, a name and a value. Values may be free text, provided as a String or as a Reader, or they may be atomic keywords, which are not further processed. Such keywords may be used to represent dates, urls, etc. Fields are optionally stored in the index, so that they may be returned with hits on the document.
Field.Index | Specifies whether and how a field should be indexed.
Field.Store | Specifies whether and how a field should be stored.
Field.TermVector | Specifies whether and how a field should have term vectors.
FieldSelectorResult | Provides information about what should be done with this Field
LoadFirstFieldSelector | Load the First field and break. See {@link FieldSelectorResult#LOAD_AND_BREAK}
MapFieldSelector | A FieldSelector based on a Map of field names to FieldSelectorResults
NumberTools |
SetBasedFieldSelector | Declare what fields to load normally and what fields to load lazily

Interfaces

Interface | Description
Fieldable | Synonymous with {@link Field}. WARNING: This interface may change within minor versions, despite Lucene's backward compatibility requirements. This means new methods may be added from version to version. This change only affects the Fieldable API; other backwards compatibility promises remain intact. For example, Lucene can still read and write indices created within the same major version.
FieldSelector | Similar to a {@link java.io.FileFilter}, the FieldSelector allows one to make decisions about what Fields get loaded on a {@link Document} by {@link Lucene.Net.Index.IndexReader#Document(int,Lucene.Net.Documents.FieldSelector)}


AbstractField Class

For a list of all members of this type, see AbstractField Members.

System.Object
Lucene.Net.Documents.AbstractField
Lucene.Net.Documents.Field
Lucene.Net.Index.FieldsReader.FieldForMerge

public abstract class AbstractField : Fieldable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

AbstractField Members | Lucene.Net.Documents Namespace


AbstractField Members

AbstractField overview

Public Instance Methods

BinaryValue
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBinaryLength | Returns the length of byte[] segment that is used as value. If Field is not binary returned value is undefined.
GetBinaryOffset | Returns offset into byte[] segment that is used as value. If Field is not binary returned value is undefined.
GetBinaryValue | Overloaded. Return the raw byte[] for the binary field. Note that you must also call {@link #GetBinaryLength} and {@link #GetBinaryOffset} to know which range of bytes in this returned array belong to the field.
GetBoost
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOmitNorms | True if norms are omitted for this indexed field
GetOmitTf | Returns true if tf is omitted for this indexed field.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBinary | True iff the value of the filed is stored as binary
IsCompressed | True if the value of the field is stored and compressed within the index
IsIndexed | True iff the value of the field is to be indexed, so that it may be searched on.
IsLazy
IsStored | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
IsStoreOffsetWithTermVector | True iff terms are stored as term vector together with their offsets (start and end positon in source text).
IsStorePositionWithTermVector | True iff terms are stored as term vector together with their token positions.
IsTermVectorStored True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
stored
attribute instead.
IsTokenized | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Name | Returns the name of the field as an interned string. For example "date", "title", "body", ...
ReaderValue
SetBoost
SetOmitNorms | Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
SetOmitTf | Expert: If set, omit tf from postings of this indexed field.
StringValue
TokenStreamValue
ToString | Prints a Field for human consumption.

Protected Instance Fields

binaryLength
binaryOffset

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

AbstractField Overloaded. Initializes a new instance of the AbstractField class.

Protected Internal Instance Fields

boost
fieldsData
isBinary
isCompressed
isIndexed
isStored
isTokenized
lazy
name
omitNorms
omitTf
storeOffsetWithTermVector
storePositionWithTermVector
storeTermVector

Protected Internal Instance Methods

SetStoreTermVector

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField Constructor

Initializes a new instance of the AbstractField class.

Overload List

Initializes a new instance of the AbstractField class.

protected internal AbstractField();

protected internal AbstractField(string,Store,Index,TermVector);

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField Constructor ()

Initializes a new instance of the AbstractField class.

protected internal AbstractField();

See Also

AbstractField Class | Lucene.Net.Documents Namespace | AbstractField Constructor Overload List


AbstractField Constructor (String, Store, Index, TermVector)

protected internal AbstractField(
string name,
Store store,
Index index,
TermVector termVector
);

See Also

AbstractField Class | Lucene.Net.Documents Namespace | AbstractField Constructor Overload List


AbstractField Fields

The fields of the AbstractField class are listed below. For a complete list of AbstractField class members, see the AbstractField Members topic.

Protected Instance Fields

binaryLength
binaryOffset

Protected Internal Instance Fields

boost
fieldsData
isBinary
isCompressed
isIndexed
isStored
isTokenized
lazy
name
omitNorms
omitTf
storeOffsetWithTermVector
storePositionWithTermVector
storeTermVector

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.binaryLength Field

protected int binaryLength;

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.binaryOffset Field

protected int binaryOffset;

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.boost Field

protected internal float boost;

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.fieldsData Field

protected internal object fieldsData;

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.IsBinary Method

True iff the value of the filed is stored as binary

public bool IsBinary();

Implements

Fieldable.IsBinary

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.IsCompressed Method

True if the value of the field is stored and compressed within the index

public bool IsCompressed();

Implements

Fieldable.IsCompressed

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.IsIndexed Method

True iff the value of the field is to be indexed, so that it may be searched on.

public bool IsIndexed();

Implements

Fieldable.IsIndexed

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.IsStored Method

True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.

public bool IsStored();

Implements

Fieldable.IsStored

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.IsTokenized Method

True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.

public bool IsTokenized();

Implements

Fieldable.IsTokenized

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.lazy Field

protected internal bool lazy;

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.Name Method

Returns the name of the field as an interned string. For example "date", "title", "body", ...

public virtual string Name();

Implements

Fieldable.Name

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.omitNorms Field

protected internal bool omitNorms;

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.omitTf Field

protected internal bool omitTf;

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.storeOffsetWithTermVector Field

protected internal bool storeOffsetWithTermVector;

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.storePositionWithTermVector Field

protected internal bool storePositionWithTermVector;

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.storeTermVector Field

protected internal bool storeTermVector;

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField Methods

The methods of the AbstractField class are listed below. For a complete list of AbstractField class members, see the AbstractField Members topic.

Public Instance Methods

BinaryValue
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBinaryLength | Returns the length of byte[] segment that is used as value. If Field is not binary returned value is undefined.
GetBinaryOffset | Returns offset into byte[] segment that is used as value. If Field is not binary returned value is undefined.
GetBinaryValue | Overloaded. Return the raw byte[] for the binary field. Note that you must also call {@link #GetBinaryLength} and {@link #GetBinaryOffset} to know which range of bytes in this returned array belong to the field.
GetBoost
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOmitNorms | True if norms are omitted for this indexed field
GetOmitTf | Returns true if tf is omitted for this indexed field.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBinary | True iff the value of the filed is stored as binary
IsCompressed | True if the value of the field is stored and compressed within the index
IsIndexed | True iff the value of the field is to be indexed, so that it may be searched on.
IsLazy
IsStored | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
IsStoreOffsetWithTermVector | True iff terms are stored as term vector together with their offsets (start and end positon in source text).
IsStorePositionWithTermVector | True iff terms are stored as term vector together with their token positions.
IsTermVectorStored True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
stored
attribute instead.
IsTokenized | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Name | Returns the name of the field as an interned string. For example "date", "title", "body", ...
ReaderValue
SetBoost
SetOmitNorms | Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
SetOmitTf | Expert: If set, omit tf from postings of this indexed field.
StringValue
TokenStreamValue
ToString | Prints a Field for human consumption.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SetStoreTermVector

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.BinaryValue Method

public abstract byte[] BinaryValue();

Implements

Fieldable.BinaryValue

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.GetBinaryLength Method

Returns the length of byte[] segment that is used as value. If Field is not binary returned value is undefined.

public int GetBinaryLength();

Return Value

length of byte[] segment that represents this Field value

Implements

Fieldable.GetBinaryLength

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.GetBinaryOffset Method

Returns offset into byte[] segment that is used as value. If Field is not binary returned value is undefined.

public int GetBinaryOffset();

Return Value

index of the byte[] segment that represents this Field value

Implements

Fieldable.GetBinaryOffset

See Also

AbstractField Class | Lucene.Net.Documents Namespace


GetBinaryValue Method

Apache Lucene.Net 2.4.0 Class Library API

AbstractField.GetBinaryValue Method

Return the raw byte[] for the binary field. Note that you must also call {@link #GetBinaryLength} and {@link #GetBinaryOffset} to know which range of bytes in this returned array belong to the field.

Overload List

Return the raw byte[] for the binary field. Note that you must also call {@link #GetBinaryLength} and {@link #GetBinaryOffset} to know which range of bytes in this returned array belong to the field.

public byte[] GetBinaryValue();

public virtual byte[] GetBinaryValue(byte[]);

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.GetBinaryValue Method ()

Return the raw byte[] for the binary field. Note that you must also call {@link #GetBinaryLength} and {@link #GetBinaryOffset} to know which range of bytes in this returned array belong to the field.

public byte[] GetBinaryValue();

Return Value

reference to the field value as byte[]

Implements

Fieldable.GetBinaryValue

See Also

AbstractField Class | Lucene.Net.Documents Namespace | AbstractField.GetBinaryValue Overload List


AbstractField.GetBinaryValue Method (Byte[])

public virtual byte[] GetBinaryValue(
byte[] result
);

Implements

Fieldable.GetBinaryValue

See Also

AbstractField Class | Lucene.Net.Documents Namespace | AbstractField.GetBinaryValue Overload List


AbstractField.GetBoost Method

public virtual float GetBoost();

Implements

Fieldable.GetBoost

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.GetOmitNorms Method

True if norms are omitted for this indexed field

public virtual bool GetOmitNorms();

Implements

Fieldable.GetOmitNorms

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.GetOmitTf Method

Returns true if tf is omitted for this indexed field.

public virtual bool GetOmitTf();

Return Value

true if tf is omitted for this indexed field

Implements

Fieldable.GetOmitTf

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.IsLazy Method

public virtual bool IsLazy();

Implements

Fieldable.IsLazy

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.IsStoreOffsetWithTermVector Method

True iff terms are stored as term vector together with their offsets (start and end positon in source text).

public virtual bool IsStoreOffsetWithTermVector();

Implements

Fieldable.IsStoreOffsetWithTermVector

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.IsStorePositionWithTermVector Method

True iff terms are stored as term vector together with their token positions.

public virtual bool IsStorePositionWithTermVector();

Implements

Fieldable.IsStorePositionWithTermVector

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.IsTermVectorStored Method

True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the

stored
attribute instead.

public bool IsTermVectorStored();

Implements

Fieldable.IsTermVectorStored

See Also

AbstractField Class | Lucene.Net.Documents Namespace | String)


AbstractField.ReaderValue Method

public abstract TextReader ReaderValue();

Implements

Fieldable.ReaderValue

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.SetBoost Method

public virtual void SetBoost(
float boost
);

Implements

Fieldable.SetBoost

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.SetOmitNorms Method

Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.

public virtual void SetOmitNorms(
bool omitNorms
);

Implements

Fieldable.SetOmitNorms

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.SetOmitTf Method

Expert: If set, omit tf from postings of this indexed field.

public void SetOmitTf(
bool omitTf
);

Parameters

omitTf

Implements

Fieldable.SetOmitTf

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.SetStoreTermVector Method

protected internal virtual void SetStoreTermVector(
TermVector termVector
);

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.StringValue Method

public abstract string StringValue();

Implements

Fieldable.StringValue

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.TokenStreamValue Method

public abstract TokenStream TokenStreamValue();

Implements

Fieldable.TokenStreamValue

See Also

AbstractField Class | Lucene.Net.Documents Namespace


AbstractField.ToString Method

Prints a Field for human consumption.

public override string ToString();

See Also

AbstractField Class | Lucene.Net.Documents Namespace


DateField Class

For a list of all members of this type, see DateField Members.

System.Object
Lucene.Net.Documents.DateField

public class DateField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DateField Members | Lucene.Net.Documents Namespace


DateField Members

DateField overview

Public Static Methods

DateToString | Converts a Date to a string suitable for indexing.
MAX_DATE_STRING |
MIN_DATE_STRING |
StringToDate | Converts a string-encoded date into a Date object.
StringToTime | Converts a string-encoded date into a millisecond time.
TimeToString | Converts a millisecond time to a string suitable for indexing.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField Methods

The methods of the DateField class are listed below. For a complete list of DateField class members, see the DateField Members topic.

Public Static Methods

DateToString | Converts a Date to a string suitable for indexing.
MAX_DATE_STRING |
MIN_DATE_STRING |
StringToDate | Converts a string-encoded date into a Date object.
StringToTime | Converts a string-encoded date into a millisecond time.
TimeToString | Converts a millisecond time to a string suitable for indexing.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField.DateToString Method

Converts a Date to a string suitable for indexing.

public static string DateToString(
DateTime date
);

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField.MAX_DATE_STRING Method

public static string MAX_DATE_STRING();

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField.MIN_DATE_STRING Method

public static string MIN_DATE_STRING();

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField.StringToDate Method

Converts a string-encoded date into a Date object.

public static DateTime StringToDate(
string s
);

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField.StringToTime Method

Converts a string-encoded date into a millisecond time.

public static long StringToTime(
string s
);

See Also

DateField Class | Lucene.Net.Documents Namespace


DateField.TimeToString Method

Converts a millisecond time to a string suitable for indexing.

public static string TimeToString(
long time
);

See Also

DateField Class | Lucene.Net.Documents Namespace


DateTools Class

For a list of all members of this type, see DateTools Members.

System.Object
Lucene.Net.Documents.DateTools

public class DateTools

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DateTools Members | Lucene.Net.Documents Namespace


DateTools Members

DateTools overview

Public Static Methods

DateToString | Converts a Date to a string suitable for indexing.
Round Overloaded. Limit a date's resolution. For example, the date
2004-09-21 13:50:11
will be changed to
2004-09-01 00:00:00
when using
Resolution.MONTH
.
StringToDate Converts a string produced by
timeToString
or
dateToString
back to a time, represented as a Date object.
StringToTime Converts a string produced by
timeToString
or
dateToString
back to a time, represented as the number of milliseconds since January 1, 1970, 00:00:00 GMT.
TimeToString | Converts a millisecond time to a string suitable for indexing.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTools Class | Lucene.Net.Documents Namespace


DateTools Methods

The methods of the DateTools class are listed below. For a complete list of DateTools class members, see the DateTools Members topic.

Public Static Methods

DateToString | Converts a Date to a string suitable for indexing.
Round Overloaded. Limit a date's resolution. For example, the date
2004-09-21 13:50:11
will be changed to
2004-09-01 00:00:00
when using
Resolution.MONTH
.
StringToDate Converts a string produced by
timeToString
or
dateToString
back to a time, represented as a Date object.
StringToTime Converts a string produced by
timeToString
or
dateToString
back to a time, represented as the number of milliseconds since January 1, 1970, 00:00:00 GMT.
TimeToString | Converts a millisecond time to a string suitable for indexing.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTools Class | Lucene.Net.Documents Namespace


DateTools.DateToString Method

Converts a Date to a string suitable for indexing.

public static string DateToString(
DateTime date,
Resolution resolution
);

Parameters

date
the date to be converted
resolution
the desired resolution, see {@link #Round(Date, DateTools.Resolution)}

Return Value

a string in format

yyyyMMddHHmmssSSS
or shorter, depeding on
resolution
; using GMT as timezone

See Also

DateTools Class | Lucene.Net.Documents Namespace


Round Method

Apache Lucene.Net 2.4.0 Class Library API

DateTools.Round Method

Limit a date's resolution. For example, the date

2004-09-21 13:50:11
will be changed to
2004-09-01 00:00:00
when using
Resolution.MONTH
.

Overload List

Limit a date's resolution. For example, the date

2004-09-21 13:50:11
will be changed to
2004-09-01 00:00:00
when using
Resolution.MONTH
.

public static DateTime Round(DateTime,Resolution);

Limit a date's resolution. For example, the date

1095767411000
(which represents 2004-09-21 13:50:11) will be changed to
1093989600000
(2004-09-01 00:00:00) when using
Resolution.MONTH
.

public static long Round(long,Resolution);

See Also

DateTools Class | Lucene.Net.Documents Namespace


DateTools.Round Method (DateTime, Resolution)

Limit a date's resolution. For example, the date

2004-09-21 13:50:11
will be changed to
2004-09-01 00:00:00
when using
Resolution.MONTH
.

public static DateTime Round(
DateTime date,
Resolution resolution
);

Parameters

date
resolution
The desired resolution of the date to be returned

Return Value

the date with all values more precise than

resolution
set to 0 or 1

See Also

DateTools Class | Lucene.Net.Documents Namespace | DateTools.Round Overload List


DateTools.Round Method (Int64, Resolution)

Limit a date's resolution. For example, the date

1095767411000
(which represents 2004-09-21 13:50:11) will be changed to
1093989600000
(2004-09-01 00:00:00) when using
Resolution.MONTH
.

public static long Round(
long time,
Resolution resolution
);

Parameters

time
resolution
The desired resolution of the date to be returned

Return Value

the date with all values more precise than

resolution
set to 0 or 1, expressed as milliseconds since January 1, 1970, 00:00:00 GMT

See Also

DateTools Class | Lucene.Net.Documents Namespace | DateTools.Round Overload List


DateTools.StringToDate Method

Converts a string produced by

timeToString
or
dateToString
back to a time, represented as a Date object.

public static DateTime StringToDate(
string dateString
);

Parameters

dateString
the date string to be converted

Return Value

the parsed time as a Date object

See Also

DateTools Class | Lucene.Net.Documents Namespace


DateTools.StringToTime Method

Converts a string produced by

timeToString
or
dateToString
back to a time, represented as the number of milliseconds since January 1, 1970, 00:00:00 GMT.

public static long StringToTime(
string dateString
);

Parameters

dateString
the date string to be converted

Return Value

the number of milliseconds since January 1, 1970, 00:00:00 GMT

See Also

DateTools Class | Lucene.Net.Documents Namespace


DateTools.TimeToString Method

Converts a millisecond time to a string suitable for indexing.

public static string TimeToString(
long time,
Resolution resolution
);

Parameters

time
the date expressed as milliseconds since January 1, 1970, 00:00:00 GMT
resolution
the desired resolution, see {@link #Round(long, DateTools.Resolution)}

Return Value

a string in format

yyyyMMddHHmmssSSS
or shorter, depeding on
resolution
; using GMT as timezone

See Also

DateTools Class | Lucene.Net.Documents Namespace


DateTools.Resolution Class

Specifies the time granularity.

For a list of all members of this type, see DateTools.Resolution Members.

System.Object
Lucene.Net.Documents.DateTools.Resolution

public class DateTools.Resolution

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DateTools.Resolution Members | Lucene.Net.Documents Namespace


DateTools.Resolution Members

DateTools.Resolution overview

Public Static Fields

DAY
HOUR
MILLISECOND
MINUTE
MONTH
SECOND
YEAR

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTools.Resolution Class | Lucene.Net.Documents Namespace


DateTools.Resolution Fields

The fields of the DateTools.Resolution class are listed below. For a complete list of DateTools.Resolution class members, see the DateTools.Resolution Members topic.

Public Static Fields

DAY
HOUR
MILLISECOND
MINUTE
MONTH
SECOND
YEAR

See Also

DateTools.Resolution Class | Lucene.Net.Documents Namespace


DateTools.Resolution.DAY Field

public static readonly Resolution DAY;

See Also

DateTools.Resolution Class | Lucene.Net.Documents Namespace


DateTools.Resolution.HOUR Field

public static readonly Resolution HOUR;

See Also

DateTools.Resolution Class | Lucene.Net.Documents Namespace


DateTools.Resolution.MILLISECOND Field

public static readonly Resolution MILLISECOND;

See Also

DateTools.Resolution Class | Lucene.Net.Documents Namespace


DateTools.Resolution.MINUTE Field

public static readonly Resolution MINUTE;

See Also

DateTools.Resolution Class | Lucene.Net.Documents Namespace


DateTools.Resolution.MONTH Field

public static readonly Resolution MONTH;

See Also

DateTools.Resolution Class | Lucene.Net.Documents Namespace


DateTools.Resolution.SECOND Field

public static readonly Resolution SECOND;

See Also

DateTools.Resolution Class | Lucene.Net.Documents Namespace


DateTools.Resolution.YEAR Field

public static readonly Resolution YEAR;

See Also

DateTools.Resolution Class | Lucene.Net.Documents Namespace


DateTools.Resolution Methods

The methods of the DateTools.Resolution class are listed below. For a complete list of DateTools.Resolution class members, see the DateTools.Resolution Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTools.Resolution Class | Lucene.Net.Documents Namespace


DateTools.Resolution.ToString Method

public override string ToString();

See Also

DateTools.Resolution Class | Lucene.Net.Documents Namespace


Document Class

For a list of all members of this type, see Document Members.

System.Object
Lucene.Net.Documents.Document

public sealed class Document

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Document Members | Lucene.Net.Documents Namespace


Document Members

Document overview

Public Instance Constructors

Document Constructor Constructs a new document with no fields.

Public Instance Methods

Add | Adds a field to a document. Several fields may be added with the same name. In this case, if the fields are indexed, their text is treated as though appended for the purposes of search. Note that add like the removeField(s) methods only makes sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Fields | Returns an Enumeration of all the fields in a document.
Get | Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.
GetBinaryValue Returns an array of bytes for the first (or only) field that has the name specified as the method parameter. This method will return
null
if no binary fields with the specified name are available. There may be non-binary fields with the same name.
GetBinaryValues | Returns an array of byte arrays for the fields that have the name specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.
GetBoost
GetField | Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added. Do not use this method with lazy loaded fields.
GetFieldable | Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added.
GetFieldables | Returns an array of {@link Fieldable}s with the given name. This method returns an empty array when there are no matching fields. It never returns null.
GetFields | Overloaded.
GetFieldsCount | Returns the number of fields in this document
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues | Returns an array of values of the field specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.
RemoveField | Removes field with the specified name from the document. If multiple fields exist with this name, this method removes the first field that has been added. If there is no field with the specified name, the document remains unchanged. Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
RemoveFields | Removes all fields with the given name from the document. If there is no field with the specified name, the document remains unchanged. Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
SetBoost
ToString | Prints the fields of a document for human consumption.

See Also

Document Class | Lucene.Net.Documents Namespace


Document Constructor

Constructs a new document with no fields.

public Document();

See Also

Document Class | Lucene.Net.Documents Namespace


Document Methods

The methods of the Document class are listed below. For a complete list of Document class members, see the Document Members topic.

Public Instance Methods

Add | Adds a field to a document. Several fields may be added with the same name. In this case, if the fields are indexed, their text is treated as though appended for the purposes of search. Note that add like the removeField(s) methods only makes sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Fields | Returns an Enumeration of all the fields in a document.
Get | Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.
GetBinaryValue Returns an array of bytes for the first (or only) field that has the name specified as the method parameter. This method will return
null
if no binary fields with the specified name are available. There may be non-binary fields with the same name.
GetBinaryValues | Returns an array of byte arrays for the fields that have the name specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.
GetBoost
GetField | Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added. Do not use this method with lazy loaded fields.
GetFieldable | Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added.
GetFieldables | Returns an array of {@link Fieldable}s with the given name. This method returns an empty array when there are no matching fields. It never returns null.
GetFields | Overloaded.
GetFieldsCount | Returns the number of fields in this document
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues | Returns an array of values of the field specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.
RemoveField | Removes field with the specified name from the document. If multiple fields exist with this name, this method removes the first field that has been added. If there is no field with the specified name, the document remains unchanged. Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
RemoveFields | Removes all fields with the given name from the document. If there is no field with the specified name, the document remains unchanged. Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
SetBoost
ToString | Prints the fields of a document for human consumption.

See Also

Document Class | Lucene.Net.Documents Namespace


Document.Add Method

Adds a field to a document. Several fields may be added with the same name. In this case, if the fields are indexed, their text is treated as though appended for the purposes of search.

Note that add like the removeField(s) methods only makes sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

public void Add(
Fieldable field
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.Fields Method

Returns an Enumeration of all the fields in a document.

public IEnumerator Fields();

See Also

Document Class | Lucene.Net.Documents Namespace


Document.Get Method

Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.

public string Get(
string name
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.GetBinaryValue Method

Returns an array of bytes for the first (or only) field that has the name specified as the method parameter. This method will return

null
if no binary fields with the specified name are available. There may be non-binary fields with the same name.

public byte[] GetBinaryValue(
string name
);

Parameters

name
the name of the field.

Return Value

a

byte[]
containing the binary field value or
null

See Also

Document Class | Lucene.Net.Documents Namespace


Document.GetBinaryValues Method

Returns an array of byte arrays for the fields that have the name specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.

public byte[][] GetBinaryValues(
string name
);

Parameters

name
the name of the field

Return Value

a

byte[][]
of binary field values

See Also

Document Class | Lucene.Net.Documents Namespace


Document.GetBoost Method

public float GetBoost();

See Also

Document Class | Lucene.Net.Documents Namespace


Document.GetField Method

Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added. Do not use this method with lazy loaded fields.

public Field GetField(
string name
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.GetFieldable Method

Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added.

public Fieldable GetFieldable(
string name
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.GetFieldables Method

Returns an array of {@link Fieldable}s with the given name. This method returns an empty array when there are no matching fields. It never returns null.

public Fieldable[] GetFieldables(
string name
);

Parameters

name
the name of the field

Return Value

a

Fieldable[]
array

See Also

Document Class | Lucene.Net.Documents Namespace


GetFields Method

Apache Lucene.Net 2.4.0 Class Library API

Document.GetFields Method

Overload List

public IList GetFields();

Returns an array of {@link Field}s with the given name. Do not use with lazy loaded fields. This method returns an empty array when there are no matching fields. It never returns null.

public Field[] GetFields(string);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.GetFields Method ()

public IList GetFields();

See Also

Document Class | Lucene.Net.Documents Namespace | Document.GetFields Overload List


Document.GetFields Method (String)

Returns an array of {@link Field}s with the given name. Do not use with lazy loaded fields. This method returns an empty array when there are no matching fields. It never returns null.

public Field[] GetFields(
string name
);

Parameters

name
the name of the field

Return Value

a

Field[]
array

See Also

Document Class | Lucene.Net.Documents Namespace | Document.GetFields Overload List


Document.GetFieldsCount Method

Returns the number of fields in this document

public int GetFieldsCount();

See Also

Document Class | Lucene.Net.Documents Namespace


Document.GetValues Method

Returns an array of values of the field specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.

public string[] GetValues(
string name
);

Parameters

name
the name of the field

Return Value

a

String[]
of field values

See Also

Document Class | Lucene.Net.Documents Namespace


Document.RemoveField Method

Removes field with the specified name from the document. If multiple fields exist with this name, this method removes the first field that has been added. If there is no field with the specified name, the document remains unchanged.

Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

public void RemoveField(
string name
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.RemoveFields Method

Removes all fields with the given name from the document. If there is no field with the specified name, the document remains unchanged.

Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

public void RemoveFields(
string name
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.SetBoost Method

public void SetBoost(
float boost
);

See Also

Document Class | Lucene.Net.Documents Namespace


Document.ToString Method

Prints the fields of a document for human consumption.

public override string ToString();

See Also

Document Class | Lucene.Net.Documents Namespace


Field Class

A field is a section of a Document. Each field has two parts, a name and a value. Values may be free text, provided as a String or as a Reader, or they may be atomic keywords, which are not further processed. Such keywords may be used to represent dates, urls, etc. Fields are optionally stored in the index, so that they may be returned with hits on the document.

For a list of all members of this type, see Field Members.

System.Object
Lucene.Net.Documents.AbstractField
Lucene.Net.Documents.Field

public sealed class Field : AbstractField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Field Members | Lucene.Net.Documents Namespace


Field Members

Field overview

Public Instance Constructors

Field Overloaded. Initializes a new instance of the Field class.

Public Instance Methods

BinaryValue | Obsolete. The value of the field in Binary, or null. If null, the Reader value, String value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), GetBinaryValue(), and tokenStreamValue() must be set.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBinaryLength (inherited from AbstractField) | Returns the length of byte[] segment that is used as value. If Field is not binary returned value is undefined.
GetBinaryOffset (inherited from AbstractField) | Returns offset into byte[] segment that is used as value. If Field is not binary returned value is undefined.
GetBinaryValue (inherited from AbstractField) | Overloaded. Return the raw byte[] for the binary field. Note that you must also call {@link #GetBinaryLength} and {@link #GetBinaryOffset} to know which range of bytes in this returned array belong to the field.
GetBoost (inherited from AbstractField)
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOmitNorms (inherited from AbstractField) | True if norms are omitted for this indexed field
GetOmitTf (inherited from AbstractField) | Returns true if tf is omitted for this indexed field.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBinary (inherited from AbstractField) | True iff the value of the filed is stored as binary
IsCompressed (inherited from AbstractField) | True if the value of the field is stored and compressed within the index
IsIndexed (inherited from AbstractField) | True iff the value of the field is to be indexed, so that it may be searched on.
IsLazy (inherited from AbstractField)
IsStored (inherited from AbstractField) | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
IsStoreOffsetWithTermVector (inherited from AbstractField) | True iff terms are stored as term vector together with their offsets (start and end positon in source text).
IsStorePositionWithTermVector (inherited from AbstractField) | True iff terms are stored as term vector together with their token positions.
IsTermVectorStored (inherited from AbstractField) True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
stored
attribute instead.
IsTokenized (inherited from AbstractField) | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Name (inherited from AbstractField) | Returns the name of the field as an interned string. For example "date", "title", "body", ...
ReaderValue | The value of the field as a Reader, or null. If null, the String value, binary value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), getBinaryValue(), and tokenStreamValue() must be set.
SetBoost (inherited from AbstractField)
SetOmitNorms (inherited from AbstractField) | Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
SetOmitTf (inherited from AbstractField) | Expert: If set, omit tf from postings of this indexed field.
SetValue | Overloaded. Expert: change the value of this field. This can be used during indexing to re-use a single Field instance to improve indexing speed by avoiding GC cost of new'ing and reclaiming Field instances. Typically a single {@link Document} instance is re-used as well. This helps most on small documents. Note that you should only use this method after the Field has been consumed (ie, the {@link Document} containing this Field has been added to the index). Also, each Field instance should only be used once within a single {@link Document} instance. See ImproveIndexingSpeed for details.
StringValue | The value of the field as a String, or null. If null, the Reader value, binary value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), getBinaryValue(), and tokenStreamValue() must be set.
TokenStreamValue | The value of the field as a TokesStream, or null. If null, the Reader value, String value, or binary value is used. Exactly one of stringValue(), readerValue(), GetBinaryValue(), and tokenStreamValue() must be set.
ToString (inherited from AbstractField) | Prints a Field for human consumption.

Protected Internal Instance Fields

boost (inherited from AbstractField)
fieldsData (inherited from AbstractField)
isBinary (inherited from AbstractField)
isCompressed (inherited from AbstractField)
isIndexed (inherited from AbstractField)
isStored (inherited from AbstractField)
isTokenized (inherited from AbstractField)
lazy (inherited from AbstractField)
name (inherited from AbstractField)
omitNorms (inherited from AbstractField)
omitTf (inherited from AbstractField)
storeOffsetWithTermVector (inherited from AbstractField)
storePositionWithTermVector (inherited from AbstractField)
storeTermVector (inherited from AbstractField)

Protected Internal Instance Methods

SetStoreTermVector (inherited from AbstractField)

See Also

Field Class | Lucene.Net.Documents Namespace


Field Constructor

Create a field by specifying its name, value and how it will be saved in the index. Term vectors will not be stored in the index.

Overload List

Create a tokenized and indexed field that is not stored. Term vectors will not be stored. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until {@link IndexWriter#AddDocument(Document)} has been called.

public Field(string,TokenStream);

Create a tokenized and indexed field that is not stored, optionally with storing term vectors. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until {@link IndexWriter#AddDocument(Document)} has been called.

public Field(string,TokenStream,TermVector);

Create a stored field with binary value. Optionally the value may be compressed.

public Field(string,byte[],Store);

Create a stored field with binary value. Optionally the value may be compressed.

public Field(string,byte[],int,int,Store);

Create a tokenized and indexed field that is not stored. Term vectors will not be stored. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until {@link IndexWriter#AddDocument(Document)} has been called.

public Field(string,TextReader);

Create a tokenized and indexed field that is not stored, optionally with storing term vectors. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until {@link IndexWriter#AddDocument(Document)} has been called.

public Field(string,TextReader,TermVector);

Create a field by specifying its name, value and how it will be saved in the index. Term vectors will not be stored in the index.

public Field(string,string,Store,Index);

Create a field by specifying its name, value and how it will be saved in the index.

public Field(string,string,Store,Index,TermVector);

See Also

Field Class | Lucene.Net.Documents Namespace


Field Constructor (String, String, Store, Index)

Create a field by specifying its name, value and how it will be saved in the index. Term vectors will not be stored in the index.

public Field(
string name,
string value_Renamed,
Store store,
Index index
);

Parameters

name
The name of the field
value_Renamed
store
Whether
value
should be stored in the index
index
Whether the field should be indexed, and if so, if it should be tokenized before indexing

See Also

Field Class | Lucene.Net.Documents Namespace | Field Constructor Overload List


Field Constructor (String, String, Store, Index, TermVector)

Create a field by specifying its name, value and how it will be saved in the index.

public Field(
string name,
string value_Renamed,
Store store,
Index index,
TermVector termVector
);

Parameters

name
The name of the field
value_Renamed
store
Whether
value
should be stored in the index
index
Whether the field should be indexed, and if so, if it should be tokenized before indexing
termVector
Whether term vector should be stored

See Also

Field Class | Lucene.Net.Documents Namespace | Field Constructor Overload List


Field Constructor (String, TextReader)

Create a tokenized and indexed field that is not stored. Term vectors will not be stored. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until {@link IndexWriter#AddDocument(Document)} has been called.

public Field(
string name,
TextReader reader
);

Parameters

name
The name of the field
reader
The reader with the content

See Also

Field Class | Lucene.Net.Documents Namespace | Field Constructor Overload List


Field Constructor (String, TextReader, TermVector)

Create a tokenized and indexed field that is not stored, optionally with storing term vectors. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until {@link IndexWriter#AddDocument(Document)} has been called.

public Field(
string name,
TextReader reader,
TermVector termVector
);

Parameters

name
The name of the field
reader
The reader with the content
termVector
Whether term vector should be stored

See Also

Field Class | Lucene.Net.Documents Namespace | Field Constructor Overload List


Field Constructor (String, TokenStream)

Create a tokenized and indexed field that is not stored. Term vectors will not be stored. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until {@link IndexWriter#AddDocument(Document)} has been called.

public Field(
string name,
TokenStream tokenStream
);

Parameters

name
The name of the field
tokenStream
The TokenStream with the content

See Also

Field Class | Lucene.Net.Documents Namespace | Field Constructor Overload List


Field Constructor (String, TokenStream, TermVector)

Create a tokenized and indexed field that is not stored, optionally with storing term vectors. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until {@link IndexWriter#AddDocument(Document)} has been called.

public Field(
string name,
TokenStream tokenStream,
TermVector termVector
);

Parameters

name
The name of the field
tokenStream
The TokenStream with the content
termVector
Whether term vector should be stored

See Also

Field Class | Lucene.Net.Documents Namespace | Field Constructor Overload List


Field Constructor (String, Byte[], Store)

Create a stored field with binary value. Optionally the value may be compressed.

public Field(
string name,
byte[] value_Renamed,
Store store
);

Parameters

name
The name of the field
value_Renamed
store
How
value
should be stored (compressed or not)

See Also

Field Class | Lucene.Net.Documents Namespace | Field Constructor Overload List


Field Constructor (String, Byte[], Int32, Int32, Store)

Create a stored field with binary value. Optionally the value may be compressed.

public Field(
string name,
byte[] value_Renamed,
int offset,
int length,
Store store
);

Parameters

name
The name of the field
value_Renamed
offset
length
store
How
value
should be stored (compressed or not)

See Also

Field Class | Lucene.Net.Documents Namespace | Field Constructor Overload List


Field Methods

The methods of the Field class are listed below. For a complete list of Field class members, see the Field Members topic.

Public Instance Methods

BinaryValue | Obsolete. The value of the field in Binary, or null. If null, the Reader value, String value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), GetBinaryValue(), and tokenStreamValue() must be set.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBinaryLength (inherited from AbstractField) | Returns the length of byte[] segment that is used as value. If Field is not binary returned value is undefined.
GetBinaryOffset (inherited from AbstractField) | Returns offset into byte[] segment that is used as value. If Field is not binary returned value is undefined.
GetBinaryValue (inherited from AbstractField) | Overloaded. Return the raw byte[] for the binary field. Note that you must also call {@link #GetBinaryLength} and {@link #GetBinaryOffset} to know which range of bytes in this returned array belong to the field.
GetBoost (inherited from AbstractField)
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOmitNorms (inherited from AbstractField) | True if norms are omitted for this indexed field
GetOmitTf (inherited from AbstractField) | Returns true if tf is omitted for this indexed field.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBinary (inherited from AbstractField) | True iff the value of the filed is stored as binary
IsCompressed (inherited from AbstractField) | True if the value of the field is stored and compressed within the index
IsIndexed (inherited from AbstractField) | True iff the value of the field is to be indexed, so that it may be searched on.
IsLazy (inherited from AbstractField)
IsStored (inherited from AbstractField) | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
IsStoreOffsetWithTermVector (inherited from AbstractField) | True iff terms are stored as term vector together with their offsets (start and end positon in source text).
IsStorePositionWithTermVector (inherited from AbstractField) | True iff terms are stored as term vector together with their token positions.
IsTermVectorStored (inherited from AbstractField) True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
stored
attribute instead.
IsTokenized (inherited from AbstractField) | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Name (inherited from AbstractField) | Returns the name of the field as an interned string. For example "date", "title", "body", ...
ReaderValue | The value of the field as a Reader, or null. If null, the String value, binary value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), getBinaryValue(), and tokenStreamValue() must be set.
SetBoost (inherited from AbstractField)
SetOmitNorms (inherited from AbstractField) | Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
SetOmitTf (inherited from AbstractField) | Expert: If set, omit tf from postings of this indexed field.
SetValue | Overloaded. Expert: change the value of this field. This can be used during indexing to re-use a single Field instance to improve indexing speed by avoiding GC cost of new'ing and reclaiming Field instances. Typically a single {@link Document} instance is re-used as well. This helps most on small documents. Note that you should only use this method after the Field has been consumed (ie, the {@link Document} containing this Field has been added to the index). Also, each Field instance should only be used once within a single {@link Document} instance. See ImproveIndexingSpeed for details.
StringValue | The value of the field as a String, or null. If null, the Reader value, binary value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), getBinaryValue(), and tokenStreamValue() must be set.
TokenStreamValue | The value of the field as a TokesStream, or null. If null, the Reader value, String value, or binary value is used. Exactly one of stringValue(), readerValue(), GetBinaryValue(), and tokenStreamValue() must be set.
ToString (inherited from AbstractField) | Prints a Field for human consumption.

Protected Internal Instance Methods

SetStoreTermVector (inherited from AbstractField)

See Also

Field Class | Lucene.Net.Documents Namespace


Field.BinaryValue Method

NOTE: This method is now obsolete.

This method must allocate a new byte[] if the AbstractField.GetBinaryOffset() is non-zero or AbstractField.GetBinaryLength() is not the full length of the byte[]. Please use AbstractField.GetBinaryValue() instead, which simply returns the byte[].

The value of the field in Binary, or null. If null, the Reader value, String value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), GetBinaryValue(), and tokenStreamValue() must be set.

public override byte[] BinaryValue();

Implements

Fieldable.BinaryValue

See Also

Field Class | Lucene.Net.Documents Namespace


Field.ReaderValue Method

The value of the field as a Reader, or null. If null, the String value, binary value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), getBinaryValue(), and tokenStreamValue() must be set.

public override TextReader ReaderValue();

Implements

Fieldable.ReaderValue

See Also

Field Class | Lucene.Net.Documents Namespace


SetValue Method

Apache Lucene.Net 2.4.0 Class Library API

Field.SetValue Method

Expert: change the value of this field. See setValue(String).

Overload List

Expert: change the value of this field. See setValue(String).

public void SetValue(TokenStream);

Expert: change the value of this field. See setValue(String).

public void SetValue(byte[]);

Expert: change the value of this field. See setValue(String).

public void SetValue(byte[],int,int);

Expert: change the value of this field. See setValue(String).

public void SetValue(TextReader);

Expert: change the value of this field. This can be used during indexing to re-use a single Field instance to improve indexing speed by avoiding GC cost of new'ing and reclaiming Field instances. Typically a single {@link Document} instance is re-used as well. This helps most on small documents. Note that you should only use this method after the Field has been consumed (ie, the {@link Document} containing this Field has been added to the index). Also, each Field instance should only be used once within a single {@link Document} instance. See ImproveIndexingSpeed for details.

public void SetValue(string);

See Also

Field Class | Lucene.Net.Documents Namespace


Field.SetValue Method (TokenStream)

Expert: change the value of this field. See setValue(String).

public void SetValue(
TokenStream value_Renamed
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.SetValue Overload List


Field.SetValue Method (Byte[])

Expert: change the value of this field. See setValue(String).

public void SetValue(
byte[] value_Renamed
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.SetValue Overload List


Field.SetValue Method (Byte[], Int32, Int32)

Expert: change the value of this field. See setValue(String).

public void SetValue(
byte[] value_Renamed,
int offset,
int length
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.SetValue Overload List


Field.SetValue Method (TextReader)

Expert: change the value of this field. See setValue(String).

public void SetValue(
TextReader value_Renamed
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.SetValue Overload List


Field.SetValue Method (String)

Expert: change the value of this field. This can be used during indexing to re-use a single Field instance to improve indexing speed by avoiding GC cost of new'ing and reclaiming Field instances. Typically a single {@link Document} instance is re-used as well. This helps most on small documents.

Note that you should only use this method after the Field has been consumed (ie, the {@link Document} containing this Field has been added to the index). Also, each Field instance should only be used once within a single {@link Document} instance. See ImproveIndexingSpeed for details.

public void SetValue(
string value_Renamed
);

See Also

Field Class | Lucene.Net.Documents Namespace | Field.SetValue Overload List


Field.StringValue Method

The value of the field as a String, or null. If null, the Reader value, binary value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), getBinaryValue(), and tokenStreamValue() must be set.

public override string StringValue();

Implements

Fieldable.StringValue

See Also

Field Class | Lucene.Net.Documents Namespace


Field.TokenStreamValue Method

The value of the field as a TokesStream, or null. If null, the Reader value, String value, or binary value is used. Exactly one of stringValue(), readerValue(), GetBinaryValue(), and tokenStreamValue() must be set.

public override TokenStream TokenStreamValue();

Implements

Fieldable.TokenStreamValue

See Also

Field Class | Lucene.Net.Documents Namespace


Field.Index Class

Specifies whether and how a field should be indexed.

For a list of all members of this type, see Field.Index Members.

System.Object
Lucene.Net.Util.Parameter
Lucene.Net.Documents.Field.Index

public sealed class Field.Index : Parameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Field.Index Members | Lucene.Net.Documents Namespace


Field.Index Members

Field.Index overview

Public Static Fields

ANALYZED | Index the tokens produced by running the field's value through an Analyzer. This is useful for common text.
ANALYZED_NO_NORMS | Expert: Index the tokens produced by running the field's value through an Analyzer, and also separately disable the storing of norms. See {@link #NOT_ANALYZED_NO_NORMS} for what norms are and why you may want to disable them.
NO | Do not index the field value. This field can thus not be searched, but one can still access its contents provided it is {@link Field.Store stored}.
NO_NORMS | Deprecated. This has been renamed to NOT_ANALYZED_NO_NORMS.
NOT_ANALYZED | Index the field's value without using an Analyzer, so it can be searched. As no analyzer is used the value will be stored as a single term. This is useful for unique Ids like product numbers.
NOT_ANALYZED_NO_NORMS | Expert: Index the field's value without an Analyzer, and also disable the storing of norms.. Note that you can also separately enable/disable norms by calling SetOmitNorms(bool). No norms means that index-time field and document boosting and field length normalization are disabled. The benfit is less memory ysage as norms take up one byte of RAM per indexed field for every document in the index, during searching. Note that once you index a given field with norms enabled, disabling norms will have no effect. In other words, for this to have the above described effect on a field, all instances of that field must be indexed with NOT_ANALYZED_NO_NORMS from the beginning.
TOKENIZED | Deprecated. This has been renamed to ANALYZED.
UN_TOKENIZED | Deprecated. This has been renamed to NOT_ANALYZED.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRealObject (inherited from Parameter) |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Parameter) |

Protected Internal Instance Methods

ReadResolve (inherited from Parameter) Resolves the deserialized instance to the local reference for accurate equals() and == comparisons.

See Also

Field.Index Class | Lucene.Net.Documents Namespace


Field.Index Fields

The fields of the Field.Index class are listed below. For a complete list of Field.Index class members, see the Field.Index Members topic.

Public Static Fields

ANALYZED | Index the tokens produced by running the field's value through an Analyzer. This is useful for common text.
ANALYZED_NO_NORMS | Expert: Index the tokens produced by running the field's value through an Analyzer, and also separately disable the storing of norms. See {@link #NOT_ANALYZED_NO_NORMS} for what norms are and why you may want to disable them.
NO | Do not index the field value. This field can thus not be searched, but one can still access its contents provided it is {@link Field.Store stored}.
NO_NORMS | Deprecated. This has been renamed to NOT_ANALYZED_NO_NORMS.
NOT_ANALYZED | Index the field's value without using an Analyzer, so it can be searched. As no analyzer is used the value will be stored as a single term. This is useful for unique Ids like product numbers.
NOT_ANALYZED_NO_NORMS | Expert: Index the field's value without an Analyzer, and also disable the storing of norms.. Note that you can also separately enable/disable norms by calling SetOmitNorms(bool). No norms means that index-time field and document boosting and field length normalization are disabled. The benfit is less memory ysage as norms take up one byte of RAM per indexed field for every document in the index, during searching. Note that once you index a given field with norms enabled, disabling norms will have no effect. In other words, for this to have the above described effect on a field, all instances of that field must be indexed with NOT_ANALYZED_NO_NORMS from the beginning.
TOKENIZED | Deprecated. This has been renamed to ANALYZED.
UN_TOKENIZED | Deprecated. This has been renamed to NOT_ANALYZED.

See Also

Field.Index Class | Lucene.Net.Documents Namespace


Field.Index.ANALYZED Field

Index the tokens produced by running the field's value through an Analyzer. This is useful for common text.

public static readonly Index ANALYZED;

See Also

Field.Index Class | Lucene.Net.Documents Namespace


Field.Index.ANALYZED_NO_NORMS Field

Expert: Index the tokens produced by running the field's value through an Analyzer, and also separately disable the storing of norms. See {@link #NOT_ANALYZED_NO_NORMS} for what norms are and why you may want to disable them.

public static readonly Index ANALYZED_NO_NORMS;

See Also

Field.Index Class | Lucene.Net.Documents Namespace


Field.Index.NO Field

Do not index the field value. This field can thus not be searched, but one can still access its contents provided it is {@link Field.Store stored}.

public static readonly Index NO;

See Also

Field.Index Class | Lucene.Net.Documents Namespace


Field.Index.NO_NORMS Field

Deprecated. This has been renamed to NOT_ANALYZED_NO_NORMS.

public static readonly Index NO_NORMS;

See Also

Field.Index Class | Lucene.Net.Documents Namespace


Field.Index.NOT_ANALYZED Field

Index the field's value without using an Analyzer, so it can be searched. As no analyzer is used the value will be stored as a single term. This is useful for unique Ids like product numbers.

public static readonly Index NOT_ANALYZED;

See Also

Field.Index Class | Lucene.Net.Documents Namespace


Field.Index.NOT_ANALYZED_NO_NORMS Field

Expert: Index the field's value without an Analyzer, and also disable the storing of norms.. Note that you can also separately enable/disable norms by calling SetOmitNorms(bool). No norms means that index-time field and document boosting and field length normalization are disabled. The benfit is less memory ysage as norms take up one byte of RAM per indexed field for every document in the index, during searching. Note that once you index a given field with norms enabled, disabling norms will have no effect. In other words, for this to have the above described effect on a field, all instances of that field must be indexed with NOT_ANALYZED_NO_NORMS from the beginning.

public static readonly Index NOT_ANALYZED_NO_NORMS;

See Also

Field.Index Class | Lucene.Net.Documents Namespace


Field.Index.TOKENIZED Field

Deprecated. This has been renamed to ANALYZED.

public static readonly Index TOKENIZED;

See Also

Field.Index Class | Lucene.Net.Documents Namespace


Field.Index.UN_TOKENIZED Field

Deprecated. This has been renamed to NOT_ANALYZED.

public static readonly Index UN_TOKENIZED;

See Also

Field.Index Class | Lucene.Net.Documents Namespace


Field.Store Class

Specifies whether and how a field should be stored.

For a list of all members of this type, see Field.Store Members.

System.Object
Lucene.Net.Util.Parameter
Lucene.Net.Documents.Field.Store

public sealed class Field.Store : Parameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Field.Store Members | Lucene.Net.Documents Namespace


Field.Store Members

Field.Store overview

Public Static Fields

COMPRESS | Store the original field value in the index in a compressed form. This is useful for long documents and for binary valued fields.
NO | Do not store the field value in the index.
YES | Store the original field value in the index. This is useful for short texts like a document's title which should be displayed with the results. The value is stored in its original form, i.e. no analyzer is used before it is stored.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRealObject (inherited from Parameter) |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Parameter) |

Protected Internal Instance Methods

ReadResolve (inherited from Parameter) Resolves the deserialized instance to the local reference for accurate equals() and == comparisons.

See Also

Field.Store Class | Lucene.Net.Documents Namespace


Field.Store Fields

The fields of the Field.Store class are listed below. For a complete list of Field.Store class members, see the Field.Store Members topic.

Public Static Fields

COMPRESS | Store the original field value in the index in a compressed form. This is useful for long documents and for binary valued fields.
NO | Do not store the field value in the index.
YES | Store the original field value in the index. This is useful for short texts like a document's title which should be displayed with the results. The value is stored in its original form, i.e. no analyzer is used before it is stored.

See Also

Field.Store Class | Lucene.Net.Documents Namespace


Field.Store.COMPRESS Field

Store the original field value in the index in a compressed form. This is useful for long documents and for binary valued fields.

public static readonly Store COMPRESS;

See Also

Field.Store Class | Lucene.Net.Documents Namespace


Field.Store.NO Field

Do not store the field value in the index.

public static readonly Store NO;

See Also

Field.Store Class | Lucene.Net.Documents Namespace


Field.Store.YES Field

Store the original field value in the index. This is useful for short texts like a document's title which should be displayed with the results. The value is stored in its original form, i.e. no analyzer is used before it is stored.

public static readonly Store YES;

See Also

Field.Store Class | Lucene.Net.Documents Namespace


Field.TermVector Class

Specifies whether and how a field should have term vectors.

For a list of all members of this type, see Field.TermVector Members.

System.Object
Lucene.Net.Util.Parameter
Lucene.Net.Documents.Field.TermVector

public sealed class Field.TermVector : Parameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Field.TermVector Members | Lucene.Net.Documents Namespace


Field.TermVector Members

Field.TermVector overview

Public Static Fields

NO | Do not store term vectors.
WITH_OFFSETS | Store the term vector + Token offset information
WITH_POSITIONS | Store the term vector + token position information
WITH_POSITIONS_OFFSETS | Store the term vector + Token position and offset information
YES | Store the term vectors of each document. A term vector is a list of the document's terms and their number of occurences in that document.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRealObject (inherited from Parameter) |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Parameter) |

Protected Internal Instance Methods

ReadResolve (inherited from Parameter) Resolves the deserialized instance to the local reference for accurate equals() and == comparisons.

See Also

Field.TermVector Class | Lucene.Net.Documents Namespace


Field.TermVector Fields

The fields of the Field.TermVector class are listed below. For a complete list of Field.TermVector class members, see the Field.TermVector Members topic.

Public Static Fields

NO | Do not store term vectors.
WITH_OFFSETS | Store the term vector + Token offset information
WITH_POSITIONS | Store the term vector + token position information
WITH_POSITIONS_OFFSETS | Store the term vector + Token position and offset information
YES | Store the term vectors of each document. A term vector is a list of the document's terms and their number of occurences in that document.

See Also

Field.TermVector Class | Lucene.Net.Documents Namespace


Field.TermVector.NO Field

Do not store term vectors.

public static readonly TermVector NO;

See Also

Field.TermVector Class | Lucene.Net.Documents Namespace


Field.TermVector.WITH_OFFSETS Field

Store the term vector + Token offset information

public static readonly TermVector WITH_OFFSETS;

See Also

Field.TermVector Class | Lucene.Net.Documents Namespace | #YES


Field.TermVector.WITH_POSITIONS Field

Store the term vector + token position information

public static readonly TermVector WITH_POSITIONS;

See Also

Field.TermVector Class | Lucene.Net.Documents Namespace | #YES


Field.TermVector.WITH_POSITIONS_OFFSETS Field

Store the term vector + Token position and offset information

public static readonly TermVector WITH_POSITIONS_OFFSETS;

See Also

Field.TermVector Class | Lucene.Net.Documents Namespace | #YES | #WITH_POSITIONS | #WITH_OFFSETS


Field.TermVector.YES Field

Store the term vectors of each document. A term vector is a list of the document's terms and their number of occurences in that document.

public static readonly TermVector YES;

See Also

Field.TermVector Class | Lucene.Net.Documents Namespace


Fieldable Interface

Synonymous with {@link Field}.

WARNING: This interface may change within minor versions, despite Lucene's backward compatibility requirements. This means new methods may be added from version to version. This change only affects the Fieldable API; other backwards compatibility promises remain intact. For example, Lucene can still read and write indices created within the same major version.

For a list of all members of this type, see Fieldable Members.

public interface Fieldable

Types that implement Fieldable

Type | Description
AbstractField |
Field | A field is a section of a Document. Each field has two parts, a name and a value. Values may be free text, provided as a String or as a Reader, or they may be atomic keywords, which are not further processed. Such keywords may be used to represent dates, urls, etc. Fields are optionally stored in the index, so that they may be returned with hits on the document.
FieldsReader.FieldForMerge |

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Fieldable Members | Lucene.Net.Documents Namespace


Fieldable Members

Fieldable overview

Public Instance Methods

BinaryValue | The value of the field in Binary, or null. If null, the Reader value, String value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), binaryValue(), and tokenStreamValue() must be set.
GetBinaryLength | Returns the of byte][ segment that is used as value. If Fields is not binarythe returned value is undefined.
GetBinaryOffset | Returns the offset into the byte[] segment that is used as value. If Fields is not binary returned value is undefined.
GetBinaryValue | Overloaded. Return the raw byte[] for the vinary field. Note that you must also call GetBinaryLength() and GetBinaryOffset() to know which range of bytes in the returned array belong to this Field.
GetBoost
GetOmitNorms | True if norms are omitted for this indexed field
GetOmitTf | True if tf is omitted for this indexed field.
IsBinary | True iff the value of the filed is stored as binary
IsCompressed | True if the value of the field is stored and compressed within the index
IsIndexed | True iff the value of the field is to be indexed, so that it may be searched on.
IsLazy | Indicates whether a Field is Lazy or not. The semantics of Lazy loading are such that if a Field is lazily loaded, retrieving it's values via {@link #StringValue()} or {@link #BinaryValue()} is only valid as long as the {@link Lucene.Net.Index.IndexReader} that retrieved the {@link Document} is still open.
IsStored | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
IsStoreOffsetWithTermVector | True iff terms are stored as term vector together with their offsets (start and end positon in source text).
IsStorePositionWithTermVector | True iff terms are stored as term vector together with their token positions.
IsTermVectorStored True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
stored
attribute instead.
IsTokenized | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Name | Returns the name of the field as an interned string. For example "date", "title", "body", ...
ReaderValue | The value of the field as a Reader, or null. If null, the String value, binary value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), binaryValue(), and tokenStreamValue() must be set.
SetBoost
SetOmitNorms | Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
SetOmitTf | Expert: If set, omit term freq, positions, and payloads from postings for this field for this field.
StringValue | The value of the field as a String, or null. If null, the Reader value, binary value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), binaryValue(), and tokenStreamValue() must be set.
TokenStreamValue | The value of the field as a TokenStream, or null. If null, the Reader value, String value, or binary value is used. Exactly one of stringValue(), readerValue(), binaryValue(), and tokenStreamValue() must be set.

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable Methods

The methods of the Fieldable interface are listed below. For a complete list of Fieldable interface members, see the Fieldable Members topic.

Public Instance Methods

BinaryValue | The value of the field in Binary, or null. If null, the Reader value, String value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), binaryValue(), and tokenStreamValue() must be set.
GetBinaryLength | Returns the of byte][ segment that is used as value. If Fields is not binarythe returned value is undefined.
GetBinaryOffset | Returns the offset into the byte[] segment that is used as value. If Fields is not binary returned value is undefined.
GetBinaryValue | Overloaded. Return the raw byte[] for the vinary field. Note that you must also call GetBinaryLength() and GetBinaryOffset() to know which range of bytes in the returned array belong to this Field.
GetBoost
GetOmitNorms | True if norms are omitted for this indexed field
GetOmitTf | True if tf is omitted for this indexed field.
IsBinary | True iff the value of the filed is stored as binary
IsCompressed | True if the value of the field is stored and compressed within the index
IsIndexed | True iff the value of the field is to be indexed, so that it may be searched on.
IsLazy | Indicates whether a Field is Lazy or not. The semantics of Lazy loading are such that if a Field is lazily loaded, retrieving it's values via {@link #StringValue()} or {@link #BinaryValue()} is only valid as long as the {@link Lucene.Net.Index.IndexReader} that retrieved the {@link Document} is still open.
IsStored | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
IsStoreOffsetWithTermVector | True iff terms are stored as term vector together with their offsets (start and end positon in source text).
IsStorePositionWithTermVector | True iff terms are stored as term vector together with their token positions.
IsTermVectorStored True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
stored
attribute instead.
IsTokenized | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Name | Returns the name of the field as an interned string. For example "date", "title", "body", ...
ReaderValue | The value of the field as a Reader, or null. If null, the String value, binary value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), binaryValue(), and tokenStreamValue() must be set.
SetBoost
SetOmitNorms | Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
SetOmitTf | Expert: If set, omit term freq, positions, and payloads from postings for this field for this field.
StringValue | The value of the field as a String, or null. If null, the Reader value, binary value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), binaryValue(), and tokenStreamValue() must be set.
TokenStreamValue | The value of the field as a TokenStream, or null. If null, the Reader value, String value, or binary value is used. Exactly one of stringValue(), readerValue(), binaryValue(), and tokenStreamValue() must be set.

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.BinaryValue Method

The value of the field in Binary, or null. If null, the Reader value, String value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), binaryValue(), and tokenStreamValue() must be set.

byte[] BinaryValue();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.GetBinaryLength Method

Returns the of byte][ segment that is used as value. If Fields is not binarythe returned value is undefined.

int GetBinaryLength();

Return Value

length of byte[] segment that represents this Field value

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.GetBinaryOffset Method

Returns the offset into the byte[] segment that is used as value. If Fields is not binary returned value is undefined.

int GetBinaryOffset();

Return Value

index of the first byte in segment that represents this Field value

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


GetBinaryValue Method

Apache Lucene.Net 2.4.0 Class Library API

Fieldable.GetBinaryValue Method

Return the raw byte[] for the vinary field. Note that you must also call GetBinaryLength() and GetBinaryOffset() to know which range of bytes in the returned array belong to this Field.

Overload List

Return the raw byte[] for the vinary field. Note that you must also call GetBinaryLength() and GetBinaryOffset() to know which range of bytes in the returned array belong to this Field.

byte[] GetBinaryValue();

Return the raw byte[] for the vinary field. Note that you must also call GetBinaryLength() and GetBinaryOffset() to know which range of bytes in the returned array belong to this Field. About reuse: if you pass in the result byte[] and it is used, it is likely the underlying implementation will hold onto this byte[] and return it in future calls to BinaryValue() of GetBinaryValue(). So if you subsequently re-use the same byte[] elsewhere it will alter this Fieldable's value.

byte[] GetBinaryValue(byte[]);

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.GetBinaryValue Method ()

Return the raw byte[] for the vinary field. Note that you must also call GetBinaryLength() and GetBinaryOffset() to know which range of bytes in the returned array belong to this Field.

byte[] GetBinaryValue();

Return Value

refererence to the Field value as byte

See Also

Fieldable Interface | Lucene.Net.Documents Namespace | Fieldable.GetBinaryValue Overload List


Fieldable.GetBinaryValue Method (Byte[])

Return the raw byte[] for the vinary field. Note that you must also call GetBinaryLength() and GetBinaryOffset() to know which range of bytes in the returned array belong to this Field. About reuse: if you pass in the result byte[] and it is used, it is likely the underlying implementation will hold onto this byte[] and return it in future calls to BinaryValue() of GetBinaryValue(). So if you subsequently re-use the same byte[] elsewhere it will alter this Fieldable's value.

byte[] GetBinaryValue(
byte[] result
);

Parameters

result
user defined buffer that will be used if non-null and large enough to contain the Field value

Return Value

See Also

Fieldable Interface | Lucene.Net.Documents Namespace | Fieldable.GetBinaryValue Overload List


Fieldable.GetBoost Method

float GetBoost();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.GetOmitNorms Method

True if norms are omitted for this indexed field

bool GetOmitNorms();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.GetOmitTf Method

True if tf is omitted for this indexed field.

bool GetOmitTf();

Return Value

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.IsBinary Method

True iff the value of the filed is stored as binary

bool IsBinary();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.IsCompressed Method

True if the value of the field is stored and compressed within the index

bool IsCompressed();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.IsIndexed Method

True iff the value of the field is to be indexed, so that it may be searched on.

bool IsIndexed();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.IsLazy Method

Indicates whether a Field is Lazy or not. The semantics of Lazy loading are such that if a Field is lazily loaded, retrieving it's values via {@link #StringValue()} or {@link #BinaryValue()} is only valid as long as the {@link Lucene.Net.Index.IndexReader} that retrieved the {@link Document} is still open.

bool IsLazy();

Return Value

true if this field can be loaded lazily

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.IsStored Method

True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.

bool IsStored();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.IsStoreOffsetWithTermVector Method

True iff terms are stored as term vector together with their offsets (start and end positon in source text).

bool IsStoreOffsetWithTermVector();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.IsStorePositionWithTermVector Method

True iff terms are stored as term vector together with their token positions.

bool IsStorePositionWithTermVector();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.IsTermVectorStored Method

True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the

stored
attribute instead.

bool IsTermVectorStored();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace |


Fieldable.IsTokenized Method

True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.

bool IsTokenized();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.Name Method

Returns the name of the field as an interned string. For example "date", "title", "body", ...

string Name();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.ReaderValue Method

The value of the field as a Reader, or null. If null, the String value, binary value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), binaryValue(), and tokenStreamValue() must be set.

TextReader ReaderValue();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.SetBoost Method

void SetBoost(
float boost
);

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.SetOmitNorms Method

Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.

void SetOmitNorms(
bool omitNorms
);

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.SetOmitTf Method

Expert: If set, omit term freq, positions, and payloads from postings for this field for this field.

void SetOmitTf(
bool omitTf
);

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.StringValue Method

The value of the field as a String, or null. If null, the Reader value, binary value, or TokenStream value is used. Exactly one of stringValue(), readerValue(), binaryValue(), and tokenStreamValue() must be set.

string StringValue();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


Fieldable.TokenStreamValue Method

The value of the field as a TokenStream, or null. If null, the Reader value, String value, or binary value is used. Exactly one of stringValue(), readerValue(), binaryValue(), and tokenStreamValue() must be set.

TokenStream TokenStreamValue();

See Also

Fieldable Interface | Lucene.Net.Documents Namespace


FieldSelector Interface

Similar to a {@link java.io.FileFilter}, the FieldSelector allows one to make decisions about what Fields get loaded on a {@link Document} by {@link Lucene.Net.Index.IndexReader#Document(int,Lucene.Net.Documents.FieldSelector)}

For a list of all members of this type, see FieldSelector Members.

public interface FieldSelector

Types that implement FieldSelector

Type | Description
LoadFirstFieldSelector | Load the First field and break. See {@link FieldSelectorResult#LOAD_AND_BREAK}
MapFieldSelector | A FieldSelector based on a Map of field names to FieldSelectorResults
SetBasedFieldSelector | Declare what fields to load normally and what fields to load lazily

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldSelector Members | Lucene.Net.Documents Namespace


FieldSelector Members

FieldSelector overview

Public Instance Methods

Accept

See Also

FieldSelector Interface | Lucene.Net.Documents Namespace


FieldSelector Methods

The methods of the FieldSelector interface are listed below. For a complete list of FieldSelector interface members, see the FieldSelector Members topic.

Public Instance Methods

Accept

See Also

FieldSelector Interface | Lucene.Net.Documents Namespace


FieldSelector.Accept Method

FieldSelectorResult Accept(
string fieldName
);

Parameters

fieldName
the field to accept or reject

Return Value

an instance of {@link FieldSelectorResult} if the {@link Field} named

fieldName
should be loaded.

See Also

FieldSelector Interface | Lucene.Net.Documents Namespace


FieldSelectorResult Class

Provides information about what should be done with this Field

For a list of all members of this type, see FieldSelectorResult Members.

System.Object
Lucene.Net.Documents.FieldSelectorResult

public sealed class FieldSelectorResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldSelectorResult Members | Lucene.Net.Documents Namespace


FieldSelectorResult Members

FieldSelectorResult overview

Public Static Fields

LAZY_LOAD | Lazily load this {@link Field}. This means the {@link Field} is valid, but it may not actually contain its data until invoked. {@link Document#GetField(String)} SHOULD NOT BE USED. {@link Document#GetFieldable(String)} is safe to use and should return a valid instance of a {@link Fieldable}. {@link Document#Add(Fieldable)} should be called by the Reader.
LOAD | Load this {@link Field} every time the {@link Document} is loaded, reading in the data as it is encounterd. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should not return null. {@link Document#Add(Fieldable)} should be called by the Reader.
LOAD_AND_BREAK | Load this field as in the {@link #LOAD} case, but immediately return from {@link Field} loading for the {@link Document}. Thus, the Document may not have its complete set of Fields. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should both be valid for this {@link Field} {@link Document#Add(Fieldable)} should be called by the Reader.
LOAD_FOR_MERGE | Behaves much like {@link #LOAD} but does not uncompress any compressed data. This is used for internal purposes. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should not return null. {@link Document#Add(Fieldable)} should be called by the Reader.
NO_LOAD | Do not load the {@link Field}. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should return null. {@link Document#Add(Fieldable)} is not called. {@link Document#Add(Fieldable)} should not be called by the Reader.
SIZE | Expert: Load the size of this {@link Field} rather than its value. Size is measured as number of bytes required to store the field == bytes for a binary or any compressed value, and 2*chars for a String value. The size is stored as a binary value, represented as an int in a byte[], with the higher order byte first in [0]
SIZE_AND_BREAK | Expert: Like {@link #SIZE} but immediately break from the field loading loop, i.e., stop loading further fields, after the size is loaded

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FieldSelectorResult Class | Lucene.Net.Documents Namespace


FieldSelectorResult Fields

The fields of the FieldSelectorResult class are listed below. For a complete list of FieldSelectorResult class members, see the FieldSelectorResult Members topic.

Public Static Fields

LAZY_LOAD | Lazily load this {@link Field}. This means the {@link Field} is valid, but it may not actually contain its data until invoked. {@link Document#GetField(String)} SHOULD NOT BE USED. {@link Document#GetFieldable(String)} is safe to use and should return a valid instance of a {@link Fieldable}. {@link Document#Add(Fieldable)} should be called by the Reader.
LOAD | Load this {@link Field} every time the {@link Document} is loaded, reading in the data as it is encounterd. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should not return null. {@link Document#Add(Fieldable)} should be called by the Reader.
LOAD_AND_BREAK | Load this field as in the {@link #LOAD} case, but immediately return from {@link Field} loading for the {@link Document}. Thus, the Document may not have its complete set of Fields. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should both be valid for this {@link Field} {@link Document#Add(Fieldable)} should be called by the Reader.
LOAD_FOR_MERGE | Behaves much like {@link #LOAD} but does not uncompress any compressed data. This is used for internal purposes. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should not return null. {@link Document#Add(Fieldable)} should be called by the Reader.
NO_LOAD | Do not load the {@link Field}. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should return null. {@link Document#Add(Fieldable)} is not called. {@link Document#Add(Fieldable)} should not be called by the Reader.
SIZE | Expert: Load the size of this {@link Field} rather than its value. Size is measured as number of bytes required to store the field == bytes for a binary or any compressed value, and 2*chars for a String value. The size is stored as a binary value, represented as an int in a byte[], with the higher order byte first in [0]
SIZE_AND_BREAK | Expert: Like {@link #SIZE} but immediately break from the field loading loop, i.e., stop loading further fields, after the size is loaded

See Also

FieldSelectorResult Class | Lucene.Net.Documents Namespace


FieldSelectorResult.LAZY_LOAD Field

Lazily load this {@link Field}. This means the {@link Field} is valid, but it may not actually contain its data until invoked. {@link Document#GetField(String)} SHOULD NOT BE USED. {@link Document#GetFieldable(String)} is safe to use and should return a valid instance of a {@link Fieldable}.

{@link Document#Add(Fieldable)} should be called by the Reader.
public static readonly FieldSelectorResult LAZY_LOAD;

See Also

FieldSelectorResult Class | Lucene.Net.Documents Namespace


FieldSelectorResult.LOAD Field

Load this {@link Field} every time the {@link Document} is loaded, reading in the data as it is encounterd. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should not return null.

{@link Document#Add(Fieldable)} should be called by the Reader.
public static readonly FieldSelectorResult LOAD;

See Also

FieldSelectorResult Class | Lucene.Net.Documents Namespace


FieldSelectorResult.LOAD_AND_BREAK Field

Load this field as in the {@link #LOAD} case, but immediately return from {@link Field} loading for the {@link Document}. Thus, the Document may not have its complete set of Fields. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should both be valid for this {@link Field}

{@link Document#Add(Fieldable)} should be called by the Reader.
public static readonly FieldSelectorResult LOAD_AND_BREAK;

See Also

FieldSelectorResult Class | Lucene.Net.Documents Namespace


FieldSelectorResult.LOAD_FOR_MERGE Field

Behaves much like {@link #LOAD} but does not uncompress any compressed data. This is used for internal purposes. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should not return null.

{@link Document#Add(Fieldable)} should be called by the Reader.
public static readonly FieldSelectorResult LOAD_FOR_MERGE;

See Also

FieldSelectorResult Class | Lucene.Net.Documents Namespace


FieldSelectorResult.NO_LOAD Field

Do not load the {@link Field}. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should return null. {@link Document#Add(Fieldable)} is not called.

{@link Document#Add(Fieldable)} should not be called by the Reader.
public static readonly FieldSelectorResult NO_LOAD;

See Also

FieldSelectorResult Class | Lucene.Net.Documents Namespace


FieldSelectorResult.SIZE Field

Expert: Load the size of this {@link Field} rather than its value. Size is measured as number of bytes required to store the field == bytes for a binary or any compressed value, and 2*chars for a String value. The size is stored as a binary value, represented as an int in a byte[], with the higher order byte first in [0]

public static readonly FieldSelectorResult SIZE;

See Also

FieldSelectorResult Class | Lucene.Net.Documents Namespace


FieldSelectorResult.SIZE_AND_BREAK Field

Expert: Like {@link #SIZE} but immediately break from the field loading loop, i.e., stop loading further fields, after the size is loaded

public static readonly FieldSelectorResult SIZE_AND_BREAK;

See Also

FieldSelectorResult Class | Lucene.Net.Documents Namespace


FieldSelectorResult Methods

The methods of the FieldSelectorResult class are listed below. For a complete list of FieldSelectorResult class members, see the FieldSelectorResult Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FieldSelectorResult Class | Lucene.Net.Documents Namespace


FieldSelectorResult.Equals Method

public override bool Equals(
object o
);

See Also

FieldSelectorResult Class | Lucene.Net.Documents Namespace


FieldSelectorResult.GetHashCode Method

public override int GetHashCode();

See Also

FieldSelectorResult Class | Lucene.Net.Documents Namespace


LoadFirstFieldSelector Class

Load the First field and break.

See {@link FieldSelectorResult#LOAD_AND_BREAK}

For a list of all members of this type, see LoadFirstFieldSelector Members.

System.Object
Lucene.Net.Documents.LoadFirstFieldSelector

public class LoadFirstFieldSelector : FieldSelector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LoadFirstFieldSelector Members | Lucene.Net.Documents Namespace


LoadFirstFieldSelector Members

LoadFirstFieldSelector overview

Public Instance Constructors

LoadFirstFieldSelector Constructor Initializes a new instance of the LoadFirstFieldSelector class.

Public Instance Methods

Accept |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LoadFirstFieldSelector Class | Lucene.Net.Documents Namespace


LoadFirstFieldSelector Constructor

Initializes a new instance of the LoadFirstFieldSelector class.

public LoadFirstFieldSelector();

See Also

LoadFirstFieldSelector Class | Lucene.Net.Documents Namespace


LoadFirstFieldSelector Methods

The methods of the LoadFirstFieldSelector class are listed below. For a complete list of LoadFirstFieldSelector class members, see the LoadFirstFieldSelector Members topic.

Public Instance Methods

Accept |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LoadFirstFieldSelector Class | Lucene.Net.Documents Namespace


LoadFirstFieldSelector.Accept Method

public virtual FieldSelectorResult Accept(
string fieldName
);

Implements

FieldSelector.Accept

See Also

LoadFirstFieldSelector Class | Lucene.Net.Documents Namespace


MapFieldSelector Class

A FieldSelector based on a Map of field names to FieldSelectorResults

For a list of all members of this type, see MapFieldSelector Members.

System.Object
Lucene.Net.Documents.MapFieldSelector

public class MapFieldSelector : FieldSelector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MapFieldSelector Members | Lucene.Net.Documents Namespace


MapFieldSelector Members

MapFieldSelector overview

Public Instance Constructors

MapFieldSelector Overloaded. Initializes a new instance of the MapFieldSelector class.

Public Instance Methods

Accept | Load field according to its associated value in fieldSelections
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapFieldSelector Class | Lucene.Net.Documents Namespace


MapFieldSelector Constructor

Create a a MapFieldSelector

Overload List

Create a a MapFieldSelector

public MapFieldSelector(IDictionary);

Create a a MapFieldSelector

public MapFieldSelector(IList);

Create a a MapFieldSelector

public MapFieldSelector(string[]);

See Also

MapFieldSelector Class | Lucene.Net.Documents Namespace


MapFieldSelector Constructor (IDictionary)

Create a a MapFieldSelector

public MapFieldSelector(
IDictionary fieldSelections
);

Parameters

fieldSelections
maps from field names (String) to FieldSelectorResults

See Also

MapFieldSelector Class | Lucene.Net.Documents Namespace | MapFieldSelector Constructor Overload List


MapFieldSelector Constructor (IList)

Create a a MapFieldSelector

public MapFieldSelector(
IList fields
);

Parameters

fields
fields to LOAD. List of Strings. All other fields are NO_LOAD.

See Also

MapFieldSelector Class | Lucene.Net.Documents Namespace | MapFieldSelector Constructor Overload List


MapFieldSelector Constructor (String[])

Create a a MapFieldSelector

public MapFieldSelector(
string[] fields
);

Parameters

fields
fields to LOAD. All other fields are NO_LOAD.

See Also

MapFieldSelector Class | Lucene.Net.Documents Namespace | MapFieldSelector Constructor Overload List


MapFieldSelector Methods

The methods of the MapFieldSelector class are listed below. For a complete list of MapFieldSelector class members, see the MapFieldSelector Members topic.

Public Instance Methods

Accept | Load field according to its associated value in fieldSelections
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapFieldSelector Class | Lucene.Net.Documents Namespace


MapFieldSelector.Accept Method

Load field according to its associated value in fieldSelections

public virtual FieldSelectorResult Accept(
string field
);

Parameters

field
a field name

Return Value

the fieldSelections value that field maps to or NO_LOAD if none.

Implements

FieldSelector.Accept

See Also

MapFieldSelector Class | Lucene.Net.Documents Namespace


NumberTools Class

For a list of all members of this type, see NumberTools Members.

System.Object
Lucene.Net.Documents.NumberTools

public class NumberTools

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

NumberTools Members | Lucene.Net.Documents Namespace


NumberTools Members

NumberTools overview

Public Static Fields

MAX_STRING_VALUE | Equivalent to longToString(Long.MAX_VALUE)
MIN_STRING_VALUE | Equivalent to longToString(Long.MIN_VALUE)
STR_SIZE | The length of (all) strings returned by {@link #longToString}

Public Static Methods

LongToString | Converts a long to a String suitable for indexing.
StringToLong | Converts a String that was returned by {@link #longToString} back to a long.
ToLong |
ToString | Overloaded.

Public Instance Constructors

NumberTools Constructor Initializes a new instance of the NumberTools class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NumberTools Class | Lucene.Net.Documents Namespace


NumberTools Constructor

Initializes a new instance of the NumberTools class.

public NumberTools();

See Also

NumberTools Class | Lucene.Net.Documents Namespace


NumberTools Fields

The fields of the NumberTools class are listed below. For a complete list of NumberTools class members, see the NumberTools Members topic.

Public Static Fields

MAX_STRING_VALUE | Equivalent to longToString(Long.MAX_VALUE)
MIN_STRING_VALUE | Equivalent to longToString(Long.MIN_VALUE)
STR_SIZE | The length of (all) strings returned by {@link #longToString}

See Also

NumberTools Class | Lucene.Net.Documents Namespace


NumberTools.MAX_STRING_VALUE Field

Equivalent to longToString(Long.MAX_VALUE)

public static readonly string MAX_STRING_VALUE;

See Also

NumberTools Class | Lucene.Net.Documents Namespace


NumberTools.MIN_STRING_VALUE Field

Equivalent to longToString(Long.MIN_VALUE)

public static readonly string MIN_STRING_VALUE;

See Also

NumberTools Class | Lucene.Net.Documents Namespace


NumberTools.STR_SIZE Field

The length of (all) strings returned by {@link #longToString}

public static readonly int STR_SIZE;

See Also

NumberTools Class | Lucene.Net.Documents Namespace


NumberTools Methods

The methods of the NumberTools class are listed below. For a complete list of NumberTools class members, see the NumberTools Members topic.

Public Static Methods

LongToString | Converts a long to a String suitable for indexing.
StringToLong | Converts a String that was returned by {@link #longToString} back to a long.
ToLong |
ToString | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NumberTools Class | Lucene.Net.Documents Namespace


NumberTools.LongToString Method

Converts a long to a String suitable for indexing.

public static string LongToString(
long l
);

See Also

NumberTools Class | Lucene.Net.Documents Namespace


NumberTools.StringToLong Method

Converts a String that was returned by {@link #longToString} back to a long.

public static long StringToLong(
string str
);

See Also

NumberTools Class | Lucene.Net.Documents Namespace


NumberTools.ToLong Method

public static long ToLong(
string t
);

See Also

NumberTools Class | Lucene.Net.Documents Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

NumberTools.ToString Method

Overload List

Inherited from Object.

public virtual string ToString();

public static string ToString(long);

See Also

NumberTools Class | Lucene.Net.Documents Namespace


NumberTools.ToString Method (Int64)

public static string ToString(
long lval
);

See Also

NumberTools Class | Lucene.Net.Documents Namespace | NumberTools.ToString Overload List


SetBasedFieldSelector Class

Declare what fields to load normally and what fields to load lazily

For a list of all members of this type, see SetBasedFieldSelector Members.

System.Object
Lucene.Net.Documents.SetBasedFieldSelector

public class SetBasedFieldSelector : FieldSelector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Documents

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SetBasedFieldSelector Members | Lucene.Net.Documents Namespace


SetBasedFieldSelector Members

SetBasedFieldSelector overview

Public Instance Constructors

SetBasedFieldSelector Constructor Pass in the Set of {@link Field} names to load and the Set of {@link Field} names to load lazily. If both are null, the Document will not have any {@link Field} on it.

Public Instance Methods

Accept Indicate whether to load the field with the given name or not. If the {@link Field#Name()} is not in either of the initializing Sets, then {@link Lucene.Net.Documents.FieldSelectorResult#NO_LOAD} is returned. If a Field name is in both
fieldsToLoad
and
lazyFieldsToLoad
, lazy has precedence.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetBasedFieldSelector Class | Lucene.Net.Documents Namespace


SetBasedFieldSelector Constructor

Pass in the Set of {@link Field} names to load and the Set of {@link Field} names to load lazily. If both are null, the Document will not have any {@link Field} on it.

public SetBasedFieldSelector(
Hashtable fieldsToLoad,
Hashtable lazyFieldsToLoad
);

Parameters

fieldsToLoad
A Set of {@link String} field names to load. May be empty, but not null
lazyFieldsToLoad
A Set of {@link String} field names to load lazily. May be empty, but not null

See Also

SetBasedFieldSelector Class | Lucene.Net.Documents Namespace


SetBasedFieldSelector Methods

The methods of the SetBasedFieldSelector class are listed below. For a complete list of SetBasedFieldSelector class members, see the SetBasedFieldSelector Members topic.

Public Instance Methods

Accept Indicate whether to load the field with the given name or not. If the {@link Field#Name()} is not in either of the initializing Sets, then {@link Lucene.Net.Documents.FieldSelectorResult#NO_LOAD} is returned. If a Field name is in both
fieldsToLoad
and
lazyFieldsToLoad
, lazy has precedence.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetBasedFieldSelector Class | Lucene.Net.Documents Namespace


SetBasedFieldSelector.Accept Method

Indicate whether to load the field with the given name or not. If the {@link Field#Name()} is not in either of the initializing Sets, then {@link Lucene.Net.Documents.FieldSelectorResult#NO_LOAD} is returned. If a Field name is in both

fieldsToLoad
and
lazyFieldsToLoad
, lazy has precedence.

public virtual FieldSelectorResult Accept(
string fieldName
);

Parameters

fieldName
The {@link Field} name to check

Return Value

The {@link FieldSelectorResult}

Implements

FieldSelector.Accept

See Also

SetBasedFieldSelector Class | Lucene.Net.Documents Namespace


Lucene.Net.Index

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Index Namespace

Namespace hierarchy

Classes

Class | Description
ByteBlockPool | Class that Posting and PostingVector use to write byte streams into shared fixed-size byte[] arrays. The idea is to allocate slices of increasing lengths For example, the first slice is 5 bytes, the next slice is 14, etc. We start by writing our bytes into the first 5 bytes. When we hit the end of the slice, we allocate the next slice and then write the address of the new slice into the last 4 bytes of the previous slice (the "forwarding address"). Each slice is filled with 0's initially, and we mark the end with a non-zero byte. This way the methods that are writing into the slice don't need to record its length and instead allocate a new slice once they hit a non-zero byte.
ByteBlockPool.Allocator
ByteSliceReader | IndexInput that knows how to read the byte slices written by Posting and PostingVector. We read the bytes in each slice until we hit the end of that slice at which point we read the forwarding address of the next slice and then jump to it.
ByteSliceWriter | Class to write byte streams into slices of shared byte[]. This is used by DocumentsWriter to hold the posting list for many terms in RAM.
CheckIndex
CheckIndex.Status
CheckIndex.Status.SegmentInfoStatus
CompoundFileReader | Class for accessing a compound stream. This class implements a directory, but is limited to only read operations. Directory methods that would normally modify data throw an exception.
CompoundFileReader.CSIndexInput | Implementation of an IndexInput that reads from a portion of the compound file. The visibility is left as "package" *only* because this helps with testing since JUnit test cases in a different class can then access package fields of this class.
CompoundFileWriter
ConcurrentMergeScheduler | A {@link MergeScheduler} that runs each merge using a separate thread, up until a maximum number of threads ({@link #setMaxThreadCount}) at which when a merge is needed, the thread(s) that are updating the index will pause until one or more merges completes. This is a simple way to use concurrency in the indexing process without having to create and manage application level threads.
ConcurrentMergeScheduler.MergeThread
CorruptIndexException | This exception is thrown when Lucene detects an inconsistency in the index.
DirectoryIndexReader | IndexReader implementation that has access to a Directory. Instances that have a SegmentInfos object (i. e. segmentInfos != null) "own" the directory, which means that they try to acquire a write lock whenever index modifications are performed.
DocumentsWriter
FieldInfo
FieldInfos | Access to the Fieldable Info file that describes document fields and whether or not they are indexed. Each segment has a separate Fieldable Info file. objects of this class are thread-safe for multiple readers, but only one thread can be adding documents at a time, with no other reader or writer threads accessing this object.
FieldReaderException
FieldSortedTermVectorMapper For each Field, store a sorted collection of {@link TermVectorEntry}s

This is not thread-safe.
FieldsReader Class responsible for access to stored document fields.

It uses <segment>.fdt and <segment>.fdx; files.
FieldsReader.FieldForMerge
FilterIndexReader A
FilterIndexReader
contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class
FilterIndexReader
itself simply implements all abstract methods of
IndexReader
with versions that pass all requests to the contained index reader. Subclasses of
FilterIndexReader
may further override some of these methods and may also provide additional methods and fields.
FilterIndexReader.FilterTermDocs | Base class for filtering {@link TermDocs} implementations.
FilterIndexReader.FilterTermEnum | Base class for filtering {@link TermEnum} implementations.
FilterIndexReader.FilterTermPositions | Base class for filtering {@link TermPositions} implementations.
IndexCommit | Deprecated. Please subclass Indexcommit class instead.
IndexFileDeleter
IndexFileNameFilter | Filename filter that accept filenames and extensions only created by Lucene.
IndexFileNames | Useful constants representing filenames and extensions used by lucene
IndexModifier
IndexReader
IndexReader.FieldOption | Constants describing field properties, for example used for {@link IndexReader#GetFieldNames(FieldOption)}.
IndexWriter An
IndexWriter
creates and maintains an index.

The

create
argument to the constructor determines whether a new index is created, or whether an existing index is opened. Note that you can open an index with
create=true
even while readers are using the index. The old readers will continue to search the "point in time" snapshot they had opened, and won't see the newly created index until they re-open. There are also constructors with no
create
argument which will create a new index if there is not already an index at the provided path and otherwise open the existing index.

In either case, documents are added with addDocument and removed with deleteDocuments(Term) or deleteDocuments(Query). A document can be updated with updateDocument (which just deletes and then adds the entire document). When finished adding, deleting and updating documents, close should be called.

These changes are buffered in memory and periodically flushed to the {@link Directory} (during the above method calls). A flush is triggered when there are enough buffered deletes (see {@link #setMaxBufferedDeleteTerms}) or enough added documents since the last flush, whichever is sooner. For the added documents, flushing is triggered either by RAM usage of the documents (see {@link #setRAMBufferSizeMB}) or the number of added documents. The default is to flush when RAM usage hits 16 MB. For best indexing speed you should flush by RAM usage with a large RAM buffer. Note that flushing just moves the internal buffered state in IndexWriter into the index, but these changes are not visible to IndexReader until either {@link #Commit()} or {@link #close} is called. A flush may also trigger one or more segment merges which by default run with a background thread so as not to block the addDocument calls (see below for changing the {@link MergeScheduler}).

The optional

autoCommit
argument to the constructors controls visibility of the changes to {@link IndexReader} instances reading the same index. When this is
false
, changes are not visible until {@link #Close()} or {@link #Commit()} is called. Note that changes will still be flushed to the {@link org.apache.lucene.store.Directory} as new files, but are not committed (no new
segments_N
file is written referencing the new files, nor are the files sync'd to stable storage) until {@link #Close()} or {@link #Commit()} is called. If something goes terribly wrong (for example the JVM crashes), then the index will reflect none of the changes made since the last commit, or the starting state if commit was not called. You can also call {@link #rollback}, which closes the writer without committing any changes, and removes any index files that had been flushed but are now unreferenced. This mode is useful for preventing readers from refreshing at a bad time (for example after you've done all your deletes but before you've done your adds). It can also be used to implement simple single-writer transactional semantics ("all or none"). You can do a two-phase commit by calling {@link #PrepareCommit()} followed by {@link #Commit()}. This is necessary when Lucene is working with an external resource (for example, a database) and both must either commit or rollback the transaction.

When

autoCommit
is
true
then the writer will periodically commit on its own. [Deprecated: Note that in 3.0, IndexWriter will no longer accept autoCommit=true (it will be hardwired to false). You can always call {@link #Commit()} yourself when needed]. There is no guarantee when exactly an auto commit will occur (it used to be after every flush, but it is now after every completed merge, as of 2.4). If you want to force a commit, call {@link #Commit()}, or, close the writer. Once a commit has finished, newly opened {@link IndexReader} instances will see the changes to the index as of that commit. When running in this mode, be careful not to refresh your readers while optimize or segment merges are taking place as this can tie up substantial disk space.

Regardless of

autoCommit
, an {@link IndexReader} or {@link org.apache.lucene.search.IndexSearcher} will only see the index as of the "point in time" that it was opened. Any changes committed to the index after the reader was opened are not visible until the reader is re-opened.

If an index will not have more documents added for a while and optimal search performance is desired, then either the full optimize method or partial {@link #Optimize(int)} method should be called before the index is closed.

Opening an

IndexWriter
creates a lock file for the directory in use. Trying to open another
IndexWriter
on the same directory will lead to a {@link LockObtainFailedException}. The {@link LockObtainFailedException} is also thrown if an IndexReader on the same directory is used to delete documents from the index.

Expert:

IndexWriter
allows an optional {@link IndexDeletionPolicy} implementation to be specified. You can use this to control when prior commits are deleted from the index. The default policy is {@link KeepOnlyLastCommitDeletionPolicy} which removes all prior commits as soon as a new commit is done (this matches behavior before 2.2). Creating your own policy can allow you to explicitly keep previous "point in time" commits alive in the index for some time, to allow readers to refresh to the new commit without having the old commit deleted out from under them. This is necessary on filesystems like NFS that do not support "delete on last close" semantics, which Lucene's "point in time" search normally relies on.

Expert:

IndexWriter
allows you to separately change the {@link MergePolicy} and the {@link MergeScheduler}. The {@link MergePolicy} is invoked whenever there are changes to the segments in the index. Its role is to select which merges to do, if any, and return a {@link MergePolicy.MergeSpecification} describing the merges. It also selects merges to do for Optimize(). (The default is {@link LogByteSizeMergePolicy}. Then, the {@link MergeScheduler} is invoked with the requested merges and it decides when and how to run the merges. The default is {@link ConcurrentMergeScheduler}.

IndexWriter.MaxFieldLength
KeepOnlyLastCommitDeletionPolicy | This {@link IndexDeletionPolicy} implementation that keeps only the most recent commit and immediately removes all prior commits after a new commit is done. This is the default deletion policy.
LogByteSizeMergePolicy | This is a {@link LogMergePolicy} that measures size of a segment as the total byte size of the segment's files.
LogDocMergePolicy | This is a {@link LogMergePolicy} that measures size of a segment as the number of documents (not taking deletions into account).
LogMergePolicy
MergePolicy

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by {@link IndexWriter}, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, {@link IndexWriter} invokes {@link #findMerges} to give the MergePolicy a chance to pick merges that are now required. This method returns a {@link MergeSpecification} instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls {@link #findMergesForOptimize} and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using {@link SerialMergeScheduler}, the merges will be run sequentially but if it is using {@link ConcurrentMergeScheduler} they will be run concurrently.

The default MergePolicy is {@link LogByteSizeMergePolicy}.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)
MergePolicy.MergeAbortedException
MergePolicy.MergeException | Exception thrown if there are any problems while executing a merge.
MergePolicy.MergeSpecification | A MergeSpecification instance provides the information necessary to perform multiple merges. It simply contains a list of {@link OneMerge} instances.
MergePolicy.OneMerge | OneMerge provides the information necessary to perform an individual primitive merge operation, resulting in a single new segment. The merge spec includes the subset of segments to be merged as well as whether the new segment should use the compound file format.
MergeScheduler Expert: {@link IndexWriter} uses an instance implementing this interface to execute the merges selected by a {@link MergePolicy}. The default MergeScheduler is {@link ConcurrentMergeScheduler}.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)
MultipleTermPositions Describe class
MultipleTermPositions
here.
MultiReader | An IndexReader which reads multiple indexes, appending their content.
MultiSegmentReader | An IndexReader which reads indexes with multiple segments.
ParallelReader
Payload
PositionBasedTermVectorMapper For each Field, store position by position information. It ignores frequency information

This is not thread-safe.
PositionBasedTermVectorMapper.TVPositionInfo | Container for a term at a position
SegmentInfo
SegmentInfos
SegmentInfos.FindSegmentsFile | Utility class for executing code that needs to do something with the current segments file. This is necessary with lock-less commits because from the time you locate the current segments file name, until you actually open it, read its contents, or check modified time, etc., it could have been deleted due to a writer commit finishing.
SegmentMerger
SegmentReader
SegmentTermDocs
SegmentTermEnum
SegmentTermPositions
SegmentTermVector
SerialMergeScheduler | A {@link MergeScheduler} that simply does each merge sequentially, using the current thread.
SnapshotDeletionPolicy A {@link IndexDeletionPolicy} that wraps around any other {@link IndexDeletionPolicy} and adds the ability to hold and later release a single "snapshot" of an index. While the snapshot is held, the {@link IndexWriter} will not remove any files associated with it even if the index is otherwise being actively, arbitrarily changed. Because we wrap another arbitrary {@link IndexDeletionPolicy}, this gives you the freedom to continue using whatever {@link IndexDeletionPolicy} you would normally want to use with your index. Note that you can re-use a single instance of SnapshotDeletionPolicy across multiple writers as long as they are against the same index Directory. Any snapshot held when a writer is closed will "survive" when the next writer is opened.

WARNING: This API is new and experimental and may suddnely changendex.

SortedTermVectorMapper Store a sorted collection of {@link Lucene.Net.Index.TermVectorEntry}s. Collects all term information into a single, SortedSet.
NOTE: This Mapper ignores all Field information for the Document. This means that if you are using offset/positions you will not know what Fields they correlate with.
This is not thread-safe
StaleReaderException | This exception is thrown when an {@link IndexReader} tries to make changes to the index (via {@link IndexReader#deleteDocument}, {@link IndexReader#undeleteAll} or {@link IndexReader#setNorm}) but changes have already been committed to the index since this reader was instantiated. When this happens you must open a new reader on the current index to make the changes.
Term | A Term represents a word from text. This is the unit of search. It is composed of two elements, the text of the word, as a string, and the name of the field that the text occured in, an interned string. Note that terms may represent more than words from text fields, but also things like dates, email addresses, urls, etc.
TermEnum
TermInfo | A TermInfo is the record of information stored for a term.
TermInfosReader
TermInfosWriter
TermVectorEntry | Convenience class for holding TermVector information.
TermVectorEntryFreqSortedComparator | Compares {@link Lucene.Net.Index.TermVectorEntry}s first by frequency and then by the term (case-sensitive)
TermVectorMapper The TermVectorMapper can be used to map Term Vectors into your own structure instead of the parallel array structure used by {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}.

It is up to the implementation to make sure it is thread-safe.
TermVectorOffsetInfo | The TermVectorOffsetInfo class holds information pertaining to a Term in a {@link Lucene.Net.Index.TermPositionVector}'s offset information. This offset information is the character offset as set during the Analysis phase (and thus may not be the actual offset in the original content).
TermVectorsReader
TermVectorsWriter

Interfaces

Interface | Description
IndexCommitPoint
IndexDeletionPolicy
TermDocs
TermFreqVector | Provides access to stored term vector of a document field. The vector consists of the name of the field, an array of the terms tha occur in the field of the {@link Lucene.Net.Documents.Document} and a parallel array of frequencies. Thus, getTermFrequencies()[5] corresponds with the frequency of getTerms()[5], assuming there are at least 5 terms in the Document.
TermPositions
TermPositionVector Extends
TermFreqVector
to provide additional information about positions in which each of the terms is found. A TermPositionVector not necessarily contains both positions and offsets, but at least one of these arrays exists.


ByteBlockPool Class

Class that Posting and PostingVector use to write byte streams into shared fixed-size byte[] arrays. The idea is to allocate slices of increasing lengths For example, the first slice is 5 bytes, the next slice is 14, etc. We start by writing our bytes into the first 5 bytes. When we hit the end of the slice, we allocate the next slice and then write the address of the new slice into the last 4 bytes of the previous slice (the "forwarding address"). Each slice is filled with 0's initially, and we mark the end with a non-zero byte. This way the methods that are writing into the slice don't need to record its length and instead allocate a new slice once they hit a non-zero byte.

For a list of all members of this type, see ByteBlockPool Members.

System.Object
Lucene.Net.Index.ByteBlockPool

public sealed class ByteBlockPool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ByteBlockPool Members | Lucene.Net.Index Namespace


ByteBlockPool Members

ByteBlockPool overview

Public Static Fields

FIRST_LEVEL_SIZE_For_NUnit_Test

Public Instance Constructors

ByteBlockPool Constructor

Public Instance Fields

buffer
buffers
byteOffset
byteUpto

Public Instance Methods

AllocSlice |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NewSlice |
NextBuffer |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool Constructor

public ByteBlockPool(
Allocator allocator,
bool trackAllocations
);

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool Fields

The fields of the ByteBlockPool class are listed below. For a complete list of ByteBlockPool class members, see the ByteBlockPool Members topic.

Public Static Fields

FIRST_LEVEL_SIZE_For_NUnit_Test

Public Instance Fields

buffer
buffers
byteOffset
byteUpto

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool.buffer Field

public byte[] buffer;

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool.buffers Field

public byte[][] buffers;

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool.byteOffset Field

public int byteOffset;

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool.byteUpto Field

public int byteUpto;

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool.FIRST_LEVEL_SIZE_For_NUnit_Test Field

public static readonly int FIRST_LEVEL_SIZE_For_NUnit_Test;

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool Methods

The methods of the ByteBlockPool class are listed below. For a complete list of ByteBlockPool class members, see the ByteBlockPool Members topic.

Public Instance Methods

AllocSlice |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NewSlice |
NextBuffer |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool.AllocSlice Method

public int AllocSlice(
byte[] slice,
int upto
);

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool.NewSlice Method

public int NewSlice(
int size
);

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool.NextBuffer Method

public void NextBuffer();

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool.Reset Method

public void Reset();

See Also

ByteBlockPool Class | Lucene.Net.Index Namespace


ByteBlockPool.Allocator Class

For a list of all members of this type, see ByteBlockPool.Allocator Members.

System.Object
Lucene.Net.Index.ByteBlockPool.Allocator

public abstract class ByteBlockPool.Allocator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ByteBlockPool.Allocator Members | Lucene.Net.Index Namespace


ByteBlockPool.Allocator Members

ByteBlockPool.Allocator overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetByteBlock |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RecycleByteBlocks |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ByteBlockPool.Allocator Constructor Initializes a new instance of the ByteBlockPool.Allocator class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ByteBlockPool.Allocator Class | Lucene.Net.Index Namespace


ByteBlockPool.Allocator Constructor

Initializes a new instance of the ByteBlockPool.Allocator class.

protected ByteBlockPool.Allocator();

See Also

ByteBlockPool.Allocator Class | Lucene.Net.Index Namespace


ByteBlockPool.Allocator Methods

The methods of the ByteBlockPool.Allocator class are listed below. For a complete list of ByteBlockPool.Allocator class members, see the ByteBlockPool.Allocator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetByteBlock |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RecycleByteBlocks |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ByteBlockPool.Allocator Class | Lucene.Net.Index Namespace


ByteBlockPool.Allocator.GetByteBlock Method

public abstract byte[] GetByteBlock(
bool trackAllocations
);

See Also

ByteBlockPool.Allocator Class | Lucene.Net.Index Namespace


ByteBlockPool.Allocator.RecycleByteBlocks Method

public abstract void RecycleByteBlocks(
byte[][] blocks,
int start,
int end
);

See Also

ByteBlockPool.Allocator Class | Lucene.Net.Index Namespace


ByteSliceReader Class

IndexInput that knows how to read the byte slices written by Posting and PostingVector. We read the bytes in each slice until we hit the end of that slice at which point we read the forwarding address of the next slice and then jump to it.

For a list of all members of this type, see ByteSliceReader Members.

System.Object
Lucene.Net.Store.IndexInput
Lucene.Net.Index.ByteSliceReader

public sealed class ByteSliceReader : IndexInput

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ByteSliceReader Members | Lucene.Net.Index Namespace


ByteSliceReader Members

ByteSliceReader overview

Public Instance Constructors

ByteSliceReader Constructor Initializes a new instance of the ByteSliceReader class.

Public Instance Fields

bufferOffset
endIndex
upto

Public Instance Methods

Clone (inherited from IndexInput) |
Close |
Eof |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilePointer |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init |
Length |
NextSlice |
ReadByte |
ReadBytes | Overloaded.
ReadBytes (inherited from IndexInput) | Overloaded. Reads a specified number of bytes into an array at the specified offset.
ReadChars (inherited from IndexInput) | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt (inherited from IndexInput) | Reads four bytes and returns an int.
ReadLong (inherited from IndexInput) | Reads eight bytes and returns a long.
ReadModifiedUTF8String (inherited from IndexInput) |
ReadString (inherited from IndexInput) | Reads a string.
ReadVInt (inherited from IndexInput) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from IndexInput) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek |
SetModifiedUTF8StringsMode (inherited from IndexInput) | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars (inherited from IndexInput) | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteTo |

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader Constructor

Initializes a new instance of the ByteSliceReader class.

public ByteSliceReader();

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader Fields

The fields of the ByteSliceReader class are listed below. For a complete list of ByteSliceReader class members, see the ByteSliceReader Members topic.

Public Instance Fields

bufferOffset
endIndex
upto

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader.bufferOffset Field

public int bufferOffset;

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader.endIndex Field

public int endIndex;

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader.upto Field

public int upto;

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader Methods

The methods of the ByteSliceReader class are listed below. For a complete list of ByteSliceReader class members, see the ByteSliceReader Members topic.

Public Instance Methods

Clone (inherited from IndexInput) |
Close |
Eof |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilePointer |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init |
Length |
NextSlice |
ReadByte |
ReadBytes | Overloaded.
ReadBytes (inherited from IndexInput) | Overloaded. Reads a specified number of bytes into an array at the specified offset.
ReadChars (inherited from IndexInput) | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt (inherited from IndexInput) | Reads four bytes and returns an int.
ReadLong (inherited from IndexInput) | Reads eight bytes and returns a long.
ReadModifiedUTF8String (inherited from IndexInput) |
ReadString (inherited from IndexInput) | Reads a string.
ReadVInt (inherited from IndexInput) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from IndexInput) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek |
SetModifiedUTF8StringsMode (inherited from IndexInput) | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars (inherited from IndexInput) | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteTo |

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader.Close Method

public override void Close();

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader.Eof Method

public bool Eof();

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader.GetFilePointer Method

public override long GetFilePointer();

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader.Init Method

public void Init(
ByteBlockPool pool,
int startIndex,
int endIndex
);

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader.Length Method

public override long Length();

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader.NextSlice Method

public void NextSlice();

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader.ReadByte Method

public override byte ReadByte();

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ReadBytes Method

Apache Lucene.Net 2.4.0 Class Library API

ByteSliceReader.ReadBytes Method

Overload List

public override void ReadBytes(byte[],int,int);

Inherited from IndexInput.

public virtual void ReadBytes(byte[],int,int,bool);

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader.ReadBytes Method (Byte[], Int32, Int32)

public override void ReadBytes(
byte[] b,
int offset,
int len
);

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace | ByteSliceReader.ReadBytes Overload List


ByteSliceReader.Seek Method

public override void Seek(
long pos
);

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceReader.WriteTo Method

public long WriteTo(
IndexOutput out_Renamed
);

See Also

ByteSliceReader Class | Lucene.Net.Index Namespace


ByteSliceWriter Class

Class to write byte streams into slices of shared byte[]. This is used by DocumentsWriter to hold the posting list for many terms in RAM.

For a list of all members of this type, see ByteSliceWriter Members.

System.Object
Lucene.Net.Index.ByteSliceWriter

public sealed class ByteSliceWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ByteSliceWriter Members | Lucene.Net.Index Namespace


ByteSliceWriter Members

ByteSliceWriter overview

Public Instance Constructors

ByteSliceWriter Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAddress |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Set up the writer to write at address.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte | Write byte into byte slice stream
WriteBytes |
WriteVInt |

See Also

ByteSliceWriter Class | Lucene.Net.Index Namespace


ByteSliceWriter Constructor

public ByteSliceWriter(
ByteBlockPool pool
);

See Also

ByteSliceWriter Class | Lucene.Net.Index Namespace


ByteSliceWriter Methods

The methods of the ByteSliceWriter class are listed below. For a complete list of ByteSliceWriter class members, see the ByteSliceWriter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAddress |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Set up the writer to write at address.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte | Write byte into byte slice stream
WriteBytes |
WriteVInt |

See Also

ByteSliceWriter Class | Lucene.Net.Index Namespace


ByteSliceWriter.GetAddress Method

public int GetAddress();

See Also

ByteSliceWriter Class | Lucene.Net.Index Namespace


ByteSliceWriter.Init Method

Set up the writer to write at address.

public void Init(
int address
);

Parameters

address

See Also

ByteSliceWriter Class | Lucene.Net.Index Namespace


ByteSliceWriter.WriteByte Method

Write byte into byte slice stream

public void WriteByte(
byte b
);

See Also

ByteSliceWriter Class | Lucene.Net.Index Namespace


ByteSliceWriter.WriteBytes Method

public void WriteBytes(
byte[] b,
int offset,
int len
);

See Also

ByteSliceWriter Class | Lucene.Net.Index Namespace


ByteSliceWriter.WriteVInt Method

public void WriteVInt(
int i
);

See Also

ByteSliceWriter Class | Lucene.Net.Index Namespace


CheckIndex Class

For a list of all members of this type, see CheckIndex Members.

System.Object
Lucene.Net.Index.CheckIndex

public class CheckIndex

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CheckIndex Members | Lucene.Net.Index Namespace


CheckIndex Members

CheckIndex overview

Public Static Fields

out_Renamed Obsolete. Default print stream for all CheckIndex instances.

Public Static Methods

Check | Overloaded.
Main |

Public Instance Constructors

CheckIndex Constructor

Public Instance Methods

CheckIndex_Renamed | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FixIndex |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetInfoStream |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckIndex Class | Lucene.Net.Index Namespace


CheckIndex Constructor

public CheckIndex(
Directory dir
);

See Also

CheckIndex Class | Lucene.Net.Index Namespace


CheckIndex Fields

The fields of the CheckIndex class are listed below. For a complete list of CheckIndex class members, see the CheckIndex Members topic.

Public Static Fields

out_Renamed Obsolete. Default print stream for all CheckIndex instances.

See Also

CheckIndex Class | Lucene.Net.Index Namespace


CheckIndex.out_Renamed Field

NOTE: This field is now obsolete.

use SetInfoStream per instance instead

Default print stream for all CheckIndex instances.

public static TextWriter out_Renamed;

See Also

CheckIndex Class | Lucene.Net.Index Namespace


CheckIndex Methods

The methods of the CheckIndex class are listed below. For a complete list of CheckIndex class members, see the CheckIndex Members topic.

Public Static Methods

Check | Overloaded.
Main |

Public Instance Methods

CheckIndex_Renamed | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FixIndex |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetInfoStream |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckIndex Class | Lucene.Net.Index Namespace


Check Method

Apache Lucene.Net 2.4.0 Class Library API

CheckIndex.Check Method

Overload List

public static bool Check(Directory,bool);

public static bool Check(Directory,bool,0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]);

See Also

CheckIndex Class | Lucene.Net.Index Namespace


CheckIndex.Check Method (Directory, Boolean)

public static bool Check(
Directory dir,
bool doFix
);

See Also

CheckIndex Class | Lucene.Net.Index Namespace | CheckIndex.Check Overload List


CheckIndex.Check Method (Directory, Boolean, 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])

public static bool Check(
Directory dir,
bool doFix,
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] onlySegments
);

See Also

CheckIndex Class | Lucene.Net.Index Namespace | CheckIndex.Check Overload List


CheckIndex_Renamed Method

Apache Lucene.Net 2.4.0 Class Library API

CheckIndex.CheckIndex_Renamed Method

Overload List

public Status CheckIndex_Renamed();

public Status CheckIndex_Renamed(0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]);

See Also

CheckIndex Class | Lucene.Net.Index Namespace


CheckIndex.CheckIndex_Renamed Method ()

public Status CheckIndex_Renamed();

See Also

CheckIndex Class | Lucene.Net.Index Namespace | CheckIndex.CheckIndex_Renamed Overload List


CheckIndex.CheckIndex_Renamed Method (0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])

public Status CheckIndex_Renamed(
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] onlySegments
);

See Also

CheckIndex Class | Lucene.Net.Index Namespace | CheckIndex.CheckIndex_Renamed Overload List


CheckIndex.FixIndex Method

public void FixIndex(
Status result
);

See Also

CheckIndex Class | Lucene.Net.Index Namespace


CheckIndex.Main Method

public static void Main(
string[] args
);

See Also

CheckIndex Class | Lucene.Net.Index Namespace


CheckIndex.SetInfoStream Method

public void SetInfoStream(
TextWriter out_Renamed
);

See Also

CheckIndex Class | Lucene.Net.Index Namespace


CheckIndex.Status Class

For a list of all members of this type, see CheckIndex.Status Members.

System.Object
Lucene.Net.Index.CheckIndex.Status

public class CheckIndex.Status

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CheckIndex.Status Members | Lucene.Net.Index Namespace


CheckIndex.Status Members

CheckIndex.Status overview

Public Instance Constructors

CheckIndex.Status Constructor Initializes a new instance of the CheckIndex.Status class.

Public Instance Fields

cantOpenSegments
clean
dir
missingSegments
missingSegmentVersion
numBadSegments
numSegments
partial
segmentFormat
segmentInfos
segmentsChecked
segmentsFileName
toolOutOfDate
totLoseDocCount

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status Constructor

Initializes a new instance of the CheckIndex.Status class.

public CheckIndex.Status();

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status Fields

The fields of the CheckIndex.Status class are listed below. For a complete list of CheckIndex.Status class members, see the CheckIndex.Status Members topic.

Public Instance Fields

cantOpenSegments
clean
dir
missingSegments
missingSegmentVersion
numBadSegments
numSegments
partial
segmentFormat
segmentInfos
segmentsChecked
segmentsFileName
toolOutOfDate
totLoseDocCount

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.cantOpenSegments Field

public bool cantOpenSegments;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.clean Field

public bool clean;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.dir Field

public Directory dir;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.missingSegments Field

public bool missingSegments;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.missingSegmentVersion Field

public bool missingSegmentVersion;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.numBadSegments Field

public int numBadSegments;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.numSegments Field

public int numSegments;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.partial Field

public bool partial;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.segmentFormat Field

public string segmentFormat;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.segmentInfos Field

public 2, Culture=neutral, PublicKeyToken=null]] segmentInfos;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.segmentsChecked Field

public 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] segmentsChecked;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.segmentsFileName Field

public string segmentsFileName;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.toolOutOfDate Field

public bool toolOutOfDate;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.totLoseDocCount Field

public int totLoseDocCount;

See Also

CheckIndex.Status Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus Class

For a list of all members of this type, see CheckIndex.Status.SegmentInfoStatus Members.

System.Object
Lucene.Net.Index.CheckIndex.Status.SegmentInfoStatus

public class CheckIndex.Status.SegmentInfoStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CheckIndex.Status.SegmentInfoStatus Members | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus Members

CheckIndex.Status.SegmentInfoStatus overview

Public Instance Constructors

CheckIndex.Status.SegmentInfoStatus Constructor Initializes a new instance of the CheckIndex.Status.SegmentInfoStatus class.

Public Instance Fields

compound
deletionsFileName
docCount
docStoreCompoundFile
docStoreOffset
docStoreSegment
hasDeletions
hasProx
name
numDeleted
numFields
numFiles
openReaderPassed
sizeMB

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus Constructor

Initializes a new instance of the CheckIndex.Status.SegmentInfoStatus class.

public CheckIndex.Status.SegmentInfoStatus();

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus Fields

The fields of the CheckIndex.Status.SegmentInfoStatus class are listed below. For a complete list of CheckIndex.Status.SegmentInfoStatus class members, see the CheckIndex.Status.SegmentInfoStatus Members topic.

Public Instance Fields

compound
deletionsFileName
docCount
docStoreCompoundFile
docStoreOffset
docStoreSegment
hasDeletions
hasProx
name
numDeleted
numFields
numFiles
openReaderPassed
sizeMB

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.compound Field

public bool compound;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.deletionsFileName Field

public string deletionsFileName;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.docCount Field

public int docCount;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.docStoreCompoundFile Field

public bool docStoreCompoundFile;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.docStoreOffset Field

public int docStoreOffset;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.docStoreSegment Field

public string docStoreSegment;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.hasDeletions Field

public bool hasDeletions;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.hasProx Field

public bool hasProx;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.name Field

public string name;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.numDeleted Field

public int numDeleted;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.numFields Field

public int numFields;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.numFiles Field

public int numFiles;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.openReaderPassed Field

public bool openReaderPassed;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus.sizeMB Field

public double sizeMB;

See Also

CheckIndex.Status.SegmentInfoStatus Class | Lucene.Net.Index Namespace


CompoundFileReader Class

Class for accessing a compound stream. This class implements a directory, but is limited to only read operations. Directory methods that would normally modify data throw an exception.

For a list of all members of this type, see CompoundFileReader Members.

System.Object
Lucene.Net.Store.Directory
Lucene.Net.Index.CompoundFileReader

public class CompoundFileReader : Directory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CompoundFileReader Members | Lucene.Net.Index Namespace


CompoundFileReader Members

CompoundFileReader overview

Public Instance Constructors

CompoundFileReader Overloaded. Initializes a new instance of the CompoundFileReader class.

Public Instance Methods

ClearLock (inherited from Directory) | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Close |
CreateOutput | Not implemented
DeleteFile | Not implemented
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff a file with the given name exists.
FileLength | Returns the length of a file in the directory.
FileModified | Returns the time the compound file was last modified.
GetDirectory |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockFactory (inherited from Directory) | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
GetLockID (inherited from Directory) | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.
GetName |
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory.
MakeLock | Not implemented
OpenInput | Overloaded.
RenameFile | Not implemented
SetLockFactory (inherited from Directory) | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Sync (inherited from Directory) | Ensure that any writes to the file are moved to stable storage. Lucene uses this to properly commit chages to the index, to prevent a machine/OS crash from corrupting the index.
ToString (inherited from Object) | Returns a String that represents the current Object.
TouchFile | Set the modified time of the compound file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

isOpen (inherited from Directory) |
lockFactory (inherited from Directory) | Holds the LockFactory instance (implements locking for this Directory instance).

Protected Internal Instance Methods

EnsureOpen (inherited from Directory) Throws AlreadyClosedException if this Directory is closed.

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader Constructor

Overload List

public CompoundFileReader(Directory,string);

public CompoundFileReader(Directory,string,int);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader Constructor (Directory, String)

public CompoundFileReader(
Directory dir,
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace | CompoundFileReader Constructor Overload List


CompoundFileReader Constructor (Directory, String, Int32)

public CompoundFileReader(
Directory dir,
string name,
int readBufferSize
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace | CompoundFileReader Constructor Overload List


CompoundFileReader Methods

The methods of the CompoundFileReader class are listed below. For a complete list of CompoundFileReader class members, see the CompoundFileReader Members topic.

Public Instance Methods

ClearLock (inherited from Directory) | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Close |
CreateOutput | Not implemented
DeleteFile | Not implemented
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff a file with the given name exists.
FileLength | Returns the length of a file in the directory.
FileModified | Returns the time the compound file was last modified.
GetDirectory |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockFactory (inherited from Directory) | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
GetLockID (inherited from Directory) | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.
GetName |
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory.
MakeLock | Not implemented
OpenInput | Overloaded.
RenameFile | Not implemented
SetLockFactory (inherited from Directory) | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Sync (inherited from Directory) | Ensure that any writes to the file are moved to stable storage. Lucene uses this to properly commit chages to the index, to prevent a machine/OS crash from corrupting the index.
ToString (inherited from Object) | Returns a String that represents the current Object.
TouchFile | Set the modified time of the compound file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

EnsureOpen (inherited from Directory) Throws AlreadyClosedException if this Directory is closed.

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.Close Method

public override void Close();

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.CreateOutput Method

Not implemented

public override IndexOutput CreateOutput(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.DeleteFile Method

Not implemented

public override void DeleteFile(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.FileExists Method

Returns true iff a file with the given name exists.

public override bool FileExists(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.FileLength Method

Returns the length of a file in the directory.

public override long FileLength(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.FileModified Method

Returns the time the compound file was last modified.

public override long FileModified(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.GetDirectory Method

public virtual Directory GetDirectory();

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.GetName Method

public virtual string GetName();

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.List Method

Returns an array of strings, one for each file in the directory.

public override string[] List();

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.MakeLock Method

Not implemented

public override Lock MakeLock(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


OpenInput Method

Apache Lucene.Net 2.4.0 Class Library API

CompoundFileReader.OpenInput Method

Overload List

public override IndexInput OpenInput(string);

public override IndexInput OpenInput(string,int);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.OpenInput Method (String)

public override IndexInput OpenInput(
string id
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace | CompoundFileReader.OpenInput Overload List


CompoundFileReader.OpenInput Method (String, Int32)

public override IndexInput OpenInput(
string id,
int readBufferSize
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace | CompoundFileReader.OpenInput Overload List


CompoundFileReader.RenameFile Method

Not implemented

public override void RenameFile(
string from,
string to
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.TouchFile Method

Set the modified time of the compound file to now.

public override void TouchFile(
string name
);

See Also

CompoundFileReader Class | Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput Class

Implementation of an IndexInput that reads from a portion of the compound file. The visibility is left as "package" *only* because this helps with testing since JUnit test cases in a different class can then access package fields of this class.

For a list of all members of this type, see CompoundFileReader.CSIndexInput Members.

System.Object
Lucene.Net.Store.IndexInput
Lucene.Net.Store.BufferedIndexInput
Lucene.Net.Index.CompoundFileReader.CSIndexInput

public sealed class CompoundFileReader.CSIndexInput : BufferedIndexInput

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CompoundFileReader.CSIndexInput Members | Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput Members

CompoundFileReader.CSIndexInput overview

Public Instance Fields

base_Renamed

Public Instance Methods

Clone |
Close | Closes the stream to further operations.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBufferSize (inherited from BufferedIndexInput) |
GetFilePointer (inherited from BufferedIndexInput) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
ReadByte (inherited from BufferedIndexInput) |
ReadBytes (inherited from BufferedIndexInput) | Overloaded.
ReadChars (inherited from IndexInput) | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt (inherited from IndexInput) | Reads four bytes and returns an int.
ReadLong (inherited from IndexInput) | Reads eight bytes and returns a long.
ReadModifiedUTF8String (inherited from IndexInput) |
ReadString (inherited from IndexInput) | Reads a string.
ReadVInt (inherited from IndexInput) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from IndexInput) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek (inherited from BufferedIndexInput) |
SetBufferSize (inherited from BufferedIndexInput) | Change the buffer size used by this IndexInput
SetModifiedUTF8StringsMode (inherited from IndexInput) | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars (inherited from IndexInput) | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

buffer (inherited from BufferedIndexInput)

Protected Internal Instance Methods

NewBuffer (inherited from BufferedIndexInput) |
ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input.
SeekInternal | Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.

See Also

CompoundFileReader.CSIndexInput Class | Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput Fields

The fields of the CompoundFileReader.CSIndexInput class are listed below. For a complete list of CompoundFileReader.CSIndexInput class members, see the CompoundFileReader.CSIndexInput Members topic.

Public Instance Fields

base_Renamed

Protected Internal Instance Fields

buffer (inherited from BufferedIndexInput)

See Also

CompoundFileReader.CSIndexInput Class | Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput.base_Renamed Field

public IndexInput base_Renamed;

See Also

CompoundFileReader.CSIndexInput Class | Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput Methods

The methods of the CompoundFileReader.CSIndexInput class are listed below. For a complete list of CompoundFileReader.CSIndexInput class members, see the CompoundFileReader.CSIndexInput Members topic.

Public Instance Methods

Clone |
Close | Closes the stream to further operations.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBufferSize (inherited from BufferedIndexInput) |
GetFilePointer (inherited from BufferedIndexInput) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
ReadByte (inherited from BufferedIndexInput) |
ReadBytes (inherited from BufferedIndexInput) | Overloaded.
ReadChars (inherited from IndexInput) | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt (inherited from IndexInput) | Reads four bytes and returns an int.
ReadLong (inherited from IndexInput) | Reads eight bytes and returns a long.
ReadModifiedUTF8String (inherited from IndexInput) |
ReadString (inherited from IndexInput) | Reads a string.
ReadVInt (inherited from IndexInput) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from IndexInput) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek (inherited from BufferedIndexInput) |
SetBufferSize (inherited from BufferedIndexInput) | Change the buffer size used by this IndexInput
SetModifiedUTF8StringsMode (inherited from IndexInput) | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars (inherited from IndexInput) | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

NewBuffer (inherited from BufferedIndexInput) |
ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input.
SeekInternal | Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.

See Also

CompoundFileReader.CSIndexInput Class | Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

CompoundFileReader.CSIndexInput Class | Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput.Close Method

Closes the stream to further operations.

public override void Close();

See Also

CompoundFileReader.CSIndexInput Class | Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput.Length Method

public override long Length();

See Also

CompoundFileReader.CSIndexInput Class | Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput.ReadInternal Method

Expert: implements buffer refill. Reads bytes from the current position in the input.

protected internal override void ReadInternal(
byte[] b,
int offset,
int len
);

Parameters

b
the array to read bytes into
offset
the offset in the array to start storing bytes
len
the number of bytes to read

See Also

CompoundFileReader.CSIndexInput Class | Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput.SeekInternal Method

Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.

protected internal override void SeekInternal(
long pos
);

See Also

CompoundFileReader.CSIndexInput Class | Lucene.Net.Index Namespace |


CompoundFileWriter Class

For a list of all members of this type, see CompoundFileWriter Members.

System.Object
Lucene.Net.Index.CompoundFileWriter

public sealed class CompoundFileWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CompoundFileWriter Members | Lucene.Net.Index Namespace


CompoundFileWriter Members

CompoundFileWriter overview

Public Instance Constructors

CompoundFileWriter Constructor Create the compound stream in the specified file. The file name is the entire name (no extensions are added).

Public Instance Methods

AddFile Add a source stream.
file
is the string by which the sub-stream will be known in the compound stream.
Close | Merge files with the extensions added up to now. All files with these extensions are combined sequentially into the compound stream. After successful merge, the source files are deleted.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDirectory | Returns the directory of the compound file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetName | Returns the name of the compound file.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


CompoundFileWriter Constructor

Create the compound stream in the specified file. The file name is the entire name (no extensions are added).

public CompoundFileWriter(
Directory dir,
string name
);

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


CompoundFileWriter Methods

The methods of the CompoundFileWriter class are listed below. For a complete list of CompoundFileWriter class members, see the CompoundFileWriter Members topic.

Public Instance Methods

AddFile Add a source stream.
file
is the string by which the sub-stream will be known in the compound stream.
Close | Merge files with the extensions added up to now. All files with these extensions are combined sequentially into the compound stream. After successful merge, the source files are deleted.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDirectory | Returns the directory of the compound file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetName | Returns the name of the compound file.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


CompoundFileWriter.AddFile Method

Add a source stream.

file
is the string by which the sub-stream will be known in the compound stream.

public void AddFile(
string file
);

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


CompoundFileWriter.Close Method

Merge files with the extensions added up to now. All files with these extensions are combined sequentially into the compound stream. After successful merge, the source files are deleted.

public void Close();

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


CompoundFileWriter.GetDirectory Method

Returns the directory of the compound file.

public Directory GetDirectory();

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


CompoundFileWriter.GetName Method

Returns the name of the compound file.

public string GetName();

See Also

CompoundFileWriter Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler Class

A {@link MergeScheduler} that runs each merge using a separate thread, up until a maximum number of threads ({@link #setMaxThreadCount}) at which when a merge is needed, the thread(s) that are updating the index will pause until one or more merges completes. This is a simple way to use concurrency in the indexing process without having to create and manage application level threads.

For a list of all members of this type, see ConcurrentMergeScheduler Members.

System.Object
Lucene.Net.Index.MergeScheduler
Lucene.Net.Index.ConcurrentMergeScheduler

public class ConcurrentMergeScheduler : MergeScheduler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ConcurrentMergeScheduler Members | Lucene.Net.Index Namespace


ConcurrentMergeScheduler Members

ConcurrentMergeScheduler overview

Public Static Methods

AnyUnhandledExceptions | Used for testing
ClearUnhandledExceptions |
SetTestMode |

Public Instance Constructors

ConcurrentMergeScheduler Constructor Initializes a new instance of the ConcurrentMergeScheduler class.

Public Instance Methods

ClearSuppressExceptions_ForNUnitTest |
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxThreadCount | Get the max # simultaneous threads that may be
GetMergeThreadPriority | Return the priority that merge threads run at. By default the priority is 1 plus the priority of (ie, slightly higher priority than) the first thread that calls merge.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge |
SetMaxThreadCount | Sets the max # simultaneous threads that may be running. If a merge is necessary yet we already have this many threads running, the incoming thread (that is calling add/updateDocument) will block until a merge thread has completed.
SetMergeThreadPriority | Return the priority that merge threads run at.
SetSuppressExceptions_ForNUnitTest |
Sync |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

dir
mergeThreadCount
mergeThreads
writer

Protected Instance Methods

DoMerge | Does the acural merge, by calling IndexWriter.Merge().
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetMergeThread | Create and return a new MergeThread.
HandleMergeException |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler Constructor

Initializes a new instance of the ConcurrentMergeScheduler class.

public ConcurrentMergeScheduler();

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler Fields

The fields of the ConcurrentMergeScheduler class are listed below. For a complete list of ConcurrentMergeScheduler class members, see the ConcurrentMergeScheduler Members topic.

Protected Instance Fields

dir
mergeThreadCount
mergeThreads
writer

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.dir Field

protected Directory dir;

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.mergeThreadCount Field

protected int mergeThreadCount;

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.mergeThreads Field

protected 2, Culture=neutral, PublicKeyToken=null]] mergeThreads;

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.writer Field

protected IndexWriter writer;

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler Methods

The methods of the ConcurrentMergeScheduler class are listed below. For a complete list of ConcurrentMergeScheduler class members, see the ConcurrentMergeScheduler Members topic.

Public Static Methods

AnyUnhandledExceptions | Used for testing
ClearUnhandledExceptions |
SetTestMode |

Public Instance Methods

ClearSuppressExceptions_ForNUnitTest |
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxThreadCount | Get the max # simultaneous threads that may be
GetMergeThreadPriority | Return the priority that merge threads run at. By default the priority is 1 plus the priority of (ie, slightly higher priority than) the first thread that calls merge.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge |
SetMaxThreadCount | Sets the max # simultaneous threads that may be running. If a merge is necessary yet we already have this many threads running, the incoming thread (that is calling add/updateDocument) will block until a merge thread has completed.
SetMergeThreadPriority | Return the priority that merge threads run at.
SetSuppressExceptions_ForNUnitTest |
Sync |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DoMerge | Does the acural merge, by calling IndexWriter.Merge().
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetMergeThread | Create and return a new MergeThread.
HandleMergeException |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.AnyUnhandledExceptions Method

Used for testing

public static bool AnyUnhandledExceptions();

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.ClearSuppressExceptions_ForNUnitTest Method

public void ClearSuppressExceptions_ForNUnitTest();

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.ClearUnhandledExceptions Method

public static void ClearUnhandledExceptions();

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.Close Method

public override void Close();

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.DoMerge Method

Does the acural merge, by calling IndexWriter.Merge().

protected virtual void DoMerge(
OneMerge merge
);

Parameters

merge

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.GetMaxThreadCount Method

Get the max # simultaneous threads that may be

public virtual int GetMaxThreadCount();

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace |


ConcurrentMergeScheduler.GetMergeThread Method

Create and return a new MergeThread.

protected virtual MergeThread GetMergeThread(
IndexWriter writer,
OneMerge merge
);

Parameters

writer
merge

Return Value

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.GetMergeThreadPriority Method

Return the priority that merge threads run at. By default the priority is 1 plus the priority of (ie, slightly higher priority than) the first thread that calls merge.

public virtual int GetMergeThreadPriority();

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.HandleMergeException Method

protected virtual void HandleMergeException(
Exception exc
);

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.Merge Method

public override void Merge(
IndexWriter writer
);

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.SetMaxThreadCount Method

Sets the max # simultaneous threads that may be running. If a merge is necessary yet we already have this many threads running, the incoming thread (that is calling add/updateDocument) will block until a merge thread has completed.

public virtual void SetMaxThreadCount(
int count
);

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.SetMergeThreadPriority Method

Return the priority that merge threads run at.

public virtual void SetMergeThreadPriority(
int pri
);

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.SetSuppressExceptions_ForNUnitTest Method

public void SetSuppressExceptions_ForNUnitTest();

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.SetTestMode Method

public static void SetTestMode();

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.Sync Method

public virtual void Sync();

See Also

ConcurrentMergeScheduler Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread Class

For a list of all members of this type, see ConcurrentMergeScheduler.MergeThread Members.

System.Object
SupportClass.ThreadClass
Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread

protected class ConcurrentMergeScheduler.MergeThread : ThreadClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ConcurrentMergeScheduler.MergeThread Members | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread Members

ConcurrentMergeScheduler.MergeThread overview

Public Instance Constructors

ConcurrentMergeScheduler.MergeThread Constructor

Public Instance Properties

Enclosing_Instance |
Instance (inherited from ThreadClass) | Gets the current thread instance
IsAlive (inherited from ThreadClass) | Gets a value indicating the execution status of the current thread
IsBackground (inherited from ThreadClass) | Gets or sets a value indicating whether or not a thread is a background thread.
Name (inherited from ThreadClass) | Gets or sets the name of the thread
Priority (inherited from ThreadClass) | Gets or sets a value indicating the scheduling priority of a thread

Public Instance Methods

Abort (inherited from ThreadClass) | Overloaded. Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRunningMerge |
GetType (inherited from Object) | Gets the Type of the current instance.
Interrupt (inherited from ThreadClass) | Interrupts a thread that is in the WaitSleepJoin thread state
Join (inherited from ThreadClass) | Overloaded. Blocks the calling thread until a thread terminates
Resume (inherited from ThreadClass) | Resumes a thread that has been suspended
Run |
SetDaemon (inherited from ThreadClass) |
SetRunningMerge |
SetThreadPriority |
Start (inherited from ThreadClass) | Causes the operating system to change the state of the current thread instance to ThreadState.Running
Suspend (inherited from ThreadClass) | Suspends the thread, if the thread is already suspended it has no effect
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConcurrentMergeScheduler.MergeThread Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread Constructor

public ConcurrentMergeScheduler.MergeThread(
ConcurrentMergeScheduler enclosingInstance,
IndexWriter writer,
OneMerge startMerge
);

See Also

ConcurrentMergeScheduler.MergeThread Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread Properties

The properties of the ConcurrentMergeScheduler.MergeThread class are listed below. For a complete list of ConcurrentMergeScheduler.MergeThread class members, see the ConcurrentMergeScheduler.MergeThread Members topic.

Public Instance Properties

Enclosing_Instance |
Instance (inherited from ThreadClass) | Gets the current thread instance
IsAlive (inherited from ThreadClass) | Gets a value indicating the execution status of the current thread
IsBackground (inherited from ThreadClass) | Gets or sets a value indicating whether or not a thread is a background thread.
Name (inherited from ThreadClass) | Gets or sets the name of the thread
Priority (inherited from ThreadClass) | Gets or sets a value indicating the scheduling priority of a thread

See Also

ConcurrentMergeScheduler.MergeThread Class | Lucene.Net.Index Namespace


Enclosing_Instance Property

Apache Lucene.Net 2.4.0 Class Library API

ConcurrentMergeScheduler.MergeThread.Enclosing_Instance Property

public ConcurrentMergeScheduler Enclosing_Instance {get;}

See Also

ConcurrentMergeScheduler.MergeThread Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread Methods

The methods of the ConcurrentMergeScheduler.MergeThread class are listed below. For a complete list of ConcurrentMergeScheduler.MergeThread class members, see the ConcurrentMergeScheduler.MergeThread Members topic.

Public Instance Methods

Abort (inherited from ThreadClass) | Overloaded. Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRunningMerge |
GetType (inherited from Object) | Gets the Type of the current instance.
Interrupt (inherited from ThreadClass) | Interrupts a thread that is in the WaitSleepJoin thread state
Join (inherited from ThreadClass) | Overloaded. Blocks the calling thread until a thread terminates
Resume (inherited from ThreadClass) | Resumes a thread that has been suspended
Run |
SetDaemon (inherited from ThreadClass) |
SetRunningMerge |
SetThreadPriority |
Start (inherited from ThreadClass) | Causes the operating system to change the state of the current thread instance to ThreadState.Running
Suspend (inherited from ThreadClass) | Suspends the thread, if the thread is already suspended it has no effect
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConcurrentMergeScheduler.MergeThread Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread.GetRunningMerge Method

public virtual OneMerge GetRunningMerge();

See Also

ConcurrentMergeScheduler.MergeThread Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread.Run Method

public override void Run();

Implements

IThreadRunnable.Run

See Also

ConcurrentMergeScheduler.MergeThread Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread.SetRunningMerge Method

public virtual void SetRunningMerge(
OneMerge merge
);

See Also

ConcurrentMergeScheduler.MergeThread Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread.SetThreadPriority Method

public virtual void SetThreadPriority(
int pri
);

See Also

ConcurrentMergeScheduler.MergeThread Class | Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread.ToString Method

public override string ToString();

See Also

ConcurrentMergeScheduler.MergeThread Class | Lucene.Net.Index Namespace


CorruptIndexException Class

This exception is thrown when Lucene detects an inconsistency in the index.

For a list of all members of this type, see CorruptIndexException Members.

System.Object
System.Exception
System.SystemException
System.IO.IOException
Lucene.Net.Index.CorruptIndexException

public class CorruptIndexException : IOException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CorruptIndexException Members | Lucene.Net.Index Namespace


CorruptIndexException Members

CorruptIndexException overview

Public Instance Constructors

CorruptIndexException Constructor

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CorruptIndexException Class | Lucene.Net.Index Namespace


CorruptIndexException Constructor

public CorruptIndexException(
string message
);

See Also

CorruptIndexException Class | Lucene.Net.Index Namespace


DirectoryIndexReader Class

IndexReader implementation that has access to a Directory. Instances that have a SegmentInfos object (i. e. segmentInfos != null) "own" the directory, which means that they try to acquire a write lock whenever index modifications are performed.

For a list of all members of this type, see DirectoryIndexReader Members.

System.Object
Lucene.Net.Index.IndexReader
Lucene.Net.Index.DirectoryIndexReader
Lucene.Net.Index.MultiSegmentReader
Lucene.Net.Index.SegmentReader

public abstract class DirectoryIndexReader : IndexReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DirectoryIndexReader Members | Lucene.Net.Index Namespace


DirectoryIndexReader Members

DirectoryIndexReader overview

Public Static Methods

ListCommits

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef (inherited from IndexReader) | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
DeleteDocument (inherited from IndexReader) Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments (inherited from IndexReader) Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory | Returns the directory this index resides in.
DocFreq (inherited from IndexReader) Returns the number of documents containing the term
t
.
Document (inherited from IndexReader) Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen (inherited from IndexReader)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from IndexReader)
GetFieldNames (inherited from IndexReader) | Get a list of unique field names that exist in this index and have the specified field option information.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit
GetRefCount (inherited from IndexReader)
GetTermFreqVector (inherited from IndexReader) | Overloaded. Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a TermPositionsVector is returned.
GetTermFreqVectors (inherited from IndexReader) | Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector contains terms and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null. The term vectors that are returned my either be of type TermFreqVector or of type TermPositionsVector if positions or offsets have been stored.
GetTermInfosIndexDivisor (inherited from IndexReader)
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | Version number when this IndexReader was opened.
HasDeletions (inherited from IndexReader) | Returns true if any documents have been deleted
HasNorms (inherited from IndexReader) | Returns true if there are norms stored for this field.
IncRef (inherited from IndexReader) | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IsCurrent Check whether this IndexReader is still using the current (i.e., most recently committed) version of the index. If a writer has committed any changes to the index since this reader was opened, this will return
false
, in which case you must open a new IndexReader in order to see the changes. See the description of the
autoCommit
 flag which controls when the {@link IndexWriter} actually commits changes to the index.
IsDeleted (inherited from IndexReader) | Returns true if document n has been deleted
IsOptimized | Checks is the index is optimized (if it has a single segment and no deletions)
MaxDoc (inherited from IndexReader) | Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.
Norms (inherited from IndexReader) | Overloaded. Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
NumDeletedDocs (inherited from IndexReader) | Returns the number of deleted docs.
NumDocs (inherited from IndexReader) | Returns the number of documents in this index.
Reopen
SetDeletionPolicy
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor (inherited from IndexReader) | For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms (inherited from IndexReader) | Overloaded. Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), {@link TermEnum#Next()} must be called on the resulting enumeration before calling other methods such as {@link TermEnum#Term()}.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

DirectoryIndexReader Constructor Initializes a new instance of the DirectoryIndexReader class.

Protected Internal Instance Fields

closeDirectory
directory
hasChanges (inherited from IndexReader)
readOnly

Protected Internal Instance Methods

AcquireWriteLock | Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner.
CommitChanges
DoClose
DoCommit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DoDelete (inherited from IndexReader) Implements deletion of the document numbered
docNum
. Applications should call {@link #DeleteDocument(int)} or {@link #DeleteDocuments(Term)}.
DoReopen | Re-opens the index using the passed-in SegmentInfos
DoSetNorm (inherited from IndexReader) | Implements setNorm in subclass.
DoUndeleteAll (inherited from IndexReader) | Implements actual undeleteAll() in subclass.

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader Constructor

Initializes a new instance of the DirectoryIndexReader class.

protected internal DirectoryIndexReader();

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader Fields

The fields of the DirectoryIndexReader class are listed below. For a complete list of DirectoryIndexReader class members, see the DirectoryIndexReader Members topic.

Protected Internal Instance Fields

closeDirectory
directory
hasChanges (inherited from IndexReader)
readOnly

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.closeDirectory Field

protected internal bool closeDirectory;

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.Directory Method

Returns the directory this index resides in.

public override Directory Directory();

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.readOnly Field

protected internal bool readOnly;

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader Methods

The methods of the DirectoryIndexReader class are listed below. For a complete list of DirectoryIndexReader class members, see the DirectoryIndexReader Members topic.

Public Static Methods

ListCommits

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef (inherited from IndexReader) | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
DeleteDocument (inherited from IndexReader) Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments (inherited from IndexReader) Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory | Returns the directory this index resides in.
DocFreq (inherited from IndexReader) Returns the number of documents containing the term
t
.
Document (inherited from IndexReader) Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen (inherited from IndexReader)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from IndexReader)
GetFieldNames (inherited from IndexReader) | Get a list of unique field names that exist in this index and have the specified field option information.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit
GetRefCount (inherited from IndexReader)
GetTermFreqVector (inherited from IndexReader) | Overloaded. Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a TermPositionsVector is returned.
GetTermFreqVectors (inherited from IndexReader) | Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector contains terms and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null. The term vectors that are returned my either be of type TermFreqVector or of type TermPositionsVector if positions or offsets have been stored.
GetTermInfosIndexDivisor (inherited from IndexReader)
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | Version number when this IndexReader was opened.
HasDeletions (inherited from IndexReader) | Returns true if any documents have been deleted
HasNorms (inherited from IndexReader) | Returns true if there are norms stored for this field.
IncRef (inherited from IndexReader) | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IsCurrent Check whether this IndexReader is still using the current (i.e., most recently committed) version of the index. If a writer has committed any changes to the index since this reader was opened, this will return
false
, in which case you must open a new IndexReader in order to see the changes. See the description of the
autoCommit
 flag which controls when the {@link IndexWriter} actually commits changes to the index.
IsDeleted (inherited from IndexReader) | Returns true if document n has been deleted
IsOptimized | Checks is the index is optimized (if it has a single segment and no deletions)
MaxDoc (inherited from IndexReader) | Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.
Norms (inherited from IndexReader) | Overloaded. Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
NumDeletedDocs (inherited from IndexReader) | Returns the number of deleted docs.
NumDocs (inherited from IndexReader) | Returns the number of documents in this index.
Reopen
SetDeletionPolicy
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor (inherited from IndexReader) | For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms (inherited from IndexReader) | Overloaded. Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), {@link TermEnum#Next()} must be called on the resulting enumeration before calling other methods such as {@link TermEnum#Term()}.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

AcquireWriteLock | Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner.
CommitChanges
DoClose
DoCommit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DoDelete (inherited from IndexReader) Implements deletion of the document numbered
docNum
. Applications should call {@link #DeleteDocument(int)} or {@link #DeleteDocuments(Term)}.
DoReopen | Re-opens the index using the passed-in SegmentInfos
DoSetNorm (inherited from IndexReader) | Implements setNorm in subclass.
DoUndeleteAll (inherited from IndexReader) | Implements actual undeleteAll() in subclass.

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.AcquireWriteLock Method

Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner.

protected internal override void AcquireWriteLock();

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.CommitChanges Method

protected internal abstract void CommitChanges();

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.DoClose Method

protected internal override void DoClose();

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.DoCommit Method

Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

protected internal override void DoCommit();

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.DoReopen Method

Re-opens the index using the passed-in SegmentInfos

protected internal abstract DirectoryIndexReader DoReopen(
SegmentInfos infos
);

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.Finalize Method

Release the write lock, if needed.

protected override void Finalize();

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.GetIndexCommit Method

public override IndexCommit GetIndexCommit();

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.GetVersion Method

Version number when this IndexReader was opened.

public override long GetVersion();

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.IsCurrent Method

Check whether this IndexReader is still using the current (i.e., most recently committed) version of the index. If a writer has committed any changes to the index since this reader was opened, this will return

false
, in which case you must open a new IndexReader in order to see the changes. See the description of the
autoCommit
 flag which controls when the {@link IndexWriter} actually commits changes to the index.

public override bool IsCurrent();

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.IsOptimized Method

Checks is the index is optimized (if it has a single segment and no deletions)

public override bool IsOptimized();

Return Value

true
if the index is optimized;
false
otherwise

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.ListCommits Method

new public static 2, Culture=neutral, PublicKeyToken=null]] ListCommits(
Directory dir
);

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.Reopen Method

public override IndexReader Reopen();

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DirectoryIndexReader.SetDeletionPolicy Method

public virtual void SetDeletionPolicy(
IndexDeletionPolicy deletionPolicy
);

See Also

DirectoryIndexReader Class | Lucene.Net.Index Namespace


DocumentsWriter Class

For a list of all members of this type, see DocumentsWriter Members.

System.Object
Lucene.Net.Index.DocumentsWriter

public sealed class DocumentsWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DocumentsWriter Members | Lucene.Net.Index Namespace


DocumentsWriter Members

DocumentsWriter overview

Public Static Fields

BYTE_BLOCK_SIZE_For_NUnit_Test
CHAR_BLOCK_SIZE

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DocumentsWriter Class | Lucene.Net.Index Namespace


DocumentsWriter Fields

The fields of the DocumentsWriter class are listed below. For a complete list of DocumentsWriter class members, see the DocumentsWriter Members topic.

Public Static Fields

BYTE_BLOCK_SIZE_For_NUnit_Test
CHAR_BLOCK_SIZE

See Also

DocumentsWriter Class | Lucene.Net.Index Namespace


DocumentsWriter.BYTE_BLOCK_SIZE_For_NUnit_Test Field

public static readonly int BYTE_BLOCK_SIZE_For_NUnit_Test;

See Also

DocumentsWriter Class | Lucene.Net.Index Namespace


DocumentsWriter.CHAR_BLOCK_SIZE Field

public static readonly int CHAR_BLOCK_SIZE;

See Also

DocumentsWriter Class | Lucene.Net.Index Namespace


FieldInfo Class

For a list of all members of this type, see FieldInfo Members.

System.Object
Lucene.Net.Index.FieldInfo

public sealed class FieldInfo : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldInfo Members | Lucene.Net.Index Namespace


FieldInfo Members

FieldInfo overview

Public Instance Fields

omitNorms
storeOffsetWithTermVector
storePositionWithTermVector
storeTermVector

Public Instance Properties

Name_ForNUnitTest
omitTf_ForNUnitTest
StorePayloads_ForNUnitTest

Public Instance Methods

Clone |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIndexed_ForNUnitTest |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfo Fields

The fields of the FieldInfo class are listed below. For a complete list of FieldInfo class members, see the FieldInfo Members topic.

Public Instance Fields

omitNorms
storeOffsetWithTermVector
storePositionWithTermVector
storeTermVector

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfo.omitNorms Field

public bool omitNorms;

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfo.storeOffsetWithTermVector Field

public bool storeOffsetWithTermVector;

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfo.storePositionWithTermVector Field

public bool storePositionWithTermVector;

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfo.storeTermVector Field

public bool storeTermVector;

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfo Properties

The properties of the FieldInfo class are listed below. For a complete list of FieldInfo class members, see the FieldInfo Members topic.

Public Instance Properties

Name_ForNUnitTest
omitTf_ForNUnitTest
StorePayloads_ForNUnitTest

See Also

FieldInfo Class | Lucene.Net.Index Namespace


Name_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

FieldInfo.Name_ForNUnitTest Property

public string Name_ForNUnitTest {get;}

See Also

FieldInfo Class | Lucene.Net.Index Namespace


omitTf_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

FieldInfo.omitTf_ForNUnitTest Property

public bool omitTf_ForNUnitTest {get;}

See Also

FieldInfo Class | Lucene.Net.Index Namespace


StorePayloads_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

FieldInfo.StorePayloads_ForNUnitTest Property

public bool StorePayloads_ForNUnitTest {get;}

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfo Methods

The methods of the FieldInfo class are listed below. For a complete list of FieldInfo class members, see the FieldInfo Members topic.

Public Instance Methods

Clone |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIndexed_ForNUnitTest |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfo.Clone Method

public object Clone();

Implements

ICloneable.Clone

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfo.IsIndexed_ForNUnitTest Method

public bool IsIndexed_ForNUnitTest();

See Also

FieldInfo Class | Lucene.Net.Index Namespace


FieldInfos Class

Access to the Fieldable Info file that describes document fields and whether or not they are indexed. Each segment has a separate Fieldable Info file. objects of this class are thread-safe for multiple readers, but only one thread can be adding documents at a time, with no other reader or writer threads accessing this object.

For a list of all members of this type, see FieldInfos Members.

System.Object
Lucene.Net.Index.FieldInfos

public sealed class FieldInfos : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldInfos Members | Lucene.Net.Index Namespace


FieldInfos Members

FieldInfos overview

Public Instance Constructors

FieldInfos Overloaded. Initializes a new instance of the FieldInfos class.

Public Instance Methods

Add | Overloaded. Adds field info for a Document.
AddIndexed | Add fields that are indexed. Whether they have termvectors has to be specified.
Clone | Returns a deep clone of this FieldInfos instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FieldInfo | Overloaded.
FieldName | Return the fieldName identified by its number.
FieldNumber |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVectors |
Size |
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded.

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos Constructor

Initializes a new instance of the FieldInfos class.

Overload List

Initializes a new instance of the FieldInfos class.

public FieldInfos();

Construct a FieldInfos object using the directory and the name of the file IndexInput

public FieldInfos(Directory,string);

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos Constructor ()

Initializes a new instance of the FieldInfos class.

public FieldInfos();

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos Constructor Overload List


FieldInfos Constructor (Directory, String)

Construct a FieldInfos object using the directory and the name of the file IndexInput

public FieldInfos(
Directory d,
string name
);

Parameters

d
The directory to open the IndexInput from
name
The name of the file to open the IndexInput from in the Directory

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos Constructor Overload List


FieldInfos Methods

The methods of the FieldInfos class are listed below. For a complete list of FieldInfos class members, see the FieldInfos Members topic.

Public Instance Methods

Add | Overloaded. Adds field info for a Document.
AddIndexed | Add fields that are indexed. Whether they have termvectors has to be specified.
Clone | Returns a deep clone of this FieldInfos instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FieldInfo | Overloaded.
FieldName | Return the fieldName identified by its number.
FieldNumber |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVectors |
Size |
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded.

See Also

FieldInfos Class | Lucene.Net.Index Namespace


Add Method

Apache Lucene.Net 2.4.0 Class Library API

FieldInfos.Add Method

Adds field info for a Document.

Overload List

Adds field info for a Document.

public void Add(Document);

public FieldInfo Add(FieldInfo);

public void Add(0, Culture=neutral, PublicKeyToken=b77a5c561934e089]],bool);

Calls 5 parameter add with false for all TermVector parameters.

public void Add(string,bool);

Calls 5 parameter add with false for term vector positions and offsets.

public void Add(string,bool,bool);

If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

public void Add(string,bool,bool,bool,bool);

If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

public void Add(string,bool,bool,bool,bool,bool);

If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

public FieldInfo Add(string,bool,bool,bool,bool,bool,bool,bool);

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.Add Method (Document)

Adds field info for a Document.

public void Add(
Document doc
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Add Overload List


FieldInfos.Add Method (FieldInfo)

public FieldInfo Add(
FieldInfo fieldInfo
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Add Overload List


FieldInfos.Add Method (0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], Boolean)

public void Add(
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] names,
bool isIndexed
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Add Overload List


FieldInfos.Add Method (String, Boolean)

Calls 5 parameter add with false for all TermVector parameters.

public void Add(
string name,
bool isIndexed
);

Parameters

name
The name of the Fieldable
isIndexed
true if the field is indexed

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Add Overload List | Add


FieldInfos.Add Method (String, Boolean, Boolean)

Calls 5 parameter add with false for term vector positions and offsets.

public void Add(
string name,
bool isIndexed,
bool storeTermVector
);

Parameters

name
The name of the field
isIndexed
true if the field is indexed
storeTermVector
true if the term vector should be stored

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Add Overload List


FieldInfos.Add Method (String, Boolean, Boolean, Boolean, Boolean)

If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

public void Add(
string name,
bool isIndexed,
bool storeTermVector,
bool storePositionWithTermVector,
bool storeOffsetWithTermVector
);

Parameters

name
The name of the field
isIndexed
true if the field is indexed
storeTermVector
true if the term vector should be stored
storePositionWithTermVector
true if the term vector with positions should be stored
storeOffsetWithTermVector
true if the term vector with offsets should be stored

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Add Overload List


FieldInfos.Add Method (String, Boolean, Boolean, Boolean, Boolean, Boolean)

If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

public void Add(
string name,
bool isIndexed,
bool storeTermVector,
bool storePositionWithTermVector,
bool storeOffsetWithTermVector,
bool omitNorms
);

Parameters

name
The name of the field
isIndexed
true if the field is indexed
storeTermVector
true if the term vector should be stored
storePositionWithTermVector
true if the term vector with positions should be stored
storeOffsetWithTermVector
true if the term vector with offsets should be stored
omitNorms
true if the norms for the indexed field should be omitted

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Add Overload List


FieldInfos.Add Method (String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

public FieldInfo Add(
string name,
bool isIndexed,
bool storeTermVector,
bool storePositionWithTermVector,
bool storeOffsetWithTermVector,
bool omitNorms,
bool storePayloads,
bool omitTf
);

Parameters

name
The name of the field
isIndexed
true if the field is indexed
storeTermVector
true if the term vector should be stored
storePositionWithTermVector
true if the term vector with positions should be stored
storeOffsetWithTermVector
true if the term vector with offsets should be stored
omitNorms
true if the norms for the indexed field should be omitted
storePayloads
true if payloads should be stored for this field
omitTf

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Add Overload List


FieldInfos.AddIndexed Method

Add fields that are indexed. Whether they have termvectors has to be specified.

public void AddIndexed(
ICollection names,
bool storeTermVectors,
bool storePositionWithTermVector,
bool storeOffsetWithTermVector
);

Parameters

names
The names of the fields
storeTermVectors
Whether the fields store term vectors or not
storePositionWithTermVector
treu if positions should be stored.
storeOffsetWithTermVector
true if offsets should be stored

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.Clone Method

Returns a deep clone of this FieldInfos instance.

public object Clone();

Implements

ICloneable.Clone

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfo Method

Apache Lucene.Net 2.4.0 Class Library API

FieldInfos.FieldInfo Method

Return the fieldinfo object referenced by the fieldNumber.

Overload List

Return the fieldinfo object referenced by the fieldNumber.

public FieldInfo FieldInfo(int);

public FieldInfo FieldInfo(string);

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.FieldInfo Method (Int32)

Return the fieldinfo object referenced by the fieldNumber.

public FieldInfo FieldInfo(
int fieldNumber
);

Parameters

fieldNumber

Return Value

the FieldInfo object or null when the given fieldNumber doesn't exist.

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.FieldInfo Overload List


FieldInfos.FieldInfo Method (String)

public FieldInfo FieldInfo(
string fieldName
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.FieldInfo Overload List


FieldInfos.FieldName Method

Return the fieldName identified by its number.

public string FieldName(
int fieldNumber
);

Parameters

fieldNumber

Return Value

the fieldName or an empty string when the field with the given number doesn't exist.

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.FieldNumber Method

public int FieldNumber(
string fieldName
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.HasVectors Method

public bool HasVectors();

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.Size Method

public int Size();

See Also

FieldInfos Class | Lucene.Net.Index Namespace


Write Method

Apache Lucene.Net 2.4.0 Class Library API

FieldInfos.Write Method

Overload List

public void Write(Directory,string);

public void Write(IndexOutput);

See Also

FieldInfos Class | Lucene.Net.Index Namespace


FieldInfos.Write Method (Directory, String)

public void Write(
Directory d,
string name
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Write Overload List


FieldInfos.Write Method (IndexOutput)

public void Write(
IndexOutput output
);

See Also

FieldInfos Class | Lucene.Net.Index Namespace | FieldInfos.Write Overload List


FieldReaderException Class

For a list of all members of this type, see FieldReaderException Members.

System.Object
System.Exception
System.SystemException
Lucene.Net.Index.FieldReaderException

public class FieldReaderException : SystemException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldReaderException Members | Lucene.Net.Index Namespace


FieldReaderException Members

FieldReaderException overview

Public Instance Constructors

FieldReaderException Overloaded. Initializes a new instance of the FieldReaderException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldReaderException Class | Lucene.Net.Index Namespace


FieldReaderException Constructor

Constructs a new runtime exception with

null
as its detail message. The cause is not initialized, and may subsequently be initialized by a call to {@link #initCause}.

Overload List

Constructs a new runtime exception with

null
as its detail message. The cause is not initialized, and may subsequently be initialized by a call to {@link #initCause}.

public FieldReaderException();

public FieldReaderException(Exception);

Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to {@link #initCause}.

public FieldReaderException(string);

public FieldReaderException(string,Exception);

See Also

FieldReaderException Class | Lucene.Net.Index Namespace


FieldReaderException Constructor ()

Constructs a new runtime exception with

null
as its detail message. The cause is not initialized, and may subsequently be initialized by a call to {@link #initCause}.

public FieldReaderException();

See Also

FieldReaderException Class | Lucene.Net.Index Namespace | FieldReaderException Constructor Overload List


FieldReaderException Constructor (Exception)

public FieldReaderException(
Exception cause
);

See Also

FieldReaderException Class | Lucene.Net.Index Namespace | FieldReaderException Constructor Overload List


FieldReaderException Constructor (String)

Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to {@link #initCause}.

public FieldReaderException(
string message
);

Parameters

message
the detail message. The detail message is saved for later retrieval by the {@link #getMessage()} method.

See Also

FieldReaderException Class | Lucene.Net.Index Namespace | FieldReaderException Constructor Overload List


FieldReaderException Constructor (String, Exception)

public FieldReaderException(
string message,
Exception cause
);

See Also

FieldReaderException Class | Lucene.Net.Index Namespace | FieldReaderException Constructor Overload List


FieldSortedTermVectorMapper Class

For each Field, store a sorted collection of {@link TermVectorEntry}s

This is not thread-safe.

For a list of all members of this type, see FieldSortedTermVectorMapper Members.

System.Object
Lucene.Net.Index.TermVectorMapper
Lucene.Net.Index.FieldSortedTermVectorMapper

public class FieldSortedTermVectorMapper : TermVectorMapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldSortedTermVectorMapper Members | Lucene.Net.Index Namespace


FieldSortedTermVectorMapper Members

FieldSortedTermVectorMapper overview

Public Instance Constructors

FieldSortedTermVectorMapper Overloaded. Initializes a new instance of the FieldSortedTermVectorMapper class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetComparator |
GetFieldToTerms | Get the mapping between fields and terms, sorted by the comparator
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIgnoringOffsets (inherited from TermVectorMapper) |
IsIgnoringPositions (inherited from TermVectorMapper) | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.
Map |
SetDocumentNumber (inherited from TermVectorMapper) | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
SetExpectations |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldSortedTermVectorMapper Class | Lucene.Net.Index Namespace


FieldSortedTermVectorMapper Constructor

Overload List

public FieldSortedTermVectorMapper(bool,bool,0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]);

public FieldSortedTermVectorMapper(0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]);

See Also

FieldSortedTermVectorMapper Class | Lucene.Net.Index Namespace


FieldSortedTermVectorMapper Constructor (0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])

public FieldSortedTermVectorMapper(
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] comparator
);

See Also

FieldSortedTermVectorMapper Class | Lucene.Net.Index Namespace | FieldSortedTermVectorMapper Constructor Overload List


FieldSortedTermVectorMapper Constructor (Boolean, Boolean, 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])

public FieldSortedTermVectorMapper(
bool ignoringPositions,
bool ignoringOffsets,
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] comparator
);

See Also

FieldSortedTermVectorMapper Class | Lucene.Net.Index Namespace | FieldSortedTermVectorMapper Constructor Overload List


FieldSortedTermVectorMapper Methods

The methods of the FieldSortedTermVectorMapper class are listed below. For a complete list of FieldSortedTermVectorMapper class members, see the FieldSortedTermVectorMapper Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetComparator |
GetFieldToTerms | Get the mapping between fields and terms, sorted by the comparator
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIgnoringOffsets (inherited from TermVectorMapper) |
IsIgnoringPositions (inherited from TermVectorMapper) | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.
Map |
SetDocumentNumber (inherited from TermVectorMapper) | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
SetExpectations |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldSortedTermVectorMapper Class | Lucene.Net.Index Namespace


FieldSortedTermVectorMapper.GetComparator Method

public virtual 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetComparator();

See Also

FieldSortedTermVectorMapper Class | Lucene.Net.Index Namespace


FieldSortedTermVectorMapper.GetFieldToTerms Method

Get the mapping between fields and terms, sorted by the comparator

public virtual IDictionary GetFieldToTerms();

Return Value

A map between field names and {@link java.util.SortedSet}s per field. SortedSet entries are {@link TermVectorEntry}

See Also

FieldSortedTermVectorMapper Class | Lucene.Net.Index Namespace


FieldSortedTermVectorMapper.Map Method

public override void Map(
string term,
int frequency,
TermVectorOffsetInfo[] offsets,
int[] positions
);

See Also

FieldSortedTermVectorMapper Class | Lucene.Net.Index Namespace


FieldSortedTermVectorMapper.SetExpectations Method

public override void SetExpectations(
string field,
int numTerms,
bool storeOffsets,
bool storePositions
);

See Also

FieldSortedTermVectorMapper Class | Lucene.Net.Index Namespace


FieldsReader Class

Class responsible for access to stored document fields.

It uses <segment>.fdt and <segment>.fdx; files.

For a list of all members of this type, see FieldsReader Members.

System.Object
Lucene.Net.Index.FieldsReader

public sealed class FieldsReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldsReader Members | Lucene.Net.Index Namespace


FieldsReader Members

FieldsReader overview

Public Instance Constructors

FieldsReader Constructor

Public Instance Methods

Close | Closes the underlying {@link Lucene.Net.Store.IndexInput} streams, including any ones associated with a lazy implementation of a Field. This means that the Fields values will not be accessible.
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Size |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FieldsReader Class | Lucene.Net.Index Namespace


FieldsReader Constructor

public FieldsReader(
Directory d,
string segment,
FieldInfos fn
);

See Also

FieldsReader Class | Lucene.Net.Index Namespace


FieldsReader Methods

The methods of the FieldsReader class are listed below. For a complete list of FieldsReader class members, see the FieldsReader Members topic.

Public Instance Methods

Close | Closes the underlying {@link Lucene.Net.Store.IndexInput} streams, including any ones associated with a lazy implementation of a Field. This means that the Fields values will not be accessible.
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Size |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FieldsReader Class | Lucene.Net.Index Namespace


FieldsReader.Close Method

Closes the underlying {@link Lucene.Net.Store.IndexInput} streams, including any ones associated with a lazy implementation of a Field. This means that the Fields values will not be accessible.

public void Close();

See Also

FieldsReader Class | Lucene.Net.Index Namespace


FieldsReader.Doc Method

public Document Doc(
int n,
FieldSelector fieldSelector
);

See Also

FieldsReader Class | Lucene.Net.Index Namespace


FieldsReader.Size Method

public int Size();

See Also

FieldsReader Class | Lucene.Net.Index Namespace


FieldsReader.FieldForMerge Class

For a list of all members of this type, see FieldsReader.FieldForMerge Members.

System.Object
Lucene.Net.Documents.AbstractField
Lucene.Net.Index.FieldsReader.FieldForMerge

public sealed class FieldsReader.FieldForMerge : AbstractField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldsReader.FieldForMerge Members | Lucene.Net.Index Namespace


FieldsReader.FieldForMerge Members

FieldsReader.FieldForMerge overview

Public Instance Constructors

FieldsReader.FieldForMerge Constructor

Public Instance Methods

BinaryValue
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBinaryLength (inherited from AbstractField) | Returns the length of byte[] segment that is used as value. If Field is not binary returned value is undefined.
GetBinaryOffset (inherited from AbstractField) | Returns offset into byte[] segment that is used as value. If Field is not binary returned value is undefined.
GetBinaryValue (inherited from AbstractField) | Overloaded. Return the raw byte[] for the binary field. Note that you must also call {@link #GetBinaryLength} and {@link #GetBinaryOffset} to know which range of bytes in this returned array belong to the field.
GetBoost (inherited from AbstractField)
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOmitNorms (inherited from AbstractField) | True if norms are omitted for this indexed field
GetOmitTf (inherited from AbstractField) | Returns true if tf is omitted for this indexed field.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBinary (inherited from AbstractField) | True iff the value of the filed is stored as binary
IsCompressed (inherited from AbstractField) | True if the value of the field is stored and compressed within the index
IsIndexed (inherited from AbstractField) | True iff the value of the field is to be indexed, so that it may be searched on.
IsLazy (inherited from AbstractField)
IsStored (inherited from AbstractField) | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
IsStoreOffsetWithTermVector (inherited from AbstractField) | True iff terms are stored as term vector together with their offsets (start and end positon in source text).
IsStorePositionWithTermVector (inherited from AbstractField) | True iff terms are stored as term vector together with their token positions.
IsTermVectorStored (inherited from AbstractField) True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
stored
attribute instead.
IsTokenized (inherited from AbstractField) | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Name (inherited from AbstractField) | Returns the name of the field as an interned string. For example "date", "title", "body", ...
ReaderValue
SetBoost (inherited from AbstractField)
SetOmitNorms (inherited from AbstractField) | Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
SetOmitTf (inherited from AbstractField) | Expert: If set, omit tf from postings of this indexed field.
StringValue
TokenStreamValue
ToString (inherited from AbstractField) | Prints a Field for human consumption.

Protected Internal Instance Fields

boost (inherited from AbstractField)
fieldsData (inherited from AbstractField)
isBinary (inherited from AbstractField)
isCompressed (inherited from AbstractField)
isIndexed (inherited from AbstractField)
isStored (inherited from AbstractField)
isTokenized (inherited from AbstractField)
lazy (inherited from AbstractField)
name (inherited from AbstractField)
omitNorms (inherited from AbstractField)
omitTf (inherited from AbstractField)
storeOffsetWithTermVector (inherited from AbstractField)
storePositionWithTermVector (inherited from AbstractField)
storeTermVector (inherited from AbstractField)

Protected Internal Instance Methods

SetStoreTermVector (inherited from AbstractField)

See Also

FieldsReader.FieldForMerge Class | Lucene.Net.Index Namespace


FieldsReader.FieldForMerge Constructor

public FieldsReader.FieldForMerge(
object value_Renamed,
FieldInfo fi,
bool binary,
bool compressed,
bool tokenize
);

See Also

FieldsReader.FieldForMerge Class | Lucene.Net.Index Namespace


FieldsReader.FieldForMerge Methods

The methods of the FieldsReader.FieldForMerge class are listed below. For a complete list of FieldsReader.FieldForMerge class members, see the FieldsReader.FieldForMerge Members topic.

Public Instance Methods

BinaryValue
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBinaryLength (inherited from AbstractField) | Returns the length of byte[] segment that is used as value. If Field is not binary returned value is undefined.
GetBinaryOffset (inherited from AbstractField) | Returns offset into byte[] segment that is used as value. If Field is not binary returned value is undefined.
GetBinaryValue (inherited from AbstractField) | Overloaded. Return the raw byte[] for the binary field. Note that you must also call {@link #GetBinaryLength} and {@link #GetBinaryOffset} to know which range of bytes in this returned array belong to the field.
GetBoost (inherited from AbstractField)
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOmitNorms (inherited from AbstractField) | True if norms are omitted for this indexed field
GetOmitTf (inherited from AbstractField) | Returns true if tf is omitted for this indexed field.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBinary (inherited from AbstractField) | True iff the value of the filed is stored as binary
IsCompressed (inherited from AbstractField) | True if the value of the field is stored and compressed within the index
IsIndexed (inherited from AbstractField) | True iff the value of the field is to be indexed, so that it may be searched on.
IsLazy (inherited from AbstractField)
IsStored (inherited from AbstractField) | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
IsStoreOffsetWithTermVector (inherited from AbstractField) | True iff terms are stored as term vector together with their offsets (start and end positon in source text).
IsStorePositionWithTermVector (inherited from AbstractField) | True iff terms are stored as term vector together with their token positions.
IsTermVectorStored (inherited from AbstractField) True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
stored
attribute instead.
IsTokenized (inherited from AbstractField) | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Name (inherited from AbstractField) | Returns the name of the field as an interned string. For example "date", "title", "body", ...
ReaderValue
SetBoost (inherited from AbstractField)
SetOmitNorms (inherited from AbstractField) | Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
SetOmitTf (inherited from AbstractField) | Expert: If set, omit tf from postings of this indexed field.
StringValue
TokenStreamValue
ToString (inherited from AbstractField) | Prints a Field for human consumption.

Protected Internal Instance Methods

SetStoreTermVector (inherited from AbstractField)

See Also

FieldsReader.FieldForMerge Class | Lucene.Net.Index Namespace


FieldsReader.FieldForMerge.BinaryValue Method

public override byte[] BinaryValue();

Implements

Fieldable.BinaryValue

See Also

FieldsReader.FieldForMerge Class | Lucene.Net.Index Namespace


FieldsReader.FieldForMerge.ReaderValue Method

public override TextReader ReaderValue();

Implements

Fieldable.ReaderValue

See Also

FieldsReader.FieldForMerge Class | Lucene.Net.Index Namespace


FieldsReader.FieldForMerge.StringValue Method

public override string StringValue();

Implements

Fieldable.StringValue

See Also

FieldsReader.FieldForMerge Class | Lucene.Net.Index Namespace


FieldsReader.FieldForMerge.TokenStreamValue Method

public override TokenStream TokenStreamValue();

Implements

Fieldable.TokenStreamValue

See Also

FieldsReader.FieldForMerge Class | Lucene.Net.Index Namespace


FilterIndexReader Class

A

FilterIndexReader
contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class
FilterIndexReader
itself simply implements all abstract methods of
IndexReader
with versions that pass all requests to the contained index reader. Subclasses of
FilterIndexReader
may further override some of these methods and may also provide additional methods and fields.

For a list of all members of this type, see FilterIndexReader Members.

System.Object
Lucene.Net.Index.IndexReader
Lucene.Net.Index.FilterIndexReader

public class FilterIndexReader : IndexReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilterIndexReader Members | Lucene.Net.Index Namespace


FilterIndexReader Members

FilterIndexReader overview

Public Instance Constructors

FilterIndexReader Constructor

Construct a FilterIndexReader based on the specified base reader. Directory locking for delete, undeleteAll, and setNorm operations is left to the base reader.

Note that base reader is closed if this FilterIndexReader is closed.

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef (inherited from IndexReader) | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
DeleteDocument (inherited from IndexReader) Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments (inherited from IndexReader) Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory
DocFreq
Document | Overloaded.
Document (inherited from IndexReader) Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen (inherited from IndexReader)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from IndexReader)
GetFieldNames
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit (inherited from IndexReader) | Expert: Return the IndexCommit that this reader has open. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: This API is new and experimental and may suddenly change.
GetRefCount (inherited from IndexReader)
GetTermFreqVector | Overloaded.
GetTermFreqVectors
GetTermInfosIndexDivisor (inherited from IndexReader)
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion
HasDeletions
HasNorms
IncRef (inherited from IndexReader) | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IsCurrent
IsDeleted
IsOptimized
MaxDoc
Norms | Overloaded.
NumDeletedDocs (inherited from IndexReader) | Returns the number of deleted docs.
NumDocs
Reopen (inherited from IndexReader)
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor (inherited from IndexReader) | For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

hasChanges (inherited from IndexReader)
in_Renamed

Protected Internal Instance Methods

AcquireWriteLock (inherited from IndexReader) | Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
DoClose |
DoCommit |
DoDelete |
DoSetNorm |
DoUndeleteAll |

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader Constructor

Construct a FilterIndexReader based on the specified base reader. Directory locking for delete, undeleteAll, and setNorm operations is left to the base reader.

Note that base reader is closed if this FilterIndexReader is closed.

public FilterIndexReader(
IndexReader in_Renamed
);

Parameters

in_Renamed

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader Fields

The fields of the FilterIndexReader class are listed below. For a complete list of FilterIndexReader class members, see the FilterIndexReader Members topic.

Protected Internal Instance Fields

hasChanges (inherited from IndexReader)
in_Renamed

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.in_Renamed Field

protected internal IndexReader in_Renamed;

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader Methods

The methods of the FilterIndexReader class are listed below. For a complete list of FilterIndexReader class members, see the FilterIndexReader Members topic.

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef (inherited from IndexReader) | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
DeleteDocument (inherited from IndexReader) Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments (inherited from IndexReader) Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory
DocFreq
Document | Overloaded.
Document (inherited from IndexReader) Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen (inherited from IndexReader)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from IndexReader)
GetFieldNames
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit (inherited from IndexReader) | Expert: Return the IndexCommit that this reader has open. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: This API is new and experimental and may suddenly change.
GetRefCount (inherited from IndexReader)
GetTermFreqVector | Overloaded.
GetTermFreqVectors
GetTermInfosIndexDivisor (inherited from IndexReader)
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion
HasDeletions
HasNorms
IncRef (inherited from IndexReader) | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IsCurrent
IsDeleted
IsOptimized
MaxDoc
Norms | Overloaded.
NumDeletedDocs (inherited from IndexReader) | Returns the number of deleted docs.
NumDocs
Reopen (inherited from IndexReader)
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor (inherited from IndexReader) | For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

AcquireWriteLock (inherited from IndexReader) | Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
DoClose |
DoCommit |
DoDelete |
DoSetNorm |
DoUndeleteAll |

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.Directory Method

public override Directory Directory();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.DocFreq Method

public override int DocFreq(
Term t
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.DoClose Method

protected internal override void DoClose();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.DoCommit Method

protected internal override void DoCommit();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


Document Method

Apache Lucene.Net 2.4.0 Class Library API

FilterIndexReader.Document Method

Overload List

Inherited from IndexReader.

public virtual Document Document(int);

public override Document Document(int,FieldSelector);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.Document Method (Int32, FieldSelector)

public override Document Document(
int n,
FieldSelector fieldSelector
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.Document Overload List


FilterIndexReader.DoDelete Method

protected internal override void DoDelete(
int n
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.DoSetNorm Method

protected internal override void DoSetNorm(
int d,
string f,
byte b
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.DoUndeleteAll Method

protected internal override void DoUndeleteAll();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.GetFieldNames Method

public override 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetFieldNames(
FieldOption fieldNames
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


GetTermFreqVector Method

Apache Lucene.Net 2.4.0 Class Library API

FilterIndexReader.GetTermFreqVector Method

Overload List

public override void GetTermFreqVector(int,TermVectorMapper);

public override TermFreqVector GetTermFreqVector(int,string);

public override void GetTermFreqVector(int,string,TermVectorMapper);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.GetTermFreqVector Method (Int32, TermVectorMapper)

public override void GetTermFreqVector(
int docNumber,
TermVectorMapper mapper
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.GetTermFreqVector Overload List


FilterIndexReader.GetTermFreqVector Method (Int32, String)

public override TermFreqVector GetTermFreqVector(
int docNumber,
string field
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.GetTermFreqVector Overload List


FilterIndexReader.GetTermFreqVector Method (Int32, String, TermVectorMapper)

public override void GetTermFreqVector(
int docNumber,
string field,
TermVectorMapper mapper
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.GetTermFreqVector Overload List


FilterIndexReader.GetTermFreqVectors Method

public override TermFreqVector[] GetTermFreqVectors(
int docNumber
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.GetVersion Method

public override long GetVersion();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.HasDeletions Method

public override bool HasDeletions();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.HasNorms Method

public override bool HasNorms(
string field
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.IsCurrent Method

public override bool IsCurrent();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.IsDeleted Method

public override bool IsDeleted(
int n
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.IsOptimized Method

public override bool IsOptimized();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.MaxDoc Method

public override int MaxDoc();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


Norms Method

Apache Lucene.Net 2.4.0 Class Library API

FilterIndexReader.Norms Method

Overload List

public override byte[] Norms(string);

public override void Norms(string,byte[],int);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.Norms Method (String)

public override byte[] Norms(
string f
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.Norms Overload List


FilterIndexReader.Norms Method (String, Byte[], Int32)

public override void Norms(
string f,
byte[] bytes,
int offset
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.Norms Overload List


FilterIndexReader.NumDocs Method

public override int NumDocs();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


TermDocs Method

Apache Lucene.Net 2.4.0 Class Library API

FilterIndexReader.TermDocs Method

Overload List

public override TermDocs TermDocs();

Inherited from IndexReader.

public virtual TermDocs TermDocs(Term);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.TermDocs Method ()

public override TermDocs TermDocs();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.TermDocs Overload List


TermPositions Method

Apache Lucene.Net 2.4.0 Class Library API

FilterIndexReader.TermPositions Method

Overload List

public override TermPositions TermPositions();

Inherited from IndexReader.

public virtual TermPositions TermPositions(Term);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.TermPositions Method ()

public override TermPositions TermPositions();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.TermPositions Overload List


Terms Method

Apache Lucene.Net 2.4.0 Class Library API

FilterIndexReader.Terms Method

Overload List

public override TermEnum Terms();

public override TermEnum Terms(Term);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace


FilterIndexReader.Terms Method ()

public override TermEnum Terms();

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.Terms Overload List


FilterIndexReader.Terms Method (Term)

public override TermEnum Terms(
Term t
);

See Also

FilterIndexReader Class | Lucene.Net.Index Namespace | FilterIndexReader.Terms Overload List


FilterIndexReader.FilterTermDocs Class

Base class for filtering {@link TermDocs} implementations.

For a list of all members of this type, see FilterIndexReader.FilterTermDocs Members.

System.Object
Lucene.Net.Index.FilterIndexReader.FilterTermDocs
Lucene.Net.Index.FilterIndexReader.FilterTermPositions

public class FilterIndexReader.FilterTermDocs : TermDocs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilterIndexReader.FilterTermDocs Members | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Members

FilterIndexReader.FilterTermDocs overview

Public Instance Constructors

FilterIndexReader.FilterTermDocs Constructor

Public Instance Methods

Close |
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Read |
Seek | Overloaded.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

in_Renamed

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Constructor

public FilterIndexReader.FilterTermDocs(
TermDocs in_Renamed
);

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Fields

The fields of the FilterIndexReader.FilterTermDocs class are listed below. For a complete list of FilterIndexReader.FilterTermDocs class members, see the FilterIndexReader.FilterTermDocs Members topic.

Protected Internal Instance Fields

in_Renamed

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.in_Renamed Field

protected internal TermDocs in_Renamed;

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Methods

The methods of the FilterIndexReader.FilterTermDocs class are listed below. For a complete list of FilterIndexReader.FilterTermDocs class members, see the FilterIndexReader.FilterTermDocs Members topic.

Public Instance Methods

Close |
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Read |
Seek | Overloaded.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.Close Method

public virtual void Close();

Implements

TermDocs.Close

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.Doc Method

public virtual int Doc();

Implements

TermDocs.Doc

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.Freq Method

public virtual int Freq();

Implements

TermDocs.Freq

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.Next Method

public virtual bool Next();

Implements

TermDocs.Next

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.Read Method

public virtual int Read(
int[] docs,
int[] freqs
);

Implements

TermDocs.Read

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


Seek Method

Apache Lucene.Net 2.4.0 Class Library API

FilterIndexReader.FilterTermDocs.Seek Method

Overload List

public virtual void Seek(Term);

public virtual void Seek(TermEnum);

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs.Seek Method (Term)

public virtual void Seek(
Term term
);

Implements

TermDocs.Seek

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace | FilterIndexReader.FilterTermDocs.Seek Overload List


FilterIndexReader.FilterTermDocs.Seek Method (TermEnum)

public virtual void Seek(
TermEnum termEnum
);

Implements

TermDocs.Seek

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace | FilterIndexReader.FilterTermDocs.Seek Overload List


FilterIndexReader.FilterTermDocs.SkipTo Method

public virtual bool SkipTo(
int i
);

Implements

TermDocs.SkipTo

See Also

FilterIndexReader.FilterTermDocs Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Class

Base class for filtering {@link TermEnum} implementations.

For a list of all members of this type, see FilterIndexReader.FilterTermEnum Members.

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Index.FilterIndexReader.FilterTermEnum

public class FilterIndexReader.FilterTermEnum : TermEnum

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilterIndexReader.FilterTermEnum Members | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Members

FilterIndexReader.FilterTermEnum overview

Public Instance Constructors

FilterIndexReader.FilterTermEnum Constructor

Public Instance Methods

Close |
DocFreq |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
SkipTo (inherited from TermEnum) |
Term |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

in_Renamed

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Constructor

public FilterIndexReader.FilterTermEnum(
TermEnum in_Renamed
);

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Fields

The fields of the FilterIndexReader.FilterTermEnum class are listed below. For a complete list of FilterIndexReader.FilterTermEnum class members, see the FilterIndexReader.FilterTermEnum Members topic.

Protected Internal Instance Fields

in_Renamed

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum.in_Renamed Field

protected internal TermEnum in_Renamed;

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Methods

The methods of the FilterIndexReader.FilterTermEnum class are listed below. For a complete list of FilterIndexReader.FilterTermEnum class members, see the FilterIndexReader.FilterTermEnum Members topic.

Public Instance Methods

Close |
DocFreq |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
SkipTo (inherited from TermEnum) |
Term |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum.Close Method

public override void Close();

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum.DocFreq Method

public override int DocFreq();

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum.Next Method

public override bool Next();

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum.Term Method

public override Term Term();

See Also

FilterIndexReader.FilterTermEnum Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Class

Base class for filtering {@link TermPositions} implementations.

For a list of all members of this type, see FilterIndexReader.FilterTermPositions Members.

System.Object
Lucene.Net.Index.FilterIndexReader.FilterTermDocs
Lucene.Net.Index.FilterIndexReader.FilterTermPositions

public class FilterIndexReader.FilterTermPositions : FilterTermDocs, TermPositions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilterIndexReader.FilterTermPositions Members | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Members

FilterIndexReader.FilterTermPositions overview

Public Instance Constructors

FilterIndexReader.FilterTermPositions Constructor

Public Instance Methods

Close (inherited from FilterTermDocs) |
Doc (inherited from FilterTermDocs) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq (inherited from FilterTermDocs) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPayload |
GetPayloadLength |
GetType (inherited from Object) | Gets the Type of the current instance.
IsPayloadAvailable |
Next (inherited from FilterTermDocs) |
NextPosition |
Read (inherited from FilterTermDocs) |
Seek (inherited from FilterTermDocs) | Overloaded.
SkipTo (inherited from FilterTermDocs) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

in_Renamed (inherited from FilterTermDocs)

See Also

FilterIndexReader.FilterTermPositions Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Constructor

public FilterIndexReader.FilterTermPositions(
TermPositions in_Renamed
);

See Also

FilterIndexReader.FilterTermPositions Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Methods

The methods of the FilterIndexReader.FilterTermPositions class are listed below. For a complete list of FilterIndexReader.FilterTermPositions class members, see the FilterIndexReader.FilterTermPositions Members topic.

Public Instance Methods

Close (inherited from FilterTermDocs) |
Doc (inherited from FilterTermDocs) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq (inherited from FilterTermDocs) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPayload |
GetPayloadLength |
GetType (inherited from Object) | Gets the Type of the current instance.
IsPayloadAvailable |
Next (inherited from FilterTermDocs) |
NextPosition |
Read (inherited from FilterTermDocs) |
Seek (inherited from FilterTermDocs) | Overloaded.
SkipTo (inherited from FilterTermDocs) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterIndexReader.FilterTermPositions Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions.GetPayload Method

public virtual byte[] GetPayload(
byte[] data,
int offset
);

Implements

TermPositions.GetPayload

See Also

FilterIndexReader.FilterTermPositions Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions.GetPayloadLength Method

public virtual int GetPayloadLength();

Implements

TermPositions.GetPayloadLength

See Also

FilterIndexReader.FilterTermPositions Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions.IsPayloadAvailable Method

public virtual bool IsPayloadAvailable();

Implements

TermPositions.IsPayloadAvailable

See Also

FilterIndexReader.FilterTermPositions Class | Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions.NextPosition Method

public virtual int NextPosition();

Implements

TermPositions.NextPosition

See Also

FilterIndexReader.FilterTermPositions Class | Lucene.Net.Index Namespace


IndexCommit Class

Deprecated. Please subclass Indexcommit class instead.

For a list of all members of this type, see IndexCommit Members.

System.Object
Lucene.Net.Index.IndexCommit

public abstract class IndexCommit : IndexCommitPoint

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexCommit Members | Lucene.Net.Index Namespace


IndexCommit Members

IndexCommit overview

Public Instance Methods

Delete |
Equals |
GetDirectory |
GetFileNames |
GetGeneration |
GetHashCode |
GetSegmentsFileName |
GetTimestamp |
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion |
IsDeleted |
IsOptimized |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

IndexCommit Constructor Initializes a new instance of the IndexCommit class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit Constructor

Initializes a new instance of the IndexCommit class.

protected IndexCommit();

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit Methods

The methods of the IndexCommit class are listed below. For a complete list of IndexCommit class members, see the IndexCommit Members topic.

Public Instance Methods

Delete |
Equals |
GetDirectory |
GetFileNames |
GetGeneration |
GetHashCode |
GetSegmentsFileName |
GetTimestamp |
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion |
IsDeleted |
IsOptimized |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit.Delete Method

public virtual void Delete();

Implements

IndexCommitPoint.Delete

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit.Equals Method

public override bool Equals(
object other
);

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit.GetDirectory Method

public abstract Directory GetDirectory();

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit.GetFileNames Method

public abstract 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetFileNames();

Implements

IndexCommitPoint.GetFileNames

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit.GetGeneration Method

public virtual long GetGeneration();

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit.GetHashCode Method

public override int GetHashCode();

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit.GetSegmentsFileName Method

public abstract string GetSegmentsFileName();

Implements

IndexCommitPoint.GetSegmentsFileName

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit.GetTimestamp Method

public long GetTimestamp();

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit.GetVersion Method

public virtual long GetVersion();

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit.IsDeleted Method

public virtual bool IsDeleted();

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommit.IsOptimized Method

public virtual bool IsOptimized();

See Also

IndexCommit Class | Lucene.Net.Index Namespace


IndexCommitPoint Interface

For a list of all members of this type, see IndexCommitPoint Members.

public interface IndexCommitPoint

Types that implement IndexCommitPoint

Type | Description
IndexCommit | Deprecated. Please subclass Indexcommit class instead.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexCommitPoint Members | Lucene.Net.Index Namespace


IndexCommitPoint Members

IndexCommitPoint overview

Public Instance Methods

Delete
GetFileNames Returns all index files referenced by this commit point.
GetSegmentsFileName Get the segments file (
segments_N
) associated with this commit point.

See Also

IndexCommitPoint Interface | Lucene.Net.Index Namespace


IndexCommitPoint Methods

The methods of the IndexCommitPoint interface are listed below. For a complete list of IndexCommitPoint interface members, see the IndexCommitPoint Members topic.

Public Instance Methods

Delete
GetFileNames Returns all index files referenced by this commit point.
GetSegmentsFileName Get the segments file (
segments_N
) associated with this commit point.

See Also

IndexCommitPoint Interface | Lucene.Net.Index Namespace


IndexCommitPoint.Delete Method

void Delete();

See Also

IndexCommitPoint Interface | Lucene.Net.Index Namespace


IndexCommitPoint.GetFileNames Method

Returns all index files referenced by this commit point.

0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetFileNames();

See Also

IndexCommitPoint Interface | Lucene.Net.Index Namespace


IndexCommitPoint.GetSegmentsFileName Method

Get the segments file (

segments_N
) associated with this commit point.

string GetSegmentsFileName();

See Also

IndexCommitPoint Interface | Lucene.Net.Index Namespace


IndexDeletionPolicy Interface

For a list of all members of this type, see IndexDeletionPolicy Members.

public interface IndexDeletionPolicy

Types that implement IndexDeletionPolicy

Type | Description
KeepOnlyLastCommitDeletionPolicy | This {@link IndexDeletionPolicy} implementation that keeps only the most recent commit and immediately removes all prior commits after a new commit is done. This is the default deletion policy.
SnapshotDeletionPolicy | A {@link IndexDeletionPolicy} that wraps around any other {@link IndexDeletionPolicy} and adds the ability to hold and later release a single "snapshot" of an index. While the snapshot is held, the {@link IndexWriter} will not remove any files associated with it even if the index is otherwise being actively, arbitrarily changed. Because we wrap another arbitrary {@link IndexDeletionPolicy}, this gives you the freedom to continue using whatever {@link IndexDeletionPolicy} you would normally want to use with your index. Note that you can re-use a single instance of SnapshotDeletionPolicy across multiple writers as long as they are against the same index Directory. Any snapshot held when a writer is closed will "survive" when the next writer is opened. WARNING: This API is new and experimental and may suddnely changendex.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexDeletionPolicy Members | Lucene.Net.Index Namespace


IndexDeletionPolicy Members

IndexDeletionPolicy overview

Public Instance Methods

OnCommit
OnInit

See Also

IndexDeletionPolicy Interface | Lucene.Net.Index Namespace


IndexDeletionPolicy Methods

The methods of the IndexDeletionPolicy interface are listed below. For a complete list of IndexDeletionPolicy interface members, see the IndexDeletionPolicy Members topic.

Public Instance Methods

OnCommit
OnInit

See Also

IndexDeletionPolicy Interface | Lucene.Net.Index Namespace


IndexDeletionPolicy.OnCommit Method

void OnCommit(
2, Culture=neutral, PublicKeyToken=null]] commits
);

See Also

IndexDeletionPolicy Interface | Lucene.Net.Index Namespace


IndexDeletionPolicy.OnInit Method

void OnInit(
2, Culture=neutral, PublicKeyToken=null]] commits
);

See Also

IndexDeletionPolicy Interface | Lucene.Net.Index Namespace


IndexFileDeleter Class

For a list of all members of this type, see IndexFileDeleter Members.

System.Object
Lucene.Net.Index.IndexFileDeleter

public sealed class IndexFileDeleter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexFileDeleter Members | Lucene.Net.Index Namespace


IndexFileDeleter Members

IndexFileDeleter overview

Public Static Fields

VERBOSE_REF_COUNTS Change to true to see details of reference counts when infoStream != null

Public Instance Constructors

IndexFileDeleter Constructor Initialize the deleter: find all previous commits in the Directory, incref the files they reference, call the policy to let it delete commits. The incoming segmentInfos must have been loaded from a commit point and not yet modified. This will remove any files not referenced by any of the commits.

Public Instance Methods

Checkpoint | For definition of "check point" see IndexWriter comments: "Clarification: Check Points (and commits)". Writer calls this when it has made a "consistent change" to the index, meaning new files are written to the index and the in-memory SegmentInfos have been modified to point to those files. This may or may not be a commit (segments_N may or may not have been written). We simply incref the files referenced by the new SegmentInfos and decref the files we had previously seen (if any). If this is a commit, we also call the policy to give it a chance to remove other commits. If any commits are removed, we decref their files as well.
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Overloaded. Writer calls this when it has hit an error and had to roll back, to tell us that there may now be unreferenced files in the filesystem. So we re-list the filesystem and delete such files. If segmentName is non-null, we will only delete files corresponding to that segment.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IndexFileDeleter Class | Lucene.Net.Index Namespace


IndexFileDeleter Constructor

Initialize the deleter: find all previous commits in the Directory, incref the files they reference, call the policy to let it delete commits. The incoming segmentInfos must have been loaded from a commit point and not yet modified. This will remove any files not referenced by any of the commits.

public IndexFileDeleter(
Directory directory,
IndexDeletionPolicy policy,
SegmentInfos segmentInfos,
TextWriter infoStream,
DocumentsWriter docWriter
);

See Also

IndexFileDeleter Class | Lucene.Net.Index Namespace


IndexFileDeleter Fields

The fields of the IndexFileDeleter class are listed below. For a complete list of IndexFileDeleter class members, see the IndexFileDeleter Members topic.

Public Static Fields

VERBOSE_REF_COUNTS Change to true to see details of reference counts when infoStream != null

See Also

IndexFileDeleter Class | Lucene.Net.Index Namespace


IndexFileDeleter.VERBOSE_REF_COUNTS Field

Change to true to see details of reference counts when infoStream != null

public static bool VERBOSE_REF_COUNTS;

See Also

IndexFileDeleter Class | Lucene.Net.Index Namespace


IndexFileDeleter Methods

The methods of the IndexFileDeleter class are listed below. For a complete list of IndexFileDeleter class members, see the IndexFileDeleter Members topic.

Public Instance Methods

Checkpoint | For definition of "check point" see IndexWriter comments: "Clarification: Check Points (and commits)". Writer calls this when it has made a "consistent change" to the index, meaning new files are written to the index and the in-memory SegmentInfos have been modified to point to those files. This may or may not be a commit (segments_N may or may not have been written). We simply incref the files referenced by the new SegmentInfos and decref the files we had previously seen (if any). If this is a commit, we also call the policy to give it a chance to remove other commits. If any commits are removed, we decref their files as well.
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Overloaded. Writer calls this when it has hit an error and had to roll back, to tell us that there may now be unreferenced files in the filesystem. So we re-list the filesystem and delete such files. If segmentName is non-null, we will only delete files corresponding to that segment.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IndexFileDeleter Class | Lucene.Net.Index Namespace


IndexFileDeleter.Checkpoint Method

For definition of "check point" see IndexWriter comments: "Clarification: Check Points (and commits)". Writer calls this when it has made a "consistent change" to the index, meaning new files are written to the index and the in-memory SegmentInfos have been modified to point to those files. This may or may not be a commit (segments_N may or may not have been written). We simply incref the files referenced by the new SegmentInfos and decref the files we had previously seen (if any). If this is a commit, we also call the policy to give it a chance to remove other commits. If any commits are removed, we decref their files as well.

public void Checkpoint(
SegmentInfos segmentInfos,
bool isCommit
);

See Also

IndexFileDeleter Class | Lucene.Net.Index Namespace


IndexFileDeleter.Close Method

public void Close();

See Also

IndexFileDeleter Class | Lucene.Net.Index Namespace


Refresh Method

Apache Lucene.Net 2.4.0 Class Library API

IndexFileDeleter.Refresh Method

Overload List

public void Refresh();

Writer calls this when it has hit an error and had to roll back, to tell us that there may now be unreferenced files in the filesystem. So we re-list the filesystem and delete such files. If segmentName is non-null, we will only delete files corresponding to that segment.

public void Refresh(string);

See Also

IndexFileDeleter Class | Lucene.Net.Index Namespace


IndexFileDeleter.Refresh Method ()

public void Refresh();

See Also

IndexFileDeleter Class | Lucene.Net.Index Namespace | IndexFileDeleter.Refresh Overload List


IndexFileDeleter.Refresh Method (String)

Writer calls this when it has hit an error and had to roll back, to tell us that there may now be unreferenced files in the filesystem. So we re-list the filesystem and delete such files. If segmentName is non-null, we will only delete files corresponding to that segment.

public void Refresh(
string segmentName
);

See Also

IndexFileDeleter Class | Lucene.Net.Index Namespace | IndexFileDeleter.Refresh Overload List


IndexFileNameFilter Class

Filename filter that accept filenames and extensions only created by Lucene.

For a list of all members of this type, see IndexFileNameFilter Members.

System.Object
Lucene.Net.Index.IndexFileNameFilter

public class IndexFileNameFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexFileNameFilter Members | Lucene.Net.Index Namespace


IndexFileNameFilter Members

IndexFileNameFilter overview

Public Static Methods

GetFilter

Public Instance Constructors

IndexFileNameFilter Constructor Initializes a new instance of the IndexFileNameFilter class.

Public Instance Methods

Accept |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsCFSFile | Returns true if this is a file that would be contained in a CFS file. This function should only be called on files that pass the above "accept" (ie, are already known to be a Lucene index file).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexFileNameFilter Class | Lucene.Net.Index Namespace


IndexFileNameFilter Constructor

Initializes a new instance of the IndexFileNameFilter class.

public IndexFileNameFilter();

See Also

IndexFileNameFilter Class | Lucene.Net.Index Namespace


IndexFileNameFilter Methods

The methods of the IndexFileNameFilter class are listed below. For a complete list of IndexFileNameFilter class members, see the IndexFileNameFilter Members topic.

Public Static Methods

GetFilter

Public Instance Methods

Accept |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsCFSFile | Returns true if this is a file that would be contained in a CFS file. This function should only be called on files that pass the above "accept" (ie, are already known to be a Lucene index file).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexFileNameFilter Class | Lucene.Net.Index Namespace


IndexFileNameFilter.Accept Method

public virtual bool Accept(
FileInfo dir,
string name
);

See Also

IndexFileNameFilter Class | Lucene.Net.Index Namespace


IndexFileNameFilter.GetFilter Method

public static IndexFileNameFilter GetFilter();

See Also

IndexFileNameFilter Class | Lucene.Net.Index Namespace


IndexFileNameFilter.IsCFSFile Method

Returns true if this is a file that would be contained in a CFS file. This function should only be called on files that pass the above "accept" (ie, are already known to be a Lucene index file).

public virtual bool IsCFSFile(
string name
);

See Also

IndexFileNameFilter Class | Lucene.Net.Index Namespace


IndexFileNames Class

Useful constants representing filenames and extensions used by lucene

For a list of all members of this type, see IndexFileNames Members.

System.Object
Lucene.Net.Index.IndexFileNames

public sealed class IndexFileNames

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexFileNames Members | Lucene.Net.Index Namespace


IndexFileNames Members

IndexFileNames overview

Public Static Fields

FIELD_INFOS_EXTENSION | Extension of field infos
SEGMENTS | Name of the index segment file
SEGMENTS_GEN | Name of the generation reference file name
VECTORS_DOCUMENTS_EXTENSION | Extension of vectors documents file
VECTORS_INDEX_EXTENSION | Extension of vectors index file

Public Static Methods

FileNameFromGeneration

Public Instance Constructors

IndexFileNames Constructor Initializes a new instance of the IndexFileNames class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IndexFileNames Class | Lucene.Net.Index Namespace


IndexFileNames Constructor

Initializes a new instance of the IndexFileNames class.

public IndexFileNames();

See Also

IndexFileNames Class | Lucene.Net.Index Namespace


IndexFileNames Fields

The fields of the IndexFileNames class are listed below. For a complete list of IndexFileNames class members, see the IndexFileNames Members topic.

Public Static Fields

FIELD_INFOS_EXTENSION | Extension of field infos
SEGMENTS | Name of the index segment file
SEGMENTS_GEN | Name of the generation reference file name
VECTORS_DOCUMENTS_EXTENSION | Extension of vectors documents file
VECTORS_INDEX_EXTENSION | Extension of vectors index file

See Also

IndexFileNames Class | Lucene.Net.Index Namespace


IndexFileNames.FIELD_INFOS_EXTENSION Field

Extension of field infos

public const string FIELD_INFOS_EXTENSION = "fnm";

See Also

IndexFileNames Class | Lucene.Net.Index Namespace


IndexFileNames.SEGMENTS Field

Name of the index segment file

public const string SEGMENTS = "segments";

See Also

IndexFileNames Class | Lucene.Net.Index Namespace


IndexFileNames.SEGMENTS_GEN Field

Name of the generation reference file name

public const string SEGMENTS_GEN = "segments.gen";

See Also

IndexFileNames Class | Lucene.Net.Index Namespace


IndexFileNames.VECTORS_DOCUMENTS_EXTENSION Field

Extension of vectors documents file

public const string VECTORS_DOCUMENTS_EXTENSION = "tvd";

See Also

IndexFileNames Class | Lucene.Net.Index Namespace


IndexFileNames.VECTORS_INDEX_EXTENSION Field

Extension of vectors index file

public const string VECTORS_INDEX_EXTENSION = "tvx";

See Also

IndexFileNames Class | Lucene.Net.Index Namespace


IndexFileNames Methods

The methods of the IndexFileNames class are listed below. For a complete list of IndexFileNames class members, see the IndexFileNames Members topic.

Public Static Methods

FileNameFromGeneration

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IndexFileNames Class | Lucene.Net.Index Namespace


IndexFileNames.FileNameFromGeneration Method

public static string FileNameFromGeneration(
string base_Renamed,
string extension,
long gen
);

See Also

IndexFileNames Class | Lucene.Net.Index Namespace


IndexModifier Class

For a list of all members of this type, see IndexModifier Members.

System.Object
Lucene.Net.Index.IndexModifier

public class IndexModifier

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexModifier Members | Lucene.Net.Index Namespace


IndexModifier Members

IndexModifier overview

Public Instance Constructors

IndexModifier Overloaded. Initializes a new instance of the IndexModifier class.

Public Instance Methods

AddDocument | Overloaded. Adds a document to this index, using the provided analyzer instead of the one specific in the constructor. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.
Close | Close this index, writing all pending changes to disk.
DeleteDocument Deletes the document numbered
docNum
.
DeleteDocuments Deletes all documents containing
term
. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. Returns the number of documents deleted.
DocCount | Returns the number of documents currently in this index. If the writer is currently open, this returns IndexWriter.DocCount(), else IndexReader.NumDocs(). But, note that IndexWriter.DocCount() does not take deltions into account, unlike IndexReader.NumDocs().
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Make sure all changes are written to disk.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInfoStream has this index open (
write.lock
could not be obtained)
GetMaxBufferedDocs has this index open (
write.lock
could not be obtained)
GetMaxFieldLength has this index open (
write.lock
could not be obtained)
GetMergeFactor has this index open (
write.lock
could not be obtained)
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundFile has this index open (
write.lock
could not be obtained)
Optimize | Merges all segments together into a single segment, optimizing an index for search.
SetInfoStream
SetMaxBufferedDocs
SetMaxFieldLength | The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. Note that this effectively truncates large documents, excluding from the index terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError. By default, no more than 10,000 terms will be indexed for a field.
SetMergeFactor
SetUseCompoundFile | Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file once the segment creation is finished. This is done regardless of what directory is in use.
ToString

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

analyzer
directory
indexReader
indexWriter
infoStream
maxBufferedDocs
maxFieldLength
mergeFactor
open
useCompoundFile

Protected Internal Instance Methods

AssureOpen | Throw an IllegalStateException if the index is closed.
CreateIndexReader | Close the IndexWriter and open an IndexReader.
CreateIndexWriter | Close the IndexReader and open an IndexWriter.
Init | Initialize an IndexWriter.

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier Constructor

Open an index with write access.

Overload List

Open an index with write access.

public IndexModifier(Directory,Analyzer,bool);

Open an index with write access.

public IndexModifier(FileInfo,Analyzer,bool);

Open an index with write access.

public IndexModifier(string,Analyzer,bool);

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier Constructor (Directory, Analyzer, Boolean)

Open an index with write access.

public IndexModifier(
Directory directory,
Analyzer analyzer,
bool create
);

Parameters

directory
the index directory
analyzer
the analyzer to use for adding new documents
create
true
to create the index or overwrite the existing one;
false
to append to the existing index

See Also

IndexModifier Class | Lucene.Net.Index Namespace | IndexModifier Constructor Overload List


IndexModifier Constructor (String, Analyzer, Boolean)

Open an index with write access.

public IndexModifier(
string dirName,
Analyzer analyzer,
bool create
);

Parameters

dirName
the index directory
analyzer
the analyzer to use for adding new documents
create
true
to create the index or overwrite the existing one;
false
to append to the existing index

See Also

IndexModifier Class | Lucene.Net.Index Namespace | IndexModifier Constructor Overload List


IndexModifier Constructor (FileInfo, Analyzer, Boolean)

Open an index with write access.

public IndexModifier(
FileInfo file,
Analyzer analyzer,
bool create
);

Parameters

file
the index directory
analyzer
the analyzer to use for adding new documents
create
true
to create the index or overwrite the existing one;
false
to append to the existing index

See Also

IndexModifier Class | Lucene.Net.Index Namespace | IndexModifier Constructor Overload List


IndexModifier Fields

The fields of the IndexModifier class are listed below. For a complete list of IndexModifier class members, see the IndexModifier Members topic.

Protected Internal Instance Fields

analyzer
directory
indexReader
indexWriter
infoStream
maxBufferedDocs
maxFieldLength
mergeFactor
open
useCompoundFile

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.analyzer Field

protected internal Analyzer analyzer;

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.directory Field

protected internal Directory directory;

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.indexReader Field

protected internal IndexReader indexReader;

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.indexWriter Field

protected internal IndexWriter indexWriter;

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.infoStream Field

protected internal StreamWriter infoStream;

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.maxBufferedDocs Field

protected internal int maxBufferedDocs;

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.maxFieldLength Field

protected internal int maxFieldLength;

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.mergeFactor Field

protected internal int mergeFactor;

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.open Field

protected internal bool open;

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.useCompoundFile Field

protected internal bool useCompoundFile;

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier Methods

The methods of the IndexModifier class are listed below. For a complete list of IndexModifier class members, see the IndexModifier Members topic.

Public Instance Methods

AddDocument | Overloaded. Adds a document to this index, using the provided analyzer instead of the one specific in the constructor. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.
Close | Close this index, writing all pending changes to disk.
DeleteDocument Deletes the document numbered
docNum
.
DeleteDocuments Deletes all documents containing
term
. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. Returns the number of documents deleted.
DocCount | Returns the number of documents currently in this index. If the writer is currently open, this returns IndexWriter.DocCount(), else IndexReader.NumDocs(). But, note that IndexWriter.DocCount() does not take deltions into account, unlike IndexReader.NumDocs().
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Make sure all changes are written to disk.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInfoStream has this index open (
write.lock
could not be obtained)
GetMaxBufferedDocs has this index open (
write.lock
could not be obtained)
GetMaxFieldLength has this index open (
write.lock
could not be obtained)
GetMergeFactor has this index open (
write.lock
could not be obtained)
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundFile has this index open (
write.lock
could not be obtained)
Optimize | Merges all segments together into a single segment, optimizing an index for search.
SetInfoStream
SetMaxBufferedDocs
SetMaxFieldLength | The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. Note that this effectively truncates large documents, excluding from the index terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError. By default, no more than 10,000 terms will be indexed for a field.
SetMergeFactor
SetUseCompoundFile | Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file once the segment creation is finished. This is done regardless of what directory is in use.
ToString

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

AssureOpen | Throw an IllegalStateException if the index is closed.
CreateIndexReader | Close the IndexWriter and open an IndexReader.
CreateIndexWriter | Close the IndexReader and open an IndexWriter.
Init | Initialize an IndexWriter.

See Also

IndexModifier Class | Lucene.Net.Index Namespace


AddDocument Method

Apache Lucene.Net 2.4.0 Class Library API

IndexModifier.AddDocument Method

Adds a document to this index. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

Overload List

Adds a document to this index. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

public virtual void AddDocument(Document);

Adds a document to this index, using the provided analyzer instead of the one specific in the constructor. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

public virtual void AddDocument(Document,Analyzer);

See Also

IndexModifier Class | Lucene.Net.Index Namespace |


IndexModifier.AddDocument Method (Document)

Adds a document to this index. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

public virtual void AddDocument(
Document doc
);

See Also

IndexModifier Class | Lucene.Net.Index Namespace | IndexModifier.AddDocument Overload List |


IndexModifier.AddDocument Method (Document, Analyzer)

Adds a document to this index, using the provided analyzer instead of the one specific in the constructor. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

public virtual void AddDocument(
Document doc,
Analyzer docAnalyzer
);

See Also

IndexModifier Class | Lucene.Net.Index Namespace | IndexModifier.AddDocument Overload List |


IndexModifier.AssureOpen Method

Throw an IllegalStateException if the index is closed.

protected internal virtual void AssureOpen();

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.Close Method

Close this index, writing all pending changes to disk.

public virtual void Close();

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.CreateIndexReader Method

Close the IndexWriter and open an IndexReader.

protected internal virtual void CreateIndexReader();

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.CreateIndexWriter Method

Close the IndexReader and open an IndexWriter.

protected internal virtual void CreateIndexWriter();

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.DeleteDocument Method

Deletes the document numbered

docNum
.

public virtual void DeleteDocument(
int docNum
);

See Also

IndexModifier Class | Lucene.Net.Index Namespace |


IndexModifier.DeleteDocuments Method

Deletes all documents containing

term
. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. Returns the number of documents deleted.

public virtual int DeleteDocuments(
Term term
);

Return Value

the number of documents deleted

See Also

IndexModifier Class | Lucene.Net.Index Namespace |


IndexModifier.DocCount Method

Returns the number of documents currently in this index. If the writer is currently open, this returns IndexWriter.DocCount(), else IndexReader.NumDocs(). But, note that IndexWriter.DocCount() does not take deltions into account, unlike IndexReader.NumDocs().

public virtual int DocCount();

See Also

IndexModifier Class | Lucene.Net.Index Namespace | |


IndexModifier.Flush Method

Make sure all changes are written to disk.

public virtual void Flush();

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.GetInfoStream Method

has this index open (

write.lock
could not be obtained)

public virtual TextWriter GetInfoStream();

See Also

IndexModifier Class | Lucene.Net.Index Namespace | SetInfoStream


IndexModifier.GetMaxBufferedDocs Method

has this index open (

write.lock
could not be obtained)

public virtual int GetMaxBufferedDocs();

See Also

IndexModifier Class | Lucene.Net.Index Namespace |


IndexModifier.GetMaxFieldLength Method

has this index open (

write.lock
could not be obtained)

public virtual int GetMaxFieldLength();

See Also

IndexModifier Class | Lucene.Net.Index Namespace |


IndexModifier.GetMergeFactor Method

has this index open (

write.lock
could not be obtained)

public virtual int GetMergeFactor();

See Also

IndexModifier Class | Lucene.Net.Index Namespace |


IndexModifier.GetUseCompoundFile Method

has this index open (

write.lock
could not be obtained)

public virtual bool GetUseCompoundFile();

See Also

IndexModifier Class | Lucene.Net.Index Namespace | SetUseCompoundFile


IndexModifier.Init Method

Initialize an IndexWriter.

protected internal virtual void Init(
Directory directory,
Analyzer analyzer,
bool create
);

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.Optimize Method

Merges all segments together into a single segment, optimizing an index for search.

public virtual void Optimize();

See Also

IndexModifier Class | Lucene.Net.Index Namespace |


IndexModifier.SetInfoStream Method

public virtual void SetInfoStream(
StreamWriter infoStream
);

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.SetMaxBufferedDocs Method

public virtual void SetMaxBufferedDocs(
int maxBufferedDocs
);

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.SetMaxFieldLength Method

The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory.

Note that this effectively truncates large documents, excluding from the index terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError.

By default, no more than 10,000 terms will be indexed for a field.
public virtual void SetMaxFieldLength(
int maxFieldLength
);

See Also

IndexModifier Class | Lucene.Net.Index Namespace |


IndexModifier.SetMergeFactor Method

public virtual void SetMergeFactor(
int mergeFactor
);

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexModifier.SetUseCompoundFile Method

Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file once the segment creation is finished. This is done regardless of what directory is in use.

public virtual void SetUseCompoundFile(
bool useCompoundFile
);

See Also

IndexModifier Class | Lucene.Net.Index Namespace | SetUseCompoundFile


IndexModifier.ToString Method

public override string ToString();

See Also

IndexModifier Class | Lucene.Net.Index Namespace


IndexReader Class

For a list of all members of this type, see IndexReader Members.

System.Object
Lucene.Net.Index.IndexReader
Lucene.Net.Index.DirectoryIndexReader
Lucene.Net.Index.FilterIndexReader
Lucene.Net.Index.MultiReader
Lucene.Net.Index.ParallelReader

public abstract class IndexReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexReader Members | Lucene.Net.Index Namespace


IndexReader Members

IndexReader overview

Public Static Methods

GetCurrentVersion | Overloaded. Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.
IndexExists Overloaded. Returns
true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
false
is returned.
IsLocked Overloaded. Returns
true
iff the index in the named directory is currently locked.
LastModified | Overloaded. Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.
ListCommits | Returns all commit points that exist in the Directory. Normally, because the default is {@link KeepOnlyLastCommitDeletionPolicy}, there would be only one commit point. But if you're using a custom {@link IndexDeletionPolicy} then there could be many commits. Once you have a given commit, you can open a reader on it by calling {@link IndexReader#open(IndexCommit)} There must be at least one commit in the Directory, else this method throws {@link java.io.IOException}. Note that if a commit is in progress while this method is running, that commit may or may not be returned array.
Main | Prints the filename and size of each file within a given compound file. Add the -extract flag to extract files to the current working directory. In order to make the extracted version of the index work, you have to copy the segments file from the compound index into the directory where the extracted files are stored.
Open | Overloaded. Returns a read/write IndexReader reading the index in an FSDirectory in the named path. NOTE: Starting in 3.0 this will return a readOnly IndexReader. Throws CorruptIndexException if the index is corrupt. Throws IOException if there is a low-level IO error.
Unlock | Obsolete.

Public Instance Methods

Close | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
DeleteDocument Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory | Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
DocFreq Returns the number of documents containing the term
t
.
Document Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush
GetFieldNames | Get a list of unique field names that exist in this index and have the specified field option information.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit | Expert: Return the IndexCommit that this reader has open. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: This API is new and experimental and may suddenly change.
GetRefCount
GetTermFreqVector | Overloaded. Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a TermPositionsVector is returned.
GetTermFreqVectors | Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector contains terms and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null. The term vectors that are returned my either be of type TermFreqVector or of type TermPositionsVector if positions or offsets have been stored.
GetTermInfosIndexDivisor
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | Version number when this IndexReader was opened. Not implemented in the IndexReader base class.
HasDeletions | Returns true if any documents have been deleted
HasNorms | Returns true if there are norms stored for this field.
IncRef | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IsCurrent Check whether this IndexReader is still using the current (i.e., most recently committed) version of the index. If a writer has committed any changes to the index since this reader was opened, this will return
false
, in which case you must open a new IndexReader in order to see the changes. See the description of the
autoCommit
 flag which controls when the {@link IndexWriter} actually commits changes to the index. Not implemented in the IndexReader base class.
IsDeleted | Returns true if document n has been deleted
IsOptimized | Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
MaxDoc | Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.
Norms | Overloaded. Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
NumDeletedDocs | Returns the number of deleted docs.
NumDocs | Returns the number of documents in this index.
Reopen
SetNorm | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor | For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.
TermDocs | Overloaded.
TermPositions | Overloaded.
Terms | Overloaded. Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), {@link TermEnum#Next()} must be called on the resulting enumeration before calling other methods such as {@link TermEnum#Term()}.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

IndexReader Overloaded. Initializes a new instance of the IndexReader class.

Protected Internal Instance Fields

hasChanges

Protected Internal Instance Methods

AcquireWriteLock | Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
DoClose | Implements close.
DoCommit | Implements commit.
DoDelete Implements deletion of the document numbered
docNum
. Applications should call {@link #DeleteDocument(int)} or {@link #DeleteDocuments(Term)}.
DoSetNorm | Implements setNorm in subclass.
DoUndeleteAll | Implements actual undeleteAll() in subclass.

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader Constructor

Overload List

Initializes a new instance of the IndexReader class.

protected internal IndexReader();

protected internal IndexReader(Directory);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader Constructor (Directory)

protected internal IndexReader(
Directory directory
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader Constructor Overload List


IndexReader Constructor ()

Initializes a new instance of the IndexReader class.

protected internal IndexReader();

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader Constructor Overload List


IndexReader Fields

The fields of the IndexReader class are listed below. For a complete list of IndexReader class members, see the IndexReader Members topic.

Protected Internal Instance Fields

hasChanges

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.hasChanges Field

protected internal bool hasChanges;

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader Methods

The methods of the IndexReader class are listed below. For a complete list of IndexReader class members, see the IndexReader Members topic.

Public Static Methods

GetCurrentVersion | Overloaded. Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.
IndexExists Overloaded. Returns
true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
false
is returned.
IsLocked Overloaded. Returns
true
iff the index in the named directory is currently locked.
LastModified | Overloaded. Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.
ListCommits | Returns all commit points that exist in the Directory. Normally, because the default is {@link KeepOnlyLastCommitDeletionPolicy}, there would be only one commit point. But if you're using a custom {@link IndexDeletionPolicy} then there could be many commits. Once you have a given commit, you can open a reader on it by calling {@link IndexReader#open(IndexCommit)} There must be at least one commit in the Directory, else this method throws {@link java.io.IOException}. Note that if a commit is in progress while this method is running, that commit may or may not be returned array.
Main | Prints the filename and size of each file within a given compound file. Add the -extract flag to extract files to the current working directory. In order to make the extracted version of the index work, you have to copy the segments file from the compound index into the directory where the extracted files are stored.
Open | Overloaded. Returns a read/write IndexReader reading the index in an FSDirectory in the named path. NOTE: Starting in 3.0 this will return a readOnly IndexReader. Throws CorruptIndexException if the index is corrupt. Throws IOException if there is a low-level IO error.
Unlock | Obsolete.

Public Instance Methods

Close | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
DeleteDocument Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory | Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
DocFreq Returns the number of documents containing the term
t
.
Document Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush
GetFieldNames | Get a list of unique field names that exist in this index and have the specified field option information.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit | Expert: Return the IndexCommit that this reader has open. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: This API is new and experimental and may suddenly change.
GetRefCount
GetTermFreqVector | Overloaded. Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a TermPositionsVector is returned.
GetTermFreqVectors | Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector contains terms and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null. The term vectors that are returned my either be of type TermFreqVector or of type TermPositionsVector if positions or offsets have been stored.
GetTermInfosIndexDivisor
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | Version number when this IndexReader was opened. Not implemented in the IndexReader base class.
HasDeletions | Returns true if any documents have been deleted
HasNorms | Returns true if there are norms stored for this field.
IncRef | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IsCurrent Check whether this IndexReader is still using the current (i.e., most recently committed) version of the index. If a writer has committed any changes to the index since this reader was opened, this will return
false
, in which case you must open a new IndexReader in order to see the changes. See the description of the
autoCommit
 flag which controls when the {@link IndexWriter} actually commits changes to the index. Not implemented in the IndexReader base class.
IsDeleted | Returns true if document n has been deleted
IsOptimized | Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
MaxDoc | Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.
Norms | Overloaded. Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
NumDeletedDocs | Returns the number of deleted docs.
NumDocs | Returns the number of documents in this index.
Reopen
SetNorm | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor | For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.
TermDocs | Overloaded.
TermPositions | Overloaded.
Terms | Overloaded. Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), {@link TermEnum#Next()} must be called on the resulting enumeration before calling other methods such as {@link TermEnum#Term()}.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

AcquireWriteLock | Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
DoClose | Implements close.
DoCommit | Implements commit.
DoDelete Implements deletion of the document numbered
docNum
. Applications should call {@link #DeleteDocument(int)} or {@link #DeleteDocuments(Term)}.
DoSetNorm | Implements setNorm in subclass.
DoUndeleteAll | Implements actual undeleteAll() in subclass.

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.AcquireWriteLock Method

Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.

protected internal virtual void AcquireWriteLock();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Close Method

Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.

public void Close();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Commit Method

Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

public void Commit();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DecRef Method

Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.

public virtual void DecRef();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DeleteDocument Method

Deletes the document numbered

docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.

public void DeleteDocument(
int docNum
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DeleteDocuments Method

Deletes all documents that have a given

term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.

public int DeleteDocuments(
Term term
);

Return Value

the number of documents deleted

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Directory Method

Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.

public virtual Directory Directory();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DocFreq Method

Returns the number of documents containing the term

t
.

public abstract int DocFreq(
Term t
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DoClose Method

Implements close.

protected internal abstract void DoClose();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DoCommit Method

Implements commit.

protected internal abstract void DoCommit();

See Also

IndexReader Class | Lucene.Net.Index Namespace


Document Method

Apache Lucene.Net 2.4.0 Class Library API

IndexReader.Document Method

Returns the stored fields of the

n
th
Document
in this index.

Overload List

Returns the stored fields of the

n
th
Document
in this index.

public virtual Document Document(int);

Get the {@link Lucene.Net.Documents.Document} at the

n
th position. The {@link Lucene.Net.Documents.FieldSelector} may be used to determine what {@link Lucene.Net.Documents.Field}s to load and how they should be loaded. NOTE: If this Reader (more specifically, the underlying
FieldsReader
) is closed before the lazy {@link Lucene.Net.Documents.Field} is loaded an exception may be thrown. If you want the value of a lazy {@link Lucene.Net.Documents.Field} to be available after closing you must explicitly load it or fetch the Document again with a new loader.

public abstract Document Document(int,FieldSelector);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Document Method (Int32)

Returns the stored fields of the

n
th
Document
in this index.

public virtual Document Document(
int n
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Document Overload List


IndexReader.Document Method (Int32, FieldSelector)

Get the {@link Lucene.Net.Documents.Document} at the

n
th position. The {@link Lucene.Net.Documents.FieldSelector} may be used to determine what {@link Lucene.Net.Documents.Field}s to load and how they should be loaded. NOTE: If this Reader (more specifically, the underlying
FieldsReader
) is closed before the lazy {@link Lucene.Net.Documents.Field} is loaded an exception may be thrown. If you want the value of a lazy {@link Lucene.Net.Documents.Field} to be available after closing you must explicitly load it or fetch the Document again with a new loader.

public abstract Document Document(
int n,
FieldSelector fieldSelector
);

Parameters

n
Get the document at the
n
th position
fieldSelector
The {@link Lucene.Net.Documents.FieldSelector} to use to determine what Fields should be loaded on the Document. May be null, in which case all Fields will be loaded.

Return Value

The stored fields of the {@link Lucene.Net.Documents.Document} at the nth position

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Document Overload List | | | |


IndexReader.DoDelete Method

Implements deletion of the document numbered

docNum
. Applications should call {@link #DeleteDocument(int)} or {@link #DeleteDocuments(Term)}.

protected internal abstract void DoDelete(
int docNum
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DoSetNorm Method

Implements setNorm in subclass.

protected internal abstract void DoSetNorm(
int doc,
string field,
byte value_Renamed
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.DoUndeleteAll Method

Implements actual undeleteAll() in subclass.

protected internal abstract void DoUndeleteAll();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.EnsureOpen Method

public void EnsureOpen();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Flush Method

public void Flush();

See Also

IndexReader Class | Lucene.Net.Index Namespace


GetCurrentVersion Method

Apache Lucene.Net 2.4.0 Class Library API

IndexReader.GetCurrentVersion Method

Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.

Overload List

Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.

public static long GetCurrentVersion(Directory);

Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.

public static long GetCurrentVersion(FileInfo);

Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.

public static long GetCurrentVersion(string);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.GetCurrentVersion Method (Directory)

Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.

public static long GetCurrentVersion(
Directory directory
);

Parameters

directory
where the index resides.

Return Value

version number.

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.GetCurrentVersion Overload List


IndexReader.GetCurrentVersion Method (FileInfo)

Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.

public static long GetCurrentVersion(
FileInfo directory
);

Parameters

directory
where the index resides.

Return Value

version number.

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.GetCurrentVersion Overload List


IndexReader.GetCurrentVersion Method (String)

Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.

public static long GetCurrentVersion(
string directory
);

Parameters

directory
where the index resides.

Return Value

version number.

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.GetCurrentVersion Overload List


IndexReader.GetFieldNames Method

Get a list of unique field names that exist in this index and have the specified field option information.

public abstract 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetFieldNames(
FieldOption fldOption
);

Parameters

fldOption
specifies which field option should be available for the returned fields

Return Value

Collection of Strings indicating the names of the fields.

See Also

IndexReader Class | Lucene.Net.Index Namespace |


IndexReader.GetIndexCommit Method

Expert: Return the IndexCommit that this reader has open. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: This API is new and experimental and may suddenly change.

public virtual IndexCommit GetIndexCommit();

Return Value

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.GetRefCount Method

public virtual int GetRefCount();

See Also

IndexReader Class | Lucene.Net.Index Namespace


GetTermFreqVector Method

Apache Lucene.Net 2.4.0 Class Library API

IndexReader.GetTermFreqVector Method

Map all the term vectors for all fields in a Document

Overload List

Map all the term vectors for all fields in a Document

public abstract void GetTermFreqVector(int,TermVectorMapper);

Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a TermPositionsVector is returned.

public abstract TermFreqVector GetTermFreqVector(int,string);

Load the Term Vector into a user-defined data structure instead of relying on the parallel arrays of the {@link TermFreqVector}.

public abstract void GetTermFreqVector(int,string,TermVectorMapper);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.GetTermFreqVector Method (Int32, TermVectorMapper)

Map all the term vectors for all fields in a Document

public abstract void GetTermFreqVector(
int docNumber,
TermVectorMapper mapper
);

Parameters

docNumber
The number of the document to load the vector for
mapper
The {@link TermVectorMapper} to process the vector. Must not be null

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.GetTermFreqVector Overload List


IndexReader.GetTermFreqVector Method (Int32, String)

Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a TermPositionsVector is returned.

public abstract TermFreqVector GetTermFreqVector(
int docNumber,
string field
);

Parameters

docNumber
document for which the term frequency vector is returned
field
field for which the term frequency vector is returned.

Return Value

term frequency vector May be null if field does not exist in the specified document or term vector was not stored.

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.GetTermFreqVector Overload List |


IndexReader.GetTermFreqVector Method (Int32, String, TermVectorMapper)

Load the Term Vector into a user-defined data structure instead of relying on the parallel arrays of the {@link TermFreqVector}.

public abstract void GetTermFreqVector(
int docNumber,
string field,
TermVectorMapper mapper
);

Parameters

docNumber
The number of the document to load the vector for
field
The name of the field to load
mapper
The {@link TermVectorMapper} to process the vector. Must not be null

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.GetTermFreqVector Overload List


IndexReader.GetTermFreqVectors Method

Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector contains terms and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null. The term vectors that are returned my either be of type TermFreqVector or of type TermPositionsVector if positions or offsets have been stored.

public abstract TermFreqVector[] GetTermFreqVectors(
int docNumber
);

Parameters

docNumber
document for which term frequency vectors are returned

Return Value

array of term frequency vectors. May be null if no term vectors have been stored for the specified document.

See Also

IndexReader Class | Lucene.Net.Index Namespace |


IndexReader.GetTermInfosIndexDivisor Method

public virtual int GetTermInfosIndexDivisor();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.GetVersion Method

Version number when this IndexReader was opened. Not implemented in the IndexReader base class.

public virtual long GetVersion();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.HasDeletions Method

Returns true if any documents have been deleted

public abstract bool HasDeletions();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.HasNorms Method

Returns true if there are norms stored for this field.

public virtual bool HasNorms(
string field
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.IncRef Method

Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.

public virtual void IncRef();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexExists Method

Apache Lucene.Net 2.4.0 Class Library API

IndexReader.IndexExists Method

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

Overload List

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

public static bool IndexExists(Directory);

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

public static bool IndexExists(FileInfo);

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
false
is returned.

public static bool IndexExists(string);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.IndexExists Method (Directory)

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

public static bool IndexExists(
Directory directory
);

Parameters

directory
the directory to check for an index

Return Value

true
if an index exists;
false
otherwise

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.IndexExists Overload List


IndexReader.IndexExists Method (FileInfo)

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

public static bool IndexExists(
FileInfo directory
);

Parameters

directory
the directory to check for an index

Return Value

true
if an index exists;
false
otherwise

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.IndexExists Overload List


IndexReader.IndexExists Method (String)

Returns

true
if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
false
is returned.

public static bool IndexExists(
string directory
);

Parameters

directory
the directory to check for an index

Return Value

true
if an index exists;
false
otherwise

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.IndexExists Overload List


IndexReader.IsCurrent Method

Check whether this IndexReader is still using the current (i.e., most recently committed) version of the index. If a writer has committed any changes to the index since this reader was opened, this will return
false
, in which case you must open a new IndexReader in order to see the changes. See the description of the
autoCommit
 flag which controls when the {@link IndexWriter} actually commits changes to the index.

Not implemented in the IndexReader base class.

public virtual bool IsCurrent();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.IsDeleted Method

Returns true if document n has been deleted

public abstract bool IsDeleted(
int n
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IsLocked Method

Apache Lucene.Net 2.4.0 Class Library API

IndexReader.IsLocked Method

NOTE: This method is now obsolete.

Please use IndexWriter.IsLocked(Directory) instead.

Returns

true
iff the index in the named directory is currently locked.

Overload List

Obsolete. Returns

true
iff the index in the named directory is currently locked.

public static bool IsLocked(Directory);

Obsolete. Returns

true
iff the index in the named directory is currently locked.

public static bool IsLocked(string);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.IsLocked Method (Directory)

NOTE: This method is now obsolete.

Please use IndexWriter.IsLocked(Directory) instead.

Returns

true
iff the index in the named directory is currently locked.

public static bool IsLocked(
Directory directory
);

Parameters

directory
the directory to check for a lock

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.IsLocked Overload List


IndexReader.IsLocked Method (String)

NOTE: This method is now obsolete.

Please use IndexWriter.IsLocked(string) instead.

Returns

true
iff the index in the named directory is currently locked.

public static bool IsLocked(
string directory
);

Parameters

directory
the directory to check for a lock

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.IsLocked Overload List


IndexReader.IsOptimized Method

Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.

public virtual bool IsOptimized();

Return Value

true
if the index is optimized;
false
otherwise

See Also

IndexReader Class | Lucene.Net.Index Namespace


LastModified Method

Apache Lucene.Net 2.4.0 Class Library API

IndexReader.LastModified Method

Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.

Overload List

Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.

public static long LastModified(Directory);

Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.

public static long LastModified(FileInfo);

Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.

public static long LastModified(string);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.LastModified Method (Directory)

Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.

public static long LastModified(
Directory directory2
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.LastModified Overload List


IndexReader.LastModified Method (FileInfo)

Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.

public static long LastModified(
FileInfo fileDirectory
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.LastModified Overload List


IndexReader.LastModified Method (String)

Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.

public static long LastModified(
string directory
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.LastModified Overload List


IndexReader.ListCommits Method

Returns all commit points that exist in the Directory. Normally, because the default is {@link KeepOnlyLastCommitDeletionPolicy}, there would be only one commit point. But if you're using a custom {@link IndexDeletionPolicy} then there could be many commits. Once you have a given commit, you can open a reader on it by calling {@link IndexReader#open(IndexCommit)} There must be at least one commit in the Directory, else this method throws {@link java.io.IOException}. Note that if a commit is in progress while this method is running, that commit may or may not be returned array.

public static 2, Culture=neutral, PublicKeyToken=null]] ListCommits(
Directory dir
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Main Method

Prints the filename and size of each file within a given compound file. Add the -extract flag to extract files to the current working directory. In order to make the extracted version of the index work, you have to copy the segments file from the compound index into the directory where the extracted files are stored.

public static void Main(
string[] args
);

Parameters

args
Usage: Lucene.Net.Index.IndexReader [-extract] <cfsfile>

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.MaxDoc Method

Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.

public abstract int MaxDoc();

See Also

IndexReader Class | Lucene.Net.Index Namespace


Norms Method

Apache Lucene.Net 2.4.0 Class Library API

IndexReader.Norms Method

Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.

Overload List

Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.

public abstract byte[] Norms(string);

Reads the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.

public abstract void Norms(string,byte[],int);

See Also

IndexReader Class | Lucene.Net.Index Namespace | SetBoost


IndexReader.Norms Method (String)

Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.

public abstract byte[] Norms(
string field
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Norms Overload List | SetBoost


IndexReader.Norms Method (String, Byte[], Int32)

Reads the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.

public abstract void Norms(
string field,
byte[] bytes,
int offset
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Norms Overload List | SetBoost


IndexReader.NumDeletedDocs Method

Returns the number of deleted docs.

public int NumDeletedDocs();

Return Value

the number of deleted docs

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.NumDocs Method

Returns the number of documents in this index.

public abstract int NumDocs();

See Also

IndexReader Class | Lucene.Net.Index Namespace


Open Method

Apache Lucene.Net 2.4.0 Class Library API

IndexReader.Open Method

Expert: Returns a read/write IndexReader reading the index in the given IndexCommit.

NOTE: Starting in 3.0 this will return a readOnly IndexReader.

Throws CorruptIndexException if the index is corrupt.

Throws IOException if there is a low-level IO error.

Overload List

Expert: Returns a read/write IndexReader reading the index in the given IndexCommit. NOTE: Starting in 3.0 this will return a readOnly IndexReader. Throws CorruptIndexException if the index is corrupt. Throws IOException if there is a low-level IO error.

public static IndexReader Open(IndexCommit);

Expert: Returns a read/write IndexReader reading the index in the given Directory, using a specific commit and with a custom IndexDeletionPolicy. NOTE: Starting in 3.0 this will return a readOnly IndexReader. Throws CorruptIndexException if the index is corrupt. Throws IOException if there is a low-level IO error.

public static IndexReader Open(IndexCommit,IndexDeletionPolicy);

Expert: Returns a read/write or read only IndexReader reading the index in the given Directory, using a specific commit and with a custom IndexDeletionPolicy. NOTE: Starting in 3.0 this will return a readOnly IndexReader. Throws CorruptIndexException if the index is corrupt. Throws IOException if there is a low-level IO error.

public static IndexReader Open(IndexCommit,IndexDeletionPolicy,bool);

Returns a read/write IndexReader reading the index in the given Directory. NOTE: Starting in 3.0 this will return a readOnly IndexReader. Throws CorruptIndexException if the index is corrupt. Throws IOException if there is a low-level IO error.

public static IndexReader Open(Directory);

Expert: Returns a read/write IndexReader reading the index in the given Directory, with a custom IndexDeletionPolicy. NOTE: Starting in 3.0 this will return a readOnly IndexReader. Throws CorruptIndexException if the index is corrupt. Throws IOException if there is a low-level IO error.

public static IndexReader Open(Directory,IndexDeletionPolicy);

Expert: Returns a read/write or read only IndexReader using the index in the given Directory, with a custom IndexDeletionPolicy. Throws CorruptIndexException if the index is corrupt. Throws IOException if there is a low-level IO error.

public static IndexReader Open(Directory,IndexDeletionPolicy,bool);

Returns a read/write or read only IndexReader using the index in the given Directory. Throws CorruptIndexException if the index is corrupt. Throws IOException if there is a low-level IO error.

public static IndexReader Open(Directory,bool);

Returns a read/write IndexReader reading the index in an FSDirectory in the named path. NOTE: Starting in 3.0 this will return a readOnly IndexReader. Throws CorruptIndexException if the index is corrupt. Throws IOException if there is a low-level IO error.

public static IndexReader Open(FileInfo);

Returns a read/write IndexReader reading the index in an FSDirectory in the named path. NOTE: Starting in 3.0 this will return a readOnly IndexReader. Throws CorruptIndexException if the index is corrupt. Throws IOException if there is a low-level IO error.

public static IndexReader Open(string);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Open Method (IndexCommit)

Expert: Returns a read/write IndexReader reading the index in the given IndexCommit.

NOTE: Starting in 3.0 this will return a readOnly IndexReader.

Throws CorruptIndexException if the index is corrupt.

Throws IOException if there is a low-level IO error.

public static IndexReader Open(
IndexCommit commit
);

Parameters

commit
the commit point to open

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Open Overload List


IndexReader.Open Method (IndexCommit, IndexDeletionPolicy)

Expert: Returns a read/write IndexReader reading the index in the given Directory, using a specific commit and with a custom IndexDeletionPolicy.

NOTE: Starting in 3.0 this will return a readOnly IndexReader.

Throws CorruptIndexException if the index is corrupt.

Throws IOException if there is a low-level IO error.

public static IndexReader Open(
IndexCommit commit,
IndexDeletionPolicy deletionPolicy
);

Parameters

commit
the commit point to open
deletionPolicy
a custom deletion policy (only used if performing deletes or setting norms)

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Open Overload List


IndexReader.Open Method (IndexCommit, IndexDeletionPolicy, Boolean)

Expert: Returns a read/write or read only IndexReader reading the index in the given Directory, using a specific commit and with a custom IndexDeletionPolicy.

NOTE: Starting in 3.0 this will return a readOnly IndexReader.

Throws CorruptIndexException if the index is corrupt.

Throws IOException if there is a low-level IO error.

public static IndexReader Open(
IndexCommit commit,
IndexDeletionPolicy deletionPolicy,
bool readOnly
);

Parameters

commit
the commit point to open
deletionPolicy
a custom deletion policy (only used if performing deletes or setting norms)
readOnly
true if no changes (deletions, norms) will be made with this IndexReader

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Open Overload List


IndexReader.Open Method (Directory)

Returns a read/write IndexReader reading the index in the given Directory.

NOTE: Starting in 3.0 this will return a readOnly IndexReader.

Throws CorruptIndexException if the index is corrupt.

Throws IOException if there is a low-level IO error.

public static IndexReader Open(
Directory directory
);

Parameters

directory
the index directory

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Open Overload List


IndexReader.Open Method (Directory, IndexDeletionPolicy)

Expert: Returns a read/write IndexReader reading the index in the given Directory, with a custom IndexDeletionPolicy.

NOTE: Starting in 3.0 this will return a readOnly IndexReader.

Throws CorruptIndexException if the index is corrupt.

Throws IOException if there is a low-level IO error.

public static IndexReader Open(
Directory directory,
IndexDeletionPolicy deletionPolicy
);

Parameters

directory
the index directory
deletionPolicy
a custom deletion policy (only used if performing deletes or setting norms)

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Open Overload List


IndexReader.Open Method (Directory, IndexDeletionPolicy, Boolean)

Expert: Returns a read/write or read only IndexReader using the index in the given Directory, with a custom IndexDeletionPolicy.

Throws CorruptIndexException if the index is corrupt.

Throws IOException if there is a low-level IO error.

public static IndexReader Open(
Directory directory,
IndexDeletionPolicy deletionPolicy,
bool readOnly
);

Parameters

directory
the index directory
deletionPolicy
a custom deletion policy (only used if performing deletes or setting norms)
readOnly
true if no changes (deletions, norms) will be made with this IndexReader

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Open Overload List


IndexReader.Open Method (Directory, Boolean)

Returns a read/write or read only IndexReader using the index in the given Directory.

Throws CorruptIndexException if the index is corrupt.

Throws IOException if there is a low-level IO error.

public static IndexReader Open(
Directory directory,
bool readOnly
);

Parameters

directory
the index directory
readOnly
true if no changes (deletions, norms) will be made with this IndexReader

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Open Overload List


IndexReader.Open Method (FileInfo)

Returns a read/write IndexReader reading the index in an FSDirectory in the named path.

NOTE: Starting in 3.0 this will return a readOnly IndexReader.

Throws CorruptIndexException if the index is corrupt.

Throws IOException if there is a low-level IO error.

public static IndexReader Open(
FileInfo path
);

Parameters

path
the path to the index directory

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Open Overload List


IndexReader.Open Method (String)

Returns a read/write IndexReader reading the index in an FSDirectory in the named path.

NOTE: Starting in 3.0 this will return a readOnly IndexReader.

Throws CorruptIndexException if the index is corrupt.

Throws IOException if there is a low-level IO error.

public static IndexReader Open(
string path
);

Parameters

path
the path to the index directory

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Open Overload List


IndexReader.Reopen Method

public virtual IndexReader Reopen();

See Also

IndexReader Class | Lucene.Net.Index Namespace


SetNorm Method

Apache Lucene.Net 2.4.0 Class Library API

IndexReader.SetNorm Method

Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.

Overload List

Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.

public void SetNorm(int,string,byte);

Expert: Resets the normalization factor for the named field of the named document.

public virtual void SetNorm(int,string,float);

See Also

IndexReader Class | Lucene.Net.Index Namespace | Norms |


IndexReader.SetNorm Method (Int32, String, Byte)

Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.

public void SetNorm(
int doc,
string field,
byte value_Renamed
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.SetNorm Overload List | Norms |


IndexReader.SetNorm Method (Int32, String, Single)

Expert: Resets the normalization factor for the named field of the named document.

public virtual void SetNorm(
int doc,
string field,
float value_Renamed
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.SetNorm Overload List | Norms |


IndexReader.SetTermInfosIndexDivisor Method

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.
public virtual void SetTermInfosIndexDivisor(
int indexDivisor
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


TermDocs Method

Apache Lucene.Net 2.4.0 Class Library API

IndexReader.TermDocs Method

Returns an unpositioned {@link TermDocs} enumerator.

Overload List

Returns an unpositioned {@link TermDocs} enumerator.

public abstract TermDocs TermDocs();

public virtual TermDocs TermDocs(Term);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.TermDocs Method ()

Returns an unpositioned {@link TermDocs} enumerator.

public abstract TermDocs TermDocs();

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.TermDocs Overload List


IndexReader.TermDocs Method (Term)

public virtual TermDocs TermDocs(
Term term
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.TermDocs Overload List


TermPositions Method

Apache Lucene.Net 2.4.0 Class Library API

IndexReader.TermPositions Method

Returns an unpositioned {@link TermPositions} enumerator.

Overload List

Returns an unpositioned {@link TermPositions} enumerator.

public abstract TermPositions TermPositions();

public virtual TermPositions TermPositions(Term);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.TermPositions Method ()

Returns an unpositioned {@link TermPositions} enumerator.

public abstract TermPositions TermPositions();

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.TermPositions Overload List


IndexReader.TermPositions Method (Term)

public virtual TermPositions TermPositions(
Term term
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.TermPositions Overload List


Terms Method

Apache Lucene.Net 2.4.0 Class Library API

IndexReader.Terms Method

Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), {@link TermEnum#Next()} must be called on the resulting enumeration before calling other methods such as {@link TermEnum#Term()}.

Overload List

Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), {@link TermEnum#Next()} must be called on the resulting enumeration before calling other methods such as {@link TermEnum#Term()}.

public abstract TermEnum Terms();

Returns an enumeration of all terms starting at a given term. If the given term does not exist, the enumeration is positioned at the first term greater than the supplied term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.

public abstract TermEnum Terms(Term);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Terms Method ()

Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), {@link TermEnum#Next()} must be called on the resulting enumeration before calling other methods such as {@link TermEnum#Term()}.

public abstract TermEnum Terms();

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Terms Overload List


IndexReader.Terms Method (Term)

Returns an enumeration of all terms starting at a given term. If the given term does not exist, the enumeration is positioned at the first term greater than the supplied term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.

public abstract TermEnum Terms(
Term t
);

See Also

IndexReader Class | Lucene.Net.Index Namespace | IndexReader.Terms Overload List


IndexReader.UndeleteAll Method

Undeletes all documents currently marked as deleted in this index.

public void UndeleteAll();

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.Unlock Method

NOTE: This method is now obsolete.

Please use IndexWriter.Unlock(Directory) instead.

public static void Unlock(
Directory directory
);

See Also

IndexReader Class | Lucene.Net.Index Namespace


IndexReader.FieldOption Class

Constants describing field properties, for example used for {@link IndexReader#GetFieldNames(FieldOption)}.

For a list of all members of this type, see IndexReader.FieldOption Members.

System.Object
Lucene.Net.Index.IndexReader.FieldOption

public sealed class IndexReader.FieldOption

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexReader.FieldOption Members | Lucene.Net.Index Namespace


IndexReader.FieldOption Members

IndexReader.FieldOption overview

Public Static Fields

ALL | All fields
INDEXED | All indexed fields
INDEXED_NO_TERMVECTOR | All fields which are indexed but don't have termvectors enabled
INDEXED_WITH_TERMVECTOR | All fields which are indexed with termvectors enabled
OMIT_TF | All fields that store omit tf
STORES_PAYLOADS | All fields that store payloads
TERMVECTOR | All fields with termvectors enabled. Please note that only standard termvector fields are returned
TERMVECTOR_WITH_OFFSET | All fields with termvectors with offset values enabled
TERMVECTOR_WITH_POSITION | All fields with termvectors with position values enabled
TERMVECTOR_WITH_POSITION_OFFSET | All fields with termvectors with offset values and position values enabled
UNINDEXED | All fields which are not indexed

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption Fields

The fields of the IndexReader.FieldOption class are listed below. For a complete list of IndexReader.FieldOption class members, see the IndexReader.FieldOption Members topic.

Public Static Fields

ALL | All fields
INDEXED | All indexed fields
INDEXED_NO_TERMVECTOR | All fields which are indexed but don't have termvectors enabled
INDEXED_WITH_TERMVECTOR | All fields which are indexed with termvectors enabled
OMIT_TF | All fields that store omit tf
STORES_PAYLOADS | All fields that store payloads
TERMVECTOR | All fields with termvectors enabled. Please note that only standard termvector fields are returned
TERMVECTOR_WITH_OFFSET | All fields with termvectors with offset values enabled
TERMVECTOR_WITH_POSITION | All fields with termvectors with position values enabled
TERMVECTOR_WITH_POSITION_OFFSET | All fields with termvectors with offset values and position values enabled
UNINDEXED | All fields which are not indexed

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption.ALL Field

All fields

public static readonly FieldOption ALL;

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption.INDEXED Field

All indexed fields

public static readonly FieldOption INDEXED;

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption.INDEXED_NO_TERMVECTOR Field

All fields which are indexed but don't have termvectors enabled

public static readonly FieldOption INDEXED_NO_TERMVECTOR;

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption.INDEXED_WITH_TERMVECTOR Field

All fields which are indexed with termvectors enabled

public static readonly FieldOption INDEXED_WITH_TERMVECTOR;

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption.OMIT_TF Field

All fields that store omit tf

public static readonly FieldOption OMIT_TF;

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption.STORES_PAYLOADS Field

All fields that store payloads

public static readonly FieldOption STORES_PAYLOADS;

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption.TERMVECTOR Field

All fields with termvectors enabled. Please note that only standard termvector fields are returned

public static readonly FieldOption TERMVECTOR;

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption.TERMVECTOR_WITH_OFFSET Field

All fields with termvectors with offset values enabled

public static readonly FieldOption TERMVECTOR_WITH_OFFSET;

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption.TERMVECTOR_WITH_POSITION Field

All fields with termvectors with position values enabled

public static readonly FieldOption TERMVECTOR_WITH_POSITION;

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption.TERMVECTOR_WITH_POSITION_OFFSET Field

All fields with termvectors with offset values and position values enabled

public static readonly FieldOption TERMVECTOR_WITH_POSITION_OFFSET;

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption.UNINDEXED Field

All fields which are not indexed

public static readonly FieldOption UNINDEXED;

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption Methods

The methods of the IndexReader.FieldOption class are listed below. For a complete list of IndexReader.FieldOption class members, see the IndexReader.FieldOption Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexReader.FieldOption.ToString Method

public override string ToString();

See Also

IndexReader.FieldOption Class | Lucene.Net.Index Namespace


IndexWriter Class

An
IndexWriter
creates and maintains an index.

The

create
argument to the constructor determines whether a new index is created, or whether an existing index is opened. Note that you can open an index with
create=true
even while readers are using the index. The old readers will continue to search the "point in time" snapshot they had opened, and won't see the newly created index until they re-open. There are also constructors with no
create
argument which will create a new index if there is not already an index at the provided path and otherwise open the existing index.

In either case, documents are added with addDocument and removed with deleteDocuments(Term) or deleteDocuments(Query). A document can be updated with updateDocument (which just deletes and then adds the entire document). When finished adding, deleting and updating documents, close should be called.

These changes are buffered in memory and periodically flushed to the {@link Directory} (during the above method calls). A flush is triggered when there are enough buffered deletes (see {@link #setMaxBufferedDeleteTerms}) or enough added documents since the last flush, whichever is sooner. For the added documents, flushing is triggered either by RAM usage of the documents (see {@link #setRAMBufferSizeMB}) or the number of added documents. The default is to flush when RAM usage hits 16 MB. For best indexing speed you should flush by RAM usage with a large RAM buffer. Note that flushing just moves the internal buffered state in IndexWriter into the index, but these changes are not visible to IndexReader until either {@link #Commit()} or {@link #close} is called. A flush may also trigger one or more segment merges which by default run with a background thread so as not to block the addDocument calls (see below for changing the {@link MergeScheduler}).

The optional

autoCommit
argument to the constructors controls visibility of the changes to {@link IndexReader} instances reading the same index. When this is
false
, changes are not visible until {@link #Close()} or {@link #Commit()} is called. Note that changes will still be flushed to the {@link org.apache.lucene.store.Directory} as new files, but are not committed (no new
segments_N
file is written referencing the new files, nor are the files sync'd to stable storage) until {@link #Close()} or {@link #Commit()} is called. If something goes terribly wrong (for example the JVM crashes), then the index will reflect none of the changes made since the last commit, or the starting state if commit was not called. You can also call {@link #rollback}, which closes the writer without committing any changes, and removes any index files that had been flushed but are now unreferenced. This mode is useful for preventing readers from refreshing at a bad time (for example after you've done all your deletes but before you've done your adds). It can also be used to implement simple single-writer transactional semantics ("all or none"). You can do a two-phase commit by calling {@link #PrepareCommit()} followed by {@link #Commit()}. This is necessary when Lucene is working with an external resource (for example, a database) and both must either commit or rollback the transaction.

When

autoCommit
is
true
then the writer will periodically commit on its own. [Deprecated: Note that in 3.0, IndexWriter will no longer accept autoCommit=true (it will be hardwired to false). You can always call {@link #Commit()} yourself when needed]. There is no guarantee when exactly an auto commit will occur (it used to be after every flush, but it is now after every completed merge, as of 2.4). If you want to force a commit, call {@link #Commit()}, or, close the writer. Once a commit has finished, newly opened {@link IndexReader} instances will see the changes to the index as of that commit. When running in this mode, be careful not to refresh your readers while optimize or segment merges are taking place as this can tie up substantial disk space.

Regardless of

autoCommit
, an {@link IndexReader} or {@link org.apache.lucene.search.IndexSearcher} will only see the index as of the "point in time" that it was opened. Any changes committed to the index after the reader was opened are not visible until the reader is re-opened.

If an index will not have more documents added for a while and optimal search performance is desired, then either the full optimize method or partial {@link #Optimize(int)} method should be called before the index is closed.

Opening an

IndexWriter
creates a lock file for the directory in use. Trying to open another
IndexWriter
on the same directory will lead to a {@link LockObtainFailedException}. The {@link LockObtainFailedException} is also thrown if an IndexReader on the same directory is used to delete documents from the index.

Expert:

IndexWriter
allows an optional {@link IndexDeletionPolicy} implementation to be specified. You can use this to control when prior commits are deleted from the index. The default policy is {@link KeepOnlyLastCommitDeletionPolicy} which removes all prior commits as soon as a new commit is done (this matches behavior before 2.2). Creating your own policy can allow you to explicitly keep previous "point in time" commits alive in the index for some time, to allow readers to refresh to the new commit without having the old commit deleted out from under them. This is necessary on filesystems like NFS that do not support "delete on last close" semantics, which Lucene's "point in time" search normally relies on.

Expert:

IndexWriter
allows you to separately change the {@link MergePolicy} and the {@link MergeScheduler}. The {@link MergePolicy} is invoked whenever there are changes to the segments in the index. Its role is to select which merges to do, if any, and return a {@link MergePolicy.MergeSpecification} describing the merges. It also selects merges to do for Optimize(). (The default is {@link LogByteSizeMergePolicy}. Then, the {@link MergeScheduler} is invoked with the requested merges and it decides when and how to run the merges. The default is {@link ConcurrentMergeScheduler}.

For a list of all members of this type, see IndexWriter Members.

System.Object
Lucene.Net.Index.IndexWriter

public class IndexWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexWriter Members | Lucene.Net.Index Namespace


IndexWriter Members

IndexWriter overview

Public Static Fields

DEFAULT_MAX_BUFFERED_DELETE_TERMS | Disabled by default (because IndexWriter flushes by RAM usage by default). Change using {@link #SetMaxBufferedDeleteTerms(int)}.
DEFAULT_MAX_BUFFERED_DOCS | Disabled by default (because IndexWriter flushes by RAM usage by default). Change using {@link #SetMaxBufferedDocs(int)}.
DEFAULT_MAX_FIELD_LENGTH | Default value is 10,000. Change using {@link #SetMaxFieldLength(int)}.
DEFAULT_MAX_MERGE_DOCS |
DEFAULT_MAX_SYNC_PAUSE_SECONDS | Default for {@link #getMaxSyncPauseSeconds}. On Windows this defaults to 10.0 seconds; elsewhere it's 0.
DEFAULT_MERGE_FACTOR |
DEFAULT_RAM_BUFFER_SIZE_MB | Default value is 16 MB (which means flush when buffered docs consume 16 MB RAM). Change using {@link #setRAMBufferSizeMB}.
DEFAULT_TERM_INDEX_INTERVAL | Default value is 128. Change using {@link #SetTermIndexInterval(int)}.
DISABLE_AUTO_FLUSH | Value to denote a flush trigger is disabled
MAX_TERM_LENGTH | Absolute hard maximum length for a term. If a term arrives from the analyzer longer than this length, it is skipped and a message is printed to infoStream, if set (see {@link #setInfoStream}).
WRITE_LOCK_NAME | Name of the write lock in the index.
WRITE_LOCK_TIMEOUT | Default value for the write lock timeout (1,000).

Public Static Methods

GetDefaultInfoStream | Returns the current default infoStream for newly instantiated IndexWriters.
GetDefaultWriteLockTimeout | Returns default write lock timeout for newly instantiated IndexWriters.
IsLocked | Overloaded.
SetDefaultInfoStream | If non-null, this will be the default infoStream used by a newly instantiated IndexWriter.
SetDefaultWriteLockTimeout | Sets the default (for any instance of IndexWriter) maximum time to wait for a write lock (in milliseconds).
Unlock |

Public Instance Constructors

IndexWriter Overloaded. Initializes a new instance of the IndexWriter class.

Public Instance Methods

Abort | Obsolete.
AddDocument | Overloaded.
AddIndexes | Overloaded.
AddIndexesNoOptimize
Close | Overloaded.
Commit
DeleteDocuments Overloaded. Deletes the document(s) containing
term
.
DocCount | Obsolete. Returns the number of documents currently in this index, not counting deletions.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpungeDeletes | Overloaded. Just like {@link #expungeDeletes()}, except you can specify whether the call should block until the operation completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.
Flush | Overloaded.
GetAnalyzer | Returns the analyzer used by this index.
GetBufferedDeleteTermsSize
GetDirectory | Returns the Directory used by this index.
GetDocCount
GetFlushCount
GetFlushDeletesCount
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInfoStream | Returns the current infoStream in use by this writer.
GetMaxBufferedDeleteTerms | Returns the number of buffered deleted terms that will trigger a flush if enabled.
GetMaxBufferedDocs | Returns the number of buffered added documents that will trigger a flush if enabled.
GetMaxFieldLength | Returns the maximum number of terms that will be indexed for a single field in a document.
GetMaxMergeDocs | Returns the largest segment (measured by document count) that may be merged with other segments. Note that this method is a convenience method: it just calls mergePolicy.GetMaxMergeDocs as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.
GetMaxSyncPauseSeconds | Obsolete. Expert: returns max delay inserted before syncing a commit point. On Windows, at least, pausing before syncing can increase net indexing throughput. The delay is variable based on size of the segment's files, and is only inserted when using ConcurrentMergeScheduler for merges.
GetMergeFactor | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index. Note that this method is a convenience method: it just calls mergePolicy.GetMergeFactor as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.
GetMergePolicy | Expert: returns the current MergePolicy in use by this writer.
GetMergeScheduler | Expert: returns the current MergePolicy in use by this writer.
GetNextMerge | Expert: the {@link MergeScheduler} calls this method to retrieve the next merge requested by the MergePolicy
GetNumBufferedDeleteTerms
GetNumBufferedDocuments
GetRAMBufferSizeMB | Returns the value set by {@link #setRAMBufferSizeMB} if enabled.
GetSegmentCount
GetSimilarity
GetTermIndexInterval | Expert: Return the interval between indexed terms.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundFile | Get the current setting of whether newly flushed segments will use the compound file format. Note that this just returns the value previously set with setUseCompoundFile(bool), or the default value (true). You cannot use this to query the status of previously flushed segments. Note that this method is a convenience method: it just calls mergePolicy.GetUseCompoundFile as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.
GetWriteLockTimeout | Returns allowed timeout when acquiring the write lock.
HasDeletions
MaxDoc | Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), without regard for deletions (see NumDocs()).
MaybeMerge | Expert: asks the mergePolicy whether any merges are necessary now and if so, runs the requested merges and then iterate (test again if merges are needed) until no more merges are returned by the mergePolicy. Explicit calls to MaybeMerge() are usually not necessary. The most common case is when merge policy parameters have changed.
Merge
Message | Prints a message to the infoStream (if non-null), prefixed with the identifying information for this writer and the thread that's calling it.
NewestSegment
NumDocs | Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), with regard for deletions. NOTE: Buffered deletions are not excluded. If these need to be excluded, call Commit() first.
NumRamDocs
Optimize | Overloaded.
PrepareCommit
RamSizeInBytes
Rollback Close the
IndexWriter
without committing any of the changes that have occurred since it was opened. This removes any temporary files that had been created, after which the state of the index will be the same as it was when this writer was first opened. This can only be called when this IndexWriter was opened with
autoCommit=false
. This also clears a previous call to PrepareCommit().
SegString
SetInfoStream | If non-null, information about merges, deletes and a message when maxFieldLength is reached will be printed to this.
SetMaxBufferedDeleteTerms | Determines the minimal number of delete terms required before the buffered in-memory delete terms are applied and flushed. If there are documents buffered in memory at the time, they are merged and a new segment is created. Disabled by default (writer flushes by RAM usage).
SetMaxBufferedDocs | Determines the minimal number of documents required before the buffered in-memory documents are flushed as a new Segment. Large values generally gives faster indexing. When this is set, the writer will flush every maxBufferedDocs added documents. Pass in {@link #DISABLE_AUTO_FLUSH} to prevent triggering a flush due to number of buffered documents. Note that if flushing by RAM usage is also enabled, then the flush will be triggered by whichever comes first. Disabled by default (writer flushes by RAM usage).
SetMaxFieldLength | The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. This setting refers to the number of running terms, not to the number of different terms. Note: this silently truncates large documents, excluding from the index all terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an System.OutOfMemoryException. By default, no more than DEFAULT_MAX_FIELD_LENGTH terms will be indexed for a field.
SetMaxMergeDocs | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. Note that this method is a convenience method: it just calls mergePolicy.SetMaxMergeDocs as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.
SetMaxSyncPauseSeconds | Obsolete. Expert: sets the max delay before syncing a commit point.
SetMergeFactor
SetMergePolicy | Expert: set the merge policy used by this writer.
SetMergeScheduler | Expert: set the merge scheduler used by this writer.
SetRAMBufferSizeMB | Determines the amount of RAM that may be used for buffering added documents before they are flushed as a new Segment. Generally for faster indexing performance it's best to flush by RAM usage instead of document count and use as large a RAM buffer as you can. When this is set, the writer will flush whenever buffered documents use this much RAM. Pass in {@link #DISABLE_AUTO_FLUSH} to prevent triggering a flush due to RAM usage. Note that if flushing by document count is also enabled, then the flush will be triggered by whichever comes first. The default value is {@link #DEFAULT_RAM_BUFFER_SIZE_MB}.
SetSimilarity | Expert: Set the Similarity implementation used by this IndexWriter.
SetTermIndexInterval Expert: Set the interval between indexed terms. Large values cause less memory to be used by IndexReader, but slow random-access to terms. Small values cause more memory to be used by an IndexReader, and speed random-access to terms. This parameter determines the amount of computation required per query term, regardless of the number of documents that contain that term. In particular, it is the maximum number of other terms that must be scanned before a term is located and its frequency and position information may be processed. In a large index with user-entered query terms, query processing time is likely to be dominated not by term lookup but rather by the processing of frequency and positional data. In a small index or when many uncommon query terms are generated (e.g., by wildcard queries) term lookup may become a dominant cost. In particular,
numUniqueTerms/interval
terms are read into memory by an IndexReader, and, on average,
interval/2
terms must be scanned for each random term access.
SetUseCompoundFile | Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file when a new segment is flushed. Note that this method is a convenience method: it just calls mergePolicy.SetUseCompoundFile as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.
SetWriteLockTimeout
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDocument Overloaded. Updates a document by first deleting the document(s) containing
term
and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

Protected Instance Methods

EnsureOpen | Overloaded.
Finalize | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

DoAfterFlush |
EnsureOpen | Overloaded. Used internally to throw an {@link AlreadyClosedException} if this IndexWriter has been closed.
TestPoint |

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter Constructor

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and

create
is
false
or if there is any other low-level IO error

Overload List

Obsolete. Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(Directory,Analyzer);

public IndexWriter(Directory,Analyzer,IndexDeletionPolicy,MaxFieldLength);

Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. NOTE: autoCommit (see above) is set to false with this constructor. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(Directory,Analyzer,MaxFieldLength);

Obsolete. Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
d
, replacing the index already there, if any. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and
create
is
false
or if there is any other low-level IO error

public IndexWriter(Directory,Analyzer,bool);

public IndexWriter(Directory,Analyzer,bool,IndexDeletionPolicy,MaxFieldLength);

Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
d
, replacing the index already there, if any. NOTE: autoCommit (see above) is set to false with this constructor. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and
create
is
false
or if there is any other low-level IO error

public IndexWriter(Directory,Analyzer,bool,MaxFieldLength);

Obsolete. Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(Directory,bool,Analyzer);

Obsolete.

public IndexWriter(Directory,bool,Analyzer,IndexDeletionPolicy);

Obsolete. Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
d
, replacing the index already there, if any. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and
create
is
false
or if there is any other low-level IO error

public IndexWriter(Directory,bool,Analyzer,bool);

Obsolete.

public IndexWriter(Directory,bool,Analyzer,bool,IndexDeletionPolicy);

Obsolete. Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(FileInfo,Analyzer);

Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. NOTE: autoCommit (see above) is set to false with this constructor. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(FileInfo,Analyzer,MaxFieldLength);

Obsolete. Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and
create
is
false
or if there is any other low-level IO error

public IndexWriter(FileInfo,Analyzer,bool);

Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any. NOTE: autoCommit (see above) is set to false with this constructor. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and
create
is
false
or if there is any other low-level IO error

public IndexWriter(FileInfo,Analyzer,bool,MaxFieldLength);

Obsolete. Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(string,Analyzer);

Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. NOTE: autoCommit (see above) is set to false with this constructor. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(string,Analyzer,MaxFieldLength);

Obsolete. Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and
create
is
false
or if there is any other low-level IO error

public IndexWriter(string,Analyzer,bool);

Constructs an IndexWriter for the index in

path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any. NOTE: autoCommit (see above) is set to false with this constructor. Throws CorruptIndexException if the index is corrupt Throws LockObtainFailedException if another writer has this index open (
write.lock
could not be obtained) Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and
create
is
false
or if there is any other low-level IO error

public IndexWriter(string,Analyzer,bool,MaxFieldLength);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter Constructor (String, Analyzer, Boolean, MaxFieldLength)

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and

create
is
false
or if there is any other low-level IO error

public IndexWriter(
string path,
Analyzer a,
bool create,
MaxFieldLength mfl
);

Parameters

path
the path to the index directory
a
the analyzer to use
create
true
to create the index or overwrite the existing one;
false
to append to the existing index
mfl
Maximum field Length: LIMITED, UNLIMITED, or user-specified

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (String, Analyzer, Boolean)

NOTE: This constructor is now obsolete.

This constructor will be removed in the 3.0 release. Use IndexWriter(string, Analyzer, bool, MaxFieldLength) instead, and call Commit() when needed

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and

create
is
false
or if there is any other low-level IO error

public IndexWriter(
string path,
Analyzer a,
bool create
);

Parameters

path
the path to the index directory
a
the analyzer to use
create
true
to create the index or overwrite the existing one;
false
to append to the existing index

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (FileInfo, Analyzer, Boolean, MaxFieldLength)

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and

create
is
false
or if there is any other low-level IO error

public IndexWriter(
FileInfo path,
Analyzer a,
bool create,
MaxFieldLength mfl
);

Parameters

path
the path to the index directory
a
the analyzer to use
create
true
to create the index or overwrite the existing one;
false
to append to the existing index
mfl
Maximum field Length: LIMITED, UNLIMITED, or user-specified

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (FileInfo, Analyzer, Boolean)

NOTE: This constructor is now obsolete.

This constructor will be removed in the 3.0 release. Use IndexWriter(FileInfo, Analyzer, bool, MaxFieldLength) instead, and call Commit() when needed

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
path
, replacing the index already there, if any.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and

create
is
false
or if there is any other low-level IO error

public IndexWriter(
FileInfo path,
Analyzer a,
bool create
);

Parameters

path
the path to the index directory
a
the analyzer to use
create
true
to create the index or overwrite the existing one;
false
to append to the existing index

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (Directory, Analyzer, Boolean, MaxFieldLength)

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
d
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and

create
is
false
or if there is any other low-level IO error

public IndexWriter(
Directory d,
Analyzer a,
bool create,
MaxFieldLength mfl
);

Parameters

d
the index directory
a
the analyzer to use
create
true
to create the index or overwrite the existing one;
false
to append to the existing index
mfl
Maximum field Length: LIMITED, UNLIMITED, or user-specified

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (Directory, Analyzer, Boolean)

NOTE: This constructor is now obsolete.

This constructor will be removed in the 3.0 release. Use IndexWriter(Directory, Analyzer, bool, MaxFieldLength) instead, and call Commit() when needed

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
d
, replacing the index already there, if any.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and

create
is
false
or if there is any other low-level IO error

public IndexWriter(
Directory d,
Analyzer a,
bool create
);

Parameters

d
the index directory
a
the analyzer to use
create
true
to create the index or overwrite the existing one;
false
to append to the existing index

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (String, Analyzer, MaxFieldLength)

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(
string path,
Analyzer a,
MaxFieldLength mfl
);

Parameters

path
the path to the index directory
a
the analyzer to use
mfl
Maximum field Length: LIMITED, UNLIMITED, or user-specified

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (String, Analyzer)

NOTE: This constructor is now obsolete.

This constructor will be removed in the 3.0 release. Use IndexWriter(string, Analyzer, MaxFieldLength) instead, and call Commit() when needed

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(
string path,
Analyzer a
);

Parameters

path
the path to the index directory
a
the analyzer to use

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (FileInfo, Analyzer, MaxFieldLength)

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(
FileInfo path,
Analyzer a,
MaxFieldLength mfl
);

Parameters

path
the path to the index directory
a
the analyzer to use
mfl
Maximum field Length: LIMITED, UNLIMITED, or user-specified

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (FileInfo, Analyzer)

NOTE: This constructor is now obsolete.

This constructor will be removed in the 3.0 release. Use IndexWriter(FileInfo, Analyzer, MaxFieldLength) instead, and call Commit() when needed

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(
FileInfo path,
Analyzer a
);

Parameters

path
the path to the index directory
a
the analyzer to use

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (Directory, Analyzer, MaxFieldLength)

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(
Directory d,
Analyzer a,
MaxFieldLength mfl
);

Parameters

d
the index directory
a
the analyzer to use
mfl
Maximum field Length: LIMITED, UNLIMITED, or user-specified

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (Directory, Analyzer)

NOTE: This constructor is now obsolete.

This constructor will be removed in the 3.0 release. Use IndexWriter(Directory, Analyzer, MaxFieldLength) instead, and call Commit() when needed

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(
Directory d,
Analyzer a
);

Parameters

d
the index directory
a
the analyzer to use

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (Directory, Boolean, Analyzer)

NOTE: This constructor is now obsolete.

This constructor will be removed in the 3.0 release. Use IndexWriter(Directory, Analyzer, MaxFieldLength) instead, and call Commit() when needed

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to or if there is any other low-level IO error

public IndexWriter(
Directory d,
bool autoCommit,
Analyzer a
);

Parameters

d
the index directory
autoCommit
see autoCommit above
a
the analyzer to use

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (Directory, Boolean, Analyzer, Boolean)

NOTE: This constructor is now obsolete.

This constructor will be removed in the 3.0 release. Use IndexWriter(Directory, Analyzer, bool, MaxFieldLength) instead, and call Commit() when needed

Constructs an IndexWriter for the index in
path
. Text will be analyzed with
a
. If
create
is true, then a new, empty index will be created in
d
, replacing the index already there, if any.

Throws CorruptIndexException if the index is corrupt

Throws LockObtainFailedException if another writer has this index open (

write.lock
could not be obtained)

Throws System.IO.IOException if the directory cannot be read/written to, or if it does not exist and

create
is
false
or if there is any other low-level IO error

public IndexWriter(
Directory d,
bool autoCommit,
Analyzer a,
bool create
);

Parameters

d
autoCommit
see autoCommit above
a
the analyzer to use
create
true
to create the index or overwrite the existing one;
false
to append to the existing index

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (Directory, Analyzer, IndexDeletionPolicy, MaxFieldLength)

public IndexWriter(
Directory d,
Analyzer a,
IndexDeletionPolicy deletionPolicy,
MaxFieldLength mfl
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (Directory, Boolean, Analyzer, IndexDeletionPolicy)

NOTE: This constructor is now obsolete.

This constructor will be removed in the 3.0 release. Use IndexWriter(Directory, Analyzer, IndexDeletionPolicy, MaxFieldLength) instead, and call Commit() when needed

public IndexWriter(
Directory d,
bool autoCommit,
Analyzer a,
IndexDeletionPolicy deletionPolicy
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (Directory, Analyzer, Boolean, IndexDeletionPolicy, MaxFieldLength)

public IndexWriter(
Directory d,
Analyzer a,
bool create,
IndexDeletionPolicy deletionPolicy,
MaxFieldLength mfl
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Constructor (Directory, Boolean, Analyzer, Boolean, IndexDeletionPolicy)

NOTE: This constructor is now obsolete.

This constructor will be removed in the 3.0 release. Use IndexWriter(Directory, Analyzer, bool, IndexDeletionPolicy, MaxFieldLength) instead, and call Commit() when needed

public IndexWriter(
Directory d,
bool autoCommit,
Analyzer a,
bool create,
IndexDeletionPolicy deletionPolicy
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter Constructor Overload List


IndexWriter Fields

The fields of the IndexWriter class are listed below. For a complete list of IndexWriter class members, see the IndexWriter Members topic.

Public Static Fields

DEFAULT_MAX_BUFFERED_DELETE_TERMS | Disabled by default (because IndexWriter flushes by RAM usage by default). Change using {@link #SetMaxBufferedDeleteTerms(int)}.
DEFAULT_MAX_BUFFERED_DOCS | Disabled by default (because IndexWriter flushes by RAM usage by default). Change using {@link #SetMaxBufferedDocs(int)}.
DEFAULT_MAX_FIELD_LENGTH | Default value is 10,000. Change using {@link #SetMaxFieldLength(int)}.
DEFAULT_MAX_MERGE_DOCS |
DEFAULT_MAX_SYNC_PAUSE_SECONDS | Default for {@link #getMaxSyncPauseSeconds}. On Windows this defaults to 10.0 seconds; elsewhere it's 0.
DEFAULT_MERGE_FACTOR |
DEFAULT_RAM_BUFFER_SIZE_MB | Default value is 16 MB (which means flush when buffered docs consume 16 MB RAM). Change using {@link #setRAMBufferSizeMB}.
DEFAULT_TERM_INDEX_INTERVAL | Default value is 128. Change using {@link #SetTermIndexInterval(int)}.
DISABLE_AUTO_FLUSH | Value to denote a flush trigger is disabled
MAX_TERM_LENGTH | Absolute hard maximum length for a term. If a term arrives from the analyzer longer than this length, it is skipped and a message is printed to infoStream, if set (see {@link #setInfoStream}).
WRITE_LOCK_NAME | Name of the write lock in the index.
WRITE_LOCK_TIMEOUT | Default value for the write lock timeout (1,000).

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DEFAULT_MAX_BUFFERED_DELETE_TERMS Field

Disabled by default (because IndexWriter flushes by RAM usage by default). Change using {@link #SetMaxBufferedDeleteTerms(int)}.

public static readonly int DEFAULT_MAX_BUFFERED_DELETE_TERMS;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DEFAULT_MAX_BUFFERED_DOCS Field

Disabled by default (because IndexWriter flushes by RAM usage by default). Change using {@link #SetMaxBufferedDocs(int)}.

public static readonly int DEFAULT_MAX_BUFFERED_DOCS;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DEFAULT_MAX_FIELD_LENGTH Field

Default value is 10,000. Change using {@link #SetMaxFieldLength(int)}.

public const int DEFAULT_MAX_FIELD_LENGTH = 10000;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DEFAULT_MAX_MERGE_DOCS Field

public static readonly int DEFAULT_MAX_MERGE_DOCS;

See Also

IndexWriter Class | Lucene.Net.Index Namespace | DEFAULT_MAX_MERGE_DOCS


IndexWriter.DEFAULT_MAX_SYNC_PAUSE_SECONDS Field

Default for {@link #getMaxSyncPauseSeconds}. On Windows this defaults to 10.0 seconds; elsewhere it's 0.

public static readonly double DEFAULT_MAX_SYNC_PAUSE_SECONDS;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DEFAULT_MERGE_FACTOR Field

public static readonly int DEFAULT_MERGE_FACTOR;

See Also

IndexWriter Class | Lucene.Net.Index Namespace |


IndexWriter.DEFAULT_RAM_BUFFER_SIZE_MB Field

Default value is 16 MB (which means flush when buffered docs consume 16 MB RAM). Change using {@link #setRAMBufferSizeMB}.

public const double DEFAULT_RAM_BUFFER_SIZE_MB = 16;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DEFAULT_TERM_INDEX_INTERVAL Field

Default value is 128. Change using {@link #SetTermIndexInterval(int)}.

public const int DEFAULT_TERM_INDEX_INTERVAL = 128;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DISABLE_AUTO_FLUSH Field

Value to denote a flush trigger is disabled

public const int DISABLE_AUTO_FLUSH = -1;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.MAX_TERM_LENGTH Field

Absolute hard maximum length for a term. If a term arrives from the analyzer longer than this length, it is skipped and a message is printed to infoStream, if set (see {@link #setInfoStream}).

public static readonly int MAX_TERM_LENGTH;

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.WRITE_LOCK_NAME Field

Name of the write lock in the index.

public const string WRITE_LOCK_NAME = "write.lock";

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.WRITE_LOCK_TIMEOUT Field

Default value for the write lock timeout (1,000).

public static long WRITE_LOCK_TIMEOUT;

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setDefaultWriteLockTimeout


IndexWriter Methods

The methods of the IndexWriter class are listed below. For a complete list of IndexWriter class members, see the IndexWriter Members topic.

Public Static Methods

GetDefaultInfoStream | Returns the current default infoStream for newly instantiated IndexWriters.
GetDefaultWriteLockTimeout | Returns default write lock timeout for newly instantiated IndexWriters.
IsLocked | Overloaded.
SetDefaultInfoStream | If non-null, this will be the default infoStream used by a newly instantiated IndexWriter.
SetDefaultWriteLockTimeout | Sets the default (for any instance of IndexWriter) maximum time to wait for a write lock (in milliseconds).
Unlock |

Public Instance Methods

Abort | Obsolete.
AddDocument | Overloaded.
AddIndexes | Overloaded.
AddIndexesNoOptimize
Close | Overloaded.
Commit
DeleteDocuments Overloaded. Deletes the document(s) containing
term
.
DocCount | Obsolete. Returns the number of documents currently in this index, not counting deletions.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpungeDeletes | Overloaded. Just like {@link #expungeDeletes()}, except you can specify whether the call should block until the operation completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.
Flush | Overloaded.
GetAnalyzer | Returns the analyzer used by this index.
GetBufferedDeleteTermsSize
GetDirectory | Returns the Directory used by this index.
GetDocCount
GetFlushCount
GetFlushDeletesCount
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInfoStream | Returns the current infoStream in use by this writer.
GetMaxBufferedDeleteTerms | Returns the number of buffered deleted terms that will trigger a flush if enabled.
GetMaxBufferedDocs | Returns the number of buffered added documents that will trigger a flush if enabled.
GetMaxFieldLength | Returns the maximum number of terms that will be indexed for a single field in a document.
GetMaxMergeDocs | Returns the largest segment (measured by document count) that may be merged with other segments. Note that this method is a convenience method: it just calls mergePolicy.GetMaxMergeDocs as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.
GetMaxSyncPauseSeconds | Obsolete. Expert: returns max delay inserted before syncing a commit point. On Windows, at least, pausing before syncing can increase net indexing throughput. The delay is variable based on size of the segment's files, and is only inserted when using ConcurrentMergeScheduler for merges.
GetMergeFactor | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index. Note that this method is a convenience method: it just calls mergePolicy.GetMergeFactor as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.
GetMergePolicy | Expert: returns the current MergePolicy in use by this writer.
GetMergeScheduler | Expert: returns the current MergePolicy in use by this writer.
GetNextMerge | Expert: the {@link MergeScheduler} calls this method to retrieve the next merge requested by the MergePolicy
GetNumBufferedDeleteTerms
GetNumBufferedDocuments
GetRAMBufferSizeMB | Returns the value set by {@link #setRAMBufferSizeMB} if enabled.
GetSegmentCount
GetSimilarity
GetTermIndexInterval | Expert: Return the interval between indexed terms.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundFile | Get the current setting of whether newly flushed segments will use the compound file format. Note that this just returns the value previously set with setUseCompoundFile(bool), or the default value (true). You cannot use this to query the status of previously flushed segments. Note that this method is a convenience method: it just calls mergePolicy.GetUseCompoundFile as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.
GetWriteLockTimeout | Returns allowed timeout when acquiring the write lock.
HasDeletions
MaxDoc | Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), without regard for deletions (see NumDocs()).
MaybeMerge | Expert: asks the mergePolicy whether any merges are necessary now and if so, runs the requested merges and then iterate (test again if merges are needed) until no more merges are returned by the mergePolicy. Explicit calls to MaybeMerge() are usually not necessary. The most common case is when merge policy parameters have changed.
Merge
Message | Prints a message to the infoStream (if non-null), prefixed with the identifying information for this writer and the thread that's calling it.
NewestSegment
NumDocs | Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), with regard for deletions. NOTE: Buffered deletions are not excluded. If these need to be excluded, call Commit() first.
NumRamDocs
Optimize | Overloaded.
PrepareCommit
RamSizeInBytes
Rollback Close the
IndexWriter
without committing any of the changes that have occurred since it was opened. This removes any temporary files that had been created, after which the state of the index will be the same as it was when this writer was first opened. This can only be called when this IndexWriter was opened with
autoCommit=false
. This also clears a previous call to PrepareCommit().
SegString
SetInfoStream | If non-null, information about merges, deletes and a message when maxFieldLength is reached will be printed to this.
SetMaxBufferedDeleteTerms | Determines the minimal number of delete terms required before the buffered in-memory delete terms are applied and flushed. If there are documents buffered in memory at the time, they are merged and a new segment is created. Disabled by default (writer flushes by RAM usage).
SetMaxBufferedDocs | Determines the minimal number of documents required before the buffered in-memory documents are flushed as a new Segment. Large values generally gives faster indexing. When this is set, the writer will flush every maxBufferedDocs added documents. Pass in {@link #DISABLE_AUTO_FLUSH} to prevent triggering a flush due to number of buffered documents. Note that if flushing by RAM usage is also enabled, then the flush will be triggered by whichever comes first. Disabled by default (writer flushes by RAM usage).
SetMaxFieldLength | The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. This setting refers to the number of running terms, not to the number of different terms. Note: this silently truncates large documents, excluding from the index all terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an System.OutOfMemoryException. By default, no more than DEFAULT_MAX_FIELD_LENGTH terms will be indexed for a field.
SetMaxMergeDocs | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. Note that this method is a convenience method: it just calls mergePolicy.SetMaxMergeDocs as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.
SetMaxSyncPauseSeconds | Obsolete. Expert: sets the max delay before syncing a commit point.
SetMergeFactor
SetMergePolicy | Expert: set the merge policy used by this writer.
SetMergeScheduler | Expert: set the merge scheduler used by this writer.
SetRAMBufferSizeMB | Determines the amount of RAM that may be used for buffering added documents before they are flushed as a new Segment. Generally for faster indexing performance it's best to flush by RAM usage instead of document count and use as large a RAM buffer as you can. When this is set, the writer will flush whenever buffered documents use this much RAM. Pass in {@link #DISABLE_AUTO_FLUSH} to prevent triggering a flush due to RAM usage. Note that if flushing by document count is also enabled, then the flush will be triggered by whichever comes first. The default value is {@link #DEFAULT_RAM_BUFFER_SIZE_MB}.
SetSimilarity | Expert: Set the Similarity implementation used by this IndexWriter.
SetTermIndexInterval Expert: Set the interval between indexed terms. Large values cause less memory to be used by IndexReader, but slow random-access to terms. Small values cause more memory to be used by an IndexReader, and speed random-access to terms. This parameter determines the amount of computation required per query term, regardless of the number of documents that contain that term. In particular, it is the maximum number of other terms that must be scanned before a term is located and its frequency and position information may be processed. In a large index with user-entered query terms, query processing time is likely to be dominated not by term lookup but rather by the processing of frequency and positional data. In a small index or when many uncommon query terms are generated (e.g., by wildcard queries) term lookup may become a dominant cost. In particular,
numUniqueTerms/interval
terms are read into memory by an IndexReader, and, on average,
interval/2
terms must be scanned for each random term access.
SetUseCompoundFile | Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file when a new segment is flushed. Note that this method is a convenience method: it just calls mergePolicy.SetUseCompoundFile as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.
SetWriteLockTimeout
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDocument Overloaded. Updates a document by first deleting the document(s) containing
term
and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

Protected Instance Methods

EnsureOpen | Overloaded.
Finalize | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

DoAfterFlush |
EnsureOpen | Overloaded. Used internally to throw an {@link AlreadyClosedException} if this IndexWriter has been closed.
TestPoint |

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.Abort Method

NOTE: This method is now obsolete.

Plese use Rollback() instead

public void Abort();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


AddDocument Method

Apache Lucene.Net 2.4.0 Class Library API

IndexWriter.AddDocument Method

Overload List

public virtual void AddDocument(Document);

Adds a document to this index, using the provided analyzer instead of the value of {@link #GetAnalyzer()}. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded. See {@link #AddDocument(Document)} for details on index and IndexWriter state after an Exception, and flushing/merging temporary free space requirements.

public virtual void AddDocument(Document,Analyzer);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.AddDocument Method (Document)

public virtual void AddDocument(
Document doc
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.AddDocument Overload List


IndexWriter.AddDocument Method (Document, Analyzer)

Adds a document to this index, using the provided analyzer instead of the value of {@link #GetAnalyzer()}. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

See {@link #AddDocument(Document)} for details on index and IndexWriter state after an Exception, and flushing/merging temporary free space requirements.

public virtual void AddDocument(
Document doc,
Analyzer analyzer
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.AddDocument Overload List


AddIndexes Method

Apache Lucene.Net 2.4.0 Class Library API

IndexWriter.AddIndexes Method

Overload List

public void AddIndexes(IndexReader[]);

public void AddIndexes(Directory[]);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.AddIndexes Method (IndexReader[])

public void AddIndexes(
IndexReader[] readers
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.AddIndexes Overload List


IndexWriter.AddIndexes Method (Directory[])

public void AddIndexes(
Directory[] dirs
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.AddIndexes Overload List


IndexWriter.AddIndexesNoOptimize Method

public void AddIndexesNoOptimize(
Directory[] dirs
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


Close Method

Apache Lucene.Net 2.4.0 Class Library API

IndexWriter.Close Method

Overload List

public virtual void Close();

Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

public virtual void Close(bool);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.Close Method ()

public virtual void Close();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.Close Overload List


IndexWriter.Close Method (Boolean)

Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

public virtual void Close(
bool waitForMerges
);

Parameters

waitForMerges
if true, this call will block until all merges complete; else, it will ask all running merges to abort, wait until those merges have finished (which should be at most a few seconds), and then return.

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.Close Overload List


IndexWriter.Commit Method

public void Commit();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


DeleteDocuments Method

Apache Lucene.Net 2.4.0 Class Library API

IndexWriter.DeleteDocuments Method

Deletes the document(s) containing

term
.

Overload List

Deletes the document(s) containing

term
.

public virtual void DeleteDocuments(Term);

Deletes the document(s) containing any of the terms. All deletes are flushed at the same time.

public virtual void DeleteDocuments(Term[]);

Deletes the document(s) matching the provided query. @param query the query to identify the documents to be deleted @throws CorruptIndexException if the index is corrupt @throws System.IO.IOException if there is a low-level IO error

public void DeleteDocuments(Query);

Deletes the document(s) matching any of the provided queries. All deletes are flushed at the same time. @param queries array of queries to identify the documents to be deleted @throws CorruptIndexException if the index is corrupt @throws System.IO.IOException if there is a low-level IO error

public void DeleteDocuments(Query[]);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DeleteDocuments Method (Term)

Deletes the document(s) containing

term
.

public virtual void DeleteDocuments(
Term term
);

Parameters

term
the term to identify the documents to be deleted

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.DeleteDocuments Overload List


IndexWriter.DeleteDocuments Method (Term[])

Deletes the document(s) containing any of the terms. All deletes are flushed at the same time.

public virtual void DeleteDocuments(
Term[] terms
);

Parameters

terms
array of terms to identify the documents to be deleted

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.DeleteDocuments Overload List


IndexWriter.DeleteDocuments Method (Query)

Deletes the document(s) matching the provided query. @param query the query to identify the documents to be deleted @throws CorruptIndexException if the index is corrupt @throws System.IO.IOException if there is a low-level IO error

public void DeleteDocuments(
Query query
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.DeleteDocuments Overload List


IndexWriter.DeleteDocuments Method (Query[])

Deletes the document(s) matching any of the provided queries. All deletes are flushed at the same time. @param queries array of queries to identify the documents to be deleted @throws CorruptIndexException if the index is corrupt @throws System.IO.IOException if there is a low-level IO error

public void DeleteDocuments(
Query[] queries
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.DeleteDocuments Overload List


IndexWriter.DoAfterFlush Method

protected internal virtual void DoAfterFlush();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.DocCount Method

NOTE: This method is now obsolete.

Please use MaxDoc() (same as this method) or NumDocs() (takes deletions into account)

Returns the number of documents currently in this index, not counting deletions.

public virtual int DocCount();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


EnsureOpen Method

Apache Lucene.Net 2.4.0 Class Library API

IndexWriter.EnsureOpen Method

Overload List

protected void EnsureOpen();

Used internally to throw an {@link AlreadyClosedException} if this IndexWriter has been closed.

protected internal void EnsureOpen(bool);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.EnsureOpen Method ()

protected void EnsureOpen();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.EnsureOpen Overload List


IndexWriter.EnsureOpen Method (Boolean)

Used internally to throw an {@link AlreadyClosedException} if this IndexWriter has been closed.

protected internal void EnsureOpen(
bool includePendingClose
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.EnsureOpen Overload List


ExpungeDeletes Method

Apache Lucene.Net 2.4.0 Class Library API

IndexWriter.ExpungeDeletes Method

Expunges all deletes from the index. When an index has many document deletions (or updates to existing documents), it's best to either call optimize or expungeDeletes to remove all unused data in the index associated with the deleted documents. To see how many deletions you have pending in your index, call {@link IndexReader#numDeletedDocs} This saves disk space and memory usage while searching. expungeDeletes should be somewhat faster than optimize since it does not insist on reducing the index to a single segment (though, this depends on the {@link MergePolicy}; see {@link MergePolicy#findMergesToExpungeDeletes}.). Note that this call does not first commit any buffered documents, so you must do so yourself if necessary. See also {@link #expungeDeletes(bool)}

Overload List

Expunges all deletes from the index. When an index has many document deletions (or updates to existing documents), it's best to either call optimize or expungeDeletes to remove all unused data in the index associated with the deleted documents. To see how many deletions you have pending in your index, call {@link IndexReader#numDeletedDocs} This saves disk space and memory usage while searching. expungeDeletes should be somewhat faster than optimize since it does not insist on reducing the index to a single segment (though, this depends on the {@link MergePolicy}; see {@link MergePolicy#findMergesToExpungeDeletes}.). Note that this call does not first commit any buffered documents, so you must do so yourself if necessary. See also {@link #expungeDeletes(bool)}

public void ExpungeDeletes();

Just like {@link #expungeDeletes()}, except you can specify whether the call should block until the operation completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

public void ExpungeDeletes(bool);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.ExpungeDeletes Method ()

Expunges all deletes from the index. When an index has many document deletions (or updates to existing documents), it's best to either call optimize or expungeDeletes to remove all unused data in the index associated with the deleted documents. To see how many deletions you have pending in your index, call {@link IndexReader#numDeletedDocs} This saves disk space and memory usage while searching. expungeDeletes should be somewhat faster than optimize since it does not insist on reducing the index to a single segment (though, this depends on the {@link MergePolicy}; see {@link MergePolicy#findMergesToExpungeDeletes}.). Note that this call does not first commit any buffered documents, so you must do so yourself if necessary. See also {@link #expungeDeletes(bool)}

public void ExpungeDeletes();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.ExpungeDeletes Overload List


IndexWriter.ExpungeDeletes Method (Boolean)

Just like {@link #expungeDeletes()}, except you can specify whether the call should block until the operation completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

public void ExpungeDeletes(
bool doWait
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.ExpungeDeletes Overload List


IndexWriter.Finalize Method

Release the write lock, if needed.

protected override void Finalize();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


Flush Method

Apache Lucene.Net 2.4.0 Class Library API

IndexWriter.Flush Method

Overload List

public void Flush();

public void Flush(bool,bool,bool);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.Flush Method ()

public void Flush();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.Flush Overload List


IndexWriter.Flush Method (Boolean, Boolean, Boolean)

public void Flush(
bool triggerMerge,
bool flushDocStores,
bool flushDeletes
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.Flush Overload List


IndexWriter.GetAnalyzer Method

Returns the analyzer used by this index.

public virtual Analyzer GetAnalyzer();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetBufferedDeleteTermsSize Method

public int GetBufferedDeleteTermsSize();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetDefaultInfoStream Method

Returns the current default infoStream for newly instantiated IndexWriters.

public static TextWriter GetDefaultInfoStream();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setDefaultInfoStream


IndexWriter.GetDefaultWriteLockTimeout Method

Returns default write lock timeout for newly instantiated IndexWriters.

public static long GetDefaultWriteLockTimeout();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setDefaultWriteLockTimeout


IndexWriter.GetDirectory Method

Returns the Directory used by this index.

public virtual Directory GetDirectory();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetDocCount Method

public int GetDocCount(
int i
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetFlushCount Method

public int GetFlushCount();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetFlushDeletesCount Method

public int GetFlushDeletesCount();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetInfoStream Method

Returns the current infoStream in use by this writer.

public virtual TextWriter GetInfoStream();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setInfoStream


IndexWriter.GetMaxBufferedDeleteTerms Method

Returns the number of buffered deleted terms that will trigger a flush if enabled.

public virtual int GetMaxBufferedDeleteTerms();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setMaxBufferedDeleteTerms


IndexWriter.GetMaxBufferedDocs Method

Returns the number of buffered added documents that will trigger a flush if enabled.

public virtual int GetMaxBufferedDocs();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setMaxBufferedDocs


IndexWriter.GetMaxFieldLength Method

Returns the maximum number of terms that will be indexed for a single field in a document.

public virtual int GetMaxFieldLength();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setMaxFieldLength


IndexWriter.GetMaxMergeDocs Method

Returns the largest segment (measured by document count) that may be merged with other segments.

Note that this method is a convenience method: it just calls mergePolicy.GetMaxMergeDocs as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.

public virtual int GetMaxMergeDocs();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setMaxMergeDocs


IndexWriter.GetMaxSyncPauseSeconds Method

NOTE: This method is now obsolete.

This will be removed in 3.0, when autoCommit=true is removed from IndexWriter.

Expert: returns max delay inserted before syncing a commit point. On Windows, at least, pausing before syncing can increase net indexing throughput. The delay is variable based on size of the segment's files, and is only inserted when using ConcurrentMergeScheduler for merges.

public double GetMaxSyncPauseSeconds();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetMergeFactor Method

Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.

Note that this method is a convenience method: it just calls mergePolicy.GetMergeFactor as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.

public virtual int GetMergeFactor();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setMergeFactor


IndexWriter.GetMergePolicy Method

Expert: returns the current MergePolicy in use by this writer.

public virtual MergePolicy GetMergePolicy();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setMergePolicy


IndexWriter.GetMergeScheduler Method

Expert: returns the current MergePolicy in use by this writer.

public virtual MergeScheduler GetMergeScheduler();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setMergePolicy


IndexWriter.GetNextMerge Method

Expert: the {@link MergeScheduler} calls this method to retrieve the next merge requested by the MergePolicy

public virtual OneMerge GetNextMerge();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetNumBufferedDeleteTerms Method

public int GetNumBufferedDeleteTerms();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetNumBufferedDocuments Method

public int GetNumBufferedDocuments();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetRAMBufferSizeMB Method

Returns the value set by {@link #setRAMBufferSizeMB} if enabled.

public virtual double GetRAMBufferSizeMB();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetSegmentCount Method

public int GetSegmentCount();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetSimilarity Method

public virtual Similarity GetSimilarity();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.GetTermIndexInterval Method

Expert: Return the interval between indexed terms.

public virtual int GetTermIndexInterval();

See Also

IndexWriter Class | Lucene.Net.Index Namespace |


IndexWriter.GetUseCompoundFile Method

Get the current setting of whether newly flushed segments will use the compound file format. Note that this just returns the value previously set with setUseCompoundFile(bool), or the default value (true). You cannot use this to query the status of previously flushed segments.

Note that this method is a convenience method: it just calls mergePolicy.GetUseCompoundFile as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.

public virtual bool GetUseCompoundFile();

See Also

IndexWriter Class | Lucene.Net.Index Namespace |


IndexWriter.GetWriteLockTimeout Method

Returns allowed timeout when acquiring the write lock.

public virtual long GetWriteLockTimeout();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setWriteLockTimeout


IndexWriter.HasDeletions Method

public bool HasDeletions();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IsLocked Method

Apache Lucene.Net 2.4.0 Class Library API

IndexWriter.IsLocked Method

Overload List

public static bool IsLocked(Directory);

public static bool IsLocked(string);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.IsLocked Method (Directory)

public static bool IsLocked(
Directory directory
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.IsLocked Overload List


IndexWriter.IsLocked Method (String)

public static bool IsLocked(
string directory
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.IsLocked Overload List


IndexWriter.MaxDoc Method

Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), without regard for deletions (see NumDocs()).

public int MaxDoc();

Return Value

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.MaybeMerge Method

Expert: asks the mergePolicy whether any merges are necessary now and if so, runs the requested merges and then iterate (test again if merges are needed) until no more merges are returned by the mergePolicy. Explicit calls to MaybeMerge() are usually not necessary. The most common case is when merge policy parameters have changed.

public void MaybeMerge();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.Merge Method

public void Merge(
OneMerge merge
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.Message Method

Prints a message to the infoStream (if non-null), prefixed with the identifying information for this writer and the thread that's calling it.

public virtual void Message(
string message
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.NewestSegment Method

public SegmentInfo NewestSegment();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.NumDocs Method

Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), with regard for deletions. NOTE: Buffered deletions are not excluded. If these need to be excluded, call Commit() first.

public int NumDocs();

Return Value

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.NumRamDocs Method

public int NumRamDocs();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


Optimize Method

Apache Lucene.Net 2.4.0 Class Library API

IndexWriter.Optimize Method

Overload List

public virtual void Optimize();

Just like {@link #Optimize()}, except you can specify whether the call should block until the optimize completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

public virtual void Optimize(bool);

public virtual void Optimize(int);

Just like {@link #Optimize(int)}, except you can specify whether the call should block until the optimize completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

public virtual void Optimize(int,bool);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.Optimize Method ()

public virtual void Optimize();

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.Optimize Overload List


IndexWriter.Optimize Method (Boolean)

Just like {@link #Optimize()}, except you can specify whether the call should block until the optimize completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

public virtual void Optimize(
bool doWait
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.Optimize Overload List


IndexWriter.Optimize Method (Int32)

public virtual void Optimize(
int maxNumSegments
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.Optimize Overload List


IndexWriter.Optimize Method (Int32, Boolean)

Just like {@link #Optimize(int)}, except you can specify whether the call should block until the optimize completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

public virtual void Optimize(
int maxNumSegments,
bool doWait
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.Optimize Overload List


IndexWriter.PrepareCommit Method

public void PrepareCommit();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.RamSizeInBytes Method

public long RamSizeInBytes();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.Rollback Method

Close the

IndexWriter
without committing any of the changes that have occurred since it was opened. This removes any temporary files that had been created, after which the state of the index will be the same as it was when this writer was first opened. This can only be called when this IndexWriter was opened with
autoCommit=false
. This also clears a previous call to PrepareCommit().

public virtual void Rollback();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SegString Method

public string SegString();

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SetDefaultInfoStream Method

If non-null, this will be the default infoStream used by a newly instantiated IndexWriter.

public static void SetDefaultInfoStream(
TextWriter infoStream
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setInfoStream


IndexWriter.SetDefaultWriteLockTimeout Method

Sets the default (for any instance of IndexWriter) maximum time to wait for a write lock (in milliseconds).

public static void SetDefaultWriteLockTimeout(
long writeLockTimeout
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SetInfoStream Method

If non-null, information about merges, deletes and a message when maxFieldLength is reached will be printed to this.

public virtual void SetInfoStream(
TextWriter infoStream
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SetMaxBufferedDeleteTerms Method

Determines the minimal number of delete terms required before the buffered in-memory delete terms are applied and flushed. If there are documents buffered in memory at the time, they are merged and a new segment is created.

Disabled by default (writer flushes by RAM usage).

public virtual void SetMaxBufferedDeleteTerms(
int maxBufferedDeleteTerms
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setRAMBufferSizeMB


IndexWriter.SetMaxBufferedDocs Method

Determines the minimal number of documents required before the buffered in-memory documents are flushed as a new Segment. Large values generally gives faster indexing.

When this is set, the writer will flush every maxBufferedDocs added documents. Pass in {@link #DISABLE_AUTO_FLUSH} to prevent triggering a flush due to number of buffered documents. Note that if flushing by RAM usage is also enabled, then the flush will be triggered by whichever comes first.

Disabled by default (writer flushes by RAM usage).

public virtual void SetMaxBufferedDocs(
int maxBufferedDocs
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | setRAMBufferSizeMB


IndexWriter.SetMaxFieldLength Method

The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. This setting refers to the number of running terms, not to the number of different terms.

Note: this silently truncates large documents, excluding from the index all terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an System.OutOfMemoryException.

By default, no more than DEFAULT_MAX_FIELD_LENGTH terms will be indexed for a field.
public virtual void SetMaxFieldLength(
int maxFieldLength
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SetMaxMergeDocs Method

Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

The default value is {@link Integer#MAX_VALUE}.

Note that this method is a convenience method: it just calls mergePolicy.SetMaxMergeDocs as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.

The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.

public virtual void SetMaxMergeDocs(
int maxMergeDocs
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SetMaxSyncPauseSeconds Method

NOTE: This method is now obsolete.

This will be removed in 3.0, when autoCommit=true is removed from IndexWriter.

Expert: sets the max delay before syncing a commit point.

public void SetMaxSyncPauseSeconds(
double seconds
);

Parameters

seconds

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SetMergeFactor Method

public virtual void SetMergeFactor(
int mergeFactor
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SetMergePolicy Method

Expert: set the merge policy used by this writer.

public virtual void SetMergePolicy(
MergePolicy mp
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SetMergeScheduler Method

Expert: set the merge scheduler used by this writer.

public virtual void SetMergeScheduler(
MergeScheduler mergeScheduler
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SetRAMBufferSizeMB Method

Determines the amount of RAM that may be used for buffering added documents before they are flushed as a new Segment. Generally for faster indexing performance it's best to flush by RAM usage instead of document count and use as large a RAM buffer as you can.

When this is set, the writer will flush whenever buffered documents use this much RAM. Pass in {@link #DISABLE_AUTO_FLUSH} to prevent triggering a flush due to RAM usage. Note that if flushing by document count is also enabled, then the flush will be triggered by whichever comes first.

The default value is {@link #DEFAULT_RAM_BUFFER_SIZE_MB}.

public virtual void SetRAMBufferSizeMB(
double mb
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SetSimilarity Method

Expert: Set the Similarity implementation used by this IndexWriter.

public virtual void SetSimilarity(
Similarity similarity
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace |


IndexWriter.SetTermIndexInterval Method

Expert: Set the interval between indexed terms. Large values cause less memory to be used by IndexReader, but slow random-access to terms. Small values cause more memory to be used by an IndexReader, and speed random-access to terms. This parameter determines the amount of computation required per query term, regardless of the number of documents that contain that term. In particular, it is the maximum number of other terms that must be scanned before a term is located and its frequency and position information may be processed. In a large index with user-entered query terms, query processing time is likely to be dominated not by term lookup but rather by the processing of frequency and positional data. In a small index or when many uncommon query terms are generated (e.g., by wildcard queries) term lookup may become a dominant cost. In particular,

numUniqueTerms/interval
terms are read into memory by an IndexReader, and, on average,
interval/2
terms must be scanned for each random term access.

public virtual void SetTermIndexInterval(
int interval
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace |


IndexWriter.SetUseCompoundFile Method

Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file when a new segment is flushed.

Note that this method is a convenience method: it just calls mergePolicy.SetUseCompoundFile as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an System.ArgumentException is thrown.

public virtual void SetUseCompoundFile(
bool value_Renamed
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.SetWriteLockTimeout Method

public virtual void SetWriteLockTimeout(
long writeLockTimeout
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace | |


IndexWriter.TestPoint Method

protected internal virtual bool TestPoint(
string name
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.Unlock Method

public static void Unlock(
Directory directory
);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


UpdateDocument Method

Apache Lucene.Net 2.4.0 Class Library API

IndexWriter.UpdateDocument Method

Updates a document by first deleting the document(s) containing

term
and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

Overload List

Updates a document by first deleting the document(s) containing

term
and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

public virtual void UpdateDocument(Term,Document);

Updates a document by first deleting the document(s) containing

term
and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

public virtual void UpdateDocument(Term,Document,Analyzer);

See Also

IndexWriter Class | Lucene.Net.Index Namespace


IndexWriter.UpdateDocument Method (Term, Document)

Updates a document by first deleting the document(s) containing

term
and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

public virtual void UpdateDocument(
Term term,
Document doc
);

Parameters

term
the term to identify the document(s) to be deleted
doc
the document to be added

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.UpdateDocument Overload List


IndexWriter.UpdateDocument Method (Term, Document, Analyzer)

Updates a document by first deleting the document(s) containing

term
and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

public virtual void UpdateDocument(
Term term,
Document doc,
Analyzer analyzer
);

Parameters

term
the term to identify the document(s) to be deleted
doc
the document to be added
analyzer
the analyzer to use when analyzing the document

See Also

IndexWriter Class | Lucene.Net.Index Namespace | IndexWriter.UpdateDocument Overload List


IndexWriter.MaxFieldLength Class

For a list of all members of this type, see IndexWriter.MaxFieldLength Members.

System.Object
Lucene.Net.Index.IndexWriter.MaxFieldLength

public sealed class IndexWriter.MaxFieldLength

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexWriter.MaxFieldLength Members | Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength Members

IndexWriter.MaxFieldLength overview

Public Static Fields

LIMITED
UNLIMITED

Public Instance Constructors

IndexWriter.MaxFieldLength Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLimit |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

IndexWriter.MaxFieldLength Class | Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength Constructor

public IndexWriter.MaxFieldLength(
int limit
);

See Also

IndexWriter.MaxFieldLength Class | Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength Fields

The fields of the IndexWriter.MaxFieldLength class are listed below. For a complete list of IndexWriter.MaxFieldLength class members, see the IndexWriter.MaxFieldLength Members topic.

Public Static Fields

LIMITED
UNLIMITED

See Also

IndexWriter.MaxFieldLength Class | Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength.LIMITED Field

public static readonly MaxFieldLength LIMITED;

See Also

IndexWriter.MaxFieldLength Class | Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength.UNLIMITED Field

public static readonly MaxFieldLength UNLIMITED;

See Also

IndexWriter.MaxFieldLength Class | Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength Methods

The methods of the IndexWriter.MaxFieldLength class are listed below. For a complete list of IndexWriter.MaxFieldLength class members, see the IndexWriter.MaxFieldLength Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLimit |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

IndexWriter.MaxFieldLength Class | Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength.GetLimit Method

public int GetLimit();

See Also

IndexWriter.MaxFieldLength Class | Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength.ToString Method

public override string ToString();

See Also

IndexWriter.MaxFieldLength Class | Lucene.Net.Index Namespace


KeepOnlyLastCommitDeletionPolicy Class

This {@link IndexDeletionPolicy} implementation that keeps only the most recent commit and immediately removes all prior commits after a new commit is done. This is the default deletion policy.

For a list of all members of this type, see KeepOnlyLastCommitDeletionPolicy Members.

System.Object
Lucene.Net.Index.KeepOnlyLastCommitDeletionPolicy

public sealed class KeepOnlyLastCommitDeletionPolicy : IndexDeletionPolicy

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

KeepOnlyLastCommitDeletionPolicy Members | Lucene.Net.Index Namespace


KeepOnlyLastCommitDeletionPolicy Members

KeepOnlyLastCommitDeletionPolicy overview

Public Instance Constructors

KeepOnlyLastCommitDeletionPolicy Constructor Initializes a new instance of the KeepOnlyLastCommitDeletionPolicy class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnCommit |
OnInit |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

KeepOnlyLastCommitDeletionPolicy Class | Lucene.Net.Index Namespace


KeepOnlyLastCommitDeletionPolicy Constructor

Initializes a new instance of the KeepOnlyLastCommitDeletionPolicy class.

public KeepOnlyLastCommitDeletionPolicy();

See Also

KeepOnlyLastCommitDeletionPolicy Class | Lucene.Net.Index Namespace


KeepOnlyLastCommitDeletionPolicy Methods

The methods of the KeepOnlyLastCommitDeletionPolicy class are listed below. For a complete list of KeepOnlyLastCommitDeletionPolicy class members, see the KeepOnlyLastCommitDeletionPolicy Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnCommit |
OnInit |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

KeepOnlyLastCommitDeletionPolicy Class | Lucene.Net.Index Namespace


KeepOnlyLastCommitDeletionPolicy.OnCommit Method

public void OnCommit(
2, Culture=neutral, PublicKeyToken=null]] commits
);

Implements

IndexDeletionPolicy.OnCommit

See Also

KeepOnlyLastCommitDeletionPolicy Class | Lucene.Net.Index Namespace


KeepOnlyLastCommitDeletionPolicy.OnInit Method

public void OnInit(
2, Culture=neutral, PublicKeyToken=null]] commits
);

Implements

IndexDeletionPolicy.OnInit

See Also

KeepOnlyLastCommitDeletionPolicy Class | Lucene.Net.Index Namespace


LogByteSizeMergePolicy Class

This is a {@link LogMergePolicy} that measures size of a segment as the total byte size of the segment's files.

For a list of all members of this type, see LogByteSizeMergePolicy Members.

System.Object
Lucene.Net.Index.MergePolicy
Lucene.Net.Index.LogMergePolicy
Lucene.Net.Index.LogByteSizeMergePolicy

public class LogByteSizeMergePolicy : LogMergePolicy

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LogByteSizeMergePolicy Members | Lucene.Net.Index Namespace


LogByteSizeMergePolicy Members

LogByteSizeMergePolicy overview

Public Static Fields

DEFAULT_MAX_MERGE_MB | Default maximum segment size. A segment of this size
DEFAULT_MIN_MERGE_MB |

Public Instance Constructors

LogByteSizeMergePolicy Constructor Initializes a new instance of the LogByteSizeMergePolicy class.

Public Instance Methods

Close (inherited from LogMergePolicy) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindMerges (inherited from LogMergePolicy) | Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency.
FindMergesForOptimize (inherited from LogMergePolicy) |
FindMergesToExpungeDeletes (inherited from LogMergePolicy) | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxMergeDocs (inherited from LogMergePolicy) | Returns the largest segment (measured by document count) that may be merged with other segments.
GetMaxMergeMB | Returns the largest segment (meaured by total byte size of the segment's files, in MB) that may be merged with other segments.
GetMergeFactor (inherited from LogMergePolicy) | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.
GetMinMergeMB | Get the minimum size for a segment to remain un-merged.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundDocStore (inherited from LogMergePolicy) | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)
GetUseCompoundFile (inherited from LogMergePolicy) | Returns true if newly flushed and newly merge segments
SetMaxMergeDocs (inherited from LogMergePolicy) | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.
SetMaxMergeMB | Determines the largest segment (measured by total byte size of the segment's files, in MB) that may be merged with other segments. Small values (e.g., less than 50 MB) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. Note that {@link #setMaxMergeDocs} is also used to check whether a segment is too large for merging (it's either or).
SetMergeFactor (inherited from LogMergePolicy) |
SetMinMergeMB | Sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).
SetUseCompoundDocStore (inherited from LogMergePolicy) | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).
SetUseCompoundFile (inherited from LogMergePolicy) | Sets whether compound file format should be used for newly flushed and newly merged segments.
ToString (inherited from Object) | Returns a String that represents the current Object.
UseCompoundDocStore (inherited from LogMergePolicy) |
UseCompoundFile (inherited from LogMergePolicy) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Size

See Also

LogByteSizeMergePolicy Class | Lucene.Net.Index Namespace


LogByteSizeMergePolicy Constructor

Initializes a new instance of the LogByteSizeMergePolicy class.

public LogByteSizeMergePolicy();

See Also

LogByteSizeMergePolicy Class | Lucene.Net.Index Namespace


LogByteSizeMergePolicy Fields

The fields of the LogByteSizeMergePolicy class are listed below. For a complete list of LogByteSizeMergePolicy class members, see the LogByteSizeMergePolicy Members topic.

Public Static Fields

DEFAULT_MAX_MERGE_MB | Default maximum segment size. A segment of this size
DEFAULT_MIN_MERGE_MB |

See Also

LogByteSizeMergePolicy Class | Lucene.Net.Index Namespace


LogByteSizeMergePolicy.DEFAULT_MAX_MERGE_MB Field

Default maximum segment size. A segment of this size

public static readonly double DEFAULT_MAX_MERGE_MB;

See Also

LogByteSizeMergePolicy Class | Lucene.Net.Index Namespace |


LogByteSizeMergePolicy.DEFAULT_MIN_MERGE_MB Field

public const double DEFAULT_MIN_MERGE_MB = 1.6;

See Also

LogByteSizeMergePolicy Class | Lucene.Net.Index Namespace | setMinMergeMB


LogByteSizeMergePolicy Methods

The methods of the LogByteSizeMergePolicy class are listed below. For a complete list of LogByteSizeMergePolicy class members, see the LogByteSizeMergePolicy Members topic.

Public Instance Methods

Close (inherited from LogMergePolicy) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindMerges (inherited from LogMergePolicy) | Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency.
FindMergesForOptimize (inherited from LogMergePolicy) |
FindMergesToExpungeDeletes (inherited from LogMergePolicy) | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxMergeDocs (inherited from LogMergePolicy) | Returns the largest segment (measured by document count) that may be merged with other segments.
GetMaxMergeMB | Returns the largest segment (meaured by total byte size of the segment's files, in MB) that may be merged with other segments.
GetMergeFactor (inherited from LogMergePolicy) | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.
GetMinMergeMB | Get the minimum size for a segment to remain un-merged.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundDocStore (inherited from LogMergePolicy) | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)
GetUseCompoundFile (inherited from LogMergePolicy) | Returns true if newly flushed and newly merge segments
SetMaxMergeDocs (inherited from LogMergePolicy) | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.
SetMaxMergeMB | Determines the largest segment (measured by total byte size of the segment's files, in MB) that may be merged with other segments. Small values (e.g., less than 50 MB) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. Note that {@link #setMaxMergeDocs} is also used to check whether a segment is too large for merging (it's either or).
SetMergeFactor (inherited from LogMergePolicy) |
SetMinMergeMB | Sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).
SetUseCompoundDocStore (inherited from LogMergePolicy) | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).
SetUseCompoundFile (inherited from LogMergePolicy) | Sets whether compound file format should be used for newly flushed and newly merged segments.
ToString (inherited from Object) | Returns a String that represents the current Object.
UseCompoundDocStore (inherited from LogMergePolicy) |
UseCompoundFile (inherited from LogMergePolicy) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Size

See Also

LogByteSizeMergePolicy Class | Lucene.Net.Index Namespace


LogByteSizeMergePolicy.GetMaxMergeMB Method

Returns the largest segment (meaured by total byte size of the segment's files, in MB) that may be merged with other segments.

public virtual double GetMaxMergeMB();

See Also

LogByteSizeMergePolicy Class | Lucene.Net.Index Namespace | setMaxMergeMB


LogByteSizeMergePolicy.GetMinMergeMB Method

Get the minimum size for a segment to remain un-merged.

public virtual double GetMinMergeMB();

See Also

LogByteSizeMergePolicy Class | Lucene.Net.Index Namespace | setMinMergeMB *


LogByteSizeMergePolicy.SetMaxMergeMB Method

Determines the largest segment (measured by total byte size of the segment's files, in MB) that may be merged with other segments. Small values (e.g., less than 50 MB) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

Note that {@link #setMaxMergeDocs} is also used to check whether a segment is too large for merging (it's either or).

public virtual void SetMaxMergeMB(
double mb
);

See Also

LogByteSizeMergePolicy Class | Lucene.Net.Index Namespace


LogByteSizeMergePolicy.SetMinMergeMB Method

Sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).

public virtual void SetMinMergeMB(
double mb
);

See Also

LogByteSizeMergePolicy Class | Lucene.Net.Index Namespace


LogByteSizeMergePolicy.Size Method

protected internal override long Size(
SegmentInfo info
);

See Also

LogByteSizeMergePolicy Class | Lucene.Net.Index Namespace


LogDocMergePolicy Class

This is a {@link LogMergePolicy} that measures size of a segment as the number of documents (not taking deletions into account).

For a list of all members of this type, see LogDocMergePolicy Members.

System.Object
Lucene.Net.Index.MergePolicy
Lucene.Net.Index.LogMergePolicy
Lucene.Net.Index.LogDocMergePolicy

public class LogDocMergePolicy : LogMergePolicy

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LogDocMergePolicy Members | Lucene.Net.Index Namespace


LogDocMergePolicy Members

LogDocMergePolicy overview

Public Static Fields

DEFAULT_MIN_MERGE_DOCS

Public Instance Constructors

LogDocMergePolicy Constructor Initializes a new instance of the LogDocMergePolicy class.

Public Instance Methods

Close (inherited from LogMergePolicy) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindMerges (inherited from LogMergePolicy) | Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency.
FindMergesForOptimize (inherited from LogMergePolicy) |
FindMergesToExpungeDeletes (inherited from LogMergePolicy) | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxMergeDocs (inherited from LogMergePolicy) | Returns the largest segment (measured by document count) that may be merged with other segments.
GetMergeFactor (inherited from LogMergePolicy) | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.
GetMinMergeDocs | Get the minimum size for a segment to remain un-merged.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundDocStore (inherited from LogMergePolicy) | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)
GetUseCompoundFile (inherited from LogMergePolicy) | Returns true if newly flushed and newly merge segments
SetMaxMergeDocs (inherited from LogMergePolicy) | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.
SetMergeFactor (inherited from LogMergePolicy) |
SetMinMergeDocs | Sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).
SetUseCompoundDocStore (inherited from LogMergePolicy) | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).
SetUseCompoundFile (inherited from LogMergePolicy) | Sets whether compound file format should be used for newly flushed and newly merged segments.
ToString (inherited from Object) | Returns a String that represents the current Object.
UseCompoundDocStore (inherited from LogMergePolicy) |
UseCompoundFile (inherited from LogMergePolicy) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Size

See Also

LogDocMergePolicy Class | Lucene.Net.Index Namespace


LogDocMergePolicy Constructor

Initializes a new instance of the LogDocMergePolicy class.

public LogDocMergePolicy();

See Also

LogDocMergePolicy Class | Lucene.Net.Index Namespace


LogDocMergePolicy Fields

The fields of the LogDocMergePolicy class are listed below. For a complete list of LogDocMergePolicy class members, see the LogDocMergePolicy Members topic.

Public Static Fields

DEFAULT_MIN_MERGE_DOCS

See Also

LogDocMergePolicy Class | Lucene.Net.Index Namespace


LogDocMergePolicy.DEFAULT_MIN_MERGE_DOCS Field

public const int DEFAULT_MIN_MERGE_DOCS = 1000;

See Also

LogDocMergePolicy Class | Lucene.Net.Index Namespace | setMinMergeDocs


LogDocMergePolicy Methods

The methods of the LogDocMergePolicy class are listed below. For a complete list of LogDocMergePolicy class members, see the LogDocMergePolicy Members topic.

Public Instance Methods

Close (inherited from LogMergePolicy) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindMerges (inherited from LogMergePolicy) | Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency.
FindMergesForOptimize (inherited from LogMergePolicy) |
FindMergesToExpungeDeletes (inherited from LogMergePolicy) | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxMergeDocs (inherited from LogMergePolicy) | Returns the largest segment (measured by document count) that may be merged with other segments.
GetMergeFactor (inherited from LogMergePolicy) | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.
GetMinMergeDocs | Get the minimum size for a segment to remain un-merged.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundDocStore (inherited from LogMergePolicy) | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)
GetUseCompoundFile (inherited from LogMergePolicy) | Returns true if newly flushed and newly merge segments
SetMaxMergeDocs (inherited from LogMergePolicy) | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.
SetMergeFactor (inherited from LogMergePolicy) |
SetMinMergeDocs | Sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).
SetUseCompoundDocStore (inherited from LogMergePolicy) | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).
SetUseCompoundFile (inherited from LogMergePolicy) | Sets whether compound file format should be used for newly flushed and newly merged segments.
ToString (inherited from Object) | Returns a String that represents the current Object.
UseCompoundDocStore (inherited from LogMergePolicy) |
UseCompoundFile (inherited from LogMergePolicy) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Size

See Also

LogDocMergePolicy Class | Lucene.Net.Index Namespace


LogDocMergePolicy.GetMinMergeDocs Method

Get the minimum size for a segment to remain un-merged.

public virtual int GetMinMergeDocs();

See Also

LogDocMergePolicy Class | Lucene.Net.Index Namespace | setMinMergeDocs *


LogDocMergePolicy.SetMinMergeDocs Method

Sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).

public virtual void SetMinMergeDocs(
int minMergeDocs
);

See Also

LogDocMergePolicy Class | Lucene.Net.Index Namespace


LogDocMergePolicy.Size Method

protected internal override long Size(
SegmentInfo info
);

See Also

LogDocMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy Class

For a list of all members of this type, see LogMergePolicy Members.

System.Object
Lucene.Net.Index.MergePolicy
Lucene.Net.Index.LogMergePolicy
Lucene.Net.Index.LogByteSizeMergePolicy
Lucene.Net.Index.LogDocMergePolicy

public abstract class LogMergePolicy : MergePolicy

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LogMergePolicy Members | Lucene.Net.Index Namespace


LogMergePolicy Members

LogMergePolicy overview

Public Static Fields

DEFAULT_MAX_MERGE_DOCS | Default maximum segment size. A segment of this size
DEFAULT_MERGE_FACTOR | Default merge factor, which is how many segments are merged at a time
LEVEL_LOG_SPAN | Defines the allowed range of log(size) for each level. A level is computed by taking the max segment log size, minuse LEVEL_LOG_SPAN, and finding all segments falling within that range.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindMerges | Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency.
FindMergesForOptimize |
FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxMergeDocs | Returns the largest segment (measured by document count) that may be merged with other segments.
GetMergeFactor | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)
GetUseCompoundFile | Returns true if newly flushed and newly merge segments
SetMaxMergeDocs | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.
SetMergeFactor |
SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).
SetUseCompoundFile | Sets whether compound file format should be used for newly flushed and newly merged segments.
ToString (inherited from Object) | Returns a String that represents the current Object.
UseCompoundDocStore |
UseCompoundFile |

Protected Instance Constructors

LogMergePolicy Constructor Initializes a new instance of the LogMergePolicy class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Size

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy Constructor

Initializes a new instance of the LogMergePolicy class.

protected LogMergePolicy();

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy Fields

The fields of the LogMergePolicy class are listed below. For a complete list of LogMergePolicy class members, see the LogMergePolicy Members topic.

Public Static Fields

DEFAULT_MAX_MERGE_DOCS | Default maximum segment size. A segment of this size
DEFAULT_MERGE_FACTOR | Default merge factor, which is how many segments are merged at a time
LEVEL_LOG_SPAN | Defines the allowed range of log(size) for each level. A level is computed by taking the max segment log size, minuse LEVEL_LOG_SPAN, and finding all segments falling within that range.

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.DEFAULT_MAX_MERGE_DOCS Field

Default maximum segment size. A segment of this size

public static readonly int DEFAULT_MAX_MERGE_DOCS;

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace | setMaxMergeDocs


LogMergePolicy.DEFAULT_MERGE_FACTOR Field

Default merge factor, which is how many segments are merged at a time

public const int DEFAULT_MERGE_FACTOR = 10;

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.LEVEL_LOG_SPAN Field

Defines the allowed range of log(size) for each level. A level is computed by taking the max segment log size, minuse LEVEL_LOG_SPAN, and finding all segments falling within that range.

public const double LEVEL_LOG_SPAN = 0.75;

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy Methods

The methods of the LogMergePolicy class are listed below. For a complete list of LogMergePolicy class members, see the LogMergePolicy Members topic.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindMerges | Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency.
FindMergesForOptimize |
FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxMergeDocs | Returns the largest segment (measured by document count) that may be merged with other segments.
GetMergeFactor | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)
GetUseCompoundFile | Returns true if newly flushed and newly merge segments
SetMaxMergeDocs | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.
SetMergeFactor |
SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).
SetUseCompoundFile | Sets whether compound file format should be used for newly flushed and newly merged segments.
ToString (inherited from Object) | Returns a String that represents the current Object.
UseCompoundDocStore |
UseCompoundFile |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Size

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.Close Method

public override void Close();

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.FindMerges Method

Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency.

public override MergeSpecification FindMerges(
SegmentInfos infos,
IndexWriter writer
);

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.FindMergesForOptimize Method

public override MergeSpecification FindMergesForOptimize(
SegmentInfos infos,
IndexWriter writer,
int maxNumSegments,
2, Culture=neutral, PublicKeyToken=null]] segmentsToOptimize
);

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.FindMergesToExpungeDeletes Method

Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time.

public override MergeSpecification FindMergesToExpungeDeletes(
SegmentInfos segmentInfos,
IndexWriter writer
);

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.GetMaxMergeDocs Method

Returns the largest segment (measured by document count) that may be merged with other segments.

public virtual int GetMaxMergeDocs();

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace | setMaxMergeDocs


LogMergePolicy.GetMergeFactor Method

Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.

public virtual int GetMergeFactor();

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.GetUseCompoundDocStore Method

Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)

public virtual bool GetUseCompoundDocStore();

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace |


LogMergePolicy.GetUseCompoundFile Method

Returns true if newly flushed and newly merge segments

public virtual bool GetUseCompoundFile();

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace |


LogMergePolicy.SetMaxMergeDocs Method

Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

The default value is {@link Integer#MAX_VALUE}.

The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.

public virtual void SetMaxMergeDocs(
int maxMergeDocs
);

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.SetMergeFactor Method

public virtual void SetMergeFactor(
int mergeFactor
);

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.SetUseCompoundDocStore Method

Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).

public virtual void SetUseCompoundDocStore(
bool useCompoundDocStore
);

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.SetUseCompoundFile Method

Sets whether compound file format should be used for newly flushed and newly merged segments.

public virtual void SetUseCompoundFile(
bool useCompoundFile
);

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.Size Method

protected internal abstract long Size(
SegmentInfo info
);

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.UseCompoundDocStore Method

public override bool UseCompoundDocStore(
SegmentInfos infos
);

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


LogMergePolicy.UseCompoundFile Method

public override bool UseCompoundFile(
SegmentInfos infos,
SegmentInfo info
);

See Also

LogMergePolicy Class | Lucene.Net.Index Namespace


MergePolicy Class

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by {@link IndexWriter}, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, {@link IndexWriter} invokes {@link #findMerges} to give the MergePolicy a chance to pick merges that are now required. This method returns a {@link MergeSpecification} instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls {@link #findMergesForOptimize} and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using {@link SerialMergeScheduler}, the merges will be run sequentially but if it is using {@link ConcurrentMergeScheduler} they will be run concurrently.

The default MergePolicy is {@link LogByteSizeMergePolicy}.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

For a list of all members of this type, see MergePolicy Members.

System.Object
Lucene.Net.Index.MergePolicy
Lucene.Net.Index.LogMergePolicy

public abstract class MergePolicy

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MergePolicy Members | Lucene.Net.Index Namespace


MergePolicy Members

MergePolicy overview

Public Instance Methods

Close | Release all resources for the policy.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindMerges | Determine what set of merge operations are now necessary on the index. The IndexWriter calls this whenever there is a change to the segments. This call is always synchronized on the IndexWriter instance so only one thread at a time will call this method.
FindMergesForOptimize |
FindMergesToExpungeDeletes | Determine what set of merge operations is necessary in order to expunge all deletes from the index.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UseCompoundDocStore | Returns true if the doc store files should use the compound file format.
UseCompoundFile | Returns true if a newly flushed (not from merge) segment should use the compound file format.

Protected Instance Constructors

MergePolicy Constructor Initializes a new instance of the MergePolicy class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergePolicy Class | Lucene.Net.Index Namespace


MergePolicy Constructor

Initializes a new instance of the MergePolicy class.

protected MergePolicy();

See Also

MergePolicy Class | Lucene.Net.Index Namespace


MergePolicy Methods

The methods of the MergePolicy class are listed below. For a complete list of MergePolicy class members, see the MergePolicy Members topic.

Public Instance Methods

Close | Release all resources for the policy.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindMerges | Determine what set of merge operations are now necessary on the index. The IndexWriter calls this whenever there is a change to the segments. This call is always synchronized on the IndexWriter instance so only one thread at a time will call this method.
FindMergesForOptimize |
FindMergesToExpungeDeletes | Determine what set of merge operations is necessary in order to expunge all deletes from the index.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UseCompoundDocStore | Returns true if the doc store files should use the compound file format.
UseCompoundFile | Returns true if a newly flushed (not from merge) segment should use the compound file format.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergePolicy Class | Lucene.Net.Index Namespace


MergePolicy.Close Method

Release all resources for the policy.

public abstract void Close();

See Also

MergePolicy Class | Lucene.Net.Index Namespace


MergePolicy.FindMerges Method

Determine what set of merge operations are now necessary on the index. The IndexWriter calls this whenever there is a change to the segments. This call is always synchronized on the IndexWriter instance so only one thread at a time will call this method.

public abstract MergeSpecification FindMerges(
SegmentInfos segmentInfos,
IndexWriter writer
);

Parameters

segmentInfos
the total set of segments in the index
writer
IndexWriter instance

See Also

MergePolicy Class | Lucene.Net.Index Namespace


MergePolicy.FindMergesForOptimize Method

public abstract MergeSpecification FindMergesForOptimize(
SegmentInfos segmentInfos,
IndexWriter writer,
int maxSegmentCount,
2, Culture=neutral, PublicKeyToken=null]] segmentsToOptimize
);

See Also

MergePolicy Class | Lucene.Net.Index Namespace


MergePolicy.FindMergesToExpungeDeletes Method

Determine what set of merge operations is necessary in order to expunge all deletes from the index.

public virtual MergeSpecification FindMergesToExpungeDeletes(
SegmentInfos segmentInfos,
IndexWriter writer
);

Parameters

segmentInfos
writer

Return Value

See Also

MergePolicy Class | Lucene.Net.Index Namespace


MergePolicy.UseCompoundDocStore Method

Returns true if the doc store files should use the compound file format.

public abstract bool UseCompoundDocStore(
SegmentInfos segments
);

See Also

MergePolicy Class | Lucene.Net.Index Namespace


MergePolicy.UseCompoundFile Method

Returns true if a newly flushed (not from merge) segment should use the compound file format.

public abstract bool UseCompoundFile(
SegmentInfos segments,
SegmentInfo newSegment
);

See Also

MergePolicy Class | Lucene.Net.Index Namespace


MergePolicy.MergeAbortedException Class

For a list of all members of this type, see MergePolicy.MergeAbortedException Members.

System.Object
System.Exception
System.SystemException
System.IO.IOException
Lucene.Net.Index.MergePolicy.MergeAbortedException

public class MergePolicy.MergeAbortedException : IOException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MergePolicy.MergeAbortedException Members | Lucene.Net.Index Namespace


MergePolicy.MergeAbortedException Members

MergePolicy.MergeAbortedException overview

Public Instance Constructors

MergePolicy.MergeAbortedException Overloaded. Initializes a new instance of the MergePolicy.MergeAbortedException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergePolicy.MergeAbortedException Class | Lucene.Net.Index Namespace


MergePolicy.MergeAbortedException Constructor

Initializes a new instance of the MergePolicy.MergeAbortedException class.

Overload List

Initializes a new instance of the MergePolicy.MergeAbortedException class.

public MergePolicy.MergeAbortedException();

public MergePolicy.MergeAbortedException(string);

See Also

MergePolicy.MergeAbortedException Class | Lucene.Net.Index Namespace


MergePolicy.MergeAbortedException Constructor ()

Initializes a new instance of the MergePolicy.MergeAbortedException class.

public MergePolicy.MergeAbortedException();

See Also

MergePolicy.MergeAbortedException Class | Lucene.Net.Index Namespace | MergePolicy.MergeAbortedException Constructor Overload List


MergePolicy.MergeAbortedException Constructor (String)

public MergePolicy.MergeAbortedException(
string message
);

See Also

MergePolicy.MergeAbortedException Class | Lucene.Net.Index Namespace | MergePolicy.MergeAbortedException Constructor Overload List


MergePolicy.MergeException Class

Exception thrown if there are any problems while executing a merge.

For a list of all members of this type, see MergePolicy.MergeException Members.

System.Object
System.Exception
System.SystemException
Lucene.Net.Index.MergePolicy.MergeException

public class MergePolicy.MergeException : SystemException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MergePolicy.MergeException Members | Lucene.Net.Index Namespace


MergePolicy.MergeException Members

MergePolicy.MergeException overview

Public Instance Constructors

MergePolicy.MergeException Overloaded. Initializes a new instance of the MergePolicy.MergeException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetDirectory | Returns the Directory of the index that hit the exception.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergePolicy.MergeException Class | Lucene.Net.Index Namespace


MergePolicy.MergeException Constructor

NOTE: This constructor is now obsolete.

use MergePolicy.MergeException(string, Directory) instead

Overload List

Obsolete.

public MergePolicy.MergeException(Exception);

public MergePolicy.MergeException(Exception,Directory);

Obsolete.

public MergePolicy.MergeException(string);

public MergePolicy.MergeException(string,Directory);

See Also

MergePolicy.MergeException Class | Lucene.Net.Index Namespace


MergePolicy.MergeException Constructor (String)

NOTE: This constructor is now obsolete.

use MergePolicy.MergeException(string, Directory) instead

public MergePolicy.MergeException(
string message
);

See Also

MergePolicy.MergeException Class | Lucene.Net.Index Namespace | MergePolicy.MergeException Constructor Overload List


MergePolicy.MergeException Constructor (String, Directory)

public MergePolicy.MergeException(
string message,
Directory dir
);

See Also

MergePolicy.MergeException Class | Lucene.Net.Index Namespace | MergePolicy.MergeException Constructor Overload List


MergePolicy.MergeException Constructor (Exception)

NOTE: This constructor is now obsolete.

use MergePolicy.MergeException(System.Exception, Directory) instead

public MergePolicy.MergeException(
Exception exc
);

See Also

MergePolicy.MergeException Class | Lucene.Net.Index Namespace | MergePolicy.MergeException Constructor Overload List


MergePolicy.MergeException Constructor (Exception, Directory)

public MergePolicy.MergeException(
Exception exc,
Directory dir
);

See Also

MergePolicy.MergeException Class | Lucene.Net.Index Namespace | MergePolicy.MergeException Constructor Overload List


MergePolicy.MergeException Methods

The methods of the MergePolicy.MergeException class are listed below. For a complete list of MergePolicy.MergeException class members, see the MergePolicy.MergeException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetDirectory | Returns the Directory of the index that hit the exception.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergePolicy.MergeException Class | Lucene.Net.Index Namespace


MergePolicy.MergeException.GetDirectory Method

Returns the Directory of the index that hit the exception.

public Directory GetDirectory();

Return Value

See Also

MergePolicy.MergeException Class | Lucene.Net.Index Namespace


MergePolicy.MergeSpecification Class

A MergeSpecification instance provides the information necessary to perform multiple merges. It simply contains a list of {@link OneMerge} instances.

For a list of all members of this type, see MergePolicy.MergeSpecification Members.

System.Object
Lucene.Net.Index.MergePolicy.MergeSpecification

public class MergePolicy.MergeSpecification

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MergePolicy.MergeSpecification Members | Lucene.Net.Index Namespace


MergePolicy.MergeSpecification Members

MergePolicy.MergeSpecification overview

Public Instance Constructors

MergePolicy.MergeSpecification Constructor Initializes a new instance of the MergePolicy.MergeSpecification class.

Public Instance Fields

merges The subset of segments to be included in the primitive merge.

Public Instance Methods

Add |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SegString |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergePolicy.MergeSpecification Class | Lucene.Net.Index Namespace


MergePolicy.MergeSpecification Constructor

Initializes a new instance of the MergePolicy.MergeSpecification class.

public MergePolicy.MergeSpecification();

See Also

MergePolicy.MergeSpecification Class | Lucene.Net.Index Namespace


MergePolicy.MergeSpecification Fields

The fields of the MergePolicy.MergeSpecification class are listed below. For a complete list of MergePolicy.MergeSpecification class members, see the MergePolicy.MergeSpecification Members topic.

Public Instance Fields

merges The subset of segments to be included in the primitive merge.

See Also

MergePolicy.MergeSpecification Class | Lucene.Net.Index Namespace


MergePolicy.MergeSpecification.merges Field

The subset of segments to be included in the primitive merge.

public 2, Culture=neutral, PublicKeyToken=null]] merges;

See Also

MergePolicy.MergeSpecification Class | Lucene.Net.Index Namespace


MergePolicy.MergeSpecification Methods

The methods of the MergePolicy.MergeSpecification class are listed below. For a complete list of MergePolicy.MergeSpecification class members, see the MergePolicy.MergeSpecification Members topic.

Public Instance Methods

Add |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SegString |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergePolicy.MergeSpecification Class | Lucene.Net.Index Namespace


MergePolicy.MergeSpecification.Add Method

public virtual void Add(
OneMerge merge
);

See Also

MergePolicy.MergeSpecification Class | Lucene.Net.Index Namespace


MergePolicy.MergeSpecification.SegString Method

public virtual string SegString(
Directory dir
);

See Also

MergePolicy.MergeSpecification Class | Lucene.Net.Index Namespace


MergePolicy.OneMerge Class

OneMerge provides the information necessary to perform an individual primitive merge operation, resulting in a single new segment. The merge spec includes the subset of segments to be merged as well as whether the new segment should use the compound file format.

For a list of all members of this type, see MergePolicy.OneMerge Members.

System.Object
Lucene.Net.Index.MergePolicy.OneMerge

public class MergePolicy.OneMerge

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MergePolicy.OneMerge Members | Lucene.Net.Index Namespace


MergePolicy.OneMerge Members

MergePolicy.OneMerge overview

Public Instance Constructors

MergePolicy.OneMerge Constructor

Public Instance Properties

Segments_ForNUnitTest

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergePolicy.OneMerge Class | Lucene.Net.Index Namespace


MergePolicy.OneMerge Constructor

public MergePolicy.OneMerge(
SegmentInfos segments,
bool useCompoundFile
);

See Also

MergePolicy.OneMerge Class | Lucene.Net.Index Namespace


MergePolicy.OneMerge Properties

The properties of the MergePolicy.OneMerge class are listed below. For a complete list of MergePolicy.OneMerge class members, see the MergePolicy.OneMerge Members topic.

Public Instance Properties

Segments_ForNUnitTest

See Also

MergePolicy.OneMerge Class | Lucene.Net.Index Namespace


Segments_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

MergePolicy.OneMerge.Segments_ForNUnitTest Property

public SegmentInfos Segments_ForNUnitTest {get;}

See Also

MergePolicy.OneMerge Class | Lucene.Net.Index Namespace


MergeScheduler Class

Expert: {@link IndexWriter} uses an instance implementing this interface to execute the merges selected by a {@link MergePolicy}. The default MergeScheduler is {@link ConcurrentMergeScheduler}.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

For a list of all members of this type, see MergeScheduler Members.

System.Object
Lucene.Net.Index.MergeScheduler
Lucene.Net.Index.ConcurrentMergeScheduler
Lucene.Net.Index.SerialMergeScheduler

public abstract class MergeScheduler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MergeScheduler Members | Lucene.Net.Index Namespace


MergeScheduler Members

MergeScheduler overview

Public Instance Methods

Close | Close this MergeScheduler.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Run the merges provided by {@link IndexWriter#GetNextMerge()}.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

MergeScheduler Constructor Initializes a new instance of the MergeScheduler class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergeScheduler Class | Lucene.Net.Index Namespace


MergeScheduler Constructor

Initializes a new instance of the MergeScheduler class.

protected MergeScheduler();

See Also

MergeScheduler Class | Lucene.Net.Index Namespace


MergeScheduler Methods

The methods of the MergeScheduler class are listed below. For a complete list of MergeScheduler class members, see the MergeScheduler Members topic.

Public Instance Methods

Close | Close this MergeScheduler.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Run the merges provided by {@link IndexWriter#GetNextMerge()}.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergeScheduler Class | Lucene.Net.Index Namespace


MergeScheduler.Close Method

Close this MergeScheduler.

public abstract void Close();

See Also

MergeScheduler Class | Lucene.Net.Index Namespace


MergeScheduler.Merge Method

Run the merges provided by {@link IndexWriter#GetNextMerge()}.

public abstract void Merge(
IndexWriter writer
);

See Also

MergeScheduler Class | Lucene.Net.Index Namespace


MultipleTermPositions Class

Describe class

MultipleTermPositions
here.

For a list of all members of this type, see MultipleTermPositions Members.

System.Object
Lucene.Net.Index.MultipleTermPositions

public class MultipleTermPositions : TermPositions, TermDocs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MultipleTermPositions Members | Lucene.Net.Index Namespace


MultipleTermPositions Members

MultipleTermPositions overview

Public Instance Constructors

MultipleTermPositions Constructor Creates a new
MultipleTermPositions
instance.

Public Instance Methods

Close |
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPayload | Not implemented.
GetPayloadLength | Not implemented.
GetType (inherited from Object) | Gets the Type of the current instance.
IsPayloadAvailable |
Next |
NextPosition |
Read | Not implemented.
Seek | Overloaded. Not implemented.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions Constructor

Creates a new

MultipleTermPositions
instance.

public MultipleTermPositions(
IndexReader indexReader,
Term[] terms
);

Exceptions

Exception Type | Condition
 | IOException

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions Methods

The methods of the MultipleTermPositions class are listed below. For a complete list of MultipleTermPositions class members, see the MultipleTermPositions Members topic.

Public Instance Methods

Close |
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPayload | Not implemented.
GetPayloadLength | Not implemented.
GetType (inherited from Object) | Gets the Type of the current instance.
IsPayloadAvailable |
Next |
NextPosition |
Read | Not implemented.
Seek | Overloaded. Not implemented.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions.Close Method

public void Close();

Implements

TermDocs.Close

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions.Doc Method

public int Doc();

Implements

TermDocs.Doc

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions.Freq Method

public int Freq();

Implements

TermDocs.Freq

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions.GetPayload Method

Not implemented.

public virtual byte[] GetPayload(
byte[] data,
int offset
);

Implements

TermPositions.GetPayload

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions.GetPayloadLength Method

Not implemented.

public virtual int GetPayloadLength();

Implements

TermPositions.GetPayloadLength

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions.IsPayloadAvailable Method

public virtual bool IsPayloadAvailable();

Return Value

false

Implements

TermPositions.IsPayloadAvailable

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions.Next Method

public bool Next();

Implements

TermDocs.Next

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions.NextPosition Method

public int NextPosition();

Implements

TermPositions.NextPosition

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions.Read Method

Not implemented.

public virtual int Read(
int[] arg0,
int[] arg1
);

Implements

TermDocs.Read

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


Seek Method

Apache Lucene.Net 2.4.0 Class Library API

MultipleTermPositions.Seek Method

Not implemented.

Overload List

Not implemented.

public virtual void Seek(Term);

Not implemented.

public virtual void Seek(TermEnum);

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultipleTermPositions.Seek Method (Term)

Not implemented.

public virtual void Seek(
Term arg0
);

Implements

TermDocs.Seek

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace | MultipleTermPositions.Seek Overload List


MultipleTermPositions.Seek Method (TermEnum)

Not implemented.

public virtual void Seek(
TermEnum termEnum
);

Implements

TermDocs.Seek

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace | MultipleTermPositions.Seek Overload List


MultipleTermPositions.SkipTo Method

public bool SkipTo(
int target
);

Implements

TermDocs.SkipTo

See Also

MultipleTermPositions Class | Lucene.Net.Index Namespace


MultiReader Class

An IndexReader which reads multiple indexes, appending their content.

For a list of all members of this type, see MultiReader Members.

System.Object
Lucene.Net.Index.IndexReader
Lucene.Net.Index.MultiReader

public class MultiReader : IndexReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MultiReader Members | Lucene.Net.Index Namespace


MultiReader Members

MultiReader overview

Public Instance Constructors

MultiReader Overloaded. Initializes a new instance of the MultiReader class.

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef (inherited from IndexReader) | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
DeleteDocument (inherited from IndexReader) Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments (inherited from IndexReader) Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory (inherited from IndexReader) | Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
DocFreq
Document | Overloaded.
Document (inherited from IndexReader) Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen (inherited from IndexReader)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from IndexReader)
GetFieldNames
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit (inherited from IndexReader) | Expert: Return the IndexCommit that this reader has open. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: This API is new and experimental and may suddenly change.
GetRefCount (inherited from IndexReader)
GetSubReaders
GetTermFreqVector | Overloaded.
GetTermFreqVectors
GetTermInfosIndexDivisor (inherited from IndexReader)
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | Not implemented.
HasDeletions
HasNorms
IncRef (inherited from IndexReader) | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IsCurrent | Checks recursively if all subreaders are up to date.
IsDeleted
IsOptimized
MaxDoc
Norms | Overloaded.
NumDeletedDocs (inherited from IndexReader) | Returns the number of deleted docs.
NumDocs
Reopen
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor (inherited from IndexReader) | For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

hasChanges (inherited from IndexReader)
subReaders

Protected Internal Instance Methods

AcquireWriteLock (inherited from IndexReader) | Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
DoClose |
DoCommit |
DoDelete |
DoSetNorm |
DoUndeleteAll |

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader Constructor

Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.

Note that all subreaders are closed if this Multireader is closed.

Overload List

Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders. Note that all subreaders are closed if this Multireader is closed.

public MultiReader(IndexReader[]);

Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.

public MultiReader(IndexReader[],bool);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader Constructor (IndexReader[])

Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.

Note that all subreaders are closed if this Multireader is closed.

public MultiReader(
IndexReader[] subReaders
);

Parameters

subReaders
set of (sub)readers

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader Constructor Overload List


MultiReader Constructor (IndexReader[], Boolean)

Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.

public MultiReader(
IndexReader[] subReaders,
bool closeSubReaders
);

Parameters

subReaders
set of (sub)readers
closeSubReaders
indicates whether the subreaders should be closed when this MultiReader is closed

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader Constructor Overload List


MultiReader Fields

The fields of the MultiReader class are listed below. For a complete list of MultiReader class members, see the MultiReader Members topic.

Protected Internal Instance Fields

hasChanges (inherited from IndexReader)
subReaders

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.subReaders Field

protected internal IndexReader[] subReaders;

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader Methods

The methods of the MultiReader class are listed below. For a complete list of MultiReader class members, see the MultiReader Members topic.

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef (inherited from IndexReader) | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
DeleteDocument (inherited from IndexReader) Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments (inherited from IndexReader) Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory (inherited from IndexReader) | Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
DocFreq
Document | Overloaded.
Document (inherited from IndexReader) Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen (inherited from IndexReader)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from IndexReader)
GetFieldNames
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit (inherited from IndexReader) | Expert: Return the IndexCommit that this reader has open. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: This API is new and experimental and may suddenly change.
GetRefCount (inherited from IndexReader)
GetSubReaders
GetTermFreqVector | Overloaded.
GetTermFreqVectors
GetTermInfosIndexDivisor (inherited from IndexReader)
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | Not implemented.
HasDeletions
HasNorms
IncRef (inherited from IndexReader) | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IsCurrent | Checks recursively if all subreaders are up to date.
IsDeleted
IsOptimized
MaxDoc
Norms | Overloaded.
NumDeletedDocs (inherited from IndexReader) | Returns the number of deleted docs.
NumDocs
Reopen
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor (inherited from IndexReader) | For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

AcquireWriteLock (inherited from IndexReader) | Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
DoClose |
DoCommit |
DoDelete |
DoSetNorm |
DoUndeleteAll |

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.DocFreq Method

public override int DocFreq(
Term t
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.DoClose Method

protected internal override void DoClose();

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.DoCommit Method

protected internal override void DoCommit();

See Also

MultiReader Class | Lucene.Net.Index Namespace


Document Method

Apache Lucene.Net 2.4.0 Class Library API

MultiReader.Document Method

Overload List

Inherited from IndexReader.

public virtual Document Document(int);

public override Document Document(int,FieldSelector);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.Document Method (Int32, FieldSelector)

public override Document Document(
int n,
FieldSelector fieldSelector
);

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.Document Overload List


MultiReader.DoDelete Method

protected internal override void DoDelete(
int n
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.DoSetNorm Method

protected internal override void DoSetNorm(
int n,
string field,
byte value_Renamed
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.DoUndeleteAll Method

protected internal override void DoUndeleteAll();

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.GetFieldNames Method

public override 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetFieldNames(
FieldOption fieldNames
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.GetSubReaders Method

public virtual IndexReader[] GetSubReaders();

See Also

MultiReader Class | Lucene.Net.Index Namespace


GetTermFreqVector Method

Apache Lucene.Net 2.4.0 Class Library API

MultiReader.GetTermFreqVector Method

Overload List

public override void GetTermFreqVector(int,TermVectorMapper);

public override TermFreqVector GetTermFreqVector(int,string);

public override void GetTermFreqVector(int,string,TermVectorMapper);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.GetTermFreqVector Method (Int32, TermVectorMapper)

public override void GetTermFreqVector(
int docNumber,
TermVectorMapper mapper
);

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.GetTermFreqVector Overload List


MultiReader.GetTermFreqVector Method (Int32, String)

public override TermFreqVector GetTermFreqVector(
int n,
string field
);

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.GetTermFreqVector Overload List


MultiReader.GetTermFreqVector Method (Int32, String, TermVectorMapper)

public override void GetTermFreqVector(
int docNumber,
string field,
TermVectorMapper mapper
);

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.GetTermFreqVector Overload List


MultiReader.GetTermFreqVectors Method

public override TermFreqVector[] GetTermFreqVectors(
int n
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.GetVersion Method

Not implemented.

public override long GetVersion();

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.HasDeletions Method

public override bool HasDeletions();

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.HasNorms Method

public override bool HasNorms(
string field
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.IsCurrent Method

Checks recursively if all subreaders are up to date.

public override bool IsCurrent();

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.IsDeleted Method

public override bool IsDeleted(
int n
);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.IsOptimized Method

public override bool IsOptimized();

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.MaxDoc Method

public override int MaxDoc();

See Also

MultiReader Class | Lucene.Net.Index Namespace


Norms Method

Apache Lucene.Net 2.4.0 Class Library API

MultiReader.Norms Method

Overload List

public override byte[] Norms(string);

public override void Norms(string,byte[],int);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.Norms Method (String)

public override byte[] Norms(
string field
);

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.Norms Overload List


MultiReader.Norms Method (String, Byte[], Int32)

public override void Norms(
string field,
byte[] result,
int offset
);

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.Norms Overload List


MultiReader.NumDocs Method

public override int NumDocs();

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.Reopen Method

public override IndexReader Reopen();

See Also

MultiReader Class | Lucene.Net.Index Namespace


TermDocs Method

Apache Lucene.Net 2.4.0 Class Library API

MultiReader.TermDocs Method

Overload List

public override TermDocs TermDocs();

Inherited from IndexReader.

public virtual TermDocs TermDocs(Term);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.TermDocs Method ()

public override TermDocs TermDocs();

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.TermDocs Overload List


TermPositions Method

Apache Lucene.Net 2.4.0 Class Library API

MultiReader.TermPositions Method

Overload List

public override TermPositions TermPositions();

Inherited from IndexReader.

public virtual TermPositions TermPositions(Term);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.TermPositions Method ()

public override TermPositions TermPositions();

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.TermPositions Overload List


Terms Method

Apache Lucene.Net 2.4.0 Class Library API

MultiReader.Terms Method

Overload List

public override TermEnum Terms();

public override TermEnum Terms(Term);

See Also

MultiReader Class | Lucene.Net.Index Namespace


MultiReader.Terms Method ()

public override TermEnum Terms();

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.Terms Overload List


MultiReader.Terms Method (Term)

public override TermEnum Terms(
Term term
);

See Also

MultiReader Class | Lucene.Net.Index Namespace | MultiReader.Terms Overload List


MultiSegmentReader Class

An IndexReader which reads indexes with multiple segments.

For a list of all members of this type, see MultiSegmentReader Members.

System.Object
Lucene.Net.Index.IndexReader
Lucene.Net.Index.DirectoryIndexReader
Lucene.Net.Index.MultiSegmentReader

public class MultiSegmentReader : DirectoryIndexReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MultiSegmentReader Members | Lucene.Net.Index Namespace


MultiSegmentReader Members

MultiSegmentReader overview

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef (inherited from IndexReader) | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
DeleteDocument (inherited from IndexReader) Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments (inherited from IndexReader) Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory (inherited from DirectoryIndexReader) | Returns the directory this index resides in.
DocFreq
Document | Overloaded.
Document (inherited from IndexReader) Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen (inherited from IndexReader)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from IndexReader)
GetFieldNames
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit (inherited from DirectoryIndexReader)
GetRefCount (inherited from IndexReader)
GetSubReaders
GetTermFreqVector | Overloaded.
GetTermFreqVectors
GetTermInfosIndexDivisor
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion (inherited from DirectoryIndexReader) | Version number when this IndexReader was opened.
HasDeletions
HasNorms
IncRef (inherited from IndexReader) | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IsCurrent (inherited from DirectoryIndexReader) Check whether this IndexReader is still using the current (i.e., most recently committed) version of the index. If a writer has committed any changes to the index since this reader was opened, this will return
false
, in which case you must open a new IndexReader in order to see the changes. See the description of the
autoCommit
 flag which controls when the {@link IndexWriter} actually commits changes to the index.
IsDeleted
IsOptimized
MaxDoc
Norms | Overloaded.
NumDeletedDocs (inherited from IndexReader) | Returns the number of deleted docs.
NumDocs
Reopen (inherited from DirectoryIndexReader)
SetDeletionPolicy (inherited from DirectoryIndexReader)
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from DirectoryIndexReader) | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

closeDirectory (inherited from DirectoryIndexReader)
directory (inherited from DirectoryIndexReader)
hasChanges (inherited from IndexReader)
readOnly (inherited from DirectoryIndexReader)
subReaders

Protected Internal Instance Methods

AcquireWriteLock (inherited from DirectoryIndexReader) | Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner.
CommitChanges |
DoClose |
DoCommit (inherited from DirectoryIndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DoDelete |
DoReopen |
DoSetNorm |
DoUndeleteAll |

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader Fields

The fields of the MultiSegmentReader class are listed below. For a complete list of MultiSegmentReader class members, see the MultiSegmentReader Members topic.

Protected Internal Instance Fields

closeDirectory (inherited from DirectoryIndexReader)
directory (inherited from DirectoryIndexReader)
hasChanges (inherited from IndexReader)
readOnly (inherited from DirectoryIndexReader)
subReaders

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.subReaders Field

protected internal SegmentReader[] subReaders;

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader Methods

The methods of the MultiSegmentReader class are listed below. For a complete list of MultiSegmentReader class members, see the MultiSegmentReader Members topic.

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef (inherited from IndexReader) | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
DeleteDocument (inherited from IndexReader) Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments (inherited from IndexReader) Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory (inherited from DirectoryIndexReader) | Returns the directory this index resides in.
DocFreq
Document | Overloaded.
Document (inherited from IndexReader) Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen (inherited from IndexReader)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from IndexReader)
GetFieldNames
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit (inherited from DirectoryIndexReader)
GetRefCount (inherited from IndexReader)
GetSubReaders
GetTermFreqVector | Overloaded.
GetTermFreqVectors
GetTermInfosIndexDivisor
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion (inherited from DirectoryIndexReader) | Version number when this IndexReader was opened.
HasDeletions
HasNorms
IncRef (inherited from IndexReader) | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IsCurrent (inherited from DirectoryIndexReader) Check whether this IndexReader is still using the current (i.e., most recently committed) version of the index. If a writer has committed any changes to the index since this reader was opened, this will return
false
, in which case you must open a new IndexReader in order to see the changes. See the description of the
autoCommit
 flag which controls when the {@link IndexWriter} actually commits changes to the index.
IsDeleted
IsOptimized
MaxDoc
Norms | Overloaded.
NumDeletedDocs (inherited from IndexReader) | Returns the number of deleted docs.
NumDocs
Reopen (inherited from DirectoryIndexReader)
SetDeletionPolicy (inherited from DirectoryIndexReader)
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from DirectoryIndexReader) | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

AcquireWriteLock (inherited from DirectoryIndexReader) | Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner.
CommitChanges |
DoClose |
DoCommit (inherited from DirectoryIndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DoDelete |
DoReopen |
DoSetNorm |
DoUndeleteAll |

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.CommitChanges Method

protected internal override void CommitChanges();

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.DocFreq Method

public override int DocFreq(
Term t
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.DoClose Method

protected internal override void DoClose();

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


Document Method

Apache Lucene.Net 2.4.0 Class Library API

MultiSegmentReader.Document Method

Overload List

Inherited from IndexReader.

public virtual Document Document(int);

public override Document Document(int,FieldSelector);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.Document Method (Int32, FieldSelector)

public override Document Document(
int n,
FieldSelector fieldSelector
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace | MultiSegmentReader.Document Overload List


MultiSegmentReader.DoDelete Method

protected internal override void DoDelete(
int n
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.DoReopen Method

protected internal override DirectoryIndexReader DoReopen(
SegmentInfos infos
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.DoSetNorm Method

protected internal override void DoSetNorm(
int n,
string field,
byte value_Renamed
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.DoUndeleteAll Method

protected internal override void DoUndeleteAll();

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.GetFieldNames Method

public override 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetFieldNames(
FieldOption fieldNames
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.GetSubReaders Method

public virtual SegmentReader[] GetSubReaders();

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


GetTermFreqVector Method

Apache Lucene.Net 2.4.0 Class Library API

MultiSegmentReader.GetTermFreqVector Method

Overload List

public override void GetTermFreqVector(int,TermVectorMapper);

public override TermFreqVector GetTermFreqVector(int,string);

public override void GetTermFreqVector(int,string,TermVectorMapper);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.GetTermFreqVector Method (Int32, TermVectorMapper)

public override void GetTermFreqVector(
int docNumber,
TermVectorMapper mapper
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace | MultiSegmentReader.GetTermFreqVector Overload List


MultiSegmentReader.GetTermFreqVector Method (Int32, String)

public override TermFreqVector GetTermFreqVector(
int n,
string field
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace | MultiSegmentReader.GetTermFreqVector Overload List


MultiSegmentReader.GetTermFreqVector Method (Int32, String, TermVectorMapper)

public override void GetTermFreqVector(
int docNumber,
string field,
TermVectorMapper mapper
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace | MultiSegmentReader.GetTermFreqVector Overload List


MultiSegmentReader.GetTermFreqVectors Method

public override TermFreqVector[] GetTermFreqVectors(
int n
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.GetTermInfosIndexDivisor Method

public override int GetTermInfosIndexDivisor();

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.HasDeletions Method

public override bool HasDeletions();

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.HasNorms Method

public override bool HasNorms(
string field
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.IsDeleted Method

public override bool IsDeleted(
int n
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.IsOptimized Method

public override bool IsOptimized();

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.MaxDoc Method

public override int MaxDoc();

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


Norms Method

Apache Lucene.Net 2.4.0 Class Library API

MultiSegmentReader.Norms Method

Overload List

public override byte[] Norms(string);

public override void Norms(string,byte[],int);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.Norms Method (String)

public override byte[] Norms(
string field
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace | MultiSegmentReader.Norms Overload List


MultiSegmentReader.Norms Method (String, Byte[], Int32)

public override void Norms(
string field,
byte[] result,
int offset
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace | MultiSegmentReader.Norms Overload List


MultiSegmentReader.NumDocs Method

public override int NumDocs();

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.SetTermInfosIndexDivisor Method

public override void SetTermInfosIndexDivisor(
int indexDivisor
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


TermDocs Method

Apache Lucene.Net 2.4.0 Class Library API

MultiSegmentReader.TermDocs Method

Overload List

public override TermDocs TermDocs();

Inherited from IndexReader.

public virtual TermDocs TermDocs(Term);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.TermDocs Method ()

public override TermDocs TermDocs();

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace | MultiSegmentReader.TermDocs Overload List


TermPositions Method

Apache Lucene.Net 2.4.0 Class Library API

MultiSegmentReader.TermPositions Method

Overload List

public override TermPositions TermPositions();

Inherited from IndexReader.

public virtual TermPositions TermPositions(Term);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.TermPositions Method ()

public override TermPositions TermPositions();

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace | MultiSegmentReader.TermPositions Overload List


Terms Method

Apache Lucene.Net 2.4.0 Class Library API

MultiSegmentReader.Terms Method

Overload List

public override TermEnum Terms();

public override TermEnum Terms(Term);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace


MultiSegmentReader.Terms Method ()

public override TermEnum Terms();

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace | MultiSegmentReader.Terms Overload List


MultiSegmentReader.Terms Method (Term)

public override TermEnum Terms(
Term term
);

See Also

MultiSegmentReader Class | Lucene.Net.Index Namespace | MultiSegmentReader.Terms Overload List


ParallelReader Class

For a list of all members of this type, see ParallelReader Members.

System.Object
Lucene.Net.Index.IndexReader
Lucene.Net.Index.ParallelReader

public class ParallelReader : IndexReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ParallelReader Members | Lucene.Net.Index Namespace


ParallelReader Members

ParallelReader overview

Public Instance Constructors

ParallelReader Overloaded. Initializes a new instance of the ParallelReader class.

Public Instance Methods

Add | Overloaded. Add an IndexReader.
Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef (inherited from IndexReader) | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
DeleteDocument (inherited from IndexReader) Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments (inherited from IndexReader) Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory (inherited from IndexReader) | Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
DocFreq
Document | Overloaded.
Document (inherited from IndexReader) Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen (inherited from IndexReader)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from IndexReader)
GetFieldNames
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit (inherited from IndexReader) | Expert: Return the IndexCommit that this reader has open. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: This API is new and experimental and may suddenly change.
GetRefCount (inherited from IndexReader)
GetSubReaders
GetTermFreqVector | Overloaded.
GetTermFreqVectors
GetTermInfosIndexDivisor (inherited from IndexReader)
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | Not implemented.
HasDeletions
HasNorms
IncRef (inherited from IndexReader) | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IsCurrent | Checks recursively if all subreaders are up to date.
IsDeleted
IsOptimized | Checks recursively if all subindexes are optimized
MaxDoc
Norms | Overloaded.
NumDeletedDocs (inherited from IndexReader) | Returns the number of deleted docs.
NumDocs
Reopen
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor (inherited from IndexReader) | For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.
TermDocs | Overloaded.
TermPositions | Overloaded.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

hasChanges (inherited from IndexReader)

Protected Internal Instance Methods

AcquireWriteLock (inherited from IndexReader) | Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
DoClose |
DoCommit |
DoDelete |
DoSetNorm |
DoUndeleteAll |

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader Constructor

Construct a ParallelReader.

Note that all subreaders are closed if this ParallelReader is closed.

Overload List

Construct a ParallelReader. Note that all subreaders are closed if this ParallelReader is closed.

public ParallelReader();

Construct a ParallelReader.

public ParallelReader(bool);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader Constructor ()

Construct a ParallelReader.

Note that all subreaders are closed if this ParallelReader is closed.

public ParallelReader();

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader Constructor Overload List


ParallelReader Constructor (Boolean)

Construct a ParallelReader.

public ParallelReader(
bool closeSubReaders
);

Parameters

closeSubReaders
indicates whether the subreaders should be closed when this ParallelReader is closed

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader Constructor Overload List


ParallelReader Methods

The methods of the ParallelReader class are listed below. For a complete list of ParallelReader class members, see the ParallelReader Members topic.

Public Instance Methods

Add | Overloaded. Add an IndexReader.
Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef (inherited from IndexReader) | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
DeleteDocument (inherited from IndexReader) Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments (inherited from IndexReader) Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory (inherited from IndexReader) | Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
DocFreq
Document | Overloaded.
Document (inherited from IndexReader) Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen (inherited from IndexReader)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from IndexReader)
GetFieldNames
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit (inherited from IndexReader) | Expert: Return the IndexCommit that this reader has open. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: This API is new and experimental and may suddenly change.
GetRefCount (inherited from IndexReader)
GetSubReaders
GetTermFreqVector | Overloaded.
GetTermFreqVectors
GetTermInfosIndexDivisor (inherited from IndexReader)
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | Not implemented.
HasDeletions
HasNorms
IncRef (inherited from IndexReader) | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IsCurrent | Checks recursively if all subreaders are up to date.
IsDeleted
IsOptimized | Checks recursively if all subindexes are optimized
MaxDoc
Norms | Overloaded.
NumDeletedDocs (inherited from IndexReader) | Returns the number of deleted docs.
NumDocs
Reopen
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor (inherited from IndexReader) | For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.
TermDocs | Overloaded.
TermPositions | Overloaded.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

AcquireWriteLock (inherited from IndexReader) | Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
DoClose |
DoCommit |
DoDelete |
DoSetNorm |
DoUndeleteAll |

See Also

ParallelReader Class | Lucene.Net.Index Namespace


Add Method

Apache Lucene.Net 2.4.0 Class Library API

ParallelReader.Add Method

Add an IndexReader.

Overload List

Add an IndexReader.

public virtual void Add(IndexReader);

Add an IndexReader whose stored fields will not be returned. This can accellerate search when stored fields are only needed from a subset of the IndexReaders.

public virtual void Add(IndexReader,bool);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.Add Method (IndexReader)

Add an IndexReader.

public virtual void Add(
IndexReader reader
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.Add Overload List


ParallelReader.Add Method (IndexReader, Boolean)

Add an IndexReader whose stored fields will not be returned. This can accellerate search when stored fields are only needed from a subset of the IndexReaders.

public virtual void Add(
IndexReader reader,
bool ignoreStoredFields
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.Add Overload List


ParallelReader.DocFreq Method

public override int DocFreq(
Term term
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.DoClose Method

protected internal override void DoClose();

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.DoCommit Method

protected internal override void DoCommit();

See Also

ParallelReader Class | Lucene.Net.Index Namespace


Document Method

Apache Lucene.Net 2.4.0 Class Library API

ParallelReader.Document Method

Overload List

Inherited from IndexReader.

public virtual Document Document(int);

public override Document Document(int,FieldSelector);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.Document Method (Int32, FieldSelector)

public override Document Document(
int n,
FieldSelector fieldSelector
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.Document Overload List


ParallelReader.DoDelete Method

protected internal override void DoDelete(
int n
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.DoSetNorm Method

protected internal override void DoSetNorm(
int n,
string field,
byte value_Renamed
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.DoUndeleteAll Method

protected internal override void DoUndeleteAll();

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.GetFieldNames Method

public override 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetFieldNames(
FieldOption fieldNames
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.GetSubReaders Method

public virtual IndexReader[] GetSubReaders();

See Also

ParallelReader Class | Lucene.Net.Index Namespace


GetTermFreqVector Method

Apache Lucene.Net 2.4.0 Class Library API

ParallelReader.GetTermFreqVector Method

Overload List

public override void GetTermFreqVector(int,TermVectorMapper);

public override TermFreqVector GetTermFreqVector(int,string);

public override void GetTermFreqVector(int,string,TermVectorMapper);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.GetTermFreqVector Method (Int32, TermVectorMapper)

public override void GetTermFreqVector(
int docNumber,
TermVectorMapper mapper
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.GetTermFreqVector Overload List


ParallelReader.GetTermFreqVector Method (Int32, String)

public override TermFreqVector GetTermFreqVector(
int n,
string field
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.GetTermFreqVector Overload List


ParallelReader.GetTermFreqVector Method (Int32, String, TermVectorMapper)

public override void GetTermFreqVector(
int docNumber,
string field,
TermVectorMapper mapper
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.GetTermFreqVector Overload List


ParallelReader.GetTermFreqVectors Method

public override TermFreqVector[] GetTermFreqVectors(
int n
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.GetVersion Method

Not implemented.

public override long GetVersion();

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.HasDeletions Method

public override bool HasDeletions();

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.HasNorms Method

public override bool HasNorms(
string field
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.IsCurrent Method

Checks recursively if all subreaders are up to date.

public override bool IsCurrent();

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.IsDeleted Method

public override bool IsDeleted(
int n
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.IsOptimized Method

Checks recursively if all subindexes are optimized

public override bool IsOptimized();

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.MaxDoc Method

public override int MaxDoc();

See Also

ParallelReader Class | Lucene.Net.Index Namespace


Norms Method

Apache Lucene.Net 2.4.0 Class Library API

ParallelReader.Norms Method

Overload List

public override byte[] Norms(string);

public override void Norms(string,byte[],int);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.Norms Method (String)

public override byte[] Norms(
string field
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.Norms Overload List


ParallelReader.Norms Method (String, Byte[], Int32)

public override void Norms(
string field,
byte[] result,
int offset
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.Norms Overload List


ParallelReader.NumDocs Method

public override int NumDocs();

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.Reopen Method

public override IndexReader Reopen();

See Also

ParallelReader Class | Lucene.Net.Index Namespace


TermDocs Method

Apache Lucene.Net 2.4.0 Class Library API

ParallelReader.TermDocs Method

Overload List

public override TermDocs TermDocs();

public override TermDocs TermDocs(Term);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.TermDocs Method ()

public override TermDocs TermDocs();

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.TermDocs Overload List


ParallelReader.TermDocs Method (Term)

public override TermDocs TermDocs(
Term term
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.TermDocs Overload List


TermPositions Method

Apache Lucene.Net 2.4.0 Class Library API

ParallelReader.TermPositions Method

Overload List

public override TermPositions TermPositions();

public override TermPositions TermPositions(Term);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.TermPositions Method ()

public override TermPositions TermPositions();

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.TermPositions Overload List


ParallelReader.TermPositions Method (Term)

public override TermPositions TermPositions(
Term term
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.TermPositions Overload List


Terms Method

Apache Lucene.Net 2.4.0 Class Library API

ParallelReader.Terms Method

Overload List

public override TermEnum Terms();

public override TermEnum Terms(Term);

See Also

ParallelReader Class | Lucene.Net.Index Namespace


ParallelReader.Terms Method ()

public override TermEnum Terms();

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.Terms Overload List


ParallelReader.Terms Method (Term)

public override TermEnum Terms(
Term term
);

See Also

ParallelReader Class | Lucene.Net.Index Namespace | ParallelReader.Terms Overload List


Payload Class

For a list of all members of this type, see Payload Members.

System.Object
Lucene.Net.Index.Payload

public class Payload : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Payload Members | Lucene.Net.Index Namespace


Payload Members

Payload overview

Public Instance Constructors

Payload Overloaded. Initializes a new instance of the Payload class.

Public Instance Methods

ByteAt | Returns the byte at the given index.
Clone | Clones this payload by creating a copy of the underlying byte array.
CopyTo | Copies the payload data to a byte array.
Equals |
GetData | Returns a reference to the underlying byte array that holds this payloads data.
GetHashCode |
GetOffset | Returns the offset in the underlying byte array
GetType (inherited from Object) | Gets the Type of the current instance.
Length | Returns the length of the payload data.
SetData | Overloaded. Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.
ToByteArray | Allocates a new byte array, copies the payload data into it and returns it.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

data | the byte array containing the payload data
length | the length of the payload data
offset | the offset within the byte array

See Also

Payload Class | Lucene.Net.Index Namespace


Payload Constructor

Creates an empty payload and does not allocate a byte array.

Overload List

Creates an empty payload and does not allocate a byte array.

public Payload();

Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.

public Payload(byte[]);

Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.

public Payload(byte[],int,int);

See Also

Payload Class | Lucene.Net.Index Namespace


Payload Constructor ()

Creates an empty payload and does not allocate a byte array.

public Payload();

See Also

Payload Class | Lucene.Net.Index Namespace | Payload Constructor Overload List


Payload Constructor (Byte[])

Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.

public Payload(
byte[] data
);

Parameters

data
the data of this payload

See Also

Payload Class | Lucene.Net.Index Namespace | Payload Constructor Overload List


Payload Constructor (Byte[], Int32, Int32)

Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.

public Payload(
byte[] data,
int offset,
int length
);

Parameters

data
the data of this payload
offset
the offset in the data byte array
length
the length of the data

See Also

Payload Class | Lucene.Net.Index Namespace | Payload Constructor Overload List


Payload Fields

The fields of the Payload class are listed below. For a complete list of Payload class members, see the Payload Members topic.

Protected Internal Instance Fields

data | the byte array containing the payload data
length | the length of the payload data
offset | the offset within the byte array

See Also

Payload Class | Lucene.Net.Index Namespace


Payload.data Field

the byte array containing the payload data

protected internal byte[] data;

See Also

Payload Class | Lucene.Net.Index Namespace


Payload.Length Method

Returns the length of the payload data.

public virtual int Length();

See Also

Payload Class | Lucene.Net.Index Namespace


Payload.offset Field

the offset within the byte array

protected internal int offset;

See Also

Payload Class | Lucene.Net.Index Namespace


Payload Methods

The methods of the Payload class are listed below. For a complete list of Payload class members, see the Payload Members topic.

Public Instance Methods

ByteAt | Returns the byte at the given index.
Clone | Clones this payload by creating a copy of the underlying byte array.
CopyTo | Copies the payload data to a byte array.
Equals |
GetData | Returns a reference to the underlying byte array that holds this payloads data.
GetHashCode |
GetOffset | Returns the offset in the underlying byte array
GetType (inherited from Object) | Gets the Type of the current instance.
Length | Returns the length of the payload data.
SetData | Overloaded. Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.
ToByteArray | Allocates a new byte array, copies the payload data into it and returns it.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Payload Class | Lucene.Net.Index Namespace


Payload.ByteAt Method

Returns the byte at the given index.

public virtual byte ByteAt(
int index
);

See Also

Payload Class | Lucene.Net.Index Namespace


Payload.Clone Method

Clones this payload by creating a copy of the underlying byte array.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

Payload Class | Lucene.Net.Index Namespace


Payload.CopyTo Method

Copies the payload data to a byte array.

public virtual void CopyTo(
byte[] target,
int targetOffset
);

Parameters

target
the target byte array
targetOffset
the offset in the target byte array

See Also

Payload Class | Lucene.Net.Index Namespace


Payload.Equals Method

public override bool Equals(
object obj
);

See Also

Payload Class | Lucene.Net.Index Namespace


Payload.GetData Method

Returns a reference to the underlying byte array that holds this payloads data.

public virtual byte[] GetData();

See Also

Payload Class | Lucene.Net.Index Namespace


Payload.GetHashCode Method

public override int GetHashCode();

See Also

Payload Class | Lucene.Net.Index Namespace


Payload.GetOffset Method

Returns the offset in the underlying byte array

public virtual int GetOffset();

See Also

Payload Class | Lucene.Net.Index Namespace


SetData Method

Apache Lucene.Net 2.4.0 Class Library API

Payload.SetData Method

Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.

Overload List

Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.

public virtual void SetData(byte[]);

Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.

public virtual void SetData(byte[],int,int);

See Also

Payload Class | Lucene.Net.Index Namespace


Payload.SetData Method (Byte[])

Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.

public virtual void SetData(
byte[] data
);

See Also

Payload Class | Lucene.Net.Index Namespace | Payload.SetData Overload List


Payload.SetData Method (Byte[], Int32, Int32)

Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.

public virtual void SetData(
byte[] data,
int offset,
int length
);

See Also

Payload Class | Lucene.Net.Index Namespace | Payload.SetData Overload List


Payload.ToByteArray Method

Allocates a new byte array, copies the payload data into it and returns it.

public virtual byte[] ToByteArray();

See Also

Payload Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper Class

For each Field, store position by position information. It ignores frequency information

This is not thread-safe.

For a list of all members of this type, see PositionBasedTermVectorMapper Members.

System.Object
Lucene.Net.Index.TermVectorMapper
Lucene.Net.Index.PositionBasedTermVectorMapper

public class PositionBasedTermVectorMapper : TermVectorMapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PositionBasedTermVectorMapper Members | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper Members

PositionBasedTermVectorMapper overview

Public Instance Constructors

PositionBasedTermVectorMapper Overloaded. Initializes a new instance of the PositionBasedTermVectorMapper class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFieldToTerms | Get the mapping between fields and terms, sorted by the comparator
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIgnoringOffsets (inherited from TermVectorMapper) |
IsIgnoringPositions | Never ignores positions. This mapper doesn't make much sense unless there are positions
Map | Callback for the TermVectorReader.
SetDocumentNumber (inherited from TermVectorMapper) | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
SetExpectations | Callback mechanism used by the TermVectorReader
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PositionBasedTermVectorMapper Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper Constructor

Overload List

public PositionBasedTermVectorMapper();

public PositionBasedTermVectorMapper(bool);

See Also

PositionBasedTermVectorMapper Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper Constructor ()

public PositionBasedTermVectorMapper();

See Also

PositionBasedTermVectorMapper Class | Lucene.Net.Index Namespace | PositionBasedTermVectorMapper Constructor Overload List


PositionBasedTermVectorMapper Constructor (Boolean)

public PositionBasedTermVectorMapper(
bool ignoringOffsets
);

See Also

PositionBasedTermVectorMapper Class | Lucene.Net.Index Namespace | PositionBasedTermVectorMapper Constructor Overload List


PositionBasedTermVectorMapper Methods

The methods of the PositionBasedTermVectorMapper class are listed below. For a complete list of PositionBasedTermVectorMapper class members, see the PositionBasedTermVectorMapper Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFieldToTerms | Get the mapping between fields and terms, sorted by the comparator
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIgnoringOffsets (inherited from TermVectorMapper) |
IsIgnoringPositions | Never ignores positions. This mapper doesn't make much sense unless there are positions
Map | Callback for the TermVectorReader.
SetDocumentNumber (inherited from TermVectorMapper) | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
SetExpectations | Callback mechanism used by the TermVectorReader
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PositionBasedTermVectorMapper Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.GetFieldToTerms Method

Get the mapping between fields and terms, sorted by the comparator

public virtual IDictionary GetFieldToTerms();

Return Value

A map between field names and a Map. The sub-Map key is the position as the integer, the value is {@link Lucene.Net.Index.PositionBasedTermVectorMapper.TVPositionInfo}.

See Also

PositionBasedTermVectorMapper Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.IsIgnoringPositions Method

Never ignores positions. This mapper doesn't make much sense unless there are positions

public override bool IsIgnoringPositions();

Return Value

false

See Also

PositionBasedTermVectorMapper Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.Map Method

Callback for the TermVectorReader.

public override void Map(
string term,
int frequency,
TermVectorOffsetInfo[] offsets,
int[] positions
);

Parameters

term
frequency
offsets
positions

See Also

PositionBasedTermVectorMapper Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.SetExpectations Method

Callback mechanism used by the TermVectorReader

public override void SetExpectations(
string field,
int numTerms,
bool storeOffsets,
bool storePositions
);

Parameters

field
The field being read
numTerms
The number of terms in the vector
storeOffsets
Whether offsets are available
storePositions
Whether positions are available

See Also

PositionBasedTermVectorMapper Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.TVPositionInfo Class

Container for a term at a position

For a list of all members of this type, see PositionBasedTermVectorMapper.TVPositionInfo Members.

System.Object
Lucene.Net.Index.PositionBasedTermVectorMapper.TVPositionInfo

public class PositionBasedTermVectorMapper.TVPositionInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PositionBasedTermVectorMapper.TVPositionInfo Members | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.TVPositionInfo Members

PositionBasedTermVectorMapper.TVPositionInfo overview

Public Instance Constructors

PositionBasedTermVectorMapper.TVPositionInfo Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOffsets | Parallel list (to {@link #GetTerms()}) of TermVectorOffsetInfo objects. There may be multiple entries since there may be multiple terms at a position
GetPosition |
GetTerms | Note, there may be multiple terms at the same position
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PositionBasedTermVectorMapper.TVPositionInfo Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.TVPositionInfo Constructor

public PositionBasedTermVectorMapper.TVPositionInfo(
int position,
bool storeOffsets
);

See Also

PositionBasedTermVectorMapper.TVPositionInfo Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.TVPositionInfo Methods

The methods of the PositionBasedTermVectorMapper.TVPositionInfo class are listed below. For a complete list of PositionBasedTermVectorMapper.TVPositionInfo class members, see the PositionBasedTermVectorMapper.TVPositionInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOffsets | Parallel list (to {@link #GetTerms()}) of TermVectorOffsetInfo objects. There may be multiple entries since there may be multiple terms at a position
GetPosition |
GetTerms | Note, there may be multiple terms at the same position
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PositionBasedTermVectorMapper.TVPositionInfo Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.TVPositionInfo.GetOffsets Method

Parallel list (to {@link #GetTerms()}) of TermVectorOffsetInfo objects. There may be multiple entries since there may be multiple terms at a position

public virtual IList GetOffsets();

Return Value

A List of TermVectorOffsetInfo objects, if offsets are store.

See Also

PositionBasedTermVectorMapper.TVPositionInfo Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.TVPositionInfo.GetPosition Method

public virtual int GetPosition();

Return Value

The position of the term

See Also

PositionBasedTermVectorMapper.TVPositionInfo Class | Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.TVPositionInfo.GetTerms Method

Note, there may be multiple terms at the same position

public virtual IList GetTerms();

Return Value

A List of Strings

See Also

PositionBasedTermVectorMapper.TVPositionInfo Class | Lucene.Net.Index Namespace


SegmentInfo Class

For a list of all members of this type, see SegmentInfo Members.

System.Object
Lucene.Net.Index.SegmentInfo

public sealed class SegmentInfo : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentInfo Members | Lucene.Net.Index Namespace


SegmentInfo Members

SegmentInfo overview

Public Instance Constructors

SegmentInfo Overloaded. Initializes a new instance of the SegmentInfo class.

Public Instance Fields

dir
docCount
name

Public Instance Methods

Clone |
Equals | We consider another SegmentInfo instance equal if it has the same dir and same name.
Files |
GetDelCount |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundFile | Returns true if this segment is stored as a compound file; else, false.
HasDeletions |
HasSeparateNorms | Returns true if any fields in this segment have separate norms.
SegString | Used for debugging
SizeInBytes | Returns total size in bytes of all of files used by this segment.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo Constructor

Overload List

public SegmentInfo(string,int,Directory);

public SegmentInfo(string,int,Directory,bool,bool);

public SegmentInfo(string,int,Directory,bool,bool,int,string,bool,bool);

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo Constructor (String, Int32, Directory)

public SegmentInfo(
string name,
int docCount,
Directory dir
);

See Also

SegmentInfo Class | Lucene.Net.Index Namespace | SegmentInfo Constructor Overload List


SegmentInfo Constructor (String, Int32, Directory, Boolean, Boolean)

public SegmentInfo(
string name,
int docCount,
Directory dir,
bool isCompoundFile,
bool hasSingleNormFile
);

See Also

SegmentInfo Class | Lucene.Net.Index Namespace | SegmentInfo Constructor Overload List


SegmentInfo Constructor (String, Int32, Directory, Boolean, Boolean, Int32, String, Boolean, Boolean)

public SegmentInfo(
string name,
int docCount,
Directory dir,
bool isCompoundFile,
bool hasSingleNormFile,
int docStoreOffset,
string docStoreSegment,
bool docStoreIsCompoundFile,
bool hasProx
);

See Also

SegmentInfo Class | Lucene.Net.Index Namespace | SegmentInfo Constructor Overload List


SegmentInfo Fields

The fields of the SegmentInfo class are listed below. For a complete list of SegmentInfo class members, see the SegmentInfo Members topic.

Public Instance Fields

dir
docCount
name

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.dir Field

public Directory dir;

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.docCount Field

public int docCount;

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.name Field

public string name;

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo Methods

The methods of the SegmentInfo class are listed below. For a complete list of SegmentInfo class members, see the SegmentInfo Members topic.

Public Instance Methods

Clone |
Equals | We consider another SegmentInfo instance equal if it has the same dir and same name.
Files |
GetDelCount |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseCompoundFile | Returns true if this segment is stored as a compound file; else, false.
HasDeletions |
HasSeparateNorms | Returns true if any fields in this segment have separate norms.
SegString | Used for debugging
SizeInBytes | Returns total size in bytes of all of files used by this segment.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.Clone Method

public object Clone();

Implements

ICloneable.Clone

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.Equals Method

We consider another SegmentInfo instance equal if it has the same dir and same name.

public override bool Equals(
object obj
);

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.Files Method

public 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] Files();

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.GetDelCount Method

public int GetDelCount();

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.GetHashCode Method

public override int GetHashCode();

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.GetUseCompoundFile Method

Returns true if this segment is stored as a compound file; else, false.

public bool GetUseCompoundFile();

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.HasDeletions Method

public bool HasDeletions();

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.HasSeparateNorms Method

Returns true if any fields in this segment have separate norms.

public bool HasSeparateNorms();

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.SegString Method

Used for debugging

public string SegString(
Directory dir
);

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfo.SizeInBytes Method

Returns total size in bytes of all of files used by this segment.

public long SizeInBytes();

See Also

SegmentInfo Class | Lucene.Net.Index Namespace


SegmentInfos Class

For a list of all members of this type, see SegmentInfos Members.

System.Object
System.Collections.ArrayList
Lucene.Net.Index.SegmentInfos

public sealed class SegmentInfos : ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentInfos Members | Lucene.Net.Index Namespace


SegmentInfos Members

SegmentInfos overview

Public Static Fields

CURRENT_FORMAT |
FORMAT | The file format version, a negative number.
FORMAT_CHECKSUM | This format adds a checksum at the end of the file to ensure all bytes were successfully written.
FORMAT_DEL_COUNT | This format adds the deletion count for each segment. This way IndexWriter can efficiently report numDocs().
FORMAT_HAS_PROX | This format adds the boolean hasProx to record if any fields in the segment store prox information (ie, have omitTf==false)
FORMAT_LOCKLESS | This format adds details used for lockless commits. It differs slightly from the previous format in that file names are never re-used (write once). Instead, each file is written to the next generation. For example, segments_1, segments_2, etc. This allows us to not use a commit lock. See file formats for details.
FORMAT_SHARED_DOC_STORE | This format allows multiple segments to share a single vectors and stored fields file.
FORMAT_SINGLE_NORM_FILE | This format adds a "hasSingleNormFile" flag into each segment info. See LUCENE-756 for details.

Public Static Methods

GenerationFromSegmentsFileName | Parse the generation off the segments file name and return it.
GetCurrentSegmentFileName | Overloaded. Get the filename of the current segments_N file from a list of files.
GetCurrentSegmentGeneration | Overloaded. Get the generation (N) of the current segments_N file from a list of files.
GetDefaultGenFileRetryCount |
GetDefaultGenFileRetryPauseMsec |
GetDefaultGenLookahedCount |
GetInfoStream |
ReadCurrentVersion | Current version number from segments file.
SetDefaultGenFileRetryCount | Advanced: set how many times to try loading the segments.gen file contents to determine current segment generation. This file is only referenced when the primary method (listing the directory) fails.
SetDefaultGenFileRetryPauseMsec | Advanced: set how many milliseconds to pause in between attempts to load the segments.gen file.
SetDefaultGenLookaheadCount | Advanced: set how many times to try incrementing the gen when loading the segments file. This only runs if the primary (listing directory) and secondary (opening segments.gen file) methods fail to find the segments file.
SetInfoStream | If non-null, information about retries when loading the segments file will be printed to this.

Public Instance Constructors

SegmentInfos Constructor Initializes a new instance of the SegmentInfos class.

Public Instance Fields

counter

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add (inherited from ArrayList) | Adds an object to the end of the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone | Returns a copy of this instance, also copying each SegmentInfo.
Commit |
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinishCommit |
GetCurrentSegmentFileName | Overloaded. Get the segments_N filename in use by this segment infos.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetGeneration |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLastGeneration |
GetNextSegmentFileName | Get the next segments_N filename that will be written.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | version number when this SegmentInfos was generated.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Info |
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList.
PrepareCommit |
Range | Returns a new SegmentInfos containg the SegmentInfo instances in the specified range first (inclusive) to last (exclusive), so total number of segments returned is last-first.
Read | Overloaded. Read a particular segmentFileName. Note that this may throw an IOException if a commit is in process.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the entire ArrayList.
RollbackCommit |
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in the entire ArrayList using the IComparable implementation of each element.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new Object array.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos Constructor

Initializes a new instance of the SegmentInfos class.

public SegmentInfos();

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos Fields

The fields of the SegmentInfos class are listed below. For a complete list of SegmentInfos class members, see the SegmentInfos Members topic.

Public Static Fields

CURRENT_FORMAT |
FORMAT | The file format version, a negative number.
FORMAT_CHECKSUM | This format adds a checksum at the end of the file to ensure all bytes were successfully written.
FORMAT_DEL_COUNT | This format adds the deletion count for each segment. This way IndexWriter can efficiently report numDocs().
FORMAT_HAS_PROX | This format adds the boolean hasProx to record if any fields in the segment store prox information (ie, have omitTf==false)
FORMAT_LOCKLESS | This format adds details used for lockless commits. It differs slightly from the previous format in that file names are never re-used (write once). Instead, each file is written to the next generation. For example, segments_1, segments_2, etc. This allows us to not use a commit lock. See file formats for details.
FORMAT_SHARED_DOC_STORE | This format allows multiple segments to share a single vectors and stored fields file.
FORMAT_SINGLE_NORM_FILE | This format adds a "hasSingleNormFile" flag into each segment info. See LUCENE-756 for details.

Public Instance Fields

counter

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.counter Field

public int counter;

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.CURRENT_FORMAT Field

public static readonly int CURRENT_FORMAT;

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.FORMAT Field

The file format version, a negative number.

public const int FORMAT = -1;

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.FORMAT_CHECKSUM Field

This format adds a checksum at the end of the file to ensure all bytes were successfully written.

public const int FORMAT_CHECKSUM = -5;

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.FORMAT_DEL_COUNT Field

This format adds the deletion count for each segment. This way IndexWriter can efficiently report numDocs().

public const int FORMAT_DEL_COUNT = -6;

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.FORMAT_HAS_PROX Field

This format adds the boolean hasProx to record if any fields in the segment store prox information (ie, have omitTf==false)

public const int FORMAT_HAS_PROX = -7;

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.FORMAT_LOCKLESS Field

This format adds details used for lockless commits. It differs slightly from the previous format in that file names are never re-used (write once). Instead, each file is written to the next generation. For example, segments_1, segments_2, etc. This allows us to not use a commit lock. See file formats for details.

public const int FORMAT_LOCKLESS = -2;

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.FORMAT_SHARED_DOC_STORE Field

This format allows multiple segments to share a single vectors and stored fields file.

public const int FORMAT_SHARED_DOC_STORE = -4;

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.FORMAT_SINGLE_NORM_FILE Field

This format adds a "hasSingleNormFile" flag into each segment info. See LUCENE-756 for details.

public const int FORMAT_SINGLE_NORM_FILE = -3;

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos Methods

The methods of the SegmentInfos class are listed below. For a complete list of SegmentInfos class members, see the SegmentInfos Members topic.

Public Static Methods

GenerationFromSegmentsFileName | Parse the generation off the segments file name and return it.
GetCurrentSegmentFileName | Overloaded. Get the filename of the current segments_N file from a list of files.
GetCurrentSegmentGeneration | Overloaded. Get the generation (N) of the current segments_N file from a list of files.
GetDefaultGenFileRetryCount |
GetDefaultGenFileRetryPauseMsec |
GetDefaultGenLookahedCount |
GetInfoStream |
ReadCurrentVersion | Current version number from segments file.
SetDefaultGenFileRetryCount | Advanced: set how many times to try loading the segments.gen file contents to determine current segment generation. This file is only referenced when the primary method (listing the directory) fails.
SetDefaultGenFileRetryPauseMsec | Advanced: set how many milliseconds to pause in between attempts to load the segments.gen file.
SetDefaultGenLookaheadCount | Advanced: set how many times to try incrementing the gen when loading the segments file. This only runs if the primary (listing directory) and secondary (opening segments.gen file) methods fail to find the segments file.
SetInfoStream | If non-null, information about retries when loading the segments file will be printed to this.

Public Instance Methods

Add (inherited from ArrayList) | Adds an object to the end of the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone | Returns a copy of this instance, also copying each SegmentInfo.
Commit |
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinishCommit |
GetCurrentSegmentFileName | Overloaded. Get the segments_N filename in use by this segment infos.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetGeneration |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLastGeneration |
GetNextSegmentFileName | Get the next segments_N filename that will be written.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | version number when this SegmentInfos was generated.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Info |
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList.
PrepareCommit |
Range | Returns a new SegmentInfos containg the SegmentInfo instances in the specified range first (inclusive) to last (exclusive), so total number of segments returned is last-first.
Read | Overloaded. Read a particular segmentFileName. Note that this may throw an IOException if a commit is in process.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the entire ArrayList.
RollbackCommit |
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in the entire ArrayList using the IComparable implementation of each element.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new Object array.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.Clone Method

Returns a copy of this instance, also copying each SegmentInfo.

public override object Clone();

Implements

ICloneable.Clone

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.Commit Method

public void Commit(
Directory dir
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.FinishCommit Method

public void FinishCommit(
Directory dir
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.GenerationFromSegmentsFileName Method

Parse the generation off the segments file name and return it.

public static long GenerationFromSegmentsFileName(
string fileName
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


GetCurrentSegmentFileName Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentInfos.GetCurrentSegmentFileName Method

Get the segments_N filename in use by this segment infos.

Overload List

Get the segments_N filename in use by this segment infos.

public string GetCurrentSegmentFileName();

Get the filename of the current segments_N file in the directory.

public static string GetCurrentSegmentFileName(Directory);

Get the filename of the current segments_N file from a list of files.

public static string GetCurrentSegmentFileName(string[]);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.GetCurrentSegmentFileName Method ()

Get the segments_N filename in use by this segment infos.

public string GetCurrentSegmentFileName();

See Also

SegmentInfos Class | Lucene.Net.Index Namespace | SegmentInfos.GetCurrentSegmentFileName Overload List


SegmentInfos.GetCurrentSegmentFileName Method (Directory)

Get the filename of the current segments_N file in the directory.

public static string GetCurrentSegmentFileName(
Directory directory
);

Parameters

directory
-- directory to search for the latest segments_N file

See Also

SegmentInfos Class | Lucene.Net.Index Namespace | SegmentInfos.GetCurrentSegmentFileName Overload List


SegmentInfos.GetCurrentSegmentFileName Method (String[])

Get the filename of the current segments_N file from a list of files.

public static string GetCurrentSegmentFileName(
string[] files
);

Parameters

files
-- array of file names to check

See Also

SegmentInfos Class | Lucene.Net.Index Namespace | SegmentInfos.GetCurrentSegmentFileName Overload List


GetCurrentSegmentGeneration Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentInfos.GetCurrentSegmentGeneration Method

Get the generation (N) of the current segments_N file in the directory.

Overload List

Get the generation (N) of the current segments_N file in the directory.

public static long GetCurrentSegmentGeneration(Directory);

Get the generation (N) of the current segments_N file from a list of files.

public static long GetCurrentSegmentGeneration(string[]);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.GetCurrentSegmentGeneration Method (Directory)

Get the generation (N) of the current segments_N file in the directory.

public static long GetCurrentSegmentGeneration(
Directory directory
);

Parameters

directory
-- directory to search for the latest segments_N file

See Also

SegmentInfos Class | Lucene.Net.Index Namespace | SegmentInfos.GetCurrentSegmentGeneration Overload List


SegmentInfos.GetCurrentSegmentGeneration Method (String[])

Get the generation (N) of the current segments_N file from a list of files.

public static long GetCurrentSegmentGeneration(
string[] files
);

Parameters

files
-- array of file names to check

See Also

SegmentInfos Class | Lucene.Net.Index Namespace | SegmentInfos.GetCurrentSegmentGeneration Overload List


SegmentInfos.GetDefaultGenFileRetryCount Method

public static int GetDefaultGenFileRetryCount();

See Also

SegmentInfos Class | Lucene.Net.Index Namespace | setDefaultGenFileRetryCount


SegmentInfos.GetDefaultGenFileRetryPauseMsec Method

public static int GetDefaultGenFileRetryPauseMsec();

See Also

SegmentInfos Class | Lucene.Net.Index Namespace | setDefaultGenFileRetryPauseMsec


SegmentInfos.GetDefaultGenLookahedCount Method

public static int GetDefaultGenLookahedCount();

See Also

SegmentInfos Class | Lucene.Net.Index Namespace | setDefaultGenLookaheadCount


SegmentInfos.GetGeneration Method

public long GetGeneration();

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.GetInfoStream Method

public static StreamWriter GetInfoStream();

See Also

SegmentInfos Class | Lucene.Net.Index Namespace | setInfoStream


SegmentInfos.GetLastGeneration Method

public long GetLastGeneration();

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.GetNextSegmentFileName Method

Get the next segments_N filename that will be written.

public string GetNextSegmentFileName();

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.GetVersion Method

version number when this SegmentInfos was generated.

public long GetVersion();

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.Info Method

public SegmentInfo Info(
int i
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.PrepareCommit Method

public void PrepareCommit(
Directory dir
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.Range Method

Returns a new SegmentInfos containg the SegmentInfo instances in the specified range first (inclusive) to last (exclusive), so total number of segments returned is last-first.

new public SegmentInfos Range(
int first,
int last
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


Read Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentInfos.Read Method

This version of read uses the retry logic (for lock-less commits) to find the right segments file to load.

Overload List

This version of read uses the retry logic (for lock-less commits) to find the right segments file to load.

public void Read(Directory);

Read a particular segmentFileName. Note that this may throw an IOException if a commit is in process.

public void Read(Directory,string);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.Read Method (Directory)

This version of read uses the retry logic (for lock-less commits) to find the right segments file to load.

public void Read(
Directory directory
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace | SegmentInfos.Read Overload List


SegmentInfos.Read Method (Directory, String)

Read a particular segmentFileName. Note that this may throw an IOException if a commit is in process.

public void Read(
Directory directory,
string segmentFileName
);

Parameters

directory
-- directory containing the segments file
segmentFileName
-- segment file to load

See Also

SegmentInfos Class | Lucene.Net.Index Namespace | SegmentInfos.Read Overload List


SegmentInfos.ReadCurrentVersion Method

Current version number from segments file.

public static long ReadCurrentVersion(
Directory directory
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.RollbackCommit Method

public void RollbackCommit(
Directory dir
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.SetDefaultGenFileRetryCount Method

Advanced: set how many times to try loading the segments.gen file contents to determine current segment generation. This file is only referenced when the primary method (listing the directory) fails.

public static void SetDefaultGenFileRetryCount(
int count
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.SetDefaultGenFileRetryPauseMsec Method

Advanced: set how many milliseconds to pause in between attempts to load the segments.gen file.

public static void SetDefaultGenFileRetryPauseMsec(
int msec
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.SetDefaultGenLookaheadCount Method

Advanced: set how many times to try incrementing the gen when loading the segments file. This only runs if the primary (listing directory) and secondary (opening segments.gen file) methods fail to find the segments file.

public static void SetDefaultGenLookaheadCount(
int count
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.SetInfoStream Method

If non-null, information about retries when loading the segments file will be printed to this.

public static void SetInfoStream(
StreamWriter infoStream
);

See Also

SegmentInfos Class | Lucene.Net.Index Namespace


SegmentInfos.FindSegmentsFile Class

Utility class for executing code that needs to do something with the current segments file. This is necessary with lock-less commits because from the time you locate the current segments file name, until you actually open it, read its contents, or check modified time, etc., it could have been deleted due to a writer commit finishing.

For a list of all members of this type, see SegmentInfos.FindSegmentsFile Members.

System.Object
Lucene.Net.Index.SegmentInfos.FindSegmentsFile

public abstract class SegmentInfos.FindSegmentsFile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentInfos.FindSegmentsFile Members | Lucene.Net.Index Namespace


SegmentInfos.FindSegmentsFile Members

SegmentInfos.FindSegmentsFile overview

Public Instance Constructors

SegmentInfos.FindSegmentsFile Overloaded. Initializes a new instance of the SegmentInfos.FindSegmentsFile class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

DoBody Subclass must implement this. The assumption is an IOException will be thrown if something goes wrong during the processing that could have been caused by a writer committing.

See Also

SegmentInfos.FindSegmentsFile Class | Lucene.Net.Index Namespace


SegmentInfos.FindSegmentsFile Constructor

Overload List

public SegmentInfos.FindSegmentsFile(Directory);

public SegmentInfos.FindSegmentsFile(FileInfo);

See Also

SegmentInfos.FindSegmentsFile Class | Lucene.Net.Index Namespace


SegmentInfos.FindSegmentsFile Constructor (FileInfo)

public SegmentInfos.FindSegmentsFile(
FileInfo directory
);

See Also

SegmentInfos.FindSegmentsFile Class | Lucene.Net.Index Namespace | SegmentInfos.FindSegmentsFile Constructor Overload List


SegmentInfos.FindSegmentsFile Constructor (Directory)

public SegmentInfos.FindSegmentsFile(
Directory directory
);

See Also

SegmentInfos.FindSegmentsFile Class | Lucene.Net.Index Namespace | SegmentInfos.FindSegmentsFile Constructor Overload List


SegmentInfos.FindSegmentsFile Methods

The methods of the SegmentInfos.FindSegmentsFile class are listed below. For a complete list of SegmentInfos.FindSegmentsFile class members, see the SegmentInfos.FindSegmentsFile Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

DoBody Subclass must implement this. The assumption is an IOException will be thrown if something goes wrong during the processing that could have been caused by a writer committing.

See Also

SegmentInfos.FindSegmentsFile Class | Lucene.Net.Index Namespace


SegmentInfos.FindSegmentsFile.DoBody Method

Subclass must implement this. The assumption is an IOException will be thrown if something goes wrong during the processing that could have been caused by a writer committing.

protected internal abstract object DoBody(
string segmentFileName
);

See Also

SegmentInfos.FindSegmentsFile Class | Lucene.Net.Index Namespace


SegmentInfos.FindSegmentsFile.Run Method

public object Run();

See Also

SegmentInfos.FindSegmentsFile Class | Lucene.Net.Index Namespace


SegmentMerger Class

For a list of all members of this type, see SegmentMerger Members.

System.Object
Lucene.Net.Index.SegmentMerger

public sealed class SegmentMerger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentMerger Members | Lucene.Net.Index Namespace


SegmentMerger Members

SegmentMerger overview

Public Instance Constructors

SegmentMerger Constructor This ctor used only by test code.

Public Instance Methods

Add | Add an IndexReader to the collection of readers that are to be merged
CloseReaders | close all IndexReaders that have been added. Should not be called before merge().
CreateCompoundFile |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Merges the readers specified by the {@link #add} method into the directory passed to the constructor
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentMerger Constructor

This ctor used only by test code.

public SegmentMerger(
Directory dir,
string name
);

Parameters

dir
The Directory to merge the other segments into
name
The name of the new segment

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentMerger Methods

The methods of the SegmentMerger class are listed below. For a complete list of SegmentMerger class members, see the SegmentMerger Members topic.

Public Instance Methods

Add | Add an IndexReader to the collection of readers that are to be merged
CloseReaders | close all IndexReaders that have been added. Should not be called before merge().
CreateCompoundFile |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Merges the readers specified by the {@link #add} method into the directory passed to the constructor
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentMerger.Add Method

Add an IndexReader to the collection of readers that are to be merged

public void Add(
IndexReader reader
);

Parameters

reader

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentMerger.CloseReaders Method

close all IndexReaders that have been added. Should not be called before merge().

public void CloseReaders();

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentMerger.CreateCompoundFile Method

public ArrayList CreateCompoundFile(
string fileName
);

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentMerger.Merge Method

Merges the readers specified by the {@link #add} method into the directory passed to the constructor

public int Merge();

Return Value

The number of documents that were merged

See Also

SegmentMerger Class | Lucene.Net.Index Namespace


SegmentReader Class

For a list of all members of this type, see SegmentReader Members.

System.Object
Lucene.Net.Index.IndexReader
Lucene.Net.Index.DirectoryIndexReader
Lucene.Net.Index.SegmentReader

public class SegmentReader : DirectoryIndexReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentReader Members | Lucene.Net.Index Namespace


SegmentReader Members

SegmentReader overview

Public Static Methods

Get Overloaded.

Public Instance Constructors

SegmentReader Constructor Initializes a new instance of the SegmentReader class.

Public Instance Properties

ProxStream_ForNUnitTest

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef
DeleteDocument (inherited from IndexReader) Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments (inherited from IndexReader) Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory (inherited from DirectoryIndexReader) | Returns the directory this index resides in.
DocFreq
Document | Overloaded.
Document (inherited from IndexReader) Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen (inherited from IndexReader)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FieldInfos | Returns the field infos of this segment
Flush (inherited from IndexReader)
foo
GetFieldNames
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit (inherited from DirectoryIndexReader)
GetRefCount (inherited from IndexReader)
GetTermFreqVector | Overloaded. Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.
GetTermFreqVectors | Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.
GetTermInfosIndexDivisor
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion (inherited from DirectoryIndexReader) | Version number when this IndexReader was opened.
HasDeletions
HasNorms
IncRef | Increments the RC of this reader, as well as of all norms this reader is using
IsCurrent (inherited from DirectoryIndexReader) Check whether this IndexReader is still using the current (i.e., most recently committed) version of the index. If a writer has committed any changes to the index since this reader was opened, this will return
false
, in which case you must open a new IndexReader in order to see the changes. See the description of the
autoCommit
 flag which controls when the {@link IndexWriter} actually commits changes to the index.
IsDeleted
IsOptimized (inherited from DirectoryIndexReader) | Checks is the index is optimized (if it has a single segment and no deletions)
MaxDoc
Norms | Overloaded.
NormsClosed | Overloaded.
NumDeletedDocs (inherited from IndexReader) | Returns the number of deleted docs.
NumDocs
Reopen (inherited from DirectoryIndexReader)
SetDeletionPolicy (inherited from DirectoryIndexReader)
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from DirectoryIndexReader) | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

closeDirectory (inherited from DirectoryIndexReader)
directory (inherited from DirectoryIndexReader)
hasChanges (inherited from IndexReader)

Protected Internal Instance Methods

AcquireWriteLock (inherited from DirectoryIndexReader) | Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner.
CommitChanges |
DoClose |
DoCommit (inherited from DirectoryIndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DoDelete |
DoReopen |
DoSetNorm |
DoUndeleteAll |
GetNorms |

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader Constructor

Initializes a new instance of the SegmentReader class.

public SegmentReader();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader Properties

The properties of the SegmentReader class are listed below. For a complete list of SegmentReader class members, see the SegmentReader Members topic.

Public Instance Properties

ProxStream_ForNUnitTest

See Also

SegmentReader Class | Lucene.Net.Index Namespace


ProxStream_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

SegmentReader.ProxStream_ForNUnitTest Property

public Lucene.Net.Store.IndexInput ProxStream_ForNUnitTest {get; set;}

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader Methods

The methods of the SegmentReader class are listed below. For a complete list of SegmentReader class members, see the SegmentReader Members topic.

Public Static Methods

Get Overloaded.

Public Instance Methods

Close (inherited from IndexReader) | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Commit (inherited from IndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DecRef
DeleteDocument (inherited from IndexReader) Deletes the document numbered
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
DeleteDocuments (inherited from IndexReader) Deletes all documents that have a given
term
indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Directory (inherited from DirectoryIndexReader) | Returns the directory this index resides in.
DocFreq
Document | Overloaded.
Document (inherited from IndexReader) Overloaded. Returns the stored fields of the
n
th
Document
in this index.
EnsureOpen (inherited from IndexReader)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FieldInfos | Returns the field infos of this segment
Flush (inherited from IndexReader)
foo
GetFieldNames
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexCommit (inherited from DirectoryIndexReader)
GetRefCount (inherited from IndexReader)
GetTermFreqVector | Overloaded. Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.
GetTermFreqVectors | Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.
GetTermInfosIndexDivisor
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion (inherited from DirectoryIndexReader) | Version number when this IndexReader was opened.
HasDeletions
HasNorms
IncRef | Increments the RC of this reader, as well as of all norms this reader is using
IsCurrent (inherited from DirectoryIndexReader) Check whether this IndexReader is still using the current (i.e., most recently committed) version of the index. If a writer has committed any changes to the index since this reader was opened, this will return
false
, in which case you must open a new IndexReader in order to see the changes. See the description of the
autoCommit
 flag which controls when the {@link IndexWriter} actually commits changes to the index.
IsDeleted
IsOptimized (inherited from DirectoryIndexReader) | Checks is the index is optimized (if it has a single segment and no deletions)
MaxDoc
Norms | Overloaded.
NormsClosed | Overloaded.
NumDeletedDocs (inherited from IndexReader) | Returns the number of deleted docs.
NumDocs
Reopen (inherited from DirectoryIndexReader)
SetDeletionPolicy (inherited from DirectoryIndexReader)
SetNorm (inherited from IndexReader) | Overloaded. Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old.
SetTermInfosIndexDivisor
TermDocs | Overloaded.
TermDocs (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermDocs} enumerator.
TermPositions | Overloaded.
TermPositions (inherited from IndexReader) | Overloaded. Returns an unpositioned {@link TermPositions} enumerator.
Terms | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteAll (inherited from IndexReader) | Undeletes all documents currently marked as deleted in this index.

Protected Instance Methods

Finalize (inherited from DirectoryIndexReader) | Release the write lock, if needed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

AcquireWriteLock (inherited from DirectoryIndexReader) | Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner.
CommitChanges |
DoClose |
DoCommit (inherited from DirectoryIndexReader) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
DoDelete |
DoReopen |
DoSetNorm |
DoUndeleteAll |
GetNorms |

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.CommitChanges Method

protected internal override void CommitChanges();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.DecRef Method

public override void DecRef();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.DocFreq Method

public override int DocFreq(
Term t
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.DoClose Method

protected internal override void DoClose();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


Document Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentReader.Document Method

Overload List

Inherited from IndexReader.

public virtual Document Document(int);

public override Document Document(int,FieldSelector);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.Document Method (Int32, FieldSelector)

public override Document Document(
int n,
FieldSelector fieldSelector
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Document Overload List


SegmentReader.DoDelete Method

protected internal override void DoDelete(
int docNum
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.DoReopen Method

protected internal override DirectoryIndexReader DoReopen(
SegmentInfos infos
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.DoSetNorm Method

protected internal override void DoSetNorm(
int doc,
string field,
byte value_Renamed
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.DoUndeleteAll Method

protected internal override void DoUndeleteAll();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.FieldInfos Method

Returns the field infos of this segment

public virtual FieldInfos FieldInfos();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.foo Method

public void foo();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


Get Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentReader.Get Method

Overload List

public static SegmentReader Get(SegmentInfo);

public static SegmentReader Get(SegmentInfo,int);

public static SegmentReader Get(Directory,SegmentInfo,SegmentInfos,bool,bool,int);

public static SegmentReader Get(bool,SegmentInfo);

public static SegmentReader Get(bool,SegmentInfos,SegmentInfo,bool);

public static SegmentReader Get(bool,Directory,SegmentInfo,SegmentInfos,bool,bool,int,bool);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.Get Method (SegmentInfo)

public static SegmentReader Get(
SegmentInfo si
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Get Overload List


SegmentReader.Get Method (SegmentInfo, Int32)

public static SegmentReader Get(
SegmentInfo si,
int readBufferSize
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Get Overload List


SegmentReader.Get Method (Directory, SegmentInfo, SegmentInfos, Boolean, Boolean, Int32)

public static SegmentReader Get(
Directory dir,
SegmentInfo si,
SegmentInfos sis,
bool closeDir,
bool ownDir,
int readBufferSize
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Get Overload List


SegmentReader.Get Method (Boolean, SegmentInfo)

public static SegmentReader Get(
bool readOnly,
SegmentInfo si
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Get Overload List


SegmentReader.Get Method (Boolean, SegmentInfos, SegmentInfo, Boolean)

public static SegmentReader Get(
bool readOnly,
SegmentInfos sis,
SegmentInfo si,
bool closeDir
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Get Overload List


SegmentReader.Get Method (Boolean, Directory, SegmentInfo, SegmentInfos, Boolean, Boolean, Int32, Boolean)

public static SegmentReader Get(
bool readOnly,
Directory dir,
SegmentInfo si,
SegmentInfos sis,
bool closeDir,
bool ownDir,
int readBufferSize,
bool doOpenStores
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Get Overload List


SegmentReader.GetFieldNames Method

public override 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetFieldNames(
FieldOption fieldOption
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | GetFieldNames


SegmentReader.GetNorms Method

protected internal virtual byte[] GetNorms(
string field
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


GetTermFreqVector Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentReader.GetTermFreqVector Method

Overload List

public override void GetTermFreqVector(int,TermVectorMapper);

Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.

public override TermFreqVector GetTermFreqVector(int,string);

public override void GetTermFreqVector(int,string,TermVectorMapper);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.GetTermFreqVector Method (Int32, TermVectorMapper)

public override void GetTermFreqVector(
int docNumber,
TermVectorMapper mapper
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.GetTermFreqVector Overload List


SegmentReader.GetTermFreqVector Method (Int32, String)

Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.

public override TermFreqVector GetTermFreqVector(
int docNumber,
string field
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.GetTermFreqVector Overload List


SegmentReader.GetTermFreqVector Method (Int32, String, TermVectorMapper)

public override void GetTermFreqVector(
int docNumber,
string field,
TermVectorMapper mapper
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.GetTermFreqVector Overload List


SegmentReader.GetTermFreqVectors Method

Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.

public override TermFreqVector[] GetTermFreqVectors(
int docNumber
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.GetTermInfosIndexDivisor Method

public override int GetTermInfosIndexDivisor();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.HasDeletions Method

public override bool HasDeletions();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.HasNorms Method

public override bool HasNorms(
string field
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.IncRef Method

Increments the RC of this reader, as well as of all norms this reader is using

public override void IncRef();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.IsDeleted Method

public override bool IsDeleted(
int n
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.MaxDoc Method

public override int MaxDoc();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


Norms Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentReader.Norms Method

Overload List

public override byte[] Norms(string);

Read norms into a pre-allocated array.

public override void Norms(string,byte[],int);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.Norms Method (String)

public override byte[] Norms(
string field
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Norms Overload List


SegmentReader.Norms Method (String, Byte[], Int32)

Read norms into a pre-allocated array.

public override void Norms(
string field,
byte[] bytes,
int offset
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Norms Overload List


NormsClosed Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentReader.NormsClosed Method

Overload List

public virtual bool NormsClosed();

public virtual bool NormsClosed(string);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.NormsClosed Method ()

public virtual bool NormsClosed();

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.NormsClosed Overload List


SegmentReader.NormsClosed Method (String)

public virtual bool NormsClosed(
string field
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.NormsClosed Overload List


SegmentReader.NumDocs Method

public override int NumDocs();

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.SetTermInfosIndexDivisor Method

public override void SetTermInfosIndexDivisor(
int indexDivisor
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


TermDocs Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentReader.TermDocs Method

Overload List

public override TermDocs TermDocs();

Inherited from IndexReader.

public virtual TermDocs TermDocs(Term);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.TermDocs Method ()

public override TermDocs TermDocs();

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.TermDocs Overload List


TermPositions Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentReader.TermPositions Method

Overload List

public override TermPositions TermPositions();

Inherited from IndexReader.

public virtual TermPositions TermPositions(Term);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.TermPositions Method ()

public override TermPositions TermPositions();

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.TermPositions Overload List


Terms Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentReader.Terms Method

Overload List

public override TermEnum Terms();

public override TermEnum Terms(Term);

See Also

SegmentReader Class | Lucene.Net.Index Namespace


SegmentReader.Terms Method ()

public override TermEnum Terms();

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Terms Overload List


SegmentReader.Terms Method (Term)

public override TermEnum Terms(
Term t
);

See Also

SegmentReader Class | Lucene.Net.Index Namespace | SegmentReader.Terms Overload List


SegmentTermDocs Class

For a list of all members of this type, see SegmentTermDocs Members.

System.Object
Lucene.Net.Index.SegmentTermDocs
Lucene.Net.Index.SegmentTermPositions

public class SegmentTermDocs : TermDocs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentTermDocs Members | Lucene.Net.Index Namespace


SegmentTermDocs Members

SegmentTermDocs overview

Public Instance Constructors

SegmentTermDocs Constructor

Public Instance Properties

FreqStream_ForNUnitTest

Public Instance Methods

Close |
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Read | Optimized implementation.
Seek | Overloaded.
SkipTo | Optimized implementation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

count
currentFieldOmitTf
currentFieldStoresPayloads
deletedDocs
df
freqStream
parent

Protected Internal Instance Methods

SkippingDoc |
SkipProx | Overloaded. Overridden by SegmentTermPositions to skip in prox stream.

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs Constructor

public SegmentTermDocs(
SegmentReader parent
);

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs Fields

The fields of the SegmentTermDocs class are listed below. For a complete list of SegmentTermDocs class members, see the SegmentTermDocs Members topic.

Protected Internal Instance Fields

count
currentFieldOmitTf
currentFieldStoresPayloads
deletedDocs
df
freqStream
parent

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.count Field

protected internal int count;

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.currentFieldOmitTf Field

protected internal bool currentFieldOmitTf;

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.currentFieldStoresPayloads Field

protected internal bool currentFieldStoresPayloads;

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.deletedDocs Field

protected internal BitVector deletedDocs;

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.df Field

protected internal int df;

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.freqStream Field

protected internal IndexInput freqStream;

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.parent Field

protected internal SegmentReader parent;

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs Properties

The properties of the SegmentTermDocs class are listed below. For a complete list of SegmentTermDocs class members, see the SegmentTermDocs Members topic.

Public Instance Properties

FreqStream_ForNUnitTest

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


FreqStream_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

SegmentTermDocs.FreqStream_ForNUnitTest Property

public Lucene.Net.Store.IndexInput FreqStream_ForNUnitTest {get; set;}

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs Methods

The methods of the SegmentTermDocs class are listed below. For a complete list of SegmentTermDocs class members, see the SegmentTermDocs Members topic.

Public Instance Methods

Close |
Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Read | Optimized implementation.
Seek | Overloaded.
SkipTo | Optimized implementation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SkippingDoc |
SkipProx | Overloaded. Overridden by SegmentTermPositions to skip in prox stream.

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.Close Method

public virtual void Close();

Implements

TermDocs.Close

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.Doc Method

public int Doc();

Implements

TermDocs.Doc

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.Freq Method

public int Freq();

Implements

TermDocs.Freq

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.Next Method

public virtual bool Next();

Implements

TermDocs.Next

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.Read Method

Optimized implementation.

public virtual int Read(
int[] docs,
int[] freqs
);

Implements

TermDocs.Read

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


Seek Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentTermDocs.Seek Method

Overload List

public virtual void Seek(Term);

public virtual void Seek(TermEnum);

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.Seek Method (Term)

public virtual void Seek(
Term term
);

Implements

TermDocs.Seek

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace | SegmentTermDocs.Seek Overload List


SegmentTermDocs.Seek Method (TermEnum)

public virtual void Seek(
TermEnum termEnum
);

Implements

TermDocs.Seek

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace | SegmentTermDocs.Seek Overload List


SegmentTermDocs.SkippingDoc Method

protected internal virtual void SkippingDoc();

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SkipProx Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentTermDocs.SkipProx Method

Overridden by SegmentTermPositions to skip in prox stream.

Overload List

Overridden by SegmentTermPositions to skip in prox stream.

protected internal virtual void SkipProx(long);

protected internal virtual void SkipProx(long,int);

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermDocs.SkipProx Method (Int64)

Overridden by SegmentTermPositions to skip in prox stream.

protected internal virtual void SkipProx(
long proxPointer
);

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace | SegmentTermDocs.SkipProx Overload List


SegmentTermDocs.SkipProx Method (Int64, Int32)

protected internal virtual void SkipProx(
long proxPointer,
int payloadLength
);

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace | SegmentTermDocs.SkipProx Overload List


SegmentTermDocs.SkipTo Method

Optimized implementation.

public virtual bool SkipTo(
int target
);

Implements

TermDocs.SkipTo

See Also

SegmentTermDocs Class | Lucene.Net.Index Namespace


SegmentTermEnum Class

For a list of all members of this type, see SegmentTermEnum Members.

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Index.SegmentTermEnum

public sealed class SegmentTermEnum : TermEnum, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentTermEnum Members | Lucene.Net.Index Namespace


SegmentTermEnum Members

SegmentTermEnum overview

Public Instance Methods

Clone |
Close | Closes the enumeration to further activity, freeing resources.
DocFreq | Returns the docFreq from the current TermInfo in the enumeration. Initially invalid, valid after next() called for the first time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Increments the enumeration to the next element. True if one exists.
Prev | Returns the previous Term enumerated. Initially null.
SkipTo (inherited from TermEnum) |
Term | Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum Methods

The methods of the SegmentTermEnum class are listed below. For a complete list of SegmentTermEnum class members, see the SegmentTermEnum Members topic.

Public Instance Methods

Clone |
Close | Closes the enumeration to further activity, freeing resources.
DocFreq | Returns the docFreq from the current TermInfo in the enumeration. Initially invalid, valid after next() called for the first time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Increments the enumeration to the next element. True if one exists.
Prev | Returns the previous Term enumerated. Initially null.
SkipTo (inherited from TermEnum) |
Term | Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum.Clone Method

public object Clone();

Implements

ICloneable.Clone

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum.Close Method

Closes the enumeration to further activity, freeing resources.

public override void Close();

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum.DocFreq Method

Returns the docFreq from the current TermInfo in the enumeration. Initially invalid, valid after next() called for the first time.

public override int DocFreq();

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum.Next Method

Increments the enumeration to the next element. True if one exists.

public override bool Next();

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum.Prev Method

Returns the previous Term enumerated. Initially null.

public Term Prev();

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermEnum.Term Method

Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.

public override Term Term();

See Also

SegmentTermEnum Class | Lucene.Net.Index Namespace


SegmentTermPositions Class

For a list of all members of this type, see SegmentTermPositions Members.

System.Object
Lucene.Net.Index.SegmentTermDocs
Lucene.Net.Index.SegmentTermPositions

public sealed class SegmentTermPositions : SegmentTermDocs, TermPositions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentTermPositions Members | Lucene.Net.Index Namespace


SegmentTermPositions Members

SegmentTermPositions overview

Public Instance Properties

FreqStream_ForNUnitTest (inherited from SegmentTermDocs)

Public Instance Methods

Close |
Doc (inherited from SegmentTermDocs) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq (inherited from SegmentTermDocs) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPayload |
GetPayloadLength |
GetType (inherited from Object) | Gets the Type of the current instance.
IsPayloadAvailable |
Next |
NextPosition |
Read |
Seek (inherited from SegmentTermDocs) | Overloaded.
SkipTo (inherited from SegmentTermDocs) | Optimized implementation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

count (inherited from SegmentTermDocs)
currentFieldOmitTf (inherited from SegmentTermDocs)
currentFieldStoresPayloads (inherited from SegmentTermDocs)
deletedDocs (inherited from SegmentTermDocs)
df (inherited from SegmentTermDocs)
freqStream (inherited from SegmentTermDocs)
parent (inherited from SegmentTermDocs)

Protected Internal Instance Methods

SkippingDoc |
SkipProx | Overloaded. Called by super.skipTo().
SkipProx (inherited from SegmentTermDocs) | Overloaded. Overridden by SegmentTermPositions to skip in prox stream.

See Also

SegmentTermPositions Class | Lucene.Net.Index Namespace


SegmentTermPositions Methods

The methods of the SegmentTermPositions class are listed below. For a complete list of SegmentTermPositions class members, see the SegmentTermPositions Members topic.

Public Instance Methods

Close |
Doc (inherited from SegmentTermDocs) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Freq (inherited from SegmentTermDocs) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPayload |
GetPayloadLength |
GetType (inherited from Object) | Gets the Type of the current instance.
IsPayloadAvailable |
Next |
NextPosition |
Read |
Seek (inherited from SegmentTermDocs) | Overloaded.
SkipTo (inherited from SegmentTermDocs) | Optimized implementation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

SkippingDoc |
SkipProx | Overloaded. Called by super.skipTo().
SkipProx (inherited from SegmentTermDocs) | Overloaded. Overridden by SegmentTermPositions to skip in prox stream.

See Also

SegmentTermPositions Class | Lucene.Net.Index Namespace


SegmentTermPositions.Close Method

public override void Close();

Implements

TermDocs.Close

See Also

SegmentTermPositions Class | Lucene.Net.Index Namespace


SegmentTermPositions.GetPayload Method

public byte[] GetPayload(
byte[] data,
int offset
);

Implements

TermPositions.GetPayload

See Also

SegmentTermPositions Class | Lucene.Net.Index Namespace


SegmentTermPositions.GetPayloadLength Method

public int GetPayloadLength();

Implements

TermPositions.GetPayloadLength

See Also

SegmentTermPositions Class | Lucene.Net.Index Namespace


SegmentTermPositions.IsPayloadAvailable Method

public bool IsPayloadAvailable();

Implements

TermPositions.IsPayloadAvailable

See Also

SegmentTermPositions Class | Lucene.Net.Index Namespace


SegmentTermPositions.Next Method

public override bool Next();

Implements

TermDocs.Next

See Also

SegmentTermPositions Class | Lucene.Net.Index Namespace


SegmentTermPositions.NextPosition Method

public int NextPosition();

Implements

TermPositions.NextPosition

See Also

SegmentTermPositions Class | Lucene.Net.Index Namespace


SegmentTermPositions.Read Method

public override int Read(
int[] docs,
int[] freqs
);

Implements

TermDocs.Read

See Also

SegmentTermPositions Class | Lucene.Net.Index Namespace


SegmentTermPositions.SkippingDoc Method

protected internal override void SkippingDoc();

See Also

SegmentTermPositions Class | Lucene.Net.Index Namespace


SkipProx Method

Apache Lucene.Net 2.4.0 Class Library API

SegmentTermPositions.SkipProx Method

Called by super.skipTo().

Overload List

Inherited from SegmentTermDocs.

protected internal virtual void SkipProx(long);

Called by super.skipTo().

protected internal override void SkipProx(long,int);

See Also

SegmentTermPositions Class | Lucene.Net.Index Namespace


SegmentTermPositions.SkipProx Method (Int64, Int32)

Called by super.skipTo().

protected internal override void SkipProx(
long proxPointer,
int payloadLength
);

See Also

SegmentTermPositions Class | Lucene.Net.Index Namespace | SegmentTermPositions.SkipProx Overload List


SegmentTermVector Class

For a list of all members of this type, see SegmentTermVector Members.

System.Object
Lucene.Net.Index.SegmentTermVector

public class SegmentTermVector : TermFreqVector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SegmentTermVector Members | Lucene.Net.Index Namespace


SegmentTermVector Members

SegmentTermVector overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetField |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTermFrequencies |
GetTerms |
GetType (inherited from Object) | Gets the Type of the current instance.
IndexesOf |
IndexOf |
Size |
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SegmentTermVector Class | Lucene.Net.Index Namespace


SegmentTermVector Methods

The methods of the SegmentTermVector class are listed below. For a complete list of SegmentTermVector class members, see the SegmentTermVector Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetField |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTermFrequencies |
GetTerms |
GetType (inherited from Object) | Gets the Type of the current instance.
IndexesOf |
IndexOf |
Size |
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SegmentTermVector Class | Lucene.Net.Index Namespace


SegmentTermVector.GetField Method

public virtual string GetField();

Return Value

The number of the field this vector is associated with

Implements

TermFreqVector.GetField

See Also

SegmentTermVector Class | Lucene.Net.Index Namespace


SegmentTermVector.GetTermFrequencies Method

public virtual int[] GetTermFrequencies();

Implements

TermFreqVector.GetTermFrequencies

See Also

SegmentTermVector Class | Lucene.Net.Index Namespace


SegmentTermVector.GetTerms Method

public virtual string[] GetTerms();

Implements

TermFreqVector.GetTerms

See Also

SegmentTermVector Class | Lucene.Net.Index Namespace


SegmentTermVector.IndexesOf Method

public virtual int[] IndexesOf(
string[] termNumbers,
int start,
int len
);

Implements

TermFreqVector.IndexesOf

See Also

SegmentTermVector Class | Lucene.Net.Index Namespace


SegmentTermVector.IndexOf Method

public virtual int IndexOf(
string termText
);

Implements

TermFreqVector.IndexOf

See Also

SegmentTermVector Class | Lucene.Net.Index Namespace


SegmentTermVector.Size Method

public virtual int Size();

Implements

TermFreqVector.Size

See Also

SegmentTermVector Class | Lucene.Net.Index Namespace


SegmentTermVector.ToString Method

public override string ToString();

See Also

SegmentTermVector Class | Lucene.Net.Index Namespace


SerialMergeScheduler Class

A {@link MergeScheduler} that simply does each merge sequentially, using the current thread.

For a list of all members of this type, see SerialMergeScheduler Members.

System.Object
Lucene.Net.Index.MergeScheduler
Lucene.Net.Index.SerialMergeScheduler

public class SerialMergeScheduler : MergeScheduler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SerialMergeScheduler Members | Lucene.Net.Index Namespace


SerialMergeScheduler Members

SerialMergeScheduler overview

Public Instance Constructors

SerialMergeScheduler Constructor Initializes a new instance of the SerialMergeScheduler class.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Just do the merges in sequence. We do this "synchronized" so that even if the application is using multiple threads, only one merge may run at a time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SerialMergeScheduler Class | Lucene.Net.Index Namespace


SerialMergeScheduler Constructor

Initializes a new instance of the SerialMergeScheduler class.

public SerialMergeScheduler();

See Also

SerialMergeScheduler Class | Lucene.Net.Index Namespace


SerialMergeScheduler Methods

The methods of the SerialMergeScheduler class are listed below. For a complete list of SerialMergeScheduler class members, see the SerialMergeScheduler Members topic.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Just do the merges in sequence. We do this "synchronized" so that even if the application is using multiple threads, only one merge may run at a time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SerialMergeScheduler Class | Lucene.Net.Index Namespace


SerialMergeScheduler.Close Method

public override void Close();

See Also

SerialMergeScheduler Class | Lucene.Net.Index Namespace


SerialMergeScheduler.Merge Method

Just do the merges in sequence. We do this "synchronized" so that even if the application is using multiple threads, only one merge may run at a time.

public override void Merge(
IndexWriter writer
);

See Also

SerialMergeScheduler Class | Lucene.Net.Index Namespace


SnapshotDeletionPolicy Class

A {@link IndexDeletionPolicy} that wraps around any other {@link IndexDeletionPolicy} and adds the ability to hold and later release a single "snapshot" of an index. While the snapshot is held, the {@link IndexWriter} will not remove any files associated with it even if the index is otherwise being actively, arbitrarily changed. Because we wrap another arbitrary {@link IndexDeletionPolicy}, this gives you the freedom to continue using whatever {@link IndexDeletionPolicy} you would normally want to use with your index. Note that you can re-use a single instance of SnapshotDeletionPolicy across multiple writers as long as they are against the same index Directory. Any snapshot held when a writer is closed will "survive" when the next writer is opened.

WARNING: This API is new and experimental and may suddnely changendex.

For a list of all members of this type, see SnapshotDeletionPolicy Members.

System.Object
Lucene.Net.Index.SnapshotDeletionPolicy

public class SnapshotDeletionPolicy : IndexDeletionPolicy

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SnapshotDeletionPolicy Members | Lucene.Net.Index Namespace


SnapshotDeletionPolicy Members

SnapshotDeletionPolicy overview

Public Instance Constructors

SnapshotDeletionPolicy Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnCommit |
OnInit |
Release | Release the currently held snapshot.
Snapshot | Take a snapshot of the most recent commit to the index. You must call release() to free this snapshot. Note that while the snapshot is held, the files it references will not be deleted, which will consume additional disk space in your index. If you take a snapshot at a particularly bad time (say just before you call optimize()) then in the worst case this could consume an extra 1X of your total index size, until you release the snapshot.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SnapshotDeletionPolicy Class | Lucene.Net.Index Namespace


SnapshotDeletionPolicy Constructor

public SnapshotDeletionPolicy(
IndexDeletionPolicy primary
);

See Also

SnapshotDeletionPolicy Class | Lucene.Net.Index Namespace


SnapshotDeletionPolicy Methods

The methods of the SnapshotDeletionPolicy class are listed below. For a complete list of SnapshotDeletionPolicy class members, see the SnapshotDeletionPolicy Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnCommit |
OnInit |
Release | Release the currently held snapshot.
Snapshot | Take a snapshot of the most recent commit to the index. You must call release() to free this snapshot. Note that while the snapshot is held, the files it references will not be deleted, which will consume additional disk space in your index. If you take a snapshot at a particularly bad time (say just before you call optimize()) then in the worst case this could consume an extra 1X of your total index size, until you release the snapshot.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SnapshotDeletionPolicy Class | Lucene.Net.Index Namespace


SnapshotDeletionPolicy.OnCommit Method

public virtual void OnCommit(
2, Culture=neutral, PublicKeyToken=null]] commits
);

Implements

IndexDeletionPolicy.OnCommit

See Also

SnapshotDeletionPolicy Class | Lucene.Net.Index Namespace


SnapshotDeletionPolicy.OnInit Method

public virtual void OnInit(
2, Culture=neutral, PublicKeyToken=null]] commits
);

Implements

IndexDeletionPolicy.OnInit

See Also

SnapshotDeletionPolicy Class | Lucene.Net.Index Namespace


SnapshotDeletionPolicy.Release Method

Release the currently held snapshot.

public virtual void Release();

See Also

SnapshotDeletionPolicy Class | Lucene.Net.Index Namespace


SnapshotDeletionPolicy.Snapshot Method

Take a snapshot of the most recent commit to the index. You must call release() to free this snapshot. Note that while the snapshot is held, the files it references will not be deleted, which will consume additional disk space in your index. If you take a snapshot at a particularly bad time (say just before you call optimize()) then in the worst case this could consume an extra 1X of your total index size, until you release the snapshot.

public virtual IndexCommitPoint Snapshot();

See Also

SnapshotDeletionPolicy Class | Lucene.Net.Index Namespace


SortedTermVectorMapper Class

Store a sorted collection of {@link Lucene.Net.Index.TermVectorEntry}s. Collects all term information into a single, SortedSet.
NOTE: This Mapper ignores all Field information for the Document. This means that if you are using offset/positions you will not know what Fields they correlate with.
This is not thread-safe

For a list of all members of this type, see SortedTermVectorMapper Members.

System.Object
Lucene.Net.Index.TermVectorMapper
Lucene.Net.Index.SortedTermVectorMapper

public class SortedTermVectorMapper : TermVectorMapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SortedTermVectorMapper Members | Lucene.Net.Index Namespace


SortedTermVectorMapper Members

SortedTermVectorMapper overview

Public Static Fields

ALL Stand-in name for the field in {@link TermVectorEntry}.

Public Instance Constructors

SortedTermVectorMapper Overloaded. Initializes a new instance of the SortedTermVectorMapper class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTermVectorEntrySet | The TermVectorEntrySet. A SortedSet of {@link TermVectorEntry} objects. Sort is by the comparator passed into the constructor. This set will be empty until after the mapping process takes place.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIgnoringOffsets (inherited from TermVectorMapper) |
IsIgnoringPositions (inherited from TermVectorMapper) | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.
Map |
SetDocumentNumber (inherited from TermVectorMapper) | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
SetExpectations |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortedTermVectorMapper Class | Lucene.Net.Index Namespace


SortedTermVectorMapper Constructor

Overload List

public SortedTermVectorMapper(bool,bool,0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]);

public SortedTermVectorMapper(0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]);

See Also

SortedTermVectorMapper Class | Lucene.Net.Index Namespace


SortedTermVectorMapper Constructor (0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])

public SortedTermVectorMapper(
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] comparator
);

See Also

SortedTermVectorMapper Class | Lucene.Net.Index Namespace | SortedTermVectorMapper Constructor Overload List


SortedTermVectorMapper Constructor (Boolean, Boolean, 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])

public SortedTermVectorMapper(
bool ignoringPositions,
bool ignoringOffsets,
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] comparator
);

See Also

SortedTermVectorMapper Class | Lucene.Net.Index Namespace | SortedTermVectorMapper Constructor Overload List


SortedTermVectorMapper Fields

The fields of the SortedTermVectorMapper class are listed below. For a complete list of SortedTermVectorMapper class members, see the SortedTermVectorMapper Members topic.

Public Static Fields

ALL Stand-in name for the field in {@link TermVectorEntry}.

See Also

SortedTermVectorMapper Class | Lucene.Net.Index Namespace


SortedTermVectorMapper.ALL Field

Stand-in name for the field in {@link TermVectorEntry}.

public const string ALL = "_ALL_";

See Also

SortedTermVectorMapper Class | Lucene.Net.Index Namespace


SortedTermVectorMapper Methods

The methods of the SortedTermVectorMapper class are listed below. For a complete list of SortedTermVectorMapper class members, see the SortedTermVectorMapper Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTermVectorEntrySet | The TermVectorEntrySet. A SortedSet of {@link TermVectorEntry} objects. Sort is by the comparator passed into the constructor. This set will be empty until after the mapping process takes place.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIgnoringOffsets (inherited from TermVectorMapper) |
IsIgnoringPositions (inherited from TermVectorMapper) | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.
Map |
SetDocumentNumber (inherited from TermVectorMapper) | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
SetExpectations |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortedTermVectorMapper Class | Lucene.Net.Index Namespace


SortedTermVectorMapper.GetTermVectorEntrySet Method

The TermVectorEntrySet. A SortedSet of {@link TermVectorEntry} objects. Sort is by the comparator passed into the constructor.
This set will be empty until after the mapping process takes place.

public virtual 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetTermVectorEntrySet();

Return Value

The SortedSet of {@link TermVectorEntry}.

See Also

SortedTermVectorMapper Class | Lucene.Net.Index Namespace


SortedTermVectorMapper.Map Method

public override void Map(
string term,
int frequency,
TermVectorOffsetInfo[] offsets,
int[] positions
);

Parameters

term
The term to map
frequency
The frequency of the term
offsets
Offset information, may be null
positions
Position information, may be null

See Also

SortedTermVectorMapper Class | Lucene.Net.Index Namespace


SortedTermVectorMapper.SetExpectations Method

public override void SetExpectations(
string field,
int numTerms,
bool storeOffsets,
bool storePositions
);

See Also

SortedTermVectorMapper Class | Lucene.Net.Index Namespace


StaleReaderException Class

This exception is thrown when an {@link IndexReader} tries to make changes to the index (via {@link IndexReader#deleteDocument}, {@link IndexReader#undeleteAll} or {@link IndexReader#setNorm}) but changes have already been committed to the index since this reader was instantiated. When this happens you must open a new reader on the current index to make the changes.

For a list of all members of this type, see StaleReaderException Members.

System.Object
System.Exception
System.SystemException
System.IO.IOException
Lucene.Net.Index.StaleReaderException

public class StaleReaderException : IOException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StaleReaderException Members | Lucene.Net.Index Namespace


StaleReaderException Members

StaleReaderException overview

Public Instance Constructors

StaleReaderException Constructor

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StaleReaderException Class | Lucene.Net.Index Namespace


StaleReaderException Constructor

public StaleReaderException(
string message
);

See Also

StaleReaderException Class | Lucene.Net.Index Namespace


Term Class

A Term represents a word from text. This is the unit of search. It is composed of two elements, the text of the word, as a string, and the name of the field that the text occured in, an interned string. Note that terms may represent more than words from text fields, but also things like dates, email addresses, urls, etc.

For a list of all members of this type, see Term Members.

System.Object
Lucene.Net.Index.Term

public sealed class Term : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Term Members | Lucene.Net.Index Namespace


Term Members

Term overview

Public Instance Constructors

Term Overloaded. Initializes a new instance of the Term class.

Public Instance Properties

text_ForNUnitTest

Public Instance Methods

CompareTo | Overloaded.
CreateTerm | Optimized construction of new Terms by reusing same field as this Term - avoids field.intern() overhead
Equals | Compares two terms, returning true iff they have the same field and text.
Field | Returns the field of this term, an interned string. The field indicates the part of a document which this term came from.
GetHashCode | Combines the hashCode() of the field and the text.
GetobjectData |
GetType (inherited from Object) | Gets the Type of the current instance.
Text | Returns the text of this term. In the case of words, this is simply the text of the word. In the case of dates and other types, this is an encoding of the object as a string.
ToString |

See Also

Term Class | Lucene.Net.Index Namespace


Term Constructor

Overload List

Constructs a Term with the given field and empty text. This serves 2 purposes: 1) reuse of a Term with the same field 2) pattern for a query

public Term(string);

public Term(string,string);

See Also

Term Class | Lucene.Net.Index Namespace


Term Constructor (String, String)

public Term(
string fld,
string txt
);

See Also

Term Class | Lucene.Net.Index Namespace | Term Constructor Overload List


Term Constructor (String)

Constructs a Term with the given field and empty text. This serves 2 purposes: 1) reuse of a Term with the same field 2) pattern for a query

public Term(
string fld
);

Parameters

fld

See Also

Term Class | Lucene.Net.Index Namespace | Term Constructor Overload List


Term Properties

The properties of the Term class are listed below. For a complete list of Term class members, see the Term Members topic.

Public Instance Properties

text_ForNUnitTest

See Also

Term Class | Lucene.Net.Index Namespace


text_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

Term.text_ForNUnitTest Property

public string text_ForNUnitTest {get;}

See Also

Term Class | Lucene.Net.Index Namespace


Term Methods

The methods of the Term class are listed below. For a complete list of Term class members, see the Term Members topic.

Public Instance Methods

CompareTo | Overloaded.
CreateTerm | Optimized construction of new Terms by reusing same field as this Term - avoids field.intern() overhead
Equals | Compares two terms, returning true iff they have the same field and text.
Field | Returns the field of this term, an interned string. The field indicates the part of a document which this term came from.
GetHashCode | Combines the hashCode() of the field and the text.
GetobjectData |
GetType (inherited from Object) | Gets the Type of the current instance.
Text | Returns the text of this term. In the case of words, this is simply the text of the word. In the case of dates and other types, this is an encoding of the object as a string.
ToString |

See Also

Term Class | Lucene.Net.Index Namespace


CompareTo Method

Apache Lucene.Net 2.4.0 Class Library API

Term.CompareTo Method

Compares two terms, returning a negative integer if this term belongs before the argument, zero if this term is equal to the argument, and a positive integer if this term belongs after the argument. The ordering of terms is first by field, then by text.

Overload List

Compares two terms, returning a negative integer if this term belongs before the argument, zero if this term is equal to the argument, and a positive integer if this term belongs after the argument. The ordering of terms is first by field, then by text.

public int CompareTo(Term);

public int CompareTo(object);

See Also

Term Class | Lucene.Net.Index Namespace


Term.CompareTo Method (Term)

Compares two terms, returning a negative integer if this term belongs before the argument, zero if this term is equal to the argument, and a positive integer if this term belongs after the argument. The ordering of terms is first by field, then by text.

public int CompareTo(
Term other
);

See Also

Term Class | Lucene.Net.Index Namespace | Term.CompareTo Overload List


Term.CompareTo Method (Object)

public int CompareTo(
object other
);

Implements

IComparable.CompareTo

See Also

Term Class | Lucene.Net.Index Namespace | Term.CompareTo Overload List


Term.CreateTerm Method

Optimized construction of new Terms by reusing same field as this Term - avoids field.intern() overhead

public Term CreateTerm(
string text
);

Parameters

text
The text of the new term (field is implicitly same as this Term instance)

Return Value

A new Term

See Also

Term Class | Lucene.Net.Index Namespace


Term.Equals Method

Compares two terms, returning true iff they have the same field and text.

public override bool Equals(
object o
);

See Also

Term Class | Lucene.Net.Index Namespace


Term.Field Method

Returns the field of this term, an interned string. The field indicates the part of a document which this term came from.

public string Field();

See Also

Term Class | Lucene.Net.Index Namespace


Term.GetHashCode Method

Combines the hashCode() of the field and the text.

public override int GetHashCode();

See Also

Term Class | Lucene.Net.Index Namespace


Term.GetobjectData Method

public void GetobjectData(
SerializationInfo info,
StreamingContext context
);

See Also

Term Class | Lucene.Net.Index Namespace


Term.Text Method

Returns the text of this term. In the case of words, this is simply the text of the word. In the case of dates and other types, this is an encoding of the object as a string.

public string Text();

See Also

Term Class | Lucene.Net.Index Namespace


Term.ToString Method

public override string ToString();

See Also

Term Class | Lucene.Net.Index Namespace


TermDocs Interface

For a list of all members of this type, see TermDocs Members.

Lucene.Net.Index.TermDocs
Lucene.Net.Index.TermPositions

public interface TermDocs

Types that implement TermDocs

Type | Description
FilterIndexReader.FilterTermDocs | Base class for filtering {@link TermDocs} implementations.
FilterIndexReader.FilterTermPositions | Base class for filtering {@link TermPositions} implementations.
MultipleTermPositions Describe class
MultipleTermPositions
here.
SegmentTermDocs
SegmentTermPositions

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermDocs Members | Lucene.Net.Index Namespace


TermDocs Members

TermDocs overview

Public Instance Methods

Close | Frees associated resources.
Doc |
Freq |
Next |
Read |
Seek | Overloaded. Sets this to the data for a term. The enumeration is reset to the start of the data for this term.
SkipTo |

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs Methods

The methods of the TermDocs interface are listed below. For a complete list of TermDocs interface members, see the TermDocs Members topic.

Public Instance Methods

Close | Frees associated resources.
Doc |
Freq |
Next |
Read |
Seek | Overloaded. Sets this to the data for a term. The enumeration is reset to the start of the data for this term.
SkipTo |

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs.Close Method

Frees associated resources.

void Close();

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs.Doc Method

int Doc();

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs.Freq Method

int Freq();

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs.Next Method

bool Next();

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs.Read Method

int Read(
int[] docs,
int[] freqs
);

See Also

TermDocs Interface | Lucene.Net.Index Namespace


Seek Method

Apache Lucene.Net 2.4.0 Class Library API

TermDocs.Seek Method

Sets this to the data for a term. The enumeration is reset to the start of the data for this term.

Overload List

Sets this to the data for a term. The enumeration is reset to the start of the data for this term.

void Seek(Term);

Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations.

void Seek(TermEnum);

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermDocs.Seek Method (Term)

Sets this to the data for a term. The enumeration is reset to the start of the data for this term.

void Seek(
Term term
);

See Also

TermDocs Interface | Lucene.Net.Index Namespace | TermDocs.Seek Overload List


TermDocs.Seek Method (TermEnum)

Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations.

void Seek(
TermEnum termEnum
);

See Also

TermDocs Interface | Lucene.Net.Index Namespace | TermDocs.Seek Overload List


TermDocs.SkipTo Method

bool SkipTo(
int target
);

See Also

TermDocs Interface | Lucene.Net.Index Namespace


TermEnum Class

For a list of all members of this type, see TermEnum Members.

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Index.FilterIndexReader.FilterTermEnum
Lucene.Net.Index.SegmentTermEnum
Lucene.Net.Search.FilteredTermEnum

public abstract class TermEnum

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermEnum Members | Lucene.Net.Index Namespace


TermEnum Members

TermEnum overview

Public Instance Methods

Close | Closes the enumeration to further activity, freeing resources.
DocFreq | Returns the docFreq of the current Term in the enumeration.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Increments the enumeration to the next element. True if one exists.
SkipTo |
Term | Returns the current Term in the enumeration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

TermEnum Constructor Initializes a new instance of the TermEnum class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum Constructor

Initializes a new instance of the TermEnum class.

protected TermEnum();

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum Methods

The methods of the TermEnum class are listed below. For a complete list of TermEnum class members, see the TermEnum Members topic.

Public Instance Methods

Close | Closes the enumeration to further activity, freeing resources.
DocFreq | Returns the docFreq of the current Term in the enumeration.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Increments the enumeration to the next element. True if one exists.
SkipTo |
Term | Returns the current Term in the enumeration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum.Close Method

Closes the enumeration to further activity, freeing resources.

public abstract void Close();

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum.DocFreq Method

Returns the docFreq of the current Term in the enumeration.

public abstract int DocFreq();

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum.Next Method

Increments the enumeration to the next element. True if one exists.

public abstract bool Next();

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum.SkipTo Method

public virtual bool SkipTo(
Term target
);

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermEnum.Term Method

Returns the current Term in the enumeration.

public abstract Term Term();

See Also

TermEnum Class | Lucene.Net.Index Namespace


TermFreqVector Interface

Provides access to stored term vector of a document field. The vector consists of the name of the field, an array of the terms tha occur in the field of the {@link Lucene.Net.Documents.Document} and a parallel array of frequencies. Thus, getTermFrequencies()[5] corresponds with the frequency of getTerms()[5], assuming there are at least 5 terms in the Document.

For a list of all members of this type, see TermFreqVector Members.

Lucene.Net.Index.TermFreqVector
Lucene.Net.Index.TermPositionVector

public interface TermFreqVector

Types that implement TermFreqVector

Type | Description
SegmentTermVector |
QueryTermVector |

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermFreqVector Members | Lucene.Net.Index Namespace


TermFreqVector Members

TermFreqVector overview

Public Instance Methods

GetField The {@link Lucene.Net.Documents.Fieldable} name.
GetTermFrequencies Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from
getTerms
method. Each location in the array contains the number of times this term occurs in the document or the document field.
GetTerms
IndexesOf Just like
indexOf(int)
but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.
IndexOf Return an index in the term numbers array returned from
getTerms
at which the term with the specified
term
appears. If this term does not appear in the array, return -1.
Size

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector Methods

The methods of the TermFreqVector interface are listed below. For a complete list of TermFreqVector interface members, see the TermFreqVector Members topic.

Public Instance Methods

GetField The {@link Lucene.Net.Documents.Fieldable} name.
GetTermFrequencies Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from
getTerms
method. Each location in the array contains the number of times this term occurs in the document or the document field.
GetTerms
IndexesOf Just like
indexOf(int)
but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.
IndexOf Return an index in the term numbers array returned from
getTerms
at which the term with the specified
term
appears. If this term does not appear in the array, return -1.
Size

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector.GetField Method

The {@link Lucene.Net.Documents.Fieldable} name.

string GetField();

Return Value

The name of the field this vector is associated with.

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector.GetTermFrequencies Method

Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from

getTerms
method. Each location in the array contains the number of times this term occurs in the document or the document field.

int[] GetTermFrequencies();

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector.GetTerms Method

string[] GetTerms();

Return Value

An Array of term texts in ascending order.

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector.IndexesOf Method

Just like

indexOf(int)
but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.

int[] IndexesOf(
string[] terms,
int start,
int len
);

Parameters

terms
array containing terms to look for
start
index in the array where the list of terms starts
len
the number of terms in the list

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector.IndexOf Method

Return an index in the term numbers array returned from

getTerms
at which the term with the specified
term
appears. If this term does not appear in the array, return -1.

int IndexOf(
string term
);

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermFreqVector.Size Method

int Size();

Return Value

The number of terms in the term vector.

See Also

TermFreqVector Interface | Lucene.Net.Index Namespace


TermInfo Class

A TermInfo is the record of information stored for a term.

For a list of all members of this type, see TermInfo Members.

System.Object
Lucene.Net.Index.TermInfo

public sealed class TermInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermInfo Members | Lucene.Net.Index Namespace


TermInfo Members

TermInfo overview

Public Instance Constructors

TermInfo Constructor

Public Instance Fields

docFreq | The number of documents which contain the term.
freqPointer |
proxPointer |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermInfo Class | Lucene.Net.Index Namespace


TermInfo Constructor

public TermInfo(
int df,
long fp,
long pp
);

See Also

TermInfo Class | Lucene.Net.Index Namespace


TermInfo Fields

The fields of the TermInfo class are listed below. For a complete list of TermInfo class members, see the TermInfo Members topic.

Public Instance Fields

docFreq | The number of documents which contain the term.
freqPointer |
proxPointer |

See Also

TermInfo Class | Lucene.Net.Index Namespace


TermInfo.docFreq Field

The number of documents which contain the term.

public int docFreq;

See Also

TermInfo Class | Lucene.Net.Index Namespace


TermInfo.freqPointer Field

public long freqPointer;

See Also

TermInfo Class | Lucene.Net.Index Namespace


TermInfo.proxPointer Field

public long proxPointer;

See Also

TermInfo Class | Lucene.Net.Index Namespace


TermInfosReader Class

For a list of all members of this type, see TermInfosReader Members.

System.Object
Lucene.Net.Index.TermInfosReader

public sealed class TermInfosReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermInfosReader Members | Lucene.Net.Index Namespace


TermInfosReader Members

TermInfosReader overview

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Returns the TermInfo for a Term in the set, or null.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexDivisor | Returns the indexDivisor.
GetMaxSkipLevels |
GetSkipInterval |
GetType (inherited from Object) | Gets the Type of the current instance.
SetIndexDivisor | Sets the indexDivisor, which subsamples the number of indexed terms loaded into memory. This has a similar effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown. + @throws IllegalStateException if the term index has already been loaded into memory.
Terms | Overloaded. Returns an enumeration of all the Terms and TermInfos in the set.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader Methods

The methods of the TermInfosReader class are listed below. For a complete list of TermInfosReader class members, see the TermInfosReader Members topic.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Returns the TermInfo for a Term in the set, or null.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexDivisor | Returns the indexDivisor.
GetMaxSkipLevels |
GetSkipInterval |
GetType (inherited from Object) | Gets the Type of the current instance.
SetIndexDivisor | Sets the indexDivisor, which subsamples the number of indexed terms loaded into memory. This has a similar effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown. + @throws IllegalStateException if the term index has already been loaded into memory.
Terms | Overloaded. Returns an enumeration of all the Terms and TermInfos in the set.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader.Close Method

public void Close();

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader.Get Method

Returns the TermInfo for a Term in the set, or null.

public TermInfo Get(
Term term,
bool useCache
);

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader.GetIndexDivisor Method

Returns the indexDivisor.

public int GetIndexDivisor();

See Also

TermInfosReader Class | Lucene.Net.Index Namespace | setIndexDivisor


TermInfosReader.GetMaxSkipLevels Method

public int GetMaxSkipLevels();

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader.GetSkipInterval Method

public int GetSkipInterval();

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader.SetIndexDivisor Method

Sets the indexDivisor, which subsamples the number of indexed terms loaded into memory. This has a similar effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown. + @throws IllegalStateException if the term index has already been loaded into memory.
public void SetIndexDivisor(
int indexDivisor
);

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


Terms Method

Apache Lucene.Net 2.4.0 Class Library API

TermInfosReader.Terms Method

Returns an enumeration of all the Terms and TermInfos in the set.

Overload List

Returns an enumeration of all the Terms and TermInfos in the set.

public SegmentTermEnum Terms();

Returns an enumeration of terms starting at or after the named term.

public SegmentTermEnum Terms(Term);

See Also

TermInfosReader Class | Lucene.Net.Index Namespace


TermInfosReader.Terms Method ()

Returns an enumeration of all the Terms and TermInfos in the set.

public SegmentTermEnum Terms();

See Also

TermInfosReader Class | Lucene.Net.Index Namespace | TermInfosReader.Terms Overload List


TermInfosReader.Terms Method (Term)

Returns an enumeration of terms starting at or after the named term.

public SegmentTermEnum Terms(
Term term
);

See Also

TermInfosReader Class | Lucene.Net.Index Namespace | TermInfosReader.Terms Overload List


TermInfosWriter Class

For a list of all members of this type, see TermInfosWriter Members.

System.Object
Lucene.Net.Index.TermInfosWriter

public sealed class TermInfosWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermInfosWriter Members | Lucene.Net.Index Namespace


TermInfosWriter Members

TermInfosWriter overview

Public Static Fields

FORMAT | The file format version, a negative number.
FORMAT_CURRENT |
FORMAT_VERSION_UTF8_LENGTH_IN_BYTES |

Public Instance Constructors

TermInfosWriter Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermInfosWriter Constructor

public TermInfosWriter(
Directory directory,
string segment,
FieldInfos fis,
int interval
);

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermInfosWriter Fields

The fields of the TermInfosWriter class are listed below. For a complete list of TermInfosWriter class members, see the TermInfosWriter Members topic.

Public Static Fields

FORMAT | The file format version, a negative number.
FORMAT_CURRENT |
FORMAT_VERSION_UTF8_LENGTH_IN_BYTES |

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermInfosWriter.FORMAT Field

The file format version, a negative number.

public const int FORMAT = -3;

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermInfosWriter.FORMAT_CURRENT Field

public static readonly int FORMAT_CURRENT;

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermInfosWriter.FORMAT_VERSION_UTF8_LENGTH_IN_BYTES Field

public const int FORMAT_VERSION_UTF8_LENGTH_IN_BYTES = -4;

See Also

TermInfosWriter Class | Lucene.Net.Index Namespace


TermPositions Interface

For a list of all members of this type, see TermPositions Members.

public interface TermPositions : TermDocs

Types that implement TermPositions

Type | Description
FilterIndexReader.FilterTermPositions | Base class for filtering {@link TermPositions} implementations.
MultipleTermPositions Describe class
MultipleTermPositions
here.
SegmentTermPositions

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermPositions Members | Lucene.Net.Index Namespace


TermPositions Members

TermPositions overview

Public Instance Methods

GetPayload
GetPayloadLength
IsPayloadAvailable
NextPosition

See Also

TermPositions Interface | Lucene.Net.Index Namespace


TermPositions Methods

The methods of the TermPositions interface are listed below. For a complete list of TermPositions interface members, see the TermPositions Members topic.

Public Instance Methods

GetPayload
GetPayloadLength
IsPayloadAvailable
NextPosition

See Also

TermPositions Interface | Lucene.Net.Index Namespace


TermPositions.GetPayload Method

byte[] GetPayload(
byte[] data,
int offset
);

See Also

TermPositions Interface | Lucene.Net.Index Namespace


TermPositions.GetPayloadLength Method

int GetPayloadLength();

See Also

TermPositions Interface | Lucene.Net.Index Namespace


TermPositions.IsPayloadAvailable Method

bool IsPayloadAvailable();

See Also

TermPositions Interface | Lucene.Net.Index Namespace


TermPositions.NextPosition Method

int NextPosition();

See Also

TermPositions Interface | Lucene.Net.Index Namespace


TermPositionVector Interface

Extends

TermFreqVector
to provide additional information about positions in which each of the terms is found. A TermPositionVector not necessarily contains both positions and offsets, but at least one of these arrays exists.

For a list of all members of this type, see TermPositionVector Members.

public interface TermPositionVector : TermFreqVector

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermPositionVector Members | Lucene.Net.Index Namespace


TermPositionVector Members

TermPositionVector overview

Public Instance Methods

GetOffsets Returns an array of TermVectorOffsetInfo in which the term is found. May return null if offsets have not been stored.
GetTermPositions Returns an array of positions in which the term is found. Terms are identified by the index at which its number appears in the term String array obtained from the
indexOf
method. May return null if positions have not been stored.

See Also

TermPositionVector Interface | Lucene.Net.Index Namespace


TermPositionVector Methods

The methods of the TermPositionVector interface are listed below. For a complete list of TermPositionVector interface members, see the TermPositionVector Members topic.

Public Instance Methods

GetOffsets Returns an array of TermVectorOffsetInfo in which the term is found. May return null if offsets have not been stored.
GetTermPositions Returns an array of positions in which the term is found. Terms are identified by the index at which its number appears in the term String array obtained from the
indexOf
method. May return null if positions have not been stored.

See Also

TermPositionVector Interface | Lucene.Net.Index Namespace


TermPositionVector.GetOffsets Method

Returns an array of TermVectorOffsetInfo in which the term is found. May return null if offsets have not been stored.

TermVectorOffsetInfo[] GetOffsets(
int index
);

Parameters

index
The position in the array to get the offsets from

Return Value

An array of TermVectorOffsetInfo objects or the empty list

See Also

TermPositionVector Interface | Lucene.Net.Index Namespace |


TermPositionVector.GetTermPositions Method

Returns an array of positions in which the term is found. Terms are identified by the index at which its number appears in the term String array obtained from the

indexOf
method. May return null if positions have not been stored.

int[] GetTermPositions(
int index
);

See Also

TermPositionVector Interface | Lucene.Net.Index Namespace


TermVectorEntry Class

Convenience class for holding TermVector information.

For a list of all members of this type, see TermVectorEntry Members.

System.Object
Lucene.Net.Index.TermVectorEntry

public class TermVectorEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermVectorEntry Members | Lucene.Net.Index Namespace


TermVectorEntry Members

TermVectorEntry overview

Public Instance Constructors

TermVectorEntry Overloaded. Initializes a new instance of the TermVectorEntry class.

Public Instance Methods

Equals |
GetField |
GetFrequency |
GetHashCode |
GetOffsets |
GetPositions |
GetTerm |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace


TermVectorEntry Constructor

Initializes a new instance of the TermVectorEntry class.

Overload List

Initializes a new instance of the TermVectorEntry class.

public TermVectorEntry();

public TermVectorEntry(string,string,int,TermVectorOffsetInfo[],int[]);

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace


TermVectorEntry Constructor ()

Initializes a new instance of the TermVectorEntry class.

public TermVectorEntry();

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace | TermVectorEntry Constructor Overload List


TermVectorEntry Constructor (String, String, Int32, TermVectorOffsetInfo[], Int32[])

public TermVectorEntry(
string field,
string term,
int frequency,
TermVectorOffsetInfo[] offsets,
int[] positions
);

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace | TermVectorEntry Constructor Overload List


TermVectorEntry Methods

The methods of the TermVectorEntry class are listed below. For a complete list of TermVectorEntry class members, see the TermVectorEntry Members topic.

Public Instance Methods

Equals |
GetField |
GetFrequency |
GetHashCode |
GetOffsets |
GetPositions |
GetTerm |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace


TermVectorEntry.Equals Method

public override bool Equals(
object o
);

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace


TermVectorEntry.GetField Method

public virtual string GetField();

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace


TermVectorEntry.GetFrequency Method

public virtual int GetFrequency();

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace


TermVectorEntry.GetHashCode Method

public override int GetHashCode();

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace


TermVectorEntry.GetOffsets Method

public virtual TermVectorOffsetInfo[] GetOffsets();

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace


TermVectorEntry.GetPositions Method

public virtual int[] GetPositions();

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace


TermVectorEntry.GetTerm Method

public virtual string GetTerm();

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace


TermVectorEntry.ToString Method

public override string ToString();

See Also

TermVectorEntry Class | Lucene.Net.Index Namespace


TermVectorEntryFreqSortedComparator Class

Compares {@link Lucene.Net.Index.TermVectorEntry}s first by frequency and then by the term (case-sensitive)

For a list of all members of this type, see TermVectorEntryFreqSortedComparator Members.

System.Object
Lucene.Net.Index.TermVectorEntryFreqSortedComparator

public class TermVectorEntryFreqSortedComparator : 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermVectorEntryFreqSortedComparator Members | Lucene.Net.Index Namespace


TermVectorEntryFreqSortedComparator Members

TermVectorEntryFreqSortedComparator overview

Public Instance Constructors

TermVectorEntryFreqSortedComparator Constructor Initializes a new instance of the TermVectorEntryFreqSortedComparator class.

Public Instance Methods

Compare |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermVectorEntryFreqSortedComparator Class | Lucene.Net.Index Namespace


TermVectorEntryFreqSortedComparator Constructor

Initializes a new instance of the TermVectorEntryFreqSortedComparator class.

public TermVectorEntryFreqSortedComparator();

See Also

TermVectorEntryFreqSortedComparator Class | Lucene.Net.Index Namespace


TermVectorEntryFreqSortedComparator Methods

The methods of the TermVectorEntryFreqSortedComparator class are listed below. For a complete list of TermVectorEntryFreqSortedComparator class members, see the TermVectorEntryFreqSortedComparator Members topic.

Public Instance Methods

Compare |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermVectorEntryFreqSortedComparator Class | Lucene.Net.Index Namespace


TermVectorEntryFreqSortedComparator.Compare Method

public virtual int Compare(
object object_Renamed,
object object1
);

Implements

IComparer`1.Compare

See Also

TermVectorEntryFreqSortedComparator Class | Lucene.Net.Index Namespace


TermVectorMapper Class

The TermVectorMapper can be used to map Term Vectors into your own structure instead of the parallel array structure used by {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}.

It is up to the implementation to make sure it is thread-safe.

For a list of all members of this type, see TermVectorMapper Members.

System.Object
Lucene.Net.Index.TermVectorMapper
Lucene.Net.Index.FieldSortedTermVectorMapper
Lucene.Net.Index.PositionBasedTermVectorMapper
Lucene.Net.Index.SortedTermVectorMapper

public abstract class TermVectorMapper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermVectorMapper Members | Lucene.Net.Index Namespace


TermVectorMapper Members

TermVectorMapper overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIgnoringOffsets |
IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.
Map | Map the Term Vector information into your own structure
SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
SetExpectations | Tell the mapper what to expect in regards to field, number of terms, offset and position storage. This method will be called once before retrieving the vector for a field. This method will be called before {@link #Map(String,int,TermVectorOffsetInfo[],int[])}.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

TermVectorMapper Overloaded. Initializes a new instance of the TermVectorMapper class.

See Also

TermVectorMapper Class | Lucene.Net.Index Namespace


TermVectorMapper Constructor

Initializes a new instance of the TermVectorMapper class.

Overload List

Initializes a new instance of the TermVectorMapper class.

protected internal TermVectorMapper();

protected internal TermVectorMapper(bool,bool);

See Also

TermVectorMapper Class | Lucene.Net.Index Namespace


TermVectorMapper Constructor ()

Initializes a new instance of the TermVectorMapper class.

protected internal TermVectorMapper();

See Also

TermVectorMapper Class | Lucene.Net.Index Namespace | TermVectorMapper Constructor Overload List


TermVectorMapper Constructor (Boolean, Boolean)

protected internal TermVectorMapper(
bool ignoringPositions,
bool ignoringOffsets
);

Parameters

ignoringPositions
true if this mapper should tell Lucene to ignore positions even if they are stored
ignoringOffsets
similar to ignoringPositions

See Also

TermVectorMapper Class | Lucene.Net.Index Namespace | TermVectorMapper Constructor Overload List


TermVectorMapper Methods

The methods of the TermVectorMapper class are listed below. For a complete list of TermVectorMapper class members, see the TermVectorMapper Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIgnoringOffsets |
IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.
Map | Map the Term Vector information into your own structure
SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
SetExpectations | Tell the mapper what to expect in regards to field, number of terms, offset and position storage. This method will be called once before retrieving the vector for a field. This method will be called before {@link #Map(String,int,TermVectorOffsetInfo[],int[])}.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermVectorMapper Class | Lucene.Net.Index Namespace


TermVectorMapper.IsIgnoringOffsets Method

public virtual bool IsIgnoringOffsets();

Return Value

false

See Also

TermVectorMapper Class | Lucene.Net.Index Namespace | IsIgnoringPositions


TermVectorMapper.IsIgnoringPositions Method

Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.

public virtual bool IsIgnoringPositions();

Return Value

false

See Also

TermVectorMapper Class | Lucene.Net.Index Namespace


TermVectorMapper.Map Method

Map the Term Vector information into your own structure

public abstract void Map(
string term,
int frequency,
TermVectorOffsetInfo[] offsets,
int[] positions
);

Parameters

term
The term to add to the vector
frequency
The frequency of the term in the document
offsets
null if the offset is not specified, otherwise the offset into the field of the term
positions
null if the position is not specified, otherwise the position in the field of the term

See Also

TermVectorMapper Class | Lucene.Net.Index Namespace


TermVectorMapper.SetDocumentNumber Method

Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader.

Default implementation IGNORES the document number. Override if your implementation needs the document number.

NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
public virtual void SetDocumentNumber(
int documentNumber
);

Parameters

documentNumber
index of document currently being mapped

See Also

TermVectorMapper Class | Lucene.Net.Index Namespace


TermVectorMapper.SetExpectations Method

Tell the mapper what to expect in regards to field, number of terms, offset and position storage. This method will be called once before retrieving the vector for a field. This method will be called before {@link #Map(String,int,TermVectorOffsetInfo[],int[])}.

public abstract void SetExpectations(
string field,
int numTerms,
bool storeOffsets,
bool storePositions
);

Parameters

field
The field the vector is for
numTerms
The number of terms that need to be mapped
storeOffsets
true if the mapper should expect offset information
storePositions
true if the mapper should expect positions info

See Also

TermVectorMapper Class | Lucene.Net.Index Namespace


TermVectorOffsetInfo Class

The TermVectorOffsetInfo class holds information pertaining to a Term in a {@link Lucene.Net.Index.TermPositionVector}'s offset information. This offset information is the character offset as set during the Analysis phase (and thus may not be the actual offset in the original content).

For a list of all members of this type, see TermVectorOffsetInfo Members.

System.Object
Lucene.Net.Index.TermVectorOffsetInfo

public class TermVectorOffsetInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermVectorOffsetInfo Members | Lucene.Net.Index Namespace


TermVectorOffsetInfo Members

TermVectorOffsetInfo overview

Public Static Fields

EMPTY_OFFSET_INFO Convenience declaration when creating a {@link Lucene.Net.Index.TermPositionVector} that stores only position information.

Public Instance Constructors

TermVectorOffsetInfo Overloaded. Initializes a new instance of the TermVectorOffsetInfo class.

Public Instance Methods

Equals | Two TermVectorOffsetInfos are equals if both the start and end offsets are the same
GetEndOffset | The accessor for the ending offset for the term
GetHashCode |
GetStartOffset | The accessor for the starting offset of the term.
GetType (inherited from Object) | Gets the Type of the current instance.
SetEndOffset |
SetStartOffset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace


TermVectorOffsetInfo Constructor

Initializes a new instance of the TermVectorOffsetInfo class.

Overload List

Initializes a new instance of the TermVectorOffsetInfo class.

public TermVectorOffsetInfo();

public TermVectorOffsetInfo(int,int);

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace


TermVectorOffsetInfo Constructor ()

Initializes a new instance of the TermVectorOffsetInfo class.

public TermVectorOffsetInfo();

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace | TermVectorOffsetInfo Constructor Overload List


TermVectorOffsetInfo Constructor (Int32, Int32)

public TermVectorOffsetInfo(
int startOffset,
int endOffset
);

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace | TermVectorOffsetInfo Constructor Overload List


TermVectorOffsetInfo Fields

The fields of the TermVectorOffsetInfo class are listed below. For a complete list of TermVectorOffsetInfo class members, see the TermVectorOffsetInfo Members topic.

Public Static Fields

EMPTY_OFFSET_INFO Convenience declaration when creating a {@link Lucene.Net.Index.TermPositionVector} that stores only position information.

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace


TermVectorOffsetInfo.EMPTY_OFFSET_INFO Field

Convenience declaration when creating a {@link Lucene.Net.Index.TermPositionVector} that stores only position information.

public static readonly TermVectorOffsetInfo[] EMPTY_OFFSET_INFO;

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace


TermVectorOffsetInfo Methods

The methods of the TermVectorOffsetInfo class are listed below. For a complete list of TermVectorOffsetInfo class members, see the TermVectorOffsetInfo Members topic.

Public Instance Methods

Equals | Two TermVectorOffsetInfos are equals if both the start and end offsets are the same
GetEndOffset | The accessor for the ending offset for the term
GetHashCode |
GetStartOffset | The accessor for the starting offset of the term.
GetType (inherited from Object) | Gets the Type of the current instance.
SetEndOffset |
SetStartOffset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace


TermVectorOffsetInfo.Equals Method

Two TermVectorOffsetInfos are equals if both the start and end offsets are the same

public override bool Equals(
object o
);

Parameters

o
The comparison object

Return Value

true if both {@link #GetStartOffset()} and {@link #GetEndOffset()} are the same for both objects.

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace


TermVectorOffsetInfo.GetEndOffset Method

The accessor for the ending offset for the term

public virtual int GetEndOffset();

Return Value

The offset

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace


TermVectorOffsetInfo.GetHashCode Method

public override int GetHashCode();

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace


TermVectorOffsetInfo.GetStartOffset Method

The accessor for the starting offset of the term.

public virtual int GetStartOffset();

Return Value

The offset

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace


TermVectorOffsetInfo.SetEndOffset Method

public virtual void SetEndOffset(
int endOffset
);

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace


TermVectorOffsetInfo.SetStartOffset Method

public virtual void SetStartOffset(
int startOffset
);

See Also

TermVectorOffsetInfo Class | Lucene.Net.Index Namespace


TermVectorsReader Class

For a list of all members of this type, see TermVectorsReader Members.

System.Object
Lucene.Net.Index.TermVectorsReader

public class TermVectorsReader : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermVectorsReader Members | Lucene.Net.Index Namespace


TermVectorsReader Members

TermVectorsReader overview

Public Instance Constructors

TermVectorsReader Constructor

Public Instance Methods

Clone |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace


TermVectorsReader Constructor

public TermVectorsReader(
Directory d,
string segment,
FieldInfos fieldInfos
);

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace


TermVectorsReader Methods

The methods of the TermVectorsReader class are listed below. For a complete list of TermVectorsReader class members, see the TermVectorsReader Members topic.

Public Instance Methods

Clone |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace


TermVectorsReader.Clone Method

public virtual object Clone();

Implements

ICloneable.Clone

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace


Get Method

Apache Lucene.Net 2.4.0 Class Library API

TermVectorsReader.Get Method

Overload List

public TermFreqVector[] Get(int);

public void Get(int,TermVectorMapper);

public TermFreqVector Get(int,string);

public virtual void Get(int,string,TermVectorMapper);

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace


TermVectorsReader.Get Method (Int32)

public TermFreqVector[] Get(
int docNum
);

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace | TermVectorsReader.Get Overload List


TermVectorsReader.Get Method (Int32, TermVectorMapper)

public void Get(
int docNumber,
TermVectorMapper mapper
);

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace | TermVectorsReader.Get Overload List


TermVectorsReader.Get Method (Int32, String)

public TermFreqVector Get(
int docNum,
string field
);

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace | TermVectorsReader.Get Overload List


TermVectorsReader.Get Method (Int32, String, TermVectorMapper)

public virtual void Get(
int docNum,
string field,
TermVectorMapper mapper
);

See Also

TermVectorsReader Class | Lucene.Net.Index Namespace | TermVectorsReader.Get Overload List


TermVectorsWriter Class

For a list of all members of this type, see TermVectorsWriter Members.

System.Object
Lucene.Net.Index.TermVectorsWriter

public sealed class TermVectorsWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermVectorsWriter Members | Lucene.Net.Index Namespace


TermVectorsWriter Members

TermVectorsWriter overview

Public Instance Constructors

TermVectorsWriter Constructor

Public Instance Methods

AddAllDocVectors | Add a complete document specified by all its term vectors. If document has no term vectors, add value for tvx.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter Constructor

public TermVectorsWriter(
Directory directory,
string segment,
FieldInfos fieldInfos
);

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter Methods

The methods of the TermVectorsWriter class are listed below. For a complete list of TermVectorsWriter class members, see the TermVectorsWriter Members topic.

Public Instance Methods

AddAllDocVectors | Add a complete document specified by all its term vectors. If document has no term vectors, add value for tvx.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


TermVectorsWriter.AddAllDocVectors Method

Add a complete document specified by all its term vectors. If document has no term vectors, add value for tvx.

public void AddAllDocVectors(
TermFreqVector[] vectors
);

Parameters

vectors

See Also

TermVectorsWriter Class | Lucene.Net.Index Namespace


Lucene.Net.Index.Compression

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Index.Compression Namespace

Namespace hierarchy

Classes

Class | Description
SharpZipLibAdapter |


SharpZipLibAdapter Class

For a list of all members of this type, see SharpZipLibAdapter Members.

System.Object
Lucene.Net.Index.Compression.SharpZipLibAdapter

public class SharpZipLibAdapter : ICompressionAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Index.Compression

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SharpZipLibAdapter Members | Lucene.Net.Index.Compression Namespace


SharpZipLibAdapter Members

SharpZipLibAdapter overview

Public Instance Constructors

SharpZipLibAdapter Constructor Initializes a new instance of the SharpZipLibAdapter class.

Public Instance Methods

Compress |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Uncompress |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SharpZipLibAdapter Class | Lucene.Net.Index.Compression Namespace


SharpZipLibAdapter Constructor

Initializes a new instance of the SharpZipLibAdapter class.

public SharpZipLibAdapter();

See Also

SharpZipLibAdapter Class | Lucene.Net.Index.Compression Namespace


SharpZipLibAdapter Methods

The methods of the SharpZipLibAdapter class are listed below. For a complete list of SharpZipLibAdapter class members, see the SharpZipLibAdapter Members topic.

Public Instance Methods

Compress |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Uncompress |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SharpZipLibAdapter Class | Lucene.Net.Index.Compression Namespace


SharpZipLibAdapter.Compress Method

public byte[] Compress(
byte[] input,
int offset,
int length
);

Implements

ICompressionAdapter.Compress

See Also

SharpZipLibAdapter Class | Lucene.Net.Index.Compression Namespace


SharpZipLibAdapter.Uncompress Method

public byte[] Uncompress(
byte[] input
);

Implements

ICompressionAdapter.Uncompress

See Also

SharpZipLibAdapter Class | Lucene.Net.Index.Compression Namespace


Lucene.Net.QueryParsers

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.QueryParsers Namespace

Namespace hierarchy

Classes

Class | Description
FastCharStream |
MultiFieldQueryParser | A QueryParser which constructs queries to search multiple fields.
ParseException | This exception is thrown when parse errors are encountered. You can explicitly create objects of this exception type by calling the method generateParseException in the generated parser. You can modify this class to customize your error reporting mechanisms so long as you retain the public fields.
QueryParser |
QueryParser.Operator | The default operator for parsing queries. Use {@link QueryParser#setDefaultOperator} to change it.
QueryParserConstants | Token literal values and constants. Generated by org.javacc.parser.OtherFilesGen#start()
QueryParserTokenManager |
Token | Describes the input token stream.
TokenMgrError | Token Manager Error.

Interfaces

Interface | Description
CharStream | This interface describes a character stream that maintains line and column number positions of the characters. It also has the capability to backup the stream to some extent. An implementation of this interface is used in the TokenManager implementation generated by JavaCCParser. All the methods except backup can be implemented in any fashion. backup needs to be implemented correctly for the correct operation of the lexer. Rest of the methods are all used to get information like line number, column number and the String that constitutes a token and are not used by the lexer. Hence their implementation won't affect the generated lexer's operation.


CharStream Interface

This interface describes a character stream that maintains line and column number positions of the characters. It also has the capability to backup the stream to some extent. An implementation of this interface is used in the TokenManager implementation generated by JavaCCParser. All the methods except backup can be implemented in any fashion. backup needs to be implemented correctly for the correct operation of the lexer. Rest of the methods are all used to get information like line number, column number and the String that constitutes a token and are not used by the lexer. Hence their implementation won't affect the generated lexer's operation.

For a list of all members of this type, see CharStream Members.

public interface CharStream

Types that implement CharStream

Type | Description
FastCharStream |

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CharStream Members | Lucene.Net.QueryParsers Namespace


CharStream Members

CharStream overview

Public Instance Methods

Backup | Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.
BeginToken | Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.
Done | The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.
GetBeginColumn | Returns the column number of the first character for current token (being matched after the last call to BeginTOken).
GetBeginLine | Returns the line number of the first character for current token (being matched after the last call to BeginTOken).
GetColumn | Obsolete. Returns the column position of the character last read.
GetEndColumn | Returns the column number of the last character for current token (being matched after the last call to BeginTOken).
GetEndLine | Returns the line number of the last character for current token (being matched after the last call to BeginTOken).
GetImage | Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.
GetLine | Obsolete. Returns the line number of the character last read.
GetSuffix | Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }
ReadChar | Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream Methods

The methods of the CharStream interface are listed below. For a complete list of CharStream interface members, see the CharStream Members topic.

Public Instance Methods

Backup | Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.
BeginToken | Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.
Done | The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.
GetBeginColumn | Returns the column number of the first character for current token (being matched after the last call to BeginTOken).
GetBeginLine | Returns the line number of the first character for current token (being matched after the last call to BeginTOken).
GetColumn | Obsolete. Returns the column position of the character last read.
GetEndColumn | Returns the column number of the last character for current token (being matched after the last call to BeginTOken).
GetEndLine | Returns the line number of the last character for current token (being matched after the last call to BeginTOken).
GetImage | Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.
GetLine | Obsolete. Returns the line number of the character last read.
GetSuffix | Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }
ReadChar | Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.Backup Method

Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.

void Backup(
int amount
);

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.BeginToken Method

Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.

char BeginToken();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.Done Method

The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.

void Done();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.GetBeginColumn Method

Returns the column number of the first character for current token (being matched after the last call to BeginTOken).

int GetBeginColumn();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.GetBeginLine Method

Returns the line number of the first character for current token (being matched after the last call to BeginTOken).

int GetBeginLine();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.GetColumn Method

NOTE: This method is now obsolete.

Returns the column position of the character last read.

int GetColumn();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace | #getEndColumn


CharStream.GetEndColumn Method

Returns the column number of the last character for current token (being matched after the last call to BeginTOken).

int GetEndColumn();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.GetEndLine Method

Returns the line number of the last character for current token (being matched after the last call to BeginTOken).

int GetEndLine();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.GetImage Method

Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.

string GetImage();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.GetLine Method

NOTE: This method is now obsolete.

Returns the line number of the character last read.

int GetLine();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace |


CharStream.GetSuffix Method

Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }

char[] GetSuffix(
int len
);

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


CharStream.ReadChar Method

Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

char ReadChar();

See Also

CharStream Interface | Lucene.Net.QueryParsers Namespace


FastCharStream Class

For a list of all members of this type, see FastCharStream Members.

System.Object
Lucene.Net.QueryParsers.FastCharStream

public sealed class FastCharStream : CharStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FastCharStream Members | Lucene.Net.QueryParsers Namespace


FastCharStream Members

FastCharStream overview

Public Instance Constructors

FastCharStream Constructor Constructs from a Reader.

Public Instance Methods

Backup |
BeginToken |
Done |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBeginColumn |
GetBeginLine |
GetColumn |
GetEndColumn |
GetEndLine |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetImage |
GetLine |
GetSuffix |
GetType (inherited from Object) | Gets the Type of the current instance.
ReadChar |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream Constructor

Constructs from a Reader.

public FastCharStream(
TextReader r
);

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream Methods

The methods of the FastCharStream class are listed below. For a complete list of FastCharStream class members, see the FastCharStream Members topic.

Public Instance Methods

Backup |
BeginToken |
Done |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBeginColumn |
GetBeginLine |
GetColumn |
GetEndColumn |
GetEndLine |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetImage |
GetLine |
GetSuffix |
GetType (inherited from Object) | Gets the Type of the current instance.
ReadChar |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.Backup Method

public void Backup(
int amount
);

Implements

CharStream.Backup

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.BeginToken Method

public char BeginToken();

Implements

CharStream.BeginToken

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.Done Method

public void Done();

Implements

CharStream.Done

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetBeginColumn Method

public int GetBeginColumn();

Implements

CharStream.GetBeginColumn

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetBeginLine Method

public int GetBeginLine();

Implements

CharStream.GetBeginLine

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetColumn Method

public int GetColumn();

Implements

CharStream.GetColumn

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetEndColumn Method

public int GetEndColumn();

Implements

CharStream.GetEndColumn

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetEndLine Method

public int GetEndLine();

Implements

CharStream.GetEndLine

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetImage Method

public string GetImage();

Implements

CharStream.GetImage

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetLine Method

public int GetLine();

Implements

CharStream.GetLine

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.GetSuffix Method

public char[] GetSuffix(
int len
);

Implements

CharStream.GetSuffix

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


FastCharStream.ReadChar Method

public char ReadChar();

Implements

CharStream.ReadChar

See Also

FastCharStream Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Class

A QueryParser which constructs queries to search multiple fields.

For a list of all members of this type, see MultiFieldQueryParser Members.

System.Object
Lucene.Net.QueryParsers.QueryParserConstants
Lucene.Net.QueryParsers.QueryParser
Lucene.Net.QueryParsers.MultiFieldQueryParser

public class MultiFieldQueryParser : QueryParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MultiFieldQueryParser Members | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Members

MultiFieldQueryParser overview

Public Static Methods

Parse Overloaded.

Public Instance Constructors

MultiFieldQueryParser Overloaded. Initializes a new instance of the MultiFieldQueryParser class.

Public Instance Fields

jj_nt (inherited from QueryParser) | Next token.
token (inherited from QueryParser) | Current token
token_source (inherited from QueryParser) | Generated token manager

Public Instance Methods

AddClause (inherited from QueryParser)
Clause (inherited from QueryParser)
Conjunction (inherited from QueryParser)
Disable_tracing (inherited from QueryParser) | Disable tracing.
Enable_tracing (inherited from QueryParser) | Enable tracing.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateParseException (inherited from QueryParser) | Generate ParseException.
GetAllowLeadingWildcard (inherited from QueryParser)
GetAnalyzer (inherited from QueryParser)
GetBooleanQuery (inherited from QueryParser) | Overloaded. Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
GetDateResolution (inherited from QueryParser) | Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.
GetDefaultOperator (inherited from QueryParser) | Gets implicit operator setting, which will be either AND_OPERATOR or OR_OPERATOR.
GetEnablePositionIncrements (inherited from QueryParser)
GetField (inherited from QueryParser)
GetFieldQuery | Overloaded.
GetFuzzyMinSim (inherited from QueryParser) | Get the minimal similarity for fuzzy queries.
GetFuzzyPrefixLength (inherited from QueryParser) | Get the prefix length for fuzzy queries.
GetFuzzyQuery
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLocale (inherited from QueryParser) | Returns current locale, allowing access by subclasses.
GetLowercaseExpandedTerms (inherited from QueryParser)
GetNextToken (inherited from QueryParser) | Get the next Token.
GetPhraseSlop (inherited from QueryParser) | Gets the default slop for phrases.
GetPrefixQuery
GetRangeCollator (inherited from QueryParser) | Returns the collator used to determine index term inclusion in ranges specified either for ConstantScoreRangeQuery or RangeQuery (if SetUseOldRangeQuery(bool) is called with the parameter true).
GetRangeQuery
GetToken (inherited from QueryParser) | Get the specific Token.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseOldRangeQuery (inherited from QueryParser)
GetWildcardQuery
Modifiers (inherited from QueryParser)
Parse (inherited from QueryParser) | Overloaded. Parses a query string, returning a {@link Lucene.Net.Search.Query}.
Query (inherited from QueryParser)
ReInit (inherited from QueryParser) | Overloaded. Reinitialise.
SetAllowLeadingWildcard (inherited from QueryParser)
SetDateResolution (inherited from QueryParser) | Overloaded. Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
SetDefaultOperator (inherited from QueryParser) Sets the boolean operator of the QueryParser. In default mode (
OR_OPERATOR
) terms without any modifiers are considered optional: for example
capital of Hungary
is equal to
capital OR of OR Hungary
.
In
AND_OPERATOR
mode terms are considered to be in conjuction: the above mentioned query is parsed as
capital AND of AND Hungary
SetEnablePositionIncrements (inherited from QueryParser)
SetFuzzyMinSim (inherited from QueryParser) | Set the minimum similarity for fuzzy queries. Default is 0.5f.
SetFuzzyPrefixLength (inherited from QueryParser) | Set the prefix length for fuzzy queries. Default is 0.
SetLocale (inherited from QueryParser) | Set locale used by date range parsing.
SetLowercaseExpandedTerms (inherited from QueryParser) Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is
true
.
SetPhraseSlop (inherited from QueryParser) | Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
SetRangeCollator (inherited from QueryParser) | Sets the collator used to determine index term inclusion in ranges specified either for ConstantScoreRangeQuery or RangeQuery (if SetUseOldRangeQuery(bool) is called with a parameter of true. WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
SetUseOldRangeQuery (inherited from QueryParser) By default QueryParser uses new ConstantScoreRangeQuery in preference to RangeQuery for range queries. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of range terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned RangeQuery and the above points are not required then set this option to
true
Default is
false
.
Term (inherited from QueryParser)
TopLevelQuery (inherited from QueryParser)
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
newBooleanClause (inherited from QueryParser) | Builds a new BooleanClause instance.
newBooleanQuery (inherited from QueryParser) | Builds a new BooleanQuery instance.
newFuzzyQuery (inherited from QueryParser) | Builds a new FuzzyQuery instance.
newMatchAllDocsQuery (inherited from QueryParser) | Builds a new MatchAllDocsQuery instance.
newMultiPhraseQuery (inherited from QueryParser) | Builds a new MultiPhraseQuery instance.
newPhraseQuery (inherited from QueryParser) | Builds a new PhraseQuery instance.
newPrefixQuery (inherited from QueryParser) | Builds a new PrefixQuery instance.
newRangeQuery (inherited from QueryParser) | Builds a new RangeQuery instance.
newTermQuery (inherited from QueryParser) | Builds a new TermQuery instance.
newWildcardQuery (inherited from QueryParser) | Builds a new WildcardQuery instance.

Protected Internal Instance Fields

boosts
fields

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Constructor

Creates a MultiFieldQueryParser. Allows passing of a map with term to Boost, and the boost to apply to each term.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

title
and
body
):

(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

+(title:term1 body:term1) +(title:term2 body:term2)

When you pass a boost (title=>5 body=>10) you can get

+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Overload List

Creates a MultiFieldQueryParser. It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

title
and
body
):
(title:term1 body:term1) (title:term2 body:term2)
When setDefaultOperator(AND_OPERATOR) is set, the result will be:
+(title:term1 body:term1) +(title:term2 body:term2)
In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

public MultiFieldQueryParser(string[],Analyzer);

Creates a MultiFieldQueryParser. Allows passing of a map with term to Boost, and the boost to apply to each term. It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

title
and
body
):
(title:term1 body:term1) (title:term2 body:term2)
When setDefaultOperator(AND_OPERATOR) is set, the result will be:
+(title:term1 body:term1) +(title:term2 body:term2)
When you pass a boost (title=>5 body=>10) you can get
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)
In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

public MultiFieldQueryParser(string[],Analyzer,IDictionary);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Constructor (String[], Analyzer, IDictionary)

Creates a MultiFieldQueryParser. Allows passing of a map with term to Boost, and the boost to apply to each term.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

title
and
body
):

(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

+(title:term1 body:term1) +(title:term2 body:term2)

When you pass a boost (title=>5 body=>10) you can get

+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

public MultiFieldQueryParser(
string[] fields,
Analyzer analyzer,
IDictionary boosts
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace | MultiFieldQueryParser Constructor Overload List


MultiFieldQueryParser Constructor (String[], Analyzer)

Creates a MultiFieldQueryParser.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

title
and
body
):

(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

+(title:term1 body:term1) +(title:term2 body:term2)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

public MultiFieldQueryParser(
string[] fields,
Analyzer analyzer
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace | MultiFieldQueryParser Constructor Overload List


MultiFieldQueryParser Fields

The fields of the MultiFieldQueryParser class are listed below. For a complete list of MultiFieldQueryParser class members, see the MultiFieldQueryParser Members topic.

Public Instance Fields

jj_nt (inherited from QueryParser) | Next token.
token (inherited from QueryParser) | Current token
token_source (inherited from QueryParser) | Generated token manager

Protected Internal Instance Fields

boosts
fields

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser.boosts Field

protected internal IDictionary boosts;

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser.fields Field

protected internal string[] fields;

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Methods

The methods of the MultiFieldQueryParser class are listed below. For a complete list of MultiFieldQueryParser class members, see the MultiFieldQueryParser Members topic.

Public Static Methods

Parse Overloaded.

Public Instance Methods

AddClause (inherited from QueryParser)
Clause (inherited from QueryParser)
Conjunction (inherited from QueryParser)
Disable_tracing (inherited from QueryParser) | Disable tracing.
Enable_tracing (inherited from QueryParser) | Enable tracing.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateParseException (inherited from QueryParser) | Generate ParseException.
GetAllowLeadingWildcard (inherited from QueryParser)
GetAnalyzer (inherited from QueryParser)
GetBooleanQuery (inherited from QueryParser) | Overloaded. Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
GetDateResolution (inherited from QueryParser) | Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.
GetDefaultOperator (inherited from QueryParser) | Gets implicit operator setting, which will be either AND_OPERATOR or OR_OPERATOR.
GetEnablePositionIncrements (inherited from QueryParser)
GetField (inherited from QueryParser)
GetFieldQuery | Overloaded.
GetFuzzyMinSim (inherited from QueryParser) | Get the minimal similarity for fuzzy queries.
GetFuzzyPrefixLength (inherited from QueryParser) | Get the prefix length for fuzzy queries.
GetFuzzyQuery
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLocale (inherited from QueryParser) | Returns current locale, allowing access by subclasses.
GetLowercaseExpandedTerms (inherited from QueryParser)
GetNextToken (inherited from QueryParser) | Get the next Token.
GetPhraseSlop (inherited from QueryParser) | Gets the default slop for phrases.
GetPrefixQuery
GetRangeCollator (inherited from QueryParser) | Returns the collator used to determine index term inclusion in ranges specified either for ConstantScoreRangeQuery or RangeQuery (if SetUseOldRangeQuery(bool) is called with the parameter true).
GetRangeQuery
GetToken (inherited from QueryParser) | Get the specific Token.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseOldRangeQuery (inherited from QueryParser)
GetWildcardQuery
Modifiers (inherited from QueryParser)
Parse (inherited from QueryParser) | Overloaded. Parses a query string, returning a {@link Lucene.Net.Search.Query}.
Query (inherited from QueryParser)
ReInit (inherited from QueryParser) | Overloaded. Reinitialise.
SetAllowLeadingWildcard (inherited from QueryParser)
SetDateResolution (inherited from QueryParser) | Overloaded. Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
SetDefaultOperator (inherited from QueryParser) Sets the boolean operator of the QueryParser. In default mode (
OR_OPERATOR
) terms without any modifiers are considered optional: for example
capital of Hungary
is equal to
capital OR of OR Hungary
.
In
AND_OPERATOR
mode terms are considered to be in conjuction: the above mentioned query is parsed as
capital AND of AND Hungary
SetEnablePositionIncrements (inherited from QueryParser)
SetFuzzyMinSim (inherited from QueryParser) | Set the minimum similarity for fuzzy queries. Default is 0.5f.
SetFuzzyPrefixLength (inherited from QueryParser) | Set the prefix length for fuzzy queries. Default is 0.
SetLocale (inherited from QueryParser) | Set locale used by date range parsing.
SetLowercaseExpandedTerms (inherited from QueryParser) Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is
true
.
SetPhraseSlop (inherited from QueryParser) | Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
SetRangeCollator (inherited from QueryParser) | Sets the collator used to determine index term inclusion in ranges specified either for ConstantScoreRangeQuery or RangeQuery (if SetUseOldRangeQuery(bool) is called with a parameter of true. WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
SetUseOldRangeQuery (inherited from QueryParser) By default QueryParser uses new ConstantScoreRangeQuery in preference to RangeQuery for range queries. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of range terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned RangeQuery and the above points are not required then set this option to
true
Default is
false
.
Term (inherited from QueryParser)
TopLevelQuery (inherited from QueryParser)
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
newBooleanClause (inherited from QueryParser) | Builds a new BooleanClause instance.
newBooleanQuery (inherited from QueryParser) | Builds a new BooleanQuery instance.
newFuzzyQuery (inherited from QueryParser) | Builds a new FuzzyQuery instance.
newMatchAllDocsQuery (inherited from QueryParser) | Builds a new MatchAllDocsQuery instance.
newMultiPhraseQuery (inherited from QueryParser) | Builds a new MultiPhraseQuery instance.
newPhraseQuery (inherited from QueryParser) | Builds a new PhraseQuery instance.
newPrefixQuery (inherited from QueryParser) | Builds a new PrefixQuery instance.
newRangeQuery (inherited from QueryParser) | Builds a new RangeQuery instance.
newTermQuery (inherited from QueryParser) | Builds a new TermQuery instance.
newWildcardQuery (inherited from QueryParser) | Builds a new WildcardQuery instance.

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


GetFieldQuery Method

Apache Lucene.Net 2.4.0 Class Library API

MultiFieldQueryParser.GetFieldQuery Method

Overload List

public override Query GetFieldQuery(string,string);

public override Query GetFieldQuery(string,string,int);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser.GetFieldQuery Method (String, String)

public override Query GetFieldQuery(
string field,
string queryText
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace | MultiFieldQueryParser.GetFieldQuery Overload List


MultiFieldQueryParser.GetFieldQuery Method (String, String, Int32)

public override Query GetFieldQuery(
string field,
string queryText,
int slop
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace | MultiFieldQueryParser.GetFieldQuery Overload List


MultiFieldQueryParser.GetFuzzyQuery Method

public override Query GetFuzzyQuery(
string field,
string termStr,
float minSimilarity
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser.GetPrefixQuery Method

public override Query GetPrefixQuery(
string field,
string termStr
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser.GetRangeQuery Method

public override Query GetRangeQuery(
string field,
string part1,
string part2,
bool inclusive
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser.GetWildcardQuery Method

public override Query GetWildcardQuery(
string field,
string termStr
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


Parse Method

Apache Lucene.Net 2.4.0 Class Library API

MultiFieldQueryParser.Parse Method

Overload List

Inherited from QueryParser.

public virtual Query Parse(string);

public static Query Parse(string,string[],Occur[],Analyzer);

public static Query Parse(string[],string[],Analyzer);

public static Query Parse(string[],string[],Occur[],Analyzer);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser.Parse Method (String, String[], Occur[], Analyzer)

public static Query Parse(
string query,
string[] fields,
Occur[] flags,
Analyzer analyzer
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace | MultiFieldQueryParser.Parse Overload List


MultiFieldQueryParser.Parse Method (String[], String[], Analyzer)

public static Query Parse(
string[] queries,
string[] fields,
Analyzer analyzer
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace | MultiFieldQueryParser.Parse Overload List


MultiFieldQueryParser.Parse Method (String[], String[], Occur[], Analyzer)

public static Query Parse(
string[] queries,
string[] fields,
Occur[] flags,
Analyzer analyzer
);

See Also

MultiFieldQueryParser Class | Lucene.Net.QueryParsers Namespace | MultiFieldQueryParser.Parse Overload List


ParseException Class

This exception is thrown when parse errors are encountered. You can explicitly create objects of this exception type by calling the method generateParseException in the generated parser. You can modify this class to customize your error reporting mechanisms so long as you retain the public fields.

For a list of all members of this type, see ParseException Members.

System.Object
System.Exception
Lucene.Net.QueryParsers.ParseException

public class ParseException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ParseException Members | Lucene.Net.QueryParsers Namespace


ParseException Members

ParseException overview

Public Instance Constructors

ParseException Overloaded. Initializes a new instance of the ParseException class.

Public Instance Fields

currentToken | This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.
expectedTokenSequences | Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.
tokenImage | This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

eol | The end of line string for this machine.
specialConstructor | This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).

Protected Internal Instance Methods

Add_escapes Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException Constructor

Overload List

The following constructors are for use by you for whatever purpose you can think of. Constructing the exception in this manner makes the exception behave in the normal way - i.e., as documented in the class "Throwable". The fields "errorToken", "expectedTokenSequences", and "tokenImage" do not contain relevant information. The JavaCC generated code does not use these constructors.

public ParseException();

public ParseException(Token,int[][],string[]);

Constructor with message.

public ParseException(string);

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException Constructor (Token, Int32[][], String[])

public ParseException(
Token currentTokenVal,
int[][] expectedTokenSequencesVal,
string[] tokenImageVal
);

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace | ParseException Constructor Overload List


ParseException Constructor ()

The following constructors are for use by you for whatever purpose you can think of. Constructing the exception in this manner makes the exception behave in the normal way - i.e., as documented in the class "Throwable". The fields "errorToken", "expectedTokenSequences", and "tokenImage" do not contain relevant information. The JavaCC generated code does not use these constructors.

public ParseException();

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace | ParseException Constructor Overload List


ParseException Constructor (String)

Constructor with message.

public ParseException(
string message
);

Parameters

message

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace | ParseException Constructor Overload List


ParseException Fields

The fields of the ParseException class are listed below. For a complete list of ParseException class members, see the ParseException Members topic.

Public Instance Fields

currentToken | This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.
expectedTokenSequences | Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.
tokenImage | This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

Protected Internal Instance Fields

eol | The end of line string for this machine.
specialConstructor | This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException.currentToken Field

This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.

public Token currentToken;

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException.eol Field

The end of line string for this machine.

protected internal string eol;

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException.expectedTokenSequences Field

Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.

public int[][] expectedTokenSequences;

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException.specialConstructor Field

This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).

protected internal bool specialConstructor;

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException.tokenImage Field

This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

public string[] tokenImage;

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException Properties

The properties of the ParseException class are listed below. For a complete list of ParseException class members, see the ParseException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


Message Property

Apache Lucene.Net 2.4.0 Class Library API

ParseException.Message Property

This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed.

public override string Message {get;}

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException Methods

The methods of the ParseException class are listed below. For a complete list of ParseException class members, see the ParseException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Add_escapes Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


ParseException.Add_escapes Method

Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.

protected internal virtual string Add_escapes(
string str
);

See Also

ParseException Class | Lucene.Net.QueryParsers Namespace


QueryParser Class

For a list of all members of this type, see QueryParser Members.

System.Object
Lucene.Net.QueryParsers.QueryParserConstants
Lucene.Net.QueryParsers.QueryParser
Lucene.Net.QueryParsers.MultiFieldQueryParser

public class QueryParser : QueryParserConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

QueryParser Members | Lucene.Net.QueryParsers Namespace


QueryParser Members

QueryParser overview

Public Static Fields

AND_OPERATOR | Alternative form of QueryParser.Operator.AND
OR_OPERATOR | Alternative form of QueryParser.Operator.OR

Public Static Methods

Escape Returns a String where those characters that QueryParser expects to be escaped are escaped by a preceding
\
.
Main

Public Instance Constructors

QueryParser Overloaded. Initializes a new instance of the QueryParser class.

Public Instance Fields

jj_nt | Next token.
token | Current token
token_source | Generated token manager

Public Instance Methods

AddClause
Clause
Conjunction
Disable_tracing | Disable tracing.
Enable_tracing | Enable tracing.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateParseException | Generate ParseException.
GetAllowLeadingWildcard
GetAnalyzer
GetBooleanQuery | Overloaded. Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
GetDateResolution | Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.
GetDefaultOperator | Gets implicit operator setting, which will be either AND_OPERATOR or OR_OPERATOR.
GetEnablePositionIncrements
GetField
GetFieldQuery | Overloaded.
GetFuzzyMinSim | Get the minimal similarity for fuzzy queries.
GetFuzzyPrefixLength | Get the prefix length for fuzzy queries.
GetFuzzyQuery | Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~) appended.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLocale | Returns current locale, allowing access by subclasses.
GetLowercaseExpandedTerms
GetNextToken | Get the next Token.
GetPhraseSlop | Gets the default slop for phrases.
GetPrefixQuery
GetRangeCollator | Returns the collator used to determine index term inclusion in ranges specified either for ConstantScoreRangeQuery or RangeQuery (if SetUseOldRangeQuery(bool) is called with the parameter true).
GetRangeQuery
GetToken | Get the specific Token.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseOldRangeQuery
GetWildcardQuery
Modifiers
Parse | Parses a query string, returning a {@link Lucene.Net.Search.Query}.
Query
ReInit | Overloaded. Reinitialise.
SetAllowLeadingWildcard
SetDateResolution | Overloaded. Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
SetDefaultOperator Sets the boolean operator of the QueryParser. In default mode (
OR_OPERATOR
) terms without any modifiers are considered optional: for example
capital of Hungary
is equal to
capital OR of OR Hungary
.
In
AND_OPERATOR
mode terms are considered to be in conjuction: the above mentioned query is parsed as
capital AND of AND Hungary
SetEnablePositionIncrements
SetFuzzyMinSim | Set the minimum similarity for fuzzy queries. Default is 0.5f.
SetFuzzyPrefixLength | Set the prefix length for fuzzy queries. Default is 0.
SetLocale | Set locale used by date range parsing.
SetLowercaseExpandedTerms Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is
true
.
SetPhraseSlop | Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
SetRangeCollator | Sets the collator used to determine index term inclusion in ranges specified either for ConstantScoreRangeQuery or RangeQuery (if SetUseOldRangeQuery(bool) is called with a parameter of true. WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
SetUseOldRangeQuery By default QueryParser uses new ConstantScoreRangeQuery in preference to RangeQuery for range queries. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of range terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned RangeQuery and the above points are not required then set this option to
true
Default is
false
.
Term
TopLevelQuery
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
newBooleanClause | Builds a new BooleanClause instance.
newBooleanQuery | Builds a new BooleanQuery instance.
newFuzzyQuery | Builds a new FuzzyQuery instance.
newMatchAllDocsQuery | Builds a new MatchAllDocsQuery instance.
newMultiPhraseQuery | Builds a new MultiPhraseQuery instance.
newPhraseQuery | Builds a new PhraseQuery instance.
newPrefixQuery | Builds a new PrefixQuery instance.
newRangeQuery | Builds a new RangeQuery instance.
newTermQuery | Builds a new TermQuery instance.
newWildcardQuery | Builds a new WildcardQuery instance.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser Constructor

Constructs a query parser.

Overload List

Constructor with used supplied CharStream.

public QueryParser(CharStream);

Constructor with generated TokenManager.

public QueryParser(QueryParserTokenManager);

Constructs a query parser.

public QueryParser(string,Analyzer);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser Constructor (String, Analyzer)

Constructs a query parser.

public QueryParser(
string f,
Analyzer a
);

Parameters

f
the default field for query terms.
a
used to find terms in the query text.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser Constructor Overload List


QueryParser Constructor (CharStream)

Constructor with used supplied CharStream.

public QueryParser(
CharStream stream
);

Parameters

stream

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser Constructor Overload List


QueryParser Constructor (QueryParserTokenManager)

Constructor with generated TokenManager.

public QueryParser(
QueryParserTokenManager tm
);

Parameters

tm

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser Constructor Overload List


QueryParser Fields

The fields of the QueryParser class are listed below. For a complete list of QueryParser class members, see the QueryParser Members topic.

Public Static Fields

AND_OPERATOR | Alternative form of QueryParser.Operator.AND
OR_OPERATOR | Alternative form of QueryParser.Operator.OR

Public Instance Fields

jj_nt | Next token.
token | Current token
token_source | Generated token manager

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.AND_OPERATOR Field

Alternative form of QueryParser.Operator.AND

public static readonly Operator AND_OPERATOR;

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.jj_nt Field

Next token.

public Token jj_nt;

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.OR_OPERATOR Field

Alternative form of QueryParser.Operator.OR

public static readonly Operator OR_OPERATOR;

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.token Field

Current token

public Token token;

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.token_source Field

Generated token manager

public QueryParserTokenManager token_source;

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser Methods

The methods of the QueryParser class are listed below. For a complete list of QueryParser class members, see the QueryParser Members topic.

Public Static Methods

Escape Returns a String where those characters that QueryParser expects to be escaped are escaped by a preceding
\
.
Main

Public Instance Methods

AddClause
Clause
Conjunction
Disable_tracing | Disable tracing.
Enable_tracing | Enable tracing.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateParseException | Generate ParseException.
GetAllowLeadingWildcard
GetAnalyzer
GetBooleanQuery | Overloaded. Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
GetDateResolution | Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.
GetDefaultOperator | Gets implicit operator setting, which will be either AND_OPERATOR or OR_OPERATOR.
GetEnablePositionIncrements
GetField
GetFieldQuery | Overloaded.
GetFuzzyMinSim | Get the minimal similarity for fuzzy queries.
GetFuzzyPrefixLength | Get the prefix length for fuzzy queries.
GetFuzzyQuery | Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~) appended.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLocale | Returns current locale, allowing access by subclasses.
GetLowercaseExpandedTerms
GetNextToken | Get the next Token.
GetPhraseSlop | Gets the default slop for phrases.
GetPrefixQuery
GetRangeCollator | Returns the collator used to determine index term inclusion in ranges specified either for ConstantScoreRangeQuery or RangeQuery (if SetUseOldRangeQuery(bool) is called with the parameter true).
GetRangeQuery
GetToken | Get the specific Token.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUseOldRangeQuery
GetWildcardQuery
Modifiers
Parse | Parses a query string, returning a {@link Lucene.Net.Search.Query}.
Query
ReInit | Overloaded. Reinitialise.
SetAllowLeadingWildcard
SetDateResolution | Overloaded. Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
SetDefaultOperator Sets the boolean operator of the QueryParser. In default mode (
OR_OPERATOR
) terms without any modifiers are considered optional: for example
capital of Hungary
is equal to
capital OR of OR Hungary
.
In
AND_OPERATOR
mode terms are considered to be in conjuction: the above mentioned query is parsed as
capital AND of AND Hungary
SetEnablePositionIncrements
SetFuzzyMinSim | Set the minimum similarity for fuzzy queries. Default is 0.5f.
SetFuzzyPrefixLength | Set the prefix length for fuzzy queries. Default is 0.
SetLocale | Set locale used by date range parsing.
SetLowercaseExpandedTerms Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is
true
.
SetPhraseSlop | Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
SetRangeCollator | Sets the collator used to determine index term inclusion in ranges specified either for ConstantScoreRangeQuery or RangeQuery (if SetUseOldRangeQuery(bool) is called with a parameter of true. WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
SetUseOldRangeQuery By default QueryParser uses new ConstantScoreRangeQuery in preference to RangeQuery for range queries. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of range terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned RangeQuery and the above points are not required then set this option to
true
Default is
false
.
Term
TopLevelQuery
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
newBooleanClause | Builds a new BooleanClause instance.
newBooleanQuery | Builds a new BooleanQuery instance.
newFuzzyQuery | Builds a new FuzzyQuery instance.
newMatchAllDocsQuery | Builds a new MatchAllDocsQuery instance.
newMultiPhraseQuery | Builds a new MultiPhraseQuery instance.
newPhraseQuery | Builds a new PhraseQuery instance.
newPrefixQuery | Builds a new PrefixQuery instance.
newRangeQuery | Builds a new RangeQuery instance.
newTermQuery | Builds a new TermQuery instance.
newWildcardQuery | Builds a new WildcardQuery instance.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.AddClause Method

public virtual void AddClause(
ArrayList clauses,
int conj,
int mods,
Query q
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Clause Method

public Query Clause(
string field
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Conjunction Method

public int Conjunction();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Disable_tracing Method

Disable tracing.

public void Disable_tracing();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Enable_tracing Method

Enable tracing.

public void Enable_tracing();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Escape Method

Returns a String where those characters that QueryParser expects to be escaped are escaped by a preceding

\
.

public static string Escape(
string s
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GenerateParseException Method

Generate ParseException.

public virtual ParseException GenerateParseException();

Return Value

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetAllowLeadingWildcard Method

public virtual bool GetAllowLeadingWildcard();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | SetAllowLeadingWildcard


QueryParser.GetAnalyzer Method

public virtual Analyzer GetAnalyzer();

Return Value

Returns the analyzer.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


GetBooleanQuery Method

Apache Lucene.Net 2.4.0 Class Library API

QueryParser.GetBooleanQuery Method

Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

Overload List

Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

public virtual Query GetBooleanQuery(ArrayList);

Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

public virtual Query GetBooleanQuery(ArrayList,bool);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetBooleanQuery Method (ArrayList)

Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

public virtual Query GetBooleanQuery(
ArrayList clauses
);

Parameters

clauses
Vector that contains {@link BooleanClause} instances to join.

Return Value

Resulting {@link Query} object.

Exceptions

Exception Type | Condition
ParseException | throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.GetBooleanQuery Overload List


QueryParser.GetBooleanQuery Method (ArrayList, Boolean)

Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

public virtual Query GetBooleanQuery(
ArrayList clauses,
bool disableCoord
);

Parameters

clauses
Vector that contains {@link BooleanClause} instances to join.
disableCoord
true if coord scoring should be disabled.

Return Value

Resulting {@link Query} object.

Exceptions

Exception Type | Condition
 | ParseException throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.GetBooleanQuery Overload List


QueryParser.GetDateResolution Method

Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.

public virtual Resolution GetDateResolution(
string fieldName
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetDefaultOperator Method

Gets implicit operator setting, which will be either AND_OPERATOR or OR_OPERATOR.

public virtual Operator GetDefaultOperator();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetEnablePositionIncrements Method

public virtual bool GetEnablePositionIncrements();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | SetEnablePositionIncrements


QueryParser.GetField Method

public virtual string GetField();

Return Value

Returns the field.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


GetFieldQuery Method

Apache Lucene.Net 2.4.0 Class Library API

QueryParser.GetFieldQuery Method

Overload List

public virtual Query GetFieldQuery(string,string);

Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.

public virtual Query GetFieldQuery(string,string,int);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetFieldQuery Method (String, String)

public virtual Query GetFieldQuery(
string field,
string queryText
);

Exceptions

Exception Type | Condition
 | ParseException throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.GetFieldQuery Overload List


QueryParser.GetFieldQuery Method (String, String, Int32)

Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.

public virtual Query GetFieldQuery(
string field,
string queryText,
int slop
);

Exceptions

Exception Type | Condition
ParseException | throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.GetFieldQuery Overload List


QueryParser.GetFuzzyMinSim Method

Get the minimal similarity for fuzzy queries.

public virtual float GetFuzzyMinSim();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetFuzzyPrefixLength Method

Get the prefix length for fuzzy queries.

public virtual int GetFuzzyPrefixLength();

Return Value

Returns the fuzzyPrefixLength.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetFuzzyQuery Method

Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~) appended.

public virtual Query GetFuzzyQuery(
string field,
string termStr,
float minSimilarity
);

Parameters

field
Name of the field query will use.
termStr
Term token to use for building term for the query
minSimilarity

Return Value

Resulting {@link Query} built for the term

Exceptions

Exception Type | Condition
ParseException | throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetLocale Method

Returns current locale, allowing access by subclasses.

public virtual CultureInfo GetLocale();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetLowercaseExpandedTerms Method

public virtual bool GetLowercaseExpandedTerms();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | #SetLowercaseExpandedTerms


QueryParser.GetNextToken Method

Get the next Token.

public Token GetNextToken();

Return Value

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetPhraseSlop Method

Gets the default slop for phrases.

public virtual int GetPhraseSlop();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetPrefixQuery Method

public virtual Query GetPrefixQuery(
string field,
string termStr
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetRangeCollator Method

Returns the collator used to determine index term inclusion in ranges specified either for ConstantScoreRangeQuery or RangeQuery (if SetUseOldRangeQuery(bool) is called with the parameter true).

public CompareInfo GetRangeCollator();

Return Value

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetRangeQuery Method

public virtual Query GetRangeQuery(
string field,
string part1,
string part2,
bool inclusive
);

Exceptions

Exception Type | Condition
ParseException | throw in overridden method to disallow

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetToken Method

Get the specific Token.

public Token GetToken(
int index
);

Parameters

index

Return Value

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.GetUseOldRangeQuery Method

public virtual bool GetUseOldRangeQuery();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | SetUseOldRangeQuery


QueryParser.GetWildcardQuery Method

public virtual Query GetWildcardQuery(
string field,
string termStr
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Main Method

public static void Main(
string[] args
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Modifiers Method

public int Modifiers();

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.newBooleanClause Method

Builds a new BooleanClause instance.

protected BooleanClause newBooleanClause(
Query q,
Occur occur
);

Parameters

q
occur

Return Value

new BooleanClause instance

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.newBooleanQuery Method

Builds a new BooleanQuery instance.

protected BooleanQuery newBooleanQuery(
bool disableCoord
);

Parameters

disableCoord

Return Value

new BooleanQuery instance

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.newFuzzyQuery Method

Builds a new FuzzyQuery instance.

protected Query newFuzzyQuery(
Term term,
float minimumSimilarity,
int prefixLength
);

Parameters

term
minimumSimilarity
prefixLength

Return Value

new FuzzyQuery instance

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.newMatchAllDocsQuery Method

Builds a new MatchAllDocsQuery instance.

protected Query newMatchAllDocsQuery();

Return Value

new MatchAllDocsQuery instance

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.newMultiPhraseQuery Method

Builds a new MultiPhraseQuery instance.

protected MultiPhraseQuery newMultiPhraseQuery();

Return Value

new MultiPhraseQuery instance

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.newPhraseQuery Method

Builds a new PhraseQuery instance.

protected PhraseQuery newPhraseQuery();

Return Value

new PhraseQuery instance

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.newPrefixQuery Method

Builds a new PrefixQuery instance.

protected Query newPrefixQuery(
Term prefix
);

Parameters

prefix

Return Value

new PrefixQuery instance

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.newRangeQuery Method

Builds a new RangeQuery instance.

protected Query newRangeQuery(
string field,
string part1,
string part2,
bool inclusive
);

Parameters

field
part1
part2
inclusive

Return Value

new RangeQuery instance

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.newTermQuery Method

Builds a new TermQuery instance.

protected Query newTermQuery(
Term term
);

Parameters

term

Return Value

new TermQuery instance

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.newWildcardQuery Method

Builds a new WildcardQuery instance.

protected Query newWildcardQuery(
Term t
);

Parameters

t

Return Value

new WildcardQuery instance

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Parse Method

Parses a query string, returning a {@link Lucene.Net.Search.Query}.

public virtual Query Parse(
string query
);

Parameters

query
the query string to be parsed.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Query Method

public Query Query(
string field
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


ReInit Method

Apache Lucene.Net 2.4.0 Class Library API

QueryParser.ReInit Method

Reinitialise.

Overload List

Reinitialise.

public virtual void ReInit(CharStream);

Reinitialise.

public virtual void ReInit(QueryParserTokenManager);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.ReInit Method (CharStream)

Reinitialise.

public virtual void ReInit(
CharStream stream
);

Parameters

stream

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.ReInit Overload List


QueryParser.ReInit Method (QueryParserTokenManager)

Reinitialise.

public virtual void ReInit(
QueryParserTokenManager tm
);

Parameters

tm

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.ReInit Overload List


QueryParser.SetAllowLeadingWildcard Method

public virtual void SetAllowLeadingWildcard(
bool allowLeadingWildcard
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


SetDateResolution Method

Apache Lucene.Net 2.4.0 Class Library API

QueryParser.SetDateResolution Method

Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.

Overload List

Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.

public virtual void SetDateResolution(Resolution);

Sets the date resolution used by RangeQueries for a specific field.

public virtual void SetDateResolution(string,Resolution);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetDateResolution Method (Resolution)

Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.

public virtual void SetDateResolution(
Resolution dateResolution
);

Parameters

dateResolution
the default date resolution to set

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.SetDateResolution Overload List


QueryParser.SetDateResolution Method (String, Resolution)

Sets the date resolution used by RangeQueries for a specific field.

public virtual void SetDateResolution(
string fieldName,
Resolution dateResolution
);

Parameters

fieldName
field for which the date resolution is to be set
dateResolution
date resolution to set

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace | QueryParser.SetDateResolution Overload List


QueryParser.SetDefaultOperator Method

Sets the boolean operator of the QueryParser. In default mode (

OR_OPERATOR
) terms without any modifiers are considered optional: for example
capital of Hungary
is equal to
capital OR of OR Hungary
.
In
AND_OPERATOR
mode terms are considered to be in conjuction: the above mentioned query is parsed as
capital AND of AND Hungary

public virtual void SetDefaultOperator(
Operator op
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetEnablePositionIncrements Method

public virtual void SetEnablePositionIncrements(
bool enable
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetFuzzyMinSim Method

Set the minimum similarity for fuzzy queries. Default is 0.5f.

public virtual void SetFuzzyMinSim(
float fuzzyMinSim
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetFuzzyPrefixLength Method

Set the prefix length for fuzzy queries. Default is 0.

public virtual void SetFuzzyPrefixLength(
int fuzzyPrefixLength
);

Parameters

fuzzyPrefixLength
The fuzzyPrefixLength to set.

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetLocale Method

Set locale used by date range parsing.

public virtual void SetLocale(
CultureInfo locale
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetLowercaseExpandedTerms Method

Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is

true
.

public virtual void SetLowercaseExpandedTerms(
bool lowercaseExpandedTerms
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetPhraseSlop Method

Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.

public virtual void SetPhraseSlop(
int phraseSlop
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetRangeCollator Method

Sets the collator used to determine index term inclusion in ranges specified either for ConstantScoreRangeQuery or RangeQuery (if SetUseOldRangeQuery(bool) is called with a parameter of true.

WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

public void SetRangeCollator(
CompareInfo rc
);

Parameters

rc
the collator to use when constructing RangeQuery and ConstantScoreRangeQuery

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.SetUseOldRangeQuery Method

By default QueryParser uses new ConstantScoreRangeQuery in preference to RangeQuery for range queries. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of range terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned RangeQuery and the above points are not required then set this option to

true
Default is
false
.

public virtual void SetUseOldRangeQuery(
bool useOldRangeQuery
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Term Method

public Query Term(
string field
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.TopLevelQuery Method

public Query TopLevelQuery(
string field
);

See Also

QueryParser Class | Lucene.Net.QueryParsers Namespace


QueryParser.Operator Class

The default operator for parsing queries. Use {@link QueryParser#setDefaultOperator} to change it.

For a list of all members of this type, see QueryParser.Operator Members.

System.Object
Lucene.Net.Util.Parameter
Lucene.Net.QueryParsers.QueryParser.Operator

public sealed class QueryParser.Operator : Parameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

QueryParser.Operator Members | Lucene.Net.QueryParsers Namespace


QueryParser.Operator Members

QueryParser.Operator overview

Public Static Fields

AND
OR

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRealObject (inherited from Parameter) |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Parameter) |

Protected Internal Instance Methods

ReadResolve (inherited from Parameter) Resolves the deserialized instance to the local reference for accurate equals() and == comparisons.

See Also

QueryParser.Operator Class | Lucene.Net.QueryParsers Namespace


QueryParser.Operator Fields

The fields of the QueryParser.Operator class are listed below. For a complete list of QueryParser.Operator class members, see the QueryParser.Operator Members topic.

Public Static Fields

AND
OR

See Also

QueryParser.Operator Class | Lucene.Net.QueryParsers Namespace


QueryParser.Operator.AND Field

public static readonly Operator AND;

See Also

QueryParser.Operator Class | Lucene.Net.QueryParsers Namespace


QueryParser.Operator.OR Field

public static readonly Operator OR;

See Also

QueryParser.Operator Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants Class

Token literal values and constants. Generated by org.javacc.parser.OtherFilesGen#start()

For a list of all members of this type, see QueryParserConstants Members.

System.Object
Lucene.Net.QueryParsers.QueryParserConstants
Lucene.Net.QueryParsers.QueryParser
Lucene.Net.QueryParsers.QueryParserTokenManager

public class QueryParserConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

QueryParserConstants Members | Lucene.Net.QueryParsers Namespace


QueryParserConstants Members

QueryParserConstants overview

Public Static Fields

_ESCAPED_CHAR | RegularExpression Id.
_NUM_CHAR | RegularExpression Id.
_QUOTED_CHAR | RegularExpression Id.
_TERM_CHAR | RegularExpression Id.
_TERM_START_CHAR | RegularExpression Id.
_WHITESPACE | RegularExpression Id.
AND | RegularExpression Id.
Boost | Lexical state.
CARAT | RegularExpression Id.
COLON | RegularExpression Id.
DEFAULT | Lexical state.
EOF | End of File.
FUZZY_SLOP | RegularExpression Id.
LPAREN | RegularExpression Id.
MINUS | RegularExpression Id.
NOT | RegularExpression Id.
NUMBER | RegularExpression Id.
OR | RegularExpression Id.
PLUS | RegularExpression Id.
PREFIXTERM | RegularExpression Id.
QUOTED | RegularExpression Id.
RangeEx | Lexical state.
RANGEEX_END | RegularExpression Id.
RANGEEX_GOOP | RegularExpression Id.
RANGEEX_QUOTED | RegularExpression Id.
RANGEEX_START | RegularExpression Id.
RANGEEX_TO | RegularExpression Id.
RangeIn | Lexical state.
RANGEIN_END | RegularExpression Id.
RANGEIN_GOOP | RegularExpression Id.
RANGEIN_QUOTED | RegularExpression Id.
RANGEIN_START | RegularExpression Id.
RANGEIN_TO | RegularExpression Id.
RPAREN | RegularExpression Id.
STAR | RegularExpression Id.
TERM | RegularExpression Id.
tokenImage | Literal token values.
WILDTERM | RegularExpression Id.

Public Instance Constructors

QueryParserConstants Constructor Initializes a new instance of the QueryParserConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants Constructor

Initializes a new instance of the QueryParserConstants class.

public QueryParserConstants();

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants Fields

The fields of the QueryParserConstants class are listed below. For a complete list of QueryParserConstants class members, see the QueryParserConstants Members topic.

Public Static Fields

_ESCAPED_CHAR | RegularExpression Id.
_NUM_CHAR | RegularExpression Id.
_QUOTED_CHAR | RegularExpression Id.
_TERM_CHAR | RegularExpression Id.
_TERM_START_CHAR | RegularExpression Id.
_WHITESPACE | RegularExpression Id.
AND | RegularExpression Id.
Boost | Lexical state.
CARAT | RegularExpression Id.
COLON | RegularExpression Id.
DEFAULT | Lexical state.
EOF | End of File.
FUZZY_SLOP | RegularExpression Id.
LPAREN | RegularExpression Id.
MINUS | RegularExpression Id.
NOT | RegularExpression Id.
NUMBER | RegularExpression Id.
OR | RegularExpression Id.
PLUS | RegularExpression Id.
PREFIXTERM | RegularExpression Id.
QUOTED | RegularExpression Id.
RangeEx | Lexical state.
RANGEEX_END | RegularExpression Id.
RANGEEX_GOOP | RegularExpression Id.
RANGEEX_QUOTED | RegularExpression Id.
RANGEEX_START | RegularExpression Id.
RANGEEX_TO | RegularExpression Id.
RangeIn | Lexical state.
RANGEIN_END | RegularExpression Id.
RANGEIN_GOOP | RegularExpression Id.
RANGEIN_QUOTED | RegularExpression Id.
RANGEIN_START | RegularExpression Id.
RANGEIN_TO | RegularExpression Id.
RPAREN | RegularExpression Id.
STAR | RegularExpression Id.
TERM | RegularExpression Id.
tokenImage | Literal token values.
WILDTERM | RegularExpression Id.

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants._ESCAPED_CHAR Field

RegularExpression Id.

public const int _ESCAPED_CHAR = 2;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants._NUM_CHAR Field

RegularExpression Id.

public const int _NUM_CHAR = 1;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants._QUOTED_CHAR Field

RegularExpression Id.

public const int _QUOTED_CHAR = 6;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants._TERM_CHAR Field

RegularExpression Id.

public const int _TERM_CHAR = 4;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants._TERM_START_CHAR Field

RegularExpression Id.

public const int _TERM_START_CHAR = 3;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants._WHITESPACE Field

RegularExpression Id.

public const int _WHITESPACE = 5;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.AND Field

RegularExpression Id.

public const int AND = 8;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.Boost Field

Lexical state.

public const int Boost = 0;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.CARAT Field

RegularExpression Id.

public const int CARAT = 17;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.COLON Field

RegularExpression Id.

public const int COLON = 15;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.DEFAULT Field

Lexical state.

public const int DEFAULT = 3;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.EOF Field

End of File.

public const int EOF = 0;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.FUZZY_SLOP Field

RegularExpression Id.

public const int FUZZY_SLOP = 20;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.LPAREN Field

RegularExpression Id.

public const int LPAREN = 13;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.MINUS Field

RegularExpression Id.

public const int MINUS = 12;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.NOT Field

RegularExpression Id.

public const int NOT = 10;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.NUMBER Field

RegularExpression Id.

public const int NUMBER = 25;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.OR Field

RegularExpression Id.

public const int OR = 9;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.PLUS Field

RegularExpression Id.

public const int PLUS = 11;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.PREFIXTERM Field

RegularExpression Id.

public const int PREFIXTERM = 21;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.QUOTED Field

RegularExpression Id.

public const int QUOTED = 18;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RangeEx Field

Lexical state.

public const int RangeEx = 1;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEEX_END Field

RegularExpression Id.

public const int RANGEEX_END = 31;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEEX_GOOP Field

RegularExpression Id.

public const int RANGEEX_GOOP = 33;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEEX_QUOTED Field

RegularExpression Id.

public const int RANGEEX_QUOTED = 32;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEEX_START Field

RegularExpression Id.

public const int RANGEEX_START = 24;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEEX_TO Field

RegularExpression Id.

public const int RANGEEX_TO = 30;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RangeIn Field

Lexical state.

public const int RangeIn = 2;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEIN_END Field

RegularExpression Id.

public const int RANGEIN_END = 27;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEIN_GOOP Field

RegularExpression Id.

public const int RANGEIN_GOOP = 29;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEIN_QUOTED Field

RegularExpression Id.

public const int RANGEIN_QUOTED = 28;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEIN_START Field

RegularExpression Id.

public const int RANGEIN_START = 23;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RANGEIN_TO Field

RegularExpression Id.

public const int RANGEIN_TO = 26;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.RPAREN Field

RegularExpression Id.

public const int RPAREN = 14;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.STAR Field

RegularExpression Id.

public const int STAR = 16;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.TERM Field

RegularExpression Id.

public const int TERM = 19;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.tokenImage Field

Literal token values.

public static string[] tokenImage;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserConstants.WILDTERM Field

RegularExpression Id.

public const int WILDTERM = 22;

See Also

QueryParserConstants Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Class

For a list of all members of this type, see QueryParserTokenManager Members.

System.Object
Lucene.Net.QueryParsers.QueryParserConstants
Lucene.Net.QueryParsers.QueryParserTokenManager

public class QueryParserTokenManager : QueryParserConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

QueryParserTokenManager Members | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Members

QueryParserTokenManager overview

Public Static Fields

jjnewLexState | Lex state array.
jjstrLiteralImages | Token literal values.
lexStateNames | Lexer state names.

Public Instance Constructors

QueryParserTokenManager Overloaded. Initializes a new instance of the QueryParserTokenManager class.

Public Instance Fields

debugStream

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNextToken | Get the next Token.
GetType (inherited from Object) | Gets the Type of the current instance.
ReInit | Overloaded. Reinitialise parser.
SetDebugStream |
SwitchTo | Switch to specified lex state.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

curChar
input_stream

Protected Internal Instance Methods

JjFillToken

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Constructor

Constructor.

Overload List

Constructor.

public QueryParserTokenManager(CharStream);

Constructor.

public QueryParserTokenManager(CharStream,int);

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Constructor (CharStream)

Constructor.

public QueryParserTokenManager(
CharStream stream
);

Parameters

stream

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace | QueryParserTokenManager Constructor Overload List


QueryParserTokenManager Constructor (CharStream, Int32)

Constructor.

public QueryParserTokenManager(
CharStream stream,
int lexState
);

Parameters

stream
lexState

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace | QueryParserTokenManager Constructor Overload List


QueryParserTokenManager Fields

The fields of the QueryParserTokenManager class are listed below. For a complete list of QueryParserTokenManager class members, see the QueryParserTokenManager Members topic.

Public Static Fields

jjnewLexState | Lex state array.
jjstrLiteralImages | Token literal values.
lexStateNames | Lexer state names.

Public Instance Fields

debugStream

Protected Internal Instance Fields

curChar
input_stream

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.curChar Field

protected internal char curChar;

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.debugStream Field

public StreamWriter debugStream;

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.input_stream Field

protected internal CharStream input_stream;

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.jjnewLexState Field

Lex state array.

public static readonly int[] jjnewLexState;

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.jjstrLiteralImages Field

Token literal values.

public static readonly string[] jjstrLiteralImages;

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.lexStateNames Field

Lexer state names.

public static readonly string[] lexStateNames;

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Methods

The methods of the QueryParserTokenManager class are listed below. For a complete list of QueryParserTokenManager class members, see the QueryParserTokenManager Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNextToken | Get the next Token.
GetType (inherited from Object) | Gets the Type of the current instance.
ReInit | Overloaded. Reinitialise parser.
SetDebugStream |
SwitchTo | Switch to specified lex state.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

JjFillToken

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.GetNextToken Method

Get the next Token.

public virtual Token GetNextToken();

Return Value

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.JjFillToken Method

protected internal virtual Token JjFillToken();

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


ReInit Method

Apache Lucene.Net 2.4.0 Class Library API

QueryParserTokenManager.ReInit Method

Reinitialise parser.

Overload List

Reinitialise parser.

public virtual void ReInit(CharStream);

Reinitialise parser.

public virtual void ReInit(CharStream,int);

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.ReInit Method (CharStream)

Reinitialise parser.

public virtual void ReInit(
CharStream stream
);

Parameters

stream

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace | QueryParserTokenManager.ReInit Overload List


QueryParserTokenManager.ReInit Method (CharStream, Int32)

Reinitialise parser.

public virtual void ReInit(
CharStream stream,
int lexState
);

Parameters

stream
lexState

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace | QueryParserTokenManager.ReInit Overload List


QueryParserTokenManager.SetDebugStream Method

public virtual void SetDebugStream(
StreamWriter ds
);

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


QueryParserTokenManager.SwitchTo Method

Switch to specified lex state.

public virtual void SwitchTo(
int lexState
);

Parameters

lexState

See Also

QueryParserTokenManager Class | Lucene.Net.QueryParsers Namespace


Token Class

Describes the input token stream.

For a list of all members of this type, see Token Members.

System.Object
Lucene.Net.QueryParsers.Token

public class Token

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Token Members | Lucene.Net.QueryParsers Namespace


Token Members

Token overview

Public Static Methods

NewToken Overloaded. Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simply add something like : case MyParserConstants.ID : return new IDToken(ofKind, image); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use it in your lexical actions.

Public Instance Constructors

Token Overloaded. Initializes a new instance of the Token class.

Public Instance Fields

beginColumn | The column number of the first character of this Token.
beginLine | The line number of the first character of this Token.
endColumn | The column number of the last character of this Token.
endLine | The line number of the last character of this Token.
image | The string image of the token.
kind | An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.
next | A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this field.
specialToken | This field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this field is set to null. When there are more than one such special token, this field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken field, and so on until the first special token (whose specialToken field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this field is null.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | An optional attribute value of the Token. Tokens which are not used as syntactic sugar will often contain meaningful values that will be used later on by the compiler or interpreter. This attribute value is often different from the image. Any subclass of Token that actually wants to return a non-null value can override this method as appropriate.
ToString | Returns the image.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token Constructor

No-argument constructor

Overload List

No-argument constructor

public Token();

Constructs a new token for the specified Image.

public Token(int);

Constructs a new token for the specified Image and Kind.

public Token(int,string);

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token Constructor ()

No-argument constructor

public Token();

See Also

Token Class | Lucene.Net.QueryParsers Namespace | Token Constructor Overload List


Token Constructor (Int32)

Constructs a new token for the specified Image.

public Token(
int kind
);

See Also

Token Class | Lucene.Net.QueryParsers Namespace | Token Constructor Overload List


Token Constructor (Int32, String)

Constructs a new token for the specified Image and Kind.

public Token(
int kind,
string image
);

Parameters

kind
image

See Also

Token Class | Lucene.Net.QueryParsers Namespace | Token Constructor Overload List


Token Fields

The fields of the Token class are listed below. For a complete list of Token class members, see the Token Members topic.

Public Instance Fields

beginColumn | The column number of the first character of this Token.
beginLine | The line number of the first character of this Token.
endColumn | The column number of the last character of this Token.
endLine | The line number of the last character of this Token.
image | The string image of the token.
kind | An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.
next | A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this field.
specialToken | This field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this field is set to null. When there are more than one such special token, this field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken field, and so on until the first special token (whose specialToken field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this field is null.

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.beginColumn Field

The column number of the first character of this Token.

public int beginColumn;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.beginLine Field

The line number of the first character of this Token.

public int beginLine;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.endColumn Field

The column number of the last character of this Token.

public int endColumn;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.endLine Field

The line number of the last character of this Token.

public int endLine;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.image Field

The string image of the token.

public string image;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.kind Field

An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.

public int kind;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.next Field

A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this field.

public Token next;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.specialToken Field

This field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this field is set to null. When there are more than one such special token, this field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken field, and so on until the first special token (whose specialToken field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this field is null.

public Token specialToken;

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token Methods

The methods of the Token class are listed below. For a complete list of Token class members, see the Token Members topic.

Public Static Methods

NewToken Overloaded. Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simply add something like : case MyParserConstants.ID : return new IDToken(ofKind, image); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use it in your lexical actions.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | An optional attribute value of the Token. Tokens which are not used as syntactic sugar will often contain meaningful values that will be used later on by the compiler or interpreter. This attribute value is often different from the image. Any subclass of Token that actually wants to return a non-null value can override this method as appropriate.
ToString | Returns the image.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.GetValue Method

An optional attribute value of the Token. Tokens which are not used as syntactic sugar will often contain meaningful values that will be used later on by the compiler or interpreter. This attribute value is often different from the image. Any subclass of Token that actually wants to return a non-null value can override this method as appropriate.

public object GetValue();

See Also

Token Class | Lucene.Net.QueryParsers Namespace


NewToken Method

Apache Lucene.Net 2.4.0 Class Library API

Token.NewToken Method

Overload List

public static Token NewToken(int);

Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simply add something like : case MyParserConstants.ID : return new IDToken(ofKind, image); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use it in your lexical actions.

public static Token NewToken(int,string);

See Also

Token Class | Lucene.Net.QueryParsers Namespace


Token.NewToken Method (Int32)

public static Token NewToken(
int ofKind
);

See Also

Token Class | Lucene.Net.QueryParsers Namespace | Token.NewToken Overload List


Token.NewToken Method (Int32, String)

Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simply add something like : case MyParserConstants.ID : return new IDToken(ofKind, image); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use it in your lexical actions.

public static Token NewToken(
int ofKind,
string image
);

See Also

Token Class | Lucene.Net.QueryParsers Namespace | Token.NewToken Overload List


Token.ToString Method

Returns the image.

public override string ToString();

See Also

Token Class | Lucene.Net.QueryParsers Namespace


TokenMgrError Class

Token Manager Error.

For a list of all members of this type, see TokenMgrError Members.

System.Object
System.Exception
System.ApplicationException
Lucene.Net.QueryParsers.TokenMgrError

public class TokenMgrError : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.QueryParsers

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TokenMgrError Members | Lucene.Net.QueryParsers Namespace


TokenMgrError Members

TokenMgrError overview

Protected Internal Static Methods

addEscapes | Replaces unprintable characters by their espaced (or unicode escaped) equivalents in the given string
LexicalError | Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexicl error curLexState : lexical state in which this error occured errorLine : line number when the error occured errorColumn : column number when the error occured errorAfter : prefix that was seen before this error occured curchar : the offending character Note: You can customize the lexical error message by modifying this method.

Public Instance Constructors

TokenMgrError Overloaded. Initializes a new instance of the TokenMgrError class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


TokenMgrError Constructor

No-arg constructor.

Overload List

No-arg constructor.

public TokenMgrError();

Full constructor.

public TokenMgrError(bool,int,int,int,string,char,int);

Constructor with message and reason.

public TokenMgrError(string,int);

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


TokenMgrError Constructor ()

No-arg constructor.

public TokenMgrError();

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace | TokenMgrError Constructor Overload List


TokenMgrError Constructor (String, Int32)

Constructor with message and reason.

public TokenMgrError(
string message,
int reason
);

Parameters

message
reason

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace | TokenMgrError Constructor Overload List


TokenMgrError Constructor (Boolean, Int32, Int32, Int32, String, Char, Int32)

Full constructor.

public TokenMgrError(
bool EOFSeen,
int lexState,
int errorLine,
int errorColumn,
string errorAfter,
char curChar,
int reason
);

Parameters

EOFSeen
lexState
errorLine
errorColumn
errorAfter
curChar
reason

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace | TokenMgrError Constructor Overload List


TokenMgrError Properties

The properties of the TokenMgrError class are listed below. For a complete list of TokenMgrError class members, see the TokenMgrError Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


Message Property

Apache Lucene.Net 2.4.0 Class Library API

TokenMgrError.Message Property

You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser.

public override string Message {get;}

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


TokenMgrError Methods

The methods of the TokenMgrError class are listed below. For a complete list of TokenMgrError class members, see the TokenMgrError Members topic.

Protected Internal Static Methods

addEscapes | Replaces unprintable characters by their espaced (or unicode escaped) equivalents in the given string
LexicalError | Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexicl error curLexState : lexical state in which this error occured errorLine : line number when the error occured errorColumn : column number when the error occured errorAfter : prefix that was seen before this error occured curchar : the offending character Note: You can customize the lexical error message by modifying this method.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


TokenMgrError.addEscapes Method

Replaces unprintable characters by their espaced (or unicode escaped) equivalents in the given string

protected internal static string addEscapes(
string str
);

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


TokenMgrError.LexicalError Method

Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexicl error curLexState : lexical state in which this error occured errorLine : line number when the error occured errorColumn : column number when the error occured errorAfter : prefix that was seen before this error occured curchar : the offending character Note: You can customize the lexical error message by modifying this method.

protected internal static string LexicalError(
bool EOFSeen,
int lexState,
int errorLine,
int errorColumn,
string errorAfter,
char curChar
);

See Also

TokenMgrError Class | Lucene.Net.QueryParsers Namespace


Lucene.Net.Search

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Search Namespace

Namespace hierarchy

Classes

Class | Description
AnonymousClassScoreDocComparator
AnonymousClassScoreDocComparator1
BooleanClause | A clause in a BooleanQuery.
BooleanClause.Occur | Specifies how clauses are to occur in matching documents.
BooleanQuery | A Query that matches documents matching boolean combinations of other queries, e.g. {@link TermQuery}s, {@link PhraseQuery}s or other BooleanQuerys.
BooleanQuery.TooManyClauses | Thrown when an attempt is made to add more than {@link #GetMaxClauseCount()} clauses. This typically happens if a PrefixQuery, FuzzyQuery, WildcardQuery, or RangeQuery is expanded to many terms during search.
CachingSpanFilter | Wraps another SpanFilter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.
CachingWrapperFilter | Wraps another filter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.
ComplexExplanation | Expert: Describes the score computation for document and query, and can distinguish a match independent of a positive value.
ConstantScoreQuery | A query that wraps a filter and simply returns a constant score equal to the query boost for every document in the filter.
ConstantScoreQuery.ConstantScorer
ConstantScoreQuery.ConstantWeight
ConstantScoreRangeQuery
DefaultSimilarity | Expert: Default scoring implementation.
DisjunctionMaxQuery | A query that generates the union of documents produced by its subqueries, and that scores each document with the maximum score for that document as produced by any subquery, plus a tie breaking increment for any additional matching subqueries. This is useful when searching for a word in multiple fields with different boost factors (so that the fields cannot be combined equivalently into a single search field). We want the primary score to be the one associated with the highest boost, not the sum of the field scores (as BooleanQuery would give). If the query is "albino elephant" this ensures that "albino" matching one field and "elephant" matching another gets a higher score than "albino" matching both fields. To get this result, use both BooleanQuery and DisjunctionMaxQuery: for each term a DisjunctionMaxQuery searches for it in each field, while the set of these DisjunctionMaxQuery's is combined into a BooleanQuery. The tie breaker capability allows results that include the same term in multiple fields to be judged better than results that include this term in only the best of those multiple fields, without confusing this with the better case of two different terms in the multiple fields.
DocIdSet | A DocIdSet contains a set of doc ids. Implementing classes must provide a DocIdSetIterator to access the set.
DocIdSetIterator
Explanation | Expert: Describes the score computation for document and query.
ExtendedFieldCacheImpl
ExtendedFieldCacheImpl.AnonymousClassDoubleParser
ExtendedFieldCacheImpl.AnonymousClassLongParser
FieldCacheImpl | Expert: The default cache implementation, storing all values in memory. A WeakHashMap is used for storage.
FieldCacheImpl.AnonymousClassByteParser
FieldCacheImpl.AnonymousClassFloatParser
FieldCacheImpl.AnonymousClassIntParser
FieldCacheImpl.AnonymousClassShortParser
FieldDoc Expert: A ScoreDoc which also contains information about how to sort the referenced document. In addition to the document number and score, this object contains an array of values for the document from the field(s) used to sort. For example, if the sort criteria was to sort by fields "a", "b" then "c", the
fields
object array will have three elements, corresponding respectively to the term values for the document in fields "a", "b" and "c". The class of each element in the array will be either Integer, Float or String depending on the type of values in the terms of each field.
FieldSortedHitQueue Expert: A hit queue for sorting by hits by terms in more than one field. Uses
FieldCache.DEFAULT
for maintaining internal term lookup tables.
Filter Abstract base class providing a mechanism to limit index search results to a subset of an index.

Note: In Lucene 3.0, Bits(IndexReader) will be removed and GetDocIdSet(IndexReader) will be made abstract. All implementin classes must therefore implement GetDocIdSet(IndexReader) in order to work with Lucene 3.0.

FilteredQuery A query that applies a filter to the results of another query.

Note: the bits are retrieved from the filter each time this query is used in a search - use a CachingWrapperFilter to avoid regenerating the bits every time.

FilteredTermEnum
FilterManager | Filter caching singleton. It can be used by {@link Lucene.Net.Search.RemoteCachingWrapperFilter} or just to save filters locally for reuse. This class makes it possble to cache Filters even when using RMI, as it keeps the cache on the seaercher side of the RMI connection. Also could be used as a persistent storage for any filter as long as the filter provides a proper hashCode(), as that is used as the key in the cache. The cache is periodically cleaned up from a separate thread to ensure the cache doesn't exceed the maximum size.
FilterManager.FilterCleaner | Keeps the cache from getting too big. If we were using Java 1.5, we could use LinkedHashMap and we would not need this thread to clean out the cache. The SortedSet sortedFilterItems is used only to sort the items from the cache, so when it's time to clean up we have the TreeSet sort the FilterItems by timestamp. Removes 1.5 * the numbers of items to make the cache smaller. For example: If cache clean size is 10, and the cache is at 15, we would remove (15 - 10) * 1.5 = 7.5 round up to 8. This way we clean the cache a bit more, and avoid having the cache cleaner having to do it frequently.
FilterManager.FilterItem | Holds the filter and the last time the filter was used, to make LRU-based cache cleaning possible. TODO: Clean this up when we switch to Java 1.5
FuzzyQuery | Implements the fuzzy search query. The similiarity measurement is based on the Levenshtein (edit distance) algorithm.
FuzzyQuery.ScoreTerm
FuzzyQuery.ScoreTermQueue
FuzzyTermEnum
Hit | Obsolete. Wrapper used by {@link HitIterator} to provide a lazily loaded hit from {@link Hits}.
HitCollector
HitIterator | Obsolete. An iterator over {@link Hits} that provides lazy fetching of each document. {@link Hits#Iterator()} returns an instance of this class. Calls to {@link #Next()} return a {@link Hit} instance.
Hits | Obsolete.
IndexSearcher
MatchAllDocsQuery | A query that matches all documents.
MultiPhraseQuery | MultiPhraseQuery is a generalized version of PhraseQuery, with an added method {@link #Add(Term[])}. To use this class, to search for the phrase "Microsoft app*" first use add(Term) on the term "Microsoft", then find all terms that have "app" as prefix using IndexReader.terms(Term), and use MultiPhraseQuery.add(Term[] terms) to add them to the query.
MultiSearcher
MultiTermQuery
ParallelMultiSearcher
PhraseQuery
PrefixFilter
PrefixQuery A Query that matches documents containing terms with a specified prefix. A PrefixQuery is built by QueryParser for input like
app*
.
Query
QueryFilter | Constrains search results to only match those which also match a provided query. Results are cached, so that searches after the first on the same index using this filter are much faster.
QueryTermVector
QueryWrapperFilter
RangeFilter A Filter that restricts search results to a range of values in a given field.

This code borrows heavily from {@link RangeQuery}, but is implemented as a Filter

RangeQuery A Query that matches documents within an exclusive range. A RangeQuery is built by QueryParser for input like
[010 TO 120]
but only if the QueryParser has the useOldRangeQuery property set to true. The QueryParser default behaviour is to use the newer ConstantScoreRangeQuery class. This is generally preferable because:
  • It is faster than RangeQuery
  • Unlike RangeQuery, it does not cause a BooleanQuery.TooManyClauses exception if the range of values is large
  • Unlike RangeQuery it does not influence scoring based on the scarcity of individual terms that may match
RemoteCachingWrapperFilter Provides caching of {@link Filter}s themselves on the remote end of an RMI connection. The cache is keyed on Filter's hashCode(), so if it sees the same filter twice it will reuse the original version.

NOTE: This does NOT cache the Filter bits, but rather the Filter itself. Thus, this works hand-in-hand with {@link CachingWrapperFilter} to keep both file Filter cache and the Filter bits on the remote end, close to the searcher.

Usage:

To cache a result you must do something like RemoteCachingWrapperFilter f = new RemoteCachingWrapperFilter(new CachingWrapperFilter(myFilter));

RemoteSearchable | A remote searchable implementation.
ReqExclScorer
ReqOptSumScorer
ScoreDoc | Expert: Returned by low-level search implementations.
Scorer Expert: Common scoring functionality for different types of queries.

A

Scorer
either iterates over documents matching a query in increasing order of doc Id, or provides an explanation of the score for a query for a given document.

Document scores are computed using a given

Similarity
implementation.

Searcher
Similarity
SimilarityDelegator | Expert: Delegating scoring implementation. Useful in {@link Query#GetSimilarity(Searcher)} implementations, to override only certain methods of a Searcher's Similiarty implementation..
Sort
SortComparator
SortField | Stores information about how to sort documents by terms in an individual field. Fields must be indexed in order to sort by them.
SpanFilter | Abstract base class providing a mechanism to restrict searches to a subset of an index and also maintains and returns position information. This is useful if you want to compare the positions from a SpanQuery with the positions of items in a filter. For instance, if you had a SpanFilter that marked all the occurrences of the word "foo" in documents, and then you entered a new SpanQuery containing bar, you could not only filter by the word foo, but you could then compare position information for post processing.
SpanFilterResult The results of a SpanQueryFilter. Wraps the BitSet and the position infomration from the SpanQuery

NOTE: This API is still experimental and subject to change.
SpanFilterResult.PositionInfo
SpanFilterResult.StartEnd
SpanQueryFilter Constrains search results to only match those which also match a provided query. Also provides position information about where each document matches at the cost of extra space compared with the QueryWrapperFilter. There is an added cost to this above what is stored in a {@link QueryWrapperFilter}. Namely, the position information for each matching document is stored.

This filter does not cache. See the {@link Lucene.Net.Search.CachingSpanFilter} for a wrapper that caches.
StringIndex | Expert: Maintains caches of term values.
TermQuery | A Query that matches documents containing a term. This may be combined with other terms with a {@link BooleanQuery}.
TermScorer Expert: A
Scorer
for documents matching a
Term
.
TimeLimitedCollector
TimeLimitedCollector.TimeExceededException
TopDocCollector
TopDocs | Expert: Returned by low-level search implementations.
TopFieldDocCollector
TopFieldDocs | Expert: Returned by low-level sorted search implementations.
WildcardQuery Implements the wildcard search query. Supported wildcards are
*
, which matches any character sequence (including the empty one), and
?
, which matches any single character. Note this query can be slow, as it needs to iterate over many terms. In order to prevent extremely slow WildcardQueries, a Wildcard term should not start with one of the wildcards
*
or
?
.
WildcardTermEnum

Interfaces

Interface | Description
ByteParser | Interface to parse bytes from document fields.
DoubleParser |
ExtendedFieldCache |
FieldCache |
FloatParser | Interface to parse floats from document fields.
IntParser | Interface to parse ints from document fields.
LongParser |
ScoreDocComparator |
Searchable |
ShortParser | Interface to parse shorts from document fields.
SortComparatorSource |
Weight |

Structures

Structure | Description
ExtendedFieldCache_Fields |
FieldCache_Fields |
ScoreDocComparator_Fields | Expert: Compares two ScoreDoc objects for sorting.


AnonymousClassScoreDocComparator Class

For a list of all members of this type, see AnonymousClassScoreDocComparator Members.

System.Object
Lucene.Net.Search.AnonymousClassScoreDocComparator

public class AnonymousClassScoreDocComparator : ScoreDocComparator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

AnonymousClassScoreDocComparator Members | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator Members

AnonymousClassScoreDocComparator overview

Public Instance Constructors

AnonymousClassScoreDocComparator Constructor Initializes a new instance of the AnonymousClassScoreDocComparator class.

Public Instance Methods

Compare |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SortType |
SortValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AnonymousClassScoreDocComparator Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator Constructor

Initializes a new instance of the AnonymousClassScoreDocComparator class.

public AnonymousClassScoreDocComparator();

See Also

AnonymousClassScoreDocComparator Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator Methods

The methods of the AnonymousClassScoreDocComparator class are listed below. For a complete list of AnonymousClassScoreDocComparator class members, see the AnonymousClassScoreDocComparator Members topic.

Public Instance Methods

Compare |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SortType |
SortValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AnonymousClassScoreDocComparator Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator.Compare Method

public virtual int Compare(
ScoreDoc i,
ScoreDoc j
);

Implements

ScoreDocComparator.Compare

See Also

AnonymousClassScoreDocComparator Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator.SortType Method

public virtual int SortType();

Implements

ScoreDocComparator.SortType

See Also

AnonymousClassScoreDocComparator Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator.SortValue Method

public virtual IComparable SortValue(
ScoreDoc i
);

Implements

ScoreDocComparator.SortValue

See Also

AnonymousClassScoreDocComparator Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1 Class

For a list of all members of this type, see AnonymousClassScoreDocComparator1 Members.

System.Object
Lucene.Net.Search.AnonymousClassScoreDocComparator1

public class AnonymousClassScoreDocComparator1 : ScoreDocComparator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

AnonymousClassScoreDocComparator1 Members | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1 Members

AnonymousClassScoreDocComparator1 overview

Public Instance Constructors

AnonymousClassScoreDocComparator1 Constructor Initializes a new instance of the AnonymousClassScoreDocComparator1 class.

Public Instance Methods

Compare |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SortType |
SortValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AnonymousClassScoreDocComparator1 Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1 Constructor

Initializes a new instance of the AnonymousClassScoreDocComparator1 class.

public AnonymousClassScoreDocComparator1();

See Also

AnonymousClassScoreDocComparator1 Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1 Methods

The methods of the AnonymousClassScoreDocComparator1 class are listed below. For a complete list of AnonymousClassScoreDocComparator1 class members, see the AnonymousClassScoreDocComparator1 Members topic.

Public Instance Methods

Compare |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SortType |
SortValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AnonymousClassScoreDocComparator1 Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1.Compare Method

public virtual int Compare(
ScoreDoc i,
ScoreDoc j
);

Implements

ScoreDocComparator.Compare

See Also

AnonymousClassScoreDocComparator1 Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1.SortType Method

public virtual int SortType();

Implements

ScoreDocComparator.SortType

See Also

AnonymousClassScoreDocComparator1 Class | Lucene.Net.Search Namespace


AnonymousClassScoreDocComparator1.SortValue Method

public virtual IComparable SortValue(
ScoreDoc i
);

Implements

ScoreDocComparator.SortValue

See Also

AnonymousClassScoreDocComparator1 Class | Lucene.Net.Search Namespace


BooleanClause Class

A clause in a BooleanQuery.

For a list of all members of this type, see BooleanClause Members.

System.Object
Lucene.Net.Search.BooleanClause

public class BooleanClause

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BooleanClause Members | Lucene.Net.Search Namespace


BooleanClause Members

BooleanClause overview

Public Instance Constructors

BooleanClause Constructor Constructs a BooleanClause.

Public Instance Methods

Equals Returns true iff
o
is equal to this.
GetHashCode | Returns a hash code value for this object.
GetOccur
GetQuery
GetType (inherited from Object) | Gets the Type of the current instance.
IsProhibited
IsRequired
SetOccur
SetQuery
ToString

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause Constructor

Constructs a BooleanClause.

public BooleanClause(
Query query,
Occur occur
);

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause Methods

The methods of the BooleanClause class are listed below. For a complete list of BooleanClause class members, see the BooleanClause Members topic.

Public Instance Methods

Equals Returns true iff
o
is equal to this.
GetHashCode | Returns a hash code value for this object.
GetOccur
GetQuery
GetType (inherited from Object) | Gets the Type of the current instance.
IsProhibited
IsRequired
SetOccur
SetQuery
ToString

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.GetOccur Method

public virtual Occur GetOccur();

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.GetQuery Method

public virtual Query GetQuery();

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.IsProhibited Method

public virtual bool IsProhibited();

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.IsRequired Method

public virtual bool IsRequired();

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.SetOccur Method

public virtual void SetOccur(
Occur occur
);

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.SetQuery Method

public virtual void SetQuery(
Query query
);

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.ToString Method

public override string ToString();

See Also

BooleanClause Class | Lucene.Net.Search Namespace


BooleanClause.Occur Class

Specifies how clauses are to occur in matching documents.

For a list of all members of this type, see BooleanClause.Occur Members.

System.Object
Lucene.Net.Util.Parameter
Lucene.Net.Search.BooleanClause.Occur

public sealed class BooleanClause.Occur : Parameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BooleanClause.Occur Members | Lucene.Net.Search Namespace


BooleanClause.Occur Members

BooleanClause.Occur overview

Public Static Fields

MUST Use this operator for clauses that must appear in the matching documents.
MUST_NOT Use this operator for clauses that must not appear in the matching documents. Note that it is not possible to search for queries that only consist of a
MUST_NOT
clause.
SHOULD Use this operator for clauses that should appear in the matching documents. For a BooleanQuery with no
MUST
clauses one or more
SHOULD
clauses must match a document for the BooleanQuery to match.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRealObject (inherited from Parameter) |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Internal Instance Methods

ReadResolve (inherited from Parameter) Resolves the deserialized instance to the local reference for accurate equals() and == comparisons.

See Also

BooleanClause.Occur Class | Lucene.Net.Search Namespace


BooleanClause.Occur Fields

The fields of the BooleanClause.Occur class are listed below. For a complete list of BooleanClause.Occur class members, see the BooleanClause.Occur Members topic.

Public Static Fields

MUST Use this operator for clauses that must appear in the matching documents.
MUST_NOT Use this operator for clauses that must not appear in the matching documents. Note that it is not possible to search for queries that only consist of a
MUST_NOT
clause.
SHOULD Use this operator for clauses that should appear in the matching documents. For a BooleanQuery with no
MUST
clauses one or more
SHOULD
clauses must match a document for the BooleanQuery to match.

See Also

BooleanClause.Occur Class | Lucene.Net.Search Namespace


BooleanClause.Occur.MUST Field

Use this operator for clauses that must appear in the matching documents.

public static readonly Occur MUST;

See Also

BooleanClause.Occur Class | Lucene.Net.Search Namespace


BooleanClause.Occur.MUST_NOT Field

Use this operator for clauses that must not appear in the matching documents. Note that it is not possible to search for queries that only consist of a

MUST_NOT
clause.

public static readonly Occur MUST_NOT;

See Also

BooleanClause.Occur Class | Lucene.Net.Search Namespace


BooleanClause.Occur.SHOULD Field

Use this operator for clauses that should appear in the matching documents. For a BooleanQuery with no

MUST
clauses one or more
SHOULD
clauses must match a document for the BooleanQuery to match.

public static readonly Occur SHOULD;

See Also

BooleanClause.Occur Class | Lucene.Net.Search Namespace | setMinimumNumberShouldMatch


BooleanClause.Occur Methods

The methods of the BooleanClause.Occur class are listed below. For a complete list of BooleanClause.Occur class members, see the BooleanClause.Occur Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRealObject (inherited from Parameter) |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Internal Instance Methods

ReadResolve (inherited from Parameter) Resolves the deserialized instance to the local reference for accurate equals() and == comparisons.

See Also

BooleanClause.Occur Class | Lucene.Net.Search Namespace


BooleanClause.Occur.ToString Method

public override string ToString();

See Also

BooleanClause.Occur Class | Lucene.Net.Search Namespace


BooleanQuery Class

A Query that matches documents matching boolean combinations of other queries, e.g. {@link TermQuery}s, {@link PhraseQuery}s or other BooleanQuerys.

For a list of all members of this type, see BooleanQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.BooleanQuery

public class BooleanQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BooleanQuery Members | Lucene.Net.Search Namespace


BooleanQuery Members

BooleanQuery overview

Public Static Methods

GetAllowDocsOutOfOrder | Whether hit docs may be collected out of docid order.
GetMaxClauseCount | Return the maximum number of clauses permitted, 1024 by default. Attempts to add more than the permitted number of clauses cause {@link TooManyClauses} to be thrown.
GetUseScorer14 |
SetAllowDocsOutOfOrder | Expert: Indicates whether hit docs may be collected out of docid order. Background: although the contract of the Scorer class requires that documents be iterated in order of doc id, this was not true in early versions of Lucene. Many pieces of functionality in the current Lucene code base have undefined behavior if this contract is not upheld, but in some specific simple cases may be faster. (For example: disjunction queries with less than 32 prohibited clauses; This setting has no effect for other queries.) Specifics: By setting this option to true, calls to {@link HitCollector#Collect(int,float)} might be invoked first for docid N and only later for docid N-1. Being static, this setting is system wide.
SetMaxClauseCount |
SetUseScorer14 |

Public Instance Constructors

BooleanQuery Overloaded. Initializes a new instance of the BooleanQuery class.

Public Instance Methods

Add | Overloaded. Adds a clause to a boolean query.
Clauses | Returns the list of clauses in this query.
Clone
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetClauses | Returns the set of clauses in this query.
GetHashCode | Returns a hash code value for this object.
GetMinimumNumberShouldMatch | Gets the minimum number of the optional BooleanClauses which must be satisifed.
GetSimilarity
GetType (inherited from Object) | Gets the Type of the current instance.
IsCoordDisabled | Returns true iff {@link Similarity#Coord(int,int)} is disabled in scoring for this query instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
SetMinimumNumberShouldMatch | Specifies a minimum number of the optional BooleanClauses which must be satisfied. By default no optional clauses are necessary for a match (unless there are no required clauses). If this method is used, then the specified number of clauses is required. Use of this method is totally independent of specifying that any specific clauses are required (or prohibited). This number will only be compared against the number of matching optional clauses. EXPERT NOTE: Using this method may force collecting docs in order, regardless of whether setAllowDocsOutOfOrder(true) has been called.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

minNrShouldMatch

Protected Internal Instance Methods

CreateWeight

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery Constructor

Constructs an empty boolean query.

Overload List

Constructs an empty boolean query.

public BooleanQuery();

Constructs an empty boolean query. {@link Similarity#Coord(int,int)} may be disabled in scoring, as appropriate. For example, this score factor does not make sense for most automatically generated queries, like {@link WildcardQuery} and {@link FuzzyQuery}.

public BooleanQuery(bool);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery Constructor ()

Constructs an empty boolean query.

public BooleanQuery();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | BooleanQuery Constructor Overload List


BooleanQuery Constructor (Boolean)

Constructs an empty boolean query. {@link Similarity#Coord(int,int)} may be disabled in scoring, as appropriate. For example, this score factor does not make sense for most automatically generated queries, like {@link WildcardQuery} and {@link FuzzyQuery}.

public BooleanQuery(
bool disableCoord
);

Parameters

disableCoord
disables {@link Similarity#Coord(int,int)} in scoring.

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | BooleanQuery Constructor Overload List


BooleanQuery Fields

The fields of the BooleanQuery class are listed below. For a complete list of BooleanQuery class members, see the BooleanQuery Members topic.

Protected Internal Instance Fields

minNrShouldMatch

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.minNrShouldMatch Field

protected internal int minNrShouldMatch;

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery Methods

The methods of the BooleanQuery class are listed below. For a complete list of BooleanQuery class members, see the BooleanQuery Members topic.

Public Static Methods

GetAllowDocsOutOfOrder | Whether hit docs may be collected out of docid order.
GetMaxClauseCount | Return the maximum number of clauses permitted, 1024 by default. Attempts to add more than the permitted number of clauses cause {@link TooManyClauses} to be thrown.
GetUseScorer14 |
SetAllowDocsOutOfOrder | Expert: Indicates whether hit docs may be collected out of docid order. Background: although the contract of the Scorer class requires that documents be iterated in order of doc id, this was not true in early versions of Lucene. Many pieces of functionality in the current Lucene code base have undefined behavior if this contract is not upheld, but in some specific simple cases may be faster. (For example: disjunction queries with less than 32 prohibited clauses; This setting has no effect for other queries.) Specifics: By setting this option to true, calls to {@link HitCollector#Collect(int,float)} might be invoked first for docid N and only later for docid N-1. Being static, this setting is system wide.
SetMaxClauseCount |
SetUseScorer14 |

Public Instance Methods

Add | Overloaded. Adds a clause to a boolean query.
Clauses | Returns the list of clauses in this query.
Clone
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetClauses | Returns the set of clauses in this query.
GetHashCode | Returns a hash code value for this object.
GetMinimumNumberShouldMatch | Gets the minimum number of the optional BooleanClauses which must be satisifed.
GetSimilarity
GetType (inherited from Object) | Gets the Type of the current instance.
IsCoordDisabled | Returns true iff {@link Similarity#Coord(int,int)} is disabled in scoring for this query instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
SetMinimumNumberShouldMatch | Specifies a minimum number of the optional BooleanClauses which must be satisfied. By default no optional clauses are necessary for a match (unless there are no required clauses). If this method is used, then the specified number of clauses is required. Use of this method is totally independent of specifying that any specific clauses are required (or prohibited). This number will only be compared against the number of matching optional clauses. EXPERT NOTE: Using this method may force collecting docs in order, regardless of whether setAllowDocsOutOfOrder(true) has been called.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


Add Method

Apache Lucene.Net 2.4.0 Class Library API

BooleanQuery.Add Method

Adds a clause to a boolean query.

Overload List

Adds a clause to a boolean query.

public virtual void Add(BooleanClause);

Adds a clause to a boolean query.

public virtual void Add(Query,Occur);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | #GetMaxClauseCount


BooleanQuery.Add Method (BooleanClause)

Adds a clause to a boolean query.

public virtual void Add(
BooleanClause clause
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | BooleanQuery.Add Overload List | #GetMaxClauseCount


BooleanQuery.Add Method (Query, Occur)

Adds a clause to a boolean query.

public virtual void Add(
Query query,
Occur occur
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | BooleanQuery.Add Overload List | #GetMaxClauseCount


BooleanQuery.Clauses Method

Returns the list of clauses in this query.

public virtual IList Clauses();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.GetAllowDocsOutOfOrder Method

Whether hit docs may be collected out of docid order.

public static bool GetAllowDocsOutOfOrder();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | SetAllowDocsOutOfOrder


BooleanQuery.GetClauses Method

Returns the set of clauses in this query.

public virtual BooleanClause[] GetClauses();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.GetMaxClauseCount Method

Return the maximum number of clauses permitted, 1024 by default. Attempts to add more than the permitted number of clauses cause {@link TooManyClauses} to be thrown.

public static int GetMaxClauseCount();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | #SetMaxClauseCount


BooleanQuery.GetMinimumNumberShouldMatch Method

Gets the minimum number of the optional BooleanClauses which must be satisifed.

public virtual int GetMinimumNumberShouldMatch();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.GetSimilarity Method

public override Similarity GetSimilarity(
Searcher searcher
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.GetUseScorer14 Method

public static bool GetUseScorer14();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.IsCoordDisabled Method

Returns true iff {@link Similarity#Coord(int,int)} is disabled in scoring for this query instance.

public virtual bool IsCoordDisabled();

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | #BooleanQuery


BooleanQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.SetAllowDocsOutOfOrder Method

Expert: Indicates whether hit docs may be collected out of docid order.

Background: although the contract of the Scorer class requires that documents be iterated in order of doc id, this was not true in early versions of Lucene. Many pieces of functionality in the current Lucene code base have undefined behavior if this contract is not upheld, but in some specific simple cases may be faster. (For example: disjunction queries with less than 32 prohibited clauses; This setting has no effect for other queries.)

Specifics: By setting this option to true, calls to {@link HitCollector#Collect(int,float)} might be invoked first for docid N and only later for docid N-1. Being static, this setting is system wide.

public static void SetAllowDocsOutOfOrder(
bool allow
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.SetMaxClauseCount Method

public static void SetMaxClauseCount(
int maxClauseCount
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.SetMinimumNumberShouldMatch Method

Specifies a minimum number of the optional BooleanClauses which must be satisfied.

By default no optional clauses are necessary for a match (unless there are no required clauses). If this method is used, then the specified number of clauses is required.

Use of this method is totally independent of specifying that any specific clauses are required (or prohibited). This number will only be compared against the number of matching optional clauses.

EXPERT NOTE: Using this method may force collecting docs in order, regardless of whether setAllowDocsOutOfOrder(true) has been called.

public virtual void SetMinimumNumberShouldMatch(
int min
);

Parameters

min
the number of optional clauses that must match

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | setAllowDocsOutOfOrder


BooleanQuery.SetUseScorer14 Method

public static void SetUseScorer14(
bool use14
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

BooleanQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace


BooleanQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string field
);

See Also

BooleanQuery Class | Lucene.Net.Search Namespace | BooleanQuery.ToString Overload List


BooleanQuery.TooManyClauses Class

Thrown when an attempt is made to add more than {@link #GetMaxClauseCount()} clauses. This typically happens if a PrefixQuery, FuzzyQuery, WildcardQuery, or RangeQuery is expanded to many terms during search.

For a list of all members of this type, see BooleanQuery.TooManyClauses Members.

System.Object
System.Exception
System.SystemException
Lucene.Net.Search.BooleanQuery.TooManyClauses

public class BooleanQuery.TooManyClauses : SystemException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BooleanQuery.TooManyClauses Members | Lucene.Net.Search Namespace


BooleanQuery.TooManyClauses Members

BooleanQuery.TooManyClauses overview

Public Instance Constructors

BooleanQuery.TooManyClauses Constructor Initializes a new instance of the BooleanQuery.TooManyClauses class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BooleanQuery.TooManyClauses Class | Lucene.Net.Search Namespace


BooleanQuery.TooManyClauses Constructor

Initializes a new instance of the BooleanQuery.TooManyClauses class.

public BooleanQuery.TooManyClauses();

See Also

BooleanQuery.TooManyClauses Class | Lucene.Net.Search Namespace


BooleanQuery.TooManyClauses Properties

The properties of the BooleanQuery.TooManyClauses class are listed below. For a complete list of BooleanQuery.TooManyClauses class members, see the BooleanQuery.TooManyClauses Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

BooleanQuery.TooManyClauses Class | Lucene.Net.Search Namespace


Message Property

Apache Lucene.Net 2.4.0 Class Library API

BooleanQuery.TooManyClauses.Message Property

public override string Message {get;}

See Also

BooleanQuery.TooManyClauses Class | Lucene.Net.Search Namespace


ByteParser Interface

Interface to parse bytes from document fields.

For a list of all members of this type, see ByteParser Members.

public interface ByteParser

Types that implement ByteParser

Type | Description
FieldCacheImpl.AnonymousClassByteParser |

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ByteParser Members | Lucene.Net.Search Namespace | GetBytes


ByteParser Members

ByteParser overview

Public Instance Methods

ParseByte Return a single Byte representation of this field's value.

See Also

ByteParser Interface | Lucene.Net.Search Namespace | GetBytes


ByteParser Methods

The methods of the ByteParser interface are listed below. For a complete list of ByteParser interface members, see the ByteParser Members topic.

Public Instance Methods

ParseByte Return a single Byte representation of this field's value.

See Also

ByteParser Interface | Lucene.Net.Search Namespace | GetBytes


ByteParser.ParseByte Method

Return a single Byte representation of this field's value.

byte ParseByte(
string string_Renamed
);

See Also

ByteParser Interface | Lucene.Net.Search Namespace


CachingSpanFilter Class

Wraps another SpanFilter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.

For a list of all members of this type, see CachingSpanFilter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.SpanFilter
Lucene.Net.Search.CachingSpanFilter

public class CachingSpanFilter : SpanFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CachingSpanFilter Members | Lucene.Net.Search Namespace


CachingSpanFilter Members

CachingSpanFilter overview

Public Instance Constructors

CachingSpanFilter Constructor

Public Instance Methods

Bits | Obsolete.
BitSpans |
Equals |
GetDocIdSet |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

cache | A transient Filter cache. To cache Filters even when using {@link Lucene.Net.Search.RemoteSearchable} use {@link Lucene.Net.Search.RemoteCachingWrapperFilter} instead.
filter |

See Also

CachingSpanFilter Class | Lucene.Net.Search Namespace


CachingSpanFilter Constructor

public CachingSpanFilter(
SpanFilter filter
);

Parameters

filter
Filter to cache results of

See Also

CachingSpanFilter Class | Lucene.Net.Search Namespace


CachingSpanFilter Fields

The fields of the CachingSpanFilter class are listed below. For a complete list of CachingSpanFilter class members, see the CachingSpanFilter Members topic.

Protected Internal Instance Fields

cache | A transient Filter cache. To cache Filters even when using {@link Lucene.Net.Search.RemoteSearchable} use {@link Lucene.Net.Search.RemoteCachingWrapperFilter} instead.
filter |

See Also

CachingSpanFilter Class | Lucene.Net.Search Namespace


CachingSpanFilter.cache Field

A transient Filter cache. To cache Filters even when using {@link Lucene.Net.Search.RemoteSearchable} use {@link Lucene.Net.Search.RemoteCachingWrapperFilter} instead.

protected internal IDictionary cache;

See Also

CachingSpanFilter Class | Lucene.Net.Search Namespace


CachingSpanFilter.filter Field

protected internal SpanFilter filter;

See Also

CachingSpanFilter Class | Lucene.Net.Search Namespace


CachingSpanFilter Methods

The methods of the CachingSpanFilter class are listed below. For a complete list of CachingSpanFilter class members, see the CachingSpanFilter Members topic.

Public Instance Methods

Bits | Obsolete.
BitSpans |
Equals |
GetDocIdSet |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CachingSpanFilter Class | Lucene.Net.Search Namespace


CachingSpanFilter.Bits Method

NOTE: This method is now obsolete.

Use GetDocIdSet(IndexReader) instead

public override BitArray Bits(
IndexReader reader
);

See Also

CachingSpanFilter Class | Lucene.Net.Search Namespace


CachingSpanFilter.BitSpans Method

public override SpanFilterResult BitSpans(
IndexReader reader
);

See Also

CachingSpanFilter Class | Lucene.Net.Search Namespace


CachingSpanFilter.Equals Method

public override bool Equals(
object o
);

See Also

CachingSpanFilter Class | Lucene.Net.Search Namespace


CachingSpanFilter.GetDocIdSet Method

public override DocIdSet GetDocIdSet(
IndexReader reader
);

See Also

CachingSpanFilter Class | Lucene.Net.Search Namespace


CachingSpanFilter.GetHashCode Method

public override int GetHashCode();

See Also

CachingSpanFilter Class | Lucene.Net.Search Namespace


CachingSpanFilter.ToString Method

public override string ToString();

See Also

CachingSpanFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter Class

Wraps another filter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.

For a list of all members of this type, see CachingWrapperFilter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.CachingWrapperFilter
Lucene.Net.Search.QueryFilter

public class CachingWrapperFilter : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CachingWrapperFilter Members | Lucene.Net.Search Namespace


CachingWrapperFilter Members

CachingWrapperFilter overview

Public Instance Constructors

CachingWrapperFilter Constructor

Public Instance Methods

Bits | Obsolete.
Equals |
GetDocIdSet |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

cache | A transient Filter cache. To cache Filters even when using {@link RemoteSearchable} use {@link RemoteCachingWrapperFilter} instead.
filter |

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter Constructor

public CachingWrapperFilter(
Filter filter
);

Parameters

filter
Filter to cache results of

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter Fields

The fields of the CachingWrapperFilter class are listed below. For a complete list of CachingWrapperFilter class members, see the CachingWrapperFilter Members topic.

Protected Internal Instance Fields

cache | A transient Filter cache. To cache Filters even when using {@link RemoteSearchable} use {@link RemoteCachingWrapperFilter} instead.
filter |

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter.cache Field

A transient Filter cache. To cache Filters even when using {@link RemoteSearchable} use {@link RemoteCachingWrapperFilter} instead.

protected internal IDictionary cache;

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter.filter Field

protected internal Filter filter;

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter Methods

The methods of the CachingWrapperFilter class are listed below. For a complete list of CachingWrapperFilter class members, see the CachingWrapperFilter Members topic.

Public Instance Methods

Bits | Obsolete.
Equals |
GetDocIdSet |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter.Bits Method

NOTE: This method is now obsolete.

Use GetDocIdSet(IndexReader) instead.

public override BitArray Bits(
IndexReader reader
);

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter.Equals Method

public override bool Equals(
object o
);

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter.GetDocIdSet Method

public override DocIdSet GetDocIdSet(
IndexReader reader
);

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter.GetHashCode Method

public override int GetHashCode();

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


CachingWrapperFilter.ToString Method

public override string ToString();

See Also

CachingWrapperFilter Class | Lucene.Net.Search Namespace


ComplexExplanation Class

Expert: Describes the score computation for document and query, and can distinguish a match independent of a positive value.

For a list of all members of this type, see ComplexExplanation Members.

System.Object
Lucene.Net.Search.Explanation
Lucene.Net.Search.ComplexExplanation

public class ComplexExplanation : Explanation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ComplexExplanation Members | Lucene.Net.Search Namespace


ComplexExplanation Members

ComplexExplanation overview

Public Instance Constructors

ComplexExplanation Overloaded. Initializes a new instance of the ComplexExplanation class.

Public Instance Methods

AddDetail (inherited from Explanation) | Adds a sub-node to this explanation node.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDescription (inherited from Explanation) | A description of this explanation node.
GetDetails (inherited from Explanation) | The sub-nodes of this explanation node.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMatch | The match status of this explanation node.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from Explanation) | The value assigned to this explanation node.
IsMatch | Indicates whether or not this Explanation models a good match. If the match statis is explicitly set (ie: not null) this method uses it; otherwise it defers to the superclass.
SetDescription (inherited from Explanation) | Sets the description of this explanation node.
SetMatch | Sets the match status assigned to this explanation node.
SetValue (inherited from Explanation) | Sets the value assigned to this explanation node.
ToHtml (inherited from Explanation) | Render an explanation as HTML.
ToString (inherited from Explanation) | Overloaded. Render an explanation as text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSummary |
ToString (inherited from Explanation) | Overloaded. Render an explanation as text.

See Also

ComplexExplanation Class | Lucene.Net.Search Namespace


ComplexExplanation Constructor

Initializes a new instance of the ComplexExplanation class.

Overload List

Initializes a new instance of the ComplexExplanation class.

public ComplexExplanation();

public ComplexExplanation(bool,float,string);

See Also

ComplexExplanation Class | Lucene.Net.Search Namespace


ComplexExplanation Constructor ()

Initializes a new instance of the ComplexExplanation class.

public ComplexExplanation();

See Also

ComplexExplanation Class | Lucene.Net.Search Namespace | ComplexExplanation Constructor Overload List


ComplexExplanation Constructor (Boolean, Single, String)

public ComplexExplanation(
bool match,
float value_Renamed,
string description
);

See Also

ComplexExplanation Class | Lucene.Net.Search Namespace | ComplexExplanation Constructor Overload List


ComplexExplanation Methods

The methods of the ComplexExplanation class are listed below. For a complete list of ComplexExplanation class members, see the ComplexExplanation Members topic.

Public Instance Methods

AddDetail (inherited from Explanation) | Adds a sub-node to this explanation node.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDescription (inherited from Explanation) | A description of this explanation node.
GetDetails (inherited from Explanation) | The sub-nodes of this explanation node.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMatch | The match status of this explanation node.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from Explanation) | The value assigned to this explanation node.
IsMatch | Indicates whether or not this Explanation models a good match. If the match statis is explicitly set (ie: not null) this method uses it; otherwise it defers to the superclass.
SetDescription (inherited from Explanation) | Sets the description of this explanation node.
SetMatch | Sets the match status assigned to this explanation node.
SetValue (inherited from Explanation) | Sets the value assigned to this explanation node.
ToHtml (inherited from Explanation) | Render an explanation as HTML.
ToString (inherited from Explanation) | Overloaded. Render an explanation as text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSummary |
ToString (inherited from Explanation) | Overloaded. Render an explanation as text.

See Also

ComplexExplanation Class | Lucene.Net.Search Namespace


ComplexExplanation.GetMatch Method

The match status of this explanation node.

public virtual bool GetMatch();

Return Value

May be null if match status is unknown

See Also

ComplexExplanation Class | Lucene.Net.Search Namespace


ComplexExplanation.GetSummary Method

protected internal override string GetSummary();

See Also

ComplexExplanation Class | Lucene.Net.Search Namespace


ComplexExplanation.IsMatch Method

Indicates whether or not this Explanation models a good match.

If the match statis is explicitly set (ie: not null) this method uses it; otherwise it defers to the superclass.

public override bool IsMatch();

See Also

ComplexExplanation Class | Lucene.Net.Search Namespace |


ComplexExplanation.SetMatch Method

Sets the match status assigned to this explanation node.

public virtual void SetMatch(
bool match
);

Parameters

match
May be null if match status is unknown

See Also

ComplexExplanation Class | Lucene.Net.Search Namespace


ConstantScoreQuery Class

A query that wraps a filter and simply returns a constant score equal to the query boost for every document in the filter.

For a list of all members of this type, see ConstantScoreQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.ConstantScoreQuery

public class ConstantScoreQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ConstantScoreQuery Members | Lucene.Net.Search Namespace


ConstantScoreQuery Members

ConstantScoreQuery overview

Public Instance Constructors

ConstantScoreQuery Constructor

Public Instance Methods

Clone
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true if
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetFilter | Returns the encapsulated filter
GetHashCode | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

filter

Protected Internal Instance Methods

CreateWeight

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ConstantScoreQuery Constructor

public ConstantScoreQuery(
Filter filter
);

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ConstantScoreQuery Fields

The fields of the ConstantScoreQuery class are listed below. For a complete list of ConstantScoreQuery class members, see the ConstantScoreQuery Members topic.

Protected Internal Instance Fields

filter

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ConstantScoreQuery.filter Field

protected internal Filter filter;

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ConstantScoreQuery Methods

The methods of the ConstantScoreQuery class are listed below. For a complete list of ConstantScoreQuery class members, see the ConstantScoreQuery Members topic.

Public Instance Methods

Clone
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true if
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetFilter | Returns the encapsulated filter
GetHashCode | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ConstantScoreQuery.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ConstantScoreQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ConstantScoreQuery.Equals Method

Returns true if

o
is equal to this.

public override bool Equals(
object o
);

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ConstantScoreQuery.GetFilter Method

Returns the encapsulated filter

public virtual Filter GetFilter();

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ConstantScoreQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ConstantScoreQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

ConstantScoreQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string field
);

See Also

ConstantScoreQuery Class | Lucene.Net.Search Namespace | ConstantScoreQuery.ToString Overload List


ConstantScoreQuery.ConstantScorer Class

For a list of all members of this type, see ConstantScoreQuery.ConstantScorer Members.

System.Object
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Search.Scorer
Lucene.Net.Search.ConstantScoreQuery.ConstantScorer

protected internal class ConstantScoreQuery.ConstantScorer : Scorer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ConstantScoreQuery.ConstantScorer Members | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer Members

ConstantScoreQuery.ConstantScorer overview

Public Instance Constructors

ConstantScoreQuery.ConstantScorer Constructor

Public Instance Properties

Enclosing_Instance

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Scorer) | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Score | Overloaded.
Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Score (inherited from Scorer) Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.

See Also

ConstantScoreQuery.ConstantScorer Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer Constructor

public ConstantScoreQuery.ConstantScorer(
ConstantScoreQuery enclosingInstance,
Similarity similarity,
IndexReader reader,
Weight w
);

See Also

ConstantScoreQuery.ConstantScorer Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer Properties

The properties of the ConstantScoreQuery.ConstantScorer class are listed below. For a complete list of ConstantScoreQuery.ConstantScorer class members, see the ConstantScoreQuery.ConstantScorer Members topic.

Public Instance Properties

Enclosing_Instance

See Also

ConstantScoreQuery.ConstantScorer Class | Lucene.Net.Search Namespace


Enclosing_Instance Property

Apache Lucene.Net 2.4.0 Class Library API

ConstantScoreQuery.ConstantScorer.Enclosing_Instance Property

public ConstantScoreQuery Enclosing_Instance {get;}

See Also

ConstantScoreQuery.ConstantScorer Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer Methods

The methods of the ConstantScoreQuery.ConstantScorer class are listed below. For a complete list of ConstantScoreQuery.ConstantScorer class members, see the ConstantScoreQuery.ConstantScorer Members topic.

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Scorer) | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Score | Overloaded.
Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Score (inherited from Scorer) Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.

See Also

ConstantScoreQuery.ConstantScorer Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer.Doc Method

public override int Doc();

See Also

ConstantScoreQuery.ConstantScorer Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer.Explain Method

public override Explanation Explain(
int doc
);

See Also

ConstantScoreQuery.ConstantScorer Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer.Next Method

public override bool Next();

See Also

ConstantScoreQuery.ConstantScorer Class | Lucene.Net.Search Namespace


Score Method

Apache Lucene.Net 2.4.0 Class Library API

ConstantScoreQuery.ConstantScorer.Score Method

Overload List

public override float Score();

Inherited from Scorer.

public virtual void Score(HitCollector);

Inherited from Scorer.

protected internal virtual bool Score(HitCollector,int);

See Also

ConstantScoreQuery.ConstantScorer Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer.Score Method ()

public override float Score();

See Also

ConstantScoreQuery.ConstantScorer Class | Lucene.Net.Search Namespace | ConstantScoreQuery.ConstantScorer.Score Overload List


ConstantScoreQuery.ConstantScorer.SkipTo Method

public override bool SkipTo(
int target
);

See Also

ConstantScoreQuery.ConstantScorer Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight Class

For a list of all members of this type, see ConstantScoreQuery.ConstantWeight Members.

System.Object
Lucene.Net.Search.ConstantScoreQuery.ConstantWeight

protected internal class ConstantScoreQuery.ConstantWeight : Weight

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ConstantScoreQuery.ConstantWeight Members | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight Members

ConstantScoreQuery.ConstantWeight overview

Public Instance Constructors

ConstantScoreQuery.ConstantWeight Constructor

Public Instance Properties

Enclosing_Instance

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue |
Normalize |
Scorer |
SumOfSquaredWeights |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConstantScoreQuery.ConstantWeight Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight Constructor

public ConstantScoreQuery.ConstantWeight(
ConstantScoreQuery enclosingInstance,
Searcher searcher
);

See Also

ConstantScoreQuery.ConstantWeight Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight Properties

The properties of the ConstantScoreQuery.ConstantWeight class are listed below. For a complete list of ConstantScoreQuery.ConstantWeight class members, see the ConstantScoreQuery.ConstantWeight Members topic.

Public Instance Properties

Enclosing_Instance

See Also

ConstantScoreQuery.ConstantWeight Class | Lucene.Net.Search Namespace


Enclosing_Instance Property

Apache Lucene.Net 2.4.0 Class Library API

ConstantScoreQuery.ConstantWeight.Enclosing_Instance Property

public ConstantScoreQuery Enclosing_Instance {get;}

See Also

ConstantScoreQuery.ConstantWeight Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight Methods

The methods of the ConstantScoreQuery.ConstantWeight class are listed below. For a complete list of ConstantScoreQuery.ConstantWeight class members, see the ConstantScoreQuery.ConstantWeight Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue |
Normalize |
Scorer |
SumOfSquaredWeights |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConstantScoreQuery.ConstantWeight Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight.Explain Method

public virtual Explanation Explain(
IndexReader reader,
int doc
);

Implements

Weight.Explain

See Also

ConstantScoreQuery.ConstantWeight Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight.GetQuery Method

public virtual Query GetQuery();

Implements

Weight.GetQuery

See Also

ConstantScoreQuery.ConstantWeight Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight.GetValue Method

public virtual float GetValue();

Implements

Weight.GetValue

See Also

ConstantScoreQuery.ConstantWeight Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight.Normalize Method

public virtual void Normalize(
float norm
);

Implements

Weight.Normalize

See Also

ConstantScoreQuery.ConstantWeight Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight.Scorer Method

public virtual Scorer Scorer(
IndexReader reader
);

Implements

Weight.Scorer

See Also

ConstantScoreQuery.ConstantWeight Class | Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight.SumOfSquaredWeights Method

public virtual float SumOfSquaredWeights();

Implements

Weight.SumOfSquaredWeights

See Also

ConstantScoreQuery.ConstantWeight Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery Class

For a list of all members of this type, see ConstantScoreRangeQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.ConstantScoreRangeQuery

public class ConstantScoreRangeQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ConstantScoreRangeQuery Members | Lucene.Net.Search Namespace


ConstantScoreRangeQuery Members

ConstantScoreRangeQuery overview

Public Instance Constructors

ConstantScoreRangeQuery Overloaded. Initializes a new instance of the ConstantScoreRangeQuery class.

Public Instance Methods

Clone
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true if
o
is equal to this.
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField | Returns the field name for this query
GetHashCode | Returns a hash code value for this object.
GetLowerVal | Returns the value of the lower endpoint of this range query, null if open ended
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUpperVal | Returns the value of the upper endpoint of this range query, null if open ended
IncludesLower Returns
true
if the lower endpoint is inclusive
IncludesUpper Returns
true
if the upper endpoint is inclusive
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery Constructor

Overload List

public ConstantScoreRangeQuery(string,string,string,bool,bool);

public ConstantScoreRangeQuery(string,string,string,bool,bool,CompareInfo);

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery Constructor (String, String, String, Boolean, Boolean)

public ConstantScoreRangeQuery(
string fieldName,
string lowerVal,
string upperVal,
bool includeLower,
bool includeUpper
);

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace | ConstantScoreRangeQuery Constructor Overload List


ConstantScoreRangeQuery Constructor (String, String, String, Boolean, Boolean, CompareInfo)

public ConstantScoreRangeQuery(
string fieldName,
string lowerVal,
string upperVal,
bool includeLower,
bool includeUpper,
CompareInfo collator
);

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace | ConstantScoreRangeQuery Constructor Overload List


ConstantScoreRangeQuery Methods

The methods of the ConstantScoreRangeQuery class are listed below. For a complete list of ConstantScoreRangeQuery class members, see the ConstantScoreRangeQuery Members topic.

Public Instance Methods

Clone
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true if
o
is equal to this.
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField | Returns the field name for this query
GetHashCode | Returns a hash code value for this object.
GetLowerVal | Returns the value of the lower endpoint of this range query, null if open ended
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUpperVal | Returns the value of the upper endpoint of this range query, null if open ended
IncludesLower Returns
true
if the lower endpoint is inclusive
IncludesUpper Returns
true
if the upper endpoint is inclusive
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery.Equals Method

Returns true if

o
is equal to this.

public override bool Equals(
object o
);

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery.GetField Method

Returns the field name for this query

public virtual string GetField();

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery.GetLowerVal Method

Returns the value of the lower endpoint of this range query, null if open ended

public virtual string GetLowerVal();

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery.GetUpperVal Method

Returns the value of the upper endpoint of this range query, null if open ended

public virtual string GetUpperVal();

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery.IncludesLower Method

Returns

true
if the lower endpoint is inclusive

public virtual bool IncludesLower();

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery.IncludesUpper Method

Returns

true
if the upper endpoint is inclusive

public virtual bool IncludesUpper();

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

ConstantScoreRangeQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace


ConstantScoreRangeQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string field
);

See Also

ConstantScoreRangeQuery Class | Lucene.Net.Search Namespace | ConstantScoreRangeQuery.ToString Overload List


DefaultSimilarity Class

Expert: Default scoring implementation.

For a list of all members of this type, see DefaultSimilarity Members.

System.Object
Lucene.Net.Search.Similarity
Lucene.Net.Search.DefaultSimilarity

public class DefaultSimilarity : Similarity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DefaultSimilarity Members | Lucene.Net.Search Namespace


DefaultSimilarity Members

DefaultSimilarity overview

Public Instance Constructors

DefaultSimilarity Constructor Initializes a new instance of the DefaultSimilarity class.

Public Instance Methods

Coord Implemented as
overlap / maxOverlap
.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Idf Overloaded. Implemented as
log(numDocs/(docFreq+1)) + 1
.
Idf (inherited from Similarity) | Overloaded.
LengthNorm Implemented as
1/sqrt(numTerms)
.
QueryNorm Implemented as
1/sqrt(sumOfSquaredWeights)
.
ScorePayload (inherited from Similarity)
SloppyFreq Implemented as
1 / (distance + 1)
.
Tf Overloaded. Implemented as
sqrt(freq)
.
Tf (inherited from Similarity) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity Constructor

Initializes a new instance of the DefaultSimilarity class.

public DefaultSimilarity();

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity Methods

The methods of the DefaultSimilarity class are listed below. For a complete list of DefaultSimilarity class members, see the DefaultSimilarity Members topic.

Public Instance Methods

Coord Implemented as
overlap / maxOverlap
.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Idf Overloaded. Implemented as
log(numDocs/(docFreq+1)) + 1
.
Idf (inherited from Similarity) | Overloaded.
LengthNorm Implemented as
1/sqrt(numTerms)
.
QueryNorm Implemented as
1/sqrt(sumOfSquaredWeights)
.
ScorePayload (inherited from Similarity)
SloppyFreq Implemented as
1 / (distance + 1)
.
Tf Overloaded. Implemented as
sqrt(freq)
.
Tf (inherited from Similarity) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity.Coord Method

Implemented as

overlap / maxOverlap
.

public override float Coord(
int overlap,
int maxOverlap
);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


Idf Method

Apache Lucene.Net 2.4.0 Class Library API

DefaultSimilarity.Idf Method

Implemented as

log(numDocs/(docFreq+1)) + 1
.

Overload List

Inherited from Similarity.

public virtual float Idf(Term,Searcher);

Inherited from Similarity.

public virtual float Idf(ICollection,Searcher);

Implemented as

log(numDocs/(docFreq+1)) + 1
.

public override float Idf(int,int);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity.Idf Method (Int32, Int32)

Implemented as

log(numDocs/(docFreq+1)) + 1
.

public override float Idf(
int docFreq,
int numDocs
);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace | DefaultSimilarity.Idf Overload List


DefaultSimilarity.LengthNorm Method

Implemented as

1/sqrt(numTerms)
.

public override float LengthNorm(
string fieldName,
int numTerms
);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity.QueryNorm Method

Implemented as

1/sqrt(sumOfSquaredWeights)
.

public override float QueryNorm(
float sumOfSquaredWeights
);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity.SloppyFreq Method

Implemented as

1 / (distance + 1)
.

public override float SloppyFreq(
int distance
);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


Tf Method

Apache Lucene.Net 2.4.0 Class Library API

DefaultSimilarity.Tf Method

Implemented as

sqrt(freq)
.

Overload List

Inherited from Similarity.

public virtual float Tf(int);

Implemented as

sqrt(freq)
.

public override float Tf(float);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace


DefaultSimilarity.Tf Method (Single)

Implemented as

sqrt(freq)
.

public override float Tf(
float freq
);

See Also

DefaultSimilarity Class | Lucene.Net.Search Namespace | DefaultSimilarity.Tf Overload List


DisjunctionMaxQuery Class

A query that generates the union of documents produced by its subqueries, and that scores each document with the maximum score for that document as produced by any subquery, plus a tie breaking increment for any additional matching subqueries. This is useful when searching for a word in multiple fields with different boost factors (so that the fields cannot be combined equivalently into a single search field). We want the primary score to be the one associated with the highest boost, not the sum of the field scores (as BooleanQuery would give). If the query is "albino elephant" this ensures that "albino" matching one field and "elephant" matching another gets a higher score than "albino" matching both fields. To get this result, use both BooleanQuery and DisjunctionMaxQuery: for each term a DisjunctionMaxQuery searches for it in each field, while the set of these DisjunctionMaxQuery's is combined into a BooleanQuery. The tie breaker capability allows results that include the same term in multiple fields to be judged better than results that include this term in only the best of those multiple fields, without confusing this with the better case of two different terms in the multiple fields.

For a list of all members of this type, see DisjunctionMaxQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.DisjunctionMaxQuery

public class DisjunctionMaxQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DisjunctionMaxQuery Members | Lucene.Net.Search Namespace


DisjunctionMaxQuery Members

DisjunctionMaxQuery overview

Public Instance Constructors

DisjunctionMaxQuery Overloaded. Initializes a new instance of the DisjunctionMaxQuery class.

Public Instance Methods

Add | Overloaded. Add a subquery to this disjunction
Clone | Create a shallow copy of us -- used in rewriting if necessary
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals | Return true iff we represent the same query as o
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Compute a hash code for hashing us
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Iterator
Rewrite | Optimize our representation and our subqueries representations
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prettyprint us.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace


DisjunctionMaxQuery Constructor

Creates a new empty DisjunctionMaxQuery. Use add() to add the subqueries.

Overload List

public DisjunctionMaxQuery(ICollection,float);

Creates a new empty DisjunctionMaxQuery. Use add() to add the subqueries.

public DisjunctionMaxQuery(float);

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace


DisjunctionMaxQuery Constructor (Single)

Creates a new empty DisjunctionMaxQuery. Use add() to add the subqueries.

public DisjunctionMaxQuery(
float tieBreakerMultiplier
);

Parameters

tieBreakerMultiplier
the score of each non-maximum disjunct for a document is multiplied by this weight and added into the final score. If non-zero, the value should be small, on the order of 0.1, which says that 10 occurrences of word in a lower-scored field that is also in a higher scored field is just as good as a unique word in the lower scored field (i.e., one that is not in any higher scored field.

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace | DisjunctionMaxQuery Constructor Overload List


DisjunctionMaxQuery Constructor (ICollection, Single)

public DisjunctionMaxQuery(
ICollection disjuncts,
float tieBreakerMultiplier
);

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace | DisjunctionMaxQuery Constructor Overload List


DisjunctionMaxQuery Methods

The methods of the DisjunctionMaxQuery class are listed below. For a complete list of DisjunctionMaxQuery class members, see the DisjunctionMaxQuery Members topic.

Public Instance Methods

Add | Overloaded. Add a subquery to this disjunction
Clone | Create a shallow copy of us -- used in rewriting if necessary
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals | Return true iff we represent the same query as o
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Compute a hash code for hashing us
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Iterator
Rewrite | Optimize our representation and our subqueries representations
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prettyprint us.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace


Add Method

Apache Lucene.Net 2.4.0 Class Library API

DisjunctionMaxQuery.Add Method

Add a subquery to this disjunction

Overload List

Add a subquery to this disjunction

public virtual void Add(Query);

public virtual void Add(ICollection);

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace


DisjunctionMaxQuery.Add Method (Query)

Add a subquery to this disjunction

public virtual void Add(
Query query
);

Parameters

query
the disjunct added

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace | DisjunctionMaxQuery.Add Overload List


DisjunctionMaxQuery.Add Method (ICollection)

public virtual void Add(
ICollection disjuncts
);

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace | DisjunctionMaxQuery.Add Overload List


DisjunctionMaxQuery.Clone Method

Create a shallow copy of us -- used in rewriting if necessary

public override object Clone();

Return Value

a copy of us (but reuse, don't copy, our subqueries)

Implements

ICloneable.Clone

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace


DisjunctionMaxQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace


DisjunctionMaxQuery.Equals Method

Return true iff we represent the same query as o

public override bool Equals(
object o
);

Parameters

o
another object

Return Value

true iff o is a DisjunctionMaxQuery with the same boost and the same subqueries, in the same order, as us

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace


DisjunctionMaxQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace


DisjunctionMaxQuery.GetHashCode Method

Compute a hash code for hashing us

public override int GetHashCode();

Return Value

the hash code

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace


DisjunctionMaxQuery.Iterator Method

public virtual IEnumerator Iterator();

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace


DisjunctionMaxQuery.Rewrite Method

Optimize our representation and our subqueries representations

public override Query Rewrite(
IndexReader reader
);

Parameters

reader
the IndexReader we query

Return Value

an optimized copy of us (which may not be a copy if there is nothing to optimize)

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

DisjunctionMaxQuery.ToString Method

Prettyprint us.

Overload List

Inherited from Query.

public override string ToString();

Prettyprint us.

public override string ToString(string);

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace


DisjunctionMaxQuery.ToString Method (String)

Prettyprint us.

public override string ToString(
string field
);

Parameters

field
the field to which we are applied

Return Value

a string that shows what we do, of the form "(disjunct1 | disjunct2 | ... | disjunctn)^boost"

See Also

DisjunctionMaxQuery Class | Lucene.Net.Search Namespace | DisjunctionMaxQuery.ToString Overload List


DocIdSet Class

A DocIdSet contains a set of doc ids. Implementing classes must provide a DocIdSetIterator to access the set.

For a list of all members of this type, see DocIdSet Members.

System.Object
Lucene.Net.Search.DocIdSet
Lucene.Net.Util.DocIdBitSet
Lucene.Net.Util.OpenBitSet
Lucene.Net.Util.SortedVIntList

public abstract class DocIdSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DocIdSet Members | Lucene.Net.Search Namespace


DocIdSet Members

DocIdSet overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Iterator |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

DocIdSet Constructor Initializes a new instance of the DocIdSet class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocIdSet Class | Lucene.Net.Search Namespace


DocIdSet Constructor

Initializes a new instance of the DocIdSet class.

protected DocIdSet();

See Also

DocIdSet Class | Lucene.Net.Search Namespace


DocIdSet Methods

The methods of the DocIdSet class are listed below. For a complete list of DocIdSet class members, see the DocIdSet Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Iterator |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocIdSet Class | Lucene.Net.Search Namespace


DocIdSet.Iterator Method

public abstract DocIdSetIterator Iterator();

See Also

DocIdSet Class | Lucene.Net.Search Namespace


DocIdSetIterator Class

For a list of all members of this type, see DocIdSetIterator Members.

System.Object
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Search.Scorer
Lucene.Net.Util.OpenBitSetIterator

public abstract class DocIdSetIterator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DocIdSetIterator Members | Lucene.Net.Search Namespace


DocIdSetIterator Members

DocIdSetIterator overview

Public Instance Methods

Doc | Returns the current document number. This is invalid until Next() is called for the first time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Moves to the next docId in the set. Returns true, iff there is such a docId.
SkipTo Skips entries to the first beyond the current whose document number is greater than or equal to target. Returns true iff there is such an entry. Behaves as if written:
 boolean skipTo(int target) { do { if (!next()) return false; } while (target > doc()); return true; }
Some implementations are considerably more efficient than that.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

DocIdSetIterator Constructor Initializes a new instance of the DocIdSetIterator class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocIdSetIterator Class | Lucene.Net.Search Namespace


DocIdSetIterator Constructor

Initializes a new instance of the DocIdSetIterator class.

protected DocIdSetIterator();

See Also

DocIdSetIterator Class | Lucene.Net.Search Namespace


DocIdSetIterator Methods

The methods of the DocIdSetIterator class are listed below. For a complete list of DocIdSetIterator class members, see the DocIdSetIterator Members topic.

Public Instance Methods

Doc | Returns the current document number. This is invalid until Next() is called for the first time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Moves to the next docId in the set. Returns true, iff there is such a docId.
SkipTo Skips entries to the first beyond the current whose document number is greater than or equal to target. Returns true iff there is such an entry. Behaves as if written:
 boolean skipTo(int target) { do { if (!next()) return false; } while (target > doc()); return true; }
Some implementations are considerably more efficient than that.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocIdSetIterator Class | Lucene.Net.Search Namespace


DocIdSetIterator.Doc Method

Returns the current document number. This is invalid until Next() is called for the first time.

public abstract int Doc();

Return Value

the current doc number

See Also

DocIdSetIterator Class | Lucene.Net.Search Namespace


DocIdSetIterator.Next Method

Moves to the next docId in the set. Returns true, iff there is such a docId.

public abstract bool Next();

Return Value

true if there is a next docId

See Also

DocIdSetIterator Class | Lucene.Net.Search Namespace


DocIdSetIterator.SkipTo Method

Skips entries to the first beyond the current whose document number is greater than or equal to target. Returns true iff there is such an entry.

Behaves as if written:

 boolean skipTo(int target) { do { if (!next()) return false; } while (target > doc()); return true; }
Some implementations are considerably more efficient than that.

public abstract bool SkipTo(
int target
);

Return Value

true if there is a docId greater than or equal to target

See Also

DocIdSetIterator Class | Lucene.Net.Search Namespace


DoubleParser Interface

For a list of all members of this type, see DoubleParser Members.

public interface DoubleParser

Types that implement DoubleParser

Type | Description
ExtendedFieldCacheImpl.AnonymousClassDoubleParser |

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DoubleParser Members | Lucene.Net.Search Namespace


DoubleParser Members

DoubleParser overview

Public Instance Methods

ParseDouble Return an long representation of this field's value.

See Also

DoubleParser Interface | Lucene.Net.Search Namespace


DoubleParser Methods

The methods of the DoubleParser interface are listed below. For a complete list of DoubleParser interface members, see the DoubleParser Members topic.

Public Instance Methods

ParseDouble Return an long representation of this field's value.

See Also

DoubleParser Interface | Lucene.Net.Search Namespace


DoubleParser.ParseDouble Method

Return an long representation of this field's value.

double ParseDouble(
string string_Renamed
);

See Also

DoubleParser Interface | Lucene.Net.Search Namespace


Explanation Class

Expert: Describes the score computation for document and query.

For a list of all members of this type, see Explanation Members.

System.Object
Lucene.Net.Search.Explanation
Lucene.Net.Search.ComplexExplanation

public class Explanation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Explanation Members | Lucene.Net.Search Namespace


Explanation Members

Explanation overview

Public Instance Constructors

Explanation Overloaded. Initializes a new instance of the Explanation class.

Public Instance Methods

AddDetail | Adds a sub-node to this explanation node.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDescription | A description of this explanation node.
GetDetails | The sub-nodes of this explanation node.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | The value assigned to this explanation node.
IsMatch | Indicates whether or not this Explanation models a good match. By default, an Explanation represents a "match" if the value is positive.
SetDescription | Sets the description of this explanation node.
SetValue | Sets the value assigned to this explanation node.
ToHtml | Render an explanation as HTML.
ToString | Overloaded. Render an explanation as text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSummary | A short one line summary which should contain all high level information about this Explanation, without the "Details"
ToString | Overloaded.

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation Constructor

Initializes a new instance of the Explanation class.

Overload List

Initializes a new instance of the Explanation class.

public Explanation();

public Explanation(float,string);

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation Constructor ()

Initializes a new instance of the Explanation class.

public Explanation();

See Also

Explanation Class | Lucene.Net.Search Namespace | Explanation Constructor Overload List


Explanation Constructor (Single, String)

public Explanation(
float value_Renamed,
string description
);

See Also

Explanation Class | Lucene.Net.Search Namespace | Explanation Constructor Overload List


Explanation Methods

The methods of the Explanation class are listed below. For a complete list of Explanation class members, see the Explanation Members topic.

Public Instance Methods

AddDetail | Adds a sub-node to this explanation node.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDescription | A description of this explanation node.
GetDetails | The sub-nodes of this explanation node.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | The value assigned to this explanation node.
IsMatch | Indicates whether or not this Explanation models a good match. By default, an Explanation represents a "match" if the value is positive.
SetDescription | Sets the description of this explanation node.
SetValue | Sets the value assigned to this explanation node.
ToHtml | Render an explanation as HTML.
ToString | Overloaded. Render an explanation as text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSummary | A short one line summary which should contain all high level information about this Explanation, without the "Details"
ToString | Overloaded.

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.AddDetail Method

Adds a sub-node to this explanation node.

public virtual void AddDetail(
Explanation detail
);

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.GetDescription Method

A description of this explanation node.

public virtual string GetDescription();

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.GetDetails Method

The sub-nodes of this explanation node.

public virtual Explanation[] GetDetails();

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.GetSummary Method

A short one line summary which should contain all high level information about this Explanation, without the "Details"

protected internal virtual string GetSummary();

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.GetValue Method

The value assigned to this explanation node.

public virtual float GetValue();

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.IsMatch Method

Indicates whether or not this Explanation models a good match.

By default, an Explanation represents a "match" if the value is positive.

public virtual bool IsMatch();

See Also

Explanation Class | Lucene.Net.Search Namespace |


Explanation.SetDescription Method

Sets the description of this explanation node.

public virtual void SetDescription(
string description
);

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.SetValue Method

Sets the value assigned to this explanation node.

public virtual void SetValue(
float value_Renamed
);

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.ToHtml Method

Render an explanation as HTML.

public virtual string ToHtml();

See Also

Explanation Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

Explanation.ToString Method

Render an explanation as text.

Overload List

Render an explanation as text.

public override string ToString();

protected internal virtual string ToString(int);

See Also

Explanation Class | Lucene.Net.Search Namespace


Explanation.ToString Method ()

Render an explanation as text.

public override string ToString();

See Also

Explanation Class | Lucene.Net.Search Namespace | Explanation.ToString Overload List


Explanation.ToString Method (Int32)

protected internal virtual string ToString(
int depth
);

See Also

Explanation Class | Lucene.Net.Search Namespace | Explanation.ToString Overload List


ExtendedFieldCache Interface

For a list of all members of this type, see ExtendedFieldCache Members.

public interface ExtendedFieldCache : FieldCache

Types that implement ExtendedFieldCache

Type | Description
ExtendedFieldCacheImpl |

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ExtendedFieldCache Members | Lucene.Net.Search Namespace


ExtendedFieldCache Members

ExtendedFieldCache overview

Public Instance Methods

GetDoubles Overloaded. Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given field.
GetLongs Overloaded. Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
field
as longs and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

See Also

ExtendedFieldCache Interface | Lucene.Net.Search Namespace


ExtendedFieldCache Methods

The methods of the ExtendedFieldCache interface are listed below. For a complete list of ExtendedFieldCache interface members, see the ExtendedFieldCache Members topic.

Public Instance Methods

GetDoubles Overloaded. Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given field.
GetLongs Overloaded. Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
field
as longs and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

See Also

ExtendedFieldCache Interface | Lucene.Net.Search Namespace


GetDoubles Method

Apache Lucene.Net 2.4.0 Class Library API

ExtendedFieldCache.GetDoubles Method

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

Overload List

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

double[] GetDoubles(IndexReader,string);

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as doubles and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

double[] GetDoubles(IndexReader,string,DoubleParser);

See Also

ExtendedFieldCache Interface | Lucene.Net.Search Namespace


ExtendedFieldCache.GetDoubles Method (IndexReader, String)

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

double[] GetDoubles(
IndexReader reader,
string field
);

Parameters

reader
Used to get field values.
field
Which field contains the doubles.

Return Value

The values in the given field for each document.

See Also

ExtendedFieldCache Interface | Lucene.Net.Search Namespace | ExtendedFieldCache.GetDoubles Overload List


ExtendedFieldCache.GetDoubles Method (IndexReader, String, DoubleParser)

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as doubles and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

double[] GetDoubles(
IndexReader reader,
string field,
DoubleParser parser
);

Parameters

reader
Used to get field values.
field
Which field contains the doubles.
parser
Computes integer for string values.

Return Value

The values in the given field for each document.

See Also

ExtendedFieldCache Interface | Lucene.Net.Search Namespace | ExtendedFieldCache.GetDoubles Overload List


GetLongs Method

Apache Lucene.Net 2.4.0 Class Library API

ExtendedFieldCache.GetLongs Method

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as longs and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

Overload List

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as longs and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

long[] GetLongs(IndexReader,string);

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as longs and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

long[] GetLongs(IndexReader,string,LongParser);

See Also

ExtendedFieldCache Interface | Lucene.Net.Search Namespace


ExtendedFieldCache.GetLongs Method (IndexReader, String)

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as longs and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

long[] GetLongs(
IndexReader reader,
string field
);

Parameters

reader
Used to get field values.
field
Which field contains the longs.

Return Value

The values in the given field for each document.

See Also

ExtendedFieldCache Interface | Lucene.Net.Search Namespace | ExtendedFieldCache.GetLongs Overload List


ExtendedFieldCache.GetLongs Method (IndexReader, String, LongParser)

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as longs and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

long[] GetLongs(
IndexReader reader,
string field,
LongParser parser
);

Parameters

reader
Used to get field values.
field
Which field contains the longs.
parser
Computes integer for string values.

Return Value

The values in the given field for each document.

See Also

ExtendedFieldCache Interface | Lucene.Net.Search Namespace | ExtendedFieldCache.GetLongs Overload List


ExtendedFieldCache_Fields Structure

For a list of all members of this type, see ExtendedFieldCache_Fields Members.

System.Object
System.ValueType
Lucene.Net.Search.ExtendedFieldCache_Fields

public struct ExtendedFieldCache_Fields

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ExtendedFieldCache_Fields Members | Lucene.Net.Search Namespace


ExtendedFieldCache_Fields Members

ExtendedFieldCache_Fields overview

Public Static Fields

EXT_DEFAULT

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ExtendedFieldCache_Fields Class | Lucene.Net.Search Namespace


ExtendedFieldCache_Fields Fields

The fields of the ExtendedFieldCache_Fields structure are listed below. For a complete list of ExtendedFieldCache_Fields structure members, see the ExtendedFieldCache_Fields Members topic.

Public Static Fields

EXT_DEFAULT

See Also

ExtendedFieldCache_Fields Class | Lucene.Net.Search Namespace


ExtendedFieldCache_Fields.EXT_DEFAULT Field

public static readonly ExtendedFieldCache EXT_DEFAULT;

See Also

ExtendedFieldCache_Fields Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl Class

For a list of all members of this type, see ExtendedFieldCacheImpl Members.

System.Object
Lucene.Net.Search.FieldCacheImpl
Lucene.Net.Search.ExtendedFieldCacheImpl

public class ExtendedFieldCacheImpl : FieldCacheImpl, ExtendedFieldCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ExtendedFieldCacheImpl Members | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl Members

ExtendedFieldCacheImpl overview

Public Instance Constructors

ExtendedFieldCacheImpl Constructor Initializes a new instance of the ExtendedFieldCacheImpl class.

Public Instance Methods

Close (inherited from FieldCacheImpl) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAuto |
GetBytes (inherited from FieldCacheImpl) | Overloaded.
GetCustom (inherited from FieldCacheImpl) |
GetDoubles | Overloaded.
GetFloats (inherited from FieldCacheImpl) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInts (inherited from FieldCacheImpl) | Overloaded.
GetLongs | Overloaded.
GetShorts (inherited from FieldCacheImpl) | Overloaded.
GetStringIndex (inherited from FieldCacheImpl) |
GetStrings (inherited from FieldCacheImpl) |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedFieldCacheImpl Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl Constructor

Initializes a new instance of the ExtendedFieldCacheImpl class.

public ExtendedFieldCacheImpl();

See Also

ExtendedFieldCacheImpl Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl Methods

The methods of the ExtendedFieldCacheImpl class are listed below. For a complete list of ExtendedFieldCacheImpl class members, see the ExtendedFieldCacheImpl Members topic.

Public Instance Methods

Close (inherited from FieldCacheImpl) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAuto |
GetBytes (inherited from FieldCacheImpl) | Overloaded.
GetCustom (inherited from FieldCacheImpl) |
GetDoubles | Overloaded.
GetFloats (inherited from FieldCacheImpl) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInts (inherited from FieldCacheImpl) | Overloaded.
GetLongs | Overloaded.
GetShorts (inherited from FieldCacheImpl) | Overloaded.
GetStringIndex (inherited from FieldCacheImpl) |
GetStrings (inherited from FieldCacheImpl) |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedFieldCacheImpl Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl.GetAuto Method

public override object GetAuto(
IndexReader reader,
string field
);

Implements

FieldCache.GetAuto

See Also

ExtendedFieldCacheImpl Class | Lucene.Net.Search Namespace


GetDoubles Method

Apache Lucene.Net 2.4.0 Class Library API

ExtendedFieldCacheImpl.GetDoubles Method

Overload List

public virtual double[] GetDoubles(IndexReader,string);

public virtual double[] GetDoubles(IndexReader,string,DoubleParser);

See Also

ExtendedFieldCacheImpl Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl.GetDoubles Method (IndexReader, String)

public virtual double[] GetDoubles(
IndexReader reader,
string field
);

Implements

ExtendedFieldCache.GetDoubles

See Also

ExtendedFieldCacheImpl Class | Lucene.Net.Search Namespace | ExtendedFieldCacheImpl.GetDoubles Overload List


ExtendedFieldCacheImpl.GetDoubles Method (IndexReader, String, DoubleParser)

public virtual double[] GetDoubles(
IndexReader reader,
string field,
DoubleParser parser
);

Implements

ExtendedFieldCache.GetDoubles

See Also

ExtendedFieldCacheImpl Class | Lucene.Net.Search Namespace | ExtendedFieldCacheImpl.GetDoubles Overload List


GetLongs Method

Apache Lucene.Net 2.4.0 Class Library API

ExtendedFieldCacheImpl.GetLongs Method

Overload List

public virtual long[] GetLongs(IndexReader,string);

public virtual long[] GetLongs(IndexReader,string,LongParser);

See Also

ExtendedFieldCacheImpl Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl.GetLongs Method (IndexReader, String)

public virtual long[] GetLongs(
IndexReader reader,
string field
);

Implements

ExtendedFieldCache.GetLongs

See Also

ExtendedFieldCacheImpl Class | Lucene.Net.Search Namespace | ExtendedFieldCacheImpl.GetLongs Overload List


ExtendedFieldCacheImpl.GetLongs Method (IndexReader, String, LongParser)

public virtual long[] GetLongs(
IndexReader reader,
string field,
LongParser parser
);

Implements

ExtendedFieldCache.GetLongs

See Also

ExtendedFieldCacheImpl Class | Lucene.Net.Search Namespace | ExtendedFieldCacheImpl.GetLongs Overload List


ExtendedFieldCacheImpl.AnonymousClassDoubleParser Class

For a list of all members of this type, see ExtendedFieldCacheImpl.AnonymousClassDoubleParser Members.

System.Object
Lucene.Net.Search.ExtendedFieldCacheImpl.AnonymousClassDoubleParser

public class ExtendedFieldCacheImpl.AnonymousClassDoubleParser : DoubleParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ExtendedFieldCacheImpl.AnonymousClassDoubleParser Members | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl.AnonymousClassDoubleParser Members

ExtendedFieldCacheImpl.AnonymousClassDoubleParser overview

Public Instance Constructors

ExtendedFieldCacheImpl.AnonymousClassDoubleParser Constructor Initializes a new instance of the ExtendedFieldCacheImpl.AnonymousClassDoubleParser class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseDouble |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedFieldCacheImpl.AnonymousClassDoubleParser Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl.AnonymousClassDoubleParser Constructor

Initializes a new instance of the ExtendedFieldCacheImpl.AnonymousClassDoubleParser class.

public ExtendedFieldCacheImpl.AnonymousClassDoubleParser();

See Also

ExtendedFieldCacheImpl.AnonymousClassDoubleParser Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl.AnonymousClassDoubleParser Methods

The methods of the ExtendedFieldCacheImpl.AnonymousClassDoubleParser class are listed below. For a complete list of ExtendedFieldCacheImpl.AnonymousClassDoubleParser class members, see the ExtendedFieldCacheImpl.AnonymousClassDoubleParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseDouble |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedFieldCacheImpl.AnonymousClassDoubleParser Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl.AnonymousClassDoubleParser.ParseDouble Method

public virtual double ParseDouble(
string value_Renamed
);

Implements

DoubleParser.ParseDouble

See Also

ExtendedFieldCacheImpl.AnonymousClassDoubleParser Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl.AnonymousClassLongParser Class

For a list of all members of this type, see ExtendedFieldCacheImpl.AnonymousClassLongParser Members.

System.Object
Lucene.Net.Search.ExtendedFieldCacheImpl.AnonymousClassLongParser

public class ExtendedFieldCacheImpl.AnonymousClassLongParser : LongParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ExtendedFieldCacheImpl.AnonymousClassLongParser Members | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl.AnonymousClassLongParser Members

ExtendedFieldCacheImpl.AnonymousClassLongParser overview

Public Instance Constructors

ExtendedFieldCacheImpl.AnonymousClassLongParser Constructor Initializes a new instance of the ExtendedFieldCacheImpl.AnonymousClassLongParser class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseLong |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedFieldCacheImpl.AnonymousClassLongParser Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl.AnonymousClassLongParser Constructor

Initializes a new instance of the ExtendedFieldCacheImpl.AnonymousClassLongParser class.

public ExtendedFieldCacheImpl.AnonymousClassLongParser();

See Also

ExtendedFieldCacheImpl.AnonymousClassLongParser Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl.AnonymousClassLongParser Methods

The methods of the ExtendedFieldCacheImpl.AnonymousClassLongParser class are listed below. For a complete list of ExtendedFieldCacheImpl.AnonymousClassLongParser class members, see the ExtendedFieldCacheImpl.AnonymousClassLongParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseLong |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedFieldCacheImpl.AnonymousClassLongParser Class | Lucene.Net.Search Namespace


ExtendedFieldCacheImpl.AnonymousClassLongParser.ParseLong Method

public virtual long ParseLong(
string value_Renamed
);

Implements

LongParser.ParseLong

See Also

ExtendedFieldCacheImpl.AnonymousClassLongParser Class | Lucene.Net.Search Namespace


FieldCache Interface

For a list of all members of this type, see FieldCache Members.

Lucene.Net.Search.FieldCache
Lucene.Net.Search.ExtendedFieldCache

public interface FieldCache

Types that implement FieldCache

Type | Description
ExtendedFieldCacheImpl |
FieldCacheImpl | Expert: The default cache implementation, storing all values in memory. A WeakHashMap is used for storage.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldCache Members | Lucene.Net.Search Namespace


FieldCache Members

FieldCache overview

Public Instance Methods

GetAuto Checks the internal cache for an appropriate entry, and if none is found reads
field
to see if it contains integers, floats or strings, and then calls one of the other methods in this class to get the values. For string values, a StringIndex is returned. After calling this method, there is an entry in the cache for both type
AUTO
and the actual found type.
GetBytes Overloaded. Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
field
as a single byte and returns an array of size
reader.maxDoc()
of the value each document has in the given field.
GetCustom Checks the internal cache for an appropriate entry, and if none is found reads the terms out of
field
and calls the given SortComparator to get the sort values. A hit in the cache will happen if
reader
,
field
, and
comparator
are the same (using
equals()
) as a previous call to this method.
GetFloats Overloaded. Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
field
as floats and returns an array of size
reader.maxDoc()
of the value each document has in the given field.
GetInts Overloaded. Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given field.
GetShorts Overloaded. Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
field
as shorts and returns an array of size
reader.maxDoc()
of the value each document has in the given field.
GetStringIndex Checks the internal cache for an appropriate entry, and if none is found reads the term values in
field
and returns an array of them in natural order, along with an array telling which element in the term array each document uses.
GetStrings Checks the internal cache for an appropriate entry, and if none is found, reads the term values in
field
and returns an array of size
reader.maxDoc()
containing the value each document has in the given field.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache Methods

The methods of the FieldCache interface are listed below. For a complete list of FieldCache interface members, see the FieldCache Members topic.

Public Instance Methods

GetAuto Checks the internal cache for an appropriate entry, and if none is found reads
field
to see if it contains integers, floats or strings, and then calls one of the other methods in this class to get the values. For string values, a StringIndex is returned. After calling this method, there is an entry in the cache for both type
AUTO
and the actual found type.
GetBytes Overloaded. Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
field
as a single byte and returns an array of size
reader.maxDoc()
of the value each document has in the given field.
GetCustom Checks the internal cache for an appropriate entry, and if none is found reads the terms out of
field
and calls the given SortComparator to get the sort values. A hit in the cache will happen if
reader
,
field
, and
comparator
are the same (using
equals()
) as a previous call to this method.
GetFloats Overloaded. Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
field
as floats and returns an array of size
reader.maxDoc()
of the value each document has in the given field.
GetInts Overloaded. Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given field.
GetShorts Overloaded. Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
field
as shorts and returns an array of size
reader.maxDoc()
of the value each document has in the given field.
GetStringIndex Checks the internal cache for an appropriate entry, and if none is found reads the term values in
field
and returns an array of them in natural order, along with an array telling which element in the term array each document uses.
GetStrings Checks the internal cache for an appropriate entry, and if none is found, reads the term values in
field
and returns an array of size
reader.maxDoc()
containing the value each document has in the given field.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache.GetAuto Method

Checks the internal cache for an appropriate entry, and if none is found reads

field
to see if it contains integers, floats or strings, and then calls one of the other methods in this class to get the values. For string values, a StringIndex is returned. After calling this method, there is an entry in the cache for both type
AUTO
and the actual found type.

object GetAuto(
IndexReader reader,
string field
);

Parameters

reader
Used to get field values.
field
Which field contains the values.

Return Value

int[], float[] or StringIndex.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


GetBytes Method

Apache Lucene.Net 2.4.0 Class Library API

FieldCache.GetBytes Method

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as a single byte and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

Overload List

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as a single byte and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

byte[] GetBytes(IndexReader,string);

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as bytes and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

byte[] GetBytes(IndexReader,string,ByteParser);

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache.GetBytes Method (IndexReader, String)

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as a single byte and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

byte[] GetBytes(
IndexReader reader,
string field
);

Parameters

reader
Used to get field values.
field
Which field contains the single byte values.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace | FieldCache.GetBytes Overload List


FieldCache.GetBytes Method (IndexReader, String, ByteParser)

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as bytes and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

byte[] GetBytes(
IndexReader reader,
string field,
ByteParser parser
);

Parameters

reader
Used to get field values.
field
Which field contains the bytes.
parser
Computes byte for string values.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace | FieldCache.GetBytes Overload List


FieldCache.GetCustom Method

Checks the internal cache for an appropriate entry, and if none is found reads the terms out of

field
and calls the given SortComparator to get the sort values. A hit in the cache will happen if
reader
,
field
, and
comparator
are the same (using
equals()
) as a previous call to this method.

IComparable[] GetCustom(
IndexReader reader,
string field,
SortComparator comparator
);

Parameters

reader
Used to get field values.
field
Which field contains the values.
comparator
Used to convert terms into something to sort by.

Return Value

Array of sort objects, one for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


GetFloats Method

Apache Lucene.Net 2.4.0 Class Library API

FieldCache.GetFloats Method

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as floats and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

Overload List

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as floats and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

float[] GetFloats(IndexReader,string);

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as floats and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

float[] GetFloats(IndexReader,string,FloatParser);

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache.GetFloats Method (IndexReader, String)

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as floats and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

float[] GetFloats(
IndexReader reader,
string field
);

Parameters

reader
Used to get field values.
field
Which field contains the floats.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace | FieldCache.GetFloats Overload List


FieldCache.GetFloats Method (IndexReader, String, FloatParser)

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as floats and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

float[] GetFloats(
IndexReader reader,
string field,
FloatParser parser
);

Parameters

reader
Used to get field values.
field
Which field contains the floats.
parser
Computes float for string values.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace | FieldCache.GetFloats Overload List


GetInts Method

Apache Lucene.Net 2.4.0 Class Library API

FieldCache.GetInts Method

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

Overload List

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

int[] GetInts(IndexReader,string);

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

int[] GetInts(IndexReader,string,IntParser);

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache.GetInts Method (IndexReader, String)

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

int[] GetInts(
IndexReader reader,
string field
);

Parameters

reader
Used to get field values.
field
Which field contains the integers.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace | FieldCache.GetInts Overload List


FieldCache.GetInts Method (IndexReader, String, IntParser)

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as integers and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

int[] GetInts(
IndexReader reader,
string field,
IntParser parser
);

Parameters

reader
Used to get field values.
field
Which field contains the integers.
parser
Computes integer for string values.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace | FieldCache.GetInts Overload List


GetShorts Method

Apache Lucene.Net 2.4.0 Class Library API

FieldCache.GetShorts Method

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as shorts and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

Overload List

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as shorts and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

short[] GetShorts(IndexReader,string);

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as shorts and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

short[] GetShorts(IndexReader,string,ShortParser);

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache.GetShorts Method (IndexReader, String)

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as shorts and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

short[] GetShorts(
IndexReader reader,
string field
);

Parameters

reader
Used to get field values.
field
Which field contains the shorts.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace | FieldCache.GetShorts Overload List


FieldCache.GetShorts Method (IndexReader, String, ShortParser)

Checks the internal cache for an appropriate entry, and if none is found, reads the terms in

field
as shorts and returns an array of size
reader.maxDoc()
of the value each document has in the given field.

short[] GetShorts(
IndexReader reader,
string field,
ShortParser parser
);

Parameters

reader
Used to get field values.
field
Which field contains the shorts.
parser
Computes short for string values.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace | FieldCache.GetShorts Overload List


FieldCache.GetStringIndex Method

Checks the internal cache for an appropriate entry, and if none is found reads the term values in

field
and returns an array of them in natural order, along with an array telling which element in the term array each document uses.

StringIndex GetStringIndex(
IndexReader reader,
string field
);

Parameters

reader
Used to get field values.
field
Which field contains the strings.

Return Value

Array of terms and index into the array for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache.GetStrings Method

Checks the internal cache for an appropriate entry, and if none is found, reads the term values in

field
and returns an array of size
reader.maxDoc()
containing the value each document has in the given field.

string[] GetStrings(
IndexReader reader,
string field
);

Parameters

reader
Used to get field values.
field
Which field contains the strings.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface | Lucene.Net.Search Namespace


FieldCache_Fields Structure

For a list of all members of this type, see FieldCache_Fields Members.

System.Object
System.ValueType
Lucene.Net.Search.FieldCache_Fields

public struct FieldCache_Fields

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldCache_Fields Members | Lucene.Net.Search Namespace


FieldCache_Fields Members

FieldCache_Fields overview

Public Static Fields

DEFAULT | Expert: The cache used internally by sorting and range query classes.
STRING_INDEX | Indicator for StringIndex values in the cache.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

FieldCache_Fields Class | Lucene.Net.Search Namespace


FieldCache_Fields Fields

The fields of the FieldCache_Fields structure are listed below. For a complete list of FieldCache_Fields structure members, see the FieldCache_Fields Members topic.

Public Static Fields

DEFAULT | Expert: The cache used internally by sorting and range query classes.
STRING_INDEX | Indicator for StringIndex values in the cache.

See Also

FieldCache_Fields Class | Lucene.Net.Search Namespace


FieldCache_Fields.DEFAULT Field

Expert: The cache used internally by sorting and range query classes.

public static readonly FieldCache DEFAULT;

See Also

FieldCache_Fields Class | Lucene.Net.Search Namespace


FieldCache_Fields.STRING_INDEX Field

Indicator for StringIndex values in the cache.

public static readonly int STRING_INDEX;

See Also

FieldCache_Fields Class | Lucene.Net.Search Namespace


FieldCacheImpl Class

Expert: The default cache implementation, storing all values in memory. A WeakHashMap is used for storage.

For a list of all members of this type, see FieldCacheImpl Members.

System.Object
Lucene.Net.Search.FieldCacheImpl
Lucene.Net.Search.ExtendedFieldCacheImpl

public class FieldCacheImpl : FieldCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldCacheImpl Members | Lucene.Net.Search Namespace


FieldCacheImpl Members

FieldCacheImpl overview

Public Instance Constructors

FieldCacheImpl Constructor Initializes a new instance of the FieldCacheImpl class.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAuto | The pattern used to detect float values in a field
GetBytes | Overloaded.
GetCustom |
GetFloats | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInts | Overloaded.
GetShorts | Overloaded.
GetStringIndex |
GetStrings |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace


FieldCacheImpl Constructor

Initializes a new instance of the FieldCacheImpl class.

public FieldCacheImpl();

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace


FieldCacheImpl Methods

The methods of the FieldCacheImpl class are listed below. For a complete list of FieldCacheImpl class members, see the FieldCacheImpl Members topic.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAuto | The pattern used to detect float values in a field
GetBytes | Overloaded.
GetCustom |
GetFloats | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInts | Overloaded.
GetShorts | Overloaded.
GetStringIndex |
GetStrings |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace


FieldCacheImpl.Close Method

public virtual void Close(
IndexReader reader
);

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace


FieldCacheImpl.GetAuto Method

The pattern used to detect float values in a field

public virtual object GetAuto(
IndexReader reader,
string field
);

Implements

FieldCache.GetAuto

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace


GetBytes Method

Apache Lucene.Net 2.4.0 Class Library API

FieldCacheImpl.GetBytes Method

Overload List

public virtual byte[] GetBytes(IndexReader,string);

public virtual byte[] GetBytes(IndexReader,string,ByteParser);

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace


FieldCacheImpl.GetBytes Method (IndexReader, String)

public virtual byte[] GetBytes(
IndexReader reader,
string field
);

Implements

FieldCache.GetBytes

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace | FieldCacheImpl.GetBytes Overload List


FieldCacheImpl.GetBytes Method (IndexReader, String, ByteParser)

public virtual byte[] GetBytes(
IndexReader reader,
string field,
ByteParser parser
);

Implements

FieldCache.GetBytes

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace | FieldCacheImpl.GetBytes Overload List


FieldCacheImpl.GetCustom Method

public virtual IComparable[] GetCustom(
IndexReader reader,
string field,
SortComparator comparator
);

Implements

FieldCache.GetCustom

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace


GetFloats Method

Apache Lucene.Net 2.4.0 Class Library API

FieldCacheImpl.GetFloats Method

Overload List

public virtual float[] GetFloats(IndexReader,string);

public virtual float[] GetFloats(IndexReader,string,FloatParser);

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace


FieldCacheImpl.GetFloats Method (IndexReader, String)

public virtual float[] GetFloats(
IndexReader reader,
string field
);

Implements

FieldCache.GetFloats

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace | FieldCacheImpl.GetFloats Overload List


FieldCacheImpl.GetFloats Method (IndexReader, String, FloatParser)

public virtual float[] GetFloats(
IndexReader reader,
string field,
FloatParser parser
);

Implements

FieldCache.GetFloats

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace | FieldCacheImpl.GetFloats Overload List


GetInts Method

Apache Lucene.Net 2.4.0 Class Library API

FieldCacheImpl.GetInts Method

Overload List

public virtual int[] GetInts(IndexReader,string);

public virtual int[] GetInts(IndexReader,string,IntParser);

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace


FieldCacheImpl.GetInts Method (IndexReader, String)

public virtual int[] GetInts(
IndexReader reader,
string field
);

Implements

FieldCache.GetInts

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace | FieldCacheImpl.GetInts Overload List


FieldCacheImpl.GetInts Method (IndexReader, String, IntParser)

public virtual int[] GetInts(
IndexReader reader,
string field,
IntParser parser
);

Implements

FieldCache.GetInts

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace | FieldCacheImpl.GetInts Overload List


GetShorts Method

Apache Lucene.Net 2.4.0 Class Library API

FieldCacheImpl.GetShorts Method

Overload List

public virtual short[] GetShorts(IndexReader,string);

public virtual short[] GetShorts(IndexReader,string,ShortParser);

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace


FieldCacheImpl.GetShorts Method (IndexReader, String)

public virtual short[] GetShorts(
IndexReader reader,
string field
);

Implements

FieldCache.GetShorts

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace | FieldCacheImpl.GetShorts Overload List


FieldCacheImpl.GetShorts Method (IndexReader, String, ShortParser)

public virtual short[] GetShorts(
IndexReader reader,
string field,
ShortParser parser
);

Implements

FieldCache.GetShorts

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace | FieldCacheImpl.GetShorts Overload List


FieldCacheImpl.GetStringIndex Method

public virtual StringIndex GetStringIndex(
IndexReader reader,
string field
);

Implements

FieldCache.GetStringIndex

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace


FieldCacheImpl.GetStrings Method

public virtual string[] GetStrings(
IndexReader reader,
string field
);

Implements

FieldCache.GetStrings

See Also

FieldCacheImpl Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassByteParser Class

For a list of all members of this type, see FieldCacheImpl.AnonymousClassByteParser Members.

System.Object
Lucene.Net.Search.FieldCacheImpl.AnonymousClassByteParser

public class FieldCacheImpl.AnonymousClassByteParser : ByteParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldCacheImpl.AnonymousClassByteParser Members | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassByteParser Members

FieldCacheImpl.AnonymousClassByteParser overview

Public Instance Constructors

FieldCacheImpl.AnonymousClassByteParser Constructor Initializes a new instance of the FieldCacheImpl.AnonymousClassByteParser class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseByte |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldCacheImpl.AnonymousClassByteParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassByteParser Constructor

Initializes a new instance of the FieldCacheImpl.AnonymousClassByteParser class.

public FieldCacheImpl.AnonymousClassByteParser();

See Also

FieldCacheImpl.AnonymousClassByteParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassByteParser Methods

The methods of the FieldCacheImpl.AnonymousClassByteParser class are listed below. For a complete list of FieldCacheImpl.AnonymousClassByteParser class members, see the FieldCacheImpl.AnonymousClassByteParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseByte |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldCacheImpl.AnonymousClassByteParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassByteParser.ParseByte Method

public virtual byte ParseByte(
string value_Renamed
);

Implements

ByteParser.ParseByte

See Also

FieldCacheImpl.AnonymousClassByteParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassFloatParser Class

For a list of all members of this type, see FieldCacheImpl.AnonymousClassFloatParser Members.

System.Object
Lucene.Net.Search.FieldCacheImpl.AnonymousClassFloatParser

public class FieldCacheImpl.AnonymousClassFloatParser : FloatParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldCacheImpl.AnonymousClassFloatParser Members | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassFloatParser Members

FieldCacheImpl.AnonymousClassFloatParser overview

Public Instance Constructors

FieldCacheImpl.AnonymousClassFloatParser Constructor Initializes a new instance of the FieldCacheImpl.AnonymousClassFloatParser class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseFloat |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldCacheImpl.AnonymousClassFloatParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassFloatParser Constructor

Initializes a new instance of the FieldCacheImpl.AnonymousClassFloatParser class.

public FieldCacheImpl.AnonymousClassFloatParser();

See Also

FieldCacheImpl.AnonymousClassFloatParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassFloatParser Methods

The methods of the FieldCacheImpl.AnonymousClassFloatParser class are listed below. For a complete list of FieldCacheImpl.AnonymousClassFloatParser class members, see the FieldCacheImpl.AnonymousClassFloatParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseFloat |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldCacheImpl.AnonymousClassFloatParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassFloatParser.ParseFloat Method

public virtual float ParseFloat(
string value_Renamed
);

Implements

FloatParser.ParseFloat

See Also

FieldCacheImpl.AnonymousClassFloatParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassIntParser Class

For a list of all members of this type, see FieldCacheImpl.AnonymousClassIntParser Members.

System.Object
Lucene.Net.Search.FieldCacheImpl.AnonymousClassIntParser

public class FieldCacheImpl.AnonymousClassIntParser : IntParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldCacheImpl.AnonymousClassIntParser Members | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassIntParser Members

FieldCacheImpl.AnonymousClassIntParser overview

Public Instance Constructors

FieldCacheImpl.AnonymousClassIntParser Constructor Initializes a new instance of the FieldCacheImpl.AnonymousClassIntParser class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseInt |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldCacheImpl.AnonymousClassIntParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassIntParser Constructor

Initializes a new instance of the FieldCacheImpl.AnonymousClassIntParser class.

public FieldCacheImpl.AnonymousClassIntParser();

See Also

FieldCacheImpl.AnonymousClassIntParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassIntParser Methods

The methods of the FieldCacheImpl.AnonymousClassIntParser class are listed below. For a complete list of FieldCacheImpl.AnonymousClassIntParser class members, see the FieldCacheImpl.AnonymousClassIntParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseInt |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldCacheImpl.AnonymousClassIntParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassIntParser.ParseInt Method

public virtual int ParseInt(
string value_Renamed
);

Implements

IntParser.ParseInt

See Also

FieldCacheImpl.AnonymousClassIntParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassShortParser Class

For a list of all members of this type, see FieldCacheImpl.AnonymousClassShortParser Members.

System.Object
Lucene.Net.Search.FieldCacheImpl.AnonymousClassShortParser

public class FieldCacheImpl.AnonymousClassShortParser : ShortParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldCacheImpl.AnonymousClassShortParser Members | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassShortParser Members

FieldCacheImpl.AnonymousClassShortParser overview

Public Instance Constructors

FieldCacheImpl.AnonymousClassShortParser Constructor Initializes a new instance of the FieldCacheImpl.AnonymousClassShortParser class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseShort |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldCacheImpl.AnonymousClassShortParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassShortParser Constructor

Initializes a new instance of the FieldCacheImpl.AnonymousClassShortParser class.

public FieldCacheImpl.AnonymousClassShortParser();

See Also

FieldCacheImpl.AnonymousClassShortParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassShortParser Methods

The methods of the FieldCacheImpl.AnonymousClassShortParser class are listed below. For a complete list of FieldCacheImpl.AnonymousClassShortParser class members, see the FieldCacheImpl.AnonymousClassShortParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseShort |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldCacheImpl.AnonymousClassShortParser Class | Lucene.Net.Search Namespace


FieldCacheImpl.AnonymousClassShortParser.ParseShort Method

public virtual short ParseShort(
string value_Renamed
);

Implements

ShortParser.ParseShort

See Also

FieldCacheImpl.AnonymousClassShortParser Class | Lucene.Net.Search Namespace


FieldDoc Class

Expert: A ScoreDoc which also contains information about how to sort the referenced document. In addition to the document number and score, this object contains an array of values for the document from the field(s) used to sort. For example, if the sort criteria was to sort by fields "a", "b" then "c", the

fields
object array will have three elements, corresponding respectively to the term values for the document in fields "a", "b" and "c". The class of each element in the array will be either Integer, Float or String depending on the type of values in the terms of each field.

For a list of all members of this type, see FieldDoc Members.

System.Object
Lucene.Net.Search.ScoreDoc
Lucene.Net.Search.FieldDoc

public class FieldDoc : ScoreDoc

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldDoc Members | Lucene.Net.Search Namespace | ScoreDoc | TopFieldDocs


FieldDoc Members

FieldDoc overview

Public Instance Constructors

FieldDoc Overloaded. Initializes a new instance of the FieldDoc class.

Public Instance Fields

doc (inherited from ScoreDoc) | Expert: A hit document's number.
fields | Expert: The values which are used to sort the referenced document. The order of these will match the original sort criteria given by a Sort object. Each object will be either an Integer, Float or String, depending on the type of values in the terms of the original field.
score (inherited from ScoreDoc) | Expert: The score of this document for the query.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldDoc Class | Lucene.Net.Search Namespace | ScoreDoc | TopFieldDocs


FieldDoc Constructor

Expert: Creates one of these objects with empty sort information.

Overload List

Expert: Creates one of these objects with empty sort information.

public FieldDoc(int,float);

Expert: Creates one of these objects with the given sort information.

public FieldDoc(int,float,IComparable[]);

See Also

FieldDoc Class | Lucene.Net.Search Namespace


FieldDoc Constructor (Int32, Single)

Expert: Creates one of these objects with empty sort information.

public FieldDoc(
int doc,
float score
);

See Also

FieldDoc Class | Lucene.Net.Search Namespace | FieldDoc Constructor Overload List


FieldDoc Constructor (Int32, Single, IComparable[])

Expert: Creates one of these objects with the given sort information.

public FieldDoc(
int doc,
float score,
IComparable[] fields
);

See Also

FieldDoc Class | Lucene.Net.Search Namespace | FieldDoc Constructor Overload List


FieldDoc Fields

The fields of the FieldDoc class are listed below. For a complete list of FieldDoc class members, see the FieldDoc Members topic.

Public Instance Fields

doc (inherited from ScoreDoc) | Expert: A hit document's number.
fields | Expert: The values which are used to sort the referenced document. The order of these will match the original sort criteria given by a Sort object. Each object will be either an Integer, Float or String, depending on the type of values in the terms of the original field.
score (inherited from ScoreDoc) | Expert: The score of this document for the query.

See Also

FieldDoc Class | Lucene.Net.Search Namespace | ScoreDoc | TopFieldDocs


FieldDoc.fields Field

Expert: The values which are used to sort the referenced document. The order of these will match the original sort criteria given by a Sort object. Each object will be either an Integer, Float or String, depending on the type of values in the terms of the original field.

public IComparable[] fields;

See Also

FieldDoc Class | Lucene.Net.Search Namespace | | Searcher#Search


FieldSortedHitQueue Class

Expert: A hit queue for sorting by hits by terms in more than one field. Uses

FieldCache.DEFAULT
for maintaining internal term lookup tables.

For a list of all members of this type, see FieldSortedHitQueue Members.

System.Object
Lucene.Net.Util.PriorityQueue
Lucene.Net.Search.FieldSortedHitQueue

public class FieldSortedHitQueue : PriorityQueue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldSortedHitQueue Members | Lucene.Net.Search Namespace | |


FieldSortedHitQueue Members

FieldSortedHitQueue overview

Public Instance Constructors

FieldSortedHitQueue Constructor Creates a hit queue sorted by the given list of fields.

Public Instance Methods

AdjustTop (inherited from PriorityQueue) Should be called when the object at top changes values. Still log(n) worst case, but it's at least twice as fast to
 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }
Clear (inherited from PriorityQueue) | Removes all entries from the PriorityQueue.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxScore | returns the maximum score encountered by elements inserted via insert()
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Overloaded.
InsertWithOverflow
LessThan Returns whether
a
is less relevant than
b
.
Pop (inherited from PriorityQueue) | Removes and returns the least element of the PriorityQueue in log(size) time.
Put (inherited from PriorityQueue) | Adds an object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Size (inherited from PriorityQueue) | Returns the number of elements currently stored in the PriorityQueue.
Top (inherited from PriorityQueue) | Returns the least element of the PriorityQueue in constant time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Initialize (inherited from PriorityQueue) | Subclass constructors must call this.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

comparators | Stores a comparator corresponding to each field being sorted by
fields | Stores the sort criteria being used.
heap (inherited from PriorityQueue) |
maxscore | Stores the maximum score value encountered, needed for normalizing.

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace | |


FieldSortedHitQueue Constructor

Creates a hit queue sorted by the given list of fields.

public FieldSortedHitQueue(
IndexReader reader,
SortField[] fields,
int size
);

Parameters

reader
Index to use.
fields
Fieldable names, in priority order (highest priority first). Cannot be
null
or empty.
size
The number of hits to retain. Must be greater than zero.

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace


FieldSortedHitQueue Fields

The fields of the FieldSortedHitQueue class are listed below. For a complete list of FieldSortedHitQueue class members, see the FieldSortedHitQueue Members topic.

Protected Internal Instance Fields

comparators | Stores a comparator corresponding to each field being sorted by
fields | Stores the sort criteria being used.
heap (inherited from PriorityQueue) |
maxscore | Stores the maximum score value encountered, needed for normalizing.

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace | |


FieldSortedHitQueue.comparators Field

Stores a comparator corresponding to each field being sorted by

protected internal ScoreDocComparator[] comparators;

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace


FieldSortedHitQueue.fields Field

Stores the sort criteria being used.

protected internal SortField[] fields;

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace


FieldSortedHitQueue.maxscore Field

Stores the maximum score value encountered, needed for normalizing.

protected internal float maxscore;

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace


FieldSortedHitQueue Methods

The methods of the FieldSortedHitQueue class are listed below. For a complete list of FieldSortedHitQueue class members, see the FieldSortedHitQueue Members topic.

Public Instance Methods

AdjustTop (inherited from PriorityQueue) Should be called when the object at top changes values. Still log(n) worst case, but it's at least twice as fast to
 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }
Clear (inherited from PriorityQueue) | Removes all entries from the PriorityQueue.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxScore | returns the maximum score encountered by elements inserted via insert()
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Overloaded.
InsertWithOverflow
LessThan Returns whether
a
is less relevant than
b
.
Pop (inherited from PriorityQueue) | Removes and returns the least element of the PriorityQueue in log(size) time.
Put (inherited from PriorityQueue) | Adds an object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Size (inherited from PriorityQueue) | Returns the number of elements currently stored in the PriorityQueue.
Top (inherited from PriorityQueue) | Returns the least element of the PriorityQueue in constant time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Initialize (inherited from PriorityQueue) | Subclass constructors must call this.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace | |


FieldSortedHitQueue.GetMaxScore Method

returns the maximum score encountered by elements inserted via insert()

public virtual float GetMaxScore();

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace


Insert Method

Apache Lucene.Net 2.4.0 Class Library API

FieldSortedHitQueue.Insert Method

Overload List

public virtual bool Insert(FieldDoc);

public override bool Insert(object);

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace


FieldSortedHitQueue.Insert Method (FieldDoc)

public virtual bool Insert(
FieldDoc fdoc
);

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace | FieldSortedHitQueue.Insert Overload List


FieldSortedHitQueue.Insert Method (Object)

public override bool Insert(
object fdoc
);

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace | FieldSortedHitQueue.Insert Overload List


FieldSortedHitQueue.InsertWithOverflow Method

public override object InsertWithOverflow(
object element
);

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace


FieldSortedHitQueue.LessThan Method

Returns whether

a
is less relevant than
b
.

public override bool LessThan(
object a,
object b
);

Parameters

a
ScoreDoc
b
ScoreDoc

Return Value

true
if document
a
should be sorted after document
b
.

See Also

FieldSortedHitQueue Class | Lucene.Net.Search Namespace


Filter Class

Abstract base class providing a mechanism to limit index search results to a subset of an index.

Note: In Lucene 3.0, Bits(IndexReader) will be removed and GetDocIdSet(IndexReader) will be made abstract. All implementin classes must therefore implement GetDocIdSet(IndexReader) in order to work with Lucene 3.0.

For a list of all members of this type, see Filter Members.

System.Object
Lucene.Net.Search.Filter
Derived types

public abstract class Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Filter Members | Lucene.Net.Search Namespace


Filter Members

Filter overview

Public Instance Methods

Bits | Obsolete. Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDocIdSet | Return a DocIdSet that provides the documents which are permitted or prohibited in search results.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Filter Constructor Initializes a new instance of the Filter class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Filter Class | Lucene.Net.Search Namespace


Filter Constructor

Initializes a new instance of the Filter class.

protected Filter();

See Also

Filter Class | Lucene.Net.Search Namespace


Filter Methods

The methods of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Instance Methods

Bits | Obsolete. Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDocIdSet | Return a DocIdSet that provides the documents which are permitted or prohibited in search results.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Filter Class | Lucene.Net.Search Namespace


Filter.Bits Method

NOTE: This method is now obsolete.

Use GetDocIdSet(IndexReader) instead.

Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.

public abstract BitArray Bits(
IndexReader reader
);

See Also

Filter Class | Lucene.Net.Search Namespace


Filter.GetDocIdSet Method

Return a DocIdSet that provides the documents which are permitted or prohibited in search results.

public virtual DocIdSet GetDocIdSet(
IndexReader reader
);

Parameters

reader

Return Value

See Also

Filter Class | Lucene.Net.Search Namespace


FilteredQuery Class

A query that applies a filter to the results of another query.

Note: the bits are retrieved from the filter each time this query is used in a search - use a CachingWrapperFilter to avoid regenerating the bits every time.

For a list of all members of this type, see FilteredQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.FilteredQuery

public class FilteredQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilteredQuery Members | Lucene.Net.Search Namespace | CachingWrapperFilter


FilteredQuery Members

FilteredQuery overview

Public Instance Constructors

FilteredQuery Constructor Constructs a new query which applies a filter to the results of the original query. Filter.GetDocIdSet() will be called every time this query is used in a search.

Public Instance Methods

Clone
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetFilter
GetHashCode | Returns a hash code value for this object.
GetQuery
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite | Rewrites the wrapped query.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight Returns a Weight that applies the filter to the enclosed query's Weight. This is accomplished by overriding the Scorer returned by the Weight.

See Also

FilteredQuery Class | Lucene.Net.Search Namespace | CachingWrapperFilter


FilteredQuery Constructor

Constructs a new query which applies a filter to the results of the original query. Filter.GetDocIdSet() will be called every time this query is used in a search.

public FilteredQuery(
Query query,
Filter filter
);

Parameters

query
Query to be filtered, cannot be
null
.
filter
Filter to apply to query results, cannot be
null
.

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery Methods

The methods of the FilteredQuery class are listed below. For a complete list of FilteredQuery class members, see the FilteredQuery Members topic.

Public Instance Methods

Clone
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetFilter
GetHashCode | Returns a hash code value for this object.
GetQuery
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite | Rewrites the wrapped query.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight Returns a Weight that applies the filter to the enclosed query's Weight. This is accomplished by overriding the Scorer returned by the Weight.

See Also

FilteredQuery Class | Lucene.Net.Search Namespace | CachingWrapperFilter


FilteredQuery.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.CreateWeight Method

Returns a Weight that applies the filter to the enclosed query's Weight. This is accomplished by overriding the Scorer returned by the Weight.

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.GetFilter Method

public virtual Filter GetFilter();

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.GetQuery Method

public virtual Query GetQuery();

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.Rewrite Method

Rewrites the wrapped query.

public override Query Rewrite(
IndexReader reader
);

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

FilteredQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

FilteredQuery Class | Lucene.Net.Search Namespace


FilteredQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string s
);

See Also

FilteredQuery Class | Lucene.Net.Search Namespace | FilteredQuery.ToString Overload List


FilteredTermEnum Class

For a list of all members of this type, see FilteredTermEnum Members.

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Search.FilteredTermEnum
Lucene.Net.Search.FuzzyTermEnum
Lucene.Net.Search.WildcardTermEnum

public abstract class FilteredTermEnum : TermEnum

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilteredTermEnum Members | Lucene.Net.Search Namespace


FilteredTermEnum Members

FilteredTermEnum overview

Public Instance Constructors

FilteredTermEnum Constructor Initializes a new instance of the FilteredTermEnum class.

Public Instance Methods

Close | Closes the enumeration to further activity, freeing resources.
Difference | Equality measure on the term
DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
EndEnum | Indicates the end of the enumeration has been reached
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SetEnum |
TermCompare | Equality compare on the term

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum Constructor

Initializes a new instance of the FilteredTermEnum class.

public FilteredTermEnum();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum Methods

The methods of the FilteredTermEnum class are listed below. For a complete list of FilteredTermEnum class members, see the FilteredTermEnum Members topic.

Public Instance Methods

Close | Closes the enumeration to further activity, freeing resources.
Difference | Equality measure on the term
DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
EndEnum | Indicates the end of the enumeration has been reached
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SetEnum |
TermCompare | Equality compare on the term

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.Close Method

Closes the enumeration to further activity, freeing resources.

public override void Close();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.Difference Method

Equality measure on the term

public abstract float Difference();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.DocFreq Method

Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.

public override int DocFreq();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.EndEnum Method

Indicates the end of the enumeration has been reached

public abstract bool EndEnum();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.Next Method

Increments the enumeration to the next element. True if one exists.

public override bool Next();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.SetEnum Method

protected internal virtual void SetEnum(
TermEnum actualEnum
);

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.Term Method

Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.

public override Term Term();

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilteredTermEnum.TermCompare Method

Equality compare on the term

protected internal abstract bool TermCompare(
Term term
);

See Also

FilteredTermEnum Class | Lucene.Net.Search Namespace


FilterManager Class

Filter caching singleton. It can be used by {@link Lucene.Net.Search.RemoteCachingWrapperFilter} or just to save filters locally for reuse. This class makes it possble to cache Filters even when using RMI, as it keeps the cache on the seaercher side of the RMI connection. Also could be used as a persistent storage for any filter as long as the filter provides a proper hashCode(), as that is used as the key in the cache. The cache is periodically cleaned up from a separate thread to ensure the cache doesn't exceed the maximum size.

For a list of all members of this type, see FilterManager Members.

System.Object
Lucene.Net.Search.FilterManager

public class FilterManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilterManager Members | Lucene.Net.Search Namespace


FilterManager Members

FilterManager overview

Public Static Methods

GetInstance

Protected Internal Static Fields

DEFAULT_CACHE_CLEAN_SIZE | The default maximum number of Filters in the cache
DEFAULT_CACHE_SLEEP_TIME | The default frequency of cache clenup
manager |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilter | Returns the cached version of the filter. Allows the caller to pass up a small filter but this will keep a persistent version around and allow the caching filter to do its job.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCacheSize | Sets the max size that cache should reach before it is cleaned up
SetCleanThreadSleepTime | Sets the cache cleaning frequency in milliseconds.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

FilterManager Constructor Sets up the FilterManager singleton.

Protected Internal Instance Fields

cache | The cache itself
cacheCleanSize | Maximum allowed cache size
cleanSleepTime | Cache cleaning frequency
filterCleaner | Cache cleaner that runs in a separate thread

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager Constructor

Sets up the FilterManager singleton.

protected internal FilterManager();

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager Fields

The fields of the FilterManager class are listed below. For a complete list of FilterManager class members, see the FilterManager Members topic.

Protected Internal Static Fields

DEFAULT_CACHE_CLEAN_SIZE | The default maximum number of Filters in the cache
DEFAULT_CACHE_SLEEP_TIME | The default frequency of cache clenup
manager |

Protected Internal Instance Fields

cache | The cache itself
cacheCleanSize | Maximum allowed cache size
cleanSleepTime | Cache cleaning frequency
filterCleaner | Cache cleaner that runs in a separate thread

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager.cache Field

The cache itself

protected internal IDictionary cache;

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager.cacheCleanSize Field

Maximum allowed cache size

protected internal int cacheCleanSize;

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager.cleanSleepTime Field

Cache cleaning frequency

protected internal long cleanSleepTime;

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager.DEFAULT_CACHE_CLEAN_SIZE Field

The default maximum number of Filters in the cache

protected internal const int DEFAULT_CACHE_CLEAN_SIZE = 100;

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager.DEFAULT_CACHE_SLEEP_TIME Field

The default frequency of cache clenup

protected internal const long DEFAULT_CACHE_SLEEP_TIME = 600000;

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager.FilterCleaner Class

Keeps the cache from getting too big. If we were using Java 1.5, we could use LinkedHashMap and we would not need this thread to clean out the cache. The SortedSet sortedFilterItems is used only to sort the items from the cache, so when it's time to clean up we have the TreeSet sort the FilterItems by timestamp. Removes 1.5 * the numbers of items to make the cache smaller. For example: If cache clean size is 10, and the cache is at 15, we would remove (15 - 10) * 1.5 = 7.5 round up to 8. This way we clean the cache a bit more, and avoid having the cache cleaner having to do it frequently.

For a list of all members of this type, see FilterManager.FilterCleaner Members.

System.Object
Lucene.Net.Search.FilterManager.FilterCleaner

protected internal class FilterManager.FilterCleaner : IThreadRunnable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilterManager.FilterCleaner Members | Lucene.Net.Search Namespace


FilterManager.manager Field

protected internal static FilterManager manager;

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager Methods

The methods of the FilterManager class are listed below. For a complete list of FilterManager class members, see the FilterManager Members topic.

Public Static Methods

GetInstance

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilter | Returns the cached version of the filter. Allows the caller to pass up a small filter but this will keep a persistent version around and allow the caching filter to do its job.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCacheSize | Sets the max size that cache should reach before it is cleaned up
SetCleanThreadSleepTime | Sets the cache cleaning frequency in milliseconds.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager.GetFilter Method

Returns the cached version of the filter. Allows the caller to pass up a small filter but this will keep a persistent version around and allow the caching filter to do its job.

public virtual Filter GetFilter(
Filter filter
);

Parameters

filter
The input filter

Return Value

The cached version of the filter

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager.GetInstance Method

public static FilterManager GetInstance();

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager.SetCacheSize Method

Sets the max size that cache should reach before it is cleaned up

public virtual void SetCacheSize(
int cacheCleanSize
);

Parameters

cacheCleanSize
maximum allowed cache size

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager.SetCleanThreadSleepTime Method

Sets the cache cleaning frequency in milliseconds.

public virtual void SetCleanThreadSleepTime(
long cleanSleepTime
);

Parameters

cleanSleepTime
cleaning frequency in millioseconds

See Also

FilterManager Class | Lucene.Net.Search Namespace


FilterManager.FilterCleaner Members

FilterManager.FilterCleaner overview

Public Instance Constructors

FilterManager.FilterCleaner Constructor

Public Instance Properties

Enclosing_Instance

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterManager.FilterCleaner Class | Lucene.Net.Search Namespace


FilterManager.FilterCleaner Constructor

public FilterManager.FilterCleaner(
FilterManager enclosingInstance
);

See Also

FilterManager.FilterCleaner Class | Lucene.Net.Search Namespace


FilterManager.FilterCleaner Properties

The properties of the FilterManager.FilterCleaner class are listed below. For a complete list of FilterManager.FilterCleaner class members, see the FilterManager.FilterCleaner Members topic.

Public Instance Properties

Enclosing_Instance

See Also

FilterManager.FilterCleaner Class | Lucene.Net.Search Namespace


Enclosing_Instance Property

Apache Lucene.Net 2.4.0 Class Library API

FilterManager.FilterCleaner.Enclosing_Instance Property

public FilterManager Enclosing_Instance {get;}

See Also

FilterManager.FilterCleaner Class | Lucene.Net.Search Namespace


FilterManager.FilterCleaner Methods

The methods of the FilterManager.FilterCleaner class are listed below. For a complete list of FilterManager.FilterCleaner class members, see the FilterManager.FilterCleaner Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterManager.FilterCleaner Class | Lucene.Net.Search Namespace


FilterManager.FilterCleaner.Run Method

public virtual void Run();

Implements

IThreadRunnable.Run

See Also

FilterManager.FilterCleaner Class | Lucene.Net.Search Namespace


FilterManager.FilterItem Class

Holds the filter and the last time the filter was used, to make LRU-based cache cleaning possible. TODO: Clean this up when we switch to Java 1.5

For a list of all members of this type, see FilterManager.FilterItem Members.

System.Object
Lucene.Net.Search.FilterManager.FilterItem

protected internal class FilterManager.FilterItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FilterManager.FilterItem Members | Lucene.Net.Search Namespace


FilterManager.FilterItem Members

FilterManager.FilterItem overview

Public Instance Constructors

FilterManager.FilterItem Constructor

Public Instance Fields

filter
timestamp

Public Instance Properties

Enclosing_Instance

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterManager.FilterItem Class | Lucene.Net.Search Namespace


FilterManager.FilterItem Constructor

public FilterManager.FilterItem(
FilterManager enclosingInstance,
Filter filter
);

See Also

FilterManager.FilterItem Class | Lucene.Net.Search Namespace


FilterManager.FilterItem Fields

The fields of the FilterManager.FilterItem class are listed below. For a complete list of FilterManager.FilterItem class members, see the FilterManager.FilterItem Members topic.

Public Instance Fields

filter
timestamp

See Also

FilterManager.FilterItem Class | Lucene.Net.Search Namespace


FilterManager.FilterItem.filter Field

public Filter filter;

See Also

FilterManager.FilterItem Class | Lucene.Net.Search Namespace


FilterManager.FilterItem.timestamp Field

public long timestamp;

See Also

FilterManager.FilterItem Class | Lucene.Net.Search Namespace


FilterManager.FilterItem Properties

The properties of the FilterManager.FilterItem class are listed below. For a complete list of FilterManager.FilterItem class members, see the FilterManager.FilterItem Members topic.

Public Instance Properties

Enclosing_Instance

See Also

FilterManager.FilterItem Class | Lucene.Net.Search Namespace


Enclosing_Instance Property

Apache Lucene.Net 2.4.0 Class Library API

FilterManager.FilterItem.Enclosing_Instance Property

public FilterManager Enclosing_Instance {get;}

See Also

FilterManager.FilterItem Class | Lucene.Net.Search Namespace


FloatParser Interface

Interface to parse floats from document fields.

For a list of all members of this type, see FloatParser Members.

public interface FloatParser

Types that implement FloatParser

Type | Description
FieldCacheImpl.AnonymousClassFloatParser |

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FloatParser Members | Lucene.Net.Search Namespace | GetFloats


FloatParser Members

FloatParser overview

Public Instance Methods

ParseFloat Return an float representation of this field's value.

See Also

FloatParser Interface | Lucene.Net.Search Namespace | GetFloats


FloatParser Methods

The methods of the FloatParser interface are listed below. For a complete list of FloatParser interface members, see the FloatParser Members topic.

Public Instance Methods

ParseFloat Return an float representation of this field's value.

See Also

FloatParser Interface | Lucene.Net.Search Namespace | GetFloats


FloatParser.ParseFloat Method

Return an float representation of this field's value.

float ParseFloat(
string string_Renamed
);

See Also

FloatParser Interface | Lucene.Net.Search Namespace


FuzzyQuery Class

Implements the fuzzy search query. The similiarity measurement is based on the Levenshtein (edit distance) algorithm.

For a list of all members of this type, see FuzzyQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.MultiTermQuery
Lucene.Net.Search.FuzzyQuery

public class FuzzyQuery : MultiTermQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FuzzyQuery Members | Lucene.Net.Search Namespace


FuzzyQuery Members

FuzzyQuery overview

Public Static Fields

defaultMinSimilarity
defaultPrefixLength

Public Instance Constructors

FuzzyQuery Overloaded. Initializes a new instance of the FuzzyQuery class.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode
GetMinSimilarity | Returns the minimum similarity that is required for this query to match.
GetPrefixLength | Returns the non-fuzzy prefix length. This is the number of characters at the start of a term that must be identical (not fuzzy) to the query term if the query is to match that term.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm (inherited from MultiTermQuery) | Returns the pattern term.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)
GetEnum

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery Constructor

Create a new FuzzyQuery that will match terms with a similarity of at least

minimumSimilarity
to
term
. If a
prefixLength
> 0 is specified, a common prefix of that length is also required.

Overload List

Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, 0.5f, 0)}.

public FuzzyQuery(Term);

Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, minimumSimilarity, 0)}.

public FuzzyQuery(Term,float);

Create a new FuzzyQuery that will match terms with a similarity of at least

minimumSimilarity
to
term
. If a
prefixLength
> 0 is specified, a common prefix of that length is also required.

public FuzzyQuery(Term,float,int);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery Constructor (Term, Single, Int32)

Create a new FuzzyQuery that will match terms with a similarity of at least

minimumSimilarity
to
term
. If a
prefixLength
> 0 is specified, a common prefix of that length is also required.

public FuzzyQuery(
Term term,
float minimumSimilarity,
int prefixLength
);

Parameters

term
the term to search for
minimumSimilarity
a value between 0 and 1 to set the required similarity between the query term and the matching terms. For example, for a
minimumSimilarity
of
0.5
a term of the same length as the query term is considered similar to the query term if the edit distance between both terms is less than
length(term)*0.5
prefixLength
length of common (non-fuzzy) prefix

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace | FuzzyQuery Constructor Overload List


FuzzyQuery Constructor (Term, Single)

Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, minimumSimilarity, 0)}.

public FuzzyQuery(
Term term,
float minimumSimilarity
);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace | FuzzyQuery Constructor Overload List


FuzzyQuery Constructor (Term)

Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, 0.5f, 0)}.

public FuzzyQuery(
Term term
);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace | FuzzyQuery Constructor Overload List


FuzzyQuery Fields

The fields of the FuzzyQuery class are listed below. For a complete list of FuzzyQuery class members, see the FuzzyQuery Members topic.

Public Static Fields

defaultMinSimilarity
defaultPrefixLength

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.defaultMinSimilarity Field

public const float defaultMinSimilarity = 0.5;

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.defaultPrefixLength Field

public const int defaultPrefixLength = 0;

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery Methods

The methods of the FuzzyQuery class are listed below. For a complete list of FuzzyQuery class members, see the FuzzyQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode
GetMinSimilarity | Returns the minimum similarity that is required for this query to match.
GetPrefixLength | Returns the non-fuzzy prefix length. This is the number of characters at the start of a term that must be identical (not fuzzy) to the query term if the query is to match that term.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm (inherited from MultiTermQuery) | Returns the pattern term.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)
GetEnum

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.Equals Method

public override bool Equals(
object o
);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.GetEnum Method

protected internal override FilteredTermEnum GetEnum(
IndexReader reader
);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.GetHashCode Method

public override int GetHashCode();

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.GetMinSimilarity Method

Returns the minimum similarity that is required for this query to match.

public virtual float GetMinSimilarity();

Return Value

float value between 0.0 and 1.0

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.GetPrefixLength Method

Returns the non-fuzzy prefix length. This is the number of characters at the start of a term that must be identical (not fuzzy) to the query term if the query is to match that term.

public virtual int GetPrefixLength();

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

FuzzyQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace


FuzzyQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

FuzzyQuery Class | Lucene.Net.Search Namespace | FuzzyQuery.ToString Overload List


FuzzyQuery.ScoreTerm Class

For a list of all members of this type, see FuzzyQuery.ScoreTerm Members.

System.Object
Lucene.Net.Search.FuzzyQuery.ScoreTerm

protected internal class FuzzyQuery.ScoreTerm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FuzzyQuery.ScoreTerm Members | Lucene.Net.Search Namespace


FuzzyQuery.ScoreTerm Members

FuzzyQuery.ScoreTerm overview

Public Instance Constructors

FuzzyQuery.ScoreTerm Constructor

Public Instance Fields

score
term

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FuzzyQuery.ScoreTerm Class | Lucene.Net.Search Namespace


FuzzyQuery.ScoreTerm Constructor

public FuzzyQuery.ScoreTerm(
Term term,
float score
);

See Also

FuzzyQuery.ScoreTerm Class | Lucene.Net.Search Namespace


FuzzyQuery.ScoreTerm Fields

The fields of the FuzzyQuery.ScoreTerm class are listed below. For a complete list of FuzzyQuery.ScoreTerm class members, see the FuzzyQuery.ScoreTerm Members topic.

Public Instance Fields

score
term

See Also

FuzzyQuery.ScoreTerm Class | Lucene.Net.Search Namespace


FuzzyQuery.ScoreTerm.score Field

public float score;

See Also

FuzzyQuery.ScoreTerm Class | Lucene.Net.Search Namespace


FuzzyQuery.ScoreTerm.term Field

public Term term;

See Also

FuzzyQuery.ScoreTerm Class | Lucene.Net.Search Namespace


FuzzyQuery.ScoreTermQueue Class

For a list of all members of this type, see FuzzyQuery.ScoreTermQueue Members.

System.Object
Lucene.Net.Util.PriorityQueue
Lucene.Net.Search.FuzzyQuery.ScoreTermQueue

protected internal class FuzzyQuery.ScoreTermQueue : PriorityQueue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FuzzyQuery.ScoreTermQueue Members | Lucene.Net.Search Namespace


FuzzyQuery.ScoreTermQueue Members

FuzzyQuery.ScoreTermQueue overview

Public Instance Constructors

FuzzyQuery.ScoreTermQueue Constructor

Public Instance Methods

AdjustTop (inherited from PriorityQueue) Should be called when the object at top changes values. Still log(n) worst case, but it's at least twice as fast to
 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }
Clear (inherited from PriorityQueue) | Removes all entries from the PriorityQueue.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from PriorityQueue) | Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
InsertWithOverflow (inherited from PriorityQueue) | insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
LessThan
Pop (inherited from PriorityQueue) | Removes and returns the least element of the PriorityQueue in log(size) time.
Put (inherited from PriorityQueue) | Adds an object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Size (inherited from PriorityQueue) | Returns the number of elements currently stored in the PriorityQueue.
Top (inherited from PriorityQueue) | Returns the least element of the PriorityQueue in constant time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Initialize (inherited from PriorityQueue) | Subclass constructors must call this.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

heap (inherited from PriorityQueue)

See Also

FuzzyQuery.ScoreTermQueue Class | Lucene.Net.Search Namespace


FuzzyQuery.ScoreTermQueue Constructor

public FuzzyQuery.ScoreTermQueue(
int size
);

See Also

FuzzyQuery.ScoreTermQueue Class | Lucene.Net.Search Namespace


FuzzyQuery.ScoreTermQueue Methods

The methods of the FuzzyQuery.ScoreTermQueue class are listed below. For a complete list of FuzzyQuery.ScoreTermQueue class members, see the FuzzyQuery.ScoreTermQueue Members topic.

Public Instance Methods

AdjustTop (inherited from PriorityQueue) Should be called when the object at top changes values. Still log(n) worst case, but it's at least twice as fast to
 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }
Clear (inherited from PriorityQueue) | Removes all entries from the PriorityQueue.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from PriorityQueue) | Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
InsertWithOverflow (inherited from PriorityQueue) | insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
LessThan
Pop (inherited from PriorityQueue) | Removes and returns the least element of the PriorityQueue in log(size) time.
Put (inherited from PriorityQueue) | Adds an object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Size (inherited from PriorityQueue) | Returns the number of elements currently stored in the PriorityQueue.
Top (inherited from PriorityQueue) | Returns the least element of the PriorityQueue in constant time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Initialize (inherited from PriorityQueue) | Subclass constructors must call this.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FuzzyQuery.ScoreTermQueue Class | Lucene.Net.Search Namespace


FuzzyQuery.ScoreTermQueue.LessThan Method

public override bool LessThan(
object a,
object b
);

See Also

FuzzyQuery.ScoreTermQueue Class | Lucene.Net.Search Namespace


FuzzyTermEnum Class

For a list of all members of this type, see FuzzyTermEnum Members.

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Search.FilteredTermEnum
Lucene.Net.Search.FuzzyTermEnum

public sealed class FuzzyTermEnum : FilteredTermEnum

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FuzzyTermEnum Members | Lucene.Net.Search Namespace


FuzzyTermEnum Members

FuzzyTermEnum overview

Public Instance Constructors

FuzzyTermEnum Overloaded. Initializes a new instance of the FuzzyTermEnum class.

Public Instance Methods

Close |
Difference |
DocFreq (inherited from FilteredTermEnum) | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
EndEnum |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from FilteredTermEnum) | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term (inherited from FilteredTermEnum) | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

SetEnum (inherited from FilteredTermEnum) |
TermCompare | The termCompare method in FuzzyTermEnum uses Levenshtein distance to calculate the distance between the given term and the comparing term.

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


FuzzyTermEnum Constructor

Overload List

public FuzzyTermEnum(IndexReader,Term);

public FuzzyTermEnum(IndexReader,Term,float);

public FuzzyTermEnum(IndexReader,Term,float,int);

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


FuzzyTermEnum Constructor (IndexReader, Term)

public FuzzyTermEnum(
IndexReader reader,
Term term
);

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace | FuzzyTermEnum Constructor Overload List


FuzzyTermEnum Constructor (IndexReader, Term, Single)

public FuzzyTermEnum(
IndexReader reader,
Term term,
float minSimilarity
);

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace | FuzzyTermEnum Constructor Overload List


FuzzyTermEnum Constructor (IndexReader, Term, Single, Int32)

public FuzzyTermEnum(
IndexReader reader,
Term term,
float minSimilarity,
int prefixLength
);

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace | FuzzyTermEnum Constructor Overload List


FuzzyTermEnum Methods

The methods of the FuzzyTermEnum class are listed below. For a complete list of FuzzyTermEnum class members, see the FuzzyTermEnum Members topic.

Public Instance Methods

Close |
Difference |
DocFreq (inherited from FilteredTermEnum) | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
EndEnum |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from FilteredTermEnum) | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term (inherited from FilteredTermEnum) | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

SetEnum (inherited from FilteredTermEnum) |
TermCompare | The termCompare method in FuzzyTermEnum uses Levenshtein distance to calculate the distance between the given term and the comparing term.

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


FuzzyTermEnum.Close Method

public override void Close();

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


FuzzyTermEnum.Difference Method

public override float Difference();

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


FuzzyTermEnum.EndEnum Method

public override bool EndEnum();

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


FuzzyTermEnum.TermCompare Method

The termCompare method in FuzzyTermEnum uses Levenshtein distance to calculate the distance between the given term and the comparing term.

protected internal override bool TermCompare(
Term term
);

See Also

FuzzyTermEnum Class | Lucene.Net.Search Namespace


Hit Class

NOTE: This class is now obsolete.

Hits will be removed indexer Lucene 3.0. Use TopDocCollector and TopDocs instead.

Wrapper used by {@link HitIterator} to provide a lazily loaded hit from {@link Hits}.

For a list of all members of this type, see Hit Members.

System.Object
Lucene.Net.Search.Hit

public class Hit

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Hit Members | Lucene.Net.Search Namespace


Hit Members

Hit overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.
GetBoost | Returns the boost factor for this hit on any field of the underlying document.
GetDocument | Returns document for this hit.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetId | Returns id for this hit.
GetScore | Returns score for this hit.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Prints the parameters to be used to discover the promised result.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Hit Class | Lucene.Net.Search Namespace


Hit Methods

The methods of the Hit class are listed below. For a complete list of Hit class members, see the Hit Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.
GetBoost | Returns the boost factor for this hit on any field of the underlying document.
GetDocument | Returns document for this hit.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetId | Returns id for this hit.
GetScore | Returns score for this hit.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Prints the parameters to be used to discover the promised result.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Hit Class | Lucene.Net.Search Namespace


Hit.Get Method

Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.

public virtual string Get(
string name
);

See Also

Hit Class | Lucene.Net.Search Namespace |


Hit.GetBoost Method

Returns the boost factor for this hit on any field of the underlying document.

public virtual float GetBoost();

See Also

Hit Class | Lucene.Net.Search Namespace |


Hit.GetDocument Method

Returns document for this hit.

public virtual Document GetDocument();

See Also

Hit Class | Lucene.Net.Search Namespace |


Hit.GetId Method

Returns id for this hit.

public virtual int GetId();

See Also

Hit Class | Lucene.Net.Search Namespace | Hits#Id


Hit.GetScore Method

Returns score for this hit.

public virtual float GetScore();

See Also

Hit Class | Lucene.Net.Search Namespace |


Hit.ToString Method

Prints the parameters to be used to discover the promised result.

public override string ToString();

See Also

Hit Class | Lucene.Net.Search Namespace


HitCollector Class

For a list of all members of this type, see HitCollector Members.

System.Object
Lucene.Net.Search.HitCollector
Lucene.Net.Search.TimeLimitedCollector
Lucene.Net.Search.TopDocCollector

public abstract class HitCollector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

HitCollector Members | Lucene.Net.Search Namespace


HitCollector Members

HitCollector overview

Public Instance Methods

Collect |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

HitCollector Constructor Initializes a new instance of the HitCollector class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HitCollector Class | Lucene.Net.Search Namespace


HitCollector Constructor

Initializes a new instance of the HitCollector class.

protected HitCollector();

See Also

HitCollector Class | Lucene.Net.Search Namespace


HitCollector Methods

The methods of the HitCollector class are listed below. For a complete list of HitCollector class members, see the HitCollector Members topic.

Public Instance Methods

Collect |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HitCollector Class | Lucene.Net.Search Namespace


HitCollector.Collect Method

public abstract void Collect(
int doc,
float score
);

See Also

HitCollector Class | Lucene.Net.Search Namespace


HitIterator Class

NOTE: This class is now obsolete.

Hits will be removed in Lucene 3.0. Use TopDocCollector and TopDocs instead.

An iterator over {@link Hits} that provides lazy fetching of each document. {@link Hits#Iterator()} returns an instance of this class. Calls to {@link #Next()} return a {@link Hit} instance.

For a list of all members of this type, see HitIterator Members.

System.Object
Lucene.Net.Search.HitIterator

public class HitIterator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

HitIterator Members | Lucene.Net.Search Namespace


HitIterator Members

HitIterator overview

Public Instance Properties

Current Returns a {@link Hit} instance representing the next hit in {@link Hits}.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length | Returns the total number of hits.
MoveNext |
Remove | Unsupported operation.
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HitIterator Class | Lucene.Net.Search Namespace


HitIterator Properties

The properties of the HitIterator class are listed below. For a complete list of HitIterator class members, see the HitIterator Members topic.

Public Instance Properties

Current Returns a {@link Hit} instance representing the next hit in {@link Hits}.

See Also

HitIterator Class | Lucene.Net.Search Namespace


Current Property

Apache Lucene.Net 2.4.0 Class Library API

HitIterator.Current Property

Returns a {@link Hit} instance representing the next hit in {@link Hits}.

public virtual object Current {get;}

Implements

IEnumerator.Current

See Also

HitIterator Class | Lucene.Net.Search Namespace


HitIterator Methods

The methods of the HitIterator class are listed below. For a complete list of HitIterator class members, see the HitIterator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length | Returns the total number of hits.
MoveNext |
Remove | Unsupported operation.
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HitIterator Class | Lucene.Net.Search Namespace


HitIterator.Length Method

Returns the total number of hits.

public virtual int Length();

See Also

HitIterator Class | Lucene.Net.Search Namespace


HitIterator.MoveNext Method

public virtual bool MoveNext();

Return Value

true if current hit is less than the total number of {@link Hits}.

Implements

IEnumerator.MoveNext

See Also

HitIterator Class | Lucene.Net.Search Namespace


HitIterator.Remove Method

Unsupported operation.

public virtual void Remove();

See Also

HitIterator Class | Lucene.Net.Search Namespace


HitIterator.Reset Method

public virtual void Reset();

Implements

IEnumerator.Reset

See Also

HitIterator Class | Lucene.Net.Search Namespace


Hits Class

NOTE: This class is now obsolete.

Hits will be removed in Lucene 3.0. Insead used TopDocCollector and TopDocs.

For a list of all members of this type, see Hits Members.

System.Object
Lucene.Net.Search.Hits

public sealed class Hits

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Hits Members | Lucene.Net.Search Namespace


Hits Members

Hits overview

Public Instance Fields

debugCheckedForDeletions

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Id | Returns the id for the nth document in this set. Note that ids may change when the index changes, so you cannot rely on the id to be stable.
Iterator | Returns a {@link HitIterator} to navigate the Hits. Each item returned from {@link Iterator#next()} is a {@link Hit}. Caution: Iterate only over the hits needed. Iterating over all hits is generally not desirable and may be the source of performance issues. If you need to iterate over many or all hits, consider using a search method that takes a {@link HitCollector}.
Length | Returns the total number of hits available in this set.
Score | Returns the score for the nth document in this set.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Hits Class | Lucene.Net.Search Namespace


Hits Fields

The fields of the Hits class are listed below. For a complete list of Hits class members, see the Hits Members topic.

Public Instance Fields

debugCheckedForDeletions

See Also

Hits Class | Lucene.Net.Search Namespace


Hits.debugCheckedForDeletions Field

public bool debugCheckedForDeletions;

See Also

Hits Class | Lucene.Net.Search Namespace


Hits Methods

The methods of the Hits class are listed below. For a complete list of Hits class members, see the Hits Members topic.

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Id | Returns the id for the nth document in this set. Note that ids may change when the index changes, so you cannot rely on the id to be stable.
Iterator | Returns a {@link HitIterator} to navigate the Hits. Each item returned from {@link Iterator#next()} is a {@link Hit}. Caution: Iterate only over the hits needed. Iterating over all hits is generally not desirable and may be the source of performance issues. If you need to iterate over many or all hits, consider using a search method that takes a {@link HitCollector}.
Length | Returns the total number of hits available in this set.
Score | Returns the score for the nth document in this set.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Hits Class | Lucene.Net.Search Namespace


Hits.Doc Method

public Document Doc(
int n
);

See Also

Hits Class | Lucene.Net.Search Namespace


Hits.Id Method

Returns the id for the nth document in this set. Note that ids may change when the index changes, so you cannot rely on the id to be stable.

public int Id(
int n
);

See Also

Hits Class | Lucene.Net.Search Namespace


Hits.Iterator Method

Returns a {@link HitIterator} to navigate the Hits. Each item returned from {@link Iterator#next()} is a {@link Hit}.

Caution: Iterate only over the hits needed. Iterating over all hits is generally not desirable and may be the source of performance issues. If you need to iterate over many or all hits, consider using a search method that takes a {@link HitCollector}.

public IEnumerator Iterator();

See Also

Hits Class | Lucene.Net.Search Namespace


Hits.Length Method

Returns the total number of hits available in this set.

public int Length();

See Also

Hits Class | Lucene.Net.Search Namespace


Hits.Score Method

Returns the score for the nth document in this set.

public float Score(
int n
);

See Also

Hits Class | Lucene.Net.Search Namespace


IndexSearcher Class

For a list of all members of this type, see IndexSearcher Members.

System.Object
Lucene.Net.Search.Searcher
Lucene.Net.Search.IndexSearcher

public class IndexSearcher : Searcher

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexSearcher Members | Lucene.Net.Search Namespace


IndexSearcher Members

IndexSearcher overview

Public Instance Constructors

IndexSearcher Overloaded. Initializes a new instance of the IndexSearcher class.

Public Instance Properties

Reader

Public Instance Methods

Close | Note that the underlying IndexReader is not closed, if IndexSearcher was constructed with IndexSearcher(IndexReader r). If the IndexReader was supplied implicitly by specifying a directory, then the IndexReader gets closed.
Doc | Overloaded.
DocFreq
DocFreqs (inherited from Searcher)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain | Overloaded.
Explain (inherited from Searcher) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexReader | Return the {@link IndexReader} this searches.
GetSimilarity (inherited from Searcher)
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc
Rewrite
Search | Overloaded.
Search (inherited from Searcher) Overloaded. Returns the documents matching
query
.
SetSimilarity (inherited from Searcher) | Expert: Set the Similarity implementation used by this Searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Searcher) creates a weight for
query

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher Constructor

Creates a searcher searching the index in the named directory.

Overload List

Creates a searcher searching the provided index.

public IndexSearcher(IndexReader);

Creates a searcher searching the index in the provided directory.

public IndexSearcher(Directory);

Creates a searcher searching the index in the named directory.

public IndexSearcher(string);

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher Constructor (String)

Creates a searcher searching the index in the named directory.

public IndexSearcher(
string path
);

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher Constructor Overload List


IndexSearcher Constructor (Directory)

Creates a searcher searching the index in the provided directory.

public IndexSearcher(
Directory directory
);

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher Constructor Overload List


IndexSearcher Constructor (IndexReader)

Creates a searcher searching the provided index.

public IndexSearcher(
IndexReader r
);

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher Constructor Overload List


IndexSearcher Properties

The properties of the IndexSearcher class are listed below. For a complete list of IndexSearcher class members, see the IndexSearcher Members topic.

Public Instance Properties

Reader

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


Reader Property

Apache Lucene.Net 2.4.0 Class Library API

IndexSearcher.Reader Property

public Lucene.Net.Index.IndexReader Reader {get;}

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher Methods

The methods of the IndexSearcher class are listed below. For a complete list of IndexSearcher class members, see the IndexSearcher Members topic.

Public Instance Methods

Close | Note that the underlying IndexReader is not closed, if IndexSearcher was constructed with IndexSearcher(IndexReader r). If the IndexReader was supplied implicitly by specifying a directory, then the IndexReader gets closed.
Doc | Overloaded.
DocFreq
DocFreqs (inherited from Searcher)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain | Overloaded.
Explain (inherited from Searcher) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexReader | Return the {@link IndexReader} this searches.
GetSimilarity (inherited from Searcher)
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc
Rewrite
Search | Overloaded.
Search (inherited from Searcher) Overloaded. Returns the documents matching
query
.
SetSimilarity (inherited from Searcher) | Expert: Set the Similarity implementation used by this Searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Searcher) creates a weight for
query

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.Close Method

Note that the underlying IndexReader is not closed, if IndexSearcher was constructed with IndexSearcher(IndexReader r). If the IndexReader was supplied implicitly by specifying a directory, then the IndexReader gets closed.

public override void Close();

Implements

Searchable.Close

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


Doc Method

Apache Lucene.Net 2.4.0 Class Library API

IndexSearcher.Doc Method

Overload List

public override Document Doc(int);

public override Document Doc(int,FieldSelector);

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.Doc Method (Int32)

public override Document Doc(
int i
);

Implements

Searchable.Doc

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher.Doc Overload List


IndexSearcher.Doc Method (Int32, FieldSelector)

public override Document Doc(
int i,
FieldSelector fieldSelector
);

Implements

Searchable.Doc

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher.Doc Overload List


IndexSearcher.DocFreq Method

public override int DocFreq(
Term term
);

Implements

Searchable.DocFreq

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


Explain Method

Apache Lucene.Net 2.4.0 Class Library API

IndexSearcher.Explain Method

Overload List

Inherited from Searcher.

public virtual Explanation Explain(Query,int);

public override Explanation Explain(Weight,int);

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.Explain Method (Weight, Int32)

public override Explanation Explain(
Weight weight,
int doc
);

Implements

Searchable.Explain

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher.Explain Overload List


IndexSearcher.GetIndexReader Method

Return the {@link IndexReader} this searches.

public virtual IndexReader GetIndexReader();

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.MaxDoc Method

public override int MaxDoc();

Implements

Searchable.MaxDoc

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.Rewrite Method

public override Query Rewrite(
Query original
);

Implements

Searchable.Rewrite

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


Search Method

Apache Lucene.Net 2.4.0 Class Library API

IndexSearcher.Search Method

Overload List

Inherited from Searcher.

public Hits Search(Query);

Inherited from Searcher.

public virtual Hits Search(Query,Filter);

Inherited from Searcher.

public virtual void Search(Query,Filter,HitCollector);

Inherited from Searcher.

public virtual Hits Search(Query,Filter,Sort);

Inherited from Searcher.

public virtual TopDocs Search(Query,Filter,int);

Inherited from Searcher.

public virtual TopFieldDocs Search(Query,Filter,int,Sort);

Inherited from Searcher.

public virtual void Search(Query,HitCollector);

Inherited from Searcher.

public virtual Hits Search(Query,Sort);

Inherited from Searcher.

public virtual TopDocs Search(Query,int);

public override void Search(Weight,Filter,HitCollector);

public override TopDocs Search(Weight,Filter,int);

public override TopFieldDocs Search(Weight,Filter,int,Sort);

See Also

IndexSearcher Class | Lucene.Net.Search Namespace


IndexSearcher.Search Method (Weight, Filter, HitCollector)

public override void Search(
Weight weight,
Filter filter,
HitCollector results
);

Implements

Searchable.Search

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher.Search Overload List


IndexSearcher.Search Method (Weight, Filter, Int32)

public override TopDocs Search(
Weight weight,
Filter filter,
int nDocs
);

Implements

Searchable.Search

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher.Search Overload List


IndexSearcher.Search Method (Weight, Filter, Int32, Sort)

public override TopFieldDocs Search(
Weight weight,
Filter filter,
int nDocs,
Sort sort
);

Implements

Searchable.Search

See Also

IndexSearcher Class | Lucene.Net.Search Namespace | IndexSearcher.Search Overload List


IntParser Interface

Interface to parse ints from document fields.

For a list of all members of this type, see IntParser Members.

public interface IntParser

Types that implement IntParser

Type | Description
FieldCacheImpl.AnonymousClassIntParser |

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IntParser Members | Lucene.Net.Search Namespace | GetInts


IntParser Members

IntParser overview

Public Instance Methods

ParseInt Return an integer representation of this field's value.

See Also

IntParser Interface | Lucene.Net.Search Namespace | GetInts


IntParser Methods

The methods of the IntParser interface are listed below. For a complete list of IntParser interface members, see the IntParser Members topic.

Public Instance Methods

ParseInt Return an integer representation of this field's value.

See Also

IntParser Interface | Lucene.Net.Search Namespace | GetInts


IntParser.ParseInt Method

Return an integer representation of this field's value.

int ParseInt(
string string_Renamed
);

See Also

IntParser Interface | Lucene.Net.Search Namespace


LongParser Interface

For a list of all members of this type, see LongParser Members.

public interface LongParser

Types that implement LongParser

Type | Description
ExtendedFieldCacheImpl.AnonymousClassLongParser |

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LongParser Members | Lucene.Net.Search Namespace


LongParser Members

LongParser overview

Public Instance Methods

ParseLong Return an long representation of this field's value.

See Also

LongParser Interface | Lucene.Net.Search Namespace


LongParser Methods

The methods of the LongParser interface are listed below. For a complete list of LongParser interface members, see the LongParser Members topic.

Public Instance Methods

ParseLong Return an long representation of this field's value.

See Also

LongParser Interface | Lucene.Net.Search Namespace


LongParser.ParseLong Method

Return an long representation of this field's value.

long ParseLong(
string string_Renamed
);

See Also

LongParser Interface | Lucene.Net.Search Namespace


MatchAllDocsQuery Class

A query that matches all documents.

For a list of all members of this type, see MatchAllDocsQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.MatchAllDocsQuery

public class MatchAllDocsQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MatchAllDocsQuery Members | Lucene.Net.Search Namespace


MatchAllDocsQuery Members

MatchAllDocsQuery overview

Public Instance Constructors

MatchAllDocsQuery Constructor Initializes a new instance of the MatchAllDocsQuery class.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

MatchAllDocsQuery Class | Lucene.Net.Search Namespace


MatchAllDocsQuery Constructor

Initializes a new instance of the MatchAllDocsQuery class.

public MatchAllDocsQuery();

See Also

MatchAllDocsQuery Class | Lucene.Net.Search Namespace


MatchAllDocsQuery Methods

The methods of the MatchAllDocsQuery class are listed below. For a complete list of MatchAllDocsQuery class members, see the MatchAllDocsQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

MatchAllDocsQuery Class | Lucene.Net.Search Namespace


MatchAllDocsQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

MatchAllDocsQuery Class | Lucene.Net.Search Namespace


MatchAllDocsQuery.Equals Method

public override bool Equals(
object o
);

See Also

MatchAllDocsQuery Class | Lucene.Net.Search Namespace


MatchAllDocsQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

MatchAllDocsQuery Class | Lucene.Net.Search Namespace


MatchAllDocsQuery.GetHashCode Method

public override int GetHashCode();

See Also

MatchAllDocsQuery Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

MatchAllDocsQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

MatchAllDocsQuery Class | Lucene.Net.Search Namespace


MatchAllDocsQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

MatchAllDocsQuery Class | Lucene.Net.Search Namespace | MatchAllDocsQuery.ToString Overload List


MultiPhraseQuery Class

MultiPhraseQuery is a generalized version of PhraseQuery, with an added method {@link #Add(Term[])}. To use this class, to search for the phrase "Microsoft app*" first use add(Term) on the term "Microsoft", then find all terms that have "app" as prefix using IndexReader.terms(Term), and use MultiPhraseQuery.add(Term[] terms) to add them to the query.

For a list of all members of this type, see MultiPhraseQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.MultiPhraseQuery

public class MultiPhraseQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MultiPhraseQuery Members | Lucene.Net.Search Namespace


MultiPhraseQuery Members

MultiPhraseQuery overview

Public Instance Constructors

MultiPhraseQuery Constructor Initializes a new instance of the MultiPhraseQuery class.

Public Instance Methods

Add | Overloaded. Add a single term at the next position in the phrase.
Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true if
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetPositions | Returns the relative positions of terms in this phrase.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSlop | Sets the phrase slop for this query.
GetTermArrays
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
SetSlop | Sets the phrase slop for this query.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace


MultiPhraseQuery Constructor

Initializes a new instance of the MultiPhraseQuery class.

public MultiPhraseQuery();

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace


MultiPhraseQuery Methods

The methods of the MultiPhraseQuery class are listed below. For a complete list of MultiPhraseQuery class members, see the MultiPhraseQuery Members topic.

Public Instance Methods

Add | Overloaded. Add a single term at the next position in the phrase.
Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true if
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetPositions | Returns the relative positions of terms in this phrase.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSlop | Sets the phrase slop for this query.
GetTermArrays
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
SetSlop | Sets the phrase slop for this query.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace


Add Method

Apache Lucene.Net 2.4.0 Class Library API

MultiPhraseQuery.Add Method

Add a single term at the next position in the phrase.

Overload List

Add a single term at the next position in the phrase.

public virtual void Add(Term);

Add multiple terms at the next position in the phrase. Any of the terms may match.

public virtual void Add(Term[]);

Allows to specify the relative position of terms within the phrase.

public virtual void Add(Term[],int);

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace | PhraseQuery#Add


MultiPhraseQuery.Add Method (Term)

Add a single term at the next position in the phrase.

public virtual void Add(
Term term
);

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace | MultiPhraseQuery.Add Overload List | PhraseQuery#Add


MultiPhraseQuery.Add Method (Term[])

Add multiple terms at the next position in the phrase. Any of the terms may match.

public virtual void Add(
Term[] terms
);

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace | MultiPhraseQuery.Add Overload List | PhraseQuery#Add


MultiPhraseQuery.Add Method (Term[], Int32)

Allows to specify the relative position of terms within the phrase.

public virtual void Add(
Term[] terms,
int position
);

Parameters

terms
position

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace | MultiPhraseQuery.Add Overload List | int)


MultiPhraseQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace


MultiPhraseQuery.Equals Method

Returns true if

o
is equal to this.

public override bool Equals(
object o
);

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace


MultiPhraseQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace


MultiPhraseQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace


MultiPhraseQuery.GetPositions Method

Returns the relative positions of terms in this phrase.

public virtual int[] GetPositions();

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace


MultiPhraseQuery.GetSlop Method

Sets the phrase slop for this query.

public virtual int GetSlop();

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace | PhraseQuery#GetSlop


MultiPhraseQuery.GetTermArrays Method

public virtual IList GetTermArrays();

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace


MultiPhraseQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace


MultiPhraseQuery.SetSlop Method

Sets the phrase slop for this query.

public virtual void SetSlop(
int s
);

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace | PhraseQuery#SetSlop


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

MultiPhraseQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace


MultiPhraseQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string f
);

See Also

MultiPhraseQuery Class | Lucene.Net.Search Namespace | MultiPhraseQuery.ToString Overload List


MultiSearcher Class

For a list of all members of this type, see MultiSearcher Members.

System.Object
Lucene.Net.Search.Searcher
Lucene.Net.Search.MultiSearcher
Lucene.Net.Search.ParallelMultiSearcher

public class MultiSearcher : Searcher

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MultiSearcher Members | Lucene.Net.Search Namespace


MultiSearcher Members

MultiSearcher overview

Public Instance Constructors

MultiSearcher Constructor Creates a searcher which searches searchables.

Public Instance Methods

Close
Doc | Overloaded.
DocFreq
DocFreqs (inherited from Searcher)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain | Overloaded.
Explain (inherited from Searcher) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSearchables | Return the array of {@link Searchable}s this searches.
GetSimilarity (inherited from Searcher)
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc
Rewrite
Search | Overloaded.
Search (inherited from Searcher) Overloaded. Returns the documents matching
query
.
SetSimilarity (inherited from Searcher) | Expert: Set the Similarity implementation used by this Searcher.
SubDoc Returns the document number of document
n
within its sub-index.
SubSearcher Returns index of the searcher for document
n
in the array used to construct this searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight | Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods
GetStarts |

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher Constructor

Creates a searcher which searches searchables.

public MultiSearcher(
Searchable[] searchables
);

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher Methods

The methods of the MultiSearcher class are listed below. For a complete list of MultiSearcher class members, see the MultiSearcher Members topic.

Public Instance Methods

Close
Doc | Overloaded.
DocFreq
DocFreqs (inherited from Searcher)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain | Overloaded.
Explain (inherited from Searcher) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSearchables | Return the array of {@link Searchable}s this searches.
GetSimilarity (inherited from Searcher)
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc
Rewrite
Search | Overloaded.
Search (inherited from Searcher) Overloaded. Returns the documents matching
query
.
SetSimilarity (inherited from Searcher) | Expert: Set the Similarity implementation used by this Searcher.
SubDoc Returns the document number of document
n
within its sub-index.
SubSearcher Returns index of the searcher for document
n
in the array used to construct this searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight | Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods
GetStarts |

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.Close Method

public override void Close();

Implements

Searchable.Close

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.CreateWeight Method

Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods

protected internal override Weight CreateWeight(
Query original
);

Return Value

rewritten queries

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


Doc Method

Apache Lucene.Net 2.4.0 Class Library API

MultiSearcher.Doc Method

Overload List

public override Document Doc(int);

public override Document Doc(int,FieldSelector);

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.Doc Method (Int32)

public override Document Doc(
int n
);

Implements

Searchable.Doc

See Also

MultiSearcher Class | Lucene.Net.Search Namespace | MultiSearcher.Doc Overload List


MultiSearcher.Doc Method (Int32, FieldSelector)

public override Document Doc(
int n,
FieldSelector fieldSelector
);

Implements

Searchable.Doc

See Also

MultiSearcher Class | Lucene.Net.Search Namespace | MultiSearcher.Doc Overload List


MultiSearcher.DocFreq Method

public override int DocFreq(
Term term
);

Implements

Searchable.DocFreq

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


Explain Method

Apache Lucene.Net 2.4.0 Class Library API

MultiSearcher.Explain Method

Overload List

Inherited from Searcher.

public virtual Explanation Explain(Query,int);

public override Explanation Explain(Weight,int);

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.Explain Method (Weight, Int32)

public override Explanation Explain(
Weight weight,
int doc
);

Implements

Searchable.Explain

See Also

MultiSearcher Class | Lucene.Net.Search Namespace | MultiSearcher.Explain Overload List


MultiSearcher.GetSearchables Method

Return the array of {@link Searchable}s this searches.

public virtual Searchable[] GetSearchables();

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.GetStarts Method

protected internal virtual int[] GetStarts();

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.MaxDoc Method

public override int MaxDoc();

Implements

Searchable.MaxDoc

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.Rewrite Method

public override Query Rewrite(
Query original
);

Implements

Searchable.Rewrite

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


Search Method

Apache Lucene.Net 2.4.0 Class Library API

MultiSearcher.Search Method

Overload List

Inherited from Searcher.

public Hits Search(Query);

Inherited from Searcher.

public virtual Hits Search(Query,Filter);

Inherited from Searcher.

public virtual void Search(Query,Filter,HitCollector);

Inherited from Searcher.

public virtual Hits Search(Query,Filter,Sort);

Inherited from Searcher.

public virtual TopDocs Search(Query,Filter,int);

Inherited from Searcher.

public virtual TopFieldDocs Search(Query,Filter,int,Sort);

Inherited from Searcher.

public virtual void Search(Query,HitCollector);

Inherited from Searcher.

public virtual Hits Search(Query,Sort);

Inherited from Searcher.

public virtual TopDocs Search(Query,int);

public override void Search(Weight,Filter,HitCollector);

public override TopDocs Search(Weight,Filter,int);

public override TopFieldDocs Search(Weight,Filter,int,Sort);

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.Search Method (Weight, Filter, HitCollector)

public override void Search(
Weight weight,
Filter filter,
HitCollector results
);

Implements

Searchable.Search

See Also

MultiSearcher Class | Lucene.Net.Search Namespace | MultiSearcher.Search Overload List


MultiSearcher.Search Method (Weight, Filter, Int32)

public override TopDocs Search(
Weight weight,
Filter filter,
int nDocs
);

Implements

Searchable.Search

See Also

MultiSearcher Class | Lucene.Net.Search Namespace | MultiSearcher.Search Overload List


MultiSearcher.Search Method (Weight, Filter, Int32, Sort)

public override TopFieldDocs Search(
Weight weight,
Filter filter,
int n,
Sort sort
);

Implements

Searchable.Search

See Also

MultiSearcher Class | Lucene.Net.Search Namespace | MultiSearcher.Search Overload List


MultiSearcher.SubDoc Method

Returns the document number of document

n
within its sub-index.

public virtual int SubDoc(
int n
);

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiSearcher.SubSearcher Method

Returns index of the searcher for document

n
in the array used to construct this searcher.

public virtual int SubSearcher(
int n
);

See Also

MultiSearcher Class | Lucene.Net.Search Namespace


MultiTermQuery Class

For a list of all members of this type, see MultiTermQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.MultiTermQuery
Lucene.Net.Search.FuzzyQuery
Lucene.Net.Search.WildcardQuery

public abstract class MultiTermQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MultiTermQuery Members | Lucene.Net.Search Namespace


MultiTermQuery Members

MultiTermQuery overview

Public Instance Constructors

MultiTermQuery Constructor Constructs a query for terms matching
term
.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm | Returns the pattern term.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query) |
GetEnum | Construct the enumeration to be used, expanding the pattern term.

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery Constructor

Constructs a query for terms matching

term
.

public MultiTermQuery(
Term term
);

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery Methods

The methods of the MultiTermQuery class are listed below. For a complete list of MultiTermQuery class members, see the MultiTermQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm | Returns the pattern term.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query) |
GetEnum | Construct the enumeration to be used, expanding the pattern term.

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery.Equals Method

public override bool Equals(
object o
);

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery.GetEnum Method

Construct the enumeration to be used, expanding the pattern term.

protected internal abstract FilteredTermEnum GetEnum(
IndexReader reader
);

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery.GetHashCode Method

public override int GetHashCode();

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery.GetTerm Method

Returns the pattern term.

public virtual Term GetTerm();

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

MultiTermQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace


MultiTermQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string field
);

See Also

MultiTermQuery Class | Lucene.Net.Search Namespace | MultiTermQuery.ToString Overload List


ParallelMultiSearcher Class

For a list of all members of this type, see ParallelMultiSearcher Members.

System.Object
Lucene.Net.Search.Searcher
Lucene.Net.Search.MultiSearcher
Lucene.Net.Search.ParallelMultiSearcher

public class ParallelMultiSearcher : MultiSearcher

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ParallelMultiSearcher Members | Lucene.Net.Search Namespace


ParallelMultiSearcher Members

ParallelMultiSearcher overview

Public Instance Constructors

ParallelMultiSearcher Constructor Creates a searcher which searches searchables.

Public Instance Methods

Close (inherited from MultiSearcher)
Doc (inherited from MultiSearcher) | Overloaded.
DocFreq | TODO: parallelize this one too
DocFreqs (inherited from Searcher)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain (inherited from MultiSearcher) | Overloaded.
Explain (inherited from Searcher) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSearchables (inherited from MultiSearcher) | Return the array of {@link Searchable}s this searches.
GetSimilarity (inherited from Searcher)
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc (inherited from MultiSearcher)
Rewrite
Search | Overloaded. A search implementation which spans a new thread for each Searchable, waits for each search to complete and merge the results back together.
Search (inherited from Searcher) Overloaded. Returns the documents matching
query
.
SetSimilarity (inherited from Searcher) | Expert: Set the Similarity implementation used by this Searcher.
SubDoc (inherited from MultiSearcher) Returns the document number of document
n
within its sub-index.
SubSearcher (inherited from MultiSearcher) Returns index of the searcher for document
n
in the array used to construct this searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from MultiSearcher) | Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods
GetStarts (inherited from MultiSearcher) |

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace


ParallelMultiSearcher Constructor

Creates a searcher which searches searchables.

public ParallelMultiSearcher(
Searchable[] searchables
);

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace


ParallelMultiSearcher Methods

The methods of the ParallelMultiSearcher class are listed below. For a complete list of ParallelMultiSearcher class members, see the ParallelMultiSearcher Members topic.

Public Instance Methods

Close (inherited from MultiSearcher)
Doc (inherited from MultiSearcher) | Overloaded.
DocFreq | TODO: parallelize this one too
DocFreqs (inherited from Searcher)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain (inherited from MultiSearcher) | Overloaded.
Explain (inherited from Searcher) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSearchables (inherited from MultiSearcher) | Return the array of {@link Searchable}s this searches.
GetSimilarity (inherited from Searcher)
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc (inherited from MultiSearcher)
Rewrite
Search | Overloaded. A search implementation which spans a new thread for each Searchable, waits for each search to complete and merge the results back together.
Search (inherited from Searcher) Overloaded. Returns the documents matching
query
.
SetSimilarity (inherited from Searcher) | Expert: Set the Similarity implementation used by this Searcher.
SubDoc (inherited from MultiSearcher) Returns the document number of document
n
within its sub-index.
SubSearcher (inherited from MultiSearcher) Returns index of the searcher for document
n
in the array used to construct this searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from MultiSearcher) | Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods
GetStarts (inherited from MultiSearcher) |

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace


ParallelMultiSearcher.DocFreq Method

TODO: parallelize this one too

public override int DocFreq(
Term term
);

Implements

Searchable.DocFreq

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace


ParallelMultiSearcher.Rewrite Method

public override Query Rewrite(
Query original
);

Implements

Searchable.Rewrite

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace


Search Method

Apache Lucene.Net 2.4.0 Class Library API

ParallelMultiSearcher.Search Method

Overload List

Inherited from Searcher.

public Hits Search(Query);

Inherited from Searcher.

public virtual Hits Search(Query,Filter);

Inherited from Searcher.

public virtual void Search(Query,Filter,HitCollector);

Inherited from Searcher.

public virtual Hits Search(Query,Filter,Sort);

Inherited from Searcher.

public virtual TopDocs Search(Query,Filter,int);

Inherited from Searcher.

public virtual TopFieldDocs Search(Query,Filter,int,Sort);

Inherited from Searcher.

public virtual void Search(Query,HitCollector);

Inherited from Searcher.

public virtual Hits Search(Query,Sort);

Inherited from Searcher.

public virtual TopDocs Search(Query,int);

public override void Search(Weight,Filter,HitCollector);

A search implementation which spans a new thread for each Searchable, waits for each search to complete and merge the results back together.

public override TopDocs Search(Weight,Filter,int);

A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.

public override TopFieldDocs Search(Weight,Filter,int,Sort);

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace


ParallelMultiSearcher.Search Method (Weight, Filter, HitCollector)

public override void Search(
Weight weight,
Filter filter,
HitCollector results
);

Implements

Searchable.Search

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace | ParallelMultiSearcher.Search Overload List


ParallelMultiSearcher.Search Method (Weight, Filter, Int32)

A search implementation which spans a new thread for each Searchable, waits for each search to complete and merge the results back together.

public override TopDocs Search(
Weight weight,
Filter filter,
int nDocs
);

Implements

Searchable.Search

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace | ParallelMultiSearcher.Search Overload List


ParallelMultiSearcher.Search Method (Weight, Filter, Int32, Sort)

A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.

public override TopFieldDocs Search(
Weight weight,
Filter filter,
int nDocs,
Sort sort
);

Implements

Searchable.Search

See Also

ParallelMultiSearcher Class | Lucene.Net.Search Namespace | ParallelMultiSearcher.Search Overload List


PhraseQuery Class

For a list of all members of this type, see PhraseQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.PhraseQuery

public class PhraseQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PhraseQuery Members | Lucene.Net.Search Namespace


PhraseQuery Members

PhraseQuery overview

Public Instance Constructors

PhraseQuery Constructor Constructs an empty phrase query.

Public Instance Methods

Add | Overloaded. Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.
Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetPositions | Returns the relative positions of terms in this phrase.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSlop | Returns the slop. See setSlop().
GetTerms | Returns the set of terms in this phrase.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
SetSlop
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery Constructor

Constructs an empty phrase query.

public PhraseQuery();

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery Methods

The methods of the PhraseQuery class are listed below. For a complete list of PhraseQuery class members, see the PhraseQuery Members topic.

Public Instance Methods

Add | Overloaded. Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.
Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetPositions | Returns the relative positions of terms in this phrase.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSlop | Returns the slop. See setSlop().
GetTerms | Returns the set of terms in this phrase.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
SetSlop
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


Add Method

Apache Lucene.Net 2.4.0 Class Library API

PhraseQuery.Add Method

Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.

Overload List

Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.

public virtual void Add(Term);

Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).

public virtual void Add(Term,int);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.Add Method (Term)

Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.

public virtual void Add(
Term term
);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace | PhraseQuery.Add Overload List


PhraseQuery.Add Method (Term, Int32)

Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).

public virtual void Add(
Term term,
int position
);

Parameters

term
position

See Also

PhraseQuery Class | Lucene.Net.Search Namespace | PhraseQuery.Add Overload List


PhraseQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable queryTerms
);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace | Query#ExtractTerms


PhraseQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.GetPositions Method

Returns the relative positions of terms in this phrase.

public virtual int[] GetPositions();

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.GetSlop Method

Returns the slop. See setSlop().

public virtual int GetSlop();

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.GetTerms Method

Returns the set of terms in this phrase.

public virtual Term[] GetTerms();

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.SetSlop Method

public virtual void SetSlop(
int s
);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

PhraseQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace


PhraseQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string f
);

See Also

PhraseQuery Class | Lucene.Net.Search Namespace | PhraseQuery.ToString Overload List


PrefixFilter Class

For a list of all members of this type, see PrefixFilter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.PrefixFilter

public class PrefixFilter : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PrefixFilter Members | Lucene.Net.Search Namespace


PrefixFilter Members

PrefixFilter overview

Public Instance Constructors

PrefixFilter Constructor

Public Instance Methods

Bits | Obsolete.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDocIdSet |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPrefix |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Prints a user-readable version of this query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

prefix

See Also

PrefixFilter Class | Lucene.Net.Search Namespace


PrefixFilter Constructor

public PrefixFilter(
Term prefix
);

See Also

PrefixFilter Class | Lucene.Net.Search Namespace


PrefixFilter Fields

The fields of the PrefixFilter class are listed below. For a complete list of PrefixFilter class members, see the PrefixFilter Members topic.

Protected Internal Instance Fields

prefix

See Also

PrefixFilter Class | Lucene.Net.Search Namespace


PrefixFilter.prefix Field

protected internal Term prefix;

See Also

PrefixFilter Class | Lucene.Net.Search Namespace


PrefixFilter Methods

The methods of the PrefixFilter class are listed below. For a complete list of PrefixFilter class members, see the PrefixFilter Members topic.

Public Instance Methods

Bits | Obsolete.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDocIdSet |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPrefix |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Prints a user-readable version of this query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrefixFilter Class | Lucene.Net.Search Namespace


PrefixFilter.Bits Method

NOTE: This method is now obsolete.

public override BitArray Bits(
IndexReader reader
);

See Also

PrefixFilter Class | Lucene.Net.Search Namespace


PrefixFilter.GetDocIdSet Method

public override DocIdSet GetDocIdSet(
IndexReader reader
);

See Also

PrefixFilter Class | Lucene.Net.Search Namespace


PrefixFilter.GetPrefix Method

public virtual Term GetPrefix();

See Also

PrefixFilter Class | Lucene.Net.Search Namespace


PrefixFilter.ToString Method

Prints a user-readable version of this query.

public override string ToString();

See Also

PrefixFilter Class | Lucene.Net.Search Namespace


PrefixQuery Class

A Query that matches documents containing terms with a specified prefix. A PrefixQuery is built by QueryParser for input like

app*
.

For a list of all members of this type, see PrefixQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.PrefixQuery

public class PrefixQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PrefixQuery Members | Lucene.Net.Search Namespace


PrefixQuery Members

PrefixQuery overview

Public Instance Constructors

PrefixQuery Constructor Constructs a query for terms starting with
prefix
.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true iff
o
is equal to this.
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetPrefix | Returns the prefix of this query.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery Constructor

Constructs a query for terms starting with

prefix
.

public PrefixQuery(
Term prefix
);

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery Methods

The methods of the PrefixQuery class are listed below. For a complete list of PrefixQuery class members, see the PrefixQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true iff
o
is equal to this.
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetPrefix | Returns the prefix of this query.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery.GetPrefix Method

Returns the prefix of this query.

public virtual Term GetPrefix();

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

PrefixQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

PrefixQuery Class | Lucene.Net.Search Namespace


PrefixQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string field
);

See Also

PrefixQuery Class | Lucene.Net.Search Namespace | PrefixQuery.ToString Overload List


Query Class

For a list of all members of this type, see Query Members.

System.Object
Lucene.Net.Search.Query
Derived types

public abstract class Query : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Query Members | Lucene.Net.Search Namespace


Query Members

Query overview

Public Static Methods

MergeBooleanQueries

Public Instance Methods

Clone | Returns a clone of this query.
Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExtractTerms | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
Weight | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Constructors

Query Constructor Initializes a new instance of the Query class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

Query Class | Lucene.Net.Search Namespace


Query Constructor

Initializes a new instance of the Query class.

protected Query();

See Also

Query Class | Lucene.Net.Search Namespace


Query Methods

The methods of the Query class are listed below. For a complete list of Query class members, see the Query Members topic.

Public Static Methods

MergeBooleanQueries

Public Instance Methods

Clone | Returns a clone of this query.
Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExtractTerms | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
Weight | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

Query Class | Lucene.Net.Search Namespace


Query.Clone Method

Returns a clone of this query.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

Query Class | Lucene.Net.Search Namespace


Query.Combine Method

Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.

public virtual Query Combine(
Query[] queries
);

See Also

Query Class | Lucene.Net.Search Namespace


Query.CreateWeight Method

protected internal virtual Weight CreateWeight(
Searcher searcher
);

See Also

Query Class | Lucene.Net.Search Namespace


Query.ExtractTerms Method

Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.

public virtual void ExtractTerms(
Hashtable terms
);

See Also

Query Class | Lucene.Net.Search Namespace


Query.GetBoost Method

Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by

b
. The boost is 1.0 by default.

public virtual float GetBoost();

See Also

Query Class | Lucene.Net.Search Namespace


Query.GetSimilarity Method

Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.

public virtual Similarity GetSimilarity(
Searcher searcher
);

See Also

Query Class | Lucene.Net.Search Namespace


Query.MergeBooleanQueries Method

public static Query MergeBooleanQueries(
Query[] queries
);

See Also

Query Class | Lucene.Net.Search Namespace


Query.Rewrite Method

Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.

public virtual Query Rewrite(
IndexReader reader
);

See Also

Query Class | Lucene.Net.Search Namespace


Query.SetBoost Method

Sets the boost for this query clause to

b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.

public virtual void SetBoost(
float b
);

See Also

Query Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

Query.ToString Method

Prints a query to a string.

Overload List

Prints a query to a string.

public override string ToString();

public abstract string ToString(string);

See Also

Query Class | Lucene.Net.Search Namespace


Query.ToString Method ()

Prints a query to a string.

public override string ToString();

See Also

Query Class | Lucene.Net.Search Namespace | Query.ToString Overload List


Query.ToString Method (String)

public abstract string ToString(
string field
);

See Also

Query Class | Lucene.Net.Search Namespace | Query.ToString Overload List


Query.Weight Method

Expert: Constructs and initializes a Weight for a top-level query.

public virtual Weight Weight(
Searcher searcher
);

See Also

Query Class | Lucene.Net.Search Namespace


QueryFilter Class

Constrains search results to only match those which also match a provided query. Results are cached, so that searches after the first on the same index using this filter are much faster.

For a list of all members of this type, see QueryFilter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.CachingWrapperFilter
Lucene.Net.Search.QueryFilter

public class QueryFilter : CachingWrapperFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

QueryFilter Members | Lucene.Net.Search Namespace


QueryFilter Members

QueryFilter overview

Public Instance Constructors

QueryFilter Constructor Constructs a filter which only matches documents matching
query
.

Public Instance Methods

Bits (inherited from CachingWrapperFilter) | Obsolete.
Equals |
GetDocIdSet (inherited from CachingWrapperFilter) |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from CachingWrapperFilter) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

cache (inherited from CachingWrapperFilter) | A transient Filter cache. To cache Filters even when using {@link RemoteSearchable} use {@link RemoteCachingWrapperFilter} instead.
filter (inherited from CachingWrapperFilter) |

See Also

QueryFilter Class | Lucene.Net.Search Namespace


QueryFilter Constructor

Constructs a filter which only matches documents matching

query
.

public QueryFilter(
Query query
);

See Also

QueryFilter Class | Lucene.Net.Search Namespace


QueryFilter Methods

The methods of the QueryFilter class are listed below. For a complete list of QueryFilter class members, see the QueryFilter Members topic.

Public Instance Methods

Bits (inherited from CachingWrapperFilter) | Obsolete.
Equals |
GetDocIdSet (inherited from CachingWrapperFilter) |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from CachingWrapperFilter) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryFilter Class | Lucene.Net.Search Namespace


QueryFilter.Equals Method

public override bool Equals(
object o
);

See Also

QueryFilter Class | Lucene.Net.Search Namespace


QueryFilter.GetHashCode Method

public override int GetHashCode();

See Also

QueryFilter Class | Lucene.Net.Search Namespace


QueryTermVector Class

For a list of all members of this type, see QueryTermVector Members.

System.Object
Lucene.Net.Search.QueryTermVector

public class QueryTermVector : TermFreqVector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

QueryTermVector Members | Lucene.Net.Search Namespace


QueryTermVector Members

QueryTermVector overview

Public Instance Constructors

QueryTermVector Overloaded. Initializes a new instance of the QueryTermVector class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetField |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTermFrequencies |
GetTerms |
GetType (inherited from Object) | Gets the Type of the current instance.
IndexesOf |
IndexOf |
Size |
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector Constructor

Overload List

public QueryTermVector(string,Analyzer);

public QueryTermVector(string[]);

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector Constructor (String[])

public QueryTermVector(
string[] queryTerms
);

Parameters

queryTerms
The original list of terms from the query, can contain duplicates

See Also

QueryTermVector Class | Lucene.Net.Search Namespace | QueryTermVector Constructor Overload List


QueryTermVector Constructor (String, Analyzer)

public QueryTermVector(
string queryString,
Analyzer analyzer
);

See Also

QueryTermVector Class | Lucene.Net.Search Namespace | QueryTermVector Constructor Overload List


QueryTermVector Methods

The methods of the QueryTermVector class are listed below. For a complete list of QueryTermVector class members, see the QueryTermVector Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetField |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTermFrequencies |
GetTerms |
GetType (inherited from Object) | Gets the Type of the current instance.
IndexesOf |
IndexOf |
Size |
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.GetField Method

public virtual string GetField();

Implements

TermFreqVector.GetField

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.GetTermFrequencies Method

public virtual int[] GetTermFrequencies();

Implements

TermFreqVector.GetTermFrequencies

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.GetTerms Method

public virtual string[] GetTerms();

Implements

TermFreqVector.GetTerms

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.IndexesOf Method

public virtual int[] IndexesOf(
string[] terms,
int start,
int len
);

Implements

TermFreqVector.IndexesOf

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.IndexOf Method

public virtual int IndexOf(
string term
);

Implements

TermFreqVector.IndexOf

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.Size Method

public virtual int Size();

Implements

TermFreqVector.Size

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryTermVector.ToString Method

public override string ToString();

See Also

QueryTermVector Class | Lucene.Net.Search Namespace


QueryWrapperFilter Class

For a list of all members of this type, see QueryWrapperFilter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.QueryWrapperFilter

public class QueryWrapperFilter : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

QueryWrapperFilter Members | Lucene.Net.Search Namespace


QueryWrapperFilter Members

QueryWrapperFilter overview

Public Instance Constructors

QueryWrapperFilter Constructor Constructs a filter which only matches documents matching
query
.

Public Instance Methods

Bits | Obsolete.
Equals |
GetDocIdSet |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryWrapperFilter Class | Lucene.Net.Search Namespace


QueryWrapperFilter Constructor

Constructs a filter which only matches documents matching

query
.

public QueryWrapperFilter(
Query query
);

See Also

QueryWrapperFilter Class | Lucene.Net.Search Namespace


QueryWrapperFilter Methods

The methods of the QueryWrapperFilter class are listed below. For a complete list of QueryWrapperFilter class members, see the QueryWrapperFilter Members topic.

Public Instance Methods

Bits | Obsolete.
Equals |
GetDocIdSet |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryWrapperFilter Class | Lucene.Net.Search Namespace


QueryWrapperFilter.Bits Method

NOTE: This method is now obsolete.

Use getDocIdSet(IndexReader) instead.

public override BitArray Bits(
IndexReader reader
);

See Also

QueryWrapperFilter Class | Lucene.Net.Search Namespace


QueryWrapperFilter.Equals Method

public override bool Equals(
object o
);

See Also

QueryWrapperFilter Class | Lucene.Net.Search Namespace


QueryWrapperFilter.GetDocIdSet Method

public override DocIdSet GetDocIdSet(
IndexReader reader
);

See Also

QueryWrapperFilter Class | Lucene.Net.Search Namespace


QueryWrapperFilter.GetHashCode Method

public override int GetHashCode();

See Also

QueryWrapperFilter Class | Lucene.Net.Search Namespace


QueryWrapperFilter.ToString Method

public override string ToString();

See Also

QueryWrapperFilter Class | Lucene.Net.Search Namespace


RangeFilter Class

A Filter that restricts search results to a range of values in a given field.

This code borrows heavily from {@link RangeQuery}, but is implemented as a Filter

For a list of all members of this type, see RangeFilter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.RangeFilter

public class RangeFilter : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RangeFilter Members | Lucene.Net.Search Namespace


RangeFilter Members

RangeFilter overview

Public Static Methods

Less Constructs a filter for field
fieldName
matching less than or equal to
upperTerm
.
More Constructs a filter for field
fieldName
matching greater than or equal to
lowerTerm
.

Public Instance Constructors

RangeFilter Overloaded. Initializes a new instance of the RangeFilter class.

Public Instance Methods

Bits | Obsolete. Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
Equals Returns true if
o
is equal to this.
GetDocIdSet | Returns a DocIdSet with documents that should be permitted in search results.
GetHashCode | Returns a hash code value for this object.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RangeFilter Class | Lucene.Net.Search Namespace


RangeFilter Constructor

lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)

Overload List

lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)

public RangeFilter(string,string,string,bool,bool);

WARNING: Using this constructor and supplying a non-null value in the collator paramter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

public RangeFilter(string,string,string,bool,bool,CompareInfo);

See Also

RangeFilter Class | Lucene.Net.Search Namespace


RangeFilter Constructor (String, String, String, Boolean, Boolean)

lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)

public RangeFilter(
string fieldName,
string lowerTerm,
string upperTerm,
bool includeLower,
bool includeUpper
);

Parameters

fieldName
The field this range applies to
lowerTerm
The lower bound on this range
upperTerm
The upper bound on this range
includeLower
Does this range include the lower bound?
includeUpper
Does this range include the upper bound?

See Also

RangeFilter Class | Lucene.Net.Search Namespace | RangeFilter Constructor Overload List


RangeFilter Constructor (String, String, String, Boolean, Boolean, CompareInfo)

WARNING: Using this constructor and supplying a non-null value in the collator paramter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

public RangeFilter(
string fieldName,
string lowerTerm,
string upperTerm,
bool includeLower,
bool includeUpper,
CompareInfo collator
);

Parameters

fieldName
lowerTerm
lower bound
upperTerm
upper bound
includeLower
is lower bound inclusive
includeUpper
is upper bound inclusive
collator
the collator that determines range inclusion; when set to null Unicode code point ordering is used

See Also

RangeFilter Class | Lucene.Net.Search Namespace | RangeFilter Constructor Overload List


RangeFilter Methods

The methods of the RangeFilter class are listed below. For a complete list of RangeFilter class members, see the RangeFilter Members topic.

Public Static Methods

Less Constructs a filter for field
fieldName
matching less than or equal to
upperTerm
.
More Constructs a filter for field
fieldName
matching greater than or equal to
lowerTerm
.

Public Instance Methods

Bits | Obsolete. Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
Equals Returns true if
o
is equal to this.
GetDocIdSet | Returns a DocIdSet with documents that should be permitted in search results.
GetHashCode | Returns a hash code value for this object.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RangeFilter Class | Lucene.Net.Search Namespace


RangeFilter.Bits Method

NOTE: This method is now obsolete.

use GetDocIdSet(IndexReader) instead

Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.

public override BitArray Bits(
IndexReader reader
);

See Also

RangeFilter Class | Lucene.Net.Search Namespace


RangeFilter.Equals Method

Returns true if

o
is equal to this.

public override bool Equals(
object o
);

See Also

RangeFilter Class | Lucene.Net.Search Namespace


RangeFilter.GetDocIdSet Method

Returns a DocIdSet with documents that should be permitted in search results.

public override DocIdSet GetDocIdSet(
IndexReader reader
);

See Also

RangeFilter Class | Lucene.Net.Search Namespace


RangeFilter.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

RangeFilter Class | Lucene.Net.Search Namespace


RangeFilter.Less Method

Constructs a filter for field

fieldName
matching less than or equal to
upperTerm
.

public static RangeFilter Less(
string fieldName,
string upperTerm
);

See Also

RangeFilter Class | Lucene.Net.Search Namespace


RangeFilter.More Method

Constructs a filter for field

fieldName
matching greater than or equal to
lowerTerm
.

public static RangeFilter More(
string fieldName,
string lowerTerm
);

See Also

RangeFilter Class | Lucene.Net.Search Namespace


RangeFilter.ToString Method

public override string ToString();

See Also

RangeFilter Class | Lucene.Net.Search Namespace


RangeQuery Class

A Query that matches documents within an exclusive range. A RangeQuery is built by QueryParser for input like

[010 TO 120]
but only if the QueryParser has the useOldRangeQuery property set to true. The QueryParser default behaviour is to use the newer ConstantScoreRangeQuery class. This is generally preferable because:
  • It is faster than RangeQuery
  • Unlike RangeQuery, it does not cause a BooleanQuery.TooManyClauses exception if the range of values is large
  • Unlike RangeQuery it does not influence scoring based on the scarcity of individual terms that may match

For a list of all members of this type, see RangeQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.RangeQuery

public class RangeQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RangeQuery Members | Lucene.Net.Search Namespace | ConstantScoreRangeQuery


RangeQuery Members

RangeQuery overview

Public Instance Constructors

RangeQuery Overloaded. Initializes a new instance of the RangeQuery class.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true iff
o
is equal to this.
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetCollator | Returns the collator used to determine range inclusion, if any.
GetField | Returns the field name for this query
GetHashCode | Returns a hash code value for this object.
GetLowerTerm | Returns the lower term of this range query
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUpperTerm | Returns the upper term of this range query
IsInclusive Returns
true
if the range query is inclusive
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)

See Also

RangeQuery Class | Lucene.Net.Search Namespace | ConstantScoreRangeQuery


RangeQuery Constructor

Constructs a query selecting all terms greater than

lowerTerm
but less than
upperTerm
. There must be at least one term and either term may be null, in which case there is no bound on that side, but if there are two terms, both terms must be for the same field.

Overload List

Constructs a query selecting all terms greater than

lowerTerm
but less than
upperTerm
. There must be at least one term and either term may be null, in which case there is no bound on that side, but if there are two terms, both terms must be for the same field.

public RangeQuery(Term,Term,bool);

public RangeQuery(Term,Term,bool,CompareInfo);

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery Constructor (Term, Term, Boolean)

Constructs a query selecting all terms greater than

lowerTerm
but less than
upperTerm
. There must be at least one term and either term may be null, in which case there is no bound on that side, but if there are two terms, both terms must be for the same field.

public RangeQuery(
Term lowerTerm,
Term upperTerm,
bool inclusive
);

Parameters

lowerTerm
term at the lower end of the range
upperTerm
term at the upper end of the range
inclusive
if true, both lowerTerm and upperTerm will be included in the range

See Also

RangeQuery Class | Lucene.Net.Search Namespace | RangeQuery Constructor Overload List


RangeQuery Constructor (Term, Term, Boolean, CompareInfo)

public RangeQuery(
Term lowerTerm,
Term upperTerm,
bool inclusive,
CompareInfo collator
);

See Also

RangeQuery Class | Lucene.Net.Search Namespace | RangeQuery Constructor Overload List


RangeQuery Methods

The methods of the RangeQuery class are listed below. For a complete list of RangeQuery class members, see the RangeQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true iff
o
is equal to this.
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetCollator | Returns the collator used to determine range inclusion, if any.
GetField | Returns the field name for this query
GetHashCode | Returns a hash code value for this object.
GetLowerTerm | Returns the lower term of this range query
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUpperTerm | Returns the upper term of this range query
IsInclusive Returns
true
if the range query is inclusive
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)

See Also

RangeQuery Class | Lucene.Net.Search Namespace | ConstantScoreRangeQuery


RangeQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.GetCollator Method

Returns the collator used to determine range inclusion, if any.

public CompareInfo GetCollator();

Return Value

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.GetField Method

Returns the field name for this query

public virtual string GetField();

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.GetLowerTerm Method

Returns the lower term of this range query

public virtual Term GetLowerTerm();

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.GetUpperTerm Method

Returns the upper term of this range query

public virtual Term GetUpperTerm();

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.IsInclusive Method

Returns

true
if the range query is inclusive

public virtual bool IsInclusive();

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

RangeQuery Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

RangeQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

RangeQuery Class | Lucene.Net.Search Namespace


RangeQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string field
);

See Also

RangeQuery Class | Lucene.Net.Search Namespace | RangeQuery.ToString Overload List


RemoteCachingWrapperFilter Class

Provides caching of {@link Filter}s themselves on the remote end of an RMI connection. The cache is keyed on Filter's hashCode(), so if it sees the same filter twice it will reuse the original version.

NOTE: This does NOT cache the Filter bits, but rather the Filter itself. Thus, this works hand-in-hand with {@link CachingWrapperFilter} to keep both file Filter cache and the Filter bits on the remote end, close to the searcher.

Usage:

To cache a result you must do something like RemoteCachingWrapperFilter f = new RemoteCachingWrapperFilter(new CachingWrapperFilter(myFilter));

For a list of all members of this type, see RemoteCachingWrapperFilter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.RemoteCachingWrapperFilter

public class RemoteCachingWrapperFilter : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RemoteCachingWrapperFilter Members | Lucene.Net.Search Namespace


RemoteCachingWrapperFilter Members

RemoteCachingWrapperFilter overview

Public Instance Constructors

RemoteCachingWrapperFilter Constructor

Public Instance Methods

Bits | Obsolete. Uses the {@link FilterManager} to keep the cache for a filter on the searcher side of a remote connection.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDocIdSet | Uses the {@link FilterManager} to keep the cache for a filter on the searcher side of a remote connection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

filter

See Also

RemoteCachingWrapperFilter Class | Lucene.Net.Search Namespace


RemoteCachingWrapperFilter Constructor

public RemoteCachingWrapperFilter(
Filter filter
);

See Also

RemoteCachingWrapperFilter Class | Lucene.Net.Search Namespace


RemoteCachingWrapperFilter Fields

The fields of the RemoteCachingWrapperFilter class are listed below. For a complete list of RemoteCachingWrapperFilter class members, see the RemoteCachingWrapperFilter Members topic.

Protected Internal Instance Fields

filter

See Also

RemoteCachingWrapperFilter Class | Lucene.Net.Search Namespace


RemoteCachingWrapperFilter.filter Field

protected internal Filter filter;

See Also

RemoteCachingWrapperFilter Class | Lucene.Net.Search Namespace


RemoteCachingWrapperFilter Methods

The methods of the RemoteCachingWrapperFilter class are listed below. For a complete list of RemoteCachingWrapperFilter class members, see the RemoteCachingWrapperFilter Members topic.

Public Instance Methods

Bits | Obsolete. Uses the {@link FilterManager} to keep the cache for a filter on the searcher side of a remote connection.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDocIdSet | Uses the {@link FilterManager} to keep the cache for a filter on the searcher side of a remote connection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteCachingWrapperFilter Class | Lucene.Net.Search Namespace


RemoteCachingWrapperFilter.Bits Method

NOTE: This method is now obsolete.

Use GetDocIdSet(IndexReader) instead.

Uses the {@link FilterManager} to keep the cache for a filter on the searcher side of a remote connection.

public override BitArray Bits(
IndexReader reader
);

Parameters

reader
the index reader for the Filter

Return Value

the bitset

See Also

RemoteCachingWrapperFilter Class | Lucene.Net.Search Namespace


RemoteCachingWrapperFilter.GetDocIdSet Method

Uses the {@link FilterManager} to keep the cache for a filter on the searcher side of a remote connection.

public override DocIdSet GetDocIdSet(
IndexReader reader
);

Parameters

reader
the index reader for the Filter

Return Value

the DocIdSet

See Also

RemoteCachingWrapperFilter Class | Lucene.Net.Search Namespace


RemoteSearchable Class

A remote searchable implementation.

For a list of all members of this type, see RemoteSearchable Members.

System.Object
System.MarshalByRefObject
Lucene.Net.Search.RemoteSearchable

public class RemoteSearchable : MarshalByRefObject, Searchable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RemoteSearchable Members | Lucene.Net.Search Namespace


RemoteSearchable Members

RemoteSearchable overview

Public Static Methods

Main Exports a searcher for the index in args[0] named "//localhost/Searchable".

Public Instance Constructors

RemoteSearchable Constructor Constructs and exports a remote searcher.

Public Instance Methods

Close |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Doc | Overloaded.
DocFreq |
DocFreqs |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MaxDoc |
Rewrite |
Search | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable Constructor

Constructs and exports a remote searcher.

public RemoteSearchable(
Searchable local
);

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable Methods

The methods of the RemoteSearchable class are listed below. For a complete list of RemoteSearchable class members, see the RemoteSearchable Members topic.

Public Static Methods

Main Exports a searcher for the index in args[0] named "//localhost/Searchable".

Public Instance Methods

Close |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Doc | Overloaded.
DocFreq |
DocFreqs |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MaxDoc |
Rewrite |
Search | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.Close Method

public virtual void Close();

Implements

Searchable.Close

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


Doc Method

Apache Lucene.Net 2.4.0 Class Library API

RemoteSearchable.Doc Method

Overload List

public virtual Document Doc(int);

public virtual Document Doc(int,FieldSelector);

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.Doc Method (Int32)

public virtual Document Doc(
int i
);

Implements

Searchable.Doc

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace | RemoteSearchable.Doc Overload List


RemoteSearchable.Doc Method (Int32, FieldSelector)

public virtual Document Doc(
int i,
FieldSelector fieldSelector
);

Implements

Searchable.Doc

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace | RemoteSearchable.Doc Overload List


RemoteSearchable.DocFreq Method

public virtual int DocFreq(
Term term
);

Implements

Searchable.DocFreq

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.DocFreqs Method

public virtual int[] DocFreqs(
Term[] terms
);

Implements

Searchable.DocFreqs

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.Explain Method

public virtual Explanation Explain(
Weight weight,
int doc
);

Implements

Searchable.Explain

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.Main Method

Exports a searcher for the index in args[0] named "//localhost/Searchable".

public static void Main(
string[] args
);

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.MaxDoc Method

public virtual int MaxDoc();

Implements

Searchable.MaxDoc

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.Rewrite Method

public virtual Query Rewrite(
Query original
);

Implements

Searchable.Rewrite

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


Search Method

Apache Lucene.Net 2.4.0 Class Library API

RemoteSearchable.Search Method

Overload List

public virtual void Search(Weight,Filter,HitCollector);

public virtual TopDocs Search(Weight,Filter,int);

public virtual TopFieldDocs Search(Weight,Filter,int,Sort);

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace


RemoteSearchable.Search Method (Weight, Filter, HitCollector)

public virtual void Search(
Weight weight,
Filter filter,
HitCollector results
);

Implements

Searchable.Search

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace | RemoteSearchable.Search Overload List


RemoteSearchable.Search Method (Weight, Filter, Int32)

public virtual TopDocs Search(
Weight weight,
Filter filter,
int n
);

Implements

Searchable.Search

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace | RemoteSearchable.Search Overload List


RemoteSearchable.Search Method (Weight, Filter, Int32, Sort)

public virtual TopFieldDocs Search(
Weight weight,
Filter filter,
int n,
Sort sort
);

Implements

Searchable.Search

See Also

RemoteSearchable Class | Lucene.Net.Search Namespace | RemoteSearchable.Search Overload List


ReqExclScorer Class

For a list of all members of this type, see ReqExclScorer Members.

System.Object
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Search.Scorer
Lucene.Net.Search.ReqExclScorer

public class ReqExclScorer : Scorer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ReqExclScorer Members | Lucene.Net.Search Namespace


ReqExclScorer Members

ReqExclScorer overview

Public Instance Constructors

ReqExclScorer Constructor Construct a
ReqExclScorer
.

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Scorer) | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Score | Overloaded. Returns the score of the current document matching the query. Initially invalid, until {@link #next()} is called the first time.
Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Score (inherited from Scorer) Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.

See Also

ReqExclScorer Class | Lucene.Net.Search Namespace


ReqExclScorer Constructor

Construct a

ReqExclScorer
.

public ReqExclScorer(
Scorer reqScorer,
Scorer exclScorer
);

Parameters

reqScorer
The scorer that must match, except where
exclScorer
indicates exclusion.

See Also

ReqExclScorer Class | Lucene.Net.Search Namespace


ReqExclScorer Methods

The methods of the ReqExclScorer class are listed below. For a complete list of ReqExclScorer class members, see the ReqExclScorer Members topic.

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Scorer) | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Score | Overloaded. Returns the score of the current document matching the query. Initially invalid, until {@link #next()} is called the first time.
Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Score (inherited from Scorer) Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.

See Also

ReqExclScorer Class | Lucene.Net.Search Namespace


ReqExclScorer.Doc Method

public override int Doc();

See Also

ReqExclScorer Class | Lucene.Net.Search Namespace


ReqExclScorer.Explain Method

public override Explanation Explain(
int doc
);

See Also

ReqExclScorer Class | Lucene.Net.Search Namespace


ReqExclScorer.Next Method

public override bool Next();

See Also

ReqExclScorer Class | Lucene.Net.Search Namespace


Score Method

Apache Lucene.Net 2.4.0 Class Library API

ReqExclScorer.Score Method

Returns the score of the current document matching the query. Initially invalid, until {@link #next()} is called the first time.

Overload List

Returns the score of the current document matching the query. Initially invalid, until {@link #next()} is called the first time.

public override float Score();

Inherited from Scorer.

public virtual void Score(HitCollector);

Inherited from Scorer.

protected internal virtual bool Score(HitCollector,int);

See Also

ReqExclScorer Class | Lucene.Net.Search Namespace


ReqExclScorer.Score Method ()

Returns the score of the current document matching the query. Initially invalid, until {@link #next()} is called the first time.

public override float Score();

Return Value

The score of the required scorer.

See Also

ReqExclScorer Class | Lucene.Net.Search Namespace | ReqExclScorer.Score Overload List


ReqExclScorer.SkipTo Method

public override bool SkipTo(
int target
);

See Also

ReqExclScorer Class | Lucene.Net.Search Namespace


ReqOptSumScorer Class

For a list of all members of this type, see ReqOptSumScorer Members.

System.Object
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Search.Scorer
Lucene.Net.Search.ReqOptSumScorer

public class ReqOptSumScorer : Scorer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ReqOptSumScorer Members | Lucene.Net.Search Namespace


ReqOptSumScorer Members

ReqOptSumScorer overview

Public Instance Constructors

ReqOptSumScorer Constructor Construct a
ReqOptScorer
.

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain | Explain the score of a document.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Scorer) | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Score | Overloaded. Returns the score of the current document matching the query. Initially invalid, until {@link #next()} is called the first time.
Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Score (inherited from Scorer) Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.

See Also

ReqOptSumScorer Class | Lucene.Net.Search Namespace


ReqOptSumScorer Constructor

Construct a

ReqOptScorer
.

public ReqOptSumScorer(
Scorer reqScorer,
Scorer optScorer
);

Parameters

reqScorer
The required scorer. This must match.
optScorer
The optional scorer. This is used for scoring only.

See Also

ReqOptSumScorer Class | Lucene.Net.Search Namespace


ReqOptSumScorer Methods

The methods of the ReqOptSumScorer class are listed below. For a complete list of ReqOptSumScorer class members, see the ReqOptSumScorer Members topic.

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain | Explain the score of a document.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Scorer) | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Score | Overloaded. Returns the score of the current document matching the query. Initially invalid, until {@link #next()} is called the first time.
Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Score (inherited from Scorer) Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.

See Also

ReqOptSumScorer Class | Lucene.Net.Search Namespace


ReqOptSumScorer.Doc Method

public override int Doc();

See Also

ReqOptSumScorer Class | Lucene.Net.Search Namespace


ReqOptSumScorer.Explain Method

Explain the score of a document.

public override Explanation Explain(
int doc
);

See Also

ReqOptSumScorer Class | Lucene.Net.Search Namespace


ReqOptSumScorer.Next Method

public override bool Next();

See Also

ReqOptSumScorer Class | Lucene.Net.Search Namespace


Score Method

Apache Lucene.Net 2.4.0 Class Library API

ReqOptSumScorer.Score Method

Returns the score of the current document matching the query. Initially invalid, until {@link #next()} is called the first time.

Overload List

Returns the score of the current document matching the query. Initially invalid, until {@link #next()} is called the first time.

public override float Score();

Inherited from Scorer.

public virtual void Score(HitCollector);

Inherited from Scorer.

protected internal virtual bool Score(HitCollector,int);

See Also

ReqOptSumScorer Class | Lucene.Net.Search Namespace


ReqOptSumScorer.Score Method ()

Returns the score of the current document matching the query. Initially invalid, until {@link #next()} is called the first time.

public override float Score();

Return Value

The score of the required scorer, eventually increased by the score of the optional scorer when it also matches the current document.

See Also

ReqOptSumScorer Class | Lucene.Net.Search Namespace | ReqOptSumScorer.Score Overload List


ReqOptSumScorer.SkipTo Method

public override bool SkipTo(
int target
);

See Also

ReqOptSumScorer Class | Lucene.Net.Search Namespace


ScoreDoc Class

Expert: Returned by low-level search implementations.

For a list of all members of this type, see ScoreDoc Members.

System.Object
Lucene.Net.Search.ScoreDoc
Lucene.Net.Search.FieldDoc

public class ScoreDoc

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ScoreDoc Members | Lucene.Net.Search Namespace |


ScoreDoc Members

ScoreDoc overview

Public Instance Constructors

ScoreDoc Constructor Expert: Constructs a ScoreDoc.

Public Instance Fields

doc | Expert: A hit document's number.
score | Expert: The score of this document for the query.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScoreDoc Class | Lucene.Net.Search Namespace |


ScoreDoc Constructor

Expert: Constructs a ScoreDoc.

public ScoreDoc(
int doc,
float score
);

See Also

ScoreDoc Class | Lucene.Net.Search Namespace


ScoreDoc Fields

The fields of the ScoreDoc class are listed below. For a complete list of ScoreDoc class members, see the ScoreDoc Members topic.

Public Instance Fields

doc | Expert: A hit document's number.
score | Expert: The score of this document for the query.

See Also

ScoreDoc Class | Lucene.Net.Search Namespace |


ScoreDoc.doc Field

Expert: A hit document's number.

public int doc;

See Also

ScoreDoc Class | Lucene.Net.Search Namespace | Searcher#Doc


ScoreDoc.score Field

Expert: The score of this document for the query.

public float score;

See Also

ScoreDoc Class | Lucene.Net.Search Namespace


ScoreDocComparator Interface

For a list of all members of this type, see ScoreDocComparator Members.

public interface ScoreDocComparator

Types that implement ScoreDocComparator

Type | Description
AnonymousClassScoreDocComparator |
AnonymousClassScoreDocComparator1 |

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ScoreDocComparator Members | Lucene.Net.Search Namespace


ScoreDocComparator Members

ScoreDocComparator overview

Public Instance Methods

Compare
SortType Returns the type of sort. Should return
SortField.SCORE
,
SortField.DOC
,
SortField.STRING
,
SortField.INTEGER
,
SortField.FLOAT
or
SortField.CUSTOM
. It is not valid to return
SortField.AUTO
. This is used by multisearchers to determine how to collate results from their searchers.
SortValue Returns the value used to sort the given document. The object returned must implement the java.io.Serializable interface. This is used by multisearchers to determine how to collate results from their searchers.

See Also

ScoreDocComparator Interface | Lucene.Net.Search Namespace


ScoreDocComparator Methods

The methods of the ScoreDocComparator interface are listed below. For a complete list of ScoreDocComparator interface members, see the ScoreDocComparator Members topic.

Public Instance Methods

Compare
SortType Returns the type of sort. Should return
SortField.SCORE
,
SortField.DOC
,
SortField.STRING
,
SortField.INTEGER
,
SortField.FLOAT
or
SortField.CUSTOM
. It is not valid to return
SortField.AUTO
. This is used by multisearchers to determine how to collate results from their searchers.
SortValue Returns the value used to sort the given document. The object returned must implement the java.io.Serializable interface. This is used by multisearchers to determine how to collate results from their searchers.

See Also

ScoreDocComparator Interface | Lucene.Net.Search Namespace


ScoreDocComparator.Compare Method

int Compare(
ScoreDoc i,
ScoreDoc j
);

See Also

ScoreDocComparator Interface | Lucene.Net.Search Namespace


ScoreDocComparator.SortType Method

Returns the type of sort. Should return

SortField.SCORE
,
SortField.DOC
,
SortField.STRING
,
SortField.INTEGER
,
SortField.FLOAT
or
SortField.CUSTOM
. It is not valid to return
SortField.AUTO
. This is used by multisearchers to determine how to collate results from their searchers.

int SortType();

Return Value

One of the constants in SortField.

See Also

ScoreDocComparator Interface | Lucene.Net.Search Namespace |


ScoreDocComparator.SortValue Method

Returns the value used to sort the given document. The object returned must implement the java.io.Serializable interface. This is used by multisearchers to determine how to collate results from their searchers.

IComparable SortValue(
ScoreDoc i
);

Parameters

i
Document

Return Value

Serializable object

See Also

ScoreDocComparator Interface | Lucene.Net.Search Namespace |


ScoreDocComparator_Fields Structure

Expert: Compares two ScoreDoc objects for sorting.

For a list of all members of this type, see ScoreDocComparator_Fields Members.

System.Object
System.ValueType
Lucene.Net.Search.ScoreDocComparator_Fields

public struct ScoreDocComparator_Fields

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ScoreDocComparator_Fields Members | Lucene.Net.Search Namespace


ScoreDocComparator_Fields Members

ScoreDocComparator_Fields overview

Public Static Fields

INDEXORDER | Special comparator for sorting hits according to index order (document number).
RELEVANCE | Special comparator for sorting hits according to computed relevance (document score).

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ScoreDocComparator_Fields Class | Lucene.Net.Search Namespace


ScoreDocComparator_Fields Fields

The fields of the ScoreDocComparator_Fields structure are listed below. For a complete list of ScoreDocComparator_Fields structure members, see the ScoreDocComparator_Fields Members topic.

Public Static Fields

INDEXORDER | Special comparator for sorting hits according to index order (document number).
RELEVANCE | Special comparator for sorting hits according to computed relevance (document score).

See Also

ScoreDocComparator_Fields Class | Lucene.Net.Search Namespace


ScoreDocComparator_Fields.INDEXORDER Field

Special comparator for sorting hits according to index order (document number).

public static readonly ScoreDocComparator INDEXORDER;

See Also

ScoreDocComparator_Fields Class | Lucene.Net.Search Namespace


ScoreDocComparator_Fields.RELEVANCE Field

Special comparator for sorting hits according to computed relevance (document score).

public static readonly ScoreDocComparator RELEVANCE;

See Also

ScoreDocComparator_Fields Class | Lucene.Net.Search Namespace


Scorer Class

Expert: Common scoring functionality for different types of queries.

A

Scorer
either iterates over documents matching a query in increasing order of doc Id, or provides an explanation of the score for a query for a given document.

Document scores are computed using a given

Similarity
implementation.

For a list of all members of this type, see Scorer Members.

System.Object
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Search.Scorer
Lucene.Net.Search.ConstantScoreQuery.ConstantScorer
Lucene.Net.Search.ReqExclScorer
Lucene.Net.Search.ReqOptSumScorer
Lucene.Net.Search.Spans.SpanScorer
Lucene.Net.Search.TermScorer

public abstract class Scorer : DocIdSetIterator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Scorer Members | Lucene.Net.Search Namespace | setAllowDocsOutOfOrder


Scorer Members

Scorer overview

Public Instance Methods

Doc (inherited from DocIdSetIterator) | Returns the current document number. This is invalid until Next() is called for the first time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from DocIdSetIterator) | Moves to the next docId in the set. Returns true, iff there is such a docId.
Score | Overloaded.
SkipTo (inherited from DocIdSetIterator) Skips entries to the first beyond the current whose document number is greater than or equal to target. Returns true iff there is such an entry. Behaves as if written:
 boolean skipTo(int target) { do { if (!next()) return false; } while (target > doc()); return true; }
Some implementations are considerably more efficient than that.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

Scorer Constructor Constructs a Scorer.

Protected Internal Instance Methods

Score Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.

See Also

Scorer Class | Lucene.Net.Search Namespace | setAllowDocsOutOfOrder


Scorer Constructor

Constructs a Scorer.

protected internal Scorer(
Similarity similarity
);

Parameters

similarity
The
Similarity
implementation used by this scorer.

See Also

Scorer Class | Lucene.Net.Search Namespace


Scorer Methods

The methods of the Scorer class are listed below. For a complete list of Scorer class members, see the Scorer Members topic.

Public Instance Methods

Doc (inherited from DocIdSetIterator) | Returns the current document number. This is invalid until Next() is called for the first time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from DocIdSetIterator) | Moves to the next docId in the set. Returns true, iff there is such a docId.
Score | Overloaded.
SkipTo (inherited from DocIdSetIterator) Skips entries to the first beyond the current whose document number is greater than or equal to target. Returns true iff there is such an entry. Behaves as if written:
 boolean skipTo(int target) { do { if (!next()) return false; } while (target > doc()); return true; }
Some implementations are considerably more efficient than that.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Score Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.

See Also

Scorer Class | Lucene.Net.Search Namespace | setAllowDocsOutOfOrder


Scorer.Explain Method

public abstract Explanation Explain(
int doc
);

See Also

Scorer Class | Lucene.Net.Search Namespace


Scorer.GetSimilarity Method

Returns the Similarity implementation used by this scorer.

public virtual Similarity GetSimilarity();

See Also

Scorer Class | Lucene.Net.Search Namespace


Score Method

Apache Lucene.Net 2.4.0 Class Library API

Scorer.Score Method

Returns the score of the current document matching the query. Initially invalid, until {@link #Next()} or {@link #SkipTo(int)} is called the first time.

Overload List

Returns the score of the current document matching the query. Initially invalid, until {@link #Next()} or {@link #SkipTo(int)} is called the first time.

public abstract float Score();

public virtual void Score(HitCollector);

Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.

protected internal virtual bool Score(HitCollector,int);

See Also

Scorer Class | Lucene.Net.Search Namespace


Scorer.Score Method ()

Returns the score of the current document matching the query. Initially invalid, until {@link #Next()} or {@link #SkipTo(int)} is called the first time.

public abstract float Score();

See Also

Scorer Class | Lucene.Net.Search Namespace | Scorer.Score Overload List


Scorer.Score Method (HitCollector)

public virtual void Score(
HitCollector hc
);

See Also

Scorer Class | Lucene.Net.Search Namespace | Scorer.Score Overload List


Scorer.Score Method (HitCollector, Int32)

Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.

protected internal virtual bool Score(
HitCollector hc,
int max
);

Parameters

hc
The collector to which all matching documents are passed through {@link HitCollector#Collect(int, float)}.
max
Do not score documents past this.

Return Value

true if more matching documents may remain.

See Also

Scorer Class | Lucene.Net.Search Namespace | Scorer.Score Overload List


Searchable Interface

For a list of all members of this type, see Searchable Members.

public interface Searchable

Types that implement Searchable

Type | Description
IndexSearcher |
MultiSearcher |
ParallelMultiSearcher |
RemoteSearchable | A remote searchable implementation.
Searcher |

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Searchable Members | Lucene.Net.Search Namespace


Searchable Members

Searchable overview

Public Instance Methods

Close | Frees resources associated with this Searcher. Be careful not to call this method while you are still using objects like {@link Hits}.
Doc Overloaded. Expert: Returns the stored fields of document
i
. Called by {@link HitCollector} implementations.
DocFreq Expert: Returns the number of documents containing
term
. Called by search code to compute term weights.
DocFreqs Expert: For each term in the terms array, calculates the number of documents containing
term
. Returns an array with these document frequencies. Used to minimize number of remote calls.
Explain
MaxDoc | Expert: Returns one greater than the largest possible document number. Called by search code to compute term weights.
Rewrite | Expert: called to re-write queries into primitive queries.
Search | Overloaded.

See Also

Searchable Interface | Lucene.Net.Search Namespace


Searchable Methods

The methods of the Searchable interface are listed below. For a complete list of Searchable interface members, see the Searchable Members topic.

Public Instance Methods

Close | Frees resources associated with this Searcher. Be careful not to call this method while you are still using objects like {@link Hits}.
Doc Overloaded. Expert: Returns the stored fields of document
i
. Called by {@link HitCollector} implementations.
DocFreq Expert: Returns the number of documents containing
term
. Called by search code to compute term weights.
DocFreqs Expert: For each term in the terms array, calculates the number of documents containing
term
. Returns an array with these document frequencies. Used to minimize number of remote calls.
Explain
MaxDoc | Expert: Returns one greater than the largest possible document number. Called by search code to compute term weights.
Rewrite | Expert: called to re-write queries into primitive queries.
Search | Overloaded.

See Also

Searchable Interface | Lucene.Net.Search Namespace


Searchable.Close Method

Frees resources associated with this Searcher. Be careful not to call this method while you are still using objects like {@link Hits}.

void Close();

See Also

Searchable Interface | Lucene.Net.Search Namespace


Doc Method

Apache Lucene.Net 2.4.0 Class Library API

Searchable.Doc Method

Expert: Returns the stored fields of document

i
. Called by {@link HitCollector} implementations.

Overload List

Expert: Returns the stored fields of document

i
. Called by {@link HitCollector} implementations.

Document Doc(int);

Get the {@link Lucene.Net.Documents.Document} at the

n
th position. The {@link Lucene.Net.Documents.FieldSelector} may be used to determine what {@link Lucene.Net.Documents.Field}s to load and how they should be loaded. NOTE: If the underlying Reader (more specifically, the underlying
FieldsReader
) is closed before the lazy {@link Lucene.Net.Documents.Field} is loaded an exception may be thrown. If you want the value of a lazy {@link Lucene.Net.Documents.Field} to be available after closing you must explicitly load it or fetch the Document again with a new loader.

Document Doc(int,FieldSelector);

See Also

Searchable Interface | Lucene.Net.Search Namespace |


Searchable.Doc Method (Int32)

Expert: Returns the stored fields of document

i
. Called by {@link HitCollector} implementations.

Document Doc(
int i
);

See Also

Searchable Interface | Lucene.Net.Search Namespace | Searchable.Doc Overload List |


Searchable.Doc Method (Int32, FieldSelector)

Get the {@link Lucene.Net.Documents.Document} at the

n
th position. The {@link Lucene.Net.Documents.FieldSelector} may be used to determine what {@link Lucene.Net.Documents.Field}s to load and how they should be loaded. NOTE: If the underlying Reader (more specifically, the underlying
FieldsReader
) is closed before the lazy {@link Lucene.Net.Documents.Field} is loaded an exception may be thrown. If you want the value of a lazy {@link Lucene.Net.Documents.Field} to be available after closing you must explicitly load it or fetch the Document again with a new loader.

Document Doc(
int n,
FieldSelector fieldSelector
);

Parameters

n
Get the document at the
n
th position
fieldSelector
The {@link Lucene.Net.Documents.FieldSelector} to use to determine what Fields should be loaded on the Document. May be null, in which case all Fields will be loaded.

Return Value

The stored fields of the {@link Lucene.Net.Documents.Document} at the nth position

See Also

Searchable Interface | Lucene.Net.Search Namespace | Searchable.Doc Overload List | | | | |


Searchable.DocFreq Method

Expert: Returns the number of documents containing

term
. Called by search code to compute term weights.

int DocFreq(
Term term
);

See Also

Searchable Interface | Lucene.Net.Search Namespace |


Searchable.DocFreqs Method

Expert: For each term in the terms array, calculates the number of documents containing

term
. Returns an array with these document frequencies. Used to minimize number of remote calls.

int[] DocFreqs(
Term[] terms
);

See Also

Searchable Interface | Lucene.Net.Search Namespace


Searchable.Explain Method

Explanation Explain(
Weight weight,
int doc
);

See Also

Searchable Interface | Lucene.Net.Search Namespace


Searchable.MaxDoc Method

Expert: Returns one greater than the largest possible document number. Called by search code to compute term weights.

int MaxDoc();

See Also

Searchable Interface | Lucene.Net.Search Namespace |


Searchable.Rewrite Method

Expert: called to re-write queries into primitive queries.

Query Rewrite(
Query query
);

See Also

Searchable Interface | Lucene.Net.Search Namespace


Search Method

Apache Lucene.Net 2.4.0 Class Library API

Searchable.Search Method

Overload List

void Search(Weight,Filter,HitCollector);

TopDocs Search(Weight,Filter,int);

TopFieldDocs Search(Weight,Filter,int,Sort);

See Also

Searchable Interface | Lucene.Net.Search Namespace


Searchable.Search Method (Weight, Filter, HitCollector)

void Search(
Weight weight,
Filter filter,
HitCollector results
);

See Also

Searchable Interface | Lucene.Net.Search Namespace | Searchable.Search Overload List


Searchable.Search Method (Weight, Filter, Int32)

TopDocs Search(
Weight weight,
Filter filter,
int n
);

See Also

Searchable Interface | Lucene.Net.Search Namespace | Searchable.Search Overload List


Searchable.Search Method (Weight, Filter, Int32, Sort)

TopFieldDocs Search(
Weight weight,
Filter filter,
int n,
Sort sort
);

See Also

Searchable Interface | Lucene.Net.Search Namespace | Searchable.Search Overload List


Searcher Class

For a list of all members of this type, see Searcher Members.

System.Object
Lucene.Net.Search.Searcher
Lucene.Net.Search.IndexSearcher
Lucene.Net.Search.MultiSearcher

public abstract class Searcher : Searchable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Searcher Members | Lucene.Net.Search Namespace


Searcher Members

Searcher overview

Public Instance Constructors

Searcher Constructor Initializes a new instance of the Searcher class.

Public Instance Methods

Close
Doc | Overloaded.
DocFreq
DocFreqs
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc
Rewrite
Search Overloaded. Returns the documents matching
query
.
SetSimilarity | Expert: Set the Similarity implementation used by this Searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight creates a weight for
query

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher Constructor

Initializes a new instance of the Searcher class.

public Searcher();

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher Methods

The methods of the Searcher class are listed below. For a complete list of Searcher class members, see the Searcher Members topic.

Public Instance Methods

Close
Doc | Overloaded.
DocFreq
DocFreqs
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity
GetType (inherited from Object) | Gets the Type of the current instance.
MaxDoc
Rewrite
Search Overloaded. Returns the documents matching
query
.
SetSimilarity | Expert: Set the Similarity implementation used by this Searcher.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight creates a weight for
query

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.Close Method

public abstract void Close();

Implements

Searchable.Close

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.CreateWeight Method

creates a weight for

query

protected internal virtual Weight CreateWeight(
Query query
);

Return Value

new weight

See Also

Searcher Class | Lucene.Net.Search Namespace


Doc Method

Apache Lucene.Net 2.4.0 Class Library API

Searcher.Doc Method

Overload List

public abstract Document Doc(int);

public abstract Document Doc(int,FieldSelector);

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.Doc Method (Int32)

public abstract Document Doc(
int i
);

Implements

Searchable.Doc

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Doc Overload List


Searcher.Doc Method (Int32, FieldSelector)

public abstract Document Doc(
int param1,
FieldSelector param2
);

Implements

Searchable.Doc

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Doc Overload List


Searcher.DocFreq Method

public abstract int DocFreq(
Term term
);

Implements

Searchable.DocFreq

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.DocFreqs Method

public virtual int[] DocFreqs(
Term[] terms
);

Implements

Searchable.DocFreqs

See Also

Searcher Class | Lucene.Net.Search Namespace


Explain Method

Apache Lucene.Net 2.4.0 Class Library API

Searcher.Explain Method

Overload List

public virtual Explanation Explain(Query,int);

public abstract Explanation Explain(Weight,int);

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.Explain Method (Query, Int32)

public virtual Explanation Explain(
Query query,
int doc
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Explain Overload List


Searcher.Explain Method (Weight, Int32)

public abstract Explanation Explain(
Weight weight,
int doc
);

Implements

Searchable.Explain

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Explain Overload List


Searcher.GetSimilarity Method

public virtual Similarity GetSimilarity();

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.MaxDoc Method

public abstract int MaxDoc();

Implements

Searchable.MaxDoc

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.Rewrite Method

public abstract Query Rewrite(
Query query
);

Implements

Searchable.Rewrite

See Also

Searcher Class | Lucene.Net.Search Namespace


Search Method

Apache Lucene.Net 2.4.0 Class Library API

Searcher.Search Method

NOTE: This method is now obsolete.

Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int) instead.

Returns the documents matching

query
.

Overload List

Obsolete. Returns the documents matching

query
.

public Hits Search(Query);

Obsolete. Returns the documents matching

query
and
filter
.

public virtual Hits Search(Query,Filter);

public virtual void Search(Query,Filter,HitCollector);

Obsolete. Returns documents matching

query
and
filter
, sorted by
sort
.

public virtual Hits Search(Query,Filter,Sort);

Finds the top

n
hits for
query
, applying
filter
if non-null.

public virtual TopDocs Search(Query,Filter,int);

public virtual TopFieldDocs Search(Query,Filter,int,Sort);

public virtual void Search(Query,HitCollector);

Obsolete. Returns documents matching

query
sorted by
sort
.

public virtual Hits Search(Query,Sort);

Finds the top

n
hits for
query
, applying
filter
if non-null.

public virtual TopDocs Search(Query,int);

public abstract void Search(Weight,Filter,HitCollector);

public abstract TopDocs Search(Weight,Filter,int);

public abstract TopFieldDocs Search(Weight,Filter,int,Sort);

See Also

Searcher Class | Lucene.Net.Search Namespace


Searcher.Search Method (Query)

NOTE: This method is now obsolete.

Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int) instead.

Returns the documents matching

query
.

public Hits Search(
Query query
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Filter)

NOTE: This method is now obsolete.

Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int) instead.

Returns the documents matching

query
and
filter
.

public virtual Hits Search(
Query query,
Filter filter
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Filter, HitCollector)

public virtual void Search(
Query query,
Filter filter,
HitCollector results
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Filter, Sort)

NOTE: This method is now obsolete.

Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int, Sort) instead.

Returns documents matching

query
and
filter
, sorted by
sort
.

public virtual Hits Search(
Query query,
Filter filter,
Sort sort
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Filter, Int32)

Finds the top

n
hits for
query
, applying
filter
if non-null.

public virtual TopDocs Search(
Query query,
Filter filter,
int n
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Filter, Int32, Sort)

public virtual TopFieldDocs Search(
Query query,
Filter filter,
int n,
Sort sort
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, HitCollector)

public virtual void Search(
Query query,
HitCollector results
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Sort)

NOTE: This method is now obsolete.

Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int, Sort) instead.

Returns documents matching

query
sorted by
sort
.

public virtual Hits Search(
Query query,
Sort sort
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Query, Int32)

Finds the top

n
hits for
query
, applying
filter
if non-null.

public virtual TopDocs Search(
Query query,
int n
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Weight, Filter, HitCollector)

public abstract void Search(
Weight weight,
Filter filter,
HitCollector results
);

Implements

Searchable.Search

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Weight, Filter, Int32)

public abstract TopDocs Search(
Weight weight,
Filter filter,
int n
);

Implements

Searchable.Search

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.Search Method (Weight, Filter, Int32, Sort)

public abstract TopFieldDocs Search(
Weight weight,
Filter filter,
int n,
Sort sort
);

Implements

Searchable.Search

See Also

Searcher Class | Lucene.Net.Search Namespace | Searcher.Search Overload List


Searcher.SetSimilarity Method

Expert: Set the Similarity implementation used by this Searcher.

public virtual void SetSimilarity(
Similarity similarity
);

See Also

Searcher Class | Lucene.Net.Search Namespace | Similarity#SetDefault


ShortParser Interface

Interface to parse shorts from document fields.

For a list of all members of this type, see ShortParser Members.

public interface ShortParser

Types that implement ShortParser

Type | Description
FieldCacheImpl.AnonymousClassShortParser |

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ShortParser Members | Lucene.Net.Search Namespace | GetShorts


ShortParser Members

ShortParser overview

Public Instance Methods

ParseShort Return a short representation of this field's value.

See Also

ShortParser Interface | Lucene.Net.Search Namespace | GetShorts


ShortParser Methods

The methods of the ShortParser interface are listed below. For a complete list of ShortParser interface members, see the ShortParser Members topic.

Public Instance Methods

ParseShort Return a short representation of this field's value.

See Also

ShortParser Interface | Lucene.Net.Search Namespace | GetShorts


ShortParser.ParseShort Method

Return a short representation of this field's value.

short ParseShort(
string string_Renamed
);

See Also

ShortParser Interface | Lucene.Net.Search Namespace


Similarity Class

For a list of all members of this type, see Similarity Members.

System.Object
Lucene.Net.Search.Similarity
Lucene.Net.Search.DefaultSimilarity
Lucene.Net.Search.SimilarityDelegator

public abstract class Similarity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Similarity Members | Lucene.Net.Search Namespace


Similarity Members

Similarity overview

Public Static Methods

DecodeNorm | Decodes a normalization factor stored in an index.
EncodeNorm |
GetDefault |
GetNormDecoder | Returns a table for decoding normalization bytes.
SetDefault | Set the default Similarity implementation used by indexing and search code.

Public Instance Methods

Coord |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Idf | Overloaded.
LengthNorm |
QueryNorm |
ScorePayload |
SloppyFreq |
Tf | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Similarity Constructor Initializes a new instance of the Similarity class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity Constructor

Initializes a new instance of the Similarity class.

protected Similarity();

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity Methods

The methods of the Similarity class are listed below. For a complete list of Similarity class members, see the Similarity Members topic.

Public Static Methods

DecodeNorm | Decodes a normalization factor stored in an index.
EncodeNorm |
GetDefault |
GetNormDecoder | Returns a table for decoding normalization bytes.
SetDefault | Set the default Similarity implementation used by indexing and search code.

Public Instance Methods

Coord |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Idf | Overloaded.
LengthNorm |
QueryNorm |
ScorePayload |
SloppyFreq |
Tf | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.Coord Method

public abstract float Coord(
int overlap,
int maxOverlap
);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.DecodeNorm Method

Decodes a normalization factor stored in an index.

public static float DecodeNorm(
byte b
);

See Also

Similarity Class | Lucene.Net.Search Namespace | #EncodeNorm


Similarity.EncodeNorm Method

public static byte EncodeNorm(
float f
);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.GetDefault Method

public static Similarity GetDefault();

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.GetNormDecoder Method

Returns a table for decoding normalization bytes.

public static float[] GetNormDecoder();

See Also

Similarity Class | Lucene.Net.Search Namespace | #EncodeNorm


Idf Method

Apache Lucene.Net 2.4.0 Class Library API

Similarity.Idf Method

Overload List

public virtual float Idf(Term,Searcher);

public virtual float Idf(ICollection,Searcher);

public abstract float Idf(int,int);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.Idf Method (Term, Searcher)

public virtual float Idf(
Term term,
Searcher searcher
);

See Also

Similarity Class | Lucene.Net.Search Namespace | Similarity.Idf Overload List


Similarity.Idf Method (ICollection, Searcher)

public virtual float Idf(
ICollection terms,
Searcher searcher
);

See Also

Similarity Class | Lucene.Net.Search Namespace | Similarity.Idf Overload List


Similarity.Idf Method (Int32, Int32)

public abstract float Idf(
int docFreq,
int numDocs
);

See Also

Similarity Class | Lucene.Net.Search Namespace | Similarity.Idf Overload List


Similarity.LengthNorm Method

public abstract float LengthNorm(
string fieldName,
int numTokens
);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.QueryNorm Method

public abstract float QueryNorm(
float sumOfSquaredWeights
);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.ScorePayload Method

public virtual float ScorePayload(
string fieldName,
byte[] payload,
int offset,
int length
);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.SetDefault Method

Set the default Similarity implementation used by indexing and search code.

public static void SetDefault(
Similarity similarity
);

See Also

Similarity Class | Lucene.Net.Search Namespace | Searcher#SetSimilarity | IndexWriter#SetSimilarity


Similarity.SloppyFreq Method

public abstract float SloppyFreq(
int distance
);

See Also

Similarity Class | Lucene.Net.Search Namespace


Tf Method

Apache Lucene.Net 2.4.0 Class Library API

Similarity.Tf Method

Overload List

public virtual float Tf(int);

public abstract float Tf(float);

See Also

Similarity Class | Lucene.Net.Search Namespace


Similarity.Tf Method (Int32)

public virtual float Tf(
int freq
);

See Also

Similarity Class | Lucene.Net.Search Namespace | Similarity.Tf Overload List


Similarity.Tf Method (Single)

public abstract float Tf(
float freq
);

See Also

Similarity Class | Lucene.Net.Search Namespace | Similarity.Tf Overload List


SimilarityDelegator Class

Expert: Delegating scoring implementation. Useful in {@link Query#GetSimilarity(Searcher)} implementations, to override only certain methods of a Searcher's Similiarty implementation..

For a list of all members of this type, see SimilarityDelegator Members.

System.Object
Lucene.Net.Search.Similarity
Lucene.Net.Search.SimilarityDelegator

public class SimilarityDelegator : Similarity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SimilarityDelegator Members | Lucene.Net.Search Namespace


SimilarityDelegator Members

SimilarityDelegator overview

Public Instance Constructors

SimilarityDelegator Constructor Construct a {@link Similarity} that delegates all methods to another.

Public Instance Methods

Coord |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Idf | Overloaded.
Idf (inherited from Similarity) | Overloaded.
LengthNorm |
QueryNorm |
ScorePayload |
SloppyFreq |
Tf | Overloaded.
Tf (inherited from Similarity) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SimilarityDelegator Class | Lucene.Net.Search Namespace


SimilarityDelegator Constructor

Construct a {@link Similarity} that delegates all methods to another.

public SimilarityDelegator(
Similarity delegee
);

Parameters

delegee
the Similarity implementation to delegate to

See Also

SimilarityDelegator Class | Lucene.Net.Search Namespace


SimilarityDelegator Methods

The methods of the SimilarityDelegator class are listed below. For a complete list of SimilarityDelegator class members, see the SimilarityDelegator Members topic.

Public Instance Methods

Coord |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Idf | Overloaded.
Idf (inherited from Similarity) | Overloaded.
LengthNorm |
QueryNorm |
ScorePayload |
SloppyFreq |
Tf | Overloaded.
Tf (inherited from Similarity) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SimilarityDelegator Class | Lucene.Net.Search Namespace


SimilarityDelegator.Coord Method

public override float Coord(
int overlap,
int maxOverlap
);

See Also

SimilarityDelegator Class | Lucene.Net.Search Namespace


Idf Method

Apache Lucene.Net 2.4.0 Class Library API

SimilarityDelegator.Idf Method

Overload List

Inherited from Similarity.

public virtual float Idf(Term,Searcher);

Inherited from Similarity.

public virtual float Idf(ICollection,Searcher);

public override float Idf(int,int);

See Also

SimilarityDelegator Class | Lucene.Net.Search Namespace


SimilarityDelegator.Idf Method (Int32, Int32)

public override float Idf(
int docFreq,
int numDocs
);

See Also

SimilarityDelegator Class | Lucene.Net.Search Namespace | SimilarityDelegator.Idf Overload List


SimilarityDelegator.LengthNorm Method

public override float LengthNorm(
string fieldName,
int numTerms
);

See Also

SimilarityDelegator Class | Lucene.Net.Search Namespace


SimilarityDelegator.QueryNorm Method

public override float QueryNorm(
float sumOfSquaredWeights
);

See Also

SimilarityDelegator Class | Lucene.Net.Search Namespace


SimilarityDelegator.ScorePayload Method

public override float ScorePayload(
string fieldName,
byte[] payload,
int offset,
int length
);

See Also

SimilarityDelegator Class | Lucene.Net.Search Namespace


SimilarityDelegator.SloppyFreq Method

public override float SloppyFreq(
int distance
);

See Also

SimilarityDelegator Class | Lucene.Net.Search Namespace


Tf Method

Apache Lucene.Net 2.4.0 Class Library API

SimilarityDelegator.Tf Method

Overload List

Inherited from Similarity.

public virtual float Tf(int);

public override float Tf(float);

See Also

SimilarityDelegator Class | Lucene.Net.Search Namespace


SimilarityDelegator.Tf Method (Single)

public override float Tf(
float freq
);

See Also

SimilarityDelegator Class | Lucene.Net.Search Namespace | SimilarityDelegator.Tf Overload List


Sort Class

For a list of all members of this type, see Sort Members.

System.Object
Lucene.Net.Search.Sort

public class Sort

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Sort Members | Lucene.Net.Search Namespace


Sort Members

Sort overview

Public Static Fields

INDEXORDER | Represents sorting by index order.
RELEVANCE | Represents sorting by computed relevance. Using this sort criteria returns the same results as calling {@link Searcher#Search(Query) Searcher#search()}without a sort criteria, only with slightly more overhead.

Public Instance Constructors

Sort Overloaded. Initializes a new instance of the Sort class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSort | Representation of the sort criteria.
GetType (inherited from Object) | Gets the Type of the current instance.
SetSort Overloaded. Sets the sort to the terms in
field
then by index order (document number).
ToString

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Sort Class | Lucene.Net.Search Namespace


Sort Constructor

Sorts by computed relevance. This is the same sort criteria as calling {@link Searcher#Search(Query) Searcher#search()}without a sort criteria, only with slightly more overhead.

Overload List

Sorts by computed relevance. This is the same sort criteria as calling {@link Searcher#Search(Query) Searcher#search()}without a sort criteria, only with slightly more overhead.

public Sort();

Sorts by the criteria in the given SortField.

public Sort(SortField);

Sorts in succession by the criteria in each SortField.

public Sort(SortField[]);

Sorts by the terms in

field
then by index order (document number). The type of value in
field
is determined automatically.

public Sort(string);

Sorts possibly in reverse by the terms in

field
then by index order (document number). The type of value in
field
is determined automatically.

public Sort(string,bool);

Sorts in succession by the terms in each field. The type of value in

field
is determined automatically.

public Sort(string[]);

See Also

Sort Class | Lucene.Net.Search Namespace


Sort Constructor ()

Sorts by computed relevance. This is the same sort criteria as calling {@link Searcher#Search(Query) Searcher#search()}without a sort criteria, only with slightly more overhead.

public Sort();

See Also

Sort Class | Lucene.Net.Search Namespace | Sort Constructor Overload List


Sort Constructor (String)

Sorts by the terms in

field
then by index order (document number). The type of value in
field
is determined automatically.

public Sort(
string field
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort Constructor Overload List | SortField#AUTO


Sort Constructor (String, Boolean)

Sorts possibly in reverse by the terms in

field
then by index order (document number). The type of value in
field
is determined automatically.

public Sort(
string field,
bool reverse
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort Constructor Overload List | SortField#AUTO


Sort Constructor (String[])

Sorts in succession by the terms in each field. The type of value in

field
is determined automatically.

public Sort(
string[] fields
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort Constructor Overload List | SortField#AUTO


Sort Constructor (SortField)

Sorts by the criteria in the given SortField.

public Sort(
SortField field
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort Constructor Overload List


Sort Constructor (SortField[])

Sorts in succession by the criteria in each SortField.

public Sort(
SortField[] fields
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort Constructor Overload List


Sort Fields

The fields of the Sort class are listed below. For a complete list of Sort class members, see the Sort Members topic.

Public Static Fields

INDEXORDER | Represents sorting by index order.
RELEVANCE | Represents sorting by computed relevance. Using this sort criteria returns the same results as calling {@link Searcher#Search(Query) Searcher#search()}without a sort criteria, only with slightly more overhead.

See Also

Sort Class | Lucene.Net.Search Namespace


Sort.INDEXORDER Field

Represents sorting by index order.

public static readonly Sort INDEXORDER;

See Also

Sort Class | Lucene.Net.Search Namespace


Sort.RELEVANCE Field

Represents sorting by computed relevance. Using this sort criteria returns the same results as calling {@link Searcher#Search(Query) Searcher#search()}without a sort criteria, only with slightly more overhead.

public static readonly Sort RELEVANCE;

See Also

Sort Class | Lucene.Net.Search Namespace


Sort Methods

The methods of the Sort class are listed below. For a complete list of Sort class members, see the Sort Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSort | Representation of the sort criteria.
GetType (inherited from Object) | Gets the Type of the current instance.
SetSort Overloaded. Sets the sort to the terms in
field
then by index order (document number).
ToString

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Sort Class | Lucene.Net.Search Namespace


Sort.GetSort Method

Representation of the sort criteria.

public virtual SortField[] GetSort();

Return Value

Array of SortField objects used in this sort criteria

See Also

Sort Class | Lucene.Net.Search Namespace


SetSort Method

Apache Lucene.Net 2.4.0 Class Library API

Sort.SetSort Method

Sets the sort to the given criteria.

Overload List

Sets the sort to the given criteria.

public virtual void SetSort(SortField);

Sets the sort to the given criteria in succession.

public virtual void SetSort(SortField[]);

Sets the sort to the terms in

field
then by index order (document number).

public void SetSort(string);

Sets the sort to the terms in

field
possibly in reverse, then by index order (document number).

public virtual void SetSort(string,bool);

Sets the sort to the terms in each field in succession.

public virtual void SetSort(string[]);

See Also

Sort Class | Lucene.Net.Search Namespace


Sort.SetSort Method (SortField)

Sets the sort to the given criteria.

public virtual void SetSort(
SortField field
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort.SetSort Overload List


Sort.SetSort Method (SortField[])

Sets the sort to the given criteria in succession.

public virtual void SetSort(
SortField[] fields
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort.SetSort Overload List


Sort.SetSort Method (String)

Sets the sort to the terms in

field
then by index order (document number).

public void SetSort(
string field
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort.SetSort Overload List


Sort.SetSort Method (String, Boolean)

Sets the sort to the terms in

field
possibly in reverse, then by index order (document number).

public virtual void SetSort(
string field,
bool reverse
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort.SetSort Overload List


Sort.SetSort Method (String[])

Sets the sort to the terms in each field in succession.

public virtual void SetSort(
string[] fieldnames
);

See Also

Sort Class | Lucene.Net.Search Namespace | Sort.SetSort Overload List


Sort.ToString Method

public override string ToString();

See Also

Sort Class | Lucene.Net.Search Namespace


SortComparator Class

For a list of all members of this type, see SortComparator Members.

System.Object
Lucene.Net.Search.SortComparator

public abstract class SortComparator : SortComparatorSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SortComparator Members | Lucene.Net.Search Namespace


SortComparator Members

SortComparator overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetComparable |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NewComparator |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

SortComparator Constructor Initializes a new instance of the SortComparator class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortComparator Class | Lucene.Net.Search Namespace


SortComparator Constructor

Initializes a new instance of the SortComparator class.

protected SortComparator();

See Also

SortComparator Class | Lucene.Net.Search Namespace


SortComparator Methods

The methods of the SortComparator class are listed below. For a complete list of SortComparator class members, see the SortComparator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetComparable |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NewComparator |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortComparator Class | Lucene.Net.Search Namespace


SortComparator.GetComparable Method

public abstract IComparable GetComparable(
string termtext
);

See Also

SortComparator Class | Lucene.Net.Search Namespace


SortComparator.NewComparator Method

public virtual ScoreDocComparator NewComparator(
IndexReader reader,
string fieldname
);

Implements

SortComparatorSource.NewComparator

See Also

SortComparator Class | Lucene.Net.Search Namespace


SortComparatorSource Interface

For a list of all members of this type, see SortComparatorSource Members.

public interface SortComparatorSource

Types that implement SortComparatorSource

Type | Description
SortComparator |

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SortComparatorSource Members | Lucene.Net.Search Namespace


SortComparatorSource Members

SortComparatorSource overview

Public Instance Methods

NewComparator Creates a comparator for the field in the given index.

See Also

SortComparatorSource Interface | Lucene.Net.Search Namespace


SortComparatorSource Methods

The methods of the SortComparatorSource interface are listed below. For a complete list of SortComparatorSource interface members, see the SortComparatorSource Members topic.

Public Instance Methods

NewComparator Creates a comparator for the field in the given index.

See Also

SortComparatorSource Interface | Lucene.Net.Search Namespace


SortComparatorSource.NewComparator Method

Creates a comparator for the field in the given index.

ScoreDocComparator NewComparator(
IndexReader reader,
string fieldname
);

Parameters

reader
Index to create comparator for.
fieldname
Name of the field to create comparator for.

Return Value

Comparator of ScoreDoc objects.

See Also

SortComparatorSource Interface | Lucene.Net.Search Namespace


SortField Class

Stores information about how to sort documents by terms in an individual field. Fields must be indexed in order to sort by them.

For a list of all members of this type, see SortField Members.

System.Object
Lucene.Net.Search.SortField

public class SortField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SortField Members | Lucene.Net.Search Namespace |


SortField Members

SortField overview

Public Static Fields

AUTO | Guess type of sort based on field contents. A regular expression is used to look at the first term indexed for the field and determine if it represents an integer number, a floating point number, or just arbitrary string characters.
BYTE | Sort using term values as encoded bytes. Sort values are bytes and lower values are at the front.
CUSTOM | Sort using a custom Comparator. Sort values are any Comparable and sorting is done according to natural order.
DOC | Sort by document number (index order). Sort values are Integer and lower values are at the front.
DOUBLE | Sort using term values as encoded Doubles. Sort values are Double and lower values are at the front.
FIELD_DOC | Represents sorting by document number (index order).
FIELD_SCORE | Represents sorting by document score (relevancy).
FLOAT | Sort using term values as encoded Floats. Sort values are Float and lower values are at the front.
INT | Sort using term values as encoded Integers. Sort values are Integer and lower values are at the front.
LONG | Sort using term values as encoded Longs. Sort values are Long and lower values are at the front.
SCORE | Sort by document score (relevancy). Sort values are Float and higher values are at the front.
SHORT | Sort using term values as encoded shorts. Sort values are shorts and lower values are at the front.
STRING | Sort using term values as Strings. Sort values are String and lower values are at the front.

Public Instance Constructors

SortField Overloaded. Initializes a new instance of the SortField class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFactory
GetField Returns the name of the field. Could return
null
if the sort is by SCORE or DOC.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLocale Returns the Locale by which term values are interpreted. May return
null
if no Locale was specified.
GetReverse | Returns whether the sort should be reversed.
GetType | Returns the type of contents in the field.
ToString

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortField Class | Lucene.Net.Search Namespace |


SortField Constructor

Creates a sort by terms in the given field where the type of term value is determined dynamically ({@link #AUTO AUTO}).

Overload List

Creates a sort by terms in the given field where the type of term value is determined dynamically ({@link #AUTO AUTO}).

public SortField(string);

Creates a sort with a custom comparison function.

public SortField(string,SortComparatorSource);

Creates a sort, possibly in reverse, with a custom comparison function.

public SortField(string,SortComparatorSource,bool);

Creates a sort, possibly in reverse, by terms in the given field where the type of term value is determined dynamically ({@link #AUTO AUTO}).

public SortField(string,bool);

Creates a sort by terms in the given field sorted according to the given locale.

public SortField(string,CultureInfo);

Creates a sort, possibly in reverse, by terms in the given field sorted according to the given locale.

public SortField(string,CultureInfo,bool);

Creates a sort by terms in the given field with the type of term values explicitly given.

public SortField(string,int);

Creates a sort, possibly in reverse, by terms in the given field with the type of term values explicitly given.

public SortField(string,int,bool);

See Also

SortField Class | Lucene.Net.Search Namespace


SortField Constructor (String)

Creates a sort by terms in the given field where the type of term value is determined dynamically ({@link #AUTO AUTO}).

public SortField(
string field
);

Parameters

field
Name of field to sort by, cannot be
null
.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, Boolean)

Creates a sort, possibly in reverse, by terms in the given field where the type of term value is determined dynamically ({@link #AUTO AUTO}).

public SortField(
string field,
bool reverse
);

Parameters

field
Name of field to sort by, cannot be
null
.
reverse
True if natural order should be reversed.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, Int32)

Creates a sort by terms in the given field with the type of term values explicitly given.

public SortField(
string field,
int type
);

Parameters

field
Name of field to sort by. Can be
null
if
type
is SCORE or DOC.
type
Type of values in the terms.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, Int32, Boolean)

Creates a sort, possibly in reverse, by terms in the given field with the type of term values explicitly given.

public SortField(
string field,
int type,
bool reverse
);

Parameters

field
Name of field to sort by. Can be
null
if
type
is SCORE or DOC.
type
Type of values in the terms.
reverse
True if natural order should be reversed.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, CultureInfo)

Creates a sort by terms in the given field sorted according to the given locale.

public SortField(
string field,
CultureInfo locale
);

Parameters

field
Name of field to sort by, cannot be
null
.
locale
Locale of values in the field.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, CultureInfo, Boolean)

Creates a sort, possibly in reverse, by terms in the given field sorted according to the given locale.

public SortField(
string field,
CultureInfo locale,
bool reverse
);

Parameters

field
Name of field to sort by, cannot be
null
.
locale
Locale of values in the field.
reverse

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, SortComparatorSource)

Creates a sort with a custom comparison function.

public SortField(
string field,
SortComparatorSource comparator
);

Parameters

field
Name of field to sort by; cannot be
null
.
comparator
Returns a comparator for sorting hits.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Constructor (String, SortComparatorSource, Boolean)

Creates a sort, possibly in reverse, with a custom comparison function.

public SortField(
string field,
SortComparatorSource comparator,
bool reverse
);

Parameters

field
Name of field to sort by; cannot be
null
.
comparator
Returns a comparator for sorting hits.
reverse
True if natural order should be reversed.

See Also

SortField Class | Lucene.Net.Search Namespace | SortField Constructor Overload List


SortField Fields

The fields of the SortField class are listed below. For a complete list of SortField class members, see the SortField Members topic.

Public Static Fields

AUTO | Guess type of sort based on field contents. A regular expression is used to look at the first term indexed for the field and determine if it represents an integer number, a floating point number, or just arbitrary string characters.
BYTE | Sort using term values as encoded bytes. Sort values are bytes and lower values are at the front.
CUSTOM | Sort using a custom Comparator. Sort values are any Comparable and sorting is done according to natural order.
DOC | Sort by document number (index order). Sort values are Integer and lower values are at the front.
DOUBLE | Sort using term values as encoded Doubles. Sort values are Double and lower values are at the front.
FIELD_DOC | Represents sorting by document number (index order).
FIELD_SCORE | Represents sorting by document score (relevancy).
FLOAT | Sort using term values as encoded Floats. Sort values are Float and lower values are at the front.
INT | Sort using term values as encoded Integers. Sort values are Integer and lower values are at the front.
LONG | Sort using term values as encoded Longs. Sort values are Long and lower values are at the front.
SCORE | Sort by document score (relevancy). Sort values are Float and higher values are at the front.
SHORT | Sort using term values as encoded shorts. Sort values are shorts and lower values are at the front.
STRING | Sort using term values as Strings. Sort values are String and lower values are at the front.

See Also

SortField Class | Lucene.Net.Search Namespace |


SortField.AUTO Field

Guess type of sort based on field contents. A regular expression is used to look at the first term indexed for the field and determine if it represents an integer number, a floating point number, or just arbitrary string characters.

public const int AUTO = 2;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.BYTE Field

Sort using term values as encoded bytes. Sort values are bytes and lower values are at the front.

public const int BYTE = 10;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.CUSTOM Field

Sort using a custom Comparator. Sort values are any Comparable and sorting is done according to natural order.

public const int CUSTOM = 9;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.DOC Field

Sort by document number (index order). Sort values are Integer and lower values are at the front.

public const int DOC = 1;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.DOUBLE Field

Sort using term values as encoded Doubles. Sort values are Double and lower values are at the front.

public const int DOUBLE = 7;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.FIELD_DOC Field

Represents sorting by document number (index order).

public static readonly SortField FIELD_DOC;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.FIELD_SCORE Field

Represents sorting by document score (relevancy).

public static readonly SortField FIELD_SCORE;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.FLOAT Field

Sort using term values as encoded Floats. Sort values are Float and lower values are at the front.

public const int FLOAT = 5;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.INT Field

Sort using term values as encoded Integers. Sort values are Integer and lower values are at the front.

public const int INT = 4;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.LONG Field

Sort using term values as encoded Longs. Sort values are Long and lower values are at the front.

public const int LONG = 6;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.SCORE Field

Sort by document score (relevancy). Sort values are Float and higher values are at the front.

public const int SCORE = 0;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.SHORT Field

Sort using term values as encoded shorts. Sort values are shorts and lower values are at the front.

public const int SHORT = 8;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.STRING Field

Sort using term values as Strings. Sort values are String and lower values are at the front.

public const int STRING = 3;

See Also

SortField Class | Lucene.Net.Search Namespace


SortField Methods

The methods of the SortField class are listed below. For a complete list of SortField class members, see the SortField Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFactory
GetField Returns the name of the field. Could return
null
if the sort is by SCORE or DOC.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLocale Returns the Locale by which term values are interpreted. May return
null
if no Locale was specified.
GetReverse | Returns whether the sort should be reversed.
GetType | Returns the type of contents in the field.
ToString

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortField Class | Lucene.Net.Search Namespace |


SortField.GetFactory Method

public virtual SortComparatorSource GetFactory();

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.GetField Method

Returns the name of the field. Could return

null
if the sort is by SCORE or DOC.

public virtual string GetField();

Return Value

Name of field, possibly

null
.

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.GetLocale Method

Returns the Locale by which term values are interpreted. May return

null
if no Locale was specified.

public virtual CultureInfo GetLocale();

Return Value

Locale, or

null
.

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.GetReverse Method

Returns whether the sort should be reversed.

public virtual bool GetReverse();

Return Value

True if natural order should be reversed.

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.GetType Method

Returns the type of contents in the field.

new public virtual int GetType();

Return Value

One of the constants SCORE, DOC, AUTO, STRING, INT or FLOAT.

See Also

SortField Class | Lucene.Net.Search Namespace


SortField.ToString Method

public override string ToString();

See Also

SortField Class | Lucene.Net.Search Namespace


SpanFilter Class

Abstract base class providing a mechanism to restrict searches to a subset of an index and also maintains and returns position information. This is useful if you want to compare the positions from a SpanQuery with the positions of items in a filter. For instance, if you had a SpanFilter that marked all the occurrences of the word "foo" in documents, and then you entered a new SpanQuery containing bar, you could not only filter by the word foo, but you could then compare position information for post processing.

For a list of all members of this type, see SpanFilter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.SpanFilter
Lucene.Net.Search.CachingSpanFilter
Lucene.Net.Search.SpanQueryFilter

public abstract class SpanFilter : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanFilter Members | Lucene.Net.Search Namespace


SpanFilter Members

SpanFilter overview

Public Instance Methods

Bits (inherited from Filter) | Obsolete. Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
BitSpans | Returns a SpanFilterResult with true for documents which should be permitted in search results, and false for those that should not and Spans for where the true docs match.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDocIdSet (inherited from Filter) | Return a DocIdSet that provides the documents which are permitted or prohibited in search results.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

SpanFilter Constructor Initializes a new instance of the SpanFilter class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpanFilter Class | Lucene.Net.Search Namespace


SpanFilter Constructor

Initializes a new instance of the SpanFilter class.

protected SpanFilter();

See Also

SpanFilter Class | Lucene.Net.Search Namespace


SpanFilter Methods

The methods of the SpanFilter class are listed below. For a complete list of SpanFilter class members, see the SpanFilter Members topic.

Public Instance Methods

Bits (inherited from Filter) | Obsolete. Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
BitSpans | Returns a SpanFilterResult with true for documents which should be permitted in search results, and false for those that should not and Spans for where the true docs match.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDocIdSet (inherited from Filter) | Return a DocIdSet that provides the documents which are permitted or prohibited in search results.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpanFilter Class | Lucene.Net.Search Namespace


SpanFilter.BitSpans Method

Returns a SpanFilterResult with true for documents which should be permitted in search results, and false for those that should not and Spans for where the true docs match.

public abstract SpanFilterResult BitSpans(
IndexReader reader
);

Parameters

reader
The {@link Lucene.Net.Index.IndexReader} to load position and DocIdSet information from

Return Value

A {@link SpanFilterResult}

See Also

SpanFilter Class | Lucene.Net.Search Namespace


SpanFilterResult Class

The results of a SpanQueryFilter. Wraps the BitSet and the position infomration from the SpanQuery

NOTE: This API is still experimental and subject to change.

For a list of all members of this type, see SpanFilterResult Members.

System.Object
Lucene.Net.Search.SpanFilterResult

public class SpanFilterResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanFilterResult Members | Lucene.Net.Search Namespace


SpanFilterResult Members

SpanFilterResult overview

Public Instance Constructors

SpanFilterResult Overloaded. Initializes a new instance of the SpanFilterResult class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBits | Obsolete.
GetDocIdSet | Returns the DocIdSet.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositions | The first entry in the array corresponds to the first "on" bit. Entries are increasing by document order
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpanFilterResult Class | Lucene.Net.Search Namespace


SpanFilterResult Constructor

NOTE: This constructor is now obsolete.

Use SpanFilterResult(DocIdSet, List) instead.

Overload List

public SpanFilterResult(DocIdSet,IList);

Obsolete.

public SpanFilterResult(BitArray,IList);

See Also

SpanFilterResult Class | Lucene.Net.Search Namespace


SpanFilterResult Constructor (BitArray, IList)

NOTE: This constructor is now obsolete.

Use SpanFilterResult(DocIdSet, List) instead.

public SpanFilterResult(
BitArray bits,
IList positions
);

Parameters

bits
The bits for the Filter
positions
A List of {@link Lucene.Net.Search.SpanFilterResult.PositionInfo} objects

See Also

SpanFilterResult Class | Lucene.Net.Search Namespace | SpanFilterResult Constructor Overload List


SpanFilterResult Constructor (DocIdSet, IList)

public SpanFilterResult(
DocIdSet docIdSet,
IList positions
);

Parameters

docIdSet
The DocIdSet for the Filter
positions
A List of {@link Lucene.Net.Search.SpanFilterResult.PositionInfo} objects

See Also

SpanFilterResult Class | Lucene.Net.Search Namespace | SpanFilterResult Constructor Overload List


SpanFilterResult Methods

The methods of the SpanFilterResult class are listed below. For a complete list of SpanFilterResult class members, see the SpanFilterResult Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBits | Obsolete.
GetDocIdSet | Returns the DocIdSet.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositions | The first entry in the array corresponds to the first "on" bit. Entries are increasing by document order
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpanFilterResult Class | Lucene.Net.Search Namespace


SpanFilterResult.GetBits Method

NOTE: This method is now obsolete.

Use GetDocIdSet() instead.

public virtual BitArray GetBits();

See Also

SpanFilterResult Class | Lucene.Net.Search Namespace


SpanFilterResult.GetDocIdSet Method

Returns the DocIdSet.

public virtual DocIdSet GetDocIdSet();

Return Value

See Also

SpanFilterResult Class | Lucene.Net.Search Namespace


SpanFilterResult.GetPositions Method

The first entry in the array corresponds to the first "on" bit. Entries are increasing by document order

public virtual IList GetPositions();

Return Value

A List of PositionInfo objects

See Also

SpanFilterResult Class | Lucene.Net.Search Namespace


SpanFilterResult.PositionInfo Class

For a list of all members of this type, see SpanFilterResult.PositionInfo Members.

System.Object
Lucene.Net.Search.SpanFilterResult.PositionInfo

public class SpanFilterResult.PositionInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanFilterResult.PositionInfo Members | Lucene.Net.Search Namespace


SpanFilterResult.PositionInfo Members

SpanFilterResult.PositionInfo overview

Public Instance Constructors

SpanFilterResult.PositionInfo Constructor

Public Instance Methods

AddPosition |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDoc |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositions |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpanFilterResult.PositionInfo Class | Lucene.Net.Search Namespace


SpanFilterResult.PositionInfo Constructor

public SpanFilterResult.PositionInfo(
int doc
);

See Also

SpanFilterResult.PositionInfo Class | Lucene.Net.Search Namespace


SpanFilterResult.PositionInfo Methods

The methods of the SpanFilterResult.PositionInfo class are listed below. For a complete list of SpanFilterResult.PositionInfo class members, see the SpanFilterResult.PositionInfo Members topic.

Public Instance Methods

AddPosition |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDoc |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPositions |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpanFilterResult.PositionInfo Class | Lucene.Net.Search Namespace


SpanFilterResult.PositionInfo.AddPosition Method

public virtual void AddPosition(
int start,
int end
);

See Also

SpanFilterResult.PositionInfo Class | Lucene.Net.Search Namespace


SpanFilterResult.PositionInfo.GetDoc Method

public virtual int GetDoc();

See Also

SpanFilterResult.PositionInfo Class | Lucene.Net.Search Namespace


SpanFilterResult.PositionInfo.GetPositions Method

public virtual IList GetPositions();

Return Value

A List of {@link Lucene.Net.Search.SpanFilterResult.StartEnd} objects

See Also

SpanFilterResult.PositionInfo Class | Lucene.Net.Search Namespace


SpanFilterResult.StartEnd Class

For a list of all members of this type, see SpanFilterResult.StartEnd Members.

System.Object
Lucene.Net.Search.SpanFilterResult.StartEnd

public class SpanFilterResult.StartEnd

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanFilterResult.StartEnd Members | Lucene.Net.Search Namespace


SpanFilterResult.StartEnd Members

SpanFilterResult.StartEnd overview

Public Instance Constructors

SpanFilterResult.StartEnd Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnd |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetStart | The Start position
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpanFilterResult.StartEnd Class | Lucene.Net.Search Namespace


SpanFilterResult.StartEnd Constructor

public SpanFilterResult.StartEnd(
int start,
int end
);

See Also

SpanFilterResult.StartEnd Class | Lucene.Net.Search Namespace


SpanFilterResult.StartEnd Methods

The methods of the SpanFilterResult.StartEnd class are listed below. For a complete list of SpanFilterResult.StartEnd class members, see the SpanFilterResult.StartEnd Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnd |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetStart | The Start position
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpanFilterResult.StartEnd Class | Lucene.Net.Search Namespace


SpanFilterResult.StartEnd.GetEnd Method

public virtual int GetEnd();

Return Value

The end position of this match

See Also

SpanFilterResult.StartEnd Class | Lucene.Net.Search Namespace


SpanFilterResult.StartEnd.GetStart Method

The Start position

public virtual int GetStart();

Return Value

The start position of this match

See Also

SpanFilterResult.StartEnd Class | Lucene.Net.Search Namespace


SpanQueryFilter Class

Constrains search results to only match those which also match a provided query. Also provides position information about where each document matches at the cost of extra space compared with the QueryWrapperFilter. There is an added cost to this above what is stored in a {@link QueryWrapperFilter}. Namely, the position information for each matching document is stored.

This filter does not cache. See the {@link Lucene.Net.Search.CachingSpanFilter} for a wrapper that caches.

For a list of all members of this type, see SpanQueryFilter Members.

System.Object
Lucene.Net.Search.Filter
Lucene.Net.Search.SpanFilter
Lucene.Net.Search.SpanQueryFilter

public class SpanQueryFilter : SpanFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanQueryFilter Members | Lucene.Net.Search Namespace


SpanQueryFilter Members

SpanQueryFilter overview

Public Instance Constructors

SpanQueryFilter Overloaded. Initializes a new instance of the SpanQueryFilter class.

Public Instance Methods

Bits | Obsolete.
BitSpans |
Equals |
GetDocIdSet |
GetHashCode |
GetQuery |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

SpanQueryFilter Overloaded. Initializes a new instance of the SpanQueryFilter class.

Protected Internal Instance Fields

query

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace


SpanQueryFilter Constructor

Initializes a new instance of the SpanQueryFilter class.

Overload List

Initializes a new instance of the SpanQueryFilter class.

protected internal SpanQueryFilter();

Constructs a filter which only matches documents matching

query
.

public SpanQueryFilter(SpanQuery);

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace


SpanQueryFilter Constructor ()

Initializes a new instance of the SpanQueryFilter class.

protected internal SpanQueryFilter();

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace | SpanQueryFilter Constructor Overload List


SpanQueryFilter Constructor (SpanQuery)

Constructs a filter which only matches documents matching

query
.

public SpanQueryFilter(
SpanQuery query
);

Parameters

query
The {@link Lucene.Net.Search.Spans.SpanQuery} to use as the basis for the Filter.

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace | SpanQueryFilter Constructor Overload List


SpanQueryFilter Fields

The fields of the SpanQueryFilter class are listed below. For a complete list of SpanQueryFilter class members, see the SpanQueryFilter Members topic.

Protected Internal Instance Fields

query

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace


SpanQueryFilter.query Field

protected internal SpanQuery query;

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace


SpanQueryFilter Methods

The methods of the SpanQueryFilter class are listed below. For a complete list of SpanQueryFilter class members, see the SpanQueryFilter Members topic.

Public Instance Methods

Bits | Obsolete.
BitSpans |
Equals |
GetDocIdSet |
GetHashCode |
GetQuery |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace


SpanQueryFilter.Bits Method

NOTE: This method is now obsolete.

public override BitArray Bits(
IndexReader reader
);

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace


SpanQueryFilter.BitSpans Method

public override SpanFilterResult BitSpans(
IndexReader reader
);

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace


SpanQueryFilter.Equals Method

public override bool Equals(
object o
);

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace


SpanQueryFilter.GetDocIdSet Method

public override DocIdSet GetDocIdSet(
IndexReader reader
);

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace


SpanQueryFilter.GetHashCode Method

public override int GetHashCode();

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace


SpanQueryFilter.GetQuery Method

public virtual SpanQuery GetQuery();

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace


SpanQueryFilter.ToString Method

public override string ToString();

See Also

SpanQueryFilter Class | Lucene.Net.Search Namespace


StringIndex Class

Expert: Maintains caches of term values.

For a list of all members of this type, see StringIndex Members.

System.Object
Lucene.Net.Search.StringIndex

public class StringIndex

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StringIndex Members | Lucene.Net.Search Namespace


StringIndex Members

StringIndex overview

Public Instance Constructors

StringIndex Constructor Creates one of these objects

Public Instance Fields

Lookup | All the term values, in natural order.
Order | For each document, an index into the lookup array.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringIndex Class | Lucene.Net.Search Namespace


StringIndex Constructor

Creates one of these objects

public StringIndex(
int[] values,
string[] lookup
);

See Also

StringIndex Class | Lucene.Net.Search Namespace


StringIndex Fields

The fields of the StringIndex class are listed below. For a complete list of StringIndex class members, see the StringIndex Members topic.

Public Instance Fields

Lookup | All the term values, in natural order.
Order | For each document, an index into the lookup array.

See Also

StringIndex Class | Lucene.Net.Search Namespace


StringIndex.Lookup Field

All the term values, in natural order.

public string[] Lookup;

See Also

StringIndex Class | Lucene.Net.Search Namespace


StringIndex.Order Field

For each document, an index into the lookup array.

public int[] Order;

See Also

StringIndex Class | Lucene.Net.Search Namespace


TermQuery Class

A Query that matches documents containing a term. This may be combined with other terms with a {@link BooleanQuery}.

For a list of all members of this type, see TermQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.TermQuery

public class TermQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermQuery Members | Lucene.Net.Search Namespace


TermQuery Members

TermQuery overview

Public Instance Constructors

TermQuery Constructor Constructs a query for the term
t
.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm | Returns the term of this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery Constructor

Constructs a query for the term

t
.

public TermQuery(
Term t
);

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery Methods

The methods of the TermQuery class are listed below. For a complete list of TermQuery class members, see the TermQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm | Returns the term of this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery.GetTerm Method

Returns the term of this query.

public virtual Term GetTerm();

See Also

TermQuery Class | Lucene.Net.Search Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

TermQuery.ToString Method

Prints a user-readable version of this query.

Overload List

Inherited from Query.

public override string ToString();

Prints a user-readable version of this query.

public override string ToString(string);

See Also

TermQuery Class | Lucene.Net.Search Namespace


TermQuery.ToString Method (String)

Prints a user-readable version of this query.

public override string ToString(
string field
);

See Also

TermQuery Class | Lucene.Net.Search Namespace | TermQuery.ToString Overload List


TermScorer Class

Expert: A

Scorer
for documents matching a
Term
.

For a list of all members of this type, see TermScorer Members.

System.Object
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Search.Scorer
Lucene.Net.Search.TermScorer

public sealed class TermScorer : Scorer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermScorer Members | Lucene.Net.Search Namespace


TermScorer Members

TermScorer overview

Public Instance Constructors

TermScorer Constructor

Public Instance Methods

Doc | Returns the current document number matching the query. Initially invalid, until {@link #next()} is called the first time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Scorer) | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next
Score | Overloaded.
SkipTo
ToString Returns a string representation of this
TermScorer
.

Protected Internal Instance Methods

Score Overloaded.

See Also

TermScorer Class | Lucene.Net.Search Namespace


TermScorer Constructor

public TermScorer(
Weight weight,
TermDocs td,
Similarity similarity,
byte[] norms
);

See Also

TermScorer Class | Lucene.Net.Search Namespace


TermScorer Methods

The methods of the TermScorer class are listed below. For a complete list of TermScorer class members, see the TermScorer Members topic.

Public Instance Methods

Doc | Returns the current document number matching the query. Initially invalid, until {@link #next()} is called the first time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Scorer) | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next
Score | Overloaded.
SkipTo
ToString Returns a string representation of this
TermScorer
.

Protected Internal Instance Methods

Score Overloaded.

See Also

TermScorer Class | Lucene.Net.Search Namespace


TermScorer.Doc Method

Returns the current document number matching the query. Initially invalid, until {@link #next()} is called the first time.

public override int Doc();

See Also

TermScorer Class | Lucene.Net.Search Namespace


TermScorer.Explain Method

public override Explanation Explain(
int doc
);

See Also

TermScorer Class | Lucene.Net.Search Namespace


TermScorer.Next Method

public override bool Next();

See Also

TermScorer Class | Lucene.Net.Search Namespace


Score Method

Apache Lucene.Net 2.4.0 Class Library API

TermScorer.Score Method

Overload List

public override float Score();

public override void Score(HitCollector);

protected internal override bool Score(HitCollector,int);

See Also

TermScorer Class | Lucene.Net.Search Namespace


TermScorer.Score Method ()

public override float Score();

See Also

TermScorer Class | Lucene.Net.Search Namespace | TermScorer.Score Overload List


TermScorer.Score Method (HitCollector)

public override void Score(
HitCollector hc
);

See Also

TermScorer Class | Lucene.Net.Search Namespace | TermScorer.Score Overload List


TermScorer.Score Method (HitCollector, Int32)

protected internal override bool Score(
HitCollector c,
int end
);

See Also

TermScorer Class | Lucene.Net.Search Namespace | TermScorer.Score Overload List


TermScorer.SkipTo Method

public override bool SkipTo(
int target
);

See Also

TermScorer Class | Lucene.Net.Search Namespace


TermScorer.ToString Method

Returns a string representation of this

TermScorer
.

public override string ToString();

See Also

TermScorer Class | Lucene.Net.Search Namespace


TimeLimitedCollector Class

For a list of all members of this type, see TimeLimitedCollector Members.

System.Object
Lucene.Net.Search.HitCollector
Lucene.Net.Search.TimeLimitedCollector

public class TimeLimitedCollector : HitCollector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TimeLimitedCollector Members | Lucene.Net.Search Namespace


TimeLimitedCollector Members

TimeLimitedCollector overview

Public Static Fields

DEFAULT_GREEDY
DEFAULT_RESOLUTION

Public Static Methods

getResolution
setResolution

Public Instance Constructors

TimeLimitedCollector Constructor

Public Instance Methods

Collect |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
isGreedy |
setGreedy |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeLimitedCollector Class | Lucene.Net.Search Namespace


TimeLimitedCollector Constructor

public TimeLimitedCollector(
HitCollector hc,
long timeAllowed
);

See Also

TimeLimitedCollector Class | Lucene.Net.Search Namespace


TimeLimitedCollector Fields

The fields of the TimeLimitedCollector class are listed below. For a complete list of TimeLimitedCollector class members, see the TimeLimitedCollector Members topic.

Public Static Fields

DEFAULT_GREEDY
DEFAULT_RESOLUTION

See Also

TimeLimitedCollector Class | Lucene.Net.Search Namespace


TimeLimitedCollector.DEFAULT_GREEDY Field

public static readonly bool DEFAULT_GREEDY;

See Also

TimeLimitedCollector Class | Lucene.Net.Search Namespace


TimeLimitedCollector.DEFAULT_RESOLUTION Field

public static readonly uint DEFAULT_RESOLUTION;

See Also

TimeLimitedCollector Class | Lucene.Net.Search Namespace


TimeLimitedCollector Methods

The methods of the TimeLimitedCollector class are listed below. For a complete list of TimeLimitedCollector class members, see the TimeLimitedCollector Members topic.

Public Static Methods

getResolution
setResolution

Public Instance Methods

Collect |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
isGreedy |
setGreedy |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeLimitedCollector Class | Lucene.Net.Search Namespace


TimeLimitedCollector.Collect Method

public override void Collect(
int doc,
float score
);

See Also

TimeLimitedCollector Class | Lucene.Net.Search Namespace


TimeLimitedCollector.getResolution Method

public static long getResolution();

See Also

TimeLimitedCollector Class | Lucene.Net.Search Namespace


TimeLimitedCollector.isGreedy Method

public bool isGreedy();

See Also

TimeLimitedCollector Class | Lucene.Net.Search Namespace


TimeLimitedCollector.setGreedy Method

public void setGreedy(
bool greedy
);

See Also

TimeLimitedCollector Class | Lucene.Net.Search Namespace


TimeLimitedCollector.setResolution Method

public static void setResolution(
uint newResolution
);

See Also

TimeLimitedCollector Class | Lucene.Net.Search Namespace


TimeLimitedCollector.TimeExceededException Class

For a list of all members of this type, see TimeLimitedCollector.TimeExceededException Members.

System.Object
System.Exception
Lucene.Net.Search.TimeLimitedCollector.TimeExceededException

public class TimeLimitedCollector.TimeExceededException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TimeLimitedCollector.TimeExceededException Members | Lucene.Net.Search Namespace


TimeLimitedCollector.TimeExceededException Members

TimeLimitedCollector.TimeExceededException overview

Public Instance Constructors

TimeLimitedCollector.TimeExceededException Constructor

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLastDocCollected |
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
getTimeAllowed |
getTimeElapsed |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeLimitedCollector.TimeExceededException Class | Lucene.Net.Search Namespace


TimeLimitedCollector.TimeExceededException Constructor

public TimeLimitedCollector.TimeExceededException(
long timeAllowed,
long timeElapsed,
int lastDocCollected
);

See Also

TimeLimitedCollector.TimeExceededException Class | Lucene.Net.Search Namespace


TimeLimitedCollector.TimeExceededException Methods

The methods of the TimeLimitedCollector.TimeExceededException class are listed below. For a complete list of TimeLimitedCollector.TimeExceededException class members, see the TimeLimitedCollector.TimeExceededException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getLastDocCollected |
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
getTimeAllowed |
getTimeElapsed |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeLimitedCollector.TimeExceededException Class | Lucene.Net.Search Namespace


TimeLimitedCollector.TimeExceededException.getLastDocCollected Method

public int getLastDocCollected();

See Also

TimeLimitedCollector.TimeExceededException Class | Lucene.Net.Search Namespace


TimeLimitedCollector.TimeExceededException.getTimeAllowed Method

public long getTimeAllowed();

See Also

TimeLimitedCollector.TimeExceededException Class | Lucene.Net.Search Namespace


TimeLimitedCollector.TimeExceededException.getTimeElapsed Method

public long getTimeElapsed();

See Also

TimeLimitedCollector.TimeExceededException Class | Lucene.Net.Search Namespace


TopDocCollector Class

For a list of all members of this type, see TopDocCollector Members.

System.Object
Lucene.Net.Search.HitCollector
Lucene.Net.Search.TopDocCollector
Lucene.Net.Search.TopFieldDocCollector

public class TopDocCollector : HitCollector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TopDocCollector Members | Lucene.Net.Search Namespace


TopDocCollector Members

TopDocCollector overview

Public Instance Constructors

TopDocCollector Constructor Construct to collect a given number of hits.

Public Instance Methods

Collect |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTotalHits | The total number of documents that matched this query.
GetType (inherited from Object) | Gets the Type of the current instance.
TopDocs | The top-scoring hits.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

hq | The priority queue which holds the top-scoring document.
totalHits | The total number of hits the collector encountered.

See Also

TopDocCollector Class | Lucene.Net.Search Namespace


TopDocCollector Constructor

Construct to collect a given number of hits.

public TopDocCollector(
int numHits
);

Parameters

numHits
the maximum number of hits to collect

See Also

TopDocCollector Class | Lucene.Net.Search Namespace


TopDocCollector Fields

The fields of the TopDocCollector class are listed below. For a complete list of TopDocCollector class members, see the TopDocCollector Members topic.

Protected Internal Instance Fields

hq | The priority queue which holds the top-scoring document.
totalHits | The total number of hits the collector encountered.

See Also

TopDocCollector Class | Lucene.Net.Search Namespace


TopDocCollector.hq Field

The priority queue which holds the top-scoring document.

protected internal PriorityQueue hq;

See Also

TopDocCollector Class | Lucene.Net.Search Namespace


TopDocCollector.totalHits Field

The total number of hits the collector encountered.

protected internal int totalHits;

See Also

TopDocCollector Class | Lucene.Net.Search Namespace


TopDocCollector Methods

The methods of the TopDocCollector class are listed below. For a complete list of TopDocCollector class members, see the TopDocCollector Members topic.

Public Instance Methods

Collect |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTotalHits | The total number of documents that matched this query.
GetType (inherited from Object) | Gets the Type of the current instance.
TopDocs | The top-scoring hits.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TopDocCollector Class | Lucene.Net.Search Namespace


TopDocCollector.Collect Method

public override void Collect(
int doc,
float score
);

See Also

TopDocCollector Class | Lucene.Net.Search Namespace


TopDocCollector.GetTotalHits Method

The total number of documents that matched this query.

public virtual int GetTotalHits();

See Also

TopDocCollector Class | Lucene.Net.Search Namespace


TopDocCollector.TopDocs Method

The top-scoring hits.

public virtual TopDocs TopDocs();

See Also

TopDocCollector Class | Lucene.Net.Search Namespace


TopDocs Class

Expert: Returned by low-level search implementations.

For a list of all members of this type, see TopDocs Members.

System.Object
Lucene.Net.Search.TopDocs
Lucene.Net.Search.TopFieldDocs

public class TopDocs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TopDocs Members | Lucene.Net.Search Namespace |


TopDocs Members

TopDocs overview

Public Instance Constructors

TopDocs Constructor Expert: Constructs a TopDocs.

Public Instance Fields

scoreDocs | Expert: The top hits for the query.
totalHits | Expert: The total number of hits for the query.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxScore | Expert: Returns the maximum score value encountered.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMaxScore | Expert: Sets the maximum score value encountered.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TopDocs Class | Lucene.Net.Search Namespace |


TopDocs Constructor

Expert: Constructs a TopDocs.

public TopDocs(
int totalHits,
ScoreDoc[] scoreDocs,
float maxScore
);

See Also

TopDocs Class | Lucene.Net.Search Namespace


TopDocs Fields

The fields of the TopDocs class are listed below. For a complete list of TopDocs class members, see the TopDocs Members topic.

Public Instance Fields

scoreDocs | Expert: The top hits for the query.
totalHits | Expert: The total number of hits for the query.

See Also

TopDocs Class | Lucene.Net.Search Namespace |


TopDocs.scoreDocs Field

Expert: The top hits for the query.

public ScoreDoc[] scoreDocs;

See Also

TopDocs Class | Lucene.Net.Search Namespace


TopDocs.totalHits Field

Expert: The total number of hits for the query.

public int totalHits;

See Also

TopDocs Class | Lucene.Net.Search Namespace |


TopDocs Methods

The methods of the TopDocs class are listed below. For a complete list of TopDocs class members, see the TopDocs Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxScore | Expert: Returns the maximum score value encountered.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMaxScore | Expert: Sets the maximum score value encountered.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TopDocs Class | Lucene.Net.Search Namespace |


TopDocs.GetMaxScore Method

Expert: Returns the maximum score value encountered.

public virtual float GetMaxScore();

See Also

TopDocs Class | Lucene.Net.Search Namespace


TopDocs.SetMaxScore Method

Expert: Sets the maximum score value encountered.

public virtual void SetMaxScore(
float maxScore
);

See Also

TopDocs Class | Lucene.Net.Search Namespace


TopFieldDocCollector Class

For a list of all members of this type, see TopFieldDocCollector Members.

System.Object
Lucene.Net.Search.HitCollector
Lucene.Net.Search.TopDocCollector
Lucene.Net.Search.TopFieldDocCollector

public class TopFieldDocCollector : TopDocCollector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TopFieldDocCollector Members | Lucene.Net.Search Namespace


TopFieldDocCollector Members

TopFieldDocCollector overview

Public Instance Constructors

TopFieldDocCollector Constructor Construct to collect a given number of hits.

Public Instance Methods

Collect |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTotalHits (inherited from TopDocCollector) | The total number of documents that matched this query.
GetType (inherited from Object) | Gets the Type of the current instance.
TopDocs |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

hq (inherited from TopDocCollector) | The priority queue which holds the top-scoring document.
totalHits (inherited from TopDocCollector) | The total number of hits the collector encountered.

See Also

TopFieldDocCollector Class | Lucene.Net.Search Namespace


TopFieldDocCollector Constructor

Construct to collect a given number of hits.

public TopFieldDocCollector(
IndexReader reader,
Sort sort,
int numHits
);

Parameters

reader
the index to be searched
sort
the sort criteria
numHits
the maximum number of hits to collect

See Also

TopFieldDocCollector Class | Lucene.Net.Search Namespace


TopFieldDocCollector Methods

The methods of the TopFieldDocCollector class are listed below. For a complete list of TopFieldDocCollector class members, see the TopFieldDocCollector Members topic.

Public Instance Methods

Collect |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTotalHits (inherited from TopDocCollector) | The total number of documents that matched this query.
GetType (inherited from Object) | Gets the Type of the current instance.
TopDocs |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TopFieldDocCollector Class | Lucene.Net.Search Namespace


TopFieldDocCollector.Collect Method

public override void Collect(
int doc,
float score
);

See Also

TopFieldDocCollector Class | Lucene.Net.Search Namespace


TopFieldDocCollector.TopDocs Method

public override TopDocs TopDocs();

See Also

TopFieldDocCollector Class | Lucene.Net.Search Namespace


TopFieldDocs Class

Expert: Returned by low-level sorted search implementations.

For a list of all members of this type, see TopFieldDocs Members.

System.Object
Lucene.Net.Search.TopDocs
Lucene.Net.Search.TopFieldDocs

public class TopFieldDocs : TopDocs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TopFieldDocs Members | Lucene.Net.Search Namespace | Searcher#Search


TopFieldDocs Members

TopFieldDocs overview

Public Instance Fields

fields | The fields which were used to sort results by.
scoreDocs (inherited from TopDocs) | Expert: The top hits for the query.
totalHits (inherited from TopDocs) | Expert: The total number of hits for the query.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMaxScore (inherited from TopDocs) | Expert: Returns the maximum score value encountered.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMaxScore (inherited from TopDocs) | Expert: Sets the maximum score value encountered.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TopFieldDocs Class | Lucene.Net.Search Namespace | Searcher#Search


TopFieldDocs Fields

The fields of the TopFieldDocs class are listed below. For a complete list of TopFieldDocs class members, see the TopFieldDocs Members topic.

Public Instance Fields

fields | The fields which were used to sort results by.
scoreDocs (inherited from TopDocs) | Expert: The top hits for the query.
totalHits (inherited from TopDocs) | Expert: The total number of hits for the query.

See Also

TopFieldDocs Class | Lucene.Net.Search Namespace | Searcher#Search


TopFieldDocs.fields Field

The fields which were used to sort results by.

public SortField[] fields;

See Also

TopFieldDocs Class | Lucene.Net.Search Namespace


Weight Interface

For a list of all members of this type, see Weight Members.

public interface Weight

Types that implement Weight

Type | Description
ConstantScoreQuery.ConstantWeight |
BoostingTermQuery.BoostingTermWeight |
SpanWeight | Expert-only. Public for use by other weight implementations

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Weight Members | Lucene.Net.Search Namespace


Weight Members

Weight overview

Public Instance Methods

Explain | An explanation of the score computation for the named document.
GetQuery | The query that this concerns.
GetValue | The weight for this query.
Normalize | Assigns the query normalization factor to this.
Scorer | Constructs a scorer for this.
SumOfSquaredWeights | The sum of squared weights of contained query clauses.

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight Methods

The methods of the Weight interface are listed below. For a complete list of Weight interface members, see the Weight Members topic.

Public Instance Methods

Explain | An explanation of the score computation for the named document.
GetQuery | The query that this concerns.
GetValue | The weight for this query.
Normalize | Assigns the query normalization factor to this.
Scorer | Constructs a scorer for this.
SumOfSquaredWeights | The sum of squared weights of contained query clauses.

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight.Explain Method

An explanation of the score computation for the named document.

Explanation Explain(
IndexReader reader,
int doc
);

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight.GetQuery Method

The query that this concerns.

Query GetQuery();

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight.GetValue Method

The weight for this query.

float GetValue();

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight.Normalize Method

Assigns the query normalization factor to this.

void Normalize(
float norm
);

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight.Scorer Method

Constructs a scorer for this.

Scorer Scorer(
IndexReader reader
);

See Also

Weight Interface | Lucene.Net.Search Namespace


Weight.SumOfSquaredWeights Method

The sum of squared weights of contained query clauses.

float SumOfSquaredWeights();

See Also

Weight Interface | Lucene.Net.Search Namespace


WildcardQuery Class

Implements the wildcard search query. Supported wildcards are

*
, which matches any character sequence (including the empty one), and
?
, which matches any single character. Note this query can be slow, as it needs to iterate over many terms. In order to prevent extremely slow WildcardQueries, a Wildcard term should not start with one of the wildcards
*
or
?
.

For a list of all members of this type, see WildcardQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.MultiTermQuery
Lucene.Net.Search.WildcardQuery

public class WildcardQuery : MultiTermQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

WildcardQuery Members | Lucene.Net.Search Namespace |


WildcardQuery Members

WildcardQuery overview

Public Instance Constructors

WildcardQuery Constructor

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm (inherited from MultiTermQuery) | Returns the pattern term.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString (inherited from MultiTermQuery) | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)
GetEnum

See Also

WildcardQuery Class | Lucene.Net.Search Namespace |


WildcardQuery Constructor

public WildcardQuery(
Term term
);

See Also

WildcardQuery Class | Lucene.Net.Search Namespace


WildcardQuery Methods

The methods of the WildcardQuery class are listed below. For a complete list of WildcardQuery class members, see the WildcardQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetTerm (inherited from MultiTermQuery) | Returns the pattern term.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString (inherited from MultiTermQuery) | Overloaded. Prints a user-readable version of this query.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from Query)
GetEnum

See Also

WildcardQuery Class | Lucene.Net.Search Namespace |


WildcardQuery.Equals Method

public override bool Equals(
object o
);

See Also

WildcardQuery Class | Lucene.Net.Search Namespace


WildcardQuery.GetEnum Method

protected internal override FilteredTermEnum GetEnum(
IndexReader reader
);

See Also

WildcardQuery Class | Lucene.Net.Search Namespace


WildcardQuery.GetHashCode Method

public override int GetHashCode();

See Also

WildcardQuery Class | Lucene.Net.Search Namespace


WildcardQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

WildcardQuery Class | Lucene.Net.Search Namespace


WildcardTermEnum Class

For a list of all members of this type, see WildcardTermEnum Members.

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Search.FilteredTermEnum
Lucene.Net.Search.WildcardTermEnum

public class WildcardTermEnum : FilteredTermEnum

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

WildcardTermEnum Members | Lucene.Net.Search Namespace


WildcardTermEnum Members

WildcardTermEnum overview

Public Static Fields

WILDCARD_CHAR |
WILDCARD_STRING | ***************************************** String equality with support for wildcards ******************************************

Public Static Methods

WildcardEquals Determines if a word matches a wildcard pattern. Work released by Granta Design Ltd after originally being done on company time.

Public Instance Constructors

WildcardTermEnum Constructor

Public Instance Methods

Close |
Difference |
DocFreq (inherited from FilteredTermEnum) | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
EndEnum |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from FilteredTermEnum) | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term (inherited from FilteredTermEnum) | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SetEnum (inherited from FilteredTermEnum)
TermCompare

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum Constructor

public WildcardTermEnum(
IndexReader reader,
Term term
);

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum Fields

The fields of the WildcardTermEnum class are listed below. For a complete list of WildcardTermEnum class members, see the WildcardTermEnum Members topic.

Public Static Fields

WILDCARD_CHAR |
WILDCARD_STRING | ***************************************** String equality with support for wildcards ******************************************

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.WILDCARD_CHAR Field

public const char WILDCARD_CHAR = ?;

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.WILDCARD_STRING Field

***************************************** String equality with support for wildcards ******************************************

public const char WILDCARD_STRING = *;

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum Methods

The methods of the WildcardTermEnum class are listed below. For a complete list of WildcardTermEnum class members, see the WildcardTermEnum Members topic.

Public Static Methods

WildcardEquals Determines if a word matches a wildcard pattern. Work released by Granta Design Ltd after originally being done on company time.

Public Instance Methods

Close |
Difference |
DocFreq (inherited from FilteredTermEnum) | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
EndEnum |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from FilteredTermEnum) | Increments the enumeration to the next element. True if one exists.
SkipTo (inherited from TermEnum) |
Term (inherited from FilteredTermEnum) | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SetEnum (inherited from FilteredTermEnum)
TermCompare

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.Close Method

public override void Close();

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.Difference Method

public override float Difference();

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.EndEnum Method

public override bool EndEnum();

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.TermCompare Method

protected internal override bool TermCompare(
Term term
);

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


WildcardTermEnum.WildcardEquals Method

Determines if a word matches a wildcard pattern. Work released by Granta Design Ltd after originally being done on company time.

public static bool WildcardEquals(
string pattern,
int patternIdx,
string string_Renamed,
int stringIdx
);

See Also

WildcardTermEnum Class | Lucene.Net.Search Namespace


Lucene.Net.Search.Function

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Search.Function Namespace

Namespace hierarchy

Classes

Class | Description
ByteFieldSource |
CustomScoreQuery |
DocValues |
FieldCacheSource |
FieldScoreQuery |
FieldScoreQuery.Type |
FloatFieldSource |
IntFieldSource |
OrdFieldSource |
ReverseOrdFieldSource |
ShortFieldSource |
ValueSource |
ValueSourceQuery |


ByteFieldSource Class

For a list of all members of this type, see ByteFieldSource Members.

System.Object
Lucene.Net.Search.Function.ValueSource
Lucene.Net.Search.Function.FieldCacheSource
Lucene.Net.Search.Function.ByteFieldSource

public class ByteFieldSource : FieldCacheSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ByteFieldSource Members | Lucene.Net.Search.Function Namespace


ByteFieldSource Members

ByteFieldSource overview

Public Instance Constructors

ByteFieldSource Overloaded. Initializes a new instance of the ByteFieldSource class.

Public Instance Methods

CachedFieldSourceEquals |
CachedFieldSourceHashCode |
Description |
Equals (inherited from FieldCacheSource) |
GetCachedFieldValues |
GetHashCode (inherited from FieldCacheSource) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues (inherited from FieldCacheSource) |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ByteFieldSource Class | Lucene.Net.Search.Function Namespace


ByteFieldSource Constructor

Create a cached byte field source with default string-to-byte parser.

Overload List

Create a cached byte field source with default string-to-byte parser.

public ByteFieldSource(string);

Create a cached byte field source with a specific string-to-byte parser.

public ByteFieldSource(string,ByteParser);

See Also

ByteFieldSource Class | Lucene.Net.Search.Function Namespace


ByteFieldSource Constructor (String)

Create a cached byte field source with default string-to-byte parser.

public ByteFieldSource(
string field
);

See Also

ByteFieldSource Class | Lucene.Net.Search.Function Namespace | ByteFieldSource Constructor Overload List


ByteFieldSource Constructor (String, ByteParser)

Create a cached byte field source with a specific string-to-byte parser.

public ByteFieldSource(
string field,
ByteParser parser
);

See Also

ByteFieldSource Class | Lucene.Net.Search.Function Namespace | ByteFieldSource Constructor Overload List


ByteFieldSource Methods

The methods of the ByteFieldSource class are listed below. For a complete list of ByteFieldSource class members, see the ByteFieldSource Members topic.

Public Instance Methods

CachedFieldSourceEquals |
CachedFieldSourceHashCode |
Description |
Equals (inherited from FieldCacheSource) |
GetCachedFieldValues |
GetHashCode (inherited from FieldCacheSource) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues (inherited from FieldCacheSource) |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ByteFieldSource Class | Lucene.Net.Search.Function Namespace


ByteFieldSource.CachedFieldSourceEquals Method

public override bool CachedFieldSourceEquals(
FieldCacheSource o
);

See Also

ByteFieldSource Class | Lucene.Net.Search.Function Namespace


ByteFieldSource.CachedFieldSourceHashCode Method

public override int CachedFieldSourceHashCode();

See Also

ByteFieldSource Class | Lucene.Net.Search.Function Namespace


ByteFieldSource.Description Method

public override string Description();

See Also

ByteFieldSource Class | Lucene.Net.Search.Function Namespace


ByteFieldSource.GetCachedFieldValues Method

public override DocValues GetCachedFieldValues(
FieldCache cache,
string field,
IndexReader reader
);

See Also

ByteFieldSource Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery Class

For a list of all members of this type, see CustomScoreQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Function.CustomScoreQuery

public class CustomScoreQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CustomScoreQuery Members | Lucene.Net.Search.Function Namespace


CustomScoreQuery Members

CustomScoreQuery overview

Public Instance Constructors

CustomScoreQuery Overloaded. Initializes a new instance of the CustomScoreQuery class.

Public Instance Methods

Clone
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CustomExplain | Overloaded. Explain the custom score. Whenever overriding {@link #CustomScore(int, float, float[])}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.
CustomScore | Overloaded.
Equals Returns true if
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStrict
Name | A short name of this query, used in {@link #ToString(String)}.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
SetStrict | Set the strict mode of this query.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery Constructor

Create a CustomScoreQuery over input subQuery.

Overload List

Create a CustomScoreQuery over input subQuery.

public CustomScoreQuery(Query);

Create a CustomScoreQuery over input subQuery and a {@link ValueSourceQuery}.

public CustomScoreQuery(Query,ValueSourceQuery);

Create a CustomScoreQuery over input subQuery and a {@link ValueSourceQuery}.

public CustomScoreQuery(Query,ValueSourceQuery[]);

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery Constructor (Query)

Create a CustomScoreQuery over input subQuery.

public CustomScoreQuery(
Query subQuery
);

Parameters

subQuery
the sub query whose scored is being customed. Must not be null.

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace | CustomScoreQuery Constructor Overload List


CustomScoreQuery Constructor (Query, ValueSourceQuery)

Create a CustomScoreQuery over input subQuery and a {@link ValueSourceQuery}.

public CustomScoreQuery(
Query subQuery,
ValueSourceQuery valSrcQuery
);

Parameters

subQuery
the sub query whose score is being customed. Must not be null.
valSrcQuery
a value source query whose scores are used in the custom score computation. For most simple/convineient use case this would be a {@link Lucene.Net.Search.Function.FieldScoreQuery FieldScoreQuery}. This parameter is optional - it can be null.

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace | CustomScoreQuery Constructor Overload List


CustomScoreQuery Constructor (Query, ValueSourceQuery[])

Create a CustomScoreQuery over input subQuery and a {@link ValueSourceQuery}.

public CustomScoreQuery(
Query subQuery,
ValueSourceQuery[] valSrcQueries
);

Parameters

subQuery
the sub query whose score is being customed. Must not be null.
valSrcQueries
value source queries whose scores are used in the custom score computation. For most simple/convineient use case these would be {@link Lucene.Net.Search.Function.FieldScoreQuery FieldScoreQueries}. This parameter is optional - it can be null or even an empty array.

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace | CustomScoreQuery Constructor Overload List


CustomScoreQuery Methods

The methods of the CustomScoreQuery class are listed below. For a complete list of CustomScoreQuery class members, see the CustomScoreQuery Members topic.

Public Instance Methods

Clone
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CustomExplain | Overloaded. Explain the custom score. Whenever overriding {@link #CustomScore(int, float, float[])}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.
CustomScore | Overloaded.
Equals Returns true if
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStrict
Name | A short name of this query, used in {@link #ToString(String)}.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
SetStrict | Set the strict mode of this query.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomExplain Method

Apache Lucene.Net 2.4.0 Class Library API

CustomScoreQuery.CustomExplain Method

Explain the custom score. Whenever overriding {@link #CustomScore(int, float, float)}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.

Overload List

Explain the custom score. Whenever overriding {@link #CustomScore(int, float, float)}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.

public virtual Explanation CustomExplain(int,Explanation,Explanation);

Explain the custom score. Whenever overriding {@link #CustomScore(int, float, float[])}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.

public virtual Explanation CustomExplain(int,Explanation,Explanation[]);

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery.CustomExplain Method (Int32, Explanation, Explanation)

Explain the custom score. Whenever overriding {@link #CustomScore(int, float, float)}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.

public virtual Explanation CustomExplain(
int doc,
Explanation subQueryExpl,
Explanation valSrcExpl
);

Parameters

doc
doc being explained.
subQueryExpl
explanation for the sub-query part.
valSrcExpl
explanation for the value source part.

Return Value

an explanation for the custom score

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace | CustomScoreQuery.CustomExplain Overload List


CustomScoreQuery.CustomExplain Method (Int32, Explanation, Explanation[])

Explain the custom score. Whenever overriding {@link #CustomScore(int, float, float[])}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.

public virtual Explanation CustomExplain(
int doc,
Explanation subQueryExpl,
Explanation[] valSrcExpls
);

Parameters

doc
doc being explained.
subQueryExpl
explanation for the sub-query part.
valSrcExpls
explanation for the value source part.

Return Value

an explanation for the custom score

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace | CustomScoreQuery.CustomExplain Overload List


CustomScore Method

Apache Lucene.Net 2.4.0 Class Library API

CustomScoreQuery.CustomScore Method

Overload List

public virtual float CustomScore(int,float,float);

public virtual float CustomScore(int,float,float[]);

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery.CustomScore Method (Int32, Single, Single)

public virtual float CustomScore(
int doc,
float subQueryScore,
float valSrcScore
);

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace | CustomScoreQuery.CustomScore Overload List


CustomScoreQuery.CustomScore Method (Int32, Single, Single[])

public virtual float CustomScore(
int doc,
float subQueryScore,
float[] valSrcScores
);

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace | CustomScoreQuery.CustomScore Overload List


CustomScoreQuery.Equals Method

Returns true if

o
is equal to this.

public override bool Equals(
object o
);

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery.IsStrict Method

public virtual bool IsStrict();

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery.Name Method

A short name of this query, used in {@link #ToString(String)}.

public virtual string Name();

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery.SetStrict Method

Set the strict mode of this query.

public virtual void SetStrict(
bool strict
);

Parameters

strict
The strict mode to set.

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace |


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

CustomScoreQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace


CustomScoreQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

CustomScoreQuery Class | Lucene.Net.Search.Function Namespace | CustomScoreQuery.ToString Overload List


DocValues Class

For a list of all members of this type, see DocValues Members.

System.Object
Lucene.Net.Search.Function.DocValues

public abstract class DocValues

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DocValues Members | Lucene.Net.Search.Function Namespace


DocValues Members

DocValues overview

Public Instance Methods

DoubleVal |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain | Explain the scoring value for the input doc.
FloatVal |
GetAverageValue | Returns the average of all values.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInnerArray |
GetMaxValue | Optional op. Returns the maximum of all values.
GetMinValue | Optional op. Returns the minimum of all values.
GetType (inherited from Object) | Gets the Type of the current instance.
IntVal |
LongVal |
StrVal |
ToString | Overloaded. Return a string representation of a doc value, as reuired for Explanations.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Constructors

DocValues Constructor Initializes a new instance of the DocValues class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues Constructor

Initializes a new instance of the DocValues class.

protected DocValues();

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues Methods

The methods of the DocValues class are listed below. For a complete list of DocValues class members, see the DocValues Members topic.

Public Instance Methods

DoubleVal |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain | Explain the scoring value for the input doc.
FloatVal |
GetAverageValue | Returns the average of all values.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInnerArray |
GetMaxValue | Optional op. Returns the maximum of all values.
GetMinValue | Optional op. Returns the minimum of all values.
GetType (inherited from Object) | Gets the Type of the current instance.
IntVal |
LongVal |
StrVal |
ToString | Overloaded. Return a string representation of a doc value, as reuired for Explanations.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues.DoubleVal Method

public virtual double DoubleVal(
int doc
);

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues.Explain Method

Explain the scoring value for the input doc.

public virtual Explanation Explain(
int doc
);

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues.FloatVal Method

public abstract float FloatVal(
int doc
);

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues.GetAverageValue Method

Returns the average of all values.

public virtual float GetAverageValue();

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues.GetInnerArray Method

public virtual object GetInnerArray();

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues.GetMaxValue Method

Optional op. Returns the maximum of all values.

public virtual float GetMaxValue();

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues.GetMinValue Method

Optional op. Returns the minimum of all values.

public virtual float GetMinValue();

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues.IntVal Method

public virtual int IntVal(
int doc
);

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues.LongVal Method

public virtual long LongVal(
int doc
);

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues.StrVal Method

public virtual string StrVal(
int doc
);

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

DocValues.ToString Method

Return a string representation of a doc value, as reuired for Explanations.

Overload List

Inherited from Object.

public virtual string ToString();

Return a string representation of a doc value, as reuired for Explanations.

public abstract string ToString(int);

See Also

DocValues Class | Lucene.Net.Search.Function Namespace


DocValues.ToString Method (Int32)

Return a string representation of a doc value, as reuired for Explanations.

public abstract string ToString(
int doc
);

See Also

DocValues Class | Lucene.Net.Search.Function Namespace | DocValues.ToString Overload List


FieldCacheSource Class

For a list of all members of this type, see FieldCacheSource Members.

System.Object
Lucene.Net.Search.Function.ValueSource
Lucene.Net.Search.Function.FieldCacheSource
Lucene.Net.Search.Function.ByteFieldSource
Lucene.Net.Search.Function.FloatFieldSource
Lucene.Net.Search.Function.IntFieldSource
Lucene.Net.Search.Function.ShortFieldSource

public abstract class FieldCacheSource : ValueSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldCacheSource Members | Lucene.Net.Search.Function Namespace


FieldCacheSource Members

FieldCacheSource overview

Public Instance Constructors

FieldCacheSource Constructor Create a cached field source for the input field.

Public Instance Methods

CachedFieldSourceEquals | Check if equals to another {@link FieldCacheSource}, already knowing that cache and field are equal.
CachedFieldSourceHashCode | Return a hash code of a {@link FieldCacheSource}, without the hash-codes of the field and the cache (those are taken care of elsewhere).
Description |
Equals |
GetCachedFieldValues | Return cached DocValues for input field and reader.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldCacheSource Class | Lucene.Net.Search.Function Namespace


FieldCacheSource Constructor

Create a cached field source for the input field.

public FieldCacheSource(
string field
);

See Also

FieldCacheSource Class | Lucene.Net.Search.Function Namespace


FieldCacheSource Methods

The methods of the FieldCacheSource class are listed below. For a complete list of FieldCacheSource class members, see the FieldCacheSource Members topic.

Public Instance Methods

CachedFieldSourceEquals | Check if equals to another {@link FieldCacheSource}, already knowing that cache and field are equal.
CachedFieldSourceHashCode | Return a hash code of a {@link FieldCacheSource}, without the hash-codes of the field and the cache (those are taken care of elsewhere).
Description |
Equals |
GetCachedFieldValues | Return cached DocValues for input field and reader.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldCacheSource Class | Lucene.Net.Search.Function Namespace


FieldCacheSource.CachedFieldSourceEquals Method

Check if equals to another {@link FieldCacheSource}, already knowing that cache and field are equal.

public abstract bool CachedFieldSourceEquals(
FieldCacheSource other
);

See Also

FieldCacheSource Class | Lucene.Net.Search.Function Namespace | equals


FieldCacheSource.CachedFieldSourceHashCode Method

Return a hash code of a {@link FieldCacheSource}, without the hash-codes of the field and the cache (those are taken care of elsewhere).

public abstract int CachedFieldSourceHashCode();

See Also

FieldCacheSource Class | Lucene.Net.Search.Function Namespace | hashCode


FieldCacheSource.Description Method

public override string Description();

See Also

FieldCacheSource Class | Lucene.Net.Search.Function Namespace


FieldCacheSource.Equals Method

public override bool Equals(
object o
);

See Also

FieldCacheSource Class | Lucene.Net.Search.Function Namespace


FieldCacheSource.GetCachedFieldValues Method

Return cached DocValues for input field and reader.

public abstract DocValues GetCachedFieldValues(
FieldCache cache,
string field,
IndexReader reader
);

Parameters

cache
FieldCache so that values of a field are loaded once per reader (RAM allowing)
field
Field for which values are required.
reader

See Also

FieldCacheSource Class | Lucene.Net.Search.Function Namespace |


FieldCacheSource.GetHashCode Method

public override int GetHashCode();

See Also

FieldCacheSource Class | Lucene.Net.Search.Function Namespace


FieldCacheSource.GetValues Method

public override DocValues GetValues(
IndexReader reader
);

See Also

FieldCacheSource Class | Lucene.Net.Search.Function Namespace


FieldScoreQuery Class

For a list of all members of this type, see FieldScoreQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Function.ValueSourceQuery
Lucene.Net.Search.Function.FieldScoreQuery

public class FieldScoreQuery : ValueSourceQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldScoreQuery Members | Lucene.Net.Search.Function Namespace


FieldScoreQuery Members

FieldScoreQuery overview

Public Instance Constructors

FieldScoreQuery Constructor

Public Instance Properties

ValSrc_ForNUnitTest (inherited from ValueSourceQuery)

Public Instance Methods

Clone (inherited from ValueSourceQuery)
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals (inherited from ValueSourceQuery) Returns true if
o
is equal to this.
ExtractTerms (inherited from ValueSourceQuery)
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode (inherited from ValueSourceQuery) | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from ValueSourceQuery)
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString (inherited from ValueSourceQuery) | Overloaded. Prints a query to a string.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from ValueSourceQuery)

See Also

FieldScoreQuery Class | Lucene.Net.Search.Function Namespace


FieldScoreQuery Constructor

public FieldScoreQuery(
string field,
Type type
);

See Also

FieldScoreQuery Class | Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type Class

For a list of all members of this type, see FieldScoreQuery.Type Members.

System.Object
Lucene.Net.Search.Function.FieldScoreQuery.Type

public class FieldScoreQuery.Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FieldScoreQuery.Type Members | Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type Members

FieldScoreQuery.Type overview

Public Static Fields

BYTE | field values are interpreted as numeric byte values.
FLOAT | field values are interpreted as numeric float values.
INT | field values are interpreted as numeric int values.
SHORT | field values are interpreted as numeric short values.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldScoreQuery.Type Class | Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type Fields

The fields of the FieldScoreQuery.Type class are listed below. For a complete list of FieldScoreQuery.Type class members, see the FieldScoreQuery.Type Members topic.

Public Static Fields

BYTE | field values are interpreted as numeric byte values.
FLOAT | field values are interpreted as numeric float values.
INT | field values are interpreted as numeric int values.
SHORT | field values are interpreted as numeric short values.

See Also

FieldScoreQuery.Type Class | Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type.BYTE Field

field values are interpreted as numeric byte values.

public static readonly Type BYTE;

See Also

FieldScoreQuery.Type Class | Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type.FLOAT Field

field values are interpreted as numeric float values.

public static readonly Type FLOAT;

See Also

FieldScoreQuery.Type Class | Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type.INT Field

field values are interpreted as numeric int values.

public static readonly Type INT;

See Also

FieldScoreQuery.Type Class | Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type.SHORT Field

field values are interpreted as numeric short values.

public static readonly Type SHORT;

See Also

FieldScoreQuery.Type Class | Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type Methods

The methods of the FieldScoreQuery.Type class are listed below. For a complete list of FieldScoreQuery.Type class members, see the FieldScoreQuery.Type Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldScoreQuery.Type Class | Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type.ToString Method

public override string ToString();

See Also

FieldScoreQuery.Type Class | Lucene.Net.Search.Function Namespace


FloatFieldSource Class

For a list of all members of this type, see FloatFieldSource Members.

System.Object
Lucene.Net.Search.Function.ValueSource
Lucene.Net.Search.Function.FieldCacheSource
Lucene.Net.Search.Function.FloatFieldSource

public class FloatFieldSource : FieldCacheSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FloatFieldSource Members | Lucene.Net.Search.Function Namespace


FloatFieldSource Members

FloatFieldSource overview

Public Instance Constructors

FloatFieldSource Overloaded. Initializes a new instance of the FloatFieldSource class.

Public Instance Methods

CachedFieldSourceEquals |
CachedFieldSourceHashCode |
Description |
Equals (inherited from FieldCacheSource) |
GetCachedFieldValues |
GetHashCode (inherited from FieldCacheSource) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues (inherited from FieldCacheSource) |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FloatFieldSource Class | Lucene.Net.Search.Function Namespace


FloatFieldSource Constructor

Create a cached float field source with default string-to-float parser.

Overload List

Create a cached float field source with default string-to-float parser.

public FloatFieldSource(string);

Create a cached float field source with a specific string-to-float parser.

public FloatFieldSource(string,FloatParser);

See Also

FloatFieldSource Class | Lucene.Net.Search.Function Namespace


FloatFieldSource Constructor (String)

Create a cached float field source with default string-to-float parser.

public FloatFieldSource(
string field
);

See Also

FloatFieldSource Class | Lucene.Net.Search.Function Namespace | FloatFieldSource Constructor Overload List


FloatFieldSource Constructor (String, FloatParser)

Create a cached float field source with a specific string-to-float parser.

public FloatFieldSource(
string field,
FloatParser parser
);

See Also

FloatFieldSource Class | Lucene.Net.Search.Function Namespace | FloatFieldSource Constructor Overload List


FloatFieldSource Methods

The methods of the FloatFieldSource class are listed below. For a complete list of FloatFieldSource class members, see the FloatFieldSource Members topic.

Public Instance Methods

CachedFieldSourceEquals |
CachedFieldSourceHashCode |
Description |
Equals (inherited from FieldCacheSource) |
GetCachedFieldValues |
GetHashCode (inherited from FieldCacheSource) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues (inherited from FieldCacheSource) |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FloatFieldSource Class | Lucene.Net.Search.Function Namespace


FloatFieldSource.CachedFieldSourceEquals Method

public override bool CachedFieldSourceEquals(
FieldCacheSource o
);

See Also

FloatFieldSource Class | Lucene.Net.Search.Function Namespace


FloatFieldSource.CachedFieldSourceHashCode Method

public override int CachedFieldSourceHashCode();

See Also

FloatFieldSource Class | Lucene.Net.Search.Function Namespace


FloatFieldSource.Description Method

public override string Description();

See Also

FloatFieldSource Class | Lucene.Net.Search.Function Namespace


FloatFieldSource.GetCachedFieldValues Method

public override DocValues GetCachedFieldValues(
FieldCache cache,
string field,
IndexReader reader
);

See Also

FloatFieldSource Class | Lucene.Net.Search.Function Namespace


IntFieldSource Class

For a list of all members of this type, see IntFieldSource Members.

System.Object
Lucene.Net.Search.Function.ValueSource
Lucene.Net.Search.Function.FieldCacheSource
Lucene.Net.Search.Function.IntFieldSource

public class IntFieldSource : FieldCacheSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IntFieldSource Members | Lucene.Net.Search.Function Namespace


IntFieldSource Members

IntFieldSource overview

Public Instance Constructors

IntFieldSource Overloaded. Initializes a new instance of the IntFieldSource class.

Public Instance Methods

CachedFieldSourceEquals |
CachedFieldSourceHashCode |
Description |
Equals (inherited from FieldCacheSource) |
GetCachedFieldValues |
GetHashCode (inherited from FieldCacheSource) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues (inherited from FieldCacheSource) |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IntFieldSource Class | Lucene.Net.Search.Function Namespace


IntFieldSource Constructor

Create a cached int field source with default string-to-int parser.

Overload List

Create a cached int field source with default string-to-int parser.

public IntFieldSource(string);

Create a cached int field source with a specific string-to-int parser.

public IntFieldSource(string,IntParser);

See Also

IntFieldSource Class | Lucene.Net.Search.Function Namespace


IntFieldSource Constructor (String)

Create a cached int field source with default string-to-int parser.

public IntFieldSource(
string field
);

See Also

IntFieldSource Class | Lucene.Net.Search.Function Namespace | IntFieldSource Constructor Overload List


IntFieldSource Constructor (String, IntParser)

Create a cached int field source with a specific string-to-int parser.

public IntFieldSource(
string field,
IntParser parser
);

See Also

IntFieldSource Class | Lucene.Net.Search.Function Namespace | IntFieldSource Constructor Overload List


IntFieldSource Methods

The methods of the IntFieldSource class are listed below. For a complete list of IntFieldSource class members, see the IntFieldSource Members topic.

Public Instance Methods

CachedFieldSourceEquals |
CachedFieldSourceHashCode |
Description |
Equals (inherited from FieldCacheSource) |
GetCachedFieldValues |
GetHashCode (inherited from FieldCacheSource) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues (inherited from FieldCacheSource) |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IntFieldSource Class | Lucene.Net.Search.Function Namespace


IntFieldSource.CachedFieldSourceEquals Method

public override bool CachedFieldSourceEquals(
FieldCacheSource o
);

See Also

IntFieldSource Class | Lucene.Net.Search.Function Namespace


IntFieldSource.CachedFieldSourceHashCode Method

public override int CachedFieldSourceHashCode();

See Also

IntFieldSource Class | Lucene.Net.Search.Function Namespace


IntFieldSource.Description Method

public override string Description();

See Also

IntFieldSource Class | Lucene.Net.Search.Function Namespace


IntFieldSource.GetCachedFieldValues Method

public override DocValues GetCachedFieldValues(
FieldCache cache,
string field,
IndexReader reader
);

See Also

IntFieldSource Class | Lucene.Net.Search.Function Namespace


OrdFieldSource Class

For a list of all members of this type, see OrdFieldSource Members.

System.Object
Lucene.Net.Search.Function.ValueSource
Lucene.Net.Search.Function.OrdFieldSource

public class OrdFieldSource : ValueSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

OrdFieldSource Members | Lucene.Net.Search.Function Namespace


OrdFieldSource Members

OrdFieldSource overview

Public Instance Constructors

OrdFieldSource Constructor Contructor for a certain field.

Public Instance Methods

Description |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

field

See Also

OrdFieldSource Class | Lucene.Net.Search.Function Namespace


OrdFieldSource Constructor

Contructor for a certain field.

public OrdFieldSource(
string field
);

Parameters

field
field whose values order is used.

See Also

OrdFieldSource Class | Lucene.Net.Search.Function Namespace


OrdFieldSource Fields

The fields of the OrdFieldSource class are listed below. For a complete list of OrdFieldSource class members, see the OrdFieldSource Members topic.

Protected Internal Instance Fields

field

See Also

OrdFieldSource Class | Lucene.Net.Search.Function Namespace


OrdFieldSource.field Field

protected internal string field;

See Also

OrdFieldSource Class | Lucene.Net.Search.Function Namespace


OrdFieldSource Methods

The methods of the OrdFieldSource class are listed below. For a complete list of OrdFieldSource class members, see the OrdFieldSource Members topic.

Public Instance Methods

Description |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrdFieldSource Class | Lucene.Net.Search.Function Namespace


OrdFieldSource.Description Method

public override string Description();

See Also

OrdFieldSource Class | Lucene.Net.Search.Function Namespace


OrdFieldSource.Equals Method

public override bool Equals(
object o
);

See Also

OrdFieldSource Class | Lucene.Net.Search.Function Namespace


OrdFieldSource.GetHashCode Method

public override int GetHashCode();

See Also

OrdFieldSource Class | Lucene.Net.Search.Function Namespace


OrdFieldSource.GetValues Method

public override DocValues GetValues(
IndexReader reader
);

See Also

OrdFieldSource Class | Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource Class

For a list of all members of this type, see ReverseOrdFieldSource Members.

System.Object
Lucene.Net.Search.Function.ValueSource
Lucene.Net.Search.Function.ReverseOrdFieldSource

public class ReverseOrdFieldSource : ValueSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ReverseOrdFieldSource Members | Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource Members

ReverseOrdFieldSource overview

Public Instance Constructors

ReverseOrdFieldSource Constructor Contructor for a certain field.

Public Instance Fields

field

Public Instance Methods

Description |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReverseOrdFieldSource Class | Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource Constructor

Contructor for a certain field.

public ReverseOrdFieldSource(
string field
);

Parameters

field
field whose values reverse order is used.

See Also

ReverseOrdFieldSource Class | Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource Fields

The fields of the ReverseOrdFieldSource class are listed below. For a complete list of ReverseOrdFieldSource class members, see the ReverseOrdFieldSource Members topic.

Public Instance Fields

field

See Also

ReverseOrdFieldSource Class | Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource.field Field

public string field;

See Also

ReverseOrdFieldSource Class | Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource Methods

The methods of the ReverseOrdFieldSource class are listed below. For a complete list of ReverseOrdFieldSource class members, see the ReverseOrdFieldSource Members topic.

Public Instance Methods

Description |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReverseOrdFieldSource Class | Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource.Description Method

public override string Description();

See Also

ReverseOrdFieldSource Class | Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource.Equals Method

public override bool Equals(
object o
);

See Also

ReverseOrdFieldSource Class | Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource.GetHashCode Method

public override int GetHashCode();

See Also

ReverseOrdFieldSource Class | Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource.GetValues Method

public override DocValues GetValues(
IndexReader reader
);

See Also

ReverseOrdFieldSource Class | Lucene.Net.Search.Function Namespace


ShortFieldSource Class

For a list of all members of this type, see ShortFieldSource Members.

System.Object
Lucene.Net.Search.Function.ValueSource
Lucene.Net.Search.Function.FieldCacheSource
Lucene.Net.Search.Function.ShortFieldSource

public class ShortFieldSource : FieldCacheSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ShortFieldSource Members | Lucene.Net.Search.Function Namespace


ShortFieldSource Members

ShortFieldSource overview

Public Instance Constructors

ShortFieldSource Overloaded. Initializes a new instance of the ShortFieldSource class.

Public Instance Methods

CachedFieldSourceEquals |
CachedFieldSourceHashCode |
Description |
Equals (inherited from FieldCacheSource) |
GetCachedFieldValues |
GetHashCode (inherited from FieldCacheSource) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues (inherited from FieldCacheSource) |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShortFieldSource Class | Lucene.Net.Search.Function Namespace


ShortFieldSource Constructor

Create a cached short field source with default string-to-short parser.

Overload List

Create a cached short field source with default string-to-short parser.

public ShortFieldSource(string);

Create a cached short field source with a specific string-to-short parser.

public ShortFieldSource(string,ShortParser);

See Also

ShortFieldSource Class | Lucene.Net.Search.Function Namespace


ShortFieldSource Constructor (String)

Create a cached short field source with default string-to-short parser.

public ShortFieldSource(
string field
);

See Also

ShortFieldSource Class | Lucene.Net.Search.Function Namespace | ShortFieldSource Constructor Overload List


ShortFieldSource Constructor (String, ShortParser)

Create a cached short field source with a specific string-to-short parser.

public ShortFieldSource(
string field,
ShortParser parser
);

See Also

ShortFieldSource Class | Lucene.Net.Search.Function Namespace | ShortFieldSource Constructor Overload List


ShortFieldSource Methods

The methods of the ShortFieldSource class are listed below. For a complete list of ShortFieldSource class members, see the ShortFieldSource Members topic.

Public Instance Methods

CachedFieldSourceEquals |
CachedFieldSourceHashCode |
Description |
Equals (inherited from FieldCacheSource) |
GetCachedFieldValues |
GetHashCode (inherited from FieldCacheSource) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues (inherited from FieldCacheSource) |
ToString (inherited from ValueSource) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShortFieldSource Class | Lucene.Net.Search.Function Namespace


ShortFieldSource.CachedFieldSourceEquals Method

public override bool CachedFieldSourceEquals(
FieldCacheSource o
);

See Also

ShortFieldSource Class | Lucene.Net.Search.Function Namespace


ShortFieldSource.CachedFieldSourceHashCode Method

public override int CachedFieldSourceHashCode();

See Also

ShortFieldSource Class | Lucene.Net.Search.Function Namespace


ShortFieldSource.Description Method

public override string Description();

See Also

ShortFieldSource Class | Lucene.Net.Search.Function Namespace


ShortFieldSource.GetCachedFieldValues Method

public override DocValues GetCachedFieldValues(
FieldCache cache,
string field,
IndexReader reader
);

See Also

ShortFieldSource Class | Lucene.Net.Search.Function Namespace


ValueSource Class

For a list of all members of this type, see ValueSource Members.

System.Object
Lucene.Net.Search.Function.ValueSource
Lucene.Net.Search.Function.FieldCacheSource
Lucene.Net.Search.Function.OrdFieldSource
Lucene.Net.Search.Function.ReverseOrdFieldSource

public abstract class ValueSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ValueSource Members | Lucene.Net.Search.Function Namespace


ValueSource Members

ValueSource overview

Public Instance Methods

Description | description of field, used in explain()
Equals | Needed for possible caching of query results - used by {@link ValueSourceQuery#equals(object)}.
GetHashCode | Needed for possible caching of query results - used by {@link ValueSourceQuery#hashCode()}.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues | Return the DocValues used by the function query.
ToString |

Protected Instance Constructors

ValueSource Constructor Initializes a new instance of the ValueSource class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueSource Class | Lucene.Net.Search.Function Namespace


ValueSource Constructor

Initializes a new instance of the ValueSource class.

protected ValueSource();

See Also

ValueSource Class | Lucene.Net.Search.Function Namespace


ValueSource Methods

The methods of the ValueSource class are listed below. For a complete list of ValueSource class members, see the ValueSource Members topic.

Public Instance Methods

Description | description of field, used in explain()
Equals | Needed for possible caching of query results - used by {@link ValueSourceQuery#equals(object)}.
GetHashCode | Needed for possible caching of query results - used by {@link ValueSourceQuery#hashCode()}.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues | Return the DocValues used by the function query.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueSource Class | Lucene.Net.Search.Function Namespace


ValueSource.Description Method

description of field, used in explain()

public abstract string Description();

See Also

ValueSource Class | Lucene.Net.Search.Function Namespace


ValueSource.Equals Method

Needed for possible caching of query results - used by {@link ValueSourceQuery#equals(object)}.

public abstract bool Equals(
object o
);

See Also

ValueSource Class | Lucene.Net.Search.Function Namespace | equals


ValueSource.GetHashCode Method

Needed for possible caching of query results - used by {@link ValueSourceQuery#hashCode()}.

public abstract int GetHashCode();

See Also

ValueSource Class | Lucene.Net.Search.Function Namespace | hashCode


ValueSource.GetValues Method

Return the DocValues used by the function query.

public abstract DocValues GetValues(
IndexReader reader
);

Parameters

reader
the IndexReader used to read these values. If any caching is involved, that caching would also be IndexReader based.

See Also

ValueSource Class | Lucene.Net.Search.Function Namespace


ValueSource.ToString Method

public override string ToString();

See Also

ValueSource Class | Lucene.Net.Search.Function Namespace


ValueSourceQuery Class

For a list of all members of this type, see ValueSourceQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Function.ValueSourceQuery
Lucene.Net.Search.Function.FieldScoreQuery

public class ValueSourceQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Function

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ValueSourceQuery Members | Lucene.Net.Search.Function Namespace


ValueSourceQuery Members

ValueSourceQuery overview

Public Instance Constructors

ValueSourceQuery Constructor Create a value source query

Public Instance Properties

ValSrc_ForNUnitTest

Public Instance Methods

Clone
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true if
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace


ValueSourceQuery Constructor

Create a value source query

public ValueSourceQuery(
ValueSource valSrc
);

Parameters

valSrc
provides the values defines the function to be used for scoring

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace


ValueSourceQuery Properties

The properties of the ValueSourceQuery class are listed below. For a complete list of ValueSourceQuery class members, see the ValueSourceQuery Members topic.

Public Instance Properties

ValSrc_ForNUnitTest

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace


ValSrc_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

ValueSourceQuery.ValSrc_ForNUnitTest Property

public ValueSource ValSrc_ForNUnitTest {get;}

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace


ValueSourceQuery Methods

The methods of the ValueSourceQuery class are listed below. For a complete list of ValueSourceQuery class members, see the ValueSourceQuery Members topic.

Public Instance Methods

Clone
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Equals Returns true if
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetHashCode | Returns a hash code value for this object.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace


ValueSourceQuery.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace


ValueSourceQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace


ValueSourceQuery.Equals Method

Returns true if

o
is equal to this.

public override bool Equals(
object o
);

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace


ValueSourceQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace


ValueSourceQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace


ValueSourceQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

ValueSourceQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace


ValueSourceQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

ValueSourceQuery Class | Lucene.Net.Search.Function Namespace | ValueSourceQuery.ToString Overload List


Lucene.Net.Search.Payloads

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Search.Payloads Namespace

Namespace hierarchy

Classes

Class | Description
BoostingTermQuery |
BoostingTermQuery.BoostingTermWeight |
BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer |
PayloadSpanUtil | Experimental class to get set of payloads for most standard Lucene queries. Operates like Highlighter - IndexReader should only contain doc of interest, best to use MemoryIndex. WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.


BoostingTermQuery Class

For a list of all members of this type, see BoostingTermQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanTermQuery
Lucene.Net.Search.Payloads.BoostingTermQuery

public class BoostingTermQuery : SpanTermQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Payloads

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BoostingTermQuery Members | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery Members

BoostingTermQuery overview

Public Instance Constructors

BoostingTermQuery Constructor

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest (inherited from SpanQuery)
Equals
ExtractTerms (inherited from SpanTermQuery)
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField (inherited from SpanTermQuery)
GetHashCode
GetPayloadSpans (inherited from SpanTermQuery)
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans (inherited from SpanTermQuery)
GetTerm (inherited from SpanTermQuery) | Return the term whose spans are matched.
GetTerms (inherited from SpanTermQuery) | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString (inherited from SpanTermQuery) | Overloaded. Prints a query to a string.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

term (inherited from SpanTermQuery)

Protected Internal Instance Methods

CreateWeight

See Also

BoostingTermQuery Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery Constructor

public BoostingTermQuery(
Term term
);

See Also

BoostingTermQuery Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery Methods

The methods of the BoostingTermQuery class are listed below. For a complete list of BoostingTermQuery class members, see the BoostingTermQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest (inherited from SpanQuery)
Equals
ExtractTerms (inherited from SpanTermQuery)
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField (inherited from SpanTermQuery)
GetHashCode
GetPayloadSpans (inherited from SpanTermQuery)
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans (inherited from SpanTermQuery)
GetTerm (inherited from SpanTermQuery) | Return the term whose spans are matched.
GetTerms (inherited from SpanTermQuery) | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString (inherited from SpanTermQuery) | Overloaded. Prints a query to a string.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

BoostingTermQuery Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

BoostingTermQuery Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.Equals Method

public override bool Equals(
object o
);

See Also

BoostingTermQuery Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.GetHashCode Method

public override int GetHashCode();

See Also

BoostingTermQuery Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight Class

For a list of all members of this type, see BoostingTermQuery.BoostingTermWeight Members.

System.Object
Lucene.Net.Search.Spans.SpanWeight
Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight

protected internal class BoostingTermQuery.BoostingTermWeight : SpanWeight

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Payloads

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BoostingTermQuery.BoostingTermWeight Members | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight Members

BoostingTermQuery.BoostingTermWeight overview

Public Instance Constructors

BoostingTermQuery.BoostingTermWeight Constructor

Public Instance Properties

Enclosing_Instance

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain (inherited from SpanWeight) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery (inherited from SpanWeight) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from SpanWeight) |
Normalize (inherited from SpanWeight) |
Scorer |
SumOfSquaredWeights (inherited from SpanWeight) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

idf (inherited from SpanWeight)
query (inherited from SpanWeight)
queryNorm (inherited from SpanWeight)
queryWeight (inherited from SpanWeight)
similarity (inherited from SpanWeight)
terms (inherited from SpanWeight)
value_Renamed (inherited from SpanWeight)

See Also

BoostingTermQuery.BoostingTermWeight Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight Constructor

public BoostingTermQuery.BoostingTermWeight(
BoostingTermQuery enclosingInstance,
BoostingTermQuery query,
Searcher searcher
);

See Also

BoostingTermQuery.BoostingTermWeight Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight Properties

The properties of the BoostingTermQuery.BoostingTermWeight class are listed below. For a complete list of BoostingTermQuery.BoostingTermWeight class members, see the BoostingTermQuery.BoostingTermWeight Members topic.

Public Instance Properties

Enclosing_Instance

See Also

BoostingTermQuery.BoostingTermWeight Class | Lucene.Net.Search.Payloads Namespace


Enclosing_Instance Property

Apache Lucene.Net 2.4.0 Class Library API

BoostingTermQuery.BoostingTermWeight.Enclosing_Instance Property

public BoostingTermQuery Enclosing_Instance {get;}

See Also

BoostingTermQuery.BoostingTermWeight Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight Methods

The methods of the BoostingTermQuery.BoostingTermWeight class are listed below. For a complete list of BoostingTermQuery.BoostingTermWeight class members, see the BoostingTermQuery.BoostingTermWeight Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain (inherited from SpanWeight) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery (inherited from SpanWeight) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from SpanWeight) |
Normalize (inherited from SpanWeight) |
Scorer |
SumOfSquaredWeights (inherited from SpanWeight) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BoostingTermQuery.BoostingTermWeight Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight.Scorer Method

public override Scorer Scorer(
IndexReader reader
);

Implements

Weight.Scorer

See Also

BoostingTermQuery.BoostingTermWeight Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class

For a list of all members of this type, see BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Members.

System.Object
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Search.Scorer
Lucene.Net.Search.Spans.SpanScorer
Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer

protected internal class BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer : SpanScorer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Payloads

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Members | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Members

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer overview

Public Instance Constructors

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Constructor

Public Instance Properties

Enclosing_Instance

Public Instance Methods

Doc (inherited from SpanScorer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Scorer) | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from SpanScorer) |
Score | Overloaded.
Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SkipTo (inherited from SpanScorer) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

doc (inherited from SpanScorer)
firstTime (inherited from SpanScorer)
freq (inherited from SpanScorer)
more (inherited from SpanScorer)
norms (inherited from SpanScorer)
payloadScore
spans (inherited from SpanScorer)
value_Renamed (inherited from SpanScorer)
weight (inherited from SpanScorer)

Protected Internal Instance Methods

ProcessPayload |
Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SetFreqCurrentDoc |

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Constructor

public BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer(
BoostingTermWeight enclosingInstance,
TermSpans spans,
Weight weight,
Similarity similarity,
byte[] norms
);

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Fields

The fields of the BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer class are listed below. For a complete list of BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer class members, see the BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Members topic.

Protected Internal Instance Fields

doc (inherited from SpanScorer)
firstTime (inherited from SpanScorer)
freq (inherited from SpanScorer)
more (inherited from SpanScorer)
norms (inherited from SpanScorer)
payloadScore
spans (inherited from SpanScorer)
value_Renamed (inherited from SpanScorer)
weight (inherited from SpanScorer)

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer.payloadScore Field

protected internal float payloadScore;

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Properties

The properties of the BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer class are listed below. For a complete list of BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer class members, see the BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Members topic.

Public Instance Properties

Enclosing_Instance

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class | Lucene.Net.Search.Payloads Namespace


Enclosing_Instance Property

Apache Lucene.Net 2.4.0 Class Library API

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer.Enclosing_Instance Property

public BoostingTermQuery.BoostingTermWeight Enclosing_Instance {get;}

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Methods

The methods of the BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer class are listed below. For a complete list of BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer class members, see the BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Members topic.

Public Instance Methods

Doc (inherited from SpanScorer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Scorer) | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next (inherited from SpanScorer) |
Score | Overloaded.
Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SkipTo (inherited from SpanScorer) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

ProcessPayload |
Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SetFreqCurrentDoc |

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer.Explain Method

public override Explanation Explain(
int doc
);

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer.ProcessPayload Method

protected internal virtual void ProcessPayload(
Similarity similarity
);

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class | Lucene.Net.Search.Payloads Namespace


Score Method

Apache Lucene.Net 2.4.0 Class Library API

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer.Score Method

Overload List

public override float Score();

Inherited from Scorer.

public virtual void Score(HitCollector);

Inherited from Scorer.

protected internal virtual bool Score(HitCollector,int);

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class | Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer.Score Method ()

public override float Score();

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class | Lucene.Net.Search.Payloads Namespace | BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer.Score Overload List


BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer.SetFreqCurrentDoc Method

protected internal override bool SetFreqCurrentDoc();

See Also

BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer Class | Lucene.Net.Search.Payloads Namespace


PayloadSpanUtil Class

Experimental class to get set of payloads for most standard Lucene queries. Operates like Highlighter - IndexReader should only contain doc of interest, best to use MemoryIndex.

WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

For a list of all members of this type, see PayloadSpanUtil Members.

System.Object
Lucene.Net.Search.Payloads.PayloadSpanUtil

public class PayloadSpanUtil

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Payloads

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PayloadSpanUtil Members | Lucene.Net.Search.Payloads Namespace


PayloadSpanUtil Members

PayloadSpanUtil overview

Public Instance Constructors

PayloadSpanUtil Constructor @param reader that contains doc with payloads to extract

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPayloadsForQuery | Query should be rewritten for wild/fuzzy support. @param query @return payloads Collection @throws IOException
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PayloadSpanUtil Class | Lucene.Net.Search.Payloads Namespace


PayloadSpanUtil Constructor

@param reader that contains doc with payloads to extract

public PayloadSpanUtil(
IndexReader reader
);

See Also

PayloadSpanUtil Class | Lucene.Net.Search.Payloads Namespace


PayloadSpanUtil Methods

The methods of the PayloadSpanUtil class are listed below. For a complete list of PayloadSpanUtil class members, see the PayloadSpanUtil Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPayloadsForQuery | Query should be rewritten for wild/fuzzy support. @param query @return payloads Collection @throws IOException
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PayloadSpanUtil Class | Lucene.Net.Search.Payloads Namespace


PayloadSpanUtil.GetPayloadsForQuery Method

Query should be rewritten for wild/fuzzy support. @param query @return payloads Collection @throws IOException

public 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetPayloadsForQuery(
Query query
);

See Also

PayloadSpanUtil Class | Lucene.Net.Search.Payloads Namespace


Lucene.Net.Search.Spans

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Search.Spans Namespace

Namespace hierarchy

Classes

Class | Description
SpanFirstQuery | Matches spans near the beginning of a field.
SpanNearQuery | Matches spans which are near one another. One can specify slop, the maximum number of intervening unmatched positions, as well as whether matches are required to be in-order.
SpanNotQuery | Removes matches which overlap with another SpanQuery.
SpanOrQuery | Matches the union of its clauses.
SpanQuery | Base class for span-based queries.
SpanScorer | Public for extension only.
SpanTermQuery | Matches spans containing a term.
SpanWeight | Expert-only. Public for use by other weight implementations
TermSpans | Expert: Public for extension only

Interfaces

Interface | Description
PayloadSpans | WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Spans | Expert: an enumeration of span matches. Used to implement span searching. Each span represents a range of term positions within a document. Matches are enumerated in order, by increasing document number, within that by increasing start position and finally by increasing end position.


PayloadSpans Interface

WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

For a list of all members of this type, see PayloadSpans Members.

public interface PayloadSpans : Spans

Types that implement PayloadSpans

Type | Description
TermSpans | Expert: Public for extension only

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PayloadSpans Members | Lucene.Net.Search.Spans Namespace


PayloadSpans Members

PayloadSpans overview

Public Instance Methods

GetPayload
IsPayloadAvailable

See Also

PayloadSpans Interface | Lucene.Net.Search.Spans Namespace


PayloadSpans Methods

The methods of the PayloadSpans interface are listed below. For a complete list of PayloadSpans interface members, see the PayloadSpans Members topic.

Public Instance Methods

GetPayload
IsPayloadAvailable

See Also

PayloadSpans Interface | Lucene.Net.Search.Spans Namespace


PayloadSpans.GetPayload Method

0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetPayload();

See Also

PayloadSpans Interface | Lucene.Net.Search.Spans Namespace


PayloadSpans.IsPayloadAvailable Method

bool IsPayloadAvailable();

See Also

PayloadSpans Interface | Lucene.Net.Search.Spans Namespace


SpanFirstQuery Class

Matches spans near the beginning of a field.

For a list of all members of this type, see SpanFirstQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanFirstQuery

public class SpanFirstQuery : SpanQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanFirstQuery Members | Lucene.Net.Search.Spans Namespace


SpanFirstQuery Members

SpanFirstQuery overview

Public Instance Constructors

SpanFirstQuery Constructor Construct a SpanFirstQuery matching spans in
match
whose end position is less than or equal to
end
.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest (inherited from SpanQuery)
Equals
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetEnd | Return the maximum end position permitted in a match.
GetField
GetHashCode
GetMatch | Return the SpanQuery whose matches are filtered.
GetPayloadSpans
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery Constructor

Construct a SpanFirstQuery matching spans in

match
whose end position is less than or equal to
end
.

public SpanFirstQuery(
SpanQuery match,
int end
);

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery Methods

The methods of the SpanFirstQuery class are listed below. For a complete list of SpanFirstQuery class members, see the SpanFirstQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest (inherited from SpanQuery)
Equals
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetEnd | Return the maximum end position permitted in a match.
GetField
GetHashCode
GetMatch | Return the SpanQuery whose matches are filtered.
GetPayloadSpans
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.Equals Method

public override bool Equals(
object o
);

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.GetEnd Method

Return the maximum end position permitted in a match.

public virtual int GetEnd();

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.GetField Method

public override string GetField();

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.GetHashCode Method

public override int GetHashCode();

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.GetMatch Method

Return the SpanQuery whose matches are filtered.

public virtual SpanQuery GetMatch();

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.GetPayloadSpans Method

public override PayloadSpans GetPayloadSpans(
IndexReader reader
);

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.GetSpans Method

public override Spans GetSpans(
IndexReader reader
);

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.GetTerms Method

Returns a collection of all terms matched by this query.

public override ICollection GetTerms();

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace | #ExtractTerms


SpanFirstQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

SpanFirstQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace


SpanFirstQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

SpanFirstQuery Class | Lucene.Net.Search.Spans Namespace | SpanFirstQuery.ToString Overload List


SpanNearQuery Class

Matches spans which are near one another. One can specify slop, the maximum number of intervening unmatched positions, as well as whether matches are required to be in-order.

For a list of all members of this type, see SpanNearQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanNearQuery

public class SpanNearQuery : SpanQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanNearQuery Members | Lucene.Net.Search.Spans Namespace


SpanNearQuery Members

SpanNearQuery overview

Public Instance Constructors

SpanNearQuery Constructor Construct a SpanNearQuery. Matches spans matching a span from each clause, with up to
slop
total unmatched positions between them. * When
inOrder
is true, the spans from each clause must be * ordered as in
clauses
.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest (inherited from SpanQuery)
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetClauses | Return the clauses whose spans are matched.
GetField
GetHashCode
GetPayloadSpans
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSlop | Return the maximum number of intervening unmatched positions permitted.
GetSpans
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInOrder | Return true if matches are required to be in-order.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery Constructor

Construct a SpanNearQuery. Matches spans matching a span from each clause, with up to

slop
total unmatched positions between them. * When
inOrder
is true, the spans from each clause must be * ordered as in
clauses
.

public SpanNearQuery(
SpanQuery[] clauses,
int slop,
bool inOrder
);

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery Methods

The methods of the SpanNearQuery class are listed below. For a complete list of SpanNearQuery class members, see the SpanNearQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest (inherited from SpanQuery)
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetClauses | Return the clauses whose spans are matched.
GetField
GetHashCode
GetPayloadSpans
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSlop | Return the maximum number of intervening unmatched positions permitted.
GetSpans
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInOrder | Return true if matches are required to be in-order.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.GetClauses Method

Return the clauses whose spans are matched.

public virtual SpanQuery[] GetClauses();

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.GetField Method

public override string GetField();

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.GetHashCode Method

public override int GetHashCode();

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.GetPayloadSpans Method

public override PayloadSpans GetPayloadSpans(
IndexReader reader
);

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.GetSlop Method

Return the maximum number of intervening unmatched positions permitted.

public virtual int GetSlop();

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.GetSpans Method

public override Spans GetSpans(
IndexReader reader
);

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.GetTerms Method

Returns a collection of all terms matched by this query.

public override ICollection GetTerms();

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace | #ExtractTerms


SpanNearQuery.IsInOrder Method

Return true if matches are required to be in-order.

public virtual bool IsInOrder();

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

SpanNearQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace


SpanNearQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

SpanNearQuery Class | Lucene.Net.Search.Spans Namespace | SpanNearQuery.ToString Overload List


SpanNotQuery Class

Removes matches which overlap with another SpanQuery.

For a list of all members of this type, see SpanNotQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanNotQuery

public class SpanNotQuery : SpanQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanNotQuery Members | Lucene.Net.Search.Spans Namespace


SpanNotQuery Members

SpanNotQuery overview

Public Instance Constructors

SpanNotQuery Constructor Construct a SpanNotQuery matching spans from
include
which have no overlap with spans from
exclude
.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest (inherited from SpanQuery)
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetExclude | Return the SpanQuery whose matches must not overlap those returned.
GetField
GetHashCode
GetInclude | Return the SpanQuery whose matches are filtered.
GetPayloadSpans
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery Constructor

Construct a SpanNotQuery matching spans from

include
which have no overlap with spans from
exclude
.

public SpanNotQuery(
SpanQuery include,
SpanQuery exclude
);

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery Methods

The methods of the SpanNotQuery class are listed below. For a complete list of SpanNotQuery class members, see the SpanNotQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest (inherited from SpanQuery)
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetExclude | Return the SpanQuery whose matches must not overlap those returned.
GetField
GetHashCode
GetInclude | Return the SpanQuery whose matches are filtered.
GetPayloadSpans
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.GetExclude Method

Return the SpanQuery whose matches must not overlap those returned.

public virtual SpanQuery GetExclude();

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.GetField Method

public override string GetField();

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.GetHashCode Method

public override int GetHashCode();

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.GetInclude Method

Return the SpanQuery whose matches are filtered.

public virtual SpanQuery GetInclude();

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.GetPayloadSpans Method

public override PayloadSpans GetPayloadSpans(
IndexReader reader
);

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.GetSpans Method

public override Spans GetSpans(
IndexReader reader
);

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.GetTerms Method

Returns a collection of all terms matched by this query.

public override ICollection GetTerms();

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace | #ExtractTerms


SpanNotQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

SpanNotQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace


SpanNotQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

SpanNotQuery Class | Lucene.Net.Search.Spans Namespace | SpanNotQuery.ToString Overload List


SpanOrQuery Class

Matches the union of its clauses.

For a list of all members of this type, see SpanOrQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanOrQuery

public class SpanOrQuery : SpanQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanOrQuery Members | Lucene.Net.Search.Spans Namespace


SpanOrQuery Members

SpanOrQuery overview

Public Instance Constructors

SpanOrQuery Constructor Construct a SpanOrQuery merging the provided clauses.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest (inherited from SpanQuery)
Equals
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetClauses | Return the clauses whose spans are matched.
GetField
GetHashCode
GetPayloadSpans
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery Constructor

Construct a SpanOrQuery merging the provided clauses.

public SpanOrQuery(
SpanQuery[] clauses
);

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery Methods

The methods of the SpanOrQuery class are listed below. For a complete list of SpanOrQuery class members, see the SpanOrQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest (inherited from SpanQuery)
Equals
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetClauses | Return the clauses whose spans are matched.
GetField
GetHashCode
GetPayloadSpans
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.Equals Method

public override bool Equals(
object o
);

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.GetClauses Method

Return the clauses whose spans are matched.

public virtual SpanQuery[] GetClauses();

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.GetField Method

public override string GetField();

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.GetHashCode Method

public override int GetHashCode();

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.GetPayloadSpans Method

public override PayloadSpans GetPayloadSpans(
IndexReader reader
);

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.GetSpans Method

public override Spans GetSpans(
IndexReader reader
);

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.GetTerms Method

Returns a collection of all terms matched by this query.

public override ICollection GetTerms();

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace | #ExtractTerms


SpanOrQuery.Rewrite Method

public override Query Rewrite(
IndexReader reader
);

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

SpanOrQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace


SpanOrQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

SpanOrQuery Class | Lucene.Net.Search.Spans Namespace | SpanOrQuery.ToString Overload List


SpanQuery Class

Base class for span-based queries.

For a list of all members of this type, see SpanQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanFirstQuery
Lucene.Net.Search.Spans.SpanNearQuery
Lucene.Net.Search.Spans.SpanNotQuery
Lucene.Net.Search.Spans.SpanOrQuery
Lucene.Net.Search.Spans.SpanTermQuery

public abstract class SpanQuery : Query

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanQuery Members | Lucene.Net.Search.Spans Namespace


SpanQuery Members

SpanQuery overview

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField | Returns the name of the field matched by this query.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPayloadSpans | Returns the matches for this query in an index, including access to any payloads at thos positions. Implementin classes that want access to the payloads will need to implement this. WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a cse.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans | Expert: Returns the matches for this query in an index. Used internally to search for spans.
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Constructors

SpanQuery Constructor Initializes a new instance of the SpanQuery class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery Constructor

Initializes a new instance of the SpanQuery class.

protected SpanQuery();

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery Methods

The methods of the SpanQuery class are listed below. For a complete list of SpanQuery class members, see the SpanQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExtractTerms (inherited from Query) | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField | Returns the name of the field matched by this query.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPayloadSpans | Returns the matches for this query in an index, including access to any payloads at thos positions. Implementin classes that want access to the payloads will need to implement this. WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a cse.
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans | Expert: Returns the matches for this query in an index. Used internally to search for spans.
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery.CreateWeight Method

protected internal override Weight CreateWeight(
Searcher searcher
);

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery.CreateWeight_ForNUnitTest Method

public Weight CreateWeight_ForNUnitTest(
Searcher searcher
);

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery.GetField Method

Returns the name of the field matched by this query.

public abstract string GetField();

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery.GetPayloadSpans Method

Returns the matches for this query in an index, including access to any payloads at thos positions. Implementin classes that want access to the payloads will need to implement this.

WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a cse.

public virtual PayloadSpans GetPayloadSpans(
IndexReader reader
);

Parameters

reader
the reader to use to access spans/payloads

Return Value

null

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery.GetSpans Method

Expert: Returns the matches for this query in an index. Used internally to search for spans.

public abstract Spans GetSpans(
IndexReader reader
);

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace


SpanQuery.GetTerms Method

Returns a collection of all terms matched by this query.

public abstract ICollection GetTerms();

See Also

SpanQuery Class | Lucene.Net.Search.Spans Namespace | Query#ExtractTerms


Spans Interface

Expert: an enumeration of span matches. Used to implement span searching. Each span represents a range of term positions within a document. Matches are enumerated in order, by increasing document number, within that by increasing start position and finally by increasing end position.

For a list of all members of this type, see Spans Members.

Lucene.Net.Search.Spans.Spans
Lucene.Net.Search.Spans.PayloadSpans

public interface Spans

Types that implement Spans

Type | Description
TermSpans | Expert: Public for extension only

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Spans Members | Lucene.Net.Search.Spans Namespace


Spans Members

Spans overview

Public Instance Methods

Doc | Returns the document number of the current match. Initially invalid.
End | Returns the end position of the current match. Initially invalid.
Next | Move to the next match, returning true iff any such exists.
SkipTo |
Start | Returns the start position of the current match. Initially invalid.

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


Spans Methods

The methods of the Spans interface are listed below. For a complete list of Spans interface members, see the Spans Members topic.

Public Instance Methods

Doc | Returns the document number of the current match. Initially invalid.
End | Returns the end position of the current match. Initially invalid.
Next | Move to the next match, returning true iff any such exists.
SkipTo |
Start | Returns the start position of the current match. Initially invalid.

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


Spans.Doc Method

Returns the document number of the current match. Initially invalid.

int Doc();

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


Spans.End Method

Returns the end position of the current match. Initially invalid.

int End();

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


Spans.Next Method

Move to the next match, returning true iff any such exists.

bool Next();

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


Spans.SkipTo Method

bool SkipTo(
int target
);

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


Spans.Start Method

Returns the start position of the current match. Initially invalid.

int Start();

See Also

Spans Interface | Lucene.Net.Search.Spans Namespace


SpanScorer Class

Public for extension only.

For a list of all members of this type, see SpanScorer Members.

System.Object
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Search.Scorer
Lucene.Net.Search.Spans.SpanScorer
Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer

public class SpanScorer : Scorer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanScorer Members | Lucene.Net.Search.Spans Namespace


SpanScorer Members

SpanScorer overview

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Scorer) | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Score | Overloaded.
Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

SpanScorer Constructor

Protected Internal Instance Fields

doc
firstTime
freq
more
norms
spans
value_Renamed
weight

Protected Internal Instance Methods

Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SetFreqCurrentDoc |

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer Constructor

protected internal SpanScorer(
Spans spans,
Weight weight,
Similarity similarity,
byte[] norms
);

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer Fields

The fields of the SpanScorer class are listed below. For a complete list of SpanScorer class members, see the SpanScorer Members topic.

Protected Internal Instance Fields

doc
firstTime
freq
more
norms
spans
value_Renamed
weight

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer.Doc Method

public override int Doc();

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer.firstTime Field

protected internal bool firstTime;

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer.freq Field

protected internal float freq;

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer.more Field

protected internal bool more;

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer.norms Field

protected internal byte[] norms;

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer.spans Field

protected internal Spans spans;

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer.value_Renamed Field

protected internal float value_Renamed;

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer.weight Field

protected internal Weight weight;

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer Methods

The methods of the SpanScorer class are listed below. For a complete list of SpanScorer class members, see the SpanScorer Members topic.

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSimilarity (inherited from Scorer) | Returns the Similarity implementation used by this scorer.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
Score | Overloaded.
Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Score (inherited from Scorer) | Overloaded. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
SetFreqCurrentDoc |

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer.Explain Method

public override Explanation Explain(
int doc
);

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer.Next Method

public override bool Next();

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


Score Method

Apache Lucene.Net 2.4.0 Class Library API

SpanScorer.Score Method

Overload List

public override float Score();

Inherited from Scorer.

public virtual void Score(HitCollector);

Inherited from Scorer.

protected internal virtual bool Score(HitCollector,int);

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer.Score Method ()

public override float Score();

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace | SpanScorer.Score Overload List


SpanScorer.SetFreqCurrentDoc Method

protected internal virtual bool SetFreqCurrentDoc();

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanScorer.SkipTo Method

public override bool SkipTo(
int target
);

See Also

SpanScorer Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery Class

Matches spans containing a term.

For a list of all members of this type, see SpanTermQuery Members.

System.Object
Lucene.Net.Search.Query
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanTermQuery
Lucene.Net.Search.Payloads.BoostingTermQuery

public class SpanTermQuery : SpanQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanTermQuery Members | Lucene.Net.Search.Spans Namespace


SpanTermQuery Members

SpanTermQuery overview

Public Instance Constructors

SpanTermQuery Constructor Construct a SpanTermQuery matching the named term's spans.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest (inherited from SpanQuery)
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField
GetHashCode | Returns a hash code value for this object.
GetPayloadSpans
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerm | Return the term whose spans are matched.
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

term

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery Constructor

Construct a SpanTermQuery matching the named term's spans.

public SpanTermQuery(
Term term
);

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery Fields

The fields of the SpanTermQuery class are listed below. For a complete list of SpanTermQuery class members, see the SpanTermQuery Members topic.

Protected Internal Instance Fields

term

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.term Field

protected internal Term term;

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery Methods

The methods of the SpanTermQuery class are listed below. For a complete list of SpanTermQuery class members, see the SpanTermQuery Members topic.

Public Instance Methods

Clone (inherited from Query) | Returns a clone of this query.
Combine (inherited from Query) | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite() and RangeQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
CreateWeight_ForNUnitTest (inherited from SpanQuery)
Equals Returns true iff
o
is equal to this.
ExtractTerms
GetBoost (inherited from Query) Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
. The boost is 1.0 by default.
GetField
GetHashCode | Returns a hash code value for this object.
GetPayloadSpans
GetSimilarity (inherited from Query) | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
GetSpans
GetTerm | Return the term whose spans are matched.
GetTerms | Returns a collection of all terms matched by this query.
GetType (inherited from Object) | Gets the Type of the current instance.
Rewrite (inherited from Query) | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
SetBoost (inherited from Query) Sets the boost for this query clause to
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
b
.
ToString | Overloaded.
ToString (inherited from Query) | Overloaded. Prints a query to a string.
Weight (inherited from Query) | Expert: Constructs and initializes a Weight for a top-level query.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CreateWeight (inherited from SpanQuery)

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.Equals Method

Returns true iff

o
is equal to this.

public override bool Equals(
object o
);

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.ExtractTerms Method

public override void ExtractTerms(
Hashtable terms
);

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.GetField Method

public override string GetField();

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.GetHashCode Method

Returns a hash code value for this object.

public override int GetHashCode();

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.GetPayloadSpans Method

public override PayloadSpans GetPayloadSpans(
IndexReader reader
);

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.GetSpans Method

public override Spans GetSpans(
IndexReader reader
);

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.GetTerm Method

Return the term whose spans are matched.

public virtual Term GetTerm();

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.GetTerms Method

Returns a collection of all terms matched by this query.

public override ICollection GetTerms();

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace | #ExtractTerms


ToString Method

Apache Lucene.Net 2.4.0 Class Library API

SpanTermQuery.ToString Method

Overload List

Inherited from Query.

public override string ToString();

public override string ToString(string);

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace


SpanTermQuery.ToString Method (String)

public override string ToString(
string field
);

See Also

SpanTermQuery Class | Lucene.Net.Search.Spans Namespace | SpanTermQuery.ToString Overload List


SpanWeight Class

Expert-only. Public for use by other weight implementations

For a list of all members of this type, see SpanWeight Members.

System.Object
Lucene.Net.Search.Spans.SpanWeight
Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight

public class SpanWeight : Weight

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SpanWeight Members | Lucene.Net.Search.Spans Namespace


SpanWeight Members

SpanWeight overview

Public Instance Constructors

SpanWeight Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue |
Normalize |
Scorer |
SumOfSquaredWeights |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

idf
query
queryNorm
queryWeight
similarity
terms
value_Renamed

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight Constructor

public SpanWeight(
SpanQuery query,
Searcher searcher
);

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight Fields

The fields of the SpanWeight class are listed below. For a complete list of SpanWeight class members, see the SpanWeight Members topic.

Protected Internal Instance Fields

idf
query
queryNorm
queryWeight
similarity
terms
value_Renamed

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.idf Field

protected internal float idf;

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.query Field

protected internal SpanQuery query;

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.queryNorm Field

protected internal float queryNorm;

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.queryWeight Field

protected internal float queryWeight;

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.similarity Field

protected internal Similarity similarity;

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.terms Field

protected internal Hashtable terms;

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.value_Renamed Field

protected internal float value_Renamed;

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight Methods

The methods of the SpanWeight class are listed below. For a complete list of SpanWeight class members, see the SpanWeight Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Explain |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue |
Normalize |
Scorer |
SumOfSquaredWeights |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.Explain Method

public virtual Explanation Explain(
IndexReader reader,
int doc
);

Implements

Weight.Explain

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.GetQuery Method

public virtual Query GetQuery();

Implements

Weight.GetQuery

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.GetValue Method

public virtual float GetValue();

Implements

Weight.GetValue

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.Normalize Method

public virtual void Normalize(
float queryNorm
);

Implements

Weight.Normalize

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.Scorer Method

public virtual Scorer Scorer(
IndexReader reader
);

Implements

Weight.Scorer

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


SpanWeight.SumOfSquaredWeights Method

public virtual float SumOfSquaredWeights();

Implements

Weight.SumOfSquaredWeights

See Also

SpanWeight Class | Lucene.Net.Search.Spans Namespace


TermSpans Class

Expert: Public for extension only

For a list of all members of this type, see TermSpans Members.

System.Object
Lucene.Net.Search.Spans.TermSpans

public class TermSpans : PayloadSpans, Spans

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Search.Spans

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

TermSpans Members | Lucene.Net.Search.Spans Namespace


TermSpans Members

TermSpans overview

Public Instance Constructors

TermSpans Constructor

Public Instance Methods

Doc |
End |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPayload |
GetPositions |
GetType (inherited from Object) | Gets the Type of the current instance.
IsPayloadAvailable |
Next |
SkipTo |
Start |
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

count
doc
freq
position
positions
term

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans Constructor

public TermSpans(
TermPositions positions,
Term term
);

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans Fields

The fields of the TermSpans class are listed below. For a complete list of TermSpans class members, see the TermSpans Members topic.

Protected Internal Instance Fields

count
doc
freq
position
positions
term

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.count Field

protected internal int count;

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.Doc Method

public virtual int Doc();

Implements

Spans.Doc

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.freq Field

protected internal int freq;

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.position Field

protected internal int position;

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.positions Field

protected internal TermPositions positions;

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.term Field

protected internal Term term;

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans Methods

The methods of the TermSpans class are listed below. For a complete list of TermSpans class members, see the TermSpans Members topic.

Public Instance Methods

Doc |
End |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPayload |
GetPositions |
GetType (inherited from Object) | Gets the Type of the current instance.
IsPayloadAvailable |
Next |
SkipTo |
Start |
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.End Method

public virtual int End();

Implements

Spans.End

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.GetPayload Method

public 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetPayload();

Implements

PayloadSpans.GetPayload

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.GetPositions Method

public virtual TermPositions GetPositions();

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.IsPayloadAvailable Method

public bool IsPayloadAvailable();

Implements

PayloadSpans.IsPayloadAvailable

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.Next Method

public virtual bool Next();

Implements

Spans.Next

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.SkipTo Method

public virtual bool SkipTo(
int target
);

Implements

Spans.SkipTo

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.Start Method

public virtual int Start();

Implements

Spans.Start

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


TermSpans.ToString Method

public override string ToString();

See Also

TermSpans Class | Lucene.Net.Search.Spans Namespace


Lucene.Net.Store

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Store Namespace

Namespace hierarchy

Classes

Class | Description
AlreadyClosedException | This exception is thrown when there is an attempt to access something that has already been closed.
BufferedIndexInput | Base implementation class for buffered {@link IndexInput}.
BufferedIndexOutput | Base implementation class for buffered {@link IndexOutput}.
ChecksumIndexInput
ChecksumIndexOutput
Directory
FSDirectory Straightforward implementation of {@link Directory} as a directory of files. Locking implementation is by default the {@link SimpleFSLockFactory}, but can be changed either by passing in a {@link LockFactory} instance to
getDirectory
, or specifying the LockFactory class by setting
Lucene.Net.Store.FSDirectoryLockFactoryClass
Java system property, or by calling {@link #setLockFactory} after creating the Directory.

Directories are cached, so that, for a given canonical path, the same FSDirectory instance will always be returned by

getDirectory
. This permits synchronization on directories.
FSDirectory.FSIndexInput
FSDirectory.FSIndexInput.Descriptor
FSDirectory.FSIndexOutput
IndexInput | Abstract base class for input from a file in a {@link Directory}. A random-access input stream. Used for all Lucene index input operations.
IndexOutput | Abstract base class for output to a file in a Directory. A random-access output stream. Used for all Lucene index output operations.
Lock
Lock.With | Utility class for executing code with exclusive access.
LockFactory

Base class for Locking implementation. {@link Directory} uses instances of this class to implement locking.

Note that there are some useful tools to verify that your LockFactory is working correctly: {@link VerifyingLockFactory}, {@link LockStressTest}, {@link LockVerifyServer}.
LockObtainFailedException This exception is thrown when the
write.lock
could not be acquired. This happens when a writer tries to open an index that another writer already has open.
LockReleaseFailedException This exception is thrown when the
write.lock
could not be released.
LockStressTest
LockVerifyServer | Simple standalone server that must be running when you use {@link VerifyingLockFactory}. This server simply verifies at most one process holds the lock at a time. Run without any args to see usage.
MMapDirectory
NativeFSLockFactory

Implements {@link LockFactory} using native OS file locks. Note that because this LockFactory relies on java.nio.* APIs for locking, any problems with those APIs will cause locking to fail. Specifically, on certain NFS environments the java.nio.* locks will fail (the lock can incorrectly be double acquired) whereas {@link SimpleFSLockFactory} worked perfectly in those same environments. For NFS based access to an index, it's recommended that you try {@link SimpleFSLockFactory} first and work around the one limitation that a lock file could be left when the JVM exits abnormally.

The primary benefit of {@link NativeFSLockFactory} is that lock files will be properly removed (by the OS) if the JVM has an abnormal exit.

Note that, unlike {@link SimpleFSLockFactory}, the existence of leftover lock files in the filesystem on exiting the JVM is fine because the OS will free the locks held against these files even though the files still remain.

If you suspect that this or any other LockFactory is not working properly in your environment, you can easily test it by using {@link VerifyingLockFactory}, {@link LockVerifyServer} and {@link LockStressTest}.
NoLockFactory | Use this {@link LockFactory} to disable locking entirely. This LockFactory is used when you call {@link FSDirectory#setDisableLocks}. Only one instance of this lock is created. You should call {@link #GetNoLockFactory()} to get the instance.
RAMDirectory | A memory-resident {@link Directory} implementation. Locking implementation is by default the {@link SingleInstanceLockFactory} but can be changed with {@link #setLockFactory}.
RAMFile
RAMInputStream | A memory-resident {@link IndexInput} implementation.
RAMOutputStream | A memory-resident {@link IndexOutput} implementation.
SimpleFSLockFactory

Implements {@link LockFactory} using {@link File#createNewFile()}. This is the default LockFactory for {@link FSDirectory}.

NOTE: the javadocs for

File.createNewFile
contain a vague yet spooky warning about not using the API for file locking. This warning was added due to this bug, and in fact the only known problem with using this API for locking is that the Lucene write lock may not be released when the JVM exits abnormally.

When this happens, a {@link LockObtainFailedException} is hit when trying to create a writer, in which case you need to explicitly clear the lock file first. You can either manually remove the file, or use the {@link Lucene.Net.Index.IndexReader#Unlock(Directory)} API. But, first be certain that no writer is in fact writing to the index otherwise you can easily corrupt your index.

If you suspect that this or any other LockFactory is not working properly in your environment, you can easily test it by using {@link VerifyingLockFactory}, {@link LockVerifyServer} and {@link LockStressTest}.
SingleInstanceLockFactory | Implements {@link LockFactory} for a single in-process instance, meaning all locking will take place through this one instance. Only use this {@link LockFactory} when you are certain all IndexReaders and IndexWriters for a given index are running against a single shared in-process Directory instance. This is currently the default locking for RAMDirectory.
VerifyingLockFactory


AlreadyClosedException Class

This exception is thrown when there is an attempt to access something that has already been closed.

For a list of all members of this type, see AlreadyClosedException Members.

System.Object
System.Exception
System.SystemException
Lucene.Net.Store.AlreadyClosedException

public class AlreadyClosedException : SystemException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

AlreadyClosedException Members | Lucene.Net.Store Namespace


AlreadyClosedException Members

AlreadyClosedException overview

Public Instance Constructors

AlreadyClosedException Constructor

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlreadyClosedException Class | Lucene.Net.Store Namespace


AlreadyClosedException Constructor

public AlreadyClosedException(
string message
);

See Also

AlreadyClosedException Class | Lucene.Net.Store Namespace


BufferedIndexInput Class

Base implementation class for buffered {@link IndexInput}.

For a list of all members of this type, see BufferedIndexInput Members.

System.Object
Lucene.Net.Store.IndexInput
Lucene.Net.Store.BufferedIndexInput
Lucene.Net.Index.CompoundFileReader.CSIndexInput
Lucene.Net.Store.FSDirectory.FSIndexInput

public abstract class BufferedIndexInput : IndexInput

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BufferedIndexInput Members | Lucene.Net.Store Namespace


BufferedIndexInput Members

BufferedIndexInput overview

Public Static Fields

BUFFER_SIZE Default buffer size

Public Instance Constructors

BufferedIndexInput Overloaded. Initializes a new instance of the BufferedIndexInput class.

Public Instance Methods

Clone |
Close (inherited from IndexInput) | Closes the stream to futher operations.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBufferSize |
GetFilePointer |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length (inherited from IndexInput) | The number of bytes in the file.
ReadByte |
ReadBytes | Overloaded.
ReadChars (inherited from IndexInput) | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt (inherited from IndexInput) | Reads four bytes and returns an int.
ReadLong (inherited from IndexInput) | Reads eight bytes and returns a long.
ReadModifiedUTF8String (inherited from IndexInput) |
ReadString (inherited from IndexInput) | Reads a string.
ReadVInt (inherited from IndexInput) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from IndexInput) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek |
SetBufferSize | Change the buffer size used by this IndexInput
SetModifiedUTF8StringsMode (inherited from IndexInput) | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars (inherited from IndexInput) | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

buffer

Protected Internal Instance Methods

NewBuffer |
ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input.
SeekInternal | Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexInput Constructor

Initializes a new instance of the BufferedIndexInput class.

Overload List

Initializes a new instance of the BufferedIndexInput class.

public BufferedIndexInput();

Inits BufferedIndexInput with a specific bufferSize

public BufferedIndexInput(int);

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexInput Constructor ()

Initializes a new instance of the BufferedIndexInput class.

public BufferedIndexInput();

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace | BufferedIndexInput Constructor Overload List


BufferedIndexInput Constructor (Int32)

Inits BufferedIndexInput with a specific bufferSize

public BufferedIndexInput(
int bufferSize
);

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace | BufferedIndexInput Constructor Overload List


BufferedIndexInput Fields

The fields of the BufferedIndexInput class are listed below. For a complete list of BufferedIndexInput class members, see the BufferedIndexInput Members topic.

Public Static Fields

BUFFER_SIZE Default buffer size

Protected Internal Instance Fields

buffer

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexInput.buffer Field

protected internal byte[] buffer;

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexInput.BUFFER_SIZE Field

Default buffer size

public const int BUFFER_SIZE = 1024;

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexInput Methods

The methods of the BufferedIndexInput class are listed below. For a complete list of BufferedIndexInput class members, see the BufferedIndexInput Members topic.

Public Instance Methods

Clone |
Close (inherited from IndexInput) | Closes the stream to futher operations.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBufferSize |
GetFilePointer |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length (inherited from IndexInput) | The number of bytes in the file.
ReadByte |
ReadBytes | Overloaded.
ReadChars (inherited from IndexInput) | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt (inherited from IndexInput) | Reads four bytes and returns an int.
ReadLong (inherited from IndexInput) | Reads eight bytes and returns a long.
ReadModifiedUTF8String (inherited from IndexInput) |
ReadString (inherited from IndexInput) | Reads a string.
ReadVInt (inherited from IndexInput) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from IndexInput) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek |
SetBufferSize | Change the buffer size used by this IndexInput
SetModifiedUTF8StringsMode (inherited from IndexInput) | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars (inherited from IndexInput) | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

NewBuffer |
ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input.
SeekInternal | Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexInput.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexInput.GetBufferSize Method

public virtual int GetBufferSize();

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace | setBufferSize


BufferedIndexInput.GetFilePointer Method

public override long GetFilePointer();

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexInput.NewBuffer Method

protected internal virtual void NewBuffer(
byte[] newBuffer
);

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexInput.ReadByte Method

public override byte ReadByte();

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


ReadBytes Method

Apache Lucene.Net 2.4.0 Class Library API

BufferedIndexInput.ReadBytes Method

Overload List

public override void ReadBytes(byte[],int,int);

public override void ReadBytes(byte[],int,int,bool);

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexInput.ReadBytes Method (Byte[], Int32, Int32)

public override void ReadBytes(
byte[] b,
int offset,
int len
);

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace | BufferedIndexInput.ReadBytes Overload List


BufferedIndexInput.ReadBytes Method (Byte[], Int32, Int32, Boolean)

public override void ReadBytes(
byte[] b,
int offset,
int len,
bool useBuffer
);

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace | BufferedIndexInput.ReadBytes Overload List


BufferedIndexInput.ReadInternal Method

Expert: implements buffer refill. Reads bytes from the current position in the input.

protected internal abstract void ReadInternal(
byte[] b,
int offset,
int length
);

Parameters

b
the array to read bytes into
offset
the offset in the array to start storing bytes
length
the number of bytes to read

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexInput.Seek Method

public override void Seek(
long pos
);

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexInput.SeekInternal Method

Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.

protected internal abstract void SeekInternal(
long pos
);

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace |


BufferedIndexInput.SetBufferSize Method

Change the buffer size used by this IndexInput

public virtual void SetBufferSize(
int newSize
);

See Also

BufferedIndexInput Class | Lucene.Net.Store Namespace


BufferedIndexOutput Class

Base implementation class for buffered {@link IndexOutput}.

For a list of all members of this type, see BufferedIndexOutput Members.

System.Object
Lucene.Net.Store.IndexOutput
Lucene.Net.Store.BufferedIndexOutput
Lucene.Net.Store.FSDirectory.FSIndexOutput

public abstract class BufferedIndexOutput : IndexOutput

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BufferedIndexOutput Members | Lucene.Net.Store Namespace


BufferedIndexOutput Members

BufferedIndexOutput overview

Public Instance Methods

Close | Closes this stream to further operations.
CopyBytes (inherited from IndexOutput) | Copy numBytes bytes from input to ourself.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Forces any buffered output to be written.
FlushBuffer | Expert: implements buffer write. Writes bytes at the current position in the output.
GetFilePointer | Returns the current position in this file, where the next write will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length | The number of bytes in the file.
Seek | Sets current position in this file, where the next write will occur.
SetLength (inherited from IndexOutput) | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for example @see FSDirectory) can use this to inform the underlying IO system to pre-allocate the file to the specified size. If the length is longer than the current file length, the bytes added to the file are undefined. Otherwise the file is truncated. file length
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte | Writes a single byte.
WriteBytes | Overloaded. Writes an array of bytes.
WriteBytes (inherited from IndexOutput) | Overloaded. Writes an array of bytes.
WriteChars (inherited from IndexOutput) | Overloaded. Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.
WriteInt (inherited from IndexOutput) | Writes an int as four bytes.
WriteLong (inherited from IndexOutput) | Writes a long as eight bytes.
WriteString (inherited from IndexOutput) | Writes a string.
WriteVInt (inherited from IndexOutput) | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong (inherited from IndexOutput) | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Constructors

BufferedIndexOutput Constructor Initializes a new instance of the BufferedIndexOutput class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BufferedIndexOutput Class | Lucene.Net.Store Namespace


BufferedIndexOutput Constructor

Initializes a new instance of the BufferedIndexOutput class.

protected BufferedIndexOutput();

See Also

BufferedIndexOutput Class | Lucene.Net.Store Namespace


BufferedIndexOutput Methods

The methods of the BufferedIndexOutput class are listed below. For a complete list of BufferedIndexOutput class members, see the BufferedIndexOutput Members topic.

Public Instance Methods

Close | Closes this stream to further operations.
CopyBytes (inherited from IndexOutput) | Copy numBytes bytes from input to ourself.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Forces any buffered output to be written.
FlushBuffer | Expert: implements buffer write. Writes bytes at the current position in the output.
GetFilePointer | Returns the current position in this file, where the next write will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length | The number of bytes in the file.
Seek | Sets current position in this file, where the next write will occur.
SetLength (inherited from IndexOutput) | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for example @see FSDirectory) can use this to inform the underlying IO system to pre-allocate the file to the specified size. If the length is longer than the current file length, the bytes added to the file are undefined. Otherwise the file is truncated. file length
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte | Writes a single byte.
WriteBytes | Overloaded. Writes an array of bytes.
WriteBytes (inherited from IndexOutput) | Overloaded. Writes an array of bytes.
WriteChars (inherited from IndexOutput) | Overloaded. Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.
WriteInt (inherited from IndexOutput) | Writes an int as four bytes.
WriteLong (inherited from IndexOutput) | Writes a long as eight bytes.
WriteString (inherited from IndexOutput) | Writes a string.
WriteVInt (inherited from IndexOutput) | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong (inherited from IndexOutput) | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BufferedIndexOutput Class | Lucene.Net.Store Namespace


BufferedIndexOutput.Close Method

Closes this stream to further operations.

public override void Close();

See Also

BufferedIndexOutput Class | Lucene.Net.Store Namespace


BufferedIndexOutput.Flush Method

Forces any buffered output to be written.

public override void Flush();

See Also

BufferedIndexOutput Class | Lucene.Net.Store Namespace


BufferedIndexOutput.FlushBuffer Method

Expert: implements buffer write. Writes bytes at the current position in the output.

public abstract void FlushBuffer(
byte[] b,
int offset,
int len
);

Parameters

b
the bytes to write
offset
the offset in the byte array
len
the number of bytes to write

See Also

BufferedIndexOutput Class | Lucene.Net.Store Namespace


BufferedIndexOutput.GetFilePointer Method

Returns the current position in this file, where the next write will occur.

public override long GetFilePointer();

See Also

BufferedIndexOutput Class | Lucene.Net.Store Namespace |


BufferedIndexOutput.Length Method

The number of bytes in the file.

public abstract long Length();

See Also

BufferedIndexOutput Class | Lucene.Net.Store Namespace


BufferedIndexOutput.Seek Method

Sets current position in this file, where the next write will occur.

public override void Seek(
long pos
);

See Also

BufferedIndexOutput Class | Lucene.Net.Store Namespace |


BufferedIndexOutput.WriteByte Method

Writes a single byte.

public override void WriteByte(
byte b
);

See Also

BufferedIndexOutput Class | Lucene.Net.Store Namespace |


WriteBytes Method

Apache Lucene.Net 2.4.0 Class Library API

BufferedIndexOutput.WriteBytes Method

Writes an array of bytes.

Overload List

Inherited from IndexOutput.

public virtual void WriteBytes(byte[],int);

Writes an array of bytes.

public override void WriteBytes(byte[],int,int);

See Also

BufferedIndexOutput Class | Lucene.Net.Store Namespace |


BufferedIndexOutput.WriteBytes Method (Byte[], Int32, Int32)

Writes an array of bytes.

public override void WriteBytes(
byte[] b,
int offset,
int length
);

Parameters

b
the bytes to write
offset
length
the number of bytes to write

See Also

BufferedIndexOutput Class | Lucene.Net.Store Namespace | BufferedIndexOutput.WriteBytes Overload List |


ChecksumIndexInput Class

For a list of all members of this type, see ChecksumIndexInput Members.

System.Object
Lucene.Net.Store.IndexInput
Lucene.Net.Store.ChecksumIndexInput

public class ChecksumIndexInput : IndexInput

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ChecksumIndexInput Members | Lucene.Net.Store Namespace


ChecksumIndexInput Members

ChecksumIndexInput overview

Public Instance Constructors

ChecksumIndexInput Constructor

Public Instance Methods

Clone (inherited from IndexInput) |
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChecksum |
GetFilePointer |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
ReadByte |
ReadBytes | Overloaded.
ReadBytes (inherited from IndexInput) | Overloaded. Reads a specified number of bytes into an array at the specified offset.
ReadChars (inherited from IndexInput) | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt (inherited from IndexInput) | Reads four bytes and returns an int.
ReadLong (inherited from IndexInput) | Reads eight bytes and returns a long.
ReadModifiedUTF8String (inherited from IndexInput) |
ReadString (inherited from IndexInput) | Reads a string.
ReadVInt (inherited from IndexInput) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from IndexInput) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek |
SetModifiedUTF8StringsMode (inherited from IndexInput) | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars (inherited from IndexInput) | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChecksumIndexInput Class | Lucene.Net.Store Namespace


ChecksumIndexInput Constructor

public ChecksumIndexInput(
IndexInput main
);

See Also

ChecksumIndexInput Class | Lucene.Net.Store Namespace


ChecksumIndexInput Methods

The methods of the ChecksumIndexInput class are listed below. For a complete list of ChecksumIndexInput class members, see the ChecksumIndexInput Members topic.

Public Instance Methods

Clone (inherited from IndexInput) |
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChecksum |
GetFilePointer |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
ReadByte |
ReadBytes | Overloaded.
ReadBytes (inherited from IndexInput) | Overloaded. Reads a specified number of bytes into an array at the specified offset.
ReadChars (inherited from IndexInput) | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt (inherited from IndexInput) | Reads four bytes and returns an int.
ReadLong (inherited from IndexInput) | Reads eight bytes and returns a long.
ReadModifiedUTF8String (inherited from IndexInput) |
ReadString (inherited from IndexInput) | Reads a string.
ReadVInt (inherited from IndexInput) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from IndexInput) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek |
SetModifiedUTF8StringsMode (inherited from IndexInput) | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars (inherited from IndexInput) | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChecksumIndexInput Class | Lucene.Net.Store Namespace


ChecksumIndexInput.Close Method

public override void Close();

See Also

ChecksumIndexInput Class | Lucene.Net.Store Namespace


ChecksumIndexInput.GetChecksum Method

public long GetChecksum();

See Also

ChecksumIndexInput Class | Lucene.Net.Store Namespace


ChecksumIndexInput.GetFilePointer Method

public override long GetFilePointer();

See Also

ChecksumIndexInput Class | Lucene.Net.Store Namespace


ChecksumIndexInput.Length Method

public override long Length();

See Also

ChecksumIndexInput Class | Lucene.Net.Store Namespace


ChecksumIndexInput.ReadByte Method

public override byte ReadByte();

See Also

ChecksumIndexInput Class | Lucene.Net.Store Namespace


ReadBytes Method

Apache Lucene.Net 2.4.0 Class Library API

ChecksumIndexInput.ReadBytes Method

Overload List

public override void ReadBytes(byte[],int,int);

Inherited from IndexInput.

public virtual void ReadBytes(byte[],int,int,bool);

See Also

ChecksumIndexInput Class | Lucene.Net.Store Namespace


ChecksumIndexInput.ReadBytes Method (Byte[], Int32, Int32)

public override void ReadBytes(
byte[] b,
int offset,
int len
);

See Also

ChecksumIndexInput Class | Lucene.Net.Store Namespace | ChecksumIndexInput.ReadBytes Overload List


ChecksumIndexInput.Seek Method

public override void Seek(
long pos
);

See Also

ChecksumIndexInput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput Class

For a list of all members of this type, see ChecksumIndexOutput Members.

System.Object
Lucene.Net.Store.IndexOutput
Lucene.Net.Store.ChecksumIndexOutput

public class ChecksumIndexOutput : IndexOutput

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ChecksumIndexOutput Members | Lucene.Net.Store Namespace


ChecksumIndexOutput Members

ChecksumIndexOutput overview

Public Instance Constructors

ChecksumIndexOutput Constructor

Public Instance Methods

Close |
CopyBytes (inherited from IndexOutput) | Copy numBytes bytes from input to ourself.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinishCommit |
Flush |
GetChecksum |
GetFilePointer |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
PrepareCommit |
Seek |
SetLength (inherited from IndexOutput) | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for example @see FSDirectory) can use this to inform the underlying IO system to pre-allocate the file to the specified size. If the length is longer than the current file length, the bytes added to the file are undefined. Otherwise the file is truncated. file length
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte |
WriteBytes | Overloaded.
WriteBytes (inherited from IndexOutput) | Overloaded. Writes an array of bytes.
WriteChars (inherited from IndexOutput) | Overloaded. Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.
WriteInt (inherited from IndexOutput) | Writes an int as four bytes.
WriteLong (inherited from IndexOutput) | Writes a long as eight bytes.
WriteString (inherited from IndexOutput) | Writes a string.
WriteVInt (inherited from IndexOutput) | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong (inherited from IndexOutput) | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput Constructor

public ChecksumIndexOutput(
IndexOutput main
);

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput Methods

The methods of the ChecksumIndexOutput class are listed below. For a complete list of ChecksumIndexOutput class members, see the ChecksumIndexOutput Members topic.

Public Instance Methods

Close |
CopyBytes (inherited from IndexOutput) | Copy numBytes bytes from input to ourself.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinishCommit |
Flush |
GetChecksum |
GetFilePointer |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
PrepareCommit |
Seek |
SetLength (inherited from IndexOutput) | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for example @see FSDirectory) can use this to inform the underlying IO system to pre-allocate the file to the specified size. If the length is longer than the current file length, the bytes added to the file are undefined. Otherwise the file is truncated. file length
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte |
WriteBytes | Overloaded.
WriteBytes (inherited from IndexOutput) | Overloaded. Writes an array of bytes.
WriteChars (inherited from IndexOutput) | Overloaded. Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.
WriteInt (inherited from IndexOutput) | Writes an int as four bytes.
WriteLong (inherited from IndexOutput) | Writes a long as eight bytes.
WriteString (inherited from IndexOutput) | Writes a string.
WriteVInt (inherited from IndexOutput) | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong (inherited from IndexOutput) | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput.Close Method

public override void Close();

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput.FinishCommit Method

public void FinishCommit();

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput.Flush Method

public override void Flush();

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput.GetChecksum Method

public long GetChecksum();

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput.GetFilePointer Method

public override long GetFilePointer();

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput.Length Method

public override long Length();

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput.PrepareCommit Method

public void PrepareCommit();

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput.Seek Method

public override void Seek(
long pos
);

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput.WriteByte Method

public override void WriteByte(
byte b
);

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


WriteBytes Method

Apache Lucene.Net 2.4.0 Class Library API

ChecksumIndexOutput.WriteBytes Method

Overload List

Inherited from IndexOutput.

public virtual void WriteBytes(byte[],int);

public override void WriteBytes(byte[],int,int);

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace


ChecksumIndexOutput.WriteBytes Method (Byte[], Int32, Int32)

public override void WriteBytes(
byte[] b,
int offset,
int length
);

See Also

ChecksumIndexOutput Class | Lucene.Net.Store Namespace | ChecksumIndexOutput.WriteBytes Overload List


Directory Class

For a list of all members of this type, see Directory Members.

System.Object
Lucene.Net.Store.Directory
Lucene.Net.Index.CompoundFileReader
Lucene.Net.Store.FSDirectory
Lucene.Net.Store.RAMDirectory

public abstract class Directory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Directory Members | Lucene.Net.Store Namespace


Directory Members

Directory overview

Public Static Methods

Copy Copy contents of a directory src to a directory dest. If a file in src already exists in dest then the one in dest will be blindly overwritten.

Public Instance Methods

ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Close | Closes the store.
CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff a file with the given name exists.
FileLength | Returns the length of a file in the directory.
FileModified | Returns the time the named file was last modified.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
GetLockID | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory. This method may return null (for example for {@link FSDirectory} if the underlying directory doesn't exist in the filesystem or there are permissions problems).
MakeLock | Construct a {@link Lock}.
OpenInput | Overloaded. Returns a stream reading an existing file.
RenameFile | Renames an existing file in the directory. If a file already exists with the new name, then it is replaced. This replacement is not guaranteed to be atomic.
SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Sync | Ensure that any writes to the file are moved to stable storage. Lucene uses this to properly commit chages to the index, to prevent a machine/OS crash from corrupting the index.
ToString (inherited from Object) | Returns a String that represents the current Object.
TouchFile | Set the modified time of an existing file to now.

Protected Instance Constructors

Directory Constructor Initializes a new instance of the Directory class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

isOpen |
lockFactory | Holds the LockFactory instance (implements locking for this Directory instance).

Protected Internal Instance Methods

EnsureOpen Throws AlreadyClosedException if this Directory is closed.

See Also

Directory Class | Lucene.Net.Store Namespace


Directory Constructor

Initializes a new instance of the Directory class.

protected Directory();

See Also

Directory Class | Lucene.Net.Store Namespace


Directory Fields

The fields of the Directory class are listed below. For a complete list of Directory class members, see the Directory Members topic.

Protected Internal Instance Fields

isOpen |
lockFactory | Holds the LockFactory instance (implements locking for this Directory instance).

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.isOpen Field

protected internal bool isOpen;

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.lockFactory Field

Holds the LockFactory instance (implements locking for this Directory instance).

protected internal LockFactory lockFactory;

See Also

Directory Class | Lucene.Net.Store Namespace


Directory Methods

The methods of the Directory class are listed below. For a complete list of Directory class members, see the Directory Members topic.

Public Static Methods

Copy Copy contents of a directory src to a directory dest. If a file in src already exists in dest then the one in dest will be blindly overwritten.

Public Instance Methods

ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Close | Closes the store.
CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff a file with the given name exists.
FileLength | Returns the length of a file in the directory.
FileModified | Returns the time the named file was last modified.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
GetLockID | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory. This method may return null (for example for {@link FSDirectory} if the underlying directory doesn't exist in the filesystem or there are permissions problems).
MakeLock | Construct a {@link Lock}.
OpenInput | Overloaded. Returns a stream reading an existing file.
RenameFile | Renames an existing file in the directory. If a file already exists with the new name, then it is replaced. This replacement is not guaranteed to be atomic.
SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Sync | Ensure that any writes to the file are moved to stable storage. Lucene uses this to properly commit chages to the index, to prevent a machine/OS crash from corrupting the index.
ToString (inherited from Object) | Returns a String that represents the current Object.
TouchFile | Set the modified time of an existing file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

EnsureOpen Throws AlreadyClosedException if this Directory is closed.

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.ClearLock Method

Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.

public virtual void ClearLock(
string name
);

Parameters

name
name of the lock to be cleared.

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.Close Method

Closes the store.

public abstract void Close();

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.Copy Method

Copy contents of a directory src to a directory dest. If a file in src already exists in dest then the one in dest will be blindly overwritten.

public static void Copy(
Directory src,
Directory dest,
bool closeDirSrc
);

Parameters

src
source directory
dest
destination directory
closeDirSrc
if
true
, call {@link #close()} method on source directory

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.CreateOutput Method

Creates a new, empty file in the directory with the given name. Returns a stream writing this file.

public abstract IndexOutput CreateOutput(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.DeleteFile Method

Removes an existing file in the directory.

public abstract void DeleteFile(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.EnsureOpen Method

Throws AlreadyClosedException if this Directory is closed.

protected internal virtual void EnsureOpen();

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.FileExists Method

Returns true iff a file with the given name exists.

public abstract bool FileExists(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.FileLength Method

Returns the length of a file in the directory.

public abstract long FileLength(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.FileModified Method

Returns the time the named file was last modified.

public abstract long FileModified(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.GetLockFactory Method

Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.

public virtual LockFactory GetLockFactory();

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.GetLockID Method

Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.

public virtual string GetLockID();

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.List Method

Returns an array of strings, one for each file in the directory. This method may return null (for example for {@link FSDirectory} if the underlying directory doesn't exist in the filesystem or there are permissions problems).

public abstract string[] List();

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.MakeLock Method

Construct a {@link Lock}.

public virtual Lock MakeLock(
string name
);

Parameters

name
the name of the lock file

See Also

Directory Class | Lucene.Net.Store Namespace


OpenInput Method

Apache Lucene.Net 2.4.0 Class Library API

Directory.OpenInput Method

Returns a stream reading an existing file.

Overload List

Returns a stream reading an existing file.

public abstract IndexInput OpenInput(string);

Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are {@link FSDirectory} and {@link Lucene.Net.Index.CompoundFileReader}.

public virtual IndexInput OpenInput(string,int);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.OpenInput Method (String)

Returns a stream reading an existing file.

public abstract IndexInput OpenInput(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace | Directory.OpenInput Overload List


Directory.OpenInput Method (String, Int32)

Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are {@link FSDirectory} and {@link Lucene.Net.Index.CompoundFileReader}.

public virtual IndexInput OpenInput(
string name,
int bufferSize
);

See Also

Directory Class | Lucene.Net.Store Namespace | Directory.OpenInput Overload List


Directory.RenameFile Method

Renames an existing file in the directory. If a file already exists with the new name, then it is replaced. This replacement is not guaranteed to be atomic.

public abstract void RenameFile(
string from,
string to
);

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.SetLockFactory Method

Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).

public virtual void SetLockFactory(
LockFactory lockFactory
);

Parameters

lockFactory
instance of {@link LockFactory}.

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.Sync Method

Ensure that any writes to the file are moved to stable storage. Lucene uses this to properly commit chages to the index, to prevent a machine/OS crash from corrupting the index.

public virtual void Sync(
string name
);

Parameters

name

See Also

Directory Class | Lucene.Net.Store Namespace


Directory.TouchFile Method

Set the modified time of an existing file to now.

public abstract void TouchFile(
string name
);

See Also

Directory Class | Lucene.Net.Store Namespace


FSDirectory Class

Straightforward implementation of {@link Directory} as a directory of files. Locking implementation is by default the {@link SimpleFSLockFactory}, but can be changed either by passing in a {@link LockFactory} instance to
getDirectory
, or specifying the LockFactory class by setting
Lucene.Net.Store.FSDirectoryLockFactoryClass
Java system property, or by calling {@link #setLockFactory} after creating the Directory.

Directories are cached, so that, for a given canonical path, the same FSDirectory instance will always be returned by

getDirectory
. This permits synchronization on directories.

For a list of all members of this type, see FSDirectory Members.

System.Object
Lucene.Net.Store.Directory
Lucene.Net.Store.FSDirectory
Lucene.Net.Store.MMapDirectory
NIOFSDirectory

public class FSDirectory : Directory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FSDirectory Members | Lucene.Net.Store Namespace |


FSDirectory Members

FSDirectory overview

Public Static Methods

FileModified | Overloaded. Returns the time the named file was last modified.
GetDirectory | Overloaded. Returns the directory instance for the named location.
GetDisableLocks | Returns whether Lucene's use of lock files is disabled.
SetDisableLocks | Set whether Lucene's use of lock files is disabled. By default, lock files are enabled. They should only be disabled if the index is on a read-only medium like a CD-ROM.

Public Instance Constructors

FSDirectory Constructor Initializes a new instance of the FSDirectory class.

Public Instance Methods

ClearLock (inherited from Directory) | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Close | Closes the store to future operations.
CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff a file with the given name exists.
FileLength | Returns the length in bytes of a file in the directory.
FileModified | Overloaded. Returns the time the named file was last modified.
GetFile |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockFactory (inherited from Directory) | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
GetLockID |
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each Lucene index file in the directory.
MakeLock (inherited from Directory) | Construct a {@link Lock}.
OpenInput | Overloaded.
RenameFile | Renames an existing file in the directory. Warning: This is not atomic.
SetLockFactory (inherited from Directory) | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Sync |
ToString | For debug output.
TouchFile | Set the modified time of an existing file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

isOpen (inherited from Directory) |
lockFactory (inherited from Directory) | Holds the LockFactory instance (implements locking for this Directory instance).

Protected Internal Instance Methods

EnsureOpen (inherited from Directory) Throws AlreadyClosedException if this Directory is closed.

See Also

FSDirectory Class | Lucene.Net.Store Namespace |


FSDirectory Constructor

Initializes a new instance of the FSDirectory class.

public FSDirectory();

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory Methods

The methods of the FSDirectory class are listed below. For a complete list of FSDirectory class members, see the FSDirectory Members topic.

Public Static Methods

FileModified | Overloaded. Returns the time the named file was last modified.
GetDirectory | Overloaded. Returns the directory instance for the named location.
GetDisableLocks | Returns whether Lucene's use of lock files is disabled.
SetDisableLocks | Set whether Lucene's use of lock files is disabled. By default, lock files are enabled. They should only be disabled if the index is on a read-only medium like a CD-ROM.

Public Instance Methods

ClearLock (inherited from Directory) | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Close | Closes the store to future operations.
CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff a file with the given name exists.
FileLength | Returns the length in bytes of a file in the directory.
FileModified | Overloaded. Returns the time the named file was last modified.
GetFile |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockFactory (inherited from Directory) | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
GetLockID |
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each Lucene index file in the directory.
MakeLock (inherited from Directory) | Construct a {@link Lock}.
OpenInput | Overloaded.
RenameFile | Renames an existing file in the directory. Warning: This is not atomic.
SetLockFactory (inherited from Directory) | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Sync |
ToString | For debug output.
TouchFile | Set the modified time of an existing file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

EnsureOpen (inherited from Directory) Throws AlreadyClosedException if this Directory is closed.

See Also

FSDirectory Class | Lucene.Net.Store Namespace |


FSDirectory.Close Method

Closes the store to future operations.

public override void Close();

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.CreateOutput Method

Creates a new, empty file in the directory with the given name. Returns a stream writing this file.

public override IndexOutput CreateOutput(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.DeleteFile Method

Removes an existing file in the directory.

public override void DeleteFile(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.FileExists Method

Returns true iff a file with the given name exists.

public override bool FileExists(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.FileLength Method

Returns the length in bytes of a file in the directory.

public override long FileLength(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FileModified Method

Apache Lucene.Net 2.4.0 Class Library API

FSDirectory.FileModified Method

Returns the time the named file was last modified.

Overload List

Returns the time the named file was last modified.

public static long FileModified(FileInfo,string);

Returns the time the named file was last modified.

public override long FileModified(string);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.FileModified Method (FileInfo, String)

Returns the time the named file was last modified.

public static long FileModified(
FileInfo directory,
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.FileModified Overload List


FSDirectory.FileModified Method (String)

Returns the time the named file was last modified.

public override long FileModified(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.FileModified Overload List


GetDirectory Method

Apache Lucene.Net 2.4.0 Class Library API

FSDirectory.GetDirectory Method

Returns the directory instance for the named location.

Overload List

Returns the directory instance for the named location.

public static FSDirectory GetDirectory(FileInfo);

Returns the directory instance for the named location.

public static FSDirectory GetDirectory(FileInfo,LockFactory);

Returns the directory instance for the named location.

public static FSDirectory GetDirectory(FileInfo,bool);

Returns the directory instance for the named location.

public static FSDirectory GetDirectory(string);

Returns the directory instance for the named location.

public static FSDirectory GetDirectory(string,LockFactory);

Returns the directory instance for the named location.

public static FSDirectory GetDirectory(string,bool);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.GetDirectory Method (FileInfo)

Returns the directory instance for the named location.

public static FSDirectory GetDirectory(
FileInfo file
);

Parameters

file
the path to the directory.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.GetDirectory Overload List


FSDirectory.GetDirectory Method (FileInfo, LockFactory)

Returns the directory instance for the named location.

public static FSDirectory GetDirectory(
FileInfo file,
LockFactory lockFactory
);

Parameters

file
the path to the directory.
lockFactory
instance of {@link LockFactory} providing the locking implementation.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.GetDirectory Overload List


FSDirectory.GetDirectory Method (FileInfo, Boolean)

Returns the directory instance for the named location.

public static FSDirectory GetDirectory(
FileInfo file,
bool create
);

Parameters

file
the path to the directory.
create
if true, create, or erase any existing contents.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.GetDirectory Overload List


FSDirectory.GetDirectory Method (String)

Returns the directory instance for the named location.

public static FSDirectory GetDirectory(
string path
);

Parameters

path
the path to the directory.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.GetDirectory Overload List


FSDirectory.GetDirectory Method (String, LockFactory)

Returns the directory instance for the named location.

public static FSDirectory GetDirectory(
string path,
LockFactory lockFactory
);

Parameters

path
the path to the directory.
lockFactory
instance of {@link LockFactory} providing the locking implementation.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.GetDirectory Overload List


FSDirectory.GetDirectory Method (String, Boolean)

Returns the directory instance for the named location.

public static FSDirectory GetDirectory(
string path,
bool create
);

Parameters

path
the path to the directory.
create
if true, create, or erase any existing contents.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.GetDirectory Overload List


FSDirectory.GetDisableLocks Method

Returns whether Lucene's use of lock files is disabled.

public static bool GetDisableLocks();

Return Value

true if locks are disabled, false if locks are enabled.

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.GetFile Method

public virtual FileInfo GetFile();

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.GetLockID Method

public override string GetLockID();

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.List Method

Returns an array of strings, one for each Lucene index file in the directory.

public override string[] List();

See Also

FSDirectory Class | Lucene.Net.Store Namespace


OpenInput Method

Apache Lucene.Net 2.4.0 Class Library API

FSDirectory.OpenInput Method

Overload List

public override IndexInput OpenInput(string);

public override IndexInput OpenInput(string,int);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.OpenInput Method (String)

public override IndexInput OpenInput(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.OpenInput Overload List


FSDirectory.OpenInput Method (String, Int32)

public override IndexInput OpenInput(
string name,
int bufferSize
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace | FSDirectory.OpenInput Overload List


FSDirectory.RenameFile Method

Renames an existing file in the directory. Warning: This is not atomic.

public override void RenameFile(
string from,
string to
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.SetDisableLocks Method

Set whether Lucene's use of lock files is disabled. By default, lock files are enabled. They should only be disabled if the index is on a read-only medium like a CD-ROM.

public static void SetDisableLocks(
bool doDisableLocks
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.Sync Method

public override void Sync(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.ToString Method

For debug output.

public override string ToString();

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.TouchFile Method

Set the modified time of an existing file to now.

public override void TouchFile(
string name
);

See Also

FSDirectory Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Class

For a list of all members of this type, see FSDirectory.FSIndexInput Members.

System.Object
Lucene.Net.Store.IndexInput
Lucene.Net.Store.BufferedIndexInput
Lucene.Net.Store.FSDirectory.FSIndexInput

public class FSDirectory.FSIndexInput : BufferedIndexInput

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FSDirectory.FSIndexInput Members | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Members

FSDirectory.FSIndexInput overview

Public Instance Constructors

FSDirectory.FSIndexInput Overloaded. Initializes a new instance of the FSDirectory.FSIndexInput class.

Public Instance Properties

isClone_ForNUnitTest

Public Instance Methods

Clone |
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBufferSize (inherited from BufferedIndexInput) |
GetFilePointer (inherited from BufferedIndexInput) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsFDValid | Method used for testing. Returns true if the underlying file descriptor is valid.
Length |
ReadByte (inherited from BufferedIndexInput) |
ReadBytes (inherited from BufferedIndexInput) | Overloaded.
ReadChars (inherited from IndexInput) | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt (inherited from IndexInput) | Reads four bytes and returns an int.
ReadLong (inherited from IndexInput) | Reads eight bytes and returns a long.
ReadModifiedUTF8String (inherited from IndexInput) |
ReadString (inherited from IndexInput) | Reads a string.
ReadVInt (inherited from IndexInput) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from IndexInput) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek (inherited from BufferedIndexInput) |
SetBufferSize (inherited from BufferedIndexInput) | Change the buffer size used by this IndexInput
SetModifiedUTF8StringsMode (inherited from IndexInput) | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars (inherited from IndexInput) | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

buffer (inherited from BufferedIndexInput)
file

Protected Internal Instance Methods

NewBuffer (inherited from BufferedIndexInput) |
ReadInternal | IndexInput methods
SeekInternal |

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Constructor

Overload List

public FSDirectory.FSIndexInput(FileInfo);

public FSDirectory.FSIndexInput(FileInfo,int);

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Constructor (FileInfo)

public FSDirectory.FSIndexInput(
FileInfo path
);

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace | FSDirectory.FSIndexInput Constructor Overload List


FSDirectory.FSIndexInput Constructor (FileInfo, Int32)

public FSDirectory.FSIndexInput(
FileInfo path,
int bufferSize
);

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace | FSDirectory.FSIndexInput Constructor Overload List


FSDirectory.FSIndexInput Fields

The fields of the FSDirectory.FSIndexInput class are listed below. For a complete list of FSDirectory.FSIndexInput class members, see the FSDirectory.FSIndexInput Members topic.

Protected Internal Instance Fields

buffer (inherited from BufferedIndexInput)
file

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.file Field

protected internal Descriptor file;

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Properties

The properties of the FSDirectory.FSIndexInput class are listed below. For a complete list of FSDirectory.FSIndexInput class members, see the FSDirectory.FSIndexInput Members topic.

Public Instance Properties

isClone_ForNUnitTest

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


isClone_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

FSDirectory.FSIndexInput.isClone_ForNUnitTest Property

public bool isClone_ForNUnitTest {get;}

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Methods

The methods of the FSDirectory.FSIndexInput class are listed below. For a complete list of FSDirectory.FSIndexInput class members, see the FSDirectory.FSIndexInput Members topic.

Public Instance Methods

Clone |
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBufferSize (inherited from BufferedIndexInput) |
GetFilePointer (inherited from BufferedIndexInput) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsFDValid | Method used for testing. Returns true if the underlying file descriptor is valid.
Length |
ReadByte (inherited from BufferedIndexInput) |
ReadBytes (inherited from BufferedIndexInput) | Overloaded.
ReadChars (inherited from IndexInput) | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt (inherited from IndexInput) | Reads four bytes and returns an int.
ReadLong (inherited from IndexInput) | Reads eight bytes and returns a long.
ReadModifiedUTF8String (inherited from IndexInput) |
ReadString (inherited from IndexInput) | Reads a string.
ReadVInt (inherited from IndexInput) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from IndexInput) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek (inherited from BufferedIndexInput) |
SetBufferSize (inherited from BufferedIndexInput) | Change the buffer size used by this IndexInput
SetModifiedUTF8StringsMode (inherited from IndexInput) | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars (inherited from IndexInput) | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

NewBuffer (inherited from BufferedIndexInput) |
ReadInternal | IndexInput methods
SeekInternal |

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Close Method

public override void Close();

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.IsFDValid Method

Method used for testing. Returns true if the underlying file descriptor is valid.

public virtual bool IsFDValid();

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Length Method

public override long Length();

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.ReadInternal Method

IndexInput methods

protected internal override void ReadInternal(
byte[] b,
int offset,
int len
);

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.SeekInternal Method

protected internal override void SeekInternal(
long position
);

See Also

FSDirectory.FSIndexInput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor Class

For a list of all members of this type, see FSDirectory.FSIndexInput.Descriptor Members.

System.Object
System.IO.BinaryReader
Lucene.Net.Store.FSDirectory.FSIndexInput.Descriptor

protected internal class FSDirectory.FSIndexInput.Descriptor : BinaryReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FSDirectory.FSIndexInput.Descriptor Members | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor Members

FSDirectory.FSIndexInput.Descriptor overview

Public Instance Constructors

FSDirectory.FSIndexInput.Descriptor Constructor

Public Instance Properties

BaseStream (inherited from BinaryReader) Exposes access to the underlying stream of the BinaryReader.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose (inherited from BinaryReader) | Releases the unmanaged resources used by the BinaryReader and optionally releases the managed resources.
FillBuffer (inherited from BinaryReader) | Fills the internal buffer with the specified number of bytes read from the stream.
Finalize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

isOpen

Protected Internal Instance Methods

Read7BitEncodedInt (inherited from BinaryReader) Reads in a 32-bit integer in a compressed format.

See Also

FSDirectory.FSIndexInput.Descriptor Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor Constructor

public FSDirectory.FSIndexInput.Descriptor(
FSIndexInput enclosingInstance,
FileInfo file,
FileAccess mode
);

See Also

FSDirectory.FSIndexInput.Descriptor Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor Fields

The fields of the FSDirectory.FSIndexInput.Descriptor class are listed below. For a complete list of FSDirectory.FSIndexInput.Descriptor class members, see the FSDirectory.FSIndexInput.Descriptor Members topic.

Protected Internal Instance Fields

isOpen

See Also

FSDirectory.FSIndexInput.Descriptor Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor.isOpen Field

protected internal bool isOpen;

See Also

FSDirectory.FSIndexInput.Descriptor Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor Methods

The methods of the FSDirectory.FSIndexInput.Descriptor class are listed below. For a complete list of FSDirectory.FSIndexInput.Descriptor class members, see the FSDirectory.FSIndexInput.Descriptor Members topic.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose (inherited from BinaryReader) | Releases the unmanaged resources used by the BinaryReader and optionally releases the managed resources.
FillBuffer (inherited from BinaryReader) | Fills the internal buffer with the specified number of bytes read from the stream.
Finalize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Read7BitEncodedInt (inherited from BinaryReader) Reads in a 32-bit integer in a compressed format.

See Also

FSDirectory.FSIndexInput.Descriptor Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor.Close Method

public override void Close();

See Also

FSDirectory.FSIndexInput.Descriptor Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor.Finalize Method

protected override void Finalize();

See Also

FSDirectory.FSIndexInput.Descriptor Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput Class

For a list of all members of this type, see FSDirectory.FSIndexOutput Members.

System.Object
Lucene.Net.Store.IndexOutput
Lucene.Net.Store.BufferedIndexOutput
Lucene.Net.Store.FSDirectory.FSIndexOutput

protected internal class FSDirectory.FSIndexOutput : BufferedIndexOutput

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

FSDirectory.FSIndexOutput Members | Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput Members

FSDirectory.FSIndexOutput overview

Public Instance Constructors

FSDirectory.FSIndexOutput Constructor

Public Instance Methods

Close |
CopyBytes (inherited from IndexOutput) | Copy numBytes bytes from input to ourself.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from BufferedIndexOutput) | Forces any buffered output to be written.
FlushBuffer | output methods:
GetFilePointer (inherited from BufferedIndexOutput) | Returns the current position in this file, where the next write will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
Seek | Random-access methods
SetLength |
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte (inherited from BufferedIndexOutput) | Writes a single byte.
WriteBytes (inherited from BufferedIndexOutput) | Overloaded. Writes an array of bytes.
WriteBytes (inherited from IndexOutput) | Overloaded. Writes an array of bytes.
WriteChars (inherited from IndexOutput) | Overloaded. Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.
WriteInt (inherited from IndexOutput) | Writes an int as four bytes.
WriteLong (inherited from IndexOutput) | Writes a long as eight bytes.
WriteString (inherited from IndexOutput) | Writes a string.
WriteVInt (inherited from IndexOutput) | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong (inherited from IndexOutput) | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FSDirectory.FSIndexOutput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput Constructor

public FSDirectory.FSIndexOutput(
FileInfo path
);

See Also

FSDirectory.FSIndexOutput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput Methods

The methods of the FSDirectory.FSIndexOutput class are listed below. For a complete list of FSDirectory.FSIndexOutput class members, see the FSDirectory.FSIndexOutput Members topic.

Public Instance Methods

Close |
CopyBytes (inherited from IndexOutput) | Copy numBytes bytes from input to ourself.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from BufferedIndexOutput) | Forces any buffered output to be written.
FlushBuffer | output methods:
GetFilePointer (inherited from BufferedIndexOutput) | Returns the current position in this file, where the next write will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
Seek | Random-access methods
SetLength |
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte (inherited from BufferedIndexOutput) | Writes a single byte.
WriteBytes (inherited from BufferedIndexOutput) | Overloaded. Writes an array of bytes.
WriteBytes (inherited from IndexOutput) | Overloaded. Writes an array of bytes.
WriteChars (inherited from IndexOutput) | Overloaded. Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.
WriteInt (inherited from IndexOutput) | Writes an int as four bytes.
WriteLong (inherited from IndexOutput) | Writes a long as eight bytes.
WriteString (inherited from IndexOutput) | Writes a string.
WriteVInt (inherited from IndexOutput) | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong (inherited from IndexOutput) | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FSDirectory.FSIndexOutput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput.Close Method

public override void Close();

See Also

FSDirectory.FSIndexOutput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput.FlushBuffer Method

output methods:

public override void FlushBuffer(
byte[] b,
int offset,
int size
);

See Also

FSDirectory.FSIndexOutput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput.Length Method

public override long Length();

See Also

FSDirectory.FSIndexOutput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput.Seek Method

Random-access methods

public override void Seek(
long pos
);

See Also

FSDirectory.FSIndexOutput Class | Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput.SetLength Method

public override void SetLength(
long length
);

See Also

FSDirectory.FSIndexOutput Class | Lucene.Net.Store Namespace


IndexInput Class

Abstract base class for input from a file in a {@link Directory}. A random-access input stream. Used for all Lucene index input operations.

For a list of all members of this type, see IndexInput Members.

System.Object
Lucene.Net.Store.IndexInput
Lucene.Net.Index.ByteSliceReader
Lucene.Net.Store.BufferedIndexInput
Lucene.Net.Store.ChecksumIndexInput
Lucene.Net.Store.RAMInputStream

public abstract class IndexInput : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexInput Members | Lucene.Net.Store Namespace |


IndexInput Members

IndexInput overview

Public Instance Methods

Clone |
Close | Closes the stream to futher operations.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilePointer | Returns the current position in this file, where the next read will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length | The number of bytes in the file.
ReadByte | Reads and returns a single byte.
ReadBytes | Overloaded. Reads a specified number of bytes into an array at the specified offset.
ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt | Reads four bytes and returns an int.
ReadLong | Reads eight bytes and returns a long.
ReadModifiedUTF8String |
ReadString | Reads a string.
ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek | Sets current position in this file, where the next read will occur.
SetModifiedUTF8StringsMode | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

IndexInput Constructor Initializes a new instance of the IndexInput class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexInput Class | Lucene.Net.Store Namespace |


IndexInput Constructor

Initializes a new instance of the IndexInput class.

protected IndexInput();

See Also

IndexInput Class | Lucene.Net.Store Namespace


IndexInput Methods

The methods of the IndexInput class are listed below. For a complete list of IndexInput class members, see the IndexInput Members topic.

Public Instance Methods

Clone |
Close | Closes the stream to futher operations.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilePointer | Returns the current position in this file, where the next read will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length | The number of bytes in the file.
ReadByte | Reads and returns a single byte.
ReadBytes | Overloaded. Reads a specified number of bytes into an array at the specified offset.
ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt | Reads four bytes and returns an int.
ReadLong | Reads eight bytes and returns a long.
ReadModifiedUTF8String |
ReadString | Reads a string.
ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek | Sets current position in this file, where the next read will occur.
SetModifiedUTF8StringsMode | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexInput Class | Lucene.Net.Store Namespace |


IndexInput.Clone Method

public virtual object Clone();

Implements

ICloneable.Clone

See Also

IndexInput Class | Lucene.Net.Store Namespace


IndexInput.Close Method

Closes the stream to futher operations.

public abstract void Close();

See Also

IndexInput Class | Lucene.Net.Store Namespace


IndexInput.GetFilePointer Method

Returns the current position in this file, where the next read will occur.

public abstract long GetFilePointer();

See Also

IndexInput Class | Lucene.Net.Store Namespace |


IndexInput.Length Method

The number of bytes in the file.

public abstract long Length();

See Also

IndexInput Class | Lucene.Net.Store Namespace


IndexInput.ReadByte Method

Reads and returns a single byte.

public abstract byte ReadByte();

See Also

IndexInput Class | Lucene.Net.Store Namespace |


ReadBytes Method

Apache Lucene.Net 2.4.0 Class Library API

IndexInput.ReadBytes Method

Reads a specified number of bytes into an array at the specified offset.

Overload List

Reads a specified number of bytes into an array at the specified offset.

public abstract void ReadBytes(byte[],int,int);

Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter.

public virtual void ReadBytes(byte[],int,int,bool);

See Also

IndexInput Class | Lucene.Net.Store Namespace |


IndexInput.ReadBytes Method (Byte[], Int32, Int32)

Reads a specified number of bytes into an array at the specified offset.

public abstract void ReadBytes(
byte[] b,
int offset,
int len
);

Parameters

b
the array to read bytes into
offset
the offset in the array to start storing bytes
len
the number of bytes to read

See Also

IndexInput Class | Lucene.Net.Store Namespace | IndexInput.ReadBytes Overload List |


IndexInput.ReadBytes Method (Byte[], Int32, Int32, Boolean)

Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter.

public virtual void ReadBytes(
byte[] b,
int offset,
int len,
bool useBuffer
);

Parameters

b
the array to read bytes into
offset
the offset in the array to start storing bytes
len
the number of bytes to read
useBuffer
set to false if the caller will handle buffering.

See Also

IndexInput Class | Lucene.Net.Store Namespace | IndexInput.ReadBytes Overload List |


IndexInput.ReadChars Method

NOTE: This method is now obsolete.

please use ReadString() or ReadBytes() instead

Reads Lucene's old "modified UTF-8" encoded characters into an array.

public virtual void ReadChars(
char[] buffer,
int start,
int length
);

Parameters

buffer
the array to read characters into
start
the offset in the array to start storing characters
length
the number of characters to read

See Also

IndexInput Class | Lucene.Net.Store Namespace |


IndexInput.ReadInt Method

Reads four bytes and returns an int.

public virtual int ReadInt();

See Also

IndexInput Class | Lucene.Net.Store Namespace |


IndexInput.ReadLong Method

Reads eight bytes and returns a long.

public virtual long ReadLong();

See Also

IndexInput Class | Lucene.Net.Store Namespace | IndexOutput#WriteLong


IndexInput.ReadModifiedUTF8String Method

public virtual string ReadModifiedUTF8String();

See Also

IndexInput Class | Lucene.Net.Store Namespace


IndexInput.ReadString Method

Reads a string.

public virtual string ReadString();

See Also

IndexInput Class | Lucene.Net.Store Namespace |


IndexInput.ReadVInt Method

Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

public virtual int ReadVInt();

See Also

IndexInput Class | Lucene.Net.Store Namespace |


IndexInput.ReadVLong Method

Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.

public virtual long ReadVLong();

See Also

IndexInput Class | Lucene.Net.Store Namespace


IndexInput.Seek Method

Sets current position in this file, where the next read will occur.

public abstract void Seek(
long pos
);

See Also

IndexInput Class | Lucene.Net.Store Namespace |


IndexInput.SetModifiedUTF8StringsMode Method

Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.

public void SetModifiedUTF8StringsMode();

See Also

IndexInput Class | Lucene.Net.Store Namespace


IndexInput.SkipChars Method

NOTE: This method is now obsolete.

this method operates on old "modified UTF-8" encoded strings

Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read

public virtual void SkipChars(
int length
);

Parameters

length
The number of chars to read

See Also

IndexInput Class | Lucene.Net.Store Namespace


IndexOutput Class

Abstract base class for output to a file in a Directory. A random-access output stream. Used for all Lucene index output operations.

For a list of all members of this type, see IndexOutput Members.

System.Object
Lucene.Net.Store.IndexOutput
Lucene.Net.Store.BufferedIndexOutput
Lucene.Net.Store.ChecksumIndexOutput
Lucene.Net.Store.RAMOutputStream

public abstract class IndexOutput

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

IndexOutput Members | Lucene.Net.Store Namespace | |


IndexOutput Members

IndexOutput overview

Public Instance Methods

Close | Closes this stream to further operations.
CopyBytes | Copy numBytes bytes from input to ourself.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Forces any buffered output to be written.
GetFilePointer | Returns the current position in this file, where the next write will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length | The number of bytes in the file.
Seek | Sets current position in this file, where the next write will occur.
SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for example @see FSDirectory) can use this to inform the underlying IO system to pre-allocate the file to the specified size. If the length is longer than the current file length, the bytes added to the file are undefined. Otherwise the file is truncated. file length
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte | Writes a single byte.
WriteBytes | Overloaded. Writes an array of bytes.
WriteChars | Overloaded. Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.
WriteInt | Writes an int as four bytes.
WriteLong | Writes a long as eight bytes.
WriteString | Writes a string.
WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Constructors

IndexOutput Constructor Initializes a new instance of the IndexOutput class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexOutput Class | Lucene.Net.Store Namespace | |


IndexOutput Constructor

Initializes a new instance of the IndexOutput class.

protected IndexOutput();

See Also

IndexOutput Class | Lucene.Net.Store Namespace


IndexOutput Methods

The methods of the IndexOutput class are listed below. For a complete list of IndexOutput class members, see the IndexOutput Members topic.

Public Instance Methods

Close | Closes this stream to further operations.
CopyBytes | Copy numBytes bytes from input to ourself.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Forces any buffered output to be written.
GetFilePointer | Returns the current position in this file, where the next write will occur.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length | The number of bytes in the file.
Seek | Sets current position in this file, where the next write will occur.
SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for example @see FSDirectory) can use this to inform the underlying IO system to pre-allocate the file to the specified size. If the length is longer than the current file length, the bytes added to the file are undefined. Otherwise the file is truncated. file length
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte | Writes a single byte.
WriteBytes | Overloaded. Writes an array of bytes.
WriteChars | Overloaded. Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.
WriteInt | Writes an int as four bytes.
WriteLong | Writes a long as eight bytes.
WriteString | Writes a string.
WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexOutput Class | Lucene.Net.Store Namespace | |


IndexOutput.Close Method

Closes this stream to further operations.

public abstract void Close();

See Also

IndexOutput Class | Lucene.Net.Store Namespace


IndexOutput.CopyBytes Method

Copy numBytes bytes from input to ourself.

public virtual void CopyBytes(
IndexInput input,
long numBytes
);

See Also

IndexOutput Class | Lucene.Net.Store Namespace


IndexOutput.Flush Method

Forces any buffered output to be written.

public abstract void Flush();

See Also

IndexOutput Class | Lucene.Net.Store Namespace


IndexOutput.GetFilePointer Method

Returns the current position in this file, where the next write will occur.

public abstract long GetFilePointer();

See Also

IndexOutput Class | Lucene.Net.Store Namespace |


IndexOutput.Length Method

The number of bytes in the file.

public abstract long Length();

See Also

IndexOutput Class | Lucene.Net.Store Namespace


IndexOutput.Seek Method

Sets current position in this file, where the next write will occur.

public abstract void Seek(
long pos
);

See Also

IndexOutput Class | Lucene.Net.Store Namespace |


IndexOutput.SetLength Method

Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for example @see FSDirectory) can use this to inform the underlying IO system to pre-allocate the file to the specified size. If the length is longer than the current file length, the bytes added to the file are undefined. Otherwise the file is truncated. file length

public virtual void SetLength(
long length
);

See Also

IndexOutput Class | Lucene.Net.Store Namespace


IndexOutput.WriteByte Method

Writes a single byte.

public abstract void WriteByte(
byte b
);

See Also

IndexOutput Class | Lucene.Net.Store Namespace |


WriteBytes Method

Apache Lucene.Net 2.4.0 Class Library API

IndexOutput.WriteBytes Method

Writes an array of bytes.

Overload List

Writes an array of bytes.

public virtual void WriteBytes(byte[],int);

Writes an array of bytes.

public abstract void WriteBytes(byte[],int,int);

See Also

IndexOutput Class | Lucene.Net.Store Namespace |


IndexOutput.WriteBytes Method (Byte[], Int32)

Writes an array of bytes.

public virtual void WriteBytes(
byte[] b,
int length
);

Parameters

b
the bytes to write
length
the number of bytes to write

See Also

IndexOutput Class | Lucene.Net.Store Namespace | IndexOutput.WriteBytes Overload List |


IndexOutput.WriteBytes Method (Byte[], Int32, Int32)

Writes an array of bytes.

public abstract void WriteBytes(
byte[] b,
int offset,
int length
);

Parameters

b
the bytes to write
offset
the offset in the byte array
length
the number of bytes to write

See Also

IndexOutput Class | Lucene.Net.Store Namespace | IndexOutput.WriteBytes Overload List |


WriteChars Method

Apache Lucene.Net 2.4.0 Class Library API

IndexOutput.WriteChars Method

NOTE: This method is now obsolete.

please pre-convert to UTF-8 bytes or use WriteString()

Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.

Overload List

Obsolete. Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.

public virtual void WriteChars(char[],int,int);

Obsolete. Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.

public virtual void WriteChars(string,int,int);

See Also

IndexOutput Class | Lucene.Net.Store Namespace


IndexOutput.WriteChars Method (Char[], Int32, Int32)

NOTE: This method is now obsolete.

please pre-convert to UTF-8 bytes or use WriteString()

Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.

public virtual void WriteChars(
char[] s,
int start,
int length
);

Parameters

s
the source of the characters
start
the first character in the sequence
length
the number of characters in the sequence

See Also

IndexOutput Class | Lucene.Net.Store Namespace | IndexOutput.WriteChars Overload List


IndexOutput.WriteChars Method (String, Int32, Int32)

NOTE: This method is now obsolete.

please pre-convert to UTF-8 bytes or use WriteString()

Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.

public virtual void WriteChars(
string s,
int start,
int length
);

Parameters

s
the source of the characters
start
the first character in the sequence
length
the number of characters in the sequence

See Also

IndexOutput Class | Lucene.Net.Store Namespace | IndexOutput.WriteChars Overload List


IndexOutput.WriteInt Method

Writes an int as four bytes.

public virtual void WriteInt(
int i
);

See Also

IndexOutput Class | Lucene.Net.Store Namespace |


IndexOutput.WriteLong Method

Writes a long as eight bytes.

public virtual void WriteLong(
long i
);

See Also

IndexOutput Class | Lucene.Net.Store Namespace |


IndexOutput.WriteString Method

Writes a string.

public virtual void WriteString(
string s
);

See Also

IndexOutput Class | Lucene.Net.Store Namespace |


IndexOutput.WriteVInt Method

Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

public virtual void WriteVInt(
int i
);

See Also

IndexOutput Class | Lucene.Net.Store Namespace |


IndexOutput.WriteVLong Method

Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

public virtual void WriteVLong(
long i
);

See Also

IndexOutput Class | Lucene.Net.Store Namespace |


Lock Class

For a list of all members of this type, see Lock Members.

System.Object
Lucene.Net.Store.Lock

public abstract class Lock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Lock Members | Lucene.Net.Store Namespace


Lock Members

Lock overview

Public Static Fields

LOCK_OBTAIN_WAIT_FOREVER | Pass this value to {@link #Obtain(long)} to try forever to obtain the lock.
LOCK_POLL_INTERVAL | How long {@link #Obtain(long)} waits, in milliseconds, in between attempts to acquire the lock.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLocked | Returns true if the resource is currently locked. Note that one must still call {@link #Obtain()} before using the resource.
Obtain | Overloaded. Attempts to obtain exclusive access and immediately return upon success or failure.
Release | Releases exclusive access.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Lock Constructor Initializes a new instance of the Lock class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

failureReason If a lock obtain called, this failureReason may be set with the "root cause" Exception as to why the lock was not obtained.

See Also

Lock Class | Lucene.Net.Store Namespace


Lock Constructor

Initializes a new instance of the Lock class.

protected Lock();

See Also

Lock Class | Lucene.Net.Store Namespace


Lock Fields

The fields of the Lock class are listed below. For a complete list of Lock class members, see the Lock Members topic.

Public Static Fields

LOCK_OBTAIN_WAIT_FOREVER | Pass this value to {@link #Obtain(long)} to try forever to obtain the lock.
LOCK_POLL_INTERVAL | How long {@link #Obtain(long)} waits, in milliseconds, in between attempts to acquire the lock.

Protected Internal Instance Fields

failureReason If a lock obtain called, this failureReason may be set with the "root cause" Exception as to why the lock was not obtained.

See Also

Lock Class | Lucene.Net.Store Namespace


Lock.failureReason Field

If a lock obtain called, this failureReason may be set with the "root cause" Exception as to why the lock was not obtained.

protected internal Exception failureReason;

See Also

Lock Class | Lucene.Net.Store Namespace


Lock.LOCK_OBTAIN_WAIT_FOREVER Field

Pass this value to {@link #Obtain(long)} to try forever to obtain the lock.

public const long LOCK_OBTAIN_WAIT_FOREVER = -1;

See Also

Lock Class | Lucene.Net.Store Namespace


Lock.LOCK_POLL_INTERVAL Field

How long {@link #Obtain(long)} waits, in milliseconds, in between attempts to acquire the lock.

public static long LOCK_POLL_INTERVAL;

See Also

Lock Class | Lucene.Net.Store Namespace


Lock Methods

The methods of the Lock class are listed below. For a complete list of Lock class members, see the Lock Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLocked | Returns true if the resource is currently locked. Note that one must still call {@link #Obtain()} before using the resource.
Obtain | Overloaded. Attempts to obtain exclusive access and immediately return upon success or failure.
Release | Releases exclusive access.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Lock Class | Lucene.Net.Store Namespace


Lock.IsLocked Method

Returns true if the resource is currently locked. Note that one must still call {@link #Obtain()} before using the resource.

public abstract bool IsLocked();

See Also

Lock Class | Lucene.Net.Store Namespace


Obtain Method

Apache Lucene.Net 2.4.0 Class Library API

Lock.Obtain Method

Attempts to obtain exclusive access and immediately return upon success or failure.

Overload List

Attempts to obtain exclusive access and immediately return upon success or failure.

public abstract bool Obtain();

Attempts to obtain an exclusive lock within amount of time given. Polls once per {@link #LOCK_POLL_INTERVAL} (currently 1000) milliseconds until lockWaitTimeout is passed.

public virtual bool Obtain(long);

See Also

Lock Class | Lucene.Net.Store Namespace


Lock.Obtain Method ()

Attempts to obtain exclusive access and immediately return upon success or failure.

public abstract bool Obtain();

Return Value

true iff exclusive access is obtained

See Also

Lock Class | Lucene.Net.Store Namespace | Lock.Obtain Overload List


Lock.Obtain Method (Int64)

Attempts to obtain an exclusive lock within amount of time given. Polls once per {@link #LOCK_POLL_INTERVAL} (currently 1000) milliseconds until lockWaitTimeout is passed.

public virtual bool Obtain(
long lockWaitTimeout
);

Parameters

lockWaitTimeout
length of time to wait in milliseconds or {@link #LOCK_OBTAIN_WAIT_FOREVER} to retry forever

Return Value

true if lock was obtained

See Also

Lock Class | Lucene.Net.Store Namespace | Lock.Obtain Overload List


Lock.Release Method

Releases exclusive access.

public abstract void Release();

See Also

Lock Class | Lucene.Net.Store Namespace


Lock.With Class

Utility class for executing code with exclusive access.

For a list of all members of this type, see Lock.With Members.

System.Object
Lucene.Net.Store.Lock.With

public abstract class Lock.With

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Lock.With Members | Lucene.Net.Store Namespace


Lock.With Members

Lock.With overview

Public Instance Constructors

Lock.With Constructor Constructs an executor that will grab the named lock.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Calls {@link #doBody} while lock is obtained. Blocks if lock cannot be obtained immediately. Retries to obtain lock once per second until it is obtained, or until it has tried ten times. Lock is released when {@link #doBody} exits.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

DoBody Code to execute with exclusive access.

See Also

Lock.With Class | Lucene.Net.Store Namespace


Lock.With Constructor

Constructs an executor that will grab the named lock.

public Lock.With(
Lock lock_Renamed,
long lockWaitTimeout
);

See Also

Lock.With Class | Lucene.Net.Store Namespace


Lock.With Methods

The methods of the Lock.With class are listed below. For a complete list of Lock.With class members, see the Lock.With Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Calls {@link #doBody} while lock is obtained. Blocks if lock cannot be obtained immediately. Retries to obtain lock once per second until it is obtained, or until it has tried ten times. Lock is released when {@link #doBody} exits.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

DoBody Code to execute with exclusive access.

See Also

Lock.With Class | Lucene.Net.Store Namespace


Lock.With.DoBody Method

Code to execute with exclusive access.

protected internal abstract object DoBody();

See Also

Lock.With Class | Lucene.Net.Store Namespace


Lock.With.Run Method

Calls {@link #doBody} while lock is obtained. Blocks if lock cannot be obtained immediately. Retries to obtain lock once per second until it is obtained, or until it has tried ten times. Lock is released when {@link #doBody} exits.

public virtual object Run();

See Also

Lock.With Class | Lucene.Net.Store Namespace


LockFactory Class

Base class for Locking implementation. {@link Directory} uses instances of this class to implement locking.

Note that there are some useful tools to verify that your LockFactory is working correctly: {@link VerifyingLockFactory}, {@link LockStressTest}, {@link LockVerifyServer}.

For a list of all members of this type, see LockFactory Members.

System.Object
Lucene.Net.Store.LockFactory
Lucene.Net.Store.NativeFSLockFactory
Lucene.Net.Store.NoLockFactory
Lucene.Net.Store.SimpleFSLockFactory
Lucene.Net.Store.SingleInstanceLockFactory
Lucene.Net.Store.VerifyingLockFactory

public abstract class LockFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LockFactory Members | Lucene.Net.Store Namespace | | |


LockFactory Members

LockFactory overview

Public Instance Methods

ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockPrefix | Get the prefix in use for all locks created in this LockFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeLock | Return a new Lock instance identified by lockName.
SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

LockFactory Constructor Initializes a new instance of the LockFactory class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

lockPrefix

See Also

LockFactory Class | Lucene.Net.Store Namespace | | |


LockFactory Constructor

Initializes a new instance of the LockFactory class.

protected LockFactory();

See Also

LockFactory Class | Lucene.Net.Store Namespace


LockFactory Fields

The fields of the LockFactory class are listed below. For a complete list of LockFactory class members, see the LockFactory Members topic.

Protected Internal Instance Fields

lockPrefix

See Also

LockFactory Class | Lucene.Net.Store Namespace | | |


LockFactory.lockPrefix Field

protected internal string lockPrefix;

See Also

LockFactory Class | Lucene.Net.Store Namespace


LockFactory Methods

The methods of the LockFactory class are listed below. For a complete list of LockFactory class members, see the LockFactory Members topic.

Public Instance Methods

ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockPrefix | Get the prefix in use for all locks created in this LockFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeLock | Return a new Lock instance identified by lockName.
SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockFactory Class | Lucene.Net.Store Namespace | | |


LockFactory.ClearLock Method

Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.

public abstract void ClearLock(
string lockName
);

Parameters

lockName
name of the lock to be cleared.

See Also

LockFactory Class | Lucene.Net.Store Namespace


LockFactory.GetLockPrefix Method

Get the prefix in use for all locks created in this LockFactory.

public virtual string GetLockPrefix();

See Also

LockFactory Class | Lucene.Net.Store Namespace


LockFactory.MakeLock Method

Return a new Lock instance identified by lockName.

public abstract Lock MakeLock(
string lockName
);

Parameters

lockName
name of the lock to be created.

See Also

LockFactory Class | Lucene.Net.Store Namespace


LockFactory.SetLockPrefix Method

Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.

public virtual void SetLockPrefix(
string lockPrefix
);

See Also

LockFactory Class | Lucene.Net.Store Namespace


LockObtainFailedException Class

This exception is thrown when the

write.lock
could not be acquired. This happens when a writer tries to open an index that another writer already has open.

For a list of all members of this type, see LockObtainFailedException Members.

System.Object
System.Exception
System.SystemException
System.IO.IOException
Lucene.Net.Store.LockObtainFailedException

public class LockObtainFailedException : IOException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LockObtainFailedException Members | Lucene.Net.Store Namespace | obtain


LockObtainFailedException Members

LockObtainFailedException overview

Public Instance Constructors

LockObtainFailedException Overloaded. Initializes a new instance of the LockObtainFailedException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockObtainFailedException Class | Lucene.Net.Store Namespace | obtain


LockObtainFailedException Constructor

Overload List

public LockObtainFailedException(string);

public LockObtainFailedException(string,Exception);

See Also

LockObtainFailedException Class | Lucene.Net.Store Namespace


LockObtainFailedException Constructor (String)

public LockObtainFailedException(
string message
);

See Also

LockObtainFailedException Class | Lucene.Net.Store Namespace | LockObtainFailedException Constructor Overload List


LockObtainFailedException Constructor (String, Exception)

public LockObtainFailedException(
string message,
Exception cause
);

See Also

LockObtainFailedException Class | Lucene.Net.Store Namespace | LockObtainFailedException Constructor Overload List


LockReleaseFailedException Class

This exception is thrown when the

write.lock
could not be released.

For a list of all members of this type, see LockReleaseFailedException Members.

System.Object
System.Exception
System.SystemException
System.IO.IOException
Lucene.Net.Store.LockReleaseFailedException

public class LockReleaseFailedException : IOException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LockReleaseFailedException Members | Lucene.Net.Store Namespace | release


LockReleaseFailedException Members

LockReleaseFailedException overview

Public Instance Constructors

LockReleaseFailedException Constructor

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockReleaseFailedException Class | Lucene.Net.Store Namespace | release


LockReleaseFailedException Constructor

public LockReleaseFailedException(
string message
);

See Also

LockReleaseFailedException Class | Lucene.Net.Store Namespace


LockStressTest Class

For a list of all members of this type, see LockStressTest Members.

System.Object
Lucene.Net.Store.LockStressTest

public class LockStressTest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LockStressTest Members | Lucene.Net.Store Namespace


LockStressTest Members

LockStressTest overview

Public Static Methods

Main

Public Instance Constructors

LockStressTest Constructor Initializes a new instance of the LockStressTest class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockStressTest Class | Lucene.Net.Store Namespace


LockStressTest Constructor

Initializes a new instance of the LockStressTest class.

public LockStressTest();

See Also

LockStressTest Class | Lucene.Net.Store Namespace


LockStressTest Methods

The methods of the LockStressTest class are listed below. For a complete list of LockStressTest class members, see the LockStressTest Members topic.

Public Static Methods

Main

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockStressTest Class | Lucene.Net.Store Namespace


LockStressTest.Main Method

public static void Main(
string[] args
);

See Also

LockStressTest Class | Lucene.Net.Store Namespace


LockVerifyServer Class

Simple standalone server that must be running when you use {@link VerifyingLockFactory}. This server simply verifies at most one process holds the lock at a time. Run without any args to see usage.

For a list of all members of this type, see LockVerifyServer Members.

System.Object
Lucene.Net.Store.LockVerifyServer

public class LockVerifyServer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

LockVerifyServer Members | Lucene.Net.Store Namespace | |


LockVerifyServer Members

LockVerifyServer overview

Public Static Methods

Main

Public Instance Constructors

LockVerifyServer Constructor Initializes a new instance of the LockVerifyServer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockVerifyServer Class | Lucene.Net.Store Namespace | |


LockVerifyServer Constructor

Initializes a new instance of the LockVerifyServer class.

public LockVerifyServer();

See Also

LockVerifyServer Class | Lucene.Net.Store Namespace


LockVerifyServer Methods

The methods of the LockVerifyServer class are listed below. For a complete list of LockVerifyServer class members, see the LockVerifyServer Members topic.

Public Static Methods

Main

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockVerifyServer Class | Lucene.Net.Store Namespace | |


LockVerifyServer.Main Method

public static void Main(
string[] args
);

See Also

LockVerifyServer Class | Lucene.Net.Store Namespace


MMapDirectory Class

For a list of all members of this type, see MMapDirectory Members.

System.Object
Lucene.Net.Store.Directory
Lucene.Net.Store.FSDirectory
Lucene.Net.Store.MMapDirectory

public class MMapDirectory : FSDirectory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

MMapDirectory Members | Lucene.Net.Store Namespace


MMapDirectory Members

MMapDirectory overview

Public Instance Constructors

MMapDirectory Constructor Initializes a new instance of the MMapDirectory class.

Public Instance Methods

ClearLock (inherited from Directory) | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Close (inherited from FSDirectory) | Closes the store to future operations.
CreateOutput (inherited from FSDirectory) | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile (inherited from FSDirectory) | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists (inherited from FSDirectory) | Returns true iff a file with the given name exists.
FileLength (inherited from FSDirectory) | Returns the length in bytes of a file in the directory.
FileModified (inherited from FSDirectory) | Returns the time the named file was last modified.
GetFile (inherited from FSDirectory) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockFactory (inherited from Directory) | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
GetLockID (inherited from FSDirectory) |
GetType (inherited from Object) | Gets the Type of the current instance.
List (inherited from FSDirectory) | Returns an array of strings, one for each Lucene index file in the directory.
MakeLock (inherited from Directory) | Construct a {@link Lock}.
OpenInput | Overloaded.
RenameFile (inherited from FSDirectory) | Renames an existing file in the directory. Warning: This is not atomic.
SetLockFactory (inherited from Directory) | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Sync (inherited from FSDirectory) |
ToString (inherited from FSDirectory) | For debug output.
TouchFile (inherited from FSDirectory) | Set the modified time of an existing file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

isOpen (inherited from Directory) |
lockFactory (inherited from Directory) | Holds the LockFactory instance (implements locking for this Directory instance).

Protected Internal Instance Methods

EnsureOpen (inherited from Directory) Throws AlreadyClosedException if this Directory is closed.

See Also

MMapDirectory Class | Lucene.Net.Store Namespace


MMapDirectory Constructor

Initializes a new instance of the MMapDirectory class.

public MMapDirectory();

See Also

MMapDirectory Class | Lucene.Net.Store Namespace


MMapDirectory Methods

The methods of the MMapDirectory class are listed below. For a complete list of MMapDirectory class members, see the MMapDirectory Members topic.

Public Instance Methods

ClearLock (inherited from Directory) | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Close (inherited from FSDirectory) | Closes the store to future operations.
CreateOutput (inherited from FSDirectory) | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile (inherited from FSDirectory) | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists (inherited from FSDirectory) | Returns true iff a file with the given name exists.
FileLength (inherited from FSDirectory) | Returns the length in bytes of a file in the directory.
FileModified (inherited from FSDirectory) | Returns the time the named file was last modified.
GetFile (inherited from FSDirectory) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockFactory (inherited from Directory) | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
GetLockID (inherited from FSDirectory) |
GetType (inherited from Object) | Gets the Type of the current instance.
List (inherited from FSDirectory) | Returns an array of strings, one for each Lucene index file in the directory.
MakeLock (inherited from Directory) | Construct a {@link Lock}.
OpenInput | Overloaded.
RenameFile (inherited from FSDirectory) | Renames an existing file in the directory. Warning: This is not atomic.
SetLockFactory (inherited from Directory) | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Sync (inherited from FSDirectory) |
ToString (inherited from FSDirectory) | For debug output.
TouchFile (inherited from FSDirectory) | Set the modified time of an existing file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

EnsureOpen (inherited from Directory) Throws AlreadyClosedException if this Directory is closed.

See Also

MMapDirectory Class | Lucene.Net.Store Namespace


OpenInput Method

Apache Lucene.Net 2.4.0 Class Library API

MMapDirectory.OpenInput Method

Overload List

public override IndexInput OpenInput(string);

public override IndexInput OpenInput(string,int);

See Also

MMapDirectory Class | Lucene.Net.Store Namespace


MMapDirectory.OpenInput Method (String)

public override IndexInput OpenInput(
string name
);

See Also

MMapDirectory Class | Lucene.Net.Store Namespace | MMapDirectory.OpenInput Overload List


MMapDirectory.OpenInput Method (String, Int32)

public override IndexInput OpenInput(
string name,
int bufferSize
);

See Also

MMapDirectory Class | Lucene.Net.Store Namespace | MMapDirectory.OpenInput Overload List


NativeFSLockFactory Class

Implements {@link LockFactory} using native OS file locks. Note that because this LockFactory relies on java.nio.* APIs for locking, any problems with those APIs will cause locking to fail. Specifically, on certain NFS environments the java.nio.* locks will fail (the lock can incorrectly be double acquired) whereas {@link SimpleFSLockFactory} worked perfectly in those same environments. For NFS based access to an index, it's recommended that you try {@link SimpleFSLockFactory} first and work around the one limitation that a lock file could be left when the JVM exits abnormally.

The primary benefit of {@link NativeFSLockFactory} is that lock files will be properly removed (by the OS) if the JVM has an abnormal exit.

Note that, unlike {@link SimpleFSLockFactory}, the existence of leftover lock files in the filesystem on exiting the JVM is fine because the OS will free the locks held against these files even though the files still remain.

If you suspect that this or any other LockFactory is not working properly in your environment, you can easily test it by using {@link VerifyingLockFactory}, {@link LockVerifyServer} and {@link LockStressTest}.

For a list of all members of this type, see NativeFSLockFactory Members.

System.Object
Lucene.Net.Store.LockFactory
Lucene.Net.Store.NativeFSLockFactory

public class NativeFSLockFactory : LockFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

NativeFSLockFactory Members | Lucene.Net.Store Namespace |


NativeFSLockFactory Members

NativeFSLockFactory overview

Public Instance Constructors

NativeFSLockFactory Overloaded. Initializes a new instance of the NativeFSLockFactory class.

Public Instance Methods

ClearLock |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockPrefix (inherited from LockFactory) | Get the prefix in use for all locks created in this LockFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeLock |
SetLockPrefix (inherited from LockFactory) | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

lockPrefix (inherited from LockFactory)

See Also

NativeFSLockFactory Class | Lucene.Net.Store Namespace |


NativeFSLockFactory Constructor

Create a NativeFSLockFactory instance, storing lock files into the specified lockDirName:

Overload List

Create a NativeFSLockFactory instance, storing lock files into the specified lockDir:

public NativeFSLockFactory(FileInfo);

Create a NativeFSLockFactory instance, storing lock files into the specified lockDirName:

public NativeFSLockFactory(string);

See Also

NativeFSLockFactory Class | Lucene.Net.Store Namespace


NativeFSLockFactory Constructor (String)

Create a NativeFSLockFactory instance, storing lock files into the specified lockDirName:

public NativeFSLockFactory(
string lockDirName
);

Parameters

lockDirName
where lock files are created.

See Also

NativeFSLockFactory Class | Lucene.Net.Store Namespace | NativeFSLockFactory Constructor Overload List


NativeFSLockFactory Constructor (FileInfo)

Create a NativeFSLockFactory instance, storing lock files into the specified lockDir:

public NativeFSLockFactory(
FileInfo lockDir
);

Parameters

lockDir
where lock files are created.

See Also

NativeFSLockFactory Class | Lucene.Net.Store Namespace | NativeFSLockFactory Constructor Overload List


NativeFSLockFactory Methods

The methods of the NativeFSLockFactory class are listed below. For a complete list of NativeFSLockFactory class members, see the NativeFSLockFactory Members topic.

Public Instance Methods

ClearLock |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockPrefix (inherited from LockFactory) | Get the prefix in use for all locks created in this LockFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeLock |
SetLockPrefix (inherited from LockFactory) | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NativeFSLockFactory Class | Lucene.Net.Store Namespace |


NativeFSLockFactory.ClearLock Method

public override void ClearLock(
string lockName
);

See Also

NativeFSLockFactory Class | Lucene.Net.Store Namespace


NativeFSLockFactory.MakeLock Method

public override Lock MakeLock(
string lockName
);

See Also

NativeFSLockFactory Class | Lucene.Net.Store Namespace


NoLockFactory Class

Use this {@link LockFactory} to disable locking entirely. This LockFactory is used when you call {@link FSDirectory#setDisableLocks}. Only one instance of this lock is created. You should call {@link #GetNoLockFactory()} to get the instance.

For a list of all members of this type, see NoLockFactory Members.

System.Object
Lucene.Net.Store.LockFactory
Lucene.Net.Store.NoLockFactory

public class NoLockFactory : LockFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

NoLockFactory Members | Lucene.Net.Store Namespace |


NoLockFactory Members

NoLockFactory overview

Public Static Methods

GetNoLockFactory

Public Instance Constructors

NoLockFactory Constructor Initializes a new instance of the NoLockFactory class.

Public Instance Methods

ClearLock |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockPrefix (inherited from LockFactory) | Get the prefix in use for all locks created in this LockFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeLock |
SetLockPrefix (inherited from LockFactory) | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

lockPrefix (inherited from LockFactory)

See Also

NoLockFactory Class | Lucene.Net.Store Namespace |


NoLockFactory Constructor

Initializes a new instance of the NoLockFactory class.

public NoLockFactory();

See Also

NoLockFactory Class | Lucene.Net.Store Namespace


NoLockFactory Methods

The methods of the NoLockFactory class are listed below. For a complete list of NoLockFactory class members, see the NoLockFactory Members topic.

Public Static Methods

GetNoLockFactory

Public Instance Methods

ClearLock |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockPrefix (inherited from LockFactory) | Get the prefix in use for all locks created in this LockFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeLock |
SetLockPrefix (inherited from LockFactory) | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NoLockFactory Class | Lucene.Net.Store Namespace |


NoLockFactory.ClearLock Method

public override void ClearLock(
string lockName
);

See Also

NoLockFactory Class | Lucene.Net.Store Namespace


NoLockFactory.GetNoLockFactory Method

public static NoLockFactory GetNoLockFactory();

See Also

NoLockFactory Class | Lucene.Net.Store Namespace


NoLockFactory.MakeLock Method

public override Lock MakeLock(
string lockName
);

See Also

NoLockFactory Class | Lucene.Net.Store Namespace


RAMDirectory Class

A memory-resident {@link Directory} implementation. Locking implementation is by default the {@link SingleInstanceLockFactory} but can be changed with {@link #setLockFactory}.

For a list of all members of this type, see RAMDirectory Members.

System.Object
Lucene.Net.Store.Directory
Lucene.Net.Store.RAMDirectory

public class RAMDirectory : Directory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RAMDirectory Members | Lucene.Net.Store Namespace


RAMDirectory Members

RAMDirectory overview

Public Instance Constructors

RAMDirectory Overloaded. Initializes a new instance of the RAMDirectory class.

Public Instance Properties

fileMap_ForNUnitTest
sizeInBytes_ForNUnitTest

Public Instance Methods

ClearLock (inherited from Directory) | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Close | Closes the store to future operations, releasing associated memory.
CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff the named file exists in this directory.
FileLength | Returns the length in bytes of a file in the directory.
FileModified | Returns the time the named file was last modified.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockFactory (inherited from Directory) | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
GetLockID (inherited from Directory) | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory.
MakeLock (inherited from Directory) | Construct a {@link Lock}.
OpenInput | Overloaded. Returns a stream reading an existing file.
OpenInput (inherited from Directory) | Overloaded. Returns a stream reading an existing file.
RenameFile | Renames an existing file in the directory.
SetLockFactory (inherited from Directory) | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
SizeInBytes | Return total size in bytes of all files in this directory. This is currently quantized to RAMOutputStream.BUFFER_SIZE.
Sync (inherited from Directory) | Ensure that any writes to the file are moved to stable storage. Lucene uses this to properly commit chages to the index, to prevent a machine/OS crash from corrupting the index.
ToString (inherited from Object) | Returns a String that represents the current Object.
TouchFile | Set the modified time of an existing file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

isOpen (inherited from Directory) |
lockFactory (inherited from Directory) | Holds the LockFactory instance (implements locking for this Directory instance).

Protected Internal Instance Methods

EnsureOpen

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory Constructor

Constructs an empty {@link Directory}.

Overload List

Constructs an empty {@link Directory}.

public RAMDirectory();

public RAMDirectory(Directory);

Creates a new

RAMDirectory
instance from the {@link FSDirectory}.

public RAMDirectory(FileInfo);

Creates a new

RAMDirectory
instance from the {@link FSDirectory}.

public RAMDirectory(string);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory Constructor ()

Constructs an empty {@link Directory}.

public RAMDirectory();

See Also

RAMDirectory Class | Lucene.Net.Store Namespace | RAMDirectory Constructor Overload List


RAMDirectory Constructor (Directory)

public RAMDirectory(
Directory dir
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace | RAMDirectory Constructor Overload List


RAMDirectory Constructor (FileInfo)

Creates a new

RAMDirectory
instance from the {@link FSDirectory}.

public RAMDirectory(
FileInfo dir
);

Parameters

dir
a
File
specifying the index directory

See Also

RAMDirectory Class | Lucene.Net.Store Namespace | RAMDirectory Constructor Overload List |


RAMDirectory Constructor (String)

Creates a new

RAMDirectory
instance from the {@link FSDirectory}.

public RAMDirectory(
string dir
);

Parameters

dir
a
String
specifying the full index directory path

See Also

RAMDirectory Class | Lucene.Net.Store Namespace | RAMDirectory Constructor Overload List |


RAMDirectory Properties

The properties of the RAMDirectory class are listed below. For a complete list of RAMDirectory class members, see the RAMDirectory Members topic.

Public Instance Properties

fileMap_ForNUnitTest
sizeInBytes_ForNUnitTest

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


fileMap_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

RAMDirectory.fileMap_ForNUnitTest Property

public System.Collections.Hashtable fileMap_ForNUnitTest {get;}

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


sizeInBytes_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

RAMDirectory.sizeInBytes_ForNUnitTest Property

public long sizeInBytes_ForNUnitTest {get; set;}

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory Methods

The methods of the RAMDirectory class are listed below. For a complete list of RAMDirectory class members, see the RAMDirectory Members topic.

Public Instance Methods

ClearLock (inherited from Directory) | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Close | Closes the store to future operations, releasing associated memory.
CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
DeleteFile | Removes an existing file in the directory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileExists | Returns true iff the named file exists in this directory.
FileLength | Returns the length in bytes of a file in the directory.
FileModified | Returns the time the named file was last modified.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockFactory (inherited from Directory) | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
GetLockID (inherited from Directory) | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.
GetType (inherited from Object) | Gets the Type of the current instance.
List | Returns an array of strings, one for each file in the directory.
MakeLock (inherited from Directory) | Construct a {@link Lock}.
OpenInput | Overloaded. Returns a stream reading an existing file.
OpenInput (inherited from Directory) | Overloaded. Returns a stream reading an existing file.
RenameFile | Renames an existing file in the directory.
SetLockFactory (inherited from Directory) | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
SizeInBytes | Return total size in bytes of all files in this directory. This is currently quantized to RAMOutputStream.BUFFER_SIZE.
Sync (inherited from Directory) | Ensure that any writes to the file are moved to stable storage. Lucene uses this to properly commit chages to the index, to prevent a machine/OS crash from corrupting the index.
ToString (inherited from Object) | Returns a String that represents the current Object.
TouchFile | Set the modified time of an existing file to now.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

EnsureOpen

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.Close Method

Closes the store to future operations, releasing associated memory.

public override void Close();

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.CreateOutput Method

Creates a new, empty file in the directory with the given name. Returns a stream writing this file.

public override IndexOutput CreateOutput(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.DeleteFile Method

Removes an existing file in the directory.

public override void DeleteFile(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.EnsureOpen Method

protected internal override void EnsureOpen();

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.FileExists Method

Returns true iff the named file exists in this directory.

public override bool FileExists(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.FileLength Method

Returns the length in bytes of a file in the directory.

public override long FileLength(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.FileModified Method

Returns the time the named file was last modified.

public override long FileModified(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.List Method

Returns an array of strings, one for each file in the directory.

public override string[] List();

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


OpenInput Method

Apache Lucene.Net 2.4.0 Class Library API

RAMDirectory.OpenInput Method

Returns a stream reading an existing file.

Overload List

Returns a stream reading an existing file.

public override IndexInput OpenInput(string);

Inherited from Directory.

public virtual IndexInput OpenInput(string,int);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.OpenInput Method (String)

Returns a stream reading an existing file.

public override IndexInput OpenInput(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace | RAMDirectory.OpenInput Overload List


RAMDirectory.RenameFile Method

Renames an existing file in the directory.

public override void RenameFile(
string from,
string to
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.SizeInBytes Method

Return total size in bytes of all files in this directory. This is currently quantized to RAMOutputStream.BUFFER_SIZE.

public long SizeInBytes();

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMDirectory.TouchFile Method

Set the modified time of an existing file to now.

public override void TouchFile(
string name
);

See Also

RAMDirectory Class | Lucene.Net.Store Namespace


RAMFile Class

For a list of all members of this type, see RAMFile Members.

System.Object
Lucene.Net.Store.RAMFile

public class RAMFile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RAMFile Members | Lucene.Net.Store Namespace


RAMFile Members

RAMFile overview

Public Instance Constructors

RAMFile Overloaded. Initializes a new instance of the RAMFile class.

Public Instance Properties

directory_ForNUnitTest
length_ForNUnitTest
sizeInBytes_ForNUnitTest

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBuffer_ForNUnitTest |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLength_ForNUnitTest |
GetSizeInBytes_ForNUnitTest |
GetType (inherited from Object) | Gets the Type of the current instance.
NumBuffers_ForNUnitTest |
SetLength_ForNUnitTest |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

RAMFile Overloaded. Initializes a new instance of the RAMFile class.

Protected Internal Instance Methods

NewBuffer Expert: allocate a new buffer. Subclasses can allocate differently.

See Also

RAMFile Class | Lucene.Net.Store Namespace


RAMFile Constructor

Initializes a new instance of the RAMFile class.

Overload List

Initializes a new instance of the RAMFile class.

protected internal RAMFile();

public RAMFile(RAMDirectory);

See Also

RAMFile Class | Lucene.Net.Store Namespace


RAMFile Constructor ()

Initializes a new instance of the RAMFile class.

protected internal RAMFile();

See Also

RAMFile Class | Lucene.Net.Store Namespace | RAMFile Constructor Overload List


RAMFile Constructor (RAMDirectory)

public RAMFile(
RAMDirectory directory
);

See Also

RAMFile Class | Lucene.Net.Store Namespace | RAMFile Constructor Overload List


RAMFile Properties

The properties of the RAMFile class are listed below. For a complete list of RAMFile class members, see the RAMFile Members topic.

Public Instance Properties

directory_ForNUnitTest
length_ForNUnitTest
sizeInBytes_ForNUnitTest

See Also

RAMFile Class | Lucene.Net.Store Namespace


directory_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

RAMFile.directory_ForNUnitTest Property

public RAMDirectory directory_ForNUnitTest {set;}

See Also

RAMFile Class | Lucene.Net.Store Namespace


length_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

RAMFile.length_ForNUnitTest Property

public long length_ForNUnitTest {get;}

See Also

RAMFile Class | Lucene.Net.Store Namespace


sizeInBytes_ForNUnitTest Property

Apache Lucene.Net 2.4.0 Class Library API

RAMFile.sizeInBytes_ForNUnitTest Property

public long sizeInBytes_ForNUnitTest {get;}

See Also

RAMFile Class | Lucene.Net.Store Namespace


RAMFile Methods

The methods of the RAMFile class are listed below. For a complete list of RAMFile class members, see the RAMFile Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBuffer_ForNUnitTest |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLength_ForNUnitTest |
GetSizeInBytes_ForNUnitTest |
GetType (inherited from Object) | Gets the Type of the current instance.
NumBuffers_ForNUnitTest |
SetLength_ForNUnitTest |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

NewBuffer Expert: allocate a new buffer. Subclasses can allocate differently.

See Also

RAMFile Class | Lucene.Net.Store Namespace


RAMFile.GetBuffer_ForNUnitTest Method

public byte[] GetBuffer_ForNUnitTest(
int index
);

See Also

RAMFile Class | Lucene.Net.Store Namespace


RAMFile.GetLength_ForNUnitTest Method

public virtual long GetLength_ForNUnitTest();

See Also

RAMFile Class | Lucene.Net.Store Namespace


RAMFile.GetSizeInBytes_ForNUnitTest Method

public long GetSizeInBytes_ForNUnitTest();

See Also

RAMFile Class | Lucene.Net.Store Namespace


RAMFile.NewBuffer Method

Expert: allocate a new buffer. Subclasses can allocate differently.

protected internal virtual byte[] NewBuffer(
int size
);

Parameters

size
size of allocated buffer.

Return Value

allocated buffer.

See Also

RAMFile Class | Lucene.Net.Store Namespace


RAMFile.NumBuffers_ForNUnitTest Method

public int NumBuffers_ForNUnitTest();

See Also

RAMFile Class | Lucene.Net.Store Namespace


RAMFile.SetLength_ForNUnitTest Method

public virtual void SetLength_ForNUnitTest(
long length
);

See Also

RAMFile Class | Lucene.Net.Store Namespace


RAMInputStream Class

A memory-resident {@link IndexInput} implementation.

For a list of all members of this type, see RAMInputStream Members.

System.Object
Lucene.Net.Store.IndexInput
Lucene.Net.Store.RAMInputStream

public class RAMInputStream : IndexInput

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RAMInputStream Members | Lucene.Net.Store Namespace


RAMInputStream Members

RAMInputStream overview

Public Static Methods

RAMInputStream_ForNUnitTest

Public Instance Constructors

RAMInputStream Constructor

Public Instance Methods

Clone (inherited from IndexInput) |
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilePointer |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
ReadByte |
ReadBytes | Overloaded.
ReadBytes (inherited from IndexInput) | Overloaded. Reads a specified number of bytes into an array at the specified offset.
ReadChars (inherited from IndexInput) | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt (inherited from IndexInput) | Reads four bytes and returns an int.
ReadLong (inherited from IndexInput) | Reads eight bytes and returns a long.
ReadModifiedUTF8String (inherited from IndexInput) |
ReadString (inherited from IndexInput) | Reads a string.
ReadVInt (inherited from IndexInput) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from IndexInput) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek |
SetModifiedUTF8StringsMode (inherited from IndexInput) | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars (inherited from IndexInput) | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RAMInputStream Class | Lucene.Net.Store Namespace


RAMInputStream Constructor

public RAMInputStream(
RAMFile f
);

See Also

RAMInputStream Class | Lucene.Net.Store Namespace


RAMInputStream Methods

The methods of the RAMInputStream class are listed below. For a complete list of RAMInputStream class members, see the RAMInputStream Members topic.

Public Static Methods

RAMInputStream_ForNUnitTest

Public Instance Methods

Clone (inherited from IndexInput) |
Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFilePointer |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
ReadByte |
ReadBytes | Overloaded.
ReadBytes (inherited from IndexInput) | Overloaded. Reads a specified number of bytes into an array at the specified offset.
ReadChars (inherited from IndexInput) | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
ReadInt (inherited from IndexInput) | Reads four bytes and returns an int.
ReadLong (inherited from IndexInput) | Reads eight bytes and returns a long.
ReadModifiedUTF8String (inherited from IndexInput) |
ReadString (inherited from IndexInput) | Reads a string.
ReadVInt (inherited from IndexInput) | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
ReadVLong (inherited from IndexInput) | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Seek |
SetModifiedUTF8StringsMode (inherited from IndexInput) | Set to read strings in the deprecated modified UTF-8 format (length in Java chars and Java's modified UTF-8 encoding). Used for pre-2.4.0 indexes. See JIRA LUCENE-510 for details.
SkipChars (inherited from IndexInput) | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RAMInputStream Class | Lucene.Net.Store Namespace


RAMInputStream.Close Method

public override void Close();

See Also

RAMInputStream Class | Lucene.Net.Store Namespace


RAMInputStream.GetFilePointer Method

public override long GetFilePointer();

See Also

RAMInputStream Class | Lucene.Net.Store Namespace


RAMInputStream.Length Method

public override long Length();

See Also

RAMInputStream Class | Lucene.Net.Store Namespace


RAMInputStream.RAMInputStream_ForNUnitTest Method

public static RAMInputStream RAMInputStream_ForNUnitTest(
RAMFile f
);

See Also

RAMInputStream Class | Lucene.Net.Store Namespace


RAMInputStream.ReadByte Method

public override byte ReadByte();

See Also

RAMInputStream Class | Lucene.Net.Store Namespace


ReadBytes Method

Apache Lucene.Net 2.4.0 Class Library API

RAMInputStream.ReadBytes Method

Overload List

public override void ReadBytes(byte[],int,int);

Inherited from IndexInput.

public virtual void ReadBytes(byte[],int,int,bool);

See Also

RAMInputStream Class | Lucene.Net.Store Namespace


RAMInputStream.ReadBytes Method (Byte[], Int32, Int32)

public override void ReadBytes(
byte[] b,
int offset,
int len
);

See Also

RAMInputStream Class | Lucene.Net.Store Namespace | RAMInputStream.ReadBytes Overload List


RAMInputStream.Seek Method

public override void Seek(
long pos
);

See Also

RAMInputStream Class | Lucene.Net.Store Namespace


RAMOutputStream Class

A memory-resident {@link IndexOutput} implementation.

For a list of all members of this type, see RAMOutputStream Members.

System.Object
Lucene.Net.Store.IndexOutput
Lucene.Net.Store.RAMOutputStream

public class RAMOutputStream : IndexOutput

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

RAMOutputStream Members | Lucene.Net.Store Namespace


RAMOutputStream Members

RAMOutputStream overview

Public Static Fields

BUFFER_SIZE_ForNUnitTest

Public Instance Constructors

RAMOutputStream Overloaded. Initializes a new instance of the RAMOutputStream class.

Public Instance Methods

Close |
CopyBytes (inherited from IndexOutput) | Copy numBytes bytes from input to ourself.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush |
GetFilePointer |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
Reset | Resets this to an empty buffer.
Seek |
SetLength (inherited from IndexOutput) | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for example @see FSDirectory) can use this to inform the underlying IO system to pre-allocate the file to the specified size. If the length is longer than the current file length, the bytes added to the file are undefined. Otherwise the file is truncated. file length
SizeInBytes | Returns the byte usage of all buffers.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte |
WriteBytes | Overloaded.
WriteBytes (inherited from IndexOutput) | Overloaded. Writes an array of bytes.
WriteChars (inherited from IndexOutput) | Overloaded. Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.
WriteInt (inherited from IndexOutput) | Writes an int as four bytes.
WriteLong (inherited from IndexOutput) | Writes a long as eight bytes.
WriteString (inherited from IndexOutput) | Writes a string.
WriteTo | Copy the current contents of this buffer to the named output.
WriteVInt (inherited from IndexOutput) | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong (inherited from IndexOutput) | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream Constructor

Construct an empty output buffer.

Overload List

Construct an empty output buffer.

public RAMOutputStream();

public RAMOutputStream(RAMFile);

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream Constructor ()

Construct an empty output buffer.

public RAMOutputStream();

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace | RAMOutputStream Constructor Overload List


RAMOutputStream Constructor (RAMFile)

public RAMOutputStream(
RAMFile f
);

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace | RAMOutputStream Constructor Overload List


RAMOutputStream Fields

The fields of the RAMOutputStream class are listed below. For a complete list of RAMOutputStream class members, see the RAMOutputStream Members topic.

Public Static Fields

BUFFER_SIZE_ForNUnitTest

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.BUFFER_SIZE_ForNUnitTest Field

public const int BUFFER_SIZE_ForNUnitTest = 1024;

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream Methods

The methods of the RAMOutputStream class are listed below. For a complete list of RAMOutputStream class members, see the RAMOutputStream Members topic.

Public Instance Methods

Close |
CopyBytes (inherited from IndexOutput) | Copy numBytes bytes from input to ourself.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush |
GetFilePointer |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Length |
Reset | Resets this to an empty buffer.
Seek |
SetLength (inherited from IndexOutput) | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for example @see FSDirectory) can use this to inform the underlying IO system to pre-allocate the file to the specified size. If the length is longer than the current file length, the bytes added to the file are undefined. Otherwise the file is truncated. file length
SizeInBytes | Returns the byte usage of all buffers.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteByte |
WriteBytes | Overloaded.
WriteBytes (inherited from IndexOutput) | Overloaded. Writes an array of bytes.
WriteChars (inherited from IndexOutput) | Overloaded. Writes a sub sequence of chars from s as "modified UTF-8" encoded bytes.
WriteInt (inherited from IndexOutput) | Writes an int as four bytes.
WriteLong (inherited from IndexOutput) | Writes a long as eight bytes.
WriteString (inherited from IndexOutput) | Writes a string.
WriteTo | Copy the current contents of this buffer to the named output.
WriteVInt (inherited from IndexOutput) | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
WriteVLong (inherited from IndexOutput) | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.Close Method

public override void Close();

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.Flush Method

public override void Flush();

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.GetFilePointer Method

public override long GetFilePointer();

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.Length Method

public override long Length();

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.Reset Method

Resets this to an empty buffer.

public virtual void Reset();

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.Seek Method

public override void Seek(
long pos
);

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.SizeInBytes Method

Returns the byte usage of all buffers.

public long SizeInBytes();

Return Value

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.WriteByte Method

public override void WriteByte(
byte b
);

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


WriteBytes Method

Apache Lucene.Net 2.4.0 Class Library API

RAMOutputStream.WriteBytes Method

Overload List

Inherited from IndexOutput.

public virtual void WriteBytes(byte[],int);

public override void WriteBytes(byte[],int,int);

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


RAMOutputStream.WriteBytes Method (Byte[], Int32, Int32)

public override void WriteBytes(
byte[] b,
int offset,
int len
);

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace | RAMOutputStream.WriteBytes Overload List


RAMOutputStream.WriteTo Method

Copy the current contents of this buffer to the named output.

public virtual void WriteTo(
IndexOutput out_Renamed
);

See Also

RAMOutputStream Class | Lucene.Net.Store Namespace


SimpleFSLockFactory Class

Implements {@link LockFactory} using {@link File#createNewFile()}. This is the default LockFactory for {@link FSDirectory}.

NOTE: the javadocs for

File.createNewFile
contain a vague yet spooky warning about not using the API for file locking. This warning was added due to this bug, and in fact the only known problem with using this API for locking is that the Lucene write lock may not be released when the JVM exits abnormally.

When this happens, a {@link LockObtainFailedException} is hit when trying to create a writer, in which case you need to explicitly clear the lock file first. You can either manually remove the file, or use the {@link Lucene.Net.Index.IndexReader#Unlock(Directory)} API. But, first be certain that no writer is in fact writing to the index otherwise you can easily corrupt your index.

If you suspect that this or any other LockFactory is not working properly in your environment, you can easily test it by using {@link VerifyingLockFactory}, {@link LockVerifyServer} and {@link LockStressTest}.

For a list of all members of this type, see SimpleFSLockFactory Members.

System.Object
Lucene.Net.Store.LockFactory
Lucene.Net.Store.SimpleFSLockFactory

public class SimpleFSLockFactory : LockFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SimpleFSLockFactory Members | Lucene.Net.Store Namespace |


SimpleFSLockFactory Members

SimpleFSLockFactory overview

Public Instance Constructors

SimpleFSLockFactory Overloaded. Initializes a new instance of the SimpleFSLockFactory class.

Public Instance Methods

ClearLock |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockPrefix (inherited from LockFactory) | Get the prefix in use for all locks created in this LockFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeLock |
SetLockPrefix (inherited from LockFactory) | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

lockPrefix (inherited from LockFactory)

See Also

SimpleFSLockFactory Class | Lucene.Net.Store Namespace |


SimpleFSLockFactory Constructor

Instantiate using the provided directory (as a File instance).

Overload List

Instantiate using the provided directory (as a File instance).

public SimpleFSLockFactory(FileInfo);

Instantiate using the provided directory name (String).

public SimpleFSLockFactory(string);

See Also

SimpleFSLockFactory Class | Lucene.Net.Store Namespace


SimpleFSLockFactory Constructor (FileInfo)

Instantiate using the provided directory (as a File instance).

public SimpleFSLockFactory(
FileInfo lockDir
);

Parameters

lockDir
where lock files should be created.

See Also

SimpleFSLockFactory Class | Lucene.Net.Store Namespace | SimpleFSLockFactory Constructor Overload List


SimpleFSLockFactory Constructor (String)

Instantiate using the provided directory name (String).

public SimpleFSLockFactory(
string lockDirName
);

Parameters

lockDirName
where lock files should be created.

See Also

SimpleFSLockFactory Class | Lucene.Net.Store Namespace | SimpleFSLockFactory Constructor Overload List


SimpleFSLockFactory Methods

The methods of the SimpleFSLockFactory class are listed below. For a complete list of SimpleFSLockFactory class members, see the SimpleFSLockFactory Members topic.

Public Instance Methods

ClearLock |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockPrefix (inherited from LockFactory) | Get the prefix in use for all locks created in this LockFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeLock |
SetLockPrefix (inherited from LockFactory) | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SimpleFSLockFactory Class | Lucene.Net.Store Namespace |


SimpleFSLockFactory.ClearLock Method

public override void ClearLock(
string lockName
);

See Also

SimpleFSLockFactory Class | Lucene.Net.Store Namespace


SimpleFSLockFactory.MakeLock Method

public override Lock MakeLock(
string lockName
);

See Also

SimpleFSLockFactory Class | Lucene.Net.Store Namespace


SingleInstanceLockFactory Class

Implements {@link LockFactory} for a single in-process instance, meaning all locking will take place through this one instance. Only use this {@link LockFactory} when you are certain all IndexReaders and IndexWriters for a given index are running against a single shared in-process Directory instance. This is currently the default locking for RAMDirectory.

For a list of all members of this type, see SingleInstanceLockFactory Members.

System.Object
Lucene.Net.Store.LockFactory
Lucene.Net.Store.SingleInstanceLockFactory

public class SingleInstanceLockFactory : LockFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SingleInstanceLockFactory Members | Lucene.Net.Store Namespace |


SingleInstanceLockFactory Members

SingleInstanceLockFactory overview

Public Instance Constructors

SingleInstanceLockFactory Constructor Initializes a new instance of the SingleInstanceLockFactory class.

Public Instance Methods

ClearLock |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockPrefix (inherited from LockFactory) | Get the prefix in use for all locks created in this LockFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeLock |
SetLockPrefix (inherited from LockFactory) | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

lockPrefix (inherited from LockFactory)

See Also

SingleInstanceLockFactory Class | Lucene.Net.Store Namespace |


SingleInstanceLockFactory Constructor

Initializes a new instance of the SingleInstanceLockFactory class.

public SingleInstanceLockFactory();

See Also

SingleInstanceLockFactory Class | Lucene.Net.Store Namespace


SingleInstanceLockFactory Methods

The methods of the SingleInstanceLockFactory class are listed below. For a complete list of SingleInstanceLockFactory class members, see the SingleInstanceLockFactory Members topic.

Public Instance Methods

ClearLock |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockPrefix (inherited from LockFactory) | Get the prefix in use for all locks created in this LockFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeLock |
SetLockPrefix (inherited from LockFactory) | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SingleInstanceLockFactory Class | Lucene.Net.Store Namespace |


SingleInstanceLockFactory.ClearLock Method

public override void ClearLock(
string lockName
);

See Also

SingleInstanceLockFactory Class | Lucene.Net.Store Namespace


SingleInstanceLockFactory.MakeLock Method

public override Lock MakeLock(
string lockName
);

See Also

SingleInstanceLockFactory Class | Lucene.Net.Store Namespace


VerifyingLockFactory Class

For a list of all members of this type, see VerifyingLockFactory Members.

System.Object
Lucene.Net.Store.LockFactory
Lucene.Net.Store.VerifyingLockFactory

public class VerifyingLockFactory : LockFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Store

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

VerifyingLockFactory Members | Lucene.Net.Store Namespace


VerifyingLockFactory Members

VerifyingLockFactory overview

Public Instance Constructors

VerifyingLockFactory Constructor

Public Instance Methods

ClearLock |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockPrefix (inherited from LockFactory) | Get the prefix in use for all locks created in this LockFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeLock |
SetLockPrefix (inherited from LockFactory) | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

lockPrefix (inherited from LockFactory)

See Also

VerifyingLockFactory Class | Lucene.Net.Store Namespace


VerifyingLockFactory Constructor

public VerifyingLockFactory(
byte id,
LockFactory lf,
string host,
int port
);

Parameters

id
should be a unique id across all clients
lf
the LockFactory that we are testing
host
host or IP where {@link LockVerifyServer} is running
port
the port {@link LockVerifyServer} is listening on

See Also

VerifyingLockFactory Class | Lucene.Net.Store Namespace


VerifyingLockFactory Methods

The methods of the VerifyingLockFactory class are listed below. For a complete list of VerifyingLockFactory class members, see the VerifyingLockFactory Members topic.

Public Instance Methods

ClearLock |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockPrefix (inherited from LockFactory) | Get the prefix in use for all locks created in this LockFactory.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeLock |
SetLockPrefix (inherited from LockFactory) | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VerifyingLockFactory Class | Lucene.Net.Store Namespace


VerifyingLockFactory.ClearLock Method

public override void ClearLock(
string lockName
);

See Also

VerifyingLockFactory Class | Lucene.Net.Store Namespace


VerifyingLockFactory.MakeLock Method

public override Lock MakeLock(
string lockName
);

See Also

VerifyingLockFactory Class | Lucene.Net.Store Namespace


Lucene.Net.Util

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Util Namespace

Namespace hierarchy

Classes

Class | Description
ArrayUtil
BitUtil | A variety of high efficiencly bit twiddling routines. (from org.apache.solr.util rev 555343)
BitVector Optimized implementation of a vector of bits. This is more-or-less like java.util.BitSet, but also includes the following:
  • a count() method, which efficiently computes the number of one bits;
  • optimized read from and write to disk;
  • inlinable get() method;
  • store and load, as bit set or d-gaps, depending on sparseness;
CloseableThreadLocal
Constants | Some useful constants.
DocIdBitSet | Simple DocIdSet and DocIdSetIterator backed by a BitArray
OpenBitSet An "open" BitSet implementation that allows direct access to the array of words storing the bits.

Unlike java.util.bitset, the fact that bits are packed into an array of longs is part of the interface. This allows efficient implementation of other algorithms by someone other than the author. It also allows one to efficiently implement alternate serialization or interchange formats.

OpenBitSet
is faster than
java.util.BitSet
in most operations and *much* faster at calculating cardinality of sets and results of set operations. It can also handle sets of larger cardinality (up to 64 * 2**32-1)

The goals of
OpenBitSet
are the fastest implementation possible, and maximum code reuse. Extra safety and encapsulation may always be built on top, but if that's built in, the cost can never be removed (and hence people re-implement their own version in order to get better performance). If you want a "safe", totally encapsulated (and slower and limited) BitSet class, use
java.util.BitSet
.

Performance Results
OpenBitSetDISI
OpenBitSetIterator
Parameter | A serializable Enum class.
PriorityQueue | A PriorityQueue maintains a partial ordering of its elements such that the least element can always be found in constant time. Put()'s and pop()'s require log(size) time.
ScorerDocQueue | A ScorerDocQueue maintains a partial ordering of its Scorers such that the least Scorer can always be found in constant time. Put()'s and pop()'s require log(size) time. The ordering is by Scorer.doc().
SmallFloat | Floating point numbers smaller than 32 bits.
SortedVIntList
StringHelper | Methods for manipulating strings.
ToStringUtils
UnicodeUtil
UnicodeUtil.UTF16Result
UnicodeUtil.UTF8Result


ArrayUtil Class

For a list of all members of this type, see ArrayUtil Members.

System.Object
Lucene.Net.Util.ArrayUtil

public sealed class ArrayUtil

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ArrayUtil Members | Lucene.Net.Util Namespace


ArrayUtil Members

ArrayUtil overview

Public Static Methods

GetNextSize |
GetShrinkSize |
Grow | Overloaded.
HashCode | Overloaded. Returns hash of chars in range start (inclusive) to end (inclusive).
Shrink | Overloaded.

Public Instance Constructors

ArrayUtil Constructor Initializes a new instance of the ArrayUtil class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ArrayUtil Class | Lucene.Net.Util Namespace


ArrayUtil Constructor

Initializes a new instance of the ArrayUtil class.

public ArrayUtil();

See Also

ArrayUtil Class | Lucene.Net.Util Namespace


ArrayUtil Methods

The methods of the ArrayUtil class are listed below. For a complete list of ArrayUtil class members, see the ArrayUtil Members topic.

Public Static Methods

GetNextSize |
GetShrinkSize |
Grow | Overloaded.
HashCode | Overloaded. Returns hash of chars in range start (inclusive) to end (inclusive).
Shrink | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ArrayUtil Class | Lucene.Net.Util Namespace


ArrayUtil.GetNextSize Method

public static int GetNextSize(
int targetSize
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace


ArrayUtil.GetShrinkSize Method

public static int GetShrinkSize(
int currentSize,
int targetSize
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace


Grow Method

Apache Lucene.Net 2.4.0 Class Library API

ArrayUtil.Grow Method

Overload List

public static byte[] Grow(byte[]);

public static byte[] Grow(byte[],int);

public static int[] Grow(int[]);

public static int[] Grow(int[],int);

public static long[] Grow(long[]);

public static long[] Grow(long[],int);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace


ArrayUtil.Grow Method (Byte[])

public static byte[] Grow(
byte[] array
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace | ArrayUtil.Grow Overload List


ArrayUtil.Grow Method (Byte[], Int32)

public static byte[] Grow(
byte[] array,
int minSize
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace | ArrayUtil.Grow Overload List


ArrayUtil.Grow Method (Int32[])

public static int[] Grow(
int[] array
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace | ArrayUtil.Grow Overload List


ArrayUtil.Grow Method (Int32[], Int32)

public static int[] Grow(
int[] array,
int minSize
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace | ArrayUtil.Grow Overload List


ArrayUtil.Grow Method (Int64[])

public static long[] Grow(
long[] array
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace | ArrayUtil.Grow Overload List


ArrayUtil.Grow Method (Int64[], Int32)

public static long[] Grow(
long[] array,
int minSize
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace | ArrayUtil.Grow Overload List


HashCode Method

Apache Lucene.Net 2.4.0 Class Library API

ArrayUtil.HashCode Method

Returns hash of chars in range start (inclusive) to end (inclusive).

Overload List

Returns hash of chars in range start (inclusive) to end (inclusive).

public static int HashCode(byte[],int,int);

Returns hash of chars in range start (inclusive) to end (inclusive).

public static int HashCode(char[],int,int);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace


ArrayUtil.HashCode Method (Byte[], Int32, Int32)

Returns hash of chars in range start (inclusive) to end (inclusive).

public static int HashCode(
byte[] array,
int start,
int end
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace | ArrayUtil.HashCode Overload List


ArrayUtil.HashCode Method (Char[], Int32, Int32)

Returns hash of chars in range start (inclusive) to end (inclusive).

public static int HashCode(
char[] array,
int start,
int end
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace | ArrayUtil.HashCode Overload List


Shrink Method

Apache Lucene.Net 2.4.0 Class Library API

ArrayUtil.Shrink Method

Overload List

public static byte[] Shrink(byte[],int);

public static int[] Shrink(int[],int);

public static long[] Shrink(long[],int);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace


ArrayUtil.Shrink Method (Byte[], Int32)

public static byte[] Shrink(
byte[] array,
int targetSize
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace | ArrayUtil.Shrink Overload List


ArrayUtil.Shrink Method (Int32[], Int32)

public static int[] Shrink(
int[] array,
int targetSize
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace | ArrayUtil.Shrink Overload List


ArrayUtil.Shrink Method (Int64[], Int32)

public static long[] Shrink(
long[] array,
int targetSize
);

See Also

ArrayUtil Class | Lucene.Net.Util Namespace | ArrayUtil.Shrink Overload List


BitUtil Class

A variety of high efficiencly bit twiddling routines. (from org.apache.solr.util rev 555343)

For a list of all members of this type, see BitUtil Members.

System.Object
Lucene.Net.Util.BitUtil

public class BitUtil

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BitUtil Members | Lucene.Net.Util Namespace


BitUtil Members

BitUtil overview

Public Static Fields

ntzTable

Public Static Methods

isPowerOfTwo | Overloaded.
nextHighestPowerOfTwo | Overloaded.
ntz |
ntz2 |
ntz3 |
pop |
pop_andnot |
pop_array |
pop_intersect |
pop_union |
pop_xor |

Public Instance Constructors

BitUtil Constructor Initializes a new instance of the BitUtil class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil Constructor

Initializes a new instance of the BitUtil class.

public BitUtil();

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil Fields

The fields of the BitUtil class are listed below. For a complete list of BitUtil class members, see the BitUtil Members topic.

Public Static Fields

ntzTable

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil.ntzTable Field

public static readonly byte[] ntzTable;

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil Methods

The methods of the BitUtil class are listed below. For a complete list of BitUtil class members, see the BitUtil Members topic.

Public Static Methods

isPowerOfTwo | Overloaded.
nextHighestPowerOfTwo | Overloaded.
ntz |
ntz2 |
ntz3 |
pop |
pop_andnot |
pop_array |
pop_intersect |
pop_union |
pop_xor |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BitUtil Class | Lucene.Net.Util Namespace


isPowerOfTwo Method

Apache Lucene.Net 2.4.0 Class Library API

BitUtil.isPowerOfTwo Method

Overload List

public static bool isPowerOfTwo(int);

public static bool isPowerOfTwo(long);

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil.isPowerOfTwo Method (Int32)

public static bool isPowerOfTwo(
int v
);

See Also

BitUtil Class | Lucene.Net.Util Namespace | BitUtil.isPowerOfTwo Overload List


BitUtil.isPowerOfTwo Method (Int64)

public static bool isPowerOfTwo(
long v
);

See Also

BitUtil Class | Lucene.Net.Util Namespace | BitUtil.isPowerOfTwo Overload List


nextHighestPowerOfTwo Method

Apache Lucene.Net 2.4.0 Class Library API

BitUtil.nextHighestPowerOfTwo Method

Overload List

public static int nextHighestPowerOfTwo(int);

public static long nextHighestPowerOfTwo(long);

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil.nextHighestPowerOfTwo Method (Int32)

public static int nextHighestPowerOfTwo(
int v
);

See Also

BitUtil Class | Lucene.Net.Util Namespace | BitUtil.nextHighestPowerOfTwo Overload List


BitUtil.nextHighestPowerOfTwo Method (Int64)

public static long nextHighestPowerOfTwo(
long v
);

See Also

BitUtil Class | Lucene.Net.Util Namespace | BitUtil.nextHighestPowerOfTwo Overload List


BitUtil.ntz Method

public static int ntz(
long val
);

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil.ntz2 Method

public static int ntz2(
long x
);

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil.ntz3 Method

public static int ntz3(
long x
);

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil.pop Method

public static int pop(
long x
);

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil.pop_andnot Method

public static long pop_andnot(
long[] A,
long[] B,
int wordOffset,
int numWords
);

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil.pop_array Method

public static long pop_array(
long[] A,
int wordOffset,
int numWords
);

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil.pop_intersect Method

public static long pop_intersect(
long[] A,
long[] B,
int wordOffset,
int numWords
);

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil.pop_union Method

public static long pop_union(
long[] A,
long[] B,
int wordOffset,
int numWords
);

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitUtil.pop_xor Method

public static long pop_xor(
long[] A,
long[] B,
int wordOffset,
int numWords
);

See Also

BitUtil Class | Lucene.Net.Util Namespace


BitVector Class

Optimized implementation of a vector of bits. This is more-or-less like java.util.BitSet, but also includes the following:

  • a count() method, which efficiently computes the number of one bits;
  • optimized read from and write to disk;
  • inlinable get() method;
  • store and load, as bit set or d-gaps, depending on sparseness;

For a list of all members of this type, see BitVector Members.

System.Object
Lucene.Net.Util.BitVector

public sealed class BitVector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

BitVector Members | Lucene.Net.Util Namespace


BitVector Members

BitVector overview

Public Instance Constructors

BitVector Overloaded. Initializes a new instance of the BitVector class.

Public Instance Methods

Clear Sets the value of
bit
to zero.
Count | Returns the total number of one bits in this vector. This is efficiently computed and cached, so that, if the vector is not changed, no recomputation is done for repeated calls.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get Returns
true
if
bit
is one and
false
if it is zero.
GetAndSet | Sets the value of bit to true and returns true if bit was already set.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Set Sets the value of
bit
to one.
Size | Returns the number of bits in this vector. This is also one greater than the number of the largest valid bit number.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write Writes this vector to the file
name
in Directory
d
, in a format that can be read by the constructor {@link #BitVector(Directory, String)}.

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector Constructor

Constructs a vector capable of holding

n
bits.

Overload List

Constructs a bit vector from the file

name
in Directory
d
, as written by the {@link #write} method.

public BitVector(Directory,string);

Constructs a vector capable of holding

n
bits.

public BitVector(int);

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector Constructor (Int32)

Constructs a vector capable of holding

n
bits.

public BitVector(
int n
);

See Also

BitVector Class | Lucene.Net.Util Namespace | BitVector Constructor Overload List


BitVector Constructor (Directory, String)

Constructs a bit vector from the file

name
in Directory
d
, as written by the {@link #write} method.

public BitVector(
Directory d,
string name
);

See Also

BitVector Class | Lucene.Net.Util Namespace | BitVector Constructor Overload List


BitVector Methods

The methods of the BitVector class are listed below. For a complete list of BitVector class members, see the BitVector Members topic.

Public Instance Methods

Clear Sets the value of
bit
to zero.
Count | Returns the total number of one bits in this vector. This is efficiently computed and cached, so that, if the vector is not changed, no recomputation is done for repeated calls.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get Returns
true
if
bit
is one and
false
if it is zero.
GetAndSet | Sets the value of bit to true and returns true if bit was already set.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Set Sets the value of
bit
to one.
Size | Returns the number of bits in this vector. This is also one greater than the number of the largest valid bit number.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write Writes this vector to the file
name
in Directory
d
, in a format that can be read by the constructor {@link #BitVector(Directory, String)}.

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.Clear Method

Sets the value of

bit
to zero.

public void Clear(
int bit
);

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.Count Method

Returns the total number of one bits in this vector. This is efficiently computed and cached, so that, if the vector is not changed, no recomputation is done for repeated calls.

public int Count();

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.Get Method

Returns

true
if
bit
is one and
false
if it is zero.

public bool Get(
int bit
);

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.GetAndSet Method

Sets the value of bit to true and returns true if bit was already set.

public bool GetAndSet(
int bit
);

Parameters

bit

Return Value

true if bit was already set

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.Set Method

Sets the value of

bit
to one.

public void Set(
int bit
);

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.Size Method

Returns the number of bits in this vector. This is also one greater than the number of the largest valid bit number.

public int Size();

See Also

BitVector Class | Lucene.Net.Util Namespace


BitVector.Write Method

Writes this vector to the file

name
in Directory
d
, in a format that can be read by the constructor {@link #BitVector(Directory, String)}.

public void Write(
Directory d,
string name
);

See Also

BitVector Class | Lucene.Net.Util Namespace


CloseableThreadLocal Class

For a list of all members of this type, see CloseableThreadLocal Members.

System.Object
Lucene.Net.Util.CloseableThreadLocal

public class CloseableThreadLocal

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

CloseableThreadLocal Members | Lucene.Net.Util Namespace


CloseableThreadLocal Members

CloseableThreadLocal overview

Public Instance Constructors

CloseableThreadLocal Constructor Initializes a new instance of the CloseableThreadLocal class.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Set |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InitialValue |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CloseableThreadLocal Class | Lucene.Net.Util Namespace


CloseableThreadLocal Constructor

Initializes a new instance of the CloseableThreadLocal class.

public CloseableThreadLocal();

See Also

CloseableThreadLocal Class | Lucene.Net.Util Namespace


CloseableThreadLocal Methods

The methods of the CloseableThreadLocal class are listed below. For a complete list of CloseableThreadLocal class members, see the CloseableThreadLocal Members topic.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Set |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InitialValue |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CloseableThreadLocal Class | Lucene.Net.Util Namespace


CloseableThreadLocal.Close Method

public void Close();

See Also

CloseableThreadLocal Class | Lucene.Net.Util Namespace


CloseableThreadLocal.Get Method

public object Get();

See Also

CloseableThreadLocal Class | Lucene.Net.Util Namespace


CloseableThreadLocal.InitialValue Method

protected virtual object InitialValue();

See Also

CloseableThreadLocal Class | Lucene.Net.Util Namespace


CloseableThreadLocal.Set Method

public void Set(
object obj
);

See Also

CloseableThreadLocal Class | Lucene.Net.Util Namespace


Constants Class

Some useful constants.

For a list of all members of this type, see Constants Members.

System.Object
Lucene.Net.Util.Constants

public sealed class Constants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Constants Members | Lucene.Net.Util Namespace


Constants Members

Constants overview

Public Static Fields

DOTNET_VERSION | Lucene.Net Runtime version
DOTNET_VERSION_1_0 | True iff Lucene.Net Runtime version is 1.0
DOTNET_VERSION_1_1 | True iff Lucene.Net Runtime version is 1.1
DOTNET_VERSION_2_0 | True iff Lucene.Net Runtime version is 2.0
DOTNET_VERSION_3_0 | True iff Lucene.Net Runtime version is 3.0
LINUX | True iff running on Linux.
OS_NAME |
SUN_OS | True iff running on SunOS.
WINDOWS | True iff running on Windows.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Constants Class | Lucene.Net.Util Namespace


Constants Fields

The fields of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Fields

DOTNET_VERSION | Lucene.Net Runtime version
DOTNET_VERSION_1_0 | True iff Lucene.Net Runtime version is 1.0
DOTNET_VERSION_1_1 | True iff Lucene.Net Runtime version is 1.1
DOTNET_VERSION_2_0 | True iff Lucene.Net Runtime version is 2.0
DOTNET_VERSION_3_0 | True iff Lucene.Net Runtime version is 3.0
LINUX | True iff running on Linux.
OS_NAME |
SUN_OS | True iff running on SunOS.
WINDOWS | True iff running on Windows.

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.DOTNET_VERSION Field

Lucene.Net Runtime version

public static readonly string DOTNET_VERSION;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.DOTNET_VERSION_1_0 Field

True iff Lucene.Net Runtime version is 1.0

public static readonly bool DOTNET_VERSION_1_0;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.DOTNET_VERSION_1_1 Field

True iff Lucene.Net Runtime version is 1.1

public static readonly bool DOTNET_VERSION_1_1;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.DOTNET_VERSION_2_0 Field

True iff Lucene.Net Runtime version is 2.0

public static readonly bool DOTNET_VERSION_2_0;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.DOTNET_VERSION_3_0 Field

True iff Lucene.Net Runtime version is 3.0

public static readonly bool DOTNET_VERSION_3_0;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.LINUX Field

True iff running on Linux.

public static readonly bool LINUX;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.OS_NAME Field

public static readonly string OS_NAME;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.SUN_OS Field

True iff running on SunOS.

public static readonly bool SUN_OS;

See Also

Constants Class | Lucene.Net.Util Namespace


Constants.WINDOWS Field

True iff running on Windows.

public static readonly bool WINDOWS;

See Also

Constants Class | Lucene.Net.Util Namespace


DocIdBitSet Class

Simple DocIdSet and DocIdSetIterator backed by a BitArray

For a list of all members of this type, see DocIdBitSet Members.

System.Object
Lucene.Net.Search.DocIdSet
Lucene.Net.Util.DocIdBitSet

public class DocIdBitSet : DocIdSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

DocIdBitSet Members | Lucene.Net.Util Namespace


DocIdBitSet Members

DocIdBitSet overview

Public Instance Constructors

DocIdBitSet Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBitSet | Returns the underlying BitArray.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Iterator |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocIdBitSet Class | Lucene.Net.Util Namespace


DocIdBitSet Constructor

public DocIdBitSet(
BitArray bitArray
);

See Also

DocIdBitSet Class | Lucene.Net.Util Namespace


DocIdBitSet Methods

The methods of the DocIdBitSet class are listed below. For a complete list of DocIdBitSet class members, see the DocIdBitSet Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBitSet | Returns the underlying BitArray.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Iterator |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocIdBitSet Class | Lucene.Net.Util Namespace


DocIdBitSet.GetBitSet Method

Returns the underlying BitArray.

public BitArray GetBitSet();

See Also

DocIdBitSet Class | Lucene.Net.Util Namespace


DocIdBitSet.Iterator Method

public override DocIdSetIterator Iterator();

See Also

DocIdBitSet Class | Lucene.Net.Util Namespace


OpenBitSet Class

An "open" BitSet implementation that allows direct access to the array of words storing the bits.

Unlike java.util.bitset, the fact that bits are packed into an array of longs is part of the interface. This allows efficient implementation of other algorithms by someone other than the author. It also allows one to efficiently implement alternate serialization or interchange formats.

OpenBitSet
is faster than
java.util.BitSet
in most operations and *much* faster at calculating cardinality of sets and results of set operations. It can also handle sets of larger cardinality (up to 64 * 2**32-1)

The goals of
OpenBitSet
are the fastest implementation possible, and maximum code reuse. Extra safety and encapsulation may always be built on top, but if that's built in, the cost can never be removed (and hence people re-implement their own version in order to get better performance). If you want a "safe", totally encapsulated (and slower and limited) BitSet class, use
java.util.BitSet
.

Performance Results

For a list of all members of this type, see OpenBitSet Members.

System.Object
Lucene.Net.Search.DocIdSet
Lucene.Net.Util.OpenBitSet
Lucene.Net.Util.OpenBitSetDISI

public class OpenBitSet : DocIdSet, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

OpenBitSet Members | Lucene.Net.Util Namespace


OpenBitSet Members

OpenBitSet overview

Public Static Methods

AndNotCount
bits2words
IntersectionCount
UnionCount
XorCount

Public Instance Constructors

OpenBitSet Overloaded. Initializes a new instance of the OpenBitSet class.

Public Instance Methods

And |
AndNot |
Capacity |
Cardinality |
Clear | Overloaded.
Clone |
EnsureCapacity |
EnsureCapacityWords |
Equals |
FastClear | Overloaded.
FastFlip | Overloaded.
FastGet | Overloaded.
FastSet | Overloaded.
Flip | Overloaded.
FlipAndGet | Overloaded.
Get | Overloaded.
GetAndSet | Overloaded.
GetBit |
GetBits |
GetHashCode |
GetNumWords |
GetType (inherited from Object) | Gets the Type of the current instance.
Intersect |
Intersects |
IsEmpty |
Iterator |
NextSetBit | Overloaded.
Or |
Remove |
Set | Overloaded.
SetBits |
SetNumWords |
Size |
ToString (inherited from Object) | Returns a String that represents the current Object.
trimTrailingZeros |
Union |
Xor |

Protected Instance Fields

bits
wlen

Protected Instance Methods

ExpandingWordNum |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet Constructor

Overload List

Initializes a new instance of the OpenBitSet class.

public OpenBitSet();

public OpenBitSet(long);

public OpenBitSet(long[],int);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet Constructor (Int64)

public OpenBitSet(
long numBits
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet Constructor Overload List


OpenBitSet Constructor ()

Initializes a new instance of the OpenBitSet class.

public OpenBitSet();

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet Constructor Overload List


OpenBitSet Constructor (Int64[], Int32)

public OpenBitSet(
long[] bits,
int numWords
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet Constructor Overload List


OpenBitSet Fields

The fields of the OpenBitSet class are listed below. For a complete list of OpenBitSet class members, see the OpenBitSet Members topic.

Protected Instance Fields

bits
wlen

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.bits Field

protected long[] bits;

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.wlen Field

protected int wlen;

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet Methods

The methods of the OpenBitSet class are listed below. For a complete list of OpenBitSet class members, see the OpenBitSet Members topic.

Public Static Methods

AndNotCount
bits2words
IntersectionCount
UnionCount
XorCount

Public Instance Methods

And |
AndNot |
Capacity |
Cardinality |
Clear | Overloaded.
Clone |
EnsureCapacity |
EnsureCapacityWords |
Equals |
FastClear | Overloaded.
FastFlip | Overloaded.
FastGet | Overloaded.
FastSet | Overloaded.
Flip | Overloaded.
FlipAndGet | Overloaded.
Get | Overloaded.
GetAndSet | Overloaded.
GetBit |
GetBits |
GetHashCode |
GetNumWords |
GetType (inherited from Object) | Gets the Type of the current instance.
Intersect |
Intersects |
IsEmpty |
Iterator |
NextSetBit | Overloaded.
Or |
Remove |
Set | Overloaded.
SetBits |
SetNumWords |
Size |
ToString (inherited from Object) | Returns a String that represents the current Object.
trimTrailingZeros |
Union |
Xor |

Protected Instance Methods

ExpandingWordNum |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.And Method

public void And(
OpenBitSet other
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.AndNot Method

public void AndNot(
OpenBitSet other
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.AndNotCount Method

public static long AndNotCount(
OpenBitSet a,
OpenBitSet b
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.bits2words Method

public static int bits2words(
long numBits
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Capacity Method

public long Capacity();

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Cardinality Method

public long Cardinality();

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


Clear Method

Apache Lucene.Net 2.4.0 Class Library API

OpenBitSet.Clear Method

Overload List

public void Clear(long);

public void Clear(long,long);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Clear Method (Int64)

public void Clear(
long index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.Clear Overload List


OpenBitSet.Clear Method (Int64, Int64)

public void Clear(
long startIndex,
long endIndex
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.Clear Overload List


OpenBitSet.Clone Method

public virtual object Clone();

Implements

ICloneable.Clone

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.EnsureCapacity Method

public void EnsureCapacity(
long numBits
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.EnsureCapacityWords Method

public void EnsureCapacityWords(
int numWords
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Equals Method

public override bool Equals(
object o
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.ExpandingWordNum Method

protected int ExpandingWordNum(
long index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


FastClear Method

Apache Lucene.Net 2.4.0 Class Library API

OpenBitSet.FastClear Method

Overload List

public void FastClear(int);

public void FastClear(long);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.FastClear Method (Int32)

public void FastClear(
int index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.FastClear Overload List


OpenBitSet.FastClear Method (Int64)

public void FastClear(
long index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.FastClear Overload List


FastFlip Method

Apache Lucene.Net 2.4.0 Class Library API

OpenBitSet.FastFlip Method

Overload List

public void FastFlip(int);

public void FastFlip(long);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.FastFlip Method (Int32)

public void FastFlip(
int index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.FastFlip Overload List


OpenBitSet.FastFlip Method (Int64)

public void FastFlip(
long index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.FastFlip Overload List


FastGet Method

Apache Lucene.Net 2.4.0 Class Library API

OpenBitSet.FastGet Method

Overload List

public bool FastGet(int);

public bool FastGet(long);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.FastGet Method (Int32)

public bool FastGet(
int index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.FastGet Overload List


OpenBitSet.FastGet Method (Int64)

public bool FastGet(
long index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.FastGet Overload List


FastSet Method

Apache Lucene.Net 2.4.0 Class Library API

OpenBitSet.FastSet Method

Overload List

public void FastSet(int);

public void FastSet(long);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.FastSet Method (Int32)

public void FastSet(
int index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.FastSet Overload List


OpenBitSet.FastSet Method (Int64)

public void FastSet(
long index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.FastSet Overload List


Flip Method

Apache Lucene.Net 2.4.0 Class Library API

OpenBitSet.Flip Method

Overload List

public void Flip(long);

public void Flip(long,long);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Flip Method (Int64)

public void Flip(
long index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.Flip Overload List


OpenBitSet.Flip Method (Int64, Int64)

public void Flip(
long startIndex,
long endIndex
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.Flip Overload List


FlipAndGet Method

Apache Lucene.Net 2.4.0 Class Library API

OpenBitSet.FlipAndGet Method

Overload List

public bool FlipAndGet(int);

public bool FlipAndGet(long);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.FlipAndGet Method (Int32)

public bool FlipAndGet(
int index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.FlipAndGet Overload List


OpenBitSet.FlipAndGet Method (Int64)

public bool FlipAndGet(
long index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.FlipAndGet Overload List


Get Method

Apache Lucene.Net 2.4.0 Class Library API

OpenBitSet.Get Method

Overload List

public bool Get(int);

public bool Get(long);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Get Method (Int32)

public bool Get(
int index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.Get Overload List


OpenBitSet.Get Method (Int64)

public bool Get(
long index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.Get Overload List


GetAndSet Method

Apache Lucene.Net 2.4.0 Class Library API

OpenBitSet.GetAndSet Method

Overload List

public bool GetAndSet(int);

public bool GetAndSet(long);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.GetAndSet Method (Int32)

public bool GetAndSet(
int index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.GetAndSet Overload List


OpenBitSet.GetAndSet Method (Int64)

public bool GetAndSet(
long index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.GetAndSet Overload List


OpenBitSet.GetBit Method

public int GetBit(
int index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.GetBits Method

public long[] GetBits();

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.GetHashCode Method

public override int GetHashCode();

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.GetNumWords Method

public int GetNumWords();

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Intersect Method

public void Intersect(
OpenBitSet other
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.IntersectionCount Method

public static long IntersectionCount(
OpenBitSet a,
OpenBitSet b
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Intersects Method

public bool Intersects(
OpenBitSet other
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.IsEmpty Method

public bool IsEmpty();

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Iterator Method

public override DocIdSetIterator Iterator();

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


NextSetBit Method

Apache Lucene.Net 2.4.0 Class Library API

OpenBitSet.NextSetBit Method

Overload List

public int NextSetBit(int);

public long NextSetBit(long);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.NextSetBit Method (Int32)

public int NextSetBit(
int index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.NextSetBit Overload List


OpenBitSet.NextSetBit Method (Int64)

public long NextSetBit(
long index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.NextSetBit Overload List


OpenBitSet.Or Method

public void Or(
OpenBitSet other
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Remove Method

public void Remove(
OpenBitSet other
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


Set Method

Apache Lucene.Net 2.4.0 Class Library API

OpenBitSet.Set Method

Overload List

public void Set(long);

public void Set(long,long);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Set Method (Int64)

public void Set(
long index
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.Set Overload List


OpenBitSet.Set Method (Int64, Int64)

public void Set(
long startIndex,
long endIndex
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace | OpenBitSet.Set Overload List


OpenBitSet.SetBits Method

public void SetBits(
long[] bits
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.SetNumWords Method

public void SetNumWords(
int nWords
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Size Method

public long Size();

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.trimTrailingZeros Method

public void trimTrailingZeros();

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Union Method

public void Union(
OpenBitSet other
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.UnionCount Method

public static long UnionCount(
OpenBitSet a,
OpenBitSet b
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.Xor Method

public void Xor(
OpenBitSet other
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSet.XorCount Method

public static long XorCount(
OpenBitSet a,
OpenBitSet b
);

See Also

OpenBitSet Class | Lucene.Net.Util Namespace


OpenBitSetDISI Class

For a list of all members of this type, see OpenBitSetDISI Members.

System.Object
Lucene.Net.Search.DocIdSet
Lucene.Net.Util.OpenBitSet
Lucene.Net.Util.OpenBitSetDISI

public class OpenBitSetDISI : OpenBitSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

OpenBitSetDISI Members | Lucene.Net.Util Namespace


OpenBitSetDISI Members

OpenBitSetDISI overview

Public Instance Constructors

OpenBitSetDISI Overloaded. Initializes a new instance of the OpenBitSetDISI class.

Public Instance Methods

And (inherited from OpenBitSet) |
AndNot (inherited from OpenBitSet) |
Capacity (inherited from OpenBitSet) |
Cardinality (inherited from OpenBitSet) |
Clear (inherited from OpenBitSet) | Overloaded.
Clone (inherited from OpenBitSet) |
EnsureCapacity (inherited from OpenBitSet) |
EnsureCapacityWords (inherited from OpenBitSet) |
Equals (inherited from OpenBitSet) |
FastClear (inherited from OpenBitSet) | Overloaded.
FastFlip (inherited from OpenBitSet) | Overloaded.
FastGet (inherited from OpenBitSet) | Overloaded.
FastSet (inherited from OpenBitSet) | Overloaded.
Flip (inherited from OpenBitSet) | Overloaded.
FlipAndGet (inherited from OpenBitSet) | Overloaded.
Get (inherited from OpenBitSet) | Overloaded.
GetAndSet (inherited from OpenBitSet) | Overloaded.
GetBit (inherited from OpenBitSet) |
GetBits (inherited from OpenBitSet) |
GetHashCode (inherited from OpenBitSet) |
GetNumWords (inherited from OpenBitSet) |
GetType (inherited from Object) | Gets the Type of the current instance.
InPlaceAnd |
InPlaceNot |
InPlaceOr |
InPlaceXor |
Intersect (inherited from OpenBitSet) |
Intersects (inherited from OpenBitSet) |
IsEmpty (inherited from OpenBitSet) |
Iterator (inherited from OpenBitSet) |
NextSetBit (inherited from OpenBitSet) | Overloaded.
Or (inherited from OpenBitSet) |
Remove (inherited from OpenBitSet) |
Set (inherited from OpenBitSet) | Overloaded.
SetBits (inherited from OpenBitSet) |
SetNumWords (inherited from OpenBitSet) |
Size (inherited from OpenBitSet) |
ToString (inherited from Object) | Returns a String that represents the current Object.
trimTrailingZeros (inherited from OpenBitSet) |
Union (inherited from OpenBitSet) |
Xor (inherited from OpenBitSet) |

Protected Instance Fields

bits (inherited from OpenBitSet)
wlen (inherited from OpenBitSet)

Protected Instance Methods

ExpandingWordNum (inherited from OpenBitSet) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OpenBitSetDISI Class | Lucene.Net.Util Namespace


OpenBitSetDISI Constructor

Overload List

public OpenBitSetDISI(DocIdSetIterator,int);

public OpenBitSetDISI(int);

See Also

OpenBitSetDISI Class | Lucene.Net.Util Namespace


OpenBitSetDISI Constructor (DocIdSetIterator, Int32)

public OpenBitSetDISI(
DocIdSetIterator disi,
int maxSize
);

See Also

OpenBitSetDISI Class | Lucene.Net.Util Namespace | OpenBitSetDISI Constructor Overload List


OpenBitSetDISI Constructor (Int32)

public OpenBitSetDISI(
int maxSize
);

See Also

OpenBitSetDISI Class | Lucene.Net.Util Namespace | OpenBitSetDISI Constructor Overload List


OpenBitSetDISI Methods

The methods of the OpenBitSetDISI class are listed below. For a complete list of OpenBitSetDISI class members, see the OpenBitSetDISI Members topic.

Public Instance Methods

And (inherited from OpenBitSet) |
AndNot (inherited from OpenBitSet) |
Capacity (inherited from OpenBitSet) |
Cardinality (inherited from OpenBitSet) |
Clear (inherited from OpenBitSet) | Overloaded.
Clone (inherited from OpenBitSet) |
EnsureCapacity (inherited from OpenBitSet) |
EnsureCapacityWords (inherited from OpenBitSet) |
Equals (inherited from OpenBitSet) |
FastClear (inherited from OpenBitSet) | Overloaded.
FastFlip (inherited from OpenBitSet) | Overloaded.
FastGet (inherited from OpenBitSet) | Overloaded.
FastSet (inherited from OpenBitSet) | Overloaded.
Flip (inherited from OpenBitSet) | Overloaded.
FlipAndGet (inherited from OpenBitSet) | Overloaded.
Get (inherited from OpenBitSet) | Overloaded.
GetAndSet (inherited from OpenBitSet) | Overloaded.
GetBit (inherited from OpenBitSet) |
GetBits (inherited from OpenBitSet) |
GetHashCode (inherited from OpenBitSet) |
GetNumWords (inherited from OpenBitSet) |
GetType (inherited from Object) | Gets the Type of the current instance.
InPlaceAnd |
InPlaceNot |
InPlaceOr |
InPlaceXor |
Intersect (inherited from OpenBitSet) |
Intersects (inherited from OpenBitSet) |
IsEmpty (inherited from OpenBitSet) |
Iterator (inherited from OpenBitSet) |
NextSetBit (inherited from OpenBitSet) | Overloaded.
Or (inherited from OpenBitSet) |
Remove (inherited from OpenBitSet) |
Set (inherited from OpenBitSet) | Overloaded.
SetBits (inherited from OpenBitSet) |
SetNumWords (inherited from OpenBitSet) |
Size (inherited from OpenBitSet) |
ToString (inherited from Object) | Returns a String that represents the current Object.
trimTrailingZeros (inherited from OpenBitSet) |
Union (inherited from OpenBitSet) |
Xor (inherited from OpenBitSet) |

Protected Instance Methods

ExpandingWordNum (inherited from OpenBitSet) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OpenBitSetDISI Class | Lucene.Net.Util Namespace


OpenBitSetDISI.InPlaceAnd Method

public void InPlaceAnd(
DocIdSetIterator disi
);

See Also

OpenBitSetDISI Class | Lucene.Net.Util Namespace


OpenBitSetDISI.InPlaceNot Method

public void InPlaceNot(
DocIdSetIterator disi
);

See Also

OpenBitSetDISI Class | Lucene.Net.Util Namespace


OpenBitSetDISI.InPlaceOr Method

public void InPlaceOr(
DocIdSetIterator disi
);

See Also

OpenBitSetDISI Class | Lucene.Net.Util Namespace


OpenBitSetDISI.InPlaceXor Method

public void InPlaceXor(
DocIdSetIterator disi
);

See Also

OpenBitSetDISI Class | Lucene.Net.Util Namespace


OpenBitSetIterator Class

For a list of all members of this type, see OpenBitSetIterator Members.

System.Object
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Util.OpenBitSetIterator

public class OpenBitSetIterator : DocIdSetIterator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

OpenBitSetIterator Members | Lucene.Net.Util Namespace


OpenBitSetIterator Members

OpenBitSetIterator overview

Protected Static Fields

bitlist

Public Instance Constructors

OpenBitSetIterator Overloaded. Initializes a new instance of the OpenBitSetIterator class.

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OpenBitSetIterator Class | Lucene.Net.Util Namespace


OpenBitSetIterator Constructor

Overload List

public OpenBitSetIterator(OpenBitSet);

public OpenBitSetIterator(long[],int);

See Also

OpenBitSetIterator Class | Lucene.Net.Util Namespace


OpenBitSetIterator Constructor (OpenBitSet)

public OpenBitSetIterator(
OpenBitSet obs
);

See Also

OpenBitSetIterator Class | Lucene.Net.Util Namespace | OpenBitSetIterator Constructor Overload List


OpenBitSetIterator Constructor (Int64[], Int32)

public OpenBitSetIterator(
long[] bits,
int numWords
);

See Also

OpenBitSetIterator Class | Lucene.Net.Util Namespace | OpenBitSetIterator Constructor Overload List


OpenBitSetIterator Fields

The fields of the OpenBitSetIterator class are listed below. For a complete list of OpenBitSetIterator class members, see the OpenBitSetIterator Members topic.

Protected Static Fields

bitlist

See Also

OpenBitSetIterator Class | Lucene.Net.Util Namespace


OpenBitSetIterator.bitlist Field

protected static readonly uint[] bitlist;

See Also

OpenBitSetIterator Class | Lucene.Net.Util Namespace


OpenBitSetIterator Methods

The methods of the OpenBitSetIterator class are listed below. For a complete list of OpenBitSetIterator class members, see the OpenBitSetIterator Members topic.

Public Instance Methods

Doc |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next |
SkipTo |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OpenBitSetIterator Class | Lucene.Net.Util Namespace


OpenBitSetIterator.Doc Method

public override int Doc();

See Also

OpenBitSetIterator Class | Lucene.Net.Util Namespace


OpenBitSetIterator.Next Method

public override bool Next();

See Also

OpenBitSetIterator Class | Lucene.Net.Util Namespace


OpenBitSetIterator.SkipTo Method

public override bool SkipTo(
int target
);

See Also

OpenBitSetIterator Class | Lucene.Net.Util Namespace


Parameter Class

A serializable Enum class.

For a list of all members of this type, see Parameter Members.

System.Object
Lucene.Net.Util.Parameter
Lucene.Net.Documents.Field.Index
Lucene.Net.Documents.Field.Store
Lucene.Net.Documents.Field.TermVector
Lucene.Net.QueryParsers.QueryParser.Operator
Lucene.Net.Search.BooleanClause.Occur

public abstract class Parameter : IObjectReference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Parameter Members | Lucene.Net.Util Namespace


Parameter Members

Parameter overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRealObject |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

Parameter Constructor

Protected Internal Instance Methods

ReadResolve Resolves the deserialized instance to the local reference for accurate equals() and == comparisons.

See Also

Parameter Class | Lucene.Net.Util Namespace


Parameter Constructor

protected internal Parameter(
string name
);

See Also

Parameter Class | Lucene.Net.Util Namespace


Parameter Methods

The methods of the Parameter class are listed below. For a complete list of Parameter class members, see the Parameter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRealObject |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

ReadResolve Resolves the deserialized instance to the local reference for accurate equals() and == comparisons.

See Also

Parameter Class | Lucene.Net.Util Namespace


Parameter.GetRealObject Method

public object GetRealObject(
StreamingContext context
);

Implements

IObjectReference.GetRealObject

See Also

Parameter Class | Lucene.Net.Util Namespace


Parameter.ReadResolve Method

Resolves the deserialized instance to the local reference for accurate equals() and == comparisons.

protected internal virtual object ReadResolve();

Return Value

a reference to Parameter as resolved in the local VM

See Also

Parameter Class | Lucene.Net.Util Namespace


Parameter.ToString Method

public override string ToString();

See Also

Parameter Class | Lucene.Net.Util Namespace


PriorityQueue Class

A PriorityQueue maintains a partial ordering of its elements such that the least element can always be found in constant time. Put()'s and pop()'s require log(size) time.

For a list of all members of this type, see PriorityQueue Members.

System.Object
Lucene.Net.Util.PriorityQueue
Lucene.Net.Search.FieldSortedHitQueue
Lucene.Net.Search.FuzzyQuery.ScoreTermQueue

public abstract class PriorityQueue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

PriorityQueue Members | Lucene.Net.Util Namespace


PriorityQueue Members

PriorityQueue overview

Public Instance Methods

AdjustTop Should be called when the object at top changes values. Still log(n) worst case, but it's at least twice as fast to
 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }
Clear | Removes all entries from the PriorityQueue.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
InsertWithOverflow | insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
LessThan | Determines the ordering of objects in this priority queue. Subclasses must define this one method.
Pop | Removes and returns the least element of the PriorityQueue in log(size) time.
Put | Adds an object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Size | Returns the number of elements currently stored in the PriorityQueue.
Top | Returns the least element of the PriorityQueue in constant time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

PriorityQueue Constructor Initializes a new instance of the PriorityQueue class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Initialize | Subclass constructors must call this.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

heap

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue Constructor

Initializes a new instance of the PriorityQueue class.

protected PriorityQueue();

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue Fields

The fields of the PriorityQueue class are listed below. For a complete list of PriorityQueue class members, see the PriorityQueue Members topic.

Protected Internal Instance Fields

heap

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.heap Field

protected internal object[] heap;

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue Methods

The methods of the PriorityQueue class are listed below. For a complete list of PriorityQueue class members, see the PriorityQueue Members topic.

Public Instance Methods

AdjustTop Should be called when the object at top changes values. Still log(n) worst case, but it's at least twice as fast to
 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }
Clear | Removes all entries from the PriorityQueue.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
InsertWithOverflow | insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
LessThan | Determines the ordering of objects in this priority queue. Subclasses must define this one method.
Pop | Removes and returns the least element of the PriorityQueue in log(size) time.
Put | Adds an object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Size | Returns the number of elements currently stored in the PriorityQueue.
Top | Returns the least element of the PriorityQueue in constant time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Initialize | Subclass constructors must call this.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.AdjustTop Method

Should be called when the object at top changes values. Still log(n) worst case, but it's at least twice as fast to

 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }

public void AdjustTop();

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Clear Method

Removes all entries from the PriorityQueue.

public void Clear();

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Initialize Method

Subclass constructors must call this.

protected void Initialize(
int maxSize
);

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Insert Method

Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).

public virtual bool Insert(
object element
);

Parameters

element

Return Value

true if element is added, false otherwise.

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.InsertWithOverflow Method

insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.

public virtual object InsertWithOverflow(
object element
);

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.LessThan Method

Determines the ordering of objects in this priority queue. Subclasses must define this one method.

public abstract bool LessThan(
object a,
object b
);

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Pop Method

Removes and returns the least element of the PriorityQueue in log(size) time.

public object Pop();

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Put Method

Adds an object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.

public void Put(
object element
);

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Size Method

Returns the number of elements currently stored in the PriorityQueue.

public int Size();

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


PriorityQueue.Top Method

Returns the least element of the PriorityQueue in constant time.

public object Top();

See Also

PriorityQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue Class

A ScorerDocQueue maintains a partial ordering of its Scorers such that the least Scorer can always be found in constant time. Put()'s and pop()'s require log(size) time. The ordering is by Scorer.doc().

For a list of all members of this type, see ScorerDocQueue Members.

System.Object
Lucene.Net.Util.ScorerDocQueue

public class ScorerDocQueue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ScorerDocQueue Members | Lucene.Net.Util Namespace


ScorerDocQueue Members

ScorerDocQueue overview

Public Instance Constructors

ScorerDocQueue Constructor Create a ScorerDocQueue with a maximum size.

Public Instance Methods

AdjustTop Should be called when the scorer at top changes doc() value. Still log(n) worst case, but it's at least twice as fast to
 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }
Clear | Removes all entries from the ScorerDocQueue.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Adds a Scorer to the ScorerDocQueue in log(size) time if either the ScorerDocQueue is not full, or not lessThan(scorer, top()).
Pop | Removes and returns the least scorer of the ScorerDocQueue in log(size) time. Should not be used when the queue is empty.
Put | Adds a Scorer to a ScorerDocQueue in log(size) time. If one tries to add more Scorers than maxSize a SystemException (ArrayIndexOutOfBound) is thrown.
Size | Returns the number of scorers currently stored in the ScorerDocQueue.
Top | Returns the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.
TopDoc | Returns document number of the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.
TopNextAndAdjustElsePop
TopScore
TopSkipToAndAdjustElsePop
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue Constructor

Create a ScorerDocQueue with a maximum size.

public ScorerDocQueue(
int maxSize
);

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue Methods

The methods of the ScorerDocQueue class are listed below. For a complete list of ScorerDocQueue class members, see the ScorerDocQueue Members topic.

Public Instance Methods

AdjustTop Should be called when the scorer at top changes doc() value. Still log(n) worst case, but it's at least twice as fast to
 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }
Clear | Removes all entries from the ScorerDocQueue.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Adds a Scorer to the ScorerDocQueue in log(size) time if either the ScorerDocQueue is not full, or not lessThan(scorer, top()).
Pop | Removes and returns the least scorer of the ScorerDocQueue in log(size) time. Should not be used when the queue is empty.
Put | Adds a Scorer to a ScorerDocQueue in log(size) time. If one tries to add more Scorers than maxSize a SystemException (ArrayIndexOutOfBound) is thrown.
Size | Returns the number of scorers currently stored in the ScorerDocQueue.
Top | Returns the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.
TopDoc | Returns document number of the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.
TopNextAndAdjustElsePop
TopScore
TopSkipToAndAdjustElsePop
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue.AdjustTop Method

Should be called when the scorer at top changes doc() value. Still log(n) worst case, but it's at least twice as fast to

 { pq.top().change(); pq.adjustTop(); }
instead of
 { o = pq.pop(); o.change(); pq.push(o); }

public void AdjustTop();

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue.Clear Method

Removes all entries from the ScorerDocQueue.

public void Clear();

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue.Insert Method

Adds a Scorer to the ScorerDocQueue in log(size) time if either the ScorerDocQueue is not full, or not lessThan(scorer, top()).

public virtual bool Insert(
Scorer scorer
);

Parameters

scorer

Return Value

true if scorer is added, false otherwise.

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue.Pop Method

Removes and returns the least scorer of the ScorerDocQueue in log(size) time. Should not be used when the queue is empty.

public Scorer Pop();

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue.Put Method

Adds a Scorer to a ScorerDocQueue in log(size) time. If one tries to add more Scorers than maxSize a SystemException (ArrayIndexOutOfBound) is thrown.

public void Put(
Scorer scorer
);

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue.Size Method

Returns the number of scorers currently stored in the ScorerDocQueue.

public int Size();

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue.Top Method

Returns the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.

public Scorer Top();

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue.TopDoc Method

Returns document number of the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.

public int TopDoc();

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue.TopNextAndAdjustElsePop Method

public bool TopNextAndAdjustElsePop();

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue.TopScore Method

public float TopScore();

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


ScorerDocQueue.TopSkipToAndAdjustElsePop Method

public bool TopSkipToAndAdjustElsePop(
int target
);

See Also

ScorerDocQueue Class | Lucene.Net.Util Namespace


SmallFloat Class

Floating point numbers smaller than 32 bits.

For a list of all members of this type, see SmallFloat Members.

System.Object
Lucene.Net.Util.SmallFloat

public class SmallFloat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SmallFloat Members | Lucene.Net.Util Namespace


SmallFloat Members

SmallFloat overview

Public Static Methods

Byte315ToFloat | byteToFloat(b, mantissaBits=3, zeroExponent=15)
Byte52ToFloat | byteToFloat(b, mantissaBits=5, zeroExponent=2)
ByteToFloat | Converts an 8 bit float to a 32 bit float.
FloatToByte |
FloatToByte315 |
FloatToByte52 |

Public Instance Constructors

SmallFloat Constructor Initializes a new instance of the SmallFloat class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmallFloat Class | Lucene.Net.Util Namespace


SmallFloat Constructor

Initializes a new instance of the SmallFloat class.

public SmallFloat();

See Also

SmallFloat Class | Lucene.Net.Util Namespace


SmallFloat Methods

The methods of the SmallFloat class are listed below. For a complete list of SmallFloat class members, see the SmallFloat Members topic.

Public Static Methods

Byte315ToFloat | byteToFloat(b, mantissaBits=3, zeroExponent=15)
Byte52ToFloat | byteToFloat(b, mantissaBits=5, zeroExponent=2)
ByteToFloat | Converts an 8 bit float to a 32 bit float.
FloatToByte |
FloatToByte315 |
FloatToByte52 |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmallFloat Class | Lucene.Net.Util Namespace


SmallFloat.Byte315ToFloat Method

byteToFloat(b, mantissaBits=3, zeroExponent=15)

public static float Byte315ToFloat(
byte b
);

See Also

SmallFloat Class | Lucene.Net.Util Namespace


SmallFloat.Byte52ToFloat Method

byteToFloat(b, mantissaBits=5, zeroExponent=2)

public static float Byte52ToFloat(
byte b
);

See Also

SmallFloat Class | Lucene.Net.Util Namespace


SmallFloat.ByteToFloat Method

Converts an 8 bit float to a 32 bit float.

public static float ByteToFloat(
byte b,
int numMantissaBits,
int zeroExp
);

See Also

SmallFloat Class | Lucene.Net.Util Namespace


SmallFloat.FloatToByte Method

public static sbyte FloatToByte(
float f,
int numMantissaBits,
int zeroExp
);

See Also

SmallFloat Class | Lucene.Net.Util Namespace


SmallFloat.FloatToByte315 Method

public static sbyte FloatToByte315(
float f
);

See Also

SmallFloat Class | Lucene.Net.Util Namespace


SmallFloat.FloatToByte52 Method

public static sbyte FloatToByte52(
float f
);

See Also

SmallFloat Class | Lucene.Net.Util Namespace


SortedVIntList Class

For a list of all members of this type, see SortedVIntList Members.

System.Object
Lucene.Net.Search.DocIdSet
Lucene.Net.Util.SortedVIntList

public class SortedVIntList : DocIdSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SortedVIntList Members | Lucene.Net.Util Namespace


SortedVIntList Members

SortedVIntList overview

Protected Internal Static Fields

BITS2VINTLIST_SIZE

Public Instance Constructors

SortedVIntList Overloaded. Initializes a new instance of the SortedVIntList class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetByteSize |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Iterator |
Size |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortedVIntList Class | Lucene.Net.Util Namespace


SortedVIntList Constructor

Overload List

public SortedVIntList(DocIdSetIterator);

public SortedVIntList(OpenBitSet);

public SortedVIntList(BitSet);

public SortedVIntList(int[]);

public SortedVIntList(int[],int);

See Also

SortedVIntList Class | Lucene.Net.Util Namespace


SortedVIntList Constructor (Int32[])

public SortedVIntList(
int[] sortedInts
);

See Also

SortedVIntList Class | Lucene.Net.Util Namespace | SortedVIntList Constructor Overload List


SortedVIntList Constructor (Int32[], Int32)

public SortedVIntList(
int[] sortedInts,
int inputSize
);

See Also

SortedVIntList Class | Lucene.Net.Util Namespace | SortedVIntList Constructor Overload List


SortedVIntList Constructor (BitSet)

public SortedVIntList(
BitSet bits
);

See Also

SortedVIntList Class | Lucene.Net.Util Namespace | SortedVIntList Constructor Overload List


SortedVIntList Constructor (OpenBitSet)

public SortedVIntList(
OpenBitSet bits
);

See Also

SortedVIntList Class | Lucene.Net.Util Namespace | SortedVIntList Constructor Overload List


SortedVIntList Constructor (DocIdSetIterator)

public SortedVIntList(
DocIdSetIterator docIdSetIterator
);

See Also

SortedVIntList Class | Lucene.Net.Util Namespace | SortedVIntList Constructor Overload List


SortedVIntList Fields

The fields of the SortedVIntList class are listed below. For a complete list of SortedVIntList class members, see the SortedVIntList Members topic.

Protected Internal Static Fields

BITS2VINTLIST_SIZE

See Also

SortedVIntList Class | Lucene.Net.Util Namespace


SortedVIntList.BITS2VINTLIST_SIZE Field

protected internal static readonly int BITS2VINTLIST_SIZE;

See Also

SortedVIntList Class | Lucene.Net.Util Namespace


SortedVIntList Methods

The methods of the SortedVIntList class are listed below. For a complete list of SortedVIntList class members, see the SortedVIntList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetByteSize |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Iterator |
Size |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortedVIntList Class | Lucene.Net.Util Namespace


SortedVIntList.GetByteSize Method

public int GetByteSize();

See Also

SortedVIntList Class | Lucene.Net.Util Namespace


SortedVIntList.Iterator Method

public override DocIdSetIterator Iterator();

See Also

SortedVIntList Class | Lucene.Net.Util Namespace


SortedVIntList.Size Method

public int Size();

See Also

SortedVIntList Class | Lucene.Net.Util Namespace


StringHelper Class

Methods for manipulating strings.

For a list of all members of this type, see StringHelper Members.

System.Object
Lucene.Net.Util.StringHelper

public abstract class StringHelper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

StringHelper Members | Lucene.Net.Util Namespace


StringHelper Members

StringHelper overview

Public Static Methods

bytesDifference | Compares two byte arrays, starting at their 0th elements, and returns the number of common elements before encountering a difference.
StringDifference | Compares two strings, character by character, and returns the first position where the two strings differ from one another.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringHelper Class | Lucene.Net.Util Namespace


StringHelper Methods

The methods of the StringHelper class are listed below. For a complete list of StringHelper class members, see the StringHelper Members topic.

Public Static Methods

bytesDifference | Compares two byte arrays, starting at their 0th elements, and returns the number of common elements before encountering a difference.
StringDifference | Compares two strings, character by character, and returns the first position where the two strings differ from one another.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringHelper Class | Lucene.Net.Util Namespace


StringHelper.bytesDifference Method

Compares two byte arrays, starting at their 0th elements, and returns the number of common elements before encountering a difference.

public static int bytesDifference(
byte[] bytes1,
int len1,
byte[] bytes2,
int len2
);

Parameters

bytes1
len1
bytes2
len2

Return Value

the number of common elements

See Also

StringHelper Class | Lucene.Net.Util Namespace


StringHelper.StringDifference Method

Compares two strings, character by character, and returns the first position where the two strings differ from one another.

public static int StringDifference(
string s1,
string s2
);

Parameters

s1
The first string to compare
s2
The second string to compare

Return Value

The first position where the two strings differ.

See Also

StringHelper Class | Lucene.Net.Util Namespace


ToStringUtils Class

For a list of all members of this type, see ToStringUtils Members.

System.Object
Lucene.Net.Util.ToStringUtils

public class ToStringUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

ToStringUtils Members | Lucene.Net.Util Namespace


ToStringUtils Members

ToStringUtils overview

Public Static Methods

Boost for printing boost only if not 1.0

Public Instance Constructors

ToStringUtils Constructor Initializes a new instance of the ToStringUtils class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToStringUtils Class | Lucene.Net.Util Namespace


ToStringUtils Constructor

Initializes a new instance of the ToStringUtils class.

public ToStringUtils();

See Also

ToStringUtils Class | Lucene.Net.Util Namespace


ToStringUtils Methods

The methods of the ToStringUtils class are listed below. For a complete list of ToStringUtils class members, see the ToStringUtils Members topic.

Public Static Methods

Boost for printing boost only if not 1.0

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToStringUtils Class | Lucene.Net.Util Namespace


ToStringUtils.Boost Method

for printing boost only if not 1.0

public static string Boost(
float boost
);

See Also

ToStringUtils Class | Lucene.Net.Util Namespace


UnicodeUtil Class

For a list of all members of this type, see UnicodeUtil Members.

System.Object
Lucene.Net.Util.UnicodeUtil

public sealed class UnicodeUtil

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

UnicodeUtil Members | Lucene.Net.Util Namespace


UnicodeUtil Members

UnicodeUtil overview

Public Static Fields

UNI_REPLACEMENT_CHAR
UNI_SUR_HIGH_END
UNI_SUR_HIGH_START
UNI_SUR_LOW_END
UNI_SUR_LOW_START

Public Static Methods

UTF16toUTF8 | Overloaded.
UTF8toUTF16 |

Public Instance Constructors

UnicodeUtil Constructor Initializes a new instance of the UnicodeUtil class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace


UnicodeUtil Constructor

Initializes a new instance of the UnicodeUtil class.

public UnicodeUtil();

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace


UnicodeUtil Fields

The fields of the UnicodeUtil class are listed below. For a complete list of UnicodeUtil class members, see the UnicodeUtil Members topic.

Public Static Fields

UNI_REPLACEMENT_CHAR
UNI_SUR_HIGH_END
UNI_SUR_HIGH_START
UNI_SUR_LOW_END
UNI_SUR_LOW_START

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace


UnicodeUtil.UNI_REPLACEMENT_CHAR Field

public static readonly int UNI_REPLACEMENT_CHAR;

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace


UnicodeUtil.UNI_SUR_HIGH_END Field

public static readonly int UNI_SUR_HIGH_END;

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace


UnicodeUtil.UNI_SUR_HIGH_START Field

public static readonly int UNI_SUR_HIGH_START;

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace


UnicodeUtil.UNI_SUR_LOW_END Field

public static readonly int UNI_SUR_LOW_END;

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace


UnicodeUtil.UNI_SUR_LOW_START Field

public static readonly int UNI_SUR_LOW_START;

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace


UnicodeUtil Methods

The methods of the UnicodeUtil class are listed below. For a complete list of UnicodeUtil class members, see the UnicodeUtil Members topic.

Public Static Methods

UTF16toUTF8 | Overloaded.
UTF8toUTF16 |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace


UTF16toUTF8 Method

Apache Lucene.Net 2.4.0 Class Library API

UnicodeUtil.UTF16toUTF8 Method

Overload List

public static void UTF16toUTF8(char[],int,UTF8Result);

public static void UTF16toUTF8(char[],int,int,UTF8Result);

public static void UTF16toUTF8(string,int,int,UTF8Result);

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF16toUTF8 Method (Char[], Int32, UTF8Result)

public static void UTF16toUTF8(
char[] source,
int offset,
UTF8Result result
);

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace | UnicodeUtil.UTF16toUTF8 Overload List


UnicodeUtil.UTF16toUTF8 Method (Char[], Int32, Int32, UTF8Result)

public static void UTF16toUTF8(
char[] source,
int offset,
int length,
UTF8Result result
);

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace | UnicodeUtil.UTF16toUTF8 Overload List


UnicodeUtil.UTF16toUTF8 Method (String, Int32, Int32, UTF8Result)

public static void UTF16toUTF8(
string s,
int offset,
int length,
UTF8Result result
);

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace | UnicodeUtil.UTF16toUTF8 Overload List


UnicodeUtil.UTF8toUTF16 Method

public static void UTF8toUTF16(
byte[] utf8,
int offset,
int length,
UTF16Result result
);

See Also

UnicodeUtil Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result Class

For a list of all members of this type, see UnicodeUtil.UTF16Result Members.

System.Object
Lucene.Net.Util.UnicodeUtil.UTF16Result

public sealed class UnicodeUtil.UTF16Result

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

UnicodeUtil.UTF16Result Members | Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result Members

UnicodeUtil.UTF16Result overview

Public Instance Constructors

UnicodeUtil.UTF16Result Constructor Initializes a new instance of the UnicodeUtil.UTF16Result class.

Public Instance Fields

length
offsets
result

Public Instance Methods

copyText |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
setLength |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UnicodeUtil.UTF16Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result Constructor

Initializes a new instance of the UnicodeUtil.UTF16Result class.

public UnicodeUtil.UTF16Result();

See Also

UnicodeUtil.UTF16Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result Fields

The fields of the UnicodeUtil.UTF16Result class are listed below. For a complete list of UnicodeUtil.UTF16Result class members, see the UnicodeUtil.UTF16Result Members topic.

Public Instance Fields

length
offsets
result

See Also

UnicodeUtil.UTF16Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result.length Field

public int length;

See Also

UnicodeUtil.UTF16Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result.offsets Field

public int[] offsets;

See Also

UnicodeUtil.UTF16Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result.result Field

public char[] result;

See Also

UnicodeUtil.UTF16Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result Methods

The methods of the UnicodeUtil.UTF16Result class are listed below. For a complete list of UnicodeUtil.UTF16Result class members, see the UnicodeUtil.UTF16Result Members topic.

Public Instance Methods

copyText |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
setLength |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UnicodeUtil.UTF16Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result.copyText Method

public void copyText(
UTF16Result other
);

See Also

UnicodeUtil.UTF16Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result.setLength Method

public void setLength(
int newLength
);

See Also

UnicodeUtil.UTF16Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result Class

For a list of all members of this type, see UnicodeUtil.UTF8Result Members.

System.Object
Lucene.Net.Util.UnicodeUtil.UTF8Result

public sealed class UnicodeUtil.UTF8Result

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

UnicodeUtil.UTF8Result Members | Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result Members

UnicodeUtil.UTF8Result overview

Public Instance Constructors

UnicodeUtil.UTF8Result Constructor Initializes a new instance of the UnicodeUtil.UTF8Result class.

Public Instance Fields

length
result

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
setLength |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UnicodeUtil.UTF8Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result Constructor

Initializes a new instance of the UnicodeUtil.UTF8Result class.

public UnicodeUtil.UTF8Result();

See Also

UnicodeUtil.UTF8Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result Fields

The fields of the UnicodeUtil.UTF8Result class are listed below. For a complete list of UnicodeUtil.UTF8Result class members, see the UnicodeUtil.UTF8Result Members topic.

Public Instance Fields

length
result

See Also

UnicodeUtil.UTF8Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result.length Field

public int length;

See Also

UnicodeUtil.UTF8Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result.result Field

public byte[] result;

See Also

UnicodeUtil.UTF8Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result Methods

The methods of the UnicodeUtil.UTF8Result class are listed below. For a complete list of UnicodeUtil.UTF8Result class members, see the UnicodeUtil.UTF8Result Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
setLength |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UnicodeUtil.UTF8Result Class | Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result.setLength Method

public void setLength(
int newLength
);

See Also

UnicodeUtil.UTF8Result Class | Lucene.Net.Util Namespace


Lucene.Net.Util.Cache

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Util.Cache Namespace

Namespace hierarchy

Classes

Class | Description
Cache |
Cache.SynchronizedCache |
SimpleLRUCache |
SimpleLRUCache_LUCENENET_190_1 |
SimpleLRUCache_LUCENENET_190_2 | Implemented for LUCENENET-190. Good for capacity > 1536
SimpleLRUCache_OrgPort | This class is the original port for 2.4.0
SimpleMapCache |


Cache Class

For a list of all members of this type, see Cache Members.

System.Object
Lucene.Net.Util.Cache.Cache
Lucene.Net.Util.Cache.Cache.SynchronizedCache
Lucene.Net.Util.Cache.SimpleLRUCache_LUCENENET_190_1
Lucene.Net.Util.Cache.SimpleLRUCache_LUCENENET_190_2
Lucene.Net.Util.Cache.SimpleMapCache

public abstract class Cache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util.Cache

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Cache Members | Lucene.Net.Util.Cache Namespace


Cache Members

Cache overview

Public Static Methods

SynchronizedCache_Renamed

Public Instance Methods

Close |
ContainsKey |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Put |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Cache Constructor Initializes a new instance of the Cache class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSynchronizedCache

See Also

Cache Class | Lucene.Net.Util.Cache Namespace


Cache Constructor

Initializes a new instance of the Cache class.

protected Cache();

See Also

Cache Class | Lucene.Net.Util.Cache Namespace


Cache Methods

The methods of the Cache class are listed below. For a complete list of Cache class members, see the Cache Members topic.

Public Static Methods

SynchronizedCache_Renamed

Public Instance Methods

Close |
ContainsKey |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Put |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSynchronizedCache

See Also

Cache Class | Lucene.Net.Util.Cache Namespace


Cache.Close Method

public abstract void Close();

See Also

Cache Class | Lucene.Net.Util.Cache Namespace


Cache.ContainsKey Method

public abstract bool ContainsKey(
object key
);

See Also

Cache Class | Lucene.Net.Util.Cache Namespace


Cache.Get Method

public abstract object Get(
object key
);

See Also

Cache Class | Lucene.Net.Util.Cache Namespace


Cache.GetSynchronizedCache Method

protected internal virtual Cache GetSynchronizedCache();

See Also

Cache Class | Lucene.Net.Util.Cache Namespace


Cache.Put Method

public abstract void Put(
object key,
object value
);

See Also

Cache Class | Lucene.Net.Util.Cache Namespace


Cache.SynchronizedCache_Renamed Method

public static Cache SynchronizedCache_Renamed(
Cache cache
);

See Also

Cache Class | Lucene.Net.Util.Cache Namespace


Cache.SynchronizedCache Class

For a list of all members of this type, see Cache.SynchronizedCache Members.

System.Object
Lucene.Net.Util.Cache.Cache
Lucene.Net.Util.Cache.Cache.SynchronizedCache

public class Cache.SynchronizedCache : Cache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util.Cache

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

Cache.SynchronizedCache Members | Lucene.Net.Util.Cache Namespace


Cache.SynchronizedCache Members

Cache.SynchronizedCache overview

Public Instance Methods

Close |
ContainsKey |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Put |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

Cache.SynchronizedCache Overloaded. Initializes a new instance of the Cache.SynchronizedCache class.

Protected Internal Instance Methods

GetSynchronizedCache

See Also

Cache.SynchronizedCache Class | Lucene.Net.Util.Cache Namespace


Cache.SynchronizedCache Constructor

Overload List

protected internal Cache.SynchronizedCache(Cache);

protected internal Cache.SynchronizedCache(Cache,object);

See Also

Cache.SynchronizedCache Class | Lucene.Net.Util.Cache Namespace


Cache.SynchronizedCache Constructor (Cache)

protected internal Cache.SynchronizedCache(
Cache cache
);

See Also

Cache.SynchronizedCache Class | Lucene.Net.Util.Cache Namespace | Cache.SynchronizedCache Constructor Overload List


Cache.SynchronizedCache Constructor (Cache, Object)

protected internal Cache.SynchronizedCache(
Cache cache,
object mutex
);

See Also

Cache.SynchronizedCache Class | Lucene.Net.Util.Cache Namespace | Cache.SynchronizedCache Constructor Overload List


Cache.SynchronizedCache Methods

The methods of the Cache.SynchronizedCache class are listed below. For a complete list of Cache.SynchronizedCache class members, see the Cache.SynchronizedCache Members topic.

Public Instance Methods

Close |
ContainsKey |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Put |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSynchronizedCache

See Also

Cache.SynchronizedCache Class | Lucene.Net.Util.Cache Namespace


Cache.SynchronizedCache.Close Method

public override void Close();

See Also

Cache.SynchronizedCache Class | Lucene.Net.Util.Cache Namespace


Cache.SynchronizedCache.ContainsKey Method

public override bool ContainsKey(
object key
);

See Also

Cache.SynchronizedCache Class | Lucene.Net.Util.Cache Namespace


Cache.SynchronizedCache.Get Method

public override object Get(
object key
);

See Also

Cache.SynchronizedCache Class | Lucene.Net.Util.Cache Namespace


Cache.SynchronizedCache.GetSynchronizedCache Method

protected internal override Cache GetSynchronizedCache();

See Also

Cache.SynchronizedCache Class | Lucene.Net.Util.Cache Namespace


Cache.SynchronizedCache.Put Method

public override void Put(
object key,
object value
);

See Also

Cache.SynchronizedCache Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache Class

For a list of all members of this type, see SimpleLRUCache Members.

System.Object
Lucene.Net.Util.Cache.Cache
Lucene.Net.Util.Cache.SimpleLRUCache_LUCENENET_190_1
Lucene.Net.Util.Cache.SimpleLRUCache

public class SimpleLRUCache : SimpleLRUCache_LUCENENET_190_1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util.Cache

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SimpleLRUCache Members | Lucene.Net.Util.Cache Namespace


SimpleLRUCache Members

SimpleLRUCache overview

Public Instance Constructors

SimpleLRUCache Constructor

Public Instance Methods

Close (inherited from SimpleLRUCache_LUCENENET_190_1) |
ContainsKey (inherited from SimpleLRUCache_LUCENENET_190_1) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get (inherited from SimpleLRUCache_LUCENENET_190_1) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Put (inherited from SimpleLRUCache_LUCENENET_190_1) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSynchronizedCache (inherited from Cache)

See Also

SimpleLRUCache Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache Constructor

public SimpleLRUCache(
int Capacity
);

See Also

SimpleLRUCache Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_1 Class

For a list of all members of this type, see SimpleLRUCache_LUCENENET_190_1 Members.

System.Object
Lucene.Net.Util.Cache.Cache
Lucene.Net.Util.Cache.SimpleLRUCache_LUCENENET_190_1
Lucene.Net.Util.Cache.SimpleLRUCache

public class SimpleLRUCache_LUCENENET_190_1 : Cache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util.Cache

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SimpleLRUCache_LUCENENET_190_1 Members | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_1 Members

SimpleLRUCache_LUCENENET_190_1 overview

Public Instance Constructors

SimpleLRUCache_LUCENENET_190_1 Constructor

Public Instance Methods

Close |
ContainsKey |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Put |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSynchronizedCache (inherited from Cache)

See Also

SimpleLRUCache_LUCENENET_190_1 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_1 Constructor

public SimpleLRUCache_LUCENENET_190_1(
int Capacity
);

See Also

SimpleLRUCache_LUCENENET_190_1 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_1 Methods

The methods of the SimpleLRUCache_LUCENENET_190_1 class are listed below. For a complete list of SimpleLRUCache_LUCENENET_190_1 class members, see the SimpleLRUCache_LUCENENET_190_1 Members topic.

Public Instance Methods

Close |
ContainsKey |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Put |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSynchronizedCache (inherited from Cache)

See Also

SimpleLRUCache_LUCENENET_190_1 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_1.Close Method

public override void Close();

See Also

SimpleLRUCache_LUCENENET_190_1 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_1.ContainsKey Method

public override bool ContainsKey(
object key
);

See Also

SimpleLRUCache_LUCENENET_190_1 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_1.Get Method

public override object Get(
object Key
);

See Also

SimpleLRUCache_LUCENENET_190_1 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_1.Put Method

public override void Put(
object Key,
object Value
);

See Also

SimpleLRUCache_LUCENENET_190_1 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_2 Class

Implemented for LUCENENET-190. Good for capacity > 1536

For a list of all members of this type, see SimpleLRUCache_LUCENENET_190_2 Members.

System.Object
Lucene.Net.Util.Cache.Cache
Lucene.Net.Util.Cache.SimpleLRUCache_LUCENENET_190_2

public class SimpleLRUCache_LUCENENET_190_2 : Cache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util.Cache

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SimpleLRUCache_LUCENENET_190_2 Members | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_2 Members

SimpleLRUCache_LUCENENET_190_2 overview

Public Instance Constructors

SimpleLRUCache_LUCENENET_190_2 Constructor

Public Instance Methods

Close |
ContainsKey |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Put |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSynchronizedCache (inherited from Cache)

See Also

SimpleLRUCache_LUCENENET_190_2 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_2 Constructor

public SimpleLRUCache_LUCENENET_190_2(
int Capacity
);

See Also

SimpleLRUCache_LUCENENET_190_2 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_2 Methods

The methods of the SimpleLRUCache_LUCENENET_190_2 class are listed below. For a complete list of SimpleLRUCache_LUCENENET_190_2 class members, see the SimpleLRUCache_LUCENENET_190_2 Members topic.

Public Instance Methods

Close |
ContainsKey |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Put |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSynchronizedCache (inherited from Cache)

See Also

SimpleLRUCache_LUCENENET_190_2 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_2.Close Method

public override void Close();

See Also

SimpleLRUCache_LUCENENET_190_2 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_2.ContainsKey Method

public override bool ContainsKey(
object key
);

See Also

SimpleLRUCache_LUCENENET_190_2 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_2.Get Method

public override object Get(
object Key
);

See Also

SimpleLRUCache_LUCENENET_190_2 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_LUCENENET_190_2.Put Method

public override void Put(
object Key,
object Value
);

See Also

SimpleLRUCache_LUCENENET_190_2 Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_OrgPort Class

This class is the original port for 2.4.0

For a list of all members of this type, see SimpleLRUCache_OrgPort Members.

System.Object
Lucene.Net.Util.Cache.Cache
Lucene.Net.Util.Cache.SimpleMapCache
Lucene.Net.Util.Cache.SimpleLRUCache_OrgPort

public class SimpleLRUCache_OrgPort : SimpleMapCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util.Cache

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SimpleLRUCache_OrgPort Members | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_OrgPort Members

SimpleLRUCache_OrgPort overview

Public Instance Constructors

SimpleLRUCache_OrgPort Constructor

Public Instance Methods

Close (inherited from SimpleMapCache) |
ContainsKey (inherited from SimpleMapCache) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
keySet (inherited from SimpleMapCache) |
Put |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

map (inherited from SimpleMapCache)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSynchronizedCache (inherited from SimpleMapCache)

See Also

SimpleLRUCache_OrgPort Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_OrgPort Constructor

public SimpleLRUCache_OrgPort(
int cacheSize
);

See Also

SimpleLRUCache_OrgPort Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_OrgPort Methods

The methods of the SimpleLRUCache_OrgPort class are listed below. For a complete list of SimpleLRUCache_OrgPort class members, see the SimpleLRUCache_OrgPort Members topic.

Public Instance Methods

Close (inherited from SimpleMapCache) |
ContainsKey (inherited from SimpleMapCache) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
keySet (inherited from SimpleMapCache) |
Put |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSynchronizedCache (inherited from SimpleMapCache)

See Also

SimpleLRUCache_OrgPort Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_OrgPort.Get Method

public override object Get(
object key
);

See Also

SimpleLRUCache_OrgPort Class | Lucene.Net.Util.Cache Namespace


SimpleLRUCache_OrgPort.Put Method

public override void Put(
object key,
object value
);

See Also

SimpleLRUCache_OrgPort Class | Lucene.Net.Util.Cache Namespace


SimpleMapCache Class

For a list of all members of this type, see SimpleMapCache Members.

System.Object
Lucene.Net.Util.Cache.Cache
Lucene.Net.Util.Cache.SimpleMapCache
Lucene.Net.Util.Cache.SimpleLRUCache_OrgPort

public class SimpleMapCache : Cache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Util.Cache

Assembly: Lucene.Net (in Lucene.Net.dll)

See Also

SimpleMapCache Members | Lucene.Net.Util.Cache Namespace


SimpleMapCache Members

SimpleMapCache overview

Public Instance Constructors

SimpleMapCache Overloaded. Initializes a new instance of the SimpleMapCache class.

Public Instance Methods

Close |
ContainsKey |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
keySet |
Put |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

map

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSynchronizedCache

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace


SimpleMapCache Constructor

Initializes a new instance of the SimpleMapCache class.

Overload List

Initializes a new instance of the SimpleMapCache class.

public SimpleMapCache();

public SimpleMapCache(Hashtable);

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace


SimpleMapCache Constructor ()

Initializes a new instance of the SimpleMapCache class.

public SimpleMapCache();

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace | SimpleMapCache Constructor Overload List


SimpleMapCache Constructor (Hashtable)

public SimpleMapCache(
Hashtable map
);

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace | SimpleMapCache Constructor Overload List


SimpleMapCache Fields

The fields of the SimpleMapCache class are listed below. For a complete list of SimpleMapCache class members, see the SimpleMapCache Members topic.

Protected Instance Fields

map

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace


SimpleMapCache.map Field

protected Hashtable map;

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace


SimpleMapCache Methods

The methods of the SimpleMapCache class are listed below. For a complete list of SimpleMapCache class members, see the SimpleMapCache Members topic.

Public Instance Methods

Close |
ContainsKey |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
keySet |
Put |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSynchronizedCache

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace


SimpleMapCache.Close Method

public override void Close();

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace


SimpleMapCache.ContainsKey Method

public override bool ContainsKey(
object key
);

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace


SimpleMapCache.Get Method

public override object Get(
object key
);

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace


SimpleMapCache.GetSynchronizedCache Method

protected internal override Cache GetSynchronizedCache();

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace


SimpleMapCache.keySet Method

public virtual ICollection keySet();

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace


SimpleMapCache.Put Method

public override void Put(
object key,
object value
);

See Also

SimpleMapCache Class | Lucene.Net.Util.Cache Namespace


(global)Hierarchy

Apache Lucene.Net 2.4.0 Class Library API

(global) Hierarchy

System.Object
IThreadRunnable
Lucene.Net.Store.Directory
Lucene.Net.Store.FSDirectory
NIOFSDirectory
SupportClass
SupportClass.AppSettings
SupportClass.BitSetSupport
SupportClass.Character
SupportClass.Checksum
SupportClass.CollectionsSupport
SupportClass.CollectionsSupport.BitSet
SupportClass.Compare
SupportClass.CompressionSupport
SupportClass.CompressionSupport.ICompressionAdapter
SupportClass.CRC32 ---- SupportClass.Checksum
SupportClass.Cryptography
SupportClass.Date
SupportClass.FileStream
SupportClass.FileSupport
SupportClass.Number
SupportClass.Single
SupportClass.TextSupport
SupportClass.ThreadClass ---- IThreadRunnable
System.Collections.Hashtable ---- System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable, System.ICloneable, System.Runtime.Serialization.IDeserializationCallback, System.Runtime.Serialization.ISerializable
SupportClass.WeakHashTable

See Also

(global) Namespace


Analyzer Hierarchy

System.Object
Analyzer
KeywordAnalyzer
PerFieldAnalyzerWrapper
SimpleAnalyzer
StandardAnalyzer
StopAnalyzer
WhitespaceAnalyzer

See Also

Analyzer Class | Analyzer Members | Lucene.Net.Analysis Namespace


Lucene.Net.Analysis.StandardHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Analysis.Standard Hierarchy

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.Standard.StandardAnalyzer
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.Standard.StandardFilter
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.Standard.StandardTokenizer

See Also

Lucene.Net.Analysis.Standard Namespace


TokenFilter Hierarchy

System.Object
TokenStream
TokenFilter
CachingTokenFilter
ISOLatin1AccentFilter
LengthFilter
LowerCaseFilter
PorterStemFilter
StandardFilter
StopFilter
TeeTokenFilter

See Also

TokenFilter Class | TokenFilter Members | Lucene.Net.Analysis Namespace


Lucene.Net.AnalysisHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Analysis Hierarchy

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.KeywordAnalyzer
Lucene.Net.Analysis.PerFieldAnalyzerWrapper
Lucene.Net.Analysis.SimpleAnalyzer
Lucene.Net.Analysis.StopAnalyzer
Lucene.Net.Analysis.WhitespaceAnalyzer
Lucene.Net.Analysis.CharArraySet.CharArraySetIterator ---- System.Collections.IEnumerator
Lucene.Net.Analysis.Token ---- System.ICloneable
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.CachingTokenFilter
Lucene.Net.Analysis.ISOLatin1AccentFilter
Lucene.Net.Analysis.LengthFilter
Lucene.Net.Analysis.LowerCaseFilter
Lucene.Net.Analysis.PorterStemFilter
Lucene.Net.Analysis.StopFilter
Lucene.Net.Analysis.TeeTokenFilter
Lucene.Net.Analysis.Tokenizer
Lucene.Net.Analysis.CharTokenizer
Lucene.Net.Analysis.LetterTokenizer
Lucene.Net.Analysis.LowerCaseTokenizer
Lucene.Net.Analysis.WhitespaceTokenizer
Lucene.Net.Analysis.KeywordTokenizer
Lucene.Net.Analysis.SinkTokenizer
Lucene.Net.Analysis.WordlistLoader
System.Collections.Hashtable ---- System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable, System.ICloneable, System.Runtime.Serialization.IDeserializationCallback, System.Runtime.Serialization.ISerializable
Lucene.Net.Analysis.CharArraySet

See Also

Lucene.Net.Analysis Namespace


Lucene.Net.DocumentsHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Documents Hierarchy

System.Object
Lucene.Net.Documents.AbstractField ---- Lucene.Net.Documents.Fieldable
Lucene.Net.Documents.Field
Lucene.Net.Documents.DateField
Lucene.Net.Documents.DateTools
Lucene.Net.Documents.DateTools.Resolution
Lucene.Net.Documents.Document
Lucene.Net.Documents.Fieldable
Lucene.Net.Documents.FieldSelector
Lucene.Net.Documents.FieldSelectorResult
Lucene.Net.Documents.LoadFirstFieldSelector ---- Lucene.Net.Documents.FieldSelector
Lucene.Net.Documents.MapFieldSelector ---- Lucene.Net.Documents.FieldSelector
Lucene.Net.Documents.NumberTools
Lucene.Net.Documents.SetBasedFieldSelector ---- Lucene.Net.Documents.FieldSelector
Lucene.Net.Util.Parameter ---- System.Runtime.Serialization.IObjectReference
Lucene.Net.Documents.Field.Index
Lucene.Net.Documents.Field.Store
Lucene.Net.Documents.Field.TermVector

See Also

Lucene.Net.Documents Namespace


Lucene.Net.Index.CompressionHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Index.Compression Hierarchy

System.Object
Lucene.Net.Index.Compression.SharpZipLibAdapter ---- SupportClass.CompressionSupport.ICompressionAdapter

See Also

Lucene.Net.Index.Compression Namespace


Lucene.Net.IndexHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Index Hierarchy

System.Object
Lucene.Net.Documents.AbstractField ---- Lucene.Net.Documents.Fieldable
Lucene.Net.Index.FieldsReader.FieldForMerge
Lucene.Net.Index.ByteBlockPool
Lucene.Net.Index.ByteBlockPool.Allocator
Lucene.Net.Index.ByteSliceWriter
Lucene.Net.Index.CheckIndex
Lucene.Net.Index.CheckIndex.Status
Lucene.Net.Index.CheckIndex.Status.SegmentInfoStatus
Lucene.Net.Index.CompoundFileWriter
Lucene.Net.Index.DocumentsWriter
Lucene.Net.Index.FieldInfo ---- System.ICloneable
Lucene.Net.Index.FieldInfos ---- System.ICloneable
Lucene.Net.Index.FieldsReader
Lucene.Net.Index.FilterIndexReader.FilterTermDocs ---- Lucene.Net.Index.TermDocs
Lucene.Net.Index.FilterIndexReader.FilterTermPositions ---- Lucene.Net.Index.TermPositions
Lucene.Net.Index.IndexCommit ---- Lucene.Net.Index.IndexCommitPoint
Lucene.Net.Index.IndexCommitPoint
Lucene.Net.Index.IndexDeletionPolicy
Lucene.Net.Index.IndexFileDeleter
Lucene.Net.Index.IndexFileNameFilter
Lucene.Net.Index.IndexFileNames
Lucene.Net.Index.IndexModifier
Lucene.Net.Index.IndexReader
Lucene.Net.Index.DirectoryIndexReader
Lucene.Net.Index.MultiSegmentReader
Lucene.Net.Index.SegmentReader
Lucene.Net.Index.FilterIndexReader
Lucene.Net.Index.MultiReader
Lucene.Net.Index.ParallelReader
Lucene.Net.Index.IndexReader.FieldOption
Lucene.Net.Index.IndexWriter
Lucene.Net.Index.IndexWriter.MaxFieldLength
Lucene.Net.Index.KeepOnlyLastCommitDeletionPolicy ---- Lucene.Net.Index.IndexDeletionPolicy
Lucene.Net.Index.MergePolicy
Lucene.Net.Index.LogMergePolicy
Lucene.Net.Index.LogByteSizeMergePolicy
Lucene.Net.Index.LogDocMergePolicy
Lucene.Net.Index.MergePolicy.MergeSpecification
Lucene.Net.Index.MergePolicy.OneMerge
Lucene.Net.Index.MergeScheduler
Lucene.Net.Index.ConcurrentMergeScheduler
Lucene.Net.Index.SerialMergeScheduler
Lucene.Net.Index.MultipleTermPositions ---- Lucene.Net.Index.TermDocs, Lucene.Net.Index.TermPositions
Lucene.Net.Index.Payload ---- System.ICloneable
Lucene.Net.Index.PositionBasedTermVectorMapper.TVPositionInfo
Lucene.Net.Index.SegmentInfo ---- System.ICloneable
Lucene.Net.Index.SegmentInfos.FindSegmentsFile
Lucene.Net.Index.SegmentMerger
Lucene.Net.Index.SegmentTermDocs ---- Lucene.Net.Index.TermDocs
Lucene.Net.Index.SegmentTermPositions ---- Lucene.Net.Index.TermPositions
Lucene.Net.Index.SegmentTermVector ---- Lucene.Net.Index.TermFreqVector
Lucene.Net.Index.SnapshotDeletionPolicy ---- Lucene.Net.Index.IndexDeletionPolicy
Lucene.Net.Index.Term ---- System.IComparable
Lucene.Net.Index.TermDocs
Lucene.Net.Index.TermEnum
Lucene.Net.Index.FilterIndexReader.FilterTermEnum
Lucene.Net.Index.SegmentTermEnum ---- System.ICloneable
Lucene.Net.Index.TermFreqVector
Lucene.Net.Index.TermInfo
Lucene.Net.Index.TermInfosReader
Lucene.Net.Index.TermInfosWriter
Lucene.Net.Index.TermPositions ---- Lucene.Net.Index.TermDocs
Lucene.Net.Index.TermPositionVector ---- Lucene.Net.Index.TermFreqVector
Lucene.Net.Index.TermVectorEntry
Lucene.Net.Index.TermVectorEntryFreqSortedComparator ---- System.Collections.Generic.IComparer`1[[System.Object, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]
Lucene.Net.Index.TermVectorMapper
Lucene.Net.Index.FieldSortedTermVectorMapper
Lucene.Net.Index.PositionBasedTermVectorMapper
Lucene.Net.Index.SortedTermVectorMapper
Lucene.Net.Index.TermVectorOffsetInfo
Lucene.Net.Index.TermVectorsReader ---- System.ICloneable
Lucene.Net.Index.TermVectorsWriter
Lucene.Net.Store.Directory
Lucene.Net.Index.CompoundFileReader
Lucene.Net.Store.IndexInput ---- System.ICloneable
Lucene.Net.Index.ByteSliceReader
Lucene.Net.Store.BufferedIndexInput
Lucene.Net.Index.CompoundFileReader.CSIndexInput
SupportClass.ThreadClass ---- IThreadRunnable
Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread
System.Collections.ArrayList ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
Lucene.Net.Index.SegmentInfos
System.Exception ---- System.Runtime.Serialization.ISerializable
System.SystemException
Lucene.Net.Index.FieldReaderException
Lucene.Net.Index.MergePolicy.MergeException
System.IO.IOException
Lucene.Net.Index.CorruptIndexException
Lucene.Net.Index.MergePolicy.MergeAbortedException
Lucene.Net.Index.StaleReaderException

See Also

Lucene.Net.Index Namespace


Lucene.Net.QueryParsersHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.QueryParsers Hierarchy

System.Object
Lucene.Net.QueryParsers.CharStream
Lucene.Net.QueryParsers.FastCharStream ---- Lucene.Net.QueryParsers.CharStream
Lucene.Net.QueryParsers.QueryParserConstants
Lucene.Net.QueryParsers.QueryParser
Lucene.Net.QueryParsers.MultiFieldQueryParser
Lucene.Net.QueryParsers.QueryParserTokenManager
Lucene.Net.QueryParsers.Token
Lucene.Net.Util.Parameter ---- System.Runtime.Serialization.IObjectReference
Lucene.Net.QueryParsers.QueryParser.Operator
System.Exception ---- System.Runtime.Serialization.ISerializable
Lucene.Net.QueryParsers.ParseException
System.ApplicationException
Lucene.Net.QueryParsers.TokenMgrError

See Also

Lucene.Net.QueryParsers Namespace


Filter Hierarchy

System.Object
Filter
CachingWrapperFilter
PrefixFilter
QueryWrapperFilter
RangeFilter
RemoteCachingWrapperFilter
SpanFilter

See Also

Filter Class | Filter Members | Lucene.Net.Search Namespace


Lucene.Net.Search.FunctionHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Search.Function Hierarchy

System.Object
Lucene.Net.Search.Function.DocValues
Lucene.Net.Search.Function.FieldScoreQuery.Type
Lucene.Net.Search.Function.ValueSource
Lucene.Net.Search.Function.FieldCacheSource
Lucene.Net.Search.Function.ByteFieldSource
Lucene.Net.Search.Function.FloatFieldSource
Lucene.Net.Search.Function.IntFieldSource
Lucene.Net.Search.Function.ShortFieldSource
Lucene.Net.Search.Function.OrdFieldSource
Lucene.Net.Search.Function.ReverseOrdFieldSource
Lucene.Net.Search.Query ---- System.ICloneable
Lucene.Net.Search.Function.CustomScoreQuery
Lucene.Net.Search.Function.ValueSourceQuery
Lucene.Net.Search.Function.FieldScoreQuery

See Also

Lucene.Net.Search.Function Namespace


Lucene.Net.Search.PayloadsHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Search.Payloads Hierarchy

System.Object
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Search.Scorer
Lucene.Net.Search.Spans.SpanScorer
Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight.BoostingSpanScorer
Lucene.Net.Search.Payloads.PayloadSpanUtil
Lucene.Net.Search.Query ---- System.ICloneable
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanTermQuery
Lucene.Net.Search.Payloads.BoostingTermQuery
Lucene.Net.Search.Spans.SpanWeight ---- Lucene.Net.Search.Weight
Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight

See Also

Lucene.Net.Search.Payloads Namespace


Query Hierarchy

System.Object
Query
BooleanQuery
ConstantScoreQuery
ConstantScoreRangeQuery
DisjunctionMaxQuery
FilteredQuery
CustomScoreQuery
ValueSourceQuery
MatchAllDocsQuery
MultiPhraseQuery
MultiTermQuery
PhraseQuery
PrefixQuery
RangeQuery
SpanQuery
TermQuery

See Also

Query Class | Query Members | Lucene.Net.Search Namespace


Lucene.Net.Search.SpansHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Search.Spans Hierarchy

System.Object
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Search.Scorer
Lucene.Net.Search.Spans.SpanScorer
Lucene.Net.Search.Query ---- System.ICloneable
Lucene.Net.Search.Spans.SpanQuery
Lucene.Net.Search.Spans.SpanFirstQuery
Lucene.Net.Search.Spans.SpanNearQuery
Lucene.Net.Search.Spans.SpanNotQuery
Lucene.Net.Search.Spans.SpanOrQuery
Lucene.Net.Search.Spans.SpanTermQuery
Lucene.Net.Search.Spans.PayloadSpans ---- Lucene.Net.Search.Spans.Spans
Lucene.Net.Search.Spans.Spans
Lucene.Net.Search.Spans.SpanWeight ---- Lucene.Net.Search.Weight
Lucene.Net.Search.Spans.TermSpans ---- Lucene.Net.Search.Spans.PayloadSpans, Lucene.Net.Search.Spans.Spans

See Also

Lucene.Net.Search.Spans Namespace


Lucene.Net.SearchHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Search Hierarchy

System.Object
Lucene.Net.Index.TermEnum
Lucene.Net.Search.FilteredTermEnum
Lucene.Net.Search.FuzzyTermEnum
Lucene.Net.Search.WildcardTermEnum
Lucene.Net.Search.AnonymousClassScoreDocComparator ---- Lucene.Net.Search.ScoreDocComparator
Lucene.Net.Search.AnonymousClassScoreDocComparator1 ---- Lucene.Net.Search.ScoreDocComparator
Lucene.Net.Search.BooleanClause
Lucene.Net.Search.ByteParser
Lucene.Net.Search.ConstantScoreQuery.ConstantWeight ---- Lucene.Net.Search.Weight
Lucene.Net.Search.DocIdSet
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Search.Scorer
Lucene.Net.Search.ConstantScoreQuery.ConstantScorer
Lucene.Net.Search.ReqExclScorer
Lucene.Net.Search.ReqOptSumScorer
Lucene.Net.Search.TermScorer
Lucene.Net.Search.DoubleParser
Lucene.Net.Search.Explanation
Lucene.Net.Search.ComplexExplanation
Lucene.Net.Search.ExtendedFieldCache ---- Lucene.Net.Search.FieldCache
Lucene.Net.Search.ExtendedFieldCacheImpl.AnonymousClassDoubleParser ---- Lucene.Net.Search.DoubleParser
Lucene.Net.Search.ExtendedFieldCacheImpl.AnonymousClassLongParser ---- Lucene.Net.Search.LongParser
Lucene.Net.Search.FieldCache
Lucene.Net.Search.FieldCacheImpl ---- Lucene.Net.Search.FieldCache
Lucene.Net.Search.ExtendedFieldCacheImpl ---- Lucene.Net.Search.ExtendedFieldCache
Lucene.Net.Search.FieldCacheImpl.AnonymousClassByteParser ---- Lucene.Net.Search.ByteParser
Lucene.Net.Search.FieldCacheImpl.AnonymousClassFloatParser ---- Lucene.Net.Search.FloatParser
Lucene.Net.Search.FieldCacheImpl.AnonymousClassIntParser ---- Lucene.Net.Search.IntParser
Lucene.Net.Search.FieldCacheImpl.AnonymousClassShortParser ---- Lucene.Net.Search.ShortParser
Lucene.Net.Search.Filter
Lucene.Net.Search.CachingWrapperFilter
Lucene.Net.Search.QueryFilter
Lucene.Net.Search.PrefixFilter
Lucene.Net.Search.QueryWrapperFilter
Lucene.Net.Search.RangeFilter
Lucene.Net.Search.RemoteCachingWrapperFilter
Lucene.Net.Search.SpanFilter
Lucene.Net.Search.CachingSpanFilter
Lucene.Net.Search.SpanQueryFilter
Lucene.Net.Search.FilterManager
Lucene.Net.Search.FilterManager.FilterCleaner ---- IThreadRunnable
Lucene.Net.Search.FilterManager.FilterItem
Lucene.Net.Search.FloatParser
Lucene.Net.Search.FuzzyQuery.ScoreTerm
Lucene.Net.Search.Hit
Lucene.Net.Search.HitCollector
Lucene.Net.Search.TimeLimitedCollector
Lucene.Net.Search.TopDocCollector
Lucene.Net.Search.TopFieldDocCollector
Lucene.Net.Search.HitIterator ---- System.Collections.IEnumerator
Lucene.Net.Search.Hits
Lucene.Net.Search.IntParser
Lucene.Net.Search.LongParser
Lucene.Net.Search.Query ---- System.ICloneable
Lucene.Net.Search.BooleanQuery
Lucene.Net.Search.ConstantScoreQuery
Lucene.Net.Search.ConstantScoreRangeQuery
Lucene.Net.Search.DisjunctionMaxQuery
Lucene.Net.Search.FilteredQuery
Lucene.Net.Search.MatchAllDocsQuery
Lucene.Net.Search.MultiPhraseQuery
Lucene.Net.Search.MultiTermQuery
Lucene.Net.Search.FuzzyQuery
Lucene.Net.Search.WildcardQuery
Lucene.Net.Search.PhraseQuery
Lucene.Net.Search.PrefixQuery
Lucene.Net.Search.RangeQuery
Lucene.Net.Search.TermQuery
Lucene.Net.Search.QueryTermVector ---- Lucene.Net.Index.TermFreqVector
Lucene.Net.Search.ScoreDoc
Lucene.Net.Search.FieldDoc
Lucene.Net.Search.ScoreDocComparator
Lucene.Net.Search.Searchable
Lucene.Net.Search.Searcher ---- Lucene.Net.Search.Searchable
Lucene.Net.Search.IndexSearcher
Lucene.Net.Search.MultiSearcher
Lucene.Net.Search.ParallelMultiSearcher
Lucene.Net.Search.ShortParser
Lucene.Net.Search.Similarity
Lucene.Net.Search.DefaultSimilarity
Lucene.Net.Search.SimilarityDelegator
Lucene.Net.Search.Sort
Lucene.Net.Search.SortComparator ---- Lucene.Net.Search.SortComparatorSource
Lucene.Net.Search.SortComparatorSource
Lucene.Net.Search.SortField
Lucene.Net.Search.SpanFilterResult
Lucene.Net.Search.SpanFilterResult.PositionInfo
Lucene.Net.Search.SpanFilterResult.StartEnd
Lucene.Net.Search.StringIndex
Lucene.Net.Search.TopDocs
Lucene.Net.Search.TopFieldDocs
Lucene.Net.Search.Weight
Lucene.Net.Util.Parameter ---- System.Runtime.Serialization.IObjectReference
Lucene.Net.Search.BooleanClause.Occur
Lucene.Net.Util.PriorityQueue
Lucene.Net.Search.FieldSortedHitQueue
Lucene.Net.Search.FuzzyQuery.ScoreTermQueue
System.Exception ---- System.Runtime.Serialization.ISerializable
Lucene.Net.Search.TimeLimitedCollector.TimeExceededException
System.SystemException
Lucene.Net.Search.BooleanQuery.TooManyClauses
System.MarshalByRefObject
Lucene.Net.Search.RemoteSearchable ---- Lucene.Net.Search.Searchable
System.ValueType
Lucene.Net.Search.ExtendedFieldCache_Fields
Lucene.Net.Search.FieldCache_Fields
Lucene.Net.Search.ScoreDocComparator_Fields

See Also

Lucene.Net.Search Namespace


Lucene.Net.StoreHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Store Hierarchy

System.Object
Lucene.Net.Store.Directory
Lucene.Net.Store.FSDirectory
Lucene.Net.Store.MMapDirectory
Lucene.Net.Store.RAMDirectory
Lucene.Net.Store.IndexInput ---- System.ICloneable
Lucene.Net.Store.BufferedIndexInput
Lucene.Net.Store.FSDirectory.FSIndexInput
Lucene.Net.Store.ChecksumIndexInput
Lucene.Net.Store.RAMInputStream
Lucene.Net.Store.IndexOutput
Lucene.Net.Store.BufferedIndexOutput
Lucene.Net.Store.FSDirectory.FSIndexOutput
Lucene.Net.Store.ChecksumIndexOutput
Lucene.Net.Store.RAMOutputStream
Lucene.Net.Store.Lock
Lucene.Net.Store.Lock.With
Lucene.Net.Store.LockFactory
Lucene.Net.Store.NativeFSLockFactory
Lucene.Net.Store.NoLockFactory
Lucene.Net.Store.SimpleFSLockFactory
Lucene.Net.Store.SingleInstanceLockFactory
Lucene.Net.Store.VerifyingLockFactory
Lucene.Net.Store.LockStressTest
Lucene.Net.Store.LockVerifyServer
Lucene.Net.Store.RAMFile
System.Exception ---- System.Runtime.Serialization.ISerializable
System.SystemException
Lucene.Net.Store.AlreadyClosedException
System.IO.IOException
Lucene.Net.Store.LockObtainFailedException
Lucene.Net.Store.LockReleaseFailedException
System.IO.BinaryReader ---- System.IDisposable
Lucene.Net.Store.FSDirectory.FSIndexInput.Descriptor

See Also

Lucene.Net.Store Namespace


Lucene.Net.Util.CacheHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Util.Cache Hierarchy

System.Object
Lucene.Net.Util.Cache.Cache
Lucene.Net.Util.Cache.Cache.SynchronizedCache
Lucene.Net.Util.Cache.SimpleLRUCache_LUCENENET_190_1
Lucene.Net.Util.Cache.SimpleLRUCache
Lucene.Net.Util.Cache.SimpleLRUCache_LUCENENET_190_2
Lucene.Net.Util.Cache.SimpleMapCache
Lucene.Net.Util.Cache.SimpleLRUCache_OrgPort

See Also

Lucene.Net.Util.Cache Namespace


Lucene.Net.UtilHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net.Util Hierarchy

System.Object
Lucene.Net.Search.DocIdSet
Lucene.Net.Util.DocIdBitSet
Lucene.Net.Util.OpenBitSet ---- System.ICloneable
Lucene.Net.Util.OpenBitSetDISI
Lucene.Net.Util.SortedVIntList
Lucene.Net.Search.DocIdSetIterator
Lucene.Net.Util.OpenBitSetIterator
Lucene.Net.Util.ArrayUtil
Lucene.Net.Util.BitUtil
Lucene.Net.Util.BitVector
Lucene.Net.Util.CloseableThreadLocal
Lucene.Net.Util.Constants
Lucene.Net.Util.Parameter ---- System.Runtime.Serialization.IObjectReference
Lucene.Net.Util.PriorityQueue
Lucene.Net.Util.ScorerDocQueue
Lucene.Net.Util.SmallFloat
Lucene.Net.Util.StringHelper
Lucene.Net.Util.ToStringUtils
Lucene.Net.Util.UnicodeUtil
Lucene.Net.Util.UnicodeUtil.UTF16Result
Lucene.Net.Util.UnicodeUtil.UTF8Result

See Also

Lucene.Net.Util Namespace


Lucene.NetHierarchy

Apache Lucene.Net 2.4.0 Class Library API

Lucene.Net Hierarchy

System.Object
Lucene.Net.LucenePackage

See Also

Lucene.Net Namespace