
Iniţiere

Capitolul 1111
Iniţiere în Math:

Editorul de ecuaţii al OpenOffice.org
     

OpenOffice.org



Copyright
Acest document este Copyright © 2005 de către contributorii menţionaţi în secţiunea Autori. 
Poate fi distribuit şi/sau modificat în conformitate cu prevederile licenţei GNU General Public 
License, versiunea a 2-a sau ulterioară (http://www.gnu.org/licenses/gpl.html) ori în 
conformitate cu prevederile licenţei Creative Commons Attribution License, versiunea 2.0 sau 
ulterioară (http://creativecommons.org/licenses/by/2.0/).

Toate mărcile înregistare menţionate în acest ghid aparţin proprietarilor de drept.

Autori
Agnes Belzunce
Daniel Carrera
Ian Laurenson 
Janet M. Swisher
Jean Hollis Weber
Peter Kupfer
Amăriuţei Gheorghe (traducerea în limba română)

P rerea dumneavoastră ă
Responsabil: Daniel Carrera
Vă rugăm să trimiteţi comentariile sau sugestiile dumneavoastră despre acest document la:
authors@user-faq.openoffice.org

Mul umiriţ
Acest capitol este extras din capitolul “Math Objects: The OpenOffice.org Equation Editor” 
din Ghidul Writer.

Data public rii şi versiunea programuluiă
Publicat la 9 aprilie 2005. Bazat pe OpenOffice.org 2.0. Tradus la 16 iulie 2005.

 Pute i g si o versiune editabil  a acestui document la adresaţ ă ă  
http://oooauthors.org/en/authors/userguide2/published/

mailto:authors@user-faq.openoffice.org
http://creativecommons.org/licenses/by/2.0/
http://www.gnu.org/licenses/gpl.html
http://oooauthors.org/en/authors/userguide2/published/


CIORN  – bazat  pe software nefinalizatĂ ă Cuprins

Cuprins

Copyright........................................................................................................................................i

Autori..............................................................................................................................................i

Părerea dumneavoastră...................................................................................................................i

Mulţumiri........................................................................................................................................i

Data publicării şi versiunea programului........................................................................................i

Introducere..........................................................................................................................................1

Să începem.....................................................................................................................................1

Introducerea unei formule...................................................................................................................2

Fereastra Selecţie...........................................................................................................................2

Exemplul 1:....................................................................................................................................3

Meniul contextual..........................................................................................................................4

Markup...........................................................................................................................................5

Caracterele greceşti........................................................................................................................5

Exemplul 2:....................................................................................................................................6

Personalizări.......................................................................................................................................7

Editorul de formule ca fereastră separată.......................................................................................7

Cum pot să măresc formula?..........................................................................................................8

Aspectul formulei...............................................................................................................................9

Folosiţi paranteze...........................................................................................................................9

Ecuaţii pe mai multe rânduri..........................................................................................................9

Întrebări frecvente.............................................................................................................................11

Cum adaug domenii pentru sumă/integrală?................................................................................11

Parantezele pentru matrice arată oribil!.......................................................................................11

Cum scriu derivatele?..................................................................................................................12

Numerotarea ecuaţiilor.................................................................................................................12

Ini iere în Mathţ i





CIORN  – bazat  pe software nefinalizatĂ ă Introducere

Introducere

OpenOffice.org (OOo) vă oferă o componentă pentru scrierea ecuaţiilor matematice, 
OOoMath. Este folosită de obicei pentru editarea ecuaţiilor din documentele text, dar poate fi 
utilizată şi în cadrul altor aplicaţii sau în mod separat. Când este utilizată cadrul Writer-ului 
ecuaţiile sunt gestionate ca obiecte incluse în documentul text.

Notă Editorul de ecuaţii este utilizat doar pentru scrierea ecuaţiilor în forma specifică (după 
cum se vede în ecuaţia 1 de mai jos). Dacă doriţi să evaluaţi o expresie matematică vă 
rugăm să citiţi ghidul pentru Calc.

df  x
dx

=ln  xtan−1 x2  
(1)

S  începemă
Pentru a insera o ecuaţie, mergeţi la Inserare > Obiect > Formulă (Insert > Object > 
Formula).

Editorul de ecuaţii deschide o zonă în partea de jos a ecranului şi o fereastră separată apare pe 
ecran. De asemenea, veţi observa şi un mic dreptunghi (cu margini gri) în documentul 
dumneavoastră; este locul unde formula va fi afişată.

Imaginea 1. Editorul de ecuaţii, fereastra Selecţie ("Selection"), şi locul unde se va afişa formula.
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Editorul de ecuaţii foloseşte un limbaj de tip markup pentru a reprezenta formulele. De 
exemplu, %beta reprezintă caracterul grecesc beta (  ). Acest limbaj este conceput să semene 
cu limba engleză cât mai mult posibil. De exemplu,  a over b (a supra b) reprezintă o fracţie: 
a
b

.

Introducerea unei formule

Sunt trei metode de a introduce o formulă:

• Selectaţi simbolul formulei din fereastra Selecţie ("Selection").

• Daţi clic - dreapta în editorul de ecuaţii şi selectaţi simbolul formulei din meniul apărut.

• Tastaţi "markup" în editorul de ecuaţii.

Meniul şi fereastra Selecţie inserează markup-ul corespunzător simbolului formulei. Astfel, 
puteţi să învăţaţi mai uşor limbajul markup pentru OOoMath.

Notă Daţi clic pe textul documentului pentru a iesi din editorul de ecuaţii.

Daţi dublu - clic pe o formulă pentru a o edita.

Fereastra Selec ieţ
Cea mai simplă metodă pentru a introduce o formulă este fereastra Selecţie, arătată în Imaginea
2.

Imaginea 2. Simbolurile sunt împărţite în categorii.

Fereastra Selecţie este împărţită în două categorii principale.

• Partea de sus grupează categoriile de simboluri. Daţi clic pe acestea pentru a schimba 
lista simbolurilor.
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• Partea de jos arată lista simbolurilor disponibile în categoria curentă.

PONT Puteţi să afişaţi sau să ascundeţi fereastra Selecţie cu Vizualizare > Selecţie (View > 
Selection).

Exemplul 1: 5×4

Pentru acest exemplu vom introduce o formulă simplă: 5×4 cu ajutorul fereastrei Selecţie:

1) Selectaţi dintre categorii butonul grafic din stânga-sus (Imaginea 3).

2) Daţi clic pe simbolul înmulţirii (ca în Imaginea 3).

Imaginea 3. Operatori unari/binari.

Când selectaţi simbolul înmulţirii în fereastra Selecţie se petrec două lucruri:

• Editorul de ecuaţii arată markup-ul: <?> times <?>

• În textul documentului apare un dreptunghi gri cu imaginea: ×

Imaginea 4. Simbolul pentru înmulţire.

Simbolurile de genul “ <?> ” (Imaginea 4) sunt locurile în care veti scrie text. Ecuaţia va fi 
actualizata în mod automat, iar rezultatul va fi cel din Imaginea 5.
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Imaginea 5. Rezultatul introducerii lui "5" şi "4" de o parte şi de alta 
a operatorului "times" ("înmulţire").

PONT Pentru ca ecuaţia să nu mai fie actualizată automat, selectaţi Vizualizare > 
AutoActualizează ecranul (View >AutoUpdate display). 

Pentru a actualiza manual o formulă, apăsaţi F9 sau selectaţi Vizualizare > 
Actualizare (View > Update).

Meniul contextual
Altă metodă pentru accesarea simbolurilor matematice este să daţi clic - dreapta pe editorul de 
ecuaţii. Aceasta va conduce la apariţia unui meniu ca cel din Imaginea 6.

Imaginea 6. Meniul contextual.

Notă Opţiunile din acest meniu corespund exact cu cele arătate în fereastra Selecţie.
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Markup
Puteţi introduce direct în editorul de ecuatii limbaj markup. De exemplu, dacă tastaţi “5 times 
4” obţineti 5×4 . Dacă veţi învăţa limbajul markup, aceasta va fi cea mai rapidă metodă de a 
introduce o formulă.

PONT Pentru a va reaminti mai uşor, reprezentarea formulei în limbajul markup aminteşte de 
cum sună citirea formulei în engleză.

Mai jos este o scurtă listă de ecuaţii des întâlnite şi reprezentările corespunzătoare.

Formula Comanda Formula Comanda

a=b a = b a sqrt {a}

a2 a^2 an a_n

∫ f x dx int f(x) dx ∑ an
sum a_n

a≤b a <= b ∞ infinity

a×b a times b x⋅y x cdot y

Caracterele greceşti

Caracterele greceşti (  , , , , etc) sunt des întâlnite în formule matematice. Aceste 
caractere nu se găsesc în fereastra Selecţie sau în meniul contextual. Astfel încât va trebui să 
învăţaţi reprezentarea lor textuală, care din fericire este destul de simplă: Tastaţi semnul % 
urmat de numele literei pe care o doriţi, dar în engleză.

• Pentru a introduce o minusculă, scrieţi numele caracterului cu minuscule.

• Pentru a introduce o majusculă, scrieţi numele caracterului cu minuscule.

Iată şi câteva exemple:

Minuscule Majuscule

%alpha   %ALPHA  A

%beta   %BETA  B

%gamma   %GAMMA  

%psi    %PSI   

%phi    %PHI   

%theta   %THETA  

Notă Tabelul cu toate caracterele alfabetului grecesc este inclus în capitolul intitulat 
"Obiecte matematice" (“Math Objects”) din Ghidul Writer.
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Altă modalitate de a insera caractere greceşti este de a folosi fereastra Catalog. Alegeţi Unelte 
> Catalog (Tools > Catalog). Fereastra catalog este arătată în Imaginea 7. Sub Setul de 
simboluri (“Symbol Set”) selectaţi "Grecesc" (“Greek”) şi daţi dublu - clic pe o literă 
grecească din listă.

Imaginea 7. Catalog - utilizată pentru introducerea caracterelor greceşti.

Exemplul 2:  ≃ 3.14159

Pentru acest exemplu vom presupune că:

• Vrem să introducem formula de mai sus (valoarea lui PI rotunjită la 5 zecimale).

• Ştim numele caracterului grecesc (“pi”).

• Dar nu ştim cuvântul din limbajul markup pentru simbolul ≃ .

Pasul 1: Tastaţi “%” urmat de textul “pi”. Va apare simbolul  .

Pasul 2: Deschideţi fereastra Selecţie (Vizualizare > Selecţie "View > Selection").

Pasul 3: Simbolul ≃  denotă o relaţie, aşa că vom apăsa pe butonul grafic pentru relaţii . 
Dacă ţineti mausul deasupra acestui buton (şi aveţi ponturile activate) va apare indicaţia despre 
categoria butonului, "Relaţii" “Relations” (Imaginea 8).

Imaginea 8. Pontul indică butonul grafic "Relaţii" ("Relations").
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Pasul 4: Ştergeţi textul <?> şi adăugaţi “3.14159” la sfârşitul ecuaţiei.  Aici vedem în fereastra 
editorului de ecuaţii “ %pi simeq 3.14159 ”, ca în Imaginea 9.

Imaginea 9. Rezultatul final.

Personaliz riă

Editorul de formule ca fereastr  separată ă
După cum se vede în Imaginea 1, editorul de formule poate acoperi o parte semnificativă a 
ferestrei de editare a Writer-ului. Pentru a transforma editorul de formule într-o fereastră 
separată procedaţi astfel:

1) Ţineţi mausul deasupra marginii ferestrei editorului de formule, ca în Imaginea 10.

2) Ţineti apăsată tasta Control şi daţi dublu - clic.

Imaginea  10.  Ţineti  apăsată  tasta  Control şi  daţi  dublu  -  clic  pe  
marginea editorului de formule matematice pentru a-l transforma într-o  
fereastră separată.

Imaginea 11 arată rezultatul. Puteţi (re)doca fereastra folisnd aceiaşi paşi. Ţineţi apăsată tasta 
Control şi daţi dublu - clic  key deasupra marginii ferestrei.
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Imaginea 11. Editorul de ecuaţii în fereastră separată.

Cum pot s  ă m rescă  formula?

Aceasta face parte dintre întrebările cele mai des repetate de către utilizatorii OOoMath. 
Răspunsul este simplu, dar nu intuitiv:

1) Porniţi editorul de formule şi alegeţi Fonturi > Mărimea fontului (Fonts > Font size).

Imaginea 12. Schimbarea  mărimii fontului a unei formule.

2) Selectaţi o mărime de font mai mare de la "Mărimea de bază" (“Base Size”) (câmpul cel 
mai de sus), ca în Imaginea 13.
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Imaginea 13. Editaţi "Base size" (sus) pentru a mări formula.

Rezultatul este arătat în Imaginea 14.

Imaginea 14. Resultatul schimbării mărimii fontului de bază.

Aspectul formulei

Cea mai dificilă parte a utilizării OOoMath vine atunci când scrieţi ecuaţii complicate. Această 
secţiune vă oferă câteva sfaturi despre scrierea formulelor complexe.

Folosi i parantezeţ
OOoMath nu "ştie" nimic despre ordinea operaţiilor (vă reamintesc că OOoMath este pentru a 
reprezenta formule, nu pentru a le calcula!). Trebuie să folosiţi paranteze pentru a stabili 
explicit ordinea operaţiilor. De exemplu:

Expresie markup Rezultat

2 over  x + 1 2
x
1

2 over {x + 1} 2
x1

Ecua ii pe mai multe rânduriţ

Să presupunem ca doriţi să tastaţi o ecuaţie scrisă pe mai multe rânduri. De exemplu:
x=3
y=1
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Prima dumneavoastra reacţie ar fi să apăsaţi pur şi simplu Enter. Totuşi, veţi observa că atunci 
când apăsaţi Enter expresia markup trece pe linia următoare, însă nu şi ecuaţia. Va trebui să 
tastaţi explicit comanda pentru o linie nouă. Aceasta este arătată în tabelul de mai jos (newline 
se traduce prin linie nouă).

Expresie markup Rezultat

x = 3

y = 1

x=3 y=1

x = 3 newline

y = 1

x=3
y=1
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Întreb ri frecventeă

Cum adaug domenii pentru sum /integral ?ă ă
Comenzilor “sum” and “int” li se pot specifica (opţional) parametrii “from” şi “to”. Acesţia 
sunt utilizaţi pentru începutul şi sfârşitul domeniului. Aceşti parametri pot fi folosiţi câte unul 
sau împreună.

Expresie markup Rezultat

sum from k = 1 to n a_k
∑
k=1

n

ak

int from 0 to x f(t) dt

∫
0

x

f  t dt

int from Re f ∫
ℜ

f

sum to infinity 2^{-n} ∑
∞

2−n

Notă Pentru mai multe detalii despre integrale şi sume, citiţi capitolul "Obiecte 
matematice" (“Math Objects”) din Ghidul Writer.

Parantezele pentru matrice arat  oribil!ă
Pentru început, să vedem sintaxa comenzii pentru matrici:

Expresie markup Rezultat

matrix { a # b ## c # d } a b
c d

Notă Rândurile sunt separate de două caractere # şi conţinutul fiecărui element este separat 
printr-un singur #.

Prima problemă este că parantezele obişnuite nu "acoperă" toată matricea:

Expresie markup Rezultat

(  matrix { a # b ## c # d }  ) 
a b
c d


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OOoMath oferă paranteze "scalabile". Aceasta înseamnă că aceste paranteze cresc o data cu 
conţinutul matricei. Folosiţi comenzile left( and right) (stânga şi dreapta) pentru a introduce 
paranteze scalabile.

Expresie markup Rezultat

left(  matrix { a # b ## c # d }  right) a b
c d 

PONT Folosiţi left[ şi right] pentru paranteze scalabile pătrate.

Cum scriu derivatele?
Scrierea derivatelor se face folosind un truc: Le scrieţi ca pe o fracţie.

Cu alte cuvinte, va trebui să folosiţi comanda “over”. Combinaţi aceasta fie cu litera “d” 
(pentru o derivare integrală) sau comanda “partial” (pentru o derivare parţială) pentru a obţine 
aspectul unei derivate.

Expresie markup Rezultat

{df} over {dx} df
dx

{partial f} over {partial y} ∂ f
∂ y

{partial^2 f} over {partial t^2} ∂2 f

∂t 2

Notă Observaţi că a trebuit să folosim acolade pentru a scrie derivata.

Numerotarea ecua iilorţ
Numerotarea ecuaţiilor este una dintre facilităţile obscure ale OOoMath. Paşii de urmat sunt 
simpli, dar neintuitivi:

1) Treceţi pe o linie nouă.

2) Tastaţi “fn” şi apoi apăsaţi F3.

Cuvântul “fn” este înlocuit de o formulă numerotată:

E=mc2  (2)

Acum puteţi da dublu - clic pe formulă pentru a o edita. De exemplu, mai jos este funcţia 
Riemann Zeta:
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 z =∑
n=1

∞ 1

nz
 (3)

Puteţi să faceţi o referire la o ecuaţie (“după cum puteţi oberva în ecuaţia (2)”) urmând aceşti 
paşi:

1) Inserare > Referinţă (Insert > Cross-reference).

2) Daţi clic pe categoria Referinţe (References tab) (Imaginea 15).

3) Sub Tip (Type), selectaţi Text.

4) Sub Selecţie (Selection), alegeţi numărul ecuaţiei.

5) Sub Format, alegeţi Referinţă (Reference).

6) Apăsaţi Inserează (Insert).

Gata! Dacă mai târziu veţi adăuga ecuaţii în document înaintea ecuaţiei referite, toate ecuaţiile 
vor fi în mod automat renumerotate iar referinţele actualizate, astfel încât să indice ecuaţiile 
iniţiale.

Imaginea 15. Inserarea unei referinţe către o ecuaţie numerotată.

PONT Pentru a insera numărul ecuaţiei fără paranteze, alegeţi Numerotare (Numbering) 
sub Format în loc de Referinţă (Reference).
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