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Introducere

Acest capitol descrie cum sd salvati documente sub forma de pagini Web din Writer, Calc,
Draw si Impress. Pentru mai multe detalii despre cum sa folositi Writer pentru compunere $i
editare de pagini web consultati Ghidul Writer (Writer Guide).

Salvarea documentelor Writer ca pagini web

Facilitatile HTML din Writer includ salvarea documentelor deja existente in formatul HTML,
crearea de documente noi 1n acest format si crearea mai multor tipuri de pagini web folosind un
vrajitor.

Cel mai usor mod de a crea documente HTML este de a incepe cu un document Writer

existent. Puteti sa previzualizati cum va ardta ca pagind web folosind Vizualizare > Aspect
Web (View > Web Layout).

Inserarea hiperlegaturilor
Puteti insera si modifica legéturi folosind dialogul Hiperlegatura. Afisati dialogul apasénd pe

butonul grafic Hiperlegatura (Hyperlink) & | de pe panoul Functii sau alegeti Inserare >

Hiperlegatura (Insert > Hyperlink). Scrierea sau lipirea unei URL intr-un document va fi
convertitd Tn mod automat in hiperlegatura, in functie de setérile de
AutoCorectie/AutoFormatare (AutoCorrect/AutoFormat).

Pentru a edita o legatura existenta:

S

1) Fie mutati cursorul in legédtura folosind tastele sdgeti, sau comutati din “HYP” in “SEL”
in bara de statut (Status Bar) (apasand pe literele HYP sau SEL 1 bara de statut, vedeti
Imaginea 1) si folositi mausul pentru a pozitiona cursorul.

100% | | INSRT || 5TD | HYP | *

HY P sau SEL

Imaginea 1: Bara de statut din Writer.

Nota Daca bara de statut indicd HYP si veti da clic stanga pe o legatura, OOo va Incerca sa
deschida adresa in browserul web indicat la setari. Va trebui sa se indice SEL in bara
de statut pentru a putea sa apasati pe o legatura pozitionand cursorul.

2) Apasati Editare > Hiperlegatura (Edit > Hyperlink). Dialogul Hiperlegatura
(Hyperlink) (Imaginea 2) se deschide.

3) Din dialogul Hiperlegatura puteti alege tipul legaturii, puteti sa specificati adresa, textul
asociat si cum sa fie afisatd (de exemplu, intr-o fereastra noud).
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Hyperlink

i_W Hyperlink bype

Iﬁ (5) Web O ETP ) Telnet

Inkternet Target ™

Frarme | % || Faorm Text :V:;'
Text http: f foonaukhors, orgf
Mame
Mew Docurment
[ Apply ] [ Clase l [ Help ] [ Back, l

Imaginea 2: Dialogul Hiperlegatura (Hyperlink).

Pentru a transforma textul existent intr-o legaturd, selectati-1, apoi deschideti dialogul
Hiperlegatura. Apasati Aplica (Apply) pentru a insera legatura in document Tnainte de a-1
inchide.

Nota Referintele nu devin hiperlegéturi intr-un document HTML.

Salvarea unui document ca o singura pagina Web

Pentru a salva un document ca o singura pagind Web (in format HTML), selectati Salveaza ca
(Save As) din meniul Fisier si specificati HTML Document ca tip de fisier.

Nota Writer nu inlocuieste spatiile multiple din fisierul original cu cod HTML pentru spatii
neintrerupte ("non-breaking'"). Daca doriti sd pastrati spatiile suplimentare 1n fisierul
HTML sau pagina web va trebui sa inserati spatii neintrerupte iIn OOo. Pentru aceasta,
apasati tastele Control+Space(bar) in loc de Space(bar).

Salvarea documentului ca o serie de pagini Web

Writer poate salva un document mare ca o serie de pagini Web (fisiere HTML) cu o pagina pe
rolul de Cuprins. Pentru a face aceasta:

1) Decideti care dintre paragrafe vor Incepe pe o pagind noua si atribuiti titlurilor
respective acelasi stil (de exemplu, Heading 1).

2) Selectati Fisier > Trimite (File > Send) si apasati pe Creazd document HTML
(Create HTML Document).

3) In dialog (Imaginea 3), introduceti numele fisierului sub care doriti sa salvati paginile.
Specificati si stilul care indica o pagind noud (si pe care l-ati ales la pasul 1).

Crearea paginilor Web 2
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Salvarea documentelor Writer ca

pagini web

4) Apasati Salveaza (Save) pentru a crea un document HTML multi-pagina. (Pentru cei
interesati, fisierele HTML generate respecta standardul HTML 4 Transitional.)

=

Hame and Path of the HTML Document

ax]

ty Becent
Documents

&

Dezktop

W
dy Metwork,
Flaces

Save in: 1 [ 001.9.100 testdocs

[~

= l:_mi;g ,

@] wehbpage.html

File name:
Save as type:

Styles:

]webpage2

jHTML Document

jHeading 1

[]
[]
[ |

Default
Figure

Heading 1

Save ]
Cancel

Imaginea 3: Crearea unei serii de pagini Web dintr-un singur document.
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Crearea paginilor Web folosind Vrajitorul

Vrajitorul Web din OOo va permite sd creati cateva tipuri standard de pagini Web. Pentru a-1
utiliza:

1) Selectati Fisier > Vrajitori > Pagina Web (File > Wizards > Web Page). Acest
vrajitor arata ca in Imaginea 4.

Web Wizard X

Steps Introduction

1. Introduction | This "Weh Wizard is ta aid vou in publishing documents on the Inkernet,

2. Documnents It will conwert the documents so that they can be viewed by a web browser, In addition, it
will generate a Table of Contents page with links For easy access to the documents, The
‘eb Wizard will also allow wou to customize the design and layout of wour web site,

‘fou will be able to keep the documents you have published on the web up-to-date and add
or remove documents at any kime.,

Choose setkings For the Web Wizard

<default = w |

Imaginea 4. Pasul 1 din Vrajitorul de pagini Web.

Nota Daca este prima dumneavoastra pagind Web singura optiune pentru vrajitor este
Obisnuit (Default). Apasati Urmatorul (Next).

2) Alegeti sau rasfoiti pentru a gasi documentul pe care doriti s il formatati si adaugati
informatiile privind 7itlul (Title), Descrierea (Summary) si Aut(h)orul, dupa cum se
vede 1n Imaginea 5. Apasati Urmatorul (Next).

Crearea paginilor Web 4



CIORNA - bazati pe software nefinalizat Salvarea documentelor Writer ca

pagini web
x s |
Web Wizard |£|
Steps | select the documents you want to publish
1. Introduction Web site content Export ko file Formnat:
limdaw bkl Original File Farmak W

', Documents

3. Main layout
Dacurnent information -
4, Layout details ;
Title:
5. Style lindas. html
6. Web site information Summary
7. Preview
Buthor:

[ add, ] [ Remaove ] | |

Imaginea 5: Pasul al doilea din Vrdjitorul de pagini Web.

3) Alegeti un aspect pentru websit apasand pe una dintre pictogramele exemplificative din
Imaginea 6. Apasati Urmatorul (Next).

] r
Web Wizard %]
Steps | Choose alayout for the table of contents of your web site
1. Introduction Layouts:
- =
2, Doacuments | |
0= 0= o= o= o= o=
3. Main lzyout 0= 0= 0= o= o= =
0= 0= 0= o= o=
4, Layout details — =
o= o= 0= 0= 0=
= o=
5. Style 2 a% -
. Web site information 1= i= e
7. Preview
| Simple

Imaginea 6. Pasul 3 din Vrajitorul de pagini Web.
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Salvarea documentelor Writer ca
pagini web

4) Alegeti informatiile care doriti sd fie listate si rezolutia ecranului, ca in Imaginea 7.

Apasati Urmatorul (Next).

Web Wizard

Steps | Customize the selected layout

1. Inkroduction

. Documents

Inchude the Following information For each docurnent in the table of contents:

I

] File Format
File Format icon

[ ] Mumber of pages
Size in KB

. [] Eile name

3. Main layout Diescription

. Layout details [ Awthor
[ creation date

5. Style [] Last change date

6. ‘Web site information

G om il Cptimize the layout For screen resolution:
) 640x4a0
(%) 800x600
() 1024%768

[ ces ([

Cancel

Imaginea 7: Pasul 4 din Vrdjitorul de pagini Web.

5) Selectati un stil pentru pagina. Folositi lista derulanta, ardtata in Imaginea 8, pentru a
selecta dintre stilurile si combinatiile coloristice prezentate. Puteti cauta o imagine de
fundal s1 un set de pictograme din Galerie. Apasati Urmatorul (Next).

Web Wizard
Steps | Select a style for the table of contents page
1. Introduction Skyle:
2. Documents Background image: -<no background image >
3. Main layout i .
Icon sek: <no icon sekx
4, Layout details :

The icon set is used for presentations in HTML Format,

Web sike information

Preview

Document
Creation Date
Last Change Date
Filename

[ I

< Back Mext =

Cancel

Imaginea 8: Pasul 5 din Vrajitorul de pagini Web.
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Salvarea documentelor Writer ca
pagini web

6) Introduceti informatii generale ca Titlu (Title) si informatii metadata in dialogul din
Imaginea 9. Apdsati Urmatorul (Next).

Web Wizard

Steps

1.

Inkroduction
Dacuments
Iain layout
Layout details

Shyle

5. Web site information

Prewview

| Enter general information for your web site

I

Title: | Test Website

HTML Metadata

Description: | Tesk Data

E-mail; |

Copyright notice: |

Created: 052605 =]
Modified: osizejs x|
[ < Back ] [ Mext =

Cancel

Imaginea 9: Pasul 6 din Vrdjitorul de pagini Web.

7) Alegeti unde sa salvati fisierul si puteti sa previzualizati pagina daca doriti, aga cum se
vede in Imaginea 10.

Web Wizard

Steps

1.

Introduction
Docurments
Iain layout
Lavout details

Skyle

Web sibe information

| Where do you want to publish your web site?

Click 'Preview’ to see a preview in your browser: -

Preview

Fublish the new web site; -
To a local Folder

| L]

[] 1o a ZIP archive

| L]

Tz carver via FTR

Publishing wia FTP Proxy is not supported.

Save settings (recommended)

Save 3s: [ ieh YWizard Setkings1 w |

Cancel

Imaginea 10: Pasul 7 din Vrajitorul de pagini Web.
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Pentru a edita sau a vizualiza codul HTML generat 1n fisier apasati Vizualizare > Sursa
HTML (View > HTML-Source) sau apasati pe butonul grafic HTML Source de pe
panoul cu unelte principal (Main toolbar).

Salvarea foilor de calcul Calc ca pagini Web

Calc poate salva fisierele ca documente HTML. Ca si pentru Writer, folositi Fisier > Salveaza
ca (File > Save As) si selectatt HTML Document, sau Fisier > Vrajitori > Pagina Web (File
> Wizards > Web Page).

Daca fisierul contine mai mult de o singura foaie, foile suplimentare vor urma una dupa alta in
fisierul HTML. Legaturi catre fiecare foaie vor fi introduse la inceputul documentului HTML.
Calc va permite de asemenea inserarea de legaturi direct in foile de calcul folosind dialogul
Hiperlegatura (Hyperlink).

Salvarea prezentarilor Impress ca pagini

WebSalvarea-documentelor Praw-ca pagini-
Web

Puteti sd exportati prezentdriledesenete ca fisiere Macromedia Flash : selectati Fisier > Export
(File > Export) si alegeti Macromedia Flash ca tip de fisier.

Puteti de asemenea sa convertiti prezentariledesenrete intr-o serie de pagini Web:
1) Fisier (File) > Export > selectati HTML Document ca tip de fisier.
2) Alegeti destinatia pentru fisier, furnizati un nume pentru figierul HTML care va rezulta,
si apasati Salveaza (Save).
3) In fereastra HTML Export, selectati daci s# folositi un design deja existent pentru
paginile web sau daeé-sé creati unul nou.

4) Apasati Urmaétorul (Next) pentru a selecta tipul de pagini web care sa fie create.
Tipurile disponibile sunt format Standard HTML, Standard HTML cu cadre, Automatic,
si WebCast. EsteExistd st o optiune pentru a crea o pagina de titlu pentru prezentare si o
alta pentru a afisa notitele aferente fiecarui cadru impreund cu cadrul respectiv.

- Standard HTML va genera o serie de pagini, fiecare contindnd un cadru. Sunt
disponibile legaturi pentru a naviga de la un cadru la altul.

- Automatic genereaza o serie de pagini, fiecare avand inclusa (ca etichetd meta)
instructiunea Refresh, ceea ce va determina browserul sa cicleze automat prin
fiecare pagina web.

«  WebCast genereaza o aplicatie ASP sau Perl pentru a afisa cadrele.

5) Dupa ce selectati tipul de publicatie pe care il doriti, selectati daca sa fie convertite
cadrele in fisiere GIF sau JPG si ce rezolutie sa fie folosita.

Crearea paginilor Web 8
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pagini WebSalvarea documentelor Draw ca pagini Web

6) Daca optiunea Creaza pagina de titlu (Create a title page) a fost aleasa la pasul 3 de mai
sus, furnizati informatiile necesare pe urmatoarea pagind. Titlul contine numele
autorului, adresa email si pagina pe Internet, putand sa furnizati si informatii de contact
aditionale.

7) In urmitoarea pagina, alegeti intre text si grafica pentru legaturile ce vor fi create pentru
navigarea intre pagini. Pentru butoanele de navigare grafice sunt mai multe stiluri dintre
care sa alegeti.

8) La pasul urmator selectati paleta de culori pentru paginile web. Printre paletele
disponibile sunt cea folosita n documentul curent, una bazata pe culorile din browser, si
una complet definita de utilizator.

9) Apasati butonul Creaza (Create) pentru a genera fisierele HTML.

Nota Fisierele HTML si cele cu imagini sunt plasate in acelasi director, astfel incat este
recomandat sa creati directoare unice pentru fiecare lucrare.

Sal csrilor ] -

WebSalvarea documentelor Draw ca pagin
Web

Exportarea desenelorprezentaritor din aplicatia OOo fmpressDraw este similard cu exportarea
prezentarilordeseneter din Prawlmpress. Folos1t1 Flsler (Flle) > Export 51 selectatl HTML
Document ca t1p de fisier. Singura-di

1a
E ﬁ - 1 Y - i ] .
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