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Why OOo for Techwriting?

Combines best features of MS Word and 
FrameMaker

Does some things better or easier

Good page layout and word processing

Runs on multiple platforms

Open source and free of charge



Jean Hollis Weber – Community Volunteer - Slide 3

Major test of OpenOffice.org

Wrote and formatted a book using OOo Writer

Output to PDF for final printing

OpenOffice.org Writer: The Free Alternative to 
Microsoft Word, O’Reilly Community Press, July 
2004
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Features for techwriters (1)

All the usual features for word processing

spell checking
wildcard search-and-replace
embeding or linking spreadsheets and 
graphics
page headers and footers
automatic tables of contents and indexes
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Features for techwriters (2)

Document templates

Styles 

Advanced page layout capabilities

Change tracking

Master documents that work

Fields
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Features for techwriters (3)

Conditional content

Bibliographic database

Equation (formula) editor

Macro language (OOo Basic)

PDF export

Microsoft Office compatibility

Customizable interface
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Document templates

Templates can store: 

styles, text, graphics 
user-specific setup information such as 
measurement units, language, the default 
printer, and toolbar and menu customization

All documents are based on templates

Can define custom templates
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Styles

A style is a set of formats to apply to selected 
items

Predefined styles in each category

Can modify these and define custom styles

Writer supports styles for 
pages
paragraphs
characters
frames
numbering
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Page layout

Page styles

Paragraph styles

Tables

Columns

Frames
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Coming in OpenOffice.org 2.0

Bookmarks in PDFs

Keyboard shortcuts for styles

Vertical text in tables

Word count in selections

Tables within tables

Bullets and numbering in table cells
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Questions?



Technical Writing Using OpenOffice.org Writer
Jean Hollis Weber

OpenOffice.org Writer is a strong competitor to Microsoft Word for both drafts and final
layout (desktop publishing) of many technical documents, because it combines some of the
best features of Word and FrameMaker. Indeed, Writer does several things better or easier
than each of them, as I’ll mention in this article. This information is covered in more detail in
my book, OpenOffice.org Writer: The Free Alternative to Microsoft Word, published by
O’Reilly Community Press in July 2004. The book was created using OpenOffice.org and
output to PDF for printing.
OpenOffice.org (OOo) is an open-source application that runs on Windows, Macintosh,
Linux, and Solaris. The application includes several components: word processor (Writer),
spreadsheets (Calc), presentations (Impress), and drawing (Draw). It is available for
download from http://www.openoffice.org/. OOo documents are zipped files containing XML
files and graphics files.
Technical writers produce a range of documents, including data sheets, specifications, user
guides, online help, marketing materials, proposals, tenders, reports, and more. Although
the final layout of many of these documents is often done using FrameMaker, PageMaker,
or Quark Express, far more documents are produced using Microsoft Word. Users of Word,
in particular, could benefit from switching to OpenOffice.org Writer.

Features of OpenOffice.org
In addition to all the usual features you’d expect to find in a word processor (such as spell
checking, wildcard search-and-replace, embeding or linking spreadsheets and graphics, use
of headers and footers, automatic tables of contents and indexes, and many others), Writer
has many features of particular interest to technical writers. Here are a few of them:
 Document templates

 Styles (for pages, paragraphs, characters, frames, and numbering)

 Advanced page layout capabilities

 Change tracking

 Master documents that work

 Fields

 Conditional content

 Bibliographic database

 Equation (formula) editor

 Macro language (OOo Basic)

 PDF export

 Microsoft Office compatibility

 Customizable interface

Let’s look at the good and (a few) bad points of each of these in a bit more detail.
Lastly, I’ll list some of the new features of OOo 2.0 of particular interest to technical writers.
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Document Templates
Templates can store styles, text, graphics, and user-specific setup information such as
measurement units, language, the default printer, and toolbar and menu customization.
All Writer documents are based on templates. If you don’t specify a template when you start
a new document, the document is based on the default template for text documents. If you
have not specified a default, Writer uses the blank template that is installed with the
program.
You can specify any template to be the default template for text documents, and you can
quickly and easily change the default template at any time. Changing a default template has
no effect on existing documents.

Styles
A style is a set of formats that you can apply to selected pages, paragraphs, characters,
frames, and other elements in your document to change their appearance quickly. When
you apply a style, you apply a whole group of formats at the same time.
Writer supports styles for pages, paragraphs, characters, frames, and numbering. It comes
with several predefined styles in each category. You can modify these styles, and you can
also define custom styles.

Page styles define the basic layout of all pages. You can have one or many page styles in a
single document; for example, you can define styles for the first page of each chapter, left
and right pages, index pages, contents pages, landscape pages, and any other pages you
might need. Although not as powerful as FrameMaker’s master pages, Writer’s page layout
handling is superior to Word’s.

Paragraph styles control all aspects of a paragraph’s appearance, such as text alignment,
tab stops, line spacing, space before and after the paragraph, first line indent, borders and
shading, plus a character style for the paragraph.

Character styles affect selected text within a paragraph, such as the font and size of text,
bold, italic, superscript, and other characteristics.

Frame styles are used to format graphic and text frames, including wrapping type, borders,
backgrounds, and columns.

Numbering styles apply alignment, numbering or bullet characters, and fonts to numbered
or bulleted lists and outline numbered paragraphs such as headings.
You can use any combination of these styles that suits your document, and in some cases
you can combine them with manual formatting (such as tagging specific paragraphs to be
kept with the following paragraph).

Page Layout
You can control page layouts by using combinations of page styles, paragraph styles,
tables, columns, and frames.
After you have set up your basic page styles, you can look at the finer details of page layout.
In many cases, you can control page layout by using paragraph styles alone. For example,
you can define heading paragraphs to be flush with the left margin and paragraphs for text
or graphics to be offset from the left margin.
In some cases, however, you might need to use other methods to place text or graphics
where you want them. One of those methods is to use tables to position various page
elements or to line up graphics or sideheads in the margin with specific paragraphs.
You can also use columns for page layout, and you can switch between single-column and
multiple-column layouts on the same page. Columns can be of equal or unequal widths. 
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For complex layout purposes, you may find that frames are a better choice, because you
have more control over the placement of text. Frames can be very useful if you are
producing a newsletter or other layout-intensive document. Frames can contain text, tables,
multiple columns, pictures, and other objects. You can link the content of one frame to
another, so the contents flow back and forth between them as you edit the text.

Change Tracking
Writer’s change tracking feature is similar to Word’s, and thus better than FrameMaker’s.
Although it has some minor irritating features, change tracking works well in Writer.

Master Documents
When working with large or complex documents (such as a book, a thesis, or a long report),
you have two choices: keep the entire document in one large file, or break it up into a series
of smaller files. Each approach has its advantages and disadvantages. Smaller files are
most useful when graphics, spreadsheets, or other included material causes the file size to
become quite large, or when different people are writing different chapters or other parts of
the full document. If you choose to use smaller files, you can often combine them into one
large file at the end of the project, before generating the table of contents and index.
Another approach is to use a master document.

Fields
Technical writers typically use fields to hold information that changes (so it can be easily
updated), to create cross-references to other parts of a document (so those references
update automatically when the target’s text or page number changes), to insert document
information into headers and footers, to create custom numbering schemes, and for other
purposes. OOo’s fields work well and are quite versatile.
An annoyance for many people is Writer’s lack of an automatically-generated list of
headings for use in cross-referencing. Instead, you must individually tag each heading (or
other text element) as a target for cross-referencing. (A macro exists to assist with this
chore.) However, if you’re accustomed to bookmarking items as targets instead of using a
built-in list, then you’ll find this feature is quite familiar.

Conditional Content
Conditional content is material that is marked so it can be included or excluded from a
document depending on a condition you specify. An example is a software manual for a
product that comes in two versions, Pro and Lite. Both product versions have much in
common, but the Pro version includes some features that are not in the Lite version. If you
use conditional content, you can maintain one file containing information for both versions
and print (or create online help) customized for each version. You don’t have to maintain two
sets of the information that is the same for both versions, so you won’t forget to update both
versions when something changes.
One major advantage of Writer over Word is that Writer supports conditional content. Word
doesn’t, although you can use various workarounds to achieve a similar result. Thus Writer
has incorporated one of FrameMaker’s major attractions for technical writers, although
Writer’s implementation is more limited than FrameMaker’s.

Bibliography Database
A bibliography is generated from bibliographic entries that you insert into a document either
directly or from a bibliography database associated with the document. If you expect to use
bibliographic entries in more than one document, you’ll save a lot of time (and improve
consistency) by creating and using a bibliography database (Tools > Bibliography
Database). Writer makes this process easy.
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Use the Insert Index/Table dialog to define the text reference delimiters and style, and the
appearance of the generated bibliography. The formatting choices are many and varied;
setting them up to suit your needs may be tedious, but the time spent will pay off in
consistency of presentation and ease of generating an end-of-book or end-of-article
bibliography.

Equation (Formula) Editor
OOo’s equation editor isn’t as robust and versatile as MathType, but I’ve heard good reports
from mathemeticians and others who use it extensively. Unlike Word’s equation editor,
Writer’s is installed automatically with a standard installation of the program.
When you choose Insert > Object > Formula, you open a separate OOo Math window in
which you can compose your equation.

Macro Language (OOo Basic)
Writer has a full macro language (OOo Basic). It’s not the same as the language (VBA)
used by MSOffice, but it has the same functionality. A recently-published book by Andrew
Pitonyak, OpenOffice.org Macros Explained (from Hentzenwerke), provides an in-depth
description of the macro language.

PDF Export
OOo provides a simple way to convert files into PDF (Portable Document Format). The
process generally produces good results, but you do not have the same control over those
results as you have when using Adobe Acrobat to create PDF files. 
The biggest limitation in OOo 1.X is that files converted to PDF do not have bookmarks, as
they do when created from Word or FrameMaker. OOo 2.0 provides this capability.

Microsoft Office Compatibility
If you need to share documents with users of Word, you can open Word files in Writer, edit
them in Writer, and save them as Word files. However, if you have used any of the powerful
features of Writer (and sometimes even when you haven’t), the output may not be quite the
same when it’s read by Word. Although some files will go back and forth between the two
programs without any major problems, other files definitely won’t. It depends on which
features of Word and Writer have been used.
In general, document contents convert fine, but layout may suffer and some fields are
changed into text. If a feature of Word isn’t supported by Writer, Writer will make some
substitution that may or may not be what you want. For example, Word’s Styleref field, used
in the headers and footers of many technical documents, is one that doesn’t convert,
because Writer doesn’t have an equivalent field.
If your publication process uses one program (such as Word) for drafts and another
program for final layout, you’ll probably find that Writer can easily be substituted for Word in
the workflow. 
If you need to convert existing documents from Microsoft Word to OOo Writer, OOo
provides a batch import facility to assist you. However, MSOffice and OOo cannot run the
same macro code. MSOffice uses VBA (Visual Basic for Applications) code, and OOo uses
StarBasic code based on the OpenOffice.org API (Application Program Interface)
environment. OOo can load the macros in MSOffice files and you can then view and edit the
macro code in OOo.

Customizable Interface
If you plan to use Writer a lot, you’ll want to take the time to set up the interface to suit your
work and your personal preferences. Writer’s default options at installation include a lot of
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automatic features that you’ll probably want to turn off. Many of these are in Tools >
Options; others are in Tools > AutoCorrect/AutoFormat. You can also change the menus
and toolbars using Tools > Customize.

Coming in OpenOffice.org 2.0
Some of the new features in OOo 2.0 of particular interest to technical writers are:
 Bookmarks in PDFs

 Keyboard shortcuts for styles

 Vertical text in tables

 Word count in selections

 Tables within tables

 Bullets and numbering in table cells

 Improved MSOffice compatibility

For a full list of new and improved features, see
http://marketing.openoffice.org/2.0/featureguide.html

Conclusion
This article has looked briefly at a few of the powerful features of OpenOffice.org Writer and
their use by technical writers. If you use Word, you’ll probably find that Writer can do the job
just as well if not better, once you get used to its different approach to many things.
However, you’ll need to evaluate whether Writer’s features and limitations are suitable for
the requirements of your documents and working environment.
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