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Choosing options that affect all of OOo
This section covers some of the settings that apply to all the 
components of OpenOffice.org. Other general options are discussed in 
Chapter 2 (Setting Up OpenOffice.org) in the Getting Started guide.

1) Click Tools > Options. The list on the left-hand side varies 
depending on which component of OOo is open. The illustrations 
in this chapter show the list as it appears when when 
OpenOffice.org Impress is open.

2) Click the + sign to the left of OpenOffice.org on the left-hand 
side. A list of subsections drops down.

Note
The Back button has the same effect on all pages of the Options 
dialog box. It resets the options to the values that were in place 
when you opened OpenOffice.org.

User Data options
Impress uses the first and last name stored in the User Data page to 
fill in the Created and Modified fields in the document properties, and 
the optional Author field often used in the footer of a presentation, so 
you will want to ensure that your name appears there. To do this:

1) In the Options dialog box, click OpenOffice.org > User Data.
2) Fill in the form on the OpenOffice.org – User Data page or delete 

any existing incorrect information.

Print options
Set the print options to suit your default printer and your most 
common printing method. You can change these settings at any time, 
either through this dialog box or during the printing process (by 
clicking the Options button on the Print dialog box).

In the Options dialog box, click OpenOffice.org > Print.

See Chapter 10 (Printing, e-mailing, exporting, and saving slide shows) 
for more about the options on this page.

Color options
On the OpenOffice.org – Colors page (Figure 1), you can specify colors 
to use in OOo documents. You can select a color from a color table, edit 
an existing color, or define new colors. These colors will then be 
available in color selection palettes in all components of OOo. You can 
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also define colors within Impress, but those colors will not be available 
to other components of OOo.

Figure 1. Defining colors to use in color palettes in OOo

Appearance options
On the OpenOffice.org – Appearance page (Figure 2), you can specify 
which items are visible and the colors used to display various items.

Figure 2. Changing the color of grid points in 
Impress and Draw

The only choice specific to Impress (and Draw) is the color of the grid 
points. Scroll down in the page until you find Drawing/Presentation.
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To change the default color for grid points, click the down-arrow by the 
color and select a new color from the pop-up box.

If you wish to save your color changes as a color scheme, click Save, 
type a name in the Scheme box; then click OK.

Choosing options for Impress
In the Options dialog box, click the + sign to the left of OpenOffice.org 
Impress on the left-hand side. A list of subsections drops down. (See 
Figure 3.)

Figure 3: Options for Impress

General options
In the Options dialog box, click OpenOffice.org Impress > General.

Figure 4: Specifying general options for Impress
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Text objects section
Allow quick editing sets Impress to immediately switch to the text 
editing mode when you click a text object. You can also activate text 

editing mode through the Allow Quick Editing icon  on the 
Options toolbar.

Only text area selectable sets Impress to select a text frame when you 
click on text. In the area of the text frame that is not filled with text, an 
object behind the text frame can be selected. You can also activate this 

mode through the Select Text Area Only icon  on the Options 
toolbar.

New document section
Start with Wizard sets Impress to start with the Presentation Wizard 
when opening a presentation with File > New > Presentation.

Settings section
Use background cache sets Impress to use the cache for displaying 
objects on the master page. This setting speeds up the display. Unmark 
this box if you want to display changing contents on the master page.

Copy when moving automatically creates a copy when you move, rotate 
or resize an object while holding down the Ctrl key. The original object 
will remain in its current position and size.

Objects always movable lets you move an object with the Rotate tool 
enabled. If this box is not marked, the Rotate tool can only be used to 
rotate an object.

Unit of measurement determines the unit of measurement for 
presentations.

Tab stops defines the spacing between tab stops.

Start presentation section
Always with current page specifies that a presentation starts with the 
current slide. Unmark this box to always start a presentation with the 
first page.

Compatibility section
The settings in this area are valid for the current document only.

Use printer metrics for document formatting applies printer metrics 
for printing and for formatting the display on the screen. If this box is 
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not checked, a printer-independent layout is used for screen display 
and printing.

Add spacing between paragraphs in the current document calculates 
the paragraph spacing in Impress exactly as Microsoft PowerPoint 
does. Microsoft PowerPoint adds the bottom spacing of a paragraph to 
the top spacing of the next paragraph to calculate the total spacing 
between both paragraphs. Impress normally uses only the larger of the 
two spacings.

View options
In the Options dialog box, click OpenOffice.org Impress > View.

Figure 5: Specifying view options for Impress

Rulers visible displays the rulers at the top and the left of the work 
area.

Guides when moving displays dotted guides that extend beyond the 
box containing the selected object and which cover the entire work 
area, helping you position the object when moving it. You can also use 

the Guides when moving icon  on the Options toolbar.

All control points in Bézier editor displays the control points of all 
Bézier points if you have previously selected a Bézier curve. If this box 
is not marked, only the control points of the selected Bézier points will 
be visible.

Contour of each individual object displays the contour line of each 
individual object when moving the object. This enables you to see if 
single objects conflict with other objects in the target position. If you 
do not mark this box, Impress displays only a square contour that 
includes all selected objects.

Grid options
The Grid page defines the grid settings for Impress. Using a grid helps 
you determine the exact position of your objects. You can also set this 
grid in line with the snap grid.
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If you have activated the snap grid but wish to move or create 
individual objects without snap positions, you can press the Ctrl to 
deactivate the snap grid for as long as needed.

In the Options dialog box, click OpenOffice.org Impress > Grid.

Grid section
Snap to grid activates the “snap” function.

Visible grid displays grid points on the screen. These points will not 
display or print as part of a presentation.

Figure 6: Specifying grid options for Impress

Resolution section
Here you can set the unit of distance for the spacing between 
horizontal and vertical grid points and subdivisions (intermediate 
points) of the grid.

Synchronize axes changes the current grid settings symmetrically.

Snap section
To snap lines snaps the edge of a dragged object to the nearest snap 
line when you release the mouse button. You can also use the Snap to 

Guides icon  on the Options toolbar.

To the page margins aligns the contour of the graphic object to the 
nearest page margin. The cursor or a contour line of the graphics 
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object must be in the snap range. You can also use the Snap to Page 

Margins icon  on the Options toolbar.

To object frame aligns the contour of the graphic object to the border 
of the nearest graphic object. The cursor or a contour line of the 
graphics object must be in the snap range. You can also use the Snap 

to Object Border icon  on the Options toolbar.

To object points aligns the contour of the graphic object to the points 
of the nearest graphic object. The cursor or a contour line of the 
graphics object must be in the snap range. You can also use the Snap 

to Object Points icon  on the Options toolbar.

Snap range defines the snap distance between the mouse pointer and 
the object contour. Impress snaps to a snap point if the mouse pointer 
is nearer than the distance selected in the Snap range box.

Snap position section
When creating or moving objects restricts graphic objects vertically, 
horizontally or diagonally (45°) when creating or moving them. You can 
temporarily deactivate this setting by pressing the Shift key.

Extend edges creates a square based on the longer side of a rectangle 
when the Shift key is pressed before you release the mouse button. 
This also applies to an ellipse (a circle will be created based on the 
longest diameter of the ellipse). When the Extend edges box is not 
marked, a square or a circle will be created based on the shorter side 
or diameter.

When rotating restricts the rotation of graphic objects within the 
rotation angle that you selected in the When rotating box. If you want 
to rotate an object outside the defined angle, press the Ctrl key when 
rotating. Release the key when the desired rotation angle is reached.

Point reduction defines the angle for point reduction. When working 
with polygons, you might find it useful to reduce their editing points.

Print options
In the Options dialog box, click OpenOffice.org Impress > Print.

See Chapter 10 (Printing, e-mailing, exporting, and saving slide shows) 
for more about the options on this page.
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Figure 7: Specifying print options for Impress

Customizing the user interface

Customizing the menu font
If you want to change the menu font from that supplied by OOo to the 
system font for your operating system, do this:

1) Choose Tools > Options > OpenOffice.org > View.
2) Check Use system font for user interface and click OK.

Customizing menu content
You can customize menus in OpenOffice.org. 

1) Choose Tools > Customize.
2) On the Customize dialog box, pick the Menus page (Figure 8).
3) In the Save In drop-down list, choose whether to save this 

changed menu for Impress or for a selected document.
4) In OpenOffice.org Impress Menus, select the menu you want 

to customize in the Menu drop-down list.
5) To customize the selected menu, click on the Menu or Modify 

buttons. You can also add commands to a menu by clicking on the 
Add button. These actions are described in the following sections. 
Use the up and down arrows next to the Entries list to move the 
selected menu item to a different position.
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6) When you are done customizing menus, click OK to save your 
changes.

Figure 8. The Menus page of the Customize dialog box

Creating a new menu
In the Customize dialog, click New to display the dialog shown in 
Figure 9.

1) Type a name for your new menu in the Menu name box.
2) Use the up and down arrow buttons to move the new menu into 

the required position on the menu bar.
3) Click OK to save.

The new menu now appears on the list of menus in the Customize 
dialog. (It will appear on the menu bar itself after you save your 
customizations.)

After creating a new menu, you need to add some commands to it, as 
described in “Adding a command to a menu” on page 15.
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Figure 9: Adding a new menu

Modifying existing menus
To modify an existing menu, select it in the Menu list and click the 
Menu button to drop down a list of modifications: Move, Rename, 
Delete. Not all of these modifications can be applied to all the entries 
in the Menu list. For example, Rename and Delete are not available 
for the supplied menus.

To move a menu (such as File), choose Menu > Move. A dialog similar 
to the one shown in Figure 9 (but without the Menu name box) opens. 
Use the up and down arrow buttons to move the menu into the 
required position.

To move submenus (such as File | Send), select the main menu (File) in 
the Menu list and then, in the Menu Content section of the dialog, 
select the submenu (Send) in the Entries list and use the arrow keys to 
move it up or down in the sequence. Submenus are easily identified in 
the Entries list by a small black triangle on the right hand side of the 
name.

In addition to renaming, you can specify a keyboard shortcut that 
allows you to select a menu command when you press Alt+ an 
underlined letter in a menu command.

1) Select a menu or menu entry.
2) Click the Menu button and select Rename.
3) Add a tilde (~) in front of the letter that you want to use as an 

accelerator. For example, to select the Save All command by 
pressing Alt+V, enter Sa~ve All.
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Adding a command to a menu
You can add commands to the supplied menus and to menus you have 
created. On the Customize dialog, select the menu in the Menu list and 
click the Add button in the Menu Content section of the dialog.

On the Add Commands dialog, select a category and then the 
command, and click Add. The dialog remains open, so you can select 
several commands. When you have finished adding commands, click 
Close. Back on the Customize dialog, you can use the up and down 
arrow buttons to arrange the commands in your preferred sequence.

Figure 10: Adding a command to a menu

Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, 
you can add submenus, rename or delete the entries, and add group 
separators.

To begin, select the menu or submenu in the Menu list near the top of 
the Customize page, then select the entry in the Entries list under 
Menu Content. Click the Modify button and choose the required action 
from the drop-down list of actions.

Most of the actions should be self-explanatory. Begin a group adds a 
separator line after the highlighted entry.
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Customizing toolbars
You can customize toolbars in several ways, including choosing which 
icons are visible and locking the position of a docked toolbar, as 
described in Chapter 1 (Introducing OpenOffice.org) of the Getting 
Started guide. This section describes how to create new toolbars and 
add other icons (commands) to the list of those available on a toolbar.

To get to the toolbar customization dialog, do any of the following:

• On the toolbar, click the arrow at the end of the toolbar and 
choose Customize Toolbar.

• Choose View > Toolbars > Customize from the menu bar.
• Choose Tools > Customize > Toolbars tab from the menu bar.

Figure 11. The Toolbars page of the Customize window

To customize toolbars:

1) In the Save In drop-down list, choose whether to save this 
changed toolbar for Impress or for a selected document.

2) In the OpenOffice.org Impress Toolbars section, select from 
the Toolbar drop-down list the toolbar that you want to 
customize.
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3) Click the Toolbar button on the right to display a drop-down list 
of choices.

4) To display or hide commands, select or deselect the checkboxes in 
the Toolbar Content – Commands section.

5) To change the position of commands on a toolbar, select a 
command and click the big up and down arrows to the right of the 
lists.

6) You can create a new toolbar by clicking on the New button, or 
customize existing toolbars by clicking on the Toolbar or Modify 
buttons, and add commands to a toolbar by clicking on the Add 
button. These actions are described below.

7) When you are done customizing toolbars, click OK to save your 
changes.

Creating a new toolbar
To create a new toolbar:

1) Choose Tools > Customize > Toolbars from the menu bar.
2) Click New. On the Name dialog, type the new toolbar's name and 

choose from the Save In drop-down list where to save this 
changed menu: for the application (for example, Writer) or for a 
selected document.

The new toolbar now appears on the list of toolbars in the Customize 
dialog. After creating a new toolbar, you need to add some commands 
to it, as described below.

Adding a command to a toolbar
If the list of available buttons for a toolbar does not include all the 
commands you want on that toolbar, you can add commands. When you 
create a new toolbar, you need to add commands to it.

1) On the Toolbars page of the Customize dialog, select the toolbar 
in the Toolbar list and click the Add button in the Toolbar Content 
section of the dialog.
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2) The Add Commands dialog is the same as for adding commands to 
menus. Select a category and then the command, and click Add. 
The dialog remains open, so you can select several commands. 
When you have finished adding commands, click Close. If you 
insert an item which does not have an associated icon, the toolbar 
will display the full name of the item: the next section describes 
how to choose an icon for a toolbar command.

3) Back on the Customize dialog, you can use the up and down 
arrow buttons to arrange the commands in your preferred 
sequence.

4) When you are done making changes, click OK to save.

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of 
the commands have associated icons.

To choose an icon for a command, select the command and click 
Modify > Change icon. On the Change Icon dialog, you can scroll 
through the available icons, select one, and click OK to assign it to the 
command.

Figure 12: Change Icon dialog

To use a custom icon, create it in a graphics program and import it into 
OOo by clicking the Import button on the Change Icon dialog. Custom 
icons must be 16 x 16 or 26 x 26 pixels in size and cannot contain more 
than 256 colors.
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Customizing keyboard shortcuts 
The Appendix to this book lists the default keyboard shortcuts supplied 
with Impress. You can change these defaults or add new shortcuts. You 
can assign shortcuts to standard Impress functions or your own macros 
and save them for use with Impress only, or with the entire 
OpenOffice.org suite.

Caution

Be careful when reassigning your operating system’s or OOo’s 
predefined shortcut keys. Many key assignments are universally 
understood shortcuts, such as F1 for Help, and are always 
expected to provide certain results. Although you can easily 
reset the shortcut key assignments to the OOo defaults, 
changing some common shortcut keys can cause confusion, 
frustration and possible data loss or corruption, especially if 
other users share your computer.

As an example, suppose you wish to assign a shortcut key to easily 
insert a duplicate slide in your presentation. You could assign the 
Insert key as a logical shortcut for this purpose, as described below:

1) Choose Tools > Customize.
2) On the Customize dialog box, pick the Keyboard page (Figure

13).
3) As the shortcut key assignment is only relevant with Impress, and 

not OpenOffice.org in general, select the Impress button (at the 
upper right corner of the Keyboard tab).

4) Next select Insert in the Category list and Duplicate Slide in 
the Function list.

5) Now select the shortcut key Insert in the Shortcut keys list and 
click the Modify button at the upper right.

6) Click OK to accept the change. Now the Insert shortcut key will 
insert a duplicate slide immediately after the currently selected 
slide.

Note

1) All existing shortcut keys for the currently selected Function 
are listed in the Keys selection box. Since there was no 
currently assigned shortcut for the 
Insert > Duplicate Slide function the Keys list was empty. 
If it had not been, and you wished to reassign a shortcut key 
combination that was already in use, you would first have 
had to Delete the existing Key.

2) Shortcut keys that are greyed-out in the listing on the 
Customize dialog box, such as F1 and F10, are not available 
for reassignment.

Customizing the user interface 19



Figure 13: Customizing keyboard shortcuts

Saving changes to a file
Changes to the shortcut key assignments (and other configurations) 
can be saved in a keyboard configuration file for use at a later time, 
thus permitting you to create and apply different configurations as the 
need arises. To save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save 
button near the bottom right of the Customize dialog box.

2) In the Save Keyboard Configuration dialog box, select All files 
from the Save as Type list.
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3) Next enter a name for the keyboard configuration file in the 
File name box, or select an existing file from the list. If you need 
to, browse to find a file from another location.

4) Click Save. A confirmation dialog box will appear if you are about 
to overwrite an existing file, otherwise there will be no feedback 
and the file will be saved.

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing 
configuration, click the Load button near the bottom right of the 
Customize dialog box, and then select the configuration file from the 
Load Keyboard Configuration dialog box.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the 
Reset button near the bottom right of the Customize dialog box. Use 
this feature with care as no confirmation dialog box will be displayed; 
the defaults will be set without any further notice or user input.

Running macros from key combinations
You can also define shortcut key combinations that will run macros. 
These shortcut keys are strictly user-defined; none are built in. For 
information on macros, see Chapter 13 (Getting started with macros) 
in the Getting Started guide.

Adding functionality with extensions
An extension is a package that can be installed into OpenOffice.org to 
add new functionality. 

Although individual extensions can be found in different places, the 
official OpenOffice.org extension repository is at 
http://extensions.services.openoffice.org/. Some extensions are free of 
charge; others are available for a fee. Check the descriptions to see 
what licenses and fees apply to the ones that interest you.

Installing extensions
To install an extension, follow these steps:

1) Download an extension and save it anywhere on your computer. 
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2) In OOo, select Tools > Extension Manager from the menu bar. 
In the Extension Manager dialog box (Figure 14), click Add.

3) A file browser window opens. Find and select the extension you 
want to install and click Open. The extension begins installing. 
You may be asked to accept a license agreement.

4) When the installation is complete, the extension is listed in the 
Extension Manager dialog.

Tip

To get extensions that are listed in the repository, you can open 
the Extension Manager and click the Get more extensions 
here link. You do not need to download them separately as in 
step 1 above.

Figure 14: Installing an extension

Note
To install a shared extension, you need write access to the 
OpenOffice.org installation directory. 

Using extensions
This section describes some of the more important and popular 
extensions to Impress. In each case, you need to first install the 
extension as described in the previous section.

Sun Presenter Console
Provides extra control over slide shows (presentations); for example, 
the presenter has ability to see the upcoming slide, the slide notes, and 
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a presentation timer—while the audience sees only the current slide. 
The Presenter Console displays the elements in three easily 
changeable views:

• The first view displays the current slide, including the effects, 
and the upcoming slide.

• The second view shows the speaker's notes in large, clear, and 
scalable type, plus the current and upcoming slide.

• The third view is a slide sorter view with the slide thumbnails.

From Sun Microsystems. Open source.

Note
The Presenter Console works only on an operating system that 
supports multiple displays.

Professional Template Pack II
Provides more than 120 templates for Writer, Calc, and Impress. 
Available in several languages. After you have installed this extension, 
you will find the templates under File > New > Templates and 
Documents. From Sun Microsystems. Freeware.

Sun Presentation Minimizer
Reduces the file size of the current presentation. Images are 
compressed, and data that is no longer needed is removed. Can 
optimize the image quality size. Presentations designed for screen or 
projector do not require the same high quality as presentations 
designed for print. From Sun Microsystems. Open source.

Template Changer
Adds two new items to the File > Templates menu that allow you to 
assign a new template to the current document or to a folder of 
documents. All styles and formatting will be loaded from that template 
and the document will behave as it was created using that template. 
Open source.
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