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Why use multiple sheets?
Chapter 1 introduced the concept of multiple sheets in a spreadsheet. 
Multiple sheets help keep information organized; once you link those 
sheets together, you unleash the full power of Calc. Consider this case.

John is having trouble keeping track of his personal 
finances. He has several bank accounts and the information 
is scattered and disorganized. He can’t get a good grasp on 
his finances until he can see everything at once. 

To resolve this, John decided to track his finances in OOo 
Calc. John knows Calc can do simple mathematical 
computations to help him keep a running tab of his 
accounts, and he wants to set up a summary sheet so that 
he can see all of his account balances at once.

This can be accomplished easily.

Note
For users with experience using Microsoft Excel, a Calc sheet is 
called either a sheet or worksheet in Excel. What Excel calls a 
workbook, Calc calls a spreadsheet (the whole document).

Setting up multiple sheets
Chapter 1 gives a detailed explanation of how to set up multiple sheets 
in a spreadsheet. Here is a quick review.

Identifying sheets
When you open a new spreadsheet it has, by default, three sheets 
named Sheet1, Sheet2, and Sheet3. Sheets in Calc are managed using 
tabs at the bottom of the spreadsheet, as shown in Figure 1.

Figure 1: Default sheet tabs
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Inserting new sheets
There are several ways to insert a new sheet. The first step, in all 
cases, is to select the sheet that will be next to the new sheet. Then do 
any of the following:

• Select Insert > Sheet from the menu bar, or
• Right-click on the tab and select Insert Sheet, or
• Click in an empty space at the end of the line of sheet tabs (see 

Figure 2).

Figure 2: Creating a new sheet

Each method opens the Insert Sheet dialog (Figure 3). Here you can 
choose to put the new sheet before or after the selected sheet and how 
many sheets to insert.

Figure 3. Insert Sheet dialog
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We need 6 sheets, one for each of the 5 accounts and one as a 
summary sheet so we will add 3 more. We also want to name each of 
these sheets for the account they represent: Summary, Checking 
Account, Savings Account, Credit Card 1, Credit Card 2, and Car Loan.

We have two choices: insert 3 new sheets and rename all 6 sheets 
afterwards; or rename the existing sheets, then insert the three new 
sheets 1 at a time, renaming each new sheet during the insert step.

To insert sheets and rename afterwards:

1) In the Insert Sheet dialog, choose the position for the new sheets 
(in this example, we use After current sheet).

2) Choose New sheet and 3 as the No. of sheets. (Three sheets are 
already provided by default.) Because you are inserting more than 
one sheet, the Name box is not available.

3) Click OK to insert the sheets.
4) For the next steps, go to “Renaming sheets” below.

To insert sheets and name them at the same time:

1) Rename the existing sheets Summary, Checking Account, and 
Savings Account, as described in “Renaming sheets” below.

2) In the Insert Sheet dialog, choose the position for the first new 
sheet.

3) Choose New sheet and 1 as the No. of sheets. The Name box is 
now available.

4) In the Name box, type a name for this new sheet, for example 
Credit Card 1.

5) Click OK to insert the sheet.
6) Repeat steps 1–4 for each new sheet, giving them the names 

Credit Card 2 and Car Loan.

On the Insert Sheet dialog, you can also add a sheet from a different 
spreadsheet file (for example, another Calc or Excel spreadsheet), by 
choosing the From file option. Click Browse and select the file; a list 
of the available sheets appears in the box. Select the sheet to import. 
If, after you select the file, no sheets appear you probably selected an 
invalid file type (not a spreadsheet, for example).

Tip

For a shortcut to inserting a sheet from another file, choose 
Insert > Sheet from file from the menu bar. The Insert Sheet 
dialog opens with the From file option preselected, and then the 
Insert dialog opens on top of it.
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If you prefer, select the Link option to insert the external sheet as a 
link instead as a copy. This is one of several ways to include “live” data 
from another spreadsheet. (See also “Linking to external data” on page 
19.) The links can be updated manually to show the current contents of 
the external file; or, depending on the options you have selected in 
Tools > Options > OpenOffice.org Calc > General > Updating, 
whenever the file is opened.

Renaming sheets
Sheets can be renamed at any time. To give a sheet a more meaningful 
name:

• Enter the name in the name box when you create the sheet, or
• Right-click on a sheet tab, select Rename Sheet from the pop-up 

menu and replace the existing name.

Note

Sheet names must start with either a letter or a number. Spaces 
are allowed after that. Other characters are not allowed. An 
invalid name will produce the error message Invalid Sheet 
Name.

Your sheet tab area should now look like this.

Figure 4: Six renamed sheets

Now we will set up the account ledgers. This is just a simple summary 
that includes the previous balance plus the amount of the current 
transaction. For withdrawals, we enter the current transaction as a 
negative number so the balance gets smaller. A basic ledger is shown 
in Figure 5.

This ledger is set up in the sheet named Checking Account. The total 
balance is summed in cell F3. You can see the equation for it in the 
formula bar. It is the summary of the opening balance, cell C3, and all 
of the subsequent transactions.
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Figure 5: Checking ledger

Referencing other sheets
On the Summary sheet we display the balance from each of the other 
sheets. If you followed the example in Figure 5, the balance for each 
account will be in cell F3 in each sheet.

There are two ways to reference cells in other sheets: by entering the 
formula directly using the keyboard or by using the mouse. We will 
look at the mouse method first.

Creating the reference with the mouse
On the Summary sheet, set up a place for all five account balances, so 
we know where to put the cell reference. Figure 6 shows a blank 
summary sheet. We want to place the reference for the checking 
account balance in cell B3.

Figure 6: Blank summary

To make the cell reference in cell B3, select the cell and follow these 
steps.

1) Click on the = icon next to the input line. The icons change and 
an equals sign appears in the input line as in Figure 7.
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Figure 7: Equal sign in input line

2) Now, click on the sheet tab for the sheet containing the cell to be 
referenced. In this case, that is the Checking Account sheet as 
shown in Figure 8.

Figure 8: Click on the checking account tab

3) Click on cell F3 (where the balance is) in the Checking Account 
sheet.

4) Return to the original sheet.
5)  The phrase ‘Checking Account’.F3 should appear in the input line 

as in Figure 9.

Figure 9: Cell reference selected

6) Click the green checkmark in the input line to finish.
7) The Summary sheet should now look like Figure 10.
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Figure 10: Finished checking account reference

Creating the reference with the keyboard
From Figure 10, you can deduce how the cell reference is constructed. 
The reference has two parts: the sheet name and the cell name.

In Figure 10 the reference is =’Checking Account’.F3 and in general 
the format is =’Sheet Name’.Cell Reference.

So, you can fill in the Savings Account cell reference by just typing it 
in. Assuming that the balance is in the same cell in the Savings 
Account sheet, F3, the cell reference should be =’Savings Account’.F3. 
(See Figure 11.)

Note
The sheet name is in single quotes, and the period (.) is outside 
the quotes.

Referencing other documents
John decides to keep his family account information in a different 
spreadsheet file from his own summary. Fortunately Calc can link 
different files together. The process is the same as described for 
different sheets in a single spreadsheet, but we add one more 
parameter to indicate which file the sheet is in.

Creating the reference with the mouse
To create the reference with the mouse, both spreadsheets need to be 
open. Select the cell in which the formula is going to be entered.

1) Click the = icon next to the input line.
2) Switch to the other spreadsheet (the process to do this will vary 

depending on which operating system you are using).
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Figure 11: Savings account cell reference

3) Select the sheet and then the reference cell.
4) Switch back to the original spreadsheet.
5) Click on the green check mark on the input line.

Your spreadsheet should now resemble Figure 12.

Figure 12: Linked files

You will get a good feel for the format of the reference if you look 
closely at the input line as in Figure 13.

Figure 13: Input line for linked file

Based on this line you can create the reference using the keyboard.
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Creating the reference with the keyboard
Typing the reference is simple once you know the format the reference 
takes. The reference has three parts to it:

• File name and path
• Sheet name
• Cell

Looking at Figure 13 you can see the the general format for the 
reference is 

=’file:///Path & File Name’#$SheetName.CellName.

Note
The reference for a file has three forward slashes /// and the 
reference for a hyperlink has two forward slashes //.

Hyperlinks and URLs
Hyperlinks can be used in Calc to create spreadsheets that will be used 
in a web interface or to jump to a different location from within a 
spreadsheet. This section covers inserting, editing, removing, and 
using hyperlinks.

Creating hyperlinks
When you type text (such as a website addresses or URL) that can be 
used as a hyperlink, OOo formats it automatically, creating the 
hyperlink and applying to the text a color and underlining. If this does 
not happen, you can enable this feature using Tools > AutoCorrect > 
Options and selecting URL Recognition.

Tips

If you do not want OOo to convert a specific URL to a hyperlink, 
select Edit > Undo Insert from the menu bar or press 
Control+Z immediately after the formatting has been applied.

To change the color of hyperlinks, go to Tools > Options > 
OpenOffice.org > Appearance, scroll to Unvisited links 
and/or Visited links, pick the new colors and click OK. Caution: 
this will change the color for all hyperlinks in all components of 
OpenOffice.org—this may not be what you want.

In Writer and Calc (but not Draw or Impress), you can also 
change the Internet link character style or define and apply 
new styles to selected links.
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You can also insert and modify links using the Hyperlink dialog 
(Figure 14). To display the dialog, click the Hyperlink icon  on the 
Standard toolbar or select Insert > Hyperlink from the menu bar. To 
turn existing text into a link, highlight it before opening the Hyperlink 
dialog. 

On the left hand side, select one of the four types of hyperlinks:

• Internet: a web address, normally starting with http://
• Mail & News: for example an email address.
• Document: the hyperlink points to another document or to 

another place in the presentation.
• New document: the hyperlink creates a new document.

Figure 14. Hyperlink dialog showing details for Internet links

The top right part of the dialog changes according to the choice made 
for the hyperlink type. A full description of all the choices, and their 
interactions, is beyond the scope of this chapter. Here is a summary of 
the most common choices used in presentations.

For an Internet type hyperlink, choose the type of hyperlink (choose 
between Web, FTP or Telnet), and enter the required web address 
(URL).

For a Mail and News type hyperlink, specify whether it is a mail or 
news link, the receiver address and for email, also the subject.

For a Document type hyperlink, specify the document path (the Open 
File button opens a file browser); leave this blank if you want to link to 
a target in the same presentation. Optionally specify the target in the 
document (for example a specific slide). Click on the Target icon to 
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open the Navigator where you can select the target, or if you know the 
name of the target, you can type it into the box.

For a New Document type hyperlink, specify whether to edit the newly 
created document immediately or just create it (Edit later) and the 
type of document to create (text, spreadsheet, etc.). For a presentation, 
Edit now is the more likely choice. The Select path button opens a 
directory picker.

The Further settings section in the bottom right part of the dialog is 
common to all the hyperlink types, although some choices are more 
relevant to some types of links.

• Set the value of Frame to determine how the hyperlink will open. 
This applies to documents that open in a Web browser.

• Form specifies if the link is to be presented as text or as a button. 
Figure 15 shows a link formatted as a button.

Figure 15: OOo Authors hyperlink as button

• Text specifies the text that will be visible to the user.
• Name is applicable to HTML documents. It specifies text that will 

be added as a NAME attribute in the HTML code behind the 
hyperlink.

• Event button: this button will be activated to allow OOo to react 
to events for which the user has written some code (macro). This 
function is not covered in this book.

Note

A hyperlink button is a type of form control. As with all form 
controls, it can be anchored or positioned by right-clicking on the 
button in design mode. More information about forms can be 
found in Chapter 15 of the Writer Guide.

For the button to work , the spreadsheet must not be in design 
mode. To toggle design mode on and off, view the Form Controls 
toolbar (View > Toolbars > Form Controls) and click the 
Design Mode On/Off button .
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Editing hyperlinks
To edit an existing link, place the cursor anywhere in the link and click 
Edit > Hyperlink. The Hyperlink dialog (Figure 14) opens. Make your 
changes and click Apply. If you need to edit several hyperlinks, you 
can leave the Hyperlink dialog open until you have edited all of them. 
Be sure to click Apply after each one. When you are finished, click 
Close.

The standard (default) behavior for activating hyperlinks in OOo 3 is to 
use Ctrl+click. This behavior can be changed in Tools > Options > 
OpenOffice.org > Security > Options, by deselecting the option 
Ctrl-click required to follow hyperlinks. If clicking in your links 
activates them, check that page to see if the option has been 
deselected.

Removing hyperlinks
To remove a hyperlink, select it and press the Delete key. The Delete 
dialog opens if it is a text hyperlink.

Relative and absolute hyperlinks
Hyperlinks can be saved as either absolute or relative. An absolute 
hyperlink says, “Here is how to get there from this known starting 
point” and a relative hyperlink says, “Here is how to get there starting 
from where you are now”.

To change the way that OOo saves the hyperlinks choose Tools > 
Options > Load/Save > General and choose if you want URLs saved 
relative to the File System, to the Internet, or both.

Calc always displays an absolute hyperlink. Don’t be alarmed when it 
does this when you have chosen a relative hyperlink.

If you have a relative hyperlink and you move files (the document and 
any linked files) on your computer, you shouldn’t have to remake your 
hyperlink as long as you maintain the same directory structure. For 
instance, if you have two spreadsheets in the same folder linked to 
each other and you move the entire folder to a new location, the 
hyperlink will not break. This is only true as long as the files’ locations 
relative to each other do not change.

In Figure 12 the path is D:\My Documents for the linked file. That is 
because the folder both sheets are in is in that directory as shown in 
Figure 16.
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Figure 16: Files on D drive

If we move that folder to the H:\ drive (Figure 17), the links in Calc will 
automatically update (Figure 19) because we have not changed the 
location of the files relative to each other. Both files are still in the 
working with multiple sheets folder as shown in Figure 18.

Figure 17: Files on H drive
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Figure 18: Directory with linked files

Figure 19: Updated links on H drive

Again, note that in both Figure 12 and Figure 19 the path is displayed 
as absolute even though it is relative.

Note

Make sure that the folder structure on your computer is the same 
as the file structure on your web server if you save your links as 
relative to the file system and you are going to upload pages to 
the Internet.

Tip

When you rest the mouse cursor on a hyperlink, a help tip 
displays the absolute reference, since OOo uses absolute path 
names internally. The complete path and address can only be 
seen when you view the result of the HTML export (saving the 
spreadsheet as an HTML file), by loading the HTML file as Text, 
or by opening it with a text editor.
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Linking to external data
You can insert tables from HTML documents, and data located within 
named ranges from an OpenOffice.org Calc or Microsoft Excel 
spreadsheet, into a Calc spreadsheet. (To use other data sources, 
including database files in OOo Base, see “Linking to registered data
sources” on page 24.)

You can do this in two ways: using the External Data dialog or using 
the Navigator. If your file has named ranges or named tables, and you 
know the name of the range or table you want to link to, using the 
External Data dialog method is quick and easy. However, if the file has 
several tables, and you want to pick only one of them, you may not be 
able to easily determine which is which; in that case, the Navigator 
method may be easier.

Using the External Data dialog
1) Open the Calc document where the external data is to be 

inserted. This is the target document.
2) Select the cell where the upper left-hand cell of the external data 

is to be inserted.
3) Choose Insert > Link to External Data.
4) On the External Data dialog (Figure 20), type the URL of the 

source document or click the [...] button to open a file selection 
dialog. Press Enter to get Calc to load the list of available tables.

5) In the Available tables/range list, select the named ranges or 
tables you want to insert. You can also specify that the ranges or 
tables are updated every n seconds.

6) Click OK to save and close this dialog.

Notes

1) The Available tables/ranges list remains empty until you 
press Enter after selecting the URL of the source.

2) The OK button remains unavailable (greyed out) until you 
select one or more tables/ranges in the list. You can hold 
down the Control key while clicking on tables/ranges to 
select more than one.

3) No images are imported 
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Figure 20: Selecting a table or range in a source document 
from the Web

Using the Navigator
1) Open the OpenOffice.org Calc spreadsheet in which the external 

data is to be inserted (target document).
2) Open the document from which the external data is to be taken 

(source document). Choose Web Page Query (OpenOffice.org 
Calc) as the file type (Figure 21).

Figure 21: Opening a file using the Web Page Query filter

3) In the target document, open the Navigator.
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4) At the bottom of the Navigator, select the source document. (In 
Figure 22, the source is named actives.) 
The Navigator now shows the range names or the tables 
contained in the source document (the example contains range 
names; other documents have a list of tables). Click on the + next 
to Range names to display the list.

5) In the Navigator, select the Insert as Link drag mode, as shown 
in Figure 22.

6) Select the required range or table and drag it from the Navigator 
into the target document, to the cell where you want the upper 
left-hand cell of the data range to be.

Figure 22: Selecting a data range in a source 
document, to be inserted as a link

7) In the target document, check the Navigator. Instead of a + by 
Range names, it shows a + by Linked areas. Click the + to see the 
same range name (see Figure 23).
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Figure 23: Linked areas in 
target spreadsheet

How to find the required data range or table
The examples above show that the import filter gave names to the data 
rangers (tables) in the sample web page starting from HTML_1. It also 
created two additional range names (not visible in the illustration):

HTML_all – designates the entire document

HTML_tables – designates all HTML tables in the document

If the data tables in the source HTML document have been given 
names (using the ID attribute on the TABLE tag), or the external 
spreadsheet includes named ranges, those names appear in the list 
along with the ranges Calc has sequentially numbered.

If the data range or table you want is not named, how can you tell 
which one to select? 

Go to the source document, which you opened in Calc using the Web 
Page Query filter. Select the range you want. Look in the Navigator: 
the range name is highlighted (see Figure 24).

If the Formula Bar is visible, the range name is also displayed in the 
Name box at the left-hand end (see Figure 25).

22 Linking Calc Data



Figure 24: Using the Navigator to find a data range name

Figure 25: Using the Name box to find a data range name
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Linking to registered data sources
You can access a variety of databases and other data sources and link 
them into Calc documents.

First you need to register the data source with OOo. (To register means 
to tell OpenOffice.org what type of data source it is and where the file 
is located.) To do this:

1) Choose File > New > Database to open the Database Wizard.
2) Select Connect to an existing database. The choices for 

database type depend on your operating system. For example, 
Microsoft Access and other Microsoft products are not among the 
choices for Linux. In our example, we chose dBASE.

Figure 26: Registering a database using the Database Wizard

3) Click Next. Select Register the database for me, but do not select 
Open the database for editing.
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4) Click Finish. Name and save the database in the location of your 
choice.

Once a data source has been registered, it can be used by any OOo 
component (for example Calc).

Viewing data sources
Open a document in Calc. To view the data sources available, press F4 
or select View > Data Sources from the menu bar. The Data Source 
View pane opens above the spreadsheet. A list of registered databases 
is in the Data Explorer area on the left. (The built-in Bibliography 
database is included in the list.)

To view each database, click on the + to the left of the name of the 
database. (This has been done for the Automobile database in Figure
27.) Click on the + next to Tables to view the individual tables.

Figure 27: Databases

Now click on a table to see all the records held in it. The data records 
are displayed on the right side of the Data Source View pane. To see 
more columns, you can click the Explorer On/Off button to hide the 
Data Explorer area.

At the top of the Data Source View pane, below the Calc toolbars, is 
the Table Data bar. This toolbar includes button for saving records, 
editing data, finding records, sorting, filtering, and other functions. For 
more details about this toolbar, see the Help for data source browser.

Below the records is the Form Navigation bar, which shows which 
record is selected and the total number of records. To the right are five 
tiny buttons. The first four move backwards or forwards through the 
records, or to the beginning or end.

Figure 28: Data Source View navigation buttons
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Editing data sources
Some data sources can be edited in the data source view. A 
spreadsheet can not.

In editable data sources, records can be edited, added, or deleted. If 
you cannot save your edits, you need to open of the database in Base 
and edit it there; see “Launching Base to work on data sources”. You 
can also hide columns and make other changes to the display.

Launching Base to work on data sources
You can launch OOo Base at any time from the Data Source View pane. 
Right-click on a database or the Tables or Queries icons and select 
Edit Database File. Once in Base, you can edit, add, and delete tables, 
queries, forms, and reports.

For more about using Base, see Chapter 8 (Getting Started with Base) 
in the Getting Started guide.

Using data sources in Calc spreadsheets
Data can be placed into Calc documents from the tables in the data 
source pane.

You can insert one or more records into the current sheet of a 
spreadsheet by selecting the rows in the data source pane and 
dragging and dropping them into the spreadsheet. The data is inserted 
at the place where you release the mouse button.

There are two ways to enter data into a Calc spreadsheet. One enters 
the data into the spreadsheet cells. The other creates records in the 
spreadsheet just like they are done in creating a form in a database. 
While you can directly access the data in the spreadsheet cells, you can 
only see the data in the records created in the spreadsheet.

Entering data directly to the spreadsheet cells uses the Data to Text 
icon. But differences exist in these two situations.

Here are the steps.

1) Click the cell of the spreadsheet which you want to be the top left 
of your data including the column names.

2) Press F4 to open the database source window and select the table 
containing the data you want to use.

3) Select the rows of data you want to add to the spreadsheet:
• Click the gray box to the left of the row you want to select if 

only selecting one row. That row is highlighted.
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• To select multiple contiguous rows, hold down the Shift key 
while clicking the gray box of the rows you need. 

• To select multiple noncontiguous rows, hold down the Control 
key while selecting the rows. The selected rows are 
highlighted.

• To select all the rows, click the gray box in the upper left 
corner. All rows are highlighted.

4) Click the Data to text icon  to insert the data into the 
spreadsheet cells.

5) Save the spreadsheet.

To add records to a spreadsheet, you need to have the Data Source 
pane open, your spreadsheet open, and the table you want to use 
selected. Follow these steps:

1) Click the gray box at the top of the column (containing the field 
name you wish to use) to highlight it.

2) Drop and drag the gray box to where you want the record to 
appear in the spreadsheet.

3) Repeat until you have moved all of the fields you need to where 
you want them.

4) Close the Data Source window: use F4.

5) Save the spreadsheet and click the Edit File button  on the 
Standard toolbar, to make the spreadsheet read-only. All of the 
fields will show the value for the data of the first record you 
selected.

6) Add the Form Navigation toolbar: View > Toolbars > Form 
Navigation. By default, this toolbar opens at the bottom of the 
Calc window, just above the status bar.

7) Click the arrows on the Form Navigation toolbar to view the 
different records of the table. The number in the Record box 
changes as you move through the records. The data in the fields 
changes to corresponding to the data for that particular record 
number. You can also search for a specific record, sort and filter 
records, and do other tasks using this toolbar.
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Embedding spreadsheets
Spreadsheets can be embedded in other OOo files. This is often used in 
Writer or Impress documents so that Calc data can be used in a text 
document. You can embed the spreadsheet as either an OLE or DDE 
object.

Object Linking and Embedding (OLE)
The major benefit of an OLE (Object Linking and Embedding) object is 
that it is quick and easy to edit the contents just by double-clicking on 
it. You can also insert a link to the object that will appear as an icon 
rather than an area showing the contents itself.

OLE objects can be linked to a target document or be embedded in the 
target document. Embedding inserts a copy of the object and details of 
the source program in the target document. If you want to edit the 
embedded spreadsheet, double-click on the object.

To add an OLE object:

1) Place the cursor in the document and location you want the OLE 
object to be.

2) Select Insert > Object > OLE Object. The dialog shown in 
Figure 29 opens.

Figure 29: Insert OLE object dialog

3) You can either create a new OLE object or create from a file.

To create a new object:
1) Select Create new and select the object type among the available 

options.

Note
“Further objects” is only available under a Windows operating 
system. It does not appear in the list under any other system.

28 Linking Calc Data



2) Click OK. An empty container is placed in the slide.
3) Double-click on the OLE object to enter the edit mode of the 

object. The application devoted to handling that type of file will 
open the object.

Note

If the object inserted is handled by OpenOffice.org, then the 
transition to the program to manipulate the object will be 
seamless; in other cases the object opens in a new window and 
an option in the File menu becomes available to update the 
object you inserted.

To insert an existing object:
1) To create from a file, select Create from file. The dialog box 

changes to look like Figure 30.
2) To insert the object as a link, select the Link to file option. 

Otherwise, the object will be embedded.
3) Click Search, select the required file in the file picker window, 

then click Open. A section of the inserted file is shown in the 
document.

Figure 30: Inserting an object as a link

Other OLE objects
Under Windows, the Insert OLE Object dialog box has an extra entry, 
Further objects, as shown in Figure 29.

1) Double-click on the entry Further objects to open the dialog 
shown in Figure 31.

2) Select Create New to insert a new object of the type selected in 
the Object Type list, or select Create from File to create a new 
object from a file.

3) If you choose Create from File, the dialog shown in Figure 32 
opens. Click Browse and choose the file to insert. The inserted 
file object is editable by the Windows program that created it.

Embedding spreadsheets 29



Figure 31: Advanced menu to insert an OLE object under 
Windows  

If instead of inserting an object, you want to insert a link to an 
object, select the Display As Icon option.

Figure 32: Insert object from a file

Non-linked OLE object
If the OLE object is not linked, it can be edited in the new document. 
For instance, if you insert a spreadsheet into a Writer document, you 
can essentially treat it as a Writer table (with a little more power). To 
edit it, double-click on it.
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Linked OLE object
When the spreadsheet OLE object is linked, if you change it in Writer it 
will change in Calc; if you change it in Calc, it will change in Writer. 
This can be a very powerful tool if you create reports in Writer using 
Calc data, and want to make a quick change without opening Calc.

Note

You can only edit one copy of a spreadsheet at t a time. If you 
have a linked OLE spreadsheet object in an open Writer 
document and then open the same spreadsheet in Calc, the Calc 
spreadsheet will be a read-only copy.

Dynamic Data Exchange (DDE)
DDE is an acronym for Dynamic Data Exchange, a mechanism whereby 
selected data in document A can be pasted into document B as a 
linked, ‘live’ copy of the original. It would be used, for example, in a 
report written in Writer containing time-varying data, such as sales 
results sourced from a Calc spreadsheet. The DDE link ensures that, as 
the source spreadsheet is updated so is the report, thus reducing the 
scope for error and reducing the work involved in keeping the Writer 
document up to date.

DDE is a predecessor of OLE. With DDE, objects are linked through file 
reference, but not embedded. You can create DDE links either within 
Calc cells in a Calc sheet, or in Calc cells in another OOo doc such as 
in Writer.

DDE link in Calc
Creating a DDE link in Calc is similar to creating a cell reference. The 
process is a little different, but the result is the same.

1) In Calc, select the cells that you want to make the DDE link to.
2) Copy them: Edit > Copy or Ctrl+C.
3) Go to the place in the spreadsheet where you want to the link to 

be.
4) Select Edit > Paste Special.
5) When the Paste Special dialog opens, select the Link option on 

the bottom left of the dialog (Figure 33). Click OK.

The cells now reference the copied data, and the formula bar shows a 
reference beginning with {=DDE.

If you now edit the original cells, the linked cells will update.
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Figure 33: Paste Special dialog in Calc, with Link option selected

DDE link in Writer
The process for creating a DDE link from Calc to Writer is similar to 
creating a link within Calc.

1) In Calc, select the cells to make the DDE link to. Copy them.
2) Go to the place in your Writer document where you want the DDE 

link. Select Edit > Paste Special.
3) Select DDE Link (Figure 34). Click OK.

Now the link has been created in Writer. When the Calc spreadsheet is 
updated, the table in Writer is automatically updated.

Figure 34: Paste Special dialog in Writer, with DDE link selected
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