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What is Calc?
Calc is the spreadsheet component of OpenOffice.org (OOo). You can 
enter (usually numerical) data in a spreadsheet and then manipulate 
this data to produce certain results.

Alternatively, you can enter data and then use Calc in a ‘What if...’ 
manner by changing some of the data and observing the results 
without having to retype the entire spreadsheet or sheet.

Spreadsheets, sheets, and cells
Calc works with elements called spreadsheets. Spreadsheets consist of 
a number of individual sheets, each containing a block of cells 
arranged in rows and columns.

These cells hold the individual elements—text, numbers, formulas, etc.
—which make up the data to display and manipulate.

Each spreadsheet can have many sheets, and each sheet can have 
many individual cells. In version 3.0 of OOo, each sheet can have a 
maximum of 65,536 rows and a maximum of 1024 columns.

Figure 1. Parts of the Calc window

Spreadsheets, sheets, and cells 5



Parts of the main Calc window
When Calc is started, the main window looks similar to Figure 1.

Title bar and Menu bar
The Title bar, at the top, shows the name of the current spreadsheet. 
When the spreadsheet is newly created, its name is Untitled X, where 
X is a number. When you save a new spreadsheet for the first time, an 
alert will prompt you to enter a name of your choice.

Under the Title bar is the Menu bar. When you choose one of the 
menus, a submenu appears with other options. You can modify the 
Menu bar, as discussed in Chapter 14 (Setting up and Customizing 
Calc).

Toolbars
Under the Menu bar by default are three toolbars: the Standard 
toolbar, the Formatting toolbar, and the Formula Bar.

The icons on these toolbars provide a wide range of common 
commands and functions. You can also modify these toolbars, as 
discussed in Chapter 14 (Setting up and Customizing Calc).

Placing the mouse pointer over any of the icons displays a small box, 
called a tooltip. It gives a brief explanation of the icon’s function. For a 
more detailed explanation, select Help > What’s This? and hover the 
mouse pointer over the icon. Tips and extended tips can now be turned 
on or off from Tools > Options > OpenOffice.org > General.

In the Formatting toolbar, the three boxes on the left are the Apply 
Style, Font Name, and Font Size lists (see Figure 2). If there is 
something in these boxes, they show the current setting for the 
selected area. (The Apply Style list may not be visible by default.) Click 
the down-arrow to the right of each box to open the list.

Figure 2. Apply Style, Font Name and Font Size boxes
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Formula Bar
On the left of the Formula Bar (see Figure 3) is a small text box, called 
the Name Box, with a letter and number combination in it, such as D7. 
This is the column letter and row number, called the cell reference, of 
the current cell.

Figure 3. Formula Bar

To the right of the Name Box are the the Function Wizard, Sum, and 
Function buttons.

Clicking the Function Wizard button opens a dialog from which you 
can search through a list of available functions. This can be very useful 
because it also shows how the functions are formatted.

The Sum button inserts a formula into the current cell that totals the 
numbers in the cells above, or to the left if there are no numbers 
above, the current cell.

The Function button inserts an equals sign into the selected cell and 
the Input line, thereby setting the cell ready to accept a formula.

When you enter new data into a cell, the Sum and Equals buttons 
change to Cancel and Accept buttons .

The contents of the current cell (data, formula, or function) are 
displayed in the Input line, the remainder of the Formula Bar. You can 
edit the cell contents of the current cell here, or you can do that in the 
current cell. To edit inside the Input line area, click the appropriate 
part of the Input line area, then type your changes. To edit within the 
current cell, just double-click the cell.

Individual cells
The main section of the screen displays the individual cells in the form 
of a grid, with each cell being at the intersection of a particular column 
and row.

At the top of the columns and at the left-hand end of the rows are a 
series of gray boxes containing letters and numbers. These are the 
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column and row headers. The columns start at A and go on to the right, 
and the rows start at 1 and go on down.

These column and row headers form the cell references that appear in 
the Sheet Area box on the Formula Bar (see Figure 3). You can turn 
these headers off by selecting View > Column & Row Headers.

Sheet tabs
At the bottom of the grid of cells are the sheet tabs. These tabs enable 
access to each individual sheet, with the visible, or active, sheet having 
a white tab.

Clicking on another sheet tab displays that sheet, and its tab turns 
white. You can also select multiple sheet tabs at once by holding down 
the Control key while you click the names.

Status bar
The Calc status bar provides information about the spreadsheet and 
convenient ways to quickly change some document features. From left 
to right, the fields are as follows.

Sheet sequence number
Shows the sequence number of the current sheet the total number 
of sheets in the spreadsheet. The sequence number may not 
correspond with the name on the sheet tab.

Page style
Shows the page style of the current sheet. To change the page style, 
right-click on this field. A list of page styles pops up; choose a 
different style by clicking on it.
To edit the page style, double-click on this field. The Page Style 
dialog opens.

Insert mode
Click to toggle between Insert and Overwrite modes when typing.

Selection mode
Click to toggle between STD (Standard), EXT (Extend), ADD (Add) 
and BLK (Block) selection. EXT is an alternative to Shift+click when 
selecting text.
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Unsaved document flag
If changes have been made to the document since it was last saved, 
an asterisk (*) appears in this field.

Digital signature
If the document has not been digitally signed, double-clicking in this 
area opens the Digital Signatures dialog, where you can sign the 
document. See Chapter 5 for more about digital signatures.

If the document has been digitally signed, an icon  shows in this 
area. You can double-click the icon to view the certificate.

Cell or object information
Displays information about the selected items. When a group of cells 
is selected, the sum of the contents is displayed by default; you can 
right-click on this field and select other functions, such as the 
average value, maximum value, minimum value, or count (number of 
items selected).
When the cursor is on an object such as a picture or chart, the 
information shown includes the size of the object and its location.

Zoom—new in OOo 3.1
To change the view magnification, drag the Zoom slider or click on 
the + and – signs. You can also right-click on the zoom level 
percentage to select a magnification value.

Starting new spreadsheets
You can create a new, blank spreadsheet from the Start Center 
(Welcome to OpenOffice.org) or from within Calc or any other 
component of OOo, for example from Writer or Draw.

From the Start Center
Click the Spreadsheet icon.

From the Menu bar
Click File and then select New > Spreadsheet.

From the toolbar
If a document is open in any component of OOo (for example, 

Writer), you can use the New Document  icon on the Standard 
toolbar. (This icon is always a page of text from the current 
component with a black down-arrow to the right.) Click the down-
arrow for a choice of which type of document to open (text 
document, spreadsheet, and so on). Click the button itself to create 

Starting new spreadsheets 9



a new document of the type that is currently open. (If a spreadsheet 
is open, a new spreadsheet document will be created).

From the keyboard
If you already have a spreadsheet open, you can press Control+N to 
open a new spreadsheet.

From a template
Calc documents can also be created from templates, if you have any 
spreadsheet templates available. Follow the above procedures, but 
instead of selecting Spreadsheet, select the Templates icon from 
the Start Center or Templates and Documents from the Menu bar 
or toolbar. On the Templates and Documents window, navigate to the 
appropriate folder and double-click on the required template. A new 
spreadsheet, based on the selected template, opens.

Opening existing spreadsheets
You can open an existing spreadsheet from the Start Center or from 
any component of OOo. Calc can open spreadsheets in a range of file 
formats, including Microsoft Excel.

From the Start Center
Click the Open a document icon.

From the Menu bar
Click File and then select Open.

From the toolbar

Click the Open icon  on the Standard toolbar.

From the keyboard
Use the key combination Control+O.

Each of these options displays the Open dialog, where you can locate 
the spreadsheet that you want to open.

Tip

You can also open a spreadsheet that has been recently 
worked on using the Recent Documents list. This list can be 
accessed from the File menu, directly below Open. The list 
displays the last 10 files that were opened in any of the OOo 
components.
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Opening CSV files
Comma separated values (CSV) files are text files that contain the cell 
contents of a single sheet. Each line in a CSV file represents a row in a 
spreadsheet. Commas, semicolons, or other characters are used to 
separate the cells. Text is put in quotation marks, numbers are written 
without quotation marks.

To open a CSV file in Calc:
1) Choose File > Open.
2) Locate the CSV file that you want to open.
3) If the file has a *.csv extension, select the file and click Open.
4) If the file has another extension (for example, *.txt), select the 

file, select Text CSV in the File type box (scroll down into the 
spreadsheet section to find it) and then click Open.

5) On the Text Import dialog, select the separator options to divide 
the text in the file into columns.

Figure 4: Text Import dialog, with Comma selected as the separator 
and double quotation mark (“) as the text delimiter.
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You can preview the layout of the imported data at the bottom of 
the dialog. Right-click a column in the preview to set the format 
or to hide the column.
If the CSV file uses a text delimiter character that is not in the 
Text delimiter list, click in the box, and type the character.

6) Click OK to open the file.

Caution If you do not select Text CSV as the file type when opening the 
file, the document opens in Writer, not Calc.

Saving spreadsheets
Spreadsheets can be saved in the following three ways.

From the Menu bar
Click File and then select Save (or Save All or Save As).

From the toolbar
Click on the Save button  on the Function bar. If the file has been 
saved and no subsequent changes have been made, this button is 
grayed-out and unselectable.

From the keyboard
Use the key combination Control+S.

If the spreadsheet has not been saved previously, then each of these 
actions will open the Save As dialog. Here you can specify the 
spreadsheet name and the location in which to save it.

Note

If the spreadsheet has been previously saved, then saving will 
overwrite the existing copy without opening the Save As 
dialog. If you want to save the spreadsheet in a different 
location or with a different name, then select File > Save As.

Password protection
To protect an entire document from being viewable without a 
password, use the option on the Save As dialog box to enter a 
password. This option is only available for files saved in 
OpenDocument formats or the older OpenOffice.org 1.x formats.
On the Save As dialog box, select the Save with password option, and 
then click Save. You will receive a prompt to type the same password 
in two fields. If the passwords match, the OK button becomes active. 
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Click OK to save the document password-protected. If the passwords 
do not match, you receive the prompt to enter the password again.

Note
Passwords must contain a minimum of 5 characters. Until you 
have entered 5 characters, the OK button remains inactive.

Saving a document automatically
You can choose to have Calc save your spreadsheet automatically at 
regular intervals. Automatic saving, like manual saving, overwrites the 
last saved state of the file. To set up automatic file saving:

1) Select Tools > Options > Load/Save > General.
2) Click on Save AutoRecovery information every. This enables 

the box to set the interval. The default value is 30 minutes. Enter 
the value you want by typing it or by pressing the up or down 
arrow keys.

Saving as a Microsoft Excel document
You may need to share your spreadsheet with other people who do not 
use OpenOffice.org, but use Microsoft Excel instead. Fortunately, 
OpenOffice.org can read and write Excel files.

To save a spreadsheet as a Microsoft Excel file:
1) First save your spreadsheet in OpenOffice.org’s format (*.ods). If 

you do not, any changes you made since the last time you saved 
will only appear in the Microsoft Word version of the document.

2) Then click File > Save As. The Save As dialog (Figure 5) 
appears.

3) In the Save as type drop-down menu, select the type of Excel 
format you need. Click Save.

Caution
From this point on, all changes you make to the spreadsheet 
will occur only in the Microsoft Excel document. You have 
actually changed the name of your document. If you want to go 
back to working with the OpenOffice.org version of your 
spreadsheet, you must open it again.

Tip

To have Calc save documents by default in a Microsoft Excel 
file format, go to Tools > Options > Load/Save > General. 
In the section named Default file format, under Document type, 
select Spreadsheet, then under Always save as, select your 
preferred file format.
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Figure 5. Saving a file in Microsoft Excel format

Saving as a CSV file
To save a spreadsheet as a comma separate value (CSV) file:

1) Choose File > Save As.
2) In the File name box, type a name for the file.
3) In the File type list, select Text CSV and click Save.

You may see the message box shown below. Click Keep Current 
Format.
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4) In the Export of text files dialog, select the options you want. 
Click OK.

Figure 6: Choosing options when exporting to Text CSV

Saving in other formats
Calc can save spreadsheets in a range of formats, including HTML 
(Web pages), through the Save As dialog. Calc can also export 
spreadsheets to ODF and XHTML. See Chapter 5 for more information.

Navigating within spreadsheets
Calc provides many ways to navigate within a spreadsheet from cell to 
cell and sheet to sheet. You can generally use whatever method you 
prefer.

Going to a particular cell

Using the mouse
Place the mouse pointer over the cell and click.

Using a cell reference
Click on the little inverted black triangle just to the right of the 
Name Box (Figure 3). The existing cell reference will be highlighted. 
Type the cell reference of the cell you want to go to and press Enter. 
Or just click into the Name Box, backspace over the existing cell 
reference, and type in the cell reference you want.

Using the Navigator

Click on the Navigator button  in the Standard toolbar (or press 
F5) to display the Navigator. Type the cell reference into the top two 
fields, labeled Column and Row, and press Enter. In Figure 19 on 
page 30, the Navigator would select cell G28.
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Moving from cell to cell
In the spreadsheet, one cell normally has a darker black border. This 
black border indicates where the focus is (see Figure 7). If a group of 
cells is selected, they have a highlight color (usually gray), with the 
focus cell having a dark border.

 
Figure 7. (left) One selected cell and (right) a group of 
selected cells

Using the mouse
To move the focus using the mouse, simply move the mouse pointer 
to the cell where the focus should be and click the left mouse button. 
This changes the focus to the new cell. This method is most useful 
when the two cells are a large distance apart.

Using the Tab and Enter keys
• Pressing Enter or Shift+Enter moves the focus down or up, 

respectively.
• Pressing Tab or Shift+Tab moves the focus right or left, 

respectively.

Using the arrow keys
Pressing the arrow keys on the keyboard moves the focus in the 
direction of the arrows.

Using Home, End, Page Up and Page Down
• Home moves the focus to the start of a row.
• End moves the focus to the column furthest to the right that 

contains data.
• Page Down moves the display down one complete screen and 

Page Up moves the display up one complete screen.
• Combinations of Control and Alt with Home, End, Page Down, 

Page Up, and the arrow keys move the focus of the current cell in 
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other ways. Table 1 describes the keyboard shortcuts for moving 
about a spreadsheet.

Tip Holding down Alt+Arrow key resizes a cell.

Table 1. Moving from cell to cell using the keyboard

Key Combination Movement

→ Right one cell

← Left one cell

↑ Up one cell

↓ Down one cell

Control+→ To last column containing data in that row or to 
Column AMJ

Control+← To first column containing data in that row or to 
Column A

Control+↑ To first row containing data in that column or to Row 
1

Control+↓ To last row containing data in that column or to Row 
65536

Control+Home To Cell A1

Control+End To lower right-hand corner of the square area 
containing data

Alt+PgDn One screen to the right (if possible)

Alt+PgUp One screen to the left (if possible)

Control+PgDn One sheet to the right (in sheet tabs)

Control+PgUp One sheet to the left (in sheet tabs)

Tab To the cell on the right

Shift+Tab To the cell on the left

Enter Down one cell (unless changed by user)

Shift+Enter Up one cell (unless changed by user)
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Customizing the effect of the Enter key
You can customize the direction in which the Enter key moves the 
focus, by selecting Tools > Options > OpenOffice.org Calc > 
General.

The four choices for the direction of the Enter key are shown on the 
right side of Figure 8. It can move data down, right, up, or left. 
Depending on the file being used or on the type of data being entered, 
different directions can be useful.

Figure 8: Customizing the effect of the Enter key

The Enter key can also be used to switch into and out of editing mode. 
Use the options under Input settings in Figure 8 to change the Enter 
key settings.

Moving from sheet to sheet
Each sheet in a spreadsheet is independent of the others, though they 
can be linked with references from one sheet to another. There are 
three ways to navigate between different sheets in a spreadsheet.

Using the keyboard
Pressing Control+PgDn moves one sheet to the right and pressing 
Control+PgUp moves one sheet to the left.

Using the mouse
Clicking one of the sheet tabs at the bottom of the spreadsheet 
selects that sheet.
If you have a lot of sheets, then some of the sheet tabs may be 
hidden behind the horizontal scroll bar at the bottom of the screen. 
If this is the case, then the four buttons at the left of the sheet tabs 
can move the tabs into view. Figure 9 shows how to do this.
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Figure 9. Sheet tab arrows

Notice that the sheets here are not numbered in order. Sheet 
numbering is arbitrary—you can name a sheet as you wish.

Note
The sheet tab arrows that appear in Figure 9 only appear if 
you have some sheet tabs that can not be seen. Otherwise, 
they appear faded as in Error: Reference source not found.

Selecting items in a sheet or spreadsheet

Selecting cells
Cells can be selected in a variety of combinations and quantities.

Single cell
Left-click in the cell. The result will look like the left side of Figure 7. 
You can verify your selection by looking in the Name Box.

Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse:
1) Click in a cell.
2) Press and hold down the left mouse button.
3) Move the mouse around the screen.
4) Once the desired block of cells is highlighted, release the left 

mouse button.

To select a range of cells without dragging the mouse:
1) Click in the cell which is to be one corner of the range of cells.
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2) Move the mouse to the opposite corner of the range of cells.
3) Hold down the Shift key and click.

To select a range of cells without using the mouse:
1) Select the cell that will be one of the corners in the range of cells.
2) While holding down the Shift key, use the cursor arrows to select 

the rest of the range.

The result of any of these methods looks like the right side of Figure 7.

Tip

You can also directly select a range of cells using the Name 
Box. Click into the Name Box as described in “Using a cell
reference” on page 15. To select a range of cells, enter the cell 
reference for the upper left-hand cell, followed by a colon (:), 
and then the lower right-hand cell reference. For example, to 
select the range that would go from A3 to C6, you would enter 
A3:C6.

Range of noncontiguous cells
1) Select the cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single 

cell.
3) Hold down the Control key and click or click-and-drag to select a 

range.
4) Repeat as necessary.

Selecting columns and rows
Entire columns and rows can be selected very quickly in OOo.

Single column or row
To select a single column, click on the column identifier letter (see 
Figure 1).

To select a single row, click on the row identifier number.

Multiple columns or rows
To select multiple columns or rows that are contiguous:

1) Click on the first column or row in the group.
2) Hold down the Shift key.
3) Click the last column or row in the group.
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To select multiple columns or rows that are not contiguous:
1) Click on the first column or row in the group.
2) Hold down the Control key.
3) Click on all of the subsequent columns or rows while holding 

down the Control key.

Entire sheet
To select the entire sheet, click on the small box between the A column 
header and the 1 row header (see Figure 10).

Figure 10. Select All box

You can also use the keyboard to select the entire sheet by pressing 
Control+A.

Selecting sheets
You can select either one or multiple sheets. It can be advantageous to 
select multiple sheets at times when you want to make changes to 
many sheets at once.

Single sheet
Click on the sheet tab for the sheet you want to select. The active sheet 
becomes white (see Error: Reference source not found).

Multiple contiguous sheets
To select multiple contiguous sheets:

1) Click on the sheet tab for the first sheet.
2) Move the mouse pointer over the last sheet tab.
3) Hold down the Shift key and click on the sheet tab.

All the tabs between these two sheets will turn white. Any actions that 
you perform will now affect all highlighted sheets.
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Multiple noncontiguous sheets
To select multiple noncontiguous sheets:

1) Click on the sheet tab for the first sheet.
2) Move the mouse pointer over the second sheet tab.
3) Hold down the Control key and click on the sheet tab.
4) Repeat as necessary.

The selected tabs will turn white. Any actions that you perform will 
now affect all highlighted sheets.

All sheets
Right-click over any one of the sheet tabs and select Select All Sheets 
from the pop-up menu.

Working with columns and rows

Inserting columns and rows
Columns and rows can be inserted individually or in groups.

Note

When you insert a single new column, it is inserted to the left 
of the highlighted column. When you insert a single new row, it 
is inserted above the highlighted row.

Cells in the new columns or rows are formated like the 
corresponding cells in the column or row before (or to the left 
of) which the new column or row is inserted.

Single column or row
A single column or row can be added using the Insert menu:

1) Select the column or row where you want the new column or row 
inserted.

2) Select either Insert > Columns or Insert > Rows.

A single column or row can also be added using the mouse:
1) Select the column or rows where you want the new column or row 

inserted.
2) Right-click the header.
3) Select Insert Rows or Insert Columns.
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Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting 
them one at a time.

1) Highlight the required number of columns or rows by holding 
down the left mouse button on the first one and then dragging 
across the required number of identifiers.

2) Proceed as for inserting a single column or row above.

Deleting columns and rows
Columns and rows can be deleted individually or in groups.

Single column or row
A single column or row can only be deleted by using the mouse:

1) Select the column or row to be deleted.
2) Right-click on the column or row header.
3) Select Delete Columns or Delete Rows from the pop-up menu.

Multiple columns or rows
Multiple columns or rows can be deleted at once rather than deleting 
them one at a time.

1) Highlight the required number of columns or rows by holding 
down the left mouse button on the first one and then dragging 
across the required number of identifiers.

2) Proceed as for deleting a single column or row above.

Tip

Instead of deleting a row or column, you may wish to delete 
the contents of the cells but keep the empty row or column. 
See Chapter 2 (Entering, Editing, and Formating Data) for 
instructions.

Working with sheets
Like any other Calc element, sheets can be inserted, deleted and 
renamed.
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Inserting new sheets
There are several ways to insert a new sheet. The first step for all of 
the methods is to select the sheets that the new sheet will be inserted 
next to. Then any of the following options can be used.

• Click on the Insert menu and select Sheet, or
• Right-click on its tab and select Insert Sheet, or
• Click into an empty space at the end of the line of sheet tabs (see 

Figure 11).

Figure 11. Creating a new sheet

Each method will open the Insert Sheet dialog (Figure 12). Here you 
can select whether the new sheet is to go before or after the selected 
sheet and how many sheets you want to insert. If you are inserting only 
one sheet, there is the opportunity to give the sheet a name.

Figure 12. Insert Sheet dialog

Deleting sheets
Sheets can be deleted individually or in groups.
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Single sheet
Right-click on the tab of the sheet you want to delete and select Delete 
Sheet from the pop-up menu, or click Edit > Sheet > Delete.

Multiple sheets
To delete multiple sheets, select them as described earlier, then either 
right-click over one of the tabs and select Delete Sheet from the pop-
up menu, or click Edit > Sheet > Delete from the Menu bar.

Renaming sheets
The default name for the a new sheet is SheetX, where X is a number. 
While this works for a small spreadsheet with only a few sheets, it 
becomes awkward when there are many sheets.

To give a sheet a more meaningful name, you can:
• Enter the name in the name box when you create the sheet, or
• Right-click on a sheet tab and select Rename Sheet from the 

pop-up menu; replace the existing name with a better one.
• (New in OOo3.1) Double-click on a sheet tab to pop up the 

Rename Sheet dialog.

Note

Sheet names must start with either a letter or a number; other 
characters including spaces are not allowed. Aside from the 
first character of the sheet name, allowed characters are 
letters, numbers, spaces, and the underline character. 
Attempting to rename a sheet with an invalid name will 
produce an error message.

Viewing Calc

Using zoom
Use the zoom function to change the view to show more or fewer cells 
in the window.

In addition to using the Zoom slider (new in OOo 3.1) on the Status bar 
(see page 9), you can open the Zoom dialog and make a selection on 
the left-hand side.

• Go to the View menu and select Zoom, or
• Double-click on the percentage figure in the status bar at the 

bottom of the window.
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Figure 13. Zoom dialog

Optimal
Resizes the display to fit the width of the selected cells. To use this 
option, you must first highlight a range of cells.

Fit Width and Height
Displays the entire page on your screen.

Fit Width
Displays the complete width of the document page. The top and 
bottom edges of the page may not be visible.

100%
Displays the document at its actual size.

Variable
Enter a zoom percentage of your choice.

Freezing rows and columns
Freezing locks a number of rows at the top of a spreadsheet or a 
number of columns on the left of a spreadsheet or both. Then when 
scrolling around within the sheet, any frozen columns and rows remain 
in view.

Figure 14 shows some frozen rows and columns. The heavier horizontal 
line between rows 3 and 14 and the heavier vertical line between 
columns C and H denote the frozen areas. Rows 4 through 13 and 
columns D through G have been scrolled off the page. Because the first 
three rows and columns are frozen into place, they remained.
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Figure 14. Frozen rows and columns

You can set the freeze point at one row, one column, or both a row and 
a column as in Figure 14.

Freezing single rows or columns
1) Click on the header for the row below where you want the freeze 

or for the column to the right of where you want the freeze.
2) Select Window > Freeze.

A dark line appears, indicating where the freeze is put.

Freezing a row and a column
1) Click into the cell that is immediately below the row you want 

frozen and immediately to the right of the column you want 
frozen.

5) Select Window > Freeze.
Two lines appear on the screen, a horizontal line above this cell 
and a vertical line to the left of this cell. Now as you scroll around 
the screen, everything above and to the left of these lines will 
remain in view.

Unfreezing
To unfreeze rows or columns, select Window > Freeze. The check 
mark by Freeze will vanish.

Splitting the screen
Another way to change the view is by splitting the window—also known 
as splitting the screen. The screen can be split horizontally, vertically, 
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or both. You can therefore have up to four portions of the spreadsheet 
in view at any one time.

Figure 15. Split screen example

Why would you want to do this? Imagine you have a large spreadsheet 
and one of the cells has a number in it which is used by three formulas 
in other cells. Using the split-screen technique, you can position the 
cell containing the number in one section and each of the cells with 
formulas in the other sections. Then you can change the number in the 
cell and watch how it affects each of the formulas.

Splitting the screen horizontally
To split the screen horizontally:

1) Move the mouse pointer into the vertical scroll bar, on the right-
hand side of the screen, and place it over the small button at the 
top with the black triangle.

Figure 16. Split screen bar on 
vertical scroll bar

2) Immediately above this button, you will see a thick black line 
(Figure 16). Move the mouse pointer over this line, and it turns 
into a line with two arrows (Figure 17).
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Figure 17. Split-screen bar on 
vertical scroll bar with cursor

3) Hold down the left mouse button, and a gray line appears, 
running across the page. Drag the mouse downwards, and this 
line follows.

4) Release the mouse button and the screen splits into two views, 
each with its own vertical scroll bar. You can scroll the upper and 
lower parts independently.

Notice in Figure 15, the Beta and the A0 values are in the upper part 
of the window and other calculations are in the lower part. Thus, you 
can make changes to the Beta and A0 values and watch their effects on 
the calculations in the lower half of the window.

Tip
You can also split the screen using a menu command. Click in a 
cell immediately below and to the right of where you wish the 
screen to be split, and choose Window > Split.

Splitting the screen vertically
To split the screen vertically:

1) Move the mouse pointer into the horizontal scroll bar at the 
bottom of the screen and place it over the small button on the 
right with the black triangle.

Figure 18: Split bar on 
horizontal scroll bar

2) Immediately to the right of this button is a thick black line (Figure
18). Move the mouse pointer over this line and it turns into a line 
with two arrows.

3) Hold down the left mouse button, and a gray line appears, 
running up the page. Drag the mouse to the left and this line 
follows.
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4) Release the mouse button, and the screen is split into two views, 
each with its own horizontal scroll bar. You can scroll the left and 
right parts of the window independently.

Removing split views
To remove a split view:

• Double-click on each split line, or
• Click on and drag the split lines back to their places at the ends of 

the scroll bars, or
• Select Window > Split. This will remove all split lines at the 

same time.

Using the Navigator
In addition to the cell reference boxes (labeled Column and Row), the 
Navigator provides several other ways to move quickly through a 
spreadsheet and find specific items.

To open the Navigator, click its icon  on the Standard toolbar, or 
press F5, or choose Edit > Navigator on the Menu bar. You can dock 
the Navigator to either side of the main Calc window or leave it 
floating. (To dock or float the Navigator, hold down the Control key and 
double-click in an empty area near the icons at the top.)

Figure 19: The Navigator in Calc

The Navigator displays lists of all the objects in a spreadsheet 
document, grouped into categories. If a plus sign appears next to a 
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category, this indicates that at least one object of this kind exists. To 
open a category and see the list of items, click on the plus sign.

To hide the list of categories and show only the icons at the top, click 

the Contents icon . Click this icon again to show the list.

Table 1 summarizes the functions of the icons at the top of the 
Navigator.

Table 2: Function of icons in the Navigator
Icon Action

Specifies the current data range denoted by the position of the 
cell cursor.

Moves to the cell at the beginning or end of the current data 
range, which you can highlight using the Data Range button.

Contents. Shows or hides the list of categories.

Toggle. Switches between showing all categories and showing 
only the selected category.

Displays all available scenarios. Double-click a name to apply that 
scenario. See Chapter 7 (Data Analysis) for more information.

Drag Mode. Select hyperlink, link, or copy. See “Choosing a drag
mode” for details.

Moving quickly through a document
The Navigator provides several convenient ways to move around a 
document and find items in it:

• To jump to a specific cell in the current sheet, type its cell 
reference in the Column and Row boxes at the top of the 
Navigator.

• When a category is showing the list of objects in it, double-click 
on an object to jump directly to that object’s location in the 
document.
To see the content in only one category, highlight that category 
and click the Toggle icon. Click the icon again to display all the 
categories. 

• Use the Start and End icons to jump to the first or last cell in the 
selected data range.
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Tip

Ranges, scenarios, pictures, and other objects are much easier 
to find if you have given them names when creating them, 
instead of keeping Calc’s default Graphics 1, Graphics 2, 
Object 1, and so on—which may not correspond to the position of 
the object in the document.

Choosing a drag mode
Sets the drag and drop options for inserting items into a document 
using the Navigator.

Insert as Hyperlink
Creates a hyperlink when you drag and drop an item into the 
current document.

Insert as Link
Inserts the selected item as a link where you drag and drop an 
object into the current document. 

Insert as Copy
Inserts a copy of the selected item where you drag and drop in the 
current document. You cannot drag and drop copies of graphics, 
OLE objects, or indexes.
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