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Introduction
This chapter describes how to create and maintain a table of contents, 
an index, and a bibliography for a text document using OpenOffice.org 
Writer. To understand the instructions, you need to have a basic 
familiarity with Writer and styles (see Chapters 6 and 7 for more about 
styles).

Tables of contents
Writer’s table of contents feature lets you build an automated table of 
contents from the headings in your document. Before you start, make 
sure that the headings are styled consistently. For example, you can 
use the Heading 1 style for chapter titles and the Heading 2 and 
Heading 3 styles for chapter subheadings.

This section shows you how to:
• Create a table of contents quickly, using the defaults.
• Customize a table of contents.

Note You can use custom styles for the different levels in the table 
of contents as well. This document uses the default styles for 
simplicity.

Creating a table of contents quickly
Although tables of contents can be customized extensively in Writer, 
most of the time you will probably find the default to be fine. Creating 
a quick table of contents is simple:

1) When you create your document, use the following paragraph 
styles for different heading levels (such as chapter and section 
headings): Heading 1, Heading 2, and Heading 3. These are what 
will appear in your table of contents. You can use more levels of 
headings, but the default setting is to use only the first three 
levels in the table of contents. It could look like Figure 1 if you 
used the default styles.

2) Place the cursor where you want the table of contents to be 
inserted.

3) Select Insert > Indexes and Tables > Indexes and Tables.
4) Change nothing in the Insert Index/Table dialog box (Figure 3). 

Click OK. The result will look like Figure 2.
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Figure 1: Headings example

Figure 2: Table of contents example

If you add or delete text (so that headings move to different pages) or 
you add, delete, or change headings, you need to update the table of 
contents. To do this:

1) Place the cursor within the table of contents.
2) Right-click and select Update Index/Table from the pop-up 

menu.

Note

If you cannot place the cursor in the table of contents, choose 
Tools > Options > OpenOffice.org Writer > Formatting 
Aids, and then select Enable in the Cursor in protected areas 
section.
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Tip

You can customize an existing table of contents at any time. 
Right-click anywhere in it and select Edit Index/Table from 
the pop-up menu. Continue as described in the next section, 
“Customizing a table of contents”.

Customizing a table of contents
To insert a customized table of contents into your document:

1) Place the cursor where you want the table of contents to appear.
2) From the main menu, choose Insert > Indexes and Tables > 

Indexes and Tables. The Insert Index/Table dialog box opens.

Figure 3. Index/Table page of Insert Index/Table dialog box

The Insert Index/Table dialog box (Figure 3) has five pages. Any or all 
of them can be used when creating or editing a table of contents:

• Use the Index/Table page to set the attributes of the table of 
contents.

• Use the Entries and Styles pages to format the entries in the table 
of contents.

• Use the Columns page to put the table of contents into more than 
one column.

• Use the Background page to add color or a graphic to the 
background of the table of contents.
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You can display a preview box, located on the left-hand side of each 
tab, to show as you work how the table of contents will look. (If you do 
not see the preview box, select Preview in the lower right-hand corner 
of the dialog box.) The illustrations in this chapter show the dialog box 
as it appears with the preview box hidden.

After making all your changes, click OK to save the table of contents 
so it appears in your document.

Using the Index/Table page
Use the Index/Table page, pictured in Figure 3, to set the attributes of 
the table of contents.

Adding a title
To give the table of contents a title, type it in the Title field. (You can 
change an existing title by typing over it.) To delete the title, clear the 
Title field.

Setting the type of index
You can create several types of indexes. They include:

• Table of Contents
• Alphabetical Index
• Illustration Index
• Table of Objects
• Bibliography

You can also create user-defined indexes.

Note You can only change the type of index when you first create it. 
Once you define an index type (for example, make a table of 
contents) you cannot change the type.

Choosing the scope of the table of contents
From the for drop-down list in the Create index/table area, select 
Entire document. There is an additional option to create a table of 
contents for just the current chapter. For more information, refer to 
Help > OpenOffice.org Writer > Contents.
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Creating a table of contents from an outline
This selection creates the table of contents using outline levels; that is, 
paragraphs formatted with one of the predefined heading styles 
(Heading 1-10) are added to the table of contents in order.

Click on the (...) button next to the option to change the numbering 
properties of the table of contents. This can be useful if you want to 
put numbers in front of each level of the contents, as in Figure 4.

Figure 4: Table of contents with numbers

Creating from index marks
This selection adds any index entries that you have inserted into the 
document by using Insert > Indexes and Tables > Entry. Normally 
you would not use this selection for a table of contents.

Protecting against manual changes
To stop the table of contents being changed accidentally, select the 
Protected against manual changes option. If this option is selected, 
the table of contents can only be changed using the right-click menu or 
the Insert Table/Index dialog box. If the option is not selected, the table 
of contents can be changed directly on the document page, just like 
other text.

Tip
Any manual changes to a table of contents are lost when you 
update it.

Changing the number of levels included
Writer displays a default setting of 10 levels of headings when it builds 
the table of contents (or the number of levels used in the document, 
whichever is smaller). To change the number of levels, enter the 
required number in the Evaluate up to level box.
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Creating from additional styles
Writer automatically assigns to the table of contents all paragraphs 
formatted with the default heading styles (Heading 1, Heading 2, and 
so on). To assign paragraphs formatted with other styles, including 
custom styles:

1) In the Create from area, select Additional Styles.
2) Click the (...) button to the right of Additional Styles. The Assign 

Styles dialog box (Figure 5) opens.

Figure 5. Assign Styles dialog box

3) In the Not applied column, click the style that you want to assign 
to the table of contents.

4) Use the >> button to move the selected style to the desired 
outline level. For example, to have paragraphs formatted with the 
selected style to appear as top-level entries in the table of 
contents, click the >> button once to move the style into the 1 
column. To move the style in the opposite direction, use the << 
button.

5) Click OK to save your changes and return to the Index/Table tab 
or click Cancel to return without saving your changes.

Note If the Outline option is selected, any changes you make to the 
position of one of the predefined Heading styles will be 
superseded by the default outline structure.
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Using the Entries page
Use the Entries page, pictured in Figure 6, to define and format the 
entries in the table of contents. For each outline level, you can add and 
delete elements such as chapter (heading) numbers, and you can also 
apply character styles to individual elements.

Figure 6. Entries page of Insert Index/Table dialog box

To begin, click a level number in the Level column to select the outline 
level whose elements you want to format. (You will be able to apply 
changes to all outline levels later.) The Structure line displays the 
elements for entries in that level. Each button on the Structure line 
represents one element:

• The E# button represents the “chapter number”, which means 
the heading number, not just for chapters but also for other levels 
of headings.

• The E button represents the entry text.
• The T button represents a tab stop.
• The # button represents the page number.
• The LS button represents the start of a hyperlink. (This button 

does not appear on the default Structure line.)
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• The LE button represents the end of a hyperlink. (This button 
does not appear on the default Structure line.)

Each white field on the Structure line represents a blank space. You 
can add custom text if you desire.

Note

If the chapter number defined for your document includes the 
word “Chapter” before the number itself, then the E# field in 
the table of contents will also include the word “Chapter”. If 
you want to include the chapter number with the page number 
(for example, in the style “1-1, 1-2, ...”) , you will find that the 
page number appears in the table of contents as “Chapter 1-
1”, which is probably not what you want.

Changing elements
To change an element in the Structure line, click the button 
representing that element and then click the element that you want to 
substitute in the row of buttons just below the Structure line. For 
example, to change a chapter number to a tab stop, click the E# 
button on the Structure line (it shows then as being pressed) and then 
click the Tab stop button in the row of available elements.

Deleting elements
To delete an element from the Structure line, click the button 
representing that element and then press the Delete key on your 
keyboard. For example, to delete a tab stop, click the T button and 
then press the Delete key.

Adding elements
To add an element to the Structure line:

1) Place the cursor in the white field to the left of where you want to 
insert the element.

2) Click one of the five buttons just below the Structure line. (For 
example, to add a tab stop, click the Tab stop button.) A button 
representing the new element appears on the Structure line.

Hyperlinking an entry
To change the default Structure line so that the chapter number and 
the entry text form a hyperlink, follow these steps:

1) On the Structure line, place the cursor in the white field to the 
left of the E# button.
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2) Click the Hyperlink button. An LS button, representing the start 
of the hyperlink, appears on the Structure line.

3) On the Structure line, place the cursor in the white field to the 
right of the E button.

4) Click the Hyperlink button again. An LE button, representing the 
end of the hyperlink, appears on the Structure line.

Figure 7 represents the completion of the above steps. The number 
and the text of the entries on that level will now be hyperlinks.

Figure 7: Hyperlink in table of contents

Applying character styles
To apply a character style to an element:

1) On the Structure line, click the button representing the element 
to which you want to apply a style.

2) From the Character Style drop-down list, select the desired style. 
Writer applies the selected style to the selected element.

To view or edit the attributes of a character style, select the style from 
the Character Style drop-down list and then click the Edit button.
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Tip

The default character style for hyperlinks is Internet Link, 
which by default is underlined and shown in blue. If you want 
the table of contents entries to work as hyperlinks, but not 
have them underlined and blue, you can change the attributes 
of the Internet Link character style. However, this changes the 
attributes of all hyperlinks in the document.
If you want other hyperlinks (for example, website addresses) 
to remain in the default style, you can change the character 
style selection for table of contents entries to Index Link (in 
Figure 7). If necessary, change the attributes for Index Link to 
what you want.

Applying changes to all outline levels
To apply the displayed structure and formatting to all outline levels, 
click the All button.

Tab position relative to Paragraph Style indent
When this option is selected, entries are indented according to the 
settings of their individual formats. Where a paragraph style with an 
indent on the left is in use, tab stops will be relative to this indent. If 
this option is not selected, tab stops will be relative to the left margin 
position.

Using the Styles page
Use the Styles page, pictured in Figure 8, to apply paragraph styles to 
the table of contents. You can apply a different paragraph style to each 
outline level of the table.

To apply a paragraph style to an outline level:
1) In the Levels list box, select the desired outline level by clicking 

it.
2) In the Paragraph Styles list box, click the paragraph style to 

apply.
3) Click the < button to apply the selected paragraph style to the 

selected outline level.

The styles of the level appears in the square brackets in the Levels list.
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Figure 8. Styles page of Insert Index/Table dialog box

To remove paragraph styling from an outline level:
1) In the Levels list box, select the desired outline level by clicking 

it.
2) Click the Default button.

To view or edit the attributes of a paragraph style, click the style in the 
Paragraph Styles list box and then click the Edit button.

Note
Changes to a paragraph style will affect any text in the 
document that is formatted using this style, not just the format 
of the table of contents.
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Using the Columns page
Use the Columns page (Figure 9) to change the number of columns for 
the table of contents.

Figure 9. Columns page of the Insert Index/Table dialog box

Adding multiple columns
To display the table of contents in more than one column:

1) Either enter the number of columns desired in the box labeled 
Columns or select the icon representing the number of columns.

2) To evenly distribute the columns according to the page width, 
check the AutoWidth box. If it is unchecked, you can manually 
set each of the following by altering the associated spin box:
• Width between each of the columns
• Spacing between each of the columns

3) You can choose to have a separator line between the columns:
• Line: The width of the line.
• Height: The height of the line.
• Position: Relative position of the line to the table (top, middle, 

or bottom) if the height is less than 100%.
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Using the Background page
Use the Background page, pictured in Figure 10, to add color or a 
graphic to the background of the table of contents.

Adding color
To add color to the background of the table of contents, select from the 
color grid.

Note

Even though the table of contents may have a shade behind it 
while editing, it is actually not shaded by default. It appears 
shaded because it is a field and will appear to have the same 
shading all fields have.

Figure 10. Background page of Insert Index/Table 
dialog box, showing Color choices

Adding a graphic
To add a graphic to the background of the table of contents:

1) From the As drop-down list, select Graphic. The Background tab 
now displays the graphics options, as shown in Figure 11.

2) Click the Browse button. The Find graphics dialog box opens.
3) Find the graphic file you want and then click the Open button. 

The Find graphics dialog box closes and the selected graphic 
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appears in the graphic preview box on the right-hand side of the 
Background tab. (If you do not see the graphic, select Preview.)

4) To embed the graphic in your document, deselect Link. To link 
the graphic to the document but not embed it, select Link.

5) In the Type area of the Background tab, choose how you want the 
background graphic to appear:
• To position the graphic in a specific location, select Position 

and then click the desired location in the position grid.
• To stretch the graphic to fill the entire background area, 

select Area.
• To repeat the graphic across the entire background area, 

select Tile.

Figure 11. Graphic options on the Background page of 
the Insert Index/Table dialog box

Deleting color or graphics
To delete color or graphics from the table background:

1) From the As drop-down list, select Color.
2) Click No Fill on the color grid.
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Maintaining a table of contents
This section shows you how to:

• Edit an existing table of contents.
• Update a table of contents when changes are made to the 

document.
• Delete a table of contents.

Editing a table of contents
To edit an existing table of contents:

1) Click anywhere in the table of contents and then right-click.

Tip

If you cannot click in the table of contents, it is probably 
because it is protected. To disable this protection, choose 
Tools > Options > OpenOffice.org Writer > Formatting 
Aids, and then select Enable in the Cursor in protected areas 
section. If you wish to edit the table of contents without 
enabling the cursor, you can access it from the Navigator as 
explained on page 20.

2) From the pop-up menu, choose Edit Index/Table. The Insert 
Index/Table dialog box (Figure 3 on page 8) opens and you can 
edit and save the table as described in the previous section.

You can also access the Index/Table dialog box from the Navigator 
(Figure 12).

1) Open the Navigator (press F5).
2) Click the + sign next to Indexes.
3) Right-click on the desired index.

Select Index > Edit.

Updating a table of contents
Writer does not update the table of contents automatically, so after any 
changes to the headings, you must update it manually. To update a 
table of contents when changes are made to the document:

1) Click anywhere in the table of contents and then right-click.
2) From the pop-up menu, choose Update Index/Table. Writer 

updates the table of contents to reflect the changes in the 
document.
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Figure 12: Access an index from 
the Navigator

Note
You can also update the index from the Navigator by selecting 
Index > Update from the menu in Figure 12.

Deleting a table of contents
To delete the table of contents from a document:

1) Click anywhere in the table of contents and then right-click.
2) From the pop-up menu, choose Delete Index/Table. Writer 

deletes the table of contents.

Note

Writer will not prompt you to confirm the delete! Use caution 
when deleting a table of contents.
You can also delete the index from the Navigator by selecting 
Index > Delete from the menu shown in Figure 12.
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Alphabetic indexes
An alphabetical index (referred to as an index) is a list of keywords or 
phrases used throughout a document that, if listed in order, may help 
the reader find information quickly. Generally an index is found in the 
back of a book or document and lists several keywords or phrases in 
alphabetical order with page numbers.

This section describes how to:
• Add index entries.
• Create an alphabetic index quickly.
• Customize the display of index entries.
• Customize the appearance of the index.
• View and edit existing index entries.

Adding index entries
Before you can create an index, you must create some index entries.

1) Either highlight the word or phrase to add to the index or place 
the cursor at the beginning of the word or phrase. (If you want to 
add multiple words as one entry it will generally be better to 
highlight the entire phrase.)

2) Click Insert > Indexes and Tables > Entry to display a dialog 
box similar to that shown in Figure 13. You can accept the word 
or phrase shown in the Entry box or change it to whatever you 
want. If you placed the cursor at the beginning of a word, clicking 
on the Entry text box inserts the word into the text box.

Figure 13. Inserting an index entry

3) Click Insert to create the entry.
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4) You can create multiple entries without closing the dialog box. For 
each one:
• Click at the location in the document that you want to index.
• Click again on the dialog box.
• Change the entry if needed, and click Insert.

5) When you are satisfied with the entries, click Close.

Note

If field shading is active (see Tools > Options > 
OpenOffice.org > Appearance > Text Document > Field 
shadings), when a selected word or phrase has been added to 
the index, it is shown in the text with a gray background. Index 
entries whose text is different from the text in the document 
are marked by a small gray rectangle.

Tip
You can also open the Insert Index Entry dialog box by clicking 
the Entry icon on the Insert toolbar, as shown in Figure 14.

Figure 14. Entry icon on Insert toolbar

Creating an alphabetic index quickly
Now that there are index entries, you can create the index.

Although indexes can be customized extensively in Writer, most of the 
time you will need to make only a few choices. To create an index 
quickly:

1) Place the cursor where you want to add the index and click 
Insert > Indexes and Tables > Indexes and Tables.

2) In the Type box on the Index/Table page of the Insert Index/Table 
dialog box (Figure 15 on page 25), select Alphabetical Index.

3) In the Options section, you may want to uncheck Case sensitive.
4) Click OK.

If you add, delete, or change the text of index entries, you need to 
update the index. Writer does not update an index automatically. To do 
this, follow the steps outlined in “Updating a table of contents” on page 
20.
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Customizing index entries
Below is a brief explanation of the fields in the Insert Index Entry 
dialog box and how to use them.

• Index – The type of index this entry is for. The default is 
Alphabetical Index, but you can use this field to create extra 
entries for a table of contents or user-defined indexes or lists of 
almost anything. For example, you might want an index 
containing only the scientific names of species mentioned in the 
text, and a separate index containing only the common names of 
species. See “Other types of indexes” on page 30.

• Entry – The word or phrase to be added to the selected index. 
This word or phrase does not need to be in the document itself; 
you can add synonyms and other terms that you want to appear in 
the index.

• 1st key – An index key is an index entry that has no associated 
page number and has several subentries that do have page 
numbers. Keys are useful ways of grouping related topics. (See 
“Example of using an index key” on page 24.)

• 2nd Key – You can have a three-level index, where some of the 
first-level keys have level-2 entries that are also keys (without 
page numbers). This degree of index complexity is not often 
necessary.

• Main entry – When the same term is indexed on several pages, 
often one of those pages has more important or detailed 
information on that topic, so it is the main entry. To make the 
page number for the main, or most important, entry stand out, 
select this option and then define the character style for the page 
number of a main index entry to be bold, for example.

• Apply to all similar texts – Select this option if you want Writer to 
automatically identify and mark any other word or phrase that 
matches the current selection. The Match case and Whole 
words only options become available if this option is selected.

Example of using an index key
An index key is a primary entry under which subentries are grouped. 
For example, you might want to create a grouping similar to this:

OpenOffice.org
Writer.. .5
Calc....10
Impress15
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In this example, OpenOffice.org is the 1st key. The subentries (with the 
page numbers showing) are the indexed entries. To insert an index 
entry for the topic Writer, on the Insert Index Entry dialog box (Figure
13 on page 22), type Writer in the Entry box and OpenOffice.org in 
the 1st key box.

Customizing the appearance of an index
The Insert Index/Table dialog box (Figure 15) has five pages. Any or all 
of them can be used to customize the appearance of an index.

• Use the Index/Table page to set the attributes of the index.
• Use the Entries and Styles pages to format the entries in the index.
• Use the Columns tab to put the index into more than one column.
• Use the Background tab to add color or a graphic to the 

background of the index.

Figure 15. Index/Table page of Insert Index/Table dialog box

The preview box, located on the left-hand side of the dialog box, shows 
as you work how the index will look. (If you do not see the preview box, 
select Preview in the lower right-hand corner of the dialog box.)

After making your changes, click OK to save the index so it appears in 
your document.
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Using the Index/Table page
Use the Index/Table page (Figure 15) to set the basic attributes of the 
index.

1) To give the Index a title, type it in the Title field. (You can change 
an existing title by typing over it.) To delete the title, clear the 
Title field.

2) To prevent the index from being changed accidentally, select 
Protected against manual changes. If this option is selected, 
the index can only be changed using the right-click menu or the 
Insert Table/Index dialog box. If the option is not selected, the 
index can be changed directly on the document page, just like 
other text.

Tip Any manual changes to an index are lost when you update it.

3) From the drop-down list in the Create index/table area, select 
Entire document. You can also choose to create an index for just 
the current chapter.

4) Various other options determine how the index handles entries:
• Combine identical entries. Defines how identical entries are 

dealt with. Normally each page number of an indexed word or 
phrase will be shown in the index; however these can be 
combined using the Combine identical entries with p or 
pp. If you want a page range displayed, select Combine with 
– (which will produce something similar to 23–31). If you want 
different entries based on what letters are capitalized, select 
Case sensitive.

• AutoCapitalize entries. Automatically capitalizes the first 
letter of each entry regardless of how they show within the 
document itself.

• Keys as separate entries. For the keys to have their own 
page numbers, select this option.

• Concordance file. Enables a list of words in an external file 
to be imported (select using the File button) and then used 
within the index. The concordance file has a special file 
format; for further information, refer to concordance file in 
Help > OpenOffice.org Help. Using a concordance file can 
speed up production of an index, but unless the words are 
very carefully selected and you edit the index afterwards, the 
resulting index can be full of entries for minor mentions of a 
term, making it less useful than a more selective index.
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• Sort. Defines how the entries are sorted when displayed. The 
only option is alphanumeric, but you can define which 
language alphabet will be used.

Using the Entries page
Use the Entries page to set exactly how and what will be displayed for 
each of the entries. The page is similar to Figure 16.

Figure 16. Entries page for creating an alphabetical index

To begin, click a number in the Level column to select the index level 
whose elements you want to format. (You will be able to apply your 
changes to all index levels later.) The Structure line displays the 
elements for entries in that level. Each button on the Structure line 
represents one element:

• The E button represents the entry text.
• The T button represents a tab stop.
• The # button represents the page number.
• The CI button represents chapter information. This may not be 

displayed immediately, but can be added.
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Each white field on the Structure line represents a blank space. You 
can add custom text if you desire.

Changing elements
To change an element in the Structure line, click the button 
representing that element and then click the element that you want to 
substitute in the row of buttons just below the Structure line. For 
example, to change entry text to a tab stop, click the E# button on the 
Structure line (it shows then as being pressed) and then click the Tab 
stop button in the row of available elements.

Deleting elements
To delete an element from the Structure line, click the button that 
represents that element and then press the Delete key on your 
keyboard. For example, to delete a tab stop, click the T button and 
then press the Delete key.

Adding elements
To add an element to the Structure line:

1) Place the cursor in the white field to the left of where you want to 
insert the element.

2) Click one of the buttons below the Structure line. (For example, to 
add a tab stop, click the Tab stop button.) A button representing 
the new element appears on the Structure line.

Applying character styles
Each of the items that can be added to the Structure line may have 
additional formatting. For example, you may want the page number to 
be a different size from the rest of the index text. To do this, apply a 
character style to one of the elements in the Structure line.

To apply a character style to an element:
1) On the Structure line, click the button representing the element 

to which you want to apply a style.
2) Select the desired style from the Character Style drop-down list. 

Writer applies the style to the selected element.

To view or edit the attributes of a character style, select the style from 
the Character Style drop-down list and then click the Edit button.
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Formatting entries
Apply additional formatting using the options in the Format section.

• Alphabetical delimiter. This will display, as a means of 
separating index entries, the first letter of all the subsequent 
index entries. For example:

A
apple,  4
author, 10

B
break,  2
bus, 4

• Key separated by commas. Arranges the entries in the index on 
the same line but separated by commas.

• Tab position relative to Paragraph Style indent. When 
checked, entries are indented according to the settings of their 
individual formats. Where a paragraph style with an indent on the 
left is in use, tab stops will be relative to this indent. If this option 
is not selected, tab stops will be relative to the left margin 
position.

Using the Styles, Columns and Background pages
Refer to “Using the Styles page” on page 15, “Using the Columns
page” on page 17, and “Using the Background page” on page 18.

Maintaining an index
To modify the appearance of an index:

1) Click anywhere in the index and then right-click.
2) From the pop-up menu, choose Edit Index/Table. The Insert 

Index/Table dialog box opens and you can edit and save the index 
using the five tabs described in the previous section.

To update or delete an index, follow the process described in the 
sections “Updating a table of contents” and “Deleting a table of
contents” on page 20.
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Viewing and editing existing index entries
Once you have added the initial entries, you can make some 
amendments or add some new ones. You can view and edit these using 
the following steps:

1) Ensure that field shading is active (Tools > Options > 
OpenOffice.org> Appearance > Text Document > Field 
shadings), so you can locate index entries more easily.

2) Place the cursor immediately to the left of an existing index entry 
in the body of your document and select Edit > Index Entry. 
Alternatively, right-click on the word or phrase and from the pop-
up menu select Index Entry.

3) A dialog box similar to Figure 17 appears. You can move through 
the various index entries using the forward and back arrow 
buttons. If there is more than one entry for a single word or 
phrase, then you can scroll through each of the entries.

4) Make the necessary modifications or additions to the index 
entries and, when finished, click OK.

Figure 17. Viewing and editing index entries

Other types of indexes
An alphabetical index is not the only type of index that you can build 
with Writer. Other types of indexes supplied with Writer include those 
for illustrations, tables, and objects, and you can even create a user-
defined index. For example, you might want an index containing only 
the scientific names of species mentioned in the text, and a separate 
index containing only the common names of species.

To create other indexes:
1) Place the cursor where you want the index created.
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2) Select Insert > Indexes and tables > Indexes and tables from 
the menu bar.

3) On the Insert Index/Table dialog box (Figure 18), in the Type 
dropdown list, select the index wanted.

4) Modify the various pages, which are very similar to those 
discussed in previous sections.

5) Select OK when everything has been set.

Figure 18. Creating other types of indexes

Bibliographies
A bibliography is useful for displaying references used throughout a 
document. These references are either stored in a bibliographic 
database or within the document itself.

This section shows you how to:
• Create a bibliographic database; add and maintain entries.
• Add a reference into a document.
• Format the bibliography.
• Update and edit an existing bibliography.

For most of this section, the database table used is the sample one that 
comes with Writer. For information on creating a new table in the 
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bibliographic database, see Chapter 8 (Getting Started with Base) in 
the Getting Started guide.

Creating a bibliographic database
Although you can create references within the document itself, 
creating a bibliographic database allows reuse in other documents and 
saves a lot of time.

Select Tools > Bibliography Database. A window similar to that in 
Figure 19 is shown.

Figure 19. Bibliography Database main window

You can use the top portion of this window to:

• Filter for specific records within the database (see “Filtering
records” below).

• Change some details of columns in the database (see “Changing
column details”).

• Select an alternative data source (another database or table) or 
change details of the fields in the database.
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The middle portion of the window shows each of the records in a table 
layout similar to that of a spreadsheet. Additional fields can be viewed 
by scrolling the table to the right.

The bottom portion of the window shows the contents of the selected 
record.

Filtering records
To set up a filter for specific records within the bibliographic database, 
select Tools > Filter from the Bibliographic Database menu bar. On 
the Standard Filter dialog box (Figure 20), choose the fields, conditions 
and values for the filter and click OK.

Figure 20. Setting up a filter for the bibliographic database

Changing column details
To change the details of columns in the bibliographic database, click 
the Column Arrangement button near the top of the window. The 
Column Layout for Table biblio dialog box (Figure 21) is displayed.

Figure 21. Changing column layout for bibliographic database
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Changing the data source
To change the data source in use (for example, if you have more than 
one bibliographic database for different purposes), click the Data 
Source button near the top of the window. The Choose Data Source 
dialog box (Figure 22) is displayed.

Figure 22: Choosing a different data source for the bibliographic 
database

Changing field details
You can make changes to the bibliography database (for example, 
rename fields or change the length of fields) by doing the following:

1) In the main document (not the Bibliography Database screen), 
press F4 or click View > Data Sources to open the data source 
window, similar to Figure 23.

2) Make sure that the Bibliography database is selected as well as 
the correct table. You may have to expand some levels to be able 
to select the correct ones.

Figure 23. Data Source view of Bibliography database
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3) Right-click on the table entry (biblio in the example) and select 
Edit Database File from the pop-up menu. This opens a window 
similar to Figure 24, which is the main menu for Base, the 
database component of OpenOffice.org.

Figure 24. Main window for working with databases

4) If Tables (under the Database view) is not selected, select it now. 
5) Right-click on the biblio table name in the Tables section and 

select Edit from the pop-up menu to display a window similar to 
that shown in Figure 25.

6) You can now select each of the rows and modify the Field 
Properties as required.

7) When finished, you will be asked to confirm that you want the 
changes saved.

Note
For more information on how to use OOo’s database features, 
see Chapter 8 (Getting Started with Base) in the Getting 
Started book.
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Figure 25. Modify table properties window

Adding entries to the database
To add entries to the database:

1) You can add records directly into the database using the lower 
portion of the window shown in Figure 19 on page 32.

2) Complete each of the fields as required. Use the Tab key to move 
between fields.

3) It is best to use a unique name in the Short name field. This is 
used when inserting entries into documents.

4) To complete the entry move to the last field and press Tab once 
more.

Note
The Identifier column in the upper portion of the Bibliography 
Database window is labeled Short name in the lower portion of 
the window.

If your document requires [Author, date] style citations, use the 
Identifier (Short name) field of the database to record the information 
in the required format. If you are using a simple citation numbering 
system (for example, [1],[2],...), use a unique reference of some sort in 
the Identifier (Short name) field. Writer will auto-number entries based 
on the position within the document.
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Maintaining entries in the database
To maintain entries in the database, use the Bibliography Database 
window as in the previous section. Click on the appropriate field and 
modify the text as appropriate.

Modified entries are saved automatically to the database when the 
cursor moves off the record.

Adding a reference (citation) into a document
Writer supports two ways of showing references (citations) in the text 
of a document:

• Using authors’ names and dates of the referenced documents, for 
example [Smith, 2004], as recorded in the Identifier (Short name) 
of each bibliographic entry.

• By numbering the referenced documents in the sequence they 
occur in the text, for example [1].

Tip
To specify which citation style is used in the document, use the 
Index/Table page on the Insert Index/Table dialog, described 
on page 39.

To add references from the bibliographic database into a document:
1) Place the cursor where you want the reference to appear.
2) From the main menu, choose Insert > Indexes and tables > 

Bibliographic entry.
3) In the Insert Bibliographic Entry dialog box, shown in Figure 26, 

choose From bibliography database at the top of the dialog 
box. (You can also insert a reference from the document itself by 
selecting From document content, but that method is not 
covered in this chapter.)

Figure 26. Inserting bibliographic 
entries into a document

Bibliographies 37



4) Select the reference from the Short name dropdown list near the 
bottom of the dialog box. The Author and Title of the selected 
reference are shown in the middle of the dialog box, to help you 
verify that it is the reference you want.

5) To insert the reference into the document, click Insert.
6) You can keep the dialog box open and insert another reference 

into the document; you don’t need to close and reopen it.
7) When you have finished inserting all the references, select Close.

Formating the bibliography
Formatting the bibliography involves choices made in two places:

• Insert Index/table dialog (covered in this section)
• Bibliography 1 paragraph style (see page 40)

To create the bibliography:
1) Place the cursor at the point where you wish to insert the 

bibliography.
2) Select Insert > Indexes and tables > Indexes and tables and 

change the Type to Bibliography, to see a dialog box similar to 
that shown in Figure 27.

Figure 27. Inserting a bibliography

The Insert Index/Table dialog box has five pages.
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Using the Index/Table page
The basic settings are selected on this page.

1) To give the bibliography a title, enter it in the Title field. (A title 
is not required.)

2) You can protect the bibliography from being changed accidentally, 
by checking Protected against manual changes.  If this option 
is selected, the bibliography can only be changed using the right-
click menu or the Insert Table/Index dialog. If the option is not 
selected, the bibliography can be changed directly on the 
document page, just like other text.

3) To have the bibliographic entries numbered within the body of the 
document (for example, [1], [2], ...), select Number entries. If, 
however, you wish to have the field Identifier (from the database) 
appear in the document, deselect this option.

4) Select the type of brackets that you want for the referenced 
entries shown within the body of the document.

5) Define the sorting you require. Currently only alphanumeric 
sorting is supported. Sorting by the the sequence that entries 
appear in the text is done on the Entries page.

Using the Entries page
The structure of this page is similar to that of the previous sections 
(see Figure 28).

You can define how the entry will appear based on the Type of the 
entry, or simply apply the same format to all entries by selecting the 
All button.

The Structure of the entry is based on the fields available in the 
bibliographic database. The ones shown by default are:

• Au – Author
• Ti – Title
• Ye - Year

To determine how entries are sorted, modify the Sort by options. To 
sort by the sequence that entries appear in the text, choose Document 
position. To sort alphanumerically, choose Content. Use Sort keys to 
group similar references.
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Figure 28. Entries page for bibliographies

Using the Styles, Columns and Background pages
Refer to “Using the Styles page” on page 15, “Using the Columns
page” on page 17, and “Using the Background page” on page 18.

Generating the bibliography
To generate the bibliography so that it appears in your document, click 
OK. The Insert Index/Table dialog box closes and the bibliography 
appears in your document.

Defining the paragraph style for the bibliography
You can modify the Bibliography 1 paragraph style to suit your 
requirements. For example, to number the entries in the bibliography 
list, you need to define a numbering style and link that numbering style 
to the Bibliography 1 paragraph style. To do this:

1) On the Styles and Formatting window, click on the List Styles 
icon. You can either define a new list style or modify one of those 
supplied. In this example, we will modify the Numbering 1 style. 
Right-click on Numbering 1 and choose Modify from the pop-up 
menu. (See Figure 29.)
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Figure 29: Modify a numbering style

2) On the Numbering Style dialog, go to the Options page. In our 
example we want to have the numbers enclosed in square 
brackets. To do this, type [ in the Before box and ] in the After 
box, as shown in Figure 30.

Figure 30: Specifying square brackets before and 
after the number in a list

3) Now go to the Position tab of the Numbering style dialog. In the 
Spacing to text box, specify how much indentation you want for 
the second and following lines of any item in the bibliography list 
of your document. Often you will need to experiment a bit to see 
what is the best setting. In our example (Figure 31), we have 
chosen 0.50 cm.
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Figure 31: Setting the spacing between the margin 
and the text

4) Click OK to save these settings and close the Numbering Style 
dialog. Return to the Styles and Formatting window, click on the 
Paragraph Styles icon, choose All Styles from the list at the 
bottom of that window, then right-click on Bibliography 1 and 
choose Modify.

5) On the Paragraph Style dialog, go to the Numbering tab and 
select Numbering 1 from the drop-down list. (See Figure 32.) 
Click OK to save this change to the Bibliography 1 paragraph 
style.

Figure 32: Applying a numbering style to a 
paragraph style

Now when you generate the bibliography, the list will look something 
like the one shown in Figure 33.
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Figure 33: Result of settings for Bibliography 1 
paragraph style

Updating and editing an existing bibliography
To modify the display of bibliography entries:

1) Click anywhere in the bibliography and then right-click.
2) From the pop-up menu, choose Edit Index/Table. The Insert 

Index/Table dialog box opens and you can edit and save the table 
using the five pages described in the previous section.

To update or delete the bibliography, follow the same process as 
described in the sections “Updating a table of contents” and “Deleting
a table of contents” on page 21.

Tools for working with bibliographies
If you find Writer’s bibliography feature too limited, try Bibus 
(http://bibus-biblio.sourceforge.net/wiki/index.php/Main_Page) or 
Zotero (http://www.zotero.org/). Both programs are free and open 
source and are reported to work well with Writer.
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