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Graphics in Writer
When you create a text document using OpenOffice.org (OOo) Writer, 
you may need to include some graphic illustrations. Graphics are 
added to textual documents for a wide variety of reasons: from 
supporting the description provided in the text—such as that used in 
this Guide—to providing an immediate visual impact of the contents, 
such as what is often found in a newspaper.

Graphics in Writer are of three basic types:
• Image files, including photos, drawings, scanned images, and 

others
• Diagrams created using OOo’s drawing tools
• Charts created using OOo’s Chart facility

This chapter covers the first two types of graphic illustrations.

More detailed descriptions on working with drawing tools can be found 
in the Draw Guide and Impress Guide. Instructions on how to create 
charts are given in the Calc Guide.

Adding images to a document
Images (also called ‘pictures’ in this guide) can be taken from a variety 
of sources. They may be downloaded from the Internet, scanned, or 
created with a graphics program; or they may be photos taken with a 
digital camera.

Inserting an image from a file
In the case where the image is already available in a file stored on the 
computer, it can be immediately inserted in the Writer document. OOo 
can import various vector (line drawing) and raster (bitmap) file 
formats. The most common are GIF, JPEG or JPG, PNG, and BMP. See 
“Graphic file types supported” on page 37 for a full list of supported 
graphic file types.

To insert an image from a file, proceed as follows:
1) Determine the destination for the image. Place the cursor at or 

near the appropriate location in the document.

Note
Do not worry too much about the exact placement of the image 
at this stage as this can be easily changed later as described in 
section “Positioning graphics within the text” on page 20.
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2) On the main menu, select Insert > Picture > From File. This 
displays the dialog box shown in Figure 1.

3) Navigate to the file to be inserted, select it, and click Open.

Figure 1: Insert picture dialog box

Note

At the bottom of the Insert picture dialog box are two check 
boxes. If Preview is checked, the selected graphic file is 
previewed in a pane, as shown in Figure 1, so you can verify 
that you have the correct file. The Link option is discussed 
below.

Linking an image file
If the Link option in the Insert picture dialog box is selected, Writer 
creates a link to the file containing the image, instead of saving a copy 
of the image in the document. The result is that the image is displayed 
in the document, but when the document is saved, it will contain only a 
reference to the image file—not the image itself. The document and the 
image remain as two separate files, and they are merged together only 
when you open the document again.

Linking an image has two advantages and one disadvantage:
• Advantage – Linking can reduce the size of the document when it 

is saved, because the image file itself is not included. The file size 
is usually not a problem on a modern computer with a reasonable 
amount of memory, unless the document includes many large 
graphics files. Writer can handle quite large files.

• Advantage – You can modify the image file separately without 
changing the document because the link to the file remains valid, 
and the modified image will appear when you next open the 
document. This can be a big advantage if you (or someone else, 
perhaps, a graphic artist) is updating images.
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• Disadvantage – If you send the document to someone else, or 
move it to a different computer, you must also send the image 
files, or the receiver will not be able to see the linked images. You 
need to keep track of the location of the images and make sure 
the recipient knows where to put them on another machine, so 
the Writer document can find them. For example, you might keep 
images in a subfolder named Images (under the folder containing 
the Writer document); the recipient of the Writer file needs to put 
the images in a subfolder with the same name (under the folder 
containing the Writer document).

Note

When inserting the same image several times in the document, 
it might appear beneficial to create links; however, this is not 
necessary as OOo embeds in the document only one copy of 
the image file.

Embedding linked images
If you originally linked the images, you can easily embed one or more 
of them later if you wish. To do so:

1) Open the Writer document in OOo.
2) Choose Edit > Links from the menu bar.

The Edit Links dialog box (Figure 2) shows all the linked files. In 
the Source file list, select the files you want to change from linked 
to embedded.

3) Click the Break Link button.
4) Save the Writer document.

Figure 2: The Edit Links dialog box
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Note
Going the other way, from embedded to linked, is not so easy—
you must delete and reinsert each image, one at a time, 
selecting the Link option when you do so.

Inserting images from other sources
You can insert images from sources other than a file:

• Graphics program
• Scanner
• OOo Gallery

Graphics program
You can use many different graphics programs to edit a graphic file. 
From these programs, you can select, copy, and paste an image or part 
of a graphic into an OOo document. Figure 3 shows an example of this 
procedure, which can be recreated with these steps:

1) In the graphic program window, select an area of the image to be 
copied.

2) Move the cursor over the selected area and press Control+C to 
copy.

Figure 3. Using a graphics program

3) Switch to the OOo Writer window.
4) Click to place the cursor where the graphic is to be inserted.
5) Press Control+V to paste the image.
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Scanner
If a scanner is connected to your computer, OOo can call the scanning 
application and insert the scanned item into the Writer document page 
as an image. To start this procedure, place the cursor where the 
graphic is to be inserted and select Insert > Picture > Scan > Select 
Source.

Although this practice is quick and easy, it is unlikely to result in a 
high-quality image of the correct size. You may get better results by 
scanning material into a graphics program and cleaning it up there 
before inserting the resulting image into Writer.

OpenOffice.org Gallery
The Gallery contains objects (graphics and sounds) that you can insert 
into your documents. The Gallery is available in all components of OOo. 
For an introduction to the Gallery, see Chapter 11 (Graphics, the 
Gallery, and Fontwork) in the Getting Started guide.

To select a graphic from the Gallery and drag it into the document:

1) Click on the Gallery icon  (located in the right side of the 
Standard toolbar) or choose Tools > Gallery.

2) Select the theme containing the image you want to insert.
3) Click on the image with the left mouse button, then drag and drop 

the image into the document. You can also right-click on the 
object and select Insert > Copy.

Figure 4 shows an example of an image dragged from the Gallery.

Figure 4. Inserting an image from the Gallery
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Modifying an image
When you insert a new image, you may need to modify it to make it 
more suitable for fitting into the document. The placement of the 
picture relative to the text is discussed in “Positioning graphics within
the text” on page 20. This section describes the use of the Picture 
toolbar, resizing, and cropping, as well as a workaround to rotate a 
picture.

Note

Although OOo provides many tools for working with images, for 
best results it is generally better to use an image manipulation 
program such as GIMP1, to modify images (for example, to 
crop, resize, rotate, and change color values) and then insert 
the result into OOo.

Using the picture toolbar
When you insert a suitable graphic image or select one already present 
in the document, the Picture toolbar appears. This toolbar can be 
either floating or docked. Figure 5 shows what the Picture toolbar 
looks like when it is floating. Two other toolbars can be opened from 
this one: the Graphic Filter toolbar, which can be torn off and placed 
elsewhere on the window, and the Color toolbar, which opens as a 
separate floating toolbar.

From these toolbars, you can apply small corrections to the graphic or 
obtain special effects.

Filters
Table 1provides a short description of the available filters, however the 
best way to understand them is to see them in action. Feel free to 
experiment with the different filters and filters settings, remembering 
that you can undo all the changes by pressing Ctrl+Z or 
Alt+Backspace or by selecting Edit > Undo.

1 GIMP is an open-source graphics program that can be downloaded from 
http://www.gimp.org/downloads/.
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Note: Graphics mode (3) can be Default, Grayscale, 
Black/White, or Watermark.

Figure 5. Picture toolbar plus tear-off Graphic 
Filter toolbar and floating Color toolbar

1 From File
2 Filter
3 Graphics mode
4 Color
5 Transparency
6 Flip Horizontally
7 Flip Vertically
8 Graphics Properties
9 Invert

10 Smooth
11 Solarization
12 Aging
13 Charcoal Sketch
14 Relief
15 Mosaic
16 Posterize
17 Pop Art
18 Sharpen
19 Remove Noise
20 Red
21 Green
22 Blue
23 Brightness
24 Contrast
25 Gamma

Figure 6 shows examples of some of the changes available on the 
Picture toolbar.

Original Image Flipped 
Vertically

Flipped 
Horizontally

Light 50%

Contrast 50% Red 50% Green 50% Blue 50%

Figure 6. Some graphic effects available from the Picture toolbar
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Table 1: Graphic filters and their effects

Icon Name Effect

Invert Inverts the color values of a color image or the 
brightness values of a grayscale image.

Smooth Softens the contrast of an image.

Sharpen Increases the contrast of an image.

Remove noise Removes single pixels from an image.

Solarization
Mimics the effects of too much light in a picture. 
A further dialog box opens to adjust the 
parameters.

Aging
Simulates the effects of time on a picture. Can be 
applied several times. A further dialog box opens 
to adjust the aging level.

Posterize Makes a picture appear like a painting by 
reducing the number of colors used.

Pop Art Modifies the picture dramatically.

Charcoal Displays the image as a charcoal sketch.

Relief
A dialog box is displayed to adjust the light 
source that will create the shadow and, hence, 
the relief effect.

Mosaic Joins groups of pixels into a single area of one 
color.

Color
Use this dialog box to modify the individual RGB color components of 
the image (red, green, blue) as well as the brightness, contrast, and 
gamma of the image. If the result is not satisfactory, you can press 
Control+Z to restore the default values.

Setting the object transparency

Modify the percentage value in the Transparency box  on the 
Picture toolbar to make the image more transparent. This is 
particularly useful when creating a watermark or when wrapping the 
image in the background.
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Using the formatting toolbar and picture dialog
When an image is selected, you can customize some aspects of its 
appearance using the tools available on the Formatting toolbar (shown 
in Figure 11) as well as in the dialog that is shown by right-clicking on 
the image and selecting Picture (see Figure 7). You can, for example, 
create a border around the image, selecting style and color; or you can 
(in the Borders page of the Picture dialog) add a shadow to the image. 

Cropping images
When you are only interested in a section of the image for the purpose 
of your document, you may wish to crop (cut off) parts of it. To start 
cropping the image, right-click on it and select Picture from the pop-
up menu. In the Picture dialog box, select the Crop page (Figure 7).

Figure 7: The options available when cropping a picture

In the Crop dialog box, you can control the following parameters:
• Keep scale / Keep image size options: when Keep scale is 

selected (default), cropping the image does not change the scale 
of the picture. When Keep image size is selected, cropping 
produces enlargement (for positive cropping values), shrinking 
(for negative cropping values), or distortion of the image so that 
the image size remains constant.
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• Left, Right, Top, and Bottom: the function of these boxes 
changes according to the choice made between Keep scale and 
Keep image size. In both cases, when a value is entered in one of 
these boxes, the image is cropped by that amount. For example, a 
value of 3cm in the Left box will cut 3 cm from the left side of the 
picture.
When Keep scale is selected, the size of the image also changes, 
so in this example the width will be reduced by 3 cm. If Keep 
image size is selected instead, the remaining part of the image is 
enlarged (positive values for cropping) or shrunk (negative values 
for cropping) so that the width and height of the image remains 
unchanged.
Note that the Width and Height fields change as you enter the 
values when in this mode. Use the thumbnail next to these fields 
to determine the correct amount by which to crop.

Resizing an image
It is possible, and quite likely, that the inserted image will not fit 
perfectly into the document because it is too big or too small. In these 
cases you will need to resize the image.

1) Click the picture, if necessary, to show the green resizing handles.
2) Position the pointer over one of the green resizing handles. The 

pointer changes shape giving a graphical representation of the 
direction of the resizing.

3) Click and drag to resize the picture.
4) Release the mouse button when satisfied with the new size.

The corner handles resize both the width and the height of the graphic 
object simultaneously, while the other four handles only resize one 
dimension at a time.

Tip
To retain the original proportions of the graphic, Shift+click 
one of the corner handles, then drag. Be sure to release the 
mouse button before releasing the Shift key.

Be aware that re-sizing a bit-mapped (raster) image will adversely 
affect the resolution, causing some degree of blurring. It is better to 
externally size your picture correctly before insertion into your 
presentation, if possible.

Figure 8 shows three examples of an image inserted into a document 
and resized.
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Figure 8. Three examples of  resized images, plus the 
original image

For more accurate resizing, use either the Crop page of the Picture 
dialog box (Figure 7) or, for images, the Type page of the Picture 
dialog box. On the Crop page you can either adjust the following 
settings or use the settings in the Crop section as described on page 
13.

• Scale Width and Height: specify in percentages the scaling of 
the picture. The size of the image changes accordingly. For a 
scaled resizing, both values should be identical.

• Image size: specify the size of the image in your preferred unit of 
measurement. The image enlarges or shrinks accordingly.

• Original size button: when clicked, restores the image to its 
original size.

In the Type page of the Picture dialog box, select the Relative option 
to toggle between percentage and actual dimension. For a scaled 
resizing, select the Keep ratio option. As for the Crop page, clicking 
on the Original Size button restores the original image size.
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Rotating a picture
Writer does not provide a tool for rotating a picture; however, there is 
a very simple workaround:

1) Open a new Draw or Impress document.
2) Insert the image you want to rotate. You can use any of the 

mechanisms described in “Adding images to a document” on page 
5, although there are some slight variations in the position of the 
menu entries and icons.

3) Select the image, then in the drawing toolbar (shown by default at 
the bottom of the window in Impress and Draw), select the 

Rotate icon .
4) Rotate the image as desired. Use the red handles at the corners of 

the picture and move the mouse in the direction you wish to 
rotate. By default the picture rotates around its center (indicated 
by a black crosshair), but you can change the pivot point by 
moving the black crosshair to the desired rotation center.

Tip
To restrict the rotation angle to multiples of 15 degrees keep 
the Shift key pressed while rotating the image.

5) Select the rotated picture by pressing Ctrl+A, then copy the 
image to the clipboard with Ctrl+C.

6) Finish by going back to the location of the Writer document 
where the image is to be inserted and pressing Ctrl+V.

Other settings
The Picture dialog box (Figure 7) consists of eight pages. The Crop 
page was described on page 13, while the use of the Type and the 
Wrap pages is explained in “Positioning graphics within the text” on 
page 20. The other pages serve the following purposes:

• Options: use this page to give the picture a descriptive name (as 
you want it to appear in the Navigator), display alternative text 
when the mouse hovers over the picture, and protect some of the 
picture settings from accidental changes. You can also prevent 
the picture from being printed by deselecting the corresponding 
option.

• Borders: use this page to create borders around the picture. The 
Borders dialog box is the same as the one used for defining table 
or paragraph borders. You can also add a shadow to the image if 
so desired.
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• Background: use this page to change the background color of 
the picture. This setting produces the desired results only for 
images with a transparent color.

• Hyperlink: use this page to associate a hyperlink to the picture. 
you can also create an image map so that only certain areas of the 
picture respond to a mouse click by opening the associated URI 
(Uniform Resource Identifier) in the default browser. More 
information on image maps can be found in the Impress Guide.

• Picture: use this page to flip the picture as well as to display the 
original location of the file in case the image is linked rather than 
embedded.

• Macro: allows you to associate a macro to the picture. You can 
choose among the predefined macros or write your own.

Deleting a picture
To delete a picture:

1) Click on the picture, if necessary, to show the green resizing 
handles.

2) Press Delete.

Using Writer’s drawing tools
You can use Writer’s drawing tools to create graphics, such as simple 
diagrams using rectangles, circles, lines, text, and other predefined 
shapes. You can also group several drawing objects to make sure they 
maintain their relative position and proportion.

You can place the drawing objects directly on a page in your document, 
or you can insert them into a frame.

You can also use the drawing tools to annotate photographs, screen 
captures, or other illustrations produced by other programs, but this is 
not recommended because:

• You cannot include images in a group with drawing objects, so 
they may get out of alignment in your document.

• If you convert a Writer document to another format, such as 
HTML, the drawing objects and the graphics will not remain 
associated; they are saved separately.

In general, if you need to create complex drawings, it is recommended 
to use OpenOffice.org Draw, which includes many more features such 
as layers, styles, and so on.
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Creating drawing objects
To begin using the drawing tools, display the Drawing toolbar (Figure
9), by clicking View > Toolbars > Drawing.

If you are planning to use the drawing tools repeatedly, you can tear off 
this toolbar and move it to a convenient place on the window.

1Select 5Freeform Line 9Symbol Shapes 13Stars
2Line 6Text 10Block arrows 14Points
3Rectangle 7Callouts 11Flowcharts 15Fontwork Gallery
4Ellipse 8Basic Shapes 12Callouts 16From File

17Extrusion On/Off
Figure 9. The Drawing toolbar

To use a drawing tool:
1) Click in the document where you want the drawing to be 

anchored. You can change the anchor later, if necessary.
2) Select the tool from the Drawing toolbar (Figure 9). The mouse 

pointer changes to a drawing-functions pointer .
3) Move the cross-hair pointer to the place in the document where 

you want the graphic to appear and then click-and-drag to create 
the drawing object. Release the mouse button. The selected 
drawing function remains active, so you can draw another object 
of the same type.

4) To cancel the selected drawing function, press the Esc key or 
click on the Select icon (the arrow) on the Drawing toolbar.

5) You can now change the properties (fill color, line type and 
weight, anchoring, and others) of the drawing object using either 
the Drawing Object Properties toolbar (Figure 10) or the choices 
and dialog boxes reached by right-clicking on the drawing object.

Set or change properties for drawing objects
To set the properties for a drawing object before you draw it:

1) On the Drawing toolbar (Figure 9), click the Select tool.
2) On the Drawing Object Properties toolbar (Figure 10), click on 

the icon for each property and select the value you want for that 
property.
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3) For more control, or to define new attributes, you can click on the 
Area or Line icons on the toolbar to display detailed dialog boxes.

The default you set applies to the current document and session. It is 
not retained when you close the document or close Writer, and it does 
not apply to any other document you open. The defaults apply to all the 
drawing objects except text objects.

1 Line 5 Line Color 9 To Foreground 13 Alignment

2 Arrow Style 6 Area 10 To Background 14 Change Anchor

3 Line Style 7 Area Style / Filling 11 Bring to Front 15 Ungroup

4 Line Width 8 Rotate 12 Send to Back 16 Group

Figure 10. Drawing Object Properties toolbar

To change the properties for an existing drawing object:
1) Select the object.
2) Continue as described above.

You can also specify the position and size, rotation, and slant and 
corner radius properties of the drawing object:

1) Right-click on the drawing object and then click Position and Size 
from the pop-up menu. The Position and Size dialog box is 
displayed.

2) Choose any properties, as required.

Resizing a drawing object
The same considerations for resizing an image apply also to resizing an 
object. Select the object, click on one of the eight handles around it 
and drag it to its new position. For a scaled resizing, select one of the 
corner handles and keep the Shift key pressed while dragging the 
handle to its new position.

For more sophisticated control of the size of the object, select Format 
> Object > Position and Size from the menu bar. Use the Position 
and Size dialog box to set the width and height independently. If the 
Keep ratio option is selected, then the two dimensions change so that 
the proportion is maintained, allowing for a scaled resizing.
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Grouping drawing objects
To group drawing objects:

1) Select one object, then hold down the Shift key and select the 
others you want to include in the group. The bounding box 
expands to include all the selected objects.

2) With the objects selected, hover the mouse pointer over one of 
the objects and choose Format > Group > Group from the menu 
bar or right-click and choose Group > Group from the pop-up 
menu.

Note
You cannot include an embedded or linked graphic in a group 
with drawing objects.

Positioning graphics within the text
When you add a graphic to a text document, you need to choose how to 
position the graphic with respect to the text and other graphics. The 
positioning of graphics is often rather time-consuming and may be very 
frustrating for both inexperienced and experienced users. As Writer is 
a word processor rather than a desktop publishing program, there are 
some limitations to the flexibility in positioning images and it takes 
time to get things exactly as you would like them. Starting from 
OpenOffice.org 3.0, this task is considerably improved by the inclusion 
of a new option that allows a “loose anchoring”.

Positioning of a graphic is controlled by working on four areas:
• Arrangement refers to the placement of a graphic on an 

imaginary vertical axis. Arrangement controls how graphics are 
stacked upon each other or relative to the text.

• Alignment refers to the vertical or horizontal placement of a 
graphic in relation to the chosen anchoring point.

• Anchoring refers to the reference point for the graphics. This 
point could be the page, or frame where the object is, a 
paragraph, or even a character.

• Text wrapping refers to the relation of graphics to surrounding 
text, which may wrap around the graphic on one or both sides, be 
overprinted behind or in front of the graphic, or treat the graphic 
as a separate paragraph or character.
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The settings for each of the four control areas above can be accessed 
in a number of different ways depending on the nature of the graphics:

1) From the Format menu, where you can find  Alignment, 
Arrange, Wrap, and Anchor (both for images and drawing 
objects).

2) By the pop-up menu displayed when right-clicking on the 
graphics.

3) From the Frame toolbar shown in Figure 11, for images with the 
Graphics frame style applied.

4) From the Type and Wrapping pages of the Picture dialog box for 
images. Note that you cannot control the arrangement using the 
dialog box. To open the Picture dialog box, click on the image to 
select it and then choose Format > Picture or right-click on the 
graphic and choose Picture on the pop-up menu.

5) From the Position and Size page of the Position and Size dialog 
box for drawing objects. To open the Position and Size dialog box, 
click on the drawing object to select it and then choose Format > 
Object > Position and Size or right-click on the graphic and 
choose Position and Size on the pop-up menu. Note that you can 
only control the alignment and anchoring.

1 Apply Style 6 Center Horizontal 11 Borders 16 Bring to Front

2 Wrap Off 7 Align Right 12 Line Style 17 Send to Back

3 Page Wrap 8 Top 13 Line Color (of the 
border)

18 Change Anchor

4 Wrap Through 9 Center 14 Background Color 19 Link Frames

5 Align Left 10 Bottom 15 Frame Properties 20 Unlink Frames

Figure 11. Frame toolbar (graphical control of positioning for images)

Arranging graphics
Arranging a graphic object means to determine its vertical position 
relative to other graphic objects or text. Arranging is only relevant 
when objects are overlapping. You can choose between four settings, 
plus a special setting for drawing objects:
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Figure 12: The Arrange menu

• Bring to Front: draws the graphic on top of any other graphics 
or text.

• Bring Forward: brings the object one level up in the stack (z-
axis). Depending on the number of overlapping objects, you may 
need to apply this option several times to obtain the desired 
result.

• Bring Backward: the opposite of Bring Forward; sends the 
selected object one level down in the object stack.

• Send to Back: sends the selected graphic to the bottom of the 
stack, so that other graphics and text cover it.

• To Background / To Foreground: only available for drawing 
objects; moves the drawing object behind or in front of the text 
respectively.

Anchoring graphics
You can anchor graphics as a character or to a page, paragraph, or 
character. You can also place graphics in a frame and anchor the frame 
to a page, paragraph, or character. Which method you choose depends 
on what you are trying to achieve.

Here are the ways you can anchor graphics or drawing objects:

To Page
The graphic keeps the same position in relation to the page margins. 
It does not move as you add or delete text or other graphics. This 
method is useful when the graphic does not need to be visually 
associated with a particular piece of text. It is often used when 
producing newsletters or other documents that are very layout 
intensive, or for placing logos in letterheads.

Caution
If you plan to use a document within a master document, do 
not anchor graphics To Page because the graphics will 
disappear from the master document. See Chapter 13 
(Working with Master Documents) for more information.
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To Paragraph
The graphic is associated with a paragraph and moves with the 
paragraph. It may be placed in the margin or another location. This 
method is useful as an alternative to a table for placing icons beside 
paragraphs.

To Character
The graphic is associated with a character but is not in the text 
sequence. It moves with the paragraph but may be placed in the 
margin or another location. This method is similar to anchoring to a 
paragraph but cannot be used with drawing objects.

As Character
The graphic is placed in the document like any other character and, 
therefore, affects the height of the text line and the line break. The 
graphic moves with the paragraph as you add or delete text before 
the paragraph. This method is useful for keeping screenshots in 
sequence in a procedure (by anchoring them as a character in a 
blank paragraph) or for adding a small (inline) icon in sequence in a 
sentence.

To Frame
If the graphic has been placed in a frame, you can anchor the 
graphic in a fixed position inside the frame. The frame can then be 
anchored to the page, a paragraph, or a character, as required.

Aligning graphics
Once you have established the anchor point of the graphic, you can 
decide the position of the graphic relative to this anchor: this is called 
aligning the graphics. There are six options to choose from: three for 
aligning the graphic horizontally (left, center, right) and three for 
aligning the graphic vertically (top, center, bottom). If you want to 
have finer control of the alignment, then you need to refer to the dialog 
box shown in Figure 13.
For both the horizontal and vertical position, start by picking the 
reference point in the right hand side drop down menu, then select in 
the first drop down menu among Left, Right or Center. If you select 
the value From left (or From top for the vertical positioning) you can 
specify the amount in your selected unit of measurement. In the 
example in Figure 13, the upper-left corner of the image will be placed 
at 3 cm from the left margin of the page horizontally and on the top 
margin vertically.
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Figure 13: Fine tuning the alignment with the Picture 
dialog box

Wrapping text around graphics
The Wrap setting determines the relation between the text and the 
graphic. Several possibilities are provided:

No Wrap
With this option the text is placed above and below the image but 
not around it. This is the wrapping type used for most of the figures 
in this guide.

Page Wrap or Optimal Page Wrap
The text flows around the image. Moving the image around the page 
causes the text to be rearranged to fill the space to the left and right 
of it. Optimal Page Wrap prevents text from being placed to the 
side of the image if the spacing between the image and the margin 
is less than 2 cm.

Wrap Through
Superimposes the image on the text. That is, the image is above the 
text. This option must be used in conjunction with the image-
transparency setting in order to make the text under the picture 
visible.
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In Background
Similar to Wrap Through, but the image is placed below the text so 
there may be no need to change the transparency to make the text 
visible.

Note
The No Wrap option found in the pop-up menu of a picture is 
equivalent to the Wrap Off menu item in the Format > Wrap 
menu.

The wrap format is normally selected after the anchoring and the 
alignment of the picture have been decided. To set the position of an 
image to the the desired wrap format, follow these steps:

1) Select a graphic by clicking on it.
2) Right-click to display the pop-up menu and move the mouse 

pointer to Wrap to display the available wrap formats. 
Alternatively you can select Format > Wrap from the main 
menu.

3) Select the desired wrap format.

Note
When anchoring a graphic as character, you can only adjust 
the distance between the image and the text, but no wrapping 
option is displayed.

To fine tune the wrapping options, open the Picture dialog box and 
select the Wrap page shown in Figure 14. For images you can open this 
dialog box by selecting Format > Picture from the main menu or 
right-click and select Picture from the pop-up menu. For drawing 
objects, you can access the Wrap page by selecting Format > Wrap > 
Edit in the main menu or right-click and select Wrap > Edit from the 
pop-up menu . This dialog box is divided into three sections.

In the top part you can select among the wrap types mentioned above, 
plus two additional wrap formats that prevent the text from filling the 
area to the left (After) or to the right (Before) of the picture. Use the 
Spacing section of the page to adjust the spacing between the image 
and the text. The contents of the Options section of the page may 
change depending on the selected wrap format.

New Paragraph
Check this box if you want OOo to start a new paragraph after the 
image even if it could still wrap around the image.

In background
This option becomes available if Through Wrap is selected; it 
moves the image in the background.
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Figure 14: The advanced wrap format options dialog 
box (shown for an image)

Contour
Wraps the text around a custom contour rather than around the 
edge of the picture. This option is only available for Page or Optimal 
Page Wrap.

Outside only
Forces the text to wrap on the outside of the image, even if the 
contour contains open areas within the shape.

Editing the contour
This option is only available for image wrapping. If you select wrapping 
around a drawing object, OOo automatically creates a contour. You can 
access the Contour Editor by selecting Format > Wrap > Edit 
Contour or from the right-click menu

The dialog box of Figure 15 opens with the image loaded in the main 
window. Use the tools to draw the region of the image you do not want 
to be covered by the text—such area will be shaded.

Some familiarity with drawing tools is required to create complex 
contours; however, in most circumstances there is no need for high 
accuracy. Figure 15 shows the actual contour used for “Example 2:
simple contour wrapping in action” and as you can see the shape of the 
line around the edge of the sphere is far from perfect.
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Figure 15: The Contour Editor in action

When you are done, click on the Apply button to save the contour. If 
you are not satisfied with the result, you can select the contour line 
and press the Delete key to restart. You can also undo the previous 
steps or you can select the Edit Points button and adjust the contour 
shape point by point.

For simple images, the AutoContour button does a decent job. If the 
contour has to be drawn around an area with the same or a similar 
color, you can select this region using the eyedropper. Select this tool, 
then click on a point in the image having the desired color. OOo 
automatically selects all the points which have the same or a similar 
color. The similarity level can be changed by modifying the value in the 
tolerance box (100% = perfect match).

Note
While all the positioning techniques discussed in this section 
apply equally to frames, contour wrapping is not possible.

Example 1: page wrapping
Figure 16 shows an example of page wrapping in action. The process 
to obtain this is the following:

1) Insert the image into the document, then anchor it to the first 
paragraph. To move the anchor, select the image and move it until 
the anchor symbol is at the beginning of the paragraph. Do not 
worry about the position as that will be fixed in the next step.
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2) Align the image so that the left margin of the image is in line with 
the paragraph indentation. This can be done with the mouse or 
using the advanced settings. In the example, the image is placed 
at 1 cm from the left of the paragraph area.

3) Change the wrap to Page Wrap. It starts out OK; however, there is 
still too little space between the image and the text. To correct it, 
access the Wrap page of the Picture dialog box and set the gap 
between the image and text to 0.2 cm in the Right and Bottom 
boxes.

4) The last touch is to change the position so that the image is below 
the first line of the paragraph. Again, you can use the mouse to 
drag the image or use the advanced settings, which require a bit 
of trial and error. It turns out that the particular line height used 
in this guide—0.75 cm from the top margin of the paragraph—is a 
good value.

Figure 16: Example of image with Page Wrap formatting

Example 2: simple contour wrapping in action
In this example we again apply page wrapping as in example 1, 
enabling this time the contour option. We will work on an image and on 
a drawing object as the contour option works slightly differently in the 
two cases.
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The example of Figure 17 has been built following the steps below, 
which you can use to practice:

1) Create some text (a very quick way to do that is to use the dummy 
text AutoText. That is, type DT and then press the F3 key).

2) Insert an image of your choice and anchor it to the first 
paragraph. Adjust the alignment as desired then change the wrap 
type to Page Wrap.

3) Right-click on the picture to select the option Wrap > Contour, 
then right-click again and select Wrap > Edit Contour from the 
pop-up menu.

4) Use the technique discussed in “Editing the contour” on page 26 
to create a custom contour and click Apply. If needed, adjust the 
spacing between the edge of the image and the text.

5) Insert an AutoShape of your choice (a rotated triangle in the 
example) and proceed as in step 2 above.

Figure 17: Image and drawing object with contour 
wrapping

6) Enable the contour wrap by selecting Format > Wrap > 
Contour from the main menu. As discussed previously, OOo 
automatically generates the contour. You may need to adjust the 
distance between the drawing object and the text.
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Example 3: Wrap Through and In Background
This example shows how to use an image as a watermark by wrapping 
it through the text and adjusting the transparency. This is not the best 
way to create watermarks and it is presented here only for its 
illustration purposes. If you need to create a watermark, it is best to 
use a Fontworks object wrapped in the background.

Figure 18: Transparent image added over the text

The Wrap Through option inserts an image overlapping the text which 
as a result will be hidden. To make the text appear, change the 
transparency of the picture; although the words under the image 
become visible, they may be difficult to read and will appear lighter 
than the rest of the text.

To reproduce the example of Figure 18 create some dummy text, then 
insert the image of your choice. Anchor the image (to the page in the 
example) and select the wrap through option from the Format > Wrap 
menu or right-clicking on the image and selecting Wrap > Wrap 
Through from the pop-up menu. Move the image into the desired 
position.  The Picture toolbar should be displayed when the image is 
selected. Change the transparency to a suitable value (in the example 
this is 40%) so that the text can be read. In the example, a shadow 
effect is applied to the text (Format > Character then select Shadow 
in the Font Effects page).

You can obtain a better result if you set a graphic’s wrap to In 
Background. In this case all the text will be clearly readable, with 
characters that have the same intensity as long as the background is 
not too dark. Also in this case you may want to adjust the transparency 
of the image.
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Adding captions to graphics
You can add captions to graphics in three ways: automatically, by using 
the Caption dialog box, or manually.

Adding captions automatically
You can set up OOo to add captions automatically whenever you insert 
a graphic, a table, or other objects into a document. You can choose 
which objects are captioned automatically, what the sequence name is 
for each caption (for example, “Table” or “Illustration”), and the 
position of the caption.

To set up automatic captions:
1) Click Tools > Options. On the Options dialog box, click on the + 

sign next to OpenOffice.org Writer to show a list of options.
2) Select AutoCaption. Now you can see several choices at the 

right of the dialog box for adding captions automatically.
3) Choose which objects you want to be automatically captioned and 

specify the characteristics of the captions.

For more information, see “AutoCaption options” in Chapter 2 (Setting 
up Writer).

When you insert a graphic, if automatic captioning is enabled, the 
graphic is placed in a frame along with a caption containing the default 
sequence name for graphics Illustration. Position the cursor in the―  
caption area and type the text for the caption. You can change the 
sequence name by selecting one from the drop-down Category list.

Note

You can specify where to place an automatic caption for any 
object except a picture; picture captions can only be 
automatically placed below the picture. If you need a caption 
above the picture (for example, for data plots in scientific 
publications), you must add the captions manually, as 
described in “Adding captions manually” on page 33.
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Tip A common sequence name—Figure—is not one of the names 
provided: <None>, Drawing, Illustration, Table, and Text. 
If you want the name “Figure” or any other custom name for 
your graphics, do the following:

1)  Open the Options – OpenOffice.org Writer – 
AutoCaption dialog box, as described above.

2)  In the Add captions automatically when inserting section, 
select OpenOffice.org Writer Picture. This activates 
the Caption area in the dialog box for pictures (graphics).

3)  Under the Category drop-down list, enter the name that 
you want added (say, Figure), by overwriting any 
sequence name in the list. (Overwriting a term does not 
delete it from the drop-down list.) You can also set some 
options for the number style and for a separator between 
the name and the number, if desired. Click OK to save 
the changes.

Using the Caption dialog box
To add captions using the Caption dialog box:

1) Insert the graphic, then select it and click Insert > Caption.
2) Under Properties on the Caption dialog box (Figure 20), make 

your selections for the Category, Numbering, and Separator fields 
(Illustration, Arabic (1 2 3), and a colon (:), respectively, for the 
example in Figure 19 and type your caption text in the Caption 
text box at the top. Whatever text you enter for the caption 
appears in the box at the bottom, after the sequence name, 
number, and separator.

3) Click OK. The graphic and its caption are placed in a frame, as 
shown in Figure 20.

Figure 19. Defining the caption for an illustration
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Tip
In the Category box, you can type any name you want, for 
example, Figure. OOo will create a numbering sequence using 
that name.

Illustration 1. An example

Figure 20. An example of a graphic and its caption contained in a 
frame. The outer box shows the edge of the frame; this border is 
normally set to be invisible.

Overriding the default positioning of captions
The default positioning for picture captions is Below, and that position 
cannot be changed using the Caption dialog. However, you can 
override the positioning manually, as follows:

1) Follow the instructions in “Using the Caption dialog box” on page 
32 to create the caption.

2) Right-click on the picture (not the frame surrounding picture and 
caption) and make sure that Anchor > To paragraph is selected.

3) Left-click on the picture and drag it below the caption.

Tip
You may wish to adjust the spacing above and below the 
caption text, to fine-tune the appearance of the picture and its 
caption.

Adding captions manually
If you need to save as .DOC files or export in other formats, you may 
find that captions applied as described above (either automatically or 
using the Caption dialog box) are lost during the export. To avoid 
export problems, or as another way to put captions above pictures or 
below them (the usual case), you can add a caption manually, in either 
of two ways:

• Place the graphic and its caption in separate paragraphs.
• Use a table.
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Place the graphic and its caption in separate paragraphs
Insert the graphic and anchor it to its paragraph as a character. Press 
Enter to create a new paragraph for the caption.

1) In the caption paragraph, type, for example, Figure and add a 
space.

2) To insert the figure number automatically, click Insert > Fields 
> Other (Control + F2) and select the Variables tab.

3) Select Number range in the Type list. Select Figure in the 
Selection list and choose, for example, Arabic (1 2 3) in the 
Format drop-down list. Click the Insert button.

4) A number will appear after the word “Figure” in the caption. Now, 
type the text of the caption.

Tips If you are manually adding captions to a lot of figures using 
this method, you might want to make an AutoText entry 
containing, for example, Figure and a space, the figure-
number field, and an optional separator and a space after it.
You can also place the caption paragraph before (above) the 
picture paragraph. Using AutoText can be a convenient way to 
deal with the lack of automatic captioning above pictures.
To ensure the picture and its caption stay together on the 
page: if the picture is going above the caption, define the text 
flow of the Figure paragraph style as Keep with next 
paragraph and the next style as Caption. Conversely, if the 
caption is going above, define the Caption paragraph style as 
Keep with next paragraph and the next style as Figure.

Use a table
Create a one-column, two-row table. Place the picture in one row and 
type the caption in the other row—or use two or more rows for the 
caption and other text. This method can be especially useful for 
pictures with numbered legends, such as Figure 11 in this chapter.

Adding an image to the Gallery
You may wish to add to the Gallery any images that you use frequently, 
for example, a company logo. You can then very easily insert these 
graphics into a document later.

To add images to the Gallery, proceed as follows:
1) Open the Gallery.

34 Working with Graphics



2) Select the theme where you want to add images, or you can 
create a new theme. Note that you can add images only to “My 
Theme” or to any other theme that you have created; these are 
indicated by a green icon in the list of themes. You cannot add 
images to the built-in themes, indicated by an icon of another 
color.

To create a new theme:
a) Click the New Theme button above the list box of Themes. 

The Properties of New Theme dialog box opens, which is 
similar to the one shown in Figure 21.

b) Select the General tab (not shown) and type a name for the 
new theme in the text box.

c) Select the Files tab, skip step 3, and continue with step 4.
3) Right-click on the desired theme and select Properties in the 

pop-up menu. This displays a window from which to select the 
files to be added.

Figure 21. Gallery properties dialog box

4) On the Files page, click the Find Files button. The Select path 
dialog box opens.

5) You can enter the path for the file’s directory in the Path text box, 
or you can navigate to locate the file’s directory. Use the File type 
drop-down list to help limit the search.
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6) Click the Select button to start the search. A list of graphic files 
is then displayed in the window. You can use the File type filter 
again to further limit the search.

7) Select the files to add. To select more than one file, hold the 
Control key down while you click on each file.

8) Finally, click Add.
9) When you have finished working with the Gallery, you can click on 

its icon  to close it.

Note

This procedure assumes that the graphic files for the themes 
already exist. You may need to import some graphics or to 
create your own onto your computer if the existing files are 
insufficient.

Note
Similar to the file search function on various operating 
systems, Find Files searches for graphic files in any 
subfolders of the directory selected in step 5.
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Graphic file types supported
OpenOffice.org Writer can open the file types listed in Table 2. Many of 
these file types are hyperlinked to Wikipedia for their definitions and 
other information.

Table 2. Graphic file types supported by OpenOffice.org Writer

File extension File type

BMP Windows Bitmap

DXF AutoCAD Drawing Interchange 
(Exchange) Format

EMF Enhanced Metafile

EPS Encapsulated PostScript

GIF Graphics Interchange Format

JPG, JPEG, JFIF, JIF Joint Photographic Experts Group

MET OS/2 Metafile

PBM Portable Bitmap

PCD Kodak Photo CD

PCT Macintosh QuickDraw PICT

PCX Zsoft PC Paintbrush

PGM Portable Graymap

PNG Portable Network Graphics

PPM Portable Pixelmap

PSD Adobe Photoshop Document

RAS Sun Raster Image

SGF StarWriter Graphics Format

SGV StarDraw 2.0

SVM StarView Metafile

TGA Truevision Targa

TIF, TIFF Tagged Image File Format

WMF Windows Metafile

XBM X Bitmap

XPM X PixMap
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