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Introduction
A data source, or database, is a collection of pieces of information that 
can be accessed or managed by OpenOffice.org (OOo). For example, a 
list of names and addresses is a data source that could be used for 
producing a mail merge letter. A shop stock list could be a data source 
managed through OOo.

Note

OpenOffice.org uses the terms “Data Source” and “Database” to 
refer to the same thing, which could be a database such as 
MySQL or dBase or a spreadsheet or text document holding 
data.

This chapter covers creating a database, showing what is contained in 
a database and how the different parts are used by OOo. It also covers 
using the Base component of OOo to register other data sources. A 
data source can be a database, spreadsheet, or text document.

Data sources are only introduced in this chapter. For more detailed 
information about the use of databases, see the Database Guide.

Note
OOo Base uses the HSQL database engine. All of the files 
created by this engine are kept in one zipped file. The database 
forms are included in this zipped file.

A database consists of a number of fields that contain the individual 
pieces of data. Each table of the database is a group of fields. When 
creating a table, you also determine the characteristics of each field in 
the table. Forms are for data entry into the fields of one or more tables 
associated with the form. They can also be used for viewing fields from 
one or more tables associated with the form. A query creates a new 
table from the existing tables based upon how you create the query. A 
report organizes the information of the fields of a query in a document 
according to your requirements.

Caution

 

The database in OOo requires Java Runtime Environment (JRE). 
If you do not have it on your computer, you can download it 
from www.java.com and install it following the instructions on 
the site. It should be Java 5.0 or higher. In OOo, use Tools > 
Options > OpenOffice.org > Java to register Java.
Windows' version of JRE can not be used, while there are other 
versions that can.
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Base creates relational databases. This makes it fairly easy to create a 
database in which the fields of the database have relationships with 
each other.

For example: Consider a database for a library. It will contain a field 
for the names of the authors and another field for the names of the 
books. There is an obvious relationship between the authors and the 
books they have written. The library may contain more than one book 
by the same author. This is what is known as a one-to-many 
relationship: one author and more than one book. Most if not all the 
relationships in such a database are one-to-many relationships.

Consider an employment database for the same library. One of the 
fields contains the names of the employees while others contain the 
social security numbers, and other personal data. The relationship 
between the names and social security numbers is one-to-one: only one 
social security number for each name.

If you are acquainted with mathematical sets, a relational database can 
easily be explained in terms of sets: elements, subsets, unions, and 
intersections. The fields of a database are the elements. The tables are 
subsets. Relationships are defined in terms of unions and intersections 
of the subsets (tables).

To explain how to use a database, we will create one for automobile 
expenses. In the process, we will be explaining how a database work.

Planning a database
The first step in creating a database is to ask yourself many questions. 
Write them down, and leave some space between the questions to later 
write the answers. At least some of the answers should seem obvious 
after you take some time to think.

You may have to go through this process a few times before everything 
becomes clear in your mind and on paper. Using a text document for 
these questions and answers makes it easier to move the questions 
around, add additional questions, or change the answers.

Here are some of the questions and answers I developed before I 
created a database for automobile expenses. I had an idea of what I 
wanted before I started, but as I began asking questions and listing the 
answers, I discovered that I needed additional tables and fields.

What are the fields going to be? My expenses divided into three broad 
areas: fuel purchases, maintenance, and vacations. The annual cost for 
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the car’s license plate and driver’s license every four years did not fit 
into any of these. It will be a table of its own: license fees.

What fields fit the fuel purchases area? Date purchased, odometer 
reading, fuel cost, fuel quantity, and payment method fit. (Fuel 
economy can be calculated with a query.)

What fields fit the maintenance area? Date of service, odometer 
reading, type of service, cost of service, and next scheduled service of 
this type (for example, for oil changes list when the next oil change 
should be). But it would be nice if there was a way to write notes. So, a 
field for notes was added to the list.

What fields fit the vacations area? Date, odometer reading, fuel 
(including all the fields of the fuel table), food (including meals and 
snacks), motel, total tolls, and miscellaneous. Since these purchases 
are made by one of two bank cards or with cash, I want a field to state 
which payment type was used for each item.

What fields fit into the food category? Breakfast, lunch, supper, and 
snacks seem to fit. Do I list all the snacks individually or list the total 
cost for snacks for the day? I chose to divide snacks into two fields: 
number of snacks and total cost of snacks. I also need a payment type 
for each of these: breakfast, lunch, supper, and total cost of snacks.

What are the fields that are common to more than one area? Date 
appears in all of the areas as does odometer reading and payment 
type.

How will I use this information about these three fields? While on 
vacation, I want the expenses for each day to be listed together. The 
date fields suggest a relationship between the vacation table and the 
dates in each of these tables: fuel and food, This means that the date 
fields in these tables will be linked as we create the database.

The type of payment includes two bank cards and cash. So, we will 
create a table with a field for the type of payment and use it in list 
boxes in the forms.

Tip

While we have listed fields we will create in the tables of the 
database, there is one more field that may be needed in a table: 
the field for the primary key. In some tables, the field for the 
primary key has already been listed. In other tables such as the 
payment type, an additional field for the primary key must be 
created.
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Creating a new database
To create a new database, click the arrow next to the New icon. In the 
drop-down menu, select Database (Figure 1). This opens the Database 
Wizard. You can also open the Database Wizard using File > New > 
Database.

Figure 1: Creating a new database

The first step of the Database Wizard has one question with two 
choices: Create a new database or Connect to an existing 
database. For this example, select Create a new database and then 
click Next.

The second step has two questions with two choices each. The default 
choice for the first question is Yes, register the database for me and 
the default choice for the second question is Open the database for 
editing. Make sure these choices are selected and click Finish.

Note
If the database is not registered, it will not be accessible to the 
other OOo components such as Writer and Calc. If the database is 
registered, other components can access it.

Save the new database with the name Automobile. This opens the 
Automobile – OpenOffice.org Base window. Figure 2 shows part of this 
window.

Tip

Every time the Automobile database is opened, the Automobile – 
OpenOffice.org Base window opens. Changes can then be made 
to the database. The title for this window is always (database 
name) – OpenOffice.org.
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Caution 

As you create a database, you should save your work regularly. 
This means more than just saving what you have just created. 
You must save the whole database as well.
For example, when you create your first table, you must save it 
before you can close it. If you look at the Save icon in the 
Standard toolbar at the top after closing the table, it will be 
active. Click the Save icon, and this icon will be grayed out 
again. Not only the table has been saved, but it also been made 
a part of the database.

Creating database tables

Note

In a database, a table stores information for a group of things we 
call fields. For example, a table might hold an address book, a 
stock list, a phone book or a price list. A database can have from 
one to several tables.

To work with tables, click the Tables icon in the Database list, or use 
Alt+a. The three tasks that you can perform on a table are in the Task 
list (see Figure 2).

Figure 2: Creating tables

Using the Wizard to create a table

Caution

 

Every table requires a Primary key field. (What this field does 
will be explained later.) We will use this field to number our 
entries and want that number to automatically increase as we 
add each entry. 
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Since none of the fields we need for our Automobile database are 
contained in any of the wizard tables, we will create a simple table 
using the wizard that has nothing to do with our database. This section 
is an exercise in explaining how the Wizard works.

The Wizard permits the fields of the table to come from more than one 
suggested table. We will create a table with fields from three different 
suggested tables in the Wizard.

Click Use Wizard to Create Table. This opens the Table Wizard.

Note

A field in a table is one bit of information. For example, in a 
price list table, there might be one field for item name, one for 
the description and a third for the price. More fields may be 
added as needed.

Step 1: Select fields.

You have a choice of two categories of suggested tables: Business and 
Personal. Each category contains its own suggested tables from which 
to choose. Each table has a list of available fields. We will use the CD-
Collection Sample table in the Personal category to select the fields we 
need.

1) Category: Select Personal. The Sample Tables drop down list 
changes to a list of personal sample tables.

2) Sample Tables: Select CD-Collection. The Available fields window 
changes to a list of available fields for this table.

3) Selected Fields: Using the > button, move these fields from the 
Available fields window to the Selected fields window in this 
order: CollectionID, AlbumTitle, Artist, DatePurchased, Format, 
Notes, and NumberofTracks.

4) Selected Fields from another sample table. Click Business as the 
Category. Select Employees from the dropdown list of sample 
tables. Use the > button to move the Photo field from the 
Available fields window to the Selected fields window. It will be at 
the bottom of the list directly below the NumberofTracks field.

5) If a mistake is made in the order as listed above, click on the field 
name that is in the wrong order to highlight it. Use the Up or 
Down arrow on the right side of the Selected Fields list (see 
Figure 3) to move the field name to the correct position. Click 
Next.
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Figure 3: Order of fields

Caution

 

Below the Selected Fields list are two buttons: one with a +, and 
one with a –. These buttons are used to add or to remove fields 
from the Selected Fields list. Be careful when using these 
buttons until well acquainted with how to create tables 
(Figure 3).

Step 2: Set field types and formats.

In this step you give the fields their properties. When you click a field, 
the information on the right changes. You can then make changes to 
meet your needs. (See Figure 4.) Click each field, one at a time, and 
make the changes listed below.

Figure 4: Changing field types
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Note

If any of these fields requires an entry, set Entry required to Yes. 
If Entry required is set to Yes, this field must have something in 
it. For example if FirstName has Entry required set to Yes, having 
an entry with the first name missing will not be allowed. In 
general, only set Entry required to Yes if something must always 
be put in that field. By default, Entry required is set to No.

• CollectionID: Change AutoValue from No to Yes.
• AlbumTitle:

– Entry required: If all of your music is in albums, change Entry 
required to Yes. Otherwise, leave Entry required as No.

– Length: Unless you have an album title that exceeds 100 
characters in length counting the spaces, do not change the 
length.

Note

In Base the maximum length of each field must be specified on 
creation. It is not easy to change this later, so if in doubt specify 
a greater length. Base uses VCHAR as the field format for text 
fields. This format only uses the actual number of characters in a 
field up to the limit set. So, a field containing 20 characters will 
only use space for 20 characters even if the limit is set at 100. 
Two album titles containing 25 and 32 characters respectively 
will use space for 25 and 32 characters and not 100 characters.

• Artist: Use the Default setting. And since music has authors, set 
Entry Required to Yes.

• Date Purchased: Length: default setting. Entry required should be 
No. (You may not know the date.)

• Format: Only change the Entry Required setting: from No to Yes.
• Notes: No changes are required.
• NumberofTracks: Change the Field Type to Tiny Integer 

[TINYINT]. Your allowable number of tracks will be 999. Small 
Integer [SMALLINT] would allow 99999 tracks if you needed 
more than 999 tracks.

• Photo: Use the default settings. 

When you have finished, click Next.

12 Getting Started with Base



Note

Each field also has a Field Type. In Base the field type must be 
specified. These types include text, integer, date and decimal. If 
the field is going to have general information in it (for example a 
name or a description), then you want to use text. If the field will 
always contain a number (for example a price), the type should be 
decimal or another appropriate numerical field. The wizard picks 
the right field type, so to get an idea of how this works, see what 
the wizard has chosen for different fields.

Step 3: Set primary key.

1) Create a primary key should be checked.
2) Select option Use an existing field as a primary key.
3) In the Fieldname drop down list, select CollectionID.
4) Check Auto value if it is not already checked.
5) Click Next.

Note

A primary key uniquely identifies an item (or record) in the table. 
For example, you might know two people called “Randy Herring” 
or three people living at the same address and the database 
needs to distinguish between them.
The simplest method is to assign a unique number to each one: 
number the first person 1, the second 2, and so on. Each entry has 
one number and every number is different, so it is easy to say 
“record ID 172”. This is the option chosen here: CollectionID is 
just a number assigned automatically by Base to each record of 
this table.
There are more complex ways of doing this, all answering the 
question “How do I make sure that every single record in my 
database can be uniquely identified?”

Step 4: Create the table.

1) If desired, rename the table at this point. If you rename it, make 
the name meaningful to you. For this example, make no changes.

2) Leave the option Insert data immediately checked.
3) Click Finish to complete the table wizard. Close the window 

created by the table wizard. You are now back to the main 
window of the database with the listing of the tables, queries, 
forms, and reports.
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Creating a table by copying an existing table
If you have a large collection of music, you might want to create a 
table for each type of music you have. Rather than creating each table 
from the wizard, you can make a copy of the original table. Each table 
can be named according to the type of music contained in it. Possible 
names could include Classical, Pop, Country and Western, and Rock, 
among others.

1) Click on the Tables icon in the Database pane to see the existing 
tables.

2) Right-click on the CD-Collection table icon. Select Copy from the 
context menu.

3) Move the mouse pointer below this table, right-click, and select 
Paste from the context menu. The Copy table window opens.

4) Change the table name to Pop and click Next.
5) Click the >> button to move all the Fields from the left window to 

the right window and click Next.
6) Since all the Fields already have the proper File Type formating, 

no changes should be needed. However, this is the time and place 
to make these changes if they are needed. (See Caution below 
for the reason why.) Click Create. The new table is created.

Caution

 

Once tables have been created using the wizard and data has 
been entered, editing them should be very limited if any editing 
is done at all. Fields can be added or deleted. But adding a field 
requires taking the time to enter the data for that one field for 
every record having an entry for that field. Deleting a field 
deletes all the data once contained in that field. Changing the 
field type of a field can lead to data being lost either partially or 
completely. When creating a new table, it pays to create the 
fields with the correct names, length and format before data is 
added.

Caution 

Tables can be deleted in a very simple way. But doing so 
removes all of the data contained in every field of the table. 
Unless you are sure, do not delete a table.
To delete a table, right-click it in the list of tables. Select 
Delete from the context menu. A popup window asks if you are 
sure you want to delete the table. Once you click Yes, the table 
and its data are gone forever unless you have a backup.
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Creating tables in Design View
Design View is a more advanced method for creating a new table. It 
allows you to directly enter information about each field in the table. 
We will use this method for the tables of our database.

Note
While the Field type and formatting are different in Design View, 
the concepts are the same as in the Wizard.

The first table to be created is Fuel. Its fields are FuelID, Date, 
FuelCost, FuelQuantity, Odometer, and PaymentType. FuelCost uses 
currency and two decimal places. FuelQuantity and Odometer use the 
number format with 3 decimal places and 1 decimal place respectively. 
PaymentType uses the text format.

1) Click Create Table in Design View.
2) FuelID entries:

a) Enter FuelID as the first Field Name.
b) Select Integer [INTEGER] as the Field Type from the 

dropdown list. (The default setting is Text [VARCHAR].)

Tip

Shortcut for selecting from the Field Type dropdown list: use the 
key for the first letter of the choice. This might require using the 
letter more than once to get the choice you want. You can cycle 
through the choices for a given letter by repeatedly using that 
letter.
After typing the name of the field in the Fields column, use the 
Tab key to move to the Field Type column. This will enter the 
field name and highlight the dropdown list. You can then use the 
key for the first letter of your choice to select the field type. Just 
remember to use it the correct number of times if necessary.

c) Change the Field Properties in the bottom section.
Change AutoValue from No to Yes (Figure 5).

Figure 5: Field Properties section (AutoValue)

d) Set FuelID as the Primary key.
Right-click on the green triangle to the left of FuelID 
(Figure 6).

Creating database tables 15



Figure 6: Primary key field

Click Primary Key in the context menu. This places a key icon in 
front of FuelID.

Note

The primary key serves only one purpose. Any name can be used 
for this field. It is not necessary to use FuelID as the name of the 
primary key field. We have used it so we know to which table it 
belongs by its name.

3) All other entries:
• Enter the next field name in the first column (Field Name 

column).
• Select the Field Type for each field.

– For Date use Date[DATE]. (Use the D key once to select it.)
– PaymentType uses Text [VARCHAR], the default setting.
– All other fields use Number [NUMERIC]. (Use the N key 

once to select it.)

• Select the Field Properties (Figure 7).

Figure 7: Field Properties section

FuelCost, FuelQuantity, and Odometer need changes in the 
Field Properties section (Figure 7).
– FuelQuantity: Change Length to 6 and Decimal places to 3. 

(Many fuel pumps measure fuel to thousands of a gallon in 
the USA where I live.)

– Odometer: Change the Length to 10 and the Decimal 
places to 1.

– FuelCost: Change the Length to 5 and Decimal places to 2. 
Click the Format example button (Figure 7). This opens 
the Field Format window (Figure 8).
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Use Currency as the Category and your currency as the 
Format. My currency has two decimal places. Use what is 
appropriate for your currency.

Figure 8: Field Format options

4) Repeat these steps for each field in the table.
5) To access additional formatting options, click the button to the 

right of the Format example panel (Format example button in 
Figure 7).

6) Description can be anything, or can be left blank. (Figure 9 is an 
example of this.)

7) To save and close the table, select File > Close. Name the table 
Fuel.

Follow the same steps to create the Vacations table. The fields and 
their field types are listed in Figure 9. Make sure you make the Date 
field the primary key before closing. (Right click the Grey box to the 
left of Date. Select Primary key from the context menu.) Name the 
table Vacations, and save it.
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Figure 9: Example of Description entries

Creating tables for the list box
When the same information can be used in several fields, design a 
table for each type of information. Each table will contain two fields: 
the information field, and ID in this order.

Caution 

You must create these tables with the information field listed 
first and the and the ID field listed last. Failure to do so will 
produce the wrong results. For my Payment table, I use Name 
and ID as my fields, with Dan, Kevin, and Cash being the Name 
entries. The corresponding ID entries are 0, 1, 2. When the 
Name field is listed first in the table, one of the three names 
will appear in the payment field of the Fuel table. If the ID field 
is listed first, 0, 1, or 2 appear in the payment field instead.

1) Follow the directions in “Creating tables in Design View” on page 
15. In the table we will create, the two fields can be Type and 
PaymentID. Make sure that the AutoValue is set to Yes for the 
PaymentID field. Set the PaymentID field as the primary key. (See 
Figure 10.)

2) Save the table using the name Payment Type.
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Figure 10: Table in Design View

Note: 
If you have several tables to create with the same fields, design 
one table and produce the other tables by cutting and pasting. 
(See “Creating a table by copying an existing table” on page 14.) 

Adding data to the list table
List tables do not require a form. Instead, add their data directly to the 
table. In this example, use the names of the two people with a bank 
card and Cash for cash purchases.

1) In the main database window, click on the Tables icon (Figure 2). 
Right-click on Payment Type and select Open from the context 
menu.
a) Enter Dan in the first row. Use the tab key to move to the 

second row.
b) Enter Kevin in the second row.
c) Enter Cash in the third row.

2) Save and close the table window.

Tip

The Enter key can also be used to move from field entry to field 
entry. For this example, enter Jan. in the first Name field. Enter 
moves the cursor to the ID field. Enter then moves the cursor to 
the second Name field.
The Down Arrow key can also be used to move from row to row.

Note

The PaymentID field contains <AutoField> until you use the 
Enter key to move to the second row. Then it becomes a 0. As 
you add the entries to each row, the rows of the PaymentID field 
change to consecutive whole numbers. For example the first 
three numbers in this field are 0,1,2.

Creating a View
A View is a query. Because of this, the details of how to create and use 
a View are in the Creating queries section.
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Figure 11: View of some fields from the Vacations table

A View is also a table. Its fields come from the fields of one or more 
tables of the database. It provides a way to look at a number of fields 
without regard to the table to which any of the fields belong. A View 
can consists of some of the fields of one table as in Figure 11. Or, it can 
consist of fields from more than one field as in Figure 12.

Figure 12: View of fields from the Fuel and Payment Type tables

Caution Data can not be entered into a View like it can be added to a 
table. It is strictly for viewing data which has already been 
entered into the table.

Defining relationships
Now that the tables have been created, what are the relationships 
between our tables? This is the time to define them based upon the 
questions we asked and answered in the beginning.

When on vacation, we want to enter all of our expenses all at one time 
each day. Most of these expenses are in the Vacations table, but the 
fuel we buy is not. So, we will relate these two tables using the Date 
fields. Since the Fuel table may have more than one entry per date, 
this relationship between the Vacations and Fuel tables is one to many. 
(It is designated 1:n.)

The Vacations tables also contains several fields for the type of 
payment used. For each field listing the payment type, there is only 
one entry from the Payment Type table. This is a one to one 
relationship: one field in one table to one entry from the other table. (It 
is designated 1:1.) Other tables also contain fields for the type of 
payment. The relationship between these fields of those tables and the 
Payment Type table are also 1:1.

Since the Payment Type table only provides a static list, we will not be 
defining a relationship between the Payment Type table and the fields 
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of the other tables which use the entries of the Payment Type table. 
That will be done when the forms are created.

The Fuel and Maintenance tables do not really have a relationship even 
though they share similar fields: Date, and Odometer. Unless a person 
is in a habit of regularly getting fuel and having their vehicle serviced, 
the entries in these tables do not share anything in common.

Tip
As you create your own databases, you need to also 
determine where tables are related and how.

1) We begin defining relationships by Tools > Relationships. The 
Automobile – OpenOffice.org Base: Relation design window opens 
(Figure 13). The icons we will use are Add Tables and New 
Relation.

Figure 13: Relation design window

2) Click the Add Tables icon. The Add Tables window opens.
3) Use one of these ways to add a table to the Relation design 

window:
• Double-click the name of the table. In our case, do this for 

both Vacations and Fuel.
• Or, click the name of the table and then click Add for each 

table.

4) Click Close when you have added the tables you want 
(Figure 21).

Figure 14: Added table lists

5) Defining the relationship between the Vacations and Fuel tables.
Two ways exist to do this:
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• Click and drag the Date field in the Fuel table to the Date field 
in the Vacations table. When you release the mouse button, a 
connecting line forms between the two date fields (Figure 15).

Figure 15: Designation for a 1:n relationship

• Or, click the New Relation icon. This opens the Relations 
window (Figure 16). Our two tables are listed in the Tables 
involved section.

– In the Fields involved section, click the dropdown list 
under the Fuel label.

Figure 16: Setting the relationship 
between tables

– Select Date from the Fuel table list.
– Click in the cell to the right of this dropdown list. This opens a 

dropdown list for the Vacations table.
– Select Date from the Vacations table list. It should now look 

like Figure 17.
– Click OK.

Figure 17: Selected fields in a relationship

6) Modifying the Update options and Delete options section of the 
Relation window.
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a) Right-click the line connecting the Date fields in the two table 
lists to open a context menu.

b) Select Edit to open the Relation window (Figure 18).
c) Select Update cascade.
d) Select Delete cascade.

Figure 18: Update options and Delete options section

While these options are not absolutely necessary, they do help. Having 
these options selected permits you to update a table that has a 
relationship defined with another table. It also permits you to delete a 
field from the table.

Creating a database form
Databases are used to store data. But, how is the data put into the 
database? Forms are used to do this. In the language of databases, a 
form is a front end for data entry and editing.

Figure 19: Fields of a simple 
form

Figure 20: Simple Form with 
additions

A simple form consists of the fields from a table (Figure 19). More 
complex forms can contain much more. These can contain additional 
text, graphics, selection boxes and many other elements. Figure 20 is 
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made from the same table with a text label (Fuel Purchases), a list box 
placed in PaymentType, and a graphic background.

Using the Wizard to create a form
We will use the Form Wizard to create two forms: CD Collection and 
Vacations. The CD Collection form will be a simple form, while the 
Vacations form will contain a form and a subform. We will create the 
Vacations form with its subform and let you modify the CD Collection 
form using the same process.

In the main database window (Figure 2), click the Form icon. Double-
click Use Wizard to Create Form to open the wizard (Figure 21). 
Simple forms require only some of these steps, while more complex 
forms may use all of them.

Step 1: Select fields.

1) Under Tables or queries, select Vacations as the table. Available 
fields lists the fields for the Vacations table.

2) Click the right double arrow to move all of these fields to the 
Fields in the form list. Click Next.

Figure 21: Form Wizard steps

Step 2: Set up a subform.

Since we have already created a relationship between the Fuel and 
Vacations tables, we will use that relationship. If no relationship had 
been defined, this would be done in step 4.

1) Click the box labeled Add Subform.
2) Click the radio button labeled Subform based upon existing 

relation.
3) Fuel is listed as a relation we want to add. So, click Fuel to 

highlight it, as in Figure 22. Click Next.

24 Getting Started with Base



Figure 22: Adding a subform

Step 3: Add subform fields.

This step is exactly the same as step 1. The only difference is that not 
all of the fields will be used in the subform.

1) Select Fuel under Tables or queries.
2) Use the >> button to move all the fields to the right.
3) Click the FuelID field to highlight it.
4) Use the < button to move the FuelID to the left (Figure 23). 
5) Click Next.

Figure 23: Selecting fields of a subform

Step 4: Get joined fields.

This step is for tables or queries for which no relationship has been 
defined. Since we want to list all expenses by the day they occur in 
both the form and subform, we will joint the Date fields of these two 
tables (Figure 24).
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Figure 24: Selection of joined subform and main form fields

1) Select Date from the First joined subform field dropdown list. 
This is the Date field in the Fuel table. This is not the Primary key 
for the Fuel table, but it is known as a Foreign key.

2) Select Date from the First joined main form field dropdown list. 
This is the Date field in the Vacations table. This is the Primary 
key for the Vacations table. Click Next.

Note
It is possible to create a relationship between two tables that is 
based upon more than one pair of fields. How to do that and why 
is discussed in the Base Guide.

Caution 

When selecting a pair of fields from two tables to use as a 
relationship, they have to have the same field type. That is why 
we used the Date field from both tables: both their field types 
are Date[DATE].
Whether a single pair of fields from two tables are chosen as 
the relationship or two or more pairs are chosen, certain 
requirements must be met for the form to work.

• No field from the subform can be the Primary key for its 
table. (FuelID cannot be used.)

• Each pair of joined fields must have the same file type.
• One of the fields from the main form must be the Primary 

key for its table. (Date would have to be used.)

Step 5: Arrange controls.

Note

Each control in a form consists of two parts: label and field. This 
step in creating the form determines where a control's label and 
field are placed in relationship with each other. The four choices 
from left to right are Columnar left, Columnar - Labels on top, As 
Data Sheet, and In Blocks - Labels Above (Figure 25).
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1) Arrangement of the main form: Click Columnar - Labels on top. 
The labels will be placed above their field.

2) Arrangement of the subform: Click As Data Sheet. (The labels are 
column headings and the field entries are in spreadsheet format.) 
Click Next.

Figure 25: Control arrangements

Step 6: Set data entry.

Unless you have a need for any of these entries to be checked, accept 
the default settings. Click Next.

Step 7: Apply styles.

1) Select the color you want in the Apply Styles list. (I chose the 
beige which is Orange 4 in the Color table.)

2) Select the Field border you want. (I prefer the 3-D look. You might 
want to experiment with the different possible settings.)

3) Click Next.

Step 8: Set name.

1) Enter the name for the form. In this case, it is Fuel.
2) Click the circle in front of Modify the form. (This circle is called a 

radio button.)
3) Click Next. The form opens in Edit mode.
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Modifying a form
We will be moving the controls to different places in the form and 
changing the background to a picture. We will also modify the label for 
the PaymentType field as well as change the field to a list box.

First, we must decide what we want to change and to what. The 
discussion will follow this ten step outline.

1) The Date field in the main form needs a dropdown capability. It 
also needs to be lengthened to show the day of the week, month, 
day, and year.

2) Shorten the length of the payment fields (all fields containing the 
word payment).

3) The controls need to be move into groups: food, fuel subform, and 
miscellaneous.

4) Some of the labels need to have their wording changed. Some 
single words should be two words. Some abbreviations should be 
used if possible (Misc. for miscellaneous).

5) The widths of several fields and labels need to be changed. Only 
Lunch, Supper, Motel, and Tolls have acceptable lengths. But for a 
better appearance, changes will be made to these as well.

6) All the fields whose label ends in Payment will be replaced with a 
list box. This box contains the entries from the Payment Type 
table.

7) The Note field needs to be lengthened vertically and a scroll bar 
added. It also needs to be moved.

8) Changes need to be made in the Date and PaymentType columns 
of the subform that are similar to the changes in the main form.

9) Headings need to be added for each group in the main form.
10) The background needs to be changed to a picture. Some of the 

labels will have to be modified so that they can be read clearly. 
The font color of the headings needs to be changed as well.

Here are some pointers that we will be using in these steps. The 
controls in the main form consists of a label and its field. Sometimes 
we want to work with the entire control, and other times we want to 
work with only the label or the field. There are times when we want to 
work with a group of controls.

• Clicking a label or field selects the entire control. A border 
appears around the control with eight green handles (Figure 26). 
You can then drag and drop it where you want.
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• Control+click a label or field selects only the label or the field 
(Figure 27).

Figure 26: A selected control

• By using the Tab key, you can change the selection from the field 
to the label or the label to the field.

Figure 27: Selecting a field of a control

• Moving a group of controls is almost as easy as moving one of 
them.
1) Click the field of the top left control to be moved, to select it.
2) Move the cursor to just above and to the left of the selected 

control.
3) Drag the cursor to the bottom right of the group of controls 

and release the mouse button.
As you drag the cursor, a dashed box appears showing what is 
contained in your selection. Make sure it is big enough to 
include the entire length of all the controls.
When you release the mouse button, a border with its green 
handles appears around the controls you selected (Figure 28).

Figure 28: Selecting multiple controls

Move the cursor over one of the fields. It changes to a double 
arrow (Figure 29).

Figure 29: Double arrow

Drag the group of controls to where you want them.

Before changing the Date field, we will move the Lunch and Tolls 
controls to the right 5 cm (2 inches).
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Tip

When either changing a size or moving a control, two properties 
of the Form Design toolbar should be selected: Snap to Grid, and 
Guides when Moving. Your controls will line up better, and an 
outline of what you are moving moves as the cursor moves.
You should also have both rulers active (Tools > Options > 
OpenOffice.org Writer > View). Since the form is created in 
Writer, that is where you have to make sure both horizontal and 
vertical rulers have a check in the box in front of them.

Note

I use centimeters when making changes in a form because 
centimeters are more accurate than inches. When moving 
controls (fields and their labels), placement is also more 
accurate. You can change your rulers from inches to centimeters 
by right-clicking each ruler and selecting centimeter from the 
context menu. You do not have to understand what centimeters 
are. You only have to match your controls, labels, or fields to 
specific numerals on a ruler.

Step 1: Change the Date field.

1) Control+click the Date field to select it (Figure 27).
2) Move the cursor over the middle green handle on the right side. It 

should change to a single arrow (Figure 30).

Figure 30: Single arrow

3) Hold the left mouse button down as you drag the cursor to the 
right until the length is 6 cm. The vertical dashed line is lined up 
with the 6. (This is approximately 2.4 inches.) Release the mouse 
button.

4) Click the Control icon in the Form Controls toolbar (Figure 31). It 
is the one circled in red. The Properties: Date Field window 
opens. Each line contains a property of the field.

Figure 31: Form Controls toolbar

• Go to the Date format property. This is a dropdown list with 
Standard (short) as the default setting.
Click the default Standard (short) to open the list. Click the 
Standard (long) entry to select it.

• Scroll down to the Dropdown property. Its default setting is 
No. It is also a dropdown list.
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Click the default No setting to open the list. Click Yes to select 
it.

Tip

To see what the Date field will look like, click the Form Mode 
On/Off icon (the second icon from the left in Figure 31). You can 
do this any time you want to see the form with the changes you 
have made.

Step 2: Shorten the width of a field.

All of the fields whose label contains the word payment are too wide. 
They need shortening before the controls are moved.

1) Control+click the BPayment field (Figure 32).

Figure 32: Selecting a field

2) Move the cursor over the middle green handle on the right. The 
cursor becomes a single arrow.

3) Drag the cursor to the left until the field is 2.5 cm wide (1 inch).

Tip
If you have the Snap to Grid and Guides when moving icons 
selected in the Design Format toolbar, you will see how wide the 
field is as you shorten it.

4) Repeat these steps to shorten these fields: Lpayment, SPayment, 
SnPayment, Mpayment, and MiscPayment.

Step 3: Move the controls to group them by category.

We want to move the controls so that they look like Figure 33.

Figure 33: Positioning of Controls
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1) Click the first control you want to move. A border appears around 
the control with eight green handles.

2) Move the cursor over the label or field of the control. It becomes 
a double arrow (Figure 29).

3) Drag and drop the control to where you want it.

Caution

  

Do not use Control+click when moving a field. It moves either 
the field or the label but not both. To move both, use a mouse 
click and drag to the desired spot.

4) Use the same steps to move the rest of the controls to where they 
belong.

Note

The only way to learn to do these two steps well is to practice 
them. Another way exists which will place controls where you 
want them, but this is a more advanced feature and will be 
explained in the Base Guide.

Step 4: Change the label wording.

Field names need to be single words. However, the labels for the fields 
can be more than one word. So, we will change them. To do so, we will 
be editing the text in the label.

1) Control+click the SnackNo label. Do one of the following:
• Right-click the SnackNo label.

– Select Control from the context menu (Figure 34). The 
window that opens is labeled Properties: Label field. It 
contains all of the properties of the selected label.

Figure 34: Context menu

– In the Label selection, click between the k and N in 
SnackNo.
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– Use the spacebar to make SnackNo into two words.
– Place a . (period) after the No. (Figure 35).
– Close the properties window.

Figure 35: Multi-word label

• Or, click the Control icon in the Form Control toolbar (Figure 
36). The Properties window opens. The rest of the steps are 
the same.

Figure 36: Form Controls toolbar

2) Use the same procedure to change these labels as well: BPayment 
to Payment, LPayment to Payment, SPayment to Payment, 
Miscellaneous to Misc., SnackCost to Snack Cost, MPayment to 
Payment, MiscPayment to Misc. Payment, and MiscNotes to Misc. 
Notes.

3) Close the Properties window.

Tip

All of the listings in the Properties window can be modified by 
you. For example, by changing the Alignment from Left to 
Center, the word or words in the label are centered within the 
Label. When you have some time, you might want to experiment 
with different settings just to see the results you get.

Step 5: Change the widths of the labels and fields.

We want the following controls to be 2 cm wide (0.8 inches): Breakfast, 
Lunch, Supper, Odometer, Snack No., Tolls, Snack Cost, Motel, and 
Misc. All of the payment fields were changed in step 2, but Misc. 
Payment needs to be changed to 3 cm (1.2 inches).

1) Click Breakfast. The border around it appears with eight green 
handles.

2) Move the cursor over the middle green handle on the right. The 
cursor changes into a single arrow.

3) Drag and drop the cursor to the left to shorten the control or to 
the right to lengthen the control. Use the guide lines to determine 
the width.

4) Repeat for the other listed controls.
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Step 6: Replace fields with other fields.

We want to replace the PaymentType field with a List Box. Then we can 
choose the type of payment from the Payment Type table rather than 
having to manually enter the type. In my case, each of my payment 
types begins with a different letter. If I enter the first letter of the 
payment type, the rest of the word automatically appears. I can then 
go to the next field.

1) Control+click the Payment field for Breakfast. The green handles 
appear around the field but not around the Label (Figure 37).

Figure 37: Selecting a field of a control

2) Right-click within the green handles and select Replace with > 
List Box. (Figure 34 is the context menu which contains the 
Replace with selection, and Figure 38 is the list of replacement 
fields.)

Figure 38: Replacement fields

3) Click the Control icon in the Form Controls toolbar (Figure 36) to 
open the Properties window.

4) On the General tab, scroll down to the Dropdown selection. 
Change the No to Yes in this dropdown list (Figure 39).
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Figure 39: Dropdown list open to 
reveal choices

5) Click the Data tab.
• Type of list contents is a dropdown list. Change it to Sql.

Figure 40: Type of list contents dropdown list 

• Type the following exactly as it is in the List contents box:

SELECT "Type", "Type" FROM "Payment Type"

Figure 41: List content for payment type fields
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Tip

You should be able to copy and paste SELECT "Type", "Type" 
FROM "Payment Type" from above directly into the List content 
box. Just make sure you copy from the S in SELECT to the 
double quotation mark after the phrase Payment Type and no 
more than this.

Note

What you wrote is called an SQL command. The words SELECT 
and FROM are written in capital letters because they are 
commands. When the command SELECT is used, it requires a 
field name within quotation marks and then the field’s alias, also 
within quotation marks. In this case, the field and its alias are the 
same. The FROM command requires the name of the table which 
contains the field. Single-word table names do not require 
quotation marks, but multiple-word table names do.

• Repeat these steps for the payment fields for Lunch, Supper, 
Motel, Snacks, and Misc. The main form should look like 
Figure 42 as far as where the controls are located. It also 
shows what the Note control should look like. Those changes 
are explained in the next step.

• Close the Properties window.

Figure 42: Position of controls in main form

Step 7: Change the Note field.

We want the Note control where it is located in Figure 42. Since it has 
a memo field type, it needs a vertical scrollbar for additional text space 
if desired.

1) Control+click the Note field. The green handles should surround 
the Note field but not its label.

2) Click the Control icon to open the Properties window (Figure 43).
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3) Scroll down to the Scrollbars setting. Change the selection from 
None to Vertical in this dropdown list.

Figure 43: Scrollbar selections in the 
Properties window

4) Close the Properties window.
5) Lengthen the Note field.

a) Move the cursor over the middle green handle at the bottom 
of the Note field. It becomes a vertical single arrow.

b) Drag the cursor down until the length is 6 cm (2.4 inches). 

Step 8: Change labels and fields in a subform.

The Date column needs to be widened. The field in the PaymentType 
column needs to be changed to a list box. The label for PaymentType 
column needs to be two words.

Change the PaymentType column:

1) Right-click the label PaymentType to open a context menu (Figure
44).

Figure 44: Choices for modifying a 
control in a subform
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2) Select Replace with, and then select List box from the context 
menu.

3) Again right-click the label PaymentType to open a context menu.
4) Select Column. This opens the Properties window (Figure 45).
5) In the Label box, change PaymentType to Payment Type.
6) Click the Data tab.
7) From the Type of list contents dropdown list, select sql.
8) Type the following exactly as it is written:

SELECT "Type", "Type" FROM "Payment Type"

9) Close the Properties window.

Figure 45: Properties window for 
control in a subform

Tip
Step 6: Replace fields with other fields., beginning with part 5, 
contains more detailed instruction.

Step 9: Add headings to groups.

1) Make sure the cursor in in the upper left corner. If it is not, click 
in that corner to move it there.

2) Use the Enter key to move the cursor down to the fifth line from 
the top.

3) Change the Apply Styles dropdown list from Default to Heading 2.

Figure 46: Apply Styles list
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4) Use the spacebar to move the cursor to where you want the 
heading to start.

5) Type the heading Meals.
6) Use the spacebar to move the cursor to the center of snack area.
7) Type the heading Snacks.
8) Use the Enter key to move the cursor between the Supper control 

and the subform.
9) Use the spacebar to move the cursor to the center of the subform.

10)  Type the heading Fuel Data.

Note

If you know how to use styles, you can open the Styles and 
Formatting window using F11. Right-clicking the Heading 2 
paragraph style allows you to modify the appearance of all three 
headings. See the Writer Guide Chapter 6.

Step 10: Change the background of a form.

The background for a form can be a color, or a graphic (picture). You 
can use any of the colors in the Color Table at Tools > Options > 
OpenOffice.org > Colors. If you know how to create custom colors, 
you can use them. You can also use a picture (graphic file) as the 
background. We will use a picture found in OOo: sky.gif (Figure 47). 
Since the background is dark in places, many of the labels and 
headings will need changing in order to be seen.

Figure 47: background graphic

1) Select the labels of the top row of controls.
a) Control+click the Date label.
b) Control+shift+click the rest of the labels of the top row. The 

border will gradually grow to the right as you do this until all 
the labels are enclosed in it.

Figure 48: Selecting multiple labels at one time

c) Click the Control icon in the Design Form toolbar to open the 
Properties window.
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d) Change the Background selection from Default to Light cyan. 
(This is a dropdown list.)

2) Select the other labels in the same way and then change their 
background color.

3) Close the Properties window.
4) Press the F11 key to open the Styles and Formatting window 

(Figure 49). Notice the left icon has a black outline around it. This 
is the Paragraph Styles icon. Below it is a list of paragraph styles 
including headings.

Note
I have chosen to use Light cyan as the background color for my 
labels. You are free to choose whatever color you wish, including 
a custom color you earlier created.

Figure 49: Top portion of the Styles and 
Formatting window

a) Right-click Heading 2 and select Modify from the context 
menu.

b) On the Paragraph Style dialog (Figure 50), click the Font 
Effects tab.

Figure 50: Tabs of the Paragraphs: Heading 2 window

c) Change the Font color dropdown list to Light cyan.
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Figure 51: Left side of 
Font Effects tab

d) Click OK to close the Paragraph Style: Heading 2 dialog.
e) Press the F11 key to close the Formatting and Styles window.

Tip

Learning how to use styles can be very helpful at times. By using 
styles, we changed the font color for all three headings at one 
time. There are other methods of changing the font color, but 
they require repeating the same steps for each heading.

5) Right-click the background and select Page from the context 
menu.

6) Click the Background tab (Figure 52).

Figure 52: Background tab of Page Styles

a) Change the As dropdown list from Color to Graphic.
b) Search for this file: sky.gif. It is located in the Gallery folder of 

OOo.
c)  Click the Browse button in the File section. Browse to the 

folder containing sky.gif.
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d) Select this file and click Open.
e) In the Type section, select Area.
f) Click OK to close the Page Style: Default window.

The form should look like Figure 53.

Figure 53: Finished form

Step 11: Change the tab order.

The Tab key moves the cursor from field to field. This is much easier to 
do than to click each field to enter data into it. It also permits us to 
group our expenses into areas before we begin entering data. For 
example, all of our meal receipts can be grouped together as can our 
snacks and also our fuel purchases.

1) Control+click the Date field.
2) Click the Form Design icon in the Form Controls toolbar to open 

the Form Design toolbar (Figure 54). Or, use View > Toolbars > 
Form Design to open this toolbar.

3) Click the Activation Order icon.

Figure 54: Form Design toolbar with Activation Order icon circled

4) Rearrange the order of the fields in the Tab Order window 
(Figure 55).
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Figure 55: Tab Order window

• Find the txtMPayment listing near the bottom of the list and 
click it.

• Click the Move Up button until txtPayment is just below 
fmtMotel.

• Use the same two steps to put the fields in the same order as 
in Figure 56. Click OK.

Figure 56: Tab order for the main form

5) Save and close the form.
6) Save the database.
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Creating forms in Design View
This method requires using the Form Controls and Form Design 
toolbars extensively. These techniques are beyond the scope of this 
document. Instructions for creating forms using Design view will be 
described in the Database Guide.

Creating subforms in Design View
Again, this is beyond the scope of this document. Creation of subforms 
in Design View will be described in the Database Guide.

Accessing other data sources
OpenOffice.org allows data sources to be accessed and then linked into 
OOo documents. For example, a mail merge links an external document 
containing a list of names and addresses into a letter, with one copy of 
the letter being generated for each entry.

To register a data source, choose File > New > Database to open the 
Database Wizard. Select Connect to an existing database. This 
allows access to the list of data sources that can be registered with 
OOo. These data sources can be accessed similarly to a dBase database 
as explained in the next section.

Once a data source has been registered, it can be used in any other 
OOo component (for example Writer or Calc) by selecting View > Data 
Sources or pressing the F4 key.

Tip Mozilla Address Books and dBase databases (among others) can 
be accessed, and entries can be added or changed.

Caution 

Spreadsheets can be accessed, but no changes can be made in 
the spreadsheet entries. All changes in a spreadsheet sheet 
must be made in the spreadsheet itself. Update the database 
and save it. Afterwards you see in your database the changes 
you made and saved in the spreadsheet. If you create and save 
an additional sheet in your spreadsheet, the database will have 
a new table the next time you access it.

44 Getting Started with Base



Accessing a dBase database
1) File > New > Database opens the Database Wizard window.

Note
Clicking the New icon and Database in the drop-down menu also 
open the Database Wizard window. (See Figure 1.)

2) Select Connect to an existing database. Pressing the Tab key 
highlights the Database type drop-down list. Typing D selects 
dBase. Click Next.

Note
Clicking the arrows opens a menu from which you can select 
dBase (Figure 57).

Figure 57: Database type selection

3) Click Browse and select the folder containing the database. Click 
Next.

4) Accept the default settings: Register the database for me, and 
Open the database for editing. Click Finish. Name and save the 
database in the location of your choice.

5) Create the Form using the Form Wizard as explained in “Creating
a database form” beginning on page 23.

Accessing a Mozilla address book
Accessing a Mozilla Address Book is very similar to accessing a dBase 
database. 

1) Select File > New > Database.
2) Select Connect to an existing database. Select Mozilla Address 

Book as the database type (Figure 57).
3) Register this data source.

These are steps 1, 2 and 4 of “Accessing a dBase database”.

Accessing spreadsheets
Accessing a spreadsheet is also very similar to accessing a dBase 
database.

1) Select File > New > Database.
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2) Select Connect to an existing database. Select Spreadsheet as the 
Database type (Figure 57).

3) Click Browse to locate the spreadsheet you want to access. If the 
spreadsheet is password protected, check the Password required 
box. Click Next.

4) If the spreadsheet requires a user’s name, enter it. If a password 
is also required, check its box. Click Next.

Caution 

This method of accessing a spreadsheet does not allow you to 
change anything in the spreadsheet. All modifications must be 
made in the spreadsheet itself. This method only allows you to 
view the contents of the spreadsheet, run queries, and create 
reports based upon the data already entered into the 
spreadsheet.

Registering databases created by OOo2.x and 
later
This is a simple procedure. Tools > Options > OpenOffice.org Base 
> Databases. Under Registered databases, there is a list of these 
databases. Below this list are three buttons: New, Delete, Edit. To 
register a database created by OOo2.x or later:

1) Click New.
2) Browse to where the database is located.
3) Make sure the registered name is correct. 
4) Click OK.

Using data sources in OpenOffice.org
Having registered the data source, whether a spreadsheet, text 
document, external database or other accepted data source, you can 
use it in other OpenOffice.org components including Writer and Calc.

Viewing data sources
Open a document in Writer or Calc. To view the data sources available, 
press F4 or select View > Data Sources from the pull-down menu. 
This brings up a list of registered databases, which will include 
Bibliography and any other database registered.

To view each database, click on the + to the left of the database’s 
name. (This has been done for the Automobile database in Figure 58.) 
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This brings up Tables and Queries. Click on the + next to Tables to view 
the individual tables created. Now click on a table to see all the records 
held in it.

Figure 58: Databases

Editing data sources
Some data sources can be edited in the View Data Sources dialog. A 
spreadsheet can not. A record can be edited, added or deleted.

The data is displayed on the right side of the screen. Click in a field to 
edit the value.

Beneath the records are five tiny buttons. The first four move 
backwards or forwards through the records, or to the beginning or end. 
The fifth button, with a small star, inserts a new record (Figure 59).

Figure 59: View Data Sources navigation buttons

To delete a record, right-click on the gray box to the left of a row to 
highlight the entire row, and select Delete Rows to remove the 
selected row.

Figure 60: Deleting a row in the Data View window

Launching Base to work on data sources
You can launch OOo Base at any time from the View Data Source pane. 
Just right-click on a database or the Tables or Queries icons and select 
Edit Database File. Once in Base, you can edit, add and delete tables, 
queries, forms, and reports.
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Using data sources in OOo documents
Data can be placed into Writer and Calc documents from the tables in 
the data source window. In Writer, values from individual fields can be 
inserted. Or, a complete table can be created in the Writer document. 
One common way to use a data source is to perform a mail merge.

Tip

 Selecting Tools > Mail Merge Wizard or clicking on the Mail 
Merge icon (a small paper-and-envelope icon on the View Data 
Source pane) launches the Mail Merge wizard which steps 
through creating a mail merge document. This is discussed in 
Chapter 11 (“Using Mail Merge”) in the Writer Guide.

Writer documents
To insert a field from a table opened in the data source window into a 
Writer document , click on the field name (the gray square at the top of 
the field list) and, with the left mouse button held down, drag the field 
onto the document. In a Writer document, it will appear as <FIELD> 
(where FIELD is the name of the field you dragged). 

For example: enter the cost of meals and who paid for them on a 
certain date of a vacation. Make a sentence of this data: “On (date), 
our breakfast cost (amount) paid by (name), our lunch cost (amount) 
paid by (name), and our supper cost (amount) paid by (name). Write 
the words of the sentence with the exception of the words in 
parentheses. Use the correct field names in the place of the words in 
parentheses.

1) Replacing (data)
• Begin the sentence by typing the word On.
• Click the field name Data in the data source window and drag 

it to the right of the word On. 
• The sentence becomes: On <Date>. If you have Field shadings 

turned on (View > Field shading), <Date> has a gray 
background. Otherwise it does not.

2) Replacing first (amount)
• Continue typing after <Date>: our breakfast cost. 
• Click the Breakfast field name and drag it to the right of what 

you have just typed.
• Make sure you have the proper spacing between the field 

names and the words before and after them.
• Results so far: On <Date> our breakfast costs <Breakfast>,
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3) Replacing the first name:
• Continue typing after <Breakfast>: paid by making sure to 

add a space afterward.
• Click the Bpayment field name and drag it to the right of what 

you just typed.
• Place a comma after <Bpayment>.
• Results so far: On <Date> our breakfast cost <Breakfast> 

paid by Dan<BPayment>,

4) Follow these examples to fill in the rest of the fields in the 
sentence.

• Use <Lunch> and <Lpayment> for the second set of (amount) 
and (name) in the sentence.

• Use <Supper> and <Spayment> for the third set of (amount) 
and (name) in th sentence.

• Final results: On <Date> our breakfast cost <Breakfast> paid 
by <BPayment>, our lunch cost <Lunch> paid by 
<LPayment>, our supper cost <Supper> paid by 
<SPayment>.

5) Add data to the fields of the sentence:
• Click the gray box to the left of the row of data you want to 

add. That row should be highlighted like the second row of 
Figure 61.

• Click the Data to Fields icon (circled in black in Figure 
61).This should fill the fields with the data from the row you 
chose.

• Click another row and then click this icon again. The data in 
the sentence changes to this selected row of data.

• Save the document.

Adding data in table format is a little easier and takes perhaps a few 
less steps. Some of the steps will be quite similar.

Note

Data can be added this way as a fields or text. Following the 
following steps. I leave this to the reader with which to 
experiment by changing the selections in the Insert Database 
Columns to see what results you can get.
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Figure 61: Selected row in data source window

1) Navigate to the place you want to place the table and click the 
location.

2) Click the gray box to the left of each row of the data source that 
you want to be a row in your table.

3) Click the Data to text icon to open the Insert Database Columns 
dialog (Figure 62). (The Data to text icon is circled in red in 
Figure 61.)

Figure 62: Insert Database Columns dialog

4) Move the fields you want in your table from the Database 
Columns list to the Table column(s) list.
• To place the fields in the order you select, click the field and 

use the single arrow to move the fields in the order you desire. 
You can also limit the fields you use to less than all of the 
fields available.

• If you want to use all of the fields, use the double arrow 
pointing to the right to move all of them at one time. The 
order of the fields in the table you create will be the same as 
in the data source table.

• If you want to remove a single field from the Table Column(s) 
list, click the field and use the single arrow pointing to the 
left.

• If you want to start over by moving all of the fields back to the 
Database Columns list, click the double arrow pointing to the 
left.
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5) Select the settings for your table. Use the default settings as in 
Figure 62.

6) Click OK.
7) Save the document.

Calc spreadsheets
There are two ways to enter data in a Calc spreadsheet. One enters the 
data into the spreadsheet cells. The other creates records in the 
spreadsheet just like they are done in creating a form in a database. 
While you can directly access the data in the spreadsheet cells, you can 
only see the data in the records created in the spreadsheet.

Entering data directly to the spreadsheet cells uses the Data to Text 
icon as we did to make a table in a Writer document. But differences 
exist in these two situations.

The steps are straightforward.

1) Click the cell of the spreadsheet which you want to be the top left 
of your data including the column names. 

2) Use F4 to open the database source window and select the table 
whose data you want to use. 

3) Select the rows of data you want to add to the spreadsheet:
• Click the gray box to the left of the row you want to select if 

only selecting one row. That row is highlighted.
• To select multiple rows, hold down the shift key while clicking 

the gray box of the rows you need. Those rows are 
highlighted.

• To select all the rows, click the gray box in the upper left 
corner. All rows are highlighted.

4) Click the Data to text icon to insert the data into the spreadsheet 
cells.

5) Save the spreadsheet.

Adding records to a spreadsheet is fairly easy. You need to have the 
Data Source window open, your spreadsheet open, and the table you 
want to use selected.

1) Click the gray box above the field name you wish to use to 
highlight it.

2) Drop and drag the gray box to where you want the record to 
appear in the spreadsheet.

3) Repeat until you have moved all of the fields you need to where 
you want them.
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4) Close the Data Source window: use F4.
5) Save the spreadsheet and click the Edit File button to make the 

spreadsheet read only. All of the fields will show the value for the 
data of the first record you selected.

6) Add the Form Navigation toolbar: View > Toolbars > Form 
Navigation.

Figure 63: Navigation arrows of a form

7) Click the arrows on the Form Navigation toolbar to view the 
different records of the table. (The arrows are circled in red.) The 
number in the box changes when you change the record number 
by clicking an arrow. The data in the fields changes 
correspondingly to the data for that particular record number.

Entering data in a form
Records are used to organize the data we enter into a form. They also 
organize the data we enter into a subform (Figure 64).

Figure 64: Single Record 

Each type of field allows a different method to enter the data. In most 
if not all cases, more than one method can be used.
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The first step to entering data in a form is to open it from the main 
database window.

1) Click the Forms icon in the Database list.
2) Find the form’s name in the Forms list (Vacations).
3) Double-click the form’s name.

The quickest way to enter a date in the Date field is to click the arrow 
that opens the dropdown calendar. Then click the day the you want 
(Figure 65). To change the month use the following steps. Then use the 
Tab key to go to the Odometer field.

• Click the left arrow before September to go back one month 
(August 2008).

• Click the right arrow after 2008 to go forward one month 
(October 2008).

• Multiple clicks in either direction will change the month the same 
number of times as the number of clicks. (The year also changes 
as you move from January back to December or December 
forward to January each time.)

Figure 65: Calendar dropdown

The Odometer, Tolls, and Motel fields are numerical fields. Enter 
values directly into them, or use the up and down arrows. When the 
value is entered, use the Tab key to go to the next field.

• Clicking the up arrow increases the value, and the down arrow 
decreases the value one unit.

• These two arrows only change the numerals to the left of the 
decimal place.

• Numerals to the right of the decimal place must be changed by 
deleting them and typing the desired ones.

The Motel's Payment field is a dropdown list. If as in my case, all of the 
elements of the list start with different letters, typing the first letter 
selects the desired letter.
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• If two or more elements of the list have the same first letter, 
repeated typing of the first letter will cycle through the elements 
with this same first letter. So, if you accidentally go past the the 
element you wanted, you can keep typing the first letter until it 
reappears again.

• When the selection is correct, use the Tab key to go to the Misc. 
field.

The rest of the fields of the main form are either numerical fields or 
dropdown lists until we reach the Misc. Notes field. It is a text field. 
Type anything you desire in this field just as you would any simple text 
editor.

Caution 

Since the Tab key is used to move between fields, it can not be 
used in a text field. All spacing must be done by the spacebar. 
Finally, the Enter key only acts as a line break to move the 
cursor to the next line. While the Enter key will move from non-
text fields to non-text fields, it will not do so from a text field. 
Use the Tab instead.

Note
If we did not have a subform for fuel data, using the Tab key in 
the last field would save all of the fields, clear them, and make 
the form ready to accept data on the second record.

Since we have a subform form, using the Tab key places the cursor in 
the first Date field of the subform with the date automatically entered 
to match the Date field of the main form.

The FuelCost, FuelQuantity, and Odometer fields are numerical fields. 
The Payment field is a dropdown list. Enter the data just as you did in 
the main form, and use the Tab key to go to the next field.

When you use the Tab key to leave the Payment field, it goes to the 
Date field of the next line and automatically enters the date. Now you 
can enter your second set of fuel data for this day.

To move to another record when the form has a subform, click any of 
the fields of the main form. In this case, click the Date field of the main 
form. Then use the directional arrows at the bottom. There are four of 
them from left to right: First Record, Previous Record, Next Record, 
and Last Record (Figure 63). To the right of these arrows is the New 
Record icon.

To create a new record while in another record in the main form, use 
one of these choices.

• Click the Next Record icon.
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• Or, click the New Record icon.

Tip

The number in the Record box is the number of the record whose 
data is shown in the form. (The data from the second record of 
the Vacations form was displayed when I took the screenshot for 
Figure 66.)
If you know the number of the record you want, you can enter it 
into the record box and then use the Enter key to take you to 
that record.

Figure 66 is a record with data inserted in its fields. Note that not all 
fields have data in them. It is only necessary to have data in every field 
if you determine ahead of time to require all fields contain data.

Caution
If you required data be entered for a particular field and you do 
not have data for that field, you can no longer create a new 
record. You have to edit the table containing that field and 
change the Entry Required. Save the table and the database. 
This could also cause you to lose data in the particular field.

Figure 66: Sample record of the Vacation form and subform

Creating queries
Queries are used to get specific information from a database. Using 
our CD-Collection table, we will create a list of albums by a particular 
artist. We will do this using the Wizard. The information we might want 
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from the Fuel table includes what our fuel economy is. We will do this 
using the Design View.

Note

Queries blur the differences between a database and a data 
source. A database is only one type of data source. However, 
searching for usable information from a data source requires a 
query. Since the query (one part of a database) does this, the 
data source appears to become one part of that database: its 
table or tables. Query results, themselves, are special tables 
within the database.

Using the Wizard to create a query
Queries created by the wizard provide a list or lists of information 
based upon what one wants to know. It is possible to obtain a single 
answer or multiple answers, depending upon the circumstances. 
Queries which require calculations are best created with the Design 
view.

In the main database window (Figure 2), click the Queries icon in the 
Databases section, then in the Tasks section, click Use Wizard to 
Create Query. The Query Wizard window opens (Figure 67). The 
information we want is what albums are by a certain musical group or 
individual (the album’s author). We can include when each album was 
bought.

Figure 67: First page of the Query Wizard
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Note

When working with a query, more than one table can be used. 
Since different tables may contain the same field names, the 
format for naming fields in a query is Table name and field name. 
A period (.) is placed between the table name and the field name. 
For example, The Lunch field of the Vacation table used in a 
query has the name Vacation.Lunch.

Step 1: Select the fields.

1) Select the CD-Collection table from the dropdown list of tables.
• If the Tables selection is not Table: CD-Collection, click the 

arrow (circled in red in Figure 67).
• Click Table: CD-Collection in the list to select it.

2) Select fields from the CD-Collection table in the Available fields 
list.
a) Click AlbumTitle, and use the > button (black oval in Figure

67) to move it to the Fields in Query list.
b) Move the Artist and DatePurchased fields in the same manner.
c) Use the up arrow to change the order of the fields: artist, 

album, and date purchased.
• Click the CD-Collection.Artist field.
• Click the up arrow to move it above CD-

Collection.AlbumTitle.
d) Click Next.

Tip To change the order of the fields, select the field you want to 
move and click the up or down arrow to move it up or down 
(circled in magenta in Figure 67).

Figure 68: List of fields added to the query

Step 2: Select the sorting order.

Up to four fields can be used to sort the information of our query. A 
little simple logic helps at this point. Which field is most important?
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In our query, the artist is most important. The album title is less 
important, and the date purchased is of least importance. Of course, if 
we were interested in what music we bought on a given day, the date 
purchased would be the most important.

Figure 69: Sorting order page

1) Click the first Sort by dropdown list.
• Click CD-Collection.Artist to select it.
• If you want the artists to be listed in alphabetical order (a-z), 

select Ascending on the right. If you want the artist listed in 
reverse order (z-a), select Descending on the right (Figure
69).

2) Click the second Sort by dropdown list.
• Click CD-Collection.ArtistTitle.
• Select Ascending or Descending according to the order you 

want.

3) Repeat this process for CD-Collection.DatePurchased.
4) Click Next.

Step 3: Select the search conditions.

The search conditions available are listed below. They allow us to 
compare the name we entered with the names of the artist in our 
database and decide whether to include a particular artist in our query 
or not.

• is equal to: the same as
• is not equal to: not the same as
• is smaller than: comes before
• is greater than: comes after 
• is equal or less than: the same as or comes before
• is equal or greater than: the same as or comes after
• like: similar to in some way
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Note
These conditions apply to numbers, letters (using the 
alphabetical order), and dates.

1) Since we are only searching for one thing, we will use the default 
setting of Match all of the following.

2) We are looking for a particular artist, so select is equal to.
3) Enter the name of the artist in the Value box. Click Next.

Step 4: Select type of query.

We want simple information, so the default setting: Detailed query is 
what we want. Click Next at the bottom of the window.

Note
Since we have a simple query, the Grouping and Grouping 
conditions are not needed. Those two steps are skipped in our 
query.

Step 5: Assign aliases if desired.

We want the default settings. Click Next.

Step 6: Overview.

Name the query (suggestion: Query_Artists). To the right of this are 
two choices. Select Display Query. Click Finish.

Step 7: Modify the query.

We are skipping this step since we have nothing to modify. If you select 
the Modify Query choice, the query would open in Design view. To 
make modifications, follow the instructions in the next section, “Using
the Design View to create a query”.

Using the Design View to create a query
Creating a query using Design View is not as hard as it may first seem. 
It may take multiple steps, but each step is fairly simple.

What fuel economy is our vehicle getting (miles per gallon in the USA)? 
This question requires creating two queries, with the first query being 
used as part of the second query.

Creating queries 59



Caution 

The procedures we will be using only work with relational 
databases. This is because of how relational databases are 
constructed. The elements of a relational database are unique. 
(The primary key insures this uniqueness.) That is, there are no 
two elements which are exactly alike. This allows us to select 
specific elements to place into our queries. Without the 
elements of the relational database being unique from all other 
elements, we could not perform these procedures.

Step 1: Open the first query in Design View.

Click Create Query in Design View.

Step 2: Add tables.

Figure 70: Add Tables or Query window

1) Click Fuel to highlight it.
2) Click Add. Click Close.

Tip

Move the cursor over the bottom edge of the fuel table (Figure
71). The cursor become a single arrow with two heads. Drag the 
bottom of the table to make it longer and easier to see all of the 
fields in the table.

Figure 71: Fuel table in query

Step 3: Add fields to the table at the bottom.

1) Double-click the FuelID field in the Fuel table.
2) Double-click the Odometer field.
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3) Double-click the FuelQuantity field.

The table at the bottom of the query window should now have three 
columns (Figure 72).

Figure 72: Query table

Step 4: Set the criterion for the query.

We want to the query's FuelID to begin with the numeral 1.

1) Type >0 in the Criterion cell under FuelID in the query table
2) Click the Run Query icon in the Query Design toolbar. This icon is 

circled in red in Figure 73.

Figure 73: Query Design toolbar

Figure 74 contains the Fuel table with my entries and the query results 
based upon the Fuel table.

Figure 74: Fuel table and query of the fuel table

Step 5: Save and close the query.

Since this query contains the ending odometer reading for our 
calculations, name it End-Reading when saving it. Then close the 
query.

Step 6: Create the query to calculate the fuel economy.

1) Click Create Query in Design View to open a new query.
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2) Add the Fuel table to the query just as you did in step 2: Add
tables. But, do not close the Add Tables window.

3) Add the End-Reading query to this query.
a) Click the Query radio button to get the list of queries in the 

database (Figure 75).

Figure 75: Selecting queries to add to another query

b) Click End-Reading.
c) Click Add, and then click Close.

Step 7: Add fields to the table at the bottom of the query.

We are going to calculate the fuel economy. To do this we need the 
FuelQuantity and distance traveled. Since the FuelQuantity we want to 
use is at the ending odometer reading, we will use the End-Reading 
query to get it. We will also use the Odometer field from the Fuel table 
and End-Reading query.

Figure 76: Tables in this query

1) Double-click FuelQuantity in the End-Reading query.
2) Double-click Odometer in the End-Reading query.
3) Double-click Odometer in the Fuel table.

Figure 77: Added fields to the query
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Step 8: Enter the FuelID difference field.

We want the difference between the FuelID value of the Fuel table and 
FuelID value of the End-Reading query to equal one (1).

1) Type "End-Reading".FuelID - Fuel.FuelID in the field to the 
right of the Odometer field of the Fuel Table (Figure 78).
Type the numeral 1 (one) in the Criterion cell of this column.

Figure 78: Typing in calculation of fields

2) Calculate the distance traveled (Figure 79):
• Type "End-Reading".Odometer – Fuel.Odometer in the Field 

cell.
• Type >0 in the Criterion cell.

Figure 79: Field for distance traveled calculations

3) Calculate fuel economy (Figure 80):
Type ("End-Reading".Odometer – Fuel.Odometer)/"End-
Reading".FuelQuantity in the Field in the next column to the 
right.

Figure 80: Fuel economy calculation field
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Caution 

When entering fields for these calculations, you must follow 
this format: table or query name followed by a period follow by 
the field name. For hyphenated or multiple-word names (table 
or query), use double quotes around the table or query name. 
The query will then add the rest of the double quotes as in 
Figure 78.
Use the arithmetical symbol between the two. More than one 
calculation can be done by using parentheses to group the 
arithmetical operations. 

Step 9: Run the query and make some modification.

After we run the query to make sure it works correctly, we will hide all 
of the fields that we do not need.

1) Click the Run Query icon in the Design Query toolbar (Figure 73). 
The results are in Figure 81.

Figure 81: Result of running the fuel economy query

Notice that not all of the last column label is visible because some 
of the labels are long. We can fix this problem by using an alias 
for many of the fields. The labels are replaced by their aliases.

2) Add Aliases:
Type in the aliases as they are listed in Figure 82.

Figure 82: Query table with aliases added

3) Run the query again. The results are in Figure 83.

Figure 83: Query run with aliases

We really do not need the column showing the difference between 
the FuelID fields from the table and query. So, we will hide it. 
While it will not be visible, it will still be used in the calculations.

4) Hide a field that does not need to be seen.
Remove the check in the box of the Visible cell as in Figure 84.
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Figure 84: Making a field invisible in a query run

5) Rerun the query (Figure 85).

Figure 85: Query run with aliases

Step 10: Close, save, and name the query.

My suggestion for a name is Fuel Economy.

There are obviously other calculations that can be made in this query 
such as cost per distance traveled and how much of the cost belongs to 
each of the payments types.

Note

To fully use queries requires a knowledge of mathematics and 
specifically set operations (unions, intersections, and, or,  
complements, and any combinations of these). For example, we 
listed all of our criteria in one row. That means that all of these 
criteria have to be met before a row of values will be created in 
the query. This is how the and operator works on sets.
It also requires having a copy of the Hsqldb User Guide available 
from http://hsqldb.org/.

Creating reports
Reports provide information found in the database in a useful way. In 
this they are similar to queries. Reports are generated from the 
database’s tables or queries. They can contain all of the fields of the 
table or query or just a selected group of fields. Reports can be static 
or dynamic. Static reports contain the data in the selected fields at the 
time the report was created. Dynamic reports can be updated to show 
the latest data.
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Caution

Dynamic reports update only the data that is changed or added 
to a table or query. It does not show any modifications made to 
a table or query. For example, open the fuel economy query you 
just created. For the "End-Reading".”Odometer – 
Fuel.”Odometer” column, change the number 1 to the number 3 
after creating the report below. The report will be identical 
before and after you make the change.

For example, a report on vacation expenses divided into categories 
should probably be a static report because it is based upon specific 
data that does not change. However, a report on the fuel data should 
probably be a dynamic report, because this report depends upon data 
that does change.

Caution 
All reports are based upon a single table or query. So you 
need first to decide what fields you want to use in the report. 
If you want to use fields from different tables, you must first 
combine these fields in a single query. Then you can create a 
report on this query.

An example of this caution is creating a report on vacation expenses. 
Fuel costs are one part of that report as are meal costs. These values 
are contained in fields of two different tables: Vacations and Fuel. So 
this report requires creating a query.

Creating a static report
We will create a report on vacation expenses. Certain questions need 
to be asked before creating the report.

• What information do we want in the report?
• How do we want the information arraigned?
• What fields are required to provide this information?
• Will a query have to be created because these fields are in 

different tables?
• Are there any calculations required in the data before being 

added to the report?

The expenses for our vacation are motel, tolls, miscellaneous, 
breakfast, lunch, supper, snacks, and fuel. One possible report would 
simply list the totals of each of these expense groups. Another possible 
report would list the expense totals for each day of the vacation. A 
third possible report would list the totals for each expense group for 
each type of payment. (This would let us know where the money came 
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from to pay the expenses.) At the present time, using the data from the 
queries in a spreadsheet is the best way to handle reports like this. In 
the near future, the report feature will include these abilities.

For our purposes, we will create two reports. The first one will list the 
expenses each day other than fuel. The second report will list the fuel 
costs each day.

The fields we will need for the first report from the Vacations table are: 
Date, Motel, Toll, Breakfast, Lunch, Supper, SnackCost, and 
Miscellaneous. This report will not require an additional query.

The second report involves the Fuel table. Since fuel was purchased 
and entered into this table at times other than during the vacation, a 
query needs to be created that contains only the fuel purchased during 
the vacation.

Vacations table report

1) Create a new report.
a) Click the Reports icon in the Database list in the Automobile – 

OpenOffice.org window.
b) In the Tasks list, click Use Wizard to Create Report. The 

Report Wizard window opens.
2) Select the fields.

a) Select Table: Vacations in the Tables or Queries dropdown list.
b) Use the > to move these fields from the Available fields list to 

the Fields in report list: Date, Motel, Tolls, Miscellaneous, 
Breakfast, Lunch, Supper, and SnackCost (Figure 86). Click 
Next.

Figure 86: Adding fields to a report

3) Label the fields: answering the question How do you want to label 
the fields.
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• Click the field label you want to change and make your 
changes as you would in any text box.

• Shorten Miscellaneous to Misc. Click Next.
5) Since we are grouping by the date, use the > button to move the 

Date field to the Grouping list. Click Next.

Figure 87: Selecting fields for grouping data

6) Sort options.
We do not want to do any additional sorting. Click Next.

7) Choose layout.
We will be using the default settings for the layout. Click Next.

8) Create report.

• Label the report: Vacation Expenses.
• Select Static report.
• Click Finished.

Note

If you feel adventurous, try selecting some of the other layout 
choices. After selecting a choice, drag and drop the Report 
Wizard window so that you can see what you have selected. 
(Move the cursor over the Heading of this window, and then 
drag and drop.)

Vacation fuel report

1) Create a query containing only fuel bought on the days of the 
vacation.
a) Open a query in Design View.
b) Follow the steps for adding tables in Add tables. Add the Fuel 

table.
c) Double-click these fields in the Fuel table listing: Date and 

FuelCost to enter them in the table at the bottom of the query.
d) In the Criterion cell of the Date field, type the following: 

BETWEEN #5/25/2007# AND #5/26/2007# 
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Figure 88: Setting the criterion for a query

2) Save, name, and close the query. (Suggestion: Vacation Fuel 
Purchases.)

Tip

When using dates in a query, enter them in numerical form MM/
DD/YYYY or DD/MM/YYYY depending upon your language's 
default setting for dates (my default setting is MM/DD/YYYY).
All dates must have a # before and after it. Hence, May 25, 2007 
is written #05/25/2007# or #25/5/2007depending upon your 
language's default setting.

3) Open a new report.
• Right-click the Vacation Fuel Purchases query.
• Select Report Wizard from the context menu.

Note
When a new report is opened in this way, the query used to 
open it is automatically selected in the Tables or Queries 
dropdown list.

4) Create the report.
Use >> to move both fields from the Available Fields to the Fields 
in Report list. Click Next.

5) Label fields.
Add a space to FuelCost to make it Fuel Cost (two words). Click 
Next.

6) Group fields.
Click Date to highlight it. Use > to move the Date field to the 
Groupings list. Click Next.

7) Choose layout.
We will be making no changes in the layout. Click Next.

8) Create report (final settings).
• Use the suggested name, which is the same as the query.
• Select Static report.
• Click Finish.
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Creating a dynamic report
We will create a report with some statistics on our fuel consumption. 
To do this, we have to modify two queries: End-Reading and Fuel 
Economy. We will be adding the FuelCost field to the End-Reading 
query. Then we will add the FuelCost field from the End-Reading query 
to the Fuel Economy query.

Tip

When opening a query to edit it, it might appear as in Figure
89. If you move your cursor over the black line (circled in red), 
it becomes a double headed arrow. Drag and drop it to a lower 
position.

Figure 89: Appearance of query when opened for editing

1) Add the FuelCost field to the End-Reading query:
• In the Fuel table list, double-click to add FuelCost to the 

bottom table (Figure 90).
• Save and close the query.

Figure 90: Adding an additional field to the query

2) Right-click the End-Reading query and select Edit from the 
context menu.
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3) Add the FuelCost field from the End-Reading query to the Fuel 
Economy query:
• Right-click the Fuel Economy query and select Edit from the 

context menu.
• Double-click the FuelCost field in the End-Reading query list 

to add it to the query table at the bottom.

4) Add a calculation field to the right of the FuelCost field.
• Type the following in an Field cell in the table at the 

bottom:"End-Reading".FuelCost/("End-Reading".Odometer 
– Fuel.Odometer)

• Type the following in its Alias cell: cost per mile.

Note If you use the metric system, cost per km is the appropriate 
alias.

5) Save and close the query.
6) Open a new report.

Right-click the Fuel Economy query and select Report Wizard.
7) Select fields.

Move all the fields from the Available fields to the Fields in report 
list. Use the >> to do so. Click Next.

8) Label fields.
Change FuelCost to Fuel Cost by placing a space between the 
words. Click Next.

9) Group fields.
Use > to move the Date field to the Groupings list. Click Next.

10) Sort options: the wizard skipped this one.
11) Choose layout.

Accept the default. Click Next.
12) Create the report.

• Change the report name to Fuel Statistics.
• The default setting is Dynamic report, so no change is 

necessary.
• Select Modify report layout.
• Click Finish.
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Modifying a report
At the end of the last section, we left the Fuel Statistics report open in 
the edit mode (Figure 91). We will be working on that report. These 
same steps can be used with any report that you open for editing.

Figure 91: A report in edit mode

The Author is the name you listed in Tools > Options > 
OpenOffice.org > User Data. The date is not correct. The columns 
need to be moved to the left to give a better appearance. None of the 
numbers are correct, but their only purpose is to show the number of 
decimal places.

Step 1: Change the date.

1) Click to the right of the date (4/26/20) so that the cursor is next to 
the field. Use the Backspace key to erase the date.

2) Insert > Fields > Date. This places today’s date where the 
original date was.

3) Changing the date formating:
a) Double-click the date field you just inserted. The Edit Fields: 

Document window opens (Figure 92).

Figure 92: Modifying a date field

b) Since this is a dynamic report, change the Select field from 
Date (fixed) to Date.

c) Change the Format to what you desire. (I use the Friday, 
December 31, 1999 choice.) Click OK.
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Step 2: Change the column widths.

The column widths can be changed by moving the cursor over the right 
border of each column so that it becomes a double-headed arrow. Then 
drag and drop it to where you want it. This has to be done for each 
column in each table in the report. This can also be done with the last 
column on the right even though there is no black border. It should 
now look something like Figure 93.

Figure 93: Realigned columns in a report

Step 3: Change the number formating in the cells.

The fuel quantity should have three decimal places. The Begin, End, 
and Distance should have one decimal place. Fuel Cost should be 
currency and have two decimal places, and Cost per mile should have 
three decimal places.

1) Right-click the cell below Quantity to open the context menu. (The 
cell is circled in red in Figure 93.)

2) Select Number format.
3) In the Options section (Figure 94),

a) Change the number of Decimal places to 3.
b) Click the green checkmark. Click OK.

Figure 94: Option section of the Number Formating window

4) Change the Cost per mile field.
a) Right-click in the cell below Fuel Cost.
b) Select Number Format.
c) In the Category list, select Currency. Click OK.
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5) Change the Fuel Cost field.
a) Right-click in the cell below Cost per mile.
b) Select Number Format.
c) In the Category list, select Currency.
d) In the Option section:

• Set the number of decimal places to 3.
• Click the green checkmark.

e) Click OK.
Step 4: Save and close the report.

Double-click the report. It should now look like Figure 95.

Figure 95: Final report
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More ways to create reports
An extension is available to assist in report creation. Sun Report 
Builder creates stylish, complex database reports. You can define 
group and page headers, group and page footers, and calculation 
fields. It is available from http://extensions.services.openoffice.org/.

To install this extension, follow these steps:
1) Select Tools > Extension Manager from the menu bar. In the 

Extension Manager dialog, click Get more extensions here....
2) The OOo extensions page opens in your browser window. Find 

and select the extension you want to install and follow the 
prompts to install it. During installation, you will be asked to 
accept a license agreement.

3) When the installation is complete, the extension is listed in the 
Extension Manager dialog.

For more about extensions, see Chapter 14 (Customizing 
OpenOffice.org).
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