
Working with Sections

Title: Working with Sections
Version: 1.0
First edition: March 2004
First English
edition: March 2004





Contents

Overview..........................................................................................................................................ii

Copyright and trademark information.........................................................................................ii

Feedback..................................................................................................................................... ii

Acknowledgments.......................................................................................................................ii

Modifications and updates.......................................................................................................... ii

What is a section?............................................................................................................................ 1

Creating sections..............................................................................................................................1

Opening the Insert Section window............................................................................................ 1

Using the Section tab...................................................................................................................2

Using the Columns tab................................................................................................................ 5

Using the Indents tab...................................................................................................................7

Using the Background tab........................................................................................................... 8

Using the Footnotes/Endnotes tab.............................................................................................10

Saving a new section................................................................................................................. 12

Maintaining sections...................................................................................................................... 12

Editing and deleting sections.....................................................................................................12

Updating links........................................................................................................................... 15

Working with Sections i



Overview

Overview

This chapter shows you how to create and maintain sections in a text document using
OpenOffice.org Writer 1.1.x. To understand the instructions, you need to know how to create
and edit documents in Writer.

Copyright and trademark information
The contents of this Documentation are subject to the Public Documentation License,
Version 1.0 (the "License"); you may only use this Documentation if you comply with the
terms of this License. A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf.

The Original Documentation is How to Work with Sections. The Initial Writer(s) of the
Original Documentation is/are Catherine Waterman © 2004. All Rights Reserved. (Initial
Writer contact(s): sparkovich@att.net. The Initial Writer contact(s) is to report  errors in the
documentation. For questions regarding how to use the software, subscribe to the Users Mail
List and post your question there: http://support.openoffice.org/index.html.)

All trademarks within this guide belong to legitimate owners.

Feedback
Please direct any comments or suggestions about this document to:
dev@documentation.openoffice.org 

Acknowledgments
Thanks to Sophie Gautier, author of the French native-language document, Comment Utiliser
Les Différentes Sections, which was used as a reference. This chapter has been slightly
modified by Paul Miller and Jean Hollis Weber, and it has been given a new title as a chapter
of the User Guide for OpenOffice.org Writer.

Modifications and updates

Version Date Description of Change

1.0 11 Dec 2004 First published edition.
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What is a section?

What is a section?

A section is a block of text that has special attributes and formatting. You can use sections to:

• Write-protect text.

• Hide text.

• Dynamically insert the contents of another document.

• Add columns, margin indents, a background color, or a background graphic to a
portion of your document.

• Customize the footnotes and endnotes for a portion of your document.

Creating sections

This part of the chapter shows you how to:

• Open Writer’s Insert Section window.

• Use the Insert Section window to customize a new section.

• Save the new section.

Opening the Insert Section window
To open Writer’s Insert Section window, follow these steps:

1) Place the cursor at the point in your document where you want to insert the new
section. Or, select the text that you want to place in the new section. 

2) From the main menu, choose Insert > Section... The Insert Section window opens. 

3) Click the Section tab if it isn’t already displayed. (See Figure 1.)

The Insert Section window has five tabs:

• Use the Section tab to set the section’s attributes.

• Use the Columns tab to format the section into columns.

• Use the Indents tab to set indents in the right and left margins of the section.

• Use the Background tab to add color or a graphic to the section’s background.

• Use the Footnotes/Endnotes tab to customize the section’s footnotes and endnotes.

The next five parts of this chapter tell you how to use each of these five tabs.

At any time, you can reset a tab to its default settings by clicking the Reset button. (Note,
however, that you cannot reset the Section tab. If you wish to undo changes to the Section
tab, you must do so manually.)
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Creating sections

Figure 1. Section tab of Insert Section dialog

Using the Section tab
Use the Section tab, pictured in Figure 1, to set the attributes of the current section. 

Naming sections

Writer automatically enters a name for the current section in the top box of the New section
area. To change the name, simply type over it.

Linking sections

You can insert the contents of another document into the current section and then have Writer
update the section whenever the other document is updated. This is called linking the section
to the other document. 
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Creating sections

To link the current section to another document, follow these steps:

1) In the Link area (see Figure 2), check the Link checkbox.

Figure 2. Link area of Section tab

2) Click the (...) button to the right of the File name field. The Insert window opens. 

3) Find and select the document whose contents you want to insert and then click the
Insert button. The Insert window closes and the name of the selected document
appears in the File name field. 

4) If you want to insert only a section of the selected document, select the desired section
from the Section drop-down list. 

Note: The section must already exist in the selected document. You cannot create a
section in the selected document at this point.

If you are familiar with DDE object linking and prefer to use DDE commands for linking,
check the DDE checkbox. The DDE command field appears, allowing you to enter a DDE
command.

You can update links automatically or manually. To learn more, see “Updating links” on page
14.

Write-protecting sections

To write-protect the current section so that its contents can’t be edited, check the Protect
checkbox in the Write protection area (Figure 3).

Figure 3. Write protection area of Section tab

Note: Write-protection only protects the section’s contents, not its attributes or format. 
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Creating sections

To prevent others from editing the section’s attributes or format, protect the section with a
password, as follows:

1) Check the With password checkbox. The Enter Password window (Figure 4) opens.

Figure 4. Enter Password window

2) Enter a password in the Password field and then confirm the password by entering it
again in the Confirm field. 

Note: Passwords must contain a minimum of 5 characters. The OK button remains
inactive until you have typed at least 5 characters.

3) Click OK. The Enter Password window closes. Anyone who tries to edit the section’s
attributes or format will be prompted to enter the password. 

Hiding sections

You can hide the current section so that it won’t be displayed on the screen or printed. You
can also specify conditions for hiding the section. For example, you can hide the section only
from certain users. 

To hide a section, check the Hide checkbox in the Hide area (Figure 5). 

Figure 5. Hide area of Section tab

If you want to hide the section only under certain conditions, enter the desired conditions in
the With Condition field. The syntax and operators that you use to enter conditions are the
same ones that you use to enter formulas. For syntax and a list of operators, see Writer’s
online help under “Conditions.”

Note: You can’t hide a section if the section is the only content on the page or if the section is in
a header, footer, footnote, endnote, frame, or table cell.
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Using the Columns tab
Use the Columns tab, pictured in Figure 6, to format the current section into columns.

Figure 6. Columns tab of the Insert Section dialog

You can use one of Writer’s predefined column layouts, or you can create a customized
column layout.

The preview box, located to the right of the Settings area, shows as you work how the
column layout will look.

Using a predefined column layout

The Settings area displays five predefined column layouts. To use one of them, simply click
the desired layout.

Specifying the number of columns

If you prefer to create a customized column layout, you must specify the number of columns
that you want. Enter the desired number in the Columns spin box of the Settings area.
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Distributing text across columns

You can choose to distribute text across the columns in one of two ways:

• Evenly. If you choose to distribute text evenly, Writer will fill the first line of each
column, followed by the second line of each column, and so on.

• Newspaper-style. If you choose to distribute text newspaper-style, Writer will fill the
columns one at a time, beginning with the first column. 

To distribute text evenly, check the Evenly distribute contents to all columns checkbox in
the Settings area. Clear this checkbox if you want to distribute text newspaper-style.

Formatting column width and spacing 

To create evenly-spaced columns that are all the same width, check the AutoWidth
checkbox in the Width and spacing area. 

To customize the width and spacing of the columns, follow these steps:

1) In the Width and spacing area, clear the AutoWidth checkbox.

2) On the Width line, enter a width for each column. 

3) On the Spacing line, enter the amount of space that you want between each column
pair.

Use the arrow keys on the Column line to scroll among the columns.

Formatting separator lines

To display separator lines between the columns, follow these steps:

1) From the Line drop-down list in the Separator line area, select the type of line that you
want. 

2) By default, the separator lines are the same height as the columns. If you want the
separator lines to be shorter than the columns, use the Height spin box to enter the
height of the separator lines as a percentage of the height of the columns. For example,
if you enter 50%, the separator lines will be half as high as the columns.

3) If you entered a height of less than 100%, use the Position drop-down list to select a
vertical alignment for the separator lines.

Reverting to a single-column layout

To revert to a single-column layout, simply reset the Columns spin box to 1. Or, in the
Settings area, click the single-column layout that’s located to the right of the Columns spin
box.
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Creating sections

Using the Indents tab
Use the Indents tab, pictured in Figure 7, to set indents in the right and left margins of the
current section.

Enter the desired left-margin indent in the Before section spin box. Enter the desired right-
margin indent in the After section spin box. The preview box on the right-hand side of the
tab shows you how the section will look with the indents applied.

Figure 7. Indents tab of the Insert Section dialog
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Using the Background tab
Use the Background tab, pictured in Figure 8, to add color or a graphic to the background of
the current section. 

Adding color 

To add color to the background of the current section, simply click the desired color in the
color grid. 

Figure 8. Background tab of the Insert Section dialog

Adding a graphic 

To add a graphic to the background of the current section, follow these steps:

1) From the As drop-down list, select Graphic. The Background tab displays the
graphics options. (See Figure 9.)

2) Click the Browse button. The Find Graphics window opens. 

3) Find the graphic file that you want to use and then click the Open button. The Find
Graphics window closes and the selected graphic appears in the graphic preview box
on the right-hand side of the Background tab. (If you don’t see the graphic, check the
Preview checkbox underneath the graphic preview box.)
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4) In the Type area of the Background tab, choose how you want the background
graphic to appear:

• To position the graphic in a specific location in the background, select Position
and then click the desired location in the position grid.

• To stretch the graphic so that it fills the entire background area, select Area.

• To repeat the graphic across the entire background area, select Tile.

Figure 9. Graphics options on the Background tab of the Insert Section dialog

Deleting color or graphics

To delete color or graphics from the background of the current section, follow these steps:

1) From the As drop-down list, select Color.

2) Click No Fill on the color grid. 
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Using the Footnotes/Endnotes tab
Use the Footnotes/Endnotes tab, pictured in Figure 10, to customize the current section’s
footnotes and endnotes.

Figure 10. Footnotes/Endnotes tab of the Insert Section dialog

Customizing footnotes

If you want the current section’s footnotes to appear separately from the other footnotes in the
document, check the Collect at end of text checkbox in the Footnotes area. 

To number the current section’s footnotes separately from the other footnotes in the
document, follow these steps:

1) In the Footnotes area, make sure that the Collect at end of text checkbox is checked.

2) Check the Restart numbering checkbox.

3) If you want the section’s footnotes to start at a number other than 1, enter the desired
starting number in the Start at spin box.

To edit the format of the section’s footnotes, follow these steps:

1) In the Footnotes area, make sure that the Collect at end of text and Restart
numbering checkboxes are checked.
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2) Check the Custom format checkbox.

3) From the drop-down list to the right of the Custom format checkbox, select a
numbering format for the footnotes.

4) To add text to the selected numbering format, use the Before and After fields. For
example, if you want the footnote numbers to be preceded by the word “Note” and
followed by a colon, fill the Before and After fields like this: 

Figure 11. Customized format for footnotes

Customizing endnotes 

If you want the current section’s endnotes to appear at the end of the section rather than at the
end of the document, check the Collect at end of section checkbox in the Endnotes area. 

To number the current section’s endnotes separately from the other endnotes in the
document, follow these steps:

1) In the Endnotes area, make sure that the Collect at end of section checkbox is
checked.

2) Check the Restart numbering checkbox.

3) If you want the section’s endnotes to start at a number other than 1, enter the desired
starting number in the Start at spin box.

To edit the format of the section’s endnotes, follow these steps:

1) In the Endnotes area, make sure that the Collect at end of section and Restart
numbering checkboxes are checked.

2) Check the Custom format checkbox.

3) From the drop-down list to the right of the Custom format checkbox, select a
numbering format for the endnotes.

4) To add text to the selected numbering format, use the Before and After fields. For
example, if you want the endnote numbers to be preceded by the word “Note” and
followed by a colon, fill the Before and After fields like this: 

Figure 12. Customized format for endnotes
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Saving a new section
To save a new section so that it appears in your document, click the Insert button. The Insert
Section window closes and the new section appears in your document.

Maintaining sections

This part of the chapter shows you how to:

• Edit and delete sections.

• Update links.

Editing and deleting sections
You can edit a section’s attributes and formatting, and you can also delete sections.

Selecting a section

To select the section that you want to edit or delete, follow these steps:

1) From the main menu, choose Format > Sections... The Edit Sections window (Figure
13) opens.

2) The name of the current section appears in the Section area, in the field that’s above
the list box. If you want to edit or delete a different section, click the name of the
desired section in the list. The selected section becomes the current section, and its
name appears in the field above the list box.

Figure 13. Edit Sections window

Working with Sections 12



Maintaining sections

Editing section attributes

To rename the current section, simply type over its name in the Section area.

From the Edit Sections window, you can also edit the current section’s link, write-protect,
and hide attributes. To learn how to edit these attributes, see:

• “Linking sections” on page 2.

• “Write-protecting sections” on page 3.

• “Hiding sections” on page 4.

Deleting sections

To delete the current section, click the Remove button. (Note that Writer won’t prompt you
to confirm the delete! To undo a delete, click the Cancel button.)

Editing the format of a section

To edit the format of the current section, click the Options... button. The Options window
(Figure 14) opens.

Figure 14. Options window
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The Options window has four tabs: Columns, Indents, Background, and
Footnotes/Endnotes. To learn how to use these tabs, see:

• “Using the Columns tab” on page 5.

• “Using the Indents tab” on page 7.

• “Using the Background tab” on page 8.

• “Using the Footnotes/Endnotes tab” on page 10.

To reset a tab to its most recently saved settings, click the Reset button.

To save your Options settings and return to the Edit Sections window, click OK. 

Updating links
You can have Writer update linked sections automatically, and you can also update links
manually.

Updating links automatically

By default, whenever you open a document that contains links, Writer prompts you to update
the links. To have Writer update links without prompting you, or to turn off automatic
updating, follow these steps:

1) From the main menu, choose Tools > Options... The Options – OpenOffice.org
window (Figure 15) opens.

Figure 15. Options - OpenOffice.org window

Working with Sections 14



Maintaining sections

2) In the list on the left, click the plus sign next to Text Document. A list of text
document settings appears underneath Text Document.

3) Under Text Document, click General. The window displays general text document
settings (Figure 16).

Figure 16. General text document settings

4) In the Update area, under Update links when loading, select an option:

• Select Always if you want Writer to update links automatically, without prompting
you, whenever you open a document that contains links. 

• Select On request if you want Writer to prompt you before updating links.

• Select Never if you don’t want Writer to update links.

5) Click OK to save your settings. The Options window closes.

Updating links manually

To update a link manually, follow these steps:

1) Open the document that contains the link.

2) From the main menu, choose Edit > Links... The Edit Links window opens. (See
Figure 17.)

3) The list on the Edit Links window displays the names of all the files that are linked to
the current document. Click the file that corresponds to the link that you want to
update.

4) Click the Update button. The most recently saved contents of the linked file appear in
the current document.
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Maintaining sections

5) To close the Edit Links window, click Close. 

Figure 17. Edit Links window
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