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Overview

Overview

This document describes the many ways that Draw can help you create drawings more easily.

Copyright and trademark information
The contents of this Documentation are subject to the Public Documentation License,
Version 1.0 (the "License"); you may only use this Documentation if you comply with the
terms of this License. A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf

The Original Documentation is Additional Tools. The Initial Writer(s) of the Original
Documentation is/are Linda Worthington © 2004. All Rights Reserved. (Initial Writer
contact(s):lindaw@openoffice.org. The Initial Writer contact(s) is to report  errors in the
documentation. For questions regarding how to use the software, subscribe to the Users Mail
List and post your question there: http://support.openoffice.org/index.html.)

Portions created by: original French document written by Michel Pinquier, translated to
English by Alex Thurgood and previous content revised by Jim Taylor. All trademarks within
this guide belong to legitimate owners.

Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org.

Acknowledgments
Thanks to Daniel Carrera, Carol Leather and Jean Hollis Weber for reviewing this chapter.

Modifications and updates

Version Date Description of Change

1.0 21 November 2004 First published edition
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Drawing Aid Tools

Drawing Aid Tools

This section describes the drawing aid tools that Draw provides.

Choosing Scale and Managing Zoom Values
To help you work with greater precision in certain areas of your drawings, Draw has a variety
of tools that let you adjust the magnification of the drawing.

Zoom using the status bar

The current zoom value is displayed in the status bar:

Figure 1 - Zoom status in status bar

If you double-click on the zoom value, a window is displayed in which you can change the
zoom percentage value:

Figure 2 - Zoom Definition dialog

You can choose from one of the preset zoom values:

• Optimal sets the zoom to show the objects of your drawing at the maximum useful
scale

• Page Width sets the right and left edges of the page to the size of the working area
• Whole Page lets you see the whole page

You can also enter the zoom value directly into the Variable box.

Zoom Toolbar

OpenOffice.org provides a toolbar  that deals entirely with zoom functions (see Figure 3). It
is a floating toolbar that can be reached by clicking the Zoom button in the main toolbar.
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This button zooms in by a factor of 2 each time it is clicked. You can also use the +
key from the number keypad. 
This button zooms out by a factor of 2 each time you click on it. You can also use the
- key from the number keypad.
This button shows the image on the screen at true size, where 1 cm on the screen
corresponds to 1 cm on the drawing. In order for this tool to work, your monitor's
driver needs to be correctly installed.
This button takes you back to the preceding zoom value.

This button takes you to the next zoom level (providing the zoom function has been
used at least once before). Both buttons work in the same way as the right and left
arrow buttons in the toolbar of most internet browsers.
This button shows the whole page.

This button sets the zoom width of the page to that of the work area.

This button selects a zoom factor that displays the objects in the work zone in the
most optimal way.
This button lets you zoom in on selected objects.

This button lets you move the visible work area currently under zoom to another part
of the page, much like in PDF viewing software. The mouse cursor turns into a hand
and you just drag the hand to the area of the page you want to see.
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Managing Layers
Draw has a workspace that can optionally comprise a series of layers on which you can draw
the different parts of your drawing. The biggest advantage to layers is that they can be
displayed or hidden at will. This technique is often used in architecture, for example.. The
basic layer contains the base plan of the building, then various layers are used to represent
piping, electrical circuits, furniture, dimensions, etc.

Layer management is handled by a particular mode available in Draw. To activate it, use
View > Layer from the menu bar, or click on the appropriate icon  at the bottom left hand
corner of the workspace:

When you switch to layer mode, tabs listing all of the available layers are shown at the
bottom of the workspace. By default, the following three layers are always present: Layout,
Controls, and Dimensions.

To activate a layer, click on its tab. The default behavior for the drawing tools is to place the
drawing on the currently selected layer. In the example above, the drawings are placed on  the
default layer named Layout. (The default layer names for user-created layers are sequentially
numbered starting from “Layer4”.)

If you right-click on a layer tab, a menu will appear that lets you insert or delete a layer,
rename an existing layer or modify it. Choosing Modify displays the following dialog box:

The Modify Layer dialog lets you specify whether a layer will be visible, whether it will be
printed when the drawing is printed (which is useful when you want to annotate the drawing
and don't want the annotations to appear in the printed version), and whether it will be
protected. 

All of the drawings in any given protected layer are protected against change (movement,
resizing, etc.).
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Figure 4 - Layer mode management

Figure 5 - Layer properties
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Once you are in layer mode, you can insert, modify, delete, or rename layers by clicking Edit
> Layer on the top menu bar, as show in Figure 6.

Placing Objects
Draw contains a few functions to help you with placement of objects on a worksheet, or with
respect to each other. The techniques described here are known as capture, snapping, and
placement techniques. All of the functions are accessible through the Option Toolbar.
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Figure 6 Adding and managing layers

Figure 7 - Snap tools

Show snap grid

Show snap lines

Show guides

Use snap grid

Snap to grid

Snap to margin

Snap to frame

Snap to object point
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The snap tools are divided into 3 groups: the magnetic grid, snap lines, and snap points.
Using these tools allows you to drag an object and have it “snap” tightly to a specific spot.
The object will not just move when you click the snap to object button, for example. You
have to click the button and then move the object.

The Magnetic Grid

One way of snapping objects into position is through the magnetic grid. This tool comprises a
grid of points to which objects can be snapped. In order to use the grid, click on the  button
in the options toolbar to display the grid, and then click on the  button to activate it. The
work area will then be filled with a set of dots, as shown below.

When the grid is active, drawing shapes can be done easily by using the dots to guide you:

In the following example, the object handles are positioned exactly on the dots in the grid.

The spacing between the dots can be defined in the Grid Options dialog (). Grid options are
located under the Drawing area of the OOo options. (Tools > Options)

With this dialog box, you can set the following parameters:

• Vertical and horizontal spacing of the dots in the grid. The default values are given in
the unit of measurement actually being used, but you can also change that.

• The resolution that corresponds to the number of subdivisions.

• The pixel size of the snap area. When the mouse cursor is closer to a dot or snap line
than the number of pixels given here, the object will snap to it.
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Figure 8 - Displaying the Magnetic Grid

Figure 9 - Drawing an object using the grid
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Figure 10 - Grid Options Dialog

Capture Lines

Capture or snap lines are horizontal or vertical lines to which you can snap objects.

In order to see the snap lines, you have to select the  button in the options toolbar, and the
 button lets you activate them.

Dynamic insertion of a capture line

You can add a snap line by sliding the mouse cursor from the vertical ruler (for vertical snap
lines) or from the horizontal ruler (for horizontal snap lines) into the workspace.

In the example in Figure 11, a horizontal snap line was made by sliding the mouse cursor
(while holding the left mouse button down) from the upper ruler onto the workspace. You
can then align objects onto this line, as shown in Figure 12:

Additional Tools 6

Figure 11 - Inserting a capture line

Figure 12 - Snapping objects to a
snap line
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You can always relocate a snap line with the mouse. However, moving snap lines will not
move any objects that have been snapped to that line.

Manual Insertion of a snap point or snap line

You can manually insert a snap point or a snap line using the Insert > Insert snap
point/line.... The following dialog box is displayed:

With this dialog, you can define the X and Y coordinates of the snap point, the X coordinate
of a vertical snap line, or the Y coordinate of a horizontal snap line.

A snap point looks like this:

Snap points can also be moved to another position on the workspace with the mouse. You
can also edit a snap point or snap line by right-clicking on it and choosing Edit from the
context menu.

Snapping to object border

The  button lets you activate snapping to an object border, where a selected object will be
snapped to the border of another object that is nearest to the mouse pointer.
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Figure 13 - Snap object insertion dialog

Figure 14 - Snap point
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In the example above, the blue circle has been snapped to the border of the yellow ellipse (in
fact, to the left vertex of the border).

Snapping to page

If you click on the  button, you can snap your objects to the margins of your workspace.
The snap can be made to the margin or to the limits of the workspace, as shown below:

Displaying guides

The  button lets you display the vertical and horizontal guides during movement of objects.
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Figure 15 - Snapping to object border

Figure 16 - Snapping to margins

Figure 17 - Guides when moving objects
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Specific Functions

Draw contains several advanced functions that are useful in certain specific instances (web
images and data exchange).

Duplication
This function duplicates a given shape while at the same time enabling you to change the
options applied to the duplicated shapes.

To start duplication, click on an object (or on a group of selected objects), then choose  Edit
> Duplicate.

The following dialog box appears:

You can choose:

• The number of copies

• The displacement along the X and Y axes between two copies

• The angle of rotation between two copies

• The change in size between each copy

• The colors of the starting and ending copies.

The options above applied to a blue rectangle produce the following result:

Additional Tools 9

Figure 18 - Duplication Dialog
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Figure 19 - Example of
Duplication

The end result of a duplication is a new group.

Cross-Fading
This operation lets you transform a shape from one form to another, with OpenOffice.org
handling all of the intermediate transitions. The result of such an operation is a new group.

Here's an example of its use.

We'll start with the following two shapes and carry out the cross-fade in 4 steps to obtain the
following drawing:
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Figure 20 - Starting shapes for
crossfading
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Figure 21 - Result of a crossfade

To carry out a cross-fade, you first need to select both objects and then choose Edit > Cross-
fading. The following dialog will appear:

The number of increments corresponds to the number of intermediate steps that the program
will generate.

The starting object is in the back and the ending object is in the front. If both objects are at
the same relative level, Cross-fade works from top to bottom of the workspace. You can use
the Arrange tool to set the relative levels of the objects. If you select the Cross-fade
attributes checkbox, Draw will apply at each step a change in the object’s attributes in order
to carry out a smooth transition from the attributes in the first shape to those in the second
shape. In the above example, the color has changed from blue to yellow. If this checkbox isn't
selected, each object created in the intermediate steps will have the same attributes as the first
object.

If you don't select the checkbox marked Same orientation, the cross-fade won't be carried
out in a 2-dimensional array and you'll get the following result:

You can clearly see from this example that Draw seems to pivot the intermediate steps in a
3D array to transform the first shape to the second.
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Figure 22 - Cross-fade options
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Note: In order for the cross-fade to function, the objects need to have attributes that are
similar. It is, for example, impossible to carry out a cross-fade between a shape filled with a
simple color and another shape filled with a bitmap image.

Exchanging Objects with Other Programs
This section describes a few ways of exchanging data between the various modules in the
OpenOffice.org suite and Draw and other programs.

Reminder Concerning Image Formats

As mentioned in several places in this document, Draw is essentially a vector graphics tool,
and even if it has a few bitmap handling functions, it is advisable to save your vector work in
a vector graphics format, rather than in bitmap format.

The major advantage of vector files is apparent when they are displayed zoomed or when you
resize them. The following image shows a comparison of the degree of detail between a
vector image on the left and a bitmap image on the right when enlarged 700 times.
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Figure 23 - 3D crossfade
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Note that it is the same basic object in both cases. 

To convert an object, just click on the context menu of the object, and two options will be
displayed: Convert to meta file and Convert to bitmap1. The conversion of a vector object
into a bitmap should only be done when no other alternative is available (for example, for use
for the Web or in a program that only accepts this type of image)2.

The Web export function

Saving a Draw image in a foreign format is done via the option Export in the File menu. The
default option proposes saving in HTML format using a conversion wizard.

This function will create as many web pages as there are pages in your Draw document. You
can optionally choose to display the pages as frames with a navigator and can even set an
index page3. 

For example, you might start from the page shown in Figure 25 (note the various tabbed
pages).

1 Depending on the complexity of the object, the conversion to metafile function may lead to a bitmap.

2 The tool for defining image maps for the web doesn't accept OpenOffice.org native file formats, only bitmaps and
metafiles.

3 This wizard is exactly the same as that contained within OpenOffice.org Impress.
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Figure 24 - Vector / bitmap comparison
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The result will look as follows:

Figure 26 - Web page generated by OpenOffice.org export
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Figure 25 - Document to save as HTML
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The following is a description of the various pages in the wizard. You will note that you can
choose to create the web page at any moment by clicking on the Create button, so you're not
obliged to continue to the end of the wizard.

➊ The first page lets you choose the
design for all of the pages, either
from an existing design or even
create a new one.

➋ On this page you can choose how
you want to be able to navigate your
web document: either via simple
pages, frames (see Figure 26) or
scripted page (via ASP or Perl,
unfortunately no direct support for
PHP as yet).

You can also decide here to insert
an index page.

➌ On the third page, you decide how
the images will be saved (GIF or
JPEG) and their associated
parameters. 
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Figure 27 - HTML Export – Choosing your design

Figure 28 - HTML Export – Choice of Publishing Format

Figure 29 - HTML Export – Choosing Image Type
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➍ The fourth page lets you enter
details about the author.

➎ On this page, you choose the
navigation button style that is used
to move from page to another. If you
decide not to choose any,
OpenOffice.org will create a text
navigator.

➏ The last page lets you define the
color scheme for the created pages.
You can save your scheme so that
you will find it again on the first
page of your HTML export wizard.

On the export page, if you don't use the default option, OpenOffice.org will suggest several
vector or bitmap formats.

Additional Tools 16

Figure 30 - HTML Export – Author Details

Figure 31 - HTML Export – Choosing navigation buttons

Figure 32 - HTML Export – Defining the Color Scheme


