/[Apache-SVN]/httpd/test/trunk/perl-framework/Apache-Test/Makefile.PL
ViewVC logotype

Diff of /httpd/test/trunk/perl-framework/Apache-Test/Makefile.PL

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

--- httpd/test/trunk/perl-framework/Apache-Test/Makefile.PL	2004/12/15 16:30:01	111991
+++ httpd/test/trunk/perl-framework/Apache-Test/Makefile.PL	2004/12/15 16:31:24	111992
@@ -63,6 +63,7 @@ WriteMakefile(
     NAME      => 'Apache::Test',
     VERSION   => $VERSION,
     PREREQ_PM => \%prereq,
+    NO_META   => 1,
     dist      => {
         COMPRESS => 'gzip -9f', SUFFIX => 'gz',
     },
@@ -140,12 +141,12 @@ sub sanity_check {
     }
 }
 
-if ($ExtUtils::MakeMaker::VERSION < 6.06) {
+if (TOP_LEVEL && $ExtUtils::MakeMaker::VERSION < 6.06) {
     # now that we're using subversion, make sure that
     # .svn directories are skipped during the build process
     # for old versions of MakeMaker
 
-    sub MY::libscan {
+    *MY::libscan = sub {
         my $self = shift;
 
         my $path = shift;
@@ -153,7 +154,7 @@ if ($ExtUtils::MakeMaker::VERSION < 6.06
         return '' if $path =~ /\B\.svn\b/;
 
         return $path;
-    }
+    };
 }
 
 sub MY::postamble {

 

infrastructure at apache.org
ViewVC Help
Powered by ViewVC 1.1.26