/[Apache-SVN]/httpd/test/trunk/perl-framework/Apache-Test/Makefile.PL
ViewVC logotype

Diff of /httpd/test/trunk/perl-framework/Apache-Test/Makefile.PL

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

--- httpd/test/trunk/perl-framework/Apache-Test/Makefile.PL	2004/12/01 04:21:44	109276
+++ httpd/test/trunk/perl-framework/Apache-Test/Makefile.PL	2004/12/01 04:23:14	109277
@@ -12,6 +12,7 @@ use constant TOP_LEVEL => !exists $ENV{M
 
 use ExtUtils::MakeMaker;
 use Symbol;
+use File::Find qw(finddepth);
 
 use Apache::TestMM qw(test clean); #enable 'make test and make clean'
 use Apache::TestRun;
@@ -27,6 +28,11 @@ Apache::TestMM::filter_args();
 
 my @scripts = qw(t/TEST);
 
+finddepth(sub {
+    return unless /(.*?\.pl)\.PL$/;
+    push @scripts, "$File::Find::dir/$1";
+}, '.');
+
 for (@scripts) {
     Apache::TestMM::generate_script($_);
 }

 

infrastructure at apache.org
ViewVC Help
Powered by ViewVC 1.1.26