Contrôle de l’infrastructure de gestion Windows

  • Pour obtenir de l’aide sur l’utilisation du contrôle WMI, consultez Contrôle de l’infrastructure de gestion Windows - Comment....

  • Pour en comprendre davantage sur le contrôle WMI, consultez Concepts de contrôle de l’infrastructure de gestion Windows.


Contrôle de l’infrastructure de gestion Windows - Comment...

  • Sauvegarder ou restaurer l’espace de stockage de l’infrastructure de gestion Windows

  • Modifier les paramètres de scripts de l’infrastructure de gestion Windows

  • Autoriser les utilisateurs de l’infrastructure de gestion Windows

  • Modifier les autorisations ou supprimer les utilisateurs autorisés


Sauvegarder ou restaurer l’espace de stockage de l’infrastructure de gestion Windows

Pour sauvegarder ou restaurer l’espace de stockage WMI

  1. Ouvrez la console de Contrôle WMI : Cliquez sur Démarrer, sur Exécuter, tapez wmimgmt.msc, puis cliquez sur OK.

  2. Dans l’arborescence de la console, cliquez avec le bouton droit sur Contrôle WMI, puis cliquez sur Propriétés.

  3. Cliquez sur l’onglet Sauvegarder/Restaurer.

  4. Cliquez sur Sauvegarder maintenant ou Restaurer maintenant.

Considérations supplémentaires

  • Pour effectuer cette procédure, vous devez être membre du groupe Administrateurs sur l’ordinateur local, ou l’autorité appropriée doit vous avoir été déléguée. Si l’ordinateur est joint à un domaine, les membres du groupe Administrateurs du domaine peuvent être en mesure d’effectuer cette procédure. Par mesure sécurité, il est conseillé d’utiliser Exécuter en tant que pour effectuer cette procédure.

  • Vous devez être connecté en tant qu’administrateur de l’ordinateur local pour enregistrer le fichier sauvegardé dans le dossier %Windir%\System32\Wbem\Repository. Autrement, vous pouvez l’enregistrer dans le dossier Documents pour le profil du compte.

  • Quand vous cliquez sur Sauvegarder maintenant pour sauvegarder manuellement l’espace de stockage, vous pouvez sauvegarder sur un nom de fichier spécifié et restaurer plus tard à partir de ce fichier enregistré. Cette approche peut être utile si vous voulez enregistrer une configuration spécifique de classes. Vous pouvez également exécuter la commande Winmgmt depuis une invite de commandes et la restaurer à partir du fichier enregistré. Pour plus d’informations sur l’utilisation de la commande Winmgmt, cliquez sur Démarrer, sur Exécuter, et tapez winmgmt /?


Modifier les paramètres de scripts de l’infrastructure de gestion Windows

Pour modifier les paramètres de scripts WMI

  1. Ouvrez la console de Contrôle WMI : Cliquez sur Démarrer, sur Exécuter, tapez wmimgmt.msc, puis cliquez sur OK.

  2. Dans l’arborescence de la console, cliquez avec le bouton droit sur Contrôle WMI, puis cliquez sur Propriétés.

  3. Cliquez sur l’onglet Avancées.

  4. DansEspace de noms par défaut pour les scripts, cliquez sur Modifier.

  5. Dans la boîte de dialogue Explorateur pour l’espace de noms, sélectionnez un espace de noms par défaut différent comme cible pour vos scripts.

Considérations supplémentaires

  • Activez les espaces de noms ciblés par défaut à un script fréquemment utilisé dans vos scripts WMI. Si aucun espace de noms est identifié à l’intérieur d’un script, il sera identifié par défaut.

  • Si l’ordinateur que vous gérez exécute Microsoft Windows NT 4.0, vous pouvez définir si les scripts WMI doivent être exécutés sous Active Server Page (ASP). Si vous activez cette option, votre ASP utilise l’identité de niveau processus des services Internet pour se connecter aux services de gestion Windows, ce qui peut compromettre la sécurité.

  • Vous pouvez changer l’espace de noms des scripts sur un ordinateur distant ou local. Pour accéder à un ordinateur distant, cliquez avec le bouton droit sur Contrôle WMI, puis sur Se connecter à un autre ordinateur, sélectionnez Un autre ordinateur et tapez le nom de l’ordinateur auquel vous souhaitez vous connecter. Si vous utilisez le Contrôle WMI depuis la console de gestion de l’ordinateur, cliquez avec le bouton droit sur le nœud Gestion de l’ordinateur pour vous connecter à l’autre ordinateur.

  • Pour vous connecter à un autre ordinateur, vous devez ouvrir une session en tant qu’administrateur sur l’ordinateur distant. Pour plus d’informations, consultez Connexion à WMI sur un ordinateur distant.


Autoriser les utilisateurs de l’infrastructure de gestion Windows

Pour autoriser les utilisateurs WMI et définir les autorisations

  1. Ouvrez la console de Contrôle WMI : Cliquez sur Démarrer, sur Exécuter, tapez wmimgmt.msc, puis cliquez sur OK.

  2. Dans l’arborescence de la console, cliquez avec le bouton droit sur Contrôle WMI, puis cliquez sur Propriétés.

  3. Cliquez sur l’onglet Sécurité.

  4. Sélectionnez l’espace de noms auquel vous souhaitez donner l’accès à un utilisateur ou à un groupe, puis cliquez sur Sécurité.

  5. Dans la boîte de dialogue Sécurité, cliquez sur Ajouter.

  6. Dans la boîte de dialogue Sélectionner utilisateurs, Ordinateurs ou Groupes, entrez le nom de l’objet (utilisateur ou groupe) que vous voulez ajouter. Cliquez sur Vérifier les noms pour vérifier votre entrée et cliquez sur OK. Il se peut que vous deviez changer l’emplacement ou cliquez sur le bouton Avancé pour demander des objets. Consultez la boîte de dialogue Aide pour plus de détails.

  7. Dans la boîte de dialogue Sécurité, dans Autorisations, sélectionnez les autorisations à octroyer ou refusez le nouvel utilisateur ou groupe :

Niveau | Description
Exécuter des méthodes | Autorise un utilisateur à exécuter les méthodes de classe WMI.
Eciture intégrale | Autorise l’accès à la lecture et l’écriture intégrales, et à la suppression de tous les objets WMI, de toutes les classes et instances (dynamique et statique).
Ecriture partielle | Autorise l’accès à l’écriture des objets statiques WMI.
Ecriture fournisseur | Autorise l’accès à l’écriture des instances de classe dynamique WMI.
Activer compte | Autorise l’accès à la lecture des objets WMI.
Activer à distance | Autorise un accès à distance à l’espace de noms.
Sécurité de lecture | Autorise l’accès en lecture seule des informations de sécurité.
Modifier la sécurité | Autorise l’accès à la lecture et à l’écriture des informations de sécurité.

Considérations supplémentaires

  • Pour exécuter cette tâche sur l’ordinateur local, vous devez être connecté en tant que membre du groupe Administrateurs local.

  • Pour exécuter cette tâche sur un ordinateur distant, le compte avec lequel vous êtes connecté doit être membre du groupe Administrateurs de cet ordinateur. Pour accéder à un ordinateur distant, cliquez avec le bouton droit sur Contrôle WMI, puis sur Se connecter à un autre ordinateur, sélectionnez Un autre ordinateur et tapez le nom de l’ordinateur auquel vous souhaitez vous connecter. Si vous utilisez le contrôle WMI depuis la console de gestion de l’ordinateur, cliquez avec le bouton droit sur Gestion de l’ordinateur pour vous connecter à l’autre ordinateur.

  • Vous pouvez supprimer l’autorisation d’accès d’un utilisateur ou d’un groupe aux services WMI en sélectionnant cet utilisateur ou groupe et en cliquant sur Supprimer.

Références supplémentaires

  • Gestion de la sécurité de l’infrastructure de gestion Windows

  • Modifier les autorisations ou supprimer les utilisateurs autorisés


Modifier les autorisations ou supprimer les utilisateurs autorisés

Pour modifier les autorisations ou supprimer les utilisateurs autorisés

  1. Ouvrez la console de Contrôle WMI : Cliquez sur Démarrer, sur Exécuter, tapez wmimgmt.msc, puis cliquez sur OK.

  2. Dans l’arborescence de la console, cliquez avec le bouton droit sur Contrôle WMI, puis cliquez sur Propriétés.

  3. Cliquez sur l’onglet Sécurité.

  4. Sélectionnez l’espace de noms pour lequel vous souhaitez changer les autorisations d’un utilisateur ou d’un groupe ou supprimer un utilisateur ou un groupe, puis cliquez sur Sécurité.

  5. Dans la boîte de dialogue Sécurité, dans Nom, sélectionnez l’utilisateur ou le groupe que vous souhaitez supprimer ou dont vous voulez modifier les autorisations.

  6. Effectuez l’une des actions suivantes :

    • Pour supprimer l’utilisateur ou le groupe, cliquez sur Supprimer.

    • Pour changer les paramètres de sécurité, dans Autorisations, modifiez les autorisations accordées ou refusées à l’utilisateur ou au groupe en désactivant ou en activant les cases correspondantes.

Considérations supplémentaires

  • Pour effectuer cette tâche, vous devez être membre du groupe Administrateurs sur l’ordinateur local, ou l’autorité appropriée doit vous avoir été déléguée.

  • La sécurité WMI est vérifiée seulement quand un utilisateur se connecte sur les services de gestion Windows. Ainsi, toute modification apportée aux autorisations d’un utilisateur alors que celui-ci est connecté ne prend effet que lors de sa prochaine connexion sur WMI. Par exemple, si l’accès d’un utilisateur est révoqué, les modifications ne prennent effet que lorsque l’utilisateur se déconnecte des services de gestion Windows et essaie de se reconnecter.

  • Vous pouvez modifier les autorisations d’un utilisateur ou d’un groupe sur un ordinateur distant ou local. Pour accéder à un ordinateur distant, cliquez avec le bouton droit sur Contrôle WMI, puis sur Se connecter à un autre ordinateur, sélectionnez Un autre ordinateur et tapez le nom de l’ordinateur auquel vous souhaitez vous connecter. Si vous utilisez le Contrôle WMI depuis la console de gestion de l’ordinateur, cliquez avec le bouton droit sur le nœud Gestion de l’ordinateur pour vous connecter à l’autre ordinateur.

Références supplémentaires

  • Gestion de la sécurité de l’infrastructure de gestion Windows.

  • Autoriser les utilisateurs de l’infrastructure de gestion Windows.


Concepts de contrôle de l’infrastructure de gestion Windows

  • Vue d’ensemble du contrôle de l’infrastructure de gestion Windows

  • Vue d’ensemble de l’infrastructure de gestion Windows

  • Gestion de la sécurité de l’infrastructure de gestion Windows


Vue d’ensemble du contrôle de l’infrastructure de gestion Windows

Le contrôle WMI (Windows Management Instrumentation) est un outil qui vous permet de configurer les paramètres WMI sur un ordinateur distant ou un ordinateur local. Grâce à lui, vous gérez à distance les tâches suivantes :

Effectuer une sauvegarde de l’espace de stockage

Vous pouvez configurer le contrôle WMI pour qu’il effectue régulièrement une sauvegarde de votre espace de stockage ou vous pouvez exécuter cette sauvegarde manuellement à tout moment. L’espace de stockage correspond à la base de données d’objets à laquelle vous pouvez accéder à l’aide de WMI. Vous avez également la possibilité de restaurer une version précédente de l’espace de stockage.

Consultez Sauvegarder ou restaurer l’espace de stockage de l’infrastructure de gestion Windows

Modifier l’espace de noms par défaut pour les scripts

Vous pouvez modifier l’espace de noms par défaut ciblé dans les scripts WMI.

Consultez Modifier les paramètres de scripts de l’infrastructure de gestion Windows

Autoriser des utilisateurs ou des groupes et définir des niveaux d’autorisation

Vous pouvez autoriser à un utilisateur ou à un groupe l’accès à WMI. Pour chaque utilisateur ou groupe autorisé, vous pouvez définir leur niveau d’autorisation pour des espaces de noms spécifiques.

Consultez :

  • Autoriser les utilisateurs de l’infrastructure de gestion Windows

  • Modifier les autorisations ou supprimer les utilisateurs autorisés

Considérations supplémentaires

  • Pour plus d’informations sur WMI, consultez Vue d’ensemble de l’infrastructure de gestion Windows.

  • Pour des informations sur l’utilisation de l’interface de ligne de commande de WMI, affichez l’utilisation de la ligne de commande du Contrôle de l’infrastructure de gestion Windows (Wmic.exe) en lançant wmic.exe -? depuis une invite de commandes.


Vue d’ensemble de l’infrastructure de gestion Windows

L’Infrastructure de gestion Windows (WMI) est la principale source de données de gestion et de fonctionnalité sur les ordinateurs locaux et distants sous les systèmes d’exploitation Microsoft Windows. Vous pouvez obtenir des données de gestion WMI directement via les scripts et applications ou via les outils de gestion de l’entreprise tels que Microsoft SMS (Microsoft Systems Management Server) et MOM ( Microsoft Operations Manager). Vous pouvez utiliser des scripts écrits dans n’importe quel langage de script qui peut fonctionner avec l’environnement d’exécution de scripts WSH (Windows Script Host).

En commençant par Windows Vista, les applications ou les scripts qui utilisent le protocole de gestion WS peuvent obtenir des données WMI via Gestion à distance de Windows.

WMI est la mise en oeuvre Microsoft de WEBM, une initiative de gestion d’entreprise basée sur le Web visant à établir des normes d’accès et de partage des informations de gestion via le réseau d’une entreprise. WMI est compatible avec WBEM et fournit un soutien intégré pour le CIM (Common Information Model), le modèle de données qui décrit les objets existants dans l’environnement de gestion d’une entreprise.

WMI comprend un référentiel d’objets compatible avec CIM et le gestionnaire d’objets CIM. Le référentiel d’objets contient des définitions d’objets qui fournissent des données pour du matériel et des logiciels plus faciles à gérer. Les exemples de classes WMI sont les classes Win32, telles que Win32_Printer ou Win32_ComputerSystem et StdRegProv, qui fournissent des données de registre.

Le gestionnaire d’objets CIM gère la collecte et la manipulation des objets dans le référentiel et réunit des informations depuis les fournisseurs WMI. Les fournisseurs WMI agissent comme intermédiaires entre le WMI et les composants du système d’exploitation, les lecteurs, les applications et les autres systèmes. Plusieurs outils de gestion du système Windows sont activés par le WMI.

Références supplémentaires

  • Pour des informations sur l’utilisation du contrôle WMI pour configurer les paramètres WMI et la sécurité sur un ordinateur distant ou local, consultez Vue d’ensemble du contrôle de l’infrastructure de gestion Windows.

  • Pour des informations sur le développement des scripts et les applications utilisant des données et des fonctions WMI, consultez Infrastructure de gestion Windows.

  • Pour des informations sur l’utilisation de l’interface de ligne de commande de WMI, affichez l’utilisation de la ligne de commande du Contrôle de l’infrastructure de gestion Windows (Wmic.exe) en lançant wmic.exe -? depuis une invite de commandes.


Gestion de la sécurité de l’infrastructure de gestion Windows

L’infrastructure de gestion Windows (WMI, Windows Management Instrumentation) gère un type de sécurité restreinte qui valide chaque utilisateur avant qu’il ne soit autorisé à se connecter à WMI, sur un ordinateur local ou distant. Cette sécurité constitue la couche supérieure de la sécurité du système d’exploitation. WMI ne remplace ni ne contourne la sécurité fournie par le système d’exploitation.

Par défaut, seul le compte administrateur de l’ordinateur local possède un contrôle total des services WMI sur l’ordinateur géré. Les membres du groupe Administrateurs ont accès aux ordinateurs distants, mais beaucoup n’ont pas accès à l’intégralité des données. Les autres utilisateurs ne reçoivent les autorisations de lecture/écriture/exécution que sur leur ordinateur local.

Vous pouvez modifier les autorisations en ajoutant un utilisateur au groupe Administrateurs sur l’ordinateur géré ou en autorisant des utilisateurs ou des groupes dans WMI et en définissant leur niveau d’autorisation. L’accès dépend des espaces de noms WMI.

La sécurité est uniquement vérifiée quand un utilisateur se connecte à WMI et à un espace de noms. Ainsi, toute modification effectuée sur les autorisations d’un utilisateur alors que l’utilisateur est connecté ne prend pas effet avant la prochaine connexion de l’utilisateur au service WMI. Par exemple, si l’accès d’un utilisateur est révoqué, les modifications ne seront effectives que lorsque l’utilisateur quittera le WMI et tentera de se reconnecter au service.

Considérations supplémentaires

  • Autoriser les utilisateurs de l’infrastructure de gestion Windows

  • Modifier les autorisations ou supprimer les utilisateurs autorisés