Administration des services de composants

Vous pouvez utiliser le composant logiciel enfichable Services de composants dans Microsoft Management Console (MMC) pour configurer et administrer les composants COM (Component Object Model), les applications COM+ et le service Coordinateur de transactions distribuées (DTC).

Les services de composants sont conçus pour les administrateurs système et les développeurs d’applications. Par exemple, les administrateurs peuvent gérer les composants et les développeurs configurer le comportement standard des composants et des applications, notamment la participation aux transactions et le pool d’objet. Pour des informations conceptuelles et procédures non traitées dans cette section, voir la page, éventuellement en anglais, traitant de COM+ (Services de composants) (http://go.microsoft.com/fwlink/?LinkId=67385).

  • Vue d’ensemble de l’administration des services de composants

  • Aide-mémoire : Configurer le système pour les services de composants

  • Aide-mémoire : Gérer des applications COM+

  • Aide-mémoire : Gérer des applications DCOM

  • Aide-mémoire : Gérer des transactions distribuées

  • Configurer le système pour les services de composants

  • Gérer des applications COM+

  • Gérer des applications DCOM

  • Gérer des transactions distribuées

  • Interface utilisateur : Services de composants


Vue d’ensemble de l’administration des services de composants

Les services de composants ciblent l’administration des applications COM+. Les développeurs utilisent COM+ pour développer des applications distribuées. Les administrateurs utilisent les services de composants pour gérer ces applications. Un administrateur reçoit un fichier d’application COM+ d’un développeur puis utilise les services de composants pour déployer cette application sur un serveur. L’administrateur configure ensuite les autorisations pour l’application, ainsi que d’autres paramètres.

En tant qu’administrateur, vous pouvez déployer et administrer des applications COM+ de deux façons. Vous pouvez utiliser le composant logiciel enfichable Services de composants de MCC (Microsoft Management Console) ou écrire des scripts pour automatiser le déploiement et l’administration. Outre l’utilisation du composant logiciel enfichable Services de composants, vous pouvez automatiser n’importe quelle tâche en écrivant un code qui utilise les objets d’administration fournis via la bibliothèque de liaison dynamique (DLL) COMAdmin Library. Pour savoir comment utiliser ces objets, visitez la page, éventuellement en anglais, traitant de l’automatisation de l’administration COM+ au niveau des tâches COM+ générales (http://go.microsoft.com/fwlink/?LinkId=66607).

Pour ce qui est des ressources Services de composants complètes pour les développeurs, visitez la page, éventuellement en anglais, traitant de COM+ (Services de composants) (http://go.microsoft.com/fwlink/?LinkId=66575).

Cette rubrique fournit une vue d’ensemble des tâches Services de composants les plus fréquemment exécutées et des concepts connexes.

Types d’application Services de composants

La plupart des tâches administratives Services de composants impliquent le déploiement d’applications et de composants sur le réseau et la garantie de performances élevées et d’une sécurité accrue pour les applications et les composants déployés. Les tâches que vous exécutez dépendent du type de l’application avec laquelle vous travaillez et des services utilisés par l’application.

Remarques

Les rubriques figurant dans cette section ne couvrent qu’une partie des paramètres que vous pouvez configurer avec le composant logiciel enfichable Services de composants. Les paramètres qui ne sont pas traités dans une rubrique ne doivent être configurés que par une personne disposant de connaissances approfondies sur l’implémentation du composant ou de l’application. Généralement, ces paramètres – qui sont traités dans la page, éventuellement en anglais, traitant de COM+ (Services de composants) (http://go.microsoft.com/fwlink/?LinkId=66575) – sont configurés par le développeur avant la livraison de l’application pour installation et déploiement.

Les applications que vous gérez dans le composant logiciel enfichable Services de composants entrent dans l’une des deux catégories suivantes : applications COM et applications COM+. Ces termes sont utilisés dans les rubriques, les paramètres pouvant varier selon le type d’application.

Applications COM

Le concept des applications COM (Component Object Model) n’a rien de nouveau. « COM » n’est autre que le terme utilisé pour faire référence aux groupes de composants COM développés pour travailler ensemble. Microsoft® Office Excel® est un exemple d’application COM. Elle est constituée des DLL d’extension de l’application exécutable principale et de l’application de support pour le vérificateur d’orthographe, de la fonctionnalité Microsoft Visual Basic®, etc.

Applications COM+

Les applications COM+ sont des groupes de composants COM développés et configurés conjointement pour pouvoir exploiter les services COM+, tels que les transactions, la mise en file d’attente, la sécurité basée sur les rôles, etc. Ce qui différencie notamment une application COM+ est écrit dans le code du composant, d’autres facteurs de différenciation étant définis via le composant logiciel enfichable Services de composants.

Les applications COM+ peuvent être réparties en deux types, chacun ayant des besoins administratifs distincts. Les deux types d’applications sont les applications serveur COM+ et les applications de bibliothèque COM+. Les applications serveur COM+ s’exécutent dans le cadre d’espace de processus qui leur est propre. À titre d’exemple, une application serveur peut être constituée d’un groupe de DLL qui encapsulent le traitement des paies. Les applications de bibliothèque COM+ sont constituées de composants développés pour s’exécuter dans le cadre du processus d’une application d’hébergement. À titre d’exemple, dans une application de bibliothèque, vous pouvez regrouper des DLL qui fournissent des services à d’autres composants applicatifs et des DLL qui partagent les caractéristiques de sécurité de ces composants.

Vue d’ensemble des tâches administratives

Les tâches administratives que vous exécutez avec les services de composants entrent dans quatre catégories relativement larges :

  • Configuration de votre système pour les services de composants

  • Configuration initiale des services

  • Installation et configuration d’applications COM+

  • Contrôle et réglage des services de composants

Remarques

Cette rubrique traite des tâches requises ou courantes. Il existe cependant d’autres tâches que vous pouvez exécuter si nécessaire. Pour une vue d’ensemble complète des tâches, consultez la documentation correspondant aux zones de tâches que vous administrez.

Configuration de votre système pour les services de composants

Lorsque vous commencez avec COM+, vous devez exécuter quelques tâches de personnalisation avant de pouvoir utiliser les services avec votre réseau. À titre d’exemple, vous devez tout d’abord configurer la sécurité administrative en affectant un utilisateur ou un groupe au rôle Administrateur de l’application système au moyen des services de composants. Pour plus d’informations, voir la section Configurer le système pour les services de composants.

Configuration initiale des services

Une fois la configuration de base des services de composants conformément aux caractéristiques de votre réseau terminée, vous pourriez avoir besoin d’ajuster les paramètres spécifiques aux types d’applications et de services que vous voulez utiliser sur le réseau.

À titre d’exemple, vous pouvez notamment configurer les types de paramètres suivants :

  • Pour garantir la sécurité des composants qui ne sont pas configurés dans les applications COM+ – soit les applications COM ou les composants COM déployés indépendamment –, vous pourriez avoir besoin de configurer des paramètres de sécurité COM spécifiques pour ces ordinateurs. (D’un autre côté, les applications COM+ peuvent être conçues pour tirer profit de la sécurité basée sur les rôles.) Pour plus d’informations, voir la section Gérer des applications DCOM.

  • Si vos applications utilisent des transactions distribuées, indiquez si le service Microsoft DTC (Distributed Transaction Coordinator) démarre manuellement ou automatiquement sur chaque ordinateur qui l’exécute. Si des transactions sont utilisées avec le service de cluster de Windows, vous devez également configurer le réseau de façon appropriée. Pour plus d’informations, voir la section Gérer des transactions distribuées.

Installation et configuration d’applications COM+

Une application COM+ doit être configurée avec des paramètres spécifiques aux services qu’elle doit utiliser. Une fois les paramètres de l’application configurés, vous pouvez installer ses sections côté client et côté serveur sur les ordinateurs du réseau. Vous trouverez ci-après deux exemples de types de tâches que vous pourriez avoir besoin d’exécuter pour installer et configurer des applications COM+ :

  • Avant de pouvoir configurer les paramètres régissant le comportement de l’application COM+ sur le réseau, installez l’application sur un ordinateur intermédiaire pour la configurer. Pour plus d’informations, voir la section Présentation de l’installation d’une application COM+.

  • Pour vous assurer que l’application COM+ participe de façon appropriée au programme de sécurité de votre réseau (l’application et d’autres ressources sont accessibles conformément aux besoins de votre réseau), vous pourriez avoir besoin d’ajouter des utilisateurs aux rôles de l’application et de définir l’identité de sécurité de l’application. Pour plus d’informations, voir la section Définir la configuration de la sécurité COM spécifique à l’application.

  • Une fois l’application COM+ configurée conformément au niveau de sécurité et aux services qu’elle doit utiliser, vous devez déployer ses sections côté client et côté serveur sur les ordinateurs de production de votre réseau. Pour plus d’informations, voir la section Gérer des applications COM+.

Contrôle et réglage des services de composants

Une fois les composants qui utilisent les services de composants déployés, vous pouvez assurer le suivi de ces services afin de contrôler les opportunités d’amélioration des performances et de gérer les défaillances. Dans certains cas, les modifications que vous apportez à ces paramètres – plus particulièrement aux fins d’une surveillance plus poussée – peuvent réduire les performances.

Vous trouverez ci-après des exemples de types de tâches que vous pourriez avoir besoin d’exécuter pour contrôler et régler vos composants et applications :

  • Installation de mises à niveau lorsqu’elles sont disponibles

  • Pour renforcer votre contrôle sur la sécurité – par exemple, pour éviter tout déblocage accidentel ou malveillant d’objets –, vous pouvez utiliser le suivi de référence pour effectuer des contrôles de sécurité supplémentaires et assurer le suivi d’informations supplémentaires.

  • Si les applications participent à des transactions distribuées, vous pouvez contrôler les performances en consultant l’état des transactions, les messages et les statistiques. Vous pouvez également renforcer les performances du système en changeant la taille ou l’emplacement du fichier journal dans lequel sont stockées les statistiques sur les transactions.

Pour les tâches en rapport avec le contrôle et le réglage qui ne sont pas traitées dans cette section, consultez la page, éventuellement en anglais, traitant des tâches COM+ générales (http://go.microsoft.com/fwlink/?LinkId=66607).


Aide-mémoire : Configurer le système pour les services de composants

Tâche | Référence
Revoir les concepts de base en rapport avec la configuration du système pour les services de composants. | Configurer le système pour les services de composants Présentation de la Configuration du système
Définir la sécurité administrative en affectant un utilisateur au rôle Administrateur de l’application système. | Définir la sécurité administrative
Rendre les ordinateurs visibles aux services de composants pour gérer les applications COM+ et contrôler les transactions. | Rendre les ordinateurs visibles aux services de composants
Activer DCOM pour communiquer avec des composants COM (Component Object Model) sur d’autres ordinateurs. | Activer ou désactiver DCOM


Aide-mémoire : Gérer des applications COM+

Tâche | Référence
Créer une nouvelle application COM+. | Présentation de l’installation d’une application COM+ Créer une nouvelle application COM+
Installer des applications serveur COM+. | Présentation de l’installation d’une application COM+ Installer des applications serveur COM+
Installer des proxys d’applications COM+. | Installer des proxys d’applications COM+
Supprimer des applications COM+. | Supprimer des applications COM+


Aide-mémoire : Gérer des applications DCOM

Tâche | Référence
Configurer la sécurité COM (Component Object Model) à l’échelle de l’ordinateur. | Définir des autorisations d’accès à l’échelle de l’ordinateur Définir des autorisations d’exécution et d’activation à l’échelle de l’ordinateur
Configurer la sécurité COM spécifique à l’application. | Définir des autorisations d’accès spécifiques à l’application Définir des autorisations d’exécution et d’activation spécifiques à l’application


Aide-mémoire : Gérer des transactions distribuées

Tâche | Référence
Revoir les concepts liés à la gestion des transactions distribuées. | Gérer des transactions distribuées Configurer le coordinateur de transactions par défaut
Configurer le coordinateur de transactions par défaut pour utiliser le gestionnaire de transactions DTC (Distributed Transaction Coordinator) d’un système distant (et non l’ordinateur local). | Configurer le coordinateur de transactions par défaut
Contrôler le suivi en arrière-plan en sélectionnant des options de sortie et de connexion. | Configurer la trace DTC
Changer la taille ou l’emplacement du fichier journal DTC. | Configurer la journalisation DTC
Configurer la sécurité DTC pour n’autoriser que les transactions locales ou utiliser un coordinateur de transactions à distance. | Configurer la sécurité DTC
Coordonner les transactions à distance. | Configurer la sécurité DTC


Configurer le système pour les services de composants

Après avoir installé le système d’exploitation, vous devez configurer le système pour activer la gestion des services de composants sur votre réseau. Vous activez le contrôle par administrateur pour l’application système. Vous configurez également les services de composants pour que votre réseau soit reconnu en rendant les ordinateurs visibles aux services de composants et en activant les communications entre les composants au-delà des limites des ordinateurs en configurant DCOM. Ces exigences en termes de configuration sont vitales à la bonne administration des services de composants.

Remarques

Selon les besoins de votre système, il peut être nécessaire d’exécuter des tâches de configuration au-delà de celles décrites dans les rubriques de cette section. Bien que vous puissiez configurer les propriétés suivantes ultérieurement, il est important que vous en ayez connaissance dès maintenant :

  • Le composant logiciel enfichable Services de composants implique l’exécution du service DTC (Distributed Transaction Coordinator). Vous devez donc configurer le service DTC. Pour plus d’informations, voir la section Gérer des transactions distribuées.

  • Si l’un de vos objectifs est d’améliorer l’évolutivité du système, vous pouvez configurer les services de composants pour qu’ils ferment les processus applicatifs qui ne sont pas utilisés. Pour plus d’informations, visitez la page, éventuellement en anglais, traitant des tâches COM+ générales (http://go.microsoft.com/fwlink/?LinkId=66607).

  • Présentation de la Configuration du système

  • Définir la sécurité administrative

  • Rendre les ordinateurs visibles aux services de composants

  • Activer ou désactiver DCOM


Présentation de la Configuration du système

Cette rubrique contient une présentation générale des tâches de configuration initiale du système qui vous exécutez avec le composant logiciel enfichable Services de composants après avoir installé le système d’exploitation.

Remarques

Le composant logiciel enfichable Services de composants implique l’exécution du service Microsoft DTC (Distributed Transaction Coordinator). Si le DTC est arrêté et que vous essayez de modifier un paramètre quelconque en utilisant le composant logiciel enfichable Services de composants, le service DTC redémarre. Si des messages d’erreur s’affichent lorsque vous essayez d’utiliser le composant logiciel enfichable Services de composants, vérifiez que le service est démarré. Dans le cas contraire, redémarrez-le dans le composant logiciel enfichable MMC des services. Pour ouvrir le composant logiciel enfichable Services, cliquez sur Démarrer, sélectionnez Outils d’administration puis cliquez sur Services.

Contrôle des paramètres au niveau de l’application système

Le dossier Application système est situé dans le dossier Applications COM+ du composant logiciel enfichable Services de composants. L’application système gère la configuration et le déploiement des services de composants. Pour protéger l’accès à cette application de la plus haute importance, vous devez définir qui peut administrer l’environnement. Cette étape est nécessaire pour modifier la configuration des services de composants, notamment en installant une application ou en ajoutant un ordinateur.

L’application système utilise la sécurité basée sur les rôles (Administrateur, Lecteur, Application serveur, N’importe quelle application et Utilisateur approuvé QC). Les membres du rôle Administrateur bénéficient d’un accès en lecture et en écriture à l’application système. Ils peuvent ajouter, modifier ou supprimer n’importe lequel des paramètres dans le composant logiciel enfichable Services de composants. Seuls les membres du rôle Administrateur peuvent installer des applications COM+ sur le système. Par défaut, le groupe Administrateurs local est le seul membre de ce rôle. Seuls les utilisateurs qui font partie du groupe Administrateurs local peuvent être ajoutés au rôle Administrateur.

Remarques

Vous devez affecter au moins un utilisateur ou un groupe au rôle Administrateur. Dans le cas contraire, personne ne peut administrer les services de composants.

Les membres du rôle Lecteur bénéficient d’un accès en lecture seule à l’application système. Ils peuvent afficher les paramètres dans le composant logiciel enfichable Services de composants mais ils ne peuvent rien modifier, ajouter ou supprimer. Par défaut, le groupe Tout le monde est membre de ce rôle, ce qui signifie que toute personne ayant accès à l’ordinateur peut afficher les paramètres des services de composants.

Remarques

Pour des raisons de sécurité, vous pourriez ne pas souhaiter que le groupe Tout le monde puisse afficher les paramètres des services de composants. Le cas échéant, vous devez supprimer le groupe Tout le monde du rôle Lecteur et n’y ajouter que les utilisateurs auxquels vous voulez accorder l’accès en lecture aux paramètres des services de composants. Vous devez redémarrer l’ordinateur afin que ces modifications soient prises en compte.

Les membres du rôle Application serveur peuvent exécuter des applications serveur COM+ tandis que les membres du rôle N’importe quelle application peuvent exécuter des applications serveur COM+ et des applications de bibliothèque COM+. Par défaut, le groupe Tout le monde est membre de chaque rôle.

Les membres du groupe Utilisateur approuvé QC sont approuvés pour transmettre des messages pour les composants en file d’attente pour le compte d’autres utilisateurs. Par défaut, ce rôle ne possède aucun membre.

Remarques

Les membres du groupe Utilisateur approuvé QC peuvent spécifier une identité arbitraire, ce qui signifie qu’un membre malveillant peut exécuter un appel de composant en file d‘attente avec des privilèges élevés. Il est donc recommandé que le nombre de ces utilisateurs soit maintenu au minimum.

Pour définir la sécurité administrative sous Application système, consultez la section Définir la sécurité administrative.

Rendre les ordinateurs visibles aux services de composants

Vous pouvez gérer les applications COM+ et leurs transactions à distance. Cependant, vous devez au préalable rendre l’ordinateur visible aux services de composants. Ajoutez l’ordinateur que vous voulez utiliser pour administrer l’arborescence de la console du composant logiciel enfichable Services de composants. Pour savoir comment ajouter des ordinateurs au services de composants, consultez la section Rendre les ordinateurs visibles aux services de composants.

Configuration de DCOM

Le protocole DCOM gère toutes les communications réseau entre les composants COM (Component Object Model) qui s’exécutent sur différents ordinateurs. Vous devez activer DCOM pur chaque ordinateur dont les composants COM communiquent avec d’autres composants sur le réseau. Bien que la désactivation de DCOM n’ait aucun impact sur les communications entre les composants d’un même ordinateur, toutes les communications entre les composants de différents ordinateurs sont désactivées si DCOM est désactivé. Pour activer la communication entre les composants au-delà des limites des ordinateurs, consultez la section Activer ou désactiver DCOM.

Références supplémentaires

  • Configurer le système pour les services de composants


Définir la sécurité administrative

L’application système est située dans le dossier Applications COM+ du composant logiciel enfichable Services de composants. L’application système gère la configuration et le déploiement au sein des services de composants. Le niveau d’authentification par défaut utilisé par l’application système pour les appels est Confidentialité du paquet, soit le niveau de sécurité le plus élevé.

Remarques

Pour des raisons de sécurité, il est fortement recommandé de laisser le niveau d’authentification de l’application système sur sa valeur par défaut Confidentialité du paquet.

Pour que des modifications puissent être apportées au système – telles que l’installation d’une application COM+ ou l’ajout d’un ordinateur –, la sécurité doit être configurée pour définir qui peut gérer l’environnement. Vous pouvez appliquer la procédure pour activer la sécurité au niveau de l’application système en définissant qui appartient au rôle Administrateur. Seuls les membres du groupe Administrateurs sur votre ordinateur peuvent appartenir au rôle Administrateur de l’application système.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent. Pour plus d’informations, voir la section « Considérations supplémentaires » de cette rubrique.

Pour définir la sécurité administrative en affectant un utilisateur ou un groupe au rôle Administrateur de l’application système

  1. Ouvrez Services de composants.

  2. Dans l’arborescence de la console, double-cliquez sur Ordinateurs puis sur Poste de travail.

  3. Double-cliquez sur Applications COM+, Application système, Rôles puis Administrateur.

  4. Sous Administrateur, cliquez avec le bouton droit de votre souris sur le dossier Utilisateurs, sélectionnez Nouveau puis cliquez sur Utilisateur.

  5. Dans la boîte de dialogue Sélectionner les utilisateurs ou les groupes, sous Entrez les noms des objets à sélectionner, tapez le nom complet de l’utilisateur ou du groupe à ajouter. Si vous ne connaissez pas le nom de l’utilisateur ou du groupe à ajouter, procédez comme suit :

    1. Cliquez sur Emplacements, sélectionnez le domaine approprié puis cliquez sur OK.

    2. Dans la boîte de dialogue Sélectionner les utilisateurs ou les groupes, cliquez sur Avancé.

    3. Pour afficher une liste des utilisateurs et des groupes dans le domaine sélectionné, cliquez sur Rechercher maintenant dans la boîte de dialogue Sélectionner les utilisateurs ou les groupes.

    4. Sélectionnez un utilisateur ou un groupe puis cliquez sur OK.

  6. Pour ajouter des comptes d’utilisateur ou des groupes supplémentaires, répétez les étapes a à d.

  7. Redémarrez l’ordinateur.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg puis appuyez sur Entrée.

  • Pour activer la sécurité administrative au niveau de l’application système, vous devez affecter au moins un utilisateur ou un groupe au rôle Administrateur. Dans le cas contraire, personne ne peut administrer les services de composants.

  • Les utilisateurs appartenant au rôle Administrateur pour l’application système peuvent être membres du groupe Administrateurs local.

Références supplémentaires

  • Configurer le système pour les services de composants


Rendre les ordinateurs visibles aux services de composants

Si vous disposez de privilèges suffisants sur un ordinateur distant, vous pouvez gérer ses applications COM+ et contrôler ses transactions au moyen du composant logiciel enfichable Services de composants de votre propre ordinateur. Cependant, vous devez au préalable rendre l’ordinateur distant visible aux services de composants. Appliquez la procédure suivante pour ajouter un ordinateur dont vous voulez administrer l’arborescence de la console du composant logiciel enfichable Services de composants.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent. Pour plus d’informations, voir la section « Considérations supplémentaires » de cette rubrique.

Pour ajouter ou supprimer un ordinateur distant dans le composant logiciel enfichable Services de composants

  1. Ouvrez Services de composants.

  2. Dans l’arborescence de la console, cliquez avec le bouton droit de votre souris sur Ordinateurs, sélectionnez Nouveau puis cliquez sur Ordinateur.

  3. Dans la boîte de dialogue Ajouter un ordinateur, tapez le nom de l’ordinateur que vous voulez ajouter. Si vous ne le connaissez pas, procédez comme suit :

    1. Cliquez sur Parcourir puis Avancé dans la boîte de dialogue Sélectionner un ordinateur.

    2. Pour affiner la recherche, renseignez autant de champs que possible sous Requêtes communes. Pour afficher une liste des ordinateurs répondant aux critères que vous avez spécifiés, cliquez sur Rechercher maintenant.

    3. Sélectionnez un ordinateur puis cliquez sur OK.

  4. Cliquez deux fois sur OK.

    L’ordinateur apparaît dans le dossier Ordinateurs. En utilisant le composant logiciel enfichable Services de composants, vous pouvez désormais gérer des objets sur l’ordinateur distant de la même façon que lorsque vous gérez des objets sur l’ordinateur local.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone Recherche, tapez dcomcnfg puis appuyez sur Entrée.

  • Pour voir les processus qui s’exécutent sur un ordinateur distant, ajouter le port TCP 135 et Dllhost.exe à la liste des exceptions du pare-feu Windows sur l’ordinateur distant administré. Ajoutez le port TCP 135 et MMC (Microsoft Management Console) à la liste des exceptions du pare-feu Windows sur l’ordinateur local.

Vous pouvez également appliquer la procédure suivante pour supprimer un ordinateur distant du composant logiciel enfichable Services de composants.

Pour supprimer un ordinateur distant du composant logiciel enfichable Services de composants

  1. Ouvrez Services de composants.

  2. Dans l’arborescence de la console, cliquez sur Ordinateurs.

  3. Dans le volet d’informations, cliquez avec le bouton droit de votre souris sur l’ordinateur que vous voulez supprimer puis cliquez sur Supprimer.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg puis appuyez sur Entrée.

Références supplémentaires

  • Configurer le système pour les services de composants


Activer ou désactiver DCOM

Si l’ordinateur utilisant Services de composants fait partie d’un réseau, le composant logiciel enfichable Services de composants nécessite le protocole DCOM pour communiquer avec les composants COM (Component Object Model) d’autres ordinateurs. Dans un système Windows, par défaut, les ordinateurs en réseau sont initialement configurés pour activer DCOM. Vous pouvez désactiver DCOM, ce qui désactive les communications avec les composants d’autres ordinateurs.

Vous pouvez appliquer la procédure suivante pour activer ou désactiver DCOM.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent.

Pour activer ou désactiver DCOM

  1. Ouvrez Services de composants.

  2. Dans l’arborescence de la console, cliquez sur le dossier Ordinateurs, cliquez avec le bouton droit de votre souris sur l’ordinateur pour lequel vous voulez activer ou désactiver DCOM puis cliquez sur Propriétés.

  3. Cliquez sur l’onglet Propriétés par défaut.

  4. Pour activer DCOM, cochez la case Activer Distributed COM (DCOM) sur cet ordinateur. Pour désactiver DCOM, désactivez cette case.

  5. Cliquez sur OK.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg puis appuyez sur Entrée.

  • Lorsque vous activez le service DCOM, vous devez également configurer le pare-feu sur l’ordinateur exécutant le composant, ainsi que sur l’ordinateur exécutant Services de composants. Pour plus de détails sur la configuration du pare-feu pour DCOM, consultez la page, éventuellement en anglais, traitant de DCOM avec les pare-feu (http://go.microsoft.com/fwlink/?LinkId=38001).

  • Si vous désactivez DCOM sur un ordinateur à distance, vous ne pouvez pas accéder à distance à cet ordinateur pour réactiver DCOM. Pour réactiver DCOM, vous devez avoir accès physiquement à cet ordinateur.

Références supplémentaires

  • Configurer le système pour les services de composants


Gérer des applications COM+

COM+ étend le modèle de programmation de composants. Vous pouvez utiliser COM+ pour ajouter des fonctionnalités utiles à un composant configuré. Les fonctionnalités ajoutées incluent la la sécurité basée sur les rôles, la mise en file d’attente, le recyclage des processus et l’accessibilité via le protocole SOAP (Simple Object Access Protocol).

Bon nombre des tâches exécutées par les administrateurs système sont liées à :

  • l’installations d’applications serveur sur des ordinateurs intermédiaires et des ordinateurs de production ;

  • l’installation de proxys d’applications sur des ordinateurs clients ;

  • la suppression ou la mise à jour d’applications.

Les administrateurs peuvent exécuter ces tâches en utilisant le composant logiciel enfichable Services de composants. Ils peuvent également automatiser ces tâches via Windows Script Host (WSH). L’installation d’une application COM+ implique généralement l’utilisation de composants et d’applications COM+ préconstruites sur un ordinateur intermédiaire utilisé pour développer et tester l’application. Pour plus d’informations sur les ordinateurs intermédiaires, voir la section Présentation de l’installation d’une application COM+.

Avant d’entamer le processus d’installation, affectez des utilisateurs ou des groupes au rôle Administrateur. Pour plus d’informations, voir la section Définir la sécurité administrative.

Pour les tâches inhérentes à la gestion d’applications COM+ qui ne sont pas traitées dans cette section, consultez la page, éventuellement en anglais, traitant de COM+ (Services de composants) (http://go.microsoft.com/fwlink/?LinkId=66575)

Les rubriques suivantes décrivent les concepts et les procédures propres aux tâches d’installation d’applications COM+ que vous pourriez avoir besoin d’exécuter.

  • Présentation de l’installation d’une application COM+

  • Créer une nouvelle application COM+

  • Installer des applications serveur COM+

  • Installer des proxys d’applications COM+

  • Supprimer des applications COM+


Présentation de l’installation d’une application COM+

Présentation de l’installation d’une application COM+

Vous pouvez développer des applications COM+ au sein de votre propre organisation, le développeur maîtrisant parfaitement l’environnement cible : comptes d’utilisateur, groupes d’utilisateurs, noms de serveur, etc. Le développeur configure et exporte l’application. L’administrateur installe tout simplement l’application sur le système cible.

Vous pouvez également acheter des applications COM+ auprès d’un éditeur de logiciels non Microsoft. Si l’éditeur de logiciels ne fournit pas un programme d’installation standard qui vous guide tout au long des étapes requises de l’installation, vous devez installer et configurer l’application COM+ vous-même.

La configuration d’une application COM+ est généralement effectuée sur un ordinateur intermédiaire plutôt que sur des ordinateurs de production. Si vous utilisez un ordinateur intermédiaire, vous devez exporter l’application COM+ configurée et un proxy d’application COM+ de l’ordinateur intermédiaire et les installer sur les ordinateurs de production.

L’installation manuelle d’une application COM+ est constituée des principales étapes suivantes. Selon la façon dont l’éditeur ou le développeur fournit l’application, toutes les étapes peuvent ne pas être obligatoires. Pour plus d’informations, reportez-vous aux informations susceptibles d’être fournies avec l’application.

  1. Sur l’ordinateur intermédiaire, configurez l’application COM+ pour un environnement cible spécifique.

  2. Exportez les fichiers d’installation côté client et côté serveur spécifiques à l’environnement de l’ordinateur intermédiaire.

  3. Installez l’application COM+ ou le proxy d’application COM+ sur les ordinateurs de production.

Pour les procédures décrivant ces étapes, consultez la section Gérer des applications COM+.

Ordinateurs intermédiaires et de production

Il est utile d’installer et de tester les applications dans un environnement intermédiaire que vous pouvez utiliser pour simuler des scénarios susceptibles de se produire une fois les applications déployées sur les ordinateurs de production utilisés par d’autres personnes sur le réseau.

Vous pouvez également utiliser des environnements intermédiaires pour gérer les versions et mettre à jour les composants. Plutôt que de changer les configurations ou de mettre à jour les composants individuellement pour une application installée sur des ordinateurs de production, vous pouvez modifier l’application, la tester dans un environnement intermédiaire puis l’exporter sous la forme d’une unité devant être installée sur les ordinateurs de production.

Dans certains cas, la configuration est identique entre l’environnement intermédiaire et l’environnement de production et la seule différence réside dans le fait que l’environnement intermédiaire n’est pas publiquement accessible. Le cas échéant, il suffit de répliquer l’application configurée et validée de l’environnement intermédiaire dans l’environnement de production.

Mise à jour des versions des applications COM+

Lorsque les applications COM+ deviennent obsolètes ou qu’elles ne sont plus utilisées, vous devez les mettre à jour ou les supprimer. Si vous voulez mettre à niveau une application COM+, vous devez tout d’abord supprimer la version préalablement installée puis installer l’application mise à jour.

Pour savoir comment supprimer puis installer des applications, consultez les sections Supprimer des applications COM+ et Installer des applications serveur COM+.

Installation côté serveur des applications COM+

Toutes les informations nécessaires en rapport avec une application serveur COM+ sont fournies dans un fichier d’application serveur (.msi). Vous pouvez utiliser le composant logiciel enfichable Services de composants ou Windows Installer pour installer l’application COM+ à partir du fichier .msi.

Pour prévenir les modifications non autorisées de vos applications exportées, ne stockez les fichiers d’application serveur que dans des répertoires assortis d’autorisations d’écriture limitées. Pour plus de sécurité, signez vos fichiers d’application serveur en utilisant Authenticode™. Pour plus d’informations sur l’utilisation d’Authenticode, visitez la page, éventuellement en anglais, traitant d’Authenticode (http://go.microsoft.com/fwlink/?LinkId=66679).

Si un composant d’une application COM+ nécessite l’installation ou la configuration d’autres ressources (connexions à des bases de données, fichiers de données ou texte, configuration de la racine virtuelle des services Internet (IIS), etc.), ces ressources doivent être installées au moyen d’outils et d’utilitaires autres que les services de composants.

Pour savoir comment installer une application COM+, consultez la section Installer des applications serveur COM+.

Installation côté client des applications COM+

Une fois l’application serveur COM+ installée sur un ordinateur, il peut être nécessaire d’accéder à l’application à distance en utilisant DCOM ou le service Message Queuing.

Si vous voulez qu’une application soit accessible à distance, vous pouvez utiliser le composant logiciel enfichable Services de composants pour exporter un proxy d’application COM+. Le fichier de proxy d’application (.msi) contient les informations nécessaires pour accéder à distance aux classes d’une application serveur COM+ à partir d’un ordinateur client via DCOM. En utilisant le fichier de proxy d’application avec le composant logiciel enfichable Services de composants, vous pouvez installer le proxy d’application COM+ sur les ordinateurs clients de votre site.

Il est possible de créer un proxy d’application qui accède à un serveur autre que l’ordinateur duquel il a été exporté. C’est extrêmement utile lorsque le proxy d’application pour un ordinateur de production doit être exporté à partir d’ordinateur intermédiaire. Pour changer le nom du serveur, cliquez sur l’onglet Options de la feuille de propriétés pour l’ordinateur dans le composant logiciel enfichable Services de composants puis entrez le nom du serveur distant (RNS) utilisé par le proxy d’application.

Pour savoir comment installer des proxys d’applications COM+, consultez la section Installer des proxys d’applications COM+.


Créer une nouvelle application COM+

Lorsque vous développez des applications COM+, les principales tâches que vous devez exécuter incluent la conception des composants COM (Component Object Model) en vue d’encapsuler la logique de l’application et l’intégration de ces composants au sein d’une application COM+. Vous pouvez intégrer les composants au sein d’une application COM+ existante ou créer une nouvelle application (vide) pour les composants. Vous pouvez utiliser le composant logiciel enfichable Services de composants pour créer de nouvelles applications COM+ vides.

Important

Vous ne pouvez pas installer une application serveur COM+ sur les ordinateurs exécutant des systèmes d’exploitation antérieurs à Microsoft Windows® 2000. Une application serveur COM+ nécessite une plateforme prenant en charge Services de composants.

La configuration minimale requise pour une application est une configuration au sein de laquelle la sécurité n’est pas requise. Si la sécurité est requise dans le cadre de l’application, utilisez le composant logiciel enfichable Services de composants pour définir la sécurité au niveau des processus ou ajouter des utilisateurs aux rôles prédéfinis une fois l’application créée.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent. Pour plus d’informations, voir la section « Considérations supplémentaires » de cette rubrique.

Pour créer une nouvelle application COM+

  1. Ouvrez Services de composants.

  2. Dans l’arborescence de la console, localisez le dossier Applications COM+ associé avec l’ordinateur sur lequel vous voulez créer l’application.

  3. Cliquez avec le bouton droit de votre souris sur le dossier Applications COM+, sélectionnez Nouveau puis cliquez sur Application.

  4. Dans l’Assistant Installation d’applications COM+, cliquez sur Suivant.

  5. Dans la page Installer ou créer une application, cliquez sur Créer une application vide.

  6. Dans la page Créer une application vide, tapez le nom de la nouvelle application. Sous Type d’activation, cliquez sur Application bibliothèque ou Application serveur puis sur Suivant.

  7. Dans la page Définir l’identité de l’application, sous Compte, cliquez sur un compte sur lequel l’identité de l’application sera définie puis sur Suivant.

    Remarques

    La sélection par défaut est Utilisateur interactif. L’utilisateur interactif est celui qui est connecté au compte Windows pour l’ordinateur exécutant l’application. Pour sélectionner un autre utilisateur, cliquez sur Cet utilisateur puis entrez les informations inhérentes à un utilisateur ou un groupe spécifique.

  8. Dans la page Ajouter des rôles d’application, cliquez sur Ajouter un rôle pour spécifier tout rôle que vous voulez créer pour l’application. Par défaut, un seul et unique rôle nommé CreatorOwner est créé.

  9. Cliquez sur Suivant.

  10. Pour ajouter les utilisateurs de votre choix aux rôles que vous avez créés, dans la page Ajouter des utilisateurs aux rôles, double-cliquez sur le nom d’un rôle et cliquez sur le dossier Utilisateurs puis sur Ajouter. Par défaut, votre compte d’utilisateur est ajouté au rôle CreatorOwner.

  11. Cliquez sur Suivant puis sur Terminer.

    La nouvelle application apparaît dans l’arborescence de la console.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg puis appuyez sur Entrée.

  • Pour exécuter cette procédure, vous devez être membre du rôle Administrateur sur l’application système de l’ordinateur cible. Dans la configuration par défaut, seuls les administrateurs de l’ordinateur local sont affectés à ce rôle. Pour plus d’informations, voir la section Définir la sécurité administrative.

  • Si vous voulez que des utilisateurs réseau non authentifiés exécutent une application COM+, les rôles d’application doivent inclure l’utilisateur Anonyme. Dans Microsoft Windows Vista®, par défaut, l’utilisateur Anonyme n’est pas inclu dans le groupe Tout le monde. Vous pouvez ajouter ce type d’utilisateur dans l’Assistant Installation d’applications COM+ lorsque vous installez ou que vous créez une application. Dans la page Ajouter des rôles d’application de l’assistant, cliquez sur Ajouter un rôle, tapez OUVERTURE DE SESSION ANONYME et cliquez sur OK.

Références supplémentaires

  • Gérer des applications COM+


Installer des applications serveur COM+

Vous pouvez utiliser le composant logiciel enfichable Services de composants pour installer des applications serveur COM+.

Important

Vous ne pouvez pas installer une application serveur COM+ sur les ordinateurs exécutant des systèmes d’exploitation antérieurs à Windows 2000. Une application serveur nécessite une plateforme prenant en charge Services de composants.

La configuration minimale requise pour une application est une configuration au sein de laquelle la sécurité n’est pas requise. Si la sécurité est requise dans le cadre de l’application, utilisez le composant logiciel enfichable Services de composants pour définir la sécurité au niveau des processus ou ajouter des utilisateurs aux rôles prédéfinis une fois l’application installée. Pour plus d’informations sur la configuration de la sécurité pour votre application, voir la page, éventuellement en anglais, traitant de la sécurité COM+ (http://go.microsoft.com/fwlink/?LinkId=66688).

Important

Si vous voulez que des utilisateurs réseau non authentifiés puissent exécuter une application COM+, les rôles d’application doivent inclure l’utilisateur Anonyme. Dans Windows Vista, par défaut, l’utilisateur Anonyme n’est pas inclu dans le groupe Tout le monde. Vous pouvez ajouter le rôle OUVERTURE DE SESSION ANONYME dans l’Assistant Installation d’applications COM+ lorsque vous installez ou que vous créez une application.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent. Pour plus d’informations, voir la section « Considérations supplémentaires » de cette rubrique.

Installation d’applications serveur COM+

  • À l’aide du composant logiciel enfichable Services de composants

  • À l’aide de l’Explorateur Windows

  • À l’aide d’une ligne de commande
Pour installer une application serveur COM+ à l’aide du composant logiciel enfichable Services de composants

  1. Ouvrez Services de composants.

  2. Dans l’arborescence de la console, localisez le dossier Applications COM+ associé avec l’ordinateur sur lequel vous voulez installer l’application.

  3. Cliquez avec le bouton droit de votre souris sur le dossier Applications COM+, sélectionnez Nouveau puis cliquez sur Application.

  4. Dans l’Assistant Installation d’applications COM+, cliquez sur Suivant.

  5. Dans la page Installer ou créer une application, cliquez sur Installer des applications préconstruites.

  6. Dans la boîte de dialogue Installer à partir du fichier d’application, recherchez et sélectionnez le fichier .msi pour l’application que vous installez puis cliquez sur Ouvrir.

  7. Dans la boîte de dialogue Sélectionner les fichiers d’application, cliquez sur Ajouter pour rechercher toute application supplémentaire que vous voulez installer puis cliques sur Suivant.

  8. Dans la page Définir l’identité de l’application, cliquez sur l’identité de l’application puis sur Suivant.

    Remarques

    La sélection par défaut est Utilisateur interactif. L’utilisateur interactif est celui qui est connecté au compte Windows pour l’ordinateur exécutant l’application. Pour sélectionner un autre utilisateur, cliquez sur Cet utilisateur puis entrez les détails inhérents à un utilisateur ou un groupe spécifique.

  9. Dans la page Options d’installation d’applications, spécifiez le répertoire dans lequel installer l’application COM+ puis cliquez sur Suivant.

    Les fichiers de composants de l’application sont copiés du fichier .msi dans le répertoire d’installation. Le répertoire d’installation par défaut est :

    %Program Files%\COMPlus Applications\appid

    Vous pouvez accepter le répertoire par défaut ou cliquez sur Répertoire spécifique et recherchez un autre emplacement.

    Remarques

    Pour exécuter cette procédure, l’identité de l’application spécifiée au cours de l’étape précédente doit au moins disposer d’un accès en lecture au répertoire d’installation et la personne chargée de l’installation doit disposer d’un accès en écriture au répertoire d’installation.

  10. Cliquez sur Terminer. La nouvelle application apparaît dans l’arborescence de la console Services de composants. Si vous installez plusieurs applications, les options que vous sélectionnez au cours de l’étape 9 sont appliquées à toutes les applications.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg puis appuyez sur Entrée.

  • Pour exécuter cette procédure, vous devez être membre du rôle Administrateur sur l’application système de l’ordinateur cible. Dans la configuration par défaut, seuls les administrateurs de l’ordinateur local sont affectés à ce rôle. Pour plus d’informations, voir la section Définir la sécurité administrative.

Vous pouvez également installer une application COM+ en faisant glisser un fichier d’application de l’Explorateur Windows au volet d’informations du composant logiciel enfichable Services de composants lorsque le dossier Applications COM+ d’un ordinateur est ouvert.

Pour installer une application serveur COM+ à l’aide de l’Explorateur Windows

  1. Sur l’ordinateur sur lequel vous voulez installer l’application COM+, utilisez l’Explorateur Windows pour localiser le fichier de l’application serveur (.msi). Le fichier peut être hébergé localement ou sur une ressource réseau partagée.

  2. Double-cliquez sur le fichier de l’application serveur. Vous pouvez également cliquer avec le bouton droit de votre souris sur le nom du fichier puis cliquer sur Installer. Le programme d’installation de Microsoft Windows installe automatiquement l’application serveur sur l’ordinateur cible.

Considérations supplémentaires

  • Pour exécuter cette procédure, vous devez être membre du rôle Administrateur sur l’application système de l’ordinateur cible. Dans la configuration par défaut, seuls les administrateurs de l’ordinateur local détiennent ce rôle. Pour plus d’informations, voir Définir la sécurité administrative.

Pour installer une application serveur COM+ à l’aide d’une ligne de commande

  • À l’invite de commandes, tapez ce qui suit puis appuyez sur Entrée.

    msiexec -i [<property overrides>] <application name>.msi

    Valeur Description

    remplacement de propriétés

    Outre le remplacement de propriétés standard du programme d’installation de Windows, vous pouvez spécifier l’option suivante pour changer le répertoire d’installation de l’application COM+ du répertoire par défaut au répertoire spécifié :

    TARGETDIR = <target installation directory>

    nom de l’application

    Le nom de l’application qui doit être installée.

Considérations supplémentaires

  • Pour exécuter cette procédure, vous devez être membre du rôle Administrateur sur l’application système de l’ordinateur cible. Dans la configuration par défaut, seuls les administrateurs de l’ordinateur local détiennent ce rôle. Pour plus d’informations, voir Définir la sécurité administrative.

Références supplémentaires

  • Gérer des applications COM+

  • Notation de la syntaxe de la ligne de commande


Installer des proxys d’applications COM+

Une fois le proxy d’application créé sous la forme d’un fichier Windows Installer (.msi), vous pouvez l’installer sur un ordinateur client. L’installation du proxy d’application fournit les informations d’enregistrement nécessaires aux applications clients pour accéder à l’application COM+ à distance, à partir de l’ordinateur client.

Important

Vous pouvez installer un proxy d’application COM+ sur un ordinateur exécutant Windows Installer. Windows Installer est automatiquement installés sur tous les ordinateurs exécutant Windows 2000, Microsoft Windows Server™ 2003 ou Windows Server 2008, et il est également disponible pour les ordinateurs exécutant des versions antérieures de Windows. Cependant, si un proxy d’application nécessite le service Composants en file d’attente COM+, le proxy d’application ne peut être installé que sur un ordinateur exécutant Windows 2000, Windows Server 2003 ou Windows Server 2008. Le service Composants en file d’attente n’est disponible que sur les plateformes prenant en charge les services de composants.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent. Pour plus d’informations, voir la section « Considérations supplémentaires » de cette rubrique.

Installation de proxys d’applications COM+

  • À l’aide du composant logiciel enfichable Services de composants

  • À l’aide de l’Explorateur Windows

  • À l’aide d’une ligne de commande
Pour installer un proxy d’application COM+ à l’aide du composant logiciel enfichable Services de composants

  1. Ouvrez Services de composants.

  2. Dans l’arborescence de la console, localisez le dossier Applications COM+ associé avec l’ordinateur sur lequel vous voulez installer l’application.

  3. Cliquez avec le bouton droit de votre souris sur le dossier Applications COM+, sélectionnez Nouveau puis cliquez sur Application.

  4. Dans l’Assistant Installation d’applications COM+, cliquez sur Suivant.

  5. Dans la page Installer ou créer une application, cliquez sur Installer des applications préconstruites.

  6. Dans la boîte de dialogue Installer à partir du fichier d’application, recherchez et sélectionnez le fichier .msi pour le proxy d’application que vous installez puis cliquez sur Ouvrir.

  7. Dans la boîte de dialogue Sélectionner les fichiers d’application, cliquez sur Ajouter pour rechercher tout proxy d’application supplémentaire que vous voulez installer puis cliquez sur Suivant.

  8. Dans la page Options d’installation d’applications, spécifiez le répertoire dans lequel vous voulez installer le proxy d’application COM+ puis cliquez sur Suivant.

    Les fichiers de composants de l’application sont copiés du fichier .msi dans le répertoire d’installation. Le répertoire d’installation par défaut est :

    %Program Files%\COMPlus Applications\appid

    Vous pouvez accepter le répertoire par défaut ou cliquer sur Répertoire spécifique et rechercher un autre emplacement.

  9. Cliquez sur Terminer. La nouvelle application apparaît dans l’arborescence de la console Services de composants. Si vous installez plusieurs applications, le répertoire que vous sélectionnez au cours de l’étape 8 est utilisé pour toutes les applications.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg puis appuyez sur Entrée.

  • Pour installer un proxy d’application COM+, vous devez disposer d’un accès en écriture au répertoire d’installation.

Pour installer un proxy d’application COM+ à l’aide de l’Explorateur Windows

  1. Sur l’ordinateur client, localisez le fichier du proxy d’application (.msi) à l’aide de l’Explorateur Windows. Ce fichier peut être hébergé localement ou sur une ressource réseau partagée.

  2. Double-cliquez sur le fichier du proxy d’application. Vous pouvez également cliquer avec le bouton droit de votre souris sur le nom du fichier puis cliquer sur Installer.

    Windows Installer installe automatiquement l’application serveur sur l’ordinateur cible.

Considérations supplémentaires

  • Pour installer un proxy d’application COM+, vous devez disposer d’un accès en écriture au répertoire d’installation.

Pour installer un proxy d’application COM+ à l’aide d’une ligne de commande

  • À l’invite de commandes, tapez ce qui suit puis appuyez sur Entrée :

    msiexec -i [<property overrides>] <application_name>.msi

    Valeur Description

    remplacement de propriétés

    Outre le remplacement de propriétés standard de Windows Installer, vous pouvez spécifier l’option suivante pour changer le répertoire d’installation de l’application COM+ du répertoire par défaut au répertoire spécifié :

    TARGETDIR = <target installation directory>

    nom_application

    Le nom de l’application qui doit être installée.

Outre le remplacement de propriétés standard de Windows Installer, vous pouvez spécifier les options du programme d’installation qui sont décrites dans le tableau suivant.

Option du programme d’installation Description
REMOTESERVERNAME = <new target server>

Change le serveur auquel se connecte l’ordinateur du serveur exporté par défaut au nouveau serveur cible spécifié.

ALLUSERS = 0

Installe le proxy d’application uniquement pour l’utilisateur actuel. Par défaut, le proxy d’application est installé à l’échelle de l’ordinateur.

TARGETDIR = <target installation directory>

Change le répertoire d’installation pour l’application COM+ du répertoire par défaut au répertoire spécifié.

Considérations supplémentaires

  • Pour installer un proxy d’application COM+, vous devez disposer d’un accès en écriture au répertoire d’installation.

Références supplémentaires

  • Gérer des applications COM+

  • Notation de la syntaxe de la ligne de commande


Supprimer des applications COM+

Lorsque les applications existantes deviennent obsolètes ou qu’elles ne sont plus utilisées, il est possible que vous deviez les supprimer. La suppression d’une application supprime également tous les composants qu’elle contient. Si ces composants dépendent de ressources supplémentaires (connexion à des bases de données, fichiers de données ou texte, configuration de la racine virtuelle des services Internet (IIS), etc.), ces ressources doivent être supprimées au moyen d’outils et d’utilitaires autres que le composant logiciel enfichable Services de composants.

Remarques

Si vous supprimez une application serveur COM+ en cours d’exécution, elle se ferme sans vous avertir avant d’être supprimée.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent.

Supprimer des applications COM+

  • À l’aide du composant logiciel enfichable Services de composants

  • À l’aide de l’Explorateur Windows

  • À l’aide d’une ligne de commande
Pour supprimer une application COM+ à l’aide du composant logiciel enfichable Services de composants

  1. Ouvrez Services de composants.

  2. Dans l’arborescence de la console, double-cliquez sur Ordinateurs puis sur l’ordinateur pour lequel vous voulez supprimer une application.

  3. Double-cliquez sur le dossier Applications COM+ de l’ordinateur spécifié pour afficher toutes les applications.

  4. Cliquez sur l’application que vous voulez supprimer.

  5. Si vous sélectionnez une application serveur, fermez-la. Pour ce faire, cliquez avec le bouton droit de votre souris sur l’application puis cliquez sur Fermer. Si vous sélectionnez une application de bibliothèque, assurez-vous que tous les processus qui utilisent cette application de bibliothèque sont fermés.

  6. Cliquez avec le bouton droit de votre souris sur l’application. Si l’option Supprimer ne figure pas dans le menu qui s’affiche lorsque vous cliquez avec le bouton droit de votre souris sur l’application, vous devez activer la suppression de l’application en procédant comme suit :

    1. Cliquez avec le bouton droit de votre souris sur l’application puis cliquez sur Propriétés.

    2. Dans la page de propriétés de l’application, sélectionnez l’onglet Paramètres avancés.

    3. Sous Protection, désactivez la case Désactiver les suppressions.

    4. Cliquez sur OK.

  7. Cliquez avec le bouton droit de votre souris sur l’application puis cliquez sur Supprimer.

  8. Dans la boîte de dialogue Confirmer la suppression de l’élément, cliquez sur Oui pour supprimer l’application.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg, puis appuyez sur Entrée.

Les procédures suivantes sont particulièrement utiles pour supprimer des applications COM+ sur des ordinateurs clients qui n’exécutent pas le composant logiciel enfichable Services de composants.

Pour supprimer une application COM+ à l’aide de l’Explorateur Windows

  1. Sur l’ordinateur sur lequel vous voulez supprimer l’application COM+, utilisez l’Explorateur Windows pour localiser le fichier de l’application serveur (.msi) ou le fichier du proxy d’application (.msi).

  2. Cliquez avec le bouton droit de votre souris sur le fichier .msi puis cliquez sur Désinstaller. Le programme d’installation de Windows supprime automatiquement l’application.
Pour supprimer une application COM+ à l’aide d’une ligne de commande

  • À l’invite de commandes, tapez ce qui suit puis appuyez sur Entrée.

    msiexec -x <application_name>.msi

    Valeur Description

    nom_application

    Le nom de l’application qui doit être supprimée.

Références supplémentaires

  • Gérer des applications COM+

  • Notation de la syntaxe de la ligne de commande


Gérer des applications DCOM

Le modèle COM (Component Object Model) permet d’encapsuler des fonctionnalités dans une application COM qui peut être réutilisée par de nombreuses autres applications. La technologie DCOM permet d’accéder à une application COM à partir de différents ordinateurs sur un réseau.

Normalement, les composants COM et COM+ sont hébergés au sein de bibliothèques de liaison dynamique (DLL) ou de fichiers exécutables (.exe). Vous pouvez installer ces composants sur un ordinateur client ou distant. Lorsque vous installez ces composants sur un ordinateur distant, l’appel est passé par DCOM qui repose sur les appels de procédure distante (RPC).

Pour les tâches en rapport avec l’administration des applications DCOM qui ne sont pas traitées dans cette section, consultez la page, éventuellement en anglais, traitant de DCOM (http://go.microsoft.com/fwlink/?LinkId=66689).

  • Définir la configuration de la sécurité COM à l’échelle de l’ordinateur

  • Définir la configuration de la sécurité COM spécifique à l’application


Définir la configuration de la sécurité COM à l’échelle de l’ordinateur

Les tâches que vous exécutez initialement aux fins de la gestion des applications DCOM sont principalement liées aux paramètres de sécurité. En utilisant le composant logiciel enfichable Services de composants, vous pouvez définir les propriétés de sécurité COM (Component Object Model) à l’échelle de l’ordinateur qui sont utilisées par les applications COM.

Pour plus d’informations sur les paramètres de sécurité COM, voir la page, éventuellement en anglais, traitant de la sécurité dans le modèle COM (http://go.microsoft.com/fwlink/?LinkId=66690).

  • Définir des autorisations d’accès à l’échelle de l’ordinateur

  • Définir des autorisations d’exécution et d’activation à l’échelle de l’ordinateur


Définir des autorisations d’accès à l’échelle de l’ordinateur

Les autorisations d’accès à l’échelle de l’ordinateur permettent de spécifier les utilisateurs qui peuvent accéder ou non aux applications COM. En utilisant le composant logiciel enfichable Services de composants, vous pouvez modifier les autorisations d’accès par défaut à l’échelle de l’ordinateur ou la stratégie de restriction à l’échelle de l’ordinateur. Cette rubrique contient la procédure de configuration des autorisations d’accès à l’échelle de l’ordinateur. Pour plus d’informations sur la stratégie de restriction à l’échelle de l’ordinateur, consultez la page, éventuellement en anglais, consacrée aux restrictions à l’échelle de l’ordinateur (http://go.microsoft.com/fwlink/?LinkId=67447).

Important

La modification des autorisations d’accès peut affecter la capacité des applications à démarrer, à se connecter, à fonctionner ou à s’exécuter correctement. Par conséquent, nous vous recommandons de modifier des autorisations spécifiques aux applications plutôt que les autorisations d’accès par défaut à l’échelle de l’ordinateur.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent.

Pour définir des autorisations d’accès à l’échelle de l’ordinateur

  1. Ouvrez Services de composants.

  2. Dans Services de composants, cliquez avec le bouton droit de votre souris sur l’ordinateur dont vous voulez modifier les autorisations d’accès à l’échelle de l’ordinateur puis cliquez sur Propriétés.

  3. Cliquez sur l’onglet Sécurité COM.

  4. Sous Autorisations d’accès, cliquez sur Modifier les limites ou sur Modifier, selon que vous voulez modifier la stratégie de restriction à l’échelle de l’ordinateur ou les paramètres par défaut à l’échelle de l’ordinateur. Une boîte de dialogue nommée Autorisation d’accès s’affiche.

  5. Pour supprimer un compte d’utilisateur ou un groupe, sélectionnez l’utilisateur ou le groupe dans la liste Noms d’utilisateurs ou de groupes et cliquez sur Supprimer. Le compte d’utilisateur ou le groupe sélectionné n’apparaît plus dans la liste.

  6. Pour ajouter un compte d’utilisateur ou un groupe, cliquez sur Ajouter. Dans la boîte de dialogue Sélectionner les utilisateurs, les ordinateurs ou les groupes, tapez le nom complet de l’utilisateur ou du groupe que vous voulez ajouter.

    Si vous ne connaissez pas le nom de l’utilisateur ou du groupe que vous voulez ajouter, cliquez sur Paramètres avancés puis sur Rechercher maintenant pour afficher une liste des utilisateurs et des groupes dans le domaine sélectionné. Sélectionnez un utilisateur ou un groupe dans la liste puis cliquez sur OK. L’utilisateur ou le groupe ajouté apparaît dans la liste Noms d’utilisateurs ou de groupes.

  7. Dans la liste Noms d’utilisateurs ou de groupes, sélectionnez le groupe ou l’utilisateur dont vous voulez modifier l’autorisation d’accès à l’échelle de l’ordinateur.

  8. Dans la liste Autorisations, cochez les cases Autoriser ou Refuser pour autoriser ou refuser l’autorisation d’accès local et l’autorisation d’accès distant au nom de groupe ou d’utilisateur sélectionné.

  9. Cliquez sur OK pour retourner dans l’onglet Sécurité COM.

  10. Cliquez sur OK. Les nouvelles autorisations d’accès à l’échelle de l’ordinateur sont appliquées au prochain démarrage d’une application sur l’ordinateur. Les applications en cours d’exécution ne sont pas affectées avant leur redémarrage.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg puis appuyez sur Entrée.

Références supplémentaires

  • Définir la configuration de la sécurité COM à l’échelle de l’ordinateur


Définir des autorisations d’exécution et d’activation à l’échelle de l’ordinateur

Les autorisations d’exécution et d’activation à l’échelle de l’ordinateur déterminent quels utilisateurs sont explicitement autorisés ou non à démarrer et à activer des applications COM (Component Object Model). En utilisant le composant logiciel enfichable Services de composants, vous pouvez modifier les autorisations d’exécution et d’activation par défaut à l’échelle de l’ordinateur ou la stratégie de restriction à l’échelle de l’ordinateur.

Important

La modification des autorisations d’exécution et d’activation peut affecter la capacité des applications à démarrer, à se connecter, à fonctionner ou à s’exécuter correctement. Par conséquent, nous vous recommandons de modifier des autorisations spécifiques aux applications plutôt que les autorisations d’exécution et d’activation par défaut.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent.

Pour définir des autorisations d’exécution et d’activation à l’échelle de l’ordinateur

  1. Ouvrez Services de composants.

  2. Dans le composant logiciel enfichable Services de composants, cliquez avec le bouton droit de votre souris sur l’ordinateur dont vous voulez modifier les autorisations d’exécution à l’échelle de l’ordinateur puis cliquez sur Propriétés.

  3. Sélectionnez l’onglet Sécurité COM.

  4. Sous Autorisations d’exécution et d’activation, cliquez sur Modifier les limites ou sur Modifier, selon que vous voulez modifier la stratégie de restriction à l’échelle de l’ordinateur ou les paramètres par défaut à l’échelle de l’ordinateur. Une boîte de dialogue nommée Autorisation d’exécution et d’activation s’affiche.

  5. Pour supprimer un compte d’utilisateur ou un groupe, sélectionnez l’utilisateur ou le groupe dans la liste Noms d’utilisateurs ou de groupes et cliquez sur Supprimer. Le compte d’utilisateur ou le groupe sélectionné n’apparaît plus dans la liste.

  6. Pour ajouter un compte d’utilisateur ou un groupe, cliquez sur Ajouter. Dans la boîte de dialogue Sélectionnez Utilisateurs et Groupes, tapez le nom complet de l’utilisateur ou du groupe que vous souhaitez ajouter. Si vous ne connaissez pas le nom de l’utilisateur ou du groupe à ajouter, cliquez sur Avancé, puis sur Rechercher pour afficher la liste des utilisateurs et des groupes du domaine sélectionné. Sélectionnez un utilisateur ou un groupe dans la liste puis cliquez sur OK. Le compte d’utilisateur ou le groupe ajouté apparaît dans la liste Noms d’utilisateurs ou de groupes.

  7. Dans la liste Noms d’utilisateurs ou de groupes, sélectionnez le groupe ou l’utilisateur dont vous voulez modifier les autorisations d’exécution et d’activation à l’échelle de l’ordinateur.

  8. Dans la liste Autorisations, cochez les cases Autoriser ou Refuser pour autoriser ou refuser l’autorisation d’exécution locale, l’autorisation d’activation locale, l’autorisation d’exécution distante et l’autorisation d’activation distante au nom de groupe ou d’utilisateur sélectionné.

  9. Cliquez sur OK pour retourner dans l’onglet Sécurité COM.

  10. Cliquez sur OK. Les nouvelles autorisations d’exécution et d’activation à l’échelle de l’ordinateur sont appliquées au prochain démarrage d’une application sur l’ordinateur. Les applications en cours d’exécution ne sont pas affectées avant leur redémarrage.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg puis appuyez sur Entrée.

  • Lorsque vous définissez des autorisations, vous devez vous assurer que SYSTÈME est inclus dans la liste Noms d’utilisateur ou de groupe dans la boîte de dialogue Autorisation d’exécution et d’activation et que SYSTÈME est assorti d’une autorisation d’exécution. SYSTÈME est inclus de manière implicite dans le groupe Tout le monde. Cependant, pour des raisons de sécurité, nous vous recommandons de ne pas activer l’autorisation d’exécution dans le groupe Tout le monde.

Références supplémentaires

  • Définir la configuration de la sécurité COM à l’échelle de l’ordinateur


Définir la configuration de la sécurité COM spécifique à l’application

En utilisant le composant logiciel enfichable Services de composants, vous pouvez définir les propriétés de sécurité COM (Component Object Model) pour une application COM spécifique.

Pour plus d’informations sur le fonctionnement de ces fonctions de sécurité, voir la page, éventuellement en anglais, traitant de la sécurité dans le modèle COM (http://go.microsoft.com/fwlink/?LinkId=66690).

  • Définir des autorisations d’accès spécifiques à l’application

  • Définir des autorisations d’exécution et d’activation spécifiques à l’application


Définir des autorisations d’accès spécifiques à l’application

Les autorisations d’accès spécifiques à l’application permettent de spécifier les utilisateurs qui peuvent accéder ou non aux applications COM (Component Object Model).

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent.

Pour définir des autorisations d’accès spécifiques à l’application

  1. Ouvrez Services de composants.

  2. Dans l’arborescence de la console, cliquez avec le bouton droit de votre souris sur l’application DCOM dont vous voulez modifier les autorisations d’accès puis cliquez sur Propriétés.

  3. Cliquez sur l’onglet Sécurité.

  4. Sous Autorisations d’accès, cliquez sur le bouton Personnaliser puis sur le bouton Modifier.

  5. Pour supprimer un compte d’utilisateur ou un groupe, sélectionnez l’utilisateur ou le groupe dans la liste Noms d’utilisateurs ou de groupes et cliquez sur Supprimer. Le compte d’utilisateur ou le groupe sélectionné n’apparaît plus dans la liste.

  6. Pour ajouter un compte d’utilisateur ou un groupe, cliquez sur Ajouter. Dans la boîte de dialogue Sélectionner les utilisateurs, les ordinateurs ou les groupes, tapez le nom complet de l’utilisateur ou du groupe à ajouter. Si vous ne le connaissez pas, cliquez sur Paramètres avancés puis sur Rechercher maintenant pour afficher une liste des utilisateurs et des groupes dans le domaine sélectionné. Sélectionnez un utilisateur ou un groupe dans la liste puis cliquez sur OK. Le compte d’utilisateur ou le groupe ajouté apparaît dans la liste Noms d’utilisateurs ou de groupes.

  7. Dans la liste Noms d’utilisateurs ou de groupes, sélectionnez le groupe ou l’utilisateur dont vous voulez modifier l’autorisation d’accès par défaut.

  8. Dans la liste Autorisations, cochez les cases Autoriser ou Refuser pour autoriser ou refuser l’autorisation d’accès local et l’autorisation d’accès distant au nom de groupe ou d’utilisateur sélectionné.

  9. Cliquez deux fois sur OK. Les nouvelles autorisations d’accès spécifiques à l’application sont appliquées au prochain démarrage de l’application sur l’ordinateur.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg, puis appuyez sur Entrée.

Références supplémentaires

  • Définir la configuration de la sécurité COM spécifique à l’application


Définir des autorisations d’exécution et d’activation spécifiques à l’application

Les autorisations d’exécution et d’activation spécifiques à l’application permettent de spécifier les utilisateurs qui ont l’autorisation ou non de démarrer ou d’activer une application COM.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent.

Pour définir des autorisations d’exécution et d’activation spécifiques à l’application

  1. Ouvrez Services de composants.

  2. Dans le composant logiciel enfichable Services de composants, cliquez avec le bouton droit de votre souris sur l’application DCOM dont vous voulez modifier les autorisations d’accès puis cliquez sur Propriétés.

  3. Sélectionnez l’onglet Sécurité.

  4. Sous Autorisations d’exécution et d’activation, cliquez sur le bouton Personnaliser puis sur le bouton Modifier.

  5. Pour supprimer un compte d’utilisateur ou un groupe, sélectionnez l’utilisateur ou le groupe dans la liste Noms d’utilisateurs ou de groupes et cliquez sur Supprimer. Le compte d’utilisateur ou le groupe sélectionné n’apparaît plus dans la liste.

  6. Pour ajouter un compte d’utilisateur ou un groupe, cliquez sur Ajouter. Ensuite, dans le volet inférieur de la boîte de dialogue Sélectionnez Utilisateurs et Groupes, tapez le nom complet de l’utilisateur ou du groupe que vous souhaitez ajouter. Si vous ne connaissez pas le nom de l’utilisateur ou du groupe à ajouter, cliquez sur Avancé, puis sur Rechercher pour afficher la liste des utilisateurs et des groupes du domaine sélectionné. Sélectionnez un utilisateur ou un groupe dans la liste puis cliquez sur OK. Le compte d’utilisateur ou le groupe ajouté apparaît dans la liste Noms d’utilisateurs ou de groupes.

  7. Dans la liste Noms d’utilisateurs ou de groupes, sélectionnez le groupe ou l’utilisateur dont vous voulez modifier l’autorisation d’accès par défaut.

  8. Dans la liste Autorisations, cochez les cases Autoriser ou Refuser pour autoriser ou refuser l’autorisation d’exécution locale, l’autorisation d’activation locale, l’autorisation d’exécution distante et l’autorisation d’activation distante au nom de groupe ou d’utilisateur sélectionné.

  9. Cliquez deux fois sur OK. Les nouvelles autorisations d’exécution et d’activation spécifiques à l’application sont appliquées au prochain démarrage de l’application sur l’ordinateur.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg puis appuyez sur Entrée.

Références supplémentaires

  • Définir la configuration de la sécurité COM spécifique à l’application


Gérer des transactions distribuées

Le service DTC (Distributed Transaction Coordinator) coordonne les transactions qui mettent à jour des ressources protégées par transaction, telles que les bases de données, les files d’attente de messages, les systèmes de fichiers, etc. Ces ressources peuvent se trouver sur un seul ordinateur ou être distribuées sur un réseau de systèmes.

En utilisant le composant logiciel enfichable Services de composants, vous pouvez configurer vos ordinateurs pour qu’ils prennent en charge les transactions locales, à distance et distribuées. Vous pouvez également contrôler et gérer toutes les transactions avec Services de composants.

Gestion des transactions

Le composant logiciel enfichable Services de composants dispose de plusieurs fonctionnalités que les administrateurs peuvent utiliser aux fins de l’administration de base du gestionnaire de transactions DTC sur un ordinateur local et des systèmes à distance.

Lorsque vous gérez des transactions, configurez tout d’abord le DTC qui coordonnera les transactions pour les applications qui s’exécutent sur votre ordinateur. Par défaut, toutes les transactions sur un ordinateur sont coordonnées par le gestionnaire local de transactions DTC de l’ordinateur. Vous pouvez également configurer votre ordinateur pour acheminer tout le trafic de coordination des transactions vers le gestionnaire de transactions DTC d’un ordinateur à distance.

La principale tâche suivante quant à la gestion des transactions consiste à configurer le DTC chargé de coordonner vos transactions. Vous pouvez utiliser Services de composants pour gérer le gestionnaire local de transactions DTC ou le gestionnaire de transactions d’un ordinateur distant. Vous pouvez accéder à la feuille de propriétés du DTC local dans l’arborescence de la console du composant logiciel enfichable Services de composants comme suit :

Services de composants\Ordinateurs\Nom de l’ordinateur\Coordinateur de transactions distribuées

Les tâches de configuration incluent le démarrage et l’arrêt du suivi, le changement de taille et d’emplacement du journal et la modification de divers paramètres de sécurité pour le gestionnaire de transactions DTC.

Le composant logiciel enfichable Services de composants fournit également les utilitaires Liste des transactions et Statistiques des transactions pour le gestionnaire de transactions DTC. Vous pouvez utiliser ces utilitaires pour afficher et modifier le statut des transactions régies par le gestionnaire de transactions DTC.

Pour plus d’informations sur les tâches DTC non traitées dans cette section, reportez-vous au guide, éventuellement en anglais, traitant de la gestion DTC (http://go.microsoft.com/fwlink/?LinkId=66713).

  • Configurer le coordinateur de transactions par défaut

  • Configurer la trace DTC

  • Configurer la journalisation DTC

  • Configurer la sécurité DTC

  • Utiliser la sauvegarde et restauration Windows avec DTC


Configurer le coordinateur de transactions par défaut

Par défaut, chaque système utilise son gestionnaire de transactions DTC (Distributed Transaction Coordinator) local pour initialiser et coordonner les transactions. Cependant, vous pouvez configurer votre ordinateur pour qu’il utilise le gestionnaire de transactions DTC d’un autre système en tant que coordinateur de transactions par défaut. Le gestionnaire de transactions DTC sur le système spécifié est utilisé en tant que coordinateur de transactions chaque fois qu’un client sur le système local initialise une transaction DTC et qu’il ne spécifie pas de manière explicite un coordinateur de transactions. Le coordinateur de transaction par défaut coordonne toutes les transactions initialisées par COM+ ou tout autre client utilisant des transactions. Le coordinateur de transactions par défaut fait également office de coordinateur de transactions pour tous les gestionnaires de ressources sur le système local qui s’enrôlent dans une transaction DTC quelconque.

Le système que vous sélectionnez en tant que coordinateur de transactions par défaut doit être fiable. La connexion réseau au système hébergeant le coordinateur de transactions par défaut doit également être fiable. Dans le cas contraire, la spécification d’un coordinateur de transactions par défaut risque de réduire la disponibilité du DTC sur le système local.

Si vous décidez d’utiliser un coordinateur de transactions par défaut à distance, votre ordinateur et le coordinateur de transactions à distance doivent être configurés pour autoriser l’accès DTC réseau. Pour savoir comment activer l’accès DTC réseau, consultez la section Configurer la sécurité DTC.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent. Pour plus d’informations, consultez la section « Considérations supplémentaires » de cette rubrique.

Pour désigner un système distant en tant que coordinateur de transactions par défaut

  1. Ouvrez Services de composants.

  2. Dans le composant logiciel enfichable Services de composants, cliquez avec le bouton droit de votre souris sur l’ordinateur dont vous voulez modifier les paramètres du coordinateur de transactions (Poste de travail, par exemple) puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue des propriétés, cliquez sur l’onglet MSDTC.

  4. Désactivez la case Utiliser un coordinateur local.

  5. Sous Nom de l’hôte coordinateur à distance, tapez le nom du système distant. Si vous n’êtes pas sûr du nom exact, cliquez sur Sélectionner pour afficher une liste de tous les composants sur le réseau puis sélectionnez l’ordinateur de votre choix dans la liste.

  6. Cliquez sur OK.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg, puis appuyez sur Entrée.

  • Pour configurer le coordinateur de transactions par défaut, vous devez disposer d’informations d’identification d’administrateur sur le système local et le système désigné en tant que coordinateur par défaut. Le système DTC local peut ainsi extraire les informations appropriées du registre du système coordinateur de transactions par défaut.

Pour désigner le système local en tant que coordinateur de transactions par défaut

  1. Ouvrez Services de composants.

  2. Dans l’arborescence de la console, cliquez avec le bouton droit de votre souris sur l’ordinateur que vous voulez désigner en tant que coordinateur de transactions par défaut puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue des propriétés de l’ordinateur, cliquez sur l’onglet MSDTC.

  4. Cochez la case Utiliser un coordinateur local.

  5. Cliquez sur OK.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg, puis appuyez sur Entrée.

  • Pour configurer le coordinateur de transactions par défaut, vous devez disposer d’informations d’identification d’administrateur sur le système local et sur le système désigné en tant que coordinateur par défaut. Le système DTC local peut ainsi extraire les informations appropriées du Registre du système coordinateur de transactions par défaut.

Références supplémentaires

  • Gérer des transactions distribuées


Configurer la trace DTC

Vous pouvez configurer la trace en arrière-plan au moyen de la feuille de propriétés DTC local dans le composant logiciel enfichable Services de composants. Vous ne pouvez utiliser cette interface que pour configurer la trace en arrière-plan. Vous ne pouvez pas l’utiliser pour contrôler le suivi des transactions individuelles ou les paramètres de suivi à distance. Pour configurer la trace DTC (Distributed Transaction Coordinator), vous pouvez sélectionner des options de sortie et de connexion. Vous pouvez utiliser les options de connexion pour contrôler le fichier journal des données de suivi.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent.

Pour configurer la trace DTC

  1. Ouvrez Services de composants.

  2. Dans le composant logiciel enfichable Services de composants, double-cliquez sur Ordinateurs, Nom de l’ordinateur et Coordinateur de transactions distribuées.

  3. Cliquez avec le bouton droit de votre souris sur DTC local puis cliquez sur Propriétés.

  4. Dans l’onglet Suivi, sous Options de sortie, sélectionnez ou désactivez les cases en fonction des options de sortie recherchées.

  5. Sous Options de connexion, cliquez sur Nouvelle session, Arrêter la session ou Purger les données selon ce qui convient.

    En option, vous pouvez entrer une valeur dans le champ Taille max. de la mémoire tampon (taille TaillePage).

  6. Cliquez sur OK.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg puis appuyez sur Entrée.

Références supplémentaires

  • Gérer des transactions distribuées


Configurer la journalisation DTC

Vous pouvez configurer l’emplacement et la taille du fichier journal DTC (Distributed Transaction Coordinator).

Attention

Si vous modifiez la taille du fichier journal DTC, le fichier journal actuel est détruit et un nouveau fichier journal est créé. Avant de modifier le fichier journal, vérifiez que le fichier journal existant peut être supprimé en toute sécurité en vous assurant qu’il n’y a pas de transaction incertaines, dont il est impossible de notifier l’annulation ou dont il est impossible de notifier la validation. Pour plus d’informations sur la gestion des journaux DTC, voir la page, éventuellement en anglais, traitant de la gestion des journaux DTC (http://go.microsoft.com/fwlink/?LinkId=66753).

Important

Avant de configurer le fichier journal, arrêtez le DTC dans le composant logiciel enfichable Services. Si vous n’arrêtez pas le DTC, toute tentative de réinitialisation du fichier journal génèrera un message de la console DTC indiquant que le service DTC doit être arrêté et redémarré pour pouvoir exécuter l’action requise.

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent.

Pour configurer la journalisation DTC

  1. Ouvrez Services de composants.

  2. Dans l’arborescence de la console, double-cliquez sur Ordinateurs, Nom de l’ordinateur et Coordinateur de transactions distribuées.

  3. Cliquez avec le bouton droit de votre souris sur DTC local puis cliquez sur Propriétés.

  4. Pour modifier l’emplacement du fichier journal, cliquez sur l’onglet Journalisation. Sous Emplacement, tapez le nouveau chemin d’accès du fichier journal. Si vous ne connaissez pas le chemin d’accès, cliquez sur Parcourir pour sélectionner un emplacement pour le fichier journal.

  5. Pour changer la taille du fichier journal, tapez la nouvelle taille du fichier journal en méga-octets (Mo) sous Capacité.

  6. Cliquez sur OK.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg, puis appuyez sur Entrée.

Références supplémentaires

  • Gérer des transactions distribuées


Configurer la sécurité DTC

Vous pouvez configurer les exigences de sécurité inhérentes aux transactions distribuées auxquelles participe votre ordinateur. Les paramètres de sécurité par défaut ne permettent pas à votre ordinateur de participer à des transactions distribuées à distance.

Important
  • Par défaut, le service DTC (Distributed Transaction Coordinator) s’exécute sous le compte Service réseau. Ce compte est spécifiquement conçu pour permettre aux services tels que le service DTC (Distributed Transaction Coordinator) de s’exécuter avec le jeu de privilèges appropriés. Pour minimiser les problèmes de sécurité potentiels et assurer le fonctionnement du service DTC, nous vous recommandons d’utiliser le compte Service réseau par défaut. Un compte d’utilisateur de domaine peut également être utilisé.

  • Si vous activez les transactions réseau DTC sur un ordinateur sur lequel le Pare-feu Windows est activé, vous devez également configurer l’ordinateur pour qu’il autorise le trafic DTC à traverser le pare-feu. Pour plus d’informations sur le pare-feu Windows, voir la page, éventuellement en anglais, traitant de la gestion des exceptions de programme, de port et de service système (http://go.microsoft.com/fwlink/?LinkId=67467).

Pour mener à bien cette procédure, il est nécessaire d’appartenir au groupe Administrateurs ou à un groupe équivalent.

Pour configurer la sécurité DTC afin de n’autoriser que les transactions locales

  1. Ouvrez Services de composants.

  2. Dans le composant logiciel enfichable Services de composants, double-cliquez sur Ordinateurs, Nom de l’ordinateur et Coordinateur de transactions distribuées.

  3. Cliquez avec le bouton droit de votre souris sur DTC local, cliquez sur Propriétés et sélectionnez l’onglet Sécurité.

  4. Sous Paramètres de sécurité, désactivez la case Accès DTC réseau.

  5. Continuez de configurer les paramètres de sécurité ou cliquez sur OK.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg, puis appuyez sur Entrée.

Pour configurer la sécurité DTC afin d’utiliser un coordinateur de transactions à distance

  1. Ouvrez Services de composants.

  2. Dans le composant logiciel enfichable Services de composants, double-cliquez sur Ordinateurs, Nom de l’ordinateur et Coordinateur de transactions distribuées.

  3. Cliquez avec le bouton droit sur DTC local, cliquez sur Propriétés, puis sélectionnez l’onglet Sécurité.

  4. Sous Paramètres de sécurité, cochez la case Accès DTC réseau.

  5. Sous Communication du gestionnaire de transactions, cochez les cases Autoriser les transactions entrantes et Autoriser les transactions sortantes.

  6. Sélectionnez un niveau d’authentification pour les communications DTC. Le niveau Authentification mutuelle requise est le plus sûr.

  7. Continuez de configurer les paramètres de sécurité ou cliquez sur OK.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg, puis appuyez sur Entrée.

Pour coordonner les transactions à distance

  1. Ouvrez Services de composants.

  2. Dans le composant logiciel enfichable Services de composants, double-cliquez sur Ordinateurs, Nom de l’ordinateur et Coordinateur de transactions distribuées.

  3. Cliquez avec le bouton droit sur DTC local, cliquez sur Propriétés, puis sélectionnez l’onglet Sécurité.

  4. Sous Paramètres de sécurité, activez la case à cocher Accès DTC réseau.

  5. Sous Client et administration, cochez la case Autoriser les clients distants.

  6. Sous Communication du gestionnaire de transactions, activez les cases à cocher Autoriser les transactions entrantes et Autoriser les transactions sortantes.

  7. Sélectionnez un niveau d’authentification pour les communications DTC. Le niveau Authentification mutuelle requise est le plus sûr.

  8. Continuez de configurer les paramètres de sécurité ou cliquez sur OK.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg, puis appuyez sur Entrée.

Pour changer le compte d’ouverture de session DTC

  1. Ouvrez Services de composants.

  2. Dans le composant logiciel enfichable Services de composants, double-cliquez sur Ordinateurs, Nom de l’ordinateur et Coordinateur de transactions distribuées.

  3. Cliquez avec le bouton droit sur DTC local, cliquez sur Propriétés, puis sélectionnez l’onglet Sécurité.

  4. Sous Compte d’ouverture de session DTC, entrez le compte sous lequel le service DTC s’exécutera ou cliquez sur Parcourir pour localiser le nom du compte. Tapez et confirmez le mot de passe pour ce compte.

  5. Cliquez sur OK.

Considérations supplémentaires

  • Le composant logiciel enfichable Services de composants ne figure plus dans Outils d’administration. Pour ouvrir Services de composants, cliquez sur Démarrer. Dans la zone de recherche, tapez dcomcnfg, puis appuyez sur Entrée.

Références supplémentaires

  • Gérer des transactions distribuées


Utiliser la sauvegarde et restauration Windows avec DTC

Le service DTC (« Distributed Transaction Coordinator » ou Coordinateur de transactions distribuées) est entièrement compatible avec les fonctionnalités de sauvegarde et de restauration Windows.

Toutefois, la sauvegarde et la restauration ne s’appliquent qu’aux ressources de l’ordinateur local. Par conséquent, si des transactions actives impliquent plusieurs ordinateurs, la cohérence transactionnelle ne peut pas être garantie.

Afin d’éviter les problèmes, assurez-vous qu’il n’y a pas de transactions incomplètes sous les conditions suivantes lors des opérations de sauvegarde et de restauration :

  • Un ordinateur fonctionne en tant que coordinateur DTC distant.

    Utilisez la procédure « Pour déterminer si un ordinateur utilise un coordinateur distant » afin de déterminer si l’ordinateur utilise un coordinateur distant. Utilisez la procédure « Pour afficher et résoudre les transactions existantes » afin de résoudre les transactions incomplètes.

  • Un ordinateur possède une application qui participe dans des transactions impliquant plusieurs ordinateurs.

    Utilisez la procédure suivante « Pour déterminer si un ordinateur utilise un coordinateur distant » sur l’ordinateur sur lequel l’application s’exécute afin de déterminer le coordinateur de transactions de cet ordinateur. Utilisez la procédure « Pour afficher et résoudre les transactions existantes » afin de résoudre les transactions incomplètes sur l’ordinateur sur lequel le coordinateur s’exécute.

Pour déterminer si un ordinateur utilise un coordinateur distant

  1. Ouvrez le composant logiciel enfichable Services de composants.

  2. Cliquez avec le bouton droit sur l’ordinateur dont vous voulez modifier les paramètres du coordinateur de transactions (Poste de travail, par exemple), puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue des propriétés de l’ordinateur, cliquez sur l’onglet MSDTC.

  4. Si la case à cocher Utiliser un coordinateur local est désactivée, le nom de l’ordinateur affiché dans Nom de l’hôte coordinateur à distance indique le coordinateur distant utilisé par l’ordinateur.

  5. Cliquez sur OK.
Pour afficher et résoudre les transactions existantes

  1. Ouvrez le composant logiciel enfichable Services de composants sur l’ordinateur qui agit en tant que coordinateur pour les transactions.

  2. Double-cliquez sur Ordinateurs, Poste de travail, Distributed Transaction Coordinator et DTC local, puis cliquez sur Liste des transactions.

    La liste affiche toutes les transactions incomplètes.

  3. Pour résoudre une transaction incomplète, cliquez avec le bouton droit sur la transaction, puis cliquez sur Résoudre. Sélectionnez Valider, Annuler ou Oublier.

Références supplémentaires

  • Gérer des transactions distribuées


Interface utilisateur : Services de composants

  • Feuille de propriétés <Application> d’applications COM+ : onglet Activation

  • Feuille de propriétés <Application> d’applications COM+ : onglet Avancé

  • Feuille de propriétés <Application> d’applications COM+ : onglet Vider

  • Feuille de propriétés <Application> d’applications COM+ : onglet Général

  • Feuille de propriétés <Application> d’applications COM+ : onglet Identité

  • Feuille de propriétés <Application> d’applications COM+ : onglet Mise en pool & recyclage

  • Feuille de propriétés <Application> d’applications COM+ : onglet Mise en file d’attente

  • Feuille de propriétés <Application> d’applications COM+ : onglet Sécurité

  • Feuille de propriétés <Application> de configuration DCOM : onglet Points de terminaison

  • Feuille de propriétés <Application> de configuration DCOM : onglet Général

  • Feuille de propriétés <Application> de configuration DCOM : onglet Identité

  • Feuille de propriétés <Application> de configuration DCOM : onglet Emplacement

  • Feuille de propriétés <Application> de configuration DCOM : onglet Sécurité

  • Feuille de propriétés Poste de travail : onglet Sécurité COM

  • Feuille de propriétés Poste de travail : onglet Propriétés par défaut

  • Feuille de propriétés Poste de travail : onglet Protocoles par défaut

  • Feuille de propriétés Poste de travail : onglet Général

  • Feuille de propriétés Poste de travail : onglet MSDTC

  • Feuille de propriétés Poste de travail : onglet Options

  • Feuille de propriétés DTC local : onglet Enregistrement

  • Feuille de propriétés DTC local : onglet Sécurité

  • Feuille de propriétés DTC local : onglet Suivi


Feuille de propriétés <Application> d’applications COM+ : onglet Activation

Option Détails

Type d’activation

Cliquez sur Application bibliothèque pour une application qui s’exécute dans le cadre du processus du client à l’origine de sa création. Elle ne peut être appelée que par des clients hébergés sur le même ordinateur.

Cliquez sur Application serveur pour une application qui s’exécute dans le cadre de son propre processus serveur dédié.

Si vous modifiez le type d’activation de l’application, d’autres propriétés propres à l’application sont réinitialisées.

SOAP

Si vous cochez la case Utilise SOAP :

  • Sous VRoot SOAP, spécifiez le répertoire de la racine virtuelle des services Internet (IIS) où les composants de cette application doivent être disponibles en tant que serveur Web XML.

  • L’option Sécurité SOAP indique si la sécurité basée sur les rôles COM+ est implémentée pour activations via le protocole SOAP (Simple Object Access Protocol).

Nom du serveur distant

Tapez le nom du serveur distant utilisé par le proxy d’application. Un proxy d’application achemine les appels clients vers une application serveur COM+ installée sur un ordinateur distant.

Répertoire racine de l’application

Tapez le chemin d’accès complet du répertoire contenant un fichier manifeste de l’assembly côte à côte valide utilisé pour créer un contexte d’activation pour l’application. Les applications utilisent des contextes d’activation pour charger une version de bibliothèque de liaison dynamique (DLL, Dynamic-Link Library) particulière, une instance d’objet COM (Component Object Model) donnée ou une version de Windows personnalisée.


Feuille de propriétés <Application> d’applications COM+ : onglet Avancé

Option Détails

Arrêt du processus serveur

Vous pouvez configurer un processus serveur pour qu’il s’arrête en cas d’inactivité pendant un certain temps. C’est un moyen utile de libérer des ressources qui ne sont plus nécessaires. Cliquez sur l’une des options suivantes :

  • Cliquez sur Ne pas arrêter l’exécution lors de l’inactivité pour spécifier que le processus serveur associé avec l’application COM+ continue de s’exécuter en l’absence d’appels clients en attente. L’application s’exécute jusqu’à sa fermeture manuelle.

  • Cilquez sur Activer l’arrêt en cas d’inactivité pour spécifier que le processus serveur associé avec l’application COM+ s’arrête automatiquement après une certaine période d’inactivité déterminée par le nombre de minutes indiqué dans la zone de texte.

Protection

Cochez l’une des cases suivantes, voire les deux, pour empêcher l’application d’être supprimée ou modifiée :

  • Désactiver les suppressions

  • Désactiver les modifications

Débogage

Cochez la case Ouvrir dans le débogueur pour spécifier qu’une application serveur s’ouvre dans le débogueur au démarrage en utilisant la ligne de commande du débogueur spécifiée sous Chemin d’accès du débogueur.

Tapez le chemin d’accès et la ligne de commande utilisée pour appeler le débogueur lorsque l’option Ouvrir dans le débogueur est activée. Pour rechercher le débogueur, cliquez sur Parcourir. Toute option de ligne de commande pour le débogueur doit être tapée dans la zone de texte une fois le débogueur localisé.

Activer les gestionnaires de ressources de compensation

Cochez cette case pour que l’application serveur utilise un gestionnaire de ressources de compensation (CRM). Les composants CRM ne sont disponibles pour l’application que si cette case est cochée.

Activer la prise en charge de 3 Go

Cochez cette case pour spécifier que l’application peut accéder à 3 gigaoctets (Go) de mémoire lorsque le système d’exploitation a été configuré pour autoriser l’accès à plus de 2 Go de mémoire.


Feuille de propriétés <Application> d’applications COM+ : onglet Vider

Option | Détails
Répertoire de vidage des images | Tapez le chemin d’accès complet du fichier de vidage. N’indiquez pas le nom du fichier. Le chemin d’accès par défaut est %SystemRoot%\system32\com\dmp.
Nombre maximal d’images de vidage | Sélectionnez le nombre maximal de fichiers devant être générés dans le répertoire de vidage des images avant d’être écrasés. Il doit être compris entre 1 et 200. Par défaut, il est configuré sur 5.
Autoriser le traitement du vidage des images | Cochez la case Autoriser le vidage d’images lors d’une erreur de l’application pour vider une image statique de l’application lorsqu’une exception se produit ou en cas d’échec de l’application.


Feuille de propriétés <Application> d’applications COM+ : onglet Général

Option | Détails
Description | Vous pouvez taper une description de 500 caractères maximum pour faciliter l’identification et la gestion de l’élément sélectionné.
Identificateur de l’application | L’identificateur global unique (GUID, Globally Unique Identifier) de la partition d’application COM+ sélectionnée. L’identificateur global unique est généré automatiquement lorsque la partition COM+ est créée. Vous pouvez l’utiliser pour identifier des versions particulières de la partition sur un ordinateur.


Feuille de propriétés <Application> d’applications COM+ : onglet Identité

Option Détails

Boutons d’option Compte système

Cliquez sur le bouton d’option correspondant au compte sous lequel l’application s’exécutera :

  • Utilisateur interactif : Cliquez sur ce bouton pour indiquer que l’application s’exécute sous l’identité de l’utilisateur actuellement connecté à l’ordinateur. Les informations d’identification de sécurité de l’utilisateur sont utilisées lorsque l’application est authentifiées pour accéder aux ressources.

  • Service local : Cliquez sur ce bouton pour indiquer que l’application s’exécute sous le compte Service local.

  • Service réseau : Cliquez sur ce bouton pour indiquer que l’application s’exécute sous le compte Service réseau.

  • Système local : Cliquez sur ce bouton pour indiquer que l’application s’exécute sous le compte Système local. Ce compte confère à l’application un accès complet à l’ordinateur local.

Bouton d’option Cet utilisateur

Cliquez sur Cet utilisateur pour indiquer que l’application s’exécute sous l’identité d’un compte utilisateur spécifié. Les informations d’identification de sécurité de l’utilisateur sont utilisées lorsque l’application est authentifiées pour accéder aux ressources. Tapez le nom d’utilisateur et le mot de passe de l’utilisateur.


Feuille de propriétés <Application> d’applications COM+ : onglet Mise en pool & recyclage

Option Détails

Pool d’application

Sous Taille du pool, tapez le nombre maximal de processus qui peuvent s’exécuter simultanément au niveau du serveur d’applications. La valeur par défaut est 1, auquel cas le service Pool d’application COM+ est désactivé.

Recyclage d’applications

Vous pouvez sélectionner des valeurs pour les options suivantes :

  • Limite de durée de vie : Le nombre maximal de minutes au cours desquelles un processus peut s’exécuter avant d’être recyclé. La plage valide est comprise entre 0 et 30 240 minutes (21 jours).

  • Limite de la mémoire : La quantité maximale de mémoire utilisée par le processus en kilo-octets (Ko) avant d’être recyclé. Si la mémoire utilisée par le processus excède la valeur spécifiée pendant plus d’une minute, le processus est recyclé. La plage valide est comprise entre 0 et 1 048 576 Ko. La valeur par défaut est 0 Ko.

  • Délai d’expiration : Le nombre de minutes qui s’écoulent avant le déblocage de toutes les références externes aux objets dans le cadre du processus avant l’arrêt forcé de ce dernier. La plage valide est comprise entre 1 et 1 440 minutes (24 heures). La valeur par défaut est 15 minutes. Cette valeur n’est utilisée que lorsqu’il a déjà été déterminé qu’un processus sera recyclé en fonction d’autres critères.

  • Limite de l’appel : Le nombre maximal d’appels que les objets d’application peuvent accepter avant que le processus soit recyclé. La plage valide est comprise entre 0 et 1 048 576 appels.

  • Limite de l’activation : Le nombre maximal d’activations d’objets d’application devant être acceptées avant que le processus soit recyclé. La plage valide est comprise entre 0 et 1 048 576 activations.


Feuille de propriétés <Application> d’applications COM+ : onglet Mise en file d’attente

Option | Détails
Zone de groupe Authentification des messages MSMQ | Cliquez sur Authentifier les messages si le niveau d’authentification des appels (sur la page de propriétés de sécurité) n’est pas AUCUN pour authentifier les messages émanant de clients demandant les services de cette application uniquement lorsque Message Queuing vérifie l’intégrité des requêtes. Si le Niveau d’authentification pour les appels (dans l’onglet Sécurité de la feuille de propriétés Application) est Aucun, les messages ne sont pas authentifiés.
Nombre maximal de lecteurs simultanés | Tapez le nombre maximal de threads simultanés qui écoutent cette file d’attente. En cas de dépassement du nombre maximal, les messages attendent en file d’attente le prochain thread disponible.


Feuille de propriétés <Application> d’applications COM+ : onglet Sécurité

Options Détails

Autorisation

Cochez la case Appliquer les vérifications d’accès pour cette application pour appliquer les vérifications d’accès basées sur les rôles pour l’application. Lorsque des rôles sont définis pour une application, l’appartenance à un rôle d’un appelant est vérifiée à chaque appel dans l’application.

Niveau de sécurité

Cliquez sur Effectuer les vérifications d’accès uniquement au niveau du processus pour n’activer les vérifications d’accès qu’au niveau de l’application. Aucune vérification de rôle n’est effectuée au niveau des composants, de l’interface ou de la méthode. Si la case Appliquer les vérifications d’accès pour cette application n’est pas cochée, ce paramètre est ignoré.

Cliquez sur Effectuer les vérifications d’accès au niveau du processus et des composants pour activer les vérifications d’accès à chaque niveau des appels dans l’application. La vérification des rôles est effectuée au niveau de l’application et au niveau des composants, de l’interface et de la méthode pour tout composant dont l’option Appliquer les vérifications d’accès au niveau du composant est sélectionnée dans l’onglet Sécurité de la feuille de propriétés correspondante. Si la case Appliquer les vérifications d’accès pour cette application n’est pas cochée, ce paramètre est ignoré.

Stratégie de restriction logicielle

Cochez la case Appliquer la stratégie de restriction logicielle pour configurer le niveau de confiance de la stratégie de restriction logicielle pour cette application dans la zone déroulante Niveau de restriction. Si la case n’est pas cochée, la configuration à l’échelle du système de la stratégie de restriction logicielle est utilisée.

Niveau d’authentification pour les appels

Lorsque vous configurez un niveau d’authentification pour une application, vous déterminez le degré d’authentification appliqué lorsque des clients appellent l’application. Plus les niveaux d’authentification sont élevés, plus la sécurité et l’intégrité sont accrues. Le niveau d’authentification que vous sélectionnez prend effet au prochain démarrage de l’application.

Sélectionnez le niveau d’authentification approprié. Les niveaux d’authentification sont répertoriés du niveau le plus bas au plus élevé :

  • Aucun : Aucune authentification.

  • Connexion : Authentification des informations d’identification uniquement lorsque la connexion est établie.

  • Appel : Authentification des informations d’identification au début de chaque appel.

  • Paquet : Authentification des informations d’identification et vérification que toutes les données sont reçues. Il s’agit du paramètre par défaut pour les applications serveur COM+.

  • Intégrité du paquet : Authentification des informations d’identification et vérification qu’aucune donnée n’a été modifiée lors du transfert.

  • Confidentialité du paquet : Authentification des informations d’identification et chiffrement des paquets, y compris les données et l’identité et la signature de l’expéditeur.

Niveau d’emprunt d’identité

Lorsque vous configurez un niveau d’emprunt d’identité pour une application, vous déterminez le degré d’autorité que l’application accorde aux autres applications quant à l’utilisation de son identité lorsqu’elle les appelle. Vous ne pouvez définir ce niveau d’emprunt d’identité que pour les applications serveur COM+. Les applications de bibliothèque s’exécutent sous l’identité du processus d’hébergement et utilisent le niveau d’emprunt d’identité spécifié par ce dernier.

Sélectionnez le niveau d’emprunt d’identité approprié. Les niveaux d’emprunt d’identité suivants sont répertoriés du niveau d’autorité accordé le plus bas au plus élevé :

  • Anonyme : Le client est anonyme pour le serveur. Le serveur peut emprunter l’identité du client mais le jeton d’emprunt d’identité (informations d’identification locales) ne contient aucune information sur le client.

  • Identifier : Le serveur peut obtenir l’identité du client et l’emprunter pour déterminer les niveaux de vérification d’accès.

  • Emprunter l’identité : Il s’agit du paramètre par défaut pour les applications serveur COM+. Le serveur peut emprunter l’identité du client lorsqu’il agit pour son compte avec malgré tout certaines restrictions. Le serveur peut accéder aux ressources situées sur le même ordinateur que le client. Si le serveur est sur le même ordinateur que le client, il peut accéder aux mêmes ressources réseau que le client. Si le serveur est sur un ordinateur autre que celui sur lequel est hébergé le client, il ne peut accéder qu’aux ressources situées sur le même ordinateur que le serveur.

  • Déléguer : Le serveur peut emprunter l’identité du client lorsqu’il agit pour son compte, que le serveur soit ou non sur le même ordinateur que le client. Lors de l’emprunt d’identité, les informations d’identification du client (les informations d’identification avec validité locale et les informations d’identification avec validité réseau) peuvent être transmises à un nombre quelconque d’ordinateurs.


Feuille de propriétés <Application> de configuration DCOM : onglet Points de terminaison

Option Détails

Protocoles et points de terminaison DCOM

Sous Protocoles et points de terminaison DCOM, cliquez sur l’entrée pour spécifier le protocole réseau utilisé pour communiquer avec un coordinateur de validation à distance :

  • Cliquez sur Ajouter pour sélectionner la séquence de protocole réseau DCOM que vous voulez ajouter.

  • Cliquez sur Supprimer pour supprimer l’entrée sélectionnée.

  • Cliquez sur Propriétés pour modifier les propriétés du point de terminaison DCOM pour le protocole spécifié.

  • Cliquez sur Effacer pour effacer la liste des protocoles et points de terminaison DCOM.


Feuille de propriétés <Application> de configuration DCOM : onglet Général

Option Détails

Nom de l’application

Le nom de l’application DCOM.

Identificateur de l’application

Cet identificateur unique est généré automatiquement à la création d’une application. Vous pouvez l’utiliser pour identifier des versions particulières de l’application sur un ordinateur.

Type d’application

Le type de l’application, notamment si l’application est sur l’ordinateur local ou un autre ordinateur du réseau.

Niveau d’authentification

Dans la zone déroulante, sélectionnez la sécurité niveau paquet utilisée par cette application pour communiquer. Les paramètres de sécurité suivants sont répertoriés du niveau de sécurité le plus bas au plus élevé :

  • Aucun : Aucune authentification.

  • Connexion : Authentification des informations d’identification uniquement lorsque la connexion est établie.

  • Appel : Authentification des informations d’identification au début de chaque appel.

  • Paquet : Authentification des informations d’identification et vérification que toutes les données sont reçues. Il s’agit du paramètre par défaut pour les applications serveur COM+.

  • Intégrité du paquet : Authentification des informations d’identification et vérification qu’aucune donnée n’a été modifiée lors du transfert.

  • Confidentialité du paquet : Authentification des informations d’identification et chiffrement des paquets, y compris les données et l’identité et la signature de l’expéditeur.

Chemin d’accès local ou Nom du service

Si l’option Type d’application est définie sur Serveur local, l’option Chemin d’accès local indique le chemin d’accès complet de l’application. Si l’option Type d’application est définie sur Service local, l’option Nom du service s’affiche.


Feuille de propriétés <Application> de configuration DCOM : onglet Identité

Option | Détails
Bouton d’option L’utilisateur interactif | Cliquez sur ce bouton pour indiquer que l’application s’exécute sous l’identité de l’utilisateur actuellement connecté à l’ordinateur. Les informations d’identification de sécurité de l’utilisateur sont utilisées lorsque l’application est authentifiées pour accéder aux ressources.
Bouton d’option L’utilisateur exécutant | Cliquez sur ce bouton pour indiquer que l’application s’exécute en utilisant le contexte de sécurité de l’utilisateur qui a démarré l’application (l’utilisateur exécutant) de sorte que l’application puisse être authentifiée dans le domaine. L’utilisateur exécutant peut être le même que l’utilisateur interactif.
Bouton d’option Cet utilisateur | Cliquez sur ce bouton pour indiquer que l’application s’exécute en utilisant le contexte de sécurité du compte d’utilisateur spécifié de sorte qu’elle puisse être authentifiée dans le domaine. Tapez le nom d’utilisateur et le mot de passe.
Bouton d’option Le compte système | Cliquez sur ce bouton pour indiquer que l’application serveur s’exécute en utilisant le contexte de sécurité du compte système intégré. Cette option n’est disponible que pour les applications installées en tant que service.


Feuille de propriétés <Application> de configuration DCOM : onglet Emplacement

Option | Détails
Case Exécuter l’application sur l’ordinateur où se trouvent les données | Cochez cette case pour indiquer que l’application s’exécute sur l’ordinateur sur lequel les données sont hébergées. Cela n’est utile que si l’application client fournit un fichier de données pour l’application serveur.
Case Exécuter l’application sur cet ordinateur | Cochez cette case pour indiquer que l’application s’exécute sur l’ordinateur local.
Case Exécuter l’application sur l’ordinateur suivant | Cochez cette case pour indiquer que l’application s’exécute sur l’ordinateur spécifié.


Feuille de propriétés <Application> de configuration DCOM : onglet Sécurité

Option Détails

Autorisations d’exécution et d’activation

Cliquez sur l’un des boutons d’option suivants :

  • Par défaut : Cliquez sur ce bouton pour indiquer que l’application utilise les autorisations par défaut définies dans l’onglet Sécurité COM de la page de propriétés de l’ordinateur.

  • Personnaliser : Cliquez sur ce bouton pour indiquer que l’application utilise les autorisations que vous avez définies. Pour modifier les autorisations, cliquez sur Modifier.

Autorisations d’accès

Cliquez sur l’un des boutons d’option suivants :

  • Par défaut : Cliquez sur ce bouton pour indiquer que l’application utilise les autorisations par défaut définies sous l’onglet Sécurité COM de la page de propriétés de l’ordinateur.

  • Personnaliser : Cliquez sur ce bouton pour indiquer que l’application utilise les autorisations que vous avez définies. Pour modifier les autorisations, cliquez sur Modifier.

Autorisations de configuration

Cliquez sur l’un des boutons d’option suivants :

  • Par défaut : Cliquez sur ce bouton pour indiquer que l’application utilise les autorisations de configuration du registre par défaut.

  • Personnaliser : Cliquez sur ce bouton pour indiquer que l’application utilise les autorisations de configuration du registre que vous avez définies. Pour modifier les autorisations, cliquez sur Modifier.


Feuille de propriétés Poste de travail : onglet Sécurité COM

Options Détails

Autorisations d’accès

Cliquez sur le bouton Modifier les limites pour définir les limites des autorisations d’accès au niveau des applications qui déterminent leurs propres autorisations.

Cliquez sur le bouton Modifier pour sélectionner des comptes d’utilisateur et des groupes auxquels les autorisations d’accès aux applications sur cet ordinateur ont été affectées ou refusées par défaut. Ce paramètre n’affecte pas les applications COM+.

Autorisations d’exécution et d’activation

Cliquez sur le bouton Modifier les limites pour définir une limite absolue au niveau des autorisations d’exécution et d’activation des composants.

Cliquez sur le bouton Modifier pour sélectionner des comptes d’utilisateur et des groupes auxquels les autorisations de démarrage des applications sur cet ordinateur ont été affectées ou refusées par défaut. Ce paramètre n’affecte pas les applications COM+.


Feuille de propriétés Poste de travail : onglet Propriétés par défaut

Option Détails

Case Activer Distributed COM (DCOM) sur cet ordinateur

Cochez cette case pour spécifier que le modèle DCOM est disponible pour toutes les applications COM (Component Object Model) installées sur cet ordinateur, permettant ainsi à ce dernier d’échanger des appels avec des applications sur d’autres ordinateurs.

Case Activer les services Internet COM sur cet ordinateur

Cochez cette case pour spécifier que les communications DCOM sont disponibles sur l’Internet pour toutes les applications COM installées sur cet ordinateur. Les serveurs DCOM sur cet ordinateur peuvent ainsi recevoir des appels entrants émanant de clients utilisant le tunneling TCP.

Propriétés par défaut de communication Distributed COM

Niveau d’authentification par défaut : Sélectionnez un niveau d’authentification à l’échelle du système que les applications client et serveur COM utilisent pour vérifier leurs identités respectives lors des appels. Les niveaux sont répertoriés par ordre de sécurité croissant.

Niveau d’emprunt d’identité par défaut : Sélectionnez le niveau d’autorité par défaut à l’échelle du système qu’un client COM sur cet ordinateur peut octroyer à une application serveur pour exécuter des tâches de traitement pour son compte. Les niveaux sont répertoriés par ordre d’autorité croissant.

Fournir une sécurité supplémentaire pour le suivi de référence : Cochez cette case pour activer l’authentification des appels de référence distribués sur cet ordinateur. Lorsque cette option est activée, le suivi de référence empêche les clients COM de débloquer des objets trop rapidement. Cependant, les performances peuvent également en souffrir.


Feuille de propriétés Poste de travail : onglet Protocoles par défaut

Option | Détails
Protocoles DCOM | Sont répertoriés sous cette option le jeu de protocoles réseau disponibles pour le modèle DCOM sur cet ordinateur. Utilisez cette boîte de dialogue pour ajouter ou supprimer des protocoles réseau, changer le niveau de priorité qui leur est appliqué et configurer les propriétés des protocoles.
Ajouter | Cliquez sur ce bouton pour ajouter un protocole réseau de sorte qu’il puisse être utilisé par le modèle DCOM sur cet ordinateur.
Supprimer | Cliquez sur ce bouton pour supprimer le protocole réseau sélectionné de la liste des protocoles disponibles pour le modèle DCOM sur cet ordinateur.
Monter, Descendre | Cliquez sur ce bouton pour déplacer le protocole sélectionné vers une position de priorité plus élevée ou plus basse dans la liste. L’ordre des protocoles reflète le niveau de priorité qui leur est appliqué, le premier protocole de la liste disposant du niveau de priorité le plus élevé.
Propriétés | Cliquez sur ce bouton pour configurer les propriétés du protocole sélectionné. Tous les protocoles ne disposent pas de cette option.


Feuille de propriétés Poste de travail : onglet Général

Option | Détails
Description | Tapez une description de 500 caractères maximum pour faciliter l’identification et la gestion de l’élément sélectionné.


Feuille de propriétés Poste de travail : onglet MSDTC

Commande Détails

Coordinateur par défaut

Utiliser un coordinateur local : Cochez cette case pour désigner le système local en tant que coordinateur par défaut.

Nom de l’hôte coordinateur à distance : Si vous désactivez la case Utiliser un coordinateur local, tapez le nom de l’ordinateur qui fera office d’hôte à distance. Pour afficher une liste des ordinateurs sur le réseau et sélectionner l’un d’entre eux, cliquez sur Sélectionner.


Feuille de propriétés Poste de travail : onglet Options

Option | Détails
Délai d’expiration de transaction | Vous pouvez entrer le délai maximal (en secondes) pendant lequel les transactions peuvent rester active avant qu’elles expirent. Les transactions qui restent actives au-delà du délai d’expiration de transaction sont automatiquement abandonnées par le système. Si le Délai d’expiration de transaction est configuré sur 0, les transactions n’expirent jamais.
Exporter | Sous Numéro RSN du proxy de l’application, tapez le nom du serveur à distance qui est utilisé pour les proxys d’applications exportés de ce serveur. Si ce champ est vide, le nom du réseau est utilisé.
Case Activer les partitions | Cochez la case Activer les partitions pour activer des partitions COM+ sur cet ordinateur. Cochez la case Vérifier le magasin local lors du choix d’une partition pour l’utilisateur pour vérifier le magasin local pour les partitions COM+ avant vérification des services de domaine Active Directory (AD DS).


Feuille de propriétés DTC local : onglet Enregistrement

Option Détails

Informations du journal

Emplacement : Pour changer l’emplacement du fichier journal, tapez le chemin d’accès complet ou cliquez sur Parcourir pour sélectionner l’emplacement. Avant de changer l’emplacement du fichier journal, arrêtez le service DTC (Distributed Transaction Coordinator) dans le composant logiciel enfichable Services puis redémarrez le service après avoir configuré la journalisation.

Capacité : Tapez la taille (en méga-octets (Mo)) du fichier journal DTC (Distributed Transaction Coordinator). Avant de changer la taille du fichier journal, arrêtez le service DTC (Distributed Transaction Coordinator) dans le composant logiciel enfichable Services puis redémarrez le service après avoir configuré la journalisation.


Feuille de propriétés DTC local : onglet Sécurité

Option Détails

Case Paramètres de sécurité – Accès DTC réseau

Cochez cette case si vous voulez autoriser tout trafic réseau au profit du DTC (Distributed Transaction Coordinator).

Si cette case n’est pas cochée, le DTC n’achemine aucune transaction vers le réseau et n’accepte aucun trafic entrant. L’administration à distance de ce DTC est également désactivée.

Case Paramètres de sécurité – Client et administration

Autoriser les clients distants : Cochez cette case si vous voulez que ce DTC coordonne les transactions pour les clients distants.

Autoriser l’administration à distance : Cochez cette case si vous voulez autoriser l’administration de ce DTC à partir d’ordinateurs distants.

Paramètres de sécurité – Communication du gestionnaire de transactions

Autoriser les transactions entrantes : Cochez cette case pour permettre à un ordinateur distant d’acheminer des transactions vers l’ordinateur local. Normalement, cette option doit être activée sur l’ordinateur hébergeant le DTC pour un gestionnaire de ressources tel que Microsoft SQL Server.

Autoriser les transactions sortantes : Cochez cette case pour permettre à l’ordinateur local d’acheminer des transactions vers un ordinateur distant. Normalement, cette option doit être activée sur l’ordinateur client où est initialisée la transaction.

Authentification mutuelle requise : Si cette option est sélectionnée, le DTC local (proxy ou service) communique avec un service DTC distant en n’utilisant que des messages chiffrés et l’authentification mutuelle (authentification de domaine Windows). Si aucune communication sécurisée ne peut être établie avec le système distant, la communication est refusée. Cette option ne peut être utilisée que dans le cadre des communications avec des ordinateurs exécutant Windows Server 2003, Windows XP SP2, Windows Vista ou Windows Server® 2008.

Autorisation de l’appelant entrant requise : Si cette option est sélectionnée et que l’authentification mutuelle ne peut être établie mais que l’appelant entrant peut être authentifié, la communication est autorisée. Cette option ne peut être utilisée que dans le cadre des communications avec des ordinateurs exécutant Windows Server 2003 ou Windows XP SP2.

Aucune authentification requise : Si cette option est sélectionnée, les communications DTC sur le réseau peuvent revenir à des communications non authentifiées et non chiffrées en cas d’échec de la mise en œuvre d’une communication sécurisée. Cette option est principalement utilisée pour permettre au DTC de communiquer avec des ordinateurs exécutant Windows 2000, Windows XP SP1 et des versions antérieures du système d’exploitation. Ce paramètre peut également être utilisé si la sécurité RPC (Remote Procedure Call) est désactivée sur l’un des systèmes.

Case Paramètres de sécurité – Activer les transactions XA

Cochez cette case pour autoriser les transactions utilisant le standard XA. Les gestionnaires de ressources qui tournent sur des systèmes d’exploitation distincts peuvent communiquer au moyen d’un gestionnaires de transactions DTC en utilisant le standard XA.

Les interfaces XA constituent un jeu standard d’interfaces de programmation qui permettent aux développeurs d’applications COM+ d’accéder aux bases de données compatibles XA et de créer des gestionnaires de ressources qui fonctionnent avec les bases de données relationnelles, la mise en file d’attente des messages, les fichiers transactionnels et les bases de données orientées objet. Bien que Microsoft ne prenne pas directement en charge le protocole XA, Microsoft prend en charge les fonctions de traduction entre les transactions OLE et XA.

Compte d’ouverture de session DTC

Spécifiez sous quel compte s’exécute le service DTC.

Par défaut, le service DTC s’exécute sous le compte Service réseau. Ce compte est spécifiquement conçu pour permettre aux services tels que le service DTC (Distributed Transaction Coordinator) de s’exécuter avec le jeu de privilèges appropriés. Pour minimiser les problèmes de sécurité potentiels, nous vous recommandons d’utiliser le compte Service réseau par défaut.

Si vous choisissez de changer le compte d’ouverture de session DTC par défaut, tapez le nom d’un autre compte dans le champ Compte ou cliquez sur Parcourir. Tapez un mot de passe et confirmez-le.


Feuille de propriétés DTC local : onglet Suivi

Option Détails

Options de sortie
  • Suivre la sortie, Suivre les transactions : Cochez ces deux cases pour activer le suivi.

  • Suivre toutes les transactions : Cochez cette case pour suivre toutes les transactions. L’activation de cette option peut affecter les performances du système. Par défaut, elle est désactivée.

  • Suivre les transactions abandonnées : Cochez cette case pour ne suivre que les transactions abandonnées. Cette option est sélectionnée par défaut.

  • Suivre les transactions à long terme : Si vous cochez cette case, les transactions maintenues au-delà d’un certain délai sont suivies, indiquant ainsi que ces transactions peuvent ne pas avoir été résolues. Le délai de dépassement défini par le système est d’une minute plus le délai d’expiration de transaction (sous réserve qu’il ait été spécifié).

Options de connexion
  • Nouvelle session : Cliquez sur ce bouton pour démarrer une nouvelle session de journalisation. Toute session de journalisation en cours d’exécution doit être arrêtée avant de pouvoir créer une nouvelle session de journalisation. Au démarrage d’une nouvelle session de journalisation, le DTC sauvegarde le journal existant, sous réserve qu’il en existe un.

  • Arrêter la session : Cliquez sur ce bouton pour arrêter la session de journalisation en cours. L’arrêt d’une session de suivi déverrouille le journal de suivi, vous permettant ainsi de le supprimer si nécessaire. Pour s’assurer que toutes les données dans la mémoire tampon sont écrites dans le journal, cliquez sur Purger les données avant d’arrêter une session de journalisation.

  • Purger les données : Cliquez sur ce bouton pour déplacer toutes les données de la mémoire tampon dans le fichier journal sur disque. Cliquez sur ce bouton avant d’afficher les données de suivi afin de vous assurer que toutes les données de suivi sont envoyées au disque. Dans le cas contraire, certaines données de suivi peuvent ne pas apparaître dans le fichier journal lorsque vous le consultez. Le fait de cliquer sur ce bouton peut affecter les performances du système. À l’arrêt de la session de suivi, ce bouton est désactivé.

  • Nombre max. de mémoires tampons : Modifiez cette valeur si vous voulez changer le nombre maximal autorisé de mémoires tampons. La valeur maximale par défaut est de 25. Si vous augmentez cette limite, le DTC écrit un message à l’observateur d’événements. Cette mémoire est prise sur la mémoire tampon non paginable. Par conséquent, si la quantité de mémoire disponible dans la mémoire tampon non paginable n’est pas suffisante, vous ne pourrez pas configurer cette valeur sur un chiffre élevé. Le cas échéant, le DTC affiche un message d’avertissement. Si cela se produit, cliquez sur OK.


Notation de la syntaxe de la ligne de commande

Le tableau suivant décrit la notation utilisée pour indiquer la syntaxe de la ligne de commande.

Notation | Description
Texte sans crochets ni accolades | Éléments à taper comme affiché
<Texte entre chevrons> | Emplacement réservé pour lequel vous devez fournir une valeur
[Texte entre crochets] | Éléments facultatifs
{Texte entre accolades} | Ensemble d’éléments requis ; choisir l’un d’entre eux
Barre verticale (|) | Séparateur pour éléments s’excluant mutuellement ; choisir l’un d’entre eux
Points de suspension (...) | Éléments pouvant être répétés