Lucene.Net.Analysis.Snowball

Snowball.Net 2.0.0 Class Library

Lucene.Net.Analysis.Snowball Namespace

Namespace hierarchy

Classes

Class | Description
SnowballAnalyzer | Filters {@link StandardTokenizer} with {@link StandardFilter}, {@link LowerCaseFilter}, {@link StopFilter} and {@link SnowballFilter}. Available stemmers are listed in {@link SF.Snowball.Ext}. The name of a stemmer is the part of the class name before "Stemmer", e.g., the stemmer in {@link EnglishStemmer} is named "English".
SnowballFilter | A filter that stems words using a Snowball-generated stemmer. Available stemmers are listed in {@link SF.Snowball.Ext}. The name of a stemmer is the part of the class name before "Stemmer", e.g., the stemmer in {@link EnglishStemmer} is named "English".


SnowballAnalyzer Class

Filters {@link StandardTokenizer} with {@link StandardFilter}, {@link LowerCaseFilter}, {@link StopFilter} and {@link SnowballFilter}. Available stemmers are listed in {@link SF.Snowball.Ext}. The name of a stemmer is the part of the class name before "Stemmer", e.g., the stemmer in {@link EnglishStemmer} is named "English".

For a list of all members of this type, see SnowballAnalyzer Members.

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.Snowball.SnowballAnalyzer

public class SnowballAnalyzer : Analyzer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Snowball

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

SnowballAnalyzer Members | Lucene.Net.Analysis.Snowball Namespace


SnowballAnalyzer Members

SnowballAnalyzer overview

Public Instance Constructors

SnowballAnalyzer Overloaded. Initializes a new instance of the SnowballAnalyzer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap (inherited from Lucene.Net.Analysis.Analyzer) |
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream | Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SnowballAnalyzer Class | Lucene.Net.Analysis.Snowball Namespace


SnowballAnalyzer Constructor

Builds the named analyzer with no stop words.

Overload List

Builds the named analyzer with no stop words.

public SnowballAnalyzer(string);

Builds the named analyzer with the given stop words.

public SnowballAnalyzer(string,string[]);

See Also

SnowballAnalyzer Class | Lucene.Net.Analysis.Snowball Namespace


SnowballAnalyzer Constructor (String)

Builds the named analyzer with no stop words.

public SnowballAnalyzer(
string name
);

See Also

SnowballAnalyzer Class | Lucene.Net.Analysis.Snowball Namespace | SnowballAnalyzer Constructor Overload List


SnowballAnalyzer Constructor (String, String[])

Builds the named analyzer with the given stop words.

public SnowballAnalyzer(
string name,
string[] stopWords
);

See Also

SnowballAnalyzer Class | Lucene.Net.Analysis.Snowball Namespace | SnowballAnalyzer Constructor Overload List


SnowballAnalyzer Methods

The methods of the SnowballAnalyzer class are listed below. For a complete list of SnowballAnalyzer class members, see the SnowballAnalyzer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPositionIncrementGap (inherited from Lucene.Net.Analysis.Analyzer) |
GetType (inherited from Object) | Gets the Type of the current instance.
TokenStream | Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SnowballAnalyzer Class | Lucene.Net.Analysis.Snowball Namespace


SnowballAnalyzer.TokenStream Method

Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.

public override TokenStream TokenStream(
string fieldName,
TextReader reader
);

See Also

SnowballAnalyzer Class | Lucene.Net.Analysis.Snowball Namespace


SnowballFilter Class

A filter that stems words using a Snowball-generated stemmer. Available stemmers are listed in {@link SF.Snowball.Ext}. The name of a stemmer is the part of the class name before "Stemmer", e.g., the stemmer in {@link EnglishStemmer} is named "English".

For a list of all members of this type, see SnowballFilter Members.

System.Object
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.Snowball.SnowballFilter

public class SnowballFilter : TokenFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Lucene.Net.Analysis.Snowball

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

SnowballFilter Members | Lucene.Net.Analysis.Snowball Namespace


SnowballFilter Members

SnowballFilter overview

Public Instance Constructors

SnowballFilter Constructor Construct the named stemming filter.

Public Instance Methods

Close (inherited from Lucene.Net.Analysis.TokenFilter) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Returns the next input Token, after being stemmed
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

input (inherited from Lucene.Net.Analysis.TokenFilter)

See Also

SnowballFilter Class | Lucene.Net.Analysis.Snowball Namespace


SnowballFilter Constructor

Construct the named stemming filter.

public SnowballFilter(
TokenStream in_Renamed,
string name
);

Parameters

in_Renamed
name
the name of a stemmer

See Also

SnowballFilter Class | Lucene.Net.Analysis.Snowball Namespace


SnowballFilter Methods

The methods of the SnowballFilter class are listed below. For a complete list of SnowballFilter class members, see the SnowballFilter Members topic.

Public Instance Methods

Close (inherited from Lucene.Net.Analysis.TokenFilter) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Next | Returns the next input Token, after being stemmed
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SnowballFilter Class | Lucene.Net.Analysis.Snowball Namespace


SnowballFilter.Next Method

Returns the next input Token, after being stemmed

public override Token Next();

See Also

SnowballFilter Class | Lucene.Net.Analysis.Snowball Namespace


SF.Snowball

Snowball.Net 2.0.0 Class Library

SF.Snowball Namespace

Namespace hierarchy

Classes

Class | Description
Among |
SnowballProgram |
TestApp |


Among Class

For a list of all members of this type, see Among Members.

System.Object
SF.Snowball.Among

public class Among

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

Among Members | SF.Snowball Namespace


Among Members

Among overview

Public Instance Constructors

Among Constructor

Public Instance Fields

method
methodobject
result
s
s_size
substring_i

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Among Class | SF.Snowball Namespace


Among Constructor

public Among(
string s,
int substring_i,
int result,
string methodname,
SnowballProgram methodobject
);

See Also

Among Class | SF.Snowball Namespace


Among Fields

The fields of the Among class are listed below. For a complete list of Among class members, see the Among Members topic.

Public Instance Fields

method
methodobject
result
s
s_size
substring_i

See Also

Among Class | SF.Snowball Namespace


Among.method Field

public MethodInfo method;

See Also

Among Class | SF.Snowball Namespace


Among.methodobject Field

public SnowballProgram methodobject;

See Also

Among Class | SF.Snowball Namespace


Among.result Field

public int result;

See Also

Among Class | SF.Snowball Namespace


Among.s Field

public string s;

See Also

Among Class | SF.Snowball Namespace


Among.s_size Field

public int s_size;

See Also

Among Class | SF.Snowball Namespace


Among.substring_i Field

public int substring_i;

See Also

Among Class | SF.Snowball Namespace


SnowballProgram Class

For a list of all members of this type, see SnowballProgram Members.

System.Object
SF.Snowball.SnowballProgram
Derived types

public class SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

SnowballProgram Members | SF.Snowball Namespace


SnowballProgram Members

SnowballProgram overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent | Set the current string.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

SnowballProgram Constructor Initializes a new instance of the SnowballProgram class.

Protected Internal Instance Fields

bra
current
cursor
ket
limit
limit_backward

Protected Internal Instance Methods

assign_to |
copy_from |
eq_s |
eq_s_b |
eq_v |
eq_v_b |
find_among |
find_among_b |
in_grouping |
in_grouping_b |
in_range |
in_range_b |
insert | Overloaded.
out_grouping |
out_grouping_b |
out_range |
out_range_b |
replace_s |
slice_check |
slice_del |
slice_from | Overloaded.
slice_to |

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram Constructor

Initializes a new instance of the SnowballProgram class.

protected internal SnowballProgram();

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram Fields

The fields of the SnowballProgram class are listed below. For a complete list of SnowballProgram class members, see the SnowballProgram Members topic.

Protected Internal Instance Fields

bra
current
cursor
ket
limit
limit_backward

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.bra Field

protected internal int bra;

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.current Field

protected internal StringBuilder current;

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.cursor Field

protected internal int cursor;

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.ket Field

protected internal int ket;

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.limit Field

protected internal int limit;

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.limit_backward Field

protected internal int limit_backward;

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram Methods

The methods of the SnowballProgram class are listed below. For a complete list of SnowballProgram class members, see the SnowballProgram Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent | Set the current string.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to |
copy_from |
eq_s |
eq_s_b |
eq_v |
eq_v_b |
find_among |
find_among_b |
in_grouping |
in_grouping_b |
in_range |
in_range_b |
insert | Overloaded.
out_grouping |
out_grouping_b |
out_range |
out_range_b |
replace_s |
slice_check |
slice_del |
slice_from | Overloaded.
slice_to |

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.assign_to Method

protected internal virtual StringBuilder assign_to(
StringBuilder s
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.copy_from Method

protected internal virtual void copy_from(
SnowballProgram other
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.eq_s Method

protected internal virtual bool eq_s(
int s_size,
string s
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.eq_s_b Method

protected internal virtual bool eq_s_b(
int s_size,
string s
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.eq_v Method

protected internal virtual bool eq_v(
StringBuilder s
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.eq_v_b Method

protected internal virtual bool eq_v_b(
StringBuilder s
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.find_among Method

protected internal virtual int find_among(
Among[] v,
int v_size
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.find_among_b Method

protected internal virtual int find_among_b(
Among[] v,
int v_size
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.GetCurrent Method

Get the current string.

public virtual string GetCurrent();

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.in_grouping Method

protected internal virtual bool in_grouping(
char[] s,
int min,
int max
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.in_grouping_b Method

protected internal virtual bool in_grouping_b(
char[] s,
int min,
int max
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.in_range Method

protected internal virtual bool in_range(
int min,
int max
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.in_range_b Method

protected internal virtual bool in_range_b(
int min,
int max
);

See Also

SnowballProgram Class | SF.Snowball Namespace


insert Method

Snowball.Net 2.0.0 Class Library

SnowballProgram.insert Method

Overload List

protected internal virtual void insert(int,int,string);

protected internal virtual void insert(int,int,StringBuilder);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.insert Method (Int32, Int32, String)

protected internal virtual void insert(
int c_bra,
int c_ket,
string s
);

See Also

SnowballProgram Class | SF.Snowball Namespace | SnowballProgram.insert Overload List


SnowballProgram.insert Method (Int32, Int32, StringBuilder)

protected internal virtual void insert(
int c_bra,
int c_ket,
StringBuilder s
);

See Also

SnowballProgram Class | SF.Snowball Namespace | SnowballProgram.insert Overload List


SnowballProgram.out_grouping Method

protected internal virtual bool out_grouping(
char[] s,
int min,
int max
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.out_grouping_b Method

protected internal virtual bool out_grouping_b(
char[] s,
int min,
int max
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.out_range Method

protected internal virtual bool out_range(
int min,
int max
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.out_range_b Method

protected internal virtual bool out_range_b(
int min,
int max
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.replace_s Method

protected internal virtual int replace_s(
int c_bra,
int c_ket,
string s
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.SetCurrent Method

Set the current string.

public virtual void SetCurrent(
string value_Renamed
);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.slice_check Method

protected internal virtual void slice_check();

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.slice_del Method

protected internal virtual void slice_del();

See Also

SnowballProgram Class | SF.Snowball Namespace


slice_from Method

Snowball.Net 2.0.0 Class Library

SnowballProgram.slice_from Method

Overload List

protected internal virtual void slice_from(string);

protected internal virtual void slice_from(StringBuilder);

See Also

SnowballProgram Class | SF.Snowball Namespace


SnowballProgram.slice_from Method (String)

protected internal virtual void slice_from(
string s
);

See Also

SnowballProgram Class | SF.Snowball Namespace | SnowballProgram.slice_from Overload List


SnowballProgram.slice_from Method (StringBuilder)

protected internal virtual void slice_from(
StringBuilder s
);

See Also

SnowballProgram Class | SF.Snowball Namespace | SnowballProgram.slice_from Overload List


SnowballProgram.slice_to Method

protected internal virtual StringBuilder slice_to(
StringBuilder s
);

See Also

SnowballProgram Class | SF.Snowball Namespace


TestApp Class

For a list of all members of this type, see TestApp Members.

System.Object
SF.Snowball.TestApp

public class TestApp

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

TestApp Members | SF.Snowball Namespace


TestApp Members

TestApp overview

Public Static Methods

Main

Public Instance Constructors

TestApp Constructor Initializes a new instance of the TestApp class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TestApp Class | SF.Snowball Namespace


TestApp Constructor

Initializes a new instance of the TestApp class.

public TestApp();

See Also

TestApp Class | SF.Snowball Namespace


TestApp Methods

The methods of the TestApp class are listed below. For a complete list of TestApp class members, see the TestApp Members topic.

Public Static Methods

Main

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TestApp Class | SF.Snowball Namespace


TestApp.Main Method

public static void Main(
string[] args
);

See Also

TestApp Class | SF.Snowball Namespace


SF.Snowball.Ext

Snowball.Net 2.0.0 Class Library

SF.Snowball.Ext Namespace

Namespace hierarchy

Classes

Class | Description
DanishStemmer | Generated class implementing code defined by a snowball script.
DutchStemmer | Generated class implementing code defined by a snowball script.
EnglishStemmer | Generated class implementing code defined by a snowball script.
FinnishStemmer | Generated class implementing code defined by a snowball script.
FrenchStemmer | Generated class implementing code defined by a snowball script.
German2Stemmer | Generated class implementing code defined by a snowball script.
GermanStemmer | Generated class implementing code defined by a snowball script.
ItalianStemmer | Generated class implementing code defined by a snowball script.
KpStemmer | Generated class implementing code defined by a snowball script.
LovinsStemmer | Generated class implementing code defined by a snowball script.
NorwegianStemmer | Generated class implementing code defined by a snowball script.
PorterStemmer | Generated class implementing code defined by a snowball script.
PortugueseStemmer | Generated class implementing code defined by a snowball script.
RussianStemmer | Generated class implementing code defined by a snowball script.
SpanishStemmer | Generated class implementing code defined by a snowball script.
SwedishStemmer | Generated class implementing code defined by a snowball script.


DanishStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see DanishStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.DanishStemmer

public class DanishStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

DanishStemmer Members | SF.Snowball.Ext Namespace


DanishStemmer Members

DanishStemmer overview

Public Instance Constructors

DanishStemmer Constructor Initializes a new instance of the DanishStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

DanishStemmer Class | SF.Snowball.Ext Namespace


DanishStemmer Constructor

Initializes a new instance of the DanishStemmer class.

public DanishStemmer();

See Also

DanishStemmer Class | SF.Snowball.Ext Namespace


DanishStemmer Methods

The methods of the DanishStemmer class are listed below. For a complete list of DanishStemmer class members, see the DanishStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

DanishStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

DanishStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(DanishStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

DanishStemmer Class | SF.Snowball.Ext Namespace


DanishStemmer.copy_from Method (DanishStemmer)

protected internal virtual void copy_from(
DanishStemmer other
);

See Also

DanishStemmer Class | SF.Snowball.Ext Namespace | DanishStemmer.copy_from Overload List


DanishStemmer.Stem Method

public virtual bool Stem();

See Also

DanishStemmer Class | SF.Snowball.Ext Namespace


DutchStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see DutchStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.DutchStemmer

public class DutchStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

DutchStemmer Members | SF.Snowball.Ext Namespace


DutchStemmer Members

DutchStemmer overview

Public Instance Constructors

DutchStemmer Constructor Initializes a new instance of the DutchStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

DutchStemmer Class | SF.Snowball.Ext Namespace


DutchStemmer Constructor

Initializes a new instance of the DutchStemmer class.

public DutchStemmer();

See Also

DutchStemmer Class | SF.Snowball.Ext Namespace


DutchStemmer Methods

The methods of the DutchStemmer class are listed below. For a complete list of DutchStemmer class members, see the DutchStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

DutchStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

DutchStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(DutchStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

DutchStemmer Class | SF.Snowball.Ext Namespace


DutchStemmer.copy_from Method (DutchStemmer)

protected internal virtual void copy_from(
DutchStemmer other
);

See Also

DutchStemmer Class | SF.Snowball.Ext Namespace | DutchStemmer.copy_from Overload List


DutchStemmer.Stem Method

public virtual bool Stem();

See Also

DutchStemmer Class | SF.Snowball.Ext Namespace


EnglishStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see EnglishStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.EnglishStemmer

public class EnglishStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

EnglishStemmer Members | SF.Snowball.Ext Namespace


EnglishStemmer Members

EnglishStemmer overview

Public Instance Constructors

EnglishStemmer Constructor Initializes a new instance of the EnglishStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

EnglishStemmer Class | SF.Snowball.Ext Namespace


EnglishStemmer Constructor

Initializes a new instance of the EnglishStemmer class.

public EnglishStemmer();

See Also

EnglishStemmer Class | SF.Snowball.Ext Namespace


EnglishStemmer Methods

The methods of the EnglishStemmer class are listed below. For a complete list of EnglishStemmer class members, see the EnglishStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

EnglishStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

EnglishStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(EnglishStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

EnglishStemmer Class | SF.Snowball.Ext Namespace


EnglishStemmer.copy_from Method (EnglishStemmer)

protected internal virtual void copy_from(
EnglishStemmer other
);

See Also

EnglishStemmer Class | SF.Snowball.Ext Namespace | EnglishStemmer.copy_from Overload List


EnglishStemmer.Stem Method

public virtual bool Stem();

See Also

EnglishStemmer Class | SF.Snowball.Ext Namespace


FinnishStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see FinnishStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.FinnishStemmer

public class FinnishStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

FinnishStemmer Members | SF.Snowball.Ext Namespace


FinnishStemmer Members

FinnishStemmer overview

Public Instance Constructors

FinnishStemmer Constructor Initializes a new instance of the FinnishStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

FinnishStemmer Class | SF.Snowball.Ext Namespace


FinnishStemmer Constructor

Initializes a new instance of the FinnishStemmer class.

public FinnishStemmer();

See Also

FinnishStemmer Class | SF.Snowball.Ext Namespace


FinnishStemmer Methods

The methods of the FinnishStemmer class are listed below. For a complete list of FinnishStemmer class members, see the FinnishStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

FinnishStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

FinnishStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(FinnishStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

FinnishStemmer Class | SF.Snowball.Ext Namespace


FinnishStemmer.copy_from Method (FinnishStemmer)

protected internal virtual void copy_from(
FinnishStemmer other
);

See Also

FinnishStemmer Class | SF.Snowball.Ext Namespace | FinnishStemmer.copy_from Overload List


FinnishStemmer.Stem Method

public virtual bool Stem();

See Also

FinnishStemmer Class | SF.Snowball.Ext Namespace


FrenchStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see FrenchStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.FrenchStemmer

public class FrenchStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

FrenchStemmer Members | SF.Snowball.Ext Namespace


FrenchStemmer Members

FrenchStemmer overview

Public Instance Constructors

FrenchStemmer Constructor Initializes a new instance of the FrenchStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

FrenchStemmer Class | SF.Snowball.Ext Namespace


FrenchStemmer Constructor

Initializes a new instance of the FrenchStemmer class.

public FrenchStemmer();

See Also

FrenchStemmer Class | SF.Snowball.Ext Namespace


FrenchStemmer Methods

The methods of the FrenchStemmer class are listed below. For a complete list of FrenchStemmer class members, see the FrenchStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

FrenchStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

FrenchStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(FrenchStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

FrenchStemmer Class | SF.Snowball.Ext Namespace


FrenchStemmer.copy_from Method (FrenchStemmer)

protected internal virtual void copy_from(
FrenchStemmer other
);

See Also

FrenchStemmer Class | SF.Snowball.Ext Namespace | FrenchStemmer.copy_from Overload List


FrenchStemmer.Stem Method

public virtual bool Stem();

See Also

FrenchStemmer Class | SF.Snowball.Ext Namespace


German2Stemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see German2Stemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.German2Stemmer

public class German2Stemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

German2Stemmer Members | SF.Snowball.Ext Namespace


German2Stemmer Members

German2Stemmer overview

Public Instance Constructors

German2Stemmer Constructor Initializes a new instance of the German2Stemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

German2Stemmer Class | SF.Snowball.Ext Namespace


German2Stemmer Constructor

Initializes a new instance of the German2Stemmer class.

public German2Stemmer();

See Also

German2Stemmer Class | SF.Snowball.Ext Namespace


German2Stemmer Methods

The methods of the German2Stemmer class are listed below. For a complete list of German2Stemmer class members, see the German2Stemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

German2Stemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

German2Stemmer.copy_from Method

Overload List

protected internal virtual void copy_from(German2Stemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

German2Stemmer Class | SF.Snowball.Ext Namespace


German2Stemmer.copy_from Method (German2Stemmer)

protected internal virtual void copy_from(
German2Stemmer other
);

See Also

German2Stemmer Class | SF.Snowball.Ext Namespace | German2Stemmer.copy_from Overload List


German2Stemmer.Stem Method

public virtual bool Stem();

See Also

German2Stemmer Class | SF.Snowball.Ext Namespace


GermanStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see GermanStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.GermanStemmer

public class GermanStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

GermanStemmer Members | SF.Snowball.Ext Namespace


GermanStemmer Members

GermanStemmer overview

Public Instance Constructors

GermanStemmer Constructor Initializes a new instance of the GermanStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

GermanStemmer Class | SF.Snowball.Ext Namespace


GermanStemmer Constructor

Initializes a new instance of the GermanStemmer class.

public GermanStemmer();

See Also

GermanStemmer Class | SF.Snowball.Ext Namespace


GermanStemmer Methods

The methods of the GermanStemmer class are listed below. For a complete list of GermanStemmer class members, see the GermanStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

GermanStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

GermanStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(GermanStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

GermanStemmer Class | SF.Snowball.Ext Namespace


GermanStemmer.copy_from Method (GermanStemmer)

protected internal virtual void copy_from(
GermanStemmer other
);

See Also

GermanStemmer Class | SF.Snowball.Ext Namespace | GermanStemmer.copy_from Overload List


GermanStemmer.Stem Method

public virtual bool Stem();

See Also

GermanStemmer Class | SF.Snowball.Ext Namespace


ItalianStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see ItalianStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.ItalianStemmer

public class ItalianStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

ItalianStemmer Members | SF.Snowball.Ext Namespace


ItalianStemmer Members

ItalianStemmer overview

Public Instance Constructors

ItalianStemmer Constructor Initializes a new instance of the ItalianStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

ItalianStemmer Class | SF.Snowball.Ext Namespace


ItalianStemmer Constructor

Initializes a new instance of the ItalianStemmer class.

public ItalianStemmer();

See Also

ItalianStemmer Class | SF.Snowball.Ext Namespace


ItalianStemmer Methods

The methods of the ItalianStemmer class are listed below. For a complete list of ItalianStemmer class members, see the ItalianStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

ItalianStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

ItalianStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(ItalianStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

ItalianStemmer Class | SF.Snowball.Ext Namespace


ItalianStemmer.copy_from Method (ItalianStemmer)

protected internal virtual void copy_from(
ItalianStemmer other
);

See Also

ItalianStemmer Class | SF.Snowball.Ext Namespace | ItalianStemmer.copy_from Overload List


ItalianStemmer.Stem Method

public virtual bool Stem();

See Also

ItalianStemmer Class | SF.Snowball.Ext Namespace


KpStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see KpStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.KpStemmer

public class KpStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

KpStemmer Members | SF.Snowball.Ext Namespace


KpStemmer Members

KpStemmer overview

Public Instance Constructors

KpStemmer Constructor Initializes a new instance of the KpStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

KpStemmer Class | SF.Snowball.Ext Namespace


KpStemmer Constructor

Initializes a new instance of the KpStemmer class.

public KpStemmer();

See Also

KpStemmer Class | SF.Snowball.Ext Namespace


KpStemmer Methods

The methods of the KpStemmer class are listed below. For a complete list of KpStemmer class members, see the KpStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

KpStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

KpStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(KpStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

KpStemmer Class | SF.Snowball.Ext Namespace


KpStemmer.copy_from Method (KpStemmer)

protected internal virtual void copy_from(
KpStemmer other
);

See Also

KpStemmer Class | SF.Snowball.Ext Namespace | KpStemmer.copy_from Overload List


KpStemmer.Stem Method

public virtual bool Stem();

See Also

KpStemmer Class | SF.Snowball.Ext Namespace


LovinsStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see LovinsStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.LovinsStemmer

public class LovinsStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

LovinsStemmer Members | SF.Snowball.Ext Namespace


LovinsStemmer Members

LovinsStemmer overview

Public Instance Constructors

LovinsStemmer Constructor Initializes a new instance of the LovinsStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

LovinsStemmer Class | SF.Snowball.Ext Namespace


LovinsStemmer Constructor

Initializes a new instance of the LovinsStemmer class.

public LovinsStemmer();

See Also

LovinsStemmer Class | SF.Snowball.Ext Namespace


LovinsStemmer Methods

The methods of the LovinsStemmer class are listed below. For a complete list of LovinsStemmer class members, see the LovinsStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

LovinsStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

LovinsStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(LovinsStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

LovinsStemmer Class | SF.Snowball.Ext Namespace


LovinsStemmer.copy_from Method (LovinsStemmer)

protected internal virtual void copy_from(
LovinsStemmer other
);

See Also

LovinsStemmer Class | SF.Snowball.Ext Namespace | LovinsStemmer.copy_from Overload List


LovinsStemmer.Stem Method

public virtual bool Stem();

See Also

LovinsStemmer Class | SF.Snowball.Ext Namespace


NorwegianStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see NorwegianStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.NorwegianStemmer

public class NorwegianStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

NorwegianStemmer Members | SF.Snowball.Ext Namespace


NorwegianStemmer Members

NorwegianStemmer overview

Public Instance Constructors

NorwegianStemmer Constructor Initializes a new instance of the NorwegianStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

NorwegianStemmer Class | SF.Snowball.Ext Namespace


NorwegianStemmer Constructor

Initializes a new instance of the NorwegianStemmer class.

public NorwegianStemmer();

See Also

NorwegianStemmer Class | SF.Snowball.Ext Namespace


NorwegianStemmer Methods

The methods of the NorwegianStemmer class are listed below. For a complete list of NorwegianStemmer class members, see the NorwegianStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

NorwegianStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

NorwegianStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(NorwegianStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

NorwegianStemmer Class | SF.Snowball.Ext Namespace


NorwegianStemmer.copy_from Method (NorwegianStemmer)

protected internal virtual void copy_from(
NorwegianStemmer other
);

See Also

NorwegianStemmer Class | SF.Snowball.Ext Namespace | NorwegianStemmer.copy_from Overload List


NorwegianStemmer.Stem Method

public virtual bool Stem();

See Also

NorwegianStemmer Class | SF.Snowball.Ext Namespace


PorterStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see PorterStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.PorterStemmer

public class PorterStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

PorterStemmer Members | SF.Snowball.Ext Namespace


PorterStemmer Members

PorterStemmer overview

Public Instance Constructors

PorterStemmer Constructor Initializes a new instance of the PorterStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

PorterStemmer Class | SF.Snowball.Ext Namespace


PorterStemmer Constructor

Initializes a new instance of the PorterStemmer class.

public PorterStemmer();

See Also

PorterStemmer Class | SF.Snowball.Ext Namespace


PorterStemmer Methods

The methods of the PorterStemmer class are listed below. For a complete list of PorterStemmer class members, see the PorterStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

PorterStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

PorterStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(PorterStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

PorterStemmer Class | SF.Snowball.Ext Namespace


PorterStemmer.copy_from Method (PorterStemmer)

protected internal virtual void copy_from(
PorterStemmer other
);

See Also

PorterStemmer Class | SF.Snowball.Ext Namespace | PorterStemmer.copy_from Overload List


PorterStemmer.Stem Method

public virtual bool Stem();

See Also

PorterStemmer Class | SF.Snowball.Ext Namespace


PortugueseStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see PortugueseStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.PortugueseStemmer

public class PortugueseStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

PortugueseStemmer Members | SF.Snowball.Ext Namespace


PortugueseStemmer Members

PortugueseStemmer overview

Public Instance Constructors

PortugueseStemmer Constructor Initializes a new instance of the PortugueseStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

PortugueseStemmer Class | SF.Snowball.Ext Namespace


PortugueseStemmer Constructor

Initializes a new instance of the PortugueseStemmer class.

public PortugueseStemmer();

See Also

PortugueseStemmer Class | SF.Snowball.Ext Namespace


PortugueseStemmer Methods

The methods of the PortugueseStemmer class are listed below. For a complete list of PortugueseStemmer class members, see the PortugueseStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

PortugueseStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

PortugueseStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(PortugueseStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

PortugueseStemmer Class | SF.Snowball.Ext Namespace


PortugueseStemmer.copy_from Method (PortugueseStemmer)

protected internal virtual void copy_from(
PortugueseStemmer other
);

See Also

PortugueseStemmer Class | SF.Snowball.Ext Namespace | PortugueseStemmer.copy_from Overload List


PortugueseStemmer.Stem Method

public virtual bool Stem();

See Also

PortugueseStemmer Class | SF.Snowball.Ext Namespace


RussianStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see RussianStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.RussianStemmer

public class RussianStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

RussianStemmer Members | SF.Snowball.Ext Namespace


RussianStemmer Members

RussianStemmer overview

Public Instance Constructors

RussianStemmer Constructor Initializes a new instance of the RussianStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

RussianStemmer Class | SF.Snowball.Ext Namespace


RussianStemmer Constructor

Initializes a new instance of the RussianStemmer class.

public RussianStemmer();

See Also

RussianStemmer Class | SF.Snowball.Ext Namespace


RussianStemmer Methods

The methods of the RussianStemmer class are listed below. For a complete list of RussianStemmer class members, see the RussianStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

RussianStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

RussianStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(RussianStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

RussianStemmer Class | SF.Snowball.Ext Namespace


RussianStemmer.copy_from Method (RussianStemmer)

protected internal virtual void copy_from(
RussianStemmer other
);

See Also

RussianStemmer Class | SF.Snowball.Ext Namespace | RussianStemmer.copy_from Overload List


RussianStemmer.Stem Method

public virtual bool Stem();

See Also

RussianStemmer Class | SF.Snowball.Ext Namespace


SpanishStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see SpanishStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.SpanishStemmer

public class SpanishStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

SpanishStemmer Members | SF.Snowball.Ext Namespace


SpanishStemmer Members

SpanishStemmer overview

Public Instance Constructors

SpanishStemmer Constructor Initializes a new instance of the SpanishStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

SpanishStemmer Class | SF.Snowball.Ext Namespace


SpanishStemmer Constructor

Initializes a new instance of the SpanishStemmer class.

public SpanishStemmer();

See Also

SpanishStemmer Class | SF.Snowball.Ext Namespace


SpanishStemmer Methods

The methods of the SpanishStemmer class are listed below. For a complete list of SpanishStemmer class members, see the SpanishStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

SpanishStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

SpanishStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(SpanishStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

SpanishStemmer Class | SF.Snowball.Ext Namespace


SpanishStemmer.copy_from Method (SpanishStemmer)

protected internal virtual void copy_from(
SpanishStemmer other
);

See Also

SpanishStemmer Class | SF.Snowball.Ext Namespace | SpanishStemmer.copy_from Overload List


SpanishStemmer.Stem Method

public virtual bool Stem();

See Also

SpanishStemmer Class | SF.Snowball.Ext Namespace


SwedishStemmer Class

Generated class implementing code defined by a snowball script.

For a list of all members of this type, see SwedishStemmer Members.

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.SwedishStemmer

public class SwedishStemmer : SnowballProgram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SF.Snowball.Ext

Assembly: Snowball.Net (in Snowball.Net.dll)

See Also

SwedishStemmer Members | SF.Snowball.Ext Namespace


SwedishStemmer Members

SwedishStemmer overview

Public Instance Constructors

SwedishStemmer Constructor Initializes a new instance of the SwedishStemmer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

bra (inherited from SnowballProgram)
current (inherited from SnowballProgram)
cursor (inherited from SnowballProgram)
ket (inherited from SnowballProgram)
limit (inherited from SnowballProgram)
limit_backward (inherited from SnowballProgram)

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

SwedishStemmer Class | SF.Snowball.Ext Namespace


SwedishStemmer Constructor

Initializes a new instance of the SwedishStemmer class.

public SwedishStemmer();

See Also

SwedishStemmer Class | SF.Snowball.Ext Namespace


SwedishStemmer Methods

The methods of the SwedishStemmer class are listed below. For a complete list of SwedishStemmer class members, see the SwedishStemmer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrent (inherited from SnowballProgram) | Get the current string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCurrent (inherited from SnowballProgram) | Set the current string.
Stem |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

assign_to (inherited from SnowballProgram) |
copy_from | Overloaded.
copy_from (inherited from SnowballProgram) | Overloaded.
eq_s (inherited from SnowballProgram) |
eq_s_b (inherited from SnowballProgram) |
eq_v (inherited from SnowballProgram) |
eq_v_b (inherited from SnowballProgram) |
find_among (inherited from SnowballProgram) |
find_among_b (inherited from SnowballProgram) |
in_grouping (inherited from SnowballProgram) |
in_grouping_b (inherited from SnowballProgram) |
in_range (inherited from SnowballProgram) |
in_range_b (inherited from SnowballProgram) |
insert (inherited from SnowballProgram) | Overloaded.
out_grouping (inherited from SnowballProgram) |
out_grouping_b (inherited from SnowballProgram) |
out_range (inherited from SnowballProgram) |
out_range_b (inherited from SnowballProgram) |
replace_s (inherited from SnowballProgram) |
slice_check (inherited from SnowballProgram) |
slice_del (inherited from SnowballProgram) |
slice_from (inherited from SnowballProgram) | Overloaded.
slice_to (inherited from SnowballProgram) |

See Also

SwedishStemmer Class | SF.Snowball.Ext Namespace


copy_from Method

Snowball.Net 2.0.0 Class Library

SwedishStemmer.copy_from Method

Overload List

protected internal virtual void copy_from(SwedishStemmer);

Inherited from SnowballProgram.

protected internal virtual void copy_from(SnowballProgram);

See Also

SwedishStemmer Class | SF.Snowball.Ext Namespace


SwedishStemmer.copy_from Method (SwedishStemmer)

protected internal virtual void copy_from(
SwedishStemmer other
);

See Also

SwedishStemmer Class | SF.Snowball.Ext Namespace | SwedishStemmer.copy_from Overload List


SwedishStemmer.Stem Method

public virtual bool Stem();

See Also

SwedishStemmer Class | SF.Snowball.Ext Namespace


Lucene.Net.Analysis.SnowballHierarchy

Snowball.Net 2.0.0 Class Library

Lucene.Net.Analysis.Snowball Hierarchy

System.Object
Lucene.Net.Analysis.Analyzer
Lucene.Net.Analysis.Snowball.SnowballAnalyzer
Lucene.Net.Analysis.TokenStream
Lucene.Net.Analysis.TokenFilter
Lucene.Net.Analysis.Snowball.SnowballFilter

See Also

Lucene.Net.Analysis.Snowball Namespace


SF.Snowball.ExtHierarchy

Snowball.Net 2.0.0 Class Library

SF.Snowball.Ext Hierarchy

System.Object
SF.Snowball.SnowballProgram
SF.Snowball.Ext.DanishStemmer
SF.Snowball.Ext.DutchStemmer
SF.Snowball.Ext.EnglishStemmer
SF.Snowball.Ext.FinnishStemmer
SF.Snowball.Ext.FrenchStemmer
SF.Snowball.Ext.German2Stemmer
SF.Snowball.Ext.GermanStemmer
SF.Snowball.Ext.ItalianStemmer
SF.Snowball.Ext.KpStemmer
SF.Snowball.Ext.LovinsStemmer
SF.Snowball.Ext.NorwegianStemmer
SF.Snowball.Ext.PorterStemmer
SF.Snowball.Ext.PortugueseStemmer
SF.Snowball.Ext.RussianStemmer
SF.Snowball.Ext.SpanishStemmer
SF.Snowball.Ext.SwedishStemmer

See Also

SF.Snowball.Ext Namespace


SnowballProgram Hierarchy

System.Object
SnowballProgram
DanishStemmer
DutchStemmer
EnglishStemmer
FinnishStemmer
FrenchStemmer
German2Stemmer
GermanStemmer
ItalianStemmer
KpStemmer
LovinsStemmer
NorwegianStemmer
PorterStemmer
PortugueseStemmer
RussianStemmer
SpanishStemmer
SwedishStemmer

See Also

SnowballProgram Class | SnowballProgram Members | SF.Snowball Namespace


SF.SnowballHierarchy

Snowball.Net 2.0.0 Class Library

SF.Snowball Hierarchy

System.Object
SF.Snowball.Among
SF.Snowball.SnowballProgram
SF.Snowball.TestApp

See Also

SF.Snowball Namespace